Novell Home

Workaround for Problem when Adding Another iSCSI Server for Cluster Backup

Novell Cool Solutions: Tip
By Deepak Sharma

Digg This - Slashdot This

Posted: 21 Jul 2005
 

"This is a good look at verifying if the cluster nodes installed correctly. This could help someone who ends up with a similarly botched system."
--Aaron Gresko, Product Specialist

I have a NetWare 6.5 SP2 two-node cluster with one iSCSI server. I wanted to add another iSCSI server in the network in which to have a backup of my iSCSI partition. (Like a cluster backup thing, you know.)

While installing it everything went fine - I could see both my devices from both nodes. Node 2 successfully got up with no errors and joined the cluster. But Node 1 came up with an error and did not join the cluster.

In the logger screen I found the following message:

Module XINIT.NLM load status OK                                                 
Loading module SBDLIB.NLM                                                       
  Cluster Split Brain Detector Library Build Number = 528                       
  Version 1.70.02   May 28, 2004                                                
  Copyright (C) 1999-2004  Novell, Inc.  All Rights Reserved.                   
Module SBDLIB.NLM load status OK                                                
Loading module PS2.NLM                                                          
  Java - PS/2 Mouse Port Driver  Build 040615                                   
  Version 1.00   June 15, 2004                                                  
  Copyright (c) 2002-2003 Novell, Inc. All rights reserved.                     
Interrupt assignment: 12                                                        
Module PS2.NLM load status OK                                                   
Loading module NCSSDK.NLM                                                       
  Cluster API Build Number = 528                                                
  Version 1.70.02   May 28, 2004                                                
  Copyright (C) 1999-2004  Novell, Inc.  All Rights Reserved.                   
SERVER-5.70-918: Loader cannot find public symbol: VipNSAddrToNodeNum for module
 NCSSDK.NLM                                                                     
SERVER-5.70-918: Loader cannot find public symbol: VipOpenNic for module NCSSDK.
NLM                                                                             
SERVER-5.70-918: Loader cannot find public symbol: VipCreateVi for module NCSSDK
.NLM                                                                            
SERVER-5.70-918: Loader cannot find public symbol: VipCloseNic for module NCSSDK
.NLM                                                                            
SERVER-5.70-918: Loader cannot find public symbol: VipNodeGroupInfo for module N
CSSDK.NLM 

Then I looked into LDNCS.NCF file and tried to load each NLM one by one and I found that a few of them were missing. I copy the NLMs from Node 2 and loaded the cluster again.......... Yahoo........ It worked fine!

PROBLEM: SERVER-5.70-918: Loader cannot find public symbol: VipNSAddrToNodeNum for module NCSSDK.NLM

SOLUTION: Copy the following files in SYS:\SYSTEM

  • clstrlib.nlm
  • sbdlib.nlm (Check if it is there. If so, it's ok, otherwise copy this also.)
  • vll.nlm
  • gipc.nlm
  • sbd.nlm
  • vipx.nlm
  • css.nlm
  • cvb.nlm
  • crm.nlm
  • pcluster.nlm
  • cma.nlm
  • cmon.nlm

If you have any questions you may contact Deepak at sharmade230177@yahoo.com


Novell Cool Solutions (corporate web communities) are produced by WebWise Solutions. www.webwiseone.com

© 2014 Novell