Novell Home

Improving WebAccess Performance over SSL

Novell Cool Solutions: Tip
By Teppo Fahlstedt

Digg This - Slashdot This

Posted: 7 Mar 2006
 

Problem

You may experience poor performance with Internet Explorer and Apache webserver on NetWare when using SSL (iManager, GroupWise WebAccess).

Solution

1. Edit the apache config file (adminserv.conf) on the NetWare Server, in SYS:APACHE\CONF.

2. Find the section that looks like this:

---------------------------------------------
<VirtualHost _default_:443<
  BrowserMatch "MSIE" nokeepalive downgrade-1.0 force-response-1.0
</VirtualHost<
---------------------------------------------
The SSL port may differ on your server.
Change "MSIE" to "MSIE 4\.0b2;".
The section should now look like this:
---------------------------------------------
<VirtualHost _default_:443<
  BrowserMatch "MSIE 4\.0b2;" nokeepalive downgrade-1.0 force-response-1.0
</VirtualHost>
---------------------------------------------

3. Restart your Apache server and feel the performance difference.

Now it only downgrades http responses with MSIE 4.0b2, which had a problem with http/1.1.

Notes about the Variables

  • nokeepalive = disables KeepAlive when set.
  • downgrade-1.0 = forces the request to be treated as a HTTP/1.0 request even if it was in a later dialect.
  • force-response-1.0 = forces an HTTP/1.0 response when set. It was originally implemented as a result of a problem with AOL's proxies. Some clients may not behave correctly when given an HTTP/1.1 response, and this can be used to interoperate with them.

Note: This solution was tested in an environment with Internet Explorer 6, NetWare Apache Server, and SSL communication (GroupWise WebAccess, iManager).


Novell Cool Solutions (corporate web communities) are produced by WebWise Solutions. www.webwiseone.com

© 2014 Novell