Novell Home

Firefox 2 Support for SecureLogin

Novell Cool Solutions: Tip
By Nicholas Lemberger

Digg This - Slashdot This

Posted: 31 Jan 2007
 

Problem

Firefox 2 doesn't support Novell SecureLogin.

Solution

This isn't exactly a 1-2-3 process, but here's how you can get the Firefox 1.5 extension working with SecureLogin:

1. Uncompress the .xpi like a 'zip' file.

2. Edit the 'install.rdf' file as follows:

Change:
<em:maxVersion>1.5+</em:maxVersion>
to:
<em:maxVersion>2.0+</em:maxVersion>

3. Re-zip that file with a .xpi extension and modify the file name to suit the new Firefox version supported.

This has been working fine for me since FireFox 2 was officially released.

Note: I first tried it by just clicking on the .xpi file to install, but this was not working. However, after adding it via:

firefox.exe -install-global-extension slomoz-2.0_v6.xpi 

... it's working fine!


Novell Cool Solutions (corporate web communities) are produced by WebWise Solutions. www.webwiseone.com

© 2014 Novell