Novell Home

Upgrading from BorderManager 3.6

Novell Cool Solutions: Tip
By Craig Johnson

Digg This - Slashdot This

Posted: 19 Sep 2007
 

Problem

A Forum reader recently asked:

"I have an existing bordermanager install of 3.60.04 9/19/03 and would like to patch it. Are 3.7+ new products upgrades or patches? Also, can I upgrade/patch to 3.7+ without having to purchase? How hard is it to from 3.60.04 to 3.9?"

And here's the response from Craig Johnson ...

Solution

Your upgrade is not going to be all that easy. You are basically looking at installing a new version over the top of the old one (though that should not be much of an issue, as long as you make sure to back up your ETC directory first, and your access rules).

VPN would be a concern in an upgrade scenario.

BorderManager 3.6 would run on NetWare 5.0, 5.1 or 6.0, but not 6.5. NBM 3.7 would run on 5.1 or 6.0, but not 6.5. NBM 3.8 would run on NW 5.1, 6.0 or 6.5. NBM 3.9 only runs on 6.5 SP6 or later.

NBM 3.9 is, as far as I know, the only version sold now. Unfortunately, you can't even get an eval copy of 3.8 now, which is too bad because it is such a useful stepping stone for upgrades since it ran on 5.1 through 6.5. Version 3.9 upgrades are only supported from NetWare 6.5 SP6 / NBM 3.8 SP5.

The usual upgrade would be to get to 3.8sp5 on NW 5.1 or 6.0, then upgrade the OS to NW 6.5sp6, and then upgrade in place to 3.9.

As an alternative, you could set up a second server in parallel to the first one, get it set up, and move the old address over to it as a secondary. (The is the best option, in my opinion.)

You could also just reinstall everything. If you have a backup of the ETC directory and access rules, it's not hard to redo the BorderManager server from scratch, as long as you know what you are doing. The real issue is if the BMgr server is a S2S VPN master - then you would need to redo the VPN from scratch.


Novell Cool Solutions (corporate web communities) are produced by WebWise Solutions. www.webwiseone.com

© 2014 Novell