Novell Home

BTRIEVE and NetWare 5.1

Novell Cool Solutions: Tip

Digg This - Slashdot This

Posted: 3 Aug 2000
 

What ever happened to BTRIEVE?

There is a "BTRIEVE" included with NetWare 5.1, and it installs during the normal server install. The official "BTRIEVE" version is 7.5.1. I put it in quotes because it is not the BTRIEVE as we all knew it before NetWare 5. This is a shim that responds to BTREIVE API's but uses the Pervasive.SQL 2000 database. This version has native TCP/IP support. Pervasive.SQL 2000 is a time-bombed (90 days) version. After 90 days, it will revert to a 2 user license version (needed by NetWare 5.1), and you will have to purchase additional licenses from Pervasive.

You may or may not be able to run BTRIEVE 6 on NetWare 5 (I never tried to), but you really don't want to (and it is no longer supported by Novell or Pervasive). It is an IPX dependent application and requires the IPX stack be loaded on the server to function. You cannot run this in a pure IP environment.

Pervasive.SQL 2000 is completely backwards compatible. Existing applications written to use Btrieve v6.10 and 6.15 will run with Pervasive.SQL 2000 without changes.

More information is on the Pervasive Web site :
http://www.pervasive.com/


Novell Cool Solutions (corporate web communities) are produced by WebWise Solutions. www.webwiseone.com

© 2014 Novell