Novell Home

Using ZENworks for Desktops 6.5 Imaging in a Cluster

Novell Cool Solutions: Tip
By Maurice Bosman

Digg This - Slashdot This

Posted: 21 Oct 2004
 

According to Novell's readme.txt for ZENworks for Desktops 6.5, Imaging doesn't work correctly in a NetWare 6.5 clustered environment. Supposedly it doesn't read the imaging policies so that automatic imaging isn't working. The transaction server is reporting: no work to do! Well, duuh!

I had opened an incident to solve this issue, and the Novell Support Engineer told me that this wasn't possible, and directed me to the readme.txt of ZENworks 6.5. I couldn't live with that answer and start thinking and testing. The cluster-enabled install of ZfD is via the Virtual Server object (target server in the installation process.) After a while I found out that the ZIS object is created for the cluster virtual server object, not for the physical cluster nodes.

Hmm. I started the installation of ZfD6.5 again and selected the Cluster Physical Nodes as target servers. I unchecked all the ZfD6.5 components except Imaging. After the install was complete, there they were -- beautiful ZIS objects for the Physical Cluster Members! Imaging, TFTP, PXE etc. are still cluster enabled.

I tested it and -- Yes! It works fine. A clustered ZfD6.5 imaging solution, complete with customized linux.2 files. I think that the documentation isn't correct. The support engineer agreed with that statement and started testing himself, he also concluded this is a perfectly functional workaround. (He gave the incident back to our company.)


Novell Cool Solutions (corporate web communities) are produced by WebWise Solutions. www.webwiseone.com

© 2014 Novell