Novell Home

LSI Logic RAID "No Hard Drives" BugFix

Novell Cool Solutions: Trench
By Jason Jones

Digg This - Slashdot This

Posted: 6 Feb 2006
 

Foreword

If you have access to the SLES9-SP3 discs, you can use them to circumvent this whole problem. Simply boot from your Service Pack 3 Disc, and SLES9 should see your Hard drives without a problem. If you only have access to the earlier versions, read on.

Background

I recently became employed as a system admin for a company which is growing *very* rapidly and on my first day they asked me to set up 3 new servers for them on some pre-purchased hardware.

Since I have a pretty solid background in Linux, I thought "noooo problem." Boy was I in for a ride.

I learned that one of our servers was an HP NetServer 2000r which had an LSI Logic RAID card controlling six hard drives.

When I put SLES in at first, everything seemed fine. I followed each step, and up until it probed the hard drives, I thought it was smooth sailing.

That's when SLES told me there weren't any hard drives present on the system. Not Good.

Steps fix "No Hard Drives" Problem.

*note* First, I apologize for the lack of screenshots. The servers are now up and running and I'd have to reboot them to attempt to get any, so I'll explain as good as text can.

  • Boot with the SLES9-1 CD-ROM
  • When booting, choose "Manual Installation" - If you choose anything else, you won't be able to load the required module for the RAID card.
  • Choose your language.
  • Choose the dialect of your language - I had to choose "English US" here.
  • Select "Kernel Modules"
  • The first option should be "Load IDE/RAID/SCSI Modules" - Choose it
  • Scroll down until you find a "megaraid-old" driver. - Make sure you choose the "-old" one. The newer one is the one causing all the problems.
  • Press Enter - It will ask you for kernel parameters. Just press enter. It'll should say "Module successfully loaded" after a couple of seconds.
  • Choose "Show Loaded Modules" - We now want to make sure the module actually loaded.
  • Look for "LSI Logic Megaraid (old driver)" in the list - If it's there, you're on the right track.
  • Choose "Ok"
  • We don't want to load any more drivers, so choose "back"
  • We now are ready to start installation, so... Choose "Start Installation" - IF YOU ARE DOING THIS FOR THE SECOND TIME, STOP HERE.
  • Choose the instllation media you're using. Most likely CD-ROM
From here, it should take you to the normal installation process. When you get to the hard drive section, it should magically display your RAID configured hard drives.

Continue on through the installation until it reboots.

*NOTE* - When it reboots, it will give you an error!

After Rebooting

It will try to reboot from the hard drive this time. If you let it, it won't be able to find the partition where you installed SLES9 due to some misconfiguration in /etc/sysconfig/kernel. We need to fix this! This is easy...

Simply follow the exact instructions above again, until you get to the part where you're choosing "Start Installation".

After that, follow these instructions.:
  • Choose "Hard Disk" - it will present you with a list of your partitions. Select the partition you need to boot from and it should boot normally from there.
  • After the First Successful Reboot

    *IMPORTANT* - ONE OF THESE OPTIONS NEEDS TO BE DONE BEFORE ANY REBOOTS, OR IT WON'T BOOT.
    1. update your machine with YOU (YAST Online Updater) and select all critical (pre-selected) updates. - If you do this, DO NOT follow step number 2.
    2. *NOTE* - If you updated your machine (followed step number 1), DO NOT DO THIS.
      • edit your /etc/sysconfig/kernel file and do the following:
      • change the "megaraid" to "megaraid-old" in the INITRD_MODULES section
      • example : INITRD_MODULES="megaraid sym53c8xx reiserfs" should be changed to INITRD_MODULES="megaraid-old sym53c8xx reiserfs"
      • become root. - (su)
      • run mkinird from a console - this creates a new boot image that the system will boot from.
After following ONE of those options, your system should boot just fine.

Enjoy your new SLES9 installation!

*NOTE* - If you ever update your system to Service Pack 3 or beyond you'll need to change your /etc/sysconfig/kernel file back to the way it originally was, or your system won't boot!


Novell Cool Solutions (corporate web communities) are produced by WebWise Solutions. www.webwiseone.com

© 2014 Novell