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About This Guide
This manual introduces you to a variety of applications shipping with openSUSE®. It
guides you through using these applications and helps you perform key tasks. It is in-
tended mainly for end users.

The manual is subdivided into the following parts:

Office and Collaboration
Use the office and collaboration software openSUSE offers, such as the OpenOf-
fice.org suite, several e-mailing and calendaring programs, and applications for
online conversations. Also find vital information concerning the management and
exchange of data on your system: how to share files on the network, how to effec-
tively search and encrypt data, and how to manage printers.

Internet
Find out how to use the Internet applications included in openSUSE, such as
Konqueror or the Firefox Web browser, a download manager, or a news feed
reader.

Multimedia
Get to know applications for graphics manipulation, management of digital pho-
tographs, sound manipulation and editing, and for CD and DVD writers.

Many chapters in this manual contain links to additional documentation resources. This
includes additional documentation that is available on the system as well as documen-
tation available on the Internet.

For an overview of the documentation available for your product and the latest docu-
mentation updates, refer to http://www.novell.com/documentation/
opensuse111 or to the following section.

http://www.novell.com/documentation/opensuse111
http://www.novell.com/documentation/opensuse111


1 Available Documentation
We provide HTML and PDF versions of our books in different languages. The following
manuals for users and administrators are available on this product:

Start-Up (↑Start-Up)
Guides you through the installation and basic configuration of your system. For
newcomers, the manual also introduces basic Linux concepts such as the file system,
the user concept and access permissions and gives an overview of the features
openSUSE offers to support mobile computing. Provides help and advice in trou-
bleshooting.

KDE User Guide (↑KDE User Guide)
Introduces the KDE desktop of openSUSE. It guides you through using and config-
uring the desktop and helps you perform key tasks. It is intended mainly for users
who want to make efficient use of KDE as their default desktop.

GNOME User Guide (↑GNOME User Guide)
Introduces the GNOME desktop of openSUSE. It guides you through using and
configuring the desktop and helps you perform key tasks. It is intended mainly for
end users who want to make efficient use of GNOME desktop as their default
desktop.

Application Guide (page 1)
Learn how to use and configure key desktop applications on openSUSE. This guide
introduces browsers and e-mail clients as well as office applications and collabora-
tion tools. It also covers graphics and multimedia applications.

Reference (↑Reference)
Gives you a general understanding of openSUSE and covers advanced system ad-
ministration tasks. It is intended mainly for system administrators and home users
with basic system administration knowledge. It provides detailed information about
advanced deployment scenarios, administration of your system, the interaction of
key system components and the set-up of various network and file services open-
SUSE offers.

Novell AppArmor Administration Guide (↑Novell AppArmor Administration Guide)
Contains in-depth information about the use of Novell AppArmor in your environ-
ment. AppArmor is a security application that lets you specify per program which
files the program may read, write, and execute.

xii Application Guide



Lessons For Lizards
A community book project for the openSUSE distribution. A snapshot of the
manual written by the open source community is released on an equal footing with
the Novell/SUSE manuals. The lessons are written in a cook book style and cover
more specific or exotic topics than the traditional manuals. For more information,
see http://developer.novell.com/wiki/index.php/Lessons
_for_Lizards.

In addition to the comprehensive manuals, several quick start guides are available:

KDE Quick Start (↑)
Gives a short introduction to the KDE desktop and some key applications running
on it.

GNOME Quick Start (↑)
Gives a short introduction to the GNOME desktop and some key applications
running on it.

Novell AppArmor Quick Start
Helps you understand the main concepts behind Novell® AppArmor.

Find HTML versions of most openSUSEmanuals in your installed system under /usr/
share/doc/manual or in the help centers of your desktop. Find the latest documen-
tation updates at http://www.novell.com/documentation where you can
download PDF or HTML versions of the manuals for your product.

For information where to find the books on your installation media, refer to the Release
Notes of this product. The Release Notes are available from your installed system under
/usr/share/doc/release-notes/ or in the help centers of your KDE or
GNOME desktop.

2 Feedback
Several feedback channels are available:

• To report bugs for a product component or to submit enhancements requests, please
use https://bugzilla.novell.com/. If you are new to Bugzilla, you
might find the Submitting Bug Reports article—available under http://en
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.opensuse.org/Submitting_Bug_Reports helpful. Frequently asked
questions on reporting bugs are available under http://en.opensuse.org/
Bug_Reporting_FAQ.

• We want to hear your comments and suggestions about this manual and the other
documentation included with this product. Please use the User Comments feature
at the bottom of each page of the online documentation and enter your comments
there.

3 Documentation Conventions
The following typographical conventions are used in this manual:

• /etc/passwd: filenames and directory names

• placeholder: replace placeholder with the actual value

• PATH: the environment variable PATH

• ls, --help: commands, options, and parameters

• user: users or groups

• Alt, Alt + F1: a key to press or a key combination; keys are shown in uppercase as
on a keyboard

• File, File > Save As: menu items, buttons

• Dancing Penguins (Chapter Penguins, ↑Another Manual): This is a reference to a
chapter in another manual.

4 About the Making of This Manual
This book is written in Novdoc, a subset of DocBook (see http://www.docbook
.org). The XML source files were validated by xmllint, processed by xsltproc,
and converted into XSL-FO using a customized version of NormanWalsh's stylesheets.
The final PDF is formatted through XEP from RenderX.

xiv Application Guide
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5 Source Code
The source code of openSUSE is publicly available. To download the source code,
proceed as outlined underhttp://www.novell.com/products/suselinux/
source_code.html. If requested we send you the source code on a DVD.We need
to charge a $15 or €15 fee for creation, handling and postage. To request a DVD of the
source code, send an e-mail to sourcedvd@suse.de [mailto:sourcedvd@suse
.de] or mail the request to:

SUSE Linux Products GmbH Product Management openSUSEMaxfeldstr. 5 D-90409
Nürnberg Germany

6 Acknowledgments
With a lot of voluntary commitment, the developers of Linux cooperate on a global
scale to promote the development of Linux. We thank them for their efforts—this dis-
tribution would not exist without them. Furthermore, we thank Frank Zappa and Pawar.
Special thanks, of course, goes to Linus Torvalds.

Have a lot of fun!

Your SUSE Team
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Part I. OpenOffice.org Novell
Edition and Other Office

Applications





1The OpenOffice.org Office
Suite
OpenOffice.org is a powerful open-source office suite that provides tools for all types
of office tasks, such as writing texts, working with spreadsheets, or creating graphics
and presentations. With OpenOffice.org, you can use the same data across different
computing platforms. You can also open and edit files in other formats, including
Microsoft Office, then save them back to this format, if needed. This chapter covers
information about the Novell® edition of OpenOffice.org and some of the key features
you should be aware of when getting started with the suite.

1.1 Understanding OpenOffice.org
OpenOffice.org consists of several application modules (subprograms), which are de-
signed to interact with each other. They are listed in Table 1.1 . A full description of
each module is available in the online help, described in Section 1.2, “Finding Help
and Information About OpenOffice.org” (page 15).

Table 1.1 The OpenOffice.org Application Modules

PurposeModule

Word processor application moduleWriter

Spreadsheet application moduleCalc

Presentation application moduleImpress

The OpenOffice.org Office Suite 3



PurposeModule

Database application moduleBase

Application module for drawing vector graphicsDraw

Application module for generating mathematical formulasMath

The appearance of the application varies depending on the desktop or windowmanager
you use. Regardless of the appearance, the basic layout and functions are the same.

This section is about OpenOffice.org in general and the advantages of the Novell Edition
of OpenOffice.org. Writer and Calc are the most common applications wherefore there
are extra chapters to explain the important functions in detail, see Chapter 2, OpenOf-
fice.org Writer (page 17) and Chapter 3, OpenOffice.org Calc (page 29). The other
modules (Impress, Base, Draw, Math) are collectived in Chapter 4, Further OpenOf-
fice.org Modules (page 33)

1.1.1 Advantages of the Novell Edition of
OpenOffice.org

openSUSE® includes the Novell edition of OpenOffice.org. The Novell edition includes
several enhancements that are not yet included in the standard edition.

Microsoft Excel*:
Compatibility: Improved Excel compatibility for certain built-in functions (e.g.,
CELL, INFO, INDIRECT), hyperlinks and filters, improved ergonomics, and
support for "R1C1" style addresses. Improved performance on certain text functions
such as SEARCH. Natural sorting option in cell range sorting.

Excel VBA Macro Interoperability:
OpenOffice.org Novell Edition eases the migration of manymacros fromMicrosoft
Excel. Although not all macros can be successfully migrated, this interoperability
offers more than the standard edition, which does not support migration of macros.
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Data Pilots:
Data Pilots are interoperable with Microsoft Office PivotTables*. OpenOffice.org
Novell Edition substantially improves the Data Pilot feature, making it possible to
edit pilots after creation.

Enhanced Fonts:
Licensed fonts from Agfa* Monotype* which are metrically identical and visually
compatible with some of the key Microsoft fonts. This allows OpenOffice.org
Novell Edition to match fonts when opening documents originally composed in
Microsoft Office, and very closely match pagination and page formatting.

EMF+Support:
The ability to render EMF+ formatted graphics.

SVG Support:
The ability to import scalable vector graphics.

Import File Formats:
Microsoft Works, WordPerfect* text and graphics, T602 files, OfficeOpen XML,
and more.

Groupwise® Integration:
OpenOffice.org Novell Edition includes improved integration with ODMA (Open
DocumentManagement Architecture) services, for example for GroupWise. If you
have the GroupWise client installed on the machine, OpenOffice.org Novell Edition
will offer to open documents from GroupWise, or save documents in GroupWise.

1.1.2 Using the Standard Edition of
OpenOffice.org

You can use the standard edition of OpenOffice.org rather than the Novell edition. If
you install the latest version of OpenOffice.org, all of your Novell Edition files remain
compatible. However, the standard edition does not contain the enhancements made in
the Novell edition.
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1.1.3 Compatibility with Other Office
Applications

OpenOffice.org can work with documents, spreadsheets, presentations, and databases
in many other formats, includingMicrosoft Office. They can be seamlessly opened like
other files and saved back to the original format. Because the Microsoft formats are
proprietary and the specifications are not available to other applications, there are occa-
sionally formatting issues. If you have problems with your documents, consider opening
them in the original application and resaving them in an open format such as RTF for
text documents or CSV for spreadsheets.

TIP

For good information about migrating from other office suites to OpenOf-
fice.org, refer to the OpenOffice.org Migration Guide at http://
documentation.openoffice.org/manuals/oooauthors2/
0600MG-MigrationGuide.pdf.

Converting Documents to the OpenOffice.org Format
OpenOffice.org can read, edit, and save documents in a number of formats. It is not
necessary to convert files from those formats to the OpenOffice.org format to use those
files. However, if you want to convert the files, you can do so. To convert a number of
documents, such as when first switching to OpenOffice.org, do the following:

1 Select File >Wizards > Document Converter.

2 Choose the file format from which to convert.

There are several StarOffice and Microsoft Office formats available.

3 Click Next.

4 Specify where OpenOffice.org should look for templates and documents to
convert and in which directory the converted files should be placed.
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IMPORTANT

Documents retrieved from a Windows partition are usually in a subdirec-
tory of /windows.

5 Make sure that all other settings are appropriate, then click Next.

6 Review the summary of the actions to perform, then start the conversion by
clicking Convert. When everthing is done, close the Wizard by clicking Close.

The amount of time needed for the conversion depends on the number of files
and their complexity. For most documents, conversion does not take very long.

Sharing Files with Users of Other Office Suites
OpenOffice.org is available for a number of operating systems. This makes it an excellent
tool when a group of users frequently need to share files and do not use the same system
on their computers.

When sharing documents with others, you have several options.

If the recipient needs to be able to edit the file
Save the document in the format the other user needs. For example, to save as a
Microsoft Word file, click File > Save As, then select the Microsoft Word file type
for the version of Word the other user needs.

If the recipient only needs to read the document
Export the document to a PDF file with File > Export as PDF. PDF files can be
read on any platform using a viewer like Adobe Acrobat Reader.

If you want to share a document for editing
Use one of the standard document formats. The default formats comply with the
OASIS standard XML format, making them compatible with a number of applica-
tions. TXT and RTF formats, although limited in formatting, might be a good option
for text documents. Comma Separated Value (CSV) is useful for spreadsheets.
OpenOffice.org might also offer your recipient's preferred format, especially
Microsoft formats.
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If you want to e-mail a document as a PDF
Click File > Send > E-mail as PDF. Your default e-mail program opens with the
file attached.

If you want to e-mail a document to a Microsoft Word user
Click File > Send > E-mail as Microsoft Word. Your default e-mail program opens
with the file attached.

Send a document as the body of an e-mail
Click File > Send > Document as E-mail. Your default e-mail program opens with
the contents of the document as the e-mail body.

1.1.4 Starting OpenOffice.org
Start the application in one of the following ways:

• Click Computer > OpenOffice.org Writer.

This opens Writer. To open a different module, click File > New from the newly
opened Writer document, then choose the module you want to open.

• Click Computer >More Applications > Office, then click the name of the
OpenOffice.org module you want to start.

SomeOpenOffice.org modules can be found in other sections of theMore Applica-
tions window. For example, the Writer/Web module is listed under Internet and
the Draw module is under Graphics.

• In a terminal window, enter ooffice. The OpenOffice.org window opens. Click
File New, then choose the module you want to open.

If any OpenOffice.org application is open, you can open any of the other applications
by clicking File > New > Name of Application.
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1.1.5 Saving OpenOffice.org files with a
password

You can save files, no matter in which OpenOffice.org format, with a password. For
this you have to activate the checkbox Save with password in the Save dialog. After
you have typed and confirmed your password, your file will be saved. Next time a user
opens the file, he will be prompted for the password. You can change the password in
two different ways:

• Overwrite the same file with File > Save as... and continue like above.

• Open File > Proberties... and click Change password...

1.1.6 Customizing OpenOffice.org
You can customize OpenOffice.org to best suit your needs and working style. Toolbars,
menus, and keyboard shortcuts can all be reconfigured to help you more quickly access
the features you use the most. You can also assign macros to application events if you
want specific actions to occur when those events take place. For example, if you always
work with a specific spreadsheet, you can create a macro that opens the spreadsheet
and assign the macro to the Start Application event.

This section contains simple, generic instructions for customizing your environment.
The changes you make are effective immediately, so you can see if the changes are
what you wanted and go back andmodify them if they were not. See the OpenOffice.org
help files for detailed instructions.

Customizing Toolbars
Use the Customize dialog to modify OpenOffice.org toolbars.

1 Click the arrow icon at the end of any toolbar, then click Customize Toolbar.

or

Click Tools > Customize > Toolbars.

2 Select the toolbar you want to customize.
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The toolbar you clicked should already be selected. You can change the toolbar
you want to customize by selecting the desired toolbar from the Toolbar menu.

3 Select the check boxes next to the commands you want to appear on the toolbar,
and deselect the check boxes next to the commands you do not want to appear.

4 Select whether to save your customized toolbar in the OpenOffice.org module
you are using or in the document.

• OpenOffice.org module

The customized toolbar is used whenever you open that module.

• Document filename

The customized toolbar is used whenever you open that document.

5 Repeat to customize additional toolbars.

6 Click OK.

You can quickly choose the buttons that appear on a particular toolbar.

1 Click the arrow icon at the end of the toolbar you want to change.

2 Click Visible Buttons to display a list of buttons.

3 Select the buttons in the list to enable (check) or disable (uncheck) them.

Customizing Menus
You can add or delete items from current menus, reorganize menus, and even create
new menus.

1 Click Tools > Customize >Menus.

2 Select the menu you want to change, or click New to create a new menu.

Click Help for more information about the options in the Customize dialog.
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3 Modify, add, or delete menu items as desired.

4 Click OK.

Customizing Keyboard Shortcuts
You can reassign currently assigned keyboard shortcuts and assign new shortcuts to
frequently used functions.

1 Click Tools > Customize > Keyboard.

2 Select the keys you want to assign to a function, or select the function and assign
the keys or key combinations.

Click Help for more information about the options in the Customize dialog.

3 Modify, add, or delete keyboard shortcuts as desired.

4 Click OK.

Customizing Events
OpenOffice.org also provides ways to assign macros to events such as application
startup or the saving of a document. The assigned macro runs automatically whenever
the selected event occurs.

1 Click Tools > Customize > Events.

2 Select the event you want to change.

Click Help for more information about the options in the Customize dialog box.

3 Assign or remove macros for the selected event.

4 Click OK.

The OpenOffice.org Office Suite 11



Changing the Global Settings
Global settings can be changed in any OpenOffice.org application by clicking Tools >
Options on the menu bar. This opens the window shown in the figure below. A tree
structure is used to display categories of settings.

Figure 1.1 The Options Window

The following table lists the settings categories along with a brief description of each
category:

NOTE

The settings categories that appear depend on the module you are working in.
For example, if you are in Writer, the OpenOffice.org Writer category appears
in the list, but the OpenOffice.org Calc category does not. The OpenOffice.org
Base category appears in both Calc and Writer. The Application column in the
table shows where each setting category is available.

Table 1.2 Global Setting Categories

ApplicationDescriptionSettings
Category

AllVarious basic settings, including your user data (such
as your address and e-mail), important paths, and
settings for printers and external programs.

OpenOf-
fice.org
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ApplicationDescriptionSettings
Category

AllIncludes the settings related to the opening and saving
of several file types. There is a dialog for general

Load/Save

settings and several special dialogs to define how
external formats should be handled.

AllCovers the various settings related to languages and
writing aids, such as your locale and spell checker

Language
Settings

settings. This is also the place to enable support for
Asian languages.

WriterConfigures the global word processing options, such
as the basic fonts and layout that Writer should use.

OpenOf-
fice.org
Writer

WriterChanges the settings related to the HTML authoring
features of OpenOffice.org.

OpenOf-
fice.org
Writer/Web

CalcChanges the settings for Calc, such as those related
to sort lists and grids.

OpenOf-
fice.org
Calc

ImpressChanges the settings that should apply to all presen-
tations. For example, you can specify the measure-
ment unit for the grid used to arrange elements.

OpenOf-
fice.org Im-
press

DrawIncludes the settings related to the vector drawing
module, such as the drawing scale, grid properties,
and some print options.

OpenOf-
fice.org
Draw

MathProvides a single dialog to set special print options
for formulas.

OpenOf-
fice.org
Math
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ApplicationDescriptionSettings
Category

BaseProvides dialogs to set and edit connections and
registered databases.

OpenOf-
fice.org
Base

AllDefines the default colors used for newly created
charts.

Charts

AllIncludes the dialogs to configure any proxies and to
change settings related to search engines.

Internet

IMPORTANT

All settings listed in the table are applied globally for the specified applications.
They are used as defaults for every new document you create.

1.1.7 Finding Templates
Templates greatly enhance the use of OpenOffice.org by simplifying formatting tasks
for a variety of different types of documents. OpenOffice.org comes with a few tem-
plates, and you can find additional templates on the Internet. You can also create your
own. Creating templates is beyond the scope of this guide, but detailed instructions are
found in the OpenOffice.org help system and in other documents and tutorials available
online.

In addition to templates, you can find other extras and add-ins online. The following
table lists a few of the prominent places where you can find templates and other extras.
Please note that the information in the following table might not be current, because
Web sites often close or change its content.
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Table 1.3 Where to Find OpenOffice.org Templates and Extras

What You Can FindLocation

Templates for Calc spreadsheets, CD
cases, seed packets, fax cover sheets, and
more

OpenOffice.org documentationWeb site,
see http://documentation
.openoffice.org/Samples
_Templates/User/template_2
_x/index.html

Templates for many types of labelsWorldlabel.com, see http://www
.worldlabel.com/Pages/
openoffice-template.htm

For more information about templates, see Section 2.5, “Using Templates to Format
Documents” (page 24) and Section 3.1.2, “Using Templates in Calc” (page 30).

1.2 Finding Help and Information
About OpenOffice.org

OpenOffice.org contains extensive online help. In addition, a large community of users
and developers support it. As a result, it is seldom hard to find help or information about
using OpenOffice.org. The following table shows some of the places where you can
go for additional information. (Because Web sites often close or their content changes,
the information in the following table might not be current when you read it.)

OpenOffice.org online help menu
Extensive help on performing any task in OpenOffice.org

Official OpenOffice.org support page (http://support.openoffice.org/
index.html)

Manuals, tutorials, user and developer forums, users@openoffice.org mailing list,
FAQs, and much more
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OpenOffice.orgMigrationGuide (http://documentation.openoffice.org/
manuals/oooauthors2/0600MG-MigrationGuide.pdf)

Information about migrating to OpenOffice.org from other office suites, including
Microsoft Office

Taming OpenOffice.org (http://www.taming-openoffice-org.com/)
Books, news, tips and tricks

OpenOffice.org Macros (http://www.pitonyak.org/oo.php)
Extensive information about creating and using macros
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2OpenOffice.org Writer
OpenOffice.org Writer is a full-featured word processor with page and text formatting
capabilities. Its interface is similar to interfaces for other major word processors, and
it includes some features that are usually found only in expensive desktop publishing
applications.

This chapter highlights a few key features of Writer. For more information about these
features and for complete instructions for usingWriter, look at the OpenOffice.org help
or any of the sources listed in Section 1.2, “Finding Help and Information About
OpenOffice.org” (page 15).

NOTE

Much of the information in this section can also be applied to other OpenOf-
fice.org modules. For example, other modules use styles similarly to how they
are used in Writer.

2.1 What's New in OpenOffice.org 3.0
Writer?

The new version of OpenOffice.org Writer brings two substantial modifications along.
A smooth way of zooming and a new kind of presenting notes. These features make
handling documents easier. In contrast to earlier versions of OpenOffice.org the notice
tags are now placed right beside the document. Notes by different authors are distin-
guished by different colors.
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Figure 2.1 New positioning of notes

Downright there is a slide bar to zoom in and out of the document. When zooming out
you are able to overview multiple sites of your document. It looks like a preview of the
document but you are still editing.

Figure 2.2 New smooth zoom in edit mode
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2.2 Creating a New Document
There are two ways to create a new document:

To create a document from scratch, click File > New > Text Document.

To use a standard format and predefined elements for your own documents, try a wizard.
Wizards are small utilities that let you make some basic decisions and then produce a
ready-made document from a template. For example, to create a business letter, click
File >Wizards > Letter. Using the wizard's dialogs, easily create a basic document using
a standard format. A sample wizard dialog is shown in Figure 2.3 .

Figure 2.3 An OpenOffice.org Wizard

Enter text in the document window as desired. Use the Formatting toolbar or the Format
menu to adjust the appearance of the document. Use theFilemenu or the relevant buttons
in the toolbar to print and save your document. With the options under Insert, add extra
items to your document, such as a table, picture, or chart.
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2.3 Sharing Documents with Other
Word Processors

You can use Writer to edit documents created in a variety of other word processors.
For example, you can import a Microsoft Word document, edit it, and save it again as
aWord document. MostWord documents can be imported into OpenOffice.org without
any problem. Formatting, fonts, and all other aspects of the document remain intact.
However, some very complex documents—such as documents containing complicated
tables, Word macros, or unusual fonts or formatting—might require some editing after
being imported. OpenOffice.org can also save inmany popular word processing formats.
Likewise, documents created in OpenOffice.org and saved asWord files can be opened
in Microsoft Word without any trouble.

This means, if you use OpenOffice.org in an environment where you frequently share
documents with Word users, you should have little or no trouble exchanging document
files. Just open the files, edit them, and save them as Word files.

2.4 Formatting with Styles
OpenOffice.org uses styles for applying consistent formatting to various elements in a
document. The following types of styles are available:

Table 2.1 About the Types of Styles

What it DoesType of Style

Applies standardized formatting to the various types of
paragraphs in your document. For example, apply a paragraph

Paragraph

style to a first-level heading to set the font and font size,
spacing above and below the heading, location of the heading,
and other formatting specifications.

Applies standardized formatting for types of text. For exam-
ple, if you want emphasized text to appear in italics, you can

Character

create an emphasis style that italicizes selected text when
you apply the style to it.
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What it DoesType of Style

Applies standardized formatting to frames. For example, if
your document uses sidebars, you can create frames with

Frame

specified graphics, borders, location, and other formatting
so that all of your sidebars have a consistent appearance.

Applies standardized formatting to a specified type of page.
For example, if every page of your document contains a

Page

header and footer except for the first page, you can use a first
page style that disables headers and footers. You can also
use different page styles for left and right pages so that you
have bigger margins on the insides of pages and your page
numbers appear on an outside corner.

Applies standardized formatting to specified list types. For
example, you can define a checklist with square check boxes

List

and a bullet list with round bullets, then easily apply the
correct style when creating your lists.

2.4.1 Opening the Styles and Formatting
Window

The Styles and Formatting window (called the Stylist in earlier versions of OpenOf-
fice.org), is a versatile formatting tool for applying styles to text, paragraphs, pages,
frames, and lists. To open this window, click Format > Styles and Formatting.
OpenOffice.org comes with several predefined styles. You can use these styles as they
are, modify them, or create new styles.

TIP

By default, the Styles and Formatting window is a floating window; that is, it
opens in its own window that you can place anywhere on the screen. If you
use styles extensively, you might find it helpful to dock the window so that it
always present in the same part of the Writer interface. To dock the Styles and
Formatting window, press Control while you double-click on a gray area in the
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window. This tip applies to some other windows in OpenOffice.org as well, in-
cluding the Navigator.

2.4.2 Applying a Style
To apply a style, select the element you want to apply the style to, and then double-
click the style in the Styles and Formatting window. For example, to apply a style to a
paragraph, place the cursor anywhere in that paragraph and double-click the desired
paragraph style.

2.4.3 Using Styles Versus Using Formatting
Buttons and Menu Options

Using styles rather than the Format menu options and buttons helps give your pages,
paragraphs, texts, and lists a more consistent look and makes it easier to change your
formatting. For example, if you emphasize text by selecting it and clicking the Bold
button, then later decide you want emphasized text to be italicized, you need to find all
of your bolded text and manually change it to italics. If you use a character style, you
only need to change the style from bold to italics and all text that has been formatted
with that style automatically changes from bold to italics.

Text formatted with a menu option or button overrides any styles you have applied. If
you use the Bold button to format some text and an emphasis style to format other text,
then changing the style does not change the text that you formatted with the button,
even if you later apply the style to the text you bolded with the button. You must man-
ually unbold the text and then apply the style.

Likewise, if you manually format your paragraphs using Format > Paragraph, it is
easy to end up with inconsistent paragraph formatting. This is especially true if you
copy and paste paragraphs from other documents with different formatting. However,
if you apply paragraph styles, formatting remains consistent. If you change a style, the
change is automatically applied to all paragraphs formatted with that style.
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2.4.4 Changing a Style
With styles, you can change formatting throughout a document by changing a style,
rather than applying the change separately everywhere you want to apply the new for-
matting.

1 In the Styles and Formatting window, right-click the style you want to change.

2 ClickModify.

3 Change the settings for the selected style.

For information about the available settings, refer to the OpenOffice.org online
help.

4 Click OK.

2.4.5 Creating a Style
OpenOffice.org comes with a collection of styles to suit many users’ needs. However,
most users eventually need a style that does not yet exist. To create a new style:

1 Right-click in any empty space in the Styles and Formatting window.

Make sure you are in the list of styles for the type of style you want to create.
For example, if you are creating a character style, make sure you are in the
character style list.

2 Click New.

3 Click OK.

4 Name your style and choose the settings you want applied with that style.

For details about the style options available in any tab, click that tab and then
click Help.
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2.5 Using Templates to Format
Documents

Most word processor users create more than one kind of document. For example, you
might write letters, memos, and reports, all of which look different and require different
styles. If you create a template for each of your document types, the styles you need
for each document are always readily available.

Creating a template requires a little bit of up-front planning. You need to determine
how you want the document to look so you can create the styles you need in that tem-
plate. You can always change your template, but a little planning can save you a lot of
time later.

NOTE

You can convert Microsoft Word templates like you would any other Word
document. See Section “Converting Documents to the OpenOffice.org Format”
(page 6) for information.

A detailed explanation of templates is beyond the scope of this section. However, more
information is found in the help system, and detailed how-tos are found at the
OpenOffice.orgDocumentation page, seehttp://documentation.openoffice
.org/HOW_TO/index.html.

2.5.1 Creating a Template
A template is a text document containing only the styles and content that you want to
appear in every document, such as your address information and letterhead on a letter.
When a document is created or opened with the template, the styles are automatically
applied to that document.

To create a template:

1 Click File > New > Text Document.

2 Create the styles and content that you want to use in any document that uses this
template.
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3 Click File > Templates > Save.

4 Specify a name for the template.

5 In the Categories box, click the category you want to place the template in.

The category is the folder where the template is stored.

6 Click OK.

2.6 Working with Large Documents
You can useWriter to work on large documents. Large documents can be either a single
file or a collection of files assembled into a single document.

2.6.1 Navigating in Large Documents
The Navigator tool displays information about the contents of a document. It also lets
you quickly jump to different elements. For example, you can use the Navigator to get
a quick overview of all images included in the document.

To open the Navigator, click Edit > Navigator. The elements listed in the Navigator
vary according to the document loaded in Writer.

Figure 2.4 Navigator Tool in Writer

Click an item in the Navigator to jump to that item in the document.
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2.6.2 Using a Master Document to Create a
Single Document from Multiple Files

If you are working with a very large document, such as a book, you might find it easier
to manage the book with a master document, rather than keeping the book in a single
file. A master document enables you to quickly apply formatting changes to a large
document or to jump to each subdocument for editing.

A master document is a Writer document that serves as a container for multiple Writer
files. You can maintain chapters or other subdocuments as individual files collected in
the master document. Master documents are also useful if multiple people are working
on a document. You can separate each person’s portion of the document into subdocu-
ments collected in a master document, allowing multiple writers to work on their sub-
documents at the same time without fear of overwriting other people’s work.

NOTE

If you are coming to OpenOffice.org from Microsoft Word, you might be ner-
vous about using master documents because the master document feature in
Word has a reputation for corrupting documents. This problem does not exist
in OpenOffice.org Writer, so you can safely use master documents to manage
your projects.

To create a master document:

1 Click New >Master Document.

or

Open an existing document and click File > Send > Create Master Document.

2 Insert subdocuments.

3 Click File Save.

The OpenOffice.org help files contain more complete information about working with
master documents. Look for the topic entitled Using Master Documents and Subdocu-
ments .
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TIP

The styles from all of your subdocuments are imported into the master docu-
ment. To ensure that formatting is consistent throughout your master document,
you should use the same template for each subdocument. Doing so is not
mandatory; however, if subdocuments are formatted differently, you might
need to do some reformatting to successfully bring subdocuments into the
master document without creating inconsistencies. For example, if two docu-
ments imported into your master document include different styles with the
same name, the master document will use the formatting specified for that
style in the first document you import.

2.7 Using Writer as an HTML Editor
In addition to being a full-featured word processor, Writer also functions as an HTML
editor. Writer includes HTML tags that can be applied as you would any other style in
a Writer document. You can view the document as it will appear online, or you can
directly edit the HTML code.

2.7.1 Creating an HTML Document
1 Click File > New > HTML Document.

2 Click the arrow at the bottom of the Formatting and Styles window.

3 Select HTML Styles.

4 Create your HTML document, using the styles to tag your text.

5 Click File > Save As.

6 Select the location where you want to save your file, name the file, and select
HTML Document (.html) from the Filter list.

7 Click OK.
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If you prefer to edit HTML code directly, or if you want to see the HTML code created
when you edited the HTML file as a Writer document, click View > HTML Source. In
HTML Source mode, the Formatting and Styles list is not available.

NOTE

The first time you switch to HTML Source mode, you are prompted to save the
file as HTML, if you have not already done so.
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3OpenOffice.org Calc

3.1 Using Spreadsheets with Calc
Calc is the OpenOffice.org spreadsheet application. Create a new spreadsheet with File
>New > Spreadsheet or open one with File >Open. Calc can read and save inMicrosoft
Excel's format, so it is easy to exchange spreadsheets with Excel users.

NOTE

Calc can process many VBA macros in Excel documents; however, support for
VBA macros is not yet complete. When opening an Excel spreadsheet that
makes heavy use of macros, you might discover that some do not work.

In the spreadsheet cells, enter fixed data or formulas. A formula can manipulate data
from other cells to generate a value for the cell in which it is inserted. You can also
create charts from cell values.

3.1.1 Using Formatting and Styles in Calc
Calc comes with a few built-in cell and page styles to improve the appearance of your
spreadsheets and reports. Although these built-in styles are adequate for many uses,
you will probably find it useful to create styles for your own frequently used formatting
preferences.
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Creating a Style
1 Click Format > Styles and Formatting.

2 In the Formatting and Styles window, click either the Cell Styles or the Page
Styles icon.

3 Right-click in the Formatting and Styles window, then click New.

4 Specify a name for your style and use the various tabs to set the desired formatting
options.

5 Click OK.

Modifying a Style
1 Click Format > Styles and Formatting.

2 In the Formatting and Styles window, click either the Cell Styles or the Page
Styles icon.

3 Right-click the name of the style you want to change, then clickModify.

4 Change the desired formatting options.

5 Click OK.

3.1.2 Using Templates in Calc
If you use different styles for different types of spreadsheets, you can use templates to
save your styles for each spreadsheet type. Then, when you create a particular type of
spreadsheet, use the applicable template and the styles you need for that template are
available in the Formatting and Styles window.

A detailed explanation of templates is beyond the scope of this section. However, more
information is found in the help system and detailed how-tos are found at the OpenOf-
fice.orgDocumentation page, seehttp://documentation.openoffice.org/
HOW_TO/index.html.
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Creating a Template
ACalc template is a spreadsheet that contains styles and content that you want to appear
in every spreadsheet created with that template, such as headings or other cell styles.
When a spreadsheet is created or opened with the template, the styles are automatically
applied to that spreadsheet.

To create a template:

1 Click File > New > Spreadsheet.

2 Create the styles and content that you want to use in any spreadsheet that uses
this template.

3 Click File > Templates > Save.

4 Specify a name for the template.

5 In the Categories box, click the category you want to place the template in.

The category is the folder where the template is stored.

6 Click OK.
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4Further OpenOffice.org
Modules
Besides OpenOffice.org Writer and OpenOffice.org Calc there are more applications
along the OpenOffice.org package. These includes Impress, Base, Draw and Math.
With these you are able to create presentations, design databases, draw up graphics and
diagrams and create mathematical formulas.

4.1 Using Presentations with Impress
Use OpenOffice.org Impress to create presentations for screen display or printing, such
as slide shows or transparencies. If you have used other presentation software, you can
move comfortably to Impress, which works very similarly to other presentation software.

Impress can open and save Microsoft Powerpoint presentations, which means you can
exchange presentations with Powerpoint users, as long as you save your presentations
in Powerpoint format.

4.1.1 Creating a Presentation
1 When you launch OpenOffice.org Impress directly, a wizard appears. Otherwise

click File > New > Presentation.

2 Select the option to use for creating the presentation.

There are three ways to create a presentation:
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• Create an empty presentation

Opens Impress with a blank slide. Use this option to create a new presentation
from scratch, without any preformatted slides.

• Create a presentation from a template

Opens Impress with your choice of template. Use this option to create a new
presentationwith a predesignedOpenOffice.org template or a template you’ve
created or installed yourself, such as your company’s presentation template.
Impress uses styles and templates the same way other OpenOffice.org mod-
ules do. See Section 2.5, “Using Templates to Format Documents” (page 24)
for more information about templates.

• Open a existing presentation

When you want to edit existing presentation check this radiobox. Click
Open... to select your presentation at the file dialog.

3 Select a slide design and an output medium, then click Next.

The slide design provides a variety of backgrounds and ready-made presentations,
or you can select Original to create your own.

The output medium is the form the final presentation will take, such an overhead
sheet, paper, or a screen slide show, among other choices.

Select Preview for a thumbnail showing your choices.

4 Select the type and speed of slide transitions and the presentation type (the timing
of the presentation), then click Create.

There are several slide transition choices, available from the drop-down.

You can choose either the default presentation type or Automatic. If you select
Automatic, specify the amount of time each page displays and the length of the
pause between presentations.

The presentation opens, ready for editing.
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4.1.2 Using Master Pages
Master pages give your presentation a consistent look by defining the way each slide
looks, what fonts are used, and other graphical elements. Impress uses two types of
master pages:

• Slide Master

Contains elements that appear on all slides. For example, you might want your
company logo to appear in the same place on every slide. The slide master also
determines the text formatting style for the heading and outline of every slide that
uses that master page, as well as any information you want to appear in a header
or footer.

• Notes Master

Determines the formatting and appearance of the notes in your presentation.

Creating a Slide Master
Impress comes with a collection of preformatted master pages. Eventually, most users
will want to customize their presentations by creating their own slide masters.

1 Start Impress, then create a new empty presentation.

2 Click View >Master > Slide Master.

This opens the current slide master inMaster View.

3 Right-click the left-hand panel, then click New Master.

4 Edit the slide master until it has the desired look.

5 Click Close Master View or View > Normal to return to Normal View.

TIP

When you have created all of the slide masters you want to use in your presen-
tations, you can save them in an Impress template. Then, any time you want
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to create presentations that use those slide masters, open a new presentation
with your template.

Applying a Slide Master
Slide masters can be applied to selected slides or to all slides in the presentation.

1 Open your presentation, then click View >Master > Slide Master.

2 (Optional) If you want to apply the slide master to multiple slides, but not to all
slides, select the slides that you want to use that slide master.

To select multiple slides, pressCtrl in the Slides Panewhile clicking on the slides
you want to use.

3 In the Task Pane, right-click the master page you want to apply.

If you do not see the Task Pane , click View > Task Pane.

4 Apply the slide master by clicking one of the following:.

• Apply to All Slides

Applies the selected slide master to all slides in the presentation.

• Apply to Selected Slides

Applies the selected slide master to the current slide, or to any slides you
select before applying the slide master. For example, if you want to apply a
different slide master to the first slide in a presentation, select that slide, then
change toMaster View and apply a slide master to that slide.

4.2 Using Databases with Base
OpenOffice.org includes a database module: Base. Use Base to design a database to
store many different kinds of information, from a simple address book or recipe file to
a sophisticated document management system.
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Tables, forms, queries, and reports can be createdmanually or using convenient wizards.
For example, the Table Wizard contains a number of common fields for business and
personal use. Databases created in Base can be used as data sources, such as when
creating form letters.

It is beyond the scope of this document to detail database design with Base. More infor-
mation can be found at the sources listed in Section 1.2, “Finding Help and Information
About OpenOffice.org” (page 15).

4.2.1 Creating a Database Using Predefined
Options

Base comes with several predefined database fields to help you create a database. The
steps in this section are specific to creating an address book using predefined fields,
but it should be easy to follow them to use the predefined fields for any of the built-in
database options.

The process for creating a database can be broken into several subprocesses:

Creating the Database
First, create the database.

1 Click File > New > Database.

2 Select Create a new database > Next.

3 Click Yes, register the database for me to make your database information
available to other OpenOffice.org modules, select both check boxes in the bottom
half of the dialog, then click Finish.

4 Browse to the directory where you want to save the database, specify a name for
the database, then click OK.

Setting Up the Database Table
Next, define the fields you want to use in your database table.
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1 In the Table Wizard, click Personal.

The Sample tables list changes to show the predefined tables for personal use.
If you had clicked Business, the list would contain predefined business tables.

2 In the Sample tables list, click Addresses.

The available fields for the predefined address book appear in the Available
fields menu.

3 In the Available fields menu, click the fields you want to use in your address
book.

You can select one item at a time, or you can shift-click multiple items to select
them.

4 Click the single→ to move the selected items to the Selected fields menu.

Tomove all available fields to the Selected fieldsmenu, click the double right-
arrow.

5 Use the ↑ and ↓ keys to adjust the order of the selected fields.

The fields appear in the table and forms in the order in which they are listed.

6 Click Next.

7 Make sure each of the fields is defined correctly.

You can change the field name, type, whether the entry is required, and the
maximum length of the field (the number of characters that can be entered in
that field). For this example, leave the settings as they are.

8 Click Next.

9 ClickCreate a primary key, click Automatically add a primary key, click Auto
value, then click Next.

10 Accept the default name for the table, selectCreate a form based on this table,
then click Finish.
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Creating a Form
Next, create the form to use when entering data into your address book.

1 In the FormWizard, click the double right-arrow icon to move all available fields
to the Fields in the form list, then click Next twice.

2 Select how you want to arrange your form, then click Next.

3 Select the option to use the form to display all data and leave all of the check
boxes empty, then click Next.

4 Apply a style and field border, then click Next.

For this example, accept the default selections.

5 Name the form, select theModify the form option, then click Finish.

Modifying the Form
After the form has been defined, you can modify the appearance of the form to suit
your preferences.

1 Close the form that opened when you finished the previous step.

2 In the main window for your database, right-click the form you want to modify
(there should be only one option), then click Edit.

3 Arrange the fields on the form by dragging them to their new locations.

For example, move the First Name field so it appears to the right of the Last
Name field, and then adjust the locations of the other fields to suit your preference.

4 When you have finished modifying the form, save it and close it.

What’s Next?
After you have created your database tables and forms, you are ready to enter your data.
You can also design queries and reports to help sort and display the data.
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Refer to OpenOffice.org online help and other sources listed in Section 1.2, “Finding
Help and Information About OpenOffice.org” (page 15) for additional information
about Base.

4.3 Creating Graphics with Draw
Use OpenOffice.org Draw to create graphics and diagrams. You can save your drawings
in today’s most common formats and import them into any application that lets you
import graphics, including the other OpenOffice.org modules. You can also create Flash
versions of your drawings.

The OpenOffice.org documentation contains complete instructions on using Draw. See
Section 1.2, “Finding Help and Information About OpenOffice.org” (page 15) for more
information.

To use a Draw graphic in a document:

1 Open Draw, then create the graphic.

2 Save the graphic.

3 Copy the graphic and paste it into the document, or insert the graphic directly
from the document.

One particularly useful feature of Draw is the ability to open it from other OpenOf-
fice.org modules so you can create a drawing that is automatically imported into your
document.

1 From anOpenOffice.org module (for example, fromWriter), click Insert >Object
> OLE Object > OpenOffice.org 3.x Drawing > OK.

This opens Draw.

2 Create your drawing.

3 Click in your document, outside the Draw frame.

The drawing is automatically inserted into your document.
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4.4 Creating Mathematical Formulas
with Math

It is usually difficult to include complex mathematical formulas in your documents.
The OpenOffice.org Math equation editor lets you create formulas using operators,
functions, and formatting assistants. You can then save those formulas as objects that
can be imported into other documents. Math functions can be inserted into other
OpenOffice.org documents like any other graphic object.

NOTE

Math is not a calculator. The functions it creates are graphical objects. Even if
they are imported into Calc, these functions cannot be evaluated.

Further OpenOffice.org Modules 41





5Viewing PDF Files and Other
Documents with Okular
Apart from PDF files, Okular allows you to view a great number of file formats, such
as PostScript, several image formats, OpenDocument format (ODF), OpenDocument
text (ODT), some eBook formats (ePub), and even Microsoft* Compiled HTML Help
(CHM). Okular also provides support for bookmarks, annotations, form fields and
multi- media contents, and rotation of pages.

5.1 Viewing PDF Files
Documents that need to be shared or printed across platforms can be saved as PDF
(Portable Document Format) files, for example, in the OpenOffice.org suite. View them
with Okular, the default KDE document viewer.

Start Okular from the main menu or press Alt + F2 and enter okular. To open a doc-
ument, select File > Open and choose the desired file from the file system. Navigate
through the document by using the navigation icons at the top or bottom of the window.
Depending on which icon you click on the navigation panel on the left, the sidebar either
shows a table of Contents, a Thumbnail view of each page, the Reviews for this file,
or your Bookmarks for this file. To filter for any text listed in the sidebar or the overall
document, enter a string into the input field at the top of the sidebar. If you want to select
and copy text or images from the file in Okular, click the Selection icon in the toolbar
and select one of the options from the context menu. Click the Browse icon to switch
back to browsing the document. Working with Bookmarks and Annotations With
Okular, you can review a document by highlighting certain text parts or adding annota-
tions or bookmarks that Okular then attaches to the file in form of metadata. Note that
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the annotations and markers you add are not stored within the document, so you cannot
print them or pass them on to other users.

Figure 5.1 Okular Viewing a PDF File

5.2 Annotating a PDF File
With Okular, you can review a document by highlighting certain text parts or adding
annotations or bookmarks that Okular then attaches to the file in form of metadata.
Note that the annotations and markers you add are not stored within the document, so
you cannot print them or pass them on to other users.

To create an annotation for a page, press F6 and select one of the annotation tools from
the toolbar that appears. The annotation is added to the list of Reviews and is flagged
with the login name of the user who created it. Use the icons at the bottom of the sidebar
to group the annotations by page, by author or to show the annotations for the current
page only.
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Figure 5.2 Annotating a PDF File

5.3 For More Information
See the homepagehttp://okular.kde.org of Okular for more information. The
supported formats can be viewed at http://okular.kde.org/formats.php.

Viewing PDF Files and Other Documents with Okular 45

http://okular.kde.org
http://okular.kde.org/formats.php




6Viewing PDF Files with Evince
FIXME
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7Getting Started with BasKet
BasKet is a note-taking application that allows you to collect and sort all kind of data.
It helps with writing down your ideas, making to do lists, and allocating your contacts.
You can sort the data in hierarchies and share it with other people. If needed, you can
even protect some of your baskets with passwords.

7.1 Creating Baskets
A basket is a document in which you can place notes. Create baskets that include dif-
ferent topics, contents, or projects and give each its own layout.

1 To start BasKet, open a shell with Alt + F2 and enter basket.

2 To create a basket, select Basket > New > New Basket.

3 Enter a name for your basket and select a template for its column structure.

4 The basket tree on the left side shows all your baskets.

Right-click a basket in the tree and selectProperties to give it a special appearance
(background color or image and text color), change its disposition (column for-
mat), or create a shortcut for it.
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Figure 7.1 Basket in Use

NOTE: Saving your Baskets

There is no need to save your work. It is saved automatically.

To assure a clearly arranged structure, you may want to create sibling baskets or sub-
baskets as well. You can do this by selecting Basket > New > New Sub-Basket. The
sub-basket appears one level down the parent basket. By selecting Basket >New >New
Sibling-Basket you create a basket in the same level as the parent basket. In both cases
the new baskets inherit the appearance and disposition from their parent baskets.

7.2 Working with Baskets
After creating your baskets and sub-baskets, fill them with different notes. Notes can
include different types of data, for example text, images, URLs, application launchers
as well as links, e-mail addresses, files and colors.
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7.2.1 Filling and Personalizing your Baskets
To insert notes into baskets, just right-click the area on the right side and choose the
type of data you need to add. You can import screen shots or colors picked from the
screen into your baskets. For a screen shot, select Insert > Grab from screen. To select
a screen color, use Insert > Color from Screen.

You may want to assign tags to your notes to structure them. Tags are marks that repre-
sent the priority, preference, or progress of a note. Select Tags and simply check or
uncheck the tags to assign or remove them from the selected notes. Customize the
available tags by selecting Tags > Customize.

Figure 7.2 Customizing Tags

To group notes that belong together select the ones you want to group, right-click on
them and selectGroup. To break up a group of notes, make sure you selected the whole
group of notes, then right-click and select Ungroup.
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You can move a note within a group of notes by selecting Note >Move Up. If you want
to move a note from within a group of notes outside it, select Note >Move On Top.

7.2.2 Importing and Exporting Baskets
If you worked with other note-taking applications in the past and do not want to lose
the collected information, import these files to BasKet. You can import data from the
applications KNotes, KJots, and StickyNotes. To do that, right-click either in the tree
structure on the left side or directly on the basket into which you want to import the
notes and select Import.

After collecting and sorting a lot of data, you might want to share it with other people.
There are two ways to prepare your notes for sharing:

• Export a basket into HTML files by right-clicking the basket you want to export
and selecting Export > HTML Web Page.

• For others to be able to open and modify your baskets, export them into basket
archives. Right-click the basket you want to export and select Export > Basket
Archive.

7.2.3 Protecting Baskets
There might be baskets that you want to protect with a password so you are the only
person who can access them. To protect a basket using a password or private and public
keys Right-click the basket and select Password.

7.2.4 Finding Data
Once you have several baskets, finding specific data can be challenging. You have
different possibilities to find the information you are looking for very quickly even
without remembering its exact title:

• Find notes by simply typing a word or two in the filter box.

• If you are searching for notes with a certain tag assigned to them, select the desired
tag in the tag box.
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• The icon on the right applies a filter to every basket.

The numbers in the basket tree on the left indicate how many notes match your search
options. The lock icon indicates that the basket is currently locked, so has not been
searched. For more information, see Section 7.2.3, “Protecting Baskets” (page 52).

7.2.5 Creating and Restoring Backups
Basket can backup your data for you. Select Basket > Backup & Restore... to open a
dialog box. It shows you where your baskets are stored in. You can select a different
folder when you select the buttonsMove to Another Folder... or Use Another Existing
Folder..., depending on your need. Start the backup process with Backup... and give
your archive a name. A previously backup can be restored with Restore a Backup...
and select the respective archive.

7.3 For More Information
The official home page of BasKet is http://basket.kde.org/index.php.
This site offers a tour through the application, news of the latest versions, and a collection
of screen shots showing different use cases.
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8Taking Notes with Tomboy
Tomboy is a GNOME desktop application for taking notes that gives you the ability to
organize the ideas and information you deal with every day. Among other things, it can
help you collect and sort all kind of data, write down your ideas, make to do lists, and
allocate your contacts.

Tomboy also has some useful editing features to help you customize your notes, includ-
ing:

• Highlighting search text

• Inline spell checking

• Auto-linking Web and e-mail addresses

• Undo/redo support

• Font styling and sizing

• Bulleted lists

Tomboy is located on the GNOME panel ( ), and by default, is started automatically
when you log into GNOME. You can also access Tomboy by clicking Computer >
More Applications > Utilities > Tomboy Notes.

This sections contains the following information

• Section 8.1, “Creating Notes” (page 56)

Taking Notes with Tomboy 55



• Section 8.2, “Searching All Notes” (page 57)

• Section 8.3, “Linking Notes” (page 58)

• Section 8.4, “Accessing Your Notes” (page 59)

• Section 8.5, “Formatting Text in Notes” (page 59)

• Section 8.6, “Exporting Notes to HTML” (page 62)

• Section 8.7, “Deleting Notes” (page 62)

• Section 8.8, “Printing Notes” (page 62)

• Section 8.9, “Configuring Tomboy Preferences” (page 63)

8.1 Creating Notes
To create a new note, click the Tomboy Notes icon ( ) in your GNOME Panel, then
select Create New Note.

Figure 8.1 A New Tomboy Note

To edit the note, click the content area, then use the keyboard to add and remove content.
The first line of the note holds the title. By default, this is populated with the text New
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Note #. You can change the title by clicking the line and using the keyboard to change
the title. By default, focus is given to the content area upon creation of a new note, so
you can immediately start editing the note without clicking the content area. For more
information on formatting the contents of a note, see Section 8.5, “Formatting Text in
Notes” (page 59).

Your note is saved automatically.

You can then organize the notes you create by linking related notes and ideas together.
Fore more information, see Section 8.3, “Linking Notes” (page 58).

8.2 Searching All Notes
To get an overview of all your notes, click , then select Search All Notes. By default,
the Search All Notes dialog box displays your notes in the order they were last modified.
Click the Note or Last Changed column headings to change the sort order. Click the
column heading a second time to toggle between ascending and descending order.

Figure 8.2 Search All Notes Dialog Box

You can find specific notes by entering text into the Search field. The list of notes au-
tomatically updates to list only the notes that contain matching text.

To open a note listed in the Search All Notes dialog box, do any of the following:

• Double-click a note.
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• Select a note, then click File > Open.

• Right-click a note, then select Open.

• Select a note, then press Ctrl + O.

8.3 Linking Notes
You can link notes in Tomboy by highlighting text in your current note, then clicking
the Link button in the toolbar. This creates a new note and underlines the note's title in
the current note.

For example, if your current note contains the phrase “resume,” you can select this text,
then click Link to create a new note with the title “resume.” A link is also created in
the current note which you can click to open the new “resume” note.

Figure 8.3 Links in Tomboy Notes

If you change the title of a note, the links in other notes to the note whose title you
changed are automatically updated.
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Typing the name of another note in your current note automatically links that note for
you.

To see what other notes link to the current note, click Tools >What links here?

8.4 Accessing Your Notes
To access your notes, click the Tomboy icon ( ) on the GNOME panel, then select
one of the notes you recently viewed or created from the menu, or Search for older
notes (see Section 8.2, “Searching All Notes” (page 57) for more information). The
Table of Contents lists all your notes in the order they were last modified.

To force a note to always appear in the panel menu regardless of when you last accessed
it, click the thumbtack icon to the right of the note to “pin” it to the menu. Notes that
are pinned to the panel menu have a thumbtack icon that look like this: . Notes that
are not pinned to the panel menu have thumbtack icons that look like this: .

8.5 Formatting Text in Notes
You can use the Text button on the Tomboy toolbar to format text within your notes.
The Text button displays a drop-down menu with the following options:

• Undo: Allows you to revert previous changes made to your note during the
current session. To undo your last change using the keyboard, press Ctrl + Z.

• Redo: Allows you to put back changes that were removed using theUndo feature.
To redo your last change using the keyboard, press Shift + Ctrl + Z.

• Bold: To make text within your note bold, select the text you want to modify,
then select the Bold option from the Text drop-down menu. You can also press Ctrl
+ B after selecting text.

• Italic: To make text within your note italic, select the text you want to modify,
then select the Italic option from the Text drop-down menu. You can also press
Ctrl + I after selecting text.
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• Strikeout: Puts a line through the selected text. To add a strikeout, select the
text you want, then select the Strikeout option from the Text drop-down menu. You
can also press Ctrl + S after selecting text.

• Highlight: Puts a yellow background around the selected text. To add a highlight,
select the text you want, then select the Highlight option from the Text drop-down
menu. You can also press Ctrl + H after selecting text.

• Fixed Width: The fixed width style allows text to use a fixed width font. To
change existing text, select the text you want to modify, then select the FixedWidth
option from the Text drop-down menu. You can also select the Fixed Width option
from the Text drop-down menu before you start typing to have the text you type
be in a fixed width style.

• Font Size: There are four options in this part of the menu: Small,Normal, Large,
and Huge. Each of these options represents a font size you can use for the selected
text in the note. To modify the font size, select the text you want to modify, then
select one of the Font Size options from the Text drop-down menu.

• Bullets: Select the Bullets option from the Text drop-down menu to begin or
end a bulleted list. If your cursor is inside a bulleted list, the Increase Indent and
Decrease Indent options are enabled.

For more information on bullets, see Section 8.5.1, “Using Bulleted Lists” (page 61).

• Increase Indent: With the cursor on a bulleted list line, select this option to
shift the current line to the right.

• Decrease Indent: With the cursor on a bulleted list line, select this option to
shift the current line to the left.

• Find in This Note: Lets you search for text within the current note. Selecting
this option causes a Find bar to open at the bottom of the note. To open the Find
bar using the keyboard, press Ctrl + F.

Enter the text you want to find. After entering text, any matches are highlighted.
Click Find Next to highlight the next match and place the cursor there. Click Pre-
vious to move to the previous match.

Use the Case sensitive checkbox to limit the matches to ones that exactly match
the case of the search string.
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To close the find bar, click X on the far left or press the Escape key.

8.5.1 Using Bulleted Lists
• Section “Beginning a Bulleted List” (page 61)

• Section “Ending a Bulleted List” (page 61)

• Section “Increasing Indentation” (page 61)

• Section “Decreasing Indentation” (page 62)

Beginning a Bulleted List
To begin a bulleted list, use any of the following methods:

• Select Bullets from the Text drop-down menu.

• Write a line of text immediatelly after the automatically created bullet, then press
Enter.

Ending a Bulleted List
To end a bulleted list, do any of the following:

• Select Bullets from the Text drop-down menu.

• Press Enter on a blank bulleted line.

• Select Decrease Indent from the Text drop-down menu until the current line is no
longer part of the bulleted list.

• Press Shift + Tab until the current line is no longer part of the bulleted list.

Increasing Indentation
To increase the line indentation in a bulleted list, select Increase Indent from the Text
drop-down menu, or press the Tab key.
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Decreasing Indentation
To decrease the line indentation in a bulleted list, select Decrease Indent from the Text
drop-down menu, or press Shift + Tab.

8.6 Exporting Notes to HTML
You can create an HTML (Hypertext Markup Language) document from one or more
notes.

1 In the note you want to export, select the Export to HTML option from the Tools
drop-down menu.

2 Specify where to save the HTML file.

3 If you want to export any notes for which a link exists in the current note, select
Export linked notes. To export all notes for which a link exits in any of the notes,
select Include all other linked notes.

4 Click Save.

8.7 Deleting Notes
To delete a note, click the Delete button on the Tomboy toolbar. You will see a dialog
box asking if you want to permanently delete the note and its contents. Click Delete to
discard the note permanently, or click Cancel to abort the process.

Links to this note from other notes will still exist, but will re-create the note upon acti-
vation.

8.8 Printing Notes
Select the Print option on the Tools drop-down menu to print the current note. You will
be presented with the standard GNOME print dialog box.
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8.9 Configuring Tomboy Preferences
To modify preferences for Tomboy, right-click the Tomboy icon ( ) on the GNOME
panel, then select Preferences. You can configure the following:

• Section 8.9.1, “Editing Preferences” (page 63)

• Section 8.9.2, “Hotkey Preferences” (page 64)

• Section 8.9.3, “Synchronization Preferences” (page 65)

• Section 8.9.4, “Add-ins Preferences” (page 66)

8.9.1 Editing Preferences
The Editing tabbed page lets you set preferences related to editing notes.

Figure 8.4 Tomboy Editing Preferences

The Editing preferences include the following:

• Spell check while typing: Underlines misspellings in red, and provides sugges-
tions in the right-click context menu.
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• Highlight WikiWords: Creates links for phrases ThatLookLikeThis.
Clicking the link creates a new note with the title corresponding to the link text.

• Use custom font: Sets a custom font to be used in your notes. If this option is
disabled, the default system font will be used.

8.9.2 Hotkey Preferences
The Hotkeys tabbed page lets you set global key combinations to perform different
functions in Tomboy. To set key combinations, the Listen for Hotkeys checkbox must
be selected. Press Alt + H to toggle this option on or off.

Figure 8.5 Tomboy Hotkey Preferences

The Hotkey preferences include the following:

• Show notes menu: Specify the key combination to open the notes menu.

• Open “Start Here”: Specify the key combination to open the “Start Here” note,
which is preinstalled with Tomboy.

• Create new note: Specify the key combination to create a new note.

• Open “Search All Notes”: Specify the key combination to open the Search All
Notes dialog box.
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8.9.3 Synchronization Preferences
The Synchronization tabbed page lets you share notes, announce notes, receive announce-
ments, and get notes from other instances of Tomboy. This can be useful, for example,
if you want to work on a single set of notes in separate instances of Tomboy running
on your desktop and your laptop.

Figure 8.6 Tomboy Synchronization Preferences

The Synchronization preferences include the following:

• Service: Specify the location of the synchronized files. By default, you can select
a local folder or WebDAV server. To synchronize to a remote location, click the
Add-ins tab, select Synchronization > SSH Sync Service Add-in, then click Enable.
This adds an SSH (sshfs FUSE) option to the Service drop-down list.

Specify the information required for the Service you selected, then click Save.

• Advanced: Specify what happens when a conflict is detected between a local
note and a note on the configured synchronization server. You can choose to be
prompted when a conflict occurs, to rename the local note, or to replace the local
note with the note on the synchronization server.

• Clear: Clears your current synchronization settings. If you choose to clear your
synchronization settings, you might have to synchronize your notes again when
you save new settings.
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To synchronize your notes, click Tools > Synchronize Notes in any open note.

8.9.4 Add-ins Preferences
The Add-ins tabbed page lets you enable and configure Tomboy add-ins (formerly
called plugins). Tomboy comes with several pre-installed add-ins, such as Backlinks,
Bugzilla Links, Evolution Mail Integration, Export to HTML, Fixed Width, Note of
the Day, Printing Support, and Sticky Notes Importer.

The list of installed add-ins is shown on the left of the Add-ins tabbed page. To enable
or disable an add-in, select the plug-in you want, then click Enable or Disable.

Figure 8.7 Tomboy Add-ins Preferences

Additional add-ins can be found in the Tomboy Add-ins [http://live.gnome
.org/Tomboy/PluginList] page. Place new add-ins in the $HOME/.tomboy/
addins folder.

66 Application Guide

http://live.gnome.org/Tomboy/PluginList
http://live.gnome.org/Tomboy/PluginList


9Encryption with KGpg
KGpg is an important component of the encryption infrastructure on your system. This
program helps you to generate and manage all needed keys. Use its editor function for
the quick creation and encryption of files or use the applet in your panel to encrypt or
decrypt by dragging and dropping. Other programs, such as your mail program (Kontact
or Evolution), access the key data to process signed or encrypted contents. This chapter
covers the basic functions needed for daily work with encrypted files.

9.1 Why Signing and Encrypting?
Signing

Signing means attaching electronic signatures to mails or even software to prove
its correct derivation. To avoid that someone writes mails using your name and to
protect both you and the people you send them to, you should sign your mails.
Signatures help you to easily check the sender of the mails you receive and to dis-
tinguish good-natured mails from malicious.

Software developers sign their software so you are able to check its integrity. Even
if you have the software from an unofficial server, you can verify the package with
the signature.

Encrypting
You might have sensitive information you want to protect from other parties. En-
crypting helps you to transform data and make it unreadable for others. This is es-
pecially important for companies who must protect internal information as well as
the employees' privacy.
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9.2 Generating a New Key Pair
To be able to exchange encrypted messages with other users, first generate your own
key pair. One part of it—the public key—is distributed to your communication partners,
who can use it to encrypt the files or e-mail messages they send. The other part of the
key pair—the private key—is used to decrypt the encrypted contents.

IMPORTANT: Private Key versus Public Key

The public key is intended for the public and should be distributed to all your
communication partners. However, only you should have access to the private
key. Do not grant other users access to this data.

Start KGpg from the main menu or press Alt + F2 and enter kgpg. When you start the
program for the first time, an assistant appears to guide you through the configuration.
Follow the instructions up to the point where you are prompted to create a key. Enter
a name, an e-mail address, and, optionally, a comment. If you do not like the default
settings provided, also set the expiration time for the key, the key size, and the encryption
algorithm used. See Figure 9.1 .

Figure 9.1 KGpg: Creating a Key
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When you start KGpg in later sessions, only a small icon with a padlock appears in the
system tray. Click that icon to display the main KGpg window on your desktop.

Confirm your settings withOK. The next dialog prompts you to enter a password twice.
The relative strength of your chosen password is measured and displayed by the Pass-
word strength meter. The program generates the key pair and displays a summary. Save
and print this revocation certificate right away and keep it in a save place. You will
need the certificate to revoke your password if you forgot it. After you confirm with
OK, KGpg displays its main window. See Figure 9.2, “The Key Manager” (page 69).

Figure 9.2 The Key Manager

9.3 Exporting the Public Key
After generating your key pair, make the public key available to other users. This enables
them to use it to encrypt or sign the messages or files they send you. To make the public
key available for others, selectKeys > Export Public Key(s). The dialog that opens offers
four options:

Email
Your public key is sent to a recipient of your choice by e-mail. If you activate this
option and confirm with OK, the dialog for creating a new e-mail message with
KMail appears. Enter the recipient and click Send. The recipient receives your key
and can then send you encrypted contents.

Clipboard
You can place your public key here before continuing to process it.
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Default Key Server
To make your public key available to a wide audience, export it to one of the key
servers on the Internet. For more information, refer to Section 9.5, “The Key
Server Dialog” (page 71).

File
If you prefer to distribute your key as a file on a data medium instead of sending
it by e-mail, click this option, confirm or change the file path and name, and click
OK.

9.4 Importing Keys
If you receive a key in a file (for example, as an e-mail attachment), integrate it in your
key ring with Import Key and use it for encrypted communication with the sender. The
procedure is similar to the procedure for exporting keys already described.

9.4.1 Signing Keys
Keys can be signed like every other file to guarantee their authenticity and integrity. If
you are absolutely sure an imported key belongs to the individual specified as the
owner, express your trust in the authenticity of the key with your signature.

IMPORTANT: Establishing a Web of Trust

Encrypted communication is only secure to the extent that you can positively
associate public keys in circulation with the specified user. By cross-checking
and signing these keys, you contribute to the establishment of a Web of Trust.
For these reasons, make really sure you only sign keys you personally checked.

Select the key to sign in the key list. Select Keys > Sign Keys. In the following dialog,
designate the private key to use for the signature. An alert reminds you to check the
authenticity of this key before signing it. If you have performed this check, click Con-
tinue and enter the password for the selected private key in the next step. Other users
can now check the signature by means of your public key.
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9.4.2 Trusting Keys
Normally, you are asked by the corresponding program whether you trust the key, or
rather, whether you assume it is really used by its authorized owner. This happens each
time a message needs to be decrypted or a signature has to be checked. To avoid this,
edit the trust level of the newly imported key. By default, the newly imported key is
listed in a white box, meaning that no concrete value has been assigned for the trust
level. To trust a key, do the following:

1 Right-click the newly imported key to access a small context menu for the key
management.

2 Select Sign Keys. KGpg opens a dialog that asks the user to recheck the fingerprint
of the key.

3 Use Continue to access the key signing dialog.

4 Select your trust level, for example, select I Have Done Very Careful Checking.
Finish this dialog.

5 Enter your passphrase to finish the key signing process. The imported key now
appears green in the trust column.

The lower the trust level is, the less you trust the signer of the key to have checked the
true identity of the keys signed. You may be entirely sure about the signer's identity,
but he may not check other people's identities properly before signing their keys.
Therefore, you could still trust him and his own key, but assign lower trust levels to
the keys signed by him. Notice that the trust level does not trigger any automatic actions
by KGpg.

9.5 The Key Server Dialog
Several Internet-based key servers offer the public keys of many users. To engage in
encrypted communication with a large number of users, use these servers to distribute
your public key. For this purpose, export your public key to one of these servers. Simi-
larly, KGpg enables you to search one of these servers for the keys of certain people
and import their public keys from the server. Open the key server dialog with File >
Key Server Dialog.
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9.5.1 Importing a Key from a Key Server
By means of the Import tab in the key server dialog, import public keys from one of
the Internet-based key servers. Select one of the preconfigured key servers and enter a
search string (e-mail address of the communication partner) or the ID of the key to find.
When you click Search, your system connects to the Internet and searches the specified
key server for a key that matches your specifications. Refer to Figure 9.3 .

Figure 9.3 Search Screen for Importing a Key

If your search on the key server is successful, a list of all retrieved server entries is
displayed in a new window. Select the key to include in your key ring and click Import.
See Figure 9.4 . Confirm the following message withOK then exit the key server dialog
with Close. The imported key then appears in the main overview of the key manager
and is ready for use.

Figure 9.4 Hits and Import
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9.5.2 Exporting Your Keys to a Key Server
To export your key to one of the freely accessible key servers on the Internet, select
the Export tab in the key server dialog. Designate the target server and the key to export
by means of two drop-down menus. Then start the export with Export.

Figure 9.5 Exporting a Key to a Key Server

9.6 Text and File Encryption
KGpg also offers the possibility to encrypt text or clipboard contents. Right-click the
padlock icon and find the options Encrypt clipboard and Decrypt clipboard as well as
the option for opening the integrated editor.

9.6.1 Encrypting and Decrypting the
Clipboard

Files copied to the clipboard can easily be encrypted with a few clicks. Open the function
overview by right-clicking the KGpg padlock icon. Select Encrypt Clipboard and des-
ignate the key to use. A status message about the encryption procedure is displayed on
the desktop. The encrypted contents can now be processed from the clipboard as
needed. The decryption of clipboard contents is just as easy. Simply open the menu on
the panel, selectDecrypt Clipboard, and enter the password associated with your private
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key. The decrypted version is now available for processing in the clipboard and in the
KGpg editor.

9.6.2 Encrypting and Decrypting by
Dragging and Dropping

To encrypt or decrypt files, click the icons on the desktop or in the file manager, drag
them to the padlock in the panel, and drop them there. If the file is not encrypted, KGpg
asks for the key to use. As soon as you select a key, the file is encrypted without any
further messages. In the file manager, encrypted files are designated with the suffix
.asc and the padlock icon. These files can be decrypted by clicking the file icon,
dragging it to the KGpg symbol in the panel, and dropping it there. If the original file-
name already exists, a dialog opens that asks how to name the file or if it should be
overwritten.

9.6.3 The KGpg Editor
Instead of creating contents for encryption in an external editor then encrypting the file
with one of the methods described above, you can use the integrated editor of KGpg
to create the file. Open the editor (Open Editor from the context menu), enter the desired
text, and clickEncrypt. Then select the key to use and complete the encryption procedure.
To decrypt files, use Decrypt and enter the password associated with the key.

Generating and checking signatures on documents is just as easy as encrypting directly
from the editor. Select a file in the file manager and copy it to the clipboard. Right-click
the padlock icon in the panel and select Sign/Verify Clipboard. Then choose the private
key to use and enter the associated password. KGpg informs about the successful gen-
eration of the signature. Files can also be signed from the editor by simply clicking
Sign/Verify. To check a signed file, go to File > Open Editor, load the file to check in
the editor, and click Sign/Verify.
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9.7 For More Information
For theoretical background information about the encryption method, refer to the brief
and clear introduction on the GnuPG project pages at http://www.gnupg.org/
documentation/howtos.html.en. This document also provides a list of further
information sources.
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10Encryption with Passwords
and Encryption Keys
The GNOME Passwords and Encryption Keys program is an important component of
the encryption infrastructure on your system. With the help of this program, you can
create and manage PGP and SSH keys, import and export PGP and SSH keys, share
your keys with others, back up your keys and keyring, cache your passphrase, and en-
crypt and decrypt the clipboard.

Figure 10.1 Password and Encryption Keys Main Window

• Section 10.1, “Signing and Encryption” (page 78)
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• Section 10.2, “Generating a New Key Pair” (page 78)

• Section 10.3, “Modifying Key Properties” (page 81)

• Section 10.4, “Importing Keys” (page 86)

• Section 10.5, “Exporting Keys” (page 87)

• Section 10.6, “Backing Up Keyrings” (page 87)

• Section 10.7, “Signing a Key” (page 88)

• Section 10.8, “File Manager Integration” (page 89)

• Section 10.9, “Encryption Preferences” (page 90)

10.1 Signing and Encryption
Signing means attaching electronic signatures to e-mail messages or even software to
prove its correct derivation. To keep someone else from writing messages using your
name, and to protect both you and the people you send them to, you should sign your
mails. Signatures help you easily check the sender of the messages you receive and
distinguish good-natured messages from malicious messages.

Software developers sign their software so that you can check the integrity. Even if you
get the software from an unofficial server, you can verify the package with the signature.

You might also have sensitive information you want to protect from other parties. En-
cryption helps you transform data and make it unreadable for others. This is important
for companies so they can protect internal information as well as their employees' pri-
vacy.

10.2 Generating a New Key Pair
To exchange encrypted messages with other users, you must first generate your own
key pair. One part of it—the public key—is distributed to your communication partners,
who can than use it to encrypt the files or e-mail messages they send. The other part of
the key pair—the private key—is used to decrypt the encrypted contents.
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IMPORTANT

The public key is intended for the public and should be distributed to all your
communication partners. However, only you should have access to the private
key. Do not grant other users access to this data.

• Section 10.2.1, “Creating OpenPGP Keys” (page 79)

• Section 10.2.2, “Creating Secure Shell Keys” (page 80)

10.2.1 Creating OpenPGP Keys
OpenPGP is a non proprietary protocol for encrypting e-mail with the use of public key
cryptography based on PGP. It defines standard formats for encrypted messages, signa-
tures, private keys and certificates for exchanging public keys.

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Click Key > Create New Key.

3 Select PGP Key, then click Continue.

4 Specify your full name, e-mail address, and any additional information.

5 (Optional) Click Advanced key options to specify the following advanced options
for the key.

Encryption Type: Specifies the encryption algorithms used to generate your
keys. DSA ElGamal is the recommended choice because it lets you encrypt, de-
crypt, sign, and verify as needed. BothDSA (sign only) and RSA (sign only) allow
only signing.

Key Strength: Specifies the length of the key in bits. The longer the key, the
more secure it is (provided a strong passphrase is used), but keep in mind that
performing any operation with a longer key requires more time than it does with
a shorter key. Acceptable values are between 1024 and 4096 bits. At least 2048
bits is recommended.
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Expiration Date: Specifies the date at which the key will cease to be usable
for performing encryption or signing operations. You will have to either change
the expiration date or generate a new key or subkey after this amount of time
passes. Sign your new key with your old one before it expires to preserve your
trust status.

6 Click Create to create the new key pair.

The Passphrase for New PGP Key dialog box opens.

7 Specify the passphrase twice for your new key, then click OK.

When you specify a passphrase, use the same practices you use when you create
a strong password. The main difference between a password and a passphrase is
that spaces are valid characters in a passphrase.

10.2.2 Creating Secure Shell Keys
Secure Shell (SSH) is a method of logging into a remote computer to execute commands
on that machine. SSH keys are used in key-based authentication system as an alternative
to the default password authentication system. With key-based authentication, there is
no need to manually type a password to authenticate.

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Click Key > Create New Key.

3 Select Secure Shell Key, then click Continue.

4 Specify a description of what the key is to be used for.

You can use your e-mail address or any other reminder.

5 (Optional) Click Advanced key options to specify the following advanced options
for the key.

Encryption Type: Specifies the encryption algorithms used to generate your
keys. Select RSA to use the Rivest-ShamirAdleman (RSA) algorithm to create
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the SSH key. This is the preferred and more secure choice. SelectDSA to use the
Digital Signature Algorithm (DSA) to create the SSH key.

Key Strength: Specifies the length of the key in bits. The longer the key, the
more secure it is (provided a strong passphrase is used), but keep in mind that
performing any operation with a longer key requires more time than it does with
a shorter key. Acceptable values are between 1024 and 4096 bits. At least 2048
bits is recommended.

6 Click Just Create Key to create the new key, or click Create and Set Up to create
the key and set up another computer to use for authentication.

7 Specify the passphrase for your new key, click OK, then repeat.

When you specify a passphrase, use the same practices you use when you create
a strong password. The main difference between a password and a passphrase is
that spaces are valid characters in a passphrase.

10.3 Modifying Key Properties
• Section 10.3.1, “Editing OpenPGP Key Properties” (page 81)

• Section 10.3.2, “Editing Secure Shell Key Properties” (page 85)

10.3.1 Editing OpenPGP Key Properties
The descriptions in this section apply to all OpenPGP keys.

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Double-click the PGP key you want to view or edit (or select the key, then click
Key > Properties).

3 Use the options on the Owner tab to add a photo to the key or to change the
passphrase associated with the key.
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Photo IDs allow a key owner to embed one or more pictures of themselves in a
key. These identities can be signed just like normal user IDs. A photo ID must
be in JPEG format and should be no larger than 240x288 pixels.

If the chosen image does not meet the required file type or size, Passwords and
Encryption Keys can resize and convert it on the fly from any image format
supported by the GDK library.

4 Click the Names and Signatures tab to add a user ID to a key.

See Section “Adding a User ID” (page 83) for more information.

5 Click the Details tab, which contains the following properties:

Key ID: The Key ID is similar to the Fingerprint, but the Key ID contains
only the last eight characters of the fingerprint. It is generally possible to identify
a key with only the Key ID, but sometimes two keys might have the same Key
ID.

Type: Specifies the encryption algorithm used to generate a key. DSA keys
can only sign. ElGamal keys are used to encrypt.

Strength: Specifies the length, in bits, of the key. The longer the key, the
more security it provides. However, a long key will not compensate for the use
of a weak passphrase.

Fingerprint: A unique string of characters that exactly identifies a key.

Created: The date the key was created.

Expires: The date the key can no longer be used (a key can no longer be used
to perform key operations after it has expired). Changing a key's expiration date
to a point in the future re-enables it. A good general practice is to have a master
key that never expires and multiple subkeys that do expire and are signed by the
master key.

Location: The location where the private key has been stored.

Subkeys: See Section “E diting OpenPGP Subkey Properties” (page 84) for
more information.
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6 Click Close.

Adding a User ID
User IDs allow multiple identities and e-mail addresses to be used with the same key.
Adding a user ID is useful, for example, when you want to have an identity for your
job and one for your friends. They take the following form:

Name (comment) <e-mail address>

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Double-click the PGP key you want to view or edit (or select the key, then click
Key > Properties).

3 Click the Names and Signatures tab, then click Add Name.

4 Specify a name in the Full Name field.

You must enter at least five characters in this field.

5 Specify an e-mail address in the Email Address field.

Your e-mail address is how most people will locate your key on a key server or
other key provider. Make sure it is correct before continuing.

6 In the Key Comment field, specify additional information that will display in the
name of your new ID
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This information can be searched for on key servers.

7 Click Close.

E diting OpenPGP Subkey Properties
Each OpenPGP key has a single master key used to sign only. Subkeys are used to en-
crypt and to sign as well. In this way, if your sub key is compromised, you don't need
to revoke your master key.

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Double-click the PGP key you want to edit (or select the key, then click Key >
Properties).

3 Click the Details tab, then click Subkeys.

4 Use the button to on the left of the dialog box to add, delete, expire, or revoke
subkeys.

Each subkey has the following information:

ID: The identifier of the subkey.
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Type: Specifies the encryption algorithm used to generate a subkey. DSA
keys can only sign, ElGamal keys are used to encrypt, and RSA keys are used
to sign or to encrypt.

Created: Specifies the date the key was created.

Expires: Specifies the date the key can no longer be used.

Status: Specifies the status of the key.

Strength: Specifies the length, in bits, of the key. The longer the key, the
more security it provides. However, a long key will not compensate for the use
of a weak passphrase.

5 Click Close.

10.3.2 Editing Secure Shell Key Properties
The descriptions in this section apply to all SSH keys.

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Double-click the Secure Shell key you want to view or edit (or select the key,
then click Key > Properties).

3 Use the options on the Key tab to change the name of the key or the passphrase
associated with the key.

4 Click the Details tab, which contains the following properties:

Algorithm: Specifies the encryption algorithm used to generate a key.

Strength: Indicates the length in bits of a key. The longer the key, the more
security it provides. However, a long key does not make up for the use of a weak
passphrase.

Location: The location where the private key has been stored.

Fingerprint: A unique string of characters that exactly identifies a key.
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5 Click Close.

10.4 Importing Keys
To import keys:

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Click Key > Import.

3 Select a file containing at least one ASCII armored public key.

4 Click Open to import the key.

You can also paste keys inside Passwords and Encryption Keys:

1 Select an ASCII armored public block of text, then copy it to the clipboard.

2 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

3 Click Edit > Paste Keys
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10.5 Exporting Keys
To export keys:

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Select the keys you want to export.

3 Click Key > Export Public Key.

4 Specify a filename and location for the exported key.

5 Click Save to export the key.

You can also export keys to the clipboard in an ASCII armored block of text:

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Select the keys you want to export.

3 Click Edit > Copy Public Key.

10.6 Backing Up Keyrings
You can back up your public and private keyrings to an archived file.

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Click Key > Back up Key Rings.

3 Specify a filename with a valid archive extension, then specify the location to
save the archive.

You can choose any of the archive types file-roller supports.
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4 Click Save.

10.7 Signing a Key
Signing another person's key means that you are giving trust to that person. Before
signing a key, carefully check the key's fingerprint to ensure that the key really belongs
to that person.

Trust is an indication of how sure you are of a person's ability to correctly extend the
web of trust. When you are faced with a key you have not signed, the validity of that
person's key will be determined based on the signatures they have collected and how
well or not you trust the people who havemade those signatures. By default, an unknown
key will require three signatures with marginal trust value or one fully trusted signature.

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Select the key you want to sign from the Trusted Keys or Other Collected Keys
tabs.

3 Click Key > Sign.

4 Select how carefully the key has been checked, then indicate if the signature
should be local to your keyring, and if your signature can be revoked
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5 Click Sign.

10.8 File Manager Integration
Passwords and Encryption Keys integrates with the Nautilus file manager. You can
encrypt, decrypt, sign, and verify files as well as import public keys from the file
manager window without launching Passwords and Encryption Keys.

• Section 10.8.1, “Encrypting Files From Nautilus” (page 89)

• Section 10.8.2, “Signing Files From Nautilus” (page 89)

• Section 10.8.3, “Decrypting Files From Nautilus” (page 90)

• Section 10.8.4, “Verifying Signatures From Nautilus” (page 90)

10.8.1 Encrypting Files From Nautilus
1 In Nautilus, right-click the files you want to encrypt.

2 Select Encrypt.

3 Select the people (recipients) you want to encrypt the file to, then click OK.

10.8.2 Signing Files From Nautilus
1 In Nautilus, right-click the files you want to sign.

2 Select Sign.

3 Select a signer, then click OK.

4 If prompted, specify the passphrase of your private key, then click OK.
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10.8.3 Decrypting Files From Nautilus
To decrypt an encrypted file in Nautilus, simply double-click the file youwant to decrypt.

If prompted, specify the passphrase of your private key.

10.8.4 Verifying Signatures From Nautilus
To verify files, simply double-click the detached signature file. Detached signature file
names often have a .sig extension.

10.9 Encryption Preferences
• Section 10.9.1, “Encryption Settings” (page 90)

• Section 10.9.2, “Passphrase Cache” (page 91)

• Section 10.9.3, “Key Servers” (page 92)

• Section 10.9.4, “Key Sharing” (page 93)

10.9.1 Encryption Settings
1 Click Computer >More Applications > Utilities > Passwords and Encryption

Keys.

2 Click Edit > Preferences, then click the Encryption Settings tab.
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3 Choose from the following options:

Default Key: Specifies the key you want to use to sign files. Files will be
encrypted to this key if theWhen encrypting, always include myself as a recipient
option is selected.

When encrypting, always include myself as a recipient: Select this option
to add yourself to the recipients list for all files encrypted by Passwords and En-
cryption Keys. If you do not select this option, and you do not select yourself as
a recipient, you cannot decrypt any files you encrypt.

4 Click Close.

10.9.2 Passphrase Cache
Enabling Passwords and Encryption Keys's passphrase caching ability allows you to
perform many operations that require entering your passphrase without reentering it
every time seahorse-daemon takes the place of gpg-agent. Letting the cached
passphrases expire is usually a good idea. This will then require reentering your
passphrase, but adds security.

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Click Edit > Preferences, then click the Passphrase Cache tab.
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3 Choose from the following options:

Never remember passphrases: Select this option to not remember any
passphrase.

Remember passphrases for ... minutes: Specifies the amount of time, in
minutes, for storing passphrases.

Always remember passphrases whenever logged in: Select this option to
remember any passphrases whenever you are logged in to the session.

Ask me before using a cached passphrase: Select this option to ask you
before a stored passphrase is used.

Automatically load Secure Shell keys: Select this option to automatically
cache any Secure Shell key.

4 Click Close.

10.9.3 Key Servers
You can keep your keys up to date by syncing keys periodically with remote keyservers.
Syncing will make sure that you have the latest signatures made on all of your keys so
that the web of trust will be the most useful.
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1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.

2 Click Edit > Preferences, then click the Key Servers tab.

Passwords and Encryption Keys provides support for HKP and LDAP keyservers.

HKP Servers: HKP keyservers are ordinary Web-based keyservers such as
the popular hkp://pgp.mit.edu:11371, also accessible at http://pgp.mit
.edu.

LDAPKeyservers: LDAP keyservers are less common, but use the standard
LDAP protocol to serve keys. ldap://keyserver.pgp.com is a good LDAP server.

3 Click Close.

10.9.4 Key Sharing
Key Sharing is provided by DNS-SD, also known as Bonjour or Rendevous. Enabling
key sharing adds the local Passwords and Encryption Keys users' public key rings to
the remote search dialog box. Using these local key servers is generally faster than ac-
cessing remote servers.

1 Click Computer >More Applications > Utilities > Passwords and Encryption
Keys.
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2 Click Edit > Preferences, then click the Key Sharing tab.

3 Select Share my keys with others on my network.

4 Click Close.
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11Kontact: E-Mailing and
Calendaring
Kontact combines the functionality of a number of KDE applications into a convenient,
single interface for personal informationmanagement. These applications include KMail
for e-mail, KOrganizer for the calendar, KAddressBook for contacts, KNode for
newsgroups, and KNotes for notes. Kontact integrates easily with the rest of the KDE
desktop and connects to a variety of groupware servers. It includes extra features, such
as journal entries, Spam and virus filtering, and an RSS reader.

Start Kontact from the main menu. Alternatively, press Alt + F2 and enter kontact .
You can also open the individual components instead of the combined application if
you only need partial functionality.

11.1 Kontact Overview
The default window view is shown in Figure 11.1, “The Kontact Summary View”
(page 98). Use the icons in the left section to access the different components. The
Summary provides basic information, including upcoming birthdays and to-dos and the
number of new mail messages. The news section can access RSS feeds to provide up-
dated news of interest to you. Use Settings > Configure Summary View to configure
the information displayed.
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Figure 11.1 The Kontact Summary View

Mail
The folder area to the left contains a list of your mail folders (mail boxes) indicating
the total number of messages and how many are still unread. To select a folder,
simply click it. The messages in that folder appear in the top right frame. The
number of messages in that folder is also shown in the status bar at the bottom of
the application window.

The subject, sender, and time of receipt of each message are listed in the header
area to the right. Click a message to select it and display it in the message window.
Sort the messages by clicking one of the column headers (subject, sender, date,
etc.). The contents of the currently selected message are displayed in the message
frame of the window. Attachments are depicted as icons at the end of the message,
based on the MIME type of the attachment, or they can be displayed inline.

Contacts
The upper left frame of this component shows all addresses in the currently activated
address books. The lower left frame lists your address books and shows whether
each one is currently active. The right frame shows the currently selected contact.
Use the search bar at the top to find a particular contact.
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Calendar
The calendar view is divided into a number of frames. By default, view a small
calendar of this month and a week view of the current week. Also find a list of to-
dos, a detailed view of the current event or to-do, and a list of calendars with the
status of each. Select a different view from the toolbar or the View menu.

To-Do List
To-do List shows your list of tasks. Click the field at the top to add a new item to
the list. Right-click in a column of an existing item to make changes to the value
in that column. An item can be broken into several subitems. Right-click and select
New Sub-to-do to create a subitem. You can also assign to-dos to other people.

Journal
The Journal provides a place for your reflections, occurrences, or experiences.
Choose a date in the calendar frame and click Add Journal Entry to add a new entry.
If a journal entry already exists for the chosen date, edit it in the right frame.

Notes
Use the Notes component to keep sticky notes to yourself. If you are using KDE,
use the KNotes icon in the system tray to make your notes visible on the desktop.

Feeds
The Feeds window is divided into three frames—a tree view with RSS feeds on
the left, an article list on the top right, and the article view on the bottom right side.
Click a feed in the tree view to display it. Right-click a feed to update, edit, or
delete it. Right-click a folder in the tree view to open a menu where you can add a
new feed or manipulate existing feeds within this folder.

11.2 Mail
Kontact uses KMail as its e-mail component. You can also start it separately with the
command kmail. To configure it, open the mail component then select Settings >
Configure KMail. KMail is a fully-featured e-mail client that supports a number of
protocols.
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Figure 11.2 The Kontact Mail Component

11.2.1 Configuring Identities
KMail can manage multiple e-mail accounts, such as your private e-mail and your
business ones. Creating separate identities for your different e-mail accounts allows
you to associate different sender addresses, cryptography settings and signatures with
each of them. To create an identity, select Settings > Configure KMail and choose
Identities > Add. Determine whether to create a new identity from scratch, use the user
settings from Personal Settings > Password & User Account, or whether to duplicate
an existing identity.

To create a new identity from scratch, enter the name of the new identity and enter your
name, organization and e-mail address in the General tab. Optionally, configure one
or several of the following options:
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Cryptography
Set the keys to use for signing and encrypting messages. For the encryption to
work, first create a key with KGpg, as described in Chapter 9, Encryption with
KGpg (page 67).

Advanced
Enter a default reply-to and a default blind carbon-copy address, choose a dictionary,
select the folders for draft, sent messages, and templates, and define by which
sending account the messages should be sent.

Templates
Define templates to use for new messages, for default replies to senders and lists,
and for forwarded messages. To use templates activate Use Custom Message
Templates, first.

Signature
Click Enable Signature first to use it. Decide how your messages should be signed.
Use the input field below to configure your signature or obtain it from a file or the
output of a command.

Picture
Use this tab to include a picture in the X-Face format in your messages. X-Face
can only hold black and white images with a dimension of 48 × 48 pixels. You can
obtain the picture from an external source or of the input field below.

11.2.2 Creating Accounts
Before you can send or receive e-mails, create one or several accounts. The settings
underAccounts determine howKontact receives and sends e-mail.Many of these settings
vary depending on the system and network in which your mail server is located. If you
are not sure about the settings or items to select, consult your ISP or system administra-
tor.

1 Start Kontact and select Settings > Configure KMail > Accounts.

2 Create an incoming account by clicking on the Receiving tab:

2a Click Add and choose the account type. The following dialog box shows
only the respective entries of your selected type.

Kontact: E-Mailing and Calendaring 101



2b If you have selected POP3, IMAP or disconnected IMAP, enter username,
password and hostname. Depending on the chosen account type, configure
additional parameters such as the mail checking interval, the hiding folders,
security settings, and others.

2c If you selected local mailbox or maildir mailbox, enter the folder location.

2d Proceed with OK.

3 Create an outgoing account by clicking on the Sending tab and click Add to
choose either SMTP or Sendmail:

• If you select SMTP, enter an account name, the host name of the SMTP
server. Should the server require login and password, also check Server re-
quires authentication and enter the required credentials. Optionally, configure
additional security settings using the Security tab.

• If you select Sendmail, no further configuration efforts are required.

4 Apply your settings and leave the account configuration dialog with OK.

11.2.3 Composing Messages
To compose new messages, selectMessage > New Message or click the corresponding
icon in the toolbar. To send messages from different e-mail accounts, select one of the
identities as described in Section 11.2.1, “Configuring Identities” (page 100). Select
View > Identity to show a popup menu. In To, enter an e-mail address or part of a name
or address in your address book. If Kontact can match what you enter to something in
the address book, a selection list opens. Click the desired contact or complete your input
if none matches. To select directly from the address book, click the Select... button next
to the Address field.

To attach files to your message, click the paper clip icon and select the file to attach.
Alternatively, drag a file from the desktop or another folder to theNewMessagewindow
or select one of the options in the Attachmenu. Normally, the format of a file is recog-
nized correctly. If the format is not recognized, right-click the icon. From the menu
that appears, select Properties. Set the format and filename in the next dialog and add
a description. In addition, decide whether the attached file should be signed or encrypted.
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When you are finished composing your message, send it immediately withMessage >
Send or move it to the outbox withMessage > Send Later. If you send the e-mail, the
message is copied to sent-mail after having been sent successfully. Messages moved
to the outbox can be edited or deleted.

11.2.4 Managing Folders
Message folders help organize your messages. By default, they are located in the ~/
.kde/share/apps/kmail/mail directory. When starting KMail for the first
time, the program creates several folders. If you are using IMAP, the IMAP folders are
listed below the local folders. Each incoming mail server has its folders in the Folder
list.

If you want to organize your messages in additional folders, create new folders by se-
lecting Folder > New Folder. This opens a window in which to specify the name and
format of the new folder.

Right-click the folder for a context menu offering several folder operations. Click Expire
to specify the expiration date for read and unread messages, what should happen with
them after expiration, and whether expired messages should be deleted or moved to a
folder. If you intend to use the folder to store messages from a mailing list, set the
necessary options under Folder >Mailing List Management.

To move one or several messages from one folder to another, drag them from the upper
window and drop them into the appropriate folder in the left window. Messages can
also be moved by highlighting the messages then pressing M or selectingMessage >
Move to. In the list of folders that appears, select the folder to which to move your
messages.

Additionally, you can add folders to the Favorite Folders pane. This enables you to go
quickly to your frequently used mail folders, especially if your folders are deeply
structured. Choose the respective folder and select Add to Favorite Folders.

11.2.5 Signing and Encrypting E-Mails
E-mail is an insecure medium as anyone could theoretically read your e-mails or send
some in your name. By signing your e-mails you enable the recipient of your e-mails
to verify the sender of the messages as the key used to sign is only available to you. By
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encrypting the contents of your e-mails make sure that they can only be read by the
recipient. KMail supports both the signing and encryption of e-mails.

Set up KMail for signing and encrypting e-mails:

1 Generate a key pair as described in Section 9.2, “Generating a New Key Pair”
(page 68) and export your public key as described in Section 9.3, “Exporting
the Public Key” (page 69).

2 Configure the details of the encryption procedure in KMail:

2a Start KMail and go to Settings > Configure KMail > Identities.

2b Select the identity under which to send encrypted and signedmessages. Click
Modify... and proceed to Cryptography.

2c Change the OpenPGP signing key by clicking on Change... and selecting
your key from the dialog box.

2d Change theOpenPGP encryption key by clicking onChange... and selecting
your key from the dialog box.

3 Apply your settings and leave the configuration dialog with OK.

Sending Signed Mails
Sign your e-mails to allow the recipient to verify whether these have really been sent
by you. KMail uses your private key to sign your messages and the recipient can verify
the signature using your public key available on key servers. To sign an e-mail, proceed
as follows:

1 Compose your e-mail as usual.

2 Select Options > Sign Message.

3 Select Attach > Attach My Public Key to create an attachment to your e-mail
containing your public key.

4 Send your message as usual viaMessage > Send Mail and enter your key's
passphrase when prompted. KMail signs your message using your private key
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and the recipient can verify the signature by the public key attached to your
message.

Sending Encrypted Mails
Use encryption on your e-mails whenever you want to make sure that only the recipient
can read the contents. To be able to exchange encrypted e-mails with another party, get
the appropriate public key and use it to encrypt your message. At the other end, the
private key is then used to decrypt the contents of your message. Of course, you can
use both signatures and encryption on your messages.

To send an encrypted e-mail, proceed as follows:

1 Start KGpg with Alt + F2 and entering kgpg.

2 Get the recipient's public key:

• If you get it directly from the recipient, import the key with KGpg via Keys
> Import Key.

• Access a public key server and import it from there. Select in KGpg File >
Key Server Dialog, and search for the key. Select the respective key and
import it into your keyring.

3 Compose a new message.

4 Select Options > Encrypt Message. If you want additionally sign it with your
key, select the respective menu entry.

5 Send the mail.

6 Check whether all keys are correct.

7 Enter your passphrase.
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11.2.6 Importing E-Mail from Other Mail
Programs

To import e-mail from other applications, select File > Import Messages from the mail
view in Kontact. It currently features import filters for Outlook Express, the mbox for-
mat, e-mail text format, Pegasus Mail, Opera, Evolution, and more. The import utility
can also be started separately with the command kmailcvt.

Select the corresponding application and confirmwithContinue. A file or a folder must
be provided, depending on the selected type. KMail then completes the process.

11.2.7 Filters
Filters are a convenient method of automatically processing incoming mail. They use
aspects of the mail, such as sender or size, to move mail to certain folders, delete un-
wanted mails, bounce mails back to the sender, or perform a number of other actions.

Setting Up a Filter
To create a filter based on an existing message, right-click the desired message then
select Create Filter and the desired filter criteria. To create a filter from scratch, select
Settings > Configure Filters.

Select the match method for filter criteria (all or any). Then select criteria that applies
only to the desired messages. In Filter Actions, set what the filter should do to the
messages that meet the criteria. The Advanced tab provides control over whether the
filter is applied for specific accounts only.

Applying Filters
Filters are applied in the order listed in the dialog accessed with Settings > Configure
Filters. Change the order by selecting a filter and clicking the arrow buttons. Filters
are only applied to new incoming messages or sent messages as specified in the filter's
advanced options. To apply filters to existing messages, right-click the desired messages
and chooseMessages > Apply Filter and the desired filter.
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If your filters do not act as expected, monitor them with Tools > Filter Log Viewer.
When logging is enabled in this dialog, it shows how messages are processed by your
filters and can help locate the problem.

11.3 Contacts
The contacts component uses KAddressBook. You can also start it separately with the
command kaddressbook. Configure it with Settings > Configure KAddressBook.
To search for a particular contact, use the search bar. With Filter, select to display only
contacts in a certain category. Right-click a contact to open a menu in which to select
from a variety of options, such as sending the contact information in an e-mail.

Figure 11.3 The Kontact Address Book

11.3.1 Adding Contacts
To add a contact with the name and e-mail address from an e-mail, right-click the address
in the mail component and select Open in Address Book. To add a new contact without
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using an e-mail, select File > New Contact in the address component. Both methods
open a dialog in which to enter information about the contact.

In the General tab, enter basic contact information, such as name, e-mail addresses,
and telephone numbers. Categories can be used to sort addresses.Details contains more
specific information, such as birthday and spouse's name.

If your contact uses an instant messenger, you can add these identities in IM Addresses.
If you do this and have Kopete or another KDE chat program running at the same time
as Kontact, view status information about these identities in Kontact. InCrypto Settings,
enter the contact's encryption data, such as public key.

Misc has additional information, such as a photograph and the location of the user's
Free/Busy information. Use Custom Fields to add your own information to the contact
or address book.

Contacts can also be imported in a variety of formats. Use File > Import and select the
desired format. Then select the file to import.

11.3.2 Creating a Distribution List
If you frequently send e-mail messages to the same group of people, a distribution list
enables you to store multiple e-mail addresses as a single contact item so that you do
not need to enter each name individually in every e-mail you send to that group. To
create a distribution list, proceed as follows:

1 Click Settings > Show Extension Bar > Distribution List Editor. A new section
appears.

2 Click New List.

3 Enter a name for the list and click OK.

4 Add contacts to the list by dragging them from the address list and dropping them
in the distribution list window.

5 Use this list like you would an individual contact when creating an e-mail.
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11.3.3 Adding Address Books
IMPORTANT: Groupware Address Books

The best way to add groupware resources is with the Groupware Wizard, a
separate tool. To use it, close Kontact then run groupwarewizard in a
command line or from the Office group of the KDE menu. Select the server
type, such as SLOX, GroupWise, or Exchange, from the list offered then enter
the address and authentication data. The wizard then adds the available re-
sources to Kontact.

Kontact can access multiple address books, such as shared ones offered by Novell
GroupWise or an LDAP server. Select View > Address Books to view the current address
books. Press Add to add one then select the type and enter the required information.

The check boxes in front of the address books show the activation status of each address
book. To prevent the display of a book without deleting it, uncheck it. Remove deletes
the selected book from the list.

11.4 Calendar
Kontact uses KOrganizer as its calendar component. You can also start it separately
with the command korganizer. To configure it, use Settings > Configure Calendar.
With the calendar, enter appointments and schedule meetings with others. If desired,
you can be reminded of upcoming events. You can also import, export, and archive
calendars with the options in File.
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Figure 11.4 The Kontact Calendar

11.4.1 Scheduling an Event
Add a new event or meeting with Actions >New Event. Enter the desired details. Under
Reminder, specify the exact time (minutes, hours, or days in advance) when the attendees
should be reminded of the event. If an event recurs, specify the appropriate interval.
Another way to create an event at a specific point in the calendar is to double-click the
corresponding field in one of the program's calendar views. This opens the same dialog
window as that available from the menu. Alternatively, select a time range in the Cal-
endar view and right-click.

Specify the attendees of an event by entering their data manually in the dialog or by
inserting data from the address book. To enter data manually, select New. To import
data from the address book, click Select Addressee then select the corresponding entries
from the dialog. To schedule the event based on the participants' availability, go to
Free/Busy and click Pick Date.

Use the Recurrence tab to configure an event that happens on a regular basis. Attach-
ments can be convenient for linking other information with the event, such as an agenda
for a meeting.
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11.4.2 Adding Calendars
IMPORTANT: Groupware Calendars

The best way to add groupware resources is with Groupware Wizard, a separate
tool. To use it, close Kontact then run groupwarewizard in a command line
or from the Office group of the KDE menu. Select the server type, such as
SLOX, GroupWise, or Exchange, from the list offered then enter the address
and authentication data. The wizard adds the available resources to Kontact.

The calendar module can connect to multiple calendars simultaneously. This is useful,
for example, to combine a personal calendar with an organizational one. To add a new
calendar, click Add then select the calendar type. Complete the necessary fields.

The check boxes in front of the calendars show the activation status of each. To prevent
the display of a calendar without deleting it, uncheck it. Remove deletes the selected
calendar from the list.

11.5 For More Information
Kontact includes help for itself and its various components. Access it with Help >
Kontact Handbook. The project's Web page, http://www.kontact.org, is also
informative.
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12Evolution: E-Mail and
Calendaring
Evolution™makes the tasks of storing, organizing, and retrieving your personal infor-
mation easy, so you can work and communicate more effectively with others. It’s a
highly evolved groupware program, an integral part of the Internet-connected desktop.

Evolution can help you work in a group by handling e-mail, address, and other contact
information, and one or more calendars. It can do that on one or several computers,
connected directly or over a network, for one person or for large groups.

With Evolution, you can accomplish your most common daily tasks quickly. For exam-
ple, it takes only one or two clicks to enter appointment or contact information sent to
you by e-mail, or to send e-mail to a contact or appointment. People who get lots of e-
mail will appreciate advanced features like search folders, which let you save searches
as though they were ordinary e-mail folders.

This chapter introduces you to Evolution and helps you get started using it. For complete
information, refer to the Evolution documentation.

• Section 12.1, “Starting Evolution for the First Time” (page 114)

• Section 12.2, “Using Evolution: An Overview” (page 125)
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12.1 Starting Evolution for the First
Time

Start the Evolution client by clickingComputer > Evolution, or by typing evolution
in a terminal window.

12.1.1 Using the Setup Assistant
The first time you run Evolution, it creates a directory called .evolution in your
home directory, where it stores all of its local data. Then, it opens a Setup Assistant to
help you set up e-mail accounts and import data from other applications.

Using the Setup Assistant takes two to five minutes.

Later on, if you want to change this account, or if you want to create a new one, click
Edit > Preferences, then clickMail Accounts. Select the account you want to change,
then click Edit. Alternately, add a new account by clicking Add.

The Setup Assistant helps you provide the information Evolution needs to get started.

• Section “Defining Your Identity” (page 114)

• Section “Receiving Mail” (page 115)

• Section “Receiving Mail Options” (page 118)

• Section “Sending Mail” (page 123)

• Section “Account Management” (page 124)

• Section “Time Zone” (page 124)

• Section “Importing Mail (Optional)” (page 125)

Defining Your Identity
The Identity window is the first step in the assistant.
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Here, you enter some basic personal information. You can define multiple identities
later by clicking Edit > Preferences, then clickingMail Accounts.

When the First-Run Assistant starts, the Welcome page is displayed. Click Forward to
proceed to the Identity window.

1 Type your full name in the Full Name field.

2 Type your e-mail address in the E-Mail Address field.

3 (Optional) Select if this account is your default account.

4 (Optional) Type a reply to address in the Reply-To field.

Use this field if you want replies to e-mails sent to a different address.

5 (Optional) Type your organization name in the Organization field.

This is the company where you work, or the organization you represent when
you send e-mail.

6 Click Forward.

Receiving Mail
The Receiving E-mail option lets you determine where you get your e-mail.

You need to specify the type of server you want to receive mail with. If you are unsure
about the type of server to choose, ask your system administrator or ISP.

• Select a server type in the Server Type list.

The following a list of server types that are available:

Novell GroupWise: Select this option if you connect to Novell®GroupWise®.
Novell GroupWise keeps e-mail, calendar, and contact information on the server.

Microsoft Exchange: Available only if you have installed the Connector for
Microsoft* Exchange. It allows you to connect to a Microsoft Exchange 2000
or 2003 server, which stores e-mail, calendar, and contact information on the
server.
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IMAP: Keeps the e-mail on your server so you can access your e-mail from
multiple systems.

IMAP4rev1: Keeps the e-mail on your server so you can access your e-mail
from multiple systems.

POP: Downloads your e-mail to your hard disk for permanent storage, freeing
up space on the e-mail server.

USENETNews: Connects to the news server and downloads a list of available
news digests.

Local Delivery: Choose this option if you want to move e-mail from the spool
(the location where mail waits for delivery) and store it in your home directory.
You need to provide the path to the mail spool you want to use. If you want to
leave e-mail in your system’s spool files, choose the Standard Unix Mbox Spool
option instead.

MH Format Mail Directories: If you download your e-mail using mh or
another MH-style program, you should use this option. You need to provide the
path to the mail directory you want to use.

Maildir FormatMail Directories: If you download your e-mail using Qmail
or another maildir-style program, you should use this option. You need to provide
the path to the mail directory you want to use.

Standard Unix Mbox Spool or Directory: If you want to read and store e-
mail in the mail spool on your local system, choose this option. You need to
provide the path to the mail spool you want to use.

None: Select this if you do not plan to check e-mail with this account. If you
select this, there are no configuration options.

Remote Configuration Options

If you selected Novell GroupWise, IMAP, POP, or USENET News as your server, you
need to specify additional information.

1 Type the hostname of your e-mail server in the Hostname field.

If you don’t know the hostname, contact your administrator.
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2 Type your username for the account in the Username field.

3 Select to use a secure (SSL) connection.

If your server supports secure connections, you should enable this security option.
If you are unsure if your server supports a secure connection, contact your system
administrator.

4 Select your authentication type in the Authentication list.

or

Click Check for Supported Types to have Evolution check for supported types.
Some servers do not announce the authentication mechanisms they support, so
clicking this button is not a guarantee that available mechanisms actually work.

If you are unsure what authentication type you need, contact your system admin-
istrator.

5 Select if you want Evolution to remember your password.

6 Click Forward.

7 (Conditional) If you chose Microsoft Exchange, provide your username in the
Username field and your Outlook Web Access (OWA) URL in the OWA Url
field. OWA URL and user names should be entered as in OWA. If the mail box
path is different from the username, OWA path should include mail box path
also. You should see something similar to this: http://<server name>/ex-
change/<mail box path>

When you have finished, continue with Section “Receiving Mail Options” (page 118).

Local Configuration Options

If you selected Local Delivery, MH-Format Mail Directories, Maildir-Format Mail
Directories, or Standard Unix Mbox Spool or Directory, you must specify the path to
the local files in the path field. Continue with Section “Receiving Mail Options”
(page 118).
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Receiving Mail Options
After you have selected a mail delivery mechanism, you can set some preferences for
its behavior.

• Section “Novell GroupWise Receiving Options” (page 118)

• Section “Microsoft Exchange Receiving Options” (page 119)

• Section “IMAP and IMAP4rev1 Receiving Options” (page 120)

• Section “POP Receiving Options” (page 121)

• Section “USENET News Receiving Options” (page 121)

• Section “Local Delivery Receiving Options” (page 122)

• Section “MH-Format Mail Directories Receiving Options” (page 122)

• Section “Maildir-Format Mail Directories Receiving Options” (page 122)

• Section “Standard Unix Mbox Spool or Directory Receiving Options” (page 123)

Novell GroupWise Receiving Options

If you select Novell GroupWise as your receiving server type, you need to specify the
following options:

1 Select if you want Evolution to automatically check for new mail.

If you select this option, you need to specify how often Evolution should check
for new messages.

2 Select if you want to check for new messages in all folders.

3 Select if you want to apply filters to new messages in the Inbox on the server.

4 Select if you want to check new messages for junk content.

5 Select if you want to only check for junk messages in the Inbox folder.
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6 Select if you want to automatically synchronize remote mail locally.

7 Type your Post Office Agent SOAP port in the Post Office Agent SOAP Port
field.

If you are unsure what your Post Office Agent SOAP port is, contact your system
administrator.

8 Click Forward.

When you have finished, continue with Section “Sending Mail” (page 123).

Microsoft Exchange Receiving Options

If you select Microsoft Exchange as your receiving server type, you need to specify the
following options.

1 Select if you want Evolution to automatically check for new mail.

If you select this option, you need to specify how often Evolution should check
for new messages.

2 Specify the Global Catalog server name in theGlobal Catalog Server Name field.

The Global Catalog Server contains the user information for users. If you are
unsure what your Global Catalog server name is, contact your system adminis-
trator.

3 Select if you want to limit the number of Global Address Lists (GAL).

The GAL contains a list of all e-mail addresses. If you select this option, you
need to specify the maximum number of responses.

4 Select if you want the password expire warning period.

If you select this option, you need to specify how often Evolution should send
the password expire message.

5 Select if you want to automatically synchronize remote mail locally.

6 Click Forward.
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When you have finished, continue with Section “Sending Mail” (page 123).

IMAP and IMAP4rev1 Receiving Options

If you select IMAP or IMAP4rev1 as your receiving server type, you need to specify
the following options:

1 Select if you want Evolution to automatically check for new mail.

If you select this option, you need to specify how often Evolution should check
for new messages.

2 Select if you want Evolution to use custom commands to connect to Evolution.

If you select this option, specify the custom command you want Evolution to
use.

3 Select if you want Evolution to show only subscribed folders.

Subscribed folders are folders that you have chosen to receive mail from by
subscribing to them.

4 Select if you want Evolution to override server-supplied folder namespaces.

By choosing this option you can rename the folders that the server provides. If
you select this option, you need to specify the namespace to use.

5 Select if you want to apply filters to new messages in the Inbox.

6 Select if you want to check new messages for junk content.

7 Select if you want to check for junk messages in the Inbox folder.

8 Select if you want to automatically synchronize remote mail locally.

9 Click Forward.

When you have finished, continue with Section “Sending Mail” (page 123).
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POP Receiving Options

If you select POP as your receiving server type, you need to specify the following op-
tions:

1 Select if you want Evolution to automatically check for new mail.If you select
this option, you need to specify how often Evolution should check for new mes-
sages.

2 Select if you want to leave messages on the server.

3 Select if you want to disable support for all POP3 extensions (support for POP3).

4 Click Forward.

When you have finished, continue with Section “Sending Mail” (page 123).

USENET News Receiving Options

If you select USENET News as your receiving server type, you need to specify the
following options:

1 Select if you want Evolution to automatically check for new mail.If you select
this option, you need to specify how often Evolution should check for new mes-
sages.

2 Select if you want to show folders in short notation.

For example, comp.os.linux would appear as c.o.linux.

3 Select if you want to show relative folder names in the subscription dialog box.

If you select to show relative folder names in the subscription page, only the
name of the folder is displayed. For example the folder evolution.mail would
appear as evolution.

4 Click Forward.

When you have finished, continue with Section “Sending Mail” (page 123).
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Local Delivery Receiving Options

If you select Local Delivery as your receiving server type, you need to specify the fol-
lowing options:

1 Select if you want Evolution to automatically check for new mail.If you select
this option, you need to specify how often Evolution should check for new mes-
sages.

2 Click Forward.

When you have finished, continue with Section “Sending Mail” (page 123).

MH-Format Mail Directories Receiving Options

If you select MH-Format Mail Directories as your receiving server type, you need to
specify the following options:

1 Select if you want Evolution to automatically check for new mail.If you select
this option, you need to specify how often Evolution should check for new mes-
sages.

2 Select if you want to user the .folders summary file.

3 Click Forward.

When you have finished, continue with Section “Sending Mail” (page 123).

Maildir-Format Mail Directories Receiving Options

If you select Maildir-Format Mail Directories as your receiving server type, you need
to specify the following options:

1 Select if you want Evolution to automatically check for new mail.If you select
this option, you need to specify how often Evolution should check for new mes-
sages.

2 Select if you want to apply filters to new messages in the Inbox.

3 Click Forward.
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When you have finished, continue with Section “Sending Mail” (page 123).

Standard Unix Mbox Spool or Directory Receiving Options

If you select Standard Unix Mbox Spool or Directory as your receiving server type,
you need to specify the following options:

1 Select if you want Evolution to automatically check for new mail.If you select
this option, you need to specify how often Evolution should check for new mes-
sages.

2 Select if you want to apply filters to new messages in the Inbox.

3 Select if you want to store status headers in Elm, Pine, and Mutt formats.

4 Click Forward.

When you have finished, continue with Section “Sending Mail” (page 123) Section
“Sending Mail” (page 123).

Sending Mail
Now that you have entered information about how you plan to get mail, Evolution needs
to know about how you want to send it.

• Select a server type from the Server Type list.

The following server types are available:

Sendmail: Uses the Sendmail program to send mail from your system.
Sendmail is more flexible, but is not as easy to configure, so you should select
this option only if you know how to set up a Sendmail service.

SMTP: Sends mail using an outbound mail server. This is the most common
choice for sending mail. If you choose SMTP, there are additional configuration
options.

SMTP Configuration

1 Type the host address in the Host field.
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If you are unsure what your host address is, contact your system administrator.

2 Select if your server requires authentication.

If you selected that your server requires authentication, you need to provide the
following information:

2a Select your authentication type in the Authentication list.

or

Click Check for Supported Types to have Evolution check for supported
types. Some servers do not announce the authentication mechanisms they
support, so clicking this button is not a guarantee that available mechanisms
actually work.

2b Type your username in the Username field.

2c Select if you want Evolution to remember your password.

3 Select if you use a secure connection (SSL).

4 Click Forward.

Continue with Section “Account Management” (page 124).

Account Management
Now that you have finished the e-mail configuration process you need to give the account
a name. The name can be any name you prefer. Type your account name on the Name
field, then click Forward.

Continue with Section “Time Zone” (page 124).

Time Zone
In this step, you need to select your time zone either on the map or select from the time
zone drop-down list.
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When you have finished, click Forward, then click Apply. Evolution opens with your
new account created.

If youwant to import e-mail from another e-mail client, continuewith Section “Importing
Mail (Optional)” (page 125). If not, skip to Section 12.2, “Using Evolution: An
Overview” (page 125).

Importing Mail (Optional)
If Evolution finds e-mail or address files from another application, it offers to import
them.

Microsoft Outlook* and versions of Outlook Express after version 4, use proprietary
formats that Evolution cannot read or import. To import information, you might want
to use the Export tool under Windows*.

Before importing e-mail from Netscape*, make sure you have selected File > Compact
All Folders. If you don’t, Evolution will import and undelete the messages in your Trash
folders.

NOTE

Evolution uses standard file types for e-mail and calendar information, so you
can copy those files from your ~/.evolution directory. The file formats
used are mbox for e-mail and iCal for calendar information.

Contacts files are stored in a database, but can be saved as a standard vCard*.
To export contact data, open your contacts tool and select the contacts you
want to export (press Ctrl+A to select them all). Click File > Save as VCard.

12.2 Using Evolution: An Overview
Now that the first-run configuration has finished, you’re ready to begin using Evolution.
Here’s a quick explanation of what’s happening in your main Evolution window.
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Figure 12.1 Evolution Window

Menu Bar
The menu bar gives you access to nearly all of Evolution features.

Folder List
The folder list gives you a list of the available folders for each account. To see the
contents of a folder, click the folder name and the contents are displayed in the e-mail
list.

Toolbar
The toolbar gives you fast and easy access to the frequently used features in each
component.
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Search Tool
The search tool lets you search your e-mail, contacts, calendar, and tasks to easily find
what you’re looking for.

Message List
The message list displays a list of e-mail that you have received. To view an e-mail in
the preview pane, click the e-mail in the e-mail list.

Shortcut Buttons
The shortcut bar lets you switch between folders and between Evolution tools. At the
bottom of the shortcut bar there are buttons that let you switch tools, and above that is
a list of all the available folders for the current tool. If you have the Evolution Connector
for Microsoft Exchange installed, you have an Exchange button in addition to buttons
for the other tools.

Status Bar
The status bar periodically displays a message, or tells you the progress of a task. This
most often happens when you’re checking or sending e-mail. These progress queues
are shown in the previous figure. The Online/Offline indicator is here, too, in the lower
left of the window.

Preview Pane
The preview pane displays the contents of the e-mail that is selected in the e-mail list.

12.2.1 The Menu Bar
The menu bar’s contents always provide all the possible actions for any given view of
your data. If you’re looking at your Inbox, most of the menu items relate to e-mail.
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Some content relates to other components of Evolution and some, especially those in
the File menu, relates to the application as a whole.

File: Anything related to a file or to the operations of the application usually falls
under this menu, such as creating things, saving them to disk, printing them, and quitting
the program itself.

Edit: Holds useful tools that help you edit text and move it around. Lets you access
the settings and configuration options in the Edit menu.

View: Lets you decide how Evolution should look. Some of the features control the
appearance of Evolution as a whole, and others the way a particular kind of information
appears.

Folder: Holds actions that can be performed on folders. You can find things like
copy, rename, delete, and so on.

Message: Holds actions that can be applied to a message. If there is only one target
for the action, such as replying to a message, you can normally find it in the Message
menu.

Search: Lets you search for messages, or for phrases within a message. You can
also see previous searches you have made. In addition to the Search menu, there is a
text entry box in the toolbar that you can use to search for messages. You can also
create a search folder from a search.

Help: Opens the Evolution Help files.

12.2.2 The Shortcut Bar
Evolution’s most important job is to give you access to your information and help you
use it quickly. One way it does that is through the shortcut bar, which is the column on
the left side of the main window. The buttons, such as Mail and Contacts, are the
shortcuts. Above them is a list of folders for the current Evolution tool.

The folder list organizes your e-mail, calendars, contact lists, and task lists in a tree,
similar to a file tree. Most people find one to four folders at the base of the tree, depend-
ing on the tool and their system configuration. Each Evolution tool has at least one,
called On This Computer, for local information. For example, the folder list for the e-
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mail tool shows any remote e-mail storage you have set up, plus local folders and search
folders.

If you get large amounts of e-mail, you might want more folders than just your Inbox.
You can create multiple calendar, task, or contacts folders.

To create a new folder:

1 Click Folder > New.

2 Type the name of the folder in the Folder Name field.

3 Select the location of the new folder.

4 Click OK.

Folder Management
Right-click a folder or subfolder to display a menu with the following options:

Copy: Copies the folder to a different location.When you select this item, Evolution
offers a choice of locations to copy the folder to.

Move: Moves the folder to another location.

Mark Messages As Read: Marks all the messages in the folder as read.

New Folder: Creates another folder in the same location.

Delete: Deletes the folder and all its contents.

Rename: Lets you change the name of the folder.

Disable: Disables the account.

Properties: Checks the number of total and unread messages in a folder, and, for
remote folders, lets you select whether to copy the folder to your local system for offline
operation.

You can also rearrange folders and messages by dragging and dropping them.
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Any time new e-mail arrives in a e-mail folder, that folder label is displayed in bold
text, along with the number of new messages in that folder.

12.2.3 E-Mail
Evolution e-mail is like other e-mail programs in several ways:

• It can send and receive e-mail in HTML or as plain text, and makes it easy to send
and receive multiple file attachments.

• It supports multiple e-mail sources, including IMAP, POP3, and local mbox or mh
spools and files created by other e-mail programs.

• It can sort and organize your e-mail in a wide variety of ways with folders,
searches, and filters.

• It lets you guard your privacy with encryption.

However, Evolution has some important differences from other e-mail programs. First,
it’s built to handle very large amounts of e-mail. The junk e-mail, message filtering
and searching functions were built for speed and efficiency. There’s also the search
folder, an advanced organizational feature not found in some e-mail clients. If you get
a lot of e-mail, or if you keep every message you get in case you need to refer to it later,
you’ll find this feature especially useful. Here’s a quick explanation of what’s happening
in your main Evolution e-mail window.

Message List
The message list displays all the e-mails that you have. This includes all your read and
unread messages, and e-mail that is flagged to be deleted.

Preview Pane
This is where your e-mail is displayed.

If you find the preview pane too small, you can resize the pane, enlarge the whole
window, or double-click the message in the message list to have it open in a new win-
dow. To change the size of a pane, drag the divider between the two panes.
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As with folders, you can right-click messages in the message list and get a menu of
possible actions, including moving or deleting them, creating filters or search folders
based on them, and marking them as junk mail.

Most of the e-mail-related actions you want to perform are listed in the Actions menu
in the menu bar. The most frequently used ones, like Reply and Forward, also appear
as buttons in the toolbar. Most of them are also located in the right-click menu and as
keyboard shortcuts.

12.2.4 The Calendar
To begin using the calendar, click Calendar in the shortcut bar. By default, the calendar
shows today’s schedule on a ruled background. At the upper right, there’s a monthly
calendar you can use to switch days. Below that, there’s a Task list, where you can keep
a list of tasks separate from your calendar appointments.

Appointment List
The appointment list displays all your scheduled appointments.

Month Pane
The month pane is a small view of a calendar month. To display additional months,
drag the column border to the left. You can also select a range of days in the month
pane to display a custom range of days in the appointment list.

Task List
Tasks are distinct from appointments because they generally don’t have times associated
with them. You can see a larger view of your task list by clicking Tasks in the shortcut
bar.

12.2.5 The Contacts Tool
The Evolution contacts tool can handle all of the functions of an address book or phone
book. However, it’s easier to update Evolution than it is to change an actual paper book,
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in part because Evolution can synchronize with PalmOS* devices and use LDAP direc-
tories on a network.

Another advantage of the Evolution contacts tool is its integration with the rest of the
application. For example, you can right-click on an e-mail address in Evolution mail
to instantly create a contact entry.

To use the contacts tool, clickContacts in the shortcut bar. By default, the display shows
all your contacts in alphabetical order, in a minicard view. You can select other views
from the Viewmenu, and adjust the width of the columns by clicking and dragging the
gray column dividers.

The largest section of the contacts display shows a list of individual contacts. You can
also search the contacts in the same way that you search e-mail folders, using the search
tool on the right side of the toolbar.
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13Synchronizing a Handheld
Computer with KPilot
Handheld computers are in widespread use among users who need to have their
schedules, to-do lists, and notes with them everywhere they go. Often users want the
same data available on both the desktop and the portable device. This is where KPilot
comes in—it is a tool to synchronize data on a handheld with that used by the KDE
applications KAddressBook, KOrganizer, and KNotes, which are part of Kontact.

13.1 Configuring the Handheld
Connection

To be able to use KPilot, first set up the connection with the handheld computer. The
configuration depends on the type of cradle (docking unit) used with the handheld.
There are two types of these:

USB
Normally, a USB cradle is autodetected.

Serial
With a serial cradle, you need to know which serial port it is actually connected.
Serial devices are named /dev/ttyS?, starting from /dev/ttyS0 for the first
port.

Before proceeding further, add your user to the group uucp that will use the
handheld. Start YaST and choose the Security and Users > User and Group Man-
agement module. Go to the Groups tab and select from Set Filter the entry System
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Groups. Search for the uucp group, select Edit and add all those users that are al-
lowed to use the handheld. Proceed with Ok and Finish.

The easiest way to set up the connection is by using the configuration assistant. Do the
following:

1 Start KPilot and select Settings > Configuration Wizard to start the assistant.

2 Enter your username and the name of the device to which the handheld is con-
nected. The device depends on your type (USB or serial) which is describe in
the list above.

3 Choose from one of the following options:

• Select Autodetect Handheld & Username if you want the assistant to detect
your handheld.

• Click Next to configure it manually.

4 Specify the applications that should be used for synchronization. You can choose
among the KDE application suite (default), Evolution, and none. After selecting,
close the windowwith Finish. Logout from your current desktop and login again
to have

5 If you use a serial device, open Settings > Configure KPilot... and change the
speed in the Device tab. In most cases, the value 57600 should be correct, but
for older PalmPilot models you have to leave it at 9600. Sometimes you have to
experiment with a correct value. Check alsoWorkarounds, if you own a special
handheld.

13.2 Conduits, Communication and
Synchronization

The main purpose of KPilot is to allow sharing of data between the applications of a
handheld computer and their KDE counterparts. KPilot does come with its own built-
in memo viewer, address viewer, and file installer, but these cannot be used outside the
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KPilot environment. Independent KDE applications are available for all functions except
the file installer.

For communication between the handheld and the different desktop programs, KPilot
relies on conduits. Conduits are external programs that perform synchronization actions.
KPilot itself is the program that oversees any data exchange between the two computer
devices. Using a particular function of the handheld on your desktop computer requires
that the corresponding conduit is enabled and configured. For the most part, these
conduits are designed to interact with specific KDE programs, so in general they cannot
be used with other desktop applications.

The time synchronization conduit is special in that there is no user-visible program for
it. It is activated in the background with each sync operation, but should only be enabled
on computers that use a network time server to correct their own time drift.

When a synchronization is started, the conduits are activated one after another to carry
out the data transfer. There are two different sync methods: a HotSync operation only
synchronizes the data for which any conduits have been enabledwhile a backup operation
performs a full backup of all data stored on the handheld.

Some conduits open a file during a sync operation, which means that the corresponding
program should not be running at that time. Specifically, KOrganizer should not be
running during a sync operation.

13.3 Conduits Used by KPilot
The conduits used by KPilot can be enabled and configured after selecting Settings >
Configure KPilot. The following is a list of some important conduits:

Addressbook
This conduit handles the data exchange with the handheld's address book. The KDE
counterpart for managing these contacts is KAddressBook. Start it from the main
menu or with the command kaddressbook.

KNotes/Memos
This conduit allows you to transfer notes created with KNotes to the handheld's
memo application. Start the KDE application from the main menu or with the
command knotes.
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Calendar (KOrganizer)
This conduit is responsible for syncing the appointments (events) of the handheld.
The desktop equivalent is KOrganizer.

ToDos (KOrganizer)
This conduit is responsible for syncing to-do items. The desktop counterpart is
KOrganizer.

Time Synchronization
Enabling this conduit adjusts the handheld's clock to that of the desktop computer
during each sync operation. This is only a good idea if the clock of the desktop
computer itself is corrected by a time server at fairly frequent intervals.

Figure 13.1 Configuration Dialog with the Available Conduits

13.4 Synchronizing with KOrganizer
On the KDE desktop, calendars, to-dos (tasks) and events (appointments) are mangaged
with KOrganizer.
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13.4.1 Managing your Calendar
Appointments

KPilot allows you to sync your appointments and display them in KOrganizer. By de-
fault, KPilot uses the standard KOrganizer file. However, this is not always a good idea.
If save your appointments into a different file, you can easily switch on or off the cal-
endar in KOrganizer and make it distinguish it from other sources. Proceed as follows:

1 Start KOrganizer: press Alt + F2 and enter korganizer.

2 Create a new calendar file. Right-click in the lower left pane (named withCalen-
dar) and choose Add.... If it is currently hidden, select Settings > Sidebar > Show
Resource View to enable it.

3 Choose Calendar in local file. A new dialog window opens.

4 Insert a name into the text field (for example “Palm”) and choose the location of
your calendar file. It is recommended to use the directory ~/.kde/share/
apps/korganizer/. Proceed with Ok.

5 Start KPilot.

6 Go to Settings > Configure KPilot. The configuration dialog appears. Enable
Conduits > Calendar (KOrganizer) and in Calendar Destination switch to Cal-
endar file. Select the calendar file that you have created in KOrganizer. Finish
with Ok.

The next time you synchronize your appointments, it will be saved into the new file.

13.4.2 Managing ToDo Items and Events
Initially, it should be sufficient to enable the ToDos conduit without changing any of
the defaults. If you want to store your Todo list in the same file as shown in Sec-
tion 13.4.1, “Managing your Calendar Appointments” (page 137), proceed as follows:

1 Start KPilot and select Settings > Configuring KPilot.

2 Enable the ToDos (KOrganizer) conduit.
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3 Select in the To do Destination the entry Calendar file. Point it to the file that
you have created in Step 2 (page 137).

The next time you synchronize your todos, it will be saved into the above file.

13.5 Configuring the KAddressBook
Conduit

Initially, it should be sufficient to enable the KAddressBook conduit without changing
any of the defaults. However, it can be sometimes useful to separate your handheld
addresses from the rest of your addressbooks. It is almost the same as in the KOrganizer
case. If you want to separate your addresses, proceed as follows:

1 Start KAddressbook: press Alt + F2 and enter kaddressbook.

2 Create a new address book. Click on the green cross icon in the lower left pane
(named with Address Books). If it is currently hidden, select View > Address
Books to enable it.

3 Choose File. A new dialog window opens.

4 Insert a name into the text field (for example “Palm Addressbook”) and choose
the location of your calendar file. It is recommended to use the directory ~/
.kde/share/apps/kabc/. Proceed with Ok.

5 Start KPilot.

6 Go to Settings > Configure KPilot. The configuration dialog appears. Enable
Conduits > Addressbook and in Sync Destination switch to vCard file. Select the
addressbook file that you have created in KAddressbook. Finish with Ok.

The next synchronization will save all your addresses into the new file.
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13.6 Working with KPilot
Synchronizing the data of KDE applications with those of the handheld computer is
easy. Simply start KPilot then press the HotSync button on the cradle or cable to initiate
the sync operation.

Figure 13.2 The Main Window of KPilot

13.6.1 Backing Up Data from the Handheld
To do a full backup, select File > Backup. The backup is performed during the next
sync operation. After that, switch back by selecting File > HotSync from the menu.
Otherwise, the time-consuming full backup will be performed again during the next
sync operation.

After a full backup, all copies of the handheld's programs and databases are found in
~/.kde/share/apps/kpilot/DBBackup/USERNAME, where USERNAME is
the name of the user registered on the handheld.
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The two built-in KPilot viewers can be used for a quick lookup of addresses or memos,
but they are not designed to actually manage this data. The KDE applications mentioned
above are much more suited for these tasks.

13.6.2 Installing Programs on the Handheld
The File Installermodule is an interesting and useful tool for the installation of handheld
programs. These programs normally have the extension .prc and they are ready to
start immediately after uploading them to the handheld. Before using such add-on pro-
grams, read their licenses as well as the instructions included.

13.7 For More Information
See the homepage http://cvs.codeyard.net/kpilot/ of KPilot for more
information.
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14Synchronizing Your Handheld
Devices with GNOME Pilot
GNOME Pilot lets you integrate your GNOME desktop with handheld computers. You
can use it to set up and perform synchronization between PDAs and your GNOME
desktop.

Thegnome-pilot package, alongwith the optional conduits inevolution-pilot,
allows you to move information between your handheld device and your GNOME
desktop. You must run the setup tool before synchronizing. The setup tool starts the
GNOME Pilot daemon, gpilotd. If it is not running, you can start the daemon with
the/usr/libexec/gpilotd command. You can also use theGNOMEPilot applet
to start the daemon.

To start the GNOME Pilot applet, click Computer >More Applications > System >
GNOME Pilot.

• Section 14.1, “GNOME Pilot Configuration Tool” (page 141)

• Section 14.2, “The Pilot Applet” (page 147)

14.1 GNOME Pilot Configuration Tool
To start the GNOME Pilot configuration tool, click Computer >More Applications >
System > GNOME Pilot.
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There are three tabs in the Pilot Settings tool: Pilots, Devices, and Conduits. The first
time you run the GNOME Pilot tools, you will be guided through the initial setup by
an assistant.

• Section 14.1.1, “The GNOME Pilot Setup Assistant” (page 142)

• Section 14.1.2, “Adding or Editing a Handheld Entry” (page 144)

• Section 14.1.3, “Adding or Editing an Entry On the Device Settings Tab” (page 145)

• Section 14.1.4, “Conduit Settings” (page 146)

14.1.1 The GNOME Pilot Setup Assistant
The setup assistant guides you through getting your handheld device ready to synchronize
with your desktop system.

1 Click Computer >More Applications > System > GNOME Pilot, then click
Forward to start the GNOME Pilot Setup Assistant

2 In the Device Settings dialog box, describe your handheld's cradle, then click
Forward.

See Section 14.1.3, “Adding or Editing an Entry On the Device Settings Tab”
(page 145) for more information about the information requested by this step.
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3 In the PDA Identification dialog box, identify your device, then click Forward.

If you have previously used synchronization software with this PDA, it will al-
ready have a synchronization ID that your desktop can get from it. If you have
not, you can set the username and ID on the PDA from your desktop.

4 On the Initial Sync dialog box, click Forward to contact your PDA device and
get or set the name and other information.
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5 Choose a name to use when referring to the PDA, and a directory on your desktop
system where you will store backups and other data.

14.1.2 Adding or Editing a Handheld Entry
The Pilots tab lists the handheld devices you have configured. If you have not used the
Pilot Settings tool before, you will not have any items in this list, and the tool will open
a new window to walk you through the process of creating one. To add a new pilot,
click Add. To edit an existing pilot entry, select it and click Edit.

When editing or creating an entry, you will be asked for five pieces of information:

• User Name: This is the name used on your Pilot. If your pilot already has a
name configured, you can get it from the pilot by clicking theGet from Pilot button.
You can also set it on the pilot by clicking the Set On Pilot button.

• ID: This is the user ID number from your pilot. You can get this value from the
handheld by clicking the Get from Pilot button. You can also set it on the handheld
by clicking the Set On Pilot button.

• Pilot Name: This is the name by which your handheld will be identified. For
example, you could call it MyPilot, or Palm5, or Roger.

• Local Basedir: This is the directory where you will store information backed
up from your handheld.
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• Sync Action: This is the action that will be performed when you press the
HotSync button on your cradle. If you set this option to Use conduit settings, then
you can choose different actions depending on the type of data being handled. If
you set it to anything else, all data will be handled the same way. For descriptions
of the synchronization actions, see Section 14.1.4, “Conduit Settings” (page 146).

14.1.3 Adding or Editing an Entry On the
Device Settings Tab

The Device Settings tab controls the way your desktop system looks at your handheld
as hardware. To add an entry to the list, click Add. To edit a device, select it, then click
Edit.

For each entry, you can specify the following options:

• Name: This is the name used to display the device in a list.

• Type: Select the type of connection you have: Serial, USB, IrDA (infrared), or
Network.

• Timeout: Specifies the amount of time to try to connect to the system, in seconds.
If there is no communication between the desktop and the handheld for this many
seconds, the system will stop trying.

• Device: Your handheld is represented to the computer as a special file in the
/dev directory. The name of the file will vary from system to system. In many
cases, however, it will be /dev/pilot. Other possible values are /dev/ttyS0
or /dev/ttyS1 for serial cradles (under Windows, these are referred to as COM
ports), or /dev/usb/, for USB cradles.

You will need to make sure that your user account has read, write, and execute
permissions on this device. To add those permissions, become root with the su
command and enter the command chmod a+wrx /dev/ttyS0. Substitute the
name of the device you are setting.

If you have not chosen the correct device, you will get an error message when you
click OK.
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• Speed: Select a number from the drop-down menu. The higher the number, the
faster you are asking the system to transfer information. Normally, you should not
change this option, because it is set by default for the fastest value that your con-
nection type can provide. If you experience problems at high speeds, reducing the
transfer speed might help.

14.1.4 Conduit Settings
AConduit is a specialized program that channels data between your computer and your
handheld. The gnome-pilot package includes several, and you can also install additional
conduits such as those for Evolution.

Each configured handheld might have its own set of conduits and conduit settings.

If a conduit is disabled, that type of data will be ignored when you HotSync. If a conduit
is enabled, its data will be synchronized according to its settings. To enable or disable
a conduit, select it and click the Enable or Disable button on the right side of the list
of conduits.

To edit the settings, select a conduit and click the Settings button. Each conduit will
have at least two settings: an Action to perform whenever you synchronize, and a One
Time Action, performed only the next time you synchronize.

Not all conduits will have all of these actions. The list of possible actions includes the
following:

• Disabled: Do nothing.

• Synchronize: Ensures that data is the same in both places, copying new data
from the pilot to the desktop, and from the desktop to the computer.

• Copy to pilot: Copies all data from the desktop to the pilot. New data added on
the pilot will not be copied to the desktop.

• Copy from pilot: Copy all data from the pilot to the desktop. New data added
on the desktop will not be copied to the pilot.

Other settings might be available as well, includingConduit Priority, which determines
the order in which conduits will be used, and Sync Private Records, which determines
whether to copy private information as well as public, or just the public data.
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14.2 The Pilot Applet
The GNOME Pilot panel applet sits in your panel until you are ready to synchronize
your handheld device. If the pilot access daemon is running, the applet will appear in
black and white. If it is not running, the applet will appear red and black. If the daemon
is paused, the applet will be yellow and black.

Click the applet button to start the GNOME Pilot configuration tool.

The following actions for the applet are available in the right-click menu:

• Restore: If your PalmOS device has lost all data, select this item to restore it
from a backup you made earlier.

• Pause Daemon: Pauses the GNOME Pilot daemon gpilotd. If the daemon is
paused, this item will read Continue.

• Restart: Stops and restarts the daemon.

• Last Log: Displays the results of the last synchronization performed.

• Preferences: Click this item to select what happens when you click the applet,
and whether to display notices in dialog boxes.
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15Instant Messaging with
Kopete
Kopete is an online messenger application allowing multiple partners connected to the
Internet to chat with each other. Kopete currently supports all common messenger
protocols, such as AOL* Instant Messenger (AIM), GroupWise® Messenger, ICQ,
Jabber*, Lotus* Sametime, MSN, SMS, and Yahoo!*.

15.1 Configuring Kopete
Before you can chat with your friends, you need to create an account:

1 Open Kopete by pressing Alt + F2 and entering kopete. If Kopete does not
start, check if the package kde4-kopete is installed.

2 Select Settings > Configure and click Add Accounts.... The configuration wizard
appears.

3 Select your messaging service. Generally, this is mostly determined by what
service your friends are using.

4 If the messaging services requires registration but you do not have an account
for this service yet, click Register New Account. In the browser window that
opens, enter your user data to register.

5 Switch back to Kopete and enter the data received on registration with the mes-
saging service. This usually consists of the nickname or e-mail address and a
password. Complete the configuration of your account by clicking Finish.
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After you have configured your account you need to add contacts to chat with them. If
you have already created an account on another PC, this data is imported and automat-
ically added to your contact list after login. To manually create a contact entry, click
File > Add Contact. A new assistant appears to help with creation. However, you must
be online and connect with Kopete to the selected messaging service to add a contact
to your list.

15.2 Chatting with Friends
It is necessary to be connected to the Internet to be able to chat with other participants.
When this is done, you should set your status by clicking File > Set Status > Online.
This establishes a connection between Kopete and the selected messaging service. After
the successful login, you are visible to others.

The main application windows features a list of contacts. You must have contacts to
chat with others. To add a new contact, click on File > Add Contact and choose your
identity. After you have entered the respective data (which can vary depending on your
account) you see your new contact. When you right-click a contact marked as online,
a menu opens with various options. Send that person amessage or start a chatting session.
A chat allows invitation of additional participants for real-time discussion. Connection
to all participants is closed when the creator of the chat session closes it.
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Figure 15.1 Chat Window

If you want to see your previous chat session, select a contact and go to Tools > Latest
History. This menu item shows your chat sessions with this person. Alternatively you
can select Edit > View History. This opens a window where you can see an overview
of all contacts and there saved messages.

You can view other options by right-clicking a username. A pop-up menu opens. An
important option is Start Chat to start a chatting session. With Rename Contact and
Remove Contact, you can run the respective action. The pop-up menu also contains a
submenu item with the username where you can block the user or get user information.

TIP: Scrolling Through Old Chat Sessions

If you want to know what you wrote during one of the last chat sessions with
a person, click a contact to open the chat window again and press Alt + ← or
Alt + → to scroll through your sessions. Alternatively, use the arrow icons in
the toolbar to scroll back and forth.
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15.3 Customizing Kopete
Kopete offers numerous options to customize it according to your needs. Find some
examples in the following sections.

15.3.1 Adding Groups
Grouping contacts in your list can give a better overview. Click File > Create New
Group. Name the group and confirm this with OK. A new folder appears in the contact
list that can be used to store the desired contacts. Drag and drop contacts into the desired
folder.

Figure 15.2 The Main Kopete Window

Empty groups can be disabled by activating Settings >Hide Empty Groups. To customize
a special group only, right-click the respective entry and select Properties in the popup
window that opens. Now change the icons or your notifications.
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15.3.2 Using an Identity
Kopete canmanage several accounts, which is helpful if you have friends using different
messenger protocols. Each account can be associated with a different identity. This is
useful for privacy or business reasons and if you do not want to reveal your name. To
create a new identity, proceed as follows:

1 In Kopete, select Settings > Configure and go to the Accounts tab. The configu-
ration window appears.

2 Select Add Identity... and enter a name, nickname, and other information.

3 If you want to use the new identity for different accounts, simply move your ac-
count into your new identity.

15.3.3 Configuring Notifications
Kopete allows you to configure notifications for events such as contacts coming online
or going offline or an incoming message for you. This can be done globally, for a spe-
cific group or a single contact.

To activate the notifications option proceed as follows:

1 Make sure all your contacts are shown in the Kopete window. If not, select Set-
tings > Show Offline Users.

2 Right-click your preferred contact and select Properties. The notification dialog
appears, see Figure 15.3
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Figure 15.3 Notification Dialog in Kopete

3 Go to the Custom Notification tab and select Contact Gone Online.

4 Decide which action should be executed for this event: Play a Sound, Show a
Message in a Popup, Log to a File, Mark Taskbar Entry, or Run Command.

5 Click OK to confirm your settings.

To modify the default notification options, select Settings > Notifications. Select which
event is important for you and change the notification settings. For example, if you
want to be informed by a sound when any of your contacts has come online, select A
contact has come online and activate Play a sound. Select the sound and click OK to
close the configuration dialog.
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15.3.4 Configuring Kopete Plug-ins
Kopete offers some nice extensions for you chat sessions which can be accessed from
Settings > Configure Plugins. For example, you can auto replace text, encrypt outgoing
messages, highlight text if the message contains some interesting words, render LaTeX
formulas, or translate messages.

15.4 For More Information
More information about Kopete and chats can be found on the following Web sites:

• Kopete Home Page [http://kopete.kde.org/]

• Common Abbreviations Used in Chat Sessions [http://www.webopedia
.com/quick_ref/textmessageabbreviations.asp]

• KDE “Internet & Network” Forum [http://www.kde-forum.org/board
.php?boardid=34]
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16Instant Messaging with
Empathy
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17Instant Messaging with Pidgin
Use Pidgin (formerly called Gaim) to use all of your instant messaging accounts from
a single instant messaging client. Pidgin supports all of the most popular instant mes-
saging protocols, so you can log in to all of your accounts at once and chat live with
your contacts in one tabbed interface, regardless of which IM system they use.

With Pidgin, you can log in to multiple accounts on multiple IM networks simultane-
ously. Pidgin also supports many features of the various networks, such as file transfer,
away messages, and typing notification.

This chapter explains the Pidgin options you need to know about to set up Pidgin and
communicate with your contacts. It does not explain all of Pidgin features and options.
For more information, open Pidgin, then click Help > Online Help or press F1.

• Section 17.1, “Supported Protocols” (page 159)

• Section 17.2, “Adding an Account” (page 160)

• Section 17.3, “Managing Your Buddy List” (page 161)

• Section 17.4, “Chatting” (page 163)

17.1 Supported Protocols
Pidgin supports the following instant messaging protocols:

• AOL* Instant Messenger (AIM)
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• Bonjour

• Gadu-Gadu

• Google Talk

• GroupWise Messenger

• ICQ

• IRC

• Jabber/XMPP

• MSN Messenger

• QC

• SILC

• SIMPLE

• Yahoo!*

• Zephyr*

17.2 Adding an Account
To use Pidgin, you must already have accounts on the systems you want to use. For
example, to use Pidgin for your AIM account, you must first have an AIM account.
Once you have those accounts, set them up in the Pidgin Add Account dialog.

1 Start Pidgin by clicking Computer >More Applications > Internet > Pidgin.

2 Click Accounts > Add/Edit to open the Accounts dialog box.

The first time you run Pidgin, or any subsequent time you start Pidgin when you
don’t have any accounts set up, the Accounts dialog box opens automatically.

3 Click Add to open the Add Account dialog.
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4 Select the protocol you want to set up.

TheAdd Account dialog differs for each protocol, depending onwhat setup options
are available for that protocol.

5 Enter the setup options for the chosen protocol.

Typical options include your account name and password. Your protocol might
support additional options, such as a buddy icon, alias, login options, or others.

6 Click Save.

7 Repeat Steps 2 to 5 for each additional protocol.

After an account is added, you can log in to that account by entering your password in
the Pidgin login dialog box.

17.3 Managing Your Buddy List
Use the Buddy List to manage your contacts, also known as buddies. You can add and
remove buddies from your Buddy List, and you can organize your buddies in groups
so they are easy to find.
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17.3.1 Displaying Buddies in the Buddy List
After your accounts are set up, all buddies who are online appear in your Buddy List.
If you also want your buddies who are not online to appear in the Buddy List, click
Buddies > Show Offline Buddies.

Figure 17.1 Pidgin Buddy List

17.3.2 Adding a Buddy
To add a buddy to your Buddy List, click Buddies > Add Buddy, then enter the informa-
tion about that buddy.

NOTE

For some protocols, you cannot add a buddy in the Pidgin interface. You must
use the client for those protocols if you want to add to your buddy list. After
you have added a buddy in the protocol’s client, that buddy appears in your
Buddy List.
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17.3.3 Removing a Buddy
To remove a buddy, right-click on that buddy’s name in the Buddy List, then click Re-
move.

17.4 Chatting
To open a chat session, double-click a buddy name in the Buddy List. The Chat screen
opens. Type your message, then press Enter to send it.

Each chat session you open appears as a tab in the Chat screen. Click on a buddy’s tab
to chat with that buddy. Close a chat session by closing the tab for that buddy.

Figure 17.2 Pidgin Chat Session
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18Using Voice over IP with Ekiga
Modern telecommunication means far more than just making a phone call. It is also
about exchanging text messages and sometimes even video conferencing. Roaming
enables you to be reachable under one phone number all across the world. Ekiga brings
these features to your Linux desktop, allowing you to communicate over broadband
Internet.

Before starting, make sure that the following requirements are met:

• Your sound card is properly configured.

• A headset or a microphone and speakers are attached to your computer.

• For dialing in to regular phone networks, a SIP account is required. SIP (Signaling
protocol for Internet Telephony) is the protocol used to establish sessions for audio
and video conferencing or call forwarding. There are many VoIP providers all over
the world. For a quick start, have a look at the service that the ekiga project provides
at http://www.ekiga.net.

• For video conferencing, a Web cam is connected to your computer.

18.1 Configuring Ekiga
On first start, Ekiga opens a configuration assistant that requests all data needed to
configure your instance of Ekiga. To configure Ekiga, proceed as follows:
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1 Enter your full name (name and surname).

2 Enter your ekiga.net account data or choose not to sign up with ekiga
.net.

To add other accounts later, configure them using Edit > Accounts.

3 Determine your connection type.

4 Determine the type of firewall to use to enable you to make calls with Ekiga.

5 Choose the audio manager to use. Accept the default setting ALSA, as it
guarantees the best sound quality and other sound systems, like OSS, are not
available on openSUSE.

6 Choose the audio input and output devices and test your settings.

7 Accept the video manager selection, V4L.

8 Choose the video input device and test your settings.

9 Check the summary of your settings and apply them.

10 If registration fails after you made changes to your configuration, just restart
Ekiga.

Ekiga allows you to maintain multiple accounts. To configure an additional account,
proceed as follows:

1 Open Edit > Accounts and select Add.

2 Choose an Account Name.

3 Select an appropriate Protocol depending on the type of account you use. Nor-
mally, you would select SIP here.

4 Enter the Registrar to which you want to register. This is usually an IP address
or a host name that will be given to you by your Internet Telephony Service
Provider. Enter User, and Password according to the data provided by your
provider.
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5 Leave the configuration dialog with OK and activate the account. The status of
your account displayed in the Ekiga main window changes to Registered.

18.2 The Ekiga User Interface
All functions of Ekiga are available through the menu bar. Shortcuts to the most impor-
tant functions are available in a toolbar to the left and by special key combinations.

Figure 18.1 Ekiga User Interface

The user interface has different modes. To switch between views, use View > View
Mode and View > Control Panel or select the view mode icon on the left side of the
GUI and the different tabs at the bottom. The Full View is shown in Figure 18.1, “Ekiga
User Interface” (page 167). All icons in the toolbar provide a tool tip that is activated
by the mouse pointer hovering over the icon.
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At the bottom of the user interface, several tabs provide the functionality for Dialpad,
Audio, Video, and Statistics. Some settings like the Audio settings may only be changed
during a phone call.

Many of the functions of Ekiga are available with keyboard shortcuts. Table 18.1,
“Keyboard Shortcuts for Ekiga” (page 168) summarizes the most important ones.

Table 18.1 Keyboard Shortcuts for Ekiga

DescriptionCtrl Sequence

Initiate a call with the current number.Ctrl + O

Hang up.Ctrl + D

Hold the current call.Ctrl + G

Transfer the current call to another party.Ctrl + T

Save the current picture to hard disk.Ctrl + S

Close the Ekiga user interface.Ctrl +W

Quit Ekiga.Ctrl + Q

Start the account manager.Ctrl + E

Open the Ekiga Preferences overview. This dialog al-
lows you to do some fine-tuning to your Ekiga settings.

Ctrl + P

Zoom in to the picture from the Web cam.Ctrl + +

Zoom out on the picture from the Web cam.Ctrl + -

Return to the normal size of the Web cam display.Ctrl + =

Use full screen for the Web cam.Ctrl + F

Display the history of your calls.Ctrl + H
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18.3 Making a Call
Once Ekiga is configured appropriately, making a call is straightforward.

1 Start Ekiga using the menu or the command line.

2 Enter the SIP address of the party to call at the SIP address prompt. The address
should look like:

• for direct local calls: sip:username@domainname or
username@hostname

• sip:username@domainname or userid@sipserver

If you have a SIP provider who accepts real phone calls, you may just enter the
number like sip:<call number>

3 Click Call or type Ctrl + O and wait for the other party to pick up the phone.

4 To end the call, click Hang up or type Ctrl + D.

If you need to tweak the sound parameters during a call, click View > View Mode >
Full View to show four tabs holding more options. The second one holds the Audio
options for Playback level and Recording level. Use the sliders to adjust the levels to
fit your needs.

18.4 Answering a Call
Ekiga can receive calls in two different ways. First, the user may be called directly with
sip:user@host. Alternatively, make your calls via a SIP provider. Most SIP
providers enable you to get calls from a normal landline to your VoIP account. Depend-
ing on the mode in which Ekiga is run, there are several ways in which you would notice
an incoming call:

Normal Application
Incoming calls can only be received and answered if Ekiga is already running. You
hear the ring sound on your headset or your speakers. If Ekiga is not running, the
call cannot be received.
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Panel Applet
Normally, the Ekiga panel applet would run silently without giving any notice of
its existence. This changes as soon as a call comes in. The main window of Ekiga
opens and you hear a ring sound on your headset or speakers.

Once you have noticed an incoming call, just click Accept to answer the call then start
talking. If you do not want to accept this call, click Reject. It is also possible to transfer
the call to another SIP address.

18.5 Using the Address Book
Ekiga offers to manage your SIP contacts. Start the address book with Tools > Address
book. An empty list window opens. To add a contact, first select Personal with your
mouse. Then right-click into the address window and selectNewContact. Alternatively,
just press Ctrl > N.

The following entries are required for a valid contact:

Name
Enter the name of your contact. This may be a full name, but you can also use a
nickname here.

SIP Address
Enter a valid SIP address for your contact.

Email
Enter the e-mail address of your contact for your own reference.

Speed Dial
With a Speed Dial you can access often used numbers more easily. This is op-
tional.

Categories
If desired, add your own categories if you have many different contacts.

Local Address Book
By default, you have a local address book with the name Personal available. If you
need more address books, create them with File > New Address Book or use the
keyboard shortcut Ctrl + B.

170 Application Guide



To call any contact from the address book, double-click this contact. The call is initiated
immediately.

18.6 For More Information
The official home page of Ekiga is http://www.ekiga.org/. This site offers
answers to frequently asked questions as well as more detailed documentation.

For information about the support of the H323 teleconferencing protocol in Linux, see
http://www.voip-info.org/wiki/view/H.323. This is also a good starting
point when searching for projects supporting VoIP.

To set up a private telephone network, you might be interested in the PBX software
Asteriskhttp://www.asterisk.org/. Find information about athttp://www
.voip-info.org/wiki-Asterisk.
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19Browsing with Konqueror
Konqueror is a modern Web browser, but can also be used as a file manager. However,
to manage your files and directories, it is recommended to use Dolphin. If you start the
browser with the icon in the panel, Konqueror opens with the Web browser profile. As
a browser, Konqueror offers tabbed browsing, the possibility of savingWeb pages with
graphics, Internet keywords, bookmarks, and support for Java and JavaScript.

Figure 19.1 The Browser Window of Konqueror

Start Konqueror from the main menu or by entering the command konqueror. If
Konqueror does not start, check if the package kde4-konqueror is installed. To
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load a Web page, enter its address in the location bar, for example, http://www
.opensuse.org. Konqueror now tries to reach the address and displays the page.
Entering the protocol at the beginning of the address (http:// in this case) is not
strictly required. The program is able to complete the address automatically, but this
only works reliably with Web addresses. For an FTP address, always enter ftp://
at the beginning of the input field.

19.1 Tabbed Browsing
If you often use more than oneWeb page at a time, tabbed browsing may make it easier
to switch between them. Load Web sites in separate tabs within one window. The ad-
vantage is that you keep more control over your desktop because you only have one
main window. After logout, the KDE session management allows for saving your Web
session in Konqueror. The next time you log in, Konqueror loads the exact URLs visited
last time.

To open a new tab, selectWindow > New Tab or press Ctrl + Shift + N. To change the
behavior of tabs, go to Settings > Configure Konqueror. In the dialog box that opens,
selectWeb Behavior > Tabbed Browsing. To open new tabs instead of windows, enable
Open Links in New Tab Instead of in New Window. You can also hide the tab bar with
Hide the Tab Bar When only One Tab is Open. To see more options, press Advanced
Options.

19.2 Automatic Scrolling
In general, scrolling with the mouse is the normal way to view information farther down
a Web page. However, there are sometimes occasions when it is preferable not to use
a mouse. It can be very convenient to use key combinations instead of removing hands
from the keyboard.

To scroll down automatically, use Shift + ↓. This scrolls down the page without further
intervention. Increase the speed by pressing Shift + ↓ again. Pressing Shift + ↑ slows
down. To stop scrolling, use ↓.

176 Application Guide

http://www.opensuse.org
http://www.opensuse.org


19.3 Profiles
Section 19.1, “Tabbed Browsing” (page 176) described how to handle tabs in Konqueror.
You can save your tabs with URLs and the position of the window in a profile. This
differs from the session management already mentioned.With profiles, your saved tabs
are at hand without the intensive start-up time of session management.

To create a profile, do the following:

1 Go to Settings > Configure View Profiles.

2 In the dialog box that appears, insert a name in Profile Name.

3 To save your URLs, select Save URLs in Profile.

4 To freeze the position and size of the windows, select SaveWindow Size in Profile.

5 Approve with Save.

The next time you need your tab collection, go to Settings > Load View Profile and find
the name listed in the menu. After you select it, Konqueror restores your tabs.

19.4 Saving Web Pages and Graphics
As in other browsers, you can save Web pages. To do this, select File > Save As and
specify a name for your HTML file. However, images are not saved. To archive an
entire Web page including the images, select Tools > Archive Web Page. Konqueror
suggests a filename that you can usually accept. The filename ends with .war, the
extension for Web archives. To view the saved Web archive later, simply click the re-
spective file and the Web page is displayed in Konqueror along with its images.

19.5 Searching with Konqueror
Searching with Konqueror is very convenient. You can use the search bar or Web
shortcuts.
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19.5.1 Using the Search Bar
Konqueror contains a search bar where you can choose from many search engines. If
you want to search for a specific term, proceed as follows:

1 Locate the search bar in Konqueror. It is on the right side after the location bar.

2 Click the icon inside the search bar. Choose a search engine from the pop-up
menu.

3 Insert your search term and press Enter. The result is displayed in Konqueror.

If you need a search engine that is not listed in the pop-up menu, add it as follows:

Procedure 19.1 Adding More Search Engines

1 In Konqueror, click the icon in the search bar.

2 Choose Select Search Engines....

3 Make sure that Enable Web Shortcuts is activated.

4 Enable the respective search engine and close the dialog with OK. You can see
your selected search engine if you click the icon in the search bar.

19.5.2 Using Web Shortcuts
Each search engine defined is attached to a web shortcut. This shortcut can be entered
in the location bar.

To see which are already defined, go to Settings > Configure Konqueror >Web Short-
cuts. You can see the names of the search providers and the shortcuts. Konqueror defines
many search engines: Google, Yahoo, and Lycos, and a number of less common re-
sources, like an acronym database, the Internet movie database, and KDE application
searches.

If you do not find your preferred search engine here, you are able to define a new one
very easily. For example, to search our home page for some interesting articles, go to
http://en.opensuse.org/, enter your query and look for the appropriate results.
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Procedure 19.2 Creating New Web Shortcuts

1 Go to the search bar, click the icon, and select Select Search Engines.

2 Make sure that Enable Web Shortcuts is activated.

3 Click New.

4 Create a new Web shortcut:

4a Assign your Web shortcut a name in Search Provider Name.

4b Enter the search URI. For example, if you want to search in openSUSE, use
http://en.opensuse.org/Special:Search?search=\{@}.
The search query is specified as \{@}. Get more information by clicking in
the text field labeled with Search URI and pressing Shift + F1.

4c Enter your abbreviations in URI Shortcuts. There can be entered more than
one, separated by commas.

5 Proceed with OK.

After creating a new Web shortcut, you can use it in the location bar. The result is dis-
played in the current window.

TIP: Using Shortcuts Directly without Opening Konqueror

You do not need to open Konqueror and enter the Web shortcut. You can use
it directly: select Run Command from the main menu or press Alt + F2. After
the dialog box appears, enter your shortcut, a colon (:), and your search term.

19.6 Bookmarks
Instead of remembering and reentering addresses for sites visited often, you can book-
mark these URLs using the Bookmark menu. As well as Web page addresses, you can
also bookmark any directories of your local disk in this way.
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To create a new bookmark in Konqueror, click Bookmarks > Add Bookmark. Any
bookmarks added previously are included as items in the menu. It is a good idea to ar-
range the bookmark collection by subjects in a hierarchical structure, so that you do
not lose track of the different items. Create a new subgroup for your bookmarks with
New Bookmark Folder. Selecting Bookmarks > Edit Bookmarks opens the bookmark
editor. Use this program to organize, rearrange, add, and delete bookmarks.

If you are using Netscape,Mozilla, or Firefox as additional browsers, it is not necessary
to recreate your bookmarks. File > Import > Import Netscape Bookmarks in the book-
mark editor enables you to integrate your Netscape and Mozilla bookmarks into your
most current collection. The reverse is also possible via Export as Netscape Bookmarks.

Change your bookmarks by right-clicking the entry. A pop-up menu appears in which
to select the desired action (cut, copy, delete, etc.).When you are satisfied with the result,
save the bookmarks with File > Save. If you only want to change the name or link, just
right-click the entry in the bookmark toolbar and select Properties. Change the name
and location and confirm with Update.

To save your bookmark list and have instant access to it, make your bookmarks visible
in Konqueror. Select Settings > Toolbars >Bookmark Toolbar (Konqueror). A bookmark
panel is automatically displayed in the current Konqueror window.

19.7 Java and JavaScript
Do not confuse these two languages. Java is an object-oriented, platform-independent
programming language from SunMicrosystems. It is frequently used for small programs
(applets), which are executed over the Internet for things like online banking, chatting,
and shopping. JavaScript is an interpreted scripting language mainly used for the dy-
namic structuring of Web pages, for example, for menus and other effects.

Konqueror allows you to enable or disable these two languages. This can even be done
in a domain-specific way, which means that you can permit access for some hosts and
block access for others. Java and JavaScript are often disabled for security reasons.
Unfortunately, some Web pages require JavaScript for correct display.
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19.8 Enabling Advertisement Blockers
Some Web pages open annoying advertisements. With the help of Konqueror, these
windows can be blocked. Proceed as follows:

Procedure 19.3 Blocking Advertisements

1 Select Settings >Web Browsing > AdBlock Filters in Konqueror.

2 Activate Enable Filters.

3 Enter an expression for the Web page to filter. For example:
http://www.example.com/*

This filters everything that comes from that URL.

4 Click Insert.

If you need the entries on another computer, click Export, save the file, move it to your
other computer and import it there in Konqueror from the same dialog box.

19.9 For More Information
For any questions or problems that arise when working with Konqueror, refer to the
application's handbook, which is available from the Help menu. Konqueror also has a
Web page, located at http://www.konqueror.org.
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20Browsing with Firefox
Included with your openSUSE® is the Mozilla Firefox Web browser. With features
like tabbed browsing, pop-up window blocking, and download and imagemanagement,
Firefox combines the latest browsing and security technologies with an easy to use in-
terface. Using tabs you can view more than one Web page in a single window. You can
suppress annoying advertisements and disable images for faster browsing. Firefox's
easy access to different search engines helps you find the information you need.

Start Firefox from the main menu or by entering the command firefox. The main
program features are described in the following sections.

20.1 Navigating Web Sites
Firefox has much the same look and feel as other browsers. It is shown in Figure 20.1,
“The BrowserWindow of Firefox” (page 184). The navigation toolbar includesForward
and Back, the smart location bar for a Web address, and the search bar. Bookmarks are
also available for quick access from the bookmarks toolbar. For more information about
the various Firefox features, use the Help menu.
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Figure 20.1 The Browser Window of Firefox

20.1.1 The Smart Location Bar
When typing into the location bar, an auto-completion drop-downmenu opens, showing
the addresses matching what you have typed. The phrase that is matched is highlighted
with bold letters. The drop-down menu shows all matching addresses, bookmark and
page titles and tag names from your browsing history and your bookmarks list.
Matching even works across word boundaries. Entries visited most frequently and re-
cently are listed first.

List entries from the bookmark list are marked with a star. Bookmarks with tags are
marked with an additional label followed by the tag names. List entries from the
browsing history are not marked.

Use ↑ and ↓ or the mouse wheel to scroll through the list. Press Enter or click on an
entry to go to the selected page. Del removes an entry from the list if it is an entry from
the history. Bookmarked entries can only be removed by deleting the associated book-
mark.

20.1.2 Zooming
Firefox offers two zooming options: page zoom, the default, and text zoom. Page view
zooms the entire page as is, with all elements of a page, including graphics, expanding
equally while text zoom only changes the text size.
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To toggle between page and text zoom, choose View > Zoom > Zoom Text Only. To
zoom in or out either use the mouse wheel while holding the Ctrl key, or use Ctrl + +
and Ctrl + -. Reset the zoom factor with Ctrl + 0

20.1.3 Tabbed Browsing
If you often use more than one Web page at a time, tabbed browsing makes it easier to
switch between pages. It allows you to load Web sites in separate tabs within one win-
dow.

Opening tabs
To open a new tab, select File > New Tab or press Ctrl + T. This opens an empty
tab in the Firefox window. To open a link on a web page or a bookmark in a tab,
middle-click it. Alternatively, right-click a link and select Open Link in New Tab.
You may also open an address in the location bar in a new tab by pressing Ctrl +
Enter.

Closing Tabs
Right-click on a tab to open a context menu giving you access to tab managing
options such as closing, reloading, or bookmarking. To close a tab, you may also
use Ctrl +W or click the close button. Any closed tab can be restored by choosing
from History > Recently Closed Tabs. In order to reopen the last closed tab either
choose Undo Close Tab from the context menu or by pressing Ctrl + Shift + T.

Sorting Tabs
By default tabs are sorted in the order you opened them. Rearrange the tab order
by dragging and dropping a tab to the desired position. If you have opened a large
number of tabs, they will not all be displayed in the tab bar. Use the arrows at the
ends of the bar to move left or right-click on the down arrow at the right end of the
tab bar to get a list of all tabs.

Dragging and Dropping
Drag and drop also works with tabs: drag a link onto an existing tab to open it in
that tab or drag and drop a link on an empty space in the tab bar to open a new tab.
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20.1.4 Using the Sidebar
Use the left side of your browser window for viewing bookmarks or the browsing his-
tory. Extensions may add new ways to use the sidebar as well. To display the sidebar,
select View > Sidebar and select the desired contents.

20.2 Finding Information
There are two ways to find information in Firefox: use the search bar to search the In-
ternet with a search engine and the find bar to search the page currently displayed.

20.2.1 Finding Information on the Web
Firefox has a search bar that can access different engines, like Google, Yahoo, or
Amazon. For example, if you want to find information about SUSE using the current
engine, click in the search bar, type SUSE, and hit Enter. The results appear in your
window. To choose your search engine, click the icon to the left of the search bar. A
menu opens with a list of available search engines.

Customizing the Search Bar
If you want to change the order, add, or delete a search engine to the bar, establish an
Internet connection and proceed as follows.

1 Click the icon to the left of the search bar.

2 SelectManage Search Engines from the menu.

3 Click Remove to delete an entry, Move Up/Down to change the order.

To add a search engine, click Get More Search Engines. Firefox displays a Web
page with available plug-ins. You can choose from Wikipedia, IMDB, Flickr,
and others. Click on a plug-in link and choose Add to install it.
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Figure 20.2 Manage Search Engines

Some Web sites offer search engines that you can add directly to the search bar.
Whenever you enter such a Web site, the icon to the left of the search bar turns blue.
Click on the icon and select the “Add” entry from the menu.

Adding Smart Keywords to Your Online Searches
Firefox lets you define your own smart keywords: abbreviations to use as a URL
shortcut for a particular search engine. If you define ws as a smart keyword for the
Wikipedia search for example, you can now type ws SEARCHTERM into the location
bar to search Wikipedia for SEARCHTERM.

To assign a shortcut for a search engine from the search bar, click the icon to the left
of the search bar and open theManage Search Engines dialog. Mark a search engine
and open the Edit Keyword dialog.

It is also possible to define a smart keyword for any search field on aWeb site. Proceed
as follows:

1 Right-click on the search field and choose Add a Keyword for this Search from
the menu that opens. The Add Bookmark dialog appears.

2 In Name, enter a descriptive name for this smart keyword.
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3 Enter your Keyword for this search.

4 Choose the location where to save this smart keyword with Create In.

5 Finalize with Add.

TIP: Smart Keywords for Regular Web sites

Using smart keywords is not restricted to search engines. You can also add a
smart keyword to a bookmark (via the bookmark's properties). For example,
if you assign nov to the Novell home page bookmark, you can open it by just
typing nov into the location bar.

20.2.2 Searching in the Current Page
To search inside a Web page, click Edit > Find in This Page or press Ctrl + F. The find
bar opens. It is usually displayed at the bottom of a window. Type your query in the
input field. Firefox finds the first occurrence of this phrase as you type. You can find
other occurrences of the phrase by pressing F3 or the Next button in the find bar.
Clicking theHighlight All button will highlight all occurrences of the pharse. Checking
theMatch Case option makes the query case-sensitive.

Firefox also offers two quick find options. Click anywhere you like to start a search on
aWeb page, type the key / immediately followed by the search term. The first occurrence
of the search term will be highlighted as you type. Use F3 to find the next occurrence.
It is also possible to limit quick find to only links. This search option is available by
typing the key '.

20.3 Managing Bookmarks
Bookmarks offer a convenient way of saving links to your favorite Web sites. Firefox
not only makes it very easy to add new bookmarks with just one mouse click, it also
offers multiple ways to manage large bookmark collections. You can sort your book-
marks into folders, create filtered views—called smart bookmarks—that will be updated
on the fly, or you can classify bookmarks with tags.
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Add a bookmark by clicking on the star in the location bar. The star will turn yellow
to indicate the page is bookmarked. Clicking once will save the bookmark in the Un-
sorted Bookmarks folder under the page title. Double clicking on the star opens a menu
which lets you choose a location where to save the bookmark and lets you enter a name
and tags. Bookmarking tabs is done via the context menu: right-click in a tab and choose
whether to Bookmark This Tab or to Bookmark All Tabs. In the latter case Firefox asks
you to create a new folder for the tab links.

To remove or edit a bookmark, open it and click on the star in the location bar. You
can also choose Bookmarks, right-click the bookmark in the list, then click Delete to
remove the bookmark or Properties to edit it.

20.3.1 Organizing Bookmarks
The Library can be used to manage the properties (name and address location) for each
bookmark and organize the bookmarks into folders and sections. It resembles Fig-
ure 20.3, “The Firefox Bookmark Library” (page 189).

Figure 20.3 The Firefox Bookmark Library
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To open the Library, click Bookmark > Organise Bookmarks. The library window is
split into two parts: the left pane shows the folder tree view, the right pane the subfolders
and bookmarks of the selected folder. Use Views to customize the right pane. The left
pane contains three main folders:

History
Contains your complete browsing history. You cannot alter this list other than
deleting entries from it.

Tags
Lists bookmarks for each tag you have specified. See Section 20.3.2, “Tags”
(page 191) for more information on tags.

All Bookmarks
This category contains the three main bookmark folders:

Bookmarks Toolbar
Contains the bookmarks and folders displayed beneath the location bar. See
Section 20.3.6, “The Bookmarks Toolbar” (page 193) for more information.

Bookmarks Menu
Holds the bookmarks and folder accessible via the Bookmarks entry in the
main menu or the bookmarks side menu.

Unsorted Bookmarks
Contains all bookmarks created with a single click on the star in the location
bar. This folder is only visible in the library and the bookmarks sidebar.

Organize your bookmarks using the right pane. Choose actions for folders or bookmarks
either from the context menu that opens when you right-click on an item or from the
Organise dialog. The properties of a chosen folder or bookmark can be edited in the
bottom part of the right pane. By default, only Name, Location, and Tags are displayed
for a bookmark. ClickMore to gain access to all properties.

Use drag and drop to rearrange your bookmarks. Left-click a bookmark and drag it to
a new position while holding the mouse button pressed. Drop it by releasing the mouse
button. You can use this technique to move a bookmark or a folder to a different folder,
or to change the order of bookmarks in a folder.
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20.3.2 Tags
Tags offer a convenient way to file a bookmark under several categories. You can tag
a bookmark with as much terms as you want. For example, to access all sites tagged
with suse enter suse into the location bar. Whats more, a smart bookmark folder for
each tag is automatically created in the tags folder of the library. Drag and drop a smart
bookmark for a tag onto your bookmark toolbar or into a folder of your bookmarks
menu to easily access it.

To add tags to a bookmark, open the bookmark in Firefox and click on the yellow star
in the location bar. The Edit This Bookmark dialog opens where you can add a comma
separated list of tags. It is also possible to add tags via the bookmark's properties dialog
which you can open in the library or by right-clicking on a bookmark in the menu or
the toolbar.

20.3.3 Importing and Exporting Bookmarks
If you used a different browser in the past, you probably want to use your old bookmarks
in Firefox, too. Firefox can automatically import bookmarks from other browsers in-
stalled on your system, such as Netscape or Opera. You also can import bookmarks
from a file exported from a browser on different computer or from a backup.

To import bookmarks from another browser or from a file in HTML format, open the
library by choosing Bookmarks > Organise Bookmarks. Start the Import Wizard by
choosing Import and Backup > Import HTML... and choose an import location. Start
the import by clickingNext. Bookmarks from another browser are imported to a separate
folder under the bookmarks menu named FromBrowser Name. Imports from an
HTML file are imported as is.

Exporting bookmarks is also done via the Import and Backup dialog in the library
window. To save your bookmarks as an HTML file, choose Export HTML.... In order
to create or restore a backup of your bookmarks, choose Backup... or Restore. Firefox
uses the JavaScript Object Notation file format (.json) for backups.
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20.3.4 Live Bookmarks
Live bookmarks display headlines in your bookmark menu and keep you up to date
with the latest news. This enables you to save time with one glance at your favorite
sites. Live bookmarks update automatically.

Many sites and blogs support this format. AWeb site indicates this by showing an orange
icon in the right part of the location bar. Click the icon and choose Subscribe Now in
the page that opens. A dialog box opens in which to select the name and location of
your live bookmark. Confirm with Add. This page also lets you choose alternative ap-
plications to subscribe to, such as Bloglines, or My Yahoo.

20.3.5 Smart Bookmarks
Smart bookmarks are virtual bookmark folders that are dynamically updated. By default,
three smart bookmark folders are already predefined: theMost Visited links are available
from your bookmarks toolbar, Recently Bookmarked links and Recent Tags are located
in the bookmarks menu. You can create new smart bookmarks by searching for certain
entries in your library.

To create a new smart bookmark, open the library by choosing Bookmarks > Organise
Bookmarks and proceed as follows:

1 Either select one of the main folders (History, Tags, All Bookmarks) or a specific
bookmarks folder.

2 Enter a search term into the input field, for example Linux. This will do a case
insensitive search for all links containing the phrase Linux in either the Web
page title, the tags, or the URL.

3 Save the search to create a new smart bookmark. A smart bookmark will always
be saved to the bookmarks menu folder—drag and drop it to the desired location.

TIP

Creating a smart bookmark from your saved bookmarks creates an up-to-date
filtered view on your bookmarks that only changes when you add or delete
bookmarks matching the search term.
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A smart bookmark folder based on your browsing history dynamically changes
as you surf the Web. Every time you browse a site that matches the search
term, it gets “added” to your smart bookmark. For this reason, it is recommend-
ed to use search terms as specific as possible. If you are interested in links to
SUSE Linux specific topics as opposed to general Linux topics, use SUSE Linux
rather than Linux.

WARNING

Clearing the private data also deletes the browsing history (unless configured
otherwise) and so will also clear history based smart bookmarks!

20.3.6 The Bookmarks Toolbar
The Bookmarks Toolbar is displayed beneath the location bar and lets you
quickly access bookmarks. You can also add, organize, and edit bookmarks directly.
By default theBookmarks Toolbar is populatedwith a predefined set of bookmarks
organized in several folders (see Figure 20.1, “The Browser Window of Firefox”
(page 184)).

To manage the Bookmarks Toolbar you can use the library as described in Sec-
tion 20.3.1, “Organizing Bookmarks” (page 189). Its content is located in the Bookmarks
Toolbar Folder. It is also possible to manage the toolbar directly. To add a folder,
bookmark, or separator, right-click on an empty space in the toolbar and choose the
appropriate entry from the pop-up menu. For adding the current page to the bar use
drag and drop: left-click on the Web page's icon in the location bar and drag it to the
desired position on the bookmarks toolbar while holding the mouse button pressed.
Hovering over an existing bookmark folder for a short while will automatically open
it, enabling you to place the bookmark within this folder.

To manage a certain folder or bookmark, right-click on it. A pop-up menu opens which
lets you Delete it or change its Properties. To move or copy an entry, choose Cut, or
Copy and Paste it to the desired position.
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20.4 Using the Download Manager
Keep track of your current and past downloads with the help of the download manager.
It automatically opens every time you download a file. To manually start the download
manager, click Tools > Downloads. While downloading a file, a progress bar indicates
the download status. If necessary, pause the download and resume it later. To open a
downloaded file with the associated application, click Open. To open the location to
which the file was saved, choose Open Containing Folder. Remove From List only
deletes the entry from the download manager, it does not delete the file from the hard
disk.

By default all files are downloaded to your desktop. To change this behavior, open the
download manger's configuration window from Edit > Preferences and go to theMain
tab. In the Download area, either choose another default location or Always Ask Me
Where to Save Files.

TIP: Resuming Downloads

If your browser crashes or is closed while downloading, all pending downloads
will automatically be resumed in the background when starting Firefox the next
time. A download that was paused before the browser was closed can manually
be resumed via the download manager.

20.5 Security
Since browsing the Internet has become more risky, Firefox offers various measures
to make browsing safer. It automatically checks whether you are trying to access a site
known to contain harmful software (malware) or a site known to steal sensitive data
(phishing) and stops you from entering these sites. The Instant Web Site ID lets you
easily check a site's legitimacy and a password manager as well as the pop-up blocker
offer additional security.

20.5.1 Instant Web Site ID
Firefox allows you to check the identity of a Web page with a single glance. The color
of the Web site's icon (also called favicon) in the location bar to the left of the address
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indicates which identity information is available and whether communication is encrypt-
ed or not:

Gray
The site does not provide any identity information and communication between
Web server and browser is not encrypted. This is fine as long as you do not exchange
sensitive information with this site. Most web sites will be “gray”.

Blue
A blue icon indicates that the domain has been verified by a certificate, so you can
be sure that you are really connected to the very site it claims to be. Communication
with a “blue” server is always encrypted.

Green
Any site with a green icon completely identifies itself by a certificate that ensures
a site is owned by the person or organization it claims to be. This is especially im-
portant when exchanging very sensitive data, for example when doing money
transactions over the Internet. In this case you can be only sure to be on your bank's
Web site when it sends complete identity information. Communication with a
“green” server is always encrypted.

To view detailed identity information, click the Web site's icon in the location bar. In
the opening pop-up click onMore Information... to open the Page Info Window. Here,
you can view the site's certificate and the encryption level as well as information about
stored passwords and cookies.

With the Permissions view you can set per-site permissions for image loading, pop-
ups, cookies and installation permissions. TheMedia view lists all images, background
graphics and embedded objects from a site and displays further information on each
item together with a preview. It also lets you save each individual item.
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Figure 20.4 The Firefox Page Info Window

20.5.2 Password Management
Every time you enter a username and a password on a Web site, Firefox offers to store
this data. A new toolbar on top of the page opens asking you whether you want Firefox
to remember the password. If you accept by clicking Remember, the password will be
stored on your hard disk in an encrypted format. Next time you access this site, Firefox
will automatically fill in the login data.

To review or manage your passwords, open the password manager by clicking Edit >
Preferences > Security > Saved Passwords.... The password manager opens with a list
of sites and their corresponding usernames. By default, the passwords are not dis-
played—click on Show Passwords to display them. Delete single or all entries from
the list using Remove or Remove All, respectively.
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To protect your passwords from unauthorized access, you can set a master password
that is required when managing or adding passwords. Open the Security tab on the
Preferences dialog and check Use a Master Password.

20.6 Customizing Firefox
Firefox can be customized extensively. You can not only change the way Firefox behaves
by altering its preferences, but also add additional functionality by installing extensions
or change the way it look and feels by installing new themes.With the Add-ons manager
Firefox offers a convenient way to manage extensions, themes and plugins.

20.6.1 Preferences
Firefox offers a wide range of configuration options available via Edit > Preferences,
see Figure 20.5, “The Preferences Window” (page 197). Each option is described in
detail in the online help, which can be accessed by clicking the Help button.

Figure 20.5 The Preferences Window
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Session management
By default, Firefox automatically restores your session—windows and tabs— only after
it has crashed or after a restart when having installed an extension. However, it can be
configured to restore a session every time it is started: Open the Preferences dialog as
described in Section 20.6.1, “Preferences” (page 197) and go to theMain tab. SetWhen
Firefox Starts: to Show My Windows and Tabs from Last Time.

When you have multiple windows open they will only be restored the next time when
you close all of them at once with File >Quit or with Ctrl +Q. If you close the windows
one by one, only the last window will be restored next time.

Clearing Private Data
When browsing the Web, Firefox always keeps track of your activities by storing your
browsing history, cookies, and form data as well as by caching Web sites you have
visited. Collecting and storing this data makes browsing more comfortable and faster.
However, when you for example use a public terminal, you might want to delete this
data. Select Tools > Clear Private Data or press Ctrl + Shift + Del and choose which
data to delete.

To automatically delete private data every time you close Firefox, open the Preferences
window as described in Section 20.6.1, “Preferences” (page 197) and go to the Privacy
tab. Check Always Clear My Private Data When I Close Firefox and choose which
data to delete by clicking the Settings... button.

Language Preferences for Web Sites
When sending a request to a Web server, the browser always sends the information,
which languages are preferred by the user. Web sites that are available in more than
one language and are configured to evaluate this language parameter will display their
pages in the language the browser requests. On openSUSE the preferred language is
preconfigured to use the same language as the desktop. To change this setting, open
the Preferences window as described in Section 20.6.1, “Preferences” (page 197), go
to the Content tab and Choose your preferred language.
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Spell Checking
When typing into multiple line input fields, Firefox by default spell-checks what you
type. Misspelled words are underlined red. To correct a word, right-click it and choose
the correct spelling from the context menu. Youmay also add the word to the dictionary
if it is correct.

To change or add a dictionary, right-click anywhere into a multi-line input field and
choose the appropriate option from the context menu. You may also disable spell-
checking for this input field here. If you want to globally disable spell checking, open
the Preferences window as described in Section 20.6.1, “Preferences” (page 197) and
go to the Advanced tab. Uncheck Check My Spelling As I Type.

20.6.2 Add-ons
Extensions let you personalize Firefox to exactly fit your needs. With the help of exten-
sions you can change Firefox's look and feel, enhance existing functionality (such as
the download manager or tabbed browsing), or add functions such as a blog editor, Bit
Torrent support or even a music player. Certain extensions also assist Web developers
while others increase security by dynamically blocking active contents. More than 5000
extensions are available for Firefox. With the add-ons manager you cannot only install
new extensions, but also disable, enable, or delete them. It also finds updates to installed
extensions.

If you do not like the standard look and feel of Firefox, install a new theme. Themes
do not change the functionality, only the appearance of the browser.

Installing Add-ons
To add an extension or theme, start the add-ons manager with Tools >Add-Ons. It opens
with the Get Add-Ons tab either displaying a choice of recommended add-ons or the
result of your last search. Use the Search All Add-Ons field to search for specific add-
ons. Click on an entry in the list to view a short description and a screenshot. Install
the add-on by clicking Add to Firefox... or open a Web page with detailed information
by clicking the Learn More link.
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Figure 20.6 Installing Firefox Extensions

If you just want to browse all available add-ons or would like to use advanced search
options, click Browse All Add-Ons. This opens the Firefox add-onsWeb page. To install
an extension, click on the Add to Firefox button on the page describing the add-on.

In order to activate freshly installed extensions or themes, Firefox needs to be restarted
via the Restart Firefox button in the add-ons manager. Restarting the browser with this
button ensures that the complete session will be restored.

Managing Add-ons
The Add-onsManager also offers a convenient interface to manage extensions, themes,
and plugins. Extensions can be enabled, disabled or uninstalled. If an extension is con-
figurable, its configuration options can be accessed via the Preferences button. In the
Themes tab you mayUninstall a theme or activate a different theme by clicking onUse
Theme. Pending extension or theme installations are also listed. Select Cancel to stop
the installation. Although you cannot installPlug-Ins as a user, youmay disable or enable
them with the Add-ons manager.

Actions like uninstalling or disabling an add-on require a browser restart. Every time
you perform such an action, the Restart Browser button is displayed in the add-ons
manager.
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20.7 Printing from Firefox
Before you actually print a Web page, you can use the print preview function to control
how the printed page will look like. Choose File > Print Preview. Configure paper size
and orientation per printer with File > Page Setup.

To print a Web page either choose File > Print or press Ctrl + P. The Printer dialog
opens. To print with the default options just click Print.

The Printer dialog also offers extensive configuration options to fine-tune the printout.
On the General tab, choose a printer, the range to print, the number of copies and the
order. Page Setup lets you specify the number of pages per side, the scaling factor as
well as paper source and type. You can also activate double-sided printing here if the
printer supports it. Control how frames, backgrounds, header and footer are printed on
the Options tab. You may also specify Job options, such as printing at a specific time,
and the Image Quality in this dialog.

20.8 For More Information
Get more information about Firefox from the official knowledge base available via F1.
More useful information is available from the following links:

Support forum: http://support.mozilla.com/forum
MainMenu reference:http://support.mozilla.com/kb/Menu+reference
Preferences reference:http://support.mozilla.com/kb/Options+window
Keyboard shortcuts: http://support.mozilla.com/kb/Keyboard
+shortcuts
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21Transferring Data From the
Internet
GNOME FTP (gFTP) is a multithreaded file transfer client. It supports FTP, FTPS
(control connection only), HTTP, HTTPS, SSH, and FSP protocols. Futhermore, it allows
to transfer files between two remote FTP servers via FXP. To start GNOME FTP, press
Alt + F2 and enter gftp.

Figure 21.1 GNOME FTP
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21.1 ASCII vs. Binary Transfers
There are two common ways of transferring files via FTP: ASCII and binary. ASCII
mode transfers files as text. ASCII files are .txt, .asp, .html, and .php files, for
example. Binarymode transfers files as raw data. Binary files are .wav, .jpg, .gif,
and mp3 files, for example.

To change the transfer mode, either click FTP > Binary or FTP > Ascii.

For FTP transfers, you can also choose FTP > Options, click the FTP tab, and select
the Transfer Files in ASCII Mode option.

21.2 Connecting to a Remote Server
To connect to a remote server, do the following:

1 In GNOME FTP, click Remote > Open URL.

2 Specify a URL to connect to, then enter a username and password.

Leave the username blank to log in as anonymous user.

3 Click Connect.

If connection was successful, a list of the files on the remote server appears in
the right part of the GNOME FTP window (the file list on the left side is your
local computer's directory of files). You can now upload and download files.

To bookmark a site you access frequently, click Bookmarks > Add Bookmark. Specify
a name for the bookmark, then click Add. The new bookmark is added to your list of
bookmarks.

21.3 Transferring Files
In the following figure, the file list on the right contains the remote server's directory
of files. The file list on the left side contains your local computer's directory of files
(on your hard drive or network).
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Figure 21.2 gFTP File Transfer

To download files, select the files you want to download in the remote list of files, then
click the left arrow button. The progress of each download is listed in the field in the
middle of the window. If the transfer is successful, the files appear in the directory
listing on the left.

To upload a file, select the files you want to upload in your local directory listing on
the left, then click the right arrow button. The progress of each download is listed in
the field in the middle of the window. If the transfer is successful, the files appear in
the remote directory listing on the right.

To modify preferences for your downloads, click FTP > Options.

21.4 Setting Up an HTTP Proxy Server
To set up an HTTP proxy server, do the following:

1 In GNOME FTP, click FTP > Options, then select the FTP tab.

2 Choose HTTP Proxy from the Proxy Server Type drop-down list, then specify
your proxy server information in that dialog box.
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3 Click the HTTP tab, and enter the same proxy server information as above in
that dialog box.

4 Click OK.

21.5 For More Information
You can find more information about gFTP at http://www.gftp.org.
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22Manipulating Graphics with
The GIMP
The GIMP (The GNU Image Manipulation Program) is a program for creating and
editing raster graphics. In most aspects, its features are comparable to those of Adobe
Photoshop and other commercial programs. Use it to resize and retouch photographs,
design graphics for Web pages, create covers for your custom CDs, or almost any other
graphics project. It meets the needs of both amateurs and professionals.

Like many other Linux programs, The GIMP is developed as a cooperative effort of
developers worldwide who volunteer their time and code to the project. The program
is under constant development, so the version included in your system may vary
slightly from the version discussed here. The layout of the individual windows and
window sections is especially likely to vary.

The GIMP is an extremely complex program. Only a small range of features, tools, and
menu items are discussed in this chapter. See Section 22.7, “For More Information”
(page 224) for ideas of where to find more information about the program.

22.1 Graphics Formats
There are two main types of graphics—raster and vector. The GIMP is intended for
working with raster graphics, which is the normal format for digital photographs or
scanned images. Raster image is a collection of pixels—small blocks of color that to-
gether create the entire image. High resolution images contain large number of pixels
and image files can easily become quite large because of this. It is also not possible to
increase the size of a pixel image without losing quality. The GIMP supports all the
common formats of raster graphics, like JPEG, PNG, GIF, BMP, TIFF, and more.
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Unlike raster graphics, vector graphics do not store information for all individual pixels.
Instead, it uses geometrical primitives such as points, lines, curves, and polygons.
Vector images can be scaled very easily and image files can be smaller. The disadvanage
of vector graphics is that it is not good at representing complex images with many colors
such as photographs. There are many specialized applications for vector graphics, for
example Inkscape. The GIMP has only a very limited support for vector graphics. For
example, the GIMP can open and rasterize vector graphics in SVG format or work with
vector paths.

The GIMP 2.4 has still supports only limited selection of color spaces. It supports in-
dexed images and grayscale or RGB images with 8 bits per channel (24 bits per pixel
in RGB images without alpha channel). Many high-end digital cameras can produce
image files with higher color depths. If you import such an image to the GIMP, you
will loose some color information.

22.2 Starting The GIMP
Start The GIMP from the main menu. Alternatively, enter gimp & in a command line.

22.2.1 The Default Windows
Three windows appear by default. They can be arranged on the screen and, except the
toolbox, closed if no longer needed. Closing the toolbox closes the application. In the
default configuration, The GIMP saves your window layout when you exit. Dialogs
left open reappear when you next start the program.

The Toolbox
Themain window of The GIMP, shown in Figure 22.1, “TheMainWindow” (page 211),
contains the main controls of the application. Closing it exits the application. At the
very top, the menu bar offers access to file functions, extensions, and help. Below that,
find icons for the various tools. Hover the mouse over an icon to display information
about it.
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Figure 22.1 The Main Window

The current foreground and background color are shown in two overlapping boxes. The
default colors are black for the foreground and white for the background. Click the box
to open a color selection dialog. Swap the foreground and background color with the
bent arrow symbol to the upper right of the boxes. Use the black and white symbol to
the lower left to reset the colors to the default.

To the right, the current brush, pattern, and gradient are shown. Click the displayed one
to access the selection dialog. The lower portion of the window allows configuration
of various options for the current tool.

Under the toolbox, a dialog shows options for the currently selected tool. If it is not
visible, open it by double-clicking the tool's icon in the toolbox.

Layers, Channels, Paths, Undo
In the first section, use the drop-down box to select the image to which the tabs refer.
By clicking Auto, control whether the active image is chosen automatically. By default,
Auto is enabled.

Layers shows the different layers in the current images and can be used to manipulate
the layers. Information is available in Section 22.5.6, “Layers” (page 222). Channels
shows and can manipulate the color channels of the image.

Paths are a vector-based method of selecting parts of an image. They can also be used
for drawing. Paths shows the paths available for an image and provides access to path
functions. Undo shows a limited history of modifications made to the current image.
Its use is described in Section 22.5.5, “Undoing Mistakes” (page 221).
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22.3 Getting Started
Although The GIMP can be a bit overwhelming for new users, most quickly find it easy
to use once they work out a few basics. Crucial basic functions are creating, opening,
and saving images.

22.3.1 Creating a New Image
To create a new image, select File >New or press Ctrl +N. This opens a dialog in which
to make settings for the new image. If desired, select a predefined setting called a
Template. To create a custom template, select File > Dialogs > Templates and use the
controls offered by the window that opens.

In the Image Size section, set the size of the image to create in pixels or another unit.
Click the unit to select another unit from the list of available units. The ratio between
pixels and a unit is set inResolution, which appears when theAdvanced Options section
is opened. A resolution of 72 pixels per inch corresponds to common screen display.
It is sufficient for Web page graphics. A higher resolution should be used for images
to print. For most printers, a resolution of 300 pixels per inch results in an acceptable
quality.

In Colorspace, select whether the image should be in color (RGB) or Grayscale. For
detailed information about image types, see Section 22.5.7, “ImageModes” (page 222).
In Fill With select the color the image is filled with. You can choose betweenForeground
Color and Background Color set in the toolbox,White or Transparency for a transparent
image. Transparency is represented by a gray checkerboard pattern. Enter a comment
for the new image in Comment.

When the settings meet your needs, press OK. To restore the default settings, press
Reset. Pressing Cancel aborts creation of a new image.

22.3.2 Opening an Existing Image
To open an existing image, select File >Open or press Ctrl +O. In the dialog that opens,
select the desired file. You can also press Ctrl + L and type directly the path to the desired
image. Then click Open to open the selected image or press Cancel to skip opening an
image.
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22.3.3 Scanning an Image
Instead of opening an existing image or creating a new one, you can scan one. To scan
directly from The GIMP, make sure that the package xsane is installed. To open the
scanning dialog, select File > Acquire > XSane: Device dialog.

Create a preview when the object to scan is smaller than the total scanning area. Press
Acquire preview in the Preview dialog to create a preview. If you want to scan only
part of the area, select the desired rectangular part with the mouse.

In the xsane dialog, select whether to scan a binary (black and white without shades of
gray), grayscale, or color image and the required scan resolution. The higher the reso-
lution you choose, the better is the quality of the scanned image. However, this also
results in a correspondingly larger file and the scanning process can take a very long
time at higher resolutions. The size of the final image (both in pixels and bytes) is shown
in the lower part of the dialog.

In the xsane dialog, use the sliders to set desired gamma, brightness, and contrast values.
These sliders are not available in binary mode. Changes are visible in the preview im-
mediately. Once all settings have been made, click Scan to scan the image.

22.3.4 The Image Window
The new, opened, or scanned image appears in its own window. The menu bar in the
top of the window provides access to all image functions. Alternatively, access the
menu by right-clicking the image or clicking the small arrow button in the left corner
of the rulers.

File offers the standard file options, such as Save and Print. Close closes the current
image. Quit closes the entire application.

With the items in the Viewmenu, control the display of the image and the image window.
New View opens a second display window of the current image. Changes made in one
view are reflected in all other views of that image. Alternate views are useful for mag-
nifying a part of an image for manipulation while seeing the complete image in another
view. Adjust the magnification level of the current window with Zoom. When Shrink
Wrap is selected, the image window is resized to fit the current image display exactly.
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22.4 Saving Images
No image function is as important as File > Save. It is better to save too often than too
rarely. Use File > Save as to save the image with a new filename. It is a good idea to
save image stages under different names or make backups in another directory so you
can easily restore a previous state.

When saving for the first time or using Save as, a dialog opens in which to specify the
filename and type. Enter the filename in the field at the top. For Save in folder, select
the directory in which to save the file from a list of commonly used directories. To use
a different directory or create a new one, open Browse for other folders. It is recom-
mended to leave Select File Type set to By Extension. With that setting, The GIMP de-
termines the file type based on the extension appended to the filename. The following
file types are frequently useful:

XCF
This is the native format of the application. It saves all layer and path information
along with the image itself. Even if you need an image in another format, it is
usually a good idea to save a copy as XCF to simplify future modifications. Infor-
mation about layers is available in Section 22.5.6, “Layers” (page 222).

PAT
This is the format used for The GIMP patterns. Saving an image in this format en-
ables using the image as a fill pattern in The GIMP.

JPEG
JPG or JPEG is a common format for photographs and Web page graphics without
transparency. Its compressionmethod enables reduction of file sizes, but information
is lost when compressing. It may be a good idea to use the preview option when
adjusting the compression level. Levels of 85% to 75% often result in an acceptable
image quality with reasonable compression. Saving a backup in a lossless format,
like XCF, is also recommended. If editing an image, save only the finished image
as JPG. Repeatedly loading a JPG then saving can quickly result in poor image
quality.

GIF
Although very popular in the past for graphics with transparency, GIF is less often
used now because of license issues. GIF is also used for animated images. The
format can only save indexed images. See Section 22.5.7, “ImageModes” (page 222)
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for information about indexed images. The file size can often be quite small if only
a few colors are used.

PNG
With its support for transparency, lossless compression, free availability, and in-
creasing browser support, PNG is replacing GIF as the preferred format for Web
graphics with transparency. An added advantage is that PNG offers partial trans-
parency, which is not offered byGIF. This enables smoother transitions from colored
areas to transparent areas (antialiasing).

To save the image in the chosen format, press Save. To abort, pressCancel. If the image
has features that cannot be saved in the chosen format, a dialog appears with choices
for resolving the situation. Choosing Export, if offered, normally gives the desired re-
sults. A window then opens with the options of the format. Reasonable default values
are provided.

22.5 Editing Images
The GIMP provides a number of tools for making changes to images. The functions
described here are those most interesting for home users.

22.5.1 Changing the Image Size
Once an image is scanned or a digital photograph is loaded from the camera, it is often
necessary to modify the size for display on a Web page or for printing. Images can
easily be made smaller either by scaling them down or by cutting off parts of them.
Making an image larger is much more problematic. Because of the nature of raster
graphics, quality is lost when an image is made larger. It is recommended to keep a
copy of your original image before scaling or cropping.

Cropping an Image
Cropping an image works like cutting the edges off a piece of paper. Select the crop
tool from the toolbox (it resembles a scalpel) or with Tools > Transform Tools > Crop
& Resize. Click a starting corner and drag to outline the area to keep.
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A small window opens with information about the starting point and the size of the se-
lected area. Adjust these values by clicking and dragging a corner of the crop box or
by adjusting the values in the window. From Selection adjusts the crop to fit the current
selection (selections are explained in Section 22.5.2, “Selecting Parts of Images”
(page 217)). Auto Shrink makes the crop smaller based on color changes in the image.

Press Cancel to abort the crop. Press Crop to crop the image. The results of Resize are
identical to those of Change Canvas Size, described in Section “Changing the Canvas
Size” (page 216).

Scaling an Image
Select Image > Scale Image to change the overall size of an image. Select the new size
by entering it inWidth or Height. To change the proportions of the image when scaling
(this distorts the image), click the chain icon to the right of the fields to break the link
between them. When those fields are linked, all values are changed proportionately
when the value in one of the fields is changed. Adjust the resolution with X resolution
and Y resolution.

Interpolation is an expert option that controls the scale method.When finished adjusting
the size, press Scale to scale the image. Reset restores the original values.Cancel aborts
the procedure.

Changing the Canvas Size
Changing the canvas size is like putting a mat around an image. Even if the mat is
smaller, the rest of the image is there, but you can only see part of it. If the mat is larger,
you see the original image with extra space around it. To do this, select Image >Canvas
Size.

In the dialog that opens, enter the new size. By default, the width and height maintain
the same proportions as the current image. To change this, click the chain icon.

After adjusting the size, determine how the existing image should be positioned in
comparison to the new size. Use the offset values or drag the box inside the frame at
the bottom. When satisfied with the changes, click Resize to change the canvas size.
Click Reset to restore the original values or Cancel to cancel the canvas resize.
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22.5.2 Selecting Parts of Images
It is often useful to perform an image operation on only part of an image. To do this,
the part of the image with which to work must be selected. Areas can be selected using
the select tools available in the toolbox, using the quick mask, or combining different
options. Selections can also be modified with the items under Select. The selection is
outlined with a dashed line, called marching ants.

Using the Selection Tools
The main select tools are rather easy to use. The paths tool, which can also be used for
more than selecting, is more complicated so is not described here. In the tool options
for the other select tools, use one of the icons in theMode row to determine whether
the selection should replace, be added to, be subtracted from, or intersect with an existing
selection.

Rect Select
This tool can be used to select rectangular or square areas. In the tool options, select
among Free Select, Fixed Size, and Fixed Aspect Ratio to control the shape and
size of the selection. To make a square selection in the free select mode, hold Shift
while selecting a region.

Ellipse Select
Use this to select elliptical or circular areas. The same options are available as with
rectangular selection. Holding Shift during selection produces a circle.

Free Select (Lasso)
Draw a selection area freehand with this tool by dragging the mouse over the image
with the left mouse button pressed. The end points will be connected with a straight
line when you release the tool. The area inside is then selected.

Fuzzy Select (Magic Wand)
This tools selects a continuous region based on color similarities. Set the maximum
difference between colors in the tool options dialog in Threshold.

By Color Select
With this, select all the pixels in the image with the same or similar color as the
clicked pixel. The maximum difference between colors can be set in the tool options
dialog in Threshold.
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Intelligent Scissors
Click a series of points in the image. As you click, the points are connected based
on color differences. Click on the first point to close the area. Convert it to a regular
selection by clicking inside it.

Using the Quick Mask
The quick mask is a way of selecting parts of an image using the paint tools. A good
way to use it is to make a rough selection using the intelligent scissors or the lasso
(freehand selection tool). Then activate the quick mask by pressing the small icon with
the dashed box in the lower left corner.

The quick mask displays the selection using an overlay of red. Areas shaded with red
are not selected. Areas appearing as they did before the mask was activated are selected.
To modify the selection, use the paint tools. Painting with white selects the painted
pixels. Painting with black deselects pixels. Shades of gray (colors are treated as shades
of gray) are a partial selection. Partial selection allows smooth transitions between se-
lected and unselected areas.

To use a different color for displaying the quickmask, right-click the quickmask button
then select Configure Color and Opacity from the menu. Click the colored box in the
dialog that opens to select a new color.

After using the paint tools to adjust the selection as desired, convert from the quick
mask view back to the normal selection view by clicking the icon in the lower left corner
of the image window (currently displaying a red box). The selection is again displayed
with the marching ants.

22.5.3 Applying and Removing Color
Most image editing involves applying or removing color. By selecting a part of the
image, limit where color can be applied or removed. When you select a tool and move
the cursor onto an image, the cursor's appearance changes to reflect the chosen tool.
With many tools, an icon of the current tool is shown along with the arrow. For paint
tools, an outline of the current brush is shown, allowing you to see exactly where you
will be painting in the image and how large an area will be painted.
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Selecting Colors
Paint tools use the foreground color. To select the color, first click the display box of
the foreground color. A dialog with four tabs opens. These tabs provide different color
selection methods. Only the first tab, shown in Figure 22.2, “The Basic Color Selector
Dialog” (page 219), is described here. The new color is shown inCurrent. The previous
color is shown in Old.

Figure 22.2 The Basic Color Selector Dialog

The easiest way to select a color is using the colored areas in the boxes to the left. In
the narrow vertical bar, click a color similar to the desired color. The larger box to the
left then shows available nuances. Click the desired color. It is then shown in Current.
If that color is not what you want, try again.

The arrow button to the right of Current enables saving a number of possible colors.
Click the arrow to copy the current color to the history. A color can then be selected
by clicking it in the history. A color can also be selected by directly entering its hex-
adecimal color code in HTML Notation.

The color selector defaults to selecting a color by hue, which is usually easiest for a
new user. To select by saturation, value, red, green, or blue, select the corresponding
radio button to the right. The sliders and number fields can also be used to modify the
currently selected color. Experiment a bit to find out what works best for you.

When the desired color is shown in Current, click OK. To restore the original values
shown when the dialog was opened, click Reset. To abort changing the color, click
Cancel.
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To select a color that already exists in your image, use the color picker tool, the icon
for which resembles an eye dropper. With the tool options, set whether the foreground
or background color should be selected. Then click a point in the image that shows the
desired color. When the color is right, click Close to close the tool's dialog.

Painting and Erasing
To paint and erase, use the tools from the toolbox. There are a number of options
available to fine-tune each tool. Pressure sensitivity options apply only when a pressure-
sensitive graphics tablet is used.

The pencil, brush, airbrush, and eraser work much like their real-life equivalents. The
ink tool works like a calligraphy pen. Paint by clicking and dragging. The bucket fill
is a method of coloring areas of an image. It fills based on color boundaries in the image.
Adjusting the threshold modifies its sensitivity to color changes.

Adding Text
With the text tool, easily add text to an image. With the tool options, select the desired
font, font size, color, justification, indent, and line spacing. Then click a starting point
in the image. A small dialog opens in which to enter your text. Enter single or multiple
lines of text then press Close.

The text tool creates text on a special layer. To work with the image after adding text,
read Section 22.5.6, “Layers” (page 222). When the text layer is active, it is possible to
modify the text by clicking in the image to reopen the entry dialog. Change the settings
by modifying the tool options.

Retouching Images—The Clone Tool
The clone tool is ideal for retouching images. It enables you to paint in an image using
information from another part of the image. If desired, it can instead take information
from a pattern.

When retouching, it is usually a good idea to use a small brush with soft edges. In this
way, the modifications can blend better with the original image.

To select the source point in the image, press and hold Ctrl while clicking the desired
source point. Then paint with the tool as usual. When you move the cursor while

220 Application Guide



painting, the source point, marked by a cross, moves as well. If the Alignment is set to
Non Aligned (the default setting), the source resets to the original when you release the
left mouse button.

22.5.4 Adjusting Color Levels
Images often need a little adjusting to get ideal print or display results. In many programs
designed for inexperienced users, the brightness and contrast levels are modified. This
can work and is also available in The GIMP, but better results can be obtained by ad-
justing the color levels.

To do this, select Layer > Colors > Levels. A dialog opens for controlling the levels in
the image. Good results can usually be obtained by clicking Auto. To make manual
adjustments to all channels, use the dropper tools in All Channels to pick areas in the
image that should be black, neutral gray, and white.

To modify a channel individually, select the desired channel in Channel. Then drag the
black, white, and middle markers in the slider in Input Levels. Alternatively, use the
dropper tools to select points in the image that should serve as the white, black, and
gray points for that channel.

If Preview is checked, the image window shows a preview of how the image would
look with the modifications applied. When the desired result is achieved, press OK to
apply the changes. With Reset, restore the original settings. Cancel aborts level adjust-
ment.

22.5.5 Undoing Mistakes
Most modifications made in The GIMP can be undone. To view a history of modifica-
tions, use the undo dialog included in the default window layout or open one from the
toolbox menu with File > Dialogs > Undo History.

The dialog shows a base image and a series of editing changes that can be undone. Use
the buttons to undo and redo changes. In this way, you can work back to the base image.
If you undo a modification then make a new one, the undone modification cannot be
redone.
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Changes can also be undone and redone with the Edit menu. Alternatively, use the
shortcuts Ctrl + Z and Ctrl + Y.

22.5.6 Layers
Layers are a very important aspect of The GIMP. By drawing parts of your image on
separate layers, change, move, or delete those parts without damaging the rest of the
image. To understand how layers work, imagine an image created from a stack of
transparent sheets. Different parts of the image are drawn on different sheets. The stack
can be rearranged, changing which parts are on top. Individual layers or groups of layers
can shift position, moving sections of the image to other locations. New sheets can be
added and others set aside.

Use the Layers dialog to view the available layers of an image. The text tool automati-
cally creates special text layers when used. The active layer is highlighted. The buttons
at the bottom of the dialog offer a number of functions. More are available in the menu
opened when a layer is right-clicked in the dialog. The two icon spaces before the image
name are used for toggling image visibility (eye icon when visible) and for linking
layers. Linked layers are marked with the chain icon and moved as a group.

Only layers with transparency (an alpha channel) can be placed above other layers in
a stack. To add this to a layer, right-click and select it from the menu.

22.5.7 Image Modes
The GIMP has three image modes—RGB, Grayscale, and Indexed. RGB is a normal
color mode and is the best mode for editing most images. Grayscale is used for black-
and-white images. Indexed limits the colors in the image to a set number. It is mainly
used for GIF images. If you need an indexed image, it is normally best to edit the image
in RGB then convert to indexed right before saving. If you save to a format that requires
an indexed image, The GIMP offers to index the image when saving.

22.5.8 Special Effects
The GIMP includes a wide range of filters and scripts for enhancing images, adding
special effects to them or making artistic manipulations. They are available in Filters
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and Script-fu. Experimenting is the best way to find out what is available. Xtns in the
toolbox includes a number of items for creating buttons, logos, and other things.

22.6 Printing Images
To print an image, selectFile > Print from the imagemenu. If your printer is configured
in the system, it should appear in the list. In some cases, it may be necessary to select
an appropriate driver with Setup Printer. Select the appropriate paper size withMedia
Size and the type inMedia Type. Other settings are available in the Image / Output
Settings tab.

Figure 22.3 The Print Dialog

In the bottom portion of the window, adjust the image size. Press Use Original Image
Size to take these settings from the image itself. This is recommended if you set an ap-
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propriate print size and resolution in the image. Adjust the image's position on the page
with the fields in Position or by dragging the image in Preview.

When satisfied with the settings, press Print. To save the settings for future use, instead
use Print and Save Settings. Cancel aborts printing.

22.7 For More Information
The following resources are very useful for users of The GIMP. They contain much
more information about The GIMP than this chapter. If you want to use The GIMP for
more advanced tasks, you should not miss these resourses.

• http://www.gimp.org is the official home page of The GIMP. News about
The GIMP and related software are regularly posted on the frontpage.

• Help provides access to the internal help system including extensive GIMP User
Manual. The package gimp-help has to be installed. This documentation is also
available online in HTML and PDF formats at http://docs.gimp.org.
Translations into many languages are available.

• A collection of many interesting GIMP tutorials is maintained at http://gimp
.org/tutorials/. It contains basic tutorials for complete begginers as well
as tutorials for advanced or expert users.

• Printed books about The GIMP are published regularly. You will find selection of
the best ones with short annotations at http://gimp.org/books/.

• GIMP functionality can be extended with scripts and plug-ins. Many such scripts
and plug-ins are distributed in the GIMP package, but other can be downloaded
from the Internet. Athttp://registry.gimp.org/, you will find a database
of GIMP scripts and plug-ins.

You can also use mailing lists or IRC channels to ask questions about The GIMP. Please
always try to find answer in documentation mentioned above or in mailing list archives
before asking your question. The time of experienced users present on GIMP lists and
channels is limited and it is better spent on answering questions that are not covered in
available documentation. Be polite and patient. It may take some time before your
question is answered. And don't ask to ask, just ask.
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• There is number of mailing lists about The GIMP. You will find them at http://
gimp.org/mail_lists.html. The GIMP User list is the most appropriate
to ask user questions in. If you do not want to subscribe to the list but want to read
its archives, visit http://lists.xcf.berkeley.edu/lists/
gimp-user/.

• There is a whole IRC network dedicated to The GIMP and GNOME desktop envi-
ronment—GIMPNet. You can connect to GIMPNet with your favourite IRC client
by pointing it at irc.gimp.org server. The #gimp-users channel is the right place to
ask question about using The GIMP. If you want to listen to developer's discussion,
join the #gimp channel.
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23Managing Your Digital Image
Collection
Managing digital photographs in Linux is very straightforward. KDE's digiKam
downloads your images directly from your camera. It helps you organize andmanipulate
your images to get the best possible result to present to others. The application includes
several useful plug-ins that can convert your images to various different formats. Image
improvement plug-ins also include red eye reduction, speck removal and hot pixel re-
moval. Various filter and effect plug-ins help create little works of art from your digital
images.

Start digiKam from the main menu or by pressing Alt + F2 and entering digikam. On
start-up, digiKam shows a window with two main areas: a list of your albums to the
left and the images in the current album to the right. See Figure 23.1, “TheMainWindow
of digiKam” (page 228). The rightmost edge of the window has a number of tabs attached
which can be used to display important information about your images or to manipulate
certain image-related data:

Properties
Use this tab to access properties assigned to your images, such as file properties
(permissions, ownership, modification date, etc.), image properties (dimensions,
file format, etc.), and photograph properties (basic model, exposure and aperture
information).

Metadata
Use this tab to access various kinds of metadata associated with your images, such
as EXIF and GPS, for example.
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Colors
Use this tab to access color management-related data and to analyze the histograms
associated with your images.

Comments/Tags
Use this tab to assign comments, tags or ratings to your images.

Tag Filters
Use Tag Filter to filter the amount of images displayed in the main view using
tagging information. For details about tagging in digiKam, refer to Section 23.4,
“Managing Tags” (page 231).

Figure 23.1 The Main Window of digiKam

23.1 Configuring Your Camera
To download images from your digital camera, simply connect the camera to the USB
port of your computer using the USB cable provided by the camera manufacturer. De-
pending on your camera model, you may need to switch your camera to a special data
transfer mode. Consult the camera's manual about this.

There are four possibilities for accessing the pictures on the camera:
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1. USB Mass Storage If your camera can be switched to a USB mass storage
device, select this option. After you connect the camera to the USB port of your
computer and turn the camera on, the new USB device is automatically detected
andmounted. KDE lets you select the action to take in the event of any such device
being mounted. You can choose to start digiKam or any other image viewing or
processing application whenever a device of this type is mounted.

2. PTP (Picture Transfer Protocol, also Known as PictBridge) If your camera
can be switched to PTP, select this option. Normally your camera is not automati-
cally mounted in PTP mode but can be accessed through digiKam.

3. Special Drivers and Gphoto2 If your camera neither supports USB mass
storage nor PTP, try the special drivers provided by gphoto2, see Section 23.10,
“Troubleshooting” (page 247)

4. CardReaders Nowadays cameras can use different non-volatile memory cards,
for example SD memory card, compact flash (CF), memory stick, to name a few.
Some new computers have a card reader on board with different slots, to support
all these formats. If you do not want to deal with cabels, protocols, or drivers, select
this option as it simplifies a lot. Normally, card readers are detected as removeable
devices and are automatically mounted in KDE.

To set up a camera in digiKam, select Import > Camera > Add Camera. First, try to
detect the camera automatically with Auto-Detect. If this fails, browse the list of sup-
ported cameras for your model with Add. If your camera model is not included in the
list, try an older model or use USB/IEEE mass storage camera and confirm with OK.

23.2 Downloading Pictures from the
Camera

To download images from a camera that has been correctly configured, attach the
camera to your computer and select the camera from theCameramenu. digiKam opens
a window and begins to download thumbnails and display them as in Figure 23.2,
“Downloading Pictures from a Camera” (page 230). Right-click an image to open a pop-
up menu with the options to View the image, to Download, or Delete the image. Select
the Settings tab to the right of the download window to rename the image files using
Renaming Options. Review the EXIF data associated with the selected image using the
Metadata tab.
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Figure 23.2 Downloading Pictures from a Camera

TIP: Renaming Images

Mass renaming of your images comes in handy if your camera's filenames are
not meaningful enough for your purpose. Provide a unique prefix, add an op-
tional date, and let digiKam provide a sequence number.

Select all images to download from the camera by pressing the left mouse button or by
clicking individual images with Ctrl pressed or by using one of the select modes provided
by the Imagesmenu at the bottom of the download window. ClickDownload and select
the destination from the list or create a new albumwithNew Album, which automatically
suggests a filename with the current date. Confirm with OK to start the download pro-
cess.

TIP: Downloading Images from the Storage Medium

To save your camera's battery power, you can also attach a USB hub to your
computer providing an appropriate slot for your storage medium and download
the files from there. Once the USB hub is connected to your computer, the
KDE media handler dialog opens and offers to download the images from the
medium you attached.
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23.3 Managing Albums
digiKam creates a folder calledMy Albums by default to hold all of your images. You
can move your images to subfolders later. The albums can be sorted by directory layout,
by collection name set in the album properties, or the date that the albums were first
created (this date can also be changed in the properties of each album).

To create a new album, use one of these methods:

• Upload new images from the camera and create the target album on-the-fly during
the download.

• Create a new album by selecting theMy Albums entry first and then Album > New
Album from the main menu.

• Import an existing folder of images from your hard disk (select Import > Add
Folders...).

• Right-clickMy Albums and select New Album.

Once you have chosen to create a new album, provide some basic administrative infor-
mation about the new album, such as an album title. Optionally, choose a collection,
insert some comments, and select an album date. Collections are a way of organizing
your albums by a common label. This label is used when you select View > Sort Albums
> By Collection. The comment is shown in the banner at the top of the main window.
The album date is used when you select View > Sort Albums > By Date.

digiKam uses the first photograph in the album as the preview icon in theMy Albums
list. To select a different one, right-click the respective photograph and select Set as
Album Thumbnail from the context menu.

23.4 Managing Tags
Managing lots of different images across various albums can be a nightmare. Tomanage
your images by custom categories and across albums, digiKam provides theMy Tags
system. Tags categorize images and more than one tag can be assigned to an image.
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For example, assume that you took several pictures of your friend, Joe, and distributed
them across various albums. Now you are looking for an easy way to generate an
overview of all pictures ever taken of Joe. Using digiKam's tags, proceed as follows
for this scenario:

1 Select Tag > New Tag in the upper menu bar and enter a name for the new tag,
in this case Joe.

The dialog box allows you to create hierarchical tags, too. For example, to have
a Joe tag which is underneath a People tag, insert People/Joe into the text
field. Provide an optional icon and leave this dialog with OK.

2 Go to each album and tag all images showing Joe by right-clicking the image
and selecting Assign Tag > Joe.

If you need to process a huge number of images, an easier way to do the tagging would
be using the Captions/Tags tab from the tab bar at the right edge of the main window.
This interface allows you to assign tags to this image, enter an optional descriptive
comment, and rate this image.When you are done with the first image, stay in this dialog,
click the right arrow button, and click Apply when finished to apply your settings. Do
it with all your images of this album. Proceed similarly with all other albums and images.

To retrieve all images in your entire collection that carry a certain tag (in this case Joe),
proceed as follows:

1 Open the Tags tab in the left tab bar.

2 Unfold theMy Tag item.

3 Select the Joe tag.

As a result, all images in your entire collection carrying this tag are displayed.
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Figure 23.3 Display Tagged Images Only

The Tag Filter in the rightmost edge of the main window limits the number of images
displayed for the current album to those marked by the tag or tags selected here.

23.5 Creating Powerful Search Filters
Any image collection soon becomes unmanageable if you do not find a means to search
for the images you need and find them without much of a hassle. To help you organize
your collection, digiKam offers you two search options:

Simple Search
A basic search. Select Tools > Search and enter a text string that might be associated
with your image (image or tag name or comment) and hit OK. You can save this
search for future use and edit other existing searches listed under Searches on the
left edge of your digiKam window.

Advanced Search
Complex search filter. Select Tools > Advanced Search, set up complex rules using
any image property (album, tag, rating, date, etc.) and combine these options as
needed. You can save your search filter for future use and edit other existing
searches listed under Searches.
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The following example illustrates how to create an Advanced Search using rating or
tag information to search for images:

1 Select Tools > Advanced Search from the main menu.

2 Select the first search criterion. In this case, selectRating+Equals+5 Stars
to search for all images that have been rated with five stars.

3 In the Add/Delete Option section, select Or and click Add. A new search rule is
added below the existing one.

4 Select the second search criterion. In this case, select Tag+Equals+Filters
to search for all images that have been tagged with a tag named Filters.

5 Add other search criteria if needed, group criteria, or delete them. The results of
your search are displayed in the search window.

6 To save the search for future use, specify a name for this search and leave the
Advanced Search dialog with OK.

Figure 23.4 Creating an Advanced Search Filter

23.6 Exporting Image Collections
digiKam provides several export options that help archive and publish your personal
image collections. It offers archiving to CD or DVD (with k3b), HTML export, and
export to a remote gallery.
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To save your image collection to CD or DVD, proceed as follows:

1 Choose the album you want to export and select Export > Archive to CD/DVD.

2 Make your adjustments in the Create CD/DVD Archive dialog using its various
submenus.

2a With Album Selection, determine which part of your collection should be
archived by selecting albums and tags.

2b InHTML Interface, decide whether your image collection should be accessi-
ble through an HTML interface and whether automatic run functionality
should be added to your CD or DVD archive. Set a selection title and image,
font, and background properties.

2c Change the settings for the volume description inMedia Volume Descriptor,
if necessary.

2d Adjust the burning options to your needs inMedia Burning, if necessary.

3 Click OK to initiate the burning process.

To create an HTML export of your image collection, proceed as follows:

1 Select Export > HTML Gallery.

2 Determine which part of your collection should be archived by selecting albums
or tags in Collection and click Next.

3 Use Theme dialog to set the title and appearance of your HTML gallery and click
Next.

4 Specify size, compression and file type for the thumbnails used for gallery navi-
gation in Image Settings and click Next.

5 Determine the location of the gallery on disk with Output and click Finish.

To export your collection to an external image gallery on the Internet, proceed as
follows:
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1 Get an account for an external Web site to host your gallery.

2 SelectExport >Remote Gallery Sync and provide URL, username, and password
for the external site when asked for them. digiKam establishes a connection to
the site specified and opens a new window called Gallery Export.

3 Determine the location of your new album in the gallery.

4 Click New Album and provide the information requested by digiKam.

5 Upload the images to the new album with Add Photos.

23.7 Viewing and Editing Images
digiKam comes with a comprehensive image viewing and editing suite consisting of
various plug-ins. To enter digiKam's viewing or editing mode, right-click an image
thumbnail and select View or Edit from the context menu. To use the plug-ins, you need
to install the digikamimageplugins package.

To view one or more images you have the following options:

• To view a single image, browse to your album or collection and click on your image
to display it. Another click brings you back to the previous view.

• To start a slide show with all images, use View > Slide > All.

• To start a slide show with selected images only, hold down the Ctrl key, select your
images, and choose View > Slide > Selection.

To edit a selected image, useEdit from themainmenu. It opens a windowwhich contains
some of the most frequently used basic editing options:

• Use the back/forward buttons to browse your album without having to go back to
the full album view.

• Use the undo/redo menus to selectively undo or redo certain operations.
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• Use the zooming options to zoom in or out or to fit the image view to the window
size you are using. Use the looking glass icon to selectively zoom into a particular
area of the image.

• Flip the image clockwise or counter-clockwise.

• Activate a slide show or full screen view of the selected image.

23.7.1 Applying Image Decorations
The editing mode contains more useful features. Use theDecoratemenu to superimpose
various kinds of graphics and text effects on your images without having to bother
about filters and their fine-tuning:

Apply Texture
Select the type of texture you want to apply to your image and determine how
prominent this texture should be (Relief). digiKam applies the texture and saves
the changes to the original copy of your image.

Add Border
Select the type of border. Depending on the type of border you have selected,
choose one or two colors to be used for the border and set the width of the border
around your image. digiKam creates the border and saves the changes to the original
copy of your image.

Insert Text
Enter the text you want to superimpose on the image, choose font, font style and
size. Select the text justification and decide whether the text should be rotated and
to what degree. Add an optional border and semi-transparency. digiKam adds your
text layer to the original image.

Template Superimpose
Just as you can superimpose any text on your image, you can also apply ready-
made templates to create funny greeting cards, posters and the like.
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23.7.2 Manipulating Color Settings
The Color menu allows you to manage all kinds of different color-related settings. Its
capabilities range from simple auto correction mechanisms to full-blown color manage-
ment via color profiles:

Auto Color Correction
If aiming for a straightforward color and exposure correction of your image, try
this option. Choose from various preset modes and apply the one that matches best.
Use the histograms to determine whether the result matches your needs.

Brightness/Contrast/Gamma
This tool offers a simple way of fixing over or underexposed images.

Hue/Saturation/Lightness
This tool helps you to optimize images that have been taken under very bright
lighting conditions and appear somewhat washed out. Bring color saturation back
to these images by manipulating the hue and saturation sliders. Depending on the
level of color, you might also want to adjust the lightness to prevent the image from
registering too dark. Of course, you can also use this tool to achieve the opposite
effect if you need to brighten up an image that has been taken at low light conditions
and contains far too much color saturation.

Color Balance
Depending on the lighting conditions under which an image was taken or the
quality of an image scan, the colors may appear somehow out of balance. Using
the color balance tool, you can try to shift the balance towards another end of the
color spectrum.

Invert
Invert the color values.

Black & White
Transform your color image into a black and white one. Use the Film, Lens Filters,
Tone, and Lightness to tweak the end product. The Film tab offers you to emulate
the effects various black and white films. To emulate color filters used with the
camera lens, use the Lens Filters tab. Note that you can only apply one filter at a
time. Using the Tone tab you can have your black and white image tinted in a par-
ticular way (sepia, for example).
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Depth
Determine the color depth (in bit). Transform 8-bit into 16-bit images and vice
versa.

Color Management
Color management via ICC color profiles helps you maintain color fidelity across
multiple output devices (camera, display, printer).

Levels Adjust
Use this option to control multiple levels and to check the resulting image in just
one tool. It lets you save the level settings you chose and thus enables you to apply
the same corrections to multiple images if needed. This comes in handy if you
know that your camera tends to use the same faulty color settings all the time and
you would like to be able to correct them with just a single click.

Color Effects
This tool offers a selection of color effects like edge finding, solarizing, etc.

White Balance
Every source of light registers differently on your digital camera's chip. Depending
on the light source, the color temperature tends to register either warmer (towards
the red end of the spectrum) or cooler (towards the blue end of the spectrum) than
standard daylight. Most cameras ship with preset white balance schemes that try
to compensate these effects. If the resulting images registers faulty, use the white
balance adjustment provided by digiKam. Either manipulate the color temperature
directly by using the Kelvin slider or choose one of the preset white balance
schemes.

Curves Adjust
This tool allows you to basically perform any operation available through the
Brightness/Contrast/Gamma and the Levels Adjust tools, but in one tool and using
free-function mapping. Therefore this tool is more powerful and flexible than the
other two, but it may take some time to get used to its handling.

Channel Mixer
The channel mixer tool provides an alternative way of converting colored images
to black and white. Using theMonochrome option and the channel sliders, you can
selectively determine how much each of the color channels contributes to the
overall image. The channel mixer option is much more flexible than the standard
conversion to black and white, because you can manage each color channel sepa-
rately.
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23.7.3 Fixing and Tweaking Your Images
Use the Enhance menu to address a number of common defects related to digital im-
agery:

Blur , Sharpen
Tweak the sharpness of your image or smooth it.

Red Eyes
Reduce or eliminate red eyes caused by use of a flash.

Inpainting
“Heal” defective areas of your image.

Noise Reduction
Remove artifacts, such as those caused by dust on your lens or sensor. Compensate
for pixel noise caused by high ISO settings of your digital camera and reduce noise
and artifacts in low quality scans.

Hot Pixels
Detect and erase problem pixels of your image caused by defective pixels of your
camera's sensor.

Lens Distortion
Compensate for barrel and pincushion distortion of your images caused by the use
of strong wide-angle or telephoto lenses.

Restoration
Provides an all-inclusive treatment to images suffering from all sorts of digital de-
fects, such as noise and scratches.

Vignetting
Compensates circular shades (vignettes) at the edges or in the center of your image
that were caused by the use of strong wide-angle or telephoto lenses.

To observe the functionality of the Fix options, look at Inpainting, for example. Assume
some dust or scratch on your lens ruined an image. To remove this kind of artifact,
proceed as follows:

1 Open your image.
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2 Use the mouse cursor to select the area to which to apply the fix.

3 Select Enhance > Inpainting or press Ctrl + E.

4 Determine the method to use to remove the artifact:

• Choose one of the preset options (Remove Small Artifact, Remove Medium
Artifact, or Remove Large Artifact) and proceed with Step 6.

• Set the filter parameters on your own. Proceed with Step 5.

5 If you opted against using any of the preset filters (in the Preset tab), open the
General and Advanced Settings tabs and adjust the settings to your needs.

6 Click OK to apply your settings and modify the image accordingly.

TIP: Creating and Reusing Your Own Filter Settings

If you need to use the same set of settings more than once, for example,
if a scratch on the lens ruined an entire series of images, create your set
of filter settings. Save them for later use by clicking Save As and saving
them to a text file. For subsequent images, open the Image Inpainting
dialog, click Load, then select the text file and apply the filter settings
with OK.

Figure 23.5 Using Inpainting to Remove Artifacts
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23.7.4 Applying Image Transformations
To scale or rotate an image, use the Transform menu:

Rotate, Flip, Free Rotation
Rotate your image to a certain degree. Rotate rotates by multiples of 90 degrees.
With Free Rotation, specify any angle you want.

Crop, Aspect Ratio Crop
Crop your image. Crop cuts to any rectangular selection on top of your image.
Aspect Ratio Crop crops the image following various sophisticated design principles.

Perspective Adjustment
Adjust the perspective of an image. For example, if you notice some odd angles in
shots containing vertical or horizontal lines, use this tool to set them right. Grab
any of the four handles to the corners of your image and move them as much as
needed. Use the Crop tool to remove the resulting black edges of your image and
to trim it down.

Shear
Shift one part of your image to one direction and the other to the opposite direction,
either horizontally or vertically. Specify the angles for vertical and horizontal shear
and use Crop to trim the resulting image.

Resize
Scale your image. Resize offers a simple interface allowing you to manipulate your
image size by pixel or percentage. Select whether to keep the aspect ratio. If you
select Restore photograph, you can fine-tune the algorithms used to on your resized
image and improve the quality of the end product. Note that this option might be
considerably slower than a simple resize operation.

Assuming you have an image that is otherwise perfect, but you are not entirely satisfied
with the composition yet or need to crop your image to match a certain paper format
for reproduction. In this case, use Aspect Ratio Crop and proceed as follows:

1 Open your image.

2 Select Transform > Aspect Ratio Crop.

3 Determine the orientation and aspect ratio to use:
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None
Specify a free crop of the image using the X, Width, and Y, Height sliders.

Custom
Select a custom ration of width versus height instead of using one of the
preset values.

X:Y Ratio
These ratios matchmost of the common paper sizes used to print photographs.
Pick the one that suits your purpose best.

Golden Ratio
A ratio (1:1.618) that is traditionally used by artists and architects to create
harmonious results.

Use theMax. Aspect button to set the crop area to the maximum possible size of
the ratio specified.

4 After determining the size of your crop selection, optionally apply compositional
rules to it. The Composition Guide helps to create a crop selection that results in
a visually pleasing image. Dotted lines are displayed that guide you to a better
composition of your image.

TIP: For More Information

For a comprehensive description of the options, refer to http://docs
.kde.org/stable/en/extragear-graphics/digikam/
using-kapp-imageeditor.html.

5 If the position of your crop does not follow the compositional rule to your satis-
faction, move it.

6 Click OK to apply your crop selection and trim your image.
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Figure 23.6 Creating a Custom Crop Using Aspect Ratio Crop

23.7.5 Applying Filters and Effects
You can select from a variety of basic effects and filters to apply to your images to give
them a more artistic or over-the-top look:

Raindrops
Apply raindrop effects to your image. Determine the size and number of the drops
and finally specify the degree of distortion caused by the drops (Fish eyes).

Infrared Film
Simulate the use of infrared film to achieve a slightly surreal effect. The result is
strikingly different from the original image. Add additional film grain and tweak
the sensitivity (ISO) to achieve a more artistic feel.

Oil Paint
Simulate an oil painting. Determine the brush size and the degree of smoothing to
apply to your image.

Emboss
Pretend your image had been embossed to a sheet of paper. Choose an appropriate
depth.
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Distortion Effects
Apply various strange distortion effects, such as fish eyes, to your image. Determine
type, level, and repetition.

Add Film Grain
Add film grain to your image to give it a rough look.

Blur Effects
Blur your image to simulate the image being out of focus or to mimic any kind of
movement that was not there when you took the image.

Charcoal Drawing
Transform your image into a black and white charcoal drawing. Choose an appro-
priate pencil size and determine the degree of smoothing to apply to the image.

Figure 23.7 Simulating IR Photography

23.8 Useful Tools
digiKam offers several little helpers for organizing your image collection and for pro-
cessing your images. Find them in the Tools menu. Some highlights:

Find Duplicate Images
If you suspect your collection to contain a number of duplicates, use this option to
find and delete them. First, determine which album or tag to include in the scope
of your search. Click OK to initiate the search. If your collection contains any du-
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plicates, you get a split screen showing both images and can select one of them for
deletion to eliminate the duplicate.

Create Calendar
Create a simple calendar using a standard layout by just selecting the images to use
and by selecting paper size and fonts.

RAW Image Converter
digiKam supports converting images from various vendor-specific RAW formats
to common image formats such as JPEG or PNG. Using this option, convert single
images. If you need to convert several images, consider using a batch conversion
(Tools > Batch Processes > RAW Images Converter (Batch)). To find out whether
your camera's RAW format is supported by digiKam converter plug-in, check
http://www.cybercom.net/~dcoffin/dcraw/.

23.9 Batch Processing
If you need to perform certain actions on a large number of files at once, use batch
processing. Add borders, edit the colors, apply various effects and filters, rename and
resize images, recompress them, or perform a RAW conversion.

An example batch processing of images could involve applying a solarizing effect to
a number of images. To queue images for batch processing and perform the actual
processing, proceed as follows:

1 Select Batch > Image Effects or right-click the album's name and select Batch
Processes > Image Effects.

2 Set the effect to Solarize and click Options to determine the degree of the effect
to be applied and display an optional preview.

3 Determine whether to rename or overwrite the original images or even have them
removed after the transformation has taken place.

4 Set the target folder to hold the resulting images. If you do not want the new
images to be written to the original folder, select New and add a new folder or
subfolder. Select the new folder with your mouse pointer.

5 Accept or modify the list of images queued for the transformation.
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6 Click Start to initiate the transformation.

digiKam informs you about the progress and the success of the transformation.

Figure 23.8 Batch Processing: Solarizing Images

23.10 Troubleshooting
Although openSUSE and digiKam support a broad range of cameras, you might occa-
sionally hit one of the following problems when using your digital camera with open-
SUSE:

Downloading Images from Your Camera Fails
If downloading your images fails no matter which protocol you have chosen (PTP
or USB), try using the command line instead of digiKam. The gphoto2 --P
command initializes the camera and downloads the images if gphoto2 supports this
camera.
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Your Camera is not Officially Supported by digiKam
Try gphoto2 --list-cameras and the information at http://www
.gphoto.org/ to obtain more information about the status of your camera's
support by Linux.

If the camera is not listed there, remove the storage medium from the camera and
use a card reader device (either an external or internal one). As soon as the medium
is detected, it is mounted automatically and you can import the images to your
digiKam collection with Import > Add Images or Import > Add Folders.

23.11 For More Information
For more information about using digital cameras with Linux, refer to the following
Web sites:

• http://www.digikam.org>—The official homepage of digiKam

• http://docs.kde.org/development/en/extragear-graphics/
digikam/index.html—The official digiKam Handbook

• http://www.gphoto.org—Information about gPhoto2

• http://www.gphoto.org/proj/libgphoto2/support.php—A
comprehensive list of supported cameras
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24Managing Your Digital Image
Collection with F-Spot
F-Spot is a management tool for your collection of digital images tailored for the
GNOME desktop. It allows you to assign different tags to your images in order to cat-
egorize them and offers various image editing options. For example, you can remove
red-eye, crop, and adjust brightness and colors. F-Spot supports sixteen common file
types, including JPEG, BMP, GIF, TIFF, and RAW.

You can import photos from your hard drive, your digital camera, or your iPod. You
can also use F-Spot to create photo CDs, generate a Website gallery, or export your
photos to your Flickr, 23, Picasa Web, or SmugMug account.

To access F-Spot, click Computer > F-Spot Photo Browser. The first time you run F-
Spot, you can tell it where to find the images you want to import into your collection.
If you already have a collection of images stored on your hard drive, enter the path to
the respective directory and optionally include subfolders. F-Spot imports these images
into its database.
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Figure 24.1 F-Spot Main Window

Thumbnails of your images are displayed in the right part of the window, and detailed
information for a selected image is displayed in a sidebar to the left. By default, your
photos are displayed in reverse-chronological order, so your newest photos are always
at the top. You can sort your photos in chronological order or reverse-alphabetical order
by clicking View > Reverse Order.

A menu bar at the top of the window allows you to access the main menus. A toolbar
below the menu bar offers the following options:

Table 24.1 F-Spot Toolbar

DescriptionIcon

Use this shortcut to change an image's orientation.Rotate (Left or Right)

The Browse mode allows you to view and search your
entire collection or tagged subsets of it. You can also use
the time line to search images by creation date.

Browse

This mode allows you to select one image and do some
basic image processing. Details are available in Sec-
tion 24.7, “Basic Photo Editing” (page 261).

Edit Image
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DescriptionIcon

Switch to fullscreen display mode.Fullscreen

Start a slide show.Slideshow

24.1 Importing Photos
You can import photos from your hard drive or from your digital camera (see Sec-
tion 24.2, “Downloading Pictures fromYour Camera” (page 252) for more information).
F-Spot automatically makes copies of photos imported from your hard drive. If you
don’t want to copy images, uncheckCopy files to the Photos folder on the Import dialog
box, or press Shift when dragging photos into F-Spot.

Figure 24.2 Importing Images into F-Spot

By default, F-Spot copies your photos to the /Photos directory in your home directory.
You can change the directory F-Spot uses by clicking Edit > Preferences.

If all the photos you are importing are from a particular event, or if they have some
other characteristic in common, you can create a tag for them so you can easily find
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them at a later time. During the import, select Attach Tag, then choose the appropriate
tag from the drop-down menu.

To import photos:

1 Click File > Import.

2 Select an import source, then click Open.

3 After the photos are finished loading, click Import.

The photos are added to your catalog.

24.2 Downloading Pictures from Your
Camera

You can import new images from your digital camera by connecting it to the USB port
of your computer. The type of camera is detected automatically. When you import
photos from your camera, F-Spot makes copies of them so that you can clear your
camera's memory.

1 Click File > Import.

2 Select your camera as the import source.

F-Spot launches a preview window displaying all the images that are available
for download from your camera. The files are copied to the target directory
specified viaCopy Files to. If Import files after copy is selected, all images copied
from the camera are automatically imported to F-Spot's database. Tagging can
be done on import, if you select the appropriate tag with Select Tags. If you do
not want to import all images on your camera to your database, just deselect the
unwanted ones in the preview window.
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3 Click Copy.

4 When the photo transfer is complete, click OK.

The photos are added to your catalog.

24.3 Getting Photo Information
When you select an image, some basic statistical information is displayed in the lower-
left part of the window. This includes the filename, its version (copy or original image),
the date of creation, size, and the exposure used in creating this particular photo.

To viewmore detailed information on a photo, including the EXIF data associated with
the file, click View >Metadata Browser.
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Figure 24.3 F-Spot Metadata Browser

24.4 Managing Tags
Use tags to categorize any of your photos to createmanageable subsets of your collection.
F-Spot comes with default tags, but you can change them and add new ones. If, for
example, you want to organize your collection of portrait shots of your loved ones, do
the following:

1 Select the Browse mode of F-Spot.

2 In the left frame of the F-Spot window, right-click the People category, then select
Create New Tag.

2a Create a new tag called Friends.

2b Create a new tag called Family.

The new tags appear as subcategories below the People category.
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3 Attach tags to images or groups of selected images.

Right-click an image, select Attach Tag, then select the appropriate tag for this
image. To attach a tag to a group of images, click the first one, then press Shift
and select the other ones without releasing the Shift key. Right-click for the tag
menu and select the matching category.

You can also use the following methods to tag photos:

• Drag and drop a photo onto a tag.

• Drag and drop a tag onto the photo.

• Use the options on the Tags menu and the Edit menu.

• Select a photo, then press t to display the Tags entry bar.

The first photo you associate with a tag is used for that tag's icon. To edit a tag's name,
parent tag, or icon, right-click the tag, then select Edit Tag.

You can change a tag's parent by dragging and dropping it where you want. You can
also edit the name of a tag by selecting it and pressing F2.

After your photos have been tagged, you can browse your collection by tags. Using our
earlier example, clicking People > Family limits the displayed collection to the photos
tagged Family. Searching your collection by tag is also possible through Find > Find
Selected Tag. The result of your search is displayed in the thumbnail overview window.

Removing tags from single images or groups of images works similarly to attaching
them. The tag editing functions are also accessible on the Tags menu in the top menu
bar.

24.5 Searching and Finding Photos
Asmentioned in Section 24.4, “Managing Tags” (page 254), tags can be used as a means
to find certain images. Another way to find images is to use the Timeline below the
toolbar. By dragging the little frame along this time line, you can limit the images dis-
played in the thumbnail overview to those taken in a selected time frame. F-Spot starts
with a default time line, but you can edit the time span by moving the sliders to the
right and left of the time line.
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You can also start a search by clicking Find > Show Find Bar. With the find bar dis-
played, you can drag tags from the tag view to the find bar.

Figure 24.4 Show Find Bar in F-Spot

To find photos that are tagged with more than one tag, select the first tag in the tag view
(or drag the tag onto the Find bar), then drag the second tag and drop it on top of the
first. You can also right-click the second tag in the tag view, or click Find > Find Se-
lected Tag With, then select the first tag (or group of tags).

You can search for photos that don’t have a particular tag by double-clicking a tag in
the Find bar. Photos that don’t have that tag (or any tag at all) are displayed. You can
also right-click a tag in the Find bar, then select Exclude.

To remove a tag from the search, drag it away from the Find bar, or right-click the tag
and select Remove.

By default, photos tagged Hidden will not be shown. You must explicitly include the
Hidden tag in your search to show such photos.

There is also a type-to-find entry. Press the forward slash (/) to open it. It cannot be
used at the same time as the Find bar. You can type queries such as “TagA and (TagB
or (TagC and TagD))”. At any point, if F-Spot recognizes what you have typed as a
valid query, it will update your search. The not operator is not yet supported.
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Figure 24.5 Type-to-find Search

24.6 Exporting Image Collections
F-Spot offers a range of export functions for your photo collections:

• Section 24.6.1, “Generating a Website Gallery” (page 258)

• Section 24.6.2, “Exporting Photos to CD” (page 259)

• Section 24.6.3, “Exporting Photos to a Folder” (page 259)

• Section 24.6.4, “Posting to a Flickr, PicasaWeb Album, SmugMug, or 23 Account”
(page 260)
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24.6.1 Generating a Website Gallery
If you use the PHP software known as Gallery [http://gallery.sourceforge
.net], you can post your photos to your existing album. Ensure that the Remote
module in your Gallery installation is enabled (Site Admin > Plugins (Get More Plugins)
> Remote).

PennAve [http://pennave.sourceforge.net/] is another dynamic photo
gallery application. It is designed to be used in conjunction with F-Spot to organize and
manage your photos.

1 Select the photos you want to export.

2 Click File > Export > Export to Web Gallery.

3 Select a gallery you want to export your images to, or click Add to add a new
gallery.

F-Spot establishes a connection to theWeb location entered for your web gallery.

4 Select the album you want to export the images to, then specify whether to scale
the images automatically and export titles and comments.

5 Click OK.
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24.6.2 Exporting Photos to CD
1 Select the photos you want to burn to CD.

2 Click File > Export > Export to CD, then click OK.

F-Spot copies the files and opens the Write to Disc dialog box.

3 Assign a name to your image disk, then select the writing speed.

4 ClickWrite to start the CD writing process.

24.6.3 Exporting Photos to a Folder
1 Select the photos you want to export.

2 Click File > Export > Export to Folder.
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3 Choose from the following export methods:

Create standalone web gallery: Exports your photos to an interactive Web-
site, ready for you to upload.

Save the files only: Exports your photos as files within directories, without
putting them into a gallery.

Create gallery using “Original”: Exports your photos ready for use with
Jakub Steiner's Original Photo Gallery [http://jimmac.musichall.cz/
original.php] software.

4 Click OK.

24.6.4 Posting to a Flickr, Picasa Web
Album, SmugMug, or 23 Account

If you use Flickr [http://www.flickr.com/], Picasa Web Album [https://
www.google.com/accounts/ServiceLogin?hl=en_US&continue=
http://picasaweb.google.com/], SmugMug [http://www.smugmug
.com/], or 23 [http://www.23hq.com/], you can post your files directly from
F-Spot to your account.

1 Select the photos you want to export.
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2 ClickFile > Export > Export to Flickr, Export to Picasaweb, Export to SmugMug,
or Export to 23hq.

3 Select or unselect the options you want in the Export dialog box.

The options displayed on the Export dialog box depend on the type of account
you are exporting to. For example, Flickr and 23 exports require authorization
in order to upload photos. To do this, click Authorize to open a Web browser,
then log in to your account.

4 Click OK.

24.7 Basic Photo Editing
F-Spot offers several basic image editing functions, such as the ability to remove red-
eye, crop, and adjust colors and brightness.

When you edit a photo, a new copy (called a version) is created, so your original photo
is never altered. After your first edit to a photo, subsequent edits modify the same ver-
sion. If you want to create multiple versions of a photo (for example, with different
cropping or coloring), click File > Create New Version. To access a photo’s original
version, click File > Version > Original.

1 Select the photo you want to edit.

2 To enter edit mode, click the Edit Photo icon in the toolbar, double-click the
image, or press Enter.
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3 Choose from the following edit functions, using the toolbar below the photo or
items on the Edit menu:

DescriptionFunction

To adjust the brightness, contrast, and colors of a
photo, click the Adjust the photo colors icon to

Adjust Colors

open the adjustment dialog box. Change the set-
tings you want, then click OK.

This effect automatically adjusts color levels to
make a color-balanced picture. It works best for

AutoColor

pictures taken with automatic white balance. Click
the Automatically adjust the colors icon to access
this feature.

You can add a description or a comment to a photo
by clicking the text entry box below the photo and
entering text.

Comment

Converts the photo to black and white.Convert to Black and
White
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DescriptionFunction

Converts the photo to sepia tones.Convert to Sepia
Tones

Cropping an image is a great way to improve the
quality of a photograph by improving how it is

Crop

framed. You crop a photo by selecting the part of
the photo you want to keep. If you want your
photo to be the exact dimensions necessary for a
certain print size, you can constrain the kind of
selection F-Spot will allow you to draw by choos-
ing the appropriate size from the Constraint drop-
down list. See the description of the Remove Red-
Eye function for details on making a selection on
your photo.

After youmake your crop selection, click theCrop
icon beneath the photo to finalize the crop. If you
are working with the original photo, cropping
creates a new version of your photo.

To remove red-eye from a photo, select a zone
containing the eyes. You might want to zoom in

Remove Red-Eye

on the image to accurately select the eyes in the
photo. You should be able to correct both eyes on
the same person at once, or even the eyes from
multiple people at once. If this does not work, or
if the selected zone contains some vivid red parts
(such as lips), you will probably have to correct
one red eye at a time.

To make your selection, click one corner of the
rectangle that will be your selection, then drag
your mouse to the diagonal corner and release it.
You can resize your selection by dragging its
edges, and you can move it by clicking in the
middle of it and dragging it to where you want it.
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DescriptionFunction

After you have selected a zone, remove the red by
clicking the Red-eye icon beneath the photo.

Access this function by clicking Edit > Sharpen.
Adjust the values for Amount, Radius, and
Threshold to your needs, then click OK.

Sharpen

Sharpening one region of a picture while blurring
all the rest is a way to emphasize a particular area

Soft Focus

and grab attention. The soft focus effect is a way
to emulate a lens that allows shooting with a short
distance in front of and beyond the subject that
appears to be in focus.

Choose the central point of the area you want to
be in focus, then click the Soft Focus icon beneath
the photo. Adjust the amount of blurring, then click
Apply.

The Straighten effect helps you level a photo and
is useful when editing landscapes taken without aStraighten
tripod (when the imaginary line of horizon is not
at 0°). This tool rotates a photo by a specified angle
and automagically crops the resulted image so that
you always see a perfect rectangle.

4 (Optional) If you want to edit another photo, use the arrow keys at the bottom
right to switch to a new photo.

5 To exit the edit mode, click Browse on the toolbar.

TIP

Professional image editing can also be done with The GIMP. For more informa-
tion, see Chapter 22, Manipulating Graphics with The GIMP (page 209).
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24.8 Sharing Photos
You can use either of the following methods to share your photos using F-Spot. Both
methods share only the photos you have selected when you run them.

• Section 24.8.1, “E-mailing Photos” (page 265)

• Section 24.8.2, “Printing Photos” (page 266)

24.8.1 E-mailing Photos
You can e-mail your photos directly from F-Spot, sending them as-is (original size) or
resizing them.

1 Select the photos you want to e-mail.

2 Click File > Send Mail.

3 Select a size for your photos.

4 Click Create mail.

Your default e-mail program opens, with your photos attached to a new mail
message.
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24.8.2 Printing Photos
1 Select the photos you want to print.

2 Click File > Print.

3 Select the print options you want, such as the printer you want to use or the page
orientation, then click Print to print your photos.
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25Playing Music and Movies
During installation, YaST normally identifies and configures the sound cards of your
computer automatically. Otherwise (or if you installed a new sound card), start YaST
and configure the sound card manually in the Sound module. When your sound card
has been configured, you can control the volume and balance with a mixer and start
other sound applications.

Linux includes a wide range of sound and multimedia applications. Some of these ap-
plications are installed on your Linux system by default. With the applications described
here, control the volume and balance of playback and play CDs, music and movie files.
You can also record and compress your own audio data.

In case one of the listed applications is not installed by default on your system, use
YaST to install the missing packages. Use the search function of the YaST package
management tool to find the package names.

25.1 Mixers
Mixers provide a convenient means of controlling the volume and balance of the sound
output and input of computers. For a description of the default KDEmixer applet, refer
to FIXME .

The main difference between the various mixers is the outer appearance of the user in-
terface. However, there are a number of mixers that are designed for specific hardware.
From the mixers available, select the one that best suits your needs.
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TIP: Starting the Mixer

Generally, it is advisable to open a mixer application before opening other
sound applications. Use the mixer to test and adjust the control settings for
the input and output of the sound card.

25.2 Playing Music Files
In Linux, find a variety of programs for playing music files, such as Ogg Vorbis, or
WAV files. Ogg Vorbis is a free audio compression format that is now supported by
the majority of audio players and even portable MP3 players. The file types supported
by the applications depend on the engine used.

NOTE: Playing MP3 Files

openSUSE® also comes with MP3 support. If your music collection consists of
both MP3 and Ogg Vorbis files, you do not need to convert any files to a dif-
ferent format. Just open amaroK (KDE) and start listening.

25.2.1 amaroK Media Player
The amaroK music player allows you to play various audio formats, create playlists,
import music from removable media such as portable MP3 players or external hard
disks (or upload files to removable media), and listen to streaming audio broadcasts of
radio stations on the Internet. The file types supported depend on the engine used.

On first start, amaroK launches a First-Run Wizard, which helps set up amaroK. In the
first step, configure your preferred look and feel for amaroK. Choose to display player
and playlist in separate windows (see Figure 25.1, “The amaroK Media Player”
(page 269)) or combine their functionality in one single window (default). In the second
step, determine where amaroK should look for your music collection. amaroK scans
these folders for playable media. By default, amaroK is configured to scan the selected
folders recursively (to include all their subdirectories in the scan), monitor changes to
the content of the selected directories, and import any playlists located there. All the
settings made with the wizard can be modified later in the configuration dialog by se-
lecting Settings > Configure AmaroK.
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Figure 25.1 The amaroK Media Player

Quick Start
On start-up, amaroK scans the folders that are part of your collection for music files.
Although you can use amaroK without building a collection, it is recommended to do
so, because most of the powerful, advanced features are only available with an existing
collection.

The amaroK main window is divided into two parts. The sidebar on the left providing
different views: your music collection, a context browser, your playlists, a file browser,
etc. Change the browser by clicking a tab on the far left. The right part contains the
playlist window and, below it, the player (if you have not configured it to be shown in
a separate window).

To play music, just drag and drop items from any of the sidebar browsers to the playlist
area. Use Shift or Ctrl to select multiple items. Double-click an item in the playlist to
play it. You can add or delete items from the list during playback with the context menu.
Use the icons located above the playlist area to Clear the playlist, to Save playlist as,
to Undo and Redo changes or to Search for a certain track. To manipulate play modes,
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either click the Repeat or Random icons in the amaroK status bar several times to switch
mode or select the desiredMode from the main amaroK menu.

The Sidebar Browsers
Context

With this tab, view information and statistics related to the track currently being
played. Switch to different views within the Context browser by clicking the tabs
on top of the sidebar. For example, click Artist to make amaroK search for the ap-
propriate Wikipedia article, which is then displayed in the context browser. To
view a track's lyrics, click the Lyrics tab to start a search and display the results.
TheMusic tab shows the album cover, if available, (see Section “The Cover Man-
ager” (page 271)) and the listening statistics related to the current track.

Collection
Use this view to manage and display your personal collection of titles. The toolbar
on top of the browser allows you to configure the way your collection is displayed
and to reorganize the collection. Define the order your titles are displayed in the
browser withGroup By. You can choose between predefined criteria or create your
own sort criteria using Primary, Secondary, and Tertiary. The next four icons let
you toggle between tree view, flat view and iPod* view or Show dividers for better
overview in large music collections. Use the wrench icon to add or delete folders
amaroK should scan for music to add to your collection.

To search or filter your collection for a certain track or album, enter the title (or
part of it) in the search field at the top. Each character you enter narrows down the
search and the selection in the browser is adjusted as you type. To search for certain
metadata such as Genre or Bitrate or to combine several search options, click the
button to the right of the search field to open the Edit Filter dialog.

Playlists
You can access different playlists with the playlist browser. Playlists holds your
personal playlists found in your collection folders. Every time you create and save
a new playlist from the playlist window, it appears here. Right-click the Playlist
folder to create or import a new playlist or to add a subfolder. To add new items
from the playlist window to an existing playlist, just drag and drop them on the
playlist in the browser window.
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IMPORTANT: Sharing Playlists with Other Players

Save playlists in m3u format, so you can share them with any other players
using this format.

Smart Playlists offer various views of your collection, such as tracks never played,
newest tracks, or tracks by genre. For example, to create a random playlist from
your collection, select 50 random Tracks and drag the entry to the playlist area.
Right-click the Smart Playlists folder to add subfolders or to create your own smart
playlists.

Radio Streams lets you listen to live radio streams from the Internet. An extensive
list is already shipped with amaroK. Right-click to add more or create subfolders.

Podcasts imports podcasts to amaroK. Right-clicking opens a menu where you can
add podcasts and subfolders, refresh all podcasts, or set the scan interval.

Files
This tab opens a file browser which corresponds to the standard KDE file manager
dialog. Use the icons at the top to navigate the file system, change the view or to
create bookmarks. Enter a URL or a path directly into the text input field. From
the contents displayed, drag elements to the playlist to include them.

Magnatune
On this tab, you can establish a connection to the Magnatune store where you can
purchase music online. Click Update to view the available albums and titles at
magnatune.com. Sort the album list byGenre and listen to some tracks with amaroK.
To buy music, click Purchase Album and enter your payment details.

Devices
If you own portable MP3 players or external hard disks, use this browser to config-
ure your portable device and to access it from amaroK.

The Cover Manager
With amaroK, you can assign a cover to each album of your collection. With the Cover
Manager, easily add, delete, and retrieve album covers.

Start the cover manager with Tools > Cover Manager. A tree view in the left part of
the window lists all artists in your collection. The main part of the window lists the
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covers of all albums. To filter the covers displayed, click an individual artist in the tree
view or enter a term in the input field at the top of the window. Use View to toggle be-
tween displaying all albums, albums with covers, or albums without covers.

There are three different methods for assigning covers to the albums:

Automatically Assign Covers
amaroK can automatically fetch all missing covers displayed in the main windows
from Amazon. Use Amazon Locale to determine from which Amazon Web server
the covers should be fetched then click Fetch Missing Covers.

IMPORTANT: Proper Tagging Needed

amaroK fetches the covers from Amazon using the query string Artist
- Album. This information is extracted from the tags of your music files.
The better they are tagged, the better the hit rate is when automatically
fetching covers.

Manually Choose a Cover Fetched from Amazon
If you want more control over what image to use and what query string to use to
retrieve a cover, right-click an album in the main window and choose Fetch From
amazon.com. Next Cover lets you cycle through all images available. Save selects
the actual cover and assigns it to the album selected. If you are not satisfied with
the covers displayed, use New Search to refine the search. Use Amazon Locale
from the toolbar of the main window to determine from which Amazon Web
server the covers should be fetched.

Manually Assign Covers
If you already have your own cover images, you can assign them by right-clicking
an album and choosing Set Custom Cover.

Visualizations
If visualizations for amaroK are installed, you can select various graphical effects for
themusic playedwith Tools >Visualizations. Native amaroK visualizations are displayed
in the player window. Cycle through the various available display modes by clicking
the animation.
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The amaroK Tray Icon
Like other KDE applications, amaroK adds an icon to the KDE system tray. You can
use this icon to control a large number of amaroK's features. Hovering the mouse
pointer over the icon displays information about the track currently played, by scrolling
the mouse wheel simultaneously you can reduce or increase the playback volume. A
single left-click closes the application window without affecting playback. Click again
to reopen the window. Clickingwith themiddlemouse button pauses playback—middle-
click again to resume playback. Right-clicking opens a context menu where you have
access to the player controls and can exit amaroK.

Using the Shift and Ctrl keys together with the mouse gives you access to more advanced
features. Holding Shiftwhile scrolling the mouse wheel seeks through the current track.
Holding Ctrl while scrolling the mouse wheel skips through tracks in the playlist.

You may also drag items and drop them on the tray icon to add them to the current
playlist. A pop-upmenu opens, asking whether to append the track to the playlist, append
and play it, or queue it after the current track.

25.2.2 JuK Jukebox
JuK (kdemultimedia3-jukebox package) is a jukebox application that lets you
manage your music file collection and playlists. JuKmaintains a list of all files it knows
about. This is called the collection list. The list is specific to JuK and is not shared with
other applications. Independent of the collection list are playlists. You can have as many
playlists as you want and you can share your JuK playlists with other media players.
You can also edit the tags of your music files.

Start JuK with the main menu or press Alt + F2 and enter juk. Find more information
about JuK in the online help.
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25.3 Handling Audio CDs
There are many ways to listen to your favorite music tracks. Either play a CD or play
digitized versions of them. The following section features some CD player applications
as well as some applications that can be used for digitizing audio CDs.

For information about how to create your own CDs, refer to Chapter 28, Burning CDs
and DVDs With K3b (page 305).

IMPORTANT: CDDA and Analog CD Playback

There are two different ways of playing audio CDs. CD and DVD drives capable
of analog CD playback read the audio data and send it to the sound output
device. Some external drives connected via PCMCIA, FireWire, or USB need to
use CDDA (Compact Disk Digital Audio) to extract the audio data first then
play it as digital PCM. The players featured in the following sections do not
support CDDA. Use XMMS if you need CDDA support.

25.3.1 KsCD—Audio CD Player
KsCD is an easy-to-use audio CD player included in the kdemultimedia3-extra
package. If it is installed, press Alt + F2 and enter kscd to start the application. KsCD
integrates into your KDE panel and can be configured to start playing automatically
after a CD has been inserted. To access the configuration menu, select Extras > Config-
ure KsCD. Fetch album and track information from a CDDB server on the Internet if
KsCD is configured accordingly. You can also upload CDDB information to share it
with others. Use the CDDB dialog for information retrieval and upload.

Figure 25.2 The KsCD User Interface
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25.3.2 Compressing Audio Data: Ripping
Audio compression can be handled by various tools. The following sections feature a
command line approach to encoding and playing audio data as well as some graphical
applications capable of audio compression.

Command Line Tools for Encoding and Playback of
Audio Data
Ogg Vorbis (package vorbis-tools) is a free audio compression format that is now
supported by the majority of audio players and even portable MP3 players. The Web
page of the project is http://www.xiph.org/ogg/vorbis.

Your system comes with several tools supporting Ogg Vorbis. oggenc is a command
line tool used for encoding WAV files to Ogg. Just run oggenc myfile.wav to
transform a given .wav file into Ogg Vorbis. The -h option displays an overview of
the other parameters. Oggenc supports encoding with a variable bit rate. In this way,
an even higher degree of compression can be achieved. Instead of the bit rate, specify
the desired quality with the parameter -q. -b determines the average bit rate. -m and
-M specify the minimum and maximum bit rate.

ogg123 is a command line Ogg player. Start it with a command like ogg123
mysong.ogg.

Compressing Audio Data Using KAudioCreator
KAudioCreator is a lean CD ripper application (see Figure 25.3, “Ripping Audio CDs
with KAudioCreator” (page 276)). Once started, it lists all the tracks of your CD in the
CD Tracks tab. Select the tracks to rip and encode. To edit the track information, use
the Album Editor under File > Edit Album. Otherwise just start the ripping and encoding
with File > Rip Selection. Watch the progress of these jobs using the Jobs tab. If con-
figured accordingly, KAudioCreator also generates playlist files for your selection that
can be used by players like amaroK, XMMS, or Banshee.
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Figure 25.3 Ripping Audio CDs with KAudioCreator

Compressing Audio CDs Using Konqueror
Before you start the actual ripping process with Konqueror, configure the handling of
audio CDs and the Ogg Vorbis encoder in the KDE Control Center. Select Sound &
Multimedia > Audio CDs. The configuration module is divided into three tabs:General,
Names, and Ogg Vorbis Encoder. Normally, a suitable CD device is detected automat-
ically. Do not change this default setting unless the autodetection failed and you need
to set the CD device manually. Error correction and encoder priority can also be set
here. TheOgg Vorbis Encoder tab determines the quality of the encoding. To configure
online lookup of album, track, and artist information for your ripped audio data, select
Add Track Information.

Start the ripping process by inserting the CD into the CD-ROM drive and entering
audiocd:/ in the Location bar. Konqueror then lists the tracks of the CD and some
folders (see Figure 25.4, “Ripping Audio Data with Konqueror” (page 277)).
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Figure 25.4 Ripping Audio Data with Konqueror

To keep uncompressed audio data on your disk, just select the .wav files and drag
them into another Konqueror window to copy them to their final destination. To start
the Ogg Vorbis encoding, drag the Ogg Vorbis folder or files from this folder to
another Konqueror window. The encoding starts as soon as you drop the Ogg Vorbis
folder at its destination.

25.4 Playing Movie Files
You can choose between several movie players shipped with your openSUSE. Kaffeine
is the default KDE movie player and can be run with several back-ends, such as Xine
and MPlayer.

The formats you can view with Kaffeine depends on the back-end (by default, Xine is
used). Xine interprets many of the most common multimedia formats available. For
more information, refer to http://xinehq.de/.

In case the format is not supported by the player's engine, openSUSE offers to search
for a suitable codec which you can then install with YaST.
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Figure 25.5 Kaffeine Main Window

Kaffeine can also play multimedia streamed over the Internet and can be used as a plug-
in for Konqueror. It provides the usual options for playing files in full screen mode,
navigating through files, and more. You can also take a snapshot of the video and save
it as an image.

Apart from Kaffeine, openSUSE also ships RealPlayer for Linux. RealPlayer supports
RealAudio, RealVideo, Ogg Vorbis, Theora, and more.

Figure 25.6 RealPlayer for Linux
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26Playing and Managing Your
Music with Banshee
Banshee™ is a GNOME music management and playback application that lets you
import CDs, sync your music collection to an iPod* or other digital audio player, play
music directly from an iPod (or other digital audio player), create playlists with songs
from your library, create audio andMP3 CDs from subsets of your library, and subscribe
to, download, and listen to your favorite podcasts. Banshee also supports streaming
audio through its Internet Radio plug-in.

To open Banshee, click Computer > Banshee Media Player.

The first time you open Banshee, you are prompted to import music. Choose an import
source, such as your home directory, a local folder, a local file, a CD, or an alternate
music source (such as a digital audio player), then click Import Music Source.

Figure 26.1 Import Music Library

After successfully importing your music, your library is displayed.
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Figure 26.2 Banshee Library

26.1 Listening to Music
To listen to music, Banshee needs to know what is available to listen to. You can listen
to music in your library, which means that you will need to import music from an ex-
ternal source such as a file, folder, or CD, or you can listen to music directly off a CD.
You can also listen to music on Internet radio stations, podcasts, and your digital audio
player (see Section 26.3, “Using Banshee with Your Digital Audio Player” (page 289)
for more information).

Banshee also comes with MP3 support. If your music collection consists of both MP3
and Ogg Vorbis files, you do not need to convert any files to a different format. Just
open Banshee and start listening.

If the format you are tying to play is not supported by the player's engine, Banshee offers
to search for a suitable codec which you can then install with YaST.

26.1.1 Importing Music
Banshee can import music from a file, folder, CD, or digital audio player.
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1 In Banshee, clickMusic > Import Music.

2 Select an import source.

3 Click Import Music Source.

Banshee can automatically query MusicBrainz [http://musicbrainz.org] for
extra information about tracks that you import and fetch cover art for display when you
play a song. To enable this feature, click Edit > Plugins, then selectMetadata Searcher.

26.1.2 Playing Your Music
To play a song, simply select the song in the library and click the play button in the
upper left corner. Use the other buttons to pause a song or play the next or previous
song. Use the loudspeaker button on the right to adjust the volume. You can also use
the items on the Playback menu to repeat or shuffle songs.

Banshee also has an integrated CD player. When you insert a music CD, your CD title
appears in the left panel. Select the title and click the play button to play your full CD.

Notification Area Icon
You can keep Banshee hidden in the notification area when you are not interacting with
it by minimizing the Banshee window. You will only see pop-up bubbles identifying
the current song when track changes happen.

If you do not want to see the pop-ups, click Edit > Plugins > Notification Area Icon >
Configuration, then deselect Show notifications when song changes.

Mini Mode
You can also use the Mini Mode feature to condense the interface and free up valuable
desktop space. You can switch between your library, playlists, and music devices while
in Mini Mode. To activate Mini Mode, click View >Mini mode.
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Figure 26.3 Banshee in Mini Mode

Music Recommendations
Banshee automatically recommends music that you might like, based on the currently
playing song. It finds artists and popular songs that people with similar musical tastes
enjoy.

Figure 26.4 Banshee Music Recommendations
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If you do not want to receive recommendations, click Edit > Plugins, then deselect
Music Recommendations.

26.1.3 Ripping Your Music
To rip music from a CD and add it to your library:

1 Insert a CD into your CD or DVD drive.

Banshee automatically lists the CD as a source in the left menu.

2 Select the CD title in the source list on the left, then click Import CD in the upper
right corner.

26.1.4 Listening to Internet Radio
You can use Banshee to listen to Internet radio stations and streaming audio. The Radio
view in Banshee automatically lists several common Internet radio stations maintained
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on banshee-project.org [http://banshee-project.org]. You can also add your
own stations.

Listening to an Internet Radio Station
To listen to Internet radio stations, select Radio in the source list on the left, then double-
click the station you want to listen to.

Figure 26.5 Internet Radio Stations in Banshee

Adding a New Internet Radio Station
1 Right-click Radio in the source list, then click Add Station.
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2 Enter the stream details in the Add new radio station dialog box, then click Save.

The new station is added to your list.

26.1.5 Listening to Podcasts
Banshee lets you subscribe, download, and listen to your favorite Podcasts. Podcasting
is a form of audio blogging where users subscribe to a feed of shows and the shows’s
episodes are downloaded and managed for offline listening.

Subscribing to a Podcast
1 ClickMusic > Subscribe to Podcast.

2 Enter the URL of the podcast you want to subscribe to.

3 To specify more options, click Advanced, then select what happens when new
episodes of this podcast are available.

4 Click Subscribe.

The new podcast is added to your list.
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Listening to a Podcast
To listen to a podcast, select Podcasts in the source list, then double-click the podcast
you want to listen to.

Figure 26.6 Podcasts in Banshee

Use the options on the Tools > Podcast menu to update a podcast, subscribe to other
podcasts, or find new podcasts.

26.2 Managing Your Music Library
Banshee gives you several ways to organize your music. You can create playlists, which
allow you to put similar songs together, and you can sort and rate songs. You can also
view a variety of information about your music collection, including playback statistics
(when a song was last played and how many times).
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26.2.1 Organizing Your Music
To create a new playlist, clickMusic > New Playlist (or press Ctrl + N). A new playlist
is displayed belowMusic Library in the left panel. To rename it, right-click the playlist,
select Rename and enter the name you want. To fill the new playlist, drag songs from
the right-hand side of the window to the respective playlist entry and drop them, or use
the options on the Edit menu to remove or delete songs and rename or delete playlists.
You can sort a playlist by clicking the title of the column. Click the column again to
reverse the sort. You can also right-clickMusic Library, then click Sort Playlists.

You can edit the name of the artist, album, and title, as well as the track number and
track count. Simply select a song, then click Edit > Edit Song Metadata. You can also
rate your music, which gives you the ability to play only songs with a certain rating.
To rate a song, select the number of stars you want to assign in the Rating field.

Figure 26.7 Editing Song Dialog Box

If you want to set all fields in a group to the same value, select multiple songs in a
playlist, then click Edit > Edit Song Metadata. Make the changes you want, then click
Apply common field values to all tracks. You can also use the Back and Forward buttons
to cycle through the selected songs.

Click the Details tab to view detailed information about the selected song, including
the bit rate, the sample rate, when a song was last played, when it was imported, how
long the song is, and how many times the song has been played.
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26.2.2 Creating Smart Playlists
You can create playlists that automatically add and remove songs based on criteria you
specify. For example, a smart playlist can contain songs you rated as five stars but that
you have not listened to for six months. Another smart playlist can contain all songs
published in 2006 that you have labeled with the Classical genre.

Banshee automatically updates all smart playlists when a change is made to your music
library. If you import new songs, Banshee checks to see if they match any of your
available smart playlists. When applicable, Banshee also updates your smart playlists
if you just listened to a song or updated a song’s metadata.

Creating a Smart Playlist
1 In Banshee, clickMusic > New Smart Playlist.

2 Specify a name for the smart playlist, then select the criteria for songs in this
playlist to match.

Use the plus and minus symbols to add or remove criteria. To use an already
defined smart playlist, click Predefined Smart Playlists, then select the playlist
you want.

3 Click Save. The smart playlist is added to your music library.
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Creating a Smart Playlist from a Search
You can create a smart playlist based on search criteria. For example, if you search for
all songs in your music library by a certain artist, Banshee can create a smart playlist
in which all songs by that artist are selected.

1 In Banshee, clickMusic > New Smart Playlist from Search.

2 Specify a name for the smart playlist, then specify the search criteria you want.

Use the plus and minus symbols to add or remove criteria. To use an already
defined smart playlist, click Predefined Smart Playlists, then select the playlist
you want.

3 Click Save. The smart playlist is added to your music library.

26.3 Using Banshee with Your Digital
Audio Player

Banshee supports several digital audio players, including Apple* iPods, Creative*
Nomads*, Dell* DJs, and almost any other generic USB Mass Storage player. Instead
of having to use separate applications to get support for your audio devices, Banshee
gives you easy, integrated support and lets you copy your music to or from your device,
no matter what format the music is in.
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26.3.1 Playing Music from your Digital
Audio Player

To play music from your digital audio player, simply plug your player into your system.
After your system recognizes your device, an icon is displayed in the left panel in
Banshee.

Select the icon to display the music on your device in the right panel. Double-click the
song you want to listen to.

Figure 26.8 Banshee MP3 Playback from an iPod Mini

To view or change device properties, right-click your device, then select Source Prop-
erties. From there, you can view various pieces of information. If you have an iPod,
you can update the owner's name.
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26.3.2 Adding Music to Your Digital Audio
Player

To add tracks to your player, simply drag the tracks you want from your Music Library
to your device.

Banshee transparently supports transcoding of your songs for any device. You can have
your music library in any number of formats (including, but not limited to, FLAC, Ogg
Vorbis, MP3, and AAC), and it will be transparently transcoded before it is sent to your
digital audio player.

To remove tracks, select your device in the list of sources, right-click the song you want
to delete, then click Remove Song(s).

26.3.3 Copying Music on Your Digital Audio
Player to Banshee

Banshee supports importing music from your digital audio player to your music library.
Simply drag and drop the songs from your digital audio player to your Music Library
and they are copied automatically. You can also import all of the music on your digital
audio player by right- clicking your player in the source list and selecting Import.

Figure 26.9 Importing Music from Your Digital Audio Player to Banshee

26.3.4 Synchronizing Your Library
To keep your digital audio player up to date with your Banshee Library, select your
player in the source list, then click Synchronize in the upper right corner.
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Banshee also synchronizes your ratings and cover art in your tracks to your iPod.

26.4 Creating Audio and MP3 CDs
1 Insert a blank CD in your CD or DVD drive.

2 Select the songs you want to burn, then click theWrite CD button in the upper
right side of Banshee.

3 Specify the disk options you want, then clickWrite.

For example, click Eject disk after writing if you want Banshee to eject your CD
when the writing is completed.

You can track the status of the burn in the bottom left corner of Banshee. A
message box appears when the burn is complete.

4 Click OK.

26.5 Sharing Your Music
You can automatically update your online Audioscrobbler [http://www.last.fm]
profile with the music you listen to in Banshee. This lets others see what you are listening
to, and gives you access to charts detailing your listening history. If you join groups
such as the Banshee Group [http://www.last.fm/group/Banshee], you can
also see what other people are listening to.
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Before you can share your music, you need to enable the Audiosrobbler plug-in and
enable song reporting.

1 In Banshee, click Tools > Audioscrobbler > Configure.

2 If you have already registered with Last.fm [http://www.last.fm/], click
Enable song reporting, then specify your Last.fm username and password.

If you have not previously registered with Last.fm, clickCreate an account. This
opens the Last.fmWeb site where you can register. Click Enable song reporting,
then specify your Last.fm username and password.

3 Click Close. Banshee starts reporting with the next song you play.

After Audioscrobbler is configured, use the options on the Tools > Audioscrobbler
menu to enable or disable song reporting, visit your user profile Web page, or
visit the Web site of any Audioscrobbler groups you belong to.

26.6 Configuring Banshee Preferences
1 Click Edit > Preferences.
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2 Choose from the following options:

Music Library
Lets you specify a music folder location. This location is used when you
import music. Click Copy files to music folder when importing to place a
copy of the files you import in your Banshee music folder.

File System Organization
Lets you determine folder hierarchy in the music library, and how filenames
are displayed.

CD Importing
Lets you determine encoding profiles for CD ripping. Select the output format
you want, then click Edit to configure advanced options for that format.

Use error correction when importing
The error correction tries to work around problem areas on a disk, such as
surface scratches, but can substantially slow down the time it takes to import.

3 Click Close to save your changes.
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27Playing Movie Files
The TotemMovie Player application is a movie player for the GNOME desktop which
provides the following features:

• Support for a variety of video and audio files

• A variety of zoom levels and aspect ratios, and a full screen view

• Seek and volume controls

• Playlists

• Complete keyboard navigation

• Video thumbnailer for GNOME

• Nautilus properties tab

To start the Totem Movie Player, click Computer >More Applications >Multimedia
> Totem Movie Player.

27.1 Using the Totem Movie Player
When you start Totem Movie Player, the following window is displayed.
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Figure 27.1 Totem Movie Player Start Up Window

27.1.1 Opening a Video or Audio File
1 ClickMovie > Open.

2 Select the files you want to open, then click Add

You can also drag a file from another application (such as a file manager) to the Totem
Movie Player window. The Totem Movie Player application opens the file and plays
the movie or song. Totem Movie Player displays the title of the movie or song beneath
the display area and in the titlebar of the window.

NOTE: Unrecognized File Format

If you try to open a file format that Totem Movie Player does not recognize,
the application displays an error message and proposes to search for suitable
codec.
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You can double-click a video or audio file in the Nautilus file manager to open it on
the Totem Movie Player window.

27.1.2 Opening a Video or Audio File By URI
Location

1 ClickMovie > Open Location.

2 Specify the URI location of the file you want to open, then click Open.

27.1.3 Playing a DVD, VCD, or CD
To play a DVD, VCD, or CD, insert the disc in the optical device of your computer,
then clickMovie > Play Disc.

To eject a DVD, VCD, or CD, clickMovie > Eject.

To pause a movie or song that is playing, click the button, or clickMovie >
Play/Pause. When you pause a movie or song, the statusbar displays Paused and the
time elapsed on the current movie or song stops.

To resume playing a movie or song, click the button, or clickMovie > Play / Pause.

To view properties of a movie or song, click View > Sidebar to make the sidebar appear,
then click Properties in the drop-down list. The dialog contains the title, artist, year,
and duration of movie or song, video dimensions, codec and framerate, and the audio
bitrate and codec.

27.1.4 Seeking Through Movies or Songs
To seek through movies or songs, use any of the following methods:

To skip forward
To skip forward a movie or song, click Go > Skip Forward.
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To skip backward
To skip backward a movie or song, click Go > Skip Backward.

To move to next movie or song
To move to the next movie or song, click Go > Next Chapter/Movie, or click the

button.

To move to previous movie or song
To move to the previous movie or song, click Go > Previous Chapter/Movie, or

click the button.

27.1.5 Changing the Zoom Factor
To change the zoom factor of the display area, use any of the following methods:

To zoom to full screen mode
Click View > Fullscreen. To exit fullscreen mode, click the Leave Fullscreen button
or press Esc.

To zoom to half size (50%) of the original movie or visualization
Click View > Fit Window to Movie > Resize 1:2.

To zoom to size (100%) of the original movie or visualization
Click View > Fit Window to Movie > Resize 1:1.

To zoom to double size (200%) of the original movie or visualization
Click View > Fit Window to Movie > Resize 2:1.

To switch between different aspect ratios, click View > Aspect Ratio. The supported
aspect ratios include:

• Auto

• Square

• 4:3 (TV)

• 16:9 (Widescreen)

• 2.11:1 (DVB)
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The default aspect ratio is Auto.

27.1.6 Showing or Hiding Controls
To hide the Totem Movie Player window controls, click View > Show Controls to des-
elect the Show Controls option. To show the controls on the Totem Movie Player win-
dow, right-click the window, then select Show Controls.If the Show Controls option is
selected, Totem Movie Player shows the menubar, time elapsed slider, seek control
buttons, volume slider, and statusbar on the window. If the Show Controls option is
not selected, the application hides these controls and shows only display area.

27.1.7 Managing Playlists
To show the playlist, click View > Sidebar, then click Playlist at the top of the sidebar.
The Playlist dialog box is displayed.

You can use the Playlist dialog box to do the following:

• To add a track or movie: Click the Add button. Select the file you want to add
to the playlist, then click OK

• To remove a track or movie: Select the filenames from the filename list box,
then click Remove.

• To save a playlist to file: Click the Save button, then specify a filename

• Tomove a track ormovie up the playlist: Select the filename from the filename
list box, then click the Up button.

• To move a track or movie down the playlist: Select the filename from the
filename list box, then click the Down button

To hide the playlist, click View > Sidebar, or click the Sidebar button.

To enable or disable repeat mode, click Edit > Repeat Mode. To enable or disable
shuffle mode, click Edit > Shuffle Mode.
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27.1.8 Choosing Subtitles
To choose the language of the subtitles, click View > Subtitles, then select the subtitles
language you want to display.

To disable the display of subtitles, click View > Subtitles > None.

By default, Totem Movie Player chooses the same language for the subtitles that you
use on your computer.

Totem Movie Player automatically loads and displays subtitles if the file that contains
them has the same name as the video file and has an asc, txt, sub, smi, or ssa file
extension.

27.1.9 Taking Screenshots
To take a screenshot of a movie or a visualization of song that is playing, click Edit >
Take Screenshot. You can save a screenshot to either of the following:

• File: Select Save screenshot to file, then click the Browse button to specify a
filename.

• Desktop: Select Save screenshot to the desktop.

27.2 Modifying Totem Movie Player
Preferences

To modify Totem Movie Player preferences, click Edit > Preferences. You can modify
the following:

27.2.1 General Preferences
The Totem General Preferences let you select a network connection speed, specify a
TV-out connection type, and change the font and encoding used to display subtitles.
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Figure 27.2 Totem General Preferences

General Preferences include the following:

Networking
Select network connection speed from the Connection speed drop-down list box.

TV-Out
SelectNo TV-out if you have no TV-out connection (this option is selected by default
if you don't have a TV-out interface). Select TV-out in fullscreen by Nvidia (NTSC)
if you want TV-out connection in NTSC, or select TV-out in fullscreen by Nvidia
(PAL) if you want TV-out connection in PAL.

Text Subtitles
Lets you change the font and encoding used to display subtitles.

27.2.2 Display Preferences
The TotemDisplay Preferences let you choose to automatically resize the windowwhen
a new video is loaded, change the color balance, and configure visual effects when an
audio file is played.
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Figure 27.3 Totem Display Preferences

Display Preferences include the following:

Automatically resize the window when a new video is loaded
Select this option if you want Totem Movie Player to automatically resize the
window when a new video is loaded.

Visual Effects
You can choose to show visual effects when an audio file is playing, select the type
of visualization you want to show, and the visualization size.

Color Balance
Specify the level of color brightness, contrast, saturation, and hue.

27.2.3 Audio Preferences
The Totem Audio Preferences dialog box lets you select the audio output type.
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Figure 27.4 Totem Audio Preferences
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28Burning CDs and DVDs With
K3b
K3b is a comprehensive program for writing data and audio CDs and DVDs. Start the
program from the main menu or by entering the command k3b. The following sections
brief you on how to start a basic burning process to get your first Linux-made CD or
DVD.

28.1 Creating a Data CD or DVD
To create a data CD or DVD, proceed as follows:

1 Select File > New Project > New Data CD Project or File > New Project > New
Data DVD Project, depending on your project. The project view appears in the
lower part of the window .

2 Drag the desired directories or individual files from your home directory to the
project folder and drop them there.

3 Save the project under a name of your choice with File > Save as.

4 Select Burn from the toolbar or hit Ctrl + B. A dialog with four tabs offering
various options for writing the CD or DVD opens. They are explained in the list
below.

5 Start the process with Burn.
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Figure 28.1 Customizing the Burning Process

TheWriting tab has various settings for the burning device, the speed, and the burning
options. The following options are offered here:

Burn Medium
The detected medium and writer are displayed under this pop-up menu. If you have
more than one writer installed, choose which one you want to use here. You can
select the speed here, too.

WARNING: Select the Writing Speed with Care

Normally, you should select Auto, which chooses the maximum writing
speed possible. However, if you increase this value but your system is not
able to send the data fast enough, you possibly get faulty disks due to
buffer underruns.

Writing Mode
This option determines how the laser writes the CD or DVD. For CDs, there are
three modes available: DAO (disk at once), TAO (track at once), and RAW. In
DAO mode, the laser is not deactivated while the disk is written. This mode is
recommended for the creation of audio CDs. In the TAO mode, a separate write
process is used for each individual track. The RAW mode is not used very often,
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because the writer does not perform any data corrections. For DVDs, there are two
modes available: auto or DAO. It is recommended to select Auto, because it allows
K3b to use the most suitable settings. Do not use the DAO mode if you want to
create multisession DVDs.

Simulate
This function can be used to check if your system supports the selected writing
speed. The writing is performed with a deactivated laser to test the system.

Create Image
This option allows you to create an ISO image of a CD or DVD. This image file
is subsequently written to the CD or DVD. Use this option on low performance
systems. Set the path for this file under Temporary File in the Image tab. Checking
this option also activates the Remove Image option. If you do not want the image
to be deleted after burning is finished, uncheck this option.

Only Create Image
If this option is enabled, the ISO image file is created but it is not subsequently
written on CD or DVD. Use this option if you want to write the image on CD or
DVD at a later time. To do this, use Tools > Burn CD Image or Tools > Burn DVD
ISO Image. If this option is used, all other options in this section are deactivated.

Remove Image
Remove the temporary image file from hard disk when finished.

Verify Written Data
Check the integrity of the written data by comparing the MD5 sums of the original
and the burned data.

The Image tab is only useful if the Create Image or the Only Create Image option is
set. In this case, determine the file in which you want to write the ISO.

In the Filesystem tab, set the Volume Name. If you clickMore Fields, you can add more
information about the project, such as its publisher and preparer, copyright information
and the application and operating system used in the creation of this project. You are
able to set the used File System and determine how Symbolic Links andWhite Space
should be handled.

TheMisc tab contains two options. The first one, Datatrack Mode is available only for
CDs. Here you can set up how data tracks should be written. In general, Auto is consid-
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ered the best suited method. TheMultisessionMode is used to append data to an already
written but not finalized medium.

After adjusting all settings to your needs, start the actual burning process using Burn.
Alternatively, save these settings for future use and adjustment with Save.

28.2 Creating an Audio CD
Basically, there are no significant differences between creating an audio CD and creating
a data CD. Select File > New Audio CD Project. Drag and drop the individual audio
tracks to the project folder. The audio data must be in WAV or Ogg Vorbis format.
Determine the sequence of the tracks by moving them up or down in the project folder.

With the help of CD Text, you are able to add certain text information to a CD, such as
CD title, artist name, and track name. CD players that support this feature can read and
display this information. To add CD text information to your audio tracks, select the
track first. Right-click and select Properties and enter your information in the new
window that opens. You can also download track information from the Internet by
clicking Query Cddb.

The dialog for burning an audio CD is not very different from the dialog for burning a
data CD. However, the Disk at Once and the Track at Oncemodes have greater impor-
tance. In TAO mode the laser stops after each track and leaves a short break. The DAO
mode uses one uninterrupted session and writes data to your disk sequentially. The
Track at Once mode inserts an intermission of two seconds after each track.

TIP: Preserving Data Integrity

When burning audio CDs, choose a lower burning speed to reduce the risk of
burning errors.

After adjusting all settings to your needs, start the actual burning process using Burn.
Alternatively, save these settings for future use and adjustment by clicking on the
floppy disk icon.
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28.3 Copying a CD or DVD
Select Tools > Copy Medium.... In the dialog that opens, choose Source Medium and
Burn Medium as shown in Figure 28.2, “Copying a Medium” (page 309). The writing
options discussed are also available here. An additional function enables the creation
of several copies of the CD or DVD.

Figure 28.2 Copying a Medium

Check Create Image to cache data to the hard disk before writing them on a target
medium. CheckOnly Create Image to create an image in the path specified in the Image
tab in theWrite Image Files To option and burn the image later.

28.4 Writing ISO Images
If you already have an ISO image, go to Tools > Burn CD Image or Tools > Burn DVD
ISO Image. Enter the location of the Image to Burn in the window that opens. K3b
calculates a check sum and displays it inMD5 Sum. Make sure to compare ISO files
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you downloaded from the Internet with the MD5 sum provided by the source of the
image. If the sums are different, the image has not been downloaded correctly.

Choose the medium and writer to use in Burn Medium. Select the speed of writing. Set
your preferences, such as number of copies in Settings. Their meaning is the same as
if creating a new CD or DVD from sratch, see Section 28.1, “Creating a Data CD or
DVD” (page 305). To burn the disk, click Start.

28.5 Creating a Multisession CD or
DVD

Multisession disks can be used to write data in more than one burning session. This is
useful, for example, for writing backups that are smaller than the media. In each session,
you can add another backup file. The interesting part is that you are not only limited to
data CDs or DVDs. You can also add audio sessions to a multisession disk.

NOTE: About Storage Space on Multisession Disks

Be aware that multisession disks need space to keep an account of all the entries
from your sessions. This leads to a smaller amount of available space on your
disk. The amount depends on the number of sessions.

To start a new multisession disk, do the following:

1 Create your data disk first and add all your files. You cannot start with an audio
CD session. Make sure that you do not fill up the entire disk, because otherwise
you cannot append a new session.

2 Burn your data with Project > Burn.

3 In the dialog box that appears, go to theMisc tab and select Start Multisession.
If you want to burn a DVD, do not use the DAO writing mode, because it does
not support multisession.

4 Configure other options if needed. See also Section 28.1, “Creating a Data CD
or DVD” (page 305).

5 Start the burning session with Burn.
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After a successful burning process, you have created a multisession disk. As long as
the media contains enough space, you can append more sessions if you like. Finish
disks with Finish Multisession only if you are sure you do not need any new sessions
or the space is occupied.

28.6 For More Information
Apart from the functions described above, K3b offers other functions, such as ripping
music from audio CDs, rewriting CDs, and more. You can findmore informations about
K3b at http://k3b.org/.
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29Burning CDs and DVDs With
Brasero
Brasero is a program for writing data and audio CDs and DVDs. Start the program from
the main menu or by entering the command brasero. The following sections brief
you on how to start a basic burning process to get your first Linux-made CD or DVD.

29.1 Creating a Data CD or DVD
After starting Brasero for the first time, the main window appears as shown in Fig-
ure 29.1 . To create a CD or DVD, click on Data project.

Figure 29.1 Main View of Brasero
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The project view appears. Drag and drop the desired directories or individual files either
from your file manager or by clicking on Add. To show your directory structure directly
in Brasero, select View > Show side panel. Save the project under a name of your choice
with Project > Save As.... After you are finished, click Burn.

A new dialog box appears where you can select the disc device to write to. Alternatively
you can save your CD or DVD as a ISO image file. Give your CD or DVD a name in
Label of the disc, decide if you need compatibility with Windows systems and finish
with Burn.

An overview of the dialog box can be seen at Figure 29.2 .

Figure 29.2 Copying Dialog

29.2 Creating an Audio CD
Basically, there are no significant differences between creating an audio CD and creating
a data CD. Proceed as follows:

1 Select Project > New Project > New Audio Project.

2 Drag and drop the individual audio tracks to the project folder. The audio data
must be in WAV or Ogg Vorbis format. Determine the sequence of the tracks
by moving them up or down in the project folder.
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3 Click Burn to open the Disc burning setup dialog box.

4 Specify a drive to write to.

5 Click Properties to adjust burning speed and other preferences. When burning
audio CDs, choose a lower burning speed to reduce the risk of burning errors.

6 Click Burn.

29.3 Copying a CD or DVD
To copy a CD or DVD, proceed as follows:

1 Click Disc Copy or go to Project > New Project > Copy Disc.... The CD/DVD
copy options dialog box opens.

2 Specify the source drive you want to copy.

3 Specify a drive or image file to write to.

4 If necessary, change the burning speed, the temporary directory and other options
in properties.

5 Click Copy.

29.4 Writing ISO Images
If you already have an ISO image, click on Burn image or go to Project > New Project
> Burn Image.... Choose the medium and writer and change parameters, if necessary,
by clicking Properties. Choose the location of the image file with the popup menu, la-
beled Path. Start the burning process and click Burn.
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29.5 Creating a Multisession CD or
DVD

Multisession discs can be used to write data in more than one burning session. This is
useful, for example, for writing backups that are smaller than the media. In each session,
you can add another backup file. The interesting part is that you are not only limited to
data CDs or DVDs. You can also add audio sessions in a multisession disc.

To start a new multisession disc, do the following:

1 Start with a data disc first as described in Section 29.1, “Creating a Data CD or
DVD” (page 313). You cannot start with an audio CD session. Make sure that
you do not fill up the entire disc, because otherwise you cannot append a new
session.

2 Click on Burn. The Disc Burning Setup opens.

3 Select Leave the disc open to add other files later to make the disc multisession
capable. Configure other options if needed.

4 Start the burning session with Burn.

29.6 For More Information
You can find more information about Brasero at http://www.gnome.org/
projects/brasero/.
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AGetting to Know Linux
Software
Linux comes with a wealth of applications, often offering more than one solution to
specific needs. The difficulty lies in finding the application that suits your needs best.
The next few sections introduce some of the most powerful Linux counterparts to
common Windows software. Each section is dedicated to one particular field of appli-
cation and presents an overview of the Windows applications and Linux equivalents
for several tasks. Below each table, find further information about the Linux applications
with links to more information. This list is by no means complete, because software
development is an evolutionary process and new applications are being created every
minute.

TIP: Applications not installed by default

Not all applications mentioned below are installed on your system by default
and some may not be shipped with your product. If the application you want
to use is missing, ask your system administrator. If the application is provided
by your product, you can install it with YaST. Use the search function of the
YaST software management tool to find the name of the wanted package.

A.1 Office Applications
This section features the most popular and powerful Linux office and business software
solutions. These include office suites, databases, accounting software, and project
management software.



Table A.1 Office Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

OpenOffice.org, StarOffice, KOf-
fice

Microsoft OfficeOffice Suite

OpenOffice.org/StarOfficeWriter,
KWord

Microsoft Word, Word-
Perfect

Word Processor

OpenOffice.org/StarOffice Calc,
Gnumeric, KSpread

Microsoft ExcelSpreadsheet

OpenOffice.org/StarOffice Im-
press, KPresenter

Microsoft PowerPointPresentation

OpenOffice.org Calc, Kst, Gnu-
plot, Grace (Xmgr), LabPlot

Microsoft ExcelData Plotting

OpenOffice.org Base, Rekall, kexi,
Mergeant, PostgreSQL

Microsoft AccessLocal Database

GnuCash,KMyMoneyMicrosoft Money,
Quicken

Financial Account-
ing

Planner, TaskjugglerMicrosoft ProjectProjectManagement

VYM (View Your Mind), Free
Mind, KDissert

MindManager, Free
Mind

Mind Mapping

A.1.1 Office Suites
OpenOffice.org

OpenOffice.org is a stable open source equivalent to MS Office including a word
processor (Writer), a spreadsheet (Calc), a database manager (Base), a presentation
manager (Impress), a drawing program (Draw), and a formula editor for generating
mathematical equations and formulas (Math). The user interface is similar to the
MS Office suite.For more details, see http://www.openoffice.org/.
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StarOffice
StarOffice, developed by Sun Microsystems, is similar to OpenOffice.org. It is
available on multiple platforms like Linux, Windows and Solaris. It contains The
same modules as the OpenOffice.org suite. However, it features many advanced
functionalities not available with OpenOffice.org. For more details, see http://
www.sun.com/software/star/staroffice/.

KOffice
KOffice is a very powerful and fully integrated office suite designed for the KDE
desktop and is shipped with the SuSE Linux distribution package. It comes with
various modules, like word processing (KWord), spreadsheets (KSpread), presen-
tations (Kpresenter),several image (Kexi) processing applications (Kivio, Karbon14,
Krita), a database front-end and many other applications. For more details, see
http://www.koffice.org/.

A.1.2 Word Processing
Writer

Writer is the stable word-processing and desktop publishing module of the
OpenOffice.org and StarOffice, developed by SunMicrosystems. StarOffice features
many advanced functions not available with OpenOffice.org. For more details, see
http://www.openoffice.org/product/writer and http://www
.http://www.sun.com/software/star/staroffice.

KWord
KWord is a stable frame-based word-processing module of the KOffice Suite. Its
easy-to-use features help to create professional looking documents. It can also
handle large amounts of texts. For more details, see http:///www.koffice
.org/kword/.

A.1.3 Spreadsheets
Calc

Calc is the spreadsheet and data plotting module of the OpenOffice.org and
StarOffice suites. It is intuitive and easy to learn and offers a comprehensive range
of powerful features. For more details, see http://www.openoffice.org/
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product/calc.html and http://www.http://www.sun.com/
software/star/staroffice.

KSpread
KSpread is the spreadsheet module of the KOffice Suite. It is a scriptable spreadsheet
program which provides both table-oriented sheets and support for complex
mathematical formulas and statistics. Formore details seehttp://www.koffice
.org/kspread/.

Gnumeric
Gnumeric is a spreadsheet solution for the GNOME desktop environment that can
also read files created with other spreadsheets. It's built-in functions and tools are
extremely accurate. For more details, see http://www.gnumeric.org.

A.1.4 Presentations
Impress

Impress is the presentation module of the OpenOffice.org suite that can create
multimedia presentations and allows the user to use 2D and 3D clip art, fontworks,
special effects, animation, and drawing tools. For more details, see http://www
.gnumeric.org.

KPresenter
KPresenter is the presentation module of the KOffice Suite. It the user to prepare
complete sets of slides containing text and graphics in a variety of formats, and of
course, you can embed all sorts of objects. For more details see http://www
.koffice.org/kpresenter/.

A.1.5 Data Plotting
Calc

See Calc (page 319).

Kst
Kst is the data plotting module for the KOffice suite. It allows for real-time data
viewing and plotting with basic data analysis. For more details, see http://kst
.kde.org/.
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Gnuplot
Gnuplot is a very powerful and portable command line controlled data plotting
software. It is also available for MacOS and Windows platforms. Plots created by
Gnuplot can be exported to various formats, such as PostScript, PDF, and SVG,
allowing you to process these plots easily. For more details see http://www
.gnuplot.info/index.html.

Grace
Grace is a 2D plotting tool for many platforms including Linux. It can create and
edit plots with a graphical user interface. Grace supports an unlimited number of
graphs per plot. For more details, seehttp://plasma-gate.weizmann.ac
.il/Grace/

LabPlot
LabPlot is a plotting tool for creating and managing 2D or 3D data plots and was
written for KDE. Graphs can be produced both from data and functions and one
plot may include multiple graphs. It also offers various data analysis methods. For
more details, see http://labplot.sourceforge.net/.

A.1.6 Local Databases
Base

Base is the database module of the OpenOffice.org and StarOffice suites. It can be
used to create "self-contained" database documents with all relevant data, table
definitions, reports, and forms. Formore details, seehttp://www.openoffice
.org/product/base.html

Kexi
Kexi is an integrated data management application. It can be used for creating
databases, inserting data, performing queries, and processing data. Forms can be
created to provide a custom interface to your data. For more details, see http://
www.koffice.org/kexi/

Rekall
Rekall is a database management tool that supports many database applications
like MySQL,PostgreSQL and Xbase. Rekall can be used for many tasks such as
reports, forms, queries and others. For more details, see http://www
.thekompany.com/products/rekall/
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Mergeant
GNOME-DB provides a unified data access architecture to GNOME. It is useful
for any application that accesses persistent data. It consists of a data abstraction
layer (Libgda), a database widget library and a database front-end (Mergeant). For
more details, see http://www.gnome-db.org/

PostgreSQL
PostgreSQL is an object-relational database management system that supports an
extended subset of the SQL standard, including transactions, foreign keys, sub-
queries, triggers, and user-defined types and functions. For more details, see
http://www.postgresql.org/

A.1.7 Financial Accounting
KmyMoney

KmyMoney is a personal financial manager for the KDE desktop. It enables users
of open source operating systems to keep track of their personal finances by pro-
viding a broad array of financial features and tools. For more details, see http://
kmymoney2.sourceforge.net

GnuCash
GnuCash is a software tool to control personal and business finances. It enables
users to keep track of income and expenses and it is also used to manage bank ac-
counts, and stock portfolios. For more details, see http://gnumeric,org

A.1.8 Project Management
Planner

Planner is a project management tool for the GNOME desktop aiming to provide
functionality similar to the project management tools used underWindows. Amongst
its features are Gantt charting and different display types for tasks and resources.
For more details see http://wwwimendio.com/projects/planner/.

Taskjuggler
Taskjuggler is a project management tool that enables the user to control projects
using Gantt charting features. It can also be used to generate reports in different
formats (XML, HTML or CSV). Taskjuggler can be controlled from the command
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line but also offers a graphical front-end. For more details see http://www
.taskjuggler.net.

A.1.9 Mind Mapping
FreeMind

FreeMind allows users to visualize their thoughts by creating and editing a mind
map. It can copy nodes or the style of nodes and paste texts from sources such as
HTML, RTF, and mails. The mind maps can be exported into various formats, such
as HTML andXML. For more details, seehttp://freemind.sourceforge
.net/wiki/index.php/Main_Page.

VYM
VYM (View Your Mind) is a tool for creating and editing mind maps. VYM mind
maps are created in XML which can be exported to HTML. For more details see
insilmaril.de/vym.

Semantik
Semantik (previously Kdissert) is a mindmapping-like tool for structuring ideas
and concepts and was designed for the KDE desktop. Users can generate various
outputs from the mind map, such as PDF files, text documents and HTML files.
For more details see http://freehackers.org/~tnagy/kdissert/.

A.2 Network
The following section features various Linux applications for networking purposes.
Get to know the most popular Linux browsers and e-mail and chat clients.

Table A.2 Network Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

Konqueror, Firefox,
Opera, Epiphany

Internet Explorer, Firefox*,
Opera

Web Browser

Evolution, Kontact,
Mozilla Thunderbird

Microsoft Outlook*, Lotus
Notes,Mozilla Thunderbird*

E-Mail Client/Personal
InformationManagement
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Linux ApplicationWindows ApplicationTask

Gaim, Kopete, Konversa-
tion, XChat

MSN, AIM*, Yahoo!* Mes-
senger, XChat, Gaim

Instant Messaging/IRC
Clients

EkigaNetMeeting, LifeMeetingConferencing (Video and
Audio)

Ekiga, SkypeX-LiteVoice over IP

gftp, kbearleechftp, wsftpFTP Clients

A.2.1 Epiphany
Epiphany

Epiphany is a lean, but powerful Web browser for the GNOME desktop. Many of
its features and extensions are similar to Firefox. For more details, see http://
//projects.gnome.org/epiphany/.

Firefox
Firefox is a web browser that runs on various platforms, including Linux, MacOS,
and Windows. Its main features include customizable searches, pop-up blocking,
RSS news feeds, password management, tabbed browsing, and some advanced
security and privacy options. For more details, see http://www.mozilla
.org/products/firefox/ or read Chapter 20, Browsing with Firefox
(page 183).

Konqueror
Konqueror is a multiple application created for the KDE desktop. It acts as Web
browser, file manager and document viewer. It supports most common web stan-
dards, such as CSS(2), Java applets, JavaScript and Netscape plug-ins, DOM, and
SSL. Formore details, seehttp://www.konqueror.org/ or read Chapter 19,
Browsing with Konqueror (page 175).

Opera
Opera is a powerful web browser with an optional e-mail client and a chat module.
Opera offers pop-up blocking, RSS feeds, built-in and customizable searches, a

324 Application Guide

http:////projects.gnome.org/epiphany/
http:////projects.gnome.org/epiphany/
http://www.mozilla.org/products/firefox/
http://www.mozilla.org/products/firefox/
http://www.konqueror.org/


password manager, and tabbed browsing. For more details see http://www
.opera.com/.

A.2.2 E-Mail Client / Personal Information
Management

Evolution
Evolution is a personal information management application for the GNOME
desktop combiningmail, calendar, and address book functionality. It offers advanced
e-mail filter and search options, and allows to you to run Evolution as an Exchange
or GroupWise client to integrate better into heterogeneous environments. For more
details, see http://projects.gnome.org/evolution/ftp.

Kontact
Kontact is the personal information management suite for the KDE desktop It in-
cludes e-mail, calendar, address book and Palm sync functions. It can act as client
for Exchange or GroupWise client. Kontact combines several KDE applications
(KMail, KAddressbook, KOrganizer, and KPilot) to form an entity providing all
the PIM functionality you need. For more details, see http://www.kontact
.org/ or read Chapter 11, Kontact: E-Mailing and Calendaring (page 97).

Mozilla Thunderbird
Mozilla Thunderbird is the e-mail client of the Mozilla suite. It is also available
for Microsoft Windows and MacOS. For more details, see http://www
.mozilla.com/en-US/thunderbird/

A.2.3 Instant Messaging / IRC Clients
Konversation

Konversation is the IRC client of the KDE desktop. Its features include support for
SSL connections,strikeout, multichannel joins, away and unawaymessages, ignore
list functionality, Unicode, auto connect to a server, optional time stamps in chat
windows, and configurable background colors. For more details, see http://
konversation.kde.org.
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Kopete
Kopete is a very intuitive and easy-to-use instant messenger tool supporting proto-
cols including IRC, ICQ, AIM, GroupWise Messenger, Yahoo, MSN, Gadu-Gadu,
Lotus Sametime, SMS messages, and Jabber. For more details, see http://
kopete.kde.org/ or readChapter 15, InstantMessagingwithKopete (page 149).

Pidgin
Pidgin (previously Gaim) is a multi-platform instant messaging client supporting
many commonly used instant messaging protocols, allowing the user to log into
various different services from a single application. For more details, see http://
pidgin.im/

XChat
XChat is an IRC chat program for both Linux and Windows. It allows to join
multiple IRC channels (chat rooms) at the same time, talk publicly, private one-on-
one conversations etc. Even file transfers are possible. For more details, see
http://www.xchat.org/.

A.2.4 VoIP, Video and Audio Conferencing
Ekiga

Ekiga (previously GnomeMeeting) is a free and open source video conferencing
and VoIP application. Ekiga supports both the SIP and H.323 protocols and is fully
interoperable with Microsoft NetMeeting and LifeMeeting. For more details see
http://www.ekiga.org/

Skype
Skype is an application for several platforms (Linux, Windows, Mac Os X) that
can be used for phone calls over the Internet with a good sound quality and with
end-to-end encryption. When using Skype, configuring the firewall or router is not
necessary. For more details, see http://www.skype.com/.

A.2.5 FTP Clients
gftp

gftp is an FTP client using the GTK toolkit. Its features include simultaneous
downloads, resume of interrupted file transfers, file transfer queues, download of
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entire directories, FTP proxy support, remote directory caching, passive and non-
passive file transfers, and drag and drop support. For more details, see http://
gftp.seul.org/.

KBear
KBear is a graphical FTP client with the ability to connect to multiple hosts simul-
taneously. The user can copy or move files or directories between the hosts by drag
and drop or cut and paste. It also has a dynamic site database. For more details, see
http://sourceforge.net/projects/kbear/.

A.3 Multimedia
The following section introduces the most popular multimedia applications for Linux.
Get to know media players, sound editing solutions, and video editing tools.

Table A.3 Multimedia Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

KsCD, Grip, BansheeCD Player, Winamp, Windows
Media Player

Audio CD Player

K3bNero, Roxio Easy CD CreatorCD Burner

KAudioCreator, Sound
Juicer

WMPlayerCD Ripper

amaroK, XMMS, Rhythm-
box

Winamp, Windows Media
Player, iTunes

Audio Player

Kaffeine, MPlayer, Xine,
XMMS, Totem, RealPlayer

Winamp, Windows Media
Player

Video Player

AudacitySoundForge, Cooledit, Auda-
city

Audio Editor

alsamixer, Kmixsndvol32Sound Mixer
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Linux ApplicationWindows ApplicationTask

LilyPond, MusE, Noteedit,
Rosegarden

Finale, SmartScore, SibeliusMusic Notation

KinoWindowsMovieMaker, Adobe
Premiere, Media Studio Pro

Video Creator and
Editor

xawtv, motv (analog), tv-
time, kdetv, zapping, Kaf-
feine

AVerTV, PowerVCR 3.0,
CinePlayer DVR

TV Viewer

A.3.1 Audio Players
Grip

Grip is a CD-player and CD-ripper for the Gnome desktop. It has the ripping capa-
bilities of cdparanoia built in, but can also use external rippers. It also provides an
automated front-end for MP3 (and other audio format) encoders, taking a disc and
transforming it straight intoMP3s. Formore details, seehttp://www.nostatic
.org/grip/.

Banshee
Banshee is a media player and can encode and decode various media formats, in-
cluding Ogg Vorbis, MP3 and FLAC. Banshee can play, import, and burn audio
CDs, and supports many portable media players, including Apple's iPod and Cre-
ative's ZEN. For more details, see http://banshee-project.org/.

KsCD
KsCD is a CD player application for the KDE desktop. Its user interface very much
resembles that of a normal hardware CD player KsCD supports CDDB, enabling
the user to track album information. For more details, see http://docs.kde
.org/en/3.3/kdemultimedia/kscd/.

328 Application Guide

http://www.nostatic.org/grip/
http://www.nostatic.org/grip/
http://banshee-project.org/
http://docs.kde.org/en/3.3/kdemultimedia/kscd/
http://docs.kde.org/en/3.3/kdemultimedia/kscd/


A.3.2 CD Burners
K3b

K3b is a CD and DVD authoring application for the KDE desktop environment for
Unix-like computer operating systems. It provides a graphical user interface to
performmost CD/DVD burning tasks like creating an Audio CD from a set of audio
files or copying a CD/DVD and a built-in DVD ripper. For more details, see
http://www.k3b.org/.

A.3.3 CD Rippers
Banshee

See Banshee (page 328)

KAudioCreator
KAudioCreator is a front-end tool for ripping audio CDs and encoding the WAV
files. Based on KDE it combines the look and feel of your desktop with the power
and flexibility of the command line tools. It allows the user to chose whatever en-
coder to encode audio files while providing a comfortable GUI. KAudioCreator
also provides a job control system so the user can see what files have succeeded,
failed and stop or cancel jobs as the application progresses. For more details, see
http://www.icefox.net/programs/?program=KAudioCreator.

Sound Juicer
Sound Juicer is a front-end application to the Cdparanoia CD ripping library. It
allows the user to extract audio from compact discs and convert it into audio files
that a personal computer or digital audio player can understand and play. It supports
ripping to any audio codecs. For more details, see http://www.burtonini
.com/blog/computers/sound-juicer.

A.3.4 Audio Players
amaroK

The amaroK media player handles various audio formats and plays the streaming
audio broadcasts of radio stations on the Internet. The program handles all file
types supported by the sound server acting as a back-end. For more details, see
http://amarok.kde.org/.
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Banshee
Rhythmbox is a powerful, multitalented media player for the GNOME desktop. It
allows you to organize and browse your music collection using playlists and even
supports Internet radio. Formore details, seehttp://projects.gnome.org/
rhythmbox.

XMMS
The XMultimedia System (XMMS) is a audio player very similar to Winamp, that
runs on many Unix-like operating systems. It focuses on music playback, offering
support for CD playback and Ogg Vorbis files. Users of Winamp should find
XMMS comfortable because of its similarity. For more details, see http://www
.xmms.org/.

A.3.5 Video Players
Kaffeine

Kaffeine is a versatile multimedia application supporting a wide range of audio
and video formats including Ogg Vorbis, WMV, MOV, and AVI. For more details,
see http://kaffeine.kde.org/.

MPplayer
MPlayer is available for Linux, Microsoft Windows and Mac OS X. MPlayer
supports a wide variety of media format. In addition to its wide range of supported
formats MPlayer can also save all streamed content to a file. For more details, see
http://www.mplayerhq.hu/.

Xine
Xine is a multimedia playback engine for Linux. xine is built around a shared library
(xine-lib) that supports different front-end player applications. Another important
feature is the ability to manually correct the synchronization of audio and video
streams. For more details, see http://xinehq.de/.

XMMS
See xawtv (page 332)

Banshee
Totem is a media player (audio and video) for the GNOME computer desktop en-
vironment which runs on Linux, Solaris, BSD and Unix-like systems. For more
details, see http://projects.gnome.org/totem/.
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XMMS
See XMMS (page 330)

RealPlayer
RealPlayer is a proprietary cross-platformmedia player by RealNetworks that plays
a number of multimedia formats, including MP3, MPEG-4, QuickTime and Win-
dows Media. For more details, see http://uk.real.com/player/.

A.3.6 Audio Editors
Audacity

Audacity is a digital audio editor application. It's cross-platform allows users to
mix tracks, apply effects to them, and export the results to WAV or Ogg Vorbis.
For more details, see http://audacity.sourceforge.net/..

A.3.7 Sound Mixers
alsamixer

alsamixer is themixer program for theAdvanced Linux SoundArchitecture (ALSA).
It is used to configure sound settings and to adjust the volume. It has an ncurses
user interface and does not require the X Window System. It supports multiple
sound cards with multiple devices. For more details, see http://www
.alsa-project.org/main/index.php/Main_Page.

A.3.8 Music Notation
LiliPond

LilyPond is a music sheet editor. Because the input format is text- based, the user
can work with any text editor to create note sheets. Users do not need to tackle any
formatting or notation issues, like spacing, line-breaking, or polyphonic collisions.
All these issues are automatically resolved by LilyPond. It supports many special
notations like chord names and tablatures. The output can be exported to PNG,
TeX, PDF, PostScript, and MIDI. For more details, see http://lilypond
.org/web/..
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MusE
MusE is at the moment a MIDI/Audio sequencer with recording and editing capa-
bilities. The project works on a complete multitrack virtual studio for Linux. For
more details, see http://www.muse-sequencer.org/index.

Noteedit
Noteedit is a powerful score editor for Linux. Use it to create sheets of notes and
to export and import scores to and from many formats, such as MIDI, MusicXML
and LilyPond. For more details, see http://developer.berlios.de/
projects/noteedit/.

Noteedit
Rosegarden is a free music composition and editing environment. It features an
audio and MIDI sequencer and a score editor. For more details, see http://
rosegardenmusic.com/.

A.3.9 Video Creators and Editors
Kino

Kino is an easy and reliable digital video editor with export to many formats. The
program supports many basic video editing and assembling tasks. It captures video
to disk in Raw DIV, AVI, and Quicktime formats. For more details, see http://
www.kinodv.org.

A.3.10 Music TV Viewers and Editors
xawtv

xawtv is a TV viewer and recorder suite. It supports both analog and digital audio
and video broadcasts using either a TV tuner or a Satellite receiver card DB-S. For
more details, see http://linux.bytesex.org/xawtv/.

kdetv
kdetv is a TV viewer and recorder application for the KDE desktop supporting
analog TV using a tuner card. For more details, see http://www.kdetv.org.

332 Application Guide

http://www.muse-sequencer.org/index
http://developer.berlios.de/projects/noteedit/
http://developer.berlios.de/projects/noteedit/
http://rosegardenmusic.com/
http://rosegardenmusic.com/
http://www.kinodv.org
http://www.kinodv.org
http://linux.bytesex.org/xawtv/
http://www.kdetv.org


A.4 Graphics
The following section presents some of the Linux software solutions for graphics work.
These include simple drawing applications as well as fully-fledged image editing tools
and powerful rendering and animation programs.

Table A.4 Graphics Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

KolourPaintMicrosoft PaintSimple Graphic Editing

The GIMP, KritaAdobe Photoshop, Paint Shop
Pro, Corel PhotoPaint, The
GIMP

Professional Graphic
Editing

OpenOffice.org Draw,
Inkscape, Dia

Adobe Illustrator, CorelDraw,
Freehand

Creating Vector Graph-
ics

Inkscape, Dia, KivioWebDraw, Freehand, Adobe
Illustrator

SVG Editing

POV-Ray, Blender,
KPovmodeler

3DStudioMAX,Maya, POV-
Ray, Blender

Creating 3D Graphics

DigiKam, f-spotSoftware provided by the
camera manufacturer

Managing Digital Pho-
tographs

Vuescan, The GIMPVuescanScanning

gwenview, gThumb, Eye
of Gnome, f-spot

ACDSeeImage Viewing

Blender
Blender is a powerful rendering and animation tool available on many platforms,
including Windows, MacOS, and Linux. For more details see http://www
.blender.org/.
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Dia
Dia is a Linux application aiming to be the Linux equivalent of Visio. It supports
many types of special diagrams, such as network or UML charts. Export formats
include SVG, PNG, and EPS. To support your own custom diagram types, provide
the new shapes in a special XML format. Formore details seehttp://projects
.gnome.org/dia/.

digiKam
digiKam is a smart digital photo management tool for the KDE desktop. Importing
and organizing your digital images is a matter of a few clicks. Create albums, add
tags to spare you from copying images around different subdirectories, and eventu-
ally export your images to your ownWeb site. For more details see http://www
.digikam.org/ or read Chapter 23, Managing Your Digital Image Collection
(page 227).

Eye of Gnome (eog)
Eye of Gnome is an image viewer application for the GNOME desktop. For more
details, see http://projects.gnome.org/eog/.

f-spot
f-spot is a flexible digital photograph management tool for the GNOME desktop.
It lets you create and manage albums and supports various export options like
HTML pages or burning of image archives to CD. You can also use it as an image
viewer on the command line. For more details, seehttp://f-spot.org/Main
_Page or read Chapter 24,Managing Your Digital Image Collection with F-Spot
(page 249).

gThumb
gThumb is an image viewer, browser, and organizer for the GNOME desktop. It
supports the import of your digital images via gphoto2, allows you to carry out
basic transformation and modifications, and lets you tag your images to create al-
bums matching certain categories. For more details, see http://gthumb
.sourceforge.net/.

Gwenview
Gwenview is a simple image viewer for KDE. It features a folder tree window and
a file list window that provides easy navigation of your file hierarchy. For more
details, see http://gwenview.sourceforge.net/home/.
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Inkscape
Inkscape is a free SVG editor. Users of Adobe Illustrator, Corel Draw, and Visio
can find a similar range of features and a familiar user interface in Inkscape. Among
its features, find SVG-to-PNG export, layering, transforms, gradients, and grouping
of objects. For more details, see http://www.inkscape.org/.

Kivio
Kivio is a flow-charting application that integrates into the KOffice suite. Former
users of Visio find a familiar look and feel in Kivio. For more details, see http://
www.koffice.org/kivio/.

KolourPaint
KolourPaint is an easy-to-use paint program for the KDE desktop. You can use it
for tasks such as painting or drawing diagrams and editing screen shots, photos,
and icons. Formore details, seehttp://kolourpaint.sourceforge.net/.

KPovmodeler
KPovmodeler is a POV-Ray front-end that integrates with the KDE desktop.
KPovmodeler saves users from needing a detailed knowledge of POV-Ray scripting
by translating the POV-Ray language in an easy-to-understand tree view. Native
POV-Ray scripts can be imported to KPovmodeler as well. For more details, see
http://www.kpovmodeler.org.

Krita
Krita is KOffice's answer to Adobe Photoshop and The GIMP. It can be used for
pixel-based image creation and editing. Its features include many of the advanced
image editing capabilities you would normally expect with Adobe Photoshop or
The GIMP. For more details, see http://www.koffice.org/krita.

OpenOffice.org Draw
See OpenOffice.org (page 318).

POV-Ray
The Persistence of Vision Raytracer creates three-dimensional, photo-realistic im-
ages using a rendering technique called ray tracing. Because there is a Windows
version of POV-Ray, it does not take much for Windows users to switch to the
Linux version of this application. For more details, see http://www.povray
.org/.
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The GIMP
GIMP (GNU ImageManipulation Program) is an open source equivalent to Adobe
Photoshop. It is a raster graphics editor used to process digital graphics and pho-
tographs. For more details, see http://www.gimp.org/ or read our GIMP
chapter.

VueScan
VueScan is a scanning software available for several platforms. You can install it
parallel to your vendor's scanner software. It supports the scanner's special hardware,
like batch scanning, autofocus, infrared channels for dust and scratch suppression,
and multiscan to reduce scanner noise in the dark areas of slides. It features simple
and accurate color correction. For more details, see http://www.hamrick
.com/index.html.

A.5 System and File Management
The following section provides an overview of Linux tools for system and file manage-
ment. Get to know text and source code editors, backup solutions, and archiving tools.

Table A.5 System and File Management Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

Konqueror, NautilusWindows ExplorerFile Manager

kate, GEdit, (X)Emacs,
vim

NotePad, WordPad,
(X)Emacs

Text Editor

ScribusAdobe DistillerPDF Creator

Adobe Reader, Evince,
KPDF, Xpdf

Adobe ReaderPDF Viewer

GOCRRecognita, FineReaderText Recognition

zip, tar, gzip, bzip2, etc.zip, rar, arj, lha, etc.Command Line Pack
Programs
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Linux ApplicationWindows ApplicationTask

Ark, File RollerWinZipGUI Based Pack Pro-
grams

YaST, GNU PartedPowerQuest, Acronis, Parti-
tion Commander

Hard Disk Partitioner

KDar, taper, dumpntbackup, VeritasBackup Software

Adobe Reader
Adobe Reader for Linux is the exact counterpart of theWindows andMac versions
of this application. The look and feel on Linux are the same as on other platforms.
The other parts of the Adobe Acrobat suite have not been ported to Linux. For more
details, seehttp://www.adobe.com/products/acrobat/readermain
.html.

Ark
Ark is a GUI-based pack program for the KDE desktop. It supports common formats,
such as zip, tar.gz, tar.bz2, lha, and rar. You can view, select, pack, and
unpack single files within an archive. For more details, see Section “Displaying,
Decompressing, and Creating Archives” (Chapter 2, Working with Your Desktop,
↑KDE User Guide).

dump
The dump package contains both dump and restore. dump examines files in a file
system, determines which ones need to be backed up, and copies those files to a
specified disk, tape, or other storage medium. The restore command performs the
inverse function of dump—it can restore a full backup of a file system. For more
details, see http://dump.sourceforge.net/.

Evince
Evince is a document viewer for PDF and PostScript formats for the GNOME
desktop. For more details, see http://www.gnome.org/projects/
evince/.
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File Roller
File Roller is a GUI-based pack program for the GNOME desktop. It provides
features similar to Ark's. For more details, see http://fileroller
.sourceforge.net/home.html.

GEdit
GEdit is the official text editor of the GNOME desktop. It provides features similar
to Kate's. For more details, see http://www.gnome.org/projects/
gedit/.

GNU Parted
GNU Parted is a command line tool for creating, destroying, resizing, checking,
and copying partitions and the file systems on them. If you need to create space
for new operating systems, use this tool to reorganize disk usage and copy data
between different hard disks. For more details, see http://www.gnu.org/
software/parted/.

GOCR
GOCR is an OCR (optical character recognition) tool. It converts scanned images
of text into text files. For more details, see http://jocr.sourceforge
.net/.

gzip, tar, bzip2
There are plenty of packaging programs for reducing disk usage. In general, they
differ only in their pack algorithm. Linux can also handle the packaging formats
used on Windows. bzip2 is a bit more efficient than gzip, but needs more time,
depending on the pack algorithm. For more details about gzip and tar, read the
shell chapter.

kate
Kate is a module of the KDE suite. It has the ability to open several files at once
either locally or remotely. With syntax highlighting, project file creation, and ex-
ternal scripts execution, it is a perfect tool for a programmer. For more details, see
http://kate.kde.org/.

KDar
Kerr stands for KDE disk archiver and is a hardware-independent backup solution.
KDar uses catalogs (unlike tar), so it is possible to extract a single file without
reading the whole archive and it is also possible to create incremental backups.
KDar can split an archive into multiple slices and trigger the burning of a data CD
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or DVD for each slice. For more details, see http://kdar.sourceforge
.net/.

Konqueror
Konqueror is the default file manager for the KDE desktop, which can also be used
as aWeb browser, document and image viewer, and CD ripper. For an introduction
to using Konqueror as a file manager, see Section “Using Dolphin File Manager”
(Chapter 2,Working with Your Desktop, ↑KDE User Guide). For more details, see
http://www.konqueror.org/.

KPDF
KPDF is a PDF viewing application for the KDE desktop. Its features include
searching the PDF and full screen reading mode like in Adobe Reader. For more
details, see http://kpdf.kde.org/.

Nautilus
Nautilus is the default file manager of the GNOME desktop. It can be used to create
folders and documents, display and manage your files and folders, run scripts, write
data to a CD, and open URI locations. For more details, see http://www.gnome
.org/projects/nautilus/ or read Section “Managing Folders and Files
with Nautilus” (Chapter 1, Getting Started with the GNOME Desktop, ↑GNOME
User Guide).

taper
Taper is a backup and restore program that provides a friendly user interface to allow
backup and restoration of files to and from a tape drive. Alternatively, files can be
backed up to archive files. Recursively selected directories are supported. For more
details, see at http://taper.sourceforge.net/.

vim
vim (vi improved) is a program similar to the text editor vi. Users may need time
to adjust to vim, because it distinguishes between commandmode and insert mode.
The basic features are the same as in all text editors. vim offers some unique options,
like macro recording, file format detection and conversion, and multiple buffers in
a screen. For more details, see http://www.vim.org/.

(X)Emacs
GNU Emacs and XEmacs are very professional editors. XEmacs is based on GNU
Emacs. To quote the GNU EmacsManual, “Emacs is the extensible, customizable,
self-documenting real-time display editor.” Both offer nearly the same functional-
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ity with minor differences. Used by experienced developers, they are highly exten-
sible through the Emacs Lisp language. They support many languages, like Russian,
Greek, Japanese, Chinese, and Korean. For more details see http://www
.xemacs.org/ and http://www.gnu.org/software/emacs/emacs
.html.

Xpdf
Xpdf is lean PDF viewing suite for Linux and Unix platforms. It includes a viewer
application and some export plug-ins for PostScript or text formats. For more details,
see http://www.foolabs.com/xpdf/.

A.6 Software Development
This section introduces Linux IDEs, toolkits, development tools, and versioning systems
for professional software development.

Table A.6 Development Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

KDevelop, Eric, Eclipse,
MonoDevelop, Anjuta

Borland C++, Delphi, Visual
Studio, .NET

IntegratedDevelopment
Environments

Qt, GTK+MFC, Qt, GTK+Toolkits

GCCVisualStudioCompilers

GDB, valgrindinformation about GDB at Vi-
sual Studio

Debugging Tools

Glade, Qt DesignerVisual Basic, Visual C++GUI Design

CVS, SubversionClearcase, Perforce, Source-
Safe

Versioning Systems

Anjuta
Anjuta is an IDE for GNOME/GTK+ application development. It includes an editor
with automated formatting, code completion, and highlighting. As well as GTK+,
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it supports Perl, Pascal, and Java development. A GDB-based debugger is also in-
cluded. For more details see http://anjuta.sourceforge.net.

CVS
CVS (Concurrent Versions System) is one of the most important version control
systems for open source. It is a front-end to the Revision Control System (RCS)
included in the standard Linux distributions. For more details, see http://
ximbiot.com/cvs/.

Eclipse
The Eclipse Platform is designed for building integrated development environments
that can be extended with custom plug-ins. The base distribution also contains a
full-featured Java development environment. For more details, see http://www
.eclipse.org.

Eric
Eric is an IDE optimized for Python and Python-Qt development. For more details,
see http://www.die-offenbachs.de/eric/index.html.

GCC
GCC is a compiler collection with front-ends for various programming languages.
Check out a complete list of features and find extensive documentation at http://
gcc.gnu.org.

GDB
GDB is a debugging tool for programs written in various programming languages.
For more details, see http://www.gnu.org/software/gdb/gdb.html.

Glade
Glade is a user interface builder for GTK+ and GNOME development. As well as
GTK+ support, it offers support for C, C++, C#, Perl, Python, Java, and others.
For more details, see http://glade.gnome.org/.

GTK+
GTK+ is a multiplatform toolkit for creating graphical user interfaces. It is used
for all GNOME applications, The GIMP, and several others. GTK+ has been de-
signed to support a range of languages, not only C/C++. Originally it was written
for GIMP, hence the name “GIMP Toolkit.” For more details, see http://www
.gtk.org. Language bindings for GTK+ are summarized under http://gtk
.org/features.html#LanguageBindings.
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KDevelop
KDevelop allows you to write programs for different languages (C/C++, Python,
Perl, etc.). It includes a documentation browser, a source code editor with syntax
highlighting, a GUI for the compiler, and much more. For more details, see
http://www.kdevelop.org.

MonoDevelop
The Mono Project is an open development initiative that is working to develop an
open source Unix version of the .NET development platform. Its objective is to
enable Unix developers to build and deploy cross-platform .NET applications.
MonoDevelop complements theMono development with an IDE. Formore details,
see http://www.monodevelop.com/.

Qt
Qt is a program library for developing applications with graphical user interfaces.
It allows you to develop professional programs rapidly. The Qt library is available
not only for Linux, but for a number of Unix flavors and even for Windows and
Macintosh. Thus it is possible to write programs that can be easily ported to those
platforms. For more details, see http://trolltech.com. Language bindings
for Qt development are summarized under http://developer.kde.org/
language-bindings/.

Qt Designer
Qt Designer is a user interface and form builder for Qt and KDE development. It
can be run as part of the KDevelop IDE or in stand-alone mode. QtDesigner can
be run under Windows and even integrates into the Visual Studio development
suite. For more details see http://trolltech.com/products/qt/
designer.html.

Subversion
Subversion does the same thing CVS does but hasmajor enhancements, likemoving,
renaming, and attachingmeta information to files and directories. For more details,
see http://subversion.tigris.org/.

Valgrind
Valgrind is a suite of programs for debugging and profiling x86 applications. For
more details, see http://valgrind.org/.
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BGNU Licenses
This appendix contains the GNUGeneral Public License and the GNU Free Documen-
tation License.

GNU General Public License
Version 2, June 1991

Copyright (C) 1989, 1991 Free Software Foundation, Inc. 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

Preamble
The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General Public License is intended
to guarantee your freedom to share and change free software--to make sure the software is free for all its users. This General Public License applies to
most of the Free Software Foundation’s software and to any other program whose authors commit to using it. (Some other Free Software Foundation
software is covered by the GNU Library General Public License instead.) You can apply it to your programs, too.

Whenwe speak of free software, we are referring to freedom, not price. Our General Public Licenses are designed to make sure that you have the freedom
to distribute copies of free software (and charge for this service if you wish), that you receive source code or can get it if you want it, that you can change
the software or use pieces of it in new free programs; and that you know you can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to ask you to surrender the rights. These restrictions
translate to certain responsibilities for you if you distribute copies of the software, or if you modify it.

For example, if you distribute copies of such a program, whether gratis or for a fee, you must give the recipients all the rights that you have. You must
make sure that they, too, receive or can get the source code. And you must show them these terms so they know their rights.

We protect your rights with two steps: (1) copyright the software, and (2) offer you this license which gives you legal permission to copy, distribute
and/or modify the software.

Also, for each author’s protection and ours, we want to make certain that everyone understands that there is no warranty for this free software. If the
software is modified by someone else and passed on, we want its recipients to know that what they have is not the original, so that any problems introduced
by others will not reflect on the original authors’ reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the danger that redistributors of a free program will individu-
ally obtain patent licenses, in effect making the program proprietary. To prevent this, we have made it clear that any patent must be licensed for everyone’s
free use or not licensed at all.

The precise terms and conditions for copying, distribution and modification follow.



GNUGENERAL PUBLIC LICENSE TERMS AND CONDITIONS FOR COPYING, DISTRIBUTIONANDMODIFICATION
0. This License applies to any program or other work which contains a notice placed by the copyright holder saying it may be distributed under the
terms of this General Public License. The “Program”, below, refers to any such program or work, and a “work based on the Program” means either the
Program or any derivative work under copyright law: that is to say, a work containing the Program or a portion of it, either verbatim or with modifications
and/or translated into another language. (Hereinafter, translation is included without limitation in the term “modification”.) Each licensee is addressed
as “you”.

Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The act of running the Program
is not restricted, and the output from the Program is covered only if its contents constitute a work based on the Program (independent of having been
made by running the Program). Whether that is true depends on what the Program does.

1. You may copy and distribute verbatim copies of the Program’s source code as you receive it, in any medium, provided that you conspicuously
and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this License
and to the absence of any warranty; and give any other recipients of the Program a copy of this License along with the Program.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Program or any portion of it, thus forming a work based on the Program, and copy and distribute such
modifications or work under the terms of Section 1 above, provided that you also meet all of these conditions:

a) You must cause the modified files to carry prominent notices stating that you changed the files and the date of any change.

b) You must cause any work that you distribute or publish, that in whole or in part contains or is derived from the Program or any part thereof, to
be licensed as a whole at no charge to all third parties under the terms of this License.

c) If the modified program normally reads commands interactively when run, you must cause it, when started running for such interactive use in the
most ordinary way, to print or display an announcement including an appropriate copyright notice and a notice that there is no warranty (or else, saying
that you provide a warranty) and that users may redistribute the program under these conditions, and telling the user how to view a copy of this License.
(Exception: if the Program itself is interactive but does not normally print such an announcement, your work based on the Program is not required to
print an announcement.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from the Program, and can be reasonably
considered independent and separate works in themselves, then this License, and its terms, do not apply to those sections when you distribute them as
separate works. But when you distribute the same sections as part of a whole which is a work based on the Program, the distribution of the whole must
be on the terms of this License, whose permissions for other licensees extend to the entire whole, and thus to each and every part regardless of who
wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the intent is to exercise the right to
control the distribution of derivative or collective works based on the Program.

In addition, mere aggregation of another work not based on the Program with the Program (or with a work based on the Program) on a volume of a
storage or distribution medium does not bring the other work under the scope of this License.

3. You may copy and distribute the Program (or a work based on it, under Section 2) in object code or executable form under the terms of Sections
1 and 2 above provided that you also do one of the following:

a) Accompany it with the complete corresponding machine-readable source code, which must be distributed under the terms of Sections 1 and 2
above on a medium customarily used for software interchange; or,

b) Accompany it with a written offer, valid for at least three years, to give any third party, for a charge no more than your cost of physically performing
source distribution, a complete machine-readable copy of the corresponding source code, to be distributed under the terms of Sections 1 and 2 above
on a medium customarily used for software interchange; or,

c) Accompany it with the information you received as to the offer to distribute corresponding source code. (This alternative is allowed only for
noncommercial distribution and only if you received the program in object code or executable form with such an offer, in accord with Subsection b
above.)

The source code for a work means the preferred form of the work for making modifications to it. For an executable work, complete source code means
all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used to control compilation and installation
of the executable. However, as a special exception, the source code distributed need not include anything that is normally distributed (in either source
or binary form) with the major components (compiler, kernel, and so on) of the operating system on which the executable runs, unless that component
itself accompanies the executable.

If distribution of executable or object code is made by offering access to copy from a designated place, then offering equivalent access to copy the
source code from the same place counts as distribution of the source code, even though third parties are not compelled to copy the source along with
the object code.

4. You may not copy, modify, sublicense, or distribute the Program except as expressly provided under this License. Any attempt otherwise to copy,
modify, sublicense or distribute the Program is void, and will automatically terminate your rights under this License. However, parties who have received
copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.
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5. You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to modify or distribute the
Program or its derivative works. These actions are prohibited by law if you do not accept this License. Therefore, by modifying or distributing the
Program (or any work based on the Program), you indicate your acceptance of this License to do so, and all its terms and conditions for copying, dis-
tributing or modifying the Program or works based on it.

6. Each time you redistribute the Program (or any work based on the Program), the recipient automatically receives a license from the original licensor
to copy, distribute or modify the Program subject to these terms and conditions. You may not impose any further restrictions on the recipients’ exercise
of the rights granted herein. You are not responsible for enforcing compliance by third parties to this License.

7. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent issues), conditions are
imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of this License, they do not excuse you from the conditions
of this License. If you cannot distribute so as to satisfy simultaneously your obligations under this License and any other pertinent obligations, then as
a consequence you may not distribute the Program at all. For example, if a patent license would not permit royalty-free redistribution of the Program
by all those who receive copies directly or indirectly through you, then the only way you could satisfy both it and this License would be to refrain en-
tirely from distribution of the Program.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the section is intended to apply and the
section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity of any such claims; this
section has the sole purpose of protecting the integrity of the free software distribution system, which is implemented by public license practices. Many
people have made generous contributions to the wide range of software distributed through that system in reliance on consistent application of that
system; it is up to the author/donor to decide if he or she is willing to distribute software through any other system and a licensee cannot impose that
choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

8. If the distribution and/or use of the Program is restricted in certain countries either by patents or by copyrighted interfaces, the original copyright
holder who places the Program under this License may add an explicit geographical distribution limitation excluding those countries, so that distribution
is permitted only in or among countries not thus excluded. In such case, this License incorporates the limitation as if written in the body of this License.

9. The Free Software Foundation may publish revised and/or new versions of the General Public License from time to time. Such new versions will
be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Program specifies a version number of this License which applies to it and “any later
version”, you have the option of following the terms and conditions either of that version or of any later version published by the Free Software Foun-
dation. If the Program does not specify a version number of this License, you may choose any version ever published by the Free Software Foundation.

10. If you wish to incorporate parts of the Program into other free programs whose distribution conditions are different, write to the author to ask
for permission. For software which is copyrighted by the Free Software Foundation, write to the Free Software Foundation; we sometimesmake exceptions
for this. Our decision will be guided by the two goals of preserving the free status of all derivatives of our free software and of promoting the sharing
and reuse of software generally.

NO WARRANTY

11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE PROGRAM, TO THE EXTENT
PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER
PARTIES PROVIDE THE PROGRAM “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING,
BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE
ENTIRERISKASTOTHEQUALITYANDPERFORMANCEOFTHEPROGRAMISWITHYOU.SHOULDTHEPROGRAMPROVEDEFECTIVE,
YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR
ANY OTHER PARTY WHOMAYMODIFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR
DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR
INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE
ORLOSSES SUSTAINEDBYYOUORTHIRDPARTIESORAFAILUREOFTHEPROGRAMTOOPERATEWITHANYOTHERPROGRAMS),
EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS

How to Apply These Terms to Your New Programs
If you develop a new program, and you want it to be of the greatest possible use to the public, the best way to achieve this is to make it free software
which everyone can redistribute and change under these terms.

To do so, attach the following notices to the program. It is safest to attach them to the start of each source file to most effectively convey the exclusion
of warranty; and each file should have at least the “copyright” line and a pointer to where the full notice is found.

one line to give the program’s name and an idea of what it does. Copyright (C) yyyy name of author
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This program is free software; you can redistribute it and/or
modify it under the terms of the GNU General Public License
as published by the Free Software Foundation; either version 2
of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program; if not, write to the Free Software
Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.

Also add information on how to contact you by electronic and paper mail.

If the program is interactive, make it output a short notice like this when it starts in an interactive mode:

Gnomovision version 69, Copyright (C) year name of author
Gnomovision comes with ABSOLUTELY NO WARRANTY; for details
type `show w’. This is free software, and you are welcome
to redistribute it under certain conditions; type `show c’
for details.

The hypothetical commands `show w’ and `show c’ should show the appropriate parts of the General Public License. Of course, the commands you use
may be called something other than `show w’ and `show c’; they could even be mouse-clicks or menu items--whatever suits your program.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a “copyright disclaimer” for the program, if necessary.
Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright
interest in the program `Gnomovision’
(which makes passes at compilers) written
by James Hacker.

signature of Ty Coon, 1 April 1989
Ty Coon, President of Vice

This General Public License does not permit incorporating your program into proprietary programs. If your program is a subroutine library, you may
consider it more useful to permit linking proprietary applications with the library. If this is what you want to do, use the GNU Lesser General Public
License [http://www.fsf.org/licenses/lgpl.html] instead of this License.

GNU Free Documentation License
Version 1.2, November 2002

Copyright (C) 2000,2001,2002 Free Software Foundation, Inc. 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

PREAMBLE
The purpose of this License is to make a manual, textbook, or other functional and useful document “free” in the sense of freedom: to assure everyone
the effective freedom to copy and redistribute it, with or without modifying it, either commercially or noncommercially. Secondarily, this License preserves
for the author and publisher a way to get credit for their work, while not being considered responsible for modifications made by others.

This License is a kind of “copyleft”, which means that derivative works of the document must themselves be free in the same sense. It complements
the GNU General Public License, which is a copyleft license designed for free software.
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We have designed this License in order to use it for manuals for free software, because free software needs free documentation: a free program should
come with manuals providing the same freedoms that the software does. But this License is not limited to software manuals; it can be used for any
textual work, regardless of subject matter or whether it is published as a printed book. We recommend this License principally for works whose purpose
is instruction or reference.

APPLICABILITY AND DEFINITIONS
This License applies to any manual or other work, in any medium, that contains a notice placed by the copyright holder saying it can be distributed under
the terms of this License. Such a notice grants a world-wide, royalty-free license, unlimited in duration, to use that work under the conditions stated
herein. The “Document”, below, refers to any such manual or work. Any member of the public is a licensee, and is addressed as “you”. You accept the
license if you copy, modify or distribute the work in a way requiring permission under copyright law.

A “Modified Version” of the Document means any work containing the Document or a portion of it, either copied verbatim, or with modifications
and/or translated into another language.

A “Secondary Section” is a named appendix or a front-matter section of the Document that deals exclusively with the relationship of the publishers or
authors of the Document to the Document’s overall subject (or to related matters) and contains nothing that could fall directly within that overall subject.
(Thus, if the Document is in part a textbook of mathematics, a Secondary Section may not explain any mathematics.) The relationship could be a matter
of historical connection with the subject or with related matters, or of legal, commercial, philosophical, ethical or political position regarding them.

The “Invariant Sections” are certain Secondary Sections whose titles are designated, as being those of Invariant Sections, in the notice that says that the
Document is released under this License. If a section does not fit the above definition of Secondary then it is not allowed to be designated as Invariant.
The Document may contain zero Invariant Sections. If the Document does not identify any Invariant Sections then there are none.

The “Cover Texts” are certain short passages of text that are listed, as Front-Cover Texts or Back-Cover Texts, in the notice that says that the Document
is released under this License. A Front-Cover Text may be at most 5 words, and a Back-Cover Text may be at most 25 words.

A “Transparent” copy of the Document means a machine-readable copy, represented in a format whose specification is available to the general public,
that is suitable for revising the document straightforwardly with generic text editors or (for images composed of pixels) generic paint programs or (for
drawings) some widely available drawing editor, and that is suitable for input to text formatters or for automatic translation to a variety of formats
suitable for input to text formatters. A copy made in an otherwise Transparent file format whose markup, or absence of markup, has been arranged to
thwart or discourage subsequent modification by readers is not Transparent. An image format is not Transparent if used for any substantial amount of
text. A copy that is not “Transparent” is called “Opaque”.

Examples of suitable formats for Transparent copies include plain ASCII without markup, Texinfo input format, LaTeX input format, SGML or XML
using a publicly available DTD, and standard-conforming simple HTML, PostScript or PDF designed for human modification. Examples of transparent
image formats include PNG, XCF and JPG. Opaque formats include proprietary formats that can be read and edited only by proprietary word processors,
SGML or XML for which the DTD and/or processing tools are not generally available, and the machine-generated HTML, PostScript or PDF produced
by some word processors for output purposes only.

The “Title Page” means, for a printed book, the title page itself, plus such following pages as are needed to hold, legibly, the material this License requires
to appear in the title page. For works in formats which do not have any title page as such, “Title Page” means the text near the most prominent appearance
of the work’s title, preceding the beginning of the body of the text.

A section “Entitled XYZ” means a named subunit of the Document whose title either is precisely XYZ or contains XYZ in parentheses following text
that translates XYZ in another language. (Here XYZ stands for a specific section name mentioned below, such as “Acknowledgements”, “Dedications”,
“Endorsements”, or “History”.) To “Preserve the Title” of such a section when you modify the Document means that it remains a section “Entitled
XYZ” according to this definition.

The Document may includeWarranty Disclaimers next to the notice which states that this License applies to the Document. TheseWarranty Disclaimers
are considered to be included by reference in this License, but only as regards disclaimingwarranties: any other implication that theseWarranty Disclaimers
may have is void and has no effect on the meaning of this License.

VERBATIM COPYING
You may copy and distribute the Document in any medium, either commercially or noncommercially, provided that this License, the copyright notices,
and the license notice saying this License applies to the Document are reproduced in all copies, and that you add no other conditions whatsoever to
those of this License. You may not use technical measures to obstruct or control the reading or further copying of the copies you make or distribute.
However, you may accept compensation in exchange for copies. If you distribute a large enough number of copies you must also follow the conditions
in section 3.

You may also lend copies, under the same conditions stated above, and you may publicly display copies.

COPYING IN QUANTITY
If you publish printed copies (or copies in media that commonly have printed covers) of the Document, numbering more than 100, and the Document’s
license notice requires Cover Texts, you must enclose the copies in covers that carry, clearly and legibly, all these Cover Texts: Front-Cover Texts on
the front cover, and Back-Cover Texts on the back cover. Both covers must also clearly and legibly identify you as the publisher of these copies. The
front cover must present the full title with all words of the title equally prominent and visible. You may add other material on the covers in addition.
Copying with changes limited to the covers, as long as they preserve the title of the Document and satisfy these conditions, can be treated as verbatim
copying in other respects.
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If the required texts for either cover are too voluminous to fit legibly, you should put the first ones listed (as many as fit reasonably) on the actual cover,
and continue the rest onto adjacent pages.

If you publish or distribute Opaque copies of the Document numbering more than 100, you must either include a machine-readable Transparent copy
along with each Opaque copy, or state in or with each Opaque copy a computer-network location fromwhich the general network-using public has access
to download using public-standard network protocols a complete Transparent copy of the Document, free of added material. If you use the latter option,
you must take reasonably prudent steps, when you begin distribution of Opaque copies in quantity, to ensure that this Transparent copy will remain thus
accessible at the stated location until at least one year after the last time you distribute an Opaque copy (directly or through your agents or retailers) of
that edition to the public.

It is requested, but not required, that you contact the authors of the Document well before redistributing any large number of copies, to give them a
chance to provide you with an updated version of the Document.

MODIFICATIONS
You may copy and distribute a Modified Version of the Document under the conditions of sections 2 and 3 above, provided that you release the Modified
Version under precisely this License, with the Modified Version filling the role of the Document, thus licensing distribution and modification of the
Modified Version to whoever possesses a copy of it. In addition, you must do these things in the Modified Version:

A. Use in the Title Page (and on the covers, if any) a title distinct from that of the Document, and from those of previous versions (which should, if
there were any, be listed in the History section of the Document). You may use the same title as a previous version if the original publisher of that version
gives permission.

B. List on the Title Page, as authors, one or more persons or entities responsible for authorship of the modifications in the Modified Version, together
with at least five of the principal authors of the Document (all of its principal authors, if it has fewer than five), unless they release you from this require-
ment.

C. State on the Title page the name of the publisher of the Modified Version, as the publisher.

D. Preserve all the copyright notices of the Document.

E. Add an appropriate copyright notice for your modifications adjacent to the other copyright notices.

F. Include, immediately after the copyright notices, a license notice giving the public permission to use the Modified Version under the terms of this
License, in the form shown in the Addendum below.

G. Preserve in that license notice the full lists of Invariant Sections and required Cover Texts given in the Document’s license notice.

H. Include an unaltered copy of this License.

I. Preserve the section Entitled “History”, Preserve its Title, and add to it an item stating at least the title, year, new authors, and publisher of the
Modified Version as given on the Title Page. If there is no section Entitled “History” in the Document, create one stating the title, year, authors, and
publisher of the Document as given on its Title Page, then add an item describing the Modified Version as stated in the previous sentence.

J. Preserve the network location, if any, given in the Document for public access to a Transparent copy of the Document, and likewise the network
locations given in the Document for previous versions it was based on. These may be placed in the “History” section. You may omit a network location
for a work that was published at least four years before the Document itself, or if the original publisher of the version it refers to gives permission.

K. For any section Entitled “Acknowledgements” or “Dedications”, Preserve the Title of the section, and preserve in the section all the substance
and tone of each of the contributor acknowledgements and/or dedications given therein.

L. Preserve all the Invariant Sections of the Document, unaltered in their text and in their titles. Section numbers or the equivalent are not considered
part of the section titles.

M. Delete any section Entitled “Endorsements”. Such a section may not be included in the Modified Version.

N. Do not retitle any existing section to be Entitled “Endorsements” or to conflict in title with any Invariant Section.

O. Preserve any Warranty Disclaimers.

If the Modified Version includes new front-matter sections or appendices that qualify as Secondary Sections and contain no material copied from the
Document, you may at your option designate some or all of these sections as invariant. To do this, add their titles to the list of Invariant Sections in the
Modified Version’s license notice. These titles must be distinct from any other section titles.

Youmay add a section Entitled “Endorsements”, provided it contains nothing but endorsements of yourModified Version by various parties--for example,
statements of peer review or that the text has been approved by an organization as the authoritative definition of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a passage of up to 25 words as a Back-Cover Text, to the end of the list of
Cover Texts in the Modified Version. Only one passage of Front-Cover Text and one of Back-Cover Text may be added by (or through arrangements
made by) any one entity. If the Document already includes a cover text for the same cover, previously added by you or by arrangement made by the
same entity you are acting on behalf of, you may not add another; but you may replace the old one, on explicit permission from the previous publisher
that added the old one.
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The author(s) and publisher(s) of the Document do not by this License give permission to use their names for publicity for or to assert or imply endorsement
of any Modified Version.

COMBINING DOCUMENTS
You may combine the Document with other documents released under this License, under the terms defined in section 4 above for modified versions,
provided that you include in the combination all of the Invariant Sections of all of the original documents, unmodified, and list them all as Invariant
Sections of your combined work in its license notice, and that you preserve all their Warranty Disclaimers.

The combined work need only contain one copy of this License, and multiple identical Invariant Sections may be replaced with a single copy. If there
are multiple Invariant Sections with the same name but different contents, make the title of each such section unique by adding at the end of it, in
parentheses, the name of the original author or publisher of that section if known, or else a unique number. Make the same adjustment to the section titles
in the list of Invariant Sections in the license notice of the combined work.

In the combination, you must combine any sections Entitled “History” in the various original documents, forming one section Entitled “History”; likewise
combine any sections Entitled “Acknowledgements”, and any sections Entitled “Dedications”. You must delete all sections Entitled “Endorsements”.

COLLECTIONS OF DOCUMENTS
Youmaymake a collection consisting of the Document and other documents released under this License, and replace the individual copies of this License
in the various documents with a single copy that is included in the collection, provided that you follow the rules of this License for verbatim copying
of each of the documents in all other respects.

You may extract a single document from such a collection, and distribute it individually under this License, provided you insert a copy of this License
into the extracted document, and follow this License in all other respects regarding verbatim copying of that document.

AGGREGATION WITH INDEPENDENT WORKS
A compilation of the Document or its derivatives with other separate and independent documents or works, in or on a volume of a storage or distribution
medium, is called an “aggregate” if the copyright resulting from the compilation is not used to limit the legal rights of the compilation’s users beyond
what the individual works permit. When the Document is included in an aggregate, this License does not apply to the other works in the aggregate which
are not themselves derivative works of the Document.

If the Cover Text requirement of section 3 is applicable to these copies of the Document, then if the Document is less than one half of the entire aggregate,
the Document’s Cover Texts may be placed on covers that bracket the Document within the aggregate, or the electronic equivalent of covers if the
Document is in electronic form. Otherwise they must appear on printed covers that bracket the whole aggregate.

TRANSLATION
Translation is considered a kind of modification, so you may distribute translations of the Document under the terms of section 4. Replacing Invariant
Sections with translations requires special permission from their copyright holders, but you may include translations of some or all Invariant Sections
in addition to the original versions of these Invariant Sections. You may include a translation of this License, and all the license notices in the Document,
and any Warranty Disclaimers, provided that you also include the original English version of this License and the original versions of those notices and
disclaimers. In case of a disagreement between the translation and the original version of this License or a notice or disclaimer, the original version will
prevail.

If a section in the Document is Entitled “Acknowledgements”, “Dedications”, or “History”, the requirement (section 4) to Preserve its Title (section 1)
will typically require changing the actual title.

TERMINATION
You may not copy, modify, sublicense, or distribute the Document except as expressly provided for under this License. Any other attempt to copy,
modify, sublicense or distribute the Document is void, and will automatically terminate your rights under this License. However, parties who have received
copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

FUTURE REVISIONS OF THIS LICENSE
The Free Software Foundation may publish new, revised versions of the GNU Free Documentation License from time to time. Such new versions will
be similar in spirit to the present version, but may differ in detail to address new problems or concerns. See http://www.gnu.org/copyleft/.

Each version of the License is given a distinguishing version number. If the Document specifies that a particular numbered version of this License “or
any later version” applies to it, you have the option of following the terms and conditions either of that specified version or of any later version that has
been published (not as a draft) by the Free Software Foundation. If the Document does not specify a version number of this License, you may choose
any version ever published (not as a draft) by the Free Software Foundation.

ADDENDUM: How to use this License for your documents
To use this License in a document you have written, include a copy of the License in the document and put the following copyright and license notices
just after the title page:

Copyright (c) YEAR YOUR NAME.
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Permission is granted to copy, distribute and/or modify this document
under the terms of the GNU Free Documentation License, Version 1.2
only as published by the Free Software Foundation;
with the Invariant Section being this copyright notice and license.
A copy of the license is included in the section entitled “GNU
Free Documentation License”.

If you have Invariant Sections, Front-Cover Texts and Back-Cover Texts, replace the “with...Texts.” line with this:

with the Invariant Sections being LIST THEIR TITLES, with the
Front-Cover Texts being LIST, and with the Back-Cover Texts being LIST.

If you have Invariant Sections without Cover Texts, or some other combination of the three, merge those two alternatives to suit the situation.

If your document contains nontrivial examples of program code, we recommend releasing these examples in parallel under your choice of free software
license, such as the GNU General Public License, to permit their use in free software.
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