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About This Guide
This manual introduces you to the GNOME graphical desktop environment as imple-
mented in SUSE® Linux Enterprise Desktop and shows you how to configure it to
meet your personal needs and preferences. It also introduces you to several programs
and services, including office programs such as OpenOffice.org, Web browsers, file
managers, scanning tools, and image editing tools. It is intended for users who have
some experience using a graphical desktop environment such asMacintosh*,Windows*,
or other Linux desktops.

The manual is subdivided into the following parts:

GNOME Desktop
Get to know your GNOME desktop and learn how to cope with basic and daily
tasks, using the central GNOME applications and some small utilities. Get an im-
pression of the possibilities GNOME offers to modify and individualize your
desktop according to your needs and wishes.

Office and Collaboration
Use the office and collaboration software your openSUSE offers, such as the
OpenOffice.org suite, several e-mailing and calendaring programs, and applications
for online conversations. Also find vital information concerning the management
and exchange of data on your system: how to share files on the network, how to
effectively search and encrypt data, and how to manage printers.

Internet
Learn how to use NetworkManager to connect to the Internet. Explore the Internet
applications included in your openSUSE, such as the Firefox Web browser, or a
news feed reader.

Multimedia
Find topics such as graphics applications, digital cameras, sound applications, and
CD and DVD writers.

Many chapters in this manual contain links to additional documentation resources. This
includes additional documentation that is available on the system as well as documen-
tation available on the Internet.



For an overview of the documentation available for your product and the latest docu-
mentation updates, refer to http://www.novell.com/documentation or to
the following section.

1 Available Documentation
We provide HTML and PDF versions of our books in different languages. The following
manuals for users and administrators are available on this product:

Start-Up (↑Start-Up)
Guides you through the installation and basic configuration of your system. For
newcomers, the manual also introduces basic Linux concepts such as the file system,
the user concept and access permissions and gives an overview of the features
openSUSE offers to support mobile computing. Provides help and advice in trou-
bleshooting.

KDE User Guide (↑KDE User Guide)
Introduces the KDE desktop of openSUSE. It guides you through using and config-
uring the desktop and helps you perform key tasks. It is intended mainly for users
who want to make efficient use of KDE as their default desktop.

GNOME User Guide (page 1)
Introduces the GNOME desktop of openSUSE. It guides you through using and
configuring the desktop and helps you perform key tasks. It is intended mainly for
end users who want to make efficient use of GNOME desktop as their default
desktop.

Application Guide (↑Application Guide)
Learn how to use and configure key desktop applications on openSUSE. This guide
introduces browsers and e-mail clients as well as office applications and collabora-
tion tools. It also covers graphics and multimedia applications.

Reference (↑Reference)
Gives you a general understanding of openSUSE and covers advanced system ad-
ministration tasks. It is intended mainly for system administrators and home users
with basic system administration knowledge. It provides detailed information about
advanced deployment scenarios, administration of your system, the interaction of
key system components and the set-up of various network and file services open-
SUSE offers.
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Novell AppArmor Administration Guide (↑Novell AppArmor Administration Guide)
Contains in-depth information about the use of Novell AppArmor in your environ-
ment. AppArmor is a security application that lets you specify per program which
files the program may read, write, and execute.

Lessons For Lizards
A community book project for the openSUSE distribution. A snapshot of the
manual written by the open source community is released on an equal footing with
the Novell/SUSE manuals. The lessons are written in a cook book style and cover
more specific or exotic topics than the traditional manuals. For more information,
see http://developer.novell.com/wiki/index.php/Lessons
_for_Lizards.

In addition to the comprehensive manuals, several quick start guides are available:

KDE Quick Start (↑)
Gives a short introduction to the KDE desktop and some key applications running
on it.

GNOME Quick Start (↑)
Gives a short introduction to the GNOME desktop and some key applications
running on it.

Novell AppArmor Quick Start
Helps you understand the main concepts behind Novell® AppArmor.

Find HTML versions of most openSUSEmanuals in your installed system under /usr/
share/doc/manual or in the help centers of your desktop. Find the latest documen-
tation updates at http://www.novell.com/documentation where you can
download PDF or HTML versions of the manuals for your product.

For information where to find the books on your installation media, refer to the Release
Notes of this product. The Release Notes are available from your installed system under
/usr/share/doc/release-notes/ or in the help centers of your KDE or
GNOME desktop.

2 Feedback
Several feedback channels are available:

About This Guide ix

http://developer.novell.com/wiki/index.php/Lessons_for_Lizards
http://developer.novell.com/wiki/index.php/Lessons_for_Lizards
http://www.novell.com/documentation


• To report bugs for a product component or to submit enhancements requests, please
use https://bugzilla.novell.com/. If you are new to Bugzilla, you
might find the Submitting Bug Reports article—available under http://en
.opensuse.org/Submitting_Bug_Reports helpful. Frequently asked
questions on reporting bugs are available under http://en.opensuse.org/
Bug_Reporting_FAQ.

• We want to hear your comments and suggestions about this manual and the other
documentation included with this product. Please use the User Comments feature
at the bottom of each page of the online documentation and enter your comments
there.

3 Documentation Conventions
The following typographical conventions are used in this manual:

• /etc/passwd: filenames and directory names

• placeholder: replace placeholder with the actual value

• PATH: the environment variable PATH

• ls, --help: commands, options, and parameters

• user: users or groups

• Alt, Alt + F1: a key to press or a key combination; keys are shown in uppercase as
on a keyboard

• File, File > Save As: menu items, buttons

• Dancing Penguins (Chapter Penguins, ↑Another Manual): This is a reference to a
chapter in another manual.
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4 About the Making of This Manual
This book is written in Novdoc, a subset of DocBook (see http://www.docbook
.org). The XML source files were validated by xmllint, processed by xsltproc,
and converted into XSL-FO using a customized version of NormanWalsh's stylesheets.
The final PDF is formatted through XEP from RenderX.

5 Source Code
The source code of openSUSE is publicly available. To download the source code,
proceed as outlined underhttp://www.novell.com/products/suselinux/
source_code.html. If requested we send you the source code on a DVD.We need
to charge a $15 or €15 fee for creation, handling and postage. To request a DVD of the
source code, send an e-mail to sourcedvd@suse.de [mailto:sourcedvd@suse
.de] or mail the request to:

SUSE Linux Products GmbH Product Management openSUSEMaxfeldstr. 5 D-90409
Nürnberg Germany

6 Acknowledgments
With a lot of voluntary commitment, the developers of Linux cooperate on a global
scale to promote the development of Linux. We thank them for their efforts—this dis-
tribution would not exist without them. Furthermore, we thank Frank Zappa and Pawar.
Special thanks, of course, goes to Linus Torvalds.

Have a lot of fun!
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Part I. Introduction to the
GNOME Desktop





1Getting Started with the
GNOME Desktop
This section describes the conventions, layout, and common tasks of the GNOME
desktop as implemented in your product.

GNOME is an easy-to-use graphical interface that can be customized to meet your
needs and personal preferences. This section describes the default configuration of
GNOME. If you or your system administrator modified the defaults, some aspect might
be different, such as appearance or keyboard shortcuts.

1.1 Logging In and Selecting a
Desktop

If more than one user account is configured on your computer, usually all users must
authenticate—unless Auto Login is enabled for a certain user. Auto login lets a user
automatically log in to the desktop environment when the system starts. This feature
can be enabled or disabled during installation or at any time using the YaST User
Management module. For more information, refer to Chapter 5,Managing Users with
YaST (↑Start-Up).

If your computer is running in a network environment and you are not the only person
using the machine, you are usually prompted to enter your username and password
when you start your system. If you did not set up your system and your user account,
check with your system administrator for your username and password.
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The programmanaging the login process depends on the desktop environment installed
on your system. For GNOME, it is GDM. If the KDE desktop is also installed on your
system, it might be KDM.

The login screen has the following items:

• Login prompt Enter your username and password to log in.

• Language menu Select a language for your session.

• Session menu Select the desktop to run during your session. If other desktops
are installed, they appear in the list.

• Restart Select to restart the computer.

• Shut Down Select to shut down the computer.

1.1.1 What Is a Session?
A session is the period of time from when you log in to when you log out. During a
session, you can use applications, print, browse the Web, and so on.

The login screen offers several login options. For example, you can select the language
of your session so that text that appears in the interface is presented in that language.

After your username and password are authenticated, the Session Manager starts. The
Session Manager lets you save certain settings for each session. It also lets you save
the state of your most recent session and return to that session the next time you log in.

The Session Manager can save and restore the following settings:

• Appearance and behavior settings, such as fonts, colors, and mouse settings.

• Applications that you were running. such as a file manager or an OpenOffice.org
program.
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TIP

You cannot save and restore applications that Session Manager does not
manage. For example, if you start the vi editor from the command line in
a terminal window, Session Manager cannot restore your editing session.

For information on configuring session preferences, see Section 2.5.8, “Managing
Sessions” (page 98).

1.1.2 Switching Desktops
If you installed both the GNOME and the KDE desktops, use the following instructions
to switch desktops.

1 Click Computer > Logout > Log Out.

In KDE, click the main menu button, then click Leave > Logout.

2 On the login screen, click Session.

3 Select the desktop you want (GNOME or KDE), then click Change Session.

4 Type your username, then press Enter.

5 Type your password, then press Enter.

1.1.3 Locking Your Screen
To lock the screen, you can do either of the following:

• Click Computer > Lock Screen.

• If the Lock button is present on a panel, click it.

To add the Lock button to a panel, right-click the panel, then click Add to Panel >
Lock Screen.
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When you lock your screen, the screen saver starts. To lock your screen correctly, you
must have a screen saver enabled. To unlock the screen, move your mouse to display
the locked screen dialog. Enter your username and password, then press Enter.

For information on configuring your screen saver, see Section 2.3.4, “Configuring the
Screen Saver” (page 67).

1.2 Logging Out
When you are finished using the computer, you can log out and leave the system running,
or restart or shut down the computer. If your system provides power management, you
can also suspend your computer, making the next system start much faster than a
complete reboot.

1.2.1 Logging Out or Switching Users
1 Click Computer > Logout.

2 Select one of the following options:

Log out Logs you out of the current session and returns you to the Login
screen.

Switch User Suspends your session, allowing another user to log in and use
the computer.

1.2.2 Restarting or Shutting Down the
Computer

1 Click Computer > Shutdown.

2 Select one of the following options:

Shutdown Logs you out of the current session, then turns off the computer.

Restart Logs you out of the current session, then restarts the computer.
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Suspend Puts your computer in a temporary state that conserves power. The
state of your session is preserved, however, including all applications you have
running and all documents you have open.

Hibernate Suspends your session, using no power until the computer is
restarted. The state of your session is preserved, however, including all applica-
tions you have running and all documents you have open.

1.3 Desktop Basics
Aswith other common desktop products, themain components of the GNOMEdesktop
are icons that link to files, folders, or programs, as well as the panel at the bottom of
the screen (similar to the Task Bar in Windows). Double-click an icon to start its asso-
ciated program. Right-click an icon to access additional menus and options. You can
also right-click any empty space on the desktop to access additional menus for config-
uring or managing the desktop itself.
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Figure 1.1 GNOME Desktop

By default, the desktop features two key icons: your personal Home folder and a trash
can for deleted items. Other icons may also be present on the desktop, such as icons
representing devices on your computer. If you double-click your Home folder, the
Nautilus file manager starts and displays the contents of your home directory. For more
information about using Nautilus, see Section 1.5, “Managing Folders and Files with
Nautilus” (page 17).

Right-clicking an icon displays a menu that offers file operations such as copying,
cutting, or renaming. SelectingProperties from themenu displays a configuration dialog.
On the Basic tab, you can change the name of the icon as well as the icon itself (by
clicking on it and selecting a file with a different one). Various information about the
object represented by the icon are also shown here. The Emblems tab lets you add
graphical descriptive symbols to the icon. The Permissions tab lets you set access per-
missions for the selected files. The Notes tab lets you manage comments. The menu
for the trash can also features the Empty Trash option, which deletes its contents.
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A link is a special type of file that points to another file or folder. When you perform
an action on a link, the action is performed on the file or folder that the link points to.
When you delete a link, you delete only the link file, not the file that the link points to.

To create a link on the desktop to a folder or a file, access the object in File Manager
by right-clicking the object and then clickingMake Link. Drag the link from the File
Manager window and drop it onto the desktop.

1.3.1 Default Desktop Icons
To remove an icon from the desktop, simply drag it onto the trash can. You cannot
move the Home icon to the trash.

WARNING

Be careful with this option—if you move folder or file icons to the trash can
and you empty the trash can, the actual data is deleted. If the icons only repre-
sent links to a file or to a directory, only the links are deleted.

1.3.2 Desktop Menu
Right-clicking an empty spot on the desktop displays a menu with various options.
Click Create Folder to create a new folder. Create a launcher icon for an application
with Create Launcher. Provide the name of the application and the command for
starting it, then select an icon to represent it. You can also change the desktop back-
ground and align desktop icons.

Getting Started with the GNOME Desktop 9



Figure 1.2 GNOME Desktop Menu

1.3.3 Bottom Panel
The desktop includes a panel across the bottom of the screen. The bottom panel contains
the Computer menu (similar to the Start menu in Windows*) and the icons of all appli-
cations currently running. You can also add applications and applets to the panel for
easy access. If you click the name of a program in the taskbar, the program's window
is moved to the foreground. If the program is already in the foreground, a mouse click
minimizes it. Clicking a minimized application reopens the respective window.

Figure 1.3 GNOME Bottom Panel

The Show Desktop icon is on the right side of the bottom panel. This icon minimizes
all programwindows and displays the desktop. Or, if all windows are alreadyminimized,
it reopens them.

If you right-click an empty spot in the panel, a menu opens, offering the options listed
in the following:

Table 1.1 Panel Menu Options

DescriptionOption

Opens a menu of applications and applets that can be added
to the panel.

Add to Panel
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DescriptionOption

Modifies the properties for this panel.Properties

Removes the panel from the desktop. All of the panel settings
are lost.

Delete This Panel

Lets you drag the panel to another side of the screen, or locks
the panel in its current position.

Allow Panel to be
Moved/Lock Panel
Position

Creates a new panel and adds it to the desktop.New Panel

Opens the Help Center.Help

Opens information about the panel application.About Panels

1.3.4 Adding Applets and Applications to
the Panel

You can add applications and applets to the bottom panel for quick access. An applet
is a small program, while an application is usually a more robust stand-alone program.
Adding an applet puts useful utilities where you can easily access them.

The GNOME desktop comes with many applets. You can see a complete list by right-
clicking the bottom panel and selecting Add to Panel.
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Figure 1.4 Add to Panel Dialog Box

Some useful applets include the following:

Table 1.2 Some Useful Applets

DescriptionApplet

Look up a word in an online dictionary.Dictionary Lookup

Terminate an application. This is especially useful if you
want to terminate an application that is no longer respond-
ing.

Force Quit

Find files, folders, and documents on the computer.Search for Files

Create, display, and manage sticky notes on your desk-
top.

Sticky Notes

Access programs from a menu like the one in previous
versions of GNOME. This is especially useful for people
who are used to earlier versions of GNOME.

Traditional Main Menu
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DescriptionApplet

Increase or decrease the sound volume.Volume Control

Display current weather information for a specified city.Weather Report

Access additional work areas, calledworkspaces, through
virtual desktops. For example, you can open applications

Workspace Switcher

in different workspaces and use them on their own
desktops without the clutter from other applications.

1.4 Using the Main Menu
Click Computer on the far left of the bottom panel to open the main menu. Commonly
used applications appear in the main menu, along with recently used applications. You
can also click Documents to display your recent documents, or click Places to display
your favorite places (such as your home directory or the Desktop). ClickMore Applica-
tions to access additional applications, listed in categories. Use the options on the right
to access Help, install additional software, open the GNOMEControl Center, lock your
screen, log out of the desktop, or check the status of your hard drive and network con-
nections.

Figure 1.5 Main Menu
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The main menu contains several elements:

1.4.1 Search Bar
The search bar helps you find applications and files on your system. Enter your search
terms in the Search field, then press Enter. The results are displayed in the Desktop
Search dialog box.

You can use the results list to open a file, forward it via e-mail, or display it in the file
manager. Simply right-click an item in the results list and select the option you want.
The options available for an item depend on the type of file it is. Clicking a file in the
list displays a preview of the file and information such as the title, path, and date the
file was last modified or accessed.

Use the Search menu to limit your search to files in a specific location, such as your
address book or Web pages, or to display only a specific type of file in your results list.
The Viewmenu lets you sort the items in your results list according to name, relevance,
or the date the file was last modified.

For more information about using the GNOME desktop’s search function, see Chapter 4,
Searching with Beagle (page 111).
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1.4.2 Main Menu Tabs
You can determine which icons appear in the main menu by clicking the Applications,
Documents, or Places tabs.

Favorite Applications
By default, Favorite Applications shows icons for several commonly used applications.
Use this view to show the applications you use most often.

To add an item to your Favorite Applications:

1 Click Computer >More Applications.

2 Right-click the application you want to add.

3 Select Add to Favorites.

The selected application is added to your Favorite Applications.

To remove an item from your Favorite Applications:

1 Click Computer.

2 Make sure that your Favorite Applications appear in the main menu.

If Favorite Applications does not appear on the main menu, click Applications.

3 Right-click the item you want to remove.

4 Select Remove from Favorites.

The removed application no longer appears in your Favorite Applications view.

Recent Applications
Recent Applications shows the last two applications you have started. Use this view to
quickly find applications you have used recently.

Getting Started with the GNOME Desktop 15



Recent Documents
Click the Documents tab to display the last several documents you have opened. Use
this view to quickly locate the documents you worked on most recently. ClickMore
Documents to open the File Browser.

Recent Places
Click the Places tab to display the last several places you have opened. Use this view
to quickly locate the places you worked on most recently. ClickMore Places to open
the File Browser.

1.4.3 System
System provides shortcuts to several system applications.

Table 1.3 System Shortcuts

DescriptionApplication

Opens the Help Center, which provides online documentation for
your system.

Help

Allows you to customize and configure your system. For more in-
formation, see Chapter 2, Customizing Your Settings (page 57).

Control Center

Opens the Software Installer, which guides you through the process
of installing new software.

Install Software

Locks your system so that nobody can access it while you are away.
Enter your password to unlock the system.

Lock Screen

Opens the Log Out dialog, where you can log out or switch users.Log Out

Opens the Shutdown dialog, where you can shut down or restart
your system, or suspend the computer.

Shutdown
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1.4.4 Status
Status displays information about your hard drive and network connection, including
the amount of available space on your hard disk and the type of network connection
you are using.

1.5 Managing Folders and Files with
Nautilus

Use the Nautilus File Manager to create and view folders and documents, run scripts,
and create CDs of your data. In addition, the File Manager provides support for Web
and file viewing.

You can open the File Manager in the following ways:

• Click Computer > Nautilus File Browser.

• Double-click your Home directory icon on the desktop.

• Click Computer >More Applications > System > Home Folder or Nautilus File
Browser.

Figure 1.6 File Manager

The elements of the Nautilus window include the following:
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Menu Lets you perform most tasks in the file manager. You can also open a pop-
up menu from file manager windows by right-clicking in a file manager window. The
items in this menu depend on where you right-click. For example, if you right-click a
file or folder, you can select items related to the file or folder. If you right-click the
background of a view pane, you can select items related to the display of items in the
view pane.

Toolbar Lets you quickly navigate among files and folders, and provides access to
files and folders.The toolbar contains Back, Forward, Up, Stop, Reload, Home, Com-
puter, and Search buttons.

Location Bar Lets you locate files, folders, and URI sites.

Side Pane Lets you navigate or display information about the selected file or folder.
Use the drop-down list to customize what is shown in the pane. The list includes ways
to view information about files, perform actions on files, add emblems to files, view a
history of recently visited sites, and display your files in the Tree system. To close the
side pane, click the X at the top right of the side pane. To display the side pane, click
View > Side Pane.

View Pane Displays folders and files. Use the options on the Viewmenu to increase
or decrease the size of content in the view pane, and to display items as a list or as icons.

Status Bar Displays the number of items in a folder and gives the available free
space. When a file is selected, the status bar displays the filename and size.

1.5.1 File Manager Navigation Shortcuts
Some simple shortcuts for navigating in the File Manager include the following:

Table 1.4 File Manager Navigation Shortcuts

DescriptionShortcut

Opens the parent folder.<— or Alt↑

Selects an item.↑ or ↓

Opens an item.Alt + ↓ or Enter
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DescriptionShortcut

Opens an item and closes the current folder.Shift + Alt + ↓

Opens the parent folder and closes the current
folder.

Shift + Alt + ↑

Closes all parent folders.Shift + Ctrl +W

Opens a location by specifying a path or URL.Ctrl + L

Opens your home directory.Alt + Home

For more information, click Help > Contents in the File Manager.

1.5.2 Archiving Folders
If you have files you haven’t recently but want to keep on your computer, you can
compress the files into a tape archive (TAR) format.

1 In the Nautilus view pane, right-click the folder you want to archive, then click
Create Archive.

2 Accept the default archive filename or provide a new name.

3 Select a file extension from the drop-down list (usetar.gz for themost common
archive form).

4 Specify a location for the archive file, then click Create.
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To extract an archived file, right-click the file, then select Extract Here.

1.5.3 Creating a CD/DVD
If your system has a CD or DVD read/write drive, you can use the Nautilus file manager
to burn CDs and DVDs.

1 ClickComputer >More Applications >Multimedia >GNOMECD/DVDCreator,
or insert a blank disc and clickMake Data CD/DVD or Make Audio CD/DVD.

2 Copy the files you want to put on the CD or DVD into the Nautilus CD/DVD
Creator window.

3 ClickWrite to Disc.

4 Modify information in the Write to Disc dialog box or accept the defaults, then
clickWrite.

The files are burned to the disc. This could take a few minutes, depending on the
amount of data being burned and the speed of your burner.

You can also use the Banshee to burn audio and MP3 CDs.

20 GNOME User Guide



1.5.4 Using Bookmarks
Use the Nautilus Bookmarks feature to mark your favorite folders.

1 Select the folder or item you want to create a bookmark for.

2 Click Bookmarks > Add Bookmark. The bookmark is added to the list, with the
folder name as the bookmark name. When you bookmark a file, it is the folder
that is actually bookmarked.

3 To select an item from your Bookmarks list, click Bookmarks, then click the de-
sired bookmark in the list.

You can also organize your Bookmarks list by clicking Bookmarks > Edit Bookmarks
and making your selections in the dialog box.

To change the order of your bookmarks, click a bookmark and drag it to the desired
location.

1.5.5 File Manager Preferences
You can change the File Manager preferences by clicking Edit > Preferences. For more
information, see Section 2.3.7, “File Management Preferences” (page 72).

1.6 Accessing Network Resources
This section describes how to access network resources:
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1.6.1 Connecting to Your Network
You can connect to a network with wired and wireless connections. To view your net-
work connection status, click Computer. In the Status area of the main menu, The Net-
work Connections icon shows your network connection status. For example, in the
following figure, the computer is connected to a wired network using an Ethernet con-
nection.

Figure 1.7 Network Connections Icon in the Main Menu

Click the icon to open the YaST Network Settings module. You an use this module to
configure your network setup method or edit your network card configuration.

1.6.2 Accessing Network Shares
Other network devices, like workstations and servers, can be set up to share some or
all of their resources. Typically, files and folders are marked to let remote users access
them. These are called network shares. If your system is configured to access network
shares, you can use Nautilus File Manager to access them.

To access network shares, double-click your Home directory icon on the desktop, then
click Network in the left pane. The view pane displays the network shares that you can
access. Double-click the network resource that youwant to access. Youmight be required
to authenticate to the resource by providing a username and password.
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Figure 1.8 Network File Browser

To access Windows shares, double-click theWindows Network icon. The Windows
shares available to you are displayed.

Other common network shares are SFTP accessible ressources (SSH File Transfer
Protocol). Double-click the icon of the host you want to a access and provide the required
access data.

For more information, see Chapter 3, Accessing Network Resources (page 105).

Adding a Network Place
1 Click Computer > Nautilus File Browser > File > Connect to Server.

2 Select a service type, then specify the required information for your type of ser-
vice.
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3 Specify the name you want displayed for this connection, then click Connect.

An icon for the network place is added to the desktop.

1.6.3 Sharing Directories From Your
Computer

You can make directories on your computer available to other users on your network.

Enabling Sharing
Use YaST to enable sharing on your computer. In order to enable sharing, you must
have root privileges and be a member of a workgroup or domain.

1 Click Computer >More Applications > System > YaST.

2 In YaST, click Network Services >Windows Domain Membership.

3 In the Windows Domain Membership module, click Allow Users to Share Their
Directories.

4 Click Finish.

Sharing a Directory
If directory sharing is enabled on your computer, use the following steps to configure
a directory to be shared.

1 Open the File Manager and browse to the directory you want to share.

2 Right-click the directory you want to share, then click Sharing Options.
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3 Select the Share this folder check box, then type the name you want to use for
this share.

4 If you want other users to be able to copy files to your shared directory, select
the Allow other people to write in this folder check box.

5 Optionally, type a Comment for the share.

6 Click Create Share.

1.7 Accessing Floppy Disks, CDs, or
DVDs

To access floppy disks, CDs, or DVDs, insert the medium into the appropriate drive.
For many types of removable media, a File Manager window pops up automatically
when the media is inserted or attached to the computer. If File Manager does not open,
double-click the icon for that drive to view the contents.

WARNING

Do not simply remove disks from the drive after using them. Floppy disks, CDs,
and DVDs must always be unmounted from the system first. Close all File
Manager sessions still accessing the medium, then right-click the icon for the
medium and select Eject Volume or Unmount Volume from the menu. Then
safely remove the floppy disk, CD, or DVD when the tray automatically opens.
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Floppy disks can also be formatted by clickingComputer >More Applications > System
> Floppy Formatter. In the Floppy Formatter dialog, select the density of the floppy
disk and the file system settings: Linux native (ext2), the file system for Linux, or DOS
(FAT) to use the floppy with Windows systems.

1.8 Finding Data on Your Computer
or in the File System

GNOME provides several ways to find data on your computer or in the file system.
With Beagle (also called Desktop Search), you can easily search your personal informa-
tion space (usually your home folder) to find documents, e-mails, Web history, IM/ITC
conversations, source code, images, music files, applications, and much more.

To locate files on your computer, clickComputer, enter your search terms in the Search
field, then press Enter. The results are displayed in the Desktop Search dialog box.

You can use the results lists to open a file, forward it via e-mail, or display it in the file
manager. Simply right-click an item in the results list and select the option you want.
The options available for an item depend on the type of file it is. Clicking a file in the
list displays a preview of the file and information such as the title, path, and date the
file was last modified or accessed.

For more information, see Chapter 4, Searching with Beagle (page 111).
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With Search for Files, you can locate files on your computer or in the file system using
a variety of search criteria, such as file content, date, owner, or file size. Start it by
clicking Computer >More Applications > System > Search for Files.

1.8.1 Searching for Files
Using Search for File on the System menu, you can locate files on your computer or
on a network share using any number of search criteria.

Figure 1.9 Search for Files Dialog

Search for Files uses the find, grep, and locate UNIX commands, and all searches are
case insensitive.

You can also open the Search for Files dialog by entering the following command in a
terminal window:

gnome-search-tool

Performing a Basic Search
1 Click Computer >More Applications > System > Search for Files.

2 Type the search text in the Name contains field.
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The search text can be a filename or partial filename, with or without wildcards,
as shown in the following table:

ResultExampleSearch Text

Searches for all files that contain
“myfile.txt” in the filename.

myfile.txtFull or partial filename

Searches for all files that have a .c
or .h extension.

*.[ch]Partial filename combined
with wildcards (* [ ])

3 In the Look in folder field, type the path to the directory where you want Search
for Files to begin the search.

4 Click Find.

Search for Files searches in the directory that you specify (and any subdirectories of
the directory) and displays the results of the search in the Search Results list. If Search
for Files does not find any files that match the search criteria, the application displays
the message No files found in the Search results list.

Adding Search Options
Use Select more options to search by file content, dates, owner, or file size.

1 Click Computer >More Applications > System > Search for Files.

2 Type the search text in the Name contains field.

3 In the Look in folder field, type the path to the directory where you want Search
for Files to begin the search.

4 Click Select more options, then click Available options

5 Select a search option that you want to apply, then click Add.

The following options are available:
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DescriptionOption

Searches for a file by filename. Type a full file-
name or a partial filename with wildcards in the

Contains the text

field provided. Use an asterisk (*) to indicate a
sequence of characters. Use a question mark (?)
to indicate a single character. The search is case
sensitive.

Searches for files that were modified within the
period specified (in days).

Date modified less than

Searches for files that were modified before the
period specified (in days).

Date modified more than

Searches for files that are equal to or larger than
the size specified (in kilobytes).

Size at least

Searches for files that are smaller than or equal
to the size specified (in kilobytes).

Size at most

Searches for empty files.File is empty

Searches for files that are owned by the user
specified. Type the name of the user in the text
box provided.

Owned by user

Searches for files that are owned by the group
specified. Type the name of the group in the text
box provided.

Owned by group

Searches for files that are owned by a user or
group that is unknown to the system.

Owner is unrecognized

Searches for filenames that do not contain the
string that you enter. Enter a full filename or a

Name does not contain

partial filenamewith wildcards in the field provid-
ed. Use an asterisk (*) to indicate a sequence of
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DescriptionOption

characters. Use a question mark (?) to indicate a
single character. The search is case sensitive.

Searches for files that contain the specified regular
expression in their directory path or filename.

Name matches regular ex-
pression

Type the regular expression in the text box provid-
ed.

Regular expressions are special text strings used
to describe a search pattern. For more information,
see Regular-Expressions.info [http://www
.regular-expressions.info].

Includes hidden and backup files in the search.Show hidden and backup
files

Follows symbolic links when searching for files.Follow symbolic links

Searches in directories that are not in the same
file system as the start directory.

Include other filesystems

6 Specify the required search information for the search option.

7 To remove a search option from the current search, click the Remove button next
to the option.

8 Click Find.

Using the Search Results List
You can use the Search Results list to open or delete a file found during a search, or
you can save the search results to a file.
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Figure 1.10 Search Results List

To open a file displayed in the Search Results list, right-click the file, then click Open
or double-click the file. To open the folder that contains a file displayed in the Search
Results list, right-click the file, then click Open Folder.

To delete a file displayed in the Search Results list, right-click the file, then clickMove
to Trash.

To save the results of the last search that Search for Files performed, right-click anywhere
in the Search results list, then click Save Results As. Type a name for the file that the
results are saved to, then click Save.

Disabling Quick Searches
By default, Search for Files tries to speed up some searches by using the locate
command.locate provides a secure way to index and quickly search for files. Because
locate relies on a file index, the Search Results list might not be up to date. To disable
quick searches, run the following command in a terminal window:

# gconftool-2 --type=bool --set
/apps/gnome-search-tool/disable_quick_search 1
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1.9 Moving Text Between Applications
To copy text between applications, select the text, then move the mouse cursor to the
position where you want the text copied. Click the center button on the mouse or the
scroll wheel to copy the text.

When copying information between programs, you must keep the source program open
and paste the text before closing it. When a program closes, any content from that ap-
plication that is on the clipboard is lost.

1.10 Printing
Before you can install a printer, you need to know the root password and have your
printer information ready. Depending on how you connect to the printer, you might also
need the printer URI, TCP/IP address or host, and the driver for the printer. A number
of common printer drivers ship with openSUSE. If you cannot find a driver for the
printer, check the printer manufacturer's Web site.

You can also use YaST to configure your printers, as described in Section “Setting Up
a Printer” (Chapter 2, Setting Up Hardware Components with YaST, ↑Start-Up).

1.10.1 Installing a Local Printer
1 Connect the printer cable to your computer and connect the printer's power supply.

The printer dialog should open. If it doesn’t, click Computer > Control Center
> Add Printer > New Printer to open it.

2 Enter the root password.

3 Click Local Printer.

4 If the printer was autodetected, select the printer from the list. If the printer was
not autodetected, click Use another printer by specifying a port and then select
the correct printer port.

5 Click Forward.
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6 Select the printer driver for this printer, then click Apply.

You can also install a printer driver from a disk, or visit the printer manufacturer's
Web site to download the latest driver.

7 Specify desired options (such as a description or location) for the printer in the
Properties dialog box, then click Close.

The installed printer appears in the Printers dialog box. You can now print to the
printer from any application.

1.10.2 Monitoring Print Jobs in GNOME

Modifying Printer Settings
1 Click Computer > Control Center > Printers.

2 Right-click the printer you want to modify, then click Properties.

3 Modify the properties, then click Close.

Canceling Print Jobs
1 Click Computer > Control Center > Printer.

2 Double-click the printer you sent the job to.

3 Right-click the print job, then click Cancel.

If the print job does not appear in the list, then the print job might have been
printed already.

Deleting a Printer
1 Click Computer > Control Center > Printer.

2 Click Edit > Become Administrator.

Getting Started with the GNOME Desktop 33



3 Type the root password, then click Continue.

4 Right-click the printer you want to delete, then click Remove.

1.11 Managing Internet Connections
To surf the Internet or send and receive e-mail messages, you must have configured an
Internet connection with YaST. Depending on your environment, in YaST select whether
to use NetworkManager. In GNOME, you can then establish Internet connections with
NetworkManager as described in Section “Using GNOME NetworkManager Applet”
(Chapter 10, Using NetworkManager, ↑Start-Up).

For a list of criteria to help you to decide whether to use NetworkManager, refer to
Section “Use Cases for NetworkManager” (Chapter 10,Using NetworkManager, ↑Start-
Up).

1.12 Exploring the Internet
The GNOME desktop includes Firefox, a Mozilla*-based Web browser. You can start
it by clicking Computer > Firefox.

You can type an address into the location bar at the top or click links in a page to move
to different pages, just like in any other Web browser.

For more information, see Chapter 20, Browsing with Firefox (↑Application Guide).

1.13 E-mail and Scheduling
For reading and managing your mail and events, openSUSE offers you Novell® Evo-
lution™, a groupware program that makes it easy to store, organize, and retrieve your
personal information.

Evolution seamlessly combines e-mail, a calendar, an address book, and a task list in
one easy-to-use application. With its extensive support for communications and data
interchange standards, Evolution can work with existing corporate networks and appli-
cations, including Microsoft* Exchange.
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To start Evolution, click Computer >More Applications >Office > Evolution Mail and
Calendar.

The first time you start Evolution, it prompts you with a few questions as it sets up a
mail account and helps you import mail from your old mail client. Then it shows you
how many new messages you have and lists upcoming appointments and tasks, as well
as the current weather and news from news feeds. The calendar, address book, and mail
tools are available in the shortcut bar on the left.

Press Ctrl + N to open a new item for whatever part of Evolution you're working in. In
mail, this creates a new message. If you're in the address book, Ctrl + N creates a new
contact card, and in the calendar, Ctrl + N creates a new appointment.

Formore information, see Chapter 12,Evolution: E-Mail and Calendaring (↑Application
Guide).

1.14 Opening or Creating Documents
with OpenOffice.org

For creating and editing documents, OpenOffice.org is installed with the GNOME
desktop. OpenOffice.org is a complete set of office tools that can both read and save
Microsoft Office file formats. OpenOffice.org has a word processor, a spreadsheet, a
database, a drawing tool, and a presentation program.
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To get started, click Computer > OpenOffice.org Writer or select an OpenOffice.org
module by clicking Computer >More Applications > Office, then select the module
you want to open.

A number of sample documents and templates are included with OpenOffice.org. You
can access the templates by clickingFile >New > Templates andDocuments. In addition,
you can use wizards, which guide you through the creation of letters and other typical
documents.

For more information, see Chapter 1, The OpenOffice.org Office Suite (↑Application
Guide) or view the help in any OpenOffice.org program.

1.15 Controlling Your Desktop’s
Power Management

GNOME Power Manager is a session daemon for the GNOME desktop that manages
the power settings for your laptop or desktop computer.

GNOME Power Manager is usually started automatically when GNOME starts, but
you can manually start GNOME Power Manager by using the following command:

gnome-power-manager --verbose --no-daemon

1.15.1 GNOME Power Manager Notification
Messages

The GNOME Power Manager displays the following notifications under the specified
conditions:
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AC Adapter Unplugged
Figure 1.11 GNOME Power Manager Notification When AC Adapter is Removed

You can disable this notification by changing the GConf key /apps/
gnome-power-manager/notify_ac_adapter.

Fully Charged
Figure 1.12 GNOME Power Manager Notification When Laptop Primary Battery

is Fully Charged

You can disable this notification by changing the GConf key /apps/
gnome-power-manager/notify_fully_charged.

You will receive a repeat notification only if your battery percentage charge drops below
95% and then is again fully charged. This prevents some machines from showing un-
wanted repeat notifications if the battery is incorrectly reporting the charged status.

Power Low
When the battery is low, you will receive the following notification. You should con-
sider switching to AC power as soon as possible.

Figure 1.13 GNOME Power Manager Notification When Battery Power is Low
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Power Critical
When the computer has run out of power, it will show this notification explaining what
action is required. You can change the critical low action using the preferences tool
(see Section 1.15.3, “Modifying Power Management Preferences” (page 40) for more
information).

Figure 1.14 GNOME Power Manager Notification When the System Power is
Critically Low

Suspend Failure
When a suspend failure occurs, you might receive this following warning. The most
common reason for this notification is that the current user does not have permission
to suspend or hibernate the computer.

Figure 1.15 GNOME Power Manager Notification When Suspend Failure Occurs

1.15.2 Viewing Power Statistics
The statistics program lets you view the power consumption of your laptop hardware
in graphic form.
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Figure 1.16 Power History Going From Battery Power to AC

To access the statistics graphs, click Computer >More Applications > System > Power
Statistics.

You might not see some options or graphs if your computer does not have the required
hardware. Youmight also see other hardware not shown here (for example UPS devices),
but these are treated the same way as other devices.

Change History
This graph shows the percentage charge available for the composite primary battery.
If you have a main laptop battery and an auxiliary battery, only the averaged value will
be shown. A legend is not shown with this graph.

Power History
This graph shows the power history charge used by the composite primary battery. The
line represents the amount of power that is either being used to charge the batteries in
the system, or the power being used by the system from the batteries. You should see
the line go up when processor intensive tasks are performed, and go down when the
system is at idle (or when the screen is dimmed). A legend is shown with this graph
when data events have been received.
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You will not receive rate data from your computer if it is not charging or discharging,
or if the computer is suspended. This is due to hardware limitations where the rate is
only sent from the battery management chip, rather than the power management chip
on the motherboard.

Estimated Time History
This graph shows the estimated charge history for the composite primary battery. The
line represents the amount of time required until charged, or the amount of time until
discharge. This line should go proportionally up when the power decreases and down
when the rate increases. A legend is shown with this graph when data events have been
received.

1.15.3 Modifying Power Management
Preferences

The Power Management Preferences dialog box lets you control the LCD brightness
when your system is on AC or battery power, the idle time for the screen power-down
and suspend action, the actions to perform when the laptop lid is closed, and the notifi-
cation area icon policy.

To access Power Management Preferences, click Computer >More Applications >
System > Power Management.

On AC Power Preferences
Use the options on the On AC Power dialog box to automatically put your computer
to sleep when it has been inactive for a specified amount of time.When your computer
is asleep, it is turned on but in a low power mode. It takes less time for a computer to
wake up from sleep than it does for the computer to start up after being turned off.

You can also set only the display to sleep. If your computer is in the middle of a task
(for example, burning a DVD) that you want to finish while you are away, set only the
display to sleep.
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Figure 1.17 GNOME Power Manager On AC Power Preferences

On Battery Power Preferences
Use the options on the On Batter Power dialog box to automatically put your computer
to sleep when it has been inactive for a specified amount of time, to specify what happens
when you laptop lid closed, and what happens when battery power is critically low.

When your computer is asleep, it is turned on but in a low power mode. It takes less
time for a computer to wake up from sleep than it does for the computer to start up after
being turned off.

You can also set only the display to sleep. If your computer is in the middle of a task
(for example, burning a DVD) that you want to finish while you are away, set only the
display to sleep.
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Figure 1.18 GNOME Power Manager On Battery Power Preferences

General Preferences
Use the options on the General Power Management Preference dialog box to configure
miscellaneous options related to GNOMEPowerManager’s behavior, such as the actions
to perform when the power or suspend buttons are pressed, if an icon is displayed in
the Notification area, and if sound is used to notify you in the event on an error.
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Figure 1.19 GNOME Power Manager General Preferences

1.15.4 Session and System Idle Times
gnome-screensaver is a session daemon that monitors user input (if the mouse
has or has not been moved, and if the keyboard has or has not been pressed), then starts
a timeout. When the value of this timeout reaches the value set in Screensaver Prefer-
ences (using the Regard this computer as idle after option), then the login is marked
as “session idle.” At this point, GNOME Power Manager performs the session idle ac-
tions, such as enabling low-power mode, and lowering the laptop panel brightness.
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Figure 1.20 Changing the Session Idle Timeout in Screensaver Preferences

As soon as the session is marked idle, GNOME Power Manager starts it's own system
timer. When the timeout set in GNOME Power Manager Preferences is reached, and
the CPU load is idle, then the idle action is performed (such as turning off the screen,
suspending, or hibernating the computer).

To make this clearer, the sliders in GNOME Power Manager Preferences are set to start
at the value of the session-timeout + 1 minute, as GNOME PowerManager Preferences
cannot logically trigger before the session is marked as idle. If you adjust the value of
the session idle timeout in Screensaver Preferences, the start time of the sliders in
GNOME Power Manager Preferences will change accordingly.

For more information, see Section 2.3.4, “Configuring the Screen Saver” (page 67).

1.16 Creating, Displaying, and
Decompressing Archives

You can use the Archive Manager application (also known as File Roller) to create,
view, modify, or unpack an archive. An archive is a file that acts as a container for
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other files. An archive can contain many files, folders, and subfolders, usually in com-
pressed form. Archive Manager application supports common formats, such as zip,
tar.gz, tar.bz2, lzh, and rar. You can use Archive Manager to create, open,
and extract a compressed non-archive file.

To start ArchiveManager, clickComputer >More Applications >Utilities > File Roller.
If you already have a compressed file, double-click the filename in the Nautilus file
manager to view the contents of the archive in Archive Manager.

Figure 1.21 Archive Manager

1.16.1 Opening an Archive
1 In Archive Manager, click Archive > Open.

2 Select the archive you want to open.

3 Click Open.

Archive Manager automatically determines the archive type, and displays the
following:

• The archive name in the window titlebar.

• The archive contents in the display area.
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• The total number of files in the archive, and the size of the archive when
uncompressed, in the statusbar.

To open another archive, click Archive > Open again. Archive Manager opens
each archive in a new window. To open another archive in the same window,
you must first click Archive > Close to close the current archive, then click
Archive > Open.

If you try to open an archive that was created in a format that Archive Manager
does not recognize, the application displays an error message.

1.16.2 Creating Archives
1 In Archive Manager, click Archive > New.

2 Specify the name and location of the new archive.

3 Select an archive type from the Archive type drop-down list.

4 Click New.

Archive Manager creates an empty archive, but does not yet write the archive to
disk. ArchiveManager writes a new archive to disk only when the archive contains
at least one file. If you create a new archive and quit Archive Manager before
you add any files to the archive, Archive Manager deletes the archive.

5 Add files and folders to the new archive:

5a Click Edit > Add Files or Edit > Add a Folder, then select the files or folders
you want to add.

You cannot add folders to the archive with the Add Files dialog box. Use
the Add a Folder dialog box.

5b Click Add.

Archive Manager adds the files to the current folder in the archive.
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You can also add files to an archive in a file manager window without opening Archive
Manager. See Section 1.5.2, “Archiving Folders” (page 19) for more information.

1.16.3 Extracting Files From an Archive
1 In Archive Manager, select the files that you want to extract.

2 Click Archive > Extract.

3 Specify the folder where Archive Manager will extracts the files.

4 Choose from the following extract options:

DescriptionOption

Extracts all files from the archive.All files

Extracts the selected files from the archive.Selected files

Extracts from the archive all files that match the
specified pattern.

Files

Reconstructs the folder structure when extracting
the specified files.

Re-create folders

For example, you specify /tmp in the Filename
text box and choose to extract all files. The archive
contains a subfolder called doc. If you select the
Re-create folders option, ArchiveManager extracts
the contents of the subfolder to /tmp/doc. If you
do not select the Re-create folders option, Archive
Manager does not create any subfolders. Instead,
Archive Manager extracts all files from the
archive, including files from subfolders, to /tmp.

Overwrites any files in the destination folder that
have the same name as the specified files.

Overwrite existing files
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DescriptionOption

If you do not select this option, Archive Manager
does not extract the specified file if an existing file
with the same name already exists in the destina-
tion folder.

Extracts the specified file only if the destination
folder does not contain the specified file, or if the

Do not extract older files

destination folder contains an older version of the
specified file. ArchiveManager uses the modifica-
tion date to determine which file is the most recent.
If the version of the file in the archive is older,
Archive Manager does not extract the specified
file to the destination folder.

This option is only available if theOverwrite exist-
ing files option is selected.

This option is available only if the archive type
supports encryption. Currently, only .zip and
.arj archives support encryption.

Password

If the archive contains encrypted files, enter the
required password in thePassword field to decrypt
the specified files during the extraction process.
The required password is the encryption password
that was specified when the archive was created.

Displays the contents of the destination folder in
a file manager window after the extraction of the
specified files is completed.

Open destination folder
after extraction

5 Click Extract.

If all of the files in the archive are protected by a password, and you have not
specified the password, Archive Manager displays an error dialog.
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If some but not all of the files in the archive are protected by a password, and
you have not specified the password, Archive Manager does not display an error
dialog. However, ArchiveManager extracts only the unprotected files to the new
archive.

To extract an archived file in a file manager window without opening Archive
Manager, right-click the file, then select Extract Here.

The Extract operation extracts a copy of the specified files from the archive. The
extracted files have the same permissions and modification date as the original
files that were added to the archive.

The Extract operation does not change the contents of the archive.

1.17 Taking Screen Shots
You can take a snapshot of your screen or an individual application window using any
of the following methods:

• From any panel

You can add the Take Screenshot button to any panel. For information on how to
do this, see Section 1.3.4, “Adding Applets and Applications to the Panel” (page 11).
After you have added the button, click the Take Screenshot button to take a snapshot
of the entire desktop.

• Use shortcut keys

Press the Print Screen button to take a screen shot of the entire desktop. Press
Alt+Print Screen to take a screen shot of the currently active window or dialog box.

• From the Application Browser

Click Computer >More Applications > System > Take Screenshot.

• From a terminal

You can use the gnome-panel-screenshot command to take a screen shot.
This command takes a screen shot of the entire screen, then displays the Save
Screenshot dialog box, which you can use to save the screen shot.
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You can use the following options with the gnome-panel-screenshot
command:

--window Takes a screen shot of the currently active window.

--delay=seconds Takes a screen shot after the specified number of seconds,
then displays the Save Screenshot dialog box.

When you take a screen shot, the Save Screenshot dialog box opens. To save the screen
shot as an image file, enter the filename for the screen shot and choose a location from
the drop-down list.

Figure 1.22 Save Screenshot Dialog Box

You can also use The GIMP to take screen shots. In The GIMP, click File > Acquire
> Screen Shot, select a Single Window or the Whole Screen, then click Grab.

1.18 Viewing PDF Files
Documents that need to be shared or printed across platforms can be saved as PDF
(Portable Document Format) files. openSUSE ships with the Evince PDF Viewer.
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Figure 1.23 Evince PDF Viewer

To open Evince, double-click a PDF file in a file manger window (or Web site), or
press Alt + F2, type evince, then press Enter.

To view a PDF file in Evince, click File > Open, locate the desired PDF file, then click
Open.

Use the navigation icons at the top of the window to navigate through the document.
If your PDF document provides bookmarks, you can access them in the left panel of
the viewer.

1.19 Controlling Sound
YaST automatically identifies and configures the sound cards in your computer. You
can also use the YaST Hardware module to configure your sound card manually. When
your sound card has been configured, you can control the volume and balance of the
sound with the GNOME Volume Control mixer.
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If the mixer icon (a loudspeaker symbol) is not visible in the panel on your desktop,
press Alt + F2 and enter gnome-volume-control, or click Computer >More Ap-
plications >Multimedia > Volume Control.

Figure 1.24 GNOME Volume Control Dialog Box

The GNOME Volume Control dialog box contains the following elements:

Menubar The items on the menubar contain all of the commands that you need to
work with the GNOME Volume Control.

Display area The display area contains the channel faders and associated options
for several mixers, which enable you to control the volume on those mixers.

NOTE

GNOME Volume Control populates the display area dynamically, based on the
functionality supported by your sound card. The mixers displayed in your
GNOME Volume Control window might be different to those shown in Fig-
ure 1.24, “GNOME Volume Control Dialog Box” (page 52).

To increase the volume, slide the fader up. To decrease the volume, slide the fader
down. To lock the left and right mixer channels together, select the Lock option for that
mixer.When you lock the mixer channels, GNOMEVolume Control synchronizes both
faders. To silence a mixer, select theMute option for that mixer. When you adjust the
fader of a muted channel, GNOME Volume Control deselects the Mute option for that
mixer.
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Any mixer that has a Rec option can be a recording source. To specify the current
recording source, select the Rec option for that mixer.

1.20 Using the Fingerprint Reader
With the ThinkFinger driver, openSUSE supports the fingerprint reader by UPEK/SGS
ThomsonMicroelectronics included with some IBM and Lenovo ThinkPads. The same
fingerprint reader can also be found in other laptops and either as a stand-alone device
or built into someUSB keyboards. For more details, refer to http://thinkfinger
.svn.sourceforge.net/viewvc/*checkout*/thinkfinger/README
.in. After registering their fingerprint, users can log in to the system either by swiping
a finger on the fingerprint reader or by typing in a password.

If the hardware check detects the fingerprint reader integrated with your laptop (or
connected to your system), the packageslibthinkfinger andpam_thinkfinger
are automatically installed. Use the command line tool tf-tool to register or verify
a fingerprint for various users. root permission is required for this. The PAMmodule
pam_thinkfinger supports user authentication by fingerprint for the following
applications and actions (although you might not be prompted to swipe your finger in
all cases):

• Logging in to GDM or a login shell

• Unlocking your screen on the GNOME desktop

• Starting YaST and the YaST modules in the GNOME control center

• Starting an application with root permission: sudo or gnomesu

• Changing to a different user identity with su or su - username

1.20.1 Registering a Fingerprint
Fingerprints can either be registered with YaST or from the command line. This section
contains instructions on registering fingerprints from the command line. Currently,
only one fingerprint per user can be registered.
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For more detailed information about configuring and using fingerprint authentication,
seehttp://en.opensuse.org/Using_Fingerprint_Authentication.

1 Open a shell and log in as root.

2 Run tf-tool --help to view the available options.

3 To register a fingerprint for a certain user, enter

tf-tool --add-user login

tf-tool prompts the user to swipe a finger until three readable fingerprints
have been gathered. The user's fingerprint data is then stored to /etc/pam
_thinkfinger/login.bir.

4 If you want to use fingerprint authentication for starting YaST or the YaST
modules in the GNOME control center, register a fingerprint for root, too.

5 To verify an existing fingerprint for a certain user, enter

tf-tool --verify-user login

6 Let the user swipe a finger. tf-tool compares the fingerprint to the print stored
for this user and provides a message if the fingerprints match.

As soon as the user's fingerprint has been successfully registered, the user can choose
to authenticate with either fingerprint or password.

To remove a user's fingerprint, delete the appropriate fingerprint file for this user:
/etc/pam_thinkfinger/login.bir.

With tf-tool --acquire you can do a test run with tf-tool. The fingerprint
is stored as /tmp/test.bir and can be verified with tf-tool --verify.

1.20.2 For More Information
• Find the project home page at http://thinkfinger.sourceforge.net/
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• For more technical details, refer to /usr/share/doc/packages/
libthinkfinger/README in your installed system.

• There are also man pages available for pam_thinkfinger and tf-tool.

1.21 Obtaining Software Updates
When you connect to the Internet, the openSUSEUpdater automatically checks whether
software updates for you system are available. An openSUSE Updater applet in the
system tray of you panel informs you about the availability of updates and lets you
easily install them with just a few clicks. The applet icon changes color and appearance
depending on the availability of updates for your system.

For detailed information on how to install software updates with openSUSE Updater
and how to configure openSUSE Updater, refer to the chapter about installing and re-
moving software in Section “Keeping the System Up-to-date” (Chapter 3, Installing,
Removing and Updating Software, ↑Start-Up).

1.22 For More Information
Along with the applications described in this chapter for getting started, GNOME can
run a lot of other applications. Find detailed information about many important applica-
tions in the other parts of this manual.

To learn more about GNOME and GNOME applications, see http://www.gnome
.org and http://gnomefiles.org.

To report bugs or add feature requests, go to http://bugzilla.gnome.org.
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2Customizing Your Settings
You can change the way the GNOME desktop looks and behaves to suit your own
personal tastes and needs. Some of the settings you might want to change include:

• Keyboard and mouse configuration, as described in Section 2.2.1, “Modifying
Keyboard Preferences” (page 60) and Section 2.2.2, “Configuring the Mouse”
(page 61)

• Desktop background, as described in Section 2.3.1, “Changing the Desktop Back-
ground” (page 64)

• Screen saver, as described in Section 2.3.4, “Configuring the Screen Saver”
(page 67)

• Password, as described in Section 2.4.2, “Changing Your Password” (page 89)

• Sounds, as described in Section 2.5.9, “Setting Sound Preferences” (page 100)

These settings and others can be changed in the Control Center.
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2.1 The Control Center
To access the Control Center, click Computer > Control Center. The Control Center is
divided into the following four categories:

Hardware
Allows you to configure hardware components such as graphics cards, monitors,
printers, or keyboard layout, and to set up your network devices and configure your
network connection. For more information, see Section 2.2, “Hardware” (page 60).

Look and Feel
Holds settings for the desktop background, the screen saver, and the fonts appearing
on the desktop. You can modify themes, window behavior, and styles of desktop
elements, such as menus, and scroll bars. Here, you can also configure 3D desktop
effects (Xgl). For more information, see Section 2.3, “Look and Feel” (page 64).

Personal
Go here to change your login password, or to configure keyboard shortcuts or
keyboard accessibility settings. For more information, see Section 2.4, “Personal”
(page 87).

System
Lets you configure system settings such as date and time, language, sound, or
power management,. Define how GNOME handles sessions on login or shutdown,
and modify the Beagle search settings. For more information, see Section 2.5,
“System” (page 91).
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Figure 2.1 GNOME Control Center

In order to change some systemwide settings, Control Center will prompt you for the
root password and start YaST. This is mostly the case for administrator settings (in-
cluding most of the hardware, the graphical user interface, Internet access, security
settings, user administration, software installation, and system updates and information).
Follow the instructions in YaST to configure these settings. Refer to the integrated
YaST help texts or refer to the Part “Installation and Setup” (↑Start-Up).

NOTE: YaST Gtk and Qt Front-Ends

YaST comes with two front-ends depending on the desktop installed on your
system. By default, the YaST gtk front-end runs on the GNOME desktop, and
the YaST qt front-end on the other desktops. This is defined with the WANT_UI
parameter in /sbin/yast2.
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Feature-wise, the gtk front-end is very similar to the qt front-end described in
the manuals. One exception is the gtk software management module, which
differs considerably from the qt port.

This chapter focuses on individual settings you can change directly in the GNOME
Control Center (without YaST interaction).

2.2 Hardware
In the following sections, find examples of how to configure some hardware aspects
of your GNOME desktop like keyboard or mouse preferences, handling of removable
drives and media, or the screen resolution.

2.2.1 Modifying Keyboard Preferences
To modify some keyboard settings such as autorepeat preferences or typing break ses-
sions, click Computer > Control Center > Hardware > Keyboard.

Figure 2.2 Keyboard Preferences Dialog

1 On the Keyboard tab, you can set some general keyboard preferences, such as
enabling keyboard repeat with individual delay and speed options, or enabling
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or disabling the blinking of the cursor and defining the speed. For more informa-
tion about the individual options, click Help.

2 To select your keyboard model, click the Layouts tab, click the Browse button
and select your model from the list.

3 To add a new language layout, click Add and choose a language layout to add to
the list. You can select different layouts to suit different locales. Select one layout
as Default.

4 On the Typing Break tab, you can set typing break preferences. For more infor-
mation about the individual options, click Help.

5 If all options are set according to your wishes, click Close.

2.2.2 Configuring the Mouse
To modify some mouse options, click Computer > Control Panel >Hardware >Mouse
to open theMouse Preferences.

Figure 2.3 Mouse Preferences Dialog

1 Use the Buttons tab to specify whether the mouse buttons are configured for left-
hand use. You can also specify the delay between clicks for a double-click.
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2 To select a different cursor theme, switch to the Cursors tab. There, you can also
enable a mouse pointer animation when you press and release Ctrl. This feature
can help you locate the mouse pointer.

3 On theMotion tab, define the Acceleration and Sensitivity of your mouse pointer.
You can also modify the distance that you must move an item with the pointer
before the action is interpreted as a drag and drop action.

4 If all options are set according to your wishes, click Close.

2.2.3 Installing and Configuring Printers
Use the Printers module to install and configure printers.

To start the Printers module, click Computer > Control Center > Hardware > Printers.

Figure 2.4 Printers Dialog

2.2.4 Configuring Removable Drives and
Media

You can use a wide variety of removable drives and media, including storage devices,
cameras, scanners, and more. The configurations for many of these devices are set up
automatically during installation. To change the configuration for a drive or other re-
movable device, click Computer > Control Center > Hardware > Removable Drives
and Media.

Some of the possible configuration settings include:
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• What happens when a blank CD is inserted in the CD drive

• What happens when an audio CD is inserted in the drive

• Whether images are automatically imported from a digital camera when it is attached
to the computer

• Whether removable storage devices are mounted when they are plugged in to the
computer

• Whether PDAs are automatically synced when attached to the computer

In general, you do not need to change the settings that are already configured unless
you want to change the behavior when a device is connected or if you want to connect
a new device that is not yet configured. If you attach a device for the first time and it
behaves in an unexpected or undesired way, check the Removable Drives and Media
settings.

2.2.5 Specifying Screen Resolution Settings
To specify the resolution and refresh rate for your screen, click Computer > Control
Center > Hardware > Screen Resolution and modify the options.

Figure 2.5 Screen Resolution Preferences Dialog
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2.2.6 Configuring a Touchpad
Use this module to configure the behavior of a touchpad. This module is only available
on computers containing touchpads, such as laptops. In most cases, the default behavior
should remain unchanged. Click Computer > Control Center > Hardware > Touchpad
to start the Touchpad module.

2.3 Look and Feel
In the following sections, find examples of how to configure some look and feel aspects
of your GNOMEdesktop, like desktop background and screens saver, 3D desktop effects,
themes, window behavior, or menus.

2.3.1 Changing the Desktop Background
The desktop background is the image or color that is applied to your desktop. You can
customize the desktop background in the following ways:

• Select an image for the desktop background. The image is superimposed on the
desktop background color. The desktop background color is visible if you select a
transparent image or if the image does not cover the entire desktop.

• Select a color for the desktop background. You can select a solid color or create a
gradient effect with two colors. A gradient effect is a visual effect where one color
blends gradually into another color.

To change the desktop preferences:

1 Click Computer > Control Center > Look and Feel > Desktop Background.

64 GNOME User Guide



2 To change the picture on the background, select one of the Desktop Wallpapers
from the list and select the style in which to arrange the image on the desktop.

3 To use a custom picture, click Add Wallpaper and select an image file from the
file system.

4 If you do not want a picture on the background, specify a color scheme using the
options in the Desktop Color drop-down list and the color selector buttons.

5 When you are satisfied with your choices, click Close.

Your desktop immediately changes to show the new settings.

2.3.2 Configuring Fonts
To select the fonts to use in your applications, windows, terminals, and desktop, click
Computer > Control Center > Look and Feel > Fonts.
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Figure 2.6 Font Preferences Dialog

The upper part of the dialog shows the fonts selected for applications, documents, the
desktop, window titles, and a fixed-width font for terminals. Click one of the buttons
to open a selection dialog where you can set the font family, style, and size. For more
information on the individual options, click Help.

2.3.3 Configuring Menus and Toolbars
You can configure the appearance and behavior of menus and toolbars. ClickComputer
> Control Center > Look and Feel >Menus & Toolbars.

If you want icons to appear in menus, select Show icons in menus. Not all menu items
have icons.

If you want to be able to define new keyboard shortcuts for menu items, select Enable
menu accelerators. When this option is enabled, you can change an application shortcut
key by placing the mouse pointer over the menu item you want to change, then pressing
the new key combination. To remove a shortcut key combination, place the mouse
pointer over the menu item, then press <— or Del.

IMPORTANT: New Keyboard Combinations Can Change Defaults

If you assign a new keyboard combination, you are not warned if you select a
combination that was previously assigned to something else. The previous as-
signment is removed and replaced by the new one. There is no automatic way
to restore the original, default keyboard shortcut for a command. You must
manually reassign the keyboard shortcut.
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This feature does not maintain shortcuts that are normally assigned to all ap-
plications, such as Ctrl + C for copy. This might lead to inconsistencies in your
GNOME applications.

If you want to be able to move toolbars to other locations on the screen, clickDetachable
toolbars. When this option is enabled, a handle displays on the left side of the toolbars
in your applications. To move a toolbar, click and hold on the handle, then drag the
toolbar to the new location.

Select one of the following options to specify how toolbar button labels display in your
GNOME-compliant applications:

Text below icons
Displays icon labels below the icons for each button.

Text beside icons
Displays icons on the toolbar, with text beside the most important icons.

Icons only
Displays icons only, without any text labels.

Text only
Displays text labels on each button, without icons.

A preview of the selected option appears in theMenu and Toolbar Preferences dialog.

2.3.4 Configuring the Screen Saver
A screen saver is a program that blanks the screen or displays graphics when the com-
puter is not used for a specified amount of time. Originally, screen savers protected
monitors from having images burned into them. Now they are used primarily for enter-
tainment or security.

To configure a screen saver, click Computer > Control Center > Look and Feel >
Screensaver.
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Figure 2.7 Screensaver Preferences Dialog

You can select from Random (random selection of screen savers from a custom-defined
list), Blank Screen, or a selection of installed screen savers.

Select a screen saver from the list to choose it. The currently selected screen saver is
displayed in the small preview window. Specify the amount of time that the screen is
to be idle before the screen saver is activated, and whether the screen is locked when
the screen saver is activated.

2.3.5 Choosing a Theme
A theme is a group of coordinated settings that specifies the visual appearance of a part
of the desktop. You can choose themes to change the appearance of the desktop. Use
the Theme Preferences tool to select from a list of preinstalled themes. The list of
available themes includes several themes for users with accessibility requirements.

To choose a theme, click Computer > Control Center > Look and Feel > Theme.

A theme contains settings that affect different parts of the desktop, as follows:
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Controls
The controls setting for a theme determines the visual appearance of windows,
panels, and applets. It also determines the visual appearance of the GNOME-com-
pliant interface items that appear on windows, panels, and applets, such as menus,
icons, and buttons. Some of the controls setting options that are available are de-
signed for special accessibility needs. You can select an option for the controls
setting in the Controls tabbed page of the Theme Details tool.

Window frame
The window frame setting for a theme determines the appearance of the frames
around windows only. You can select an option for the window frame setting in
theWindow Border tabbed page of the Theme Details tool.

Icon
The icon setting for a theme determines the appearance of the icons on panels and
the desktop background. You can select an option for the icon setting in the Icons
tabbed page of the Theme Details tool.

The color settings for the desktop and applications are controlled using themes. You
can choose from a variety of preinstalled themes. Selecting a style from the list overview
applies it automatically. Details opens another dialog where you can customize the
style of single desktop elements, like window content, window borders, and icons.
Making changes and leaving the dialog by clickingClose switches the theme toCustom
Theme. Click Save Theme to save your modified theme under a custom name. The In-
ternet and other sources provide many additional themes for GNOME as .tar.gz
files. Install these with Install Theme.

Procedure 2.1 Creating a Custom Theme

The themes that are listed in the Theme Preferences tool are different combinations
of controls options, window frame options, and icon options. You can create a custom
theme that uses different combinations of options.

1 Click Computer > Control Center > Look and Feel > Theme.

2 Select a theme from the list of themes, then click Theme Details.

3 Select the controls option that you want to use in the custom theme from the list
in the Controls tabbed page.
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4 Click theWindow Border tab, then select the window frame option that you want
to use in the custom theme.

5 Click the Icons tab, then select the icons option that you want to use in the custom
theme.

6 Click Close > Save Theme.

A Save Theme to Disk dialog is displayed.

7 Type a name and a short description for the custom theme in the dialog, then
click Save.

The custom theme now appears in your list of available themes.

Procedure 2.2 Installing a New Theme

You can add a theme to the list of available themes. The new thememust be an archive
file that is tarred and zipped (a .tar.gz file).

1 Click Computer > Control Center > Look and Feel > Theme.

2 Click Install Theme.

3 Specify the location of the theme archive file in the Location field, then click
OK.

You can also click Browse to browse for the file.

4 Click Install to install the new theme.

Procedure 2.3 Installing a New Theme Option

You can install new controls options, window frame options, or icons options. You
can find many controls options on the Internet.

1 Click Computer > Control Center > Look and Feel > Theme.

2 Click Theme Details, then click the tab for the type of theme you want to install.

For example, to install an icons option, click the Icons tab.
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3 Click Install Theme.

4 Specify the location of the theme archive file in the Location field, then click
OK.

5 Click Install to install the new theme option.

Procedure 2.4 Deleting a Theme Option

You can delete controls options, window frame options, or icons options.

1 Click Computer > Control Center > Look and Feel > Theme.

2 Click Theme Details, then click the tab for the type of option you want to delete.

3 Click Go To Theme Folder.

A file manager window opens on the default option folder.

4 Use the file manager window to delete the option.

2.3.6 Customizing Window Behavior
Use theWindow Preferences tool to customize window behavior for the desktop. You
can determine how a window reacts to contact with the mouse pointer or to double-
clicks on its title bar, and you can define which key to hold for moving an application
window.

To customize window behavior, click Computer > Control Center > Look and Feel >
Windows.
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Figure 2.8 Window Preferences Dialog

When several application windows populate the desktop, the active one by default is
the one last clicked. Change this behavior by activating Select WindowsWhen theMouse
Moves over Them. If desired, activateRaise SelectedWindow after an Interval and adjust
the latency time with the slider. This raises a windows a short time after the window
receives focus.

Application windows can be shaded (rolled up) by double-clicking the title bar, leaving
only the title bar visible. This saves space on the desktop and is the default behavior.
It is also possible to set windows to maximize when the title bar is double-clicked.

Using the radio buttons, select a modifier key to press for moving a window (Ctrl, Alt,
Hyper, or theWindows key).

2.3.7 File Management Preferences
You can change the preferences for Nautilus file manager in the Control Center by
clicking Computer > Control Center > Look and Feel > File Management, or from
Nautilus by clicking Edit > Preferences.
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Figure 2.9 File Manager Preferences

1 On the Views tab, define options for various Nautilus views, for example, select
if Nautilus should also show hidden files and backup files.

2 On the Behavior tab,you can define several options such as to open files or
folders in Nautilus upon single or double mouse-click, or to include a Delete
menu item in Nautilus which deletes files or folders directly from your file system
instead of moving them to the trash.

3 On the Display tab, configure the date format and the way icon captions appear
in Nautilus.

4 Switch to the List Columns tab to configure the columns that appear in Nautilus,
as well as the order in which they appear.

5 Click the Preview tab to specify for which files to show previews in Nautilus
and if folders should the number of items they contain.

6 For more information on the available options click Help.
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7 If all options are set according to your wishes, click Close to apply the changes.

2.3.8 Locking Desktop Functions
openSUSE ships with a graphical lockdown editor (pessulus package) that lets you
disable (lockdown) certain desktop functions. This is useful if you want to restrict the
actions that users can perform on a computer. For example, you might want to prevent
command line operations on a computer that is for public use at a trade show.

If the pessulus package is already installed, start the Lockdown Editor from the
main menu with Computer > Control Center > Look and Feel > Lockdown Editor or
press Alt + F2 and enter pessulus.

Figure 2.10 General Lockdown Editor Settings

When the Lockdown Editor starts, it tries to connect to the GConf mandatory configu-
ration source (xml:merged:$prefix/etc/gconf/gconf.xml.mandatory).
If you run pessulus as root, you have access to this configuration source and a
lock icon is displayed next to the checkbox for each setting. Click the lock to specify
if the setting is mandatory. If the setting is mandatory, regular users will not be able to
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change or override the setting. If you do not have access to the mandatory configuration
source, the lock icon does not appear. In this case, all disabled settings are stored in the
user's default configuration source and can be modified later using other tools such as
gconf-editor or gconftool-2. For more information about GConf and mandatory confi-
guration sources, see “Using GConf” [http://library.gnome.org/admin/
system-admin-guide/stable/] in theGNOMEDesktop SystemAdministration
Guide .

Click a category on the left to view the settings for this category that can be disabled.

1 To disable printing (or prevent the user from modifying print settings), access
to the command line, and saving to disk, set the according options in theGeneral
category.

2 To lock down the panel, disable the panel applets you specify, and disable the
force quit, lock screen, and log out options, use the options in the Panel category.

3 To control access to features in Epiphany, use the options in the Epiphany Web
Browser category.

4 Use the options in the GNOME Screensaver category to lock the screen when
the screen saver goes active, enable or disable the log out after a delay option in
the unlock dialog box, and to enable or disable the switch user option in the unlock
dialog box.

5 For more information on the available options of each category, click Help.

6 If all options are set according to your wishes, click Close to apply the changes.

2.3.9 Customizing the Main Menu
Use theMain Menu application to customize the GNOME Main menu. To start the
application in system view, root privileges are needed. . To start the application in
user view , click Computer > Control Center > Look and Feel >Main Menu - User
View.
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Figure 2.11 Main Menu Editor

TheMain Menu window shows the selected Editing Mode at the top. The current main
menu submenus are displayed on the left of the main window, the items belonging to
the selected submenu are shown on the right. Groups in a submenu are nested below
that submenu. To find an item, click the arrow next to a submenu in theMenus list,
select the group containing that item, then locate the item in the Items list.

NOTE: Implications of Main Menu Changes

Changes you make to the main menu are not overwritten during a subsequent
system update. Changes are applied after the latest menu view is generated.

Procedure 2.5 Editing the Main Menu

You can change the order in which items appear in the main menu, rename menu
items, show or hide menu items, or delete items from the menu altogether, and add
newmenu items. For example, you might want to place your frequently used applica-
tions at the top of the menu or at the top of their groups to make them easier to find.
Adding new items to the main menu is helpful when you install an application, but
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it is also useful if you have other applications that do not currently appear on the
menu. You can also add a directory, a link, or another type of item to the menu.

1 To move a menu item, click the menu item in the Items list on the right and drag
it to a new location in the menu. You can move the item to a new location in the
same menu, or drop it on an item in theMenus list to move it to a new menu or
group. Use theMove Up andMove Down buttons to change an item’s location
in the menu.

2 To rename an existing menu item, right-click the item in the Items list, select
Properties, and enter a new name.

3 To hide an item so it does not appear in the menu, deactivate the checkbox next
to the item in the Items list. An activated checkbox indicates that the item is
currently shown in the menu.When an item is hidden, it still remains in the Items
list and can be shown at any other time if you decide you want it to (re)appear
in the menu.

4 To delete an item from the Items list altogether, right-click the item and click
Delete. If you want to show a deleted item in the menu again, you must add it
like you would a new application.

5 To add a new item, proceed as follows:

5a In theMenus list, click the arrow next to the menu containing the group
where you want to add the application, then select the group. The contents
of that group appear in the Items list.

5b Click New Item and select the Type of menu item to add. For example, to
add a directory, select Directory.

5c Click Browse and select the item to add.

5d Enter a Name for the new menu item.

5e If you want a short description to appear in the main menu if a user hovers
the mouse pointer over the menu item, enter the description in the Comment
field.
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5f If you want to assign an icon to the new item, click the image frame on the
left, then select an icon for the item. If you do not select an icon, the item
appears in the menu without an icon.

6 If you want to restore the default menu layout, click Revert.

7 If all options are set according to your wishes, clickClose to apply your changes.

NOTE

The first time you use the Main Menu application to edit the menu,
changes do not take effect until you log out and log back in. After the
first time, changes appear immediately when you make them.

2.3.10 Improving Access for the Visually
Impaired

The Orca screen reader assists visually impaired users so they can read the information
on the screen, either bymagnifying the screen, reading screen output aloud, or outputting
information from the screen in Braille to a screen reader. To configure Orca, click
Computer > Control Center > Look and Feel > Orca Screen Reader.

The first time you run this module, a terminal opens so you can set up the Orca screen
reader. This setup consists of a series of yes/no questions. Answer the questions as ap-
propriate for your setup. After the setup is complete, you must log out and log back in
for your setup to take effect.

After the initial setup, to change the preferences you set during setup or to set additional
options, click Computer > Control Center > Look and Feel > Orca Screen Reader.

2.3.11 Configuring Desktop Effects
Xgl is an X server architecture that lets you turn your desktop into a rotating 3D cube,
tile windows so they do not overlap, and switch tasks while viewing live thumbnails.
You can enable translucent or transparent windows, zoom in and out of the desktop
screen, and use other window effects such as shadows, fading, and transformations.
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You can also configure windows to snap to other windows and screen edges when they
are moved.

Figure 2.12 3D Desktop

Enabling Desktop Effects
To enable Xgl, you need a graphics adapter capable of providing 3D support, and you
also need the graphics driver that Linux uses to operate the graphics adapter. This
driver must be able to handle OpenGL (or 3D) requests from the Linux kernel. For a
list of supported adapters, see the /etc/X11/xgl-hardware-list file that is
included with the openSUSE installation. This file tells you which graphics cards are
known to work with Xgl, which cards do not work with Xgl, and which cards might
work with Xgl but are not supported because they are either too slow or contain too
many known defects.

Your screen resolution must be within the 1024x768 to 1920x2000 range, and your
color depth must be set at 24-bit. 3D acceleration must also be enabled. Use SaX2 to
change your graphics card and monitor properties if necessary.

Customizing Your Settings 79



To enable desktop effects:

1 Click Computer > Control Center.

2 Click Desktop Effects in the Look and Feel group.

The Desktop Effects tool analyzes your system and tries to determine whether
or not you can run Xgl. If it finds anything wrong, it advises you on what actions
you can take. For example, youmight be advised to change your screen resolution
or color depth, or to activate 3D acceleration. Follow the on-screen prompts to
configure your system for Xgl.

3 After your system is configured for Xgl, click Enable Desktop Effects.

4 Type the root password, then click Continue.

5 Click Log Out to log out of your session, then type your username and password
to log back in.

The default desktop effects are now enabled. For example, windows “wobble”
when they first appear and when you move them, they fade away when you close
them, and dragging a window to the far right of the screen rotates the desktop
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cube. To change any of these effects, see Section “Modifying Desktop Effects”
(page 81).

You can also enable Xgl by running the following command as root:
gnome-xgl-switch --enable-xgl

To disable Xgl, click Disable Desktop Effects in the Desktop Effects Settings dialog
box, or run the following command as root:
gnome-xgl-switch --disable-xgl

Modifying Desktop Effects
Use the Desktop Effects Settings tool to enable or disable specific desktop effects, or
to change the keystrokes or mouse actions used to control those effects.

Open Desktop Effects Settings from the main menu by clicking Computer > Control
Center > Look and Feel > Desktop Effects.

Figure 2.13 Window Effects Tabbed Page

1 Use the options on theWindow Effects tab to specify what happens when you
move windows, how window transitions appear, and to change window opacity.

Customizing Your Settings 81



2 Switch to the Desktop Cube tab to specify how many sides your desktop cube
has, which keystroke and mouse button combination you can use to drag the
cube, and to configure edge flipping.

3 To configure window tiling, zooming, and water effects, click theOther Features
tab.

4 For more information on the individual options, click Help.

5 If all options are set according to your wishes, click Close to apply the changes.

You can also use gconf-editor to change Xgl settings.

1 Click Computer >More Applications > System >GNOME Configuration Editor
or press Alt + F2 and enter gconf-editor.

2 Navigate to the apps/compiz/general and apps/compiz/plugins
registry folders and make the changes you want.

3 Click File > Quit to close the Configuration Editor.

Xgl Shortcuts
The following table contains a list of the default keystrokes and mouse movements you
can use to perform desktop effects. To change any of these shortcuts, see Section
“Modifying Desktop Effects” (page 81).

Table 2.1 Desktop Effects Shortcuts

ShortcutEffect

Shift + F9Activate or deactivate rain effect

Ctrl + Alt + Super (Windows key) and move
the mouse pointer

Create ripples with themouse pointer

Ctrl + Alt + ↓ (use the Left and Right arrows
to scroll)

Panoramic view of all desktop cubes

82 GNOME User Guide



ShortcutEffect

Ctrl + Alt +← or→ or drag a window to the
edge of the screen

Rotate desktop cube

Ctrl + Alt + left-click the desktop and drag the
mouse pointer

Rotate desktop cube manually

Ctrl + Alt + Shift +← or→Rotate desktop cube while keeping
the current active window with you

Alt +→|Switch windows (thumbnail view)

Ctrl + Alt + ↑ or move the mouse pointer to
the top left corner of the screen

Tile windows

Left-click the window and dragWobbly window

Super key (Windows key) and Button 3Zoom once

Super key (Windows key) and scroll wheel
up

Zoom in manually

Super key (Windows key) and scroll wheel
down

Zoom out manually

More Desktop Effects
Here are some other things you can do with Xgl.

Switching Tasks

Press Alt +→| to display a thumbnail view of all windows open on your desktop.While
holding the Alt key down, press→| to cycle through the list of windows. The currently
highlighted window will appear in focus. Release the keys to access that window.
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Figure 2.14 Thumbnail View

Unfolding the Cube

Press Ctrl + Alt + ↓ to unfold the desktop cube, opening a panoramic view of all your
desktops. Your desktop cube is laid out like a film strip on your screen, and you can
use← and→ to select a different screen. This is similar to the switcher feature (Alt +
→|), but lets you view a thumbnail of your entire desktop instead of only your active
windows.
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Figure 2.15 Panoramic View of All Desktop Cubes

Displaying a Skydome Image Behind the Cube

You can add background wallpaper (also known as a skydome image) that is visible
when you rotate or unfold the desktop cube.

1 Click Computer >More Applications > System >GNOME Configuration Editor
or press Alt + F2 and enter gconf-editor.

2 Navigate to the apps/compiz/plugins/cube/screen0/options
registry folder.

3 Scroll down the list on the right side of the Configuration Editor and select sky-
dome.

4 Double-click skydome_image and specify the path to the skydome image you
want to display behind the cube.
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Skydome imagesmust be in.png format. The suggested image sizes for skydome
images are 1024 x 1024, 1024 x 2048, 1024 x 4096, 2048 x 1024, 2048 x 2048,
2048 x 4096, 4096 x 1024, 4096 x 2048, and 4096 x 4096.

5 (Optional) Select skydome_animated to make it look like you are moving around
the cube when you use your mouse to rotate the cube.

6 Click OK.

7 Click File > Quit to close the Configuration Editor.

Figure 2.16 Skydome Image
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2.4 Personal
In the following sections, find examples of how to configure some personal aspects of
your GNOME desktop, like keyboard accessibility, keyboard shortcuts, assistive tech-
nology support, and learn how to change your password or manage virtual keyrings.

2.4.1 Configuring Assistive Technology
Support

Several assistive technologies are included for users with special needs:

• Screen reader

• Screen magnifier

• On-screen keyboard

To configure assistive technology options, clickComputer >Control Center > Personal
> Assistive Technology Preferences.

Figure 2.17 Assistive Technology Preferences Dialog

To activate the technologies, first select Enable Assistive Technologies. Choose the
technologies you want to enable every time you log in.

Click Keyboard Accessibility to get to the Keyboard Preferences designed to help users
with motion impairments using the GNOME desktop. Some of the available settings
on the Accessibility include:
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• How long a key is pressed and held before being recognized as valid input

• Whether the keyboard can be used as a mouse

• Whether key combinations that use Alt, Ctrl, and Shift can be duplicated with “sticky
keys”

You can then define various settings for keys:

Sticky Keys
Some keyboard shortcuts require that one key (a modifier key) is kept pressed
constantly (this applies to Alt, Ctrl, and Shift) while the rest of the shortcut is typed.
When sticky keys are used, the system regards those keys as staying pressed after
being pressed once. To enable sticky keys, activate Simulate simultaneous keypress-
es. If Disable if two keys pressed together is selected, the keys do not “stick” any-
more when two keys are pressed simultaneously. The system then assumes that the
keyboard shortcut has been completely entered.

Slow Keys
To prevent accidental typing, activateOnly Accept long keypresses. Set a minimum
time limit that a key must be pressed and held before it is recognized as valid input
by the system.

Bounce Keys
To prevent double typing, activate Ignore fast duplicate keypresses and set a mini-
mum time limit for accepting two subsequent keypress events of the same key as
the input of two individual characters.

Mouse Keys
To use the keyboard as mouse, switch to theMouse Keys tab and activate Allow to
control the pointer using the keyboard. The mouse pointer is controlled with the
arrow keys of the number pad. Use the sliders to set the maximum speed of the
mouse pointer, the acceleration time until the maximum speed is reached, and the
latency between the pressing of a key and the cursor movement.

In order to set acoustic notifications for some key or accessibility events, click Notifi-
cations and set the options according to your wishes.

The gok package must be installed in order to get on-screen keyboard support, and the
gnopernicus and gnome-mag packages must be installed in order to get screen-
reading and magnifying capabilities.
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If these packages are not installed on your system (they are installed by default during
installation), install them with the following procedure:

1 Start the YaST packagemanager from the command line or openYaST and select
Software > Software Management.

2 For Filter, select Search.

3 In the Search field, enter the name of the package you want to install and press
Enter. The package is listed in the right frame.

4 Select it for installation. Once done, you can search for more packages and select
them for installation in one go.

5 Click Accept to start the installation of the packages.

For more information about the GNOME accessibility features, refer to the GNOME
Desktop Accessibility Guide available from Yelp.

2.4.2 Changing Your Password
For security reasons, it is a good idea to change your login password from time to time.
To change your password:

1 Click Computer > Control Center > Personal > Change Password.

2 Type your old (current) password.

3 Type your new password.

4 Confirm your new password by typing it again, then click OK.

2.4.3 Managing Keyrings
GNOMEKeyringManager provides an interface for viewing secrets stored in keyrings
on your computer. Secrets include such items as:

• Passwords
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• Wireless credentials

• Certificates

• Credentials for logging in to another computer

Most users will not need to use GNOMEKeyringManager because secrets are automat-
ically managed by the applications that create them.Whenever any GNOME application
that uses GNOME Keyring needs to access passwords or credentials stored there, a
check is made if the keyring is locked or not. If it is locked, you will be prompted for
the master password to unlock the keyring.

To open Keyring Manager (independent of any application interaction) press Alt + F2
and enter gnome-keyring-manager.

To delete a secret:

1 In the list of keyrings on the left side of Keyring Manager, click Default.

2 Click the secret you want to delete in the list in the top right area of Keyring
Manager.

3 Click Keyring Delete Keyring.

The secret is removed from the list.

2.4.4 Customizing Keyboard Shortcuts
A keyboard shortcut is a key or combination of keys that provides an alternative to
standard ways of performing an action. You can customize the keyboard shortcuts for
a number of actions.

To open the Keyboard Shortcuts tool, click Computer > Control Center > Personal >
Shortcuts.
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Figure 2.18 Keyboard Shortcuts Dialog

To change the shortcut keys for an action, select the action and then press the keys you
want to associate with the action. To disable the shortcut keys for an action, click the
shortcut for the action, then press <—.

2.5 System
In the following sections, find examples of how to configure some system aspects of
your GNOME desktop, like language settings, power management, preferred applica-
tions, session and session sharing preferences, Beagle search options, and audio prefer-
ences.

2.5.1 Configuring Streaming Audio and
Video

With GNOME Control Center, you can configure which audio and video plug-ins you
want to use for streaming multimedia. To open this application, click Computer >
Control Center > System > GStreamer Properties.
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In most cases, you should use the default selections. However, if you want to select
other plug-ins, select the plug-in you want from the menus. The Audio tab lists the plug-
ins for audio input and output. The Video tab lists the video plug-ins.

Click Close when you are finished. The system is immediately configured to use the
selected plug-ins.

2.5.2 Configuring Language Settings
SUSE Linux Enterprise Desktop can be configured to use any of many languages. The
language setting determines the language of dialogs and menus, and can also determine
the keyboard and clock layout.

You can set the following language settings:

• Primary language

• Whether the keyboard language setting should depend on the primary language

• Whether the time zone should depend on the primary language

• Secondary languages

To configure your language settings:

1 Click Computer > Control Center > System > Language.

2 Enter the root password.

If you do not know the root password, contact your system administrator. You
cannot continue without the root password.

3 Specify the primary language, whether you want to adapt the keyboard layout
or time zone to the primary language, and any secondary languages you need to
support on the computer.

4 Click Accept.
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The language configuration settings are written to several configuration files.
This process can take a few minutes. The new settings take effect immediately
after they are written to the configuration files.

2.5.3 Configuring Network Proxies
The Network Proxy Configuration tool lets you configure how your system connects
to the Internet. You can configure the desktop to connect to a proxy server and specify
the details of the server. A proxy server is a server that intercepts requests to another
server and fulfills the request itself, if it can. You can specify the Domain Name Service
(DNS) name or the Internet Protocol (IP) address of the proxy server. A DNS name is
a unique alphabetic identifier for a computer on a network. An IP address is a unique
numeric identifier for a computer on a network.

Click Computer > Control Center > System > Network Proxies.

Figure 2.19 Network Proxy Configuration Dialog

For more information on the individual options, click Help.
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2.5.4 Configuring Power Management
The Power Management module lets you manage your system’s power-saving options.
It is especially useful for extending the life of a laptop’s battery charge. However,
several options also help to save electricity when you are using a computer that is
plugged in to an electricity source.

Sleep mode shuts down the computer when it is unused for a specified amount of time.
Whether you are using battery or AC power, you can specify the amount of time that
the computer remains unused before it is put to sleep. You can also put the computer’s
display to sleep without shutting down the computer, saving the power required by the
display.

Sleep mode is especially important when the computer is operating under battery
power. Both the screen and the computer draw power from the battery, so you can save
a significant amount of battery power by shutting down one or both. It is common to
put the display to sleep after a shorter period of time. Then, if the computer remains
unused for an additional amount of time, it is also put to sleep.

There are several sleepmodes or actions you can set in the PowerManagement module:

Do nothing
The computer does not shut down or automatically go into any kind of power-
saving mode. If you have a laptop, the laptop continues to run normally when the
lid is closed.

Blank screen
The screen is blanked, reducing power consumption.

Suspend
Suspendmode turns off power-consuming computer components such as the display
and the hard drive without saving the contents of RAM. Any unsaved data is lost.

Hibernate
The computer saves the contents of RAM to the hard disk, then shuts down. When
you turn the computer on again, the saved data is put back into RAM, restoring
your computer to the state it was in before it shut off.Hibernate requires an amount
of free hard disk space equal to the amount of RAM installed on the computer.
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To open the Power Management module, click Computer > Control Center > System
> Power Management.

Procedure 2.6 Specifying Your Computer’s Sleep Settings

1 Click the tab for the type of power you are using: if your computer uses AC
power, click Running on AC. If your computer runs on battery power, click
Running on Battery. If your computer operates on both AC and battery power,
you can configure the settings on both tabs.

The settings you choose are in effect no matter which power source you use.

2 Use the sliders to set the amount of inactive time that passes before the display
and computer go into sleep mode.

When the display is in sleep mode, the computer continues to run. When the
computer is in sleep mode, power to the display and hard disk is shut off and the
computer uses only the power needed to maintain the contents of RAM.

3 If the computer is a laptop, set the actions you want taken when the laptop lid is
closed.

4 If you configure how a laptop manages battery power, configure the action you
want taken if battery power reaches a critical level.

Choose the option you prefer by selecting it from the menu. If you have sufficient
free disk space, Hibernate is the best choice.

5 If you want power management to prefer power savings over performance, select
the check box for that option.

If the check box is selected, the performance of some power-consuming features,
such as the display, is reduced slightly to reduce power consumption.

6 On the General tab, you can set further options, for example the action to take
when the power button is pressed, or the sleep type to use when the computer is
inactive. The options available there depend on the type of computer you use
(laptop or other computer).

7 You can also define when and how to display the power icon in the notification
area.
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8 When all options are set according to your wishes, click Close. The options you
selected go into effect immediately.

2.5.5 Setting Preferred Applications
The Preferred Applicationsmodule allows you change the default application for various
common tasks such as browsing the internet, sending mails or transferring data with
FTP.

Figure 2.20 Preferred Applications

1 Click Computer > Control Center > System > Preferred Applications.

2 Click the tab for the type of application you want to set.

3 Select one of the available from the applications from the Select menu or enter
the command used to start the application.

4 Click Close.

The changes take effect immediately.
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2.5.6 Setting Session Sharing Preferences
The Remote Desktop Preference dialog box lets you share a GNOME desktop session
between multiple users and set session-sharing preferences.

IMPORTANT: Sharing Desktop Sessions Affects System Security

Be aware that sharing desktop sessions can be a security risk. Use the restriction
options available. If you need to adjust the options to a lower security level,
do not forget to switch back to a higher security level as soon as possible.

1 Click Computer > Control Center > System > Remote Desktop.

2 To share your desktop session with other users, activate Allow other users to
view your desktop. All keyboard, pointer, and clipboard events from the remote
user are ignored.

3 If you want or need to allow other users to access and control your session from
a remote location, activate Allow other users to control your desktop. Click the
highlighted text below to send the system address by e-mail to a remote user.

4 Make use of the security options available: ifAsk you for confirmation is activated,
remote users require your confirmation before they can connect to your session.
To achieve a higher security level, activateRequire the user to enter this password
(if authentication is used).
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2.5.7 Configuring Search with Beagle
Settings

Beagle is the search engine used on the GNOME desktop. By default, Beagle is config-
ured to start automatically and index your home directory. If you want to change these
settings, specify the number of results displayed after a search or change the Beagle
privacy settings, click Computer > Control Center > System > Search & Indexing.

Figure 2.21 Search Preferences

For more information, see Section 4.4, “Setting Search Preferences” (page 116) and
Section 4.6, “Preventing Files and Directories from Being Indexed” (page 118).

2.5.8 Managing Sessions
This module lets you manage your sessions. A session occurs between the time that
you log in to the desktop environment and the time that you log out. You can set session
preferences and specify which applications to start when you begin a session. You can
configure sessions to save the state of applications and then restore the state when you
start another session.

You can also use this preference tool to manage multiple sessions. For example, you
might have a mobile session which starts applications you use most frequently when
traveling, a demo session that starts applications used to present a demonstration or

98 GNOME User Guide



slide show to a customer, and a work session that uses a different set of applications
when you are working in the office.

Click Computer > Control Center > System > Sessions.

Figure 2.22 Sessions Dialog—Session Options Page

Procedure 2.7 Setting Session Preferences

1 Use the Session Options tab to manage multiple sessions and set preferences for
the current session.

For example, to manage multiple sessions, click Add and enter a session name
to create a new session. When you log in to GDM, you can then choose which
of the multiple session to use.

2 On theCurrent Session tab, you can modify options for your current session. For
more information on the individual options, click Help.

3 On the Startup Programs tab you can add programs to start automatically when
beginning a session. ClickAdd and specify the command that runs this application.
If you specify more than one startup application, use the Order box to specify
the startup order of the each application. The commands are executed automati-
cally when you log in.

You can also Delete a startup application or temporarily Disable a startup appli-
cation.
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2.5.9 Setting Sound Preferences
The Sound Preferences tool lets you control when the sound server starts. You can also
specify which sounds to play when particular events occur.

Click Computer > Control Center > System > Sound to open the Sound Preferences
tool.

Figure 2.23 Sound Preferences Dialog

Use the Sounds tab to specify when to launch the sound server. You can also enable
sound event functions.

Click Enable software sound mixing (ESD) to start the sound server when you start a
session. When the sound server is active, the desktop can play sounds.

Click Play system sounds to play sounds when particular events occur in the desktop.

Finally, select the sound to play at each of the specified events.
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Some applications play a beep sound to indicate a keyboard input error. Use the System
Beep tab to set preferences for the system beep.

2.5.10 Configuring Administrative Settings
with YaST

For your convenience, YaST is available from the Control Panel as well as the Appli-
cations menu. For information about using YaST, refer to Part “Installation and Setup”
(↑Start-Up).
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Part II. Internet Connectivity,
Files and Resources





3Accessing Network Resources
From your desktop, you can access files and directories or certain services on remote
hosts or make your own files and directories available to other users in your network.
openSUSE® offers the following ways of accessing and creating network shared re-
sources.

• Network Browsing: Your file manager, Nautilus, lets you browse your network
for shared resources and services. Learn more about this in Section 3.2, “Accessing
Network Shares” (page 106).

• Sharing Folders inMixed Environments: Using Nautilus, configure your files
and folders to share with other members of your network. Make your data readable
or writable for users from any Windows or Linux workstation. Learn more about
this in Section 3.3, “Sharing Folders” (page 107).

• Managing Windows Files: openSUSE can be configured to integrate into an
existing Windows network. Your Linux machine then behaves like a Windows
client. It takes all account information from the Active Directory domain controller,
just as the Windows clients do. Learn more about this in Section 3.4, “Managing
Windows Files” (page 109).

• Configuring and Accessing aWindows Network Printer: You can configure
a Windows network printer through the GNOME Control Center. Learn how to
configure this in Section 3.5, “Configuring and Accessing a Windows Network
Printer” (page 110).
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3.1 General Notes on File Sharing and
Network Browsing

Whether and to which extent you can use file sharing and network browsing on your
machine and in your network highly depends on the network structure and on the con-
figuration of your machine. Before setting up either of them, contact your system ad-
ministrator to make sure that your network structure supports this feature and to check
whether your company's security policies permit it.

Network browsing, be it SMB browsing forWindows shares or SLP browsing for remote
services, relies heavily on the machine's ability to send broadcast messages to all clients
in the network. These messages and the clients' replies to them enable your machine to
detect any available shares or services. For broadcasts to work effectively, your machine
must be part of the same subnet as all other machines it is querying. If network browsing
does not work on your machine or the detected shares and services do not match with
what you expected, contact your system administrator to make sure that you are con-
nected to the appropriate subnet.

To allow network browsing, your machine needs to keep several network ports open
to send and receive network messages that provide details on the network and the
availability of shares and services. The standard openSUSE is configured for tight se-
curity and has a firewall up and running that protects your machine against the Internet.
To adjust the firewall configuration, you would either need to ask your system admin-
istrator to open a certain set of ports to the network or to tear down the firewall entirely
according to your company's security policy. If you try to browse a network with a re-
strictive firewall running on your machine, Nautilus warns you about your security re-
strictions not allowing it to query the network.

3.2 Accessing Network Shares
Networking workstations can be set up to share folders. Typically, files and folders are
marked to let remote users access them. These are called network shares. If your system
is configured to access network shares, you can use your file manager to access these
shares and browse them just as easily as if they were located on your local machine.
Whether you have only read access or also write access to the shared folders depends
on the permissions granted to you by the owner of the shares.
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To access network shares, open Nautilus and click Network Servers. Nautilus displays
the networks that you can access. Click a network, then click the server. You might be
required to authenticate to the server by providing a username and password.

Figure 3.1 Network File Browser

3.3 Sharing Folders
Sharing and exchanging documents is a must-have in corporate environments. Nautilus
offers you file sharing, which makes your files and folders available to both Linux and
Windows users.

3.3.1 Enabling Sharing on the Computer
Before you can share a folder, you must enable sharing on your computer. To enable
sharing:

1 Click Computer >More Applications > System > YaST.

2 Enter the root password.

3 Click Network Services.
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4 ClickWindows Domain Membership.

5 Click Allow Users to Share Their Directories, then click Finish.

3.3.2 Enabling Sharing for a Folder
To configure file sharing for a folder:

1 Open Nautilus.

2 Right-click the window background or a folder, then select Sharing Options from
the context menu.

3 Select Share this folder.

4 (Optional) If you want other people to be able to write to the folder, select Allow
other people to write in this folder.

5 (Conditional) If the folder does not already have the permissions that are required
for sharing, click Add the permissions automatically.

The folder icon changes to indicate that the folder is now shared.

IMPORTANT: Samba Domain Browsing

Samba domain browsing only works if your system's firewall is configured ac-
cordingly. Either disable the firewall entirely or assign the browsing interface
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to the internal firewall zone. Ask your system administrator about how to
proceed.

3.4 Managing Windows Files
With your openSUSEmachine being an Active Directory client, you can browse, view,
and manipulate data located on Windows servers. The following examples are just the
most prominent ones:

Browsing Windows Files with Nautilus
Use Nautilus's network browsing features to browse your Windows data.

Viewing Windows Data with Nautilus
Use Nautilus to display the contents of yourWindows user folder just as you would
for displaying a Linux directory. Create new files and folders on the Windows
server.

Manipulating Windows Data with GNOME Applications
Many GNOME applications allow you to open files on the Windows server, ma-
nipulate them, and save them back to the Windows server.

Single-Sign-On
GNOME applications, including Nautilus, support Single-Sign-On, which means
that to access other Windows resources, such as Web servers, proxy servers, or
groupware servers like MS Exchange, you do not need to reauthenticate. Authenti-
cation against all these is handled silently in the background once you provided
your username and password on login.

To access your Windows data using Nautilus, proceed as follows:

1 Open Nautilus and click Network Servers.

2 ClickWindows Network.

3 Click the icon of the workgroup containing the computer you want to access.

4 Click the computer’s icon (and authenticate, if prompted to do so), then navigate
to the shared folder on that computer.
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To create folders in your Windows user folder using Nautilus, proceed as you would
when creating a Linux folder.

3.5 Configuring and Accessing a
Windows Network Printer

Being part of a corporate network and authenticating against a Windows Active Direc-
tory server, you can access corporate resources, such as printers. GNOME allows you
to configure printing from your Linux client to a Windows network printer.

To configure a Windows network printer for use through your Linux workstation, pro-
ceed as follows:

1 Start the GNOME Control Center from the main menu.

2 Select Hardware > Printers.

3 Select New Printer.

Adding a printer requires root privileges, so you must enter the root password to
continue.

4 Select Network Printer, then selectWindows Printer (SMB) from the drop-down
menu.

5 Enter or select the Windows host, the printer, and the username and password
required to access the Windows computer, then click Forward.

6 Select the driver that most closely matches the printer, then click Forward.

7 Click Apply.

The printer is ready for use.

To print to the Windows network printer configured above, select it from the list of
available printers.
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4Searching with Beagle
Beagle is a search tool that indexes your personal information space (normally your
home directory) to find whatever you are looking for. Using Beagle, you can find doc-
uments, e-mails and attachments, Web history, IM/IRC conversations, address book
contacts, calendar appointments, notes, source code, images, music and video files,
archives and their contents, and applications.

• Section 4.1, “Using Beagle” (page 111)

• Section 4.2, “Search Tips” (page 113)

• Section 4.3, “Performing a Property Search” (page 114)

• Section 4.4, “Setting Search Preferences” (page 116)

• Section 4.5, “Indexing Other Directories” (page 117)

• Section 4.6, “Preventing Files and Directories from Being Indexed” (page 118)

4.1 Using Beagle
To use Beagle, click Computer, enter your search terms in the Search field, then press
Enter. The results are displayed in the Desktop Search dialog box.
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Figure 4.1 Desktop Search Dialog Box

You can use the results lists to open a file, forward it via e-mail, or display it in the file
manager. Simply right-click an item in the results list and select the option you want.
The options available for an item in the results list depend on the type of file it is. Se-
lecting a file in the list displays a preview of the file and information such as the title,
path, and date the file was last modified or accessed.
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Figure 4.2 Desktop Search Dialog Box With a File Selected

Use the Search menu to limit your search to files in a specific location, such as your
address book or Web pages, or to display only a specific type of file in your results list.
The Viewmenu lets you sort the items in your results list according to name, relevance,
or the date the file was last modified.

You can also access Desktop Search by clicking Computer >More Applications >
System > Search.

4.2 Search Tips
• You can use both uppercase and lowercase letters in search terms. Searches are not
case-sensitive by default.

To perform a case-sensitive search, put double quotationmarks (“) around the word
you want to match exactly. For example, if you use “APPLE” in a search, apple
will be ignored.
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• To search for optional terms, use OR (for example, apples OR oranges).

IMPORTANT

The OR is case-sensitive when used to indicate optional search terms.

• To exclude search terms, use a minus sign (-) in front of the term you want to ex-
clude (for example, apples -oranges will find results containing apples but not or-
anges).

• To search for an exact phrase or word, put quotation marks (“) around the phrase
or word.

• Common words such as “a,” “the,” and “is” are ignored.

• The base form of a search term is used when searching (for example, a search for
“driving” will match “drive,” “drives,” and “driven”).

4.3 Performing a Property Search
By default, the Beagle search tool looks for search terms in the text of documents and
in their metadata. To search for a word in a particular property, use property:query.
For example, author:john searches for files that have “john” listed in the Author
property.

Table 4.1 Supported Property Keywords

PropertyApplies toKeyword

Name of albumMusic filesalbum

Name of artistMusic fileartist

Author of the document (same as Creator of the
Document)

Documentauthor

Creator of the document, mapped to dc:creator
(for example, creator of PDF files)

Documentcreator
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PropertyApplies toKeyword

E-mail addressAddress bookemail

File extension (for example, extension:jpeg or
ext:mp3). Use extension: or ext: to search in
files with no extension.

Fileextension or ext

Genre of musicMusic filegenre

Comments and descriptions found in images
that have an IPTC caption or Exif comment

Image fileimagecomment

Model of camera (for example, EOS2D)JPEG imageimagemodel

F-Spot and Digikam image tags, and IPTC
keywords

Image fileimagetag

Name of senderE-mailmailfrom

E-mail address of senderE-mailmailfromaddr

Id of mailing list (for example, dashboard-
hackers.gnome.org)

E-mailmailinglist

Name of recipientE-mailmailto

E-mail address of recipientE-mailmailtoaddr

SpeakerChatspeakingto

Title of document, mapped to dc:title (for exam-
ple, title tag of HTML files)

Documenttitle

Property searches follow the rules mentioned in Section 4.2, “Search Tips” (page 113).
You can use property searches as an OR query or as an exclusion query, and phrases
can be used as query. For example, the following line will search for all PDF or HTML
documents containing the word “apple” whose author property contains “john” and
whose title does not contain the word “oranges”:
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apple ext:pdf OR ext:html author:john -title:oranges

4.4 Setting Search Preferences
Use the Search Preferences dialog box to set search preferences for Beagle.

1 Click Computer >More Applications > System > Search & Indexing.

You can also click Search > Preferences in the Desktop Search dialog box.

2 Choose from the following options:

Start search & indexing services automatically: Select this option if you
want the search daemon to start automatically when you log in to your session
(this option is selected by default). If you want to use Beagle’s Search function-
ality, the daemon must be running.

Index data while on battery power: Select this option if you want your data
to be indexed when your computer is operating on battery power. This option is
particularly useful if you are using openSUSE on a laptop and you want to stop
indexing when your laptop is running on battery power.
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Automatically start searching after the user has stopped typing: Select
this option if you want Beagle to start searching as soon as you stop entering text
in the Find field in the Desktop Search window. This option has no effect on the
Search field in the main menu.

Display the search window by pressing: Choose the keystrokes that will
display the Desktop Search window by specifying any combination of Ctrl, Alt,
and a function key. F12 is the default keystroke.

3 Click OK.

4.5 Indexing Other Directories
By default, Beagle indexes your home directory only. If you do not want your home
directory to be indexed, uncheck the Index my home directory option on the Indexing
tab of the Search Preferences dialog box. If you want to index additional folders, follow
these steps:

1 Click Computer >More Applications > System > Search & Indexing.

You can also click Search > Preferences in the Desktop Search dialog box.

2 Click the Indexing tab.
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3 Click Add in the General section of the dialog box.

4 Select the directory you want to index, then click Open.

Make sure you have rights to the directories you add.

5 If you want to remove a directory from the list of indexed directories, select it
in the list, then click Remove.

6 Click OK.

4.6 Preventing Files and Directories
from Being Indexed

Use the Search Preferences dialog box to specify resources that you do not want indexed.
These resources can include directories, patterns, mail folders, or types of objects.

1 Click Computer >More Applications > System > Search & Indexing.

2 Click the Indexing tab.

3 Click Add in the Privacy section.

4 Select a resource to exclude from indexing, then specify the path to the resource.

5 Click OK twice.

4.7 For More Information
More information about Beagle can be found on the following Web site:

• Beagle Home Page [http://beagle-project.org/]

118 GNOME User Guide

http://beagle-project.org/


5Managing Printers
openSUSE®makes it easy to print your documents, whether your computer is connected
directly to a printer or linked remotely on a network. This chapter describes how to set
up printers in SLED and manage print jobs.

5.1 Installing a Printer
Before you can install a printer, you need to know the root password and have your
printer information ready. Depending on how you connect to the printer, you might also
need the printer URI, TCP/IP address or host, and the driver for the printer. A number
of common printer drivers ship with SLED. If you cannot find a driver for the printer,
check the printer manufacturer's Web site.

5.1.1 Installing a Network Printer
1 Click Computer > Control Center > Add Printer > New Printer.

2 Enter the root password.

3 Click Network Printer, then select the type of connection for this printer.

CUPS Printer (IPP): A printer attached to a different Linux system on the
same network running CUPS or a printer configured on another operating system
to use IPP.
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Windows Printer (SMB): A printer attached to a different system which is
sharing a printer over a SMB network (for example, a printer attached to a
Microsoft Windows machine). Please refer to Section 3.5, “Configuring and
Accessing a Windows Network Printer” (page 110) for configuration details.

UNIX Printer (LPD): A printer attached to a different UNIX system that
can be accessed over a TCP/IP network (for example, a printer attached to another
Linux system on your network).

HP JetDirect: A printer connected directly to the network instead of to a
computer.

4 Specify the printer's information, then click Forward.

5 Select the printer driver for this printer, then click Apply.

You can also install a printer driver from a disk, or visit the printer manufacturer's
Web site to download the latest driver.

6 Specify desired options (such as a description or location) for the printer in the
Properties dialog box, then click Close.

The installed printer appears in the Printers panel. You can now print to the printer from
any application.

5.1.2 Installing a Local Printer
1 Connect the printer cable to your computer and connect the printer's power supply.

The printer dialog should open. If it doesn’t, click Computer > Control Center
> Add Printer > New Printer to open it.

2 Enter the root password.

3 Click Local Printer.

4 If the printer was autodetected, select the printer from the list. If the printer was
not autodetected, click Use another printer by specifying a port and then select
the correct printer port.
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5 Click Forward.

6 Select the printer driver for this printer, then click Apply.

You can also install a printer driver from a disk, or visit the printer manufacturer's
Web site to download the latest driver.

7 Specify desired options (such as a description or location) for the printer in the
Properties dialog box, then click Close.

The installed printer appears in the Printers dialog box. You can now print to the
printer from any application.

5.2 Modifying Printer Settings
1 Click Computer > Control Center > Printers.

2 Right-click the printer you want to modify, then click Properties.

3 Modify the properties, then click Close.

5.3 Canceling Print Jobs
1 Click Computer > Control Center > Printer.

2 Double-click the printer you sent the job to.

3 Right-click the print job, then click Cancel.

If the print job does not appear in the list, then the print job might have been
printed already.

5.4 Deleting a Printer
1 Click Computer > Control Center > Printer.
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2 Click Edit > Become Administrator.

3 Type the root password, then click Continue.

4 Right-click the printer you want to delete, then click Remove.
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AMoving from Windows to
Linux
If you are coming from Microsoft Windows, take a look at how familiar elements of
Windows translate to openSUSE®. After logging in, you will notice that the desktop
has a familiar layout and recognizable icons, many of them similar to theWindows and
Macintosh desktops.

Figure A.1 GNOME Desktop



A.1 Starting Applications from the
Main Menu

Similar to the Start menu on Windows, you can access all the programs installed on
your system from the main menu. To open the menu click Computer in the left corner
of the panel. Commonly used applications appear in the main menu, along with recently
used applications. ClickMore Applications to access additional applications, listed in
categories. Find more information about the main menu in Section 1.4, “Using theMain
Menu” (page 13).

Figure A.2 Main Menu in GNOME

Alternatively, you can also start programs from the command line. Press Alt + F2 to
open a dialog where you can enter a command to start the application. The name of the
command is often (but not always) the application name written in lowercase.
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A.2 Managing Files
To start the File Manager, click Computer > Nautilus File Browser, click your home
folder icon on the desktop or press Alt + F2 and enter nautilus.

Figure A.3 File Manager

For more information about the File Manager, see Section 1.5, “Managing Folders and
Files with Nautilus” (page 17).

A.3 Using the Command Line
To run commands in a command line environment, similar to a command prompt on
Windows, click Computer >More Applications > System > Gnome Terminal or press
Alt + F2 and enter gnome-terminal.
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Figure A.4 Windows Command Prompt and Terminal

A.4 Customizing Your Desktop
To change to the way your GNOME desktops looks and behaves, click Computer >
Control Center. Some of the settings you might want to change include the desktop
background, screen saver, keyboard and mouse configuration, sounds, and file associa-
tions.
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Figure A.5 GNOME Control Center

For more information, see Chapter 2, Customizing Your Settings (page 57).

A.5 Switching between Applications
Similar to the taskbar onWindows, the bottom panel in GNOME lets you easily switch
between open windows. Switch between them with a single click.

A.6 Accessing Network Resources
From your desktop, you can access files and directories or certain services on remote
hosts or make your own files and directories available to other users in your network.
openSUSE offers various different ways of accessing and creating network-shared re-
sources. Given that the network structure and the configuration of your computer allow
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for it, you can easily browse your network for shared resources and services with the
file manager.

Figure A.6 GNOME Network Browsing

To learn more about the various possibilities of accessing network resources, refer to
Section 1.6, “Accessing Network Resources” (page 21).
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BGNU Licenses
This appendix contains the GNUGeneral Public License and the GNU Free Documen-
tation License.

GNU General Public License
Version 2, June 1991

Copyright (C) 1989, 1991 Free Software Foundation, Inc. 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

Preamble
The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General Public License is intended
to guarantee your freedom to share and change free software--to make sure the software is free for all its users. This General Public License applies to
most of the Free Software Foundation’s software and to any other program whose authors commit to using it. (Some other Free Software Foundation
software is covered by the GNU Library General Public License instead.) You can apply it to your programs, too.

Whenwe speak of free software, we are referring to freedom, not price. Our General Public Licenses are designed to make sure that you have the freedom
to distribute copies of free software (and charge for this service if you wish), that you receive source code or can get it if you want it, that you can change
the software or use pieces of it in new free programs; and that you know you can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to ask you to surrender the rights. These restrictions
translate to certain responsibilities for you if you distribute copies of the software, or if you modify it.

For example, if you distribute copies of such a program, whether gratis or for a fee, you must give the recipients all the rights that you have. You must
make sure that they, too, receive or can get the source code. And you must show them these terms so they know their rights.

We protect your rights with two steps: (1) copyright the software, and (2) offer you this license which gives you legal permission to copy, distribute
and/or modify the software.

Also, for each author’s protection and ours, we want to make certain that everyone understands that there is no warranty for this free software. If the
software is modified by someone else and passed on, we want its recipients to know that what they have is not the original, so that any problems introduced
by others will not reflect on the original authors’ reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the danger that redistributors of a free program will individu-
ally obtain patent licenses, in effect making the program proprietary. To prevent this, we have made it clear that any patent must be licensed for everyone’s
free use or not licensed at all.

The precise terms and conditions for copying, distribution and modification follow.



GNUGENERAL PUBLIC LICENSE TERMS AND CONDITIONS FOR COPYING, DISTRIBUTIONANDMODIFICATION
0. This License applies to any program or other work which contains a notice placed by the copyright holder saying it may be distributed under the
terms of this General Public License. The “Program”, below, refers to any such program or work, and a “work based on the Program” means either the
Program or any derivative work under copyright law: that is to say, a work containing the Program or a portion of it, either verbatim or with modifications
and/or translated into another language. (Hereinafter, translation is included without limitation in the term “modification”.) Each licensee is addressed
as “you”.

Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The act of running the Program
is not restricted, and the output from the Program is covered only if its contents constitute a work based on the Program (independent of having been
made by running the Program). Whether that is true depends on what the Program does.

1. You may copy and distribute verbatim copies of the Program’s source code as you receive it, in any medium, provided that you conspicuously
and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this License
and to the absence of any warranty; and give any other recipients of the Program a copy of this License along with the Program.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Program or any portion of it, thus forming a work based on the Program, and copy and distribute such
modifications or work under the terms of Section 1 above, provided that you also meet all of these conditions:

a) You must cause the modified files to carry prominent notices stating that you changed the files and the date of any change.

b) You must cause any work that you distribute or publish, that in whole or in part contains or is derived from the Program or any part thereof, to
be licensed as a whole at no charge to all third parties under the terms of this License.

c) If the modified program normally reads commands interactively when run, you must cause it, when started running for such interactive use in the
most ordinary way, to print or display an announcement including an appropriate copyright notice and a notice that there is no warranty (or else, saying
that you provide a warranty) and that users may redistribute the program under these conditions, and telling the user how to view a copy of this License.
(Exception: if the Program itself is interactive but does not normally print such an announcement, your work based on the Program is not required to
print an announcement.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from the Program, and can be reasonably
considered independent and separate works in themselves, then this License, and its terms, do not apply to those sections when you distribute them as
separate works. But when you distribute the same sections as part of a whole which is a work based on the Program, the distribution of the whole must
be on the terms of this License, whose permissions for other licensees extend to the entire whole, and thus to each and every part regardless of who
wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the intent is to exercise the right to
control the distribution of derivative or collective works based on the Program.

In addition, mere aggregation of another work not based on the Program with the Program (or with a work based on the Program) on a volume of a
storage or distribution medium does not bring the other work under the scope of this License.

3. You may copy and distribute the Program (or a work based on it, under Section 2) in object code or executable form under the terms of Sections
1 and 2 above provided that you also do one of the following:

a) Accompany it with the complete corresponding machine-readable source code, which must be distributed under the terms of Sections 1 and 2
above on a medium customarily used for software interchange; or,

b) Accompany it with a written offer, valid for at least three years, to give any third party, for a charge no more than your cost of physically performing
source distribution, a complete machine-readable copy of the corresponding source code, to be distributed under the terms of Sections 1 and 2 above
on a medium customarily used for software interchange; or,

c) Accompany it with the information you received as to the offer to distribute corresponding source code. (This alternative is allowed only for
noncommercial distribution and only if you received the program in object code or executable form with such an offer, in accord with Subsection b
above.)

The source code for a work means the preferred form of the work for making modifications to it. For an executable work, complete source code means
all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used to control compilation and installation
of the executable. However, as a special exception, the source code distributed need not include anything that is normally distributed (in either source
or binary form) with the major components (compiler, kernel, and so on) of the operating system on which the executable runs, unless that component
itself accompanies the executable.

If distribution of executable or object code is made by offering access to copy from a designated place, then offering equivalent access to copy the
source code from the same place counts as distribution of the source code, even though third parties are not compelled to copy the source along with
the object code.

4. You may not copy, modify, sublicense, or distribute the Program except as expressly provided under this License. Any attempt otherwise to copy,
modify, sublicense or distribute the Program is void, and will automatically terminate your rights under this License. However, parties who have received
copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.
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5. You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to modify or distribute the
Program or its derivative works. These actions are prohibited by law if you do not accept this License. Therefore, by modifying or distributing the
Program (or any work based on the Program), you indicate your acceptance of this License to do so, and all its terms and conditions for copying, dis-
tributing or modifying the Program or works based on it.

6. Each time you redistribute the Program (or any work based on the Program), the recipient automatically receives a license from the original licensor
to copy, distribute or modify the Program subject to these terms and conditions. You may not impose any further restrictions on the recipients’ exercise
of the rights granted herein. You are not responsible for enforcing compliance by third parties to this License.

7. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent issues), conditions are
imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of this License, they do not excuse you from the conditions
of this License. If you cannot distribute so as to satisfy simultaneously your obligations under this License and any other pertinent obligations, then as
a consequence you may not distribute the Program at all. For example, if a patent license would not permit royalty-free redistribution of the Program
by all those who receive copies directly or indirectly through you, then the only way you could satisfy both it and this License would be to refrain en-
tirely from distribution of the Program.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the section is intended to apply and the
section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity of any such claims; this
section has the sole purpose of protecting the integrity of the free software distribution system, which is implemented by public license practices. Many
people have made generous contributions to the wide range of software distributed through that system in reliance on consistent application of that
system; it is up to the author/donor to decide if he or she is willing to distribute software through any other system and a licensee cannot impose that
choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

8. If the distribution and/or use of the Program is restricted in certain countries either by patents or by copyrighted interfaces, the original copyright
holder who places the Program under this License may add an explicit geographical distribution limitation excluding those countries, so that distribution
is permitted only in or among countries not thus excluded. In such case, this License incorporates the limitation as if written in the body of this License.

9. The Free Software Foundation may publish revised and/or new versions of the General Public License from time to time. Such new versions will
be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Program specifies a version number of this License which applies to it and “any later
version”, you have the option of following the terms and conditions either of that version or of any later version published by the Free Software Foun-
dation. If the Program does not specify a version number of this License, you may choose any version ever published by the Free Software Foundation.

10. If you wish to incorporate parts of the Program into other free programs whose distribution conditions are different, write to the author to ask
for permission. For software which is copyrighted by the Free Software Foundation, write to the Free Software Foundation; we sometimesmake exceptions
for this. Our decision will be guided by the two goals of preserving the free status of all derivatives of our free software and of promoting the sharing
and reuse of software generally.

NO WARRANTY

11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE PROGRAM, TO THE EXTENT
PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER
PARTIES PROVIDE THE PROGRAM “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING,
BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE
ENTIRERISKASTOTHEQUALITYANDPERFORMANCEOFTHEPROGRAMISWITHYOU.SHOULDTHEPROGRAMPROVEDEFECTIVE,
YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR
ANY OTHER PARTY WHOMAYMODIFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR
DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR
INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE
ORLOSSES SUSTAINEDBYYOUORTHIRDPARTIESORAFAILUREOFTHEPROGRAMTOOPERATEWITHANYOTHERPROGRAMS),
EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS

How to Apply These Terms to Your New Programs
If you develop a new program, and you want it to be of the greatest possible use to the public, the best way to achieve this is to make it free software
which everyone can redistribute and change under these terms.

To do so, attach the following notices to the program. It is safest to attach them to the start of each source file to most effectively convey the exclusion
of warranty; and each file should have at least the “copyright” line and a pointer to where the full notice is found.

one line to give the program’s name and an idea of what it does. Copyright (C) yyyy name of author
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This program is free software; you can redistribute it and/or
modify it under the terms of the GNU General Public License
as published by the Free Software Foundation; either version 2
of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program; if not, write to the Free Software
Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.

Also add information on how to contact you by electronic and paper mail.

If the program is interactive, make it output a short notice like this when it starts in an interactive mode:

Gnomovision version 69, Copyright (C) year name of author
Gnomovision comes with ABSOLUTELY NO WARRANTY; for details
type `show w’. This is free software, and you are welcome
to redistribute it under certain conditions; type `show c’
for details.

The hypothetical commands `show w’ and `show c’ should show the appropriate parts of the General Public License. Of course, the commands you use
may be called something other than `show w’ and `show c’; they could even be mouse-clicks or menu items--whatever suits your program.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a “copyright disclaimer” for the program, if necessary.
Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright
interest in the program `Gnomovision’
(which makes passes at compilers) written
by James Hacker.

signature of Ty Coon, 1 April 1989
Ty Coon, President of Vice

This General Public License does not permit incorporating your program into proprietary programs. If your program is a subroutine library, you may
consider it more useful to permit linking proprietary applications with the library. If this is what you want to do, use the GNU Lesser General Public
License [http://www.fsf.org/licenses/lgpl.html] instead of this License.

GNU Free Documentation License
Version 1.2, November 2002

Copyright (C) 2000,2001,2002 Free Software Foundation, Inc. 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

PREAMBLE
The purpose of this License is to make a manual, textbook, or other functional and useful document “free” in the sense of freedom: to assure everyone
the effective freedom to copy and redistribute it, with or without modifying it, either commercially or noncommercially. Secondarily, this License preserves
for the author and publisher a way to get credit for their work, while not being considered responsible for modifications made by others.

This License is a kind of “copyleft”, which means that derivative works of the document must themselves be free in the same sense. It complements
the GNU General Public License, which is a copyleft license designed for free software.
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We have designed this License in order to use it for manuals for free software, because free software needs free documentation: a free program should
come with manuals providing the same freedoms that the software does. But this License is not limited to software manuals; it can be used for any
textual work, regardless of subject matter or whether it is published as a printed book. We recommend this License principally for works whose purpose
is instruction or reference.

APPLICABILITY AND DEFINITIONS
This License applies to any manual or other work, in any medium, that contains a notice placed by the copyright holder saying it can be distributed under
the terms of this License. Such a notice grants a world-wide, royalty-free license, unlimited in duration, to use that work under the conditions stated
herein. The “Document”, below, refers to any such manual or work. Any member of the public is a licensee, and is addressed as “you”. You accept the
license if you copy, modify or distribute the work in a way requiring permission under copyright law.

A “Modified Version” of the Document means any work containing the Document or a portion of it, either copied verbatim, or with modifications
and/or translated into another language.

A “Secondary Section” is a named appendix or a front-matter section of the Document that deals exclusively with the relationship of the publishers or
authors of the Document to the Document’s overall subject (or to related matters) and contains nothing that could fall directly within that overall subject.
(Thus, if the Document is in part a textbook of mathematics, a Secondary Section may not explain any mathematics.) The relationship could be a matter
of historical connection with the subject or with related matters, or of legal, commercial, philosophical, ethical or political position regarding them.

The “Invariant Sections” are certain Secondary Sections whose titles are designated, as being those of Invariant Sections, in the notice that says that the
Document is released under this License. If a section does not fit the above definition of Secondary then it is not allowed to be designated as Invariant.
The Document may contain zero Invariant Sections. If the Document does not identify any Invariant Sections then there are none.

The “Cover Texts” are certain short passages of text that are listed, as Front-Cover Texts or Back-Cover Texts, in the notice that says that the Document
is released under this License. A Front-Cover Text may be at most 5 words, and a Back-Cover Text may be at most 25 words.

A “Transparent” copy of the Document means a machine-readable copy, represented in a format whose specification is available to the general public,
that is suitable for revising the document straightforwardly with generic text editors or (for images composed of pixels) generic paint programs or (for
drawings) some widely available drawing editor, and that is suitable for input to text formatters or for automatic translation to a variety of formats
suitable for input to text formatters. A copy made in an otherwise Transparent file format whose markup, or absence of markup, has been arranged to
thwart or discourage subsequent modification by readers is not Transparent. An image format is not Transparent if used for any substantial amount of
text. A copy that is not “Transparent” is called “Opaque”.

Examples of suitable formats for Transparent copies include plain ASCII without markup, Texinfo input format, LaTeX input format, SGML or XML
using a publicly available DTD, and standard-conforming simple HTML, PostScript or PDF designed for human modification. Examples of transparent
image formats include PNG, XCF and JPG. Opaque formats include proprietary formats that can be read and edited only by proprietary word processors,
SGML or XML for which the DTD and/or processing tools are not generally available, and the machine-generated HTML, PostScript or PDF produced
by some word processors for output purposes only.

The “Title Page” means, for a printed book, the title page itself, plus such following pages as are needed to hold, legibly, the material this License requires
to appear in the title page. For works in formats which do not have any title page as such, “Title Page” means the text near the most prominent appearance
of the work’s title, preceding the beginning of the body of the text.

A section “Entitled XYZ” means a named subunit of the Document whose title either is precisely XYZ or contains XYZ in parentheses following text
that translates XYZ in another language. (Here XYZ stands for a specific section name mentioned below, such as “Acknowledgements”, “Dedications”,
“Endorsements”, or “History”.) To “Preserve the Title” of such a section when you modify the Document means that it remains a section “Entitled
XYZ” according to this definition.

The Document may includeWarranty Disclaimers next to the notice which states that this License applies to the Document. TheseWarranty Disclaimers
are considered to be included by reference in this License, but only as regards disclaimingwarranties: any other implication that theseWarranty Disclaimers
may have is void and has no effect on the meaning of this License.

VERBATIM COPYING
You may copy and distribute the Document in any medium, either commercially or noncommercially, provided that this License, the copyright notices,
and the license notice saying this License applies to the Document are reproduced in all copies, and that you add no other conditions whatsoever to
those of this License. You may not use technical measures to obstruct or control the reading or further copying of the copies you make or distribute.
However, you may accept compensation in exchange for copies. If you distribute a large enough number of copies you must also follow the conditions
in section 3.

You may also lend copies, under the same conditions stated above, and you may publicly display copies.

COPYING IN QUANTITY
If you publish printed copies (or copies in media that commonly have printed covers) of the Document, numbering more than 100, and the Document’s
license notice requires Cover Texts, you must enclose the copies in covers that carry, clearly and legibly, all these Cover Texts: Front-Cover Texts on
the front cover, and Back-Cover Texts on the back cover. Both covers must also clearly and legibly identify you as the publisher of these copies. The
front cover must present the full title with all words of the title equally prominent and visible. You may add other material on the covers in addition.
Copying with changes limited to the covers, as long as they preserve the title of the Document and satisfy these conditions, can be treated as verbatim
copying in other respects.
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If the required texts for either cover are too voluminous to fit legibly, you should put the first ones listed (as many as fit reasonably) on the actual cover,
and continue the rest onto adjacent pages.

If you publish or distribute Opaque copies of the Document numbering more than 100, you must either include a machine-readable Transparent copy
along with each Opaque copy, or state in or with each Opaque copy a computer-network location fromwhich the general network-using public has access
to download using public-standard network protocols a complete Transparent copy of the Document, free of added material. If you use the latter option,
you must take reasonably prudent steps, when you begin distribution of Opaque copies in quantity, to ensure that this Transparent copy will remain thus
accessible at the stated location until at least one year after the last time you distribute an Opaque copy (directly or through your agents or retailers) of
that edition to the public.

It is requested, but not required, that you contact the authors of the Document well before redistributing any large number of copies, to give them a
chance to provide you with an updated version of the Document.

MODIFICATIONS
You may copy and distribute a Modified Version of the Document under the conditions of sections 2 and 3 above, provided that you release the Modified
Version under precisely this License, with the Modified Version filling the role of the Document, thus licensing distribution and modification of the
Modified Version to whoever possesses a copy of it. In addition, you must do these things in the Modified Version:

A. Use in the Title Page (and on the covers, if any) a title distinct from that of the Document, and from those of previous versions (which should, if
there were any, be listed in the History section of the Document). You may use the same title as a previous version if the original publisher of that version
gives permission.

B. List on the Title Page, as authors, one or more persons or entities responsible for authorship of the modifications in the Modified Version, together
with at least five of the principal authors of the Document (all of its principal authors, if it has fewer than five), unless they release you from this require-
ment.

C. State on the Title page the name of the publisher of the Modified Version, as the publisher.

D. Preserve all the copyright notices of the Document.

E. Add an appropriate copyright notice for your modifications adjacent to the other copyright notices.

F. Include, immediately after the copyright notices, a license notice giving the public permission to use the Modified Version under the terms of this
License, in the form shown in the Addendum below.

G. Preserve in that license notice the full lists of Invariant Sections and required Cover Texts given in the Document’s license notice.

H. Include an unaltered copy of this License.

I. Preserve the section Entitled “History”, Preserve its Title, and add to it an item stating at least the title, year, new authors, and publisher of the
Modified Version as given on the Title Page. If there is no section Entitled “History” in the Document, create one stating the title, year, authors, and
publisher of the Document as given on its Title Page, then add an item describing the Modified Version as stated in the previous sentence.

J. Preserve the network location, if any, given in the Document for public access to a Transparent copy of the Document, and likewise the network
locations given in the Document for previous versions it was based on. These may be placed in the “History” section. You may omit a network location
for a work that was published at least four years before the Document itself, or if the original publisher of the version it refers to gives permission.

K. For any section Entitled “Acknowledgements” or “Dedications”, Preserve the Title of the section, and preserve in the section all the substance
and tone of each of the contributor acknowledgements and/or dedications given therein.

L. Preserve all the Invariant Sections of the Document, unaltered in their text and in their titles. Section numbers or the equivalent are not considered
part of the section titles.

M. Delete any section Entitled “Endorsements”. Such a section may not be included in the Modified Version.

N. Do not retitle any existing section to be Entitled “Endorsements” or to conflict in title with any Invariant Section.

O. Preserve any Warranty Disclaimers.

If the Modified Version includes new front-matter sections or appendices that qualify as Secondary Sections and contain no material copied from the
Document, you may at your option designate some or all of these sections as invariant. To do this, add their titles to the list of Invariant Sections in the
Modified Version’s license notice. These titles must be distinct from any other section titles.

Youmay add a section Entitled “Endorsements”, provided it contains nothing but endorsements of yourModified Version by various parties--for example,
statements of peer review or that the text has been approved by an organization as the authoritative definition of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a passage of up to 25 words as a Back-Cover Text, to the end of the list of
Cover Texts in the Modified Version. Only one passage of Front-Cover Text and one of Back-Cover Text may be added by (or through arrangements
made by) any one entity. If the Document already includes a cover text for the same cover, previously added by you or by arrangement made by the
same entity you are acting on behalf of, you may not add another; but you may replace the old one, on explicit permission from the previous publisher
that added the old one.
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The author(s) and publisher(s) of the Document do not by this License give permission to use their names for publicity for or to assert or imply endorsement
of any Modified Version.

COMBINING DOCUMENTS
You may combine the Document with other documents released under this License, under the terms defined in section 4 above for modified versions,
provided that you include in the combination all of the Invariant Sections of all of the original documents, unmodified, and list them all as Invariant
Sections of your combined work in its license notice, and that you preserve all their Warranty Disclaimers.

The combined work need only contain one copy of this License, and multiple identical Invariant Sections may be replaced with a single copy. If there
are multiple Invariant Sections with the same name but different contents, make the title of each such section unique by adding at the end of it, in
parentheses, the name of the original author or publisher of that section if known, or else a unique number. Make the same adjustment to the section titles
in the list of Invariant Sections in the license notice of the combined work.

In the combination, you must combine any sections Entitled “History” in the various original documents, forming one section Entitled “History”; likewise
combine any sections Entitled “Acknowledgements”, and any sections Entitled “Dedications”. You must delete all sections Entitled “Endorsements”.

COLLECTIONS OF DOCUMENTS
Youmaymake a collection consisting of the Document and other documents released under this License, and replace the individual copies of this License
in the various documents with a single copy that is included in the collection, provided that you follow the rules of this License for verbatim copying
of each of the documents in all other respects.

You may extract a single document from such a collection, and distribute it individually under this License, provided you insert a copy of this License
into the extracted document, and follow this License in all other respects regarding verbatim copying of that document.

AGGREGATION WITH INDEPENDENT WORKS
A compilation of the Document or its derivatives with other separate and independent documents or works, in or on a volume of a storage or distribution
medium, is called an “aggregate” if the copyright resulting from the compilation is not used to limit the legal rights of the compilation’s users beyond
what the individual works permit. When the Document is included in an aggregate, this License does not apply to the other works in the aggregate which
are not themselves derivative works of the Document.

If the Cover Text requirement of section 3 is applicable to these copies of the Document, then if the Document is less than one half of the entire aggregate,
the Document’s Cover Texts may be placed on covers that bracket the Document within the aggregate, or the electronic equivalent of covers if the
Document is in electronic form. Otherwise they must appear on printed covers that bracket the whole aggregate.

TRANSLATION
Translation is considered a kind of modification, so you may distribute translations of the Document under the terms of section 4. Replacing Invariant
Sections with translations requires special permission from their copyright holders, but you may include translations of some or all Invariant Sections
in addition to the original versions of these Invariant Sections. You may include a translation of this License, and all the license notices in the Document,
and any Warranty Disclaimers, provided that you also include the original English version of this License and the original versions of those notices and
disclaimers. In case of a disagreement between the translation and the original version of this License or a notice or disclaimer, the original version will
prevail.

If a section in the Document is Entitled “Acknowledgements”, “Dedications”, or “History”, the requirement (section 4) to Preserve its Title (section 1)
will typically require changing the actual title.

TERMINATION
You may not copy, modify, sublicense, or distribute the Document except as expressly provided for under this License. Any other attempt to copy,
modify, sublicense or distribute the Document is void, and will automatically terminate your rights under this License. However, parties who have received
copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

FUTURE REVISIONS OF THIS LICENSE
The Free Software Foundation may publish new, revised versions of the GNU Free Documentation License from time to time. Such new versions will
be similar in spirit to the present version, but may differ in detail to address new problems or concerns. See http://www.gnu.org/copyleft/.

Each version of the License is given a distinguishing version number. If the Document specifies that a particular numbered version of this License “or
any later version” applies to it, you have the option of following the terms and conditions either of that specified version or of any later version that has
been published (not as a draft) by the Free Software Foundation. If the Document does not specify a version number of this License, you may choose
any version ever published (not as a draft) by the Free Software Foundation.

ADDENDUM: How to use this License for your documents
To use this License in a document you have written, include a copy of the License in the document and put the following copyright and license notices
just after the title page:

Copyright (c) YEAR YOUR NAME.
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Permission is granted to copy, distribute and/or modify this document
under the terms of the GNU Free Documentation License, Version 1.2
only as published by the Free Software Foundation;
with the Invariant Section being this copyright notice and license.
A copy of the license is included in the section entitled “GNU
Free Documentation License”.

If you have Invariant Sections, Front-Cover Texts and Back-Cover Texts, replace the “with...Texts.” line with this:

with the Invariant Sections being LIST THEIR TITLES, with the
Front-Cover Texts being LIST, and with the Back-Cover Texts being LIST.

If you have Invariant Sections without Cover Texts, or some other combination of the three, merge those two alternatives to suit the situation.

If your document contains nontrivial examples of program code, we recommend releasing these examples in parallel under your choice of free software
license, such as the GNU General Public License, to permit their use in free software.

142 GNOME User Guide


	GNOME User Guide
	About This Guide
	1. Available Documentation
	2. Feedback
	3. Documentation Conventions
	4. About the Making of This Manual
	5. Source Code
	6. Acknowledgments

	I. Introduction to the GNOME Desktop
	1. Getting Started with the GNOME Desktop
	1.1. Logging In and Selecting a Desktop
	1.1.1. What Is a Session?
	1.1.2. Switching Desktops
	1.1.3. Locking Your Screen

	1.2. Logging Out
	1.2.1. Logging Out or Switching Users
	1.2.2. Restarting or Shutting Down the Computer

	1.3. Desktop Basics
	1.3.1. Default Desktop Icons
	1.3.2. Desktop Menu
	1.3.3. Bottom Panel
	1.3.4. Adding Applets and Applications to the Panel

	1.4. Using the Main Menu
	1.4.1. Search Bar
	1.4.2. Main Menu Tabs
	. Favorite Applications
	. Recent Applications
	. Recent Documents
	. Recent Places

	1.4.3. System
	1.4.4. Status

	1.5. Managing Folders and Files with Nautilus
	1.5.1. File Manager Navigation Shortcuts
	1.5.2. Archiving Folders
	1.5.3. Creating a CD/DVD
	1.5.4. Using Bookmarks
	1.5.5. File Manager Preferences

	1.6. Accessing Network Resources
	1.6.1. Connecting to Your Network
	1.6.2. Accessing Network Shares
	. Adding a Network Place

	1.6.3. Sharing Directories From Your Computer
	. Enabling Sharing
	. Sharing a Directory


	1.7. Accessing Floppy Disks, CDs, or DVDs
	1.8. Finding Data on Your Computer or in the File System
	1.8.1. Searching for Files
	. Performing a Basic Search
	. Adding Search Options
	. Using the Search Results List
	. Disabling Quick Searches


	1.9. Moving Text Between Applications
	1.10. Printing
	1.10.1. Installing a Local Printer
	1.10.2. Monitoring Print Jobs in GNOME
	. Modifying Printer Settings
	. Canceling Print Jobs
	. Deleting a Printer


	1.11. Managing Internet Connections
	1.12. Exploring the Internet
	1.13. E-mail and Scheduling
	1.14. Opening or Creating Documents with OpenOffice.org
	1.15. Controlling Your Desktop’s Power Management
	1.15.1. GNOME Power Manager Notification Messages
	. AC Adapter Unplugged
	. Fully Charged
	. Power Low
	. Power Critical
	. Suspend Failure

	1.15.2. Viewing Power Statistics
	. Change History
	. Power History
	. Estimated Time History

	1.15.3. Modifying Power Management Preferences
	. On AC Power Preferences
	. On Battery Power Preferences
	. General Preferences

	1.15.4. Session and System Idle Times

	1.16. Creating, Displaying, and Decompressing Archives
	1.16.1. Opening an Archive
	1.16.2. Creating Archives
	1.16.3. Extracting Files From an Archive

	1.17. Taking Screen Shots
	1.18. Viewing PDF Files
	1.19. Controlling Sound
	1.20. Using the Fingerprint Reader
	1.20.1. Registering a Fingerprint
	1.20.2. For More Information

	1.21. Obtaining Software Updates
	1.22. For More Information

	2. Customizing Your Settings
	2.1. The Control Center
	2.2. Hardware
	2.2.1. Modifying Keyboard Preferences
	2.2.2. Configuring the Mouse
	2.2.3. Installing and Configuring Printers
	2.2.4. Configuring Removable Drives and Media
	2.2.5. Specifying Screen Resolution Settings
	2.2.6. Configuring a Touchpad

	2.3. Look and Feel
	2.3.1. Changing the Desktop Background
	2.3.2. Configuring Fonts
	2.3.3. Configuring Menus and Toolbars
	2.3.4. Configuring the Screen Saver
	2.3.5. Choosing a Theme
	2.3.6. Customizing Window Behavior
	2.3.7. File Management Preferences
	2.3.8. Locking Desktop Functions
	2.3.9. Customizing the Main Menu
	2.3.10. Improving Access for the Visually Impaired
	2.3.11. Configuring Desktop Effects
	. Enabling Desktop Effects
	. Modifying Desktop Effects
	. Xgl Shortcuts
	. More Desktop Effects
	. Switching Tasks
	. Unfolding the Cube
	. Displaying a Skydome Image Behind the Cube



	2.4. Personal
	2.4.1. Configuring Assistive Technology Support
	2.4.2. Changing Your Password
	2.4.3. Managing Keyrings
	2.4.4. Customizing Keyboard Shortcuts

	2.5. System
	2.5.1. Configuring Streaming Audio and Video
	2.5.2. Configuring Language Settings
	2.5.3. Configuring Network Proxies
	2.5.4. Configuring Power Management
	2.5.5. Setting Preferred Applications
	2.5.6. Setting Session Sharing Preferences
	2.5.7. Configuring Search with Beagle Settings
	2.5.8. Managing Sessions
	2.5.9. Setting Sound Preferences
	2.5.10. Configuring Administrative Settings with YaST



	II. Internet Connectivity, Files and Resources
	3. Accessing Network Resources
	3.1. General Notes on File Sharing and Network Browsing
	3.2. Accessing Network Shares
	3.3. Sharing Folders
	3.3.1. Enabling Sharing on the Computer
	3.3.2. Enabling Sharing for a Folder

	3.4. Managing Windows Files
	3.5. Configuring and Accessing a Windows Network Printer

	4. Searching with Beagle
	4.1. Using Beagle
	4.2. Search Tips
	4.3. Performing a Property Search
	4.4. Setting Search Preferences
	4.5. Indexing Other Directories
	4.6. Preventing Files and Directories from Being Indexed
	4.7. For More Information

	5. Managing Printers
	5.1. Installing a Printer
	5.1.1. Installing a Network Printer
	5.1.2. Installing a Local Printer

	5.2. Modifying Printer Settings
	5.3. Canceling Print Jobs
	5.4. Deleting a Printer

	6. Desktop Integrated Collaboration Environment
	7. Assistive Technology Support
	8. Backing Up User Data

	A. Moving from Windows to Linux
	A.1. Starting Applications from the Main Menu
	A.2. Managing Files
	A.3. Using the Command Line
	A.4. Customizing Your Desktop
	A.5. Switching between Applications
	A.6. Accessing Network Resources

	B. GNU Licenses
	B.1. GNU General Public License
	B.1.1. Preamble
	B.1.2. GNU GENERAL PUBLIC LICENSE TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
	. NO WARRANTY
	. END OF TERMS AND CONDITIONS

	B.1.3. How to Apply These Terms to Your New Programs

	B.2. GNU Free Documentation License
	B.2.1. PREAMBLE
	B.2.2. APPLICABILITY AND DEFINITIONS
	B.2.3. VERBATIM COPYING
	B.2.4. COPYING IN QUANTITY
	B.2.5. MODIFICATIONS
	B.2.6. COMBINING DOCUMENTS
	B.2.7. COLLECTIONS OF DOCUMENTS
	B.2.8. AGGREGATION WITH INDEPENDENT WORKS
	B.2.9. TRANSLATION
	B.2.10. TERMINATION
	B.2.11. FUTURE REVISIONS OF THIS LICENSE
	B.2.12. ADDENDUM: How to use this License for your documents




