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About This Guide

This guide is for anyone who wants to better understand how the Designer tool fits into the Identity 
Manager framework. The guide also covers basic Designer concepts and features that are available. 
Sections in the book include:

Chapter 1, “Designer Concepts,” on page 11
Chapter 2, “Getting Help,” on page 19
Chapter 3, “What’s New in Designer,” on page 27
Chapter 4, “Workspaces, Perspectives, and Views,” on page 29
Chapter 5, “Editors, Builders, and Wizards,” on page 77
Chapter 6, “Planning Identity Solutions,” on page 85
Appendix B, “Terminology,” on page 95
Appendix C, “Menu Options,” on page 97

Target Audience

Designer for Identity Manager was created for the following audiences:

Enterprise IT developers 
Consultants
Sales engineers
Architects or system designers
System administrators

Designer is aimed at information technology professionals who:

Have a strong understanding of directories, databases, and the information environment
Act in the role of a designer or architect of identity-based solutions

You don’t need to be a developer or programmer to use Designer. Designer contains fourteen 
builders to help you build working policies and drivers, seven editors to assist you in editing 
projects, and wizards to help you build drivers. Designer also contains over thirty views to help you 
design and implement Identity Manager solutions. Experienced users can bypass the wizards and 
interact directly at any level of detail.

Feedback

We want to hear your comments and suggestions about this manual and the other documentation 
included with this product. Please use the User Comment feature at the bottom of each page of the 
online documentation, or go to www.novell.com/documentation/feedback.html and enter your 
comments there.
About This Guide 9



10 Under

novdocx (en)  13 M
ay 2009
Documentation Updates

For the most recent version of the Understanding Designer for Identity Manager 3.6, visit the 
Novell documentation web site (http://www.novell.com/documentation/designer30/index.html) or 
the Identity Manager Web site (http://www.novell.com/identity/access/identity_integration).

Additional Documentation

Designer 3.0.1  for Identity Manager 3.6 Administration Guide
Identity Manager 3.6 Installation Guide
Identity Manager 3.6 Overview
Understanding Policies for Identity Manager 3.6
Policies in Designer 3.0
Novell Credential Provisioning for Identity Manager 3.6
Identity Manager 3.6 DTD Reference
Identity Manager 3.6 driver guides (http://www.novell.com/documentation/idm35drivers/)

For more documentation concerning Identity Manager 3.6, see the Identity Manager 3.6 
Documentation Index (http://www.novell.com/documentation/idm36/index.html).

Documentation Conventions

In Novell® documentation, a greater-than symbol (>) is used to separate actions within a step and 
items in a cross-reference path.

A trademark symbol (®, TM, etc.) denotes a Novell trademark. An asterisk (*) denotes a third-party 
trademark.

When a single pathname can be written with a backslash for some platforms or a forward slash for 
other platforms, the pathname is presented with a backslash. Users of platforms that require a 
forward slash, such as Linux* or UNIX*, should use forward slashes as required by your software.
standing Designer for Identity Manager
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1Designer Concepts

Designer for Identity Manager helps you design, test, document, and deploy Identity Manager 
solutions in a network or test environment. From a design perspective, Designer helps you 
graphically see all of the components that make up your Identity Manager solution and how they 
interact. From a test perspective, Designer enables you to modify your Identity Manager 
implementations to ensure they perform as expected.

From a document perspective, Designer keeps track of your design and layout information and 
presents that information in a format of your choosing with the simple click of a button. From a 
deployment perspective, Designer allows you to deploy and enable part or all of your Identity 
Manager solution into your actual networking environment. In addition, Designer enables teams to 
share work on enterprise-level projects.

Section 1.1, “How Identity Manager Works,” on page 11
Section 1.2, “How Designer Works with Identity Manager,” on page 14
Section 1.3, “Designer Features,” on page 16
Section 1.4, “Designer, iManager, and the User Application Administration Console,” on 
page 17

1.1  How Identity Manager Works
Novell® Identity Manager is a collection of products that provide the following capabilities:

Section 1.1.1, “Data Synchronization,” on page 12
Section 1.1.2, “Workflow,” on page 12
Section 1.1.3, “Role Assignments,” on page 13
Section 1.1.4, “Attestation,” on page 13
Section 1.1.5, “Self-Service,” on page 13
Section 1.1.6, “Auditing and Reporting,” on page 13

Identity Manager provides these capabilities through a number of components, as shown in the 
following figure.
Designer Concepts 11
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Figure 1-1   Identity Manager Functionality

For more information on how Identity Manager components work together, see the Identity 
Manager 3.6 Overview manual.

1.1.1  Data Synchronization
Simply put, data synchronization is the ability to move data that has been changed in one location to 
a different location. Data synchronization can include password synchronization, but it is not limited 
to that because Identity Manager can synchronize any data that is stored in a connected system that 
has access to the Identity Vault.

Data synchronization, including password synchronization, is provided by the five base components 
of the Identity Manager solution: the Identity Vault, Metadirectory engine, drivers, Remote Loader, 
and connected applications. For more information about data synchronization, see “Data 
Synchronization” in the Identity Manager 3.6 Overview.

1.1.2  Workflow
Through the User Application, Identity Manager provides the means to perform such functions as 
workflow approval, role assignments, attestation, and identity self-service. The User Application is 
a browser-based Web application that allows you to initiate provisioning and role assignment 
requests, as well as manage the approval process for these requests. 
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Workflow approval allows users to request access to networking resources, which can include an 
approval process involving one or more managers. For more information about the User 
Application, see “Workflow” in the Identity Manager 3.6 Overview.

1.1.3  Role Assignments
Role assignments allow users to receive access to network resources that have been assigned to 
them. You can receive access to role assignments either at an individual level or at a group 
membership level. 

The Roles Module Administrator can create new roles; modify existing roles; remove roles; modify 
relationships between roles; grant or revoke role assignments for users; and create, modify, and 
remove Separation of Duties constraints. For more information about Roles based provisioning, see 
the Identity Manager Roles Based Provisioning Module 3.6.1 documentation (http://
www.novell.com/documentation/idmrbpm361/index.html).

1.1.4  Attestation
Attestation allows your organization to assure that user access to resources does not break any 
corporate or government regulations. Using this process, individual users can validate their own 
profile information, and roles managers can validate role assignments and Separation of Duties 
violations.

For more information about attestation, see “Section 20.0, Making Attestation Requests” in the 
Identity Manager Roles Based Provisioning Module 3.6.1 User Application User Guide (http://
www.novell.com/documentation/idmrbpm361/ugpro/data/bookinfo.html).

1.1.5  Self-Service
The self-service capabilities of Identity Manager allow users to edit their own profiles, search a 
directory, change their passwords (including password hints and challenge responses), review 
password status, and, if authorized, create accounts for new users or groups. If you are an 
administrator, you can also view reports on the applications that are associated with a user.

For more information about Identity Manager’s self-service capabilities, see the Identity Manager 
Roles Based Provisioning Module 3.6.1 User Application User Guide (http://www.novell.com/
documentation/idmrbpm361/ugpro/data/bookinfo.html).

1.1.6  Auditing and Reporting
Identity Manager uses a platform agent to capture events from the Identity Vault and tracks those 
events through either the Novell Audit or the Novell SentinelTM system. Novell Audit is a 
centralized, cross-platform auditing service that collects event data from applications across 
multiple platforms and writes the data to a data store. Novell Sentinel is a security information and 
event management (SIEM) solution that automates the collection, analysis, and reporting of system 
network, application, and security logs.

For a more complete introduction to Novell Audit, see the Novell Audit site (http://
www.novell.com/products/audit/). For a more complete introduction to Novell Sentinel, see the 
Novell Sentinel site (http://www.novell.com/products/sentinel/).
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1.2  How Designer Works with Identity Manager
Designer for Identity Manager is a powerful, graphical toolset that works on Windows* or Linux 
workstations or laptops. Designer is self-contained, with a complete help system as part of the 
software. This allows you to take a laptop anywhere to work on your Identity Manager solution.

Designer helps you plan, design, test, document, and deploy Identity Manager solutions in a network 
or test environment. Designer does this through a series of windows called “views,” as well as a 
number of builders, wizards, and editors.

Figure 1-2   The Outline View, Modeler, and Palette in Designer

Section 1.2.1, “Planning,” on page 15
Section 1.2.2, “Designing,” on page 15
Section 1.2.3, “Testing,” on page 15
Section 1.2.4, “Project Documentation,” on page 15
Section 1.2.5, “Deployment,” on page 15
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1.2.1  Planning
Designer allows you to set up complete Identity Manager solutions in a test environment so you 
can work through any problems before deploying the solution into an actual work environment.
The Project view has directories that allow you to use drag and drop to store plans, documents, 
and figures pertaining to your Identity Manager solution.
For more information on planning your Identity Manager solution, see Chapter 6, “Planning 
Identity Solutions,” on page 85.

1.2.2  Designing
Designer can help you graphically see all of the components that make up your Identity 
Manager solution and how they interact with each other.
The Architect view in the Modeler gives you icons and a graphics area to help you organize and 
visualize your Identity Manager environment. For more information on the Architect view, see 
“Architect Mode” in the Designer 3.0.1  for Identity Manager 3.6 Administration Guide.
The Developer view in the Modeler allows you to design and configure the components that 
make up your Identity solution. For more information on the Modeler view, see “Creating a 
Model” in the Designer 3.0.1  for Identity Manager 3.6 Administration Guide.

1.2.3  Testing
Designer allows you to modify your Identity Manager implementations in a test environment to 
ensure that they perform as expected. 
Designer is team-enabled, allowing teams to share work on enterprise-level projects. Through 
the Version Control view, teams can work on the same solutions, share policy procedures, and 
keep track of who make changes to objects. For more information on the Version Control view, 
see “Version Control” in the Designer 3.0.1  for Identity Manager 3.6 Administration Guide.

1.2.4  Project Documentation
Designer keeps track of your design and layout information in a project and can present that 
information in a format of your choosing with the simple click of a button.
Using Designer to document your Identity Manager solution can save you weeks or months of 
gathering and writing driver specifications and their implementations. For more information on 
documenting your projects, see “Documenting Projects” in the Designer 3.0.1  for Identity 
Manager 3.6 Administration Guide.

1.2.5  Deployment
Designer allows you to deploy and enable part or all of your Identity Manager solution into 
your actual networking environment.
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Through the Import feature, you can import tested solutions or parts of a project from a test or 
working environment. For more information on importing, see “Importing into Designer” in 
the Designer 3.0.1  for Identity Manager 3.6 Administration Guide.
After you have a tested solution that is ready for deployment, you can use Designer’s Deploy 
feature to place that project into production. For more information on deploying a project, see 
“Deploying and Exporting” in the Designer 3.0.1  for Identity Manager 3.6 Administration 
Guide.

1.3  Designer Features
Section 1.3.1, “Highly Productive Environment,” on page 16
Section 1.3.2, “Tools for Developers,” on page 17

1.3.1  Highly Productive Environment
The following Designer features help you be more productive:

Provides a disconnected mode that enables you to work from your laptop when you’re on the 
go
Strong visual editors, minimal pop-ups, and well-synchronized views maximize productivity
Powerful window, view, perspective, and tool management
Designer is team-enabled, allowing teams to share work on enterprise-level projects through 
the Version Control view
Dozens of wizards and builders to help you configure projects and policies
Auto-creation of objects, auto-value, auto-connection, auto-layouts
Strong copy/paste functionality within and across editors
Full keyboard support in all editors
Full undo/redo functionality in most editors and views
Ability to scale the UI from basic to more advanced views
Ability to filter key views to see as much or as little as you need to see
Integrated XML editor with syntax highlighting, auto-suggest, and search and replace 
capabilities
Very efficient, compact, powerful, and productive off-line schema management tools
Value history on many fields to reduce typing
Many preferences and settings that can help you customize the UI to fit how you want to use 
Designer
Logs and traces that are easy to access and view
Thorough contextual help and a powerful searchable help system
Quick and easy installation
Auto-update notifies you of any updates and easily pulls them in
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1.3.2  Tools for Developers
Easily add and model something that is not in the shipping version of Designer.

For example, you can add your own applications, drivers, resources, and icons.
Configure Designer to use a different editor.
You can configure all file types (for example, .xml and .txt) to use your text editor of choice. 
Eclipse-based text editors work best, but you can also include various artifacts (for example, 
word processing documents and spreadsheets). Your system’s native text editor is 
automatically integrated into Designer if the platform supports it.
Develop and debug in Java*.
If you install Designer plug-ins into a full Eclipse install, you can perform Java development 
and debugging, ANT, C#, and UML modeling, all in the same tool alongside Designer. This has 
particular value to Identity Manager driver writers (Java or C) who want the tools all together.
Use public APIs.
Identity Manager uses fully published public Eclipse APIs as an underlying project data model 
that is consistent with open industry standards in its format, along with published Eclipse 
extension points.
With an off-the-shelf Eclipse book and knowledge of our extension points, you should be able 
to contribute very rich content to Designer. There are books, resources, and forums in the 
Eclipse community to address most of your needs. For further information, see Eclipse 
Resources (http://www.eclipse.org/resources/).

1.4  Designer, iManager, and the User Application 
Administration Console
Identity Manager contains three tools to assist you in setting up and configuring a working Identity 
Manager solution. These are Designer, iManager, and the User Application Administration Console.

iManager and Designer have similarities, but their features and user experience are optimized for 
their respective target users and environments. Designer is a planning and design tool, while 
iManager is a real-time administrator tool. They are compatible. You can export information (for 
example, a driver set or driver) from one to the other. Also, several key common UI elements are 
now similar so that you can move between the tools more effectively.

iManager is a browser-based tool that provides a single point of administration for many Novell 
products, including Identity Manager. By using the Identity Manager plug-ins for iManager, you can 
manage Identity Manager and receive real-time health and status information about your Identity 
Manager system.

The User Application provides a Web-based administration console that allows you to configure, 
manage, and customize password self-service, roles, and provisioning. The administration console is 
added as an Administration tab in the User Application for anyone who has been assigned 
administrative rights.

These three tools can help you to implement a viable Identity Manager solution into your 
organization.
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2Getting Help

You can find information about Designer in its local help system, in the readme.txt file, and in the 
online documentation. Information in the help system is not localized. If you need localized 
information, refer to the Designer 3.0.1 for Identity Manager 3.6 Administration Guide on the 
Novell® documentation Web site (http://www.novell.com/documentation).

Section 2.1, “Help from the Welcome Page,” on page 19
Section 2.2, “Browsing for Information,” on page 20
Section 2.3, “Getting Context-Sensitive Help,” on page 22
Section 2.4, “Help from the Web,” on page 22
Section 2.5, “Viewing Demos,” on page 23
Section 2.6, “Searching for Information,” on page 24
Section 2.7, “Customizing the Browser and Help Server,” on page 24

2.1  Help from the Welcome Page
When Designer starts, a Welcome page appears and makes it easy for you to get started.

Figure 2-1   The Welcome Page
Getting Help 19
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Table 2-1   Options on the Welcome Page

The icons on the toolbar take you to the Welcome page, toggle between previous and next pages, 
and enable you to customize the Welcome page.

Figure 2-2   Icons on the Toobar

You can close the Welcome page at any time by clicking the X next to Welcome.

Figure 2-3   The Close Icon

To return to the Welcome page, click Help > Welcome.

2.2  Browsing for Information
To navigate all of the help topics, you can use a built-in Web browser:

1 From Designer’s main menu, select Help > Help Contents.

Option Description

Overview Provides an overview of Designer and Identity 
Manager.

What’s New Describes what’s new in this release.

Enables you to update Designer. 

Links to the Readme file.

Tutorials Launches Flash demos of some Designer tasks.

Web Resources Provides links to online information and downloads.

Run Designer Takes you to the Designer program.
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The text under Using the Eclipse help system describes the icons that help you navigate and use 
the Help system.

2 In the Contents pane, select Designer for Identity Manager.

3 Navigate to the topic that you’re interested in.
or
Select the Index icon in the Contents pane to see an index of the topics.
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2.3  Getting Context-Sensitive Help
1 Press F1 or click the Help icon .

If you maximize an editor (for example, the Modeler), help topics do not display when you 
press F1. To view the help, minimize the editor.

2 Click links under About and Dynamic Help.

2.4  Help from the Web
To view results found through Google* or in the Eclipse help system:

1 Select Help > Search.
2 Type text in the Search expression field, then click Go or press Enter.
3 Click Web Search.
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Figure 2-4   Related Topics in Google and Eclipse

2.5  Viewing Demos
To see how Designer works, view the Flash demos that are available on the Welcome page:

1 Select Help > Welcome.
2 Select the Tutorials icon.

3 Select a demo:
Model Projects
Import
Create a Workflow
Manage and Simulate Policies
Documentation Generation Overview
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2.6  Searching for Information
1 Select Help > Search.
2 Type a topic in the Search field, then click Go.

You can also select Help > Help Contents, then use the Search option above the Contents pane, or 
click Search at the bottom of the context-sensitive Help view.

2.7  Customizing the Browser and Help Server
1 From the main menu, click Window > Preferences.
2 Select Help, make changes, then click OK.
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Because Designer is built on Eclipse, you are able to use Help server functionality. It is a 
development tool for building your own tools. If you have a team environment where the entire 
team is using Eclipse, you might want to set up a common Help server, and then use that server 
for help files and content.
For more information on Help and the Help server:

See “Help” in the Designer 3.0.1  for Identity Manager 3.6 Administration Guide.
Go to the Eclipse Web site.

3 (Optional) Expand Help, then click Content.

4 (Optional) Make changes concerning the Help server, then click OK.
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3What’s New in Designer

Designer is constantly being updated with new features and enhancements. To find out what’s new 
in Designer:

1 Run Designer for Identity Manager.

2 Click Help > What’s New.
You can also click Help > Help Contents > Designer for Identity Manager > What’s New in 
Designer.
In addition, Designer’s auto-update feature notifies you of new features so you can download 
them to have the most current version of Designer.
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4Workspaces, Perspectives, and 
Views

Designer has many views to help you manage your projects. Many of these views help you manage 
the different elements that appear in the Modeler view and give you a different perspective on the 
projects you are creating. 

For instance, the Project view shows all of the projects you have created, and the Outline view 
shows all of the objects that have been created and added to the project. The Navigator view shows 
all of the files that have been created for the project and their respective file types and locations. 

For information on the Modeler view and its functions, see “Creating a Model” in the Designer 3.0.1  
for Identity Manager 3.6 Administration Guide. For information on policies, see Understanding 
Policies for Identity Manager 3.6 and Policies in Designer 3.0.

Section 4.1, “Specifying the Workspace,” on page 29
Section 4.2, “Managing Perspectives,” on page 31
Section 4.3, “Managing Views,” on page 33
Section 4.4, “The Project View,” on page 42
Section 4.5, “The Outline View,” on page 45
Section 4.6, “The Navigator View,” on page 61
Section 4.7, “Policy Set View,” on page 64
Section 4.8, “The Properties View,” on page 66
Section 4.9, “The Search Results View,” on page 69
Section 4.10, “The Tasks View,” on page 70
Section 4.11, “The Trace and Error Log Views,” on page 75
Section 4.12, “The Dataflow View,” on page 76
Section 4.13, “The Project Checker,” on page 76

4.1  Specifying the Workspace
A workspace is a directory on your local hard drive where your projects and settings are stored. You 
specify your workspace directory each time you launch Designer, unless you select the Use this as 
the default and do not ask again option to skip the Workspace Launcher window.
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Figure 4-1   Selecting a Workspace Directory

The default workspace directory for a Designer 3 Windows workstation is Documents and 
Settings\username\designer_workspace. 

WARNING: Earlier Designer workspaces are not compatible with Designer 3.0 and above. 
Designer stores projects and configuration information in a workspace. These workspaces are not 
compatible from one version of Designer to another. You need to point Designer 3 to a new 
workspace, and not to a workspace used by a previous version of Designer.

If you have Designer 2.x or 3.0 Milestone projects, you can import the projects into Designer 3 (File 
> Import > Project from File System). Be sure the Copy project into the workspace option is 
selected. Importing the project runs the Converter Wizard, making the project compatible with 
Designer 3 architecture and placing it under your designated Designer 3 workspace directory 
(designer_workspace by default).

You can switch to another workspace by selecting File > Switch Workspace > Other. Select or type 
the name of the different workspace. Designer quickly restarts, loads the new workspace, and loads 
any projects and settings you have in that workspace. If the workspace doesn’t exist, Designer 
creates it. Do not use previous Designer workspaces with Designer 3.

For quick access, the most recently used workspaces appear when you select File > Switch 
Workspace. 

You can have multiple workspaces.

Section 4.1.1, “Project File Format,” on page 30

4.1.1  Project File Format
All projects are stored on the file system in a directory. By default, this is in the C:\Documents and 
Settings\Username\designer_workspace directory on a Windows workstation. However, you 
can specify a different directory when you create the project. (See “Creating a Project” in the 
Designer 3.0.1  for Identity Manager 3.6 Administration Guide.) All of your data and graphical 
layout information is saved in a directory corresponding to the project name. For example, the 
following files and directories are stored under the \designer_workspace3\Blanston01 
directory:
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Figure 4-2   Local Directory Structure

The main file in the project’s directory is the .proj file. This file uses an industry-standard XML 
format called XMI (XML Metadata Interchange Format). You never need to directly edit this file. 

What is XMI?

XMI enables easy interchange of metadata between modeling tools and between tools and metadata 
repositories in distributed heterogeneous environments. XMI integrates three key industry 
standards: 

XML (Extensible Markup Language, a W3C standard)
UML (Unified Modeling Language, an OMG modeling standard)
MOF (Meta Object Facility, an OMG modeling and metadata repository standard)

The integration of these three standards into XMI combines the best of OMG and W3C metadata 
and modeling technologies. The integration enables developers of distributed systems to share 
object models and other metadata. XMI, together with MOF and UML, forms the core of the OMG 
repository architecture that integrates object-oriented modeling and design tools with each other and 
with a MOF-based extensible repository framework.

For more information about XMI, go to XML Metadata Interchange (XMI) (http://www.oasis-
open.org/cover/xmi.html). 

4.2  Managing Perspectives
A perspective is a collection of related views and editors. To get to the perspective choices, select 
Window > Open Perspective > Other. The following perspectives are available:

Designer: Provides views (for example, Project, Outline, Property, and Tasks) and editors (for 
example, the Modeler or the Policy Editor) to help you design and deploy Identity Management 
solutions.
Resource: A generic perspective. You can use this perspective for projects other than Designer.
exteNd Perspective: For XML development to the exteNdTM platform.
Debug: Used for XML development.

Section 4.2.1, “Opening a Perspective,” on page 32
Section 4.2.2, “Resetting a Perspective,” on page 33
Section 4.2.3, “Closing a Perspective,” on page 33
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4.2.1  Opening a Perspective
The Designer perspective should be open and active the first time you run the application. If you 
close the perspective and want to reopen it, use menus or the Perspective Bar.

“Using Menus to Open a Perspective” on page 32
“Using the Perspective Bar to Open a Perspective” on page 32

Using Menus to Open a Perspective

1 On the main menu, click Window > Open Perspective.

2 Select Designer.
3 Click OK.

Using the Perspective Bar to Open a Perspective

1 On the main Perspective Bar (found on the right side, on the same level as the toolbar), click 
the Perspective Switcher icon.

2 From the list, select Designer, then click OK.
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4.2.2  Resetting a Perspective
After moving or resizing items in the Modeler workspace, you might want to return your perspective 
to its original layout. To quickly reset items in the workspace:

1 From the main menu, click Window.
2 Click Reset Perspective.

4.2.3  Closing a Perspective
Do one of the following:

On the main menu, select Window > Close Perspective (or Close All Perspectives). 

Figure 4-3   Options to Close a Perspective

On the Perspective Bar, right-click the perspective, then click Close.

4.3  Managing Views
Views enable you to view or edit projects.

Section 4.3.1, “Available Views In Designer,” on page 34
Section 4.3.2, “Opening a View,” on page 38
Section 4.3.3, “Moving a View,” on page 39
Section 4.3.4, “Minimizing and Maximizing Views,” on page 40
Section 4.3.5, “Closing a View,” on page 40
Section 4.3.6, “Reopening a View Window,” on page 40
Section 4.3.7, “Using Fast Views,” on page 41
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4.3.1  Available Views In Designer
Below is a list of all of the views that are available to you in Designer. The view names are followed 
by a brief description and information on where in the Designer help they can be found. The views 
are broken into two groups: the views that appear in the Window > Show View option and the views 
that appear in the Window > Show View > Other option. Some views are listed in both locations.

Figure 4-4   Selecting a View

“Views in the Window > Show View Option” on page 34
“Views in the Window > Show View> Other Option” on page 35

Views in the Window > Show View Option

The views that appear in the Window > Show View option include:

Dataflow. Designer allows you to manage how the data flows between the Identity Vault and 
the connected systems. You can see how the data flows between all of the connected systems, 
make changes as needed, create reports about the data, and view the flow of passwords between 
the systems. For more information, see “Managing the Flow of Data” in the Designer 3.0.1  for 
Identity Manager 3.6 Administration Guide.
Outline. The Outline view provides an outline of all of the objects you have open in an active 
editor. The Outline view’s contents vary, depending on the editor you have open at the time. For 
example, if you have a project open in the Modeler view, you see an outline of all of the objects 
that have been created for that project. See Section 4.5, “The Outline View,” on page 45.
Policy Set. The Policy Set view lists policies and displays a toolbar. The list displays all 
policies contained in the selected policy set. During a transformation, the policies within the list 
are executed from top to bottom. For a description of the icons located on the Policy Set view 
toolbar, see Section 4.7, “Policy Set View,” on page 64.
Project. The Project view lists all existing Designer projects. From the Project view, you can 
quickly find, open, view, navigate, manage, close, and delete any Designer project. See 
Section 4.4, “The Project View,” on page 42.
Project Checker. Designer provides a Project Checker tool to check your project. The Project 
Checker checks for proper design, contexts, server associations, policies, missing user data, and 
dependency problems that would cause the project deployment into the Identity Vault to fail. 
standing Designer for Identity Manager
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The project can be checked at any time, but you should always run the Project Checker before 
deploying your project. See “Checking Your Projects” in the Designer 3.0.1  for Identity 
Manager 3.6 Administration Guide.
Provisioning View. The Provisioning view provides persistent access to Designer’s 
provisioning features. Use the Provisioning view to access the editors that allow you to create 
and manipulate User Application components, manipulate object definitions, such as import or 
export object definitions, and define the User Application driver’s supported and default 
locales. 
Search Results. You can use the Search Results view to search across an entire project. With 
the Modeler view active, press Ctrl+F, then select the object types for which you want to 
search. The results appear in the Search Results view, sorted by name, class, type, and notes. 
See Section 4.9, “The Search Results View,” on page 69. 
Tasks. The Tasks view enables you to make and prioritize notes while you manage identities. 
This view is for your convenience; it can contain whatever you want and won’t affect the 
functionality of your solution. See Section 4.10, “The Tasks View,” on page 70.
Trace. The Error Log view can help you troubleshoot. If something isn’t working, messages 
written to the error log might help you. The log is named .log. It is a hidden file. To view the 
error log, you can use menus or browse the file system. See “Viewing the Error Log” in the 
Designer 3.0.1  for Identity Manager 3.6 Administration Guide.
Version Control. Version control enables you to track revisions of your project, along with all 
the objects and files in that project, share those revisions with other members of your team, 
manage the history of your objects, and make sure that every member of your team is using the 
same version of your project. See “Version Control” in the Designer 3.0.1  for Identity 
Manager 3.6 Administration Guide.

Views in the Window > Show View> Other Option

The views that appear in the Window > Show View > Other option contain views under the 
following headings:

“General” on page 35
“Designer for Identity Manager” on page 36
“Help” on page 37
“PDE Runtime” on page 37
“Provisioning” on page 37
“XML” on page 38

General

Bookmarks. The Bookmarks view enables you to see bookmarks that you have set in your text 
editors. To access the Bookmarks view, select Window > Show View > Other and select the 
Bookmarks option under the General heading.
Console. The Console view allows you to view any consoles you have open. To access the 
Console view, select Window > Show View > Other and select the Console option under the 
General heading.
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Internal Web Browser. You can open the Internal Web Browser view by selecting Window > 
Show View > Other and then selecting the Internal Web Browser option under the General 
heading. You can also open a Web browser within the Designer utility. The Web browser button 
is available from the main toolbar. See “Opening a Web Browser” in the Designer 3.0.1  for 
Identity Manager 3.6 Administration Guide.
Navigator. The Navigator view enables you to manage and view the file resources that are in 
your workspace. You can see your projects and files as they actually exist in the file system. 
You can add files and folders, and append them to your projects or workspace. See Section 4.6, 
“The Navigator View,” on page 61.
Outline. The Outline view provides an outline of all of the objects you have open in an active 
editor. The Outline view’s contents vary, depending on the editor you have open at the time. For 
example, if you have a project open in the Modeler view, you see an outline of all of the objects 
that have been created for that project. See Section 4.5, “The Outline View,” on page 45.
Problems. You can validate your XML files by using the right-mouse menu in the Source 
editor. If any validation errors or warnings occur, they are displayed in the Problems view.
The Problems view shows you errors, warnings, and information on any problems relating to 
data source explorer failures, EMF problems, moduleCore validation markers, problems, or 
validation messages. To bring up the Problems view, select Window > Show View > Other, then 
select the Problems option under the General heading.
Progress. The Progress view displays the progress of an operation. To bring up the Progress 
view, select Window > Show View > Other, then select the Progress option under the General 
heading.
Project Explorer. The Project Explorer view allows you to view information about all of the 
objects found in a project. Pertinent information about a selected object is displayed in the 
Properties view. To bring up the Project Explorer view, select Window > Show View > Other, 
then select the Project Explorer option under the General heading.
Properties. The Properties view displays information on key-value pairs (for example, Max 
Log Entries 2). The information displayed depends on what is selected in the active view (for 
example, the Modeler or Outline view). Often, the Properties view lets you edit the 
information. You can also view and edit the Administrator settings in an Identity Vault. See 
Section 4.8, “The Properties View,” on page 66.
Tasks. The Tasks view enables you to make and prioritize notes while you manage identities. 
This view is for your convenience; it can contain whatever you want and won’t affect the 
functionality of your solution. See Section 4.10, “The Tasks View,” on page 70.

Designer for Identity Manager

Dataflow. Designer allows you to manage how the data flows between the Identity Vault and 
the connected systems. You can see how the data flows between all of the connected systems, 
make changes as needed, create reports about the data, and view the flow of passwords between 
the systems. For more information, see “Managing the Flow of Data” in the Designer 3.0.1  for 
Identity Manager 3.6 Administration Guide.
eDirectory Browser. To locate or modify objects during your project development, use the 
eDirectory Object Manager to browse to and edit attributes of objects in the Identity Vault and 
other eDirectory trees. See “Managing Directory Objects” in the Designer 3.0.1  for Identity 
Manager 3.6 Administration Guide.
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Policy Set. The Policy Set view lists policies and displays a toolbar. The list displays all 
policies contained in the selected policy set. During a transformation, the policies within the list 
are executed from top to bottom. For a description of the icons located on the Policy Set view 
toolbar, see Section 4.7, “Policy Set View,” on page 64.
Project. The Project view lists all existing Designer projects. From the Project view, you can 
quickly find, open, view, navigate, manage, close, and delete any Designer project. See 
Section 4.4, “The Project View,” on page 42.
Project Checker. Designer provides a Project Checker tool to check your project. The Project 
Checker checks for proper design, contexts, server associations, policies, missing user data, and 
dependency problems that would cause the deployment of project into the Identity Vault to fail. 
The project can be checked at any time, but you should always run the Project Checker before 
deploying your project. See “Checking Your Projects” in the Designer 3.0.1  for Identity 
Manager 3.6 Administration Guide.
Search Results. You can use the Search Results view to search across an entire project. With 
the Modeler view active, press Ctrl+F, then select the object types you want to search on. The 
results appear in the Search Results view, sorted by name, class, type, and notes. See 
Section 4.9, “The Search Results View,” on page 69. 
Trace. The Error Log view can help you troubleshoot. If something isn’t working, messages 
written to the error log might help you. The log is named .log. It is a hidden file. To view the 
error log, you can use menus or browse the file system. See “Viewing the Error Log” in the 
Designer 3.0.1  for Identity Manager 3.6 Administration Guide.
Version Control. Designer 3 for Identity Manager contains a new feature called version 
control. Version control enables you to track revisions of your project, along with all the objects 
and files in that project, share those revisions with other members of your team, manage the 
history of your objects, and make sure that every member of your team is using the same 
version of your project. See “Version Control” in the Designer 3.0.1  for Identity Manager 3.6 
Administration Guide.

Help

Help. You can bring up the Help view by pressing F1 or by clicking a help button. You can also 
access help by clicking the Help menu at the top of Designer. See Chapter 2, “Getting Help,” 
on page 19.

PDE Runtime

Error Log. The Error Log view can help you troubleshoot. If something isn’t working, 
messages written to the error log might help you. The log is named .log. It is a hidden file. See 
“Viewing the Error Log” in the Designer 3.0.1  for Identity Manager 3.6 Administration Guide.
Plug-in Registry. A problem can occur if a plug-in fails to load. Use the Plug-in Registry view 
to see which plug-ins are loaded. See “Checking Loaded Plug-Ins” in the Designer 3.0.1  for 
Identity Manager 3.6 Administration Guide.

Provisioning

Data Item Mapping. Specifies how object attributes are mapped. See “Mapping Identity Vault 
to an LDAP Schema” in the Designer 3.0.1  for Identity Manager 3.6 Administration Guide.
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E-Mail Notification. Notification templates enable you to customize and send e-mail 
messages that users receive when triggers occur. The E-Mail Notification view allows you to 
view how notification templates are mapped to an e-mail server. See “Setting Up E-Mail 
Notification Templates” in the Designer 3.0.1  for Identity Manager 3.6 Administration Guide.
Provisioning View. The Provisioning view provides persistent access to Designer’s 
provisioning features. Use the Provisioning view to access the editors that allow you to create 
and manipulate User Application components, manipulate object definitions such as import or 
export object definitions, and define the User Application driver’s supported and default 
locales. To access the Provisioning view, select Window > Show View > Other and select the 
Provisioning View option under the Provisioning heading. 

XML

XPath Navigator. The XPath Navigator view supports context-sensitive editing of XPath 
expressions and syntax highlighting. It automatically attaches to the currently selected XML 
editor and uses its Document node as the evaluation context. The namespace context shows all 
namespaces in scope on its document element. See “XPath Navigator” in the Designer 3.0.1  
for Identity Manager 3.6 Administration Guide.

4.3.2  Opening a View
Figure 4-5   Selecting a View to Open

To open a view, select Windows > Show View, then select an option. There are a number of available 
views that you can see when you select the Window > Show View > Other option.

To narrow the list of views from the Other option, use the view filter:

1 Select Window > Show View > Other.
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2 In the edit box, type the name of the view that you want (for example, Trace).

You can open, maximize, and close these views. You can also arrange them however you want, or 
make Fast Views from them. See Section 4.3.7, “Using Fast Views,” on page 41.

To quickly expand or contract a view, double-click the view’s tab.

When you minimize a view or an editor stack, a placeholder tray appears in the closest location 
along the left, bottom, or right edge of the workbench. Each view from the view stack acts as a fast 
view while in this location. You can restore the stack by clicking the tray's Restore icon. You can 
drag and drop minimized trays to new locations along the workbench edge. Maximizing any stack 
triggers minimization of all others. 

Figure 4-6   A Placeholder Tray for the Project View

4.3.3  Moving a View
To move a view, drag the view’s tab to one of the following locations:

The left, bottom, top, or right of Designer
Stacked with other views
Outside of Designer, where it floats on your desktop

If two or more views are open, you can switch their order.
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4.3.4  Minimizing and Maximizing Views
To minimize a view, do one of the following:

Click the Minimize button in the view’s title bar .
Press Ctrl+M.

To restore the view to its original size, click the Restore button in the view’s title bar. 

To maximize a view or editor, do one of the following

Double-click the view’s tab.
Click the Maximize button .
Press Ctrl+M.

When expanded, the view or editor fills the entire application space. This feature provides maximum 
working space.

To restore the editor or view to its original dimensions, double-click the view’s tab. 

4.3.5  Closing a View
To close a view or editor, do one of the following:

Click the X on the view’s tab.
Right-click the view’s tab, then select Close.

Figure 4-7   Options to Close a View

4.3.6  Reopening a View Window
1 From the main menu, select Window > Show View.
standing Designer for Identity Manager
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