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87 Setting Up GroupWise Modes and Accounts

This section will familiarize you with GroupWise® modes and accounts, and help you set up users 
to use them.

“GroupWise Modes” on page 919

“Accounts” on page 925

“GroupWise Check” on page 943

GroupWise Modes
GroupWise provides three different ways to run the GroupWise client: Online mode, Caching 
mode, and Remote mode.

“Online Mode” on page 919

“Caching Mode” on page 919

“Remote Mode” on page 920

Most GroupWise features are available in all three GroupWise modes, with a few exceptions. 
Subscribing to other users’ notifications is not available in Caching mode. Subscribing to other 
users’ notifications and Proxy are not available in Remote mode.

The system administrator can add or remove a drop-down list on the client toolbar that allows users 
to select the GroupWise mode being used.

1 In ConsoleOne®, click Tools > GroupWise Utilities > Client Options.

2 Click Environment > the Client Access tab.

3 Select or deselect By Default, Show Login Mode Drop-Down List on Client Toolbar.

Online Mode
When using Online mode, users are connected to the post office on the network. The mailbox 
displays the messages and information stored in the Online mailbox (also called the network 
mailbox). Online mode is connected to the Online mailbox continuously. Users should use this 
mode if they do not have a lot of network traffic. If the Post Office Agent shuts down or if users 
lose the network connection, they will lose the connection to their mailbox.

Caching Mode
Users can use GroupWise in Caching mode whether or not the network or Post Office Agent is 
available. Because users are not connected to the network all the time, this mode cuts down on 
network traffic and has the best performance. A connection is automatically made to retrieve and 
send new messages. All updates are performed in the background so GroupWise is not interrupted. 
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Caching mode stores a copy of the entire Online mailbox, including messages and other 
information, on a user’s local drive. When users run Caching mode and Remote mode on the same 
computer, the same local mailbox (also called the Caching mailbox or Remote mailbox) can be 
used to minimize disk space usage. To use Caching mode, the client installation must be a standard 
installation, not a workstation installation.

Allowing or Forcing Use of Caching Mode

The system administrator can allow or disallow the use of Caching mode, and can also force users 
to log in to GroupWise in Caching mode.

1 In ConsoleOne, click Tools > GroupWise Utilities > Client Options.

2 Click Environment > the Client Access tab.

3 Select or deselect Allow Use of Caching Mode.

4 Select or deselect Force Use of Caching Mode.

Downloading the System Address Book

When users prime their Caching mailboxes, they receive a copy of the system address book. After 
the initial priming of the Caching mailbox, users can re-download the system address book and 
their personal address books in Caching mode by clicking View > Retrieve System Address Book 
or View > Retrieve Personal Address Book while in the Address Book. Address books will also 
be re-downloaded in Caching mode when users click Tools > Retrieve Entire Mailbox.

Users can also specify to download the system address book (and any rules they have created) on 
a regular basis. In Remote or Caching mode, click Accounts > Account Options > the GroupWise 
account > Properties > the Advanced tab > select Refresh Address Books and Rules Every __ 
Days. By default this is set to 7 days, but can be changed.

If you configure the POA to generate the system address book regularly, Caching mode users will 
always have a current copy to download. In ConsoleOne, right-click the POA object > click 
Properties. On the GroupWise Agent Settings page, make sure that Generate Address Book for 
Remote is selected. You can choose the time when you want the generation to take place.

If you want to generate the system address book for download more often than once a day, you can 
delete the existing wprof50.db file from the \wpcsout\ofs subdirectory of each post office. A new 
downloadable system address book will be generated automatically for users on each post office.

Remote Mode
“Remote Password” on page 921

“Async Gateway and X.25 Gateway” on page 921

“Remote Performance” on page 921

“Hit the Road” on page 921

“Remote Properties” on page 922

“Remote Mode Connections” on page 922

Remote mode is familiar to GroupWise users on the road. Similar to Caching mode, a copy of the 
Online mailbox, or the portion of the mailbox that users specify, is stored on the local drive. Users 
can periodically retrieve and send messages with the type of connection they specify (modem, 
network, or TCP/IP). Users can restrict what is retrieved, such as only new messages or only 
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message subject lines. To use Remote mode, the client installation must be a standard (full) 
installation, not a workstation installation.

The system administrator can allow or disallow the use of Remote mode.

1 In ConsoleOne, click Tools > GroupWise Utilities > Client Options.

2 Click Environment > the Client Access tab.

3 Select or deselect Allow Use of Remote Mode.

Remote Password

To use Remote mode, users must have a password set in Online mode. When they run in Remote 
mode for the first time, they can specify to use the same password in Remote mode or choose a 
new one.

Async Gateway and X.25 Gateway

For GroupWise to use a modem connection, the GroupWise Async Gateway or X.25 Gateway 
must be installed and configured in your GroupWise system. The gateway provides the means by 
which the client communicates with the GroupWise system.

Remote Performance

The system administrator can configure the MTA so that it re-directs Remote mode requests to 
other MTAs and POAs. The GroupWise client can establish a client/server connection to an MTA 
across the Internet. For more information, see “Enabling Live Remote” on page 601.

Hit the Road

Users can use Hit the Road on the Tools menu (or switch from Online mode to Remote mode) to 
create, set up, or update the Remote mailbox. A copy of the mailbox is created on the user’s local 
drive and any current connections are detected and set up. If users have already used Caching 
mode, the local mailbox has already been created. Users can also use Hit the Road to create setup 
files on a diskette to set up their Remote mailbox on a computer that's not connected to the 
network. Several users can set up their Remote mailboxes on a single shared computer.

Hit the Road creates a network connection for the method (direct connection or TCP/IP) 
GroupWise uses to access the user's post office. GroupWise can then use this connection, when 
running in Remote mode, to connect to the GroupWise system. For example, a network connection 
lets users of docked laptops run GroupWise in Remote mode and connect to the GroupWise system 
through the network connection rather than a modem connection.

Hit the Road also creates modem connections for Remote Profiles in the Async Gateway or X.25 
Gateway. Remote Profiles let GroupWise connect to the GroupWise system.

To use Hit the Road:

1 In the GroupWise client, click Tools > Hit the Road.

2 Follow the prompts to create the Remote mailbox on the computer or on a diskette.

Installing the Remote Mailbox from Diskette

 If Hit the Road created the user's Remote mailbox on diskette, the user needs to install the Remote 
mailbox on the computer that will be running in Remote mode. 

1 Insert the diskette containing the Remote mailbox into the computer's disk drive. 
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2 From the Windows Taskbar, click Start > Run.

3 Type A:\SETUP > click OK.

Follow the prompts. The setup program creates a Remote mailbox and copies the required 
files to the computer's hard drive.

Remote Properties

Users can change the way Remote mode is set up, including the connection, time zone, signature, 
and so forth, in Account Options on the Accounts menu. Remote is listed as an account.

By default, if an item is deleted from the Remote mailbox, the item will be deleted from the Online 
mailbox the next time a connection is made. Deletion options in Remote Properties can be changed 
so that an item deleted from the Remote mailbox will stay in the Online mailbox or vice versa.

Remote Mode Connections

“Setting Up a Modem Connection” on page 922

“Setting Up a Network Connection” on page 923

“Setting Up a TCP/IP Connection” on page 924

Setting Up a Modem Connection

If you are going to connect with a modem, you must create at least one modem connection. A 
modem connection provides GroupWise with the information it needs to connect to the 
GroupWise system through the GroupWise Async Gateway or GroupWise X.25 Gateway.

To set up a modem connection:

1 In the client, log in or change to Remote mode.

2 Click Accounts > Account Options > double-click the Remote account. 

3 Click the Connection tab, click Connect To, click New, click Modem, then click OK.

4 Type a descriptive name for the modem connection in the Connection Name box.

5 Click the country code, then type the area code and phone number for the gateway to the 
master GroupWise system.

You can use a comma (,) to signal a one-second pause in dialing such as 9, (800) 555-5555. 
The 9 accesses an outside line and the comma causes a one-second pause to wait for the dial 
tone before dialing the number. If you enter dashes, spaces, and parentheses, they are ignored. 

6 Type the login ID for the gateway.

7 Click Password, type the gateway password, click OK, retype the password, then click OK. 

8 Click the Advanced tab.

9 If your modem requires a script, specify the path to the script in the Modem Script box, click 
Edit Script, then specify the necessary When Given and Respond With commands.

To save the script without changing its filename, click Save > Close.

or

To save the script with a new filename, click Save As > type a name > Close.

10 Click a disconnect method.
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11 Click Attempts, then specify the number of times to redial if the line is busy.

12 Click Retry Interval, then specify the time interval between each redial attempt.

13 Click OK.

14 Select the connection you want, then click Select.

15 Select the location you are connecting from in the Connecting From box. If none are listed, 
use the Default Location option.

If you need to create a new location, click the Connect From button. This is useful for laptop 
users who are calling into the GroupWise system from different geographic locations. 

16 Select the modem to use for dialing up the gateway in the Connect Using box. If you have not 
yet defined your modem, click Modem to add a modem to your system.

17 Click OK, then click Close.

Setting Up a Network Connection

While running in Remote mode, GroupWise can connect to the user's Online mailbox using a 
network connection. A network is useful for laptop users connecting to the network through a 
docking station, or for remote users connecting through a modem using remote node software.

To create a network connection:

1 In the client, log in or change to Remote mode.

2 Click Accounts > Account Options > double-click the Remote account.

3 Click the Connection tab, click Connect To, click New, click Network, then click OK. 

4 Type a descriptive name for the network connection in the Connection Name box.

5 Type the path to any post office directory in the master GroupWise system.

Users can connect to their own post offices or to any post office in the master GroupWise 
system to access their Online mailboxes.

6 Click a disconnect method.

Method Description

When All Updates Are Received Disconnects after requests are sent and after all responses 
to the requests are received (or disconnects automatically 
when the time allowed by the gateway has expired).

Do Not Wait for Responses Disconnects immediately after requests are sent and 
pending responses are received. Pending responses are 
responses to other requests that are waiting to be 
downloaded to you.

Manually Lets you manually control when to disconnect (or 
disconnects automatically when the time allowed by the 
gateway has expired).
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7 Click OK.

8 Select the connection you want, then click Select.

9 Select the location you are connecting from in the Connecting From box. If none are listed, 
use the Default Location option.

If you need to create a new location, click the Connect From button. This is useful for laptop 
users who are calling into the GroupWise system from different geographic locations. 

10 Click OK, then click Close.

Setting Up a TCP/IP Connection

A TCP/IP connection enables GroupWise, while running in Remote mode, to connect to the 
GroupWise system through a network connection using TCP/IP rather than a modem connection. 
A TCP/IP connection can be made through a network connection, such as a laptop connecting to 
the network through its docking station, or through a modem using remote node software.

To create a TCP/IP connection:

1 In the client, log in or change to Remote mode.

2 Click Accounts > Account Options > double-click the Remote account.

3 Click the Connection tab, click Connect To, click New, click TCP/IP, then click OK.

4 Type a descriptive name for the TCP/IP connection.

5 Type the IP address or the DNS name.

6 Type the IP port for this address.

7 Click a disconnect method.

Method Description

When All Updates Are Received Disconnects after requests are sent and after all 
responses to the requests are received (or disconnects 
automatically when the time allowed by the gateway 
has expired).

Do Not Wait for Responses Disconnects immediately after requests are sent and 
pending responses are received. Pending responses 
are responses to other requests that are waiting to be 
downloaded to you.

Manually Lets you manually control when to disconnect (or 
disconnects automatically when the time allowed by 
the gateway has expired).

Method Description

When All Updates Are Received Disconnects after requests are sent and after all 
responses to the requests are received (or disconnects 
automatically when the time allowed by the gateway has 
expired).
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8 Click OK.

9 Select the connection you want, then click Select.

10 Select the location you are connecting from in the Connecting From box. If none are listed, 
use the Default Location option.

If you need to create a new location, click the Connect From button. This is useful for laptop 
users who are calling into the GroupWise system from different geographic locations. 

11 Click OK, then click Close.

Accounts
“Accounts Menu” on page 925

“Enabling POP3, IMAP4, and NNTP Account Access in Online Mode” on page 925

Accounts Menu
In addition to the Remote account, users can access and configure POP3 and IMAP4 Internet e-
mail accounts and NNTP News accounts from the Accounts menu. While the user is in Remote 
and Caching mode, POP3, IMAP4, and NNTP accounts are accessed without needing to connect 
to the GroupWise system. If the system administrator enables it, users can also access and 
configure their POP3, IMAP4, and NNTP accounts from the Accounts menu while in Online 
mode.

Enabling POP3, IMAP4, and NNTP Account Access in Online Mode
By default, POP3, IMAP4, and NNTP accounts can be added, configured, and accessed by users 
in Remote and Caching mode only. Account items and information are not accessible in Online 
mode, nor can items and information be uploaded to the Online mailbox until the system 
administrator enables it.

To enable POP3, IMAP4, and NNTP account access in client users’ Online mode for an entire post 
office:

1 Make sure GroupWise 6 agents have been installed. For more information, see “Message 
Transfer Agent” on page 557.

2 Make sure Internet Addressing is enabled. For more information, see “Internet Addressing” 
on page 52.

3 In ConsoleOne, select the post office object.

4 Click Tools > GroupWise Utilities > Client Options.

Do Not Wait for Responses Disconnects immediately after requests are sent and 
pending responses are received. Pending responses 
are responses to other requests that are waiting to be 
downloaded to you.

Manually Lets you manually control when to disconnect (or 
disconnects automatically when the time allowed by the 
gateway has expired).

Method Description
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5 Click Environment, then click the General tab.

6 Select Allow Use of POP and IMAP Accounts in the Online Mailbox.

7 Select Allow Use of News (NNTP) Accounts in the Online Mailbox.

8 Click OK.
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88 Using a Configuration File to Enable 
AutoUpdate and to Select Installation 
Responses

“Introduction” on page 927

“Installing with the Configuration File (setup.cfg)” on page 928

“Modifying the Configuration File” on page 928

“Adding LDAP Directory Service Accounts” on page 934

“Enabling AutoUpdate” on page 935

“Modifying Addon.cfg” on page 937

“Error Log File” on page 938

“Startup Switches for Administrator-Defined Setup” on page 938

Introduction
During installation and any subsequent updates, the GroupWise® 6 client setup program generally 
requires user intervention at the workstation to install the client software. By using a configuration 
file, you can cause installations and updates to occur, simplifying or eliminating the user response 
during installation. You can also use this configuration file to enable AutoUpdate, which forces 
updates to take place. This allows you to maintain current versions of the GroupWise software on 
the network. The use of a configuration file to install GroupWise is often called an administrator-
defined setup.

Information can be added to the configuration file that will add predefined LDAP directory service 
accounts to the Address Book in the client during installation.

The configuration file, setup.cfg, is an ASCII text file that supports extended ASCII characters. 
The file contains the responses normally provided by the user during the installation of the client 
files; for example, the path for the client files, whether to complete a workstation or standard 
installation, and the folder for the GroupWise icon are specified in this file.

When the GroupWise client setup.exe file is executed, it looks in the same directory for a setup.cfg 
file. If none is found, the installation proceeds, prompting the user for the needed information. If 
the setup.cfg file is found, the setup program installs the software, using the information outlined 
in the configuration file. Depending on the entries in the configuration file, the user might or might 
not be prompted to provide information during the installation.

If you are going to use a configuration file to install client software, it is recommended that users 
be given Read and File Scan rights to the software_distribution_directory\client and 
software_distribution_directory\client\win32 directories. (This does not apply if you are running 
AutoUpdate over an IP connection.)
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Installing with the Configuration File (setup.cfg)
During the installation of GroupWise Administration, the GroupWise client files were copied to 
the software distribution directory on your server. For example, if you accepted the default 
z:\grpwise\software as your target, the GroupWise client software was copied to 
z:\grpwise\software\client\win32. 

For GroupWise 6 Support Pack 1, the setupip.fil file, used when running AutoUpdate over an IP 
connection, is not included in the support pack image because of its size (over 44 MB). This file 
must be downloaded separately from Novell Software Downloads (http://download.novell.com) 
and copied to software_distribution_directory\admin\utility\setupip.

1 Make a backup copy of software_distribution_directory\client\setup.cfg. using an ASCII text 
editor, edit the setup.cfg file entries with the values you want. See “Modifying the 
Configuration File” on page 928 for more information.

2 If you want to add predefined LDAP directory service accounts to the Address Book, follow 
the procedure in “Adding LDAP Directory Service Accounts” on page 934.

3 If you want to use AutoUpdate, follow the procedure in “Enabling AutoUpdate” on page 935.

4 Save setup.cfg, then copy the file to the software_distribution_directory\client\wiN32 
directory. 

5 If you want to install additional components on users’ workstations, follow the procedure in 
“Modifying Addon.cfg” on page 937.

If you use several different configuration files, you will need to save them with different names 
and use the config=setup filename startup switch. See “Startup Switches for Administrator-
Defined Setup” on page 938 for more information.

To stop setup.exe from using the setup.cfg file, delete setup.cfg from the directory where setup.exe 
resides.

Modifying the Configuration File
The configuration file is divided into the following sections. In the configuration file, each section 
head must be enclosed in brackets [ ] as shown.

“[GroupWiseSetup]” on page 929

“[ShowDialogs]” on page 929

“[AutoUpdate]” on page 931

“[Startup]” on page 932

“[GWTIP]” on page 932

“[GWMAILTO]” on page 932

“[GWCHECK]” on page 933

“[IntegrationApps]” on page 933

“[Languages]” on page 934

Additional setup profiles are available on the Internet at support.novell.com/misc/worldwide.htm
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[GroupWiseSetup] 
“Version=” on page 929

“StandardInstall=” on page 929

“Path=” on page 929

“Folder=” on page 929

“DefaultIPAddress=” on page 929

“DefaultIPPort=” on page 929

Version= 

This must match the version being installed; otherwise, the setup program will not use setup.cfg. 
The default is 6.

StandardInstall= 

Specify the type of installation desired. Specify No for a workstation installation, which allows the 
user to run GroupWise from the network. Specify Yes for a standard installation, which allows the 
user to run GroupWise from the computer's hard drive. A standard installation is required to use 
Caching mode and Remote mode. The default is No.

Path= 

This is the path where you want GroupWise to be installed during a standard installation. The 
default path is c:\novell\groupwise\.

Folder= 

This will create and install the GroupWise icons to the specified folder. The default folder is 
GroupWise.

DefaultIPAddress=

This optional entry specifies the default IP address for the client to use the first time it is started.

DefaultIPPort=

This optional entry specifies the default IP port for the client to use the first time it is started.

[ShowDialogs]
“HideAllDialogs=” on page 930

“Welcome=” on page 930

“SetupOptions=” on page 930

“DestinationDirectory=” on page 930

“SelectOptionalComponents=” on page 930

“SelectProgramFolder=” on page 930

“SelectStartUpFolderSoftware=” on page 930

“LanguageSelection=” on page 930
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“SoftwareIntegrations=” on page 930

“StartCopyingFiles=” on page 931

“SetupComplete=” on page 931

HideAllDialogs=

Specify No to display dialog boxes during the installation. Specify Yes to hide the dialog boxes. 
A progress indicator will be displayed to inform the user of the installation status. The default is 
No.

If an entry is missing from the setup.cfg file and HideAllDialogs=Yes, the setup program will 
select the default setting. If HideAllDialogs=No, the setup program will prompt the user for a 
selection.

Welcome=

Specify Yes to display the Welcome dialog box during the installation. Specify No to hide this 
dialog box. The default is Yes.

SetupOptions=

Specify Yes to display the Setup Options dialog box during the installation. Specify No to hide this 
dialog box. The default is Yes.

DestinationDirectory=

Specify Yes to display the Destination Directory dialog box during the installation. Specify No to 
hide this dialog box. The default is Yes.

SelectOptionalComponents=

Specify Yes to display the Select Optional Components dialog box during the installation. Specify 
No to hide this dialog box. The default is Yes.

SelectProgramFolder=

Specify Yes to display the Select Program Folder dialog box during the installation. Specify No to 
hide this dialog box. The default is Yes.

SelectStartUpFolderSoftware=

Specify Yes to display the Select Startup Folder Software dialog box during the installation. 
Specify No to hide this dialog box. The default is Yes.

LanguageSelection=

Specify Yes to display the Language Selection dialog box during the installation. Specify No to 
hide this dialog box. The default is Yes.

SoftwareIntegrations=

Specify Yes to display the Software Integrations dialog box during the installation. Specify No to 
hide this dialog box. The default is Yes.
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StartCopyingFiles=

Specify Yes to display the Start Copying Files dialog box during the installation. Specify No to 
hide this dialog box. The default is Yes.

SetupComplete=

Specify Yes to display the Setup Complete dialog box during the installation. Specify No to hide 
this dialog box. The default is Yes.

[AutoUpdate] 
When an update to the GroupWise software is available, users are prompted if they want to install 
the new software when they start GroupWise. For complete instructions on enabling AutoUpdate, 
see “Enabling AutoUpdate” on page 935.

“Enabled=” on page 931

“SetupIPEnabled=” on page 931

“ForceUpdate=” on page 931

“GraceLoginCount=” on page 931

“PromptUntilUpdated=” on page 931

Enabled=

Specify Yes if you want users to be prompted to update their GroupWise client software as soon 
as a newer version is available. Specify No if you want to disable the AutoUpdate feature. The 
ForceUpdate= entry is then ignored. This might be useful if you intend to distribute the client 
software using a different method such as ZENworksTM Application Launcher, or if you want to 
disable AutoUpdates at the post office level during a migration to a newer version of GroupWise. 
The default is Yes.

SetupIPEnabled=

The default is No. Specify Yes if you want to run AutoUpdate over an IP connection to a software 
distribution directory that resides on an HTTP web server.

ForceUpdate= 

When this entry is set to Yes, GroupWise automatically updates the users' software. The default is 
No.

Users can still click Cancel to cancel out of the update; however, they cannot run the client 
software and access their mailboxes until they update the software.

GraceLoginCount=

Specify the number of grace logins allowed before you will require the users to update their client 
software. If ForceUpdate is set to No, this entry is ignored.

PromptUntilUpdated= 

When PromptUntilUpdated= is set to Yes, the user will be prompted to update the client each time 
the GroupWise client starts. The user can choose not to install the new software when prompted 
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and still run the currently installed version of the client. The AutoUpdate reminder will appear the 
next time the user starts the client. The default is No.

[Startup] 

Notify=

If you specify Yes, the setup program will place Notify in the Startup folder to be started 
automatically when the computer starts. The default is No.

[GWTIP] 
The Tip of the Day introduces what’s new in the GroupWise client, as well as displaying a variety 
of hints about using GroupWise. A new tip is displayed each time GroupWise is started.

“Default=” on page 932

“Hide=” on page 932

“Workstation=” on page 932

Default=

If you specify No, Tip of the Day will not be installed. If you specify Yes, Tip of the Day will be 
installed. The default is Yes.

Hide=

If you specify No, Tip of the Day will appear in the Select Components dialog box. The default is 
No.

The Hide= entry allows the system administrator to force the user to install or not install a 
particular component. If Hide=Yes, then the component will not be listed in the Select 
Components dialog and the Default= entry will determine if the component is going to be installed. 
For example, if Hide=Yes and Default=Yes, then the component will always be installed. 
However, if Hide=Yes and Default=No, then the component will never be installed.

Workstation=

If you specify No, Tip of the Day will not be available for a workstation installation. If you specify 
Yes, Tip of the Day will be available for a workstation installation. The default is Yes.

[GWMAILTO]
This section enables Internet Browser Mail Integration, which makes the GroupWise client the 
default e-mail program in the user’s browser. Whenever a user clicks an e-mail link on a Web page 
or chooses Mail in the browser, the GroupWise client opens.

“Default=” on page 933

“Hide=” on page 933

“Workstation=” on page 933
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Default=

If you specify No, Internet Browser Mail Integration will not be installed. If you specify Yes, 
Internet Browser Mail Integration will be installed. The default is Yes.

Hide=

If you specify No, Internet Browser Mail Integration will appear in the Select Components dialog 
box. The default is No.

The Hide= entry allows the system administrator to force the user to install or not install a 
particular component. If Hide=Yes, then the component will not be listed in the Select 
Components dialog and the Default= entry will determine if the component is going to be installed. 
For example, if Hide=Yes and Default=Yes, then the component will always be installed. 
However, if Hide=Yes and Default=No, then the component will never be installed.

Workstation=

If you specify No, Internet Browser Mail Integration will not be available for a workstation 
installation. If you specify Yes, Internet Browser Mail Integration will be available for a 
workstation installation. The default is Yes.

[GWCHECK]
This section installs and enables GroupWise Check (also called GWCheck). GroupWise Check is 
a tool that performs maintenance and repair tasks to keep GroupWise operating efficiently. It is 
essentially a standalone version of the Mailbox/Library Maintenance feature available in 
GroupWise Administration in ConsoleOne. GWCheck will check and repair GroupWise user, 
message, library, and resource databases without having ConsoleOne® and the GroupWise snap-
in loaded. In addition to checking post office, user, and library databases, it will also check remote 
and archive databases.

“InstallGWCheck=” on page 933

“GWCheckEnabled=” on page 933

InstallGWCheck=

Specify Yes to install GWCheck files to the workstation. Specify No to not install GWCheck. The 
default is Yes.

GWCheckEnabled=

Specify Yes to install the files to the same directory as the GroupWise client, which will result in 
the Repair Mailbox option being enabled under the Tools menu in the client. Specify No to install 
the files in a GWCheck subdirectory below the GroupWise client directory, which disables the 
Repair Mailbox option until the files are manually copied into the GroupWise directory. The 
default is No.

[IntegrationApps] 
GroupWise will install integration for the following applications, if found, unless the entry is set 
to No.

Lotus Word Pro
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Microsoft Binder

Microsoft Excel (versions higher than 7.0)

Microsoft Excel 7.0

Microsoft Word (versions higher than 7.0)

Microsoft Word 7.0

Microsoft PowerPoint

Corel Presentations

Corel Quattro Pro

Corel WordPerfect 7.0

Corel WordPerfect 8.0

Corel WordPerfect 9.0

Corel WordPerfect 10.0

[Languages] 
The default language is set to English, and all other languages are set to No, meaning they will not 
be installed. See the setup.cfg file for a listing of the different languages. The GroupWise client 
might not yet be available in all listed languages.

Adding LDAP Directory Service Accounts
LDAP directory service accounts provide users with the ability to search directory services such 
as Bigfoot for names of people. Each search can check potentially millions of names. After 
locating a name through a directory service search, users can add those names to their personal 
address books.

You can add predefined LDAP directory service accounts to the Address Book by adding 
information to setup.cfg. In GroupWise 6 Support Pack 1, this information can be added even after 
the initial installation. After the accounts are added, this information does not have to be removed 
from setup.cfg. During subsequent installations, GroupWise will add any new accounts listed but 
will not update or duplicate existing LDAP accounts.

The user can also choose to add LDAP directory service accounts after the GroupWise client is 
installed.

To add an LDAP account during installation, add the following lines to the setup.cfg file, 
providing information that is specific to the account:

[LDAP Account 1]
Description=Ldap Server1
Server=ldap.server1.com
Port=389
SearchRoot=c=us
Login=TRUE

You can add multiple accounts:

[LDAP Account 2]
Description=Ldap Server2
Server=ldap.server2.com
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Port=389
SearchRoot=0=widget, c=us
Login=FALSE

Enabling AutoUpdate
AutoUpdate can occur whether users have a mapped drive or IP connection to the software 
distribution directory. If users have a mapped drive to the software distribution directory, make 
sure they have Read and Scan rights to the software_distribution_directory\client and 
software_distribution_directory\client\win32 directories. 

If you are going to use AutoUpdate over an IP connection, copy 
software_distribution_directory\admin\utility\setupip\setupip.fil to an HTTP web server, or copy 
the entire client directory to the HTTP web server.

For GroupWise 6 Support Pack 1, setupip.fil is not included in the support pack image because of 
its size (over 44 MB). This file must be downloaded separately from Novell Software Downloads 
(http://download.novell.com) and copied to 
software_distribution_directory\admin\utility\setupip.
IMPORTANT: To install the GroupWise client using AutoUpdate, you must first make sure GroupWise 6 
Administration and GroupWise 6 agents have been installed, and that administration, agent, and client 
software has been updated.

In the following procedure, steps 1-4 apply only if you will be using an IP connection for 
AutoUpdate.

1 Run software_distribution_directory\admin\utility\setupip\writeip.exe. 

Specify an IP location for setupip.fil (or the IP location of the software distribution client 
subdirectory). For example, you can specify:

http://151.155.135.122/gw6/client

or

http://intranet.company.com/software/gw6/gwclient

You can include proxy and port information, for example:

http://name.mycompany.com/software/gw6/client;proxy.place.mycompany:1690

Parameter Description

Description= The name that displays in the list of LDAP directory services in the 
Address Book.

Server= The LDAP server name or IP address.

Port= The LDAP directory service’s port number. The number is usually 389.

SearchRoot= The base or root of the LDAP directory service where the user will 
search for names. For example, the base could be a country, 
organization, or other type of grouping. This is not required for all LDAP 
directory services. If a search root is required, the LDAP directory 
service will provide the information.

Login= TRUE means users are prompted for a username and password when 
they use that LDAP directory service.
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You can specify up to five locations. During AutoUpdate, each location is checked, in order, 
until a connection is made. 

If you select Choose IP Address at Random, the order in which the locations are checked is 
selected randomly when AutoUpdate occurs. This will balance the load on the web server.

2 Specify other options, such as the location for downloading the client installation files 
(setupip.fil or the client subdirectory files). 

You can have files downloaded to a temporary or specific directory.

If you select Allow the User to Change the Download Directory, the user is prompted for the 
location of the download directory and can change the default location.

3 Click OK.

Setupip.exe is created. writeip.ini is also created, which stores the options you selected in 
writeip.exe.

4 Copy setupip.exe to the software_distribution_directory\client\win32 directory.

5 Make a backup copy of software_distribution_directory\client\setup.cfg.

6 Using an ASCII text editor, edit the setup.cfg file entries with the values you want.

6a Under the [AutoUpdate] heading, specify

Enabled=Yes

6b Specify

ForceUpdate=Yes

if you want GroupWise to automatically update the users’ client software

or

ForceUpdate=No

if you want users to be prompted to update their client software.

6c Specify the number of grace logins you want to allow a user before forcing an 
AutoUpdate, for example:

GraceLoginCount=2

This entry is ignored if ForceUpdate=No.

6d If you will be using an IP connection for AutoUpdate, specify

SetupIPEnabled=Yes

7 Save the file as setup.cfg. Copy setup.cfg from software_distribution_directory\client to 
software_distribution_directory\client\win32.

8 If necessary, modify the addon.cfg files with the values you want. See “Modifying 
Addon.cfg” on page 937 for more information.

9 Log in to ConsoleOne as an Admin equivalent.

10 Click Tools > GroupWise System Operations.

11 Double-click Software Directory Management.

12 Click the software distribution directory, then click Update.

13 Select Force Auto-Update Check by GroupWise Components.
936   Administration



    Novell Confidential                                                                                            Manual (99a)  28 October 2003
This causes the GroupWise client to check for a new version. If a new version is found, the 
next time a user starts the GroupWise client, he or she is prompted to update the client 
software. If you have set ForceUpdate=Yes, the user will not be prompted before installation 
begins. If a mapped drive to the software distribution directory is found, the client software is 
installed from the mapped drive. If a mapped drive to the software distribution directory is not 
found, GroupWise looks at the IP locations you specified in writeip.ini and installs the client 
software.

In the event that no connection to the software distribution directory can be made, the file 
setupip.err is created in c:\windows of the user’s workstation. This file explains why none of 
the connections could be made.

Modifying Addon.cfg
The addon.cfg file is an ASCII text file that supports extended ASCII characters. The GroupWise 
client setup program uses the addon.cfg file to install additional components on users' 
workstations. The components might include software not shipped with GroupWise. The 
addon.cfg is specific to each program being installed. The required program files and the 
associated addon.cfg file must be copied to a subdirectory under 
software_distribution_directory\client\win32\addons.

During the client installation, the GroupWise setup program will search the subdirectories under 
the \addons directory for any addon.cfg files. The setup program will then execute the installation 
program for that component using the settings specified in the addon.cfg. If an entry is missing in 
the addon.cfg file, the installation program will prompt the user for the required information.

Addon.cfg files for Internet Browser Mail Integration and GroupWise Tip of the Day are included 
in the corresponding subdirectories under \addons, but the basic control for installing these two 
components is in the [GWMAILTO] and [GWCHECK] sections of setup.cfg.

When creating an addon.cfg for a different component, you must include at least the following 
section headings and associated entries. If the installation program requires additional information, 
you might include that information as additional entries. The required entries are as follows:

“[GroupWiseAddon]” on page 937

“[Name]” on page 938

“[Description]” on page 938

[GroupWiseAddon] 
This section head must be included with the following entries.

Entry Example

Install=add-on’s_setup_program_filename Install=setup.exe

Parameters=parameters_to_be_passed_on_to_the_add-
on’s_setup_program

Parameters=/install

Silent=parameters_to_append_to_administrator-
defined_setup

Silent=/s

Size=installed_size_of_add-on_in_kilobytes Size=100
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[Name] 
Under this section head, specify the two-letter language code for the language being installed, 
followed by the name of the add-on. This name appears in the components listing. 

Example: US=GroupWise Tip of the Day

[Description] 
Under this section head, specify the two-letter language code followed by a short description of 
the add-on. This description appears in the Description field when the component is highlighted in 
the component listing. 

Example: US=GroupWise Tip of the Day introduces new features and 
provides tips for using the GroupWise client.

Error Log File
If an error occurs during the installation and ShowDialogs=No, the error message is logged in 
gwsetup.err in the user's \windowS directory. If ErrorMessage=error_text has been added as the 
last entry under the [GroupWiseSetup] section, the error text will be displayed. Otherwise, a 
generic error message will be displayed notifying the user to contact the system administrator. The 
log file is an ASCII text file.

Startup Switches for Administrator-Defined Setup
For startup switches that can be used in conjunction with an administrator-defined setup, see 
“Startup Switches for Administrator-Defined Setup” on page 948.
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89 Using ZENworks for Desktops to Distribute the 
GroupWise Client

You can use the Application Management functionality in Novell® ZENworksTM for Desktops to 
distribute the GroupWise® client to workstations. The following sections provide instructions:

“Understanding the GroupWise Client .aot Files” on page 939

“Creating a GroupWise Client Application Object” on page 940
IMPORTANT: This information assumes that you are familiar with ZENworks for Desktops. For background 
information, or for help completing the ZENworks tasks outlined in the steps below, see the ZENworks for 
Desktops documentation at the Novell Documentation Web site (http://www.novell.com/documentation).

Understanding the GroupWise Client .aot Files
The most effective way to create a GroupWise client Application object is from an Application 
Object Template (.aot) file. If desired, you can use the ZENworks snAppShotTM utility to create a 
GroupWise client .aot file, or you can use one of the predefined .aot files included with 
GroupWise:

usonly.aot: Creates an Application object you can use to install the English version of the 
GroupWise client.

uswms9x.aot: Creates an Application object you can use to install the English version of the 
GroupWise client and the Windows Messaging System for Windows 95/98/ME.

uswmsnt.aot: Creates an Application object you can use to install the English version of the 
GroupWise client and the Windows Messaging System for Windows.

multi1.aot: Creates an Application object you can use to install the English, Danish, Dutch, 
Finnish, French, German, Italian, Norwegian, Portuguese, and Swedish versions of the 
GroupWise client. 

multi2.aot: Creates an Application object you can use to install the English, Czech, 
Hungarian, Polish, and Russian versions of the GroupWise client. 

multi3.aot: Creates an Application object you can use to install the English, Arabic, Chinese 
Simplified, Chinese Traditional, Hebrew, Japanese, Thai, and Turkish versions of the 
GroupWise client.

The .aot files contain the basic information required to create GroupWise client Application 
objects in Novell® eDirectoryTM. For example, the multi2.aot file can be used to create an 
Application object that, when associated with users, will cause the English, Czech, Hungarian, 
Polish, and Russian versions of the GroupWise client to be installed to a user’s workstation. For 
this to work, you must have already installed the files for these language versions to a GroupWise 
software distribution directory or another installation source directory.
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Creating a GroupWise Client Application Object
To create a GroupWise client Application object from one of the .aot files:

1 In ConsoleOne®, right-click the container where you want to create the GroupWise client 
Application object > click New > click Object to display the New Object dialog box.

2 In the list of objects, select App:Application, then click OK to display the New Application 
dialog box.

3 Select the Using an .AOT/.AXT File option, then click Next.

4 Browse for and select the .aot file you want to use, then click next.

By default, the .aot files are located in the client\zen directory in the GroupWise software 
distribution directory.

For example, if you want to create an Application object that will install the English, Czech, 
Hungarian, Polish, and Russian versions of the GroupWise client, select the multi2.aot file.

5 Customize the object name, source path, and target path, then click Next.

Object Name: This is the name that will be used for the Application object in eDirectory. You 
might want to use a descriptive name (for example, "GroupWise ECHPR Client" for the 
English, Czech, Hungarian, Polish, and Russian versions. 

SOURCE_PATH: This is the directory from which the GroupWise client will be installed. 
Specify the full path to the CLIENT directory (for example, 
\\server1\vol1\grpwise\software\client). Unless all users will have the same drive mapping to 
the volume, make sure you use a UNC path.

This path is saved as the SOURCE_PATH variable. If you need to change it later, you can do 
so on the Application object’s Macros page (Application object > Common tab > Macros 
page).

TARGET_PATH: This is the directory where the GroupWise client will be installed. Specify 
a path relative to the user’s workstation.

This path is saved as the TARGET_PATH variable. If you need to change it later, you can do 
so on the Application object’s Macros page (Application object > Common tab > Macros 
page).

6 Review the information, then click Finish to create the Application object.

7 Right-click the newly-created GroupWise client Application object > click Properties.

8 Click the Common tab > click Macros to display the Macros page.

If you used one of the multix.aot files to create the Application object, the Macros list includes 
a DEFAULT_LANGUAGE variable. This variable specifies the interface language that the 
GroupWise client will default to when it is installed. If necessary, individual users can change 
the language when they start the GroupWise client. If you modify the default language, use 
the language codes listed under “/l-xx” on page 947.

If you have users who use different language versions and you don’t want them to need to 
change the default language, you can use the same .aot file to create multiple Application 
objects. For each Application object, you would need to specify a default language and then 
associate the Application object with the users who would want that default language. 

9 Click the Availability tab, then click System Requirements to display the System 
Requirements page.
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Verify that the system requirements are satisfactory for your environment. If necessary, add 
additional requirements or remove the predefined requirements.

10 On the Application object’s Associations page (Associations tab), add the users or 
workstations you want the GroupWise client Application object distributed to.

11 Configure any other Application object settings required to provide the performance or 
functionality you want.

For example, you can configure the Application object so that the GroupWise client will be 
installed immediately upon distribution to the user’s workstation, without any intervention by 
the user. Or, you can change the locations where the GroupWise client’s icon will be 
displayed. For information about Application object settings, see the ZENworks for Desktops 
documentation at the Novell Documentation Web site (http://www.novell.com/
documentation).

After you associate the Application objects with the users you want, Novell Application 
Launcher/Explorer will display the Application object’s icon on the users’ workstations, 
provided the workstation meets the operating system requirements. If the Application object’s 
icon does not appear immediately, have the user refresh the Novell Application Launcher/
Explorer. 

12 If necessary, repeat the above steps to create additional GroupWise client Application objects 
from the GroupWise client .aot files.
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90 Tools for Analyzing and Correcting GroupWise 
Client Problems

The following tools can assist you in analyzing and correcting GroupWise® client problems.

“GroupWise Exception Handler” on page 943

“GroupWise Check” on page 943

GroupWise Exception Handler
In the event that the GroupWise client causes an exception (or "crashes"), GroupWise generates a 
GroupWise Exception Report. This report contains information that is useful in analyzing the 
problem that the client is having so that it can be solved.

Location
The report is saved in \TEMP\GRPWISE.RPT. The \TEMP directory used is the one specified by 
the TMP environment variable, or if not defined by TMP, the one specified by the TEMP 
environment variable. If neither environment variable is defined, GroupWise uses the current 
directory specified when GRPWISE.EXE is started (Win 95/98/ME) or the Windows directory 
(Win NT/2000).

Size
Each time an exception or crash occurs, a new report is appended to grpwise.rpt. if the file reaches 
100K, the oldest reports (at the beginning of the file) are deleted.

Contents
The GroupWise Exception Report contains information such as the date and time the report was 
generated, the exception code, fault address, date of grpwise.exe, computer and user name where 
the exception occurred, hardware and operating system information, process modules, raw stack 
dumps, and call stacks.

GroupWise Check
GroupWise Check (also called GWCheck) is a tool that performs maintenance and repair tasks to 
keep GroupWise operating efficiently. It is essentially a standalone version of the Mailbox/Library 
Maintenance feature available in ConsoleOne®. GroupWise Check will check and repair 
GroupWise user, message, library, and resource databases without having ConsoleOne and the 
GroupWise snap-in loaded. In addition to checking post office, user, and library databases, it will 
also check remote and archive databases. 
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Enabling GroupWise Check in the Client
GroupWise Check can be installed with the client (unless you have specified in setup.cfg that it 
not be installed), and is available by clicking Tools > Repair Mailbox in the client in Caching and 
Remote modes after you complete the following:

1 Locate the directory named gwcheck. this is a subdirectory of the directory where the client 
is installed (usually c:\novell\groupwise).

2 Locate grpwise.exe. It is usually in c:\novell\groupwise.

3 Copy all the files in gwcheck to the directory where grpwise.exe is located.

You will now be able to run GroupWise Check in Caching and Remote mode. The GroupWise 
Check dialog box is titled GroupWise Mailbox Maintenance. For detailed information about 
GroupWise Check, click Help in this dialog box, or see “GroupWise Check (GWCheck)” on 
page 429.

Running GroupWise Check Before Opening a Caching or Remote Mailbox
You can use Ctrl+Shift when accessing a Caching or Remote mailbox to run GroupWise Check 
before opening the mailbox.
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91 Startup Switches

“Startup Switches for the Client” on page 945

“Startup Switches for Administrator-Defined Setup” on page 948

Startup Switches for the Client
GroupWise® has optional commands that you can use when you start the program. Some of these 
startup switches are for your convenience, while others are necessary to run GroupWise on your 
particular hardware.

“/@u-?” on page 945

“/@u-user ID” on page 946

“/bl” on page 946

“/c” on page 946

“/cm” on page 946

“/iabs” on page 946

“/ipa-IP address or name” on page 946

“/ipp-port number” on page 946

“/l-xx” on page 947

“/la-network ID” on page 948

“/nu” on page 948

“/ph-pathname” on page 948

“/pc-path to caching mailbox” on page 948

“/pr-path to remote mailbox” on page 948

/@u-?
Displays a login dialog box whenever you open the GroupWise client, allowing you to supply any 
necessary login information.

Syntax: /@u-?

Example: groupwise.exe /@u-?
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/@u-user ID
Lets you use your GroupWise user ID to use the GroupWise client as yourself on another user's 
computer. The other user remains logged on to the network.

Syntax: /@u-user ID

Example: groupwise.exe /@u-ltanaka

/bl 
Prevents the GroupWise client logo screen from being displayed when you start the GroupWise 
client.

Syntax: /bl

Example: groupwise.exe /bl

/c
Checks for unopened items. If there are unopened items, the GroupWise client opens as usual. 
Otherwise, the GroupWise client does not start.

Syntax: /c

Example: groupwise.exe /c

/cm
Checks for unopened items. If there are unopened items, the GroupWise client opens minimized 
and a beep sounds. Otherwise, the GroupWise client does not start.

Syntax: /cm

Example: groupwise.exe /cm

/iabs
Initializes the Address Book when the GroupWise client starts.

Syntax: /iabs

Example: groupwise.exe /iabs

/ipa-IP address or name
Lets you specify the IP address or the name of the IP address when you are running in client/server 
mode.

Syntax: /ipa-IP_address

Example: groupwise.exe /ipa=127.65.45.1

/ipp-port number 
Lets you specify the IP port number when you are running in client/server mode.
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Syntax: /ipp-port_number

Example: groupwise.exe /ipp-1677

/l-xx
Applies only if you have two or more language versions or language modules. This option instructs 
GroupWise to override the default environment language (under Environment in Options) with the 
language specified by the language code xx. The language codes are listed below. This table lists 
the language codes used by all Novell® products. GroupWise might not yet be available in some 
of the listed languages. For current information, contact your local reseller.

Syntax: /l-xx

Example: groupwise.exe /l-ES

Language Code

Arabic AR

Chinese Simplified CS

Chinese Traditional CT

Danish DK

Dutch NL

Hebrew HE

Hungarian MA

Italian IT

Japanese NI

Norwegian NO

English US

Finnish SU

French FR

German DE

Polish PL

Portuguese-Brazil BR

Russian RU

Spanish ES

Swedish SV

Thai TH

Turkish TR
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/la-network ID
Lets you use your network ID to use the GroupWise client as yourself on another user's computer. 
The other user remains logged on to the network.

Syntax: /la-network_ID

Example: groupwise.exe /la-jgrey

/nu
Turns off AutoRefresh. If this option is selected, click View > Refresh whenever you want to 
update the display to see the items currently in your mailbox.

Syntax: /nu

Example: groupwise.exe /nu

/ph-pathname
Lets you specify the path to the post office.

Syntax: /ph-pathname

Example: groupwise.exe /ph-j:\mail\denver1

/pc-path to caching mailbox
Opens GroupWise in Caching mode. GroupWise must be restarted when you change from Online 
to Caching.

Syntax: /pc-path_to_caching_mailbox

Example: groupwise.exe /pc-c:\novell\groupwise\cache

/pr-path to remote mailbox
Opens the GroupWise client in Remote mode. This startup switch can be used in the Target text 
box only.

Syntax: /pr-path_to_remote_mailbox

Example: groupwise.exe /pr-c:\novell\groupwise\remote

Startup Switches for Administrator-Defined Setup
The following startup switches can be used in conjunction with an administrator-defined setup. 
These switches might be used individually or in combination.

“config=setup filename” on page 949

“noconfig” on page 949

“record” on page 949
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config=setup filename 
This runs the setup program using a configuration file other than SETUP.CFG. The other 
configuration file must be located in the software distribution directory. This switch does not apply 
when the GroupWise client setup program is executed by AutoUpdate.

Syntax: config=setup filename

Example: setup config=test.cfg

noconfig
This runs the setup without using the configuration file, even if one exists.

Syntax: noconfig

Example: setup noconfig

record 
This option runs the setup program, displaying all installation dialog boxes, and records the 
installation responses as they are selected. No installation files are copied and no changes are made 
to your machine. After setup finishes, a corresponding setup.cfg file is created in the \windows 
directory of your workstation.

Syntax: record

Example: setup record
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