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1.0  Novell Messenger Product Overview
Novell® Messenger 1.0 is a corporate instant messaging product that is based on Novell 
eDirectoryTM. Features include:

Sending instant messages in a secure environment (user authentication through eDirectory 
and SSL encryption of messages)

Creating a contact list and displaying user information from the contact list (all based on user 
information already available in eDirectory)

Displaying user presence (online, busy, away, idle, and so on)

Blocking others from seeing your presence

Creating custom statuses to define your presence

Participating in multi-user conversations

Saving personal conversations

Creating and searching a corporate-level conversation archive

The server side of this product is called Novell Messenger. The client side is called Novell 
GroupWise® Messenger because it has been customized to accompany the GroupWise product.

2.0  Novell Messenger Administration and Agents

2.1  System Requirements
For information about system requirements, see System Requirements in the Novell Messenger 
Installation guide (NovellMessengerInstallationGuide.pdf in the \docs\en subdirectory of the 
Novell GroupWise Messenger CD). 

2.2  Installation

2.2.1  Installing Novell Messenger Administration and Agents

1 Run setup.exe at the root of the Novell GroupWise Messenger CD to launch the Messenger 
Installation program.

2 Follow the on-screen instructions.

3 Click Installation Guide for detailed installation instructions.
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2.2.2  Distributing the GroupWise Messenger Client from the Novell Messenger Download 
Page

1 Run the Novell Messenger Installation program. See “Installing Novell Messenger 
Administration and Agents” on page 2.

2 In your Web browser, enter the IP address of the Novell Messenger download page.

This is the IP address and port of the Messaging Agent. By default, the Messaging Agent port 
is 8300. For example, if you installed to a server with an IP address of 13.45.67.89, the Novell 
Messenger download page would be http://13.45.67.89:8300.

3 Follow the instructions on the download page to install the GroupWise Messenger software.

2.3  Known Issues 
The following sections described known issues for Messenger administration and agents.

2.3.1  No Long Name Space Support on NetWare

If you install the Messenger agents on NetWare®, the path to the installation directory must use 
directory names that do not exceed the 8.3 naming convention. This naming convention must also 
be used for all files used by the Messenger agents, such as startup files, certificate files, and key 
files.

2.3.2  No Special Characters in File and Directory Names

Do not use extended characters or international characters in file and directory names.

2.3.3  Messenger Agents on a NetWare Cluster

If you install the Messenger agents on a NetWare cluster, you must install them on every node in 
the cluster. Some files are automatically installed to the current sys:\system location, rather than 
to the shared cluster volume. By installing to every node, you ensure that the proper files are 
available no matter which cluster node the Messenger agents fail over to.

2.3.4  Messenger Agents in Protected Mode on NetWare

On a NetWare server, you cannot run the Messenger agents in protected mode unless you are using 
LDAP access to eDirectory.

2.3.5  Required Rights for eDirectory Access

Because Messenger is based on eDirectory, the Messenger agents must be able to access 
eDirectory with the rights necessary to perform their tasks. The simplest way to accomplish this is 
to let the Messenger agents log in to eDirectory as an Admin equivalent user.

If you do not want to let the Messenger agents log in to eDirectory as an Admin equivalent user, 
you must set up an eDirectory user for them that has the rights detailed in eDirectory Access and 
Authentication in Installing a Messenger System in the Installation guide.

2.3.6  Configuration Changes in ConsoleOne

When you change Messenger system and agent configuration settings in ConsoleOne®, you must 
restart the Messenger agents in order to put the new settings into effect.
2   



Manual 3/17/03103Novell Confidential readmeen_web.fm last saved  4/1/03
When you change user-related settings, such as policy settings, users must log in again in order to 
put the new settings into effect. In the GroupWise Messenger client, users can click File > Log Out 
to easily log out and back in again.

2.3.7  LDAP Attributes in the Messenger Information List

The Messenger information list defines what user information is displayed when a user displays 
properties of a contact in the GroupWise Messenger client. ConsoleOne lists eDirectory attributes 
of type STRING and DN when you are configuring the information list. However, if you are using 
LDAP access to eDirectory, the LDAP attributes telephoneNumber and faxNumber can be 
manually added to the list, even though the eDirectory equivalent of these attributes is not of type 
STRING or DN. 

Other LDAP attributes that do not correspond to eDirectory attributes can also be manually added 
to the information list.

2.3.8  Manual Update to the Attribute Mapping Table for Early Versions of eDirectory

Versions of eDirectory earlier than 8.5 do not have the ability to recognize all NDS® attributes. If 
you will be using such a version of eDirectory and want to implement LDAP access to eDirectory, 
you will need to manually add all the Messenger attributes in the nmschema.sch file to the LDAP 
attribute mapping table, located on the LDAP Group object in eDirectory.

1 In ConsoleOne, right-click the LDAP Group object for the server you want to update, then 
click Properties.

2 Click Attribute Mappings > Add.

3 Select the NDS attribute drop-down list and scroll down until you find the attributes with the 
nnm prefix (for example, nnmAgentSettings).

Attributes names that start with lowercase letters sort after all attribute names that start with 
uppercase letters.

4 Select one of the nnm-prefixed attributes (for example, nnmAgentSettings).

5 In the Primary LDAP attribute edit box, type the name of the nnm-prefixed attribute (for 
example, nnmAgentSettings).

6 Click OK.

7 Repeat Step 3 through Step 6 for each nnm-prefixed attribute in the NDS Attribute list 
(through nnmWorkPath).

8 Click Apply or OK to save the Messenger attributes.

3.0  GroupWise Messenger Client

3.1  Installation
1 In a Web browser, enter the IP address of the GroupWise Messenger download page. 

You can get this information from your system administrator.

2 Follow the instructions on the download page to install the GroupWise Messenger client.
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3.2  Client Features
For information about GroupWise Messenger client features, click Help > Help in GroupWise 
Messenger.

3.3  Integration with the GroupWise Client
GroupWise Messenger can run simultaneously with the GroupWise client.
IMPORTANT: The username and password you use to log in to GroupWise Messenger is your directory 
(NDS/eDirectory) username and password, which might or might not be the same as your GroupWise 
username and password. Check with your system administrator.

There are several integration points in the GroupWise client if GroupWise Messenger is installed:

You can send an instant message from the GroupWise client by clicking File > New > Instant 
Message.

You can display the GroupWise Messenger contact list from the GroupWise client by clicking 
Tools > Messenger > Contact List.

You can specify whether or not to start GroupWise Messenger when you start the GroupWise 
client. In the GroupWise client, click Tools > Options, then double-click Environment. On the 
General tab, select or deselect Launch Messenger At Startup.

You can open GroupWise Messenger settings from the GroupWise client. Click Tools > 
Messenger > Preferences.

3.4  Known Issues
The following sections described known issues for the GroupWise Messenger client.

3.4.1  Running on Windows 98

When you run the GroupWise Messenger client on Windows* 98, you need to have Internet 
Explorer 5 or higher installed.

3.4.2  Running on Windows NT 4

When you run the GroupWise Messenger client on Windows NT* 4, status images will not appear 
next to status items in the menus.

3.4.3  RichEdit 3.0 Required for Text Size Changing

In the GroupWise Messenger client, you can click View > Text Size to select a larger or smaller 
text size in the Conversation window. However, unless your workstation has RichEdit 3.0 
installed, selecting a text size does not change the size of the text in the Conversation window.

RichEdit 3.0 is part of newer Windows operating systems. If your Windows operating system is 
still using RichEdit 2.0, you can update to RichEdit 3.0 by installing the Microsoft* Windows 
Installer Redistributable (http://www.microsoft.com/downloads/
details.aspx?displaylang=en&FamilyID=CEBBACD8-C094-4255-B702-DE3BB768148F).

3.4.4  Archived Conversation View

When you view an archived conversation, only the first 65 KB of text are displayed in the 
Conversation window in the GroupWise Messenger client. However, if you save the archived 
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conversation to disk as a text file, the entire conversation is saved and available for review in a text 
editor.

4.0  Additional Documentation

4.1  Readme Files
You can find readme files in the following locations on the Novell GroupWise Messenger CD:

Administration: \server\readmeen.txt
Client: \client\win32\readmeen.txt

For information on the latest Novell Messenger issues, see the Novell Messenger Readmes at the 
GroupWise 6.5 Documentation Web site (http://www.novell.com/documentation/lg/gw65/
index.html).

4.2  Installation Guide
For detailed installation instructions, see the Novell Messenger Installation guide 
(NovellMessengerInstallationGuide.pdf), which is available from the Messenger Installation 
program.

The Installation guide is also in the \server\docs\en directory on the Novell GroupWise Messenger 
CD. 

To view this guide properly, you will need to have Adobe Acrobat Reader 5.0 installed on your 
machine. If you need to update Adobe Acrobat Reader, see the Adobe Web site (http://
www.adobe.com/products/acrobat/readstep2.html).

4.3  Administration Guide
For additional Novell Messenger documentation, see the Novell Messenger Administration guide 
on the GroupWise 6.5 documentation Web site (http://www.novell.com/documentation/lg/gw65/
index.html).

5.0  Documentation Conventions
In this documentation, a greater-than symbol (>) is used to separate actions within a step and items 
in a cross-reference path.

A trademark symbol (®, TM, etc.) denotes a Novell trademark; an asterisk (*) denotes a third-
party trademark.

6.0  Legal Notices
Novell, Inc. makes no representations or warranties with respect to the contents or use of this 
documentation, and specifically disclaims any express or implied warranties of merchantability or 
fitness for any particular purpose. Further, Novell, Inc. reserves the right to revise this publication 
and to make changes to its content, at any time, without obligation to notify any person or entity 
of such revisions or changes.
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Further, Novell, Inc. makes no representations or warranties with respect to any software, and 
specifically disclaims any express or implied warranties of merchantability or fitness for any 
particular purpose. Further, Novell, Inc. reserves the right to make changes to any and all parts of 
Novell software, at any time, without any obligation to notify any person or entity of such changes.

You may not export or re-export this product in violation of any applicable laws or regulations 
including, without limitation, U.S. export regulations or the laws of the country in which you 
reside.

Copyright © 2003 Novell, Inc. All rights reserved. No part of this publication may be reproduced, 
photocopied, stored on a retrieval system, or transmitted without the express written consent of the 
publisher.

ConsoleOne, GroupWise, NDS, NetWare, and Novell are registered trademarks of Novell, Inc. in 
the United States and other countries.

eDirectory is a trademark of Novell, Inc.

All third-party products are the property of their respective owners.
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