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GroupWise Messenger 1.0 Support Pack 2
June 15, 2004

Overview
The information in this Readme file pertains to Novell® GroupWise® Messenger 1.0 Support Pack 
2. You must have GroupWise Messenger 1.0 installed before you install Support Pack 2.

For information on the latest Support Pack issues, see the Consolidated Support Pack Readme 
Addendum (http://support.novell.com/cgi-bin/search/searchtid.cgi?/10091736.htm).

1.0  Support Pack Installation

1.1  Messenger Version Information
Messenger 1.0 Support Pack 2 can be applied to the following Messenger versions:

Messenger 1.0 (original version)

Messenger 1.0.1 (Support Pack 1)

1.2  Prerequisites
Before installing Messenger 1.0 Support Pack 2:

Ensure that the network login account used to apply the Support Pack has Read, Write, Create, 
and Erase rights to the Messenger installation directory.

Ensure that users do not access the Messenger client software in the 
\novell\nm\ma\software\client directory during the update process.

1.3  Downloading the Support Pack
Messenger 1.0 Support Pack 2 is available in regular format for installing from a local or network 
driven and in ISO format for burning CDs. You can choose between multilingual and English-only 
downloads.

1.3.1  Downloading the Regular Version

1 In the list of Support Packs, click GW Messenger SP2.

2 Click the filename (gwm1sp2m.exe for multilingual or gwm1sp2e.exe for English only), then 
follow the instructions to download the file into a temporary directory.

3 Extract the .exe file into a directory at the root of your local drive or to a network server drive 
that can handle long pathnames.

The compressed file contains directory paths that could exceed DOS limits. 
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4 Continue with Section 1.4, Installing the Support Pack.

1.3.2  Downloading the ISO Version

1 In the list of Support Packs, click GW Messenger SP2 ISO for the Novell GroupWise 
Messenger CD.

2 Click the filename (gwm1sp2m_i.exe for multilingual or gwm1sp2e_i.exe for English only), 
then follow the instructions to download the file into a temporary directory.

3 Extract the .exe file into a directory at the root of your local drive or to a network server drive 
that can handle long pathnames.

The compressed files contain directory paths that could exceed DOS limits. 

4 Burn a CD from the directory.

5 Continue with Section 1.4, Installing the Support Pack.

1.4  Installing the Support Pack
Use Windows* to run the Messenger setup.exe program extracted in the preceding section.

1 Click Start > Run > Browse. 

2 Select the setup.exe file on the local or network drive.

or

Select the setup.exe file at the root of the Novell GroupWise Messenger CD.

3 Click OK to run the Messenger Installation program.

4 Follow the on-screen instructions provided in the Messenger Installation program to update 
the software.

5 After applying the Support Pack on NetWare® servers where Messenger agents are running, 
restart the servers to ensure that all updated NLMTM programs are loaded.

This resolves any errors you might see during the update process.

2.0  Defect Fixes

2.1  Installation Fixes
The latest version of LDAP libraries is now installed.(368668) 

2.2  Client Fixes
The client no longer tries to log in if there is no network available.(351309) 

You can now log into the client without receiving a directory access error.(359626) 

When clients are disconnected from the server, their login attempt intervals have been 
randomized so that not all clients are trying to reconnect at the same time.(353101) 

Clients on slow connections wait more than 30 seconds before timing out and failing to 
connect.(353182) 

If you have the client running on one workstation and then log in to Messenger again on 
another workstation, the transition between workstations occurs smoothly.(357762, 367520) 
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If the client disconnects and reconnects while you are typing a message, your typing is not 
interrupted.(367522) 

If you have the client running on one workstation and receive an invitation to a conversation 
while you are away from that workstation (for example, you are driving to work), the 
invitation is rejected when Messenger closes there, so that when you log in on a different 
workstation (for example, when you arrive at work), the invitation can be re-sent to the new 
workstation.(358207) 

You can drag and drop multiple contacts.(346208) 

When you add a contact from a participant in a conversation, the contact is added to the folder 
you select.(345339) 

Users are prevented from accidently clearing their passwords. This is important because 
passwords are required.(347729) 

After deselecting Remember Password, the password is cleared from the registry.(367925) 

If you single-click a contact folder icon to collapse it, then move the mouse (after the mouse 
is released), the dialog box warning that sorting is turned on no longer appears.(345867) 

If you shut down Windows* while Messenger is still running, the window position and any 
Messenger settings you have changed during the current session are saved before Windows 
shuts down.(346609, 358136) 

The Messenger icon that displays in the Windows Alt+Tab menu displays cleanly.(356748) 

The cursor is visible over all Messenger windows.(368967) 

If you press F2 to rename a contact and no contact is selected, it does not cause an 
error.(341627) 

If a user selects Use Windows Color Scheme on the View menu and has not defined a default 
compose font under Tools > Options > Message, the Windows system font color is used by 
default.(344741) 

The Always Accept Invites check box now works as designed.(364618) 

Changing font in a message view now uses the Message Compose font instead of the Contact 
List font.(369124) 

If user View > Window Always on Top, the window is on top on startup. (369125) 

If you use the addContact URL command in your browser and provide no parameters, the Add 
Contact dialog box still opens.(360037) 

If you use the startIM URL command in your browser and provide no parameters, the client 
still starts.(359938, 360040) 

Errors generated from searching an archive that includes sessions from a 32-user conference 
have been eliminated. (364330) 

The client no longer crashes if a user sends a message to himself or herself. (366503) 

In Polish, the Back and Next buttons display correctly.(369350) 

2.3  Administration Fixes
The Query Timeout setting on the LDAP Profile page of the Messenger Service object is 
honored so that searches for contacts terminate after the specified interval.(358226) 
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If you enable SNMP during installation, you can turn it off in ConsoleOne®, rather than using 
the /nosnmp startup switch in the Messaging Agent startup file.(359214) 

2.4  Messaging Agent Fixes
When the Messaging Agent restarts, client users are able to reconnect much more 
quickly.(329351, 346664) 

Performance has been improved when connecting to secure (SSL-enabled) servers.(362442)  

When the Messaging Agent is running on a multiprocessor NetWare server, a large number 
of users can log in simultaneously.(369129) 

The Messaging Agent keeps better track of what LDAP connection slots are available, so that 
users are not denied login when slots are actually available.(342071) 

On a good connection back to a bad server, the default connections are now initialized 
immediately.(363027) 

The Messaging Agent can handle multiple, rapid requests to add contacts, such as when you 
perform a search, select a large number of contacts, then click Add.(346102) 

The Messaging Agent Web console displays users’ login IDs rather than their User object 
names.(338907) 

Timeout events are now handled correctly.(363041) 

The login time is now updated for User objects using the Messaging Agent’s rights.(362527) 

Blank lines in files.txt are now ignored. (366502) 

Pre- and post-processing search errors are reported to client along with status errors. (367405) 

Distinguished names (DNs) are treated as internal by the Messaging Agent. (369376) 

Messaging Agent threads no longer hang when users log out.(369375) 

Mozilla browser speed in accessing the Web console has been improved. (363565) 

The links on the Messaging Agent Web console continue to work when iChain® is also 
running.(100308250) 

Fixed some Messaging Agent abends.(350247, 357682) 

2.5  Archive Agent Fixes
Searches of the archive return all legitimate hits.(359225) 

The Archive Agent Web console displays users’ login IDs rather than their User object 
names.(338907) 

When indexing a conversation, the archive agent now ensures that special characters (such as 
ampersand and quote) and double-byte characters are properly handled so that searches work 
correctly.(365715)  
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3.0  Documentation

3.1  Support Pack Readme Addendum
For information on the latest Support Pack issues, see the Consolidated Support Pack Readme 
Addendum (http://support.novell.com/cgi-bin/search/searchtid.cgi?/10091736.htm).

3.2  Messenger 1.0 Installation Guide
For detailed installation instructions, see the Messenger 1.0 Installation Guide 
(NovellMessengerInstallationGuide.pdf) in the \server\docs\en directory of the Support Pack. The 
latest version is available on the GroupWise ®6.5 Documentation page at the Novell® 
Documentation Web site (http://www.novell.com/documentation). It has been updated to 
correspond with Novell Messenger 1.0 Support Pack 2.

3.3  Messenger 1.0 Administration Guide
For additional Messenger 1.0 documentation, see the Messenger 1.0 Administration Guide on the 
GroupWise 6.5 Documentation page at the Novell Documentation Web site (http://
www.novell.com/documentation). It has been updated to correspond with Novell Messenger 1.0 
Support Pack 2.

3.4  Original Messenger 1.0 Readme Files
For Messenger Readme information, see the following additional Readme files that shipped with 
the original release of Messenger 1.0:

Administrations and Agents: \server\readmeus.txt
Client: \client\win32\readmeen.txt

These Readme files do not contain Support Pack information.

4.0  Documentation Conventions
In this documentation, a greater-than symbol (>) is used to separate actions within a step and items 
in a cross-reference path.

A trademark symbol (®, TM, etc.) denotes a Novell trademark; an asterisk (*) denotes a third-party 
trademark.

5.0  Legal Notices
Novell, Inc. makes no representations or warranties with respect to the contents or use of this 
documentation, and specifically disclaims any express or implied warranties of merchantability or 
fitness for any particular purpose. Further, Novell, Inc. reserves the right to revise this publication 
and to make changes to its content, at any time, without obligation to notify any person or entity 
of such revisions or changes.

Further, Novell, Inc. makes no representations or warranties with respect to any software, and 
specifically disclaims any express or implied warranties of merchantability or fitness for any 
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particular purpose. Further, Novell, Inc. reserves the right to make changes to any and all parts of 
Novell software, at any time, without any obligation to notify any person or entity of such changes.

You may not use, export, or re-export this product in violation of any applicable laws or 
regulations including, without limitation, U.S. export regulations or the laws of the country in 
which you reside.

Copyright © 2004 Novell, Inc. All rights reserved. No part of this publication may be reproduced, 
photocopied, stored on a retrieval system, or transmitted without the express written consent of the 
publisher.

GroupWise, NetWare, and Novell are registered trademarks of Novell, Inc. in the United States 
and other countries.

NLM is a trademark of Novell, Inc.

All third-party trademarks are the property of their respective owners.
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