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About This Guide

This Novell® GroupWise® Migration Utility 2.1 for Microsoft Exchange Installation and 
Migration Guide explains how to install, configure, and run the GroupWise Migration Utility for 
Microsoft Exchange. The guide is divided into the following sections: 

Chapter 1, “Installing the GroupWise Migration Utility 2.1 for Microsoft Exchange,” on page 9
Chapter 2, “Migrating Your Exchange System to GroupWise 6.5,” on page 19
Chapter 3, “Using the GroupWise Import Utility 2.1 for Microsoft Outlook,” on page 35
Appendix A, “Novell eDirectory Attributes Populated from Exchange,” on page 41
Appendix B, “GroupWise Migration Utility 2.1 Error Messages,” on page 43

Additional Documentation

For information about the GroupWise Gateway for Microsoft Exchange, see the GroupWise 
Gateways Documentation Web site (http://www.novell.com/documentation/gwgateways).

For additional GroupWise documentation, see the following guides at the GroupWise 6.5 
Documentation Web site (http://www.novell.com/documentation/gw65):

Installation Guide

Administration Guide

Multi-System Administration Guide 

Interoperability Guide 

Troubleshooting Guides

GroupWise Client User Guides

Documentation Updates

For the most recent version of the GroupWise Migration Utility 2.1 for Microsoft Exchange 
Installation and Migration Guide, visit the GroupWise Gateways Documentation Web site (http:/
/www.novell.com/documentation/gwgateways).

Documentation Conventions

In Novell documentation, a greater-than symbol (>) is used to separate actions within a step and 
items in a cross-reference path.

A trademark symbol (®, TM, etc.) denotes a Novell trademark. An asterisk (*) denotes a third-party 
trademark.

When a single pathname can be written with a backslash for some platforms or a forward slash for 
other platforms, the pathname is presented with a backslash. Users of platforms that require a 
forward slash, such as Linux*, should use forward slashes as required by your software.
About This Guide 7
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When a startup switch can be written with a forward slash for some platforms or a double hyphen 
for other platforms, the startup switch is presented with a forward slash. Users of platforms that 
require a double hyphen, such as Linux, should use double hyphens as required by your software.

User Comments

We want to hear your comments and suggestions about this manual and the other documentation 
included with this product. Please use the User Comment feature at the bottom of each page of the 
online documentation, or go to www.novell.com/documentation/feedback.html and enter your 
comments there.
8   GroupWise Migration Utility 2.1 for Microsoft Exchange Installation and Migration Guide
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1 Installing the GroupWise Migration Utility 2.1 for 
Microsoft Exchange

Your migration from Microsoft Exchange to Novell® GroupWise® 6.5 can go more smoothly if 
you invest time in planning. The tasks below help you meet system requirements, plan your 
migration from start to finish, and install the Migration Utility on one or more servers or 
workstation:

“Meeting Migration Utility System Requirements” on page 9

“Planning Your Migration from Exchange to GroupWise” on page 10

“Installing the Migration Utility” on page 16

Meeting Migration Utility System Requirements
Exchange system requirements:

Microsoft Exchange 5.5 or later system

Outlook* 2002 client with Service Pack 1 or later installed on users’ workstations

GroupWise system requirements:

GroupWise 6.5 system with Support Pack 2 or later on one of the following operating 
systems:

NetWare® 4.2, 5.1, or 6.x with the latest Support Pack installed

SUSE® LINUX Enterprise Server 8 or 9

Red Hat* Enterprise Linux 2.1 or later

Windows* NT* with the latest Service Pack installed

Windows 2000 Server or Windows 2003 Server with the latest Service Pack installed

GroupWise 6.5 client with Support Pack 2 or later installed on users’ workstations

Migration Utility workstation or server requirements:

Windows 2000 or later with the latest Service Pack installed

Outlook 2002 client with Service Pack 1 or later installed

Collaboration Data Objects Component installed with Outlook

GroupWise 6.5 client with Support Pack 2 or later installed

Novell ClientTM 4.90 with Support Pack 2 or later installed
Installing the GroupWise Migration Utility 2.1 for Microsoft Exchange 9
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Planning Your Migration from Exchange to GroupWise
Several aspects of your system must be considered as you plan your migration from Exchange to 
GroupWise:

“Gateway Preparation” on page 10

“Exchange Preparation” on page 10

“GroupWise Preparation” on page 10

“eDirectory Preparation” on page 11

“Migration Scenarios” on page 12

“Time Requirements” on page 14

“Existing eDirectory User Objects” on page 15

“Existing GroupWise Accounts” on page 15

“Exchange Migration Planning Worksheet” on page 17

“Exchange Migration Quick Checklist” on page 18

Print the Planning Worksheet to help you gather the information you need as you perform the 
migration. Use the Quick Checklist to track migration progress.

Gateway Preparation
If you are migrating a large Exchange system, you cannot complete the migration in a single day 
or even in a single weekend. To keep e-mail flowing for users, you can implement the Exchange 
Gateway to connect your existing Exchange system with your new GroupWise system during the 
time while users are being migrated. 

Install and start the Exchange Gateway with directory synchronization and exchange enabled 
before you install and run the Migration Utility. This creates a representation of your Exchange 
system in your GroupWise system. Each Exchange server is represented by a GroupWise external 
post office. The external post offices all belong to an external domain that represents your 
Exchange system.

The Exchange Gateway is available on the Novell Downloads page (http://download.novell.com/
pages/PublicSearch.jsp). Documentation for the Exchange Gateway is available on the GroupWise 
Gateways Documentation Web site (http://www.novell.com/documentation/gwgateways). 

Exchange Preparation
Make sure you know how many Exchange servers are in your Exchange system. You migrate users 
from one Exchange server at a time. You can list your Exchange servers on the “Exchange 
Migration Planning Worksheet” on page 17.

Make sure that you have administrator rights to all Exchange servers.

GroupWise Preparation
You migrate users into one GroupWise post office at a time. The number of Exchange users you 
have determines how many GroupWise post offices you need.
10   GroupWise Migration Utility 2.1 for Microsoft Exchange Installation and Migration Guide
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The maximum size for a GroupWise post office can range from 1000 to 2500 users, taking into 
account the following considerations:

Minimizing the impact if you have a problem with a server.

Avoiding excessive time requirements for performing post office and mailbox maintenance 
activities including backups.

Allowing room to grow while maintaining best performance. 

For more information about planning the size and composition of your GroupWise post offices, 
see “Understanding the Purpose of Post Offices” and “Planning a New Post Office ” in “Post 
Offices” in the GroupWise 6.5 Administration Guide. See also the GroupWise 6.5 Best Practices 
Guide (http://www.novell.com/coolsolutions/gwmag/features/
a_gw65_best_practices_guide_gw.html).

Complete the following GroupWise tasks before starting the migration:

Make a list of which Exchange users you want in each post office. Use the “Exchange 
Migration Planning Worksheet” on page 17.

Create the GroupWise domains and post offices where you want to migrate your Exchange 
users.

Install and start the Message Transfer Agent (MTA) for each domain.

Install and start the Post Office Agent (POA) for each post office.

Decide whether you want to use LDAP authentication in the GroupWise post offices. For 
information about GroupWise authentication and passwords, see “Providing LDAP 
Authentication for GroupWise Users” in “Post Office Agent” in the GroupWise 6.5 
Administration Guide. However, do not change the post office security level from the default 
of low until after you have migrated the Exchange mailboxes into it.

Install and start the Internet Agent for your GroupWise system to facilitate name resolution 
between the GroupWise and Exchange systems.

Complete GroupWise installation and setup instructions are available on the GroupWise 6.5 
Documentation Web site (http://www.novell.com/documentation/gw65/index.html)

You can create the post offices on any supported GroupWise platform (NetWare, Linux, or 
Windows). 
IMPORTANT: If you want to migrate Exchange mailboxes into an existing GroupWise post office where 
existing users log in to GroupWise using LDAP authentication, see “Existing eDirectory User Objects” on 
page 15 for an additional GroupWise preparation step.

Use the “Exchange Migration Planning Worksheet” on page 17 to list the GroupWise post offices 
where you want to migrate Exchange users.

eDirectory Preparation
The Migration Utility can create both eDirectoryTM User objects and GroupWise accounts at the 
same time, or it can add GroupWise accounts to existing User objects. The Migration Utility also 
migrates Exchange distribution lists/groups and creates Distribution List objects for them.
IMPORTANT: If User objects already exist in your system for the users being migrated, see “Existing 
eDirectory User Objects” on page 15 for an additional eDirectory preparation step.

Make sure you know all of the eDirectory contexts where you want to migrate users and create the 
User objects if desired.
Installing the GroupWise Migration Utility 2.1 for Microsoft Exchange 11
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If you are distributing users and distribution lists throughout many eDirectory contexts, you can 
provide the Migration Utility with a simple ASCII text file that lists the users and distribution lists, 
along with their eDirectory contexts. The Migration Utility expects each line to provide two pieces 
of information, separated by a tab:

user_ID             context 
distribution_list   context

You need to create this eDirectory account file before you run the Migration Utility. For easiest 
access, create it in the directory where you install the Migration Utility. Make sure that the contexts 
you list in the file already exist in eDirectory. The Migration Utility does not create new contexts.
IMPORTANT: If User objects already exist in your system, make sure that you provide the correct context for 
those users. If the Migration Utility uses one context for a user and an existing User object resides in a different 
context, duplicate users result.

You can use the “Exchange Migration Planning Worksheet” on page 17 to list users, trees, and 
contexts.

Migration Scenarios
Small System Migration: One Exchange Server to One GroupWise Post Office

Large System Migration: One Exchange Server to Multiple GroupWise Post Offices

Large System Migration: Multiple Exchange Servers to One GroupWise Post Office

Large System Migration: Multiple Exchange Servers to Multiple GroupWise Post Offices

Large System Migration Tips

Small System Migration: One Exchange Server to One GroupWise Post Office

If your Exchange system is small, you can perform the migration as a single migration procedure. 
The Migration Utility can migrate users from one Exchange server into one GroupWise post 
office. 

The migration procedure for a small system entails three Migration Utility sessions: one for 
mailboxes, one for distribution lists/groups, and one for public folders. The mailbox session must 
be completed before you start the distribution list/group session. The distribution list/group session 
must be completed before you start the public folder session.

If you have more than one Exchange server or you want to divide your Exchange users into more 
than one GroupWise post office, you must perform a large system migration.

GroupWise
Post Office

Microsoft  Exchange
Server

Outlook
Client

GroupWise
Client
12   GroupWise Migration Utility 2.1 for Microsoft Exchange Installation and Migration Guide
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Large System Migration: One Exchange Server to Multiple GroupWise Post Offices

You might want to migrate your Exchange users into multiple GroupWise post offices. You need 
a separate Migration Utility session for the users going into each post office.

Large System Migration: Multiple Exchange Servers to One GroupWise Post Office

You might need to migrate users from multiple Exchange servers. You need a separate Migration 
Utility session for the users on each Exchange server.

GroupWise
Post Office 

Microsoft  Exchange
Server

Outlook
Client

GroupWise
Client

GroupWise
Post Office 

GroupWise
Client

GroupWise
Post Office 

GroupWise
Client

GroupWise
Post Office 

Microsoft  Exchange
Server

Outlook
Client

GroupWise
Client

Microsoft  Exchange
Server

Outlook
Client

Microsoft  Exchange
Server

Outlook
Client
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Large System Migration: Multiple Exchange Servers to Multiple GroupWise Post Offices 

You will probably need to migrate users from multiple Exchange servers to multiple GroupWise 
post offices. This can require a substantial number of Migration Utility sessions to cover all the 
pairings of Exchange server and GroupWise post office.

Large System Migration Tips

For a large system migration, you can run Migration Utility sessions simultaneously on multiple 
servers or workstations. Because the Migration Utility is CPU-intensive, you might want to install 
and run each Migration Utility session on a different server or workstation. However, you can run 
multiple sessions on the same server or workstation if sufficient system resources are available.

For a large system migration, you can preconfigure each Migration Utility session before you 
actually start the migration. To accomplish this, you can run the Migration Utility at each location 
up until you would click Start to perform the migration. This creates a control file named 
ExchMig.uct that contains a list of users to be migrated. The control file is created in the Migration 
Utility installation directory. After creating the control file, you can cancel out of the Migration 
Utility, then proceed to the next location and create a control file there. In this way, you can 
preconfigure the entire migration before you ever click Start. You can create a Migration Quick 
Checklist for each session to help you track migration progress.

An advantage to running multiple Migration Utility sessions is that if one session must be stopped, 
it does not halt the entire migration process. When you restart a session, the Migration Utility picks 
up where it left off. It does not need to start over at the top of the list of users to migrate.

Time Requirements
Depending on the number of users and the amount of e-mail that users have accumulated, the 
migration process can require a substantial amount of time. The larger the amount of e-mail, the 
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more servers or workstations you should concurrently run the Migration Utility on, in order to 
speed up the process. Large numbers of recurring appointments are especially high in overhead.

You can also streamline the migration process by choosing not to migrate items older than a 
specified date, sent items, journal items, and deleted items.

Existing eDirectory User Objects
If the users whose mailboxes are being migrated to GroupWise already have eDirectory User 
objects with personal passwords already set, the security level on the post office to which the users 
are being migrated is important. You can check the security setting in ConsoleOne®:

1 Browse to and right-click the Post Office object, then click Properties.

2 Click GroupWise > Security.

If Security Level is set to Low or High, or if eDirectory Authentication is selected, the 
Migration Utility can add GroupWise accounts to existing User objects as they are added to 
the post office. However, if LDAP Authentication is selected, the Migration Utility cannot add 
GroupWise accounts because the Migration Utility cannot perform LDAP authentication.

3 If LDAP Authentication is selected, select a different security option, then click OK to save 
your change.

4 After all Exchanges user have been migrated to the post office, return to ConsoleOne and 
select LDAP Authentication again.

Existing GroupWise Accounts
You cannot use the Migration Utility to migrate data from a mailbox in an Exchange system into 
an existing GroupWise mailbox that has a personalized password that does not match the default 
password used by the Migration Utility. To accomplish this task, the user can use Microsoft 
Outlook to save all data from the Exchange mailbox into a PST file, then use the GroupWise 
Import Utility for Microsoft Outlook to import the Exchange data into the existing GroupWise 
mailbox. For instructions, see Chapter 3, “Using the GroupWise Import Utility 2.1 for Microsoft 
Outlook,” on page 35.
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Installing the Migration Utility
For best performance, you should install the Migration Utility on each Exchange server. However, 
you can install it on another server or workstation if necessary. The server or workstation where 
you install the Migration Utility must already have the GroupWise client and Outlook installed 
because the Migration Utility relies on MAPI as provided by these e-mail clients. The Migration 
Utility updates the MAPI provider, so it must be installed after the clients.

To install the GroupWise Migration Utility:

1 Make sure that you have administrator rights to the Exchange server that you want to migrate.

2 Run setup.exe, then click Next to continue with the installation.

3 Click Yes to accept the license agreement.

4 Click Next to accept the default installation location.

or

Browse to and select the directory where you want to install the Migration Utility, click OK, 
then click Next.

5 Select the Program Folder where you want the Setup program to create the program icon for 
the Migration Utility (typically Novell GroupWise), then click Next. 

6 Click Finish when the installation is complete.

7 Repeat Step 2 through Step 6 for each server or workstation where you want to run the 
Migration Utility.

As an alternative, you could map a drive from other servers and workstations to a central 
installation of the Migration Utility. However, the Migration Utility runs faster when installed 
locally.

8 Continue with “Migrating Your Exchange System to GroupWise 6.5” on page 19.
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Exchange Migration Planning Worksheet
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Exchange Migration Quick Checklist
Mailboxes

From Exchange Server: _______________________________________________

To GroupWise Post Office: ____________________________________________ 

Plan the migration for users on the Exchange server listed above, including Exchange 
Gateway setup if necessary, and creation of User objects and eDirectory contexts as needed. 
You can list users and contexts on the “Exchange Migration Planning Worksheet” on page 17.

See “Planning Your Migration from Exchange to GroupWise” on page 10

Install the Migration Utility on the Exchange server or other machine. For best performance, 
install it on the Exchange server.

See “Installing the Migration Utility” on page 16.

Make sure that the Outlook Collaboration Data Objects module is installed where you 
installed the Migration Utility.

See “Checking for the Outlook Collaboration Data Objects Module” on page 19

Set up administrative access to the Exchange server.

See “Designating a Service Account Administrator on Exchange 5.5” on page 20 or 
“Ensuring Administrative Rights on Exchange 2000/2003” on page 20.

Set up mailbox access in the Exchange system.

See “Setting Up a MAPI Profile” on page 21.

Before your first migration session, configure GroupWise so that users can successfully reply 
to and forward messages after they are migrated.

See “Establishing the GroupWise Internet Domain Name” on page 22

Migrate users from the Exchange server to the GroupWise post office listed above.

See “Migrating Exchange Mailboxes” on page 25.

After your last mailbox migration session, migrate distribution lists/groups and public folders 
in one migration session each.

Distribution Lists/Groups

After migrating all mailboxes:

Use any convenient machine for this Migration Utility session.

Map drives to all locations of the .uct files created during mailbox migrations.

Migrate the Exchange distribution lists/groups into your GroupWise system.

See “Migrating Exchange Distribution Lists/Groups” on page 30.

Public Folders

After migrating all mailboxes and distribution lists/groups:

Use any convenient machine for this Migration Utility session.

Migrate the Exchange public folders into your GroupWise system.

See “Migrating Exchange Public Folders” on page 32.
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2 Migrating Your Exchange System to GroupWise 
6.5

Before you start the migration process, both the Novell® GroupWise® system and the Microsoft 
Exchange system should be running smoothly. Then complete the following tasks to migrate your 
users from Exchange to GroupWise:

“Checking for the Outlook Collaboration Data Objects Module” on page 19

“Designating a Service Account Administrator on Exchange 5.5” on page 20

“Ensuring Administrative Rights on Exchange 2000/2003” on page 20

“Setting Up a MAPI Profile” on page 21

“Establishing the GroupWise Internet Domain Name” on page 22

“Setting Up a Connection between Windows and Linux” on page 23

“Starting the Migration Utility” on page 24

“Using the Migration Utility” on page 25

“Helping Outlook Users Adapt to GroupWise 6.5” on page 34

Checking for the Outlook Collaboration Data Objects Module
Some versions of Outlook install the Collaboration Data Objects (CDO) module by default and 
some do not. The Migration Utility requires that the CDO be installed on the computer where it 
runs. 

1 In the Windows Control Panel, double-click Add/Remove Programs.

2 Select the Microsoft Office entry, then click Change.

3 Click Next, then expand the Microsoft Outlook for Windows entry.
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If a red X appears beside the Collaboration Data Objects item in the list, then the CDO has not 
been installed.

4 If necessary, select Run from My Computer in the drop-down list for Select Collaboration 
Data Objects, then click Update to install the CDO component.

Designating a Service Account Administrator on Exchange 5.5
The Migration Utility needs full access to your Exchange system. Therefore, the user who runs the 
Migration Utility must be set up as a Service Account Administrator in your Exchange system.

1 In Exchange Administrator, select an Exchange Domain object, then click File > Properties.

2 On the Permissions tab, select the user account that you plan to log in as when you run the 
Migration Utility.

IMPORTANT: If you plan to run the Migration Utility from a server or workstation other than the server 
where Exchange is installed, that server or workstation must have a username and password identical to 
the one you select on the Permissions tab. Otherwise, you cannot access the Exchange server with the 
necessary rights.

3 In the Roles field, select Service Account Administrator.

4 Click OK to grant the rights to the selected user.

5 Restart the Information Store service.

5a In the Windows Services window, select Microsoft Exchange Information Store.

5b Click Actions > Restart.

Ensuring Administrative Rights on Exchange 2000/2003
The Migration Utility needs full access to your Exchange system. Therefore, the user who runs the 
Migration Utility must be set up with sufficient rights in your Exchange system.

1 In Exchange System Manager, right-click an Exchange Server object, then click Properties.

2 On the Security tab, select the user account that you plan to log in as when you run the 
Migration Utility.
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IMPORTANT: If you plan to run the Migration Utility from a server or workstation other than the server 
where Exchange is installed, that server or workstation must have a username and password identical to 
the one you select on the Permissions tab. Otherwise, you cannot access the Exchange server with the 
necessary rights.

3 Make sure that all the check boxes in the Allow column are selected, then click OK.

Setting Up a MAPI Profile
Setting up a MAPI profile provides login information so the Migration Utility can access a specific 
Exchange server. You need to create a MAPI profile for each Exchange server in your system so 
that the Migration Utility can access it.

1 In the Windows Control Panel, double-click Mail, click Show Profiles, then click Add.

2 Provide a name for the new profile, then click OK.

3 Select Add a New E-Mail Account, then click Next.

4 Select Microsoft Exchange Server, then click Next.

5 Provide login information for the Exchange server:

5a Specify the name of the Exchange server from which you are migrating users.

5b Specify a mailbox name on that server.

You can use your mailbox name, your username, or someone else’s as long as the 
mailbox resides on that Exchange server.
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5c Click Check Name to make sure that the login information is accurate.

If the name check fails, the Migration Utility cannot access your Exchange system.

5d Click Next.

6 Click Finish.

The new profile now appears in the profile list.

7 Select Prompt for a Profile To Be Used, then click OK.

8 Repeat Step 1 through Step 7 for each Exchange server in your system.

Establishing the GroupWise Internet Domain Name
If you want users to be able to reply to and forward messages after they have been migrated to the 
GroupWise system, you must use the same Internet domain name for the GroupWise system as 
you use for your Exchange system.

1 Make sure that the Internet Agent is installed and running in your GroupWise system.

2 In ConsoleOne®, log in to the eDirectoryTM tree where you want the Migration Utility to create 
User objects for the Exchange users. Make sure you have sufficient rights to create User 
objects in the contexts where you want the Migration Utility to create them.

3 Click Tools > GroupWise System Operations > Internet Addressing.

4 To add an Internet domain name that matches the one for your Exchange system, click Create 
in the Internet Domain Names box.

5 Type the domain name, then click OK twice to save the new domain name.

The Migration Utility always uses the userID@Internet_domain format for addresses that are 
migrated from Exchange to GroupWise.

6 Make sure that the Internet Agent is running in your GroupWise system.
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Setting Up a Connection between Windows and Linux
If you are migrating from Exchange to GroupWise on Linux, you must create the proper 
connection between the Exchange server and a Linux server where a GroupWise domain directory 
is located before you start the Migration Utility. Linux provides a configuration called a Samba 
share that allows a Linux file system to appear like a Windows disk drive from the point of view 
of your Exchange server.

“Configuring the Samba Share for Your GroupWise Domain Location” on page 23

“Testing the Samba Share Access from Windows” on page 24

Configuring the Samba Share for Your GroupWise Domain Location
Windows workstations use the Server Message Block (SMB) and NetBIOS protocols for sharing 
drives. By configuring your Linux server to support these protocols, your Windows workstation 
can access your Linux server as if it is a shared drive.

1 On the Linux server, add the user that you plan to log in as when you run the Migration Utility.

You set up this user on the Windows side in “Designating a Service Account Administrator 
on Exchange 5.5” on page 20 or “Ensuring Administrative Rights on Exchange 2000/2003” 
on page 20. Now you are setting up the user on the Linux side. Use the same username on 
Linux as you used on Windows. The steps below provide an example.

1a In a terminal window, log in as root.

1b Enter the following command to create the user:

useradd -mg root username

1c Enter the following command to assign a password to the user:

passwd username

Use the same password on Linux as you used on Windows.

1d Enter the password, then enter it again for verification.

2 Add the user and password to the list of users that can authenticate to the Samba server, for 
example:

2a Enter the following command:

smbpasswd -a username

2b Enter the password, then enter it again for verification.

3 Start the Samba server, for example:

3a Change to the /etc/rc.d directory.

3b Start the NetBIOS daemon:

./nmb start

3c Start the Samba daemon:

./smb start

If a message notifies you that the daemon is already running, stop and then start it to pick 
up the new username and password information.
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Testing the Samba Share Access from Windows
After you have configured the Samba share on the Linux server, you should test it on the Windows 
workstation or server where you plan to run the Migration Utility.

1 Map a drive to the Linux server, for example:

1a Right-click My Network Places, then click Map Network Drive.
IMPORTANT: Do not use Novell Map Network Drive. The Samba share is set up to work with 
Windows, not with the Novell ClientTM.

1b Select a drive letter.

1c In the Folder field, specify the IP address of the Linux server and the Linux username you 
created in Step 1b in “Configuring the Samba Share for Your GroupWise Domain 
Location” on page 23, for example:

\\172.16.5.18\gwmigrate

1d Click Finish.

1e When prompted, provide the username and password established in Step 1b and Step 1c 
in “Configuring the Samba Share for Your GroupWise Domain Location” on page 23.

This shows that the Samba share is working correctly from the Windows operating system 
level.

2 Start ConsoleOne and authenticate to the eDirectory tree where your GroupWise system is 
located.

3 Connect to the GroupWise domain on the Linux server.

3a Click Tools > GroupWise System Operations > Select Domain. 

3b Browse to and select the domain database (wpdomain.db) on the Linux server, then click 
Open.

3c Click OK to connect to the domain.

If you connect to the domain successfully, then the Migration Utility can successfully migrate 
users from your Exchange system to GroupWise on Linux. If you cannot connect to the domain 
successfully, the migration from Exchange to GroupWise on Linux cannot succeed. Some Linux 
Samba servers require more stringent authentication than others. You can find assistance with 
setting up the connection between Windows and your Linux server from the following resources:

The Official Samba-3 HOWTO and Reference Guide (http://www.comp.hkbu.edu.hk/docs/s/
samba30/htmldocs/howto)

GroupWise Support Forum (http://support.novell.com/forums/2gw.html)

The connection must be set up correctly before you start the migration process.

Starting the Migration Utility
1 Make sure that you have administrator rights to the Exchange server that you want to migrate, 

as described in “Designating a Service Account Administrator on Exchange 5.5” on page 20 
or “Ensuring Administrative Rights on Exchange 2000/2003” on page 20, depending on the 
version of your Exchange system.

2 Log in to the eDirectory tree where you are migrating the Exchange users.
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IMPORTANT: Make sure that you have sufficient rights to create User objects in the contexts you have 
planned.

3 Map a drive to a GroupWise domain directory.

If the domain is located on Linux, you can use a Samba share as described in “Setting Up a 
Connection between Windows and Linux” on page 23. 

4 Click Start > Programs > GroupWise > GroupWise Migration Utility for Microsoft Exchange.

or

Double-click the Migration Utility icon created by the Installation program on y our desktop.

5 Continue with “Using the Migration Utility” on page 25.

Using the Migration Utility
The migration process for your Exchange system is performed in three phases. First, you migrate 
all Exchange mailboxes. Second, you migrate Exchange distribution lists/groups. Third, you 
migrate Exchange public folders.

“Migrating Exchange Mailboxes” on page 25

“Migrating Exchange Distribution Lists/Groups” on page 30

“Migrating Exchange Public Folders” on page 32

Migrating Exchange Mailboxes
1 If you are running the GroupWise Gateway for Microsoft Exchange:

1a In ConsoleOne, disable directory synchronization and exchange on the Optional Gateway 
Settings page of the Exchange Gateway object.

1b For the users to be migrated, delete the External User objects from the external post office 
in the external domain that represents your Exchange system in your GroupWise system.

The External User objects must be deleted because they interfere with the creation of new 
User objects with the same names in the GroupWise system. 

2 Follow the instructions in “Starting the Migration Utility” on page 24, then return to Step 3 
below.

3 Select Mailboxes, then click Next.
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4 Fill in the following fields:

Exchange MAPI Profile: Select the Exchange administrator profile you created in “Setting 
Up a MAPI Profile” on page 21. Click Create if you have not set up the MAPI profile.

GroupWise Domain: Browse to and select the domain directory where the GroupWise 
domain database (wpdomain.db) resides.

GroupWise Post Office: Select the post office where you want to migrate the Exchange 
users. The list offers those post offices that belong to the domain selected above.

Default eDirectory Context: Browse to and select the eDirectory context for User objects. 

If you have already created the User objects in eDirectory, then the Migration Utility adds 
GroupWise accounts to the User objects, if the existing User object names match the 
Exchange account names. If you have not yet created the User objects, then the Migration 
Utility creates both the User objects and the GroupWise accounts in the context you specify.

eDirectory Account File: If you want to create the User objects in multiple eDirectory 
contexts, browse to and select the eDirectory account file, as described in “eDirectory 
Preparation” on page 11.

Any Exchange users not found in the eDirectory account file are placed in the location 
specified in the Default eDirectory Context field.

Create GroupWise External Entities for New Accounts: If you select this option, the 
Migration Utility creates External Entity objects instead of User objects for your Exchange 
users. External entities can be given GroupWise accounts but are not considered eDirectory 
users for licensing purposes.

5 Click Next to list the users on the Exchange server.
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Users marked with <new> do not exist in the post office into which you are migrating users. 
If a user is marked with <exist>, then a GroupWise account for that user ID already exists. 
This is not a problem if both mailboxes belong to the same user; the contents of the Exchange 
mailbox are merged into the contents of the existing GroupWise mailbox. However, if the 
Exchange user ID is already in use in GroupWise by a different user, you must migrate the 
user into a different post office or give the user a new user ID in Exchange and then perform 
the migration.

6 Select the users you want to migrate into the post office, then click Next.

7 Select migration options:

Root Folder Name: Specify the name of the folder in GroupWise that will hold the migrated 
contents of users’ Outlook mailboxes. The default folder name is Exchange.

Default Password: Provide a default password for all GroupWise mailboxes. Make sure you 
notify your users what their password is and remind them to change it so that users cannot 
access each others’ mailboxes.

If the Migration Utility is creating both eDirectory User objects and GroupWise accounts, the 
default password is used for both eDirectory and GroupWise. If eDirectory User objects 
already exist and already have passwords, the existing eDirectory passwords are retained on 
the User objects and the default password is used for the GroupWise mailboxes. For 
information about GroupWise passwords, see “Mailbox Passwords” in “Security” in the 
GroupWise 6.5 Administration Guide.
Migrating Your Exchange System to GroupWise 6.5 27



    Novell Confidential                                                                                            Manual (ENU)  21 December 2004
If LDAP authentication is enabled on the POA for the post office, the POA validates users’ 
eDirectory passwords against passwords stored in the LDAP directory, not against passwords 
stored in users’ GroupWise databases. The POA can authenticate GroupWise users against 
any network directory that supports LDAP. For information about LDAP authentication, see 
“Providing LDAP Authentication for GroupWise Users” in “Post Office Agent” in the 
GroupWise 6.5 Administration Guide.

Mailbox Items: Select All Items, or select Exclude Messages Before and specify a date. 
Messages dated on or after the specified date are migrated to GroupWise. Messages dated 
before the specified date are not migrated to GroupWise.

Migrate Deleted Items: Select this option if you want to migrate deleted items into your 
GroupWise mailbox.

Migrate Sent Items: Select this option if you want to migrate sent items into your GroupWise 
mailbox.

Migrate Journal: Select this option to migrate journal items.

The fewer items you migrate, the faster the migration proceeds. If you choose to migrate 
deleted, sent, or journal items, all such items are migrated, regardless of date.

Migrate Inbox into Primary GroupWise Mailbox: Select this option to have the contents 
of users’ current Outlook Inbox folder automatically appear in the main GroupWise Mailbox 
folder, rather than in the Inbox folder under the root folder specified above. 

Migrate Drafts into GroupWise Work in Progress: Select this option to have the contents 
of users’ current Outlook Drafts folder automatically appear in the GroupWise Work in 
Progress folder, rather than in the Drafts folder under the root folder specified above.

All other Outlook mailbox contents appear in folders under the root folder specified above.

At this point, the Migration Utility has created and saved an ExchMig.uct file that contains 
the user information that you have specified for this migration session, thus recording where 
each mailbox will be migrated. This control file is created in the Migration Utility installation 
directory and can be viewed in a text editor such as Notepad.

If you are performing a large system migration, you might want to cancel the Migration Utility 
at this point, start the Migration Utility at the next location where you want to run it, then 
repeat Step 3 through Step 7 for that migration session. In this manner, you can preconfigure 
in advance all the servers and workstation that are participating in the migration process. 
When you are ready to actually perform the migration, go to each location, run through the 
Migration Utility, and accept the preconfigured information provided by the ExchMig.uct file, 
then:

8 Click Next, then click Start to start the migration.

The Migration Utility log file displays at the end of the migration process. Use the Level drop-
down list (Error, Warning, Verbose, Diagnostic) to control how much information is 
displayed. If a message extends beyond the viewing window, click it to display the full 
message text.

The Migration Utility log file is named migrate.log and is located in the Migration Utility 
installation directory. To start a new log file, click Clear Log in the Migration Log dialog box. 
This saves the existing log file as migrate.001. The extension increments each time you start 
a new log file.

9 Click Finish when the user migration is complete.

10 If you are running the Exchange Gateway:
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The Migration Utility creates a gateway.csv file that enables you to update migrated users’ 
auto-forwarding information for Exchange 5.5. The gateway.csv file is a simple comma-
separated values file that updates each Exchange user’s mailbox with the appropriate 
forwarding address.

Later versions of Exchange require manual update.

10a For Exchange 5.5, import the gateway.csv file into your Exchange system using 
Exchange Administrator. Click Tools > Directory Import. Specify the gateway domain, 
server, and container (Recipients/GroupWise). Select the gateway.csv file, then click 
Import.

or

For Exchange 2000/2003, manually update migrated users’ auto-forwarding information 
using Active Directory* Users and Computers. Double-click each Exchange user, then 
select Delivery Options. Select the newly migrated GroupWise user as the Alternate 
Recipient.

10b In ConsoleOne, enable directory synchronization and exchange on the Optional Gateway 
Settings page of the Exchange Gateway object.

10c Delete the gateway status correlation database (gwcorr.db) in the gateway installation 
directory, then delete any files in the Exchange Gateway’s ds and dx subdirectories.

This cleanup assures a clean synchronization between systems.

10d Stop and then start the Exchange Gateway, which causes an immediate directory 
synchronization and exchange.

This directory synchronization and exchange notifies your Exchange system about the 
new GroupWise users that have just been migrated into the GroupWise system.

10e In ConsoleOne, disable directory synchronization and exchange on the Optional Gateway 
Settings page of the Exchange Gateway object.

10f Delete the migrated users’ External User objects to prevent duplicate entries in the 
GroupWise Address Book.

11 Repeat Step 1 through Step 10 until you have migrated all of your Exchange users.

The more sessions of the Migration Utility you run concurrently, the faster the process moves 
along. For best performance, run each session on a different server or workstation, as 
described in “Installing the Migration Utility” on page 16.

If you want to run multiple sessions on the same server or workstation, you must set up unique 
locations for .uct files. To accomplish this, create a Migration Utility icon on your desktop. 
Edit its properties, and in the Target field, add path to the directory where you want that 
session of the Migration Utility to create its .uct file. For example you could create three 
control file directories (c:\mig1, c:\mig2, and c:\mig3) and create three desktop icons with the 
following target lines:

“c:\Program Files\ 
            Novell\GroupWise Migration Utility for Microsoft Exchange\exchldr.exe” c:\mig1 
“c:\Program Files\ 
            Novell\GroupWise Migration Utility for Microsoft Exchange\exchldr.exe” c:\mig2 
“c:\Program Files\ 
           Novell\GroupWise Migration Utility for Microsoft Exchange\exchldr.exe” c:\mig3

Start each session using its customized desktop icon, then let them run concurrently.

When you have migrated all of your Exchange users to GroupWise, you are ready to migrate 
Exchange distribution lists/groups. Distribution lists/groups can be migrated in one session per 
GroupWise post office.
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Migrating Exchange Distribution Lists/Groups
Exchange 5.5 distribution lists and Exchange 2000/2003 groups are parallel to GroupWise 
distribution lists, both of which are publicly available groups of users created by an administrator. 
All mailboxes must be migrated before you migrate distribution lists/groups because users must 
be added to distribution lists/groups based on their new GroupWise locations, not on their old 
Exchange locations. Although it probably required multiple session to migrate mailboxes, 
migration of all distribution lists/groups can be accomplished in just one session unless you want 
to spread your distribution lists/groups across multiple post offices.

1 Map a drive to each server or workstation where you ran the Migration Utility to migrate 
users.

In order to migrate distribution lists/groups, the Migration Utility needs access to all of the 
.uct files that were created during mailbox migration.

2 Follow the instructions in “Starting the Migration Utility” on page 24.

3 In the main Migration Utility dialog box, select Distribution Lists/Groups, then click Next.

4 Fill in the following fields:

Exchange MAPI Profile: Select the Exchange administrator profile you created in “Setting 
Up a MAPI Profile” on page 21. Click Create if you have not set up the MAPI profile.

GroupWise Domain: Browse to and select the domain directory where the GroupWise 
domain database (wpdomain.db) resides.

GroupWise Post Office: Select the post office where you want to migrate the distribution 
lists/group.

Default eDirectory Context: Browse to and select the eDirectory context for Distribution 
List objects. 

eDirectory Account File: If you want to create the Distribution List objects in multiple 
eDirectory contexts, browse to and select the eDirectory account file, as described in 
“eDirectory Preparation” on page 11.

5 Click Next to list all distribution lists/groups in your Exchange system.
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Distribution lists/groups marked with <new> do not exist in the post office into which you are 
migrating them. If a distribution list/group is marked with <exist>, then a GroupWise 
distribution list by that name already exists. This is not a problem if you want to merge the 
contents of the Exchange distribution list/group into the contents of the existing GroupWise 
distribution list. If you do not want this to happen, then rename one of the distribution lists so 
that the names are unique. 

6 Select the distribution lists you want to migrate, then click Next to provide the required 
information about the Exchange users you have moved to GroupWise.

7 Click Add, then browse to and select the .uct file created during each user migration session.
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8 Repeat Step 7 for each .uct file you created while migrating mailboxes.

9 When your list of the .uct files is complete, click Next, then click Start to perform the 
distribution list migration.

10 Click Finish when the distribution list migration is complete.

Distribution lists that are nested within distribution lists are not migrated. Therefore, you must 
manually put nested distribution lists back where they belong.

11 If you had nested distribution lists/groups in your Exchange system, use ConsoleOne to set 
them up in your GroupWise system the way they were in your Exchange system.

See “Adding Members to a Distribution List” in “Distribution Lists, Groups, and 
Organizational Roles” in the GroupWise 6.5 Administration Guide.

12 If you are migrating your Exchange distribution lists into multiple GroupWise post offices, 
repeat Step 2 through Step 11 for each post office.

When you have migrated all of your Exchange distribution lists to GroupWise, you are ready to 
migrate public folders. Public folders can be migrated in one session.

Migrating Exchange Public Folders
Exchange public folders are similar to GroupWise shared folders. Exchange provides a public 
location for public folders, but when you migrate them to GroupWise, the public folders are owned 
by a GroupWise resource. The Migration Utility automatically sets up shared folder access as 
similar as possible to the public folders in the Exchange system.

“Preparing Your GroupWise System to Receive the Public Folders” on page 32

“Migrating the Public Folders” on page 33
IMPORTANT: Migrate public folders only once. If you repeat the public folder migration session, duplicate 
shared folders are created.

Preparing Your GroupWise System to Receive the Public Folders

Public folders are migrated to a GroupWise resource. You might find it convenient to own that 
resource yourself or you can choose a different owner.

1 In ConsoleOne, create a new resource to own the public folders.

1a Browse to and right-click the container object where you want to create the Resource 
object, then click New > Resource.

1b Fill in the fields:

Resource Name: Specify a name for the resource, for example, PublicFolders.

GroupWise Post Office: Browse to and select the post office that you want the resource 
to belong to.
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The user that you want to own the resource must belong to the same post office.

Owner: Browse to and select the user that you want to own the resource.

The owner of the public folders resource controls which users the folders are shared with 
and what rights each user has to the folders. Initially, the rights match the original public 
shared folders, except that GroupWise does not include the concept of granting rights to 
all users. In GroupWise, rights are granted on a user by user basis.

1c Click OK to create the new resource.

2 Set the post office security level to Low.

2a Browse to and right-click the Post Office object that owns the new resource you just 
created, then click Properties.

2b Click GroupWise > Security.

2c Select Low, then click OK.

3 Continue with “Migrating the Public Folders” on page 33.

Migrating the Public Folders

1 Follow the instructions in “Starting the Migration Utility” on page 24.

2 In the main Migration utility dialog box, select Public Folders, then click Next.

3 Fill in the following fields:

Exchange MAPI Profile: Select the Exchange administrator profile you created in “Setting 
Up a MAPI Profile” on page 21. Click Create if you have not set up the MAPI profile.

GroupWise Domain: Browse to and select the domain directory where the GroupWise 
domain database (wpdomain.db) resides.

GroupWise Post Office: Select the post office where you want to migrate the Exchange 
public folders.

GroupWise Owner (User ID and Password): Provide the name of the resource, created in 
Step 1 in “Preparing Your GroupWise System to Receive the Public Folders” on page 32, that 
you want to own the GroupWise shared folders that correspond to the Exchange public 
folders. 
IMPORTANT: Resources do not have passwords, so leave the Password field empty.

4 Click Next, then click Start to perform the public folder migration.
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5 Click Finish when the public folder migration is complete.

You have now finished your part in the migration from Exchange to GroupWise, but your users 
still have some work to do. As an administrator, you can help users adapt to GroupWise.

Helping Outlook Users Adapt to GroupWise 6.5
You can distribute the GroupWise client to your users’ desktops in a variety of ways, as described 
in “Distributing the GroupWise Client” in “Client” in the GroupWise 6.5 Administration Guide.

You should also distribute the GroupWise Import Utility for Microsoft Outlook to your users so 
that they can import their Outlook PST files into their GroupWise mailboxes. Depending on the 
needs of your users, you could provide a network installation of the Import Utility that users could 
run, you could e-mail the Import Utility to users so they can install it on their own workstations, 
or you could provide them with the URL for the Novell Downloads page (http://
download.novell.com/pages/PublicSearch.jsp) where they can download the Import Utility for 
themselves.

Also, let users of public folders know that they will receive notifications that they must accept in 
order to continue participating in the corresponding GroupWise shared folders.

To help users adjust to GroupWise, make sure that they have access to the GroupWise Import 
Utility for Microsoft Outlook Quick Start (ImportUtilityQuickStart.pdf). It is available in the 
installation directories of both the Migration Utility and the Import Utility. You might want to print 
copies for your users to help them get comfortable in their GroupWise mailboxes as quickly as 
possible. For your convenience, the same information is presented in Chapter 3, “Using the 
GroupWise Import Utility 2.1 for Microsoft Outlook,” on page 35 in this guide.
34   GroupWise Migration Utility 2.1 for Microsoft Exchange Installation and Migration Guide

http://download.novell.com/pages/PublicSearch.jsp


    Novell Confidential                                                                                            Manual (ENU)  21 December 2004
3 Using the GroupWise Import Utility 2.1 for 
Microsoft Outlook

As soon as your system administrator has migrated your e-mail system from Microsoft Exchange 
to Novell® GroupWise® 6.5, you can use the GroupWise Import Utility 2.1for Microsoft Outlook 
to import personal information from Outlook PST (Personal Folder Storage) files on your 
workstation into your GroupWise mailbox or archive. The following tasks help you install and run 
the GroupWise Import Utility, explain some of the differences you might notice between 
GroupWise and Outlook, and lead you to additional information about using GroupWise as your 
e-mail and collaboration tool.

“Meeting Import Utility System Requirements” on page 35

“Installing the GroupWise Windows Client” on page 35

“Installing the GroupWise Import Utility for Microsoft Outlook” on page 36

“Accessing Your GroupWise Mailbox” on page 36

“Importing Outlook PST Files into GroupWise” on page 37

“Getting Acquainted with GroupWise” on page 38

“Adapting to Differences between GroupWise and Outlook” on page 39

Meeting Import Utility System Requirements
The workstation where you want to run the GroupWise Import Utility must have the following 
versions of both e-mail clients installed:

Microsoft Outlook 2002 client with Service Pack 1 or later

GroupWise 6.5 Windows client with Support Pack 2 or later

Installing the GroupWise Windows Client
After your system administrator has migrated your Exchange system to GroupWise, you can begin 
using the GroupWise Windows client. Refer to the GroupWise 6.5 Quick Start (http://
www.novell.com/documentation/gw65/pdfdoc/gw65_qs/gw65_qs.pdf).

If you want to use the GroupWise 6.5 Cross-Platform client on Linux or Macintosh* rather than 
the GroupWise Windows client, you can do so after using the Windows client to import your PST 
files.
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Installing the GroupWise Import Utility for Microsoft Outlook
When you first start the GroupWise client, your mailbox contains all the items that were migrated 
from your Outlook mailbox on the Exchange server into your GroupWise mailbox. It does not 
contain items that you have saved elsewhere in Outlook PST files. The GroupWise Import Utility 
helps you complete the migration process by bringing your personal information into your 
GroupWise mailbox or archive.

To install the GroupWise Import Utility:

1 Obtain the utility from one of the following sources:

Your system administrator might provide the utility for you.

You can download the utility from the Novell Downloads page (http://
download.novell.com/pages/PublicSearch.jsp).

2 Save the setup.exe file for the GroupWise Import Utility to a convenient location.

3 Make sure you are not running the Windows GroupWise client while you install the Import 
Utility.

4 Run setup.exe, then click Next to begin the installation.

5 Click Yes to accept the license agreement.

6 Click Next to accept the default installation location.

or

Browse to and select the directory where you want to install the Import Utility, click OK, then 
click Next.

7 Click Finish after the program files have been installed.

Accessing Your GroupWise Mailbox
When your system administrator migrated your mailbox to GroupWise, a default password was 
set for you. You cannot start GroupWise without this password. If you have not yet received your 
GroupWise password, contact your system administrator. 

Be aware that your system administrator might have chosen not to migrate any items older than a 
certain date, sent items, journal entries, and deleted items from your Outlook mailbox.

1 Start the GroupWise Windows client.

You can see that the GroupWise Migration Utility run by your system administrator has 
created a new folder with subfolders for various types of items from your Outlook mailbox. 
By default, the new folder is called Exchange, but your system administrator might have 
chosen a different name.

You can leave migrated items in the Exchange folder or move them into folders in your 
GroupWise Cabinet as needed. The GroupWise Find feature helps you locate what you need 
in either case. Migrated items in the Exchange folder can be replied to and forwarded just like 
native GroupWise items, provided that your e-mail address is of the format 
userID@internet_domain_name. 

Your system administrator might have chosen to migrate items from your Outlook Inbox 
folder into your main GroupWise Mailbox folder and items from your Outlook Drafts folder 
into your GroupWise Work in Progress folder. If so, these migrated items are not found under 
the Exchange folder.
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2 To replace the default GroupWise password provided by your system administrator with your 
own mailbox password, click Tools > Options > Security > Password.

Changing your password prevents other users from accessing your mailbox.

By default, the GroupWise client starts in Online mode, which means that the client interacts 
actively with the Post Office Agent for your post office. In Online mode, if the Post Office 
Agent server goes down, you can no longer access your GroupWise mailbox. As an 
alternative, you can use Caching mode, where a copy of your Online mailbox is created on 
your local workstation. In Caching mode, if the Post Office Agent server goes down, you can 
still access your mailbox. Messages you want to send are saved until the client can contact the 
Post Office Agent again.

3 If you want to use Caching mode:

3a Click File > Mode > Caching.

3b Specify the directory where you want to create your Caching mailbox, then click OK.

The GroupWise client restarts whenever you switch between Online mode and Caching 
mode.

By default, the GroupWise client retains all messages in your Online mailbox indefinitely. 
Over time, your mailbox can grow very large. Your system administrator might choose to 
restrict the size of your mailbox. If you want to clean up your mailbox on a regular schedule, 
you can configure GroupWise to archive items after a specified amount of time is passed.

4 If you want to set up an archive:

4a Click Tools > Options > Environment > File Location.

4b In the Archive Directory field, specify the location where you want your archive, then 
click OK.

4c To control archiving, click Tools > Options > Environment > Cleanup.

If you want to access your GroupWise mailbox through a modem connection, perhaps from 
your laptop, you can create a Remote mailbox that provides a copy of all or only part of your 
Online mailbox and includes the information necessary to establish the connection to the 
network.

5 If you want to create a Remote mailbox:

5a Click Tools > Hit the Road.

5b Provide your GroupWise password, then click OK.

The Hit the Road wizard then guides you through the rest of the setup process.

Importing Outlook PST Files into GroupWise
When you use the Import Utility, your PST file is imported into whichever version of your mailbox 
your currently accessing. If you run the utility with the GroupWise client in Online mode, the PST 
file is imported into your Online mailbox. If you run the utility when you are accessing your 
GroupWise archive, the PST file is imported into your archive.

1 If you want to import a PST file into a location other than your current one, select the location 
from the drop-down list above the Folder List (Online, Caching, Remote, or Archive).

2 Click File > Import PST.
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3 In the New Root Folder field, provide the name of a new folder into which you want to import 
the contents of the PST file.

The new folder is created at the highest level of your GroupWise folder list in your mailbox 
or archive. 

4 In the PST File field, browse to and select a PST file.

5 Click OK to start the import.

You can watch as the folder and its subfolders are created in your GroupWise mailbox or 
archive. You can leave the folder in its default location or move it to a location of your choice. 
Items from the PST file folder can be moved into other folders as needed.

6 Repeat Step 1 through Step 5 for each PST file you want to import.

If you want to import an Outlook Personal Address Book into GroupWise, you can place it in an 
Outlook PST file and then import it using the steps above.

Getting Acquainted with GroupWise
GroupWise is a cross-platform, corporate e-mail system that provides secure messaging, 
calendaring, scheduling, and instant messaging. GroupWise also includes task management, 
contact management, document management, and other productivity tools. GroupWise can be 
used on your desktop at work, in a Web browser anywhere you have an Internet connection, and 
even on wireless devices. 

Thanks to the Migration Utility that was run by your system administrator, the following tasks 
have already been done for you:

Your GroupWise mailbox already contains all of the items that you had in your Outlook 
mailbox (unless your system administrator restricted the migration).

Your Exchange distribution lists have been converted to GroupWise personal groups.

All Exchange public folders have been converted into GroupWise shared folders. For each 
Exchange public folder where you had access, you should receive a notification that a 
corresponding GroupWise folder has been shared with you. 

Your Exchange Contacts folder has been converted into a GroupWise address book and is 
displayed in the GroupWise Contacts folder.

And now the Import Utility has imported your personal items from Outlook into your GroupWise 
mailbox.

As you learn to use GroupWise, refer to the following sources:

Click Help > Help Topics for assistance with common tasks that you need to learn how to do 
in GroupWise.

Click Help > User Guide to display the GroupWise Windows Client User Guide in HTML 
format. The same guide is available in PDF format for printing on the GroupWise 6.5 
Documentation Web site (http://www.novell.com/documentation/gw65). You might want to 
print the “Getting Started” section as a quick reference for the GroupWise client.

Click Help > Cool Solutions Web Community to join with other GroupWise users in learning 
the latest tips and tricks.

Visit the GroupWise Support Forum (http://support.novell.com/forums/2gw.html) to get 
answers to your GroupWise questions from helpful GroupWise experts.
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Visit BrainStorm, Inc. (http://www.brainstorminc.com/vendors/default.asp), a Novell 
Authorized Global End-User Training Partner, to check into GroupWise quick start cards, 
reference books, guides, training workbooks, and Web-based training.

Adapting to Differences between GroupWise and Outlook
As you become familiar with GroupWise, you will find that you can perform most of your typical 
e-mail tasks with ease. However, there are a few areas of functionality where GroupWise is 
substantially different from Exchange:

GroupWise does not have a feature like the Outlook Journal feature. The Migration Utility run 
by your system administrator created a Journal folder in your mailbox where existing journal 
entries are stored as a reference.

Recurring items are stored in GroupWise as multiple, individual items, rather than as a single 
recurring item. This enables you to modify one or more of the recurring items individually, 
but does produce a large number of seemingly duplicate items. This is working as designed in 
GroupWise.

GroupWise stores all contacts in a single address book that is linked to your Contacts folder, 
rather than storing contacts in multiple folders in your mailbox.

GroupWise displays all appointments in the Calendar folder. If you had multiple Calendars in 
Outlook, all appointments are combined together in the GroupWise Calendar. However, you 
can display any GroupWise folder as a Calendar, so you can still view your separate Calendars 
in GroupWise.

GroupWise allows you to store all types of items (messages, appointments, reminder notes, 
and so on) together in the same folder rather than having folders dedicated to specific item 
types.
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A Novell eDirectory Attributes Populated from 
Exchange

During migration from Microsoft Exchange to Novell® GroupWise®, the Migration Utility 
automatically populates the following eDirectoryTM attributes on User objects with information 
from the Exchange system when the GroupWise account is created:

eDirectory Attribute Description

assistant Assistant

assistantPhone Assistant’s phone number

company Company

country Country

homePhone Home phone number

L City

mobile Mobile phone number

otherPhoneNumber Business phone number

pager Pager phone number

Physical Delivery Office Name City

Postal Code ZIP code

S State

SA Street address
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B GroupWise Migration Utility 2.1 Error Messages

The Novell® GroupWise® Migration Utility 2.1 for Microsoft Exchange might generate the 
messages in the “Error Message List” on page 43. Error messages display while the Migration 
Utility runs and are written to the migrate.log file located in the Migration Utility installation 
directory.

Error Message List
Error EID 0200 -- Could not open Exchange private store
Error EID: 0202 -- Could not open Exchange mailbox table
Error EID: 0205 -- Could not log onto Exchange server through MAPI
Error EID: 0208 -- Could not log onto mailbox
Error EID: 0232 -- User not created
Error EID: 0247 -- Could not open GroupWise MAPI store provider for specified user
Error EID: 0258 -- Could not attach to eDirectory context

Error EID 0200 -- Could not open Exchange private store

Source: GroupWise Migration Utility for Microsoft Exchange

Explanation: The Migration Utility could not access the mailbox store on the Exchange server. This error might 
be accompanied by the additional error, “Properties for this information service must be defined 
prior to use.”

Possible Cause: Outlook has been installed on the Windows machine where you want to run the Migration Utility 
but you have not yet run Outlook. Outlook must be run at least once in order for its MAPI providers 
to be available for use by the Migration Utility.

Action: Run Outlook before running the Migration Utility.

Possible Cause: Outlook is not properly configured to communicate with the Exchange server.

Action: In Outlook, click Help > Detect and Repair, then click Start.

Possible Cause: The user running the Migration Utility does not have Admin privileges.

Action: Before running the Migration Utility, follow the instructions in “Designating a Service Account 
Administrator on Exchange 5.5” on page 20 or “Ensuring Administrative Rights on Exchange 
2000/2003” on page 20, depending on your version of Exchange.

Error EID: 0202 -- Could not open Exchange mailbox table

Source: GroupWise Migration Utility for Microsoft Exchange.

Explanation: The Migration Utility could not read the list of mailboxes in your Exchange system.

Possible Cause: The user that is running the Migration Utility does not have administrator rights to the Exchange 
server or the Domain object in the Exchange system.
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Action: Configure the user that runs the Migration Utility to have administrator rights, as described in 
“Designating a Service Account Administrator on Exchange 5.5” on page 20 or “Ensuring 
Administrative Rights on Exchange 2000/2003” on page 20, depending on your version of 
Exchange.

Possible Cause: You are running the Migration Utility on a server or workstation other than the Exchange server 
where the mailboxes are located, and the server or workstation does not have a username and 
password that matches a username and password with administrator rights on the Exchange server.

Action: Set up a username and password on the server or workstation where you are running the Migration 
utility that matches a username and password on the Exchange server.

Error EID: 0205 -- Could not log onto Exchange server through MAPI

Source: GroupWise Migration Utility for Microsoft Exchange.

Explanation: The Migration Utility cannot access the Exchange server.

Possible Cause: The Exchange server is down.

Action: Make sure that the Exchange server is running.

Possible Cause: The server or workstation where you are running the Migration Utility has Outlook 2002 but no 
Service Packs have been applied to it. 

Action: Apply Outlook 2002 Service Pack 1 or later.

Error EID: 0207 -- Generated exception accessing Exchange mailbox store.

Source: GroupWise Migration Utility for Microsoft Exchange.

Explanation: The Migration Utility cannot access the mailbox store on the Exchange server.

Possible Cause: The server or workstation where you are running the Migration Utility has Outlook 2002 but no 
Service Packs have been applied to it. 

Action: Apply Outlook 2002 Service Pack 1 or later.

Error EID: 0208 -- Could not log onto mailbox

Source: GroupWise Migration Utility for Microsoft Exchange.

Explanation: The Migration Utility cannot access a mailbox that was selected for migration.

Possible Cause: The mailbox was deleted from the Exchange system between the time it was selected for migration 
and the time when the migration session was run.

Action: None. The mailbox is no longer available for migration.

Error EID: 0232 -- User not created

Source: GroupWise Migration Utility for Microsoft Exchange.

Explanation: The Migration Utility could not create a GroupWise account for the Exchange user.

Possible Cause: The username already exists in eDirectoryTM.

Action: Rename the Exchange mailbox so that the associated username is unique in eDirectory.

Action: Rename the existing GroupWise user so that the Exchange username is unique in eDirectory. See 
“Renaming Users and Their GroupWise Accounts” in “Users” in the GroupWise 6.5 
Administration Guide
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Possible Cause: The Post Office Agent (POA) for the post office where the user is being migrated is not running.

Action: Start the POA. See “Starting the POA” in “Post Office Agent” in GroupWise 6.5 Administration 
Guide.

Error EID: 0247 -- Could not open GroupWise MAPI store provider for specified user

Source: GroupWise Migration Utility for Microsoft Exchange.

Explanation: The Migration Utility could not access the GroupWise mailbox that it previously created for the 
user.

Possible Cause: The Post Office Agent (POA) for the post office where the user is being migrated is not running.

Action: Start the POA. See “Starting the POA” in “Post Office Agent” in GroupWise 6.5 Administration 
Guide.

Possible Cause: The mailbox was created during a previous migration session and has now been removed from the 
GroupWise system.

Action: Select the mailbox again in a subsequent migration session.

Possible Cause: The eDirectory object for the user exists but the GroupWise account could not be created.

Action: Select the mailbox again in a subsequent migration session.

Error EID: 0258 -- Could not attach to eDirectory context

Source: GroupWise Migration Utility for Microsoft Exchange.

Explanation: The Migration Utility could not locate the eDirectory context where it has been instructed to create 
User objects for Exchange users.

Possible Cause: The context does not exist in eDirectory.

Action: Create the eDirectory context using ConsoleOne®.

Action: Specify an existing context in the Migration Utility.
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C Documentation Updates

This section lists updates to the GroupWise Migration Utility Installation and Migration Guide 
that have been made since the initial release of the Migration Utility 2.0. The information helps 
you to keep current on documentation updates and, in some cases, software updates (such as a 
Support Pack release).

The information is grouped according to the date when the GroupWise Migration Utility 
Installation and Migration Guide was republished. Within each dated section, the updates are 
listed by the names of the main table of contents sections.

The GroupWise Migration Utility Installation and Migration Guide has been updated on the 
following dates:

“September 6, 2005” on page 47

September 6, 2005

Location Change

“Migrating Exchange 
Distribution Lists/Groups” on 
page 30

Indicated that nested distribution lists are not migrated.

“Migrating Exchange Public 
Folders” on page 32

Explained how to migrate Exchange public folders to a GroupWise® 
resource.

Appendix A, “Novell 
eDirectory Attributes 
Populated from Exchange,” 
on page 41

Added a list of eDirectoryTM attributes that are automatically populated 
on User objects when GroupWise accounts are created.

“Error EID 0200 -- Could not 
open Exchange private 
store” on page 43

Added a solution for a new error message.
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