Novell Identity Manager Designer 4.0.1 Readme

April 15, 2011

This document contains known issues and other information about Novell Designer 4.0.1.

7.7.1 GNOME
7.7.2 KDE

1.0 Documentation

1.1 What's New in Designer 4.0.1

The What's New section for Designer 4.0.1 for Identity Manager is included in the build. This section will also be available online after Designer 4.0.1 is released.

1.2 Finding Documentation

The documentation for Designer 4.0.1 for Identity Manager is included in the build. This documentation will also be available online after the latest version is released.

This Readme contains the known issues for Designer version 4.0.1. In addition to this Readme, there is a separate Identity Manager 4.0.1 Readme.

Additional documentation resources are also available for the following:

1.3 Browsing or Searching

To browse the Designer help topics after Designer is installed:

  1. In Designer, click Help > Help Contents.

  2. Select a book, browse the table of contents, then click a topic.

To search for specific Designer information after Designer is installed:

  1. Click Help > Search, then enter text.


    Press F1 on any page. (In Linux, press CTRL + F1.)

  2. Type a topic in the Search field, then click Go.

2.0 Localization

2.1 Available Languages

Designer includes User Interface translation for Brazilian Portuguese, Chinese (Simplified), Chinese (Traditional), Dutch, French, German, Italian, Japanese, and Spanish. The User Interface language can be chosen during installation or runtime, through the Preferences dialog box.

2.2 Non-Translated Components

This release does not include translation of the Designer runtime help or product documentation. At this time, the project documentation generated by Designer is available in English only.

2.3 Plug-Ins

Some plug-ins are provided by the metadirectory and are available only in the languages supported by the metadirectory, including Chinese (Simplified), Chinese (Traditional), French, German, and Japanese. Some third-party plug-ins might be available in English only.

3.0 Installation Issues

3.1 Unable to Install Designer on Windows

Some users have reported that they cannot install Designer on Windows. The installation starts but closes with the following error:

"This Application has Unexpectedly Quit." 

If you see this issue:

  1. Right-click the Designer install.exe file, choose Properties, then select the Compatibility tab.

  2. Under the Compatibility mode section, choose the Run this program in compatibility mode option, then select Windows 2000 from the drop-down menu.

    The Designer installation should execute normally.

3.2 Installing Designer to a Network Drive with UAC Turned On in Windows Vista

Designer 4.0.1 is officially tested and supported on Windows Vista. However, if you turn on User Account Control (UAC) in Windows Vista, the programs might be unable to access some network locations and you cannot install Designer to a network drive. This problem might also occur when you use the command prompt to access a network location.

To resolve this problem, you need to configure the EnableLinkedConnections registry value by following instructions in the article entitled “After you turn on User Account Control in Windows Vista, programs may be unable to access some network locations” dated July 20, 2007, in the Microsoft Knowledge Base.

Follow these steps to apply the workaround to configure the EnableLinkedConnections registry value:

  1. Click Start, type regedit in the Start Search box, then press Enter.

  2. Locate and right-click the following registry subkey:

  3. Select New, then click DWORD Value.

  4. Type EnableLinkedConnections, then press Enter.

  5. Right-click EnableLinkedConnections, then click Modify.

  6. In the Value data box, type 1, then click OK.

  7. Exit the Registry Editor, then restart the computer.

3.3 Installing on English Windows with the East Asian Language Pack and with a Double-Byte Install Path

When you are installing on a path where there are double-byte characters and if your operating system is running the English version of Windows with the East Asian Language Packs installed, the install package throws an error, saying that it cannot extract the compressed file. There are known issues with using double-byte character sets (DBCS) in Windows file paths that come from the OS vendor or the install framework vendor. As an alternative, you can install to DBCS paths when you are installing to a localized version of the operating system.

3.4 Installation on Linux Throws an Exception Error

The following error occurs with some versions of Linux:

Invocation of this Java Application has caused an InvocationTargetException. This application will now exit.

The xhost program makes Linux more secure by not allowing other hosts and users to make connections to the X server. If you are logged in as a valid user and are trying to run the install as root, this error can occur. For more information on xhost, refer to the man page for xhost.

3.5 Warning Messages When You Start Designer after Installing

The following warning messages appear on the SUSE Linux Enterprise Desktop ( SLED 11) and openSUSE 11.1 platforms:

Gtk-Message: Failed to load module "gnomebreakpad": cannot open shared object file: No such file or directory 

Gtk-Message: Failed to load module "canberra-gtk-module": cannot open shared object file: No such file or directory 

It is safe to ignore these messages.

3.6 Designer Fails to Launch on the openSUSE 10.3 32-Bit Platform

To work around the issue, launch Designer through PuTTY and Xming:

  1. Download PuTTY save it in the Windows folder.

  2. Download Xming, then install it.

  3. In the taskbar, click the Xming icon > View Log Copy Display "".

  4. At the command prompt, open PuTTY, then paste in the X display location.

  5. In the Category, go to Connection > SSh > X11 > check enable x11 forwarding.

  6. In the Category, go to the session, click the default settings, then save them.

  7. Open PuTTY again, then log in to a Linux system.

  8. Launch Designer.

3.7 Designer 4.0.1 Readme Displays Junk Characters

If you open the Designer 4.0.1 Readme during the Designer 4.0.1 installation, junk characters are displayed on the screen. It also shows an error. It is safe to ignore this error. The Readme opens correctly after the installation is succesfully completed.

3.8 Designer Does Not Launch after a Successful Installation on a 64-Bit System

If you are installing Designer on a 64-bit system, make sure that libgthread-2_0-0-32bit-2.17.2+2.17.3+20080708+r7171-3.1.x86_64.rpm compat library is installed before starting the Designer installation.

3.9 Establishing Communication with eDirectory within Designer 4.0.1 Causes an Error on Windows 7

This issue occurs because a previous version of NICI might not have uninstalled properly and might have some residual files left on the file system.

To work around the issue, remove all the NICI files from the system and reinstall Designer and the Novell Client.

4.0 Encryption/Security Issues

4.1 Project Files Are Not Encrypted

Passwords are obfuscated. However, if you have other sensitive data in your project file, it is not encrypted in any way, and you must take care to safeguard your information.

5.0 Issues in Generating Documentation for Projects

5.1 Using the Adobe Acrobat Reader for Linux

By default, Linux might be using a PDF reader (Evince) that doesn't support the embedded font we use to display double-byte characters. You should use the Adobe Acrobat Reader for Linux to support these languages.

5.2 Generating Documentation for Large Projects Might Cause a Memory Outage

To avoid a memory outage, generate documents individually for Identity Vaults, drivers, and driver sets.

6.0 General Issues

The following sections provide information for known issues at the time of the product release.

6.1 Notification Templates Are Filtered by Name and Locality Settings

When you run Designer in any language, by default you see only the notification templates for the language that you are running in. To see the templates in additional languages, change the filter settings for the Outline view:

  1. Click the Filter icon in the upper right corner of the Outline view.

  2. Select the languages that you want to see.

Also, when creating new templates, you must add the correct language code to the template name so that your new templates are filtered correctly. For example, a German template should be named <TemplateName_de>. The language codes are as follows:

  • da-Danish
  • de-German
  • es-Spanish
  • fr-French
  • it-Italian
  • ja-Japanese
  • nl-Dutch
  • pt-Portuguese
  • ru-Russian
  • sv-Swedish
  • zh-CN-Chinese Simplified
  • zh-TW-Chinese Traditional
  • en-English (or leave the language code off)

6.2 Manager-Employee String Not Localized for Relationships Under DAL for the Portuguese Locale

6.3 Designer Doesn't Launch after Installation on Windows Vista

Windows Vista implemented a User Account Control feature that prevents applications from running as Administrator unless you specifically allow it.

If Designer does not install correctly or launch after installation on Windows Vista:

  1. Right-click the Designer shortcut on the desktop.

  2. Select Run as Administrator.

For Designer auto-updates to work on Windows Vista (Ultimate and Business versions), ensure that the logged-in user is an Administrator or equivalent.

6.4 Live Operations on Windows Vista Are Slow

When you run Designer on Windows Vista, you might see poor performance when doing live operations on a Windows 2003 server. You can resolve this issue by disabling TCP Auto Tuning on Windows Vista. To do this, open a command prompt, then enter the following:

netsh interface tcp set global autotuninglevel=disabled 

6.5 NICI Fails to Install on Windows during Designer Installation

If you get the following error message during the installation of Designer, one of the reasons could be that the path of the Designer executables is too long. In spite of the error message, Designer installation completes successfully, but NICI fails to install.

Error Executing the Specific Program 

C:\Users\Administrator\AppData\Local\Temp\pftE915~tmp\Disk1\Setup.exe -s -f1C:\Users\Administrator\Desktop\designer_cdimage_win\linux\final\designer_win32\designer_install\components\nici\wcniciu0.iss -f2C:\Users\Administrator\AppData\Local\Temp\designerNici.log 

To work around this issue, manually install NICI by running the <Designer Install Location>\components\nici\wcniciu0.exe command.

6.6 The JVM Crashes When You Close Designer on Windows Vista

After you perform any live operation in Designer on Windows Vista, the JVM might crash when you close Designer. This is because of an errant call in JClient. If this happens, no data is lost; simply close the error window.

This issue is being addressed.

6.7 Application Schema Is Not Imported by Default

An application schema is not automatically imported by default. You can always perform a refresh application schema operation on a particular application after the project has been imported:

  1. Right-click the driver.

  2. Select Live > Refresh application schema.

    You can also change this preference by selecting Window > Preferences >Novell >Identity Manager > Import/Deploy > Behaviors> Import, then selecting Include application schema when importing drivers.

6.8 Running Designer with 120 DPI Fonts in Windows

120 DPI is too large for text in standard Windows XP decorations. Adjust the display settings:

  1. In the Control Panel, select Display > Appearance > Effects.

  2. In Use the following method to smooth edges of screen fonts, toggle Standard to ClearType.

    If you have a display that needs120+ DPI fonts, you need ClearType. In addition to the obvious anti-aliasing aspects, ClearType provides better weight to the fonts. Without ClearType, the fonts are too thin and light, decreasing readability.

  3. Click OK, then click Advanced.

  4. In the Item field, reduce the Icon, Menu, Message Box, Selected Items, and ToolTip sizes.

  5. Reduce the title bars and related controls to a preferred size.

  6. Fix the icon spacing and scroll bar width.

  7. Make sure that the display is set at a high resolution.

    This helps eliminate most of the display related issues on an HD monitor.

6.9 Boosting Modeler Performance

If you want to maximize the performance on large-scale operations, such as copying and pasting several objects, the performance is up to ten times faster if you hide or close the Outline view. You get additional enhanced performance if you also close the Properties view. To quickly restore these views, click Window > Reset Perspective.

6.10 JDBC 3.5 Driver Project Names

If a project contains a JDBC 3.5 driver, you might notice that the default driver name is JDBC 3\.5. This is normal and allows the driver to deploy correctly.

6.11 Designer 4.0.1 Does Not Support 2.1.1 Workspaces

Designer 2.1.1 workspaces are not compatible with Designer 4.0.1. Designer stores projects and configuration information in a workspace. These workspaces are not compatible from one version of Designer to another. You need to point Designer 4.0.1 to a new workspace and not to a workspace used by a previous version of Designer.

6.12 Role Editor Limitations

The Role Editor does not support the fan-out driver capability and cannot choose logical systems for SAP drivers. Although the Role Editor displays entitlements, it cannot differentiate between logical systems.

6.13 Designer 4.0.1 Does Not Support Conversion of Projects Older than Designer 3.0

To resolve this issue, convert the older projects to Designer 3.0.1, then import them into Designer 3.5.

6.14 The Project Converter Does Not Support Remotely Mounted Workspace

If you convert the Designer 3.5 project to Designer 4.0.1 after mounting the Designer 3.5 workspace in the local machine where Designer 4.0.1 is installed, the Project Converter does not convert the Designer 3.5 project.

To workaround this issue, copy the Designer 3.5 workspace to the local machine where Designer 4.0.1 is installed, then run the the Project Converter.

6.15 The Document Generator Does Not Generate Documentation for Roles-Based Entitlement Policies and Roles-Based Provisioning Module Resources

6.16 The Internal Web Browser Does Not Work on Linux Platforms in Designer

The internal Web browser does not work as expected because of XULrunner issues.

To work around the issue, get the external browser from Designer > Windows > Preferences > General > Web Browser > Use External Web Browser. This brings up the iManager URL through the system default Web browser, such as Mozilla Firefox or Microsoft Internet Explorer.

6.17 Deploying Linkages for ECMAScripts to the Provisioning Request Definition

ECMAScripts should be deployed along with their linkages. Direct deployment of the ECMAScript does not deploy the linkages. You can only add the deployed (eDirectory) scripts to the provisioning request definition (PRD) if the links that connect the ECMAScript with the driver are present.

You can link the ECMAScript with a driver in one of these ways:

  • Deploy the linkages in the driver by right-clicking and selecting Driver > Live Compare > Update eDirectory.

  • Click Driver > Live Compare > Update eDirectory to create the policy linkages on the driver. When the driver is imported into the next project, the ECMAScript linkages are also imported.

  • When you see the scripts in the Outline view of next project, go to Driver Configuration, click the ECMAScript tab, then manually add the script. This creates a linkage between the script and the driver.

6.18 MVEditor Does Not Resolve the DN for the DAL Global Query

When the entity type is not specified, the MVEditor lookup selection filters the search results and displays the correct values. When the entity type is specified, the DAL query no longer returns the correct values.

To work around the issue, do not specify the DAL entity key if you are specifying the global expression because the global query already references an entity key in the definition. You can either specify the DAL entity key lookup and map the display expression or you can specify the DAL query global expression, but you cannot specify both at the same time.

6.19 An Attribute with an Underscore in the LDAP Name Breaks the Detail Portlet

The issue occurs if you use an underscore (_) in the attribute name. For example, attributes such as TestName or Test-Name work fine, but Test_Name does not.

6.20 No Local History Preferences

The Local History Preferences available with Designer are an Eclipse feature. These preferences are not intended to cache the Designer data.

To minimize the history that Designer can cache:

  1. Access the Local History Preference page by clicking Windows > Preferences > General > Workspace > Local History.

  2. Set the following preference values:

    • Days to keep files: 1

    • Maximum entries per file: 1

    • Maximum file size (MB): 1

  3. Restart Designer to apply the changed values.

6.21 Setting the LDAP Ports Correctly after Importing a Project into Designer

When you create a project after importing it from a live system in Designer, Designer does not correctly set the ports in the Identity Vault Properties view.

To work around this issue, change the LDAP ports in the Identity Vault Properties view prior to deploying the imported project.

6.22 Proxy Settings Do Not Work for Designer

If you are using proxy to connect to Internet, ensure that Eclipse plug-ins required for the proxy connection are loaded at the time when update packages are called.

  1. Start Designer.

  2. Cancel the update dialogs that display after Designer is launched.

  3. Go to Window > Preferences > General > Network Connections to load the Eclipse plug-ins required for setting up the proxy connection.

  4. Check updates for Designer or Package by clicking Help > Check for package updates.

    The correct updates are available.

7.0 Linux Issues

7.1 JVM Terminated Exit Code=1 Error

Some installations have reported a JVM terminated exit code=1 error on SLED 10 SP1 workstations. You can apply a temporary workaround by making the following change in the /etc/X11/xorg.conf file:

Section "Extensions"
Option "MIT-SHM" "no"

Be aware that disabling this extension degrades performance.

7.2 Installing Designer on openSUSE 10.3 with the GNOME Interface

The GNOME interface in openSUSE 10.3 does not initially work with Identity Manager Designer. For example, Designer doesn't launch under GNOME, Designer crashes as soon as you hover over a tooltip, or Designer crashes when deleting objects from the Project view. In order for openSUSE 10.3 with GNOME to work with Designer 3.x or later, you need to update all of the libraries from Be sure to include the following:

  • bug-buddy

  • gtk2

If you are having problems when running the updates or if you need to configure the update server, go to the YaST Online Update documentation site for additional help.

7.3 Stack Smashing Error on openSUSE 10.3

When starting Designer with on openSUSE 10.3, you might receive the following error on the console:

"*** stack smashing detected ***: ~/designer/jre/bin/java terminated" 

Designer fails to start. This error might be a result of using the Smart Common Input Method platform (SCIM) language input system on your Linux desktop, specifically the scim-bridge-gtk module for GTK. You can fix this error in one of two ways:

  • Remove the scim-bridge-gtk module.

  • Export the GTK_IM_MODULE=xim environment variable. (Click export GTK_IM_MODULE=xim for further instructions.)

7.4 Installing Designer on Debian-Based Linux Distributions

Although we cannot officially support all Linux distributions, many customers have reported success in running Designer on Debian-based distributions, such as Ubuntu. To do this, perform the following steps:

  1. Download and extract Designer from the Cool Solutions Web site to a folder of your choice.

  2. Use the Ubuntu synaptic package manager to install the alien, rpm, and gettext packages.


    From the command line, enter sudo apt-get -f install alien rpm gettext.

  3. Change directories to the designerInstallDir directory.

  4. At the command line, enter sudo rpm -ivh --nodeps components/nici/nici.i386.rpm).

    This adds an entry to the RPM database that the installer checks for when you enter rpm -qa at the command line.

  5. The gettext RPM is also required for the standard Designer installer. Download any installable gettext.rpm version, then install it. For example, rpm -ivh --nodeps gettext[version].rpm. This step adds the gettext entry to the RPM database.

  6. Run the standard Designer ./install script as a desktop user.

7.5 Running eDirectory with Designer on Linux

If you are running eDirectory on Linux and also want to run Designer, you might need to run Designer as root. The eDirectory install requires you to install its base packages as root, which prevents a typical user from running them. Specifically, Designer crashes if you are running as a nonroot user when importing or deploying and when connecting to a tree.

7.6 Running Designer on Linux with gtk-qt-engine

We don't recommend running Designer with the gtk-qt-engine RPM installed. This RPM package is installed with SUSE Linux and some other Linux distributions. Known issues cause crashes and Designer theme issues when this package is installed.

If you use this RPM package, obtain the latest version. You can download this version from the KDE Web site..

Even with the latest version of the package, the Designer theme functionality might not be present.

To determine whether you have the gtk-qt-engine RPM package installed, enter:

rpm -qa|grep gtk-qt

If gtk-qt-engine appears in the list, you should remove the package by issuing the following command as the root user:

rpm -e gtk-qt-engine

7.7 Display Issues on Linux

7.7.1 GNOME

If you encounter display issues in GNOME:

  1. Select the Applications menu.

  2. Click Preferences > Font, then decrease the size of the application font.

  3. You can also adjust the thematic elements to your liking.

    Keep in mind that GTK thematic elements can cause performance issues with Designer. If Designer is running slowly, especially when you use pull-down menus and other widgets, you might try changing to a simplified GTK theme.

    Normally, this process fixes display issues.

7.7.2 KDE

Because Eclipse (Designer) is a GTK application, you should use GTK themes instead of qt-based themes.

First, you need to prepare to use the themes.

You must remove the gtk-qt-engine package. This can be done through YaST or by using the instructions given in Running Designer on Linux with gtk-qt-engine.

You need to have the following packages installed on your Linux system. If you installed the GNOME subsystem, you already have these packages installed:

  • gtk-engines

  • gtk2-engines

  • control-center2 > Gnome Control Center

  • gtk2-themes > or the themes you downloaded, and all the related dependencies

  • gnome-themes is only needed if you are going to use Gnome Control Center to set your theme

After you have completed the prerequisites, do one of the following:

  • Set your GTK theme and font settings from the KDE SUSE menu. Select Utilities > Desktop > Gnome Control Center. You can set this control center application to automatically run each time KDE is started. The following command accomplishes this:

    ln -s /opt/gnome/lib/control-center-2.0/gnome-settings-daemon /home/user/.kde/Autostart

    For user, use your username.

  • Create a GTK control file (usually named .gtkrc-2.0) in your user home directory or the directory where your system is configured to look for GTK2_RC_FILES. Entering set |grep gtk shows how this environment variable is configured and the files it requires. You can use any font and GTK theme that you prefer.

    For example: include "/opt/gnome/share/themes/Xfce-stellar/gtk-2.0/gtkrc" style "user-font"

    /gtkrc" style "user-font"


    font_name="Sans Serif 6"


    widget_class "*" style "user-font" gtk-theme-name="Xfce-stellar"

    gtk-font-name="Sans Serif 6"

7.8 Designer Launch Fails on SLED 10.3 64-Bit

7.8.1 Adding XULrunner to Designer.ini on the SLED 10.3 64-Bit

To launch Designer, add the XULrunner version to the Designer.ini file.

  1. Check the XULrunner version in the /usr/lib directory.

  2. Add the XULrunner information by modifying the Designer.ini file.

    1. Open the Designer.ini file from the Designer installation directory.

    2. Add the following line at the end of the Designer.ini file:

  3. Save the Designer.ini file, then launch Designer.

7.8.2 JVM Crashes When Launching Designer, the Welcome Page, or Opening Help on 64-Bit Linux

If the 32-bit version of XULrunner is installed on a 64-bit Linux distribution, the JVM might crash when you launch Designer, when the Welcome Page displays, or when you view a Help topic. To resolve this problem:

  1. Open the Designer.ini file located in the Designer installation directory.

  2. Add the following line at the end of the Designer.ini file:

  3. Save the Designer.ini file, then launch Designer.

7.8.3 The Welcome Page Doesn't Display on Some Linux Distributions

If the Welcome page doesn't display correctly on Linux, it is probably because your version of XULrunner isn't compatible with Eclipse. Designer uses the embedded browser that XULrunner provides in a few places, including the Welcome page and the Help system.

To download a compatible version of XULrunner:

  1. Download the XULrunner installer for Linux.

  2. Unregister your current version of XULrunner by running the following command as root:

    xulrunner --unregister-global
  3. Follow the instructions to install XULrunner.

  4. Restart Designer, then confirm that the Welcome page is working as expected.

7.9 Dialog Box Buttons Do Not Respond to Mouse Clicks on openSUSE 11.2

If buttons in dialog boxes do not respond to mouse clicks, you can work around this issue in one of these ways:

  • Use the Space key or the Enter key to activate the buttons.

  • Add export GDK_NATIVE_WINDOWS=true to the file.

7.10 Cannot Select Options When Creating or Configuring a Driver

At times, you cannot select drop-down options when creating or configuring a driver. To avoid the problem, use the following workaround:

  1. Click the drop-down menu, but continue to hold the left mouse button.

  2. Continue to hold the left mouse button until the desired option is highlighted.

  3. Release the left mouse button to select the option.

7.11 An Exception Occurs while Browsing the Designer 4.0.1 Help System

When you browse the Help content on the openSUSE 11.2 platform, it throws an exception. This is probably because your version of XULrunner is not compatible with Eclipse. To avoid this exception, use the following workaround:

  1. Download the xulrunner- file, then install it on openSUSE 11.2.

    For instructions, see the installation steps in the The Welcome Page Doesn't Display on Some Linux Distributions.

  2. Open the Designer.ini file from the Designer installation directory, then add the following line at the end:

  3. Save the Designer.ini file, then restart Designer.

8.0 Workflow/Provisioning Issues

8.1 A Form Field That Returns Undefined Does Not Display an Error or Warning

If a field on a form used by a workflow returns the value “undefined”, the form does not display an Error or Warning message. This situation results from a problem in the script. In general, if a form script evaluates to “undefined”, the script is considered to be in error. The workaround is to make sure you do not set “undefined” in the preactivity mappings. To do this, use a try/catch/finally block to ensure that there is always a valid value being sent to each control.

8.2 Possible Timeout When Setting Trustee Rights on a Provisioning Request Definition

You might encounter the following error message when trying to set Trustee Rights on a provisioning request definition or when trying to access the Identity Vault through the ECMA expression builder:

Cannot connect to host 'xxx', verify the address is correct and the server is running.

If the address is correct and the server is running, this might be caused by a slow connection.

You can change the connection timeout by setting the Connection preference via Window > Preferences > Novell > Provisioning.

8.3 Saving Incorrect Credentials in the Provisioning Request Definition Editor

When you connect to the Identity Vault from the provisioning request editor (for example, when you set Trustee rights on a provisioning request definition) you are prompted for your Identity Vault credentials. If you type an incorrect password, then click the Save password button in the Identity Vault credentials dialog box, you cannot connect to the Identity Vault and are not prompted to retype your credentials.

To work around this issue, access the Modeler view, then reconfigure the Identity Vault credentials for the project.

8.4 Resources Associated with Roles Are Not Deleted from the Resources List of the Role Editor

Under the Resources List in the Role Editor, a read-only list of the associated resources is available along with the role. The information in this list is obtained and updated for all the roles when the Role Catalog is imported from eDirectory. You can see new resource associations but not the resource associations that have been removed in the User Application.

To work around this issue, ensure that the deleted resource associations are removed from the Resources List:

  1. Before performing a Live Import from the Role Catalog, go to the Navigator View, then navigate to the \MyProject\Model\Provisioning\AppConfig\RoleConfig\ResourceAssociations folder.

  2. Remove all the files in the folder except the ResourceAssociations.digest file.

  3. From the Provisioning View, select the Role Catalog object, then run the Live Import to import all of the resource associations again and to provide the updated correct information.

8.5 Error When Using the Compare Feature in a Project Under Version Control

If you add a User Application driver to a project under version control and you perform a compare after checking in the project again, you might see the following exception in the error log:

Unable to find a light item for the path: Model/Provisioning/AppConfig/.appconfig 

You can safely ignore this error.

8.6 Exceptions When Importing a Project Archive

If you import a project archive file into Designer, you might not see the existing team definitions. You also see the following error in the error log:


To make the team definitions available, restart Designer.

8.7 Role Compare Shows Incorrect Results

If you use both the User Application user interface and Designer to create roles, the Live Compare feature of Designer might not display the expected results. To work around this problem, do either of the following:

  • Use only Designer to create, delete, or modify all roles.

  • Use the Compare window that is displayed during a deploy. The Compare window displays the correct results. You can cancel the deploy if you only want to see the compare results.

8.8 Null Pointer Exception Error When Checking In Provisioning Objects to Version Control

If you commit any provisioning objects to version control when the Provisioning Request Definition (PRD) is open with unsaved changes, a Null Pointer Exception error occurs in the error log. You might not realize that the commit failed unless you have the Error Log view open. The easy workaround is to save the provisioning object before checking it into version control or to close the object without saving it.

8.9 Reverting an Open Provisioning Request Definition Causes the Editor to Close

If you revert a provisioning request definition (PRD) while it is open in the provisioning request definition editor, the editor closes, then reopens with the refreshed version of the PRD. This is a normal action of the provisioning request definition editor.

8.10 Reverting Locale Changes Might Display the Incorrect Status

When you use the Locales and Localization Resource Groups window (Configure > Locales) to add and remove locales, then perform a version control Revert, Designer might incorrectly indicate that the local object has changed. This happens if you have not made any changes, but you close the window by clicking OK. You can avoid this message by clicking Cancel instead of OK.

8.11 Problems Setting Trustees on Read-Only Provisioning Request Definitions after Migrating the User Application Driver to 3.6.1

If you set trustees on one of the read-only provisioning request definitions (such as the Roles or Attestation objects) on a User Application driver migrated to 3.6.1, Designer creates an extra copy of the provisioning request definition. You see two objects with the same name in the Provisioning view.

To delete the extra object:

  1. Back up your project.

  2. With the project open, access the Navigator view, then navigate to the Model\Provisioning\AppConfig\RequestDefs folder of the project.

    The Navigator view displays the provisioning request definitions as .prd and .digest files. The extra copy of the provisioning request definition has the same name with a number appended to it. For example, the Attestation Report displays in the Navigator view as AttestationReport.prd and AttestationReport.digest. The extra copy displays as AttestationReport1.prd and AttestationReport1.digest.

  3. Delete the files with numbes appended to the names, such as AttestationReport1.prd and AttestionReport1.digest.

  4. Save the project.

8.12 Entitlement Parameters Are Not Correctly Generated for Entitlements with the Identity Manager 4.0.1 Format

Identity Manager 4.0.1 entitlements accept JSON expressions. However, the generated expression returns a simple parameter, for example:

Ensure that you edit the expression to be a JSON expression. For example, for an Active Directory driver, modify the expression as follows:

{"ID", ""}

9.0 Provisioning/Migration Issues

9.1 User Application 3.7 Driver Migration Does Not Automatically Deploy the Notification Templates

You should manually add and deploy the notification templates while working with the User Application drivers migrated from User Application versions prior to 3.7. Use the following steps to deploy the notification templates:

  1. Go to the Outline view in the Designer.

  2. Go to the Identity Vault where the migrated environment is created.

  3. Right-click Default Notification Collection.

  4. Click Add All Templates, then right-click Default Notification Collection.

  5. Go to Live > Deploy, then deploy all the changes.

9.2 Direct Migration of the User Application Driver to the 4.0.1 Version Is Not Supported

The Identity Manager driver migration is no longer an option with Designer 4.0.1. Designer 4.0.1 supports only upgrades of driver packages. To upgrade the earlier versions of the User Application driver to the 4.0.1 version, you need to migrate the driver to the 4.0 version, then use the User Application package upgrade to upgrade to the 4.0.1 version.

10.0 Version Control Issues

10.1 404 Error When Comparing Version Control Revisions on Large Projects

There is an intermittent problem that occurs when you compare a large project or when you have a very slow connection when comparing a project. Compare takes a long time to run, and not all of the items appear in the Compare window. Most of the time, this problem is resolved when you try again. If the problem persists, contact Novell Support for information about temporarily turning off the status thread.

10.2 Driver Not Appearing in Version Control or Modeler Views after Checking for Updates

If you add a driver to a driver set on one computer, save that update to a version control server, then perform Get Updates on a second computer, you won't see the driver added to the driver set. If this happens, refresh the Modeler view by closing and then reopening the view. Then run refresh on the Version Control view.

10.3 Copying, Pasting, and Dragging in the Navigator View Don't Update Version Control

Copying and pasting or dragging and dropping operations in the Navigator View are not handling files properly if the files are under version control. The workaround is to perform these operations from the Project view.

11.0 Packages Issues

11.1 Automatic Updates for Packages Fail if the Site Requires Authentication

If you are automatically downloading packages from a site that requires authentication, the download fails. You can work around this problem by configuring Designer to automatically authenticate to the download site.

  1. In Designer, click Windows > Preference > General > Network Connections.

  2. Click Manual proxy.

  3. Specify the server and port of the proxy server.

  4. Click Enable proxy authentication.

  5. Specify the username and password to authenticate to the site where you download packages.

  6. Click OK to save the changes.

12.0 Upgrade Issues

12.1 Upgrading from Designer 3.0.1 to Designer 4.0.1 is Not Supported

Designer 4.0.1 is a full-fledged RCP application. It does not support upgrades from the previous versions of Designer. You can still export Designer 3.0.1 workspaces into Designer 4.0.1, which triggers the project conversion and converts the project to a 4.0.1 version.

13.0 Help Issues

13.1 Help in the Manage Directory Continues Loading for More Than 12 Hours

The Loading Help dialog box appears, but the Help window does not appear. The Loading Help dialog box is not closed until Designer is restarted.

14.0 Legal Notices

Novell, Inc., makes no representations or warranties with respect to the contents or use of this documentation, and specifically disclaims any express or implied warranties of merchantability or fitness for any particular purpose. Further, Novell, Inc., reserves the right to revise this publication and to make changes to its content, at any time, without obligation to notify any person or entity of such revisions or changes.

Further, Novell, Inc., makes no representations or warranties with respect to any software, and specifically disclaims any express or implied warranties of merchantability or fitness for any particular purpose. Further, Novell, Inc., reserves the right to make changes to any and all parts of Novell software, at any time, without any obligation to notify any person or entity of such changes.

Any products or technical information provided under this Agreement may be subject to U.S. export controls and the trade laws of other countries. You agree to comply with all export control regulations and to obtain any required licenses or classification to export, re-export or import deliverables. You agree not to export or re-export to entities on the current U.S. export exclusion lists or to any embargoed or terrorist countries as specified in the U.S. export laws. You agree to not use deliverables for prohibited nuclear, missile, or chemical biological weaponry end uses. See the Novell International Trade Services Web page for more information on exporting Novell software. Novell assumes no responsibility for your failure to obtain any necessary export approvals.

Copyright © Novell, Inc. All rights reserved. No part of this publication may be reproduced, photocopied, stored on a retrieval system, or transmitted without the express written consent of the publisher.

For Novell trademarks, see the Novell Trademark and Service Mark list.

All third-party trademarks are the property of their respective owners.