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About This Guide

The Kablink Vibe 3.3 Advanced User Guide explains how to use advanced features of the Vibe product.

 Chapter 1, “Are You an Advanced Vibe User?,” on page 11

 Chapter 2, “Creating and Managing Workspaces,” on page 15

 Chapter 3, “Managing Folders,” on page 25

 Chapter 4, “Controlling Access,” on page 41

 Chapter 5, “Branding a Folder or Workspace,” on page 53

 Chapter 6, “Creating and Managing Landing Pages,” on page 55

 Chapter 7, “Creating Custom Workspace Views,” on page 87

 Chapter 8, “Creating Custom Folder Views,” on page 97

 Chapter 9, “Designing Custom Folder Entry Forms,” on page 109

 Chapter 10, “Using Custom JSP Files to Enhance Your Vibe Pages,” on page 123

 Chapter 11, “Creating and Managing Workflows,” on page 127

 Chapter 12, “Managing Remote Applications,” on page 167

 Chapter 13, “Managing Your Data Quota,” on page 175

 Chapter 14, “Restoring Deleted Items,” on page 183

 Chapter 15, “Using Kablink Vibe on Your Mobile Device,” on page 185

 Appendix A, “What’s New in Vibe 3.x,” on page 201

 Appendix B, “Using HTML Markup in Vibe,” on page 207

Audience

This guide is intended for all new Kablink Vibe users who want more information about advanced 
Vibe functionality.

Feedback

We want to hear your comments and suggestions about this manual and the other documentation 
included with this product. Please use the User Comments feature at the bottom of each page of the 
online documentation.

Documentation Updates

For the most recent version of this manual, visit the Kablink Vibe 3.2 Documentation Web site (http://
www.novell.com/documentation/kablinkvibe32). 
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Additional Documentation

You can find more information in the Kablink Vibe documentation, which is accessible from the 
Kablink Vibe 3.2 Documentation Web site (http://www.novell.com/documentation/kablinkvibe32). 

To access the Kablink Vibe 3.3 User Guide from within Vibe, click the Help icon (question mark).
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1 1Are You an Advanced Vibe User?

Kablink Vibe is an enterprise collaboration tool designed to increase individual productivity, team 
effectiveness, and organizational success by providing the right set of tools to the right people. Key 
Vibe features include Team workspaces, calendars, task lists, document management, discussion 
threads, wikis, blogs, RSS feeds, and workflows.

Vibe enables ordinary users to perform content-management functions. Because all Vibe users need 
to manage a personal workspace, and can also create team workspaces, all users have the potential to 
become “advanced Vibe users.”

Although all Vibe users have the ability to become advanced users, many users never have the need 
to progress beyond the basic Vibe functionality. This is because Vibe lends itself to two main groups: 
content consumers and content providers.

 Section 1.1, “Content Consumers,” on page 11

 Section 1.2, “Content Providers,” on page 11

1.1 Content Consumers
Content consumers use Kablink Vibe to get important information that pertains to them. They 
participate in team workspaces in order to better collaborate with colleagues and facilitate their work 
assignments. They identify subject-matter experts and search for important information. 

Content consumers can learn how to accomplish these and other important tasks in the Kablink Vibe 
3.3 User Guide

1.2 Content Providers
Content providers use Kablink Vibe to manage teams by creating team workspaces and making 
information easily accessible through landing pages and other advanced Vibe features.

Advanced Vibe users might perform any of the following functions:

 Create or manage workspaces and folders: When you create your own workspace or folder, 
you are the owner of that workspace or folder. By default, you are also the owner of all sub-
workspaces and sub-folders.

For example, suppose that your manager assigns you to lead an advertising campaign for a new 
product. Because accomplishing this assignment involves the combined efforts of various 
members of your team, you decide to create a new workspace dedicated to the new campaign.

For in-depth information, see Chapter 2, “Creating and Managing Workspaces,” on page 15 and 
Chapter 3, “Managing Folders,” on page 25.
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 Control user access to workspaces and folders: As the owner of a workspace or folder, you are 
responsible for controlling which users have access rights, and deciding which rights are 
appropriate for which people.

For example, as the advertising campaign manager for a new product, you need to decide if Vibe 
users who are not members of your team are allowed to create entries in your team workspace, 
or whether non-team members should even be allowed to view the workspace.

Also, when new users join the team, it is your responsibility to grant them appropriate rights.

For in-depth information, see Chapter 4, “Controlling Access,” on page 41.

 Create unique brands for workspaces and folders: As the owner of a workspace or folder, you 
are responsible for creating a unique and attractive brand. Creating a unique brand is a good 
way to differentiate your workspace or folder from other places in the Vibe site.

For example, as the advertising campaign manager for a new product, you brand your team 
workspace with a graphic of the product logo, along with the new marketing slogan.

For in-depth information, see Chapter 5, “Branding a Folder or Workspace,” on page 53.

 Create landing pages: As the owner of a workspace, you can present the most important 
information on the home page of the workspace. At the same time, you can change the look and 
feel of the home page. (You can create landing pages in personal workspaces only if your Vibe 
administrator has enabled this functionality.)

For example, as the advertising campaign manager for a new product, you create a landing page 
in the team workspace. In the landing page you display the current product shipment schedule, 
the latest news concerning the product, open tasks as they relate to your team members, and so 
forth.

For in-depth information, see Chapter 6, “Creating and Managing Landing Pages,” on page 55.

 Create custom workspace and folder views: As the owner of a workspace or folder, you can 
create custom views that modify what is displayed on the home page of your workspace or 
folder. You can display uploaded files, remote applications, pictures, and more.

For example, as the advertising campaign manager for a new product, you can customize the 
home page of your team workspace to display pictures of the various marketing logo options for 
the product, as well as uploaded notes from team meetings.

For in-depth information, see Chapter 7, “Creating Custom Workspace Views,” on page 87 and 
Chapter 8, “Creating Custom Folder Views,” on page 97.

 Create custom folder entry forms: As the owner of a workspace or folder, you can create 
custom folder entry forms that users can fill in when they are making entries in the workspace or 
folder. 

For example, as the advertising campaign manager for a new product, you decide to create a 
new folder called “Slogans.” Inside this folder, you create a new entry form that enables team 
members to easily submit their ideas for catchy slogans for the new product. The entry form 
contains a field for the team member to type his or her name, a field where they can type the 
slogan, a field where they can upload pertinent pictures, and so on.

For in-depth information, see Chapter 9, “Designing Custom Folder Entry Forms,” on page 109.

 Create and manage workflows: As the owner of a workspace or folder, you can create 
workflows that automate otherwise time-consuming manual processes.

For example, as the advertising campaign manager for a new product, you notice that expense 
reporting is taking more time than you want. The current process is for members of your team to 
request an expense reimbursement from you, then for you to send the request to HR, who then 
transfers the request to Finance. To automate this process, you implement a workflow that sends 
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you an e-mail notification requesting your approval when the request is submitted. When you 
give your approval, the workflow is automatically transferred to HR. If HR approves the 
request, then the workflow is transferred to Finance, where the reimbursement is addressed.

For in-depth information, see Chapter 11, “Creating and Managing Workflows,” on page 127.

 Manage remote applications: As the owner of a workspace or folder, you can enable remote 
applications that have been set up by your Vibe administrator.

For in-depth information, see Chapter 12, “Managing Remote Applications,” on page 167.
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2 2Creating and Managing Workspaces

Kablink Vibe enables you to create and manage your workspaces in the following ways:

 Section 2.1, “Creating and Managing a Team Workspace,” on page 15

 Section 2.2, “Creating and Managing a Discussions Workspace,” on page 16

 Section 2.3, “Creating and Managing a Basic Workspace,” on page 17

 Section 2.4, “Creating and Managing a Project Management Workspace,” on page 18

 Section 2.5, “Creating and Managing a Team Workspace Root Workspace,” on page 20

 Section 2.6, “Using Global Workspaces,” on page 21

 Section 2.7, “Creating Workspace Hierarchies,” on page 21

 Section 2.8, “Creating Custom Workspace Views,” on page 23

 Section 2.9, “Setting a Maximum Number of File Versions,” on page 23

 Section 2.10, “Setting a File Upload Size Limit,” on page 23

 Section 2.11, “General Workspace Management,” on page 23

2.1 Creating and Managing a Team Workspace
Team workspaces are the key to helping you and your team accomplish tasks and meet objectives, 
together.

As the owner of a workspace, you are primarily responsible for workspace administration. You can 
create other containers for information (sub-workspaces and folders), adjust access control to 
determine who can do what in the workspace, and provide some initial content to assist team 
members with getting started.

For information about how to perform basic management tasks on a team workspace, such as 
creating the workspace, adding team members, and sending e-mail to team members, see “Managing 
a Team Workspace” in the Kablink Vibe 3.3 User Guide.

 Section 2.1.1, “Allowing Visitors to Your Team Workspace,” on page 16

 Section 2.1.2, “Using Team Workspaces to Create Hierarchies,” on page 16
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2.1.1 Allowing Visitors to Your Team Workspace

By default, only team members can view and participate in the workspaces and folders contained in 
the team workspace. There might be times when you want to allow other people to visit your team 
workspace (which, by default, means that they can read entries and comment on them, but they 
cannot create entries).

To allow visitors to your team workspace:

1 Navigate to the team workspace where you want to allow visitors.

2 Click Workspace > Access Control.

Kablink Vibe displays the Configure Access Control page for the team workspace.

3 Ensure that the workspace is not inheriting its access control settings. Select the no radio button, 
then click Apply.

4 (Conditional) If Visitor is not already a column in the provided table, click Add a Role > Visitor:

5 On the left side of the table, click Add a User, then use the type-to-find functionality to select the 
name of the person you want to add as a visitor to the team workspace.

6 In that new user’s row, select the check box in the Visitor column.

7 Repeat Step 5 and Step 6 until you have added all your visitors.

8 Click Save Changes > Close.

The people who now have the Visitor role can view your team workspace and add comments to 
existing entries. They cannot create new entries.

For more information on managing access control, see Section 4.2, “Managing Access Control for 
Users and Groups,” on page 45.

2.1.2 Using Team Workspaces to Create Hierarchies

Team workspaces in Vibe can be used to organize information inside of existing workspaces, creating 
different levels of hierarchy within a workspace. 

You can also use other types of workspaces to create hierarchies. For information explaining the 
advantages and disadvantages of using each type of workspace, see Section 2.7, “Creating Workspace 
Hierarchies,” on page 21.

2.2 Creating and Managing a Discussions Workspace
The Discussions workspace can be the home page for a set of discussion forums. You can also use the 
Discussions workspace to house other types of folders. 

Discussions workspaces can be particularly useful for site administrators, or other Kablink Vibe users 
who are responsible for creating the overall structure of the Vibe site. For example, you can use a 
Discussions workspace to organize a set of company-wide discussions on various topics. This can 
help organize your Vibe site, so users know where they should go if they are looking for a particular 
discussion forum.

 Section 2.2.1, “Creating a Discussions Workspace,” on page 17

 Section 2.2.2, “Using Discussions Workspaces to Create Hierarchies,” on page 17
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2.2.1 Creating a Discussions Workspace

1 Navigate to the place in Vibe where you want to create the Discussions workspace. 

Depending on your rights, you might create this workspace at the Global level, if you are 
creating a company-wide Discussions workspace; or you might create this workspace in a lower-
level workspace, if the Discussions workspace is intended for a smaller number of Vibe users.

2 Click Workspace > New Workspace in the Action toolbar.

The New Workspace page is displayed.

3 In the Workspace Title field, specify a name for the Discussions workspace.

4 In the Workspace section, select Discussions Workspace.

5 In the Workspace Folders section, select Discussion.

You can add additional Discussion folders after the workspace has been created.

6 Click OK.

2.2.2 Using Discussions Workspaces to Create Hierarchies

Discussions workspaces in Kablink Vibe can be used to organize information inside of existing 
workspaces, creating different levels of hierarchy within a workspace. 

You can also use other types of workspaces to create hierarchies. For information explaining the 
advantages and disadvantages of using each type of workspace, see Section 2.7, “Creating Workspace 
Hierarchies,” on page 21.

2.3 Creating and Managing a Basic Workspace
Basic workspaces in Kablink Vibe can be used to organize information inside of existing workspaces, 
creating different levels of hierarchy within a workspace. 

You can also use other types of workspaces to create hierarchies. For information explaining the 
advantages and disadvantages of using each type of workspace, see Section 2.7, “Creating Workspace 
Hierarchies,” on page 21.

To create a basic workspace:

1 Navigate to the place in Vibe where you want to create the basic workspace. 

2 Click Workspace > New Workspace in the Action toolbar.

The New Workspace page is displayed.

3 In the Workspace Title field, specify a name for the basic workspace.

4 In the Workspace section, select Workspace.

5 In the Workspace Folders section, select the folders that you want the new workspace to contain.

You can add additional folders after the workspace has been created.

6 Click OK.
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2.4 Creating and Managing a Project Management Workspace
Project Management workspaces include special accessories that help leaders track the progress of 
task completion for potentially large projects. Although Project Management workspaces can contain 
any type of folder, they are specifically designed to work in conjunction with Tasks and Milestones 
folders.

 Section 2.4.1, “Creating a Project Management Workspace,” on page 18

 Section 2.4.2, “Managing a Project Management Workspace,” on page 18

 Section 2.4.3, “Understanding Tasks and Milestones,” on page 19

2.4.1 Creating a Project Management Workspace

1 Navigate to the place in Kablink Vibe where you want to create the Project Management 
Workspace.

2 Click Workspace > New Workspace in the Action toolbar.

The New Workspace page is displayed.

3 In the Workspace Title field, specify a name for the Project Management workspace.

4 In the Workspace section, select Project Management Workspace.

5 Click OK.

2.4.2 Managing a Project Management Workspace

After you create the Project Management workspace, notice that the workspace contains key folders, 
such as a Tasks folder, Milestones folder, Files folder, and so forth.

The home page of the Project Management workspace provides the following features that enable 
you to better manage your project:

Task Summary Accessory: This accessory lists all of the tasks that exist in the Tasks folder of your 
Project Management workspace.

To modify the information in this accessory, navigate to the Tasks folder of this Project Management 
workspace. For information about Tasks folders, see “Working with Tasks Folders” in the Kablink Vibe 
3.3 User Guide.

Project Information Box: Displays the Status, Manager, and Due Date of the project.

To modify this information:

1 Click Workspace > Edit Workspace in the Action toolbar.

2 In the Project Information Box section, modify the Manager, Status, and Due Date fields as needed.

3 Click OK.

Project Statistics: Displays the current task and milestone statistics that are associated with the 
project.
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2.4.3 Understanding Tasks and Milestones

Because tasks and milestones contribute important information to your Project Management 
workspace, it is important that you understand how they work.

 “Understanding Tasks” on page 19

 “Understanding Milestones” on page 19

Understanding Tasks

Tasks folders keep track of the progress made in completing work assignments. For information 
about Tasks folders, see “Working with Tasks Folders” in the Kablink Vibe 3.3 User Guide.

Understanding Milestones

The Milestones folder contains the various milestones for a project. Each milestone entry has specific 
Tasks folders that are associated with the milestone. When all of the tasks in the Tasks folders are 
complete, you can mark the milestone that is associated with those tasks as completed.

 “Creating a Milestone” on page 19

 “Using the Milestones Folder” on page 20

 “Modifying a Milestone” on page 20

Creating a Milestone

1 Navigate to the Milestones folder in your Project Management workspace.

2 Click Add Milestone.

The Milestone page is displayed.

3 Specify the following information:

Title: Provide a title for the milestone.

Description: Describe the milestone.

Due Date: Specify when the milestone is due.

Responsible: Specify the users who are responsible for completing the milestone.

Responsible Groups: Specify the groups who are responsible for completing the milestone.

Responsible Teams: Specify the teams who are responsible for completing the milestone.

Send an E-Mail Notification to Responsibles: Select this option if you want Vibe to send an e-
mail notification and iCal task/appointment to all of the users, groups, or teams that you 
associate with the entry.

For more information on iCal functionality in Vibe, see “Synchronizing Tasks and Calendars to a 
Desktop Application” in the Kablink Vibe 3.3 User Guide.

Status: Use the drop-down list to specify a status for the milestone (Open, Reopen, Completed).

Task Folders: Use the tree to navigate to and select the Tasks folders that you want to associate 
with the milestone.

The tasks in these Tasks folders must be completed before the milestone can be marked as 
Completed.

Attachments: Attach any appropriate files.
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Subscribe to This Entry: You can configure Vibe to send you notifications when activity takes 
place in this entry. For more information, see “Subscribing to a Folder or Entry” in the Kablink 
Vibe 3.3 User Guide.

Send E-Mail When Entry is Submitted: To ensure that certain co-workers are aware of your 
entry, you can send them an e-mail directly from Vibe, notifying them that an entry has been 
created. For more information, see “Filling Out the Send E-Mail Page” in the Kablink Vibe 3.3 User 
Guide.

Using the Milestones Folder

The Milestones folder contains the following columns that contain information about each milestone:

Name: Displays the name of the milestone.

Responsible: Displays the people who are responsible for the milestone.

Tasks: Displays the Tasks folders that are associated with the milestone.

Mouse over the colors in the bar chart, and Vibe explains the value (needs action, in process, 
completed).

Status: Displays the status of the milestone.

Due date: Displays the due date of the milestone.

Modifying a Milestone

1 In the Milestones folder, click the milestone name in the Name column.

The milestone entry is displayed.

2 In the Entry toolbar, click Modify.

The Milestone page is displayed.

3 Make any modifications, then click OK.

You might need to refresh the page for your changes to be displayed.

2.5 Creating and Managing a Team Workspace Root Workspace
A Team Workspace Root workspace is designed to contain multiple team workspaces. Use this type 
of workspace if you want to create additional team workspaces as sub-workspaces to this workspace. 
When users with appropriate rights view this workspace, they can easily create a new team 
workspace by clicking the Add a Team Workspace button, as described in “Creating a Highly Visible 
Team Workspace” in the Kablink Vibe 3.3 User Guide. The Add a Team Workspace button is not displayed 
in regular team workspaces. 

You can control who has access to create workspaces in Team Workspace Root workspaces by 
modifying the access controls, as described in Chapter 4, “Controlling Access,” on page 41.

For more information on organizing team workspaces for a Kablink Vibe site, see “Organizing Team 
Workspaces” in the Kablink Vibe 3.3 Administration Guide.
20 Kablink Vibe 3.3 Advanced User Guide



To create a Team Workspace Root workspace:

1 Navigate to the location where you want to create the Team Workspace Root workspace.

2 Create a regular team workspace, as described in “Creating a Team Workspace inside of an 
Existing Team Workspace” in the Kablink Vibe 3.3 User Guide.

3 Navigate to the workspace that you just created in Step 2.

4 Click Workspace > Configure Views, URLs and Controls in the Action toolbar.

5 On the Configure Workspace View tab, in the Default View section, select Team Workspace Root.

6 Click Apply > Close.

2.6 Using Global Workspaces
Global workspaces contain information beyond the scope of teamwork that might be of interest 
broadly across your organization.

Global workspaces can be created only by Kablink Vibe administrators. For more information on 
Global workspaces, see “Creating Global Workspaces” in the Kablink Vibe 3.3 Administration Guide.

2.7 Creating Workspace Hierarchies
Creating hierarchies in Kablink Vibe is a powerful way to organize workspaces in a meaningful way. 
Hierarchies can make information easier to find and increase effectiveness across the Vibe site.

Vibe provides three types of workspaces that you can use to create hierarchies within existing 
workspaces. Each type of workspace has its advantages and disadvantages for creating workspace 
hierarchies. Depending on your objectives and your environment, you might want to use any of the 
following types of workspaces:

 Section 2.7.1, “Discussions Workspaces,” on page 21

 Section 2.7.2, “Basic Workspaces,” on page 22

 Section 2.7.3, “Team Workspaces,” on page 22

2.7.1 Discussions Workspaces

If you don’t anticipate your workspace having hundreds or thousands of sub-folders, Discussions 
workspaces are recommended over basic workspaces and team workspaces.

The following sections describe the advantages and disadvantages of using a Discussions workspace 
to create hierarchies within existing workspaces:

 “Advantages” on page 21

 “Disadvantages” on page 22

Advantages

 Retains the access control rights of higher-level (parent) workspaces by default

 Lists sub-folders and sub-workspaces on the workspace home page (and displays how many 
items are in each folder)
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Disadvantages

 Does not scale well (if you have hundreds or thousands of sub-folders, you should use a basic 
workspace to improve performance)

2.7.2 Basic Workspaces

The following sections describe the advantages and disadvantages of using a basic workspace to 
create hierarchies within existing workspaces:

 “Advantages” on page 22

 “Disadvantages” on page 22

Advantages

 Retains the access control rights of higher-level (parent) workspaces by default

 Scales well (because basic workspaces do not list sub-folders and sub-workspaces on the 
workspace home page)

Disadvantages

 Does not list sub-folders and sub-workspaces on the workspace home page

2.7.3 Team Workspaces

The following sections describe the advantages and disadvantages of using a Team workspace to 
create hierarchies within existing workspaces:

 “Advantages” on page 22

 “Disadvantages” on page 22

Advantages

 Lists sub-folders and sub-workspaces on the workspace home page (and displays how many 
items are in each folder)

Disadvantages

 Does not retain the access control rights of higher-level (parent) workspaces by default

 Does not scale well (if you have hundreds or thousands of sub-folders, you should use a basic 
workspace to improve performance)
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2.8 Creating Custom Workspace Views
Kablink Vibe enables you to create custom workspace views. Workspace views define what is 
displayed on the main page of your workspace. When you create custom workspace views, you can 
configure workspaces to display optional features such as remote applications, attachments, and 
more.

For information on how to create custom workspace views, see Chapter 7, “Creating Custom 
Workspace Views,” on page 87.

2.9 Setting a Maximum Number of File Versions
You can configure folders and workspaces to allow only a certain number of versions for each file 
within the folder or workspace. For more information, see Section 3.4.1, “Automatically Deleting 
Minor File Versions That Exceed the Allowed Maximum,” on page 31.

2.10 Setting a File Upload Size Limit
You can set a limit on the size of files users can upload to your workspaces and folders. For more 
information, see Section 3.5, “Limiting the File Upload Size for Folders and Workspaces,” on page 33.

2.11 General Workspace Management
If you have appropriate rights, you can perform various types of management functions on a 
workspace, such as copying the workspace to another location, moving the workspace, adding 
folders to the workspace, deleting the workspace, and so forth.

For information on how to perform these and other types of management tasks, see “General 
Workspace Management” in the Kablink Vibe 3.3 User Guide.
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3 3Managing Folders

Kablink Vibe enables you to manage your folders in the following ways:

 Section 3.1, “Managing Folder Views,” on page 25

 Section 3.2, “Working with Folder Entry Types,” on page 26

 Section 3.3, “Enabling Folders to Receive Entries through E-Mail,” on page 29

 Section 3.4, “Limiting File Versions for Folders and Workspaces by Configuring Automatic 
Deletion,” on page 31

 Section 3.5, “Limiting the File Upload Size for Folders and Workspaces,” on page 33

 Section 3.6, “Setting Up a Folder or External E-Mail Address to Receive All Sent E-Mail 
Messages,” on page 33

 Section 3.7, “Configuring Folders to Send E-Mail Notifications to Other Users,” on page 34

 Section 3.8, “Setting Up and Using WebDAV,” on page 35

 Section 3.9, “Viewing Vibe Folders as RSS or Atom Feeds,” on page 38

 Section 3.10, “Applying Landing Page Elements to a Folder,” on page 38

3.1 Managing Folder Views
Kablink Vibe enables you to change the way you and other users view your folder. You can change 
the default view, or allow multiple views. 

For example, you might have a Tasks folder where the start date and end date are particularly 
important. You can configure your Tasks folder to be displayed in a Calendar folder view to place 
emphasis on the start and end dates of tasks. You can make this view the default view, or allow users 
to toggle between alternate folder views that you pre-enable.

 Section 3.1.1, “Changing the Default Folder View,” on page 25

 Section 3.1.2, “Enabling Alternate Folder Views,” on page 26

3.1.1 Changing the Default Folder View

Vibe enables you to change the default view of folders for which you have appropriate rights. This 
can be an existing folder view or a custom folder view that you created. For information about how to 
create a custom folder view, see Chapter 8, “Creating Custom Folder Views,” on page 97.

 “Enabling Views to Be Used as the Default View” on page 26

 “Selecting a New Default Folder View” on page 26
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Enabling Views to Be Used as the Default View

Before you can set a view as the default folder view, you need to enable that view

1 Navigate to the folder where you want to change the default view.

2 Click Folder > Configure Views, URLs and Controls in the Action toolbar.

3 On the Folder Views, Entries and Workflows tab, in the Allowed Views section, select the view whose 
look best presents your folder list or workspace.

4 Click Apply.

The folder view has now been added to the Default View section, and can be chosen as the default 
view, as described in “Selecting a New Default Folder View” on page 26.

Selecting a New Default Folder View

1 On the Folder Views, Entries and Workflows tab, in the Default View section, select the folder view 
that you enabled in “Enabling Views to Be Used as the Default View” on page 26.

2 Click Apply > Close.

3.1.2 Enabling Alternate Folder Views

Because only folder owners have rights to set the default view of a folder, Vibe enables folder owners 
to select alternate views that external users of the folder are allowed to use, if they are not satisfied 
with the default view, or feel more comfortable using another view.

1 Navigate to the folder where you want to enable alternate views.

2 Click Folder > Configure Views, URLs and Controls in the Action toolbar.

3 On the Folder Views, Entries and Workflows tab, in the Allowed Views section, select all of the views 
that you want to enable as alternate folder views.

4 Click Apply > Close.

Users can now view the folder in an alternate view.

1 Click Folder > Folder Options in the Action toolbar.

The Folder Options dialog box is displayed.

2 In the View Options section, select the desired alternate view, then click OK.

3.2 Working with Folder Entry Types
 Section 3.2.1, “Enabling Alternate Folder Entry Types,” on page 27

 Section 3.2.2, “Changing the Entry Type for Entries in a Folder,” on page 27

 Section 3.2.3, “Changing the View Definitions for Existing Folders and Folder Entries,” on 
page 28
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3.2.1 Enabling Alternate Folder Entry Types

You can select the types of entries that you want to allow users to create in a certain folder. You can 
configure your folder to allow alternate entry types, or you can change the current default entry type. 
If you enable multiple entry types, users who submit entries into this folder can choose which type of 
entry they want to add, such as a task entry, calendar entry, and so forth.

1 Navigate to the folder where you want to enable alternate entry types.

2 Click Folder > Configure Views, URLs and Controls in the Action toolbar.

3 On the Folder Views, Entries and Workflows tab, in the Default Entry Types section, select the entry 
types that you want to allow users to create in the folder.

4 Click Apply > Close.

If you enable additional entry types, users who submit entries into this folder can click New in the 
Folder Entry toolbar, then use the drop-down list to choose the type of entry they want to add, 
depending on which types of entries you enabled on the folder.

Site administrators and folder owners can use the Form and View Designers functionality to create 
new entry types (custom forms), which then appear in this list. (When folder owners create new 
entry types, those entry types are listed in the Local Definitions section of this list.)

For more information on how to create custom entry types, see Chapter 9, “Designing Custom Folder 
Entry Forms,” on page 109.

3.2.2 Changing the Entry Type for Entries in a Folder

You can change an entry from one type to another type. For example, suppose you are using a 
Discussion entry to discuss the new marketing logo for a product. The discussion results in an action 
item for you to refine the look of the new logo. You can then change the Discussion entry to a Task 
entry for you to keep track of this new action item.

You can change the entry type for a single entry or for every entry of a certain type in a folder. 

If the new entry type that you choose contains elements that were not in the original entry type, the 
new elements are displayed as blank in existing entries. If the new entry type that you choose doesn’t 
have elements that did exist in the original entry type, any information that was in those elements is 
removed from the entries. However, the information is not deleted, and is reinstated if the entry is 
changed back to the original entry type.

 “Changing the Entry Type for All Entries In a Folder” on page 27

 “Changing the Entry Type for a Single Entry” on page 28

Changing the Entry Type for All Entries In a Folder

You can simultaneously change the entry type for all entries of a certain type in a given folder. 
Changing the entry type for entries as described in this section changes the entry form that is used 
when creating an entry.

1 Navigate to the folder that contains the entries that you want to change.

2 Click Folder > Configure Views, URLs and Controls.

3 Click the Entry Type tab.
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4 In the Entry Type To Be Changed drop-down list, select the current entry type for entries in the 
folder that you want to change to a different entry type.

5 In the New Entry Type drop-down list, select the new entry type that you want to convert the 
entries to.

6 Click OK, then click OK again to confirm.

Changing the Entry Type for a Single Entry

1 Navigate to and open the entry that you want to change.

2 Click Actions > Change Entry Type.

3 In the New Entry Type drop-down list, select the entry type for the entry.

4 Click OK.

3.2.3 Changing the View Definitions for Existing Folders and Folder Entries

View definitions affect how a folder or entry is displayed. You can simultaneously change the 
definitions for folders and folder entries that have already been created. You can change all sub-
folders to match the parent folder, and you can change all entries within a given folder to be of a 
specific entry type.

This feature must first be enabled by your Kablink Vibe administrator. If it is not enabled, it is not 
visible. For information on how to enable this feature, see “Enabling Folder Administrators to Apply 
Definition Settings to Sub-Folders and Entries” in the Kablink Vibe 3.3 Administration Guide.

 “Applying Definition Settings to All Sub-Folders” on page 28

 “Applying Definition Settings to Existing Entries” on page 28

Applying Definition Settings to All Sub-Folders

You can apply the folder definition settings of a parent folder to all sub-folders. For example, if you 
have a Discussions folder that contains sub-folders, but not all of the sub-folders are Discussions 
folders, you can simultaneously convert all the sub-folders to be displayed as Discussions folders.

1 Navigate to the folder where you want to apply entry definition types to folders or entries that 
have already been created.

2 Click Folder > Configure Views, URLs and Controls in the Action toolbar.

3 On the Folder Views, Entries and Workflows tab, in the Recursively apply section, select Change 
contained folders to inherit this folder’s definitions.

4 Click Apply > Close.

All definition settings on the Folder Views, Entries and Workflows tab are applied to all sub-folders.

Applying Definition Settings to Existing Entries

You can convert all the entries that are contained within a specific folder to be of a single entry type. 
For example, a user might begin a discussion entry in a Discussion folder, then move the entry to the 
Tasks folder after it is decided that something needs to be done in order to resolve the discussion. 
After the discussion entry is added to the Tasks folder, the entry can be converted to a task entry.
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IMPORTANT: Changing entry definition settings as described in this section changes all entries 
within the folder and all sub-folders to be the same entry type. You should not perform the steps in 
this section if you want your folder and sub-folders to contain multiple types of folder entries, as 
described in Section 3.2.1, “Enabling Alternate Folder Entry Types,” on page 27.

To make all folder entries the same within a specific folder:

1 Navigate to the folder where you want to apply entry definition types to folders or entries that 
have already been created.

2 Click Folder > Configure Views, URLs and Controls in the action toolbar.

3 On the Folder Views, Entries and Workflows tab, in the Recursively apply section, select Change 
contained folders to inherit this folder’s definitions, then select Change contained entries to be of the 
following entry type.

4 In the drop-down list, select the entry type that you want to apply to all existing entries in the 
folder.

To add entry types to this drop-down list, select the entry types in the Default Entry Types section, 
then click Apply.

5 Click Apply > Close.

3.3 Enabling Folders to Receive Entries through E-Mail
Kablink Vibe enables you to e-mail entries into folders. This is useful if you don’t have access to the 
Vibe site and still want to create an entry. You can also send text messages into folders, so you can still 
capture thoughts and contribute to conversations when you don’t have access to a computer or the 
Internet.

To enable folders to receive entries via e-mail, complete the following sections:

 Section 3.3.1, “Enabling and Configuring the Inbound E-Mail Server,” on page 29

 Section 3.3.2, “Enabling Incoming E-Mail for the Vibe Site,” on page 29

 Section 3.3.3, “Enabling E-Mail Posting with a Simple URL,” on page 30

 Section 3.3.4, “Defining Who Has Access to E-Mail Entries,” on page 30

3.3.1 Enabling and Configuring the Inbound E-Mail Server

The Vibe administrator should have enabled and configured the inbound e-mail server during the 
Vibe installation, as described in “Enabling Inbound E-Mail” in the Kablink Vibe 3.3 Installation Guide. 

For information about enabling and configuring inbound e-mail after the Vibe installation, see 
“Reconfiguring the Vibe Site” in the Kablink Vibe 3.3 Administration Guide.

3.3.2 Enabling Incoming E-Mail for the Vibe Site

For folders to be able to receive entries via e-mail, Vibe administrators need to enable the Vibe site to 
allow incoming e-mail.

For information on how to enable Vibe to allow incoming e-mail, see “Disabling/Enabling Inbound E-
Mail Postings” in the Kablink Vibe 3.3 Administration Guide.
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3.3.3 Enabling E-Mail Posting with a Simple URL

When you define a simple URL for a folder, Vibe creates a URL that enables you to quickly navigate 
to the folder, and also creates a corresponding e-mail address that users of the folder can e-mail to.

1 Navigate to the folder where you want to define the URL.

2 Click Folder > Configure Views, URLs and Controls in the Action toolbar.

3 Click the Simple URLs and E-mail Addresses tab.

4 In the Define a simple URL for this folder or workspace section, specify the URL that you want to use 
to reference the folder.

5 Click Add.

6 Select Allow e-mail posts to this folder via the following addresses.

7 Click Apply, then click Close.

You can now make entries to the folder by e-mail or by text-messaging your entry to the e-mail 
address that you created, as described in “Adding Entries to a Folder Via E-Mail” in the Kablink Vibe 
3.3 User Guide.

3.3.4 Defining Who Has Access to E-Mail Entries

By default, only users with rights to create entries in a particular folder can e-mail entries into that 
folder.

Vibe enables you to view who has rights to create entries in a folder, grant rights to other Vibe users, 
or configure the folder to allow all users to create entries by e-mailing into it.

 “Viewing Who Has Rights” on page 30

 “Granting Rights to Other Vibe Users” on page 30

 “Setting Up a Folder That All Users Can Send E-Mail To” on page 31

Viewing Who Has Rights

1 Navigate to the folder where you want to view who currently has rights to create entries in the 
folder.

2 Click View > Who Has Access in the Action toolbar.

3 In the provided table, the Create Entries section lists all of the users who have rights to create 
entries in the folder.

These are the users who have rights to e-mail entries into the folder.

Granting Rights to Other Vibe Users

You can grant other Vibe users rights to create entries in a folder.

For information on how to change access control settings in a folder, see Section 4.2.1, “Controlling 
Access to Workspaces and Folders,” on page 45.
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Setting Up a Folder That All Users Can Send E-Mail To

You can enable your Vibe folder to receive e-mail entries from all users, regardless of whether they 
have access to create entries in the folder or not.

This enables e-mail entries to be submitted by anybody, inside or outside of the Vibe system. If you 
are worried about receiving spam messages in your folder, do not set up your folder to accept e-mail 
entries in the way described in this section.

1 Navigate to the folder where you want to enable all users to create entries via e-mail.

2 Click Folder > Access Control in the Action toolbar.

3 Ensure that No is selected in the Inherit Role Membership section, then click Apply.

4 In the table, click Add a User.

5 In the provided field, use the type-to-find functionality and specify E-mail Posting Agent.

6 In the E-mail Posting Agent row, select the check box in the Participant column.

7 Click Save Changes > Close.

Now all users can create entries in this folder via e-mail, using the e-mail address that you 
created in Section 3.3.3, “Enabling E-Mail Posting with a Simple URL,” on page 30.

3.4 Limiting File Versions for Folders and Workspaces by 
Configuring Automatic Deletion
Because a significant amount of data can be consumed by old versions of files, you can set file version 
restrictions for workspaces and folders that you own. You might want to do this if the Vibe 
administrator has set a data quota on workspaces and folders throughout the Vibe site, or if you 
simply want to limit the amount of clutter in your folders and workspaces. 

You can configure folders and workspaces to automatically delete minor file versions that exceed the 
maximum number that you set for each file, and you can configure folders to automatically delete 
minor file versions after a specified number of days. Major file versions are never automatically 
deleted.

 Section 3.4.1, “Automatically Deleting Minor File Versions That Exceed the Allowed Maximum,” 
on page 31

 Section 3.4.2, “Automatically Deleting Minor File Versions After a Specified Number of Days,” 
on page 32

3.4.1 Automatically Deleting Minor File Versions That Exceed the Allowed 
Maximum

You can configure folders and workspaces to allow only a certain number of file versions for each file 
version set within the folder or workspace. (A file version set includes the major file version and all 
minor file versions. For more information about major and minor file versions, see “Incrementing the 
Major Version Number of a File” in “Working with Files in a Folder Entry” in the Kablink Vibe 3.3 User 
Guide.) 

After the maximum number of versions is reached and a new minor version is created in the file 
version set, the oldest minor version is automatically deleted and cannot be recovered.
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Major versions are never deleted, so if there is a minor version that you want to keep from being 
deleted, you can increment it to a major version, as described in “Incrementing the Major Version 
Number of a File” in “Working with Files in a Folder Entry” in the Kablink Vibe 3.3 User Guide.

This setting is inherited by all sub-folders, so any sub-folders are also restricted to the maximum 
number that you set. For example, if you specify a maximum version number of 5 in Folder A, Sub-
Folder B also has a maximum version number of 5. This means that each file in the folder can have a 
maximum of 5 versions associated with it.

The maximum number that you set includes the major file version as well as any minor file versions. 
For example, if you set the maximum version number to be 5, each file version set can have one major 
file version and four minor file versions.

To configure a folder or workspace to have a maximum number of allowed file versions:

1 Navigate to the folder or workspace where you want to set the maximum number of allowed file 
versions.

2 Click Folder > Configure Views, URLs and Controls if you are setting the number on a folder.

or

Click Workspace > Configure Views, URLs and Controls if you are setting the number on a 
workspace.

3 Click the Versioning and Folder Settings tab.

4 Select Enable File Versions if it is not already selected, then specify the maximum number of 
allowed versions in the Maximum Versions field.

5 (Conditional) If the text (Inherited) appears next to the Maximum Versions field, click Stop 
Inheriting from Parent. This configures the folder or workspace to not inherit this setting from a 
higher-level folder or workspace.

6 Click OK.

3.4.2 Automatically Deleting Minor File Versions After a Specified Number of 
Days

You can configure all minor versions of each file to be automatically deleted after a specified number 
of days (major versions are never deleted). When you configure a folder in this way, all versions of 
the document that are not a major version are deleted after the specified number of days. (For more 
information about major and minor versioning, see “Incrementing the Major Version Number of a 
File” in “Working with Files in a Folder Entry” in the Kablink Vibe 3.3 User Guide.)

The setting to automatically delete old versions is not inherited by sub-folders; it must be configured 
individually for each folder. Because of this, you can enable this feature only on individual folders, 
and not on the parent workspace. If the Vibe administrator has configured file versions throughout 
the Vibe site to be automatically deleted after a certain number of days, you can either disable the 
automatic deletion or specify a new day limit for each folder.

1 Navigate to the folder where you want to specify the number of days to wait before the excess 
versions are deleted.

2 Click Folder > Configure Views, URLs and Controls.

3 Click the Versioning and Folder Settings tab.

4 Select Enable Version Aging, then specify the number of days in the Delete Old Versions after field.

5 Click OK.
32 Kablink Vibe 3.3 Advanced User Guide



3.5 Limiting the File Upload Size for Folders and Workspaces
The file upload size limit conserves disk space in your folders and workspaces because it prevents 
users from uploading large files. The default size limit for uploading files into your Vibe site is 2 GB. 
This limit can be increased or decreased by your Vibe administrator. You can change the limit for the 
workspaces and folders that you are the owner of, but you cannot make the limit greater than what is 
set by your Vibe administrator.

This setting is inherited by all sub-folders, so any sub-folders are also restricted to the size limit that 
you set. 

1 Navigate to the folder or workspace where you want to set a limit on the size of files that can be 
uploaded.

2 Click Folder > Configure Views, URLs and Controls if you are setting the limit on a folder.

or

Click Workspace > Configure Views, URLs and Controls if you are setting the limit on a workspace.

3 Click the Versioning and Folder Settings tab.

4 In the File Size Limit section, specify the limit in the Maximum Size field.

5 Click OK.

3.6 Setting Up a Folder or External E-Mail Address to Receive 
All Sent E-Mail Messages
Like a personal e-mail Outbox for the Vibe site, you can configure a folder or any e-mail address to 
receive all e-mail messages that you personally send from the Vibe site. This can help you better track 
your activity.

Vibe administrators might need to enable this functionality, as described in “Enabling Users to 
Configure a Folder or External E-Mail Address to Receive Sent E-Mails” in “Managing E-Mail 
Configuration” in the Kablink Vibe 3.3 Administration Guide.

Actions that cause e-mail messages to be sent from the Vibe site and to be saved in the Vibe folder 
that you designate are:

 Using the E-Mail Team and E-Mail Contributors options, as described in “Informing Others about 
a Folder or Workspace” in the Kablink Vibe 3.3 User Guide.

 Using the Share this Entry option, as described in “Sharing an Entry” in the Kablink Vibe 3.3 User 
Guide.

 Using the Send E-Mail When Entry is Submitted option, as described in the “Sending an E-Mail 
about an Entry” in the Kablink Vibe 3.3 User Guide.

 Filling in the Announcement field when creating or editing a team workspace, as described in 
“Creating a New Workspace” and “Sending E-Mail to Team Members and Announcing the 
Workspace after Its Creation” in the in the Kablink Vibe 3.3 User Guide.

NOTE: Certain types of e-mail messages that do not require you to personally add text, such as 
setting digest notifications or workflow notifications, are not saved to the folder that you designate.
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To set up a folder or external e-mail address to receive all e-mail messages that you send from the 
Vibe site:

1 Create a new folder in the workspace where you want the folder to reside.

For information on how to create a folder, see “Creating a New Folder” in the Kablink Vibe 3.3 
User Guide.

2 Define a simple URL for the folder, and allow e-mails to be sent to the folder.

For information on how to define a URL for a folder and allow e-mailing into it, see Section 3.3.3, 
“Enabling E-Mail Posting with a Simple URL,” on page 30.

3 Navigate to your user profile page by clicking My Workspace, then clicking Profile.

The Profile page is displayed.

4 Click Edit.

5 In the BCC Email Address field, specify the e-mail address of the folder or external e-mail address.

If the BCC Email Address field does not exist, contact your Vibe administrator.

The folder e-mail address was created when you defined a simple URL for the folder and 
allowed e-mail posting into the folder, as described in Step 2.

6 Click OK.

3.7 Configuring Folders to Send E-Mail Notifications to Other 
Users
As a folder owner, you can configure Kablink Vibe to send other users e-mail notifications, in order to 
inform them of any activity in the folder and any sub-folders of the folder. If a user does not want to 
be informed of activity in the folder, the user can change the notification settings. A user’s individual 
settings override or cancel notifications established by folder owners.

You cannot directly configure a sub-folder to send e-mail notifications; instead, you must configure 
the parent folder.

1 Navigate to the folder from where you want to send the e-mail notifications.

2 Click Folder > E-Mail Settings in the Action toolbar.

The E-Mail Settings page is displayed.

3 In the Select the Type of E-Mail Notification section, select the type of e-mail notification that you 
want to send.

 Digest: Vibe sends one message that summarizes all of the activity in the folder and its sub-
folders (available for folders only). Vibe sends digest notifications at a schedule established 
by your site administrator.

As a folder owner, you can set your own schedule for digest notifications. For more 
information, see Step 5.

 Individual Messages (with Attachments): Vibe sends one message for every new or 
changed entry, and messages include attached files. Vibe sends all types of individual 
notifications every five minutes.

 Individual Messages without Attachments: Vibe sends one message for every new or 
changed entry. The e-mail messages do not include files that might be attached to the new 
or changed entries. Vibe sends all types of individual notifications every five minutes.
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 Message Suitable for Text Messaging: Vibe sends a message suitable for viewing as a text 
message. The content of the message includes only the entry title and a link to the new or 
changed entry. Vibe sends all types of individual notifications every five minutes.

4 Specify the users who you want to receive the e-mail notifications.

You can specify specific e-mail addresses, users, groups, or send the notifications to all team 
members.

5 (Optional) Click Set a Different Schedule for This Folder if you want to set a digest schedule for the 
folder that is different from the digest schedule set by the site administrator.

6 Click Apply > Close.

3.8 Setting Up and Using WebDAV
WebDAV is a standard collaborative editing and file management protocol. Kablink Vibe supports 
the use of WebDAV tools, and enables you to manage your Vibe files through WebDAV. Vibe utilizes 
WebDAV when editing attached files, and you can also set up WebDAV to view documents in a Vibe 
folder.

If you are using WebDAV on Windows 7, you or your Vibe administrator must ensure that your 
workstation meets all the necessary prerequisites in order to support WebDAV, as described in 
“Configuring Vibe to Support WebDAV on Windows 7” in the Kablink Vibe 3.3 Administration Guide.

If you cannot use WebDAV as described in the following sections, consult your Vibe administrator.

 Section 3.8.1, “Using WebDAV to Edit Individual Files,” on page 35

 Section 3.8.2, “Using WebDAV on a Vibe Folder,” on page 36

3.8.1 Using WebDAV to Edit Individual Files

You can use either of the following methods to edit files through WebDAV:

 “Editing a File Directly from the Vibe Interface” on page 35

 “Using the WebDAV URL to Open the File in a Document Editor” on page 36

Editing a File Directly from the Vibe Interface

When you use the Edit-in-Place functionality to edit a Vibe file, as described in “Editing Files” in the 
Kablink Vibe 3.3 User Guide, Vibe uses WebDAV to retrieve, lock, modify, and unlock the file. No 
special setup or configuration is needed in Vibe to use WebDAV in this way.

NOTE: Edit-in-Place functionality is not supported on Mac when you use Microsoft Office as your 
document editor. To use Edit-in-Place functionality on Mac, you must use OpenOffice as your 
document editor.
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Using the WebDAV URL to Open the File in a Document Editor

You can obtain the WebDAV URL for individual files within Vibe, as described in “Obtaining the 
WebDAV URL for a File” in the Kablink Vibe 3.3 User Guide.

After you have obtained the WebDAV URL for the file, you can specify the URL in a document editor 
such as Microsoft Office to open the file. Refer to the documentation for your specific document 
editor for instructions on how to accomplish this.

3.8.2 Using WebDAV on a Vibe Folder

When you use WebDAV on a Vibe folder, you can create a mapped drive to a Vibe folder, enabling 
users to browse and navigate the Vibe folder in a WebDAV interface. To manage your Vibe folders 
through a WebDAV interface, you must first configure the Vibe folder to support WebDAV, then 
create a mapped drive to the Vibe folder.

NOTE: Because of limitations with WebDAV on Mac, you cannot use WebDAV to view a Vibe folder 
in a Mac environment.

 “Prerequisite for Windows XP and Windows Vista” on page 36

 “Configuring a Folder to Support WebDAV” on page 36

 “Viewing the Vibe Folder in Your Windows Environment” on page 37

 “Viewing the Vibe Folder in Your Linux Environment” on page 37

Prerequisite for Windows XP and Windows Vista

When you use WebDAV on a Vibe folder on Windows XP or Windows Vista, you must first install the 
Software Update for Web Folders (KB907306). For information on how to perform this installation, 
see “Software Update for Web Folders” (http://www.microsoft.com/downloads/
details.aspx?familyid=17c36612-632e-4c04-9382-987622ed1d64&displaylang=en), and follow the 
provided instructions.

Configuring a Folder to Support WebDAV

When a folder is configured to support WebDAV, Vibe requires that each file added to the folder have 
a unique name. This is because when you view a folder through WebDAV, you see only the files that 
are within the folder and not the entries that contain each file. Some folder types are configured to 
support WebDAV by default, and some are not.

Files folders and Photo Album folders are configured by default to support WebDAV, because they 
require that all files have a unique name.

All other types of Vibe folders, however, must be manually configured to support WebDAV. This is 
because Vibe allows you to add multiple files with the same name to a single folder, if each file is 
added as a separate entry. 

To configure a folder to support WebDAV by requiring that all files uploaded to the folder have a 
unique name:

1 Navigate to the folder that you want to configure to support WebDAV.

2 Click Folder > Edit Folder in the Action toolbar.
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3 Toward the bottom of the page, select Require that all files uploaded into this folder have a unique 
name.

4 Click OK.

For information about what users experience when they try to add a file to a WebDAV-enabled folder 
when the file has the same name as a file that has already been added to the folder, see “Adding Files 
to a Files Folder and Other WebDAV-Enabled Folders” in the .

Viewing the Vibe Folder in Your Windows Environment

After your Vibe folder has been configured to support WebDAV, as described in “Configuring a 
Folder to Support WebDAV” on page 36, you can view the Vibe folder in your Windows environment 
in either of the following ways:

 “Creating a Mapped Drive to the Vibe Folder” on page 37

 “Adding a Vibe Folder as a Network Place” on page 37

Creating a Mapped Drive to the Vibe Folder

If you are using Windows XP as your client operating system, creating a mapped drive to the Vibe 
folder as described in this section does not work. Instead, add the Vibe folder as a network place, as 
described in “Adding a Vibe Folder as a Network Place” on page 37.

1 Navigate to the folder where you want to create the mapped drive.

2 Click the link in the footer.

3 In the provided table, copy the WebDAV URL.

4 Map a drive to the folder.

You accomplish this by using the Map Network Drive feature for Windows.

5 Specify your Vibe credentials, then complete the setup process.

Adding a Vibe Folder as a Network Place

If you are using Windows Vista as your client operating system, adding a Vibe folder as a network 
place as described in this section does not work. Instead, create a mapped drive to the Vibe folder, as 
described in “Creating a Mapped Drive to the Vibe Folder” on page 37.

1 Navigate to the folder where you want to create the mapped drive.

2 Click the link in the footer.

3 In the provided table, copy the WebDAV URL.

4 Add the folder as a network place.

You accomplish this by using the My Network Places feature for Windows.

Viewing the Vibe Folder in Your Linux Environment

After your Vibe folder has been configured to support WebDAV, as described in “Configuring a 
Folder to Support WebDAV” on page 36, you can view the Vibe folder in your Linux environment.

1 Navigate to the folder where you want to create the mapped drive.

2 Click the link in the footer.

3 In the provided table, copy the WebDAV URL.
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4 Use either Nautilus or Konqueror to access the Vibe folder.

For specific information on how to use Nautilus or Konqueror, consult your Linux 
documentation.

5 Specify your Vibe credentials, then complete the setup process.

3.9 Viewing Vibe Folders as RSS or Atom Feeds
RSS and Atom are Web formats used to publish frequently updated content such as blog entries, 
news headlines, or podcasts. RSS and Atom documents, which are often called feeds, contain either a 
summary or full content from an associated Web site. RSS and Atom make it possible for people to 
keep up with their favorite Web sites in an automated manner that's easier than checking the sites 
manually. RSS and Atom enable you to set up feeds to Kablink Vibe folders and view those feeds in 
one convenient location.

You can set up a Vibe folder to be accessed by an RSS or Atom reader. When you do this, the Vibe 
folder sends new or modified folder entries to your RSS or Atom reader. This is an easy way to stay 
informed on activity in a certain folder.

To set up a Vibe folder as an RSS or Atom feed:

1 Navigate to the folder that you want to set up as an RSS or Atom feed.

2 Click the Footer toolbar, located at the bottom of the folder page.

3 If you are setting up an RSS feed, select and copy the RSS URL in the RSS URL section in the 
provided table.

or

If you are setting up an Atom feed, select and copy the Atom URL in the ATOM URL section in 
the provided table.

4 In your RSS reader or Atom reader, create a new RSS or Atom feed, and paste the RSS URL or 
the Atom URL that you copied in Step 3.

The folder is now set up as an RSS or Atom feed, and entries that are created in the folder appear 
in your RSS or Atom reader.

3.10 Applying Landing Page Elements to a Folder
Landing pages and landing page elements can enhance the presentation and utility of your Kablink 
Vibe folders. You can set up a landing page on your folder, or you can simply apply some key 
landing page elements to the folder, such as hiding the Vibe masthead, the Navigation panel, and so 
forth.

 Section 3.10.1, “Displaying a Landing Page on a Folder,” on page 38

 Section 3.10.2, “Applying Specific Landing Page Elements to a Folder,” on page 39

3.10.1 Displaying a Landing Page on a Folder

Just as landing pages can enhance the presentation and utility of your Vibe workspaces, they can also 
enhance your Vibe folders.

For information on how you can create a landing page for a folder, see Section 6.13, “Creating a 
Landing Page for a Folder,” on page 84.
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3.10.2 Applying Specific Landing Page Elements to a Folder

You can leverage certain landing page elements in your Vibe folder without implementing an actual 
landing page. 

For example, you might want to hide the Navigation panel from your folder in order to create more 
viewing room for users who view the folder.

You can apply the following landing page elements to a folder, without implementing an actual 
landing page:

 Hide the Vibe Masthead

 Hide the Navigation panel

 Hide the Footer toolbar

To make these modifications to your folder without implementing an actual landing page, you need 
to add the Landing Page element to your folder Form definition. For information on how to add the 
Landing Page element to your folder Form definition, see Chapter 8, “Creating Custom Folder 
Views,” on page 97.
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4 4Controlling Access

If you are a Kablink Vibe site administrator or a workspace and folder owner, it is your responsibility 
to keep your content safe and your content consumers happy, by making sure they have access to the 
files and folders they depend on. Access control in Vibe is how you accomplish this.

Workspace and folder owners are responsible for controlling user access in their workspaces or 
folders. Site administrators are responsible for controlling user access across the entire site.

 Section 4.1, “Understanding Access Control,” on page 41

 Section 4.2, “Managing Access Control for Users and Groups,” on page 45

 Section 4.3, “Managing Access Control for Remote Applications,” on page 51

4.1 Understanding Access Control
Access control is how you specify which users have the right to perform which tasks in which places. 
Because your Kablink Vibe site is a hierarchy of workspaces and folders and because access control 
settings can be inherited (or not), access control settings affect a variety of Vibe features

Kablink Vibe uses role-based access control. By default, there are seven roles, and each role contains 
specific rights. If you want a particular user to have certain rights, you can assign that user to the 
appropriate role.

For example, a user who has been assigned to the Participant role in a workspace or folder can add 
comments or replies, create entries, delete his or her own entries, modify his or her own entries, and 
read entries in that folder or workspace.

The following sections help you better understand how access control works in Vibe.

 Section 4.1.1, “Inheritance,” on page 42

 Section 4.1.2, “Navigation,” on page 42

 Section 4.1.3, “Default Access Control Behavior in Workspaces,” on page 43

 Section 4.1.4, “Default User Rights,” on page 43

 Section 4.1.5, “Default Roles,” on page 43

 Section 4.1.6, “Default Users and Groups,” on page 44
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4.1.1 Inheritance

Workspaces can inherit the access control settings of their parent workspaces. You should understand 
the following facts about access control inheritance:

 If you create a new workspace under an existing workspace that is inheriting its access control 
settings from its parent, the new workspace continues the inheritance chain. If you change any 
access control settings above the new workspace at a later time, the access control settings for the 
new workspace also change. Global workspaces inherit access control settings from the parent 
workspace by default.

 If you create a new workspace under an existing workspace that is not inheriting its access 
control settings, the new workspace retains the non-inherited settings of the parent workspace.

 If you move a workspace that is inheriting its access control settings from its original parent 
workspace, it inherits the access control settings of the new parent workspace into which it is 
moved. If the new parent workspace has different settings than the original parent workspace, 
the access control settings for the moved workspace change accordingly.

 Team membership is inherited separately from access control settings. If access control settings 
are being inherited, this does not necessarily mean that team membership is also being 
inherited. To edit team membership or to change the team membership inheritance settings for a 
team workspace, click Workspace > Edit Team.

4.1.2 Navigation

As a best practice, you should not grant users access to sub-workspaces and sub-folders while 
restricting access for the same users to the higher-level (parent) folders. Ignoring this best practice 
can be problematic for the following reasons:

 Users cannot navigate to the sub-workspace or sub-folder using the Workspace tree navigation, 
even though they have appropriate rights to the sub-workspace or sub-folder.

If you understand this limitation and still have a need to restrict access to a parent workspace or 
folder while granting access to a sub-workspace or sub-folder, users can still access the hidden 
sub-workspace or sub-folder by using the Search feature or by accessing the location through 
WebDAV.

 Users can see the name of a higher-level workspace, even though they do not have appropriate 
rights.

Users who use the Search feature or WebDAV to locate the sub-workspace or sub-folder that 
they have been granted access to are able to see the name of the parent workspace, which they 
would otherwise not be able to see. However, they can see only the workspace name, not the 
contents of the workspace.
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4.1.3 Default Access Control Behavior in Workspaces

By default, most places inherit the access control settings of their parent. When you establish settings 
for a primary space, all sub-places automatically apply the same settings, saving administration time. 
However, unlike other types of workspaces, Team workspaces do not retain the access control 
settings of the parent workspace by default. This is because the desired access control settings for 
Team workspaces can vary greatly depending on the objectives of the team. 

Also, team membership is inherited separately from access control settings. If access control settings 
are being inherited, this does not necessarily mean that team membership is also being inherited. To 
edit team membership or to change the team membership inheritance settings for a team workspace, 
click Workspace > Edit Team.

4.1.4 Default User Rights

By default, all Vibe users have rights to perform the following actions:

 Participate in any team workspaces in which they are a member (create folders and entries, 
make comments, etc.)

 Create team workspaces (by default, only members of a team can view and participate in team 
workspaces)

 Visit all personal workspaces (read entries and comment on them)

 Participate in all global workspaces and folders

4.1.5 Default Roles

Vibe includes default roles that you can assign to users and groups. The following sections describe 
the function of each default role, but do not describe all of the rights associated with each role. For a 
complete list of rights, click the name of the role in the table on the Configure Access Control page. 
(In the Action toolbar, click Workspace > Access Control or Folder > Access Control.)

For a complete list of roles that site administrators can add, see “Controlling User Access throughout 
the Vibe Site” in the Kablink Vibe 3.3 Administration Guide. For a detailed description of each right that 
can be associated with a given role, see “Understanding the Various Rights for Roles” in the Kablink 
Vibe 3.3 Administration Guide.

Vibe enables site administrators to create their own custom roles, as described in “Defining a New 
Role” in the Kablink Vibe 3.3 Administration Guide. If you have a need for a custom role, consult your 
Vibe administrator.

By default, you can assign users to various roles in workspaces and folders, as well as in entries.

 “Understanding Default Roles for Workspaces and Folders” on page 43

 “Understanding Default Roles for Entries” on page 44

Understanding Default Roles for Workspaces and Folders

Role Description

Visitor Has read-only and comment-only access.
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Understanding Default Roles for Entries

4.1.6 Default Users and Groups

You can assign default or custom access control roles to users and groups for the Vibe site if you are 
the Vibe administrator, or in your workspaces if you are a workspace owner. In addition to the users 
and groups that the Vibe administrator creates, Vibe includes four default users and groups to which 
you can assign roles.

Participant Can create entries and modify those entries, plus perform tasks associated with 
the Visitor role.

Guest Participant Can read entries, create entries, and add comments.

Team Member Has all the rights of a Participant. In addition, can generate reports and manage 
global tags.

Workspace and Folder 
Administrator

Can create, modify, or delete workspaces or folders; moderate participation (modify 
or delete the entries of others); design entries and workflows; set entry-level 
access controls on entries of others; and can perform tasks associated with the 
Participant and Team Member role.

Workspace Creator Can create sub-workspaces. In Team Workspace Root workspaces, this role 
allows users to create their own team workspaces.

Role Description

Read Can read the entry.

Read and Reply Can read the entry and add comments or replies to the entry.

Write Can read the entry, add comments or replies, and modify the entry.

Delete Can read the entry, add comments or replies, modify, and delete the entry.

Change Access Controls Can read the entry, add comments or replies, modify, and delete the entry. Can 
also modify the access control settings of the entry.

Role Description

Default User and Group Description

Owner of a Workspace or 
Folder

The person who created the workspace, or the person assigned to be the owner 
of the workspace.

Team Members The individuals who are designated as team members in a given place.

For information about how to add team members, see “Adding Additional Team 
Members to Your Workspace” in the Kablink Vibe 3.3 User Guide.

All Users Every person registered within the Vibe site.

Site Administrator The person who has rights to perform any task in any workspace or folder. 
Available only to Vibe administrators.
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4.2 Managing Access Control for Users and Groups
When you have appropriate rights, you can control which users have access to workspaces, folders, 
and entries. Furthermore, you can regulate what actions they are allowed to perform. For example, 
you can allow a specific team to view a workspace, but only allow certain members of that team to 
create entries in the workspace.

You can control access to workspaces, folders, and entries.

 Section 4.2.1, “Controlling Access to Workspaces and Folders,” on page 45

 Section 4.2.2, “Controlling Access to Entries,” on page 49

4.2.1 Controlling Access to Workspaces and Folders

 “Accessing the Configure Access Control Page” on page 45

 “Activating the Table” on page 46

 “Adding Roles to the Access Control Table” on page 47

 “Adding Users to the Access Control Table” on page 47

 “Adding Groups to the Access Control Table” on page 48

 “Assigning Roles to Users and Groups” on page 48

 “Using the Configure Access Control Page to Adjust Access Controls” on page 49

 “Creating Access Controls for Remote Applications” on page 49

Accessing the Configure Access Control Page

Kablink Vibe provides a table on the Configure Access Control page that enables you to make all of 
your needed access control modifications. You must use this table to perform any access control 
modifications in Vibe.

1 Navigate to the workspace or folder where you want to modify user access rights.

2 Click Workspace > Access Control in the Action toolbar if you want to change the access control 
settings for a workspace.

or

Click Folder > Access Control in the Action toolbar if you want to change the access control 
settings for a folder.
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The Configure Access Control page is displayed.

Activating the Table

Before you can make modifications to the table on the Configure Access Control page, you need to 
ensure that the folder or workspace does not inherit its access control settings from its parent folder 
or workspace:

1 In the Folder Inheritance section, select no, then click Apply.

You can now make modifications to the table.
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Adding Roles to the Access Control Table

1 Click the Add a Role link at the top of the table.

2 From the drop-down list, select the role that you want to add.

Vibe adds a new column to the table for the new role.

3 Assign the appropriate user or group to this role by selecting the check box in the user’s or 
group’s row, as described in “Assigning Roles to Users and Groups” on page 48.

For information on how to add a new user to the access control table, see “Adding Users to the 
Access Control Table” on page 47.

For information on how to add a new group to the access control table, see “Adding Groups to 
the Access Control Table” on page 48.

4 Click Save Changes.

Adding Users to the Access Control Table

You can individually add users to the Access Control table, or you can add them by using the Vibe 
clipboard.

 “Adding Individual Users” on page 47

 “Adding Users from the Clipboard” on page 48

Adding Individual Users

1 Click the Add a User link in the left column of the table.

2 In the Add a User field, begin typing the name of the user that you want to add, then select that 
user from the provided list.

Vibe adds a new row to the table for the new user.
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3 Assign the user to the appropriate role by selecting the check box in the column of the user’s 
row, as described in “Assigning Roles to Users and Groups” on page 48.

4 Click Save Changes.

Adding Users from the Clipboard

1 In the upper left corner of the Access Control table, click Add User Names from Clipboard.

All of the users who are currently on your clipboard are added to the Access Control table.

For more information on how to use the Vibe clipboard, see “Using the Vibe Clipboard” in the 
Kablink Vibe 3.3 User Guide.

2 Assign the users to the appropriate role by selecting the check box in the column of each user’s 
row, as described in “Assigning Roles to Users and Groups” on page 48.

3 Click Save Changes.

Adding Groups to the Access Control Table

1 Click the Add a Group link in the left column of the table. 

2 In the Add a Group field, begin typing the name of the group that you want to add, then select 
that group from the provided list.

Vibe adds a new row to the table for the new group.

3 Assign the group to the appropriate role by selecting the check box in the column of the group’s 
row, as described in “Assigning Roles to Users and Groups” on page 48.

4 Click Save Changes.

Assigning Roles to Users and Groups

A role is a set of privileges. When you assign a user or group to a role, that user or group 
automatically has all the rights associated with that role.

1 Ensure that the user or group and the role that you want to associate with the user or group are 
visible in the Access Control table.

For information on how to add a role or a user or group to the table, see “Adding Roles to the 
Access Control Table” on page 47, “Adding Users to the Access Control Table” on page 47, and 
“Adding Groups to the Access Control Table” on page 48.

2 In the row of the user or group, select the check box that is located in the role column that you 
want to assign to the user or group.

3 Click Save Changes.
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If you want to unassign a role:

1 Deselect the appropriate check box, then click Save Changes.

Using the Configure Access Control Page to Adjust Access Controls

Vibe enables you to adjust the access control settings of any workspace or folder, directly from the 
Configure Access Control page.

1 In the workspace tree at the top of the Configure Access Control page, navigate to the place 
where you want to adjust the access controls.

2 Click the linked title of the place where you want to adjust the access controls.

Vibe displays the Configure Access Control page for the page that you specified.

Creating Access Controls for Remote Applications

Because not all remote applications can be completely trusted, it is often a good idea to limit the 
privileges of the remote application. 

For information on how to do this by using access controls, see Section 12.4, “Managing Access 
Controls for Remote Applications,” on page 172.

4.2.2 Controlling Access to Entries

Vibe enables you to set access controls for an entry that differ from the access controls of the parent 
folder. You might want to do this if you have granted a group of users access to a folder, but only 
want a subset of that group to have access to see certain entries within the folder. Or, you might want 
to set access controls on a particular entry to make that entry visible to users who don’t have access to 
the folder where the entry resides, as described in “Exposing a Vibe Entry to a Wider Audience Than 
the Folder Access Controls Allow” on page 51.

Before you can modify access controls for an entry, you need to ensure that the entry does not inherit 
its access control settings from the parent folder:

To set access controls on an entry:

1 Navigate to the entry where you want to modify user access rights.

2 Click Actions > Access Control in the Entry toolbar.

The Configure Access Control page is displayed.
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3 To set access controls that differ from the access controls of the parent folder, select Specify the 
access controls for this entry, then click Apply.

4 Use the table to modify user access to the entry. 

You can assign various roles to team members, groups, or individual users. 
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For information about the roles that you can assign, see “Understanding Default Roles for 
Entries” on page 44.

For information about how to add users and groups to the access control table, see “Adding 
Users to the Access Control Table” on page 47 and “Adding Groups to the Access Control Table” 
on page 48.

5 (Optional) Select Include the Folder Access Controls if you want to extend the new entry-level 
access controls to include the access controls that are already in place for the folder. Selecting 
this option automatically grants users the same access rights to the entry that they have to the 
folder.

Deselect Include the Folder Access Controls if you want the new entry-level access controls to 
override the folder-level access controls. If you deselect this option, you must use the entry-level 
access controls to specify each user or group that you want to have access to the entry. Users who 
have access to the folder that contains the entry but have not been granted access rights to the 
entry itself do not have access to the entry. 

6 Click Save Changes > Close.

Exposing a Vibe Entry to a Wider Audience Than the Folder Access Controls 
Allow

You can make a Vibe entry visible to a wider audience than is normally allowed for the folder where 
the entry resides. For example, if your folder is visible only to team members, the default access 
controls allow only team members to see all entries that are created in the folder. However, by 
deselecting Include the Folder Access Controls, you can enable a wider audience to view a specific entry. 
You might want to do this if the majority of content in a folder is sensitive and should be restricted to 
a limited audience, but you want to expose a specific entry to a larger audience.

For example, suppose that you are a member of a finance team that is responsible for the accounting 
of your company’s quarterly earnings. All the information in your team’s workspace is confidential. 
However, when it is time to announce the company’s quarterly earnings, you create a Vibe entry that 
contains the earning results, and you modify the access controls of this specific entry to make the 
entry visible to all company employees.

To expose a Vibe entry to a wider audience than is currently allowed in the folder:

1 Modify the entry access controls as described in Section 4.2.2, “Controlling Access to Entries,” 
on page 49.

Ensure that you deselect Include the Folder Access Controls, as described in Step 5 of this section.

NOTE: When you expose a Vibe entry to a wider audience than is currently allowed in the folder, 
users must perform a search in order to locate the entry, or they must have the entry shared with 
them. Users cannot locate the entry by navigating the Workspace tree as described in “Navigating the 
Workspace Tree” in the Kablink Vibe 3.3 User Guide.

4.3 Managing Access Control for Remote Applications
Because not all remote applications can be completely trusted, it is often a good idea to limit the 
privileges of the remote application. 

For information on how to do this by using access controls, see Section 12.4, “Managing Access 
Controls for Remote Applications,” on page 172.
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5 5Branding a Folder or Workspace

Branding a folder or workspace is a good way to make the folder or workspace more unique and 
identifiable. When you brand a folder or workspace, the brand is applied to all sub-workspaces and 
sub-folders. However, folder and workspace owners in lower-level folders and workspaces can 
override the higher-level brand settings by adding a workspace brand of their own. For example, the 
Global Workspaces folder can be branded with the company logo and slogan, while a team 
workspace at a lower level in the workspace tree can be branded with a logo for the product that the 
team is responsible for. Members of that team can then override the team brand by branding 
individual folders within the team workspace that they are responsible for.

Kablink Vibe administrators can disable this functionality when they create a site-wide brand, as 
discussed in “Creating a Site-Wide Brand” in the Kablink Vibe 3.3 Administration Guide. 

If you are unable to brand a folder or workspace as discussed in this section, contact your Vibe 
administrator.

To brand a folder or workspace:

1 Navigate to the folder or workspace where you want to create the brand.

2 Click Workspace > Brand Workspace if you are branding a workspace.

or

Click Folder > Brand Folder if you are branding a folder.

The Workspace/Folder Branding dialog box is displayed.

3 Specify the following information to create your desired brand:

Use Branding Image: Select this option if you want to use the drop-down list to select an 
existing image, or click the Browse icon  to browse to an image on your computer’s file 
system.
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Use Advanced Branding: Select this option, then click Advanced if you want to create a brand 
that includes advanced features, such as linking to another Vibe page or displaying a YouTube 
video.

You can add a YouTube video in your branding section by clicking the Video icon .

For more information about displaying YouTube videos in Vibe, see “Displaying YouTube 
Videos in a Folder Entry” in the Kablink Vibe 3.3 User Guide.

For more information about linking to another Vibe page, see “Linking to a Folder or Folder 
Entry” in the Kablink Vibe 3.3 User Guide.

If you add a URL to the advanced branding, the URL cannot contain the 
url_created_by_teaming parameter. If this parameter does exist, delete it before saving your 
brand.

Background Image: Click the Browse icon  to browse to an image on your computer’s file 
system. If you are branding a team workspace, you can use the provided drop-down list to select 
an image that is already attached to the workspace. (For information on how to attach an image 
to a team workspace, see “Modifying a Workspace” in the Kablink Vibe 3.3 User Guide.)

This background image is displayed behind your regular branding.

Stretch Image: Stretches the image to occupy the entire branding area.

If you stretch your background image, the image overrides any background color that you have 
set.

Background Color: Adds a background color that occupies the entire branding area. To change 
the background color, click the color name to the right of this field, select the new color, then 
click OK.

If you added a background image and stretched the image, the background color is not 
displayed.

Text Color: Changes the text color of the workspace name in the upper right corner of the 
branding area. To change the text color, click the color name to the right of this field, select the 
new color, then click OK.

Clear branding: Clears all your current branding selections.

4 Click OK.

The folder or workspace now displays the brand that you created.
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6 6Creating and Managing Landing Pages

Landing pages in Kablink Vibe can benefit your workspaces and folders in two key ways:

 Improved Customization: Landing pages provide an excellent opportunity to put a custom, 
personal face on workspaces and folders in your Vibe site, while still providing the team-
focused, collaborative functionality that Vibe affords.

 Increased Retrievability: Landing pages increase the accessibility and visibility of the 
information that is most critical to your team or organization. You can bring important entries or 
entire folders to the forefront of workspaces, ensuring that users access the information they 
need in a quick, efficient manner.

For example, a landing page for a city’s public sector might look something like this:

 Section 6.1, “Landing Page Best Practices,” on page 56

 Section 6.2, “Enabling the Landing Page View for a Workspace,” on page 57
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 Section 6.3, “Setting Up Your Landing Page,” on page 58

 Section 6.4, “Publishing Your Landing Page,” on page 76

 Section 6.5, “Modifying the Contents of Your Landing Page,” on page 76

 Section 6.6, “Changing the Order of Landing Page Elements,” on page 77

 Section 6.7, “Deleting Content from Your Landing Page,” on page 78

 Section 6.8, “Automatically Displaying the Newest Folder Entries on Your Landing Page,” on 
page 78

 Section 6.9, “Adding Accessories to Your Landing Page,” on page 80

 Section 6.10, “Enabling Graphics to Be Used on a Landing Page,” on page 82

 Section 6.11, “Displaying YouTube Videos on a Landing Page,” on page 83

 Section 6.12, “Creating a Landing Page On Your Personal Workspace,” on page 84

 Section 6.13, “Creating a Landing Page for a Folder,” on page 84

 Section 6.14, “Downloading Existing Landing Pages,” on page 85

6.1 Landing Page Best Practices
When creating landing pages, the following best practices can make the creation process easier and 
make your landing pages more visually appealing:

 Section 6.1.1, “Best Practices for Adding Content,” on page 56

 Section 6.1.2, “Best Practices for Look and Feel,” on page 56

6.1.1 Best Practices for Adding Content

To easily add content to your landing pages:

 Wherever possible, build custom pieces using HTML elements on the landing page itself.

For more information about adding HTML elements, see “Adding an HTML Editor” on page 75.

 If you want to duplicate the same information on multiple landing pages, create the information 
in an entry (such as a blog entry) somewhere on the Vibe site where you have access. After you 
create the information in an entry, you can then reference that entry from multiple different 
landing pages.

For more information about adding entry elements, see “Adding an Entry” on page 66.

 If you plan to edit the HTML of an item, ensure that you have local copies of all images in the 
HTML. Images do not load properly when you edit the landing page unless you have local 
copies.

6.1.2 Best Practices for Look and Feel

To make your landing page look more professional:

 Create nice looking graphics to incorporate into the page. 

 Use a simple, classy image for the background that can be repeated vertically and horizontally.
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 For subject headers, set the opacity to somewhere between .65 and .85 (<style="opacity: .??;">), 
and round each corner to somewhere between 4 and 10 (<style=”border-radius: ??px:>). Ensure 
that settings for each corner are consistent.

 When you want to display a graphic on the landing page, especially in tables, re-size the graphic 
outside of Vibe before you add it to the landing page. Then use that pre-sized graphic as a 
building block to build out the desired sized page. This is important because the pixel sizing 
within the landing page editor might not present what you expect.

 When you want to display a calendar on the landing page, always use the Enhanced View 
element.

For more information about the Enhanced View element, see “Adding an Enhanced View 
Element” on page 68.

 If your table contains pixels (or if the percentages do not total 100 percent), you must add an 
additional column to the table that has a width of * in order for the columns to stay at their fixed 
widths. This is an HTML browser requirement.

For example, suppose you want a 3-column table with the first column with a width of 450 
pixels, the second column with a width of 150 pixels, and the third column with a width of 10 
percent. For the columns to retain their fixed widths, you must add a fourth column, and specify 
* in the provided field.

6.2 Enabling the Landing Page View for a Workspace
Before you can create the landing page, you need to enable the landing page view for the workspace.

Kablink Vibe includes a default workspace landing page view. The default landing page view 
contains a Landing Page Layout section, a Description section, a Branding section, an Icon section, and an 
Attachments section.

Or, you can create a custom landing page view for a workspace that contains only the sections that 
you choose. For information on how to create a custom landing page view for a workspace, see 
Chapter 7, “Creating Custom Workspace Views,” on page 87.

You can enable the landing page view on an existing workspace, or when you are creating a 
workspace.

 Section 6.2.1, “Enabling the Landing Page View on an Existing Workspace,” on page 57

 Section 6.2.2, “Enabling the Landing Page View on a Workspace You Are Creating,” on page 58

6.2.1 Enabling the Landing Page View on an Existing Workspace

1 Navigate to the workspace where you want to create the landing page.

You can create a landing page for a personal workspace only if your Vibe administrator has 
enabled you to do so. For more information, see Section 6.12, “Creating a Landing Page On Your 
Personal Workspace,” on page 84.

2 Click Workspace > Configure Views, URLs and Controls in the Action toolbar.

3 On the Configure Workspace View tab, in the Default View section, select Landing Page.

4 Click Apply > Close.
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What was previously displayed on the main page of the workspace is no longer displayed and 
the main page of the workspace is blank.

5 Continue with Section 6.3, “Setting Up Your Landing Page,” on page 58.

6.2.2 Enabling the Landing Page View on a Workspace You Are Creating

1 Navigate to the workspace where you want to create the new workspace.

2 Click Workspace > New Workspace.

The New Workspace page is displayed.

3 In the Workspace Title field, specify a title for the workspace.

4 In the Workspace section, select Landing Page.

5 Finish creating the workspace, then click OK.

For more information on creating a workspace, see “Creating a New Workspace” in “General 
Workspace Management” in the Kablink Vibe 3.3 User Guide.

6 Continue with Section 6.3, “Setting Up Your Landing Page,” on page 58.

6.3 Setting Up Your Landing Page
After you enable a landing page as described in Section 6.2, “Enabling the Landing Page View for a 
Workspace,” on page 57, you need to set it up to display the desired layout options and content, as 
described in the following sections:

 Section 6.3.1, “Choosing Layout Options for Your Landing Page,” on page 58

 Section 6.3.2, “Adding a Background Image or Color to Your Landing Page,” on page 59

 Section 6.3.3, “Adding Content to Your Landing Page,” on page 61

 Section 6.3.4, “Configuring Landing Page Elements,” on page 63

6.3.1 Choosing Layout Options for Your Landing Page

1 Navigate to the landing page that you created in Section 6.2, “Enabling the Landing Page View 
for a Workspace,” on page 57.

2 Click Workspace > Edit Workspace in the Action toolbar.

or

Click Folder > Edit Folder if your landing page is on a folder.
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3 In the Landing Page Layout section, below the workspace Title field, select from the following 
options to modify the display of your landing page:

 Hide the Masthead: Select this option to hide the masthead (Navigation toolbar). This 
hides everything above the Action toolbar.

 Hide the Navigation Panel: Select this option to hide the Navigation panel.

 Hide the Footer: Select this option to hide the Footer toolbar.

 Hide the Menu: Select this option to hide the menu (Action toolbar) from all users who do 
not have rights to edit the workspace. Users who have rights to edit the workspace still see 
the menu.

4 In the Landing Page Style section, select from the following options to modify the style of your 
landing page:

 Light: No background shading is displayed on landing page elements.

 Dark: (Default) Displays a dark background on each element to provide contrast between 
the landing page elements.

5 Click OK to save the layout and style changes.

6.3.2 Adding a Background Image or Color to Your Landing Page

1 Navigate to the landing page that you created in Section 6.2, “Enabling the Landing Page View 
for a Workspace,” on page 57.

2 Click Workspace > Edit Workspace in the Action toolbar.

or

Click Folder > Edit Folder if your landing page is on a folder.
Creating and Managing Landing Pages 59



3 In the Landing Page Layout section, in the content editor, click the edit icon  in the upper right 
corner of the landing page element.

The Landing Page Properties dialog box is displayed.

4 Configure the following options to modify the background image and color:

Background Image: To add images to be used as the background image, you must first add 

them to the drop-down list before you can select them. Click the Browse icon , then navigate 
to and select the image that you want to add. Select the image from the drop-down list that you 
want to use as the background image.

Background image repeat: In the drop-down list, select whether you want the image to repeat 
horizontally and vertically, only horizontally, only vertically, or not at all.

Background Color: Click the Browse icon  to choose a color from a list of colors.

5 Click OK.
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6.3.3 Adding Content to Your Landing Page

To help make the landing page creation process easier and to help make your landing pages look 
more professional, review the best practices discussed in Section 6.1, “Landing Page Best Practices,” 
on page 56.

1 Navigate to the landing page that you created in Section 6.2, “Enabling the Landing Page View 
for a Workspace,” on page 57.

2 Click Workspace > Edit Workspace in the Action toolbar.

or

If you are creating a landing page for a folder, click Folder > Edit Folder.

3 In the Landing Page Layout section, in the content editor, use the element palette to select the 
landing page element that you want to display on your landing page.

You can add the following elements:

 Table: Creates a table with the number of columns that you specify. You can add other 
elements inside this table.

 List: Creates a list where you can add other elements.

 Entry: Enables you to reference an entry that has previously been created in Kablink Vibe.
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The actual content of your landing page can be created in entries elsewhere on the Vibe site 
which are then simply referenced from the landing page. This is helpful if you want to 
duplicate the same information on multiple landing pages. After you create the information 
in an entry, you can then reference that entry from multiple different landing pages.

When you add an entry to the landing page by using the Entry element, only the entry title 
and description can be displayed. If you want to display entry comments, add the 
Enhanced View element to the landing page.

 Folder: Enables you to reference a folder that has previously been created in Vibe. You can 
choose how many entries from the folder that you want to display on your landing page at 
any one time.

 Enhanced View: Enables you to display entries and folders in enhanced ways. The 
following options are available:

 Display an entry: Displays the entry title, description, author, date, and the 10 most 
recent comments.

 Display recent entries: Displays the most recent entries from the specified folder. 
Displays the title, description, author, date, and the 10 most recent comments for each 
entry.

 Display a list of recent entries: Displays a list of the most recent entries from the 
specified folder. Displays the title, author, and date of the entry.

 Display a sorted list of recent entries: Displays a list in alphabetical order of the most 
recent entries from the specified folder. Displays the title, author, and date of the entry.

 Display a sorted list of files: Displays a list in alphabetical order of the files that were 
most recently added to the folder. This includes files that are attached to entries.

 Display calendar: Displays the specified calendar with the full calendar view.

 Display my calendar events: Displays all the calendar events and tasks that are 
assigned to the user who is viewing the landing page. Calendar events and tasks are 
displayed in a calendar view. Tasks are displayed on the calendar according to the task 
duration; tasks that do not have either a start and end date or a duration specified are 
not displayed. 

 Display task folder: Displays the specified task folder with information about each 
task, such as the title, due date, priority, and so forth.

 Display my tasks: Displays all the tasks that are assigned to the user who is viewing 
the landing page.

 Display survey: Displays the specified survey in a full, interactive view. Users can 
participate in the survey directly from the landing page.

 Graphic: Enables you to reference a graphic that has previously been added to the 
workspace.

 Link (URL): Enables you to create a link to a Web URL.

 Link to Folder/Workspace: Enables you to add a link to a Vibe folder or workspace.

 Link to Entry: Enables you to add a link to a Vibe entry.

 Utility Element: Enables you to add various utilities, such as the My Workspace link.

 Custom JSP: Enables you to reference a custom JSP file that has previously been created by 
a Vibe administrator.

 HTML: Displays an HTML editor where you can compose messages, create links, upload 
pictures, and more. The information that you create in this HTML editor is displayed on 
your landing page.
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 Embedded Web Page: Enables you to reference any Web site and display it on your landing 
page.

4 Drag the element that you want to display on your landing page and drop it onto the landing 
page canvas.

After you drop the element onto the landing page canvas, you are prompted to configure it. 

How you configure a landing page element depends on the type of element that you add. 

5 Configure the landing page element as described in Section 6.3.4, “Configuring Landing Page 
Elements,” on page 63.

6.3.4 Configuring Landing Page Elements

You need to configure the elements of your landing page when you create them, as described in 
Section 6.3.3, “Adding Content to Your Landing Page,” on page 61.

You can also reconfigure the elements of your landing page at any time, as described in Section 6.5, 
“Modifying the Contents of Your Landing Page,” on page 76.

 “Adding a Table” on page 64

 “Adding a List” on page 65

 “Adding an Entry” on page 66

 “Adding a Folder” on page 67

 “Adding an Enhanced View Element” on page 68

 “Adding a Graphic” on page 69

 “Adding a Link (URL)” on page 70

 “Adding a Link to a Folder/Workspace” on page 71

 “Adding a Link to an Entry” on page 71

 “Adding a Utility Element” on page 72

 “Adding a Custom JSP” on page 73

 “Adding an HTML Editor” on page 75

 “Adding an Embedded Web Page” on page 76
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After you have added and configured the elements of your landing page, you are ready to publish 
the landing page. For information on how to do this, see Section 6.4, “Publishing Your Landing 
Page,” on page 76.

Adding a Table

To add a table to the landing page:

1 In the Landing Page Layout section, in the content editor, click Table in the element palette, then 
drag the table into the desired area of the landing page canvas.

2 Set the following configuration options to finish setting up the table:

 Show border: Select this option if you want the border of the table to be visible.

 Number of rows: Specify the number of rows that you want the table to have.

The height of the table is determined by the number of rows in the table and the contents of 
the table.

 Number of columns: Specify the number of columns that you want the table to have. You 
can have up to ten columns.

 Column width: Specify the width that you want for each column by either percentage or 
pixel. You can have both percentages and pixels within the same table.

If your table contains pixels (or if the percentages do not total 100 percent), you must add an 
additional column to the table that has a width of * in order for the columns to stay at their 
fixed widths. This is an HTML browser requirement.

For example, suppose you want a 3-column table with the first column with a width of 450 
pixels, the second column with a width of 150 pixels, and the third column with a width of 
10 percent. For the columns to retain their fixed widths, you must add a fourth column, and 
specify * in the provided field.

3 Click OK.
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After you add a table to a landing page, you can add content within the table.

1 Select an element from the element palette and drag and drop it into the location of the table 
where you want to add the content.

Adding a List

To add a list to the landing page:

1 In the Landing Page Layout section, in the content editor, click List in the element palette, then 
drag the list and drop it into the desired area of the landing page canvas.

2 Set the following configuration options to finish setting up the list:

 Title: Specify a title for the list.

 Width: Specify the width that you want the element to be on the landing page, either by 
percent or pixels.

 Height: (Conditional) Specify the height that you want the element to be on the landing 
page by pixels.

 Show scroll bars when needed: Select this option to have scroll bars appear on elements 
when the element requires more room than the width and height that you defined. (If you 
specified 100%, scroll bars are never needed.) If the element does need more room than you 
defined and you do not select this option, the remaining part of the element is cropped and 
you are unable to see it.

 Show border: Select this option if you want the border of the list to be visible.

3 Click OK.
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After you add a list to a landing page, you can add content within the list.

1 Select an element from the element palette and drag and drop it into the location of the list 
where you want to add the content.

Adding an Entry

The actual content of your landing page is created in entries. The landing page simply references 
entries that have already been created within Vibe.

When you use the Entry element to add an entry to the landing page, only the entry title and 
description can be displayed. If you want to display entry comments, add the Enhanced View 
element to the landing page, as described in “Adding an Enhanced View Element” on page 68.

To add an entry to the landing page:

1 In the Landing Page Layout section, in the content editor, click Entry in the element palette, then 
drag the entry into the desired area of the landing page canvas.

2 Click Edit next to the Entry field.

If you are reconfiguring the element, the entry that is being referenced is shown here.

3 Set the following configuration options to finish setting up the entry:

 Find: Select whether you want to search the entire site for the entry or search only within 
the current folder or workspace, then use the provided field to specify the entry that you 
want to display on the landing page.

This field uses type-to-find functionality, so Vibe displays the available options as you type. 
Click in the field and press the Spacebar to list all the available options.

 Width: Specify the width that you want the element to be on the landing page, either by 
percent or pixels.

 Height: (Conditional) Specify the height that you want the element to be on the landing 
page by pixels.
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 Show scroll bars when needed: Select this option to have scroll bars appear on elements 
when the element requires more room than the width and height that you defined. (If you 
specified 100%, scroll bars are never needed.) If the element does need more room than you 
defined and you do not select this option, the remaining part of the element is cropped and 
you are unable to see it.

 Show Title Bar: Select this option if you want the title bar of the entry to be visible.

4 Click OK.

Adding a Folder

1 In the Landing Page Layout section, in the content editor, click Folder in the element palette, then 
drag the folder into the desired area of the landing page canvas.

2 Click Edit next to the Folder field.

If you are reconfiguring this element, the folder that is being referenced is shown here.

3 Set the following configuration options to finish setting up the folder:

 Find: Select whether you want to search the entire site for the folder or search only within 
the current folder or workspace, then use the provided field to specify the folder that you 
want to display on the landing page.

This field uses type-to-find functionality, so Vibe displays the available options as you type. 
Click in the field and press the Spacebar to list all the available options.

 Width: Specify the width that you want the element to be on the landing page, either by 
percent or pixels.

 Height: (Conditional) Specify the height that you want the element to be on the landing 
page by pixels.

 Show scroll bars when needed: Select this option to have scroll bars appear on elements 
when the element requires more room than the width and height that you defined. (If you 
specified 100%, scroll bars are never needed.) If the element does need more room than you 
defined and you do not select this option, the remaining part of the element is cropped and 
you are unable to see it.
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 Number of entries to show: Specify the number of folder entries that you want to be 
displayed at any one time.

 Show Title Bar: Select this option if you want the folder title bar to be displayed.

 Show Folder Description: Select this option if you want the folder description to be 
displayed.

 Show Entries Opened: Select this option if you want opened entries to be displayed.

4 Click OK.

Adding an Enhanced View Element

1 In the Landing Page Layout section, in the content editor, click Enhanced View in the element 
palette, then drag the enhanced view into the desired area of the landing page canvas.

2 In the Enhanced View drop-down list, select one of the available options.

For more information about each option, see Enhanced View.

3 Set the configuration options that apply to the enhanced view element that you are adding. 
Depending on the option that you selected in Step 2, the following configuration options are 
available:

 Entry: Click Edit. 

If you are reconfiguring this element, the folder that is being referenced is shown here.

 Folder: Click Edit. 

If you are reconfiguring this element, the folder that is being referenced is shown here.

 Find: Select whether you want to search the entire site for the folder or entry, or only within 
the current folder or workspace, then use the provided field to specify the folder or entry 
that you want to display on the landing page.

 Number of entries to show: (Conditional) Specify the number of folder entries that you 
want to be displayed at any one time.

This option is available only when referencing a folder.

 Width: Specify the width that you want the element to be on the landing page, either by 
percent or pixels.
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 Height: (Conditional) Specify the height that you want the element to be on the landing 
page by pixels.

This option is not available when selecting Display calendar or Display my calendar events in 
the Enhanced View drop-down list.

 Show Title Bar: Select this option if you want the title bar to be displayed.

This option is available depending on what you select in the Enhanced View drop-down list.

 Show scroll bars when needed: Select this option to have scroll bars appear on elements 
when the element requires more room than the width and height that you defined. (If you 
specified 100%, scroll bars are never needed.) If the element does need more room than you 
defined and you do not select this option, the remaining part of the element is cropped and 
you are unable to see it.

4 Click OK.

Adding a Graphic

Before you can add a graphic to your landing page, you need to attach the graphic to the landing 
page, as described in Section 6.10, “Enabling Graphics to Be Used on a Landing Page,” on page 82.

1 In the Landing Page Layout section, in the content editor, click Graphic in the element palette, then 
drag the graphic into the desired area of the landing page canvas.

2 Set the following configuration options to finish setting up the graphic:

 Graphic: In the Graphic drop-down list, select the graphic that you want to display.

All attachments that are attached to the landing page workspace are displayed in this list. 
Attachments are also displayed in the Current Attached Files section at the bottom of the 
page.

 Set image size: Select this option to specify a specific width and height for the graphic.

 Width: Specify the width that you want the element to be on the landing page, either by 
percent or pixels.

 Height: (Conditional) Specify the height that you want the element to be on the landing 
page by pixels.
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 Show scroll bars when needed: Select this option to have scroll bars appear on elements 
when the element requires more room than the width and height that you defined. (If you 
specified 100%, scroll bars are never needed.) If the element does need more room than you 
defined and you do not select this option, the remaining part of the element is cropped and 
you are unable to see it.

 Show border: Select this option if you want the border of the graphic to be visible.

3 Click OK.

Adding a Link (URL)

1 In the Landing Page Layout section, in the content editor, click Link (URL) in the element palette, 
then drag the link element into the desired area of the landing page canvas.

2 Set the following configuration options to finish setting up the URL link:

 Title: Specify the title that you want to be displayed.

 URL: Specify the URL that you want to link to.

To link to a URL outside of Vibe, you must include http:// at the beginning of the URL.

To link to a page within Vibe, the best method is to use the Link to Folder/Workspace 
element or the Link to Entry element.

An alternative is to paste a Vibe permalink into this field. To get the permalink URL of a 
Vibe page, simply navigate to the page that you want to link to, click Permalink in the footer 
toolbar, then copy the permalink URL from the Permalink field.

 Open URL in a new window: Select this option if you want to open the URL in a new 
browser window.

3 Click OK.
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Adding a Link to a Folder/Workspace

You can create a link to any folder or workspace for which you have appropriate rights.

1 In the Landing Page Layout section, in the content editor, click Link to Folder/Workspace in the 
element palette, then drag the link element into the desired area of the landing page canvas.

2 Click Edit next to the Folder/Workspace field.

If you are reconfiguring the element, the folder or workspace that is being referenced is shown 
here.

3 Set the following configuration options to finish setting up the link:

 Find: Select whether you want to search the entire site for the folder or only within the 
current folder or workspace, then use the provided field to specify the folder or workspace 
that you want to link to.

This field uses type-to-find functionality, so Vibe displays the available options as you type.

 Title: Specify a title for the link.

 Open the folder/workspace in a new window: Select this option if you want to open the 
folder or workspace in a new browser window.

Adding a Link to an Entry

Enables you to create a link to any entry for which you have appropriate rights.

1 In the Landing Page Layout section, in the content editor, click Link to Entry in the element palette, 
then drag the link element into the desired area of the landing page canvas.

2 Click Edit next to the Entry field.

If you are reconfiguring the element, the entry or workspace that is being referenced is shown 
here.
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3 Set the following configuration options to finish setting up the link:

 Find: Select whether you want to search the entire site for the entry or only within the 
current folder or workspace, then use the provided field to specify the entry that you want 
to link to.

This field uses type-to-find functionality, so Vibe displays the available options as you type.

 Title: Specify a title for the link.

 Open the entry in a new window: Select this option if you want to open the entry in a new 
browser window.

Adding a Utility Element

Most utility elements are options that are normally displayed either in the Vibe masthead or 
Navigation panel; however, because it is often desirable to hide the masthead and Navigation panel 
in order to make more room for information on your landing page, utility elements enable you to 
display important features in a more concise view.

1 In the Landing Page Layout section, in the content editor, click Utility Element in the element 
palette, then drag the utility into the desired area of the landing page canvas.
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2 Select from the following utility elements:

Link to “Follow this folder or workspace”: Displays a Follow This Workspace or Follow This 
Folder link.

Link to “My Workspace”: Displays a link to your personal workspace.

Link to “Share this folder or workspace”: Displays a Share This Workspace or Share This Folder 
link.

Link to “Vibe administration page”: Provides a link to the Vibe Administration page.

This link is visible only to Vibe users who have administrative rights.

Sign-in form: Displays a Sign In form when users are not logged in to Vibe.

3 Click OK.

Adding a Custom JSP

Custom JSP files are stored in the \webapps\ssf\WEB-INF\jsp\custom_jsps directory. If you want 
to include a custom JSP file in your landing page, you must store the file in this directory in order to 
reference it from Vibe.

Typically, only Vibe administrators have access to this directory. If you want to create a custom JSP 
file, consult your Vibe administrator.

After the custom JSP file has been placed in the \webapps\ssf\WEB-INF\jsp\custom_jsps 
directory:

1 In the Landing Page Layout section, in the content editor, click Custom JSP in the element palette, 
then drag the JSP element into the desired area of the landing page canvas.
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2 In the Custom JSP name field, type the name of the custom JSP file that you want to reference.

You must obtain this filename from your Vibe administrator. Only your Vibe administrator can 
enable JSP files to be used in the Vibe site.

3 Depending on how you want to use this custom JSP file, select either Associate a folder with this 
custom jsp, or Associate an entry with this custom jsp.

For example, if your administrator has enabled a custom JSP file that enhances the way entries 
are displayed on the landing page, and you want to utilize this JSP file for a specific folder, you 
would select Associate a folder with this custom jsp.

4 Click Edit next to the Folder field.

If you are reconfiguring the element, the field displays the folder that the custom JSP file is 
currently associated with. If you are creating a new element, this field is blank.
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5 Set the appropriate configuration options to finish setting up the custom JSP:

Find: Select whether you want to search the entire site for the folder or only within the current 
folder or workspace, then use the provided field to specify the folder that you want to associate 
the JSP file with.

This field uses type-to-find functionality, so Vibe displays the available options as you type.

Number of entries to show: Specify how many folder entries you want to be displayed on the 
landing page at any one time.

Show Title Bar: Select this option if you want the title bar of the entry to be visible.

Width: Specify the width that you want the element to be on the landing page, either by percent 
or pixels.

Height: (Conditional) Specify the height that you want the element to be on the landing page by 
pixels.

Show scroll bars when needed: Select this option to have scroll bars appear on elements when 
the element requires more room than the width and height that you defined. (If you specified 
100%, scroll bars are never needed.) If the element does need more room than you defined and 
you do not select this option, the remaining part of the element is cropped and you are unable to 
see it.

6 Click OK.

Adding an HTML Editor

To add content (such as text, links, pictures, and videos) to your landing page by using an HTML 
editor:

1 In the Landing Page Layout section, in the content editor, click HTML in the element palette, then 
drag the HTML element into the desired area of the landing page canvas.

2 Specify content in the HTML editor that you want to be displayed on the landing page. Click the 
Show/Hide icon  to show and hide additional options.

3 Click OK.
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Adding an Embedded Web Page

1 In the Landing Page Layout section, in the content editor, click Embedded Web Page in the element 
palette, then drag the page into the desired area of the landing page canvas.

2 Set the following configuration options to finish setting up the embedded Web page:

 URL: Specify the URL for the embedded Web page that you want to display.

 Name: Specify a name for the page. This name is displayed on the landing page above the 
embedded Web page.

 Height: Specify the height (in pixels) to indicate how much of the page you want to display.

 Width: Specify the width (in pixels) to indicate how much of the page you want to display.

 Show scrollbars: Select whether you want to display scroll bars. Keep the default of Auto if 
you want Vibe to auto detect whether scroll bars are needed.

 Show border: Select whether you want to display a border around the embedded Web 
page.

3 Click OK.

6.4 Publishing Your Landing Page
After you have added elements to your landing page and configured them, you need to publish the 
contents of the landing page.

1 Scroll to the bottom of the page that contains the landing page editor.

2 Click OK.

The landing page is displayed with all of the content that you previously added.

6.5 Modifying the Contents of Your Landing Page
Kablink Vibe enables you to modify the elements that have been previously added to your landing 
page.

1 Navigate to the landing page that contains the elements that you want to modify.

For information about each type of element, see Section 6.3.4, “Configuring Landing Page 
Elements,” on page 63.
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2 Click Workspace > Edit Workspace in the Action toolbar.

or

If your landing page is on a folder, click Folder > Edit Folder.

3 In the Landing Page Layout section, in the content editor, click the edit icon  in the upper right 
corner of the landing page element that you want to modify.

The properties dialog box of the element that you are modifying is displayed.

4 Modify the properties of the element, then click OK.

6.6 Changing the Order of Landing Page Elements
Kablink Vibe enables you to change the order of elements that have been previously added to your 
landing page.

1 Navigate to the landing page that contains the elements that you want to reorder.

For information about each type of element, see Section 6.3.4, “Configuring Landing Page 
Elements,” on page 63.

2 Click Workspace > Edit Workspace in the Action toolbar.

or

If your landing page is on a folder, click Folder > Edit Folder.

3 In the Landing Page Layout section, in the content editor, click the Move icon  in the upper right 
corner of the landing page element that you want to move, then drag the element to the desired 
location on the landing page canvas.

4 Click OK to save your changes.
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6.7 Deleting Content from Your Landing Page
Kablink Vibe enables you to delete elements that have previously been added to your landing page.

1 Navigate to the landing page that contains the element that you want to delete.

2 Click Workspace > Edit Workspace in the Action toolbar.

or

If your landing page is on a folder, click Folder > Edit Folder.

3 In the Landing Page Layout section, in the content editor, click the delete  icon in the upper right 
corner of the landing page element that you want to delete.

4 Click OK to delete the element.

6.8 Automatically Displaying the Newest Folder Entries on 
Your Landing Page
You do not need to manually modify your landing page every time you want to replace an entry. 
Because it can be tedious to delete an entry and then add another one from the Add/Delete form in 
the Edit Workspace page, Kablink Vibe enables you to leverage the power of workflows to help keep 
your landing page up-to-date, with minimal manual effort.

For example, suppose that you are the manager of a particular product, and you want to use your 
team landing page to display the product’s earnings for the most recent quarter. You could reference 
a particular entry in the Quarterly Earnings folder, where all of the quarterly earnings for the product 
are stored; however, this would mean that at the end of each quarter you would need to manually 
delete the old entry from your landing page, and then add the new entry for the new quarter. Vibe 
provides an easier way: simply reference the Quarterly Earnings folder from your landing page, and 
at the end of each quarter start the Publish workflow (as described in Section 11.6.1, “Available 
Workflows,” on page 161) on the entry that contains the earning for that quarter. This displays the 
entry that contains the updated quarterly earnings.

 Section 6.8.1, “Pointing to the Folder Where the Entry Resides,” on page 78

 Section 6.8.2, “Using the Publish Workflow to Publish Entries to Your Landing Page,” on page 79

6.8.1 Pointing to the Folder Where the Entry Resides

When you add content to your landing page (as described in Section 6.3.3, “Adding Content to Your 
Landing Page,” on page 61), if you display an entry that you might want to replace in the future, you 
should reference the folder where the entry resides instead of referencing the entry directly.

1 Navigate to your landing page.

2 Click Workspace > Edit Workspace.

or

If your landing page is on a folder, click Folder > Edit Folder.

3 In the Landing Page Layout section, in the content editor, click Folder in the element palette, then 
drag the folder into the desired area of the landing page canvas.
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4 Set the following configuration options to finish setting up the folder:

 Folder: Click Edit. 

If you have configured this element as described in this section, the folder that is being 
referenced is shown here.

 Find: Specify the folder where the entry that you want to display resides.

This field uses type-to-find functionality, so Vibe displays the available options as you type.

 Number of entries to show: Specify the number of folder entries that you want to be 
displayed at any one time.

 Show Title Bar: Select this option if you want the folder title bar to be displayed.

 Show Folder Description: Select this option if you want the folder description to be 
displayed.

 Show Entries opened: Select this option if you want opened entries to be displayed.

5 Click OK.

6.8.2 Using the Publish Workflow to Publish Entries to Your Landing Page

By default, Vibe includes a workflow called Publish. This workflow can help you more easily manage 
what is displayed on your landing page.

If you are referencing a folder from your landing page (as described in Section 6.8.1, “Pointing to the 
Folder Where the Entry Resides,” on page 78), and you have configured the landing page to display 
just one entry from the folder, you can use the Publish workflow to decide which entry you want to 
display on your landing page.

The most recent entry that you publish is the entry that is displayed on the landing page (published 
to the landing page).

 “Enabling the Publish Workflow on Your Folder” on page 80

 “Publishing a New Entry to Your Landing Page” on page 80
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Enabling the Publish Workflow on Your Folder

1 Navigate to the folder where you want to enable the Publish workflow.

2 Click Folder > Configure Views, URLs and Controls in the Action toolbar.

3 On the Folder Views, Entries and Workflows tab, in the Allowed Workflows section, select Publish 
Workflow.

4 Click Apply > Close.

Publishing a New Entry to Your Landing Page

1 Open the entry that you want to display on your landing page.

2 In the Entry toolbar, click Workflow > Start Workflow: Publish Workflow.

The entry where you most recently started the Publish workflow is now displayed on your 
landing page, replacing the entry that was previously displayed.

6.9 Adding Accessories to Your Landing Page
You can add accessories to a landing page by modifying the view of the standard landing page, or by 
creating a new landing page view. You must be the Vibe administrator to modify the view of the 
standard landing page. If you are not the Vibe administrator, you must create a new landing page 
view.

 Section 6.9.1, “Modifying the Default Landing Page,” on page 80

 Section 6.9.2, “Creating a New Landing Page View,” on page 81

6.9.1 Modifying the Default Landing Page

You can add the Accessory Panel to the default Landing Page view. This means that all landing pages 
that are created in the Vibe site will contain the Accessory Panel.

You must be the Kablink Vibe administrator or have administrative rights to modify the default 
Landing Page view.

1 Click the Administration icon  in the upper right corner of the Vibe page.

The administration page is displayed.

2 Under System, click Form/View Designers.

The Form and View Designers page is launched.

3 Expand Workspace view, then click Landing Page.

4 Click Workspace view > Add.

5 In the Standard Form Elements section, click Accessory Panel, then click OK.

The Accessory Panel has now been added to the standard Landing Page view, so users can add 
accessories to their landing pages.
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6.9.2 Creating a New Landing Page View

You can create your own Landing Page view, then add the Accessory Panel element to the view. You 
do not need to be the Vibe administrator to create a new landing page view.

 “Creating the New Landing Page Definition” on page 81

 “Adding the Landing Page Layout Option” on page 81

 “Enabling the New Landing Page” on page 82

 “Modifying the Landing Page After You Have Created It” on page 82

Creating the New Landing Page Definition

1 Navigate to the workspace where you want to create the new Landing Page view.

2 Click Workspace > Form/View Designers in the Action toolbar.

The Form and View Designers page is displayed.

3 Click New > Workspace views.

4 Specify the following information:

Caption: Specify a name for the new landing page.

This is the name that appears in the Vibe interface for users to see when they use this workspace. 
(For example, Custom Landing Page.)

Name: Specify the internal name for the landing page.

The name that you enter in this field is not visible to users who use this workspace. (For 
example, custom_landing_page.)

Family: Select the workspace type that this view is most closely associated with.

Workspace Icons: Select the workspace icon that you want to represent the landing page.

5 Click OK.

The Designer page is launched.

6 Continue with “Adding the Landing Page Layout Option” on page 81.

Adding the Landing Page Layout Option

1 In the Designer page, click Workspace Add/Modify Form > Add.

2 In the Layout Options section, click Landing Page Layout.

3 Specify the following information:

Caption: Specify a name for the Landing Page Layout, or keep the default.

Name: Specify the internal name for the Landing Page Layout.

4 Click OK.

5 Click Workspace view > Add.

6 In the Standard Form Elements section, click Landing Page Layout.

7 For the Caption and Data item name fields, retain the same information that you specified in 
Step 3.

8 Click OK > Close > Close.

9 Continue with “Enabling the New Landing Page” on page 82.
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Enabling the New Landing Page

After you have created the new landing page view, you need to enable it on the workspace.

1 From the workspace where you want to enable the landing page, click Workspace > Configure 
Views, URLs and Controls.

2 On the Configure Workspace View tab, in the Default View section, go to the Local Definitions 
subsection and select the landing page that you created.

3 Click Apply > Close.

The landing page is now displayed when you access the workspace.

4 Continue with “Modifying the Landing Page After You Have Created It” on page 82.

Modifying the Landing Page After You Have Created It

Now that you have created and enabled the new landing page, you can configure the landing page 
layout options, such as hiding the Navigation panel. This can give your landing page a more 
traditional landing page feel.

For information about how to modify the landing page layout options, see Section 6.3.1, “Choosing 
Layout Options for Your Landing Page,” on page 58.

6.10 Enabling Graphics to Be Used on a Landing Page
Before you can add a graphic to a landing page, as described in “Adding a Graphic” on page 69, you 
need to attach the graphic to the workspace or folder, depending on whether your landing page is on 
a workspace or folder.

 Section 6.10.1, “Enabling Graphics to Be Used on a Workspace Landing Page,” on page 82

 Section 6.10.2, “Enabling Graphics to Be Used on a Folder Landing Page,” on page 82

6.10.1 Enabling Graphics to Be Used on a Workspace Landing Page

1 Navigate to the landing page where you want to attach the graphic.

2 Click Workspace > Edit Workspace.

3 In the Attachments section, click Browse, then browse to and select the graphic that you want to 
add.

4 After the file is selected and is displayed in the Attachments field, click OK.

To delete a file from the workspace:

1 In the Current Attached Files section, select the file that you want to delete.

2 Click OK.

6.10.2 Enabling Graphics to Be Used on a Folder Landing Page

 “Adding the Attachment Element to the Folder Form” on page 83

 “Attaching the Graphic to the Folder” on page 83
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Adding the Attachment Element to the Folder Form

You should have already added the Landing Page element to both the folder Form and View in order 
to create a landing page for a folder. (For more information, see Section 6.13, “Creating a Landing 
Page for a Folder,” on page 84.)

To enable graphics to be used on your folder landing page:

1 Add the Attachments element to the folder Form, as described in Section 8.3, “Modifying an 
Existing Folder View,” on page 103.

You do not need to add the Attachments element to the folder View, because this element should 
only be displayed on the folder Form.

2 Continue with “Attaching the Graphic to the Folder” on page 83.

Attaching the Graphic to the Folder

1 Navigate to the landing page where you want to attach the graphic.

2 Click Folder > Edit Folder.

3 In the Attachments section, click Browse, then browse to and select the graphic that you want to 
add.

4 After the file is selected and is displayed in the Attachments field, click OK.

To delete a file from the folder:

1 In the Current Attached Files section, select the file that you want to delete.

2 Click OK.

6.11 Displaying YouTube Videos on a Landing Page
Kablink Vibe enables you to display YouTube videos in various sections of a landing page.

 Section 6.11.1, “Displaying Videos in the Branding Section of a Landing Page,” on page 83

 Section 6.11.2, “Displaying Videos in the Main Landing Page Area,” on page 83

6.11.1 Displaying Videos in the Branding Section of a Landing Page

You can add a YouTube video to the Branding section of a landing page, as described in Chapter 5, 
“Branding a Folder or Workspace,” on page 53.

6.11.2 Displaying Videos in the Main Landing Page Area

You can display YouTube videos on a landing page in the following ways:

 By adding an HTML editor, as described in “Adding an HTML Editor” on page 75. Click the 
Expand icon , then click the Video icon .

 By referencing a folder or folder entry that contains a YouTube video, as described in 
Section 6.3.3, “Adding Content to Your Landing Page,” on page 61.
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 For information on how to create a folder entry that contains a YouTube video, see “Displaying 
YouTube Videos in a Folder Entry” in the Kablink Vibe 3.3 User Guide.

![In the Discription section of the workspace, as described in “Displaying YouTube Videos in a 
Workspace” in the Kablink Teaming 3 User Guide.] 

6.12 Creating a Landing Page On Your Personal Workspace
You can create a landing page on your personal workspace only if your Kablink Vibe administrator 
has enabled you to do so. If you are unable to create a landing page on your personal workspace as 
described in this section, consult your Vibe administrator.

If you are a Vibe administrator and you want to enable users to create landing pages on their 
personal workspaces, see “Enabling Users to Create Landing Pages on Personal Workspaces” in the 
Kablink Vibe 3.3 Administration Guide.

1 In your personal workspace, click Workspace > Configure Views, URLs and Controls in the Action 
toolbar.

2 On the Configure Workspace View tab, in the Default View section, select the landing page option 
that your administrator added.

3 Click Apply > Close.

4 Continue with Section 6.3, “Setting Up Your Landing Page,” on page 58 to complete the creation 
of your landing page.

6.13 Creating a Landing Page for a Folder
Displaying landing pages at the workspace level makes the workspace home page a quick portal to 
the most important information contained throughout the workspace. In addition to displaying 
landing pages at the workspace level, Kablink Vibe also enables you to display landing pages at the 
folder level.

You might want to create a landing page for a folder if your folder contains many sub-folders, is 
frequently visited, and contains a lot of information. Because workspace landing pages are more 
common than folder landing pages, the process for creating a landing page on the folder is more 
complex than creating a landing page for a workspace.

By default, in order to create a landing page for a folder in Vibe, you need to create a new folder view. 
(For example, you might name your folder view “Landing Page.”) You need to populate this folder 
view with the Landing Page Layout layout option in the Folder Form, and the Landing Page Layout 
element in the Folder View. For information on how to create a landing page by creating a new folder 
view, see Chapter 8, “Creating Custom Folder Views,” on page 97.
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After you create the new landing page folder view, continue setting up your landing page by 
following the information in Section 6.3, “Setting Up Your Landing Page,” on page 58.

6.14 Downloading Existing Landing Pages
The Novell Vibe Resource Library provides a collection of existing Vibe folder entry forms, 
workflows, and landing pages that have been designed to solve specific business problems. You can 
easily download the custom forms and workflows, then import them into your Vibe environment. 
You can further customize these forms and workflows to suit your individual business needs.

1 Navigate to the Novell Vibe Resource Library Web site (http://www.novell.com/products/vibe-
onprem/resource-library/).

2 Click the Workspaces tab.

3 Select the custom workspace that you want to use in your Vibe environment.

4 In the Attachment section, click the zip file to download it.

5 Import the file into your Vibe environment and deploy it for use.

For information on how to do this, follow the Novell Vibe Resource Library Deployment 
Instructions (http://www.novell.com/products/vibe-onprem/resource-library/demos/
form_workflow_deployment.html).
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7 7Creating Custom Workspace Views

Kablink Vibe enables you to create custom workspace views and to customize existing views. 
Workspace views define what is displayed on the home page of your workspace. When you create 
custom workspace views, you can configure workspaces to display optional features such as remote 
applications, attachments, and more. You can even create a custom workspace landing page.

To create a custom workspace view, you must complete the following sections:

 Section 7.1, “Understanding Workspace Forms and Views,” on page 87

 Section 7.2, “Creating a New Custom Workspace View,” on page 89

 Section 7.3, “Modifying an Existing Workspace View,” on page 93

 Section 7.4, “Enabling the Workspace View,” on page 93

 Section 7.5, “Populating Elements in the Workspace View,” on page 94

 Section 7.6, “Understanding Elements,” on page 94

 Section 7.7, “Understanding Layout Options,” on page 96

7.1 Understanding Workspace Forms and Views
When creating custom workspace views, you must create both the form and the view.

The workspace view is what users see when they access the workspace. Each view must have a 
corresponding form. The form is how workspace administrators enter data, which is then displayed 
in the workspace view. Forms contain a series of fields, presented in a specific order and layout that 
you define.
Creating Custom Workspace Views 87



For example, the form for a Team workspace is what workspace administrators see when they edit 
the workspace by clicking Workspace > Edit Workspace. It looks like this:

The view for a Team workspace is what users see when they access the workspace. It looks like this:
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7.2 Creating a New Custom Workspace View
Vibe enables you to create custom workspace views that contain elements that are unique to your 
needs. To do this, you must create both the form and the view. For more information about forms and 
views, see Section 7.1, “Understanding Workspace Forms and Views,” on page 87.

 Section 7.2.1, “Creating the View,” on page 89

 Section 7.2.2, “Adding Elements to the Workspace Add/Modify Form,” on page 89

 Section 7.2.3, “Adding Elements to the Workspace View,” on page 91

7.2.1 Creating the View

1 Navigate to the workspace where you want to create the new view.

2 Click Workspace > Form/View Designers in the Action toolbar.

The Form and View Designers page is launched.

3 Click New > Workspace Views.

The Add a New Definition form is displayed.

4 Specify the following information in the Add a New Definition section:

Caption: Specify the name of the workspace view that you want to appear in the Kablink Vibe 
interface. (For example, “Custom Workspace.”)

Name: Specify the internal name of the workspace view. This name is not visible to regular Vibe 
users. (For example, “custom_workspace.”)

Family: Select the workspace type that this view is most closely associated with.

Workspace Icons: Select the icon that you want to represent the workspace. The icon that you 
select is displayed with the name of the workspace in the Navigation panel.

5 Click OK.

6 Continue with Section 7.2.2, “Adding Elements to the Workspace Add/Modify Form,” on 
page 89.

7.2.2 Adding Elements to the Workspace Add/Modify Form

The workspace add/modify form is the form you see when you are creating or modifying the content 
of your workspace home page. This form needs to contain the elements and layout options that you 
want to display in your workspace home page. For example, you might want to display multiple 
remote applications and a two-column table.

After you add elements and layout options to the workspace form, you must then add those same 
elements and layout options to the workspace view in order for the elements and options to be 
displayed in your workspace. For information on how to add features to the workspace view, see 
Section 7.2.3, “Adding Elements to the Workspace View,” on page 91.

1 Under the custom workspace form that you created, expand Workspace Add/Modify Form.

If you are modifying an existing form, all of the elements and layout options that are currently 
applied to your form are displayed.

or

If you are creating a new form, only the default options are displayed.
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2 Add and modify the desired elements and layout options, as described in the following sections:

 “Adding Elements to a Form” on page 90

 “Modifying Elements in a Form” on page 90

 “Deleting Elements in a Form” on page 91

 “Adding Layout Options to a Form” on page 91

Based on the modifications that you make to a form element or option, you might need to make the 
same modifications to the corresponding view element or option.

Adding Elements to a Form

1 Click Workspace Add/Modify Form.

2 In the Workspace Add/Modify Form window on the right side of the page, click Add.

3 In the Standard Form Elements section, click the element that you want to add.

For information on the types of elements that you can add, see Section 7.6.1, “Workspace Form 
Elements,” on page 94.

4 Specify the appropriate information.

5 Click OK.

Modifying Elements in a Form

If you are modifying an existing form, you can modify existing elements.

1 Expand Workspace Add/Modify Form, then click the element that you want to modify.

2 In the window on the right side of the page, click Modify.

3 Make the desired modifications, such as changing the caption or data name, then click OK.
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Deleting Elements in a Form

If you are modifying an existing form, you can delete existing elements.

1 Expand Workspace Add/Modify Form, then click the element that you want to delete.

2 In the window on the right side of the page, click Delete.

3 Click OK.

Adding Layout Options to a Form

1 Click Workspace Add/Modify Form.

2 In the Workspace Add/Modify Form window on the right side of the page, click Add.

3 In the Layout Options section, click the layout option that you want to add.

For information on the types of layout options that you can add, see Section 7.7, “Understanding 
Layout Options,” on page 96.

4 Specify the appropriate information.

5 Click OK.

7.2.3 Adding Elements to the Workspace View

The workspace view is how the information from your workspace add/modify form is displayed to 
users who view your workspace. Every form must have a corresponding view. This view needs to 
contain all of the elements and layout options that you want to display in your workspace home 
page; it is made up of elements from the form.

Vibe provides you with all of the tools necessary to create a workspace view that suits any of the 
purposes that you want to accomplish with your workspace.

Before you can add elements and layout options to the workspace view, you must first add the 
elements and layout options to the workspace form in order for them to be displayed in your 
workspace. (For information on how to add features to the workspace form, see Section 7.2.2, 
“Adding Elements to the Workspace Add/Modify Form,” on page 89.)

To add elements to the views:

1 Under the custom entry form that you created, expand Workspace view.

If you are modifying an existing view, all of the elements and layout options that are currently 
applied to your view are displayed.

or

If you are creating a new view, only the default options are displayed.
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2 Add the desired elements and layout options, as described in the following sections:

 “Adding Elements to a View” on page 92

 “Modifying Elements in a View” on page 92

 “Deleting Elements in a View” on page 92

 “Adding Layout Options to a View” on page 93

Adding Elements to a View

1 Click Workspace view.

2 In the Workspace View window on the right side of the page, click Add.

3 In the Standard Form Elements section, click the element that you want to add.

When you add elements to a view, you add elements that have already been added to the form; 
any form element that you create can be added as a view element.

For information on the types of elements that you can add that are specific to views, see 
Section 7.6.2, “Workspace View Elements,” on page 95.

4 Specify the appropriate information.

5 Click OK.

Modifying Elements in a View

If you are modifying an existing view, you can modify existing elements.

1 Expand Workspace view, then click the element that you want to modify.

2 In the window on the right side of the page, click Modify.

3 Make the desired modifications, such as changing the caption or data name, then click OK.

Deleting Elements in a View

If you are modifying an existing view, you can delete existing elements.

1 Expand Workspace view, then click the element that you want to delete.

2 In the window on the right side of the page, click Delete.

3 Click OK.
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Adding Layout Options to a View

1 Click Workspace view.

2 In the Workspace view window on the right side of the page, click Add.

3 In the Layout Options section, click the layout option that you want to add.

For information on the types of layout options that you can add, see Section 7.7, “Understanding 
Layout Options,” on page 96.

4 Specify the appropriate information.

5 Click OK.

7.3 Modifying an Existing Workspace View
You can also create a custom workspace by modifying an existing workspace view.

1 In the folder or workspace where the custom workspace view was created, click Workspace > 
Form/View Designers.

The Form and View Designers page is launched.

2 Expand Workspace view, then click the custom workspace view that you want to modify.

3 Continue with Section 7.2.2, “Adding Elements to the Workspace Add/Modify Form,” on 
page 89.

7.4 Enabling the Workspace View
After you have created the workspace view, you need to enable it as the default view for the 
workspace.

1 Navigate to the workspace where you want to enable your custom view as the default view.

2 Click Workspace > Configure Views, URLs and Controls in the Action toolbar.

3 On the Configure Workspace View tab, in the Local Definitions section, select the custom view that 
you created.

4 Click Apply > Close.
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7.5 Populating Elements in the Workspace View
After you create a workspace view, you need to populate and customize some of the elements that 
you included in the view. 

For example, if you added a Branding element, you need to create your brand to display in the 
workspace; if you added a Description element, you need to populate the element with a description 
of the workspace; if you added an Attachment element, you need to attach any files that you want to 
display in the workspace, and so forth.

1 After the workspace view has been created and enabled as the default workspace view, as 
described in Section 7.4, “Enabling the Workspace View,” on page 93, navigate to the workspace.

2 Click Workspace > Edit Workspace.

A page with all of the form elements that you added to the workspace view add/modify form is 
displayed. (If you want these elements to be displayed in the workspace, ensure that you have 
also added them to the view form of the workspace view.)

3 Populate the elements with the desired information.

For example, add a workspace description and attach any files.

4 Click OK.

7.6 Understanding Elements
Elements make up the content of your workspace forms and views. 

When you are adding elements to a form, remember that you need to add that same element to the 
view in order for it to be displayed in the workspace.

You can add the following elements:

 Section 7.6.1, “Workspace Form Elements,” on page 94

 Section 7.6.2, “Workspace View Elements,” on page 95

7.6.1 Workspace Form Elements

Attachment(s): Adds a field that enables you to browse for and upload files, making them accessible 
to those who view the workspace.

The files that you upload are displayed in the workspace home page.

Checkbox: Adds a check box that can be selected or deselected.

Date: Adds a field that launches a calendar applet when users click inside it.

Date and Time: Adds two fields. The first field launches a calendar applet, and the second field 
launches a time-selection applet when users click inside.

E-Mail List: Adds a field that enables you to specify e-mail addresses.

Description: Adds an HTML text editor that enables you to specify a description of the workspace.

File Upload: Adds a field that enables users to browse for and upload files.

Group List: Adds an element that enables users to add groups.
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Hidden Field: Adds a hidden element. When you design the custom form, you can use this element 
to add boilerplate text to every entry that is created. This text is “hidden” because it does not appear 
on the entry form when users are creating an entry; however, the text does appear on the entry view 
after the entry is created.

HTML Editor Text Area: Adds an HTML text area where you can compose messages, create links, 
upload pictures, and more. The information that you create in this HTML editor is displayed in your 
folder.

Icon: Enables the workspace owner to choose from a selection of icons to represent the workspace.

Number: Adds a field that requires users to enter a number. Alphabetic characters are rejected.

Picture: Adds a field that enables you to browse for and upload pictures.

Radio Buttons: Enables you to display options that users can select with radio buttons.

Remote Application: Enables you to display certain applications that have been configured by your 
Vibe administrator.

For more information on remote applications, see Chapter 12, “Managing Remote Applications,” on 
page 167.

Selectbox: Enables you to display options that users can select.

Team List: Adds a field that enables users to specify teams.

Text: Adds a field where users can enter text.

Text Area: Adds an expandable field where users can enter text.

Title: Adds a field that enables you to specify a title for the workspace.

URL: Add a field that converts any text into a hyperlink. 

User List: Adds a field that enables you to specify other Vibe users, using type-to-find functionality. 
When you specify a user’s name when you modify the workspace, as described in Section 8.5, 
“Populating Elements in the Folder View,” on page 104, Vibe displays the user’s name on the folder 
home page, with links to his or her personal workspaces.

Users External to Vibe: Vibe uses this option internally when synchronizing tasks and calendars to 
another application through iCal. You should not manually add this element to any form or view.

For more information about iCal in Vibe, see “Synchronizing Tasks and Calendars to a Desktop 
Application” in the Kablink Vibe 3.3 User Guide.

7.6.2 Workspace View Elements

Any form element that you create can be added as a view element, if you want it to appear in the 
view. 

The following elements are specific to views; they cannot be added to a form.

Accessory Panel: Displays the Accessory Panel on the workspace home page. Users can use this 
panel to add community or personal accessories, depending on their individual rights.

For more information on accessories, see “Managing Accessories” in the Kablink Vibe 3.3 User Guide.

Attachments: Displays all attachments.
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Landing Page Layout: Adds a landing page creation form that enables you to create landing page 
elements to display in your workspace.

You must add the Landing Page Layout layout option in the workspace add/modify form before you 
can add it as a view element.

Title: On the workspace home page, displays the title that you specified for the workspace.

Workspace and Folder List: Displays a workspace tree that contains the workspace and all sub-
workspaces and sub-folders.

7.7 Understanding Layout Options
Layout options can enhance the presentation of your workspace forms and views. 

When you are adding layout options to a form, remember that you need to add the same layout 
options to the view in order for it to be displayed in the workspace.

You can add the following form layout options:

Box: Places a box around the specified elements.

Custom JSP: Enables you to reference a custom JSP from the Vibe directory.

Custom JSPs must be created by Vibe administrators before you can reference them, as described in 
Chapter 10, “Using Custom JSP Files to Enhance Your Vibe Pages,” on page 123.

Divider: Displays a horizontal line between elements.

Expandable Area: Displays an expandable tree element.

Fieldset: Adds a box that can contain other elements.

Use this option if your form is exceptionally long.

HTML: Adds HTML formatting.

Landing Page Layout: (For the View Definition, the Landing Page Layout is in the Elements section) 
Adds a landing page creation form that enables you to create landing page elements that you can 
populate when you modify your workspace.

Three Column Table: Enables you to add elements within a three-column table.

Two Column Table: Enables you to add elements within a two-column table.
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8 8Creating Custom Folder Views

Kablink Vibe enables you to design custom folder views. Folder views define what is displayed on 
the home page of your folder. When you design custom folder views, you can configure folders to 
display optional features such as remote applications, attachments, and more. You can even create a 
folder landing page.

To create a custom folder view, you must complete the following sections:

 Section 8.1, “Understanding Folder Forms and Views,” on page 97

 Section 8.2, “Creating a New Custom Folder View,” on page 98

 Section 8.3, “Modifying an Existing Folder View,” on page 103

 Section 8.4, “Enabling the Folder View,” on page 104

 Section 8.5, “Populating Elements in the Folder View,” on page 104

 Section 8.6, “Understanding Elements,” on page 104

 Section 8.7, “Understanding Layout Options,” on page 106

8.1 Understanding Folder Forms and Views
When creating custom folder views, you must create both the form and the view.

The folder view is what users see when they access the folder. Each view must have a corresponding 
form. The form is how folder administrators enter data, which is then displayed in the folder view. 
Forms contain a series of fields, presented in a specific order and layout that you define.
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For example, the form for a Discussion folder is what folder administrators see when they edit the 
folder by clicking Folder > Edit Folder. It looks like this:

The view for a Discussion folder is what users see when they access the folder. It looks like this:

8.2 Creating a New Custom Folder View
Vibe enables you to create custom folder views that contain elements that are unique to your needs. 
To do this, you must create both the form and the view. For more information about forms and views, 
see Section 8.1, “Understanding Folder Forms and Views,” on page 97.

 Section 8.2.1, “Creating the View,” on page 98

 Section 8.2.2, “Adding Elements to the Folder Add/Modify Form,” on page 99

 Section 8.2.3, “Adding Elements to the Folder View,” on page 101

8.2.1 Creating the View

1 Navigate to the folder or workspace where you want to create the new view.
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If you create a new folder view at the workspace level, the folder view can be enabled on any 
folder within the workspace. If you create the folder view at the folder level, the folder view can 
be enabled only on that folder where the view was created.

2 If you are creating the new folder view at the folder level, click Folder > Form/View Designers in 
the Action toolbar.

or

If you are creating the new folder view at the workspace level, click Workspace > Form/View 
Designers in the Action toolbar.

The Form and View Designers page is displayed.

3 Click New > Folder Views.

The Add a New Definition form is displayed.

4 Specify the following information in the Add a New Definition section:

Caption: Specify the name of the folder view that you want to appear in the Kablink Vibe 
interface. (For example, “Custom Blog.”)

Name: Specify the internal name of the folder view. This name is not visible to regular Vibe 
users. (For example, “custom_blog.”)

Family: Select the folder type that this view is most closely associated with.

Create a File Entry on file drag/drop: Select this option if you want Vibe to create a new file 
entry when you drag and drop a file into the folder by using the Add Files to Folder feature, as 
described in “Adding a File by Dragging and Dropping” in the Kablink Vibe 3.3 User Guide.

If you do not select this option, the default entry type for the folder is created when you drag 
and drop a file into the folder using the Add Files to Folder feature, as described in “Dragging 
and Dropping Files” in the Kablink Vibe 3.3 User Guide. For example, in a Blog folder, a blog entry 
is created, and the file is added as an entry attachment.

If you are creating a new view for a Files folder, this option has no effect.

Folder Icons: Select the icon that you want to represent the folder. The icon that you select is 
displayed with the name of the folder in the Navigation panel.

5 Click OK.

6 Continue with Section 8.2.2, “Adding Elements to the Folder Add/Modify Form,” on page 99.

8.2.2 Adding Elements to the Folder Add/Modify Form

After you add elements and layout options to the folder form as described in this section, you must 
then add those same elements and layout options to the folder view in order for them to be displayed 
in your folder. For information on how to add elements and layout options to the folder view, see 
“Adding Elements to the Folder View” on page 101.

1 Expand the custom folder form that you previously defined.
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2 Add, modify, and delete elements and layout options, as described in the following sections:

 “Adding Elements to a Folder Form” on page 100

 “Modifying Elements in a Folder Form” on page 100

 “Deleting Elements in a Folder Form” on page 101

 “Adding Layout Options to a Form” on page 101

Based on the modifications that you make to a form element or option, you might need to make the 
same modifications to the corresponding view element or option.

Adding Elements to a Folder Form

1 Click Folder Form.

2 In the Folder Form window on the right side of the page, click Add.

3 In the Standard Form Elements section, click the element that you want to add.

For information on the types of elements that you can add, see Section 8.6.1, “Folder Form 
Elements,” on page 104.

4 Specify the appropriate information to configure the element.

5 Click OK.

Modifying Elements in a Folder Form

If you are modifying an existing form, you can modify existing elements.

1 Expand Folder Form, then click the element that you want to modify.

2 In the window on the right side of the page, click Modify.

3 Make the desired modifications, such as changing the caption or data name, then click OK.
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Deleting Elements in a Folder Form

If you are modifying an existing form, you can delete existing elements.

1 Expand Folder Form, then click the element that you want to delete.

2 In the window on the right side of the page, click Delete.

3 Click OK.

Adding Layout Options to a Form

1 Click Folder Form.

2 In the Folder Form window on the right side of the page, click Add.

3 In the Layout Options section, click the layout option that you want to add.

For information on the types of layout options that you can add, see Section 8.7, “Understanding 
Layout Options,” on page 106.

4 Specify the appropriate information to configure the layout option.

5 Click OK.

8.2.3 Adding Elements to the Folder View

The folder view is how your folder form is displayed to other users. Every folder form must have a 
view associated with it. This view needs to contain all of the elements that you want to display in 
your folder. For information on how to add elements and layout options to the folder view, see 
Section 8.2.2, “Adding Elements to the Folder Add/Modify Form,” on page 99.

1 Expand the custom folder view that you previously defined, then expand Folder View.

If you are modifying an existing view, all of the elements and layout options that are currently 
applied to the view are displayed.

or

If you are creating a new view, only the default options are displayed.
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2 Add, modify, and delete elements and layout options, as described in the following sections:

 “Adding Elements to a Folder View” on page 102

 “Modifying Elements in a Folder View” on page 102

 “Deleting Elements in a Folder View” on page 103

 “Adding Layout Options to a Folder View” on page 103

Adding Elements to a Folder View

1 Click Folder View.

2 In the Folder View Definition window on the right side of the page, click Add.

3 In the Standard Form Elements section, click the element that you want to add to the view.

For information on the types of elements that you can add, see Section 8.6.2, “Folder View 
Elements,” on page 106.

Before you can add some of these elements to your Folder View, you must first add them to the 
Folder Form. For information on how to do this, see “Adding Elements to a Folder Form” on 
page 100.

4 Specify the appropriate information to configure the element.

5 Click OK.

Modifying Elements in a Folder View

If you are modifying an existing view, you can modify existing elements.

1 Expand Folder View, then click the element that you want to modify.

2 In the window on the right side of the page, click Modify.

3 Make the desired modifications, such as changing the caption or data name, then click OK.
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Deleting Elements in a Folder View

If you are modifying an existing view, you can delete existing elements.

1 Expand Folder View, then click the element that you want to delete.

2 In the window on the right side of the page, click Delete.

3 Click OK.

Adding Layout Options to a Folder View

1 Click Folder View.

2 In the Folder View window on the right side of the page, click Add.

3 In the Layout Options section, click the layout option that you want to add.

For information on the types of layout options that you can add, see Section 8.7, “Understanding 
Layout Options,” on page 106.

4 Specify the appropriate information to configure the layout option.

5 Click OK.

8.3 Modifying an Existing Folder View
In addition to creating a new custom folder view as described in Section 8.2, “Creating a New 
Custom Folder View,” on page 98, you can create a custom folder by modifying an existing folder 
view.

1 In the folder or workspace where the custom folder view was previously defined, click Folder > 
Form/View Designers.

The Form and View Designers page is launched.

2 Expand Folder Views, then click the custom folder view that you want to modify.

3 Continue with Section 8.2.2, “Adding Elements to the Folder Add/Modify Form,” on page 99.
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8.4 Enabling the Folder View
After you have defined and designed the folder view, you need to enable it to be viewed by those 
who will use the folder.

You can enable the folder view to be the default folder view for a folder, or to be an alternate folder 
view.

For information on how to do this, see Section 3.1, “Managing Folder Views,” on page 25.

8.5 Populating Elements in the Folder View
After you create and enable a folder view, you need to populate and customize some of the elements 
that you included in the view. 

For example, if you added a Branding element, you need to create your brand to display in the folder; 
if you added a Description element, you need to populate the element with a description of the 
folder; if you added an Attachment element, you need to attach any files that you want to display in 
the folder, and so forth.

1 Ensure that the folder view has been created and enabled as the default folder view, as described 
in Section 8.2, “Creating a New Custom Folder View,” on page 98 and Section 8.4, “Enabling the 
Folder View,” on page 104.

2 Navigate to the folder where you enabled the folder view.

3 Click Folder > Edit Folder in the Action toolbar.

A page with all of form elements that you added to the folder form is displayed. (If you want 
these elements to be displayed in the folder, ensure that you have also added them to the folder 
view, as described in Section 8.2.3, “Adding Elements to the Folder View,” on page 101.)

4 Populate the elements with the desired information.

For example, create your folder brand, add a folder description, attach any files, and so forth.

5 Click OK.

8.6 Understanding Elements
Elements make up the content of your forms and views. Some elements can be used only once. 

When you are adding elements, remember that when you add an element to a form, you need to add 
that same element to the view in order for it to be displayed in the folder.

You can add the following elements:

 Section 8.6.1, “Folder Form Elements,” on page 104

 Section 8.6.2, “Folder View Elements,” on page 106

8.6.1 Folder Form Elements

Attachments: Enables you to display uploaded files as an attachment.

Attachments include a thumbnail, and details about the document, such as file size and author.
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Checkbox: Adds a check box that can be selected or deselected.

Date: Adds a field that launches a calendar applet when users click inside it.

Date and Time: Adds two fields. The first field launches a calendar applet, and the second field 
launches a time-selection applet when users click inside.

E-Mail Address List: Adds a field that enables you to specify e-mail addresses.

Description: Adds an HTML text editor that enables you to provide a description of the folder.

File Upload: Enables you to upload files.

Group List: Adds an element that enables users to add groups.

Hidden Field: Adds a hidden element. When you design the custom form, you can use this element 
to add boilerplate text to every entry that is created. This text is “hidden” because it does not appear 
on the entry form when users are creating an entry; however, the text does appear on the entry view 
after the entry is created.

HTML Editor Text Area: Adds an HTML text editor where you can compose messages, create links, 
upload pictures, and more. The information that you create in this HTML editor is displayed in your 
folder.

Icon: Enables you to change the folder icon that is displayed in the Navigation panel.

Number: Adds a field that requires users to enter a number. Alphabetic characters are rejected.

Picture: Adds a field that enables you to upload a picture to display in your folder.

Radio Buttons: Enables you to display options that users can select with radio buttons.

Remote Application: Enables you to display certain applications that have been configured by your 
Vibe administrator.

For more information on remote applications, see Chapter 12, “Managing Remote Applications,” on 
page 167.

Selectbox: Enables you to display options that users can select.

Team List: Adds a field that enables users to specify teams.

Text: Adds a field where users can enter text.

Text Area: Adds an expandable field where users can enter text.

Title: Adds a field that enables you to specify a title for the workspace.

URL: Add a field that converts any text into a hyperlink. 

User List: Adds a field that enables you to specify other Vibe users, using type-to-find functionality. 
When you specify a user’s name when you modify the workspace, as described in Section 8.5, 
“Populating Elements in the Folder View,” on page 104, Vibe displays the user’s name on the folder 
home page, with links to his or her personal workspaces.

Users External to Vibe: Vibe uses this option internally when synchronizing tasks and calendars to 
another application through iCal. You should not manually add this element to any form or view.

For more information about iCal in Vibe, see “Synchronizing Tasks and Calendars to a Desktop 
Application” in the Kablink Vibe 3.3 User Guide.
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8.6.2 Folder View Elements

Any form element that you create can be added as a view element, if you want it to show up in the 
view. 

The following elements are specific to views; they cannot be added to a form.

Accessory Panel: Displays the Accessory Panel on the workspace home page. Users can use this 
panel to add community or personal accessories, depending on their individual rights.

For more information on Accessories, see “Managing Accessories” in the Kablink Vibe 3.3 User Guide.

Discussion Folder: Displays folder entries in the Discussion folder view.

Entry Creation Date: Displays the date and time that an entry was created.

Entry Creator: Displays the creator of an entry.

Entry Creator and Creation Date: Displays who created the entry and when they created it.

Landing Page Layout: Adds a landing page creation form that enables you to create landing page 
elements to display in your folder.

You must add the Landing Page Layout layout option in the folder form before you can add it as a 
view element.

Title: Adds a field that enables you to specify a title for the workspace.

8.7 Understanding Layout Options
Layout options can enhance the presentation of your folder forms and views in Kablink Vibe. 

When you are adding layout options to a form, remember that you need to add that same layout 
options to the view in order for it to be displayed in the folder.

You can add the following layout options:

Box: Places a box around the specified elements.

Custom JSP: Enables you to reference a custom JSP from the Vibe directory.

Custom JSPs must be created by Vibe administrators before you can reference them, as described in 
Chapter 10, “Using Custom JSP Files to Enhance Your Vibe Pages,” on page 123.

Divider: Displays a horizontal line between elements.

Expandable Area: Displays an expandable tree element.

Use this option if your form is exceptionally long.

Fieldset: Adds a box that can contain other elements.

HTML: Adds HTML formatting.

Landing Page Layout: (For the View Definition, the Landing Page Layout is in the Elements section) 
Adds a landing page creation form that enables you to create landing page elements that you can 
populate when you modify your workspace.

Three Column Table: Enables you to add elements within a three-column table.
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Two Column Table: Enables you to add elements within a two-column table.
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9 9Designing Custom Folder Entry Forms

Folder Entry forms in Kablink Vibe can be customized to suit your precise business needs. You can 
create your own custom entry forms and views by using the Vibe Form and View Designers tool, or 
you can download existing custom entry forms from the Novell Vibe Resource Library.

 Section 9.1, “Downloading Existing Custom Forms and Workflows,” on page 109

 Section 9.2, “Understanding Entry Forms and Views,” on page 109

 Section 9.3, “Creating a Custom Folder Entry Form,” on page 111

 Section 9.4, “Modifying an Existing Entry Form,” on page 117

 Section 9.5, “Understanding Elements,” on page 118

 Section 9.6, “Understanding Layout Options,” on page 120

9.1 Downloading Existing Custom Forms and Workflows
The Novell Vibe Resource Library provides a collection of existing Kablink Vibe folder entry forms 
and workflows that have been designed to solve specific business problems. You can easily 
download the custom forms and workflows, then import them into your Vibe environment. You can 
further customize these forms and workflows to suit your individual business needs.

1 Go to the Novell Vibe Resource Library Web site (http://www.novell.com/products/vibe-
onprem/resource-library/).

2 Click Forms and Workflows.

3 Select the custom form or workflow that you want to use in your Vibe environment.

4 In the Attachment section, click the zip file to download it.

5 Import the file into your Vibe environment and deploy it for use.

For information on how to do this, follow the Novell Vibe Resource Library Deployment 
Instructions (http://www.novell.com/products/vibe-onprem/resource-library/demos/
form_workflow_deployment.html).

9.2 Understanding Entry Forms and Views
When creating custom forms, you must create both the form and the view.

The form is how users enter data into the Vibe system. Forms contain a series of fields, presented in a 
specific order and layout defined by the user who created the custom entry. Each form must have a 
corresponding view that contains all or some of the elements and layout options that exist in the 
form. The view defines how the data for the entry is displayed after it has been added to Vibe by 
users filling out the form.
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For example, the form for a File entry is what users see when they are creating a File entry. Users 
access this form by clicking New File Entry in a Files folder. It looks like this:

The view for a File entry is what users see after the File entry is created. It looks like this:
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9.3 Creating a Custom Folder Entry Form
Kablink Vibe enables you to create custom folder entry forms that contain fields that are unique to 
your needs. To do this, you must create both the form and the view. For more information about 
forms and views, see Section 9.2, “Understanding Entry Forms and Views,” on page 109.

For example, you can create a custom entry form for an expense report.

 Section 9.3.1, “Creating the Folder Entry Form,” on page 111

 Section 9.3.2, “Adding Elements to the Entry Form Definition,” on page 112

 Section 9.3.3, “Adding Elements to the Entry View Definition,” on page 114

 Section 9.3.4, “Adding Elements to the Summary View,” on page 116

9.3.1 Creating the Folder Entry Form

1 Navigate to the folder or workspace where you want to create the custom entry form.

If you create the entry form in a folder, the form can be applied only to entries in that folder. If 
you create the entry form in a workspace, the form can be applied to entries in any folder in the 
workspace.

2 If you are creating the entry form at the folder level, click Folder > Form/View Designers in the 
Action toolbar.

or

If you are creating the entry form at the workspace level, click Workspace > Form/View Designers in 
the Action toolbar.
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The Form and View Designers page is displayed.

3 Click New > Entry Definitions.

The Add a New Definition form is displayed.

4 Specify the following information in the Add a New Definition section:

Caption: Specify a name for the folder entry.

This is the name that appears in the Vibe interface. Users see it when they create an entry of this 
type. (For example, “Expense Report.”)

Name: Specify the internal name for the folder entry.

The name that you enter in this field is not visible to users who create this type of entry. (For 
example, “expense_report.”)

Family: Select the item type that is closest to the function of the item you are creating. Users can 
use the family type when performing filtered searches.

Allowed Comments/Reply Types: Select all of the comments or reply types that you want to 
allow on the entry.

When users comment on this type of entry, they can choose from the options that you specify in 
this section.

To select multiple options, hold the Ctrl key while selecting the comment or reply types.

5 Click OK.

6 Continue with Section 9.3.2, “Adding Elements to the Entry Form Definition,” on page 112.

9.3.2 Adding Elements to the Entry Form Definition

The entry form is what users see when they are creating a new entry. This form needs to contain all of 
the fields necessary for users to create this type of entry. For example, an Expense Report form needs 
to contain the expense code, the purpose for the expense, the cost of the expense, and so forth.

After you add elements and layout options to the entry form, you must then add all of the elements 
and layout options to the entry view in order for them to be displayed when users view the entry. 
(For information on how to add elements to the entry view, see Section 9.3.3, “Adding Elements to the 
Entry View Definition,” on page 114.)

To add elements to the form:

1 Under the custom entry form that you created, expand Entry Form Definition, then expand Form.

All of the elements and layout options that are currently applied to your form are displayed.
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2 Add, modify, and delete the desired elements and layout options, as described in the following 
sections:

 “Adding Elements to a Form” on page 113

 “Modifying Elements in a Form” on page 113

 “Deleting Elements in a Form” on page 114

 “Adding Layout Options to a Form” on page 114

Based on the modifications that you make to a form element or option, you might need to make the 
same modifications to the corresponding view element or option.

Adding Elements to a Form

1 Click Form.

2 In the Form window on the right side of the page, click Add.

3 In the Standard Form Elements section, click the element that you want to add.

For information on the types of elements that you can add, see Section 9.5.1, “Entry Form 
Elements,” on page 118.

4 Specify the appropriate information to configure the element.

5 Click OK.

Modifying Elements in a Form

1 Expand Form, then click the element that you want to modify.

2 In the window on the right side of the page, click Modify.

3 Make the desired modifications, such as changing the caption or data name, then click OK.
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Deleting Elements in a Form

1 Expand Form, then click the element that you want to delete.

2 In the window on the right side of the page, click Delete.

3 Click OK.

Adding Layout Options to a Form

1 Click Form.

2 In the Form window on the right side of the page, click Add.

3 In the Layout Options section, click the layout option that you want to add.

For information on the types of layout options that you can add, see Section 9.6, “Understanding 
Layout Options,” on page 120.

4 Specify the appropriate information to configure the element.

5 Click OK.

9.3.3 Adding Elements to the Entry View Definition

The entry view is how the information from your entry form is displayed to users who view your 
entry. Every form must have a corresponding view. This view needs to contain all of the fields 
necessary for users to get the information they need when viewing the entry; it is made up of 
elements from the form.

Before you can add elements and layout options to the entry view, you must first add those same 
elements and layout options to the entry form in order for them to be displayed in your entry. (For 
information on how to add features to the entry form, see Section 9.3.2, “Adding Elements to the 
Entry Form Definition,” on page 112.)

To add elements to the view:

1 Under the custom entry form that you created, expand Entry View Definition.
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2 Add, modify, and delete the desired elements and layout options, as described in the following 
sections:

 “Adding Elements to an Entry View Definition” on page 115

 “Modifying Elements in an Entry View Definition” on page 115

 “Deleting Elements in an Entry View Definition” on page 116

 “Adding Layout Options to an Entry View Definition” on page 116

Adding Elements to an Entry View Definition

1 Click Entry View Definition.

2 In the Entry View Definition window on the right side of the page, click Add.

3 In the Standard Form Elements section, click the element that you want to add.

For information on the types of elements that you can add, see Section 9.5.2, “Entry View 
Elements,” on page 120.

4 Specify the appropriate information to configure the element.

5 Click OK.

Modifying Elements in an Entry View Definition

1 Expand Entry View Definition, then click the element that you want to modify.

2 In the window on the right side of the page, click Modify.

3 Make the desired modifications, then click OK.
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Deleting Elements in an Entry View Definition

1 Expand Entry View Definition, then click the element that you want to delete.

2 In the window on the right side of the page, click Delete.

3 Click OK.

Adding Layout Options to an Entry View Definition

1 Click Entry View Definition.

2 In the Entry View Definition window on the right side of the page, click Add.

3 In the Layout Options section, click the layout option that you want to add.

For information on the types of layout options that you can add, see Section 9.6, “Understanding 
Layout Options,” on page 120.

4 Specify the appropriate information to configure the element.

5 Click OK.

9.3.4 Adding Elements to the Summary View

The summary view is used to display entries in a folder before the entries are opened.

To add elements to the summary view:

1 Under the custom entry form that you created, expand Summary View.

2 Add, modify, and delete the desired elements and layout options, as described in the following 
sections:

 “Adding Elements to a Summary View” on page 117

 “Modifying Elements in an Summary View Definition” on page 117

 “Deleting Elements in an Summary View Definition” on page 117

 “Adding Layout Options to a Summary View” on page 117
116 Kablink Vibe 3.3 Advanced User Guide



Adding Elements to a Summary View

1 Click Summary View.

2 In the Summary View window on the right side of the page, click Add.

3 In the Standard Form Elements section, click the element that you want to add.

For information on the types of elements that you can add, see Section 9.5.2, “Entry View 
Elements,” on page 120.

4 Specify the appropriate information to configure the element.

5 Click OK.

Modifying Elements in an Summary View Definition

1 Expand Summary View, then click the element that you want to modify.

2 In the window on the right side of the page, click Modify.

3 Make the desired modifications, then click OK.

Deleting Elements in an Summary View Definition

1 Expand Summary View, then click the element that you want to delete.

2 In the window on the right side of the page, click Delete.

3 Click OK.

Adding Layout Options to a Summary View

1 Click Summary View.

2 In the Summary View window on the right side of the page, click Add.

3 In the Layout Options section, click the layout option that you want to add.

For information on the types of layout options that you can add, see Section 9.6, “Understanding 
Layout Options,” on page 120.

4 Specify the appropriate information to configure the element.

5 Click OK.

9.4 Modifying an Existing Entry Form
1 Navigate to the folder or workspace where the custom folder entry was created.

2 If the folder entry was created at the folder level, click Folder > Form/View Designers in the Action 
toolbar.

or

If the folder entry was created at the at the workspace level, click Workspace > Form/View 
Designers in the Action toolbar.

The Form and View Designers page is displayed.
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3 Expand Entry Definitions, then click the custom entry that you want to modify.

4 Continue with Section 9.3.2, “Adding Elements to the Entry Form Definition,” on page 112.

9.5 Understanding Elements
Elements make up the content of your forms and views. 

When you are adding elements, remember that when you add an element to a form, you need to add 
that same element to the view in order for it to be displayed in the custom form.

You can add the following elements:

 Section 9.5.1, “Entry Form Elements,” on page 118

 Section 9.5.2, “Entry View Elements,” on page 120

9.5.1 Entry Form Elements

Cancel Button: Adds the Cancel button.

Checkbox: Adds a check box that can be selected and deselected.

Date: Adds a field that launches a calendar applet when users click inside it.

Date and Time: Adds two fields. The first field launches a calendar applet, and the second field 
launches a time-selection applet when users click inside.

E-Mail Address List: Adds a field that enables you to specify e-mail addresses.

Event: Adds fields that enable users to specify the start time and end time of an event.

File Upload: Adds a field that enables users to browse for and upload files.

Form: This element is for internal use and is required on the entry form.

Form Buttons: Adds the OK and Cancel buttons.
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Group List: Adds a type-to-find field that enables users to find and select Vibe groups.

Guest User Name: Adds a field where users who are logged in to the Vibe site as Guest can specify 
their name. This field is displayed on the entry form only when the Guest user is viewing the form.

HTML Editor Text Area: Adds an HTML text area where users can compose messages, create links, 
upload pictures, and more.

Hidden Field: Adds a hidden element. When you design the custom form, you can use this element 
to add boilerplate text to every entry that is created. This text is “hidden” because it does not appear 
on the entry form when users are creating an entry; however, the text does appear on the entry view 
after the entry is created.

Icon: Enables the workspace owner to choose an icon to represent the workspace.

Number: Adds a field that requires users to enter a number. Alphabetic characters are rejected.

Picture: Adds a field that enables users to browse for and upload pictures.

Places: Adds a workspace tree that enables users to browse to and select folders.

Radio Buttons: Enables you to display options that users can select with radio buttons.

Remote Application: Enables you to choose a remote application to display.

Remote applications must be created and enabled for use by the Vibe administrator.

Selectbox: Enables you to display options that users can select.

Send E-Mail When Entry is Submitted: Adds an option that enables users to automatically send an 
e-mail to other Vibe users, after the entry is submitted.

Show Only When In Workflow States: Enables you to hide elements from being displayed on the 
entry form unless the entry is in a designated state of a workflow.

Subscribe to This Entry: Adds an option that enables users to subscribe to the entry.

Survey: Adds options that enable users to create a survey.

Team List: Adds a field that enables users to specify teams.

Text: Adds a field where users can enter text.

Text Area: Adds an expandable field where users can enter text.

Title: Adds a field where users can enter a title for the entry.

URL: Add a field that converts any text into a hyperlink. 

User List: Adds a field that enables users to use the type-to-find functionality to specify other Vibe 
users.

User List Selectbox: Adds a list of users that you can choose from in the entry form. This list is 
populated from the User List element that is defined on the folder view of the parent folder (for more 
information about how to add a User List element to a custom folder view by either creating a new 
folder view or modifying an existing folder view, see Chapter 8, “Creating Custom Folder Views,” on 
page 97). You need to reference this User List element by specifying the element’s data name in the 
Source User List Element from the Parent Folder when creating the User List Selectbox element.

Users External to Vibe: Vibe uses this option internally when synchronizing tasks and calendars to 
another application by using iCal. You should not manually add this element to any form or view.
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For more information about iCal in Vibe, see “Synchronizing Tasks and Calendars to a Desktop 
Application” in the Kablink Vibe 3.3 User Guide.

9.5.2 Entry View Elements

Any form element that you create can be added as a view element, if you want it to appear in the 
view. 

The following elements are specific to views; they cannot be added to a form.

Attachments: Displays all attachments.

Comments: Displays all comments.

Comments and Attachments Tabs: Displays the Comments and Attachments tabs. Also, where 
applicable, it displays the Entry History and File Versions tabs.

Description: Displays the entry description.

Entry Creation Date: (Not available with a Summary View) Displays the date that the entry was 
created.

Entry Creator: (Not available with a Summary View) Displays who created the entry.

Entry Creator and Creation Date: (Not available with a Summary View) Displays who created the 
entry and when they created it.

Entry Workflow: Displays the workflow process, the state of the workflow process, and any actions 
to be performed on the workflow.

Remote Application: (Not available with a Summary View) Enables you to add custom applications 
that are running on a separate server.

For more information on remote applications, see Chapter 12, “Managing Remote Applications,” on 
page 167.

Replies: All replies to an entry are listed here. You can move this section to another location in the 
entry view by moving this element.

Show Only When In Workflow States: Enables you to hide elements from being displayed on the 
entry view unless the entry is in a designated state of a workflow.

Title: Displays the title of the entry.

9.6 Understanding Layout Options
Layout options can enhance the presentation of your forms and views. 

When you are adding layout options, remember that when you add layout options to a form, you 
need to add the same layout options to the view in order for it to be displayed in the custom form.

You can add the following layout options:

Box: Places a box around the specified elements.

Custom JSP: Enables you to reference a custom JSP from the Vibe directory.
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Custom JSPs must be created by Vibe administrators before you can reference them, as described in 
Chapter 10, “Using Custom JSP Files to Enhance Your Vibe Pages,” on page 123.

Divider: Displays a horizontal line between elements.

Expandable Area: Displays an expandable tree element.

Use this option if your form is exceptionally long.

Fieldset: Adds a box that can contain other elements.

HTML: Adds HTML formatting.

Three Column Table: Enables you to add elements within a three-column table.

Two Column Table: Enables you to add elements within a two-column table.
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10 10Using Custom JSP Files to Enhance 
Your Vibe Pages

Kablink Vibe supports the use of custom JavaServer Pages (JSPs) that can help you modify the 
behavior of certain areas in your Vibe site. For example, your Vibe administrator might enable a 
custom JSP file that enhances the functionality of Vibe landing pages by enabling users to participate 
in a survey directly from a workspace landing page.

Before you can leverage the functionality of custom JSP files, your Vibe administrator must first make 
the files available. Your Vibe administrator will inform you about the names of the files and what 
they can be used for.

Some areas of Vibe, such as landing pages, enable you to add custom JSP files by default. Other areas, 
such as folder and workspace forms and views, first require you to do some additional steps, as 
described in the following sections:

 Section 10.1, “Applying JSP Files to a Landing Page,” on page 123

 Section 10.2, “Enabling Vibe Forms and Views to Reference JSP Files,” on page 123

10.1 Applying JSP Files to a Landing Page
Landing pages can enhance the presentation of your workspaces and folders and increase the 
accessibility of the information they contain. For more information about landing pages, see 
Chapter 6, “Creating and Managing Landing Pages,” on page 55.

By default, JSP files can be applied to your Kablink Vibe landing page. For information on how to 
reference a JSP file from a landing page, see “Adding a Custom JSP” on page 73.

10.2 Enabling Vibe Forms and Views to Reference JSP Files
 Section 10.2.1, “Applying JSP Files to a Folder Entry Form and View,” on page 124

 Section 10.2.2, “Applying JSP Files to a Folder or Workspace View,” on page 125
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10.2.1 Applying JSP Files to a Folder Entry Form and View

Folder entry forms are used to add folder entries to all types of Kablink Vibe folders. Folder entry 
views are used to display folder entries in all types of Vibe folders. You can create your own folder 
entry forms and views, or modify existing forms and views. For more information, see Chapter 9, 
“Designing Custom Folder Entry Forms,” on page 109.

To enable a folder entry form and view to reference a custom JSP file:

1 Create a new custom folder entry form and view, as described in Section 8.2, “Creating a New 
Custom Folder View,” on page 98.

or

Modify an existing folder entry form and view, as described in Section 9.4, “Modifying an 
Existing Entry Form,” on page 117.

Only Vibe administrators have the ability to modify default folder entry forms.

2 Add a JSP layout option and element to the folder entry form, as described in Section 8.2.2, 
“Adding Elements to the Folder Add/Modify Form,” on page 99.

3 Specify the following information:

Caption: Specify a name for the custom JSP.

Data Name: Specify an internal name for the custom JSP.

Custom Form JSP: Specify the filename of the custom JSP file.

You must obtain this filename from your Vibe administrator. Only your Vibe administrator can 
make JSP files available to be used in the Vibe site.

4 Click OK.
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10.2.2 Applying JSP Files to a Folder or Workspace View

Vibe enables you to create custom folder and workspace views. Folder and workspace views define 
what is displayed on the home page of your folder or workspace. When you create custom folder or 
workspace views, you can display optional features such as remote applications, attachments, and 
you can also reference JSP files. For more information, see Chapter 8, “Creating Custom Folder 
Views,” on page 97, and Chapter 7, “Creating Custom Workspace Views,” on page 87.

To enable a folder or workspace view to reference a custom JSP file:

1 Create a new custom folder or workspace view, as described in Section 7.2, “Creating a New 
Custom Workspace View,” on page 89.

or

Modify an existing folder or workspace view, as described in Section 7.3, “Modifying an Existing 
Workspace View,” on page 93.

Only Vibe administrators have the ability to modify default folder and workspace views.

2 Add a JSP layout option and element to the folder or workspace view, as described in 
Section 8.2.3, “Adding Elements to the Folder View,” on page 101 or Section 7.2.3, “Adding 
Elements to the Workspace View,” on page 91, depending on whether you are working with a 
folder or workspace view.

3 Specify the following information:

Caption: Specify a name for the custom JSP.

Data Name: Specify an internal name of the custom JSP.

Custom Form JSP: Specify the filename of the custom JSP file.

You must obtain this filename from your Vibe administrator. Only your Vibe administrator can 
make JSP files available to be used in the Vibe site.

4 Click OK.
Using Custom JSP Files to Enhance Your Vibe Pages 125



126 Kablink Vibe 3.3 Advanced User Guide



11 11Creating and Managing Workflows

Kablink Vibe enables you to create custom workflows to streamline important business processes. 
Vibe administrators can create workflows and implement them across the entire site, and individual 
folder and workspace owners can create workflows to be used in their respective folders and 
workspaces.

After you have created a workflow, you can perform the management functions that are described in 
this section. You can enable workflows to automatically start when certain types of entries are created 
in the folder, when users comment on or reply to an entry, or you can configure them to be manually 
started by users who view the entry.

Examples of workflows include approving documents, ordering supplies, hiring new employees, 
requesting paid time off, and getting expense reimbursements.

 Section 11.1, “Creating a Simple Workflow,” on page 127

 Section 11.2, “Creating an Advanced Workflow,” on page 135

 Section 11.3, “Visually Representing a Workflow,” on page 152

 Section 11.4, “Adding Access Controls to a Workflow,” on page 154

 Section 11.5, “Downloading Existing Custom Forms and Workflows,” on page 161

 Section 11.6, “Workflows Included with Vibe,” on page 161

 Section 11.7, “Enabling Workflows,” on page 162

 Section 11.8, “Testing A Workflow,” on page 164

 Section 11.9, “Importing and Exporting a Workflow,” on page 164

11.1 Creating a Simple Workflow
If you have a straightforward business process that you think might benefit from a workflow, you can 
create a simple workflow to help automate that process, and you don’t need in-depth workflow 
training to do it.

For example, you might want to create a workflow that automates the review process of articles for 
the company magazine. To create a simple workflow such as this, complete the following sections:

 Section 11.1.1, “Creating the Workflow Definition,” on page 128

 Section 11.1.2, “Adding Workflow States,” on page 128

 Section 11.1.3, “Adding Workflow Start and End States,” on page 130

 Section 11.1.4, “Adding Manual Transitions,” on page 131

 Section 11.1.5, “Sending E-Mail Notifications,” on page 133

 Section 11.1.6, “Enabling Your Workflow for Use,” on page 135
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11.1.1 Creating the Workflow Definition

1 Navigate to the workspace or folder where you want to create the workflow.

You can create workflows at the workspace level or at the folder level. If you create a workflow 
at the workspace level, the workflow can be applied to all sub-folders and sub-workspaces. If 
you create a workflow at the folder level, the workflow can be applied only to that folder, and to 
the folder’s sub-folders.

2 If you are creating the workflow at the folder level, click Folder > Form/View Designers in the 
Action toolbar.

or

If you are creating the workflow at the workspace level, click Workspace > Form/View Designers in 
the Action toolbar.

The Form and View Designers page is displayed.

3 In the Form and View Designers page, click New > Workflow Processes.

The Add a New Definition form is displayed.

4 Specify the following information:

Caption: Specify a name for the workflow process.

This is the name that appears in the Vibe interface. Users see it when they use this workflow. 
(For example, “Article Production.”)

Name: Specify the internal name for the workflow process.

The name that you enter in this field is not visible to users who use this workflow. (For example, 
“article_production.”)

5 Click OK.

6 Continue with Section 11.1.2, “Adding Workflow States,” on page 128.

11.1.2 Adding Workflow States

Workflow states are the phases that a workflow goes through as it completes the business process. 

For example, the Article Production workflow contains five states: Article Composition, Peer Review, 
Edit, Manager Approval, Publish.

1 In the Designer page, expand the workflow definition that you created in Section 11.1.1, 
“Creating the Workflow Definition,” on page 128.

2 Click Workflow Process.

3 Click Add.
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4 Click State.

5 Specify the following information:

Caption: Specify a name for the workflow state.

This is the name that appears in the Vibe interface. Users see it when they use this workflow. 
(For example, “Article Composition.”)

Name: Specify the internal name for the workflow state.

The name that you enter in this field is an internal-use database name. Names for elements in a 
definition must be unique. The first character must be an alphabetic character (a-z, A-Z). For the 
rest, you can use alphanumeric characters (a-z, A-Z, 0-9), hyphens (-), and underscores (_).

Description: Describe the function of the state.

6 Click OK.

7 Repeat Step 2 through Step 6 to add additional workflow states.

The new states are added to the workflow and appear in the Workflow Preview section at the 
bottom part of the window.

For more information on the Workflow Preview section, see Section 11.3, “Visually Representing a 
Workflow,” on page 152.

8 Continue with Section 11.2.3, “Adding Workflow Start and End States,” on page 138 for 
information on how you can define start and end states for your workflow.
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11.1.3 Adding Workflow Start and End States

Vibe enables you to add a Start and End state to your workflow. This is important, because without 
an End state, a workflow does not officially stop unless you manually stop it. Adding an End state to 
a workflow automatically stops the workflow when it reaches the final state.

1 Click Workflow Process.

2 In the Workflow process window, click Modify. 

3 Specify the following information:

Initial State: Select the Start state of the workflow process.

End State: Select the End (final) state of the workflow process.

You can select multiple End states by holding the Ctrl key while clicking additional states.

Background Actions Will Run in the Context Of: Select either Entry Owner or Folder Owner.

This option defines the level of access control that the workflow uses. Typically the folder owner 
has more access control rights than the entry owner. Certain workflow operations require the 
appropriate access controls to complete, so selecting Entry Owner might not provide the 
workflow with sufficient access controls. For example, suppose your workflow moves the entry 
to a different folder. If you select to run background actions in the context of the entry owner and 
the user who is running the workflow at the time the entry is to be moved does not have rights 
to create entries in the target folder, the workflow cannot complete. If the folder owner has rights 
to create entries in the target folder, selecting to run background actions in the context of the 
folder owner allows the workflow to complete as designed.

4 Click OK.

In the Workflow Preview section, the Start state is marked with yellow, and the End state is 
marked with red.

For more information on the Workflow Preview section, see Section 11.3, “Visually Representing a 
Workflow,” on page 152.
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5 Continue with Section 11.1.4, “Adding Manual Transitions,” on page 131 for information on how 
you can create transitions that move an entry from one workflow state to the next.

11.1.4 Adding Manual Transitions

After you have defined the workflow states, you need to create transitions that move an entry from 
one state to the next. The easiest kind of transitions to implement are manual transitions. 

Manual transitions provide a drop-down list in the entry that allows the user to choose when to 
transition the entry. The workflow creator decides which workflow states the user can select in the 
drop-down list.

For example, from the “Article Composition” state, the workflow creator might allow the user to 
transition the entry to either the “Peer Review” or the “Edit” state.

To create manual transitions from one workflow state to the next workflow state:

1 Expand Workflow Process, then expand the workflow state where you want to transition the entry 
from.

For this example, expand the “Article Composition” state.
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2 Click Transitions, then click Add in the Transitions box in the right section of the Designer page.

3 Click Manual Transition.

For information regarding the other transition types, see Section 11.2.4, “Adding Transitions,” on 
page 138.

4 In the To State select box, select the next state in the workflow.

This is the state that users will be allowed to transition the entry to.

5 Click OK.

Repeat Step 2 through Step 5 if you want to allow users to select from multiple states.

6 Repeat this procedure for all other states in the workflow.

In the Workflow Preview section, you see a diagram representing all of your workflow states 
(circles) and transitions (arrows).

For more information on the Workflow Preview section, see Section 11.3, “Visually Representing a 
Workflow,” on page 152.
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7 Continue with Section 11.1.5, “Sending E-Mail Notifications,” on page 133.

11.1.5 Sending E-Mail Notifications

Now that you have added your workflow states and specified how the entry will transition through 
those states, you need to set up notifications that inform Vibe users when they need to take action on 
the entry as it moves into a state corresponding with their area of expertise.

For example, Julio composes an article for the company magazine. After he composes the article, he 
transitions the entry to the next workflow state, Peer Review. Anne, Julio’s co-worker, then receives 
an e-mail message notifying her that an article is ready for her to review. After Anne reviews the 
article, she transitions it to the next workflow state, Edit, and so forth.

1 Expand the workflow definition, then click the workflow state where you want the notification 
to be sent.

For example, click Peer Review.

2 Click Add.

3 Click On Entry.

4 In the On Entry box, click OK.

5 Click On Entry. (This is located underneath the workflow state where you just created it.)

In the On Entry box, you can select from many options. These are actions that you can choose to 
perform when the entry enters this workflow state, such as moving the entry to another location, 
copying the entry, or sending notifications. For this basic workflow example, simply select to 
send e-mail notifications. 

For information about all of the options that you can choose to perform when an entry enters a 
workflow state, see Section 11.2.6, “Adding On-Entry or On-Exit Events,” on page 144.

6 Click Add > Notifications.

7 In the Notifications box, specify the following information:
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Entry Creator: Select this option if you want to send a notification to the user who created the 
entry.

Team: Select this option if you want to send a notification to the entire team.

Users: Specify individual users to whom you want to send a notification.

Groups: Specify groups to whom you want to send a notification.

Additional E-Mail Addresses to Notify: Specify an e-mail address where you want a 
notification to be sent.

Select an Entry Type: Use the drop-down list to select the type of entry that most closely 
represents the type of entry that is going through the workflow. Some entry types have user lists, 
group lists, and team lists that are available in the entry type. For example, if you select Task 
Entry, you can select Assigned to, Assigned to Groups, and Assigned to Teams and have notifications 
sent to those users.

Text to be Put in the Notification Subject Line: Specify the text that you want to appear in the 
subject line of the notification that is sent.

For example, Peer Review Needed.

You can use certain HTML constructs to provide specific information about the entry that is 
transitioning through the workflow. For example, you can populate the Notification Subject Line 
with the entry title and who last modified the entry: Workflow notification for 
{{vibe:title}} from {{vibe:modifiedBy}}.

For more information about all the HTML constructs you can use, see Appendix B, “Using 
HTML Markup in Vibe,” on page 207.

Append the Entry Title: (Optional) Select this option if you want the entry title to appear after 
the text in the subject line.

Include a Link to the Entry: Displays a link to the entry in the e-mail notification. This option is 
enabled by default. If you do not want a link to the entry in your e-mail notification, you must 
deselect this option.

Include the Full Entry: Displays the full entry in the e-mail notification.

Text to be Put in the Notification Body: Specify text that you want to appear in the main body 
of the e-mail notification. You can also select Append the Entry Body if you want the main body of 
the entry to display with the e-mail notification message.

Any text formatting that you use in this field needs to be done in the HTML format. Following 
are some examples of HTML formatting:

 <i></i> for italics

 <b></b> for bold

 <br> for a break (return/enter)

 <p></p> for a new paragraph

<a href=“www.example.com”></a> for links to URLs

You can use certain HTML constructs to provide specific information about the entry that is 
transitioning through the workflow. For example, you can populate the Notification Body with 
the name of the user who last modified the entry: This entry was last modified by 
{{vibe:modifiedBy}}.

For more information about all the HTML constructs you can use, see Appendix B, “Using 
HTML Markup in Vibe,” on page 207.

Append the Entry Description: (Optional) Select this option if you want the main body of the 
entry to display with the e-mail notification message.
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8 Click OK.

9 Repeat this process for every workflow state that needs an e-mail notification message.

11.1.6 Enabling Your Workflow for Use

Now that you have created your workflow, you need to enable it. For information on how to do this, 
see Section 11.7, “Enabling Workflows,” on page 162.

11.2 Creating an Advanced Workflow
This section expands the workflow design presented in Section 11.1, “Creating a Simple Workflow,” 
on page 127. 

For example, you might want to create a workflow that automates the expense reporting process for 
your department.

Figure 11-1   Advanced Workflow Example

To create this and other advanced workflows, complete the following sections:

 Section 11.2.1, “Creating the Workflow Definition,” on page 136

 Section 11.2.2, “Adding Workflow States,” on page 136

 Section 11.2.3, “Adding Workflow Start and End States,” on page 138

 Section 11.2.4, “Adding Transitions,” on page 138

 Section 11.2.5, “Setting Up Transition Types,” on page 140

 Section 11.2.6, “Adding On-Entry or On-Exit Events,” on page 144

 Section 11.2.7, “Setting Up On-Entry and On-Exit Events,” on page 145

 Section 11.2.8, “Adding a Parallel Workflow Thread,” on page 148

 Section 11.2.9, “Chaining Workflows,” on page 149

 Section 11.2.10, “Adding a Question to a Workflow,” on page 149

 Section 11.2.11, “Enabling Your Workflow for Use,” on page 152
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11.2.1 Creating the Workflow Definition

1 Navigate to the workspace or folder where you want to create the workflow.

You can create workflows at the workspace level or at the folder level. If you create a workflow 
at the workspace level, the workflow can be applied to any folder or workspace included in the 
workspace. If you create a workflow at the folder level, the workflow can be applied only to that 
folder, and to the folder’s sub-folders.

2 If you are creating the workflow at the folder level, click Folder > Form/View Designers in the 
Action toolbar.

or

If you are creating the workflow at the workspace level, click Workspace > Form/View Designers in 
the Action toolbar.

The Form and View Designers page is displayed.

3 In the Form and View Designers page, click New > Workflow Processes.

The Add a New Definition form is displayed.

4 Specify the following information:

Caption: Specify a name for the workflow process.

This is the name that appears in the Vibe interface. Users see it when they use this workflow. 
(For example, “Expense Report Workflow.”)

Name: Specify the internal name for the workflow process.

The name that you enter in this field is not visible to users who use this workflow. (For example, 
“expense_report_workflow.”)

5 Click OK.

6 After you define a workflow, you need to add states to your workflow. For information on how 
to do this, continue with Section 11.2.2, “Adding Workflow States,” on page 136.

11.2.2 Adding Workflow States

Workflow states are the phases that a workflow goes through as it completes the business process. 

For example, the Expense Report workflow contains six states: Submit Expense Report, Finance 
Department, Needs Attention, Report Processed, Statistics Department, and Records Department.

1 In the Designer page, expand the workflow definition that you created in Section 11.2.1, 
“Creating the Workflow Definition,” on page 136.

2 Click Workflow Process.
136 Kablink Vibe 3.3 Advanced User Guide



3 Click Add.

4 Click State.

5 Specify the following information:

Caption: Specify a name for the workflow state.

This is the name that appears in the Vibe interface. Users see it when they use this workflow. 
(For example, “Article Composition.”)

You can use alphanumeric characters (a-z, A-Z, 0-9), dashes (-), underscores (_), and spaces.

Name: Specify the internal name for the workflow state.

The name that you enter in this field is an internal-use database name. Names for elements in a 
definition must be unique. The first character must be an alphabetic character (a-z, A-Z). For the 
rest, you can use alphanumeric characters (a-z, A-Z, 0-9), hyphens (-), and underscores (_).

Description: Describe the function of the state.

6 Click OK.

7 Repeat Step 2 through Step 6 to add additional workflow states.

The new states are added to the workflow and appear in the Workflow Preview section located in 
the bottom part of the window.

For more information on the Workflow Preview section, see Section 11.3, “Visually Representing a 
Workflow,” on page 152.

8 After you have added states to your workflow, you need to define the Start and End states. For 
information on how to do this, see Section 11.2.3, “Adding Workflow Start and End States,” on 
page 138.
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11.2.3 Adding Workflow Start and End States

Vibe enables you to add Start and End states to your workflow. This is important, because without an 
End state, a workflow does not officially stop unless you manually stop it. Adding an End state to a 
workflow automatically stops the workflow when it reaches the final state.

1 Click Workflow Process.

2 In the Workflow process window, click Modify.

3 Specify the following information:

Initial State: Select the Start state of the workflow process.

End State: Select the End (final) state of the workflow process.

You can select multiple End states by holding the Ctrl key while clicking additional states.

Background Actions Will Run in the Context Of: Select either Entry Owner or Folder Owner.

4 Click OK.

In the Workflow Preview section, Start states are marked with yellow, and End states are marked 
with red.

For more information on the Workflow Preview section, see Section 11.3, “Visually Representing a 
Workflow,” on page 152.

5 Continue with Section 11.2.4, “Adding Transitions,” on page 138 for information on how to 
create transitions that move an entry from one state to the next.

11.2.4 Adding Transitions

After you have defined the workflow states, you need to create transitions that move an entry from 
one workflow state to the next.

1 Expand Workflow Process, then expand the workflow state that you want to transition the entry 
from.

For this example, expand the “Submit Expense Report” state.
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2 Click Transitions, then click Add in the Transitions box in the right section of the Designer page.

3 Click the type of transition that you want to add.

Custom Transition: Use this transition if you want to integrate an external process with a Vibe 
workflow. To do this, consult with your Vibe administrator.

For example, you might want to synchronize a Vibe workflow with an external workflow. You 
can write some custom Java code and use a custom transition to accomplish this. 

Immediate Transition: The entry is immediately transitioned.

Manual Transition: Provides a drop-down list in the entry that allows the user to choose when 
to transition the entry. The workflow creator decides which workflow states the user can select 
in the drop-down list.

Transition After Time Elapsed: The entry is transitioned to the next workflow state after a 
specified amount of time.

Transition on Comment or Reply: The entry is transitioned to the next workflow state after a 
user makes a comment or a reply on the entry.

Transition on Entry Data Values: The entry is transitioned to a new state based on the value that 
a user specifies for a custom element in the entry.

For example:

 If you want to assign an entry to a specific state based on a value the user selects, you define 
a custom element with multiple values from which a user can make a selection (from a 
drop-down list on the form). Map each of these values to specific states in the initial 
workflow state by using the Transition on Entry Data Values option. This option is useful for 
assigning help tickets in a help desk, assigning entries to the appropriate review contact, 
and so on.

 If you want to transition an entry at a specific time, you can transition the entry based on a 
custom date element.

Transition on Modify: The entry is transitioned to a new state when it is modified.

This can be useful for review purposes.

Transition on Response: Allows you to transition an entry to a new state based on a response to 
a question in the entry. Map each possible answer to a workflow question to one of these 
transitions by using the Data name for each Workflow Response. 

For specific instructions on how to do this, see Section 11.2.10, “Adding a Question to a 
Workflow,” on page 149.
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Transition on a Variable: You can make decisions based on the value of a variable that you set. 
For example, you could have a process that sends e-mail notifications when it enters a state. The 
process re-enters that same state later in the process, but you do not want to send the 
notifications more than once. Set up that first state so that it sends notifications only if the “sent 
notifications” variable is not true.

Wait for Parallel Thread(s) to End: Allows you to transition an entry to a new state when one or 
more specified parallel workflow threads end.

4 Specify setup options.

After you select a transition type in Step 3, you must set up the transition. Each transition type 
requires you to specify different setup options.

For specific information regarding the information that you need to specify for the individual 
fields, see “Setting Up Transition Types” on page 140.

5 Click OK.

6 Repeat Step 1 through Step 5 for all other states in the workflow.

In the Workflow Preview section, you see a diagram representing all of your workflow states 
(circles) and transitions (arrows).

For more information on the Workflow Preview section, see Section 11.3, “Visually Representing a 
Workflow,” on page 152.

7 After you have set up how entries transition from one workflow state to another in your 
workflow, you can set up events to occur when the entry enters or exits particular workflow 
states. For information on how to do this, as well as the kinds of entry and exit events that you 
can set up, see Section 11.2.6, “Adding On-Entry or On-Exit Events,” on page 144.

11.2.5 Setting Up Transition Types

When you choose a specific type of transition, you might need to provide specific information 
regarding the type of transition that you selected.

Following are the types of transitions that you can choose from, and information describing the fields 
that you must complete in order to set up each type of transition:

 “Custom Transition” on page 141

 “Immediate Transition” on page 141

 “Manual Transition” on page 141
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 “Transition After Time Elapsed” on page 141

 “Transition on Comment or Reply” on page 142

 “Transition on Entry Data Values” on page 142

 “Transition on Modify” on page 142

 “Transition on Response” on page 142

 “Transition on a Variable” on page 143

 “Wait for Parallel Thread(s) to End” on page 144

Custom Transition

After you begin creating the Custom Transition as described in Section 11.2.4, “Adding Transitions,” 
on page 138, you see the following options:

Condition Class Name: Specify the Java filename where your Vibe administrator created the custom 
transition. Consult with your Vibe administrator to get the name of this file.

To State: Select the state where you want to transition the entry.

Immediate Transition

After you begin creating the Immediate Transition as described in Section 11.2.4, “Adding 
Transitions,” on page 138, you see the following option:

To State: Select the state where you want to immediately transition the entry.

Manual Transition

After you begin creating the Manual Transition as described in Section 11.2.4, “Adding Transitions,” 
on page 138, you see the following option:

To State: Select the state where you want to allow users to transition the entry.

After you create the transition, repeat Step 2 on page 139 through Step 5 on page 140 if you want to 
allow users to select from multiple states.

You can set access controls on the manual transition to allow only certain users to transition the entry. 
If you do not set any access controls, the default is to allow all users who have Write access to the 
entry to transition the entry. For more information about how to set access controls on the manual 
transition, see Section 11.4.3, “Setting Access Controls on a Manual Transition,” on page 159.

Transition After Time Elapsed

After you begin creating the Transition After Time Elapsed transition as described in Section 11.2.4, 
“Adding Transitions,” on page 138, you see various options. You can specify values for each option, 
and the values are added together. For example, if you want to transition entries 4 business days, 3 
hours, and 20 minutes after they enter the workflow state, you enter 4 in the Business Days field, 3 in 
the Hours field, and 20 in the Minutes field.

Numbers entered in the following fields must be whole values. Decimal points and fractions are not 
valid.
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Calendar Days: Specify how many calendar days to wait before the transition. Calendar days include 
weekends and holidays.

Business Days: Specify how many business days to wait before the transition. Business days do not 
include weekends and holidays.

The Vibe administrator determines which days are considered to be business days, as described in 
“Configuring Weekends and Holidays” in “Site Setup” in the Kablink Vibe 3.3 Administration Guide.

Hours: Specify how many hours to wait before the transition.

Minutes: Specify how many minutes to wait before the transition.

To State: Select the state where you want to transition the entry after the elapsed time that you 
specified.

Transition on Comment or Reply

After you begin creating the Transition on Comment or Reply transition as described in 
Section 11.2.4, “Adding Transitions,” on page 138, you see the following option:

To State: Select the state where you want to transition the entry after a user comments on or replies to 
the entry.

Transition on Entry Data Values

After you begin creating the Transition on Entry Data Values transition as described in Section 11.2.4, 
“Adding Transitions,” on page 138, you see the following options:

Match Entry Data Values: Select Match Any if only one condition must be met for the entry to 
transition. Select Match All if all conditions must be met before the entry transitions.

To State: Select the state where you want to transition the entry.

Transition on Modify

After you begin creating the Transition on Modify transition as described in Section 11.2.4, “Adding 
Transitions,” on page 138, you see the following option:

To State: Select the state where you want to transition the entry when the entry is modified.

When you are working with a File entry, modifications made to the file also cause the workflow to be 
transitioned. Modifications to a file include setting the status of the file, incrementing the major 
version, editing the file note, reverting to a previous version, and deleting the file. For more 
information about working with File entries, see “Working with Files in a Folder Entry” in the Kablink 
Vibe 3.3 User Guide

Transition on Response

After you begin creating the Transition on Response transition as described in Section 11.2.4, “Adding 
Transitions,” on page 138, you see the following option:

Workflow Question: Specify the Data Name for the workflow question that you previously defined.

For information on how to create a workflow question, see “Creating a Workflow Question” on 
page 150.
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Workflow Response: Specify the Data Name for the workflow response that you have previously 
defined.

For information on how to create a workflow response, see “Creating Answers to a Workflow 
Question” on page 150.

To State: Select the state where you want to transition the entry after a user responds to the workflow 
question.

The Transition Occurs: 

 As soon as one person answers with the Workflow Response: Transitions the entry 
immediately after one person responds to the workflow question with the value that is in the 
Workflow Response field in the Transition on Response dialog box.

 As soon as a majority have answered with the Workflow Response: Transitions the entry 
immediately after a majority of people respond to the workflow question with the value that is 
in the Workflow Response field in the Transition on Response dialog box.

 After everyone has responded and all have answered with the Workflow Response: 

Transitions the entry after all responders have responded to the workflow question and all 
people respond with the value that is in the Workflow Response field in the Transition on 
Response dialog box.

 After everyone has responded and somebody answered with the Workflow Response: 

Transitions the entry after all responders have responded to the workflow question and at least 
one person responds with the value that is in the Workflow Response field in the Transition on 
Response dialog box.

 After everyone has responded and not all have answered with the Workflow Response: 

Transitions the entry after all responders have responded to the workflow question and at least 
one person responds with a value that is not in the Workflow Response field in the Transition on 
Response dialog box.

 After everyone has responded and a majority answered with the Workflow Response: 

Transitions the entry after all responders have responded to the workflow question and the 
majority of people respond with the value that is in the Workflow Response field in the Transition 
on Response dialog box.

For more information about how to designate specific users to respond to the question, see 
“Designating Specific Users to Respond to a Workflow Question” on page 151

Transition on a Variable

After you begin creating the Transition on a Variable transition as described in Section 11.2.4, 
“Adding Transitions,” on page 138, you see the following options:

Variable Name: Specify the name of the workflow variable that you want to activate the transition.

You must have already created a workflow variable. You create a workflow variable as an On Entry 
or On Exit event, as described in Section 11.2.6, “Adding On-Entry or On-Exit Events,” on page 144.

Variable Value: Specify the value of the workflow variable that you want to activate the transition.

You must have already created a workflow variable. You create a workflow variable as an On Entry 
or On Exit event, as described in Section 11.2.6, “Adding On-Entry or On-Exit Events,” on page 144.

To State: Select the state where you want to transition the entry.
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Wait for Parallel Thread(s) to End

After you begin creating the Wait for Parallel Thread(s) to End transition as described in 
Section 11.2.4, “Adding Transitions,” on page 138, you see the following options:

Parallel Thread Name: Select the parallel thread that you want to wait for.

Transition to State: Select the state where you want to transition the entry after all selected threads 
have ended.

11.2.6 Adding On-Entry or On-Exit Events

You can take action when a process enters or exits a workflow state. For example, when an entry 
enters (or exits) a workflow state, you can send a notification, begin or end a parallel process, set a 
variable, modify an element within the entry, and more.

1 Navigate to and click the workflow state where you want to set up an event to occur when the 
entry enters or exits the state.

2 Click Add.

3 Click On Entry or On Exit, depending on whether you want the event to occur when the entry 
enters or exits the state.

4 In the On Entry (or On Exit) box, click OK.

5 Click On Entry or On Exit, depending on whether you are adding an On Entry or On Exit event. 
(This is located underneath the workflow state where you just created it.)

6 Click Add.

7 Click the type of event that you want to add.

Copy Entry: Allows you to copy an entry to a new location in Vibe when it enters or exits a 
specific state.

When used as an On Entry event, this event cannot be used in the initial state of a workflow or in 
any workflow state that is immediately transitioned to from the initial state with an Immediate 
Transition.

Custom Action: Use the custom action if you want to integrate an external process (usually 
contained within a JAR file) with a Vibe workflow. To do this, consult with your Vibe 
administrator.

For more information about how Vibe administrators can enable JAR files to be used as custom 
workflow actions, see “Enabling Custom JAR Files to Be Used on Your Vibe Site” in the Kablink 
Vibe 3.3 Administration Guide.

Move Entry: Allows you to move an entry to a new location in Vibe when it enters or exits a 
specific state.

Notifications: Allows you to notify specific users or groups about an entry when it enters or 
exits the state.

Remote Application: Remote applications communicate with a third-party online application, 
and send information from that third-party application back into Vibe. You can enable a remote 
application to start when entries enter or exit a workflow state.

Remote applications need to be set up and configured by your Vibe administrator before you 
can add them.

Set Entry Data: Enables you to automatically modify an element within an entry when the entry 
enters or exits a workflow state.
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Set a Workflow Variable: Defines a variable to be used when transitioning a workflow.

This workflow variable is referenced with the Transition On a Variable transition, as described in 
Section 11.2.4, “Adding Transitions,” on page 138.

Start a Parallel Workflow Thread: Allows you to start a parallel workflow when an entry enters 
or exits a specific state. Parallel workflows are useful if two or more processes need to occur 
simultaneously. Only when the parallel thread is finished can the main workflow thread 
proceed.

Before you can start a parallel workflow thread, you first need to create it. For information on 
how to create a parallel workflow thread, see Section 11.2.8, “Adding a Parallel Workflow 
Thread,” on page 148.

Start a Workflow Process: Vibe enables you to chain workflows together. When you are creating 
a workflow (or modifying an existing workflow), you can start an existing workflow process on 
the workflow you are creating (or modifying). This can speed up the workflow creation process 
by helping you make use of existing workflows.

Starting an existing workflow process is not the same as starting a parallel workflow thread. 
Unlike a parallel workflow thread, when you chain workflows together by starting an existing 
workflow process, there is no way to share variables or states between the two workflows; in 
other words, there is no physical connection between the two workflows.

Stop a Workflow Thread: Allows you to stop a parallel workflow when an entry enters or exits 
a specific state.

8 Set up the event you selected in Step 7. Each event type requires you to specify different setup 
options.

For information on what to specify for the individual fields, see Section 11.2.7, “Setting Up On-
Entry and On-Exit Events,” on page 145.

9 Click OK.

10 Repeat this procedure for all other states in the workflow where you want to set up on-entry or 
on-exit events.

11 Set up access controls on the workflow. For information on how to do this, see Section 11.4, 
“Adding Access Controls to a Workflow,” on page 154.

11.2.7 Setting Up On-Entry and On-Exit Events

After you add an on-entry or on-exit event to a workflow as described in Section 11.2.6, “Adding On-
Entry or On-Exit Events,” on page 144, you need to provide information to set up the event.

 “Copy Entry” on page 146

 “Custom Action” on page 146

 “Move Entry” on page 146

 “Notifications” on page 146

 “Remote Applications” on page 147

 “Set Entry Data” on page 147

 “Set a Workflow Variable” on page 148

 “Start a Parallel Workflow Thread” on page 148

 “Start a Workflow Process” on page 148

 “Stop a Workflow Thread” on page 148
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Copy Entry

Select the Destination Folder: Select the folder to copy the entry to.

Selected Folder: Displays the destination folder that you selected.

Start This Workflow on the New Entry: Select the state where you want the workflow to start on the 
new entry. You can configure the workflow to start at the initial state, at the current state, or to not 
start at all.

Custom Action

Action Class Name: Specify the name of the custom action that your Vibe administrator has set up.

Work with your Vibe administrator for information on what you should put in this field.

For more information about how Vibe administrators can enable JAR files to be used as custom 
workflow actions, see “Enabling Custom JAR Files to Be Used on Your Vibe Site” in the Kablink Vibe 
3.3 Administration Guide.

Move Entry

Select the Destination Folder: Select the folder to move the entry to.

Selected Folder: Displays the destination folder that you selected.

Notifications

Entry Creator: Select this option if you want to send a notification to the user who created the entry.

Team: Select this option if you want to send a notification to the entire team.

Users: Specify individual users to whom you want to send a notification.

Groups: Specify groups to whom you want to send a notification.

Additional E-mail Addresses to Notify: Specify an e-mail address where you want a notification to 
be sent.

Select an Entry Type: Use the drop-down list to select the type of entry that most closely represents 
the type of entry that is going through the workflow.

Text to be Put in the Notification Subject Line: Specify the text that you want to appear in the 
subject line of the notification that is sent.

For example, Peer Review Needed.

Append the Entry Title: (Optional) Select this option if you want the entry title to appear after the 
text in the subject line.

Include a Link to the Entry: Displays a link to the entry in the e-mail notification. This option is 
enabled by default. If you do not want a link to the entry in your e-mail notification, you must 
deselect this option.

Include the Full Entry: Displays the full entry in the e-mail notification.
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Text to be Put in the Notification Body: Specify text that you want to appear in the main body of the 
e-mail notification. You can also select Append the Entry Body if you want the main body of the entry 
to display with the e-mail notification message.

Any text formatting that you use in this field needs to be done in the HTML format. Following are 
some examples of HTML formatting:

 <i></i> for italics

 <b></b> for bold

 <br> for a break (return/enter)

 <p></p> for a new paragraph

<a href=“www.example.com”></a> for links to URLs

Append the Entry Body: (Optional) Select this option if you want the main body of the entry to 
display with the e-mail notification message.

Remote Applications

Remote Application: From the drop-down list, select the remote application.

Remote applications need to be set up and enabled by your Vibe administrator before you can use 
them. For more information about remote applications, see Chapter 12, “Managing Remote 
Applications,” on page 167.

Variable Name: Specify the name of the variable to contain the results that are returned by the 
remote application.

Execute Action in the Context Of: Select who you want the remote application to be in relation to: 
Active User, Entry Owner, or Folder Owner.

Set Entry Data

Select an Entry Type: Select the entry type that you want to associate the workflow with.

Select an Element within the Entry: Select the element in the entry that you want to be automatically 
modified.

Select the Operation: Depending on the type of element that you selected, you have various 
modification options that you can perform. Possible operations include:

 Set: Provides another drop-down list whereby you can select the action that you want to 
perform on the element. If it is a text element, you can specify text to be added to the element.

 Set to Now:  Resets the date of the element to the current day and time.

 Increment Date: Increments the date of the element by a specified number of minutes, hours, or 
days.

 Decrement Date: Decrements the date of the element by a specified number of minutes, hours, 
or days.

 Set to Now: Resets the date of the element to the current day and time.

Select the New Value: This is the new value for the element that you are modifying. The options in 
this list are based on the operation that you previously selected.
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Set a Workflow Variable

Variable Value: Specify the name of the workflow variable.

Variable Name: Specify the value of the workflow variable. This is the name that is referenced 
internally.

Start a Parallel Workflow Thread

Parallel Thread Name: Select the parallel workflow thread that you want to start.

You must have already created the parallel workflow thread in order for it to be displayed in this list.

For information on how to create a parallel workflow thread, see Section 11.2.8, “Adding a Parallel 
Workflow Thread,” on page 148.

Start a Workflow Process

Workflow Process: From the drop-down list, select the workflow process that you want to start.

Stop a Workflow Thread

Parallel Thread Name: Select the workflow thread that you want to stop.

11.2.8 Adding a Parallel Workflow Thread

Vibe workflows support parallel workflow threads, which enable you to start a second workflow 
inside of an existing workflow. Parallel workflows are useful if two or more processes need to occur 
simultaneously. The main workflow is dependent on the parallel workflow thread; only when the 
parallel thread is finished can the main workflow thread proceed.

To create a parallel workflow thread:

1 Click Workflow Process.

2 Click Add > Parallel Workflow Thread.

3 Specify the following information:

Caption: Specify a name for the parallel workflow thread.

This is the name that appears in the Vibe interface, that users see when they use this workflow 
thread.

Data Name: Specify the internal name for the parallel workflow thread.

The name that you enter in this field is not visible to users who use this workflow thread.

Start State: Select the first state in the parallel workflow thread.

End State: Select the last state in the parallel workflow thread.

4 Click OK.

For information on how to start and stop a parallel workflow thread after you have created it, see 
Section 11.2.6, “Adding On-Entry or On-Exit Events,” on page 144.
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11.2.9 Chaining Workflows

Vibe enables you to chain workflows together by starting a workflow process inside of a workflow 
that you are creating (or modifying). This can speed up the workflow creation process by helping you 
make use of existing workflows.

Starting an existing workflow process is not the same as starting a parallel workflow thread. Unlike a 
parallel workflow thread, when you chain workflows together by starting an existing workflow 
process, there is no way to share variables or states between the two workflows; in other words, there 
is no physical connection between the two workflows.

You chain workflows by adding an On Entry or On Exit option to the workflow state where you want 
to add the existing workflow process. Use the On Entry or On Exit option to add the existing 
workflow process, as described in Section 11.2.6, “Adding On-Entry or On-Exit Events,” on page 144.

11.2.10 Adding a Question to a Workflow

Workflow questions can enhance the ease and usability of workflows. For example, imagine a Time-
Off Request workflow where a manager can respond to a request by simply selecting Yes or No in the 
workflow. 

In the following example, if the manager selects Yes, the workflow is transferred to the next state of 
the workflow, HR Approval. If the manager selects No, the request is denied and the workflow is 
ended.

Figure 11-2   Workflow Question Layout

 “Creating a Workflow Question” on page 150

 “Creating Answers to a Workflow Question” on page 150

 “Designating Specific Users to Respond to a Workflow Question” on page 151
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 “Creating Transitions” on page 152

 “Setting Access Controls on a Workflow Question” on page 152

Creating a Workflow Question

1 Click the workflow state where you want to add the workflow question.

A workflow question can be specific to a single state (each state can have only one associated 
question), or you can define a global question, which you can then associate with any number of 
states. Global questions are useful when multiple states require the same question and answer 
set.

2 Click Add > Workflow Question.

3 Specify the following information:

Question Text: Specify the question that you want to appear in the workflow.

For example, Approve time-off request?

Data Name: Specify the internal name for the workflow question.

This name must be unique because it is the name that you use to refer to the workflow question 
in future steps. For example, approve_timeoff_request.

4 Click OK.

5 Continue with “Creating Answers to a Workflow Question” on page 150.

Creating Answers to a Workflow Question

1 Click Workflow Question.

This is the question that you created in “Creating a Workflow Question” on page 150.

2 Click Add > Workflow Response.

3 Specify the following information:
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Response Text: Specify a single response option.

For example, Yes.

Data Name: Specify the internal name for the workflow response.

For example, yes.

4 Click OK.

5 Repeat Step 1 through Step 4 to create multiple answers to the same workflow question.

Users using this workflow can choose from the answers that you create.

You can designate specific users as responders to the workflow question, as described in 
“Designating Specific Users to Respond to a Workflow Question” on page 151.

Designating Specific Users to Respond to a Workflow Question

When you designate specific users as responders to a workflow question, you can configure the 
workflow to transition only after all responders have answered the workflow question, or only after 
all responders have answered the workflow question correctly. For more information, see “Transition 
on Response” on page 142. 

1 Click Workflow Question.

This is the question that you created in “Creating a Workflow Question” on page 150.

2 Click Add > Responders.

The Responders dialog box is displayed.

3 In the provided form, specify which users or groups of users you want to specify as responders 
to the workflow question:

Folder Default Access: Select this option to specify all users who have access to the folder as 
responders.

Entry Creator: Select this option to specify the user who created the entry as a responder.

Team: Select this option to specify the team as responders.
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Users: Specify individual users as responders.

Groups: Specify groups as responders.

Select an Entry Type: Select the type of entry that most closely represents the type of entry that 
is going through the workflow.

Select Elements within the Entry: Enables you to select elements that are contained in the entry. 
Users associated with that element are granted access.

For example, if you select Task Entry in the Select an Entry Type drop-down list, the options that 
you can select in the Select Elements within the Entry are Assigned to, Assigned to Groups, Assigned 
to Teams.

4 Click OK.

Creating Transitions

Now that you have created the workflow question and workflow answers, you need to create 
transitions that correspond to the answers that you created. This kind of transition is called 
“Transition on Response.” 

For information on how to create a Transition on Response, see Section 11.2.4, “Adding Transitions,” 
on page 138.

Setting Access Controls on a Workflow Question

If you want to add access controls to this workflow question, you must use the Transition Out of This 
State access control setting. For more information, see Section 11.4, “Adding Access Controls to a 
Workflow,” on page 154.

11.2.11 Enabling Your Workflow for Use

Now that you have created your workflow, you need to enable it. For information on how to do this, 
see Section 11.7, “Enabling Workflows,” on page 162.

11.3 Visually Representing a Workflow
Kablink Vibe enables you to view a visual representation of your workflow, which makes the creation 
process easier by allowing you to envision the workflow in every step of its development.

As you create your workflow in the Designer section, the changes you make are automatically added 
to the Workflow Preview section.
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Figure 11-3   Workflow Preview Section

You can modify the workflow layout in the Workflow Preview section. You must save the layout after 
you have modified it.

 Section 11.3.1, “Modifying a Workflow Layout,” on page 153

 Section 11.3.2, “Saving a Workflow Layout,” on page 153

11.3.1 Modifying a Workflow Layout

You can easily modify the visual representation of a workflow. Modifying the workflow layout can 
make it easier to understand how a workflow process operates because it enables you to better 
visualize the process.

1 In the Workflow Preview section, click a workflow state and drag the state to the desired location.

Transition arrows automatically adjust to the new locations of the workflow states.

11.3.2 Saving a Workflow Layout

By default, every time you make a change in the Designer section when you create a workflow, any 
changes that you previously made in the Workflow Preview section are reverted to the state when you 
last saved.

To save your layout in the Workflow Preview section:

1 Click Save Layout after you have modified your workflow layout.

Now, when you make changes in the Designer section, the changes that you previously made to 
your workflow layout in the Workflow Preview section are retained.
Creating and Managing Workflows 153



11.4 Adding Access Controls to a Workflow
Kablink Vibe enables you to set access controls on workflows that you create. You can set access 
controls on an entire workflow, or on the individual states of a workflow.

 Section 11.4.1, “Setting Access Controls on an Entire Workflow,” on page 154

 Section 11.4.2, “Setting Access Controls on Individual States of a Workflow,” on page 157

 Section 11.4.3, “Setting Access Controls on a Manual Transition,” on page 159

11.4.1 Setting Access Controls on an Entire Workflow

1 In the Designer page, expand the workflow definition that you created in Section 11.2.1, 
“Creating the Workflow Definition,” on page 136.

2 Click Workflow Process.

3 Click Add > Access controls.

4 Click OK.

5 Expand Workflow Process, then click Access controls.

6 Click Add.

7 Click the access control setting that you want to add.
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Delete Access: Enables you to grant specific users rights to delete entries as they transition 
through the workflow process.

Modify Access: Enables you to grant specific users rights to modify entries as they transition 
through the workflow process.

Modify Specified Fields: Enables you to grant specified users or groups rights to modify 
specific fields within an entry as the entry transitions through the workflow. 

Field elements must first be configured to allow field-level modifications. You designate which 
fields have the field-level modification access control by selecting the Allow field level modification 
option when you are creating or modifying an element within the entry form, as described in 
“Adding Elements to a Form” on page 113 and “Modifying Elements in a Form” on page 113. 
The elements that have been configured to allow field-level modifications can be modified only 
by the users that you specify in the Modify Specified Fields access control, and only in the 
workflow state where this access control exists.

Read Access: Enables you to grant specific users rights to read entries as they transition through 
the workflow process. Furthermore, you can choose whether or not users are allowed to 
comment or reply to the entries.

Transition Into This State: Enables you to grant specific users rights to transition entries into 
any state in the workflow.

Transition Out of This State: Enables you to grant specific users rights to transition entries out 
of any state in the workflow.

This is the access control setting that determines who can see a workflow question. If you are 
adding a workflow question to your workflow or to an individual state, as described in 
Section 11.2.10, “Adding a Question to a Workflow,” on page 149, and you want to add access 
controls to determine who sees the question, you must use this access control setting.

8 Define the access control setting that you added in Step 7 by specifying the following 
information in the provided form:
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Folder Default Access: Select this option to grant access to all users who have access to the 
folder.

Entry Creator: Select this option to grant access to the user who created the entry.

Team: Select this option to grant access to the team.

Users: Specify individual users to whom you want to grant access.

Groups: Specify groups to whom you want to grant access.

Select an Entry Type: Select an entry type that contains a user list. Users who are in the user list 
that you select in the Select Elements within the Entry field are granted access.

Select Elements within the Entry: Select the user list fields that are contained within the 
selected entry type that contain users who you want to grant access.

Access control rights can be granted only for the User List, Group List, and List elements. By 
default, only calendar entry types and task entry types contain these elements. For Calendars, 
this is the Attendee, Attendee Groups, and Attendee Teams fields. For tasks, this is the Assigned to, 
Assigned to Groups, and Assigned to Teams fields.

For information about how to add these elements to existing entry types, or how to create your 
own custom entry types where you can add these elements, see Chapter 9, “Designing Custom 
Folder Entry Forms,” on page 109.

9 Click OK.
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11.4.2 Setting Access Controls on Individual States of a Workflow

1 In the Designer page, expand the workflow definition that you created in Section 11.2.1, 
“Creating the Workflow Definition,” on page 136.

2 Expand Workflow Process, then click the state where you want to add the access controls.

3 Click Add > Access controls.

4 Click OK.

5 Expand the state where you just added the access controls, then click Access controls.

6 Click Add.

7 Click the access control setting that you want to add.

Delete Access: Enables you to grant specific users rights to delete entries when they are in this 
workflow state.

Modify Access: Enables you to grant specific users rights to modify entries when they are in this 
workflow state.

Modify Specified Fields: Enables you to grant specified users or groups rights to modify 
specific fields within an entry as the entry transitions through the workflow. 

Field elements must first be configured to allow field-level modifications. You designate which 
fields have the field-level modification access control by selecting the Allow field level modification 
option when you are creating or modifying an element within the entry form, as described in 
“Adding Elements to a Form” on page 113 and “Modifying Elements in a Form” on page 113. 
The elements that have been configured to allow field-level modifications can be modified only 
by the users that you specify in the Modify Specified Fields access control, and only in the 
workflow state where this access control exists.

Read Access: Enables you to grant specific users rights to read entries when they are in this 
workflow state. Furthermore, you can choose whether or not users are allowed to comment or 
reply to the entries.

Transition Into This State: Enables you to grant specific users rights to transition entries into 
this state.
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This setting is relevant only when a manual transition is defined involving this state.

Transition Out of This State: Enables you to grant specific users rights to transition entries out 
of this state.

This setting is relevant only when a manual transition is defined involving this state.

8 Define the access control setting that you added in Step 7 by specifying the following 
information in the provided form:

Folder Default Access: Select this option to grant access to users who have access to the folder.

Entry Creator: Select this option to grant access to the user who created the entry.

Team: Select this option to grant access to the team.

Users: Specify individual users to whom you want to grant access.

Groups: Specify groups to whom you want to grant access.

Select an Entry Type: Select an entry type that contains a user list. Users who are in the user list 
that you select in the Select Elements within the Entry field are granted access.

Select Elements within the Entry: Select the user list fields that are contained within the 
selected entry type that contain users who you want to grant access.
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Access control rights can be granted only for the User List, Group List, and List elements. By 
default, only calendar entry types and task entry types contain these elements. For Calendars, 
this is the Attendee, Attendee Groups, and Attendee Teams fields. For tasks, this is the Assigned to, 
Assigned to Groups, and Assigned to Teams fields.

For information about how to add these elements to existing entry types, or how to create your 
own custom entry types where you can add these elements, see Chapter 9, “Designing Custom 
Folder Entry Forms,” on page 109.

9 Click OK.

11.4.3 Setting Access Controls on a Manual Transition

1 In the Designer page, expand the workflow definition that you created in Section 11.2.1, 
“Creating the Workflow Definition,” on page 136.

2 Expand Workflow Process, expand the state that contains the manual transition where you want 
to set the access controls, expand Transitions, then click Manual Transition.

3 Click Add > Manual Transition Access Controls.
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4 In the provided form, specify which users or groups of users who you want to grant access to 
transition the entry:

Folder Default Access: Select this option to grant access to users who have access to the folder.

Entry Creator: Select this option to grant access to the user who created the entry.

Team: Select this option to grant access to the team.

Users: Specify individual users to whom you want to grant access.

Groups: Specify groups to whom you want to grant access.

Select an Entry Type: Select an entry type that contains a user list. Users who are in the user list 
that you select in the Select Elements within the Entry field are granted access.

Select Elements within the Entry: Select the user list fields that are contained within the 
selected entry type that contain users who you want to grant access.

Access control rights can be granted only for the User List, Group List, and List elements. By 
default, only calendar entry types and task entry types contain these elements. For Calendars, 
this is the Attendee, Attendee Groups, and Attendee Teams fields. For tasks, this is the Assigned to, 
Assigned to Groups, and Assigned to Teams fields.
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For information about how to add these elements to existing entry types, or how to create your 
own custom entry types where you can add these elements, see Chapter 9, “Designing Custom 
Folder Entry Forms,” on page 109.

5 Click OK.

11.5 Downloading Existing Custom Forms and Workflows
The Novell Vibe Resource Library provides a collection of existing Vibe folder entry forms and 
workflows that have been designed to solve specific business problems. You can easily download the 
custom forms and workflows, then import them into your Vibe environment. You can further 
customize these forms and workflows to suit your individual business needs.

1 Navigate to the Novell Vibe Resource Library Web site (http://www.novell.com/products/
teaming/resource-library/).

2 In the Forms and Workflows tab, select the custom form or workflow that you want to use in your 
Vibe environment.

3 In the Attachment section, click the zip file to download it.

4 Import the file into your Vibe environment and deploy it for use.

For information on how to do this, follow the Novell Vibe Resource Library Deployment 
Instructions (http://www.novell.com/products/vibe-onprem/resource-library/demos/
form_workflow_deployment.html).

11.6 Workflows Included with Vibe
Kablink Vibe includes three predefined workflows. One is available for you to enable and use; the 
others are used within Vibe.

 Section 11.6.1, “Available Workflows,” on page 161

 Section 11.6.2, “Internal Workflows,” on page 162

11.6.1 Available Workflows

Vibe currently includes the Publish workflow, which is functional as soon as you enable it, as 
described in Section 11.7, “Enabling Workflows,” on page 162.

You can use the Publish workflow in the following ways:

Publish Entries to a Landing Page: You can use the Publish workflow to publish entries to a landing 
page, without manually modifying the contents of the landing page.

For more information, see Section 6.8, “Automatically Displaying the Newest Folder Entries on Your 
Landing Page,” on page 78.

Keep Entries Private: You can use the Publish workflow to keep entries private until you are ready to 
publish them for other Vibe users to read.

For example, you can associate the Publish workflow with a certain entry type in a folder (see 
Section 11.7.1, “Enabling Workflows to Start When an Entry Is Created,” on page 163 for more 
information). When you create an entry in the folder, the entry is created as Private. When you are 
ready for other Vibe users to view the entry, you can change the workflow status to Publish. 
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To transition the workflow status of an entry from Private to Publish:

1 Open the entry, and in the Transition to field, select Publish in the drop-down list.

2 Click OK.

To make the workflow status of the entry Private again:

1 Open the entry where you want to change the workflow status.

2 In the Entry toolbar, click Workflow > Stop Workflow: Publish Workflow, then click OK when you 
are asked if you really want to stop the workflow.

3 In the Entry toolbar, click Workflow > Start Workflow: Publish Workflow, then click OK when you 
are asked if you really want to start the workflow.

The workflow status of the entry is now Private.

11.6.2 Internal Workflows

Vibe includes two workflows that are used internally.

 “Task Workflow” on page 162

 “Calendar Workflow” on page 162

Task Workflow

Vibe uses the Task workflow internally to allow all users who are assigned to a particular task to 
make modifications to the task, if they are not members of the workspace where the task resides.

This workflow should not be manually added to any workspace or folder.

Calendar Workflow

Vibe uses the Calendar workflow internally to allow all users who are attendees in an event to make 
modifications to the calendar event, if they are not members of the workspace where the event 
resides.

This workflow should not be manually added to any workspace or folder.

11.7 Enabling Workflows
After a workflow is created, you can enable the workflow to automatically start when certain types of 
entries are created in the folder, or when users comment on or reply to entries. Or, you can enable 
users to manually start workflows when they view the entry.

Before you can enable a workflow, the workflow must first be created. For information on how to 
create a workflow, see either Section 11.1, “Creating a Simple Workflow,” on page 127 or Section 11.2, 
“Creating an Advanced Workflow,” on page 135, depending on the type of workflow that you want 
to create.
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You can enable workflows only in folders for which you have appropriate rights. When you enable a 
workflow in a folder, it is automatically enabled on all sub-folders and sub-workspaces, and can be 
applied to all entries that are created in that folder and its sub-folders.

 Section 11.7.1, “Enabling Workflows to Start When an Entry Is Created,” on page 163

 Section 11.7.2, “Enabling Workflows to Start When Users Comment on or Reply to an Entry,” on 
page 163

 Section 11.7.3, “Allowing Users to Manually Start Workflows,” on page 164

11.7.1 Enabling Workflows to Start When an Entry Is Created

You can enable a workflow to automatically start on all entries that are created in a specific folder, 
whenever an entry is created. This is called “associating workflows with entries.”

1 Navigate to the folder where you want to enable the workflow.

2 Click Folder > Configure Views, URLs and Controls in the Action toolbar.

3 On the Folder Views, Entries and Workflows tab, in the Workflow Associations section, click the drop-
down list next to the entry type that you want to associate the workflow with, then select the 
desired workflow.

To add workflows to this drop-down list, you need to create them. After workflows have been 
created at this folder level, or at a higher workspace level, they appear in this list. For 
information on how to create workflows, see either Section 11.1, “Creating a Simple Workflow,” 
on page 127 or Section 11.2, “Creating an Advanced Workflow,” on page 135, depending on the 
type of workflow that you want to create.

4 Click Apply > Close.

Now, when this type of entry is created in this folder, Vibe automatically starts the workflow by 
placing the entry in the initial state of the workflow process that you specified.

When you enable a folder to support multiple entry types, you can associate workflows to the 
specific types of entries. For example, if you have a folder that supports both file entries and calendar 
entries, you can have one kind of workflow start when you create a file entry, and another kind of 
workflow start when you create a Calendar entry. For information on how to enable multiple entry 
types in a single folder, see Section 3.2.1, “Enabling Alternate Folder Entry Types,” on page 27.

11.7.2 Enabling Workflows to Start When Users Comment on or Reply to an 
Entry

You can enable a workflow to automatically start when users comment on or reply to an entry. This is 
called “associating workflows with comments or replies.”

1 Navigate to the folder where you want to enable the workflow.

2 Click Folder > Configure Views, URLs and Controls in the Action toolbar.

3 On the Folder Views, Entries and Workflows tab, in the Workflow Associations section, click the drop-
down list next to the comment or reply type that you want to associate the workflow with, then 
select the desired workflow.
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To add workflows to this drop-down list, you need to create them. After workflows have been 
created at this folder level, or at a higher workspace level, they appear in this list. For 
information on how to create workflows, see either Section 11.1, “Creating a Simple Workflow,” 
on page 127 or Section 11.2, “Creating an Advanced Workflow,” on page 135, depending on the 
type of workflow that you want to create.

4 Click Apply > Close.

Now, when this type of comment or reply is made to an entry in this folder, Vibe automatically 
starts the workflow by placing the entry in the initial state of the workflow process that you 
specified.

11.7.3 Allowing Users to Manually Start Workflows

You can allow users to decide if they want to start a workflow on an entry, and if they do, at what 
point they want to start the workflow. Also, you can give users the option to choose among multiple 
workflows for each entry.

1 Navigate to the folder where you want to enable users to start the workflows.

2 Click Folder > Configure Views, URLs and Controls in the Action toolbar.

3 On the Folder Views, Entries and Workflows tab, in the Allowed Workflows section, select the 
workflows that you want to allow users to choose from.

The Local Definitions section in the Allowed Workflows section displays all of the workflows that 
you have created locally. The other workflows listed in the Allowed Workflows section were either 
created by your Vibe administrator, by another user at a higher level in the workspace tree, or 
are included with the Vibe product.

4 Click Apply > Close.

Now, when users create entries in this folder, they can start and stop workflows as they desire. 
For information on how to start and stop a workflow, see “Using Workflows” in the Kablink Vibe 
3.3 User Guide.

11.8 Testing A Workflow
To test a workflow, simply create the workflow in a testing workspace and ensure that it works 
according to your specifications. When the workspace is ready to be deployed in a production 
environment, export the workflow, then import it into the production workspace where you want to 
deploy it.

For information on how to import and export a workflow, see Section 11.9, “Importing and Exporting 
a Workflow,” on page 164.

11.9 Importing and Exporting a Workflow
Kablink Vibe enables you to import and export workflows into and out of Vibe.

 Section 11.9.1, “Importing a Workflow,” on page 165

 Section 11.9.2, “Exporting a Workflow,” on page 165
164 Kablink Vibe 3.3 Advanced User Guide



11.9.1 Importing a Workflow

1 Navigate to the workspace where you want to import the workflow.

2 Click Workspace > Form/View Designers in the Action toolbar.

3 Click Import.

The Import Definitions page is displayed.

4 Click Browse.

5 Browse for and select the workflow that you want to import.

6 Click OK > Close.

11.9.2 Exporting a Workflow

1 Navigate to the workspace where you created the workflow.

2 Click Workspace > Form/View Designers.

3 Click Export.

The Export Definitions page is launched.

4 Expand Workflow Processes, then select the workflow that you want to export.

5 Click OK.

6 Select the location where you want to save the workflow, then save it.
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12 12Managing Remote Applications

Remote applications communicate with a third-party, online application, and send information from 
the third-party application back into Kablink Vibe. 

For example, your Vibe administrator could create a remote application for Twitter that displays all 
of your Twitter entries in Vibe. 

Remote applications are vastly customizable, and are set up by your Vibe administrator. Talk with 
your Vibe administrator if you have a request for a new remote application.

This section describes how to set up remote applications after they have already been created and 
enabled by your Vibe administrator. 

 Section 12.1, “Adding Remote Applications to Views and Forms,” on page 167

 Section 12.2, “Setting Up a Remote Application,” on page 168

 Section 12.3, “Setting Up Multiple Remote Applications on a Single Page,” on page 170

 Section 12.4, “Managing Access Controls for Remote Applications,” on page 172

12.1 Adding Remote Applications to Views and Forms
Kablink Vibe enables you to add a Remote Application element to a folder or workspace view or a 
custom form. The Remote Application element is a drop-down list that enables users of the view or 
form to select from a list of remote applications. This is useful if the current view or form does not 
allow you to select a remote application to run; it is also useful if you want to run multiple remote 
applications in a single view or form. (For specific information on configuring a view or form to run 
multiple remote applications, see Section 12.3, “Setting Up Multiple Remote Applications on a Single 
Page,” on page 170.)

Unless you are the Vibe administrator, you can perform the following procedure only on custom 
views and forms for which you have appropriate rights. You can create custom views and forms for 
workspaces, folders, or entries, as described in Chapter 7, “Creating Custom Workspace Views,” on 
page 87, Chapter 8, “Creating Custom Folder Views,” on page 97, and Chapter 9, “Designing Custom 
Folder Entry Forms,” on page 109.

To add a Remote Application element to a view or form:

1 Navigate to the workspace or folder where you want to add the Remote Application element.

If you want to add the Remote Application element to a form, navigate to the workspace or 
folder where the form was created.

2 Click Workspace > Form/View Designers if the form was created at the workspace level.

or

Click Folder > Form/View Designers if the form was created at the folder level.

The Form and View Designers page is displayed.
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3 Click the entry definition, folder view, or workspace view where you want to add the Remote 
Application element.

4 Add the Remote Application element to the desired folder view, workspace view, or entry 
definition, as described in the following sections:

Folder View: Section 8.2.2, “Adding Elements to the Folder Add/Modify Form,” on page 99.

Workspace View: Section 7.2.2, “Adding Elements to the Workspace Add/Modify Form,” on 
page 89.

Entry Definition (Form): Section 9.3.2, “Adding Elements to the Entry Form Definition,” on 
page 112.

12.2 Setting Up a Remote Application
 Section 12.2.1, “Setting Up a Remote Application in a Workspace,” on page 168

 Section 12.2.2, “Setting Up a Remote Application as an Accessory,” on page 169

12.2.1 Setting Up a Remote Application in a Workspace

1 Navigate to the workspace or folder where you want to display the remote application.

2 Click Workspace > Edit Workspace, or Folder > Edit Folder.

3 In the Remote Application section, click the drop-down list and select the remote application that 
you want to enable.

4 Click OK.

The remote application is displayed at the top of the folder or workspace.
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12.2.2 Setting Up a Remote Application as an Accessory

Kablink Vibe allows you to set up remote applications as accessories. You might want to do this if 
you want to view more than one remote application on a single Vibe page.

1 Navigate to the page where you want to create the Remote Application accessory.

2 Locate the Accessory Panel, then click Accessory Panel.

3 Click Add an Accessory.

4 Select the scope of the accessory you want to create, then select Remote Application.

5 Click OK.
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6 Specify a title for the accessory, then use the Remote Application drop-down menu to select the 
remote application that you want to add.

7 Click Apply > Close.

The new accessory is displayed.

12.3 Setting Up Multiple Remote Applications on a Single Page
You can use either of the following methods to set up multiple remote applications on a single 
Workspace or Folder.

 Section 12.3.1, “Launching a Remote Application as an Accessory,” on page 170

 Section 12.3.2, “Creating a New Workspace or Folder View That Supports Multiple Remote 
Applications,” on page 171

12.3.1 Launching a Remote Application as an Accessory

If you want to view more than one remote application on a single Kablink Vibe page, you can set up 
one remote application in your workspace, and then you can view subsequent remote applications as 
accessories.

For more information on viewing remote applications as accessories, see Section 12.2.2, “Setting Up a 
Remote Application as an Accessory,” on page 169.
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12.3.2 Creating a New Workspace or Folder View That Supports Multiple 
Remote Applications

If you don’t want your remote application to be displayed as an accessory, but you still want to enable 
multiple remote applications on a single page, you can accomplish this by creating a new view for the 
workspace or folder where you want the remote applications to be displayed, and then configuring 
the workspace or folder to support the new view.

 “Creating the New View” on page 171

 “Configuring the Workspace or Folder to Support the New View” on page 171

 “Using the New View to Enable a Remote Application” on page 172

Creating the New View

1 In the Workspace or Folder where you want to enable additional remote applications, click 
Workspace > Form/View Designers or Folder > Form/View Designers.

The Form and View Designers page is launched.

2 Click New > Folder Views or Workspace Views, depending on whether you are working in a 
workspace or folder.

3 Provide a caption and a name for the new definition. 

4 Select the type of workspace for which you want to create the new definition.

5 Click OK.

6 Click the Workspace Add/Modify Form link.

7 In the box on the right side of the page, click Add.

8 In the Form Elements section, click Remote Application.

9 Provide a caption and a name for the new remote application field that you’re creating.

The text that you enter in the Caption field is what the remote application field is called in the 
workspace or folder form.

10 Click OK.

11 Click Close to exit the Form and View Designer.

Configuring the Workspace or Folder to Support the New View

 “Configuring a Workspace to Support the New View” on page 171

 “Configuring a Folder to Support the New View” on page 171

Configuring a Workspace to Support the New View

For information on how to configure the workspace to support the new view that you created in 
“Creating the New View” on page 171, see Section 7.4, “Enabling the Workspace View,” on page 93.

Configuring a Folder to Support the New View

For information on how to configure the workspace to support the new view that you created in 
“Creating the New View” on page 171, see Section 3.1.1, “Changing the Default Folder View,” on 
page 25.
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Using the New View to Enable a Remote Application

Now that you have created the new definition and configured the workspace or folder to support it, 
you need to enable the additional remote application.

To enable the additional remote application, see Section 12.2, “Setting Up a Remote Application,” on 
page 168.

12.4 Managing Access Controls for Remote Applications
Because not all remote applications can be completely trusted, it is often a good idea to limit the 
privileges of the remote application. Because Kablink Vibe administrators are responsible for creating 
and enabling the remote application for the Vibe site, they are also responsible for setting up access 
controls on the remote application.

Before you modify the access control settings of remote applications for a specific workspace or 
folder, you should consult with your Vibe administrator to ensure that what you plan to do is safe.

When an application is restricted to a specific role, the application can use Web services to perform 
only those tasks that are allowed for that role. For example, the Participant role can create new 
entries, modify entries that the user created, add comments to entries, and so on. Participants cannot 
perform system administration tasks and cannot modify other users’ entries.

To limit the remote application to privileges assigned to a specific role:

1 Navigate to the folder or workspace where you want to set the access control settings on the 
remote application.

2 Click Workspace > Access Control or Folder > Access Control.

3 On the Configure Access Control page, click Add an Application.

4 In the Add an Application field, use type-to-find functionality to specify and select the application 
that you want to add.

5 Close the Add an Application panel by clicking the X in the upper right corner.

6 In the access control table, select the check box that is located in the row of the remote 
application that you just added, and the column of the role that you want to assign to the 
application.
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7 Click Save Changes > Close.

The application that you added is now restricted to those operations allowed for the role that you 
selected. For example, if you assigned the Participant role to the remote application, then the 
inheritance of workspace and folder access controls means that it is very likely that most workspaces 
and folders inherit this setting. Assuming that all places inherited this setting, the most powerful role 
the remote application can assume within the installation is that of a Participant.

If you are not sure what access control settings to assign to a particular remote application, consult 
with your Vibe administrator.

If your Vibe administrator has enabled multiple applications for your site, some of these applications 
might be grouped together in an Application Group. Application Groups are similar to groups that 
contain usernames. Application groups contain the names of registered applications. After your Vibe 
administrator defines application groups, you as a workspace and folder owner can assign access-
control roles to groups of applications instead of assigning roles to one application at a time.
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13 13Managing Your Data Quota

Data quotas can be enabled by your Kablink Vibe administrator in order to limit the amount of data 
that is stored on the Vibe site. For information on how the Vibe administrator can enable data quotas, 
see “Managing Disk Space Usage with Data Quotas and File Restrictions” in the Kablink Vibe 3.3 
Administration Guide.

If data quotas have been enabled on your Vibe site, you need to understand what counts toward your 
data quotas, the different kinds of data quotas that exist, and how you can view the current data 
usage so you can know when you are approaching the allotted data quota. If you meet your allotted 
quota, Vibe enables you to purge files and attachments that you have previously deleted.

 Section 13.1, “Understanding Data Quotas,” on page 175

 Section 13.2, “Viewing Your Data Quota,” on page 176

 Section 13.3, “Setting a Data Quota for Workspaces and Folders,” on page 178

 Section 13.4, “Adding Files and Attachments to the Vibe Site When You Are Over Your Quota,” 
on page 179

 Section 13.5, “E-Mailing Files and Attachments to the Vibe Site When You Are Over Your 
Quota,” on page 179

 Section 13.6, “Adding Files Through WebDAV When You Are Restricted by a Data Quota,” on 
page 179

 Section 13.7, “Working with File Versions When You Are Restricted by a Data Quota,” on 
page 180

 Section 13.8, “Making Disk Space Available by Purging Deleted Items,” on page 180

13.1 Understanding Data Quotas
Only files and attachments count toward your data quota. Workspaces, folders, and entries that do 
not contain files and attachments do not count toward your data quota. Files and attachments must 
be deleted and purged in order to make more disk space available.

The Kablink Vibe administrator can enable two kinds of data quotas:

 User data quotas

 Workspace and folder data quotas

The administrator can enable one of these quotas, or both of them.

 Section 13.1.1, “Understanding User Data Quotas,” on page 176

 Section 13.1.2, “Understanding Workspace and Folder Data Quotas,” on page 176
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13.1.1 Understanding User Data Quotas

User data quotas limit the amount of data individual users can add to the Vibe site. Any files and 
attachments that you add to the Vibe site counts toward your data quota, regardless of the folders or 
workspaces where you add them.

13.1.2 Understanding Workspace and Folder Data Quotas

Workspace and folder quotas limit the amount of data that can be stored in individual workspaces 
and folders.

Sub-workspaces and sub-folders that have a data quota are subject to their own data quota as well as 
any data quotas that exist on parent folders and workspaces. For example, consider a workspace that 
has a data quota of 50 MB. The workspace contains two sub-workspaces: Workspace A and 
Workspace B. Users cannot upload data that is in excess of 50 MB into either of these sub-workspaces. 
Furthermore, users cannot upload data into both of these sub-workspaces that is in excess of 50 MB 
(for example, users cannot upload data that is in excess of 30 MB into both sub-workspace, because 
the amount of combined data for both sub-workspaces is greater than 50 MB).

13.2 Viewing Your Data Quota
Data quotas might or might not be in use on your Vibe site. If you are unable to view your data 
quotas as described in this section, your Vibe administrator has not yet restricted the amount of data 
that can be added to the Vibe site.

If you have exceeded your allotted data quota, you should purge items that you have previously 
deleted, as discussed in Section 13.8, “Making Disk Space Available by Purging Deleted Items,” on 
page 180.

 Section 13.2.1, “Viewing Your User Data Quota,” on page 176

 Section 13.2.2, “Viewing Your Workspace or Folder Data Quota,” on page 177

13.2.1 Viewing Your User Data Quota

If your administrator has set a user data quota and if you are an active contributor to your Kablink 
Vibe site, you might want to periodically view your current data quota to ensure that you are not 
approaching the user limit.

To view your current data quota and how much you are currently using:

1 Navigate to the home page of your personal workspace.

2 Click the Profile link, located next to your name.
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3 Your data quota is displayed in the upper right corner of the Profile page, along with the amount 
you are currently using.

13.2.2 Viewing Your Workspace or Folder Data Quota

The Vibe administrator can set a data quota on your workspaces and folders, or the administrator can 
allow you to set your own data quotas on your own workspaces and folders.

You must be an administrator for the workspace or folder in order to view data quotas.

To view your current workspace or folder quota:

1 Navigate to the workspace or folder where you want to view the quota.

2 Click Workspace > Configure Views, URLs and Controls if you want to view the quota for a 
workspace.

or

Click Folder > Configure Views, URLs and Controls if you are managing the quota for a folder.

3 Click the Quotas tab.
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The following data quota information is displayed for the workspace or folder:

 Workspace/Folder Disk Space Used: The amount of disk space the workspace or folder is 
currently using. This does not include disk space that is being used by sub-workspaces and 
sub-folders.

 Workspace and Children Disk Space Used/Folder and Sub-Folder Disk Space Used: The 
amount of disk space that is being used by the workspace or folder and all of its sub-
workspaces and sub-folders.

 Lowest Quota on Parent Workspaces or Folders: The lowest quota that exists on any 
workspace or folder that is higher in the folder hierarchy than the workspace or folder that 
you are currently viewing.

Sub-workspaces and sub-folders that have a data quota are subject to their own data quota 
as well as any data quotas that exist on parent folders and workspaces. For more 
information, see Section 13.1.2, “Understanding Workspace and Folder Data Quotas,” on 
page 176.

 Current Quota: The current data quota that exists on the workspace or folder.

 Set a Quota: Enables you to change the data quota for the workspace or folder.

13.3 Setting a Data Quota for Workspaces and Folders
The Vibe administrator can allow you to set your own data quotas for your workspaces and folders. 
If you cannot set a data quota as described in this section, your administrator has not allowed this 
capability.

If workspace and folder administrators have set data quotas at higher-level workspaces, your 
workspaces and folders are subject to any quotas that are set on the higher-level workspaces. For 
example, suppose you are the administrator of a team workspace called “Online Marketing”. This 
team workspace is a sub-workspace to a workspace called “Marketing”. If the workspace 
administrator for the Marketing workspace has set a data quota of 100 MB, users in your workspace 
and in other sub-workspaces to the Marketing workspace cannot upload more than 100 MB of 
collective data to the sub-workspaces, regardless of what is set as the data quota for the sub-
workspaces. For more information, see Section 13.1.2, “Understanding Workspace and Folder Data 
Quotas,” on page 176.
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To set a data quota for workspaces and folders:

1 Navigate to the workspace or folder where you want to view the quota.

2 Click Workspace > Configure Views, URLs and Controls if you are managing the quota for a 
workspace.

or

Click Folder > Configure Views, URLs and Controls if you are managing the quota for a folder.

3 Click the Quotas tab.

4 In the Set a Quota field, specify the new data quota for the workspace or folder, then click OK.

13.4 Adding Files and Attachments to the Vibe Site When You 
Are Over Your Quota
If you have exceeded your data quota but you still need to add files and attachments to the Kablink 
Vibe site, you need to decrease your disk usage by purging files and attachments that you have 
previously deleted.

For information on how to purge deleted items, see Section 13.8, “Making Disk Space Available by 
Purging Deleted Items,” on page 180.

13.5 E-Mailing Files and Attachments to the Vibe Site When You 
Are Over Your Quota
Kablink Vibe enables you to add files and entry attachments to the Vibe site via e-mail, as described 
in “Adding Entries to a Folder Via E-Mail” in the Kablink Vibe 3.3 User Guide. However, if you have 
met your data quota, you are unable to e-mail entries to Vibe if they include attachments.

If you have exceeded your allotted data quota, you should purge the items that you have previously 
deleted, as discussed in Section 13.8, “Making Disk Space Available by Purging Deleted Items,” on 
page 180.

13.6 Adding Files Through WebDAV When You Are Restricted by 
a Data Quota
When you add files to the Kablink Vibe site through WebDAV, the files still count against your data 
quota, just as if you had added the files through the regular Vibe interface.
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13.7 Working with File Versions When You Are Restricted by a 
Data Quota
Kablink Vibe enables you to create multiple versions of the same file, as described in “Using Version 
Control with Files” in the Kablink Vibe 3.3 User Guide.

When you edit a document in Vibe, Vibe creates a new version of the file. This new version counts 
against the data quota of the user who edited the file; it does not count against the quota of the user 
who originally posted the file. File versions also count against the data quota of individual 
workspaces and folders.

You can manage your data quota by deleting previous versions of a file that you no longer need. For 
information about how to delete previous file versions, see “Deleting Existing Versions of a File” in 
the Kablink Vibe 3.3 User Guide.

IMPORTANT: When you use OpenOffice to edit a document in Vibe, a new version of the document 
is created each time you click Save. Because each version of a document counts against your data 
quota, you should save the document only once if you are using OpenOffice as an editor.

When you use Microsoft Office, Vibe creates only one version when you save the document. Clicking 
Save multiple times does not create multiple versions, as is the case when you edit documents with 
OpenOffice.

13.8 Making Disk Space Available by Purging Deleted Items
Files and attachments that have been deleted but not yet purged still count toward your data quota. 
Workspaces, folders, and entries that do not contain files and attachments do not count toward your 
data quota. If you have reached your allotted data quota, you need to purge deleted files and 
attachments.

You can purge any item that you have rights to delete.

NOTE: Purged items cannot be recovered. When you purge items from the Vibe site, remember the 
following:

 Purging an entry also purges all attached files, comments, and replies.

 Purging a folder also purges all entries and sub-folders that are associated with that folder.

 Purging a workspace also purges all folders, sub-folders, and entries that are associated with 
that workspace.

1 Navigate to the folder or workspace where the deleted item that you now want to purge 
previously resided.

For example, if you want to purge a file entry that was in your personal Files folder, navigate to 
the Files folder in your personal workspace.

If you want to see everything that has been deleted in the Vibe site, navigate to the highest level 
workspace. (By default this is the Home Workspace directory.)

2 Click the Trash icon , located in the Navigation panel.

The Trash page displays all workspaces, folders, and entries that have been deleted in or below 
the current workspace or folder.
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3 Select the file entry or any other type of entry that contains an attachment that you want to 
purge.

4 Click Purge > OK.

The item is purged from the Vibe site.
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14 14Restoring Deleted Items

Kablink Vibe enables you to undelete a workspace, folder, or entry that you previously deleted, 
restoring it to its previous location. When you undelete an entry, all associated attachments, 
comments, and replies are also undeleted.

You cannot undelete an item that has been purged.

 Section 14.1, “Rights Associated with Undeletion,” on page 183

 Section 14.2, “Undeleting Workspaces, Folders, and Entries,” on page 183

 Section 14.3, “Undeleting Mirrored Files,” on page 184

 Section 14.4, “Undeleting Items That Contain Workflows,” on page 184

 Section 14.5, “Locating Deleted Items,” on page 184

14.1 Rights Associated with Undeletion
As a general rule, if you have rights to delete an item in Kablink Vibe, you also have rights to 
undelete that item.

Remember the following when undeleting:

 You can undelete an item that another user deleted, if you have appropriate rights.

 If you have rights to undelete an entry, but do not have rights to undelete the folder that contains 
the entry, you cannot undelete the entry.

 If you have rights to undelete a folder, but do not have rights to undelete the workspace that 
contains the folder, you cannot undelete the folder.

 When you undelete a folder, the contents of the folder are not automatically undeleted. You need 
to undelete the contents of the folder separately.

 When you undelete an entry in a deleted folder, the folder is automatically undeleted. However, 
if you do not have rights to undelete the folder, you cannot undelete the entry.

14.2 Undeleting Workspaces, Folders, and Entries
If you have the appropriate rights, you can undelete any workspace, folder, or entry and restore it to 
its previous location.

1 Navigate to the folder or workspace where the deleted workspace, folder, or entry previously 
resided.

For example, if you want to restore a Blog folder that was in your personal workspace, navigate 
to your personal workspace.
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If you want to see everything that has been deleted in the Kablink Vibe site, navigate to the 
highest level workspace. (By default this is the Home Workspace directory.)

2 Click the Trash icon , located in the Navigation panel.

The Trash page displays all workspaces, folders, and entries that have been deleted in or below 
the current workspace or folder.

3 Select the workspace, folder, or entry that you want to undelete.

4 Click Restore.

The workspace, folder, or entry is restored to its previous location.

14.3 Undeleting Mirrored Files
Undeleting files that have been deleted through a mirrored folder is not supported in Kablink Vibe. 
Files that are deleted through a mirrored folder cannot be recovered.

14.4 Undeleting Items That Contain Workflows
When you undelete a workspace or folder where a workflow has been created, the workflow is also 
restored with the workspace or folder. 

When you undelete a folder entry where a workflow has been enabled, the entry is restored with the 
workflow still enabled. The entry is in the same workflow state as it was when it was deleted.

14.5 Locating Deleted Items
If you cannot find an item in your Kablink Vibe site that you know was there previously, it has 
probably been deleted.

To locate the deleted item, you can do either of the following:

 Perform a search for the deleted item, as described in “Searching for Deleted Items” in the 
Kablink Vibe 3.3 User Guide.

 Navigate to the folder or workspace where the item previously resided, and click the Trash icon 
 located in the Navigation panel, as described in Section 14.2, “Undeleting Workspaces, 

Folders, and Entries,” on page 183.
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15 15Using Kablink Vibe on Your Mobile 
Device

Mobile access to the Kablink Vibe site can be deactivated by your Vibe administrator. If you are 
unable to access the Vibe mobile interface as described in this section, consult your Vibe 
administrator.

You can download a native application for your iPhone or Android device. These applications have a 
more polished user interface and don’t require you to sign in each time you access Vibe. However, the 
mobile app for Vibe does not store information on your device; information can be viewed only when 
you have an Internet connection. 

Other devices can access the Vibe mobile interface by using a mobile browser that meets the 
requirements listed in Section 15.2, “Browser Requirements,” on page 186.

 Section 15.1, “Supported Mobile Devices,” on page 185

 Section 15.2, “Browser Requirements,” on page 186

 Section 15.3, “Getting Started,” on page 186

 Section 15.4, “Supported Features,” on page 190

 Section 15.5, “Features that Are Not Supported in the Vibe Mobile Interface,” on page 199

 Section 15.6, “Security Considerations,” on page 199

 Section 15.7, “Troubleshooting Your Mobile Device,” on page 199

15.1 Supported Mobile Devices
The Kablink Vibe mobile interface is supported on the following mobile devices:

 iPhone (native application is available for a free download in the Apple App Store for iOS 3.2 or 
later)

 Android phones and tablets (native application is available for a free download in the Google 
Play App Store--formerly known as the Android Market--for Android 2.2 or later)

 BlackBerry

 Any other mobile device that provides an HTTP/HTML-based interface

Ensure that your device’s browser meets the requirements that are discussed in Section 15.2, 
“Browser Requirements,” on page 186.

By default, the iPad displays the full UI (the same UI that is displayed when you access Vibe from 
your workstation). All other tablets (Android, Kindle, Xoom, Playbook, etc.) display the mobile UI by 
default. The Vibe administrator can change this default behavior as described in “Changing the 
Default View for Tablets” in “Site Setup” in the Kablink Vibe 3.3 Administration Guide.
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15.2 Browser Requirements
To use Kablink Vibe from a mobile device, your device’s browser must support: 

 HTML 4

 JavaScript

15.3 Getting Started
 Section 15.3.1, “Getting Started with iPhone or Android Devices,” on page 186

 Section 15.3.2, “Getting Started with Other Devices,” on page 189

15.3.1 Getting Started with iPhone or Android Devices

 “Connecting to an Initial Vibe Site” on page 186

 “Connecting to Additional Vibe Sites” on page 187

 “Switching from One Vibe Site to Another” on page 188

 “Modifying the Configuration Settings for a Vibe Site” on page 188

 “Deleting the Configuration Settings for a Vibe Site” on page 189

Connecting to an Initial Vibe Site

When you first set up the application, you need to specify information for just one Vibe site. After 
you have performed the initial setup as described in this section, launching the Vibe application 
automatically connects you and authenticates you to your Vibe server.

1 Download the Vibe mobile application from either the Apple App Store or from the Google Play 
App Store (formerly known as the Android Market).

2 Launch the Vibe mobile application on your iPhone or Android device.

3 Accept the Vibe license agreement.

4 On the New Site page, specify the following information:

Site Name: Specify a name for your Vibe site. This is the name that appears at the top of the 
home page.

URL:  Specify the URL for the Vibe site. For example, http://vibesite.com.

Make Primary Site: Select this option if you have configured or are planning to configure 
multiple Vibe sites and you want this site to be displayed when you first launch the application. 

Login Name: Specify the login name that you use to log in to the Vibe site.

Password: Specify the password that you use to log in to the Vibe site.

Save Password: Select this option if you want your password to be securely stored on your 
device so that you can automatically be signed in to the Vibe site when you launch the Vibe 
application.

5 Click Login or Done.
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The home page is displayed. If it is not, tap the site on the site page to connect to the site.

Connecting to Additional Vibe Sites

You can configure the Vibe mobile application to connect to multiple Vibe sites. 

1 Launch the Vibe mobile application on your iPhone or Android device.

2 Tap the Menu button on your device.

3 For iPhone devices, on the Vibe Sites page, tap the Plus icon.

or

For Android devices, tap Select a Site, then on the Site List page, tap New Site.

4 Specify the following information

Site Name: Specify a name for your Vibe site. This is the name that appears at the top of the 
home page. Give the site a unique name to differentiate it from other Vibe sites that you have 
configured.

URL:  Specify the URL for the Vibe site. For example, http://vibesite.com.

Make Primary Site: Select this option if you have configured or are planning to configure 
multiple Vibe sites and you want this site to be displayed when you first launch the application. 

Login Name: Specify the login name that you use to log in to the Vibe site.

Password: Specify the password that you use to log in to the Vibe site.

Save Password: Select this option if you want your password to be securely stored on your 
device so that you can automatically be signed in to the Vibe site when you launch the Vibe 
application.

5 Click Login or Done.
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The home page is displayed. If it is not, tap the site on the site page to connect to the site.

Switching from One Vibe Site to Another

If you have configured multiple Vibe sites as described in “Connecting to Additional Vibe Sites” on 
page 187, you can easily leave one Vibe site to view information on another Vibe site.

1 Tap the Menu button on your device.

2 For iPhone devices, on the Vibe Sites page, tap the site that you want to connect to.

or

For Android devices, tap Select a Site, then on the Site List page, tap the site that you want to 
connect to.

Modifying the Configuration Settings for a Vibe Site

You can modify the configuration settings for a Vibe site after you have already configured it in the 
Vibe application. For example, you can modify your username, password, or site name.

1 Tap the Menu button on your device.

2 For iPhone devices, on the Vibe Sites page, tap the Configure icon next to the site that you want to 
modify.

or

For Android devices, tap Select a Site, then on the Site List page, tap the Configure icon next to the 
site that you want to modify.

3 Make the desired modifications, then tap Save or Done.
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Deleting the Configuration Settings for a Vibe Site

You can modify the configuration settings for a Vibe site after you have already configured it in the 
Vibe application. 

1 Tap the Menu button on your device.

2 For iPhone devices, on the Vibe Sites page, tap the Configure icon next to the site that you want to 
delete.

or

For Android devices, tap Select a Site, then on the Site List page, tap the Configure icon next to the 
site that you want to delete.

3 Scroll to the bottom of the page, then click Delete Site or Delete, then click Delete or Yes to confirm 
the deletion.

15.3.2 Getting Started with Other Devices

Use the following information to help you access Kablink Vibe from your mobile device, and learn 
basic navigation:

1 On your mobile device, launch a Web browser such as Mozilla Firefox or Internet Explorer.

2 Specify the URL of your corporation’s Vibe site.

For example, http://host:port.

Vibe automatically detects that you are using a mobile device, and directs you to the Vibe mobile 
interface.

If Vibe displays the regular Vibe interface instead of the mobile interface, add /mobile to the 
end of the Vibe URL, as discussed in “Your Browser Does Not Automatically Direct You to the 
Mobile Interface” in “Troubleshooting” in the Kablink Vibe 3.3 User Guide.

3 Specify your username and password, then tap Login.
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The home page is displayed.

15.4 Supported Features
 Section 15.4.1, “Navigating to the Home Page of the Mobile Interface,” on page 191

 Section 15.4.2, “Searching the Mobile Interface,” on page 191

 Section 15.4.3, “Viewing Your Teams,” on page 193

 Section 15.4.4, “Viewing Your Favorite Places,” on page 193

 Section 15.4.5, “Viewing Your Recent Places,” on page 193

 Section 15.4.6, “Viewing File Entries and Attachments,” on page 193

 Section 15.4.7, “Viewing YouTube Videos,” on page 193

 Section 15.4.8, “Viewing What’s New,” on page 194

 Section 15.4.9, “Viewing What’s Unread,” on page 195

 Section 15.4.10, “Viewing the Workspace Tree,” on page 195

 Section 15.4.11, “Viewing Profile Information,” on page 196

 Section 15.4.12, “Creating a Folder Entry,” on page 196

 Section 15.4.13, “Commenting on a Folder Entry,” on page 196

 Section 15.4.14, “Deleting a Folder Entry,” on page 197

 Section 15.4.15, “Calling Vibe Users with One Click (iPhone and Android Only),” on page 197

 Section 15.4.16, “Sending E-Mail,” on page 197

 Section 15.4.17, “Following People and Places of Interest,” on page 198

 Section 15.4.18, “Transitioning Entries from One Workflow State to Another,” on page 198

 Section 15.4.19, “Using Folders,” on page 198
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15.4.1 Navigating to the Home Page of the Mobile Interface

Regardless of where you are in the Vibe mobile interface, you can easily navigate to the home page.

1 Tap the Home icon  in the Navigation toolbar at the top of the mobile interface.

The home page is displayed.

15.4.2 Searching the Mobile Interface

The Kablink Vibe mobile interface enables you to search for people, places, entries, and attachments.

Advanced Search is not supported in the mobile interface. However, you can save an advanced 
search when you access Vibe from your workstation, then use it on your mobile device.

 “Performing a Basic Search” on page 191

 “Using a Saved Search” on page 192

Performing a Basic Search

To perform a basic search in the Vibe mobile interface:

1 Tap the Search icon  in the Navigation toolbar at the top of the mobile interface.

The Search drop-down menu is displayed.
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2 In the drop-down list, select the category for which you want to search.

You can search for People, Places, or All.

3 Select whether you want to search the entire Vibe site, or only the workspace that you currently 
are in.

4 Specify the words or phrases that you want to search for, then tap OK.

The Search Results page is displayed.

Using a Saved Search

Vibe enables you to perform saved searches that you have previously created and saved when you 
accessed the Vibe site from your workstation.

TIP: Even though the Vibe mobile interface does not have an Advanced search, you can create and 
save an Advanced search when you access the Vibe site from your workstation. You can then use the 
saved search on your mobile device.

For information on how to create a saved search, see “Saving and Reusing Searches” in the Kablink 
Vibe 3.3 User Guide.

For information on how to save an Advanced Search when accessing the Vibe site from your 
workstation, see “Using Advanced Search” in the Kablink Vibe 3.3 User Guide.

To access and use a saved search from the Vibe mobile interface:

1 Tap the Search icon  in the Navigation toolbar at the top of the mobile interface.

2 In the Saved Searches section, tap the saved search that you want to run.

The Search Results page displays the results for your saved search.
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15.4.3 Viewing Your Teams

You can quickly view all the teams of which you are a member.

1 On the home page, tap My Teams.

15.4.4 Viewing Your Favorite Places

You can quickly view your favorite places. 

1 On the home page, tap My Favorites.

To add or delete favorites, you must access the Vibe site from your workstation. For more 
information, see “Managing Your Favorite Places” in the Kablink Vibe 3.3 User Guide.

15.4.5 Viewing Your Recent Places

The Vibe mobile interface enables you to quickly view workspaces and folders that you have visited 
since you last logged in to the current Vibe session.

1 On the home page, tap Recent Places.

or

From any other page, tap Actions > Recent Places.

15.4.6 Viewing File Entries and Attachments

The Vibe mobile interface enables you to view file entries as well as documents that have been 
attached to entries.

1 Navigate to and open the entry that contains the document that you want to view.

2 In the Attachments section, tap the name of the document that you want to view.

TIP: If your mobile device is capable of viewing the file in its native format, you can simply tap the 
file link to view the file.

For example, when you use an iPhone, you can tap the file link to view Microsoft Word files, PDF 
files, and Microsoft Excel files.

15.4.7 Viewing YouTube Videos

The Vibe mobile interface enables you to view YouTube videos that are posted in your Vibe site. 
However, you cannot use a mobile device to view YouTube videos that are posted in the Branding 
section of workspaces or folders; the video must be posted within a folder entry or in the Description 
section of the folder or workspace.

Your BlackBerry or other mobile device might not be properly set up to view YouTube videos. If you 
are having difficulty viewing YouTube videos from your mobile device, follow the instructions in 
“You Are Unable to View YouTube Videos from Your Mobile Device” in the Kablink Vibe 3.3 User 
Guide.
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To view a YouTube video from the Vibe mobile interface:

1 Navigate to and open the entry that contains the YouTube video that you want to view.

2 Tap the YouTube icon .

You are directed to the mobile YouTube site to view the video.

To post YouTube videos, you must access the Vibe site from your workstation. For more information, 
see “Displaying YouTube Videos in a Folder Entry” in the Kablink Vibe 3.3 User Guide.

15.4.8 Viewing What’s New

The Vibe mobile interface enables you to see new entries that have been added to the Vibe site.

 “Viewing What’s New in Your Teams” on page 194

 “Viewing What’s New in Your Followed Places” on page 194

 “Viewing What’s New in Your Favorite Places” on page 194

 “Viewing What’s New Across the Entire Site” on page 194

 “Viewing the Newest Micro-Blog Entries of People You’re Following” on page 194

 “Viewing What’s New in a Folder” on page 195

 “Viewing What’s New in a Workspace” on page 195

Viewing What’s New in Your Teams

1 On the home page, tap What’s New.

2 From the What’s New drop-down list on the home page, tap My Teams.

Viewing What’s New in Your Followed Places

1 On the home page, tap What’s New.

2 From the What’s New drop-down list on the home page, tap All Followed.

Viewing What’s New in Your Favorite Places

1 On the home page, tap What’s New.

2 From the What’s New drop-down list on the home page, tap Favorites.

Viewing What’s New Across the Entire Site

1 On the home page, tap What’s New.

2 From the What’s New drop-down list on the home page, tap Site Wide.

Viewing the Newest Micro-Blog Entries of People You’re Following

1 On the home page, tap What’s New.

2 From the What’s New drop-down list on the home page, tap Micro-Blogs.
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Viewing What’s New in a Folder

1 Navigate to the folder where you want to see new items.

2 Tap Actions > New in This Folder.

Viewing What’s New in a Workspace

1 Navigate to the workspace where you want to see new items.

2 Tap Actions > New in This Workspace.

15.4.9 Viewing What’s Unread

The Vibe mobile interface enables you to see which entries have not yet been read.

 “Viewing What’s Unread in a Folder” on page 195

 “Viewing What’s Unread in a Workspace” on page 195

 “Viewing What’s Unread across the Entire Site” on page 195

Viewing What’s Unread in a Folder

1 Navigate to the folder where you want to see new items.

2 Tap Actions > Unread in This Folder.

Viewing What’s Unread in a Workspace

1 Navigate to the workspace where you want to see new items.

2 Tap Actions > Unread in This Workspace.

Viewing What’s Unread across the Entire Site

1 On the home page, tap Actions > Unread Site Wide.

15.4.10 Viewing the Workspace Tree

The Vibe mobile interface enables you to view the Workspace tree, so you can see the hierarchy of 
where you currently are and quickly navigate to a different workspace or folder.

1 Tap the Tree icon .
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The Workspace tree is displayed.

15.4.11 Viewing Profile Information

You can view the complete user profile information for yourself or for other users. 

 “Viewing Your Own User Profile Information” on page 196

 “Viewing Another User’s Profile Information” on page 196

Viewing Your Own User Profile Information

1 From the home page, tap My Profile.

All your profile information is displayed.

To edit your profile information, access Vibe from your workstation, then follow the steps in 
“Modifying Your Profile” in the Kablink Vibe 3.3 User Guide.

Viewing Another User’s Profile Information

1 Search for the person whose profile you want to view, as described in “Performing a Basic 
Search” on page 191.

2 Tap the name of the user whose profile information you want to view.

The user’s profile is displayed.

15.4.12 Creating a Folder Entry

1 Navigate to the folder where you want to create the entry.

2 Tap New.

If you do not have rights to create an entry in this folder, this option is not displayed

3 Specify the appropriate information for the entry, such as a title and description, then tap OK.

15.4.13 Commenting on a Folder Entry

1 Navigate to and open the entry that you want to comment on.

2 Tap Comment.

3 Specify your comment, then tap OK.
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15.4.14 Deleting a Folder Entry

1 Navigate to and open the entry that you want to delete.

2 Tap Delete.

If you do not have rights to delete the entry, this option is not displayed.

3 Tap OK when asked if you really want to delete the entry.

15.4.15 Calling Vibe Users with One Click (iPhone and Android Only)

When you use Vibe from your iPhone or Android device, you can call other Vibe users with just one 
click.

1 Navigate to the personal workspace of the user whom you want to call.

You can navigate to a user’s personal workspace by tapping the user’s linked name that appears 
next to any entry that user has posted. Or, you can search for the user as described in 
Section 15.4.2, “Searching the Mobile Interface,” on page 191.

2 Tap the user’s linked phone number.

A call is made to the user.

15.4.16 Sending E-Mail

The Vibe mobile interface enables you to quickly send e-mail to other Vibe users.

1 Navigate to the personal profile of the user to whom you want to send an e-mail.

You can navigate to a user’s personal profile by tapping the user’s linked name that appears next 
to any entry that user has posted. Or, you can search for the user as described in Section 15.4.2, 
“Searching the Mobile Interface,” on page 191.

2 Tap the user’s linked e-mail address.
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15.4.17 Following People and Places of Interest

The Vibe mobile interface enables you to follow places or people. You can easily see activity 
generated in the specific place that you are following, or by the specific person that you are following.

 “Configuring Vibe to Follow Workspaces, Folders, and People” on page 198

 “Viewing Your Followed Workspaces, Folders, and People of Interest” on page 198

 “Unfollowing Workspaces, Folders, or People” on page 198

Configuring Vibe to Follow Workspaces, Folders, and People

1 Navigate to the workspace or folder that you want to follow. If you want to follow a person, 
navigate to the user’s personal workspace.

2 Tap Actions > Follow this Folder, Follow this Workspace, or Follow this Person, depending on what 
you want to follow.

Viewing Your Followed Workspaces, Folders, and People of Interest

If you are currently following a workspace, folder, or person, Vibe enables you to easily see activity 
generated in the specific place that you are following, or by the specific person that you are following.

For more information, see “Viewing What’s New in Your Followed Places” on page 194.

Unfollowing Workspaces, Folders, or People

If you are currently following someone or some place in Vibe, you can unfollow that person or place 
in the Vibe mobile interface.

1 Navigate to the workspace or folder that you want to stop following. If you want to stop 
following a Vibe user, navigate to that user’s personal workspace.

2 Tap Actions > Stop Following this Workspace, Stop Following this Folder, or Stop Following this Person, 
depending on what you want to stop following.

15.4.18 Transitioning Entries from One Workflow State to Another

The Vibe mobile interface enables you to transition entries from one workflow state to another.

For information on how to create a workflow, see Chapter 11, “Creating and Managing Workflows,” 
on page 127.

To transition entries to another workflow state in the Vibe mobile interface:

1 Navigate to and open the entry that you want to transition to a new workflow state.

2 In the Workflow section, tap the new workflow state in the drop-down list, then tap OK.

15.4.19 Using Folders

The Vibe mobile interface enables you to use most types of Vibe folders. However, not all folder types 
support the full functionality that is available when accessing the Vibe site from your workstation. 
For more information, see Section 15.5, “Features that Are Not Supported in the Vibe Mobile 
Interface,” on page 199.
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15.5 Features that Are Not Supported in the Vibe Mobile 
Interface
The following Kablink Vibe features are not supported when you access Vibe from the mobile 
interface. If you want to use any of these features, you must access Vibe from your workstation:

 “Using Advanced Search” in the Kablink Vibe 3.3 User Guide

You cannot create an advanced search in the mobile interface, but you can access a saved search, 
as described in “Using a Saved Search” on page 192.

 “Viewing and Revisiting Recent Entries” in the Kablink Vibe 3.3 User Guide

 “Adding a Favorite Place” and “Editing Your Favorite Places” in the Kablink Vibe 3.3 User Guide

 “Creating a New Folder” in the Kablink Vibe 3.3 User Guide

  “Working with Surveys Folders” in the Kablink Vibe 3.3 User Guide

You can use the Vibe mobile interface to view Surveys folders and see the titles of the individual 
surveys that the folders contain, but you cannot view the survey itself or participate in it.

 “Viewing Your Tasks in a Full Interactive View” in the Kablink Vibe 3.3 User Guide

 Chapter 5, “Branding a Folder or Workspace,” on page 53

You cannot use the Vibe mobile interface to brand a workspace or folder, or view branding that 
has already been created on a workspace or folder.

 “Editing Files” in the Kablink Vibe 3.3 User Guide

 “Attaching Files to a Folder Entry” in the Kablink Vibe 3.3 User Guide

 “Allowing Guest Access to Your Vibe Site” in the Kablink Vibe 3.3 Administration Guide

15.6 Security Considerations
When you access Kablink Vibe from your mobile device, you enjoy the same security as when you 
access Vibe from your workstation. Security features include:

 Secure access via SSL.

 All previously established access control settings are preserved in the mobile interface.

However, you cannot set new access control settings in the mobile interface. For information on 
how to set new access control settings when you access the Vibe site from your workstation, see 
Chapter 4, “Controlling Access,” on page 41.

15.7 Troubleshooting Your Mobile Device
If you encounter difficulties when accessing Kablink Vibe from your mobile device, see 
“Troubleshooting Your Mobile Device” in the Kablink Vibe 3.3 User Guide.
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A AWhat’s New in Vibe 3.x

In Kablink Vibe 3x you’ll find new features, a fresh user interface, and significant updates. 

The following list is an overview of the new features for advanced users.

 Section A.1, “Landing Page Enhancements (v3.3, v3.2, v3.1),” on page 201

 Section A.2, “Workflow Enhancements (v3.3, v3.2, v3.1),” on page 203

 Section A.3, “Versioning Enhancements (v3.2),” on page 204

 Section A.4, “Limiting the File Upload Size (v3.2),” on page 205

 Section A.5, “Entry Type Modifications (v3.2),” on page 205

 Section A.6, “Mobile Applications (v3.2),” on page 205

 Section A.7, “HTML Markup Language (v3.1),” on page 205

 Section A.8, “Workspace and Folder Data Quotas (v3.1),” on page 205

 Section A.9, “Custom Digest Notifications (v3.1),” on page 205

 Section A.10, “Capture E-Mail You Send from the Vibe Site in One Location (v3.1),” on page 206

 Section A.11, “Mobile Enhancements (v3.1),” on page 206

 Section A.12, “Improved Folder and Workspace Branding (v3),” on page 206

 Section A.13, “Entry-Level Access Controls (v3),” on page 206

A.1 Landing Page Enhancements (v3.3, v3.2, v3.1)
 Section A.1.1, “Landing Page Enhancements in Vibe 3.3,” on page 201

 Section A.1.2, “Landing Page Enhancements in Vibe 3.2,” on page 202

 Section A.1.3, “Landing Page Enhancements in Vibe 3.1,” on page 203

A.1.1 Landing Page Enhancements in Vibe 3.3

 “Configuring a Landing Page to Display All Calendar Events Assigned to the User Who Views 
the Page” on page 202

 “Configuring a Landing Page to Display All Tasks Assigned to the User Who Views the Page” 
on page 202

 “Configuring the Width and Height of Landing Page Elements” on page 202

 “Adding Rows to Tables” on page 202
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Configuring a Landing Page to Display All Calendar Events Assigned to the User 
Who Views the Page

Kablink Vibe 3.3 enables you to configure a landing page to display all the calendar events and tasks 
that are assigned to the user who views the landing page. Calendar events and tasks are displayed in 
a calendar view. Tasks are displayed on the calendar according to the task duration; tasks that do not 
have either a start and end date or a duration specified are not displayed. You do this by adding an 
Enhanced View element to the landing page. For more information, see Section 6.3.3, “Adding 
Content to Your Landing Page,” on page 61.

Configuring a Landing Page to Display All Tasks Assigned to the User Who 
Views the Page

Kablink Vibe 3.3 enables you to configure a landing page to display all the tasks that are assigned to 
the user who views the landing page. You do this by adding an Enhanced View element to the 
landing page. For more information, see Section 6.3.3, “Adding Content to Your Landing Page,” on 
page 61.

Configuring the Width and Height of Landing Page Elements

Kablink Vibe 3.3 enables you to specify the width and height of most landing page elements. For 
more information, see Section 6.3.3, “Adding Content to Your Landing Page,” on page 61.

Adding Rows to Tables

Kablink Vibe 3.3 enables you to add rows to tables on a landing page. For more information, see 
“Adding a Table” on page 64.

A.1.2 Landing Page Enhancements in Vibe 3.2

 “Adding a Background Image or Color to a Landing Page” on page 202

 “Hiding the Action Toolbar on a Landing Page” on page 202

 “Configuring Column Widths by Pixel in a Table” on page 203

Adding a Background Image or Color to a Landing Page

Novell Vibe 3.2 enables you to add a background image or background color to your landing page. 
For more information, see Section 6.3.2, “Adding a Background Image or Color to Your Landing 
Page,” on page 59.

Hiding the Action Toolbar on a Landing Page

Novell Vibe 3.2 enables you to hide the Action toolbar on the landing page. For more information, see 
Section 6.3.1, “Choosing Layout Options for Your Landing Page,” on page 58.
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Configuring Column Widths by Pixel in a Table

Novell Vibe 3.2 enables you to configure column widths by pixels as well as by percent for tables on 
your landing page. For more information, see Section 6.3.3, “Adding Content to Your Landing Page,” 
on page 61.

A.1.3 Landing Page Enhancements in Vibe 3.1

 “Changing the Order of Content on a Landing Page” on page 203

 “Adding HTML Content to a Landing Page” on page 203

 “Adding Extensions to a Landing Page” on page 203

Changing the Order of Content on a Landing Page

Novell Vibe 3.1 enables you to reorder content on your landing page. For more information, see 
Section 6.6, “Changing the Order of Landing Page Elements,” on page 77.

Adding HTML Content to a Landing Page

Novell Vibe 3.1 enables you to add an HTML editor to your landing page. For more information, see 
Section 6.3.3, “Adding Content to Your Landing Page,” on page 61.

Adding Extensions to a Landing Page

Novell Vibe 3.1 enables you to add extensions to your landing page. For more information, see 
Section 6.3.3, “Adding Content to Your Landing Page,” on page 61.

A.2 Workflow Enhancements (v3.3, v3.2, v3.1)
 Section A.2.1, “Workflow Enhancements in Vibe 3.3,” on page 203

 Section A.2.2, “Workflow Enhancements in Vibe 3.2,” on page 204

 Section A.2.3, “Workflow Enhancements in Vibe 3.1,” on page 204

A.2.1 Workflow Enhancements in Vibe 3.3

Kablink Vibe enables you to transition entries through a workflow after a specified number of 
business days (excluding weekends and holidays). For more information, see “Transition After Time 
Elapsed” on page 141.

The Vibe administrator determines which days are considered to be business days, as described in 
“Configuring Weekends and Holidays” in “Site Setup” in the Kablink Vibe 3.3 Administration Guide.
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A.2.2 Workflow Enhancements in Vibe 3.2

Novell Vibe 3.2 provides new workflow capabilities. These capabilities include: 

 Automatically modifying an element within an entry when the entry enters or exits a workflow 
state, as described in Section 11.2.6, “Adding On-Entry or On-Exit Events,” on page 144 and 
Section 11.2.7, “Setting Up On-Entry and On-Exit Events,” on page 145.

 Restricting users from commenting or replying to entries in a workflow when the Read Access 
access control setting is enabled on the workflow, as described in Section 11.4, “Adding Access 
Controls to a Workflow,” on page 154.

 Showing a link to the entry within a workflow notification, as described in Section 11.1.5, 
“Sending E-Mail Notifications,” on page 133.

A.2.3 Workflow Enhancements in Vibe 3.1

Novell Vibe 3.1 provides new workflow capabilities. These capabilities include:

 Controlling which users can manually transition workflows

For more information, see Section 11.4.3, “Setting Access Controls on a Manual Transition,” on 
page 159.

 Transitioning the workflow after users have responded

For more information, see “Designating Specific Users to Respond to a Workflow Question” on 
page 151.

 Specifying e-mail addresses for workflow notifications

For more information, see Section 11.1.5, “Sending E-Mail Notifications,” on page 133.

A.3 Versioning Enhancements (v3.2)
 Section A.3.1, “Configuring a Folder to Delete Excess Versions,” on page 204

 Section A.3.2, “Configuring a Folder to Delete Versions after a Specified Number of Days,” on 
page 204

A.3.1 Configuring a Folder to Delete Excess Versions

Novell Vibe 3.2 enables workspace and folder owners to set a limit on the number of versions of a 
single file that are allowed to exist. For more information, see Section 3.4.1, “Automatically Deleting 
Minor File Versions That Exceed the Allowed Maximum,” on page 31.

A.3.2 Configuring a Folder to Delete Versions after a Specified Number of 
Days

You can configure all but the top version of each file to be automatically deleted after a specified 
number of days. For more information, see Section 3.4.2, “Automatically Deleting Minor File Versions 
After a Specified Number of Days,” on page 32.
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A.4 Limiting the File Upload Size (v3.2)
Workspace and folder owners can set a limit on the size of files that can be uploaded to the folder or 
workspace. For more information, see Section 3.5, “Limiting the File Upload Size for Folders and 
Workspaces,” on page 33.

A.5 Entry Type Modifications (v3.2)
Novell Vibe 3.2 enables you to change the entry type for a single entry or for ever entry of a certain 
type in a folder. For more information, see Section 3.2.2, “Changing the Entry Type for Entries in a 
Folder,” on page 27.

A.6 Mobile Applications (v3.2)
Novell Vibe 3.2 provides native applications for iPhone and Android devices. These applications 
have a more polished user interface and don’t require you to sign in each time you access Vibe.

iPhone and Android native applications are not compatible with Kablink Vibe.

For more information, see Section 15.3.1, “Getting Started with iPhone or Android Devices,” on 
page 186.

A.7 HTML Markup Language (v3.1)
Novell Vibe 3.1 enables you to add HTML markup into any HTML editor, such as in the Description 
section of entries, folders, and workspaces. For more information, see Appendix B, “Using HTML 
Markup in Vibe,” on page 207.

A.8 Workspace and Folder Data Quotas (v3.1)
If your Vibe administrator has enabled this functionality, you can set data quotas on workspaces and 
folders that you are manage. For more information, see Section 13.3, “Setting a Data Quota for 
Workspaces and Folders,” on page 178.

A.9 Custom Digest Notifications (v3.1)
Novell Vibe 3.1 enables you to set custom digest notifications on your folders, rather than accepting 
the default digest notification that is set up by your Vibe administrator.

For more information, see Section 3.7, “Configuring Folders to Send E-Mail Notifications to Other 
Users,” on page 34.
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A.10 Capture E-Mail You Send from the Vibe Site in One Location 
(v3.1)
Like a personal e-mail Outbox for the Vibe site, you can configure a folder or any e-mail address to 
receive all e-mail messages that you personally send from the Vibe site. 

For more information, see Section 3.6, “Setting Up a Folder or External E-Mail Address to Receive All 
Sent E-Mail Messages,” on page 33.

A.11 Mobile Enhancements (v3.1)
Novell Vibe 3.1 enables you to delete folder entries from the mobile interface. For more information, 
see Section 15.4.14, “Deleting a Folder Entry,” on page 197.

You can also add users, groups, and teams to calendar and task entries that you create from the 
mobile interface.

A.12 Improved Folder and Workspace Branding (v3)
Adding a personal brand to your workspace or folder is easier than ever before with Kablink Vibe 3. 
For information about how you can quickly create a personal brand, see Chapter 5, “Branding a 
Folder or Workspace,” on page 53.

A.13 Entry-Level Access Controls (v3)
You can now set access controls on individual entries that differ from those set on the parent folder. 
For more information, see Section 4.2.2, “Controlling Access to Entries,” on page 49.
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B BUsing HTML Markup in Vibe

Vibe enables you to add HTML markup into the following locations of the Vibe interface:

 Any HTML editor, such as in the Description section of entries, folders, and workspaces.

For more information, see “Modifying the Description Section of an Entry”, “Modifying a 
Folder”, and “Modifying a Workspace” in the Kablink Vibe 3.3 User Guide.

 The Subject Line and Notification Body of workflow notification messages.

For more information, see Step 7 in Section 11.1.5, “Sending E-Mail Notifications,” on page 133.

You can add the following HTML markup items:

Markup Text Function

{{vibe:title}} Displays the title of the entry, folder, or workspace.

{{vibe:user}} Displays the name of the user who is viewing the entry, folder, or workspace.

{{vibe:user|name}} Displays the user ID of the user who is currently viewing the entry, folder, or 
workspace.

{{vibe:createdBy}} Displays the name of the user who created the entry, folder, or workspace.

{{vibe:createdBy|name}} Displays the user ID of the user who created the entry, folder, or workspace.

{{vibe:createdOn}} Displays the date the entry, folder, or workspace was created.

{{vibe:modifiedBy}} Displays the name of the user who last modified the entry, folder, or 
workspace.

{{vibe:modifiedBy|name}} Displays the user ID of the user who last modified the entry, folder, or 
workspace.

{{vibe:modifiedOn}} Displays the date the entry, folder, or workspace was last modified.

{{vibe:data|dataName}} Displays the value of the specified data item. Data items are elements that 
have been added to the form or view definition by using the Form and View 
Designer. Replace dataName with the data name of the element that you want 
to show.

For a list of elements, see Section 9.5, “Understanding Elements,” on 
page 118.

For more information about how to use the Form and View Designer to create 
custom forms and views, see Chapter 7, “Creating Custom Workspace Views,” 
on page 87, Chapter 8, “Creating Custom Folder Views,” on page 97, and 
Chapter 9, “Designing Custom Folder Entry Forms,” on page 109.
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{{vibe:permalink | link}} Displays a permalink to the current entry, folder, or workspace. Replace link 
with the permalink of the entry, folder, or workspace.

This markup option is most useful when it is used in the Subject line of a 
workflow notification e-mail. For example, the Subject line might read, A 
workflow changed occurred in entry. The user can then click entry in 
the Subject line of the notification to be taken directly to the entry.

To get the permalink URL of a Vibe page, simply navigate to the page that you 
want to link to, click Permalink in the footer toolbar, then copy the permalink 
URL from the Permalink field.

{{vibe:image | imageName | 
alt=... | height=... | width=... | 
border=0 or 1}}

Displays the image that you specify. Replace imageName with the filename of 
the image that you want to display. Images must be attached to the entry, 
folder, or workspace.

For information on how to attach entries, see “Attaching Files to a Folder 
Entry”, “Modifying a Folder”, and “Modifying a Workspace” in the Kablink Vibe 
3.3 User Guide.

If you want to specify a custom size, you can add the alt, height, and width 
arguments. These arguments are not required.

{{vibe:file | filename | title}} Displays a link to a file. File must be attached to the entry, folder, or workspace.

For information on how to attach entries, see “Attaching Files to a Folder 
Entry”, “Modifying a Folder”, and “Modifying a Workspace” in the Kablink Vibe 
3.3 User Guide.

For example, {{vibe:file | tree.jpg | tree}} outputs the word tree as a link to the 
tree.jpg file.

[[entry title]] Creates a link to the entry that you specify. You must specify the exact name of 
the entry.

For more information about creating links in Vibe, see “Linking to a Folder or 
Folder Entry” in the Kablink Vibe 3.3 User Guide.

Markup Text Function
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