
Novell

Manual December 9, 200289
w w w . n o v e l l . c o m

NsureTM Resources
1 . 0
1 0 3 - 0 0 0 2 7 9 - 0 0 1

D
 E P LO Y ME N T  G U I D E
Deployment Guide
103-000279-001
February 4, 2003

Novell Confidential



Manual December 9, 200289
Legal Notices
Novell, Inc. makes no representations or warranties with respect to the contents or use of this documentation, and specifically 
disclaims any express or implied warranties of merchantability or fitness for any particular purpose. Further, Novell, Inc. 
reserves the right to revise this publication and to make changes to its content, at any time, without obligation to notify any 
person or entity of such revisions or changes.

Further, Novell, Inc. makes no representations or warranties with respect to any software, and specifically disclaims any 
express or implied warranties of merchantability or fitness for any particular purpose. Further, Novell, Inc. reserves the right 
to make changes to any and all parts of Novell software, at any time, without any obligation to notify any person or entity of 
such changes.

You may not export or re-export this product in violation of any applicable laws or regulations including, without limitation, 
U.S. export regulations or the laws of the country in which you reside.

Copyright © 2002 Novell, Inc. All rights reserved. No part of this publication may be reproduced, photocopied, stored on a 
retrieval system, or transmitted without the express written consent of the publisher.
Novell, Inc.
1800 South Novell Place
Provo, UT 84606
U.S.A.

www.novell.com
Deployment Guide
December 13, 2002
Online Documentation: To access the online documentation for this and other Novell products, and to get 
updates, see www.novell.com/documentation.
Deployment Guide
103-000279-001
February 4, 2003

Novell Confidential



Manual December 9, 200289
Novell Trademarks
Novell is a registered trademark of Novell, Inc. in the United States and other countries.
ConsoleOne is a registered trademark of Novell, Inc. in the United States and other countries.
DirXML is a registered trademark of Novell, Inc. in the United States and other countries.
GroupWise is a registered trademark of Novell, Inc. in the United States and other countries.
eDirectory is a trademark of Novell, Inc. 
Novell Certificate Server is a trademark of Novell, Inc.
Novell Client is a trademark of Novell, Inc. 
Novell eGuide is a trademark of Novell, Inc. 
Nsure is a trademark of Novell, Inc.

Third-Party Trademarks
All third-party trademarks are the property of their respective owners.
Deployment Guide
103-000279-001
February 4, 2003

Novell Confidential



Manual December 9, 200289
Deployment Guide
103-000279-001
February 4, 2003

Novell Confidential



Manual May 15, 200259
Contents

About This Guide  9

1 Introducing Novell Nsure Resources  11
The Novell Nsure Resources Model .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  12
Automated Business Policies and Processes .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  14

Sample Scenario .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  15
A Close-Up of Each System  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  18

SAP.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  19
PeopleSoft  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  20
Active Directory .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  21
NT Domain  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  22
eDirectory.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  23
Active Directory with Exchange 2000.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  24
Exchange 5.5 .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  25
Notes .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  26
GroupWise  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  27

Nsure Resources Tools   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  28
Making Novell Nsure Resources Work for You   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  28

2 Setting Up the Workforce Tree  31
Setting Up eDirectory on a Windows NT/2000 Server .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  31

System Requirements  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  31
Prerequisites  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  32
Installing eDirectory on Windows NT/2000 .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  32

Setting up DirXML on a Windows NT/2000 Server   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  36

3 Setting Up Novell iManager and eGuide  37
Installing iManager and eGuide Program Files   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  37

System Requirements  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  37
Installation   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  38

Installing Configuration Files for DirXML Drivers.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  40
Configuring iManager and eGuide .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  41

Running the iManager Configuration Wizard .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  41
Creating Novell Nsure Resources Objects .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  42
Running the eGuide Quick Setup Wizard   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  42
Setting up eGuide Roles in iManager   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  44

4 Preparing the Lab for Novell Nsure Resources  47
Setting Up a PeopleSoft Client for PeopleSoft 8.1 .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  49

Prerequisites  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  49
Collecting Configuration Information  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  50
Contents 5

Deployment Guide
103-000205-001
February 4, 2003

Novell Confidential



Manual May 15, 200259
Installing Configuration Files .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   51
Installing the PeopleSoft External API .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   51
Installing a Sample Project   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   52
Configuring the Remote Loader for the Driver .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   57

Setting Up a PeopleSoft Client for PeopleSoft 7.5   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   58
Prerequisites .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   58
Collecting Configuration Information.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   59
Installing Configuration Files .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   60
Installing the PeopleSoft Service Agent  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   61
Running the Message Agent Test Program .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   66
Installing the Event Server .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   71
Configuring the Remote Loader for the Driver .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   74

Setting Up SAP  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   76
Prerequisites .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   76
Collecting Configuration Information.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   77
Configuring the SAP System   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   78
Installing and Configuring the Remote Loader and Driver .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   85

Setting Up Lotus Notes  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   87
Prerequisites .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   87
Collecting Configuration Information.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   88
Creating Lotus Notes Accounts  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   89
Configuring Database Replication Using NDSRep   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   91

Setting Up GroupWise.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   97
Prerequisites .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   97
Collecting Configuration Information   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   98
Configuring Driver Authentication  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   99
Installing and Configuring the Remote Loader and Driver .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  103

Setting Up Exchange 5.5  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  105
Prerequisites .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  105
Collecting Configuration Information.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  106
Creating an Authoritative User.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  107
Creating Distribution Lists  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  107
Installing and Configuring the Remote Loader and Driver .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  107

Setting Up NT Domain   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  110
Prerequisites .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  110
Collecting Configuration Information.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  111
Creating an Authoritative User.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  112
Granting Rights to the Driver   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  112
Installing and Configuring the Remote Loader and Driver .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  112

Setting Up Active Directory  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  115
Prerequisites .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  115
Collecting Configuration Information   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  116
Creating an Admin User .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  117
Installing and Configuring the Remote Loader and Driver .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  118

Setting Up Active Directory and Exchange 2000  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  120
6   Deployment Guide

Deployment Guide
103-000205-001
February 4, 2003

Novell Confidential



Manual May 15, 200259
Prerequisites  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   120
Collecting Configuration Information  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   121
Creating an Admin User  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   122
Collecting Default Exchange Information .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   124
Installing and Configuring the Remote Loader and Driver  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   125

Setting Up eDirectory   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   127
Prerequisites  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   127
Collecting Configuration Information  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   127
Installing DirXML and the DirXML eDirectory Driver  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   128
Configuring the Driver   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   128

5 Configuring DirXML Drivers  131
Importing the Preconfigured Drivers .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   131
Configuring Secure Data Transfers for the DirXML Driver for eDirectory  .  .  .  .  .  .  .  .  .  .  .  .   133
Testing the Novell Nsure Resources Process  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   135

Start Each Driver .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   135
Hire a New Employee   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   136
Modify Employee Information.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   136
Promote an Employee to Management.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   136
Remove an Employee  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   136

A Moving Novell Nsure Resources from the Lab to Production  139
Novell Nsure Resources Deployment  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   139

Discovery .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   140
Requirements and Design Analysis   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   141
Proof of Concept  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   145
Data Validation and Preparation  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   145
Production Pilot .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   146
Production Rollout Planning  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   146
Production Deployment.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   147

B Activating Novell Nsure Resources  149
Purchasing DirXML Licenses   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   150
Generating a Product Activation Request  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   150
Submitting an Activation Request  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   151
Installing a Product Activation Credential  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   152
Viewing Product Activations for DirXML and DirXML Drivers  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   153

C Documentation Updates  155
December 5, 2002  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   155

Introducing Novell Nsure Resources .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   156
Preparing the Lab for Novell Nsure Resources.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   156
Contents 7

Deployment Guide
103-000205-001
February 4, 2003

Novell Confidential



Manual May 15, 200259
8   Deployment Guide

Deployment Guide
103-000205-001
February 4, 2003

Novell Confidential



Manual (99a) December 9, 200289
About This Guide

This guide describes the Novell® NsureTM Resources data model and explains 
how to set up and test this product in a lab environment. 

The guide contains the following sections:

Chapter 1, “Introducing Novell Nsure Resources,” on page 11

Understanding the design and purpose of Novell Nsure Resources is key 
to a successful deployment. This section explains the Novell Nsure 
architecture, default dataflow, and policy.

Chapter 2, “Setting Up the Workforce Tree,” on page 31

The Workforce Tree is a flat Novell eDirectoryTM tree hosting DirXML® 
and the Novell Nsure Resources data store. This section explains how to 
install and configure the Workforce Tree.

Chapter 3, “Setting Up Novell iManager and eGuide,” on page 37

Novell iManager and Novell eGuideTM are browser-based tools that will 
help you set up Novell Nsure solutions. This section explains how to 
install and use these tools. 

Chapter 4, “Preparing the Lab for Novell Nsure Resources,” on page 47

Each system that will share data must be prepared to communicate with 
DirXML and the Workforce Tree. This section explains how to prepare 
HR, messaging, and account systems. 

Chapter 5, “Configuring DirXML Drivers,” on page 131
About This Guide 9
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After you have prepared each system for provisioning, you must provide 
the DirXML drivers with system-specific information. This section walks 
you through driver configuration and validation.

Appendix A, “Moving Novell Nsure Resources from the Lab to 
Production,” on page 139

This appendix covers fundamental steps that contribute to a successful 
roll-out of Novell Nsure Resources to a production environment.

Appendix B, “Activating Novell Nsure Resources,” on page 149

Nsure Resources must be activated within 90 days of installation, 
otherwise it will shut down. This section explains how to request and 
install an activation credential.

Additional Documentation

For documentation on using DirXML and the DirXML drivers, see the  
DirXML Documentation Web site (http://www.novell.com/documentation/lg/
dirxml11a).

Documentation Updates

For the most recent version of the Novell Nsure Resources Deployment 
Guide, see the  Novell Nsure Resources Documentation Web site (http://
www.novell.com/documentation/lg/eprov10).

Documentation Conventions

In this documentation, a greater-than symbol (>) is used to separate actions 
within a step and items within a cross-reference path.

A trademark symbol (®, TM, etc.) denotes a Novell trademark. An asterisk (*) 
denotes a third-party trademark.

User Comments

We want to hear your comments and suggestions about this manual and the 
other documentation included with Novell Nsure Resources. To contact us, 
send e-mail to proddoc@novell.com.
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1 Introducing Novell Nsure Resources

Today’s businesses often manage several separate systems that hold 
information about their employees. E-mail, directory, and ERP accounts are 
needed to provide employees access to company resources. The costs 
associated with managing employee data in separate systems is substantial 
and grows as the number of systems increase.

DirXML® alleviates the problems associated with synchronizing data across 
heterogeneous systems. This technology provides for highly customized data 
exchange between key corporate systems without requiring changes to the 
systems themselves.

Novell® NsureTM Resources tailors the DirXML technology to support a set of 
business policies and processes to efficiently manage employee identities 
across the following systems:

The Novell Nsure Resources Model
With this solution, events in the Human Resources system drive most data 
exchanges. Data modification in the HR system sets provisioning processes in 
motion to

Human Resource Systems Messaging Systems Account Systems

PeopleSoft*
SAP*

Exchange 5.5
Exchange 2000

GroupWise®

Lotus Notes*

Novell eDirectoryTM

Active Directory*
NT Domain
Introducing Novell Nsure Resources 11

Deployment Guide
103-000279-001
February 4, 2003

Novell Confidential



Manual December 9, 200289
Trigger the automatic creation or modification of a User object for an 
individual 

Grant employees access to both messaging and account systems

Provide access to information that the individual needs in order to 
complete their assigned role

Although data exchanges are generally initiated by events in the HR system, 
the core of this solution is built on the concept of an eDirectory Workforce 
Tree that can be used by all participating systems.    

Figure 1 Provisioning Repository

In simplest terms, eDirectory is a list of objects that represent network 
resources, such as network users or servers. An eDirectory tree is a virtual 
representation of how network resources are organized. For more information 

eDirectory
Driver

Workforce
Tree

GroupWise
Driver

NT4
Driver

Exchange
 Driver

Active Directory
Driver

SAP
Driver

Lotus Notes
 Driver

PeopleSoft
HR Driver

Nsure Resources
Repository
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about eDirectory and tree design, see Understanding Novell eDirectory (http:/
/www.novell.com/documentation/lg/edir87/edir87/data/fbadjaeh.html).

The Workforce Tree is a flat eDirectory tree that includes containers for users 
and provisioning services. The default Workforce Tree structure is as shown 
below. 

Figure 2 Workforce Tree Structure

This tree structure and Novell Nsure Resources objects are created 
automatically during setup.

Automated Business Policies and Processes 
DirXML brokers the exchange of information held in the Workforce Tree 
through rules and style sheets that support business policy and processes.

The policies provided by the default installation of Novell Nsure Resources 
are as follows: 

User Object Names: The User object name is generated by prepending the 
first letter of the person’s first name to the person’s last name. 
Introducing Novell Nsure Resources 13
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For example, John Brown’s User object name would be JBROWN. If 
another JBROWN user object already exists, John’s User object would 
instead be named JBROWN1. This policy is defined in the HR driver’s 
Create style sheet.

Passwords: Each user object is assigned an initial password with the value 
of their last name.

John Brown’s initial password would be BROWN. The HR driver’s 
Create style sheet uses the value of the Surname attribute to create this 
password.

Group Membership: Active users are added to either the Employee Group 
or the Manager Group.

The HR driver determines where to assign the user to based on the value 
of the user’s Position or isManager attribute. If this value is changed, the 
user’s Group Membership will be changed accordingly. 

If John Brown enters the system as an employee with no direct reports, he 
is included in the Employee Group. When John is assigned a management 
position, the driver will change John’s group membership so that he is no 
longer part of the Employee Group but is part of the Manager Group. This 
process is handled by the HR driver’s CommandTransform style sheet.

When an employee is no longer active, the employee is removed from 
both groups.

Placement: Users will be placed in either the Active or Inactive container 
inside YourOrganization/Users. 

Using logic defined in its Placement rule, the HR driver checks the status 
of the employee in the HR system to determine which container the User 
object is placed in. If the user’s status changes, the driver will move the 
user to the appropriate container. 

Account Name: The account name for objects in the messaging systems 
and in the account systems is generated using the same logic used to 
generate the User object in the Workforce Tree: first letter of the first 
name plus last name. This logic is defined in the Create style sheet for the 
account driver.

E-Mail Addresses: An e-mail address is generated by the messaging 
system. This address is published back to the Workforce Tree for access 
by other DirXML drivers.
14   Deployment Guide
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E-Mail Distribution Lists: Users are added to either a Managers or an 
Employees e-mail distribution list.

When the isManager attribute for a user object changes, the messaging 
driver revises the distribution lists as appropriate. 

Sample Scenario
The sections that follow explain how the DirXML drivers work to process 
common business events. These examples are based on a hypothetical setup 
that includes PeopleSoft, NT, and Exchange 5.5 and a hypothetical user, John 
Brown, a new engineering manager.

Employee is Hired 

When John is hired, an HR Consultant enters John’s data in PeopleSoft. The 
DirXML drivers respond as follows: 

The PeopleSoft driver ensures that sufficient data has been provided to 
allow John’s User object to be created; the minimum data required is a 
first name and a last name. 

The driver verifies that John doesn’t already exist in the Workforce Tree 
and then generates additional data including organizational hierarchy 
information. Organizational hierarchy is defined by the values of two 
User object attributes: manager and directReports. The driver populates 
these two attributes as well as John’s Group Membership attribute, 
indicating that he is part of the Managers group. The driver then publishes 
the new data to the Workforce Tree.

The NT Domain driver is notified of the Add and creates an NT Domain 
account for John. When the NT account is created, the Preferred Name 
attribute is generated and published back to the Workforce Tree. 

The Preferred Name attribute triggers the creation of an e-mail account 
and e-mail ID for John in Exchange. The Exchange driver publishes the 
e-mail ID back to the Workforce Tree and also adds John to the Managers 
e-mail group. 

The PeopleSoft driver subscribes to Workforce Tree attribute for e-mail 
address and will update this field in its data tables.
Introducing Novell Nsure Resources 15
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Employee Takes a Temporary Leave of Absence

An HR Consultant changes John’s status in PeopleSoft to Inactive at the 
beginning of the leave period. The DirXML drivers respond as follows: 

The PeopleSoft driver moves John’s User object to the Inactive container 
in the Workforce Tree. The driver also removes John from the Managers 
group and clears organizational relationships. The Login Disabled 
attribute is set to True. This updated data is published to the Workforce 
Tree.
NOTE: Whenever a user’s data is updated, attributes that reflect organizational 
hierarchy are verified and updated if necessary. This check happens for the 
employee, his manager, and his direct reports. So, when John’s manager attribute 
is cleared, the driver also removes John from his manager’s directReports 
attribute. The manager attribute for any employees that were reporting to John will 
be cleared because John is no longer managing that group.

The NT Domain driver is notified of the event and disables John’s NT 
account.

The Exchange driver disables John’s mailbox and removes him from the 
Managers e-mail list.

Upon return from leave, John’s PeopleSoft status is changed to Active. 
The Login Disabled attribute is set to False. The PeopleSoft driver returns 
him to the Managers Group and re-establishes organizational 
relationships. This updated data is published to the Workforce Tree.

John’s User object is moved to the Active container in the Workforce 
Tree.

The NT Domain driver receives the event and enables John’s NT account.

The Exchange driver enables John’s mailbox and adds him to the 
Managers e-mail list.

Employee Updates Personal Information

Using Novell eGuideTM, John changes his cell phone number. This data change 
is recorded in the Workforce Tree. The DirXML drivers respond as follows: 

The PeopleSoft driver subscribes to the eDirectory Mobile attribute and 
updates its data stores to reflect the changed number. 
16   Deployment Guide
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Introducing Novell Nsure Resources 17

The NT driver does not track cell phone numbers and is unaffected by 
John’s data change.

The Exchange driver subscribes to the eDirectory Mobile attribute and 
updates its data stores to reflect the changed number. 

Employee is Reassigned

John accepts a new position in the company and in doing so relocates to a new 
city and reports to a different manager. An HR Consultant updates the 
PeopleSoft records to reflect the changes. The DirXML drivers respond as 
follows:

The PeopleSoft driver changes the value of John’s manager attribute, 
removes John from his previous manager’s directReports attribute, and 
adds John to his new manager’s directReports attribute. User objects for 
people who reported to John are updated; John is removed from their 
manager attribute. 

The PeopleSoft driver publishes John’s updated user information, 
including his new office location, to the Workforce Tree. 

The NT driver does not subscribe to the affected attributes of the User 
object and is not affected by these changes.

The Exchange driver subscribes to several attributes that have changed, 
such as John’s fax number, office phone number, office location, etc., and 
updates its data store.

Employee Leaves the Company 

John accepts a position with a partner and leaves the company. The HR 
Consultant updates the PeopleSoft records. The DirXML drivers respond as 
follows:

The PeopleSoft driver removes John from the Managers group and clears 
organizational relationships. (The User objects for both John’s manager 
and his direct reports are also updated.) The driver moves John’s User 
object to the Inactive container and sets his Login Disabled attribute to 
True. This updated data is published to the Workforce Tree.

The NT Domain driver is notified of the event and disables John’s NT 
account.

The Exchange driver disables John’s mailbox and removes him from the 
Managers e-mail list.
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A Close-Up of Each System
When you set up Novell Nsure Resources, you will select drivers for one HR 
system, one messaging system, and one or more account systems. A 
fundamental characteristic of this solution is that the HR system is the primary 
originator of employee data, so most of the information starts there and moves 
to the Workforce Tree where the data can be accessed by other systems. Of 
course, there are some cases where data does not originate in the HR system; 
an obvious example is an e-mail address. As you would expect, this attribute 
is generated and owned by the messaging system.

Following are detailed diagrams that show the data flow for shared attributes 
in each system. 
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SAP

Figure 3 Dataflow for the SAP Driver
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PeopleSoft

Figure 4 Dataflow for the PeopleSoft Driver
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Active Directory

Figure 5 Dataflow for the Active Directory Driver
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NT Domain

Figure 6 Dataflow for the NT Domain Driver
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eDirectory

Figure 7 Dataflow for the eDirectory Driver
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Active Directory with Exchange 2000

Figure 8 Dataflow for the Active Directory with Exchange 2000 Driver
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Exchange 5.5

Figure 9 Dataflow for the Exchange 5.5 Driver
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Notes

Figure 10 Dataflow for the Lotus Notes Driver
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GroupWise

Figure 11 Dataflow for the GroupWise Driver
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including installing and configuring DirXML drivers, customizing data 
exchange, and setting up reporting schemes to track DirXML 
transactions.

Making Novell Nsure Resources Work for You
Using real-world configurations from a sampling of customers who have 
implemented provisioning solutions, we assembled a representative 
configuration, designed to give you a head start on implementation. However, 
it’s impossible to get an out of-the-box configuration that works for every 
business environment.   

The default configuration will help you get Novell Nsure Resources up and 
running very quickly in your lab. To implement a complete Nsure Resources 
solution you must complete the following processes: 

Install and test the default configuration in the lab.

The following sections will help you complete this requirement:

Chapter 2, “Setting Up the Workforce Tree,” on page 31
Chapter 3, “Setting Up Novell iManager and eGuide,” on page 37
Chapter 4, “Preparing the Lab for Novell Nsure Resources,” on page 47
Chapter 5, “Configuring DirXML Drivers,” on page 131

Analyze your business practices, modify the lab configuration to 
address your business requirements, and move the customized 
systems to production.

The work of customizing Nsure Resources requires careful analysis, clear and 
timely communication, and expert knowledge of XML and XSLT. Working 
with an Nsure Resources expert can make a successful transition to production 
much more efficient. 

Appendix A, “Moving Novell Nsure Resources from the Lab to Production,” 
on page 139 will help you understand the complexity of deploying DirXML 
in production and what to expect if you choose to work with an Nsure 
Resource expert. 
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Activate Novell Nsure Resources.

Nsure Resources is based on Novell DirXML technology. DirXML and 
DirXML drivers must be activated within 90 days of installation, otherwise 
they will shut down. Appendix B, “Activating Novell Nsure Resources,” on 
page 149 explains how to request and install the necessary activation 
credential.
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2 Setting Up the Workforce Tree

The Workforce Tree is the heart of the Novell® NsureTM Resources solution. It 
requires both Novell eDirectoryTM and DirXML®. Additionally, it is the 
reference point for Novell iManager and Novell eGuideTM.

To set up the Workforce Tree for the lab, complete the instructions in the 
following sections:

“Setting Up eDirectory on a Windows NT/2000 Server” on page 31

“Setting up DirXML on a Windows NT/2000 Server” on page 36

Setting Up eDirectory on a Windows NT/2000 Server
Nsure Resources requires eDirectory 8.6.2 or later. It can be installed on 
several platforms. For this implementation, we’re documenting an eDirectory 
installation on Windows*. You can use other eDirectory supported platforms 
for the Workforce Tree. Instructions for installing eDirectory on platforms 
other than Windows are available at the eDirectory Documentation Web site 
(http://www.novell.com/documentation/lg/edir87). 
IMPORTANT: Regardless of platform, there are some settings specific to Nsure 
Resources that you must use. These settings are documented in this section and 
include the following items: an OU named Services and allowance for clear text 
communications.

System Requirements
Novell Nsure Resources is not an upgrade to a previously released product. 
The server that will host eDirectory and DirXML should not have previously 
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released versions of these products installed. This server must meet the 
following prerequisites:

Windows NT* server 4.0 with Service Pack 4 or later, or Windows 2000 
Server with Service Pack 2 or later

An assigned IP address

A Pentium* III 450-700 MHz (single) 384 MB RAM and a monitor color 
palette set to a number higher than 16

An account with Administrative rights to the Windows NT/2000 server.

Prerequisites
Because NTFS provides a safer transaction process than a FAT file system 
provides, you can only install eDirectory on an NTFS partition. 
Therefore, if you only have FAT file systems, do one of the following: 

Create a new partition and format it as NTFS.

Use Disk Administrator. Refer to the Windows NT Server User Guide 
for more information.

Convert an existing FAT file system to NTFS, using the CONVERT 
command.

If your server has only a FAT file system and you forget or overlook this 
process, the installation program prompts you to provide an NTFS 
partition.

Make sure you have the latest Windows NT/2000 Service Packs installed. 
The latest updated Windows Service Pack needs to be installed after the 
installation of the Windows SNMP service.

Installing eDirectory on Windows NT/2000
IMPORTANT: Structure your Workforce Tree exactly as explained in this section. The 
DirXML drivers and logic are dependent on this structure.

1 At the NT/2000 server, log in as Administrator or as a user with 
administrative privileges.

2 Insert the eDirectory CD. If you have Autorun turned off, run 
SETUP.EXE from the NT directory.
32   Deployment Guide

Deployment Guide
103-000279-001
February 4, 2003

Novell Confidential



Manual December 9, 200289
Setting Up the Workforce Tree 33

3 Select Install Novell Directory Services.

Installing the other listed components is not necessary unless you are also 
provisioning GroupWise® as the messaging system. If you are using 
GroupWise, then you must install ConsoleOne®.

4 Click Install.

The installation program checks for the following components before it 
installs eDirectory. If a component is missing or is an incorrect version, 
the installation program automatically launches an installation for the 
component.

The installation of these components might take several minutes.

Novell ClientTM for Windows NT/2000/XP. 

For more information on the Novell Client for Windows NT/2000/
XP, see the Novell Client for Windows (http://www.novell.com/
documentation/lg/noclienu/index.html) online documentation.
NOTE: If the Novell Client must be installed or updated, the computer will be 
restarted after this installation. When prompted to log in, log in to the 
Workstation Only.

Novell licensing

You can obtain an evaluation license file from the Novell eDirectory 
Eval License Download (http://www.novell.com/products/
edirectory/licenses/eval_87.html) Web site.

To purchase eDirectory licenses, see the Novell eDirectory How To 
Buy (http://www.novell.com/products/edirectory/howtobuy.html) 
Web site.

NICI 2.4.0

For more information on the Novell International Cryptographic 
Infrastructure, see the NICI Administration Guide (http://
www.novell.com/documentation/lg/nici/pdfdoc/
nici_admin_guide.pdf).

5 At the Welcome screen, click Next.

6 Follow the online instructions in the Novell eDirectory Product 
Installation Wizard to view and accept the license agreement, then click 
Next.

7 Select a language for the installation, then click Next.

8 Specify an installation path, then click Next.

9 Select Create a New eDirectory Tree, then click Next.
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10 Enter information in the eDirectory Installation dialog box. 
IMPORTANT: Use only characters that are valid in LDAP. LDAP supports 
alphanumeric characters, does not support spaces in a name, requires an alpha 
character to begin a name, and supports only one non-alphanumeric character, the 
dash (-). 

Figure 12 eDirectory Installation Information

Tree Name: You are setting up the Workforce Tree that will be used 
by all Novell Nsure Resources components. Choose a tree name that 
will indicate that this is the Workforce Tree. 

New Server: For New Server object context, enter the server name 
inside the Services container inside the organization name you 
choose.

You must use Services as the container. This container is referenced 
by all of this solution’s rules and style sheets.
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Admin Name: The Admin name can be simply Admin. The context 
for this object should be inside Services.

Admin Context: Use Services as the container for the admin user. 

Password/Retype Password: Set the password for the admin user.

11 Click Next, then in the HTTP Server Port Configuration dialog box, 
specify which ports to use for the eDirectory administrative HTTP server, 
then click Next.
IMPORTANT: Make sure that the HTTP stack ports you set during the eDirectory 
install are different than the HTTP stack ports you have used or will be using for 
Novell iManager. If you’re installing eDirectory and iManager on the same 
computer, you’ll need to change the port. For more information, click Help.

12 In the Certificate Server dialog box, select Create an Organizational 
Certificate Authority, then click Next. 

With the exception of an eDirectory account system, lab systems will not 
use secure connections. If you are provisioning an eDirectory account 
tree as part of the lab configuration, you’ll use the Certificate Authority 
at a later time.

13 In the LDAP Configuration dialog box, specify which LDAP ports to use.
IMPORTANT: The default settings should work for the lab implementation. 
However, if you’ll be running other LDAP applications, like the Exchange driver or 
Active Directory driver on this same computer, you should change the Clear Text 
Port number to a different number now to prevent conflicts later. 

14 Deselect the Require TLS for Simple Bind option so that clear text 
passwords will be allowed in the lab implementation, then click Next.

15 Accept the defaults on the NMAS Login Methods dialog box, then click 
Next. 

16 At the Summary page, click Finish.

For more detailed information about eDirectory, refer to the eDirectory 
Documentation Web site (http://www.novell.com/documentation/lg/
edir87).

17 Continue with the next section, “Setting up DirXML on a Windows NT/
2000 Server” on page 36.
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Setting up DirXML on a Windows NT/2000 Server
You need to install DirXML on the eDirectory server you just set up. For this 
implementation, we’re documenting a DirXML installation on Windows. 
Instructions for installing DirXML on platforms other than Windows are 
available in the DirXML 1.1a Administration Guide (http://www.novell.com/
documentation/lg/dirxml11a/dirxml/data/a7c9ie0.html).

1 Insert the Novell Nsure Resources CD. If you have Autorun turned off, 
run INSTALL.EXE from the NT directory. 

2 At the Welcome page, click Next.

3 Read the License Agreement, then click I Accept.

4 Select DirXML Engine and Drivers and click Next.

5 Select the DirXML Engine.

6 If you will be provisioning an eDirectory Account Tree as one of your 
account systems, select DirXML Driver for eDirectory.
NOTE: Only the eDirectory Driver requires that it be installed on the Workforce 
Tree as well as on the Account Tree. 

Other drivers do not need to be installed at this time because they will use the 
Remote Loader service, which will be installed and configured later when you set 
up each system.

7 Click Next.

8 In the Schema Extension dialog box, enter the following information: 

Tree Name: This field is already populated with the tree name you 
specified during the eDirectory installation. 

Fully Distinguished User Name: Browse to and select the admin 
user you created during eDirectory installation, for example, 
Admin.Services.YourOrganization 

User Password: Enter the Admin password you defined during 
eDirectory installation.

9 Click Next.

The schema is extended to include DirXML objects such as Driver and 
Driver Set and DirXML attributes such as DirXML associations.

10 At the Summary page, click Finish, then at the Installation Complete 
page, click Close.

You have completed setup of the Workforce Tree.

11 Continue with the next section, Chapter 3, “Setting Up Novell iManager 
and eGuide,” on page 37.
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3 Setting Up Novell iManager and 
eGuide

Novell® iManager and Novell eGuideTM are installed on your Web server. 
Procedures in this section explain how to install and configure these tools. You 
must complete each of the following sections: 

“Installing iManager and eGuide Program Files” on page 37

“Installing Configuration Files for DirXML Drivers” on page 40

“Configuring iManager and eGuide” on page 41

Installing iManager and eGuide Program Files
iManager and eGuide program files will be installed on your Web server. If 
you don’t have a Web server set up already, the installation program will 
install Apache and Tomcat as well as iManager and eGuide. Use the Web 
Applications CD to install iManager and eGuide program files.

System Requirements
For the lab implementation, we document iManager and eGuide installations 
on Windows. Both of these provisioning tools can be installed on other 
platforms as well. Installation instructions for platforms other than Windows 
are available at the iManager Documentation Web site (http://
www.novell.com/documentation/lg/imanage15) and the eGuide 
Documentation Web site (http://www.novell.com/documentation/lg/
eguide21).
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The following are the minimum system requirements for running eGuide and 
iManager:

Installation
The Web Applications installation is an umbrella installation; it chains 
together the installation programs for each of the Web components you need 
in order to manage Novell Nsure Resources. 

If you don’t have a Web server installed, you’ll see three installation 
programs: the Web server installation, iManager installation, and eGuide 
installation. If you already have a Web server installed, you’ll see two 
installation programs: iManager installation and eGuide installation.

To install Web applications: 

System Component Requirement

Operating System Windows NT/2000/XP

Web Server Apache 1.3 (tested and recommended on all platforms)

An existing IIS installation will prevent the Web Apps 
install from installing Apache and Tomcat. You’ll need 
to uninstall IIS if you want to install Apache and Tomcat.

Web Application Server Tomcat 3.2 (tested and recommended) or any Web 
application server that supports the 2.2 Java* Servlet 
Specification

Java Virtual Machine (JVM*) Version 1.3 or later (1.3.1 recommended)

LDAP Directory Supports LDAP v3

Uses clear text passwords for clear text connections

Browser for eGuide Administration Utility 
and for iManager 

Netscape* 6.2 or later

Internet Explorer 5.5 or later

Browser for eGuide Client Netscape 4.78 or later (6.2 recommended)

Internet Explorer 5.0 or later (5.5 recommended)
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1 If you already have a Web server running, stop it before starting the 
installation.

2 At your Web server, insert the Web Applications CD.

3 At the eDirectory Web Applications Welcome page, select a language for 
the Web Applications installation, then click OK.

4 Read the Introduction, then click Next.

5 Read the License Agreement, mark I Accept, then click Next.

6 At the Select Web Applications dialog box, select both iManager and 
eGuide, then click Next.

7 Review the information on the Selected Applications page, then click 
Install.

8 At the iManager Welcome page, select a language for the iManager 
installation, then click OK.

9 Read the introduction, then click Next.

10 At the Detection Summary page, click Next.

You might need to resolve port conflicts. Be aware of port usage by other 
services, such as iMonitor.

11 Select an install location, then click Next.

12 At the Pre-Installation Summary, click Install to install iManager files. 

This installation may take a few minutes.

13 To complete iManager installation and launch the eGuide installation, 
review the summary, then click Done.    

14 Select a language for the eGuide installation, then click OK.

15 Read the Important Information page, then click Next.

16 Select an install location and click Next.

17 Review the Pre-Installation Summary and click Install. 

eGuide files are installed.

18 At the Install Complete page, click Done, and then click Done again to 
complete the installation of both eGuide and iManager. 
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19 Close the Help page and continue with the next section, “Installing 
Configuration Files for DirXML Drivers” on page 40.

If prompted for a system reboot, click No to decline.

Installing Configuration Files for DirXML Drivers
The DirXML drivers for Novell Nsure Resources come with configuration 
files that specify common provisioning policies and processes. 

1 At your Web server, insert the Novell Nsure Resources CD. If you have 
Autorun turned off, run INSTALL.EXE from the NT directory. 

2 At the Welcome page, click Next.

3 Read the License Agreement, then click I Accept.

4 Select DirXML Management Utilities, then click Next.

5 Select the Novell iManager Plug-ins for DirXML and DirXML 
Preconfigured Drivers, then click Next.

Plug-ins and preconfigured drivers are copied to the Tomcat directory for 
use during iManager and driver configuration.

6 Select all the preconfigured driver files, then click Next.

7 Review the Summary page, then click Finish.

If a message pops up indicating you have an LDAP driver, click OK.

An installation screen appears and files are copied.

8 When the Restart Web Services message appears, click OK.

9 At the Installation Complete page, click Close.

10 Restart your Web services.    

10a Choose Start > Settings > Control Panel, and open Administrative 
Tools.

10b Open Services. 

10c Select your Web services and click Restart. By default, iManager 
installs the Apache and Jakarta Web services.
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11 Continue with the next section, “Configuring iManager and eGuide” on 
page 41.

Configuring iManager and eGuide 
Before you configure management tools, be sure your browser meets 
minimum version requirements. To configure management tools, complete 
the steps in the following sections:

“Running the iManager Configuration Wizard” on page 41

“Creating Novell Nsure Resources Objects” on page 42

“Running the eGuide Quick Setup Wizard” on page 42

“Setting up eGuide Roles in iManager” on page 44

Running the iManager Configuration Wizard
The iManager Wizard extends the schema for Role-Based Services (RBS) and 
creates RBS objects. To run the wizard:

1 Open a browser at the Web server, and launch iManager. Enter

http://localhost/eMFrame/

2 Authenticate to the Workforce Tree.

3 At the Collection Information page, select the Organization object you 
created during eDirectory installation, such as YourOrganization 
container, then click Next.

4 Select all modules in the Modules to Be Installed list.

5 Specify the Workforce Tree as the Scope.

6 Ensure that the Inheritable option is checked.

7 Click Start to update the schema for Role-Based Services (RBS) and 
create RBS objects.

This update may take a few minutes.

8 When the update is finished and the Completed status shows on the page, 
click Close.
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9 Continue with the next section, “Creating Novell Nsure Resources 
Objects” on page 42.

Creating Novell Nsure Resources Objects
Default objects used by Nsure Resources are created by the Load Sample 
Objects Wizard. These objects must be created before you configure eGuide.

1 If you are already authenticated to the Workforce Tree in iManager, skip 
to Step 3, otherwise, launch iManager from your Web browser. Enter,

http://localhost/eMFrame/

2 Authenticate to the Workforce Tree.

3 Select DirXML Management > Load Sample Objects.

This task creates the objects necessary to manage data exchange with 
Novell NsureTM Resources. These objects include

An Organizational Unit named Services under your top-level 
Organization object.

A DirXML driver set named Nsure Resources inside the Services 
Organizational Unit.

4 At the Welcome page, select Load Sample Objects for Nsure Resources, 
then click Next.

5 At the Container Name prompt, enter your top-level organization name, 
such as YourOrganization, then click Next.

When you click Next, the Nsure Resources driver set is created, as well 
as container objects for users and group objects for employees and 
managers.

6 Click Finish, then click the Exit button at the top of the page, and continue 
with the next section, “Running the eGuide Quick Setup Wizard” on page 
42.

Running the eGuide Quick Setup Wizard
Before you can use eGuide, you must run the Quick Setup Wizard. 

This wizard specifies the following defaults:
42   Deployment Guide

Deployment Guide
103-000279-001
February 4, 2003

Novell Confidential



Manual December 9, 200289
Search root

Authentication proxy user

LDAP directory

1 At the Web server, enter the following URL in your browser:

http://localhost/eGuide/admin/ 
(case-sensitive)
NOTE: If the Quick Setup Wizard fails to start, you might need to modify the 
configuration of your Web server and/or servlet engine in order to make the eGuide 
application accessible. The configuration requirements vary depending on the 
specific Web server. Consult your Web server documentation for details. Be aware 
that you may need to restart your Web server and servlet engine after 
reconfiguring them.

2 Click Quick Setup.

3 At the Welcome page, click Next.

4 Provide the following information for your LDAP Data Source, the 
Workforce Tree. 

Display Name: You choose the display name for your data source. 
Use the Workforce Tree name. 
NOTE: Only ASCII characters, numbers, or underscore characters can be 
used in this field; spaces are not allowed. Because this name is for display 
only, it doesn’t need to exactly match your tree name.

Host Name: The IP address of the server hosting the Workforce 
Tree.

Port: Leave the default setting unless you changed the LDAP port 
during eDirectory installation. If you need to check the port number 
for your eDirectory installation, find the LDAP Server object in 
eDirectory (in iManager, click LDAP Management).

Enable SSL: Leave this option unchecked.

Secure Port: This option is necessary only when you use SSL. Leave 
the default.

5 Click Next.

6 Provide the following Authentication Proxy Credentials using LDAP 
syntax, then click Next:
Setting Up Novell iManager and eGuide 43

Deployment Guide
103-000279-001
February 4, 2003

Novell Confidential



Manual December 9, 200289
44   Deployment Guide

Authentication search root: This setting determines where the 
search begins for a user who logs in without specifying a context.
o=YourOrganization

Authentication user name: This setting specifies which object’s 
rights should be used to browse the search scope for the user who 
logs in without specifying a context.
To use the Admin object, select Authentication user name and enter 
cn=Admin,ou=Services,o=YourOrganization

Authentication password: Enter the password for the 
Authentication user specified above.

7 Enter Admin in the Search for Username field, then click Search to 
assign an eGuide administrator.

8 Move the Admin object from the Available list to the Selected list, click 
Next, then click Finished.

The eGuide Administration utility is displayed.

9 Under the Security heading, click Administration Roles.

10 Click Edit for the Role Based Services (RBS) entry.

11 Mark Enable RBS, then click Save.

12 When the Modification Successful message is displayed, click LDAP 
Data Sources under the Configuration heading.

13 For the Workforce Tree data source, click Edit.

14 In the Search root field, enter 
ou=Active,ou=Users,o=YourOrganization

This limits eGuide searches initiated by users in the Active container to 
objects in the Active container.

15 Click Save at the bottom of the page, then continue with the next section, 
“Setting up eGuide Roles in iManager” on page 44.

Now Roles and Tasks can be used with eDirectory. 

Setting up eGuide Roles in iManager
Novell eGuide allows users to locate information about other users as well as 
to update their own information. To make eGuide information available to 
users in the Active container, set up eGuide Roles in iManager as follows.

1 Launch iManager. Enter

http://localhost/eMFrame/
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2 Authenticate to the Workforce Tree.

3 Click the Configure icon at the top of the page.

4 Click Role Configuration > Modify eGuide Roles.

5 Configure the Attributes Edit role.

5a Click Modify members.

5b In the Name field, enter Active.Users.YourOrganization.

This role setting allows users in the Active container to modify all 
attributes associated with this role, including phone numbers for their 
mobile phone, home phone, and pager. 

5c Click Add > Ok > Ok.

6 Configure the Attributes View role.

6a Click Modify members.

6b In the Name field, enter Active.Users.YourOrganization.

6c In the Scope field, enter Active.Users.YourOrganization.

This role setting allows users in the Active container to view all 
attributes associated with this role for themselves and others in this 
container.

6d Click Add > Ok > Ok.

eGuide is ready for use by users whose object data is generated by Nsure 
Resources. 

7 Exit eGuide and continue with the next section, Chapter 4, “Preparing the 
Lab for Novell Nsure Resources,” on page 47.
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4 Preparing the Lab for Novell Nsure 
Resources

After the Workforce Tree is set up and Novell® iManager and Novell eGuideTM 
have been installed, you install remote drivers and configure participating 
systems. Use to the following sections to help you with system setup and 
configuration. These systems can be set up in any order.
IMPORTANT: Have the system administrator for each participating system work with 
you to make the setup process quick and accurate.

HR Systems

“Setting Up a PeopleSoft Client for PeopleSoft 8.1” on page 50
“Setting Up a PeopleSoft Client for PeopleSoft 7.5” on page 59
“Setting Up SAP” on page 78

Messaging Systems

“Setting Up Lotus Notes” on page 89
“Setting Up GroupWise” on page 98
“Setting Up Exchange 5.5” on page 106

Account Systems

“Setting Up NT Domain” on page 110
“Setting Up Active Directory” on page 114
“Setting Up Active Directory and Exchange 2000” on page 119
“Setting Up eDirectory” on page 126
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After setting up participating systems, you need to configure DirXML® 
drivers and tools as explained in Chapter 5, “Configuring DirXML Drivers,” 
on page 131.

When Novell NsureTM Resources is set up completely, your lab configuration 
will look something like the following illustration. 
48   Deployment Guide

Deployment Guide
103-000279-001
February 4, 2003

Novell Confidential



Manual December 9, 200289
Figure 13 Lab Configuration
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Setting Up a PeopleSoft Client for PeopleSoft 8.1
While you set up PeopleSoft, have your PeopleSoft Administrator work with 
you.

The instructions in this section are for the PeopleSoft 4.0 driver, which 
supports PeopleTools 8.17 or higher. For the lab implementation, you will set 
up a PeopleSoft client that can communicate with your PeopleSoft database 
and with the DirXML engine. You will install the PeopleSoft Service Agent 
(PSA) and the DirXML Remote Loader on the PeopleSoft client.
NOTE: Details about driver architecture and driver/application relationships are 
discussed in the driver implementation guides. You can reference driver implementation 
guides on the DirXML Driver Documentation Web Site (http://www.novell.com/
documentation/lg/dirxmldrivers/index.html).

To prepare a lab workstation to provision resources to PeopleSoft users, 
complete the following sections:

“Prerequisites” on page 50

“Collecting Configuration Information” on page 51

“Installing Configuration Files” on page 52

“Installing the PeopleSoft External API” on page 52

“Installing a Sample Project” on page 53

“Configuring the Remote Loader for the Driver” on page 58

Prerequisites
The computer where you will install the Remote Loader and the driver must 
be running the following software:

Windows NT 4.0 with Service Pack 5 or higher, or Windows 2000 
Service Pack 2 or higher

The appropriate version of the PeopleTools client and Application Server

PeopleSoft Platform PeopleTools Client Version PeopleSoft Application Server

PeopleSoft 8.1 PeopleTools 8.17 or higher PeopleTools 8.17 or higher
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The PeopleSoft External API (PSEXTAPI) software

Collecting Configuration Information
You’ll need to provide a number of system-specific details when you install 
and configure Novell Nsure Resources for PeopleSoft. Some of these details 
can be collected before you complete the following procedures, and others 
will be defined during the process. 

Print and complete the Import Driver Form for PeopleSoft 3.6a (http://
www.novell.com/documentation/lg/eprov10/configs/ps36.html), which 
mirrors the actual form you will fill out in iManager, or print the following 
table and record information there.

System Value

IP Address and Port for PeopleSoft 
Application Server

(Ask the PeopleSoft Administrator.)

PeopleSoft User ID and Password

(Ask the PeopleSoft Administrator.)

IP Address and Port Number for the 
Remote Loader

(See “Configuring the Remote 
Loader for the Driver” on page 58.)

Driver Object Password

(See “Configuring the Remote 
Loader for the Driver” on page 58.)

Remote Loader Password

(See “Configuring the Remote 
Loader for the Driver” on page 58.)
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Installing Configuration Files
The files necessary for installing a sample project and for installing the 
Remote Loader are available on the Novell Nsure Resources CD. 

1 At your PeopleSoft client computer, insert the Novell Nsure Resources 
CD. 

2 At the Welcome page, click Next. 

3 Read the License Agreement, then click I Accept. 

4 Select the following items, then click Next.

DirXML Remote Loader Service

DirXML Management Utilities

5 Accept the default installation path for the Remote Loader, then click 
Next.

6 Mark the following items, then click Next.

DirXML Remote Loader Service

DirXML Driver for PeopleSoft

7 Select Application Components, then click Next.

8 Select Install Components for PeopleSoft, then click Next.

9 Accept the default directory location for the PeopleSoft components, then 
click Next.

10 Review the Product Summary, then click Finish.

The files you need to complete the next sections are now available.

11 When prompted, click Yes to create a desktop shortcut for the Remote 
Loader.

12 Continue with “Installing a Sample Project” on page 53.

Installing the PeopleSoft External API
Before installing a sample project, you should install the PeopleSoft External 
Application Interface software (PSEXTAPI). The PSEXTAPI requires a Java 
Virtual Machine because the calls to the application server are done through 
Jolt. The JVM should be installed on the Operating System where the driver 
shim (NPS8Shim.dll) runs. 
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If you don’t have the JVM, you can download it from the Microsoft* 
Download Center (http://www.microsoft.com/downloads) (msjavx86.exe); or 
you can use the JVM supplied with Sun’s JDK* 1.2.2. For additional 
information, please refer to your PeopleSoft documentation.

To install the PSEXTAPI:

1 Run SETUP.EXE from {PSHOME}\BIN\CLIENT\WINX86_API\

2 Change the environment path to include the directory: 
{PSHOME}\BIN\CLIENT\WINX86_API\ 

3 Reboot your workstation.

Verifying PeopleSoft’s Connection to the JVM: You should verify that 
PeopleSoft can connect successfully to the JVM. Run jnitest.exe from the 
PeopleSoft External API directory: 
{PSHOME}\BIN\CLIENT\WINX86_API\

Installing a Sample Project
Complete the following tasks to install the sample project for testing and 
configuration purposes:

1. “Extracting the PSA Files” on page 53

2. “Importing the PSA Project into the PeopleSoft Database” on page 54

3. “Building Project Record Definitions” on page 54

4. “Applying Security to the PSA” on page 55

5. “Testing Sample PeopleSoft Applications” on page 55
NOTE: Any references to specific paths in these sections represent the defaults 
indicated during the installation procedures. Apply the necessary changes if applicable.

Extracting the PSA Files

The PSA project comes as a self-extracting project. To extract the project:

1 From the location you specified when you installed the components for 
PeopleSoft, run DIRXML DRIVER 4_0 PSA.EXE. The default location 
is Novell\NDS\PS. 
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2 Click Next, select the destination directory, then click Next to begin 
extracting the PSA files.

3 Click Finish to close the extraction process.

The PSA is now ready to be installed into your PeopleSoft environment.

Importing the PSA Project into the PeopleSoft Database

With PeopleSoft 8, projects are now delivered in a cache directory structure, 
which is similar to the cache structure found within PeopleSoft. With previous 
versions of PeopleSoft you needed to use the Data Mover script and compare, 
but this process is no longer necessary. 

To import the PSA into the PeopleSoft database:

1 Connect to the PeopleSoft database as administrator in two tier mode. 

2 From the Application Designer, select File > Copy Project From File.

3 Click Browse and select the PSA project directory: C:\PSA\PSA-PSA8\.

4 Click Copy.

5 With all object types selected, click Copy to copy all project components 
into the PeopleSoft database.

Building Project Record Definitions

After you have imported the project into the PeopleSoft database, you should 
build project record definitions and then build project views.

1 Log into PeopleSoft using an administrator username that has 
administrative and development rights.

2 From the Application Designer, select Build > Project.

3 From Build Options, click Create Tables and Execute SQL Now. 

4 Click Build to create sample project tables. After project tables are 
created, click Close to close the Build Progress window.
NOTE: You must create project tables before creating the views. Views are 
created using information from table fields.

5 From the Application Designer, select Build > Project.

6 From Build Options, click Create Views and Execute SQL Now. 
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7 Click Build to create the sample project views. After views are created, 
click Close to close the Build Progress window.

Applying Security to the PSA

If you want to set up an account specifically for PSA security (instead of using 
an administration account), you need to assign security to this account. If you 
do not apply security, the driver can not access the objects.

1 From the Application Designer, select Go > PeopleTools > Maintain 
Security.

2 Click Use > Roles > General > Add.

3 In the Add Role field, enter DirXML Administration 4, then click 
OK.

4 In the Description field, enter DirXML Administration 4. 

5 Select the Permission Lists tab and click the drop-down arrow in the 
Permission List column. 

6 For the Permission List value, enter DIRXML, then click OK. The 
Description field will populate automatically.

7 Click File > Save.

8 Click Use > User Profiles > General > Update/Display.

9 Enter your administrative username as the User ID, then click OK.

10 Select the Roles tab, then click the last row to add data.

11 Add the DirXML Administration 4 role to this user, then click Save.

12 Close and restart the PeopleSoft clients and applications.

Testing Sample PeopleSoft Applications

You can test to ensure transactions are created by entering a new person using 
the PeopleSoft DirXML sample application. This example uses Departments, 
so you will need to create a sample department, and then add a person 
(assigning him or her to that department) to validate that the application 
works.

To test sample PeopleSoft applications:
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1 From the Application Designer, select Go > DirXML > DirXML 
Administrator.

2 From the DirXML Administrator menu, select Use > DirXML Sample 
Department.

3 Click an empty Department field row to add sample department, 
description, and DirXML DN values.

4 Click Save to add the Department.

5 From the DirXML Administrator menu, select Use > DirXML Sample 
People > Add.

6 Select the ADD button and a valid ID will be entered by default.

7 Enter data into the various fields for this ID and click Save.

Asterisks represent required fields.

8 Next you want to validate that an ADD transaction was created by 
accessing the TRANS01 Application. Select Use > DirXML 
TRANSACTION01.

9 Select the Search button.

10 Verify that the transaction was created and select the transaction.
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Figure 14 DirXML Transaction01

11 Select Use > DirXML Schema 01 > DirXML Schema.

12 Verify the Schema data on the first tab (Schema 01 A). 

13 Verify that you can update the fields on the second tab (DirXML Schema 
01 B).

14 Select Use > DirXML Trans by Associations. Verify that you can view the 
data.
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Figure 15 DirXML Trans by Associations

15 Select Use > DirXML Driver Defaults. Verify that you can view the 
sequence of transactions.

16 Verify that other Transaction table applications work by clicking Use > 
DirXML Transaction 02 (03, 04, and so forth.)
NOTE: You can create additional transaction tables (Transaction 02, Transaction 
03, and so forth.) However, the delivered sample application is not configured to 
use these additional transaction tables.

Configuring the Remote Loader for the Driver
If you are running another DirXML Remote Loader service on this computer, 
such as the Remote Loader for the Exchange driver, stop that service before 
starting this procedure. Restart the service after completing this Remote 
Loader installation.

1 Run the DirXML Remote Loader Configuration Wizard on your desktop.

2 At the Welcome page, click Next.

3 Keep the default Command Port number, then click Next. 

4 Keep the default Configuration File Name, then click Next.

5 In the DirXML Driver dialog box, mark Native, ensure that the 
PeopleSoft 4.0 driver, NPS8shim.dll, is in the path, then click Next.

6 In the Connection to DirXML dialog box, leave the default Port settings 
and unmark SSL.
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7 Record the port number in the table under “Collecting Configuration 
Information” on page 51, then click Next. This information will be 
required later during driver parameter configuration.

8 Set the Trace Level to 3, so that you’ll get minimal tracking data for 
troubleshooting, specify a filename and location for the trace file, then 
click Next.
NOTE: If you are running multiple Remote Loader sessions on a single computer, 
you should create separate trace files.

9 Mark Install the Remote Loader Instance as a Service and click Next.

10 Set remote and driver passwords. 

We recommend keeping remote passwords and driver passwords the 
same across systems and changing them later when you go to production. 
Record the passwords in the table under “Collecting Configuration 
Information” on page 51. This information will be required later during 
driver parameter configuration.

11 Click Next, review the summary, then click Finish.

12 Start the service when prompted.

The PeopleSoft system is prepared to provision resources to employees. 
Complete preparation of other participating systems, then proceed to 
Chapter 5, “Configuring DirXML Drivers,” on page 131.

Setting Up a PeopleSoft Client for PeopleSoft 7.5
While you set up PeopleSoft, have your PeopleSoft Administrator work with 
you.

The instructions in this section are for the PeopleSoft 3.6 driver, which 
supports PeopleTools 7.57 or higher. For the lab implementation, you will set 
up a PeopleSoft client that can communicate with your PeopleSoft database 
and with the DirXML engine. You will install the PeopleSoft Service Agent 
(PSA) and the DirXML Remote Loader on the PeopleSoft client.
NOTE: Details about driver architecture and driver/application relationships are 
discussed in the driver implementation guides. You can find driver implementation 
guides on the Novell Documentation Web Site (http://www.novell.com/documentation/
lg/dirxmldrivers/index.html).
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To prepare a lab workstation to provision PeopleSoft users, complete the 
following sections:

“Prerequisites” on page 60

“Collecting Configuration Information” on page 60

“Installing Configuration Files” on page 61

“Installing the PeopleSoft Service Agent” on page 62

“Running the Message Agent Test Program” on page 68

“Installing the Event Server” on page 73

“Configuring the Remote Loader for the Driver” on page 77

Prerequisites
The computer where you will install the Remote Loader and the driver must 
be running the following software:

Windows NT 4.0 with Service Pack 5 or higher, or Windows 2000 
Service Pack 2 or greater

The appropriate version of the PeopleTools client and Application Server

Collecting Configuration Information
You’ll need to provide a number of system-specific details when you install 
and configure Novell Nsure Resources for PeopleSoft. Some of these details 
can be collected before you complete the following procedures, and others 
will be defined during the process. 

Print and complete the Import Driver Form for PeopleSoft 4.0 (http://
www.novell.com/documentation/lg/eprov10/configs/ps40.html), which 
mirrors the actual form you will fill out in iManager, or print the following 
table and record information there.

PeopleSoft Platform PeopleTools Client Version PeopleSoft Application 
Server

PeopleSoft 7.5 PeopleTools 7.57 or 
higher

PeopleTools 7.57 or 
higher
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Installing Configuration Files
The files necessary for installing a sample project and for installing the 
Remote Loader are available on the Novell Nsure Resources CD. 

1 At your PeopleSoft client computer, insert the Novell Nsure Resources 
CD. 

2 At the Welcome page, click Next. 

System Value

IP Address and Port for 
PeopleSoft Application Server

(Ask your PeopleSoft 
Administrator.)

IP Address and Port for 
PeopleSoft Event Server 

(Ask your PeopleSoft 
Administrator.)

PeopleSoft User ID and Password

(Ask your PeopleSoft 
Administrator.)

IP Address and Port Number for 
the Remote Loader

(See “Configuring the Remote 
Loader for the Driver” on page 77.)

Remote Loader Password

(See “Configuring the Remote 
Loader for the Driver” on page 77.)

Driver Object Password

(See “Configuring the Remote 
Loader for the Driver” on page 77.)
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3 Read the License Agreement, then click I Accept. 

4 Select the following items, then click Next.

DirXML Remote Loader Service

DirXML Management Utilities

5 Accept the default installation path for the Remote Loader, then click 
Next.

6 Mark the following items, then click Next.

DirXML Remote Loader Service

DirXML Driver for PeopleSoft

7 Select Application Components, then click Next.

8 Select Install Components for PeopleSoft, then click Next.

9 Accept the default directory location for the PeopleSoft components, then 
click Next.

10 Review the Product Summary, then click Finish.

The files you need to complete the next sections are now available.

11 When prompted, click Yes to create a desktop shortcut for the Remote 
Loader.

12 Continue with the next section, “Installing the PeopleSoft Service Agent” 
on page 62.

Installing the PeopleSoft Service Agent
NOTE: Any references to specific paths in these sections represent the defaults 
indicated during the installation procedures. Apply the necessary changes if applicable.

Complete the following tasks to install the PSA on PeopleSoft 7.5:

“Extracting the PSA Files” on page 62

“Installing the PeopleSoft Service Agent” on page 63

“Copying the Novell Integration Project into a Target Database” on page 
64

“Establishing Security to PSA Objects in PeopleSoft 7.5” on page 67

Extracting the PSA Files

The PSA project comes as a self-extracting project. To extract the project:
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1 From the location you specified when you installed the components for 
PeopleSoft, run DIRXML_DRIVER_36.EXE. The default location is 
Novell\NDS\PS. 

2 Click Next, select the destination directory, then click Next to begin 
extracting the PSA files.

3 Click Finish to close the extraction process.

The PSA is now ready to be installed into your PeopleSoft environment.

Installing the PeopleSoft Service Agent

Before you can install and configure the PeopleSoft objects, you need access 
to a PeopleSoft user ID and password with Administrator or appropriate 
developer rights.You can create a unique user ID and password for 
implementing these objects.

To apply the delivered PSA set of objects, follow the steps below or use 
PeopleSoft’s standard upgrade procedures. For information on PeopleSoft 
upgrade procedures, refer to PeopleSoft documentation.

Installing the PSA for PeopleSoft 7.5

Data Mover is an application tool used to import external PeopleSoft objects 
into an existing PeopleSoft 7.5 database. Using the standard PeopleSoft 
upgrade process, you use Data Mover to move the DirXML for PeopleSoft 
projects into an organization’s PeopleSoft environment.

A Data Mover script (DMS) is provided with the driver. This script imports 
new and modified objects into the data dictionary tables. You should only run 
this script on a refreshed Application Update Database (AUD). Refreshing the 
database resolves any conflicts between the delivered objects and any objects 
that already exist in the AUD database. 
WARNING: If the DMS is run against a database other than the AUD, it should fail or 
overwrite existing data. If you run the script directly against the PeopleSoft development 
database, it will corrupt the database. 

To ensure that the DMS files were copied during the component installation, 
check the C:\PSA directory. This is the default directory that the installation 
program uses. If you altered this setting during the installation, check the 
directory that you entered. The following are default steps to import the 
external PeopleSoft objects:

1 From the Start menu, click Programs > PeopleSoft > Data Mover.
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2 Log in to the AUD database in 2-tier mode.

3 Select File > Open.

4 Browse to the appropriate file for your installation > select the DMS 
script with the appropriate release number. (For example, 
DIRXML_DRIVER_PSA_36IMP.DMS.)

5 In the Data Mover syntax dialog box, verify that the input and log files 
are pointing to the directory containing the data (.DAT) files on the local 
drive. 

The following is an example of the delivered syntax:

SET OUTPUT c:\PSA\PSA-PS75\AU_CHECK.DAT;

SET INPUT c:\PSA\PSA-PS75\DIRXML_DRIVER_PSA_36IMP.DAT;

SET LOG c:\PSA\PSA-PS75\DIRXML_DRIVER_PSA_36IMP.LOG;

SET NO TRACE;

SET IGNORE_DUPS;

EXPORT AU_CHECK;

IMPORT *;

6 Select File > Run Script.

From the report in the bottom status panel, verify the import was 
successful. If the import fails, make sure the input and output paths point 
the proper directories.

7 Close Data Mover.

Copying the Novell Integration Project into a Target Database

Your target database contains the system catalog, data dictionary structures, 
and sample application data. When moving from an AUD database to the 
target database, objects from the data dictionary in the AUD are copied to the 
data dictionary of the target database. 

After the copy is complete, you must build the database. The build creates the 
physical tables or views in the underlying database so that the objects are 
accessible. You should be logged in as an administration user when 
completing these procedures.
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We recommend the following:

Use a clean copy of a target database for this procedure.

If you apply a copy to a database with production data, do a copy and 
compare before you apply the copy.

Complete an installation and test that installation against a target 
database.

Do this before you change the configuration and before you apply the 
database to a development or production environment.

To copy the project into a target database:

1 From the Start menu, click Programs > PeopleSoft > PeopleTools.

2  Log in to the AUD database in two-tier mode.

3 Click Go > PeopleTools > Application Designer. 

4 Click File > Open.

5 Click Object Type, then click Project.

6 Click Selection Criteria, Name, then type DIRXML_DRIVER_PSA_36, 
then click Select.

7 Click the project, then click Select.

8 Click Tools > Upgrade > Copy. 

9 Type the target database name (the project will be copied to this 
database), operator ID, and password, then click OK.

Be sure to select all objects with the project, including the project itself.

10 Check the Export Project box to export the objects to the target database, 
then click Copy.

All objects are copied from the AUD to the target database.

11 Close the Application Designer window.

Building Project Record Definitions

After you have imported the project into the PeopleSoft database, you should 
build project record definitions and then build project views.

1 From the Start menu, click Programs > PeopleSoft > PeopleTools.
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2 Log in to the target database using an administrator username that has 
administrative and development rights.

3 In the Application Designer, click File, then click Open. 

4 Select the DIRXML_DRIVER_PSA_36 project, and click Select.

5 Click Build > Project.

6 From Build Options, click Create Tables and Execute SQL Now. 

7 Click Build to create sample project tables. After project tables are 
created, click Close to close the Build Progress window.
NOTE: You must create project tables before creating the views. Views are 
created using information from table fields.

8 From the Application Designer, select Build > Project.

9 From Build Options, click Create Views and Execute SQL Now. 

10 Click Build to create the sample project views. After views are created, 
click Close to close the Build Progress window.

You should now assign security rights to the new objects (see “Establishing 
Roles and Initiating Workflow” on page 66).

Establishing Roles and Initiating Workflow

A role is a class of users who perform the same type of work. Business rules 
typically determine what role performs what activity. The eDirectory 
administrator has been designated as the role performing the ADD, UPD, and 
DIS events. This means that workflow must be activated and a role user must 
be assigned to the eDirectory administrator role. To activate a workflow, 
complete the following:

1 Click Go > PeopleTools > Workflow Administrator.

2 Click Use > Workflow System Defaults > Defaults.

3 Check the Worklist Active box.

4 If you are using e-mail and other electronic forms, check the applicable 
boxes.

5 Ensure that a default role user, typically WF Admin, is also assigned, and 
click Save. If workflow is not currently being used by other processes, 
change this to the role of eDirectory Administrator.
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You should now assign security rights to the new objects (see “Establishing 
Security to PSA Objects in PeopleSoft 7.5” on page 67).

Establishing Security to PSA Objects in PeopleSoft 7.5

You can assign security rights to all new panels and pages that have been 
added to a project. Use an administrator-type account to establish security. 

Applying Security for the New PSA Objects

1 Click Go > PeopleTools > Security Administrator.

2 Click File > Open. Select the ALLPANLS Operator Class, then click OK.

3 Click the Menu Items icon from the left pane.

4 Click Insert > Menu Name.

5 Double-click DirXML_Administrator_36, click Select All, then click 
OK.

6 Click Select All, then click OK.

7 Save. After you save, you can exit the Security Administrator interface.

Verifying Access to PSA Object

After you have applied security to the new PSA objects, you should use the 
sample application to verify that you can access, change, and save data.

You can test to ensure that transactions are created by entering a new person 
using the PeopleSoft DirXML sample application. This example uses 
Departments, so you will need to create a sample department, and then add a 
person (assigning him or her to that department) to validate that the 
application works.

To test sample PeopleSoft applications:

1 Connect to the PeopleSoft database as administrator. 

2 From the Application Designer, select Go > DirXML Administrator 36 
EP.

3 Select Use > DirXML Sample Department.
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4 Click an empty Department field row to add sample department and 
description. The DirXML DN is used for mapping to the eDirectory 
account system.

5 Click Save to add the Department.

6 Select Use > DirXML Sample People > Add.

7 Enter an ID number for the new person and click OK.

8 Enter data into the various fields for this ID and click Save.

(The required fields include first name, last name, birth date, status, title, 
and department ID.) 

9 To validate that an ADD transaction was created, access the eDirectory 
Worklist Maintenance menu. Click Use > eDirectory Worklist 
Maintenance > eDirectory Worklist. You can then search for the ID you 
just created. 

10 Click the Search button.

11 Double-click the event you created. Look at the panels and verify that the 
data you entered exists.

12 Close the PeopleSoft Client.

Running the Message Agent Test Program
You can test the following PeopleSoft Message Agents:

DIRXML_TRANS01

DIRXML_SCHEMA01

DIRXML_SCHEMA01_UPDATE

DIRXML_SCHEMA01_QUERY

Testing the DIRXML_TRANS01 PeopleSoft Message Agent

DIRXML_TRANS01.IST verifies that the Message Agent is receiving events 
from the worklist.

1 Click the C:\PSA\PSA-P75\ directory.
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2 Copy PSMTST32v75.EXE, the test program for a message agent, to the 
{PS_HOME}\BIN\CLIENT\WINX86 directory.

3 Create a shortcut on the desktop to the Message Agent Test program.

4 View the program’s properties, and validate that the .IST file is not set to 
read-only.

5 Double-click the test program.

6 Click File > Open.

7 Click the DIRXML_TRANS01.IST file > Open.

8 Ensure that the appropriate connect string, operator ID, and password are 
listed for connecting to the application server.

9 Click Execute!.

If the Message Agent is working properly, a list of processing key fields 
will be populated.

The following is a sample script:

Connect 137.65.147.162:7000,PS,PS;
StartMessage DIRXML_TRANS01,DIRXML_TRANS01;
ProcessMessage;
GetOutPutall;
Disconnect;

In this script the connect string is 137.65.147.162:7000. The User ID is 
PS, and the password is PS.

You can now close the DIRXML_TRANS01 window. Do not close the 
Message Agent Test program, as you will use it in the following steps.

Testing the DIRXML_SCHEMA01 PeopleSoft Message Agent

DIRXML_SCHEMA01.IST verifies that all of the fields on the 
DIRXML_SCHEMA01 business process definition are being passed to the 
Message Agent. 

1 Double-click the message test program.

2 Click File > Open.

3 Click the DIRXML_SCHEMA01.IST file > Open.

4 Verify that the appropriate connect string, operator ID, and password are 
listed.

5 Modify the INSTANCEID, INSTSTATUS, ACTIVITY NAME, and 
EVENTNAME fields. 
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You can find this information by searching for the person and viewing the 
DIRXML_SCHEMA01 panel on the eDirectory Work List Maintenance 
Search panel. 

Figure 16 eDirectory Work List Maintenance Search Panel

These fields must correspond to the event that you are trying to receive 
the output data for. Copy and paste appropriate values from the output 
from the previous test. This output was generated from testing 
DIRXML_WL_SRCH.IST.

6 Click Save.

7 Click Execute!

If the Message Agent is working properly, all the fields that are populated 
in PeopleSoft will be populated in the output.

The following is a sample script:

Connect 137.65.147.182:7000,PS,PS;
StartMessage DIRXML_SCHEMA01,DIRXML_SCHEMA01;
Setfield BUSPROCNAME=DIRXML_INTEGRATION;
Setfield ACTIVITYNAME=DIRXML_EVENT1;
Setfield EVENTNAME=ADD;
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Setfield WORKLISTNAME=DIRXML_ADD;
Setfield INSTANCEID=5;
Setfield INSTSTATUS=0;
Setfield COMMENTSHORT=Selected;
ProcessMessage;
GetOutPutall;
Disconnect;

8 Close the log files.

Testing the DIRXML_SCHEMA01_UPDATE PeopleSoft Message Agent

DIRXML_SCHEMA01_UPDATE.IST tests updates to the PeopleSoft record 
DIRXML_SCHEMA01_UPDATE. This process tests events that come from 
eDirectory rather than events that are sent from PeopleSoft. 

1 Double-click the message test program.

2 Click File > Open.

3 Click the DIRXML_SCHEMA01_UPDATE.IST file > Open.

4 Verify that the appropriate connect string, operator ID, and password are 
listed.

5 Modify the ASSOC ID, NDS ID, NDS CONTEXT, and Description 
fields.

These fields must correspond to the employee that you are trying to 
update.

6 Click Save.

7 Click Execute!.

If the Message Agent is working properly, the eDirectory Subscriber page 
(the NDS Data Update panel for PeopleSoft 7.5) will be populated with 
the appropriate eDirectory ID, Distinguished Name, e-mail, and 
Description fields for the selected employee. 

The following is a sample script:

Connect 137.65.139.178:7000,PS,PS;
StartMessage 
DIRXML_SCHEMA01_UPDATE,DIRXML_SCHEMA01_UPDATE;
SetField Assoc ID=8964;
SetField NDS ID=GHORNBE;
SetField NDS CONTEXT=NCS.PRV.NOVELL;
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SetField Description=Updated;
SetField email=unknown;
ProcessMessage;
GetOutPutall;
Disconnect;

8 Close the log file.

Testing the DIRXML_SCHEMA01_QUERY PeopleSoft Message Agent

DIRXML_SCHEMA01_QUERY.IST tests the query function for the driver 
from PeopleSoft. This process tests the ability to retrieve data from PeopleSoft 
based on ASSOC ID. 

The Output fields defined on the Query object need to be equivalent to those 
that are defined on the DIRXML_SCHEMA01 object. The primary difference 
between these two objects is the key input fields. This object only has the 
object ID as the key field (for example, ASSOC ID).

1 Double-click the message test program.

2 Click File > Open.

3 Click the DIRXML_SCHEMA01_QUERY.IST file > Open.

4 Verify that the appropriate connect string, operator ID, and password are 
listed.

5 Modify the ASSOC ID.

This field must correspond to the employee that you are trying to access.

6 Click Execute!.

If the Message Agent is working properly, all the fields that are populated 
in PeopleSoft will be populated in the output.

The following is a sample script:

Connect 137.65.139.178:7000,PS,PS;
StartMessage 
DIRXML_SCHEMA01_QUERY,DIRXML_SCHEMA01_QUERY;
SetField Assoc ID=8964;
ProcessMessage;
GetOutPutall;
Disconnect

7 Close the log file.
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Installing the Event Server

Manually Installing and Configuring the Event Server

Typically, the Event Server is installed when you run the installation program. 
If either of the following has occurred, manually install or configure the 
desktop shortcut for the Event Server:

You did not install the Event Server when you installed other components.

Various directory paths were unavailable during the installation.

Installing the Event Server

The following steps assume that eDirectory has been installed on drive C: of 
the server in the \NOVELL\RemoteLoader\ directory.

1 Copy NPS75EVENTSERVER.EXE to the C:\NOVELL\NDS directory.

2 Create a shortcut for the Event Server application on the desktop.
IMPORTANT: If you are running multiple PeopleSoft drivers, create one shortcut 
for each Event Server.

3 Edit the command line in the Target field. Right-click the shortcut > click 
Properties > Shortcut. 

The following graphic illustrates this field:

Figure 17 The Target Field for Desktop Shortcuts
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Enter parameters for the shortcut. In the following example, {PS_Home} 
is the root of the PeopleSoft directory structure.

C:\Novell\NDS\NPS75EventServer.exe -c -s:16386 
-p:{PS_Home}\bin\client\winx86

The -c parameter configures the Event Server so that it runs as a console 
application. When you use this parameter, configure the DOS window 
properties with the following:

A scroll bar

A different color layout

The Event Server communicates with the driver using a Windows sockets 
interface or listening port. The PeopleSoft 7.5 Event Server uses socket 
number 16386. If this number conflicts with sockets already being used 
in your organization, use a different port set. This number is the Event 
Server Port number you will need when configuring the driver.

Because each Event Server requires four consecutive sockets or ports, 
socket numbers for multiple Event Servers must be at least four digits 
apart.

The Event Server must establish communications with the PeopleSoft 
Message Agent. It does this by connecting to the PeopleSoft Message 
Agent DLL files. 

These DLL files are typically located in the 
{PS_HOME}\BIN\CLIENT\WINX86 directory. 

For the NPS75EventServer shortcut, an example path to the PeopleSoft 
Message DLLs is -p:d:\psoft\hr757\bin\client\winX86. In 
this example, {PS_HOME} is equal to d:\psoft\hr757.

4 Enter the following in the Start In field:

c:\Novell\NDS 

This is the directory where eDirectory is installed. The following figure 
illustrates this field:
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Figure 18 The Start In Field

5 Select Apply > Click OK.

6 Open the application via the shortcut.

You can customize the scroll bar and color changes by right-clicking the 
window’s menu and customizing its properties. 

Stopping the Event Server

You might need to stop the Event Server to refresh PeopleSoft connectivity, 
recycle the server, or debug. When you stop the Event Server, the Event Server 
sends a stop command to the driver shim. This command shuts down the 
driver shim before the Event Server exits.

To stop the Event Server from a console window:

1 Select the Event Server window.

2 Enter Q.
IMPORTANT: You can stop the Event Server by clicking the Exit icon in the window. 
However, click this icon only if the driver shim is not running. Before clicking the icon, 
shut down the driver shim. Do this from the DirXML Driver Set Properties menu.

Installing the Event Server as a Service

You can install the Event Server as an NT or Windows 2000 service. 
Normally, the Event Server is installed during the driver installation.

Two additional shortcuts are placed on the desktop during the installation 
process. These shortcuts enable you to create or remove the Event Server as a 
service.

To install the Event Server as a service:

1 Ensure that the Event Server program is available. 

On a local machine, verify that NPSxEvent Server.EXE is saved 
locally to the machine.
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If installing the Event Server on a remote server where eDirectory is 
not installed, copy DIRXMLLIB.DLL and EXPAT.DLL from the 
NOVELL\NDS directory to the directory that the Event Server will 
be run from.
NOTE: The PeopleSoft client must always be installed on the server where 
the Event Server is going to run.

The remote server's IP address will be used when configuring the 
Event Server in the driver parameters.

2 At the command prompt, go to the directory where the executable file is 
stored, then enter the following:

NPS75EventServer.exe -i -s:16386 
-p:{PS_HOME}\bin\client\winx86

The socket number and the path to the PeopleSoft PSMSG.DLL might be 
different, based on your environment and driver configuration.

3 From the Start menu, click Settings > Control Panel > Services > 
DirXML Event Server for PS 7.5 (or the appropriate release).

4 Click Startup > select the Automatic radio button to automatically start up 
the Event Server at login > click Start.

To stop the service:

1 From the Start menu, click Settings > Control Panel > Services. 

2 Select the service, then click Stop.

Manually Uninstalling the Event Server as a Service

You can uninstall or remove the Event Server as a service. Follow the same 
steps as for installing the Event Server. However, in Step 2 substitute the -u 
parameter for the -i parameter.

For example, enter NPS75EventServer.exe -u -s:16386 
-p:{PS_HOME}\bin\client\winx86
NOTE: When the Event Server runs as a service, there is no console window. All debug 
information will only be available in the DSTRACE log.
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Configuring the Remote Loader for the Driver
If you are running another DirXML Remote Loader service on this computer, 
such as the Remote Loader for the Exchange driver, stop that service before 
starting this procedure. Restart the service after completing this Remote 
Loader installation.

1 Run the DirXML Remote Loader Configuration Wizard on your desktop.

2 At the Welcome page, click Next.

3 Keep the default Command Port number, then click Next. 

4 Keep the default Configuration File Name, then click Next.

5 In the DirXML Driver dialog box, mark Native, browse to the PeopleSoft 
3.6 driver, c:\Novell\Remoteloader\NPSshim.dll, then click Next.

6 In the Connection to DirXML dialog box, leave the default Port settings, 
unmark SSL.

7 Record the port number in the table under “Collecting Configuration 
Information” on page 60. Then click Next. This information will be 
required later during driver parameter configuration.

8 Set the Trace Level to 3, so that you’ll get minimal tracking data for 
troubleshooting, specify a filename and location for trace file, then click 
Next.
NOTE: If you are running multiple Remote Loader sessions on a single computer, 
you should create separate trace files.

9 Mark Install the Remote Loader Instance as a Service and click Next.

10 Set remote and driver passwords. 

We recommend keeping remote passwords and driver passwords the 
same across systems and changing them later when you go to production. 
Record the passwords in the table under “Collecting Configuration 
Information” on page 60. This information will be required later during 
driver parameter configuration.

11 Click Next, review the summary, then click Finish.

12 Start the service when prompted.
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The PeopleSoft system is prepared to provision resources to employees. 
Complete preparation of other participating systems and then proceed to 
Chapter 5, “Configuring DirXML Drivers,” on page 131.

Setting Up SAP
While you set up SAP, have a Basis consultant available who is able to 
configure ALE. However, the ALE steps in this document should be followed 
as written. They may differ from the consultant’s standard steps. 
NOTE: Details about driver architecture and driver/application relationships are 
discussed in the driver implementation guides. You can find driver implementation 
guides on the Novell Documentation Web Site (http://www.novell.com/documentation/
lg/dirxmldrivers/index.html).

To prepare a lab workstation to provision resources to SAP users, complete the 
following sections:

“Prerequisites” on page 78

“Collecting Configuration Information” on page 79

“Configuring the SAP System” on page 80

“Installing and Configuring the Remote Loader and Driver” on page 87

Prerequisites
The computer where you will install the Remote Loader and the driver must 
be running the following software:

The system where the driver shim is running must have the SAP 
JavaConnector (JCO) client technology installed for connectivity to the 
SAP HR system.

Currently the driver supports only client version 1.1.x. This client is 
freely available through SAP and is provided for most popular server 
operating systems. You can download the JCO from the SAP Connectors 
site (http://service.sap.com/connectors).

The driver shim will run on an SAP R/3 host system. As part of the 
installation, you must install the Remote Loader service on the SAP 
system. 
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SAP HR revision level 4.5B or higher.

Collecting Configuration Information
You’ll need to provide a number of system-specific details when you install 
and configure Novell Nsure Resources for SAP. Some of these details can be 
collected before you complete the following procedures, and others will be 
defined during the process. 

Print and complete the Import Driver Form for SAP (http://www.novell.com/
documentation/lg/eprov10/configs/sap.html), which mirrors the actual form 
you will fill out in iManager, or print the following table and record 
information there.

System Value

IP Address for the SAP 
Application Server

(Ask your SAP Administrator.)

SAP System Number

(Ask your SAP Administrator.)

SAP Client Number

(Ask your SAP Administrator.)

SAP User ID and Password

(Ask your SAP Administrator.)

Metadata File Directory

(Default=c:\Novell\RemoteLoader
\lib\SAPutils.)

IDocs File Directory

(See “Creating a Port Definition” 
on page 83.)
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Configuring the SAP System
As part of configuring the SAP system, you should complete the following 
steps in this order:

1. “Defining Sending and Receiving Systems” on page 81

2. “Creating a Distribution Model” on page 82

3. “Creating a Port Definition” on page 83

4. “Generating Partner Profiles” on page 83

5. “Generating an IDoc” on page 84

6. “Activating Change Pointers” on page 85

7. “Schedule a Job for Change Pointer Processing” on page 85

8. “Scheduling a Job” on page 85

9. “Testing the Change Pointer Configuration” on page 86

10. “Creating a CPIC User” on page 86

11. “Populating eDirectory with Organizational Data” on page 87

IP Address and Port Number for 
the Remote Loader

(See “Installing and Configuring 
the Remote Loader and Driver” on 
page 87.)

Driver Object Password

(See “Installing and Configuring 
the Remote Loader and Driver” on 
page 87.)

Remote Loader Password

(See “Installing and Configuring 
the Remote Loader and Driver” on 
page 87.)

System Value
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NOTE: The following instructions are for SAP version 4.6C. If you are using a previous 
version of SAP, the configuration process is the same; however, the SAP interface will 
be different. 

Defining Sending and Receiving Systems

The sending and receiving systems must be defined for messaging. In order to 
distribute data between systems you must first define both the sending and 
receiving systems as unique logical systems.

There is a one-to-one relationship between a client and a logical system. 
Therefore, you must assign a client to each logical system. You should never 
assign the same client to more than one logical system. 

For this particular solution, we recommend defining two logical systems. One 
logical system will act as the receiver and the other logical system will act as 
the sender. Although only one of these clients is used as a data source (that is, 
the client/logical system where employee data is stored and "actions" occur) 
and target for the driver, the second client is needed for defining the receiving 
logical system. 
NOTE: Depending on your current SAP environment, you might not need to create a 
logical system. You might only need to modify an existing Distribution Model by adding 
the HRMD_A message type to a previously configured Model View. For more 
information, see “Creating a Distribution Model” on page 82. 

It is important, however, that you follow SAP’s recommendations for logical systems and 
configuring your ALE network. The following instructions assume that you are creating 
new logical systems and a new model view.

Creating a Logical System

1 Enter transaction code SPRO, then display the SAP Reference IMG 
project (or the project applicable to your organization).

2 Click Basis Components > Application Link Enabling (ALE) > Sending 
and Receiving Systems > Logical Systems > Define Logical System.

3 Click Edit > New Entries.

4 Enter a name and a description for the logical system you want to create.

5 Save your entry.
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Assigning a Client to the Logical System

1 Enter transaction code SPRO, then display the SAP Reference IMG 
project (or the project applicable to your organization).

2 Click Basis Components > Application Link Enabling (ALE) > Sending 
and Receiving Systems > Logical Systems > Assign Client to Logical 
System.

3 Select the client.

4 Click GOTO > Details to display the Client Details dialog box. 

5 In the Logical System field, enter the logical system you want to assign 
to this client.

6 Save your entry.

Creating a Distribution Model

The distribution model contains essential information about message flow. 
The model view defines the systems that will communicate with each other 
and the messages that will flow between them. The distribution model forms 
the basis of distribution and controls it directly. 

To create a distribution model:

1 Verify that you are logged on to the sending system/client.

2 Enter transaction code BD64. Ensure that you are in Change mode.

3 Click Edit > Model View > Create.

4 Enter the short and technical names for your view, as well as the start and 
end date, then click Continue.

5 Select the view you created, then click Add Message Type.

6 Define the sender/logical system name.

7 Define the receiver/server name.

8 Define the Message Type you want to use (HRMD_A), then click 
Continue.

9 Click Save.
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Creating a Port Definition

The port is the communication channel to which IDocs are sent. The port 
describes the technical link between the sending and receiving systems. You 
should configure a file port for this solution. The file port is used to determine 
the directory and the file location to which IDocs are sent. 

To create a file port definition:

1 Enter transaction code WE21.

2 Select File, then click the Create icon. Enter information for the following 
fields:

Name port

Port description

Version: Select SAP release 4.X

3 Define the outbound file:

3a Select the physical directory. This is the directory where you want 
IDocs placed. You might need to create this directory.

Enter the directory where the outbound files are written, for example: 
\\SAPDEV\NOV\SYS\GLOBAL\SAPNDSCONNECTOR

3b Enter the function module. This names the IDoc file in a specific 
format. For example: EDI_PATH_CREATE_CLIENT_DOCNUM

4 Save your changes.
NOTE: You do not need to configure the other three tabs for the port properties 
(outbound:trigger, inbound file, and status file).

Generating Partner Profiles

The system automatically generates a partner profile or you can manually 
maintain the profile.
NOTE: If you are using an existing distribution model and partner profile, you do not 
need to automatically generate a partner profile. Instead, you can modify it to include 
the HRMD_A message type.

To automatically generate a partner profile:

1 Enter transaction code BD82.
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2 Select the Model View. This should be the Model View previously 
created in “Creating a Distribution Model” on page 82.

3 Ensure the Transfer IDoc immediately and Trigger Immediately radio 
buttons are selected.

4 Click Execute.

Modify Port Definition

When you generated a partner profile, the port definition might have been 
entered incorrectly. For your system to work properly, you need to modify the 
port definition. 

1 Enter transaction code WE20.

2 Select Partner Type LS.

3 Select your receiving partner profile.

4 Select Outbound Parameters, then click Display.

5 Select message type HRMD_A.

6 Click Outbound Options, then modify the receiver port so it is the file port 
name you created in “Creating a Port Definition” on page 83.

7 From the Output Mode, select Transfer IDoc Immediately to send IDocs 
immediately after they are created.

8 From the IDoc Type section, select HRMD_A03 as basictype if you are 
using SAP 4.5. If you are using SAP 4.6, you should select HRMD_A05.

9 Click Continue/Save.

Generating an IDoc

1 Enter transaction code PFAL.

2 Insert the Object Type P for person objects.

3 Enter an Employee’s ID for the Object ID or select a range of employees.

4 Click Execute.

Ensure that the status is set to "passed to port okay." 
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The IDoc has been created. Go to the directory where IDocs are stored (it 
was defined in the file port setup) and verify that the IDoc text file was 
created. 

Activating Change Pointers

To activate change pointers globally:

1 Enter transaction code BD61.

2 Enable the Change Pointers Active tab.

To activate change pointers for a message type:

1 Enter transaction code BD50.

2 Scroll to the HRMD_A message type.

3 Check the HRMD_A check box, then click Save.

Schedule a Job for Change Pointer Processing

1 Enter transaction code SE38 to begin defining the variant.

2 Select the RBDMIDOC program, select Variant, then click the Create 
icon.

3 Name the variant and give it a description. 
NOTE: Make note of the variant name so you can use it when scheduling the job.

4 Select the HRMD_A message type, then click Save.

You will be prompted to select variant attributes. Select the background 
processing attribute.

5 Click Save.

Scheduling a Job

1 Enter transaction code SM36.

2 Name the job.

3 Assign Job Class.
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Job Class is the priority in which jobs are processed. Class A is the highest 
priority and will be processed first. For a production environment, we 
recommend assigning the class to B or C.

4 Schedule a start time. Click the Start Condition tab, then click Date and 
Time. Enter a scheduled start time, which must be a future event.

4a Mark the job as a periodic job > click the Periodic Values tab, 
schedule how frequently you want the job to run, then press Enter. 
For testing purposes, we recommend setting this period to 5 minutes.

4b Click Save.

5 Define the job steps.

5a Enter the ABAP program name: RBDMIDOC.

5b Select the variant you created in the previous step.

6 Click Save.
IMPORTANT: Click Save once; otherwise, the job will be scheduled to run 
multiple times.

Testing the Change Pointer Configuration

1 From the SAP client, hire an employee.

2 Ensure that an IDoc was created. 

You can verify IDoc creation in two locations:

Enter transaction code WE02

Go to the IDoc file locations

Creating a CPIC User

Users are client-independent. For each client that will be using the driver, a 
system user with CPIC access must be created. 

1 From User Maintenance in SAP, enter a username in the user dialog box, 
then click the Create icon.

2 Click the Address tab, then enter data in the last name and format fields.

3 Click the Logon Data tab, then define the initial password and set the user 
type to CPIC.
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4 Click the Profiles tab, then add the SAP_ALL, SAP_NEW and 
S_A.CPIC profiles.

5 Click Save.
NOTE: Initially, you can create a dialog user to test your SAP system configuration. If 
there are processing problems, you can analyze the dialog user in the debugger. You 
should also log into the SAP system once to set this user’s password. After the system 
is tested and works properly, you should switch to a CPIC user for security measures.

Populating eDirectory with Organizational Data

In SAP HR, there is not a direct relationship between a manager and his or her 
employees. The hierarchical relationship exists between the positions they 
hold. To establish a manager-to-employee relationship, it is necessary to 
traverse from manager Person to manager Position to employee Position to 
employee Person.

In order to populate eDirectory with the organizational data, the existing data 
must be exported from SAP. To export your organization’s hierarchical data, 
perform the following steps before starting the driver:

1 From the SAP client, enter transaction code PFAL.

2 Insert the Object Type O for Organization objects.

3 Enter the organizations you want to export to eDirectory. You can choose 
to export one organization, a range of organizations, or all organizations.

4 Click Execute. Ensure that the status is set to "passed to port okay."

5 Repeat the above process for Object Type C for Job objects.

6 Repeat the above process for Object Type S for Position objects.
IMPORTANT: It is important that you export the objects in the order specified 
above. This ensure that the driver makes the correct relationships.

Installing and Configuring the Remote Loader and Driver
The following instructions explain how to install the Remote Loader and 
driver on the Windows NT/2000 platform. If you need setup instructions for 
UNIX platforms, see the DirXML Driver for SAP Implementation Guide 
(http://www.novell.com/documentation/lg/dirxmldrivers/sap/data/
aazjth1.html).
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NOTE: If you are running another DirXML Remote Loader service on this computer, 
such as the Remote Loader for the Exchange driver, stop that service before starting 
this procedure. Restart the service after completing this Remote Loader installation.

1 Insert the Novell Nsure Resources CD and click Next at the Welcome 
page. 

2 At the License page, click I Accept.

3 At the Components dialog box, select DirXML Remote Loader Service 
and click Next.

4 Accept the default installation path for the Remote Loader, then click 
Next.

5 Mark the following items, then click Next.

DirXML Remote Loader Service

DirXML Driver for SAP

6 Review the Product Summary, then click Finish to install the Remote 
Loader files.

7 When prompted, create a shortcut.

8 Run the DirXML Remote Loader Configuration Wizard from your 
desktop.

9 At the Welcome page, click Next.

10 Keep the default Command Port number, then click Next. 

11 Keep the default Configuration File Name, then click Next.

12 In the DirXML Driver dialog box, mark Java, then click Next.

13 In the Connection to DirXML dialog box, leave the default Port settings, 
and ensure that Use SSL is unchecked.

14 Record the port number in the table under “Collecting Configuration 
Information” on page 79, then click Next. This information will be 
required later during driver parameter configuration.

15 Set Trace Level to 3, so that you’ll get minimal tracking data for 
troubleshooting, specify a location and filename for the trace file, then 
click Next.
NOTE: If you are running multiple Remote Loader sessions on a single computer, 
you should create separate trace files.
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16 Mark Install the Remote Loader Instance as a Service, then click Next.

17 Set Remote Loader and Driver Object passwords. 

We recommend keeping remote passwords and driver passwords the 
same across systems and changing them later when you go to production. 
Record the passwords in the table under “Collecting Configuration 
Information” on page 79. This information will be required later during 
driver parameter configuration.

18 Review the summary and click Finish.

19 When prompted, start the service.

The SAP system is prepared to provision resources to employees. 
Complete preparation of other participating systems and then proceed to 
Chapter 5, “Configuring DirXML Drivers,” on page 131.

Setting Up Lotus Notes
While you set up the Notes system, have your Notes Administrator work with 
you.
NOTE: Details about driver architecture and driver/application relationships are 
discussed in the driver implementation guides. You can find driver implementation 
guides on the Novell Documentation Web Site (http://www.novell.com/documentation/
lg/dirxmldrivers/index.html).

To prepare a lab workstation to provision resources to Notes users, complete 
the following sections in the order they are listed:

“Prerequisites” on page 90

“Collecting Configuration Information” on page 90

“Creating Lotus Notes Accounts” on page 92

“Configuring Database Replication Using NDSRep” on page 93

“Installing and Configuring the Remote Loader and Driver” on page 96
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Prerequisites
The DirXML Notes driver must always run on the same computer where the 
Lotus Notes server and Lotus Notes client are installed. This computer must 
be running the following software:

Windows NT with Service Pack 5 or Service Pack 6, or Windows 2000 
Server, or Windows 2000 Professional.

Lotus Notes R5.0.4 or higher 

Collecting Configuration Information
You’ll need to provide a number of system-specific details when you install 
and configure Novell Nsure Resources for Notes. Some of these details can be 
collected before you complete the following procedures, and others will be 
defined during the process. 

Print and complete the Import Driver Form for Lotus Notes (http://
www.novell.com/documentation/lg/eprov10/configs/notes.html), which 
mirrors the actual form you will fill out in iManager, or print the following 
table and record information there.

System Value

Notes User ID 

User Password

Notes User ID File 

Notes Server 

Server Password

Notes Server ID File

Notes Certifier File 

Certifier Password

Notes Organization Name

Notes Domain Name
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Target Notes Database 

Notes Changelog Database

Notes ID Storage Path

Notes Certification Log Database

Notes Mail Database Template 

Mail Database Storage Path

Notes Mail Server

Internet Mail Domain Name

Managers Group UNID

Employee Group UNID

Deny Access Group UNID

Driver Publisher Filter File

Remote Hostname and Port

(See “Installing and Configuring 
the Remote Loader and Driver” on 
page 96.)

Remote Driver Password

(See “Installing and Configuring 
the Remote Loader and Driver” on 
page 96.)

Remote Loader Password

(See “Installing and Configuring 
the Remote Loader and Driver” on 
page 96.)

System Value
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Creating Lotus Notes Accounts
You will create a user ID for use exclusively by the driver. This user needs 
Manager access to the public address book and the CERT.LOG file. 
IMPORTANT: If the CERT.LOG isn’t available on the lab server, you must create it.

You will also create groups that support provisioning policies.

To create Lotus Notes accounts:

1 Create a Notes User ID of User Type Person with Manager access to the 
public address book and to the CERT.LOG file. Export the User ID 
information; the typical location is the c:\LotusNotes\Data directory. 

2 Record the User ID information in the table under “Collecting 
Configuration Information” on page 90. This information will be required 
later during driver parameter configuration.

3 Insert the Novell Nsure Resources CD and copy the Notes Discovery 
Utility, NOTESIDTOOL.EXE, from /UTILITIES/NOTES_DISC/ to the 
LOTUS/DOMINO.

4 Double-click the utility, then enter the DN of the Loop User.

The Loop User DN will be used as the attribute value for the groups’ 
owner and administrator attributes.

5 Click Generate to create the following three groups: 

Employees: Contains user objects that do not have the isManager 
attribute indicating they are managers. 

Managers: Contains user objects that do have the isManager 
attribute indicating they are managers. An e-mail distribution list is 
created based on the membership of this group.

Deny Access Group: Contains user objects representing people that 
have left the company or taken a temporary leave.
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Figure 19

6 Click Paste to File to copy the Association String for each group from the 
fields in the Notes Discovery Utility to a text file for later use. 

The strings are used by the driver to uniquely identify these objects. 

7 Close the Discovery utility and continue with the next section, 
“Configuring Database Replication Using NDSRep” on page 93.

Configuring Database Replication Using NDSRep
You can configure database replication between Lotus Notes and eDirectory 
through NDSRep. NDSRep is an add-in process that sits on the Lotus 
Domino* server to facilitate data replication. NDSRep is responsible for 
sending changes from the address book on the Domino server to the output 
database. 

Use the NDSReg executable to define the parameters used by the NDSRep 
process. 

1 Copy NDSREP.EXE and NDSREG.EXE from 
\NT\DIRXML\DRIVERS\LOTUSNOTES\BIN to the 
LOTUS\DOMINO directory.

2 Open the \LOTUS\DOMINO directory on the Lotus Notes server and 
double-click NDSREG.EXE to start the NDSRep Configuration Tool. 
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Figure 20 NDSRep Configuration Tool

3 Set the NDSRep parameters as follows:

Option Description

Automatically reload 
configuration 

Leave it unchecked.
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Replication Schedule Set this for 1 minute.

This determines how often NDSRep checks the 
input database.

DN Format The rules created by the Wizard Import file for the 
driver (NOTESIMPORT.XML) expect Slash. 

The default rules require this field to be Slash.

Loop Detection Make sure this is checked and enter the fully 
qualified DN of the Notes ID assigned to the driver.

For example, if the driver’s ID is Notes Driver and 
it is certified by the organizational certifier (root 
certifier) for NotesOrg, then the DN is as follows

CN=Notes Driver/O=NotesOrg

Record this information in the table under 
“Collecting Configuration Information” on page 90. 
This information will be required later during driver 
parameter configuration.

Input Database Enter NAMES.NSF (if you’re using a different 
target database, enter its name). 

Enter this without full path information. This 
filename must match the Input Database field 
specified in the driver parameters.

Record this information in the table under 
“Collecting Configuration Information” on page 90. 
This information will be required later during driver 
parameter configuration.

Input DB Is a Notes 
Directory

Check this option.

This tells the Notes driver the database type. 

Option Description
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4 Click Save Configuration.

5 Add NDSRep to the Server Tasks in the NOTES.INI file in the 
LOTUS\DOMINO directory to automatically load NDSRep on the 
Domino server. For example,

ServerTasks=Router,Replica,Update,Amgr,AdminP,maps,ndsrep

6 Add LOTUS\NOTES to your system path. For example,

PATH=C:\WINNT\System32;C:\WINNT;C:\LOTUS\NOTES

7 Reboot the computer, then continue with “Installing and Configuring the 
Remote Loader and Driver” on page 96.

Installing and Configuring the Remote Loader and Driver

If you are running another DirXML Remote Loader service on this computer, 
such as the Remote Loader for the Exchange driver, stop that service before 

Output Database Enter NDSRep.NSF (or if you’re using a different 
database, the name of your output database).   

NDSRep creates this database where filtered 
updates will be accessed by 
NOTESDRIVERSHIM. 

This filename must match the Output Database 
field specified in the driver parameters. 

Record this information in the table under 
“Collecting Configuration Information” on page 90. 
This information will be required later during driver 
parameter configuration.

Publisher Filter This is the Publisher filter specified for the driver’s 
Publisher channel. This file is created when 
NotesDriverShim starts. It can be any filename 
you choose. Include a full path. 

Record this information in the table under 
“Collecting Configuration Information” on page 90. 
This information will be required later during driver 
parameter configuration.

Option Description
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starting this procedure. Restart the service after completing this Remote 
Loader installation.

1 Insert the Novell Nsure Resources CD and click Next at the Welcome 
page. 

2 At the License page, click I Accept.

3 At the Components dialog box, select DirXML Remote Loader Service, 
then click Next.

4 Accept the default installation path for the Remote Loader and click Next.

5 Mark the following items, then click Next.

DirXML Remote Loader Service

DirXML Driver for Notes

6 Review the Product Summary and click Finish to install the Remote 
Loader files.

7 When prompted, create a shortcut.

8 Run the DirXML Remote Loader Configuration Wizard from your 
desktop.

9 At the Welcome page, click Next.

10 Keep the default Command Port number, then click Next. 

11 Keep the default Configuration File Name, then click Next.

12 In the DirXML Driver dialog box, mark Java, then click Next.

13 In the Connection to DirXML dialog box, leave the default Port settings, 
and ensure that Use SSL is unchecked.

14 Record the port number in the table under “Collecting Configuration 
Information” on page 90, then click Next. This information will be 
required later during driver parameter configuration.

15 Set Trace Level to 3, so that you’ll get minimal tracking data for 
troubleshooting, specify a location and filename for the trace file, then 
click Next.
NOTE: If you are running multiple Remote Loader sessions on a single computer, 
you should create separate trace files.

16 Mark Install the Remote Loader Instance as a Service, then click Next.
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17 Set Remote Loader and Driver Object passwords. 

We recommend keeping remote passwords and driver passwords the 
same across systems and changing them later when you go to production. 
Record the passwords in the table under “Collecting Configuration 
Information” on page 90. This information will be required later during 
driver parameter configuration.

18 Review the summary and click Finish.

19 When prompted, start the service.

Copying the NOTES.JAR File

1 Copy the NOTES.JAR file from the LOTUS\NOTES directory to the 
NOVELL\REMOTELOADER\LIB directory.

This will ensure that NOTESDRIVERSHIM is loaded with the correct 
version of NOTES.JAR for your Notes installation.

The Notes system is prepared to provision resources to employees. 
Complete preparation of other participating systems and then proceed to 
Chapter 5, “Configuring DirXML Drivers,” on page 131.

Setting Up GroupWise
GroupWise® runs on an eDirectory server. For the lab implementation, 
GroupWise should be installed on the server that is hosting your Workforce 
Tree. Having GroupWise on your Workforce Tree allows GroupWise to 
participate in the preconfigured data exchange through the provisioning 
repository. This configuration streamlines lab setup, but will not address many 
organizations’ configurations. Customization will be required in most cases.

Work with your GroupWise Administrator to complete installation and setup. 
For the lab configuration, install the same version of GroupWise on the 
Workforce Tree that you are running in your production environment. For 
GroupWise installation instructions, see the GroupWise Documentation Web 
site (http://www.novell.com/documentation-index/
index.jsp?category=GroupWise). 

The remote driver for GroupWise will be installed on a separate Windows 
workstation. To prepare this workstation, complete the following sections:
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“Prerequisites” on page 99

“Collecting Configuration Information” on page 100

“Configuring Driver Authentication” on page 101

“Installing and Configuring the Remote Loader and Driver” on page 105

Details about driver architecture and driver/application relationships are 
discussed in the driver implementation guides.You can find driver 
implementation guides on the Novell Documentation Web Site (http://
www.novell.com/documentation/lg/dirxmldrivers/index.html).

Prerequisites
Your GroupWise installation should include the following objects:

A GroupWise container for GroupWise-specific objects under the 
Organization object in your Workforce Tree

GroupWise Post Office

GroupWise Distribution List for Employees 

GroupWise Distribution List for Managers

Your GroupWise installation should be configured to generate Internet e-
mail addresses. See Internet-Style Addressing (http://www.novell.com/
documentation/lg/gw6/index.html?gw6_admin/data/a3ikxn4.html) in the 
GroupWise documentation.

The computer where you will install Remote Loader and the driver must 
be running the following software:

Windows NT with Service Pack 6, or Windows 2000 Server, or 
Windows 2000 Professional.

Novell ClientTM 4.81 or higher for Windows NT/2000

You can install the Novell Client 4.83 or higher from the root of the 
DirXML 1.1a product CD or from Novell Product Downloads (http:/
/download.novell.com/filedist/PublicSearch).
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Collecting Configuration Information 
You’ll need to provide a number of system-specific details when you install 
and configure Novell Nsure Resources for GroupWise. Some of these details 
can be collected before you complete the following procedures, and others 
will be defined during the process. 

Print and complete the Import Driver Form for GroupWise (http://
www.novell.com/documentation/lg/eprov10/configs/gw.html), which mirrors 
the actual form you will fill out in iManager, or print the following table and 
record information there.

System Value

IP Address for the Primary 
Domain Server

Primary Domain Path

Username 

eDirectory User Context

Password

Default Post Office DN

Employees Group Object 
Distinguished Name

Managers Group Object 
Distinguished Name

IP Address and Port Number for 
the Remote Loader

(See “Installing and Configuring 
the Remote Loader and Driver” on 
page 105.)

Driver Object Password

(See “Installing and Configuring 
the Remote Loader and Driver” on 
page 105.)
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Configuring Driver Authentication
This driver handles system authentication differently than most DirXML 
drivers. In order for the driver to authenticate to the GroupWise domain, both 
the driver and the GroupWise domain systems must first authenticate to its 
respective operating system. (If the driver is on the same computer as the 
domain database, you do not need to configure authentication.)

As part of configuring authentication, you will create accounts with the same 
username and password on each system and assign the account administrative 
rights.

In order to configure authentication you should:

“Create a User Account for the System Containing the Driver” on page 
101

“Create a User Account for the System Containing the GroupWise 
Domain” on page 104

Create a User Account for the System Containing the Driver

When the Driver Is on Windows NT

1 From the Start Menu, select Programs > Administrative Tools (Common) 
> User Manager.

2 Select User > New User, then enter a new user name.

The user name must be the same on both systems.

3 Enter a case-sensitive password. 

The password must be the same on both systems.

4 Select Password Never Expires, then uncheck all other boxes.

5 Select Groups > Add Administrators to the Member Of list, then click 
OK.

6 Click OK.

7 Select the user you just created.

Remote Loader Password

(See “Installing and Configuring 
the Remote Loader and Driver” on 
page 105.)

System Value
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8 Select Policies, then select User Rights.

9 Mark the Show Advanced User Rights check box.

10 Select Log on as a Service from the Rights drop-down list.

11 Click Add, then click Show Users.

12 Select the user you just created.

13 Click Add, then click OK.

14 Click OK.

15 Close the User Manager window.

16 Reboot the system.

When the Driver Is on Windows 2000

1 From the Start Menu, click Settings > Control Panel > Administrative 
Tools > Computer Management.

2 In the Tree view, open Local Users and Groups.

3 Click Users, click Action, then click New User.

4 Enter a user name, and enter a case-sensitive password.

The user name and password must be the same on both systems.

5 Uncheck all other boxes.

6 Click Password Never Expires.

7 Select Create, then click Close.

8 In the Tree view, select Groups.

9 Double-click Administrators.

10 Click Add.

11 Select the user you just created > Add > OK > OK.

12 Close the Computer Management window.

13 Select Local Security Policy from the Administrative Tools window.

14 Open Local Policies in the Tree view.

15 Select User Rights Assignment.
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16 Double-click Log On As a Service.

17 Select Add.

18 Enter the user you just created > Add > OK > OK.

19 Close the Local Security Settings window.

20 Close the Administrative Tools window.

21 Restart your computer.

When the Driver Is on Windows 2000 AD Domain Controller

1 From the Start Menu, click Settings > Control Panel > Administrative 
Tools > Active Directory Users and Computers.

2 In the Tree view, click Users > Action > New > User.

3 Enter the full name, then enter the user login name. 

The user login name is used in the driver configuration. The user name 
must be the same on both systems.

4 Click Next.

5 Enter a case-sensitive password.

The password must be the same on both systems.

6 Select Password Never Expires.

7 Click Next, then click Finish.

8 In the Tree view, select Builtin > Administrator’s properties > Members 
> Add.

9 Select the full name of the user you entered in step 3 > Add > OK > OK.

10 Close the Active Directory Users and Computers window.

11 In the Administrative Tools window, select Domain Controller Security 
Policy.

12 In Tree View, expand Security Settings > Local Policies > User Rights 
Assignment.

13 Select Log On As a Service > Security > Add > Browse.

14 Select the user you created in step 3 > Add > OK > OK > OK.
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15 Close the Domain Controller Security Policy.

16 Reboot the system.

Create a User Account for the System Containing the GroupWise Domain

If you have not created the user account for the driver system, refer to “Create 
a User Account for the System Containing the Driver” on page 101.

When the GroupWise Domain Is on Windows 2000

1 From the Start Menu, click Settings > Control Panel > Administrative 
Tools > Computer Management.

2 In the Tree view, open Local Users and Groups > Users > Action > New 
User.

3 Enter a user name.

The user name must be the same on both systems.

4 Enter a case-sensitive password.

5 Select Password Never Expires, then uncheck all other boxes.

6 Click Create, then click Close.

7 Close the Windows Manager window.

8 Double-click the My Computer icon on the desktop.

9 Right-click the drive that contains the GroupWise Domain > Properties > 
Sharing.

10 Select New Share.

11 Enter a share name to be used by the drive.

12 Select Permissions > Everyone > Remove.

13 Select Add.

14 Select the user you added above.

15 Click Add > OK.

16 Select Permissions: Full Control > OK > OK > OK.

17 Reboot the system.
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Installing and Configuring the Remote Loader and Driver
If you are running another DirXML Remote Loader service on this computer, 
such as the Remote Loader for the Exchange driver, stop that service before 
starting this procedure. Restart the service after completing this Remote 
Loader installation.

1 Insert the Novell Nsure Resources CD and click Next at the Welcome 
page. 

2 At the License page, click I Accept.

3 At the Components dialog box, select DirXML Remote Loader Service, 
then click Next.

4 Accept the default installation path for the Remote Loader, then click 
Next.

5 Mark the following items, then click Next.

DirXML Remote Loader Service

DirXML Driver for GroupWise

6 Review the Product Summary, then click Finish to install the Remote 
Loader files.

7 When prompted, create a shortcut.

8 Run the DirXML Remote Loader Configuration Wizard from your 
desktop.

9 At the Welcome page, click Next.

10 Keep the default Command Port number and click Next. 

11 Keep the default Configuration File Name and click Next.

12 In the DirXML Driver dialog box, mark Java, then click Next.

13 In the Connection to DirXML dialog box, leave the default Port settings, 
and ensure that Use SSL is unchecked.

14 Record the port number in the table under “Collecting Configuration 
Information” on page 100, then click Next. This information will be 
required later during driver parameter configuration.
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15 Set Trace Level to 3, so that you’ll get minimal tracking data for 
troubleshooting, specify location and filename for the trace file, then click 
Next.
NOTE: If you are running multiple Remote Loader sessions on a single computer, 
you should create separate trace files.

16 Mark Install the Remote Loader Instance as a Service and click Next.

17 Set Remote Loader and Driver Object passwords. 

We recommend keeping remote passwords and driver passwords the 
same across systems and changing them later when you go to production. 
Record the passwords in the table under “Collecting Configuration 
Information” on page 100. This information will be required later during 
driver parameter configuration.

18 Review the summary, then click Finish.

19 When prompted, start the service.

The GroupWise system is prepared to provision resources to employees. 
Complete preparation of other participating systems and then proceed to 
Chapter 5, “Configuring DirXML Drivers,” on page 131.

Setting Up Exchange 5.5
While you set up the Exchange 5.5 system, have your Exchange Administrator 
work with you.

If you want to use Exchange 2000, you must set it up with Active Directory. 
See “Setting Up Active Directory and Exchange 2000” on page 119.
NOTE: Details about driver architecture and driver/application relationships are 
discussed in the driver implementation guides. You can find driver implementation 
guides on the Novell Documentation Web Site (http://www.novell.com/documentation/
lg/dirxmldrivers/index.html).

To prepare a lab workstation to provision Exchange 5.5 users, complete the 
following sections:

“Prerequisites” on page 107

“Collecting Configuration Information” on page 107

“Creating Distribution Lists” on page 109
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“Installing and Configuring the Remote Loader and Driver” on page 109

Prerequisites
The computer where you will install the Remote Loader and the driver must 
be configured as follows:

A Windows NT Server that belongs to the same domain as the Exchange 
Server domain. This restriction is a Microsoft-imposed NT credential 
restriction.

The NT server must have the following Microsoft DLLs installed in the 
WINNT\system32 directory: LIBXDS.DLL, EXCHMEM.DLL, and 
EXPSRV.DLL. These files are installed by the Exchange Administrator 
program. Exchange Administrator can be installed from the Microsoft 
Exchange Server CD.

Collecting Configuration Information
You’ll need to provide a number of system-specific details when you install 
and configure Novell Nsure Resources for Exchange. Some of these details 
can be collected before you complete the following procedures, and others 
will be defined during the process. 

Print and complete the Import Driver Form for Exchange 5.5 (http://
www.novell.com/documentation/lg/eprov10/configs/ex55.html), which 
mirrors the actual form you will fill out in iManager, or print the following 
table and record information there.

System Value

NT Domain

NOTE: If you are also 
synchronizing NT data, the 
domains must be the same.

IP Address for the Exchange 
Server

Exchange Server Name
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Creating an Authoritative User
You can configure the driver to use any existing account with the 
administrative rights, or to ease future management, you can create a new 
account to be used exclusively by the driver. If you are also using the NT 
driver, you can use a single authoritative user for both drivers.

Record account information in the table under “Collecting Configuration 
Information” on page 107. This information will be required later during 
driver parameter configuration.

Exchange Organization

Exchange Site Name

Authoritative User and Password

(See “Creating an Authoritative 
User” on page 108.)

IP Address and Port Number for 
the Remote Loader

(See “Installing and Configuring 
the Remote Loader and Driver” on 
page 109.)

Driver Object Password

(See “Installing and Configuring 
the Remote Loader and Driver” on 
page 109.)

Remote Loader Password

(See “Installing and Configuring 
the Remote Loader and Driver” on 
page 109.)

System Value
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Creating Distribution Lists
The Exchange 5.5 driver has an e-mail distribution list (DL) for managers and 
for employees. 

Create an Employees DL and a Managers DL. Name these DLs Employees 
and Managers so that they will match the names of the group objects created 
in the Workforce Tree. 

Installing and Configuring the Remote Loader and Driver
If you are running another DirXML Remote Loader service on this computer, 
such as the Remote Loader for the NT Domain driver, stop that service before 
starting this procedure. Restart the service after completing this Remote 
Loader installation.

1 Insert the Novell Nsure Resources CD and click Next at the Welcome 
page. 

2 At the License page, click I Accept.

3 At the Components dialog box, select DirXML Remote Loader Service, 
then click Next.

4 Accept the default installation path for the Remote Loader, then click 
Next.

5 Mark the and the following items, then click Next.

DirXML Remote Loader Service

DirXML Driver for Exchange 5.5

6 Review the Product Summary, then click Finish to install the Remote 
Loader files.

7 When prompted, create a shortcut.

8 Run the DirXML Remote Loader Configuration Wizard from your 
desktop.

9 At the Welcome page, click Next.

10 Keep the default Command Port number, then click Next. 

11 Keep the default Configuration File Name, then click Next.

12 In the DirXML Driver dialog box, mark Native, then click Next.

The driver should show up in edit field: 
c:\Novell\Remoteloader\Exchange55Shim.dll
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13 In the Connection to DirXML dialog box, leave the default Port settings, 
ensure that Use SSL is unchecked.

14 Record the port number in the table under “Collecting Configuration 
Information” on page 107, then click Next. This information will be 
required during driver parameter configuration.

15 Set Trace Level to 3, so that you’ll get minimal tracking data for 
troubleshooting, specify a location and filename for the trace file, then 
click Next.
NOTE: If you are running multiple Remote Loader sessions on a single computer, 
you should create separate trace files.

16 Mark Install the Remote Loader Instance as a Service and click Next.

17 Set Remote Loader and Driver Object passwords. 

We recommend keeping remote passwords and driver passwords the 
same across systems and changing them later when you go to production. 
Record the passwords in the table under “Collecting Configuration 
Information” on page 107. This information will be required later during 
driver parameter configuration.

18 Review the summary, then click Finish.

19 When prompted, start the service.

The Exchange 5.5 system is prepared to provision resources to 
employees. Complete preparation of other participating systems and then 
proceed to Chapter 5, “Configuring DirXML Drivers,” on page 131.

Setting Up NT Domain
While you set up the NT system, have your NT Administrator work with you.
NOTE: Details about driver architecture and driver/application relationships are 
discussed in the driver implementation guides. You can reference driver implementation 
guides on the Novell Documentation Web Site (http://www.novell.com/documentation/
lg/dirxmldrivers/index.html).

To prepare a lab workstation to provision NT Domain users, complete the 
following sections:

“Prerequisites” on page 111

“Collecting Configuration Information” on page 111

“Creating an Authoritative User” on page 112

“Granting Rights to the Driver” on page 112

“Installing and Configuring the Remote Loader and Driver” on page 113
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Prerequisites
The computer where you will install Remote Loader and the driver must be 
running the following software:

Windows NT 4 with Service Pack 5 or Service Pack 6

Collecting Configuration Information
You’ll need to provide a number of system-specific details when you install 
and configure Novell Nsure Resources for NT Domain. Some of these details 
can be collected before you complete the following procedures, others will be 
defined during the process. 

Print and complete the Import Driver Form for NT Domain (http://
www.novell.com/documentation/lg/eprov10/configs/nt.html), which mirrors 
the actual form you will fill out in iManager, or print the following table and 
record information there.

System Value

Domain Server

Domain Name 

NOTE: If you are also 
synchronizing Exchange 5.5 data, 
the domains must be the same.

Authoritative User 

(See “Creating an Authoritative 
User” on page 112.)

Password

(See “Creating an Authoritative 
User” on page 112.)

IP Address and Port Number the 
for Remote Loader (Remote Host 
Name and Port)

(See “Installing and Configuring 
the Remote Loader and Driver” on 
page 113.)
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Creating an Authoritative User
The driver needs Read/Write rights to the domain. You can configure the 
driver to use any existing account with the appropriate rights, or to ease future 
management, you can create a new account to be used exclusively by the 
driver. If you are also using the Exchange 5.5 driver, you can use a single 
authoritative user for both drivers.

Granting Rights to the Driver
You need to grant rights to the driver so that it can access the SAM keys in the 
registry of the server that has the domain you want to use.

Creating an Administrator equivalent gives the driver rights to read and write 
to the domain, but, by default, even the Administrator cannot access the 
registry until you explicitly assign that access.

1 Log in to NT as Administrator. 

2 Run regedt32.

3 Select the HKEY_LOCAL_MACHINE window. 

4 Select the SAM key, then go to the Security menu and select Permissions. 

5 Check the Replace Permission on Existing Subkeys check box. 

6 Give Full Control permission to Administrators, then click OK. 

7 Click Yes to replace the permission on all existing subkeys within SAM.

Driver Object Password

(See “Installing and Configuring 
the Remote Loader and Driver” on 
page 113.)

Remote Loader Password

(See “Installing and Configuring 
the Remote Loader and Driver” on 
page 113.)

System Value
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8 Close the registry.

Installing and Configuring the Remote Loader and Driver
If you are running another DirXML Remote Loader service on this computer, 
such as the Remote Loader for the Exchange driver, stop that service before 
starting this procedure. Restart the service after completing this Remote 
Loader installation.

1 Insert the Novell Nsure Resources CD and click Next at the Welcome 
screen. 

2 At the License page, click I Accept.

3 At the Components dialog box, select DirXML Remote Loader Service, 
then click Next.

4 Accept the default installation path for the Remote Loader, then click 
Next.

5 Mark the following items, then click Next.

DirXML Remote Loader Service

DirXML Driver for NT Domain

6 Review the Product Summary, then click Finish to install Remote Loader 
files.

7 When prompted, create a shortcut.

8 Run the DirXML Remote Loader Configuration Wizard from your 
desktop.

9 At the Welcome page, click Next.

10 Keep the default Command Port number, then click Next. 

11 Keep the default Configuration File Name, then click Next.

12 In the DirXML Driver dialog box, mark Native, browse to the NT 
Domain driver, c:\Novell\Remoteloader\NTDomainShim.dll, then click 
Next.

13 In the Connection to DirXML dialog box, leave the default Port settings, 
and ensure that Use SSL is unchecked.
Preparing the Lab for Novell Nsure Resources 113

Deployment Guide
103-000279-001
February 4, 2003

Novell Confidential



Manual December 9, 200289
114   Deployment Guide

14 Record the port number in the table under “Collecting Configuration 
Information” on page 111, then click Next. This information will be 
required later during driver parameter configuration.

15 Set Trace Level to 3, so that you’ll get minimal tracking data for 
troubleshooting, specify a location and filename for the trace file, then 
click Next.
NOTE: If you are running multiple Remote Loader sessions on a single computer, 
you should create separate trace files.

16 Mark Install the Remote Loader Instance as a Service, then click Next.

17 Set Remote Loader and Driver Object passwords. 

We recommend keeping remote passwords and driver passwords the 
same across systems and change it later when you go to production. 
Record the passwords in the table under “Collecting Configuration 
Information” on page 111. This information will be required later during 
driver parameter configuration.

18 Review the summary, then click Finish.

19 When prompted, start the service.

The NT system is prepared to provision resources to employees. 
Complete preparation of other participating systems and then proceed to 
Chapter 5, “Configuring DirXML Drivers,” on page 131.

Setting Up Active Directory
While you set up the Active Directory system, have your Active Directory 
Administrator work with you.
NOTE: Details about driver architecture and driver/application relationships are 
discussed in the driver implementation guides. You can find driver implementation 
guides on the Novell Documentation Web Site (http://www.novell.com/documentation/
lg/dirxmldrivers/index.html).

To prepare a lab workstation to provision Active Directory users, complete the 
following sections:

“Prerequisites” on page 115

“Collecting Configuration Information” on page 115

“Creating an Admin User” on page 116

“Installing and Configuring the Remote Loader and Driver” on page 118
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Prerequisites
The computer where you will install Remote Loader and the driver must be 
running the following software:

Windows 2000 Server or Windows 2000 Professional (Support Pack 1)

The server must be a member of the Active Directory tree

Internet Explorer 5.5 or greater

Collecting Configuration Information 
You’ll need to provide a number of system-specific details when you install 
and configure Novell Nsure Resources for Active Directory. Some of these 
details can be collected before you complete the following procedures, and 
others will be defined during the process. 

Print and complete the Import Driver Form for Active Directory (http://
www.novell.com/documentation/lg/eprov10/configs/ad.html), which mirrors 
the actual form you will fill out in iManager, or print the following table and 
record information there.

System Value

Authentication ID

Password

The IP Address for the Domain 
Controller

Domain Name

Domain DNS Name 

IP Address and Port Number for 
the Remote Loader (Remote Host 
Name and Port)

(See “Installing and Configuring 
the Remote Loader and Driver” on 
page 118.)
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Creating an Admin User
Create a user with Admin privileges to be exclusively used by the driver to 
authenticate into Active Directory. Doing this keeps DirXML Admin account 
isolated from changes to other Admin accounts.

1 Click Start > Programs > Administrative Tools > Active Directory Users 
and Computers.

2 From Active Directory Users and Computers, select the container where 
you want to add the user and then click Create a New User.

3 Enter the Fullname, which is the AD object name, and enter the User 
logon name, which is the AD authentication name. 

Authentication Server (if the driver 
is not installed on PDC)

Driver Object Password

(See “Installing and Configuring 
the Remote Loader and Driver” on 
page 118.)

Remote Loader Password

(See “Installing and Configuring 
the Remote Loader and Driver” on 
page 118.)

System Value
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Figure 21 Creating an Active Directory User for the Driver

Record the logon name plus the domain in the table under “Collecting 
Configuration Information” on page 115. For example, record 
novelldirxml@mercury.com. This information will be required later 
during driver parameter configuration.

4 Click Next, then set the password for the new user. Mark Password Never 
Expires so that a password policy won’t disable the driver unexpectedly.

Record the password in the table under “Collecting Configuration 
Information” on page 115. This information will be required later during 
driver parameter configuration.

5 Click Next, then review the summary, then click Finish.

6 In the Tree view, select Builtin > Administrator’s properties > Members 
> Add.

7 Select the full name of the user you created > Add > OK > OK.

8 Close the Active Directory Users and Computers window.
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9 In the Administrative Tools window, select Domain Controller Security 
Policy.

10 In Tree View, expand Security Settings > Local Policies > User Rights 
Assignment.

11 Select Log On As a Service > Security > Add > Browse.

12 Select the user you created > Add > OK > OK > OK.

13 Close the Domain Controller Security Policy.

14 Reboot the system.

15 Continue with the next section, “Installing and Configuring the Remote 
Loader and Driver” on page 118.

Installing and Configuring the Remote Loader and Driver
If you are running another DirXML Remote Loader service on this computer, 
such as the Remote Loader for the Exchange driver, stop that service before 
starting this procedure. Restart the service after completing this Remote 
Loader installation.

1 Insert the Novell Nsure Resources CD and click Next at the Welcome 
screen.

2 At the License page, click I Accept.

3 At the Components dialog box, select DirXML Remote Loader Service, 
then click Next.

4 Accept the default installation path for the Remote Loader and click Next.

5 Mark the following items, then click Next.

DirXML Remote Loader Service

DirXML Driver for Active Directory

6 Review the Product Summary, then click Finish to install Remote Loader 
files.

7 When prompted, create a shortcut.

8 Run the DirXML Remote Loader Configuration Wizard from your 
desktop.
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9 At the Welcome page, click Next.

10 Keep the default Command Port number, then click Next. 

11 Keep the default Configuration File Name, then click Next.

12 In the DirXML Driver dialog box, mark Native, then click Next.

13 In the Connection to DirXML dialog box, leave the default Port settings, 
and ensure that Use SSL is unchecked.

14 Record the port number in the table under “Collecting Configuration 
Information” on page 115, then click Next. This information will be 
required later during driver parameter configuration.

15 Set Trace Level to 3, so that you’ll get minimal tracking data for 
troubleshooting, specify a location and filename for the trace file, then 
click Next.
NOTE: If you are running multiple Remote Loader sessions on a single computer, 
you should create separate trace files.

16 Mark Install the Remote Loader Instance as a Service, then click Next.

17 Set Remote Loader and Driver Object passwords. 

We recommend keeping remote passwords and driver passwords the 
same across systems and change it later when you go to production. 
Record the passwords in the table under “Collecting Configuration 
Information” on page 115. This information will be required later during 
driver parameter configuration.

18 Review the summary, then click Finish.

19 When prompted, start the service.

The Active Directory system is prepared to provision resources to 
employees. Complete preparation of other participating systems and then 
proceed to Chapter 5, “Configuring DirXML Drivers,” on page 131.

Setting Up Active Directory and Exchange 2000
To prepare a lab workstation to provision Active Directory users, complete the 
following sections:

“Prerequisites” on page 120
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“Collecting Configuration Information” on page 120

“Creating an Admin User” on page 122

“Installing and Configuring the Remote Loader and Driver” on page 124
NOTE: Details about driver architecture and driver/application relationships are 
discussed in the driver implementation guides. You can find driver implementation 
guides on the Novell Documentation Web Site (http://www.novell.com/documentation/
lg/dirxmldrivers/index.html).

Prerequisites
The computer where you will install Remote Loader and the driver must be 
running the following software: 

Windows 2000 Server or Windows 2000 Professional (Support Pack 1)

The server must be a member of the Active Directory tree

Internet Explorer 5.5 or greater

Exchange 2000 must be installed within the Active Directory tree

Collecting Configuration Information
You’ll need to provide a number of system-specific details when you install 
and configure Novell Nsure Resources for Active Directory and Exchange 
2000. Some of these details can be collected before you complete the 
following procedures, and others will be defined during the process. 

Print and complete the Import Driver Form for Active Directory and 
Exchange 2000 (http://www.novell.com/documentation/lg/eprov10/configs/
adex2k.html), which mirrors the actual form you will fill out in iManager, or 
print the following table and record information there.

System Value

Authentication ID and Password

IP Address for Domain Controller 
(Authentication Server)

Domain Name

Domain DNS Name
Deployment Guide
103-000279-001
February 4, 2003

Novell Confidential

http://www.novell.com/documentation/lg/dirxmldrivers/index.html
http://www.novell.com/documentation/lg/eprov10/configs/adex2k.html
http://www.novell.com/documentation/lg/eprov10/configs/adex2k.html


Manual December 9, 200289
IP Address and Port Number for 
the Remote Loader

(See “Installing and Configuring 
the Remote Loader and Driver” on 
page 124.)

Default Exchange Server

(See “Collecting Default 
Exchange Information” on page 
123.)

Default Legacy Exchange DN

(See “Collecting Default 
Exchange Information” on page 
123.)

Default Exchange MTA

(See “Collecting Default 
Exchange Information” on page 
123.)

Default Exchange MDB

(See “Collecting Default 
Exchange Information” on page 
123.)

Driver Object Password

(See “Installing and Configuring 
the Remote Loader and Driver” on 
page 124.)

Remote Loader Password

(See “Installing and Configuring 
the Remote Loader and Driver” on 
page 124.)

System Value
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Creating an Admin User
Create a user with Admin privileges to be exclusively used by the driver to 
authenticate into Active Directory. Doing this keeps DirXML Admin account 
isolated from changes to other Admin accounts.

1 Click Start > Programs > Administrative Tools > Active Directory Users 
and Computers.

2 From Active Directory Users and Computers, select the container where 
you want to add the user, then click Create a New User.

3 Enter the Fullname, which is the AD object name, and enter the User 
logon name, which is the AD authentication name. 

Figure 22 Creating an Active Directory User for the Driver

Record the logon name plus the domain in the table under “Collecting 
Configuration Information” on page 120. For example, record 
novelldirxml@mercury.com. This information will be required later 
during driver parameter configuration.

4 Click Next, then set the password for the new user. Mark Password Never 
Expires so that a password policy won’t disable the driver unexpectedly.
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Record the password in the table under “Collecting Configuration 
Information” on page 120. This information will be required later during 
driver parameter configuration.

5 Click Next, review the summary, then click Finish.

6 In the Tree view, select Builtin > Administrator’s properties > Members 
> Add.

7 Select the full name of the user you created > Add > OK > OK.

8 Close the Active Directory Users and Computers window.

9 In the Administrative Tools window, select Domain Controller Security 
Policy.

10 In Tree View, expand Security Settings > Local Policies > User Rights 
Assignment.

11 Select Log On As a Service > Security > Add > Browse.

12 Select the user you created > Add > OK > OK > OK.

13 Close the Domain Controller Security Policy.

14 Reboot the system.

15 Continue with the following section, “Collecting Default Exchange 
Information” on page 123.

Collecting Default Exchange Information
You will be prompted for Exchange information during driver parameter 
configuration. To gather this information:

1 Click Create a New User to serve as a template for the Exchange 2000 
Discovery Utility.

1a Enter a Full Name, such as Exchange Template, and a User Logon 
Name, such as Exchange Template.

1b Keep the defaults, including Create an Exchange Mailbox, and work 
through to Finish.

2 Run the discovery utility from the Novell Nsure Resources CD. The file 
is at 
\UTILITIES\EX2K_DISC\ EX2KDISCOVERYTOOL.EXE 
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3 Change the Administrator LDAP Name to the LDAP name of the user 
you just created. 

4 Enter the new user’s password and the Exchange server’s IP address, then 
click Discover.

5 Copy the following values from the discovery utility to a text file for later 
use during driver parameter configuration.

Default Exchange Server

Default Legacy Exchange DN

Default Exchange MTA

Default Exchange MDB

6 Continue with the next section, “Installing and Configuring the Remote 
Loader and Driver” on page 124.

Installing and Configuring the Remote Loader and Driver
If you are running another DirXML Remote Loader service on this computer, 
such as the Remote Loader for the Exchange driver, stop that service before 
starting this procedure. Restart the service after completing this Remote 
Loader installation.

1 Insert the Novell Nsure Resources CD and click Next at the Welcome 
page. 

2 At the License page, click I Accept.

3 At the Components dialog box, select DirXML Remote Loader Service, 
then click Next.

4 Accept the default installation path for the Remote Loader, then click 
Next.

5 Mark the following items, then click Next.

DirXML Remote Loader Service 

DirXML Driver for Active Directory with Exchange 2000

6 Review the Product Summary, then click Finish to install Remote Loader 
files.

7 When prompted, create a shortcut.
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8 Run the DirXML Remote Loader Configuration Wizard from your 
desktop.

9 At the Welcome page, click Next.

10 Keep the default Command Port number, then click Next. 

11 Keep the default Configuration File Name, then click Next.

12 In the DirXML Driver dialog, mark Native, then click Next.

13 In the Connection to DirXML dialog, leave the default Port settings, 
ensure that Use SSL is unchecked.

14 Record the port number in the table under “Collecting Configuration 
Information” on page 120, then click Next. This information will be 
required later during driver configuration.

15 Set Trace Level to 3, so that you’ll get minimal tracking data for 
troubleshooting, specify a location and filename for trace file, then click 
Next.
NOTE: If you are running multiple Remote Loader sessions on a single computer, 
you should create separate trace files.

16 Mark Install the Remote Loader Instance as a Service, then click Next.

17 Set Remote Loader and Driver Object passwords. 

We recommend keeping remote passwords and driver passwords the 
same across systems and change it later when you go to production. 
Record the passwords in the table under “Collecting Configuration 
Information” on page 120. This information will be required later during 
driver parameter configuration.

18 Review the summary, then click Finish.

19 When prompted, start the service.

The Active Directory/Exchange 2000 system is prepared to provision 
resources to employees. Complete preparation of other participating 
systems and then proceed to Chapter 5, “Configuring DirXML Drivers,” 
on page 131.
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Setting Up eDirectory
The eDirectory system differs from the other systems installed in the lab in 
that it requires a DirXML driver on both the Workforce Tree that holds the 
Nsure Resources repository and on the corporate tree that holds your corporate 
hierarchy. In effect, you must install DirXML on both trees. The DirXML 
installation on the Workforce Tree was covered in “Setting up DirXML on a 
Windows NT/2000 Server” on page 36. This section covers the DirXML 
installation for the corporate tree.

To prepare the corporate eDirectory tree for provisioning, complete the 
following sections:

“Prerequisites” on page 126

“Configuring Secure Data Transfers for the DirXML Driver for 
eDirectory” on page 133

“Installing DirXML and the DirXML eDirectory Driver” on page 127

Prerequisites
This section covers a lab implementation using eDirectory running on 
Windows. The information for setting up the DirXML driver for eDirectory 
on other platforms is available on the DirXML Drivers Documentation Web 
site (http://www.novell.com/documentation/lg/dirxmldrivers/index.html).

The server where eDirectory is installed should have the following software 
installed:

Windows NT/2000 Service Pack 2 or greater

eDirectory 8.6.2 or higher

Collecting Configuration Information
You’ll need to provide system-specific details when you install and configure 
Novell Nsure Resources for eDirectory. 

Print and complete the Import Driver Form for eDirectory (http://
www.novell.com/documentation/lg/eprov10/configs/ps36.html), which 
mirrors the actual form you will fill out in iManager, or gather and record the 
following information for later use.
126   Deployment Guide

Deployment Guide
103-000279-001
February 4, 2003

Novell Confidential

http://www.novell.com/documentation/lg/dirxmldrivers/index.html
http://www.novell.com/documentation/lg/dirxmldrivers/index.html
http://www.novell.com/documentation/lg/eprov10/configs/ps36.html


Manual December 9, 200289
Account Tree Address and Port

Installing DirXML and the DirXML eDirectory Driver
1 At the server hosting your account tree, insert the Novell Nsure Resources 

CD. 

2 At the Welcome page, click Next.

3 Read the License Agreement, then click I Accept.

4 Select DirXML Engine and Drivers, then click Next.

5 Mark the following items, then click Next.

DirXML Engine

DirXML Driver for eDirectory

6 In the Schema Extension dialog box, enter the following information and 
click Next.

Tree Name: This is populated with the tree name you specified 
during the eDirectory installation. 

Fully Distinguished User Name: Browse to and select an Admin 
equivalent user. 

User Password: Enter the Admin password.

7 Review the Summary screen, click Finish, then click Close.

Configuring the Driver
Use the Create Driver task in iManager to configure the driver. Because this 
is the first time you will have authenticated to the eDirectory account tree 
through iManager, you’ll also have to configure iManager roles and tasks.

To configure the driver:

1 Launch iManager on the computer where you installed the driver. Enter

http://Web_Server_IP_Address/eMFrame/

2 At the authentication screen, connect to the eDirectory account tree.

IMPORTANT: Use the IP address for the tree name.
Preparing the Lab for Novell Nsure Resources 127

Deployment Guide
103-000279-001
February 4, 2003

Novell Confidential



Manual December 9, 200289
3 At the Collection Information page, select a container at a level below 
which you want users to be able to use eGuide self provisioning, then 
click Next.

4 Select the modules in the Modules to be Installed list.

5 Specify the account tree as the Scope.

6 Ensure that Inheritable is marked.

7 Click Start to install and update iManager files.

This installation may take a few minutes.

8 When the update is finished, click Close.

9 Click DirXML Management > Create Driver.

10 Mark In a New Driver Set, then click Next.

11 Provide a name, context, and server for the driver set. Leave Create a New 
Partition on the Driver Set marked, then click Next.

12 Mark Import a Preconfigured Driver for the Server, select EP-EDir-
Account.xml, then click Next.

13 Provide driver configuration information at the prompts, then click Next. 
You’ll be prompted for following information:

Driver name

Workforce Tree address and port

Container where new users will be created

14 Click Define Security Equivalence, add Admin, then click OK.

15 Click Exclude Administrative Roles, add Admin, click OK, then click 
Next.

16 Review the driver summary, then click Finish.

17 Complete preparation of other participating systems and then proceed to 
Chapter 5, “Configuring DirXML Drivers,” on page 131.
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5 Configuring DirXML Drivers

After the systems hosting DirXML® drivers have been set up for Remote 
Loader service, you will configure the drivers. Drivers are configured using 
Novell® iManager.

To configure the drivers and test your configuration, complete the following 
sections: 

“Importing the Preconfigured Drivers” on page 131

“Configuring Secure Data Transfers for the DirXML Driver for 
eDirectory” on page 133

“Testing the Novell Nsure Resources Process” on page 135

Importing the Preconfigured Drivers 
Using application information that you provide, the Import Drivers Wizard 
completes configuration for the DirXML drivers. 

You’ll need the data you collected and recorded in the Configuration 
Information tables at the beginning of each system’s setup.

1 Launch iManager from your Web browser. Enter

http://Web_Server_IP_Address/eMFrame/

2 Authenticate to the Workforce Tree.

3 Select DirXML Management > Import Drivers.

4 Mark In an Existing Driver Set, browse to 
Nsure Resources.Services.YourOrganization, then click Next.
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5 Browse to the server object in the Services OU, then click Next.

6 Select the appropriate driver configuration files for your installation.

Select one HR driver, one messaging driver, and one or more account 
drivers; don’t select any other files.

7 Click Next, then fill in the prompts for application information using the 
data you gathered and recorded in Configuration Information tables.

You will be presented with a page of information prompts for each driver 
you selected. 

8 Click Define Security Equivalence, add Admin, then click OK.

9 Click Exclude Administrative Roles, add Admin, click OK, then click 
Next.

10 After providing all required information, click Finish with Overview.
NOTE: If you quit before configuring all of the drivers, none of the drivers will be 
added to the driver set.

11 If you are running Exchange 5.5 without NT Domain, remove the 
preferredName required attribute from the Exchange 5.5 Subscriber 
Creation rule.

11a From the DirXML Overview page, click the icon for the Exchange 
5.5 driver.

11b At the DirXML Driver Overview page, click the icon for the 
Subscriber Creation Rule.

11c Click the Edit XML link at the top of the page.

11d Delete the following line, click Apply, then click OK.

<required-attr attr-name="preferredName"/>

12 If you are sharing data with a Novell eDirectoryTM account tree, continue 
with “Configuring Secure Data Transfers for the DirXML Driver for 
eDirectory” on page 133. 

If not, setup of Nsure Resource is complete. Continue with “Testing the 
Novell Nsure Resources Process” on page 135.
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Configuring DirXML Drivers 133

Configuring Secure Data Transfers for the DirXML 
Driver for eDirectory

Complete this section only if you are provisioning an eDirectory account tree. 
The DirXML driver for eDirectory requires Novell Certificate ServerTM and a 
Certificate Authority (CA) to ensure data security. All transactions between 
trees must be secured through SSL technology. 

If the Workforce Tree is running eDirectory 8.7, use the NDS2NDS Driver 
Certificate wizard to set up KMOs as explained in the following sections. If 
the Workforce Tree is running an earlier version of eDirectory 8.7, set up 
certificates as explained in Configuring Secure Data Transfers using 
ConsoleOne  (http://www.novell.com/documentation/lg/dirxmldrivers/
edirectory/data/agy16jv.html#agy16jv).

Install NICI

This procedure installs NICI 2.4.1, which is required for the Certificate 
Wizard.

1 At the Web server, insert the Web Applications CD.

2 Run INSTALLS\WIN\NICI\WCNICIU0.EXE.

3 At the Welcome page, click Next.

4 At the License Agreement page, click Yes to accept the license terms.

5 At the Setup Complete page, mark Yes I Want to Restart My Computer 
Now, then click Finish.

6 Continue with the next section.

Run the Certificate Wizard

1 Launch iManager and authenticate to your Workforce Tree.

2 Click DirXML Management > NDS2NDS Driver Certificate.

3 At the Welcome page, enter the requested information for the first tree (in 
this case, the Workforce Tree).

Default values are provided using objects in the tree that you 
authenticated to when you launched iManager. You must enter or confirm 
the following information:

Driver DN: Use the distinguished name of the eDirectory driver, 
such as
EP-EDir-Workforce.Nsure Resources.Services.YourOrganization

The tree name: Enter the IP address for the Workforce Tree.
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A username for an account with Admin privileges, such as Admin.

The password for the user. 

The user’s context, such as Services.YourOrganization

4 Click Next.

The wizard uses the information you entered to authenticate to the first 
tree, verify the driver DN, and verify that the driver is associated with a 
server.

5 Enter the requested information for the second tree (in this case, the 
Account Tree).

Enter or confirm the following information:

Driver DN: Use the distinguished name of the eDirectory driver, 
such as EP-EDir-Account.DriverSet.YourOrganization

The tree name: Enter the IP address for the Account Tree.

A username for an account with Admin privileges, such as Admin.

The password for the user. 

The user’s context, such as London.YourOrganization

6 Click Next. 

The wizard uses the information you entered to authenticate to the second 
tree, verify the driver DN, and verify that the driver is associated with a 
server.

7 Review the information on the Summary Page, then click Finish.

If KMOs already existed for these trees, the wizard deletes them and then 
does the following:

Exports the trusted root of the CA in tree one.

Creates KMO objects 

Issues a certificate signing request

Places certificate key pair names in the drivers’ Authentication ID

8 Complete preparation of other participating systems and then proceed to 
“Testing the Novell Nsure Resources Process” on page 135.
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Testing the Novell Nsure Resources Process
After participating systems are set up and their drivers have been configured, 
use the following procedures to verify that data is synchronized correctly. 

Start Each Driver
Start one driver at a time to validate proper DirXML configuration. 

1 On each system, ensure that the Remote Loader service is running and 
that you can view the trace screen for the Remote Loader.

2 Open a DSTrace screen on the computer where the Workforce Tree is 
installed.

3 In iManager, select DirXML Management > Overview.

4 Browse to the Nsure Resources driver set.

5 Click the status icon in the upper right corner of the driver’s icon, then 
click Start Driver. 

6 Review the messages in the DSTrace screen and the remote trace screen 
to verify successful driver start.

7 After all drivers are running, begin the provisioning process as described 
in the following section, “Hire a New Employee” on page 135.

Hire a New Employee
In your HR system, hire John Brown. Hire him as an employee; he will be 
promoted to manager in later testing. Verify data synchronization as follows.

Workforce Tree Object: A User object named JBROWN exists in the 
Active.Users.YourOrganization container. John is listed in the Employee 
group. 

Account Systems: An account was created for John in each of your 
account systems. Log in to the account systems as John.

Messaging Systems: An account was created for John. He was added to 
the employee distribution list. Access John’s mail account. Look at John’s 
object in the Workforce Tree and verify that the Internet Email Address is 
populated.
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Modify Employee Information
Log in to eGuide as John and change his cell phone number. Verify data 
synchronization as follows. 

Workforce Tree Object: John’s Mobile attribute reflects the change.

HR Systems: John’s new cell phone number has been updated.

Promote an Employee to Management
In the HR system, assign John to a management position. Verify data 
synchronization as follows. 

Workforce Tree Object: John’s isManager attribute is set to True. John is 
no longer part of the Employee group; he is part of the Manager group. 

Messaging Systems: John is added to the Managers distribution list. He is 
removed from the Employees distribution list.

Remove an Employee
In the HR system, terminate John’s employment. Verify data synchronization 
as follows. 

Workforce Tree Object: John’s LoginDisabled attribute is set to True. 
John is no longer part of the Employee group or the Manager group. His 
user object is moved to the Users/Inactive container. 

Account Systems: John’s account is disabled. Access is denied if login is 
attempted.

Messaging Systems: John’s account is disabled. 
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A Moving Novell Nsure Resources from 
the Lab to Production

This section focuses on implementing Novell® NsureTM Resources. It provides 
an overview of the type of activities that would normally be taken from the 
inception of a Novell Nsure Resources project to its full production 
deployment. It is intended to provide you with sufficient understanding of the 
process so that you can maximize the benefit from working with Novell Nsure 
Resources. 

We strongly recommend that a trained Novell Nsure Resources expert be 
engaged to assist in each phase of the solution deployment. For more 
information about partnership options, see the Novell Nsure Solution Partner 
Web site (http://www.novell.com/solutions/nsure/partners).

This section is not exhaustive; it is not intended to address all possible 
configurations, nor is it intended to be rigid in its execution. Each environment 
is different and will require flexibility in the type of activities to be used.

This section might be periodically updated. For the most recent version of this 
section, refer to the Novell Nsure Resources Documentation Web site (http://
www.novell.com/documentation/lg/eprov10). 

Novell Nsure Resources Deployment 
There are several activities suggested as best practices when deploying Novell 
Nsure Resources: 

“Discovery” on page 140

“Requirements and Design Analysis” on page 141
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“Proof of Concept” on page 145

“Data Validation and Preparation” on page 146

“Production Pilot” on page 146

“Production Rollout Planning” on page 146

“Production Deployment” on page 147

Discovery
You might want to begin your Novell Nsure Resources implementation with a 
discovery process that can do the following:

Identify the primary objectives in managing identity information

Define or clarify the business issues being addressed

Determine what initiatives are required to address outstanding issues

Determine what it would take to carry out one or more of these initiatives

Develop a high-level strategy or "solution roadmap" and an agreed 
execution path 

Discovery provides a common understanding of the issues and solutions for 
all stakeholders. It provides an excellent primer for the analysis phase that 
requires stakeholders to have a basic knowledge of directories, Novell 
eDirectoryTM, DirXML®, and XML integration in general. 

It can establish a base level understanding among all stakeholders

It can capture key business and systems information from stakeholders

It can enable a solution roadmap to be developed

The discovery also identifies immediate next steps, which might include the 
following:

Identifying planning activities in preparation of a requirements and 
design phase

Defining additional education for stakeholders

Key Deliverables

Structured interviews with key business and technical stakeholders

High-level summary report of the business and technical issues

Recommendations for the next steps
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An executive presentation outlining the outcome of the discovery

Requirements and Design Analysis
This analysis phase captures both technical and business aspects of the project 
in detail and produces the data model and high-level DirXML architecture 
design. This activity is a crucial first step from which the solution is 
implemented. 

The focus of the design will be specifically on identity management; however, 
many of the elements traditionally associated with a resource management 
directory, such as file and print, can also be addressed. Here is a sample of 
items that you may want to assess:

What versions of system software are being used?

Is the directory design appropriate?

Is the quality of the data in all systems appropriate? (If the data are not of 
usable quality, business policy may not be implemented as desired.)

After the requirements analysis, you can establish the scope and project plan 
for the implementation, and can determine if any prerequisite activities need 
to occur. To avoid costly mistakes, be as complete as possible in gathering 
information and documenting requirements.

The following tasks might be completed during the requirements assessment:

“Define the Business Requirements” on page 141

“Analyze Your Business Processes” on page 143

l“Design an Enterprise Data Model” on page 144

Define the Business Requirements

Gather your organization's business processes and the business requirements 
that define these business processes.

For example, a business requirement for terminating an employee might be 
that the employee's network and e-mail account access must be removed the 
same day the employee is terminated.

The following tasks can guide you in defining the business requirements:

Establish the process flows, process triggers, and data mapping 
relationships.
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For example, if something is going to happen in a certain process, what 
will happen because of that process? What other processes are triggered?

Map data flows between applications.

Identify data transformations that need to take place from one format to 
another, such as 2/25/2002 to 25 Feb 2002.

Document the data dependencies that exist.

If a certain value is changed, it is important to know if there is a 
dependency on that value. If a particular process is changed, it is 
important to know if there is a dependency on that process.

For example, selecting a "temporary" employee status value in a human 
resources system might mean that the IT department needs to create a user 
object in eDirectory with restricted rights and access to the network 
during certain hours.

List the priorities. 

Not every requirement, wish, or desire of every party can be immediately 
fulfilled. Priorities for designing and deploying the provisioning system 
will help plan a roadmap.

It might be advantageous to divide the deployment into phases that will 
enable implementation of a portion of the deployment earlier and other 
portions of the deployment later.

Define the prerequisites. 

The prerequisites required for implementing a particular phase of the 
deployment should be documented.

Identify authoritative data sources. 

Learning early on which items of information system administrators and 
managers feel belong to them can help in obtaining and keeping buy-in 
from all parties.

For example, the account administrator might want ownership over 
granting rights to specific files and directories for an employee. This can 
be accommodated by implementing local trustee assignments in the 
account system.
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Analyze Your Business Processes

The analysis of business processes often commences by interviewing essential 
individuals such as managers, administrators, and employees who actually use 
the application or system. Issues to be addressed include:

Where does the data originate? 

Where does the data go?

Who is responsible for the data?

Who has ownership for the business function to which the data belongs?

Who needs to be contacted to change the data?

What are all the implications of the data being changed?

What work practices exist for data handling (gathering and/or editing)?

What types of operations take place?

What methods are used to ensure data quality and integrity?

Where do the systems live (on what servers, in which departments)?

What processes are not suitable for automated handling?

For example, questions that might be posed to an administrator for a 
PeopleSoft system in Human Resources may include

What data are stored in the PeopleSoft database?

What appears in the various panels for an employee account?

What actions are required to be reflected across the provisioning system 
(such as add, modify, or delete)?

Which of these are required? Which are optional?

What actions need to be triggered based on actions taken in PeopleSoft?

What operations/events/actions are to be ignored?

Interviewing key people can lead to other areas of the organization that can 
provide a more clear picture of the entire process.
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Design an Enterprise Data Model

After your business processes have been defined, you can begin to design a 
data model that reflects your current business process.

The model should illustrate where data originates, where they move to, and 
where they can't move. It should also account for how critical events affect the 
data flow.

You might also wish to develop a diagram that illustrates the proposed 
business process and the advantages of implementing automated provisioning 
in that process.

The development of this model begins by answering questions such as the 
following:

What types of objects (users, groups, etc) are being moved?

Which events are of interest?

Which attributes need to be synchronized?

What data is stored throughout your business for the various types of 
objects being managed?

Is the synchronization one-way or two-way?

Which system is the authoritative source for which attributes?

It is also important to consider the interrelationships of different values 
between systems. 

For example, an employee status field in PeopleSoft might have three set 
values: employee, contractor, and intern. However, the Active Directory 
system might have only two values: permanent and temporary. In this 
situation, the relationship between the "contractor" status in PeopleSoft and 
the "permanent" and "temporary" values in Active Directory needs to be 
determined.

The focus of this work should be to understand each directory system, how 
they relate to each other, and what objects and attributes need to be 
synchronized across the systems.

Key Deliverables

Data model showing all systems, authoritative data sources, events, 
information flow and data format standards

Appropriate DirXML architecture for the solution

Detail for additional system connection requirements
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Strategies for data validation and record matching 

Directory design to support the DirXML infrastructure

Dependencies

Staff familiar with all external systems (such as HR database 
administrator, network and messaging system administrator)

Availability of system schemas and sample data

Data model from the analysis and design phase

Availability of basic information such as organizational chart, WAN and 
server infrastructure 

Proof of Concept
The outcome of this activity is to have a sample implementation in a lab 
environment that reflects your company’s business policy and data flow. It is 
based on the design of the data model developed during the requirement 
analysis and design and is a final step before the production pilot. 
NOTE: This step is often beneficial in gaining management support and funding for a 
final implementation effort.

Key Deliverables

A functioning DirXML proof of concept with all system connections 
operational

Dependencies

Hardware platform 

Necessary software 

Analysis and design phase that identifies the required connections

Availability and access to other systems for testing purposes

Data model from the analysis and design phase

Data Validation and Preparation
The data in production systems can be of varying quality and consistency and 
therefore may introduce inconsistencies when synchronizing systems. This 
phase presents an obvious point of separation between the Nsure Resources 
implementation team and the business units or groups who "own" or manage 
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the data in the systems to be integrated. At times, the associated risk and cost 
factors may not belong in a provisioning project. 

Key Deliverables

Production data sets appropriate for loading into eDirectory (as identified 
in the analysis and design activities). This includes the likely method of 
loading (either bulk load or via connectors). The requirement for data that 
are validated, or otherwise formatted is also identified.

Dependencies

Data model from analysis and design phase (proposed record matching 
and data format strategy)

Access to production data sets 

Production Pilot
The purpose of this activity is to begin the migration into a production 
environment. During this phase, there may be additional customization that 
occurs. In this limited introduction, desired outcomes of the preceding 
activities can be confirmed and agreement obtained for production rollout. 
NOTE: This phase might provide the acceptance criteria for the solution and/or the 
necessary milestone en route to full production.

Key Deliverables

Pilot solution providing live proof of concept and validation for data 
model and desired process outcomes 

Dependencies

All previous activities (analysis and design, DirXML technology 
platform).

Production Rollout Planning
This phase is where the production deployment is planned. The plan should:

Confirm server platforms, software revisions, and service packs

Confirm the general environment

Confirm introduction of eDirectory and mixed tree coexistence

Confirm partitioning and replication strategies

Confirm DirXML implementation

Plan the legacy process cutover
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Plan a rollback contingency strategy

Key Deliverables

Production rollout plan

Legacy process cutover plan

Rollback contingency plan

Dependencies

All previous activities

Production Deployment
This phase is where the pilot solution is expanded to affect all live data in the 
production environment. It typically follows agreement that the production 
pilot meets all the technical and business requirements.

Key Deliverables

Production solution ready for transition

Dependencies

All previous activities
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B Activating Novell Nsure Resources 

Novell® NsureTM Resources is based on Novell DirXML® technology. The 
following information explains how activation works for products based on 
DirXML. To activate your products you must:

Purchase DirXML licenses

Generate a Product Activation Request

Submit the Product Activation Request

Install the Product Activation Credential received from Novell

DirXML and DirXML drivers must be activated within 90 days of installation, 
otherwise they will shut down. At any time during the 90 days, or afterward, 
you can choose to activate DirXML products to a fully licensed state.

If you are installing a DirXML product on multiple trees, as would be the case 
if you use the DirXML driver for eDirectory, you must install a unique Product 
Activation Credential on each tree. You use the same license to get both 
Product Activation Credentials.
NOTE: Activating a driver does not change your current configuration or install a newer 
version of the driver shim. It simply changes the driver to an activated state.

Activation procedures are the same regardless of the DirXML products you 
purchase. The following examples describe various activation scenarios you 
might encounter: 

You purchase a DirXML bundled activation, as with the purchase of 
Novell Nsure Resources. This includes the activation of multiple drivers 
and the DirXML engine.
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You purchase an individual driver activation, as would be the case if you 
decided to use one of the DirXML drivers not included as part of Novell 
Nsure Resources, for example, the JDBC* driver. This includes the 
activation of a single driver and the DirXML engine.

You purchase a customized or third-party driver activation. This includes 
the activation of a customized or third-party driver and the DirXML 
engine.

After you complete the activation procedures, you can view your current 
DirXML activations through Novell iManager. For more information, refer to  
“Viewing Product Activations for DirXML and DirXML Drivers” on page 
153.

For more information about Activation, refer to Activation Basics (http://
www.novell.com/partners/partnerplace/epd/product_activation_basics.html) 
and Activation Troubleshooting (http://www.novell.com/partners/
partnerplace/epd/troubleshooting_activation.html).

Purchasing DirXML Licenses
To purchase DirXML licenses, see the information on How to Buy (http://
www.novell.com/products/edirectory/dirxml/howtobuy.html).

After you purchase a DirXML product license, Novell will send you a 
Customer ID via e-mail. If you do not remember or do not receive your 
Customer ID, please call the Novell Activation Center at 1-800-418-8373 in 
the U.S. In all other locations, call 1-801-861-8373. (You will be charged for 
calls made using the 801 area code.) 
NOTE: The individual who purchases the DirXML license will receive an e-mail 
containing the Customer ID. If your company uses its purchasing agent to handle this 
transaction, you might need to check with this individual to obtain your Customer ID. 

Generating a Product Activation Request
You use your Customer ID to generate a Product Activation Request in Novell 
iManager. You should create a Driver Set object before you generate a Product 
Activation Request to activate DirXML.
NOTE: You will need to generate only one Product Activation Request for each tree 
where the driver is installed.
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1 Open iManager.

2 Click DirXML Management > Activation Request Wizard. 

3 Enter the name of the driver set or browse to a driver set where you want 
the driver to be activated > click Next.

4 If the driver set is not associated with a server or is associated with 
multiple servers, select a server to associate with a driver set > click Next.

When you select the server, your customer ID and identifying information 
about the server's tree are stored in the Product Activation Request.

5 Enter your Novell Customer ID > click Next to build your Activation 
Request file.

6 Copy the Activation Request file into the text area to the clipboard > click 
Next. 

You will need to paste the contents of this file in a text area at the Novell 
Product Activator Web site.
IMPORTANT: Do not edit the content of the Product Activation Request.

7 Click the hyperlink to launch the Novell Product Activator Web site 
(http://www.novell.com/activator).

or

Click Finish to return to the main menu of iManager.
NOTE: To continue the activation process, you need to submit this Product Activation 
Request to Novell at the Novell Product Activator Web site (http://www.novell.com/
activator). For information, see “Submitting an Activation Request” on page 151.

Submitting an Activation Request
After you create a Product Activation Request, you submit it to Novell 
through the Novell Product Activator Web site (http://www.novell.com/
activator). After you submit the Product Activation Request, Novell will send 
an e-mail containing a Product Activation Credential. You use this credential 
to activate the driver.

1 Log in at the Product Product Activator Web site (http://www.novell.com/
activator).

You must have an eLogin account to access the Product Activator Web 
site. If you don’t already have an eLogin account, you can create this free 
account when you visit the Product Activator site.
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2 Click Browse to specify the path to the Product Activation Request file or 
paste the text of the Product Activation Request into the text area.

If you copied the Product Activation Request to a diskette, make sure you 
have the request available on the computer you are working on.
IMPORTANT: Do not edit the content of the Product Activation Request.

3 Click Submit.

4 Mark the product you are activating.

You need to activate each line item.

5 Click Submit.

Novell generates a Product Activation Credential based on the Product 
Activation Request you submitted and sends that credential to you via e-
mail.

Installing a Product Activation Credential 
You should install the Product Activation Credential via iManager. The 
following procedures explain how to install the Product Activation Credential.

1 Open the Novell e-mail that contains the Product Activation Credential.

2 Do one of these steps:

Save the Product Activation Credential file.

or

Open the Product Activation Credential file > copy the contents of 
the Product Activation Credential file to your clipboard.
IMPORTANT: Do not edit the contents of the Product Activation Credential 
file.

3 Open iManager.

4 Choose DirXML Management > Activation Installation Wizard.

5 Select the driver set or browse to a driver set > click Next.

6 If the driver set is not associated with a server or is associated with 
multiple servers, select a server to associate with a driver set > click Next.

7 Do one of these steps:
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Specify where you saved the DirXML Activation Credential > click 
Next.

or 

Paste the contents of the DirXML Activation Credential into the text 
area > click Next.

8 Click Finish.
NOTE: You need to activate each driver set that has a driver, but you can use the same 
Product Activation Credential to activate each driver set (in the same tree that 
corresponds to your acquired license). Make sure you install the Product Activation 
Credential on the same tree where you generated the Product Activation Request. 

Viewing Product Activations for DirXML and DirXML 
Drivers

For each of your DirXML license purchases, you can see the Product 
Activations you have installed for those licenses. To view Product 
Activations:

1 Open iManager.

2 Click eDirectory Administration > Modify Object.

3 Enter the driver set or the driver you want to view activation information 
for in the object name field.

or

Browse to the driver set or the driver you want to view activation 
information on. 

4 From the DirXML tab, select Activation.

DirXML and DirXML Driver activations display on this page. You can 
view the activation text or remove an activation from DirXML or from 
any driver. (You might want to remove an activation if it contains an 
error.)
NOTE: After installing a valid Product Activation Credential for a driver set, you 
might still see "Trial Version" next to the driver name. If this is the case, restart the 
driver and the message should then disappear.
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C Documentation Updates

This section contains information on documentation content changes that have 
been made in the Deployment Guide for Novell Nsure Resources. The 
information will help you to keep current on updates to the documentation.

The information is grouped according to the date the documentation updates 
were published. Within a dated section, the changes are alphabetically listed 
by the names of the main table of contents sections for Policy and Distribution 
Services.

The documentation is provided on the Web in two formats: HTML and PDF. 
The HTML and PDF documentation are both kept up-to-date with the 
documentation changes listed in this section.

If you need to know whether a copy of the PDF documentation you are using 
is the most recent, the PDF document contains the date it was published in the 
Legal Notices section immediately following the title page.

The documentation was updated on the following dates:

“December 5, 2002” on page 155

December 5, 2002
Updates were made to the following sections. The changes are explained 
below.

Introducing Novell Nsure Resources

Preparing the Lab for Novell Nsure Resources
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Introducing Novell Nsure Resources
The following updates were made in this section:

Preparing the Lab for Novell Nsure Resources
The following updates were made in this section:

Location Change

“A Close-Up of Each 
System” on page 18

Updated data flow diagrams to correct inaccurate attribute listings.

Location Change

“Testing Sample PeopleSoft 
Applications” on page 55

Updated this procedure with information specific to PeopleSoft 8.1x.
156   Deployment Guide

Deployment Guide
103-000279-001
February 4, 2003

Novell Confidential


	About This Guide
	1 Introducing Novell Nsure Resources
	The Novell Nsure Resources Model
	Automated Business Policies and Processes
	Sample Scenario

	A Close-Up of Each System
	SAP
	PeopleSoft
	Active Directory
	NT Domain
	eDirectory
	Active Directory with Exchange 2000
	Exchange 5.5
	Notes
	GroupWise

	Nsure Resources Tools
	Making Novell Nsure Resources Work for You

	2 Setting Up the Workforce Tree
	Setting Up eDirectory on a Windows NT/2000 Server
	System Requirements
	Prerequisites
	Installing eDirectory on Windows NT/2000

	Setting up DirXML on a Windows NT/2000 Server

	3 Setting Up Novell iManager and eGuide
	Installing iManager and eGuide Program Files
	System Requirements
	Installation

	Installing Configuration Files for DirXML Drivers
	Configuring iManager and eGuide
	Running the iManager Configuration Wizard
	Creating Novell Nsure Resources Objects
	Running the eGuide Quick Setup Wizard
	Setting up eGuide Roles in iManager


	4 Preparing the Lab for Novell Nsure Resources
	Setting Up a PeopleSoft Client for PeopleSoft 8.1
	Prerequisites
	Collecting Configuration Information
	Installing Configuration Files
	Installing the PeopleSoft External API
	Installing a Sample Project
	Configuring the Remote Loader for the Driver

	Setting Up a PeopleSoft Client for PeopleSoft 7.5
	Prerequisites
	Collecting Configuration Information
	Installing Configuration Files
	Installing the PeopleSoft Service Agent
	Running the Message Agent Test Program
	Installing the Event Server
	Configuring the Remote Loader for the Driver

	Setting Up SAP
	Prerequisites
	Collecting Configuration Information
	Configuring the SAP System
	Installing and Configuring the Remote Loader and Driver

	Setting Up Lotus Notes
	Prerequisites
	Collecting Configuration Information
	Creating Lotus Notes Accounts
	Configuring Database Replication Using NDSRep

	Setting Up GroupWise
	Prerequisites
	Collecting Configuration Information
	Configuring Driver Authentication
	Installing and Configuring the Remote Loader and Driver

	Setting Up Exchange 5.5
	Prerequisites
	Collecting Configuration Information
	Creating an Authoritative User
	Creating Distribution Lists
	Installing and Configuring the Remote Loader and Driver

	Setting Up NT Domain
	Prerequisites
	Collecting Configuration Information
	Creating an Authoritative User
	Granting Rights to the Driver
	Installing and Configuring the Remote Loader and Driver

	Setting Up Active Directory
	Prerequisites
	Collecting Configuration Information
	Creating an Admin User
	Installing and Configuring the Remote Loader and Driver

	Setting Up Active Directory and Exchange 2000
	Prerequisites
	Collecting Configuration Information
	Creating an Admin User
	Collecting Default Exchange Information
	Installing and Configuring the Remote Loader and Driver

	Setting Up eDirectory
	Prerequisites
	Collecting Configuration Information
	Installing DirXML and the DirXML eDirectory Driver
	Configuring the Driver


	5 Configuring DirXML Drivers
	Importing the Preconfigured Drivers
	Configuring Secure Data Transfers for the DirXML Driver for eDirectory
	Testing the Novell Nsure Resources Process
	Start Each Driver
	Hire a New Employee
	Modify Employee Information
	Promote an Employee to Management
	Remove an Employee


	A Moving Novell Nsure Resources from the Lab to Production
	Novell Nsure Resources Deployment
	Discovery
	Requirements and Design Analysis
	Proof of Concept
	Data Validation and Preparation
	Production Pilot
	Production Rollout Planning
	Production Deployment


	B Activating Novell Nsure Resources
	Purchasing DirXML Licenses
	Generating a Product Activation Request
	Submitting an Activation Request
	Installing a Product Activation Credential
	Viewing Product Activations for DirXML and DirXML Drivers

	C Documentation Updates
	December 5, 2002
	Introducing Novell Nsure Resources
	Preparing the Lab for Novell Nsure Resources



