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Novell JVM 1.4.0 for NetWare Overview

The Novell® Java* Virtual Machine (JVM) is the Novell Software 
Development Kit (SDK) for Java. The Graphical User Interface (GUI) lets you 
run graphical Java applications.

Novell JVM 1.4.0 for NetWare® contains the following components:

! Several NetWare Loadable ModuleTM (NLMTM) programs, which let the 
NetWare server run Java-based applications and applets that use the 
packages in the Java core API. Novell JVM for NetWare supports multi-
threaded applications and applications that use a graphical interface.

! NetWare GUI including drivers for most popular video cards.
Novell JVM 1.4.0 for NetWare Overview 5
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1 JVM Setup and Operating 
Requirements

This chapter contains information necessary for setting up Novell® JVM for 
NetWare®. This chapter includes the following topics:

! “Important Java Files” on page 7

! “Supported Video Controllers” on page 9

! “Hardware Requirements” on page 10

! “Software Requirements” on page 11

! “Frequently Asked Questions (FAQs)” on page 11

Important Java Files

Directory File Description

SYS:\JAVA\LIB rt.jar

charsets.jar

Standard Java Classes

Standard Java Classes

SYS:\JAVA\BIN\CLIENT JVM.NLM Client version of Hotspot

SYS:\JAVA\BIN\SERVER JVM.NLM Server version of Hotspot
JVM Setup and Operating Requirements 7
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SYS:\JAVA\BIN dt_skt.nom

cmm.nlm

dcpr.nlm

Support file for Sun’s JDB

Color Management Module

Support file for Java 2D graphics engine

fontmn.nlm Font manager

hprof.nlm Java heap profiler

jvmlib.nlm JVM library support module

java.nlm Novell JVM for NetWare

jdbc.nlm Java database connectivity NLM

jmcsock.nlm Java multicast socket support

jnet.nlm Java.net classes support

jpeg.nlm JPEG image support

jvmlib.nlm Multimedia support

mlib.nlm Multimedia support

nawt.nlm Native Java methods for GUI

zip.nlm Java compression library

zip_g.nlm

icelib.nlm

icewm.nlm

Java compression library, debug version

Window manager libraries for NetWare GUI

SYS:\JAVA\NWGFX\BIN conlogj.nlm Native Java methods for console log GUI 
application

conlogo.nlm OS support for console log GUI application

nterm.nlm OS support for server console GUI application

ntermj.nlm Native Java methods for server console GUI 
application

SYS:\JAVA\NWGFX\BIN nwbg.nlm Native support for JVM GUI background Utility

Directory File Description
8   Novell JVM 1.4.0 for NetWare
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Supported Video Controllers
Instead of supporting specific chipsets, Novell supports the VESA BIOS 
extensions that allow abstraction away from the hardware. JVM provides one 
physical driver that works with NetWare 6, VESA (Xvesa.nlm). This driver 
provides graphics support for VESA 1.2 and higher compliant video 
controllers. Resolution for VESA video controllers is controller dependent.

NetWare 6 has XFree86 Xvesa as the default Xserver. XFree86 supports 
VESA 1.2 through 3.0. NetWare also includes Xi Graphic’s Accelerated-X as 

nwbgpnt.nlm Native support for JVM GUI background Utility

startx.def Starts graphical user interface

vesa_rsp.ncf Script for setting up GUI to SVGA 256 colors

xaccel.nlm Driver for Xi Graphics, Inc. Accelerated-X server

Xvesa.nlm Driver for Super VGA 256-color cards

xlib.nlm Display mechanism for graphical user interface

xmodmap.nlm International Keyboard Support NLM

xsetup.ncf Script for starting graphical GUI setup utility

SYS:\JAVA\LIB\FONTS Fonts for displaying characters in a GUI window

SYS:\JAVA\NWGFX\lib\X11\
locale

Locale specific files such as xmodmap.* and 
keyboard mapping files

SYS:\JAVA\NWGFX\PIXMAPS *.xpm xpm format files used for background pattern

SYS:\JAVA\NWGFX\HELP Help directories for Java help files and help sets

SYS:\ETC\ java.cfg Environment configuration file

SYS:\JAVA\NWGFX\ACE\ETC Xaccel.ini Template configuration file for Xi Graphics 
Accelerated-X server

Directory File Description
JVM Setup and Operating Requirements 9
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JVM currently supports the following video controllers:

! VESA 1.x, 2.x, 3.x

640 x 480 256-colors

800 x 600 256-colors (assuming mode is supported)

1024 x 768 256-colors (assuming mode is supported)

VESA 1.x and 2.x support covers a large percentage of recently 
manufactured controllers and provides nonaccelerated support for 
additional hardware modes. 

! Over 540 specific video controllers in the following modes:

640 x 480 256-colors

800 x 600 256-colors (assuming mode is supported)

1024 x 768 256-colors (assuming mode is supported)

See “Configuring XServer Using the GUI Environment Utility” on page 
25 for instructions on accessing the video card tab in the Desktop Menu 
to view a complete list of supported controllers.

NOTE: During the install, NetWare GUI boots to SVGA 800 x 600 256-color mode.

To learn how to configure your monitor for an accelerated video driver, see “Configuring 
Your System for an Accelerated Video Driver” on page 25.

Hardware Requirements

CPU
" A CPU speed of 200 MHz and above

! Intel* Pentium* Pro

! Intel Pentium

Memory
" 128MB minimum (Refer to NetWare 6 memory requirements)
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Hard Disk Space
" 150MB minimum

Mouse
" PS/2

" USB mouse
NOTE: Some applications can function without a mouse, but it is not recommended.

Software Requirements
" NetWare 6 with support pack 2 or later loaded and running on the server.

" Novell JVM for NetWare self-extracting executable file. (See “Novell 
JVM 1.4.0 for NetWare Overview” on page 5.)

" Workstation running Windows* 95 or Windows NT* with the Novell 
Client TM 32

Frequently Asked Questions (FAQs)
This section contains some frequently asked questions. Use this section to 
answer questions and concerns you might have.

What is Novell JVM for NetWare?
Java Virtual Machine for NetWare is the Novell Software Development Kit 
for Java. 

What Novell platforms are supported in this release?
This release of Novell JVM for NetWare supports NetWare 6, and requires 
Support Pack 2 or later.

How many Java applications can be run concurrently on the server?
You can run any number of applications as long as you do not exceed the 
available memory on the server. The memory requirements of the applications 
and the amount of main memory available on the server determines how many 
applications you can run. 
JVM Setup and Operating Requirements 11
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What are the memory requirements for running Novell JVM for 
NetWare on the server?

You should have at least 32 MB of main memory available to run text-based 
Java applications—and at least 64 MB to run graphical applications.

Can I run any Java application or applet on the server?
Novell JVM for NetWare can run any application certified as 100% Pure Java, 
as described by JavaSoftTM. However, if you have applications that use native 
methods, you must port these applications to NetWare before you run them.

Can I display graphical interfaces on the server?
Yes. NetWare GUI lets you display graphical interfaces that use the Abstract 
Window Toolkit (AWT) and Java Foundation Classes (JFC) libraries from 
Sun Microsystems, Inc.

Are there limitations to using the GUI on the server?
The limitations of graphical applications in NetWare GUI are the same as the 
limitations of other Java implementations.

Do I need to buy a new video controller?
No. NetWare GUI includes drivers for popular video controllers. See 
“Supported Video Controllers” on page 9. A VESA 2.0 compliant video 
controller will give the best generic performance.

Is it difficult to configure a Novell server platform to use video 
controllers?

No. The Novell JVM for NetWare installation includes a utility 
(VESA_RSP.NCF) that automatically recognizes and configures the Novell 
server platform to use your video controller. Click the Settings option to see 
all the different configuration options.
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The GUI is self configuring the first time it is run. VESA. RSP.NCF is used 
to reset the GUI to its self configured state.

Can Java applications take advantage of multiple threads? 
Yes. Novell JVM for NetWare supports applications that use multiple Java 
threads.

Does this release of Novell JVM for NetWare include a Symantec Just 
In Time (JIT) for NetWare Compiler?

No. It uses Hotspot.

What Novell-specific services does Novell JVM for NetWare support?
The standard Java Application Programming Interfaces (APIs) support the 
Novell file system and networking. It does not support other NetWare-specific 
services such as the directory, eDirectoryTM objects, or the bindery. These 
services are supported by other libraries in the Novell Developer Kit (NDK).
JVM Setup and Operating Requirements 13
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2 Installation Guide

After you install NetWare® software, you can upgrade and start the JVM for 
NetWare. This chapter includes the following topics:

! “Installation Prerequisites” on page 15

! “Installing or Upgrading Novell JVM for NetWare” on page 15

! “Troubleshooting” on page 18

! “Supporting the Graphics Font” on page 20

Installation Prerequisites
" NetWare 6 running with support pack 2 or later

" Novell JVM for NetWare self-extracting executable file (See “Novell 
JVM 1.4.0 for NetWare Overview” on page 5)

" Client workstation running Windows 95/98 or Windows NT/2000/XP 
with Novell Client 32

" USB or PS/2-style mouse attached

Installing or Upgrading Novell JVM for NetWare
If you are doing an upgrade, you do not need to complete the first tasks. 
Instead, begin with “Installing Novell JVM for NetWare” on page 17.
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Using INETCFG to Change or Add TCP/IP
To change or add TCP/IP information after installation, you need to load the 
INETCFG utility on the server. INETCFG might prompt you for permission 
to transfer text from AUTOEXEC.NCF to other text files in the SYS:\ETC 
directory. Enter Yes if this occurs, and then use the standard setup method 
instead of the quick method.

To configure the gateway address from INETCFG, complete the following:

1 From the Internetworking Configuration menu, select Protocols > TCP/
IP.

2 Press the Down-arrow until Lan Static Routing is highlighted.

3 Select Lan Static Routing and press Enter.

4 Select Enabled and press Enter.

5 Select Lan Static Routing Table and press Enter.

6 Press Insert.

7 Select Route Type and press Enter.

8 Select Default Route and press Enter.

9 On the Next Hop Router on Route line, enter the IP address for your 
router.

10 On the Metric for this Route line, enter the number of hops to the router 
you selected.

11 Press Esc until Update Database appears.

12 Select Yes.

Configuring DNS Domain Name and the Addresses of DNS Servers
If your version of INETCFG lets you configure the DNS domain name and the 
addresses of DNS servers, the options will be under Protocols > TCP/IP > 
DNS Resolver Configuration.

If your INETCFG does not have this configuration option, from a client 
workstation, create a file called SYS:\ETC\RESOLV.CFG on the NetWare 
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domain <your.domain.com>

nameserver 001.01.01.01

Where <your.domain.com> is the fully qualified domain name of your 
NetWare server, and where the entries for the name server are the IP addresses 
for the name servers on your network. You must enter the domain and name 
server parameters. You can have more than one name server line to search 
more than one domain name server.

Installing Novell JVM for NetWare

Prerequisites

" NetWare 6 installed on the server with Support Pack 2.

" Shut down NetWare GUI if it is running (See “Shutting Down NetWare 
GUI” on page 22.)

" Shut down Novell JVM for NetWare if it is running (See “Unloading 
Novell JVM for NetWare” on page 22.)

Installation Procedure

1 Obtain the admin rights for the sys: volume of the servers by mapping a 
volume or logging in.

2 Run the Novell JVM for NetWare self-extracting executable file on the 
client. 

This expands the archive and launches the InstallShield installation script.

3 At the Welcome screen, click next.

4 To accept the license agreement, click Yes; otherwise, click No. 

Rejecting the license agreement stops the installation process.

5 At the Installation components screen, click Next.

6 At the Select Destination Servers screen, select the servers you want to 
install Novell JVM for NetWare on and click Next.

7 After reviewing the current settings profile, click Back to change the 
description of the servers. If you are satisfied with the profile, click Next.
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The installation process copies the .zip file to the destination servers and 
unzips the file on each server.

The Readme document contains last-minute information about JVM for 
NetWare that is not in the HTML documentation.

Loading Novell JVM for NetWare
When you install Novell JVM for NetWare, the NetWare GUI is automatically 
configured during the install. After the installation, you can load Novell JVM 
for NetWare and start the NetWare GUI.

! To load Novell JVM for NetWare without NetWare the GUI, at the server 
console, enter

load java

This loads Novell JVM for NetWare into memory and allows the 
command interpreter to recognize when a Java application or applet is 
launched.

! To load Novell JVM for NetWare and start the NetWare GUI, at the 
server console, enter 

startx

This first loads Novell JVM for NetWare—if it is not already loaded. It 
then starts the NetWare GUI. When the Novell button appears on the 
taskbar in the bottom left corner, the process is complete.

You can now launch Java applications and applets.

If you experience difficulties loading Novell JVM for NetWare, see 
“Troubleshooting” on page 18.

Troubleshooting
This section provides you with suggestions for resolving problems you might 
have when you load Novell JVM for NetWare.
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Java Applications Fail to Load
If Java applications have trouble running in the NetWare GUI, ensure that the 
DISPLAY variable is set to127.0.0.1:0.0 or to the IP number of the server. 
(For more information, see “Setting the DISPLAY Environment Variable” on 
page 31.)

GUI Fails to Load
If the NetWare GUI fails to load after you install Novell JVM for NetWare, 
run the following .NCF file at the server console:

vesa_rsp

This configures the NetWare GUI for SVGA 256 colors and sets the resolution 
to 800 X 600. The GUI resolution can then be changed from the NetWare GUI 
desktop menu. For more information, see “Configuring XServer Using the 
GUI Environment Utility” on page 25.

GUI Resolution is Not Working Properly
If your GUI resolution is not working, configure the NetWare GUI for SVGA 
by entering the following at the server console:

vesa_rsp

This sets the minimum resolution. The GUI resolution can then be changed 
from the NetWare GUI desktop menu. For more information, see 
“Configuring XServer Using the GUI Environment Utility” on page 25.

Mouse Does Not Respond
If the mouse that is properly attached to your server does not function in the 
NetWare GUI, it might not be configured correctly. To automatically 
reconfigure the mouse, do the following:

1 Close the NetWare GUI.

2 At the server console enter the following command:
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For instructions on starting the GUI, see “Loading Novell JVM for 
NetWare” on page 18.

This automatically reconfigures the mouse. It also resets the NetWare 
GUI to its base configuration (SVGA 256 colors and a resolution of 800 
X 600.) The GUI resolution can then be changed from the NetWare GUI 
desktop menu. For more information, see “Configuring XServer Using 
the GUI Environment Utility” on page 25.

Applications Using JAVA.NET Do Not Work Properly
If Java applications that use the JAVA.NET package have trouble resolving 
host names or IP addresses, ensure that the TCP/IP configuration includes the 
file /ETC/RESOLV.CFG, and that WINSOCK is loaded on the server.

The /ETC/RESOLV.CFG file tells the server its fully qualified domain name 
(FQDN), and it allows the server to locate name servers that can resolve names 
into IP addresses.

Another problem might be that the IP address and DNS name of the client 
machine need to be added to the /ETC/HOSTS file. The proper entry format is

<IP address> <DNS name>

Supporting the Graphics Font
The FONT.PROPERTIES file controls the Java font-to-native-font mapping 
in JAVA\LIB\FONT.PROPERTIES. The FONT.PROPERTIES file is 
platform-specific and indicates the fonts that a particular platform uses for its 
Java virtual fonts. The FONT.PROPERTIES file for JDK1.4.0 on NetWare is 
nearly identical to the Solaris implementation. For a description, see the font 
properties on the Sun Web site (http://java.sun.com/j2se/1.4/docs/guide/intl/
fontprop.html)
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3 Administration Guide

This chapter explains the administrative tasks that you can do with Novell® 
JVM 1.4.0 for NetWare®. 

JAVA.CFG
The Java configuration file (JAVA.CFG) is the first file your system reads 
when you load Java. This file is not necessary to load or run java applications 
but it will set some default environment values if the file is present. When you 
install JVM, the install procedure creates the following default environment 
settings in the java.cfg file:

JAVA_HOME=SYS:\JAVA

MGMT_HOME=SYS:\PUBLIC\MGMT

JAVA_FONTS=SYS:\JAVA\LIB\FONTS

If you want to update the SYS:\SYSTEM\AUTOEXEC.NCF file, add the 
following lines right after the mount all command in the file:

SEARCH ADD SYS:\JAVA\BIN

SEARCH ADD SYS:\JAVA\BIN\CLASSIC

SEARCH ADD SYS:\JAVA\NWGFX\bin

STARTX

HINT: The STARTX line is optional. It causes the Java GUI to begin running at server 
startup. You might want to delete any other instances of these lines in the 
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Loading and Unloading Novell JVM for NetWare

Loading Novell JVM for NetWare without NetWare GUI
To load Novell JVM for NetWare (JAVA.NLM) without running NetWare 
GUI, at the server console, enter

load java

For more information, see “Starting NetWare GUI” on page 22.

Unloading Novell JVM for NetWare
You can unload Novell JVM for NetWare (java.nlm) from memory by 
entering the following command at the server console:

unload java

NetWare GUI Tasks

Starting NetWare GUI
To start the NetWare GUI, at the server console enter

startx

This loads Novell JVM for NetWare, if not already loaded, then loads 
NetWare GUI into memory.

Shutting Down NetWare GUI
The following are three ways to shut down NetWare GUI. The first two close 
the NetWare GUI without shutting down the JVM.

! Activate the desktop menu (see “Activating the Desktop Menu” on page 
23), then click Close GUI > Yes.

! Press Ctrl+Alt+Backspace.

! To shut down the JVM as well as NetWare GUI, toggle to the server 
console (see “Toggling between NetWare GUI and the Console” on page 
23), then enter
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Toggling between NetWare GUI and the Console
! To toggle to the next screen, press Alt+Esc.

! To toggle to the NetWare screen selection list, press Ctrl+Esc.

Activating the Desktop Menu
To activate the desktop menu in NetWare GUI, click the Novell button in the 
lower lefthand corner of the screen.

Configuring the Desktop Menu

GUI Menu

The GUI menu consists of items that are either menus or commands. Menus 
contain the following:

! Default name

! International name (optional)
If you enter an international name, this name appears in the GUI menu; 
otherwise, the default name appears.

Internationalized names are stored in files with the properties extension. 
A Properties file is a text file that contains key=value entries. For 
example, PROGRAMS=programs or UTILITIES=utilities. You must 
place these files in the SYS:\java\lib\taskbar directory.

Properties File

The properties file lets you specify characters that you are not able to enter 
from the server’s keyboard. You do this by specifying the Unicode values on 
the right side of the equal sign (=). For example, you can specify the value 
RUN with any of the following values:

! RUNITEM=Run

! RUNITEM=\u0052\u0075\u006e

! RUNITEM=R\u0075\n

When you specify the Properties file, you specify the default properties file 
such as NWMenu.properties. Names are retrieved from that file according to 
the language and locale of the server. For example, if the NWMenu.properties 
file is used, the server is set to use German, and there is a 
NWMenu_de.properties file, the NWMenu_de.properties file is searched first 
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If you want to use a properties file for your names, you can use a default name 
such as MyNames.properties. If you are providing the product for an 
internationalized audience, you might want to ship properties files for each of 
the locales supported by the server.
IMPORTANT: Do not add your own name entries in the NWMenu.properties file. This 
file is overwritting when you install a newer version of the JVM.

Commands

Commands contain the following:

! Default name

! International name

! The command to execute
IMPORTANT: We recommend that you specify an .NCF file that contains actual 
commands to execute.

You configure the GUI menu by using the Menu Editor. To access this tool, 
on the GUI taskbar click Settings > Menu Editor.

Creating a Menu Item

1 Right-click on the location where you want to install the menu item.

2 Click New Command or New Menu.

3 Enter the information in the edit field.

4 Click File > Save on the menu bar.

Modifying a Menu Item

1 Click the menu item you want to change.

2 Modify the command information in the Edit panel.

3 Click File > Save on the menu bar.

Deleting a Menu Item

1 Right-click the menu item.

2 Click Remove.

3 Click File > Save on the menu bar.
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Moving Menu Items

1 Right-click the menu item.

2 Click Move Up or Move down.

3 Click File > Save on the menu bar.

If a menu is open, the selected menu item moves into that menu; 
otherwise; the menu item moves past the menu.

Configuring XServer Using the GUI Environment Utility
You use the GUI environment utility to configure Super VGA, and 
Accelerated-X Servers on NetWare. This utililty lets you select the video 
board, keyboard, mouse, and monitor from a set of predefined hardware 
devices supported by the GUI environment utility.

1 Activate the desktop menu.

See “Activating the Desktop Menu” on page 23.

2 Click Settings > GUI Environment.

See the GUI environment online help for further documentation on using this 
utility.

Configuring Your System for an Accelerated Video Driver
To achieve the best video quality when you configure your accelerated video 
driver, configure the monitor and select a refresh rate as high as possible.

1 From the desktop menu toolbar, select GUI Environment.

2 Select your video board from the Video Board List.

This activates the monitor tab. The default settings are Super VGA with 
640 x 480 resolution and monitor tab deactivated.

3 Select your monitor from the list of monitors. 

This enables all possible refresh rates for the selected monitor.

4 Select the highest available refresh rate, and then set the video board to 
the desired resolution.

5 Select Test and then click OK. 

6 After the test pattern display, click OK > Yes > Yes.
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Selecting a Background Pattern
1 Activate the desktop menu.

See “Activating the Desktop Menu” on page 23.

2 Click Tools > Backgrounds.

All files in the SYS:\JAVA\NWGFX\PIXMAPS directory display. The 
supported graphics formats are XPM, JPEG, and BMP. If you have 
background patterns (in the supported formats) that you want to use, place 
them in the SYS:\JAVA\NWGFX\PIXMAPS directory.

3 Select the desired background pattern and test it by clicking test.

4 If you want this background, click OK.

Using NetWare GUI without a Mouse
If you start NetWare GUI without a mouse driver attached to a PS/2, or USB, 
the GUI will start in mouseless mode. When the Mouse Device query screen 
appears, select No Mouse.

When the NetWare GUI system is executing in mouseless mode, use the 
keypad keys for mouse movement and button clicks.
IMPORTANT: NUMLOCK must be activated to enable keypad mouse movements.

KeypadKey Function

Arrows Move the mouse pointer.

Shift+arrows Accelerate pointer movement.

5 Behaves like the default pointer button.

0 Locks the default pointer button down (for easy dragging).

. (decimal) Unlocks the default pointer button (releases a drag).

+ (plus) Double-clicks the default pointer button.

ALT+F7 Switches to the next program.
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Keystroke Actions for Java Text Areas and Text Fields
The following table shows the keystroke actions for Java text areas and text 
fields as implemented for the Novell JVM for NetWare.

Action Text Area Text Field

Navigate out forward Ctrl+Tab Tab

Navigate out backward Ctrl+Shift+Tab Shift+Tab

Move up/down one line Up-arrow, Down-arrow

Move to prev/next char Left-arrow, Right-arrow Left, Right

Move to prev/next word Ctrl+Left-arrow, Ctrl+Right-arrow Ctrl+Left, Ctrl+Right

Move to start/end of line Home, End Home/End

Move to start/end of text area Ctrl+Home, Ctrl+End

Move up/down a page PgUp, PgDn

Select all Ctrl+A Ctrl+/

Deselect all Arrow keys Ctrl + \

Extend selection up/down Shift+Up arrow, Shift+Down 
arrow

Extend selection left/right Shift+Left-arrow, Shift+Right- 
arrow

Shift+Left, Shift+Right

Extend selection to start/end of 
line

Shift+Home, Shift+End Shift+Home, Shift+End

Extend selection to prev/next 
word

Ctrl+Shift+Left-arrow, 
Ctrl+Shift+Right-arrow

Ctrl+Shift+Left, Ctrl+Shift+Right

Extend selection to start/end of 
text area

Ctrl+Shift+Home, Ctrl+Shift+End

Extend up a page Shift+PgUp
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Applet and Application Tasks

Running an Applet
! To run the applet in the existing screen, enter

applet <html filename>

! Or, to run the applet in a new screen, enter

applet -j-ns <html filename>

Novell JVM for NetWare assigns a screen to the applet and executes the 
applet. The NetWare GUI is then loaded and the applet is displayed.

While the applet is running, you can toggle between the NetWare GUI and the 
server console. (For more information, see “Toggling between NetWare GUI 
and the Console” on page 23.)

For example, suppose an applet called MYAPP is found in SYS:\MYAPPS\. 
To run this applet, you would enter

applet SYS:\MYAPPS\MYAPP.HTML

Running an Application
! To run an application in the existing screen, enter

Copy selection Ctrl+C Ctrl+C

Cut selection Ctrl+X Ctrl+X

Paste Ctrl+V Ctrl+V

Delete next character Delete Delete

Delete previous character Backspace Backspace

Insert tab Tab

Toggle Insert/Replace mode Insert Insert

Insert line break Enter

Submit entry Enter

Action Text Area Text Field
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! To run the application in a new screen, enter

java -ns <application name>

Novell JVM for NetWare assigns a screen to the application and then executes 
the application. If the application requires a graphical interface, Novell JVM 
for NetWare loads NetWare GUI and displays the application. If the 
application requires console keyboard input, the -ns option must be used.

While the application is running, you can toggle between NetWare GUI and 
the server console. (See “Toggling between NetWare GUI and the Console” 
on page 23.)

To run multiple applications concurrently, toggle to the console and follow 
one of the above procedures for running a Java application. When the 
application is finished executing, Novell JVM for NetWare removes the 
application's window from the screen.

All GUI applications appear in the same GUI screen. The server supports only 
one attached monitor at a time.

Enabling Symmetric Multiple Processor Support
NetWare 6 allows symmetric multiple processor support—this is the default 
setting. To force the JVM instance to run on a specific processor, use the -mp 
flag. Disabling multiple processor support is equivalent to using the -mp0 flag.

! The multiple processor command line option assigns a JVM to run on a 
processor other than zero. To use this setting, enter the following at the 
server console:

java -mp <application name>

A processor is chosen for you.

! If you want to assign a JVM to a processor, the processor number should 
follow -mp. For example, to assign a JVM specifically to processor 3, 
enter the following at the server console:

java -mp3 <application name>

If your specific application heavily uses services on processor 0, such as file 
IO, processor 0 might be faster.

To assign a JVM to processor 0, enter the following at the server console:
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Getting a List of Running Java Processes
To display a list of currently running processes and their process IDs, enter the 
following at the server console:

java -show

Shutting Down a Running Java Process
1 Get a list of the running Java processes 

See “Getting a List of Running Java Processes” on page 30.

2 At the server console, enter

java -kill<process ID>

For example:

java -kill610

Replace 610 with the ID of the process to be killed.

3 To shut down all running processes, enter the following at the server 
console:

java -killall

Viewing and Setting Environment Variables

Viewing the Current Values of Environment Variables
1 Start the Novell JVM for NetWare.

See “Loading Novell JVM for NetWare without NetWare GUI” on page 
22.

2 At the server console, enter

envset

When you unload Novell JVM (JAVA.NLM) for NetWare, the process 
deletes the Environment variables that use ENVSET. You can add 
Environment variables in the SYS:\ETC\JAVA.CFG file, which is read when 
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NOTE: The file SYS:\ETC\JAVA.CFG is not required for JVM 1.4.0. However, it might 
be convenient to create it and populate it with common environment variables.

Setting the DISPLAY Environment Variable
IMPORTANT: You must understand the UNIX* XWindows environment to set up the 
DISPLAY environment variable.

1 Start Novell JVM for NetWare.

See “Loading Novell JVM for NetWare without NetWare GUI” on page 
22.

2 At the server console, enter

envset DISPLAY=<IP address>:<display>

The default value for DISPLAY is 127.0.0.1:0, which is the address of the 
loopback interface and the default value for the display and screen you 
want to use.

Using the Remote Display Feature
The Remote Variable Display feature lets you export the display of any X 
client programs on to any machine on the network running an X server. 
Because NetWare GUI is X based, all Java GUI applications and applets are 
considered X clients and are able to use the remote display feature.

Allowing Remote Access to a Server

You must configure your destination server to allow remote access. The 
following are two methods to authorize access of a remote Xclient to a local 
Xserver:

! Enter -ac at the Xserver command line.

This turns off access control and lets any other client access the server. Be 
cautious with this method. It lets anyone who can connect to your Xserver 
do tasks in your account name and run programs on your display.

! Run xhost on the local system.

You use this command to add hosts to the list of client workstations you 
allow to access your server. You also use this command to delete 
workstations from this list. For more information on determining the best 
method of allowing remote access, see your Xserver user manual.
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Displaying a Java Applet or Application on a Local Xserver

1 Start Xserver at the local system.

2 Allow the remote NetWare system to access the local Xserver.

See “Allowing Remote Access to a Server” on page 31.

3 At the local system, start RCONJ and log in to the NetWare server.

4 If Java is not loaded on the NetWare server, do the following in the 
RCONJ window:

4a Load Java.

4b Enter the following command:

envset display=[ip address of local Xserver]:0

4c Start the Java applet or application.

5 If Java is loaded on the NetWare server, enter the following in the RCONJ 
window and then start the Java applet or application.

envset display=[ip address of server]:0

6 If you want the application to always open to the GUI screen, enter the 
following at the command line of the client workstation:

envset display=[IP address of server]:0.0

All Java GUI applications will now display on the remote client 
workstation on the GUI screen. If you do not want the application to 
always open to the GUI screen, remove the “.0” from the end of the IP 
address.
NOTE: The NetWare Console screen does not automatically switch to the GUI 
screen when a GUI application is opened on the remote exports or foreign IP 
addresses.

Setting the CWD Environment Variable
You can use the Current Working Directory (CWD) variable to run an 
application in a specific directory even if it is not part of a package. The CWD 
variable is set to the root when Java is loaded; however, you can set it to any 
desired directory.

1 Start the Novell JVM for NetWare.

See “Loading Novell JVM for NetWare without NetWare GUI” on page 
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2 To set the CWD for all applications, enter the following at the server 
console:

envset CWD=<pathname>

For example:

envset CWD=SYS:\MYJAVA\MYAPP

The preferred method is to set the CWD for the current application by 
using the -env option. For example:

Java -envCWD=SYS:\MYFILES MYAPP

Setting the CLASSPATH Environment Variable
A default CLASSPATH variable is set when Java loads. If the CLASSPATH 
variable is set incorrectly, your Java applications might not run. You can 
improve the performance by reducing the size of the CLASSPATH variable. 

1 Start Novell JVM for NetWare.

See “Loading Novell JVM for NetWare without NetWare GUI” on page 
22.

2 Enter the following at the server console:

envset CLASSPATH=<current CLASSPATH value>;<path to 
append>

For example, entering envset at the server console could produce the 
following for the CLASSPATH variable:

CLASSPATH=SYS:\JAVA\LIB;SYS:
\JAVA\CLASSES

To append the path SYS:\MYCLASSES to this CLASSPATH, enter

envset CLASSPATH=SYS:\JAVA\LIB;
SYS:\JAVA\CLASSES;SYS:\MYCLASSES

Or substitute <current CLASSPATH value> with $CLASSPATH, as in 
the following:

envset CLASSPATH=$CLASSPATH;SYS:\MYCLASSES
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The CLASSPATH variable provides a default path. The directory to this path, 
SYS:\JAVA\CLASSES, is created by the install program. To use this default 
path, or any path inside the CLASSPATH variable, place your classes in the 
directory pointed to by the path.
NOTE: The default CLASSPATH variable includes “.”, which means to look in the 
current working directory for the application. It also includes the CWD specified with the 
-env option. If the CWD variable is not set correctly, the application might not run (see 
“Setting the CWD Environment Variable” on page 32.)
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4 Developer's Guide

This section contains information you might need to know for developing Java 
applications with Novell® JVM for NetWare®.

Prerequisites
" Novell JVM for NetWare started

See “Loading Novell JVM for NetWare without NetWare GUI” on page 
22.

" TCP/IP support for Java set up

See “Using INETCFG to Change or Add TCP/IP” on page 16.

Tasks
! “Using Java Native Interface (JNI) on NetWare” on page 35

! “WATCOM 11.0 Compiler Flags for Native Method NLM Programs” on 
page 39

Using Java Native Interface (JNI) on NetWare
The JAVA\BIN directory includes a file named JNI.ZIP. When you extract this 
file, it demonstrates simple native method examples for Java 1.x. This section 
is an example of how to write native methods for the Java 1.4.0 Virtual 
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Tools Required
" Java 1.4.0 for NetWare

" JDK 1.4.0 for Win32

" NetWare SDK May 2001

" Watcom 11.0 (10.6 is not supported.)

" Microsoft NMAKE (Watcom supplies one, but use it at your own risk.)

" MKS Utilities (grep, cp, rm, sed) in your PATH

Description of Files

Building a JNI Example
After you unpack the package, complete the following:

1 Configure the following parameters in Makefile:

WIN32JAVABASE - Specify where the Win32 JDK is installed.

NWJAVABASE - Specify where the NetWare JDK is installed (typically 
the mounted SYS: drive).

NLMSDKBASE - Specify where the NetWare NDK is installed.

File Description

MAKEFILE Make file for NetWare

NWNATIVE.JAVA Native method java class

NWTEST.JAVA Test class

README.TXT

NWIMPL.C Native method C implementation

NWMAIN.C CLIB NLM wrapper - main()
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nmake

The following are the file descriptions:

! MAKEFILE. Make file for NetWare

! NWNATIVE.JAVA. Native method java class

! NWTEST.JAVA. Test class

! README.TXT 

! NWIMPLE.C Native method C implementation

! NWMAIN.C CLIB NLM wrapper - main ()

3 To clean the build, enter the following at a Windows command prompt:

nmake clean

Installing a JNI Example
After you build the example and map your server volume SYS: to drive G:, 
complete the following steps install JNI:

1 Check to see if G:\JAVA\CLASSES exists as a directory. If not, enter

mkdir G:\java\classes

2 Copy the NLM to G:\JAVA\BIN by entering the following command:

copy nwnative.nlm G:\java\bin

3 Copy the classes to G:\JAVA\CLASSES, and then at the command 
prompt in Windows enter

copy *.class g:\java\classes

Running a JNI Example
If your CLASSPATH variable is correct, you can run JNI. Enter the following 
at the command prompt:

java NWTest

Unloading JNI
To unload, at the server console enter

java -exit
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JNI Notes
This section contains notes and examples that might be helpful with the JNI 
process:

1. What you can do in your main() function depends on how you build your 
NetWare Loadable ModuleTM (NLMTM) program. If you include the 
following option in your Makefile, your NLM program can use a 
synchronized startup:

Option SYNCHRONIZE

With the synchronize option, you can initialize any global information 
your NLM program might contain in the main() function as long as you 
call the following function after initialization has completed:

void SynchronizeStart();

For example:

main()

{

/* Do global initialization */

SynchronizeStart(); /*MUST BE CALLED */

ExitThread, 0); /* MUST BE CALLED*/

}

If you choose not to use a synchronized startup for your NLM program, 
you must limit your main() function to the following:

main ()

{

ExitThread (TSR_THREAD,);

}

2. If you use the Metroworks IDE, the Synchronized linker option can be 
turned on by clicking the following box:

ALT-F7 > NLM Linker > Flags > Synchronize

3. Do not use the standard malloc() or realloc() or free() calls directly. Java 
provides the following macros in sys_api.h instead:

! sysMalloc - same parameters as malloc()
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! sysRealloc - same parameters as realloc()

! sysCalloc - same parameters as calloc()

Using these macros gives you free resource tracking. This also lets the 
memory used by your NLM program use Virtual Memory in NetWare 6. 
In some instances, you might prefer memory returned from malloc, such 
as buffers used for callbacks or ECBs.

4. When you link your NLM, you might get the following errors:

! Warning! W1008: cannot open math387s.lib: No such file or 
directory

! Warning! W1008: cannot open noemu387.lib: No such file or 
directory

! Warning! W1008: cannot open emu387.lib: No such file or directory

! Warning! W1008: cannot open clib3s.lib: No such file or directory

If you find the correct libraries to correct for these warnings, you'll link in 
a bad prelude.obs and things will not work properly. If you're using C++, 
see Item 4 below. To prevent these warnings, add the following Makefile 
option:

Option NoDefaultLibs

5. If you are using C++, add the following lines to the link file:

LIBPath $(WATCOM)\lib386;$(WATCOM)\lib386\netware;

LIBFile $(WATCOM)\lib386\plbx3s.lib

Remove the $(PRELUDE) entry from the file directive.

6. If you used the word stub in the name of any of your native method 
classes, change sedscript to ensure that it doesn't corrupt your .EXP file.

WATCOM 11.0 Compiler Flags for Native Method NLM Programs
Optimized flags are

/zp=1 /ri /ei /5s /or /ot /w3 /s /zq /ez

Debug flags are

/zp=1 /ri /ei /d2 /od /3s /w1 /s /zq /ez

IMPORTANT: /ri and /ei are critical for building native method NLM programs.
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Source Level Debugging
You can debug applications running on NetWare using any JDPA compliant 
debugger or debugging IDE. The following are available debuggers:

! NetBeans (www.NetBeans.org)

! Forte (forte.sun.com)

! Novell’s Silverstream IDE

Remote and local debugging of Java Applications are available through the 
socket transport.
IMPORTANT: The socket transport name of NetWare is dt_skt. On other platforms, it 
is dt_socket.

Required VM Options
To debug applications, you need the following debug invocation options:

! -Xdebug. Enables debugging.

! -Xrunjdwp: <sub_options> Loads the JPDA reference implementation 
of JDWP. This library resides in the target VM and uses JVMDI and JNI 
to interact with it. It uses a transport and the JDWP protocol to 
communicate with a separate debugger application. The following 
section describes the specific sub_options:

Name Required Default Value Description

Help No N/A Prints a brief help message and exits 
the VM.

Transport Yes none. Must be 
dt_skt

Name of the transport to use in 
connecting to debugger application
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-Xrunjdwp Examples

-Xrunjdwp:transport=dt_skt,server=y,address=8000

Listen for a socket connection on port 8000. Suspend this VM before main 
class loads (suspend=y by default). After the debugger application connects, 
it can resume the VM.

-Xrunjd2p:transport=dt_skt,address=8000

Start the application without suspending. Then listen for a socket connection 
on port 8000. When the debugger application connects, it can suspend the 
VM.

Complete Examples

java -Xdebug 
-runjdwp:transport=dt_skt,server=y,address=8000
-Xbootclasspath/a:SYS:/myapp/foo.jar HelloWorld

Listen for a socket connection on port 8000. Suspend this VM before the main 
class loads. After the debugger application connects, it can send a JDWP 

Server No N If Y, listen for a debugger application to 
attach; otherwise attach to the 
debugger application at the specified 
address

If Y and no address is specified, 
choose a transport address to listen to 
a debugger application at and print the 
address to the standard output stream.

Address Yes, if 
server = n; 
otherwise, 
no

Transport address for the connection. 
If server=n, attempt to attach to 
debugger application at this address. If 
server=y, listen for a connection at this 
address.

Name Required Default Value Description
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Obtaining the Fully qualified Domain of the Local Host
With the NetWare JVM, the call 
java.net.InetAddress.getLocalHost().getHostName() will return the name of 
the NetWare server. To obtain the fully qualified domain (DNS) name, 
(FQDN) of the local host, use the following:

InetAddresslocalhost=InetAddress.getByName(InetAddr
ess.getLocalHost().getHostAddress() );

The object, localhost, now contains the correct FDQN and can be obtained via 
the call, localhost.getHostName.
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