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Getting Started With ZENworks for Desktops

This Getting Started guide includes information about the installing, planning, setting up, and 
testing processes that ZENworks® for Desktops (ZfD) customers will typically encounter while 
implementing this product on a test system.

Check the  ZfD documentation Web site  (http://www.novell.com/documentation/lg/zdfs/docui/
index.html) for updated or additional information. 

This guide contains these major sections:

“Installation and Setup” on page 11

“Automatic Workstation Import” on page 25

“Workstation Management” on page 31

“Application Management” on page 35

“Workstation Imaging” on page 49

“Remote Management” on page 63

“Workstation Inventory” on page 69

Appendix A, “Documentation Updates,” on page 79

What’s New in ZENworks for Desktops 3.2
ZENworks for Desktops 3.2 (ZfD 3.2) includes some new enhancements, including:  

Imaging enhancements (for more information, see Chapter 5, “Workstation Imaging,” on 
page 49).

Compression on disk – around 50% of original size

Compression over the wire – up to 20% less traffic

Advanced imaging accessible by policy

Server-based multicast

Integration with Preboot Services to enable the Preboot Execution Environment

Enhanced thin client integration

Compatibility with Windows* 2000 Terminal Server

Compatibility with Citrix* MetaFrame XP

New Policy Copy tool

Enhanced Remote Control performance

Remote Control across a slow WAN connection

Up to 90% improvement over a LAN connection
Getting Started With ZENworks for Desktops 9
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Documentation Conventions
In Novell® documentation, a greater-than symbol (>) is used to separate actions within a step and 
items in a cross-reference path.

A trademark symbol (®, TM, etc.) denotes a Novell trademark. An asterisk (*) denotes a third-party 
trademark.
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1 Installation and Setup

This section includes information about the installation of ZENworks® for Desktops (ZfD). More 
specifically, it focuses on the Typical Install option in order to provide an overall look at the ZfD 
components available for installation prior to deployment on a production system.

This section also includes important information you will need before the installation and while 
you are using the installation program, as well as information you will need in order to use most 
of the ZfD components:

“Hardware and Software Requirements” on page 11

“ZfD Installation Prerequisites” on page 16

“Pre-Selecting an Installation Option” on page 17

“Using the Typical Install Option” on page 19

“Setting Up Required Desktop Policies” on page 21

“Other Things You Can Do” on page 24

Hardware and Software Requirements
This section includes the hardware and software specifications necessary for a successful 
installation of ZfD, including:

“Overall Hardware Requirements” on page 11

“Overall Software Requirements” on page 12

Overall Hardware Requirements
For full functionality and performance, ZfD requires the following minimum amounts of 
processing power, disk space, and RAM on the servers and workstations where it will be installed:

Resource Minimum Disk 
Space

Minimum Hardware Requirement

User workstation; complete 
ZfD installation

5 MB A Pentium* (or higher) personal computer, 75 MHz, 
16 MB of RAM

User workstation with ZfD 
Preboot Services installed

0 MB A Pentium (or higher) personal computer, 75 MHz, 
16 MB of RAM; Preboot Execution Environment 
(PXE) -enabled network adapter or PXE-On-Disk 
boot diskette

User workstation with ZfD 
Remote Management 
installed

2 MB Available disk space on the drive where Windows* is 
installed
Installation and Setup 11
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IMPORTANT: ZfD is not supported on the NEC* 9800 (also known as PC98) series of personal computers.

Overall Software Requirements
The requirements table in this section lists the software that is required to be installed on the server 
where you install ZfD. In addition, this section includes the following software accessibility 
information:

“Support for ZfD in an IPX Environment” on page 13

“Obtaining NetWare Support Packs” on page 14

“Obtaining and Installing the JVM for Your NetWare Server” on page 14

“Obtaining and Installing ConsoleOne” on page 14

“Obtaining and Installing the Novell Client” on page 16

ZENworks server without 
ZENworks database installed

160 MB NetWare® 4.11, 4.2, 5.x, or 6 servers: 128 MB of 
RAM (minimum) with 7 MB free

ZENworks server with 
ZENworks database installed

220 MB 
(database will 
expand)

256 MB of RAM on NetWare 4.11, 4.2, 5.x, or 6 
servers with 40 MB free

ZENworks server with 
ZENworks Preboot Services 
installed

10 MB 128 MB of RAM with 8 MB free

Platform Minimum Software Requirement

Management 
Console

ConsoleOne® 1.3.2 (or later) included on the ZfD Companion CD shipping with 
ZENworks for Desktops — must be installed after any NetWare Support Packs 
are applied

NetWare 4.x NetWare 4.11 with NW4SP9.EXE applied (SFTIIITM or SMP not 
supported); NetWare 4.2 with NW4SP8A.EXE patch (or later) applied

JVM (Java* Virtual Machine) 1.1.7b (dated January 2001 or later) included 
on the ZfD Companion CD shipping with ZENworks for Desktops — must 
be installed after any NetWare Support Packs are applied

ORB.EXE shipping on the ZfD Companion CD — must be installed after 
any NetWare Support Packs are applied

IP Protocol Stack bound and available on the server

IMPORTANT: ZfD 3.2 Preboot Services are not supported on NetWare 4.x.

NetWare 5.0 NW5SP6.EXE (or later) patch applied

JVM 1.1.7b (dated January 2001 or later) included on the ZfD Companion 
CD shipping with ZENworks for Desktops — must be installed after any 
NetWare Support Packs are applied

IP Protocol Stack bound and available on the server

Resource Minimum Disk 
Space

Minimum Hardware Requirement
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Support for ZfD in an IPX Environment

ZfD functions correctly when the IP protocol stack is loaded or bound to the network interface card 
(NIC) on the workstation. This is possible in a pure IP or IP/IPXTM environment using the NetWare 
Core ProtocolTM (NCPTM), but not in a pure IPX environment without NCP and when the IP stack 
is not bound.

The following table lists several network protocol configurations and their support for ZfD. 

NetWare 5.1 NW51SP2A.EXE (or later) patch applied

JVM 1.1.7b (dated January 2001 or later) included on the ZfD Companion 
CD shipping with ZENworks for Desktops — must be installed after any 
NetWare Support Packs are applied

IP Protocol Stack bound and available on the server

NetWare 6

NOTE: NetWare 6 
is supported with 
ZfD 3.2 SP1 or later

Support Pack 3 (recommended)

Novell eDirectory (8.6.0 minimum, 8.7 recommended)

JVM 1.3.1 (minimum) with JAVA.NLM must be installed

IP Protocol Stack must be bound and available on the  server

Windows NT* 
server

NDS® Corporate Edition or NDS eDirectoryTM

IP Protocol Stack bound and available on the server

Windows 2000 
server

NDS eDirectory 8 or NDS eDirectory 8.5. 

IP Protocol Stack bound and available on the server

Novell ClientTM for 
Windows 95/98

Version 3.3 with the SP4 patch. The basic version of the client is available from 
the Novell Software Downloads Web site (http://download.novell.com). The SP4 
patch is available from the \CLIENT directory of the Companion CD shipping with 
ZfD 3.2 (English only version).

or

Version 3.31, which is available on the \CLIENT directory on the ZfD 3.2 
Companion CD (English, French, German version).

Check the Novell Client Documentation Web site (http://www.novell.com/
documentation) for minimum requirements.

Novell Client for 
Windows NT/2000/
XP

Version 4.83 with the SP4 patch. The basic version of the client is available from 
the Novell Software Downloads Web site (http://download.novell.com). The SP4 
patch is available from the \CLIENT directory of the Companion CD shipping with 
ZfD 3.2 (English only version).

or

Version 4.81, which is available on the \CLIENT directory of the ZfD 3.2 
Companion CD (English, French, German version).

Check the Novell Client Documentation Web site (http://www.novell.com/
documentation) for minimum requirements.

Platform Minimum Software Requirement
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IMPORTANT: ZfD will not function in an IP-to-IP gateway or in an IPX-to-IP gateway environment.

Obtaining NetWare Support Packs

If you install ZfD on a NetWare 5.x or NetWare 6 server, make sure you have installed the 
appropriate NetWare patch first. Support Pack files for NetWare are available from the Minimum 
Patch List at the Novell Support Connection® Web site (http://support.novell.com/misc/
patlst.htm).

Obtaining and Installing the JVM for Your NetWare Server

To determine the version of the NetWare JVM on your NetWare server, show the date of the 
JAVA.NLM by entering the following command at the system console:

modules java

You can also determine the version by entering the following command at the system console:

java -version

If you plan to install ZfD on a NetWare 4.x server, you should install the JVM for NetWare version 
1.1.7b available from the Companion CD that ships with ZfD. Using this version will help you 
avoid errors when loading Automatic Workstation Import. It is fully compatible with ZENworks 
for Desktops 3.2 and ZENworks for Servers 2.0 (or higher).

In some circumstances, the time to run Auto Workstation Import may take a very long time to run 
on a NetWare 5.1 server. If this is the case, you can use the JVM for NetWare version 1.2.2 from 
the Companion CD that ships with ZfD.
WARNING: If you are using ZENworks for Servers 2.0 Tiered Electronic Distribution (TED) in a mixed JVM 
environment, you must disable subscriber security. For more information, see TID 10060307 at the Novell 
Knowledgebase Web site (http://support.novell.com/cgi-bin/search/searchtid.cgi?/10060307.htm).

Obtaining and Installing ConsoleOne

We recommend that you use ConsoleOne 1.3.2 from the Companion CD that ships with ZfD. 
Using version 1.3.2 (or later) will help you avoid errors when using context-sensitive JavaHelp for 
the ZfD snap-ins. You can also obtain this version of ConsoleOne from the Novell Software 
Downloads Web site (http://download.novell.com).

Network Protocol ZfD Support

Pure IPX (no IP stack loaded or 
bound to the NIC on the 
workstation).

Automatic Workstation Import will not work

Some parts of Remote Management will not work

Policies are supported

Application Launcher is supported

IPX for NCP (IP stack for the 
Internet, host, etc.)

Fully supported

IP/IPX for NCP Fully supported

Pure IP for NCP Fully supported
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WARNING: If you have previously installed ConsoleOne on your server, check the version number. If your 
installed ConsoleOne is a newer version than the 1.3.2 version that ships on the Companion CD, do not 
attempt to install the older version over the newer version. 

From the Companion CD, you should browse to and install ConsoleOne 1.3.2 on a network server.
IMPORTANT:  ZfD snap-ins do not load properly on the NetWare server console. After installation, do not run 
ConsoleOne directly from the server console to administer ZfD snap-ins. Instead, run ConsoleOne from a 
Windows workstation with a shortcut to the network server where you installed it.

This section includes the following topics:

“Installing ConsoleOne on a NetWare Server” on page 15

“Installing ConsoleOne and ZfD on a Windows NT Server” on page 15

“Installing ConsoleOne to a Workstation Hard Drive” on page 15

Installing ConsoleOne on a NetWare Server

Use the following steps if you install ConsoleOne on a NetWare server volume:

1 Bring down Java* and any Java applications that are running on the server, including the 
server GUI. You can do this by entering the following command at the server console:

java -exit

2 Ask all users who are currently running ConsoleOne remotely through a network connection 
exit their ConsoleOne sessions.

3 At a Windows workstation, insert the Companion CD > browse to the \CONSOLEONE 
directory > run C1.EXE.

4 Follow the prompts in the installation program. When asked to specify an installation path, 
enter \\SERVER_NAME\SYS\PUBLIC\MGMT\CONSOLEONE\1.2. 

5 At the Summary screen, click Finish.

6 If you receive a prompt asking how to handle overwriting newer files, select Never Overwrite 
Newer files > click OK.

7 After the installation, an Installation Complete message appears. Click Close.

Installing ConsoleOne and ZfD on a Windows NT Server

NDS for NT servers must have a share name to install to. Normally, when NDS for NT is installed, 
if you install the admin programs, the share name is created for you. To establish a valid 
connection to a Windows NT server, map a drive to the NT SYS share and log in as Administrator.

If you have not installed the admin programs, you must create a share for the C:\NOVELL (or 
whichever drive where NDS for NT is installed) directory named SYS.

If the SYS share name does not exist, an error is displayed indicating that ConsoleOne cannot be 
found. ConsoleOne snap-ins (such as ZfD) cannot be installed under this condition.

Installing ConsoleOne to a Workstation Hard Drive

Although the ConsoleOne installation program lets you install ConsoleOne files to a local hard 
drive, and though minor performance enhancements can be achieved by doing so, such an 
installation will not include the ZfD snap-ins.

Instead of using the ConsoleOne installation program to get a local installation, we recommend the 
following:
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1 Install ConsoleOne and ZfD to the server, including all of the components you plan to use.

2 From the PUBLIC\MGMT\CONSOLEONE directory on the server, copy the 1.2 folder > 
paste it to a clean area on your local drive.

3 Create a shortcut on your desktop to the 1.2\BIN\CONSOLEONE.EXE file in your local 
installation.

Another alternative is to use snAppShotTM to create your own application object (.AOT file) for 
ConsoleOne snap-ins or to use the pre-packaged ConsoleOne Application object (created during 
ZfD installation) to distribute the ConsoleOne snap-ins to other workstations.

You can configure the pre-packaged Application object by running the C1UPDATE.EXE program 
from SYS\PUBLIC\ZENWORKS on the server where you have installed ZfD. This utility helps 
you configure the object with the path to ConsoleOne on the server (usually 
SYS\PUBLIC\MGMT\CONSOLEONE\1.2). Configuring with this path ensures that all of 
ConsoleOne and the ZfD snap-ins will be available. The program also lets you configure a path 
for local installation of ConsoleOne (usually C:\NOVELL\CONSOLEONE\1.2).

When the update is executed, it prepares the ConsoleOne Update object for association and 
distribution to a workstation or a user. For information about distributing a pre-defined .AOT 
object, see "Application Management" in Administration at the ZENworks for Desktops 3.2 
documentation Web site (http://www.novell.com/documentation).

Obtaining and Installing the Novell Client

All versions of ZfD, including ZfD 3.2, require the appropriate version of the Novell Client. Both 
the the International (English, French, German) and the English-only version of ZfD 3.2 can use 
client version 3.31 for Windows 9x workstations or version 4.81 for Windows NT/2000 
workstations or servers. You can obtain the Novell Client from the Companion CD (English, 
French, German) or download from the Novell Software Downloads Web site (http://
download.novell.com).

To install the Windows 95/98 client, run SETUP.EXE from the 
CLIENT\PRODUCTS\WIN95\IBM_language directory.

To install the Windows NT/2000 client, run SETUPNW.EXE from the 
CLIENT\PRODUCTS\I386 directory.

For more information about installing a Novell Client, particularly in a ZfD environment, see the 
Novell Client documentation Web site (http://www.novell.com/documentation).

ZfD Installation Prerequisites
Before you can install ZfD, you must perform the following tasks:

Make sure that you have made and archived a reliable backup.

Make sure that all of the recommended hardware and software requirements are met. In 
particular, make sure that the recommended version of ConsoleOne is installed on the server 
where you will install ZfD. For more information, see “Obtaining and Installing ConsoleOne” 
on page 14. 

Make sure that you have Admin or equivalent rights to all NetWare servers where you will 
install ZfD components. For installation on Windows NT/2000 servers, you should have Full 
Control permissions.
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Make sure you are authenticated to the server as an administrator equivalent if you are 
installing to an NT server. If you log in to the NT server using an IP address, your user object 
will not be authenticated to the server with the server name that is necessary for the installation 
program. It is not necessary to map a drive to the server to authenticate to it.

To authenticate to an NT server, go to Network Neighborhood > double-click the server name 
> enter your user ID (admin or equivalent) and password.

Make sure that NDS for NT servers have a share name to install to. For more information, see 
“Installing ConsoleOne and ZfD on a Windows NT Server” on page 15.

Make sure that the Java runtime environment (JRE) is not running on any Windows NT server 
you are installing to as you start the installation program.

Make sure that you have Admin or equivalent rights to extend the NDS schema.

Make sure that the workstation where you will run the installation program has NDS 
(eDirectory) authentication to the server (or to the servers) where you plan to install the 
product.

If you will be installing on a NetWare server, it will be necessary to unload JAVA.NLM (at 
the Server Console, type java -exit). Make sure you do this when Java is not being used 
by another process and the proper Java components have already been installed.

Exit any program that uses files in the SYS:PUBLIC directory on any server where you will 
be installing ZfD.

If you choose to install the Sybase* database and it is already running on the server, be sure 
to quit the database process before proceeding with the installation program.

Exit any Windows programs on the network workstation from which you will be running the 
installation program.

Set the screen resolution on the ConsoleOne administration workstation at 800 × 600. You 
will not be able to view all of the ConsoleOne information on the screen if the resolution is 
set lower than 800 × 600.

We recommend installing ZfD 3.2 from a Windows NT/2000 workstation or server.

Pre-Selecting an Installation Option
Although this section of Getting Started focuses on the Typical install option so that you can 
become acquainted with all of the features of the ZfD product, there are actually three install 
options you can choose from when installing ZfD:

“Typical Install Option” on page 17

“Product Install Option” on page 18

“Custom Install Option” on page 18
NOTE: PXE is included in the installation program by default if you choose a Typical install option. You must 
choose Imaging (PXE) if you want to install PXE in the Custom or Product install options. PXE is part of ZfD 
3.2 Preboot Services, which must be purchased separately.

Typical Install Option
The ZfD Typical install option is designed to install all ZfD components at one time on the servers 
you select. It extends the schema of the NDS tree, copies the appropriate files to the server or 
servers, and creates the new Application objects in the server’s container. 
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For administrators who know that they want to use all of the components, this can save time. In a 
test environment, for example, the need to evaluate the entire ZfD product may indicate choosing 
this option. The components that are installed in a Typical Install include:

Application Management

Automatic Workstation Import

Workstation Management

Workstation Imaging with Preboot Services

Remote Management

Workstation Inventory

Sybase Database (optional)

Product Install Option
The ZfD Product install option is designed to install selected groups of ZfD components on the 
servers you select. For administrators who know that they want to select a specific group or groups 
of components, this can save time. In a test environment, for example, the need to evaluate only 
the components relevant to your business may indicate choosing this option. The following groups 
can be individually selected when you choose the Product Install:

Workstation Management (which includes the Automatic Workstation Import, Workstation 
Inventory, and Workstation Manager components)

Remote Management

Application Management

Workstation Imaging

You can select the specific parts of the products you select for installation, including files, schema 
extensions, NDS Objects, and support for PXE (also called ZfD Preboot Services).

Custom Install Option
The ZfD Custom install option is designed to let you install any of the ZfD components 
individually (or in a grouping of your choice) on the servers you select.

For administrators who know that they want to use only certain components, this can save time 
and server space. In a test environment, for example, the need to evaluate only the ZfD component 
or components you are interested in may indicate choosing this option. The following components 
can be individually selected when you choose the Custom Install:

Application Management

Automatic Workstation Import

Remote Management

Workstation Inventory

Workstation Management

Sybase Database

Workstation Imaging

You can select the specific parts of the components you select for installation, including files, 
schema extensions, NDS Objects, and PXE support.
18   ZENworks for Desktops 3.2 Getting Started Guide



    Novell Confidential                                                                                            Manual (99a)  28 October 2003
Using the Typical Install Option
Although you may eventually choose another installation type, the Typical install option 
documented here contains information you will need to know when you install using any of the 
options in your production environment. The sections include:

“Running the Typical Installation Option” on page 19

“Preboot Services CD Installation Options” on page 21

“Determining Whether the NDS Schema Has Been Extended” on page 21

Running the Typical Installation Option
Use the steps in this section to get ZfD up and running on a NetWare or Windows NT/2000 server 
using the Typical install option:

1 Select a network workstation (or a Windows NT/2000 server) where you can later run 
ConsoleOne to administer ZfD. This is the workstation/server where you will run the ZfD 
installation program.
IMPORTANT: Make sure that this workstation/server and all other administrative workstations or servers 
are not running ConsoleOne while the ZfD installation is running.

2 At the workstation/server, insert the ZfD Program CD. 

The WINSETUP.EXE program will autorun. If it does not autorun, run it from the root of the 
CD.

At any time while the NIS setup program is running, you have the option of clicking Back to 
change your install preferences.

3 Click English > Install ZENworks to launch the NIS setup program.

A warning dialog box is displayed to let you know that this version of ZfD is English only and 
will overwrite a localized version of ZfD previously installed on your server.

3a Click Yes to continue.

4 At the Novell Product Installation dialog box, read the notes and cautions > click Next to 
display the License Agreement for the ZfD software.

5 Read the License agreement > click Accept if you agree with the terms of the license and the 
limited warranty. 

If you do not agree with the terms of the software agreement, do not install the software.

6 In the Install Prerequisites dialog box, ensure that the network server or servers to which you 
are installing meet the minimum requirements listed > click Accept when you are ready to 
proceed. 

7 In the ZENworks Install Types dialog box, select Typical > click Next.

8 In the ZENworks List of Trees dialog box, click the name of the NDS tree where you want to 
install ZfD > click Next.

If you are installing on a server where a previous version of ZfD Workstation Inventory or the 
Inventory database is installed, a ZfD3.2 Upgrade Notice is displayed. You have the choice 
of selecting Upgrade or Full Install. 

If you choose Upgrade, only ZfD 3.2 Inventory enhancements will be installed on the ZfD 3 
servers. 
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If you choose Full Install, the servers you select later will have the Sybase database and the 
policies and configurations overwritten.

8a Click the type of install you want, depending on your test environment.

9 In the ZENworks List of Servers dialog box, click the names of the servers where you want 
to install ZfD > click Next. 

10 In the Inventory Database Server Selection dialog box, select the server where you want to 
install the ZENworks Inventory database (you can also choose not to install the database at 
this time) > click Next.

If you choose to install the database, a subsequent dialog box will be displayed where you can 
choose the server volume where you want to install it. You should choose a volume other than 
SYS: to avoid filling up vital disk space on that volume. For more information, see “Setting 
Up Workstation Inventory” on page 71.

11 In the Languages dialog box, English is chosen by default. Click Next.

12 In the Automatic Workstation Import Management dialog box, select the Import (or Import/
Removal) role for at least one of the servers where you are installing ZfD > click Next.

For more information about server roles in Automatic Workstation Import, see Understanding 
Automatic Workstation Import and Removal in Automatic Workstation Import and Removal 
in Deployment.

13 In the Inventory Server Roles dialog box, select the assignment you want to give to each of 
the Inventory servers you have created > click Next. 

For more information about server roles in Workstation Inventory, see Implementing the 
Inventory Server Roles in Deployment.

14 In the ScanDir Volume dialog box, select the server volume where you want the scan data files 
to be stored. For more information, see “Setting Up Workstation Inventory” on page 71.

14a If you previously chose to install the database, you will be prompted to enter a unique site 
ID and name on the Site ID for Database dialog box. For more information, see “Setting 
Up Workstation Inventory” on page 71.

15 Click Next to continue.

16 In the Summary dialog box, review the list of the products to be installed and the disk space 
that each product will consume when installed > click Finish to begin the installation process.

17 If you have chosen to install ZfD Preboot Services, the ZfD 3.2 Preboot Services dialog box 
is displayed to remind you that you will have to insert the Preboot Services CD in the CD 
drive, or browse to the appropriate PXE files. Click OK.

18 In the Preboot Services Source Location dialog box, select the location (at the root of the CD) 
where the ZFDPXE file is located > click OK.
NOTE: If you copy the ZfD Program CD and the ZfD Preboot Services CD to a local drive, the installation 
program will not prompt for a change of CDs. For more information, see “Preboot Services CD Installation 
Options” on page 21.

The Typical install option checks to see if you have the proper rights to copy files and to extend 
the schema, then the program executes these processes for each ZfD component until all are 
installed.
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Preboot Services CD Installation Options
If you choose to install ZfD Preboot Services, the ZfD installation program requires a discrete 
subinstall of this feature. Because the Preboot Services software is available only on a separate CD, 
you have three options for installing the PXE software:

1. Copy the ZfD Program CD to a network location and use the ZfD Preboot Services CD in the 
local CD drive of the workstation you are using for the installation. You would use this 
method if you want to install PXE at different times or to different servers.

2. Use the ZfD Program CD in the CD drive of the workstation you are using for installation, 
then swap to the Preboot Services CD when the Preboot Services subinstall is called. You 
would use this method if you want to visit several sites to perform multiple installations.

3. Copy the ZfD Program CD to the hard drive of the workstation you are using for installation, 
then copy the Preboot Services CD to the \PXE subdirectory now located in the directory you 
created when you copied the ZfD Program CD. You would use this method to perform any 
number of installations on servers accessible from your site. It does not require swapping 
CDs. Be aware that by default, this installation method will install Preboot Services every 
time the installation runs. There will be no prompts or pauses.

Determining Whether the NDS Schema Has Been Extended
After you install ZfD 3.2, you can use the ConsoleOne Schema Manager tool to determine whether 
your NDS schema has been extended by the ZfD 3.2 product installation program. When the 
schema has been extended for ZfD 3.2, attributes are added to the list.

To use the Schema Manager after the ZfD 3.2 product installation:

1  From ConsoleOne, click Tools > Schema Manager.

2 Click Attributes to open the list of schema attributes.

You should see the following attributes if ZfD 3.2 is installed:

ZENLOCZfD3Installed

ZENLOCZfD3SP1Installed

ZENLOCZfD332Installed

Setting Up Required Desktop Policies
ZfD requires policy packages in the NDS tree that can hold the desktop policies that you can later 
configure and enable. Any ZfD installation option (including a Typical install) also requires that 
you create and associate one Search Policy so that it will be enabled to find the other policies you 
create.

This section includes the information you need for setting up Desktop Policies, including:

“Creating the Policy Packages” on page 22

“Setting Up the Search Policy” on page 23

“Associating the Container Package” on page 24

In a production environment (that is, a live network with actual users where you will install ZfD) 
after the ZfD test installation, you can add the policies that the individual components need to 
function correctly. For general guidelines about setting up policies, see Understanding ZfD 
Policies and Policy Packages in Planning Workstation Management in Deployment.
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Creating the Policy Packages
A policy package holds the individual Windows desktop policies that dictate the rules of use or 
configuration for users or their workstations. You should create an Organizational Unit (OU) for 
holding the policy packages. Consider the following when determining where to place this OU:

Whether you have partitions in your tree

The 256-character limit in NDS for the full distinguished name

The Search policy is used to locate the policy package

To minimize tree walking, it is best to create this policy package OU at the root of the partition 
that contains the objects with which the policy package will be associated. In doing so, the 
following benefits are realized:

Tree walking is minimized with the root of the partition and the Search policy being used

Placing the OU at the partition's root maximizes the number of characters that will be 
available for naming plural policies

To create a policy package:

1 In ConsoleOne, right-click the container where you want the container for the policy packages 
placed > click New > click Object > click Organizational Unit > click OK.

2 Give the container a short name.

Because you can have both ZfD and ZenWorks for Servers (ZfS) policies in the same tree, 
make sure you distinguish your ZfD policies container with a unique name. For example, ZfD 
Policies.

3 Right-click the policy package’s container > click New > click Policy Packages.

4 Select one of the following policy packages:

Container Package
Server Package
Service Location Package
User Package
Workstation Package

5 Click Next > give the package a short name > click Next > click Create Another Policy 
Package (unless this is the last one being created) > click Finish.

Short package name suggestions include:

Container
Server
Location
User
Workstation

6 Repeat Step 4 through Step 5 for each policy package to be created.
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Setting Up the Search Policy
The Search Policy is required for finding other policies.

To create the Search Policy:

1 In ConsoleOne, right-click the Container Package > click Properties.

2 Check the check box under the Enabled column for the Search policy.

This both selects and enables the policy.

3 Click Properties.

The Search Level tab is displayed.

4 Select the level to search up to:

[Root]: Search to the root of the tree.

Object Container: Search to the parent container.

Partition: Search to the partition root.

Selected Container: Search to the selected container.

5 If you chose Selected Container, browse to select the container.

6 To determine the searching limits in either direction, enter a number:

7 Click the Search Order tab > select the policy searching order.

Use the arrow keys, the Add button, and the Remove button as necessary to create your search 
order.

8 Click the Refresh Interval tab > select the frequency for how often the policy should be 
refreshed.

The default is hourly. If you should set both time increments to zero (0), policies will never 
be refreshed.

9 Click the Associations tab > Add.

10 Browse to select the container object for association to the Search Policy.

11 Click OK when finished.

Number Description

0 Limits the search to the selected level.

1 Limits the search to one level above the selected level.

For example, if you selected the server’s parent container, this would limit the search 
to one level above the parent level.

-1 Limits the search to one level below the selected level.

For example, if you selected [Root], -2 would limit the search up to two levels below 
[Root].
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Associating the Container Package
The Search Policy you configured and enabled will not be in effect until you associate the 
Container Package with a container object.

To associate the Container Package:

1 In ConsoleOne, right-click the Container Package > click Properties.

2 Click the Associations tab > Add.

3 Browse for the container high in the tree for associating the package > click OK.

Other Things You Can Do
For detailed information about installing and configuring specific ZfD components, see the 
following sections: 

“Setting Up Automatic Workstation Import” on page 28

“Installing Application Management” on page 38

“Preparing an Imaging Server” on page 53

“Installing the Remote Management Component” on page 65

Installing Workstation Inventory to NetWare Servers in Deployment

Installing Workstation Inventory to Windows NT/2000 Servers in Deployment

Installing Workstation Inventory in an Existing ZfD 3 Setup in Deployment
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2 Automatic Workstation Import

ZENworks® for Desktops (ZfD) Automatic Workstation Import provides simplified, hands-off 
management of users’ workstations. Workstation objects provide you with a way to push software 
and computer settings down to the client using Novell® Application LauncherTM (NAL).

Automatic Workstation Import includes Automatic Workstation Removal. However, for your test 
system, you initially do not need to set up Automatic Workstation Removal. For information on 
Automatic Workstation Removal, see Installing Automatic Workstation Import and Removal in 
Deployment.

Automatic Workstation Import must be set up before you set up Workstation Management (User 
and Workstation policy packages), Workstation Inventory, Imaging, or Remote Control.

To use Automatic Workstation Import, you must select Automatic Workstation Import and either 
the Import or Import/Removal option when you install ZfD.

You must also configure the import policy for ZfD, then associate the Server Package as part of 
setting up Automatic Workstation Import.

To get you started with a setup of Automatic Workstation Import on your test system, perform the 
steps in the following sections:

“Installing Automatic Workstation Import” on page 25

“Setting Up Policies for Automatic Workstation Import” on page 26

“Setting Up Automatic Workstation Import” on page 28

“Other Things You Can Do” on page 32

Installing Automatic Workstation Import
If you have already installed Automatic Workstation Import, such as in performing a Typical 
Install, skip to “Setting Up Policies for Automatic Workstation Import” on page 26.

Use the following steps to get Automatic Workstation Import installed on a NetWare® or NT*/
2000 server:

1 Select a workstation where you can run the ZfD installation program and later run 
ConsoleOne® to administer ZfD.
IMPORTANT: Make sure that this workstation and all other administrative workstations are not running 
ConsoleOne while the ZfD installation is running and that Java* is unloaded on all NetWare 5.x servers.

2 At the workstation, insert the ZENworks for Desktops Program CD. 

The WINSETUP.EXE program will autorun. If it does not autorun, run it from the root of the 
CD.

3 To launch the NIS setup program, click English > Install ZENworks.
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4 To display the License Agreement for the ZfD software, click Next > read the agreement > 
click Accept if you agree with the terms of the agreement. 

If you do not agree with the terms of the software agreement, do not install the software.

5 In the Install Prerequisites screen, ensure that the network server or servers to which you are 
installing meet the minimum requirements listed > click Accept when you are ready to 
proceed.

6 In the ZENworks Install Types dialog box, select Custom > click Next.

7 Deselect all options except for Automatic Workstation Import > click Next.

8 If you have already extended the schema on the current tree for ZfD, deselect Schema 
Extensions > click Next.

Keep the other two options selected, because both files and NDS® objects need to be installed 
for Automatic Workstation Import.

9 In the ZENworks List of Trees dialog box, click the name of the NDS tree where you want to 
install Automatic Workstation Import > click Next.

10 In the ZENworks List of Servers dialog box, click the names of the servers where you want 
to install Automatic Workstation Import > click Next.

11 In the Languages dialog box, click the language of the files that you have chosen to be 
installed to the server > click Next.
TIP: English is chosen by default and must be installed in addition to any other language you choose.

12 In the Automatic Workstation Import Management dialog box, select the Import (or Import/
Removal) role for at least one of the servers where you are installing Automatic Workstation 
Import > click Next.

13 In the Summary dialog box, review the list of the products to be installed and the disk space 
that each product will consume when installed > click Finish to begin the installation process.

Setting Up Policies for Automatic Workstation Import
To set up the necessary policies for Automatic Workstation Import, do the following in order:

1. “Configuring the Workstation Import Policy for ZfD” on page 26

2. “Associating the Server Package” on page 27

Configuring the Workstation Import Policy for ZfD
For Automatic Workstation Import to work, you must configure the Workstation Import Policy. 
This policy determines how the workstation objects will be named and placed in NDS.

To configure the Workstation Import Policy for ZfD:

1 If you have not created a Server Package, in ConsoleOne, right-click the server container 
where your server object is found > click New > click Policy Package > select Server Package 
> select Workstation Import > click Next > name the package > click Next > click Finish.

2 Right-click the Server Package > click Properties.

The Policies tab with the General page is displayed. You should use the General policies for 
your test system. General policies will apply to all valid platforms (NetWare and Windows* 
NT*/2000).
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3 On the General page, check the box under the Enabled column for the Workstation Import 
policy.

This both selects and enables the policy.

4 Click Properties.

5 On the Containers tab, click Add.

6 Select a valid workstation container where rights are needed to create workstations > click 
OK.

7 Click the Platforms tab.

The General page with its Location tab is displayed. Again, use these settings, which will 
apply to all platforms.

8 To select where to create workstation objects, click the Create Workstation Objects In drop-
down list > select one of the following:

Selected Container: The selected path is displayed (recommended). You may need to create 
the container before you can select it here.

Server Container: Uses a server container, or enter a relative DS path.

User Container: Uses a user container, or enter a relative DS path.

Associated Object Container: Uses an associated object container, or enter a relative DS 
path.

9 Click the Naming tab.

10 To change the default workstation naming syntax, do one or more of the following:

Click Add to add name field items (Computer+MAC Address defaults). You can select 
from the following: User, Container, DNS, Server, OS, CPU, IP Address, or user-
defined.

Click an item, then click either the up-arrow or down-arrow to change the item’s position 
in the syntax.

11 To set login limits, click the Limits page > do any of the following:

Select the user login number if relative to a user container, or if "user" is part of the 
workstation’s name. This number represents how many times you will allow a user to log 
in before importing the workstation.

To limit the number of workstations that can be imported per hour, check the box.

Select the upper limit for the number of Workstation objects that can be created in an 
hour.

12 Click OK.

Associating the Server Package
The policies you configured and enabled will not be in effect until you associate their policy 
package with a Server or Container object.

To associate the Server Package:

1 In ConsoleOne, right-click the Server Package > click Properties.

2 Click the Associations tab > Add.

3 Browse for the server container or server object for associating the package > click OK.
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Setting Up Automatic Workstation Import
The following steps assume that you selected the Import or Import/Removal option as part of 
Automatic Workstation Import installation.

To set up Automatic Workstation Import:

1 Set up a DNS name for Automatic Workstation Import to use.

This can be either a DNS entry or an entry in a local HOSTS file. An example of a DNS name 
is www.novell.com.

The following is an example of the text you would add in a HOSTS file for Automatic 
Workstation Import:

151.155.155.55 zenwsimport

In this example, the TCP/IP address is for the server where you are running the Automatic 
Workstation Import service. "zenwsimport" is not the name of a server, but a DNS name that 
resolves to this TCP/IP address. In other words, zenwsimport is a label to identify the server 
as the one running the Automatic Workstation Import service.

For Windows 95/98, the HOSTS file’s location should be:

Win95-98_drive:\Win95-98_directory\HOSTS

IMPORTANT: Note that the default host file in Windows is named HOSTS.SAM. Do not use the .SAM 
extension with your host filename. Rename HOSTS.SAM to HOSTS, or make a copy and rename the 
copy. Remember that by default, Windows 95/98 hides filename extensions that are of a known type. 
Therefore, make sure filename extensions are being displayed so that you can correctly rename the 
HOSTS.SAM file to HOSTS.

For Windows NT/2000, the HOSTS file’s location should be:

WinNT-2K_drive:\WinNT-2K_directory\SYSTEM32\DRIVERS\ETC\HOSTS

Note that HOSTS as shown above is a filename, not a folder name. By default, Windows 95/
98 will hide filename extensions (such as .SAM) because it is a known file type.

2 To verify the DNS name or TCP/IP address, at the workstation command prompt type:

ping zenwsimport

3 To place Workstation Manager on the workstation, install the Novell® ClientTM that ships with 
ZfD.

4 Check the box to enable Workstation Manager. 

At this point, if the scheduler is working, registration should happen automatically when any 
of these events occur:

Scheduler service startup (95/98 and NT/2000)

User login (95/98 and NT/2000)

User logout (NT/2000 only)
TIP: If WSREG32.LOG shows problems or no activity, registration can be forced to run (without event 
logging) by running WSREG32.EXE (located at 
windows_drive:\windows_directory\windows_system_directory).

5 To verify that Automatic Workstation Import is running on a NetWare server, on the server 
console type:

java -show
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and look for:

com.novell.application.zenworks.autowsmanagement...

6 To verify that Automatic Workstation Import is running on a Windows NT/2000 server, check 
services for:

ZENworks Workstation Import

7 If Automatic Workstation Import is not running, restart the server.

Other Things You Can Do
After you have installed and set up a test system with Automatic Workstation Import, you can set 
up additional features:

Automatic Workstation Removal: Automatically remove Workstation objects from the 
tree.

Logged In Workstations: View which workstations a user is logged in to.

Reporting: Create reports on workstation activities.

User Histories: View the user history for a workstation.

Workstation Associations: View which workstations are associated with a User object.

Workstation Groups: Manage multiple workstations as a group.

Workstation Registration: View when a workstation was last registered.

For more information, see Automatic Workstation Import in Administration.
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3 Workstation Management

ZENworks® for Desktops (ZfD) Workstation Management includes policies and configuration 
files for the User and Workstation policy packages.

For more information on policies, see Workstation Management in Administration.

This section contains the following topics:

“Installing Workstation Management” on page 31

“Other Things You Can Do” on page 32

If you have not already installed Workstation Management, such as in performing a Typical Install, 
perform the steps in the following section.

Installing Workstation Management
Use the following steps to install Workstation Management on a NetWare® or Windows* NT*/
2000 server:

1 Select a workstation where you can run the ZfD installation program and later run 
ConsoleOne® to administer ZfD.
IMPORTANT: Make sure that this workstation and all other administrative workstations are not running 
ConsoleOne while the ZfD installation is running.

2 At the workstation, insert the ZENworks for Desktops product CD. 

The WINSETUP.EXE program will autorun. If it does not autorun, run it from the root of the 
CD.

3 To launch the NIS setup program, click English > Install ZENworks.

4 To display the License Agreement for the ZfD software, click Next > read the agreement > 
click Accept if you agree with the terms of the license and limited warranty.

If you do not agree with the terms of the software agreement, do not install the software.

5 In the Install Prerequisites screen, ensure that the network server or servers to which you are 
installing meet the minimum requirements listed > click Accept when you are ready to 
proceed.

6 In the ZENworks Install Types dialog box, select Custom > click Next.

7 Deselect all options except for Workstation Management > click Next.

8 If you have already extended the schema on the current tree for ZfD, deselect Schema 
Extensions > click Next.

The Files and NDS Objects options should be left enabled.
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9 In the ZENworks List of Trees dialog box, click the name of the NDS® tree where you want 
to install Workstation Management > click Next.

10 In the ZENworks List of Servers dialog box, select the servers where you want to install 
Workstation Management > click Next.

11 In the Languages dialog box, click the language of the files that you have chosen to be 
installed to the server > click Next.

English is chosen by default and must be installed in addition to any other language you 
choose.

12 In the Summary dialog box, review the list of the products to be installed and the disk space 
that each product will consume when installed > click Finish to begin the installation process.

Other Things You Can Do
After you have installed and set up a ZfD test system, you can set up additional policies.

Other things you can do with ZfD policies:

Effective Policies: Policies can be in effect for both User and Workstation objects.

Policy Package Migration: Migrate the ZENworks 2 policies to ZfD 3.2 policies and 
packages.

Policy Package Copy Utility: Copy a Policy package from one NDS container to another 
using the Policy Package Copy utility.

Scheduled Actions: Schedule specific actions for the workstation.

Scheduling Policies: Schedule when policies will be in effect.

Other ZfD policies you can configure:

Client Configuration: Set configuration parameters for workstations. This policy is found 
only on the WinNT-2000, Win95-98, and Win3x pages.

Computer Extensible: Set user-defined policies (from .ADM files) for workstation objects.

Desktop Preferences: Set defaults for a user’s desktop.

Dynamic Local User: Establish parameters for governing Windows NT*/2000 users.

Help Desk: Establish how users can obtain help desk support.

Inventory Roll-Up: Configure how to roll up workstation inventory information to a server.

RAS Configuration: Configure dial-up networking parameters.

Remote Control: Specify policy parameters for remotely controlling a user or workstation.

Restrict LogIn: Include or exclude users who can log in using a particular workstation.

SMTP Host: Establish the IP address of the relay host that precesses outbound Internet e-
mail.

SNMP Trap Target: Establish SNMP trap targets.

User Extensible: Set user-defined policies (from .ADM files) for user objects.

Workstation Inventory: Establish parameters for inventorying workstations.

Workstation Removal: Configure when to remove unused Workstation objects.
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Windows 2000 Group: Copy Active Directory group policies to NDS and edit them.

Windows Terminal Server: Configure support for Citrix*.

For information, see Workstation Management in Administration.
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4 Application Management

ZENworks® for Desktops (ZfD) lets you use NDS® to manage applications for users on 
Windows* 95/98 and Windows NT*/2000 workstations (32-bit Windows platforms). The 
following sections provide information to help you understand, set up, and test ZfD Application 
Management:

“Application Management Overview” on page 35

“Installing Application Management” on page 38

“Starting Application Launcher and Application Explorer” on page 39

“Distributing an Application” on page 40

“Uninstalling an Application” on page 43

“Working While Disconnected from NDS” on page 44

“Other Things You Can Do” on page 47

Application Management Overview
Using ZfD Application Management, you can distribute (install) applications to workstations and 
uninstall the applications you’ve distributed. The following sections introduce the components 
involved in Application Management and provide additional information about distributing, 
uninstalling, and caching applications:

“Application Management Components” on page 35

“Application Distribution” on page 37

“Application Uninstall” on page 37

“Application Caching” on page 38

Application Management Components
ZfD Application Management consists of three main components:

“Application Objects” on page 36

“snAppShot” on page 36

“Novell Application Launcher and Application Explorer” on page 37
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Application Objects

For an application to be distributed to a workstation, the application must first have an NDS object 
that defines the information required to distribute it. ZfD Application Management includes a 
ConsoleOne® snap-in that enables you to create Application objects in NDS. Application objects 
define information such as: 

The physical location of application source files on the network

The target location for installation of the application on a workstation

Registry settings, .INI files, text configuration files, application files, icons, shortcuts, and 
other settings that support the application

The users or workstations associated to (and thus authorized to use) the application

Additional settings such as availability scheduling, granting of rights, fault tolerance, load 
balancing, application site lists, and folders

Application objects give you tremendous control over how applications are distributed. For 
example, you could create an Application object that installs an application to the user’s 
workstation and then immediately runs the application. Or you could create an Application object 
that automatically installs files when the user logs in to a workstation and then disappears from the 
workstation’s desktop. You could even create Application objects that are available for a certain 
period of time or only on specific days.

In addition to adding Application objects to NDS, the Application Management snap-in adds new 
property pages to the following objects: User, Group, Workstation, Workstation Group, 
Organizational Unit, and Organization. These property pages let you associate applications with a 
specific user, a specific workstation, groups of users, groups of workstations, entire organizational 
units, or entire organizations.

snAppShot

Distributing an application to a workstation can require various changes to the workstation, such 
as modifying the workstation’s settings and installing the application’s source files. All these 
changes must be recorded in the Application object.

To help you create Application objects that contain the correct distribution information, ZfD 
Application Management provides the snAppShotTM utility. SnAppShot creates application 
installation packages that consist of two types of files: an Application object template (.AOT) file 
and one or more application source (.FIL) files.

The .AOT file contains information about the application source (.FIL) files that will be installed 
and the workstation settings that will be modified to support the application. When you create an 
Application object, you can specify the .AOT file to use as the template for the Application object, 
in which case the .AOT information is used to populate the Application object’s information fields 
(source files location, installation target directory, Registry settings, .INI files, shortcuts, and so 
forth).

To use snAppShot to create an installation package for an application, you start snAppShot on a 
workstation that does not have the application installed. SnAppshot records the changes that occur 
on the workstation as the application is installed. As the installation proceeds, snAppShot captures 
the differences between the workstation’s pre-installation configuration state and the 
workstation’s post-installation state, compares the two pictures, and records any differences in the 
.AOT file. SnAppShot also tracks all of the files that are installed to the workstation. These files, 
which become the application source files, are copied to a network source location, renamed 
numerically, and given a .FIL file extension.

SnAppShot can be used on Windows 95/98 and Windows NT/2000 workstations.
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Novell Application Launcher and Application Explorer

Novell® Application LauncherTM and Application Explorer are workstation applications that 
display Application object icons on users’ workstations and perform various application 
management functions, such as distributing (installing) applications, uninstalling applications, and 
caching applications. Application Launcher and Application Explorer display only the Application 
objects to which the user or workstation has been associated (granted rights). 

Application Launcher is a standalone desktop window. With Application Launcher, users can 
create personal folders (if you’ve given them the appropriate rights), refresh applications, change 
views, and get information about folders and applications.

Application Explorer also provides a standalone desktop window. Application Launcher limits 
you to displaying Application objects only in the Application Launcher window, but Application 
Explorer lets you display Application objects in the Application Explorer window, the Start menu, 
the Quick Launch toolbar, the system tray, and the desktop.

Both Application Launcher and Application Explorer can be used on Windows 95/98 and 
Windows NT/2000 workstations. The main difference is that Application Launcher can be used to 
replace the Windows desktop, providing greater administrative control of users’ workstations, 
while Application Explorer extends the desktop and allows users to access Application objects 
from multiple locations.

You control whether users run Application Launcher/Explorer by including the appropriate 
executable commands in users’ login scripts.

Application Launcher/Explorer requires the Novell ClientTM to be installed on the workstation.

Application Distribution
ZfD Application Management provides the ability to distribute applications to Windows 95/98 and 
Windows NT/2000 workstations. You can:

Distribute applications to workstations whose users are authenticated to NDS.

Distribute applications to workstations whose users are not currently authenticated to NDS. 
Workstations that have been disconnected from the network (NDS) can continue to run, 
install, and verify applications. To run, the applications must have already been installed. To 
install or verify applications, the applications must reside in a local cache (hidden directory). 
The applications can be distributed from the network (prior to disconnecting) or from a 
portable storage medium, such as a CD or Jaz* drive (after disconnecting).

Distribute MSI-based applications. Application objects can be created using Microsoft* 
Windows Installer (.MSI) packages and distributed to users.

Distribute applications to users in a Microsoft Windows Terminal Server environment or 
Citrix* MetaFrame environment.

Distribute applications to newly imaged workstations as part of the imaging process.

Application Uninstall
Any application (including MSI-based applications) distributed through ZfD Application 
Management can be uninstalled. The uninstall includes the deletion of all files, .INI entries, and 
registry entries associated with the application. Shared DLL references are observed.
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Each user’s workstation contains a local cache that contains information about applications 
installed on the workstation. When you uninstall an application, this cache is used to ensure that 
the appropriate files and settings are removed from the workstation.

By default, users are restricted from uninstalling applications themselves; however, you as a 
system administrator can enable users with this capability, or you can limit application uninstall to 
yourself and other system administrators. 

Application Caching
Application caching enables users to install, run, and verify (repair) applications while they are 
disconnected from NDS.

ZfD Application Management creates a hidden cache directory (NALCACHE) on the root of each 
user’s workstation. This cache directory contains the NDS information required to run an 
application when the workstation is disconnected from NDS. If the application has already been 
installed to the workstation and the user disconnects from NDS, the application will continue to 
run just as if the user were still connected.

The cache directory also can contain the application source files and other information required to 
install the application or verify (repair) problems that may occur with the application while in 
disconnected mode. For example, if a user does not install the application before disconnecting 
from NDS, he or she can still install it if the application has been cached to the workstation’s cache 
directory.

To ensure that users will always have mission-critical applications when disconnected, you can 
configure Application objects to be cached automatically when you associate the Application 
objects with users. This is called a forced cache. In addition, you can configure Application 
Launcher/Explorer to display the Application Management dialog box. This dialog box, which is 
turned of by default, enables users to select which applications they want to cache to their 
workstations’ local drives.

To save disk space, application files are compressed before being stored in the cache directory.

Installing Application Management
If you followed the installation instructions in Chapter 1, “Installation and Setup,” on page 11 to 
perform a Typical Install, Application Management was installed at that time. Skip to the next 
section, “Starting Application Launcher and Application Explorer” on page 39. Otherwise, 
complete the tasks in the following sections:

“Completing the Installation Prerequisites” on page 38

“Running the Installation Program” on page 39

Completing the Installation Prerequisites
Before you can install ZfD Application Management, you must perform the following tasks:

Make sure that all of the recommended hardware and software requirements are met. For 
details, see “Overall Hardware Requirements” on page 11 and “Overall Software 
Requirements” on page 12.

Make sure that you have Admin equivalent rights to the server where you will install 
Application Management.
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Make sure that you have Admin equivalent rights to extend the NDS schema.

Make sure that the workstation from where you will run the installation program is 
authenticated to the server where you are installing the product.

If you will be installing on a NetWare® server, it will be necessary to unload JAVA.NLM (at 
the Server Console, type java -exit). Make sure you do this when Java* is not being used 
by another process and the proper Java components have already been installed.

Exit any program that uses files in the SYS:PUBLIC directory on the server where you will 
be installing Application Management.

Exit any Windows programs on the network workstation from which you will be running the 
installation program.

Running the Installation Program
Complete the following steps to install ZfD Application Management:

1 Select a network workstation where you can later run ConsoleOne to administer Application 
Management. This is the workstation where you will run the ZfD installation program.
IMPORTANT: Make sure that this workstation and all other administrative workstations are not running 
ConsoleOne while the ZfD installation is running.

2 At the workstation, insert the ZENworks for Desktops Program CD. 

The WINSETUP.EXE program will autorun. If it does not autorun, run it from the root of the 
CD.

3 Click English > Install ZENworks to launch the NIS setup program.

4 Follow the prompts until you reach the ZENworks Install Types dialog box. 

5 In the ZENworks Install Types dialog box, select Custom > click Next.

6 In the Components dialog box, deselect all components except Application Management > 
click Next.

7 In the ZENworks Part Selection dialog box, make sure all parts (Files, Schema Extensions, 
and NDS Objects) are selected > click Next.

8 In the ZENworks List of Trees dialog box, select the name of the NDS tree where you want 
to install Application Management > click Next.

9 In the ZENworks List of Servers dialog box, select the name of the server where you want to 
install Application Management > click Next.

10 In the Languages dialog box, select the language you want installed > click Next.

11 In the Summary dialog box, review the products to be installed > click Finish > follow the 
prompts to complete the installation.

Starting Application Launcher and Application Explorer
Application Launcher/Explorer must be running on each workstation to which you want to 
distribute applications. Complete the steps in the following sections to start Application Launcher/
Explorer on users’ workstations:

“Starting Application Launcher” on page 40

“Starting Application Explorer” on page 40
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Starting Application Launcher
1 To manually start Application Launcher on a workstation, run NAL.EXE from the 

SYS:\PUBLIC directory on the server where you installed ZfD Application Management.

or

To automatically start Application Launcher each time the user logs in to NDS, enter the 
following line in the user’s login script:

@\\servername\sys\public\nal.exe

where servername is the actual name of your network server.

Starting Application Explorer
1 To manually start Application Explorer on a workstation, run NALEXPLD.EXE from the 

SYS:\PUBLIC directory on the server where you installed ZfD Application Management.

or

To automatically start Application Explorer each time the user logs in to NDS, enter the 
following line in the user’s login script:

@\\servername\sys\public\nalexpld.exe

where servername is the actual name of your network server.

Distributing an Application
Distributing applications is one of the primary tasks you’ll perform using ZfD Application 
Management. The following sections provide instructions for distributing a simple application, 
Microsoft Notepad, from the network to a user’s workstation. Once you’ve distributed Notepad, 
you’ll better understand the process required to distribute more complex applications that use 
snAppShot packages or Microsoft Windows Installer packages.

“Copying NOTEPAD.EXE to a Network Directory” on page 40

“Creating the Notepad Application Object” on page 41

“Specifying NOTEPAD.EXE as the Application File to Install” on page 41

“Defining the Application’s Operating System Requirement” on page 42

“Associating the Application Object with a User” on page 42

“Running Notepad on the User’s Workstation” on page 42

Copying NOTEPAD.EXE to a Network Directory
An application’s source files must be kept in a network directory so that Application Launcher/
Explorer can access the files from the user’s workstation to install them. We recommend that you 
create separate directories for each application’s source files.

1 Create a NOTEPAD directory in the network location where you want the application source 
files.

2 Copy NOTEPAD.EXE from a workstation’s Windows directory (for example, 
C:\WINDOWS or C:\WINNT) to the NOTEPAD directory.
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IMPORTANT: Copy Notepad from a workstation that is running the same operating system as the one 
to which you want to distribute Notepad. For example, if you want to distribute Notepad to a Windows 95/
98 workstation, copy NOTEPAD.EXE from a Windows 95/98 workstation, not a Windows NT/2000 
workstation. This ensures that the workstation will be able to run that version of Notepad. 

Creating the Notepad Application Object
1 In ConsoleOne, right-click the container in which you want to create the Application object > 

click New > click Object.

2 Click App:Application in the list > click OK.

3 Click Manually (No .AOT/.AXT or .MSI File) > click Next.

4 In the Object Name field, enter Notepad. This is the name that will be given to the 
Application object.

5  In the Path to Executable field, enter:

%*windisk%\notepad\notepad.exe

%*windisk% is a Windows macro variable that represents the disk drive where the Windows 
directory is located (typically C:). The path specified above will cause NOTEPAD.EXE to be 
run from the workstation’s C:\NOTEPAD directory.

Application Launcher/Explorer support a variety of macros, including Windows macro 
variables, environment variables, NDS macro variables, login script variables, and 
Application object macros.

6  Click Finish to create the Application object.

Specifying NOTEPAD.EXE as the Application File to Install
Notepad will be run from the workstation’s %*windisk%\NOTEPAD directory. You need to 
configure the Application object to copy NOTEPAD.EXE from the network to the workstation’s 
%*windisk%\NOTEPAD directory.

1 Right-click the Notepad Application object > click Properties.

2 Click the Distribution Options tab > click Application Files.

3 Click Add > File to display the Edit Files dialog box.

4 In the Source File field, enter the UNC path for the NOTEPAD.EXE file you copied to the 
network. For example: 

\\NOVELL\APPS\NOTEPAD\NOTEPAD.EXE.

5 In the Target File field, enter:

%*windisk%\notepad\notepad.exe

6 Click OK to add NOTEPAD.EXE to the Application Files list. Only files in this list will be 
copied to the workstation.

7 Leave the Application object properties open > continue with the next section.
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Defining the Application’s Operating System Requirement
Before Application Launcher/Explorer can distribute the Application object to a user, it must 
verify that the user’s workstation meets the application’s requirements for the operating system.

By default, when you create an Application object, the operating system requirements are defined 
as any version of Windows 95/98 or Windows NT/2000. These requirements are sufficient for 
distributing Notepad. If you want to see where the operating system requirements are set, you can 
follow the steps below to verify the requirements. If not, you can skip to the next section, 
“Associating the Application Object with a User” on page 42.

To verify the application’s operating system requirements:

1 Click the Availability tab > click System Requirements.

2 Verify that the list contains an OS Version requirement (Windows NT/2000 or Windows 95/
98) for the workstation you want to distribute the application to. If the correct OS version is 
not listed, click Add > Operating System > enter the requirements for the operating system > 
click OK to add it to the list.
IMPORTANT: An OS Version requirement must be defined before an application will be distributed.

3 Leave the Application object properties open > continue with the next section.

Associating the Application Object with a User
1 Click the Associations tab.

2 Click Add > browse and select a user you want to distribute the application to > click OK to 
add the user to the Associations list.

3 Select the locations where you want the Application object icon to display. To do so, select 
the appropriate check boxes located in front of the user in the Associations list.

Application Launcher can display the icon in the Application Launcher window. Application 
Explorer can display the icon in the Application Launcher window, the Start menu, the system 
tray, the Quick Launch toolbar, and the desktop. Click the Help button for more information 
about each location.

4 Click OK (or Apply) to save the Application object information.

Running Notepad on the User’s Workstation
1 At the user’s workstation, make sure the user is logged in to NDS.

2 If Application Launcher/Explorer is not running, start it. See “Starting Application Launcher 
and Application Explorer” on page 39.

or

If Application Launcher/Explorer is already running, right-click the Application Launcher/
Explorer icon > click Refresh. 

The Application object icon should appear in the locations you specified when associating the 
Application object with the user.

3 Double-click the Application object to install Notepad to the workstation and run the 
application.

You can verify that Notepad was installed to the workstation by looking in the C:\NOTEPAD 
directory.

4 When you are finished with Notepad, close it.
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Uninstalling an Application
To see how to uninstall an application, you can uninstall Notepad. If you have not distributed and 
run Notepad on a workstation, see “Distributing an Application” on page 40.

Before uninstalling Notepad, you must enable it to be uninstalled. Once you’ve done this, you can 
uninstall Notepad through ConsoleOne (a forced uninstall) or you can uninstall it from the 
workstation (a user-initiated uninstall). The following sections provide instructions:

“Enabling Notepad to be Uninstalled” on page 43

“Forcing an Uninstall” on page 43

“Enabling Users to Uninstall Applications” on page 44

Enabling Notepad to be Uninstalled
Application Launcher/Explorer will not uninstall an application unless it has been marked as 
uninstallable. By default, applications are not marked as uninstallable.

To enable Notepad to be uninstalled:

1 In ConsoleOne, right-click the Notepad Application object > click Properties.

2 Click the Common tab > click Uninstall.

3 Select the Enable Uninstall option to turn it on.

4 Click Apply.

5 Continue with “Forcing an Uninstall” on page 43 or “Enabling Users to Uninstall 
Applications” on page 44.

Forcing an Uninstall
You can force an application to be uninstalled by disassociating it from the user.

1 If the Notepad Application object’s property pages are not displayed, right-click the Notepad 
Application object > click Properties.

2 Click the Associations tab.

3 Select the user you want to disassociate from the application > click Delete.

4 Click OK.

The next time Application Launcher/Explorer refreshes, it will uninstall Notepad from the 
user’s workstation.

5 To force a refresh, right-click the Application Launcher/Explorer icon on the user’s 
workstation > click Refresh.

TIP: You can use the Unassociated Days to Uninstall option to specify a longer grace period for the user. To 
do so, right-click the user’s object in ConsoleOne > click Properties > click the Application Launcher tab > click 
Edit > modify the option. 
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Enabling Users to Uninstall Applications
By default, users are not allowed to uninstall applications that you’ve distributed to them. You can, 
however, enable users to do so.
IMPORTANT: If, in the previous section, you disassociated Notepad from the user in order to force an 
uninstall, you need to associate Notepad with the user, refresh Application Launcher/Explorer on the user’s 
workstation, and double-click the Notepad icon to install Notepad again before completing the following steps.

1 If the Notepad Application object’s property pages are not displayed, right-click the Notepad 
Application object > click Properties.

2 Click the Common tab > click Uninstall.

3 Select Enable User to Perform a Manual Uninstall.

4 Click OK.

5 At the user’s workstation, right-click the Application Launcher/Explorer icon > click Refresh.

6 After Application Launcher/Explorer has refreshed, right-click the Notepad icon > click 
Uninstall > click Yes.

When Application Launcher/Explorer uninstalls an application, it removes all application files and 
settings from the workstation. However, if the Application object is still associated with the user, 
the Application object’s icon will remain on the workstation. This enables the user to reinstall the 
application at a later time.

Working While Disconnected from NDS
ZfD Application Management provides users with the ability to run applications, install 
applications, and verify (repair) applications while disconnected from NDS. To enable a user to 
run, install, or verify Notepad while disconnected, complete the tasks in the following sections:

“Marking Notepad as Disconnectable” on page 44

“Running Notepad While Disconnected from NDS” on page 45

“Caching Notepad” on page 45

“Installing Notepad from the Cache” on page 47

Marking Notepad as Disconnectable
Before an application can be run, installed, or verified on a disconnected workstation, it must be 
marked as being a disconnectable application. By default, when you create an Application object, 
the application is marked as disconnectable.

Marking an application as disconnectable does not necessarily mean that a user will be able to run 
the application when disconnected. Running the application also requires that the application be 
installed or cached on the workstation (for more information on caching, see “Caching Notepad” 
on page 45). If, however, an application is installed on a workstation but is not marked 
disconnectable, Application Launcher/Explorer will not display the application icon when 
disconnected. 

Applications that are run from the network or are dependent upon network resources such as a 
database should not be marked disconnectable.

To verify that Notepad is disconnectable:
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1 In ConsoleOne, right-click the Notepad Application object > click Properties.

2 On the Identification Icon page, verify that Disconnectable is checked.

3 Click OK (or Cancel).

Running Notepad While Disconnected from NDS
When a workstation disconnects from NDS, Application Launcher/Explorer continues to display 
an Application object’s icon if the application is installed (or cached) on the workstation. As part 
of the installation of a disconnectable application, Application Launcher/Explorer copies the 
application’s NDS information to a hidden directory (C:\NALCACHE) on the workstation. This 
information, along with the installed application files, enables the user to run the application just 
like he or she would if connected to NDS. 

To disconnect, you can use the Work Offline option provided with Application Launcher/
Explorer. The Work Offline option causes Application Launcher/Explorer to ignore NDS even 
when the user is authenticated.

1 Make sure that Notepad is installed on the workstation.

If you have not distributed and run Notepad on the user’s workstation, see “Distributing 
an Application” on page 40.

If you uninstalled Notepad in the previous section by disassociating Notepad from the 
user, associate the application again (see “Associating the Application Object with a 
User” on page 42).

If you uninstalled Notepad from the workstation, double-click the Notepad Application 
object’s icon to install Notepad again.

2 At the user’s workstation, right-click the Application Launcher/Explorer icon > click Work 
Offline.

Application Launcher/Explorer disconnects from NDS and refreshes the workstation to 
reflect the applications that are still available in disconnected mode. The Notepad icon should 
still be displayed in the same locations as when Application Launcher/Explorer is connected 
to NDS.

3 Double-click the Notepad icon to launch Notepad.

4 When you finish using Notepad, close it.

5 Right-click the Application Launcher/Explorer icon > click Work Online to reconnect to 
NDS.

Caching Notepad
If a user has not installed an application, you can make the application available for installation in 
disconnected mode. Or, if the application is already installed, you can make it possible for the user 
to verify or repair problems with the application.

This is accomplished by caching the application source files to a local drive (either the hard drive 
or portable media such as a Jaz drive or CD). Application source files are compressed to save space 
on the local disk.

You can enable users to cache their own applications, or you can force cache an application. The 
following sections use Notepad to explain these options.
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“Enabling Users to Cache Applications” on page 46

“Forcing Notepad to Be Cached” on page 46
IMPORTANT: The following sections require Notepad to be uninstalled before starting them. To uninstall 
Notepad, right-click the Notepad icon > click Uninstall.

Enabling Users to Cache Applications

Application Launcher/Explorer’s Manage Applications dialog box lets users manage the 
applications that are installed or cached on their workstation. Using the dialog box, users can 
install, uninstall, cache, and remove cached applications.

By default, the Manage Applications dialog box is not available to users. To enable and use the 
dialog box:

1 In ConsoleOne, right-click the user’s object > click Application Launcher > click Edit.

2 Click the User tab > select Enable Manage Applications Dialog > select Yes from the Setting 
list.

3 Click OK > click OK again to save the change.

4 At the user’s workstation, make sure the NDS tree that contains the user’s object is the 
primary tree (right-click the Novell icon in the system tray > click NetWare Connections > 
select a tree > click Set Primary).

5 Right-click the Application Launcher/Explorer icon > click Refresh.

6 Right-click the Application Launcher/Explorer icon > click Manage Applications.

The Manage Applications dialog box opens with the Install Applications tab displayed.

7 Click the Cache Applications tab.

Notepad appears in the Cache Applications to Install/Verify While Disconnected list. This list 
includes all applications that you can cache to your local drive.

8 Check the Notepad box to select Notepad > click Apply.

Notepad is moved from the Cache Application to Install/Verify While Disconnected list to the 
Remove Applications from Cache list, indicating that it has been added to the cache. To verify 
that Notepad was cached, you can use Windows Explorer to look in the 
C:\NALCACHE\NDS_tree_name\.Notepad.context directory. If the application is cached, 
this directory will contain an INSTALL directory.
NOTE: NALCACHE is a hidden directory. To see the directory, Windows Explorer must be configured to 
view hidden directories and files. In Windows Explorer > click the View menu > Folder Options > View. 
Under Hidden Files, select Show All Files > click OK.

9 If you plan to complete the steps in the next section to see how to force an application to be 
cached, select Notepad (in the Remove Applications From the Cache list) > click Apply. 
Otherwise, skip to “Installing Notepad from the Cache” on page 47.

Forcing Notepad to Be Cached

To force Notepad to be cached locally:

1 In ConsoleOne, right-click the Notepad Application object > click Properties.

2 Click the Associations tab.

3 In the Associations list, select the user for whom you want to cache the application > check 
the Force Cache box (on the same line as the user).
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4 Click OK.

The next time Application Launcher/Explorer refreshes on the user’s workstation, the 
application will be cached to the C:\NALCACHE directory. 

5 To force a refresh, right-click the Application Launcher/Explorer icon on the user’s 
workstation > click Refresh.

6 To verify that Notepad was cached, use Windows Explorer to look in the 
C:\NALCACHE\NDS_tree_name\.Notepad.context directory.

If the application is cached, this directory will contain an INSTALL directory. You can also 
use the Manage Applications dialog box, discussed in “Enabling Users to Cache 
Applications” on page 46, to verify that Notepad is cached.
NOTE: NALCACHE is a hidden directory. To see the directory, Windows Explorer must be configured to 
view hidden directories and files. In Windows Explorer > click the View menu > Folder Options > View. 
Under Hidden Files, select Show All Files > click OK.

Installing Notepad from the Cache
Once an application has been cached to a user’s workstation, the user can install the application 
when he or she needs it. 

To install Notepad from the cache:

1 Make sure Notepad is uninstalled. To do so, right-click the Notepad icon > click Uninstall > 
click Yes

2 Disconnect from NDS. To do so, right-click the Application Launcher/Explorer icon > click 
Work Offline.

3 After Application Launcher/Explorer has disconnected, double-click the Notepad icon.

or

Right-click the Application Launcher/Explorer icon > click Manage Applications > select 
Notepad in the Install Applications list > click OK.

Other Things You Can Do
The previous sections introduced you to the basics of distributing, uninstalling, and caching 
applications. You can also do such things as:

Distribute applications that use snAppShot (.AOT) packages.

Distribute applications that use Microsoft Windows Installer (.MSI) packages.

Distribute applications to users in a Microsoft Windows Terminal Server environment or 
Citrix MetaFrame environment.

Create folders to organize applications you distribute. You can specify the workstation 
locations where you want to use folders (Start menu or Application Launcher/Explorer 
window). 

Set up schedules and more detailed workstation requirements for distributing applications.

Set up load balancing, fault tolerance, site lists, and source lists to ensure that applications are 
available whenever needed.

Create virtual CDs of applications that can be used to distribute applications to disconnected 
workstations.
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For information about these topics and many more, see Application Management in ZENworks for 
Desktops 3.2 Administration Guide at the ZENworks for Desktops 3.2 documentation Web site 
(http://www.novell.com/documentation).

For information about deploying ZfD Application Management throughout your business, see 
Application Management in ZENworks for Desktops 3.2 Deployment Guide at the ZENworks for 
Desktops 3.2 documentation Web site (http://www.novell.com/documentation).
48   ZENworks for Desktops 3.2 Getting Started Guide

http://www.novell.com/documentation
http://www.novell.com/documentation
http://www.novell.com/documentation


    Novell Confidential                                                                                            Manual (99a)  28 October 2003
5 Workstation Imaging

ZENworks® for Desktops (ZfD) includes an Imaging component that lets you take images of 
workstation hard disks and put them on other workstations over the network. You can perform 
imaging tasks by using Preboot Services, by physically visiting workstations (manually), or 
automatically through NDS®. 

“What’s New for Workstation Imaging” on page 49

“Basic Imaging Operations” on page 53

“Preparing for Basic Imaging Operations” on page 53

“Testing Basic Imaging Operations” on page 55

“Other Things You Can Do” on page 62

What’s New for Workstation Imaging
This section of Getting Started gives an overview of the new features for workstation imaging.

“Preboot Services” on page 49

“Compression” on page 51

“Purge Deleted Files from an Image” on page 52

“Creating Imaging Boot Diskettes” on page 52

“Multicast from ConsoleOne” on page 52

“Scripted Imaging” on page 52

“Linux Menu” on page 52

“Additional Updates” on page 52

Preboot Services
PXE (Preboot Execution Environment) is an industry-standard protocol that allows a workstation 
to boot up and execute a program from the network before the workstation operating system starts. 
PXE uses DHCP and TFTP protocols. The PXE environment is loaded from either the NIC 
(Network Interface Card) in flash or ROM, or in the same memory as the system BIOS.

Minimum Hardware Requirements

The following table lists the minimum hardware requirements for Preboot Services.
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Minimum Software Requirements

The following table lists the minimum software requirements for the server where you will install 
Preboot Services.

A standard DHCP server must already be installed—either on the same server where you are 
installing ZfD Preboot Services or on another server in the network—before you install the ZfD 
Preboot Services Proxy DHCP server. If the standard DHCP server is on the same server where 
you are installing the Proxy DHCP server, you must set option tag 60 in DHCP services. For more 
information, see the ZfD 3.2 Preboot Services Administration guide at the ZfD 3.2 Preboot 
Services documentation Web site (http://www.novell.com/documentation/lg/zd32pb/index.html).
IMPORTANT: Installing and running the Proxy DHCP server on a NetWare 5.x server that is already running 
a standard DHCP server is not supported.

Using PXE

By using PXE, you can put an image on a workstation even if the workstation's hard disk is blank. 
You do not need to install a Linux* imaging partition on the workstation. Before you can use PXE, 
make sure that you have installed the new Imaging and PXE Support components of ZfD 3.2 on 
your server.

When a PXE-enabled workstation is booted, it looks for the server where PXE is installed. Using 
a DHCP request, it checks the server to see if there is any imaging work to do. If there is imaging 
work to do, it downloads the Linux imaging environment from the server so that the workstation 
can be booted to Linux. Then the image is downloaded to the workstation. If there is no imaging 
work to do, these three files are not downloaded and the workstation proceeds to boot to its 
operating system.

To image a workstation using PXE, you need to find out if the workstation is PXE capable, and 
then make sure that PXE is enabled. (When PXE is enabled, it can lengthen the time of the boot 
process slightly, so most NICs have PXE turned off by default.) To enable PXE, enter the computer 
system BIOS and look at the boot up options. These typically include Floppy Disk, Hard Disk, and 
CD-ROM. If PXE is not listed and the NIC is embedded in the motherboard, refer to the integrated 
devices section of the BIOS. In the integrated devices section, you may have an option to activate 

Resource Minimum Disk Space Minimum Hardware Requirements

User workstation 0 MB A Pentium* (or higher) personal computer, 75 
MHz, 16 MB of RAM; PXE-enabled network 
adapter or PXE-On-Disk boot diskette

PXE server 10 MB 128 MB of RAM with 8 MB free

Platform Minimum Software Requirements

NetWare® 4.x Not supported

NetWare 5.0 NW5SP5.EXE (or later) patch applied

NetWare 5.1 NW51SP1.EXE (or later) patch applied

Windows NT* 4.0 server Service Pack 6a (or later) applied

Windows* 2000 server No special requirements
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PXE. It may be called by another name, such as MBA (Managed Boot Agent) or Pre-Boot Service. 
Once you have activated it, it will become available in the Boot section of the BIOS. If the 
computer system does not have an integrated NIC, you may need to use NIC management software 
to configure your NIC to support PXE. Refer to your NIC documentation for support of PXE.

If the workstation is not PXE capable, you may be able to make it capable by updating your BIOS 
version or NIC driver, using a PXE boot disk, or purchasing a PXE capable NIC and installing it 
in your computer. To create a PXE boot disk, use the PXE-On-Disk utility that is installed as part 
of PXE Support in ZfD 3.2. You can access the utility with the Create PXE Disk button in Imaging 
Boot Disk Creator. (To start this utility from ConsoleOne®, click Tools > ZENworks Utilities > 
Imaging > Create or Modify Boot Diskette.)

If you are using a PXE-enabled workstation but have previously installed a Linux imaging 
partition on the workstation, you can disable or delete the partition. You can disable (and enable) 
the imaging partition at any time when you boot to Linux. You can delete the partition only when 
you are putting an image on the workstation using standard imaging. 
IMPORTANT: After you have deleted the partition, you need to make sure that the image you put on the 
workstation was made on a computer without a Linux imaging partition. Otherwise, the wrong MBR (Master 
Boot Record) is restored, and the computer will fail to boot. In addition, in you remove the Linux imaging 
partition from a Windows NT or Windows 2000 machine, Windows will no longer be able to boot. You should 
only remove the Linux imaging partition if you are going to restore an image to the workstation.

For More Information

Refer to the ZfD 3.2 Preboot Services Installation guide for information about installing and 
configuring PXE. To access this guide, start the ZfD 3.2 installation > click English > click Preboot 
Services Installation Guide. You can also find this guide at the ZfD 3.2 Preboot Services 
documentation Web site (http://www.novell.com/documentation/lg/zd32pb/index.html).

Refer to the ZfD 3.2 Preboot Services PXE-On-Disk User Guide for information about creating a 
PXE boot disk. To access this guide, on a Windows machine that has ZfD 3.2 PXE components 
installed on it, click the Start button > Programs > PXE > PXE on Disk > PXE on Disk Manual. 
You can also find this guide at the ZfD 3.2 Preboot Services documentation Web site (http://
www.novell.com/documentation/lg/zd32pb/index.html).

Detailed product documentation about configuring PXE is included in the ZfD 3.2 Preboot 
Services Administration  Guide, which is available at the ZfD 3.2 Preboot Services documentation 
Web site (http://www.novell.com/documentation/lg/zd32pb/index.html).

Compression
When you take an image of a workstation, you can choose from three new compression options: 

Optimize for Speed takes the least amount of time but creates the largest image file. This is 
used by default when an image is made.

Optimize for Space creates the smallest image file but may take a significant amount of time.

Balanced is a compromise between compression time and image file size.

These options are available on the ZENworks Imaging Configuration property page and from the 
Linux command line. They are also available in Image Explorer. (To start this utility from 
ConsoleOne, click Tools > ZENworks Utilities > Imaging > Image Explorer.) In Image Explorer, 
you can compress an open image by clicking File > Compress Image, or you can compress any 
image without opening it by clicking Tools > QuickCompress.
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All image files are in compressed form when they are sent over the network. The image file is 
compressed on the workstation before it is sent to the server to be stored. When restoring an image, 
the compressed file is sent to the target workstation where it is decompressed. 

If you have used Delete to hide files in the image, they are removed from the image during 
compression.

Purge Deleted Files from an Image
In Image Explorer, you can remove excluded or hidden files and folders from the open image by 
clicking File > Purge Delete Files.

Creating Imaging Boot Diskettes
There are now three imaging boot diskettes instead of two. You can create these diskettes with 
Imaging Boot Disk Creator.

Multicast from ConsoleOne
You can perform imaging multicasting from ConsoleOne. Three new property pages on the Server 
object (Multicast Session Settings, Multicast Session Participation, and ZENworks Imaging 
Multicast Sessions) let you explicitly define or use rules to define the workstations that will be 
included in the session, specify the image file or workstation you want to use as the master for the 
multicast session, and specify the requirements for a session to begin. You can also specify to 
delete the session information as soon as the session has finished. For more information, see 
Multicasting Images in the ZENworks for Desktops 3.2 Administration Guide guide.

Scripted Imaging
In addition to the standard imaging option, there is now a scripted imaging option on the 
Workstation Image Files property page in ConsoleOne that allows you to specify advanced 
commands for imaging a workstation. See the ConsoleOne Help on this property page for 
examples of commands you can use.

Linux Menu
When you boot up a workstation with a Linux imaging partition and enter img at the Linux bash 
prompt, the img commands are now available from a menu. For more information, see Imaging 
Engine (img: Command Line and Menu) in Imaging Utilities and Options in the ZENworks for 
Desktops 3.2 Administration Guide guide.

Additional Updates
The Linux kernel version is now 2.4.3.

There are now five files on the bootable CD instead of three.

The Pump utility has been updated to a new version that works with more versions of 
Microsoft* DHCP servers.

Network drivers are now built as files (modules) on the boot diskette so that it is easier to 
update drivers to new versions.

USB support has been added.

Token Ring support has been added. (Drivers are not provided by default.)
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Basic Imaging Operations
The following sections of Getting Started provide instructions for setting up and testing the 
following basic imaging operations:

Taking an image of a workstation manually

Putting an image on a workstation manually

Enabling a workstation for unattended imaging operations

Triggering unattended imaging operations through NDS

Defining a workstation imaging policy in NDS

These sections will help you prepare for and test the basic workstation imaging operations:

“Preparing for Basic Imaging Operations” on page 53

“Testing Basic Imaging Operations” on page 55

“Other Things You Can Do” on page 62

Preparing for Basic Imaging Operations
In order to test the basic imaging operations covered in Getting Started, you need a minimum setup 
of one ZfD server, one 32-bit Windows* workstation, and three high-density diskettes. 

The following sections cover the details of why these items are needed and how to prepare them:

“Preparing an Imaging Server” on page 53

“Preparing a Workstation for Imaging” on page 54

“Creating Imaging Boot Diskettes” on page 55

Preparing an Imaging Server
Although it is possible to image a workstation without connecting to a server (by booting the 
workstation from diskettes or a CD), it is easier and more typical to connect to a server to perform 
imaging operations. One reason for this is that workstation images are typically quite large (even 
if compressed), and so having a server to store them on is helpful. Also, burning CDs and 
configuring workstations to boot from them are not always convenient. Accordingly, the imaging 
tests covered in Getting Started will use an imaging server. Here are the requirements for this 
server:

Server Must Have Because

A fixed IP address When you connect to the imaging server during a workstation imaging operation, you must do 
so using the fixed IP address or DNS name of the imaging server.

Enough space to store a 
workstation image

The workstation images that you take during your tests will be stored on the imaging server. 
Unless you use compression for your workstation images, they are nearly the same size as the 
data on the workstation hard disk, which could be hundreds of MB. 
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Preparing a Workstation for Imaging
As mentioned in the previous section, it is possible (but typically not as convenient) to image a 
workstation without connecting to the network. It is also possible to image non-Windows 
computers, but such operations can’t be fully automated through NDS and the images can only be 
raw, bit-by-bit images of the entire hard disk, as opposed to customizable, file-by-file images of 
the data only. For these reasons, the imaging tests covered in Getting Started will use a network-
connected Windows workstation. Here are the requirements for this workstation:

The Imaging and Automatic 
Workstation Import 
components of ZfD installed

These software components enable the server to act as an imaging server and to register 
workstations in NDS® for unattended imaging operations. If you have already done a typical ZfD 
installation on the server, the server is ready to act as an imaging server. If not, use the following 
steps to install the needed components:

1. Make sure your server meets the “Overall Software Requirements” on page 12.

2. Run the ZfD installation program (WINSETUP.EXE) either on your server (Windows NT*/
2000) or from a Windows workstation with a drive mapped to your server (NetWare®).

3. When prompted for the install type, choose Custom Install.

4. When prompted for the components to install, choose Automatic Workstation Import and 
Imaging.

5. When prompted for the NDS tree to install to, choose the tree that your server is in.

6. When prompted for the import/removal role, choose Import.

7. If you are installing Preboot Services (PXE), insert the ZfD 3.2 Preboot Services CD or 
browse to the location of the Preboot Services installation files.

8. When the installation is done, restart your server.

Workstation Must Have Because

A supported Ethernet card The workstation must connect with the imaging server to store or retrieve the images used in your 
tests. This connection is made when the workstation is under the control of the ZfD imaging engine 
(which is a Linux application), not when the workstation is running under Windows. Therefore, 
make sure the workstation has one of the Supported Ethernet Cards listed in Workstation Imaging 
in Administration.

Windows 95, 98, NT, or 
2000 installed

Your imaging tests will include unattended operations that are currently supported only on 32-bit 
Windows platforms.

15 MB free disk space Unless you are using PXE, your imaging tests will include unattended operations that require a 
small ZfD imaging (Linux) partition to be installed on the workstation hard disk, so that the imaging 
engine can gain control on bootup. It is permissible for the 15 MB free space to be inside an 
existing partition.

Standard hardware 
architecture

NEC* PC98 architecture is not supported.

PXE enabled If you are using Preboot Services, PXE must be enabled either in the BIOS or through a PXE boot 
disk. See “Preboot Services” on page 49 for more information.

Server Must Have Because
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Creating Imaging Boot Diskettes
As mentioned in the previous section, the imaging engine that performs the actual imaging of the 
workstation is a Linux application. Therefore, the workstation must be booted to Linux 
temporarily while the imaging is performed. This means you need to prepare a bootable device that 
has the Linux kernel, ZfD imaging engine, and network drivers installed. Generally, you can use 
diskettes, a CD, or a small hard-disk partition. If you use PXE, these Linux components are 
downloaded to the workstation when it boots if there is imaging work to do. The imaging tests 
covered in Getting Started will make use of diskettes initially and a hard-disk partition later on. 
For now, just create the imaging diskettes as follows:

1 Format three high-density diskettes, or use preformatted blank diskettes. If you need the 
imaging diskettes to include support for booting your test workstation with a non-English 
keyboard, you’ll need a fourth diskette.

2 Browse to the ZENWORKS\IMAGING folder in your ZfD installation (on the imaging 
server) and run ZIMGBOOT.EXE.
TIP: You can also start ZIMGBOOT.EXE in ConsoleOne by clicking Tools > ZENworks Utilities > Imaging 
> Create or Modify Boot Diskette.

3 On the screen that appears, near the bottom under Imaging Proxy Server Address, enter either 
the fixed IP address or the full DNS name of your imaging server.

4 For the other fields and options on the screen, keep the default settings unless you have a 
specific reason to change a setting, such as to include support for a non-English keyboard. 
Click Help for details on specific settings.

5 Click Create Boot Disk 1 > insert the first diskette > click OK.

6 When the first diskette has been created, click Create Boot Disk 2 > insert the second diskette 
> click OK.

7 When the second diskette has been created, click Create Boot Disk 3 > insert the third diskette 
> click OK.

8 If you need the imaging diskettes to include support for a non-English keyboard, when the 
third diskette has been created, click Create Language Disk > insert the fourth diskette > click 
OK. Otherwise, skip this step.

9 When the last (third or fourth) diskette has been created, click Close.

Testing Basic Imaging Operations
Once you have completed the preparations outlined in the previous section, you can begin testing 
the basic imaging operations listed below. We recommend that you conduct the tests in the order 
listed.

Test What It Is What It Involves

1 “Manually Taking an Image 
of a Workstation” on page 56

Taking an image of the workstation by booting from the imaging diskettes and entering 
a particular imaging command. The image will be stored on your imaging server.

2 “Manually Putting an Image 
on a Workstation” on page 57

Putting an image on the workstation by booting from the imaging diskettes and entering 
a particular imaging command. The image will be retrieved from your imaging server.
Workstation Imaging 55



    Novell Confidential                                                                                            Manual (99a)  28 October 2003
Manually Taking an Image of a Workstation
1 Insert the first imaging diskette and reboot the workstation.

2 At the boot prompt, type manual > press Enter.

3 When prompted, insert the second diskette > press Enter.

4 When prompted, insert the third diskette > press Enter.

5 If you are prompted for a language diskette, insert it > press Enter.

6 (Optional) At the bash prompt, type img dump > press Enter.

This displays a list of the partition slots on the workstation. For your reference, note the 
number and type of partitions and which one is active.

or

Type img to display a menu > select Dump > No Geometry.

7 To take an image of the workstation, you have two choices:

You can enter a command at the bash prompt using the following format:

img makep serverIPaddr_or_DNSname [comp=comp level] //uncpath/
newimg.zmg

The makep parameter stands for "make on proxy," or in other words, create an image and 
store it on the imaging (proxy) server. The IP address or DNS name should be that of your 
imaging server, and the UNC path specifies the location and filename where the new 
image is to be stored. comp level is the amount of compression used when creating the 
image. Specify any number from 0-9. 0 means no compression. 1 is the same as Optimize 
for Speed and is used by default if you do not specify this parameter. 6 is the same as 
Balanced. 9 is the same as Optimize for Space. See below for more information.

For example:

img makep 137.65.95.127 comp=6 //xyz_srv/sys/imgs/cpqnt.zmg

IMPORTANT: Make sure to use forward slashes in the UNC path as shown above. Backslashes 
aren’t recognized by Linux. Alternatively, you can use backslashes and enclose the entire UNC path 
in quotes. The path you specify must exist on your imaging server.

You can type img to display a menu > select an Image > Proxy Image. Type the IP 
address or DNS name of your imaging (proxy) server. Type the UNC path and filename 

3 “Enabling a Workstation for 
Unattended Imaging 
Operations” on page 58

Registering the workstation as an object in your NDS tree, installing a ZfD imaging 
agent on the workstation, and installing a permanent ZfD imaging partition on the hard 
disk. The imaging agent stores certain unique data about the workstation, such as its 
NETBIOS name and its NDS distinguished name, in a safe place on the hard disk so it 
can be restored when the workstation is reimaged.

4 “Triggering an Unattended 
Imaging Operation” on 
page 60

Setting a flag in the Workstation object that says to take or put an image on the 
workstation the next time it is booted, and then verifying that the imaging operation 
occurs as expected.

5 “Defining a Workstation 
Policy for Unattended 
Imaging Operations” on 
page 61

Creating a Workstation Imaging Policy object (within a Workstation Policy Package) 
that specifies which image to put on a workstation during an unattended imaging 
operation, based on factors such as the workstation’s chipset type, hard drive type, and 
so on.

Test What It Is What It Involves
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where the new image is to be stored on the imaging (proxy) server. Select a compression 
option. (Optimize for Speed takes the least amount of time but creates the largest image 
file. Optimize for Space creates the smallest image file but may take a significant amount 
of time. Balanced is a compromise between compression time and image file size.) 
Specify any advanced parameters, such as xpartition. If you want, specify additional 
information in the Description (a description of the image), Machine Name (the computer 
on which the image is being stored), Author (the name of the person entering this 
information), and Comments (any additional comments) fields.

For details on this and other related img command parameters, see Imaging Engine (img: 
Command Line and Menu) in Imaging Utilities and Options in ZENworks for Desktops 3.2 
Administration Guide.

Depending on the amount of data on the hard disk, the image might take several minutes to 
create. If the screen goes blank, just press any key. (Linux enters a screen-saving mode after 
a few minutes.)

8 When the image has been created and the bash prompt reappears, remove any diskettes from 
the drive and reboot the workstation.

9 (Optional) Verify that the image file was created on your imaging server. You might also want 
to check its size.

Manually Putting an Image on a Workstation
1 If you haven’t already done so, create the image that you will put on the workstation, as 

instructed in “Manually Taking an Image of a Workstation” on page 56.

Make sure the image is of the same type of workstation (same hardware configuration) and is 
stored on your imaging server. You can use a previous image of the same workstation.
IMPORTANT: If you are putting an image on a workstation without a Linux imaging partition, make sure 
the image was made on a workstation without a Linux imaging partition. Otherwise, the wrong MBR 
(Master Boot Record) is restored, and the workstation will fail to boot.

2 (Optional) Boot the workstation from a Windows startup disk and run FDISK to remove all 
partitions from the hard disk.
TIP: Running FDISK is not required, but it is recommended for purposes of comparing the workstation’s 
partitions before and after the imaging operation.

3 Insert the first imaging diskette and reboot the workstation.

4 At the boot prompt, type manual > press Enter.

5 When prompted, insert the second diskette > press Enter.

6 When prompted, insert the third diskette > press Enter.

7 If you are prompted for a language diskette, insert it > press Enter.

8 (Optional) At the bash prompt, type img dump > press Enter.

This displays a list of the partition slots on the workstation. For your reference, note the 
number and type of partitions and which one is active. If you removed all partitions using 
FDISK, each slot should be empty and none should be active.

or

Type img to display a menu > select Dump > No Geometry.

9 To put the new image on the workstation, you have two choices:
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You can enter a command at the bash prompt using the following format:

img restorep serverIPaddr_or_DNSname //uncpath/newimg.zmg

The restorep parameter stands for "restore from proxy," or in other words, retrieve an 
image from the imaging (proxy) server and put it on this workstation. The IP address or 
DNS name should be that of your imaging server, and the UNC path specifies the location 
and filename where the image is to be retrieved from. For example:

img restorep 137.65.95.127 //xyz_srv/sys/imgs/cpqnt.zmg

IMPORTANT: Make sure to use forward slashes in the UNC path as shown above. Backslashes 
aren’t recognized by Linux. Alternatively, you can use backslashes and enclose the entire UNC path 
in quotes. The server portion of the path must be the name of your imaging server.

You can type img to display a menu > select Restore an Image > Proxy Image. Type the 
IP address or DNS name of the imaging (proxy) server. Type the UNC path and filename 
where the image is to be retrieved from. Specify any advanced parameters, such as sfileset 
or apartition:ppartition.

For details on this and other related img command parameters, see Imaging Engine (img: 
Command Line and Menu) in Imaging Utilities and Options in ZENworks for Desktops 
3.2 Administration Guide.

Depending on the size of the image, it might take several minutes to lay down. Images actually 
take slightly longer to lay down than they do to take. If the screen goes blank, just press any 
key. (Linux enters a screen-saving mode after a few minutes.)

10 (Optional) When the image has been laid down and the bash prompt reappears, type img 
dump > press Enter.

or

Type img to display a menu > select Dump > No Geometry.

As before, this displays a list of the partition slots on the workstation. You should now see 
information about the new partitions that were created and activated by the image that you just 
laid down.

11 At the bash prompt, type lilo.s > press Enter.

12 Remove any diskettes from the drive and reboot the workstation. Verify that it boots to the 
operating system that was installed by the new image. 

Enabling a Workstation for Unattended Imaging Operations
If you have enabled PXE on the workstation and have installed PXE support on your imaging 
server, this procedure is not a prerequisite to performing unattended imaging operations. When a 
PXE-enabled workstation is booted, it looks for the server where PXE is installed. Using a DHCP 
request, it checks the server to see if there is any imaging work to do. If there is imaging work to 
do, it downloads the files LINUX.1, LINUX.2, and LOADLIN.EXE so that the workstation can 
be booted to Linux. Then the image is downloaded to (or taken of) the workstation.

Follow this procedure if you are not using PXE. This procedure needs to be performed only once 
on your test workstation, prior to performing the unattended imaging operations covered in the 
next two sections. It is not a prerequisite to performing manual imaging operations or other 
automated imaging operations that you might want to perform in a production environment. For 
more information, see “Other Things You Can Do” on page 62.

1 If you haven’t already done so, install the Novell® ClientTM required by ZfD on the 
workstation. For instructions, see “Overall Software Requirements” on page 12.
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2 If you haven’t already done so, register the workstation as an object in your NDS tree. For 
instructions, see “Automatic Workstation Import” on page 25.

You don’t need to complete all the tasks mentioned in the instructions. Just create a server 
policy package that contains a minimal workstation import policy (use the defaults for 
naming, groups, and limits), and then associate the server package with the container where 
you want the Workstation object to be created. Then, configure the workstation to 
communicate with the import service on the imaging server, and reboot the workstation. 
Before proceeding with the next step, check your NDS tree to make sure the Workstation 
object was created.

3 Install the ZfD imaging agent on the workstation.
NOTE: The ZfD imaging agent has already been installed on the workstation if in Step 1 you did a custom 
Novell client installation and chose the Imaging Services option. If this is the case, skip to Step 4. 
Otherwise, proceed with Step 3a to install the ZfD imaging agent.

3a Browse to the ZENWORKS\IMAGING folder in your ZfD installation (on the imaging 
server).

3b Complete the steps that correspond to the type of workstation:

3c Reboot the workstation.

4 Take an image of the workstation again as instructed in “Manually Taking an Image of a 
Workstation” on page 56. 
IMPORTANT: Do this even if you have taken an image of the workstation previously. This ensures that 
the new image captures the changes you made in the preceding steps.

5 When the image has been created, reboot the workstation with the first imaging diskette > type 
install at the boot prompt > press Enter.

This starts the process of creating the ZfD imaging (Linux) partition in the first partition slot. 
It also destroys all existing partitions, even if slot 1 is empty and available. By default, the ZfD 
partition size will be 15 MB.

Workstation Type Steps

Windows 95 or 98 1. Copy ZISWIN.EXE, ZISLIB16.DLL, and ZISLIB32.DLL to the 
NOVELL\ZENIS folder.

2. Run ZISWIN.EXE from the NOVELL\ZENIS folder.

3. Run REGEDIT.EXE and browse to 
HKEY_LOCAL_MACHINE > Software > Microsoft > 
Windows > CurrentVersion > RunServices.

4. Add the string value ZENwork Imaging Service and set it 
to the filename and path of the ZISWIN.EXE file. For 
example, c:\novell\zenis\ziswin.exe

5. Save the changes and close REGEDIT.

Windows NT or 2000 1. Copy ZISWIN.EXE and ZISWINR.DLL (in the NLS\ENGLISH 
subfolder or the appropriate language subfolder) to your 
WINNT\SYSTEM32 folder.

2. From a command prompt, change to your 
WINNT\SYSTEM32 folder > type ziswin -install > 
press Enter.
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TIP: If the ZfD imaging partition already exists, it will be upgraded, and your existing Windows partitions 
will be left intact. For more information on installing or upgrading the ZfD imaging partition, see Setting 
Up Workstations for Imaging in Workstation Imaging in Deployment.

6 When prompted, reinsert the first imaging diskette > press Enter.

7 (Optional) When the ZfD imaging partition has been created and the bash prompt reappears, 
type img dump > press Enter.

This displays a list of the partition slots on the workstation. Unless you were upgrading your 
ZfD imaging partition, each partition slot should be empty and none should be active. The ZfD 
imaging partition is hidden from the list, so the number of partition slots in the list should be 
one less than before.

or

Type img to display a menu > select Dump > No Geometry.

8 At the bash prompt, restore the image you took in Step 4. Use the img restorep command 
or select Restore an Image > Proxy Image from the menu as instructed in Step 9 of “Manually 
Putting an Image on a Workstation” on page 57.

9 (Optional) When the image has been restored and the bash prompt reappears, use the img 
dump command to redisplay the list of the partition slots on the workstation.

or

Type img to display a menu > select Dump > No Geometry.

You should now see information about the Windows partitions that were restored and 
activated. There should still be one less partition slot than before because the Linux partition 
is still hidden (and will continue to be).

10 At the bash prompt, type lilo.s > press Enter.

11 When the bash prompt reappears, remove the diskette and reboot the workstation.

The workstation should boot to Windows. If the bash prompt reappears, enter the lilo.s 
command again and reboot a second time.

From this point on, whenever the workstation is rebooted, the imaging engine will gain control and 
check the imaging server to see if an imaging operation should be performed. If you have not 
configured the Workstation object (in NDS) to trigger an unattended imaging operation, the 
imaging engine will simply exit and automatically reboot the workstation to Windows.

Triggering an Unattended Imaging Operation
1 If the imaging operation that you want to trigger is to put an image on the workstation, do the 

following. Otherwise, skip this step. 

1a If you haven’t already done so, create the image to be put on the workstation. Make sure 
to store it on your imaging server. For instructions, see “Manually Taking an Image of a 
Workstation” on page 56.

1b In ConsoleOne, create a Workstation Image object in your NDS tree. Configure the 
object to point to the image file that is to be put on the workstation. For details on pointing 
to the image file, click Help in the Image File Location dialog box.

2 In ConsoleOne, right-click the Workstation object > click Properties.

3 On the ZENworks Imaging Configuration page, do either of the following:
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To take an image of the workstation the next time it boots, check the first check box > 
click the browse button next to the available field > select your imaging server and the 
path and filename under which to store the new image > check the Use Compression 
check box and select a compression option if you want to use compression (click Help 
for details) > click OK.

To put an image on the workstation the next time it boots, check the Put an Image on This 
Workstation on Next Boot check box > check the box that says to use an image other than 
the effective policy image or multicast session > click the browse button next to the 
available field > select the Workstation Image object you created in Step 1b > click OK. 

4 Click OK to save the imaging configuration settings.
TIP: Once the imaging operation has been performed on the workstation, ZfD will clear these imaging 
configuration settings automatically so that the imaging operation won’t keep recurring.

5 Verify that the imaging operation occurs as expected when you reboot the workstation.

Defining a Workstation Policy for Unattended Imaging Operations
1 In ConsoleOne, right-click the container that holds the Workstation objects that you want to 

create the policy for > click New > Policy Package.

2 Click Workstation Package > Workstation Imaging Policy > Next.

3 Enter a name for the policy package (such as Workstation Policies for This Container) > click 
Next.

4 Select Define Additional Properties > click Finish.

5 Enable the Workstation Imaging Policy > click Properties.

6 On the Image Selection Rules page, click Add > select a Workstation Image object > use the 
drop-down fields and operators to specify the conditions under which the selected image 
should be used (click Help for details) > click OK.

Repeat this step as many times as needed to specify the particular images that should be used 
under different conditions.
TIP: These rules will be used by your imaging server to determine which image to put on workstations 
during unattended imaging operations. The various hardware configuration data specified in the rules are 
compared against the actual hardware configuration data detected by the ZfD imaging engine on the 
workstation. To see this data for a particular workstation, boot it with the ZfD imaging diskettes in manual 
mode and issue the img info command or type img > select Information from the menu.

7 Click OK to save the policy.

8 On the Associations page of the policy package, add the container that holds the Workstation 
objects that you want the policy to apply to > click OK.

9 Test the policy by configuring the Workstation object to receive an image on its next boot as 
instructed in “Triggering an Unattended Imaging Operation” on page 60. Be sure to choose 
the option to use the effective policy image.

10 Verify that the imaging policy selects the correct image when the unattended imaging 
operation is triggered on the workstation (the next time it boots).
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Other Things You Can Do
Besides the basic imaging operations covered in Getting Started, ZfD gives you the additional 
imaging capabilities listed below. These capabilities are described elsewhere in the ZfD 
documentation. 

Boot from a CD to perform imaging operations: This gives you more space to include 
additional, custom files (such as drivers and images) on the imaging boot device. See Setting 
Up Workstations for Imaging in Workstation Imaging in Deployment.

Perform disconnected imaging operations: You can perform imaging operations on a 
workstation without connecting to an imaging server if you store the needed image files on a 
local device, such as a CD, hard-disk partition, or Jaz* drive. See Setting Up Imaging Services 
in Workstation Imaging in Deployment.

Manipulate workstation partitions: When a workstation is booted in manual imaging mode, 
you can issue various commands to resize or otherwise manipulate the existing workstation 
partitions. See Imaging Utilities and Options in Workstation Imaging in Administration.

Deploy images using an imaging server policy: An imaging server policy helps you to 
automate the deployment of images to workstations that haven’t been specifically enabled for 
unattended imaging operations. See Setting Up Imaging Services in Workstation Imaging in 
Deployment.

Multicast an image: In a single operation, you can take an image of a workstation, broadcast 
it over the network to multiple other workstations, and lay it down on those workstations 
simultaneously with no NDS involvement. In ZfD 3.2, you can perform imaging multicasting 
from ConsoleOne. New property pages on the Server object let you explicitly define 
workstations or use rules to define workstations that will be included in the session, specify 
the image file or workstation you want to use as the master for the multicast session, and 
specify the requirements for a session to begin. You can also specify to delete the session 
information as soon as the session has finished. See Multicasting Images in Workstation 
Imaging in Administration.

Manipulate images: After creating an image, you can customize it by creating variants that 
include or exclude certain files or that add specific registry settings. You can also create add-
on images from Application objects in NDS or by dragging individual files into a new image 
archive. You can associate multiple add-on images with a single Workstation Image object in 
NDS. See Preparing Images in Workstation Imaging in Administration.
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6 Remote Management

ZENworks® for Desktops 3.2 (ZfD 3.2) Remote Management lets you remotely manage 
workstations from the remote management console. Remote Management lets you do the 
following:

Remotely wake up a powered-off managed workstation

Assume control of the managed workstation

Execute files found on the managed workstation

Reboot the managed workstation

Transfer files between the remote management console and the managed workstation

Chat with the user at the managed workstation

Diagnose problems on the managed workstation

Ping the Remote Management Agent on the managed workstation

Blank the managed workstation screen during a Remote Control session

Lock the keyboard and mouse controls at the managed workstation during a Remote Control 
session

Suppress the wallpaper displayed on the desktop of the managed workstation during a Remote 
Control or Remote View session

Configure the time-out period for a Remote Control or a Remote View session

Remote Management can save you and your organization time and money. For example, you or 
your organization's help desk can analyze and remotely fix workstation problems without visiting 
the user's workstation, which reduces problem resolution times and increases productivity.
IMPORTANT: ZfD 3.2 Remote Management functionality can be used to remotely manage Windows* 95/98 
or Windows NT*/2000 workstations. If you need to remotely manage Windows NT/2000 servers, you can use 
the ZENworks for Servers (ZfS) Remote Management functionality. For more information, see the ZENworks 
for Servers documentation (http://www.novell.com/documentation).

This document covers the following information:

“Installation Prerequisites for Remote Management” on page 64

“Specific Hardware and Software Requirements for Remote Management” on page 64

“Installing the Remote Management Component” on page 65

“Setting Up Security for Remote Management Sessions” on page 66

“Starting a Remote Management Session” on page 67

“Other Things You Can Do” on page 67
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Installation Prerequisites for Remote Management
Before you begin a remote management session, you must prepare the workstation you are going 
to manage. Complete the following tasks:

Install ZfD 3.2 on the ZfD server.

Prepare the managed workstation for Remote Management.

Uninstall any third-party remote control agent or remote control application running on 
the managed workstation.

Install the Novell® ClientTM that ships with ZfD 3.2 or later on the managed workstation.

Ensure that you select the option to install the Workstation Manager on the managed 
workstation.

Register the managed workstation with NDS®.

For details, see “Setting Up Automatic Workstation Import” on page 28.

Prepare the management console for Remote Management.

Install the network management utility, ConsoleOne®, on the management console.

Import the registered managed workstation into NDS. For details, see “Setting Up 
Automatic Workstation Import” on page 28.

Associate the Remote Management policy settings for the managed workstation in either 
of the following ways:

For a Workstation object or for the Container of a Workstation object, you can associate 
a Remote Management policy with the Workstation object or Container.

For a Workstation object, you can ignore the Remote Management policy and associate 
the settings from the Remote Management settings page.

You can similarly associate Remote Management settings with the User object, Group, 
or Container of the logged-in user. For details, see The Package Associations Report in 
Reporting in Administration.
NOTE: If you are upgrading ZENworks 2 to ZfD 3.2, ensure that the ZfD 3.2 policies have been 
created and appropriately associated.

Make sure you have the administrator rights to install the Remote Management Agent.

Make sure you have the required rights to access a managed workstation. For details, see 
Setting Up Remote Management Security in Remote Management in Deployment.

Specific Hardware and Software Requirements for Remote 
Management

The following requirements must be met for full Remote Management functionality:

Platform Minimum Hardware and Software Requirements

ZfD 3.2 server See “Overall Software Requirements” on page 12

Appropriate protocol stack (IP, IPXTM, or IP/CMD)
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Installing the Remote Management Component
To install the Remote Management Agent, ensure you have administrator rights. 

To remotely access a workstation, the appropriate Remote Management Agent must be loaded on 
that workstation. The Remote Management Agent is a service installed on the Windows 95/98/NT/
2000 workstation that runs automatically after installation. The agent can be installed using the 
Novell Application LauncherTM (NAL), the login script or the RMSETUP.EXE program.

The preferred method for installing the agent is to add the Remote Management Install Application 
object to the Application Launcher and associate the Application object with the managed 
workstation. The Remote Management Install Application object is created in NDS during ZfD 
3.2 installation.

The following sections provide information for installing the Remote Management Agent:

“Installing the Remote Management Agent using the Application Launcher” on page 65

“Installing the Remote Management Agent using the Login Script” on page 66

“Installing the Remote Management Agent using the RMSETUP.EXE Program” on page 66
IMPORTANT: For Windows NT/2000 managed workstations, you must associate the Application object with 
the Workstation object or the Container of the Workstation object. You will not be able to launch the Application 
object if you associate it with a User object.

Installing the Remote Management Agent using the Application Launcher
To install the Remote Management Agent using the Application Launcher:

1 From the management console, right-click a managed workstation.

2 Click Properties > Applications.

3 Click Add > browse to select Remote Management Install.

4 From the Applications page, select an association for Remote Management Install.

The default association for the Remote Management Agent Application object is App 
Launcher. When this option is selected, the Remote Management Install Application object 
icon is displayed in the Application Launcher and Application Explorer (browser view), 
depending what ones you make available at the managed workstation.

5 Click OK.

6 Double-click the Remote Management Agent from the Application Explorer.

Management console See “Overall Software Requirements” on page 12

Appropriate protocol stack (IP, IPX, or IP/CMD)

Managed workstation Windows 95/98, Windows NT/2000

Novell Client that ships with ZfD3.2 (Workstation Manager 
installed)

Appropriate protocol stack (IP, IPX, or IP/CMD)

2 MB hard disk space on the drive on which Windows is installed

Platform Minimum Hardware and Software Requirements
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NOTE: Upgrade the ZfD 3.2 Remote Management files on the ZENworks server before running the 
Remote Management Install object from the Application Explorer.

Installing the Remote Management Agent using the Login Script
If the NAL components are not installed on the ZENworks server and the target machine, you can 
add the Remote Management agent install program (RMSETUP.EXE) in the login script, at any 
user/container object level.

To add RMSETUP.EXE to the login script:

1 From ConsoleOne, right-click the container or any user object > click Properties > Login 
Script.

2 Add the following line to the login script:

#ZENworks_server_name\SYS\PUBLIC\ZENWORKS\
RMSETUP.EXE

3 Click Apply > Close.

4 From the target workstation, log in as user where the modified login script is associated.

Installing the Remote Management Agent using the RMSETUP.EXE Program
1 From the workstation where you want to install the Remote Management Agent, map to the 

SYS:\PUBLIC\ZENWORKS directory located on the ZfD server.

2 Double-click RMSETUP.EXE

This automatically installs the Remote Management Agent files on the managed workstation.

Setting Up Security for Remote Management Sessions
Default values are provided for parameters in each page of the Remote Management policy. You 
can change the default values to suit your requirements.

1 Right-click the managed workstation from the management console.

2 Click Properties > Remote Management.

3 Click the Use These Setting and Ignore Workstation Remote Management Policy option.

4 Click the remote session tab for which you want to change settings > enable or disable the 
following options:

The Remote Management session for Remote Control, Remote View, File Transfer, 
Remote Execute, Chat, and Diagnostic sessions.

The Prompt User for Permission option for Remote Control, Remote View, File Transfer, 
and Remote Execute sessions.

The Give User Audible Signal option for Remote Control and Remote View sessions.

The Give User Visible Signal option for Remote Control and Remote View sessions.

The Display Remote Management Agent Icon option for Remote Control, Remote View, 
File Transfer, Remote Execute, Chat, and Diagnostic sessions.

The Allow Blanking User's Screen option for Remote Control session.

The Allow Locking User’s Keyboard and Mouse option for Remote Control session.
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Starting a Remote Management Session
Remote Management security is enabled when a Remote Management session is initiated by the 
administrative user (the network administrator or another user). Refer to the following table for 
directions to initiate a Remote Management session.

Other Things You Can Do
The following section provides information about other Remote Management tasks that you can 
do using ZfD 3.2:

Remote Management Security: Obtain details about parameters for each page in the Remote 
Management policy, set up remote management rights for the management console user, and 
monitor login and logout events. For details, see Setting Up Remote Management Security in 
Remote Management in Deployment.

Ping: Ping the Remote Management Agent installed on the workstation. For details, see 
Pinging the Remote Management Agent from the Management Console in Managing Remote 
Workstations in Administration.

Remote Wake Up: Remotely wake up a powered-off network node. For details, see 
Managing a Remote Wake Up Session in Managing Remote Workstations in Administration.

Remote Control: Remotely control a managed workstation. For details, see Managing a 
Remote Control Session in Managing Remote Workstations in Administration.

Remote View: Remotely view the desktop of a managed workstation. For details, see 
Managing a Remote View Session in Managing Remote Workstations in Administration.

Remote Execute: Remotely execute an executable on a managed workstation. For details, see 
Running an Application on the Managed Workstation in Managing Remote Workstations in 
Administration.

Remote Diagnostics: Remotely diagnose problems on a managed workstation. For details, 
see Diagnostic Information in Administration.

File Transfer: Transfer files between the management console and the managed workstation. 
For details, see Managing a File Transfer Session in Managing Remote Workstations in 
Administration.

Remote Management 
Session

To Initiate

Ping Right-click the managed workstation > click Actions > click Ping Remote 
Management Agent.

Remote Control Right-click the managed workstation > click Actions > click Remote Control.

Remote View Right-click the managed workstation > click Actions > click Remote View.

File Transfer Right-click the managed workstation > click Actions > click File Transfer.

Remote Execute Right-click the managed workstation > click Actions > click Remote Execute.

Chat Right-click the managed workstation > click Actions > click Chat.

Diagnostics Right-click the managed workstation > click Actions > click Diagnostics.

Remote Wake Up Right-click the managed workstation > click Actions > click Remote Wake Up.
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Chat: Chat with the user at the managed workstation. For details, see Managing a Chat 
Session in Managing Remote Workstations in Administration.
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7 Workstation Inventory

ZENworks for Desktops®  (ZfD) 3.2 lets you gather complete hardware and software inventory 
information for all managed workstations on your network. Using a centralized database, the 
network administrator can query, view, or report this inventory information using ConsoleOne®. 
ZfD also provides roll-up of inventory information across servers for large networks.

The following sections contain detailed information to help you plan, set up, and begin using 
Workstation Inventory in a test environment:

“Specific Hardware and Software Requirements for Workstation Inventory” on page 69

“Setting Up Workstation Inventory” on page 71

“Viewing the Inventory Information” on page 77

“Other Things You Can Do” on page 77

The focus of Getting Started is setting up a test system so you can better understand ZfD. Before 
you install Workstation Inventory in your working environment, you must plan and decide the 
inventory server tree hierarchy for your company. You should organize your inventory deployment 
based on your network and information requirements. See Workstation Inventory in Deployment 
for more information.

Specific Hardware and Software Requirements for Workstation 
Inventory

The following requirements must be met for full Workstation Inventory functionality:

Platform Minimum Hardware and Software Requirements

NetWare® 4.x or 5.x servers NetWare 4.x with Support Pack 8a or later installed,  NetWare 5.0 with Support Pack 5 
or later installed, or NetWare 5.1 with Support Pack 2 or later installed . See “Obtaining 
NetWare Support Packs” on page 14 for more information.

128 MB RAM.

45 MB for inventory with a database, 35 MB for inventory.

Availability of a NetWare volume other than \SYS:.

Valid IP address and IP Services installed.

Java* Virtual Machine (JVM) shipped with the ZfD 3.2 Companion CD. See “Obtaining 
and Installing the JVM for Your NetWare Server” on page 14.

On a NetWare 4.x server, install JVM and then install VisiBroker* shipped with the ZfD 
3.2 Companion CD. Run the ORB.EXE to install VisiBroker on a NetWare 4.x server.

Long name space installed.
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Windows* NT*/2000 servers Windows NT 4.0 with Support Pack 4 or later installed.

NDS® for NT 8 or later installed, or NDS eDirectoryTM 8.34.

Ensure that you have installed the Management Utilities when installing NDS on 
Windows NT/2000. The Management Utilities share the existing NDS default directory as 
SYS. To install Workstation Inventory, this SYS share directory should exist.

You must log in to the Windows NT/2000 server as an administrator or with administrator 
rights.

You must run the installation program from a Windows NT or a Windows 2000 server or 
workstation. The installation program assigns rights to the scan directory (\SCANDIR) 
and loads Sybase* and Service Manager as services. 

If you have configured the Inventory server that is a Windows NT/2000 server and there 
are Windows 95/98 workstations that will send their scan data to that Windows NT/2000 
server, you must do the following for the scanners to collect data:

If there are NDS users who are also Windows NT/2000 domain users, ensure that the 
users logged in are valid users of the Windows NT/2000 domain in the existing share 
created by ZfD.

If there are users logged in to a different domain, ensure that the users are trusted users 
of the domain in the existing share created by ZfD.

If there are NDS users who are not users of any Windows NT/2000 domain, ensure that 
the users do not log in to NDS during workstation startup. However, these users can log 
in to NDS later.

Inventory database server Database requirements:

Sybase ASA 7.0.0.505

Oracle* version 8.0.4.2.0 or 8i on NetWare 5.x servers. Oracle version 8.1.5 on Windows NT/
2000 servers. To maintain the database in Oracle, see Configuring the Inventory Database 
for Oracle in Workstation Inventory in Deployment for more information.

Hard disk requirements:

Recommended minimum hard disk space on a lowest level server with 10,000 workstations 
is 1 GB. 

The minimum hard disk space on the topmost level server (Root Server) is 20 GB. 

Depending on the number of workstations attached, the hard disk size may vary from 1 GB 
to 20 GB.

RAM requirements:

Recommended minimum memory on the database is 256 MB with minimum cache size of 
32 MB. 512 MB or higher is recommended at the Root Server level with a cache size of 256 
MB.

ZfD Inventory database files should not be installed on an NFS-mounted volume of a NetWare 
server.

If you want to install the Inventory database on a different version of Oracle, the Inventory 
database schema should be regenerated. Contact Novell® Technical ServicesSM for more 
information. 

Platform Minimum Hardware and Software Requirements
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For IPXTM workstations, NetBEUI should be installed on the workstations. For Windows NT/2000 
workstations the NetBios service should be running.

ZfD supports Workstation Inventory in a Novell Cluster Services environment. For more 
information, see Integrating ZfD 3.2 or ZfD 3.2 SP1 with Novell Cluster Services in 
Administration.

Setting Up Workstation Inventory
Follow this sequence to set up Workstation Inventory:

1 Ensure that the necessary prerequisites are met. 

Ensure that you have installed the JVM. See “Obtaining and Installing the JVM for Your 
NetWare Server” on page 14 for more information. 

Ensure that you have installed ConsoleOne. See “Obtaining and Installing ConsoleOne” 
on page 14.

Use top-down deployment for Inventory installation. Always begin the installation at the 
topmost level server and proceed with the next lower-level servers. For example, in an 
inventory setup with a Root Server and a Leaf Server, complete the inventory installation 
at the Root Server, and then run the installation for the Leaf Server.

2 Run the installation program.

3 Choose the following options to install the Inventory components on the server:

Select the Custom Install option.

Select the Workstation Inventory and Sybase components.

Select the Files, Schema Extensions, and NDS Objects options.

If you are installing ZfD 3.2 on an existing ZfD3/SP1 server, you must select the Files, 
Schema Extensions, and NDS Objects options.

4 Select the NDS tree where you want to install ZfD.

The installation program detects if ZfD 3 already exists. If ZfD 3 exists, the installation 
program prompts you to choose either Upgrade or Full Install. If you are installing on an 
existing ZfD setup, see Installing Workstation Inventory in an Existing ZfD 3 Setup in 
Workstation Inventory in Deployment.

5 Select the server from the displayed list of servers to which you have logged in to while 
installing. 

Windows 95/98 workstation Novell ClientTM version 3.3 shipped with the ZfD 3.2 Client CD (English only).

Novell Client version 3.31 shipped with the ZfD 3.2 Companion CD (English, French, German). 

For more information, see “Obtaining and Installing the Novell Client” on page 16.

Windows NT/2000 
workstation

Novell Client version 4.8 shipped with the ZfD 3.2 Client CD (English only). 

Novell Client version 4.81 shipped with the ZfD 3.2  Companion CD (English, French, German). 

For more information, see “Obtaining and Installing the Novell Client” on page 16.

Platform Minimum Hardware and Software Requirements
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On the server, the installation program will create an Inventory Service object with the 
following name servername_ZenInvservice in NDS for each server. This object contains the 
inventory settings. 

6 (Optional) Select the database server from the displayed list of servers connected to the tree 
you have logged in to. 

The Sybase database (MGMTDB.DB) and related database files will be installed on the server 
you specify. To install the Inventory database on the different servers, run ZfD installation for 
each database server.

During the database installation, if you are prompted that a newer version of the Inventory 
database files exist, choose to overwrite the existing database. 

6a Specify the volume on the database server. 

If a database already exists, and you specify a different volume during the installation, the 
existing database will not be overwritten.

Because the database file can grow large, place the database on a volume other than SYS:.

7 Choose a role for each selected server. 

For information about each server role, see Implementing the Inventory Server Roles in 
Workstation Inventory in Deployment. 

The installation program copies all Inventory components on each server, irrespective of the 
server role. 

8 Specify the location of the Scan Directory (SCANDIR) on the server. 

The location of SCANDIR that contains the scan data files is   
specified_scandir_volume\ZENWORKS\SCANDIR on the specified server. These files grow 
with each scan cycle and depend on the number of scanned workstations, choose a directory 
on a volume other than SYS:. If you place files other than the STR files in this directory, the 
inventory components will delete these files.

9 Assign unique site information for each database. 

This information identifies the database so that you can query an individual database, report 
information, and view inventory information for the database. 

In the following illustration, each Inventory database has been given unique identification. 
The database at the Root Server has site ID 101 and site name AusInvDB, the database at the 
Intermediate Server has site ID 102 and site name Brisbane, and the database at the Leaf 
Server has site ID 103 and site name Sydney. To obtain inventory information, you can  query 
the database with the name Sydney, or you can view the collective information from the 
AusInvDB Root Server.
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The site ID must be between 0 to 255. Also, the site name should not contain any underscore 
characters ( _ ). ZfD does not verify whether the site information is unique. 

To understand the changes that the inventory installation makes, see Understanding the 
Effects of Workstation Inventory Installation  in Administration.

On NetWare servers, after installing the Inventory components on the server, the server need 
not be rebooted. 

10 Install the Inventory files on the workstations. 

10a Ensure that the workstations meet the requirements specified in “Specific Hardware and 
Software Requirements for Workstation Inventory” on page 69. 

10b (Optional) On an existing ZfD setup, ensure that Inventory scanning is not scheduled on 
the workstation. The Workstation Manager in the System tray should display No for 
Inventory - Currently Running tab. 

10c Run the Novell Client installation program on the workstation. Novell Client will install 
the inventory files. See “Obtaining and Installing the Novell Client” on page 16.

If the required Novell Client already exists, the preferred method for installing the 
inventory files is to add the Inventory Application object to the Application Launcher and 
associate the Application object with the managed workstation. The Inventory 
Application object is created in NDS during installation. Use ConsoleOne to configure 
the Inventory Application object. The Inventory Application object on Windows 95/98 is 
ZFD3INV95. On Windows NT/2000, the Inventory Application object is ZFD3INVNT. 
You can use NAL to execute the Application object.

When you configure the policies, ensure that you schedule the Inventory task for the 
workstation. 

11 Load the database on the server. 

101         AusInvDb

102         Brisbane

103         Sydney

101  AusInvDb

Sybase/
Oracle

Inventory
Database

Root Server

Site ID Site Name

102  Brisbane

Sybase

Intermediate Server
with Database

103  Sydney

Sybase

Leaf Server with
Database
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On a NetWare server, enter mgmtdbs at the server console. The MGMTDBS.NCF file 
in the SYS:\SYSTEM directory loads the Inventory database (MGMTDB.DB) 
maintained in Sybase.

On a Windows NT/2000 server, the installation program creates the database server as a 
service: Adaptive Service Anywhere - ZENworks for Desktops 3. At server startup, this 
service is automatically loaded.

12 To set up the workstations for scanning, the workstations must be registered in NDS and be 
imported as NDS Workstation objects. See Setting Up Automatic Workstation Import for 
more information.

13 Configure the policies for the servers. For more information, see “Configuring the Policies on 
the Servers” on page 74.
NOTE: Do not rename any ZfD NDS objects such as the Inventory Service object or the Database object, 
and other policy objects that ZfD generates. ZfD will not function properly if you rename any ZfD objects.

There may be optional tasks that you need to do to implement Workstation Inventory. See 
“Other Things You Can Do” on page 77 for more information.

Configuring the Policies on the Servers
Based on the role of the Inventory server, configure the inventory settings. Consider the following 
sample scenarios:

“Configuring Inventory in a Standalone Scenario” on page 74

“Configuring Inventory in a Roll-Up Scenario” on page 74
NOTE: For information about configuring policies based on the servers, see Configuring Servers for 
Workstation Inventory in Workstation Inventory in Deployment.

Configuring Inventory in a Standalone Scenario

In a standalone server scenario, there is a single server that acts as the Inventory server and also 
the database server. There is no requirement for roll-up of inventory data. 

During the installation, you selected to install Workstation Inventory and Sybase components. You 
also assigned the role for the server as Standalone Server, and assigned a unique site ID and site 
name to the database. 

To configure the inventory settings for the Standalone Server:

1 Complete the steps in “Configuring the Database Location Policy” on page 75.

2 Complete the steps in “Configuring the Workstation Inventory Policy” on page 76.

3 Start Inventory Services. On the NetWare server, enter startinv. ZfD updates for 
Inventory will be effective only if you start the Inventory services on the servers.

Configuring Inventory in a Roll-Up Scenario

In this setup, one server acts as the Root Server with Database, and the other server is a Leaf Server. 
The Leaf Server configuration does not require a database.

During the installation for the Root Server, you selected to install Workstation Inventory and 
Sybase components. You also assigned the role for the server as Root Server, and assigned a unique 
site ID and site name to the database.

To configure the inventory settings for the Root Server:
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1 Complete the steps in “Configuring the Database Location Policy” on page 75.

2 Start Inventory Services. On the NetWare server, enter startinv. ZfD updates for 
Inventory will be effective only if you start the Inventory services on the servers.

During the installation for the Leaf Server, you selected to install Workstation Inventory. You also 
assigned the role for the server as Leaf Server.

To configure the inventory settings for the Leaf Server:

1 Specify the details of the next-level server in the Roll-Up policy contained in the Server 
package. Complete the steps in “Configuring the Roll-Up Policy” on page 75.

2 Complete the steps in “Configuring the Workstation Inventory Policy” on page 76.

3 Start Inventory Services. On the NetWare server, enter startinv. ZfD updates for 
Inventory will be effective only if you start the Inventory services on the servers.

Configuring the Database Location Policy

To enable the Database Location policy in the Service Location package and associate the database 
object with the Inventory Service object of the server:

1 In ConsoleOne, right-click the Policy Packages container > click New > Policy Package > 
Service Location Package > ZENworks Database >  Next. 

2 Type the name for the Service Location Package > click Next > click Finish. 

This procedure creates the Service Location package.

3 In ConsoleOne, right-click the Service Location Package > click Properties > click Policies. 

4 Check the check box under the Enabled column for the ZENworks Database policy. 

5 Click Properties.

6 Browse to the DN of the ZENworks Database object > click OK twice.

7 Click the Associations tab > Add.

8 Browse to select the container under which the Inventory Service object is present > click OK 
twice.

Configuring the Roll-Up Policy

To configure the Roll-Up policy:

1 In ConsoleOne, right-click the Policy Packages container > click New > Policy Package > 
Server Package > zeninvRollUpPolicy > Next.

2 Type the name for the Server Package > Next > Finish.

3  In ConsoleOne, right-click the Server Package > click Properties > Policies. 

4 Select any of these: General, NetWare, or WinNT-2000. 

5 Check the check box under the Enabled column for the zeninvRollup policy.

6 Click Properties.

7 Browse to select the DN of the Inventory Service object > click OK. 

8 Click the Associations tab > Add. 

9 Browse for the server that you want to associate the Roll-Up policy to > click OK twice.
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10 In ConsoleOne, right-click the Server Package > click Properties > Policies.

11 Select any of these: General, NetWare, or WinNT-2000.

12 Click the Roll-Up policy row > Properties > Roll-Up policy tab > Roll-Up Schedule.

13 Specify the roll-up time > click OK. 

This will schedule the roll-up time. 

When scheduling the roll-up of data in the Inventory policies, we recommend that the roll-up 
frequency should be at least one day. If the roll-up of scan data is scheduled too frequently (for 
example less than one hour), there may be some performance degradation of the Inventory 
server.

Configuring the Workstation Inventory Policy

To configure the Workstation Inventory policy package:

1 In ConsoleOne, right-click the Policy Packages container > click New > Policy Package > 
Workstation Package >  Workstation Inventory > Next.

2 Type the name for the Workstation Package > click Next > Finish.

3 In ConsoleOne, right-click the Workstation Package > click Properties > Policies > click 
Win95-98 or WinNT-2000 tab.

4 Check the Workstation Inventory policy > click OK. 

5 Click the Associations tab > Add.

6 Browse to select the container object under which the workstations are registered > click OK 
twice.

7 In ConsoleOne, right-click the Workstation Package > click Properties >  Policies > Win95-
98 or WinNT-2000 tab.

8 Click Workstation Inventory row > Properties > Workstation Inventory Policy tab.

9 Browse to select the DN of the Inventory Service object. 

This setting specifies that the scanner will send the workstation scan data to this Inventory 
server.

10 Check the Enable the software scan option to enable software scanning of workstations > click 
OK.

11 In ConsoleOne, right-click the Workstation Package > click Properties >  Policies > Win95-
98 or WinNT-2000 tab. 

12 Click Workstation Inventory policy row > click Properties > click the Policy Schedule tab.

13 Modify the schedule > click OK twice. 

14 In ConsoleOne, right-click the Inventory Service object (servername_ZenInvService) > click 
Properties > click the Inventory Service Object Properties tab.

15 Check Enable Scan of Workstations > click OK.

This setting ensures that scanning is enabled for the workstations associated with the selected 
Inventory server.
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Viewing the Inventory Information
The following list gives the steps to view inventory information, query inventory, and generate 
inventory reports:
NOTE: To view the inventory information, you must have administrative privileges. An administrator can 
assign users as trustees of the database object. See Assigning Trustees to the Database Object  in 
Workstation Inventory in Administration.

To view the following inventory information in ConsoleOne:

Inventory summary of a managed workstation: Click Tools > click Configure DB > click 
a ZENworks Database object > click OK. Right-click a workstation > click Actions > 
Inventory.

Minimal inventory information of a managed workstation: Right-click a managed 
workstation > click Properties > click ZENworks Inventory > click Minimal Information.

Query the Inventory database: Click Tools > click Configure DB > click a ZENworks 
Database object > click OK. Click a container > click Tools > click Inventory Query.

Generate the inventory reports: Click Tools > click Configure DB > click a ZENworks 
Database object > click OK. Click the server object > Click Tools > click Inventory Reports 
> Click the report you want to generate. Specify the Selection Criteria. Click the Run Selected 
Report button.
NOTE: To generate inventory reports from an Inventory database with inventory information of more than 
2,000 workstations, use the Data Export tool for better performance. The Data Export tool generates the 
inventory information in to a comma separated value (.CSV) file. Use this .CSV file along with any 
standard reporting tool such as Seagate* Crystal Reports*.

Exporting the inventory data to comma separated value format: Click Tools > click 
Configure DB > click a ZENworks Database object > click OK. Click Tools > click Data 
Export. Follow the Data Export wizard instructions.

Other Things You Can Do
The following list illustrates additional tasks that you can do with Workstation Inventory:

Configuring an Inventory database for Oracle: See Configuring the Inventory Database 
for Oracle in Workstation Inventory in Deployment for more information.

Optimizing the performance of the Oracle database: To optimize the Oracle database to 
improve the performance while querying and generating reports from a large Inventory 
database, see Optimizing the Performance of the Oracle Database in Workstation Inventory 
in Administration.

Planning the optimum database cache size: To plan the optimum database cache size for 
Sybase, see Using an Optimal Database Cache Size on the Inventory Database Server to 
Improve Performance in Workstation Inventory in Administration.

Organizing the database spaces for Sybase database: To organize the database files on 
Sybase, see Organizing the Database Spaces for a Sybase Database on NetWare or Windows 
NT/2000 Servers (AlterDBSpace Tool) in Workstation Inventory in Administration.

Optimizing the Sybase database on Windows NT/2000 servers: To optimize the Sybase 
database on Windows NT/2000 servers using the Inventory database service configuration 
tool, see Using the Inventory Database Service Configuration Tool for Windows NT/2000 in 
Workstation Inventory in Administration.
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Using ZENworks 2 Inventory policies and database: To reuse the ZENworks 2 inventory 
policies and database in ZfD 3.2, see Migrating ZENworks 2 Inventory Information  in 
Workstation Inventory in Administration.

Customizing software scanning of workstations: To specify the applications you want to 
scan for, to import files that contain the list of applications, or to export and modify the list of 
applications as a text file, see Customizing Software Scanning of Workstations in Workstation 
Inventory in Administration.

Customizing software scanning information of vendors and products in the display: To 
customize the names by using the software rules file, see Customizing the Software Scanning 
Information of Vendors and Products in Workstation Inventory in Administration.

Synchronizing the Inventory database with NDS: To view whether the workstations 
objects in NDS are synchronized with the Inventory database, see Synchronizing the 
Inventory Database with eDirectory (NDS-DB Sync Tool) in Workstation Inventory in 
Administration.

Changing the existing role of the Inventory Service object: To modify the roles that you 
have specified during installation, see Changing the Role of the Inventory Service Object in 
Workstation Inventory in Administration.

Backing up the Inventory database: To make a backup of the inventory database for Sybase 
or Oracle, see Backing Up the Inventory Database  in Workstation Inventory in 
Administration.

Map view of the servers deployed for inventory: To view the servers and database servers 
that you have deployed for inventory, see Viewing the Servers Deployed for Inventory in 
Workstation Inventory in Administration.

Exporting the inventory data to CSV format: To filter the inventory information to a CSV 
file, see Exporting the Inventory Data to CSV Format in Workstation Inventory in 
Administration.

Troubleshooting inventory problems with log files and scan status: To view the status of 
scan and the log files that the inventory components update in NDS, see Troubleshooting 
Workstation Inventory with Status Logs in Workstation Inventory in Administration.
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A Documentation Updates

The information in this section is grouped according to the date when the ZENworks for Desktops 
3.2 Getting Started Guide was updated and republished. Updates were made to this guide on the 
following dates:

August 15, 2003

October 10, 2003

November 11, 2003

August 15, 2003

October 10, 2003

November 11, 2003

Location Update

“Overall Software Requirements” on 
page 12

Added support for Novell® NetWare®6.

Location Update

“ZfD Installation Prerequisites” on 
page 16

Added information to the eighth item in the checklist to 
make it clear that the server being installed to must reside 
in an eDirectory® tree.

Location Update

“ZfD Installation Prerequisites” on 
page 16

Rewrote information in the eighth item in the checklist for 
clarification.
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