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IV Remote Management

Novell® ZENworks® for Servers (ZfS) Remote Management gives you the 
ability to manage remote servers from the management console. You can use 
ZfS to remotely manage NetWare® 4.2/5.x/6 or Windows* NT*/2000 servers.

The Remote Management Agent is installed on each NetWare and Windows 
server that you want to remotely manage. NetWare 5.1 or 6 provides a Java*-
based remote console utility that lets you use a network server manage a 
remote NetWare server.

Remote Management can save you and your organization time and money. For 
example, you or your organization's help desk can analyze and remotely fix 
server problems without having to visit the server, which reduces problem 
resolution times and increases productivity.

This documentation contains following sections:

Chapter 34, “Remote Management for NetWare Servers,” on page 1051

Chapter 35, “Remote Management for Windows NT/2000 Servers,” on 
page 1059 

Chapter 36, “Documentation Content Changes,” on page 1085
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34 Remote Management for NetWare 
Servers

The Java* -based remote console utility (RConsoleJ) for Novell® ZENWorks 
for Servers (ZfS) lets you control a NetWare® server and perform the 
following tasks:

Use console commands as you would at the server console

Use NLMTM programs as you would at the server console (for example, 
EDIT.NLM to edit files)

Control the server from another server that is using RConsoleJ

Upgrade a NetWare server (text-based UI only)

This section contains the following topics:

“Introduction” on page 1051

“Deploying” on page 1052

Introduction
ZfS RConsoleJ has the following components. These components interact 
with each other during the remote control session of a NetWare server:

“RConsoleJ Client” on page 1052

“RConsoleJ Agent” on page 1052

“RConsoleJ Proxy Agent” on page 1052
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RConsoleJ Client
The RConsoleJ Client is a Java-based utility running on the workstation. From 
the RConsoleJ Client you can remotely control and monitor all NetWare 
console operations. 

RConsoleJ Agent
The RConsoleJ Agent (RCONAG6.NLM) is a utility running on the target 
NetWare server. The target NetWare server can be connected over IP, IPXTM, 
or IP/IPX running the RConsoleJ Agent. The RConsoleJ Agent services all 
RConsoleJ Client requests.

The RConsoleJ Agent advertises its services using the Service Location 
Protocol (SLP) on a NetWare 5.x and up box. 

RConsoleJ Proxy Agent
The RConsoleJ Proxy Agent (RCONPRXY.NLM) is a utility running on a 
NetWare server (supported only on Netware 5.x and up). It routes all IP 
packets to IPX and vice versa.

The RConsoleJ Proxy Agent advertises its services using the Service Location 
Protocol (SLP).
IMPORTANT: If the target NetWare server uses only IPX, the NetWare server (loaded 
with the RConsoleJ Proxy Agent) must have both IP and IPX stacks installed.

Deploying
Before you install RConsoleJ, ensure that all the installation prerequisites for 
Remote Control are met.

“Setting Up RConsoleJ” on page 1053

“Initiating RConsoleJ” on page 1054

“Setting Up Security for RConsoleJ” on page 1058
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Setting Up RConsoleJ
To set up RConsoleJ, complete the following sections:

“Loading the RConsoleJ Agent” on page 1053

“Running the RConsoleJ Client” on page 1053

“Loading the RConsoleJ Proxy Agent on a Proxy Server” on page 1054

Loading the RConsoleJ Agent

1 At the server console prompt, enter

RCONAG6

2 Enter the password you want network administrators to use when 
accessing the target NetWare server using RConsoleJ.

3 Enter the TCP port number. 

The default value is 2034.

If the server communicates using IPX only, enter -1 to disable TCP 
listening.

To enable listening over a dynamically assigned port, enter 0.

4 Enter the SPXTM port number on which RCONAG6 will listen for a proxy 
server. 

The default is 16800.

If the server communicates using IP only, enter -1 to disable SPX 
listening.

To enable listening over a dynamically assigned port, enter 0.
NOTE: /DEV/TCP and /DEV/TCPSSL will fail if you are using a pure IPX server.

To enable RConsoleJ across the firewall, you need to keep the following ports 
open: 2034, 2035, and 2036. 

Running the RConsoleJ Client

To run the RConsoleJ Client on a server, 

1 From ConsoleOne®, select the target NetWare server object.

2 Click the Tools menu > Remote Management > NetWare.

The Novell RConsoleJ dialog box is displayed.
Remote Management for NetWare Servers 1053
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Loading the RConsoleJ Proxy Agent on a Proxy Server

The NetWare server loaded with RConsoleJ Proxy Agent should have an IP/
IPX stack loaded.

1 At the server console prompt, enter the following command:

RCONPRXY

2 Enter the TCP port number on which RCONPRXY will listen for 
RConsoleJ.

The default is 2035.

To enable listening over a dynamically assigned port, enter 0.

When the NetWare server is running the RConsoleJ Proxy Agent, the 
RConsoleJ Client can communicate through it with the target NetWare 
server that uses only IPX to communicate.

Initiating RConsoleJ
This section will help you initiate RConsoleJ in the following scenarios: 

“Scenario 1: An IP Client Controlling an IP NetWare Server” on page 
1054

“Scenario 2: An IP Client Controlling an IPX NetWare Server” on page 
1056

Scenario 1: An IP Client Controlling an IP NetWare Server

Prerequisites

“Loading the RConsoleJ Agent” on page 1053

“Running the RConsoleJ Client” on page 1053
1054   Administration
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Starting an IP Connection

The RConsoleJ Client communicates directly with the RConsoleJ Agent using 
TCP/IP.

To start an IP connection:

When you run the RConJ client from ConsoleOne, the Novell RConsoleJ 
dialog box will be displayed with the Netware Server IP address. To run the 
RConsoleJ client, see “Running the RConsoleJ Client” on page 1053.

1 Enter the password specified during loading the RConsoleJ Agent.

2 Enter the port number.

The default is 2034.

3 Click Connect.

Ne
tWare ServerUnsecure

IP

The target server is 
controlled from the 
client

RC
on
soleJ Client

Workstation NetWare
Server

or

The RConsoleJ Client 
communicates over IP

Target
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Scenario 2: An IP Client Controlling an IPX NetWare Server

Prerequisites

“Loading the RConsoleJ Agent” on page 1053

“Running the RConsoleJ Client” on page 1053

“Loading the RConsoleJ Proxy Agent on a Proxy Server” on page 1054

Starting an IPX Connection

The RConsoleJ Client communicates with the RConsoleJ Agent through the 
RConsoleJ Proxy Agent because the target NetWare server is based only on 
IPX. 

The RConsoleJ Proxy Agent is loaded on a NetWare server (proxy server) that 
has both IP and IPX stacks loaded. The RConsoleJ Proxy Agent receives all 
the IP requests from the RConsoleJ Client, converts them to IPX requests, and 
then sends them to the RConsoleJ Agent and vice-versa.
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To start an IPX connection:

When you run the RConsoleJ client from ConsoleOne, the Novell RConsoleJ 
dialog box will be displayed with the Netware Server IP address. To run the 
RConsoleJ client, see “Running the RConsoleJ Client” on page 1053.

1 From the Connect type drop-down list, select Connect through Proxy. 
Select SPX to get the IPX address and select TCP to get the IP address.

2 The default port will be selected when you make the above change.

The default is 16800 for IPX address and 2034 for IP address.

3 Enter the IP address of the proxy server, or click the Remote Servers icon 
and then select a proxy server from the list.

Ne
tWare Server

IP

The target server is 
controlled from the 
client

RC

on
soleJ Client

Workstation NetWare
Server

or

IP

IPX

or

The RConsoleJ Client 
communicates over IP

The proxy server provides 
access to IPX-only target 
servers (and IP servers if
desired).*

*If the target server uses IPX, the proxy server must have 
both IP and IPX stacks loaded.

Target

Pr
oxy Server
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4 Enter the port number specified during loading the RConsoleJ Proxy 
Agent.

The RConsoleJ Client communicates with the RConsoleJ Proxy Agent on 
this port.

The default is 2035.

5 Click Connect.

Setting Up Security for RConsoleJ
You can change the agent password to ensure that RConsoleJ sessions are 
secure.

To change the agent password for a remotely managed NetWare server:

1 At the NetWare Console prompt, enter unload rconag6 to unload 
RCONAG6.NLM.

2 Enter load rconag6 encrypt.

3 Enter a new password.

4 Enter the TCP port number. The default is 2034.

5 Enter the SPX port number. The default is 16800.

6 Enter y when prompted to save the following command line in the 
LDRCONAG.NCF file.

For Netware 4.x and 5.x:

LOAD RCONAG6 - E <encrypted password> <TCP port 
number> <SPX port number> 

For Netware 6.x:

LOAD RCONAG6 - E <encrypted password> <TCP port 
number> <SPX port number> <Secure port number>.

If you enter n, the LDRCONAG.NCF file will not be updated. The new 
password will be valid only for the current session. At a later time, if you 
load RCONAG6 from the LDRCONAG.NCF file later, the previously 
saved password will be used. 

The new password will be in effect when the agent is loaded from the 
LDRCONAG script file.
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35 Remote Management for Windows NT/
2000 Servers

Novell® ZENworks® for Servers (ZfS) Remote Management allows you to 
remotely view, control, and manage Windows* NT*/2000 servers from your 
computer. 

This chapter contains the following topics:

“Remote Management Terminology” on page 1059

“Understanding Remote Management for Windows NT/2000 Servers” on 
page 1061

“Setting Up Security for Remote Management” on page 1063

“Managing Remote Windows NT/2000 Servers” on page 1067

Remote Management Terminology
The following brief glossary provides basic definitions of Remote 
Management terms:

Managed server: A NetWare® 4.2/5.x/6 or Windows NT/2000 server that 
you want to remotely view, control, or manage. To remotely view or control a 
server, you must install the ZfS 3 Remote Management Agent on it. If you 
want a secure Remote Management session, you must install the ZfS 3 
Subscriber component on the managed server.

Management console: A Windows workstation or server running Novell 
ConsoleOne® with the ZfS 3 Remote Management ConsoleOne snap-ins 
installed. The management console provides the interface where you manage 
and administer your network.
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Management server: A server with Novell eDirectoryTM and the ZfS 3 
Distributor components. The eDirectory and Distributor components must be 
installed only if you want a secure Remote Management session. Your 
management server can be a managed server or another server. 

Remote operator: A user who can remotely view, control, and manage 
servers.

Administrator: A person who has the rights to install Remote Management. 
All administrators are remote operators but all remote operators are not 
administrators.

Viewing window: A representation of the managed server desktop. It is 
displayed on the management console when the remote operator initiates a 
Remote Management session.
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Understanding Remote Management for Windows NT/
2000 Servers

The following illustration depicts the functionality of the ZfS 3 Remote 
Management, which is explained below:

To remotely view or manage a server, the ZfS 3 Remote Management Agent 
component must be installed on that server. During the ZfS 3 Remote 
Management installation, the administrator selects the servers and specifies 
the directory where you want to install the Remote Management Agent. For 
more information, see Installing Remote Management in the Installation 
guide. 

The Remote Management Agent starts automatically when the managed 
server boots up. When the remote operator initiates a Remote Management 

ZENworks Remote Management

NetWare
or

Windows NT/2000

IP

Windows NT/2000/XP
Management Console

 Remote Control

Remote View

Remote
Operator

Remote
Management Agent

NDSNDSZENworks

Managed Server
Windows NT/2000

IP IP
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session with a managed server, he or she will be prompted to enter the Remote 
Management Agent password. The agent password can be set either by the 
administrator during the Remote Management installation or by the user at the 
managed server after the installation. On successful verification, the Remote 
Management session proceeds and the Viewing window will be displayed on 
the management console.

To ensure that the Remote Management session is secure, the user at the 
managed server can change the agent password. If the user at the managed 
server sets a new password for the agent, the password set by the administrator 
during the Remote Management installation will be ineffective. It is very 
essential that the user at the managed server must communicate the new 
password to the remote operator each time it is changed. For more details on 
how to set up a new agent password or change the existing agent password, 
see “Setting Up the Agent Password at the Managed Server” on page 1066.
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Setting Up Security for Remote Management
The following sections provide information about setting up security for the 
Remote Management sessions:

“Configuring the Remote Management Policies” on page 1063

“Setting Up the Agent Password at the Managed Server” on page 1066

Configuring the Remote Management Policies
To configure the Remote Management policies, you must perform the 
following tasks:

“Creating the Policy Packages” on page 1063

“Creating and Configuring the TED Objects” on page 1064

“Configuring the Server Remote Management Policy” on page 1064

“Configuring the Distribution Object for Remote Management” on page 
1066

“Configuring the Distributor and the Subscriber Objects” on page 1066

Creating the Policy Packages
ZfS 3 requires policy packages in the eDirectory tree that can hold the server 
policies. You can later configure and enable the server policies.

Policy packages are eDirectory objects that contain collections of policies 
grouped according to the object types. You should create an Organizational 
Unit (OU) for holding the policy packages. Consider the following when 
determining where to place this OU:

Whether you have partitions in your tree

The 256-character limit in eDirectory for the full distinguished name

How you will use the Search policy to locate the policy package

If you install ZENworks for Desktops (ZfD) to your tree, you may want to 
keep the ZfS and ZfD policies in separate containers, such as ZfS_Policies and 
ZfD_Policies.

For ZfS 3 Remote Management, create two containers, one for Tiered 
Electronic Distribution (TED) objects and the other for the Remote 
Management policy package.
Remote Management for Windows NT/2000 Servers 1063
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To create a container:

1 In ConsoleOne, right-click the container where you want the container for 
the policy packages placed.

2 Click New > Object > Organizational Unit > OK.

3 Name the container, for example, ZfS_Policies > click OK.
IMPORTANT: If you have partitions that are accessed across a WAN, make sure that 
the Policy Package objects are in the same partition as the Server object so that the 
Policy/Package Agents will load. Also make sure that the Search policy does not require 
searching outside the partition where the Server object exists. 

For Remote Management, you must create the Distributed Server package. 
The Distributed Server package is required to distribute the Remote 
Management policies among the managed servers for enforcement.

To create the Distributed Server package:

1 Right-click the policy package’s container > click New > click Policy 
Package.

The Policy Package Wizard is displayed.

2 From the Policy Packages list, select Distributed Server Package > click 
Next.

3 Enter a name for the Distributed Server Package > click Next > click 
Finish.

Creating and Configuring the TED Objects
For ZfS 3 Remote Management, you must create and configure the following 
TED objects:

TED Distribution

TED Channel

To create and configure the TED objects, see “Configuring TED Objects” on 
page 540.

Configuring the Server Remote Management Policy
The Server Remote Management policy defines the behavior of the Remote 
Management Agent. This policy is distributed to the specified Windows 
managed servers using the TED, which helps the remote operator to associate 
the Remote Management policy to a group of Windows managed servers from 
the management console.
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To configure the Server Remote Management policy:

1 In ConsoleOne, right-click the Distribute Server Package object > click 
Properties.

2 Click the Policies tab > select the Windows sub-option.

3 Select the check box under the Enabled column for the Server Remote 
Management Policy.

4 Click the Properties button > the Remote Management tab.

5 Click the General tab.

6 Click Display Remote Management Agent Icon To Users for Remote 
Control and Remote View sessions.

7 Click the Remote Control tab > select the options that you want to use. 
Your choices are:

Prompt User for Permission to Remote Control

Give User Audible Signal when Remote Controlled

Give User Visible Signal when Remote Controlled

Allow Blanking User's Screen

Allow Locking User’s Keyboard and Mouse

8 Click the Remote View tab > select the options that you want to use. Your 
choices are:

Prompt User for Permission to Remote View

Give User Audible Signal when Remote Viewed

Give User Visible Signal when Remote Viewed

9 Click Apply > Close.

10 Right-click the Server Remote Management policy > select Edit 
Schedule.

11 Modify the schedule > click Apply > click Close.

12 To associate the Server Remote Management policy with a managed 
server, click the Distribution tab.

13 Click Add > browse for and select the Distribution object > click OK.

14 Click Apply > click Close.
Remote Management for Windows NT/2000 Servers 1065
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Configuring the Distribution Object for Remote Management
You must configure the Distribution object for distributing the Remote 
Management policies.

To configure the Distribution object:

1 In ConsoleOne, right-click the Distribution object > click Properties.

2 Click the Type tab.

3 Select Policy Package from the Select Type drop-down list.

4 Click Add > select the Distributed Server package that has the Server 
Remote Management policy.

5 Click the Schedule tab.

6 Modify the schedule > click Apply > click Close.

Configuring the Distributor and the Subscriber Objects
To configure the Distributor and the Subscriber objects, see “Configuring 
TED Objects” on page 540.

If the managed servers are residing on a different eDirectory tree or the 
Windows NT server does not have the eDirectory installed, you must create 
and configure an External Subscriber object for sending Distributions to 
Subscribers residing on managed servers in other trees. For more information 
on External Subscribers, see “Configuring TED Objects” on page 540.

Setting Up the Agent Password at the Managed Server
The user at the managed server can change the password of the Remote 
Management Agent to make sure that the Remote Management sessions are 
secure.

To change the agent password:

1 Right-click the Remote Management Agent icon from the system tray of 
the Windows NT/2000 managed server.

2 Click Security > click Set Password.

Use a password of ten or fewer alphanumeric characters. The password is 
case-sensitive and cannot be blank.

The new password must be communicated to the remote operator each time it 
is changed.
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Managing Remote Windows NT/2000 Servers
The following sections provide information that will help you effectively 
manage Remote Management sessions on Windows NT/2000 servers:

“Initiating Remote Management Sessions” on page 1067

“Managing a Remote View Session” on page 1069

“Managing a Remote Control Session” on page 1072

“Viewing the Audit Log for Remote Management Sessions” on page 
1082

“Improving the Remote Management Performance” on page 1082

“Unloading and Reloading the Remote Management Agent” on page 
1083

Initiating Remote Management Sessions
You have several options for initiating a Remote Management session from 
ConsoleOne. They include the following:

“Initiating the Remote Management Session from within ConsoleOne” 
on page 1067

“Initiating Remote Management Sessions from the eDirectory/NDS 
Namespace” on page 1068

“Initiating Remote Management Sessions from the Atlas Namespace” on 
page 1069

Initiating the Remote Management Session from within ConsoleOne

1 In ConsoleOne, click Tools > Remote Management > Windows.

2 In the Remote Management dialog box, enter the IP address or the DNS 
name of the managed server.

3 Enter the agent password.

4 Select the Remote Management operation that you want to initiate with 
the managed server. 

5 Click OK.
Remote Management for Windows NT/2000 Servers 1067
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Initiating Remote Management Sessions from the eDirectory/NDS Namespace

You can start a Remote Management session from the eDirectory (NDS) 
namespace (in ConsoleOne) using one of the following methods:

1 In ConsoleOne, click Tools > Remote Management > Windows.

2 In the Remote Management dialog box, enter the IP address or the DNS 
name of the managed server.

3 Enter the agent password.

4 Select the Remote Management operation that you want to initiate with 
the managed server. 

5 Click OK.

You can also use the following procedure: 

1 In ConsoleOne, select a managed server.

2 Click Tools > Remote Management > Windows.

3 In the Remote Management dialog box, select the IP address of the 
managed server from the Agent drop-down list.

The IP address of the selected managed server will be automatically 
populated to the Agent drop-down list.

4 Enter the agent password.

5 Select the Remote Management operation that you want to initiate with 
the managed server. 

6 Click OK.

You can also use the following procedure:

1 In ConsoleOne, right-click a managed server.

2 Click Remote Management > Windows.

3 In the Remote Management dialog box, select the IP address of the 
managed server from the Agent drop-down list.

The IP address of the selected managed server will be automatically 
populated to the Agent drop-down list.

4 Enter the agent password.

5 Select the Remote Management operation that you want to initiate with 
the managed server. 

6 Click OK.
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Initiating Remote Management Sessions from the Atlas Namespace

Before initiating a Remote Management session from the Atlas namespace (in 
ConsoleOne), make sure that the NetWare® Management AgentTM (NMA) is 
installed and the Discovery discovers the network topology.

To initiate the Remote Management session:

1 In ConsoleOne, right-click a managed server.

2 Click Actions > click Remote Control or Remote View.

3 Select the IP address and enter the agent password.

The IP address of the selected managed server will be automatically 
populated to the Agent drop-down list.

4 Click OK.

Managing a Remote View Session
After you have initiated a Remote Management session and selected Remote 
View as the operation, you have several options to help you view the managed 
server. 

“Controlling the Display of the Viewing Window” on page 1069

“Using the Viewing Window Accelerator Keys” on page 1070

“Defining a Custom Accelerator Key Sequence” on page 1071

“Stopping a Remote View Session from the Managed Server” on page 
1072

Controlling the Display of the Viewing Window

You can regulate the display of the Viewing window through using the control 
options.

To enable the control options:

1 Click the Remote Management Agent icon, located at the top left corner 
of the Viewing window.

2 Click Configure.

3 To enable the use of accelerator keys on the management console, select 
Enable Accelerator Keys.
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4 To use the 16-color palette on the managed server during the Remote 
Management session, select 16 Color Mode. 

Selecting 16 Color Mode will enhance the Remote Management 
performance.

5 To suppress the wallpaper displayed on the managed server’s desktop, 
select Hide Wallpaper. 

6 To save the Control Parameter settings, click the Save on Exit check box.

The saved settings will be implemented in the next Remote View session.

7 Click OK.

Using the Viewing Window Accelerator Keys

You can use accelerator keys to assign the shortcut keys to the control options 
and also to control the display of the Viewing window. Default accelerator key 
sequences are assigned to each accelerator key option. The Accelerator Keys 
dialog box displays the default key sequence in the edit field of each 
accelerator key option. You can define a custom accelerator key sequence to 
change the default sequence. For more information, see “Defining a Custom 
Accelerator Key Sequence” on page 1071.

To enable the Accelerator Keys option:

1 Click the Remote Management Agent icon, located at the top left corner 
of the Viewing window.

2 Click Configure.

3 Select Accelerator Keys Enable.

4 Click OK.

To open the Accelerator Keys dialog box:

1 Click the Remote Management Agent icon, located at the top left corner 
of the Viewing window.

2 Click Accelerator Keys.
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The following table explains the Accelerator Key options you can during the 
Remote View session:

Defining a Custom Accelerator Key Sequence

The default keystrokes assigned to the accelerator key options are displayed 
in the edit field to the right of each accelerator key option in the Accelerator 
Keys dialog box. You can change the accelerator key sequence and define a 
custom accelerator key sequence if you do not want to use the default 
keystroke.

To define a custom accelerator key sequence:

1 Click the Remote Management Agent icon, located at the top-left corner 
of the Viewing window.

2 Click Accelerator Keys.

3 Click the edit field of the accelerator key option where you want to define 
a custom accelerator key sequence.

4 Press the new accelerator key sequence.

5 Click OK.
IMPORTANT: The shift keys are left-right sensitive, and are indicated in the Control 
Options dialog box as Lshift and Rshift.

Option Default 
Keystroke

Description

Full Screen Toggle Ctrl+Alt+M Applicable only if the color resolution settings on 
the management console and managed server are 
similar.

Sizes the Viewing window to the size of your 
screen without window borders.

Refresh Screen Ctrl+Alt+R Refreshes the Viewing window.

Restart Viewer Ctrl+Alt+T Re-establishes the connection with the managed 
server.

Accelerator Keys 
Enable

Ctrl+Alt+H Enables you to change the default accelerator key 
sequences.

Stop Viewing Left-Shift+Esc Closes the Viewing window.

Configure Dialog Alt+M Opens the Control Parameters dialog box.

Accelerator Keys Dialog Alt+A Opens the Accelerator Keys dialog box.
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Stopping a Remote View Session from the Managed Server

You can stop a Remote View session from the managed server using any of 
the following methods:

Right-click the Remote Management Agent icon and click Terminate RC/
RV Session.

Close the Visible Signal window displayed on the top right corner of the 
managed server desktop.

Press the keystroke that you have defined for the Stop Viewing option in 
the Accelerator Keys dialog box.

Managing a Remote Control Session
After you have initiated a Remote Management session and selected Remote 
Control as the operation, you can control the managed server from the 
management console to provide user assistance and to help resolve server 
problems. With remote control connections, the remote operator can go 
beyond viewing the managed server to taking control of it.

You can effectively manage a Remote Control session by performing the 
following tasks with the Viewing window control options, the Viewing 
window toolbar buttons, and the Remote Management Agent icon options:

“Controlling the Display of the Viewing Window” on page 1073

“Using the Viewing Window Accelerator Keys” on page 1074

“Using the Toolbar Buttons on the Viewing Window” on page 1076

“Enabling the Wallpaper on the Managed Server” on page 1077

“Enhancing the Remote Control Performance Over a Fast Link or a Slow 
Link” on page 1078

“Using the Remote Management Agent Icon” on page 1078

“Obtaining Information About Remote Management Sessions” on page 
1079

“Stopping a Remote Control Session from the Managed Server” on page 
1081
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Controlling the Display of the Viewing Window

You can control the display of the managed server by using the Viewing 
window control options.

To enable control options:

1 Click the Remote Management Agent icon, located at the top left corner 
of the Viewing window.

2 Click Configure.

3 Select the control options you want to enable for the remote session.

The following table explains the options you can use to control the 
display of the Viewing window.

Option Description

Warn Before Screen Blanking Informs the user at the management console before the managed 
server screen is blanked.

Enable Accelerator Keys Enables the accelerator keys on the management console so that you 
can change the default accelerator key sequences during the remote 
session.

16 Color Mode Forces the use of 16-color palette on the managed server during a 
Remote Management session. This enhances the Remote 
Management performance.

Use this option only if you are performing the Remote Management 
session over a slow WAN.

Hide Wallpaper Suppresses any wallpaper displayed on the managed server. This 
option is enabled by default. If you want to display the wallpaper on the 
managed server during a Remote Control or Remote View session, 
disable this option.

System Key Pass Passes Alt-key sequences on the management console to the remote 
Windows NT/2000 server.

During a Remote View session, the System Key Pass-Through option 
is not enabled.

Network Type If the managed server resides over a LAN, selecting the Fast Links 
option will accelerate the Remote Management performance.

If the managed server is connected over a dial-up link, selecting the 
Slow Links option will accelerate the Remote Management 
performance.
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4 To save the Control Parameter settings, click the Save on Exit check box.

The saved settings will be implemented in the next Remote Control 
session.

Using the Viewing Window Accelerator Keys

You can use accelerator keys to assign shortcut keys to the control options and 
also to control the display of the Viewing window. Default accelerator key 
sequences are assigned to each accelerator key option. The Accelerator Keys 
dialog box displays the default key sequence in the edit field of each 
accelerator key option. You can define a custom accelerator key sequence to 
change the default sequence. For more information, see “Defining a Custom 
Accelerator Key Sequence” on page 1071.

To enable the Accelerator Keys option:

1 Click the Remote Management Agent icon, located at the top left corner 
of the Viewing window.

2 Click Configure.

3 Select Enable Accelerator Keys.

To open the Accelerator Keys dialog box:

1 Click the Remote Management Agent icon, located at the top left corner 
of the Viewing window.

2 Click Accelerator Keys.

The following table explains the Accelerator Key options you can use to 
control the display of the Viewing window:

Option Default Keystroke Description

Full Screen Toggle Ctrl+Alt+M Applicable only if the color resolution settings on the 
management console and managed server are similar.

Sizes the Viewing window to the size of your screen 
without window borders.

Refresh Screen Ctrl+Alt+R Refreshes the Viewing window.

Restart Viewer Ctrl+Alt+T Re-establishes the connection with the managed 
server.

Accelerator Keys 
Enable

Ctrl+Alt+A Enables you to change the default accelerator key 
sequences.
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Stop Viewing Left-Shift+Esc Closes the Viewing window.

Configure Dialog Alt+M Opens the Control Parameters dialog box.

Accelerator Keys Dialog Alt+A Opens the Accelerator Keys dialog box.

System Key Pass Ctrl+Alt+S Passes Alt-key sequences on the management 
console to the managed server.

Mouse/Keyboard Lock Ctrl+L Locks the keyboard and mouse controls at the 
managed server.

This option is available only if the Allow Locking User’s 
Keyboard and Mouse option is enabled in the Server 
Remote Management policy. 

Screen Blank Ctrl+B Blanks the screen at the managed server.

This option is available only if the Allow Blanking User’s 
Screen option is enabled in the Server Remote 
Management policy. 

Ctrl+Alt+Del Ctrl+D Restarts the Windows NT/2000 servers.

Start Ctrl+S Opens the taskbar with the Start button on Windows 
NT/2000 server.

Application Switcher Ctrl+T Switches applications on managed servers.

Option Default Keystroke Description
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Using the Toolbar Buttons on the Viewing Window

The following table describes the toolbar options in the Viewing window:

Button Default Keystroke Key Function

Screen Blanking Ctrl+L Displays only if the Allow Blanking User’s Screen 
option is enabled in the security settings.

Blanks the screen at the managed server. When the 
remote operator selects this option, the screen of the 
managed server will be blacked out and the 
operations performed by the remote operator on the 
managed server will not be visible to the user at the 
managed server.

Not supported over certain display adapters. Refer to 
the ZfS 3 Readme located at the root of the 
ZENworks for Servers 3 product CD for the list of 
display adapters that do not support this feature. 

Mouse and Keyboard Lock

 

Ctrl+B Locks the keyboard and mouse controls at the 
managed server. When the remote operator selects 
this option, the user at the managed server will not be 
able to use the keyboard and mouse controls of the 
managed server.

System Start

 

Ctrl+S Sends the Ctrl+Esc keystroke to the managed 
server.

Opens the taskbar with the Start button on Windows 
NT/2000 servers.

Application Switcher

 

Ctrl+T Sends the Alt-tab key sequences to the managed 
server.

Switches applications on managed servers. 

To switch the applications, 

1. In the Viewing window, click the Application 
Switcher icon or press the Application Switcher 
shortcut key.

2. To traverse to the application you want using the 
Application Switcher icon.

3. To view the application, press Tab.
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You can define a custom key sequence if you do not want to use the default 
key sequence. For more information, see “Defining a Custom Accelerator Key 
Sequence” on page 1071.

Enabling the Wallpaper on the Managed Server

When the remote operator initiates a Remote Control session, any wallpaper 
displayed on the desktop of the managed server will be suppressed. This 
feature reduces the response time from the managed server for requests from 
the management console because less traffic is generated over the network 
while the wallpaper is suppressed.

You can configure the control parameter for this option to change the default 
settings and enable the display of the wallpaper on the managed server. When 
you terminate the Remote Control session, the suppressed wallpaper will be 
restored.

To enable the display of suppressed wallpaper on the managed server:

1 Click the Remote Management Agent icon, located at the top left corner 
> click Configure.

2 Deselect the Hide Wallpaper option.

System Key Pass Through

 

Ctrl+Alt+S Sets the system key pass to On or Off.

Passes Alt-key sequences on the management 
console to the managed server.

Certain key sequences such as Ctrl+Esc, Alt+Tab, 
Ctrl+Alt+Del, and Alt+PrintScreen are not allowed 
even when the System Key Pass-Through is set to 
On. However, you can use the toolbar buttons on the 
Viewing window for the Ctrl+Esc, Alt+Tab, and 
Ctrl+Alt+Del keystrokes.

CTRL+ALT+DEL

 

Ctrl+D Sends the Ctrl+Alt+Del keystroke to the managed 
server.

Displays the Security window on a Windows NT/2000 
managed server.

Button Default Keystroke Key Function
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Enhancing the Remote Control Performance Over a Fast Link or a Slow Link

The Remote Control performance, especially over a slow link, has been 
enhanced through using improved compression.

The performance during a Remote Control session over a slow link or a fast 
link varies depending on the network traffic. For better response time, try one 
or more of the following strategies:

Deselect the Hide Wallpaper option on the managed server in the Control 
Parameters dialog box.

Assign color settings on the management console higher than the 
managed server or assign the same color settings for the management 
console and the managed server.

Deselect the Enable Pointer Shadow option before starting the Remote 
Control or Remote View session.

To deselect Enable Pointer Shadow:

1 From the Windows desktop, click Start > Settings > Control Panel > 
double-click Mouse.

2 Click Pointers > deselect Enable Pointer Shadow.

Using the Remote Management Agent Icon

You can manage a remote session from the managed server using the Remote 
Management Agent icon  options. By default, the Remote Management 
Agent icon will be displayed in the system tray of the Windows NT/2000 
servers. This icon indicates that the Remote Management Agent is loaded on 
the managed server.

The user at the managed server can right-click the Remote Management Agent 
icon and choose from the following options:

Option Description

Terminate Session Disconnects and closes the remote session on the 
managed server and displays a message on the 
management console indicating that the remote session is 
closed.

Security Allows the user at the managed server to set or clear the 
password for the server.
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Setting Up a Password for the Managed Server

The user at the managed server can set an agent password. This password will 
override the password set by the administrator during the ZfS Remote 
Management installation.

To set the agent password:

1 From the managed server, right-click the Remote Management Agent 
icon.

2 Click Security > Set Password.

Use a password of ten or fewer alphanumeric characters. The password is 
case-sensitive and cannot be blank.

After the completion of the Remote Management session, you can clear the 
agent password. If you clear the agent password, the remote operator cannot 
perform the Remote Management operations.

To clear the agent password:

1 On the managed server, right-click the Remote Management Agent icon.

2 Click Security > Clear Password.

Obtaining Information About Remote Management Sessions

Using the Information window, the user at the managed server can view 
details about the session, such as who is accessing the managed server for a 
remote session, the security settings, and the protocol in use for the remote 
session.

Information Displays information such as who is accessing the 
managed server for the remote session, security settings, 
and the protocol in use for the remote session.

For details, see “Obtaining Information About Remote 
Management Sessions” on page 1079.

You can right-click or double-click the Remote 
Management Agent icon to view the Information window.

Help Displays the Remote Management Agent help file.

Option Description
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To view information about remote sessions:

1 On the managed server, right-click the Remote Management Agent icon.

2 Click Information.

3 Click the General tab to view the general information and the Security tab 
to view the security information.

After you have opened the Information window, you can view different kinds 
of information about remote sessions on the managed server. See the 
following sections for details:

“Obtaining General Information” on page 1080

“Obtaining Security Information” on page 1081

Obtaining General Information

The following table explains the general information you can obtain about 
Remote Management sessions from the Information window:

Parameter Description

RM Operation Lists the ongoing Remote Management sessions.

RM Information > Initiator Displays the name of the remote operator.

RM Information > Protocol Displays the protocol that the Remote Management Agent 
uses to communicate with the management console during a 
remote session.

RM Information > Optimization Displays if the optimization driver is enabled or disabled for the 
Remote Management session. The Remote Management 
Agent performance will be optimized if the video card on the 
managed server is compatible with the performance 
enhancement driver that is installed during Remote 
Management Agent installation.
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Obtaining Security Information

The Security Information dialog box displays information based on the 
Remote Control and Remote View sessions.

Stopping a Remote Control Session from the Managed Server

You can stop a Remote Control session from the managed server using any of 
the following methods:

Right-click the Remote Management Agent icon and click Terminate RC/
RV Session.

Close the Visible Signal window displayed on the top right corner of the 
managed server desktop.

Press the keystroke that you have defined for the Stop Viewing option in 
the Accelerator Keys dialog box.

Options Description

Permission Required Indicates if the remote operator should obtain permission from the 
user at the managed server each time the he wants to perform the 
remote management session on the managed server.

Audible Signal Required Indicates if an audible signal should be sent to the managed server 
every time the remote operator accesses the managed server.

Beep Every Indicates the time interval based on which the audible signal is 
periodically sent to the managed server.

Visual Signal Required Indicates if a visible signal should be sent to the managed server 
every time the remote operator accesses the managed server.

Display Name Every Indicates the time interval based on which the visual signal is 
periodically sent to the managed server.

Screen Blanking Allowed Indicates if the remote operator is allowed to blank the managed 
server screen. Screen Blanking Allowed is applicable for Remote 
Control only.

Locking Control Allowed Indicates if the remote operator is allowed to lock the keyboard and 
mouse controls of the managed server. Locking Control Allowed is 
applicable for Remote Control only.
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Viewing the Audit Log for Remote Management Sessions
ZfS records log information on a Windows NT/2000 managed server. 

To view the audit log for Remote Management sessions:

1 Click Start > Programs > Administrative Tools > Event Viewer.

2 Click Log > Application.

3 Double-click the event associated with the source Remote Management 
Agent.

To view only the events pertinent to the Remote Management Agent, choose 
Remote Management Agent from the source drop-down list in the Filter 
dialog box.

Improving the Remote Management Performance
The following instructions will help in improving the Remote Management 
performance:

Set the managed server screen resolution to either 640x480 or 600x800.

On Windows 2000, deselect the Enable Pointer Shadow option for 
optimal performance. 

To deselect Enable Pointer Shadow:

From the Windows desktop, click Start > Settings > Control Panel > 
double-click Mouse.

Click Pointers > deselect Enable Pointer Shadow.

The speed of the management console depends upon the processing 
power of the client machine. We recommended that you to use single-
processor client with a Pentium* III, 500MHz (or later).

At the managed server, use a plain background. Do not set a wallpaper 
pattern.

If the Task manager is opened at the target machine, you can close it or 
minimize it.

Make sure that the scrolling texts (such as the debug windows) and 
animations are not active on the managed server.

Make sure to minimize or close the dialog boxes that are not in use.

Use the Page Up and Page Down keys for scrolling through the contents.
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To perform any operations at the managed server, if possible, use the 
toolbar options instead of menu options.

To maximize remote management visibility, set the management console 
screen resolution higher than the managed server resolution.

If the optimization driver is disabled, set the color settings at managed 
server to 256 bit.

To maximize the Remote Management performance over WAN, do the 
following at the managed server:

Set the color mode of the managed server to 16 color.

Select the Slow Link Option.

Unloading and Reloading the Remote Management Agent
The following sections explain how you can use the Remote Management 
Agent during remote sessions:

“Unloading the Remote Management Agent” on page 1083

“Reloading the Remote Management Agent” on page 1084

Unloading the Remote Management Agent

You can unload the Remote Management Agent during a remote session. 
When you unload the Remote Management Agent, the remote session stops. 
To start another remote session, you will need to reload the Remote 
Management Agent. For more information, see “Reloading the Remote 
Management Agent” on page 1084. 

To unload the Remote Management Agent from a Windows NT managed 
server:

1 From the Control Panel, double-click Services.

2 Click Novell ZFS Remote Management Agent > Stop.

To unload the Remote Management Agent from a Windows 2000 managed 
server:

1 From the Control Panel, double-click Administrative Tools.

2 Double-click Services.

3 Click Novell ZFS Remote Management Agent > Stop.
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IMPORTANT: You will be able to stop the Remote Management Agent on Windows 
NT/2000 only if you have the rights to stop the service. 

Reloading the Remote Management Agent

During ZfS installation, the Remote Management Agent is installed on the 
managed server and started automatically when the managed server starts up. 
If you shut down the Remote Management Agent during a remote session, the 
remote session stops. To start another remote session, you need to reload the 
Remote Management Agent on the managed server.

To reload the Remote Management Agent on Windows NT:

1 From the Control Panel, double-click Services.

2 Click Novell ZFS Remote Management Agent > Start.
IMPORTANT: You will be able to load the Remote Management Agent on Windows NT 
only if you have the rights to start the Windows NT service.

To reload the Remote Management Agent on Windows 2000:

1 From the Control Panel, double-click Administrative Tools.

2 Double-click Services.

3 Click Novell ZFS Remote Management Agent > Start.
IMPORTANT: You will be able to load the Remote Management Agent on Windows 
2000 only if you have the rights to start the service.
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36 Documentation Content Changes

This section contains information on documentation content changes that have 
been made for Remote Management since the initial release of ZENworks® 
for Servers 3 (ZfS). The information will help you to keep current on changes 
to the documentation and, in some cases, the ZfS software (such as with a 
Service Pack release).

The information is grouped according to the date the documentation changes 
were published. Within a dated section, the changes are alphabetically listed 
by the names of the main table of contents sections for Remote Management.

The documentation is provided on the Web in two formats: HTML (standard 
Web help) and PDF. The Web help and PDF help are both kept up to date with 
the documentation changes listed in this section.

The documentation was updated on the following dates:

“May 17, 2002” on page 1085

May 17, 2002
Changes were made to the following section:

“Remote Management for Windows NT/2000 Servers” on page 1085

Remote Management for Windows NT/2000 Servers
The following change was made in this section:

Location Change

“Remote Management 
Terminology” on page 1059

Defined the term Viewing window.
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