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NetWare Migration Wizard 6 Administration Guide

Novell® NetWare® Migration Wizard 6 lets you copy data from a NetWare 
or a Windows* NT* server to another NetWare server in your network.

Migrating Data from NetWare 3—Migration Wizard copies the NetWare 3 file 
system and bindery objects to a destination NDS® tree. When the bindery 
objects are copied to the destination NDS tree, they are automatically 
converted to NDS objects.

Migrating Data from NetWare 4, 5, or 6—Migration Wizard migrates the file 
system and NDS database from a NetWare 4, NetWare 5, or NetWare 6 source 
server to a faster, more reliable NetWare destination server. After NDS is 
migrated, the destination server replaces and assumes the identity of the 
source server on the network. Valid destination servers must be ruuning 
NetWare 5.0, 5.1, or 6.

Migrating Data from Windows NT—Migration Wizard migrates NT domain 
users and local and global groups from a Windows NT 3.51 or 4 server to a 
destination NDS tree. During the migration, the NT users and groups are 
converted to NDS objects and placed in the destination NDS tree. NetWare 
Migration Wizard 6 also migrates NT shared folders to a NetWare file system 
while migrating and converting Windows NT permissions to NetWare trustee 
rights.

Documentation Conventions

In this documentation, a greater-than symbol (>) is used to separate actions 
within a step and items in a cross-reference path.

Also, a trademark symbol (®, TM, etc.) denotes a Novell trademark. An asterisk 
(*) denotes a third-party trademark.
NetWare Migration Wizard 6 Administration Guide 7
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1 Migrating Data from NetWare 3

Novell® NetWare® Migration Wizard 6 copies and consolidates your NetWare 
3 bindery and file system from one or more existing NetWare 3 servers to a 
destination NDS® tree. 

The following figure shows how the Migration Wizard manages the migration 
of data from multiple NetWare 3 servers to a destination NDS tree.

To migrate data from NetWare 3, complete the following tasks in the order 
they are listed.

1. “Meet System and Software Requirements” on page 10

2. “Run Novell NetWare Migration Wizard” on page 12

NetWare 3
Servers

Destination
NDS Tree

Windows 98
or

Windows NT 4.0/2000
Workstation

Data

NetWare
Migration

Wizard

files
volumes
objects
Migrating Data from NetWare 3 9
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3. “Verify Your Migration Project” on page 17

4. “Migrate Users and Data to the Destination NDS Tree” on page 17

5. “Perform Post-Migration Tasks” on page 20

Meet System and Software Requirements

� Log in to your destination NDS tree with a user that is listed in the bindery 
context of the destination NDS tree. Make sure the user has the 
Supervisor right to the destination servers that you are migrating file data 
to and three available user licenses. 

For more on how to enable the Supervisor right, see the ConsoleOneTM 
Documentation (http://www.novell.com/documentation).

� Make sure you have the Write right to all NDS containers and directories 
that are receiving data from NetWare 3.

Preparing the Workstation

� A Windows 98, Windows NT (4.0 or later), or Windows 2000 
workstation with 50 MB of available disk space.

IMPORTANT: NetWare Migration Wizard 6 does not run on a Windows 95 
workstation.

� The Windows 98 workstation must be running Novell ClientTM for 
Windows 98 version 3.3 or later.

� The Windows NT/2000 workstation must be running Novell Client 
for Windows NT/2000 version 4.8 or later.

To check your current Novell Client version, right-click the N icon on the 
workstation toolbar, and then click Novell Client Properties > Client. If 
you need to download the latest client, see the Novell Software 
Downloads Web site (http://www.novell.com/download).

� The IPXTM protocol running on your Novell Client workstation. Make 
sure that your client workstation has an IPX connection to your source 
server and destination tree. 
10 NetWare Migration Wizard Aministration Guide
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Preparing the Source Server

The source server is the existing server that contains the data that will be 
copied to the destination NDS tree.

� The source server must be running NetWare 3.11 or later.

Load the following NLMTM program at the server console of each 
NetWare 3 source server that you are planning to migrate:

� For NetWare 3.11, load TSA311.NLM

� For NetWare 3.12 and 3.2, load TSA312. NLM

� Use SYSCON to verify that you have the console operator right to the 
source server.

� Back up all data on the source server.

Preparing the Servers in the Destination NDS Tree

The destination NDS tree is the NDS tree that contains the servers that will 
receive the data migrated from the NetWare 3 source server. After data is 
copied from the source server, it appears in the destination NDS tree. 

Make sure that all the servers that you are migrating data to in the destination 
NDS tree have the following:

� NetWare 4, NetWare 5, or NetWare 6 installed.

NOTE: NetWare Migration Wizard 6 does not migrate to NetWare 4.10 servers.

� The IPX protocol running and bound to the network card of each NetWare 
server in the destination NDS tree that you are migrating files to.

WARNING: If IPX is not bound and running on the destination server, the file 
migration will fail. To check whether IPX is bound, enter CONFIG at the server 
console of the destination server.

Continue with the next section, "Creating a Template Object."

Creating a Template Object

This is an optional prerequisite task. A Template object is used to define 
additional NDS user attributes to NetWare 3 users during the migration. We 
recommend that you use a Template object because it is an organized way to 
migrate your NetWare 3 users to the NDS tree and manage them once they are 
there.
Migrating Data from NetWare 3 11
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If there is a conflict between the properties of a Template object and properties 
of a NetWare 3 user, the properties of the Template object will, in most cases, 
take priority. For example, if a minimum password length of seven characters 
is specified for the NetWare 3 user, Jeff, and a minimum password length of 
nine characters is specified in the Template object, then when Jeff’s object is 
migrated, the object will be created in NDS with a password length of nine 
characters. 

If you want to know what additional NDS attributes can be defined in a 
Template object, run ConsoleOne and double-click a Template object to view 
all of the existing properties.

The last name, full name, and description of every NetWare 3 object is always 
migrated and these corresponding properties from the Template object are 
overwritten.

If you decide to use a Template object, you can create one in ConsoleOne by 
clicking File > New > Object > Template.

Continue with the next section, "Run Novell NetWare Migration Wizard."

Run Novell NetWare Migration Wizard

1 Download and install NetWare Migration Wizard 6 from the NetWare 
section of the Novell Software Downloads Web site (http://
www.novell.com/download/). 

2 Run Migration Wizard from the location where you installed it.

The installation program, by default, installs Migration Wizard at this 
location: Start Menu > Programs > Novell > Netware Migration Wizard 
> NetWare Migration Wizard.

3 Read the Welcome screen and click OK.

4 Click Create a New Project > OK. 

5 Click NetWare 3 > OK.

6 Click the View Setup Tasks button. 

This launches your default Web browser and takes you to the NetWare 
Migration Wizard 6 online documentation.

7 Browse to Chapter 1, “Migrating Data from NetWare 3,” on page 9 and 
make sure you have completed the system and software requirements in 
"Meet System and Software Requirements." Then close your browser.
12 NetWare Migration Wizard Aministration Guide
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8 Click Next.

9 Name your migration project, choose a place to save it, and then click 
Next.

By default, Migration Wizard saves your project in C:\Program 
Files\Novell\NetWare Migration Wizard.

10 Select the source servers that you want to migrate.

Only servers that you are already logged in to appear in the Selected 
Servers text box. To log in to a server, click the Server icon. When you 
are finished selecting your servers, click Next.

11 Select your destination NDS tree and click Next.

12 Decide whether you want Migration Wizard to find any NetWare 3 and 
NDS User objects that have the same name, click Yes or No, and then 
click Next.

If you choose to do this, Migration Wizard will look for duplicate 
usernames in the destination NDS tree and on the NetWare 3 source 
servers. Migration Wizard will then display its findings and you can 
choose to merge the matching User objects.

13 To create and save your project, click Create. 

When a project is created and saved, Migration Wizard also creates 
success and error logs which contain the details of what took place during 
the migration.

14 If you clicked No in Step 12, skip the rest of these steps and continue with 
“Model Your Migration Project” on page 15. If you clicked Yes in Step 
12, continue with the next step.

15 Complete the following tasks:

15a Click the Browse button to select an NDS container on the 
destination NDS tree. 

Migration Wizard will search this container and all subcontainers for 
matching NDS usernames.

15b Browse the tree and select an NDS container, and then click OK.

15c Click Next to begin searching for duplicate usernames.

15d Decide how to handle duplicate usernames.

The following screen is an example of the username table in 
Migration Wizard. Carefully review this screen. If you do not make 
Migrating Data from NetWare 3 13
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any changes, Migration Wizard will automatically merge the 
NetWare 3 user with the displayed NDS user.

Figure 1 Merging Your NetWare 3 Users with Duplicate NDS Users

You have the following options for each NetWare 3 user:

� Merge the NetWare 3 user with the displayed NDS user 

Simply leave the NetWare 3 user displayed as it is in the table 
and continue with the next user.

� Merge an NDS user other than the currently displayed NDS user 

Click the arrow by the NDS username to view a drop-down list 
containing all the NDS users that have the same username 
(including contexts) as the adjacent NetWare 3 user. Select one 
of the NDS names and continue with the next NetWare 3 user.

� Do not merge any of the NDS users with the NetWare 3 user 

If you know that none of the listed NDS users represents the 
same person as the adjacent NetWare 3 user, click the arrow by 
the NDS username and then click Don’t Merge.
14 NetWare Migration Wizard Aministration Guide
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15e Once you have made a decision for each listed NetWare 3 user, click 
Finish.

The NetWare 3 users that you chose to merge with NDS User objects 
appear automatically as dropped objects in the destination NDS tree.

Continue with the next section, "Model Your Migration Project."

Model Your Migration Project

Most of your work will be done in the Project Window, where you can drag 
and drop NetWare 3 bindery objects and volume data into NDS containers in 
the destination NDS tree. 

The Project Window is a place to model different migration scenarios before 
you begin the actual migration. The source server’s bindery objects and 
volume data are shown in the left side of the Project Window, and the 
destination NDS tree is displayed in the right side of the Project Window. All 
of the planning in the Project Window is done offline, meaning that items 
moved and created in the Project Window are not actually moved or created 
until you begin the migration. 

The Project Window and the Using the Project Window dialog box appear 
once you have created the migration project. The following figure is an 
example of the Using the Project Window dialog box that appears on top of 
the Project Window.
Migrating Data from NetWare 3 15
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Figure 2 Using the Project Window Dialog Box

The three basic steps outlined in this dialog box should be performed for each 
migration project. Once you are familiar with the tasks that you will be 
performing, click Close to access the Project Window and begin modeling 
your migration.

Complete the following tasks:

1 Determine which NetWare 3 bindery objects and volume data will be 
copied to which containers in the destination server’s NDS tree.

2 If needed, create new objects in the destination NDS tree.

� To create a new NDS Organizational Unit (also called a container), 
right-click the parent of the Organizational Unit. 

� To create a new folder, right-click an existing folder or volume.

3 Drag and drop NetWare 3 bindery objects, folders, and volumes into NDS 
containers. 

Continue with the next section, "Verify Your Migration Project."
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Verify Your Migration Project

Once you have modeled your migration in the Project Window, you should 
verify that the proposed locations for these new objects do not conflict with 
existing names in the destination NDS tree. 

Remember, dragged-and-dropped items appearing in the NDS tree are merely 
assigned to be copied to that area in the NDS tree. Objects will not actually be 
migrated until you begin the migration.

Once you have modeled your migration project, you can run a standalone 
verification wizard or you can verify and migrate at the same time. Running 
the standalone verification wizard prior to migration is not mandatory; 
however, catching any critical errors or warnings before you begin your 
migration will speed up the verification process during the migration. 

1 To run the standalone verification wizard, click Project > Verify Project.

2 Follow the procedure in the next section “Migrate Users and Data to the 
Destination NDS Tree” on page 17, starting with "Step 2."

Migrate Users and Data to the Destination NDS Tree

Although you have selected the volumes and containers where the NetWare 3 
data will be copied, no data has been migrated. When migrated, NetWare 3 
User objects are converted to NDS objects and placed in the destination NDS 
tree. To begin the migration, do the following:

1 From the Migration Wizard toolbar, click Project > Verify and Migrate 
Project.

IMPORTANT: If you are notified during the verification that certain NLM files are 
outdated on your NetWare 3 source server, you must update those files. To update 
the files, copy them from the Products\NW3X directory. It is important that you copy 
only the NLM files that Migration Wizard prompts you to. After copying the NLM 
files, reboot the NetWare 3 source server and launch Migration Wizard again.

The Products\NW3X directory is located in the same directory where Migration 
Wizard was installed (C:\Program Files\Novell\Novell NetWare Migration 
Wizard\Products\NW3X).

2 Read the Welcome Screen and then click Next.

3 (Conditional) If you are migrating more than one server, choose the order 
that you want your servers migrated in and then click Next.

This matters only if you have duplicate User objects among your source 
servers. 
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4 If prompted, select what volume you want to migrate your NetWare 3 
print queue volume to, and then click Next.

5  If you want to apply a Template object to newly created users, browse the 
tree, select the Template object from the tree view and then click Next. 

If you do not want to use a Template object, uncheck the check box and 
click Next.

IMPORTANT: Home directories are not automatically migrated. To migrate them, 
you must drag and drop the NetWare 3 directory that lists the home directories into 
the destination NDS tree. Then use a Template object when migrating your 
NetWare 3 users to the destination NDS tree and make sure that the specified 
home directory path in the Template object points to the location where you 
dropped the NetWare 3 directory in the destination NDS tree.

HINT: If you have not created a Template object but you want to use one now, 
save the project, go to ConsoleOne, and create the Template object. Next, run 
Migration Wizard again and click Open Last Project. Then restart the migration 
procedure beginning with "Step 1 on page 17."

6 Decide how you want to handle any duplicate filenames between the 
NetWare 3 source servers and the destination NDS tree. Select one of the 
following and then click Next:

� Don’t Copy Over Existing Files 

� Copy the Source File If It Is Newer

� Always Copy the Source File

7 If you are migrating this NetWare 3 server for the first time, click Yes > 
Next. If you are continuing with a previous migration, click No > Next. 

When you migrate users and groups from NetWare 3, Migration Wizard 
stores a table in the bindery of each source server of the NDS names that 
it associates with the migrated NetWare 3 users as they are migrated to the 
destination NDS tree. This way, you can migrate a few users at different 
times and Migration Wizard will remember where you migrated them to. 
Also, by storing this information, Migration Wizard can assign the correct 
file permissions to the appropriate users.

8 Enter the password for the destination NDS tree and click Next.

9 Enter the password for the source server that you are migrating and then 
click Next.

If you are migrating multiple servers at one time, you will see this screen 
for every source server that you are migrating.
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10 Click Next to verify that you have enough disk space on the destination 
volume to accommodate your NetWare 3 file system.

Migration Wizard will also scan the contents of all dropped folders and 
verify that you have sufficient rights to migrate them. 

11 If prompted, resolve any naming conflicts between different-type objects, 
and then click Next.

You can choose to rename different-type objects or to not migrate them. 
If you are migrating multiple servers at one time, you will see this screen 
for every source server that you are migrating.

12 If prompted, resolve any naming conflicts between same-type objects, 
and then click Next.

You can choose to merge same-type objects or to not migrate them. If you 
are migrating multiple servers at one time, you will see this screen for 
every source server that you are migrating.

13 Verify that you do not want to migrate the listed NetWare 3 users, and 
then click Next. 

You will see this screen for every source server that you are migrating. If 
you have made a mistake, click Cancel to return to the Project Window 
and drag and drop the users that you want to migrate. 

14 Verify that you do not want to migrate the listed NetWare 3 groups, and 
then click Next.

You will see this screen for every source server that you are migrating. If 
you have made a mistake, click Cancel to return to the Project Window 
and drag and drop the users that you want to migrate.

15 Resolve any critical errors and click Next. 

Warnings, or noncritical errors, can be resolved after the migration. To 
resolve a critical error or warning, read the description in the text field 
located beneath it. This description should give you a good idea of what 
could be the possible cause of the error and a suggestion for fixing it. 

16 Do one of the following: 

� If you are only verifying your project at this point, read the 
Verification Summary, click Finish, and follow the instructions in 
“Migrate Users and Data to the Destination NDS Tree” on page 17 to 
begin the actual migration.

� If you are actually migrating at this point, read the Verification 
Summary and click Proceed to start the actual migration.
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17 (Migration only) View the Error Log and the Success Log.

Continue with the next section, "Perform Post-Migration Tasks."

Perform Post-Migration Tasks

After you’ve migrated the bindery objects and file system to the destination 
server, complete the following tasks:

� Modify the print configuration if you want to convert your queue-based 
printing to NDPS®.

For more information, see the Novell Documentation Web site (http://
www.novell.com/documentation/lg/nw51/docui/index.html) > 
Additional Documentation > Print Services > Novell Distributed Print 
Services.

� Make sure that applications have migrated correctly.

After migration, if you want to install additional network products and 
services, you can do so from the servertop by clicking the Novell icon > 
Install.

� Make sure that each migrated user has the correct Novell Client 
properties to log in to the destination NDS tree.

� Modify user login scripts to accommodate the new location of data in the 
NDS tree.

For more information, see the Novell Documentation Web site (http://
www.novell.com/documentation/lg/nw51/docui/index.html) > 
Additional Documentation > Novell Clints > Novell Client for Windows 
> Setting Up Client Login > Setting Up Login Scripts.

� Reassign home directories if they were not migrated.
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2 Migrating Data from NetWare 4, 5, or 6

When you migrate data from a NetWare® 4, NetWare 5, or NetWare 6 source 
server to a NetWare destination server, Novell® NetWare Migration Wizard 6 
copies the file system and NDS® database from the source server to the newly 
installed NetWare destination server. 

After the source server’s file system and NDS database is migrated to the 
destination server, the source server is automatically brought down and the 
destination server reboots and assumes the name and identity of the source 
server on your existing network.

Before you can migrate your data, you must first install a destination NetWare 
server in a temporary NDS tree. A temporary tree is simply a tree that contains 
one server with a basic installation of NetWare and no additional products 
installed (other than SMSTM or any other default products). 

Source Server

Temporary
Server Name

Temporary
NDS Tree

replaces
and 

assumes
the identity

of

Existing
NDS Tree

NetWare
Destination Server
Migrating Data from NetWare 4, 5, or 6 21

NetWare Migration Wizard Aministration Guide
103-000161-001
August 13, 2001

Novell Confidential



Manual Rev 99a38 July 17, 2001
To migrate data from NetWare 4, NetWare 5, or NetWare 6, complete the 
following tasks in the order they are listed.

1. “Meet System and Software Requirements” on page 22

2. “Run Migration Wizard” on page 25

3. “Perform Post-Migration Tasks” on page 32

Meet System and Software Requirements

Preparing the Workstation

Make sure your workstation has the following:

� A Windows 98 or Windows NT 4/2000 workstation with 50 MB of 
available disk space.

� The Windows 98 workstation must be running Novell ClientTM for 
Windows 98 version 3.3 or later.

IMPORTANT: NetWare Migration Wizard 6 does not run on Windows 95 
workstations.

� The Windows NT 4/2000 workstation must be running Novell Client 
for Windows NT version 4.8 or later.

� If migrating from NetWare 4, the IPXTM protocol should be configured on 
your Novell Client workstation.

� For better performance, it is strongly recommended that the source server, 
destination server, and client workstation be running on a common LAN 
segment.

Preparing the Source Server

The source server is the NetWare server that contains the files, volumes, and 
NDS objects that will be copied to the NetWare destination server. Valid 
source servers can be running NetWare 4.11, 4.2, 5.0, 5.1, or 6.

� Use ConsoleOneTM to verify that you have the Supervisor right to the 
source server’s file system and the source server itself.

� Update the source server with the latest NetWare Support Pack. 

Updates are available at the Consolidated Support Pack Home Page 
(http://support.novell.com/csp/csplist.html).
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� (Conditional) If you are migrating data from NetWare 4, make sure that 
the source server’s volumes are running long name space support on all 
volumes to be copied. 

To add long name space support to a NetWare 4.11 or NetWare 4.2 
volume, enter the following at the server console: LOAD LONG and then 
ADD NAME SPACE LONG TO volumename. 

� Load DSREPAIR and run the following three options:

� Unattended Full Repair

� Time Synchronization

� Report Synchronization Status

Make sure that these finish with no errors.

� Back up NDS and all data.

Preparing the Destination Server

The destination server is the new computer that will receive the data from the 
source server. This server must be installed into a temporary tree. 

After data is migrated from the source server to the destination server, the 
destination server reboots and Migration Wizard automatically modifies the 
destination server’s AUTOEXEC.NCF file to include the source server’s 
name and internal IPXTM number/server ID. You don’t have to modify these  
manually.

Valid destination servers can be running NetWare 5.0, 5.1, and 6. Migration 
Wizard does not migrate to NetWare 4 destination servers.

Review the following tasks before installing the NetWare operating system on 
the destination server:

� Use ConsoleOne to verify that you have the Supervisor right to the 
destination server’s file system and the destination server itself.

� Make sure you create a temporary NDS tree with a temporary NDS tree 
name.

IMPORTANT: The temporary name and temporary NDS tree name must not be 
the same as the source server’s name or NDS tree name; otherwise, the 
destination server will not assume the identity of the source server after the 
migration.
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� During the installation, create volumes on the destination server that are 
the same size as, or larger than, volumes on the source server.

Volume names on the destination server must be the same as the volume 
names on the source server. 

Migration Wizard migrates compressed volumes. If you are migrating 
compressed volumes to uncompressed volumes, Migration Wizard 
decompresses the volumes during the migration. Make sure you have 
enough room on the uncompressed volume to accommodate the source 
volumes once they are decompressed.

� If migrating from NetWare 4, install and configure the IPX protocol.

The IPX protocol must be bound to the destination server for the 
migration to work. (You can remove IPX after completing the migration.)

IMPORTANT: IP addresses for the source server will not be migrated. For more 
information on changing your IP addresses, see "Step 3 on page 28."

� Install the destination server with the NetWare operating system that you 
are migrating to. 

� For instructions on installing NetWare 5, see the NetWare 5 
Overview and Installation Guide (http://www.novell.com/
documentation/lg/nw5/docui/index.html). 

Make sure that you select the New Server option on the Additional 
Products and Services screen during the NetWare 5 installation, and 
deselect all products except SMS.

� For instructions on installing NetWare 5.1, see the NetWare 5.1 
Installation Guide (http://www.novell.com/documentation/lg/nw51/
docui/index.html).

Make sure that you select the custom option on the Installation 
Options screen during the NetWare 5.1 installation, and deselect all 
deselectable products except SMS. Don’t worry about any default 
products that you can’t deselect.

� For instructions on installing NetWare 6, see "Installation 
GuideSetting Up NetWare 6 in the NetWare 6 "Installation Guide".

Make sure that you select the Pre-migration server option during the 
NetWare 6 installation. And then select the custom option so that you 
can verify that you have enough room on your destination server to 
accomodate your source server data.

Continue with the next section, "Run Migration Wizard."
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Run Migration Wizard

1 Download and install NetWare Migration Wizard 6 from the NetWare 
section of the Novell Software Downloads Web site (http://
www.novell.com/download).

2 Run Migration Wizard from the location where you installed it. 

The installation program, by default, installs Migration Wizard at this 
location: Start Menu > Programs > Novell > Netware Migration Wizard 
> NetWare Migration Wizard. 

3 Read the Welcome screen and click OK.

4 Click Create a New Project > OK.

5 Click NetWare 4, 5, or 6 > OK.

6 Click the View Setup Tasks button. 

This launches your default Web browser and takes you to the NetWare 
Migration Wizard 6 online documentation.

7 Browse to Migrating Data from NetWare 4, 5, or 6 and make sure you 
have completed the system and software requirements in "Meet System 
and Software Requirements." Then close your browser.

8 Click Next.

9 Name the project, choose a place to save it, and then click Next.

By default, Migration Wizard saves all projects to C:\Program 
Files\Novell\NetWare Migration Wizard.

10 Select the NDS tree that contains your source server and click Next. 

11 Select your source server from the NDS tree and click Next.

12 Select the NDS tree that contains your destination server and click Next.

13 Select your destination server from the destination NDS tree and click 
Next. 

14 To save your project and access the Project Window, click Create.

The Project Window now appears.

Continue with the next section, "Copy Volumes."
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Copy Volumes

1 In the Project Window, click Copy Volumes.

Before Migration Wizard starts copying files, it backs up your directory 
and file trustees and saves them in files located on the source and the 
destination server. Once the NDS migration is complete, Migration 
Wizard restores the trustees from the files it stored on the destination 
server.

You do not need to copy all volumes at once. You can select volumes to 
copy now and then copy other volumes later by reopening the project file. 
Remember that open files are not migrated. 

IMPORTANT: If you choose to copy your volumes in phases, at the final volume 
copy, make sure you select all volumes that you previously copied and then click 
Cancel. Otherwise, Migration Wizard will restore trustee assignments only to the 
last volumes that were copied.

2 Select each volume name from the text field and then click Yes or No. 

If you decide not to copy any of the volumes, select No for all volumes, 
click Next, and then continue with “Edit Configuration Files” on page 28. 
If you selected Yes for one or more of the volumes, continue with "Step 
3."

If you have big volumes or slow LAN connections, or if you want to 
reconfigure your data by putting existing directories into different folders 
on the destination server, you should consider using a backup tape to copy 
your volumes.

IMPORTANT: If you using tape backup, do not restore the source server’s 
standard SYS: directories to the destination server if you are upgrading your 
NetWare operating system to a higher version. The standard SYS: directories, like 
SYS:SYSTEM and SYS:PUBLIC, were created for you during the NetWare 
installation. 

If you are only migrating your existing data to new hardware and keeping the same 
version of NetWare, restore the source server’s standard SYS: directories to the 
destination server.

If you decide to use tape backup, select No for all volumes on the Select 
Volumes to Copy screen, click Next, and continue with “Edit 
Configuration Files” on page 28.

3 Decide if you want to copy the source server’s SYS: directories to the 
destination server’s SYS:MIG directory, and then click Next. 
26 NetWare Migration Wizard Aministration Guide

NetWare Migration Wizard Aministration Guide
103-000161-001
August 13, 2001

Novell Confidential



Manual Rev 99a38 July 17, 2001
Migration Wizard never overwrites the SYS: directories on the 
destination server. If you choose to migrate the source server’s SYS: 
directories, Migration Wizard migrates them to the SYS:SYS.MIG 
directory on the destination server. 

If there are files in the source server’s SYS: directories that you want to 
utilize on the destination server, after the NDS migration is completed, 
copy the files from the SYS:SYS.MIG directory into the appropriate 
SYS: directory on the destination server. 

Remember, any applications that have NLM programs in this directory 
will need to be reinstalled after the migration.

4 Decide how you want to handle any duplicate filenames between the 
source server and the destination NDS tree. Select one of the following 
and then click Next:

� Don’t Copy Over Existing Files 

� Copy the Source File If It Is Newer

� Always Copy the Source File

5 Determine how you would like to copy your volumes and then click Next. 

You have the following two choices:   

� Copy volumes with users logged in

� Disable login  

Migration Wizard does not copy open files. If you disable user login, you 
can be sure that no other users will log in to the network and open files 
during the file copy.

6 Enter the passwords for the source and destination trees, and then click 
Next.

7 If prompted, resolve any critical errors or warnings, and then click Next.

8 To copy the file system to the destination NDS tree, click Migrate.

9 Review the error and success logs, and then click Done.

Continue with the next section, "Edit Configuration Files."
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Edit Configuration Files

1 In the Project Window, click Edit Configuration Files.

Migration Wizard lets you modify any .NCF or .CFG files on the 
destination server. These files contain default LOAD statements and 
parameters.

IMPORTANT: If you are editing your AUTOEXEC.NCF, make sure the file is 
closed before you migrate your NDS database. 

2 In the text box, select the configuration file that you want to edit and then 
click Edit File.

3 Copy and paste the commands from the configuration file on the source 
server to the corresponding configuration file on the destination server. 
When you are finished, click Save & Close. 

If you intend to change the IP address on your destination server to be the 
same as the IP address of your source server, you must edit your 
configuration files and change the IP address in two places: 
AUTOEXEC.NCF and SYS:ETC/HOSTS.

Copy the source server’s IP address and paste it into the destination 
server’s AUTOEXEC.NCF file. (This works only if your IP LOAD and 
BIND statements are located in the AUTOEXEC.NCF.) You also need to 
go to the server console of the destination server and change the IP 
address in the SYS:ETC\HOSTS file. Look for the original name of the 
destination server.

If you use INETCONFIG to assign IP addresses, change the IP addresses 
after the migration is complete.

4 (Conditional) If you are using configured time sources 
(TIMESYNC.CFG), then copy and paste your timesync information from 
the source server’s TIMESYNC.CFG file to the destination server’s 
TIMESYNC.CFG file.

5 Close the Compare Configurations dialog box.

Continue with the next section, "Begin NDS Migration."
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Begin NDS Migration

1 In the Project Window, click Begin NDS Migration.

2 Back up all volumes that you are not planning to migrate and complete 
the following tasks before continuing:

� Make sure all volume data migrated successfully.

� Make sure all critical errors from the file copy are resolved.

� Make sure the servers in your source NDS tree are in time sync and 
that NDS is synchronized. For more information, see Step 2 on page 
31.

3 Click Next.

4 Insert the licensing diskette, browse to or enter the path to the licensing 
file, and then click Next. 

If you have an MLA, you also have the option of selecting the MLA 
instead of inserting the licensing diskette.

5 Select Yes or No to update the source server’s schema.

Migration Wizard will update the source server’s schema to include the 
NDS classes of the default applications that are installed on the 
destination server.

If you select No, by default the Yes radio button is enabled, which causes 
Migration Wizard to compare the source and destination schemas. This 
comparison will help you determine how to extend your schema in 
preparation for the migration.

6 Before continuing, verify that you have run the DSREPAIR procedures in 
"Step 2 on page 31" to verify that the NDS tree containing the source 
server is functioning correctly, click Yes or No to acknowledge that your 
tree is healthy, and then click Next. 

Migration Wizard does not prevent you from continuing if you have not 
run DSREPAIR to verify the health of your tree. However, if your tree is 
unhealthy before you begin the migration, the migration might not 
complete successfully. 

7 If you are migrating from NetWare 4 running Border Manager, NetWare 
5, or NetWare 6, you will be prompted to copy and transfer the NICI 
configuration files from the source server to the destination server. Just 
follow the on-screen instructions and when the NICI configuration is 
complete, continue with the next step. 
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IMPORTANT: If you are getting NICI errors when NDS is trying to load or when 
you are copying the NICI files, you should first check and see if PKI.NLM will load 
on the destination server. If PKI.NLM won’t load, see “NICI Errors” on page 55.

8 Delete all user connections (except your own) to the source and 
destination servers, and then click Next.

9 Enter the passwords for the source and destination trees, and then click 
Next.

10 Resolve any critical errors or warnings on the Migrate NDS Verification 
Results screen, and then click Next.

11 Click Migrate to begin the NDS migration.

At the end of this the migration process, the source server is brought down 
and the destination server reboots and takes over the name and identity of 
the source server. 

Migration Wizard automatically modifies the following items in the 
destination server’s AUTOEXEC.NCF file:

� The file server name is changed to the name of the source server

� The time zone is changed to the time zone stored in the source 
server’s AUTOEXEC.NCF file

� The server ID is changed to the IPX internal net value or server ID 
stored in the source server’s AUTOEXEC.NCF file

� The default time server type is changed to the value stored in the 
source server’s AUTOEXEC.NCF file

� The bindery context is changed to the bindery context stored in 
source server’s AUTOEXEC.NCF file

IMPORTANT: During the migration, the source server’s timesync information is 
not automatically migrated.

12 View the Error and Success logs, and then click Done.

Use the Error Log to see a listing of all errors that occurred during the 
migration. If there were errors, use the Success Log to determine how far 
the migration got before the error occurred.

If the NDS migration failed, see “NDS Migration” on page 56 for 
instructions on how to restore your servers to their original configuration.

13 Check the former destination server and verify that it has restarted and 
taken on the name of the source server.
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14 Reboot your workstation and log in to the former destination server. 

If you can’t log in,  refer to “Workstation-to-Server Connections” on page 
52.

Continue with the next section, "Finish NDS Migration."

Finish NDS Migration

1 In the Project Window, click Finish NDS Migration.

2 Read the Continue NDS Migration screen and make sure that 

� The former destination server has restarted and taken on the name 
and identity of the source server

� Licensing is installed

� NDS is synchronized on all servers in the tree

To check NDS synchronization status, enter DSREPAIR at the server 
console and run the Report Synchronization Status and Time 
Synchronization options. 

If the destination server does not contain a Read/Write or Master 
replica, you must check NDS synchronization by running 
DSREPAIR on another server in the NDS tree that has one of these 
replicas.

3 Click Yes or No to verify that you have completed the tasks in "Step 2," 
and then click Next.

4 Enter the password for the source tree and click Next.

5 Resolve any warnings or errors and click Next.

6 To finish the NDS migration, click Continue.

During this stage, Migration Wizard is restoring the file trustees and 
updating the Volume objects in the tree.

7 View the error and success logs, and then click Done to close the current 
project.

Continue with the next section, "Perform Post-Migration Tasks."
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Perform Post-Migration Tasks

1 Run DSREPAIR on the destination server and select Unattended Full 
Repair.

2 Make sure that user information migrated successfully.

3 Reinstall any applications that have files or NLM programs associated 
with the following volume SYS: directories: SYSTEM, PUBLIC, MAIL, 
ETC, and NETBASIC.

IMPORTANT: Because the source server’s identity will replace the destination 
server, all NDS objects on the destination server, including those representing 
applications, are removed and replaced by the NDS objects that exist on the 
source server. However, the NLM programs associated with the destination 
server’s applications will still exist. Because you cannot manage applications 
without their corresponding NDS objects, you must reinstall the applications to 
restore their NDS objects to the NDS tree.

If your destination server was running NetWare 5.1, you might see warnings on 
your server referring to SMS, LDAP, Novell Certificate Server, or NetWare 
Management Portal. Just ignore the warnings and reinstall the products after NDS 
has been migrated. 

To reinstall these network products and services, go to the NetWare 
Deployment Manager utility (NWDEPLOY.EXE) located on the 
NetWare Operating System CD, or go to the GUI interface and click the  
Novell icon on the servertop. 

4 Install the latest NetWare Support Pack.

This will ensure that you get the latest code for the applications that you 
are reinstalling. The latest Support Packs are available at the Novell 
Support Web site (http://www.support.novell.com/misc/patlst.htm).

5 Run DSREPAIR > Time Synchronization to verify that your source server 
is synchronized with the rest of your servers. 
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3 Migrating Data from Windows NT 

Novell® NetWare® Migration Wizard 6 automates key tasks, such as 
migrating users and their file permissions, assigning passwords, and migrating 
the NT file system to a designated NDS® tree. This automation eliminates the 
need to choose from various utilities that would help you perform these tasks 
individually.

Although many tasks are automated in Migration Wizard, you should consider 
the following issues before you get started.

First, you should plan your migration by answering the following questions:

� Which NT users are accessing which NT files and directories, and where 
are those files and directories located?

Windows NT 3.51/4
Server

NetWare
Server

Windows  NT 4.0 Workstation,
Windows NT 2000 Workstation,

or Windows NT 4.0 Server

Data

NetWare
Migration
Wizard

File System
and

NT Objects
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This information will help you decide which NT servers to migrate first 
and how many servers you will need to migrate at one time. When you 
migrate your users and groups, you will want to migrate all files and 
directories that they have access to at the same time that you migrate their 
User objects.

� Which NetWare servers and volumes are you going to migrate your NT 
folders to? 

You should plan which servers and volumes in your destination NDS tree 
will receive each of your NT folders. You can select a separate location 
for each NT folder, if desired. In order to plan effectively, you will need 
to become familiar with the file structure on the NetWare servers in your 
destination NDS tree.

� Which NT users and groups are you going to migrate? Which NDS 
containers on the destination NDS tree are you going to migrate them 
into?

Decide which NT user and groups you are going to migrate, and then 
determine whether you will need to create separate containers for your 
NT users and groups in the destination NDS tree. When you model your 
migration in the Project Window, you can create any additional NDS 
containers you might need by right-clicking an NDS Organizational Unit.

� Do any existing NDS User objects represent the same person in your NT 
domain?

Determine whether any of your NT users already have an NDS account. 
During the migration you will be asked if you want to search the NDS tree 
for duplicate usernames. When Migration Wizard finds identical 
usernames, it will display these in a table where you can choose to merge 
the listed NT user with a NDS User object. 

� What will you do with any applications that do not run on NetWare?

Migration Wizard does not migrate applications. After the migration, you 
will have to reinstall your applications. If you have some applications that 
do not run on NetWare, you can keep an NT server intact and use it as an 
application server. 

� How do you want to migrate information about your users and groups? 
Do you want to use a Template object, ZENworksTM User Policy 
Packages, or both?

For information, see “Creating a Template Object” on page 36 and  
“Creating ZENworks User Policy Packages” on page 37.
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� Do you have any trusted domains?

If so, you must reassign any trusted domain permissions to the 
appropriate NT user and groups after the migration is complete. Use 
ConsoleOneTM to reassign all lost trusted domain permissions.

Once you have planned your migration, you’re ready to begin your NT 
migration. Complete the following tasks in the order they are listed.

1. “Meet System and Software Requirements” on page 35

2. “Perform Prerequisite Tasks” on page 36

3. “Run Migration Wizard” on page 39

4. “Model Your Migration Project” on page 42

5. “Verify Your Migration Project” on page 45

6. “Migrate Users and Data to the Destination NDS Tree” on page 46

7. “Perform Post-Migration Tasks” on page 50

Meet System and Software Requirements

You can run Migration Wizard either from the Windows NT 4 server that you 
are migrating data from or from a Windows NT 4 or Windows 2000 
workstation. However, the migration is faster if you run Migration Wizard  
from the server rather than from the workstation because the files are copied 
directly from server-to-server rather than via the client workstation. 

Make sure you have the following NT permissions:

� Write/Modify permission to the NT Domain and the Registry of the PDC

� Read permission to all folders and files you are migrating

� Log in to the NT domain with a user that has administrative rights to the 
NetWare destination server

Make sure you have the Supervisor right to the NetWare destination server.

The following table lists the hardware and software requirements for the 
workstation or server that you are using to run Migration Wizard.
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To check the Microsoft Service Pack version, click Start > Run, type winver 
in the text field, and then click OK. To download and install Microsoft Service 
Packs, see the ZDNet Web site (http://updates.zdnet.com/products/
pr_13616.htm).

To check your current Novell Client version, right-click the N icon on your 
workstation and click Novell Client Properties > Client. To download the 
Novell Client, see the Novell Download Web site (http://www.novell.com/
download).

Continue with the next section, "Perform Prerequisite Tasks."

Perform Prerequisite Tasks

Creating a Template Object

The first prerequisite task is to determine whether you want to use a Template 
object to migrate your NT users to the destination NDS tree.

A Template object is used to define additional NDS User attributes for NT 
users during the migration. Template objects are especially useful for defining 
additional attributes that are not found in the Windows NT domains. We 
recommend that you use a Template object because it is an organized way to 
migrate your NT users to the NDS tree and manage them once they are there.

IMPORTANT: In order to migrate home directories, you must use a Template 
object.

Platform Hardware Software

Windows NT 4 and 
Windows NT 2000 
workstations

Minimum hardware 
requirements of 
Windows NT 4 and 2000 
workstations

Novell ClientTM for 
Windows NT 4 and 2000 
version 4.8 or later

Microsoft* Service Pack 
6 or later

Windows NT 4 server Minimum hardware 
requirements of 
Windows NT 4

Novell Client for 
Windows NT version 4.8 
or later

Microsoft Service Pack 
6 or later
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If there is a conflict between the properties of a Template object and an NT 
policy, the properties of the Template object will, in most cases, take priority. 
For example, if a minimum password length of seven characters is specified 
for user Jeff in an NT policy and a minimum password length of nine 
characters is specified in the Template object, then when Jeff’s object is 
migrated, the object will be created in NDS with a password length of nine 
characters. 

If you want to know what additional NDS attributes can be defined in a 
Template object, run ConsoleOne and double-click a Template object to view 
all of the existing properties.

The last name, full name, and description of every NT object is always 
migrated and these corresponding properties from the Template object are 
overwritten. 

If you decide to use a Template object, you can create one in ConsoleOneTM 
by clicking File > New > Object > Template.

Creating ZENworks User Policy Packages

The next prerequisite task is to decide whether to use ZENworksTM User 
Policy Packages.

ZENworks User Policy Packages help control the appearance and 
functionality of a user’s desktop. Migration Wizard associates ZENworks 
User Policy Packages only with groups.

If you decide to use ZENworks, you can determine the appearance of all 
workstations belonging to the users associated with a particular NDS group. 
When you associate a ZENworks User Policy Package with an NDS group, 
the properties you apply in the policy package allow you to control 
workstation attributes by setting a certain workstation backdrop, restricting 
rights to the control panel, and modifying the workstation’s sound and color 
scheme for users within that group.

NOTE: Migration Wizard does not migrate Microsoft NT 3.51 roaming profiles.

If you want to use ZENworks, install ZENworks Full 2.0 in your destination 
NDS tree. ZENworks Full 2.0 can be installed from the NetWare 5.0 or 5.1 
product CD. ZENworks 3.0 is not supported.

To create ZENworks User Policy Packages in ConsoleOne, do the following:

1 In NetWare Administrator, right-click an NDS Organizational Unit in the 
tree view and then click Create > Policy Package.
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The type of workstation you have in your NT network (Windows NT/
2000, Windows 95/98, or both) will determine whether you want to create 
WINNT-2000 user policy packages, WIN 95-98 policy packages, or both. 

2 In ConsoleOne, click the user policy package icon in the toolbar. If you 
don’t know which icon it is, mouseover the icons to see a short 
description.

For more information about installing and using ZENworks, see the Novell 
Product Documentation Web site (http://www.novell.com/documentation).

Registering the Workstation

If you are running Migration Wizard from a workstation, make sure that the 
workstation is registered within the domain that you want to migrate. If it is 
registered properly, continue with “Run Migration Wizard” on page 39. 

If you want to change the domain that your workstation is registered in, 
complete the following instructions for Windows NT or Windows 2000.

IMPORTANT: Migration Wizard does not run on a Windows 95 workstation.

Windows NT Workstations

1 At the workstation, right-click Network Neighborhood and then click 
Properties.

2 Click the Identification tab and then click Change > Domain. 

3 Specify the appropriate domain, enter your Administrator name and 
password, and then click OK.

4 Reboot the workstation and launch Migration Wizard again; then 
continue with the next section, "Run Migration Wizard."

Windows 2000 Workstations

1 At the workstation, right-click My Network Places, and then click 
Properties.

2 Click the Network Identification link.

3 Click Properties and enter the computer name and appropriate domain, 
and then click OK.

4 Reboot the workstation and launch Migration Wizard again; then 
continue with the next section, "Run Migration Wizard."
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Run Migration Wizard

1 Download and install Migration Wizard from Novell Software 
Downloads (http://www.novell.com/download) > NetWare > NetWare 
Migration Wizard 6 or from the NetWare 6 Operating System CD. Follow 
the download and installation instructions.

2 Launch Migration Wizard from the Start menu by clicking Programs > 
Novell > NetWare Migration Wizard > NetWare Migration Wizard.

3 Click Create a New Project > OK. 

4 Click Microsoft Windows NT 3.51/4 Server > OK.

5 Click the View Setup Tasks button. 

This launches your default Web browser and takes you to the NetWare 
Migration Wizard 6 online documentation.

6 Make sure you have completed the system and software requirements in 
“Meet System and Software Requirements” on page 35 of the online 
documentation. Then close your browser.

7 Click Next.

8 Verify that the NT domain that appears in the grayed-out text field is the 
domain that you want to migrate.

Migration Wizard automatically displays the NT domain that your 
workstation or server is a member of. 

If you are running Migration Wizard from a workstation, you can change 
the domain that it is registered in. To do this, exit Migration Wizard and 
follow the instructions in “Registering the Workstation” on page 38.

9 Name your migration project, choose a place to save it, and then click 
Next.

By default, Migration Wizard saves your project in C:\Program 
Files\Novell\NetWare Migration Wizard.

10 Select your destination NDS tree from the drop-down list and then click 
Next. 

The destination NDS tree is the NDS tree that you want to migrate your 
NT data to.

If you are not logged in to your NDS tree, the NDS tree name will not 
appear in the drop-down list. If this is the case, click the Browse button to 
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log in to your NDS tree. Once you are logged in, the NDS tree name 
automatically appears in the drop-down list.

11 Decide whether you want Migration Wizard to find any User objects in 
your NT domain and in the destination NDS tree that have the same name, 
and then click Yes or No.

12 Click Create to create and save your migration project.

When a project is created and saved, Migration Wizard creates a file that 
contains the success and error logs of your project; these logs contain the 
details of what took place during the migration.

13 (Conditional) If you clicked Yes in "Step 11," continue with Step 13a. If 
you clicked No, skip the rest of the steps in this procedure and go to 
“Model Your Migration Project” on page 42.

13a Click the Browse button to select an NDS container on the 
destination NDS tree.

13b Browse the tree and select an NDS container, and then click OK.

13c Click Next to begin searching for duplicate usernames.

13d Decide what you want to do with NT users that have the same name 
as NDS users.

The following screen is an example of the username table in 
Migration Wizard. Carefully review this screen. If you do not make 
any changes, Migration Wizard will automatically merge the 
displayed NDS user with the adjacent NT user.
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Figure 3 Merging Your NT Users with Duplicate NDS Users

You have the following options for each listed NT user:

� Merge the NT user with the displayed NDS user. Simply leave 
that user as it is displayed in the table and continue with the next 
listed NT user.

� Merge an NT user with a different NDS user. Click the arrow by 
the NDS username to view a drop-down list containing all the 
NDS users that have the same username (including contexts) as 
the adjacent NT user. Select one of the NDS names and continue 
with the next listed NT user.

� Do not merge the NT user with any of the matching NDS users. 
Right-click the NDS user and click Don’t Merge. Select this 
option if you know that none of the listed NDS users represents 
the same person as the adjacent NT user.

13e Once you have made a decision for each listed NT user, click Finish.

The Project Window will now appear and the NT users that you 
chose to merge with NDS User objects appear automatically as 
dropped objects in the destination NDS tree. 

Continue with the next section, "Model Your Migration Project."
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Model Your Migration Project

Most of your work will be done in the Project Window, where you can drag 
and drop NT User and Group objects into NDS containers, and NT folders and 
volumes into any volume or folder in the destination NDS tree.

The Project Window is a place to model different migration scenarios before 
you begin the actual migration without affecting your NT domain or your 
destination NDS tree. All of the planning in the Project Window is done off-
line, meaning that items moved and created in the Project Window are not 
actually moved or created until you begin the migration. 

HINT: For information on shared NT folders that end with a dollar sign ($), click 
anywhere on your Windows desktop, press F1, click the Index tab, and then enter 
$shares in the keyword text field. 

The Project Window and the Using the Project Window dialog box appear 
once you have created the migration project.

The following figure is an example of the Using the Project Window dialog 
box that appears on top of the Project Window. 

Figure 4 Using the Project Window Dialog Box

The three basic steps outlined in this dialog box should be performed for each 
migration project. Once you are familiar with the tasks that you will be 
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performing, click Close to access the Project Window and begin modeling 
your migration project.

Using the Project Window

Review the following tips to help you organize your migration project and use 
the Project Window more effectively.

� Creating a New NDS Organizational Unit or Folder—To create a new 
NDS Organizational Unit (OU), right-click the parent NDS 
Organizational Unit or folder and then click New Organizational Unit or 
New Folder. The following figure is an example of this task in the Project 
Window.

Figure 5 Right-clicking Organizational Units in the Project Window

You can create new NDS OUs in the NDS tree and then migrate your NT 
information to those OUs. This keeps the NT information organized and 
in one place in the NDS tree. You can also choose to migrate the NT data 
to existing OUs; just remember that you can always create a new OU in 
the NDS tree if you need to.

If you add new containers or names to the destination tree, the names you 
choose must adhere to the following NDS naming conventions:

� Names must be unique. For example, Debra Jones and Daniel Jones 
cannot both be named DJONES if they are in the same container.

� The following special characters are allowed only if they are 
preceded by a backslash (\): plus sign (+), equal sign (=), and period 
(.).
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� Uppercase and lowercase letters, underscores, and spaces are not 
acknowledged by NDS. For example, Manager_Profile and 
MANAGER PROFILE are considered identical names in NDS.

� Setting the Context—To set the context, right-click an NDS 
Organizational Unit and then click Set Context.

When you set the context, you can designate what part of the NDS tree 
will appear in the right side of the Project Window. This is useful if you 
have a large NDS tree with many objects.

Setting the context at a specific container will eliminate the need to scroll 
down or collapse objects in your NDS tree. Once the context is set, this 
container will appear as the top object in the right side of the Project 
Window.

� Viewing a Description of the Objects in the Project Window—To see 
a short description of what an icon represents in the Project Window, 
right-click an NDS object and then click What’s This?

� Backing Out a Dropped Object—To return a dropped object to its 
original position, right-click a dropped NT object in the NT domain or the 
destination NDS tree and then click Back Out Dropped Object.

The following screen is an example of how a dropped object appears in 
the NDS tree, along with the right-click menu.

Figure 6 Right-clicking Objects in the Project Window
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� Finding Out Where a Dropped NT Object Came From—To find out 
where a dropped object was located in the NT domain, right-click an NT 
object and then click Where Did It Come From? When dragging and 
dropping a large number of objects, this will help you remember where a 
dropped object was previously located in the NT domain.

Once you feel comfortable with where you have dropped your NT folders, 
users, and groups in the NDS tree, verify your migration project to resolve any 
potential problems before migrating your NT data.

Continue with the next section, "Verify Your Migration Project."

Verify Your Migration Project

Once you have modeled your migration in the Project Window, you should 
verify that the proposed locations for these new objects do not conflict with 
existing names, rights, name spaces, etc., in the NDS tree. 

Remember, dragged-and-dropped items appearing in the NDS tree are merely 
assigned to be copied to that area in the NDS tree. Objects will not actually be 
copied until you begin the migration process.

Because a similar verification process is run when you begin the actual NT 
migration, running the standalone verification process prior to migration is not 
mandatory; however, catching any critical errors or warnings now will speed 
up the verification process during the migration. 

You must resolve all critical errors before you begin to actually migrate your 
migration project. Warnings can be resolved after the migration.

1 From the Migration Wizard toolbar, click Project > Verify Project, or 
click the Verification button on the toolbar and then click Next.

2 Follow the procedure in the next section, "Migrate Users and Data to the 
Destination NDS Tree," starting with "Step 2."
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Migrate Users and Data to the Destination NDS Tree

Although you have selected the volumes and containers where the NT data 
will be copied, no data has yet been migrated. When migrated, NT User 
objects are converted to NDS objects and placed in the destination NDS tree. 
To begin the migration, do the following:

1 From the Migration Wizard toolbar, click Project > Verify and Migrate 
Project.

2 Read the Welcome screen and then click Next.

3  If you want to apply a Template object to newly created NDS users, 
browse the tree, select the Template object from the tree view and then 
click Next. 

If you do not want to use a Template object, uncheck the check box and  
click Next.

IMPORTANT: To migrate home directories, you must use a Template object when 
migrating your NT users to the destination NDS tree. Make sure a Home Directory 
property is defined for the Template object you are using.

HINT: If you have not created a Template object but you want to use one now, 
save the project, go to ConsoleOneTM, and create the Template object. Next, run 
Migration Wizard again and click Open Last Project. Then restart this migration 
procedure again starting with "Step 1."

4 (Conditional) If ZENworks is installed, complete the following steps:

4a Browse the destination NDS tree and select any of the ZENworks 
User Policy Packages that you want to associate with your NT 
groups, and then click Next. 

4b Select a ZENworks User Policy Package from the drop-down list, 
and then select the NT groups that you want to associate with each 
ZENworks User Policy Package. Click the right-arrow to move the 
associated groups to the Associate NT Groups window, and then 
click Next.

HINT: If you selected both WINNT-2000 and WIN 95-98 policy packages in 
the previous dialog box, you will first see a dialog box dealing only with your 
WINNT-2000 policy packages, followed by another dialog box dealing only 
with your WIN 95-98 policy packages. If you selected only one type of policy 
package, you will see only one dialog box.

The drop-down list contains all the ZENworks User Policy Packages 
that you selected in the previous step. You can associate as many NT 
groups as you want with each policy package.
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4c Review the NT groups that you chose to associate with specific 
ZENworks User Policy Packages, and then click Next. 

If you want to change an association, click Back and follow the 
instructions in "Step 4b."

HINT: This screen will not appear if you are using ZENworks 3.0.

5 Decide how you want to handle any duplicate filenames between the 
Microsoft NT domain and the destination NDS tree. Select one of the 
following and then click Next:

� Don’t Copy Over Existing Files 

� Copy the Source File If It Is Newer

� Always Copy the Source File

6 Decide how you want to handle passwords for your NT users. Select one 
of the following and then click Next:

� Assign the Same Password to All Users—Migration Wizard will 
assign the same password to all migrated users.

� Assign a Randomly Generated Password to All Users—Migration 
Wizard will randomly generate passwords, assign them, and then 
store the passwords it assigns in a file that it creates, named 
project_name_OUT.TXT. This file is saved in the same directory 
where your migration project is located.

� Read Passwords from a File—Migration Wizard will migrate the 
current NT passwords to the destination NDS tree by reading them 
from a text file. You must create the text file containing the NT 
passwords before you begin the migration.

For more information on how to create this file, click the Help 
button.

7 Set NT migration options by checking or unchecking the check boxes 
next to the following options and then click Next:

� Migrate File Permissions—Normally, Migration Wizard migrates 
file and directory permissions. If, for some reason, you want to 
reassign file and directory permissions, you can choose to not copy 
the file and directory permissions here and then assign them later 
with ConsoleOne.

� Migrate Everyone Permissions—The NDS container that you drop 
the NT Domain Info object into will be assigned the permissions that 
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were associated with group Everyone. If you are migrating the 
Everyone permissions, be sure to drop the NT Domain Info object 
high enough in the NDS tree so that all NT users will inherit those 
permissions.

HINT: Every new folder that is created in the NT domain automatically 
receives the Everyone permissions by default.

� Restart Option—Normally, this information is not erased; however, 
if you have previously run a migration and deleted the NDS objects 
from the destination tree, and you are planning to start over and 
migrate the same domain again, check this check box.

When you migrate users and groups from NT, Migration Wizard 
stores a table of NT names and associated NDS usernames in the 
registry of the Primary Domain Controller (PDC). Migration Wizard 
then uses this information when migrating the file system so that it 
can remember where each user and group has been migrated to in the 
destination NDS tree. By storing this information, Migration Wizard 
can assign the correct file permissions to the appropriate users. 

8 (Conditional) If you are running the standalone verification process, you 
will now be asked if you want to check for rights and volume size on the 
destination server. Check Yes if you want to check these things now, and 
then click Next.

Since this process is quite time-consuming, you might not want to do this 
every time you verify your migration project. But it is very useful if you 
want to verify that you have enough space on the destination volume to 
accommodate your NT file system.

Migration Wizard will also scan the contents of all dropped folders and 
verify that you have sufficient rights to migrate them. 

NOTE: NT can filter supervisory privileges. If you have all rights at the root of a 
directory structure, this does not guarantee that you have these rights throughout 
the directory structure.

9 In the Verify NT to NetWare Project window, click Next to begin the 
verification. 

10 If prompted, resolve any naming conflicts between different-type objects, 
and then click Next.

You can choose to merge different-type objects or to keep them as they 
are.
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11 If prompted, resolve any naming conflicts between same-type objects, 
and then click Next.

You can choose to merge same-type objects or to keep them as they are.

12 If prompted, verify that you do not want to migrate the listed NT users and 
groups, and then click Next. 

This procedure must be done three times—once for all your NT local 
groups, NT global groups, and NT users that were not dragged and 
dropped into the destination NDS tree. If you migrated all of your users 
and groups, you will not see this dialog box.

If you have made a mistake, click Cancel. This will return you to the 
Project Window. Drag and drop the objects, go to the toolbar, click 
Project > Start Migration, and then restart this procedure with "Step 1 on 
page 46."

13 Resolve any critical errors. 

Warnings or noncritical errors, can be resolved after the migration. To 
resolve a critical error or warning, read the description in the text field 
located beneath it. This description should give you a good idea of what 
could be the possible cause and a suggestion for fixing it. 

14 Do one of the following:

� If you are actually migrating at this point, click Proceed to start the 
actual migration.

� If you are only running the standalone verification process at this 
point, click Finish and then follow the instructions in “Migrate Users 
and Data to the Destination NDS Tree” on page 46 to begin the actual 
migration.

15 (Migration only) View the Error and Success Logs.

Continue with the next section, Perform Post-Migration Tasks.
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Perform Post-Migration Tasks

After you’ve migrated your NT data to the destination NDS tree, complete the 
following tasks:

� Install the latest Novell Client software on any workstations that it was 
not previously installed on. 

You can download the client from the Novell Software Download Web 
site (http://www.novell.com/download). For instructions on installing the 
Novell Client on multiple workstations at the same time, see the Novell 
Client Documentation at (http://www.novell.com/documentation).

� Use ConsoleOne to make sure that your NT users and groups have been 
migrated to the correct place in the destination NDS tree and have the 
correct file and shared permissions. 

HINT: If you end up with more or fewer permissions than you planned for, enter 
CACLS/? at the DOS prompt and follow the on-screen instructions. Permissions 
are sometimes hidden in Microsoft utilities; therefore, running this command at the 
DOS prompt lets you see all of the permissions associated with your NT objects, 
even the hidden ones.

� At the destination NetWare server, use ConsoleOne to view the volume 
that you migrated your data to and verify that it was done correctly.

� Set up your printer mappings in NDPS®. For instructions, go to the online 
documentation  (http://www.novell.com/documentation) of the operating 
system that you are running on the destination server and click Print 
Services > Novell Distributed Print Services. 

� Check the migrated users’ home directories to make sure that they were 
migrated the way you expected them to be.

� Distribute the new NDS passwords to all of your users. The passwords are 
located in a password file that Migration Wizard created for you named 
project_name_OUT.TXT. This file is located in the same directory where 
you saved your migration project.
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4 Troubleshooting 

Refer to the appropriate section if you are having trouble with any of the 
following:

� “General Connection Problems” on page 51

� “Workstation-to-Server Connections” on page 52

� “Server-to-Server Connections” on page 53

� “File Copy” on page 53

� “SMDR Errors” on page 54

� “Restoring Trustees” on page 54

� “NUWAGENT.NLM” on page 55

� “NICI Errors” on page 55

� “NDS Migration” on page 56 

General Connection Problems

To eliminate unneccessary connection problems, make sure that 

� The source and destination servers have enough available server and 
workstation licenses to do the migration.

� The NDS® user that you are using to do the migration has no concurrent 
connection limitations. To check this, do the following:

� Run ConsoleOneTM on the workstation.

� Edit the properties of the NDS User object.

� Click the Login Restrictions tab.

� Uncheck the Limit Concurrent Connections check box.
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� The NDS user that you are using to do the migration has the Supervisor 
right to the source server’s NDS object. Use ConsoleOneTM to verify that 
the NDS object of the NDS user is listed in the source server’s Operators 
list. 

Workstation-to-Server Connections

If you have problems establishing or maintaining connections between your 
servers and workstations, try one or more of these troublshooting suggestions: 

� Reboot the client workstation to clear the cache in the Novell® ClientTM. 

� Map a drive to the server instead of logging in. This is especially useful 
when connecting with the IPXTM protocol.

� Search for the server by its IP or IPX address instead of its name. Enter 
the IP or IPX address in the Server field of the Novell Login dialog box.

� Try connecting to the server and not the NDS tree by entering only the 
name of the server and leaving the tree name and context blank.

� Clear all unauthenticated connections. To do this, right-click the N icon 
and click NeWare Connections. Detach from all servers and trees that you 
are not authenticated to, and then try logging in again.

� Make sure your Preferred NetWork Protocol is set correctly by doing the 
following:

� Right-click the N icon.

� Click Novell Client Properties > Protocol Preferences.

� Select the desired preferred network protocol and click OK.

� Reboot the workstation.

� Unbind the protocol you are not using from the destination server. For 
example, if you are using IPX for the migration, but IP is bound on the 
destination server, unbind the IP protocol on the destination server during 
the migration.
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Server-to-Server Connections

If you have problems establishing or maintaining connections between your 
servers, try one or more of these troublshooting suggestions:

� Do not remove the source or destination server from the NDS tree. The 
servers must be able to communicate with the other servers in the tree 
during the migration.

� Make sure the destination and source servers can communicate with each 
other. 

For IPX connections, enter DISPLAY SERVERS at the server console.  
For IP connections, enter PING at the server console.

� If you are using IPX, make sure the frame type and the IPX network 
number/server ID are consistent between the source and destination 
servers. For IP connections, verify that you have corresponding 
addressing, subnet mask, and gateway information.

� Reboot the destination server.

File Copy

There are a few common troubleshooting procedures you can try if you are 
having problems during the file copy:

� Enable login on both the destination and source servers. If you have 
disabled login before you started the file copy, the servers can’t log in to 
each other in order to migrate the files.  

NOTE: If you have selected to do so, Migration Wizard disables login for you 
during the migration.

� If files are copying very slowly, make sure that the servers and 
workstation are configured at the lowest common LAN speed. Verify that 
the NICs and anything in between are all hard coded to either 
communicate half-duplex or full-duplex; they need to be the same 
throughout. If there are problems with full-duplex, use half-duplex.

� If compressed files are migrated to uncompressed volumes, file copy 
might be slower.
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SMDR Errors

Sometimes the SMDR.NLM program that is running on the destination server 
can’t make a connection to the source server. To correct this problem, try one 
or more of the following:

� Reboot the source server.

� Unbind the protocol you are not using from the destination server. For 
example, if you are using IPX for the migration, but IP is bound on the 
destination server, unbind the IP protocol on the destination server during 
the migration.

� If Migration Wizard can’t load the appropriate TSA.NLM on your  
destination server, manually load it from the destination server console 
and following the onscreen instructions. Or, enter SMDR NEW at the 
server console to re-create the SMDR object.

� Load SMDR.NLM at the destination server console and then enter SMDR 
NEW at the destination server console to solve SMSTM problems.

� Make sure the latest NLMTM programs are loaded. 

Migration Wizard automatically copies the required NLMs to the source 
and destination servers. To verify that you have the latest NLMs loaded, 
check the files in the NetWare Migration Wizard\Products\NW3x 
directory. You might have to load TSA312 manually.

� Check your primary connections. Right-click the N icon in the system 
tray and click NetWare Connections. Make sure the destination tree and 
server are marked as "primary."

� If you are migrating from NetWare 3, make sure the bindery context is set 
on the destination server. If you are migrating to NetWare 6, enter set 
bindery context = o=[context] on the destination server 
console. 

Restoring Trustees

� If the trustees fail to restore and you get a 0xfffffffb error, this means that 
you did not modify your IP address in all the necessary places. For more 
information, see “Edit Configuration Files” on page 28.

� If you need to restore trustees, in the Migration Wizard, you can click the 
Finish NDS Migration button or select Restore Trustees from the toolbar.
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NUWAGENT.NLM

NUWAGENT.NLM is the NLM program that the Migration Wizard uses to do 
much of its work. If you get errors that the NUWAGENT.NLM won’t load, try 
the following:

� Manually load NUWAGENT.NLM from the server console.

� Enter SMDR NEW at the destination server console. This re-creates the 
SMDR configuration and allows NUWAGENT.NLM to load.

NICI Errors

If you are gettting NICI errors when NDS is trying to load or when you are 
copying the NICI files in the Migration Wizard, this might mean that your 
NICI files are corrupt. To correct the problem, follow these steps on the server 
that is getting NICI errors:

1 Copy the *.NFK file from server’s license diskette to the server’s 
SYS:SYTEM directory. 

2 Rename the *.NFK file that you just copied to NICIFK (this has no 
extension).

3 Go to the Novell Support Web site (http://support.novell.com/filefinder) 
and download NREPAIR3.EXE.

4 Extract NREPAIR3.EXE and locate NREPAIR.NLM.

5 Run NREPAIR.NLM on the server, clicking Yes at all the prompts.

6 Reboot the server.

7 Load PKI.NLM on the server and verify that you are no longer getting 
NICI errors.

If you still see NICI errors, go to the Novell Support Home Page (http://
www.support.novell.com/search/kb_index.jsp) and search for TID 
10025666.
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NDS Migration 

If the migration fails during the NDS Migration step, you need to restore the 
source and destination servers to their original configuration before you can 
retry the NDS migration. The instructions for restoring the servers to their 
original configurations are different depending on when the migration of data 
failed.

If Begin NDS Migration, button 3, failed and the destination server did not 
reboot and take on the name and identity of the source server, complete the 
steps in “Restore Source Server to Its Original Configuration” on page 56.

If Begin NDS Migration, button 3, successfully completed and the destination 
server has already rebooted and taken on the name and identity of the source 
server, complete the steps in the following sections:

1. “Remove NDS from the Destination Server” on page 57

2. “Remove NDS from the Source Server” on page 58

3. “Restore NDS to the Source Server” on page 59

4. “Reinstall the Destination Server” on page 60

Restore Source Server to Its Original Configuration

If Begin NDS Migration, button 3, failed and the destination server did not 
reboot and take on the name and identity of the source server, you need only 
restore NDS to the source server. Once NDS has been restored, you have 
restored the source server to its original configuration and you are ready to try 
the NDS migration again.

1 Enter one of the following at the server console of the source server:

� If your source server is running NetWare 4, enter LOAD INSTALL.

� If your source server is running NetWare 5 or later, enter  
NWCONFIG.

2 Select Directory Options > Directory Backup and Restore > Restore 
Local DS Information after Hardware Upgrade.

3 Press F3 and enter SYS:SYSTEM\NUW30\NDSBU when promted for 
the location of the backup files. 

NDS has now been restored to the source server.

IMPORTANT: Do not reboot the destination server. Since the destination server 
did not take over the identity of the source server, no other action is required prior 
to performing the NDS migration again.
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4 To perform the NDS migration again, launch Migration Wizard and open 
the project you were previously working on. When the project opens and  
you see the Project Window, click the Begin NDS Migration button and 
follow the instructions in “Begin NDS Migration” on page 29. 

Remove NDS from the Destination Server

If Begin NDS Migration, button 3, successfully completed and the destination 
server has already rebooted and taken on the name and identity of the source 
server, you must remove NDS from the destination server before you can 
restore NDS to the source server.

1 At the destination server console, enter NWCONFIG.

2 Select Directory Options > Remove Directory Services from This Server.

3 Press Enter when you see a warning instructing you to not remove 
Directory Services.

Ignore any other errors during the removal of NDS.

4 Select Yes to Remove Directory Services.

5 Enter the Admin username and password.

6 Press Enter to reference a different object. 

This object is used when NDS is restored back to the source server.

WARNING: Do not press Esc. If you do, the server references you entered will not 
be saved or restored to the server.

7 Enter the full Admin username as the placeholder object distinguished 
name. 

8 Enter [Root] as the distinguished name to change from.

9 If the information about single reference time source appears, review the 
information and press Enter.

10 If your server holds the Master copy of a replica, you will see a warning. 
Press Enter.

11 Designate another server to hold the Master replica. You can choose to let 
NWCONFIG randomly select another server, or you can designate one 
yourself.

12 Return to the NWCONFIG utility and verify that NDS has been removed 
by selecting Remove Directory Services from This Server. 
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If the message appears saying that NDS has already been removed, bring 
the destination server down and continue with the next section, "Remove 
NDS from the Source Server."

If NDS was not successfully removed, exit NWCONFIG and enter 
NWCONFIG -DSREMOVE at the destination server console.Then follow 
this procedure again, beginning with "Step 2."

Remove NDS from the Source Server

Once NDS has been removed from the destination server, remove NDS from 
the source server.

1 Restart the source server by entering Server at the DOS command 
prompt.

2 Enter LOAD INSTALL -DSREMOVE.

This command will instruct INSTALL or NWCONFIG to ignore any 
warnings or errors during the removal of NDS.

If your source server is running NetWare 4, enter LOAD INSTALL -
DSREMOVE. 

If your source server is running NetWare 5 or later, enter NWCONFIG -
DSREMOVE.

3 Select Directory Options > Remove Directory Services from This Server.

4 Press Enter to skip past any warning screens.

5 Select Yes to remove NDS.

6 Press Enter to skip the error message warning you that NDS is locked. 

Ignore, but keep track of, any additional NDS error messages that appear.

7 When the INSTALL or NWCONFIG menu appears again, select Remove 
Directory Services again. 

If a message indicates that NDS is already removed, continue with the next 
section, "Restore NDS to the Source Server."

If NDS was not properly removed, contact Novell Technical Support at 1-800-
858-4000.
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Restore NDS to the Source Server

By removing NDS from the source server, you removed the server from any 
replica rings that held a partition of the source server. Now you must complete 
the following procedure to restore NDS to the source server.

1 Enter one of the following at the server console:

� If your source server was running NetWare 4, enter LOAD 
INSTALL.

� If your source server was running NetWare 5 or later, enter LOAD 
NWCONFIG.

2 Select Directory Services > Install Directory Services onto This Server.

3 Select the NDS tree where the source server existed prior to migration.

4 Select a time zone and time configuration parameters.

Ignore any warnings or errors that appear during the restoration of NDS, 
but make a note of the errors before pressing ESC.

5 Enter the Admin name and password.

6 Enter the context where the source server existed prior to migration and 
press F10.

7 Save the NDS (Directory) information.

8 Wait while the server synchronizes with the NDS tree, which might take 
a while.

9 Return to the INSTALL or NWCONFIG utility and select Directory 
Options > Select Directory Back Up and Restore > Restore Local DS 
Information after Hardware Upgrade > Restore Reference from another 
Object to This Server. 

This will restore all references to the Server object that you assigned 
when you removed NDS from the destination server.

10 Press Enter.

11 Enter the full Admin username as the placeholder object distinguished 
name, and then enter [Root] as the distinguished name to change from.

12 Exit the NWCONFIG or INSTALL utility.

13 At the server console of the source server, enter LOAD DSREPAIR. 

14 Select Unattended Full Repair > Advanced Options > Check Volume 
Objects and Trustees.
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15 Enter the Admin username and password.

16 Exit DSREPAIR.

17 At the workstation where you performed the migration, open your 
project.

18 From the Migration Wizard Tools menu, click Restore Trustees to restore 
the trustee assignments.

19 If the source server held the master replica of any partitions and you want 
to restore these partitions prior to doing the NDS migration again, use 
DSREPAIR to re-create them.

The source server is now restored to its original configuration.

Continue with the next section, "Reinstall the Destination Server."

Reinstall the Destination Server

To perform the migration again, you must reinstall the operating system on the 
destination server. 

HINT: If you had your server imaged, you can just restore the image rather than 
reinstall.

1 Bring down the destination server.

2 Install NetWare and follow the on-screen instructions during the  
installation.

After NetWare is installed on the destination server, you are ready to perform 
the NDS migration again. Go to “Begin NDS Migration” on page 29.
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