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About This Guide

This guide describes how to use the Novell® NetWare® Migration Wizard to copy data from one 
NetWare server to another NetWare server in your network. The guide is intended for network 
administrators and is divided into the following sections:

Chapter 1, “Overview,” on page 5 explains the capabilities of Novell NetWare Migration 
Wizard.

Chapter 2, “Migrating Data from NetWare 5 or 6,” on page 7 explains the prerequisites and 
instructions for migrating data from a NetWare 5, or NetWare 6 server.

Chapter 3, “Troubleshooting,” on page 19 provides solutions for resolving errors encountered 
during the migration.

Additional Documentation

The entire NetWare 6.5 documentation set is available online at the Novell NetWare 6.5 Product 
Documentation Web site (http://www.novell.com/documentation/lg/nw65).

Novell Education offers a variety of courses that help you maximize your investment in NetWare. 
For course descriptions, details, and locations of training events, visit the Novell Education Web 
site (http://www.novell.com/education/netware6).

Documentation Updates

For the most recent version of the NetWare Migration Wizard 7.0 Administration Guide, see the 
NetWare Migration Wizard 7.0 online documentation (http://www.novell.com/documentation/lg/
migwiz70/index.html).

Documentation Conventions

In this documentation, a greater-than symbol (>) is used to separate actions within a step and items 
in a cross-reference path.

A trademark symbol (®, TM, etc.) denotes a Novell trademark. An asterisk (*) denotes a third-party 
trademark.

When a single pathname can be written with a backslash for some platforms or a forward slash for 
other platforms, the pathname is presented with a backslash. Users of platforms that require a 
forward slash, such as UNIX*, should use forward slashes as required by your software.
About This Guide 3
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1 Overview

Novell® NetWare® Migration Wizard lets you copy data from one NetWare server to another 
NetWare server in your network.

Migrating Data from NetWare 5 or 6—Migration Wizard migrates the file system and NDS 
database from a NetWare 5, NetWare 6, or NetWare 6.5 source server to a faster, more reliable 
NetWare 6 or NetWare 6.5 destination server. After NDS is migrated, the destination server 
replaces and assumes the identity of the source server on the network.

Valid destination servers must be running NetWare 6.0 or 6.5 if migrating from a NetWare 5 source 
server. If migrating from NetWare 6, valid destination servers must be running NetWare 6. 
Migrations from NetWare 6 to NetWare 6.5 can be accomplished in one of two ways: 

Migrate from a NetWare 6.0 source server to a NetWare 6.0 destination server, then upgrade 
the destination server to NetWare 6.5 with either an in-place or remote upgrade.

Upgrade the NetWare 6.0 source server to NetWare 6.5 with either an in-place or remote 
upgrade, then migrate the upgraded NetWare 6.5 source server to a NetWare 6.5 destination 
server.

IMPORTANT: To perform a migration from a NetWare 3 or NetWare 4 source server, or to perform a migration 
to a NetWare 5 destination server, use the Migration Wizard Utility version 6.5.

What’s New
Migration Wizard 7.0 has been updated with the following new features:

Migration Wizard 7.0 speeds up the file copy procedure by implementing multi-threading in 
determining file sizes while the file copy is running. 

In previous versions of the Migration Wizard, the file copy procedure does not begin until the 
file sizes are completely discovered. With Migration Wizard 7.0, the copy procedure and the 
file size determination occur simultaneously.

The transfer of NICI keys during the migration can now be accomplished across the wire with 
Migration Wizard 7.0.

Previous versions of the Migration Wizard required using a floppy diskette swap to transfer 
NICI keys. Migration Wizard 7.0 still provides the option of using the floppy diskette swap if 
wanted, but now the transfer can be completed quickly and securely over the wire instead.

Migration Wizard 7.0 now displays a listing of created folders, dropped volumes, and dropped 
folders during the verification stage of the migration.

Migration Wizard 7.0 now has the ability to update ZENworks® for Servers information 
during the migration process.
Overview 5
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2 Migrating Data from NetWare 5 or 6

When you migrate data from a NetWare® 5 or NetWare 6 source server to a NetWare destination 
server, Novell® NetWare Migration Wizard 7.0 copies the file system and NDS® database from 
the source server to the newly installed NetWare destination server. 

After the source server’s file system and NDS database is migrated to the destination server, the 
source server is automatically brought down and the destination server reboots and assumes the 
name and identity of the source server on your existing network.

Before you can migrate your data, you must first install a destination NetWare server in a 
temporary NDS tree. A temporary tree is simply a tree that contains one server with a basic 
installation of NetWare and no additional products installed (other than SMSTM or any other default 
products). 

To migrate data from NetWare 5 or NetWare 6, complete the following tasks in the order they are 
listed:

1. Meet System and Software Requirements (page 8).

2. Run Migration Wizard (page 10).

3. Model Your Migration Project (page 11).

4. Verify Your Migration Project (page 11).

5. Copy File System Data (page 12).

6. Edit Configuration Files (page 13).

7. Begin NDS Migration (page 13).

8. Finish the NDS/eDirectory Migration (page 16).

9. Perform Post-Migration Tasks (page 16).

Source Server

Temporary
Server Name

Temporary
NDS Tree

replaces
and 

assumes
the identity

of

Existing
NDS Tree

NetWare
Destination Server
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Meet System and Software Requirements

Workstation Requirements
A Windows NT (4.0 or later), Windows 2000, or Windows XP Professional Edition 
workstation with 50 MB of available disk space.

If running on a Windows 2000 workstation, Service Pack 2 or later must be installed.

The Migration Wizard Utility does not work with Windows XP Home Edition or Windows 
95/98.

Novell ClientTM software installed and connected to the network.

Windows NT/2000/XP workstations must be running Novell Client for Windows NT/2000/
XP version 4.9 or later. 

To check the Novell Client version, right-click the N icon on the workstation toolbar, then 
click Novell Client Properties > Client. To download the latest client, see the Novell Software 
Downloads site (http://download.novell.com).

Microsoft* Jet Database drivers installed if running on a Windows NT 4.0 workstation.

If Microsoft Jet Database drivers are not installed on your NT 4.0 workstation, they can be 
downloaded from www.microsoft.com/downloads by searching for the Jet 4.0 Service Pack 3 
Update.

Microsoft Data Access Components (MDAC) 2.7 installed on the workstation. 

If MDAC 2.7 is not installed on your workstation, it can be downloaded from 
www.microsoft.com/downloads.

(Conditional) If migrating from NetWare 4, the IPXTM protocol should be configured on your 
Novell Client workstation.

For better performance, we strongly recommend that the source server, destination server, and 
client workstation run on a common LAN segment.

Source Server Requirements
The source server is the NetWare server that contains the files, volumes, and NDS objects that will 
be copied to the NetWare destination server. Valid source servers can be running NetWare 5.0, 5.1, 
6.0, or 6.5. Migrations to a NetWare 6.5 destination server can be successfully completed from a 
NetWare 5.0, 5.1, 6.0, or 6.5 source server. However, migrating from NetWare 6.0 to NetWare 6.5 
must be done in one of two ways:

Migrate from a NetWare 6.0 source server to a NetWare 6.0 destination server, then upgrade 
the destination server to NetWare 6.5 with either an in-place or remote upgrade.

Upgrade the NetWare 6.0 source server to NetWare 6.5 with either an in-place or remote 
upgrade, then migrate the upgraded NetWare 6.5 source server to a NetWare 6.5 destination 
server.

IMPORTANT: To perform a migration from a NetWare 3 or NetWare 4 server, use the Migration Wizard Utility 
version 6.5.

Use ConsoleOne® to verify that you have the Supervisor right to the source server’s file 
system and the source server itself.
8   NetWare Migration Wizard 7.0 Administration Guide
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WARNING: When migrating a NetWare 6.0 server with eDirectoryTM version 8.6.2 to a new NetWare 6.0 
server with eDirectory 8.6.2, you might encounter an NDS® error stating you couldn’t copy an NDS object 
because you do not have the proper rights. This can occur even if you are logged in as Admin. 

Installing eDirectory version 8.7 on the source server and running the migration again resolves this issue.

Update the source server with the latest NetWare Support Pack. 

Updates are available at the Consolidated Support Pack home page (http://
support.novell.com/tools/csp).

Any applications, products, or services (virus scan software, backup software, etc.) running 
on the server to be migrated should be shut down before beginning the migration.

Load DSRepair and run the following three options:

Unattended Full Repair

Time Synchronization

Report Synchronization Status

Make sure that these finish with no errors.

Back up NDS and all data.

Destination Server Requirements
The destination server is the new computer that will receive the data from the source server. This 
server must be installed into a temporary tree. 

After data is migrated from the source server to the destination server, the destination server 
reboots and Migration Wizard automatically modifies the destination server’s autoexec.ncf file to 
include the source server’s name and internal IPX number/server ID. You don’t have to modify 
these manually.

Valid destination servers can be running NetWare 6.0 and 6.5. Migration Wizard 7.0 does not 
migrate to NetWare 4 or NetWare 5 destination servers. If migrating from NetWare 6.0, valid 
destination servers must be running NetWare 6.0. Migrations from NetWare 6.0 to NetWare 6.5 
can be accomplished in one of two ways:

Migrate from a NetWare 6.0 source server to a NetWare 6.0 destination server, then upgrade 
the destination server to NetWare 6.5 with either an in-place or remote upgrade.

Upgrade the NetWare 6.0 source server to NetWare 6.5 with either an in-place or remote 
upgrade, then migrate the upgraded NetWare 6.5 source server to a NetWare 6.5 destination 
server.

IMPORTANT: To perform a migration to a NetWare 5 server, use the Migration Wizard Utility version 6.5. 

Install the destination server with the NetWare operating system that you are migrating to. 

For instructions on installing NetWare 6.0, see the NetWare 6 Overview and Installation 
Guide (http://www.novell.com/documentation/lg/nw6p/index.html?page=/
documentation/lg/nw6p/setupenu/data/hz8pck9v.html).

Make sure that you select the Pre-migration Server option described in “Selecting the 
Type of Installation” in the NetWare 6 Overview and Installation Guide during the 
NetWare 6 installation. And then select the custom option so that you can verify that you 
have enough room on your destination server to accommodate your source server data.

For instructions on installing NetWare 6.5, see the NetWare 6.5 Installation and Overview 
Guide (http://www.novell.com/documentation/lg/nw65).
Migrating Data from NetWare 5 or 6 9
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Make sure that you select the Pre-migration Server pattern described in the NetWare 6.5 
Overview and Installation Guide (http://www.novell.com/documentation/lg/nw65/
index.html?page=/documentation/lg/nw65/install/data/aj8szb0.html) under the 
Choosing the Server Type heading during the NetWare 6.5 installation.

Use ConsoleOne to verify that you have the Supervisor right to the destination server’s file 
system and the destination server itself.

If the destination server is running NetWare 6.5, the Universal Password feature must be 
disabled until the migration completes. 

Universal Password is disabled by default on NetWare 6.5.

Create a temporary NDS tree with a temporary NDS tree name. 
IMPORTANT: The temporary name and temporary NDS tree name must not be the same as the source 
server’s name or NDS tree name; otherwise, the destination server will not assume the identity of the 
source server after the migration.

Migration Wizard migrates compressed volumes. If you are migrating compressed volumes 
to uncompressed volumes, Migration Wizard decompresses the volumes during the migration. 
Make sure you have enough room on the uncompressed volume to accommodate the source 
volumes after they are decompressed.

During the installation, assign a different IP address to the destination server than is assigned 
to the source server. 

After the migration completes and the source server is taken offline, you can change the 
destination server’s IP address to match what had been assigned to the source server.

Continue with the next section, Run Migration Wizard.

Run Migration Wizard
1 Install NetWare Migration Wizard 7.0 from the products\migrtwzd directory on NetWare 6.5 

CD 1 (Operating System).

Expand the utility and install it on a workstation by double-clicking the migrtwzd.exe file.
TIP: There are some known issues with Java and certain video cards that cause the Migration Wizard 
installation to quit after extracting. If you encounter this issue, update your graphics card drivers to the 
latest version, or disable the hardware acceleration for your graphics card.

2 Run Migration Wizard from the location where you installed it. 

The installation program, by default, installs Migration Wizard at this location: Start > 
Programs > Novell > Netware Migration Wizard > NetWare Migration Wizard. 

3 Read the Welcome screen, then click OK.

4 Click Create a New Project > OK.

5 Click NetWare 5 or 6 to NetWare 6 or 6.5 > OK.

6 Click View Online Documentation. 

This launches your default Web browser and takes you to the NetWare Migration Wizard 7.0 
online documentation.

7 Make sure you have completed the system and software requirements in “Meet System and 
Software Requirements” on page 18, then close your browser.

8 Click Next.
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9 Name the project, select a place to save it, then click Next.

By default, Migration Wizard saves all projects to c:\Program Files\Novell\NetWare 
Migration Wizard.

10 Select the NDS tree that contains your source server, then click Next. 

11 Select your source server from the NDS tree, then click Next.

12 Select the NDS tree that contains your destination server, then click Next.

13 Select your destination server from the destination NDS tree, then click Next. 

14 To save your project and access the Project Window, click Create.

Continue with the next section, Model Your Migration Project.

Model Your Migration Project
Most of your work will be done in the Project Window, where you can drag-and-drop NetWare 5 
and 6 data into volumes and folders in the destination NDS tree. 

The Project Window is a place to model different migration scenarios before you begin the actual 
migration. The source server’s volume data is shown in the left side of the Project Window, and 
the destination NDS tree is displayed in the right side of the Project Window. All of the planning 
in the Project Window is done offline, meaning that folders moved and created in the Project 
Window are not actually copied or created until you begin the migration. 

The Project Window and the Using the Project Window dialog box appear after you have created 
the migration project. 

1 Determine what NetWare 5 or 6 volume data will be copied to which folders in the destination 
server’s NDS tree.

2 If needed, create new folders in the destination NDS tree.

To create a new folder, right-click an existing folder or volume.

3 Drag-and-drop NetWare 5 or 6 folders and volumes into NDS containers. 
IMPORTANT: If you are migrating NDPS® information to the destination server, make sure you migrate 
the sys:ndps directory and the sys:login/ippdocs directory. They are necessary for NDPS to function 
properly.

Continue with the next section, Verify Your Migration Project.

Verify Your Migration Project
After you have modeled your migration by dragging-and-dropping volume data in the Project 
Window, you should verify your project. The Verification Wizard will inform you of such things 
as insufficient rights, name spaces that are not loaded, disk space limitation, and improper TSAs. 

Remember, dragged-and-dropped items appearing in the NDS tree are merely assigned to be 
copied to that area in the NDS tree. Objects will not actually be migrated until you begin the 
migration.

To begin the verification and migration:

1 On the Migration Wizard toolbar, click Project > Verify and Migrate Project, or click the 
Verify and Migrate button.

Continue with the next section, Copy File System Data.
Migrating Data from NetWare 5 or 6 11



    Novell Confidential                                                                                            Manual (Rev 99a)  13 November 2003
Copy File System Data
During the Copy File System step, all source server trustees and ownerships are backed up to 
special trustee backup files. These files can be used in case the NDS/eDirectory on the source 
server has to be removed and the trustees and ownerships restored. For more information on NDS 
restoration, see “NDS Migration” on page 22.

Additionally, all source server standard sys: volume trustees and ownerships will be backed up to 
special trustee backup files and these files are copied to the destination server. They are restored 
during the fourth phase of the migration.

All trustees for dropped folders are also backed up to special backup files and these files are copied 
to the destination server during this step. Also, dropped directories are copied to the destination 
server and created directories are added to the destination server during this step.

1 In the Project View dialog box, click Copy File System Data.

Before Migration Wizard starts copying files, it backs up your directory and file trustees and 
saves them in files located on the source and the destination server. When the NDS migration 
is complete, Migration Wizard restores the trustees from the files it stored on the destination 
server.

2 Decide how you want to handle any duplicate filenames between the source server and the 
destination NDS tree, select one of the following, then click Next:

Don’t Copy Over Existing Files 

Copy the Source File If It Is Newer

Always Copy the Source File

3 Decide how you want to copy your volumes, select one of the following, then click Next. 

Copy Volumes with Users Logged In

Disable Login  

Migration Wizard does not copy open files. If you disable user login, you can be sure that no 
other users will log in to the network and open files during the file copy.

4 Type the passwords for the source and destination trees, then click Next.

5 If prompted, resolve any critical errors or warnings and then click Next.

6 (Conditional) If newer NLMs are available, a dialog box displays asking if you want to copy 
these newer NLMs to your system. To have the Migration Wizard Utility copy the NLMs for 
you, click Yes.

7 In the Ready to Copy Files dialog box, read the explanation of the file copy process and then 
click Proceed.

The Back Up the Source Server’s Trustees? screen displays. 

8 If your source server has previously been backed up by the Migration Wizard during this step, 
you can click No. If the source server has not undergone a Migration Wizard backup, back it 
up now by clicking Yes.

9 Review the error and success logs, then click Done.

Continue with the next section, Edit Configuration Files.
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Edit Configuration Files
The Edit Configuration Files step compares the configuration files between the source and 
destination servers and lets you make changes to those files if you want.

1 In the Project View dialog box, click Edit Configuration Files.

Migration Wizard lets you modify any .ncf or .cfg files on the destination server. These files 
contain default LOAD statements and parameters.
IMPORTANT: Make sure that all files are closed before you migrate your NDS database. 

2 In the text box, select the configuration file that you want to edit and then click Edit File.

3 Copy and paste the commands from the configuration file on the source server to the 
corresponding configuration file on the destination server, then click Save & Close. 

If you intend to change the IP address on your destination server to be the same as the IP 
address of your source server, you must edit your configuration files and change the IP address 
in two places: autoexec.ncf and sys:\etc\hosts.

Copy the source server’s IP address and paste it into the destination server’s autoexec.ncf file. 
(This works only if your IP LOAD and BIND statements are located in autoexec.ncf.) You 
also need to go to the server console of the destination server and change the IP address in the 
sys:\etc\hosts file. Look for the original name of the destination server.

If you use INETCFG to assign IP addresses, change the IP addresses after the migration is 
complete.

4 (Conditional) If you are using configured time sources (timesync.cfg), then copy and paste 
your Timesync information from the source server’s timesync.cfg file to the destination 
server’s timesync.cfg file.

5 Close the Compare Configurations dialog box.

Continue with the next section, Begin NDS Migration.

Begin NDS Migration
The Begin NDS Migration step migrates the NDS/eDirectory files from the source server to the 
destination server. The source server is brought down and the destination server is restarted during 
this step.

1 In the Project View dialog box, click Begin NDS/eDir Migration.

2 Back up all volumes that you are not planning to migrate and ensure the following before 
continuing:

All volume data migrated successfully

All critical errors from the file copy are resolved

The servers in your source NDS tree are in time sync and NDS is synchronized. 

For more information, see “Source Server Requirements” on page 8.

3 Click Next.

4 Select Yes or No to update the source server’s schema, then click Next.

Migration Wizard can update the source server’s schema to include the NDS classes of the 
default applications that are installed on the destination server.
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By default, Yes is selected, which causes Migration Wizard to compare the source and 
destination schemas. This comparison will help you determine how to extend your schema in 
preparation for the migration.

5 (Optional but recommended) Verify that you have run the DSREPAIR procedures in “Source 
Server Requirements” on page 8 to verify that the NDS tree containing the source server is 
functioning correctly, click Yes or No to acknowledge that your tree is healthy, then click 
Next. 

Migration Wizard does not prevent you from continuing if you have not run DSREPAIR to 
verify the health of your tree. However, if your tree is unhealthy before you begin the 
migration, the migration might not complete successfully. 

6 You are now prompted to copy and transfer the NICI configuration files from the source server 
to the destination server. 

To ensure the security certificate works properly on the destination server, you must copy the 
source server’s NICI configuration files to the destination server. To facilitate the NICI file 
copy, nuwnici.nlm is first copied to both the source and destination servers.

You can choose to copy the NICI files Automatically (Over the network) or using a diskette 
swap. Select the radio button next to the method you want, then click Next.

7 (Conditional) If you selected the diskette swap, continue with Step 7a. If you selected the 
automatic copy over the network, proceed to Step 8.

7a To copy the nuwnici.nlm to the source and destination servers, click Copy NLM.

7b Click Next.

7c Insert a blank formatted diskette into the floppy drive on the destination server.

7d At the destination server console, enter load nuwnici -1.

7e Remove the diskette from the destination server and insert it into the source server’s 
floppy drive.

7f At the source server console, enter load nuwnici -2.

This copies the NICI files to the diskette.

7g Remove the diskette from the source server and insert it into the destination server’s 
floppy drive.

7h At the destination server console, enter load nuwnici -3.

This copies the NICI files to the destination server.

7i Click Next.
TIP: If you get NICI errors when NDS tries to load or when you copy the NICI files, check and see if 
pki.nlm will load on the destination server. If it won’t load, see “NICI Errors” on page 22.

8 Delete all user connections (except your own) to the source and destination servers, then click 
Next.

If you want to first broadcast a logout message to any users logged in to the server, click 
Broadcast Logout Message, type the message in the field, and then click OK.

9 Type the passwords for the source and destination trees, then click Next.

10 Resolve any critical errors or warnings on the Migrate NDS Verification Results screen, then 
click Next.
14   NetWare Migration Wizard 7.0 Administration Guide



    Novell Confidential                                                                                            Manual (Rev 99a)  13 November 2003
11 Perform the eDirectory step-by-step migration.

The eDirectory migration is broken into several steps. This is for diagnostic purposes. If the 
eDirectory migration fails for any reason, you will know exactly what step it failed on and can 
take the appropriate measures to fix the problem.

For more information on the eDirectory/NDS migration process, including steps to restore the 
source and destination servers, see “NDS Migration” on page 22.

11a Click Next.

The first step changes autoexec.ncf and timesync.cfg; modifies the server name in hosts, 
hostname, and snmp.cfg; and renames smdr.cfg to smdr.mig.  The first step also renames 
rootcert.der in both the sys:system and sys:public directories to rootcert.der.bak.

At the end of the migration process, the source server is brought down and the destination 
server reboots and takes over the name and identity of the source server.

Migration Wizard automatically modifies the following items in the destination server’s 
autoexec.ncf file:

The file server name is changed to the name of the source server

The time zone is changed to the time zone stored in the source server’s autoexec.ncf 
file

The server ID is changed to the IPX internal net value or server ID stored in the 
source server’s autoexec.ncf file

The default time server type is changed to the value stored in the source server’s 
autoexec.ncf file

The bindery context is changed to the bindery context stored in source server’s 
autoexec.ncf file

IMPORTANT: During the migration, the source server’s Timesync information is not automatically 
migrated.

11b To begin the next step (backing up eDirectory, copying the eDirectory backup files to the 
destination server, and copying the eDirectory backup files to sys:system\nuw30\ndsbu 
on the source server), click Next.

11c Down the source server by clicking Next.

The Source Server Status dialog box displays. 

11d Verify that the source server is down, then click OK.

11e To begin the next step (removing eDirectory from the destination server and deleting the 
client connection), click Next.

11f To begin the next step (upgrading eDirectory on the destination server if necessary, 
restoring eDirectory on the destination server, and preparing to reboot the destination 
server), click Next.

11g Reboot the destination server by clicking Next.

11h If you are ready to proceed, click Yes > Finish.

12 Check the former destination server and verify that it has restarted and taken on the name of 
the source server.
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13 Reboot your workstation and log in to the former destination server. 

This clears old connections from the workstation and establishes a clean connection to the 
former destination server.

If you can’t log in, refer to “Workstation-to-Server Connections” on page 20.

14 Restart the Migration Wizard utility.

15 Read the Welcome screen, then click OK.

16 Click Open Last Project > OK.

The utility verifies that the first three steps of the project file are complete. 

17 If you are ready to finish the migration, click Yes.

Finish the NDS/eDirectory Migration
The Finish the NDS/eDirectory Migration step upgrades the schema and restores the trustees to 
the new server after it has restarted.

1 In the Project View dialog box, click Finish NDS/eDir Migration.

The Continue NDS/eDir Migration dialog box appears, outlining the NDS backlink process 
that needs to be run on the destination server.

2 At the destination server console, enter the following:

set dstrace=on

then

set dstrace=+blink

then

set dstrace=*b

3 Click Yes > Next.

4 Type the tree password in the field provided, then click Next > Continue.

5 Review the error and success logs, then click Done.

6 In the Project View dialog box, click Close.

Continue with the next section, Perform Post-Migration Tasks.

Perform Post-Migration Tasks
1 Run DSREPAIR on the destination server and select Unattended Full Repair.

2 Make sure that user information migrated successfully.
TIP: During the migration, the standard sys directory from the source server is saved in the sys.mig 
directory on the destination server.

3 Run DSREPAIR > Time Synchronization to verify that your source server is synchronized 
with the rest of your servers. 

4 Verify that the correct IP address is assigned to the new server in all appropriate files.

For example, autoexec.ncf, sys:\etc\hosts, and sys:\etc\hostname.
IMPORTANT: Failure to have the correct IP address in the hosts or hostname files causes the post-
installation of some products to fail.
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5 (Conditional) If you have performed a migration to a NetWare 6.0 destination server, verify 
that sys:\public\rootcert.der exists. If it does not, copy the file from an existing server on the 
network, or create a new one following the instructions in ROOTCERT.DER not exported 
during the install of Certificate server (http://support.novell.com/cgi-bin/search/
searchtid.cgi?/10066860.htm). 

If the rootcert.der file does not exist, a post-migration install of applications could fail.

6 Reinstall any applications.
IMPORTANT: Because the source server’s identity replaces the destination server, all NDS objects on 
the destination server, including those representing applications, are removed and replaced by the NDS 
objects that exist on the source server. However, the NLM programs associated with the destination 
server’s applications still exist. Because you cannot manage applications without their corresponding 
NDS objects, you must reinstall the applications to restore their NDS objects to the NDS tree.

If your destination server was running NetWare 5.1, you might see warnings on your server referring to 
SMS, LDAP, Novell Certificate Server, or NetWare Management Portal. Just ignore the warnings and 
reinstall the products after NDS has been migrated. 

To reinstall these network products and services, go to the NetWare Deployment Manager 
utility (nwdeploy.exe) located on NetWare 6.5 CD 1 (Operating System), or go to the GUI 
interface and click the Novell icon on the servertop. 

7 If you haven’t already done so, install the latest NetWare Support Pack.

This ensures that you get the latest code for the applications that you are reinstalling. The 
latest Support Packs are available at the Novell Support Web site (http://support.novell.com/
misc/patlst.htm).

Installing Tomcat and exteNd Application Server After the Migration

After completing a NetWare 6.5 to NetWare 6.5 migration using the Migration Wizard, complete 
the following steps to ensure that Tomcat installs correctly:

1 Copy sys:\sys.mig\java to sys:\java, overwriting all existing files.

2 Copy sys:\sys.mig\adminsrv to sys:\adminsrv, overwriting all existing files.

3 Copy sys:\sys.mig\system\ipconf to sys:\system\ipconf, overwriting all existing files.

After completing a NetWare 6.5 to NetWare 6.5 migration using the Migration Wizard, complete 
the following steps to ensure that exteNd Application Server installs correctly:

1 Copy sys:\sys.mig\java to sys:\java, overwriting all existing files.

2 Copy sys:\sys.mig\etc\my.cnf to sys:\etc\my.cnf.

Installing Native File Access for UNIX after the Migration

After completing a NetWare 5.1 to NetWare 6.5 migration using the Migration Wizard, complete 
the following steps to ensure that Native File Access for UNIX installs correctly:

1 Delete the NFAUUser object.

2 Run the schinst utility.

Syntax: 

schinst -n -w

SCHINST takes the administrator's FDN and password as input for extending the schema.

3 Run nisinst.

4 Execute nfsstart.
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3 Troubleshooting 

Refer to the appropriate section if you are having trouble with any of the following:

General Connection Problems (page 19)

Workstation-to-Server Connections (page 20)

Server-to-Server Connections (page 20)

File Copy (page 20)

SMDR Errors (page 21)

Restoring Trustees (page 21)

Nuwagent.nlm (page 21)

NICI Errors (page 22)

NDS Migration (page 22) 

CCS_pbeDecrypt Error When Migrating from NetWare 5.0 (page 25)

General Connection Problems
To eliminate unnecessary connection problems, make sure that 

The source and destination servers have enough available server and workstation licenses to 
do the migration.

The NDS® user that you are using to do the migration has no concurrent connection 
limitations. To check this, do the following:

Run ConsoleOne® on the workstation.

Edit the properties of the NDS User object.

Click the Login Restrictions tab.

Uncheck the Limit Concurrent Connections check box.

The NDS user that you are using to do the migration has the Supervisor right to the source 
server’s NDS object. Use ConsoleOne to verify that the NDS object of the NDS user is listed 
in the source server’s Operators list. 
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Workstation-to-Server Connections
If you have problems establishing or maintaining connections between your servers and 
workstations, try one or more of the following: 

Reboot the client workstation to clear the cache in the Novell® ClientTM software. 

Map a drive to the server instead of logging in. This is especially useful when connecting with 
the IPXTM protocol.

Search for the server by its IP or IPX address instead of its name. Type the IP or IPX address 
in the Server field of the Novell Login dialog box.

Try connecting to the server and not the NDS tree by specifying only the name of the server 
and leaving the tree name and context blank.

Clear all unauthenticated connections. To do this, right-click the N icon and then click 
NetWare Connections. Detach from all servers and trees that you are not authenticated to, then 
try logging in again.

Make sure your Preferred NetWork Protocol is set correctly by doing the following:

Right-click the N icon.

Click Novell Client Properties > Protocol Preferences.

Select the desired preferred network protocol, then click OK.

Reboot the workstation.

Unbind the protocol you are not using from the destination server. For example, if you are 
using IPX for the migration but IP is bound on the destination server, unbind the IP protocol 
on the destination server during the migration.

Server-to-Server Connections
If you have problems establishing or maintaining connections between your servers, try one or 
more of the following:

Do not remove the source or destination server from the NDS tree. The servers must be able 
to communicate with the other servers in the tree during the migration.

Make sure the destination and source servers can communicate with each other. 

For IPX connections, enter DISPLAY SERVERS at the server console. For IP connections, 
enter PING at the server console.

If you are using IPX, make sure the frame type and the IPX network number/server ID are 
consistent between the source and destination servers. For IP connections, verify that you 
have corresponding addressing, subnet mask, and gateway information.

Reboot the destination server.

File Copy
If you are having problems during the file copy, try one or more of the following:

Enable login on both the destination and source servers. If you have disabled login before you 
started the file copy, the servers can’t log in to each other in order to migrate the files.  
NOTE: If you have selected to do so, Migration Wizard disables login for you during the migration.
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If files are copying very slowly, make sure that the servers and workstation are configured at 
the lowest common LAN speed. Verify that the NICs and anything in between are all hard 
coded to either communicate half-duplex or full-duplex; they need to be the same throughout. 
If there are problems with full-duplex, use half-duplex.
NOTE: If compressed files are migrated to uncompressed volumes, file copy might be slower.

SMDR Errors
Sometimes the smdr.nlm program that is running on the destination server can’t make a connection 
to the source server. To correct this problem, try one or more of the following:

Unbind the protocol you are not using from the destination server. For example, if you are 
using IPX for the migration but IP is bound on the destination server, unbind the IP protocol 
on the destination server during the migration.

If Migration Wizard can’t load the appropriate tsa.nlm on your destination server, manually 
load it from the destination server console and following the onscreen instructions. Or, enter 
SMDR NEW at the server console to re-create the SMDR object.

Load smdr.nlm at the destination server console and then enter SMDR NEW at the destination 
server console to solve SMSTM problems.

Make sure the latest NLMTM programs are loaded. 

Migration Wizard automatically copies the required NLMs to the source and destination 
servers. To verify that you have the latest NLMs loaded, check the files in the NetWare 
Migration Wizard\products\nw3x directory. You might have to load TSA312 manually.

Check your primary connections. Right-click the N icon in the system tray, then click 
NetWare Connections. Make sure the destination tree and server are marked as “primary.”

Reboot the source server.

Restoring Trustees
If the trustees fail to restore and you get a 0xfffffffb error, this means that you did not modify 
your IP address in all the necessary places. For more information, see “Edit Configuration 
Files” on page 13.

If you need to restore trustees, in the Migration Wizard, you can click the Finish NDS 
Migration button or select Restore Trustees on the toolbar.

Nuwagent.nlm
Nuwagent.nlm is the NLM program that the Migration Wizard uses to do much of its work. If you 
get errors that the nuwagent.nlm won’t load, try the following:

Manually load nuwagent.nlm at the server console.

Enter SMDR NEW at the destination server console. This re-creates the SMDR configuration 
and allows nuwagent.nlm to load.
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NICI Errors
If you are getting NICI errors when NDS is trying to load or when you are copying the NICI files 
in the Migration Wizard, this might mean that your NICI files are corrupt. To correct the problem, 
follow these steps on the server that is getting NICI errors:

1 Copy the *.nfk file from NetWare 6.5 CD 1 (Operating System) to the server’s sys:system 
directory. 

2 Rename the *.nfk file that you just copied to nicifk (this has no extension).

3 Go to the Novell Support Web site (http://support.novell.com/filefinder) and download 
nrepair3.exe.

4 Extract nrepair3.exe and locate nrepair.nlm.

5 Run nrepair.nlm on the server, clicking Yes at all the prompts.

6 Reboot the server.

7 Load pki.nlm on the server and verify that you are no longer getting NICI errors.

If you still see NICI errors, go to the Novell Knowledgebase (http://support.novell.com/search/
kb_index.jsp) and search for TID #10025666.

NDS Migration 
If the migration fails during the NDS Migration step, you need to restore the source and destination 
servers to their original configuration before you can retry the NDS migration. The instructions for 
restoring the servers to their original configurations are different depending on when the migration 
of data failed.

If Begin NDS Migration, button 3, failed and the destination server did not reboot and take on the 
name and identity of the source server, complete the steps in “Restore Source Server to Its Original 
Configuration” on page 22.

If Begin NDS Migration, button 3, successfully completed and the destination server has already 
rebooted and taken on the name and identity of the source server, complete the steps in the 
following sections:

1. “Remove NDS from the Destination Server” on page 23.

2. “Remove NDS from the Source Server” on page 24.

3. “Restore NDS to the Source Server” on page 24.

4. “Reinstall the Destination Server” on page 25.

Restore Source Server to Its Original Configuration
If Begin NDS Migration, button 3, failed and the destination server did not reboot and take on the 
name and identity of the source server, you need only restore NDS to the source server. When NDS 
has been restored, you have restored the source server to its original configuration and you are 
ready to try the NDS migration again.

1 Enter one of the following at the server console of the source server:

LOAD INSTALL if the source server is running NetWare 4

NWCONFIG if the source server is running NetWare 5 or later
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2 Select Directory Options > Directory Backup and Restore > Restore Local DS Information 
after Hardware Upgrade.

3 Press F3 and enter SYS:SYSTEM\NUW30\NDSBU when prompted for the location of the 
backup files. 

NDS has now been restored to the source server.
IMPORTANT: Do not reboot the destination server. Because the destination server did not take over the 
identity of the source server, no other action is required prior to performing the NDS migration again.

4 To perform the NDS migration again, launch Migration Wizard and then open the project you 
were previously working on. When the project opens and you see the Project Window, click 
the Begin NDS Migration button and follow the instructions in “Begin NDS Migration” on 
page 13. 

Remove NDS from the Destination Server
If Begin NDS Migration, button 3, successfully completed and the destination server has already 
rebooted and taken on the name and identity of the source server, you must remove NDS from the 
destination server before you can restore NDS to the source server.

1 At the destination server console, enter NWCONFIG.

2 Select Directory Options > Remove Directory Services from This Server.

3 Press Enter when you see a warning instructing you to not remove Directory Services.

Ignore any other errors during the removal of NDS.

4 Select Yes to Remove Directory Services.

5 Specify the Admin username and password.

6 Press Enter to reference a different object. 

This object is used when NDS is restored back to the source server.
WARNING: Do not press Esc. If you do, the server references you entered will not be saved or restored 
to the server.

7 Specify the full Admin username as the placeholder object distinguished name. 

8 Specify Root as the distinguished name to change from.

9 (Conditional) If the information about single reference time source appears, review the 
information and press Enter.

10 (Conditional) If your server holds the Master copy of a replica, press enter when you see a 
warning.

11 Designate another server to hold the Master replica.

You can choose to let NWCONFIG randomly select another server, or you can designate one 
yourself.

12 Return to the NWCONFIG utility and verify that NDS has been removed by selecting 
Remove Directory Services from This Server. 

If the message appears saying that NDS has already been removed, bring the destination 
server down and continue with the next section, “Remove NDS from the Source Server” on 
page 24.

If NDS was not successfully removed, exit NWCONFIG and enter NWCONFIG -DSREMOVE 
at the destination server console. Then follow this procedure again, beginning with Step 2.
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Remove NDS from the Source Server
After NDS has been removed from the destination server, remove NDS from the source server.

1 Restart the source server by entering Server at the DOS command prompt.

2 Enter one of the following: 

LOAD INSTALL -DSREMOVE (if source server is running NetWare 4)

NWCONFIG -DSREMOVE (if source server is running NetWare 5 or later)

INSTALL or NWCONFIG will now ignore any warnings or errors during the removal of 
NDS.

3 Select Directory Options > Remove Directory Services from This Server.

4 Press Enter to skip past any warning screens.

5 Select Yes to remove NDS.

6 Press Enter to skip the error message warning you that NDS is locked. 

Ignore, but keep track of, any additional NDS error messages that appear.

7 When the INSTALL or NWCONFIG menu appears again, select Remove Directory Services 
again. 

If a message indicates that NDS is already removed, continue with the next section, “Restore NDS 
to the Source Server” on page 24.

If NDS was not properly removed, contact Novell Technical ServicesSM at 1-800-858-4000.

Restore NDS to the Source Server
By removing NDS from the source server, you removed the server from any replica rings that held 
a partition of the source server. Now you must complete the following procedure to restore NDS 
to the source server.

1 Enter one of the following at the server console:

LOAD INSTALL. (if source server was running NetWare 4)

LOAD NWCONFIG. (if source server was running NetWare 5 or later)

2 Select Directory Services > Install Directory Services onto This Server.

3 Select the NDS tree where the source server existed prior to migration.

4 Select a time zone and time configuration parameters.

Ignore any warnings or errors that appear during the restoration of NDS, but make a note of 
the errors before pressing Esc.

5 Type the Admin name and password.

6 Type the context where the source server existed prior to migration, then press F10.

7 Save the NDS (Directory) information.

8 Wait while the server synchronizes with the NDS tree, which might take a while.

9 Return to the INSTALL or NWCONFIG utility and select Directory Options > Select 
Directory Back Up and Restore > Restore Reference from another Object to This Server. 

This restores all references that you assigned to the Server object when you removed NDS 
from the destination server.
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10 Press Enter.

11 Type the full Admin username as the placeholder object distinguished name, then specify 
Root as the distinguished name to change from.

12 Exit the NWCONFIG or INSTALL utility.

13 At the server console of the source server, enter LOAD DSREPAIR. 

14 Select Unattended Full Repair > Advanced Options > Check Volume Objects and Trustees.

15 Type the Admin username and password.

16 Exit DSREPAIR.

17 At the workstation where you performed the migration, open your project.

18 From the Migration Wizard Tools menu, select Restore Trustees to restore the trustee 
assignments.

19 (Conditional) If the source server held the master replica of any partitions and you want to 
restore these partitions prior to doing the NDS migration again, use DSREPAIR to re-create 
them.

The source server is now restored to its original configuration.

Continue with the next section, “Reinstall the Destination Server” on page 25.

Reinstall the Destination Server
To perform the migration again, you must reinstall the operating system on the destination server. 
TIP: If you had your server imaged, you can just restore the image rather than reinstall the server.

1 Bring down the destination server.

2 Install NetWare and follow the on-screen instructions during the installation.

After NetWare is installed on the destination server, you are ready to perform the NDS migration 
again. Go to “Begin NDS Migration” on page 13.

CCS_pbeDecrypt Error When Migrating from NetWare 5.0
When performing a migration from NetWare 5.0, you might receive a CCS_pbeDecrypt error 
on the source server console when attempting to back up either the source server trustees or the 
NDS database.

If this occurs, make sure that the latest Support Pack is installed on the NetWare 5.0 server and do 
the following:

1 At the NetWare 5.0 source server console, enter Down.

2 At the DOS prompt, enter copy c:\nwserver\expxeng.xlm 
c:\nwserver\novxeng.xlm.

3 Enter copy c:\nwserver\domxeng.xlm c:\nwserver\novxeng.xlm.

NOTE: This might fail because domxeng.xlm is not present. This is not a problem.

If you used a directory other than \nwserver to store the server files, substitute that directory 
for nwserver in steps 2 and 3.

4 Restart the NetWare 5.0 server.
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