Legal Notices

Novell, Inc. makes no representations or warranties with respect to the contents or use of this documentation, and specifically disclaims any express or implied warranties of merchantability or fitness for any particular purpose. Further, Novell, Inc. reserves the right to revise this publication and to make changes to its content, at any time, without obligation to notify any person or entity of such revisions or changes.

Further, Novell, Inc. makes no representations or warranties with respect to any software, and specifically disclaims any express or implied warranties of merchantability or fitness for any particular purpose. Further, Novell, Inc. reserves the right to make changes to any and all parts of Novell software, at any time, without any obligation to notify any person or entity of such changes.

You may not use, export, or re-export this product in violation of any applicable laws or regulations including, without limitation, U.S. export regulations or the laws of the country in which you reside.

Copyright © 2005 Novell, Inc. All rights reserved. No part of this publication may be reproduced, photocopied, stored on a retrieval system, or transmitted without the express written consent of the publisher.

Novell, Inc. has intellectual property rights relating to technology embodied in the product that is described in this document. In particular, and without limitation, these intellectual property rights may include one or more of the U.S. patents listed at http://www.novell.com/company/legal/patents/ and one or more additional patents or pending patent applications in the U.S. and in other countries.
Novell Trademarks

ConsoleOne is a registered trademark of Novell, Inc. in the United States and other countries.
eDirectory is a trademark of Novell, Inc. in the United States and other countries.
exeNd is a trademark of Novell, Inc.
Internetwork Packet Exchange and IPX are trademarks of Novell, Inc.
NetWare is a registered trademark of Novell, Inc. in the United States and other countries.
NetWare Loadable Module and NLM are trademarks of Novell, Inc.
Nterprise is a trademark of Novell, Inc.
Nterprise Branch Office is a trademark of Novell, Inc.
NMAS is a trademark of Novell, Inc.
Novell is a registered trademark of Novell, Inc. in the United States and other countries.
Novell Client is a trademark of Novell, Inc.
Novell Directory Services and NDS are registered trademarks of Novell, Inc. in the United States and other countries.
Novell Technical Services is a service mark of Novell, Inc.
Storage Management Services is a trademark of Novell, Inc.
ZENworks is a registered trademark of Novell, Inc. in the United States and other countries.

Third-Party Materials

All third-party trademarks are the property of their respective owners.
# Contents

About This Guide 7

1 Overview
- About NetWare Migration Wizard .......................... 9
- Product History ............................................ 11

2 Preparing for a Server Migration 13
- Meeting System and Software Requirements .................. 13
  - Workstation Requirements ................................ 13
  - Source Server Requirements ................................ 14
  - Destination Server Requirements ............................ 14
- Installing the Migration Wizard Software ....................... 15
- Preparing the Source Server for Migration ...................... 15
- Installing the Destination Server ................................ 15
- What’s Next .................................................. 16

3 Migrating Data from NetWare 5 or 6 17
- Review Tips for a Successful Migration ......................... 17
- Start Migration Wizard and Create a Project File ............... 17
- Model Your Migration Project .................................. 18
  - Working in the Project Window ................................. 19
- Verify Your Migration Project ................................... 20
  - Project Verification ........................................ 20
  - Verification with Full Trustee/Ownership Backup ............ 21
- Migration Step 1: Copy File System Data ...................... 21
- Migration Step 2: Edit Configuration Files .................. 24
- Migration Step 3: Begin NDS/eDirectory Migration ........... 25
- Migration Step 4: Finish the NDS/eDirectory Migration .......... 28
- Perform Post-Migration Tasks .................................. 28

4 Troubleshooting 31
- General Connection Problems .................................. 31
- Workstation-to-Server Connection Problems .................. 32
- Server-to-Server Connection Problems ........................ 32
- File Copy Problems ......................................... 32
- SMDR Errors .................................................. 33
- Restoring Trustees ........................................... 33
- Nuwagent.nlm Load Errors .................................... 33
- NICI Errors .................................................. 34
- NMAS Error When Migrating from NetWare 5.1 .................. 34
- NDS/eDirectory Migration Failures ............................. 34
  - Restore Source Server to Its Original Configuration .......... 35
  - Remove NDS/eDirectory from the Destination Server ........ 35
  - Remove NDS/eDirectory from the Source Server ............... 36
  - Restore NDS/eDirectory to the Source Server ................ 37
  - Reinstall the Destination Server ................................ 38
- CCS_pbeDecrypt Error When Migrating from NetWare 5.0 ........ 38
About This Guide

This guide describes how to use the Novell® NetWare® Migration Wizard to copy data from one NetWare server to another NetWare server in your network. The guide is intended for network administrators and is divided into the following sections:

- Chapter 1, “Overview,” on page 9 explains the features and capabilities of Novell NetWare Migration Wizard.
- Chapter 2, “Preparing for a Server Migration,” on page 13 provides instructions for installing the NetWare Migration Wizard and preparing the servers for the migration.
- Chapter 3, “Migrating Data from NetWare 5 or 6,” on page 17 contains the instructions for migrating data from a NetWare 5 or NetWare 6 server.
- Chapter 4, “Troubleshooting,” on page 31 provides solutions for resolving errors encountered during the migration.

Documentation Updates

For the most recent version of this guide, see the Novell online documentation (http://www.novell.com/documentation).

Documentation Conventions

In this documentation, a greater-than symbol (>) is used to separate actions within a step and items in a cross-reference path.

A trademark symbol (®, ™, etc.) denotes a Novell trademark. An asterisk (*) denotes a third-party trademark.

When a single pathname can be written with a backslash for some platforms or a forward slash for other platforms, the pathname is presented with a backslash. Users of platforms that require a forward slash, such as Linux* and UNIX*, should use forward slashes as required by your software.

Additional Documentation

The entire NetWare 6.5 documentation set is available online at the Novell NetWare 6.5 Product Documentation Web site (http://www.novell.com/documentation/nw65).

The entire Open Enterprise Server (OES) documentation set is available online at the Novell OES Product Documentation Web site (http://www.novell.com/documentation/oes).

Novell Education offers a variety of courses that help you maximize your investment in NetWare. For course descriptions, details, and locations of training events, visit the Novell Education Web site (http://www.novell.com/education/netware6).
User Comments

We want to hear your comments and suggestions about this manual and the other documentation included with OES. To contact us, use the User Comments feature at the bottom of any page in the online documentation.
1

Overview

The Novell® NetWare® Migration Wizard lets you transfer file system data and the NDS®/eDirectory™ database from one NetWare server to a faster, more reliable NetWare server on your network. When the transfer is complete, the destination server replaces and assumes the identity of the source server on the network.

NetWare Migration Wizard version 8.0 supports migrations from NetWare 5.1, NetWare 6.0, or NetWare 6.5 source servers. Destination servers must be running NetWare 6.0 or 6.5. It also supports Open Enterprise Server (OES) for NetWare as a source and destination server.

**IMPORTANT:** To perform a migration from a NetWare 3 or NetWare 4 source server, or to perform a migration to a NetWare 5 destination server, use the NetWare Migration Wizard version 6.5 that is available on the Novell product download site (http://download.novell.com). Type *Migration Wizard* in the Search field, click Search, then select version 6.5 from the results list.

If you want to migrate data from Microsoft* Windows* domains to NetWare, or consolidate data from one or more NetWare servers to an existing NetWare server or Novell Nentreprise™ Branch Office™ Appliance, use the Novell Server Consolidation Utility that is available on the Novell product download site (http://download.novell.com/pages/PublicSearch.jsp). Type *Server Consolidation Utility* in the Search field, click Search, then select the latest version of the Novell NetWare Server Consolidation Utility from the results list.

This chapter describes what NetWare Migration Wizard is and how you can use it to migrate data from an existing NetWare server to a new NetWare 6 or OES NetWare server. It also contains a version history of new features in each release of NetWare Migration Wizard.

**About NetWare Migration Wizard**

Novell NetWare Migration Wizard is designed to help you transfer the identity of one server to another server. This is what is referred to as a server hardware upgrade.

**NOTE:** If you want to add a new server with a new name into your network, you wouldn’t use the Migration Wizard; you would use the NetWare server installation program.

NetWare Migration Wizard is an ideal tool for moving existing NetWare data onto faster, more reliable server hardware. It is a Windows-based program that you install and run on a workstation. With the Migration Wizard, you model your migration project using simple drag-and-drop procedures before you actually perform the migration. This helps prevent errors from interrupting your data migration and allows you to prevent mistakes before they happen.

You can also take advantage of this modeling capability to reorganize the data on your server and even resize volumes, if needed. However, Migration Wizard is best suited for migrations requiring a minimal amount of volume reorganization.

As you work through the modeling phase of NetWare Migration Wizard, all of your decisions are recorded in a migration project file. At any time during the modeling process, you can save the project file, exit the utility, and then restart Migration Wizard and resume from where you left off.
After the modeling phase is completed, you can proceed with the actual migration. This process is divided into four basic steps:

- **Step 1: Copy File System Data.**
  Using the data contained in the migration project file, Migration Wizard copies the files and folders (or even entire volumes) you selected from the source server to a newly installed destination server. All file system data, including meta-data such as file trustees, ownerships and attributes, is copied from the old machine to the new one.

- **Step 2: Edit Configuration Files.**
  During this step, Migration Wizard presents configuration files such as autoexec.ncf and startup.ncf side-by-side so you can easily copy commands and settings from the source server’s configuration files to matching files on the destination server.

- **Step 3: Begin NDS/eDirectory Migration.**
  The NDS®/eDirectory™ files are transferred from the old server to the new one without any additional work on your part. After the migration, the eDirectory partitions that existed on the old server will exist on the new server. This is because the Migration Wizard backs up the entire eDirectory database on the source server and then restores it on the destination server.

- **Step 4: Finish NDS/eDirectory Migration.**
  After the source server’s file system and NDS/eDirectory database are migrated to the destination server, the source server is automatically brought down and the destination server reboots and assumes the name and identity of the source server on your existing network.

---

Before you can migrate your data, you must first install a destination NetWare server in a temporary eDirectory tree. A temporary eDirectory tree is simply a tree that contains one server with a basic installation of NetWare and no additional products installed (other than SMS or any other default products).

Migration Wizard automatically modifies the destination server’s autoexec.ncf file to include the source server’s name and internal IPX™ number/server ID. You don’t have to modify these manually. Because the server’s identity has been transferred from one physical server to another, you don’t need to upgrade any client applications that might be doing drive mappings or running applications based on the server name. However, you do have to manually change the IP address of the destination server to match that of the source server.
Migration Wizard does not migrate any products and services that are running on the source server. After the migration is complete, you need to reinstall all applications on the destination server and reconfigure them, if necessary.

**Product History**

This section lists the enhancements and new features introduced in NetWare Migration Wizard 8.0 and previous versions back to version 6.5.

**TIP:** Each new release of NetWare Migration Wizard includes performance enhancements and bug fixes that increase the speed and reliability of NetWare migrations. If you have had unsatisfactory results with early versions of this utility, we encourage you to give the latest version a try.

**Migration Wizard 8.0**

- Adds the ability to filter the files you want to copy according to creation, last accessed, or modified dates.
- Lets you exclude specific file types or file names from the copy process.
- Includes an option to synchronize file and folders so that data deleted while you model a migration project is also deleted on the destination server when you run the project.
- Gives you the option to automatically compare file information between the source and destination after the copy process is complete to validate the integrity of the file copy.

**Migration Wizard 7.1**

- Allowed migration directly from a NetWare 6 source server to a NetWare 6.5 destination server.

**Migration Wizard 7.0**

- Sped up the file copy procedure by implementing multithreading in determining file sizes while the file copy is running.

In previous versions of the Migration Wizard, the file copy procedure did not begin until the file sizes were completely discovered. With Migration Wizard 7.0, the copy procedure and the file size determination occurred simultaneously.

- Allowed NICI keys to be transferred across the wire during the migration.

Previous versions of the Migration Wizard required using a floppy diskette swap to transfer NICI keys. Migration Wizard 7.0 still provided the option of using the floppy diskette swap if wanted, but the transfer could be completed quickly and securely over the wire instead.

- Displayed a listing of created folders, dropped volumes, and dropped folders during the verification stage of the migration.
- Added the ability to update ZENworks® for Servers information during the migration process.
- Removed support for migrating data from NetWare 3 and 4 source servers.
- Moved the NT-to-NetWare migration capability to the Server Consolidation Utility 2.5.
- Moved the printing migration capability to the Server Consolidation Utility 2.5.
Migration Wizard 6.5

IMPORTANT: Versions of the Migration Wizard after 6.5 no longer support migrations from NetWare 3 bindery-based servers and from NetWare 4 NDS based servers. To accommodate the needs of NetWare 3 and 4 customers, Novell continues to provide Migration Wizard version 6.5 as a separate download.

- File copy operation no longer required you to have exactly the same volumes on the source and destination servers.
- This version introduced the drag-and-drop interface that allows the user to model the migration project before actually performing the migration.
- The Begin NDS/eDir Migration step was divided into several substeps to allow you to verify that each step completed correctly before continuing.
Preparing for a Server Migration

To prepare your network for a server migration with the Novell® NetWare® Migration Wizard, complete the tasks in the following sections:

- “Meeting System and Software Requirements” on page 13
- “Installing the Migration Wizard Software” on page 15
- “Preparing the Source Server for Migration” on page 15
- “Installing the Destination Server” on page 15

Meeting System and Software Requirements

The NetWare Migration Wizard runs on a Windows workstation and lets you transfer NetWare file system and eDirectory™ data from one NetWare server to another. This section lists the system and software requirements for the Windows workstation, the source server, and the destination server.

Workstation Requirements

- A PC workstation running one of the following versions of Windows:
  - Windows 2000 (with Service Pack 2 or later)
  - Windows XP Professional Edition
  
  The NetWare Migration Wizard does not work with Windows XP Home Edition, Windows NT®, or Windows 95/98.
- 50 MB of available disk space
- Novell Client™ software
  
  Windows workstations must be running the Novell Client for Windows 2000/XP version 4.91 or later.

  To check the Novell Client version, right-click the N icon in the workstation system tray (toolbar), and then click Novell Client Properties > Client. To download the latest client, see the Novell Software Downloads site (http://download.novell.com).

  You must also make the following settings in your Novell Client software:

  - Disable file caching (right-click the N icon > Novell Client Properties > Advanced Settings > File Caching > Setting: Off)
  - (Conditional) Enable UTF-8 support if you are copying extended ASCII (multinational characters) or double-byte character set (oriental languages) data (right-click the N icon > Novell Client Properties > Advanced Settings > Use UTF8 encoding and NCPs > Setting: On)

- Microsoft Data Access Components (MDAC) 2.8 or later
If MDAC 2.8 or later is not installed on your workstation, it can be downloaded from the Microsoft Downloads Web site (http://www.microsoft.com/downloads).

**Source Server Requirements**

The source server is the NetWare server that contains the files, volumes, and NDS®/eDirectory objects to be copied to the NetWare destination server.

- Supported source servers can be running any of these versions of NetWare:
  - NetWare 5.0 or 5.1
  - NetWare 6.0 or 6.5
  - Open Enterprise Server for NetWare

  **IMPORTANT:** To perform a migration from a NetWare 3 or NetWare 4 server, use the Migration Wizard Utility version 6.5.

- Update the source server with the latest NetWare Support Pack.
  
  Updates are available at the Consolidated Support Pack home page (http://support.novell.com/tools/csp).

- You must have the Supervisor right to the source server’s file system and the source server itself.
  
  Use ConsoleOne® to verify that you have the necessary rights.

  **IMPORTANT:** When migrating a NetWare 6.0 server with eDirectory version 8.6.2 to a new NetWare 6.0 server with eDirectory 8.6.2, you might encounter an NDS error stating you couldn’t copy an NDS object because you do not have the proper rights. This can occur even if you are logged in as Admin.
  
  Installing eDirectory version 8.7 or later on the source server and running the migration again resolves this issue.

**Destination Server Requirements**

The destination server is the new computer that is to receive the data from the source server. This server must be installed into a temporary tree and it must be the only server in that tree.

- Supported destination servers can be running these versions of NetWare:
  - NetWare 6.0 or 6.5
  - Open Enterprise Server for NetWare

  Migration Wizard 8.0 does not migrate to NetWare 4 or NetWare 5 destination servers.

  **IMPORTANT:** To perform a migration to a NetWare 5 server, use the Migration Wizard Utility version 6.5.

- Select the Pre-Migration Server pattern when you install the destination server.

- You must have the Supervisor right to the destination server’s file system and the destination server itself.
  
  After you install the destination server, use ConsoleOne to verify that you have the necessary rights.

- The source and destination servers must be using the same time synchronization method: Timesync (timesync.nlm) or NTPv3 (xntpd.nlm).
See the *Network Time Management for NetWare Administration Guide for OES* for more information about time synchronization.

**Installing the Migration Wizard Software**

For NetWare 6.5 SP3, download the overlay CD images for *NetWare 6.5 CD 1 (Operating System)* and *NetWare 6.5 CD 2 (Products)* from Novell’s Download site (http://download.novell.com). Using CD burning software such as Roxio® Easy CD Creator, create your own CDs from the downloaded ISO images. The NetWare Migration Wizard 8.0 is located on *NetWare 6.5 SP3 CD 1 (Operating System)* in the products/Migration_Utilities directory.

NetWare Migration Wizard 8.0 is also available online at Novell’s Download site (http://download.novell.com). Type *NetWare Migration Wizard* in the search box and submit your search. Select version 8.0 for instructions on how to download the migwiz.exe file.

Expand the utility and install it on a workstation by double-clicking the migrtwzd.exe file and following the on-screen installation instructions.

**TIP:** There are some known issues with Java® and certain video cards that cause the Migration Wizard installation to quit after extracting. If you encounter this issue, update your graphics card drivers to the latest version or disable the hardware acceleration for your graphics card.

**Preparing the Source Server for Migration**

Before you run the NetWare Migration Wizard, follow these steps to prepare the source server:

1. Shut down any applications, products, or services (virus scan software, backup software, etc.) running on the server to be migrated.
2. Verify the health of eDirectory by loading DSRepair and running the following three options:
   - Unattended Full Repair
   - Time Synchronization
   - Report Synchronization Status
   If any errors are reported, resolve them before attempting the migration.
3. Back up eDirectory and all data on the server.
4. Remove any unnecessary applications, then delete and purge unused files and folders.

**Installing the Destination Server**

The next step is to install the destination server with the NetWare operating system that you are migrating to.

1. Obtain the NetWare installation software for the version of NetWare you require (NetWare 6.0 or NetWare 6.5/Open Enterprise Server).
2. Prepare the new server hardware as recommended in the NetWare installation documentation.
3. Run the NetWare Install program.
   - For instructions on installing NetWare 6.0, see the *NetWare 6 Overview and Installation Guide* (http://www.novell.com/documentation/nw6p/index.html?page=/documentation/nw6p/setupenu/data/hz8pck9v.html).
For instructions on installing NetWare 6.5, see the NetWare 6.5 Installation and Overview Guide (http://www.novell.com/documentation/nw65/install/data/hz8pck9v.html).

For instructions on installing Open Enterprise Server for NetWare, see the OES for NetWare Installation Guide (http://www.novell.com/documentation/oes/install-nw/data/hz8pck9v.html).

During the installation, make sure that you do the following:

- As you create volumes, verify that you have enough room on your destination server to accommodate your source server data.

  If you are migrating compressed volumes to uncompressed volumes, Migration Wizard decompresses the volumes during the migration. Make sure you have enough room on the uncompressed volume to accommodate the source volumes after they are decompressed.

- Select the Pre-Migration Server pattern.

- Assign a different IP address to the destination server than is assigned to the source server.

  After the migration completes and the source server is taken offline, you can change the destination server’s IP address to match what had been assigned to the source server.

- Assign the destination server a temporary name and install it into a new temporary eDirectory tree.

  You can name the server and tree anything you want (provided the names do not conflict with any existing server or tree on the network), because they are only temporary and cease to exist after the migration is complete.

  **IMPORTANT:** The temporary server name and temporary tree name must not be the same as the source server’s name or tree name; otherwise, the destination server cannot assume the identity of the source server after the migration.

(Conditional) If the destination server is running NetWare 6.5/Open Enterprise Server, you must disable the Universal Password feature until the migration completes.

Universal Password is disabled by default on NetWare 6.5/Open Enterprise Server.

**What’s Next**

For instructions on using the NetWare Migration Wizard, continue with Chapter 3, “Migrating Data from NetWare 5 or 6,” on page 17.
3

Migrating Data from NetWare 5 or 6

After you have completed the prerequisite procedures in Chapter 2, “Preparing for a Server Migration,” on page 13, you are ready to migrate data from your NetWare 5 or NetWare 6 source server. To do this, complete the following tasks in the order they are listed:

1. Review Tips for a Successful Migration (page 17)
2. Start Migration Wizard and Create a Project File (page 17).
3. Model Your Migration Project (page 18).
4. Verify Your Migration Project (page 20).
5. Migration Step 1: Copy File System Data (page 21).

Review Tips for a Successful Migration

- When you run the NetWare Migration Wizard, you must be logged in to the network as a user with the Supervisor right to both the source and destination servers. If you are not logged in when you start the Migration Wizard, you can log in as you select the source and destination trees.
- For better performance, we strongly recommend that the source server, destination server, and client workstation run on a common LAN segment.
- You should use the fastest workstation available to run the Migration Wizard. If possible, assign the workstation a static IP address. Turn off screen savers and power management to avoid interruptions during the migration.

Start Migration Wizard and Create a Project File

1. Start NetWare Migration Wizard from the location where you installed it.
   By default, Migration Wizard is installed in c:\program files\novell migration wizard. You can access it on the desktop by clicking Start > Programs > Novell Migration Wizard > Novell Migration Wizard.

2. Read the About screen, then click OK.
3 Do one of the following:
- To start a new migration project, click Create a New Project > OK.
- To open an existing project, click Open an Existing Project > OK, select the project file you want to work on, and then click Open.
- To open the last project you worked on, click Open Last Project > OK.

4 (Optional) Click View Online Documentation.
This launches your default Web browser and takes you to the NetWare Migration Wizard online documentation.
Make sure you have completed the procedures in Chapter 2, “Preparing for a Server Migration,” on page 13. Then close your browser and click Next.

5 Name the project, select a place to save it, type a descriptive filename, then click Next.
By default, Migration Wizard saves all projects to c:\program files\novell migration wizard. You can click Browse to select a different location.
Migration Wizard uses a project (.mdb) file to record your progress throughout the migration. At any point before the migration is complete, you can exit Migration Wizard and restart the utility to pick up where you left off.
The filename can be up to 64 characters long and can include any character except \ * ? < > | " / . It is a good idea to use a standard naming convention to clearly identify each project.

6 Select the eDirectory tree that contains your source server, then click Next.
If necessary, click the Login button to attach to the tree.

7 Select your source server from the eDirectory tree, then click Next.
If necessary, navigate the tree until you find the desired source server.

8 Select the eDirectory tree that contains your destination server, then click Next.
If necessary, click the Login button to attach to the tree.

9 Select your destination server from the destination eDirectory tree, then click Next.
If necessary, navigate the tree until you find the destination server. It should be the only server in the tree.

10 To create the project file with the information you have entered thus far, click Create.
Continue with the next section, Model Your Migration Project.

Model Your Migration Project

The Project Window and the Getting Started Migrating from NetWare 5 or 6 window appear after you have created the migration project file.
If you do not want the Getting Started window to appear the next time you run the Migration Wizard, deselect Always Show This Window. Click Close to close the Getting Started window and begin modeling your project.
The Project Window is where you can model different migration scenarios before you begin the actual migration. To do this, you drag volumes and folders from the left pane (which displays the source server’s volumes) and drop them into volumes and folders in the right pane (which shows the destination server’s volumes).
Dragging-and-dropping data in the Project Window does not immediately perform the action. It only creates a preview of where the data will ultimately reside on the destination server. The data is copied only after the project verification is complete and the migration process begins.

**Working in the Project Window**

To begin modeling your migration project, decide what file system data on the source server will be copied to which volumes and folders on the destination server. You can drag-and-drop entire volumes or just selected folders from the source server to the destination server.

You can also move created and dropped folders around in the destination pane by dragging them to the desired location.

**Other Project Window Actions**

In addition to dragging-and-dropping volumes and folders, you can perform several other tasks in the Project Window:

- To view a short description of the icons in the Project Window, right-click an object and then click What’s This.
- To set a new eDirectory tree context in either the left or right pane, right-click a container and then click Set Context.
- To create a new folder on the destination server, right-click an existing parent folder or volume and then click New Folder.
- To rename a newly created folder, right-click the folder and then click Rename.
- To show where a folder went, right-click the folder in the left pane and then click Where Did it Go?
  
The folder that was moved is highlighted in its new location in the right pane.
- To show where a folder came from, right-click the folder in the right pane and then click Where Did It Come From?
- To cancel a “dropped” action, right-click a folder in the right pane and then click Back Out Dropped Directory.
- To show all folders selected for copying, right-click a container in the left pane and then click Show Dropped Folders.
- To view the available disk space prior to performing the verification, right-click the destination volume in the right pane and then click Properties.

  Right-clicking on a source volume or folder in the left pane and then clicking Properties displays the size of the source object.

**Resolving Duplicate Directory Conflicts**

If you drag a folder from the source server into a folder with the same name on the destination server, a Duplicate Directory Encountered window appears. Here you can indicate how you want to handle occurrences of duplicate directories:

- Don’t Copy the Directory
  
  Ensures that directories already existing on the destination server are not overwritten. The Migration Wizard copies only the source directories that do not exist on the destination server.
- Merge Directory Contents
Merges the contents of the directory on the source server with the contents of the duplicate directory on the destination server.

- **Merge All**
  Merges the contents of all duplicate directories.

- **Rename**
  Renames a directory on the source server. You must enter a new directory name in the field provided. The directory on the destination server retains its original name.

### Migrating User Directories and Server Application Directories

Because the destination server takes the place of the source server when the migration is complete, you should model your project to minimize the necessity of changing user login script mappings and application load files.

To preserve login script mappings to user directories, drag-and-drop these directories to the same location on the destination server as on the source server.

Likewise, to preserve application load files, drag-and-drop application directories to the same location on the destination server as on the source server.

When you have finished modeling your migration project, continue with the next section, **Verify Your Migration Project**.

### Verify Your Migration Project

After you have modeled your migration by dragging-and-dropping data in the Project Window, you must verify your project to check for problems that might hinder a successful migration.

**NOTE:** Remember, dragged-and-dropped items appearing in the eDirectory tree are merely assigned to be copied to that area in the eDirectory tree. Objects are not migrated until you actually begin the migration.

You can also have Migration Wizard back up all trustee and ownership information for the source server in case NDS/eDirectory has to be removed from the source server and the trustees and ownerships restored.

Whichever verification option you choose, Migration Wizard backs up the trustee and ownership information for the source server’s standard sys: volume and dropped folders to special trustee backup files for use only by Migration Wizard. These files are copied to the destination server and the information they contain is restored during Step 4 of the migration (Finish the NDS/eDirectory Migration).

### Project Verification

To perform the verification without backing up all trustee and ownership information:

1. On the Migration Wizard toolbar, click Project > Verify and Migrate Project, or click the Verify and Migrate button.

2. (Conditional) If the Verification Wizard informs you of any problems it finds (such as insufficient rights, name spaces that are not loaded, disk space limitation, and improper TSAs), you must resolve these problems and rerun the Verification Wizard before proceeding.

Continue with the next section, **Migration Step 1: Copy File System Data**.
Verification with Full Trustee/Ownership Backup

To perform the verification and back up all trustee and ownership information on the source server:

1. On the Migration Wizard toolbar, click Project > Backup Trustees.
2. Enter the passwords for the source and destination servers and then click Next.
3. Read the information on the Ready to Copy Files screen and then click Next.

In addition to backing up trustee and ownership information for the sys: volume and dropped folders, Migration Wizard backs up all of the source server trustees and ownerships. This backup can be used in case the NDS/eDirectory database on the source server has to be removed and the trustees and ownerships restored. For more information on eDirectory restoration, see “NDS/eDirectory Migration Failures” on page 34.

4. (Conditional) If the Verification Wizard informs you of any problems it finds (such as insufficient rights, name spaces that are not loaded, disk space limitation, and improper TSAs), you must resolve these problems and rerun the Verification Wizard before proceeding.

Continue with the next section, Migration Step 1: Copy File System Data.

Migration Step 1: Copy File System Data

During the Copy File System Data step, the dropped directories are copied to the destination server and created directories are added to the destination server.

1. In the Project View dialog box, click Copy File System Data.

Before Migration Wizard starts copying files, it backs up your directory and file trustees and saves them in files located on the source and destination servers. When the eDirectory migration is complete, Migration Wizard restores the trustees from the files stored on the destination server.

2. In the Dropped Folders dialog box, verify the accuracy of the source and destination paths for all of your dropped folders and then click Next.

3. (Conditional) If you created new folders as part of your migration project, verify the source and destination paths in the Created Folders dialog box and then click Next.

4. In the Duplicate Files dialog box, indicate how you want to handle any duplicate filenames between the source and the destination by selecting one of the following and then click Next:
   - Don’t Copy Over Existing Files
     The file on the source server is not copied and the file with the same name on the destination server is not replaced.
   - Copy the Source File If It Is Newer (Default)
     If the file on the source server is newer than the one on the destination server, the file on the destination server is replaced.
   - Always Copy the Source File
     The file on the source server always replaces the file with the same name on the destination server.
5 In the Disable Login dialog box, indicate whether you want users to be logged in during the data migration by selecting one of the following and then click Next.

- **Copy Volumes with Users Logged In (Default)**
  Migration Wizard does not copy open files. Select this option if you want to copy nonaccessed files while users are logged in.

- **Disable Login**
  If you disable user login, you can be sure that no other users can log in to the network and open files during the file copy.
  If you want to delete all user connections prior to performing the migration, click Broadcast Logout Message to warn users to log out. If any user connections remain, you must manually disconnect them from the source server console.

6 In the File Date Filters dialog box, indicate whether you want to filter the files to be copied according to Accessed, Modified, or Created dates and then click Next.

If you select Yes, specify the desired date ranges. If you select No, all files are copied.

Two dates can be set for each attribute. The first date is an On or After date and the second is an On or Before date. For example, if you only select On or Before for the Accessed attribute and set the date for October 10, 2005, only those files accessed on or before October 10, 2005, are copied. In the same example, if you also select On or After and set the date to September 1, 2005, only those files accessed on or after September 1, 2005, and on or before October 10, 2005, are copied.

You can specify as many ranges as you want, and only those files that meet all of the selected criteria are copied.

7 In the Wildcard Selection dialog box, indicate whether you want to filter files by name or extension by typing the filenames or extension types in the field provided and then click Next.

You can use a wildcard character to represent one or more characters in a search. The two most commonly used wildcards are

- **The question mark (?)**
  Used to represent a single alphanumeric character in a search expression. For example, typing `te?q.txt` would exclude tent.txt, test.txt, and text.txt from the copy process.

- **The asterisk**
  Used to specify zero or more alphanumeric characters in a search expression. For example, typing `h*a.txt` would exclude his.txt, his.txt, house.txt, and happiness.txt from the copy process.

Type as many filenames or file extension types as you want. As in the following example, separate each entry with a hard return:

* .mp3
* .wav
  test.txt

8 In the Synchronize Files and Folders dialog box, specify whether you want the Migration Wizard to delete files and folders on the destination server that do not exist on the source server and then click Next.

If users are active on the source server while you model your migration project, it is possible that they could delete files and folders that you have already selected for migration.
Selecting Yes causes the Migration Wizard to scan all dropped folders after the copy process completes and to delete any files and folders from the destination server that don’t exist on the source server.

No is the default selection.

In the Compare Files and Folders dialog box, specify whether you want the Migration Wizard to compare files and folders between the source and destination servers after the copy process completes and then click Next.

Selecting Yes causes the Migration Wizard to compare the following information during the post-copy file comparison:

- Names
- Dates
- Sizes
- Attributes
- Trustees
- Owners

If you select Yes, you are given the option of doing a binary comparison of the files after the copy process completes. A binary (byte-by-byte) comparison gives the greatest assurance that two files are identical, but it takes longer to complete.

By default, the Migration Wizard compares the Read inhibit (Ri) and Delete inhibit (Di) attributes on Read-only files. If you do not want this check to be performed, deselect Compare Ri/Di Attributes. (See the online help for an explanation of why you might want to disable this comparison.)

No is the default selection.

Specify where to store the trustee backup files, then click Next.

The trustee backup files are stored on the destination server’s sys: volume by default. If your destination server has limited free space on volume sys:, you can select another volume to hold the backup files.

Type the passwords for the source and destination trees, then click Next.

SMS is the backup and copy engine used by the Migration Wizard. You type your passwords here because SMS requires that the servers involved in the migration be authenticated to each other.

(Conditional) If prompted, resolve any critical errors or warnings discovered during verification and then click Next.

If there were errors discovered in the verification attempt, they are shown in the Error Resolution dialog box. Errors could include name conflicts, insufficient rights, required name spaces not loaded, and insufficient disk space.

Errors found during the verification process are classified as follows:

- Errors that must be resolved before files can be copied
- Errors that should be resolved but might not affect the copy process
- Informational messages about the decisions you made in the Project Window

A description of each error and a possible resolution appear in the Information text box. If no resolution is provided, you can find more information in the Novell Error Codes online.

13  (Conditional) If newer NLM™ programs are available and you want to copy them to your system, click Yes in the dialog box that appears.

14  In the Ready to Copy Files dialog box, read the explanation of the file copy process and then click Proceed.

15  In the Back Up the Source Server’s Trustees screen, specify whether you want Migration Wizard to back up the source server’s trustee information and then click Next.
  •  Click Yes if you want Migration Wizard to back up all of the trustee information on the entire source server.
  •  Click No if you want Migration Wizard to back up the trustees of the volumes or folders you have selected to be migrated.

If Migration Wizard detects that trustees have already been backed up for the selected volumes or folders, you are asked if you want to back up the trustees for that specific volume or folder again.

The Migration Wizard proceeds with the trustee backup (if selected) and file copy.

16  When the Copy Volumes Status screen appears, review the error and success logs and then click Done.

Continue with the next section, Migration Step 2: Edit Configuration Files.

Migration Step 2: Edit Configuration Files

The Edit Configuration Files step compares the configuration files between the source and destination servers and lets you make any desired changes to those files.

1  In the Project View dialog box, click Edit Configuration Files.

Migration Wizard lets you modify any .ncf or .cfg files on the destination server. These files contain default LOAD statements and parameters.

IMPORTANT: Make sure that all files are closed before you migrate your eDirectory database.

2  In the text box, select the configuration file that you want to edit and then click Edit File.

3  Copy and paste the commands from the configuration file on the source server to the corresponding configuration file on the destination server, then click Save & Close.

If you intend to change the IP address on your destination server to be the same as the IP address of your source server, you must edit your configuration files and change the IP address in two places: autoexec.ncf and sys:\etc\hosts.

Copy the source server’s IP address and paste it into the destination server’s autoexec.ncf file. (This works only if your IP LOAD and BIND statements are located in autoexec.ncf.) You also need to go to the server console of the destination server and change the IP address in the sys:\etc\hosts file. Look for the original name of the destination server.

If you use INETCFG to assign IP addresses, change the IP addresses after the migration is complete.

4  (Conditional) If you are using configured time sources (timesync.cfg), copy and paste your Timesync information from the source server’s timesync.cfg file to the destination server’s timesync.cfg file.
5 Close the Compare Configurations dialog box.

Continue with the next section, Migration Step 3: Begin NDS/eDirectory Migration.

**Migration Step 3: Begin NDS/eDirectory Migration**

The Begin NDS/eDirectory Migration step migrates the eDirectory files from the source server to the destination server. The source server is brought down and the destination server is restarted during this step.

1 In the Project View dialog box, click Begin NDS/eDir Migration.

2 Before continuing, back up all volumes that you are not planning to migrate, ensure the following, and then click Next:
   - All volume data migrated successfully
   - All critical errors from the file copy are resolved
   - The servers in your source tree are in time synchronization and eDirectory is synchronized

Verify that you have run the DSRepair procedures in “Preparing the Source Server for Migration” on page 15 to ensure that the eDirectory tree containing the source server is functioning correctly.

**TIP:** If you are required to fix any eDirectory errors, wait approximately 30 minutes for the eDirectory tree to synchronize before continuing.

3 In the Update Schema dialog box, indicate whether you want the Migration Wizard to update the source server’s schema and then click Next.
   - Yes is the default selection. This causes the Migration Wizard to compare the source and destination schemas and update the source server’s schema to include the eDirectory classes of the default applications that are installed on the destination server. You must be logged in as a user with all rights to the [Root] of the tree to make these changes.
   - If you do not have the necessary rights to extend the schema, select No. The migration continues, but you might experience some problems with your eDirectory tree if you skip this procedure.

4 In the Verify Novell Directory Services Tree dialog box, click Yes to acknowledge that the source eDirectory tree is healthy (you should have run the DSRepair procedures in Step 2).

If you click No, the Migration Wizard does not prevent you from continuing. However, if your tree is unhealthy before you begin the migration, the migration might not complete successfully.

5 To ensure the security certificate works properly on the destination server, indicate how you want to copy the source server’s NICI configuration files to the destination server and then click Next.

To facilitate the NICI file copy, nuwnici.nlm is first copied to both the source and destination servers. You can choose to copy the NICI files Automatically (over the network) or using a diskette swap.

6 (Conditional) If you selected the diskette swap, continue with Step 6a. If you selected the automatic copy over the network, skip to Step 7.

6a To copy the nuwnici.nlm to the source and destination servers, click Copy NLM and click Next.
6b Insert a blank formatted diskette into the floppy drive on the destination server.

6c At the destination server console, enter

```
load nuwnici -1
```

6d Remove the diskette from the destination server and insert it into the source server’s floppy drive.

6e At the source server console, enter

```
load nuwnici -2
```

This copies the NICI files to the diskette.

6f Remove the diskette from the source server and insert it into the destination server’s floppy drive.

6g At the destination server console, enter

```
load nuwnici -3
```

This copies the NICI files to the destination server.

6h Click Next.

**TIP:** If you get NICI errors when eDirectory tries to load or when you copy the NICI files, check if pki.nlm will load on the destination server. If it won’t load, see “NICI Errors” on page 34.

7 Delete all user connections (except your own) to the source and destination servers, then click Next.

If you want to first broadcast a logout message to any users logged in to the server, click Broadcast Logout Message, type the message in the field, and then click OK.

8 Type the passwords for the source and destination trees, then click Next.

9 Resolve any critical errors or warnings on the Migrate NDS/eDir Verification Results screen, then click Next.

10 Perform the eDirectory step-by-step migration.

The eDirectory migration is divided into several steps. This is for diagnostic purposes. If the eDirectory migration fails for any reason, you know exactly what step it failed on and can take the appropriate measures to fix the problem.

For more information on the NDS/eDirectory migration process, including steps to restore the source and destination servers, see “NDS/eDirectory Migration Failures” on page 34.

10a Click Next.

The first step changes autoexec.ncf and timesync.cfg; modifies the server name in hosts, hostname, and snmp.cfg; and renames smdr.cfg to smdr.mig. The first step also renames rootcert.der in both the sys:system and sys:public directories to rootcert.der.bak.

At the end of the migration process, the source server is brought down and the destination server reboots and takes over the name and identity of the source server.

Migration Wizard automatically modifies the following items in the destination server’s autoexec.ncf file:

- The file server name is changed to the name of the source server
- The time zone is changed to the one stored in the source server’s autoexec.ncf file
- The server ID is changed to the IPX™ internal net value or server ID stored in the source server’s autoexec.ncf file
- The default time server type is changed to the value stored in the source server’s autoexec.ncf file
- The bindery context is changed to the bindery context stored in source server’s autoexec.ncf file

**IMPORTANT:** During the migration, the source server’s Timesync information is not automatically migrated.

10b Click Next again.

This step backs up eDirectory and copies the eDirectory backup files to the destination server and to sys:system\nuw30\ndsbu on the source server.

10c Down the source server by clicking Next.

The Source Server Status dialog box displays.

10d Verify that the source server is down by clicking Yes.

10e Click Next again.

This step removes eDirectory from the destination server and deletes the client connection.

10f Click Next again.

This step upgrades eDirectory on the destination server if necessary, restores eDirectory on the destination server, and prepares to reboot the destination server.

10g Reboot the destination server by clicking Next.

10h When you are ready to proceed, click Yes > Finish.

11 Check the former destination server and verify that it has restarted and taken on the name of the source server.

The server console prompt should display the source server’s name.

12 Exit the Migration Wizard.

The project file is automatically saved.

13 Reboot your workstation and log in to the former destination server.

This clears old connections from the workstation and establishes a clean connection to the former destination server.

If you can’t log in, refer to “Workstation-to-Server Connection Problems” on page 32.

14 Restart the Migration Wizard utility.

15 Read the About screen, then click OK.

16 Click Open Last Project > OK.

The utility verifies that the first three steps of the project file are complete.

17 Click Yes when prompted if you are ready to proceed to the fourth step.
Migration Step 4: Finish the NDS/eDirectory Migration

The Finish the NDS/eDirectory Migration step upgrades the schema and restores the trustees to the new server after it has restarted.

1. In the Project View dialog box, click Finish NDS/eDir Migration.
   The Continue NDS/eDir Migration dialog box appears, outlining the eDirectory health checks and other tasks you should complete before continuing.

2. To run the NDS/eDirectory backlinker process, go to the destination server console and enter the following commands:
   ```
   set dstrace=on
   set dstrace=+blink
   set dstrace=*b
   ```
   Check the Directory Services screen for messages indicating the successful completion of the backlinker process.

3. On the Continue NDS/eDir Migration screen, click Yes > Next.

4. Type the tree password in the field provided, then click Next > Continue.

5. Review the error and success logs, then click Done.

6. In the Project View dialog box, click Close.

7. Click File > Exit to exit the Migration Wizard.

Continue with the next section, Perform Post-Migration Tasks.

Perform Post-Migration Tasks

1. Run DSRepair on the destination server and select Unattended Full Repair to ensure that eDirectory is functioning properly.

2. Using ConsoleOne®, verify that the user information migrated successfully.
   **TIP:** During the migration, the standard `sys:` directory from the source server is saved in the `sys.mig` directory on the destination server.

3. Run DSRepair > Time Synchronization to verify that your source server is synchronized with the rest of your servers.

4. Verify that the correct IP address is assigned to the new server in all appropriate files.
   For example, check `autoexec.ncf`, `sys:\etc\hosts`, and `sys:\etc\hostname`, or type `config` at the server console.
   **IMPORTANT:** Failure to have the correct IP address in the hosts or hostname files causes the post-installation of some products to fail.

5. (Conditional) If you have performed a migration to a NetWare 6.0 destination server, verify that `sys:\public\rootcert.der` exists.
   If it does not exist, copy the file from an existing server on the network, or create a new one following the instructions in ROOTCERT.DER not exported during the install of Certificate server (http://support.novell.com/cgi-bin/search/searchtid.cgi/?10066860.htm).
   If the rootcert.der file does not exist, a post-migration install of applications could fail.
6 (Conditional) If you haven’t already done so, install the latest NetWare Support Pack on the destination server.

This ensures that you get the latest code for the applications that you are reinstalling. The latest Support Packs are available at the Novell Support Web site (http://support.novell.com/misc/patlst.htm).

7 Reinstall any server applications.

**IMPORTANT:** Because the source server’s eDirectory database replaces the destination server’s eDirectory database, all eDirectory objects on the destination server before the migration, including those representing applications, are replaced by the eDirectory objects that exist on the source server. However, the NLM programs associated with the destination server’s applications still exist. Because you cannot manage applications without their corresponding eDirectory objects, you must reinstall the applications to restore their eDirectory objects to the tree.

You can reinstall these network products and services using either of two methods:

- Go to the destination server, load the GUI interface if necessary by typing `startx`, and click the Novell icon in the lower-left corner of the servertop. Then click Install > Add to install products.

- To install products remotely, run the NetWare Deployment Manager utility (nwdeploy.exe, or nwdeploynobrowser.exe for a nonbrowser-based version) located on NetWare 6.5 CD 1 (Operating System). Under Post-Install tasks, select Install NetWare 6.5 Products and follow the on-screen instructions to run the Remote Product Install utility.

**Installing Tomcat and exteNd Application Server after the Migration**

If needed, after completing a NetWare 6.5-to-NetWare 6.5 migration using the Migration Wizard, complete the following steps to ensure that Tomcat installs correctly:

1. Copy `sys:\sys.mig\java` to `sys:\java`, overwriting all existing files.
2. Copy `sys:\sys.mig\adminsrv` to `sys:\adminsrv`, overwriting all existing files.
3. Copy `sys:\sys.mig\system\ipconf` to `sys:\system\ipconf`, overwriting all existing files.

After completing a NetWare 6.5-to-NetWare 6.5 migration using the Migration Wizard, complete the following steps to ensure that exteNd™ Application Server installs correctly:

1. Copy `sys:\sys.mig\java` to `sys:\java`, overwriting all existing files.
2. Copy `sys:\sys.mig\etc\my.cnf` to `sys:\etc\my.cnf`.

**Installing Native File Access for UNIX after the Migration**

If needed, after completing a NetWare 5.1-to-NetWare 6.5 migration using the Migration Wizard, complete the following steps to ensure that Native File Access for UNIX installs correctly:

1. Delete the NFAU User object.
2. Run the schinst utility by entering

   `schinst -n -w`

   SCHINST takes the administrator’s FDN and password as input for extending the schema.
3. Run nisinst.
4. Execute nfsstart.
4 Troubleshooting

Refer to the appropriate section if you are having trouble with any of the following:

- General Connection Problems (page 31)
- Workstation-to-Server Connection Problems (page 32)
- Server-to-Server Connection Problems (page 32)
- File Copy Problems (page 32)
- SMDR Errors (page 33)
- Restoring Trustees (page 33)
- Nuwagent.nlm Load Errors (page 33)
- NICI Errors (page 34)
- NDS/eDirectory Migration Failures (page 34)
- CCS_pbeDecrypt Error When Migrating from NetWare 5.0 (page 38)

General Connection Problems

To eliminate unnecessary connection problems, make sure that

- The source and destination servers have enough available server and workstation licenses to do the migration.

- The eDirectory™ user that you are using to do the migration has no concurrent connection limitations. To check this, do the following:
  - Run ConsoleOne® on the workstation.
  - Edit the properties of the User object.
  - Click the Login Restrictions tab.
  - Deselect the Limit Concurrent Connections option.

- The eDirectory user that you are using to do the migration has the Supervisor right to the source server’s eDirectory object. Use ConsoleOne to verify that the User object is listed in the source server’s Operators list.
Workstation-to-Server Connection Problems

If you have problems establishing or maintaining connections between your servers and workstations, try one or more of the following:

- Reboot the client workstation to clear the cache in the Novell® Client™ software.
- Map a drive to the server instead of logging in. This is especially useful when connecting with the IPX™ protocol.
- Search for the server by its IP or IPX address instead of its name. Type the IP or IPX address in the Server field of the Novell Login dialog box.
- Try connecting to the server and not the eDirectory tree by specifying only the name of the server and leaving the tree name and context blank.
- Clear all unauthenticated connections. To do this, right-click the N icon and then click NetWare Connections. Detach from all servers and trees that you are not authenticated to, then try logging in again.
- Make sure your Preferred NetWork Protocol is set correctly by doing the following:
  - Right-click the N icon.
  - Click Novell Client Properties > Protocol Preferences.
  - Select the desired preferred network protocol, then click OK.
  - Reboot the workstation.
- Unbind the protocol you are not using from the destination server. For example, if you are using IP for the migration but IPX is bound on the destination server, unbind the IPX protocol on the destination server during the migration.

Server-to-Server Connection Problems

If you have problems establishing or maintaining connections between your servers, try one or more of the following:

- Do not remove the source and destination servers from their respective eDirectory trees. The servers must be able to communicate with the other servers in the tree during the migration.
- Make sure the destination and source servers can communicate with each other.
  For IP connections, enter `ping` at the server console and specify the other server’s IP address.
  For IPX connections, enter `display servers` at the server console.
- For IP connections, verify that you have corresponding addressing, subnet mask, and gateway information. If you are using IPX, make sure the frame type and the IPX network number/server ID are consistent between the source and destination servers.
- Reboot the destination server.

File Copy Problems

If you are having problems during the file copy, try one or more of the following:

- Enable login on both the destination and source servers. If you have disabled login before you started the file copy, the servers can’t log in to each other in order to migrate the files.

  NOTE: If you have selected to do so, Migration Wizard disables user logins for you during the migration.
If files are copying very slowly, make sure that the servers and workstation are configured at the highest common LAN speed. Verify that the NICs and anything in between are all hard coded to either communicate half-duplex or full-duplex; they need to be the same throughout. If there are problems with full-duplex, use half-duplex.

**NOTE:** If compressed files are migrated to uncompressed volumes, file copy might be slower.

If Migration Wizard encounters filenames with a total path length of more than 256 bytes, the file copy stops. You might need to reorganize the data on your source server if your path lengths are longer than 256 bytes.

**SMDR Errors**

Sometimes the smdr.nlm program that is running on the destination server can’t make a connection to the source server. To correct this problem, try one or more of the following:

- Unbind the protocol you are not using from the destination server. For example, if you are using IP for the migration but IPX is bound on the destination server, unbind the IPX protocol on the destination server during the migration.

- If Migration Wizard can’t load the appropriate tsa.nlm on your destination server, manually load it from the destination server console and following the onscreen instructions. Or, enter `smdr new` at the server console to re-create the SMDR object.

- Load smdr.nlm at the destination server console and then enter `smdr new` at the destination server console to solve SMS problems.

- Make sure the latest NLM™ programs are loaded on your servers.

  Migration Wizard automatically copies the required NLMs to the source and destination servers. To verify that you have the latest NLMs loaded, check the files in the NetWare Migration Wizard\products\nw3x directory. You might have to load TSA312 manually.

- Check your primary connections. Right-click the N icon, then click NetWare Connections. Make sure the destination tree and server are marked as Primary.

- Reboot the source server.

**Restoring Trustees**

- If the trustees fail to restore and you get a 0xfffffffb error, this means that you did not modify your server’s IP address in all the necessary places. For more information, see “Migration Step 2: Edit Configuration Files” on page 24.

- If you need to restore trustees, you can click the Finish NDS/eDir Migration button in the Migration Wizard, or select Restore Trustees on the toolbar.

**Nuwagent.nlm Load Errors**

Nuwagent.nlm is the NLM program that Migration Wizard uses to do much of its work. If you get errors that the nuwagent.nlm won’t load, try the following:

- Manually load nuwagent.nlm at the server console.

- Enter `smdr new` at the destination server console. This re-creates the SMDR configuration and allows nuwagent.nlm to load.
NICI Errors

If you are getting NICI errors when eDirectory is trying to load or when you are copying the NICI files in Migration Wizard, this might mean that your NICI files are corrupt. To correct the problem, follow these steps on the server that is getting NICI errors:

1. Copy the *.nfk file from NetWare 6.5 CD 1 (Operating System) to the server’s sys:system directory.
2. Rename the *.nfk file that you just copied to nicifk (this has no extension).
5. Run nrepair.nlm on the server, clicking Yes at all the prompts.
6. Reboot the server.
7. Load pki.nlm on the server and verify that you are no longer getting NICI errors.

If you still see NICI errors, refer to TID #10025666 (http://support.novell.com/search/xxxxxx) in the Novell Knowledgebase.

NMAS Error When Migrating from NetWare 5.1

When migrating from NetWare 5.1 Support Pack 7 with eDirectory 8.0 to NetWare 6.5 Support Pack 2 using Migration Wizard 8.0, NMAS™ might show a -1660 (0xFFFFF984) error after completing Step 3 (Start NDS®/eDirectory Migration) and rebooting the server and client.

This is the expected behavior because this is a new server that hasn't been fully installed, so there are no objects in the Security container, which means that NMAS (and other security products such as NICI and PKI) have not been configured.

If you have Novell Client™ 4.9 and later, you must disable the NMAS authentication. Right-click the N icon, click Novell Client Properties > Advanced Login, then deselect the NMAS Authentication option.

NDS/eDirectory Migration Failures

If the migration fails during the NDS/eDirectory Migration step, you need to restore the source and destination servers to their original configuration before you can retry the NDS/eDirectory migration. The instructions for restoring the servers to their original configurations are different depending on when the migration of data failed.

If Begin NDS/eDir Migration (Step 3) failed and the destination server did not reboot and take on the name and identity of the source server, complete the steps in “Restore Source Server to Its Original Configuration” on page 35.

If Begin NDS/eDir Migration (Step 3) successfully completed and the destination server has already rebooted and taken on the name and identity of the source server, complete the steps in the following sections:

1. “Remove NDS/eDirectory from the Destination Server” on page 35.
4. “Reinstall the Destination Server” on page 38.

**Restore Source Server to Its Original Configuration**

If Begin NDS/eDir Migration (Step 3) failed and the destination server did not reboot and take on the name and identity of the source server, you need only restore NDS/eDirectory to the source server. When NDS/eDirectory has been restored, you have restored the source server to its original configuration and you are ready to try the NDS/eDirectory migration again.

1. Enter one of the following at the server console of the source server:
   - load install if the source server is running NetWare 4
   - nwconfig if the source server is running NetWare 5 or later
2. Select Directory Options > Directory Backup and Restore > Restore Local DS Information after Hardware Upgrade.
3. Press F3 and enter `sys:system\nw30\ndsbu` when prompted for the location of the backup files.

   NDS/eDirectory has now been restored to the source server.

   **IMPORTANT:** Do not reboot the destination server. Because the destination server did not take over the identity of the source server, no other action is required prior to performing the NDS/eDirectory migration again.

4. Perform the NDS/eDirectory migration again.
   4a. Launch Migration Wizard and open the project you were previously working on.
   4b. When the project opens and you see the Project Window, click Begin NDS/eDir Migration.
   4c. Follow the instructions in “Migration Step 3: Begin NDS/eDirectory Migration” on page 25.

**Remove NDS/eDirectory from the Destination Server**

If Begin NDS/eDir Migration (Step 3) successfully completed and the destination server has already rebooted and taken on the name and identity of the source server, you must remove NDS/eDirectory from the destination server before you can restore NDS/eDirectory to the source server.

1. At the destination server console, enter `nwconfig`.
2. Select Directory Options > Remove Directory Services from This Server.
3. Press Enter when you see a warning instructing you to not remove Directory Services.
   Ignore any other errors during the removal of NDS/eDirectory.
5. Specify the Admin username and password.
6. Press Enter to reference a different object.

   This object is used when NDS/eDirectory is restored back to the source server.

   **WARNING:** Do not press Esc. If you do, the server references you entered will not be saved or restored to the server.
7 Specify the full Admin username as the placeholder object distinguished name.

8 Specify Root as the distinguished name to change from.

9 (Conditional) If the information about the single reference time source appears, review the information and press Enter.

10 (Conditional) If your server holds the master copy of a replica, press Enter when you see a warning.

11 Designate another server to hold the master replica.
   You can choose to let NWCONFIG randomly select another server or you can designate one yourself.

12 Return to the NWCONFIG utility and select Remove Directory Services from This Server to verify that NDS/eDirectory has been removed.
   If a message appears saying that NDS/eDirectory has already been removed, bring the destination server down and continue with the next section, Remove NDS/eDirectory from the Source Server.
   If NDS/eDirectory was not successfully removed, exit NWCONFIG and enter `nwconfig -dsremove` at the destination server console. Then follow this procedure again, beginning with Step 2 on page 35.

Remove NDS/eDirectory from the Source Server

After NDS/eDirectory has been removed from the destination server, remove NDS/eDirectory from the source server.

1 Restart the source server by entering `server` at the DOS command prompt.

2 Enter one of the following:
   * `load install -dsremove` (if source server is running NetWare 4)
   * `nwconfig -dsremove` (if source server is running NetWare 5 or later)
   INSTALL or NWCONFIG will now ignore any warnings or errors during the removal of NDS.

3 Select Directory Options > Remove Directory Services from This Server.

4 Press Enter to skip past any warning screens.

5 Select Yes to remove NDS/eDirectory.

6 Press Enter to skip the error message warning you that eDirectory is locked.
   Ignore, but keep track of, any additional eDirectory error messages that appear.

7 When the INSTALL or NWCONFIG menu appears again, select Remove Directory Services again.
   If a message indicates that eDirectory is already removed, continue with the next section, Restore NDS/eDirectory to the Source Server.
   If eDirectory was not properly removed, contact Novell Technical Services℠.
Restore NDS/eDirectory to the Source Server

By removing NDS/eDirectory from the source server, you removed the server from any replica rings that held a partition of the source server. Now you must complete the following procedure to restore NDS/eDirectory to the source server.

1. Enter one of the following at the server console:
   • \texttt{load install} (if source server was running NetWare 4)
   • \texttt{load nwconfig} (if source server was running NetWare 5 or later)

2. Select Directory Services > Install Directory Services onto This Server.

3. Select the eDirectory tree where the source server existed prior to migration.

4. Select a time zone and time configuration parameters.
   Make a note of any warnings or errors that appear during the restoration of eDirectory and press Esc to continue without fixing the errors.

5. Enter the Admin name and password.

6. Type the context where the source server existed prior to migration, then press F10.

7. Save the NDS (Directory) information.

8. Wait while the server synchronizes with the eDirectory tree, which might take a while.

9. Return to the INSTALL or NWCONFIG utility and select Directory Options > Select Directory Back Up and Restore > Restore Reference from another Object to This Server.
   This restores all references that you assigned to the Server object when you removed eDirectory from the destination server.

10. Press Enter.

11. Enter the full Admin username as the placeholder object distinguished name, then specify Root as the distinguished name to change from.

12. Exit the NWCONFIG or INSTALL utility.

13. At the server console of the source server, enter \texttt{load dsrepair}.

14. Select Unattended Full Repair > Advanced Options > Check Volume Objects and Trustees.

15. Enter the Admin username and password.

16. Exit DSREPAIR.

17. At the workstation where you performed the migration, open your project.

18. From the Migration Wizard Tools menu, select Restore Trustees to restore the trustee assignments.

19. (Conditional) If the source server held the master replica of any partitions and you want to restore these partitions prior to doing the eDirectory migration again, use DSREPAIR to recreate them.
   The source server is now restored to its original configuration.

Continue with the next section, Reinstall the Destination Server.
Reinstall the Destination Server

To perform the migration again, you must reinstall the operating system on the destination server.

**TIP:** If you had your server imaged, you can just restore the image rather than reinstall the server.

1 Bring down the destination server.
2 Install NetWare and follow the on-screen instructions during the installation.

After NetWare is installed on the destination server, you are ready to perform the eDirectory migration again. Go to “Migration Step 3: Begin NDS/eDirectory Migration” on page 25.

**CCS_pbeDecrypt Error When Migrating from NetWare 5.0**

When performing a migration from NetWare 5.0, you might receive a CCS_pbeDecrypt error on the source server console when attempting to back up either the source server trustees or the NDS database.

If this occurs, make sure that the latest Support Pack is installed on the NetWare 5.0 server and then do the following:

1 At the NetWare 5.0 source server console, enter `down`
2 At the DOS prompt, enter:
   
   ```
   copy c:\nwserver\expxeng.xlm c:\nwserver\novxeng.xlm
   ```
3 Enter:
   
   ```
   copy c:\nwserver\domxeng.xlm c:\nwserver\novxeng.xlm
   ```
4 Restart the NetWare 5.0 server.

**NOTE:** This might fail because domxeng.xlm is not present. This is not a problem.

If you used a directory other than `nwserver` to store the server files, substitute that directory for `nwserver` in steps 2 and 3.