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About This Guide

This guide describes how to use the Novell® NetWare® Migration Wizard to copy data from one
NetWare server to another NetWare server in your network. The guide is intended for network
administrators and is divided into the following sections:

¢ Chapter 1, “NetWare Migration Overview,” on page 9 explains the features and capabilities
of Novell NetWare Migration Wizard.

¢ Chapter 2, “What’s New,” on page 11 lists new and enhanced features in each release of
NetWare Migration Wizard.

¢ Chapter 3, “Preparing for a Server Migration,” on page 13 provides instructions for installing
the NetWare Migration Wizard and preparing the servers for the migration.

¢ Chapter 4, “Migrating Data from NetWare Servers,” on page 17 contains the instructions for
migrating data from a NetWare 5 or NetWare 6 server.

¢ Chapter 5, “Troubleshooting,” on page 31 provides solutions for resolving errors encountered
during the migration.

* Chapter 6, “Security Considerations,” on page 39 provides information on how to use
Migration Wizard in the most secure way possible.

Documentation Updates

For the most recent version of this guide, see the Novell online documentation (http://
www.novell.com/documentation).

Documentation Conventions

In this documentation, a greater-than symbol (>) is used to separate actions within a step and items
in a cross-reference path.

A trademark symbol (®, ™ etc.) denotes a Novell trademark. An asterisk (*) denotes a third-party
trademark.

When a single pathname can be written with a backslash for some platforms or a forward slash for
other platforms, the pathname is presented with a backslash. Users of platforms that require a
forward slash, such as Linux* and UNIX*, should use forward slashes as required by your
software.

Additional Documentation

The entire NetWare 6.5 documentation set is available online at the Novell NetWare 6.5 Product
Documentation Web site (http://www.novell.com/documentation/nw65).

The entire Open Enterprise Server (OES) documentation set is available online at the Novell OES
Product Documentation Web site (http://www.novell.com/documentation/oes).

About This Guide 7


http://www.novell.com/documentation
http://www.novell.com/documentation/nw65
http://www.novell.com/documentation/nw65
http://www.novell.com/documentation/oes
http://www.novell.com/documentation/oes

User Comments

We want to hear your comments and suggestions about this manual and the other documentation
included with OES. To contact us, use the User Comments feature at the bottom of any page in the
online documentation.
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NetWare Migration Overview

The Novell® NetWare® Migration Wizard 8.1 is one of two utilities included in the Novell Server
Consolidation and Migration Toolkit. NetWare Migration Wizard lets you copy file system data
and the NDS®/eDirectory™ database from an existing NetWare server to a new NetWare server on
your network. When the migration is complete, the new server replaces and assumes the identity
of the old server on the network.

NetWare Migration Wizard version 8.1 supports migrations from NetWare 4, NetWare 5, or
NetWare 6 source servers. Destination servers must be running NetWare 6. It also supports Open
Enterprise Server (OES) for NetWare as a source and destination server.

IMPORTANT: If you want to migrate data from servers in Microsoft* Windows* domains, or consolidate data
from one or more NetWare servers to existing OES NetWare servers, OES Linux servers, or Novell Nterprise™
Branch Office™ Appliances, use the Novell Server Consolidation Utility 4.1 that is included as part of the
Server Consolidation and Migration Toolkit.

This chapter describes what NetWare Migration Wizard is and how you can use it to migrate data
from an existing NetWare server to a new NetWare 6 or OES NetWare server.

For a version history of new features in each release of NetWare Migration Wizard, see Chapter
2, “What’s New,” on page 11.

About NetWare Migration Wizard

Novell NetWare Migration Wizard is designed to help you transfer the identity of one server to
another server. This is what is referred to as a server hardware upgrade.

NOTE: If you want to add a new server with a new name into your network, you wouldn’t use the Migration
Wizard; you would use the NetWare server installation program.

NetWare Migration Wizard is an ideal tool for moving existing NetWare data onto faster, more
reliable server hardware. It is a Windows-based program that you install and run on a workstation.
With the Migration Wizard, you model your migration project using simple drag-and-drop
procedures before you actually perform the migration. This helps prevent errors from interrupting
your data migration and allows you to prevent mistakes before they happen.

You can also take advantage of this modeling capability to reorganize the data on your server and
even resize volumes, if needed. However, Migration Wizard is best suited for migrations requiring
a minimal amount of volume reorganization.

As you work through the modeling phase of NetWare Migration Wizard, all of your decisions are
recorded in a migration project file. At any time during the modeling process, you can save the
project file, exit the utility, and then restart Migration Wizard and resume from where you left off.

After the modeling phase is completed, you can proceed with the actual migration. This process is
divided into four basic steps:

¢ Step 1: Copy File System Data.

NetWare Migration Overview 9



10

Using the data contained in the migration project file, Migration Wizard copies the files and
folders (or even entire volumes) you selected from the source server to a newly

installed destination server. All file system data, including meta-data such as file trustees,
ownerships and attributes, is copied from the old machine to the new one.

+ Step 2: Edit Configuration Files.

During this step, Migration Wizard presents configuration files such as autoexec.ncf and
startup.ncf side-by-side so you can easily copy commands and settings from the source
server’s configuration files to matching files on the destination server.

¢ Step 3: Begin NDS/eDirectory Migration.

The NDS®/eDirectoryT’V' files are transferred from the old server to the new one without any
additional work on your part. After the migration, the eDirectory partitions that existed on the
old server will exist on the new server. This is because the Migration Wizard backs up the

entire eDirectory database on the source server and then restores it on the destination server.

+ Step 4: Finish NDS/eDirectory Migration.

After the source server’s file system and NDS/eDirectory database are migrated to the
destination server, the source server is automatically brought down and the destination server
reboots and assumes the name and identity of the source server on your existing network.

Existing
Temporary NDS Tree
NDS Tree
Temporary |
Server Name replaces
and
. assumes
NetWare the identity ‘
Destination Server of

Source Server

Before you can migrate your data, you must first install a destination NetWare server in a
temporary eDirectory tree. A temporary eDirectory tree is simply a tree that contains one server
with a pre-migration installation of NetWare and no additional products installed (other than SMS
and other products installed by default).

Migration Wizard automatically modifies the destination server’s autoexec.ncf file to include the
source server’s name and internal IPX™ number/server ID. You don’t have to modify these
manually. Because the server’s identity has been transferred from one physical server to another,
you don’t need to upgrade any client applications that might be doing drive mappings or running
applications based on the server name. However, you do have to manually change the IP address
of the destination server to match that of the source server.

Migration Wizard does not migrate any products and services that are running on the source server.
After the migration is complete, you need to reinstall all applications on the destination server and
reconfigure them, if necessary.

NetWare Migration Wizard 8.1 Administration Guide



2 What’s New

This chapter lists the new features and enhancements for the Novell® NetWare® Migration
Wizard.

Product History

This section lists the enhancements and new features introduced in NetWare Migration Wizard 8.1
and previous versions back to version 6.5.

TIP: Each new release of NetWare Migration Wizard includes performance enhancements and bug fixes that
increase the speed and reliability of NetWare migrations. If you have had unsatisfactory results with early
versions of this utility, we encourage you to give the latest version a try.

Migration Wizard 8.1

*

Packaged Migration Wizard as part of the Novell Server Consolidation and Migration Toolkit.
NetWare Migration Wizard 8.1 is now launched from the Server Consolidation and Migration
Toolkit. The Toolkit provides a single launch interface for both the Server Consolidation
Utility and the NetWare Migration Wizard.

Removed functionality for full backup of source server’s trustees. The ability to perform a full
backup of all the source server’s trustees has been removed from the NetWare Migration
Wizard. This confusing and time-consuming step is not needed as long as you do a full backup
of the source server.

You can still choose to back up trustees for the files you are migrating.

Added support for NetWare 4.x and NetWare 5.0 as source servers. This functionality was
previously available only in Migration Wizard 6.5.

Migration Wizard 8.0

*

Added the ability to filter the files you want to copy according to creation, last accessed, or
modified dates.

Let you exclude specific file types or file names from the copy process.

Included an option to synchronize file and folders so that data deleted while you model a
migration project is also deleted on the destination server when you run the project.

Gave you the option to automatically compare file information between the source and
destination after the copy process is complete to validate the integrity of the file copy.

Migration Wizard 7.1

*

Allowed migration directly from a NetWare 6 source server to a NetWare 6.5 destination
server.

What’s New 11



What’s Next

See Chapter 3, “Preparing for a Server Migration,” on page 13 for instructions on how to install
the NetWare Migration Wizard on a Windows workstation and prepare the source and destination
servers for a successful migration.

12

Migration Wizard 7.0

*

Sped up the file copy procedure by implementing multithreading in determining file sizes
while the file copy is running.

In previous versions of the Migration Wizard, the file copy procedure did not begin until the
file sizes were completely discovered. With Migration Wizard 7.0, the copy procedure and the
file size determination occured simultaneously.

Allowed NICI keys to be transferred across the wire during the migration.

Previous versions of the Migration Wizard required using a floppy diskette swap to transfer
NICI keys. Migration Wizard 7.0 still provided the option of using the floppy diskette swap if
wanted, but the transfer could be completed quickly and securely over the wire instead.

Displayed a listing of created folders, dropped volumes, and dropped folders during the
verification stage of the migration.

Added the ability to update ZENworks® for Servers information during the migration process.
Removed support for migrating data from NetWare 3 and 4 source servers.

Moved the NT-to-NetWare migration capability to the Server Consolidation Utility 2.5.
Moved the printing migration capability to the Server Consolidation Utility 2.5.

Migration Wizard 6.5

*

*

*

File copy operation no longer required you to have exactly the same volumes on the source
and destination servers.

This version introduced the drag-and-drop interface that allows the user to model the
migration project before actually performing the migration.

The Begin NDS/eDir Migration step was divided into several substeps to allow you to verify
that each step completed correctly before continuing.

NetWare Migration Wizard 8.1 Administration Guide



Preparing for a Server Migration

To prepare your network for a server migration with the Novell® NetWare® Migration Wizard,
complete the tasks in the following sections:

¢ “Meeting System and Software Requirements” on page 13
¢ “Preparing the Source Server for Migration” on page 14

¢ “Installing the Destination Server” on page 14

Meeting System and Software Requirements

The Server Consolidation and Migration Toolkit, which includes NetWare Migration Wizard 8.1,
runs on a Windows workstation. This section provides information about the system and software
requirements for the Windows workstation, the source server, and the destination server.

Workstation Requirements

NetWare Migration Wizard 8.1 is installed as part of the Server Consolidation and Migration
Toolkit. If you have not already met the workstation requirements and installed the toolkit, see
“Installing the Server Consolidation and Migration Toolkit” in the Novell Server Consolidation
and Migration Toolkit Administration Guide.

Source Server Requirements

The source server is the NetWare server that contains the files, volumes, and NDS®/eDirectory™
objects to be copied to the NetWare destination server.

U The source server must be running a supported version of NetWare. See “Supported Source
and Destination Server Versions” in the Novell Server Consolidation and Migration Toolkit
Administration Guide for more information.

U If necessary, update the source server with the latest NetWare Support Pack.

Updates are available at the Consolidated Support Pack home page (http://
support.novell.com/tools/csp).

U You must have the Supervisor right to the source server’s file system and the source server
itself.

Use ConsoleOne® to verify that you have the necessary rights.

IMPORTANT: When migrating a NetWare 6.0 server with eDirectory version 8.6.2 to a new NetWare 6.0
server with eDirectory 8.6.2, you might encounter an NDS error stating you couldn’t copy an NDS object
because you do not have the proper rights. This can occur even if you are logged in as Admin.

Installing eDirectory version 8.7 or later on the source server and running the migration again resolves
this issue.

Preparing for a Server Migration 13
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Destination Server Requirements

The destination server is the new computer that is to receive the data from the source server. This
server must be installed into a temporary tree and it must be the only server in that tree.

U The destination server must be running a supported version of NetWare. See “Supported
Source and Destination Server Versions” in the Novell Server Consolidation and Migration
Toolkit Administration Guide for more information.

Migration Wizard 8.1 does not migrate to NetWare 4 or NetWare 5 destination servers.

U Select the Pre-Migration Server pattern when you install the destination server, as instructed
in “Installing the Destination Server” on page 14.

U You must have the Supervisor right to the destination server’s file system and the destination
server itself.

After you install the destination server, use ConsoleOne to verify that you have the necessary
rights.

U The source and destination servers must be using the same time synchronization method:
Timesync (timesync.nlm) or NTPv3 (xntpd.nlm).

See the Network Time Management for NetWare Administration Guide for OES for more
information about time synchronization.

Preparing the Source Server for Migration
Before you launch NetWare Migration Wizard from the Server Consolidation and Migration
Toolkit, follow these steps to prepare the source server:

1 Shut down any applications, products, or services (virus scan software, backup software, etc.)
running on the server to be migrated.

2 Verify the health of eDirectory by loading DSRepair and running the following three options:
¢ Unattended Full Repair
¢ Time Synchronization
+  Report Synchronization Status
If any errors are reported, resolve them before attempting the migration.
3 Back up eDirectory and all data on the server.

4 Remove any unnecessary applications, then delete and purge unused files and folders.

Installing the Destination Server
The next step is to install the destination server with the NetWare operating system that you are
migrating to.

1 Obtain the NetWare installation software for the version of NetWare you require (NetWare
6.0 or NetWare 6.5/0pen Enterprise Server).

2 Prepare the new server hardware as recommended in the NetWare installation documentation.

3 Run the NetWare Install program.
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¢ For instructions on installing NetWare 6.0, see the NetWare 6 Overview and Installation
Guide (http://www.novell.com/documentation/nw6p/index.html?page=/documentation/
nwop/setupenu/data/hz8pck9v.html).

¢ For instructions on installing NetWare 6.5, see the NetWare 6.5 Installation and
Overview Guide (http://www.novell.com/documentation/nw65/install/data/
hz8pck9v.html).

¢ For instructions on installing Open Enterprise Server for NetWare, see the OES for
NetWare Installation Guide (http://www.novell.com/documentation/oes/install-nw/data/
hz8pck9v.html).

4 During the installation, make sure that you do the following:

+ Asyou create volumes, verify that you have enough room on your destination server to
accommodate your source server data.

If you are migrating compressed volumes to uncompressed volumes, Migration Wizard
decompresses the volumes during the migration. Make sure you have enough room on
the uncompressed volume to accommodate the source volumes after they are
decompressed.

¢ Select the Pre-Migration Server pattern.

+  Assign a different IP address to the destination server than is assigned to the source
server.

After the migration completes and the source server is taken offline, you can change the
destination server’s IP address to match what had been assigned to the source server.

*  Assign the destination server a temporary name and install it into a new temporary
eDirectory tree.

You can name the server and tree anything you want (provided the names do not conflict
with any existing server or tree on the network), because they are only temporary and
cease to exist after the migration is complete.

IMPORTANT: The temporary server name and temporary tree name must not be the same as the
source server’s name or tree name; otherwise, the destination server cannot assume the identity of
the source server after the migration.

5 (Conditional) If the destination server is running NetWare 6.5/Open Enterprise Server, you
must disable the Universal Password feature until the migration completes.

Universal Password is disabled by default on NetWare 6.5/0Open Enterprise Server.

What’s Next

For instructions on using the NetWare Migration Wizard, continue with Chapter 4, “Migrating
Data from NetWare Servers,” on page 17.
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Migrating Data from NetWare Servers

After you have completed the prerequisite procedures in Chapter 3, “Preparing for a Server
Migration,” on page 13, you are ready to migrate data from your NetWare source server. To do
this, complete the following tasks in the order they are listed:

1.

A A A O

Review Tips for a Successful Migration (page 17)

Launch Migration Wizard and Create a Project File (page 17).
Model Your Migration Project (page 18).

Verify Your Migration Project (page 20).

Migration Step 1: Copy File System Data (page 20).

Migration Step 2: Edit Configuration Files (page 23).

Migration Step 3: Begin NDS/eDirectory Migration (page 24).
Migration Step 4: Finish the NDS/eDirectory Migration (page 27).
Perform Post-Migration Tasks (page 27).

Review Tips for a Successful Migration

¢ When you run the NetWare Migration Wizard, you must be logged in to the network as a user

with the Supervisor right to both the source and destination servers. If you are not logged in
when you start the Migration Wizard, you can log in as you select the source and destination
trees.

For better performance, we strongly recommend that the source server, destination server, and
client workstation run on a common LAN segment.

You should use the fastest workstation available to run the Migration Wizard. If possible,
assign the workstation a static IP address. Turn off screen savers and power management to
avoid interruptions during the migration.

Launch Migration Wizard and Create a Project File

1 If you have not already done so, start the Server Consolidation and Migration ToolKkit.

By default, the toolkit is installed in c:\program files\novell server consolidation and
migration toolkit. You can access it on the desktop by clicking Start > Programs > Novell
Server Consolidation and Migration Toolkit > Novell Server Consolidation and Migration
Toolkit.

2 Read the Welcome screen, then click Create or Open Project.

3 Select NetWare or Open Enterprise Server (eDirectory), then click Next.

Migrating Data from NetWare Servers 17



4 Sclect Migrate Data to New Server (Hardware Upgrade), then click Next.
NetWare Migration Wizard 8.1 is launched.

5 Read the About screen, then click OK.

6 Do one of the following:
+ To start a new migration project, click Create a New Project > OK.

+ To open an existing project, click Open an Existing Project > OK, select the project file
you want to work on, and then click Open.

+ To open the last project you worked on, click Open Last Project > OK.
7 (Optional) Click View Online Documentation.

This launches your default Web browser and takes you to the NetWare Migration Wizard
online documentation.

Make sure you have completed the procedures in Chapter 3, “Preparing for a Server
Migration,” on page 13. Then close your browser and click Next.

8 Name the project, select a place to save it, type a descriptive filename, then click Next.

By default, Migration Wizard saves all projects to c:\program files\novell migration wizard.
You can click Browse to select a different location.

Migration Wizard uses a project (.mdb) file to record your progress throughout the migration.
At any point before the migration is complete, you can exit Migration Wizard and restart the
utility to pick up where you left off.

The filename can be up to 64 characters long and can include any character except \ * ? <> |
“/. It is a good idea to use a standard naming convention to clearly identify each project.

9 Select the eDirectory tree that contains your source server, then click Next.
If necessary, click the Login button to attach to the tree.
10 Sclect your source server from the eDirectory tree, then click Next.
If necessary, navigate the tree until you find the desired source server.
11 Select the eDirectory tree that contains your destination server, then click Next.
If necessary, click the Login button to attach to the tree.
12 Seclect your destination server from the destination eDirectory tree, then click Next.

If necessary, navigate the tree until you find the destination server. It should be the only server
in the tree.

13 To create the project file with the information you have entered thus far, click Create.

Continue with the next section, Model Your Migration Project.

Model Your Migration Project

18

The Project Window and the Getting Started Migrating from NetWare 5 or 6 window appear after
you have created the migration project file.

If you do not want the Getting Started window to appear the next time you run the Migration
Wizard, deselect Always Show This Window. Click Close to close the Getting Started window and
begin modeling your project.
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The Project Window is where you can model different migration scenarios before you begin the
actual migration. To do this, you drag volumes and folders from the left pane (which displays the
source server’s volumes) and drop them into volumes and folders in the right pane (which shows
the destination server’s volumes).

Dragging-and-dropping data in the Project Window does not immediately perform the action. It
only creates a preview of where the data will ultimately reside on the destination server. The data
is copied only after the project verification is complete and the migration process begins.

Working in the Project Window

To begin modeling your migration project, decide what file system data on the source server will
be copied to which volumes and folders on the destination server. You can drag-and-drop entire
volumes or just selected folders from the source server to the destination server.

You can also move created and dropped folders around in the destination pane by dragging them
to the desired location.

Other Project Window Actions

In addition to dragging-and-dropping volumes and folders, you can perform several other tasks in
the Project Window:

+ To view a short description of the icons in the Project Window, right-click an object and then
click What’s This.

+ To set a new eDirectory tree context in either the left or right pane, right-click a container and
then click Set Context.

* To create a new folder on the destination server, right-click an existing parent folder or
volume and then click New Folder.

+ To rename a newly created folder, right-click the folder and then click Rename.

+ To show where a folder went, right-click the folder in the left pane and then click Where Did
it Go?

The folder that was moved is highlighted in its new location in the right pane.

¢ To show where a folder came from, right-click the folder in the right pane and then click
Where Did It Come From?

¢ To cancel a “dropped” action, right-click a folder in the right pane and then click Back Out
Dropped Directory.

+ To show all folders selected for copying, right-click a container in the left pane and then click
Show Dropped Folders.

+ To view the available disk space prior to performing the verification, right-click the
destination volume in the right pane and then click Properties.

Right-clicking on a source volume or folder in the left pane and then clicking Properties
displays the size of the source object.
Resolving Duplicate Directory Conflicts

If you drag a folder from the source server into a folder with the same name on the destination
server, a Duplicate Directory Encountered window appears. Here you can indicate how you want
to handle occurrences of duplicate directories:
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+ Don’t Copy the Directory

Ensures that directories already existing on the destination server are not overwritten. The
Migration Wizard copies only the source directories that do not exist on the destination server.

¢ Merge Directory Contents

Merges the contents of the directory on the source server with the contents of the duplicate
directory on the destination server.

* Merge All
Merges the contents of all duplicate directories.
¢ Rename

Renames a directory on the source server. you must enter a new directory name in the field
provided. The directory on the destination server retains its original name.

Migrating User Directories and Server Application Directories

Because the destination server takes the place of the source server when the migration is complete,
you should model your project to minimize the necessity of changing user login script mappings
and application load files.

To preserve login script mappings to user directories, drag-and-drop these directories to the same
location on the destination server as on the source server.

Likewise, to preserve application load files, drag-and-drop application directories to the same
location on the destination server as on the source server.

When you have finished modeling your migration project, continue with the next section, Verify
Your Migration Project.

Verify Your Migration Project

After you have modeled your migration by dragging-and-dropping data in the Project Window,
you must verify your project to check for problems that might hinder a successful migration.

NOTE: Remember, dragged-and-dropped items appearing in the eDirectory tree are merely assigned to be
copied to that area in the eDirectory tree. Objects are not migrated until you actually begin the migration.

To perform the verification:

1 On the Migration Wizard toolbar, click Project > Verify and Migrate Project, or click the
Verify and Migrate button.

2 (Conditional) If the Verification Wizard finds any problems (such as insufficient rights, name
spaces that are not loaded, disk space limitation, and improper TSAs), you must resolve these
problems and rerun the Verification Wizard before proceeding.

Continue with the next section, Migration Step 1: Copy File System Data.

Migration Step 1: Copy File System Data

During the Copy File System Data step, the dropped directories are copied to the destination server
and created directories are added to the destination server.

1 In the Project View dialog box, click Copy File System Data.
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3

In the Dropped Folders dialog box, verify the accuracy of the source and destination paths for
all of your dropped folders and then click Next.

(Conditional) If you created new folders as part of your migration project, verify the source
and destination paths in the Created Folders dialog box and then click Next.

In the Duplicate Files dialog box, indicate how you want to handle any duplicate filenames
between the source and the destination by selecting one of the following and then click Next:

¢ Don’t Copy Over Existing Files

The file on the source server is not copied and the file with the same name on the
destination server is not replaced.

¢ Copy the Source File If It Is Newer (Default)

If the file on the source server is newer than the one on the destination server, the file on
the destination server is replaced.

+  Always Copy the Source File

The file on the source server always replaces the file with the same name on the
destination server.

In the Disable Login dialog box, indicate whether you want users to be logged in during the
data migration by selecting one of the following and then click Next.

¢ Copy Volumes with Users Logged In (Default)

Migration Wizard does not copy open files. Select this option if you want to copy
nonaccessed files while users are logged in.

¢ Disable Login

If you disable user login, you can be sure that no other users can log in to the network and
open files during the file copy.

If you want to delete all user connections prior to performing the migration, click
Broadcast Logout Message to warn users to log out. If any user connections remain, you
must manually disconnect them from the source server console.

In the File Date Filters dialog box, indicate whether you want to filter the files to be copied
according to Accessed, Modified, or Created dates and then click Next.

If you select Yes, specify the desired date ranges. If you select No, all files are copied.

Two dates can be set for each attribute. The first date is an On or After date and the second is
an On or Before date. For example, if you only select On or Before for the Accessed attribute
and set the date for October 10, 2005, only those files accessed on or before October 10, 2005,
are copied. In the same example, if you also select On or After and set the date to September
1, 2005, only those files accessed on or after September 1, 2005, and on or before October 10,
2005, are copied.

You can specify as many ranges as you want, and only those files that meet all of the selected
criteria are copied.

In the Wildcard Selection dialog box, indicate whether you want to filter files by name or
extension by typing the filenames or extension types in the field provided and then click Next.

You can use a wildcard character to represent one or more characters in a search. The two
most commonly used wildcards are

¢ The question mark (?)

Used to represent a single alphanumeric character in a search expression. For example,
typing te?t . txt would exclude tent.txt, test.txt, and text.txt from the copy process.
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+ The asterisk

Used to specify zero or more alphanumeric characters in a search expression. For
example, typing h*s. txt would exclude hs.txt, his.txt, house.txt, and happiness.txt
from the copy process.

Type as many filenames or file extension types as you want. As in the following example,
separate each entry with a hard return:

* mp3
* wav
test.txt

In the Synchronize Files and Folders dialog box, specify whether you want the Migration
Wizard to delete files and folders on the destination server that do not exist on the source
server and then click Next.

If users are active on the source server while you model your migration project, it is possible
that they could delete files and folders that you have already selected for migration.

+ Selecting Yes causes the Migration Wizard to scan all dropped folders after the copy
process completes and to delete any files and folders from the destination server that
don’t exist on the source server.

+  No is the default selection.

In the Compare Files and Folders dialog box, specify whether you want the Migration Wizard
to compare files and folders between the source and destination servers after the copy process
completes and then click Next.

¢ Selecting Yes causes the Migration Wizard to compare the following information during
the post-copy file comparison:

¢ Names

¢ Dates

+ Sizes

+ Attributes
¢ Trustees
¢ Owners

If you select Yes, you are given the option of doing a binary comparison of the files after
the copy process completes. A binary (byte-by-byte) comparison gives the greatest
assurance that two files are identical, but it takes longer to complete.

By default, the Migration Wizard compares the Read inhibit (Ri) and Delete inhibit (Di)
attributes on Read-only files. If you do not want this check to be performed, deselect
Compare Ri/Di Attributes. (See the online help for an explanation of why you might want
to disable this comparison.)

+ No is the default selection.

10 Specify where to store the trustee backup files, then click Next.

Before Migration Wizard starts copying files, it backs up trustee and ownership information
for the source server’s standard sys: volume and dropped folders to special trustee backup
files for use only by Migration Wizard. When the eDirectory migration is complete, Migration
Wizard restores the trustees from the files stored on the destination server.
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The trustee backup files are stored on the destination server’s sys: volume by default. If your
destination server has limited free space on volume sys:, you can select another volume to
hold the backup files.

11 Type the passwords for the source and destination trees, then click Next.

SMS is the backup and copy engine used by the Migration Wizard. You type your passwords
here because SMS requires that the servers involved in the migration be authenticated to each
other.

12 (Conditional) If prompted, resolve any critical errors or warnings discovered during
verification and then click Next.

If there were errors discovered in the verification attempt, they are shown in the Error
Resolution dialog box. Errors could include name conflicts, insufficient rights, required name
spaces not loaded, and insufficient disk space.

Errors found during the verification process are classified as follows:

¢ Errors that must be resolved before files can be copied

¢ Errors that should be resolved but might not affect the copy process

¢ Informational messages about the decisions you made in the Project Window

A description of each error and a possible resolution appear in the Information text box. If no
resolution is provided, you can find more information in the Novell Error Codes online
documentation (http://www.novell.com/documentation/nwec/index.html). Search the system
by error code number.

13 (Conditional) If newer NLM™ programs are available and you want to copy them to your
system, click Yes in the dialog box that appears.

14 In the Ready to Copy Files dialog box, read the explanation of the file copy process and then
click Proceed.

The Migration Wizard proceeds with the trustee backup and file copy.

15 When the Copy Volumes Status screen appears, review the error and success logs and then
click Done.

Continue with the next section, Migration Step 2: Edit Configuration Files.

Migration Step 2: Edit Configuration Files
The Edit Configuration Files step compares the configuration files between the source and
destination servers and lets you make any desired changes to those files.
1 In the Project View dialog box, click Edit Configuration Files.

Migration Wizard lets you modify any .ncf or .cfg files on the destination server. These files
contain default LOAD statements and parameters.

IMPORTANT: Make sure that all files are closed before you migrate your eDirectory database.
2 In the text box, select the configuration file that you want to edit and then click Edit File.

3 Copy and paste the commands from the configuration file on the source server to the
corresponding configuration file on the destination server, then click Save & Close.

If you intend to change the IP address on your destination server to be the same as the IP
address of your source server, you must edit your configuration files and change the IP address
in two places: autoexec.ncf and sys:\etc\hosts.
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Copy the source server’s IP address and paste it into the destination server’s autoexec.ncf file.
(This works only if your IP LOAD and BIND statements are located in autoexec.ncf.) You
also need to go to the server console of the destination server and change the IP address in the
sys:\etc\hosts file. Look for the original name of the destination server.

If you use INETCFG to assign IP addresses, change the IP addresses affer the migration is
complete.

(Conditional) If you are using configured time sources (timesync.cfg), copy and paste your
Timesync information from the source server’s timesync.cfg file to the destination server’s
timesync.cfg file.

5 Close the Compare Configurations dialog box.

Continue with the next section, Migration Step 3: Begin NDS/eDirectory Migration.

Migration Step 3: Begin NDS/eDirectory Migration

24

The Begin NDS/eDirectory Migration step migrates the eDirectory files from the source server to
the destination server. The source server is brought down and the destination server is restarted
during this step.

1 In the Project View dialog box, click Begin NDS/eDir Migration.

2 Before continuing, back up all volumes that you are not planning to migrate, ensure the

following, and then click Next:
¢ All volume data migrated successfully
¢ All critical errors from the file copy are resolved

¢ The servers in your source tree are in time synchronization and eDirectory is
synchronized

Verify that you have run the DSRepair procedures in “Preparing the Source Server for
Migration” on page 14 to ensure that the eDirectory tree containing the source server is
functioning correctly.

TIP: If you are required to fix any eDirectory errors, wait approximately 30 minutes for the eDirectory tree
to synchronize before continuing.

In the Update Schema dialog box, indicate whether you want the Migration Wizard to update
the source server’s schema and then click Next.

¢ Yesis the default selection. This causes the Migration Wizard to compare the source and
destination schemas and update the source server’s schema to include the eDirectory
classes of the default applications that are installed on the destination server. You must
be logged in as a user with all rights to the [Root] of the tree to make these changes.

¢ Ifyou do not have the necessary rights to extend the schema, select No. The migration
continues, but you might experience some problems with your eDirectory tree if you skip
this procedure.

In the Verify Novell Directory Services Tree dialog box, click Yes to acknowledge that the
source eDirectory tree is healthy (you should have run the DSRepair procedures in Step 2).

If you click No, the Migration Wizard does not prevent you from continuing. However, if your
tree is unhealthy before you begin the migration, the migration might not complete
successfully.
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8 To ensure the security certificate works properly on the destination server, indicate how you
want to copy the source server’s NICI configuration files to the destination server and then
click Next.

To facilitate the NICI file copy, nuwnici.nlm is first copied to both the source and destination
servers. You can choose to copy the NICI files Automatically (over the network) or using a
diskette swap.

6 (Conditional) If you selected the diskette swap, continue with Step 6a. If you selected the
automatic copy over the network, skip to Step 7.

6a To copy the nuwnici.nlm to the source and destination servers, click Copy NLM and click
Next.

6b Insert a blank formatted diskette into the floppy drive on the destination server.
6c¢ At the destination server console, enter
load nuwnici -1

6d Remove the diskette from the destination server and insert it into the source server’s
floppy drive.

6e At the source server console, enter
load nuwnici -2
This copies the NICI files to the diskette.

6f Remove the diskette from the source server and insert it into the destination server’s
floppy drive.

6g At the destination server console, enter

load nuwnici -3

This copies the NICI files to the destination server.
6h Click Next.

TIP: If you get NICI errors when eDirectory tries to load or when you copy the NICI files, check if pki.nlm
will load on the destination server. If it won’t load, see “NICI Errors” on page 34.

7 Delete all user connections (except your own) to the source and destination servers, then click
Next.

If you want to first broadcast a logout message to any users logged in to the server, click
Broadcast Logout Message, type the message in the field, and then click OK.

8 Type the passwords for the source and destination trees, then click Next.

9 Resolve any critical errors or warnings on the Migrate NDS/eDir Verification Results screen,
then click Next.

10 Perform the eDirectory step-by-step migration.

The eDirectory migration is divided into several steps. This is for diagnostic purposes. If the
eDirectory migration fails for any reason, you know exactly what step it failed on and can take
the appropriate measures to fix the problem.

For more information on the NDS/eDirectory migration process, including steps to restore the
source and destination servers, see “NDS/eDirectory Migration Failures™ on page 34.

10a Click Next.
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The first step changes autoexec.ncf and timesync.cfg; modifies the server name in hosts,
hostname, and snmp.cfg; and renames smdr.cfg to smdr.mig. The first step also renames
rootcert.der in both the sys:system and sys:public directories to rootcert.der.bak.

At the end of the migration process, the source server is brought down and the destination
server reboots and takes over the name and identity of the source server.

Migration Wizard automatically modifies the following items in the destination server’s
autoexec.ncf file:

¢ The file server name is changed to the name of the source server
¢ The time zone is changed to the one stored in the source server’s autoexec.ncf file

¢ The server ID is changed to the IPX™ internal net value or server ID stored in the
source server’s autoexec.ncf file

¢ The default time server type is changed to the value stored in the source server’s
autoexec.ncf file

¢ The bindery context is changed to the bindery context stored in source server’s
autoexec.ncf file

IMPORTANT: During the migration, the source server’s Timesync information is not automatically
migrated.

10b Click Next again.

This step backs up eDirectory and copies the eDirectory backup files to the destination
server and to sys:system\nuw30\ndsbu on the source server.

10c Down the source server by clicking Next.

The Source Server Status dialog box displays.
10d Verify that the source server is down by clicking Yes.
10e Click Next again.

This step removes eDirectory from the destination server and deletes the client
connection.

10f Click Next again.

This step upgrades eDirectory on the destination server if necessary, restores eDirectory
on the destination server, and prepares to reboot the destination server.

10g Reboot the destination server by clicking Next.
10h When you are ready to proceed, click Yes > Finish.

11 Check the former destination server and verify that it has restarted and taken on the name of
the source server.

The server console prompt should display the source server’s name.
12 Exit the Migration Wizard.

The project file is automatically saved.
13 Reboot your workstation and log in to the former destination server.

This clears old connections from the workstation and establishes a clean connection to the
former destination server.

If you can’t log in, refer to “Workstation-to-Server Connection Problems” on page 32.

26 NetWare Migration Wizard 8.1 Administration Guide



14
15
16

17

Restart the Migration Wizard utility.

Read the About screen, then click OK.

Click Open Last Project > OK.

The utility verifies that the first three steps of the project file are complete.

Click Yes when prompted if you are ready to proceed to the fourth step.

Migration Step 4: Finish the NDS/eDirectory Migration

The Finish the NDS/eDirectory Migration step upgrades the schema and restores the trustees to
the new server after it has restarted.

1

3
4
5
6
7

In the Project View dialog box, click Finish NDS/eDir Migration.

The Continue NDS/eDir Migration dialog box appears, outlining the eDirectory health checks
and other tasks you should complete before continuing.

To run the NDS/eDirectory backlinker process, go to the destination server console and enter
the following commands:

set dstrace=on
set dstrace=+blink
set dstrace=*b

Check the Directory Services screen for messages indicating the successful completion of the
backlinker process.

On the Continue NDS/eDir Migration screen, click Yes > Next.

Type the tree password in the field provided, then click Next > Continue.
Review the error and success logs, then click Done.

In the Project View dialog box, click Close.

Click File > Exit to exit the Migration Wizard.

Continue with the next section, Perform Post-Migration Tasks.

Perform Post-Migration Tasks

1

2

Run DSRepair on the destination server and select Unattended Full Repair to ensure that
eDirectory is functioning properly.

Using ConsoleOne®, verify that the user information migrated successfully.

TIP: During the migration, the standard sys: directory from the source server is saved in the sys.mig
directory on the destination server.

Run DSRepair > Time Synchronization to verify that your source server is synchronized with
the rest of your servers.

Verify that the correct IP address is assigned to the new server in all appropriate files.

For example, check autoexec.ncf, sys:\etc\hosts, and sys:\etc\hostname, or type config at
the server console.

IMPORTANT: Failure to have the correct IP address in the hosts or hostname files causes the post-
installation of some products to fail.
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5 (Conditional) If you have performed a migration to a NetWare 6.0 destination server, verify
that sys:\public\rootcert.der exists.

If it does not exist, copy the file from an existing server on the network, or create a new one
following the instructions in ROOTCERT.DER not exported during the install of Certificate
server (http://support.novell.com/cgi-bin/search/searchtid.cgi?/10066860.htm).

If the rootcert.der file does not exist, a post-migration install of applications could fail.

6 (Conditional) If you haven’t already done so, install the latest NetWare Support Pack on the
destination server.

This ensures that you get the latest code for the applications that you are reinstalling. The
latest Support Packs are available at the Novell Support Web site (http://support.novell.com/
misc/patlst.htm).

7 Reinstall any server applications.

IMPORTANT: Because the source server’s eDirectory database replaces the destination server’s
eDirectory database, all eDirectory objects on the destination server before the migration, including those
representing applications, are replaced by the eDirectory objects that exist on the source server.
However, the NLM programs associated with the destination server’s applications still exist. Because you
cannot manage applications without their corresponding eDirectory objects, you must reinstall the
applications to restore their eDirectory objects to the tree.

You can reinstall these network products and services using either of two methods:

+ Go to the destination server, load the GUI interface if necessary by typing startx, and
click the Novell icon in the lower-left corner of the servertop. Then click Install > Add to
install products.

¢ Toinstall products remotely, run the Novell Deployment Manager utility (nwdeploy.exe,
or nwdeploynobrowser.exe for a nonbrowser-based version) located on NetWare 6.5 CD
1 (Operating System). Under Post-Install tasks, select Install NetWare 6.5 Products and
follow the on-screen instructions to run the Remote Product Install utility.

Installing Tomcat and exteNd Application Server after the Migration

If needed, after completing a NetWare 6.5-to-NetWare 6.5 migration using the Migration Wizard,
complete the following steps to ensure that Tomcat installs correctly:

1 Copy sys:\sys.mig\java to sys:\java, overwriting all existing files.
2 Copy sys:\sys.mig\adminsrv to sys:\adminsrv, overwriting all existing files.

3 Copy sys:\sys.mig\system\ipconf to sys:\system\ipconf, overwriting all existing files.

After completing a NetWare 6.5-to-NetWare 6.5 migration using the Migration Wizard, complete
the following steps to ensure that exteNd™ Application Server installs correctly:

1 Copy sys:\sys.mig\java to sys:\java, overwriting all existing files.

2 Copy sys:\sys.mig\etc\my.cnf to sys:\etc\my.cnf.
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Installing Native File Access for UNIX after the Migration

If needed, after completing a NetWare 5.1-to-NetWare 6.5 migration using the Migration Wizard,
complete the following steps to ensure that Native File Access for UNIX installs correctly:

1 Delete the NFAU User object.
2 Run the schinst utility by entering

schinst -n -w

SCHINST takes the administrator's FDN and password as input for extending the schema.
3 Run nisinst.

4 Execute nfsstart.
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Troubleshooting

Refer to the appropriate section if you are having trouble with any of the following:

*

*

*

General Connection Problems (page 31)

Workstation-to-Server Connection Problems (page 32)
Server-to-Server Connection Problems (page 32)

File Copy Problems (page 32)

SMDR Errors (page 33)

Restoring Trustees (page 33)

Nuwagent.nlm Load Errors (page 34)

NICI Errors (page 34)

NDS/eDirectory Migration Failures (page 34)

CCS_pbeDecrypt Error When Migrating from NetWare 5.0 (page 38)

General Connection Problems

To eliminate unnecessary connection problems, make sure that

*

*

*

The source and destination servers have enough available server and workstation licenses to
do the migration.

The eDirectory™ user that you are using to do the migration has no concurrent connection
limitations. To check this, do the following:

+ Run ConsoleOne® on the workstation.

+ Edit the properties of the User object.

¢ Click the Login Restrictions tab.

¢ Deselect the Limit Concurrent Connections option.

The eDirectory user that you are using to do the migration has the Supervisor right to the
source server’s eDirectory object. Use ConsoleOne to verify that the User object is listed in
the source server’s Operators list.
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Workstation-to-Server Connection Problems

If you have problems establishing or maintaining connections between your servers and
workstations, try one or more of the following:

+ Reboot the client workstation to clear the cache in the Novell® Client™ software.

+ Map adrive to the server instead of logging in. This is especially useful when connecting with
the IPX™ protocol.

* Search for the server by its IP or IPX address instead of its name. Type the IP or IPX address
in the Server field of the Novell Login dialog box.

* Try connecting to the server and not the eDirectory tree by specifying only the name of the
server and leaving the tree name and context blank.

¢ Clear all unauthenticated connections. To do this, right-click the N icon and then click
NetWare Connections. Detach from all servers and trees that you are not authenticated to, then
try logging in again.

¢ Make sure your Preferred NetWork Protocol is set correctly by doing the following:
+ Right-click the N icon.
+ Click Novell Client Properties > Protocol Preferences.
+ Select the desired preferred network protocol, then click OK.
+ Reboot the workstation.

+ Unbind the protocol you are not using from the destination server. For example, if you are
using IP for the migration but IPX is bound on the destination server, unbind the IPX protocol
on the destination server during the migration.

Server-to-Server Connection Problems

If you have problems establishing or maintaining connections between your servers, try one or
more of the following:

+ Do not remove the source and destination servers from their respective eDirectory trees. The
servers must be able to communicate with the other servers in the tree during the migration.

* Make sure the destination and source servers can communicate with each other.

For IP connections, enter ping at the server console and specify the other server’s IP address.
For IPX connections, enter display servers at the server console.

¢ For IP connections, verify that you have corresponding addressing, subnet mask, and gateway
information. If you are using IPX, make sure the frame type and the IPX network number/
server ID are consistent between the source and destination servers.

* Reboot the destination server.

File Copy Problems

If you are having problems during the file copy, try one or more of the following:

+ Enable login on both the destination and source servers. If you have disabled login before you
started the file copy, the servers can’t log in to each other in order to migrate the files.

NOTE: If you have selected to do so, Migration Wizard disables user logins for you during the migration.
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If files are copying very slowly, make sure that the servers and workstation are configured at
the highest common LAN speed. Verify that the NICs and anything in between are all hard
coded to either communicate half-duplex or full-duplex; they need to be the same throughout.
If there are problems with full-duplex, use half-duplex.

NOTE: If compressed files are migrated to uncompressed volumes, file copy might be slower.

If Migration Wizard encounters filenames with a total path length of more than 256 bytes, the
file copy stops. You might need to reorganize the data on your source server if your path
lengths are longer than 256 bytes.

Data Set Currently In Use Errors in the Error Log

If you see NWSMTS error: Data set is currently in use and cannot be
accessed errors in the error log file after the migration, it means the specified files were open
during the file copy and were not migrated. You can expect to see these errors for files such as
sys:_swap_.mem and others that are always open. These errors are mainly informational.

SMDR Errors

Sometimes the smdr.nlm program that is running on the destination server can’t make a connection
to the source server. To correct this problem, try one or more of the following:

*

Unbind the protocol you are not using from the destination server. For example, if you are
using IP for the migration but IPX is bound on the destination server, unbind the IPX protocol
on the destination server during the migration.

If Migration Wizard can’t load the appropriate tsa.nlm on your destination server, manually
load it from the destination server console and following the onscreen instructions. Or, enter
smdr new at the server console to re-create the SMDR object.

Load smdr.nlm at the destination server console and then enter smdr new at the destination
server console to solve SMS problems.

Make sure the latest NLM™ programs are loaded on your servers.

Migration Wizard automatically copies the required NLMs to the source and destination
servers. To verify that you have the latest NLMs loaded, check the files in the NetWare
Migration Wizard\products\nw3x directory. You might have to load TSA312 manually.

Check your primary connections. Right-click the N icon, then click NetWare Connections.
Make sure the destination tree and server are marked as Primary.

Reboot the source server.

Restoring Trustees

*

*

If the trustees fail to restore and you get a Oxftftfftb error, this means that you did not modify
your server’s IP address in all the necessary places. For more information, see “Migration
Step 2: Edit Configuration Files” on page 23.

If you need to restore trustees, you can click the Finish NDS/eDir Migration button in the
Migration Wizard, or select Restore Trustees on the toolbar.
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Nuwagent.nim Load Errors

NICI Errors

Nuwagent.nlm is the NLM program that Migration Wizard uses to do much of its work. If you get
errors that the nuwagent.nlm won’t load, try the following:

+ Manually load nuwagent.nlm at the server console.

+ Enter smdr new at the destination server console. This re-creates the SMDR configuration
and allows nuwagent.nlm to load.

If you are getting NICI errors when eDirectory is trying to load or when you are copying the NICI
files in Migration Wizard, this might mean that your NICI files are corrupt. To correct the problem,
follow these steps on the server that is getting NICI errors:

1 Copy the *.nfk file from NetWare 6.5 CD I (Operating System) to the server’s sys:system
directory.

2 Rename the *.nfk file that you just copied to nicifk (this has no extension).

3 Go to the Novell Support Web site (http://support.novell.com/filefinder) and download
nrepair3.exe.

4 Extract nrepair3.exe and locate nrepair.nlm.
5 Run nrepair.nlm on the server, clicking Yes at all the prompts.
6 Reboot the server.

7 Load pki.nlm on the server and verify that you are no longer getting NICI errors.

If you still see NICI errors, refer to TID #10025666 (http://support.novell.com/search/xxxxxx) in
the Novell Knowledgebase.

NMAS Error When Migrating from NetWare 5.1

When migrating from NetWare 5.1 Support Pack 7 with eDirectory 8 to NetWare 6.5 Support Pack
2 using Migration Wizard 8.0, NMAS™ might show a - 1660 (0xFFFFF984) error after completing
Step 3 (Start NDS®/eDirectory Migration) and rebooting the server and client.

This is the expected behavior because this is a new server that hasn't been fully installed, so there
are no objects in the Security container, which means that NMAS (and other security products such
as NICI and PKI) have not been configured.

If you have Novell Client™ 4.9 and later, you must disable the NMAS authentication. Right-click
the N icon, click Novell Client Properties > Advanced Login, then deselect the NMAS
Authentication option.

NDS/eDirectory Migration Failures

If the migration fails during the NDS/eDirectory Migration step, you need to restore the source and
destination servers to their original configuration before you can retry the NDS/eDirectory
migration. The instructions for restoring the servers to their original configurations are different
depending on when the migration of data failed.

34 NetWare Migration Wizard 8.1 Administration Guide


http://support.novell.com/filefinder
http://support.novell.com/search/xxxxxx

If Begin NDS/eDir Migration (Step 3) failed and the destination server did nof reboot and take on
the name and identity of the source server, complete the steps in “Restore Source Server to Its
Original Configuration” on page 35.

If Begin NDS/eDir Migration (Step 3) successfully completed and the destination server has
already rebooted and taken on the name and identity of the source server, complete the steps in the
following sections:

1. “Remove NDS/eDirectory from the Destination Server” on page 35.
2. “Remove NDS/eDirectory from the Source Server” on page 36.

3. “Restore NDS/eDirectory to the Source Server” on page 37.
4

. “Reinstall the Destination Server” on page 38.

Restore Source Server to Its Original Configuration

If Begin NDS/eDir Migration (Step 3) failed and the destination server did not reboot and take on
the name and identity of the source server, you need only restore NDS/eDirectory to the source
server. When NDS/eDirectory has been restored, you have restored the source server to its original
configuration and you are ready to try the NDS/eDirectory migration again.

1 Enter one of the following at the server console of the source server:
¢ load install if the source server is running NetWare 4
¢+ nwconfig if the source server is running NetWare 5 or later

2 Sclect Directory Options > Directory Backup and Restore > Restore Local DS Information
after Hardware Upgrade.

3 Press F3 and enter sys : system\nuw30\ndsbu when prompted for the location of the
backup files.

NDS/eDirectory has now been restored to the source server.

IMPORTANT: Do not reboot the destination server. Because the destination server did not take over the
identity of the source server, no other action is required prior to performing the NDS/eDirectory migration
again.

4 Perform the NDS/eDirectory migration again.
4a Launch Migration Wizard and open the project you were previously working on.

4b When the project opens and you see the Project Window, click Begin NDS/eDir
Migration.

4c Follow the instructions in “Migration Step 3: Begin NDS/eDirectory Migration” on
page 24.

Remove NDS/eDirectory from the Destination Server

If Begin NDS/eDir Migration (Step 3) successfully completed and the destination server has
already rebooted and taken on the name and identity of the source server, you must remove NDS/
eDirectory from the destination server before you can restore NDS/eDirectory to the source server.

1 At the destination server console, enter nwconfig.
2 Seclect Directory Options > Remove Directory Services from This Server.

3 Press Enter when you see a warning instructing you to not remove Directory Services.
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11

12

Ignore any other errors during the removal of NDS/eDirectory.
Select Yes to Remove Directory Services.

Specify the Admin username and password.

Press Enter to reference a different object.

This object is used when NDS/eDirectory is restored back to the source server.

WARNING: Do not press Esc. If you do, the server references you entered will not be saved or restored
to the server.

Specify the full Admin username as the placeholder object distinguished name.
Specify Root as the distinguished name to change from.

(Conditional) If the information about the single reference time source appears, review the
information and press Enter.

(Conditional) If your server holds the master copy of a replica, press Enter when you see a
warning.
Designate another server to hold the master replica.

You can choose to let NWCONFIG randomly select another server or you can designate one
yourself.

Return to the NWCONFIG utility and select Remove Directory Services from This Server to
verify that NDS/eDirectory has been removed.

If a message appears saying that NDS/eDirectory has already been removed, bring the
destination server down and continue with the next section, Remove NDS/eDirectory from
the Source Server.

If NDS/eDirectory was not successfully removed, exit NWCONFIG and enter nwconfig -
dsremove at the destination server console. Then follow this procedure again, beginning
with Step 2 on page 35.

Remove NDS/eDirectory from the Source Server

36

After NDS/eDirectory has been removed from the destination server, remove NDS/eDirectory
from the source server.

1
2

o O b~ W

Restart the source server by entering server at the DOS command prompt.
Enter one of the following:

¢ load install -dsremove (if source server is running NetWare 4)
¢+ nwconfig -dsremove (if source server is running NetWare 5 or later)

INSTALL or NWCONFIG will now ignore any warnings or errors during the removal of
NDS.

Select Directory Options > Remove Directory Services from This Server.
Press Enter to skip past any warning screens.

Select Yes to remove NDS/eDirectory.

Press Enter to skip the error message warning you that eDirectory is locked.

Ignore, but keep track of, any additional eDirectory error messages that appear.
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When the INSTALL or NWCONFIG menu appears again, select Remove Directory Services
again.

If a message indicates that eDirectory is already removed, continue with the next section, Restore
NDS/eDirectory to the Source Server.

If eDirectory was not properly removed, contact Novell Technical ServicesS“.

Restore NDS/eDirectory to the Source Server

By removing NDS/eDirectory from the source server, you removed the server from any replica
rings that held a partition of the source server. Now you must complete the following procedure to
restore NDS/eDirectory to the source server.

1

© 0 N O G

10
11

12
13
14
15
16
17
18

Enter one of the following at the server console:

¢ load install (if source server was running NetWare 4)

¢ load nwconfig (if source server was running NetWare 5 or later)
Select Directory Services > Install Directory Services onto This Server.
Select the eDirectory tree where the source server existed prior to migration.
Select a time zone and time configuration parameters.

Make a note of any warnings or errors that appear during the restoration of eDirectory and
press Esc to continue without fixing the errors.

Enter the Admin name and password.

Type the context where the source server existed prior to migration, then press F10.
Save the NDS (Directory) information.

Wait while the server synchronizes with the eDirectory tree, which might take a while.

Return to the INSTALL or NWCONFIG utility and select Directory Options > Select
Directory Back Up and Restore > Restore Reference from another Object to This Server.

This restores all references that you assigned to the Server object when you removed
eDirectory from the destination server.

Press Enter.

Enter the full Admin username as the placeholder object distinguished name, then specify
Root as the distinguished name to change from.

Exit the NWCONFIG or INSTALL utility.

At the server console of the source server, enter Load dsrepair.

Select Unattended Full Repair > Advanced Options > Check Volume Objects and Trustees.
Enter the Admin username and password.

Exit DSREPAIR.

At the workstation where you performed the migration, open your project.

From the Migration Wizard Tools menu, select Restore Trustees to restore the trustee
assignments.

Troubleshooting 37



19 (Conditional) If the source server held the master replica of any partitions and you want to
restore these partitions prior to doing the eDirectory migration again, use DSREPAIR to re-
create them.

The source server is now restored to its original configuration.

Continue with the next section, Reinstall the Destination Server.

Reinstall the Destination Server

To perform the migration again, you must reinstall the operating system on the destination server.
TIP: If you had your server imaged, you can just restore the image rather than reinstall the server.
1 Bring down the destination server.

2 Install NetWare and follow the on-screen instructions during the installation.

After NetWare is installed on the destination server, you are ready to perform the eDirectory
migration again. Go to “Migration Step 3: Begin NDS/eDirectory Migration” on page 24.

CCS_pbeDecrypt Error When Migrating from NetWare 5.0

38

When performing a migration from NetWare 5.0, you might receive a CCS_pbeDecrypt error on
the source server console when attempting to back up either the source server trustees or the NDS
database.

If this occurs, make sure that the latest Support Pack is installed on the NetWare 5.0 server and
then do the following:

1 At the NetWare 5.0 source server console, enter
down
2 At the DOS prompt, enter.
copy c:\nwserver\expxeng.xlm c:\nwserver\novxeng.xlm
3 Enter.
copy c:\nwserver\domxeng.xlm c:\nwserver\novxeng.xlm
NOTE: This might fail because domxeng.xlm is not present. This is not a problem.

If you used a directory other than \nwserver to store the server files, substitute that directory
for \nwserver in steps 2 and 3.

4 Restart the NetWare 5.0 server.
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Security Considerations

This chapter provides information on how to use the utilities included in the Novell® Server
Consolidation and Migration Toolkit in the most secure way possible.

General Network Security Guidelines

Access to network resources in general, and servers in particular, should be governed by the
security guidelines outlined in “Security” in the Novell OES Planning and Implementation Guide.

Migration Wizard Security

Standard security algorithms and well established obfuscation methods are used in the NetWare®
Migration Wizard to protect the privacy of administrator passwords.

In a secure environment, you should use the diskette method to copy NICI keys from the source
server to the destination server, instead of copying the keys over the wire. For more information,
see Step 5 on page 25.
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Documentation Updates

This section contains information on documentation content changes that have been made in the
Novell NetWare Migration Wizard Administration Guide. This information can help you to keep
current on updates to the documentation.

All changes that are noted in this section were also made in the documentation. The documentation
is provided on the Web in two formats: HTML and PDF. The HTML and PDF documentation are
both kept up-to-date with the documentation changes listed in this section.

The documentation update information is grouped according to the date the changes were
published. Within a dated section, the changes are listed by the names of the main table of contents
sections.

If you need to know whether a copy of the PDF documentation you are using is the most recent,
the PDF document contains the date it was published on the front title page and in the Legal
Notices section immediately following the title page.

This documentation was updated on the following dates:

* “August 19, 2005 (Open Enterprise Server SP1)” on page 41

August 19, 2005 (Open Enterprise Server SP1)

Updates were made to the following sections. The changes are explained below.
+ NetWare Migration Overview
¢ What’s New
¢ Preparing for a Server Migration
* Migrating Data from NetWare Servers
¢ Troubleshooting

¢ Security Considerations

NetWare Migration Overview

The following updates were made in this section:

Location Change

“About NetWare Revised references to the NetWare Migration Wizard 8.1, which is now part
Migration Wizard” on of the Server Consolidation and Migration Toolkit.

page 9
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What’s New

The following updates were made in this section:

Location Change

“Migration Wizard 8.1”  Added section on new and enhanced features in NetWare Migration Wizard
on page 11 version 8.1.

Preparing for a Server Migration

The following updates were made in this section:

Location Change

“Meeting System and Updated workstation requirements for running the Server Consolidation and
Software Migration Toolkit.

Requirements” on

page 13

Migrating Data from NetWare Servers

The following updates were made in this section:

Location Change

“Launch Migration Revised steps for launching the NetWare Migration Wizard from the Server
Wizard and Create a Consolidation and Migration Toolkit.

Project File” on

page 17

Troubleshooting

Added new troubleshooting information about “Data Set Currently In Use” errors.

Security Considerations

Added this new chapter to explain how to use the NetWare Migration Wizard in the most secure
way possible.
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