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Instructions for Internat
and click Wrap. 3. Right-
it. 5. Right-click the nest
even though the file is no
PDF will be correct. For 

To begin a QuickStart (English): Click in the box under the word Novell. Insert QuickStart and Title elements. 2. Type the product name. 3. Insert the HeadQS element and type 
the title of your card. 4. Put in your product version: Click Special > Variable > select the variable named Version > Edit Definition > enter the version number > click Done > Done. 
It will appear as background text replacing Version X.X. 
For a single (stand-alone) card: Keep this master page, named “QS-Single.“  It shows the part number on the bottom right, since single cards don’t have front matter. 
For a card that’s part of a booklet: Use Special > Master Page Usage to change to using “First” master page on the first page of the card.  It doesn’t show the part number, since 
part number will be noted in the front of the booklet.

Novell
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Q U I C K S TA R T

eDirectory
Novell eDirectory Overview

Novell® eDirectoryTM is a highly scalable, high performing, secure directory service. It can store 

and manage millions of objects, such as users, applications, network devices, and data. Novell 

eDirectory natively supports the directory standard Lightweight Directory Access Protocol (LDAP) 

version 3 over Secure Socket Layer (SSL). 

Novell eDirectory provides the basic foundation for the directory service, which provides 

replication and partitioning capabilities, along with other utilities. Additional packages that 

build upon this basic directory structure, such as DirXMLTM and Account Management, are also 

available separately to increase functionality. 

S U P PO R T ED  P L A T F O R M S

NetWare®

Windows* NT*

Windows 2000

Solaris*

Linux*

FO R  M O RE  INFO RM AT ION

For more information on Novell eDirectory, refer to the following sources:

Product information (http://www.novell.com/products/nds)

Product support (http://support.novell.com)

Online forums (news://forums.novell.com)

Product catalog (http://www.novell.com/catalog)

Product documentation (http://www.novell.com/documentation)
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eDirectory
Installing or Upgrading Novell eDirectory 
on NetWare

Use the following instructions to install or upgrade Novell® eDirectoryTM on a NetWare® server.

Novell eDirectory for NetWare can co-exist with the following NDS® or eDirectory versions:

NetWare 4.11 or 4.2 with NDS 6.09 or later

NetWare 5 with Support Pack 5 or later, and NDS 7.47 or later (but earlier than NDS 8)

NetWare 5 with Support Pack 5 or later, and NDS 8.51 or later

NetWare 5.1with Support Pack 1 or later

NDS eDirectory 8.5 on Windows* NT*, Windows 2000, NetWare, Solaris*, Linux*, or Tru64 
UNIX*

Novell eDirectory 8.6 on Windows* NT*, Windows 2000, NetWare, Solaris*, or Linux*

S Y S TE M  R EQ U IRE ME N TS

If you are using RCONSOLE, a ConsoleOneTM administrator workstation with the following:

A 200 MHz or faster processor

A minimum of 64 MB RAM (128 MB recommended)

The Novell ClientTM that shipped with NetWare 5 or later.

The Novell Cryptography Support Modules (Novell International Cryptographic 
Infrastructure [NICI] 1.5.1 or later), available from the product CD or from the Novell 
Cryptography Web site (http://www.novell.com/products/cryptography).

Administrative rights to the eDirectory tree so that you can modify the schema.
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H AR DW A RE  RE QU IR EM ENT S

Hardware requirements depend on the specific implementation of eDirectory.

For example, a base installation of eDirectory with the standard schema requires about 74 MB of 

disk space for every 50,000 users. However, if you add a new set of attributes or completely fill 

in every existing attribute, the object size grows. These additions affect the disk space, 

processor, and memory needed.

Two factors increase performance: more cache memory and faster processors.

For best results, cache as much of the DIB Set as the hardware allows.

eDirectory scales well on a single processor. However, Novell eDirectory 8.6 takes advantage of 

multiple processors. Adding processors improves performance in some areas, for example, logins 

and having multiple threads active on multiple processors. eDirectory itself is not processor-

intensive, but it is I/O-intensive.

The following table illustrates typical system requirements for eDirectory for NetWare:

Requirements for processors might be greater than the table indicates, depending upon 

additional services available on the computer as well as the number of authentications, reads, 

and writes that the computer is handling. Processes such as encryption and indexing can be 

processor-intensive. 

Of course, faster processors improve performance. Additional memory also improves 

performance because eDirectory can then cache more of the directory into memory.

FOR C IN G  THE  BA CKL INK  PR OCE SS  TO  R UN

Because the internal eDirectory identifiers change when upgrading to Novell eDirectory, the 

backlink process has to update backlinked objects for them to be consistent.

Objects Processor Memory Hard Disk

100,000 Pentium* III 450-700 MHz 
(single)

384 MB 144 MB

1 million Pentium III 450-700 MHz (dual) 2 GB 1.5 GB

10 million Pentium III 450-700 MHz (2 to 4) 2 GB + 15 GB
10
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Backlinks keep track of external references to objects on other servers. For each external 

reference on a server, the backlink process ensures that the real object exists in the correct 

location and verifies all backlink attributes on the master of the replica. The backlink process 

occurs two hours after the database is open and then every 780 minutes (13 hours). The interval 

is configurable from 2 minutes to 10,080 minutes (7 days).

After migrating to eDirectory, we recommend that you force the backlink to run by issuing a SET 

DSTRACE=*B command from the server console. Running the backlink process is especially 

important on servers that do not contain a replica.

I N S T A L L I N G  N O V E L L  E D I RE CT O RY  ON  NE TW ARE

If your eDirectory tree does not have a Novell Certificate ServerTM, the eDirectory installation 

program does the following:

Creates a Security container object for the entire eDirectory tree

This object is created at the top of the eDirectory tree and must remain there.

Creates an Organizational Certificate Authority (CA) object

Places the Organizational CA object in the Security container

Only one Organizational CA object can exist in an eDirectory tree. Because you must not move 

this object from one server to another, ensure that the first eDirectory server is the one that you 

intend to permanently host the Organizational CA object. 

Prerequisites
If you are installing into a tree that has NetWare 5 servers, each NetWare 5.0 server must be 

running NetWare 5.0 Support Pack 5 or later. Each NetWare 5.1 server must be running NetWare 

5.1 Support Pack 1 or later.

If you are upgrading eDirectory on a NetWare 5.1 server, the NetWare 5.1 server must be running 

NetWare 5.1 Support Pack 2a or later.

Updating the eDirectory Schema
To upgrade an existing NetWare 5.x server to eDirectory into an existing tree, update the 

eDirectory schema by running DSREPAIR on the server that has the master replica of the Tree 

partition.

IMPORTANT: If the master replica of the Tree partition resides on a Windows NT/2000 server, 
follow the instructions in “Updating the eDirectory Schema” on page 20.
000-0000-000
November 30, 2001
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If one or both of the following conditions exist, you must run DSREPAIR.NLM before installing the 

first eDirectory server in your tree:

Any NetWare 5 server in your eDirectory tree is eDirectory 8.

Your first installation of eDirectory 8.6 is on a NetWare 5 server that does not hold a writable 
replica of the root partition.

To update the eDirectory schema:

1 Copy the appropriate DSREPAIR.NLM file from the product CD to the  SYS:\SYSTEM directory 
of the server that contains the master replica of the Tree partition.

Table 1

2 At the server console of the master replica of the Tree partition, load DSREPAIR.NLM.

3 Select Advanced Options Menu > Global Schema Operations.

4 Enter the Administrator’s name (for example, .Admin.VMP) and password.

5 Select Post NetWare 5 Schema Update > Yes.

DSREPAIR.NLM updates the schema and posts the results to the DSREPAIR.LOG file.

Ignore errors associated with adding object classes. DSREPAIR.NLM is simply applying the 
Post NetWare 5 Schema Update changes to each object.

6 Copy the appropriate patch version of DSREPAIR.NLM to each NetWare server in the 
eDirectory tree.

Use Table 1 as a reference. Having a correct version on each server ensures that the schema 
needed for eDirectory is properly maintained when DSREPAIR.NLM is run in the future.

If you use an earlier version of DSREPAIR.NLM and select Rebuild Operational Schema, 
schema enhancements made by the Post NetWare 5 Schema Update will be lost. To resolve 
lost schema enhancements, run DSREPAIR.NLM according to the following table.

For This Version of 
NetWare

With This Version of NDS Copy

4.11 or 4.2 6.09 or later PATCHES\DSREPAIR\ 
NW4X\DSREPAIR.NLM

5.0 or later NDS 7 version 7.47 or later PATCHES\DSREPAIR\ 
NW5X\DSREPAIR.NLM

5.0 or later 8.11 or 8.17 Not supported

5.0 or later 8.51 or later PATCHES\DSREPAIR\ 
NWNDS8\DSREPAIR. NLM
12
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This action resynchronizes the schema from the root of the tree.

7 Close DSREPAIR.NLM before installing eDirectory on the server.

If DSREPAIR.NLM is loaded, the server might not restart.

Installing a Support Pack

Table 2

1 (Conditional) Download the latest support pack to the NetWare 5.x server.

For example, download to SYS:\.

If you purchased a support pack CD from Support Connection, skip this step.

2 (Conditional) Expand the support pack.

For NW51SP1.EXE, the support pack might take several minutes to verify an ARJ-SECURITY 
envelope. After verification, the support pack creates an NW5SPX directory and places 
subdirectories and files there.

If you purchased a CD from Support Connection, skip this step. The support pack is already 
expanded.

3 At the server console, start NWCONFIG.NLM.

4 Select Product Options > Install a Product Not Listed. 

5 Press F3 (F4 if you're using RCONSOLE) > specify the path to the expanded Support Pack files, 
such as SYS:\NW5SP4.

If you are running DSREPAIR.NLM from 
here

Do this

A server that holds a writable replica of 
the root partition

Reapply the Post NetWare 5 Schema Update 
to your eDirectory tree.

From any other server Click Advanced Options > Global Schema 
Operations > Request Schema from Tree.

Before installing eDirectory on this server Install this support pack

NetWare 5 NetWare 5 Support Pack 6a

NetWare 5.1 NetWare 5.1 Support Pack 2a or later
000-0000-000
November 30, 2001
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6 Select options. 

Follow the online instructions to install the support pack.

During installation, the support pack might prompt you concerning extending the schema. 
Although you have already extended the schema for eDirectory, you most likely need to 
extend the schema for other functionality, such as Novell Licensing Services.

7 Take the server down, then restart it.

If you checked the Reboot Server option in Step 6, the server automatically restarts.

Installing eDirectory
1 (Conditional) If you are upgrading eDirectory, do the following:

1a In the AUTOEXEC.NCF file, comment out the lines that load virus scanners, database 
applications such as Sybase* or Oracle*, backup applications, and other programs that 
rely on files being continually open and volumes being mounted. 

During the eDirectory installation, the software must dismount volumes so that trustee 
assignments can be migrated. 

Be aware that virus scanners and other programs might be embedded inside other 
products, for example, ZENworksTM, ManageWiseTM, and BorderManagerTM.

1b Restart the server and verify that the programs and applications referred to in Step 1a 
are not running.

HINT: If you uncompress the volume you are installing eDirectory on, the install will finish 
quicker.

2 (Conditional) If you have an IP-only environment, load IPXSPX.NLM.

NWCONFIG.NLM looks to Btrieve* for the product list. Btrieve subsequently requires IPXTM. 
Loading IPXSPX.NLM allows Btrieve to load. When you reboot the server, IPXSPX.NLM does 
not reload, so you have an IP-only environment again.

3 At the server console, load NWCONFIG.NLM.

4 Select Product Options > Install a Product Not Listed.

5 Press F3 (F4 if you're using RCONSOLE) > enter the path to the eDirectory files under the NW 
directory, for example, SYS:\NW.

Follow on screen prompts concerning license agreements, the readme file, and tips. 

After files are copied, the server automatically restarts and begins to install components for 
ConsoleOne and Novell Certificate Server.

6 Enter the administrator’s login name (for example, Admin.VMP).

IMPORTANT: This window might close before you enter this information. If it does, toggle 
(Alt+Esc) to the screen and enter the information. Otherwise, the installation will not be 
complete.
14
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7 Follow the online instructions concerning the Certificate Server, LDAP, languages, 
components, and products to install.

8 When the installation is completed, restore the lines that you commented out in Step 1a on 
page 14 > restart the server by clicking Yes.

Repeat this procedure for each NetWare server you want to upgrade to eDirectory for NetWare.

Lost Trustee Assignments on NFS Gateway Volumes
The eDirectory installation process does not upgrade trustee assignments on NFS Gateway 

volumes. If you are hosting NFS Gateway volumes on a server upgraded to eDirectory, those 

trustee assignments are mapped to non-existent trustees.

To delete the inaccurate trustee assignments, complete the following steps:

1 On the server, load UNICON > authenticate to eDirectory.

2 Select Start/Stop Services > NFS Gateway Server > Del.

3 From a workstation, log in to the server > delete the file SYS:\NFSGW\SFSxxxx.DAT.

4 At the server, load UNICON again > authenticate to eDirectory.

5 Select Start/Stop Services > NFS Gateway Server.

You will need to manually create new trustee assignments for eDirectory objects to any NFS 

Gateway volumes.
000-0000-000
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the title of your card. 4. Put in your product version: Click Special > Variable > select the variable named Version > Edit Definition > enter the version number > click Done > Done. 
It will appear as background text replacing Version X.X. 
For a single (stand-alone) card: Keep this master page, named “QS-Single.“  It shows the part number on the bottom right, since single cards don’t have front matter. 
For a card that’s part of a booklet: Use Special > Master Page Usage to change to using “First” master page on the first page of the card.  It doesn’t show the part number, since 
part number will be noted in the front of the booklet.
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eDirectory
Installing or Upgrading Novell eDirectory 
on Windows NT/2000

Use the following instructions to install or upgrade Novell® eDirectoryTM on a Windows* NT* or 

Windows 2000 server.

S Y S TE M  R EQ U IRE ME N TS

A Windows NT server 4.0 with Service Pack 4 or later (or Windows 2000 Server) and an 
assigned IP address.

A Pentium* 200 with a minimum of 64 MB RAM (128 MB recommended) and a monitor color 
palette set to a number higher than 16.

(Optional) One or more workstations running one of the following:

Novell ClientTM for Windows 95/98 3.0 or later

Novell Client for Windows NT 4.5 or later

NT client

Administrative rights to the NT/2000 server and to all portions of the eDirectory tree that 
contain domain-enabled User objects. For an installation into an existing tree, you need 
administrative rights to the Tree object so that you can extend the schema and create 
objects.

H A RD WA R E  R EQ U I RE MEN TS

Hardware requirements depend on the specific implementation of eDirectory.

For example, a base installation of eDirectory with the standard schema requires about 74 MB of 

disk space for every 50,000 users. However, if you add a new set of attributes or completely fill 

in every existing attribute, the object size grows. These additions affect the disk space, 

processor, and memory needed.
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Two factors increase performance: more cache memory and faster processors.

For best results, cache as much of the DIB Set as the hardware allows. 

eDirectory scales well on a single processor. However, Novell eDirectory 8.6 takes advantage of 

multiple processors. Adding processors improves performance in some areas, for example, logins 

and having multiple threads active on multiple processors. eDirectory itself is not processor-

intensive, but it is I/O-intensive.

The following table illustrates typical system requirements for Novell eDirectory for Windows NT 

and Windows 2000:

Requirements for processors might be greater than the table indicates, depending upon 

additional services available on the computer as well as the number of authentications, reads, 

and writes that the computer is handling. Processes such as encryption and indexing can be 

processor-intensive. 

FOR C IN G  THE  BA CKL INK  PR OCE SS  TO  R UN

Because the internal eDirectory identifiers change when upgrading to eDirectory, the backlink 

process has to update backlinked objects for them to be consistent.

Backlinks keep track of external references to objects on other servers. For each external 

reference on a server, the backlink process ensures that the real object exists in the correct 

location and verifies all backlink attributes on the master of the replica. The backlink process 

occurs two hours after the database is open and then every 780 minutes (13 hours). The interval 

is configurable from 2 minutes to 10,080 minutes (7 days).

After migrating to eDirectory, we recommend that you force the backlink to run by issuing a SET 

DSTRACE=*B command from the server console. Running the backlink process is especially 

important on servers that do not contain a replica.

Objects Processor Memory Hard Disk

10,000 Pentium* III 450-700 MHz (single) 384 MB 144 MB

1 million Pentium III 450-700 MHz (dual) 2 GB 1.5 GB

10 million Pentium III 450-700 MHz (2 to 4) 2 GB + 15 GB
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I N S T A L L I N G  N O V E L L  E D I R E CT O R Y  O N  W I N D OW S  N T /2 0 0 0

Novell eDirectory 8.6 for NT upgrades NT servers running NT Service Pack 4 or later and 

eDirectory 8.35 or later.

If no eDirectory tree exists, you can install eDirectory 8.6. The installation program creates an 

eDirectory tree.

If your eDirectory tree does not have a Novell Certificate ServerTM, the eDirectory installation 

program does the following:

Creates a Security container object for the entire eDirectory tree

This object is created at the top of the eDirectory tree and must remain there.

Creates an Organizational Certificate Authority (CA) object

Places the Organizational CA object in the Security container

Only one Organizational CA object can exist in an eDirectory tree. Because you must not move 

this object from one server to another, ensure that the first eDirectory server is the one that you 

intend to permanently host the Organizational CA object. 

Prerequisites
Because NTFS provides a safer transaction process than a FAT file system provides, you can 
only install eDirectory on an NTFS partition. Therefore, if you only have FAT file systems, 
do one of the following: 

Create a new partition and format it as NTFS.

Use Disk Administrator. Refer to Windows NT Server User Guide for more information.

Convert an existing FAT file system to NTFS, using the CONVERT command.

If your server only has a FAT file system and you forget or overlook this process, the 
installation program prompts you to provide an NTFS partition.

If you are installing eDirectory for NT/2000 into an eDirectory tree that has NetWare® and 
NT/2000 servers, each NetWare server must be running one of the following:

NetWare 4.2 with NDS 6.09 or later

NetWare 5.0 with Support Pack 5 or later

NetWare 5.1 with Support Pack 1 or later

NetWare 6

Each NT/2000 server must be running eDirectory 8.0 or later.
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Updating the eDirectory Schema
To upgrade an existing tree, run DSREPAIR on the server that contains the master replica of the 

Tree partition. 

IMPORTANT: If the master replica of the Tree partition resides on a NetWare server, follow the 
instructions in “Updating the eDirectory Schema” on page 11.

The eDirectory installation program checks the existing schema’s version. If the schema has not 

been upgraded, the installation program instructs you to run DSREPAIR, then discontinues.

1 Copy PATCHES\DSREPAIR\ NTNDS8\DSREPAIR. DLL from the product CD to the directory 
where you installed eDirectory, for example, G:\NOVELL\NDS.

This file is version 8.35.

2 Start NDSCONSOLE by running NDSCONS.EXE. 

This file is in the directory where you installed eDirectory.

3 Select DSREPAIR from the NDS® Service list.

4 Enter -ins in the Startup Parameters field > click Start.

After the schema has been updated, the status field next to the DSREPAIR module in 
NDSCONSOLE will be blank.

5 To see the results of the schema update, select DSREPAIR in NDSCONSOLE.

6 Click Start > File > Open Log File > Open. 

The last entry of the log file will contain the results of the schema update.

Installing eDirectory 
1 At the NT/2000 server, log in as Administrator or as a user with administrative privileges.

2 Run SETUP.EXE from the NT directory on the product CD.

3 Select which components to install.

You can install the components separately or together.

Install Novell Directory Services®

This option installs eDirectory in an NT/2000-only or mixed NetWare/NT/2000 server 
environment. 

Follow the online instructions in the Installation Wizard. 

SLP Directory Agent

Installs SLP Directory Agent, which allows you to control the collection and 
dissemination of network service information through advanced features.
20
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Follow the online instructions in the Installation Wizard. Select the type of setup you 
want to install: 

Directory: Use eDirectory to manage, configure, and store Directory Agents, scopes, 
and services.

Local: The Directory Agent and its associated scopes and services are stored and 
configured through the local machine. 

Install ConsoleOne

This option installs ConsoleOneTM 1.3. 

Follow the online instructions in the Installation Wizard.

The installation program checks for the following components. If a component is missing or is an 

incorrect version, the installation program automatically launches an installation for the 

component.

Novell Client for Windows NT/2000

For more information on the Novell Client for Windows NT, see the Novell Client for Windows 
online documentation (http://www.novell.com/documentation/lg/client/docui/
index.html).

Novell licensing

Evaluation licenses (http://www.novell.com/products/edirectory/licenses/eval_861.html) 
are available.
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To begin a QuickStart (English): Click in the box under the word Novell. Insert QuickStart and Title elements. 2. Type the product name. 3. Insert the HeadQS element and type the title of your card. 
4. Put in your product version: Click Special > Variable > select the variable named Version > Edit Definition > enter the version number > click Done > Done. It will appear as background text replacing 
Version X.X. 
For a single (stand-alone) card: Keep this master page, named “QS-Single.“  It shows the part number on the bottom right, since single cards don’t have front matter. 
For a card that’s part of a booklet: Use Special > Master Page Usage to change to using “First” master page on the first page of the card.  It doesn’t show the part number, since part number will be 
noted in the front of the booklet.
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Q U I C K S T A R T

eDirectory
Installing Novell eDirectory on Solaris

This section contains the minimum system requirements for Novell® eDirectoryTM on Solaris*, basic 

installation commands, and a brief description of the eDirectory configuration utilities.

S Y S T E M  R E Q U I R E M E N T S

All recommended Solaris OS patches are available at the SunSolve* Online Web page (http://
sunsolve.sun.com)

Solaris 2.6 (with patch 105591-07 or later) 

Solaris 7 (with patch 106327-06 or later for 32-bit systems) 

Solaris 7 (with patch 106300-07 or later for 64-bit systems)

Solaris 8 (with patch 109461-02 and patch 108827-10 or later)

A minimum of 64 MB RAM (128 MB recommended)

74 MB of disk space to install eDirectory. Additional disk space required based on data.

S O F T W A R E  R E Q U I R E M E N T S

Netware Time Protocol

ConsoleOne 1.3 or later

H A R D W A R E  R E Q U I R E M E N T S

Hardware requirements depend on the specific implementation of eDirectory.

Two factors increase performance: more cache memory and high end processors.

For best results, cache as much of the DIB Set as the hardware allows up to 2GB.

eDirectory scales well on a single processor. However, eDirectory 8.6 takes advantage of multiple 

processors. Adding processors improves performance in some areas, for example, logins and having multiple 
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threads active on multiple processors. eDirectory itself is not processor-intensive, but it is I/O-intensive.

The following table illustrates typical system requirements for Novell eDirectory for Solaris.

Requirements for processors might be greater than the table indicates, depending upon additional services 

available on the computer as well as the number of authentications, reads, and writes that the computer is 

handling. Processes such as encryption and indexing can be processor-intensive. 

F O R C I N G  T H E  B A C K L I N K  P R O C E S S  T O  R U N

Because the internal eDirectory identifiers change when upgrading to Novell eDirectory, the backlink 

process has to update backlinked objects for them to be consistent.

Backlinks keep track of external references to objects on other servers. For each external reference on a 

server, the backlink process ensures that the real object exists in the correct location and verifies all backlink 

attributes on the master of the replica. The backlink process occurs two hours after the database is open and 

then every 780 minutes (13 hours). The interval is configurable from 2 minutes to 10,080 minutes (7 days).

After migrating to eDirectory, start the ndstrace process by issuing the ndstrace -l >log& command, 

which runs the process at the background. You can force the backlink to run by issuing the ndstrace -c 

SET DSTRACE=*B command from the ndstrace command prompt. You can then unload the ndstrace 

process by issuing the ndstrace -u command. Running the backlink process is especially important on 

servers that do not contain a replica.

Objects Processor Memory Hard Disk

100,000 Sun* Enterprise 220 384 MB 144 MB

1 million Sun Enterprise 450 2 GB 1.5 GB

10 million Sun Enterprise 4500 with multiple 
processors

2 GB + 15 GB
24
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P R E R E Q U I S I T E S

eDirectory Server must be installed on all servers that you want to place an eDirectory replica on.

Meet the “System Requirements” on page 23.

Enable the Solaris host for multicast routing on the server on which you are installing the product. 
Enter the following command to check whether the host is enabled for multicast routing: 

/usr/bin/netstat -nr

The following entry should be present in the routing table:

224.0.0.0 host_IP_address

If the entry is not present, log in as root, and enter the following command to enable multicast routing: 

route add -net 224.0.0.0 -net 224.0.0.0 netmask 240.0.0.0 hme0 

NICI 2.3 is a pre-requisite for installing eDirectory. eDirectory prompts for the installation of NICI 2.3 
if it is not installed. The NOVLniu0-2.3.0 package contains NICI 2.3.

For secure Novell eDirectory operations, you will need the NICI Foundation Key file. You can obtain 
an evaluation license file from the Novell eDirectory Eval License Download (http://www.novell.com/
products/edirectory/licenses/eval_861.html) Web site. If you do not use the NICI Foundation Key, you 
will not be able to create Certificate Authority and Key Material objects.

If you have more than one server in the tree, the time on all the network servers should be 
synchronized. Use Network Time Protocol (NTP) to synchronize time. 

If you are installing a secondary server, all the replicas in the partition where you have installed the 
product should be in the On state.

I N S T A L L I N G  E D I R E C T O R Y  O N  S O L A R I S

Use the nds-install utility to install eDirectory components on Solaris systems. This utility is located in the 

Setup directory on the CD for the Solaris platform. The utility adds the required packages based on the 

components you select to install.

To install eDirectory components on Solaris systems:

1 Log in as root on the host.

2 Enter the following command from the setup directory:

nds-install

3 When prompted, accept the license agreement.

The installation program displays a list of Novell eDirectory components that you can install.
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4 Specify the option for the component you want to install. The appropriate packages are installed on the 
Solaris host. 

Table 3 lists the packages installed for each eDirectory component.

Table 3

5 If you are prompted, enter the complete path to the NICI Foundation Key file.

You will be prompted to enter the complete path to the NICI Foundation Key only if the installation 
program is not able to locate the file in the default location (/var, the mounted license diskette, or the 
current directory).

IMPORTANT: Before you begin to use Novell eDirectory, ensure that SLP has been installed for the 
eDirectory tree to be advertised. To determine the advertisement of the eDirectory tree, enter the following: 

/usr/bin/slpinfo -s "ndap.novell//(svcname-ws==*tree_name.)/"

C O N F I G U R I N G  E D I R E C T O R Y  O N  S O L A R I S

1. Use the ndsconfig utility to configure eDirectory. 

To create a new tree, enter ndsconfig new -t corp-tree -n o=company -a 
cn=admin.o=company

To add a replica into an existing tree, enter ndsconfig add -t corp-tree -n 
o=company -a cn=admin.o=company

To remove a replica, enter ndsconfig rm -a cn=admin.o=company

eDirectory Component Packages Installed Description

eDirectory Server NDSbase, NDScommon, 
NDSsecur, NDSsecutl, 
NDSmasv, NDSserv, 
NDSimon, NDSrepair, NDSslp 
and NDSdexvnt.

The eDirectory replica server will 
be installed on the specified server

Administration Utilities NDSadmutl, NDSsecutl, 
NDSbase, and NLDAPbase

The Novell Import Conversion 
Export and LDAP Tools utilities 
will be installed on the specified 
workstation

Management Console for 
eDirectory

NDSbase, NDSslp, NovLC1, 
C1JRE, NDSadmutl, 
NLDAPbase, and NDS set of 
packages

The management console for 
eDirectory will be installed on the 
specified workstation

NMAS (Novell Modular 
Authentication Service) 
server

NDSnmas The NMAS server components 
and the configuration utilities will 
be installed on the specified server. 
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2. Use the ldapconfig utility to modify, view, and refresh LDAP object attributes.

3. Use the nmasconfig utility to configure NMAS and the policy-based authentication methods (log in 
methods).

4. Use the pkiconfig utility to create the following Novell PKI Objects:

Organizational Certificate Authority (CA) 

Server Certificates (Stored as Key Material Objects (KMO))

User Certificates

Security Container

SAS Service object
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To begin a QuickStart (English): Click in the box under the word Novell. Insert QuickStart and Title elements. 2. Type the product name. 3. Insert the HeadQS element and type the title of your card. 
4. Put in your product version: Click Special > Variable > select the variable named Version > Edit Definition > enter the version number > click Done > Done. It will appear as background text replacing 
Version X.X. 
For a single (stand-alone) card: Keep this master page, named “QS-Single.“  It shows the part number on the bottom right, since single cards don’t have front matter. 
For a card that’s part of a booklet: Use Special > Master Page Usage to change to using “First” master page on the first page of the card.  It doesn’t show the part number, since part number will be 
noted in the front of the booklet.
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Q U I C K S T A R T

eDirectory
Installing Novell eDirectory on Linux

This section contains the minimum system requirements for Novell® eDirectoryTM on Linux*, basic 

installation commands, and a brief description of the eDirectory configuration utilities.

S Y S T E M  R E Q U I R E M E N T S

Linux 2.2 and glibc 2.1.3 (Recommended glibc 2.2)

A minimum of 64 MB RAM (128 MB recommended)

74 MB of disk space for minimum of 50,000 users. Additional disk space required based on data.

S O F T W A R E  R E Q U I R E M E N T S

Netware Time Protocol

ConsoleOne 

ConsoleOne 1.3 or later

A minimum of 64 MB RAM (128 MB recommended)

200 MHz processor (a faster one is recommended)

H A R D W A R E  R E Q U I R E M E N T S

Hardware requirements depend on the specific implementation of eDirectory.

Two factors increase performance: more cache memory and faster processors.

For best results, cache as much of the DIB Set as the hardware allows up to 2GB.

eDirectory scales well on a single processor. However, eDirectory 8.6 takes advantage of multiple 

processors. Adding processors improves performance in some areas, for example, logins and having multiple 

threads active on multiple processors. eDirectory itself is not processor-intensive, but it is I/O-intensive.

The following table illustrates typical system requirements for eDirectory for Linux:
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Requirements for processors might be greater than the table indicates, depending upon additional services 

available on the computer as well as the number of authentications, reads, and writes that the computer is 

handling. Processes such as encryption and indexing can be processor-intensive. 

F O R C I N G  T H E  B A C K L I N K  P R O C E S S  T O  R U N

Because the internal eDirectory identifiers change when upgrading to Novell eDirectory 8.6, the backlink 

process has to update backlinked objects for them to be consistent.

Backlinks keep track of external references to objects on other servers. For each external reference on a 

server, the backlink process ensures that the real object exists in the correct location and verifies all backlink 

attributes on the master of the replica. The backlink process occurs two hours after the database is open and 

then every 780 minutes (13 hours). The interval is configurable from 2 minutes to 10,080 minutes (7 days).

After migrating to eDirectory, start the ndstrace process by issuing the ndstrace -l >log& command, 

which runs the process at the background. You can force the backlink to run by issuing the ndstrace -c 

SET DSTRACE=*B command from the ndstrace command prompt. You can then unload the ndstrace 

process by issuing the ndstrace -u command. Running the backlink process is especially important on 

servers that do not contain a replica.

Objects Processor Memory Hard Disk

100,000 Pentium* III 450-700 MHz 
(single)

384 MB 144 MB

1 million Pentium III 450-700 MHz (dual) 2 GB 1.5 GB

10 million Pentium III 450-700 MHz (2 to 4) 2 GB + 15 GB
30
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P R E R E Q U I S I T E S

eDirectory Server must be installed on all servers that you want to place an eDirectory replica on.

Meet the “System Requirements” on page 29.

Enable the Linux host for multicast routing on the server on which you are installing the product. Enter 
the following command to check whether the host is enabled for multicast routing: 

/bin/netstat -nr

The following entry should be present in the routing table:

224.0.0.0 0.0.0.0

If the entry is not present, log in as root, and enter the following command to enable multicast routing: 

route add -net 224.0.0.0 netmask 240.0.0.0 dev -interface 

NICI 2.3 is a pre-requisite for installing eDirectory. eDirectory prompts for the installation of NICI 2.3 
if it is not installed. The NOVLniu0-2.3.0 package contains NICI 2.3.

For secure Novell eDirectory operations, you will need the NICI Foundation Key file. You can obtain 
an evaluation license file from the Novell eDirectory Eval License Download (http://www.novell.com/
products/edirectory/licenses/eval_861.html) Web site. If you do not use the NICI Foundation Key, you 
will not be able to create Certificate Authority and Key Material objects.

If you have more than one server in the tree, the time on all the network servers should be 
synchronized. Use Network Time Protocol (NTP) to synchronize time.

If you are installing a secondary server, all the replicas in the partition where you have installed the 
product should be in the On state.

I N S T A L L I N G  E D I R E C T O R Y  O N  L I N U X

Use the nds-install utility to install eDirectory components on Linux systems. This utility is located in the 

Setup directory on the CD for the Linux platform. The utility adds the required packages based on the 

components you select to install.

To install eDirectory components on Linux systems:

1 Log in as root on the host.

2 Enter the following command from the setup directory:

nds-install
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3 When prompted, accept the license agreement.

The installation program displays a list of eDirectory components that you can install.

4 Specify the option for the component you want to install. The appropriate RPMs are installed on the 
Linux host. 

Table 4 lists the RPMs installed for each eDirectory component.

Table 4

5 If you are prompted, enter the complete path to the NICI Foundation Key file.

You will be prompted to enter the complete path to the NICI Foundation Key only if the installation 
program is not able to locate the file in the default location (/var, the mounted license diskette, or the 
current directory).

IMPORTANT: Before you begin to use eDirectory, ensure that SLP is installed for the eDirectory tree to be 
advertised. To determine the advertisement of the eDirectory tree, enter the following: 

/usr/bin/slpinfo -s "ndap.novell//(svcname-ws==*tree1.)/"

C O N F I G U R I N G  E D I R E C T O R Y  O N  L I N U X

1. Use the ndsconfig utility to configure eDirectory. 

To create a new tree, enter ndsconfig new -t corp-tree -n o=company -a 
cn=admin.o=company

To add a replica into an existing tree, enter ndsconfig add -t corp-tree -n 
o=company -a cn=admin.o=company

eDirectory Component Packages Installed Description

eDirectory Server NDSbase, NDScommon, 
NDSsecur, NDSsecutl, 
NDSmasv, NDSserv, 
NDSimon, NDSrepair, NDSslp 
and NDSdexvnt

The eDirectory replica server will 
be installed on the specified server

Administration Utilities NDSadmutl, NDSsecutl, 
NDSbase and NLDAPbase

The Novell Import Conversion 
Export and LDAP Tools utilitites 
will be installed on the specified 
workstation

Management Console for 
eDirectory

NDSbase, NDSslp, NovLC1, 
C1JRE, and NDS set ot 
packages

The management console for 
eDirectory will be installed on the 
specified workstation

NMAS (Novell Modular 
Authentication Service) 
server

NDSnmas The NMAS server components 
and the configuration utilities will 
be installed on the specified server. 
32
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To remove a replica, enter ndsconfig rm -a cn=admin.o=company

2. Use the ldapconfig utility to modify, view, and refresh LDAP object attributes.

3. Use the nmasconfig utility to configure NMAS and the policy-based authentication methods (log in 
methods).

4. Use the pkiconfig utility to create the following Novell PKI Objects:

Organizational Certificate Authority (CA) 

Server Certificates (Stored as Key Material Objects (KMO))

User Certificates

Security Container

SAS Service object
000-0000-000
November 30, 2001

33



QuickStart Rev 99a44 August 22, 2001
34

000-0000-000
November 30, 2001


	Novell eDirectory Overview
	Supported Platforms
	For More Information

	Installing or Upgrading Novell eDirectory on NetWare
	System Requirements
	Hardware Requirements
	Forcing the Backlink Process to Run
	Installing Novell eDirectory on NetWare
	Prerequisites
	Updating the eDirectory Schema
	Installing a Support Pack
	Installing eDirectory
	Lost Trustee Assignments on NFS Gateway Volumes


	Installing or Upgrading Novell eDirectory on Windows NT/2000
	System Requirements
	Hardware Requirements
	Forcing the Backlink Process to Run
	Installing Novell eDirectory on Windows NT/2000
	Prerequisites
	Updating the eDirectory Schema
	Installing eDirectory


	Installing Novell eDirectory on Solaris
	System Requirements
	Software Requirements
	Hardware Requirements
	Forcing the Backlink Process to Run
	Prerequisites
	Installing eDirectory on Solaris
	configuring eDirectory on Solaris

	Installing Novell eDirectory on Linux
	System Requirements
	Software requirements
	Hardware Requirements
	Forcing the Backlink Process to Run
	Prerequisites
	Installing eDirectory on Linux
	ConfigurinG eDirectory on Linux


