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Legal Notices

Novell, Inc. makes no representations or warranties with respect to the contents or use of this documentation, and 
specifically disclaims any express or implied warranties of merchantability or fitness for any particular purpose. 
Further, Novell, Inc. reserves the right to revise this publication and to make changes to its content, at any time, 
without obligation to notify any person or entity of such revisions or changes.

Further, Novell, Inc. makes no representations or warranties with respect to any software, and specifically disclaims 
any express or implied warranties of merchantability or fitness for any particular purpose. Further, Novell, Inc. 
reserves the right to make changes to any and all parts of Novell software, at any time, without any obligation to 
notify any person or entity of such changes.

You may not use, export, or re-export this product in violation of any applicable laws or regulations including, 
without limitation, U.S. export regulations or the laws of the country in which you reside.

Copyright © 2004-2005 Novell, Inc. All rights reserved. Permission is granted to copy, distribute, and/or modify this 
document under the terms of the GNU Free Documentation License (GFDL), Version 1.2 or any later version, 
published by the Free Software Foundation with no Invariant Sections, no Front-Cover Texts, and no Back-Cover 
Texts. A copy of the GFDL can be found at http://www.fsf.org/licenses/fdl.html or at “GNU Free Documentation 
License” on page 112.

THIS DOCUMENT AND MODIFIED VERSIONS OF THIS DOCUMENT ARE PROVIDED UNDER THE 
TERMS OF THE GNU FREE DOCUMENTATION LICENSE WITH THE FURTHER UNDERSTANDING THAT:

1. THE DOCUMENT IS PROVIDED ON AN “AS IS” BASIS, WITHOUT WARRANTY OF ANY KIND, 
EITHER EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, WARRANTIES THAT THE 
DOCUMENT OR MODIFIED VERSION OF THE DOCUMENT IS FREE OF DEFECTS, MERCHANTABLE, 
FIT FOR A PARTICULAR PURPOSE, OR NON-INFRINGING. THE ENTIRE RISK AS TO THE QUALITY, 
ACCURACY, AND PERFORMANCE OF THE DOCUMENT OR MODIFIED VERSION OF THE DOCUMENT 
IS WITH YOU. SHOULD ANY DOCUMENT OR MODIFIED VERSION PROVE DEFECTIVE IN ANY 
RESPECT, YOU (NOT THE INITIAL WRITER, AUTHOR OR ANY CONTRIBUTOR) ASSUME THE COST OF 
ANY NECESSARY SERVICING, REPAIR OR CORRECTION. THIS DISCLAIMER OF WARRANTY 
CONSTITUTES AN ESSENTIAL PART OF THIS LICENSE. NO USE OF ANY DOCUMENT OR MODIFIED 
VERSION OF THE DOCUMENT IS AUTHORIZED HEREUNDER EXCEPT UNDER THIS DISCLAIMER; 
AND

2. UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, WHETHER IN TORT (INCLUDING 
NEGLIGENCE), CONTRACT, OR OTHERWISE, SHALL THE AUTHOR, INITIAL WRITER, ANY 
CONTRIBUTOR, OR ANY DISTRIBUTOR OF THE DOCUMENT OR MODIFIED VERSION OF THE 
DOCUMENT, OR ANY SUPPLIER OF ANY OF SUCH PARTIES, BE LIABLE TO ANY PERSON FOR ANY 
DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OF ANY CHARACTER 
INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF GOODWILL, WORK STOPPAGE, 
COMPUTER FAILURE OR MALFUNCTION, OR ANY AND ALL OTHER DAMAGES OR LOSSES ARISING 
OUT OF OR RELATING TO USE OF THE DOCUMENT AND MODIFIED VERSIONS OF THE DOCUMENT, 
EVEN IF SUCH PARTY SHALL HAVE BEEN INFORMED OF THE POSSIBILITY OF SUCH DAMAGES.

Novell, Inc. has intellectual property rights relating to technology embodied in the product that is described in this 
document. In particular, and without limitation, these intellectual property rights may include one or more of the U.S. 
patents listed at http://www.novell.com/company/legal/patents/ and one or more additional patents or pending patent 
applications in the U.S. and in other countries.

Novell, Inc.
404 Wyman Street, Suite 500
Waltham, MA 02451
U.S.A.
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www.novell.com

Online Documentation: To access the online documentation for this and other Novell products, and to get 
updates, see www.novell.com/documentation.
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Novell Trademarks

Evolution is a trademark of Novell, Inc.
GroupWise is a registered trademark of Novell, Inc, in the United States and other countries.
NetWare is a registered trademark of Novell, Inc, in the United States and other countries.
Novell is a registered trademark of Novell, Inc, in the United States and other countries.
Novell iFolder is a registered trademark of Novell, Inc, in the United States and other countries.
Red Carpet is a registered trademark of Novell, Inc, in the United States and other countries.
SUSE is a registered trademark of SUSE LINUX AG, a Novell business.

Third-Party Materials

All third-party trademarks are the property of their respective owners.
Parts of this manual are copyright © 2003-2004 Sun Microsystems.
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About This Guide

Congratulations on choosing the Novell® Linux* Desktop (NLD). This manual is designed to 
introduce you to the GNOME graphical desktop environment and show you how to configure it to 
meet your personal needs and preferences. It also introduces you to several programs and services, 
including office programs such as OpenOffice.org, Web browsers, file managers, scanning tools, 
and image editing tools. It is intended for users who have some experience using a graphical desktop 
environment such as Macintosh*, Windows*, or other Linux desktops.

This guide contains the following sections:

• Chapter 1, “Welcome,” on page 11
• Chapter 2, “Getting Started,” on page 21
• Chapter 3, “Customizing Your Settings,” on page 35
• Chapter 4, “The OpenOffice.org Office Suite,” on page 65
• Chapter 5, “Browsing the Internet,” on page 77
• Chapter 6, “Using Collaboration Software,” on page 89
• Chapter 7, “Using Multimedia Utilities,” on page 93
• Chapter 8, “Accessing Files on the Network,” on page 101
• Chapter 9, “Managing Printers,” on page 105
• Appendix A, “GNU Licenses,” on page 107
• “Glossary” on page 119

Audience

This guide is intended for NLD users using the GNOME desktop.

Feedback

We want to hear your comments and suggestions about this manual and the other documentation 
included with this product. Please use the User Comments feature at the bottom of each page of the 
online documentation, or go to www.novell.com/documentation/feedback.html and enter your 
comments there.

Documentation Updates

For the latest version of this documentation, see the Novell Linux Desktop documentation (http://
www.novell.com/documentation/lg/nld/index.html) Web site.

Additional Documentation

The Novell Linux Desktop GNOME User Guide and documentation for each of the components 
included with Novell Linux Desktop can be accessed using the Help Center. To access the Novell 
Help Center, click Help on the top panel of the desktop and then click User's Manual.

For documentation about the NLD KDE Desktop, see Novell Linux Desktop KDE User Guide (http:/
/www.novell.com/documentation/nld/userguide_kde/data/front.html).
9
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For information about installing and administering NLD, see the Novell Linux Desktop Deployment 
Guide (http://www.novell.com/documentation/nld/nld_deployment/data/front.html).

Documentation Conventions

In Novell documentation, a greater-than symbol (>) is used to separate actions within a step and 
items in a cross-reference path.

A trademark symbol (®, TM, etc.) denotes a Novell trademark. An asterisk (*) denotes a third-party 
trademark.
ll Linux Desktop 9 GNOME User Guide
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Welcome 1

The Novell® Linux Desktop (NLD) offers an easy-to-use graphical interface that, like other popular 
desktops, can be customized to meet your needs and personal preferences. This chapter introduces 
the desktop and highlights some of the differences between NLD and other common desktop 
products.

• “Introducing the Novell Linux Desktop” on page 11
• “For Microsoft Windows Users” on page 12
• “Finding the Information You Need” on page 16

1.1  Introducing the Novell Linux Desktop 
The Novell Linux Desktop (NLD) is a new Linux desktop created by combining two of the best 
Linux desktops available with leading Novell products and services. 

NLD is powered by SUSE® LINUX and combines the best Linux software—including 
OpenOffice.org productivity software (compatible with Microsoft* Office documents) and the 
award winning Novell EvolutionTM collaboration software—with leading Novell products and 
services to create a work environment that helps you capture and share business information. 

NLD features include the following: 

• OpenOffice.org productivity suite: Provides word processing, spreadsheet, presentation, 
drawing, and database programs.

• CD nurner: Provides a comfortable user interface to perform most CD- and DVD-burning 
tasks.

• CUPS printing system: Lets you set up and print to local and network printers.
• File manager: Helps you navigate files, networks, and devices; designed especially for people 

migrating from Microsoft Windows. The file manager includes a desktop icon named 
Computer, similar to the Windows My Computer.

• Firefox*: A powerful Web browser.
• Agfa* fonts: High-quality licensed fonts, metrically compatible with those used in Microsoft 

Office, to help preserve formatting and styles across platforms.
• RealNetworks* RealPlayer*: Media player for RealAudio* and RealVideo* formats. Works 

with or without your Web browser.
• Macromedia* Flash*: Browser plug-in for display of Flash vector animation on the Web.
• Sun* Java* Runtime Environment: Lets you use the broadest range of Java software with 

the best performance.

NLD offers a host of capabilities for organizations using a mixture of Linux and Windows systems. 
They include the following:

• Microsoft Office format support: OpenOffice.org supports the file formats from Office 97, 
2000, and XP, so you don’t have to worry about the format, even when people send you 
documents from the newest systems.
Welcome 11
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• Citrix*: Lets you establish a session with a Citrix server, which enables the user to access 
server-based applications that appear to run locally on the client machine but execute on the 
server.

• Metrically compatible fonts: Not only do the files translate, but Novell has chosen fonts that 
are the same size as those on Windows, to help preserve page breaks, bullet points, and other 
document formatting.

• Windows (SMB) networking: Lets you open the My Computer view and double-click the 
Windows Network icon to get to file servers and shared volumes.

• Communications standards support: Novell Evolution works with POP, SMTP, IMAP, and 
other standardized communications protocols, letting you use the application as an e-mail client 
for virtually any messaging system.

• Optional Microsoft Exchange support with Novell Connector: With Novell Connector, you 
can use Evolution to access shared or private e-mail, group schedules, company address lists, 
public folders, and more on a Microsoft Exchange 2000 or 2003 server.

• Keyboard shortcuts: NLD uses familiar Windows shortcuts such as Cut, Copy, and Paste. For 
information on changing keyboard shortcuts, see Section 3.1.4, “Customizing Keyboard 
Shortcuts,” on page 40.

1.2  For Microsoft Windows Users
If you are coming from Microsoft Windows, take a look at how familiar elements of Windows 
translate to the Novell Linux Desktop. After logging in, you will notice that the desktop has a 
familiar layout and recognizable icons, many of them similar to the Windows and Macintosh* 
desktops.

Figure 1-1   Novell Linux Desktop (GNOME)
ll Linux Desktop 9 GNOME User Guide
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1.2.1  Start Menu
You can access all of your programs by clicking the Programs menu, similar to the Start menu in 
Windows.

Figure 1-2   Novell Linux Desktop Programs Menu

1.2.2  Windows Explorer
To manage files, double-click Computer on the desktop. This opens the contents of the Computer 
folder in File Manager.

Figure 1-3   Comparing Windows Explorer to the Novell Linux Desktop File Manager

For more information, see “Managing Folders and Files with File Manager” on page 27.
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1.2.3  Command Prompt
To run commands from a command line, similar to what you might have done at Command Prompt 
in Windows, click Programs > System Tools > Terminal. In the terminal window, you can run most 
Linux commands.

Figure 1-4   Comparing Windows Command Line Prompt to the Novell Linux Desktop Terminal Window

1.2.4  Control Panel
To change to the way NLD looks and behaves, click System > Personal Settings. Some of the 
settings you might want to change include the desktop background, screen saver, keyboard and 
mouse configuration, sounds, and file associations.

Figure 1-5   Comparing Windows Control Panel to Novell Linux Desktop Personal Settings

For more information, see Chapter 3, “Customizing Your Settings,” on page 35.
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1.2.5  Print Manager
To set up or add a printer to NLD, click System > Personal Settings. In the Settings window, double-
click Printers.

Figure 1-6   Comparing the Printers and Faxes Folder in Windows to the Novell Linux Desktop Printers View 

For more information, see Chapter 9, “Managing Printers,” on page 105.

1.2.6  Task Switching
Similar to the Task Bar in Windows, the bottom panel in NLD lets you easily switch between open 
windows. Unlike Windows, NLD lets you set up multiple desktops where each one can be running 
different programs. With a single click, you can switch between them.

TIP: You can also use the traditional Alt+Tab to switch between tasks.

Figure 1-7   Comparing Windows Task Bar to Novell Linux Desktop Bottom Panel

1.2.7  My Network Places
If your system is configured to access places on a network, you can use File Manager to access those 
locations. On the Desktop, click Computer > Network. Depending on how your system was 
configured, select the network resource you want to browse.
Welcome 15
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Figure 1-8   Comparing Windows My Network Places to Novell Linux Desktop Network

For more information, see Chapter 8, “Accessing Files on the Network,” on page 101.

1.3  Finding the Information You Need
To help you use NLD, Novell and the open source community at large have created a wealth of 
information. We have compiled relevant information and made it available to you in various 
formats:

• “Instruction Manuals and Documentation” on page 16
• “Additional Resources” on page 19

1.3.1  Instruction Manuals and Documentation
NLD includes a Help Center, which includes the NLD User Guides, all available information 
sources for your workstation, and online help for installed programs. The Help Center also provides 
access to man (manual) and info (information) pages associated with command line programs as 
well as to the help for graphical programs. To access the man and info pages, click Help > User’s 
Manual from the menu panel and then click the links for the manual and info pages listed under the 
heading Additional Documents.

Using the Help Center

When you start the Help Center (by clicking Help > User's Manual in the menu panel or clicking 
Help in an application), the view as shown in the following figure is displayed and consists of three 
main areas.
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Figure 1-9   Main Window of the Help Center

The Help Center consists of three main areas:

• Menu Bar and Toolbar (page 17)
• Navigation Area with Tabs (page 17)
• View Window (page 18)

Menu Bar and Toolbar

The menu bar provides the main editing, navigation, and configuration options. 

• The File menu: Contains the option for printing the currently displayed content.
• The Edit menu: Lets you access the search function.
• The Go menu: Contains navigation options, including Home (home page of the Help Center), 

Back, Forward, and Last Search Result.
• The Settings menu: Lets you configure shortcuts to the Help Center and generate a search 

index for all selected information sources.

The toolbar contains three navigation icons (Forward, Back, Home) and a Printer icon for printing 
the current contents. Also on the toolbar is a shortcut to printing information and to zoom in or out 
on the displayed information.

Navigation Area with Tabs

The navigation area in the left frame of the window provides an input field for a quick search in 
selected information sources.

• The Contents tab: Presents a tree view of all available and currently installed information 
sources. Click the book icons to open and browse the individual categories. 

• The Glossary tab: Provides a quick reference where you can look up the definitions of words 
that might be unfamiliar to you.

Details regarding the search and the configuration of the search function in the Search tab are found 
in “Search Function of the Help Center” on page 18. 
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View Window

The view window always displays the currently selected contents, such as online manuals, search 
results, or Web pages. 

Search Function of the Help Center

To search all installed information sources in NLD, generate a search index and set a number of 
search parameters. To do this, click the Search tab. 

Figure 1-10   Configuring the Search Function

If no search index was generated previously, the system automatically prompts you to do so when 
you click the Search tab or type a search string and click Search. In the dialog for generating the 
search index (Figure 1-11 below), select the information sources to index. The index is generated 
when you exit the dialog by clicking OK. 
ll Linux Desktop 9 GNOME User Guide
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Figure 1-11   Generating a Search Index

To limit the search base and the hit list as precisely as possible, use the three drop-down menus to 
determine the number of displayed hits and the selection area of sources to search. The following 
options are available for determining the selection area: 

• Default: A predefined selection of sources is searched. 
• All: All sources are searched. 
• None: No sources are selected for the search. 
• Custom: Lets you determine the sources to search by selecting them in the overview. 

Upon completion of the search configuration, click Search. The relevant items are then displayed in 
the view window and can easily be navigated with mouse clicks. 

1.3.2  Additional Resources
Other places to look for support include the following:

• Novell Linux Desktop Deployment Guide (http://www.novell.com/documentation/nld/
nld_deployment/data/front.html)

• SUSE Support Knowledgebase (http://portal.suse.com/sdb/en/index.html)
• GNOME Documentation Web site (http://www.gnome.org/learn/users-guide/latest/)
• Novell Online Documentation (http://www.novell.com/documentation/nld)
• Novell Technical Support Knowledgebase (http://support.novell.com/search/kb_index.jsp)
• Novell Discussion Groups (http://support.novell.com/forums/index.html)

In addition, general purpose search engines are often helpful. For example, you might try the search 
terms “Linux CD-RW help” or “OpenOffice file conversion problem” if you were having trouble 
with the CD burning or with OpenOffice.Org file conversion. Google* also has a specific Linux 
search engine at http://www.google.com/linux which you might find useful.
Welcome 19
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Getting Started 2

This chapter assists you in becoming familiar with the conventions, layout, and common tasks of 
Novell® Linux Desktop (NLD). If you have not yet installed NLD, see the Novell Linux Desktop 
Quick Start (http://www.novell.com/documentation/nld/qsnld/data/brmch9i.html).

• Starting NLD (page 21)
• Logging Out (page 22)
• Desktop Basics (page 23)
• Managing Folders and Files with File Manager (page 27).
• “Accessing Files across Multiple Workstations” on page 29
• Opening or Creating Documents with OpenOffice.org (page 29)
• Finding Files on Your Computer (page 30)
• Exploring the Internet (page 33)
• E-mail and Calendering (page 33)
• Moving Text between Applications (page 33)
• Other Useful Programs (page 33)
• Obtaining Software Updates (page 34)

2.1  Starting NLD
When you start NLD, you are prompted to enter your username and password. This is the username 
and password you created when you installed NLD. If you did not install NLD, check with your 
system administrator for the username and password.

The login has three menu items:

• Login Prompt:  Enter your username and password to log in.
• Session:  Specify the desktop to run during your session. If other desktops are installed, they 

appear in the list.
• Actions:  Perform a system action, such as shut down the computer, reboot the computer, or 

configure the Login Manager.

2.1.1  What Is a Session?
A session is the period of time from when you log in to when you log out. The login screen offers 
several login options. For example, you can select the language of your session so that text that 
appears in the NLD interface is presented in that language. 

After your username and password are authenticated, the Session Manager starts. The Session 
Manager lets you save certain settings for each session. It also lets you save the state of your most 
recent session and return to that session the next time you log in.

The Session Manager can save and restore the following settings:
Getting Started 21
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• Appearance and behavior settings, such as fonts, colors, and mouse settings.
• Applications that you were running. such as a file manager or an OpenOffice.org program. 

TIP: You cannot save and restore applications that Session Manager does not manage. For 
example, if you start the vi editor from the command line in a terminal window, Session 
Manager cannot restore your editing session.

For information on configuring session preferences, see “Managing Sessions” on page 59.

2.1.2  Switching Desktops
If you installed both the GNOME and the KDE desktops, use the following instructions to switch 
desktops.

1 Click System > Logout username > OK.
In KDE, click N > Logout > Logout.

2 On the Novell Linux Desktop login screen, click Session.

3 Select the desktop you want (GNOME or KDE), then click OK.

4 Type your username, then press Enter.

5 Type your password, then press Enter.

6 Click Make Default to make the desktop you choose in Step 3 on page 22 your new default 
desktop, or click Just For This Session to leave your previous desktop as the default the next 
time you log in.
See the “Novell Linux Desktop 9 KDE User Guide”for more information on using the KDE 
desktop.

2.1.3  Locking Your Screen
To lock the screen, you can do either of the following:

• Click System > Lock Screen.

• If the Lock button is present on a panel, click it (Description: Lockscreen icon ).
To add the Lock button to a panel, right-click the panel and then click Add to Panel > Actions > 
Lock.

When you lock your screen, the screen saver starts. To lock your screen correctly, you must have a 
screen saver enabled. To unlock the screen, move your mouse to display the locked screen dialog. 
Enter your username and password, then press Enter.

For information on configuring your screen saver, see “Configuring the Screen Saver” on page 44.

2.2  Logging Out
When you are finished using the computer, click System > Log Out username. Then select one of the 
following: 

• Log out
• Shut down
ll Linux Desktop 9 GNOME User Guide
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• Restart the computer

If you want to save your current settings so that you can restore the session later, click Save Current 
Setup.

2.3  Desktop Basics
As with other common desktop products, the main components of the NLD desktop are icons that 
link to files, folders, or programs, as well as the panels at both the top and bottom of the screen 
(similar to the Task Bar in Windows). Double-click an icon to start its associated program. Right-
click an icon to access additional menus and options. You can also right-click any empty space on 
the desktop to access additional menus for configuring or managing the desktop itself.

By default, the desktop features three key icons: your personal folder, Computer, and a trash can for 
deleted items. Other icons representing devices on your computer might also be present on the 
desktop. If you double-click your personal folder, File Manager starts and displays the contents of 
your home directory. For more information about using File Manager, see “Managing Folders and 
Files with File Manager” on page 27. 

Right-clicking an icon displays a menu offering file operations, like copying, cutting, or renaming. 
Selecting Properties from the menu displays a configuration dialog. The title of an icon as well as 
the icon itself can be changed with Select Custom Icon. The Emblems tabbed page lets you add 
graphical descriptive symbols to the icon. The Permissions tabbed page provides access to the 
access, read, and write permission settings for this file for the user, the group, or others. The Notes 
tabbed page lets you manage comments. The menu for the trash can additionally features the Empty 
Trashcan option, which deletes its contents.

A link is a special type of file that points to another file or folder. When you perform an action on a 
link, the action is performed on the file or folder the link points to. When you delete a link, you 
delete only the link file, not the file that the link points to.

To create a link on the desktop to a folder or a file, access the object in question in File Manager by 
right-clicking the object and then clicking Make Link. Drag the link from the File Manager window 
and drop it onto the desktop. 

2.3.1  Default Desktop Icons
To remove an icon from the desktop, simply drag it onto the trash can. However, be careful with this 
option—if you move folder or file icons to the trash can, the actual data is deleted. If the icons only 
represent links to a file or to a directory, only the links are deleted.

2.3.2  Desktop Menu
Right-clicking an empty spot on the desktop displays a menu with various options. Click Create 
Folder to create a new folder. Create a launcher icon for an application with Create Launcher. 
Provide the name of the application and the command for starting it, then select an icon to represent 
it. You can also change the desktop background and align desktop icons. 

2.3.3  Panel
The desktop includes two panels: the top and the bottom.
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Top Panel

The left side of the top panel (as shown in the following figure) consists of the Program, System, and 
Help menus, and quick start icons for the Web browser, EvolutionTM, OpenOffice.org Writer, and the 
network connection monitor. The right side of the top panel consists of a volume manager, a time 
and date program, and a task switcher.

Figure 2-1   Top Panel

You can add quick start icons to the top panel by right-clicking the panel and then clicking Add to 
Panel. Browse to and select the program you want to add from the menu list.

Bottom Panel

The bottom panel contains the icons of all applications currently running. If you click the name of a 
program in the taskbar, the program's window is moved to the foreground. If the program is already 
in the foreground, a mouse click minimizes it. Clicking a minimized application reopens the 
respective window. 

On the right side of the bottom panel are two icons: the Show Desktop icon which minimizes all 
program windows and displays the desktop, and the Workspace Switcher icon. 

Workspace Switcher provides access to additional work areas through virtual desktops. These 
virtual desktops, called workspaces, provide extra space in which to arrange open applications and 
windows. For example, you can put an editor on one workspace, some shells on another, and your e-
mail application and Web browser on a third workspace. Using Workspace Switcher, you can 
quickly access the programs running in the selected space and avoid windows piled on top of each 
other on one desktop.

If you right-click an empty spot in the panel, a menu opens, offering the options listed in the 
following table:

Table 2-1   Panel Menu Options

Show Desktop:

Workspace Switcher:

Option Description

Add to Panel Opens a menu list of applications and applets that can be added to the 
panel. 

Delete This Panel Removes the panel from the desktop. All of the panel settings are lost.

Lock/Unlock Panel Position Locks the panel in its current position (so that it can’t be moved to another 
location on the desktop, and unlocks the panel (so it can be moved).

To move the panel to another location, middle-click and hold on any vacant 
space on the panel, and then drag the panel to the location you want. 
ll Linux Desktop 9 GNOME User Guide



    N
ovell C

onfidential
novdocx (E

N
U

)  4 A
ugust 2005
2.3.4  Adding Applets and Applications to the Panel
You can add applications and applets to a panel for quick access. An applet is a small program that 
has limited access to your system resources. An application is usually a more robust stand-alone 
program, and access to your system resources is not as strict. 

Right-click any vacant space on the panel, click Add to Panel, then click the applet that you want to 
add from one of the submenus. Some useful programs to add to your panel include the following:

Table 2-2   Programs You Can Add to Your Panel

Properties Modifies the properties for this panel. 

New Panel Creates a new panel and adds it to the desktop.

Help Opens the Help Center.

About Panels Opens information about the panel application.

About GNOME Opens information about GNOME.

Grouping Program Description

Accessories Dictionary Lookup Searches an online dictionary for definitions and 
correct spellings of words you enter.

Sticky Notes Creates, displays, and manages sticky notes on 
your desktop.

Stock Ticker Displays continuously updated stock quotes.

Weather Report Displays current weather information for the 
specified city.

Actions Force Quit Terminates an application. This is especially useful if 
you want to terminate an application that is no 
longer responding.

Lock Locks the screen so you can temporarily leave your 
computer.

Log Out Logs you out of this session so you can log in as a 
different user or shut down the computer.

Search Finds files, folders, and documents on your 
computer.

Internet Inbox Monitor Sends an alert when new mail arrives.

Utility Battery Charge Monitor Monitors a laptop's remaining battery power.

Disk Mounter Mounts local disks and devices.

Pilot Applet Moves information between your handheld PalmOS 
device and your desktop.

System Monitor Monitors your system's load.

Option Description
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Mousing over a program in the list displays a brief overview of the program. For more information 
about a program, see the program's Help which is available by right-clicking on the icon in the panel 
and then clicking Help.

2.3.5  Main Menu
Open the main menu by clicking Programs on the far left of the top panel. The applications are 
listed in categories, except for more commonly used applications, which can be added to the main 
menu. The System menu includes tasks and applications that affect the entire system, like Personal 
Settings, Recent Files, and Search for Files. There is also the Run Program option, which lets you 
enter a command to start a program instead of navigating through the various program menus.

Figure 2-2   Novell Linux Desktop Programs Menu

For information on editing the main menu, see “Modifying the Contents of the Programs Menu” on 
page 38.

2.3.6  Handling Floppy Disks, CDs, or DVDs
To access floppy disks, CDs, or DVDs, insert the medium into the appropriate drive. Double-click 
the drive in Computer to view the contents. Copy files to your personal home directory by dragging-
and-dropping.

WARNING: Do not simply remove floppy disks from the drive after using them. Floppy disks, 
CDs, and DVDs must always be unmounted from the system first. Close all File Manager sessions 
still accessing the medium, then right-click the icon for the medium and select Eject from the menu. 
Then safely remove the floppy disk or CD when the tray opens automatically.

Floppy disks can also be formatted by clicking Programs > System Tools > Format a Floppy. In the 
Floppy Formatter dialog, select the density of the floppy disk and the file system settings: Linux 
native (ext2), the file system for Linux, or DOS (FAT) to use the floppy with Windows systems.
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2.4  Managing Folders and Files with File 
Manager
The File Manager program included with NLD is Nautilus. Using File Manager, you can create and 
view folders and documents, run scripts, and create CDs of your data. In addition, File Manager 
provides support for Web and file viewing.

Figure 2-3   Nautilus File Manager

You can open File Manager in the following ways:

• Click Programs > Accessories > File Manager
• Click the Computer icon on the desktop
• Click the username Home icon on the desktop

File Manager runs in object-oriented or spatial mode by default, similar to the early Macintosh 
Finder*. When you click a folder in spatial mode, a window for that folder opens. If you click the 
folder again, the opened folder is brought into focus. This one-to-one relationship is closer to the 
way you work with objects around you, like desks, chairs, and tables. However, spatial mode might 
be awkward for those that are use to a file manager like Windows Explorer, which uses a browser 
mode. 
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Figure 2-4   Nautilus File Manager in Browser Mode

You can change to the browser mode by right-clicking the folder and then clicking Browse Folder. 
This gives you a familiar view with a location window that shows the current path and buttons for 
common functions. This applies to the current File Manager window.

You can change the preferences for files and folders in File Manager by clicking Edit > Preferences 
> Behavior, then selecting from the following options:

Table 2-3   File Manager Options

Option Description

Single Click to Activate Item Performs the default action for an item when you 
click the item. If this option is selected and you point 
to an item, the title of the item is underlined.

Double Click to Activate Items Performs the default action for an item when you 
double-click the item.

Run Executable Files When They Are Clicked Runs an executable file when you click the file. An 
executable file is a text file than can execute (that is, 
a shell script).

View Executable Files When They Are Clicked Displays the contents of an executable file when you 
click the file.

Ask Each Time Displays a dialog when you click an executable file. 
The dialog asks whether you want to execute the file 
or display the file.

Ask Before Emptying Trash or Deleting Files Displays a confirmation message before the Trash is 
emptied or before files are deleted.

Include a Delete Command That Bypasses Trash Adds a Delete menu item to the Edit menu and the 
pop-up menu that is displayed when you right-click a 
file, folder, or desktop object. When you select an 
item and then click Delete, the item is immediately 
deleted from your file system.
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Some simple shortcuts for navigating include the following: 

Table 2-4   File Manager Navigation Shortcuts

For more information, click Help > Contents on the File Manager menu bar.

2.5  Accessing Files across Multiple 
Workstations
Working in multiple locations has traditionally meant that you had to conscientiously manage file 
versions, secure data transfer, and periodically back up data for multiple workstations. With Novell 
iFolder®, you always have convenient and secure access to the most recent version of your 
documents because iFolder transparently updates your files between the iFolder server and any 
workstations where you log in to iFolder.

To log in to iFolder, click Programs > Accessories > Novell iFolder. You must have an iFolder 
account set up in order to use iFolder. If you do not have an account, contact your system 
administrator.

For more information, see the Novell iFolder 2.1 User Guide (http://www.novell.com/
documentation/ifolder21/enduser/data/a2iii88.html).

2.6  Opening or Creating Documents with 
OpenOffice.org
For creating and editing documents, NLD includes OpenOffice.org, a complete set of office tools 
that can both read and save Microsoft Office file formats. OpenOffice.org has a word processor, a 
spreadsheet, a drawing tool, and a presentation program. To get started, select one of the tools from 
the Programs > Office menu, or click the quick start icon (Description: OpenOffice.org Writer 
icon ) in the top panel to start OpenOffice.org Writer.

A number of sample documents and templates are included with OpenOffice.org. You can access the 
templates by clicking File > New > Templates and Documents. In addition, you can use AutoPilot, a 
feature which guides you through the creation of letters and other typical documents.

Shortcut Description

Backspace or Alt+Up-arrow Opens the parent folder.

Up or Down Selects an item.

Alt+Down, or Enter Opens an item.

Shift+Alt+Down Opens an item and closes the current folder.

Shift+Alt+Up Opens the parent folder and closes the current folder.

Shift+Ctrl+W Closes all parent folders.

Ctrl+L Opens a location by specifying a path or URL.

Alt+Home Opens your home directory.
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For a more in-depth introduction to OpenOffice.org, see Chapter 4, “The OpenOffice.org Office 
Suite,” on page 65 or view the help in any OpenOffice.org program.

2.7  Finding Files on Your Computer
Using Search for File on the System menu, you can locate files on your computer using any number 
of search criteria.

Figure 2-5   Search for Files Dialog

Search for Files uses the find, grep, and locate UNIX commands, and all searches are case 
insensitive.

You can also open the Search for Files dialog by entering the following command in a terminal 
window:

gnome-search-tool

2.7.1  Performing a Basic Search
1 Click System > Search for Files.

2 Type the search text in the Name Contains field. 
The search text can be a filename or partial filename, with or without wildcards, as shown in 
the following table:

3 In the Look in Folder field, type the path to the directory where you want Search for Files to 
begin the search.

4 Click Find.

Search Text Example Result

Full or partial filename myfile.txt Searches for all files that contain “myfile.txt” 
in the filename.

Partial filename combined with 
wildcards (* [ ])

*.[ch] Searches for all files that have a .c or .h 
extension.
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Search for Files searches in the directory that you specify (and any subdirectories of the directory) 
and displays the results of the search in the Search Results list. If Search for Files does not find any 
files that match the search criteria, the application displays the message No files found in the 
Search results list.

2.7.2  Adding Search Options
Use Show More Options to search by file content, dates, owner, or file size.

1 Click System > Search for Files.

2 Type the search text in the Name Contains field. 

3 In the Look in Folder field, type the path to the directory where you want Search for Files to 
begin the search.

4 Click Show More Options, then click Available Options

5 Select a search option that you want to apply, then click Add.

The following options are available:

Option Description

Contains the Text Searches for a file by filename. Type a full filename or a 
partial filename with wildcards in the field provided. Use an 
asterisk (*) to indicate a sequence of characters. Use a 
question mark (?) to indicate a single character. The search 
is case sensitive.

Date Modified Less Than Searches for files that were modified within the period 
specified (in days).

Date Modified More Than Searches for files that were modified before the period 
specified (in days).

Size At Least Searches for files that are equal to or larger than the size 
specified (in kilobytes).

Size At Most Searches for files that are smaller than or equal to the size 
specified (in kilobytes).

File is Empty Searches for empty files.

Owned By User Searches for files that are owned by the user specified. Type 
the name of the user in the text box provided.

Owned By Group Searches for files that are owned by the group specified. 
Type the name of the group in the text box provided.

Owner is Unrecognized Searches for files that are owned by a user or group that is 
unknown to the system.

Name Does Not Contain Searches for filenames that do not contain the string that you 
enter. Enter a full filename or a partial filename with 
wildcards in the field provided. Use an asterisk (*) to indicate 
a sequence of characters. Use a question mark (?) to 
indicate a single character. The search is case sensitive.
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6 Specify the required search information for the search option.

7 Repeat Step 5 on page 31 and Step 6 on page 32 for each search option you want to apply.

To remove a search option from the current search, click the Remove button next to the option.

8 Click Find.

2.7.3  Using the Search Results List
You can use the Search Results list to open or delete a file found during a search, or you can save the 
search results to a file.

Figure 2-6   Search Results List

To open a file displayed in the Search Results list, right-click the file and then click Open or double-
click the file. To open the folder that contains a file displayed in the Search Results list, right-click 
the file and then click Open Folder.

To delete a file displayed in the Search Results list, right-click the file and then click Move to Trash.

To save the results of the last search that Search for Files performed, right-click anywhere in the 
Search results list and then click Save Results As. Type a name for the file the results are saved to, 
then click Save.

Name Matches Regular 
Expression

Searches for files that contain the specified regular 
expression in their directory path or filename. Type the 
regular expression in the text box provided.

Regular expressions are special text strings used to describe 
a search pattern. For more information, see Regular-
Expressions.info (http://www.regular-expressions.info).

Show Hidden and Backup Files Includes hidden and backup files in the search.

Follow Symbolic Links Follows symbolic links when searching for files.

Include Other Filesystems Searches in directories that are not in the same file system 
as the start directory.

Option Description
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2.7.4  Disabling Quick Searches
By default, Search for Files tries to speed up some searches by using the locate command. 
locate provides a secure way to index and quickly search for files. Because locate relies on a 
file index, the Search Results list might not be up to date. To disable quick searches, run the 
following command in a terminal window:

# gconftool-2 --type=bool --set /apps/gnome-search-tool/
disable_quick_search 1

2.8  Exploring the Internet
NLD includes Firefox, a Mozilla* based Web browser. You can start it by clicking Programs > 

Firefox Web Browser, or clicking the quick start icon (Description: Firefox Quick Start icon ) in 
the top panel.

You can type an address into the location bar at the top or click links in a page to move to different 
pages, just like in any other Web browser.

For more information, see Chapter 5, “Browsing the Internet,” on page 77.

2.9  E-mail and Calendering
Novell Evolution seamlessly combines e-mail, a calendar, an address book, and a task list in one 
easy-to-use application. With its extensive support for communications and data interchange 
standards, Evolution can work with existing corporate networks and applications, including 
Microsoft Exchange.

To start Evolution, click Programs > Novell Evolution or click the quick start icon (Description: 
Evolution Quick Start icon ) in the top panel.

The first time you start it, Evolution prompts you with a few questions as it sets up a mail account 
and helps you import mail from your old mail client. Then it shows you how many new messages 
you have and lists upcoming appointments and tasks, as well as the current weather and news from 
news feeds. The calendar, address book, and mail tools are available in the shortcut bar on the left.

For more information, see Chapter 6, “Using Collaboration Software,” on page 89.

2.10  Moving Text between Applications
To copy text between applications, select the text and then move the mouse cursor to the position 
where you want the text copied. Click the center button on the mouse or the scroll wheel to copy the 
text.

When copying information between programs, you must keep the source program open and paste 
the text before closing it. When a program closes, any content from that application that is on the 
clipboard is lost. 

2.11  Other Useful Programs
In addition to the programs already discussed, like applets you can add to a panel, NLD also 
includes additional programs that can help you complete your work (listed in the following table). 
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When you mouse over an application in the menu, a brief overview of the program is displayed. For 
more information about a program, see the program's Help.

Table 2-5   Additional NLD Programs

2.12  Obtaining Software Updates
Novell offers important updates and enhancements that help protect your computer and ensure that it 
runs smoothly through Red Carpet®. The Software Update feature is designed to help you manage 
the software you have on your computer and to install, update, and remove programs without your 
having to track dependencies and resolve conflicts. Contact your system administrator for more 
information about how your company is disseminating updates.

To access the update tool, click Programs > System Tools > Software Update.

For more information on Red Carpet, see the Novell Red Carpet Administration Guide (http://
www.novell.com/documentation/ximian/redcarpet.pdf).

Program Grouping Program Description

Accessories Calculator Performs simple and advanced calculations.

Dictionary Looks up words online.

File Manager Displays and accesses documents and folders 
on your system.

Find Files Finds documents and folders on your computer.

Text Editor Creates and edits simple text files.

Graphics Diagram Editor Creates and edits simple diagrams and 
flowcharts.

GIMP Image Editor Creates, edits, and composes graphics.

Thumbnail Image Browser Displays and organizes your images.

Internet Citrix ICA Client Establishes a session with a Citrix server.

Instant Messenger Sends instant messages using Gaim.

IRC Client Collaborates with others on an Internet Relay 
Chat network.

NetWork Selector Selects a different network device on your 
computer.

Video Conferencing Communicates with others using audio/video-
conferencing.

System Tools Archive Files Creates, displays, modifies, or unpacks .tar, .zip, 
and .tgz files.
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Customizing Your Settings 3

You can change the way Novell® Linux Desktop (NLD) looks and behaves to suit your own 
personal tastes and needs. Some of the settings you might want to change include the desktop 
background, screen saver, keyboard and mouse configuration, sounds, and file associations. Start by 
clicking System > Personal Settings, and then select the desktop settings you want to modify. The 
Settings dialog is divided into the following four categories:

• Personal Settings (page 35)
• Appearance (page 41)
• Hardware (page 47)
• System (page 54)

Figure 3-1   Settings Dialog

To edit administrator settings (System > Administrator Settings), you use the YaST Control Center. 
The administrator settings includes most of the hardware, the graphical user interface, Internet 
access, security settings, user administration, software installation, and system updates and 
information. You need the root password to access the YaST Control Center.

For information on configuring administrator settings, see Using YaST to Configure the Novell 
Linux Desktop (http://www.novell.com/documentation/nld/nld_deployment/data/bsj9luh.html) in 
the Novell Linux Desktop Deployment Guide.

3.1  Personal Settings
Personal settings include the following:

• Accessibility 
• Assistive Technology Support 
Customizing Your Settings 35
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• Menu 
• Shortcuts 

3.1.1  Configuring Accessibility Settings
Click System > Personal Settings > Accessibility. 

The settings of this module facilitate the use of the keyboard for users with motion impairments. The 
module consists of the three tabs: Basic, Filters, and Mouse Keys. Before modifying settings, 
activate Enable Keyboard Accessibility Features. 

Figure 3-2   Keyboard Accessibility Preferences Dialog

Features (Basic Tab)

The keyboard accessibility functions can be deactivated automatically after a certain time. Set an 
appropriate time limit (measured in seconds) with the slider. The system can additionally provide 
audible feedback when the keyboard accessibility functions are activated and deactivated. 

Enable Sticky Keys (Basic Tab)

Some keyboard shortcuts require that one key (a modifier key) is kept pressed constantly (this 
applies to Alt, Ctrl, and Shift) while the rest of the shortcut is typed. When sticky keys are used, the 
system regards those keys as staying pressed after being pressed once. For an audible feedback 
generated each time a modifier key is pressed, activate Beep when the modifier is pressed. If Disable 
If Two Keys Pressed Together is selected, the keys do not “stick” anymore when two keys are 
pressed simultaneously. The system then assumes that the keyboard shortcut has been completely 
entered. 
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Enable Repeat Keys (Basic Tab)

Activate Repeat Keys to make settings with sliders for Delay and Speed. This determines how long a 
key must be pressed for the automatic keyboard repeat function to be activated and at what speed the 
characters are then typed. 

Test the effect of the settings in the field at the bottom of the dialog. Select parameters that reflect 
your normal typing habits. 

Enable Slow Keys (Filters Tab)

To prevent accidental typing, set a minimum time limit that a key must be pressed and held before it 
is recognized as valid input by the system. Also determine whether audible feedback should be 
provided for keypress events, accepted keypresses, and the rejection of a keypress. 

Enable Bounce Keys (Filters Tab)

To prevent double typing, set a minimum time limit for accepting two subsequent keypress events of 
the same key as the input of two individual characters. If desired, activate audible feedback upon 
rejection of a keypress event. 

Toggle Keys (Filters Tab)

You can request audible feedback from the system when a keycap modifier key is pressed. 

Mouse Keys Tab

Activates the keyboard mouse; the mouse pointer is controlled with the arrow keys of the number 
pad. Use the sliders to set the maximum speed of the mouse pointer, the acceleration time until the 
maximum speed is reached, and the latency between the pressing of a key and the cursor movement. 

3.1.2  Configuring Assistive Technology Support
Click System > Personal Settings > Assistive Technology Support. 

NLD includes assistive technologies for users with special needs. These technologies include a 
screenreader, magnifier, and on-screen keyboard. To enable the technologies, first select Enable 
Assistive Technologies and then select the technologies you want.
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Figure 3-3   Assistive Technology Preferences Dialog

The gok package must be installed in order to get on-screen keyboard support, and the gnopernicus 
and gnome-mag packages must be installed in order to get screenreading and magnifying 
capabilities.

To install these packages: 

1 Click System > Administrator Settings.

2 Type the root password, then click OK.

3 Click Software > Install and Remove Software.

4 Select Selection from the Filter drop-down menu, then select Accessibility from the Selection 
list.

5 Select gok, gnopernicus, and gnome-mag from the Package list

6 Click Accept.

7 Insert Novell Linux Desktop 9 CD 2, then click OK.

8 Click Cancel > Close after the package installation is complete.

3.1.3  Modifying the Contents of the Programs Menu
Click System > Personal Settings > Menus. 

Use this module to modify the contents of the Programs menu.
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Figure 3-4   Programs Menu Dialog

Adding a Menu
1 Click System > Personal Settings > Menus.

2 Access the location where you want to add the menu.

3 Click File > Create Folder.
An untitled folder is added to the menu. The name of the folder is selected.

4 Type a name for the folder, then press Enter.

The next time that you log out then log in again, the menu is in the assigned location. 

Adding a Launcher to a Menu

When you click a launcher, you initiate one of the following actions:

• Start a particular application.
• Execute a command.
• Open a folder in a File Manager window.
• Open a Web browser at a particular URL. A URL (the address of a particular location on the 

Web).
• Open special URIs. The GNOME Desktop contains special URIs that enable you to access 

particular functions from File Manager.

You can find launchers in the following places in the GNOME Desktop:

• Panels: Launchers are represented by icons.
• Menus: Launchers are represented by menu items, which usually have icons beside them.
• Desktop: Launchers are represented by icons.

To add a launcher to a menu:

1 Click System > Personal Settings > Menus.

2 Access the location where you want to add the launcher.
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3 Click File > Create Launcher.

4 Specify the properties of the launcher in the Create Launcher dialog. 

5 Click OK.

Editing a Menu Item
1 Click System > Personal Settings > Menus.

2 Right-click the item that you want to edit, then click Properties.
Click Edit Launcher if the item you are editing is a launcher.

3 Modify the properties of the menu item.

4 Click Close.

Deleting an Item from a Menu
1 Right-click the item that you want to delete.

2 Click Move to Trash.

3.1.4  Customizing Keyboard Shortcuts
Click System > Personal Settings > Shortcuts. 

A keyboard shortcut is a key or combination of keys that provides an alternative to standard ways of 
performing an action. Use the Keyboard Shortcuts tool to display the default keyboard shortcuts. 
You can customize the shortcuts to your preferences. 

Figure 3-5   Keyboard Shortcuts Dialog

To change the shortcut keys for an action, click the shortcut for the action and then press the keys 
you want to associate with the action. To disable the shortcut keys for an action, click the shortcut 
for the action and then press the Backspace key.
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3.2  Appearance
Appearance settings include the following:

• Desktop background 
• Fonts 
• Screen saver 
• Theme 
• Windows 

3.2.1  Changing the Desktop Background
Click System > Personal Settings > Desktop Background. 

The desktop background is the image or color that is applied to your desktop. You can customize the 
desktop background in the following ways:

• Select an image for the desktop background. The image is superimposed on the desktop 
background color. The desktop background color is visible if you select a transparent image or 
if the image does not cover the entire desktop.

• Select a color for the desktop background. You can select a solid color or create a gradient 
effect with two colors. A gradient effect is a visual effect where one color blends gradually into 
another color.

You can also change the appearance of your desktop background from within the Nautilus file 
manager. To use an image file as a background picture, drag it from the file manager and drop it into 
Desktop Wallpaper.

If you do not want any background picture, click No Wallpaper and select a desktop color instead. 

The following table lists the background preferences that you can modify:

Table 3-1   Background Preferences

Option Description

Desktop Wallpaper Displays an image of your choice on the desktop.

Style Determines what processing steps should be applied to the selected image to 
adapt it optimally to the current screen resolution. To specify how to display the 
image, select one of the following options from the Style drop-down list:

• Centered: Displays the image in the middle of the desktop.

• Fill Screen: Enlarges the image to cover the desktop and maintains the 
relative dimensions of the image.

• Scaled: Enlarges the image until the image meets the screen edges and 
maintains the relative dimensions of the image.

• Tiled: Enlarges the image until the image meets the screen edges and 
maintains the relative dimensions of the image.

Add Wallpaper Opens a dialog where you can select an image file to use as the background 
picture.
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3.2.2  Configuring Fonts
Click System > Personal Settings > Fonts. 

Use the Font Preferences dialog to select the fonts to use in your applications, windows, terminals, 
and desktop.

Figure 3-6   Font Preferences Dialog

Remove Removes a Desktop Wallpaper after you select it and then click Remove.

Desktop Colors Lets you specify a color scheme using the options in the Desktop Color drop-
down list and the color selector buttons. You can specify a color scheme using 
any of the following options:

• Solid Color specifies a single color for the desktop background.

To select a color, click Color. In the Pick a Color dialog, select a color and 
then click OK 

• Horizontal Gradient creates a gradient effect from the left screen edge to 
the right screen edge.

Click Left Color to display the Pick a Color dialog, then select the color 
that you want to appear at the left edge.

Click Right Color, then select the color that you want to appear at the 
right edge.

• Vertical Gradient creates a gradient effect from the top screen edge to 
the bottom screen edge.

Click Top Color to display the Pick a Color dialog, then select the color 
that you want to appear at the top edge.

Click Bottom Color, then select the color that you want to appear at the 
bottom edge.

Option Description
ll Linux Desktop 9 GNOME User Guide



    N
ovell C

onfidential
novdocx (E

N
U

)  4 A
ugust 2005
The upper part of the dialog shows the fonts selected for the application, desktop, window title, and 
terminal. Click one of the buttons to open a selection dialog where you can set the font family, style, 
and size.

To specify how to render fonts on your screen, select one of the following options:

• Monochrome: Renders fonts in black and white only. The edges of characters might appear 
jagged in some cases because the characters are not antialiased. Antialiasing is an effect that is 
applied to the edges of characters to make the characters look smoother.

• Best Shapes: Antialiases fonts where possible. Use this option for standard Cathode Ray Tube 
(CRT) monitors.

• Best Contrast: Adjusts fonts to give the sharpest possible contrast and antialiases fonts so that 
characters have smooth edges. This option might enhance the accessibility of the GNOME 
Desktop to users with visual impairments.

• Subpixel Smoothing (LCDs): Uses techniques that exploit the shape of individual Liquid 
Crystal Display (LCD) pixels to render fonts smoothly. Use this option for LCD or flat-screen 
displays.

Click Details to specify further details of how to render fonts on your screen:

• Resolution (Dots Per Inch): Use the spin box to specify the resolution to use when your 
screen renders fonts.

• Smoothing: Select one of the options to specify how to antialias fonts.
• Hinting: Select one of the options to specify how to apply hinting to improves the quality of 

fonts at small sizes and at low screen resolutions.
• Subpixel Order: Select one of the options to specify the subpixel color order for your fonts. 

Use this option for LCD or flat-screen displays.

Previewing a Font

You can use the File Manager to preview a font:

1 Open a File Manager window.
To open a file manager in browser mode, right-click a folder then click Browse Folder. See 
“Managing Folders and Files with File Manager” on page 27 for more information.

2 Enter the following URI in the location bar:
fonts:/// 

The fonts are displayed as icons in the view pane.

3 Double-click an icon to display a preview of the font.

Adding a TrueType Font

You can use the File Manager to add a TrueType font:

1 Open a File Manager window, then select the TrueType font you want to add.

2 Open another file browser window, then enter the following URI in the location bar:
fonts:/// 

The fonts are displayed as icons in the view pane.

3 Copy the TrueType font file that you want to add to the fonts:/// location.
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3.2.3  Configuring the Screen Saver
Click System > Personal Settings > Screensaver. 

The module for configuring the screen saver is subdivided into two tabbed pages: Display Modes 
and Advanced. Select the screen saver on the Display Modes page; the Advanced page contains a 
few special options that normally do not need to be modified. 

Figure 3-7   Screensaver Preferences Dialog

You can select from Random Screen Saver (random selection of screen savers from a custom-
defined list), Only One Screen Saver, Blank Screen Only, or Disable Screen Saver. 

Select one or more screen savers from the list for the either the Only One Screen Saver or Random 
Screen Saver operating mode. The currently selected screen saver is displayed in the small preview 
window. The Preview button launches a full screen preview of that screen saver, which can be closed 
by pressing any key. Select the previous or following screen saver for preview by clicking the 
corresponding triangles below the selection list. 

Finally, determine after how long the screen should be made completely blank (Blank After), the 
screen saver module should be changed (Cycle After), or the screen should be locked (Lock Screen 
After). All time references are in minutes. 

You can use the Advanced page to display a directory of graphics as your screen saver by selecting 
Choose Random Image and then selecting a directory containing images. 

3.2.4  Choosing a Theme
Click System > Personal Settings > Theme. 

A theme is a group of coordinated settings that specifies the visual appearance of a part of the 
desktop. You can choose themes to change the appearance of the desktop. Use the Theme 
Preferences tool to select from a list of preinstalled themes. The list of available themes includes 
several themes for users with accessibility requirements.
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A theme contains settings that affect different parts of the desktop, as follows: 

• Controls

The controls setting for a theme determines the visual appearance of windows, panels, and 
applets. It also determines the visual appearance of the GNOME-compliant interface items that 
appear on windows, panels, and applets, such as menus, icons, and buttons. Some of the 
controls setting options that are available are designed for special accessibility needs. You can 
select an option for the controls setting in the Controls tabbed page of the Theme Details tool.

• Window frame
The window frame setting for a theme determines the appearance of the frames around 
windows only. You can select an option for the window frame setting in the Window Border 
tabbed page of the Theme Details tool.

• Icon
The icon setting for a theme determines the appearance of the icons on panels and the desktop 
background. You can select an option for the icon setting in the Icons tabbed page of the Theme 
Details tool.

The color settings for the desktop and applications are controlled using themes. You can choose 
from a variety of preinstalled themes. Selecting a style from the list overview applies it 
automatically. Details opens another dialog where you can customize the style of single desktop 
elements, like window content, window borders, and icons. Making changes and leaving the dialog 
by clicking Close switches the theme to Custom Theme. Click Save Theme to save your modified 
theme under a custom name. The Internet and other sources provide many additional themes for 
GNOME as .tar.gz files. Install these with the Install theme. 

Creating a Custom Theme

The themes that are listed in the Theme Preferences tool are different combinations of controls 
options, window frame options, and icon options. You can create a custom theme that uses different 
combinations of options.

1 Click System > Personal Settings > Theme.

2 Select a theme from the list of themes, then click Theme Details.

3 Select the controls option that you want to use in the custom theme from the list in the Controls 
tabbed page.

4 Click the Window Border tab, then select the window frame option that you want to use in the 
custom theme.

5 Click the Icons tab, then select the icons option that you want to use in the custom theme.

6 Click Close > Save Theme.
A Save Theme to Disk dialog is displayed.

7 Type a name and a short description for the custom theme in the dialog, then click Save. 
The custom theme now appears in your list of available themes.

Installing a New Theme

You can add a theme to the list of available themes. The new theme must be an archive file that is 
tarred and zipped (a .tar.gz file).
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1 Click System > Personal Settings > Theme.

2 Click Install Theme.

3 Specify the location of the theme archive file in the Location field, then click OK.
You can also click Browse to browse for the file.

4 Click Install to install the new theme.

Installing a New Theme Option

You can install new controls options, window frame options, or icons options. You can find many 
controls options on the Internet.

1 Click System > Personal Settings > Theme.

2 Click Theme Details, then click the tab for the type of theme you want to install.
For example, to install an icons option, click the Icons tab.

3 Click Install Theme.

4 Specify the location of the theme archive file in the Location field, then click OK.

5 Click Install to install the new theme option.

Deleting a Theme Option

You can delete controls options, window frame options, or icons options.

1 Click System > Personal Settings > Theme.

2 Click Theme Details, then click the tab for the type of option you want to delete.

3 Click Go To Theme Folder.
A File Manager window opens on the default option folder.

4 Use the File Manager window to delete the option.

Previewing Themes

You can use the File Manager to preview and change themes.

1 Open a file manager window.
To open a File Manager in browser mode, right-click a folder and then click Browse Folder. 
See “Managing Folders and Files with File Manager” on page 27 for more information.

2 Enter the following URI in the location bar:
themes:/// 

The themes are displayed in the view pane.

3 Double-click a theme to change it.

3.2.5  Customizing Window Behavior
Click System > Personal Settings > Windows. 

Use the Window Preferences tool to customize window behavior for the desktop. You can determine 
how a window reacts to contact with the mouse pointer or to double-clicks on its titlebar, and you 
can define which key to hold for moving an application window. 
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Figure 3-8   Window Preferences Dialog

When several application windows populate the desktop, the active one by default is the one last 
clicked. Change this behavior by activating Select Windows When the Mouse Moves over Them. If 
desired, activate Raise Selected Window after an Interval and adjust the latency time with the slider. 
This raises a windows a short time after the window receives focus. 

Application windows can be shaded (rolled up) by double-clicking the title bar, leaving only the title 
bar visible. This saves space on the desktop and is the default behavior. It is also possible to set 
windows to maximize when the title bar is double-clicked. 

Using the radio buttons, select a modifier key to press for moving a window (Ctrl, Alt, Hyper, or the 
Windows logo key). 

3.3  Hardware
Hardware settings include the following:

• Keyboard 
• Mouse 
• Printers 
• Screen resolution 

3.3.1  Modifying Keyboard Preferences
Click System > Personal Settings > Keyboard. 

Use the Keyboard Preferences tool to modify the autorepeat preferences for your keyboard and to 
configure typing break settings.

You can set the preferences in the following areas:

• Keyboard
• Typing Break
• Layouts
• Layout Options
Customizing Your Settings 47



48

    N
ovell C

onfidential
novdocx (E

N
U

)  4 A
ugust 2005

 () () ()Nove
Configuring Keyboard Preferences

Use the Keyboard tabbed page to set general keyboard preferences.

Figure 3-9   Keyboard Preferences Dialog—Keyboard Page

You can modify any of the following keyboard preferences:

Table 3-2   Keyboard Preferences

Click the Accessibility button to start the Keyboard accessibility preference tool. 

Configuring Typing Break Preferences

Use the Typing Break tabbed page to set typing break preferences.

Option Description

Key Presses Repeat When Key is 
Held Down

Enables keyboard repeat. The action associated with a key is 
performed repeatedly when you press and hold that key. For 
example, if you press and hold a character key, the character is 
typed repeatedly.

Use the Delay option to select the delay from the time you press a 
key to the time that the action repeats.

Use the Speed option to set the speed at which the action is 
repeated.

Cursor Blinks in Text Boxes and 
Fields

Lets the cursor blink in fields and text boxes.

Use the slider to specify the speed at which the cursor blinks.

Type to Test Settings The test area is an interactive interface that lets you see how the 
keyboard settings affect the display as you type. Type text in the 
test area to test the effect of your settings.
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Figure 3-10   Keyboard Preferences Dialog—Typing Break Page

You can modify any of the following typing break preferences:

Table 3-3   Typing Break Preferences

Click the Accessibility button to start the Keyboard accessibility preference tool. 

Configuring Keyboard Layout Preferences

Use the Layouts tabbed page to set your keyboard layout. 

Option Description

Lock Screen to Enforce Typing Break Locks the screen when you are due a typing break.

Work Interval Lasts Lets you specify how long you can work before a typing break 
occurs.

Break Interval Lasts Lets you specify the length of your typing breaks.

Allow Postponing of Breaks Lets you postpone typing breaks.
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Figure 3-11   Keyboard Preferences Dialog—Layouts Page

Select your keyboard model from the drop-down list, then use the navigational buttons to add or 
remove the selected layout to or from the list of available layouts.

You can select different layouts to suit different locales. For more information on keyboard layouts, 
see the Keyboard Layout Switcher manual (http://www.gnome.org/~shaunm/doctable/docs/gkb/
HEAD/index.html).

Click the Accessibility button to start the Keyboard accessibility preference tool. 

Configuring Keyboard Layout Options

Use the Layout Options tabbed page to set your keyboard layout options. 

Figure 3-12   Keyboard Preferences Dialog—Layout Options Page

Select an option from the list of available layout options and click Add to add the option or Remove 
to remove it.

For more information on keyboard layouts, see the Keyboard Layout Switcher manual (http://
www.gnome.org/~shaunm/doctable/docs/gkb/HEAD/index.html).
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Click the Accessibility button to start the Keyboard accessibility preference tool. 

3.3.2  Configuring the Mouse
Click System > Personal Settings > Mouse. 

Use the Mouse Preference tool to configure your mouse for right-hand use or for left-hand use. You 
can also specify the speed and sensitivity of mouse movement.

You can customize the settings for the Mouse Preference tool in the following areas:

• Buttons
• Cursors
• Motion

Configuring Button Preferences

Use the Buttons tabbed page to specify whether the mouse buttons are configured for left-hand use. 
You can also specify the delay between clicks for a double-click.

Figure 3-13   Mouse Preferences Dialog—Buttons Page

The following table lists the mouse button preferences you can modify.

Table 3-4   Mouse Button Preferences

Option Description

Left-handed Mouse Configures your mouse for left-hand use, swapping the functions of the left 
mouse button.

Timeout Use the slider to specify the amount of time that can pass between clicks 
when you double-click. If the interval between the first and second clicks 
exceeds the time that is specified here, the action is not interpreted as a 
double-click.
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Configuring Cursor Preferences

Use the Cursors tabbed page to set your mouse pointer preferences.

Figure 3-14   Mouse Preferences Dialog—Cursors Page

The following table lists the mouse pointer preferences you can modify. 

Table 3-5   Mouse Pointer Preferences

Configuring Motion Preferences

Use the Motion tabbed page to set your preferences for mouse movement.

Option Description

Cursor Size Displays a small, medium, or large mouse pointer. 
Changes are not activated until the next time you log in.

Highlight the Pointer When You Press Ctrl Enables a mouse pointer animation when you press and 
release Ctrl. This feature can help you locate the mouse 
pointer.
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Figure 3-15   Mouse Preferences Dialog—Motion Page

The following table lists the mouse motion preferences you can modify.

Table 3-6   Mouse Motion Preferences

3.3.3  Installing and Configuring Printers
Click System > Personal Settings > Printers. 

Use this module to install and configure printers.

Figure 3-16   Printers Dialog

Option Description

Acceleration Use the slider to specify the speed at which your mouse pointer moves on your 
screen when you move your mouse.

Sensitivity Use the slider to specify how sensitive your mouse pointer is to movements of 
your mouse.

Threshold Use the slider to specify the distance that you must move an item before the move 
action is interpreted as a drag and drop action.
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For more information about setting up printing, see Chapter 9, “Managing Printers,” on page 105.

3.3.4  Specifying Screen Resolution Settings
Click System > Personal Settings > Screen Resolution. 

Use this module to specify the resolution settings for your screen, including Resolution and Refresh 
Rate.

Figure 3-17   Screen Resolution Preferences Dialog

The following table lists the screen resolution preferences you can modify.

Table 3-7   Screen Resolution Preferences

If you cannot find a setting you want, you might need to use the Administrator Settings to 
reconfigure your graphics card and monitor settings. See Configuring the Graphics Card and 
Monitor (http://www.novell.com/documentation/nld/nld_deployment/data/
bsj9mwg.html#bsmqn45) in the Novell Linux Desktop Deployment Guide for more information.

3.4  System
System settings include the following:

• Change Password
• File associations 
• Network proxies 
• Sessions 
• Sound 

Option Description

Resolution Select the resolution (in pixels) to use for the screen.

Refresh Rate Select the refresh rate to use for the screen.

Make Default for This Computer Only Makes the screen resolution settings the default settings 
only for the computer that you are logged in to.
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3.4.1  Changing Your Password
Click System > Personal Settings > Change Password 

Use this module to change your password. This module is included with NLD 9 SP2 or later.

Figure 3-18   Change Password Dialog

Specify your current password, specify your new password twice, then click OK.

3.4.2  Specifying File Associations
Click System > Personal Settings > File Associations. 

Use the File Types and Programs tool to specify how files of various types are displayed and edited, 
and to associate an application with a service so that the application performs the task required by 
the service.

Figure 3-19   File Types and Programs Dialog

Use the File Types and Programs tool to configure the following:

• File Types
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You can specify how files of various types are displayed and edited. For example, you can 
specify an icon to represent a particular type of file, or you can specify that if a file is a plain 
text file, the file is launched in a text editor. 

The file manager and other applications check the contents of a file to determine the type of a 
file. If the first lines do not determine the type of the file, then the application checks the 
filename.

• Services
A Uniform Resource Identifier (URI) is a string that identifies a particular location in a file 
system or on the Web. For example, the Web address of a Web page is a URI. A service is a 
protocol or task that a URI requests. For example, the http://www.gnome.org URI requests the 
HTTP service.
You can associate an application with a service so that the application performs the task 
required by the service. For example, you can associate your preferred Web browser with the 
HTTP service.

To view the contents of a category of file types, click the Right-arrow next to the category name. 
The category expands and displays a description of each file type and the file extension that is 
associated with the file type.

To select a file type that you want to work with, click the file type. 

Adding a File Type
1 Click System > Personal Settings > File Associations.

2 Click Add File Type, then specify the properties of the new file type.
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Description: Add File Type dialog

The following table describes the options available in the Add File Type dialog.

Option Description

No Icon The icon that represents the file type. Select an icon in the selector 
dialog or select an icon from another directory by clicking Browse. 
Then click OK.

Description A description of the file type. 

MIME Type The MIME type for this type of file, which identifies the format of the 
file and enables applications to read it. For example, an e-mail 
application can use the image/png MIME type to detect that a 
Portable Networks Graphic (PNG) file is attached to an e-mail 
message.

Category The category the file type belongs to in this preference tool. Click 
Choose to select a category in the Choose a File category dialog.

Filename Extensions The file extensions associated with the file type. Type a file 
extension in the field on the left side, then press Enter. 

To delete a file extension, select the file extension in the field on the 
right side and then click Remove.

Viewer Component The viewer component used to display files of this type in the File 
Manager.

Default Action The default application used to open files of this type.
Customizing Your Settings 57



58

    N
ovell C

onfidential
novdocx (E

N
U

)  4 A
ugust 2005

 () () ()Nove
3 Click OK.

Adding a Service
1 Click System > Personal Settings > File Associations.

2 Click Add Service, then specify the properties of the new service.

Description: Add Service dialog

The following table describes the options available in the Add Service dialog:

3 Click OK.

Program to Run The command used to start the program associated with the file 
type.To choose a command that you entered previously, click the 
Down-arrow and then select the command to run.

You can also use the Browse find and select a command to run. 

Run in Terminal Runs the program in a terminal window. Select this option for a 
program that does not create a window to run in.

Option Description

Description A description of the service.

Protocol The protocol for the service.

Program to Run This option is not available in this release.

Program The command used to start the program associated with the service. To 
choose a command that you entered previously, click the Down-arrow 
and then select the command to run.

You can also use the Browse button to find and select a command to run. 

Run in Terminal Runs the program in a terminal window. Select this option for a program 
that does not create a window to run in.

Option Description
ll Linux Desktop 9 GNOME User Guide



    N
ovell C

onfidential
novdocx (E

N
U

)  4 A
ugust 2005
3.4.3  Configuring Network Proxies
Click System > Personal Settings > Network Proxies. 

The Network Proxy Configuration tool lets you configure how your system connects to the Internet. 
You can configure the desktop to connect to a proxy server and specify the details of the server. A 
proxy server is a server that intercepts requests to another server and fulfills the request itself, if it 
can. You can specify the Domain Name Service (DNS) name or the Internet Protocol (IP) address of 
the proxy server. A DNS name is a unique alphabetic identifier for a computer on a network. An IP 
address is a unique numeric identifier for a computer on a network.

Figure 3-20   Network Proxy Configuration Dialog

The following table lists the Internet connection options that you can modify.

Table 3-8   Internet Connection Options

Option Description

Direct Internet connection Connects directly to the Internet, without a proxy server.

Manual proxy configuration Connects to the Internet through a proxy server and lets you 
configure the proxy server manually.

HTTP proxy The DNS name or IP address of the proxy server to use when 
you request a HTTP service. Specify the port number of the 
HTTP service on the proxy server in the Port box.

Secure HTTP proxy The DNS name or IP address of the proxy server to use when 
you request a Secure HTTP service. Specify the port number 
of the Secure HTTP service on the proxy server in the Port 
box.

FTP proxy The DNS name or IP address of the proxy server to use when 
you request an FTP service. Specify the port number of the 
FTP service on the proxy server in the Port box.

Socks host The DNS name or IP address of the Socks host to use. Specify 
the port number for the Socks protocol on the proxy server in 
the Port spin box.
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3.4.4  Managing Sessions
Click System > Personal Settings > Sessions. 

This module lets you manage your sessions. A session occurs between the time that you log in to the 
desktop environment and the time that you log out. You can set session preferences and specify 
which applications to start when you begin a session. You can configure sessions to save the state of 
applications and then restore the state when you start another session.

You can also use this preference tool to manage multiple sessions. For example, you might have a 
mobile session which starts applications you use most frequently when traveling, a demo session 
that starts applications used to present a demonstration or slide show to a customer, and a work 
session that uses a different set of applications when you are working in the office.

This module consists of three tabbed pages:

• Session Options: Lets you manage multiple sessions and set preferences for the current 
session. 

• Current Session: Lets you specify startup order values and select restart styles for the session-
managed applications in your current session.

• Startup Programs: Lets you specify non-session-managed startup applications, which start 
automatically when you start a session.

Setting Session Preferences

Use the Session Options tabbed page to manage multiple sessions and set preferences for the current 
session.

Figure 3-21   Sessions Dialog—Session Options Page

The following table lists the session options that you can modify. 

Automatic proxy configuration Connects to the Internet through a proxy server and lets you 
configure the proxy server automatically.

Autoconfiguration URL The URL that contains the information required to configure the 
proxy server automatically.

Option Description
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Table 3-9   Session Preferences for Current Session

Setting Session Properties

Use the Current Session tabbed page to specify startup order values and to choose restart styles for 
the session-managed applications in your current session.

Figure 3-22   Sessions Dialog—Current Session Page

The following table lists the session properties that you can configure.

Option Description

Show Splash Screen on Login Displays a splash screen when you start a session.

Prompt on Logout Displays a confirmation dialog when you end a session.

Automatically Save Changes to Session Automatically saves the current state of your session. The 
session manager saves the session-managed applications 
that are open and the settings associated with the session-
managed applications. The next time you start a session, 
the applications start automatically with the saved settings.

If you do not select this option, the Logout Confirmation 
dialog displays a Save Current Setup option when you end 
your session. 

Sessions Lets you manage multiple sessions in the desktop, as 
follows:

• To create a new session, click Add. The Add a New 
Session dialog is displayed, letting you specify a 
name for your session.

• To change the name of a session, select the session 
and then click Edit. The Edit Session Name dialog is 
displayed, letting you specify a new name for your 
session.

• To delete a session, select the session and then click 
Delete.
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Table 3-10   Session Properties for Session-Managed Applications

Configuring Startup Applications

Use the Startup Programs tabbed page to specify non-session-managed startup applications.

Figure 3-23   Sessions Dialog—Startup Programs Page

Startup applications are applications that start automatically when you begin a session. You specify 
the commands that run these applications and the commands execute automatically when you log in.

You can also start session-managed applications automatically. For more information, see “Setting 
Session Preferences” on page 60.

Option Description

Order Specifies the order in which the session manager starts session-managed startup 
applications. The session manager starts applications with lower order values first. The 
default value is 50.

To set the startup order of an application, select the application in the table. Use the Order 
box to specify the startup order value. 

Style Determines the restart style of an application. To select a restart style for an application, 
select the application in the table and then select one of the following styles:

• Normal: Starts automatically when you start a session. Use the kill command to 
terminate applications with this restart style during a session.

• Restart: Restarts automatically when you close or terminate the application. Select 
this style for an application if it must run continuously during your session. To 
terminate an application with this restart style, select the application in the table and 
then click Remove.

• Trash: Does not start when you start a session.

• Settings: Starts automatically when you start a session. Applications with this style 
usually have a low startup order and store your configuration settings for GNOME 
and session-managed applications.

Remove Deletes the selected application from the list. The application is removed from the session 
manager and closed. Applications that you delete are not started the next time you start a 
session. 

Apply Applies changes made to the startup order and the restart style.
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To add a startup application, click Add. The Add Startup Program dialog is displayed. Specify the 
command to start the application in the Startup Command field. If you specify more than one startup 
application, use the Order box to specify the startup order of the each application.

To edit a startup application, select the startup application and then click Edit. The Edit Startup 
Program dialog is displayed. Modify the command and the startup order for the startup application.

To delete a startup application, select the startup application and then click Delete. 

3.4.5  Setting Sound Preferences
Click System > Personal Settings > Sound. 

The Sound Preference tool lets you control when the sound server starts. You can also specify which 
sounds to play when particular events occur.

Setting General Sound Preferences

Use the General tabbed page to specify when to launch the sound server. You can also enable sound 
event functions.

Figure 3-24   Sound Preferences Dialog—General Page

Click Enable sound server startup to start the sound server when you start a session. When the 
sound server is active, the desktop can play sounds.

Click Sounds for events to play sounds when particular events occur in the desktop. You can select 
this option only if the Enable sound server startup option is selected. 

Setting Sound Event Preferences

Use the Sound Events tabbed page to associate particular sounds with particular events.

IMPORTANT: You must enable the Enable Sound Server Startup and Sounds For Events options 
on the General tab before you can access the Sound Events page.
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Figure 3-25   Sound Preferences Dialog—Sound Events Page

The Event column displays a hierarchical list of events that can occur. To expand a category of 
events, click the Right-arrow beside a category of events. The Sound File column lists the sound file 
that plays when the event occurs. You can test a sound by first selecting the corresponding notice in 
the Event column, then clicking Play

To associate a sound with an event, select the event in the Sounds table. Specify the name of the 
sound file that you want to associate with the selected event in the Sound File field, or click Browse 
to display the Select Sound File dialog which provides a list of files to choose from. You can only 
associate sound files in .wav format with events.

Setting System Bell Preferences

Some applications play a bell sound to indicate a keyboard input error. Use the System Bell tabbed 
page to set preferences for the system bell. 

Figure 3-26   Sound Preferences Dialog—System Bell Page

The following table lists the system bell preferences that you can modify.
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Table 3-11   System Bell Preferences

Option Description

Sound an Audible Bell Enables the system bell.

Visual Feedback Enables visual feedback to indicate input errors.

Flash Window Titlebar Causes window titlebars to flash to indicate an input error.

Flash Entire Screen Causes the entire screen to flash to indicate an input error.
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The OpenOffice.org Office Suite 4

OpenOffice.org is a powerful Linux office suite that offers tools for all types of office tasks, such as 
writing texts, working with spreadsheets, and creating graphics and presentations. With 
OpenOffice.org, you can use the same data across different computing platforms. You can also open 
and edit files in Microsoft Office formats and then save them back to the same format, if needed.

OpenOffice.org comprises the following application modules that are designed to interact with each 
other.

• Writer: Powerful word processor application.
• Calc: Spreadsheet application that includes a chart utility.
• Draw: Drawing application for creating vector graphics.
• Impress: Application for creating presentations.

This chapter covers only the following basic skills needed to get started with OpenOffice.org. For 
more detailed information, see the OpenOffice.org 1.x.x User Guide (http://
documentation.openoffice.org/manuals/OOo1.x.x/user_guide.pdf).

• “Accessing OpenOffice.org” on page 65
• “Compatibility with Other Applications” on page 66
• “Getting Help” on page 66
• “Changing the Global Settings” on page 67
• “Word Processing with Writer” on page 68
• “Using Spreadsheets with Calc” on page 72
• “Creating Presentations with OpenOffice.org Impress” on page 73
• “Creating Graphics Using Draw” on page 74

4.1  Accessing OpenOffice.org
1 Click Programs > Office.

2 Select from the following options:

You can also start OpenOffice.org by typing ooffice in a terminal window, or by clicking 

Description: Word Processor icon  on the menu bar. If any OpenOffice.org application is open, 
you can open any of the other applications by clicking File > New > Name of Application.

Click To Open

Word Processor Writer

Presentation Impress

Spreadsheet Calc

Drawing Draw
The OpenOffice.org Office Suite 65

http://documentation.openoffice.org/manuals/OOo1.x.x/user_guide.pdf
http://documentation.openoffice.org/manuals/OOo1.x.x/user_guide.pdf
http://documentation.openoffice.org/manuals/OOo1.x.x/user_guide.pdf


66

    N
ovell C

onfidential
novdocx (E

N
U

)  4 A
ugust 2005

 () () ()Nove
4.2  Compatibility with Other Applications
OpenOffice.org works with Microsoft Office documents, spreadsheets, presentations, and databases. 
These files can be seamlessly opened like other files and saved back to the same format. Because the 
Microsoft formats are closed and the specifics are not available to other applications, there are 
occasionally formatting issues. If you have problems with your documents, open them in the 
original application and resave them in an open format, such as RTF for text documents or CSV for 
spreadsheets.

4.2.1  Converting Documents
To convert a number of documents, such as when first switching to OpenOffice.org:

1 Click File > AutoPilot > Document Converter.

2 Select the file format you want to convert.
There are several StarOffice and Microsoft Office formats available.

3 Click Next, then specify where OpenOffice.org should look for templates and documents to 
convert and in which directory the converted files should be placed. 

4 Click Next to see a summary of the actions that will be performed. 

5 Click Convert.

4.2.2  Sharing Documents
When sharing documents with others, you have several options. If the recipient only needs to read 
the document, export it to PDF format by clicking File > Export as PDF. PDF files can be read on 
any platform using the Adobe* Acrobat* Reader. To share a document for editing, use one of the 
regular document formats. The default formats comply with the OASIS standard XML format, 
making them compatible with a number of applications. TXT and RTF formats, although limited in 
formatting, are a good option for text documents, and CSV is useful for spreadsheets. 
OpenOffice.org might also offer your recipient’s preferred format.

OpenOffice.org is available for a number of operating systems. This makes it an excellent tool when 
a group of users needs to share files and does not use the same file systems.

4.3  Getting Help
You can get help for OpenOffice.org at any time from the Help menu. Depending on your selection, 
the depth and type of help provided varies. To get thoroughly acquainted with a topic, click Help > 
Contents. The help system provides information about each of the modules of OpenOffice.org 
(Writer, Calc, Impress, and Draw). 

If you find this information too broad or overwhelming, try the Help Agent instead, which offers 
help and tips as you perform different actions with OpenOffice.org. Click Help > Help Agent to 
enable this. If less information would be sufficient, try Tips and Extended Tips. They enable the 
program’s tool tips—short information about the element that the mouse is pointing to. These items 
can easily be disabled later when you are more familiar with the program. 

TIP: If you are not sure whether the features are active, open the Help menu. A checked menu item 
indicates that the corresponding help function is currently active. 
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For more information and tutorials for an OpenOffice.org application, use one of the following 
sources:

• How To (http://documentation.openoffice.org/HOW_TO/index.html)
• User FAQ (http://documentation.openoffice.org/user_faq/index.html)
• OpenOffice.org 1.1 Impress QuickStart Guide (PDF) (http://documentation.openoffice.org/

quickstart/Impress_quickstart.pdf)
• OpenOffice Support Web site (http://support.openoffice.org/index.html)
• OpenOffice Tutorials (http://www.tutorialsforopenoffice.org)

4.4  Changing the Global Settings
Global settings can be changed in any OpenOffice.org application by clicking Tools > Options on 
the menu bar. This opens the window shown in the figure below. A tree structure is used to display 
categories of settings. 

Figure 4-1   The Options Window

The following table lists the setting categories along with a brief description of each category.

Table 4-1   Global Setting Categories

Setting Category Description

OpenOffice.org Covers the various basic settings, including your user data (like your 
address and e-mail), important paths, and settings for printers and 
external programs.

Load/Save Includes the settings related to the opening and saving of several file 
types. There is a dialog for general settings and several special dialogs to 
define how external formats should be handled.

Language Settings Covers the various settings related to languages and writing aids, namely 
your locale and spell checker settings. This is also the place to enable 
support for Asian languages.
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IMPORTANT: All settings as listed above are applied globally—they are used as defaults for every 
new document you create. 

4.5  Word Processing with Writer
There are two ways to create a new document: from scratch or using AutoPilot, which lets you use a 
standard format and predefined elements. This sections discusses the following tasks:

• “Creating Documents with AutoPilot” on page 68
• “Creating Documents without AutoPilot” on page 69
• “Selecting Text” on page 70
• “Navigating in Large Documents” on page 70
• “Formatting with Styles” on page 70

4.5.1  Creating Documents with AutoPilot
To use a standard format and predefined elements for your own documents, try AutoPilot. This is a 
small utility that lets you make some basic decisions and then produces a ready-made document 
from a template. For example, to create a business letter, click File > AutoPilot > Letter. 

Internet Includes the dialogs to configure any proxies and to change settings 
related to search engines.

Text Document Configures the global word processing options, such as the basic fonts 
and layout that Writer should use.

HTML Document Changes the settings related to the HTML authoring features of 
OpenOffice.org.

Spreadsheet Changes the settings for Calc, such as those related to sort lists and grids.

Presentation Changes the settings that should apply to all presentations. For example, 
you can specify the measurement unit for the grid used to arrange 
elements.

Drawing Includes the settings related to the vector drawing module, such as the 
drawing scale, grid properties, and some print options.

Formula Provides a single dialog to set some special print options for formulas.

Chart Defines the default colors used for newly created charts.

Data Sources Defines how external data sources should be accessed.

Setting Category Description
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Figure 4-2   OpenOffice.org AutoPilot

Click Next to proceed to each successive page. To modify any previous entries, click Back. Exit the 
AutoPilot by clicking Cancel. Access a help document with Help. 

When you are finished, click Create. OpenOffice.org produces a document according your 
specifications. Now you can compose the text (body) of the document itself. AutoPilot can assist in 
the creation of letters, faxes, agendas, memos, and presentations. 

4.5.2  Creating Documents without AutoPilot
Create a new text document by clicking File > New > Text Document. When editing a text 
document, a second toolbar called the object bar, is available just below the standard function bar. 
Move the mouse pointer over an icon to get a tooltip. Documents can also be formatted with the 
Stylist. See “Using the Stylist” on page 71 for more information.

Figure 4-3   OpenOffice.org Writer

Use the File menu or the relevant buttons on the toolbar to print and save your document. Use the 
options on the Insert menu to add extra items to your document, such as a table, picture, or chart.
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4.5.3  Selecting Text
To select text, click the desired beginning of the selection and, keeping the mouse button pressed, 
move the cursor toward the end of the range (which can be characters, lines, or entire paragraphs). 
Release the button when all desired text is selected. While selected, text is displayed in inverted 
colors. Open a context menu by right-clicking the selected text. Use the context menu to change the 
font, the font style, and other text properties.

Selected text can also be cut or copied to the clipboard, then pasted back into the document at 
another location. Use the Edit context menu or the relevant toolbar icons to access these functions.

4.5.4  Navigating in Large Documents
The Navigator tool displays information about the contents of a document. It also lets you quickly 
jump to different elements. For example, you can use Navigator to get a quick overview of all the 
chapters or to see a list of the images included in the document.

Figure 4-4   Navigator Tool in Writer

Open Navigator by clicking Edit > Navigator. The elements listed in Navigator vary according to 
the document loaded in Writer.

4.5.5  Formatting with Styles
Styles save you time by letting you make formatting changes once that apply to the entire document. 
They give you templates not only for paragraphs and individual characters, but also for pages, text 
frames, and lists. 

• “Using the Style Catalog” on page 70
• “Creating Your Own Styles” on page 71
• “Using the Stylist” on page 71

Using the Style Catalog

Click Format > Styles > Catalog to open the Style Catalog, which you can use to create, edit, and 
manage the formatting styles used by OpenOffice.org.
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Figure 4-5   OpenOffice.org Style Catalog

If you set the drop-down list at the bottom of this dialog box to Automatic, OpenOffice.org offers a 
selection of styles appropriate for the task at hand. If you select All Styles from the list, the Style 
Catalog displays all styles from the currently active category. In the previous figure, the category is 
Paragraph Styles. You can select a different category by clicking the drop-down list at the top 
of the dialog.

By formatting your text with this method, called soft formatting, text is not formatted directly. 
Instead, a style is applied to it. The style can be easily modified, automatically resulting in a 
formatting change for all the text that the style is assigned to.

To assign a style to a paragraph, click anywhere inside the paragraph, click Format > Styles > 
Catalog, and then double-click the style you want to apply.

Creating Your Own Styles
1 Format a paragraph or a character as desired using the Format menu or the toolbar. 

2 Select the formatted item whose style you want to copy.

3 Click Format > Styles > Catalog.

4 Click New, then type a name for your style.

5 Click OK.

This style can now be applied to other texts.

You can change the details of a style by selecting it in the Style Catalog and then clicking Modify. 
This opens a dialog in which all the possible formatting properties are available for modification.

Using the Stylist

The Stylist is a floating palette you can use to apply styles quickly as you type. You can also use it to 
modify existing styles or create new ones. The Stylist lists styles using several different filters, so 
you can locate the ones you need quickly. To open the Stylist, click Format > Stylist
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Figure 4-6   OpenOffice.org Stylist

To dock the Stylist, hold down the Ctrl key and drag the title bar to the left or to the right side of your 
workspace. To undock the Stylist, hold down the Ctrl key and double-click a free space on the 
Stylist's toolbar.

To apply a style:

1 Select the text you want to format.
To apply a character style to a word, click the word; to apply a paragraph style, click the 
paragraph.

2 Double-click the style in the Stylist. 

4.6  Using Spreadsheets with Calc
Calc is the spreadsheet module of OpenOffice.org. Use this application to, for example, handle your 
private or business accounting data. If Writer (or any other OpenOffice.org application) is already 
running, start Calc by clicking File > New > Spreadsheet—or click Programs > Office > 
Spreadsheet on the main desktop menu.

After starting, Calc presents an empty spreadsheet divided into rows and columns. Rows are 
numbered from top to bottom and columns are lettered from left to right. The intersection of a row 
and a column marks the location of a cell, so each cell has a unique address coordinate. For instance, 
the address B3 refers to the cell located in the second column (B) and the third row. This address is 
also shown at the top to the left of the entry field. 
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Figure 4-7   OpenOffice.org Calc

A cell can be active or inactive. The currently active cell has a thick black frame around it. To 
activate another cell, move the frame with the arrow keys or click another cell with the mouse. You 
can edit a cell if it is currently active. 

4.7  Creating Presentations with OpenOffice.org 
Impress
The Impress presentation software helps you create effective multimedia presentations. You can 
create slides that contain many different elements, including text, bulleted and numbered lists, 
tables, charts, clip art, and graphic objects. Also integrated with Impress is a spell checker, a 
thesaurus, preset text styles, and attractive background styles. You can edit PowerPoint* 
presentations in Impress as well as save your work in PowerPoint format or create Flash (.swf) 
versions of your presentations.
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Figure 4-8   OpenOffice.org Impress

If Writer (or any other OpenOffice.org application) is already running, start Impress by clicking File 
> New > Presentation—or click Programs > Office > Presentation on the main desktop menu.

4.8  Creating Graphics Using Draw
Draw can be used to create vector graphics. Vector graphics are images in which lines and curves are 
defined through certain parameters, such as the location of points and the curvature. 

To create a new drawing, start Draw from the main menu by clicking Programs > Office > Drawing. 
If OpenOffice.org is already running, click File > New > Drawing. The graphical objects available 
in Draw can be modified in various aspects, such as line thickness, line type, color, and fill. 

Figure 4-9   OpenOffice.org Draw
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Browsing the Internet 5

Included with Novell® Linux Desktop (NLD) is the Mozilla Firefox browser. Firefox lets you 
browse the Web the same as other Web browsers. Firefox includes features such as tabbing, pop-up 
window blocking, and download management. This chapter discusses the following information:

• Navigating Web Pages (page 77)
• Tabbing through Multiple Web Sites (page 78)
• Using Basic Commands and Functions and Stopping Pop-ups (page 79)
• Mozilla Firefox Extensions (page 81)
• Browsing History (page 82)
• Printing from Firefox (page 83)
• Managing Bookmarks (page 84)
• “Importing and Exporting Bookmarks” on page 86

5.1  Navigating Web Pages
To start Firefox, click Programs > Firefox Web Browser or click the quick start icon (Description: 

Mozilla Firefox Quick Start icon ) on the top panel. You will notice that Firefox has the same 
look-and-feel as other browsers. The Navigation Toolbar includes navigational buttons such as 
Forward and Back as well as a location bar for a Web address. Bookmarks are also available for 
quick access.

Figure 5-1   Firefox Interface

For more information about the various Firefox features, click Help on the menu bar. 
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5.2  Tabbing through Multiple Web Sites
Viewing multiple Web sites can clutter your desktop with open windows. Firefox can display each 
additional Web site using tabs within a single browser window.

To see how this works, open Firefox. After the browser loads your default home page, press Ctrl+T 
to open a new tab.

Figure 5-2   Firefox Tabbing Feature

Note that the second tab appears at the top of the main window. You can alternate between these 
Web pages by pressing Ctrl+Tab. If you need additional browsing tabs, press Ctrl+T again or right-
click a link and then click Open Link in New Tab.

If you want the browser to open multiple sites when you start the browser, click Edit > Preferences. 
In the Preferences dialog, click General. 
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Figure 5-3   Browsing Multiple Sites

The browser offers a variety of options. You can use the pages you’re currently browsing, select 
startup pages from your bookmarks, or use a blank page. You can also type one or more start page 
addresses, separating multiple address with a space. And you can specify as many addresses as you 
like.

You can also customize the behavior of tabs by accessing the Tabs menu. To do so, right-click a tab. 
The Tab menu lets you create new tabs, reload the current tab (also Ctrl+R), reload all tabs, close 
other tabs, or close the current tab (Ctrl+W).

5.3  Using Basic Commands and Functions and 
Stopping Pop-ups
This section discusses basic commands and functions you can use to get around in Firefox, as well 
as the features for stopping annoying pop-up advertisements:

• “Keyboard Commands for Getting Around Firefox” on page 79
• “Controlling Pop-ups” on page 80

5.3.1  Keyboard Commands for Getting Around Firefox
The following are the most common commands for navigating Firefox.

Table 5-1   Firefox Navigation Commands

Command Description

Ctrl+N Opens a new browser window.

Ctrl+T Opens a new tabbed page in the browser.
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You can view all of the available commands in the drop-down menus under File, Edit, and View. For 
a complete listing of shortcuts, see Keyboard Shortcuts (http://www.mozilla.org/support/firefox/
keyboard).

5.3.2  Controlling Pop-ups
When browsing the Internet, you might come across Web sites that pop up new browser windows to 
advertise products or services, which can become annoying. Firefox includes built-in features for 
managing pop-ups. Click Edit > Preferences, and then click Web Features in the Preferences dialog.

Figure 5-4   Blocking Pop-ups in Firefox

If you want to completely remove pop-ups, make sure that Block Pop-up Windows is selected. If you 
want, you can then approve specific Web sites to allow them to push pop-ups to your Web browser.

After you have configured pop-up filtering, the first time you access a Web site that uses pop-ups, a 
message similar to the following appears above the Web site content indicating that one or more 
pop-ups have been blocked.

Ctrl+O Opens a file.

Ctrl+W Closes the current tabbed window in the browser.

Ctrl+Shift+W Closes the window.

Ctrl+R Refreshes the window.

Command Description
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Figure 5-5   Message When Pop-ups are Detected

In the lower-left corner of your browser, an icon also appears each time a pop-up is blocked:

Figure 5-6   Pop-up Blocked Icon

Some sites require the use of pop-ups to function properly. If you need to toggle your pop-up 
settings for a particular site, click the icon shown above.

Figure 5-7   Unblock Current Site

To unblock the current Web site pop-ups, click Allow popups for name_of _site. 

5.4  Mozilla Firefox Extensions
Mozilla Firefox is a multifunctional application, which means you can download and install add-
ons, known as extensions. For example, you can add the Google Search Bar to Firefox, which 
provides a convenient Google search box to your browser.

To add an extension, click Tools > Extensions.
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Figure 5-8   Firefox Extensions

In the bottom-right corner of the Extensions dialog, click Get More Extensions to launch the Mozilla 
extensions update Web page where you can choose from a variety of available extensions, such as 
the Google bar. Click the extension you want to install. When the page loads with the extension you 
want, click the install link to download and install the extension. When you restart Firefox, the new 
extension is installed and running.

5.5  Browsing History
Like other Web browsers, Firefox keeps a history of the Web sites you have visited, making it easier 
to go find these sites again later. 

Press Ctrl+H to open the History frame.

Figure 5-9   Browsing History

You can browse the history, which is recorded by days. You can also search through your browser 
history. To view a Web site accessed on a particular day, click that day.

When you enter a search word, Firefox searches the browser history for sites containing your search 
term. A search results list is returned displaying all visited sites containing your search term.

To the right of the Search string field, click View to display a menu that lets you sort the sites in your 
history in other ways.
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5.6  Printing from Firefox
You can configure the way Firefox prints the content it displays using the Page Setup dialog.

Click File > Page Setup, then click the Format & Options tab to select the orientation of your print 
jobs. You can scale or make it auto-adjust. If you want to print a background, select Print 
Background (Colors & Images).

Figure 5-10   Page Setup Dialog—Format & Options Page

Click the Margins & Header/Footer tab to adjust margins as well as to select what you want or don’t 
want in the headers and footers.
Browsing the Internet 83



84

    N
ovell C

onfidential
novdocx (E

N
U

)  4 A
ugust 2005

 () () ()Nove
Figure 5-11   Page Setup Dialog—Margins & Header/Footer Page

5.7  Managing Bookmarks
Bookmarks offer a handy way of returning to a Web site that you have visited before.

To add the current Web site to your list of bookmarks, click Bookmarks > Bookmark This Page. If 
your browser currently displays multiple Web sites on tabs, only the URL on the currently selected 
tab is added to your list of bookmarks. 

When you add a bookmark, you can specify an alternate name for the bookmark and you can select 
a folder where Firefox should store it. If you want to bookmark Web sites on multiple tabs, click 
Bookmark All Tabs in a Folder in the Add Bookmark dialog. Firefox creates a new folder that 
includes bookmarks of each site displayed on each tab.

To remove a Web site from the bookmarks list, click Bookmarks, right-click the site's bookmark in 
the list, and then click Delete.

5.7.1  Using Bookmarks Manager
Bookmarks Manager can be used to manage the properties (name, address location) for each 
bookmark, as well as organize the bookmarks into folders and separate sections. You can rearrange, 
automatically sort, edit, and import or export bookmarks.
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Figure 5-12   Bookmarks Manager in Firefox

To open Bookmarks Manager, click Bookmarks > Manage Bookmarks.

5.7.2  Moving and Editing Bookmarks
Bookmark Manager has several buttons that allow you to edit and move bookmarks:

Table 5-2   Bookmark Manager Buttons

5.7.3  Adding or Editing Bookmark Properties
Use the Bookmark Properties dialog to specify or edit the following:

• Name: The name that appears on the toolbar. It is prefilled with the page’s title. If the title is 
long, it is a good idea to edit the bookmark name to free up space on the toolbar.

• Location: The Web address (URL) of the site/page you bookmarked.

Button Description

New Bookmark Manually add a new bookmark.

New Folder Creates a new bookmark (subfolder).

New Separator Adds a new separator. The separator is placed above the bookmark/
folder that you have selected in Bookmark Manager. Separators can 
help distinguish different bookmark categories from each other.

Move Moves a bookmark to a new position/folder in your bookmarks file. 
When you click this button, a Choose Folder dialog appears, letting you 
select the folder you want to move the bookmark to; then click OK. You 
can also drag-and-drop bookmarks to a new location:

You cannot move the bookmark out of your bookmarks file; that is, this 
function cannot be used for exporting individual bookmarks. 

Properties Opens the Bookmark Properties dialog.

Delete Deletes the selected bookmark.
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• Keyword: A shortcut to Web sites. Using a keyword is a great way to easily access your 
favorite sites. For example, you can enter news as the keyword for your favorite news site. 
Then simply typing news in the browser's address bar (where you would normally enter the 
site’s address) will take you to this site. 

• Description: You can add a description for your site here. This can be useful if you have many 
bookmarks or the site’s address or name doesn't indicate what the site is about.

Figure 5-13   Bookmark Properties Dialog

Select Load this bookmark in the sidebar to make the bookmarked page load in Firefox’s sidebar 
instead of in the browser window.

5.7.4  Sorting Bookmarks
You can sort your bookmarks manually by dragging-and-dropping them to a new position, or by 
using the automatic sort function in Bookmarks Manager.

To access the automatic sort function, click the View menu in Bookmarks Manager. You can choose 
to sort by name, location, keyword, description, last modified, last visited, or alphabetically (A-Z or 
Z-A).

This rearranges the bookmark order in Bookmark Manager. If you want to rearrange the order in 
which they appear when you select Bookmarks, right-click any bookmark in the browser window 
(not in Bookmark Manager) and then click Sort By Name.

5.8  Importing and Exporting Bookmarks
You can use Bookmarks Manager to import bookmarks from a different browser (or from a backup 
copy), take your bookmarks with you to another browser, or make a backup copy of your 
bookmarks.

5.8.1  Importing Bookmarks
1 In Firefox, click Bookmarks > Manage Bookmarks.

2 Click File > Import. 

3 Select a bookmark import source, then click Next.
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If you.choose to import bookmarks from a listed browser, Firefox automatically finds and 
imports your bookmarks for you.
If you want to import bookmarks from a browser that is not listed, from backed up Firefox 
bookmarks, or from bookmarks from any other source, select From File. In this case, a dialog 
appears that lets you specify the file you want to import. Depending on the browser you want to 
import bookmarks from, it might be necessary to export those bookmarks first.

5.8.2  Exporting Bookmarks
1 In Firefox, click Bookmarks > Manage Bookmarks.

2 Click File > Export.

3 Specify a name and location for the exported file.

4 Click Save.
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Using Collaboration Software 6

Novell® Linux Desktop (NLD) includes groupware programs to make the tasks of managing 
information and communicating with colleagues easier:

• E-mail and Calendering with Novell Evolution (page 89)
• E-mail and Calendaring with the GroupWise Linux Client (page 90)
• Instant Messaging with Gaim (page 91)

6.1  E-mail and Calendering with Novell Evolution
Information is useless unless it’s organized and accessible. Novell EvolutionTM makes the tasks of 
storing, organizing, and retrieving your personal information easier so you can work more 
efficiently and communicate with others.

Figure 6-1   Novell Evolution Main Mail Window

Evolution can help you work in a group by handling e-mail, address, and other contact information, 
as well as one or more calendars. It can do all this on one or several computers, connected directly or 
over a network, for one person or for large groups.

With Evolution, you can accomplish your most common daily tasks faster. For example, it takes 
only one or two clicks to enter appointment or contact information sent to you by e-mail, or to send 
e-mail to a contact or appointment. Evolution makes displays faster and more efficient, so searches 
are faster and memory usage is lower. People who get a lot of mail will appreciate advanced features 
like VFolders, which lets you save searches as though they were ordinary mail folders.
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6.1.1  Starting Evolution for the First Time
To start Evolution, click Programs > Novell Evolution on the menu panel. 

The first time you run the program, it creates a directory called .evolution in your home 
directory, where it stores all of its local data. Then, it opens a first-run assistant to help you set up 
mail accounts and import data from other applications. Using the first-run assistant should take 
approximately two to five minutes.

Later, if you want to change this account or create a new one, click Tools > Settings > Mail 
Accounts. Then select the account you want to change and click Edit, or click Add to configure 
another account.

6.1.2  For More Information
For complete Novell Evolution documentation, see the Evolution 2.0 User Guide (http://
www.novell.com/documentation/nld/evolution/data/front.html).

6.2  E-mail and Calendaring with the GroupWise 
Linux Client
If your company uses Novell GroupWise®, you can download and install the GroupWise 6.5 for 
Linux Cross-Platform client. This GroupWise client lets Linux users access their GroupWise 
mailboxes to send and receive mail.

The GroupWise Cross-Platform client provides Linux users with the following essential 
collaboration features:

• Online mode and Caching mode
• Read/Compose messages, appointments, tasks, and notes in Plain Text or HTML views
• Reply/Forward/Accept/Decline/Delegate
• Address Book
• Calendaring support, including Busy Search and Posted Items
• Folder support, including Checklist, Contacts, Junk Mail, and Trash
• Personal folders and shared folders
• Proxy access to others’ mailboxes
• Archiving
• Find

The GroupWise Client is a free download from the Novell Download Web site (http://
download.novell.com/pages/PublicSearch.jsp). On the Novell Downloads page, select GroupWise 
from the Limit Results To list, click Search, and then click GroupWise 6.5 for Linux Cross-Platform 
Client on Linux.

The GroupWise 6.5 Cross-Platform Client User Guide (http://www.novell.com/documentation/
gw65/index.html?page=/documentation/gw65/gw65d_userxplat/data/ab32nt1.html) is available on 
the GroupWise 6.5 Documentation Web site.
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6.3  Instant Messaging with Gaim
Gaim is a multiprotocol instant messaging (IM) client for Linux, BSD, Mac* OS X, and Windows. It 
is compatible with GroupWise Messenger, AOL* Instant Messenger (AIM), ICQ, Yahoo!*, IRC, 
Jabber, Gadu-Gadu, and Zephyr networks.

This release of Gaim includes the following new features:

• Added support for Novell privacy settings 
• Added ability to initiate multiuser chats in GroupWise Messenger 
• Plug-in Actions menu 
• Support for the SLIC protocol 
• An option to suppress disconnect notification when using the auto-connect plug-in 

6.3.1  Configuring Gaim for GroupWise Messenger
In order to use Gaim with GroupWise Messenger, your system administrator must be running 
GroupWise Messenger for Linux Server or GroupWise Messenger Support Pack 2 (or later) 
Messenger Server for NetWare® and Windows. 

1 Launch Instant Messenger by clicking Programs > Internet > Instant Messenger.

2 Click Accounts > Add.

3 Select the GroupWise protocol.

4 Type your screen name, password, and alias in the appropriate fields.

5 Select any desired user options. 

6 Click Show More Options.

7 Type your server address in the Server Address field.

8 Type your server port (if different from the default) in the Server Port field.

9 Select your proxy type, if needed.

10 Click Save, then click Close in the Accounts window.

11 Select the GroupWise account you just created in the Login window.

12 Type your password in the Password field.

13 Click Sign On.

6.3.2  For More Information
For complete GAIM documentation, see the GAIM Web Site (http://gaim.sourceforge.net/
documentation.php).
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Using Multimedia Utilities 7

This chapter provides an overview of music and movie applications for various multimedia tasks. A 
more detailed explanation of a utility's features can be found by clicking Help inside the utility.

Novell® Linux Desktop (NLD) provides utilities for the following:

• Creating CDs (page 93)
• Playing CDs (page 95)
• Playing Music Files (page 95)
• Playing Movies (page 96)
• Playing Streaming Audio and Video (page 96)
• Controlling Volume and Balance (page 97)
• Extracting Audio from CDs (page 97)

7.1  Creating CDs
The CD Burner is a feature-rich CD/DVD burning application using K3b - The CD Kreator. It 
supports various project types (audio CD, data CD, mixed mode CD, Video CD, and data DVD) and 
also features like Audio CD ripping with CDDB support.

Figure 7-1   K3b - The CD Kreator

K3b - The CD Kreator provides a comfortable user interface to perform most CD/DVD-burning 
tasks like creating an Audio CD from a set of audio files or copying a CD. The experienced user can 
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take advantage of all steps of the burning process, and the beginner can use the automatic settings 
and the CD Burner defaults that allow a quick start.

7.1.1  Creating a Data CD
1 Click Programs > Multimedia > CD Burner.

2 Click the New Data CD Project icon in the bottom panel.

3 Follow the instructions to drag-and-drop files you want to include on the CD.

4 Click Project > Burn.

5 Specify the settings for burning your CD, then click Burn.

7.1.2  Creating an Audio CD
1 Click Programs > Multimedia > CD Burner.

2 Click the New Audio CD Project icon in the bottom panel.

3 Follow the instructions to drag-and-drop the audio tracks you want to include on the CD.
The audio data must be in MP3, WAV, or Ogg Vorbis format. The sequence of the tracks can be 
determined by moving them up or down in the project folder.

4 Click Project > Burn.

5 Specify the settings for burning your CD, then click Burn.
If you select the Track at Once mode, a two-second intermission is inserted after each track.

7.1.3  Copying a CD
1 Click Programs > Multimedia > CD Burner.

2 Click the Copy CD icon in the bottom panel.

3 Select settings for the CD reading and writing devices.
Click On the Fly to burn the CD as soon as it has been read, or click Only Create Image to 
create an image in the path specified in the Write Image File to field.

4 Click Start.

7.1.4  Writing ISO Images
1 Click Programs > Multimedia > CD Burner.

2 Click Tools, select the media, then click Burn ISO Image.

3 Browse to and select the Image to Burn.
K3b calculates and displays a check sum. If the ISO file was downloaded from the Internet, this 
sum is displayed if the download was successful.

4 (Optional) Use the Options and Advanced tabbed pages to set your preferences.

5 Click Start to burn the image.
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7.2  Playing CDs
NLD includes CD Player for playing CDs. The first time a CD is inserted, NLD detects the CD and 
prompts you about running CD Player. If you select Yes, the player is launched. If you select No, no 
application is launched.

Figure 7-2   CD Player

To launch CD Player, click Programs > Multimedia > CD Player.

7.3  Playing Music Files
Music Player is an ID3 organized music library and player for your MP3, PLAC, or Ogg Vorbis 
music files. It lets you display information about the songs in your Library though metadata reading, 
create playlists by dragging and dropping from the Library view, search for entries in the Library, 
and listen to Internet radio stations.

To launch the player, click Programs > Multimedia > Music Player.

Figure 7-3   Music Player

To play a track, select the track, then click the play button on the toolbar, or simply double-click the 
track to start playing it. When a track ends, Music Player plays the next track in the list. In the 
Library, you can play all the songs from an artist, or you can play a single album.

For more information on using Music Player, click Help > Contents to open the Music Player 
Manual.
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7.4  Playing Movies
Totem Movie Player lets you play MPEG and AVI movies and supports playback of DVDs, VCDs, 
and audio CDs. In addition to playing video and audio files, Totem Movie Player lets you view 
video in different aspect ratios and zoom levels, play video at full screen, perform seeks, and create 
playlists. Totem Movie Player does not play some codecs, QuickTime*, Windows Media files, and 
copy-protected DVDs.

To launch the player, click Program > Multimedia > Totem Movie Player.

Figure 7-4   Totem Movie Player

Click Movie > Play VCD or Movie > Play DVD to start playback of a VCD or DVD. Totem offers 
menu support for DVDs on the Go menu. Movie streams can be fetched via the network—click 
Movie > Open Location and enter the URL. You can take screen shots by clicking Edit > Take 
Screenshot.

7.5  Playing Streaming Audio and Video
Although you can listen to radio stations with Music Player, NLD also includes RealPlayer for 
streaming audio and video. While browsing the Internet, you might come across other radio stations, 
movie trailers, and other music sources. RealPlayer supports RealAudio, RealVideo 10, MP3, Ogg 
Vorbis (http://www.vorbis.com), Theora, H263, AAC, and more.

To launch RealPlayer, click Programs > Multimedia > RealPlayer.
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Figure 7-5   RealPlayer

7.6  Controlling Volume and Balance
The Volume Control application provides a means of controlling the volume and balance of the 
sound output and input of your computer. To access Volume Control, click Programs > Multimedia 
> Volume Control, or click the Quickstart icon in the top panel.

Figure 7-6   Volume Control

For easier access, Volume Control can be added to upper or lower panels, giving you one-click 
access. Right-click a panel, then click Add to Panel > Multimedia > Volume Control. Right-click the 
volume control applet, then click Open Volume Control to access the more advanced mixer 
functions.

7.7  Extracting Audio from CDs
Sound Juicer is a.CD ripper tool that lets you extract the audio from audio CDs and convert it into a 
variety of audio formats your computer can understand and play. It can also look up the titles and 
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artists of the tracks on your CD from the Internet using the freely available MusicBrainz (http://
www.musicbrainz.org) service.

To launch Sound Juicer, click Programs > Multimedia > More > CD Ripper.

Figure 7-7   Sound Juicer

7.7.1  Using Sound Juicer
1 Insert an audio CD into your drive.

2 Click Programs > Multimedia > More > CD Ripper.
When you start Sound Juicer, it examines the CD in the currently selected drive and tries to 
locate information about its contents. It can match against things like the serial number and the 
length and positions of the tracks.

3 In the fields at the top of the dialog, type the artist and album name.
If the disk is a single, type the name of the artist and the title of the track. If the disc is by 
multiple artists, you can type Various or leave it blank. This information is placed in the 
extracted files so that the files can be easily catalogued and searched by music-playing 
software. Each track also has a title and artist field that can be set separately. This information 
is also encoded in the output files.

TIP: When you edit the disk Artist field, all the track Artist fields are updated to reflect that. 
This saves you a lot of typing as most discs are by a single artist.

4 To exclude tracks, deselect them in the Extract column. 
Use the options on the Edit menu to select or deselect all the tracks at the same time.

5 Click Extract to read the audio from the CD and save it to disk. 
By default, files are stored in the /album_artist/album_title directory in your home directory, 
but you can change this in the Preferences dialog.
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Extracting a CD can take a long time, depending on the speed of your computer. By default, 
Sound Juicer compresses the audio at the same time it extracts it from the CD so that it takes up 
less space on disk.

The Re-read button is useful if you change CDs but don't want to restart the program. Clicking this 
button causes Sound Juicer to update the list of tracks.

7.7.2  Configuring Sound Juicer Preferences
The Preferences window lets you control which CD drive Sound Juicer uses (if you have more than 
one CD drive), where the extracted audio is placed, and which file format/codec is used for the 
extracted audio.

Figure 7-8   Sound Juicer Preferences Dialog

If you have multiple CD drives in your system, click the CD Drive drop-down list to select the drive 
to use by default. You can also browse for a directory to place the audio files in.

The Track Names section lets you control how the audio files are laid out in your chosen directory. 
For example, in the default setup, the first track of your CD might be extracted to ~ /album artist/
album title/01 - Rapture [Radio Edit].ogg.

Strip Special Characters controls whether the filename should be made safe for the command line. 
This involves removing characters such as / \ * and ?. It's a good idea to select this option.

The options in the Track Format section let you select the file format you want to save the audio 
files to:

• Ogg Vorbis (http://www.vorbis.com) is the default and is recommended due to its high quality 
and low file size nature, as well as the fact that it is an open format available to everyone. Ogg 
Vorbis can be played by virtually all Linux installations out of the box, and WinAmp for 
Windows also supports it.
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• MP3 is widely known and used, and has good hardware support. If you have a portable MP3 
player that doesn't accept Vorbis files, you might want to use this so you can upload the music 
to that device.

• FLAC is a lossless codec, as opposed to Vorbis and MP3 which are lossy. Lossless codecs don't 
throw away any information, which means that you get a 100% faithful reproduction of the 
original sound. Lossy codecs use complex mathematical constructions, called psychoacoustic 
models, to eliminate information that you cannot normally hear. The end result sounds virtually 
identical to the original, however. If quality is of the highest concern to you, and you have a lot 
of disk space, you might want to try FLAC.

• Wave raw audio is the lowest common denominator format. It isn't compressed at all, and 
results in the biggest files. It's often used for professional audio work.
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Accessing Files on the Network 8

This chapter helps you access network resources using the following tasks:

• “Connecting to Your Network” on page 101
• “Managing Network Connections” on page 102
• “Accessing Network Shares” on page 103

8.1  Connecting to Your Network
There are essentially two ways that you can connect to a network: via wired and wireless 
connections.

By default, the Network Connections icon is loaded on your main panel. If the icon is a red X, your 
machine is not currently connected to a network:

Figure 8-1   Main Panel When Not Connected to a Network

8.1.1  Connecting to a Wired Connection
1 Make sure that an Ethernet cable is connected to your computer's network interface card.

2 Click the Network Connections icon on the main panel, then click Ethernet: eth0.

After a wired network connection is established, the Network Connections icon changes to display 
two desktops.

Figure 8-2   Main Panel When Connected to a Wired Network

A connection to the network is confirmed when (active) is listed next to the Ethernet menu item. 
You can also confirm connectivity by clicking the Network Connections icon and then clicking 
Connection Information. If connected, the Connection Information window displays your IP 
address.

8.1.2  Connecting to a Wireless Connection
1 Make sure that an Ethernet cable is connected to your computer's network interface card.

2 Click the Network Connections icon on the main panel, then click Wireless: eth1.

The Network Connections icon changes to a wireless signal strength bar, and any detected wireless 
networks are displayed in the Network Connections menu.

Figure 8-3   Main Panel When Connected to a Wireless Network
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If your network name is displayed, select the network name from the Network Connections menu. 

After you are connected, the Network Connections icon turns blue (Description: NetApplet icon ).

If you do not see your wireless network name in the Network Connections menu:

1 Click the Network Connections icon on the main panel, then click Other.

2 In the Specify an ESSID dialog, type the wireless network name in the ESSID: field.

3 (Conditional) If the wireless network is encrypted, click Show Encryption Key to display the 
Encryption Key field.

4 Type the encryption code, then click OK.
Your wireless network's name should now appear in the Network Connections menu.

5 Select the wireless network's name. 
Upon connection, the Network Connections icon turns blue.

You can also confirm connection by selecting Connection Information from the Network 
Connections menu. If connected, your IP address is displayed in the Connection Information dialog.

8.2  Managing Network Connections
The Network Connection icon lets you monitor, manage, and configure your network connections. 
Clicking the icon opens a menu that displays which network connection is active, if you have more 
than one network device in your computer.

For example, if your laptop computer is configured to use a wireless port and a port for a network 
cable, you will see two network connections in the list, as in the following figure.

Figure 8-4   Managing Network Connections
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If you are connected to the network via a cable and need to switch to use your wireless, simply click 
the Network Connections icon and then click Wireless: eth1. NLD switches your network 
connection and acquires a new IP address, if needed.

IMPORTANT: Prior to making the change, you should save any data, because the change in 
services might require that certain applications or services be restarted.

Using the menu, you can view connection informations such as the IP address being used and your 
hardware address.

If you need to update or make changes to your network settings, select Configure Network Settings 
from the Network Connections menu. This launches the Network Card Setup wizard, which steps 
you through the configuration process. Using this option requires you to provide the password for 
root.

8.3  Accessing Network Shares
Other network devices, like workstations and servers, can be set up to share some or all of their 
resources. Typically, files and folders are marked to let remote users access them. These are called 
network shares. If your system is configured to access network shares, you can use File Manager to 
access them. 

To access network shares, double-click Computer and then click Network. The window displays the 
network shares that you can access. Double-click the network resource that you want to access. You 
might be required to authenticate to the resource by providing a username and password.

To access NFS shares, double-click the UNIX Network icon. A list of UNIX shares available to you 
is displayed.

To access Windows shares, double-click the Windows Network icon. The Windows shares available 
to you are displayed.

Figure 8-5   Workgroups on a Windows Network

8.3.1  Adding a Network Place
1 Double-click Computer.

2 Click File > Connect to Server.
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3 Specify the name you want displayed for this link and its URL, then click Connect.
An icon for the network place is added to the desktop.
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Managing Printers 9

Novell® Linux Desktop (NLD) makes it easy to print your documents, whether your computer is 
connected directly to a printer or linked remotely on a network. This chapter describes how to set up 
printers in NLD and manage print jobs with the following tasks:

• “Installing a Printer” on page 105
• “Modifying Printer Settings” on page 106
• “Canceling Print Jobs” on page 106
• “Deleting a Printer” on page 106

9.1  Installing a Printer
Before you can install a printer, you need to know the root password and have your printer 
information ready. Depending on how you connect to the printer, you might also need the printer 
URI, TCP/IP address or host, and the driver for the printer. A number of common printer drivers 
ship with NLD. If you cannot find a driver for the printer, check the printer manufacturer's Web site.

9.1.1  Installing a Network Printer
1 Click System > Personal Settings > Printers > New Printer.

2 Enter the root password.

3 Click Network Printer, then select the type of connection for this printer.
CUPS Printer (IPP): A printer attached to a different Linux system on the same network 
running CUPS or a printer configured on another operating system to use IPP.
Windows Printer (SMB): A printer attached to a different system which is sharing a printer 
over a SMB network (for example, a printer attached to a Microsoft Windows machine). 
UNIX Printer (LPD): A printer attached to a different UNIX system that can be accessed over 
a TCP/IP network (for example, a printer attached to another Linux system on your network).
HP JetDirect Printer: A printer connected directly to the network instead of to a computer. 

4 Specify the printer's information.

5 Select the printer driver for this printer, then click Apply.
You can also install a printer driver from a disk, or visit the printer manufacturer's Web site to 
download the latest driver. 

The installed printer appears in the Printers panel. You can now print to the printer from any 
application.

9.1.2  Installing a Local Printer
1 Connect the printer cable to your computer and connect the printer's power supply.

2 Click System > Personal Settings > Printers > New Printer.

3 Enter the root password.
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4 Click Local Printer.

5 If the printer was autodetected, select the printer from the list. If the printer was not 
autodetected, click Use Another Printer by Specifying a Port and then select the correct printer 
port.

6 Select the printer driver for this printer, then click Apply.
You can also install a printer driver from a disk, or visit the printer manufacturer's Web site to 
download the latest driver. 

The installed printer appears in the Printers panel. You can now print to the printer from any 
application.

9.2  Modifying Printer Settings
1 Click System > Personal Settings > Printer.

2 Right-click the printer you want to modify, then click Properties.

3 Modify the properties, then click Close.

9.3  Canceling Print Jobs
1 Click System > Personal Settings > Printer.

2 Double-click the printer you sent the job to. 

3 Select the print job from the list.
If the print job does not appear in the list, then the print job might have been sent to the printer 
already.

4 Click Edit > Cancel Jobs.

9.4  Deleting a Printer
1 Click System > Personal Settings > Printer.

2 Click Edit > Become Administrator.

3 Type the root password, then click OK.

4 Right-click the printer you want to delete, then click Remove.
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GNU Licenses A

This appendix contains the following:

• “GNU General Public License” on page 107
• “GNU Free Documentation License” on page 112

A.1  GNU General Public License
Version 2, June 1991 

Copyright (C) 1989, 1991 Free Software Foundation, Inc. 59 Temple Place - Suite 330, Boston, MA 
02111-1307, USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing 
it is not allowed.

A.1.1  Preamble
The licenses for most software are designed to take away your freedom to share and change it. By 
contrast, the GNU General Public License is intended to guarantee your freedom to share and 
change free software--to make sure the software is free for all its users. This General Public License 
applies to most of the Free Software Foundation’s software and to any other program whose authors 
commit to using it. (Some other Free Software Foundation software is covered by the GNU Library 
General Public License instead.) You can apply it to your programs, too.

When we speak of free software, we are referring to freedom, not price. Our General Public 
Licenses are designed to make sure that you have the freedom to distribute copies of free software 
(and charge for this service if you wish), that you receive source code or can get it if you want it, that 
you can change the software or use pieces of it in new free programs; and that you know you can do 
these things. 

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to 
ask you to surrender the rights. These restrictions translate to certain responsibilities for you if you 
distribute copies of the software, or if you modify it. 

For example, if you distribute copies of such a program, whether gratis or for a fee, you must give 
the recipients all the rights that you have. You must make sure that they, too, receive or can get the 
source code. And you must show them these terms so they know their rights. 

We protect your rights with two steps: (1) copyright the software, and (2) offer you this license 
which gives you legal permission to copy, distribute and/or modify the software. 

Also, for each author’s protection and ours, we want to make certain that everyone understands that 
there is no warranty for this free software. If the software is modified by someone else and passed 
on, we want its recipients to know that what they have is not the original, so that any problems 
introduced by others will not reflect on the original authors’ reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the danger 
that redistributors of a free program will individually obtain patent licenses, in effect making the 
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program proprietary. To prevent this, we have made it clear that any patent must be licensed for 
everyone’s free use or not licensed at all. 

The precise terms and conditions for copying, distribution and modification follow. 

A.1.2  GNU GENERAL PUBLIC LICENSE TERMS AND 
CONDITIONS FOR COPYING, DISTRIBUTION AND 
MODIFICATION
0. This License applies to any program or other work which contains a notice placed by the 
copyright holder saying it may be distributed under the terms of this General Public License. The 
“Program”, below, refers to any such program or work, and a “work based on the Program” means 
either the Program or any derivative work under copyright law: that is to say, a work containing the 
Program or a portion of it, either verbatim or with modifications and/or translated into another 
language. (Hereinafter, translation is included without limitation in the term “modification”.) Each 
licensee is addressed as “you”.

Activities other than copying, distribution and modification are not covered by this License; they are 
outside its scope. The act of running the Program is not restricted, and the output from the Program 
is covered only if its contents constitute a work based on the Program (independent of having been 
made by running the Program). Whether that is true depends on what the Program does. 

1. You may copy and distribute verbatim copies of the Program’s source code as you receive it, in 
any medium, provided that you conspicuously and appropriately publish on each copy an 
appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this 
License and to the absence of any warranty; and give any other recipients of the Program a copy of 
this License along with the Program. 

You may charge a fee for the physical act of transferring a copy, and you may at your option offer 
warranty protection in exchange for a fee. 

2. You may modify your copy or copies of the Program or any portion of it, thus forming a work 
based on the Program, and copy and distribute such modifications or work under the terms of 
Section 1 above, provided that you also meet all of these conditions: 

a) You must cause the modified files to carry prominent notices stating that you changed the files 
and the date of any change. 

b) You must cause any work that you distribute or publish, that in whole or in part contains or is 
derived from the Program or any part thereof, to be licensed as a whole at no charge to all third 
parties under the terms of this License.

c) If the modified program normally reads commands interactively when run, you must cause it, 
when started running for such interactive use in the most ordinary way, to print or display an 
announcement including an appropriate copyright notice and a notice that there is no warranty (or 
else, saying that you provide a warranty) and that users may redistribute the program under these 
conditions, and telling the user how to view a copy of this License. (Exception: if the Program itself 
is interactive but does not normally print such an announcement, your work based on the Program is 
not required to print an announcement.) 

These requirements apply to the modified work as a whole. If identifiable sections of that work are 
not derived from the Program, and can be reasonably considered independent and separate works in 
themselves, then this License, and its terms, do not apply to those sections when you distribute them 
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as separate works. But when you distribute the same sections as part of a whole which is a work 
based on the Program, the distribution of the whole must be on the terms of this License, whose 
permissions for other licensees extend to the entire whole, and thus to each and every part regardless 
of who wrote it. 

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely 
by you; rather, the intent is to exercise the right to control the distribution of derivative or collective 
works based on the Program. 

In addition, mere aggregation of another work not based on the Program with the Program (or with a 
work based on the Program) on a volume of a storage or distribution medium does not bring the 
other work under the scope of this License. 

3. You may copy and distribute the Program (or a work based on it, under Section 2) in object code 
or executable form under the terms of Sections 1 and 2 above provided that you also do one of the 
following: 

a) Accompany it with the complete corresponding machine-readable source code, which must be 
distributed under the terms of Sections 1 and 2 above on a medium customarily used for software 
interchange; or, 

b) Accompany it with a written offer, valid for at least three years, to give any third party, for a 
charge no more than your cost of physically performing source distribution, a complete machine-
readable copy of the corresponding source code, to be distributed under the terms of Sections 1 and 
2 above on a medium customarily used for software interchange; or, 

c)  Accompany it with the information you received as to the offer to distribute corresponding 
source code. (This alternative is allowed only for noncommercial distribution and only if you 
received the program in object code or executable form with such an offer, in accord with 
Subsection b above.) 

The source code for a work means the preferred form of the work for making modifications to it. For 
an executable work, complete source code means all the source code for all modules it contains, plus 
any associated interface definition files, plus the scripts used to control compilation and installation 
of the executable. However, as a special exception, the source code distributed need not include 
anything that is normally distributed (in either source or binary form) with the major components 
(compiler, kernel, and so on) of the operating system on which the executable runs, unless that 
component itself accompanies the executable. 

If distribution of executable or object code is made by offering access to copy from a designated 
place, then offering equivalent access to copy the source code from the same place counts as 
distribution of the source code, even though third parties are not compelled to copy the source along 
with the object code. 

4. You may not copy, modify, sublicense, or distribute the Program except as expressly provided 
under this License. Any attempt otherwise to copy, modify, sublicense or distribute the Program is 
void, and will automatically terminate your rights under this License. However, parties who have 
received copies, or rights, from you under this License will not have their licenses terminated so 
long as such parties remain in full compliance. 

5. You are not required to accept this License, since you have not signed it. However, nothing else 
grants you permission to modify or distribute the Program or its derivative works. These actions are 
prohibited by law if you do not accept this License. Therefore, by modifying or distributing the 
Program (or any work based on the Program), you indicate your acceptance of this License to do so, 
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and all its terms and conditions for copying, distributing or modifying the Program or works based 
on it. 

6. Each time you redistribute the Program (or any work based on the Program), the recipient 
automatically receives a license from the original licensor to copy, distribute or modify the Program 
subject to these terms and conditions. You may not impose any further restrictions on the recipients’ 
exercise of the rights granted herein. You are not responsible for enforcing compliance by third 
parties to this License. 

7. If, as a consequence of a court judgment or allegation of patent infringement or for any other 
reason (not limited to patent issues), conditions are imposed on you (whether by court order, 
agreement or otherwise) that contradict the conditions of this License, they do not excuse you from 
the conditions of this License. If you cannot distribute so as to satisfy simultaneously your 
obligations under this License and any other pertinent obligations, then as a consequence you may 
not distribute the Program at all. For example, if a patent license would not permit royalty-free 
redistribution of the Program by all those who receive copies directly or indirectly through you, then 
the only way you could satisfy both it and this License would be to refrain entirely from distribution 
of the Program. 

If any portion of this section is held invalid or unenforceable under any particular circumstance, the 
balance of the section is intended to apply and the section as a whole is intended to apply in other 
circumstances. 

It is not the purpose of this section to induce you to infringe any patents or other property right 
claims or to contest validity of any such claims; this section has the sole purpose of protecting the 
integrity of the free software distribution system, which is implemented by public license practices. 
Many people have made generous contributions to the wide range of software distributed through 
that system in reliance on consistent application of that system; it is up to the author/donor to decide 
if he or she is willing to distribute software through any other system and a licensee cannot impose 
that choice. 

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of 
this License. 

8. If the distribution and/or use of the Program is restricted in certain countries either by patents or 
by copyrighted interfaces, the original copyright holder who places the Program under this License 
may add an explicit geographical distribution limitation excluding those countries, so that 
distribution is permitted only in or among countries not thus excluded. In such case, this License 
incorporates the limitation as if written in the body of this License. 

9. The Free Software Foundation may publish revised and/or new versions of the General Public 
License from time to time. Such new versions will be similar in spirit to the present version, but may 
differ in detail to address new problems or concerns. 

Each version is given a distinguishing version number. If the Program specifies a version number of 
this License which applies to it and “any later version”, you have the option of following the terms 
and conditions either of that version or of any later version published by the Free Software 
Foundation. If the Program does not specify a version number of this License, you may choose any 
version ever published by the Free Software Foundation. 

10. If you wish to incorporate parts of the Program into other free programs whose distribution 
conditions are different, write to the author to ask for permission. For software which is copyrighted 
by the Free Software Foundation, write to the Free Software Foundation; we sometimes make 
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exceptions for this. Our decision will be guided by the two goals of preserving the free status of all 
derivatives of our free software and of promoting the sharing and reuse of software generally. 

NO WARRANTY

11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO 
WARRANTY FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. 
EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR 
OTHER PARTIES PROVIDE THE PROGRAM “AS IS” WITHOUT WARRANTY OF ANY 
KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE 
PROGRAM IS WITH YOU. SHOULD THE PROGRAM PROVE DEFECTIVE, YOU ASSUME 
THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN 
WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY 
MODIFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE 
TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR 
CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE 
PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING 
RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A 
FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS), EVEN IF 
SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH 
DAMAGES. 

END OF TERMS AND CONDITIONS

A.1.3  How to Apply These Terms to Your New Programs
If you develop a new program, and you want it to be of the greatest possible use to the public, the 
best way to achieve this is to make it free software which everyone can redistribute and change 
under these terms.

To do so, attach the following notices to the program. It is safest to attach them to the start of each 
source file to most effectively convey the exclusion of warranty; and each file should have at least 
the “copyright” line and a pointer to where the full notice is found. 

one line to give the program’s name and an idea of what it does. Copyright (C) yyyy name of author

This program is free software; you can redistribute it and/or
modify it under the terms of the GNU General Public License
as published by the Free Software Foundation; either version 2
of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program; if not, write to the Free Software
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Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, 
USA.

Also add information on how to contact you by electronic and paper mail.

If the program is interactive, make it output a short notice like this when it starts in an interactive 
mode: 

Gnomovision version 69, Copyright (C) year name of author
Gnomovision comes with ABSOLUTELY NO WARRANTY; for details
type `show w’. This is free software, and you are welcome
to redistribute it under certain conditions; type `show c’ 
for details.

The hypothetical commands `show w’ and `show c’ should show the appropriate parts of the 
General Public License. Of course, the commands you use may be called something other than 
`show w’ and `show c’; they could even be mouse-clicks or menu items--whatever suits your 
program.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a 
“copyright disclaimer” for the program, if necessary. Here is a sample; alter the names: 

Yoyodyne, Inc., hereby disclaims all copyright
interest in the program `Gnomovision’
(which makes passes at compilers) written 
by James Hacker.

signature of Ty Coon, 1 April 1989
Ty Coon, President of Vice

This General Public License does not permit incorporating your program into proprietary programs. 
If your program is a subroutine library, you may consider it more useful to permit linking proprietary 
applications with the library. If this is what you want to do, use the GNU Lesser General Public 
License (http://www.fsf.org/licenses/lgpl.html) instead of this License. 

A.2  GNU Free Documentation License
Version 1.2, November 2002

Copyright (C) 2000,2001,2002 Free Software Foundation, Inc. 59 Temple Place, Suite 330, Boston, 
MA 02111-1307 USA 

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing 
it is not allowed.

A.2.1  0. PREAMBLE
The purpose of this License is to make a manual, textbook, or other functional and useful document 
“free” in the sense of freedom: to assure everyone the effective freedom to copy and redistribute it, 
with or without modifying it, either commercially or noncommercially. Secondarily, this License 
preserves for the author and publisher a way to get credit for their work, while not being considered 
responsible for modifications made by others.
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This License is a kind of “copyleft”, which means that derivative works of the document must 
themselves be free in the same sense. It complements the GNU General Public License, which is a 
copyleft license designed for free software.

We have designed this License in order to use it for manuals for free software, because free software 
needs free documentation: a free program should come with manuals providing the same freedoms 
that the software does. But this License is not limited to software manuals; it can be used for any 
textual work, regardless of subject matter or whether it is published as a printed book. We 
recommend this License principally for works whose purpose is instruction or reference.

A.2.2  1. APPLICABILITY AND DEFINITIONS
This License applies to any manual or other work, in any medium, that contains a notice placed by 
the copyright holder saying it can be distributed under the terms of this License. Such a notice grants 
a world-wide, royalty-free license, unlimited in duration, to use that work under the conditions 
stated herein. The “Document”, below, refers to any such manual or work. Any member of the 
public is a licensee, and is addressed as “you”. You accept the license if you copy, modify or 
distribute the work in a way requiring permission under copyright law.

A “Modified Version” of the Document means any work containing the Document or a portion of it, 
either copied verbatim, or with modifications and/or translated into another language.

A “Secondary Section” is a named appendix or a front-matter section of the Document that deals 
exclusively with the relationship of the publishers or authors of the Document to the Document’s 
overall subject (or to related matters) and contains nothing that could fall directly within that overall 
subject. (Thus, if the Document is in part a textbook of mathematics, a Secondary Section may not 
explain any mathematics.) The relationship could be a matter of historical connection with the 
subject or with related matters, or of legal, commercial, philosophical, ethical or political position 
regarding them.

The “Invariant Sections” are certain Secondary Sections whose titles are designated, as being those 
of Invariant Sections, in the notice that says that the Document is released under this License. If a 
section does not fit the above definition of Secondary then it is not allowed to be designated as 
Invariant. The Document may contain zero Invariant Sections. If the Document does not identify 
any Invariant Sections then there are none.

The “Cover Texts” are certain short passages of text that are listed, as Front-Cover Texts or Back-
Cover Texts, in the notice that says that the Document is released under this License. A Front-Cover 
Text may be at most 5 words, and a Back-Cover Text may be at most 25 words.

A “Transparent” copy of the Document means a machine-readable copy, represented in a format 
whose specification is available to the general public, that is suitable for revising the document 
straightforwardly with generic text editors or (for images composed of pixels) generic paint 
programs or (for drawings) some widely available drawing editor, and that is suitable for input to 
text formatters or for automatic translation to a variety of formats suitable for input to text 
formatters. A copy made in an otherwise Transparent file format whose markup, or absence of 
markup, has been arranged to thwart or discourage subsequent modification by readers is not 
Transparent. An image format is not Transparent if used for any substantial amount of text. A copy 
that is not “Transparent” is called “Opaque”.

Examples of suitable formats for Transparent copies include plain ASCII without markup, Texinfo 
input format, LaTeX input format, SGML or XML using a publicly available DTD, and standard-
conforming simple HTML, PostScript or PDF designed for human modification. Examples of 
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transparent image formats include PNG, XCF and JPG. Opaque formats include proprietary formats 
that can be read and edited only by proprietary word processors, SGML or XML for which the DTD 
and/or processing tools are not generally available, and the machine-generated HTML, PostScript or 
PDF produced by some word processors for output purposes only.

The “Title Page” means, for a printed book, the title page itself, plus such following pages as are 
needed to hold, legibly, the material this License requires to appear in the title page. For works in 
formats which do not have any title page as such, “Title Page” means the text near the most 
prominent appearance of the work’s title, preceding the beginning of the body of the text.

A section “Entitled XYZ” means a named subunit of the Document whose title either is precisely 
XYZ or contains XYZ in parentheses following text that translates XYZ in another language. (Here 
XYZ stands for a specific section name mentioned below, such as “Acknowledgements”, 
“Dedications”, “Endorsements”, or “History”.) To “Preserve the Title” of such a section when you 
modify the Document means that it remains a section “Entitled XYZ” according to this definition.

The Document may include Warranty Disclaimers next to the notice which states that this License 
applies to the Document. These Warranty Disclaimers are considered to be included by reference in 
this License, but only as regards disclaiming warranties: any other implication that these Warranty 
Disclaimers may have is void and has no effect on the meaning of this License.

A.2.3  2. VERBATIM COPYING
You may copy and distribute the Document in any medium, either commercially or 
noncommercially, provided that this License, the copyright notices, and the license notice saying 
this License applies to the Document are reproduced in all copies, and that you add no other 
conditions whatsoever to those of this License. You may not use technical measures to obstruct or 
control the reading or further copying of the copies you make or distribute. However, you may 
accept compensation in exchange for copies. If you distribute a large enough number of copies you 
must also follow the conditions in section 3.

You may also lend copies, under the same conditions stated above, and you may publicly display 
copies. 

A.2.4  3. COPYING IN QUANTITY
If you publish printed copies (or copies in media that commonly have printed covers) of the 
Document, numbering more than 100, and the Document’s license notice requires Cover Texts, you 
must enclose the copies in covers that carry, clearly and legibly, all these Cover Texts: Front-Cover 
Texts on the front cover, and Back-Cover Texts on the back cover. Both covers must also clearly and 
legibly identify you as the publisher of these copies. The front cover must present the full title with 
all words of the title equally prominent and visible. You may add other material on the covers in 
addition. Copying with changes limited to the covers, as long as they preserve the title of the 
Document and satisfy these conditions, can be treated as verbatim copying in other respects.

If the required texts for either cover are too voluminous to fit legibly, you should put the first ones 
listed (as many as fit reasonably) on the actual cover, and continue the rest onto adjacent pages.

If you publish or distribute Opaque copies of the Document numbering more than 100, you must 
either include a machine-readable Transparent copy along with each Opaque copy, or state in or with 
each Opaque copy a computer-network location from which the general network-using public has 
access to download using public-standard network protocols a complete Transparent copy of the 
Document, free of added material. If you use the latter option, you must take reasonably prudent 
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steps, when you begin distribution of Opaque copies in quantity, to ensure that this Transparent copy 
will remain thus accessible at the stated location until at least one year after the last time you 
distribute an Opaque copy (directly or through your agents or retailers) of that edition to the public.

It is requested, but not required, that you contact the authors of the Document well before 
redistributing any large number of copies, to give them a chance to provide you with an updated 
version of the Document.

A.2.5  4. MODIFICATIONS
You may copy and distribute a Modified Version of the Document under the conditions of sections 2 
and 3 above, provided that you release the Modified Version under precisely this License, with the 
Modified Version filling the role of the Document, thus licensing distribution and modification of 
the Modified Version to whoever possesses a copy of it. In addition, you must do these things in the 
Modified Version:

A. Use in the Title Page (and on the covers, if any) a title distinct from that of the Document, and 
from those of previous versions (which should, if there were any, be listed in the History section of 
the Document). You may use the same title as a previous version if the original publisher of that 
version gives permission.

B. List on the Title Page, as authors, one or more persons or entities responsible for authorship of the 
modifications in the Modified Version, together with at least five of the principal authors of the 
Document (all of its principal authors, if it has fewer than five), unless they release you from this 
requirement.

C. State on the Title page the name of the publisher of the Modified Version, as the publisher.

D. Preserve all the copyright notices of the Document.

E. Add an appropriate copyright notice for your modifications adjacent to the other copyright 
notices.

F. Include, immediately after the copyright notices, a license notice giving the public permission to 
use the Modified Version under the terms of this License, in the form shown in the Addendum 
below.

G.  Preserve in that license notice the full lists of Invariant Sections and required Cover Texts given 
in the Document’s license notice.

H. Include an unaltered copy of this License.

I. Preserve the section Entitled “History”, Preserve its Title, and add to it an item stating at least the 
title, year, new authors, and publisher of the Modified Version as given on the Title Page. If there is 
no section Entitled “History” in the Document, create one stating the title, year, authors, and 
publisher of the Document as given on its Title Page, then add an item describing the Modified 
Version as stated in the previous sentence.

J. Preserve the network location, if any, given in the Document for public access to a Transparent 
copy of the Document, and likewise the network locations given in the Document for previous 
versions it was based on. These may be placed in the “History” section. You may omit a network 
location for a work that was published at least four years before the Document itself, or if the 
original publisher of the version it refers to gives permission.
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K. For any section Entitled “Acknowledgements” or “Dedications”, Preserve the Title of the 
section, and preserve in the section all the substance and tone of each of the contributor 
acknowledgements and/or dedications given therein.

L. Preserve all the Invariant Sections of the Document, unaltered in their text and in their titles. 
Section numbers or the equivalent are not considered part of the section titles.

M. Delete any section Entitled “Endorsements”. Such a section may not be included in the Modified 
Version.

N. Do not retitle any existing section to be Entitled “Endorsements” or to conflict in title with any 
Invariant Section.

O. Preserve any Warranty Disclaimers.

If the Modified Version includes new front-matter sections or appendices that qualify as Secondary 
Sections and contain no material copied from the Document, you may at your option designate some 
or all of these sections as invariant. To do this, add their titles to the list of Invariant Sections in the 
Modified Version’s license notice. These titles must be distinct from any other section titles.

You may add a section Entitled “Endorsements”, provided it contains nothing but endorsements of 
your Modified Version by various parties--for example, statements of peer review or that the text has 
been approved by an organization as the authoritative definition of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a passage of up to 25 words 
as a Back-Cover Text, to the end of the list of Cover Texts in the Modified Version. Only one 
passage of Front-Cover Text and one of Back-Cover Text may be added by (or through 
arrangements made by) any one entity. If the Document already includes a cover text for the same 
cover, previously added by you or by arrangement made by the same entity you are acting on behalf 
of, you may not add another; but you may replace the old one, on explicit permission from the 
previous publisher that added the old one.

The author(s) and publisher(s) of the Document do not by this License give permission to use their 
names for publicity for or to assert or imply endorsement of any Modified Version.

A.2.6  5. COMBINING DOCUMENTS
You may combine the Document with other documents released under this License, under the terms 
defined in section 4 above for modified versions, provided that you include in the combination all of 
the Invariant Sections of all of the original documents, unmodified, and list them all as Invariant 
Sections of your combined work in its license notice, and that you preserve all their Warranty 
Disclaimers.

The combined work need only contain one copy of this License, and multiple identical Invariant 
Sections may be replaced with a single copy. If there are multiple Invariant Sections with the same 
name but different contents, make the title of each such section unique by adding at the end of it, in 
parentheses, the name of the original author or publisher of that section if known, or else a unique 
number. Make the same adjustment to the section titles in the list of Invariant Sections in the license 
notice of the combined work.

In the combination, you must combine any sections Entitled “History” in the various original 
documents, forming one section Entitled “History”; likewise combine any sections Entitled 
“Acknowledgements”, and any sections Entitled “Dedications”. You must delete all sections 
Entitled “Endorsements”.
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A.2.7  6. COLLECTIONS OF DOCUMENTS
You may make a collection consisting of the Document and other documents released under this 
License, and replace the individual copies of this License in the various documents with a single 
copy that is included in the collection, provided that you follow the rules of this License for 
verbatim copying of each of the documents in all other respects.

You may extract a single document from such a collection, and distribute it individually under this 
License, provided you insert a copy of this License into the extracted document, and follow this 
License in all other respects regarding verbatim copying of that document.

A.2.8  7. AGGREGATION WITH INDEPENDENT WORKS
A compilation of the Document or its derivatives with other separate and independent documents or 
works, in or on a volume of a storage or distribution medium, is called an “aggregate” if the 
copyright resulting from the compilation is not used to limit the legal rights of the compilation’s 
users beyond what the individual works permit. When the Document is included in an aggregate, 
this License does not apply to the other works in the aggregate which are not themselves derivative 
works of the Document.

If the Cover Text requirement of section 3 is applicable to these copies of the Document, then if the 
Document is less than one half of the entire aggregate, the Document’s Cover Texts may be placed 
on covers that bracket the Document within the aggregate, or the electronic equivalent of covers if 
the Document is in electronic form. Otherwise they must appear on printed covers that bracket the 
whole aggregate.

A.2.9  8. TRANSLATION
Translation is considered a kind of modification, so you may distribute translations of the Document 
under the terms of section 4. Replacing Invariant Sections with translations requires special 
permission from their copyright holders, but you may include translations of some or all Invariant 
Sections in addition to the original versions of these Invariant Sections. You may include a 
translation of this License, and all the license notices in the Document, and any Warranty 
Disclaimers, provided that you also include the original English version of this License and the 
original versions of those notices and disclaimers. In case of a disagreement between the translation 
and the original version of this License or a notice or disclaimer, the original version will prevail.

If a section in the Document is Entitled “Acknowledgements”, “Dedications”, or “History”, the 
requirement (section 4) to Preserve its Title (section 1) will typically require changing the actual 
title.

A.2.10  9. TERMINATION
You may not copy, modify, sublicense, or distribute the Document except as expressly provided for 
under this License. Any other attempt to copy, modify, sublicense or distribute the Document is 
void, and will automatically terminate your rights under this License. However, parties who have 
received copies, or rights, from you under this License will not have their licenses terminated so 
long as such parties remain in full compliance.
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A.2.11  10. FUTURE REVISIONS OF THIS LICENSE
The Free Software Foundation may publish new, revised versions of the GNU Free Documentation 
License from time to time. Such new versions will be similar in spirit to the present version, but may 
differ in detail to address new problems or concerns. See http://www.gnu.org/copyleft/.

Each version of the License is given a distinguishing version number. If the Document specifies that 
a particular numbered version of this License “or any later version” applies to it, you have the option 
of following the terms and conditions either of that specified version or of any later version that has 
been published (not as a draft) by the Free Software Foundation. If the Document does not specify a 
version number of this License, you may choose any version ever published (not as a draft) by the 
Free Software Foundation.

A.2.12  ADDENDUM: How to use this License for your 
documents
To use this License in a document you have written, include a copy of the License in the document 
and put the following copyright and license notices just after the title page:

Copyright (c) YEAR YOUR NAME.
Permission is granted to copy, distribute and/or modify this document
under the terms of the GNU Free Documentation License, Version 1.2
or any later version published by the Free Software Foundation;
with no Invariant Sections, no Front-Cover Texts, and no Back-Cover 
Texts.
A copy of the license is included in the section entitled “GNU
Free Documentation License”.

If you have Invariant Sections, Front-Cover Texts and Back-Cover Texts, replace the “with...Texts.” 
line with this:

with the Invariant Sections being LIST THEIR TITLES, with the
Front-Cover Texts being LIST, and with the Back-Cover Texts being LIST.

If you have Invariant Sections without Cover Texts, or some other combination of the three, merge 
those two alternatives to suit the situation.

If your document contains nontrivial examples of program code, we recommend releasing these 
examples in parallel under your choice of free software license, such as the GNU General Public 
License, to permit their use in free software.
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Glossary

This glossary contains general terms commonly used in Linux and computing.

access permissions
The access permissions define which user group a new user is assigned to and the 
resulting permissions. The access permissions are generally set by the system 
administrator. 

ACL
Access Control List. A set of data that informs a computer's operating system which 
permissions, or access rights, that each user or group has to a specific system object, such 
as a directory or file. Each object has a unique security attribute that identifies which users 
have access to it, and the ACL is a list of each object and user access privileges such as 
read, write, or execute.

ADSL 
Asymmetric Digital Subscriber Line. Transmission procedure that transmits data about 100 
times faster than ISDN in the telephone network.

AGP
Accelerated Graphics Port. High-speed slot for graphics cards based on PCI but offering a 
larger bandwidth. In Contrast, AGP graphics cards can revert directly (without routing 
around the processor) to the random access memory and main memory, to swap graphics 
data there.

ATAPI
Advanced Technology Attachment Packet Interface. Type of CD-ROM drive that is 
connected to an (E)IDE controller. Apart from ATAPI drives, there are SCSI CD-ROM 
drives, handled by a SCSI controller, and proprietary CD-ROM drives that use their own 
controller or are connected to a sound card.

bandwidth
Maximum load capacity of a data channel.

BIOS
Basic Input/Output System. Small component responsible for the initialization of important 
hardware processes. This essential procedure is complete when the boot menu appears 
on the screen.

bookmark
Personal collection of interesting Web page or file references directly accessible in the 
browser.

browser
Program that searches and displays contents. Today it is mostly used for programs that 
graphically display contents of World Wide Web pages.
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client
Workstation in a computer network using the services of a server.

codec
Compressor/Decompressor. A codec is any technology for compressing and 
decompressing data. Codecs can be implemented in software, hardware, or a combination 
of both. Some popular codecs for computer video include MPEG, Indeo, and Cinepak.

command line
Text-based mode of operating in which commands are entered at a prompt. A command 
line can be accessed from within a graphical environment as well as from virtual consoles.

console
Formerly synonymous with terminal. In Linux, there are several virtual consoles that allow 
the screen to be used for several independent, parallel work sessions.

daemon
Disk and Execution Monitor. Program that monitors in the background and comes into 
action when required. Daemons answer FTP or HTTP requests, for example, or control 
activity in the PCMCIA slots.

DDC
Direct Display Channel. Communication standard between the monitor and the graphics 
card which transmits various parameters, such as monitor name or resolution, to the 
graphics card.

DNS
Domain Name System. System that converts name-based addresses to TCP/IP addresses 
and vice versa.

EIDE
Enhanced Integrated Drive Electronics. Improved IDE standard that allows hard disks with 
a size greater than 512 MB. See also IDE.

environment
A shell usually provides an environment in which the user can perform temporary settings. 
These settings include path specifications for programs, the username, the current path, 
and the appearance of prompts. The data is saved in an environment variable. The 
assignment of the environment variables is possible, for example, by means of the 
configuration files of the shell.

environment variable
Position in the environment of the shell. Every environment variable has a name that is 
usually capitalized. The variables are assigned values, such as pathnames.

EXT2
Second Extended File System. Default file system used by Linux.

firewall
Protects a local network or host from unauthorized access from the Internet using various 
security measures.
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free software
See GNU.

FTP
File Transfer Protocol. Protocol based on TCP/IP for transferring files.

GNOME
GNU Network Object Model Environment. User-friendly graphical desktop environment for 
Linux.

GNU
Project of the Free Software Foundation (FSF).The aim of the GNU Project is to create a 
free UNIX-compatible operating system—free not so much in the sense of free of cost, but 
in the sense of freedom: having the right to obtain, modify, and change the software. To 
guarantee the freedom of the source code (the actual program code), every change of the 
original code must be free as well, so modifications of or additions to the original software 
cannot compromise this freedom in any way. The now classic GNU Manifesto (http.//
www.gnu.org/gnu/manifesto.html) explains many aspects of this thinking. In legal terms, 
GNU software is protected by the GNU General Public License or GPL (http.//
www.gnu.org/copyleft/gpl.html) and by the GNU Lesser General Public License or LGPL 
(http.//www.gnu.org/copyleft/lgpl.html).

In connection with the GNU Project, all UNIX tools and utilities are being redeveloped and, 
in part, provided with more or enhanced functionalities. Even complex software systems, 
such as Emacs or glibc, are integral components of the project.

The Linux kernel, subject to the GPL, profits from this project (especially from the tools), 
but should not be seen as the same thing.

GPL
GNU General Public License. See GNU.

home directory
Private directory in the Linux system that belongs to a specific user (usually in /home/
username). Except for the superuser root, only the home directory owner has full access 
rights to his home directory.

hostname
Name of a machine in Linux, usually the name by which it can be reached on the network.

HTML
Hyper Text Markup Language. Most important language used in the World Wide Web for 
designing the contents. The layout commands made available by HTML define how a 
document looks and how it is displayed in a browser.

HTTP
Hyper Text Transfer Protocol. Protocol used between the browsers and Internet servers to 
transmit HTML pages over the World Wide Web.

IDE
Integrated Drive Electronics. Widely used hard disk standard in low-grade and middle-
grade PCs.
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IP address
Numerical 32-bit Internet address, appearing in four decimal series separated by periods 
(for example, 192.168.10.1), which is uniquely assigned to a machine connected to TCP/IP 
networks.

IRQ
Interrupt Request. Request to the operating system carried out by a hardware component 
or a program to assign it processor capacity.

ISDN
Integrated Services Digital Network. Popular digital standard for high-speed data transfer 
over the telephone network.

KDE
K Desktop Environment. User-friendly graphical desktop environment for Linux.

kernel
The central core of any operating system. It manages memory, contains the drivers that 
enable communication with the hardware, and handles processes and tasks. Applications 
run on top of the kernel.

LILO
Linux Loader. Small program installed in the boot sector of the hard disk that can start not 
only Linux but other operating systems as well.

link
Pointer to a file, widely used in the Internet as well as in the Linux file system. In Linux, 
there is a distinction made between hard and symbolic links. Although hard links refer to 
the exact position in the file system, the symbolic link only points to the respective name.

Linux
High performance UNIX-like operating system core distributed freely under the GPL 
(GNU). The name is an acronym (LINUS’ uniX) and refers to its creator, Linus Torvalds. 
Although the name, in a strict sense, refers only to the kernel itself, the popular 
understanding of the term usually includes the entire system.

man pages
Manual Pages. Traditional documentation for UNIX systems, which can be read using the 
man command.

MBR
Master Boot Record. First physical sector of the hard disk from which the content is loaded 
to the main memory and executed by the BIOS. This code then loads either the operating 
system from a hard disk partition or a more sophisticated boot loader, such as LILO.

MD5
Algorithm for generating check sums.

mounting
Insertion of file systems into the directory tree of the system.
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MP3
Very efficient compression procedure for audio files that reduces the size by a factor of ten, 
in contrast to an uncompressed audio file.

NFS
Network File System. Protocol for accessing a file system shared over a network.

NIS
Network Information Service. Centralized data administration system in networks. 
Usernames and passwords can be simultaneously managed network-wide by NIS.

partition
Logical, independent section of a hard disk. Each partition can contain different file 
systems. In Windows, also known as drives.

path
Unique description of a file’s position in a file system.

PCMCIA
Personal Computer Memory Card International Association. An organization consisting of 
companies that have developed a standard for small, credit card-sized devices, called PC 
Cards. Originally designed for adding memory to portable computers, the PCMCIA 
standard has been expanded several times and is now suitable for many types of devices. 
In general, you can exchange PC Cards on the fly, without rebooting your computer. For 
example, you can slip in a fax modem card when you want to send a fax and then, when 
you're done, you can replace the fax modem card with a memory card.

plug-and-play
Automatic hardware component configuration technology. Resources, such as IRQ and 
DMA, are configured and managed separately from the system.

process
Execution of a program by the processor. In Linux, started programs or executable files run 
as processes, often referred to as tasks. Processes can be controlled by commands 
entered in the shell.

processor
Brain of every computer, working through and performing commands given by a user or a 
program in machine language. The processor has control over the entire system and is 
responsible for the actual performance of the computer.

prompt
See command line.

protocol
Standard specifically defined for regulating communication for hardware, software, or 
networks. There is a multitude of these standards. The most common examples are HTTP 
and FTP.

proxy
Most commonly used cache implemented by Internet providers that stores frequently 
requested contents in a database to allow other machines requesting those pages to load 
123



124

    N
ovell C

onfidential
novdocx (E

N
U

)  4 A
ugust 2005

 () () ()Nove
them directly from it. This process not only reduces the time it takes to download this 
information, but also conserves the available bandwidth.

ReiserFS
File system that logs its changes to a journal. Compared to Ext2, this features allows a file 
system to be restored very speedily. ReiserFS is optimized for small files.

root
User undertaking the configuration and maintenance of a complex computer system, such 
as a network. This system administrator is usually the only person who has access to all 
parts of the system (root permissions).

root directory
The base directory of the file system that does not have any parent directory (all other 
directories have a parent directory). In UNIX, the root directory is represented as a slash
(/).

SCSI
Small Computer Systems Interface. Hard disk standard implemented in servers and other 
high-level machines because of its high-speed performance.

shell
Especially flexible command line often equipped with its own specific programming 
language. Examples are BASH, sh, and tcsh.

SMTP
Simple Mail Transfer Protocol. Protocol for transferring e-mails.

SSL
Secure Socket Layer. Encryption procedure for transferring HTTP data.

superuser
See root.

system administrator
See root.

task
See process.

TCP/IP
Internet communication protocol finding increased use in local networks, known as 
intranets.

Telnet
Protocol and command for communicating with other hosts. Normally, the user sees Telnet 
only as a means for logging in to a remote system.

terminal
Designation of a keyboard and monitor combination connected to a central computer. On 
workstations, this term is also used for programs that emulate a real terminal.
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UNIX
Operating system that is widely distributed, mostly on workstations in networks. Since the 
beginning of the 1990s, there has been a freely available version for PCs: Linux.

URL
Uniform Resource Locator. Unique Internet address that contains the type (for example, 
http://) and the name of the host (for example, www.suse.de).

user directory
See home directory.

VESA
Video Electronics Standard Association. Industrial consortium that defines, among other 
things, important video standards.

window manager
Layer that interacts between the X Window System and the user. It is responsible for, 
among other things, the desktop display. There is a wide variety of window managers 
available, one of the more popular ones being kwm for KDE.

WWW
World Wide Web. Based on the HTTP protocol, this is a hyperlinked collection of 
documents, files, and images that can be viewed with a Web browser.

X Window System
Standard for graphical interfaces in Linux. It is the middle layer between the hardware and 
the window manager, such as KDE or GNOME.

X11
See X Window System.

YaST
Yet another Setup Tool. The SUSE LINUX system assistant.
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