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About This Guide

This guide contains information regarding known issues and caveats that affect the installation and
usage of Novell® Nterprise™ Linux Services (NNLS).

Information in this readme is divided into two categories:
+ Known Issues: These are problems that Novell intends to address in future releases.

¢ Caveats: These alert users to functionality that is working as designed but might require
special attention when working with the product.

For planning and installation instructions, see the Novell Nterprise Linux Services Installation
Guide.

For complete information on setting up and using NNLS, see the Novell Nterprise Linux Services
online documentation (http://www.novell.com/documentation/Ig/nnls).

Documentation Conventions

In this documentation, a greater-than symbol (>) is used to separate actions within a step and items
within a cross-reference path.

A trademark symbol (®, ™, etc.) denotes a Novell trademark. An asterisk (*) denotes a third-party
trademark.

When a single pathname can be written with a backslash for some platforms or a forward slash for
other platforms, the pathname is presented with a backslash. Users of platforms that require a
forward slash, such as UNIX*, should use forward slashes as required by your software.

About This Guide 9
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Nterprise Linux Services Issues and Caveats

This section contains information regarding general issues and caveats in Novell® Nterprise™
Linux Services (NNLS). For component-specific information, see the following:.

Service

See

Administration Services

Chapter 8, “iManager,” on page 29

Chapter 13, “Resource Management,” on page 43

File Services

Chapter 7, “Novell iFolder 2.1.2 and Novell NetDrive 4.1,” on page 27
Chapter 12, “Novell NetStorage,” on page 39
Chapter 14, “Samba,” on page 45

Identity Services

Chapter 3, “DirXML Starter Pack,” on page 19
Chapter 5, “eGuide,” on page 23
Chapter 10, “Linux User Management,” on page 33

Chapter 4, “Novell eDirectory 8.7.3,” on page 21

Messaging Services

Chapter 6, “GroupWise Collaboration Client,” on page 25

Chapter 11, “NetMail,” on page 35

Print Services

Chapter 9, “iPrint,” on page 31

Web Experience

Chapter 15, “Virtual Office,” on page 47

Web Server

Chapter 2, “Apache Web Server,” on page 17

To Get the Latest Issues

For information on the latest issues since the release of Novell Nterprise Linux Services, see the
Novell Technical Information Database (http://support.novell.com/cgi-bin/search/searchtid.cgi?/

348509.htm) on the Web.

Testing Notes

Novell has tested NNLS on the supported Red Hat* and SuSE* platforms with all the vendor
patches that were released through October 31, 2003.

Nterprise Linux Services Issues and Caveats 11
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Source Files for Open Source Components

Source files for the Open Source components of Novell Nterprise Linux Services are available for
download at the following location:

http://forge.novell.com/modules/xfmod/project/?nnls (http://forge.novell.com/modules/xfmod/
project/?nnls).

Linux Server Requirements Must Be Met

Before installing NNLS, you must ensure that the target server meets the specific software,
hardware, and configuration requirements outlined in the “NNLS Planning Worksheet” in the
Novell Nterprise Linux Services Installation Guide.

The points summarized in the following sections are particularly important.

The Server Must Have a Static IP Address

You must assign the server a static IP address prior to installing NNLS.

The /etc/hosts File Must Contain an Entry for the Server

Installation

Known Issues

NNLS products must be able to resolve the server’s IP address. This involves checking and
possibly changing the /etc/hosts file as described in “Check /etc/hosts Before Installing NNLS” in
the Novell Nterprise Linux Services Installation Guide.

This section contains known issues and caveats pertaining to the NNLS installation processes.

If the NNLS Install Fails or Is Interrupted

During the information-gathering phase of the installation, you can terminate the installation
anytime by pressing Ctrl+C.

If you are installing into an existing tree and the install is interrupted, the NNLS install will not
allow you to reinstall products you were installing at the time of the interruption. You must first
remove these products prior to running the installation again.

To remove the products, complete the following steps:

1 Use iManager (or ConsoleOne®, LDAP Browser, etc.) to remove all Novell eDirectory™
objects associated with the failed NNLS server install from the target tree.

2 Run the NNLS install with the uninstall option to remove the products.

NOTE: You can also remove eDirectory from the NNLS server outside of the NNLS install using the / usr/
sbi n/ nds- uni nstal | command at a shell prompt.

12 Novell Nterprise Linux Services Readme
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Error: Unable to Determine Universal Password Status
This error appears when the eDirectory installation is not completed as instructed in “Installing or
Upgrading Novell eDirectory on Linux” in the Novell eDirectory 8.7.3 Installation Guide.

You Must Specify Typeful Admin Names

When installing NNLS, you must enter a fully distinguished admin name using the typeful syntax
that includes object type abbreviations (cn=. ou=. o=. etc.). For example, you might enter
cn=admin.ou=myorganization.o=mycompany.

Use Dot-Delimited Input for All Products

For all parameters requiring full contexts, we recommend that you separate the names using dot-
delimited syntax. Separate the fields using periods (.) rather than commas (,).

The NNLS installation routines convert the name separators to commas when this is required by
individual product components.

IMPORTANT: After the NNLS products are installed, be sure to follow the conventions specified in the
documentation for each product. Some contexts must be specified using periods (.) and others using commas

(.)-

iManager Problems When Running the Configure Servlet

iManager freezes or reports an out of memory error when running the configure servlet zost:/nps/
servlet/configure.

This occurs when DirXML® is installed on the host machine more than once. An errant self-
referential symbolic link is created in the /usr/lib/dirxml/rules/precfg directory.

To fix this problem, remove the symbolic link precfg located in the /ust/lib/dirxml/rules/precfg
directory.

Caveats

Red Carpet Installation Requires Internet Connection

If you do not have Internet connectivity when the install tries to perform the Red Carpet™
configuration, the configuration will fail and the install will report that Red Carpet was not
installed. After you have re-established the Internet connection, uninstall Red Carpet and then
reinstall it.

Stop RPM Management Programs before Installing

RPM management programs that lock the database, such as Synaptic, should be stopped before
running the install.

Server Time Must Be Synchronized prior to Installing NNLS

If you are installing NNLS into an existing eDirectory tree, or if you plan to install NNLS on
multiple servers using the same eDirectory tree, you must ensure that the system time on each
server is synchronized prior to installing NNLS.

Information on setting up NTP support on Linux is available in various locations on the Web, such
as the Red Hat Web site (http://www.redhat.com/docs/manuals/linux).

Nterprise Linux Services Issues and Caveats 13
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For more information on this and other planning tasks, see ‘“Preparing to Install Nterprise Linux
Services” in the Novell Nterprise Linux Services Installation Guide.
If Server Time Is Not Synchronized prior to Installing NNLS

If server time is not synchronized when eDirectory is installed, the NNLS installation script
(uninstall option) cannot uninstall eDirectory.

You must then enter the following command in a shell script on the server:

[ usr/ sbi n/ nds-uni nst al |

Gettext Not Found Error Occurs During eDirectory Install

eDirectory uses gettext to translate messages in its init scripts. If gettext is not found on your
system, you receive the following error during the installation:

gettext: conmmand not found
However, installation is unaffected and will succeed.

In addition, there might be messages that would normally be displayed when running eDirectory
init scripts that are not displayed.

Post-Install

There are no known post-install issues or caveats.

General Issues

This section contains information on known issues that affect the general operation of NNLS after
it is installed and initially configured.

NNLS Man Pages Not Working on SuSE

To enable most of the NNLS man pages to work as expected on a SuSE machine, you must do the
following after installing and starting NNLS:

1 Log out.
2 Log back in again.
NOTE: A few of the NNLS man pages require exporting the MANPATH variable as explained in NNLS Man

Pages in /opt/novell/man Not Accessible below.
NNLS Man Pages in /opt/novell/man Not Accessible

Some NNLS man pages are installed in /opt/novell/man and are not automatically accessible from
a shell prompt.

To make the pages visible in the current shell and its child processes, you must do the following:
1 While logged in as the root user, enter the following command at the system prompt:

export MANPATH=$MANPATH: / opt / novel | / man

14 Novell Nterprise Linux Services Readme



Ending a URL with oneNet Returns an Internal Server Error

Experienced NetWare® users might be accustomed to entering URLs that end with oneNet. With
the release of NetWare 6.5, these URLs became obsolete.

For example, Novell NetStorage now runs in a shared instance of the Apache Web server. To
distinguish it from other applications running on the server, you must add NetStorage to the
address that was previously used as follows:

¢ For the folder view, enter ht t ps: // | P_addr ess/ Net St or age
¢ For the text view, enter ht t ps: / /| P_addr ess/ oneNet / Net St or age

where IP_address is the IP address of the NNLS server you are accessing.

For a list of all the service URLs in NNLS, refer to “Quick Reference to NNLS User Services” in
the Novell Nterprise Linux Services Overview, Planning, and Implementation Guide.

General Caveats

eDirectory Authentication Settings Default to a Single Server

To facilitate the installation of the first server in a new tree, the installation script uses the
eDirectory information you have entered as the default for each eDirectory parameter that follows.

This also applies when you are installing NNLS into an existing eDirectory tree.

After you have installed a service, if you need to change the eDirectory authentication
configuration, see “Modifying Service Authentication Settings Created by the NNLS Installation”
in the Novell Nterprise Linux Services Overview, Planning, and Implementation Guide.

Nterprise Linux Services Issues and Caveats 15
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Apache Web Server

The section contains the known issues for the Apache Web server running on Novell® Nterprise™
Linux Services (NNLS).

Known Issues

Apache Process Might Not Start

In rare cases Apache is not starting properly after rebooting the server. Because other NNLS
products, such as iFolder and Virtual Office, depend on Apache, they are also affected.

This issue is related to the use of the Apache /etc/init.d/novell-httpd stop command. After issuing
this command, a wait period of 20 seconds is allowed to pass, giving time for all processes to
terminate before shutting down.

However, if any processes do not terminate before the specified 20 seconds, a kill -9 occurs.
Apache creates a PID file that is used to track processes that are still running. The kill -9 command
bypasses Apache's normal cleanup process, which results in the PID file being left on the disk
rather than being deleted as it would be during a normal shutdown.

Ultimately, the PID file might contain an already running value. After the server is rebooted, the
PID file is read, indicating falsely that Apache is already running.

You can verify if your server is encountering this problem by opening the /var/log/boot.log file and
searching for some part of the following text strings:

/etc/init.d/ novell-httpd: Starting Apache:
[etc/init.d/ novell-httpd: httpd (pid 1121) already running

To resolve this issue, delete the /var/opt/novell/httpd/run/httpd.pid file and then enter / et ¢/
init.d/ novell-httpd start ata shell prompt.

Apache Web Server 17
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DirXML Starter Pack

This section provides known issues and caveats regarding the DirXML® Starter Pack component
of Novell® Nterprise™ Linux Services.

Caveats

Novell Client 4.83 SP1 or Later Is Required

The DirXML Password Sync agent for Windows 2000 and Windows NT requires the Novell
Client™ 4.83 SP1 or later. You can get the client at http://download.novell.com (http://
download.novell.com).

DirXML Starter Pack 19
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Novell eDirectory 8.7.3

This section contains known issues when using Novell® eDirectory™ 8.7.3 with Novell
Nterprise™ Linux* Services. For additional Novell eDirectory 8.7.3 information, refer to the
Readme (http://www.novell.com/documentation/Ig/edir873/readme/readme.txt) located with the
eDirectory 8.7.3 online documentation (http://www.novell.com/documentation/lg/edir873/
index.html).

NMAS Issues

For NMAS™ information, refer to the Security Services Readme (http://www.novell.com/
documentation/lg/nmas23/readme/security readme.html) located with the NMAS 2.3 online
documentation (http://www.novell.com/documentation/lg/nmas23).

Certificate Server Issues

NICI Issues

For Certificate Server information, refer to the Security Services Readme (http://www.novell.com/
documentation/lg/nmas23/readme/security readme.html) located with the Novell Certificate
Server™ 2.7 online documentation (http://www.novell.com/documentation/lg/crt27).

For NICI information, refer to the Security Services Readme (http://www.novell.com/
documentation/lg/nmas23/readme/security readme.html) located with the NICI 2.6.x online
documentation (http://www.novell.com/documentation/lg/nici20).

Configuring SLP

If NNLS detects OpenSLP, it will not install the Novell SLP daemon. In either case, installing
NNLS does not configure the Service Location Protocol. Be sure to configure SLP to point an
appropriate DA. For more information, see Configuring OpenSLP for eDirectory in the Novell
eDirectory 8.7.3 Administration Guide. Failure to configure SLP will cause problems. For
example, the rename of a tree will fail to complete because the server must check to see that the
new tree name is not in use.

Novell eDirectory 8.7.3 21
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Merging Novell eDirectory Trees

There is a possibility that you will see the following error when attempting to merge two NNLS
trees:

“The source tree root partition cannot do a merge right now due to DS:
ERR_PARTITION BUSY. Either wait for the operation to complete, or try to fix it with
DSREPAIR tool. And then run this operation again.

An error occurred while preparing the source tree partitions for merging.
Merge Unsuccessful.”

To resolve this error, do one of the following:

+ Wait for eDirectory to perform a Reference-Check and Purger operation on the source tree
server.

+ Start the Reference Check and Purger processes using the agent triggers in iMonitor.
In most cases, the merge will complete at this point.

For more information, see “Merging Novell eDirectory Trees” in the Novell eDirectory 8.7.3
Administration Guide.

Creating User Objects or Moving Partitions in iManager

22

When creating User objects or moving partitions in iManager, you might receive the following
error:

“(Error -601) The object name entered could not be found in the context specified.”

Although this message indicates that the creation has not completed, the operation most likely will
complete successfully. The creation and verify (after creation) operations are not being served
from the same replica. The user is created in replica A, but replica B is immediately queried.
Because the change has not been received by replica B, the -601 error is reported.

We recommend that you verify the creation or move before performing other tasks.
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eGuide

For Novell® eGuide 2.1.2 issues, see the Readme (http://www.novell.com/documentation/lg/
eguide212/readme/eguide readme.html) located with the Novell eGuide online documentation.

eGuide 23
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GroupWise Collaboration Client

This section describes known issues and caveats for the GroupWise® Collaboration Client
component of Novell® Nterprise™ Linux Services (NNLS).

Known Issues

Adding a Startup Switch to Go to Remote Mode

The GroupWise Collaboration Client works in Remote mode only. To open the client in Remote
mode each time you double-click the desktop shortcut, you must add the /pr-
path_to_remote_mailbox startup switch to the Target field in your desktop shortcut. Otherwise,
you need to select Remote Mailbox Path each time you start the client.

Calendars of GroupWise and Other IMAP4 Accounts Do Not Synchronize

Calendar entries (appointments and so forth) between GroupWise and other IMAP4 accounts (for
example, NetMail™) do not synchronize, so you can view calendar information only in the account
where it was entered.

Find Does Not Locate Items Downloaded As Header Only

When items have been downloaded as Header Only, these items are not searched by Find or
displayed in Find results.

Posted Items Created As Group Items in IMAP4 Folders

Posted items (appointments, tasks, reminder notes, and mail messages) created in IMAP4 account
folders are displayed as group items and not as posted items.

Reply Privately (Outside Discussion) To Field Displays Incorrectly

If this option is selected with a posted task or appointment, the To field displays $$$.$$$.$$$.

Printed Items Show Incorrect Username Information

Printed items from IMAP4 folders show $$$ in the header instead of the username.

Shared IMAP4 Folders Allow Unsupported Sharing

The option to share an IMAP4 folder with a user outside of the IMAP4 server is not functional
although it is selectable.
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Caveats

Unsupported Features

Because this client will generally be running against a NetMail back end and not a GroupWise
back end, some functionality in the user interface is not supported. Unless you run this client
against a GroupWise back end, the following GroupWise functionality is not supported:

*

*

*

*

Document Management
GroupWise Client Rules (although NetMail rules that are set up in NetMail are supported)
GroupWise Messenger
Junk Mail Handling

Notify

Online and Caching Modes
Proxy

Conceal Subject

Routing Slip

Shared Address Books
Status Tracking

Subscribe/Unsubscribe Dialog Box Search Field

26

The search field in the Subscribe/Unsubscribe dialog box is case sensitive.
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Novell iFolder 2.1.2 and Novell NetDrive 4.1

For Novell® iFolder® 2.1 issues, see the Readme located with the Novell iFolder online
documentation (http://www.novell.com/documentation/lg/ifolder21/index.html).

For Novell NetDrive 4.1 issues, see the Readme located with the Novell iFolder online
documentation (http://www.novell.com/documentation/lg/ifolder21/index.html).
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iManager

This section describes known issues and caveats for the iManager component of Novell®
Nterprise™ Linux Services (NNLS).

Known Issues

iManager Product Readme

For all Novell iManager issues, see the Readme (http://www.novell.com/documentation/lg/
imanager20) included with the Novell iManager documentation.

Create Home Directory Not a Linux Feature

If you select the Create Home Directory option when creating a user in iManager, a home directory
is not created on the NNLS server. This is because the option applies only to NetWare® volumes.

However, a home directory is automatically created for Linux User Management (LUM) users
when they log in to the NNLS server for the first time.

Browsing for NetStorage Objects with Netscape or Mozilla Browsers

Caveats

If you are using a Netscape® or Mozilla browser and attempt to browse to a location object in the
StorageLocation: Create/Modify List submenu, the selected object does not show up in Storage
Location Objects. The object appears to be selected but is not visible. The temporary workaround
is to use another browser, or to use a Netscape or Mozilla browser knowing that the object is
selected even though you can’t see it.

Pop-Ups Must Be Enabled

For iManager wizards and help to work, you must enable pop-up windows in your Web browser
while working in iManager. If you use an application that blocks pop-up windows, you must
disable the blocking feature while working in iManager.

If you manage your server using a Mozilla browser, you must enable pop-up windows by
completing the steps for your browser type.

Mozilla Web Browser

To enable pop-up windows in a Mozilla 1.4 and later Web browser:

1 Open the Mozilla Web browser.
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2 Click Edit > Preferences.
This opens the Preferences dialog box.
3 In the Category navigator, click Privacy & Security > Pop-up Windows.
4 Disable Block Unrequested Pop-ups by unchecking its check box.
5 Click OK.

Mozilla Firebird Browser

To enable pop-up windows in a Mozilla Firebird 0.6.1 and later Web browser:
1 Open the Mozilla Firebird Web browser.
2 Click Tools > Options.
This opens the Options dialog box.
3 In the left navigator, click Web Features.
4 Disable Block Pop-up Windows by unchecking its check box.
5 Click OK.

Security Alert Message

30

When accessing iManager or using some iManager plug-ins, a security alert appears in your
browser stating that the Certificate is not trusted. This happens because the Apache Web server is
using a self-signed certificate created by the NNLS install. The message is informational. You can
choose to proceed and use iManager, view the certificate and install it into the browser’s
Certificate Store to permanently trust it, or choose not to trust it, in which case you cannot use
iManager. You could also configure Apache to use your own trusted certificate (if you have one).
To increase security, it is recommended that you do not run with a self-signed certificate for very
long.

For additional information on how to configure Apache to use your trusted certificate, see the
Apache documentation at the Apache Web site (http://httpd.apache.org/docs-2.0).

Novell Nterprise Linux Services Readme


http://httpd.apache.org/docs-2.0

iPrint

The following are known issues for iPrint running on Novell® Nterprise™ Linux Services.

Known Issues
Removing Port 443 before Creating Objects

When using Mozilla to create iPrint Driver Store or Manager objects in Novell iManager, you must
remove port 443 from the eDir Server field; otherwise, iManager cannot create the object.
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Linux User Management

This section describes known issues for the Linux User Management component of Novell®
Nterprise™ Linux Services (NNLS).

Known Issues

Uninstall Error: NAM Is Not Deconfigured

If you uninstall Linux User Management (LUM) and see this error:
1 Delete the /etc/nam.conf file.
2 Run install.sh again to uninstall Linux User Management.

3 (Conditional) If the target eDirectory tree still exists, launch iManager and remove the UNIX
Workstation object associated with the NNLS server.

LUM Doesn’t Track Renamed Objects

Linux User Management tracks where the UNIX Config object resides using the /etc/nam.conf
file. By default, this is the Organization object you specify during installation.

If you rename any of the container objects that define the context for the UNIX Config object, the
changes are not reflected in the configuration file and Linux User Management stops working.

To resolve this issue:
1 Open /etc/nam.conf in a standard UNIX ASCII editor, such as vi.
2 Find the line that begins with base-name=.
3 Modify the directory context to reflect the renamed objects.

For example, if you have placed the UNIX Config object in an Organization Unit object
named test in the Organizational object named novell, you would specify the base-name value
using comma-delimited syntax as follows: base-name=ou=test,o=novell.

4 Save the file.
5 Restart LUM using the following commands:

/etc/init.d/ nancd stop
/etc/init.d/ nancd start
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LinuxUserManagement Module in iManager Does Not Get Installed when RBS Is
Installed

The LinuxUserManagement module depends on the iManagerBase module being enabled first.
Currently, iManager does not have a way to specify this type of dependency, so the module won’t
be installed when Role-Based Services (RBS) in iManager are installed.

To work around this, unselect the LinuxUserManagement plug-in when RBS is first enabled.
Then return and select the plug-in by itself.
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This chapter provides known issues and caveats regarding the NetMail™ component of Novell®
Nterprise™ Linux* Services.

Known Issues

Upgrading to NetMail 3.5 from Previous Versions of NetMail

Customers with existing NetMail systems should not install NetMail 3.5 using the Nterprise Linux
Services installation. For specific instructions on upgrading an existing NetMail system to
NetMail 3.5, see Upgrading to NetMail 3.5 in the NetMail 3.5 Administration Guide (http://
www.novell.com/documentation/beta/netmail35/netmail35/data/bou06jd.html).

Installing NetMail 3.5 to Multiple Servers

Customers installing NetMail 3.5 to multiple servers should only use the Nterprise Linux Services
installation to install NetMail 3.5 to the first server in the tree. For specific instructions on
installing NetMail 3.5 to subsequent servers in the tree, see Installing NetMail 3.5 on Multiple
Servers in the NetMail 3.5 Administration Guide (http://www.novell.com/documentation/beta/
netmail35/netmail35/data/bou0iaS.html).

Can’t Log In to NetMail After Install

If you do not reboot the server or restart NetMail after a new install, sometimes users are not able
to login to WebAccess or WebMail.

To resolve this, stop NetMail using the following command:
/etc/init.d/ novell-netmail stop
Then restart NetMail using the following command:

/etc/init.d/ novell-netmail start

NMAP User Contexts Default to the Server Context

During install, the user context for the NMAP Agent defaults to the same context as the messaging
server’s assocated NCP Server object. After install, the NMAP Agent’s user contexts can be
modified using WebAdmin.

IMPORTANT: When you add, modify, or remove contexts to the NMAP Agent, you must restart the
messaging server to effect your changes.
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Mozilla Browsers

If you enter incorrect login information when using a Mozilla browser to access WebAccess or
WebMail, the login dialog box doesn’t display again. You must either refresh the window or re-
enter the URL.

If you click the Log In Again link after logging out of WebAccess or WebMail, you are taken to
the logged-out page. You must start a new browser to get to the login prompt.

GroupWise Client Issues

There is no synchronization of user calendars between the NetMail server and the GroupWise®
client. Therefore, busy searches against users who have previously accepted appointments in the
GroupWise client do not return the users’ accepted appointments.

Accessing WebAdmin Through iManager

Caveats

When iManager attempts to access WebAdmin from a remote machine, a misconfigured IP
address on the WebAdmin configuration object can result in the host not being found.

This could occur during the WebAdmin installation, when an attempt is made to store the IP
address of the server on the ncp server name Web Administration Object, where ncp server name
is the name of the server. If the IP address can not be properly resolved, this address defaults to
127.0.0.1.

NOTE: By default, WebAdmin is installed on the iManager server.
To correct this, perform the following steps in iManager:
1 Click the View Objects button @ on the iManager toolbar.
2 In the Object view, select the Web Administration Server object.
NOTE: The object is named server_name Web Administration Server.
3 Select Modify Object from the Task list.
The configuration window displays the object’s attributes.
4 Seclect the WebAdminAddress attribute, then click edit.

8 Change the IP address in the WebAdminAddress attribute to the address of the WebAdmin
server.

IMPORTANT: If you modify attributes in multiple tabs, you must click Apply in each page to save your
changes.

6 When finished, click OK.

Calendaring Issues

When addressing calendar items (appointments, tasks, and notes), always use the recipients’ login
name and official domain name (for example, user login_id@domain_name). This allows the
sender to receive status information. If you address a calendar item using a user’s alias or hosting
domain, you cannot view which recipients have accepted or declined the calendar item.
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Spaces in NetMail NDS Object Names

To comply with SMTP standards defined in RFC 2821, resources, users, groups, and
organizational roles cannot have spaces in their names. The Modular Web clients, WebAccess and
WebAdmin, treat the space as a separator character between addresses. Other e-mail clients either
treat the space as a separator character or remove the space.
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Novell NetStorage

This section contains information regarding known issues when using Novell® NetStorage with
Novell Nterprise™ Linux* Services.

Known Issues

Logging In As a Different User

If you are using Windows* 98 and Internet Explorer and, after logging in to Novell NetStorage
you intend to log in again as a different user, you must first delete Internet Explorer cookies and
log out from Windows 98 or you will not be able to log in again. This is necessary because
Windows 98 retains user information, and NetStorage cookies are created that are user specific.

When using Windows 2000 and Microsoft* Web Folders, you must enable the Launch Folder
Windows in a Separate Process option:

1 Double-click My Computer, then click Tools > Folder Options > View.
2 Check the Launch Folder Windows in a Separate Process check box.

For all versions of Windows and Internet Explorer, configure Internet Explorer to prompt for
username and password:

1 Click Tools > Internet Options > Security > Custom Level.

2 In the User Authentication Setting section, click Prompt for Username and Password, then
click OK twice.

Internet Explorer Unable to Open Some Web Folders
If you use Microsoft Web Folders with NetStorage to create a new folder, you might not be able
to open that folder using Internet Explorer.

Character Set Issues with Netscape

If you use the Netscape browser to open NetStorage, square boxes might display in place of some
characters. To resolve this, click View > Character Set > Unicode (UTF-8), then click View >
Character Set > Set Default Character Set.

Storage Location Objects Required

After installing NetStorage, you might be able to see only your iFolder directory and a local shared
directory on the Linux server using NetStorage. The local shared directory contains a Readme file
with more NetStorage-specific information.
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Storage Location objects are required for accessing files and directories on Linux servers. Users
might have specific Novell eDirectory™ rights to certain files and folders on your network but
cannot access those files and folders using NetStorage unless Storage Location objects have been
created.

To create a Storage Location object:

1 Open your browser (Internet Explorer 5 or later, Mozilla, etc.) and specify the URL for
iManager.

The URL is http://server_ip_address/nps/iManager.html. Replace server ip address with the
IP address or DN'S name of the Linux server running NetStorage or the IP address for Apache-
based services.

2 Type your username and password.

3 In the left column, click File Access and then click Storage Location: Create.

4 Specify the object name, display name, directory location, context, and an optional comment.
¢ The object name is the name of the object in the eDirectory tree.

¢ The display name is the name to be displayed in the NetStorage directory access list. This
is the shortcut name and is seen by users. If you use the same display name for two
different Storage objects, a digit is added to the names to make each name unique.

¢ The directory location is the location of the directory on the file system. The location is
a URL that includes the file system type, server name, volume, and directory path.

If the storage being accessed is on a NetWare server, the URL must be in the following
format:

ncp://server_namel/volumelpath_to_directory
For example:
ncp://serverl.digitalair.com/mktg/reports

or

ncp://111.222.3.4/mktg/reports

If the storage being accessed is on a Linux server, the URL must be in the following
format:

cifs://server_namelcifs _share _name

If the file system is omitted, it is assumed that it is a NetWare® Core Protocol™ (NCP™)
system.

¢ The context is the directory context that the Storage Location object resides in. Click the
object selector to select the context.

¢ The comment is written by the administrator and is not displayed to users.

8 Click Create, then click OK.

After you create a Storage Location object, you must create a list of Storage Location objects that
can be used with a specified User, Group, Profile, or Container object. Users see the directory
associated with the object the next time they log in. After this list is created, you can modify it from
the same window by assigning additional Storage Location objects to the list or by deleting
Storage Location objects from the list.
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1 Open your browser (Internet Explorer 5 or later, Mozilla, etc) and specify the URL for
iManager.

The URL is http://server_ip_address/nps/iManager.html. Replace server ip address with the
IP address or DN'S name of the Linux server running NetStorage or the IP address for Apache-
based services.

2 Enter your username and password.
3 In the left column, click File Access, and then click Storage Location: Create/Modify List.

4 Click the Object Selector button; select the User, Group, Profile, or Container object that the
list is to be created for; then click OK.

85 Click the Object Selector button, select the Storage Location objects you want included in this
list, then click OK.

You can select multiple Storage Location objects in the Object Selector window. When you
select multiple Storage Location objects, they appear in the Selected Objects list. If the list
already contains Storage Location objects and you want to add more, ensure that the original
objects are still in the list before clicking OK.

You can remove existing storage locations by deleting their names from the list before
clicking OK.

6 When you are finished creating or modifying the list, click OK.

See the NetStorage Administration Guide for more information on NetStorage and Storage
Location objects.

NetStorage Authentication Domain Allows More Than One Primary

On the Authentication Domain submenu of iManager, a missing check mark allows multiple
primary domains to be specified. There should only be one primary domain. The temporary
workaround is to click the Make Primary button on the domain you want to be the primary, wait
for the domain to become the primary, then click the same Make Primary button again.

NetStorage URL Not Saved In Virtual Office Services Administration

With some browsers (including Mozilla 1.5, Internet Explorer 6.1 SP1, and Netscape 7.01 and
7.02), the URL you enter for your NetStorage Web page in the Virtual Office Services
Administration plug-in does not save. If the URL you enter is not saved, try a different browser.
Internet Explorer 6 and Netscape 7.1 are known to work.

NetStorage and iManager Required to Be on Same Server

In order to use iManager to manage NetStorage, iManager must be installed on the same server as
NetStorage.

If you do not have iManager installed on the same server as NetStorage, use one of the following
workarounds:

+ Install iManager on each server where NetStorage is installed and point your browser to the
IP address or URL of that server when you want to make NetStorage changes.

+ Contact NetStorage directly from your browser, and not use iManager. Not all NetStorage
configuration options can be performed using this method. For example, you cannot create
storage location objects using this method. The URL for this method is http://ip address or
DNS name of server/oneNet/nsadmin.
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User File Access Link in iManager to Access NetStorage Configuration

The link in iManager to make NetStorage configuration changes and to create Storage Location
objects has changed from NetStorage Administration to File Access.
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Resource Management

This section contains known issues and caveats pertaining to the Novell® Resource Management
components included in Novell Nterprise™ Linux Services.

Known Issues

Red Carpet Daemon Version Support

The Resource Management snap-in does not support Red Carpet™ Daemon version 2 or later.

Cannot Access Resource Management in iManager

The Resource Management iManager plug-in connects to WebAdmin. When iManager attempts
to access WebAdmin from a remote machine, a misconfigured I[P address on the WebAdmin
configuration object can result in the host not being found.

This could occur during the WebAdmin installation, when an attempt is made to store the IP
address of the server on the ncp server name Web Administration Object, where ncp server name
is the name of the server. If the IP address can not be properly resolved, this address defaults to
127.0.0.1.

NOTE: By default, WebAdmin is installed on the iManager server.
To correct this, perform the following steps in iManager:
1 Click the View Objects button @ on the iManager toolbar.

2 In the Object view, select the Web Administration Server object.

NOTE: The object is named server_name Web Administration Server.
3 Seclect Modify Object from the Task list.
The configuration window displays the object’s attributes.
4 Sclect the WebAdminAddress attribute, then click Edit.
5 Change the IP address in the WebAdminAddress attribute to that of the WebAdmin server.

IMPORTANT: If you modify attributes in multiple tabs, you must click Apply in each page to save your
changes.

6 When finished, click OK.
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Caveats

SSL Warnings

When using the Resource Management iManager snap-in, SSL warnings are displayed during the
initial iManager login and when you attempt to perform a resource management task. Additional
security warnings are displayed in Internet Explorer when using an IP address to access the

iManager server. To prevent these additional warnings, use a DNS name in place of the IP address.

Web Browser Error during Updates

When updating components used by the Resource Management snap-in, your Web browser might
return an error. If this occurs, Red Carpet continues the install process; however, no progress
updates are displayed. The following list contains components that might cause an error when
updated:

* Apache

+ ceDirectory™
¢ Tomcat

¢ iManager

¢ WebAdmin

Red Carpet Daemon Account

To manage an NNLS server when the server NCP™ object is not available (the server is in a
different tree than the one you are currently logged in to), a Red Carpet daemon account is
required.

To create a Red Carpet daemon account, perform the following at the remote server:

NOTE: If the remote server is an NCP object and the novell-nrm-rcd-link package is installed, this is not
required.

1 Log in as root.
2 Enterrug ua.
3 Specify a username and password.

4 Enter +super user to give the account full access to the Red Carpet daemon.
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Samba

This section describes known issues for the Samba component of Novell® Nterprise™ Linux
Services (NNLS).

Known Issues

Samba Does Not Work Via smbfs for SUSE with Patches

If you try to use the smbfs mount command after installing the patches for SuSE, for example:

//xyz.provo.novell.com/voll /mnt/voll smbfs
noauto,owner,username=Y OUR_USER NAME,uid=500,gid=100 0 0

the mount will succeed, but attempting to copy files from the smbfs share to the local file system
will result in a 0 byte file.

Using the Novell Client 4.9 to Connect to Samba

Users who have the Novell Client™ 4.9 installed cannot map drives to their Samba share on the
NNLS server until they turn off the UNC Path Filter.

1 Right-click the red N in the taskbar, then select NetWare Client Properties.
2 Click the Advanced Settings tab.

3 Scroll down to UNC Path Filter parameter group, click the group entry, then change the setting
to Off.

4 Click OK, then restart Windows.
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Virtual Office

This section describes known issues for the Virtual Office component of Novell® Nterprise™
Linux Services (NNLS).

Known Issues

E-Mail Attachment Might Not Appear

Attachments might not function when the eMail service is configured to use IMAP pointed at a
GroupWise® IMAP provider.

Simultaneous Logout With iChain

In order for Virtual Office to simultaneously log out of iChain®, the iChain accelerator must have
the Forward Authentication Information to Web Server option enabled or be using an LDAP
profile where Allow Authentication through HTTP Authorization and Use Basic/Proxy
Authentication are enabled, or be using OLAC configured to inject user credentials into the
Authorization header.

eGuide Authentication Fails

The eGuide Service does not authenticate against a remote server over SSL.The Virtual Office
home page displays an error message, "Error: Authentication failed: improper configuration.
Please contact your adminstrator." Also, the Advanced Search and Link buttons ask for
credentials. To correct this error, import the correct Trusted Root Certificate into the JVM* on the
server that Virtual Office uses. For detailed instructions on importing the certificate, see “Step Six:
Import the Trusted Root Certificate Configuration” in the eGuide 2.1.1 Administration Guide.

NetStorage URL Not Saved In Virtual Office Services Administration

With some browsers (including Mozilla 1.5, Internet Explorer 6.1 SP1, and Netscape 7.01 and
7.02), the URL you enter for your NetStorage Web page in the Virtual Office Services
Administration plug-in does not save. If the URL you enter is not saved, try a different browser.
Internet Explorer 6 and Netscape 7.1 are known to work.
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