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About This Quick Start Guide

This guide steps you through the following: 

1. Setting up Novell Filr with test users and data on a Windows/Active Directory network. 
2. Briefly exploring Novell Filr administration and user functionality. 

A lab network is the assumed target environment, but the instructions can be adapted for installing 
Filr on a production network if desired. 

 Chapter 1, “Small Versus Large Filr Deployments,” on page 7
 Chapter 2, “Hands-on System Requirements,” on page 9
 Chapter 3, “Downloading Filr Software,” on page 13
 Chapter 4, “Creating Test Users,” on page 17
 Chapter 5, “Preparing Folders and Files,” on page 21
 Chapter 6, “Deploying and Configuring the Filr Appliances,” on page 47
 Chapter 7, “Securing LDAP Communications between Filr and Active Directory,” on page 69
 Chapter 8, “Administering Filr,” on page 77
 Chapter 9, “Using Filr,” on page 101

Audience

This guide is for administrators of Windows/Active Directory networks who want to evaluate Novell 
Filr.

Feedback

We want to hear your comments and suggestions about this guide and the other Filr documentation. 
Please use the User Comments feature at the bottom of each page of the online documentation.

Documentation Updates

For the most recent version of this guide, access it on the Web (http://www.novell.com/
documentation/novell-filr1/filr1_hands-on_w/data/bookinfo.html).

Additional Documentation

For additional Novell Filr documentation, see the Filr Documentation Web page  (http://
www.novell.com/documentation/novell-filr1).
About This Quick Start Guide 5
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1 1Small Versus Large Filr Deployments

Novell Filr can be deployed in the following ways:

 As a Small Deployment: A single, multi-purpose Filr appliance
 As a Large Deployment: At least three separate, single-purpose appliances (Filr, Filrsearch, and 

MySQL)

Either deployment type works for the exercises in this guide, but production environments require 
large deployments, and many production workloads require clustered Filr appliances.

Your First Hands-on Task: Choose a Deployment Type

1 Using the information in this section, choose a deployment type for the hands-on exercises that 
matches your goals for learning about Filr.
For example, if you only have a casual interest in learning about Filr and want to invest the 
minimum time and effort required, a small deployment is the best fit. On the other hand, if you 
think you might want to deploy Filr inside your organization, and you want to investigate what 
that will require, you should probably consider a large deployment.
 Comparison of Deployment Types: The following table summarizes the main differences 

between small and large Filr deployments.

Small Deployment Large Deployment

 Does not support production environments  Supports production environments

 Maximum capacity is

 300 active users

 2,500 folders

 50,000 files

 Supports more than

 300 active users

 2,500 folders

 50,000 files

 Cannot be upgraded to a large deployment, 
and cannot “grow” by leveraging shared, 
external storage

 If shared storage is configured as part of the 
initial configuration, a large deployment can 
“grow” to include multiple, clustered Filr 
appliances.

IMPORTANT: Shared storage is not 
covered in this guide, but a link to that 
documentation is provided.

 Requires downloading two files: the Filr 
appliance and the Hands-on_Filr-
windows.zip file

 Requires downloading four files: the Filr, 
Filrsearch, and MySQL appliances, and the 
Hands-on_Filr-windows.zip file

 Offers a streamlined, quick installation and 
configuration

 Requires a more involved installation and 
configuration
Small Versus Large Filr Deployments 7



 Both Types Are Covered in This Guide: Where different procedures are required, section 
titles begin with “Small Deployment” or “Large Deployment.”
Most of the sections apply to both deployment types. 

2 Continue with Chapter 2, “Hands-on System Requirements,” on page 9.

 Uses only one IP address  Requires three IP addresses

 Cannot access an existing MySQL 
database (all functionality is contained 
within the single appliance)

 Can use an existing MySQL database in 
place of the MySQL appliance provided 
with Filr

Small Deployment Large Deployment
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2 2Hands-on System Requirements

To set up Filr for the hands-on exercises, ensure that your system meets the requirements for your 
deployment type.

 Section 2.1, “Small Deployment: System Requirements,” on page 9
 Section 2.2, “Large Deployment: System Requirements,” on page 10

2.1 Small Deployment: System Requirements

Table 2-1   Small Deployment System Requirements

Item Details

A Windows 2003 R2 or 2008 R2 server that is attached to an Active Directory 
domain. 

Administrative rights on the server.

Software for the Filr appliance (see Section 3.1, “Small Deployment: 
Software,” on page 13)

One of the three virtualization platforms listed in “Filr Server Requirements” in 
the Novell Filr 1.0.1 Installation and Configuration Guide:

 Hyper-V

 VMware

 Xen

The virtualization server should have at least the following resources 
available for the Filr virtual machines:

 12 GB RAM

 125 GB free hard drive space

One IP address on the Active Directory domain network, including:

 DNS host name

 The subnet mask

 The primary gateway IP address

 A DNS server IP address

w
Windows Server

Filr Software

Virtualization Server

Filr

One IP Address on
Your network
Hands-on System Requirements 9



2.2 Large Deployment: System Requirements

Table 2-2   Large Deployment System Requirements

Two Web-based email addresses for receiving invitations and notifications

A Windows workstation for administering the appliances and testing the Filr 
Windows application:

 Enterprise-level (non-home) version of Windows XP, Windows 7, or 
Windows 8

 Joined to your Active Directory domain

 Mozilla Firefox 9, Mozilla Firefox 10, Microsoft Internet Explorer 8, or 
Microsoft Internet Explorer 9 for configuring and managing the 
appliance after the initial setup

 Microsoft Office or LibreOffice

 A Java Runtime Environment (JRE)

Wireless connectivity on your network

At least one mobile device (iOS 5 or later or Android 2.3 or later) that is 
capable of connecting to your network’s wireless connection

Item Details

my-email1@example.com

my-email2@example.com

Two Email Addresses

Windows Workstation

Wireless Connectivity

Mobile Devices

Item Details

A Windows 2003 R2 or 2008 R2 server that is attached to an Active Directory 
domain. 

Administrative rights on the server.

Software for the three Filr appliances: Filr, Filrsearch, and MySQL (see 
Section 3.2, “Large Deployment: Software,” on page 14).

w
Windows Server

Filr Software

Filrsearch Software

MySQL Software
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One of the three virtualization platforms listed in “Filr Server Requirements” in 
the Novell Filr 1.0.1 Installation and Configuration Guide:

 Hyper-V

 VMware

 Xen

The virtualization server should have at least the following resources 
available for the Filr virtual machines:

 18 GB RAM

 250 GB Hard drive free space

Three IP addresses on the Active Directory domain network for the Filr 
appliances, including:

 IP addresses

 DNS host names

 The subnet mask

 The primary gateway IP address

 At least one DNS server IP address

Two Web-based email addresses for receiving invitations and notifications

A Windows workstation for administering the appliances and testing the Filr 
Windows application:

 Enterprise-level (non-home) version of Windows XP, Windows 7, or 
Windows 8

 Joined to your Active Directory domain

 Mozilla Firefox 9, Mozilla Firefox 10, Microsoft Internet Explorer 8, or 
Microsoft Internet Explorer 9 for configuring and managing the 
appliance after the initial setup

 Microsoft Office or LibreOffice

 A Java Runtime Environment (JRE)

Wireless connectivity on your network

At least one mobile device (iOS 5 or later or Android 2.3 or later) that is 
capable of connecting to your network’s wireless connection

Item Details

Virtualization Server

Filr Filrsearch MySQL

Three IP Addresses on
Your network

my-email1@example.com

my-email2@example.com

Two Email Addresses

Windows Workstation

Wireless Connectivity

Mobile Devices
Hands-on System Requirements 11
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3 3Downloading Filr Software

 Section 3.1, “Small Deployment: Software,” on page 13
 Section 3.2, “Large Deployment: Software,” on page 14

3.1 Small Deployment: Software
1 If you don’t already have a Novell account, register for one on the Novell Web site (https://

secure-www.novell.com/selfreg/jsp/createAccount.jsp?).
2 Access the Novell Downloads Web page (http://download.novell.com).
3 Do a keyword search for Novell Filr.

4 In the Results section, click the Novell Filr Evaluation Download button.

5 Continue the download process until you have successfully downloaded the following: 
 Hands-on_Filr-windows.zip
Downloading Filr Software 13
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 The file for your virtualization platform:

6 Continue with Chapter 4, “Creating Test Users,” on page 17. 

3.2 Large Deployment: Software
1 If you don’t already have a Novell account, register for one on the Novell Web site (https://

secure-www.novell.com/selfreg/jsp/createAccount.jsp?).
2 Access the Novell Downloads Web page (http://download.novell.com).
3 Do a keyword search for Novell Filr.

4 In the Results section, click the Novell Filr Evaluation Download button.

VMware Filr.x86_64-version.ovf.zip

Hyper-V Filr.x86_64-version.vhd.zip

Xen Filr.x86_64-version.xen.tar
14 Filr 1.0.1 Hands-on Guide for Windows
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5 Continue the download process until you have successfully downloaded the following:
 Hands-on_Filr-windows.zip

 The files for your virtualization platform:

6 Continue with Chapter 4, “Creating Test Users,” on page 17. 

VMware Filr.x86_64-version.ovf.zip

Filrsearch.x86_64-version.ovf.zip

MySQL.x86_64-version.ovf.zip

Hyper-V Filr.x86_64-version.vhd.zip

Filrsearch.x86_64-version.vhd.zip

MySQL.x86_64-version.vhd.zip

Xen Filr.x86_64-version.xen.tar

Filrsearch.x86_64-version.xen.tar

MySQL.x86_64-version.xen.tar
Downloading Filr Software 15
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4 4Creating Test Users

For information about users and groups in Filr, see “Users and Groups with Filr” in the How Filr 
Works–Overview Guide.

The tasks in this guide involve the test users shown in Table 4-1.

Table 4-1   Test Users to Create

1 Create an ou container named testusers in your AD domain.

First Name Last Name User Logon 
Name

Role in Organization Example 
Password

Home 
Folder

A Red ared Development Supervisor F1lrrock$ Yes

A Pink apink Developer F1lrrock$ No

A Blue ablue IT Supervisor F1lrrock$ Yes

A Green agreen Network Technician F1lrrock$ No

A Yellow ayellow Marketing Supervisor F1lrrock$ Yes

A Orange aorange Marketing Administrative Assistant F1lrrock$ No

A Black ablack Director of Sales F1lrrock$ Yes

A Gray agray Sales Representative F1lrrock$ No

Filr Proxyuser filrproxyuser n/a N0v3llfi!r No
Creating Test Users 17



TIP: Locating the container at the top of the domain isn’t required, but it makes the path shorter 
during the LDAP import.
The use of a separate container simplifies the LDAP import process and the removal of users 
when your evaluation concludes.

2 Create the users listed in Table 4-1 in the testusers container and assign them passwords as 
indicated in the table and shown in the screen shots that follow.
Users are assigned the same password to simplify the evaluation test process.
The password for the proxy user is the “administrative” password used in the examples in this 
guide.
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If the suggested passwords don’t meet your password policy requirements, specify passwords 
that do.

IMPORTANT: Make sure that you deselect User must change password at next login as shown. 
Creating Test Users 19



3 Ensure that you create all of the users.

4 Continue with Chapter 5, “Preparing Folders and Files,” on page 21.
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5 5Preparing Folders and Files

Figure 5-1 illustrates the folders and files that are contained in the zip that you downloaded in 
Chapter 3, “Downloading Filr Software,” on page 13.

Figure 5-1   Hands-on Files and Folders

 Section 5.1, “Unzipping the Exercise Folders and Files,” on page 22
 Section 5.2, “Setting Up the Home_Folders Share,” on page 23
 Section 5.3, “Assigning Home Folders,” on page 31
 Section 5.4, “Setting Up the Other Hands-on Exercise Folders and Files,” on page 34

Drive C:

Your Windows Server

Sales *Mrktg *

personnel

2014.xls

reviews **

salaries **

mpink

2013.doc

projects **

current

future

abc-requ.doc

xyz-requ.doc

Novell_Filr.pdf

quick_starts **

advertising

filr_flyer.pdf

brochures **

revenue

2014.xls

projections **

quotas **

2013.xls

training

** These folders become Net Folders with the implementation of Filr. 

Dev * IS *

w

ablack ***

Home_Folders *

Filr Exercise Folders

Hands-on_Filr-Windows.zip

download
.novell
.com

ablue ***

ared ***

ayellow ***

*** These folders are created by Windows for the users that you create. 

Folders and files are downloaded in the .zip file.

* You create Windows Shares for these. Then later you designate 
   them as Net Folder Servers.
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5.1 Unzipping the Exercise Folders and Files
1 Copy the Hands-on_Filr-windows.zip file that you downloaded in Chapter 3, “Downloading 

Filr Software,” on page 13, to Local Disk (C:) on your Windows server.

2 Right-click the zip file, then select Extract All.

3 Change the extraction path to c:\, then click Extract.
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4 Double click the extracted Filr-Exercise-Folders folder to reveal the five directories used in the 
exercises that follow.

5 Continue with Setting Up the Home_Folders Share.

5.2 Setting Up the Home_Folders Share
 Section 5.2.1, “Configuring Home_Folders Share Permissions,” on page 23
 Section 5.2.2, “Configuring Home_Folders NTFS Permissions,” on page 27

5.2.1 Configuring Home_Folders Share Permissions

1 On the Windows server, click the Windows Explorer icon .
2 Navigate to the Home_Folders folder that you downloaded and extracted in Section 5.1, 

“Unzipping the Exercise Folders and Files,” on page 22.
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3 Share Home_Folders by doing the following:
3a Right click the folder.
3b Click Properties.

3c Click the Sharing tab, then click Advanced Sharing.
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3d Select the Share this folder option, name the share Home_Folders$, then click Permissions.
As you probably know, the dollar sign ($) hides the folder from users browsing the 
network.

4 Configure group permissions by doing the following:
4a Click Remove to remove access by the Everyone group.

4b Click Add.
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4c In the Enter the object names to select field, type Domain Users, then click Check Names.

4d Click OK.
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4e Under Permissions for Domain Users, Allow full control, then click OK > OK.

4f Continue with Configuring Home_Folders NTFS Permissions.

5.2.2 Configuring Home_Folders NTFS Permissions

1 Configure file permissions by doing the following:
1a Click the Security tab, then click Advanced.
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1b Click Change Permissions.

1c Deselect Include inheritable permissions from this object’s parent, then on the warning, click 
Add.
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1d In the Permission entries list, Shift-click to select the two Users entries, then click Remove.

1e Click Add.

1f Type filrproxyuser, then click Check Names.
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1g Click OK.
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1h Allow full control, then click OK > OK > OK > Close.

2 Continue with Assigning Home Folders.

5.3 Assigning Home Folders
1 In Administrative Tools > Active Directory Users and Computers, right-click A Black, then select 

Properties.
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2 Click the Profile tab.

3 Under Home folder, select Connect, then click the Connect drop-down list and select H:.
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4 For the first user, in the To field, type the UNC path to the HOME_Folders share on your 
Windows server, followed by %username%. 
For example, the share path on the Windows server used for the development of this guide is 
\\Windows-DC\Home_Folders$\%username%.

5 Select the string and copy it to the clipboard by using Ctrl+C.
For the second and subsequent users, you can use Ctrl+V to paste the string into the To field.

6 Click OK.
7 Repeat from Step 1 for each of the following users:

 A Blue
 A Red
 A Yellow

8 After configuring the home folders indicated, verify that the home folders have been created by 
accessing the Home_Folders folder in Windows Explorer.
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9 Continue with Setting Up the Other Hands-on Exercise Folders and Files.

5.4 Setting Up the Other Hands-on Exercise Folders and Files
 Section 5.4.1, “Creating Shares and Changing Share Permissions,” on page 34
 Section 5.4.2, “Changing the NTFS Permissions,” on page 39

5.4.1 Creating Shares and Changing Share Permissions

Table 5-1 lists the rest of the Filr exercise folder names and the users to assign full share permissions.

Table 5-1   Share Permission Assignments

Create shares and assign share access by doing the following for each folder listed.

1 In Windows Explorer, right-click one of the four folders in Table 5-1, starting with Dev, then click 
Properties.

Folder Name Users to Assign Full Share Permissions

Dev  ared

 filrproxyuser

IS  ablue

 filrproxyuser

Mrktg  ayellow

 filrproxyuser

Sales  ablack

 filrproxyuser
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2 Click the Sharing tab, then click Advanced Sharing.

3 Select the Share this folder option, then click Permissions.
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4 Click Remove to remove access by the Everyone group.

5 Click Add.
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6 In the Enter the object names to select field, type the users listed in the second column of Table 5-1 
on page 34, separated by a semicolon.
For example, for the Dev folder, type ared;filrproxyuser, then click Check Names to validate 
your entries.

7 Click OK.

8 With Filr Proxyuser selected, under Permissions for Filr Proxyuser > Full Control, select Allow.
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9 Select the other user and assign it Full Control as well.

10 Click OK > OK > Close.
11 Right-click the next folder (skipping Home_Folders), then repeat from Step 1 until all of the 

folders have been shared and secured.
12 Continue with Changing the NTFS Permissions.
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5.4.2 Changing the NTFS Permissions

Table 5-2 lists the Filr exercise folder names and the users to assign full NTFS permissions.

Table 5-2   NTFS Permission Assignments

Adjust NTFS permissions to the Filr_Exercise_Folders folder by doing the following:

1 In Windows Explorer, right-click Filr_Exercise_Folders and select Properties.

2 Click the Security tab, then click Advanced.

Folder Name Users to Assign Full NTFS Permissions

Filr Exercise Folders filrproxyuser

Dev ared

IS ablue

Mrktg ayellow

Sales ablack
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3 Click Change Permissions.

4 Deselect Include inheritable permissions from this object’s parent, then click Add.
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5 In the Permission entries list, select the Users entries, then click Remove.

6 Click Add.
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7 Type filrproxyuser, then click Check Names.

8 Click OK.
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9 Allow full control, then click OK > OK > OK > OK.

10 Double-click Filr-Exercise-Folders.

11 Right-click the Dev folder listed in the right frame, then select Properties.
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12 Click the Security tab, then click Edit.

13 Click Add.
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14 Referring to Table 5-2 on page 39, type the user (object name) to assign full permissions to the 
directory (ared is for Dev), then click Check Names.

15 Click OK.
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16 Allow full control, then click OK > OK.

17 Right-click the next folder name listed in Table 5-2 on page 39, click Properties, then repeat from 
Step 12 on page 44 until full rights have been assigned as indicated in the table.
When all of the folders have been assigned, continue with Chapter 6, “Deploying and 
Configuring the Filr Appliances,” on page 47.
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6 6Deploying and Configuring the Filr 
Appliances

 Section 6.1, “Small Deployment: Deploying and Configuring,” on page 47
 Section 6.2, “Large Deployment: Deploying and Configuring,” on page 52

6.1 Small Deployment: Deploying and Configuring
 Section 6.1.1, “Deploying Filr,” on page 47
 Section 6.1.2, “Configuring the Filr Appliance,” on page 51

6.1.1 Deploying Filr

IMPORTANT: The instructions in this section assume that Filr is being deployed on a VMware 
server. 

If you are deploying Filr on Hyper-V, follow the instructions in “Hyper-V Configuration” in the 
Novell Filr 1.0.1 Installation and Configuration Guide to the point that you power on the appliance. Then 
resume these instructions at Step 5 on page 48.

If you are deploying Filr on Xen, follow the instructions in “Xen Configuration” in the Novell Filr 1.0.1 
Installation and Configuration Guide to the point that you power on the appliance. Then resume these 
instructions at Step 5 on page 48.

1 On a workstation with the vSphere client installed, extract the Filr.x86_64-version.ovf.zip 
file that you downloaded in Chapter 3, “Downloading Filr Software,” on page 13 until you have 
a folder containing three files with .mf, .ovf, and .vmdk extensions.

2 Using the vSphere client, attach to your VMware ESX server, then click File > Deploy OVF 
Template.
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3 Browse to and open the Filr .ovf file, then proceed through the various dialogs as you normally 
would until the virtual machine is deployed.

4 Edit the virtual machine settings and add a 100 GB hard disk.

5 After the hard disk has been added, click Power on the virtual machine.
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6 After the appliance starts, accept the license agreement. 
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7 Complete the initial configuration settings, substituting the IP address and other settings that 
you identified in Chapter 2, “Hands-on System Requirements,” on page 9 for the Filr appliance 
on your network.

IMPORTANT: Ensure that the Time Zone settings match the settings of your Windows 
environment.

For example, the following screen shows the IP addresses and the other information that was 
used for the Filr appliance that was deployed in a private network when this guide was 
developed.

8 Proceed through the screens, accepting the defaults, until the configuration process completes.

9 Continue with Configuring the Filr Appliance.
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6.1.2 Configuring the Filr Appliance

1 In your management browser, enter the following URL: https://Filr-appliance-IP-
address:9443.

2 Click through the security warnings and accept the certificate if needed. 
3 Log in with Username: vaadmin and the password you set in Step 7 on page 55.

4 Click the Novell Appliance Configuration icon.

5 Ensure that Small Deployment is selected, then click Next.
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6 Specify and confirm N0v3llfi!r as the root password.

7 Click Finish.

8 Skip to Chapter 7, “Securing LDAP Communications between Filr and Active Directory,” on 
page 69.

6.2 Large Deployment: Deploying and Configuring
 Section 6.2.1, “Deploying Filr,” on page 53
 Section 6.2.2, “Deploying Search,” on page 56
 Section 6.2.3, “Deploying MySQL,” on page 58
 Section 6.2.4, “Configuring the MySQL Appliance,” on page 60
 Section 6.2.5, “Configuring the Search Appliance,” on page 63
 Section 6.2.6, “Configuring the Filr Appliance,” on page 65

IMPORTANT: The instructions in this section assume that the Filr appliances are being deployed on 
a VMware server. 

If you are deploying Filr on Hyper-V or Xen, refer to the instructions in “Installing the Filr Appliance 
and Configuring the Operating System” in the Novell Filr 1.0.1 Installation and Configuration Guide. In 
each case, after you reach the point where you accept the license agreement, you can return to the 
respective deploying sections in this guide and continue on from that point.
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6.2.1 Deploying Filr

1 On a workstation with the vSphere client installed, extract the Filr.x86_64-version.ovf.zip 
file that you downloaded in Chapter 3, “Downloading Filr Software,” on page 13 until you have 
a folder containing three files with .mf, .ovf, and .vmdk extensions.

2 Using the vSphere client, attach to your VMware ESX server, then click File > Deploy OVF 
Template.

3 Browse to and open the Filr.x86_version.ovf.zip file, then proceed through the various 
dialogs as you normally would until the virtual machine is deployed.

4 Edit the virtual machine settings and add a 100 GB hard disk.
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TIP: When you deploy Filr in a production environment, you have a choice to make at this point. 
You can either add a second hard disk to the appliance or you can specify an NFS mount point 
for shared storage. 
Shared storage lets you provide a more robust and expandable environment by clustering 
multiple Filr appliances that all access the same storage area. For more information, see the 
information in the Novell Filr 1.0.1 Installation and Configuration Guide, starting with the table 
named “Filr Appliance Storage.”

5 After the hard disk has been added, click Power on the virtual machine.

6 After the appliance starts, accept the license agreement. 
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7 Complete the initial configuration settings, substituting the IP address and other settings that 
you identified in Chapter 2, “Hands-on System Requirements,” on page 9 for the Filr appliance 
on your network.

IMPORTANT: Ensure that the Time Zone settings match the settings of your Windows 
environment.

For example, the following screen shows the IP addresses and the other information that was 
used for the Filr appliance that was deployed in a private network when this guide was 
developed.
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8 Proceed through the screens, accepting the defaults, until the configuration process completes.

9 Continue with Deploying Search.

6.2.2 Deploying Search

1 On the VMware workstation host machine, extract the Filrsearch.x86_64-version.ovf.zip 
file that you downloaded in Downloading Filr Software until you have a folder containing three 
files with .mf, .ovf, and .vmdk extensions.
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2 Proceed as you did with Filr by deploying the Filrsearch OVF template file, and so on until the 
virtual machine is deployed.

3 Edit the virtual machine settings and add a 25 GB disk.

4 After the hard disk has been added, power on the virtual machine.
5 When the license agreement appears, read and accept it, then complete the initial configuration 

settings, as shown below. Substitute the IP address and other settings that you identified in 
Chapter 2, “Hands-on System Requirements,” on page 9 for the Filrsearch appliance on your 
network.

IMPORTANT: Ensure that the Time Zone settings match the settings of the Windows 
environment.

For example, the following screen shows the IP addresses and the other information that was 
used for the Filrsearch appliance that was deployed in a private network when this guide was 
developed.
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6 Proceed through the screens, accepting the defaults, until the configuration process completes.

7 Continue with Deploying MySQL.

6.2.3 Deploying MySQL

1 On the VMware workstation host machine, extract the MySQL.x86_64-version.ovf.zip file 
that you downloaded in Downloading Filr Software until you have a folder containing three 
files with .mf, .ovf, and .vmdk extensions.
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2 Proceed as you did with Filr and Filrsearch by deploying the MySQL OVF template file, and so 
on until the virtual machine is deployed.

3 Edit the virtual machine settings and add a 100 GB disk.

4 After the hard disk has been added, power on the virtual machine.
5 When the license appears, read and accept it, then complete the initial configuration settings as 

shown below. Substitute the IP address and other network settings that you identified in 
Chapter 2, “Hands-on System Requirements,” on page 9 for the MySQL appliance. 

IMPORTANT: Ensure that the Time Zone settings match the settings of the Windows server.
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6 Proceed through the screens, accepting the defaults, until the configuration process completes.

7 Continue with Configuring the MySQL Appliance.

6.2.4 Configuring the MySQL Appliance

1 Launch your management browser on the management workstation and enter the following 
URL: https://MySQL-appliance-ip-address:9443.

2 Click through the security warnings and accept the certificate if needed. 
3 Log in with Username: vaadmin and the password you set for the vaadmin user in Step 5 on 

page 59.
60 Filr 1.0.1 Hands-on Guide for Windows



4 Click the phpMyAdmin icon.

5 Type Username root and Password root, then click Go.

6 Click Users.

7 Create a database user for the Filr appliance by doing the following:
7a Click Add User.
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7b Type the required information in the fields indicated.

7c Select Create database with same name and grant all privileges, then click Add User.

8 Secure the MySQL appliance by changing the root user password.
8a In the Users Overview section, select root, then click Edit Privileges.

Field Name Value to Type

User name filr

Host ip_address_of_Filr_appliance

Password password

Re-type password
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8b Scroll down to the Change password section, type a new password in both Password fields, 
then click Go.

9 Continue with Configuring the Search Appliance.

6.2.5 Configuring the Search Appliance

1 In your management browser, enter the following URL: https://Filrsearch-appliance-ip-
address:9443.

2 Click through the security warnings and accept the certificate if needed. 
3 Log in with Username: vaadmin and the password you set for the vaadmin user in Step 6 on 

page 58.
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4 Click the Filr Search Appliance Configuration icon.

5 Click Next.

6 Type and confirm a Password for the search service, then click Finish.
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7 Click Submit.

8 When the password is updated, continue with Configuring the Filr Appliance.

6.2.6 Configuring the Filr Appliance

1 In your management browser, enter the following URL: https://Filr-appliance-IP-
address:9443.

2 Click through the security warnings and accept the certificate if needed. 
3 Log in with Username: vaadmin and the password you set in Step 7 on page 55.

4 Click the Novell Appliance Configuration icon.
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5 Ensure that Large Deployment is selected, then click Next.

6 Type the IP address of the MySQL appliance in the Host Name field, and the User Password that 
you specified in Step 7b on page 62, then click Next.

7 Type the IP address of the Filrsearch appliance in the Host Name field, and the Lucene User 
Password that you specified in Step 6 on page 64, then click Next.
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8 Click Finish.

You now have a basic large deployment Filr infrastructure.

Continue with Chapter 7, “Securing LDAP Communications between Filr and Active Directory,” on 
page 69.
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7 7Securing LDAP Communications 
between Filr and Active Directory

1 Generate a self-signed certificate for Active Directory.
1a On the Windows server, click Start > Run, then enter mmc. 

1b In MMC, type Ctrl+M.
1c  If the Internet Information Services (IIS) Manager snap-in is not installed on your Windows 

server, install it. 
1d With IIS selected, click Add, then click OK.

1e In the left frame, click Internet Information Services, then click a Windows server that Filr can 
connect to for synchronizing the test users that you created in Chapter 4, “Creating Test 
Users,” on page 17.
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1f In the Filter list, scroll down to Server Certificates and double-click the icon.

1g In the Actions list, click Create Self-Signed Certificate.

1h Name the certificate with a name you can remember, such as the server name, then click 
OK.

1i Type Ctrl+M, select the Certificates plug-in, then click Add.
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1j Select Computer account, then click Next.

1k Click Finish.

1l In the Snap-ins dialog, click OK.
1m In MMC, expand the Certificates plug-in, expand Personal, then click Certificates.
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1n Right-click the certificate you created, select All Tasks, then click Export....

1o In the Certificate Export wizard, click Next.

1p Ensure that No, do not export the private key is selected, then click Next.
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1q Ensure that DER encoded binary is selected, then click Next.

1r Name the certificate, then click Next.

1s Click Finish > OK.
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The certificate is saved in C:\Users\Your-User-Name.
1t Ensure that the certificate is accessible from your management browser.

2 Using your management browser, import the certificate into the Filr appliance’s Java Keystore:
2a In the upper-right corner of the Filr Console, click the Home link.
2b Click the Appliance System Configuration icon.

2c Click the Digital Certificates icon.

2d Click File > Import > Trusted Certificate.
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2e Browse to the certificate file that you saved in Step 1s on page 73, then click Open.

2f Click OK.

2g Click Close.

2h Click Reboot > OK > OK.
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As soon as the Filr appliance restarts, both the Windows server and Filr are prepared for the exercises 
in Chapter 8, “Administering Filr,” on page 77.
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8 8Administering Filr

The Filr administration exercises are summarized in the following graphic.

NOTE: If you want the ability to repeat the exercises that follow, consider taking a snapshot of the 
Filr VMs before you begin. That way you can always restore the VMs to their original states without 
risking ripple effects from previous steps.

This section guides you through the following tasks:

 Section 8.1, “Synchronizing LDAP Users,” on page 77
 Section 8.2, “Setting Up Users’ My Files Folders,” on page 83
 Section 8.3, “Setting Up Net Folders,” on page 84
 Section 8.4, “Enabling Sharing,” on page 93
 Section 8.5, “Setting Guest Access,” on page 94
 Section 8.6, “Allowing the Desktop Application to Be Deployed,” on page 95
 Section 8.7, “(Optional) Setting Up Email Communication with the Filr VM,” on page 96

8.1 Synchronizing LDAP Users
In Section 4, “Creating Test Users,” on page 17, you populated Active Directory with the users shown 
in Figure 8-1 on page 78.

Filr
Virtual Appliance

Windows Server
Virtual Machine

Sychronize AD UsersA

Set Up Personal StorageB

Set Up Net FoldersC

Set Up SharingD

WinWin
Home Folders My Files

Share Name NetFolder

Shared by MeShared with Me

AD Users Filr Users
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Figure 8-1   Users Created for the Filr Exercises

Importing users to Filr is accomplished by setting up LDAP synchronization with Active Directory.

1 Using your administrative browser, access Filr through the following URL:

https://Filr-appliance-IP-address:8443

2 If prompted, accept and trust the certificate.
3 Sign in as User ID: admin with Password: admin.

4 When prompted, change the password to the administrative password you have chosen.

5 Click admin (upper right), then select Administration Console.
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6 Under System, click LDAP.

7 Click Add a New LDAP Source

8 Click OK.

9 Enter the LDAP source information.
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10 Skip to the Base DN field, then type the DN of the testusers container on your server. 
For example, ou=testusers,dc=filr-lab,dc=local.

This is the location of the users that you created in Active Directory (Figure 8-1 on page 78). As 
with Step 9, if you aren’t certain of the syntax, use the dsquery user command.

11 Select the following options: 
 Enable Schedule
 Run Immediately

Field Name Value to Enter

LDAP Server URL ldaps://windows-server-IP-address

User DN IMPORTANT: This is the distinguished name of an Active Directory user 
who has sufficient rights to access the information for the test users that 
you created in Chapter 4, “Creating Test Users,” on page 17. For example, 
it could be the user name that you used for that task.

TIP: If you aren’t certain of the syntax, open a terminal prompt on the 
server and enter the dsquery user command. 

For example, the DN for the Administrator user account used to create the 
test users when developing this guide is: 
cn=Administrator,cn=users,dc=filr-lab,dc=local.

Password The password of the user above. 

For example, the password of the Administrator user on the server used 
for this guide is N0v3llfi!r.

LDAP Unique Identifier objectGUID

LDAP Attribute for Filr sAMAccountName
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 Every Day
 Repeat Every 0.25 Hours

12 Select the following options for user synchronization: 
 Synchronize User Profiles
 Register LDAP User Profiles Automatically

13 Click Apply.

All of the users in the testusers container are added.

14 Click Close.
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15 Remove the filrproxyuser by doing the following:
15a In the left frame, click User Accounts.

15b Select Filr Proxyuser.

15c Click More, then select Purge Users and their Workspaces.
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15d Click Yes.

16 Continue with Section 8.2, “Setting Up Users’ My Files Folders,” on page 83.

For complete instructions on using Filr LDAP synchronization, see “Synchronizing Users and 
Groups from an LDAP Directory,” in the Novell Filr 1.0.1 Administration Guide.

8.2 Setting Up Users’ My Files Folders
1 Under Management > User Accounts, select the check boxes next to the names of the following 

users:
 A Black
 A Green
 A Orange
 A Pink
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2 Click More > Enable Personal Storage.

3 Continue with Setting Up Net Folders.

8.3 Setting Up Net Folders
 Section 8.3.1, “Specifying Net Folder Servers,” on page 84
 Section 8.3.2, “Creating Net Folders and Setting Net Folder Access and Sharing Rights,” on 

page 89

8.3.1 Specifying Net Folder Servers

Net Folder Servers are connections to shares on Windows file servers. You can set up as many 
connections to each file server as needed. For the hands-on lab, you create one Net Folder Server for 
each Share defined in “Setting Up the Other Hands-on Exercise Folders and Files” on page 34.

Configuring the Home_Folders Net Folder Server

1 Under Management, click Net Folder Servers.
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2 Four of the users that you synchronized with the Windows server have Home directories on the 
server. Therefore, the Net Folder Server for the Home_Folder$ share on your Windows server 
(for example, Windows-DC-Home_Folders$), is already created and listed.

IMPORTANT: Although Home folders are technically like other Net Folders in Filr, their 
primary role is personal storage. Therefore, they are accessed through My Files rather than 
through Net Folders.

3 The Home Net Folder Server is marked with an icon that indicates that its configuration needs 
attention.
In the Name column, click the Home_Folders$ server link.

4 One valuable Filr feature is the ability to share files and folders with others who do not have 
native file system rights. 
This sharing functionality is provided through Net Folder proxy users. However, the “Home” 
Net Folder Server has no Net Folder proxy user configured. That is why the yellow icon is 
displayed.
You granted the Net Folder proxy user (filrproxyuser) full control of the Home_Folders$ share 
in Step 2 on page 18. You simply need to make Filr aware of that assignment.
4a In the Proxy Name field, type the DN of the filrproxyuser. 

For example, in the guide’s development environment, this is
cn=filrproxyuser,cn=testusers,dc=filr-lab, dc=local

4b In the Proxy Password field, type the password specified for the filrproxyuser:
For example, N0v3llfi!r
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4c Click Test Connection.

5 When you click Test Connection, you should see a message that the test succeeded.
Click OK.

6 Click OK > OK.
The warning icon is removed.

Configuring the Other Net Folder Servers

1 To add Net Folder Servers for the other shares on the Windows server, click Add.

2 Use the information in Table 8-1 as you add a Net Folder server for each share.
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Table 8-1   Net Folder Servers to Add

2a Type the information for each share in the fields indicated, beginning with Dev. Then click 
Test Connection to verify that the information is typed correctly.

Share Field Text

Dev Name Development

Server Path \\windows-server-IP-address\Dev

Proxy Name filrproxyuser DN

For example: cn=filrproxyuser,ou=testusers,dc=filr-
lab,dc=local

filrproxyuser Password For example: N0v3llfi!r

IS Name IS

Server Path \\windows-server-IP-address\IS

Proxy Name filrproxyuser DN

For example: cn=filrproxyuser,ou=testusers,dc=filr-
lab,dc=local

Proxy Password For example: N0v3llfi!r

Mrktg Name Marketing

Server Path \\windows-server-IP-address\Mrktg

Proxy Name filrproxyuser DN

For example: cn=filrproxyuser,ou=testusers,dc=filr-
lab,dc=local

Proxy Password For example: N0v3llfi!r

Sales Name Sales

Server Path \\windows-server-IP-address\Sales

Proxy Name filrproxyuser DN

For example: cn=filrproxyuser,ou=testusers,dc=filr-
lab,dc=local

Proxy Password For example: N0v3llfi!r
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Notice that the Net Folder Server names do not necessarily need to mirror the server and 
share names.

2b Click OK.

2c Under Synchronization Schedule, select 
 Enable Scheduled Synchronization
 Every Day
 Repeat every 0.25 hours

Then click OK.

2d Repeat from Step 2 to create Net Folder Servers for the IS, Marketing, and Sales shares.
3 Click Sync.
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When the sync operation completes, Filr has metadata for each Net Folder Server in its database.
4 Continue with Creating Net Folders and Setting Net Folder Access and Sharing Rights.

8.3.2 Creating Net Folders and Setting Net Folder Access and Sharing 
Rights

Net Folders are connections to specific directories on Net Folder Servers. You can set up as many Net 
Folders as needed. You can also specify a separate and independent synchronization schedule for 
each Net Folder.

1 Under Management, click Net Folders.

2 Use the information in Table 8-2 as you create the Net Folders needed for the hands-on exercises.
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Table 8-2   Net Folder Configuration Information

2a Click Add.

Although the Home_Folders$ share is Net Folder Server and four users have Home folders, 
there are no Net Folders displayed. 
Home folders are displayed and managed under My Files rather than Net Folders.

2b Referring to Table 8-2, in the New Net Folder dialog type a name (starting with reviews). 
Select the appropriate Net Folder Server, type the relative path for the Net Folder, then click 
Test Connection to verify that the information is entered correctly.

Name Server Relative Path Users with Rights 
to Net Folder

Sharing Rights

reviews Development personnel\reviews ared Allow Access

Internal

comp planning Development personnel\salaries ared Allow Access

projects Development projects ared Allow Access

Internal

External

training IS training\quick_starts ablue Allow Access

Internal

Re-share

cool stuff Marketing advertising\brochures ayellow Allow Access

Internal

External

Public

Re-share

projections Sales revenue\projections ablack Allow Access

Internal

2013 tracking Sales revenue\quotas ablack Allow Access

Internal
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2c Click OK. 

2d Click Index the Contents of This Net Folder and Enable Just-in-Time Synchronization.

Although content indexing carries significant processing overhead and should, therefore, 
probably not be applied to all Net Folders, the content used in these exercises is so small 
that the overhead involved with indexing is miniscule. 

2e Click the Rights tab. 
In the User or Group field, begin typing the user listed in the table, then select the correct 
user.
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2f In the Grant Rights dialog, set the sharing rights as listed for the folder, then click OK.

2g Click OK.

2h Click OK, then return to Step 2 for the next Net Folder.
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2i When all of the Net Folders have been specified, continue with Enabling Sharing.

8.4 Enabling Sharing
Even though you granted sharing rights in the previous section, actually allowing users to share files 
and folders requires that you enable sharing for the Filr site.

1 Under System, click Share Settings.

2 In the User or Group field, start to type all, then select All Internal Users.

3 Click Re-share items and Share with the public, then click OK.
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This sets the maximum sharing rights that can be granted anywhere on the system. Re-sharing 
and public access are only available if they are actually enabled on the Net Folders.

4 Click OK.

8.5 Setting Guest Access
The hands-on exercises let you access Filr as a user who doesn’t have an account in Filr.

1 Under System, click User Access.

2 Select Allow Guest access and Guest access is read-only, then click OK.
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The read-only option prevents public (guest) users from logging comments. This is generally a 
good idea in light of the risk of “spam” comments. Comments cannot be removed in this version 
of Filr.

3 Continue with Allowing the Desktop Application to Be Deployed.

8.6 Allowing the Desktop Application to Be Deployed
Some of the Filr end user exercises are done through the Desktop Application. To enable the Desktop 
Application to be deployed through the Web application:

1 Under System, click Desktop Application.

2 Select Be deployed.
In the Auto-update URL field, type https://Filr-appliance-IP-address:8443/desktopapp/, 
then click OK.
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3 Continue with (Optional) Setting Up Email Communication with the Filr VM.

8.7 (Optional) Setting Up Email Communication with the Filr VM
The hands-on exercises leverage two of your personal email addresses:

 One is assigned to user ared for demonstrating Filr’s notification capabilities.
 The other is used for inviting an external user to collaborate on a project.

If you are not interested in email notifications or external sharing as part of the end user exercises, 
you can skip all of the remaining sections and steps in this guide that are marked (Email Only).

If you want to experiment with email notifications that originate from Filr, you must complete the 
following sections:

 Section 8.7.1, “(Email Only) Entering an Email Address for User ared,” on page 96
 Section 8.7.2, “(Email Only) Synchronizing ared’s Change with Filr,” on page 99

8.7.1 (Email Only) Entering an Email Address for User ared

1 On the Windows server, click Start > Administrative Tools > Active Directory Users and Computers.
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2 Right-click user ared and select Properties.
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3 Type the email address you have chosen to use with these exercises, for example 
myusername@examplemail.com.

4 Click OK, then continue with (Email Only) Synchronizing ared’s Change with Filr.
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8.7.2 (Email Only) Synchronizing ared’s Change with Filr

1 In the Administration Console under System, click LDAP.

2 Select Run immediately.

3 Click Apply.

User ared’s profile is modified.

4 Continue with Chapter 9, “Using Filr,” on page 101.
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9 9Using Filr

The Filr end user exercises can be summarized as follows:

This section guides you through the following tasks:

 Section 9.1, “Accessing Filr to Do the Filr End User Exercises,” on page 101
 Section 9.2, “Understanding Test Users and Their Roles,” on page 106
 Section 9.3, “Exploring Filr Functionality for End Users,” on page 107

9.1 Accessing Filr to Do the Filr End User Exercises
You need connections to Filr through the following access points to complete the Filr End User 
Exercises:

 A browser
 The Filr Desktop Application
 A mobile device

 Section 9.1.1, “Connecting to Filr through a Browser and Installing the Filr Desktop 
Application,” on page 101

 Section 9.1.2, “Starting the Filr Desktop Application,” on page 104
 Section 9.1.3, “Installing and Starting a Filr Mobile App,” on page 106

9.1.1 Connecting to Filr through a Browser and Installing the Filr Desktop 
Application

To connect through the browser and install the Filr Desktop Application:

1 On the Windows management workstation, start a browser and access the following URL:

https://Filr-appliance-IP-address:8443

2 If prompted, accept and install the certificate.

Windows
2008 R2

FilrYou Access Devices and Methods

WinWin

You use various clients, including mobile devices, to access Novell Filr. 
Filr provides access to test folders and files on a Windows server.
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3 Log in as User ID: apink.

4 In the upper-right corner, click apink, then select Download Filr Desktop App.

5 Click the appropriate link for the host workstation, for example, Windows X64 Client.

6 Save the file.
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7 When the download completes, click Open Folder.
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8 Right-click the downloaded file and select Run as administrator.

9 Run the installation, accepting the licenses, rebooting the workstation, and so on until the 
desktop application is installed.
Depending on your download speed, downloading and installing Microsoft .NET can take a 
while.
For additional information, see the applicable Quick Start on the Novell Filr online 
documentation site.

10 Continue with Starting the Filr Desktop Application.

9.1.2 Starting the Filr Desktop Application

1 On the Novell Filr welcome screen, click Start.

2 In the Server URL field, type https://Filr-appliance-IP-address:8443, type Username: 
apink and apink’s Password, then click Next.
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3 Continue through any security warnings.
4 Click Next.

5 Click Next.
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6 Click Finish.

A Filr folder is now available in on the workstation (in Windows Explorer or Macintosh Finder).

9.1.3 Installing and Starting a Filr Mobile App

Filr mobile apps are available as free downloads in the Apple App Store, the Google Play App Store, 
and the Amazon Appstore for Android.

Download and install the Filr mobile app on the mobile device as you would any other device app.

To access the Filr Mobile App:

1 Start the app in the same way that you start other apps on your mobile device.
2 Log in as Username: ablack.
3 Continue with Understanding Test Users and Their Roles.

9.2 Understanding Test Users and Their Roles
Table 4-1 lists eight users that have been synchronized from the Windows server to Filr.

As you can see, there are differences in their Home Folder and personal storage allocations (third 
column). Most have one or the other, but ablack has both and agray has no personal storage. We will 
briefly explore what this means in Section 9.3.1, “My Files—Home Folders and Personal Storage,” on 
page 107.

Notice also that only the manager-level users (ared, ablue, and so on) have file system rights on the 
Windows server (fourth column). Nevertheless, the hands-on exercises require that files be accessed 
by internal and external users who do not have file system rights. We will explore how this is 
accomplished in the “sharing” sections, starting with Section 9.3.2, “Internal Sharing,” on page 114.
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Table 9-1   User Roles and Tasks

9.3 Exploring Filr Functionality for End Users
After you have completed the setup and administration instructions in this guide, the Filr VMs and 
your Windows server are ready for the exercises in the following sections:

 Section 9.3.1, “My Files—Home Folders and Personal Storage,” on page 107
 Section 9.3.2, “Internal Sharing,” on page 114
 Section 9.3.3, “(Email Only) External Sharing,” on page 122
 Section 9.3.4, “Public Sharing,” on page 130
 Section 9.3.5, “Re-sharing and Searching,” on page 133
 Section 9.3.6, “More Things You Can Try,” on page 136

9.3.1 My Files—Home Folders and Personal Storage

The files and folders that users see when they access My Files are illustrated in Figure 9-1 and 
demonstrated in the steps that follow the figure.

 The top half shows that two storage locations can be assigned to users for their own use—
personal storage on the Filr data disk and/or home storage on a Windows file server.

 The bottom half shows how the assigned storage is displayed in My Files, depending on what a 
user is assigned. 

User Name Role in the FILR-LAB 
organization

Home Folder and Personal 
Storage

File System Rights on the 
Windows Server

ared Development Manager Home folder Full control of Dev share and 
directory

apink Developer Personal None

ablue IT Manager Home folder Full control of IT share and 
directory

agreen Filr Administrator Personal None

ayellow Marketing Manager Home folder Full control of Mrktg share and 
directory

aorange Product Line Manager Personal None

ablack District Manager Home folder

Personal

Full control of Sales share and 
directory

agray Account Manager None
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Figure 9-1   What Filr Users See in My Files Depends on What Is Set Up for Them

In the following steps, take the role and do the steps of the users that are indicated.

1 User ablack is a fan of the Hubble telescope and especially likes this image (http://hubblesite.org/
gallery/wallpaper/pr2007041a). 
On the Windows VMware host workstation, open a browser, then select the 1280X1024 link.

2 Right-click the displayed image, then save it to the desktop.

My Files

local.txt

Only
Filr Storage

My Files

remote.txt

Only
Home Folder

Home 

My Files

local.txt

Both

remote.txt

Filer Data Disk

local.txt

NTFS
Home Folders

remote.txt

My Files

and
or
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3 On the Windows server, access user ablack’s home folder in Windows Explorer.

4 Drag and drop (copy) the image from the desktop to ablack’s home folder on the Windows 
server.

5 In the administrative browser, sign out as user admin.
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6 Sign in as User ID: ablack.

7 Click MyFiles and notice the folder named Home. This is ablack’s home folder on the Windows 
server. 

Refer to Table 4-1 and notice that user ablack has a home Folder and is also assigned personal 
storage. In other words, user ablack is an example of the section labeled “Both” in Figure 9-1. 
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8 Open the Home folder. 
The Hubble image file is there as you would expect it to be.

9 Sign out as user ablack.

10 Sign in as User ID: admin.

11 Access the Administration Console (upper-right corner).
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12 Under Management, click User Accounts. 

13 Select A Black, then click More and select Purge User Workspaces > Yes.
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14 Click Yes.

15 Select A Black again, then click More and select Disable Personal Storage.

16 Sign out as user admin, then sign in as user ablack.
17 Notice that the Home folder has disappeared from user ablack’s My Files folder (the up-arrow 

left of Home has disappeared) and the Hubble image file is now directly listed as a child. 

Because you purged and removed the Personal Storage that was assigned to user ablack, user 
ablack now fits the definition in the section of Table 4-1 that is labeled “Only Home Folder.” 
(Purging ablack’s personal storage had no effect on the Windows server’s file structure or files.)

18 Click the down-arrow next to the image, then select Share. 

19 In the Share with field, type all, select All Internal Users, then click OK.
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20 Click OK.

21 Feel free to explore further if you want to get more experience with Filr’s My Files functionality 
and the role that traditional home folders play in that context. Then continue with Internal 
Sharing.

9.3.2 Internal Sharing

The exercises in this section demonstrate how Novell Filr users can share files with users who are 
internal to your organization. 

 “User ared Initiates User apink’s Annual Review” on page 114
 “User apink Responds to the Annual Review Request” on page 118
 “User ared Approves apink’s Annual Review” on page 120

User ared Initiates User apink’s Annual Review

User ared needs to complete the annual review for user apink, but apink doesn’t have file system access 
to the review file (apink_2013.doc). Rather than sending the file in email or assigning apink the 
required file system trustee rights on the Windows server, ared simply shares the review file with 
apink and includes Editor privileges. First, however, ared optionally ensures that email notifications 
will be sent when the file changes.

1 Sign in to the Web application as user ared. (This requires that you sign out as user ablack first.)
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2 Click Shared with Me and notice that the image that ablack shared is listed.

IMPORTANT: If you are not experimenting with email notifications, skip to Step 4 and skip all 
subsequent steps that are marked (Email only).

3 (Email only) Click A Red in the upper-right corner, then select View Profile. 

When the profile displays, notice that the email address you configured in Active Directory for 
user ared is listed.
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4 Click Net Folders > reviews > apink.

5 Click the check box for apink_2013.doc, then click the file drop-down arrow  to the right of 
the file and select Share.

6 In the Share with field, type p, then select A Pink.

7 Select Editor, then click OK
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8 Click OK.

9 (Email only) Click the check box for apink_2013.doc and the file drop-down arrow again, then 
click Subscribe.

10 (Email only) Expand the Message Only option, then select the email address you entered for user 
ared in Directory and click OK.

11 Click the comment icon .
12 Add a comment, such as 

Hi pink. 

Would you please edit this with your objectives and achievements and let me 
know when you have finished? 
Thanks. 
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red

13 Click Send and close the Comments dialog.

User apink Responds to the Annual Review Request

1 On the Windows 7 VM desktop in the notifications area, right-click the Filr icon. 

2 Select Open Filr folder.

3 Double-click Shared with Me.
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4 Right-click apink_2013.doc, then select Open.

The file should open in LibreOffice Writer, assuming the prerequisites are met for the Windows 
workstation.

5 Make a few changes, then save and close the file. 
You can be as verbose or brief as you want.

6 In the Shared with Me folder on the workstation, right-click the file you just edited and select 
Synchronize now.

7 Sign in to the Web application as user apink

8 Click Shared with Me.
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9 Click the drop-down arrow for apink_2013.doc, then click View HTML.

Your changes are reflected in the view.
10 Close the HTML view.
11 Click the review file’s comment icon, type a comment indicating that the review is ready, then 

click Send and close the comment panel.

12 Continue with User ared Approves apink’s Annual Review.

User ared Approves apink’s Annual Review

1 Log in to the email account that you assigned to user ared, open the message from filr-admin, 
then click the Visit Message link.
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2 Sign in to the Web application as user ared.
The message from apink is displayed.

3 In the new comment box, type a comment indicating that the review is approved, then click 
Send.
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4 Close the view. 
5 Continue with (Email Only) External Sharing.

9.3.3 (Email Only) External Sharing

The exercises in this section demonstrate how Filr users can share files with users who are external to 
your organization. 

 “About External Users” on page 122
 “User ared Gathers Input for the Next Release” on page 122
 “User opaque Self-Provisions and Responds to the Review Request” on page 125
 “User ared Responds to User opaque’s Input” on page 128

IMPORTANT: Completing the instructions in Section 8.7, “(Optional) Setting Up Email 
Communication with the Filr VM,” on page 96 is required for the exercises in this section.

About External Users

External users are those who receive share invitations through email and subsequently provision 
themselves as system users. They can then log in to the system using the credentials they establish 
with Filr, or they can elect to be authenticated through a Google or Yahoo Open ID account.

For more information about the different kinds of users who can access Filr, see “Users and Groups 
with Filr” in the How Filr Works–Overview Guide.

User ared Gathers Input for the Next Release

User ared managed the ABC product release and is responsible for gathering input for the upcoming 
XYZ product. User ared also wants to invite input from a key partner named M Opaque. Inviting M 
Opaque to participate requires using the second email address mentioned in Chapter 2, “Hands-on 
System Requirements,” on page 9 and further explained in Section 8.7, “(Optional) Setting Up Email 
Communication with the Filr VM,” on page 96.

1 If you aren’t already signed in to the Web application as user ared, do so now.
2 Click Net Folders > projects > current.

3 Click the check box for abc_reqr.doc, then click the file drop-down arrow  to the right of the 
file and select Share.
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4 In the Share with field, type your second email address, then click the plus sign (+) to add the 
external user.

At this point, user ared could share the document with internal or other external users, but for 
brevity’s sake, we aren’t including steps for that. 

5 Click OK > OK.
6 Click the check box for abc_reqr.doc and the file drop-down arrow again, then click Subscribe.

7 Expand the Message only option, then select the email address you entered for user ared in 
Directory and click OK.
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8 Click the comment icon  to the right of the down-arrow.
9 Add a comment, such as

It’s time to gather input for the next release. 
Please log comments to let us know which features we need to include this time. 
Then click Send.

10 Close the Comments dialog.
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11 Continue with User opaque Self-Provisions and Responds to the Review Request.

User opaque Self-Provisions and Responds to the Review Request

1 Log in to the email account that you used to invite user opaque to participate in the review.
2 Open the message from the email address that you assigned to user ared and click the 

abc_reqr.doc link.

3 The registration dialog lets external users register or log in as a guest.
Register as M Opaque by typing First name: M, Last name: Opaque, Password: F1lrrock$, and Re-
enter password: F1lrrock$. 
The User ID (email address) cannot be changed.
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4 Open the confirmation email, then click Sign in and access shared items.

5 Type the password F1lrrock$, then click Sign in. 
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6 Click Comments and read the comment from user ared.

7 Click Actions, then click Subscribe. 

Emails will now be sent to user opaque as others comment on the document or perform other 
actions.

8 Read the HTML view of ABC Project.

9 Log the following comment, then click Send.
Competing products have had morning coffee functionality for over 18 months 
now.

If the next release doesn’t include this, we will be forced to switch.
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10 Continue with User ared Responds to User opaque’s Input.

User ared Responds to User opaque’s Input

User ared receives notification of user opaque’s comment (you can check ared’s email if you wish) and 
remembers that the requested feature has been discussed. It should already be in the next 
requirements document (xyz_reqr.doc), but ared isn’t certain that it is.

1 Log in to the Web application as user ared.
2 Click Net Folders > projects > future.

3 Click the file drop-down arrow  for xyz_reqr.doc and select View HTML. 
The file has not been updated.

4 Click the file drop-down arrow  again, then select View details. 

5 Click Edit this file, then continue past the security warning and other messages until you are 
prompted to log in.
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6 Log in as user ared.
7 Insert the following text before the period:

, and it will make the morning coffee

8 Save the file and close LibreOffice.
9 Navigate to xyz_reqr.doc again and view its details to confirm that the change has been made.

10 Log and send a comment indicating that the file has been updated.
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11 Log a comment for the abc_reqr.doc file that Opaque’s requirement has been included in the 
next version.

12 Continue with Public Sharing.

9.3.4 Public Sharing

User ayellow wants to get the word out about the abc version of the organization’s product and elicits 
the help of user aorange with the effort.

1 Log in to the Web application as User ID: ayellow.
2 Click Net Folders > cool stuff.
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3 Click the file drop-down arrow  for abc_flyer.pdf, then select Share. 

4 In the Share with field, type o, then select A Orange.

5 Click Public > OK > OK.

6 Log in as User ID: aorange.
7 Click Shared with Me.

8 Click the action drop-down for the abc_flyer.pdf file, then click Share.
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9 Click Make Public.

10 In the Type column, click Public to view and copy the URLs that can be shared in social media, 
and so on.

11 Enter one of the URLs in a separate browser window or tab, then click Enter as Guest to see what 
Internet users who access the URL will see.
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12 Continue with Re-sharing and Searching.

9.3.5 Re-sharing and Searching

1 Log in to the Web application as User ID: ablue.
2 In Net Folders, navigate to training > Novell-Filr.pdf, then share the file with agreen as a Viewer 

with rights to reshare the file with internal users.
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3 Log in as user agreen, then share the file (with rights to reshare) with users apink, ayellow, aorange, 
ablack, and agray.
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A few days after user agreen has shared the file, user apink is talking with user ared in the hallway and 
mentions the file.

1 Log in as user ared, then in the search field, type quick and press Enter.

Because the file is not found, user ared asks apink to share the file.
2 Log in as user apink and share the file with ared.
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3 Log in as user ared and search for the file again.
The file is listed in the search results window.

9.3.6 More Things You Can Try

There are a few additional files in the other Net Folders that you can experiment with as indicated 
below. You can also experiment with your own files. 

Activity Type Net Folder File Location Task Descriptions

Planning comp planning 2014.xls 1. User ared opens the file in LibreOffice and plans a 
5.5% increase for apink’s 2014 salary.

Planning projections fy_2014.xls 1. User ablack shares the file with user agray as a 
viewer and asks whether the goals are realistic.

2. User agray comments that the Q3 estimate is low and 
the Q4 estimate is high. User agray asks that $10,000 
be transferred from Q4 to Q3.

3. User ablack adjusts the Q3 and Q4 estimates, thanks 
agray, and acknowledges the change.

Reporting quotas fy_2013.xls 1. User ablack shares this file with user agray as an 
Editor and requests that agray update it with Q4 
actual results.

2. User agray opens the file, enters $110,900, and saves 
the file. 

3. User agray comments that the file is now ready for 
review.
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