15.3 eDirectory Coexistence and Migration

The following sections summarize eDirectory coexistence and migration considerations.

15.3.1 Coexistence

The following table lists the operating systems and eDirectory versions that OES NetWare® and OES Linux have been tested with (and found to be compatible with):

Platform

eDirectory Version

NetWare 6.5 SP2

eDirectory 8.7.3 IR2 (eDirectory 8.7.3.2)

NetWare 6.0 SP5

eDirectory 8.6.2

NetWare 5.1 SP8

eDirectory 8.7.3

NetWare 5.1 SP7

eDirectory 8.7.3

NetWare 5.1

NDS® 8 (must have latest NDS 8 and eDirectory 8.7 schema extensions)

NetWare 4.2

NDS 6 (6.21 or later)

SLES 9

eDirectory 8.7.3

SUSE® LINUX Professional 9.1

eDirectory 8.7.3

Red Hat* AS 3.0

eDirectory 8.7.3 IR 3 (eDirectory 8.7.3.3)

Windows 2003 Server

eDirectory 8.7.3 IR 3 (eDirectory 8.7.3.3) or later

Windows 2003 Server

Active Directory (synchronized users via Identity Manager)

Windows 2000 Advanced Server

eDirectory 8.7.3 IR 3 (eDirectory 8.7.3.3) or later

Windows NT

NT Domain (synchronized users via Identity Manager)

NetWare Coexistence Issues

  • On NetWare, use Deployment Manager to check the tree for the correct versions of NDS/eDirectory and to determine if the needed schema extensions are present.

  • There are several issues with NetWare 5.1 SP7 and NDS 8 regarding SLP and LDAP authentication. If you cannot upgrade to NetWare 5.1 SP8, apply the sas.nlm and SLP modules from NetWare 5.1 SP8 for LDAP and SLP compatibility.

    If the sas.nlm module is not applied, an OES Linux server installed into a NetWare 5.1 SP7 tree hangs during installation during LDAP authentication. If the SLP modules are not applied, the NetWare 5.1 SP7 server might not be able to work correctly with the Linux version of OpenSLP.

Linux Coexistence Issues

There are no known eDirectory coexistence issues.

15.3.2 Migration

This section provides information on migrating a previous installation of eDirectory to the OES version (eDirectory 8.7.3 IR5).

NetWare Caveats

For NetWare, a migration is the same as an Upgrade. For instructions, see Upgrading to OES NetWare in the OES NetWare Installation Guide .

Linux Caveats

  • Upgrades from Novell Nterprise Linux Services (NNLS) are not supported, but upgrades from SLES 9 with eDirectory 8.7.3 to OES Linux are supported.

  • If you attempt to install OES Linux on a server that already has eDirectory 8.7.3 installed, the eDirectory included with OES (eDirectory 8.7.3 IR 5) overwrites the previous eDirectory installation. You should install OES on a clean computer. Do not try to upgrade eDirectory.

  • Installing OES Linux into a NetWare 6.5 SP2 tree causes the NetWare server to abend due to an issue in NetWare 6.5 SP2 that is fixed in NetWare 6.5 SP3 and later.

    Before installing an OES Linux server into a NetWare 6.5 SP2 tree, upgrade any NetWare 6.5, NetWare 6.5 SP1, and NetWare 6.5 SP2 LDAP servers that will be pointed to by the OES installation to NetWare 6.5 SP3 or later.