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About This Guide

IMPORTANT: The Virtual Office product and associated patches are not included in OES SP2.

To use this guide, you must install OES using SP1 software (available for download from the Novell 
Support Web site (http://support.novell.com/tools/csp/csp_oes.html)). Otherwise, you will not be 
able to complete the exercises in this guide.

Most organizations test new products in a lab setting prior to making them available for general use.

This guide is designed to help you set up a Novell® Open Enterprise Server (OES) server in a lab 
environment using a specific and simplified configuration. The configuration is limited in scope and 
is meant only to acquaint you with OES and provide exposure to the Novell products it contains.

Guide Purposes

The instructions in this guide will help you do the following:

• Install an OES Linux server into an eDirectoryTM tree named EXAMPLE_TREE

If you already installed OES for NetWare® using the instructions in the Lab Guide for OES 
NetWare, you will install this server into the tree you created during that installation.

• Install select OES components on the server
• Perform simple tasks to get acquainted with basic OES services

About Information Flow in This Guide

The sections in this guide are designed to be accessed sequentially, guiding you through the 
following main tasks:

1. Installing an OES Linux server.
2. Setting up the eDirectory infrastructure—User objects, Group objects, passwords, etc.
3. Reviewing the services featured in the guide and performing all additional setup tasks required 

for test driving and exploring the features.
4. Test driving and exploring the features.

Using This Guide as a Reference

If you want to install additional OES servers or create a different tree structure than the one specified 
in this guide, you can still use these instructions as a basic guide for setting up OES services in a lab 
environment. However, you should also refer to the information found in the following guides:

• Novell OES SP2 Planning and Implementation Guide
• OES Linux Installation Guide
9
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Feedback

We want to hear your comments and suggestions about this manual and the other documentation 
included with this product. Please use the User Comments feature at the bottom of each page of the 
online documentation.

Documentation Conventions

In this documentation, a greater-than symbol (>) is used to separate actions within a step and items 
within a cross-reference path.

A trademark symbol (®, TM, etc.) denotes a Novell trademark. An asterisk (*) denotes a third-party 
trademark.

When a single pathname can be written with a backslash for some platforms, or a forward slash for 
other platforms, the pathname is presented with a forward slash to reflect the Linux convention. 
Users of platforms that require a backslash, such as NetWare, should use backslashes as required by 
the software.
or OES SP2 Linux
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1Installing an OES Linux Server in 
Your Lab

IMPORTANT: When you create a new eDirectoryTM tree that will contain both NetWare® and 
Linux servers, you should start the tree creation using a NetWare server first. To install a NetWare 
server, see the Lab Guide for OES NetWare.

If you use a Linux server to create a new tree, you need to install at least three OES Linux servers 
before adding a NetWare server to the newly created tree. Otherwise, you cannot install any Client 
or Server licenses, making any features that require a NetWare Server license or NetWare Client 
Access license inaccessible.

Novell® will be addressing this problem in a subsequent release of Open Enterprise Server.

Use the instructions in this section to install Novell Open Enterprise Server (OES) in your lab.

This section describes the following tasks:

• Section 1.1, “Lab Setup Requirements,” on page 11
• Section 1.2, “Creating or Obtaining Installation Media,” on page 12
• Section 1.3, “Installing the Server Software,” on page 13
• Section 1.4, “Setting the Root Password and Configuring the Network,” on page 15
• Section 1.5, “Configure eDirectory,” on page 16
• Section 1.6, “Configure OES Services,” on page 17
• Section 1.7, “Set Up the Graphical User Interface,” on page 17
• Section 1.8, “What’s Next,” on page 18

1.1  Lab Setup Requirements
For the tasks and exercises described in this guide, you will need the following:

Server-class computer with the following:

Component Minimum Recommended

Processor Pentium* II or AMD* K7 450 
MHz

Pentium III, Pentium III Xeon*, 
Pentium 4, or Intel* Xeon 700 
MHz or higher

RAM 512 MB 1 GB

Display adapter Super VGA VESA 1.2-compliant, high 
resolution

CD drive Supports the ElTorito 
Specification
Installing an OES Linux Server in Your Lab 11
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Network printer with an assigned static IP address and a connection to your lab network.
Workstation with 

• One of the following platforms installed:
• Windows* XP
• Windows 2000

• Internet Explorer (IE) 6 SP1 or later installed.
We recommend you use IE for all instructions in this guide. Some procedures, such as 
iPrint installation, work only in IE.

• A print driver for the network printer installed on the workstation.

1.2  Creating or Obtaining Installation Media
The Novell OES SP2 Planning and Implementation Guide contains full instructions for obtaining 
OES SP2 installation media. 

However, for the exercises in this guide you will need OES SP1 media, available on the Novell 
Support Web site (http://support.novell.com/tools/csp/csp_oes.html).

1.2.1  Preparing the Installation Media
If you already have OES Linux product CDs, skip to Section 1.3, “Installing the Server Software,” 
on page 13.

To install Novell Open Enterprise Server using CD image files, you need the following:

CD-R device on your workstation
CD-burning software (such as Roxio Easy CD Creator or Nero) that is capable of creating CDs 
from ISO image files
Six 700 MB CD-R media

Do the following:
1 Create the CDs that are required for the exercises in this guide by using your CD-burning 

software.
2 Label each CD using the information in the following table.

Hard drive

(All data will be erased)

20 GB

Network card Ethernet 100 Mbps

IP address

(Novell iFolder® requires a 
separate IP address on 
Linux.)

• IP address on lab subnet

• Subnet mask

• Default gateway

Mouse Not required USB or PS/2*

Component Minimum Recommended
or OES SP2 Linux
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Continue with Installing the Server Software.

1.3  Installing the Server Software
Complete the instructions in the following sections.

1.3.1  Prerequisites
Before installing Novell Open Enterprise Server (OES) for Linux on your server, you must complete 
the following tasks:

Ensure that the server you are installing OES on meets the requirements outlined in Section 1.1, 
“Lab Setup Requirements,” on page 11.
Prepare the software for installation as explained in Section 1.2.1, “Preparing the Installation 
Media,” on page 12.

1.3.2  Procedure

WARNING: This procedure permanently erases any data currently on your server’s hard drive.

1 Prepare the BIOS on your server machine so that it will boot from the CD-ROM drive first.
2 Insert the CD labeled Open Enterprise Server SP1 CD1 into your server and reboot the 

machine.
3 When the boot selection screen appears, immediately press the Down-arrow key to select the 

Installation option, then press Enter.
If you don’t respond before the machine starts booting from the hard disk, you need to reboot 
and start over.

4 After the boot process completes, read and then agree to the Novell OES software license 
agreement.

5 Select and accept an installation language.
6 (Conditional) If you are asked to select an installation type, select New Installation, then click 

OK.
7 On the Installation Settings screen, scroll down the list and click Partitioning.

The OES install tries to add SLES 9 partitions to your existing partitions. 

ISO Image Filename Label

oes-sp1-linux-1.iso Open Enterprise Server SP1 CD1

oes-sp1-linux-1.iso Open Enterprise Server SP1 CD2

oes-sp1-linux-3.iso Open Enterprise Server SP1 CD3

oes-sp1-linux-5-sles9-2.iso SUSE CORE Version 9 CD 1

oes-sp1-linux-6-sles9-3.iso SUSE CORE Version 9 CD 2

oes-sp1-linux-7-sles9-4.iso SUSE CORE Version 9 CD 3 
Installing an OES Linux Server in Your Lab 13
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8 To ensure a clean install, use the following table to navigate and configure the partitioning 
screens.

9 On the Installation Settings screen, scroll down and click Software.
Use the following table to navigate and configure the software screens.

10 On the Installation Settings screen, scroll down and click Timezone.
11 Select and accept your time zone.
12 On the Installation Settings screen, click Accept.
13 Click Yes, Install.
14 As the install proceeds, you are prompted to insert the following CDs. Click OK after each 

insertion.

• Open Enterprise Server SP1 CD2
• Open Enterprise Server SP1 CD3

Screen Name Action

Suggested Partitioning 1. Select Base Partition Setup on This 
Proposal.

2. Click Next.

Expert Partitioner 1. Click Delete > Yes.

2. Click Create > OK.

Create a Primary Partition 1. Select Swap from the File System drop-
down list.

2. In the End field, type a partition size roughly 
twice the amount of RAM installed on the 
server. 
For example, if the server has 512 MB RAM 
installed, type 1024M.

3. Click OK.

Expert Partitioner 1. Click Create > OK.

Create a Primary Partition 1. Click OK.

Expert Partitioner 1. Click Next.

Screen Name Action

Software Selection 1. Click Detailed Selection.

Selection List 1. Deselect the following because they will not 
be used for the exercises in this guide:
- Novell QuickFinder
- Novell NCP Server
- Novell Backup Services (SMS)
- Novell Health Monitoring

2. Click Accept.

Automatic Changes 1. Click Continue.
or OES SP2 Linux
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• SUSE CORE Version 9 CD1
• SUSE CORE Version 9 CD2
• SUSE CORE Version 9 CD3

After the files are copied, the system configuration takes a few minutes to complete.

1.4  Setting the Root Password and Configuring 
the Network
After the initial system configuration and system reboot, the installation needs more information 
about the root user and the network.

1 Use the following table to navigate and complete the various configuration screens.

Screen Name Action

Password for Root 1. Enter and confirm the root user password.

Network Configuration 1. Click the Network Interfaces link.

Network Cards Configuration 1. Click Configure.

Network Address Setup 1. In the IP Address field, type the IP address 
you want to use for the server and all OES 
services.

2. Change the Subnet Mask if needed.

3. Click Host Name and Name Server.

Host Name and Name Server Configuration 1. In the Host Name field, type the DNS 
hostname for the IP address you just 
assigned.
For example, myserver.

2. In the Domain Name field, type the DNS 
Domain Name for your network.
For example, mysite.example.com.

3. Type the IP address of at least one Name 
Server and type your DNS Domain Name in 
at least one of the Domain Search fields. 

4. Click OK.

Network Address Setup 1. Click Routing.

Routing Configuration 1. Type the IP address of the default gateway 
for your lab subnet.

2. Click OK.

Network Address Setup 1. Click Next.

Network Cards Configuration 1. Click Finish.

Network Configuration 1. Click Next.
Installing an OES Linux Server in Your Lab 15
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1.5  Configure eDirectory
For the exercises in this guide, you need specific eDirectoryTM, NTP, and SLP configurations.

1 Use the following table to navigate and complete the eDirectory screens.

Test Internet Connection In a production environment, it is critical that you 
apply all software updates. However, this is not 
required for the exercises in this lab guide.

1. Check No, Skip This Test.

2. Click Next.

Service Configuration 1. Click Next.

OES Configuration - Now or Later 1. Click Next (Configure Now).

Screen Name Action

eDirectory Configuration - New Tree 1. In the Tree Name field, type
EXAMPLE_TREE.

2. Click Next.

eDirectory Configuration - New Tree 
Information

1. In the FDN Admin Name with Context field, 
type
CN=admin.O=COMPANY.
In this lab guide, the Admin user is named 
admin (all lowercase) for convenience when 
typing the name to authenticate and to 
distinguish the name from the Admin User 
object which is always uppercase by 
convention. The Admin User object can be 
named anything you choose. 
All container objects are created using 
uppercase so they are more easily 
distinguished in the illustrations and 
procedures in this guide.

2. In the Admin Password and Verify Admin 
Password fields, specify the same password 
as for the eDirectory Admin user.

3. Click Next.

4. Change the server context to
OU=SERVERS.OU=LAB.O=COMPANY.

5. Click Next.

Screen Name Action
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1.6  Configure OES Services
For the exercises in this guide, you need the specific service configurations outlined in this section.

1 Use the following table to navigate the screens and configure OES services.

1.7  Set Up the Graphical User Interface
Although most Linux servers don’t have a graphical user interface loaded, the lab server you are 
installing has the KDE interface loaded by default. 

When the Hardware Configuration screen appears, do the following.
1 Review the Graphics Cards configuration to make sure your monitor was detected and that 

your color and resolution settings are the way you want them. 
If the settings are correct, skip to Step 3.

eDirectory Configuration - NTP and SLP 1. Time synchronization is required for 
eDirectory.
If you have already installed the OES 
NetWare server (LAB_NW), type the 
NetWare server’s IP address in the Network 
Time Protocol (NTP) Server field.
Otherwise, assuming this is the first server 
in the tree, leave the field set to Local Clock, 
which sets up this server an NTPv3 time 
source. 

2. Click Next.
The exercises in this guide do not require 
SLP.

SLP Configuration 1. Click Yes to confirm that SLP is not being 
configured.

Screen Name Action

Installation Settings 1. Scroll down and click Novell Samba.

Novell Samba LDAP Server Configuration 1. Click Next.

Novell Samba Configuration 1. In the Base Context for Samba Users field, 
change the context to
O=COMPANY.

2. Click Next.

Installation Settings 1. Click Next.
As indicated on the screen, the iManager 
plug-in configuration process can take 
several minutes. After that, the service 
configurations and the system configuration 
are saved to the server’s system partition.

Release Notes 1. Click Next.

Screen Name Action
Installing an OES Linux Server in Your Lab 17
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2 (Conditional) If the configuration is incomplete or wrong, click the Graphic Cards link and 
follow the on-screen prompts until your monitor and display settings (color, resolution, etc.) are 
correctly set up.

3 Click Next.
4 When the Installation Completed screen appears, click Finish.

1.8  What’s Next
On the login splash screen, notice that the eDirectory Admin user is listed as an available user 
account on the OES server. This is because of an integration of eDirectory with the local Linux user 
management system (POSIX). There is more information about this in the next section.

Continue with Chapter 2, “eDirectory, Users and Groups, and Identity Services,” on page 19.
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2eDirectory, Users and Groups, and 
Identity Services

Novell® eDirectoryTM is the central, key component of Novell Open Enterprise Server (OES) and 
provides the following:

• Centralized identity management
• The underlying infrastructure for managing your network servers and the services they provide
• Secure access to network services both within the firewall and from the Web

The installation scenario presented in this guide creates a new eDirectory tree named 
EXAMPLE_TREE that you can use for testing and learning about OES. As you work with the tree 
and the objects it contains, you will begin to better understand the role eDirectory plays.

This section discusses the following:

• Section 2.1, “Using the eDirectory Information in This Guide,” on page 19
• Section 2.2, “An Introduction to eDirectory Planning,” on page 20
• Section 2.3, “Accessing iManager,” on page 23
• Section 2.4, “Setting Up Role-Based Services,” on page 24
• Section 2.5, “Creating a Context for Your Users and Groups,” on page 25
• Section 2.6, “Setting Up Universal Password for Users,” on page 25
• Section 2.7, “Creating Users (First Server in the Tree),” on page 26
• Section 2.8, “Creating Corresponding Windows Users,” on page 27
• Section 2.9, “Creating a Group Object,” on page 27
• Section 2.10, “Enabling the Group Object for Linux User Management (LUM),” on page 28
• Section 2.11, “Enabling Users for Samba,” on page 28
• Section 2.12, “A Note about Identity Manager Bundle Edition,” on page 29
• Section 2.13, “What’s Next,” on page 29

2.1  Using the eDirectory Information in This 
Guide
Before you install OES in a production environment, it is critical that you and your organization take 
time to plan and design your tree.

However, the instructions in this guide require no planning on your part. In fact, most of the 
eDirectory objects needed for the exercises in this guide were created in Chapter 1, “Installing an 
OES Linux Server in Your Lab,” on page 11.

The information that follows introduces eDirectory.

If you are already familiar with eDirectory and want to skip the planning introduction, we 
recommend that you do the following:
eDirectory, Users and Groups, and Identity Services 19
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1. View the eDirectory tree structure used in this guide (Figure 2-1 on page 21).
2. Then skip to Section 2.5, “Creating a Context for Your Users and Groups,” on page 25.

2.2  An Introduction to eDirectory Planning
If you want an efficient and intuitive eDirectory design, you and your organization will need to base 
it on 

• The layout of your network.
• The structure of your organization.

You and your team should carefully think through the issues and design considerations discussed in 
“Designing Your Novell eDirectory Network” in the Novell eDirectory 8.7.3 Administration Guide.
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2.2.1  Your Lab’s eDirectory Tree
Figure 2-1 illustrates an eDirectory tree like the one you will use in the lab exercises found in this 
guide. It also illustrates and explains the basic elements you should consider when designing an 
eDirectory tree.

NOTE: The IS Organizational Unit object is included for explanatory purposes and is not created in 
this guide.

Figure 2-1   Your Lab’s eDirectory Tree

 As shown in this lab example, these organizations
 create Organizational Unit objects (specified using 
 OU=name) that reflect their departments, 
 divisions, geographical locations, etc., as is logical 
 for their organization.

 Sometimes large organizations create multiple
 Organization objects below the Tree object to 
 represent separate business units or subsidiaries.

C Every tree requires an Admin User object. 
 You will log in as Admin to create or import other 
 User objects and to create the rest of your tree
 structure.

D This example shows two Organizational Unit 
 objects at the department level (LAB and IS). 

E It  also illustrates how Organizational Unit objects 
 can be nested to provide as complex a hierarchy 
 as is necessary to manage the organization. 

This illustrates the basic elements you should 
consider when planning your tree.

A The Tree object is the top container object in the 
 tree. It usually contains an Organization object 
 (specified in the install using O=COMPANY) that 
 represents your company or organization.

B The Organization object is normally the first 
 (and often the only) container object under the 
 Tree object. It is  typically named after your 
 organization. 

 Small organizations keep object management 
 simple by having all other objects, such as users, 
 printers, and servers, directly under the 
 Organization object.

 Organizations that are large enough to have
 departments or other organizational units usually 
 decide to have their tree structure reflect their 
 organizational structure.

COMPANY

SERVERS PRINTERS

LAB ISadmin

USERS

EXAMPLE_TREE

A

C

B

D

E
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2.2.2  Your Current Lab Tree
The eDirectory tree you have created by installing OES in your lab is illustrated and explained in 
Figure 2-2. The objects that are dimmed are for explanatory purposes and do not exist in your 
current tree. When you finish with this guide, your tree will look more like Figure 2-1.

Figure 2-2   Your Current Lab Tree

C The OES installation process can also create 
 Organizational Unit objects to define a context
 for the OES Server object (DNS hostname).

D All other Organization Unit objects that you have 
 planned for your tree must be created after the 
 installation completes.

E The exception to D is that subsequent 
 installations can create additional contexts (for 
 example, IS > Servers) to contain other OES 
 servers (for example, IS_NW) that 
 you install into the tree.

A The OES installation process requires that you
 specify names for the following objects:

 A1 A Tree object
 A2 An Organization object

B One of the first objects you specify during an 
 initial installation is the Admin user.  
 
 During an initial installation, you should also 
 specify this Admin for each parameter 
 that calls for a User object (administrator, proxy 
 user, etc.).

COMPANY

SERVERS PRINTERS

LAB ISadmin

T USERSR

EXAMPLE_TREE

LAB_NW

B

A1

A2

D

SERVERS

EC

(DNS hostname) IS_NW (DNS hostname)
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2.2.3  Expanding Your Lab Tree
The instructions in this guide cover only the installation of a single OES server in the tree. 

If you were to decide to install additional servers in the tree, the processes you would follow could 
involve some preparatory tasks, as illustrated in Figure 2-3. 

Figure 2-3   An Expanded Tree

2.3  Accessing iManager
Novell iManager is the main browser-based tool you will use to manage eDirectory and your OES 
services. 

To start iManager and prepare your browser for future sessions:
1 In Internet Explorer 6 or later, start iManager by entering the following URL:
http://IP_or_DNS/nps

where IP_or_DNS is the IP address or DNS name of your OES server.
If your server has a DNS name on your network, the OES installation used that name when 
creating the SSL certificate for the server. We recommend that you use that name in all OES 
access URLs.

IMPORTANT: Although most OES tasks can be performed using Mozilla-based browsers, 
some of the printer configuration steps in this guide work only with Internet Explorer. For this 
reason, the procedures in this guide assume that IE is the browser being used.

B If you want to specify other Admin users in the OES 
 installation parameters, you can do this during
 the installation.

A During subsequent installations into the same tree, 
 you can create new Organizational Unit objects to 
 provide a context for other OES servers being 
 installed.

COMPANY

SERVERS PRINTERS

LAB ISadmin

USERS SERVERS

B

A

admin2

LAB_NW (DNS hostname) IS_NW (DNS hostname)

EXAMPLE_TREE
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2 (Conditional) If you do not receive a security alert (typically a pop-up message stating that the 
certificate is not trusted by your browser), skip to Section 2.4, “Setting Up Role-Based 
Services,” on page 24.
If you receive a security alert, it is because the eDirectory certificate authority (CA) that issued 
the certificate for your OES server is not recognized by your browser as a valid CA. 
In this case, you have the following options:

• You can click Yes to proceed each time you receive an alert.

If you prefer this option, skip to Section 2.4, “Setting Up Role-Based Services,” on 
page 24.

• You can avoid future messages when using the browser by importing the CA’s certificate 
(also called the root certificate).
If you want to do this, continue with Step 3.

• You can purchase and install a server certificate from a third-party CA that the browser 
recognizes.
This process is beyond the scope of this guide. For more information, see the 
documentation for your Linux platform and “Using Certificate Authorities from Third-
Party Providers” in the Novell eDirectory 8.7.3 Administration Guide.

3 In the Security Alert pop-up dialog box, click View Certificate.
4 Click Install Certificate > Next.
5 Select the Place All Certificates in the Following Store option.
6 Click Browse.
7 Select Trusted Root Certification Authorities.
8 Click OK > Next > Finish.
9 Confirm that you want to add the certificate to the root store. 

10 Click OK > OK > Yes.

Do not close iManager. Continue with the next section, Setting Up Role-Based Services.

2.4  Setting Up Role-Based Services
When iManager is installed in connection with OES, the administrative tasks available through the 
Roles and Tasks icon are available to all users until you run the configuration wizard.

1 If you haven’t done so already, log in to iManager using the eDirectory Admin user account 
and password.

2 Click the Configure icon .
3 Select Role Based Services > RBS Configuration.
4 Select the Configure iManager link in the Notice.
5 Click the Browse icon  next to the Container field.
6 Click COMPANY, then click Next.
7 Click the Browse icon  next to the Scope field.
8 Click EXAMPLE_TREE.
9 Click Start.
or OES SP2 Linux
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10 When the installation process completes, click Close.
The eDirectory Admin user is now the only user configured to perform the administrative tasks 
available through the Roles and Tasks icon.

Do not close iManager. Continue with the next section, Creating a Context for Your Users and 
Groups.

2.5  Creating a Context for Your Users and 
Groups
All OES products require that you create User objects to represent the users on your system. The 
Linux User Management and Samba components for OES Linux servers also require that you create 
a Group object that you can assign the users to.

If you reviewed Section 2.2, “An Introduction to eDirectory Planning,” on page 20, you might have 
noticed an Organizational Unit object in Figure 2-2 and Figure 2-3 named Users. It is usually helpful 
to have at least one Organization Unit object to contain user-related objects, such as User objects 
and Group objects. 

To create an Organizational Unit container object named Users in the LAB Organizational Unit 
object:

1 In iManager, click the View Objects icon .
2 In the left pane, click the down-arrow  next to the COMPANY Organization object . 
3 Click LAB, then select Create Object from the drop-down list.
4 From the Available Object Classes list, select Organizational Unit, then click OK.
5 In the Organizational Unit name field, type USERS.
6 Click OK > OK.

Do not close iManager. Continue with the next section, Setting Up Universal Password for Users.

2.6  Setting Up Universal Password for Users
On networks where administrators plan to provide Samba access from Windows workstations to file 
services on an OES server, the simplest password management method is to establish a Universal 
Password policy for all eDirectory users. This ensures that passwords are always synchronized.

The OES for Linux installation creates a Universal Password (UP) policy named Samba Default 
Password Policy. 

To ensure a consistent lab experience, you will associate the Samba policy with the USERS 
container created in Section 2.5, “Creating a Context for Your Users and Groups,” on page 25.

Complete the following steps:
1 In iManager, click the Roles and Tasks icon .
2 Click Passwords > Password Policies.
3 Click Edit.
4 Click the Policy Assignment tab.
5 Click the Browse icon  next to the Assign To field.
eDirectory, Users and Groups, and Identity Services 25
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6 In the Contents pane, click the down-arrow  next to COMPANY, then click the down-arrow  
next to LAB.

7 Select the USERS Organization Unit object, then click OK.
8 Click Apply > OK.

Do not close iManager. Continue with the next section, Creating Users (First Server in the Tree).

2.7  Creating Users (First Server in the Tree)
NOTE: If you have already installed and worked with an OES NetWare server, the following three 
User objects already exist and only need to be enabled for Linux User Management. For 
instructions, skip to Section 2.10, “Enabling the Group Object for Linux User Management 
(LUM),” on page 28.

For the lab exercises, you will need to create the users shown in Table 2-1.

Table 2-1   Usesr to Create

1 In the left pane, continue from Step 8 in the previous section by clicking Users > Create User.
2 In the Username field, type a username from Table 2-1. 

This is ajohns the first time through the process.
3 Type the first name (optional) and last name (required) for the user as shown in Table 2-1.
4 Click the Browse icon  next to the Context field.
5 Click the USERS object.
6 Type the same password in both the Password and Retype Password fields. 
7 Do not check Set Simple Password. 

This is not required for OES because Universal Password is used.
8 Do not check Create Home Directory.

This option applies only to NCPTM volumes.
9 (Optional) If desired, type a title and other information you want to appear in eGuide search 

results.
10 Click OK.
11 Click Repeat Task to repeat the process until the other users listed in Table 2-1 on page 26 and 

any additional User objects you want are created.
If you create additional User obects for users that already exist on the Windows workstation, be 
sure the password you set in Step 6 matches the Windows password.

12 Click OK.

Username First Name Last Name

User 1: ajohns Arnold Johns

User 2: bjohnson Bobby Johnson

User 3: cmartin Chris Martin
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Do not close iManager. Continue with the next section, Section 2.8, “Creating Corresponding 
Windows Users,” on page 27.

2.8  Creating Corresponding Windows Users
Some OES services, such as Samba and iFolder®, interact seamlessly with Windows users that have 
the same username and password as the eDirectory users.

You must now create Windows user accounts for the three users listed in Table 2-1 on page 26 and 
assign each user the same password you specified for the corresponding eDirectory account.

1 On the Windows workstation, log in as an Administrator user.
2 Access the Control Panel and select User Accounts (Windows XP) or Users and Passwords 

(Windows 2000).
On Windows 2000, you specify the password before the account type.

3 Create a user account for each user in Table 2-1, specifying that the account is Limited 
(Windows XP) or Standard (Windows 2000) and setting the same password you specified in 
Step 6 on page 26.

2.9  Creating a Group Object
To simplify user management, you should create a group and associate users with the group. This 
lets you apply actions to multiple users by simply performing the action on the group that the users 
belong to. 

1 In iManager > Roles and Tasks, click Groups > Create Group.
2 In the Group Name field, type LinuxUsers.

We are using this name because the users in this group will be enabled for Linux access (or 
Linux User Management).The name contains uppercase and lowercase letters simply to 
illustrate that case is preserved in object names. Some administrators use mixed case to 
improve readability.

3 Click the Browse icon  next to the Context field.
4 Click the USERS object.
5 Click OK > Modify.
6 Click the Members tab.
7 Click the Browse icon  next to the Members field.
8 Click the down-arrow  next to USERS.
9 Click each User object you created in Section 2.7, “Creating Users (First Server in the Tree),” 

on page 26, then click OK > Apply > OK.

Do not close iManager. Continue with the next section, Creating Users (First Server in the Tree).
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2.10  Enabling the Group Object for Linux User 
Management (LUM)
If you want eDirectory users to access PAM-enabled services such as login or passwd, on an OES 
server or Linux workstation, you need to enable the users for Linux access (LUM). 

LUM is also required if you want Samba (Windows CIFS/SMB) file services from the OES server 
available to eDirectory users.

Because Linux access requires that users belong to a Linux-enabled group, we will enable the 
LinuxUsers group and the User objects just added to the group at the same time.

1 In the Roles and Tasks list, click Linux User Management > Enable Groups for Linux.
2 Click the Browse icon  next to the Group Name field.
3 Click LinuxUsers > OK.
4 Make sure the Linux-Enable All Users in These Groups option is selected, then click Next 

twice.
5 Click the Browse icon  next to the Linux Workstation Name field.
6 Click the up-arrow .
7 Click the down-arrow  next to SERVERS.
8 Click the UNIX Workstation object for the server you are installing, then click OK.
9 Click Next > Finish > OK.

Do not close iManager. Continue with the next section, Enabling Users for Samba.

2.11  Enabling Users for Samba
Users who access Windows file services (CIFS) on Linux servers must be enabled for Samba.

1 In the Roles and Tasks list, click Samba Management > Enable Linux User for Samba.
2 Click the Browse icon  next to the Select a Linux User to Enable for Samba field.
3 Click the up-arrow .
4 Click the down-arrow  next to USERS.
5 Click ajohns.
6 Click OK twice.
7 Repeat the task for each user you created in this guide.
8 Click OK to finish.
9 Close iManager.

Continue with the next section, A Note about Identity Manager Bundle Edition.
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2.12  A Note about Identity Manager Bundle 
Edition
If your organization has more than one directory storing user information, you should consider 
implementing the Novell Identity Manager Bundle Edition included with Novell Open Enterprise 
Server.

The Identity Manager Bundle Edition provides licensed synchronization of information (including 
passwords) held in NT Domains, Active Directory* Domains, and eDirectory trees. 

Not only can you import User objects into eDirectory rather than creating them as you have in this 
section, but you can use Identity Manager to keep all the user data (including passwords) that are 
stored in your different databases synchronized with each other. 

When data from one system changes, Identity Manager detects and propagates these changes to 
other connected systems based on the business policies you define. 

For more information, see “Using the Identity Manager Bundle Edition” in the Novell OES SP2 
Planning and Implementation Guide.

2.13  What’s Next
When you have created all the User objects for your lab, continue with Chapter 3, “Novell Samba 
(Windows File Services) on OES,” on page 31.
eDirectory, Users and Groups, and Identity Services 29
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3Novell Samba (Windows File 
Services) on OES

Samba is an open-source software suite (freely available under the GNU General Public License) 
that lets you use the Microsoft* SMB/CIFS networking protocol with Linux computers and other 
platforms. Samba lets Windows users access the Novell® Open Enterprise Server (OES) like they 
would a Windows file server.

This section discusses the following:

• Section 3.1, “Overview of Novell Samba,” on page 31
• Section 3.2, “Create User Home Directories,” on page 32
• Section 3.3, “What’s Next,” on page 32

3.1  Overview of Novell Samba
Figure 3-1 on page 31 illustrates the file services that are enabled by completing the steps in the 
section that follows. 

A more detailed overview of Samba file services on OES is found in “Novell Samba” in the Novell 
OES SP2 Planning and Implementation Guide.

Figure 3-1   Samba on OES

eDirectory
LDAP server

Samba users must
be enabled for 
Linux User
Management
(LUM)

Any CIFS/SMB Client
(such as Windows Explorer)

Samba server
processes

Web Folders
(Windows Explorer or

Internet Explorer browser)

Access Methods Authentication File Storage Services

OES Linux
server

WebDAV

CIFS
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3.2  Create User Home Directories
If you followed the steps in Section 2.11, “Enabling Users for Samba,” on page 28, the User objects 
you created are enabled for access to Samba on OES.

However, before users can access Samba, you must create user home directories. Since home 
directories are created the first time users log in to the server, it is easy to create the directories by 
logging in as each user from a shell prompt..

1 On your server, open a shell prompt .
2 Set the system so that the contents of the home directories you are going to create are hidden 

from everyone except the directory owner by entering the following to change the umask:
umask 0077

3 Log in using the su command for each User object you created in Section 2.7, “Creating Users 
(First Server in the Tree),” on page 26. 
Because you are logged in as root, you won’t need to enter a user password.
For example, log in for ajohns by entering
su ajohns

exit

The su (switch user) command logs in ajohns, automatically creating a home directory named 
ajohns. The exit command logs ajohns out.

4 Repeat Step 3 for each user.
5 Restore the default umask setting by entering
umask 0022

6 At the shell prompt, enter exit.

3.3  What’s Next
If you want to test Samba file services at this point, go to Section 10.1, “Using Samba (Windows 
File Services),” on page 55.

Otherwise, continue with Chapter 4, “iFolder 3.x,” on page 33.
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4iFolder 3.x

As a key file service component of Novell® Open Enterprise Server (OES), iFolder® 3.x provides a 
Web- and network-based repository (iFolder server) that stores master copies of locally accessible 
files. 

This section discusses the following:

• Section 4.1, “Overview of iFolder,” on page 33
• Section 4.2, “Install iFolder 3.x Enterprise Server and Web Access,” on page 34
• Section 4.3, “Installing the iFolder 3.x iManager Plug-in,” on page 35
• Section 4.4, “Provisioning Users for iFolder 3.x,” on page 36
• Section 4.5, “Installing the iFolder Client,” on page 36
• Section 4.6, “Configuring iFolder Accounts and Creating iFolders,” on page 37
• Section 4.7, “What’s Next,” on page 38

4.1  Overview of iFolder
Figure 4-1 illustrates the file services that are enabled by completing the steps in the sections that 
follow. 

A more detailed overview of iFolder 3.x file services on OES is found in “Novell iFolder 3.1” in the 
Novell OES SP2 Planning and Implementation Guide.
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Figure 4-1   iFolder File Services on OES

4.2  Install iFolder 3.x Enterprise Server and Web 
Access
The iFolder 3.x software distributed with OES SP2 should be installed after the OES server is up and 
running. 

1 Log in to the OES Linux server as the root user.
2 Use the following table to install and configure iFolder 3.x.

Screen Name Action

Desktop 1. Click the N in the lower-left corner, then click 
System > YaST.

YaST 1. Click Network Services.

2. Scroll down and click iFolder 3.x.

3. Click Continue to install the iFolder 3.x 
RPMs.

4. When prompted, insert the Open Enterprise 
Server SP2 CD2 CD, then click OK.

OES Li nux
server

eDirectory
LDAP se rver

iFolder Client
for Novell Linux Desktop

iFolder Client
for Windows 2000/XP 

Access Methods Authentication/File Encryption iFolder 3.x Services

iFolder Client
for Macintosh OS X 10.3x

iFolder 3.x
Enterprise se rvers

iFolder 3.x Web Access
via a Web browser

iFolder 3.x Web Access
server on the same 

or different OES se rver

HTTPS

HTTPS

HTTPS

HTTPS

HTTPS

Sync

Upload or Download

eDirectory LDAP 
server on the 

same or different
OES se rver
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Continue with the next section, Installing the iFolder Client.

4.3  Installing the iFolder 3.x iManager Plug-in
To manage iFolder 3.x users and servers, you must install the iFolder 3 plug-in.

1 Start iManager and log in as the Admin user.
2 In iManager, click the Configure icon 

Novell iFolder 3 LDAP Server Configuration 1. In the Admin Password field, type the 
eDirectoryTM Admin user password you 
specified in Section 1.5, “Configure 
eDirectory,” on page 16.

2. Click Next.

iFolder System Configuration 1. In the System Name field, type 
IF3_hostname (for example 
IF3_myserver).

2. In the System Store Path field, append 
/data to the path so that the field now 
reads 
/var/opt/novell/ifolder3/data.

3. Click Next.

iFolder Admin Configuration 1. In the iFolder Admin DN field, type 
cn=admin.o=COMPANY. 
For simplicity, we’ll use the eDirectory 
Admin user to administer iFolder 3 in this 
guide. This is not recommended in a 
production environment.

2. Type the eDirectory Admin user password in 
the iFolder Admin Password and Verify 
Admin Password fields.

3. In the Proxy Context field, type o=COMPANY. 

4. Click Next.

5. Click Yes to restart the Apache server.

YaST 1. Scroll down and click iFolder 3.x Web 
Access.

2. Click Continue to install the iFolder 3.x Web 
Access RPMs.

IFolder Web Access Configuration 1. In the iFolder Server URL field, add :80 
(port 80) after localhost so that the field now 
reads
http://localhost:80

2. Click Next.

3. Click Yes to restart the Apache server.

YaST 1. Close YaST.

Desktop 1. Click the red N, then click Logout twice.

Screen Name Action
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3 Click Module Installation > Available Novell Plug-in Modules.
4 Select iFolder3.npm.
5 Click Install.
6 When the process completes, close iManager.
7 Log in to the server as the root user and click the Shell Prompt icon .
8 At the shell prompt, stop and restart the Tomcat servlet engine by entering the following 

command:
/etc/init.d/novell-tomcat4 restart

Give Tomcat a couple of minutes to restart, then continue with the next section, Provisioning Users 
for iFolder 3.x.

4.4  Provisioning Users for iFolder 3.x
Users who access iFolder file services must be provisioned for iFolder.

1 Log in to iManager as the Admin user.
2 Click the Roles and Tasks icon .
3 From the Roles and Tasks list, select Novell iFolder 3 > System.
4 In the iFolder Server field, type the same IP address or DNS hostname you entered to open 

iManager.
5 Select Authenticate Using Current iManager Credentials, then click OK.
6 Click OK to import the certificate.
7 Click the LDAP tab.
8 Click Modify.
9 In the Search DNs field and type ou=USERS,ou=LAB,o=COMPANY.

IMPORTANT: The elements are separated by commas, not periods.

10 Press Enter, then click OK.
11 Click Update and Synchronize Now.
12 Close iManager.

Continue with the next section, Installing the iFolder Client.

4.5  Installing the iFolder Client
NOTE: Although the exercises in this guide focus on Windows, the iFolder client is also available 
for Linux and Macintosh*. For more information, see the iFolder User Guide for Novell iFolder 3.x.

The iFolder client is required for 

• Automatically synchronizing local iFolder files with the files on the iFolder 3.x enterprise 
server.

• The iFolder owner to share iFolders with other users.
or OES SP2 Linux
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IMPORTANT: To install the client, the workstation must have an active Internet connection.

To install the iFolder client:
1 Make sure you are logged in to the workstation as a Windows user with Administrator 

privileges.
2 Access your OES Linux server’s welcome pages by entering either the server’s IP address or 

DNS hostname followed by /welcome in your browser.
For example: myserver.company.example.com/welcome

3 On the OES Welcome Page in the left panel, click the iFolder 3.0 link.
4 In the iFolder links box, click Download iFolder 3.0 Windows Client. 
5 Open the downloaded file and install the client. 

The installation process includes several steps. For the installation to succeed, you must agree, 
accept, and answer Yes to the various prompts.
5a The iFolder 3.1 client requires the Microsoft .NET framework. If you have not already 

installed .NET software, it is automatically downloaded and installed. You must accept 
the license agreement. Then, after the software is installed, it must be configured (an 
automatic process).
You are then prompted to restart the workstation. 

5b Click the Restart button.
After the workstation restarts, you are prompted to install the client software. 

5c Click through the dialogs, accepting the defaults, until the process is finished, then click 
Yes to restart the workstation again.
After the workstation restarts, you are informed that the Mono framework for Linux is 
being installed.
The Mono® project is an open source effort led by Novell and is the foundation for many 
new applications.

5d If your workstation has a personal firewall (the default for Windows XP), you must 
choose to unblock the Mono-XSP Server.

5e When you are prompted to set up an iFolder account, click No. 
You will set up accounts in the next section.

6 Log out of the Windows workstation.

Continue with Configuring iFolder Accounts and Creating iFolders.

4.6  Configuring iFolder Accounts and Creating 
iFolders
Before users can create iFolders, they must set up an iFolder account on the workstation. 

You should have already create a Windows user account for each eDirectory user as instructed in 
Section 2.8, “Creating Corresponding Windows Users,” on page 27. You must now configure an 
iFolder account and create an iFolder for each user.

1 Log in to the Windows workstation as one of the users you created in Section 2.8, “Creating 
Corresponding Windows Users,” on page 27. 
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The first time through this is ajohns.
2 When you are prompted to set up an iFolder account, click Yes.
3 In the Server field, type the IP address or DNS hostname of your OES Linux server.
4 Type the username (ajohns, the first time) and password in their respective fields.
5 Select Remember Password, then click OK.
6 If prompted, accept the certificate by clicking Yes. 
7 Right-click the desktop, then click New to create a new folder named username_IF3, where 

username is the logged-in user.
For example, create a folder named ajohns_IF3 for ajohns.

8 After creating the folder, right-click it, then click Convert to an iFolder.
9 Click OK.

10 Select Do Not Show This Message Again, then click Close.
11 Log out and repeat this process for the other users.

4.7  What’s Next
If you want to test iFolder file services at this point, go to Section 10.2, “Using iFolder,” on page 56.

Otherwise, continue with Chapter 5, “Virtual Office,” on page 39.
or OES SP2 Linux
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5Virtual Office

As a key productivity component of Novell® Open Enterprise Server (OES), Novell Virtual Office 
provides Web access to OES services. 

This section discusses the following:

• Section 5.1, “Overview of Virtual Office,” on page 39
• Section 5.2, “What’s Next,” on page 39

5.1  Overview of Virtual Office
Figure 5-1 on page 39 illustrates the services that are available by default on the lab installation of 
OES outlined in this guide. 

A more detailed overview of Virtual Office on OES is found in “Overview of Virtual Office” in the 
Novell OES SP2 Planning and Implementation Guide.

Figure 5-1    Virtual Office Overview

5.2  What’s Next
When you completed the instructions in Chapter 1, “Installing an OES Linux Server in Your Lab,” 
on page 11, your Virtual Office installation was complete. No further configuration is required.
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If you want to test Virtual Office at this point, go to Section 10.3, “Using Virtual Office,” on 
page 57.

Otherwise, continue with Chapter 6, “iPrint,” on page 41.
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6iPrint

As the print services component of Novell® Open Enterprise Server (OES), Novell iPrint provides a 
powerful and easy-to-implement printing solution that lets your network users print from any Linux, 
Macintosh, or Windows workstation to any network printer. iPrint provides the print services behind 
the Print button in Virtual Office.

This section discusses the following:

• Section 6.1, “Overview of iPrint,” on page 41
• Section 6.2, “Creating an eDirectory Context for Printers,” on page 42
• Section 6.3, “Creating a Print Driver Store,” on page 43
• Section 6.4, “Adding Printer Drivers to the Driver Store from the Windows Platforms,” on 

page 43
• Section 6.5, “Creating a Print Manager Object,” on page 44
• Section 6.6, “Creating iPrint Printer Objects,” on page 44
• Section 6.7, “What’s Next,” on page 45

6.1  Overview of iPrint
Figure 6-1 illustrates the printing services that are enabled by completing the steps in the sections 
that follow. 

A more detailed overview of iPrint services on OES is found in “iPrint Functionality” in the Novell 
OES SP2 Planning and Implementation Guide.
iPrint 41



42 Lab Guide f

novdocx (E
N

U
)  9 D

ecem
ber 2005
Figure 6-1   iPrint on OES

6.2  Creating an eDirectory Context for Printers
System administrators often create one or more container objects just for network printers. 
Obviously, this is an optional organizational preference issue. The printers themselves can be placed 
in the most convenient places for your network users. 

1 Log in to the Windows workstation as a Windows user with Administrator privileges.
2 Start iManager by entering the following URL in a browser Address field:
http://IP_or_DNS/nps

where IP_or_DNS is the IP address or DNS name of your OES server.
3 Log in to iManager as Admin.
4 Click the View Objects icon .
5 In the left pane, click the down-arrow  next to the COMPANY Organization object. 
6 Click LAB, then select Create Object from the drop-down list.
7 From the Available Object Classes list, select Organizational Unit, then click OK.
8 In the Organizational Unit Name field, type PRINTERS.
9 Click OK twice.
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6.3  Creating a Print Driver Store
iPrint stores print driver files by workstation type for each of your network printers in a driver store 
in eDirectoryTM.

1 In iManager, click the Roles and Tasks icon .
2 Click iPrint > Create Driver Store.
3 In the Driver Store Name field, type Print_Drivers.

This name illustrates another option for naming eDirectory objects—separating words with an 
underscore (_).

4 Click the Browse icon  next to the Container Name field.
5 Click the down-arrow  next to LAB, then click the PRINTERS Organizational Unit object.
6 Click the Browse icon  next to the eDir Server field.
7 Click the down-arrow  next to LAB, click the down-arrow  next to SERVERS, then click 

your OES server name.
8 Click OK twice.

6.4  Adding Printer Drivers to the Driver Store 
from the Windows Platforms
You can load printer drivers to the Driver Store using driver files. However, because most Windows 
workstations have an extensive list of printer drivers available on the system, the simplest way to 
add drivers for a Windows workstation is to upload them directly.

You can upload Windows XP drivers from a Windows XP workstation, Windows 2000 drivers from 
a Windows 2000 workstation, etc.

Complete the following steps once for each of the Windows platforms (XP, 2000, etc.) that you have 
in your lab:

1 Open a browser on the workstation and enter the following URL in the Address field:
http://IP_or_DNS/ipp

where IP_or_DNS is the IP address or DNS name of your OES server.
2 Click Install iPrint Client.
3 Click either Open (Windows 2000) or Run (Windows XP).
4 Click Next and follow any prompts.
5 After the client installs, click Finish.
6 Close the browser.
7 If it is not already running, start iManager (http://server/nps) and log in as the Admin user.
8 Click iPrint > Manage Driver Store.
9 Click the Browse icon  next to the iPrint Driver Store Name field.

10 Browse to the Printers container (COMPANY > LAB > PRINTERS), then click the 
Print_Drivers object.

11 Click OK.
12 Click the Drivers tab.
iPrint 43
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13 Click the link for your workstation type (Windows XP, Windows 2000, etc.).
14 Click Add from System.
15 In the Add Resource dialog box, select the correct driver for the printer you plan to use for the 

lab test.
16 Click OK.
17 (Optional) To test multiple printers, repeat Step 14 through Step 16 for each printer you want to 

test.
18 When finished, click Apply > OK.

6.5  Creating a Print Manager Object
The iPrint Manager is represented by and managed through a Print Manager object in eDirectory. It 
is a daemon that runs on the OES server, and it must be running when you create Print objects. After 
printing is set up, the iPrint Manager receives print job requests and forwards them to printers when 
the printers are ready.

1 Continuing from Step 18 in the previous section, click iPrint > Create Print Manager.
2 In the Manager Name field, type the following:
iPrint_Manager

3 Click the Browse icon  next to the Container Name field.
4 Click the down-arrow  next to LAB, then click PRINTERS.
5 Click the Browse icon  next to the eDir Server field.
6 Click the down-arrow  next to LAB, click the down-arrow  next to SERVERS, then click 

your OES server name.
7 Click the Browse icon  next to the Driver Store field.
8 Click the down-arrow  next to LAB, click the down-arrow  next to PRINTERS, then click 

Print_Drivers.
9 In one of the iPrint Service fields, type either the full DNS name of your lab server or its IP 

address, depending on the option you select.
10 Click OK twice.

6.6  Creating iPrint Printer Objects
You can create iPrint Printer objects for all your printers that have drivers in the Driver Store and an 
IP address or DNS name.

1 In iManager, click the Roles and Tasks icon .
2 Click iPrint > Create Printer.
3 In the Printer Name field, type a name for your printer.
4 Click the Browse icon  next to the Container Name field.
5 Click the down-arrow  next to LAB, then click PRINTERS.
6 Click the Browse icon  next to the Print Manager Name field.
7 Click the down-arrow  next to LAB, click the down-arrow  next to PRINTERS, then click 

iPrint_Manager.
or OES SP2 Linux
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8 Type the DNS name or IP address of the printer in the field indicated.
9 Type a location so users know where to find the printer.

10 (Optional) Type a description.
11 Click Next.
12 Select the appropriate drivers for each Windows platform you are testing.
13 Click Next > OK.
14 Close iManager.

6.7  What’s Next
If you want to test iPrint at this point, go to Section 10.4, “Using iPrint,” on page 58.

Otherwise, continue with Chapter 7, “NetStorage,” on page 47.
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7NetStorage

As a versatile file services component of Novell® Open Enterprise Server (OES), Novell NetStorage 
provides the file services behind the Files button in Virtual Office. NetStorage can also be accessed 
directly rather than through Virtual Office. 

This section discusses the following:

• Section 7.1, “Overview of NetStorage,” on page 47
• Section 7.2, “Making the Home Directories Available in NetStorage,” on page 48
• Section 7.3, “What’s Next,” on page 49

7.1  Overview of NetStorage
Figure 7-1 on page 47 illustrates the NetStorage file services that are enabled by default. 

A more detailed overview of NetStorage file services on OES is found in “NetStorage” in the Novell 
OES SP2 Planning and Implementation Guide.

Figure 7-1   NetStorage on OES

In OES, the default NetStorage installation provides access to a shared folder on the local file 
system that contains a ReadMe.html file with instructions for creating NetStorage Storage 
Location objects. The iFolder share is available only when iFolder 2.x is installed and configured on 
the same server.
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7.2  Making the Home Directories Available in 
NetStorage
Because NetStorage makes files available on the Internet, a logical target for most users is the home 
directories. To make a directory on the OES Linux server available in NetStorage, you must create a 
Storage Location Object that points to the directory and then add the object to a Storage Location 
List as explained in the following sections.

7.2.1  Creating a Storage Location Object
A Storage Location object stores the location of a directory that users can access through NetStorage 
and also specifies the protocol used for file access.

1 Start iManager by entering the following URL in a browser Address field:
http://IP_or_DNS/nps

where IP_or_DNS is the IP address or DNS name of your OES server.
2 Log in to iManager as the Admin user.
3 Click the Roles and Tasks icon .
4 Click File Access (NetStorage) > New Storage Location.
5 In the Object Name field, type
StorLoc_hostname

where hostname is the name of your lab server. This is the name of the Storage Location object 
in eDirectoryTM (for example, StorLoc_myserver).

6 In the DisplayName field, type
Home

This is the name that displays in the NetStorage directory access list.
7 In the Directory Location field, type
ssh://IP_or_DNS_Name/Home

where IP_or_DNS_Name is the IP address or full DNS name of your lab server (for example, 
ssh://myserver.mysite.example.com/Home).

8 Click the Browse icon  next to the Context field.
9 Click the down-arrow  next to COMPANY, click the down-arrow  next to LAB, then click 

the SERVERS Organizational Unit object.
10 Click Create > OK.

7.2.2  Adding the Object to a Storage Location List
A Storage Location List stores information about the Storage Location objects that a User, Group, or 
Container object has access to.

1 In the list of tasks below File Access (NetStorage), click Assign Storage Location to Object. 
2 Click the Browse icon  next to the Object field.
3 Click USERS > OK.
4 Click the Browse icon  next to the Storage Location Objects field.
or OES SP2 Linux
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5 Click the down-arrow  next to SERVERS.
6 Click the StorLoc_hostname object for your lab server, then click OK.
7 Click OK twice.

7.3  What’s Next
If you want to test NetStorage file services at this point, go to Section 10.5, “Using NetStorage,” on 
page 58.

Otherwise, continue with Chapter 8, “eGuide,” on page 51.
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8eGuide

Novell® eGuide provides user access to information stored in eDirectoryTM and other LDAP-
compliant data sources. eGuide provides “white pages” access to user information through the 
eGuide button in Virtual Office.

Depending on how you configure eGuide, any information you choose to store in eDirectory objects 
can be exposed to users.

This section discusses the following:

• Section 8.1, “Overview of eGuide,” on page 51
• Section 8.2, “What’s Next,” on page 52

8.1  Overview of eGuide
Figure 8-1 on page 51 illustrates that by default eGuide on OES lets users view their own 
information and see limited information about other users on the system. 

A more detailed overview of eGuide on OES is found in “White Pages (eGuide)” in the Novell OES 
SP2 Planning and Implementation Guide.

Figure 8-1   eGuide on OES
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8.2  What’s Next
If you want to test eGuide at this point, go to Section 10.6, “Using eGuide,” on page 59.

Otherwise, continue with Chapter 9, “eDirectory Linux Access (LUM),” on page 53.
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9eDirectory Linux Access (LUM)

Novell® Linux User Management (LUM) is a key component of Novell Open Enterprise Server 
(OES) and provides two basic functions:

• It lets you create Linux User objects in eDirectoryTM for Windows users who will access Samba 
file services on your OES server, as demonstrated earlier in this guide. 

• It lets you require users who are accessing PAM-enabled services, such as login or ftp, on the 
OES server to authenticate through eDirectory. 

This section discusses the following:

• Section 9.1, “Overview of Linux User Management,” on page 53
• Section 9.2, “What’s New,” on page 54

9.1  Overview of Linux User Management
Figure 9-1 on page 53 illustrates how LUM works with PAM-enabled services. For a more detailed 
overview, see “Linux Access for eDirectory Users (LUM)” in the Novell OES SP2 Planning and 
Implementation Guide.

Figure 9-1   Linux User Management on OES
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Table 9-1   PAM-enabled Services

The user-creation steps you completed earlier in this guide (Section 2.7, “Creating Users (First 
Server in the Tree),” on page 26) created three LUM users with rights to log in to the OES server. 

9.2  What’s New
If you want to test LUM services at this point, go to Section 10.7, “Using Linux User Management 
(LUM),” on page 59.

Otherwise, continue with Chapter 10, “Getting Acquainted with OES,” on page 55.

Command Where Executed Function for LUM Users

ftp Another host Transfer files to and from the OES server after supplying an 
eDirectory/LUM username and password.

login OES server or in an 
SSH session with the 
OES server

Log in to the OES server using an eDirectory/LUM username 
and password, either directly or in an SSH session with the 
server if sshd is also enabled.

passwd OES server or in an 
SSH session with the 
OES server

This command is not PAM-enabled by default, meaning that it 
does not use LUM. eDirectory users manage their passwords 
through eDirectory, not on the server.

For more information, see “Password Support in OES” in the 
Novell OES SP2 Planning and Implementation Guide.

rlogin Another host Log in to the OES server from a remote host system shell prompt 
after supplying an eDirectory/LUM username and password.

rsh Another host Execute a command on the OES server from a remote host 
system shell prompt after supplying an eDirectory/LUM 
username and password.

sshd Another host Establish a secure encrypted connection with the OES server 
after supplying an eDirectory/LUM username and password.

su OES server or in an 
SSH session with the 
OES server

While logged in as an eDirectory/LUM user, temporarily become 
another user.

This is most often used to temporarily become the root user (who 
is purposely not a LUM user) to administer the local Linux 
machine will full system privileges. 
or OES SP2 Linux
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10Getting Acquainted with OES

After you have installed Novell® Open Enterprise Server (OES) and completed the configuration 
instructions located in the preceding sections, your OES server is ready for lab use.

The instructions and information in this section will acquaint you with the basic services available in 
OES. More detailed service overviews are available in the Novell OES SP2 Planning and 
Implementation Guide. For comprehensive documentation for each service, see the administration 
guides and other documentation listed on the OES documentation Web site (http://www.novell.com/
documentation/oes).

This section guides you through the following tasks:

• Section 10.1, “Using Samba (Windows File Services),” on page 55
• Section 10.2, “Using iFolder,” on page 56
• Section 10.3, “Using Virtual Office,” on page 57
• Section 10.4, “Using iPrint,” on page 58
• Section 10.5, “Using NetStorage,” on page 58
• Section 10.6, “Using eGuide,” on page 59
• Section 10.7, “Using Linux User Management (LUM),” on page 59
• Section 10.8, “What’s Next,” on page 60

10.1  Using Samba (Windows File Services)
IMPORTANT: To perform the steps in this section, you must have completed all the instructions in 
Chapter 3, “Novell Samba (Windows File Services) on OES,” on page 31.

1 Log in to the Windows workstation as ajohns.
2 In Windows Explorer or My Computer, click Tools > Map Network Drive.
3 From the drop-down list, select an unused drive letter.
4 In the Folder field, type the following:
\\IP_or_DNS_Name\ajohns

where IP_or_DNS_Name is the IP address or full DNS name of the OES server.
5 Click Finish.

Entering a password is not required because the Windows and Samba usernames and 
passwords match.

6 Drag-and-drop some files from Windows Explorer or the desktop into the Samba folder (the 
drive mapping you just created).

7 Log in to the OES server as the root user and open the Konqueror file manager . 
8 Access the /home/ajohns directory and verify that the files you placed in the Samba folder 

appear on the server.

By default, this drive mapping is available each time ajohns logs in to the Windows workstation.
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Continue with the next section, Section 10.2, “Using iFolder,” on page 56.

10.2  Using iFolder
IMPORTANT: To perform the steps in this section, you must have completed all the instructions in 
Chapter 4, “iFolder 3.x,” on page 33.

10.2.1  Observing File Synchronization
To understand more about how iFolder works, it is helpful to observe the file synchronization 
processes in action.

1 Open the ajohns_IF3 folder on the desktop.
2 Right-click the iFolder icon  in your system tray, then click Preferences.
3 To facilitate observation of the synchronization process, set the Synchronization Frequency to 

1 minute, then click OK.
4 Right-click the iFolder icon  in your system tray, then click iFolders.
5 Create two or three test files on your desktop.
6 Drag and drop the files into the ajohns_IF3 folder.
7 In the iFolders window, observe that the next time ajohns_IF3 is selected, the files are 

synchronized with the iFolder server.
Rather than waiting for the next synchronization, you can right-click the ajohns_IF3 entry in 
the iFolders window, then click Synchronize Now.

8 Delete a file or drag it back onto the desktop and observe how the action is synchronized with 
the server.

9 Keep one or two files in the iFolder Home folder and close the Windows Explorer window.

Continue with the next section, “Using iFolder Web Access.”

10.2.2  Using iFolder Web Access

NOTE: All interaction with an iFolder 3.x server is encrypted using SSL 3.0 by default.

Users can access their iFolders through most browsers that support SSL 3.0. 
1 Open your browser and enter the following URL:
https://IP_or_DNS_name/ifolder

where IP_or_DNS_name is the IP address or complete DNS name of your OES Linux server.
2 Log in as ajohns.
3 Click the ajohns_IF3 link and observe the following:

• The files you copied in the previous section are available in the browser.
• By clicking a file link, you can download and save the file to your desktop.
• In the dialog box to the right, you can upload new files or files that you have downloaded 

and modified.
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• The New Folder dialog box lets you create new folders in the iFolder on the server. 
Changes made to iFolders on the server through browser connections are synchronized with the 
corresponding iFolders on workstation desktops the next time users log in. 

4 Close the browser.

Continue with the next section, “Sharing an iFolder.”

10.2.3  Sharing an iFolder
Users can share their iFolders with other iFolder users who have configured an iFolder account on 
the same server.

1 While still logged in as ajohns, right-click the ajohns_IF3 folder on the desktop.
2 Click iFolder > Share With.
3 Click Add > Bobby Johnson (left panel) > Add > OK.

Notice that the permissions are set to Read/Write.
4 Click Apply > OK.
5 Log ajohns out of Windows.
6 Log in as bjohnson.
7 Right-click the iFolder icon  on the status bar, then click iFolders. 
8 Wait a few seconds or so until the ajohns_IF3 folder appears in your list, click the folder, 

then click Set Up .
9 In the dialog box, browse to the Desktop, then click OK twice.

10 After a brief synchronization, an ajohns_IF3 iFolder appears on the desktop.
Because of the default permission settings when the folder was shared, bjohnson now has Read 
and Write rights to the ajohns_IF3 iFolder.

11 Open the ajohns_IF3 folder and rename one of the files it contains. 
The file will be renamed on the server at the next synchronization and will also be renamed in 
the iFolder that ajohns has on his desktop the next time he logs in.

10.3  Using Virtual Office
1 Log bjohnson out of Windows, then log in as a Windows user with Administrator privileges.

Administrator privileges are required to install the printer in Section 10.4, “Using iPrint,” on 
page 58.

2 Using a Java-enabled Web browser, enter the following URL in the Address field:
http://IP_or_DNS/vo

where IP_or_DNS is the IP address or DNS name of your OES server.
3 Log in to Virtual Office as bjohnson. 

In contrast to Samba, there is no automatic login connection between the Windows and Virtual 
Office usernames.

4 Move the mouse over each of the icons at the top of the page and notice the labels associated 
with each icon. 
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The following sections can be accessed using their own URLs, but for demonstration purposes we 
will have you access them through Virtual Office.

10.4  Using iPrint
IMPORTANT: To perform the steps in this section, you must have completed all the instructions in 
Chapter 6, “iPrint,” on page 41.

1 In Virtual Office, click the iPrint icon .
2 (Conditional) If you have not previously installed the iPrint client on the workstation, click the 

Install iPrint Client link and install the client now.
3 After the client is installed, click the link for the printer you created in Section 6.6, “Creating 

iPrint Printer Objects,” on page 44.
You might need to click the Refresh button to see the printers.

4 Answer the prompts to install the printer on the workstation.
5 Access the Printers property page by clicking Start > Settings > Printers.
6 Right-click the printer, then click Properties.
7 Click Print Test Page > OK > OK.

A test page should print at your printer.

10.5  Using NetStorage
IMPORTANT: To perform the steps in this section, you must have completed all the instructions in 
Chapter 4, “iFolder 3.x,” on page 33 and in Section 10.2, “Using iFolder,” on page 56. 

1 In Virtual Office, click the Files icon .
2 In the left panel, click the Home folder, then click ajohns.

Notice that the folder appears to be empty. This is because you changed the umask when you 
created the home directories. (See Section 3.2, “Create User Home Directories,” on page 32.) 
As a result of the umask change, only ajohns has rights to see the contents of the ajohns home 
directory (except for the root user, of course, who can see everything on the server).

3 Click the bjohnson home directory.
4 Click the File link, then click New Folder.
5 Create a folder named Bobbys_Stuff.
6 Click Bobbys_Stuff.
7 Click File > Upload.
8 Browse to a file on the workstation, click the file, then click Open.
9 Click Upload.

Notice that the file appears in Bobbys_Stuff.
10 Click the newly uploaded file, then click the File link. 

Notice the additional file handling options that are now active, such as Delete, Rename, and 
Download.
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11 (Optional) To read more information about using NetStorage to access other file storage 
systems, click the Shared folder, then double-click the Read Me.html file.

For more information on using NetStorage, see the OES NetStorage Administration Guide for 
NetWare.

10.6  Using eGuide
1 In Virtual Office, click the eGuide icon .

Notice that Last Name and Starts With are selected in the two drop-down lists.
2 Type john in the Search field, then click Search.

Both Arnold Johns and Bobby Johnson are listed.
3 Enter various search strings to display the eDirectoryTM users you have created.

Notice that when you select the currently logged-in user, an Edit Information option is 
included. 

4 Select Bobby Johnson > Edit Information.
5 Click Change Password.

Users can change their passwords stored in eDirectory by using this dialog box.
6 Click the browser’s Back button.

Although it appears that users can edit the various fields belonging to them, attempts to save 
changes fail. To enable this feature, you must assign Role-Based Services or ACLs. For more 
information, see the Novell eGuide 2.1.2 Administration Guide.

10.7  Using Linux User Management (LUM)
The following steps briefly demonstrate how LUM works with PAM-enabled services.

1 At a the OES server, open a new shell prompt by pressing Ctrl+Alt+F1.
2 Log in as the eDirectory user cmartin.

The command prompt changes, indicating you are logged in.
3 Open a different shell prompt by pressing Ctrl+Alt+F2. 
4 Log in as the root user.
5 Change to the /etc/pam.d directory by entering
cd /etc/pam.d

6 Make a copy of the login file located in the directory by entering
cp login login.copy

7 Open the original login file for editing by entering
vi login

8 To enter Insert mode, type
i

9 Use the Delete and the Down-arrow keys to remove the first few lines of the file, so that the 
first line reads 
#%PAM-1.0
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10 Press Escape.
11 Press and hold the Shift key, then press Z twice.
12 Return to the first shell prompt and log out as user cmartin by entering

exit

13 Try to log in again as user cmartin.
The systems responds that the login request was incorrect.
When you removed the first five lines from the login file, you removed the eDirectory Linux 
Access (LUM) support from the login command.

14 To restore eDirectory Linux Access for the login command, do the following:
14a Change to the shell prompt where you are logged in as the root user, then enter

rm login

This deletes the file you changed in Step 9.
14b Enter

mv login.copy login

This renames the copy file created in Step 6 to the original filename, restoring the original 
login behavior.

15 Change back to the first shell prompt and log in as cmartin to verify that eDirectory Linux 
access is restored.

16 Press Ctrl+Alt+F7 to return to the GUI interface.

10.8  What’s Next
After you complete the exercises in this guide, we recommend you do the following:

1. Think about the needs of your organization and how the various OES product components can 
help you address those needs.

2. Go back to the various components and work with them considering the needs you identified.
3. Begin planning your organization’s eDirectory tree and the rollout of OES services to your 

organization.

As you plan for, work with, and install OES, you should consult the other OES product 
documentation:

Title Contents

Novell OES SP2 Planning and 
Implementation Guide

Detailed overviews of all components, planning 
information and instructions, and links to configuration 
and maintenance information in the administration 
guides associated with each OES product component.

OES Linux File and Data Locations Comprehensive installation instructions for all OES 
components.
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ADocumentation Updates

This appendix summarizes the changes made to this lab guide since the initial release of Novell® 
Open Enterprise Server.

A.1  January 25, 2006

A.2  December 23, 2005

A.3  November 1, 2005

A.4  October 18, 2005

A.5  October 3, 2005

Chapter or Section Changed Summary of Changes

Section 1.3, “Installing the Server 
Software,” on page 13

Corrected a reference to SP2 software. This guide uses 
SP1 software because Virtual Office isn’t included in SP2.

Chapter or Section Changed Summary of Changes

Various. Included notes that Virtual Office requires OES SP1 and 
provided information on where to get the software.

Chapter or Section Changed Summary of Changes

Entire guide. Page design reformatted to comply with revised Novell 
documentation standards.

Chapter or Section Changed Summary of Changes

All sections Made various changes recommended by the 
documentation editor.

Chapter or Section Changed Summary of Changes

Various Made various changes recommended by documentation 
testers. None are substantive.
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A.6  September 30, 2005

Chapter or Section Changed Summary of Changes

Chapter 1, “Installing an OES Linux Server 
in Your Lab,” on page 11

Modified the Important statement to reflect how to add a 
NetWare® server to a Linux tree.

Section 1.1, “Lab Setup Requirements,” on 
page 11

Modified the IP address requirement because iFolder® 3 
doesn’t require a separate address.

Removed the information about older Windows platforms 
not supported by iFolder 3.

Section 1.2.1, “Preparing the Installation 
Media,” on page 12

Changed the CD media requirement to six from five.

Updated the image/label table to reflect new CD names.

Section 1.3, “Installing the Server 
Software,” on page 13

Made minor changes to the installation instructions.

Section 1.4, “Setting the Root Password 
and Configuring the Network,” on page 15

Made minor changes, including references to running the 
online update process.

Section 1.6, “Configure OES Services,” on 
page 17

Removed the iFolder 2.x configuration instructions.

Section 1.7, “Set Up the Graphical User 
Interface,” on page 17

Renamed the section and reworked it to include steps 
rather than paragraph explanations.

Section 1.8, “What’s Next,” on page 18 Removed the statement about not logging in and other 
editing changes.

Section 2.3, “Accessing iManager,” on 
page 23

Added a statement that Internet Explorer is required for 
some tasks in this guide.

Section 2.7, “Creating Users (First Server 
in the Tree),” on page 26

Moved this section ahead and modified to reflect iManager 
changes to user management.

Section 2.8, “Creating Corresponding 
Windows Users,” on page 27

Added this section to demonstrate seamless login to 
Samba.

Section 2.9, “Creating a Group Object,” on 
page 27

Moved this section back and modified the title because 
enabling Groups for Linux access has been decoupled.

Section 2.10, “Enabling the Group Object 
for Linux User Management (LUM),” on 
page 28

Created a new section to reflect iManager changes.

Section 2.11, “Enabling Users for Samba,” 
on page 28

Created a new section to reflect iManager changes.

Section 3.2, “Create User Home 
Directories,” on page 32

Modified the title because the home directories are now also 
a target for NetStorage exercises. Modified the procedure 
for creating home directories and included instructions for 
making the directories private.

Chapter 4, “iFolder 3.x,” on page 33 Created a new chapter for iFolder 3.x. 

Removed the iFolder 2.x chapter.
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Section 5.1, “Overview of Virtual Office,” on 
page 39

Modified the graphic to reflect iFolder 3.x connection.

Section 6.4, “Adding Printer Drivers to the 
Driver Store from the Windows Platforms,” 
on page 43

Removed the references to older Windows platforms (even 
though iPrint still supports them).

Section 7.2, “Making the Home Directories 
Available in NetStorage,” on page 48

Added a new section to prepare the environment for the 
NetStorage exercises later in the guide.

Section 10.1, “Using Samba (Windows File 
Services),” on page 55

Modified this section to demonstrate seamless access from 
Windows to the Samba share. Changed instructions for 
verifying file transfers to use the GUI rather than the shell.

Section 10.2, “Using iFolder,” on page 56 Added a new section to reflect iFolder 3.x.

Removed the exercises for demonstrating iFolder 2.x.

Section 10.3, “Using Virtual Office,” on 
page 57

Changed the exercise to have bjohnson log in as 
preparation for the NetStorage exercises.

Section 10.5, “Using NetStorage,” on 
page 58

Changed the exercise to demonstrate a Storage Location 
object that is mapped to the home directories.

Section 10.6, “Using eGuide,” on page 59 Made the exercise a little more specific.

Chapter or Section Changed Summary of Changes
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