
openSUSE® provides the tools that Linux* users require in their daily activities. It comes with an easy-to-use
graphical user interface (KDE* desktop) that communicates with the underlying Linux system to access and
manage files, folders, and programs. openSUSE provides an integrated suite of applications for a wide range of
purposes (office, multimedia, Internet). The OpenOffice.org suite is also included, which allows you to edit and
save files in a number of formats. Because the office suite is available for several operating systems, you can
use the same data across different computing platforms.

Getting Started
When you start your system, you are usually prompted to
enter your username and password. If you did not install
your system yourself, check with your system administrator
for your username and password.

After logging in to KDE for the first time, you see the KDE
desktop, which shows the following basic elements:

Desktop Icons: Click an icon on the desktop to access
its associated program or application. Right-click to open
a context menu for moving, copying, or performing other
functions on an icon.

Desktop Context Menu: Right-click an empty area on
the desktop to access this context menu for creating new
objects, such as files, folders, or bookmarks; configuring
the appearance of the desktop; running applications; and
logging out.

KDE Panel: By default, the panel of your KDE desktop
consists of the following areas (from left to right): main
menu button, quick launcher, desktop previewer, taskbar,
and system tray. You can add or remove icons in the panel
and customize the appearance of the panel as well as its
location on the desktop. If you hold your mouse pointer
over an icon in the panel, a short description is displayed.

Main Menu Button: Use the icon at the far left of the
panel to open a menu which holds a search function at the
top and several tabs at the bottom, thus providing quick
access to the key functions of the menu. The Applications
tab shows all installed programs in a function-oriented menu
structure which makes it easy to find the right application
for your purpose even if you do not know the application
names yet.

Quick Launcher The quick launcher contains some
larger icons that are shortcuts to frequently used programs,
folders, and functions, such as an Internet browser, your
home folder, and direct desktop access.
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Desktop Previewer: Between the quick launcher and
the taskbar, find a miniature preview that shows your virtual
desktops. openSUSE allows you to organize your programs
and tasks on several desktops, which minimizes the number
of windows to arrange on the screen (see Section “Using
Virtual Desktops”). To switch between desktops, click one
of the symbols in the previewer.

Taskbar: By default, all started applications and open
windows are displayed in the taskbar, which allows you to
access any application regardless of the currently active
desktop. Click to open the application. Right-click to see
options for moving, restoring, or minimizing the window.

System Tray: This rightmost part of the panel usually
holds some smaller icons, including the system clock display-
ing time and date, the volume control, and icons for several
other helper applications.

Starting Programs
To start a program from the main menu, click the main
menu icon in the panel or press Alt + F1 to open the main
menu. For an overview of all programs installed on your
system, click Applications. The function-oriented menu
structure makes it easy to find the right application for your
purpose even if you do not know the application names
yet. To navigate through the structure, click an entry and
use the arrow icons at the right or the left to switch back
and forth. Apart from that, the tabs Favorites or History
provide quick access to some applications.

To search for an application, enter the application's name
(or part of it) in the search field at the top of the main
menu. Each character you enter narrows down the search.
The search results are shown directly below the search field.
The results are sorted by categories for better overview.

Customizing Your Desktop
You can change the way your KDE desktop looks and be-
haves to suit your own personal tastes and needs.

Changing Individual Desktop Elements
In the following, find some examples of how to change in-
dividual desktops elements.

Adding Program Icons to Your Desktop
To create a link to an application and place it on the desk-
top, proceed as follows:

1. Click the main menu button.
2. Browse to the desired program.
3. Left-click and drag the menu entry to the desktop then

release the mouse button.
4. Select Link Here from the context menu that appears

then position the icon as desired.

To delete an icon from your desktop, right-click the pro-
gram icon and select Move to Trash.

Customizing the KDE Panel
You can customize the KDE panel according to your prefer-
ences by adding, deleting, or moving icons or changing the
overall appearance of the panel.

1. To add or remove icons from the panel, right-click an
empty patch in the panel. A context-menu appears.

2. To add an application, click Add Application to Panel
and select the desired application from one of the cat-
egories of the submenu.

3. To add an applet (miniprogram), click Add Applet to
Panel and, from the dialog box that appears, select the
desired applet. Click Add to Panel to insert the applet
into the panel.

4. To remove icons from the panel, select Remove from
Panel → Applications or Remove from Panel → Applet
and choose the icon to remove.
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5. To change the overall appearance or behavior of the
panel, select Configure Panel from the context menu.
A configuration dialog appears where you can adjust
further settings.

Changing the Desktop Background
You can change the background colors of your desktop or
select a picture to use as the background. Because KDE of-
fers virtual desktops (see Section “Using Virtual Desktops”),
you can apply these changes to one or all of your virtual
desktops.

1. Right-click an empty patch of the desktop and select
Configure Desktop. A configuration dialog appears.

2. In Settings for Desktop select the virtual desktops to
which the changes should apply.

3. If you want a different picture as the background, click
Picture and select one of the pictures provided by the
list. To use a custom picture, click the folder button
beneath the list and select an image file from the file
system.

4. Click Slide Show to have multiple images appear in a
slide show mode.

5. If you do not want a picture on the background, click
No picture.

6. From the Options group, click the left button below
Colors to select the color for your background. For a
multicolor background, set Colors to an option other
than Single Color and click the right button below to
select a second color.

7. Click Apply then OK to close the configuration dialog.

Using the KDE Control Center
Apart from changing individual desktop elements, KDE al-
lows you to personalize your desktop to a very high degree.
Find more settings to adjust the overall appearance and
behavior of your desktop in the KDE control center. There,
you can also change fonts, keyboard and mouse configura-
tion, regional and language settings, parameters for your
Internet and network usage, and more.

Start the control center from the main menu by selecting
Favorites → Configure Desktop or press Alt + F2 and enter
kcontrol.

The sidebar provides different categories with a subset of
settings each. To get an impression of the numerous possi-
bilities, just click a category icon and explore the possibilities
provided there.

For an overview of all categories, switch to a tree view.
Change the view by selecting View → Mode → Tree View.

Clicking an item displays the corresponding settings on the
right. Change the settings as desired. No changes take effect
until you click Apply. Reset all items on the page to the
default values by clicking Default. Performing tasks in some
areas of the control center requires system administrator
(otherwise known as root) permissions.

Using Virtual Desktops
The desktop environment allows you to organize your pro-
grams and tasks on several virtual desktops. If you often
run a lot of programs simultaneously, this minimizes the
number of windows to arrange on your screen. You might,
for example, use one desktop for e-mailing and calendaring
and another for word processing or graphics applications.

Moving an Application to a Virtual Desktop
You can display a running application on one or all virtual
desktops or move it to other desktops.

1. Open the application.
2. Right-click the title bar of the application.
3. Click To Desktop.
4. Select the desktop on which to place the application.
5. To switch between desktops, click the desired desktop

in the desktop previewer in the panel.

Adding Additional Virtual Desktops
Some users might need more desktops than provided by
default. To add additional desktops:
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1. Right-click the desktop previewer in the panel and select
Configure Desktops. A configuration dialog appears
where you can increase or reduce the number of virtual
desktops. You can also change the default names of the
desktop.

2. Click OK to apply the changes and to close the configu-
ration dialog.

3. If you want the names of the desktops to appear in the
desktop previewer rather than the number, right-click
the desktop previewer and select Pager Options →
Desktop Name.

Using 3D Desktops Effects
If your computer supports Xgl, you can use graphical effects
like turning your desktop into a rotating 3D cube, enabling
translucent or transparent windows, zooming in and out of
the desktop screen, and using other window effects, such
as shadows, fading, and transformations.

To enable and use Xgl, some hardware requirements must
be met—in particular, your graphics adapter must be capa-
ble of providing 3D support. After your system has been
configured for Xgl as described in KDE User Guide, you can
make use of the following effects:

• Wrap your virtual desktops around a cube and rotate the
cube to get to another virtual desktop. Rotate the cube
with Ctrl + Alt + → or Ctrl + Alt + ←.

• Fly through the range of virtual desktops without having
to use the pager and select the one to use. To change to
this panel-like view, use Ctrl + Alt + ↓. To scroll to a
desktop left or right of the current one, keep holding
Ctrl + Alt and use → and ←.

• Zoom into certain parts of the desktop. Select the area
to enlarge and right-click while holding the Windows key.

• Show all windows opened on one virtual desktop as if
they were resized so all fit in the display at once. Arrange
the windows using Ctrl + Alt + ↑. While holding down
Ctrl + Alt, use the arrow keys to determine the focus.

• Create virtual raindrops on your desktop and use a virtual
windshield wiper to get rid of them. Toggle the raindrops
with Shift + F9 and toggle the windshield wiper with Shift
+ F8.

Using Konqueror
Konqueror is a unified Web browser, file manager, docu-
ment viewer, and image viewer. As a file manager, it lets
you display, manage, and create files and generally organize
your file system the way you like.

Start Konqueror as a file manager by clicking the house
icon in the panel. Konqueror displays the contents of your
home directory.

Konqueror Main Window
The Konqueror main window consists of the following ele-
ments:

Menu Bar: The menu bar holds menu items for actions
like copying, moving, or deleting files, changing views,
starting additional tools, defining your settings, and getting
help.

Toolbar: The toolbar provides quick access to frequently
used functions that can also be accessed via the menu. If
you hover the mouse pointer over an icon, a short descrip-
tion is displayed.

Location Bar: The location bar shows the path to your
directory or file in your file system. You can enter a path
to a directory directly by typing it in or by clicking one of
the directories in the display field. Delete the contents of

4



the location bar by clicking the black symbol with a white
X on the left. After typing an address, press Enter.

Navigation Panel: Hide and show the navigation panel
on the left by pressing F9. The navigation panel displays
your information in a tree view. Determine which contents
to see by clicking one of the symbols in the tab at the left
of the navigation panel. If you hold your mouse pointer
over an icon, a short description is displayed.

Display Field: The display field shows the contents of
the selected directory or file. In the View menu, choose
between different view modes to display the contents, such
as Icon View, Tree View, or Detailed List View. If you click a
file, Konqueror shows a preview of the contents or loads
the file into an application for further processing. If you
hold the mouse pointer over the file, Konqueror shows a
tool tip with detailed information about the file, such as
owner, permissions, or last modification date.

Managing Files and Folders with Konqueror
To perform actions like copying, moving, or deleting files,
you need appropriate permissions to the folders and files
involved in your action.

To copy or move a file or folder, proceed as follows:

1. To select one or multiple files and folders in Konqueror
press Ctrl and click the files.

2. Right-click and select Copy or Cut from the context
menu.

3. Navigate to the destination folder in which to insert the
object. Right-click the destination folder and select
Paste. The object is copied or moved there.

You can also copy or move objects by dragging and drop-
ping them. When dropping the object, you are asked
whether the object should be moved or copied.

To delete a file or folder, right-click the object and select
Move to Trash from the context menu. The object is moved
to the trash bin from which you can restore it if necessary
or delete the object irretrievably.

Browsing the Internet with Konqueror
To use Konqueror as a Web browser, just type a URL in the
location bar. Like Firefox*, Konqueror also features tabbed
browsing. This means that you can load one page in the
background while reading another. To open an empty tab
in Konqueror, press Ctrl + Shift + N and enter a new URL.
Alternatively, right-click a link in the Web site currently
displayed and select Open in New Tab. Right-click a tab to
access more tab options like reloading, duplicating, or
closing the tab.

You can also use bookmarks for your favorite Web sites
(and also for files and folders). Add and manage your
bookmarks with the Bookmarks menu.

Browsing the Internet with Firefox
As well as Konqueror, openSUSE also includes the Firefox
Web browser. To start Firefox, press Alt + F2 and enter
firefox.

With features like tabbed browsing, pop-up window block-
ing, and download and image management, Firefox com-
bines the latest Web technologies. Its easy access to differ-
ent search engines helps you find the information you need.
Enter a URL in the location bar to start browsing. To open
an empty tab in Firefox, press Ctrl + T and enter a new URL.
To open a link in a new tab, click the link with your middle
mouse button. Right-click the tab itself to access more tab
options. You can create a new tab, reload one or all existing
tabs, or close them. You can also change the sequence of
the tabs by dragging and dropping them to the desired
position.

Finding Information with Firefox
Firefox offers two different kinds of search options: you
can find information on the Web or you can search the
current Web page for keywords.

1. To start a search on the Web with the Google* engine,
just type your search keywords in the integrated search
bar at the right of the location bar and press Enter. The
results appear in the window.

2. To use a different search engine, click the G icon in the
search bar to open a list of other search engines.
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3. Click the desired engine and press Enter to start the
search.

To search the current Web page for keywords, press Ctrl +
F to open a find bar at the bottom of the window. Enter
your search keyword there and use the buttons beneath
the bar to search in different directions or to highlight all
hits in the text.

Downloading Files from the Web
If you download a file with Firefox, the Download Manager
starts and saves this file to the folder configured in the
preferences. By default, your desktop is the destination
folder for downloaded files. Firefox shows your finished
downloads in a dialog box.

You can open the downloaded files from there directly. To
clean up the history of downloaded files, click Clean Up.

Configuring Firefox Preferences
To adjust the default download folder or activate or modify
the pop-up blocking feature, click Edit → Preferences.

From here, you can also configure numerous other settings,
such as appearance, language, privacy, and tab options. Just
click the icons and set the options on each page according
to your preferences. Click Close to apply the changes.

Managing Passwords with KWallet
When you select the option to remember a password in a
KDE application for the first time (for your e-mail account,
for example), the KWallet wizard starts by default. KWallet
is a password management tool that can collect all pass-
words and store them in an encrypted file.

To activate KWallet, select Basic Setup and click Next. Select
Yes, I wish to use the KDE wallet to store my personal infor-
mation and enter a password. This is your master password
to open KWallet. It cannot be recovered if you forget it.
Click Finish to close the wizard. After this initial configura-
tion, you can open your wallet at any time to view, search,
delete, or create entries. Normally you do not need to insert
an entry manually. KDE recognizes if a resource requires
authentication and KWallet starts automatically, prompting
you for the KWallet password.

E-Mailing and Calendaring
For reading and managing your mails and appointments,
you can use Kontact as your personal information manage-
ment tool (PIM). Kontact combines KDE applications like
KMail, KOrganizer, and KAddressBook into a single interface.
This gives you easy access to your e-mail, calendar, address
book, and other PIM functionality.

Starting Kontact for the First Time
To start Kontact, press Alt + F2 and enter kontact. To
access one of the components, click the corresponding icon
in the left sidebar.

Before you can send or receive mails, you must configure
your e-mail account.

1. Click the Mail icon then select Settings → Configure
KMail.

2. In the configuration dialog, click Accounts. There you
can configure the settings for outgoing and incoming
mails.

3. For incoming mails, click the Receiving tab and click
Add. Select the appropriate account type and enter the
details in the following dialog.
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4. Proceed similarly for outgoing mails on the Sending
tab. If you are not sure about the settings or items to
select, consult your Internet Service Provider or system
administrator.

Instant Messaging with Kopete
Kopete is an online messenger application that allows mul-
tiple partners connected to the Internet to chat with each
other. Kopete currently supports all common messenger
protocols, such as AOL* Instant Messenger (AIM), Group-
Wise®Messenger, ICQ, IRC, Jabber*, Lotus* Sametime, MSN,
SMS, and Yahoo!*. To be able to use instant messaging (IM),
you must register with a provider offering IM services.

To start Kopete, press Alt + F2 and enter kopete. When
starting Kopete for the first time, a configuration wizard
appears that assists you in creating your user profile.

First, select the service with which you have registered and
click Continue. Then enter the user data received on regis-
tration with the messaging service: a user ID, a password,
and the server name and port. Complete the configuration
of the messenger account by clicking Finish.

Add contacts to chat with them by clicking File → Add
Contact. An assistant appears to help with creation. Howev-
er, you must be online and connected to the selected
messaging service to add a contact to your list.

To start a chat, click the desired contact and type your
message in the lower part of the chatting window. Press
Enter to send the message. The upper part of the window
displays the messages you have sent and received.

Starting OpenOffice.org
The office suite OpenOffice.org offers a complete set of
office tools, including word processor, spreadsheet, presen-
tation, vector drawing, and database components. Because
OpenOffice.org is available for a number of operating sys-
tems, you can use the same data across different computing
platforms.

To start OpenOffice.org, press Alt + F2 and enter OOo or
open the main menu and navigate to Office Suite. To create
a new document, select File → New and choose the type
of document to create. To open an existing document, se-
lect Open and choose the appropriate file from the file
system.

Viewing PDF Files
Documents that need to be shared or printed across plat-
forms can be saved as PDF (Portable Document Format)
files, for example, in the OpenOffice.org suite. openSUSE
ships with several PDF viewers, such as KPDF and Adobe*
Acrobat* Reader.

To access KPDF or Adobe* Acrobat* Reader:

1. Click the main menu button.
2. Click Office → Document Viewer. Select Acrobat Reader

or KPDF to open the PDF viewer of your choice. Alter-
natively, press Alt + F2 and enter acroread or kpdf.

3. To view a PDF file, click File→ Open. Locate the desired
PDF file and click Open.

4. Navigate through the documents by using the navigation
icons at the top or bottom of the window. If your PDF
document provides bookmarks, you can access them
in the left panel of the viewer.
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Searching for Data
KDE provides more than one application for finding data
on your computer or in the file system. With Kerry, you can
easily search your personal information space (usually your
home folder), which is indexed by Beagle. KFind is another
option.

Using Kerry
Use Kerry to find documents, e-mails, Web history, IM/ITC
conversations, source code, images, music files, applications,
and much more:

1. Press Alt + Space to open the Kerry Beagle Search dia-
log.

2. Enter the search string in Search. Enter words or
phrases and modify your search options as described
in the tips displayed in the search window.

3. Click an entry in the column on the right to select the
scope of the search. The selected entry is highlighted.

4. Click the Enter icon to start the search. The results are
displayed in the window. Use the links contained in
each result to open the result directly or show its loca-
tion in the file system with the file manager.

Using KFind
To perform basic and advanced searches, use KFind. Start
it from the main menu by clicking Applications → Find
Files/Folders or press Alt + F2 and enter kfind.

Searching by Name
To use a filename (or a part of it) as the search keyword,
proceed as follows:

1. Enter the filename or a part of the filename in the
Named input field. Use wild cards, such as an asterisk
(*), to indicate missing characters in the filename.

2. Specify the folder in which to search for the file. Either
enter a path to the folder in Look in or click Browse to
locate the folder.

3. To search subfolders, check Include Subfolders.
4. Click Find to start the search. The results are displayed

in the lower part of the dialog. To directly open the

result, just click it. Right-click it to choose one of the
options from the context menu.

Searching by Contents or Properties
For a more detailed search, you can also specify further
options, such as a text the file must contain or the creation
or modification date of a file.

1. On the Name/Location tab, specify at least the path to
search for the file. You can leave the Named empty.

2. To search for certain contents in a file, click the Con-
tents tab. In Containing Text, enter the word or phrase
the file to find must contain. This option does not work
for all types of files.

3. To search for properties such as creation or modifica-
tion date of the file, click the Properties tab and choose
the options you want.

4. Click Find to start the search.

Creating a CD or DVD
If you possess a CD or DVD writer, you can burn files to a
CD or DVD with K3b.

1. Press Alt + F2 and enter k3b. K3b opens.
2. Click New Data CD Project in the bottom part of the

window.
3. Use the tree view in the top left part of the window to

search for the files or folders to burn. When they appear
in the top right part of the window, drag and drop them
into the Current Projects window.
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4. Insert a writable CD into the device then click the Burn
icon.

5. Enter the required information in the Data Project dia-
log. If you are not sure which settings to choose, click
K3b Defaults. This should work well for almost all files.

6. Click Burn.

Managing Your Digital Image
Collection
With digiKam, it is easy to manage your digital images:
download your images from the camera, edit and improve
them, organize them in albums (or flag them with tags for
easy retrieval, independent of folders or albums), and
archive them on CD or export them to a Web image gallery.
digiKam also contains a set of useful batch functions and
plug-ins, allowing you to convert multiple images to various
different formats, rename multiple images, or automatically
improve them with functions such as red eye reduction,
speck removal, and hot pixel removal. Various filter and
effect plug-ins help create works of art from your digital
images.

To start digiKam, press Alt + F2 and enter digikam. On
first start-up, digiKam creates a custom folder in which to
store your albums.

digiKam's main window contains a tree view at the left and
shows thumbnails of the images at the right. For quick ac-
cess to your images, use the sidebar at the left, which allows
you to switch between different views, sorting the images
according to albums, tags, dates or searches. To enter

digiKam's viewing and editing mode, double-click an image
thumbnail.

Managing Your Music Collection
KDE's amaroK music player allows you to play various audio
formats, create playlists, import music from an iPod* (or
upload files to your iPod), and listen to streaming audio
broadcasts of radio stations on the Internet. The file types
supported depend on the engine used for amaroK.

To start amaroK, press Alt + F2 and enter amarok. On first
start, amaroK launches a First-Run Wizard with which to
define the folders where amaroK should look for your music
files.

amaroK's main window shows a sidebar on the left providing
different views: your music collection, a context browser,
your playlists, a file browser, etc. The right part of the win-
dow shows the current playlist. To play music, just drag and
drop items from any of the sidebar browsers to the playlist
area. Double-click an item in the playlist to start playback.

If your music files are properly tagged (containing at least
information about the artist and album), you can make use
of several nice amaroK features. To automatically fetch the
album cover images from Amazon, select Tools → Cover
Manager and click Fetch Missing Covers. The next time you
play a track from this album, the cover is displayed in the
context browser and on the on-screen display. To learn
more about the artist, switch to the Context browser in the
sidebar. Click the Artist tab to make amaroK search for the
appropriate Wikipedia article, which is then displayed in
the context browser. To view a track's lyrics, click the Lyrics
tab to start a search and display the results.

Configuring Your System with YaST
Whereas the KDE control center is only for configuring your
KDE desktop, you can change the installation and the con-
figuration of your whole system with YaST. Therefore, ad-
ministrator (root) permission is required to open YaST.
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YaST holds various modules for adjusting your system set-
tings. They are subdivided into the following categories:

Software: Use the modules of this category to set certain
options for installation and update and to install or remove
software packages.

Hardware: Use these modules to configure the hardware
of your computer, such as monitor, keyboard, mouse,
printer, or scanner.

System: With these modules, you can change system
settings, such as date, time, or language, and perform tasks,
such as backup or restoration of files.

Network Devices: Use these modules to configure your
network devices, such as network cards, ISDN, DSL, or mo-
dem.

Network Services: These modules are for network ser-
vices and for configuring several clients, such as LDAP and
NFS clients.

Novell AppArmor: Use the modules of this category to
configure the Novell AppArmor application security system.

Security and Users: Here, you can configure security
aspects, such as the firewall options, and create and manage
users and groups.

Miscellaneous: Holds several modules that cannot easily
be classified into the first six module groups. For example,
you can view log files, read the release notes and install
drivers from a vendor CD.

To open YaST, press Alt + F2 and enter yast. A dialog
opens in which to enter the root password. The YaST
modules offer integrated online help texts.

Managing Printers
Printers can either be connected to your system locally or
accessed over a network. To use a local printer, make sure

that it is connected to your machine. Shut down the system
before connecting a non-USB printer to your system.

You can configure printers with YaST. Start YaST and select
Hardware → Printer in the YaST control center. This opens
the main printer configuration window. If autodetection of
printing devices fails, click Add in the Printer Configuration
dialog to start the manual configuration workflow. Follow
the instructions in the YaST online help. If you are not sure
which option to choose and which information to enter,
ask your system administrator.

After configuring a printing device correctly, you can ad-
dress it from any application.

Logging Out
When you are finished using the computer, you can log out
and leave the system running or restart or shut down the
computer. Click the main menu button on your panel and
select Leave → Logout. This ends your session but leaves
the system running. To turn off the computer, select Leave
→ Shutdown Computer instead.

For More Information
This guide gave you a short introduction to the KDE desktop
and some key applications running on it. To discover more,
refer to KDE User Guide and the other manuals available
for openSUSE at http://www.novell.com/
documentation/opensuse103 or in your installed sys-
tem under /usr/share/doc/manual.
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GNU Free Documentation License
Version 1.2, November 2002

Copyright (C) 2000,2001,2002 Free Software Foundation, Inc. 59 Temple Place, Suite 330, Boston, MA
02111-1307 USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing
it is not allowed.

PREAMBLE
The purpose of this License is to make a manual, textbook, or other functional and useful document
“free” in the sense of freedom: to assure everyone the effective freedom to copy and redistribute it,
with or without modifying it, either commercially or noncommercially. Secondarily, this License preserves
for the author and publisher a way to get credit for their work, while not being considered responsible
for modifications made by others.

This License is a kind of “copyleft”, which means that derivative works of the document must themselves
be free in the same sense. It complements the GNU General Public License, which is a copyleft license
designed for free software.

We have designed this License in order to use it for manuals for free software, because free software
needs free documentation: a free program should come with manuals providing the same freedoms
that the software does. But this License is not limited to software manuals; it can be used for any textual
work, regardless of subject matter or whether it is published as a printed book. We recommend this
License principally for works whose purpose is instruction or reference.

APPLICABILITY AND DEFINITIONS
This License applies to any manual or other work, in any medium, that contains a notice placed by the
copyright holder saying it can be distributed under the terms of this License. Such a notice grants a
world-wide, royalty-free license, unlimited in duration, to use that work under the conditions stated
herein. The “Document”, below, refers to any such manual or work. Any member of the public is a li-
censee, and is addressed as “you”. You accept the license if you copy, modify or distribute the work in
a way requiring permission under copyright law.

A “Modified Version” of the Document means any work containing the Document or a portion of it,
either copied verbatim, or with modifications and/or translated into another language.

A “Secondary Section” is a named appendix or a front-matter section of the Document that deals ex-
clusively with the relationship of the publishers or authors of the Document to the Document’s overall
subject (or to related matters) and contains nothing that could fall directly within that overall subject.
(Thus, if the Document is in part a textbook of mathematics, a Secondary Section may not explain any
mathematics.) The relationship could be a matter of historical connection with the subject or with re-
lated matters, or of legal, commercial, philosophical, ethical or political position regarding them.

The “Invariant Sections” are certain Secondary Sections whose titles are designated, as being those of
Invariant Sections, in the notice that says that the Document is released under this License. If a section
does not fit the above definition of Secondary then it is not allowed to be designated as Invariant. The
Document may contain zero Invariant Sections. If the Document does not identify any Invariant Sections
then there are none.

The “Cover Texts” are certain short passages of text that are listed, as Front-Cover Texts or Back-Cover
Texts, in the notice that says that the Document is released under this License. A Front-Cover Text may
be at most 5 words, and a Back-Cover Text may be at most 25 words.

A “Transparent” copy of the Document means a machine-readable copy, represented in a format whose
specification is available to the general public, that is suitable for revising the document straightforwardly
with generic text editors or (for images composed of pixels) generic paint programs or (for drawings)
some widely available drawing editor, and that is suitable for input to text formatters or for automatic
translation to a variety of formats suitable for input to text formatters. A copy made in an otherwise
Transparent file format whose markup, or absence of markup, has been arranged to thwart or discourage
subsequent modification by readers is not Transparent. An image format is not Transparent if used for
any substantial amount of text. A copy that is not “Transparent” is called “Opaque”.

Examples of suitable formats for Transparent copies include plain ASCII without markup, Texinfo input
format, LaTeX input format, SGML or XML using a publicly available DTD, and standard-conforming
simple HTML, PostScript or PDF designed for human modification. Examples of transparent image formats
include PNG, XCF and JPG. Opaque formats include proprietary formats that can be read and edited
only by proprietary word processors, SGML or XML for which the DTD and/or processing tools are not
generally available, and the machine-generated HTML, PostScript or PDF produced by some word pro-
cessors for output purposes only.

The “Title Page” means, for a printed book, the title page itself, plus such following pages as are needed
to hold, legibly, the material this License requires to appear in the title page. For works in formats which
do not have any title page as such, “Title Page” means the text near the most prominent appearance
of the work’s title, preceding the beginning of the body of the text.

A section “Entitled XYZ” means a named subunit of the Document whose title either is precisely XYZ
or contains XYZ in parentheses following text that translates XYZ in another language. (Here XYZ stands
for a specific section name mentioned below, such as “Acknowledgements”, “Dedications”, “Endorse-
ments”, or “History”.) To “Preserve the Title” of such a section when you modify the Document means
that it remains a section “Entitled XYZ” according to this definition.

The Document may include Warranty Disclaimers next to the notice which states that this License applies
to the Document. These Warranty Disclaimers are considered to be included by reference in this License,
but only as regards disclaiming warranties: any other implication that these Warranty Disclaimers may
have is void and has no effect on the meaning of this License.

VERBATIM COPYING
You may copy and distribute the Document in any medium, either commercially or noncommercially,
provided that this License, the copyright notices, and the license notice saying this License applies to
the Document are reproduced in all copies, and that you add no other conditions whatsoever to those
of this License. You may not use technical measures to obstruct or control the reading or further
copying of the copies you make or distribute. However, you may accept compensation in exchange for
copies. If you distribute a large enough number of copies you must also follow the conditions in section
3.

You may also lend copies, under the same conditions stated above, and you may publicly display copies.

COPYING IN QUANTITY
If you publish printed copies (or copies in media that commonly have printed covers) of the Document,
numbering more than 100, and the Document’s license notice requires Cover Texts, you must enclose
the copies in covers that carry, clearly and legibly, all these Cover Texts: Front-Cover Texts on the front
cover, and Back-Cover Texts on the back cover. Both covers must also clearly and legibly identify you
as the publisher of these copies. The front cover must present the full title with all words of the title
equally prominent and visible. You may add other material on the covers in addition. Copying with
changes limited to the covers, as long as they preserve the title of the Document and satisfy these
conditions, can be treated as verbatim copying in other respects.

If the required texts for either cover are too voluminous to fit legibly, you should put the first ones
listed (as many as fit reasonably) on the actual cover, and continue the rest onto adjacent pages.

If you publish or distribute Opaque copies of the Document numbering more than 100, you must either
include a machine-readable Transparent copy along with each Opaque copy, or state in or with each
Opaque copy a computer-network location from which the general network-using public has access to
download using public-standard network protocols a complete Transparent copy of the Document,
free of added material. If you use the latter option, you must take reasonably prudent steps, when you
begin distribution of Opaque copies in quantity, to ensure that this Transparent copy will remain thus
accessible at the stated location until at least one year after the last time you distribute an Opaque
copy (directly or through your agents or retailers) of that edition to the public.

It is requested, but not required, that you contact the authors of the Document well before redistributing
any large number of copies, to give them a chance to provide you with an updated version of the
Document.

MODIFICATIONS
You may copy and distribute a Modified Version of the Document under the conditions of sections 2
and 3 above, provided that you release the Modified Version under precisely this License, with the
Modified Version filling the role of the Document, thus licensing distribution and modification of the
Modified Version to whoever possesses a copy of it. In addition, you must do these things in the Modified
Version:

A. Use in the Title Page (and on the covers, if any) a title distinct from that of the Document, and
from those of previous versions (which should, if there were any, be listed in the History section of the
Document). You may use the same title as a previous version if the original publisher of that version
gives permission.

B. List on the Title Page, as authors, one or more persons or entities responsible for authorship of
the modifications in the Modified Version, together with at least five of the principal authors of the
Document (all of its principal authors, if it has fewer than five), unless they release you from this re-
quirement.

C. State on the Title page the name of the publisher of the Modified Version, as the publisher.

D. Preserve all the copyright notices of the Document.

E. Add an appropriate copyright notice for your modifications adjacent to the other copyright notices.

F. Include, immediately after the copyright notices, a license notice giving the public permission to
use the Modified Version under the terms of this License, in the form shown in the Addendum below.

G. Preserve in that license notice the full lists of Invariant Sections and required Cover Texts given
in the Document’s license notice.

H. Include an unaltered copy of this License.

I. Preserve the section Entitled “History”, Preserve its Title, and add to it an item stating at least the
title, year, new authors, and publisher of the Modified Version as given on the Title Page. If there is no
section Entitled “History” in the Document, create one stating the title, year, authors, and publisher of
the Document as given on its Title Page, then add an item describing the Modified Version as stated in
the previous sentence.

J. Preserve the network location, if any, given in the Document for public access to a Transparent
copy of the Document, and likewise the network locations given in the Document for previous versions
it was based on. These may be placed in the “History” section. You may omit a network location for a
work that was published at least four years before the Document itself, or if the original publisher of
the version it refers to gives permission.

K. For any section Entitled “Acknowledgements” or “Dedications”, Preserve the Title of the section,
and preserve in the section all the substance and tone of each of the contributor acknowledgements
and/or dedications given therein.

L. Preserve all the Invariant Sections of the Document, unaltered in their text and in their titles.
Section numbers or the equivalent are not considered part of the section titles.

M. Delete any section Entitled “Endorsements”. Such a section may not be included in the Modified
Version.

N. Do not retitle any existing section to be Entitled “Endorsements” or to conflict in title with any
Invariant Section.

O. Preserve any Warranty Disclaimers.

If the Modified Version includes new front-matter sections or appendices that qualify as Secondary
Sections and contain no material copied from the Document, you may at your option designate some
or all of these sections as invariant. To do this, add their titles to the list of Invariant Sections in the
Modified Version’s license notice. These titles must be distinct from any other section titles.

You may add a section Entitled “Endorsements”, provided it contains nothing but endorsements of your
Modified Version by various parties--for example, statements of peer review or that the text has been
approved by an organization as the authoritative definition of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a passage of up to 25 words as
a Back-Cover Text, to the end of the list of Cover Texts in the Modified Version. Only one passage of
Front-Cover Text and one of Back-Cover Text may be added by (or through arrangements made by)
any one entity. If the Document already includes a cover text for the same cover, previously added by
you or by arrangement made by the same entity you are acting on behalf of, you may not add another;
but you may replace the old one, on explicit permission from the previous publisher that added the
old one.

The author(s) and publisher(s) of the Document do not by this License give permission to use their
names for publicity for or to assert or imply endorsement of any Modified Version.
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COMBINING DOCUMENTS
You may combine the Document with other documents released under this License, under the terms
defined in section 4 above for modified versions, provided that you include in the combination all of
the Invariant Sections of all of the original documents, unmodified, and list them all as Invariant Sections
of your combined work in its license notice, and that you preserve all their Warranty Disclaimers.

The combined work need only contain one copy of this License, and multiple identical Invariant Sections
may be replaced with a single copy. If there are multiple Invariant Sections with the same name but
different contents, make the title of each such section unique by adding at the end of it, in parentheses,
the name of the original author or publisher of that section if known, or else a unique number. Make
the same adjustment to the section titles in the list of Invariant Sections in the license notice of the
combined work.

In the combination, you must combine any sections Entitled “History” in the various original documents,
forming one section Entitled “History”; likewise combine any sections Entitled “Acknowledgements”,
and any sections Entitled “Dedications”. You must delete all sections Entitled “Endorsements”.

COLLECTIONS OF DOCUMENTS
You may make a collection consisting of the Document and other documents released under this License,
and replace the individual copies of this License in the various documents with a single copy that is in-
cluded in the collection, provided that you follow the rules of this License for verbatim copying of each
of the documents in all other respects.

You may extract a single document from such a collection, and distribute it individually under this License,
provided you insert a copy of this License into the extracted document, and follow this License in all
other respects regarding verbatim copying of that document.

AGGREGATION WITH INDEPENDENT WORKS
A compilation of the Document or its derivatives with other separate and independent documents or
works, in or on a volume of a storage or distribution medium, is called an “aggregate” if the copyright
resulting from the compilation is not used to limit the legal rights of the compilation’s users beyond
what the individual works permit. When the Document is included in an aggregate, this License does
not apply to the other works in the aggregate which are not themselves derivative works of the Docu-
ment.

If the Cover Text requirement of section 3 is applicable to these copies of the Document, then if the
Document is less than one half of the entire aggregate, the Document’s Cover Texts may be placed on
covers that bracket the Document within the aggregate, or the electronic equivalent of covers if the
Document is in electronic form. Otherwise they must appear on printed covers that bracket the whole
aggregate.

TRANSLATION
Translation is considered a kind of modification, so you may distribute translations of the Document
under the terms of section 4. Replacing Invariant Sections with translations requires special permission
from their copyright holders, but you may include translations of some or all Invariant Sections in addition
to the original versions of these Invariant Sections. You may include a translation of this License, and
all the license notices in the Document, and any Warranty Disclaimers, provided that you also include
the original English version of this License and the original versions of those notices and disclaimers. In
case of a disagreement between the translation and the original version of this License or a notice or
disclaimer, the original version will prevail.

If a section in the Document is Entitled “Acknowledgements”, “Dedications”, or “History”, the requirement
(section 4) to Preserve its Title (section 1) will typically require changing the actual title.

TERMINATION
You may not copy, modify, sublicense, or distribute the Document except as expressly provided for
under this License. Any other attempt to copy, modify, sublicense or distribute the Document is void,
and will automatically terminate your rights under this License. However, parties who have received
copies, or rights, from you under this License will not have their licenses terminated so long as such
parties remain in full compliance.

FUTURE REVISIONS OF THIS LICENSE
The Free Software Foundation may publish new, revised versions of the GNU Free Documentation License
from time to time. Such new versions will be similar in spirit to the present version, but may differ in
detail to address new problems or concerns. See http://www.gnu.org/copyleft/.

Each version of the License is given a distinguishing version number. If the Document specifies that a
particular numbered version of this License “or any later version” applies to it, you have the option of
following the terms and conditions either of that specified version or of any later version that has been
published (not as a draft) by the Free Software Foundation. If the Document does not specify a version
number of this License, you may choose any version ever published (not as a draft) by the Free Software
Foundation.

ADDENDUM: How to use this License for your documents
To use this License in a document you have written, include a copy of the License in the document and
put the following copyright and license notices just after the title page:

   Copyright (c) YEAR YOUR NAME.
   Permission is granted to copy, distribute and/or modify this document
   under the terms of the GNU Free Documentation License, Version 1.2
   only as published by the Free Software Foundation;
   with the Invariant Section being this copyright notice and license.
   A copy of the license is included in the section entitled “GNU
   Free Documentation License”.

If you have Invariant Sections, Front-Cover Texts and Back-Cover Texts, replace the “with...Texts.” line
with this:

   with the Invariant Sections being LIST THEIR TITLES, with the
   Front-Cover Texts being LIST, and with the Back-Cover Texts being LIST.

If you have Invariant Sections without Cover Texts, or some other combination of the three, merge
those two alternatives to suit the situation.

If your document contains nontrivial examples of program code, we recommend releasing these examples
in parallel under your choice of free software license, such as the GNU General Public License, to permit
their use in free software.

Created by SUSE® with XSL-FO
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