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NetWare 6 Readme

This document provides information on known issues and limitations for the 
initial release of NetWare® 6. The issues are divided into sections based on 
product features. Use the Table of Contents or the Search feature to locate the 
information you need. 

For information about additional issues discovered after the release, see the 
Novell® Support Knowlegebase (http://support.novell.com/search/
kb_index.jsp) and enter TID #10064501.

Complete information describing system requirements; installation, 
configuration, and optimization procedures; and administration tasks is 
available in the documentation provided on CD or online.

Documentation Conventions

In this documentation, a greater-than symbol (>) is used to separate actions 
within a step and items in a cross-reference path.

Also, a trademark symbol (®, TM, etc.) denotes a Novell® trademark. An 
asterisk (*) denotes a third-party trademark.
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1 General Information

This chapter contains general information about NetWare® 6. 

NOTE: Many product issues have been resolved in the Support Pack 1 release of 
NetWare 6. We encourage you to update your network to the latest Support Pack.

For information about additional issues discovered after the release, see the 
Novell® Support Knowlegebase (http://support.novell.com/search/
kb_index.jsp) and enter TID #10064501.

NetWare 6 Contents

The NetWare 6 package consists of the following:

� Operating System CD

� Client CD

� Novell ClientTM 4.81 for Windows* NT*/2000 

� Novell Client 3.31 for Windows 95/98

� NMAS Client 2.0

� NICI Client 1.5.7 for Windows

� NICI Client 2.0.2 for Windows

� Novell NetDrive Client 4.0

� Novell ConsoleOneTM 1.3 with snap-ins

� Documentation CD

NOTE: We welcome your feedback about the completeness, accuracy, and 
accessibility of the NetWare 6 documentation. Please send your comments to 
webdoc@novell.com (mailto:webdoc@novell.com?subject=NetWare%206) with 
NetWare 6 in the subject line.
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MP-Enabled Components

The following core NetWare 6 components are MP-enabled:

� Core operating system

� ODITM (including LSLTM, LAN, TSMTM, MSMTM, HSMTM)

� TCP/IP

� NCP/IP

� Winsock (including NILE and BSD)

� CLIB BSD calls

� Novell Storage ServicesTM file system

� Novell eDirectoryTM, including LDAP

� Novell JVM for NetWare

� Novell Modular Authentication Service (NMASTM)

� Novell Cluster ServicesTM

� NetWare Enterprise Web Server

� NetWare Web Search

� NetWare FTP Server

� Scripting products (NSN, Perl, and UCS)

All other NetWare 6 components included with this release function in an MP 
environment.

Compatibility with Other Novell Products

The following Novell products are compatible with NetWare 6:

� Account Management 2.1 for Windows 2000 

� DirXMLTM 1.01

� GroupWise® 5.5 Enhancement Pack 3 and GroupWise 6

� iChain 1.5 and 2.0

� Novell BorderManagerTM 3.6 Support Pack 1a

� Novell Internet Messaging SystemTM (NIMSTM) 2.6 and 3.0

� Novell OnDemand ServicesTM 1.0
10 NetWare 6 Readme
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� Novell Portal Services 1.0

� Novell Single Sign-on 2.1

If you install Novell Single Sign-on to a NetWare 6 server that is not an 
SD Key Server and you select No when prompted to make the server an 
SD Key Server, you may see messages indicating that Novell Single Sign-
on did not successfully install. The messages and entries in the log file 
(sys:system\sssi.log) falsely indicate that the SD Key Client and Secret 
Store Service were not installed successfully.

Despite these messages, SSS.NLM is correctly installed, the schema is 
extended, and Novell Single Sign-On should function properly in the tree.

� Novell ZENworksTM for Desktops 3.0 Support Pack 1 and Novell 
ZENworks for Desktops 3.2

� Novell ZENworks for Servers 2 with the latest Support Pack

There are some compatibility issues using NetWare 6 with ZENworks for 
Servers 2. For an explanation of the issues and their resolution, see the 
ZENworks for Servers 2 online documentation (http://www.novell.com/
documentation/lg/zfs2/index.html).

NetWare 5.1 Products Not Included in NetWare 6 

� NIAS components that enable NetWare to function as a WAN or RAS 
(dial-up) gateway

If you are upgrading from a previous version of NetWare, your INITSYS 
files might need to be edited to remove WAN components that are 
autoloaded.

� Novell Servlet Gateway

This functionality is now provided by the Tomcat servlet engine.

� IBM* WebSphere* application server

This has been replaced by the Tomcat servlet engine. If you are using a 
previous version of WebSphere on NetWare, you can use the WebSphere-
to-Tomcat migration utility included with NetWare 6. For instructions on 
using the utility, see Migrating from WebSphere to Tomcat in Getting 
Results with Novell Web Services.

� Collabra News Server and Novell Media Server

During an upgrade from a NetWare 5.1 server, these products are 
removed without warning.
General Information 11
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Client DOS Utilities

Many DOS utilities have been removed from NetWare 6. The following 
utilities are still included for your convenience, but they are not supported:

� CAPTURE

� CX

� FILER

� LOGIN

� LOGOUT

� MAP

� NCOPY

� NDIR

� NetWare Administrator

� NLIST

� NPRINTER

� RIGHTS

International Issues

� Euro Character. There are several places throughout Netware 6 where the 
euro character is displayed as its hex value “[20AC]”. This happens 
because the server code page does not support some of the newer 
extended characters, including the euro. Although the hex value of the 
euro is displayed in a few locations, the integrity of the object containing 
the euro character should remain intact.

� Web Page Encoding Issue. To properly display international text in your 
Web browser, the proper Code Page must be selected for that language. 
From the main browser menu, click View > Encoding. Then select the 
proper Code Page for the language you want to display. If the correct 
Code Page is not selected, you might see question marks or corrupted 
text.
12 NetWare 6 Readme
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2 Installation and Upgrade

This chapter contains the following subsections:

� “Before the Installation or Upgrade” on page 13

� “During the Installation or Upgrade” on page 16

� “After the Installation or Upgrade” on page 18

You should also review the other sections of this Readme for additional 
installation and upgrade issues. 

For complete instructions on preparing the network and installing or 
upgrading to NetWare® 6, see the NetWare 6 Overview and Installation Guide. 

IMPORTANT: Upgrades from any Beta version of NetWare 6 to the shipping 
version of the product are not supported. 

Before the Installation or Upgrade

Upgrading with NetWare Accelerated Upgrade

Do not use NetWare Accelerated Upgrade to upgrade the first server in the tree 
to NetWare 6—you must use the NetWare 6 installation program. After you 
upgrade or install the first NetWare 6 server using the installation program, 
you can then use NetWare Accelerated Upgrade to upgrade other servers in the 
tree.

NetWare Accelerated Upgrade is intended for use by network administrators 
who are skilled at troubleshooting and installing NetWare networks.
Installation and Upgrade 13
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Upgrading NetWare 5 Servers with NDS 7 and NSS Volumes

A NetWare 5 server with NDS® 7 and NSS volumes is inaccessible after 
completing the Prepare a Server with NDS 7 and NSS step in NetWare 
Deployment Manager. For this reason, complete this step just before you 
upgrade to NetWare 6.

Update NetWare 5 Servers Running NMAS before Installing Novell 
Native File Access Protocols

Before installing Novell® Native File Access Protocols (as part of the 
NetWare 6 installation or otherwise), all NetWare 5 and NetWare 5.1 servers 
(in the tree) running NMAS must be updated to NMASTM 2.0.1, NICI 2.0.1, 
and ConsoleOneTM 1.3.2. 

NMAS 2.0.1, NICI 2.0.1, and ConsoleOne 1.3.2 updates and instructions are 
available at www.novell.com/downloads. 

NetWare 4.11 Upgrades

NetWare 4.11 requires that Support Pack 8 or later be installed before 
upgrading. The requirement was accidentally omitted from the Upgrade to 
NetWare 6 > Meet System and Software Requirements section of the printed 
NetWare 6 Overview and Installation manual.

Mixed NDS Environments and Synchronization -628 Errors

If your network includes servers running NetWare 5 with NDS eDirectoryTM 
8.5 (Build 85.00), NetWare 5 with NDS eDirectory servers in the same replica 
ring with NetWare 4 servers, or NetWare 5 with NDS 7 servers, you must 
update NDS before installing a NetWare 6 server. (You must also complete the 
Network Preparation tasks in NetWare Deployment Manager.) 

If you do not update NDS, -628 errors will occur during synchronization. For 
information on updating NDS to the proper version number, see http://
support.novell.com/cgi-bin/search/searchtid.cgi?/10063534.htm (http://
support.novell.com/cgi-bin/search/searchtid.cgi?/10063534.htm).

NDS updates are available on the Novell Support Web site (http://
support.novell.com).

Prepare the Schema before Upgrading or Installing

Before you install or upgrade to NetWare 6 on an existing network, make sure 
to complete all relevant steps in the "Network Preparation" section of NetWare 
14 NetWare 6 Readme

NetWare 6 Readme
103-000171-001

February 15, 2002
Novell Confidential



Manual 99a38 July 17, 2001
Deployment Manager and specifically complete Step 3: Prepare for NDS 
eDirectory 8.6. This step identifies and updates a server on the network that 
holds the Master or Read/Write replica of the Root of the tree. 

NetWare Deployment Manager (NWDEPLOY.EXE) runs on a Windows 
workstation and is located on the NetWare Operating System CD.

For complete instructions on preparing the network, see the NetWare 6 
Overview and Installation Guide. 

Video Driver for NetWare Deployment Manager on Windows 2000

NetWare Deployment Manager might not run on Windows 2000 computers 
with the Matrox G400 video driver. To fix the problem, download and install 
the latest video driver from Matrox (http://www.matrox.com).

Using a Compaq ML530 Computer

NetWare 6 will not install on the Compaq* ML530 computer unless the 
ML530 ROM has been flashed (updated) using Compaq's SmartStart 5.1 or 
later. The ROM flash utility from Compaq's SmartStart 5.0 or earlier is not 
sufficient. If the ROM is not updated, the NetWare 6 installation might hang 
while configuring IP addresses.

Accelerated Upgrade: Removing Unsupported LAN Drivers

To avoid any problems, upgrade your LAN drivers before using NetWare 
Accelerated Upgrade to upgrade your server to NetWare 6.

If you did not select the Auto-detect Computer Hardware after Rebooting 
option, NetWare Accelerated Upgrade will not automatically update any old 
LAN drivers and you might not be able to connect to your server. To correct 
this problem, unload or remove any unsupported drivers and then load the 
corresponding supported NetWare 6 drivers. After the upgrade is finished, 
modify the AUTOEXEC.NCF file to reflect any name changes. 

If you did not upgrade your LAN drivers before upgrading to NetWare 6 and 
you have old hardware, select the Auto-detect Computer Hardware after 
Rebooting option. If you do this, NetWare Accelerated Upgrade automatically 
replaces any old LAN drivers with NetWare 6 LAN drivers. 

NOTE: Some LAN driver hardware is no longer supported on NetWare 6.
Installation and Upgrade 15
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During the Installation or Upgrade

Copying and Overwriting Existing Files

Because all the components of NetWare 6 have been tested as a whole, you 
should select Overwrite on all files that report a new date conflict during an 
upgrade.

Installing from a Bootable CD

If your server supports a bootable CD-ROM and you want to boot to the 
NetWare Operating System CD, make sure that the machine boot order 
specifies that the CD boots before the hard drive. This ensures that the CD is 
available for booting and formatting the hard disk. 

To boot to the NetWare Operating System CD, the server must have a ROM 
BIOS that fully supports the El Torito specification. Booting on a machine 
where the specification is not supported might result in hangs after starting 
Caldera* DR DOS* or in messages such as “No operating system found.” If 
your computer or storage adapter is not working, contact the vendor for an 
updated BIOS.

If you boot the CD to install NetWare using an existing DOS partition, it must 
not be a FAT32 partition. The DOS that boots on the CD does not recognize 
FAT32 partitions and will not be able to write to the drive. To install with a 
FAT32 partition, you must boot a FAT32-compatible DOS and then run 
INSTALL.BAT either from the CD or a network drive.

Installing Only IPX

Most NetWare 6 services require IP. If you choose to install IPXTM only, you 
will have very limited functionality. Installing IP as the default protocol is 
highly recommended.

Installing IPX after Installing IP Only

If during the installation you select IP only, the server ID number is removed 
from the AUTOEXEC.NCF at the end of the installation. It is used only for 
IPX-needed configurations (IP/IPX and IP/SCMD). If you decide to add IPX 
to your server later after initially installing IP only, you will need to add the 
SERVERID xxxxxxxx line to your AUTOEXEC.NCF after the server name to 
use IPX services on the server.
16 NetWare 6 Readme
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Installing a NetWare 5.1 Server into a Tree with a NetWare 6 SDI 
Server

When installing a NetWare 5.1 server into a tree with a NetWare 6 Security 
Domain Infrastructure (SDI) server, the installation fails with a “125” error 
due to a security upgrade.

The following error message is displayed:

Error while Contacting Security Domain Infrastructure Key 
Server: NW6_1.Servers.RCH.TX.HCSC

Error #125

If the Security Domain Infrastructure server in the NDSPKI:SD Key Server 
DN attribute in the Security.KAP.WO container is a NetWare 6 server, then a 
NetWare 5.1 server installation into the tree will fail with this error. 

This error happens during the final file copy and shows up as part of the Novell 
Certificate ServerTM installation. To complete the installation of the NetWare 
5.1 server, complete the following steps: 

1 Install the NetWare 5.1 server standalone (into its own tree).

2 Delete the file SYS:SYSTEM\NICI\NICISDI.KEY.

3 Update the NetWare 5.1 server to NICI 2.0.1 or later.

You can download this version of NICI from the Novell download site.

4 Using NWCONFIG, uninstall eDirectory on the NetWare 5.1 server.

5 Using NWCONFIG, install eDirectory onto this server and specify to 
install the server into the existing NetWare 6 tree.

6 Run the Novell Certificate Server installation either from the server 
console or through the NetWare Deployment Manager. 

The Certificate Server installation automatically creates the necessary 
security objects.

7 Configure products that use SSL certificates, such as LDAP, Web Server, 
etc., to use the new certificates.

Accelerated Upgrade: Installing Apache Web Server

Because NetWare Accelerated Upgrade does not install or update any 
software applications outside of the core NetWare operating system, the 
Apache Web server is not upgraded/installed during the upgrade. The 
following products are dependent on Apache: Novell iFolder, NetWare Web 
Installation and Upgrade 17
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Search, Novell iManager, NetWare Web Access, and Novell NetStorage. If 
you plan to install any of these products after the upgrade, make sure that you 
install the Apache Web server first.

After the Installation or Upgrade

Missing Device Drivers

The server installation program copies to a startup directory 
(C:\NWSERVER) only drivers (such as HAMs, CDMs and PSMs) for devices 
that were auto-detected during the installation process. If you attempt to load 
a HAM, CDM, or PSM that was not auto-detected during installation and it 
fails to load, copy the appropriate driver from the C:\NWSERVER\DRIVERS 
directory to the C:\NWSERVER directory and then load the driver again.

Status of Old LAN and WAN Files

After an upgrade to NetWare 6, old LAN and WAN files will not be deleted. 
These old files might not be supported in a NetWare 6 environment.

To Speed Up the Post-Installation Utility

If performance of the post-installation utility and other Java* applications is 
slow, then change the VM Cache Pool Percentage SET parameter by entering 
the following command at the server console:

SET VM CACHE POOL PERCENTAGE = 30

Performance of the post-installation program and some Java applications is 
significantly improved with this change. The changes are saved by the 
operating system and remain even if the server is rebooted.

Update SMS Components

A new release of Storage Management Services (SMS) is available at the 
Novell Support Web site (http://support.novell.com). This release contains 
important fixes to the SMS components delivered with NetWare 6. 

The fixes ensure compatibility between earlier versions of NetWare and the 
NetWare 6 SMS modules. In addition, the patch includes updates to SMS 
components (including SMDR and TSA), which have made the product more 
stable and robust.
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To maintain backup and restore services on NetWare 6 and your network, you 
must install the patch. The patch will supersede the SMS modules installed by 
default during the NetWare 6 installation. 

For more information, see the Readme included with the patch. 

Agent Installation for GroupWise 6 Replaces LDAP Files Needed by 
iFolder

The Agent Installation program for GroupWise® 6 lets you overwrite LDAP 
modules that consequently disable iFolder running on NetWare 6. To avoid 
this problem, select No when prompted to overwrite the LDAP modules 
during GroupWise Agent Installation. The LDAP module includes:

� LDAPSDK.NLM

� LDAPSSL.NLM

� LDAPX.NLM

If these files are overwritten (by selecting Yes), you must manually copy the 
files from the NetWare 6 Operating System CD before iFolder will run on 
NetWare 6.
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3 ConsoleOne 1.3

Installing the NICI Client

Some of the ConsoleOne® snap-ins for NetWare® 6 require the NICI Client. 
To use those snap-ins, you must install NICI on every workstation where you 
will use ConsoleOne.

IMPORTANT: Two versions of NICI are provided for Windows platforms: 1.5.7 
and 2.0.2. We recommend that you install both versions.

NICI 1.5.7 is implemented as a kernel driver, while NICI 2.0.2 is implemented as a 
shared DLL. Applications using NICI 1.5.7 will not work if only NICI 2.0.2 is 
installed. Likewise, new applications will require at least NICI version 2.0.2. Both 
NICI versions can be installed on the same Windows workstations, providing 
support for all applications.

A Client CD containing the NICI client for Microsoft* Windows operating 
systems is included with NetWare 6. NICI clients for Solaris* and Linux* can 
be found on the Novell software download page (http://www.novell.com/
download).

To install the NICI client from the Client CD, insert the CD. An autorun 
application begins. Select the NICI client from the list.

Running ConsoleOne on the NetWare Server Console

For best performance, we recommend that you install ConsoleOne on a 
workstation. Use the NetWare 6 Client CD to install ConsoleOne and snap-ins 
onto your workstation. 

Losing Connection to ConsoleOne after Cluster

After a node in the cluster dies, you should log out and then log back in to see 
the Cluster View in ConsoleOne.
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ConsoleOne Is Not Refreshing Properly

With 3D mouse pointer software installed on a machine running ConsoleOne, 
the screen might appear to not refresh properly.

To solve this problem, remove the 3D mouse pointers.

For more information on this issue, refer to Solution #10058840 (http://
support.novell.com).

ConsoleOne Does Not See the Tree

In a pure IP environment, ConsoleOne does not see the eDirectoryTM tree of 
the server that ConsoleOne is running on. 

To fix this, make the following changes in the AUTOEXEC.NCF file:

� Add the statement LOAD SCMD.NLM after the LOAD and BIND 
statements for TCPIP. 

� Add IPX to the serverID. For information on the serverID format, see 
Chapter 7, “IPX Dependencies,” on page 37. 

� Then restart the server.

For more information on this issue, refer to Solution #2943528 (http://
support.novell.com).

Administering Volumes and Files Using Novell Client for Windows 95/
98

There is a defect in earlier versions of Novell® ClientTM for Windows 95/98 
that causes problems when you try to administer volumes and files in 
ConsoleOne. (This is not a problem with Windows NT or 2000.) This defect 
has been resolved in the Novell Client that ships with NetWare 6.

If you are using an earlier version of the Client, you should disable caching on 
Windows 95/98 by modifying several settings in the Client properties panel.

1 Right-click the red N in the system tray.

2 Click Novell Client Properties > Advanced Settings.

3 For each of the following options, adjust the setting as specified:

Option Setting

Cache Writes Change from On to Off.

Delay Writes Change from On to Off.
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4 Click OK.

Support for the Hong Kong Supplementary Character Set

This release of ConsoleOne does not support the Hong Kong Supplementary 
Character Set (HKSCS). We are currently working on a patch to allow HKSCS 
support in future releases of ConsoleOne. 

File Cache Level Change from 3 to 0.

File Write Through Change from Off to On.

True Commit Change from Off to On.

Option Setting
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4 DNS/DHCP

Known Issues

� The Novell® iManager browser-based DNS/DHCP management utility 
does not support the following: 

� IPV6.INT zones

� Configuring DHCP Option 60

NOTE: This issue is resolved in NetWare 6 Support Pack 1.

� Pooled Mac addresses (Use the Java Management tool to manage 
this feature.)

NOTE: This issue is resolved in NetWare 6 Support Pack 1.

� While importing the DHCP configuration, a default subnet address range 
is automatically created. The DHCP Server reference is not automatically 
updated; you can manually update the server reference later.

NOTE: This issue is resolved in NetWare 6 Support Pack 1.

Special Instructions

� For improved performance, configure the DNS/DHCP scope settings 
before you start using the Novell iManager browser-based DNS/DHCP 
management utility. 

� The recommended settings for the Novell iManager browser-based DNS/
DHCP management utility are as follows:

Display Settings Font Size Browser Text Size

800 * 600 Small Medium to Smallest

1024 * 768 Small Largest to Smallest
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� While importing the DHCP configuration, if the subnet address range        
contains a reference to an external DHCP server, this reference is 
automatically replaced by a reference to the default DHCP server that you 
specify.

� The Novell DNS and DHCP servers are based on ISC BIND Version 4.9.6 
and ISC DHCP Version 2.
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5 Novell iManager 1.0 and iMonitor 1.5 
for Novell eDirectory 8.6

This chapter contains the following subsections:

� “Novell iManager 1.0” on page 27

� “iMonitor 1.5” on page 31

Novell iManager 1.0

Associating a Role to a Scope

If you add a member to a role and then try to associate that role to a scope that 
does not exist, you will get an error message. Click OK to clear the error 
message.

Creating Objects with European Characters

To create objects in Novell® iManager containing European characters, set 
your browser locale to any European language. Even if you set your locale 
back to English, you can now create and view objects containing European 
characters. Using Internet Explorer 5.5, do the following:

1 Click Tools > Internet Options.

2 Click Language > Add.

3 Select a European language (such as Portuguese or German) and then 
click OK.
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Setting Up Encoding for Foreign Languages

If you are experiencing problems with correct character display in Novell 
iManager, you should verify that your browser's language and character set 
encoding are configured properly.

To enable Novell iManager to display information in the language you expect, 
you need to

� Set your browser's language preference to the appropriate language

� Select the encoding that supports your browser's language

Setting Your Browser's Language

Using Internet Explorer 5.5, do the following:

1 Click Tools > Internet Options to display the Internet Options dialog box.

2 On the General page, click Languages. 

3 Add your language to the list and make your language the first language 
in the list.

4 Click OK to save the changes and then close your browser.

5 Open your browser and log in to Novell iManager.

Selecting the Correct Encoding

When your browser receives encoded Novell iManager information, it uses 
the currently selected character set encoding to display the information. For 
this reason, you need to make sure that you've selected the correct character 
set encoding for your browser's language. 

Using Internet Explorer 5.5, do the following:

1 Click View > Encoding to display the Encoding submenu.

2 Click the appropriate character-set encoding for your language. 

IMPORTANT: On Windows workstations, Novell iManager uses Windows 
encoding to display characters. On other platforms, Novell iManager uses ISO 
encoding. If both encoding types are displayed, select the type that is appropriate 
for your platform. 
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Creating New Roles

If you have more than one rbsCollection in your tree and you create a new role 
in one rbsCollection and assign tasks to that role from another rbsCollection, 
users will not be able to see their assigned roles and tasks when they log in to 
Novell iManager. 

When creating new rbsRole objects in Novell iManager, the tasks for that role 
should be assigned from the same rbsCollection container that the role was 
created in.

Out-of-Memory Errors

If you receive out-of-memory errors when running Novell iManager (Error: 
500 on client browsers and OutOfMemory Java exception on the Server Login 
Screen), edit the SYS:TOMCAT\33\BIN\TOMCAT33.NCF file and add the 
following switch to the Java command line:

-Xmx128m

128 represents the heap memory (in MB) that Tomcat will use. You can go as 
high as 400 for this parameter. To change the heap memory to 400 MB, your 
Java command line would look similar to the following:

java -Xmx400m -envCWD=$TOMCAT_HOME -classpath 
$TOMCAT_CLASSPATH -Dtomcat.home=SYS:\tomcat\33 
org.apache.tomcat.startup.Main -f sys:/tomcat/33/conf/
nwserver.xml %1 

To determine the heap memory that Tomcat is currently using, enter the 
following at the server console:

: java -show

This command will return a process number such as 196.

The following command will show the heap memory setting as well as the 
current usage for the heap and physical memory:

: java -showmemory196

Use the number returned from the Java -show command (196 in the above 
example).
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Deleting All Role Objects

If you delete all the rbsRole objects in Novell iManager without also deleting 
the tasks, you can create a new rbsRole object, but the task list will not show 
any of the tasks.

You can create a role without any tasks and then modify the role to include 
tasks. However, we recommend instead that you re-install the product 
packages in order to re-create the removed roles. Use the Install Package task 
in Novell iManager to reinstall the product packages.

Modifying the Novell iManager Installation Path during a NetWare 6 
Custom Installation

You should not modify the Novell iManager installation path during the 
NetWare custom installation unless the container you specify in the 
installation field already exists.

If you do specify a container that does not exist, you will receive -601 (No 
Such Entry) errors on the following files:

.../BASE/EDIR.XML

.../DNSDHCP/DNSDHCP.XML

.../IPRINT/IPRINT.XML

.../NLS/NLS.XML

You will also receive the following error:

Failed to associate initial roles with user admin.

If you receive this error, you can associate the initial roles with the 
administrator User object after the installation finishes by completing the 
following steps:

1 In Novell iManager, click the Configure tab. 

2 Click Role Based Services Setup > Create rbsCollection. 

3 Follow the online instructions to create an rbsCollection container.

4 To install the Novell iManager plug-ins, click Role Based Services Setup 
> Install Plug-in.

5 Associate each role with the Admin User object.

5a Click Role Management > Modify Role.

5b Click the icon in the Members column of a role.

5c Follow the online instructions to add the admin User object as a 
member of the role.
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Setting Inheritance Rights

In this release of Novell iManager, the ability to set inheritance rights is not 
available. Inheritance from the container chosen as the scope down through 
any subcontainers is automatically set and cannot be changed. This allows 
only the chosen container to be used as the scope and not the subcontainers as 
well. 

Performing a Post-installation of Novell iManager

When performing a post-installation of Novell iManager, you must restart 
both Apache and Tomcat after the installation is complete in order for Novell 
iManager to work properly. 

Granting Additional eDirectory Rights to Owners of rbsCollection 
Containers

When you make a user an owner of an rbsCollection container, you should 
grant that user the additional eDirectory rights needed to fully administer that 
collection. This user should be given supervisor entry rights to the objects 
needing modification (assign roles to, etc.).

Assigning a Container Object As a Member of a Role

When you assign a container object (Organization or Organizational Unit) as 
a member of a role, only the users directly under the container will have access 
to that role. Users in subcontainers under the one assigned will not be able to 
use that role. This is the same way that assigning containers to Group objects 
works in eDirectory. 

iMonitor 1.5

Browsing for Objects Containing Extended Characters

When using iMonitor to browse an eDirectory tree for objects, an object with 
extended characters in the name might not hyperlink to the object properties 
correctly. This problem does not happen with any objects that contain double-
byte characters.
Novell iManager 1.0 and iMonitor 1.5 for Novell eDirectory 8.6 31

NetWare 6 Readme
103-000171-001

February 15, 2002
Novell Confidential



Manual 99a38 July 17, 2001
32 NetWare 6 Readme

NetWare 6 Readme
103-000171-001

February 15, 2002
Novell Confidential



Manual 99a38 July 17, 2001
6 iPrint/NDPS

Installing Printers on Windows NT/2000

To install a printer on Windows NT/2000, you must have Administrator rights 
or be a Power User. 

IP Address Limitation

NOTE: This issue is resolved in NetWare® 6 Support Pack 1.

When using iPrint, IP addresses must be between 1 and 255 for the Network 
ID and Host ID. Addresses that have a 0 (zero) in any of the four octets are not 
currently supported. For example, 1.0.0.9 is not supported.

Using NDPS Gateways

When you use Novell® iManager to create an NDPS® Printer object and select 
the Novell Gateway, the Novell Gateway (NDPSGW.NLM) is used.

When you use NetWare Administrator to create a Printer object and select the 
Novell Gateway, the gateway comprised of PH.NLM and NDPDS.NLM is 
used. This is the only version of the gateway that supports RP protocol and 
local ports.

To use a third-party print vendor’s gateway, you must use NetWare 
Administrator to create the NDPS Printer object.

Running iPrint Map Designer

To have full functionality of the iPrint Map Designer, IPPSRVR.NLM must be 
loaded before starting iPrint Map Designer.
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Invalid IP Address When Loading the NDPS Manager

When you load the NDPS Manager, you can specify an IP address or DNS 
name. If you do not specify one, the NDPS Manager uses the address stored 
in SYS:\ETC\HOSTNAME. If either the IP address or DNS name specified 
on the command line or in the HOSTNAME file is invalid, you will receive 
the following error:

IP Address xxx.xxx.xx.xxx, specified at load time, is not 
bound. Program execution cannot continue normally. Press 
Escape to continue.

To resolve the error, use a valid DNS Name or IP Address on the command 
line, or edit the SYS:\ETC\HOSTNAME file to contain a valid address.

Using TTS on NSS Volumes

NOTE: This issue is resolved in NetWare 6 Support Pack 1.

By default the Transaction Tracking SystemTM (TTSTM) is not enabled on NSS 
volumes for NetWare 6 servers. To protect database integrity, NDPS requires 
that TTS be enabled on the NDPS Manager's host volume before 
NDPSM.NLM is loaded. If the NDPS Manager’s host volume is an NSS 
volume, you should enable TTS by completing the following:

1 Enter

NSS /transaction=NDPS_Manager_host_volume_name

If you want to list the NSS volumes on a server, enter NSS volumes.

2 Dismount the NSS volume by entering 

NSS /Deactivate=NDPS_Manager_host_volume_name

3 Remount the volume with TTS enabled by entering

mount NDPS_Manager_host_volume_name

iPrint Client Install Page Has No Link

NOTE: This issue is resolved in NetWare 6 Support Pack 1.

When using a map generated by the iPrint Map Designer, if users click on a 
printer from a workstation that does not have the iPrint client installed, they 
might be redirected to an iPrint client install page that does not have the client 
install link.

To resolve this, use a text editor to edit LOGIN\IPPDOCS\TOOLS.JS and 
make the following changes to the Function: ProductNotInstalled section.
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Replace the

"        document.writeln(\"" + 
parent.iprintclientinstallString + "<BR><BR>\");\n" +

line of code with these lines:

"        document.writeln(\"" + 
parent.iprintclientinstallString + "\");\n" +

"        document.writeln(\"<BR>\");\n" +

"        document.writeln(\"<BR>\");\n" +
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7 IPX Dependencies

If you select TCP/IP as your only protocol during the NetWare® 6 installation, 
IPX/SPXTM will no longer be available. 

If you have problems loading IPX/SPX-dependent NLMTM programs, add the 
following line after the Server Name in the AUTOEXEC.NCF file:

serverID XXXXXXXX

Replace XXXXXXXX with the internal IPXTM address you want to assign to 
the server. This address can be numbers and letters A, B, C, D, E, F only 
(serverID is a hex value).

For example, the serverID line could appear as follows:

serverID 12345abc

For the changes to take effect, you must restart your server after updating the 
AUTOEXEC.NCF file.
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8 NetWare Enterprise Web Server

No NDS Replica on the Web Server

If the Web server does not have an NDS® replica, users cannot access private 
pages through the Web server. Users are allowed to authenticate, but the page 
access returns a 404 error.

To avoid this problem, make sure the Web server has an NDS replica.

Internet Explorer Issues

Folder operations in WebDAV have limitations. When you copy a folder to 
another folder of the same name, Internet Explorer sends a request to delete 
the original folder and its contents before it copies the new folder. 

To update a folder and its contents with a folder of the same name in another 
location, copy the contents of the folder rather than the folder itself to the 
target destination.

ActiveX Controls

If icons such as those for Users, Groups, and Organizational Units are missing 
from your My Network folder, check the security settings in Internet Explorer. 
Security settings must allow ActiveX Controls to be downloaded and run. 
When the following message appears, accept the module to allow it to run:

Novell DAVICONS.OCX Signed ActiveX Controls Being Downloaded

If your Web folders still do not display the icons, you must repair Internet 
Explorer 5 by doing the following: 

1 From your desktop, click Start > Settings > Control Panel.

2 Double-click Add/Remove Programs. 
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3 Click Microsoft Internet Explorer 5 > Change/Remove > Repair Internet 
Explorer.

4 Restart your system if required.

INDEX.HTML Renamed

When upgrading to NetWare® 6 from an earlier version of NetWare, the file 
INDEX.HTML in the document root of the Enterprise Web Server 
(volume:\NOVONYX\SUITESPOT\DOCS) might be renamed to 
INDEX_ENTERPRISE.HTML. This occurs when the new NetWare 6 default 
home page is installed as INDEX.HTML.
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9 NetWare FTP Server

Intruder Detection

� To disable intruder detection, both intruder detection parameters 
(INTRUDER_HOST_ ATTEMPTS and 
INTRUDER_USER_ATTEMPTS) must be set to zero (0).

� To enable intruder detection, both intruder detection parameters 
(INTRUDER_HOST_ ATTEMPTS and 
INTRUDER_USER_ATTEMPTS) must be set to a value greater than 
zero (0).

Login from FTP Client

When logging in from FTP client, the format of the user distinguished name 
should be either username or .username.ou1.... 

Don’t use the format .cn=username.ou=ou1....

NOTE: This issue is resolved in NetWare 6 Support Pack 1.

Use Home Icon Instead of Back Icon

From the Service Manager panel of the FTP Server, do not click the Back icon 
in the navigation toolbar of the browser to return to the Service Selector panel 
of NetWare® Web Manager. Instead, click the Home icon in the Service 
Manager panel to return to the Service Selector panel.

Configuring FTP Server with Cluster Services

� When FTP Server is configured to run in the Active/Passive mode, add 
only nwftpd to the end of load script and add only unload nwftpd to 
the beginning of the unload script.

� When FTP Server is configured to run in the Active/Passive mode, make 
sure to comment the nwftpd entry in AUTOEXEC.NCF. Also, before 
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you bring the resource online, execute unload nwftpd to bring down 
the FTP service already running.
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10 NetWare Migration Wizard 6

NOTE: Additional Readme information is available at the end of the NetWare® 
Migration Wizard 6 installation. Once Migration Wizard is installed, you can also 
view the Readme before you launch the wizard by clicking Start > Programs > 
Novell > NetWare Migration Wizard > NetWare Migration Wizard Readme.

Migrating to NetWare 6 NSS Volumes

When migrating to NetWare 6 NSS volumes, trustee assignments might not be 
fully restored to User and Group objects the first time you run the Finish NDS 
Migration step. NSS volumes depend on the NDS® backlink process to create 
ID information on objects before trustees can be associated with those objects. 
Therefore, you must verify that the backlink process is complete before 
running the Finish NDS Migration step. 

If you have already run the Finish NDS Migration step and are missing 
trustees, you can manually complete the backlink process and rerun the Finish 
NDS Migration step. Reboot the server after this step completes.

To manually run the backlink process, enter the following commands at the 
server console:

set dstrace=on

set dstrace=+blink

set dstrace=*b

If you switch to the Directory Services screen on the server, you can watch the 
objects as they are processed. The above commands must be repeated until no 
more User or Group objects appear in the backlinked list on the Directory 
Services screen.
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11 NetWare WebAccess

Do Not Run NetWare WebAccess and Novell Portal Services on Same 
Server

NetWare® WebAccess and Novell Portal Services cannot be run 
simultaneously on the same server. NetWare WebAccess is based on Novell® 
Portal Services technology. Therefore, the limitation of not being able to run 
two instances of Novell Portal Services on the same server also applies when 
attempting to run NetWare WebAccess and Novell Portal Services on the same 
server.

Form Authentication Type Required for Some Lotus Notes Applets

In order for some Lotus* Notes* applets to display correctly, you must select 
FORM as the authentication type when configuring the NetWare WebAccess 
Email gadget using ConsoleOneTM. BASIC is the default Lotus Notes 
authentication type.

WebAccess Object Name Change

An object in the WebAccess container in Novell eDirectoryTM might be 
referred to incorrectly in the documentation. The WebAccess_portalgroup 
object should be WebAccess_Configuration_All_Users. This is the object 
used to configure NetWare WebAccess gadgets in ConsoleOne.
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12 NetWare Web Manager

Upgrading Products Accessible through NetWare Web Manager

If you are upgrading products accessible through NetWare® Web Manager, 
new configuration files will be written out and the old configuration files will 
be backed up in their current location.

A “_BKddd” (where ddd is a number) will be appended to the old 
configuration file. For example, MAGNUS.CONF will become 
MAGNUS.CONF_BK000.

If another installation is done on top of this one, MAGNUS.CONF will 
become MAGNUS.CONF_BK001. The count is incremented with each new 
upgrade installation. If you want to restore the old settings, you can manually 
merge the new and old files. 

Using Internet Explorer

To view NetWare Web Manager with Internet Explorer, you must change a 
setting in Internet Explorer to set the correct page caching option.

1 From the tool bar, click Tools > Internet Options > General > Settings.

2 Check the Every Visit to This Page check box so that the browser re-
requests a page and displays the appropriate information after you have 
made new selections on the NetWare Enterprise Server forms.
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13 NetWare Web Search Server

Web Search and Web Server Interaction

The NetWare® Web Search installation program automatically detects and 
registers itself with both the Apache and Enterprise Web servers if they are 
installed on your server. However, the NetWare Web Search Manager 
(AdminServlet) will be registered only with the Apache Web server, which is 
the Web server used by all NetWare Web administration utilities (such as 
NetWare Web Manager and NetWare Remote Manager). The Search and Print 
servlets will be registered with both Web servers, if available.

IMPORTANT: Web Search uses the Enterprise server’s NLMTM programs when 
authorizing rights-based search results. If the Enterprise Web server is not 
installed, the rights-based search results feature will not work. However, Web 
Search will continue to operate without this feature and will simply return all search 
results.

Regenerating All Indexes after Installation

After upgrading from a previous installation of Web Search to the NetWare 6 
version, you must regenerate the older indexes before they can be searched.

Indexes No Longer Listed on Default Search Page

After upgrading from previous versions of Web Search, the list of indexes 
(formerly called collections) that appear on the default search page might 
disappear. This is because subsequent versions of Web Search differentiate 
between the indexes specified by a particular query versus those actually 
available at the server.
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To fix this problem so that all available indexes display on the search page, 
either use the templates that ship with the newer Web Search (located in the 
\NSearch\Templates\Samples directory) or make the following changes to the 
SEARCHTEMPLATE.HTML file that you are currently using as your search 
page:

1. Change $$BeginCollectionsLoop to $$BeginServerCollectionsLoop.

2. Change $$EndCollectionsLoop to $$EndServerCollectionsLoop.

New Sample Web Search Templates

NetWare Web Search includes new sample search results templates. You 
should always use the new templates as a basis for your templates.

If you install Web Search over a previous installation, your existing templates 
will not be overwritten. The new templates will be copied into the 
volume:\searchroot\TEMPLATES\SAMPLES directory.

To test the sample templates from a Web client machine, include the Theme 
query parameter with the value Samples: 

&theme=Samples&other_query_parameters

You can also temporarily change the TEMPLATES directory to the 
SAMPLES directory in the Search Properties form in the NetWare Web 
Search Manager.

Also, all of the template’s colors and fonts are now in the 
volume:\searchroot\DOCS\TEMPLATE.CSS style sheet. This allows you to 
easily modify fonts and colors across all of your templates to match the design 
of your Web sites.
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14 Novell Advanced Audit Service 
(NAAS)

Default Configuration

� NAAS is not supported in a mixed network environment containing 
NDS® 6.x, 7.x, and NDS 8.x. NAAS enables auditing only for NetWare® 
servers that are running in pure NDS (Novell® eDirectoryTM) 8.x 
networks. It does not audit NetWare servers running NDS 8.x even if they 
are part of a mixed network running NDS versions earlier than NDS 8.x. 
Therefore, you should install and configure NAAS only in networks 
solely running NDS 8.x.

� The ConsoleOneTM-based NAAS default configuration utility cannot be 
run from a NetWare 6 server console. Instead, you must run it from a 
Windows workstation.

� By default, NAAS searches only up to three levels up the tree to find a 
policy of any type for an object. If policy is not found in the three levels, 
that object is not audited. 

If the depth of the partition is greater than three, specific NAAS Search 
Criteria policies should be associated with the objects with search level 
equal to the partition depth.

� The NAAS default configuration utility fails to create NAAS objects if 
the partition root is not an Organization Unit or Tree Root. Before using 
this utility, manually create a NAAS container under the partition root.

� If the NetWare server hosts two partitions, and the server partition root is 
an ancestor of the other partition, explicitly give rights to the NAAS 
Agents to the objects in the other partition.
Novell Advanced Audit Service (NAAS) 51

NetWare 6 Readme
103-000171-001

February 15, 2002
Novell Confidential



Manual 99a38 July 17, 2001
� The default configuration utility configures NAAS for a single partition 
and, by default, the Audit Server generates reports only for the query 
domains in the same partition. 

If the Auditor Query Domain is in a partition other than that of the Audit 
Server, you need to give specific rights to that NAAS Server Object.

� The default configuration utility can make a user Auditor for only one 
partition. 

To make the same user an Auditor for more than one partition, do the 
following:

� Manually configure NAAS.

� Grant the auditor Read and Compare rights to the LDAP Server 
attribute for the partition containing the User object.

� Grant the auditor Read and Compare rights to the 
LDAP:keyMaterialName attribute for the partition containing the 
User object.

� After generating a report for one naasAuditorQueryDomain, restart 
ConsoleOne to generate a report for a second domain.

� The NAAS schema for eDirectory does not get extended from the 
NetWare 6 server if that server happens to be a non replica server.

Run the NAAS install from a NetWare 6 server that is hosting a Read/
Write replica of the eDirectory.

Audit Data Commit

Automatic commit of audit cache on reaching the specified threshold is not 
enabled. The size of the cache file will grow until the periodic commit is 
scheduled.

NAAS Agent

Occasionally, the NAAS Agent may fail to commit data to the NAAS Server 
due to a communication failure. However, there is no loss of data and the data 
is cached. 

To resolve this, do the following:

1 Unload Java. 

This unloads some of the NAAS Agent and NAAS Server components.
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2  Reload Java using the LOAD JAVA command at the system console.

3 Reload the unloaded NAAS components using the ST_AGENT and 
ST_SRVR commands at the system console.

Loading the Shims

If all three NAAS Shims are required to be loaded, the load order should be as 
follows:

FSSHIM.NLM

NSSSHIM.NLM

DSSHIM.NLM

eDirectory Auditing

� Auditing is not enabled for the following events in Novell eDirectory:

� DSE ADD MEMBER

� DSE DELETE MEMBER

NOTE: This issue is resolved in NetWare 6 Support Pack 1.

�  If the NetWare server hosts two partitions and the server partition is a 
child partition of the other, only the server partition is audited.

Audit Report Generation

� Generating a report for a large number of records takes more time than 
generating a report for a small number of records. For example, it will 
take approximately 15 minutes to generate a report containing 17,000 
records. 

NOTE: This issue is resolved in NetWare 6 Support Pack 1.

� Two or more Audit report queries cannot be processed simultaneously by 
the Audit database. so auditors should generate one report at a time. 

NOTE: This issue is resolved in NetWare 6 Support Pack 1.

� If event filters are created for NSS or NWFS, the Audit report will contain 
events for both NSS and NWFS even when only one of the two is 
selected. This happens only for events that are common to both NSS and 
NWFS. 
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15 Novell Certificate Server

Novell Certificate Server Dependencies

The Certificate Server ConsoleOneTM snap-in has the following dependencies:

� Client NICI 2.0.2 or later for Windows

� Novell® LDAP SDK

� Novell ClientTM version 4.8 or later for Windows NT/2000, or Novell 
Client version 3.3 or later for Windows 95/98/ME

If any of the above dependencies are not met, Certificate Server functionality 
will not be available and you will get one or both of the following error 
messages:

NICI 2.0.2 or later is not installed on this client. 
The Certificate Server snap-in will not function 
until NICI is installed.

The dynamic link library ccsw32.dll could not be 
found in the specified path.

These error messages will occur only once on the first object access.

You will typically not have LDAP SDK in your ConsoleOne distribution if 
you obtained ConsoleOne directly from the Novell Web site. You should use 
the version of ConsoleOne provided with NetWare® 6. The ConsoleOne shell 
is located on the Client CD at \CONSOLEONE\C1.EXE and the snap-ins are 
located on the Client CD at \CONSOLEONE\NW6SNAPINS.EXE. 
ConsoleOne and snap-ins are also available on an installed NetWare 6 server 
at SYS:\PUBLIC\MGMT\CONSOLEONE\1.2\BIN\CONSOLEONE.EXE.

NICI 2.0.2 for Windows is available on the Client CD at 
\NICI\WCNICIU0.EXE or from the Novell Free Download Site (http://
www.novell.com/download/).
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Browser Support

You must use the Internet Explorer 5 or later or the Netscape Navigator 4 or 
later browser to use the certificates generated by Novell Certificate Server for 
SSL or LDAP connections. Older browsers are not supported.

Removing a Server from NDS

When removing a server from NDS® and then reinstalling it into the same 
context with the same name, a successful reinstallation occurs only if the SAS 
Service object representing the removed server is also deleted, if it exists.

For example, for a server named MYSERVER, there could exist a SAS object 
named SAS Service–MYSERVER located in the same container as the server. 
This SAS object must be manually deleted (using ConsoleOne) after the 
server is removed from the tree, but before the server is reinstalled into the 
tree.

IMPORTANT: If the server is the Organizational CA or the SD Key server, you 
must complete some additional steps. These steps are documented in TID 
10056795 (entitled “Certificate Server Issues: Removing a Server from a Tree”). 
You can search for this TID in the Novell Knowledgebase located at (http://
support.novell.com).

Verisign Certificates and Creating a Server Certificate (KMO)

If you use Verisign as the external Certificate Authority (CA) during the 
creation of a Server Certificate (KMO), you no longer need to obtain 
Verisign’s trusted root to paste into the Trusted Root field. You can now select 
the option No Trusted Root Available, click Next, and then paste in the 
certificate you received from Verisign.

When the certificate is installed, the server determines if the certificate you 
pasted chains to a Verisign embedded root. If it does, the certificate and the 
trusted root are added to the Server Certificate object in NDS.
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16 Novell Client for Windows

See the Novell® ClientTM Readme (http://www.novell.com/documentation/lg/
noclienu/index.html) for issues related to the Novell Client for Windows 95/
98 and Novell Client for Windows NT/2000.
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17 Novell Cluster Services

This chapter contains the following subsections:

� “Installation/Upgrade Issues” on page 59

� “Other Issues” on page 60

Installation/Upgrade Issues

Perform Cluster Pre-upgrade from an NT Workstation

You must run the Deployment Manager option to prepare your cluster for an 
upgrade from an NT workstation rather than from a Windows 9x workstation.

Also ensure that your cluster-enabled volumes are in the Running state. Use 
Cluster View in ConsoleOneTM to check the state of each corresponding 
cluster volume resource.

Shared Cluster Volumes Disabled in NetWare Deployment Manager

Shared volumes are disabled after you complete the Prepare a Novell Cluster 
for Upgrade step in NetWare Deployment Manager. Once the upgrade to 
NetWare 6 is complete, the shared volumes are re-enabled.

Do Not Create Traditional Volumes during Cluster Upgrade

Do not create new traditional volumes on NetWare 5 servers when upgrading 
a cluster from NetWare 5 to NetWare 6.

After one NetWare 5 server in the cluster is upgraded to NetWare 6, upgraded 
NSS volumes on shared storage might appear as free space in a traditional 
partition. Creating a volume on the free space will corrupt the NSS volume.
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NSS volume corruption  occurs if all of the following conditions exist on your 
system:

� The Prepare a Novell Cluster for Upgrade option in the Deployment 
Manager was run and completed.

� At least one of the NetWare 5 servers in the cluster was upgraded to 
NetWare 6.

� One of the NetWare 5 servers not yet upgraded was rebooted and an 
attempt was made on that server to create a traditional partition using 
NWCONFIG.

Unable to Authenticate to a New Node during Installation

When using NetWare Deployment Manager to install a new node into a 
cluster, you might not be able to authenticate to the new node. If this happens, 
map a drive from the workstation running Novell Client software (right-click 
the red N) to each node in the cluster and then repeat the NetWare Deployment 
Manager steps to install the node into the cluster.

Directory Tree Not Visible during Installation

When running the Cluster Services installation, you occasionally might be 
unable to see the eDirectoryTM tree you want to install into from the installation 
browser. If this happens, type the name of the tree in the browser path: 
treename/cluster.context.

Other Issues

Deactivate Shared NSS Pools

After creating shared NSS pools or volumes, you must deactivate them before 
you bring the cluster resource online; otherwise, the resource will go comatose 
because it is already active on the server where it was created.

Using DELAY.NLM in Cluster Resource Scripts

NOTE: This issue is resolved in NetWare 6 Support Pack 1.

If you use DELAY.NLM to delay execution of commands in a cluster resource 
load or unload script, do not use the load command in the script to load 
DELAY.NLM. Instead, add a command to load DELAY.NLM to the 
AUTOEXEC.NCF file on each server where the resource will run. Then 
specify the amount of time you want to delay command execution by adding 
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the DELAY command to the load or unload script. For example, if you want 
to cause a five-second delay, add DELAY 5 to the script.

Do Not Use the Prepare Volume for Use by Novell Cluster Services 
Option in NetWare Remote Manager

NOTE: This issue is resolved in NetWare 6 Support Pack 1.

If you are using NetWare Remote Manager to create NSS pools and volumes 
to use in your cluster, do not check the Prepare Volume for Use by Novell 
Cluster Services check box. This feature does not work and will not correctly 
cluster enable your newly created pool or volume.

Instead, go to the NetWare Remote Manager Cluster Config screen and use the 
New Cluster Volume button to cluster enable the volume. You can also use 
ConsoleOneTM to create and cluster enable NSS volumes.
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18 Novell Compatibility Mode Driver

There is no control on the Designated Router Election process. To make any 
migration agent a Designated Router, use INETCFG to assign it the highest 
priority IP Address.

NOTE: This issue is resolved in NetWare 6 Support Pack 1.
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19 Novell eDirectory 8.6 for NetWare

Installing into an Existing Tree

If you are installing into a tree that has NetWare 5 servers, each NetWare 5.0 
server must be running NetWare 5.0 Support Pack 6a (http://
support.novell.com/misc/patlst.htm#nw) or later. Each NetWare 5.1 server 
must be running NetWare 5.1 Support Pack 2a (http://support.novell.com/
misc/patlst.htm#nw) or later.

Distributing Proper Versions of DSREPAIR to All Servers in the Tree

For information on preparing an existing tree for a NetWare 6 installation, see 
"Updating the eDirectory Schema for NetWare" in Chapter 1, "Installing and 
Upgrading Novell eDirectory," of the Novell eDirectory Administration 
Guide. 

You can also use NetWare Deployment Manager to prepare your tree for 
installation.

Installing into a NetWare 4 Tree

When installing a NetWare 6 server into a pure NetWare 4 tree, clicking the 
Browse button on the eDirectory installation screen to search for a context will 
not return a list of available containers. You must type the context where you 
want to install the NetWare 6 server into the tree.

Persistent Search Operations

A persistent search operation might not retrieve the updated information if 
entries in the eDirectory database change frequently. 
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Additional Readme Information

For information on additional eDirectory issues for this release, see TID 
#10063534 (http://support.novell.com) in the Novell Support Connection 
Knowledgebase.
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20 Novell GroupWise

In order to use GroupWise® 5.5 Enhancement Pack WebAccess on NetWare® 
6, you must download and install the WebAccess 5.5 EP SP4 Rev 3 patch or 
later (FWAEP4C.EXE, FWAEP4D.EXE, etc.) available from Novell Support 
Connection® Patches and Files (http://support.novell.com/filefinder). The 
patch is a prerelease version (Field Test File) of GroupWise 5.5 Enhancement 
Pack Support Pack 4. Your system must be running GW 5.5 SP3a before you 
can install this patch. Follow the installation instructions provided with the 
patch.

This patch resolves the following compatibility issues between GroupWise 
5.5 Enhancement Pack WebAccess and NetWare 6:

� If NetWare 6 is installed on a system where GroupWise 5.5 Enhancement 
Pack WebAccess has already been installed, the NetWare 6 installation 
program changes WebAccess from using the Novell® Servlet Gateway to 
using the Tomcat Servlet Gateway. Your existing WebAccess software is 
not designed to work with Tomcat. Therefore, you must install the 
WebAccess patch for compatibility with NetWare 6 and Tomcat.

� If you attempt to install GroupWise 5.5 Enhancement Pack WebAccess 
on NetWare 6 without first obtaining the patch, the WebAccess 
installation program will encounter problems. It will not be able to 
automatically stop your Web server, WebSphere, or Java for you so that 
the WebAccess installation can proceed. Although you can work around 
these installation problems by manually stopping the listed programs and 
then continuing the installation, you will still need to install the patch to 
provide WebAccess compatibility with Tomcat. 
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21 Novell iFolder

Selecting the Pre-migration Server Option

If you install iFolder via a Custom installation of the Pre-migration server 
option available in NetWare® 6, make sure NetWare Web Manager is also 
selected to be installed. You will need to reboot your server after the 
installation in order for iFolder to work properly.

Using a Proxy Server

If you plan to use a proxy server, set the following options on each workstation 
where the iFolder client will be installed: 

1 Open Internet Explorer and click Internet Options > Connections > LAN 
Settings > Use a Proxy Server > Advanced.

2 Check the Use the Same Proxy Server for All Protocols check box. 

Installing iFolder on NT 4 Workstations

NOTE: This issue is resolved in NetWare 6 Support Pack 1.

If you install the iFolder client on an NT 4 workstation with NTFS volumes, 
the iFolder client login will fail. To fix this, complete one of the following 
procedures for each iFolder workstation.

Modify Workstation Permissions

1 Open Explorer and click Program Files > Novell > iFolder.

2 Right-click the iFolder folder and then click Properties > Security.

3 Make sure the user has Full Control permissions.
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Apply the iFolder Patch

NOTE: This issue is resolved in NetWare 6 Support Pack 1.

1 Go to the Novell Support Web site (http://support.novell.com) and click 
Patches and Files.

2 Enter

IFLDRCLA.EXE

The A is a variable and will change as the iFolder client is updated.

3 Double-click IFLDRCLA.EXE to begin the download process.

Creating a User Account

Before you can access your iFolder files from the iFolder Web site, you must 
first download and install the iFolder client and then log in. The iFolder user 
account can be created only by logging in from the iFolder client. After you 
have logged in from the iFolder client, you will then be able to access your 
iFolder files from the Java applet via a browser.
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22 Novell International Cryptographic 
Infrastructure (NICI)

Some of the ConsoleOneTM snap-ins for NetWare® 6 require the NICI Client. 
To use those snap-ins, you must install NICI on every workstation where you 
will use ConsoleOne.

IMPORTANT: Two versions of NICI are provided for Windows platforms: 1.5.7 
and 2.0.2. We recommend that you install both versions.

NICI 1.5.7 is implemented as a kernel driver and NICI 2.0.2 is implemented as a 
shared DLL. Applications using NICI 1.5.7 will not work if only NICI 2.0.2 is 
installed. Likewise, new applications will require at least NICI version 2.0.2. Both 
NICI versions can be installed on the same Windows workstations, providing 
support for all applications.

The Client CD that is included with NetWare 6 contains the NICI client for 
Microsoft Windows operating systems. NICI clients for Solaris and Linux can 
be found on the Novell® software download page (http://www.novell.com/
download).

To install the NICI client from the Client CD, insert the CD. An autorun 
application begins. Select the NICI client from the list.
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23 Novell Modular Authentication 
Service (NMAS)

NICI Client

You must have the NICI Client installed on each client that will run 
ConsoleOneTM and NMAS. See “Novell International Cryptographic 
Infrastructure (NICI)” on page 71 for more information.

Update NetWare 5 Servers Running NMAS before Installing Novell 
Native File Access Protocols

Before installing Novell® Native File Access Protocols (as part of the 
NetWare® 6 installation or otherwise), all NetWare 5 servers (in the tree) 
running NMAS must be updated to NMAS 2.0.1, NICI 2.0.1, and ConsoleOne 
1.3.

NMAS 2.0.1, NICI 2.0.1, and ConsoleOne 1.3.2 updates and instructions are 
available at www.novell.com/downloads.

NMAS and BorderManager Interoperability

In order for BorderManagerTM Enterprise Edition 3.5 (BMEE35) and NMAS 
to coexist, the Login Policy Object must be created using the BMEE35 
NetWare Administrator snap-ins.

In order to install BMEE35 in a tree with NMAS, complete the following 
steps:

1 If a Login Policy Object already exists, delete it from the Security 
Container.

2 Install BMEE35.
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3 Create a new Login Policy Object using NetWare Administrator with the 
BMEE35 snap-ins. 

4 Configure the BorderManager services to use the Login Policy Object.

Refer to the Border Manager documentation (http://www.novell.com/
documentation/) for details.

5 Run the NMAS installation from the server-side GUI.

6 Reinstall any NMAS Methods and re-create any NMAS login sequences.

Simple Password and Force Password Change

The Simple Password method is used for various authentication services in 
NetWare 6. These include the Native File Access Pack that provides 
authentication support for CIFS and AFP.

A problem might arise if you set or change a user's simple password from the 
ConsoleOne administrative snap-ins using Force Password Change. If you 
experience problems setting an initial password, you might need to check the 
Force Password Change check box. If the user already has a password set, 
Force Password Change might not work unless you remove the current 
password and enter a new one.

Explicit Rights and Graded Authentication

You must give explicit rights to users with graded authentication. Inherited 
rights do not work. For example, an administrator's Supervisor right is defined 
at the [Root] container. Rights for the administrator are not defined in the 
Volume object. So if the administrator changes the volume's security label 
from Logged In to any other security label, the administrator cannot get the 
appropriate rights. The administrator must assign explicit rights to the volume, 
directories, or files in the volume.
74 NetWare 6 Readme

NetWare 6 Readme
103-000171-001

February 15, 2002
Novell Confidential



Manual 99a38 July 17, 2001
24 Novell Native File Access Protocols 

This chapter contains the following subsections:

� “General Issues” on page 75

� “Macintosh / AFP Issues” on page 78

� “Windows / CIFS Issues” on page 80

� “UNIX / NFS Issues” on page 82

General Issues

Update NetWare 5 Servers Running NMAS before Installing Novell 
Native File Access Protocols

Before installing Novell® Native File Access Protocols (as part of the 
NetWare® 6 installation or otherwise), all NetWare 5 servers (in the tree) 
running NMASTM must be updated to NMAS 2.0.1, NICI 2.0.1, and 
ConsoleOneTM 1.3.2. 

NMAS 2.0.1, NICI 2.0.1, and ConsoleOne 1.3.2 updates and instructions are 
available at www.novell.com/downloads. 

Beta Files Must Be Removed Prior to Installation

If you installed an earlier version of the AFPTCP or CIFS code (the Beta test 
release), you need to completely remove it (including the login methods from 
NDS®) before you reinstall.
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Uninstalling the Software

To remove the software, complete the following steps on each server running 
Novell Native File Access Protocol software.

1 Run Native File Access for Macintosh* (AFP) Uninstall using 
NWCONFIG or the GUI Uninstall. Reboot the server or unload the 
AFPTCP.NLM (AFPSTOP.NCF).

2 Run Native File Access for Windows (CIFS) Uninstall using 
NWCONFIG or the GUI Uninstall. Reboot the server or unload the CIFS 
NLMTM programs (CIFSSTOP.NCF).

3 Use ConsoleOne to remove the NMAS Login Server Methods from NDS.

3a Go to the root of the tree and select the Security object.

3b Right-click the Security object, select the Login Policy object, and 
then click Properties.

3c Delete/deselect LSMAFP and LSMCIFS sequences from Selected 
Login Methods.

3d Close the Properties window.

3e Select and delete the LSMAFP and LSMCIFS objects under 
Security/Authorized Login Methods.

NOTE: The uninstall program removes references to CIFS and AFP from the 
PRODUCTS.DAT and AUTOEXEC.NCF files. It does not remove the related NLM 
programs (CIFS.NLM, AFPTCP.NLM) and configuration files (AFPVOL.CFG, 
CTXS.CFG, CIFSCTXS.CFG, CIFS.CFG).

Intermittent Java Fatal Error

When the installation progress bar shows 100% copy and processing settings, 
the following error might occur: 

A fatal error has occurred. This program will terminate. You 
may check sys:\ni\data\ni.log for more details after you 
dismiss the dialog com/novell/admin/ns/nds/jndi/
ndsnamespaceImpl.

If this error occurs, terminate the installation and try again.
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Possible Login Error

If you encounter a login error while connecting to the server from a Macintosh 
or Windows workstation, run ConsoleOne and verify that the Simple 
Password, LSMCIFS, and LSMAFP login sequences are installed. 

If the sequences are not installed, do the following:

1 Run ConsoleOne and locate the Security container.

2 Double-click the Security container.

3 Right-click the Login Policy icon and click Properties > New Sequence.

4 Enter simplepassword as the Sequence Name.

5 Select the SimplePassword Object from the left column and click the 
arrow to add it to the right column.

6 Click Apply.

7 Repeat the above steps for the LSMAFP and LSMCIFS login sequences.

8 Restart the server.

NMAS.DLL Could Not Initialize Cryptographic Services (-1461)

If any of the following errors appear when launching ConsoleOne, you need 
to install NICI Client 2.02 or later on the administrator workstation:

NMAS.DLL could not initialize cryptographic services or 
cryptographic services are not available. (-1461)

NMAS.DLL is unloading b/c of errors during initialization. 

The library NMASWrap could not be located.

NMAS PutLoginConfig -1460 error

You might see the following error while trying to assign a simple password in 
ConsoleOne 1.2d1:

NMAS PutLoginConfig -1460 (NICI_E_NOT_FOUND error)

This error could be caused by either of the following:

� NICI Client is not installed. You must install the client.

� NICI Partition key is missing. You must reinstall NetWare. 
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Macintosh / AFP Issues

AppleTalk Not Supported as a Transport Protocol

The legacy AppleTalk* protocol stack is not supported as a transport protocol 
in this version of Novell Native File Access Protocols for Macintosh. 
AppleTalk migration is targeted for a subsequent release.

Older Mac applications that have unique dependencies upon AppleTalk as a 
transport protocol must be updated to a version that is known to work over 
TCP/IP. The AppleTalk stack protocols (TLAP, ELAP, LLAP, DDP, RTMP, 
AEP, ATP, NBP, ADSP, ZIP, ASP, and PAP) are not supported over TCP/IP by 
Apple*. 

Therefore, Novell does not support those legacy protocols either. Both Novell 
and Apple have embraced TCP/IP as the Internet standard transport protocol.

IMPORTANT: Older NetWare for Macintosh and Prosoft versions of AFP.NLM and 
APPLETLK.NLM are not supported. Do not attempt to mix old Mac support NLM 
programs with the new AFPTCP.NLM.

Server MONITOR Does Not Register Mac Connections

The MONITOR.NLM on the server does not register Mac connections. Also, 
the active connections’ Network Address list indicates “no address available.” 
This is a known problem for connections other than NCPTM sessions.

User Authentication Method Not Found

Mac users receiving the following error message should check the AppleShare 
folder in the Extensions folder and try again: 

The UserAuthentication Method required by this server can't 
be found

This error occurs because the new AFPTCP.NLM cannot coexist with prior 
versions of the AFP.NLM. 

To fix this error, do the following:

1 Unload the old AFP.NLM and remove it from the AUTOEXEC.NCF file. 

2 Unload and delete the old AFPCON.NLM and do not use it again. 

3 Delete the old AFPCON configuration file in 
SYS:\SYSTEM\GLOBDATA.AFP if it exists.

4 Make sure that the user’s context is in the context search file CTXS.CFG.
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Mac OS 8.x Will Not Mount Volumes Checked to Mount at Startup

Mac OS 8.x will not mount volumes checked to mount at startup. To resolve 
this, add the server volume's alias to the StartUp Items folder inside the 
System Folder on the Mac's local startup disk.

Drag a NetWare Folder to the Trash and Errors Occur

When you drag a NetWare folder to the trash, an error occurs because it is 
unable to leave the item in the trash and it will delete it immediately. 

This happens on Mac OS 8.1 with NSS volumes. Also, Mac OS X running 
with network volumes does not support the functionality associated with the 
Trash icon.

0x01 Filenames and NSS Volumes

Certain extensions and control panels (such as MacAdministrator) use 
filenames beginning with 0x01 to ensure that they load first. These filenames 
will not work correctly on an NSS volume.

Unloading AFPTCP.NLM and WSPDSI.NLM Programs

The Winsock component used by the Macintosh Native File Access NLM 
does not always clean up all open sockets. If you unload AFPTCP.NLM and 
then explicitly unload WSPDSI.NLM, it might give you the following 
warning in flashing red text:

WARNING!!!

1 active Winsock 2 DSI socket session(s)

Unloading WSPDSI.NLM with active session(s) will abend the 
server.

Unload all Winsock 2 apps with active SSL socket session(s).

Unload module anyway?

Do not unload the module or the server will abend.

The warning is correct. WSPDSI thinks there are still active AFP sessions and 
it will abend the server if you unload it. The last line of the warning should 
read "Unload AFPTCP.NLM" but, because AFPTCP is already unloaded, 
unloading AFPTCP will have no effect.

There is no need to unload WSPDSI manually. AFPTCP.NLM loads it 
automatically on startup and AFPSTOP.NCF does not unload it. It remains 
loaded. Under normal use, you should not see this warning.
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Volume ID

You might get pervasive errors in a clustered AFP environment when the 
volume ID is set to higher than 32. To eliminate these errors, use ConsoleOne 
to edit the cluster AFP/TCP volume resource and change the volume ID to 32 
or lower. Remember to make the value you choose unique from other volume 
IDs.

Windows / CIFS Issues

Problem with Microsoft Patch

Microsoft recently released a patch to its Windows NT 4.0 RPC service to 
address a vulnerability to Denial-of-Service attacks. Although the CIFS 
Import Users functionality does not cause or participate in any denial of 
service attacks, the patch does change the Window NT 4.0 RPC interface 
which, in turn, affects the CIFS Import Users functionality.

The interface changes are in the process of being tested, and we will release a 
patch to correct this problem soon after NetWare 6 ships.

Workstations Might Not Be Able to Access a Windows 2000 Primary 
Domain Controller

If the Primary Domain Controller (PDC) is a Windows 2000 server, Windows 
workstations might not be able to access the CIFS server. To fix this, complete 
the following steps:

1 Specify the following parameter in SYS:\ETC\CIFS.CFG:

-PDC PDC_name IP_address

For example: 

PDC ONENET 130.57.66.134

2 Enter CIFSSTOP and then CIFSSTRT.

PDC and CIFS on Different Subnets

If the PDC and CIFS servers are on different subnets, the -PDCNAME option 
(which uses DNS resolution) might not work. Use the -PDC option instead.
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Password Changes

Trying to change a password from a Windows 9x or NT4 client workstation 
might fail if the default network username and password in the client's cache 
is not a valid combination on the CIFS server where the password change was 
attempted. 

To avoid this problem, validate the username and password combination in the 
client's cache on the CIFS server before attempting the password change. You 
can validate by attempting to access the file system on the CIFS server by 
browsing to Network Neighborhood. 

Password Changes and Case Sensitivity

When the CIFS password (simple password) on NetWare server is changed 
using the NET PASSWORD command on a Windows 9x client, the client 
always sends the old and new passwords in upper case. As a result, the regular 
NDS password update will not be successful if the old regular NDS password 
contains lowercase letters. Also, the new password will be stored in upper 
case.

For Windows NT/2000, the user should provide a case-sensitive password; if 
not, the regular NDS password update will not be successful.

CIFS Server on NetWare Does Not Function As a Master Browser

NOTE: This issue is resolved in NetWare 6 Support Pack 1.

If the CIFS server on NetWare is the only member of a workgroup, then the 
workgroup will not appear under Network Neighborhood. However, it might 
be possible to locate the server using the Find Computer feature.

Configuration File Options Not Supported

The -ASYNC, -OPLOCKS, and -UNICODE options are not supported with 
this release. Make sure these options are set to Off.

CIFS Server Not Visible in Network Neighborhood

You might occasionally find that your CIFS server is not visible using 
Network Neighborhood. This can happen if you have a domain that contains 
only Windows 95/98 and no NT/2000/XP servers or clients. To correct this 
problem, enter the server name or IP address in Find Computer.
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MS Paint "Out of Memory" Error

CIFS users might occasionally see an Out of Memory error when using MS 
Paint on a Windows NT workstation. This error message is incorrect and no 
processes are out of memory. The error message will disappear if the data file 
is first saved to local storage and then copied to the remote storage directory.

UNIX / NFS Issues

Upgrade Issues

� Before beginning an upgrade from NetWare 5.0 with NetWare NFS 
Services 2.4 installed, you must comment out the UNISTART entry in 
AUTOEXEC.NCF. 

� Before rebooting the system after an upgrade from NetWare 5.1 with 
ZENworksTM for Desktops 3.2 and PXE support installed, you must 
change the load order in AUTOEXEC.NCF so that NFSSTART.NCF 
comes before ZFDSTART.NCF.

� Upgrading from NetWare 5.1 with NetWare NFS* Services 3.0 installed 
removes the product but retains the NFS Server and NIS configuration.

� After an upgrade from NetWare 5.1 with NetWare NFS Services 3.0 
installed, you must remount the NetWare exports mounted on NFS 
clients.

� After upgrading from NetWare 5.1 with NetWare NFS Services 3.0 
installed, the NFS Gateway component of NetWare NFS Services 3.0 will 
not be functional; it is not supported on NetWare 6.

General

� If the server holding the master eDirectoryTM replica is down, Native File 
Access for UNIX* will not work on servers that have a Read-Only 
replica, a Filtered replica, or no replica. 

� When Native File Access for UNIX is installed on a multiserver tree, the 
UNIX profile of the NIS User object is not mapped to root. Therefore, 
NFS Server fails to load.

Refer to the SYS:ETC\SCHINST.LOG file after the installation and run 
schinst again if any errors are logged.

� If the pkernel screen displays messages similar to the following, you can 
ignore them (they do not affect functionality in any way):

RPC:svc_register failed for prog=186A4, vers=1

NOTE: This issue is resolved in NetWare 6 Support Pack 1.
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� When Native File Access for UNIX is installed, the nfsstart entry is added 
to AUTOEXEC.NCF, so the services are not automatically available after 
installation. 

To make Native File Access for UNIX available, run nfsstart after 
installation or reboot the server.

ConsoleOne

� If you administer NFS exports of multiple servers and switch between 
them, it is possible that the data you view is for the previous server.

Click the corresponding Server object, right-click Exports, and then click 
Refresh to display its data.

� When managing the NFS server through ConsoleOne, if you try to export 
a volume without logging in to the Novell eDirectory tree, the following 
message displays erroneously: Config file is open. 

To export a volume, log in to the Novell eDirectory tree. 

NOTE: This issue is resolved in NetWare 6 Support Pack 1.

� When managing NFS Server through ConsoleOne, if a value that is out of 
range or invalid is entered in NFS Server > Options > Parameters, a cursor 
is placed in the next field and you cannot modify that field. 

To modify the field, close the panel and open it again. Enter a valid 
number that is in the range in the NFS Server > Options > Parameters 
field.

NOTE: This issue is resolved in NetWare 6 Support Pack 1.

� When managing NIS through ConsoleOne, eDirectory objects of type 
ipService and nisObject cannot be created. 

� When performing special map migration through ConsoleOne, the 
complete path of the file is required (for example, 
SYS:ETC\NIS\PHLIST).

NOTE: This issue is resolved in NetWare 6 Support Pack 1.

� Administering NetWare 5 NFS Services on NetWare 5 from ConsoleOne 
on NetWare 6 is not supported.
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NFS Server

� If exported NSS volumes are deactivated and activated in a different 
order, operations from an NFS client on these mount points will fail.                   

To ensure proper functionality, unload and reload the NFS Server 
software and remount the exported path on the NFS client.

� Hard links are not supported on exported NSS Volumes.

� Traditional volumes can be mounted only using NFS version 2.

Even though showmount shows the volumes as exported, they are not 
mountable using NFS version 3. You need to explicitly mount the 
exported traditional volumes specifying the mount version as 2. 

� If a Windows workstation user who has write permission to a file created 
in a mounted volume by a UNIX user attempts to modify the file, the 
ownership of the file will change from the UNIX user to the Windows 
workstation user.

� UnixWare* 7 NFS client access has issues with recursive delete and C file 
compilation. Also, the ownership of a file will change if a nonowner user 
with permissions to the file edits it.

NIS Server

� No error message is displayed to convey that the NetWare server fails to 
become a slave to the UnixWare 7 NIS Master.

� To set the password for a user from a UNIX NIS client, use ypset to set 
the default domain in the NetWare server.

� NIS objects such as nisDomain, nisMap, and nisObject cannot have 
names with more than 64 characters.

� Unloading nisbind might take several minutes.

� If maps are pushed to an NetWare NIS slave server using any map name 
(for example, hosts.byname or hosts.byaddr), both maps are updated in 
the slave server.

� For Default maps, the pound sign (#) is not a valid comment character. If 
you don’t want to migrate a particular record, remove it from the text file 
before migrating.

� The bootparam and netgroup maps are not supported in this release.

� Using ypcat groups does not show the members of the group.

NOTE: This issue is resolved in NetWare 6 Support Pack 1.
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Migration

� After a new user is created and the user's UNIX profile is set, if the group 
corresponding to the user's GID exists, the user will be listed as a member 
of that group. However, the rights of the group will not flow down to this 
user. Remove the user from the members list and add it again.

� While migrating domains using the -x option, edit the context parameter 
by prefixing each of the dots in the Relative Distinguished Names with a 
backslash ( \ ) to distinguish them from eDirectory (NDS) names.
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25 Novell NetDrive

� NetDrive supports HTTPS for WebDAV only on Windows NT 4.0 and 
Windows 2000 workstations.

� If your NetDrive client is behind a firewall regulated by a 
BorderManagerTM server that is configured for FTP proxy and 
authentication, NetDrive cannot map a network drive via FTP to any 
servers that reside outside the firewall. To solve this problem, disable the 
FTP proxy authentication on the BorderManager server.
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26 Novell NetStorage

Changing iFolder IP Address after the NetStorage Installation

If you change the iFolderTM server IP address, DNS name, or port number after 
NetStorage has been installed, you must either reinstall NetStorage or edit the 
XSYNCNSP\IFOLDER SERVER registry setting to reflect the change. 
NetStorage will not function properly without this change.

Changing Apache Port Numbers after the NetStorage Installation

If you change the Apache Web server port numbers after NetStorage has been 
installed, you must either reinstall NetStorage or edit the 
XSYNCNSP\SECURE PORT registry setting to reflect the change. 
NetStorage will not function properly without this change.

Logging In as a Different User

If you are using Windows 98 and Internet Explorer, and after logging in to 
NetStorage you intend to log in again as a different user, you must first delete 
Internet Explorer cookies and log out from Windows 98 or you will not be able 
to log in again. This is necessary because Windows 98 retains user information 
and NetStorage cookies are created that are user specific. 

When using Windows 2000 and Microsoft Web Folders, you must enable the 
Launch Folder Windows in a Separate Process option by doing the following:

1 Double-click My Computer and then click Tools > Folder Options > 
View. 

2 Check the Launch Folder Windows in a Separate Process check box.
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Internet Explorer Unable to Open Some Web Folders

If you use Microsoft Web Folders with NetStorage to create a new folder, you 
might not be able to open that folder using Internet Explorer.

Hosts File Not Usable by NetStorage

NetStorage cannot use the SYS:\ETC\HOSTS file to resolve DNS names. If 
you have applications that can use DNS names (such as iFolder), your DNS 
names must be registered with a valid DNS server which is identified in the 
SYS:\ETC\RESOLVE.CFG file. The DNS server is normally registered 
automatically during the NetWare 6 installation.

NetStorage Help Not Accessible When Using NetWare WebAccess

NetStorage online help is not accessible when both of the following conditions 
exist:

� You access NetStorage using NetWare® WebAccess

� NetStorage and NetWare WebAccess are installed on different servers 

To make NetStorage help accessible, copy the SYS:NETSTORAGE directory 
from the server where NetStorage is installed to the server where NetWare 
WebAccess is installed and add the following lines to the 
SYS:APACHE\CONF\ADMINSERV.CONF file on the NetWare WebAccess 
server.

Alias /NetStorage "SYS:/webapps/NetStorage"

<Directory "SYS:/webapps/NetStorage">

   Options Indexes FollowSymLinks

   AllowOverride None

       Order deny,allow

   Allow from all

</Directory>

Character Set Issues with Netscape

If you use the Netscape* browser to open NetStorage, square boxes will be 
displayed in place of some characters. To resolve this, click View > Character 
Set > Unicode (UTF-8) and then click View > Character Set > Set Default 
Character Set. 
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Downloading Folders Using a Browser is Not Supported

The Novell NetStorage documentation indicates that you can download 
folders using a browser with NetStorage. This is incorrect. You can download 
individual files using a browser with NetStorage, but downloading folders is 
not currently supported.

You can create new folders or you can copy, delete, rename, or move existing 
files and folders by right-clicking the file or folder and then selecting the 
option you want.
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27 Novell Storage Services

Previous NSS Volumes Not Automatically Upgraded

Previous NSS volumes are not automatically upgraded during the NetWare® 6 
installation process. After you install NetWare and reboot the server, you can 
upgrade previous NSS volumes to the current NSS volume layout. 

Before you upgrade previous NSS volumes, you must ensure that NDS® is up 
and running and that the Backlink process is complete.

To upgrade previous NSS volumes, do the following at the server console: 

� To upgrade a single NSS volume, enter

nss /zlssvolumeupgrade=volume 

� To upgrade all NSS volumes, enter

nss /zlssvolumeupgrade=all

After you upgrade all the volumes, you can use the MOUNT ALL command 
or mount the volumes individually.

Must Add Trustee Rights to SYS:LOGIN When Upgrading Volume 
SYS:

You can use the Volume Conversion Utility (VCU) to upgrade a traditional 
volume SYS: to the NSS volume SYS:. However, the implied trustee rights do 
not transfer with this method. After you upgrade volume SYS:, you must 
manually add a public trustee with read and file scan rights to the LOGIN 
directory.
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Modifying a Volume’s NDS Object When Converting Volumes

You can convert traditional volumes to NSS volumes after you upgrade to 
NetWare 6. The following is an example of using the volume conversion 
utility (VCU) when you want to modify the volume’s NDS object:

vcu TRAD NSSPOOL provo_tree\novell\provo ds_poolname ds_volName

DS tree: provo_tree
DS context:provo.novell
DS NSSPOOL name: ds_poolName
DS TRAD name: ds_volName

Do Not Create Traditional Volumes Still in Clusters

After you upgrade the first server in a cluster, the shared NSS volumes might 
appear as free space in a traditional partition on the remaining NetWare 5 
servers. Creating a volume in this space will corrupt the NSS volumes. For 
more information, see Chapter 17, “Novell Cluster Services,” on page 59.
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28 Novell TCP/IP

Missing INETCFG Information

NOTE: This issue is resolved in NetWare® 6 Support Pack 1.

If any information is missing from INETCFG after a new installation, it is 
because no information was uploaded to the TCPIP.CFG file. Similarly, if 
INETCFG information is missing or you get configuration error messages 
after an upgrade, it is because no new information was uploaded to the 
TCPIP.CFG file and some entries have become invalid. In either case, delete 
the SYS:/ETC/TCPIP.CFG file and reconfigure through INETCFG. 

Supernetting

� Once the server is configured with a supernet mask, it behaves like an end 
node when IP Forward gets disabled. It continues to behave like an end 
node, even if the mask is changed to a non-supernet mask and the system 
is reinitialized. To make it work like a router, change the state of the IP 
packet forwarding or RIP or LAN Static Routing in INETCFG and 
reinitialize the system.

� With the CIDR mask on, some valid host IDs ending in .255/.0 cannot be 
bound. 

Fault Tolerance

� Fault tolerance is supported on ODITM compliant drivers (such as 
CE100B, IBMFE, PCNTNW, 3C90XC, and N100).

� Load balancing and fault tolerance features cannot be configured in the 
protocols menu of INETCFG if the bindings are created by transferring 
commands from AUTOEXEC.NCF. To resolve this problem, delete all of 
the bindings from the Bindings menu and add them again.
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Load Balancing

� Load balancing might not work when all the clients’ IP address are 
mapped to a single server NIC and all the clients start data transfer 
simultaneously. 

� Multihoming might not work in some cases where the hosts are 
supernetted.

Viewing Bindings

NOTE: This issue is resolved in NetWare 6 Support Pack 1.

You can discover and load drivers using NWCONFIG and subsequently bind 
the boards to IP addresses through INETCFG. However, NWCONFIG does 
not show the bindings. To see the drivers, unload the drivers from the system 
console and reinitialize the system. NWCONFIG then shows the bindings 
added through INETCFG.

Routing

EGP and OSPF are not completely functional in this release.

RAM

Ensure that at least 512 MB of RAM is available where the server is to be 
stressed with heavy network operations.

IP Trace

Once the IP Trace is loaded, you cannot load anything from the console until 
the Trace finishes. To load something, close the Trace screen.

Application Dependency

If the IP address used by an application is changed, it might stop working. For 
more information, refer to the documentation for the particular application.
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29 Pervasive.SQL

Pervasive.SQL 2000 Database Licenses

A permanent two-user license is installed during the NetWare® 6 installation 
process. If you are upgrading an existing NetWare server, an unlimited license 
that will expire 90 days after installation is also installed. 

The permanent two-user license is intended for use by the NetWare operating 
system. If you have additional applications using Pervasive.SQL 2000 or 
Pervasive.SQL 2000i, including the Btrieve* interface, you can use the 
unlimited user count license for 90 days. If you have applications that need 
access to the NetWare Pervasive.SQL 2000i database engine, you must 
purchase an appropriate user count license from Pervasive* Software before 
the 90-day evaluation period ends. Please allow adequate time before the end 
of the evaluation period to receive your user count license.

For more information on Pervasive.SQL 2000i, features, documentation, or 
information, see the following:

Internet: Pevasive Software Web site (http://www.pervasive.com) 

Email: Salessupport@pervasive.com

Phone (U.S.):1-800-287-4383

Phone numbers for all international offices are available from the Contact Us 
link (http://www.pervasive.com/company/contact/index.asp) on the Pervasive 
Software Web site.
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Known Issues

So that Pervasive can update known issue reports periodically between 
releases, all Known Issues are now published in the Pervasive Knowledge 
Base (http://support.pervasive.com/eSupport/). Search on "Pervasive.SQL 
2000 Service Pack 3 known issues".

You can also see a static list of known issues, including links to the associated 
Knowledge Base articles, at their Fixed Defects and Known Issues Web page 
(http://www.pervasive.com/support/updates/psql2kfixed.asp).

Technical Support

For technical support and discussions about Pervasive products, see their 
DevTalk forum  (http://www.pervasive.com/devtalk).

To file a support incident, submit an Electronic Support Incident  (http://
www.pervasive.com/support/support_email.asp).

You can also visit the Pervasive Support Center (http://www.pervasive.com/
support/supportcenter.asp) for other contact information.

Useful Links

You can also check out the following:

� Comprehensive list and details of Pervasive products  (http://
www.pervasive.com/offerings).

� Discussions about Pervasive development issues  (http://
www.pervasive.com/devtalk).

� Technical papers  (http://www.pervasive.com/support/TechPapers.asp).

� Online product manuals (http://www.pervasive.com/support/technical/
online_manuals.asp).

� Support programs (http://www.pervasive.com/support/
support_programs.asp).

� Pervasive Knowledge Base (http://support.pervasive.com/eSupport/).

� Updates and patches (http://www.pervasive.com/support/updates/).
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30 Scripting Products

Scripting Products Included

The following scripting products are included with NetWare® 6. Readme 
information can be found at the links provided.

� Novell® Script for NetWare (NSN) (http://www.developer.novell.com/
ndk/nscript.htm#readme)

� Perl for NetWare (http://www.developer.novell.com/ndk/
perl5.htm#readme)

� NetBasic* 6.0 (http://www.developer.novell.com/ndk/nb6.htm#readme)

� Universal Component System (UCS)  (http://www.developer.novell.com/
ndk/ucs.htm#readme)

Upgrading from NetWare 5.1 to NetWare 6

� The NSN and NetBasic configuration files 
(SYS:SYSTEM\NSNSYS.INI, SYS:UCS\UCX.INI, and 
SYS:SYSTEM\NBSYS.INI) are overwritten during the upgrade. If you 
previously made changes to the files, you might want to keep a copy of 
them. 

� ScriptEase (SE) is not installed as part of NetWare 6. If the system is 
upgraded from NetWare 5.1 to NetWare 6, SE will be available because 
it was part of the NetWare 5.1 system. Note that Novell will not provide 
customer support for SE in a NetWare 6 environment.

NSN Compiler

The NSN Compiler SDK is not included with NetWare 6. The NSN product 
on the NDK Web site (http://www.developer.novell.com/ndk/nscript.htm) has 
the latest version of the compiler.
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Novell Script Pages

Novell Script Pages (NSP) prevents any NSP page from being uploaded and 
executed without the execute bit set on the NSP file itself or on the parent 
directory. 

To mark an NSP file or directory with the execute bit, do the following:

1 Access NDS® from the NetWare Web Manager General Administration 
page.

2 Navigate to the NSP file or directory and display the access control rights 
for that object.

3 Check the Execute check box and save your changes.

After the NSP page file or directory has been marked with the execute bit, 
NSP will allow it to run.
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31 Storage Management Services (SMS)

This chapter contains the following subsections:

� “Backup and Restore Issues” on page 101

� “Client Issues” on page 102

� “Other Issues” on page 103

Backup and Restore Issues

Update SMS Components

NOTE: This issue is resloved in NetWare® 6 Support Pack 1.

A new release of Storage Management Services (SMS) is available at the 
Novell® Support Web site (http://support.novell.com). This release contains 
important fixes to the SMS components delivered with NetWare 6. 

The fixes ensure compatibility between earlier versions of NetWare and the 
NetWare 6 SMS modules. In addition, the patch includes updates to SMS 
components (including SMDR and TSA), which have made the product more 
stable and robust.

To maintain backup and restore services on NetWare 6 and your network, you 
must install the patch. The patch will supersede the SMS modules installed by 
default during the NetWare 6 installation. 

For more information, see the Readme included with the patch. 
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DOS File Systems on NSS

TSADOSP.NLM, the target service agent for the DOS file system on NSS, is 
no longer required. Instead, load DOSFAT.NSS and TSA600.NLM on the 
server hosting the DOS partition. This enables the partition to be listed as an 
NSS volume for backup or restore operations.

Exclude/Include Options for Workstation Restore

When Exclude/Include options are set for a workstation restore, only the 
selected data sets are restored. The log file and the status window of the 
session reports incorrect status. All the data sets are reported as restored, 
whereas only the data sets matching the specified options are actually restored.

Hard Links Not Supported by NSS in NetWare 6

Hard links are not supported by NSS in NetWare 6. Therefore, existing hard 
links in your data can no longer be restored to NSS.

Restoring Hard Links in a NetWare Traditional File System 

Hard links in a NetWare Traditional File System cannot be restored to a 
directory that does not exist on the volume. That is, if the hard link has to be 
created in a directory that is different from the parent directory (where the file 
was originally located), then the directory for the hard link should exist on the 
volume before the hard link can be created. This is unlike a normal restore 
operation wherein a new directory is created whenever the restore directory is 
different from the parent directory.

Client Issues

Windows 2000 and NT Workstation Registration Using IPX/SPX

NOTE: This issue is resloved in NetWare 6 Support Pack 1.

The Windows workstation will not register to the NetWare server if both are 
configured to use only IPXTM/SPXTM.

Setting the Username and Password for Windows 2000 Workstation

Follow the procedure below to set the username and password on a Windows 
2000 workstation. The TSAPrefs interface does not let you set these fields 
while registering the workstation to a server.
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1 From the Start Menu, click Settings > Control Panel, double-click 
Administrative Tools > Computer Management, and then click Local 
Users&Groups > Users.

2 Double-click a user from the list.

3 In the Member Of window, select the group that has the security policy, 
click Act As Part of the Operating System, add the user as a member of 
the group, and then click Apply > OK.

If you need to assign a security policy to a group, do the following:

� Return to the Administrative Tools window and click Local Security 
Policies > Local Policies > User Rights Assignment.

The list of policies and the local and effective settings are displayed.

� Double-click Act As Part of the Operating System Security Policy to 
display the Local Security Policy Setting dialog box.

� Click Add, select the group that this policy is to be assigned to, and 
then click Add > OK.

4 Restart the Windows NT Target Service Agent for the changes to take 
effect.

5 Register the workstation to a server.

Other Issues

SBCON recognizes data only in the System Independent Data Format (SIDF). 
If the media contains data in any format other than SIDF, the media must be 
labeled before use. 
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32 Third-Party Adapters, Drivers, and 
Applications

Using Virus Scan Software with NetWare 6

When performing virus scans with Norton or McAfee software, you must 
exclude the protected NSS volume named _ADMIN. Otherwise, the server 
will abend.

ISA Adapters Are Not Supported on NetWare 6

For performance and scalability reasons, all ISA adapter drivers have been 
removed from NetWare 6. There is a possibility that a family driver might 
support adapters which run on more than one bus type (PCI and ISA). In this 
case, any ISA adapter would be considered a noncertified driver and would 
not be supported by Novell®. 

CardBus and Mini-PCI LAN Drivers

There are no certified CardBus or Mini-PCI drivers in NetWare® 6. However, 
we have included drivers for adapters that use the 3COM* 3C1556.LAN 
Mini-PCI driver and drivers for XIRCOM CardBus adapters, which use the 
CE3ODI.LAN driver. These drivers are located in the 
DRIVERS\UNSUPDRV directory on the Operating System CD or in the 
NWSERVER\DRIVERS\UNSUPDRV directory, located in the DOS partition 
after installation. 

IMPORTANT: Although these drivers might work, they have been included only 
for use in cases where laptop servers are needed for demonstration purposes. 
They should be considered not supported by Novell. See the Readme in the 
UNSUPDRV directory for details.
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Suggested LAN Driver Substitution

In some cases there are no substitutes for LAN drivers. For example, Compaq 
no longer supports the Netflex 3 LAN hardware associated with the 
CPQNF3.LAN driver. 3Com provides limited support for their 3c90x LAN 
card line to LAN cards starting with the 3c905b hardware and beyond.   

Unsupported versions of these drivers are located on the NetWare 6 Operating 
System CD and can be installed in the NWSERVER\DRIVERS\UNSUPDRV 
directory.

Patches for Backup

Patches for backup and restore operations will be available on the Novell 
Support Web site (http://support.novell.com) concurrent with the shipment of 
NetWare 6.

WAN Support

WAN support is not included with NetWare 6. If you are upgrading from a 
previous version of NetWare, your AUTOEXEC.NFC and STARTUP.NCF 
files might need to be edited to remove WAN components that are autoloaded.
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