
 

2 Developing and Maintaining Collector 
Scripts 

Collector Scripts can be fully customized or built from scratch by any user. Sentinel 
provides the Collector Builder development environment for building and maintaining 
Collector Scripts. The Collector Builder is an integrated development environment (IDE) 
that makes developing Collector Scripts easy. 

Since Sentinel 6, the functions of configuring, debugging and deploying Collector Scripts 
has been moved to the Event Source Management feature of Sentinel Control Center. For 
more information on these functions, see Event Source Management in Sentinel User 
Guide. 

 

Collector Script Development Overview 
The following are the basic steps in implementing a Collector Script. 

1. Determine what you want to monitor 
2. Determine how to monitor the data 
3. Determine the product’s operating system 

 If the host and product are co-located, the most logical way to obtain the data 
is to read it from the product’s log file.  

 If the host and product are not located on the same machine, the needed data 
can be obtained through a network file system setup (such as NFS, Samba or 
SMB share), a TCP/IP socket connection or a serial connection. 
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4. Create the Collector Script to parse the data from the data source you want to 
monitor. For more information, see “Building a Collector Script”. 

5. Import the Collector Script from the collector workspace directory and deploy the 
Collector Script using Event Source Management in Sentinel Control Center. For 
more information on these functions, see Event Source Management in Sentinel 
User Guide. 

 

Building a Collector Script 
Building a Collector Script requires you to create the following files: 

 “Template files” 
 “Parameter files” 
 “Lookup files” (optional) 

The most efficient way to develop a Collector Script is to do one of the following: 

 Find an existing Collector Script that parses similar data that is acquired using a 
similar connection method as the data you want to parse. 

 Download the Collector Script Template from the Novell Collector website 
(http://support.novell.com/products/sentinel/collectors.html) 

By using one of the above options, you can start creating the parsing code specific to the 
device you want to collect data from without having to create template, parameter, and 
lookup files from scratch. 
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To use an existing Collector Script do one of the following, depending on where you 
obtained the existing Collector Script: 

If you downloaded the Collector Script from the Novell Collector website: 

1. Download the Collector Installer from Novell Collector website 
(http://support.novell.com/products/sentinel/collectors.html) 
NOTE: Some of the Collectors may require an installer to install. In that case, the 
instructions to install the Collector are explained in the specific Collector related 
documentation. 

2. Run the Collector Installer, with the installedAgentDirectory command argument 
set to %ESEC_HOME%\data\collector_workspace and the srcAgentDirectory 
command argument set to the directory where the downloaded Collector Script 
zip file is located. This will place the contents of the zip file in the collector 
workspace directory. 

3. Click View > Refresh Collectors in Collector Builder to load the newly installed 
Collector Scripts. 

If you have the Collector Script deployed in Event Source Management: 

1. Stop the Collector you wish to modify. 
2. Right click on the Collector and select Debug… 
3. In the Collector Debugger window, select the Upload/Download tab. 
4. Ensure the destination directory field points to the collector workspace directory. 
5. Click the Download button. The Collector Script will be downloaded from the 

Plug-in Repository to your local collector workspace directory. 
6. Click on View > Refresh Collectors in Collector Builder to load the downloaded 

Collector Scripts. 

Creating and Configuring Template Files 
To creating and configuring Template files: 

1. Start Collector Builder. 
2. In the Collectors tree, right-click Collectors and click New Collector. 
3. Enter the new Collector name in the space provided and press Enter. 
4. Right-click on the new Collector and click New Template. 
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5. In the New Template box on the Collectors tree type a new template name and 
press Enter. 

6. Select the new template and click the Template Editor tab. 
7. In the Template Editor panel, drag and drop states to the editing area using the 

state buttons on the left of the panel. For information about adding states to a 
template, see “Adding a States to a Template”. 

8. Click Save. 

Adding a State to a Template File 
All Collectors begin processing at state 1, regardless of where state 1 appears in the 
template. Assuming state 1 is a processing state, insert the new state following state 1. 

Collector Builder automatically assigns the first state a state number of 1. It is 
recommended that this first state contain only a BREAKPOINT() parsing command. 
Putting only a breakpoint after State 1 will allow for easier debugging. When debugging, 
the parser will automatically stop on the next state. 

When building a template, start with ‘breakpoint only’ parse state. Then, add the working 
state (Receive state, Parse state and so on) at State 2. If you need to add a state to the 
beginning of the template, insert it after the BREAKPOINT only. 

Do not delete the BREAKPOINT only parse state unless it is necessary to add another 
state at the beginning of the template. Optionally, you can enter comments in this 
BREAKPOINT only about the functionality of the template. 

To Add a State to a Template: 

1. Click the Collectors tab to open the Collectors tree panel. 
2. In the Collectors tree, select a template to display the Template Editor in the right 

panel. 
3. Click Options > Add State > Transmit, Receive, Decide, Parse, Next, Go To or 

Stop states as needed or click the appropriate buttons. 

  Transmit 

  Receive 

  Decide 

  Parse 

  Next 

  Go To 

  Stop  

4. Using the editing panels at the bottom of the Template Editor panel, insert the 
new code into each state as you add it. 
Alternatively, you can also drag and drop a Parse State button from the left side of the 
Template Editor into the editing area. 
NOTE: Do not use double quotation marks as part of the decide string either in 
the receive state (to match the delimiter in a log file, for example) or in a decide 
state, you will get the following error message: 

***ERROR: Reading Template File..." 

When one or more quotes is put into the decide or delimiter string, a quote 
mismatch occurs as follows: 

StateDecideString: "test"123" 

The workaround is to use \22\ instead of a quote ("). 
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NOTE: If you select another item in the Collectors tab (even in the same 
Collector) and then go back to the offending template, Collector Builder gives 
you this error message and will not display any part or states of the template. The 
error is occurring because the quote character (") is used to delimit field values in 
a .tem file. For example: 

StateDecideString: "test" 
StateDelimiterString: "123" 

Entering a Parsing Command through the Visual Editor 
There are two methods of entering a Parsing Command, using the Visual Editor or using 
the Text Editor. Limit your commands to no more than 4096. 

To enter a Parsing Command through the Visual Editor: 

1. In the Template Editor, select a parse state. The Visual Editor tab is open by 
default when you click a template to open. 

 
2. In the visual editor, drag the parsing commands to the right side of the panel. 

 

 
3. Enter the argument values in the Popup Command Editor window. 

 Select a Type: The types for each parsing command are described in the 
Sentinel User Reference Guide. 

 Specify a Value: Values are defined for a specific application. Examples of 
values for each parsing command are in the Sentinel User Reference Guide.  
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To enter a Parsing Command through the Text Editor: 

1. In the Template Editor, click the Text Editor tab. 
2. Manually enter your parsing commands. 

Use the Tab key on the keyboard to line up text when using a fixed font. Copy, cut 
and paste options function like any standard text editor. 

Editing a Parsing Command 

 
 Arguments: Includes all of the possible arguments for the parsing command you 

selected in the Visual Editor 
 Argument Use: Defines whether the argument is mandatory or optional 
 Type: Determines the variable type; for example, strings, string variables, numbers, 

number variables, floats, float variables or predefined variables 
 Value: Value you define for the variable that’s named in the Type column 

To edit a Parsing Command: 

1. In the visual editor, either: 
 Right click on a parsing command and choose Add to State Script 
 Double-click on a parsing command, the Command Editor will open 

2. Fill in the Type and Value boxes to complete the editing. For more information 
on Parsing Command descriptions, see Sentinel User Reference Guide. 

Creating and Configuring Parameter Files 
To creating and configuring Parameter Files: 

1. Select a template and click the Parameters tab in the right panel. 
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2. Double-click the new... button in the second column of the Parameters table. 
3. Enter the new parameter name (this is the name of your script, such as r4.1) and 

press Enter. 
4. (Optional) Right-click the Bitmap button (second column/second row) and click 

Assign Bitmap. In the Bitmap Assignment dialog box, select a Bitmap button. 
5. Double-click each of the new parameter boxes and enter the appropriate values. 
6. When all of the values are defined, the parameter and the template file need to be 

compiled to create a script. Go to section “Building Scripts”. 

Sentinel 6 Compatible Parameter Conventions 
Use the following conventions when creating parameters to ensure compatibility with 
Sentinel 6 Event Source Management features. 

 First column in the Parameters screen has the default values 
 Second column has the description of the Parameters 
 In a collector, if you have the same parameters in multiple scripts, the script name will 

precede the parameter name (internal, not display name). 

Creating and Configuring Lookup Files 
This is an optional procedure. 

To create and configure Lookup Files: 

1. Right-click a Collector and click New Lookup File. 
2. In the New Lookup File box, type a new lookup file name and press Enter. 
3. In the Match column, Double-click new... and enter the string to match and press 

Enter. You can add, insert and delete match clauses. 
 To add: In the Match column, right-click a match clause and click Add 

Match Clause. 
 To insert: In the Match column, right-click a match clause and click Insert 

Match Clause. 
 To delete: In the Match column, right-click a match clause and click Delete 

Match Clause. 
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4. (Optional) To enter parsing commands, right-click in the Parsing column to open 

the Visual Editor. For information about using the Visual Editor, see “To Enter 
Parsing Commands Using the Visual Editor”. 

5. Select the parsing commands and complete them in the Command Editor 
window. The commands display in the Parsing column. 

6. When all of the values are defined, it must be compiled to create a script. Go to 
section “Building a Script”. 

Scripts 
Scripts (.asd files) are generated from a combination of the template files and parameter 
files. You can generate multiple scripts from one template. Collector Builder allows you 
to: 

 “Build a script” 
 :Assigning a Startup Sequence to a Script” 

Building a Script 

To Build a script: 

1. In the left panel, select the template that you are building the scripts from. 
2. Select File > Build Scripts. 

 
3. In the Template Editor tab, drag a script from the template to the Startup Scripts 

or Backout Scripts column in the right panel. 
 

 
Scripts execute in the order they appear in the Startup Scripts and Backout Scripts 
columns. To rearrange the script order, drag the scripts up or down in the columns. 
NOTE: The final script in a backout sequence must end with the Stop processing 
state. 
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4. Click File > Save. 

Assigning a Startup Sequence to a Script 
If you want a port to run at startup, you can assign a startup sequence to run a specified set 
of scripts at startup. A startup sequence is a file that contains the names of the scripts to 
run at startup. 

NOTE: For compatibility with Sentinel 6, the startup sequence filename must be 
startup.chn. 

To assigning a Startup Sequence to a Script: 

1. Right-click a script name in the Collectors tree and select New Startup Sequence. 
The New Startup Sequence dialog box displays. 

2. In the New Startup Sequence dialog box, type the sequence name and click OK. 
The new startup sequence name is added to the menu at the top of the Startup 
Scripts panel. The following restrictions apply to sequence names: 
 Do not use startup or backout as sequence names 
 Do not use duplicate sequence names within the same Collector 

3. Drag the script file names from the Collectors tree to the Startup Scripts column. 
The scripts execute in the order that they appear in the column, from top to 
bottom. 

4. To rearrange the script order, drag the scripts from the column, or right-click the 
Startup Scripts panel and select Reorder Startup Script. 


