Novell
Server Consolidation Utility

3.0 o
ADMINISTRATION GUIDE

December 3, 2004

Novell



Legal Notices

Novell, Inc. makes no representations or warranties with respect to the contents or use of this documentation, and specifically disclaims any express
or implied warranties of merchantability or fitness for any particular purpose. Further, Novell, Inc. reserves the right to revise this publication and to
make changes to its content, at any time, without obligation to notify any person or entity of such revisions or changes.

Further, Novell, Inc. makes no representations or warranties with respect to any software, and specifically disclaims any express or implied warranties
of merchantability or fitness for any particular purpose. Further, Novell, Inc. reserves the right to make changes to any and all parts of Novell software,
at any time, without any obligation to notify any person or entity of such changes.

You may not use, export, or re-export this product in violation of any applicable laws or regulations including, without limitation, U.S. export
regulations or the laws of the country in which you reside.

Copyright © 2002-2004 Novell, Inc. All rights reserved. No part of this publication may be reproduced, photocopied, stored on a retrieval system, or
transmitted without the express written consent of the publisher.

Novell, Inc. has intellectual property rights relating to technology embodied in the product that is described in this document. In particular, and without
limitation, these intellectual property rights may include one or more of the U.S. patents listed at http://www.novell.com/company/legal/patents/ and
one or more additional patents or pending patent applications in the U.S. and in other countries.

Novell, Inc.

404 Wyman Street, Suite 500
Waltham, MA 02451

US.A.

www.novell.com

Novell Server Consolidation Utility 3.0 Administration Guide
December 3, 2004

Online Documentation: To access the online documentation for this and other Novell products, and to get updates, see
www.novell.com/documentation.



Novell Trademarks

ConsoleOne is a registered trademark of Novell, Inc. in the United States and other countries.

eDirectory is a trademark of Novell, Inc.

Internetwork Packet Exchange and IPX are trademarks of Novell, Inc.

NetWare is a registered trademark of Novell, Inc. in the United States and other countries.

NetWare Core Protocol and NCP are trademarks of Novell, Inc.

NetWare Loadable Module and NLM are trademarks of Novell, Inc.

Novell is a registered trademark of Novell, Inc. in the United States and other countries.

Novell Client is a trademark of Novell, Inc.

Novell Cluster Services is a trademark of Novell, Inc.

Novell Directory Services and NDS are registered trademarks of Novell, Inc. in the United States and other countries.
Novell Distributed Print Services is a trademark and NDPS is a registered trademark of Novell, Inc in the United States and other countries.
Nterprise is a trademark of Novell, Inc.

Nterprise Branch Office is a trademark of Novell, Inc.

Storage Management Services and SMS are trademarks of Novell, Inc.

ZENworks is a registered trademark of Novell, Inc.

Third-Party Trademarks

All third-party trademarks are the property of their respective owners.






Contents

About This Guide 7

1 Overview 9
What's New. . . . . . . e 9
Benefits of Using the Server Consolidation Utility . . . . . . . . . . . . . . . 10
What's Next. . . . . . . e e 11

2 Installing the Server Consolidation Utility 13
Meeting System and Software Requirements . . . . . . . . . . .. L 13
Workstation Requirements . . . . . . . . . L e e e 13

Server Requirements . . . . . . . . . L e e e 14
Installing the Software . . . . . . . . . . e 15
What's Next. . . . . . . . e 15

3 Consolidating Data From NetWare 17
Create aProject File . . . . . . . . . 18
Select a Source and Destination Tree . . . . . . . . . . . L 19
Select Volumes, Directories, and Printer Agents. . . . . . . . . . . e 19
Perform Pre-Copy Verifications. . . . . . . . . . . . e 21
Resolve Errors . . . . . . L e 25
Match Up Tree Objects . . . . . . . . . . . e 26

Server Consolidation Utility and Novell Nterprise Branch Office . . . . . . . . . . . . ... .. .. ... ... .. 28

Default Server and Home Directory for Created Users . . . . . . . . . . . . . . . .. .. .. ... . ..., 32

Start the Consolidation . . . . . . . . . L e 33
Schedule a Consolidation Project . . . . . . . . . . . . e 33
Consolidate to or froma NetWare 5.1 Cluster . . . . . . . . . . . . . . . . . . e 34

4 Consolidating Data from Windows NT 37
Meet System and Software Requirements . . . . . . . . . . . L 38
Perform Prerequisite Tasks. . . . . . . . . . . . e e 38
Create a Template Object. . . . . . . . . . . . . e 38
Register the Workstation . . . . . . . . . . . e 39

Run Server Consolidation . . . . . . . . . . . . L e 39
Model Your Consolidation Project . . . . . . . . . . . . . e 41
Verify Your Consolidation Project. . . . . . . . . . . . . . e 42
Migrate Users and Data to the Destination eDirectory Tree . . . . . . . . . . . . . .. . . . ... 43
Perform Post-Consolidation Tasks . . . . . . . . . . . . . . . . e 45
Troubleshooting the Server Consolidation Utility 47

A Changing the Server’s Code Page 51
Install a NetWare Server with Regional Support . . . . . . . . . . . . . . . e 51
Convert an Existing NetWare Serverto a Foreign Code Page. . . . . . . . . . . . . . .. ... .. ... . ..... 52
Verifying the Current Code Page ona NetWare Server . . . . . . . . . . . . . . . . . . it 53

Contents 5



Novell Server Consolidation Utility 3.0 Administration Guide



About This Guide

This guide describes how to use the Novell® Server Consolidation Utility to copy data from one
location to another location on your NetWare® network. The guide is intended for network
administrators and is divided into the following sections:

+ Chapter 1, “Overview,” on page 9 explains the capabilities of the Server Consolidation Utility.

¢ Chapter 2, “Installing the Server Consolidation Utility,” on page 13 explains the prerequisites
and instructions for installing the Server Consolidation Utility.

¢ Chapter 3, “Consolidating Data From NetWare,” on page 17 provides instructions for
consolidating data and moving printers from NetWare to NetWare using the Server
Consolidation Utility.

¢ Chapter 4, “Consolidating Data from Windows NT,” on page 37 provides instructions for
consolidating data from Windows* NT* to NetWare using the Server Consolidation Utility.

* “Troubleshooting the Server Consolidation Utility” on page 47 provides solutions for
resolving errors encountered during the consolidation process.

* Appendix A, “Changing the Server’s Code Page,” on page 51 provides instructions for
changing the code page on your source and destination servers, if necessary.

Documentation Updates

For the most recent version of the Novell Server Consolidation Utility Administration Guide, see
the Novell Product Documentation Web site (http://www.novell.com/documentation/
servercon30).

Documentation Conventions

In this documentation, a greater-than symbol (>) is used to separate actions within a step and items
in a cross-reference path.

Also, a trademark symbol (¥, ™, etc.) denotes a Novell trademark. An asterisk (*) denotes a third-
party trademark.

When a single pathname can be written with a backslash for some platforms or a forward slash for
other platforms, the pathname is presented with a backslash. Users of platforms that require a
forward slash, such as UNIX*, should use forward slashes as required by your software.
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Additional Documentation

A video demo is available to walk users through the basics of running the Server Consolidation
Utility. To view the video (Macromedia* Flash* Player required), point your browser to this URL
(http://www.novell.com/documentation/servercon26/download/SCU-Demo.swf).

To download the demo, use this link (http://www.novell.com/documentation/servercon26/
download/SCU-Demo.zip).

NOTE: This video is best viewed at a screen resolution of 1024 x 768 or higher. If your screen resolution is
set at 1024 x 728, view the video in full screen mode for best results.

Novell Education offers a variety of courses that help you maximize your investment in NetWare.
For course descriptions, details, and locations of training events, visit the Novell Education Web
site (http://www.novell.com/education/netware6).
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What’s New

Overview

Novell® Server Consolidation Utility 3.0 helps you consolidate data and reorganize your network
by moving data from any number of NetWare volumes (or directories within volumes) to another
NetWare 5.1, 6.0, or 6.5 server; to a NetWare Cluster/SAN; or to multiple NetWare 6.0 or 6.5
servers. This cuts down on the number of servers you have to manage and simplifies the
administration of your network.

In each case, the accompanying rights, trustees, ownership, and name space information are copied
along with the files to the destination server. The utility also copies many user attributes from one
tree to another.

NOTE: If you want to migrate data from old hardware that is being replaced, use the Migration Wizard Utility
thatis available at Novell’s product download site (http://download.novell.com/pages/PublicSearch.jsp). Select
the “Search by Product” radio button, and select NetWare Migration Wizard from the “Choose a Product” drop-
down list.

This section describes what’s new in this release, what the Server Consolidation Utility is, how it
works, and how you can use it to consolidate your data.

Server Consolidation Utility 3.0 adds two new features to those that existed in previous versions:

+ A new command line option is available for scheduling the utility to run at a predetermined
date and time. Adding an N after the passwords instructs the utility to skip the Error and
Success Log review dialog and simply exit the application after it finishes.

+ Novell ZENworks® 6.5 now creates an NT Roaming Profile directory the first time an NT
user logs into his or her eDirectory account on NetWare. The time-consuming process of
having the Server Consolidation Utility copy the NT Profile directory is no longer needed and
has been removed.

New features in version 2.6 let you:
+ Exclude specific file types or filenames from the copy process
For example, copy all of the data from a volume except for any .mp3 files.

+ Automatically compare file information between the source and destination after the copy
process completes to validate the integrity of the file copy

This includes the option of doing a detailed binary (byte-by-byte) comparison.
¢ Check for sufficient disk space on the destination server before beginning the file copy
¢ Disable login on the source server during the copy process

+ Specify a default server and home directory path for any new users you create on the
destination server

+ Copy an expanded list of user attributes when creating users

Overview 9


http://download.novell.com/pages/PublicSearch.jsp

With version 2.0, you could copy volumes and specific directories between different eDirectory
trees, as well as consolidate to NetWare 6.5. Version 2.0 also let you:

+ Copy data from NT* 4.0 Domains to NetWare

+ Schedule projects and run them completely unattended

+ Filter the files you want to copy based on date

¢ Add users to Novell eDirectory on the destination tree if they don’t already exist

¢ Copy data to the Novell Nterprise™ Branch Office™ Appliance

With NetWare Server Consolidation Utility version 1.0, you could copy entire volumes and
specific directories between NetWare 4, NetWare 5, and NetWare 6 servers in the same
eDirectory™ tree.

Benefits of Using the Server Consolidation Utility

10

The benefits the Novell Server Consolidation Utility 3.0 provides can be better understood through
examining two consolidation scenarios.

In the first scenario, suppose you have three existing NetWare 5 servers. You recently purchased
a multiprocessor server that you want to make a NetWare 6.5 server. You want to migrate the data
from each of the three servers to the single NetWare 6.5 server. Rather than manually moving all
the data and Printer Agents, or backing up the data on each of the three servers and then restoring
it to the NetWare 6.5 server, you can use the Server Consolidation Utility to automate the data
migration process.

The following figure shows how this consolidation scenario might look.

Figure 1 Multiprocessor Server Consolidation
o5 eDirectory Tree
( )
Server 1 Server 2 Server 3 MP Server
Data
Volumes

Data Migration

In the second scenario, suppose you have five existing NetWare 5 servers. You recently purchased
two multiprocessor servers and the necessary hardware to create a two-node cluster complete with
an attached Storage Area Network (SAN). You have decided to install NetWare 6.5 on the two-
node cluster because NetWare 6.5 is fully multiprocessor enabled and comes with Novell Cluster
Services™ software and a two-node cluster license. You want to migrate the data from each of the
five servers to the SAN on the two-node cluster. Rather than manually moving all the data and
Printer Agents or backing up the data and restoring it to the SAN, you can use the Novell Server
Consolidation Utility, which automates the data migration process.
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The following figure shows how this consolidation scenario might look.

Figure 2 Cluster Server Consolidation

eDirectory Tree
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Cluster Cluster
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TEyys

Data Migration

Shared Disk
System

What’s Next

See Chapter 2, “Installing the Server Consolidation Utility,” on page 13 for instructions on how to
install the Server Consolidation Utility on a Windows workstation.
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Installing the Server Consolidation Utility

The Novell® Server Consolidation Utility helps you consolidate data from several servers onto
fewer servers, so you have fewer servers to manage.

To set up the utility, complete the tasks in the following sections:

* “Meeting System and Software Requirements” on page 13

+ “Installing the Software” on page 15

Meeting System and Software Requirements

The Server Consolidation Utility runs on a Windows workstation and lets you copy files to
different servers and reassign printer agents to different locations either in the same eDirectory™
tree or between different eDirectory trees.

Workstation Requirements

a

O

A Windows* 2000 (with Service Pack 2 or later) or Windows XP Professional Edition
workstation with 50 MB of available disk space.

The Server Consolidation Utility does not work with Windows XP Home Edition, Windows
NT, or Windows 95/98.

Novell Client™ software installed and connected to the network.

You must be logged in to the network with Supervisor rights to both the source and destination
servers.

Windows 2000/XP workstations must be running Novell Client for Windows NT/2000/XP
version 4.9 Support Pack 2 or later.

To check the Novell Client version, right-click the N icon on the workstation toolbar, then
click Novell Client Properties > Client. To download the latest client, see the Novell Software
Downloads site (http://download.novell.com).

(If copying data from NetWare 4) The IPX™ protocol running on the Novell Client
workstation.

The source and destination server running on the same LAN segment for best performance.
Microsoft Data Access Components (MDAC) 2.8 installed on the workstation.

If MDAC 2.8 is not installed on your workstation, it can be downloaded from
www.microsoft.com/downloads.

Installing the Server Consolidation Utility 13
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Server Requirements

14

d
a

a

Destination server running NetWare 5.1 or later.
Source server running NetWare 4.10 or later, or Windows NT 4.0 with Support Pack 6 or later.

To copy data from NetWare 3 servers, use the NetWare Migration Wizard 6.5, which is
available for free at the Novell Software Downloads site (http://download.novell.com).

The Supervisor right to both the source server and the destination server.
Use ConsoleOne® to verify that you have the Supervisor right to both servers.
The latest NetWare Support Packs on both the source and destination servers.

Updates are available for specific NetWare versions at the Consolidated Support Pack home
page (http://support.novell.com/tools/csp).

(If copying data from NetWare 4.10, 4.11 or 4.2) Each volume to be copied running long name
space support.

To add long name space support to a NetWare 4.10 volume, enter at the server console LOAD
OS2 .NAMand then ADD NAME SPACE OS2 volume_name Replace volume_name with
the name of the NetWare 4.10 volume.

To add long name space support to a NetWare 4.11 or 4.2 volume, enter at the server console
LOAD LONG.NAMand then ADD NAME SPACE LONG volume name Replace
volume _name with the name of the NetWare 4.11 or 4.2 volume.

A backup of eDirectory.

For information on creating a backup of eDirectory, see Backing Up and Restoring Novell
eDirectory (http://www.novell.com/documentation/lg/edir873/edir873/data/a2n4mb6.html)
in the Novell eDirectory 8.7.3 Administration Guide.

The same code page for both the source and destination servers.

IMPORTANT: If both servers don’t have the same code page, data will be lost during the consolidation.
For instructions on changing your server’s codepage, see Appendix A, “Changing the Server’'s Code
Page,” on page 51.

On a NetWare 4 source server, the SET parameter Convert Compressed to Uncompressed
Option=0.

Setting the option to 0 leaves compressed files compressed when they are accessed. This
prevents compressed files from uncompressing and taking up all of your destination server’s
disk space when they are accessed. Setting the option to 1 changes compressed files to
uncompressed on second access, and setting the option to 2 always changes compressed files
to the uncompressed version.

To view your server’s current Convert Compressed to Uncompressed Option SET parameter,
execute the SET command at the server console prompt, select the File System category, and
page through the information until you see Convert Compressed to Uncompressed Option.

To change your server’s Convert Compressed to Uncompressed Option to 0, enter SET
Convert Compressed to Uncompressed Option=0 atthe server console prompt.

IMPORTANT: When using the Server Consolidation Utility to copy data from a compressed volume to
an uncompressed volume, ensure the server has enough space left in the volume to accommodate the
uncompressed data.

Decompression requires some disk space to decompress the file and back it up. Having a small amount
of space left on the system might result in a server abend or unwanted behavior in the file system.

The latest smdr.nlm and tsa.nlm loaded.

Novell Server Consolidation Utility 3.0 Administration Guide
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U (If copying data from NetWare 4) The source and destination servers must see each other via
IPX. For information on verifying IPX communication between servers, see the
troubleshooting section’s “Errors When Connecting to a NetWare 4 Server” on page 49.

After meeting the system and software requirements, you can install the software and run the
program.

Installing the Software

The Novell Server Consolidation Utility is located on NetWare 6.5 CD 1 (Operating System) in the
products\servcons directory.

The latest version can be downloaded from the Novell Product Downloads Web site (http://
download.novell.com).

Expand the utility and install it on a workstation by double-clicking the nwsc.exe file and
following the on-screen installation instructions.

TIP: There are some known issues with Java and certain video cards that cause the Server Consolidation
Utility installation to quit after extracting. If you encounter this issue, update your graphic card drivers to the
latest version, or disable the hardware acceleration for your graphics card.

What’s Next

If you are consolidating data within a NetWare or Nterprise Branch Office environment, go to
Chapter 3, “Consolidating Data From NetWare,” on page 17.

If you are consolidating data from a Windows NT environment to NetWare, go to Chapter 4,
“Consolidating Data from Windows NT,” on page 37.

Installing the Server Consolidation Utility 15
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Consolidating Data From NetWare

The Server Consolidation Utility is a Windows program that is launched from the Start menu.

To launch the utility, click Start > Programs > Novell Server Consolidation Utility > Novell Server
Consolidation Utility. Then complete the following tasks:

1. Create a Project File (page 18).

2. Select a Source and Destination Tree (page 19).

3. Select Volumes, Directories, and Printer Agents (page 19).
4. Perform Pre-Copy Verifications (page 21).

5. Resolve Errors (page 25).

6. Start the Consolidation (page 33).

The Server Consolidation Utility has a helpful interface that guides you through each step of the
process.

In addition, this chapter contains information on the following optional tasks:
1. Schedule a Consolidation Project (page 33).
2. Consolidate to or from a NetWare 5.1 Cluster (page 34).

Consolidation Issues

There are certain rules that you should be aware of when copying files or moving Printer Agents.
+ Open files cannot be copied.

There is one exception to this rule. NSS has a feature called File Copy on Write. This permits
a file that is being changed to be accessed in the same state as it was in when it was last closed
by all processes.

This feature is enabled on an NSS volume either by using ConsoleOne® or entering
nss /filecopyonwrite=volname

at the server console to change the volume attributes. For example, nss /
filecopyonwrite=voll would enable File Copy on Write for the voll: volume. The
effect is immediate, but it affects only files that are currently closed and then opened later.

¢ Ifyourun a Server Consolidation Utility project involving a NetWare® cluster and the cluster
fails over during the consolidation, the file copy will stop. The Server Consolidation Utility
project must be run again.

+ Printer Agents can be moved, print queues cannot.

+ Printer Agents that are moved still use the same Print Broker.

Consolidating Data From NetWare 17



+ Printer Agents can be moved only within the same tree. They cannot be moved between
different trees.

+ Print Services Managers must be operational.

+ After moving Printer Agents from the source to the destination server, unload the source Print
Services Manager so the migrated Printer Agents can establish a connection to the destination
Print Services Manager.

TIP: After unloading the source Print Services Manager, send a test print job to the printer that was
moved. This ensures that communication with the destination Print Services Manager is established.
After that communication has been established, the source Print Services Manager can be brought back
up.

* You might need to manually load or reload the appropriate tsa.nlm or smdr.nlm.

Create a Project File

18

The Server Consolidation Utility uses a project (.mdb) file to record your intended actions. The
actions are recorded so you can execute them now or save the project file and execute the actions
later.

The filename can be up to 64 characters long and can include any character except\ * ? <>|" /.

You have the option to:
1. Create a new project.
2. Open an existing project.

3. Open the last project you worked on.

To create a project file, complete the following steps:
1 In the Startup dialog box, click the radio button next to the selection you want.

2 Click OK.

3 (Conditional) If you choose to create a new project, you are prompted to select the source type.
The choices are:

¢ NetWare NDS/eDir Tree

¢ Microsoft* Windows Domain

3a In the Project Type dialog box, click the radio button next to the selection you want.
3b Click OK.

If you choose to create a new project, you are prompted to view the setup tasks for the utility
and to verify that you have met the requirements before continuing.

4 Click Next.

After performing the setup tasks for the utility, you must name the project and specify the
location on the workstation where the project file is to be stored.

5 Type a project filename in the field provided.

6 (Conditional) If you want to store the project file in a location other than the default location
provided, click Browse.

7 Click Next to select a source and destination tree.
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Select a Source and Destination Tree

After you create a project file, the Startup dialog box is displayed. The Server Consolidation Utility
allows you to move volumes, directories, and printer objects between servers in either the same
tree or between different trees. However, in order to do this, you must be logged in to the trees that
you will be working in.

1 Select the source and destination eDirectory™ (NDS®) tree from the drop-down list provided
or click Login to browse to a tree that is not in the drop-down list.

Only trees that you are currently logged in to are available on the drop-down list.
1a (Conditional) In the Novell Login dialog box, click Trees.
1b Browse to each desired tree and log in with the correct username and password.

If you do not know the tree name, in the Server field of the Login dialog box, type the IP
address or DNS name of the server that you will be consolidating to or from.

IMPORTANT: If you are performing a consolidation to an Nterprise Branch Office appliance, the
Admin user’s context is always appusers.

1c Click OK.
2 Click Next.

3 In the Startup dialog box, click Create to finish creating the project file.

Select Volumes, Directories, and Printer Agents

The Project Window (see Figure 3 on page 20) is where you select which volumes and directories
to copy and which Printer objects to move. The Project Window is divided into two panes that each
show the trees that you are working in.

You drag objects from the left pane and drop them into the right pane. You select volumes and
directories to copy to different servers, and Printer Agents to move to different Print Managers.

NOTE: The Server Consolidation Utility does not move Print Brokers or Print Managers. If you want to move
a Print Broker, you must first create a new broker on the target server, copy the contents to the new server
(perform the consolidation), and then delete the old broker. The Server Consolidation Utility only moves Printer
Agents, and only within the same tree.
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Figure 3 Project Window Post-Copy View
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Dragging and Dropping Volumes

When you drag-and-drop volumes into the right pane of the Project Window, a Volume Drop
Options dialog box displays. You must choose to either migrate the volume contents into the
directory or volume that you selected or create a new directory with the name of the volume that
is being moved.

1
2

Click the radio button next to the option you want.

Click OK.

Navigating the Project Window

In addition to dragging-and-dropping objects, you can perform several other tasks from the Project
Window menu:

*

*

Save project settings: Click File > Save As.
Move created and dropped objects around by dragging them to the desired location.

Create a new container or folder: Select the parent container or existing folder in the right
pane, then click Edit > New Folder.

Cancel a "dropped" action: Select the volume or directory in the right pane, then click Edit >
Back Out.

Rename a newly created container or folder: Select the parent container or existing folder in
the right pane, then click Edit > Rename.

Show where a folder or object went: Select the object in the left pane, then click Edit > Where
Did It Go. The directory or volume that was moved is highlighted in its new location in the
right pane.
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+ Show where a folder or object came from: Select the object in the right pane, then click Edit
> Where Did It Come From. The directory or volume that it came from is highlighted in the
left pane.

+ Show all folders or objects selected for copying: Select a container in the left pane, then click
Edit > Show Dropped Folders [or Show Dropped Printers].

TIP: The previous six tasks can also be performed by right-clicking the object to see the same menu
option.

+ View the available disk space prior to performing the verification by right-clicking the
destination volume in the right pane of the Project Window and then selecting Properties.
Right-clicking the source folder or volume in the left pane of the Project Window and then
selecting Properties displays the size of the source object.

Creating containers and dragging-and-dropping objects in the Project Window does not
immediately perform the action. It only creates a preview of where the files and objects will reside.
The actions are completed only after the verification process is complete and the copy process
begins.

Perform Pre-Copy Verifications

After you have dragged-and-dropped the selected directories or volumes and have performed any
other setup tasks, proceed by clicking Project > Verify and Copy Data or by clicking Do the
Consolidation on the button bar. The Verification Wizard displays.

Begin the Verification

1 Click Next to begin the verification process.

The Dropped Folders dialog box displays, showing the source path and destination path for
the dropped folders.

2 Do one of the following:
¢ If the source and destination paths are correct, click Next.

¢ If the source or destination path is incorrect, click Cancel and make the appropriate
changes in the Project window.

If you created new folders in the right pane of the Project window as part of your consolidation
project, the Created Folders dialog box now displays.

3 (Conditional) If prompted with the Create Folders dialog box, do one of the following:
¢ Ifthe destination path of the created folders is correct, click Next.

¢ Ifthe destination path is incorrect, click Cancel and make the appropriate changes in the
Project window.

The Duplicate File Resolution dialog box displays.

Resolve File Conflicts

If a file is found on the destination volume or directory that has the same name as a file being
copied from the source, you must decide what to do. You have three options to choose from on the
Duplicate File Resolution dialog box:

+ Don’t copy over existing files

The file on the source server is not copied and the file on the destination server is not replaced.
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+ Copy the source file if it is newer (Default)

If the file on the source server is newer than the one on the destination server, the file on the
destination server is replaced.

+ Always copy the source file

The file on the source server always replaces the file with the same name on the destination
server.

1 Click the radio button next to the option you want.

2 Click Next.

The Synchronize Files and Folders dialog box now displays.

Synchronize Files and Folders

In the Synchronize Files and Folders dialog box, you have the option to delete files and folders on
the destination server that do not exist on the source server. Selecting Yes deletes all files and
folders on the destination server that are not on the source server. No is the default selection.

1 Click the radio button next to the option you want.

2 Click Next.

The Compare Files and Folders dialog box now displays.

Compare Files and Folders

In the Compare Files and Folders dialog box, you have the option to compare files and folders
between the source and destination servers after the copy process completes. Selecting Yes
compares the following information between the source and destination files and folders:

¢ Names
+ Dates

* Sizes

*

Attributes
+ Trustees

¢ Owners

If you select Yes, you are given the option of doing a binary comparison of the files after the copy
process completes. A binary (byte-by-byte) comparison gives the greatest assurance that two files
are identical, but it takes longer to complete.

1 (Conditional) If you do not want to compare source and destination files after the copy
process, click the No radio button.

2 (Conditional) If you want to compare source and destination files after the copy process, click
the Yes radio button.

3 Ifyouselected Yes in the previous step and if you want to perform a binary comparison of the
files that were copied, check the Binary Comparison check box.

4 Click Next.

The File Date Filters dialog box now displays.
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Copy Files Based on Dates

In the File Date Filters dialog box, you have the option to copy files based on dates and three
separate attributes:

* Accessed
+ Modified
¢ Created

If No is selected in this dialog box, all files are copied. If Yes is selected, date ranges can be entered
for the file copy. You can select as many criteria as you would like, and only those files that meet
all of the selected criteria are copied.

Two dates can be set for each attribute. The first date is an On or After date and the second is an
On or Before date. For example, if you only check the On or Before check box and set the date for
November 10, 2000, for the Accessed attribute, only those files accessed on or before November
10, 2000, are copied. In the same example, if you also check the On or After check box and set the
date to October 1, 2000, only those files accessed on or after October 1, 2000, and on or before
November 10, 2000, are copied.

1 (Conditional) If you do not want to filter files based on dates, click the No radio button.
2 (Conditional) If you want to filter based on dates, do the following:
2a Click the Yes radio button.

2b Check any of the available check boxes for the desired combination of file types and
dates.

To change the date from the default provided, check the box next to the desired date. Next,
highlight with your mouse the portion of the date you want to change. Either type a new value
using the keyboard number pad, or use the mouse to click the Up-and Down-arrows provided
to the immediate right of the date field.

3 Click Next.

The Wildcard Selection dialog box now displays.

Wildcard Selection

In the Wildcard Selection dialog box, you have the option to exclude specific file types or file
names from the copy process.

A wildcard is a character that can be used to represent one or more characters in a search. The two
most commonly used wildcards are

¢ The question mark (?)
Used to represent a single alphanumeric character in a search expression.

For example, excluding the file te?t.txt would exclude tent.txt, test.txt, and text.txt from the
COpy process.

¢ The asterisk (*)

Used to specify zero or more alphanumeric characters in a search expression. For example,
excluding the file h*s.txt would exclude house.txt, his.txt, horses.txt, and happiness.txt from
the copy process.

1 Type the file extension types or filenames in the field provided. For multiple filenames or
types, press Enter between each entry. Wildcards (* ?) are permitted.
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For example, if you want to exclude a specific file named test.txt from being copied, type
test. txtinthe field provided. If you want to exclude all .mp3 files from being copied, type
* .mp3 in the field provided.

Type as many filenames or file extension types as you want. Separate the filenames or file
extensions by pressing Enter between each entry. Do not use spaces or commas to separate the
entries. See the following examples:

Correct:

* mp3

test.txt

* wav

Incorrect:

* mp3 test.txt *.wav
or

*.mp3, test.txt, *.wav

2 Click Next.

If you are performing a consolidation between servers in different trees, the Check for Trustees
and Ownerships dialog box now displays. If you are performing a consolidation between servers
in a single tree, proceed to “Verify Password” on page 23.

Check for Trustees and Ownership

When you copy data from one tree to another, the Server Consolidation Utility searches the
destination tree for trustees that match the source tree trustees of the copied data. Trustees that are
potential matches are displayed and can be matched up during “Match Up Tree Objects” on
page 26.

This check for trustees and ownerships must be performed the first time a consolidation is run. If
a consolidation is run a second time, this search does not need to be repeated, as long as trustees
have not been added to the source server and new directories or folders have not been dropped onto
the destination server. If either has happened, another search is necessary. This trustee and
ownership check slows down the verification process.

NOTE: If a file has already been copied to the destination server or tree, that file’s trustees are not updated

during the consolidation unless the source file’s date is more recent than the date on the destination file. The
Server Consolidation Utility reads the file date to determine what to copy, and adding trustees to a file does

not update the file date.

1 Click Browse to select the destination container you want to search.

2 Check the Search All Subordinate Containers check box to search all containers in the
destination tree below, and including, the one you selected.

Leaving the box unchecked searches only the selected destination container. For better
performance, limit the search to the container that you believe the object resides in. Searching
from Root takes significantly longer depending on the size of the destination tree.

3 Click Next.

If consolidating data to an Nterprise Branch Office appliance, there is not an option to specify the
container you want to search. Click the Yes or No radio button, then click Next.

The Password Verification dialog box now displays.
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Verify Password

1 In the Password Verification dialog box, enter the passwords for the source and destination
trees in the fields provided.

NOTE: SMS is the back up and copy engine used by the Server Consolidation Utility. You enter your
password here because SMS requires that the servers involved in the consolidation are authenticated to
each other.

2 Click Next.

The Novell Server Consolidation Verification dialog box now displays.

Check for Sufficient Disk Space and Disable Login

Before beginning to consolidate your data, you can verify that your destination volumes have
enough space to accommodate the data that will be moved. Verifying disk space can be a long
process if you have many files to copy.

You can also disable login on the source server before copying file data. Users already logged in
to the source server are not logged out, but no new logins are allowed until the consolidation
completes. If you disable login and the workstation running the consolidation project crashes for
any reason during the consolidation, you might have to manually re-enable login on the source
server console.

1 To verify the available space on the destination volumes, check the Check for Sufficient Disk
Space check box

2 To have the utility disable login on the source server prior to copying data, check the Disable
Login check box

3 To begin the verification prior to copying the files and moving the printers, click Next

During the verification process, you might see a message informing you that an updated tsa.nlm
or smdr.nlm must be copied for the consolidation to work. Click Yes to continue the project
verification. Clicking No stops the consolidation.

Resolve Errors

If there were errors discovered in the verification attempt, they will be shown in the Error
Resolution dialog box. Errors could include name conflicts, insufficient rights, required name
spaces not loaded, and insufficient disk space.

Errors found during the verification process are classified as follows:

@ Errors must be resolved before files can be copied.

& Errors should be resolved but might not affect the copy process.

In addition, the Error Resolution dialog box might display informational text classified as follows:
@ Information about the decisions you made in the Project Window.

A description of the error and a possible resolution appears in the Information text box. If no
resolution is provided, you can find more information in the Novell Error Code online
documentation (http://www.novell.com/documentation/lg/nwec/index.html). (Search the system
by error code number.)

After resolving any errors that exist, click Next. If there were no errors, warnings, or informational
text to display, and if you are moving objects from one tree to another, the Tree-to-Tree Object
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Match Up dialog box now displays. If you are not moving objects between trees, proceed to “Start
the Consolidation” on page 33.

Match Up Tree Objects

All trustees of copied data that appear in both the source and destination trees are displayed in the
Tree-to-Tree Object Match Up dialog box based on their category. These trustees are discovered
during the Check for Trustees and Ownership step on page 23.

This screen allows you to match the trustees found in the destination server with trustees from the
source server. If an appropriate match does not exist, you can create a user on the destination server
that matches the trustee on the source server. You can also browse to an existing user in the
destination tree and match it up with the source server trustee.

IMPORTANT: If you are consolidating to an Nterprise™ Branch Office™ Appliance, see “Server
Consolidation Utility and Novell Nterprise Branch Office” on page 28 now.

1 Select the type of objects to display from the drop-down list provided in the Tree-to-Tree
Object Match Up dialog box.

2 Check the check box to the left of the object you want to match up.

To select more than one object, press and hold the Ctrl key while checking the check box to
the left of the objects that you want to select. You can also check the check box to the left of
one object, press and hold the Shift key, then check the check box to the left of a second object
to select those two objects and all other objects located between them in the list.

The following attributes are copied for each selected user:
¢ Common Name

¢ Description

¢  E-mail Address

¢ Fax Number

¢ Full Name

¢ Generational Qualifier

¢ Given Name

¢ Initials

¢ Internet E-mail Address
¢+ Language

¢ Locality Name

¢ Lockout After Detection
¢ Login Allowed Time

¢ Login Disabled

¢ Login Expiration Time
¢ Login Grace Limit

¢ Login Grace Remaining
¢ Login Intruder Limit

¢ Login Maximum Simultaneous

26 Novell Server Consolidation Utility 3.0 Administration Guide



¢ Login Script

¢ Mailbox Location

¢ Network Address Restriction
¢ Organizational Name

¢ Organizational Unit Name

¢ Password Allow Change

¢ Password Expiration Interval
¢ Password Expiration Time

¢ Password Minimum Length
¢+ Password Required

¢ Password Unique Required

¢ Physical Delivery Office name
¢ Post Office Box

¢ Postal Address

¢ Postal Code

¢ State or Province Name

¢ Street Address

¢ Surname

¢ Telephone Number

+ Title

2a (Conditional) If you selected more than one object, right-click on the selected objects and
then click Create All Selected Objects.

2b (Optional) If you want to create objects for all of the selected objects, click the Yes radio
button.

2c¢c To select the container that the objects will be created in, click Browse.
2d Click OK.

2e To unmatch more than one object, select the desired objects, right-click the objects, and
then click Unmatch All Selected Objects.

From the drop-down menu under the Destination Object heading, select the option you want:
¢ The object in the destination tree that has the same name as the object in the source tree
¢ Don’t match (object doesn’t exist in the destination tree)

¢ Browse

¢  Create

(Conditional) If you selected Browse in Step 3, do the following in the Context Browser
dialog box:

4a Sclect a matching object.
4b Click OK.
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5 (Conditional) If you selected Create in Step 3, do the following in the Object Creation dialog
box:

Ba To browse to the container that the new object will be created in, click Browse.
Sb Sclect the container.

5S¢ Click OK.

8d Type the new object’s name in the field provided, then click OK.

5e Repeat Step 5d for each object you want to create.

NOTE: When the Server Consolidation Utility creates a new user, it assigns a random password to that
user. The username and the randomly assigned password are written to the success log. This log file can
be viewed after the consolidation completes.

The Server Consolidation Utility allows the user to create groups if they don't already exist in the
destination tree and it adds the users that are members of the source group to the new destination group.
However, it does not modify an existing group. If you use the utility to create a group in the destination
tree and then add additional members to the source tree’s group, those added members are not added
to the destination group. Also, if you choose to create the groups manually (on the destination) rather than
using the Server Consolidation Utility, and then you attempt to match up the groups during the
consolidation, the group members are not transferred.

6 When you have finished matching all the objects, click Next.

7 (Conditional) If you have unmatched objects, do one of the following in the Unmatched
Objects dialog box that displays:

¢ To proceed without matching the objects, click Yes.

¢ To go back and match up the objects before continuing, click No.

The Default Server and Home Directory for Created Users dialog box now displays. Proceed to
“Default Server and Home Directory for Created Users” on page 32.

Server Consolidation Utility and Novell Nterprise Branch Office

28

Novell® Nterprise™ Branch Office™ is a business office management solution that reduces the
costs and challenges of managing and using offices in remote locations. Novell Nterprise Branch
Office is appliance software that you can deploy on hardware at remote offices and still have the
flexibility to manage from one central location at your corporate offices. Administrators and users
access the features they need through the Internet from a Web browser.

Moving directories, volumes, or users and their associated trustees and rights to a new Novell
Nterprise Branch Office appliance is a daunting task made easier by the Server Consolidation
Utility. Moving information with the Server Consolidation Utility is faster and easier than
manually entering individual users, copying files, and manually assigning their rights and trustees
on a new Nterprise Branch Office appliance.

The Server Consolidation Utility works with Novell Nterprise Branch Office appliances in much
the same way it works with Novell NetWare servers. However, there are a few differences in the
way the Server Consolidation Utility runs in relation to Nterprise Branch Office. This section will
describe the following:

¢ Unlocking the Nterprise Branch Office Appliance (page 29)

¢ Binding [IPX When Consolidating from NetWare 4 (page 29)

+ Modifying the Hosts File (page 30)

+ Performing a Server Consolidation to a Novell Nterprise Branch Office Appliance (page 31)
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Unlocking the Nterprise Branch Office Appliance

In order to perform a consolidation to an Nterprise Branch Office appliance, you must be logged
in as Admin with supervisor rights to the appliance. The Branch Office appliance does not allow
supervisor rights for Admin unless the server is unlocked. When the server is unlocked, Admin is
granted supervisor rights and the consolidation can be run.

1 At the server console, log in by entering the Admin username and password.
2 Enter unlock.
3 When prompted, enter y for Yes.

4 To relock the server, at the server console enter 1lock.

Proceed to “Binding IPX When Consolidating from NetWare 4 on page 29.

Binding IPX When Consolidating from NetWare 4

Before running a consolidation project from a NetWare 4 server to an Nterprise Branch Office
appliance, you must first bind [IPX™ on the Nterprise Branch Office appliance and on the
workstation running the Server Consolidation Utility. Otherwise the consolidation will fail.

1 At the Nterprise Branch Office appliance server console, enter inetcfg.
Select Boards, then press Enter.

Press Insert.

Select the appropriate network interface, then press Enter.

Specify a board name and slot number, then press Esc.

Select Yes to save changes, then press Enter.

To return to the main Internetworking Configuration screen, press Esc.

Select Protocols, then press Enter.
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Select IPX, then press Enter.
10 Enable and configure IPX, then exit the INETCFG utility.

TIP: If you prefer, IPX can also be enabled on the server by adding the appropriate Load and Bind commands
to the server’s autoexec.ncf file.

Proceed to “Verifying IPX is Bound On the Client” on page 29.

Verifying IPX is Bound On the Client
1 Right-click on the red N in the system tray on your workstation.
2 Sclect Novell Client Properties.
3 Select the Protocol Preferences tab.
If the Protocol window displays both IP and IPX, the client has IPX bound.
If the Protocol window displays only IP, then IPX needs to be bound on the workstation.

Proceed to “Binding IPX on the Client” on page 29.

Binding IPX on the Client
1 Insert the Novell Clients Software CD (March 2003).

Consolidating Data From NetWare 29



2 Sclect the client version you want, then click Next.
3 Select the appropriate language, then click Next.
4 Seclect Custom, then click Next.

5 Click the radio button next to IP and IPX.

6 Click Next > Next > Finish.

Proceed to “Modifying the Hosts File”” on page 30.

Modifying the Hosts File

The Server Consolidation Utility connects the servers involved in a consolidation using one of two
methods, SLP or the sys:\etc\hosts file. Nterprise Branch Office does not configure SLP, so
consolidations to Nterprise Branch Office appliances must use information in the hosts file.

In order to successfully complete a consolidation, the sys:\etc\hosts file on the Nterprise Branch
Office appliance must contain the IP address and server name of the source servers involved in the
consolidation. This information must be manually input into the file before running the Server
Consolidation project.

IMPORTANT: The Nterprise Branch Office appliance reconfigures itself each time it is restarted. This causes
the sys:\etc\hosts file on the appliance to be rewritten each time it is restarted. If only one consolidation is being
run with an Nterprise Branch Office appliance, the hosts file needs to be modified only once to include the
source server’s I[P address and server name. However, if more than one consolidation is going to be run on
an Nterprise Branch Office appliance, and the appliance has been restarted since the last consolidation, the
hosts file must be modified each time the appliance is restarted.

On the Nterprise Branch Office Appliance
1 At the Nterprise Branch Office appliance’s server console, enter edit.
Press Insert.
Select sys:, then press Enter.
Select etc, then press Enter.

Select hosts, then press Enter > Enter.

O g b ON

Add to the file the IP address and server name of every source server involved in the
consolidation project.

Type the IP addresses and server names as xxx.xxx.xxx.xxx Server Name.
7 Save the file.

8 Run the consolidation project.

On the Client Workstation
1 Launch Windows Explorer.
2 Browse to the Nterprise Branch Office server.
3 Double-click the server name.
4 Double-click the sys: volume.
5 Double-click the etc directory.
6 Open the Hosts file with a text editor.
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7 Add to the file the IP address and server name of every source server involved in the
consolidation project.

Type the IP addresses and server names as xxx.xxx.xxx.xxx Server Name.
8 Save the file.

9 Run the consolidation project.

Proceed to “Performing a Server Consolidation to a Novell Nterprise Branch Office Appliance”
on page 31.

Performing a Server Consolidation to a Novell Nterprise Branch Office Appliance

When performing a consolidation to the Nterprise Branch Office appliance using the Server
Consolidation Utility, you will see several screens that are different from the ones displayed during
a consolidation on a regular NetWare server. The different screens that require navigation are
described below.

Match Up Tree Objects

The Tree-to-Tree Object Match Up screen displays. Any objects that appear in both the source and
destination trees are displayed based on their class. To match up objects in a consolidation
involving an Nterprise Branch Office appliance, complete the following steps:

1 Select the type of objects to display from the drop-down list provided.
2 Check the check box to the left of the object you want to match up.

To select more than one object, press and hold the Ctrl key while checking the check box to

the left of the objects that you want to select. You can also check the check box to the left of
one object, press and hold the Shift key, then check the check box to the left of a second object
to select those two objects and all other objects located between them in the list.

The following attributes are copied for each selected user:
¢ Department

¢ Description

¢ E-mail Address

¢ Fax Number

¢ Full Name

¢ Given Name

¢ Internet E-mail Address
¢ Location

¢ Postal Address

¢ Surname

¢ Telephone Number

¢ Title

¢ Unique IDs

2a (Conditional) If you selected more than one object, right-click the objects and then click
Create All Selected Objects.
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2b (Optional) If you want to create users for all of the selected users, click the Yes radio
button.

2c¢c From the drop-down list, select whether these will be Local Users or Remote Users.

2d Click OK.

From the drop-down menu under the Destination Object heading, select the option you want:
¢ The object in the destination tree that has the same name as the object in the source tree
¢ Don’t match (object doesn’t exist in the destination tree)

¢ Browse

¢ Create (if you are matching users)

(Conditional) If you selected Browse in Step 3, do the following in the Context Browser
dialog box:

4a Sclect a matching object.
4b Click OK.

(Conditional) If you selected Create in Step 3, do the following in the Object Creation dialog
box:

Sa From the drop-down list, select whether you want to create a Local User or Remote User.
Sb Type the new user’s name in the field provided, then click OK

B¢ Repeat Step 5a for each user you want to create.

When you have finished matching all the objects, click Next.

(Conditional) If you have unmatched objects, do one of the following in the Unmatched
Objects dialog box that displays:

¢ To proceed without matching the objects, click Yes.

¢ To go back and match up the objects before continuing, click No.

Proceed to “Default Server and Home Directory for Created Users” on page 32 to complete the
consolidation.

Default Server and Home Directory for Created Users

32

In the Default Server and Home Directory for Created Users dialog box, you have the option to
assign a default server for all created users. The default server is the server the user gets a
connection to during login if the user doesn't request a connection to a specific server. It’s also the
server used if the user makes a network request without naming the server, and it’s the server the
user still has an attachment to after logging out.

You can also assign a parent directory for any created user’s home directory. A home directory is
an optional, single-valued property that specifies the location (volume and path) and name for the
user’s working area on the server.

1 (Conditional) If you want to assign a default server for all created users, click the first Browse

button.

2 Select a server from the tree.

3 Click OK.
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4 (Conditional) If you want to assign a parent directory for any created user’s home directory,
click the second Browse button.

5 Select a directory from the tree.

6 Click OK > Next.

The Start Novell Server Consolidation Utility dialog box now displays.

Start the Consolidation

After selecting the objects to copy and resolving critical errors, you can now copy your files by
clicking Proceed in the Start Novell Server Consolidation Utility dialog box.

During the copy process, new folders and objects are created, files are copied, and Printer Agents
are moved to their destination (as specified in the right pane of the Project Window).

When the copy process is complete, a Process Finished screen displays that lets you
¢ View the error log.
+ View the success log.
¢ Close the Process Finished screen.

TIP: You can also view the error and success logs of any completed project from the Project Window by
opening the project file and clicking View > Error Log or View > Success Log, or by clicking the corresponding
button on the button bar.

If you interrupt the copy process before it completes, all objects, directories, and files already
copied to the destination server will remain there unless you manually delete them.

Schedule a Consolidation Project

The Server Consolidation Utility lets users schedule projects to run when they are most
convenient. This means that users can create a consolidation project during the day and schedule
it to run during the night when there is a smaller chance that files that are to be moved will be open
and being worked on.

The Server Consolidation Utility uses the Scheduled Tasks capability built into Windows to
schedule a consolidation project to run at a time that is most convenient to you.

TIP: Before scheduling a consolidation project we recommend that you complete the verification process and
resolve all errors. When you have verified the project, resolved any errors, and reached the Start Novell Server
Consolidation Utility dialog box described in “Start the Consolidation” on page 33, then the project can be
scheduled.

To schedule a project to run at a later time:
1 Ensure that a Server Consolidation Project has been created.
Write down the project name and path of its location for later reference.
2 Click Start > Settings > Control Panel.
3 Double-click the Scheduled Tasks icon.
4 Double-click the Add Scheduled Task icon.
5 When the Scheduled Task Wizard launches, click Next.
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Select the Novell NetWare Server Consolidation Utility from the list of programs provided,
then click Next.

Assign the scheduled task a name, select its frequency (in most cases, the preferred choice will
be One Time Only), then click Next.

Select the start time and date for the project to run, then click Next.

Enter the Windows username and password of the admin user that will perform the task, then
click Next.

Verify that the time displayed for running the project is correct. If it is, check the Open
Advanced Properties for This Task When I Click Finish check box, then click Finish.

After the Advanced Properties dialog box opens, click Task.
In the dialog box that opens, complete the Run field.

The dialog box is populated with a pathname that ends in \fc.exe. Add the following
parameters, separated by a single space, to this pathname for the scheduled consolidation
project to run:

¢ (Required) The pathname, in quotation marks, to the consolidation project that you are
scheduling to run. For example:

"c:\my projects\sc1.mdb" (where sc1.mdb is the saved project)
¢ (Required) The letter Y, to automatically run the selected Server Consolidation project.
¢ (Required) The password for the admin on the source server.
¢ (Required) The password for the admin on the destination server.

¢ (Optional) The letter N, to skip the Error and Success Log review dialog and simply exit
the utility after it finishes.

When completed, the Run field of the Advanced Properties dialog box should look similar to
this:

c:\program files\novell\netware server consolidation utility\fc.exe "c:\my projects\scl.mdb" y
test] test2

In the previous example, c:\program files\novell\netware server consolidation utility\fc.exe is
the pathname that was already in the Run: field of the dialog box, "c:\my projects\sc1.mdb" is
the saved project that is scheduled to run, y is the Yes parameter to automatically run the
project, testl is the admin password on the source server, and test 2 is the admin password on
the destination server.

After entering the parameters, click OK.

In the dialog box that appears, enter the Windows username and password of the admin
running the project, then click OK.

The Server Consolidation project will run at the scheduled time.

Consolidate to or from a NetWare 5.1 Cluster

34

When a volume is cluster enabled, an object is created in eDirectory with the name of the cluster
followed by an underscore followed by the volume name. For example, clusterl voll. For the

Server Consolidation Utility to function properly with a NetWare 5.1 cluster-enabled volume, the
server name followed by an underscore followed by the Volume Name object must be used in the

Project Window instead. For example, serverl voll.
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This substitution can be accomplished by completing the following steps:
1 Start ConsoleOne, and browse to the context where the NCP™ Server object resides.

2 Right-click the right pane, select NEW/Volume, then type the name of the new object in the
first field.

This should be the server name followed by an underscore followed by the volume name.
3 In the second field, browse and select the appropriate server.
4 In the third field, select the volume from the drop-down menu, then click OK.

5 In the Server Consolidation Utility Project Window, refresh the container where the Volume
object is located to make the new object appear.

6 When dragging-and-dropping in the project window, use the newly created Volume object.

If you use the clustername_volumename object instead of creating and using the new Volume
object, a critical SMDR error will occur and you won’t be able to complete the consolidation
process.

7 After the consolidation is complete, you can delete the newly created Volume object.
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Consolidating Data from Windows NT

The Novell® Server Consolidation Utility automates key tasks, such as migrating users and their
file permissions, assigning passwords, and migrating the NT* file system to a designated
eDirectory™ tree. This automation eliminates the need to choose from various utilities that would
help you perform these tasks individually.

Although many tasks are automated in the Server Consolidation Utility, you should consider the
following issues before you get started.

Plan your consolidation by answering the following questions:

U Which NT users are accessing which NT files and directories, and where are those files and
directories located?

This information will help you decide which NT servers to migrate first and how many servers
you will need to migrate at one time. When you migrate your users and groups, you will want
to migrate all files and directories that they have access to at the same time that you migrate
their User objects.

QO Which NetWare® servers and volumes are you going to migrate your NT folders to?

You should plan which servers and volumes in your destination eDirectory tree will receive
each of your NT folders. You can select a separate location for each NT folder, if desired. In
order to plan effectively, you will need to become familiar with the file structure on the
NetWare servers in your destination eDirectory tree.

U Which NT users and groups am I going to migrate? Which eDirectory containers on the
destination eDirectory tree am I going to migrate them into?

Decide which NT user and groups you are going to migrate, then determine whether you will
need to create separate containers for your NT users and groups in the destination eDirectory
tree. When you model your migration in the Project Window, you can create any additional
eDirectory containers you might need by right-clicking an eDirectory Organizational Unit.

U Do any existing eDirectory User objects represent the same person in my NT domain?

Determine whether any of your NT users already have an eDirectory account. During the
migration you will be asked if you want to search the eDirectory tree for duplicate usernames.
When the Server Consolidation Utility finds identical usernames, it will display these in a
table where you can choose to merge the listed NT user with an eDirectory User object.

U What will T do with any applications that do not run on NetWare?

The Server Consolidation Utility does not migrate applications. After the migration, you will
have to reinstall your applications. If you have some applications that do not run on NetWare,
you can keep an NT server intact and use it as an application server.

U How do I want to migrate information about my users and groups? Do I want to use a
Template object?

For information, see “Create a Template Object” on page 38.
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U Do I have any trusted domains?

If so, you must reassign any trusted domain permissions to the appropriate NT user and groups
after the migration is complete. Use ConsoleOne® to reassign all lost trusted domain
permissions.

When you have planned your migration, you’re ready to begin your NT migration. Complete the
following tasks in the order they are listed.

1. Meet System and Software Requirements (page 38).

Perform Prerequisite Tasks (page 38).

Run Server Consolidation (page 39).

Model Your Consolidation Project (page 41).

Verify Your Consolidation Project (page 42).

Migrate Users and Data to the Destination eDirectory Tree (page 43).

NS kWD

Perform Post-Consolidation Tasks (page 45).

Meet System and Software Requirements

You can run the Novell Server Consolidation Utility from a Windows NT 4 server or a Windows
NT 4, Windows 2000, or Windows XP Professional Edition workstation.

Make sure you have the following NT permissions:
¢ Write/Modify permission to the NT Domain and the Registry of the PDC

+ Read permission to all folders and files you are migrating
Log in to the NT domain as a user that has administrative rights to the Domain.

The following table lists the hardware and software requirements for the workstation that you are
using to run Server Consolidation.

Platform Hardware Software

Windows NT/2000/XP Minimum hardware Novell Client™ for

workstations requirements of Windows NT/2000/XP
Windows NT/2000/XP version 4.91 SP2 or
workstations later

To check your current Novell Client version, right-click the N icon on your workstation and then
click Novell Client Properties > Client. To download the Novell Client, see the Novell Product
Downloads (http://download.novell.com) Web site.

Continue with the next section, “Perform Prerequisite Tasks” on page 38.

Perform Prerequisite Tasks
Create a Template Object

The first prerequisite task is to determine whether you want to use a Template object to migrate
your NT users to the destination eDirectory tree.
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A Template object defines additional eDirectory User attributes for NT users during the migration.
We recommend that you use a Template object because it is an organized way to migrate your NT
users to the eDirectory tree and manage them after they are there.

IMPORTANT: In order to migrate home directories, you must use a Template object.

If there is a conflict between the properties of a Template object and an NT policy, the properties
of the Template object will, in most cases, take priority. For example, if a minimum password
length of seven characters is specified for user Jeff in an NT policy and a minimum password
length of nine characters is specified in the Template object, then when Jeff’s object is migrated,
the object will be created in eDirectory with a password length of nine characters.

If you want to know what additional eDirectory attributes can be defined in a Template object, run
ConsoleOne and double-click a Template object to view all of the existing properties.

The last name, full name, and description of every NT object is always migrated and these
corresponding properties from the Template object are overwritten.

If you decide to use a Template object, you can create one in ConsoleOne by clicking File > New
> Object > Template.

Register the Workstation

If you are not running the Server Consolidation Utility from the NT server, make sure that the
workstation running the Server Consolidation Utility is registered within the domain that you want
to migrate. If it is registered properly, continue with “Run Server Consolidation” on page 39.

If you want to change the domain that your workstation is registered in, complete the following
instructions for Windows NT or Windows 2000.

Windows NT Workstations
1 At the workstation, right-click Network Neighborhood and then click Properties.
2 Click the Identification tab, then click Change > Domain.
3 Specify the appropriate domain, type your Administrator name and password, then click OK.

4 Reboot the workstation and launch the Server Consolidation Utility again; then continue with
the next section, Run Server Consolidation.

Windows 2000 Workstations
1 At the workstation, right-click My Network Places and then click Properties.
2 Click the Network Identification link.
3 Click Properties, specify the computer name and appropriate domain, then click OK.

4 Reboot the workstation and launch the Server Consolidation Utility again; then continue with
the next section, Run Server Consolidation.

Run Server Consolidation

1 Launch the Server Consolidation Utility by clicking Start > Programs > Novell Server
Consolidation Utility > Novell Server Consolidation Utility.

2 Click Create a New Project > OK.
3 Click Microsoft Windows Domain > OK.
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Click the View Online Documentation button.

This launches your default Web browser and takes you to the NetWare Server Consolidation
Utility online documentation.

5 Make sure you have completed the system and software requirements in “Meet System and

Software Requirements” on page 38 of the online documentation. Then close your browser.

6 Click Next.

Name your consolidation project, select a place to save it, then click Next.

By default, the Server Consolidation Utility saves your project in c:\Program
Files\Novell\NetWare Server Consolidation Utility.

Verify that the NT domain that appears in the grayed-out text field is the domain that you want
to migrate.

The Server Consolidation Utility automatically displays the NT domain that your workstation
or server is a member of.

You can change the domain that the workstation running the utility is registered in. To do this,
exit the utility and follow the instructions in “Register the Workstation” on page 39.

Select your destination eDirectory tree from the drop-down list, then click Next.
The destination eDirectory tree is the eDirectory tree that you want to migrate your NT data to.

If you are not logged in to your eDirectory tree, the eDirectory tree name will not appear in
the drop-down list. If this is the case, click the Browse button to log in to your eDirectory tree.
After you are logged in, the eDirectory tree name automatically appears in the drop-down list.

10 Decide whether you want Server Consolidation to find any User objects in your NT domain

11

and in the destination eDirectory tree that have the same name, click Yes or No, then click
Next.

To create and save your consolidation project, click Create.

When a project is created and saved, the Server Consolidation Utility creates a file that
contains the success and error logs of your project; these logs contain the details of what took
place during the consolidation.

12 (Conditional) If you clicked Yes in Step 10, continue with Step 12a. If you clicked No, skip

the rest of the steps in this procedure and go to “Model Your Consolidation Project” on
page 41.

12a To select an eDirectory container on the destination eDirectory tree, click the Browse
button.

12b Browse the tree and select an eDirectory container, then click OK.

12¢ To begin searching for duplicate usernames, click Next.

12d Decide what you want to do with NT users that have the same name as eDirectory users.
You have the following options for each listed NT user:

¢ Merge the NT user with the displayed eDirectory user. Simply leave that user as it is
displayed in the table and continue with the next listed NT user.

¢ Merge an NT user with a different eDirectory user. Click the arrow by the eDirectory
username to view a drop-down list containing all the eDirectory users that have the
same username (including contexts) as this NT user. Select one of the eDirectory
names and continue with the next listed NT user.
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¢ Do not merge the NT user with any of the matching eDirectory users. Click the arrow
by the eDirectory username to view a drop-down list, then select Don’t Merge. Select
this option only if you know that none of the listed eDirectory users represents the
same person as the adjacent NT user.

12e After you have made a decision for each listed NT user, click Finish.

The Project Window will now appear and the NT users that you chose to merge with
eDirectory User objects appear automatically as dropped objects in the destination
eDirectory tree.

Continue with the next section, “Model Your Consolidation Project” on page 41.

Model Your Consolidation Project

Most of your work will be done in the Project Window, where you can drag-and-drop NT User and
Group objects into eDirectory containers, and NT folders into any volume or folder in the
destination eDirectory tree.

The Project Window is a place to model different migration scenarios before you begin the actual
migration without affecting your NT domain or your destination eDirectory tree. All of the
planning in the Project Window is done offline, meaning that items moved and created in the
Project Window are not actually moved or created until you begin the migration.

TIP: For information on shared NT folders that end with a dollar sign ($), click anywhere on your Windows
desktop, press F1, click the Index tab, then type $shares in the keyword text field.

The Project Window and the Using the Project Window dialog box appear after you have created
the consolidation project.

The three basic steps outlined in this dialog box should be performed for each consolidation
project. When you are familiar with the tasks that you will be performing, click Close to access the
Project Window and begin modeling your migration project.

Using the Project Window

Review the following tips to help you organize your migration project and use the Project Window
more effectively.

+ Dragging-and-Dropping the NT Domain Info object—To perform a consolidation from an
NT domain, you must drag-and-drop the NT Domain Info object from the left pane of the
Project Window to an eDirectory container in the right pane of the Project Window.

¢ Creating a New eDirectory Organizational Unit or Folder—To create a new eDirectory
Organizational Unit (OU), right-click the parent eDirectory Organizational Unit or folder and
then click New Organizational Unit or New Folder.

You can create new eDirectory OUs in the eDirectory tree and then migrate your NT
information to those OUs. This keeps the NT information organized and in one place in the
eDirectory tree. You can also choose to migrate the NT data to existing OUs; just remember
that you can always create a new OU in the eDirectory tree if you need to.

If you add new containers or names to the destination tree, the names you choose must adhere
to the following eDirectory naming conventions:

+ Names must be unique. For example, Debra Jones and Daniel Jones cannot both be
named DJONES if they are in the same container.
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+ The following special characters are allowed only if they are preceded by a backslash (\):
plus sign (+), equal sign (=), and period (.).

+ Uppercase and lowercase letters, underscores (_), and spaces are not acknowledged by
eDirectory. For example, Manager Profile and MANAGER PROFILE are considered
identical names in eDirectory.

+ Setting the Context—To set the context, right-click an eDirectory Organizational Unit and
then click Set Context.

When you set the context, you can designate what part of the eDirectory tree will appear in
the right side of the Project Window. This is useful if you have a large eDirectory tree with
many objects.

Setting the context at a specific container will eliminate the need to scroll down or collapse
objects in your eDirectory tree. Once the context is set, this container will appear as the top
object in the right side of the Project Window.

+ Viewing a Description of the Objects in the Project Window—To see a short description
of what an icon represents in the Project Window, right-click an eDirectory object and then
click What’s This?

+ Backing Out a Dropped Object—To return a dropped object to its original position, right-
click a dropped NT object in the NT domain or the destination eDirectory tree and then click
Back Out Dropped Object.

¢ Finding Out Where a Dropped NT Object Came From—To find out where a dropped
object was located in the NT domain, right-click an NT object and then click Where Did It
Come From? When dragging-and-dropping objects, this will help you remember where a
dropped object was previously located in the NT domain.

When you are satisfied with where you have dropped your NT folders, users, and groups in the
eDirectory tree, verify your consolidation project to resolve any potential problems before
migrating your NT data.

Continue with the next section, “Verify Your Consolidation Project” on page 42.

Verify Your Consolidation Project

42

After you have modeled your consolidation in the Project Window, you should verify that the
proposed locations for these new objects do not conflict with existing names, rights, name spaces,
etc., in the eDirectory tree.

Remember, dragged-and-dropped items appearing in the eDirectory tree are merely assigned to be
copied to that area in the eDirectory tree. Objects will not actually be copied until you begin the
consolidation process.

Because a similar verification process is run when you begin the actual NT migration, running the
standalone verification process prior to migration is not mandatory; however, catching any critical
errors or warnings now will speed up the verification process during the migration.

You must resolve all critical errors before you begin to actually migrate your migration project.
Warnings can be resolved after the migration.
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Migrate Users and Data to the Destination eDirectory Tree

Although you have selected the volumes and containers where the NT data will be copied, no data
has yet been migrated. When migrated, NT User objects are converted to eDirectory objects and
placed in the destination eDirectory tree.

1 From the Server Consolidation Utility toolbar, click Project > Verify and Copy Data or click
the Do the Consolidation button on the toolbar, and then click Next.

2 Read the Welcome screen, then click Next.

3 If you want to apply a Template object to newly created eDirectory users, browse the tree,
select the Template object from the tree view, and then click Next.

If you do not want to use a Template object, uncheck the check box and click Next.

To migrate home directories, you must use a Template object when migrating your NT users
to the destination eDirectory tree. Make sure a Home Directory property is defined for the
Template object you are using.

TIP: If you have not created a Template object but you want to use one now, save the project, go to
ConsoleOne®, and create the Template object. Next, run the Server Consolidation Utility again and click
Open Last Project. Then restart this migration procedure again starting with Step 1.

4 Decide how you want to handle any duplicate filenames between the Windows NT domain
and the destination eDirectory tree, select one of the following, then click Next:

¢+ Don’t Copy Over Existing Files—The file on the source server is not copied and the file
on the destination server is not replaced.

¢ Copy the Source File If It Is Newer—If the file on the source server is newer than the
one on the destination server, the file on the destination server is replaced.

¢ Always Copy the Source File—The file on the source server always replaces the file
with the same name on the destination server.

8 Decide how you want to handle passwords for your NT users, select one of the following, then
click Next:

¢ Assign the Same Password to All Users—The utility will assign the same password to
all migrated users.

¢ Assign a Randomly Generated Password to All Users—The utility will randomly
generate passwords, assign them, and then store the passwords it assigns in a file that it
creates, named project_name_out.txt. This file is saved in the same directory where your
consolidation project is located.

¢+ Read Passwords from a File—The utility will migrate the current NT passwords to the
destination eDirectory tree by reading them from a text file. You must create the text file
containing the NT passwords before you begin the migration.

For more information on how to create this file, click the Help button.

6 Sect NT migration options by checking or unchecking the check boxes next to the following
options and then click Next:

¢ Copy File Permissions—Normally, the utility migrates file and directory permissions.
If, for some reason, you want to reassign file and directory permissions, you can choose
to not copy the file and directory permissions here and then assign them later with
ConsoleOne.
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10

11

12

¢+ Copy Everyone Permissions—The eDirectory container that you drop the NT Domain
Info object into will be assigned the permissions that were associated with group
Everyone. If you are migrating the Everyone permissions, be sure to drop the NT Domain
Info object high enough in the eDirectory tree so that all NT users will inherit those
permissions.

TIP: Every new folder that is created in the NT domain automatically receives the Everyone
permissions by default.

¢ Restart Option—Normally, this information is not erased; however, if you have
previously run a consolidation program and deleted the eDirectory objects from the
destination tree, and you are planning to start over and migrate the same domain again,
check this check box.

When you migrate users and groups from NT, the Server Consolidation Utility stores a
table of NT names and associated eDirectory usernames in the registry of the Primary
Domain Controller (PDC). The utility then uses this information when migrating the file
system so that it can remember where each user and group has been migrated to in the
destination eDirectory tree. By storing this information, the utility can assign the correct
file permissions to the appropriate users.

To begin the verification, click Next in the Verify NT to NetWare Project window.

(Conditional) If prompted, resolve any naming conflicts between different-type objects, then
click Next.

You can choose to merge different-type objects or to keep them as they are.

(Conditional) If prompted, resolve any naming conflicts between same-type objects, then
click Next.

You can choose to merge same-type objects or to keep them as they are.

(Conditional) If prompted, verify that you do not want to migrate the listed NT users and
groups, then click Next.

If you migrated all of your users and groups, you will not see this dialog box.

Otherwise, this step must be done three times—once each for your NT local groups, NT global
groups, and NT users that were not dragged and dropped into the destination eDirectory tree.

If you have made a mistake, click Cancel to return to the Project Window. Then drag-and-drop
the objects, go to the toolbar, click Project > Verify and Copy Data, then restart this procedure
with Step 1 on page 43.

Resolve any critical errors.

Warnings or noncritical errors can be resolved after the consolidation. To resolve a critical
error or warning, read the description in the text field located beneath it. This description
should give you a good idea of what could be the possible cause and a suggestion for fixing it.

Do one of the following:
+  To start the actual consolidation, click Proceed.

¢ Ifyou are only running the verification process at this point and want to do the
consolidation later, click Cancel > Yes to save the changes you have made to the project
file.

When you are ready to proceed with the consolidation project, restart the Server
Consolidation Utility, select Open an Existing Project, and click OK. Then select the
project file you want to open, click Open, and then follow the instructions found in
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“Migrate Users and Data to the Destination eDirectory Tree” on page 43, starting with
Step 1.

13 (Consolidation only) View the Error and Success Logs.

Continue with the next section, “Perform Post-Consolidation Tasks” on page 45.

Perform Post-Consolidation Tasks

After you’ve migrated your NT data to the destination eDirectory tree, complete the following
tasks:

U Use ConsoleOne or Novell iManager to make sure that your NT users and groups have been
migrated to the correct place in the destination eDirectory tree and have the correct file and
shared permissions.

TIP: If you end up with more or fewer permissions than you planned for, enter CACLS/? at the DOS
prompt and follow the on-screen instructions. Permissions are sometimes hidden in Microsoft* utilities;
therefore, running this command at the DOS prompt lets you see all of the permissions associated with
your NT objects, even the hidden ones.

U At the destination NetWare server, use ConsoleOne or iManager to view the volume that you
migrated your data to and verify that it was done correctly.

U Set up your printer mappings in NDPS®. For instructions, go to the online documentation
(http://www.novell.com/documentation) for the destination server’s operating system and
click Print Services > Novell Distributed Print Services.

U Check the migrated users’ home directories to make sure that they were migrated the way you
expected them to be.

U Distribute the new eDirectory passwords to all of your users. The passwords are located in a
password file that the Server Consolidation Utility created for you named
project_name_out.txt. This file is located in the same directory where you saved your
consolidation project.

If you are using Novell ZENworks® to support Roaming Profiles, ZENworks version 6.5 now
creates an NT Roaming Profile directory the first time a migrated NT user logs into his or her
eDirectory account on NetWare. The directory is either the eDirectory User Home Directory or an
explicit UNC path, as specified in the ZENworks User Package assigned to that user. The time-
consuming process of having the Server Consolidation Utility copy the NT Profile directory is no
longer needed and has been removed.
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Troubleshooting the Server Consolidation Utility

Refer to the appropriate section if you are having trouble with any of the following:
¢ “SMDR Not Communicating” on page 47
¢ “NDPS Printer Agents Don’t Migrate” on page 47
* “NUWAGENT Won’t Load (NetWare 4.2 Only)” on page 47
+ “Server Consolidation Performance Problems” on page 48
* “Volume Contents Do Not Display” on page 48
+ “Copies Incomplete Data Files” on page 48

* “Errors When Connecting to a NetWare 4 Server” on page 49

In general, when troubleshooting errors in the Server Consolidation Utility, first ensure that the
latest smdr.nlm and tsa.nlm are loaded on the source and destination servers.

SMDR Not Communicating

Possible Cause: ~ Smdr.nlm is not loaded on either the source or the destination server, or SLP is not properly
configured.

Action: Enter display slp services smdr.novell// (svcname-
ws==source_server name)(replace source_server_name with the name of your source
server) at the destination server console.

If smdr.nlm is not loaded on the source or destination server, manually load it.

If it appears there is a problem with SLP, go to Novell’s Knowledgebase (http://
support.novell.com/search/kb_index.jsp) and search for SLP-related configuration information.

NDPS Printer Agents Don’t Migrate

Possible Cause:  If after a migration, it appears NDPS® Printer Agents have not migrated, it is possible that NDS®
has not had time to properly synchronize.

Action:  Wait for a few minutes, then check again to see if NDS has been updated to reflect the Printer
Agent migration.

Action:  Ifthe Printer Agents have still not migrated after allowing NDS to synchronize, ensure the Novell®
Distributed Print Services™ Manager (ndpsm.nlm) is loaded on either the source or destination
server.

NUWAGENT Won’t Load (NetWare 4.2 Only)
Possible Cause:  Clibaux.nlm is not loaded.

Action:  Go to the server specified in the error message and at the server console, enter load
clibaux.nlm.
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Server Consolidation Performance Problems

Explanation:

Possible Cause:
Action:
Possible Cause:

Action:

Possible Cause:

Action:

Possible Cause:

Action:

Possible Cause:

Possible Cause:

The performance of a project can be determined by looking at the success log after a project
completes. The success log gives the amount of time the project took to complete and the amount
of data copied.

There are several factors that determine the performance of the file copy. It is also important that
each server is updated to the latest Support Pack to ensure you have the latest performance
enhancements for SMS™.

Heavy traffic on the network.
Speeds can be increased by connecting servers and the workstation to a dedicated switch.
A mismatch in duplexing among servers, switches, and the workstation.

Make sure all hardware is set to either full duplex or half duplex. Setting all hardware to half
duplex might result in greater performance than full duplexing.

Virus scan software running on the source or destination servers.

Turn off any virus scanning software on the source or destination servers to increase the speed of
the consolidation. Turn the virus scanning software back on after the consolidation completes.

An incorrect version of smdr.nlm is loaded on a NetWare® 5 server.

At the NetWare 5 server, unload smdr.nlm, then load the smdr.nlm file that comes with the Server
Consolidation Utility.

Small file sizes.

In general, the larger the file sizes, the better the performance. Copying a single 500 MB file will
be significantly faster than copying five thousand 100 KB files.

Hardware configuration.

The performance of the Server Consolidation Utility varies according to the environment. Using
a 100 MB LAN, tests have measured speeds ranging from 3 to 15 GB per hour, with the most
common speed being between 5 and 8 GB per hour. You should check the performance of your
LAN before copying very large amounts of data.

The Server Consolidation Utility will copy data at a faster rate than a Windows* file copy.

Volume Contents Do Not Display

Problem:

Action:

No data appears in the Volume object after dropping a container into a volume that has not been
opened.

Map a drive to the volume from a workstation.

Copies Incomplete Data Files

48

Problem:

Action:

Files copied to the destination server have any of the following characteristics:
+ Destination is a 0-byte file.
¢ Creation time and date are incorrect when compared to the source server.
¢ Modification time and date are incorrect when compared to the source server.

+ File was not completely copied. (This would be indicated by the destination file being smaller
in size than the source file.)

Use the latest TSA500 and SMDR on the source server if it is a NetWare 5 server.
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Use the latest TSA600 and SMDR on the source server if it is a NetWare 6 server.

For more information, see TID #10076801 in the Knowledgebase at Novell’s Support Web site
(http://support.novell.com).

Errors When Connecting to a NetWare 4 Server

Problem:

Action:

Problem:

Action:

Problem:

Action:

Action:

When attempting to connect to a NetWare 4 server, any of the following types of errors are
returned:

¢ An error occurred opening the file. filename was invalid.
* Error opening connection to SMDR.

¢ The name spaces couldn’t be checked.

+ 8998 error. NWGetVolumeNumber.

There are several actions to take if errors are returned when trying to connect to a NetWare 4
server, including the following:

+ If your source server is NetWare 4, make sure that you have IPX™ on your client. For
information on verifying IPX on your client, see “Verifying [PX is Bound On the Client” on
page 29.

+ Add a mapped drive to the source server.
¢ Ensure that SLP is configured properly on the servers involved in the consolidation project.

NetWare 6.5 won’t communicate with NetWare 4 during a consolidation. IPX was not installed
during the NetWare 6.5 installation.

Add IPX to the NetWare 6.5 server after the NetWare 6.5 installation is complete.
1 Enter edit at the NetWare 6.5 server console.
2 Press the Insert key.
3 Select sys: and press Enter.
4 Sclect System and press Enter.
85 Select autoexec.ncf and press Enter > Enter.
6 Add the server ID of the source server and save the autoexec.ncf file.
IPX connection is not communicating.
Ensure that there is an IPX connection to the server.
To verify that the source and destination servers can see each other via IPX:

1 On the server console of the destination server, enter serverid xxxxx, where xxxxx is the
unique server ID number for the server.

2 Enter load ipxping.
3 Enter the internal IPX number of the source server.

4 Repeat this process on the source server, replacing the internal IPX number of the source
server with the destination server’s internal IPX number in Step 3.

Bind IPX on the destination server.
1 At the destination server console, enter inetc£fg.

2 Sclect Boards and press Enter.
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Press the Insert key.

Select the appropriate network interface and press Enter.

Enter a board name and slot number, then press the Esc key.

Select Yes to save changes and press Enter.

Press the Esc key to return to the main Internetworking Configuration screen.

Select Protocols and press Enter.

© O N o g @

Select IPX and press Enter.
10 Enable and configure IPX and exit the inetcfg utility.

TIP: If you prefer, IPX can also be enabled on the server by adding the appropriate Load and Bind commands
to the server’s autoexec.ncf file.

Action:  Verify that IPX is bound on the client running the Server Consolidation Utility:
1 Right-click on the red N in the system tray on your workstation.
2 Seclect Novell Client Properties.
3 Select the Protocol Preferences tab.
If the Protocol window displays both IP and IPX, the client has IPX bound.
If the Protocol window displays only IP, then IPX needs to be bound on the workstation.
Action:  Bind IPX on the client running the Server Consolidation Utility:
1 Insert the Novell Clients Software CD (March 2003).
2 Sclect the client version you want and click Next.
3 Select the appropriate language and click Next.
4 Sclect Custom and click Next.
5 Click the radio button next to one of the following two choices:
¢ [Pand IPX
¢ [P with IPX compatibility
TIP: You can select this choice if you are running in an scmd environment.
6 Click Next > Next > Finish.
Action:  Ensure that the correct smdr.nlm and tsa.nlm are loaded on the server.
1 On the server console, enter unload smdr.
Enter smdr new.
Enter N when asked if you want to disable NDS.
Enter N when asked if you want to disable SLP.
Enter N when asked if you want to disable SAP.
Enter N when asked if you want to disable name resolution through sys:\etc\hosts file.

Enter load smdr on the server console.

0 N o a A WON

Enter Lload tsa600 on the server console.
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Changing the Server’s Code Page

When using the Server Consolidation Utility, the source and destination servers must have the
same code page set, or data will be lost during the consolidation.

WARNING: We do not recommend converting a foreign-language code page server back to English, nor
converting a foreign-language code page server to another foreign-language code page. If either is done, it is
possible that documents and folders named with or containing foreign characters might become irreversibly
corrupted.

There are two recommended ways to create a NetWare® server with foreign-code page support:
¢ Install the server with the regional support you want

¢ Convert an English server to a foreign-language code page

Install a NetWare Server with Regional Support
To install an English server with code page support for a foreign language, you must have an
English NetWare® installation CD or access to English NetWare install files.
1 Begin the NetWare installation.

For information on installing your specific version of NetWare, see the NetWare on-line
documentation (http://www.novell.com/documentation).

During the installation, a Regional Settings screen will display. You will see three options:
¢ Country: 001 (USA)
¢ Code page: 437 (United States English)
¢ Keyboard: United States
2 Change the first option, Country:, to the country you want the server to support.

For example, if you want to install your English server with Japanese double-byte support,
change the Country: option to 081 (Japan).

When you change the Country: option, the Code page: and Keyboard: options change
automatically to the appropriate code page and keyboard.

3 If you intend to type foreign characters using the keyboard on the server console, accept the
automatic setting displayed for the Keyboard: option.

If you do not intend to type any foreign characters on the server console, manually change the
Keyboard: option to US International (the last keyboard option displayed in the list).

4 Complete the server installation.

When the server reboots after the installation is complete, you will have an English server
with a foreign code page.
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Convert an Existing NetWare Server to a Foreign Code Page

To convert an existing English server to a foreign code page, you must have an English NetWare
installation CD or access to English NetWare install files.

1 Bring the server down.
2 At the DOS prompt, go to c:\nwserver.
3 Rename Iconfig.sys to lconfig.437.

The Iconfig.sys file determines what code page NetWare will run. The purpose of renaming
the existing file is to allow for rolling back to the original configuration if necessary.

4 Browse to the \install\lconfig directory on the NetWare installation CD or at the location of
your NetWare installation files.

This directory contains the lconfig.sys files for all languages. The naming convention is
Ic_country codepage.country telephone code. Therefore, the Japanese Iconfig.sys file is
named Ic_932.081, for example.

The following is a partial list of Iconfig.sys files with their associated language names:
¢ Chinese-S LC_936.086

¢  Chinese-T LC_950.088

¢ French LC 850.033

¢ German LC _850.049

¢ Italian LC 850.039

¢ Japanese LC 932.081

¢+ Korean LC 949.082

¢ Portuguese LC_860.351

¢ Russian LC_855.007 or LC_866.007
¢ Spanish (Argentina) LC_850.054

¢ US English LC 437.001

5 Sclect the language code page file you want to implement and copy it to the c:\nwserver
directory.

6 Rename the Ic_xxx.xxx file you just copied to Iconfig.sys.

If you are converting an English server to a single-byte language like German or Russian, then
you are finished. When you start the server, you will have foreign-language code page support
for the country you selected.

If you have selected a double-byte code page like Japanese or Chinese, continue with Step 7.
7 (Conditional) If installing a double-byte codepage, copy the necessary server font files.

7a Go to :\startup on your NetWare installation CD and select the font files appropriate for
your language:

¢ Japan = jpn*.fnt

¢ Korea = kor*.fnt

¢ Chinese T = bg5*.fnt
¢  Chinese S = gb*.fnt
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7b Add Load vgadisp.nlmto c:\nwserver\startup.ncf.

Vgadisp.nlm allows for double-byte characters such as Japanese or Chinese to be viewed

in the C-worthy portion of the system console. It is cosmetic and does not affect the
functionality of the server.

8 Restart the server.

You will now have foreign-language code page support for the country you selected.

Verifying the Current Code Page on a NetWare Server

To verify the code page currently installed on your NetWare server, enter language at the server
console.

This will return “Current NLM language is (4) ENGLISH. Current DOS code page is (437)”, if

your server is using the English code page.

The following is a partial list of common codepages:

*

*

*

Chinese-S 936
Chinese-T 950
French 850
German 850
Italian 850
Japanese 932
Korean 949
Portuguese 860
Russian 855 or 866
Spanish 850
US English 437
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