# Contents

## I Configuration

### 1 The KDE Desktop

#### 1.1 Desktop Components

- 1.1.1 The Desktop Menus
- 1.1.2 The Trash Bin
- 1.1.3 CD-ROM, DVD-ROM, and Floppy Disks
- 1.1.4 The Printer Icon
- 1.1.5 The Panel
- 1.1.6 The Main Menu

#### 1.2 Settings

- 1.2.1 Peripherals
- 1.2.2 Desktop
- 1.2.3 Sound & Multimedia
- 1.2.4 Appearance
- 1.2.5 Regional & Accessibility

#### 1.3 Konqueror as a File Manager

- 1.3.1 The Konqueror Menu
- 1.3.2 The Toolbar
- 1.3.3 The Location Bar
- 1.3.4 The Main Window

---

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>I Configuration</td>
<td>3</td>
</tr>
<tr>
<td>1 The KDE Desktop</td>
<td>5</td>
</tr>
<tr>
<td>1.1 Desktop Components</td>
<td>6</td>
</tr>
<tr>
<td>1.1.1 The Desktop Menus</td>
<td>6</td>
</tr>
<tr>
<td>1.1.2 The Trash Bin</td>
<td>8</td>
</tr>
<tr>
<td>1.1.3 CD-ROM, DVD-ROM, and Floppy Disks</td>
<td>8</td>
</tr>
<tr>
<td>1.1.4 The Printer Icon</td>
<td>9</td>
</tr>
<tr>
<td>1.1.5 The Panel</td>
<td>11</td>
</tr>
<tr>
<td>1.1.6 The Main Menu</td>
<td>12</td>
</tr>
<tr>
<td>1.2 Settings</td>
<td>13</td>
</tr>
<tr>
<td>1.2.1 Peripherals</td>
<td>13</td>
</tr>
<tr>
<td>1.2.2 Desktop</td>
<td>15</td>
</tr>
<tr>
<td>1.2.3 Sound &amp; Multimedia</td>
<td>16</td>
</tr>
<tr>
<td>1.2.4 Appearance</td>
<td>16</td>
</tr>
<tr>
<td>1.2.5 Regional &amp; Accessibility</td>
<td>18</td>
</tr>
<tr>
<td>1.3 Konqueror as a File Manager</td>
<td>20</td>
</tr>
<tr>
<td>1.3.1 The Konqueror Menu</td>
<td>21</td>
</tr>
<tr>
<td>1.3.2 The Toolbar</td>
<td>23</td>
</tr>
<tr>
<td>1.3.3 The Location Bar</td>
<td>23</td>
</tr>
<tr>
<td>1.3.4 The Main Window</td>
<td>23</td>
</tr>
</tbody>
</table>
## Important Utilities

1. **Creating an Image Gallery** .................................................. 24
2. **KInternet — Connecting to the Internet** .............................. 24
3. **The Download Manager KGet** ........................................... 26
4. **SuSEWatcher** .................................................................... 27
5. **The Clipboard Klipper** ....................................................... 27
6. **Monitoring Print Jobs** ....................................................... 28
7. **Formatting Floppy Disks with KFloppy** ............................... 30
8. **Ark: Displaying, Decompressing, and Creating Archives** ....... 30
9. **Desktop Sharing** .............................................................. 32
10. **Screenshots with KSnapshot** ............................................ 33
11. **The Information Manager Kontact** ..................................... 34
12. **Chatting With Friends: Kopete** ........................................ 35
13. **Font Administration with KFontinst** ................................. 38

## The GNOME Desktop

1. **The Desktop** ..................................................................... 42
2. **The Icons** .......................................................................... 42
3. **The Desktop Menu** ............................................................ 42
4. **The Panel** .......................................................................... 43
5. **The Main Menu** .................................................................. 43
6. **Handling Floppy Disks, CDs, or DVDs** ................................. 43

2. **Settings** ........................................................................... 44
1. **Keyboard** ........................................................................... 44
2. **Mouse Configuration** ........................................................ 45
3. **Menus and Toolbars** ........................................................ 45
4. **Screensaver** ...................................................................... 45
5. **Windows** .......................................................................... 46
6. **Background** ....................................................................... 46
7. **Font** .................................................................................. 47
8. **Theme** ............................................................................... 47
## II Office Applications

### 3 The OpenOffice.org Office Suite

<table>
<thead>
<tr>
<th>3.1 The OpenOffice.org Quickstarter</th>
<th>58</th>
</tr>
</thead>
<tbody>
<tr>
<td>3.2 Getting Help</td>
<td>59</td>
</tr>
<tr>
<td>3.3 Managing the Transition from Microsoft Office</td>
<td>60</td>
</tr>
<tr>
<td>3.3.1 From MS Word to OpenOffice.org Write</td>
<td>60</td>
</tr>
<tr>
<td>3.3.2 From MS Excel to OpenOffice.org Calc</td>
<td>61</td>
</tr>
<tr>
<td>3.3.3 From MS PowerPoint to OpenOffice.org Impress</td>
<td>61</td>
</tr>
<tr>
<td>3.4 Changing the Global Settings</td>
<td>61</td>
</tr>
<tr>
<td>3.5 Word Processing with OpenOffice.org Writer</td>
<td>63</td>
</tr>
<tr>
<td>3.5.1 Creating Texts with the AutoPilot</td>
<td>63</td>
</tr>
<tr>
<td>3.5.2 Creating Texts without the AutoPilot</td>
<td>64</td>
</tr>
<tr>
<td>3.5.3 Selecting Text</td>
<td>64</td>
</tr>
<tr>
<td>3.5.4 Working with the Stylist</td>
<td>65</td>
</tr>
<tr>
<td>3.5.5 Inserting a Table</td>
<td>67</td>
</tr>
<tr>
<td>3.5.6 Inserting Graphics</td>
<td>68</td>
</tr>
<tr>
<td>3.6 Spreadsheets with OpenOffice.org Calc</td>
<td>68</td>
</tr>
<tr>
<td>3.6.1 Changing Cell Attributes</td>
<td>69</td>
</tr>
</tbody>
</table>
# Contents

9 The Web Browser Galeon 111

9.1 Optimized for the Web ........................................ 112
9.2 Efficient Surfing with Tabs .................................. 113
9.3 Smart Bookmarks .............................................. 113
9.4 Settings and Controls ...................................... 113
9.5 For More Information .................................... 114

10 The Mozilla Web Browser 115

10.1 The Initial Browser Window ............................... 116
10.1.1 The Menu Bar .......................................... 117
10.1.2 The Navigation Toolbar ............................... 118
10.1.3 The Personal Toolbar ................................ 118
10.1.4 Sidebar ................................................ 119
10.2 Working with Tabs ......................................... 119
10.3 Preferences ................................................... 120

11 Encryption with KGpg 123

11.1 Key Management ........................................... 124
11.1.1 Generating a New Key Pair ......................... 124
11.1.2 Exporting the Public Key ........................... 124
11.1.3 Importing Keys ....................................... 126
11.2 The Key Server Dialog ................................ 127
11.2.1 Importing a Key from a Key Server ............ 127
11.2.2 Exporting Your Keys to a Key Server .......... 128
11.3 Text and File Encryption ................................ 129
11.3.1 Encrypting and Decrypting the Clipboard ..... 129
11.3.2 Encrypting and Decrypting by Dragging and Dropping 129
11.3.3 The KGpg Editor .................................... 130
11.4 For More Information .................................... 131
IV Multimedia

15 Sound in Linux

15.1 The ALSA PCM Types ........................................ 176
15.2 Mixers .............................................................. 176
  15.2.1 gamix ......................................................... 177
  15.2.2 qamix .......................................................... 177
  15.2.3 KMix .......................................................... 178
  15.2.4 The GNOME Mixer Applet .................................. 178
  15.2.5 alsamixer ..................................................... 178
  15.2.6 Mixer Parameters of Soundblaster Live! and Audigy ... 179
  15.2.7 The Mixer for the Sound Chip Envy24 ...................... 179
  15.2.8 Configuration of the S/PDIF Channels ..................... 181
15.3 Players ............................................................ 181
  15.3.1 amaroK ......................................................... 181
  15.3.2 XMMS .......................................................... 184
  15.3.3 kscd — Audio CD Player .................................. 185
  15.3.4 The Audio CD Player WorkMan ............................ 185
  15.3.5 GNOME CD Player Applet .................................. 185
15.4 Buffering and Latencies ........................................ 186
15.5 The JACK Audio Connection Kit ................................ 187
15.6 Hard Disk Recording with Audacity ............................ 188
  15.6.1 Recording WAV Files and Importing Files ................. 189
  15.6.2 Editing Audio Files ........................................ 190
  15.6.3 Saving and Exporting ...................................... 191
15.7 Direct Recording and Playback of WAV Files .................. 191
15.8 Compressing Audio Data ........................................ 192
15.9 ALSA and MIDI .................................................... 193
  15.9.1 Loading Sound Fonts: SB Live! and AWE .................. 194
  15.9.2 vkeybd — Virtual MIDI Keyboard ........................ 195
  15.9.3 Establishing Connections between MIDI Ports ............ 196
20.3.2 Opening an Existing Image .............................................. 240
20.3.3 The Image Window ..................................................... 240
20.4 Saving Images ............................................................. 240
20.5 Editing Images: Basics .................................................. 242
  20.5.1 Changing the Image Size ............................................ 242
  20.5.2 Selecting Parts of Images ........................................... 243
  20.5.3 Applying and Removing Color .................................... 245
  20.5.4 Adjusting Color Levels ............................................. 247
  20.5.5 Undoing Mistakes .................................................... 248
20.6 Editing Images: Advanced Features ................................ 248
  20.6.1 Layers ................................................................. 248
  20.6.2 Image Modes ....................................................... 249
  20.6.3 Special Effects ..................................................... 249
20.7 Printing Images ........................................................... 249
20.8 Configuring GIMP ........................................................ 251
  20.8.1 Customizing Windows ............................................... 251
  20.8.2 Setting Preferences ................................................ 251
20.9 For More Information .................................................... 251

V Excursions ................................................................. 253

21 Working with the Shell .................................................... 255
  21.1 Introduction to Bash .................................................... 256
    21.1.1 Commands .......................................................... 256
    21.1.2 Files and Directories ............................................. 256
    21.1.3 Bash Functions .................................................... 259
    21.1.4 Specifying Paths ................................................ 260
    21.1.5 Wild Cards ....................................................... 261
    21.1.6 Less and More .................................................... 262
    21.1.7 Pipes ............................................................... 262
Congratulations for selecting SUSE LINUX. A few clicks are all that is needed to prepare the installation, which takes fifteen to twenty minutes. After configuring the users and their passwords and selecting the screen resolution, your SUSE LINUX system is ready for use. If you are familiar with earlier versions of SUSE LINUX, you will notice how much the configuration with the system assistant YaST has been expanded and simplified.

Get to know the graphical desktop environments KDE and GNOME and learn how to adapt them to your personal preferences. The following sections introduce some very useful and interesting programs from the large range of available applications in different categories, including office programs such as OpenOffice.org, web browsers, programs to manage your schedule, file managers, scanning tools, and image editing programs.

Additionally find information about the SUSE help system and the available information sources containing further documentation. Also included are a list of frequently asked questions about SUSE LINUX.

Changes in the User Guide

The following is a list of the changes introduced in this guide, as compared to the previous version (SUSE LINUX 9.1):

- The instructions for the installation and configuration with YaST have been moved to the Administration Guide.
- The following chapters have been revised:
The chapter about OpenOffice.org now includes a section discussing the migration of MS Office documents to the OpenOffice.org formats.

The chapter about GNOME has been updated to reflect the current version.

The chapters about the KDE desktop, KOrganizer (schedule manager), KAddressbook (contact organizer), KMail, and about synchronizing handhelds with KPilot have been updated to match the current version of KDE.

Typographical Conventions

The following typographical conventions are used in this book:

- `/etc/passwd`: files or directories
- `<placeholder>`: replace the character string `<placeholder>` (including the angle brackets) with the actual value
- `PATH`: an environment variable
- `ls`: commands
- `user`: users
- `<Alt>`: a key to press
- `'File'`: menu items, buttons

Acknowledgements

With a lot of personal commitment, the Linux developers continue to promote the development of Linux. We would like to express our sincere gratitude for their efforts. Without them, this distribution would not exist. Additional thanks go to Frank Zappa and Pawar. Special thanks, of course, to LINUS TORVALDS.

Have a lot of fun!

Your SUSE Team
Part I

Configuration
The KDE Desktop

The KDE desktop offers an intuitive graphical interface. The following sections show you how to make efficient use of KDE’s features and how to customize the desktop to meet your personal needs. This is followed by an introduction to the file manager Konqueror and a brief description of some small but useful utilities.

1.1 Desktop Components .................................................. 6
1.2 Settings ................................................................. 13
1.3 Konqueror as a File Manager ....................................... 20
1.4 Important Utilities .................................................... 24
1.1 Desktop Components

The main components are the icons on the desktop and the panel at the bottom of the screen. The mouse is your most important tool. Click a symbol or an icon once to start the associated program or the file manager Konqueror. If you right-click an icon, different menus appear, depending on the program. As well as the icons, there are two desktop menus.

1.1.1 The Desktop Menus

If you middle-click the desktop (if your mouse only has two buttons, press both buttons at the same time), a window and desktop management menu is displayed. The menu lists the various desktops and the windows opened in them. Click one of the following menu items:

‘Unclutter Windows’ If you have several windows on your desktop, they are placed next to each other and aligned with the top left corner.

‘Cascade Windows’ Starting from the top left corner, the windows on the desktop are placed on top of each other in such a way that only the top and left borders of the lower windows are visible.

‘Desktop x’ Desktop 1 is your default desktop. This part of the menu lists all the windows currently opened. You can bring them to the foreground by clicking one of the respective items.

‘Additional Desktops’ You can use the additional (virtual) desktops provided and switch to them with the menu or the panel. All functions are available on all desktops. This limits the number of programs and associated windows that need to be arranged on one desktop. These virtual desktops resemble additional desks in your office.

If you right-click the desktop, a more complex menu is displayed, allowing you to customize your desktop.

‘Create New’ Use this menu item to create new directories, files, or devices on the desktop. A list of possible elements is provided for selection in a submenu.
‘Bookmarks’ The bookmark editor allows you to create, group, change, or delete bookmarks. The bookmarks are used by the browser and file manager Konqueror. The bookmark editor also allows you to import bookmarks from other browsers, such as Mozilla, Netscape, Opera, and Internet Explorer.

‘Run Command . . . ’ This menu item opens a window in which to enter a command manually. The command is executed after pressing Enter.

‘Undo’ Use this item to undo the last action. For example, if you have just created a new directory on the desktop, clicking this item reverts the creation so the directory disappears.

‘Paste’ To keep a folder or document handy on the desktop, you can copy an icon from the file manager by right-clicking and selecting ‘Copy’ then moving the mouse to the desired location on the desktop. Right-click again and select ‘Paste’. The icon is now available on your desktop and can be moved around by dragging it with the left mouse button pressed.

‘Icons’ This allows you to rearrange the icons on the desktop. You can also change the order of the icons.

‘Windows’ This arranges the windows on the desktop, either on top of each other beginning from the top left corner or next to each other.

‘Refresh Desktop’ If the desktop should appear garbled in some way, use this menu item to redraw it.

‘Configure Desktop . . . ’ This menu item starts a configuration dialog with which to configure the appearance and behavior of the desktop. Details about the configuration of the desktop are provided in Settings on page 13.

‘Start New Session’ This menu opens a dialog box asking if you want to start a new user environment. After clicking ‘Start New Session’, the current session disappears into the background and the system switches to a new login screen. Each session has a function key assigned to it: F7 represents the first session, F8 the second one, and so on. To switch between different sessions, press Ctrl-Alt-F(x), where F(x) is the function key corresponding to the desired session.

‘Lock Screen’ If you leave your workstation and do not log out, you should use this function to prevent others from gaining access to your files. Depending on the setting, the screen turns blank or starts displaying a screensaver. To continue using the computer, enter your password.
‘Logout’ Log out of your system if you are not going to use the system for some time.

1.1.2 The Trash Bin

The trash bin is a directory for files marked for deletion. Drag icons from the file manager or the desktop to the trash bin icon by keeping the left mouse button pressed then release to drop them there. Alternatively, right-click an icon and select ‘Move to Trash’ from the menu. Click the trash bin icon to view its contents. You can retrieve an item from the trash if desired.

Files removed with ‘Delete’ are not kept in the trash bin, but permanently deleted right away. To permanently delete the files in the trash bin itself, right-click the trash bin icon and select ‘Empty Trash Bin’.

1.1.3 CD-ROM, DVD-ROM, and Floppy Disks

If you click the floppy disk icon when a floppy disk is inserted, the file manager starts and displays the content of the floppy disk. Display a context menu with various options by right-clicking the individual icons on the floppy disk. It is also possible to move the icon to a different location, such as the desktop or your home directory, by simply keeping the left mouse button pressed over it and dragging it to the destination. You will be asked whether you want to move or copy the file or create a link. The same technique can be used to copy or move files from your home directory to the floppy disk.

Right-click the floppy disk icon to access the context menu. ‘Unmount’ is a very important option. Be sure to unmount the drive before removing a floppy disk from the drive, because this is necessary to trigger the actual writing of the data to the floppy disk.

The handling of CDs and DVDs is similar, with the only difference that these media are not writable. Despite this, you must unmount CD and DVD drives, because otherwise you will not be able to remove the disk from the drive. You can also select ‘Eject’, which causes the medium to be unmounted and ejected. Both methods only work if the CD or DVD is no longer accessed and any file manager window displaying the content of the CD or DVD has been closed.
1.1.4 The Printer Icon

Right-click the printer icon and choose ‘Actions’ → ‘Print files’. The KPrinter dialog window starts. This program enables you to adjust a number of settings and send print jobs directly. The upper part of the main window, like that in Figure 1.1, shows the selected printer. To switch to another printer, click the arrow next to the printer name and select the device to use from the list displayed.

![Figure 1.1: The Main Window of KPrinter](image)

To configure the selected printer, click ‘Properties…’. A configuration dialog like that shown in Figure 1.2 on the following page opens, enabling you to change the paper format (e.g., from A4 to letter) or to select a different paper tray. Changing trays is especially useful if one of the trays contains letterhead paper and another contains plain white paper.
Under ‘Orientation’, choose between ‘Portrait’ and ‘Landscape’ and whether the pages should be turned 180 degrees so that they are printed upside down. To the right of ‘Orientation’, specify the settings for two-sided printing. If ‘None’ is selected, only one page is printed per sheet. If you select ‘Long side’, the front and back are printed like in a book. With ‘Short side’, the back is printed reversely and you must turn the sheet up to view the text correctly. With ‘Start:/End:’, specify whether your document should have start or end banners, such as “confidential” or “secret”. Under ‘Pages per Sheet’, select to print two or four pages on one sheet. For this purpose, the pages are downsized accordingly. If you click ‘Save’, your settings are saved and used again for the following print jobs. However, if you click ‘OK’, the settings only apply to the current job. If you close the dialog with ‘Cancel’, all changes are discarded.

After making all settings, click ‘Expand’. The second part of the window now
becomes visible. Click the blue folder icon. By default, your home directory is displayed. Select a file and confirm with ‘OK’. You can also select the file by double-clicking it. The respective file then appears in the overview of the main window, together with the name, type, and path specification. Now click ‘Print’ to send the job to the printer. The job is placed in the queue and can be monitored with KJobViewer. On the other hand, if you click the document, two additional buttons become active to the right. Use the X button to remove the document from the selection or use the magnifying glass icon to display, edit, and save the file with KWrite or OpenOffice.org (depending on the document type). Afterwards, simply close the editing program and click ‘Print’ in the KPrinter dialog. The printout will reflect any changes made to the document while editing.

All KDE applications use KPrinter for printing. For example, if you click the printer icon in KWrite, the KPrinter dialog appears. The file to print is already pre-selected.

### 1.1.5 The Panel

The panel at the lower edge of the screen consists of several areas. By default, the icon for the main menu is located to the far left. Other icons are next to it. The house icon provides quick access to your home directory with all subdirectories. The other icons start applications, such as OpenOffice.org, K-Mail, and the web browser Konqueror, if these programs were installed.

Next to these icons are the numbered buttons with which to switch desktops. These multiple desktops enable you to organize your work if you use many programs simultaneously, as if you had several desks for various tasks.

The taskbar is located next to the virtual desktops. All started applications are displayed in the taskbar. If you click a window title in the taskbar, the application is moved to the foreground. If it is already in the foreground, clicking minimizes the application. If you click it again, it reopens. Next to the taskbar, find applets, such as the clipboard Klipper, SuSEwatcher, and any other applets you have started. The clock helps you keep track of the time.

If you right-click an empty space in the panel, a menu providing the usual help and configuration options for the panel is displayed. Use the menu to change the size of the panel and to add or remove applications. To add an application, search for it in the menu and select it. Remove applications or applets by right-clicking the corresponding icon and selecting ‘Remove’ from the displayed menu.
1.1.6 The Main Menu

Open the main menu by clicking the icon to the far left of the panel. Alternatively, press (Alt)-F1. The main menu is subdivided into these sections: ‘Recently Used Applications’ (or ‘Most Used Applications’), ‘All Applications’ (a menu with all applications sorted according to categories), and ‘Actions’. The following section provides information about a number of actions that can be triggered from the main menu. Detailed information about the Control Center is available in Settings on the next page.

‘Bookmarks’ By selecting ‘Edit Bookmarks’ from this menu, start an editor in which to organize your bookmarks. If you select one of the bookmarks present in the menu, the Konqueror browser starts and loads the corresponding URL.

‘Run Command...’ This item opens a dialog where you can enter a command. You can use it to quickly start an application whose command you know — without having to navigate through the program submenus.

‘Start New Session’ To start a second session with a graphical user interface on your machine, select ‘Start New Session’ from the main menu. Your current session remains active while you are taken to the login screen. Log in. You can also start another window manager. Access the first session by pressing (Ctrl)-Alt-F7. Press F8 instead of F7 to access the new session. Additional sessions can be accessed by pressing (Ctrl)-Alt-F9 to F12.

‘Lock Screen’ If you leave your workstation, you can blank your screen or start a screensaver. Access to the session can only be regained with a password. To unlock, enter your normal login password. Locking the screen ensures that others cannot read or manipulate your documents or e-mail messages.

Logout User You can log out from the system by means of this menu item. However, first you will be asked what should happen after the logout. If you select ‘Login as different user’, the login screen is displayed, allowing you or another user to log in to the system. You can also shut down and turn off the computer or shut it down and reboot immediately. Confirm your selection with ‘OK’ or remain logged in by clicking ‘Cancel’.
1.2 Settings

The KDE desktop can be customized according to your preferences and needs. ‘Control Center’ in the main menu opens the configuration dialog for your KDE desktop. The following section introduces a number of modules.

1.2.1 Peripherals

This opens the configuration dialogs for the mouse, keyboard, and printer administration.

Keyboard

Keyboard Repeat  Keeping a key pressed causes the associated character to be printed repeatedly as long as the key is pressed. The option is activated by default.

NumLock on KDE Startup  Here, determine whether the number pad of your keyboard should be active when KDE is started.

Key Click Volume  If you want to hear a sound when a key is clicked, activate this option and adjust the volume with the slider.

Mouse

The mouse configuration comprises three tabs: ‘General’, ‘Advanced’, and ‘Mouse Navigation’. The configuration options of the ‘General’ tab are:

Button Mapping  Here, specify right-handed or left-handed use of your mouse.

Icons  Determine how the system should react to clicks and double-clicks. The default setting for the KDE desktop is a single click for opening files or folders and a mouse pointer that changes its appearance when it is moved over icons. To use double-click for opening files and folders, select ‘Double-click to open files and folders (select icons on first click)’. Finally, set the size and color of the pointer and the kind of visual feedback given when programs are started.

Under the ‘Pointer Theme’ tab, choose among a number of themes to give the mouse pointer an appearance to your liking. The configuration options of the ‘Advanced’ tab are:
**Pointer Acceleration**  The pointer acceleration defines the relation between the speed with which you move the input device (mouse) and the pointer speed as displayed on the screen. The higher the selected factor is, the more difficult it is to control the screen pointer.

**Pointer Threshold**  The threshold (in pixels) specifies the distance the pointer must move before the specified pointer acceleration actually comes into force. In this way, you have exact control over the mouse pointer when moving it a small distance, but you can still cover a large distance on the screen with a flick of the wrist.

**Double Click Interval**  Here, set the maximum interval between two mouse clicks that should still be interpreted as a double-click.

**Drag Start Time**  An object selected with a click is moved only if you continue to move the pointer for the specified period (in milliseconds).

**Drag Start Distance**  An object selected with a click is moved only if you drag it the minimum distance specified (in pixels).

**Mouse Wheel Scrolls By**  If you have a wheel mouse, specify the number of lines the selected element should scroll with each wheel notch.

To be able to navigate the mouse pointer with the arrow keys of the number pad, activate this function under ‘Mouse Navigation’ and customize the parameters according to your needs.

**Printers**

The printer administration module mainly consists of three parts. The top frame lists all printers available in the network. The center part features a configuration and information zone comprising four tabs. The lower part indicates the current print system type. The following description only covers the configuration part.

---

**Note**

The configuration options relevant for your daily work with the system can be accessed under ‘Jobs’ and ‘Instances’. ‘Information’ and ‘Properties’ mainly provide information or are used for system administration.

---

14  1.2. Settings
Depending on which printer is currently selected in the overview, view and modify status and model information and configuration options in the following four tabs at the center of the dialog window:

**Information**  This tab provides general and unmodifiable information about the printer, such as the printer type, its status, location, and designation.

**Jobs**  This tab corresponds to KJobViewer, described in *Monitoring Print Jobs* on page 28.

**Properties**  All settings related to the printer are available here: general information, drivers, interfaces, separator pages, quotas, and user accesses.

**Instances**  Depending on the document type, you may have diverse requirements for the printouts (page format, duplex printing, orientation, print quality, and banners). Combine the characteristic settings for each type in printer profiles, called instances. To create a new profile, select ‘New’ and enter a name for the profile. Click ‘Settings...’ to open a configuration dialog in which to specify these settings. To save the settings and exit the dialog, click ‘OK’. To define one of your custom profiles as the default for this printer, click ‘Set as Default’. Your default profile is used when printing from applications. You can only switch between the individual profiles in the printer administration module.

1.2.2 Desktop

Under ‘Appearance’, set the standard font, font size, background colors, and underlining on the desktop. Under ‘Window Behavior’, configure the behavior of the windows and their activation. For example, set the focus to follow the mouse. In this case, you do not need to click a window to activate it.

The taskbar in the panel displays the applications currently started on your system. In this module, determine to what extent started programs and virtual desktops should be displayed in the taskbar and which actions should be associated with mouse clicks in the taskbar.

Under ‘Panels’, set the position and size of the panels and configure their hiding mode. You can also place additional menus in the panel. If the standard number of virtual desktops is not sufficient, set up additional virtual desktops under ‘Multiple Desktops’ and assign them names.
1.2.3 Sound & Multimedia

Here, perform all settings for the playback of audio CDs and for the sound system. Under ‘System Bell’, switch from system notification to a system bell and specify the volume, pitch, and duration of the bell.

By default, system notifications are used. Use this module to determine how the system should inform you in the event of a problem, when a task is performed, or if an event requiring your immediate attention occurs.

In the upper part of the dialog, select the application for which to configure the system notifications. As soon as you select a program, all events the application can send to the user are listed in the lower window. Determine the notification type for each notification in the ‘Actions’ dialog.

The standard view of the system notification dialog only offers ‘Play a sound’ for audible notification. Click ‘More Options’ to access other action modes. You can log the notification to a file, execute a program, or show the message in a pop-up window. In the lower part of the dialog under ‘Quick Controls’, globally activate or deactivate the actions for all programs.

1.2.4 Appearance

This item features all fine tuning options for the appearance of your desktop.

Screensaver

The module for selecting and configuring the screensaver consists of three parts. Select a suitable screensaver from the list to the left. The preview to the right shows how the selected program looks. Use ‘Setup’ to configure the selected screensaver and ‘Test’ to view it in full-screen mode.

Start Screensaver Automatically For the screensaver to be activated automatically, select this option and specify the time (in minutes) after which the screensaver should be activated.

Require Password to Stop Screensaver The screensaver can lock your workstation and require a password for the release.
Colors

Use this module to manage and edit color schemes for your desktop. Select one of the many existing schemes. The preview window displays all desktop elements in the defined colors. To change the color of one or several widgets, select the name of the widget from ‘Widget Color’ and click the color bar below to choose a suitable color in the color editor. Finally, adjust the contrast settings and save the modified scheme under a name of your choice. To apply this scheme globally, activate ‘Apply colors to non-KDE applications’.

Window Decorations

Select a decoration style for your application windows from the list under the ‘General’ tab. Click ‘Apply’ to test the selected style. To position or move individual elements of the title bar, activate ‘Use custom titlebar button positions’ and rearrange the elements under the ‘Buttons’ tab. If additional configuration options are available for the selected style, access these under the ‘Configure’ tab.

Background

This module lets you set the properties of your desktop’s background. The selection made with ‘Settings for Desktop’ decides to which desktops these settings should be applied. You can get an impression of the effect of your settings from the preview to the right.

In the ‘Wallpaper’ section, decide whether to use ‘No Wallpaper’ at all or a single ‘Wallpaper’. The desktop background can also be taken over by a special slide show program.

The ‘Options’ section lets you set various settings related to positions, colors, and shading. Depending on the background settings made so far, some items may not be active.

‘Advanced Options...’ opens a dialog for a number of special settings. It allows you to enter the details about a program acting upon the background, for example, to change it at certain intervals.

Fonts

All fonts and font attributes used on the desktop can be configured here. Click ‘Choose...’ then specify your settings in the dialog that opens. By default, antialiasing is activated for all fonts. To deactivate or customize antialiasing, select the respective check boxes.
Note

Changes to the antialiasing settings are only applied to newly-started programs. Programs already open are not affected by the changes.

Note

Style

Here, select the style for all widgets (elements of the graphical interface) in KDE applications. The configuration contains three tabs. Select the style under ‘Style’ and refer to the preview in the lower part of the window. Use ‘Effects’ to configure various GUI effects and transparency types, if supported by the respective style.

1.2.5 Regional & Accessibility

Country/Region & Language

The settings in this module only apply to KDE applications. Other applications, such as OpenOffice.org, may need to be configured separately. All regional system settings can be configured under five tabs.

Locale

Select the desired country from the list. Settings, such as the language, numbers, currency, time, and date are automatically set to suitable values. A preview of all current regional settings is displayed in the lower part of the dialog. For example, to use the regional settings for the US but use Spanish as the system language, click ‘Add Language’ to select this language and add it to the list of available system languages. To remove a language, mark it in the list and click ‘Remove Language’.

Numbers

To use different number settings than the default settings associated with the country selected under ‘Locale’, configure the decimal symbol, thousands separator, positive sign, and negative sign in this dialog. The decimal symbol and the thousands separator for currencies are configured separately under the ‘Money’ tab. The default setting on a US system is “.” for the decimal symbol, an optional “,” for the thousands separator, no entry for the positive sign, and “-” for the representation of negative numbers.

Money

Configure all currency-related settings that should differ from the default settings for the selected system language in this dialog. For example,
on a US system, the currency symbol is “$”, the decimal symbol is “.”, thousands are separated with a “,”, and the number of fraction digits is “2”. The position of the currency symbol and the prefix for positive and negative amounts is arranged in such a way that the currency symbol precedes the prefix and the amount.

**Time & Date** This dialog allows you to set your calendar system, the time, date, and short date format, and the first day of the week. A detailed explanation is displayed if you click the “?” symbol in the title bar then the respective menu item.

**Other** This tab features the setting for the default paper format and measurements. On a US system, the default paper format is “US Letter” and the imperial system is used for measurements.

**Accessibility**

The settings in this module facilitate access to the system for users with hearing problems or motor disorders. This module contains the ‘Bell’ and ‘Keyboard’ tabs.

**Audible Bell** System bells can be communicated to the user in a visible or in an audible form. The default setting is the audible variant with ‘Use System bell’. To configure a specific sound, activate ‘Use customized bell’ and use ‘Browse...’ to select a suitable sound from the list.

**Visible Bell** For system bells to be communicated visually, activate ‘Use visible bell’. If no other modifications are performed, the screen is inverted when a system bell rings (‘Invert screen’ is activated by default). The duration of the visual bell can be adjusted with the slider. Instead of the inversion, the screen can be set to flash. To do this, activate ‘Flash screen’ and select a suitable color in the color editor by clicking the color bar.

**Sticky Keys** Some shortcuts require a key to be held down (this is the case with (Alt), (Ctrl), and (Shift)) while the second part of the shortcut is entered. If sticky keys are enabled, the system considers these keys to be held down even if they are only pressed once for a short time.

**Slow Keys** Here, determine if and to what extent the system delays the output of characters on the screen when a key is pressed. The longer the interval adjusted with the slider is, the longer a key can be pressed without triggering a repeated output of the respective character on the screen.
Bounce Keys  If you activate this option, pressing a key twice is only interpreted as two characters if the interval selected with the slider has elapsed. If a key is pressed twice inadvertently, this is ignored.

1.3   Konqueror as a File Manager

Konqueror is a unified web browser, file manager, document viewer, and image viewer. The following paragraphs cover the use of Konqueror for file management. Start Konqueror by clicking the house icon in the panel. The contents of your home directory are then displayed.

The file manager window consists of the menu bar at the top, the toolbar, and the location bar. The lower part of the window is split vertically into the navigation panel and the main window, which displays the contents.

![Image: The File Manager Konqueror]

**Figure 1.3:** The File Manager Konqueror
1.3.1 The Konqueror Menu

‘Location’ Using ‘Location’, open additional Konqueror windows. If you click ‘New Window’, your home directory is displayed in a new window. ‘Duplicate Window’ produces a second window with the same content. You can also send a file or a link (using the browser function) by e-mail. If you click one of these menu items, the KMail composer opens. Specify the recipient and compose a text. Depending on the selected item, the file is already attached or the link is displayed in the e-mail body. You can also print directly from this menu.

‘Edit’ Most items under ‘Edit’ only become active if you select an object in the main window. Apart from the standard editing functions like cutting, copying, pasting, renaming, moving to the trash, and deleting, there is also the ‘Create New’ item, which can be used to create directories, files, and devices. Another item in the ‘Edit’ menu lets you view and change the properties of files and directories and their permissions. With it, grant or deny the owner, a group, or all users read, write, and execute permissions. In the main window, select one or several files by moving the mouse pointer over them while keeping the left mouse button pressed or by using the ‘Select’ menu.

‘View’ Use the ‘View’ menu to change views. If a directory has many objects in it, the text view or the tree view may be more efficient. To view HTML pages, activate ‘Use index.html’. If a directory contains a file with this name, Konqueror loads and displays it.

To influence the way in which the main window displays directory contents, use the items ‘Icon Size’, ‘Show Hidden Files’, ‘Sort’, and ‘Preview’. In addition, use ‘Configure Background’ to set the main windows’s background to a certain color or use an image for it.

‘Go’ The ‘Go’ menu contains the navigation functions ‘Up’, ‘Back’, ‘Forward’, and ‘Home Page’. However, the same functions can be accessed more quickly and conveniently through the toolbar. You can also call applications from this menu and open all folders that have an icon on the desktop. In the lower part of the menu, find a list of the recently-viewed directories or links.

‘Bookmarks’ Bookmarks can be made for Internet addresses (URLs) and paths to specific files or directories on your host. If you select ‘Add Bookmark’, the current content of the location bar is saved as a bookmark. To access this
location, simply click this bookmark. For practical reasons, arrange bookmarks in folders. The SUSE folder already exists. This folder contains bookmarks of important SUSE web pages. ‘Edit Bookmarks’ opens the bookmark editor in which to perform tasks like deleting obsolete bookmarks, renaming bookmarks, and moving bookmarks from one folder to another.

‘Extra’ This menu includes entries for a variety of items, such as ‘Run Command’, ‘Open Terminal Window’, and ‘Search for Files’. You can use ‘Filter View’ to limit the view to certain types of files. For example, one of your directories may hold graphics files of different formats, but you only want to see those in PNG format. You could then use this submenu item to hide all files that are not in PNG format.

Selecting ‘Create Image Gallery’ causes Konqueror to search the directory for any image files. The program then creates thumbnail pictures of them and combines these into an HTML page. A dialog box prompts you to set the options for the HTML page, such as the font and the number of thumbnails per line.

‘Settings’ Use the ‘Settings’ menu to configure the look and feel of Konqueror. If you do not want a menu, select ‘Hide Menubar’. Press (Ctrl)-M to display it again. The ‘Toolbars’ submenu allows you to hide or display other elements of the file manager.

View profiles can be used to change the view according to predefined usage patterns. To switch between the available profiles, select ‘Load View Profile’. One of the profiles is the web browser profile, which is used automatically when you click the Konqueror icon in the panel. Add your own profiles by selecting ‘Manage View Profiles…’. In addition, you can specify individual keyboard shortcuts with ‘Configure Shortcuts…’, customize the toolbar with ‘Configure Toolbars’, and configure global settings for the file manager with ‘Configure Konqueror’.

‘Window’ The ‘Window’ menu allows you to split the main window horizontally and vertically. It also allows you to manage the tabbed subwindows within the main window by opening a new tab or closing a tab, duplicating an existing tab, or detaching a tab into a separate window.

‘Help’ Under the ‘Help’ menu, access the Konqueror handbook or the ‘What’s This?’ function. Normally this function can also be accessed with the question mark symbol at the top right in the title bar. The mouse pointer is then displayed with a question mark. If you click an icon, a brief help text is displayed (if there is one available). The ‘Help’ menu also provides a short in-
1.3.2 The Toolbar

The toolbar provides quick access to frequently-used functions that can also be accessed via the menu. If you let the mouse pointer rest above an icon, a short description is displayed. Right-click a free space in the toolbar to open a menu with which to change the position of the toolbar, switch from icons to text, change the icon size, and display or hide the individual bars. Start the configuration dialog with ‘Configure Toolbars’. To the right, the toolbar features the Konqueror icon, which is animated while a directory or web page is loaded.

1.3.3 The Location Bar

The location bar is preceded by a black symbol with a white X. If you click this icon, the contents of the line are deleted, allowing entry of a new location. Valid locations can be path specifications, like the one that appears when the home directory is displayed, or web page URLs. After entering an address, press [Enter] or click ‘Go’ to the right of the input line. Access directories or web pages visited recently via the black arrow to the right of the location bar. This function saves some typing if you need to access certain contents repeatedly. If there are locations that you need to view again and again, it is more convenient to create bookmarks for them.

1.3.4 The Main Window

The main window displays the content of the selected directory. If you click an icon, the respective file is displayed in Konqueror or loaded into the respective application for further processing. Clicking an RPM package lists the contents of the file. Selecting ‘Install package with YaST’ prompts you to enter the root password after which the package is installed.

If you right-click an icon, a menu opens. The kind of menu displayed depends on the file type and offers common actions, such as ‘Cut’, ‘Copy’, ‘Paste’, and ‘Delete’. Use ‘Open with…’ to select the application with which to open the file from a list of suitable programs.
The quickest way to perform many actions is the drag and drop method. For example, easily move files from one Konqueror window to another by simply dragging them there while pressing the left mouse button. Subsequently, you are asked whether the objects should be moved or copied.

### 1.4 Important Utilities

The following pages introduce a number of small KDE utilities intended to assist in daily work. These applications perform various tasks, such as managing your keys for encrypting and signing files and e-mail messages, managing your clipboard, formatting floppy disks, compressing and decompressing diverse file archive types, and sharing your desktop with other users.

#### 1.4.1 Creating an Image Gallery

If you have a large collection of images in a directory, you may find it difficult to manage them. Konqueror can help you by creating an HTML file with thumbnails. Open the respective directory in Konqueror and select ‘Tools’ → ‘Create Image Gallery…’. A dialog opens in which to specify the page title, the number of thumbnails per line, the background and foreground colors, and some other details. When you are finished, select ‘Create’ to start the action. By default, Konqueror creates a file named `index.html`. It can be opened with Konqueror and presents you with a well-arranged thumbnail index of your image collection. To view an image in full size, simply click the corresponding thumbnail.

#### 1.4.2 KInternet — Connecting to the Internet

To surf the Internet or send and receive e-mail messages, connect a modem or an ISDN or ethernet card to your machine and configure it. This can be done with the help of the system assistant YaST. As soon as the respective device has been configured correctly, control the Internet dial-up with KInternet.

On start-up, KDE loads KInternet. The program checks whether an Internet connection can be established. If this is possible, the application icon, a plug, automatically appears in the right part of the KDE panel. The following is an overview of the icons and their meanings:

- 🌐 Currently there is no connection to the Internet.
The connection is just being established or terminated.

The connection has been established.

Data is transmitted to or from the Internet.

An error has occurred. If a connection has already been configured with YaST, use ‘View Log ...’ to identify the reason for the error. The menu can be accessed by right-clicking the KInternet icon.

The connection is not yet active, but will be established as soon as a request is made.

Right-click KInternet to access a menu for configuring KInternet. To configure your access, select ‘Settings ...’ → ‘Configure with YaST ...’. After entering the root password, YaST starts. Depending on the access type, start the modem, ISDN, network, or DSL configuration of YaST to select a provider from a list.

KInternet can do even more: if the option ‘Channel Bundling’ is activated in YaST, a second ISDN channel can be added to an existing connection with ‘Add link’. This doubles the transfer rate (although at a higher price). Activate channel bundling if you need to download large files. The activated channel bundling is evident from the red plus symbol at the top left corner of the KInternet icon.

Users who want to establish Internet connections automatically can use dial on demand (DoD). If this mode is selected, KInternet automatically connects to your Internet service provider (ISP) as soon as a request is submitted. After a certain time-out, the connection is terminated. A DoD connection is evident from the blue D at the bottom right corner of the KInternet icon.

---

**Caution**

**Beware of Soaring Costs**

Note that DoD only makes sense if you have a flat rate Internet account. If that is not the case, connecting and disconnecting all the time can become very costly.
1.4.3 The Download Manager KGet

KGet is the download manager for KDE. It manages your transfers in a window. Stop, resume, delete, queue, and add transfers.

Adding Transfers

Start KGet by pressing \(\text{Alt} + \text{F2}\) and entering the command \texttt{kget}. When the program is started for the first time, a dialog is displayed. Confirm this dialog to integrate KGet in Konqueror. When you close the dialog, KGet is integrated in the system tray of the panel as an icon with a downward arrow.

Click this arrow to open the dialog displaying your transfers. To add a transfer to the list, select ‘File’ → ‘Paste’. A dialog opens. Enter a URL in the input field and confirm with ‘OK’. Then specify the location for saving the downloaded file. After all information has been entered, the entry for the transfer is added to the main window of KGet and started.

Another way to add a transfer is by means of drag and drop. Simply drag a file, for example, from an FTP server, from Konqueror and drop it in the main window.

Timer-Controlled Transfers

You can also instruct KGet to perform your transfers at a specific time. Activate ‘Options’ → ‘Offline Mode’. All transfers inserted from this point are not started immediately but queued. To start the clock, double-click the respective entry. A dialog opens. Select ‘Advanced’. The dialog is expanded by the settings needed for starting the transfer at a certain time. Enter the day, month, year, and time. Then close the window.

After making the desired settings for all your transfers, set KGet back to the online mode by deactivating ‘Options’ → ‘Offline Mode’. The transfers should start at the specified times.

Settings

In ‘Settings’ → ‘Configure KGet ...’, set preferences for the connection, determine directories for specific file extensions, and specify other settings.
1.4.4 SuSEWatcher

SuSEWatcher is a program that is integrated in the system tray of the panel. It checks for new updates and new hardware. To be able to find any new updates, it requires an online connection. The program SuSEWatcher is included in the package kdebase3-SuSE. The status of SuSEWatcher is displayed in the panel by icons in different colors.

When you click the icon in the panel, a window opens, informing you about the status of your online updates and the availability of any new updates. You can also launch the check manually by clicking ‘Check for updates’. Start the online update by selecting ‘Start online update’ and entering the root password. The YaST Online Update window is displayed.

1.4.5 The Clipboard Klipper

The KDE program Klipper serves as a clipboard for selected text, normally marked by keeping the left mouse button pressed. This text can be transferred to another application by moving the mouse pointer to the target location then pressing the middle mouse button (on a two-button mouse, press both buttons simultaneously). The text is copied to the selected location from the clipboard.

By default, Klipper is started when KDE is loaded and appears as a clipboard icon in the panel. View the contents of the clipboard by clicking this icon. The Klipper context menu and the last seven entries, also referred to as the history, are displayed. See Figure 1.4 on the next page. If an extensive text was copied to Klipper, only the first line of the text is displayed. The most recent entry is listed on top and is marked as active with a black check mark. To copy an older text fragment from Klipper to an application, select it by clicking it, move the mouse pointer to the target application, then middle-click.

As well as the contents of the clipboard, the context menu features the following menu items:

**Enable Actions**  If you click this, a black check mark is displayed in front of it. For example, if you mark a URL with the mouse when actions are enabled, a window opens, enabling you to select a browser for displaying this URL. Click ‘Actions Enabled’ to disable this function.

**Clear Clipboard History**  Deletes all entries from the clipboard.
Configure Klipper... This opens the Klipper configuration dialog. Control the program with keyboard shortcuts or use regular expressions. Check the Klipper handbook for details. Former Windows users may appreciate the option for activating the keyboard shortcuts \( \text{Ctrl}-\text{C} \) and \( \text{Ctrl}-\text{X} \) for cutting and \( \text{Ctrl}-\text{V} \) for pasting under the ‘General’ tab. To use this feature, activate the entry ‘Synchronize contents of the clipboard and the selection’ in ‘Clipboard/Selection Behavior’. Subsequently, use the mouse or the keyboard shortcuts to which you are accustomed.

Help This item opens a submenu from which to open the Klipper handbook, send a bug report to the developers, and view information about Klipper and KDE.

Quit If you click ‘Quit’, a dialog is displayed asking whether Klipper should be started automatically the next time you log in. If you click ‘No’, start the program from the main menu the next time you want to use it. If you click ‘Cancel’, the program is not terminated.

1.4.6 Monitoring Print Jobs

Start KJobViewer from the main menu or with the command `kjobviewer` from the command line. This program assists with monitoring print jobs. Print jobs are placed in a queue from which they are sent to the printer consecutively. As long as your jobs are not printed, edit them with the ‘Jobs’ menu or by clicking the respective icon. See Figure 1.5 on the facing page.
The KDE Desktop

Figure 1.5: Monitoring Print Jobs with KJobViewer

If, for example, you want to check if you sent the correct document to the printer, you can stop the job and resume it if you decide to print it. Remove your own print jobs from the queue with ‘Remove’. To change the printer, select a different printer with ‘Move to Printer ...’.


‘Filter’ enables you to switch between various printers, toggle completed jobs, and limit the view to your own print jobs by selecting ‘Show Only User Jobs’. The current user is then displayed in the top right field.

‘Settings’ → ‘Configure KJobViewer ...’ opens a configuration dialog. Here, determine the maximum number of print jobs to display. Enter a number in the field or use the slider to the right to determine a value. Press ‘OK’ to save the setting or ‘Cancel’ to exit the dialog without saving.

The icons in the toolbar correspond to the functions you can access by way of the menu. A help text explaining the function is displayed when you move the mouse pointer over one of the icons.

The job list consists of eight columns. The job ID is automatically assigned by the print system to identify the various jobs. The next column contains the login of the user who sent the job followed by the file name of the document. The status column indicates whether a job is still in the queue, currently being printed, or already completed. Next, the size of the document is displayed in kilobytes and
number of pages. The default priority of 50 can be increased or reduced if nec-
ecessary. Billing information can be cost centers or other company-specific infor-
mation. If you right-click a job in the list, the ‘Jobs’ menu opens under the mouse
pointer, allowing you to select an action. Only a few functions are available for
completed jobs. If you activate ‘Keep window permanent’, KJobViewer opens
automatically when you log in the next time. You can also start KJobViewer us-
ing the printer icon in the panel.

1.4.7 Formatting Floppy Disks with KFloppy

KFloppy is the floppy disk formatter of KDE. Start the program from the main
menu or from the command line with the command kfloppy. KFloppy opens a
dialog, shown in Figure 1.6 on the next page, in which to specify a number of set-
tings. Under ‘Floppy Drive’, select the primary or the secondary drive, assuming
your machine has two floppy disk drives. The default setting for the size is ‘3.5”
1.44 MB’, which is the most commonly used floppy disk type. The setting for the
file system is very important. Choose between the Linux format ext2 and MS-
DOS. If you select MS-DOS, you will be able to read and write the floppy disk on
a Windows machine.

In the center, select ‘Quick Format’ or ‘Full Format’. The quick format procedure
merely rewrites the file system and deletes all data. The full format procedure
rewrites all tracks and sectors and is able to detect and mark bad sectors. Sectors
marked as bad are not used for writing data. Select ‘Verify Integrity’ to have the
formatting checked and verified upon completion. If you activate ‘Volume Label’,
designate a name for the floppy disk in the input field below.

After making all settings, click ‘Format’. You are warned that all data on the disk
will be lost and prompted to confirm. KFloppy informs you if any problems occur
during the formatting procedure, including information about any bad sectors.

Click ‘Help’ to access a short menu that offers the KFloppy handbook. Addition-
ally use it to send a bug report or other concerns to the developers of KFloppy.
Selecting ‘About KFloppy’ accesses information about the version, authors, trans-
lation, and license. ‘About KDE’ provides information about KDE and web pages
of the KDE developers. Exit KFloppy by clicking ‘Quit’.

1.4.8 Ark: Displaying, Decompressing, and Creating Archives

To save space on the hard disk, use a packer that compresses files and directo-
ries to a fraction of their original size. The application Ark can be used to man-
Figure 1.6: The Floppy Disk Formatter KFloppy

age such archives. It supports common formats, such as zip, tar.gz, tar.bz2, lha, rar, and some others.

Start Ark from the main menu or from the command line with the command ark. If you already have some compressed files, move these from an open Konqueror window to the Ark window to view the contents of the archive. To view an integrated preview of the archive in Konqueror, right-click the archive in Konqueror and select ‘Preview in Archiver’. Alternatively, select ‘File’ → ‘Open’ in Ark to open the file directly. See Figure 1.7 on the following page.


To create a new archive, select ‘File’ → ‘New’. Enter the name of the new archive in the dialog that opens, and specify the format using ‘Archive Format’. After confirming with ‘Save’ or by pressing Enter, Ark opens an empty window. You can drag and drop files and directories from the file manager into this window.
As the final step,Ark compresses everything into the previously selected archive format. For more information about Ark, select ‘Help’ → ‘Ark Handbook’.

### 1.4.9 Desktop Sharing

You can share your desktop with other users working on other hosts. Desktop sharing makes use of the RFB protocol, more commonly referred to as VNC. This feature makes a Linux desktop available to clients using other operating systems that support VNC.

To grant trustworthy users access to your desktop, send them a password. This can be done by means of an invitation. Start the Control Center from the main menu and select ‘Desktop Sharing’ in the ‘Internet & Network’ module.

**Caution**

**Desktop Sharing and Security**

Make sure you send invitations only to people you consider absolutely trustworthy. The recipient of an invitation has unrestricted access to all your personal data. Because of this security concern, a VNC connection is not kept alive for more than one hour.

Select ‘Create & manage invitations’ and, in the dialog that opens, choose between ‘Create Personal Invitation...’ and ‘Invite via Email’. In the first case, the
The KDE Desktop program generates an invitation that includes the IP address of the host, the password, and expiry time. This data must be given to the recipient manually. If you select ‘Invite via Email’, all the necessary data is transmitted by e-mail. KMail starts automatically and generates an e-mail message with the needed data (host, password, and expiry). If the recipient also uses KDE and KMail, he or she can connect to your desktop simply by clicking the link provided at the end of the message. Users of other desktops need to start a suitable VNC viewer and copy the link into its address field. KDE informs you whenever a VNC connection is requested, asking you whether to allow or deny the connection.

![Desktop Sharing - Control Center](image)

**Figure 1.8: Desktop Sharing with Invitation by E-Mail**

### 1.4.10 Screenshots with KSnapshot

With KSnapshot, create snapshots of your screen or individual application windows. Start the program from the main menu or from the command line with the command `ksnapshot`. The dialog window of KSnapshot consists of two parts.
See Figure 1.9. The upper area contains a preview of the current screen and three buttons for creating and saving the screenshots. In the lower part of the window, you can set some options to decide how the screenshot should be created.

**Figure 1.9: KSnapshot**

To take a screenshot, use ‘Snapshot delay’ to determine the period in seconds to wait between when ‘New Snapshot’ is clicked and the actual creation of the screenshot. If ‘Only grab the window containing the pointer’ is active, only the window currently under the pointer is “photographed.” By default, the program creates a shot of the entire screen. To change this, you can select an item from ‘Screenshot Mode’. To save the screenshot to a file, select ‘Save as…’ and set the directory and file name in the dialog that opens. To print the screenshot right away, select ‘Print’.

### 1.4.11 The Information Manager Kontakt

The application Kontakt bundles the display of e-mails, notes, contacts, news, weather, and a calendar into one window. Open it by pressing Alt-F2 and entering kontakt. See Figure 1.10 on the facing page.

Select ‘Settings’ to configure Kontakt and its individual components. To decide which components should be used, select ‘Choose Components…’. Make settings for individual components by selecting the ‘Configure Kontakt…’ menu. Settings for these components are the same as those for the individual programs.
that correspond to them. Therefore, if you are unsure about specific settings, consult the manuals of those separate programs.

‘Configure General View…’ lets you decide how components should display their information in the general view (star icon). For instance, you can configure the KDE address book component to display all birthdays or anniversaries or decide which directories should be listed in the summary.

1.4.12 Chatting With Friends: Kopete

Kopete is an online messenger application allowing multiple partners connected to the Internet to chat with each other. Kopete currently supports all common messenger protocols, such as ICQ, MSN, Yahoo, SMS, Jabber, and IRC.

Configuring Kopete

Configure Kopete by entering your personal user data. Click ‘Settings’ → ‘Configure Kopete’. ‘Connections’ shows all currently available protocols. Check the desired connection type to activate it.

With ‘Accounts’, enter your user data. You must register with a provider offering instant messaging services before using such service. Click ‘New’ to open a configuration assistant that can assist you in completing your user profile.
The next step lists the available messaging services. Select the service with which you have registered and click ‘Continue’. In the next step, enter the user data received upon registration with the messaging service. This usually consists of the nickname or e-mail address and the password you chose. Complete the configuration of the messenger account by clicking ‘Finish’.

![Kopete Configuration Panels](image)

**Figure 1.11: Kopete Configuration Panels**

The next item in the configuration dialog is ‘Appearance’. It influences how Kopete is displayed. The tab ‘Emoticons’ provides a selection of various types of smileys.

The tabs ‘Chat window’ and ‘Colors & Fonts’ offer the possibility to adjust the appearance of the chat windows for communication with other participants. Choose between the classic themes of the corresponding providers or to create a custom theme by adjusting the font or color to personal preference.

**Adding Contacts**

It is necessary to add contacts in order to chat with a participant. If you have already created an account on another PC, this data is readily imported and automatically added to your contact list. To create a contact entry manually, click ‘File’ → ‘Add contact’.
A new assistant appears automatically that will accompany you until completion. However, consider that must be online to add a contact to your list.

Adding Groups
Access this with ‘File’ → ‘Create New Group’. Name the group and confirm this with ‘OK’. A new folder appears in the contact list that can be used to store the desired contacts. You can drag and drop contacts into the desired folder. This allows grouping contacts for a better overview.

Using Kopete
It is necessary to establish a connection to the Internet to be able to chat with other participants. When this is done, clicking ‘File’ → ‘Connection’ → ‘Connect All’ then establishes a connection between Kopete and the selected messaging service.

The main application windows features a list of contacts. When you right-click a contact marked as online, a menu opens with various options. Send that person a message or start a chatting session. A chat allows invitation of other participants for real-time discussion. The connection to all other participants is closed when the creator of the chat session leaves the room.

Files can be transferred comfortably with an instant messenger by right-clicking a user name. Many options, like ‘Delete Contact’, ‘Show User Information’, ‘Block User’, and ‘Send File’, can be found here. Clicking ‘Send File’ opens a dialog for selecting the desired file. Confirming with ‘OK’ sends a dialog to the receiving user asking whether he wants to accept the file. If he accepts, the file transfer starts.

Figure 1.12: The Main Kopete Application
1.4.13 Font Administration with KFontinst

By default, SUSE LINUX provides various fonts commonly available in different file formats (Bitmap, TrueType, etc.). These are commonly known as System Fonts. Users can additionally install their own fonts from various collections on CD-ROM. Such user-installed fonts are, however, only visible and available to the corresponding user.

The KDE control center provides a comfortable tool for administering system and user fonts. It is shown in Figure 1.13.

To check which fonts are currently available, type the URL `fonts:/` into the address field of a Konqueror session. This displays two windows: Personal and System. User-installed fonts are installed to the folder Personal. Only root can install to the System folder.

To install fonts as a user, follow these steps:

1. Start the Control Center and access the appropriate module with ‘System Administration’ ➝ ‘Font Installation’.
2. Choose ‘Add Fonts’ from the icon bar or from the menu available when right-clicking the list.
3. In the dialog that opens, select one or more fonts for installation.

Figure 1.13: Font Administration from the Control Center
4. The marked fonts are then installed to your personal font folder. Selecting a font shows a preview.

To update system fonts, first select ‘System administration mode’ and enter your root password then proceed as described for user font installation.

The feature for deactivating installed fonts is very useful. They are not removed but are made unavailable to the system. Select the ‘deactivate’ icon or its counterpart from the context menu. This makes the green checkmark disappear. The new settings become active after confirmation with ‘Apply’. The deactivated fonts are then no longer available to applications. This reduces the size of font lists displayed in applications.
GNOME (GNU Network Object Model Environment) is a fast Linux desktop. The aim of its development was to make the user interface more uniform while streamlining the various aspects of the look and feel. The basic components for window management and other components enable data sharing among various applications and are based on a uniform operating concept and help system.
2.1 The Desktop

The most important elements of the GNOME desktop are the icons on the desktop, the panel at the lower border, and the desktop menu. The mouse is your most important tool.

2.1.1 The Icons

By default, the desktop features three symbols: your personal folder, the start dialog for the configuration of the desktop, and the trash can. If you double-click your personal folder, Nautilus starts and displays your home directory. More information about the use of Nautilus is available in File Management with Nautilus on page 49. All files deleted with Nautilus are sent to the trash can.

Right-clicking an icon displays a menu offering file operations, like copying, cutting, or renaming. Selecting ‘Properties’ from the menu displays a configuration dialog. The title of an icon as well as the icon itself can be changed with ‘Use custom icon’. The ‘Emblems’ tab offers the possibility to add graphical descriptive symbols to the icon. The ‘Permissions’ tab provides access to the access, read, and write permission settings for this file for the user, the group, or others. The ‘Notes’ tab offers the management of comments. The menu for the trash can additionally features the ‘Empty Trashcan’ option. This deletes its contents.

To remove an icon from the desktop, simply move it into the trash can. However, be careful with this option — if you throw folder icons or file icons into the trash can, the actual data is deleted. If the icons only represent links to a file or to a directory, only the links are deleted.

To create a link on the desktop to a folder or a file, access the object in question with Nautilus. Right-click the object and select ‘Make Link’. Drag the link from the Nautilus window and drop it on the desktop.

2.1.2 The Desktop Menu

Right-clicking a free spot on the desktop displays a menu with various options. Select ‘New Folder’ to create a new folder. Create a launcher icon for an application with ‘New Launcher’. Provide the name of the application and the command for starting it then choose an icon to represent it. It is also possible to change the desktop background or to reset it to its default setting.
2.1.3 The Panel

The panel contains the window icons of all started applications in the taskbar. If you click the name of a window in the taskbar, it is moved to the foreground. If the program is already in the foreground, a mouse click minimizes it. Clicking a minimized application reopens the respective window.

Beside the taskbar, the ‘Workspace Switcher’ provides access to additional work areas. These virtual desktops provide extra space in which to arrange open applications and windows. For example, put an editor on one workspace, some shells on another, and your e-mail application and web browser on a third.

If you right-click an empty spot in the panel, a menu opens, offering help, information, and commands for GNOME and panels. Select ‘Properties’ to open a configuration dialog in which to change the position and background of the panel. If desired, create additional panels or add launchers, tools, and various applets to the existing panels with ‘Add to Panel’. Use drawers to organize your favorite applications or important documents. The contents are only displayed when the drawer is opened with a single click. Right-click the drawer and select ‘Properties’ to modify its size and appearance. Click the icon to change it. Remove panel elements by right-clicking the respective icons and selecting ‘Remove’.

2.1.4 The Main Menu

Open the main menu by means of the icon to the far left of the panel. Apart from the applications, which are organized in categories, find default functions, such as ‘Log out’ and ‘Lock screen’. Use ‘Open Recent’ to gain quick access to recent files. Use ‘Search for Files’ to find files.

With ‘Run Program …’, enter and run a command, for example, for starting a program instead of navigating through the various program menus. From the main menu, you can also start the ‘GNOME Control Center’ for configuring the desktop or YaST for installing additional software.

2.1.5 Handling Floppy Disks, CDs, or DVDs

To access floppy disks, CDs, or DVDs, insert the medium in the appropriate drive. Right-click an empty spot of the desktop and select the desired medium from the ‘Drives’ list. A floppy disk or CD icon appears. Double-clicking the icon launches Nautilus, which displays the contents of the medium. Copy files to your personal home directory by dragging and dropping. Copy files to a floppy disk in the same way.
Caution

Do not simply remove floppy disks from the drive after using them. Floppy disks, CDs, and DVDs must always be unmounted from the system first. Close all Nautilus sessions still accessing the medium then right-click the icon for the medium and select ‘eject’ from the menu. Then safely remove the floppy disk or CD (the tray opens automatically). The icon disappears from the desktop.

Caution

Floppy disks can also be formatted from the floppy disk menu. In the dialog, choose the format and density of the floppy disk. In ‘file system type’, choose between ‘Linux native (ext2)’, the file system for Linux, and ‘DOS (FAT)’, because Windows cannot access Linux file systems. Help provides some instructions for the tool.

2.2 Settings

The GNOME desktop can be customized according to your preferences and needs. Click the ‘Start Here’ icon on the desktop. If this icon is not visible, start Nautilus by right-clicking the desktop then selecting ‘New Window’. Under ‘Location:’, enter preferences://. Open the various configuration dialogs by double-clicking the respective icons.

Note

In the individual modules, access specific help for the options with ‘Help’. The system immediately adopts every change made in a configuration module.

Note

2.2.1 Keyboard

In the ‘Keyboard’ module, determine settings such as the repeat rate and sound events associated with your keyboard. The module consists of the ‘Keyboard’ and ‘Audio’ tabs. Use the ‘Audio’ tab to configure an audio signal for your keyboard. For audible notification when a wrong key is pressed, activate the corresponding radio button. Exit the ‘Keyboard’ module with ‘Close’ or go the accessi-
bility module with ‘Accessibility’. The functionality of this module is described in Accessibility on page 47.

2.2.2 Mouse Configuration

The mouse configuration consists of three tabs: ‘Buttons’, ‘Cursor’, and ‘Motion’. The configuration options of the ‘Buttons’ tab refer to the ‘Mouse Orientation’. Left-handed users should activate ‘Left-handed mouse’ to swap the right and left mouse buttons. Use the slider to determine the maximum delay (in seconds) between two clicks that the system should interpret as a double-click.

The appearance and size of the cursor can be changed under the ‘Cursor’ tab. Four different settings are available. Changes are not activated until the next login. Under ‘Locate Pointer’, activate an option that causes the cursor to be highlighted when you press Ctrl, making it easier to find. Under ‘Movement’, set the ‘Acceleration’ and ‘Sensitivity’ of the screen cursor.

2.2.3 Menus and Toolbars

The settings in this module affect the menus and toolbars of all GNOME-compatible applications. Select for toolbar icons to be displayed as ‘Text Only’, ‘Icons Only’, ‘Text Beside Icons’, or ‘Text Below Icons’. The default setting is ‘Text Only’.

Activate ‘Toolbars can be detached and moved around’ to allow the detachment of the toolbar from all other window elements and allow its free positioning on the desktop. This makes a grabbing area appear on the left side of the toolbar. Clicking and holding this area relocates the toolbar.

Every menu entry in any application menu can be displayed with the corresponding icon. Activating ‘Show icons in menus’ tests the settings with the provided example menu.

2.2.4 Screensaver

The module for configuring the screensaver is subdivided into two tabs: ‘Display Modes’ and ‘Advanced’. Select the screensaver in ‘Display Modes’. The ‘Advanced’ tab contains a few special options that normally do not need to be modified.
Select the screen saver mode under the ‘Display Modes’ tab. Choose from ‘Random Screen Saver’ (random selection of screen savers from a custom-defined list), ‘Only One Screen Saver’, ‘Blank Screen Only’, or ‘Disable Screen Saver’.

Select one or more screensavers from the list for the operating modes ‘Only One Screen Saver’ or ‘Random Screen Saver’. The currently selected screensaver is displayed in the small preview window. The ‘Preview’ button launches a fullscreen preview of that screensaver, which can be aborted by pressing any key. Select the previous or following screensaver for preview by clicking the corresponding triangles below the selection list.

In the last step, determine after how long the screen should be made completely black (‘Blank After’), the screensaver module should be changed (‘Cycle After’), or the screen should be locked (‘Lock Screen After’). All time references are given in minutes.

### 2.2.5 Windows

This module controls the behavior of application windows. Determine how the window should react to contact with the mouse pointer or to double-clicks on its title and define the key to hold for moving an application window.

When several application windows populate the desktop, the active one, by default, is the one last clicked. Change this behavior by activating ‘Select windows when the mouse moves over them’. If desired, activate ‘Raise selected window after an interval’ and adjust the latency time with the slider. This activates a window only when the cursor was placed within the window for a time exceeding the set latency.

Application windows can be shaded by double-clicking the title bar, leaving only the title bar visible. This saves space on the desktop and is the default behavior. It is alternatively possible to set windows to maximize when the title bar is double-clicked.

With the radio buttons, select the modifier key to press for moving a window. The possible choices are Ctrl, Alt, and the (Windows) key.

### 2.2.6 Background

Determine a background for your desktop. By default, the changes made here are applied to all virtual desktop. If you do not want any background picture, click ‘No Picture’ and define a background style. The drop-down menu offers a
horizontal gradient, a vertical gradient, or no gradient at all. Use ‘Color’ to define the desired colors in the color editor.

To use an image file as a background picture, drag it from the file manager and drop it in ‘Select picture’. Alternatively, click ‘Select picture’ to open a dialog in which to select the desired image.

‘Picture Options’ determines what processing steps should be applied to the selected image to adapt it optimally to the current screen resolution. The options are ‘Wallpaper’, ‘Centered’, ‘Scaled’, and ‘Stretched’.

### 2.2.7 Font

This module determines the font to use for the desktop. In a second step, enable optional effects for the improvement of the font quality. The upper part of the dialog window shows the fonts selected for ‘Application font’, ‘Desktop font’, ‘Window title font’, and ‘Terminal font’. Click one of the buttons to open a selection dialog in which to set the font family, style, and size. The options for ‘Font Rendering’ and the additional configuration options accessible through ‘Details’ are set to optimal values by default.

### 2.2.8 Theme

The style for all control elements on the desktop and of GNOME applications is set here. Choose from various preinstalled themes. Selecting a style in the list overview applies it automatically. ‘Details’ opens another dialog in which to customize the style of single desktop elements, like window content, window borders, and icons. Making changes and leaving the dialog with ‘Close’ switches the theme to ‘Custom theme’. Click ‘Save theme’ to save your modified theme under a custom name. The Internet and other sources provide many additional themes for GNOME as .tar.gz files. Install these with ‘Install theme’.

### 2.2.9 Accessibility

The settings of this module facilitate the use of the keyboard for users with motion impairments. The module consists of the three tabs ‘Basic’, ‘Filters’, and ‘Mouse’. Before modifying settings, activate ‘Enable keyboard accessibility features’.
Features The keyboard accessibility functions can be deactivated automatically after a certain time. Set an appropriate time limit measured in seconds with the slider. The system can additionally provide audible feedback when the keyboard accessibility functions are activated and deactivated.

Enable Sticky Keys Some keyboard shortcuts require that one key is kept pressed constantly (this applies to (Alt), (Ctrl) or (Shift)) while the rest of the shortcut is typed. When “sticky” keys are used, the system regards those keys as pressed after being hit once. For an audible feedback generated each time a modifier key (Ctrl) or (Alt) is pressed, activate ‘Beep when modifier is pressed’. If ‘Disable if two keys pressed together’ is selected, the keys do not stick anymore once two keys are pressed simultaneously. The system then assumes that the keyboard shortcut has been completely entered.

Repeat Keys Activate ‘Repeat Keys’ to make settings with sliders for ‘Delay’ and ‘Speed’. This determines how long a key must be pressed for the automatic keyboard repeat function to be activated and at what speed the characters are then typed.

Test the effect of the settings in the field at the bottom of the dialog window. Choose parameters that reflect your normal typing habits.

Enable Slow Keys To prevent accidental typing, set a minimum time limit that a key must be pressed and held before it is recognized as valid input by the system. Also determine whether audible feedback should be provided for keypress events, accepted keypresses, and the rejection of a keypress.

Enable Bounce Keys To prevent double typing, set a minimum time limit for accepting two subsequent keypress events of the same key as the input of two individual characters. If desired, activate audible feedback upon rejection of a keypress event.

Toggle Keys It is possible to request audible feedback from the system when a keycap modifier key is pressed.

Mouse Activates the keyboard mouse — the mouse pointer is controlled with the arrow keys of the number pad. Use the sliders to set the maximum speed of the mouse pointer, the acceleration time until the maximum speed is reached, and the latency between the pressing of a key and the cursor movement.
2.2.10  Keyboard Shortcuts

Use this module to manage global keyboard combinations. It is possible to determine the keyboard combinations to use during text input and those for objects on the desktop.

The list overview window displays a list of all currently available actions along with their keyboard shortcuts. Deactivate or change a keyboard shortcut by clicking the corresponding shortcut entry. Then enter a new shortcut or delete the current one with [Delete]. All changes take effect immediately. Restore the current keyboard shortcut by clicking its entry and leaving the dialog with ‘Close’.

2.2.11  Sound (system alerts)

This module allows the association of certain system events and application alerts with characteristic audio signals. The dialog box consists of two tabs (‘General’ and ‘Sound Events’). The two check boxes in the ‘General’ tab must be activated to use audio signals for certain desktop events.

In the second tab, determine which events and application alerts should be associated with which sounds. All sound associations already defined for applications are listed. Test a sound by first selecting the corresponding notice in the ‘Event’ column then clicking ‘Play’. Change the sound by clicking ‘Event’ then ‘Browse’. The dialog that appears provides a list of files from which to choose. Close it with ‘OK’.

2.3  File Management with Nautilus

Nautilus is the file manager and viewer of GNOME. The following section provides an overview of the basic functions of Nautilus as well as a few tips on its configuration. More information can be found in the help pages for Nautilus.

2.3.1  Navigating in Nautilus

Figure 2.1 on the following page shows the standard window of Nautilus. To open folders or files double-click the icons. Folders will be displayed in a new window in addition to the parent folder. Alternatively, set Nautilus to behave like a browser with the same navigation functionality. Right-click a folder and select ‘Open in File Browser’.
The standard window is shown in Figure 2.1. Use the icons in the toolbar to move forward and backward, to move one level up in the directory tree, to stop loading a document, to reload the document, or to go to the preferred starting page. ‘Location’ shows the path to the current directory or to the current file. A different path can be directly entered here. ‘Notes’ is useful for managing personal information about objects. These notes are saved along with the object.

Nautilus tries to select appropriate icons for objects according to their associated file information. Image and text files are shown as a thumbnail. Double-clicking shows the file in a viewer.

2.3.2 File Management

Nautilus supports dragging and dropping for managing files. To move files from one directory to another, use ‘New Window’ from the context menu or the ‘File’ menu in Nautilus to open two windows. Access the path of the original location of the objects in one window and access the destination path for those files in the second window. To move the files, drag the files from one window to the other and drop them there. Copying files is a little more complicated. Right-click the object to copy and select ‘Duplicate’. Then move the copy to the new directory.
The context menu that appears when right-clicking an object provides functions for renaming files and other tasks.

### 2.3.3 Configuring Nautilus


The ‘Views’ dialog allows switching the ‘Default View’ between ‘Icon View’ and ‘List View’. A sorting order can be set for any of these options.

The ‘Behavior’ dialog allows choosing between single-click and double-click response and also sets the handling of executable files. These can either be started on activation or the content displayed. The operating mode of the trash is also set here. Activate a confirmation dialog before deletion, if desired. ‘Include a Delete command that bypasses trash’ can also be set. The files are immediately deleted if this option is activated.

The ‘Icon Captions’ dialog features three options for determining what information should be displayed for icons and how it should be displayed. In the ‘Preview’ dialog, select whether to activate preview thumbnails for certain file types.

### 2.4 Important Utilities

 GNOME features a wealth of applets and applications. This section provides an introduction to some of the most useful and interesting, all of which are compatible with the GNOME configuration scheme.

### 2.4.1 Dictionary

Dictionary is a useful applet for checking the spelling and the meaning of words. An Internet connection is required, as this applet accesses an online dictionary.

Enter the term to look up in ‘Word’. The menu under ‘Dictionary’ gives a choice between ‘Look Up Word’ and ‘Check Spelling’. By default, the query is sent to the dict.org server. To use a different server, select ‘Edit’ ➝ ‘Preferences’. Refer to Figure 2.2 on the following page. dict.org allows you to choose between various
2.4.2 Managing Archives with File Roller

In GNOME, manage file archives with File Roller. This application is able to handle archives of the following types: .tar, .tar.gz, .tgz, .tar.bz, .tar.bz2, .tar.Z, .zip, .lha, .rar, .lzh, .ear, .jar, and .war. Easily view archive contents from File Roller with other applications without needing to decompress the archives. File Roller supports drag and drop, allowing you to drag file icons from the desktop or from the file manager (Nautilus) to the File Roller dialog and drop them there.

To create a new archive, select ‘Archive’ → ‘New’. In the next dialog, specify the directory in which to create the new archive in the left window. Enter the file name of the new archive in the input field below without the file extension. Then
The GNOME Desktop

determine the archive type with the drop-down menu above the name field. Exit the dialog with ‘OK’ and return to the main view of File Roller. Now, add files to the archive by inserting files from the desktop or the file manager with drag and drop or by selecting ‘Edit’ → ‘Add Files’. In the following dialog, select one or several files (keep Ctrl pressed to select multiple files) or directories. If necessary, determine the following advanced options for the archive:

**Add only if newer** If the archive already contains a file with the same name, the file is only added if it is newer than the one existing in the archive.

**Include subfolders** To compress an entire directory, activate this option to include all subdirectories.

**Exclude backup files (**)** Avoid unnecessary data trash by disabling the inclusion of backup copies when creating an archive.

**Exclude hidden files (.* )** Usually, hidden files do not contain any data that are relevant for the user. By default, they are not included in the archive to reduce the amount of data.

**Exclude files** This explicitly excludes certain files from the archive. This option is useful if you want to compress entire directories but exclude certain files from the archive. Instead of file names, you can also specify search patterns.

**Ignore case** File Roller ignores different spellings of file names and extensions, like JPEG or jpeg.

After completing the selection and configuration, exit the dialog. The archive created is available for further processing at the desired location. To decompress an archive, load it to File Roller, click ‘Edit’ → ‘Extract to’, and specify the target directory.
Part II

Office Applications
OpenOffice.org is a powerful Linux office suite that offers tools for all types of office tasks, such as writing texts, working with spreadsheets, or creating graphics and presentations. With OpenOffice.org, use the same data across different computing platforms. You can also open and edit files in Microsoft Office formats then save them back to this format, if needed. This chapter only covers the basic skills needed to get started with OpenOffice.org.
OpenOffice.org consists of several application modules (subprograms), which are designed to interact with each other. They are listed in Table 3.1. The discussion in this chapter is focused on Writer and Calc. The other modules are only explained briefly. A full description of each module is available in the online help, described in Getting Help on the facing page.

Table 3.1: The OpenOffice.org Application Modules

<table>
<thead>
<tr>
<th>Application Module</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OpenOffice.org Writer</td>
<td>Powerful word processor application</td>
</tr>
<tr>
<td>OpenOffice.org Calc</td>
<td>Spreadsheet application that includes a chart utility</td>
</tr>
<tr>
<td>OpenOffice.org Draw</td>
<td>Drawing application for creating vector graphics</td>
</tr>
<tr>
<td>OpenOffice.org Math</td>
<td>Application for generating mathematical formulas</td>
</tr>
<tr>
<td>OpenOffice.org Impress</td>
<td>Application for creating presentations</td>
</tr>
</tbody>
</table>

3.1 The OpenOffice.org Quickstarter

The Quickstarter is a convenient addition to the OpenOffice.org suite. After selecting ‘OpenOffice.org Quickstarter’ from the main menu for the first time, you are asked whether the quickstart function of the program should be enabled. Doing so can be useful if you intend to use OpenOffice.org frequently and have sufficient RAM available.

When enabled, the Quickstarter icon appears in the desktop panel at the lower right edge of the screen. Right-clicking the icon displays a menu like the one shown in Figure 3.1 on the next page, which gives access to a number of possibilities: directly start the individual OpenOffice.org application modules, quickly reopen the recently used files, or create a new document from a template. Customize the Quickstarter settings by selecting ‘Configure OpenOffice.org Quickstarter...’.

Once enabled, the Quickstarter is started automatically each time you log in to your desktop. To stop this from happening in the future, select ‘Quit’ in the Quickstarter menu.
3.2 Getting Help

Get help for OpenOffice.org at any time from the ‘Help’ menu. Depending on your selection, the depth and type of help provided varies. To get thoroughly acquainted with a topic, select ‘Help’ → ‘Contents’. The help system provides information about each of the modules of OpenOffice.org (Writer, Calc, Impress, etc.).

If you find this information too broad or overwhelming, try the ‘Help Agent’ instead, which offers help and tips as you perform different actions with OpenOffice.org. Select ‘Help’ → ‘Help Agent’ to enable this. If you feel you need just a few hints, try ‘Tips’ or ‘Extended Tips’. They enable the program’s tooltips — short information about the element (such as a button) over which the mouse is hovering. ‘Extended Tips’ gives a longer version of the tooltips.

---

**Note**

If you are not sure whether the features are active, open the ‘Help’ menu. A checked menu item indicates that the corresponding help function is currently active.
3.3 Managing the Transition from Microsoft Office

OpenOffice.org is able to work with Microsoft Office documents. To convert such documents, select ‘File’ → ‘AutoPilot’ → ‘Document Converter…’. Choose the file format from which to convert. There are several StarOffice and Microsoft Office formats available. After selecting a format, click ‘Next’ then specify where OpenOffice.org should look for documents to convert and in which directory the converted files should be placed. Before continuing, make sure all other settings are appropriate.

**Note**

Documents from a Windows partition are usually in a subdirectory of `/windows/`.

Click ‘Next’ to see a summary of the actions to perform, which gives another opportunity to check whether all settings are correct. Finally, start the conversion by clicking ‘Convert’.

Given that the workings of Microsoft formats are not disclosed by the company, other office programs may have difficulties importing such files in the correct way. If you intend to use your documents on other platforms, you should preferably save them in open formats (such as those of OpenOffice.org) to avoid any file conversion problems.

### 3.3.1 From MS Word to OpenOffice.org Write

When importing Word files into OpenOffice.org, some of the formatting of the original may be lost. For consistent fonts, use the SUSE Linux YaST Online Update to download the Microsoft fonts or install these fonts during the original installation of SUSE Linux. Please observe the license conditions for these fonts.

A very useful feature of OpenOffice.org is that you can save all your documents as PDF files. To do so, select ‘File’ → ‘Export…’.

Files composed with OpenOffice.org can be saved in the `.doc` format. They can then be opened and edited with Microsoft Office on a Windows system. Remember to select the correct version of Word when saving, so that you can open
the files with the Microsoft system that you have installed. To save a file to such a format, select ‘File’ → ‘Save As...’ and then choose the desired format.

If you have problems opening your documents, try using the RTF format. Because this format does not depend on a specific word processor, it can be handled both by MS Word and OpenOffice.org, while still carrying over the formatting information.

3.3.2 From MS Excel to OpenOffice.org Calc

OpenOffice.org can save files in recent Microsoft formats down to version MS Office 95. This is not only true for OpenOffice.org Writer, but also for OpenOffice.org Calc and OpenOffice.org Impress.

You can open MS Excel files with OpenOffice.org Calc. Again, you can save your documents as PDF files. If you continue to use MS Office, your can also save your spreadsheets in MS Excel formats then reimport them with the Microsoft program. Export files by selecting ‘File’ → ‘Save As...’ then choosing the desired format. If you have difficulties with the formatting, try using the CSV (comma separated value) format, which can be handled by both spreadsheet programs and should thus carry over all the information.

3.3.3 From MS PowerPoint to OpenOffice.org Impress

If you have any PowerPoint presentations, you can import them with OpenOffice.org Impress. The program also allows you to export presentations to Macromedia Flash and PDF formats.

3.4 Changing the Global Settings

Global settings can be changed by selecting ‘Tools’ → ‘Options...’. This opens the window shown in Figure 3.2 on the following page. A tree structure is used to display categories of settings.

‘OpenOffice.org’ This entry covers various basic settings. This includes your user data, like your address and e-mail, important paths, and settings for printers and external programs.
‘Load/Save’  This entry includes settings related to the opening and saving of several file types. There is a dialog for general settings and several special dialogs to define how external formats should be handled.

‘Language Settings’  This entry covers various settings related to languages and writing aids, namely your locale and spell checker settings. This is also the place to enable support for Asian languages.

‘Internet’  This entry includes dialogs to configure any proxies and to change settings related to search engines.

‘Text Document’  Under this entry, configure global word processing options, such as the basic fonts and layout Writer should use.

‘HTML Document’  Under this entry, change the settings related to the HTML authoring features of OpenOffice.org.

‘Spreadsheet’  Use this to change settings for Calc, such as those related to sort lists and grids.

‘Presentation’  Under this entry, change settings that should apply to all presentations. For example, specify the measurement unit for the grid used to arrange elements.
‘Drawing’ This entry covers settings related to the vector drawing module, such as the drawing scale, grid properties, and some print options.

‘Formula’ This entry provides a single dialog for setting some special print options for formulas.

‘Chart’ This defines the default colors used for newly created charts.

‘Data Sources’ Use this to define how external data sources should be accessed.

Note

All settings as listed above are applied globally — they are used as defaults for every new document you create.

3.5 Word Processing with OpenOffice.org Writer

3.5.1 Creating Texts with the AutoPilot

To use a standard format and predefined elements for your own documents, try the AutoPilot. This is a small utility that lets you make some basic decisions then produces a ready-made document from a template. For example, to create a business letter, select ‘File’ → ‘AutoPilot’ then select ‘Letter…’. This opens the dialog shown in Figure 3.3 on the next page.

Click ‘Next’ in each page to proceed to the next one. To modify any previous entries, use ‘Back’. Exit the dialog with ‘Cancel’. Access a help document with ‘Help’.

When finished, click ‘Create’. OpenOffice.org produces a letter according your specifications. Now, compose the text (body) of the letter itself. AutoPilot is not limited to letters, but can also assist in the creation of faxes, agendas, memos, and presentations.


3.5.2 Creating Texts without the AutoPilot

Create a new text document by selecting ‘File’ → ‘New’ → ‘Text Document’. When editing a text document, a second toolbar, called the object bar, is available just below the standard function bar. Move the mouse pointer over an icon to get a short help text. Documents can also be formatted with the Stylist, which is described in Working with the Stylist on the facing page.

3.5.3 Selecting Text

To select text, click the desired beginning of the selection and, keeping the mouse button pressed, move the cursor towards the end of the range (which can be characters, lines, or entire paragraphs). Release the button when all desired text is selected. While selected, text is displayed in inverted colors. Open a context menu by right-clicking the selection. Use the context menu to change the font, the font style, and other text properties.

The Navigator displays information about the contents of a document. It also enables you to jump quickly to the different elements included. For example, use the Navigator to get a quick overview of all the chapters or to see a list of the images included in the document. Figure 3.4 on the next page shows the Navigator in action. The elements listed in the Navigator vary according to the document loaded in Writer. Open the Navigator by selecting ‘Edit’ → ‘Navigator’.
3.5.4 Working with the Stylist

The Stylist can help you format text in a number of ways. It can be opened or closed at any time by toggling ‘Format’ → ‘Stylist’ or by pressing **F11**. The dialog window of the Stylist is shown in Figure 3.5 on the following page.

If you set the drop-down list at the lower edge of the Stylist to ‘Automatic’, OpenOffice.org tries to offer a selection of styles adapted to the task at hand. On the other hand, if you select ‘All’, the Stylist offers all styles from the currently active group. Select groups with the buttons at the top. Text can be hard-formatted or soft-formatted:

**Hard Formatting**  Formatting properties are directly assigned to a text range and each property must be applied to each range by hand. The assignment is static and can only be changed manually. This is only recommended for short documents.

**Soft Formatting**  With this method, text is not formatted directly. It has a style applied to it. The style itself can be modified quite easily. Modifying a style automatically results in a formatting change of all the text to which it is assigned.

This approach has many advantages when creating larger documents (theses, books, and the like). Although not as intuitive, it is very efficient and
fast if the formatting needs to be changed extensively and consistently. Using this method also makes it much easier to try different layouts with the document. Define the format of paragraphs, pages, and frames for a style and select fonts and numbering methods.

To assign a style to a paragraph, select the style to use then click the paint bucket icon in the Stylist. Click the paragraphs to which to assign the style. Pressing Esc or clicking the paint bucket icon again turns off the function.

Easily create your own styles by formatting a paragraph or a character as desired. Use the ‘Character…’ and ‘Paragraph…’ items in the ‘Format’ menu to achieve the desired results. In the Stylist, click ‘New Style from Selection’ (to the right of the bucket symbol). Enter a name for your style and click ‘OK’.

Now, you can use the newly created style on other parts of the document. Change details of the style easily by selecting it in the list, right-clicking, and selecting

---

**Figure 3.5: The Stylist for Writer**
‘Modify…’ from the menu. This opens a dialog in which all the possible formatting properties are available for modification.

### 3.5.5 Inserting a Table

Create a table by clicking the ‘Insert’ icon in the main toolbar and keeping it pressed for a few seconds. This opens another toolbar in which to specify the object to insert. If you now move the mouse cursor to the third icon, a grid opens, as shown in Figure 3.6.

![Figure 3.6: Inserting a Table Using the Toolbar](image)

If your table should have two columns and two rows, for example, just run the mouse over that range of columns and rows to select them from the grid. When you release the button, the table is inserted into the document at the current text cursor position.

---

**Note**

The ‘Insert’ icon changes depending on the last object selected for insertion. This also means that you can now insert a table again with just a short click, without any need to reopen the pop-up toolbar.
3.5.6 Inserting Graphics

Graphics can be inserted with the same pop-up toolbar as tables, only you need to select its second button. Alternatively, select ‘Insert’ → ‘Graphics’ → ‘From File…’. This opens a dialog window in which to select the desired file. If you check ‘Preview’, the selected image is displayed in the right part of the dialog. The preview may take some time in the case of larger images. After confirming your choice, the inserted image is placed in the document at the cursor position.

In the document itself, select an image by clicking it. When selected, an image has little square handles on its edges. Then select ‘Graphics…’ from the context menu to open a dialog in which to change various image settings, such as the wrap type and border style.

To change the size of an image, first click it to activate it. Now click any of its handles, keep the button pressed, and drag the handle until the dashed frame reaches the desired size. When you release the button, the image is scaled according to your changes. To change the position of an image while leaving its size unchanged, click the image and keep the mouse button pressed. Drag the image to the desired position.

3.6 Spreadsheets with OpenOffice.org

Calc

Calc is the spreadsheet module of OpenOffice.org. Use this application, for example, to handle your private or business accounting data. If Writer is already running, start Calc by selecting ‘File’ → ‘New’ → ‘Spreadsheet’.

After starting, Calc presents an empty spreadsheet divided into rows and columns. Rows are numbered from top to bottom and columns are lettered from left to right. The intersection of a row and a column marks the location of a cell, so each cell has a unique address coordinate. For instance, the address B3 refers to the cell located in the second column (B) and the third row. This address is also shown at the top to the left of the entry field.

A cell may be active or inactive. The currently active cell has a thick black frame around it. To activate another cell, move the frame with the cursor keys or click another cell with the mouse. You can edit a cell if it is currently active.
3.6.1 Changing Cell Attributes

To enter something in a cell, simply write in that cell. By default, texts are aligned to the left and numbers to the right. To confirm your entry, press \( \text{Enter} \). To change the formatting of selected cells, right-click to open a context menu and select ‘Format Cells...’. This opens a dialog in which to change the cell attributes. The dialog, as shown in Figure 3.7, has the tabs ‘Numbers’, ‘Font’, ‘Font Effects’, ‘Alignment’, ‘Borders’, ‘Background’, and ‘Cell Protection’. By enabling ‘Protected’ under ‘Cell Protection’, prevent a cell from being modified.

Figure 3.7: The Cell Attributes Dialog

3.6.2 A Practical Example: Monthly Expenses

Calculations can be made using formulas. Any numeric values entered in cells can be used in formulas by referring to the unique coordinates of each cell. For example, you may want to keep a record of your monthly expenses. This could
be done by writing a few items into a very basic spreadsheet as in Figure 3.8. The cell B3 contains the phone bill for January and B4 the fuel expenses. To add both amounts together, enter \( = \text{B3} + \text{B4} \) in cell B5. Now cell B5 should display the corresponding result. If you have mistyped the numbers (or estimated your phone bill inaccurately), just reenter the amounts and Calc automatically updates the sum. Calc offers many functions beyond the four fundamental arithmetic operations. A comprehensive list arranged in categories is available under ‘Insert’ → ‘Function…’.

![Figure 3.8: A Spreadsheet Example for Calc](image)

Any spreadsheet can be easily extended. For instance, to insert another row between Fuel and Sum, right-click the 5 button to the left and select ‘Insert Row’ from the context menu. A new row is inserted below the current one and can immediately be used for additional input.

Entering formulas in the above way is cumbersome when many cells are involved. For example, if you have several items in your A column and want to add them, try the SUM function. In the field B6, enter the formula \( =\text{SUM} (\text{B3} : \text{B5}) \). An alternative possibility is to click the Sigma icon next to the input line and enter the range manually. This formula adds all numbers from B3 to B5. You can also specify several ranges at once.

As shown in the above formula, a range is defined by two cell addresses separated by a colon. Separate ranges with semicolons. Accordingly, the formula \( =\text{SUM} (\text{B3} : \text{B5}; \text{D3} : \text{D5}) \) adds everything from B3 to B5 and from D3 to D5. Basically, the formula is a short form of a longer one, which would read \( =\text{B3} + \text{B4} + \text{B5} + \text{D3} + \text{D4} + \text{D5} \).
3.6.3 Creating Charts

Now, add some more entries to the spreadsheet, for instance, by including some more months in row 2. After doing so, the table could look like Figure 3.9.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Month</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Expenses</td>
<td>January</td>
<td>February</td>
<td>March</td>
</tr>
<tr>
<td>3</td>
<td>Telephone</td>
<td>500</td>
<td>300</td>
<td>430</td>
</tr>
<tr>
<td>4</td>
<td>Gas</td>
<td>200</td>
<td>80</td>
<td>200</td>
</tr>
<tr>
<td>5</td>
<td>Sum</td>
<td>700</td>
<td>380</td>
<td>630</td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Figure 3.9: Expanded Example Spreadsheet**

Select the range from A2 to E5. The text appears white on black.

To create a chart, select ‘Insert’ → ‘Chart...’. This opens a dialog window. The first page in this dialog gives the option to modify the original cell selection and to specify whether to use the first row or column as chart labels. Usually, the settings on this page can be accepted without change. Continue by clicking ‘Next’.

The dialog consists of four pages. The main page shows the available chart types. The types offered include line, area, column, and bar charts. To the left, the page displays a preview of your data according to the type selected. The most suitable type for this example is the line chart. Click ‘Next’ to proceed to a page in which to choose from different variants of line charts: with or without symbols, stacked, percent, cubic spline, and so on. For the current example, select ‘Symbols’. If you enable ‘Show text elements in preview’, the column headers (January, February, etc.) are displayed on the X axis and the numerical values on the Y axis. Also, a chart legend is added on the right-hand side.

On the next page, give the chart, as well as its X axis and Y axis, a title. In this case, use ‘Monthly Expenses’ as a chart title and ‘Euro’ on the Y axis. The X axis title is disabled by default. Finally, after clicking ‘Create’, the chart is inserted into your spreadsheet. Figure 3.10 on the next page shows the sample chart in its final form.
3.6.4 Importing Spreadsheet Tables

There is often a need to import data available as a table, so it can be presented as a spreadsheet. In Calc, there are two ways to achieve this.

**Importing Data from the Clipboard**  For example, you may want to import stock exchange data. Display the desired table in your web browser. Then select the table with the mouse or using ‘Copy’, depending on the browser. This copies the selected data to the clipboard.

After that, open a new OpenOffice.org document with ‘File’ → ‘New’ → ‘Spreadsheet’. Select the cell in which the inserted table should start. Then select ‘Edit’ → ‘Paste’. This inserts the table into the document with all the formatting specifications, hyperlinks, and other information included.

**Importing Data with a Filter**  Import a saved HTML file to Calc by selecting ‘File’ → ‘Open’. This opens a dialog window in which to select ‘Web Page
(OpenOffice.org Calc)’ under ‘File type’. Use the arrow keys to scroll the list of file types. Finally, select the file name then ‘Open’ to import the table.

3.7 Creating Graphics Using OpenOffice.org Draw

Draw can be used to create vector graphics. Vector graphics are images in which lines and curves are defined through certain parameters, such as the location of points and the curvature.

To create a new drawing, start Draw from the main menu with ‘Applications’ → ‘OpenOffice.org Draw’. If OpenOffice.org is already running, select ‘File’ → ‘New’ → ‘Drawing’. The graphical objects available in Draw can be modified in various aspects, such as line thickness, line type, color, and fill.

Try to draw a rectangle. In the main toolbar, which is displayed on the left side, click the filled rectangle button (fifth from top) and keep the mouse button pressed for a few seconds until an additional toolbar opens. This includes a selection of filled and unfilled rectangles and squares, some of them with rounded corners. Select one of the filled rectangles. The mouse cursor should turn into a cross. Now move the cursor to the canvas and click it, dragging the mouse towards the bottom right. Draw shows the outline of a rectangle that is reshaped as you move. When you are satisfied with the size of the object, release the mouse button.

The properties of the rectangle, such as its fill color, can be modified with the following steps: First, activate the object with a single click. This should enable the green handles on the rectangle’s corners and edges, which allow you to reshape and resize it. Next, open the context menu by right-clicking. After selecting ‘Area…’, a dialog opens in which to change various properties. When you are done with your modifications, click ‘OK’. As an alternative method to change the fill color, select one directly in the object bar at the top (to the right of the paint bucket).

There are many more useful drawing objects available in the toolbar. Use it to create circles, ellipses, lines, and even 3D elements.
3.8 Creating Presentations with OpenOffice.org Impress

3.8.1 Creating Presentations with the AutoPilot

To use Autopilot to create presentations, select ‘File’ → ‘AutoPilot’ → ‘Presentation…’. With the AutoPilot, define the basic structure of a presentation in three brief steps. In doing so, set backgrounds, the output medium, and various effects. You can also import data from an existing presentation with the help of assistants.

After completing the procedure by clicking ‘Create’, Impress offers a number of templates for the page layout. Select one that suits your purposes and enter a name for the first slide. Then click ‘OK’ to generate the first slide of the new presentation.

To complete your presentation, enter a title and the text for each page. When finished, view the presentation by selecting ‘Slide Show’ → ‘Slide Show’. To advance to the next page during the show, click. To exit from it, press Esc. Refer to the help system of OpenOffice.org to learn more.

3.8.2 Adding a Slide

To add another slide to your presentation, select ‘Insert’ → ‘Slide’. This opens the dialog window shown in Figure [3.11] on the facing page. Enter a name for the slide and determine which of the predefined layouts to use. Then click ‘OK’ to insert the slide or ‘Cancel’ to abort the procedure. To use templates, select ‘File’ → ‘New’ → ‘From Template…’. 
Figure 3.11: Inserting Slides in Impress
KWrite can be used to write simple texts or lists. Apart from these basic editing functions, KWrite can also be used to view and edit different types of source and HTML code with syntax highlighting. This chapter provides a brief overview of the main features of KWrite, introducing the main menus and tools.
4.1 Starting KWrite

Start KWrite from the main menu or using the command `kwrite`. The command can be entered on the command line together with the name of the file to open. As well as using the menu bar, the toolbar, and a number of shortcuts, you can right-click the opened document to access a context menu providing basic editor functions.

KWrite supports the drag and drop functions of KDE. This means that you can simply drag documents with the mouse from one application into another or paste data from the clipboard, described in The Clipboard Klipper on page 27. To edit a text file for which there is an icon on the desktop, click the icon with the left mouse button and hold the button while dragging it into the editor window. You can now edit the file as usual. Paste text from the clipboard by middle-clicking.

To edit or view the source code of an HTML page, drag the URL into the editor window of KWrite, keeping the left mouse button pressed.

![Figure 4.1: The KWrite Text Editor](image)
4.2 The File Menu

‘New’ (Ctrl-N) This creates a new file and, at the same time, opens a new KWrite window in which to start typing your text.

‘Open...’ (Ctrl-O) Use this to open an existing file. It opens a file selection dialog that resembles a file manager. The left-hand area provides a number of quick navigation buttons to list the files in your home directory or on the floppy with just one click, without having to navigate through the entire directory hierarchy. Alternatively, use the entry field in the toolbar at the top or browse directories with the arrow buttons. As soon as a directory is selected, the files and subdirectories in it are listed in the right-hand part of the dialog. To speed things up, narrow down the list according to the file type by specifying the file extension, such as *.txt, under ‘Filter’.

To mark the current directory for quick access at a later time, click the star button in the toolbar and create a bookmark for it. Any directory bookmarked in this way can subsequently be reached via the menu to avoid going through the entire file system again. Use the configuration menu accessible with the wrench button to customize the way in which the items in the dialog are sorted and viewed.

‘Recently Opened Files’ This opens a menu from which you can open the recently opened files.

‘Save’ (Ctrl-S) This saves the document in its current form. If you have been editing a new document, the program displays a dialog with which to specify the name of the file and its location (directory).

‘Save As...’ This opens a dialog in which to specify the name and the directory under which to save the document. The dialog is essentially the same as the one displayed after selecting ‘File’ → ‘Open...’.

‘Reload’ (F5) This reloads the currently opened file, reverting it to its state as saved on disk.

‘Print...’ (Ctrl-P) This opens a simple dialog in which to define printing options for the document and start the print job.

‘Close’ (Ctrl-W) This closes the currently loaded document. If there are changes that have not yet been saved, a dialog opens to ask whether to do so.

‘Quit’ (Ctrl-Q) This exits the editor. If there are unsaved changes to a loaded document, KWrite shows a dialog asking whether to save before exiting.
4.3 The Edit Menu

This menu provides all the program’s editing functions, such as selecting and searching or replacing text according to certain patterns.

‘Undo’/’Redo’ Use this to undo any unwanted changes and to restore the original text after an undo step. These functions are also available using the keyboard shortcuts Ctrl+Z and Ctrl+Shift+Z.

‘Cut’ (Ctrl+X) This cuts the currently selected text region.

‘Copy’ (Ctrl+C) This copies the selected text region to the clipboard.

‘Paste’ (Ctrl+V) Use this to insert text from the clipboard. You can also paste text by middle-clicking.

‘Select All’ (Ctrl+A) This selects all the text in a document, for example, to copy and paste it into another document.

‘Deselect’ (Ctrl+Shift+A) This menu item deselects a previously selected text area. You can do the same by left-clicking in the document window.

‘Block Selection Mode’ (Ctrl+Shift+B) KWrite not only supports marking and removing horizontal selections (lines or paragraphs), but also vertical selections (any desired text block). This item toggles the block selection mode. Text marked in this way can be moved to the clipboard using ‘Copy’ or ‘Cut’.

‘Overwrite Mode’ (Ins) This changes the program’s input mode. By default, KWrite inserts new text at the current cursor position. Selecting this menu item switches the editing mode so any existing text is overwritten.

‘Find. . . ’ (Ctrl+F), ‘Find Next’ (F3), ‘Find Previous’ (Shift+F3), ‘Replace. . . ’ (Ctrl+R) In the dialog that opens, enter a search string or a regular expression and define the search direction, the starting point, and other details. To go from one match of the search term to the next, select ‘Find Next’. To go to a previous match of the search term, select ‘Find Previous’. To replace a search term with another string, use ‘Replace. . . ’.

‘Go to Line. . . ’ (Ctrl+G) To jump to a particular line in the document, select this menu item, enter the line number in the dialog that opens, then confirm with ‘OK’.
4.4 The View Menu

From this menu, change several aspects of the text display in KWrite. Enable or disable the editor’s word wrap feature and toggle the display of line numbers (F11). Also decide whether to display the icon border (F6) to see or hide the bookmarks. Finally, the menu has an item to set the encoding of the text document.

4.5 The Bookmarks Menu

In KWrite, bookmarks are references to specific positions in the document. They can be used to navigate quickly to a given line, which is especially useful with longer documents. To use bookmarks, first enable the icon border (‘View’ → ‘Show Icon Border’). Add a bookmark by clicking the icon border at the desired line. A paper clip should appear after this to indicate that the bookmark has been set. Remove a bookmark by clicking the corresponding clip.

To navigate between bookmarks, press F5 (Page down) (next bookmark) and F5 (Page up) (previous bookmark). Remove all bookmarks in one step by selecting ‘Clear Bookmarks’.

4.6 The Tools Menu

This menu provides a number of actions that can be used to format the current document in a basic way.

‘Highlight Mode’ This is set to ‘Normal’ by default, but you can choose from numerous highlight modes for different document formats (such as HTML) and programming languages.

‘End of Line’ The end-of-line characters as stored by KWrite should always be set according to the operating environment in which the documents are used and distributed. Use this menu to choose ‘UNIX’, ‘Windows/DOS’, or ‘Macintosh’.

‘Indent’ Text blocks can be indented by a certain amount, as defined under ‘Settings’ → ‘Configure Editor...’ → ‘Editing’. To indent the current text, select ‘Indent’ or press Ctrl-I. To undo one level of indentation, select ‘Unindent’ or press Ctrl-(Shift)-I.
4.7 The Settings Menu

‘Show Toolbar’ Enable this to display a toolbar of the main editing functions.

‘Show Statusbar’ Enable this for KWrite to include a status bar at the lower edge of its window. The status bar would display the current line and column number, the input mode, and the save status of the document.

‘Show Path’ If this is enabled, KWrite displays the file name of the loaded document together with its complete path (rather than just the file name) in the window title bar.

‘Configure Editor…’ This opens a dialog with all the configuration options available for KWrite. This includes the color scheme and the fonts used, settings for indentation, text selection, and word wrap, and shortcut and highlighting options. The dialog also allows you to define a default view profile and integrate an external module for checking spelling.

‘Configure Shortcuts…’ This opens a dialog in which to change the existing keyboard shortcuts or define custom shortcuts.

‘Configure Toolbars…’ This opens a dialog in which to add and remove toolbar buttons.

4.8 The Help Menu

This menu gives access to the KWrite handbook. Click ‘What’s This?’ (or use the shortcut Shift+F1) to access context-sensitive tooltips.

4.9 Kate

The editor Kate provides further possibilities. It is based on the same editor component as KWrite, but can open and handle multiple files simultaneously.

A useful feature is syntax highlighting. Both KWrite and Kate offer this feature. It formats program code to make it more readable. This can be activated in ‘Extras’ → ‘syntax highlighting’.

82
Synchronizing a Handheld Computer with KPilot

Handheld computers are in widespread use among users who need to have their schedules, to-do lists, and notes with them everywhere they go. Often users want the same data to be available both on the desktop and on the portable device. This is where KPilot comes in — it is a tool to synchronize data on a handheld with that used by the KDE applications KAddressBook, KOrganizer, and KNotes.
5.1 How KPilot Works

The main purpose of KPilot is to allow the sharing of data between the applications of a handheld computer and their KDE counterparts. KPilot does come with its own built-in memo viewer, address viewer, and file installer, but these cannot be used outside the KPilot environment. Independent KDE applications are available for all these functions except the file installer.

For communication between the handheld and the different desktop programs, KPilot relies on conduits. KPilot itself is the program that oversees any data exchange between the two computer devices. Using a particular function of the handheld on your desktop computer requires that the corresponding conduit is enabled and configured. For the most part, these conduits are designed to interact with specific KDE programs, so in general they cannot be used with other desktop applications.

The time synchronization conduit is special in that there is no user-visible program for it. It is activated in the background with each sync operation, but should only be enabled on computers that use a network time server to correct their own time drift.

When a synchronization is started, the conduits are activated one after another to carry out the data transfer. There are two different sync methods: a HotSync operation only synchronizes the data for which any conduits have been enabled while a backup operation performs a full backup of all data stored on the handheld.

Some conduits open a file during a sync operation, which means the corresponding program should not be running at the given time. Specifically, KOrganizer should not be running during a sync operation.

5.2 Conduits Used by KPilot

The conduits used by KPilot can be enabled and configured after selecting ‘Settings’ → ‘Configure KPilot…’. The following is a list of some important conduits:

Address Book  This conduit handles the data exchange with the handheld’s address book. The KDE counterpart for managing these contacts is KAddressBook. Start it from the main menu or with the command kaddressbook.

For details about this program, refer to Address Management with KAddressBook on page 99.
KNotes/Memos  This conduit allows you to transfer notes created with KNotes to the handheld’s memo application. Start the KDE application from the main menu or with the command knotes.

Calendar (KOrganizer)  This conduit is responsible for syncing the appointments (events) of the handheld. The desktop equivalent is KOrganizer. For more information about this program, refer to Scheduling with KOrganizer on page 91.

Tasks (KOrganizer)  This conduit is responsible for syncing task (to-do) items. The desktop counterpart is again KOrganizer.

Time Synchronization Conduit  Enabling this conduit adjusts the handheld’s clock to that of the desktop computer during each sync operation. This is only a good idea if the clock of the desktop computer itself is corrected by a time server at fairly frequent intervals.

![Configuration Dialog with the Available Conduits]

*Figure 5.1: Configuration Dialog with the Available Conduits*

### 5.2.1 Configuring the Handheld Connection

To be able to use KPilot, first set up the connection with the handheld computer. The configuration depends on the type of cradle (docking unit) used with the handheld. There are two types of these: USB cradles and serial cradles.
Configuring the Connection from within KPilot

The easiest way to set up the connection is by using the configuration assistant. Select ‘Settings’ → ‘Configuration Assistant’ to start the assistant. In the first step, enter your user name and the name of the device to which the handheld is connected. The assistant attempts to detect them itself if you select ‘Autodetect Handheld & User Name’. If the autodetection fails, refer to Creating a /dev/pilot Link on this page.

After confirming with ‘Next’, the assistant prompts you to specify the applications that should be used for synchronization. You can choose among the KDE application suite (default), Evolution, and none. After selecting, close the window with ‘Finish’.

Creating a /dev/pilot Link

The setup of the connection with a serial handheld cradle is different from that of a USB cradle. Depending on which cradle is used, you may or may not need to create a symbolic link named /dev/pilot.

USB   Normally, a USB cradle is autodetected and there should be no need to create the symbolic link mentioned.

Serial With a serial cradle, you need to know to which serial port it is actually connected. Serial devices are named /dev/ttyS?, starting from /dev/ttyS0 for the first port. To set up a cradle connected to the first serial port, enter the command:

```
ln -s /dev/ttyS0 /dev/pilot
```

5.2.2 Configuring the KAddressBook Conduit

Initially, it should be sufficient to enable the KAddressBook conduit without changing any of the defaults. After the data has been synchronized for the first time, configure the details: what to do in case of conflicts, the way in which backup databases are saved, and how certain fields as stored on the handheld should be assigned to the fields expected by KAddressBook.
5.2.3 Managing To-Do Items and Events

On the KDE desktop, to-dos (tasks) and events (appointments) are managed with KOrganizer. Start the application from the main menu or with the command `korganizer`. After enabling the calendar and the to-do conduit of KPilot, set some configuration options before using them.

![ KPilot Configuration ]

**Figure 5.2: KPilot Configuration**

KOrganizer stores its files in the directory `~/.kde/share/apps/korganizer`. However, given that the directory `.kde/` begins with a dot, it may not be shown by the file selection dialog. In this case, enter the complete path manually or explicitly toggle the display of hidden files (dot files) in the file selection dialog. The default shortcut for this is F8.

After opening the directory `~/.kde/share/apps/korganizer`, select a file that can be used as a calendar file by KOrganizer. In our example, this is the file `palm.ics`. In the case of a user called `tux`, the complete path and file name would be `/home/tux/.kde/share/apps/korganizer/palm.ics`, as shown in Figure 5.3 on the next page.

KOrganizer should not be running when data is being exchanged with the handheld. Otherwise KPilot fails to carry out the sync operation.
5.3 Working with KPilot

Synchronizing the data of KDE applications with those of the handheld computer is quite easy. Simply start KPilot then press the “HotSync” button on the cradle to initiate the sync operation.

5.3.1 Backing up Data from the Handheld

To do a full backup, select ‘File’ → ‘Backup’. The backup is performed during the next sync operation. After that, switch back by selecting ‘File’ → ‘HotSync’ from the menu. Otherwise, the time-consuming full backup will be performed again during the next sync operation.

After a full backup, all copies of the handheld’s programs and databases are found in ~/.kde/share/apps/kpilot/DBBackup/
\dbreplaceable{username}, where ⟨username⟩ is the name of the user as registered on the handheld.

The two built-in KPilot viewers can be used for a quick lookup of addresses or memos, but they are not designed to actually manage this data. The KDE applications mentioned above are much more suited for these tasks.
5.3.2 Installing Programs on the Handheld

The ‘File Installer’ module is an interesting and useful tool for the installation of handheld programs. These programs normally have the extension .prc and they are ready to start immediately after uploading them to the handheld. Before using such add-on programs, read their licenses as well as the instructions included.

*Figure 5.4: The Main Window of KPilot*
KOrganizer is a KDE application for scheduling and managing events and tasks. Because of the variety of ways in which the program can present your schedule, it is a very helpful tool for keeping track of deadlines, outstanding tasks, and appointments. It can also remind you of birthdays and meetings, if you enable this function.
6.1 Starting KOrganizer

Start KOrganizer from the main menu or with korganizer. The main window has several toolbars, a menu bar, the date navigator with a month view of the calendar, the main part displaying the currently selected calendar view, and a list containing all the current to-do items. All the common program actions, such as saving, printing, and creating or deleting events, can be performed from the menus. See Figure 6.1.

![Figure 6.1: The Main Window of KOrganizer](image)

KOrganizer can also be started in a windows containing other tools for office planning. More details are available in The Information Manager Kontact on page 34.

6.2 Configuring KOrganizer

To configure KOrganizer, select ‘Settings’ → ‘Configure KOrganizer...’. This opens a dialog in which to enter your name and e-mail address. When working with the program, the name is used to indicate who is the owner of a given to-do item or event. The e-mail address is used to identify the owner of the calendar. A user who is not the owner can read the calendar, but not modify it. ‘Send copy to
owner when mailing events’ should be enabled if you want to receive a copy of every e-mail sent out by the program (in your name) to the attendees of an event. For KOrganizer to save your scheduling items automatically when exiting, check ‘Enable automatic saving of calendar’. This also saves all changes automatically at a user-definable interval. To be prompted before any items are deleted, enable ‘Confirm deletes’.

Under ‘Time & Date’, customize the defaults for working hours and appointments, define the default alarm time, and set your time zone. KOrganizer switches between winter and daylight savings time automatically.

Under ‘Fonts’, set your preferred font type and size for the different text fields of the program. Fonts can be selected for the time bar, the month view, and, under ‘Agenda view’, for the day view, week view, and work week view.

Under ‘Colors’, set the colors that should be used to highlight events, to-do items, and other elements. For instance, define that to-do items due on the current day should be dark red and that overdue to-do items should be light red.

The other items of the preferences dialog allow customization of the various views and the program’s group features. Under ‘Group Scheduling’, provide additional e-mail addresses, which is useful if you are registered for a certain event under a different address.

![Figure 6.2: Configuring KOrganizer](image_url)
6.3 Using the Calendar

The calendar of KOrganizer can be displayed in a number of different views to show a certain month, day, week, or work week. There is also a view of the next three days. Details of these views can be configured with ‘Settings’ → ‘Configure KOrganizer...’ under the ‘Views’ item. Switch between the different views with the ‘View’ menu or by clicking the corresponding button in the toolbar.

Existing event items can easily be modified with the mouse. One possibility is to change the start and end date or time by clicking the item’s upper or lower edge then dragging it to the desired position. In the day, week, and work week view, directly move an item to another time by clicking it then dragging it to the new position. You can also move events outside the time of the current view. For instance, an item can be dragged to the date navigator to the left. Even drag an item to the date navigator of another KOrganizer window.

6.3.1 Events

To schedule a new event, select ‘Actions’ → ‘New Event...’. Enter the desired details. Under ‘Reminder’, specify the exact time (minutes, hours, or days in advance) at which the attendees should be reminded of the event. If an event recurs, specify the interval. Another way to create an event at a specific point in the calendar is to double-click the corresponding field in one of the program’s calendar views. This opens the same dialog window as that available from the menu.

Specify the attendees of an event by entering their data manually in the dialog or by inserting data from the address book. To enter such data manually, select ‘New’. To import data from the address book, select ‘Address Book...’ then the corresponding entry from the dialog.

6.3.2 Attendees

Participants for a schedule item are listed under ‘Attendees’ in the item view. Sort the attendee list by clicking the column header of the value by which to sort. To add an attendee for an item, click ‘New’. Then enter the name in ‘Name’ and the e-mail address in the field below. Use ‘Address Book...’ to query the address book and select entries from it. In ‘Role’, define the function of an attendee (observer, chair, participant), which can also be used to sort the list of attendees later. With ‘Status:’, assign a status to an attendee, such as needs action, accepted, or
completed. Change the status of an attendee at any time by selecting the attendee in the list then choosing another status from the drop-down list. If you check ‘Request response’, the attendees receive an e-mail with the relevant schedule item.

### 6.3.3 To-Do Items

Create a new to-do item by selecting ‘Actions’ → ‘New To-Do…’. In the dialog that opens, specify the exact start and due date and time for the new task, its progress in percent, and its priority. If other people are involved, specify their details under ‘Attendees’. The created to-do item is then automatically included in the left list under ‘To-do items’. The ‘Summary’ column in this list shows the description. ‘Priority’ shows the value selected.

### 6.3.4 Categories

To manage your schedule, group events and to-dos according to certain categories. Assign the scheduling items to one or several categories, for instance, if one of your items is related to job training, you could assign it to both ‘Business’ and ‘Education’. Categories can be assigned in the dialogs for the creation of new
events and to-dos after selecting ‘Categories…’. Create additional categories with ‘Edit Categories’.

### 6.4 Printing

Selecting ‘File’ → ‘Print…’ opens a dialog in which to define the calendar period to print and the type of view to use. To specify the period, enter the dates by hand or use the calendar available from the drop-downs. To use the print preview function, you must have KGhostView installed. Alternatively, specify a different PostScript viewer, such as gv, after selecting ‘File’ → ‘Print…’ → ‘Print…’ → ‘System Options…’ then going to the ‘Preview’ item in the dialog.

### 6.5 Address Book

To store important contacts or to search for a contact, open the address book by selecting ‘File’ → ‘Addressbook’. In the address book window, make a new entry by selecting ‘File’ → ‘New Contact…’. The KDE address book application,
although linked with KOrganizer, is an independent program. Learn more about it in *Address Management with KAddressBook* on page 99.

### 6.6 Help

For any problems or questions regarding KOrganizer, consult the detailed instructions for the program. Access them with ‘Help’ → ‘KOrganizer Handbook’.
KAddressBook provides quick and comfortable access to all address data of your contacts. As well as managing your local address data, KAddressBook can access, if available, a central LDAP server that hosts contact data for your entire department or your entire company. KAddressBook supports the import and export of data in several formats, including vCard, CSV, and MS-Exchange, ensuring smooth interaction with other programs.
7.1 Starting the Program

KAddressBook can be started independently from the main menu, from the appointment scheduler KOrganizer, or the mail program KMaiil. On start-up, the KDE Address Book window consists of three frames, as shown in Figure 7.1. The top frame contains the menu and toolbars. The two lower frames contain the current list of contacts and the address data of the currently selected contact.

![KAddressBook Main Window]

Figure 7.1: KAddressBook Main Window

7.2 Creating a New Contact

Open the contact editor with ‘File’ → ‘New Contact’ (Ctrl-N) or by clicking on the respective icon in the toolbar. See Figure 7.2 on the facing page.

Enter all important information, including name, title, private and business addresses, all phone numbers, e-mail addresses, and URLs, under the ‘General’ tab. If desired, assign the contact to a category that can later be used for filtering the address view. Select a standard category (Family, Friend, Business, Customer, or School) or create a new category.
The ‘Details’ tab allows you to enter some useful extra information, such as birthdays, anniversaries, and job-related data, and offers the possibility to add comments for this contact. Under the ‘Misc’ tab, you can add a picture or logo to the selected contact and specify the longitude and latitude of the contact’s location.

7.3 Creating Address Lists

To merge a number of contacts from your address database into a list, you can create a distribution list. To do so, select ‘Settings’ → ‘Toolbars’ → ‘Distribution Lists’. In the editor that opens, select ‘New List’ to create a new list. Then drag and drop all desired contact entries from the overview in the upper part into the editor’s list. See Figure 7.3 on the next page.
7.4 Searching Address Data

Basically, KAddressBook offers three options for searching address data:

**Searching the Local Database** In the main window to select the search criterion: ‘Given Name’, ‘Family Name’, or ‘Email Address’. As soon as you enter a character string in the adjacent input field, the program starts searching your data by the selected criterion. The search result is displayed both in the overview and in the detailed view.

**Searching for Initials or Numbers (Jump Bar)**
Activate this toolbar with ‘Settings’ → ‘Show Jump Bar’. Depending on the activated search criterion in the ‘Incremental search’, clicking the respective letter or number lists the contact entries whose names, family names, or e-mail addresses begin with this letter or number.

**Searching Remote Resources (LDAP, IMAP, etc.)**
Unless you have already done so, first make sure that resources are included in the search by clicking ‘Add’. This opens a dialog in which to select an address resource, such as LDAP or IMAP. Select the desired resource then enter the corresponding parameters. After confirming with ‘Ok’, the program connects to the resource and starts retrieving the address data from it.
To start the actual search, enter your search term in the main window’s input field. The result of your search appears in the currently active view (by default, as a table). Limit the search range by defining a category for the search term, such as given name, family name, or phone number.

7.5 Importing and Exporting Address Data

‘File’ → ‘Import’ adds a contact present in another file or on another file system. ‘Export’ exports a contact in a certain format. For example, it is possible to transfer addresses onto a mobile phone or create a vCard and send it via e-mail.

7.6 For More Information

If you have questions or encounter problems when working with KAddressBook, read more about the program by selecting the ‘Help’ menu item.
Part III

Internet
Konqueror is not only a versatile file manager. It is also a modern web browser. If you start the browser with the icon in the panel, Konqueror opens with the web browser profile.
8.1 Starting Konqueror and Opening Web Pages

Start Konqueror from the main menu or by entering the command `konqueror`. To load a web page, enter its address in the location bar, for example, `http://www.suse.de`. Konqueror now tries to reach the address and display the page. Entering the protocol at the beginning of the address (`http://` in this case) is not strictly required. The program is able to complete the address automatically, but this only works reliably with web addresses. For an FTP address, always enter `ftp://` at the beginning of the input field.

![Figure 8.1: The Browser Window of Konqueror](image)

Figure 8.1: The Browser Window of Konqueror
8.2 Saving Web Pages and Graphics

As in other browsers, you can save web pages. To do this, select ‘Location’ → ‘Save as . . . ’ and specify a name for your HTML file. However, images are not saved. To archive an entire web page including the images, select ‘Extras’ → ‘Archive Web Page’. Konqueror suggests a file name that you can usually accept. The file name ends with .war, the extension for web archives. To view the saved web archive later, simply click the respective file and the web page is displayed in Konqueror along with its images.

8.3 Enhanced Web Browsing (Internet Keywords)

Searching the web using Konqueror is very practical. Konqueror defines a number of search engines for you, all with a specific shortcut. To search for a certain topic on the Internet, enter the shortcut and the keyword separated by a colon. The relevant page containing the search results is then displayed.

You can also define your own shortcuts. Simply select ‘Settings’ → ‘Configure Konqueror’ → ‘Web Shortcuts’. A dialog appears in which to define your own abbreviations.

8.4 Bookmarks

Instead of remembering and reentering addresses for sites visited often, you can bookmark these URLs using the ‘Bookmark’ menu. Apart from web page addresses, you can also bookmark any directories of your local disk in this way.

To create a new bookmark in Konqueror, click ‘Bookmarks’ → ‘Add Bookmark’. Any bookmarks added previously are included as items in the menu. It is a good idea to arrange the bookmark collection by subjects in a hierarchical structure, so that you do not lose track of the different items. Create a new subgroup for your bookmarks with ‘New Directory’. Selecting ‘Bookmarks’ → ‘Edit Bookmarks . . . ’ opens the bookmark editor. Use this program to organize, rearrange, add, and delete bookmarks.
If you are using Netscape or Mozilla as additional browsers, it is not necessary to recreate your bookmarks. ‘File’ ➔ ‘Import Netscape Bookmarks...’ in the bookmark editor enables you to integrate your Netscape and Mozilla bookmarks into your most current collection. The reverse is also possible via ‘Export as Netscape Bookmarks...’.

Change your bookmarks by right-clicking the entry. A pop-up menu appears in which to select the desired action (cut, copy, delete, etc.). When you are satisfied with the result, save the bookmarks with ‘File’ ➔ ‘Save’.

To save your bookmark list and have instant access to it, make your bookmarks visible in Konqueror. Select ‘Settings’ ➔ ‘Show Bookmark Toolbar’. A bookmark panel is automatically displayed in the current Konqueror window.

8.5  Java and JavaScript

Do not confuse these two languages. Java is an object-oriented, platform-independent programming language from Sun Microsystems. It is frequently used for small programs (applets), which are executed over the Internet for things like online banking, chatting, and shopping. JavaScript is an interpreted scripting language mainly used for the dynamic structuring of web pages, for example, for menus and other effects.

Konqueror allows you to enable or disable these two languages. This can even be done in a domain-specific way, which means that you can permit access for some hosts and block access for others. Java and JavaScript are often disabled for security reasons. Unfortunately, some web pages require JavaScript for correct display.

8.6  For More Information

For any questions or problems that arise when working with Konqueror, refer to the application’s handbook, which is available from the ‘Help’ menu. Konqueror also has a web page, which is located at http://www.konqueror.org.
Recently, the widely-used web browser has been transformed into a real jack-of-all-trades. The fact that today’s Internet applications feature such depth in integration and are heavily integrated into their corresponding desktop environments is almost taken for granted. Users of outdated machines soon feel the effects of this development. All-around browsers are often memory-eaters, sluggish in their operation, and occupy thirty megabytes on the hard disk.

That is why the idea behind Galeon is to devote itself just to one assignment: the web and only the web. Galeon implements the speedy Gecko engine of the Mozilla browser and integrates this into a functional user interface. The application loads quickly and is one of the fastest browsers available.
Galeon’s most essential navigation tools are available in the first toolbar. ‘Next’ and ‘Back’ flip through the history of visited Internet sites, as in other browsers. ‘Reload’ updates the contents of a site. ‘Cancel’ stops a connection or transfer from taking place. Zoom, the magnification level of a document, is usually scaled to 100% — a 1:1 display of the document. The up and the down arrows to its right set the zoom levels in intervals of ten. Enter Internet addresses (URLs) in the following entry box. The GNOME foot shows Galeon’s progress. If the icon is animated, Galeon is working and transferring data.

9.1 Optimized for the Web

Galeon is primarily designed to make surfing the Internet as convenient as possible. In the default configuration, Galeon presents a second toolbar, enabling quick access to the popular Google search engine and its news and image search function. It can also offer access to an online dictionary and use the bookmarklets. This is made possible by small JavaScript functions built into Galeon, for example,
find out how current a page is or allow the Internet site to slowly scroll down the screen.

### 9.2 Efficient Surfing with Tabs

Galeon can display multiple documents in a single application window. To open a link in a web site in the form of a new tab, right-click that link. Select ‘Open in new tab’ in the pop-up menu. Create a fresh Galeon tab by clicking ‘File’ → ‘Open New Tab’. Click the tabs to switch the display.

### 9.3 Smart Bookmarks

Smart bookmarks give access to a site’s functions along with its address, for example, searching the Internet for terms with Google. Enter the word in the input field after the Google icon. The result is displayed after a few seconds.

To activate or create additional smart bookmarks, select ‘Bookmarks’ → ‘Smart Bookmarks Toolbar’ → ‘Folder actions’ → ‘Edit...’. A window opens in which to edit the bookmarks. To create a new bookmark, mark ‘Smart Bookmarks Toolbar’ and select ‘File’ → ‘New item’. Enter a name in ‘Name’ and the web address in ‘URL’. The ‘Smart URL’ field is a URL that additionally contains a wild card for the entered string. For example, the smart URL for Google is http://www.google.com/search?q=%s. %s is the wild card. Save your bookmark settings with ‘File’ → ‘Save’.

### 9.4 Settings and Controls

Modify the configuration of the browser with ‘Settings’ → ‘Preferences’. This dialog provides access to settings controlling both appearance and functionality.

Galeon features built-in password management and cookie controls. It also has options that specify the web sites from which images may be downloaded. All these options can be accessed through a single dialog via ‘Tools’ → ‘Cookies’ → ‘View Cookies’.
9.5 For More Information

For more information about Galeon, see http://galeon.sourceforge.net. The GNOME home page http://www.gnome.org can also be helpful.
The Mozilla Web Browser

Mozilla is a web browser developed as an Open Source program with the aim of providing an Internet application that is fast, compliant with standards, and portable across different computing platforms. In addition to the basic browser, Mozilla includes a number of extra components, such as a mail component and a web page design component. This chapter focuses on the web browser component.
10.1 The Initial Browser Window

In its default configuration, the window presented by the browser includes these elements: the actual document window (occupying the majority of the window and used to display web pages), the menu bar, the navigation toolbar, and the personal toolbar. See Figure 10.1. There is also a combined status and component bar at the bottom of the window. Finally, to the left of the document window, **Mozilla** provides a sidebar that contains a number of different tabs, each of them giving access to a particular task.

![Figure 10.1: The Initial Browser Window](image)

When you right-click in the document window, **Mozilla** opens a context menu with a number of entries. Use this menu, for example, to add the current page to your bookmarks (‘Bookmark This Page’) or to view its source code (‘View Page Source’).
10.1.1 The Menu Bar

The menu bar includes the following menus:

File This menu provides the common entries to open, save, and print files or web pages. It also allows you to send an entire web page or only the link to a page as an e-mail. Selecting ‘Edit Page’ loads the current page into the Mozilla Composer, which allows you to edit web pages and to create your own from scratch. Mozilla’s online help documents include an introduction to creating web pages, which you may want to read as a primer on the topic. The ‘File’ menu also includes the ‘Work Offline’ item, which tells the browser to use only locally stored or cached web pages.

Edit ‘Edit’ includes the common editing operations, such as ‘Undo’, ‘Cut’, ‘Copy’, ‘Paste’, and ‘Delete’. There is also an item to search for words or text strings in web pages. ‘Find Previous’ repeats the previous search action. ‘Preferences’ opens a dialog in which to change the browser’s configuration options. The details of this are described in Preferences on page 120.

View The ‘View’ menu includes items to display or hide the different elements of the browser and also to stop loading a web page or reload it. There are also items to change the text zoom for the pages displayed and to change the character coding. Another item in this menu lets you view the source of a web page.

Go This is the navigation menu with items to go ‘Back’ or ‘Forward’ in the page history or to jump to the ‘Home’ page. Selecting ‘History’ opens a window that lists the addresses of all the web pages recently visited with the browser.

Bookmarks Use ‘Bookmarks’ to create and edit bookmarks. Bookmarks can be arranged in folders. Any previously created bookmarks can be selected from the menu.

Tools A number of useful browser functions can be accessed via the ‘Tools’ menu. For example, access a search engine to find certain contents on the Internet. The Cookie Manager gives control over the cookies the browser has stored on your computer and lists each cookie together with the address of the site from which it originated. Use it to reverse previous decisions on whether to accept or reject cookies. The Image Manager allows you to block images and advertising banners from web sites, which improves speed. The Password Manager can make things easier for you if you frequently log
in to sites (both in internal networks and on the Internet). Mozilla can remember the passwords for you. However, this feature also poses a certain security risk, so you may not want to use it for sites with high privacy requirements, such as online banking sites.

**Window** This menu lets you switch to other browser windows and to those of other Mozilla components (if installed) — to the mail client, the composer, and the address book.

**Help** Mozilla is a multipurpose tool, so you may want to use this menu to access the online help, which provides information and hints about the features of the program.

### 10.1.2 The Navigation Toolbar

The buttons of the navigation toolbar give quick access to the basic functions of the browser. Use ‘Forward’ and ‘Back’ to jump one step ahead or back in the history of pages viewed previously. ‘Reload’ updates the contents of a page. Usually, web sites are stored in the cache for a certain time, in case they are called again. Reload always loads the current page from the Internet. ‘Stop’ aborts the loading of a page, so no further data is transferred from the corresponding site.

The next element to the right is the location bar in which to enter Internet addresses (URLs) or search terms. If you enter a search term then press ‘Search’, Mozilla searches the web for that term using the search engine set in the preferences. After having visited a number of sites, directly select their addresses again by clicking the down arrow, which opens a drop-down list. Mozilla stores the contents of this list so it is available in your next browser session. Start typing a previous address then hit `<Tab>` to complete it automatically.

‘Print’ prints the current page. The downward arrow to its right also gives access to a print preview of the document. To the very right, the navigation toolbar displays the Mozilla logo, which is animated as long as the browser is transferring data.

### 10.1.3 The Personal Toolbar

The personal toolbar is a customizable toolbar that is preconfigured to include the following elements:
The Mozilla Web Browser

**Home**  This points to a web address configured to be displayed as Mozilla’s start page.

**Bookmarks**  This button lets you access the bookmarks collected from intranet or Internet sites.

**The Mozilla Organization**  This points to the home page of the Mozilla project.

### 10.1.4 Sidebar

The sidebar is located to the left in a separate subwindow.

**What’s Related**  Under this tab, Mozilla can list a number of sites whose topic is related to the current one.

**Search**  This is an interface to several well-known search engines.

**Bookmarks**  This tab is an additional entry point to your bookmarks, which are presented here in a tree structure.

**History**  This tab provides a list of the recently visited web pages.

### 10.2 Working with Tabs

Mozilla can display several web pages at a time in one window by using tabbed browsing. This is often more convenient than opening a new browser window for each new document. To display a document (open a link) under a new tab, right-click the corresponding link then select ‘Open Link in New Tab’ from the context menu. The different documents are now directly available by clicking the different tabs arranged at the top of the main window.

As soon as you start using tabs, an extra button appears to the left of the tab bar, which allows you to open a new empty tab. Press \( \text{Ctrl-1} \) to achieve the same. To close the currently active tab, click the button with the X to the very right of the tab bar. Right-click a tab to open context menu that offers several related actions, such as closing the tab or closing all other tabs.
10.3 Preferences

Many often-needed browser settings are available in the dialog that opens when you select ‘Edit’ → ‘Preferences’.

**Appearance**  Under this entry, set the fonts and colors the browser should use, select a theme, and switch between the German and the English language version.

**Navigator**  The first thing that can be changed under this entry is the start page for the browser. Configure Mozilla to start with a blank page, the home page as defined below (which may be your organization’s intranet portal, for instance), or the last page visited. In the ‘History’ dialog, define the number of days for which the addresses of visited pages should be stored. ‘Languages’ lets you define a list of preferred languages, which is useful for pages that are available in several languages. Under ‘Internet Search’, tell Mozilla which search engine to use.
If you do not want Mozilla to show matching Internet addresses from the history automatically as soon as you start typing, disable this feature under ‘Smart Browsing’ → ‘Automatically complete text typed into Location bar’. Alternatively, configure Mozilla to autocomplete addresses in the entry field itself. To do so, select the ‘Advanced...’ button then, in the dialog, ‘Autocomplete best match as you type’.

One of the options available in the ‘Tabbed Browsing’ dialog is to have Mozilla open a new tab for a web page whenever you middle-click a link. Under ‘Downloads’, specify how the progress of file downloads should be monitored. Enabling ‘Open the download manager’ causes the browser to open the full-featured download manager dialog. ‘Open a progress dialog’ limits the dialog to a progress bar displayed during download. Turn off all download feedback by enabling ‘Don’t open anything’.

**Privacy & Security**  This is one of the most important parts of the preferences, with a number of settings related to cookie handling and the built-in password management. In addition to that, there is an entry in which to specify from which web sites Mozilla should accept images.

To maintain a degree of privacy, it is often a good idea to accept cookies only from the server from which the requested document is received. To achieve this, enable ‘Enable cookies for the originating web site only’. Enabling ‘Disable cookies’ may cause some web pages not to function in the intended way. With ‘Manage Stored Cookies’, inspect the properties of any cookies that have been accepted.

Use the ‘Images’ dialog to define similar settings for the handling of graphics. This is especially useful if you do not want to clog an already slow connection (modems) with the download of large images. The dialog also allows you to suppress the animation of any images. To achieve this, just select ‘Never’ under the ‘Animated images should loop’ header.

In the ‘Passwords’ dialog, decide whether Mozilla should store any passwords entered. Consider both convenience and security. However, if you use the browser for online banking, you should definitely not have the corresponding password stored by Mozilla.

**Advanced**  Often, web pages are not only written in plain HTML. Many sites also use JavaScript or Java to produce some special effects. As a general rule, it is recommended to turn off Java. Under ‘Scripts & Plugins’, you should also turn off JavaScript at least for ‘Mail & Newsgroups’. Other dialogs available under this entry are related to the browser’s ‘Cache’ and to the ‘Proxies’ used by it.
The settings in the ‘Cache’ dialog depend on the specific circumstances with which the browser needs to cope, but the default 4096 kB size of the ‘Memory Cache’ is often too small. A cache is a temporary storage area used for the files fetched from the network so they can be reused.
Encryption with KGpg

KGpg is an important component of the encryption infrastructure on your system. With the help of this program, generate and manage all needed keys, use its editor function for the quick creation and encryption of files, or use the applet in your panel to encrypt or decrypt by dragging and dropping. This chapter covers the basic functions needed for daily work with encrypted files.

11.1 Key Management .................................. 124
11.2 The Key Server Dialog ............................ 127
11.3 Text and File Encryption .......................... 129
11.4 For More Information .............................. 131
11.1 Key Management

This section covers operations needed for handling your digital key ring. Other programs, such as your mail program (KMail or Evolution), access the managed key data to process signed or encrypted contents.

11.1.1 Generating a New Key Pair

To be able to exchange encrypted messages with other users, first generate your own key pair. One part of it — the public key — is distributed to your communication partners, who can use it to encrypt the files or e-mail messages they send. The other part of the key pair — the private key — is used to decrypt the encrypted contents.

Note

Private Key versus Public Key

The public key is intended for the public and is distributed to all of your communication partners. However, only you should have access to the private key. Do not grant other users access to this data.

Start KGpg from the main menu by selecting ‘Internet’ → ‘Security’ or enter kgpg on the command line. When you start the program for the first time, an assistant appears to guide you through the configuration. Follow the instructions up to the point where you are prompted to create a key. Enter a name, an e-mail address, and, optionally, a comment. If you do not like the default settings provided, also set the expiration time for the key, the key size, and the encryption algorithm used. See Figure 11.1 on the facing page.

Confirm your settings with ‘OK’. The next dialog asks you to enter a password. After doing so twice, the program generates the key pair and display a summary. It is a good idea to save or print a revocation certificate right away. Such a certificate will be needed if you forget the password for your private key, so need to revoke it. After confirming with ‘OK’, KGpg displays its main window. See Figure 11.2 on page 126.

11.1.2 Exporting the Public Key

After generating your key pair, make the public key available to other users. This enables them to use it to encrypt or sign the messages or files they send you. To
make the public key available for others, select ‘Keys’ → ‘Export Public Key(s)’. The dialog that opens offers four options:

‘Email’ Your public key is sent to a recipient of your choice by e-mail. If you activate this option and confirm with ‘OK’, the dialog for creating a new e-mail message with KMail appears. Enter the recipient and click ‘Send’. The recipient will receive your key and can then send you encrypted contents.

‘Clipboard’ You can place your public key here before you continue to process it.

‘Default Key Server’ To make your public key available to a wide audience, export it to one of the key servers on the Internet. For more information, refer to The Key Server Dialog on page 127.
If you prefer to distribute your key as a file on a data medium instead of sending it by e-mail, click this option, confirm or change the file path and name, and click ‘OK’.

11.1.3 Importing Keys

If you receive a key in a file (for example, as an e-mail attachment), integrate it in your key ring with ‘Import Key...’ and use it for encrypted communication with the sender. The procedure is similar to the procedure for exporting keys already described.

Signing Keys

Keys can be signed like every other file to guarantee their authenticity and integrity. If you are absolutely sure an imported key belongs to the individual specified as the owner, express your trust in the authenticity of the key with your signature.

Note

Encrypted communication is only secure to the extent that you can positively associate public keys in circulation with the specified user. By cross-checking and signing these keys, you contribute to the establishment of a web of trust.
Select the key to sign in the key list. Select ‘Keys’ → ‘Sign Key(s)...’. In the following dialog, designate the private key to use for the signature. An alert reminds you to check the authenticity of this key before you sign it. If you have performed this check, click ‘Continue’ and enter the password for the selected private key in the next step. Other users can now check the signature by means of your public key.

**Trusting Keys**

Normally, you are asked by the corresponding program whether you trust the key (whether you assume it is really used by its authorized owner). This happens each time a message needs to be decrypted or a signature must be checked. To avoid this, edit the trust level of the newly imported key. By default, a newly imported key is listed with a “?”, meaning that no concrete value has been assigned for the trust level.

Right-click the newly imported key to access a small context menu for key management. Select ‘Edit Key in Terminal’ from it. KGpg opens a text console in which to set the trust level with a few commands.

At the prompt of the text console (Command >), enter `trust`. Now on a scale between 1 and 5 make an estimate of how much you trust the signers of the imported key to have checked the true identity of the key owner. Enter the selected value at the prompt (Your decision?). If you are really sure about the signers’ trustworthiness, enter 5. Answer the following question by entering y. Finally, enter `quit` to exit the console and return to the list of keys. The key now has the trust level `Ultimate`.

**11.2 The Key Server Dialog**

Several Internet-based key servers offer the public keys of many users. To engage in encrypted communication with a large number of users, use these servers to distribute your public key. For this purpose, export your public key to one of these server. Similarly, KGpg enables you to search one of these servers for the keys of certain people and import their public keys from the server.

**11.2.1 Importing a Key from a Key Server**

By means of the ‘Import’ tab in the key server dialog, import public keys from one of the Internet-based key servers. Use the drop-down menu to select one of
the preconfigured key servers and enter a search string (e-mail address of the
communication partner) or the ID of the key to find. When you click ‘Search’,
your system connects to the Internet and searches the specified key server for a
key that matches your specifications. Refer to Figure 11.3.

If your search on the key server is successful, a list of all retrieved server entries
is displayed in a new window. Select the key to include in your key ring and click
‘Import’. See Figure 11.4 on the facing page. Confirm the following message with
‘OK’ then exit the key server dialog with ‘Close’. The imported key then appears
in the main overview of the key manager and is ready for use.

11.2.2 Exporting Your Keys to a Key Server

To export your key to one of the freely accessible key servers on the Internet, se-
lect the ‘Export’ tab in the key server dialog. Designate the target server and the
key to export by means of two drop-down menus. Then start the export with ‘Ex-
port’.

**Figure 11.3: Search Screen for Importing a Key**
11.3 Text and File Encryption

KGpg also offers the possibility to encrypt text or clipboard contents. Click the padlock icon and find the options ‘Encrypt clipboard’ and ‘Decrypt clipboard’ as well as the option for opening the integrated editor.

11.3.1 Encrypting and Decrypting the Clipboard

Files copied to the clipboard can easily be encrypted with a few clicks. Open the function overview by clicking the KGpg icon. Select ‘Encrypt Clipboard’ and designate the key to use on the panel. A status message about the encryption procedure is displayed on the desktop. The encrypted contents can now be processed from the clipboard as needed. The decryption of clipboard contents is just as easy. Simply open the menu on the panel, select ‘Decrypt Clipboard’, and enter the password associated with your private key. The decrypted version is now available for processing in the clipboard and in the KGpg editor.

11.3.2 Encrypting and Decrypting by Dragging and Dropping

To encrypt or decrypt files, click the icons on the desktop or in the file manager, drag them to the padlock in the panel, and drop them there. If the file is not encrypted, KGpg asks for the key to use. As soon as you have selected a key, the file is encrypted without any further messages. In the file manager, encrypted files are designated with the suffix .asc and the padlock icon. These files can be decrypted by clicking the file icon, dragging it to the KGpg symbol in the panel,
and dropping it there. Then select whether the file should be decrypted and saved or displayed in the editor. If you select ‘Decrypt and Save’, KGpg prompts for the password of your private key and saves the decrypted file in the same directory as the encrypted file.

### 11.3.3 The KGpg Editor

Instead of creating contents for encryption in an external editor then encrypting the respective file with one of the methods described above, you can use the integrated editor of KGpg to create the file. Open the editor (‘Open Editor’ from the context menu), enter the desired text, and click ‘Encrypt’. Then select the key to use and complete the encryption procedure. To decrypt files, use ‘Decrypt’ and enter the password associated with the key.

Generating and checking signatures is just as easy as encrypting directly from the editor. Go to ‘Signature’ → ‘Generate Signature...’ and select the file to sign from the file dialog. Then designate the private key to use and enter the associated password. KGpg informs you about the successful generation of the signature. Files can also be signed from the editor by simply clicking ‘Sign/Verify’. To
check a signed file, go to ‘Signature’ → ‘Verify Signature...’ and select the file to check in the following dialog. As soon as you confirm the selection, KGpg checks the signature and reports the result of the operation. Another possibility is to load the signed file into the editor and click ‘Sign/verify’.

11.4 For More Information

For theoretical background information about the encryption method, refer to the brief and clear introduction on the GnuPG project pages at http://www.gnupg.org/documentation/howtos.html.en. This document also provides a list of further information sources.
KMail is the KDE mail application. In addition to sending and receiving e-mail and using multiple mail protocols, it offers the possibility to configure several custom filters for sorting e-mail messages in individual folders. Encryption, decryption, and signing of e-mail messages can also be handled conveniently in KMail.
12.1 KMail and Kontact

KMail can be displayed along with other applications in one window using the Kontact utility. Refer to The Information Manager Kontact on page 34 for details about this.

12.2 Mail Formats

KMail can save messages in the following formats:

mbox This traditional UNIX format (the oldest) saves all messages in a single file. Directories are also simulated by means of individual files. The individual mails can only be distinguished by the From line.

MailDir In contrast to the mbox format, the MailDir format has a unique file name for every message. Messages are stored in directories and can easily be identified and further processed. KMail uses the MailDir format (as the more convenient alternative) by default, but MailDir is not supported by many other e-mail programs. This can be a disadvantage if you sometimes want to use a different e-mail program. However, there is no problem processing old e-mails in mbox format when using MailDir. Just copy or move the mbox file into a MailDir folder.

12.3 Access Types

KMail allows you to access your electronic mail in various ways. The access type largely depends on your Internet service provider (ISP) or mail server. The most important access types are POP3, IMAP, and dIMAP:

POP3 (Post Office Protocol) POP3 (post office protocol version 3) is a standardized method (protocol) for the delivery of e-mail. A POP3 server stores the messages until the user retrieves them with a POP3 client (in this case, KMail). The user may or may not be asked to authenticate with a name and a password. The drawback of this protocol is that it transmits passwords as plain text. To remedy this, alternative protocols have been developed, namely APOP and KPOP. These transmit passwords in encrypted form. Most ISPs use POP3. For a more detailed explanation of the protocol, see http://en.wikipedia.org/wiki/Post_Office_Protocol.
IMAP (Internet Message Access Protocol)
Unlike a POP3 server, an IMAP mail server stores the messages and allows you to access them from it. They are only downloaded to your client host as needed. This offers a number of advantages. One of them is that the same messages are available from several client hosts (your machine at work and your laptop used on the road, for example). Another one is that mailboxes can be shared among different users. For a more detailed explanation of the protocol, see http://en.wikipedia.org/wiki/IMAP.

dIMAP (Disconnected IMAP) dIMAP offers the same possibilities as IMAP with the additional advantage that messages can be edited offline. This is a big advantage for those situations where a permanent connection to the server is not available as when using a laptop. With dIMAP, messages edited offline are synched with the server as soon as the connection is reestablished.

12.4 Configuring KMail

When KMail is started for the first time, a Mail folder is added to your home directory. This folder contains some basic mail directories (inbox, outbox, drafts, sent, and trash). Go to ‘Settings’ ➔ ‘Configure KMail...’ to enter the information needed for sending and receiving messages. All configuration options can be accessed under ‘Configure KMail’ (wrench icon).

12.4.1 Defining Your User Identity

KMail allows you to manage several e-mail addresses (such as your private e-mail address and your business address). When writing an e-mail, select one of the identities previously defined. To create a new identity profile, select ‘Settings’ ➔ ‘Configure KMail...’ then ‘Identities’ ➔ ‘New...’, which opens a dialog. Give the new identity a name (such as “private” or “office”). Click ‘OK’ to proceed to a dialog in which to enter some additional information.

Under the ‘General’ tab, enter your name, organization, and e-mail address. Under ‘Encryption’, select your keys to send digitally signed or encrypted messages. For the encryption features to work, first create a key with KGpg, described in Encryption with KGpg on page 123.

Under ‘Advanced’, you can enter a reply-to and a blind carbon-copy address, choose a dictionary, select the folders for drafts and sent messages, and define
how messages should be sent. Under ‘Signature’, decide if and how each of your messages should be signed with an extra piece of text at the end. To activate this, select ‘Enable Signature’ and decide whether the signature should be taken from a file, from an input field, or from the output of a command. When you are finished with all your identity settings, confirm with ‘Ok’.

### 12.4.2 Setting up Network Connections

The settings under ‘Network’ (opened with ‘Settings’ → ‘Configure KMail…’) decide how KMail receives and sends e-mail. There are two tabs, one each for sending and for receiving mail. Many of these settings vary depending on the system and network in which your mail server is located. If you are not sure about the settings or items to select, consult your ISP or system administrator.

Create outgoing mail boxes under the ‘Sending’ tab. ‘Add’ lets you choose between the server types SMTP and sendmail. SMTP is the right choice in most cases. After making this selection, a window appears in which to enter SMTP server data. Provide a name and enter the server address (as given to you by your ISP). If the server wants you to authenticate yourself, enable ‘Server requires authentication’.

Security settings are under the ‘Security’ tab. Specify your preferred encryption method here. If uncertain about which one to choose, click ‘Check What the Server Supports’. The respective settings are then tested and applied. If necessary, consult your system administrator.

Make settings for receiving e-mail under the ‘Receiving’ tab. Use ‘Add’ to create a new account. Choose between different methods for fetching mail, such as local (Mbox or Maildir format), POP3, or IMAP. Usually POP3 is suitable. After making your selection, a window appears in which to enter the POP3 server data. Enter the name of the server in the field at the top. In the other fields, enter the values provided by your ISP or your system administrator. The fields ‘User’, ‘Server’, and ‘Password’ are required.

The ‘Security’ tab offers several methods for encryption and authorization. If you are uncertain about which options your server provides, try ‘Check What the Server Supports’.

### 12.4.3 Configuring the Appearance of KMail

Under ‘Appearance’, customize KMail according to your preferences. Use the ‘Fonts’ tab to configure the fonts for the various displays, such as the message text and first-level quoted text. To do this, activate ‘Use custom fonts’.
To customize the colors, activate ‘Use custom colors’ in the ‘Colors’ tab. Double-click an entry to access a dialog in which to select the colors. The ‘Layout’ tab offers options for splitting the KMail window and for displaying a MIME tree. A MIME tree shows all the attachments to a message.

The ‘Header’ tab provides options for general settings, like displaying the file size or encryption symbols. Also, customize the date display and message grouping. ‘Profiles’ is responsible for the configuration of the appearance. Some standard profiles are provided with the program, like those for users who prefer high contrast. Selecting a profile overwrites the current layout settings.

### 12.5 Using KMail

After starting, KMail displays its main window. By default, the main window consists of three sections:

![Figure 12.1: Main Window of KMail after Start-Up](image)

The folder area to the left contains a list of your mail folders (mail boxes) indicating the total number of messages and how many are still unread. To select a folder, simply click it. The messages it contains appear in the top right frame. The number of messages is also displayed in the status bar at the bottom of the application window.
The subject, sender, and time of receipt of each message are listed in header area to the right. Click a message to select it and display it in the message window. Sort the messages by clicking one of the columns (subject, sender, date, etc.).

The contents of the currently selected message are displayed in the message frame of the window. Attachments are depicted as icons at the end of the message, based on the MIME type of the attachment. Use \( \text{PgUp} \) and \( \text{PgDn} \) to scroll through the pages of the message or use \( \uparrow \) and \( \downarrow \) to scroll line by line. These shortcuts are indicated to the right of the respective menu items in the main menu.

Messages can be marked with different status flags. Change the status with ‘Message’ → ‘Highlight as’. You can use this feature to highlight important messages that you do not want to forget.

### 12.6 Creating a New Message

To compose new messages, select ‘Message’ → ‘New Message ...’ (\( \text{Ctrl} + \text{N} \)). To compose a message, fill in the respective fields in the message composer window, shown in Figure 12.2.

![Figure 12.2: Composing a Message](image)

To send messages from different e-mail accounts, select one of the identities configured as described in Defining Your User Identity on page 135. The ‘...’ buttons...
next to ‘To:’ and ‘CC:’ (and possibly ‘BCC:’) open the address book, allowing you to select an address. After entering the first few characters of an address, press \(\text{Ctrl} + \text{I}\) to see a list of possible completions.

To attach files to your message, click the paper clip icon and select the file to attach. Alternatively, drag a file from the desktop or another folder to the ‘New Message’ window or select one of the options in the ‘Attach’ menu.

Normally, the format of a file is recognized correctly. If this is not the case, right-click the icon. From the menu that appears, select ‘Properties’. This opens a dialog in which to set the format and the name of the file and add a description. In addition, decide whether the attached file should be signed or encrypted.

When you are finished composing your message, you can either send it immediately (‘Message’ → ‘Send’) or move it to the outbox. If you do the former, the message is copied to sent-mail after having been sent successfully. If you do the latter, it is moved to the outbox. You can edit any message in the outbox using the ‘Edit’ main menu or delete it.

### 12.7 Message Folders

Message folders help to organize your messages. By default, they are located in the directory `~/Mail`. When starting KMail for the first time, the program creates the folders inbox, outbox, sent-mail, and trash automatically. The function of these folders is as follows:

- **inbox** KMail stores all newly retrieved messages in this folder (unless a filter has been defined).
- **outbox** Contains the messages waiting to be sent.
- **sent-mail** Contains copies of all e-mails that have been sent.
- **trash** Contains copies of all e-mails deleted with \(\text{Del}\) or ‘Edit’ → ‘Delete’.

If you want additional folders to organize your messages, create them by selecting ‘Folder’ → ‘New Folder...’. This opens a window in which to specify options for the folder under the ‘General’ tab. See Figure 12.3 on the next page. Enter a name for the folder and select a parent folder (in ‘Belongs to:’) if the new folder should be created as a subfolder.
Under the tab ‘Old Message Expiry’, specify the expiration date for read and unread messages and what should happen with them after expiration. If you intend to use the folder to store messages from a mailing list, set the necessary options under the ‘Associated Mailing List’ tab.

To move one or several messages from one folder to another, highlight the messages to move then press (M) or select ‘Message’ → ‘Move to...’. In the list of folders that appears, select the folder to which to move your messages. Messages can also be moved by dragging them from the upper window and dropping them into the appropriate folder in the left window.

**Figure 12.3: Creating New Folders**
To remove all the messages from a folder, click ‘Folder’ → ‘Empty’. All messages located in the folder are then moved to the trash.

**Note**

Messages are not deleted permanently until you empty the trash.

---

### 12.8 Importing Mail

KMail assists in importing e-mail messages from previously-used applications. Select ‘Tools’ → ‘Import messages’ to open the import utility. KMail currently features import filters for Outlook Express 4, 5, and 6, the mbox format, simple e-mail texts, Pegasus Mail, and Evolution folders. The import utility can also be started separately by pressing **Alt-F2** and entering the command `kmailcvt`.

Select the corresponding application and confirm with ‘Continue’. A file or a folder must be provided, depending on the selected type. KMail then completes the process.

### 12.9 The Address Book


### 12.10 Filters

Filters enable the automatic processing of incoming messages. However, filters can also be applied to messages manually. To do so, highlight the messages then press **Ctrl-J** or select ‘Message’ → ‘Apply filters’. The filters are applied to all selected messages by matching rules. All existing filter rules are applied. There is no way to exclude certain filters from the action.
12.10.1 Filter Rules

A filter consists of one or several filter rules and filter actions. A filter rule can select one or several messages according to criteria, such as sender, content, or recipients. The filter action can perform tasks, like moving, deleting, marking, or forwarding these messages.

12.10.2 Examples of Filters

Assume, for instance, you are subscribed to the KDE user list (kde-user@kde.org). Whenever a message from the mailing list arrives, you want the message moved into another folder. The following steps are necessary for creating this filter.

1. Add a new folder as described in Message Folders on page 139. Provide a suitable name for it, such as kde-user.

2. First, think about the best way to clearly identify the messages to filter. The messages from the KDE user list described in our example can be identified by the mailto:kde-user@kde.org address, found in the ‘To:’ or ‘CC:’ field.

3. Click ‘Settings’ → ‘Configure Filters’. The left side of the window that opens displays the existing filters. The right side is composed of two panels: filter rules and filter actions.

4. Click the ‘New’ icon (bottom left) to create an empty filter. It appears as <unknown>.

5. In the ‘Filter Criteria’ panel, select ‘To’ or ‘CC’ from the first drop-down menu and ‘contains’ from the second drop-down menu. Enter kde-user@kde.org in the text field.

6. In the ‘Filter actions’ panel, select ‘Move to Folder’ from the first drop-down menu. A second drop-down menu with the list of folders appears. Choose the folder to which the filtered messages should be moved if they meet the desired criteria. In this case, choose ‘kde-user’ from the drop-down menu.

7. Confirm the changes with ‘OK’.

More complex filters are also possible. For example, you may want to save only the messages written by Fred Johnson (fj@anywhere.com) to the KDE user list. Here, the remaining filter criteria come into play:
1. Click ‘Settings’ → ‘Configure Filters’ and select the newly created filter.

2. To filter all messages containing mailto:kde-user@kde.org in the ‘To:’ or ‘Cc:’ fields and originating from Fred, define a second filter under ‘Filter Criteria’ using the second row of drop-down menus. Select ‘From’ in the first menu and ‘contains’ in the second. Then enter Fred’s e-mail address (fj@anywhere.com) in the input field. Make sure to enable ‘Applies to all’.

3. Select the action to execute (move, delete, etc.).

You have now created a filter that transfers all mails from Fred Johnson on the KDE user list as specified.

12.10.3 Spam Filters

While electronic mail has many advantages, it also has a significant disadvantage: spam. Unsolicited mass mailings, also known as spam, sent by the advertisement industry clog your electronic inbox and cause long transfer times. Filtering tools can separate the annoying ballast from important messages. SpamAssassin is such a tool that can be embedded into KMail. It relies on various built-in rules and has the ability to learn from its experience with spam. The configuration of this useful application for KMail is described here.

Preparations

The actual software must be present before spam messages can be filtered. Run YaST as user root and install the package spamassassin with the package manager. Then configure the system to activate the SpamAssassin service on system start-up by opening the runlevel editor in YaST (located under ‘System’). Search the list of services for spamd and select ‘activate’. Confirm the choice with ‘Finish’. This completes the SpamAssassin installation process.

Create an additional folder in KMail (naming it spam, for instance) in which to store the messages classified as spam. If you already have collected some spam messages, move as many of them as possible into this folder. This folder can be used later as a training stock and allows the tool to decide which of your incoming messages should be classified as spam.
Spam Filtering

KMail requires two filters for spam processing:

The first filter examines the size of a message. Select ‘Settings’ → ‘Configure filters…’. In the dialog that appears, create a new filter entry and name it SpamAssassin, for example. Select ‘<Size in bytes>’ as the filtering property and ‘is less than’ as the qualifier. Set the threshold to ‘300000’.

Under ‘Filter actions’, select ‘pipe through application’ and enter spamc in the field next to it. Note that the option ‘abort processing here upon matching filter condition’ must be deactivated. Confirm the first filter with ‘Apply’.

The above filtering rule specifies that KMail passes only those messages to spamc that have a size less than 300 KB. You may try other threshold values, but keep in mind that, with a higher threshold, the processing time increases. SpamAssassin then tests all messages for characteristics of spam and alters the message header by adding the line X-Spam-Status: YES. The second filter relies on this.

Add a second filter to the list and name it SPAMFilter. This filter moves the messages marked by SpamAssassin to the spam folder.

Select ‘<header field>’ as the property and ‘contains’ as the qualifier. Enter X-Spam-Status: YES in the corresponding text entry field.

Under ‘Filter actions’, select ‘file in folder’ with spam as the destination folder. Confirm with ‘Apply’.

These two filters should be placed in the order described at the top of the list. Any other filters can be placed below them.

Distinguishing Wanted and Unwanted Messages

SpamAssassin ships with predefined rules that control the recognition of spam messages. It is possible for SpamAssassin to miss a message occasionally, but the program can be trained to lower the number of false negatives. The utility sa-learn is included for this purpose. If your messages are stored in the MailDir format (refer to Mail Formats on page 134), run the following command:

```sh
sa-learn --spam --dir ~/Mail/spam/cur/
```

If your messages are stored in the mbox format, run the following command:

```sh
sa-learn --mbox --spam ~/Mail/.spam.directory/*
```
SpamAssassin returns the following message upon a successful spam recognition event:

Learned from 15 message(s)

To learn more about this tool, visit the site http://www.spamassassin.org or read the corresponding man page.

12.11 Encrypting Mail with PGP or GnuPG

KMail allows you to encrypt outgoing e-mail messages. To encrypt your e-mail, first generate a key pair as described in Encryption with KGpg on page 123. KMail then needs to be restarted to be able to use the encryption features.

To configure the details of the encryption procedure, select ‘Settings’ → ‘Configure KMail...’ → ‘Security’ → ‘Crypto plugins’. When you are finished with these settings, select ‘Identities’ to specify the identity under which to send encrypted and signed messages. Then use ‘Modify...’ to open a window in which to enter your OpenPGP key. After confirming with ‘OK’, the key should be displayed in the corresponding field. Close the configuration dialog with ‘Ok’.

The public key must be made available to recipients of a signed message so they can verify its authenticity. Other users must have your public key to send encrypted messages to you, the owner of the key.

12.11.1 Signing Messages

Create your messages as usual. Before sending the message, select ‘Options’ → ‘Sign message’ or the corresponding toolbar button. The message is now ready to be sent. To sign a message, KMail must know your PGP or GnuPG password. However, if you have already provided the password, KMail signs the message without requesting any further information. Check whether a message has actually been signed by looking into the sent-mail folder (or the outbox if you did not use ‘Send Now’). The corresponding message should be explicitly marked as having been signed.
12.11.2 Checking the Signature of a Received Message

If KMail is able to verify the signature of an e-mail, a green frame with the key ID is displayed. If the signature cannot be verified, a yellow frame with an alert is displayed. This means that you do not have a suitable public key for the signature.

12.11.3 Sending Public Keys

Create a message for the person who should receive your public key. Then select ‘Attach’ → ‘Attach Public Key’. The mail can now be sent. There is no guarantee that the recipient of a signed message receives the correct key. It is possible for the mail to be intercepted on the way to the recipient and signed with another key. Therefore, the recipient should check the attached key by comparing the finger print with a previously received value. Further information about this can be found in the PGP and GnuPG documentation.

12.11.4 Decrypting Messages

In KMail, select the message to decrypt. Enter your password when prompted. KMail attempts to decrypt the message. If it was encrypted with your public key, KMail displays it in clear text. If not, you cannot read the e-mail message. KMail saves these e-mail messages in encrypted form to prevent anyone from reading them without your password.

12.11.5 Encrypting Messages

To send an encrypted message to a recipient for whom you have the public key, simply write the message in the ‘Create Message’ window. Before sending the message, click the red key icon in the window’s toolbar. Now the message can be sent. If KMail cannot find a key for the recipient, a list with all available keys is shown. Select the appropriate one from the list or abort the process. KMail also informs you if errors occur during the encryption process. You cannot read encrypted messages if you did not click ‘Always encrypt to self’ in the ‘Security’ tab.
12.12 For More Information

If you encounter problems or simply want to learn more about KMail, use the ‘Help’ menu to read the program’s help pages. More detailed information is available on the KMail home page at http://kmail.kde.org.
Evolution is a groupware suite created by Ximian. It offers regular e-mail features along with extended features, like task lists and a calendar. The application also provides a complete address book, including the ability to send contact information to others in vCard format.

<table>
<thead>
<tr>
<th>13.1</th>
<th>Starting Evolution ........................................</th>
<th>150</th>
</tr>
</thead>
<tbody>
<tr>
<td>13.2</td>
<td>Importing E-Mail from Other Mail Programs .............</td>
<td>150</td>
</tr>
<tr>
<td>13.3</td>
<td>Evolution Overview .......................................</td>
<td>151</td>
</tr>
<tr>
<td>13.4</td>
<td>E-Mail ..................................................................</td>
<td>152</td>
</tr>
<tr>
<td>13.5</td>
<td>Calendar ................................................................</td>
<td>157</td>
</tr>
<tr>
<td>13.6</td>
<td>Contacts ..................................................................</td>
<td>158</td>
</tr>
<tr>
<td>13.7</td>
<td>Public Address Books in Evolution ......................</td>
<td>159</td>
</tr>
<tr>
<td>13.8</td>
<td>For More Information .........................................</td>
<td>160</td>
</tr>
</tbody>
</table>
13.1 Starting Evolution

Start Evolution from the main menu or with evolution. When started for the first time, Evolution offers a configuration assistant. If it is not opened automatically, select ‘Tools’ → ‘Settings’ → ‘Mail Accounts’ and click ‘Add’. Click ‘Next’ to access the assistant. Enter your name and your e-mail address in the respective fields. Additional addresses can be configured later. Click ‘Next’.

Select the appropriate incoming e-mail format for this address in ‘Server Type’. POP is the most common format for downloading mail from a remote server. IMAP works with mail folders on a special server. Obtain this information from your ISP or server administrator. Complete the other relevant fields displayed when the server type is selected. Click ‘Next’ when finished.

The next set of information to enter is about mail delivery. This is used for all configured e-mail addresses. To submit outgoing e-mail on the local system, select ‘Sendmail’. For a remote server, select ‘SMTP’. Get the details from your ISP or server administrator. For SMTP, complete the other fields displayed after selection. Click ‘Next’ when finished.

By default, the e-mail address is used as the name to identify the account. Enter another name if desired. The field ‘Make this my default account’ determines whether the account should be used as the default. The default account is the e-mail address initially selected for sending e-mail. Another account can be selected in the message composition window if desired. Click ‘Next’.

The time zone information from the next window is used for the calendar functions. It is important to select the correct time zone for using the appointment scheduling functions. Click the dot on the map for a city in your time zone. Selection zooms the display to that area and a change can be made if desired. When the correct time zone is displayed under ‘Selection’, click ‘Next’. In the next window, click ‘Finish’ to save the data entered. Use ‘Back’ to make changes.

13.2 Importing E-Mail from Other Mail Programs

Evolution can import e-mail from other e-mail programs, such as Netscape or KMail. To do so, select ‘File’ → ‘Import...’. For KMail, select ‘Import a single file’. For Netscape, select ‘Import data and settings from older programs’. Get more information with ‘Help’.
13.3 Evolution Overview

The default window view is shown in Figure 13.1. The available menus, menu items, and the icons in the toolbar vary from window to window. Use the ‘Shortcuts’ panel to the left to select the information to display in the right panel. Adjust the size of any panels by dragging the dividing bars.

Use ‘View’ to remove the ‘Shortcuts Bar’ or add a ‘Folder Bar’ at any time. The different items listed in ‘Shortcuts’ are described in the following.

![Figure 13.1: The Evolution Window with Shortcuts and Summary](image)

13.3.1 Summary

The ‘Summary’ provides some basic information about e-mail, appointments, and tasks along with personally configurable weather and news sources. This window is shown in Figure 13.1. Use ‘Tools’ → ‘Settings’ → ‘Summary Preferences’ to configure the information displayed.
13.3.2 Inbox

In this view, the upper half of the window shows the contents of the folder Inbox. The lower half is a preview pane used to display the selected mail message. Disable the preview pane with ‘View’ → ‘Preview Pane’.

To change the folder displayed, click the down arrow next to ‘Inbox’ and select another folder from the list. Use the search bar to search the messages in a folder. If desired, click a table header for the message list to sort the messages by that header. The sort can be either ascending or descending as shown by the arrow to the right. Click the header until the correct direction is displayed.

13.3.3 Calendar

The initial display shows a day view of the current day with the month and a task list shown in an additional pane to the right. Week, work week, and month views are also available from the toolbar or the ‘View’ menu. Use the search bar to find an entered appointment. Add appointments and tasks using the buttons in the toolbar. Also use the toolbar to page through the calendar or jump to a specific date.

13.3.4 Tasks

‘Tasks’ provides a list of tasks. Use the toolbar to add tasks. Search the tasks with the search bar.

13.3.5 Contacts

This view shows all the addresses in your address book. To locate a particular address, use the search bar or click the button to the right displaying the first letter of the contact’s last name. Add contacts or lists with the toolbar.

13.4 E-Mail

To configure the mail settings in Evolution, go to ‘Shortcuts’ → ‘Inbox’. Then activate ‘Tools’ → ‘Settings’.
13.4.1 Configuring Accounts

Evolution is capable of fetching e-mail from multiple mail accounts. The account from which to send e-mail can be selected when composing a message. To edit a current account, select the account in ‘Settings’ ➝ ‘Mail Accounts’ and click ‘Edit’. To add a new account, click ‘Add’. The configuration assistant described in Starting Evolution on page 150 opens. To delete an account, select it and click ‘Delete’.

To make an account the default account for sending e-mail, select the desired account then press ‘Default’. To disable fetching e-mail from an account, select the account then click ‘Disable’. A disabled account can still be used as the address for sending, but that account is not checked for incoming e-mail. If necessary, re-activate the account with ‘Enable’.

13.4.2 Mail Preferences

Use ‘Mail Preferences’ to select or disable the quote highlight color or how long after opening a message is marked as read. Also make settings regarding how images in HTML mail messages are handled.

13.4.3 Creating Messages

To compose a new message, click ‘New’ ➝ ‘Mail Message’. Replying to or forwarding a message opens the same message editor. Next to ‘From’, select from which account to send the message. In the recipient fields, enter an e-mail address or part of a name or address in your address book. If Evolution can match what you enter to something in the address book, a selection list is displayed. Click the desired contact or complete your input if none match. To select directly from the address book, click ‘To’ or ‘CC’.

Evolution can send e-mail as plain text or HTML. To format HTML mail, select ‘Format’ in the toolbar. To send attachments, select ‘Attach’ or ‘Insert’ ➝ ‘Attachment...’.

To send your message, click ‘Send’. If not ready to send it immediately, make another selection under ‘File’. For example, save the message as a draft or send it later.
13.4.4 Encrypted E-Mail and Signatures

Evolution supports e-mail encryption with PGP. It can sign e-mail and check signed e-mail messages. To use these features, generate and manage keys with an external application, such as `gpg` or `KPGp`.

To sign an e-mail message before sending it, select ‘Security’ → ‘PGP sign’. When you click ‘Send’, a dialog prompts for the password of your secret key. Enter the password and exit the dialog with ‘OK’ to send the signed e-mail. To sign other e-mail messages in the course of this session without needing to “unlock” the secret key repeatedly, activate ‘Remember this password for the remainder of this session’.

When you receive signed e-mail from other users, a small padlock icon appears at the end of the message. If you click this symbol, Evolution starts an external program (`gpg`) to check the signature. If the signature is valid, a green check mark appears next to the padlock symbol. If the signature is invalid, a broken padlock appears.

The encryption and decryption of e-mail is just as easy. After composing the e-mail message, go to ‘Security’ → ‘PGP encrypt’ and send the e-mail message. When you receive encrypted messages, a dialog opens to ask for the password of your secret key. Enter the passphrase to decrypt the e-mail message.

13.4.5 Folders

It is often convenient to sort e-mail messages into a variety of folders. To view your folder tree, select ‘View’ → ‘Folder Bar’. If accessing mail over IMAP, the IMAP folders are also shown in this folder bar. For POP and most other formats, your folders are stored locally, sorted under ‘Local Folders’. Your ‘Contacts’, ‘Calendar’, and ‘Tasks’ are also treated as folders in this view, but should not be used for storing e-mail.

Several folders are included by default. ‘Inbox’ is where new messages fetched from a server are initially placed. ‘Sent’ is used for saving copies of sent e-mail messages. ‘Outbox’ is temporary storage for e-mail that has not yet been sent. It is useful if working offline or if the outgoing mail server is temporarily unreachable. ‘Drafts’ is used for saving unfinished e-mail messages. The ‘Trash’ folder is intended for temporary storage of deleted items. The folder can be emptied automatically by activating the respective option under ‘Tools’ → ‘Settings’ → ‘Mail Preferences’.
New folders can be created under ‘Local Folders’ or as subfolders of existing folders. Create as complex a folder hierarchy as desired. To create a new folder while in the ‘Inbox’ view, select ‘File’ → ‘Folder’ → ‘New Folder’. In the following dialog, enter a name for the new folder. Leave the ‘Folder Type’ as ‘Mail’ for a new mail storage folder. Use the mouse to determine the parent folder under which to place the new folder. Exit the dialog with ‘OK’.

To move a message into a folder, select the message to move. Right-click to open the context menu. Select ‘Move to Folder...’ and, in the dialog that opens, the destination folder. Click ‘OK’ to move the message. The message header in the original folder is shown with a line through it, meaning it is marked for deletion in that folder. The message is stored in the new folder. Messages can be copied in a similar manner.

Manually moving a number of messages into different folders can be time-consuming. Filters can be used to automate this procedure.

### 13.4.6 Filters

Evolution offers a number of options for filtering e-mail. Filters can be used to move a message into a specific folder or to delete a message. Messages can also be moved directly to the trash with a filter. There are two options for creating a new filter: creating a filter from scratch or creating a filter based on a message to filter. The latter is extremely useful for filtering messages sent to a mailing list.

**Setting up a Filter**

Select ‘Tools’ → ‘Filters’. This dialog lists your existing filters, which can be edited or deleted. Click ‘Add’ to create a new filter.

Enter a name for the new filter in ‘Rule Name’. Select the criteria to use for the filter. Options include sender, recipients, source account, subject, date, and status. The drop-box showing ‘Contains’ provides a variety of options, such as *contains*, *is*, and *is not*. Select the appropriate condition. Enter the text for which to search. Click ‘Add criterion’ to add more filter criteria. Use ‘Execute actions’ to determine if all or only some of the criteria must be met to apply the filter.

In the lower part of the window, determine the action to take when the filter criteria are met. Messages can, for example, be moved or copied to a folder or assigned a special color. When moving or copying, select the destination folder by clicking. In the folder list that appears, select the folder. Use ‘New’ to create a new folder. Click ‘OK’ when the correct folder is selected. When finished creating the filter, click ‘OK’.
Creating a Filter from a Message
Select the message on which to base the filter. Right-click and select ‘Create Rule From Message’. Select the desired filter option. This opens the filter creation dialog with the correct criteria already selected. Add additional criteria if desired. Select the appropriate filter action. Click ‘OK’ when finished.

Applying Filters
Filters are applied in the order listed in the dialog accessed with ‘Tools’ ➝ ‘Filters’. Change the order by highlighting a filter and clicking ‘Up’ or ‘Down’. Click ‘OK’ to close the filter dialog when finished.

Filters are applied to all new mail messages. They are not applied to mail already in your folders. To apply filters to messages already received, select the desired messages then select ‘Actions’ ➝ ‘Apply Filters’.

13.4.7 Virtual Folders
VFolders are a unique feature of Evolution. A VFolder is a virtual folder that displays messages based on search or filter criteria. Rather than moving the mes-
sages into a folder, messages shown in a virtual folder remain in their original folder. Actions are applied to the message in the original folder.

VFolders are a useful means of reading new mail in one place after it has been sorted into a number of different folders with filters. For example, a VFolder could be created to search all your folders for unread e-mail.

To create a new virtual folder, select ‘Tools’ → ‘Virtual Folder Editor...’. In the dialog, click ‘Add’. Like filters, virtual folders can also be created from e-mail messages. Right-click the e-mail message, select ‘Create Rule from Message’, and define the desired criteria.

Enter a ‘Rule Name’. For the new mail example mentioned above, set the criterion to ‘Status’ ‘is not’ ‘Read’. Set the sources as desired. Other VFolder searches can be set similarly. Click ‘OK’ when finished. This returns to the virtual folder list. The order can be changed if desired. Click ‘OK’ to close it.

The new VFolder is in the folder list under ‘VFolders’. You can read, answer, and delete e-mail with the VFolder. However, deleting the message deletes it from the real folder in which it is stored, not just the VFolder.

### 13.5 Calendar

#### 13.5.1 Adding Appointments

To add a new appointment to your calendar, click ‘New Appointment’. Under the ‘Appointment’ tab, enter the details for the appointment. Select a category, if desired, to ease searching and sorting later. Optionally set for Evolution to provide a reminder before your appointment under the ‘Reminder’ tab. If the appointment occurs regularly, set that under ‘Recurrence’. Click ‘Save and Close’ after all settings are made. The new appointment is then shown in your calendar.

#### 13.5.2 Scheduling a Meeting

To schedule a meeting with other people, click ‘New Appointment’ then select ‘Actions’ → ‘Schedule Meeting’. Enter information as for an appointment. Under ‘Meeting’, add attendees. For those in your ‘Contacts’, click ‘Invite Others...’ and select attendees from the dialog. When finished, click ‘Save and Close’. The attendees will be sent an e-mail about the scheduled meeting.
This system can also be used to schedule a time that fits all attendees or to reserve resources. For more information about the scheduling functions, refer to the internal help.

### 13.5.3 Adding Tasks

Evolution helps to keep track of your tasks. To add a new task to your list, click ‘New Task’. Enter summary information, due and start dates, and a description. Enter task status and other information under ‘Details’. Click ‘Save and Close’ to add the task to your list. Double-click the task to reopen the dialog and make changes or mark it as completed.

### 13.6 Contacts

#### 13.6.1 Adding Contacts

Along with the name and e-mail address, Evolution can store other address and contact information about a person. The e-mail address of a sender can quickly be added by right-clicking the marked address in the message preview. Select ‘Add to Contacts’ and confirm the inclusion in the following pop-up. To enter more information, click ‘Edit Full’ to open the contact editor. Otherwise, click ‘OK’. If you have selected ‘Edit Full’, click ‘Save and Close’ to exit the contact editor when you are finished.

To enter a completely new contact, click ‘New Contact’ in the ‘Contacts’ view. Enter all desired contact information. Click ‘Save and Close’ when finished.

#### 13.6.2 Making a List

If you frequently send e-mail messages to a group of people, make this easier by creating a list. Click ‘New’ → ‘Contact List’ in the ‘Contacts’ view. The contact list editor opens. Enter a name for the list. Add addresses by typing the address in the box and clicking ‘Add’ or by dragging contacts from the ‘Contacts’ view and dropping them in the box. Toggle ‘Hide addresses’ to select whether the recipients can see who else has received the mail. Click ‘Save and Close’ when finished. The list is now one of your contacts and appears in the composition window after the first few letters are typed.
13.6.3 Sharing Contacts

To send contact information from your address book to another Evolution user, right-click the contact to share. Select ‘Forward Contact’. This sends the contact “card” as an attachment in an e-mail. Compose and send this message as usual. To add a contact you have been sent, go to the contact in the e-mail message and click ‘Save in addressbook’ to add the complete contact card to your address book.

13.7 Public Address Books in Evolution

By means of the LDAP protocol, Evolution can access public address books, such as those used by SUSE LINUX Openexchange Server or Microsoft Exchange. Evolution offers full access to these address books — it can read them and add new entries. If you use SUSE LINUX in a large network (e.g., in your company), do not hesitate to make use of this possibility.

Note

Some specific information about your network is required for configuring LDAP access. Obtain this information from the responsible system administrator.

To configure access to an LDAP server from your workstation, select ‘Tools’ → ‘Settings’ → ‘Directory Servers’. All previously configured LDAP accesses are listed in the overview. Click ‘Add’ to add a new LDAP access. A configuration assistant starts, helping configure the LDAP access in a few steps. Exit the welcome screen of the assistant with ‘Next’ and specify the following settings in the dialogs:

**Server Information** Enter the server name and the login method for the LDAP server. The default method is anonymous access.

**Connecting to the Server** Enter the port number and the security protocols (SSL or TLS) to use.

**Searching the Directory** Enter the search base, the search range, the search duration, and, possibly, a limitation of the displayed hits.
**Display Name**  In this last step, enter the name under which the selected server should appear in the list. Close the assistant with ‘Next’ and ‘Finish’.

Upon completion of the configuration, the new LDAP server appears in your contact list under ‘Other Contacts’ and can be browsed for any entries.

### 13.8 For More Information

Evolution offers extensive internal help pages. Use the ‘Help’ menu to access this information. For more information about Evolution, refer to Ximian’s web site at http://www.ximian.com.
Even in this age of the Internet and e-mail, traditional communication means like phone and fax are still important. The communication package CapiSuite offers an ISDN-based solution for a computer-supported answering machine and fax. The following chapter explains how CapiSuite works. This is followed by a description of its configuration with YaST and a brief introduction to the usage of the system.
CapiSuite is a daemon (a program that runs in the background) that provides basic telecommunication functions. The current version mainly offers functions for telephone and fax connections.

For example, the system supports the establishment and termination of incoming and outgoing fax and voice connections. Fax and audio files can then be sent and received over these connections. Some special functions, like the switching of a phone connection to a fax connection and the processing of DTMF (Dual Tone Multi Frequency — common touchtone phone tones), are supported.

However, the system does not constitute a complete application suite for certain tasks, such as an answering machine application. The actual application was written in the Python scripting language (a language especially suitable for beginners) and can thus be freely adjusted to your requirements. CapiSuite merely processes the provided scripts and executes the specified commands. This allows the creation of flexible solutions from a simple answering machine or fax program to a small call center (for which the system is still lacking some basic features).

The CapiSuite package includes some ready-made scripts that enable a comfortable multiuser answering machine and fax solution. The following pages refer to the use of these scripts. Following the installation, details on the system as well as instructions for writing custom scripts are available in /usr/share/doc/packages/capisuite/manual/index.html and on the project page http://www.capisuite.de.

14.1 Configuration

CapiSuite makes use of the CAPI programming interface for ISDN hardware. Because this interface has only been available for Linux for a short time, suitable drivers are not yet available for all ISDN adapters. However, drivers are already available for ISDN adapters from AVM and can easily be installed and configured with YaST.

Test the functionality of the CAPI driver by executing the command capiinfo as root. If detailed information about the capabilities of the ISDN adapter is returned, the driver is installed correctly and CapiSuite can be installed with YaST and used.
If needed, installation instructions are published on the web site of the CAPISuite project at http://www.capisuite.de.

Following the installation, YaST contains two modules for configuring the fax and answering machine functionality. These modules are described below.

### 14.1.1 Configuring Fax Services

The YaST module ‘Fax’ from the ‘Network Devices’ group contains a form with a user list and buttons for the processing of list entries. The list contains all the users already configured for the fax system. The CAPISuite scripts used here are multiuser and allow each user to send and receive faxes individually. The target number of an incoming call determines which user receives the fax. The list of this module is empty when it is started for the first time.

If various users want to receive faxes with CAPISuite, it must be ensured that the associated phone numbers are all different and that all these numbers are also associated with the line to which the ISDN adapter is connected. This is of importance if you concurrently use an ISDN PBX.

Use the buttons under the list to edit or delete existing entries or create new entries. When editing or creating, a dialog opens in which to enter or modify the following data:

**‘User’** Here, select the user for whom to activate the fax functionality. Incoming fax messages and status reports will be sent to this user account.
Figure 14.1: YaST Module for the Configuration of the Fax Function

‘Fax Numbers’ Phone numbers assigned to the user for incoming fax messages are entered in this field. Separate multiple phone numbers with commas. All faxes sent to these numbers will be forwarded to the user by e-mail. Leave this field empty if you only want the user to be able to send fax messages.

‘StationID’ For identification purposes, the fax protocol uses a special ID that should normally contain the external phone number of the fax device in international notation. An example for a valid station ID is +1 305 123456 for the fax number 123456 in Miami, Florida. The maximum length of this entry is twenty digits. Valid characters are numbers, spaces, and the + symbol as prefix to the international country code.

‘Header’ This field can contain an arbitrary text to use as a header for sent faxes. Whether and how this text is featured on the sent document depends on the ISDN driver used.
‘Action’ The default setting MailAndSave causes a received fax message to be saved in the system and forwarded to the user by e-mail. The SaveOnly option merely causes the fax to be saved to the hard disk. This option is recommended for expert users only.

Click ‘OK’ to accept the changes. Click ‘Cancel’ to drop the changes and close the form.

14.1.2 Configuring the Answering Machine

The provided standard scripts also offer a comfortable multiuser answering machine. This can be configured with the YaST ‘Answering Machine’ module in the ‘Network Devices’ group.

Similar to the fax configuration, there is a list with the already configured users (which is empty when the module is started for the first time). The recorded incoming call is sent to the user associated with the phone number. This shows the
importance of assigning unique phone numbers to the users. The individual user welcome message cannot be set at this point. The recording can be made later with the remote access function of the configured answering machine. The answering machine has an automatic silence recognition routine that terminates the recording session after five seconds without noises.

**Note**

Incoming fax calls are also automatically recognized and received in most cases. This automatic routine can, however, fail with older fax machines, which is why a separate fax number is to preferred whenever possible.

**Note**

Use ‘Add’, ‘Edit’, and ‘Delete’ to administer the entries. The entry form for creating a new entry or for modifying an existing one contains the following fields:
‘User’ Select the system user for whom the answering machine should be configured. One or more fax numbers are assigned to each registered user. Incoming calls to these numbers are then sent to the user as e-mails.

‘Phone Numbers’ Set the phone numbers for which messages should be recorded for the user. Faxes can also be sent to the declared phone numbers as the answering machine has an automatic fax recognition feature. Separate multiple numbers with commas.

‘Response Time’ This value defined in seconds determines after how much time the answering machine should answer an incoming call. A value can be selected from the list or entered.

‘Duration’ Determines the maximum recording time for the answering machine — the maximum duration of a recorded incoming call in seconds.
This value is usually of secondary importance, as the recording is usually terminated when the caller hangs up. However, to avoid extensive recordings, this value should be set to a reasonable time, such as two minutes (120 seconds).

‘Action’ The answering machine features various processing options for incoming messages. The default setting MailAndSave records a message, saves it in the system, and delivers it to the user by e-mail. The SaveOnly option can be chosen if the reception of e-mails is not desired. It merely saves the message to the hard disk. This option is only recommended for expert users. The None option completely deactivates the recording of messages. It plays the welcome message then hangs up.

‘PIN’ Enter a personal identification number (PIN) for remote access. A numerical code of any length can be entered. If it is entered during playback of the welcome message, the user is taken to the remote access menu. The remote access feature is disabled if the field is left empty.

‘OK’ accepts the changes. ‘Cancel’ closes the dialog without applying any changes.

14.2 Usage

The following section briefly describes the use of the system. Following a short introduction to the reception of messages with the Linux mail system, a description is provided for the operation of the fax functionality and the answering machine.

14.2.1 General Notes about Reception

The development of CapiSuite heavily relied on using already existing capabilities of Linux. This is why the delivery of incoming faxes and voice messages is handled by the internal Linux mail system instead of proprietary applications and protocols. This requires the configuration of a mail client for receiving local messages for each user of CapiSuite.

If you have not disabled the sending of mail in the CapiSuite configuration, you will receive all incoming voice and fax messages in your e-mail program, where you can view them or listen to them as usual.
14.2.2 Fax Operation

No further instructions are necessary for receiving fax messages. As soon as a fax is received for a number assigned to a user, the message is stored in the system and delivered to the user as an e-mail with a PDF attachment. PDF is a common exchange format for documents and can be read in virtually all operating systems with Acrobat Reader from Adobe.

For backup purposes, every document received is also stored on the hard disk in /var/spool/capisuite/users/\(<username>/received/. This directory can be accessed if anything goes wrong during the e-mail transmission or if an e-mail message was accidentally deleted. More information can be found in the CapiSuite documentation in /usr/share/doc/packages/capisuite/manual/index.html.

The command line tool capisuitefax is available for sending faxes. It accepts one or more target fax numbers and one or more documents in the PostScript format. This format is generated by most Linux applications when printing to a file. capisuitefax supports parameters such as the following:

- **-h** or **--help**  Returns a short summary of valid parameters.
- **-d** <number> or **--dialstring=<number>**  
  This parameter declares the target number to which the fax should be sent.
- **-q** or **--quiet**  capisuitefax usually generates a few informative messages. This option suppresses this and only allows the display of possible error messages.

The following command would send the two documents document1.ps and document2.ps to the target number 089123456:

```bash
 capisuitefax -d 089123456 document1.ps document2.ps
```

capisuitefax converts the documents to the correct format and stores them together with a description file in a special folder from which they are then fetched and sent by CapiSuite. There can be a short delay between the execution of the command and the actual sending. The user is notified by e-mail when a fax message has been successfully sent or after the failure of a set number of attempts.

In the standard desktop KDE, fax messages can easily be sent from any KDE application with the help of the KDEPrintFax utility. Configure KDEPrintFax as follows:
1. Start KDEPrintFax. This can be done by pressing (Alt-F2) and entering kdeprintfax.

2. Select ‘Settings’ → ‘Configure KDEPrintFax’.

3. Click the ‘System’ icon in the left pane.

4. As capisuitefax is largely compatible with the HylaFAX suite, select HylaFAX under ‘Fax system’.

5. Set ‘Command’ to /usr/bin/capisuitefax -d %number %files.

6. Finish the configuration by clicking ‘OK’ and closing KDEPrintFax.

*Figure 14.5: Configuring CapiSuite in KDEPrintFax*
'Send to Fax' is then available in the ‘Print’ menu of any KDE application. Selecting it starts KDEPrintFax, which requests the target phone number and sends the fax.

Non-KDE applications can also use this function if their print command can be set manually. In this case, replace lpr with kprinter. When you print a document, the KDE print menu will be displayed along with the possibility to transmit fax messages.

---

**Caution**

To date, capisuitefax does not support the full range of HylaFAX features. Thus, features such as the resolution settings are currently ignored.

---

### 14.2.3 Operation of the Answering Machine

If e-mail transmission was not deactivated, voice messages left on the answering machine are sent by e-mail to the recipient associated with the dialed phone number. Thus, the operation of the answering machine does not require any additional description. All incoming messages can be received and opened in the e-mail client. For backup purposes, the incoming messages are also stored in `/var/spool/capisuite/users/{username}/received/`.

The recording of the personal welcome message is performed directly over the remote access feature of the answering machine. To access your answering machine remotely, call your associated number from any telephone. Enter the previously-defined PIN during the welcome message playback. Wait a few seconds if you mistype your PIN then try again after the beep. Shortly after having correctly entered the PIN, the answering machine gives the number of stored messages. You then have the choice of recording a new welcome message or listening to your stored messages. Follow the instructions given.

The following table provides a brief overview of the menu items for remotely accessing messages. It is recommended to carry a copy of it if you use the remote access frequently. The commands can be entered at any time during the playback of the messages. This means that an excessively long voice message can be skipped easily.
Table 14.1: Commands for Message Playback

<table>
<thead>
<tr>
<th>Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>delete current message</td>
</tr>
<tr>
<td>4</td>
<td>skip to the next message</td>
</tr>
<tr>
<td>5</td>
<td>skip to the previous message</td>
</tr>
<tr>
<td>6</td>
<td>replay current message</td>
</tr>
</tbody>
</table>
Part IV

Multimedia
Sound in Linux

Linux offers a wide range of sound applications in various stages of development. This chapter provides an overview of a wide range of applications for various multimedia tasks together with some technical background information. Applications that are not part of the standard installation can be installed with YaST.
15.1 The ALSA PCM Types

As of version 0.9 of the *Advanced Linux Sound Architecture* ( ALSA), the concept for PCM devices was fundamentally modified and expanded. PCM is an acronym for “Pulse Code Modulation” and designates the digital output interfaces when relating to sound cards. The user can influence the way ALSA addresses the sound card by selecting a specific PCM type. The main PCM types are hw and plughw.

To understand the difference between the two types, consider how a PCM device is opened. It must be opened with specific settings for at least the following parameters: sample format, sample frequency, number of channels, number of periods (previously referred to as fragments), and size of a period. For example, an application may attempt to play a WAV file with a sample frequency of 44.1 kHz although the sound card does not support this frequency. In this case, ALSA can automatically convert the data in the plug-in layer to a format supported by the sound card. The conversion affects the following parameters: sample format, sample frequency, and number of channels.

Activate the plug-in layer by selecting the PCM type plughw. If the PCM type hw is selected, ALSA tries to open the PCM devices directly with the parameters required by the application. The complete designator for a PCM device consists of the PCM type followed by a colon, the card number, and the device number, for example, plughw:0, 0.

The dmix output plug-in is a recent addition to the PCM types. It allows applications to share access to a PCM device on sound cards that do not support this natively. The complete identifier in this case is plug:dmix. More information about dmix can be found at [http://alsa.opensrc.org/index.php?page=DmixPlugin](http://alsa.opensrc.org/index.php?page=DmixPlugin).

15.2 Mixers

Mixers provide a convenient means of controlling the volume and balance of the sound output and input of computers. The main difference between the various mixers consists in the outer appearance of the user interface. However, there are a number of mixers that are designed for specific hardware. One example is envy24control, a mixer for the Envy 24 sound chip. Another one is hdspmixer, which is for RME Hammerfall cards. From the mixers available, select the one that best suits your needs.
Note

Generally, it is advisable to open a mixer application prior to opening other sound applications. Use the mixer to test and adjust the control settings for the input and output of the sound card. Some sound cards may not allow simultaneous access from multiple applications. If a sound application freezes, this might be the cause.

15.2.1 gamix

If you have multiple sound cards, gamix provides a set of controllers for each card. Slide the control sliders to set the levels as desired.

![Figure 15.1: The Mixer gamix](image)

15.2.2 qamix

QAMix is a mixer with a QT interface. If necessary, the application interface can be configured in a flexible way in an XML file. All parameters can be controlled via MIDI. On start-up, the application first searches the directory ~/.qamix for an XML file corresponding to the name of the ALSA driver of your sound card. If such a file does not exist, it searches the same directory for the file default.xml. If this file does not exist either, the program continues its search in the directory /usr/share/qamix.
If you have several sound cards, select the desired card with the parameters \texttt{-d}. The parameter \texttt{hw:0} stands for the first sound card, \texttt{hw:1} for the second, and so on. The parameter \texttt{-g} can be used to specify a file for the XML description of the application interface explicitly. Detailed information about the XML format is available in the directory \texttt{/usr/share/doc/packages/qamix}.

![Figure 15.2: The Mixer QAmix](image)

### 15.2.3 KMix

KMix is the KDE mixer. It provides a convenient and familiar interface for KDE users. It can also be integrated into the KDE panel.

### 15.2.4 The GNOME Mixer Applet

If you use GNOME, the GNOME Mixer applet can be added to the panel for convenient volume control. Simply right-click the panel then select ‘Add to Panel’ \rightarrow ‘Multimedia’ \rightarrow ‘Volume Control’. Right-click the volume control applet then select ‘Run Volume Control’ to access the more advanced mixer functions.

### 15.2.5 alsamixer

alsamixer can be run from the command line without the X environment. The application is operated with the cursor keys. Use \texttt{Q}, \texttt{W}, \texttt{E}, \texttt{Y}, \texttt{X}, and \texttt{C} to set different levels for the left and right channels. \texttt{M} mutes single channels. In this
case, ‘MM’ appears above the muted controller. To terminate `alsamixer`, press `Esc`.

The basic controls for sound output are ‘Master’, ‘PCM’, and ‘CD’. ‘Master’ sets the master volume. ‘PCM’ and ‘CD’ control the respective weighting of the PCM and audio CD channels.

Determine the recording source by pressing `Space`. The ‘capture’ controller regulates the input amplifier. Whether the ‘Line’ controller or the ‘MIC’ controller is used depends on the recording source.

For more information, enter `man alsamixer`. `alsamixergui` is a mouse-operated variant of `alsamixer` with a graphical interface.

---

**Note**

The look and feel of `alsamixer` depends on the type of sound card used. The description referred to the AC97 standard for mixer functionality. If your sound card does not comply with this standard, some features may not be supported. The mixer `Envy24` should be used for sound cards equipped with the `Envy24` (ice1712) chip (see `The Mixer for the Sound Chip Envy24` on this page).

---

15.2.6 Mixer Parameters of Soundblaster Live! and Audigy

Apart from the parameters of the ‘AC97’ standard, there are many additional options for Soundblaster Live! and Audigy cards. The controls ‘AC97’, ‘Wave’, and ‘Music’ are used for playback. ‘AC97’ can be used to adjust the level of the ‘AC97’ mix. This mix also receives input from the ‘line’, ‘mic’, and ‘CD’ signals. ‘Wave’ adjusts the level of the PCM channels. ‘Music’ controls the volume of the internal wavetable synthesis of MIDI data.

Apart from the ‘Capture’ parameter for recordings, the ‘AC97 Capture’ control is used to control the level of the ‘AC97’ recording sources. Furthermore, ‘Wave’ and ‘Music’ can be selected as recording source. This internal loopback capture can be activated in the ‘AC97’ standard by selecting the ‘Mix’ control as recording source.

---

15.2.7 The Mixer for the Sound Chip Envy24

`envy24control` is a mixer application for sound cards using the `Envy24` (ice1712) chip. Start this mixer with ‘SUSE’ → ‘Multimedia’ → ‘Sound’ or from the com-
Figure 15.3: Monitor and Digital Mixer of envy24control

The flexibility of the Envy24 chip can result in varying functionalities in different sound cards. The latest details on this sound chip are available in /usr/share/doc/packages/alsa/alsa-tools/envy24control.

Monitor and Patchbay of envy24control

The ‘Monitor Mixer’ of envy24control shows the signal levels that can be mixed digitally in the sound card. The signals designated as ‘PCM Out’ are generated by applications that send PCM data to the sound card. The signals of the analog inputs are shown under ‘H/W In’. The ‘S/PDIF’ inputs are shown to the right. The input and output levels of the analog channels must be set under ‘Analog Volume’.

Use the ‘Monitor Mixer’ sliders for digital mixing. The respective levels are displayed in the ‘Digital Mixer’. For each output channel, the ‘Patchbay’ contains a row of radio buttons for selecting the desired channel source.

Analog Inputs and Outputs

Adjust the amplification for the analog-to-digital and digital-to-analog converters under ‘Analog Volume’. The ‘DAC’ sliders are used for the output channels and the ‘ADC’ sliders are used for the input channels. Use the radio buttons to switch the levels between +4 dBu and -10 dBV. The first setting is intended for audio professionals. The latter is for private purposes.
15.2.8 Configuration of the S/PDIF Channels

The S/PDIF channel settings are made under ‘Hardware Settings’. The Envy24 chip reacts to volume changes with a delay that can be configured with ‘Volume Change’.

15.3 Players

Linux offers a variety of programs for playing audio CDs and various music formats such as MP3, OGG, and WAV files. Where possible, the supported formats of the players are listed.

15.3.1 amaroK

As well as Kscd, which is a pure audio CD player, KDE comes with the amaroK media player, which handles various audio formats, such as MP3 and OGG, and plays the streaming audio broadcast by radio stations on the Internet. The program handles all file types supported by the sound server acting as a back-end — currently aRts or GStreamer.

amaroK enables you to put together playlists very easily. Compile playlists with a few drag and drop actions. Playlists can be created using a number of different views, simplifying management of music titles. You can also drag and drop files from Konqueror. Save playlists in m3u or pls format, so you can share them with any other players using these formats.

After starting amaroK for the first time, the program displays two windows. The smaller window contains the usual controls of a media player and the other shows the playlist. See Figure [15.4] on the next page. Both windows can be hidden as needed. To display or hide the playlist, click ‘PL’ in the player window. To hide the player window itself, set the program’s preferences accordingly. When the player window is hidden, the control elements are displayed at the bottom of the playlist window. To open the amaroK application menu, right-click anywhere in the player window or select the menu button in the bottom right of the playlist window. The menu includes a help entry, which describes the program’s numerous features.
Playlists

The right part of the playlist window contains the currently-loaded playlist. Play titles listed in it in the order of your choice. Initially, the list is empty, so you need to create one. The best way to do this is by using the sidebar to the left of the window. To the very left, there are a number of tabs that can be used to open different views. From each of these views, drag individual titles or entire directories and drop them into the playlist to include them in the list. The following is a description of the function of each tab.

File Browser  This is the top tab, which opens a file browser. This corresponds to the standard KDE file selector dialog with the usual controls to navigate the file system. Enter a URL or directory directly into the text input field. From the contents displayed, drag elements to the playlist to include them in it.

Collection  Use this view to manage and display your personal collection of titles. The collection view may include files from different locations. Selecting ‘Actions’ \rightarrow ‘Configure Folders’ opens a dialog with which to include all
Sound in Linux

your music folders in a list. To scan all these directories, select ‘Actions’ → ‘Start Scan’. The result is displayed as a tree structure. Using ‘Primary’ and ‘Secondary’, organize the two top branches of the tree according to the criteria ‘Album’, ‘Artist’, ‘Genre’, and ‘Year’. Once the tree view is ready, find titles simply by typing them into the input field. The selection in the tree view jumps to the first matching entry automatically as you type.

Context  With this tab, view information about your collection and various data related to the current artist. For example, the view informs you about your favorite titles, the newest titles added to the collection, and other details.

Search  This tab opens a dialog in which to perform a recursive search for a file in a given directory. To do so, enter a text string for the title and the location at which to start the search. Then select ‘Search’ and wait for the results to appear in the lower section of the window.

Streams  This view manages Internet radio streams. After making sure that you are connected to the Internet, select ‘Fetch Stream Information’. amarok includes an entry for every reachable stream in the list below. Then drag any entry from this list and drop it into the playlist to listen to the broadcast.

Effects
Select the ‘FX’ button in the player window or use the amarok application menu to open a dialog in which to enable and configure several sound effects, such as an equalizer, the stereo balance, and a hall effect. Select the desired effects and adjust the settings, if available, for each of them.

Visualizations
amarok comes with a number of visualizations that display a graphical effect for the music played. Native amarok visualizations are displayed in the player window. Cycle through the various available display modes by clicking the animation.

In addition to the above, amarok also supports the visualization plug-ins of the XMMS media player. To use these, first install the xmms-plugins package then select ‘Visualizations’ from the amarok menu. This opens a window listing the available plug-ins. XMMS plug-ins are always displayed in an extra window. In some cases, there is an option to display them in fullscreen mode. For some plug-ins, you may not get a smooth visual effect unless you use a 3D-accelerated graphics card.
15.3.2 XMMS

XMMS is another full-featured media player with robust audio support, so that pops or breaks during playback should be very rare. The application is easy to use. The button for displaying the menu is located in the upper left corner of the program window.

Figure 15.5: XMMS with Equalizer, OpenGL Spectrum Analyzer, and Infinity Plug-Ins

Select the output plug-in module with ‘Options’ → ‘Preferences’ → ‘Audio I/O Plugins’. If the `xmms-kde` package is installed, the aRts sound server can be configured here.

Note

XMMS automatically redirects its output to the ‘Disk Writer Plugin’ if it is not able to find a configured sound card. In this case, the played files are written to the hard disk as WAV files. The time display then runs faster than when playing the output through a sound card.
Various visualization plug-ins can be started through ‘Options’ → ‘Preferences’ → ‘Visualization Plugins’. If you have a graphics card with 3D acceleration, select an application such as the OpenGL spectrum analyzer. If the `xmms-plugins` package is installed, try the Infinity plug-in.

To the left under the menu button, there are five buttons with different letters on them. These buttons allow quick access to additional menus, dialog boxes, and configurations. The playlist can be opened with the ‘PL’ button and the equalizer can be activated with the ‘EQ’ button.

### 15.3.3 kscd — Audio CD Player

kscd is an easy-to-use audio CD player. It can be accessed from the ‘SUSE’ menu under ‘Multimedia’ → ‘CD’ → ‘KsCD’. To access the configuration menu, click the tool icon. kscd can be configured to search an online CDDB server for the name and track names of a CD.

![The kscd User Interface](image)

**Figure 15.6: The kscd User Interface**

### 15.3.4 The Audio CD Player WorkMan

WorkMan offers a simple user interface with an abundance of functions. It is ideal for those who prefer a CD player without the KDE look and feel.

### 15.3.5 GNOME CD Player Applet

This is a simple applet that can be added to a GNOME panel. Add it by right-clicking the panel and selecting ‘Add to Panel’ → ‘Multimedia’ → ‘CD Player’.
15.4 Buffering and Latencies

This section explains how uninterrupted audio playback can be ensured. This problem is by no means limited to Linux, but is inherent in all multitasking operating systems. In a multitasking operating system, several processes usually run concurrently. As the processor can only handle one process at a time, each process is assigned a certain amount of time by the operating system’s scheduler. The switching action between processes normally happens so quickly that the user does not notice it.

However, during audio playback, even brief interruptions are noticeable in the form of clicks. Therefore, audio programs use a buffer for the playback, enabling the audio data in the buffer to be emitted continuously by the sound card even when the audio program is interrupted by the scheduler. Accordingly, the playback is click-free if the buffer is large enough to bridge the longest possible interruption.

However, the buffer size also determines the reaction time (latency) of the program. Therefore, the buffer size is kept as small as possible especially for interactive applications, such as real-time synthesizers and DJ mixer consoles. Basically, the length of the interruptions depends on the system load and the priority of the process. Consequently, the size of the buffer required for click-free playback can be reduced by increasing the priority of the audio program or by switching to a real-time scheduler. For this reason, many audio programs attempt to switch their processes to a real-time scheduler, but switching a process to another scheduler is only possible with root privileges. The application setpriority in the rtstools package is required for this task.

For example, proceed as follows to run the application timidity with the FIFO scheduler:

1. Start timidity
2. Open a root console session.
3. Use pidof timidity to find the process ID of timidity.
4. Change the scheduler with the command setpriority <processID> fifo 10.

You can use the following command in a root shell to speed up this procedure:
for i in 'pidof timidity'; do setpriority $i fifo 10; done

Running a program in root mode is always risky, as the program is permitted to do anything. If the computer is connected to the Internet, the security risk would be unacceptable. Security bugs in the program could be exploited for the purpose of gaining access to the system.

---

**Caution**

The commands described in the following paragraphs should *never* be executed on machines that can be accessed from the Internet or if a system crash or data loss would have serious consequences.

---

The *sudo* mechanism should be used for running a program in root mode. This mechanism is demonstrated by means of the *timidity++* application. To enable all users on your system to execute *timidity++* with root privileges, modify the file `/etc/sudoers`. See *sudo* and *sudoers* for the procedure. If you are not familiar with *vi*, select a different editor, such as *joe*, by exporting the desired editor, for example, with the command `export EDITOR=joe`. Then execute `visudo` as root and append the following line at the end of the file `/etc/sudoers`:

```
ALL ALL=(ALL) /usr/bin/timidity
```

Now all system users are permitted to run *timidity++* in root mode with the command `sudo timidity`. The password of the respective user is requested if more than five minutes passed since the last `sudo` command.

---

15.5 The JACK Audio Connection Kit

Using the JACK Audio Connection Kit (packages named *jack* and *qjackconnect*), applications can exchange audio data with each other and with the sound card. This is only possible if the respective application has a JACK interface. JACK support has become a standard feature, so there are many applications that have the needed interface.

To use JACK, either start the graphical front-end *QJackCtl* or start the engine from the command line with `jackd -d alsa -d hw:0`. JACK was designed
to achieve a low latency. Therefore, the engine should run with real-time priority. For more information, read the file /usr/share/doc/packages/jack/README.SuSE.

The patchbay QJackConnect assists in tracking the JACK clients running in your system. Following the program launch with qjackconnect, the clients with readable ports are listed on the left side and the clients with writable ports are listed on the right side. If no JACK clients were started, the lists initially only display the inputs and outputs of the sound card. The lists are updated automatically as the port configuration changes. The ports are displayed in a tree view under the client. Connect individual ports by selecting them from the lists and clicking ‘Connect’. Connect multiple ports simultaneously by selecting clients.

15.6 Hard Disk Recording with Audacity

With audacity (package audacity), record and edit audio files. This is called hard disk recording. When you start the program for the first time, select a language. At other times, change the language setting under ‘File’ → ‘Preferences’ → ‘Interface’. The language change is then effective the next time you start the program.
15.6.1 Recording WAV Files and Importing Files

Click the red recording button to generate an empty stereo track and start the recording. To change the standard parameters, specify the settings under ‘File’ → ‘Preferences’. ‘Audio I/O’ and ‘Quality’ are important for the recording. Even if tracks already exist, pressing the recording button creates new tracks. Initially, this may be confusing, as these tracks cannot be seen in the standard-size program window.

To import audio files, select ‘Project’ → ‘Import Audio’. The program supports the WAV format as well as the compressed MP3 and Ogg Vorbis formats. See Compressing Audio Data on page 192 for more information about these formats.
15.6.2  Editing Audio Files

The ‘AudioTrack’ menu can be opened to the left of each track and offers various views. One of them is ‘Waveform dB’, which is not suitable for checking the signal tuning, as in this view the data is always adjusted to the maximum amplitude of the track.

Depending on the application, various view formats for segment selections are offered under ‘Set Selection Format’. With ‘Set Snap-To Mode’, the segment boundaries can automatically be adapted to the selected view format. For example, if you select ‘PAL frames’ as the view format and activate ‘Snap-To’, the segment boundaries will always be selected in multiples of frames.

The many editing tools are all equipped with tool tips and should therefore be quite easy to use. The ‘Undo History’ function, which can be accessed with ‘View’ → ‘History’, is a useful feature for viewing recent editing steps and undoing them by clicking the respective item in the list. Use ‘Discard’ with caution, because it deletes editing steps from the list. Subsequently, these steps can no longer be undone.

![Figure 15.9: The Spectrum](image)

```plaintext
10 dB
0 dB
-10 dB
-20 dB
-30 dB
-40 dB
-50 dB
-60 dB
-70 dB
-80 dB
43Hz 87Hz 173Hz 348Hz 691Hz 1KHz 3KHz 6KHz 11KHz

Cursor: 587 Hz (D4) = -10 dB  Peak: 623 Hz (D#4)
Spectrum
Hanning window

1024
Log frequency

Export...
Close
```

Figure 15.9: The Spectrum
The built-in spectrum analyzer assists in quickly tracking down any noises. View the spectrum of the selected segment with ‘View’ → ‘Plot Spectrum’. Select a logarithmic frequency scale in octaves with ‘Log frequency’. If you move the mouse pointer within the spectrum, the frequencies of the peaks are automatically displayed together with the respective notes.

Unwanted frequencies are best removed with ‘Effect’ → ‘FFT Filter’. In connection with the filtering process, it may be necessary to readjust the signal amplitude with ‘Amplify’. Additionally, ‘Amplify’ can be used to check the amplitude. By default, the ‘New Peak Amplitude’ is set to 0.0 dB. This value represents the highest possible amplitude in the selected audio format. ‘Amplification’ shows the value needed to amplify the selected segment to this peak amplitude. A negative value indicates overamplification.

### 15.6.3 Saving and Exporting

To save the entire project, select ‘File’ → ‘Save Project’ or ‘Save Project As’. This generates an XML file with the extension .aup, which describes the project. The actual audio data is saved in a directory named after the project with _data appended.

The entire project or the currently selected segment can also be exported as a stereo WAV file. To export the project in MP3 format, refer to the information in [Compressing Audio Data](#) on the next page.

### 15.7 Direct Recording and Playback of WAV Files

`arecord` and `aplay` from the kalsatools package provide a simple and flexible interface to the PCM devices. `arecord` and `aplay` can be used to record and play audio data in the WAV format among other formats. The command `arecord -d 10 -f cd -t wav mysong.wav` records a WAV file of ten seconds in CD quality (16 bit, 44.1 kHz). List all options of `arecord` and `aplay` by running them with the `--help` option.

`q@Record` is a simple recording program with a graphical interface and level display. As this program makes use of an internal buffer of about 1 MB (configurable with `--buffersize`), it enables uninterrupted recordings even on slow hardware, especially if it is run with real-time priority (for more information,
see Buffering and Latencies on page 186. During the recording, the currently-used buffer size is displayed in the status line under ‘Buffer’ and the maximum buffer size required so far for this recording is displayed under ‘Peak’.

Figure 15.10: QARes – A Simple Hard Disk Recording Application

15.8 Compressing Audio Data

Uncompressed audio data in CD quality consumes almost ten MB per minute. The MP3 procedure was developed by Fraunhofer IIS for the purpose of drastically compressing this data. Unfortunately, this procedure is patented. Therefore, companies that distribute MP3 encoders are required to pay license fees. The powerful MP3 encoder Lame was developed for Linux. Although the source code of Lame is under the GPL, SUSE is not allowed to include this encoder in our distribution. For more information about the legal situation, visit the project web page at http://lame.sourceforge.net. In some countries (including Germany and the USA), the use of Lame is permitted for research purposes only.

Ogg Vorbis (package name vorbis-tools) is a free audio compression format that is now supported by the majority of audio players. The web page of the project is http://www.xiph.org/ogg/vorbis. The vorbis-tools package includes an encoder and a simple player. The encoder is started from the command line with `oggenc`. The only parameter needed is the WAV file to compress. The option `-h` displays an overview of the other parameters. The latest version of the Ogg encoder even supports encoding with a variable bit rate. In this way, an even higher degree of compression can be achieved. Instead of the bit rate, specify the
desired quality with the parameter \(-q\). The parameter \(-b\) determines the average bit rate. \(-m\) and \(-M\) can be used to specify the minimum and maximum bit rate. 

ogg123 is a command-line Ogg player. The program requires the specification of a playback device. Start it with a command like `ogg123 -d alsa09 mysong.ogg`.

### 15.9 ALSA and MIDI

Apart from the possibility to play PCM data, many sound cards also offer MIDI functionality. The ALSA MIDI sequencer implements an efficient architecture for routing MIDI data. You need the packages `pmidi`, `aseqview`, `vkeybd`, `awesfx`, `snd_sf2`, and `kalsatools`.

Many sound cards have an external MIDI port for connecting MIDI devices, such as synthesizers, keyboards, and sound modules. If the MIDI port of the card is supported by ALSA, use a sequencer application, such as `jazz`, to record and play MIDI files. An overview of the MIDI devices provided by your card is available in the KDE Control Center under ‘Sound & Multimedia’ \(\rightarrow\) ‘Sound System’ \(\rightarrow\) ‘MIDI’. Here, also determine the devices to use for playing MIDI files. On the command line, list the available MIDI devices and their internal ALSA port numbers with the command `pmidi -l`. For a Soundblaster Live! card, the listing would appear as in Example 15.1.

**Example 15.1:** MIDI Devices of a Soundblaster Live! Card

<table>
<thead>
<tr>
<th>Port</th>
<th>Client name</th>
<th>Port name</th>
</tr>
</thead>
<tbody>
<tr>
<td>72:0</td>
<td>External MIDI 0</td>
<td>MIDI 0-0</td>
</tr>
<tr>
<td>73:0</td>
<td>Emu10k1 WaveTable</td>
<td>Emu10k1 Port 0</td>
</tr>
<tr>
<td>73:1</td>
<td>Emu10k1 WaveTable</td>
<td>Emu10k1 Port 1</td>
</tr>
<tr>
<td>73:2</td>
<td>Emu10k1 WaveTable</td>
<td>Emu10k1 Port 2</td>
</tr>
<tr>
<td>73:3</td>
<td>Emu10k1 WaveTable</td>
<td>Emu10k1 Port 3</td>
</tr>
</tbody>
</table>

The first column lists the internal port numbers by which the device is addressed by the ALSA driver. The other columns show the designation and port name of the device. Apart from the external MIDI port, several WaveTable ports are listed. Use a command like `pmidi -p 73:0 mysong.mid` to play a MIDI file over one of the listed ports.
Note

If a MIDI player is interrupted during playback, a continuous sound may persist. If this happens, run the all_notes_off script or restart ALSA as root with rcalsasound restart.

Note

Many sound cards (like Soundblaster AWE and Live!) have an internal WaveTable synthesizer that converts MIDI events into audible sounds. These MIDI events can be sent to the WaveTable synthesizer by an external MIDI keyboard or by a program, such as a MIDI player or sequencer. For Soundblaster AWE and Live! cards, the WaveTable synthesizer must be initialized with a sound font before any sound can be heard.

15.9.1 Loading Sound Fonts: SB Live! and AWE

The package awesfx contains the sfxload command for loading sound fonts in Soundblaster AWE and Live! cards. Suitable sound font files are available on the driver CD of your sound card. The start-up script of ALSA can automatically load the sound fonts required for the WaveTable synthesis, provided the respective files were installed from the Creative driver CD using YaST. Currently, the script only works for one sound card. However, ALSA can easily manage up to eight sound cards.

Sound fonts can be loaded with a command like sfxload -D <n> /usr/share/sfbank/creative/8MBGMSFX.SF2. ⟨n⟩ stands for the number of the sound card (0, 1, etc.). This may not be the number under which the sound card was configured. This number is instead determined by the order in which the individual sound drivers are loaded.

You can also load one of the sound fonts installed in /usr/share/sounds/sf2. The sound font Vintage_Dreams_Waves_v2.sf2 by IAN WILSON contains 128 analog synthesizer sounds and eight drum sets. It is suitable for SB AWE as well as for SB Live! cards. The ROM sound font gu11-rom.sf2 by SAMUEL COLLINS is only suitable for SB AWE cards. It provides an extended general MIDI bank for these cards. Review the copyright files and the documentation in /usr/share/doc/packages/snd_sf2. More sound fonts are available at URLs such as http://www.hammersound.net.
15.9.2 vkeybd — Virtual MIDI Keyboard

If you do not have an external MIDI keyboard connected to your sound card, use the virtual keyboard vkeybd. For this purpose, the internal port numbers listed with `pmidi -l` as described above are important. To start the program from the command line, enter `vkeybd --addr 73:0 &`. The port address must be adapted to your system. Specify the first WaveTable port from the list. If an external sound generator is connected, alternatively specify the port number of the external MIDI port.

vkeybd supports a number of additional options. For example, enter `vkeybd --addr 73:0 --octave 5 &` to increase the number of displayed octaves to five. An overview of the command line options can be accessed with `vkeybd --help` or in `vkeybd`.

The instrument designation in the preset list can be configured by specifying a preset file with the `--preset` option. Extract the instrument names of a sound font file with the command `sftovkb`. Change to the respective directory with `cd /usr/share/sounds/sf2` and enter the command `sftovkb Vintage_Dreams_Waves_v2.sf2 > /vintage.vkb` to save the names in your home
directory in `vintage.vkb`. The `vkeybd` interface can be configured with the ‘view’ menu.

The mapping of the keys to the sent MIDI notes is saved in the file `~/.vkeybdrc`. Additional specifications can be made in this file. To implement your own modifications, retrieve the designations of keyboard events with the `xev` program.

15.9.3 Establishing Connections between MIDI Ports

![Image of readable and writeable ports](image)

**Figure 15.12:** Connecting MIDI Ports and Status Display with `kaconnect`

ALSA provides an efficient infrastructure for the connection of several MIDI ports. Sound cards and MIDI programs (provided these support the ALSA sequencer structure) have one or several MIDI ports for communicating with each other. These ports can be connected with the KDE program `kaconnect` or the command `aconnect`. On start-up, `kaconnect` shows the readable and writable MIDI ports available on your system and the connection status. To test the procedure, start two MIDI programs with the commands `vkeybd` and `aseqview`. For the connection between MIDI ports, specify the port address of the program after the program name. For example, assign port number `128:0` to the first program and `129:0` to the second. The ports of the programs are also displayed by `kaconnect`.

196  15.9. ALSA and MIDI
As `vkeybd` was executed without the `--addr` parameter, the connection between the program port and the WaveTable port (or the external MIDI) port can now be established manually. To do this, select the respective ports and click ‘connect’. To use the command-line tool `aconnect`, enter `aconnect 128:0 73:0` (or the respective ports) to establish a unidirectional connection between the sender port `128:0` and the receiver port `73:0`.

You can now establish a connection between the MIDI port of the keyboard and the MIDI port of the ALSA sequencer viewer. If you modify keyboard settings, such as the panning or the pitch wheel (which must first be activated under ‘View’), these changes are promptly reflected in `aseqview`.

List the ports available for sending and receiving as well as their connection status with `aconnect -il` or `aconnect -ol`. Terminate connections established with `aconnect` with the option `-d`, for example, `aconnect -d 128:0 129:0`. To terminate all connections, enter `aconnect -x`. Get information about other options with `man aconnect`.

---

**Note**

`aseqnet` can be used to establish MIDI connections over a network.

---

**Figure 15.13: Configuring Split Zones with QMidiRoute**

The program QMidiRoute enables flexible MIDI routing. The MIDI events as received at the writable MIDI port are presented as one or several maps, from which they can be selected and transformed into other events. To mention just
one practical application of this technique, you could split a keyboard into several regions, each sending on a different MIDI channel. QMidiRoute also has a window listing all MIDI events received on the input port.

15.10 MIDI Playback without a WaveTable Card

Some sound cards do not have a WaveTable synthesizer for playing MIDI files with the loaded sound font (or instrument patch). In this case, use a software WaveTable synthesizer like fluidsynth or timidity++.

15.10.1 The Sound Font Synthesizer fluidsynth

After the program is started with a command like fluidsynth -a alsa -m alsa_seq gm.sf2, fluidsynth appears in the list of writable MIDI ports and can be used as sound source. In this example, gm.sf2 is a file in the widely-used SoundFont format. Suitable files are available on the Internet. fluidsynth has numerous command-line options that can be displayed with fluidsynth -h.

15.10.2 Configuration of timidity++

timidity++ is configured by means of the configuration file /usr/share/timidity/timidity.cfg. View documentation for the configuration with man timidity.cfg. Also refer to the documentation in /usr/share/doc/packages/timidity.

Suitable instrument patches are available at http://www.stardate.bc.ca/eawpatches/html/default.htm. From this URL, you can download the file eawpats12_full.rar. Although the size of this file is 22 MB, the download is worthwhile, because it equips you with a full set of GM, GS, and XG instruments. To use these patches with timidity++, proceed as follows. First, assume the root user identity. Then create the directory /usr/share/timidity/eawpats, copy eawpats12_full.rar there, and change to this directory. The command unrar x eawpats12_full.rar decompresses the archive.

Now edit the file timidity.cfg in the directory /usr/share/timidity/. It should only contain the two lines shown in File 15.2 on the facing page.
**Example 15.2: timidity.cfg**

dir /usr/share/timidity/eawpats source timidity.cfg

eawpats12_full.rar also contains a file called timidity.cfg, which is placed in the directory eawpats following the decompression. The file is included with the source command. In this file, only the four lines shown in Example 15.3 are relevant. All other lines can be deleted.

**Example 15.3: timidity.cfg of eawpats12_full.rar**

source gravis.cfg source gsdrums.cfg source gssfx.cfg source xgmap2.cfg

Then the file permissions must be updated. To do this, enter the command chmod -R a+r /usr/share/timidity/eawpats. To use sound fonts instead of the Gravis instrument patches, modify the file /usr/share/timidity/timidity.cfg. For example, to use the Vintage Dreams sound font with timidity++, create a timidity.cfg consisting of a single line: soundfont /usr/share/sounds/sf2/Vintage_Dreams_Waves_v2.sf2. More information about this subject is available in /usr/share/doc/packages/timidity/C/README.sf.

### 15.10.3 Starting timidity++ with the Graphical Interface

There are few programs that offer as many program interfaces as timidity++. For an overview, enter man timidity. The *Athena Widget Interface* is a mature interface that is started with /usr/bin/timidity -iatv &.

---

**Note**

You should not be in the directory /usr/share/timidity when you start timidity++.
15.10.4 The ALSA Server Mode of timidity++

To start timidity++ in the ALSA server mode, enter /usr/bin/timidity -iA -B2,8 -Os &. A message, such as Opening sequencer port: 128:0 128:1, will be displayed, showing the MIDI port by means of which the synthesizer can be addressed (e.g., with vkeybd --addr 128:0). To terminate timidity++, enter killall timidity to kill all timidity++ processes.

15.11 AlsaModularSynth — Synthesizer and Effect Processor

AlsaModularSynth (from the package alsamodular) is a digital replica of an analog modular synthesizer. The program has a JACK interface and can load all kinds of LADSPA effect plug-ins. Thus, it can also be used as a versatile effect processor.

Enter ams to start AlsaModularSynth from the command line. The parameter -j activates the JACK mode, provided the JACK engine jackd is running (see The JACK Audio Connection Kit on page 187). The required port connections can be established with QJackConnect. Individual ports are generated for each PCM module in the JACK mode. AlsaModularSynth only appears in the list of QJackConnect if at least one PCM module exists.

The directory /usr/share/doc/packages/alsamodular contains numerous example patches that demonstrate the various possibilities. Detailed documentation is available in the subdirectory html.

15.11.1 Synthesizer Patch Examples

The application package for AlsaModularSynth provides a selection of patch examples to allow the user to start working with the application right away. The folder demos is located in the directory /usr/share/doc/packages/alsamodular. A few autonomous patches are contained there that generate interesting random sound loops. The files concerned begin with example_ams_demo. Patches containing scope and spectrum in their name feature corresponding modules whose visualization can be opened by right-clicking the module title. Experiment a little, for example, and experience how the character of the music changes when the quantization of the Quantizer module (ID 7)
Figure 15.14: The AlsaModularSynth Main Panel

is changed from pentatonic to 1/6 (full range scale). Complete instruments can be found in the folder instruments. The patches miniam.sams as well as phaser_instrument.ams are actually quite versatile. These patches are supplied with a number of presets that can be called with MIDI program changes. A few of the presets are defined with the ‘Parameter View’ dialog available from ‘View’. A systematic guide to the creation of custom patches is provided in the tutorial folder.

15.11.2 AlsaModularSynth as an Effect Processor

Especially in the JACK mode, AlsaModularSynth can be used as a versatile effect processor. One example for this is example_capture.ams. If you connect an external sound source to your sound card and use alsamixer to specify the correct settings for the capture, the example will work even without JACK. With the ‘Ladspa Browser’, started with ‘Module’ → ‘Show Ladspa Browser’, generate
modules for LADSPA effects. Plug-ins should always be created with ‘Create Plugin’, unless you use AlsaModularSynth as a polyphonic synthesizer. ‘Create Poly Plugin’ generates a separate plug-in instance for each part.

15.11.3 AlsaModularSynth as a Synthesizer

After having used the MIDI patchbay kaconnect to connect AlsaModularSynth with a master keyboard (vkeybd or an external keyboard), you can use the program as a synthesizer. If polyphony is not explicitly activated with the parameter --poly, AlsaModularSynth will be monophonic, just like its classical model. The envelope modules are single-triggered, as is often the case with analog synthesizers. This means that they are not restarted during legato play. This allows interesting phrasing. Multitriggering is activated by connecting the trigger output signal of the MCV module to the retrigger input port of the envelope module.

A few LADSPA plug-ins greatly enhance the virtual analog sound of AlsaModularSynth. The plug-ins “Saw-VCO”, “Mvclpf-3”, “Mvclpf-4”, and “Phaser1” by Fons Andersen deserve special attention. “Saw-VCO” is designed to resemble an
analog saw-toothed wave generator. “Mvclpf-3” and “Mvclpf-4” are very realistic reproductions of the filter cascade invented by R. A. Moog. These plug-ins represent a milestone in the digital reproduction of this legendary low-pass filter. An effect module frequently featured in a classic modular system is the Bode Frequency Shifter. The plug-in of the same name implemented by Steve Harris allows experimenting with frequency shifting.

15.11.4 Keeping Track with the Control Center

Select the MIDI channel in the ‘Control Center’, build connections between the MIDI controllers and the module parameters, and create individually operable user interfaces, for example, for live performances. Range limitations for the sliders can also be set here.

The list to the left displays the MIDI controllers used in a patch. In this tree view, the parameters associated with a controller are shown under the respective controller. As soon as a controller event that does not exist in the list is received via MIDI, it is added to the list. The list to the right shows the modules and their parameters. If you select a parameter here, the respective control appears, enabling modification of the parameter and range limits.

To create a MIDI binding, select a controller in the list to the left and a parameter in the list to the right. Then click ‘Bind’. To clear a MIDI binding, simply select the respective parameter in the list to the left under the controller and click ‘Clear Binding’. ‘Clear All’ clears the entire list of MIDI controllers and bindings. With ‘Toggle MIDI Sign’, determine whether a parameter should increase or decrease with rising controller values. The settings of these MIDI controllers become effective only when the current parameter value has been attained. This prevents sudden parameter jolts.

‘Add to Parameter View’ adds the currently marked module parameter to the ‘Parameter View’ dialog. The parameters can be easily arranged into tabulators and labeled frames.

15.11.5 The MIDI Out Module

The output of the MIDI events generated by a MIDI Out module is realized by way of the two readable MIDI ports of AlsaModularSynth in the left list of ka-connect. If several MIDI Out modules are used simultaneously, the MIDI events are merged accordingly. As both notation and controller events can be sent, the module can also be used to control all kinds of parameters via control voltage. To
do this, the readable MIDI ports must be connected with the writable MIDI port. The example example_midiout_controller.ams shows the change in an envelope with autogenerated controller events. Easily follow the movement of the envelope by opening the configuration dialog of the ENV module (ID 5) with the right mouse button. The option ‘Follow MIDI’ in the ‘Control Center’ should be deactivated while this patch is running.

If you connect the readable MIDI ports of AlsaModularSynth with a MIDI sound generator, example_midiout_note.ams plays scales controlled by an LFO. example_midiout_note_velocity.ams shows that the velocity data can also be autogenerated. example_midiout_random.ams generates random music with drums.
15.11.6 Writing WAV Files with the WAV Out Module

Using the WAV Out module, directly record the signals generated or processed by AlsaModularSynth as a WAV file in CD quality. In the configuration dialog of the module, select ‘New File’ to open a file browser. If the file displayed under ‘File’ is successfully generated, the buttons under ‘Record’ are activated and can be used.

15.12 NoteEdit and MIDI Sequencers

NoteEdit is one of the most comprehensive Linux applications for editing scores with a graphical interface. As the entered notes are sounded immediately by the selected MIDI device, even newcomers can easily prepare scores with NoteEdit. This program offers the entire range of music symbols for writing scores. With NoteEdit, even play and record MIDI files. The scores can be exported in several formats, including MusicTeX and LilyPond.

Start the application with noteedit. A few examples can be found in /usr/share/doc/packages/noteedit/examples/, which can be opened with
'File' → 'Open'. Use 'TSE3' → 'TSE3 Midi In' to import MIDI files. These are loaded into the editor with 'TSE3' → 'Score'. Set various options for the conversion in the 'Filter' dialog box.

'Midi' → 'Devices' allows selection of one of the ALSA MIDI devices configured in the system. This device is then used for playback as well as for recording. The instrument, the MIDI channel, and many other parameters, such as the stereo panorama, can be set under 'Staff' → 'Staff Properties'.

Notes can easily be entered with the help of the mouse. First, choose the length of the note and any required accidental in the toolbar. Click to insert a note or right-click to insert a rest. The 'Insert' menu provides objects like clef, meter, and key. More information about NoteEdit is available in the directory /usr/share/doc/packages/noteedit.

In Linux, there are several MIDI sequencers, some of which are very mature. For example, Jazz is a proven, stable program. The development of Rosegarden, the classic among sequencer programs and notation editors for Linux, has been resumed. Therefore, this program may also be of interest to you. Muse is also a very active project. Meanwhile, the program can be used as a sequencer.
The configuration of TV cards is integrated in the configuration tool YaST. If your card has been correctly identified, it can be automatically configured. Otherwise, enter the card settings manually.

The following sections focus on the motv application, created by the author of the BTTV driver. Another TV application is KWinTV. If you prefer KWinTV, it should be easy to use after reading this chapter.

16.1 Watching TV with motv .......................... 208
16.2 Video Text with alevt .......................... 210
16.3 Webcams and motv .......................... 210
16.4 nxtvepg — The TV Magazine for Your PC .... 211
16.5 Webcam Operation with gqcam ............... 212
16.1 Watching TV with motv

motv is an improved successor to xawtv. It incorporates all essential functions into the user interface. Start the application with ‘SUSE’ → ‘Multimedia’ → ‘Video’. Start it at the command line with motv. Initially, only a TV window appears after the application starts. Open a menu window by right-clicking it.

![The TV Application motv](image)

**Figure 16.1: The TV Application motv**

16.1.1 Video Source and Network Search

In ‘Settings’ → ‘Input’, select the video source. If you select ‘Television’ here, set up the broadcasting network before starting the application. This automatically takes place with the network search, also found under the ‘Settings’ menu. If you click ‘Save settings’, the network found is entered into the .xawtv file in your home directory and will be available the next time you start the application.

---

**Note**

If you do not want to browse for all available channels, find the next channel with (Ctrl)↑. If needed, subsequently adjust the broadcast frequency with ← or →.

---

Note
16.1.2 From Silent Film to Sound Film

The audio output of the TV card is connected to the line input of your sound card, to the speakers, or to an amplifier. Some TV cards can change the volume of the audio output. The volume can then be set with the sliders that appear after selecting ‘Settings’ → ‘Slider’. This window also provides the sliders for brightness, contrast, and color.

To use your sound card for audio playback, check the mixer settings using gamix, described in Mixers on page 176. For sound cards meeting the AC97 specifications, set ‘Input-MUX’ to ‘Line’. The volume can then be adjusted with the ‘Master’ and ‘Line’ sliders.

16.1.3 Screen Proportions and Full-Screen Mode

Most television images have a height and width ratio of 4:3. These proportions can be set with ‘Tools’ → ‘Screen Dimensions’. If ‘4:3’ is selected here (this is the default setting), the screen dimensions are retained automatically, even when the display size is changed.

With or ‘Tools’ → ‘Fullscreen’, switch to full-screen mode. If the TV image in full-screen mode is not scaled to the full monitor size, some fine-tuning is required. Many graphics cards can scale the full-screen mode television image to the full monitor size without changing the graphical mode. If your card does not support this function, the graphics mode must be switched to 640x480 for the full-screen mode. Create the related configuration in ‘Settings’ → ‘Configuration’. After restarting motv, the monitor mode is also changed if you have switched to full-screen mode.

Note

The .xawtv file is created automatically and updated by clicking ‘Settings’ → ‘Save settings’. Here, the broadcasters are saved along with the configuration. More information about the configuration file can be found in the man page for xawtvrc.

16.1.4 The Launcher Menu

Use the launcher menu to start other applications to use with motv. Start the audio mixer gamix and the video text application alevt, for example, using a key-
board shortcut. Applications to launch from motv must be entered in the .xawtv file. The entries should look like this:

[launch] Gamix = Ctrl+G, gamix AleVT = Ctrl+A, alevt

The shortcut then the command used to start the application should follow the application name itself. Start the applications entered under [launch] via the ‘Tool’ menu.

16.2 Video Text with alevt

Use alevt to browse video text pages. Start the application via ‘SUSE’ → ‘Multimedia’ → ‘Video’ → ‘alevt’ or at the command line with alevt.

The application saves all the pages of the selected station just activated with motv. Browse pages by entering the desired page number or by clicking a page number. Move forward or backward through the pages by clicking ‘<’ or ‘>’, located in the lower window margin.

16.3 Webcams and motv

If your webcam is already supported by Linux, access it with motv. Find a summary of the supported USB devices at http://www.linux-usb.org. If you have already used motv to access the TV card prior to accessing the webcam, the bttv driver is loaded. The webcam driver is loaded automatically when your webcam is connected to the USB. Start motv at the command line with the parameter -c /dev/video1 to access the webcam. Access the TV card with motv -c /dev/video0.

When connecting the webcam to the USB before the bttv driver has been automatically loaded (for example, by starting a TV application), /dev/video0 is reserved for the webcam. In this case, if you start motv with the -c /dev/video1 parameter to access the TV card, you might get an error message, because the bttv driver was not automatically loaded. Solve this problem by loading the driver separately with modprobe bttv as the user root. Access an overview of the configurable video devices on your system with motv -hwscan.
16.4 **nxtvepg — The TV Magazine for Your PC**

From some broadcasters, an EPG signal (Electronic Program Guide) is transmitted along with the video text signal. Easily view this electronic guide using the program `nxtvepg`. To do this, however, you must have a TV card supported by the `bttv` driver and be able to receive one of the channels broadcast with an EPG.

With `nxtvepg`, the broadcasts are sorted according to channel and topic, such as ‘movie’ and ‘sport’, and filtered according to criteria, such as Live, Stereo, or Subtitle. Start the application via the ‘SUSE’ → ‘Multimedia’ → ‘Video’ menu or at the command line with `nxtvepg`.

### 16.4.1 Importing the EPG Database

To set up and update the program database via the EPG signal, set the tuner of your TV card to a station that broadcasts EPG. This can be done using a TV application, such as `motv` or `nxtvepg`. Only one application at a time can access the tuner.

If you set an EPG broadcaster in `motv`, `nxtvepg` immediately begins importing the current list of TV programs. The progress will be displayed.

If you have not started a TV application, let `nxtvepg` search for EPG broadcasters. To do this, use ‘Configure’ → ‘Provider scan’. ‘Use .xatv’ is activated by default. This indicates that `nxtvepg` is accessing the broadcasters saved in this file.

---

**Note**

If there are problems, check to see if the proper video source has been chosen under ‘TV card input’.

---

Select from the EPG providers found in ‘Configure’ → ‘Select Provider’. ‘Configure’ → ‘Merge Providers’ even creates flexible associations between the various provider databases.

### 16.4.2 Sorting the Programs

`nxtvepg` provides a convenient filter function for managing even the most extensive program offerings. Activate a network selection list with ‘Configure’ →
‘Show networks’. The ‘Filter’ menu offers plenty of filter functions. Right-click the program list to open a special filter menu in which to activate contextual filter functions.

Of particular interest is the ‘Navigate’ menu. This is built directly from the EPG data. It will appear in the language provided by the network.

### 16.5 Webcam Operation with gqcam

gqcam is a webcam application that assists in taking snapshots or automatic picture series with webcams. To use gqcam, your webcam must be supported by Video4Linux. Many USB webcams, like the Logitech Quickcam Express, are automatically recognized. Grayscale and color cameras can be used. TV cards that support Video4Linux can also be used as an image source. An overview of the supported USB devices is maintained at [http://www.linux-usb.org](http://www.linux-usb.org). A graphical user interface is not compulsory because gqcam can also run from the command line.
16.5.1 Operation

Connect your camera to the USB port of your computer before starting gqcam. Then run gqcam. The current picture of your webcam is automatically shown in the upper part of the application window. The lower part has sliders for adjusting the brightness, white balance, contrast, tint, and color saturation according to your liking. The brightness is automatically preset. This feature can be set in ‘General’ in ‘File’ → ‘Preferences’. ‘Filters’ features false color correction switches because some cameras swap the red and blue channels in transmission.

If you operate more than one webcam, use ‘File’ → ‘Open New Camera’ to switch to another camera. Select the new device from the dialog that opens. The first camera is attached to the device /dev/video0, the second is attached to /dev/video1, and so on.

16.5.2 Snapshots

To take a snapshot with a camera, click ‘Snap Picture’. Select a file name and picture format in the dialog that opens. Create a picture series with ‘Camera’ → ‘Set Timer…’. Set the capturing frequency in seconds or minutes along with the properties of the images in ‘Set image information’. An optional script to run after every capture event can be chosen with ‘Run command after snap:’. This could, for example, be used to upload the captured image onto an FTP server.

16.5.3 Command Line

gqcam can also be run without its graphical user interface. This may be interesting, for instance, for automatic surveillance controlled by a cron job. This requires that all the necessary settings be passed to the application as parameters. Running gqcam -t JPEG -s -d webcam.jpg saves the current image captured by the camera with the file name webcam.jpg. The option -t defines the file format. Possible values are JPEG, PNG, and PPM. The command line switch -s activates the color correction. The file name for saving is passed with the option -d. If more than one webcam is operated, the name of the device must be passed. If no device is given, the default device /dev/video0 is used. To capture an image from the second camera, the option -v /dev/video1 must be added. List all options with gqcam --help.
K3b is a comprehensive program for writing data and audio CDs. Along with the usual features, the program offers some additional options that facilitate work, especially in the field of multimedia. Start the program from the main menu or by entering the command k3b. The main program features are described in the following sections.

17.1 Creating a Data CD ........................................... 216
17.2 Burning CDs .................................................. 217
17.3 Creating an Audio CD ....................................... 218
17.4 Copying a CD .................................................. 219
17.5 Writing ISO Images ......................................... 220
17.6 For More Information ....................................... 220
17.1 Creating a Data CD

Creating a data CD is easy. Go to ‘File’ → ‘New Project’ → ‘New Data Project’. The project view appears in the lower part of the window, as shown in Figure [17.1]. Drag the desired directories or individual files from your home directory to the project folder and drop them there. Save the project under a name of your choice with ‘File’ → ‘Save as’.

![Figure 17.1: Creating a New Data CD](image)

Then select ‘Burn’ from the toolbar. A dialog with five tabs offering various options for writing the CD opens. See Figure [17.2] on page 218.
17.2 Burning CDs

The detected writer is displayed under ‘Device’ in the burning dialog. Set the burning speed in ‘Burning Speed’. The following options are offered here:

‘Mode’ This option determines how the laser writes a CD. In the DAO (disk at once) mode, the laser is not deactivated while the CD is written. This mode is recommended for the creation of audio CDs. However, it is not supported by all CD writers. In the TAO mode (track at one), a separate write process is applied for every individual track. The RAW mode is not used very often, as the writer does not perform any data corrections. The best setting is ‘automatic’, as it allows K3b to use the most suitable settings.

‘Simulate’ This function can be used to check if your system supports the selected writing speed. The writing is performed with the laser deactivated to test the system.

‘On the fly’ Burns the desired data without first creating an image file (do not use this feature on low-performance machines). An image file — also known as an ISO image — is a file containing the entire CD content that is subsequently written to the CD exactly as it is.

‘Burnfree’ This option was formerly known as burn-proof. It helps to avoid buffer underruns of a CD writer. If burnfree is selected, the CD writer will mark the current position and can return here in the event of a buffer underrun. However, this causes small data gaps that are audible in audio CDs. It is preferable to select a suitable burning speed that avoids buffer underruns.

‘Create Image File only’ This option creates an image file. Set the path for this file under ‘Temporary File’. The image file can be written to CD at a later time. To do this, use ‘Tools’ → ‘Write ISO Image’. If this option is used, all other options in this section are deactivated.

The ‘Settings’ tab features options needed for the creation of CDs with multiple data or audio tracks (multisession CDs). In the ‘Name of Media’ tab, specify a name, description, publisher, and other details for the CD.

Under ‘File system’, specify settings for the file system on the CD (RockRidge, Joliet, UDF). Also determine how symbolic links, file permissions, and blanks are treated. In the ‘Advanced’ tab, experienced users can specify additional settings.
17.3 Creating an Audio CD

Basically, there are no significant differences between creating an audio CD and creating a data CD. Select ‘File’ → ‘New Audio Project’. Drag and drop the individual audio tracks to the project folder. The audio data must be in MP3, WAV, or Ogg Vorbis format. The sequence of the tracks can be determined by moving them up or down in the project folder.

The dialog for burning an audio CD is not very different from the dialog for burning a data CD. However, the option ‘Disc at once’ and the ‘Track at once’ mode bear greater importance. The ‘Track at once’ mode inserts an intermission of two seconds after each track.
17.4 Copying a CD

Select ‘Copy CD’ from the toolbar. In the following dialog, make the settings for the reading and writing device as shown in Figure 17.3. The options introduced above are also available here. An additional function enables the creation of several copies of the CD.

![Figure 17.3: Copying a CD](image-url)
17.5 Writing ISO Images

If you already have an ISO image, go to ‘Tools’ → ‘Write ISO Image’. A window opens in which to enter the location of the ‘Image to Write’. K3b calculates a check sum and displays it in ‘MD5 Sum’. If the ISO file was downloaded from the Internet, this sum shows if the download was successful.

Use the ‘Options’ and ‘Advanced’ tabs to set your preferences. To burn the CD, click ‘Write’.

17.6 For More Information

Apart from the two main functions described above, K3b offers other functions such as the creation of DVD copies, reading audio data in WAV format, rewriting CDs, or the integrated audio player. A detailed description of all available program features is available at http://k3b.sourceforge.net.
gPhoto 2.0 is a command-line program for communicating between the computer and a digital camera. It is compatible with several graphical interfaces (front-ends), including gtKam, Konqueror, Kamera, and GnoCam. This chapter covers the use of gtKam, Konqueror, and Digikam.
A comprehensive list of supported cameras is available at [http://www.gphoto.org/cameras.html](http://www.gphoto.org/cameras.html). If `gphoto2` is installed, retrieve the list with the command `gphoto2 --list-cameras`. `gphoto2 --help` provides information about the available commands in the command-line interface.

### 18.1 Connecting to the Camera

The fastest and most convenient way to connect digital cameras to the computer is USB, provided the kernel, the camera, and the computer support USB. The standard SUSE kernel provides this support. A suitable cable is also required.

**Note**

Using the USB connection can quickly drain your camera's batteries. Consider using a power adapter.

Simply connect the camera to the USB port and turn on the camera. You may need to switch your camera to a special data transfer mode. For this procedure, consult the manual of your digital camera.

### 18.2 Installating the Programs

Use YaST to install the `gtkam` package. The other required packages are selected automatically. `Digikam` is included in the default installation. If it is not installed, use YaST to install it, if desired.

### 18.3 Using Konqueror

KDE users can easily access digital cameras by means of the familiar Konqueror interface. Connect your camera to the USB port. A camera icon should appear on the desktop. Click this icon to open the camera in Konqueror. The camera can also be accessed by entering the URL `camera:/` in Konqueror. Navigate through the camera’s directory structure until the files are shown. Use the usual Konqueror file management features to copy the files as desired. More information about using Konqueror is available in [The Web Browser Konqueror](#) on page 107.
18.4 Using gtKam

gtKam is a graphical interface for downloading and deleting pictures from the digital camera. To adjust or edit your pictures, use The GIMP as described in Chapter Manipulating Graphics with The GIMP on page 235.

![Figure 18.1: The Main Window of gtKam](image)

Connect your camera to the appropriate port and turn on the camera. Start gtKam with the command `gtkam &`. From the menu, select ‘Camera’ ➝ ‘Select Camera...’. In the dialog that opens, select the camera model or use ‘Detect’. Select the appropriate port if the detection fails.

The main gtKam window is divided into three sections — the menu and toolbars, the left pane with index settings and camera and directory selection, and the right pane for displaying an index listing with or without thumbnails. The icons in the toolbar provide the main functions needed. The disk icon saves the selected images. The trash icon deletes them. The icon with the arrows loads the image index displayed in the right pane. The icon with the paper and pencil opens the camera configuration options. The door icon exits the program.

Your camera should be listed in the left pane. Use the plus sign (+) to the left to expand the tree display of the directory structure. Your exact directory structure depends on the camera type and model. Continue expanding until you reach the entries that cannot be expanded. These are the index listings of the pictures. Click an item to select it. If ‘View Thumbnails’ is activated, the picture names and thumbnails are displayed in the right window pane. Otherwise, the names and an icon are displayed.
Images in the right pane can be selected or deselected by clicking them. Select all images with ‘Select’ → ‘All’ or (Shift)-A. To save the selected images, use the disk icon in the toolbar, select ‘File’ → ‘Save Selected Photos...’, or use the shortcut (Ctrl)-S. The ‘Save’ dialog, shown in Figure 18.2, has a number of options. Under ‘What to Save’, select whether to save the thumbnails, the images, or both. With ‘Open image(s) with:’, save the image and open it in another program. To open the images in The GIMP immediately, enter gimp. Using the file names suggested by the camera is recommended.

![Figure 18.2: Saving Images](image)

### 18.5 Using Digikam

Digikam by Renchi Raju is a KDE program for downloading photographs from digital cameras. On start-up, Digikam presents a window with three sections:
your home directory is displayed to the left, the photographs available in the camera are displayed to the right, and a list of cameras is displayed below.

To set up a camera in Digikam, select ‘Configure’ → ‘Setup’. A window displaying a list of supported cameras opens. First, try to autodetect the camera with ‘Auto-Detect’. If this fails, browse the list for your model. If your camera model is not included in the list, try an older model. Normally, this should work.

The path to your image folders (the location where your photographs are saved) can be specified in the same dialog under the ‘General Settings’ tab. You can also determine the size of the thumbnails, the way file names are displayed, and some other settings.

After your camera has been detected correctly and you have configured the program as desired, confirm with ‘OK’. The name of your camera is then displayed at the bottom left in the main window. Double-click it or select ‘Camera’ → ‘Connect’ to connect Digikam to your camera. The thumbnails are displayed to the right. Right-click the image to open a pop-up menu with which to view, save, or delete the image or view its properties.

Select all photographs to download from the camera by pressing the left mouse button or clicking individual photographs with \textit{Shift} pressed. Selected photographs appear with inverted colors. Drag the selected photographs to the desired directory. Digikam then downloads the photographs and saves them in the selected directory.

\section*{18.6 For More Information}

For more information about using digital cameras with Linux, refer to the following web sites:

- \url{http://digikam.sourceforge.net/} Information about Digikam
- \url{http://www.gphoto.org} Information about gPhoto, gPhoto2, and gPhoto2-compatible GUls
- \url{http://www.thekompany.com/projects/gphoto/} Information about Kamera, a KDE front-end for gPhoto2
- \url{http://www.stud.uni-karlsruhe.de/~urc8/GnoCam/} Information about GnoCam
Kooka — A Scanning Application

Kooka is a KDE application for scanning. This chapter explains the user interface and the functionality of the application.

19.1 The Kooka Window ........................................ 228
19.2 The Preview .................................................. 228
19.3 The Final Scan ............................................... 228
19.4 The Menus .................................................... 229
19.5 The Gallery .................................................. 231
19.6 Optical Character Recognition ............................. 232
19.1 The Kooka Window

Start Kooka from the main menu or enter the command kooka. When started, Kooka opens a three-frame window with a menu bar to the upper left and a tool-bar directly below it. All windows can be freely readjusted or rearranged with the mouse. It is also possible to completely detach single frames from the Kooka window for deliberate placement on the desktop. To move the frames, click and drag the thin double line right above the frame. Any frame, except the main window, can be placed within any other frame aligned to the left, right, top, bottom or centered. Centered windows have the same size, are stacked, and can be brought to the foreground with tabs.

The ‘Image Viewer’ and the ‘Scan Preview’ frames share a window by default. Tabs allow switching between them. The left frame provides the gallery. This is a small file browser for accessing the scanned images. The frame to the lower right is shared by the OCR (optical character recognition) and the thumbnails, which can be loaded into the image viewer with a simple click of the mouse. See Figure 19.1 on the facing page.

Selecting ‘Show Scan Parameters’ in the ‘Tool Views’ subentry of the ‘Settings’ menu creates a third tab labeled ‘Scan Parameter’ next to the already existing ‘Image Viewer’ and ‘Scan Preview’ tabs in the main window. This is where the actual scanning parameters are set.

19.2 The Preview

A preview should always be created when the object to scan is smaller than the total scanning area. Set a few parameters to the left of the preview frame. Select the scanning size with ‘Custom’ or one of the standard formats. See Figure 19.2 on page 230. The ‘Custom’ setting is the most flexible, because it allows selection of the desired area with the mouse. Once the settings have been made, request the preview of the image to scan by clicking ‘Preview Scan’ on ‘Scan Parameter’.

19.3 The Final Scan

If you selected ‘Custom’ for the scanning size, use the mouse to select the rectangular area to scan. The selected area is confined by a dotted border.
Click ‘Scan Parameter’ again. Choose between color and black-and-white scanning and set the resolution with the slider. See Figure 19.3 on page 231. The higher the resolution, the better the quality of the scanned image is. However, this also results in a correspondingly larger file and the scanning process can take a very long time at high resolutions. Activate ‘Use custom gamma table’ and click ‘Edit’ to change the settings for brightness, contrast, and gamma.

Once all settings have been made, click ‘Final Scan’ to scan the image. The scanned image is then displayed in the image viewer and as a thumbnail. When prompted, select the format in which to save the image. To save all the future images in that same format, check the corresponding box. Confirm with ‘OK’.

19.4 The Menus

Some of the functions of the toolbar are also available in the ‘File’ and ‘Image’ menus. Modify preference settings for Kooka in ‘Settings’.
File  Use this menu to start the KPrinter printing assistant, to create a new folder for your images, and to save, delete, and close files. The OCR results of a scanned text document can be saved here. Also use this menu to close Kooka.

Image  The ‘Image’ menu allows starting a graphics application for postprocessing or optical character recognition of an image. The recognized text from an OCR operation is displayed in its own frame. Various tools for scaling, rotating, and flipping an image are available. These functions can also be accessed from the toolbar. The submenu ‘Create From Selection’ allows saving an area of an image previously marked with the mouse.

Settings  ‘Settings’ adjusts of the look and feel of Kooka. The toolbar and status bar can be switched on and off and keyboard shortcuts for menu entries can be defined. ‘Configure Toolbars’ provides a list of all the functions available to the toolbar. ‘Configure Kooka’ opens a configuration dialog in which to modify the look and feel of Kooka. Normally, however, the defaults are sufficient. In ‘Tool Views’, enable and disable the thumbnail viewer, the preview, the gallery, the scanning parameters, and the OCR result window.

Help  The ‘Help’ menu provides access to the online help manual for Kooka.
Also use it to access a feedback channel for problems and wishes. It also provides information about the version, authors, and license of Kooka and KDE.

### 19.5 The Gallery

The gallery window shows the default folder where Kooka stores all its image files. An example is shown in Figure 19.4 on the next page. To save an image to your personal home directory, click the thumbnail to select it then select ‘File’ → ‘Save Image’. Then enter your personal home directory and give the file a descriptive name.

To add images to the gallery, simply drag and drop them from Konqueror. Start Konqueror, navigate to the directory containing the images to add to the gallery, and drag them with the mouse to a folder of the Kooka gallery.
19.6 Optical Character Recognition

If the character recognition module is installed, documents can be scanned in ‘lineart’ mode, saved in the proposed format, then processed for text recognition from the ‘Image’ menu. Process the entire document or only a previously selected area. A configuration dialog tells the module whether the original text is in printed type, handwriting, or standardized type. Also set the language so the module can process the document correctly. See Figure 19.5.
Switch to the ‘OCR Result Text’ window and check the text, which may need to be proofread. To do this, save the text with ‘File’ → ‘Save OCR Result Text’. The text can then be processed with OpenOffice or KWrite.
The GIMP (The GNU Image Manipulation Program) is a program for creating and editing pixel graphics. In most aspects, its features are comparable to those of Adobe Photoshop and other commercial programs. Use it to resize and retouch photographs, design graphics for web pages, make covers for your custom CDs, or almost any other graphics project. It meets the needs of both amateurs and professionals.

20.1 Graphics Formats .............................................. 236
20.2 Starting The GIMP ............................................. 236
20.3 Getting Started in GIMP ....................................... 239
20.4 Saving Images .................................................. 240
20.5 Editing Images: Basics ....................................... 242
20.6 Editing Images: Advanced Features ....................... 248
20.7 Printing Images ............................................... 249
20.8 Configuring GIMP ............................................. 251
20.9 For More Information ......................................... 251
Like many other Linux programs, The GIMP is developed as a cooperative effort of developers worldwide who volunteer their time and code to the project. The program is under constant development, so the version included in your SUSE LINUX may vary slightly from the version discussed here. The layout of the individual windows and window sections is especially likely to vary.

The GIMP is an extremely complex program. Only a small range of features, tools, and menu items are discussed in this chapter. See For More Information on page [251] for ideas of where to find more information about the program.

20.1  Graphics Formats

There are two main formats for graphics — pixel and vector. The GIMP works only with pixel graphics, which is the normal format for photographs and scanned images. Pixel graphics consist of small blocks of color that together create the entire image. The files can easily become quite large because of this. It is also not possible to increase the size of a pixel image without losing quality.

Unlike pixel graphics, vector graphics do not store information for all individual pixels. Instead, they store information about how image points, lines, or areas are grouped together. Vector images can also be scaled very easily. The drawing application of OpenOffice.org, for example, uses this format.

20.2  Starting The GIMP

Start GIMP from the main menu. Alternatively, enter gimp & in a command line.

20.2.1  Initial Configuration

When starting GIMP for the first time or the 2.0 version for the first time, a configuration wizard opens for preparatory configuration. The default settings are acceptable for most purposes. Press ‘Continue’ in each dialog unless you are familiar with the settings and prefer another setup.
20.2.2 The Default Windows

Three windows appear by default. They can be arranged on the screen and, except the toolbox, closed if no longer needed. Closing the toolbox closes the application. In the default configuration, The GIMP saves your window layout when you exit. Dialogs left open reappear when you next start the program.

GIMP Tip of the Day

This small window opens with useful tips and tricks each time the program starts. Reading the tips is recommended for new users. Uncheck ‘Show tip next time GIMP starts’ to disable it. This setting can also be changed in the preferences. Press ‘Close’ to close the window.

The Toolbox

The main window of The GIMP, shown in Figure 20.1 on the following page, contains the main controls of the application. Closing it exits the application. At the very top, the menu bar offers access to file functions, extensions, and help. Below that, find icons for the various tools. Hover the mouse over an icon to display information about it.
Figure 20.1: The Main Window

The current foreground and background color are shown in two overlapping boxes. The default colors are black for the foreground and white for the background. Click the box to open a color selection dialog. Swap the foreground and background color with the bent arrow symbol to the upper right of the boxes. Use the black and white symbol to the lower left to reset the colors to the default.

To the right, the current brush, pattern, and gradient are shown. Click the displayed one to access the selection dialog. The lower portion of the window contains the ‘Tool Options’ dialog. It allows configuration of various options for the current tool.
Layers, Channels, Paths, Undo

In the first section, use the drop-down box to select the image to which the tabs refer. By clicking ‘Auto’, control whether the active image is chosen automatically. By default, ‘Auto’ is enabled.

‘Layers’ shows the different layers in the current images and can be used to manipulate the layers. Information is available in Layers on page 248. ‘Channels’ shows and can manipulate the color channels of the image.

Paths are an advanced method of selecting parts of an image. They can also be used for drawing. ‘Paths’ shows the paths available for an image and provides access to path functions. ‘Undo’ shows a limited history of modifications made to the current image. Its use is described in Undoing Mistakes on page 248.

The bottom portion of the window contains three tabs. With them, select the current brush, gradient, and pattern.

20.3 Getting Started in GIMP

20.3.1 Creating a New Image

To create a new image, select ‘File’ → ‘New’ or press (Ctrl)+(N). This opens a dialog in which to make settings for the new image. If desired, use ‘From Template’ to select a template on which to base the new image. The GIMP includes a number of templates, ranging from an A4 sheet of paper to a CD cover, from which to choose. To create a custom template, select ‘File’ → ‘Dialogs’ → ‘Templates...’ and use the controls offered by the window that opens.

In the ‘Image Size’ section, set the size of the image to create in pixels or another unit. GIMP defaults use inches as the other unit. Click the unit to select another unit from the list of available units. Changing the pixel size modifies the other unit size and vice versa. The ratio between pixels and a unit is set in ‘Resolution’. A resolution of 72 pixels per inch corresponds to screen display. It is sufficient for web page graphics. A higher resolution should be used for images to print. For most printers, a resolution of 300 pixels per inch results in an acceptable quality.

In ‘Image Type’, select whether the image should be in color (‘RGB’) or ‘grayscale’. For detailed information about image types, see Image Modes on page 249. Select the ‘Fill Type’ for the new image. ‘Foreground’ and ‘Background’ use the colors selected in the toolbox. ‘White’ uses a white background in the image. ‘Transparent’ creates a clear image. Transparency is represented by a gray checkerboard pattern. Enter a comment for the new image in ‘Image Comment’.
When the settings meet your needs, press ‘OK’. To restore the default settings, press ‘Reset’. Pressing ‘Cancel’ aborts creation of a new image.

### 20.3.2 Opening an Existing Image

To open an existing image, select ‘File’ ➝ ‘Open’ or press (Ctrl)-O. In the dialog that opens, the current directory is listed above the center column. Available directories are listed in the left column. Double-click the directory to make it the current one. .. / moves up a level in the hierarchy.

The center column shows the files available in the current directory. Click a file name to select it. If available, a preview of the selected file is shown in the right column. Alternatively, enter a file name in the field towards the bottom. Pressing Tab while entering a name in the field attempts to complete the name. Available completions are then listed in the ‘Folders’ and ‘Files’ columns. Select one or enter enough of the name to identify the file uniquely then press Tab again. Click ‘OK’ to open the selected image. Press ‘Cancel’ to skip opening an image.

### 20.3.3 The Image Window

The new or opened image appears in its own window. The menu bar in the top of the window provides access to all image functions. Alternatively, access the menu by right-clicking the image or clicking the small arrow button in the left corner of the rulers.

‘File’ offers the standard file options, such as ‘Save’ and ‘Print’. ‘Close’ closes the current image. ‘Quit’ closes the entire application.

With the items in the ‘View’ menu, control the display of the image and the image window. ‘New View’ opens a second display window of the current image. Changes made in one view are reflected in all other views of that image. Alternate views are useful for magnifying a part of an image for manipulation while seeing the complete image in another view. Adjust the magnification level of the current window with ‘Zoom’. When ‘Shrink Wrap’ is selected, the image window is resized to fit the current image display exactly.

### 20.4 Saving Images

No image function is as important as ‘File’ ➝ ‘Save’. It is better to save too often than too rarely. Use ‘File’ ➝ ‘Save as’ to save the image with a new file name. It
is a good idea to save image stages under different names or make backups in another directory so you can easily restore a previous state.

When saving for the first time or using ‘Save as’, a dialog opens in which to specify the file name and type. The current directory is shown in a box centered above the two columns. Select another directory by double-clicking it in ‘Folders’. To save the image as an existing file, select it in ‘Files’. Otherwise, enter a new name in the field at the bottom. It is recommended to leave ‘Determine File Type’ set to ‘By Extension’. With that setting, GIMP determines the file type based on the extension appended to the file name. The following file types are frequently useful:

**XCF** This is the native format of The GIMP. It saves all layer and path information along with the image itself. Even if you need an image in another format, it is usually a good idea to save a copy as XCF to simplify future modifications. Information about layers is available in [Layers](#) on page 248.

**PAT** This is the format used for GIMP patterns. Saving an image in this format enables using the image as a fill pattern in GIMP.

**JPG** JPG or JPEG is a common format for photographs and web page graphics without transparency. Its compression method enables reduction of file sizes, but information is lost when compressing. It may be a good idea to use the preview option when adjusting the compression level. Levels of 85 percent to 75 percent often result in an acceptable image quality with reasonable compression. Saving a backup in a lossless format, like XCF, is also recommended. If editing an image, save only the finished image as JPG. Repeatedly loading a JPG then saving can quickly result in poor image quality.

**GIF** Although very popular in the past for graphics with transparency, GIF is less often used now because of license issues. GIF is also used for animated images. The format can only save indexed images. See [Image Modes](#) on page 249 for information about indexed images. The file size can often be quite small if only a few colors are used.

**PNG** With its support for transparency, lossless compression, free availability, and increasing browser support, PNG is replacing GIF as the preferred format for web graphics with transparency. An added advantage is that PNG offers partial transparency, which is not offered by GIF. This enables smoother transitions from colored areas to transparent areas (antialiasing).

To save the image in the chosen format, press ‘OK’. To abort, press ‘Cancel’. If the image has features that cannot be saved in the chosen format, a dialog appears
with choices for resolving the situation. Choosing ‘Export’, if offered, normally gives the desired results. A window then opens with the options of the format. Reasonable default values are provided.

20.5  Editing Images: Basics

20.5.1  Changing the Image Size

Once an image is scanned or a digital photograph is loaded from the camera, it is often necessary to modify the size for display on a web page or for printing. Images can easily be made smaller either by scaling them down or by cutting off parts of them. Making an image larger is much more problematic. Because of the nature of pixel graphics, quality is lost when an image is made larger. It is recommended to keep a copy of your original image before scaling or cropping.

Cropping an Image

Cropping an image works like cutting the edges off a piece of paper. Select the crop tool from the toolbox (it resembles a scalpel) or with ‘Tools’ ➝ ‘Transform Tools’ ➝ ‘Crop & Resize’. Click a starting corner and drag to outline the area to keep.

A small window opens with information about the starting point and the size of the selected area. Adjust these values by clicking and dragging a corner of the crop box or by adjusting the values in the window. ‘From Selection’ adjusts the crop to fit the current selection (selections are explained in Selecting Parts of Images on the facing page). ‘Auto Shrink’ makes the crop smaller based on color changes in the image.

Press ‘Cancel’ to abort the crop. Press ‘Crop’ to crop the image. The results of ‘Resize’ are identical to those of ‘Change Canvas Size’, described in Changing the Canvas Size on the next page.

Scaling an Image

Select ‘Image’ ➝ ‘Scale Image’ to change the overall size of an image. Select the new size by entering it in ‘New Width’ or ‘New Height’ or by adjusting the ‘Ratio’. To change the proportions of the image when scaling (this distorts the image), click the chain icon to the right of the ratio fields to break the link between them. When those fields are linked, all values are changed proportionately when
the value in one of the four fields is changed. When the link is broken, width and height can be adjusted independently of each other or the X and Y ratios can be adjusted individually.

The values in the ‘Print Size’ are independent of the pixel size. In that section, modify the image resolution by modifying the resulting image size when printed or modifying the resolution itself. Use the unit drop-down boxes to change the measuring unit.

‘Interpolation’ is an expert option that controls the scale method. When finished adjusting the size, press ‘OK’ to scale the image. ‘Reset’ restores the original values. ‘Cancel’ aborts the procedure.

### Changing the Canvas Size

Changing the canvas size is like putting a mat around an image. Even if the mat is smaller, the rest of the image is there, but you can only see part of it. If the mat is larger, you see the original image with extra space around it. To do this, select ‘Image’ → ‘Canvas Size’.

In the dialog that opens, enter the new size. By default, the width and height maintain the same proportions as the current image. To change this, click the chain icon to the right of ‘Ratio’. Enter the desired size in the height and width fields or adjust the ratios.

After adjusting the size, determine how the existing image should be positioned in comparison to the new size. Use the offset values or drag the box inside the frame at the bottom. When satisfied with the changes, click ‘OK’ to change the canvas size. Click ‘Reset’ to restore the original values or ‘Cancel’ to cancel the canvas resize.

---

**Note**

The same results can be achieved using the ‘Resize’ option of the crop tool.

---

### 20.5.2 Selecting Parts of Images

It is often useful to perform an image operation on only part of an image. To do this, the part of the image with which to work must be selected. Areas can be selected using the select tools available in the toolbox, using the quick mask, or combining different options. Selections can also be modified with the items under ‘Select’. The selection is outlined with a dashed line, called *marching ants*.
Using the Select Tools

The main select tools are rather easy to use. The paths tool, which can also be used for more than selecting, is more complicated so is not described here. In the tool options for the other select tools, determine whether the selection should replace, be added to, be subtracted from, or intersect with an existing selection.

Rectangular Select  This tool can be used to select rectangular or square areas. In the tool options, select among ‘Free Select’, ‘Fixed Size’, and ‘Fixed Aspect Ratio’ to control the shape and size of the selection.

Elliptical Select  Use this to select elliptical or circular areas. The same options are available as with rectangular selection.

Lasso  Draw a selection area freehand with this tool by dragging the mouse over the image with the left mouse button pressed. The end points will be connected with a straight line when you release the tool. The area inside is then selected.

Magic Wand  This tools selects a region based on color similarities.

By Color  With this, select all the pixels in the image with the same color as the clicked pixel.

Intelligent Scissors  Click a series of points in the image. As you click, the points are connected based on color differences.

Using the Quick Mask

The quick mask is a way of selecting parts of an image using the paint tools. A good way to use it is to make a rough selection using the intelligent scissors or the lasso (freehand selection tool). Then activate the quick mask by pressing the small icon with the dashed box in the lower left corner.

The quick mask displays the selection using an overlay of red. Areas shaded with red are not selected. Areas appearing as they did before the mask was activated are selected. To modify the selection, use the paint tools. Painting with white selects the painted pixels. Painting with black unselects pixels. Shades of gray (colors are treated as shades of gray) are a partial selection. Partial selection allows smooth transitions between selected and unselected areas.
Note

To use a different color for displaying the quick mask, right-click the quick mask button and select ‘Configure Color and Opacity’ from the menu. Click the colored box in the dialog that opens to select a new color.

Note

After using the paint tools to adjust the selection as desired, convert from the quick mask view back to the normal selection view by clicking the icon in the lower left corner of the image window (currently displaying a red box). The selection is again displayed with the marching ants.

20.5.3 Applying and Removing Color

Most image editing involves applying or removing color. By selecting a part of the image, limit where color can be applied or removed. When you select a tool and move the cursor onto an image, the cursor’s appearance changes to reflect the chosen tool. With many tools, an icon of the current tool is shown along with the arrow. For paint tools, an outline of the current brush is shown, allowing you to see exactly where you will be painting in the image and how large an area will be painted.

Selecting Colors

By default, paint tools use the foreground color. However, this can be changed in the tool options of fill tools. To select the color, first click the display box of the foreground or background color, as desired.

A dialog with four tabs opens. These tabs provide different color selection methods. Only the first tab, shown in Figure 20.2, is described here. The new color is shown in ‘Current’. The previous color is shown in ‘Old’.

The easiest way to select a color is using the colored areas in the boxes to the left. In the narrow vertical bar, click a color similar to the desired color. The larger box to the left then shows available nuances. Click the desired color. It is then shown in ‘Current’. If that color is not what you want, try again.

The arrow button to the right of ‘Current’ enables saving a number of possible colors. Click the arrow to copy the current color to the history. A color can then be selected by clicking it in the history. A color can also be selected by directly entering its hexadecimal color code in ‘Hex Triplet’.
The color selector defaults to selecting a color by hue, which is usually easiest for a new user. To select by saturation, value, red, green, or blue, select the corresponding radio button to the right. The sliders and number fields can also be used to modify the currently selected color. Experiment a bit to find out what works best for you.

When the desired color is shown in ‘Current’, click ‘OK’. To restore the original values shown when the dialog was opened, click ‘Reset’. To abort changing the color, click ‘Cancel’.

To select a color that already exists in your image, use the color picker tool, the icon for which resembles an eye dropper. With the tool options, set whether the foreground or background color should be selected. Then click a point in the image that shows the desired color. When the color is right, click ‘Close’ to close the tool’s dialog.

**Painting and Erasing**

To paint and erase, use the tools from the toolbox. There are a number of options available to fine-tune each tool. Pressure sensitivity options apply only when a pressure-sensitive graphics tablet is used.
The pencil, brush, airbrush, and eraser work much like their real-life equivalents. The ink tool works like a calligraphy pen. Paint by clicking and dragging. The bucket fill is a method of coloring areas of an image. It fills based on color boundaries in the image. Adjusting the threshold modifies its sensitivity to color changes.

**Adding Text**

With the text tool, easily add text to an image. With the tool options, select the desired font, font size, color, justification, indent, and line spacing. Then click a starting point in the image. A small dialog opens in which to enter your text. Enter single or multiple lines of text then press ‘Close’.

The text tool creates text on a special layer. To work with the image after adding text, read [Layers](#) on the next page. When the text layer is active, it is possible to modify the text by clicking in the image to reopen the entry dialog. Change the settings by modifying the tool options.

**Retouching Images — The Clone Tool**

The clone tool is ideal for retouching images. It enables you to paint in an image using information from another part of the image. If desired, it can instead take information from a pattern.

When retouching, it is usually a good idea to use a small brush with soft edges. In this way, the modifications can blend better with the original image.

To select the source point in the image, press and hold `Ctrl` while clicking the desired source point. Then paint with the tool as usual. When you move the cursor while painting, the source point, marked by a cross, moves as well. If the ‘Alignment’ is set to ‘Non Aligned’ (the default setting), the source resets to the original when you release the left mouse button.

**20.5.4 Adjusting Color Levels**

Images often need a little adjusting to get ideal print or display results. In many programs designed for inexperienced users, the brightness and contrast levels are modified. This can work and is also available in The GIMP, but better results can be obtained by adjusting the color levels.

To do this, select ‘Layer’ → ‘Colors’ → ‘Levels’. A dialog opens for controlling the levels in the image. Good results can usually be obtained by clicking ‘Auto’. To
make manual adjustments to all channels, use the dropper tools in ‘All Channels’ to pick black, gray, and white points from the image itself.

To modify a channel individually, select the desired channel in ‘Modify Levels for Channel’. Then drag the black, white, and middle markers in the slider in ‘Input Levels’. Alternatively, use the dropper tools to select points in the image that should serve as the white, black, and gray points for that channel.

If ‘Preview’ is checked, the image window shows a preview of how the image would look with the modifications applied. When the desired result is achieved, press ‘OK’ to apply the changes. With ‘Resest’, restore the original settings. ‘Cancel’ aborts level adjustment.

### 20.5.5 Undoing Mistakes

Most modifications made in The GIMP can be undone. To view a history of modifications, use the undo dialog included in the default window layout or open one from the toolbox menu with ‘File’ → ‘Dialogs’ → ‘Undo History’.

The dialog shows a base image and a series of editing changes that can be undone. Use the yellow arrow at the bottom left to undo changes. Use the green arrow at the right to redo an undone change. In this way, you can work back to the base image. If you undo a modification then make a new one, the undone modification cannot be redone.

Changes can also be undone and redone with the ‘Edit’ menu. Alternatively, use the shortcuts (Ctrl)+Z and (Ctrl)+Y.

### 20.6 Editing Images: Advanced Features

#### 20.6.1 Layers

Layers are a very important aspect of The GIMP. By drawing parts of your image on separate layers, change, move, or delete those parts without damaging the rest of the image. To understand how layers work, imagine an image created from a stack of transparent sheets. Different parts of the image are drawn on different sheets. The stack can be rearranged, changing which parts are on top. Individual layers or groups of layers can shift position, moving sections of the image to other locations. New sheets can be added and others set aside.
Use the ‘Layers’ dialog to view the available layers of an image. The text tool automatically creates special text layers when used. The active layer is highlighted. The buttons at the bottom of the dialog offer a number of functions. More are available in the menu opened when a layer is right-clicked in the dialog. The two icon spaces before the image name are used for toggling image visibility (eye icon when visible) and for linking layers. Linked layers are marked with the chain icon and moved as a group.

Only layers with transparency (an alpha channel) can be placed above other layers in a stack. To add this to a layer, right-click and select it from the menu.

### 20.6.2 Image Modes

GIMP has three image modes — RGB, Grayscale, and Indexed. RGB is a normal color mode and is the best mode for editing most images. Grayscale is used for black-and-white images. Indexed limits the colors in the image to a set number. It is mainly used for GIF images. If you need an indexed image, it is normally best to edit the image in RGB then convert to indexed right before saving. If you save to a format that requires an indexed image, GIMP offers to index the image when saving.

### 20.6.3 Special Effects

The GIMP includes a wide range of filters and scripts for adding special effects to an image or making artistic manipulations. They are available in ‘Filters’ and ‘Script-fu’. Experimenting is the best way to find out what is available. ‘Xtns’ in the toolbox includes a number of items for creating buttons, logos, and other things.

### 20.7 Printing Images

To print an image, select ‘File’ → ‘Print’ from the image menu. If your printer is configured in SUSE, it should appear in the list. In some cases, it may be necessary to select an appropriate driver with ‘Setup Printer’. Select the appropriate paper size with ‘Media Size’ and the type in ‘Media Type’. Other settings are available in the ‘Image / Output Settings’ tab.

In the bottom portion of the window, adjust the image size. Press ‘Use Original Image Size’ to take these settings from the image itself. This is recommended if
Figure 20.3: The Print Dialog

you set an appropriate print size and resolution in the image. Adjust the image’s position on the page with the fields in ‘Position’ or by dragging the image in ‘Preview’. When satisfied with the settings, press ‘Print’. To save the settings for future use, instead use ‘Print and Save Settings’. ‘Cancel’ aborts printing.
20.8 Configuring GIMP

20.8.1 Customizing Windows

It is possible to customize your window layout extensively. Dialogs can be combined as multiple items in one window or with tabs. Do this by dragging and dropping a dockable window into a dock bar or existing tab. New dialogs can be opened with ‘File’ → ‘Dialogs’ from the toolbox.

20.8.2 Setting Preferences

A number of configuration options are available in ‘File’ → ‘Preferences’. The default settings should meet the needs of the average user. It may be useful, however, to review the options under ‘Environment’ → ‘Resource Levels’ and ‘Interface’ → ‘Image Windows’.

20.9 For More Information

The following are some resources that may be useful for the GIMP user. Unfortunately, the newness of this version means that many resources may be outdated.

- ‘Help’ provides access to the internal help system.
- The GIMP User Group offers an informative and interesting web site at http://gug.sunsite.dk.
- http://www.gimp.org is the official home page of The GIMP.
- Grokking the GIMP by Carey Bunks is an excellent book based on an older GIMP version. Although some aspects of the program have changed, it can provide excellent guidance for image manipulation.
- http://gimp-print.sourceforge.net is the web page for the GIMP print plug-in. The user manual available from the site provides detailed information about configuring and using the program.
Part V
Excursions
Graphical user interfaces are increasingly becoming important for Linux, but using the mouse is not always the best way to perform daily tasks. The command line provides high flexibility and efficiency. The first part of this chapter provides an introduction to the Bash shell. It is followed by an explanation of the user permissions concept in Linux and a list of the most important commands. The chapter closes with a description of the vi text editor.
Text-based applications are especially important for controlling older Linux computers that do not have the resources for demanding display systems. Virtual consoles are used in this case. Six of them are available in text mode. Press \texttt{Alt-F1} through \texttt{Alt-F6}. The seventh console is reserved for X.

## 21.1 Introduction to Bash

In the KDE taskbar, there is an icon depicting a monitor with a seashell. When you click this icon, a console window opens in which to enter commands. The console normally runs Bash (Bourne again shell), a program developed as part of the GNU project. It is, by far, the most widely used derivative of the Bourne shell (sh). Once you have opened the shell, see the prompt on the first line. The prompt usually consists of the user name, host name, and current path, but it can be customized. When the cursor is behind this prompt, you can send commands directly to your computer system.

### 21.1.1 Commands

A command consists of several elements. The first element is always the actual command, followed by parameters or options. Commands are executed when you press \texttt{Enter}. Before doing so, easily edit the command line, add options, or correct typing errors. One of the most frequently used commands is \texttt{ls}, which can be used with or without arguments. Entering the plain \texttt{ls} command in the console shows the contents of the current directory.

Options are prefixed with a hyphen. The command \texttt{ls -l}, for instance, shows the contents of the same directory in full detail. Next to each file name, see the date when the file was created, the file size in bytes, and further details, which are covered later. One very important option that exists for many commands is the \texttt{--help} option. By entering \texttt{ls --help}, display all the options for the \texttt{ls} command.

Also use the \texttt{ls} command to view the contents of other directories. To do so, the directory must be specified as a parameter. For example, to see the contents of Desktop, enter \texttt{ls -l Desktop}.

### 21.1.2 Files and Directories

To use the shell efficiently, it is really useful to have some knowledge about the file and directory structures of a Linux system. You can think of directories as
Working with the Shell

electronic folders in which files, programs, and subdirectories are stored. The top level directory in the hierarchy is the root directory, referred to as / . This is the place from which all other directories can be accessed.

The /home directory contains the directories in which the individual users can store their personal files. Figure 21.1 shows the standard directory tree in Linux, with the home directories of the example users xyz, linux, and tux. The directory tree of a Linux system has a functional structure that follows the Filesystem Hierarchy Standard. The following list provides a brief description of the standard directories in Linux.

Figure 21.1: Excerpt from a Standard Directory Tree

/ root directory, starting point of the directory tree
/home (private) directories of users
/dev device files that represent hardware components
/etc important files for system configuration
/etc/init.d boot scripts
21.1.3 Bash Functions

There are two important functions of the shell that can make your work a lot easier:

- The history function — To repeat a command that has been entered before, press ↑ until the previous command appears at the prompt. Move forward through the list of previously entered commands by pressing ↓. To edit the command line, just move the cursor to the desired position using the arrow keys and start typing. Use (Ctrl+R) to search in the history.

- The expansion function — Expand a file name to its full length after typing its first letters until it can be uniquely identified. To do so, type the first letters then hit Tab. If there are several file names starting with the same letters, obtain a list of them by hitting Tab twice.

First Example: Managing Files

Now that you know what a command looks like, which directories exist in SUSE LINUX, and how to speed up things when using Bash, put this knowledge into practice with a small exercise.

1. Open a console from the KDE desktop by clicking the shell icon.

2. Enter the ls command to see the contents of your home directory.

3. Use the command mkdir (which stands for make directory) to create a new subdirectory called test by entering mkdir test.

4. Now launch the KEdition editor by pressing (Alt+F2) and entering kedit in the input field. Type a few letters in the editor then save the file as Testfile in your home directory. Linux distinguishes between uppercase and lowercase. For this example, use an uppercase T.

5. View the contents of your home directory again. Instead of typing ls again, just press ↑ twice and the ls command should reappear at the prompt. To execute the command, hit (Enter). The newly created directory test should appear in blue letters and Testfile in black. This is how directories and files can be distinguished in a console.
6. Move **Testfile** into the subdirectory **test** with the command `mv`. To speed this up, use the expansion function: just enter `mv T` and press (TAB). As long as there is no other file beginning with this letter in the directory, the shell expands the file name and adds the string `estfile`. Otherwise, add a letter or two yourself and test (TAB) each time to see whether the shell can now expand the name. Finally, type a space then `test` after the expanded file name and press (Enter) to execute the command.

7. At this point, **Testfile** should no longer be in the directory. Check this by entering `ls` again.

8. To see whether the file has been successfully moved, change into the directory **test** with the command `cd test`. Now enter `ls` again. You should see **Testfile** in the listing. Change back to your home directory at any point by entering only `cd`.

9. To make a copy of a file, use `cp`. For instance, enter `cp Testfile Testbackup` to copy **Testfile** to **Testbackup**. Once again, the command `ls` can be used to see whether both files are in the directory.

### 21.1.4 Specifying Paths

When working with files or directories, it is important specify the correct path. However, you do not need to enter the entire (absolute) path from the root directory to the respective file. Rather, you can start from the current directory. Address your home directory directly with ~. Accordingly, there are two ways to list the file **Testfile** in the directory **test**: by entering the relative path with `ls test/*` or by specifying the absolute path with `ls /test/*`.

To list the contents of home directories of other users, enter `ls username`. In the above-mentioned directory tree, one of the sample users is **tux**. In this case, `ls  tux` would list the contents of the home directory of **tux**.

Refer to the current directory with a dot. The next higher level in the tree is represented by two dots. By entering `ls  ..`, see the contents of the parent directory of the current directory. The command `ls  ../..` shows the contents of the directory two levels higher in the hierarchy.

**Second Example: Working with Paths**

Here is another example to illustrate how to move around in the directories of your SUSE LINUX system.
1. Change into your home directory with the command `cd`. Then create a directory in it with the name `test2` by entering `mkdir test2`.

2. Change into the new directory with `cd test2` and create a subdirectory in it with the name `subdirectory`. To change into it, use the expansion function: enter `cd su` then press (→). The shell will expand the rest of the directory name.

3. Now try to move the previously created file `Testbackup` into the current directory (`subdirectory`) without changing the directory again. To achieve this, specify the relative path to that file: `mv ../../test/Testbackup ..`. The dot at the end of this command is required to tell the shell that the current directory is the destination to which to move the file. `../../`, in this example, refers to your home directory.

### 21.1.5 Wild Cards

Another convenience offered by the shell is wild cards. There are four different types of these in Bash:

- `?` Matches exactly one arbitrary character
- `*` Matches any number of characters
- `[set]` Matches one of the characters from the group specified inside the square brackets, which is represented here by the string `set`
- `![set]` Matches one character other than those identified by `set`

Assuming that your `test` directory contains the files `Testfile`, `Testfile1`, `Testfile2`, and `datafile`, the command `ls Testfile?` lists the files `Testfile1` and `Testfile2`. With `ls Test*`, the list will also include `Testfile`. The command `ls *fil*` shows all the sample files. Finally, you can use the `set` wild card to address all sample files whose last character is a number: `ls Testfile[1-9]`.

Of the four types of wild cards, the most inclusive one is the asterisk. It could be used to copy all files contained in one directory to another one or to delete all files with one command. The command `rm *fil*`, for instance, would delete all files in the current directory whose name includes the string `fil`. 
21.1.6 Less and More

Linux includes two small programs for viewing text files directly in the shell. Rather than starting an editor to read a file like Readme.txt, simply enter less Readme.txt to display the text in the console window. Use (Space) to scroll down one page. Use (Page Up) and (Page Down) to move forward or backward in the text. To exit less, press (Q).

Instead of less, you can also use the older program more. However, it is less convenient because it does not allow you to scroll backwards.

The program less got its name from the the precept that less is more and can also be used to view the output of commands in a convenient way. To see how this works, read [Pipes] on the current page.

21.1.7 Pipes

Normally, the standard output in the shell is your screen or the console window and the standard input is the keyboard. To forward the output of a command to an application such as less, use a pipeline.

To view the files in the test directory, enter the command ls test | less. The contents of the test directory will be displayed with less. This only makes sense if the normal output with ls would be too lengthy. For instance, if you view the contents of the dev directory with ls /dev, you will only see a small portion in the window. View the entire list with ls /dev | less.

It is also possible to save the output of commands to a file. For example, ls test > Content generates a new file called Content that contains a list of the files and directories in test. View the file with less Content.

You can also use a file as the input for a command. For example, sort the text lines in Testfile with sort < Testfile. The output of the command sort is sent to the screen. The text is sorted by the first letters of the individual lines.

If you need a new file containing the sorted list, pipe the output of the command sort to a file. To test this, create an unsorted name list in an editor and save it under list in the test directory. Then change into test and enter the command sort < unsortedlist > sortedlist. Finally, view the sorted list with less.

Just like the standard output, the standard error output is sent to the console as well. However, to redirect the standard error output to a file named errors, append 2> errors to the corresponding command. Both standard output
and standard error are saved to one file named alloutput if you append >& alloutput. Finally, to append the output of a command to an already existing file, the command must be followed by » instead of a single >.

### 21.1.8 Archives and Data Compression

Now that you have already created a number of files and directories, consider the subject of archives and data compression. Suppose you want to have the entire test directory packed in one file that you can save on a floppy disk as a backup copy or send by e-mail. To do so, use the command `tar` (for tap archiver). With `tar --help`, view all the options for the `tar` command. The most important of these options are explained here:

- `-c` (for create) Create a new archive.
- `-t` (for table) Display the contents of an archive.
- `-x` (for extract) Unpack the archive.
- `-v` (for verbose) Show all files on screen while creating the archive.
- `-f` (for file) Choose a file name for the archive file. When creating an archive, this option must always be given as the last one.

To pack the test directory with all its files and subdirectories into an archive named testarchive.tar, use the options `-c` and `-f`. For the testing purposes of this example, also add `-v` to follow the progress of the archiving, although this option is not mandatory. After using `cd` to change to your home directory where the test directory is located, enter `tar -cvf testarchive.tar test`. After that, view the contents of the archive file with `tar -tf testarchive.tar`. The test directory with all its files and directories has remained unchanged on your hard disk. To unpack the archive, enter `tar -xvf testarchive.tar`, but do not try this yet.

For file compression, the obvious choice on Linux is the popular gzip program. Just enter `gzip testarchive.tar`. With `ls`, now see that the file testarchive.tar is no longer there and that the file testarchive.tar.gz has been created instead. This file is much smaller and therefore much better suited for transfer via e-mail or storage on a floppy.

Now, unpack this file in the test2 directory created earlier. To do so, enter `cp testarchive.tar.gz test2` to copy the file to that directory.
Change to the directory with `cd test2`. A compressed archive with the `.tar.gz` extension can be unzipped with the `gunzip` command. Enter `gunzip testarchive.tar.gz`, which results in the file `testarchive.tar`, which then needs to be extracted or `untarred` with `tar -xvf testarchive.tar`. You can also unzip and extract a compressed archive in one step by adding the `-z` option. The complete command would be `tar -xzvf testarchive.tar.gz`. With `ls`, you can see that a new `test` directory has been created with the same contents as your `test` directory in your home directory.

### 21.1.9 mtools

`mtools` are a set of commands for working with MS-DOS file systems. The commands included in `mtools` allow you to address the first floppy drive as `a:` just like under MS-DOS, and the commands are like MS-DOS commands except they are prefixed with an `m`:

- `mdir a:` displays the contents of the floppy disk in drive `a:`
- `mcopy Testfile a:` copies the file `Testfile` to the floppy disk
- `mdel a:Testfile` deletes `Testfile` in `a:`
- `mformat a:` formats the floppy disk in MS-DOS format (using the `fdformat` command)
- `mcd a:` makes `a:` your current directory
- `mmd a:test` creates the subdirectory `test` on the floppy disk
- `mrda a:test` deletes the subdirectory `test` from the floppy disk

### 21.1.10 Cleaning Up

After this crash course, you should be familiar with the basics of the Linux shell or command line. You may want to clean up your home directory by deleting the various test files and directories using the `rm` and `rmdir` commands. At the end of this chapter, find a list of the most important commands and a brief description of their functions.
21.2 Users and Access Permissions

Since its inception in the early 1990s, Linux has been developed as a multiuser system. Any number of users can work on it simultaneously. Users need to log in to the system before starting a session at their workstations. Each user has a user name with a corresponding password. This differentiation of users guarantees that unauthorized users cannot see files for which they do not have permission. Larger changes to the system, such as installing new programs, are also usually impossible or restricted for normal users. Only the root user, or super user, has the unrestricted capacity to make changes to the system and has unlimited access to all files. Those who use this concept wisely, only logging in with full root access when necessary, can cut back the risk of unintentional loss of data. Because under normal circumstances only root can delete system files or format hard disks, the threat from the Trojan horse effect or from accidentally entering destructive commands can be significantly reduced.

21.2.1 File System Permissions

Basically, every file in a Linux file system belongs to a user and a group. Both of these proprietary groups and all others can be authorized to write, read, or execute these files.

A group, in this case, can be defined as a set of connected users with certain collective rights. For example, call a group working on a certain project project3. Every user in a Linux system is a member of at least one proprietary group, normally users. There can be as many groups in a system as needed, but only root is able to add groups. Every user can find out, with the command groups, of which groups he is a member.

File Access The organization of permissions in the file system differs for files and directories. File permission information can be displayed with the command ls -l. The output could appear as in Output 21.1:

```
Example 21.1: Sample Output Showing File Permissions
-rw-r----- 1 tux project3 14197 Jun 21 15:03 Roadmap
```

As shown in the third column, this file belongs to user tux. It is assigned to the group project3. To discover the user permissions of the Roadmap file, the first column must be examined more closely.
This column is comprised of one leading character followed by nine characters grouped in threes. The first of the ten letters stands for the type of file system component. The dash (–) shows that this is a file. A directory (d), a link (l), a block device (b), or a character device could also be indicated.

The next three blocks follow a standard pattern. The first three characters refer to whether the file is readable (r) or not (–). A w in the middle portion symbolizes that the corresponding object can be edited and a dash (–) means it is not possible to write to the file. An x in the third position denotes that the object can be executed. Because the file in this example is a text file and not one that is executable, executable access for this particular file is not needed.

In this example, tux has, as owner of the file Roadmap, read (r) and write access (w) to it, but cannot execute it (x). The members of the group project3 can read the file, but they cannot modify it or execute it. Other users do not have any access to this file. Other permissions can be assigned by means of ACLs (Access Control Lists). See Access Control Lists on page 269 for details and refer to the chapter in the Administration Guide for further background information.

**Directory Permissions** Access permissions for directories have the type d. For directories, the individual permissions have a slightly different meaning.

**Example 21.2:** Sample Output Showing Directory Permissions

```bash
drwxrwxr-x 1 tux project3 35 Jun 21 15:15 ProjectData
```

In Output 21.2, the owner (tux) and the owning group (project3) of the directory ProjectData are easy to recognize. In contrast to the file access permissions from File Access on the page before, the set reading permission (r) means that the contents of the directory can be shown. The write permission (w) means new files can be created. The executable permission (x) means the user can change to this directory. In the above example, this
means the user **tux** as well as the members of the group **project3** can change to the `ProjectData` directory (x), view the contents (r), and add new files to it (w). The rest of the users, on the other hand, are given less access. They may enter the directory (x) and browse through it (r), but not insert any new files (w).

### 21.2.2 Modifying File Permissions

**Changing Access Permissions** The access permissions of a file or directory can be changed by the owner and, of course, by **root** with the command `chmod` followed by the parameters changing the permissions and one or more file names. The parameters form different categories:

1. users concerned
   - u *(user)* — owner of the file
   - g *(group)* — group that owns the file
   - o *(others)* — additional users (if no parameter is given, the changes apply to all categories)
2. a character for deletion (–), setting (=), or insertion (+)
3. the abbreviations
   - r — read
   - w — write
   - x — execute
4. file name or names separated by spaces

If, for example, the user **tux** in Example 21.2 on the facing page also wants to grant other users write (w) access to the directory `ProjectData`, he can do this using the command `chmod o+w ProjectData`.

If, however, he wants to deny all users other than himself write permissions, he can do this by entering the command `chmod go-w ProjectData`. To prohibit all users from adding a new file to the folder `ProjectData`, enter `chmod -w ProjectData`. Now, not even the owner can write to the file without first reestablishing write permissions.

**Changing Ownership Permissions** Other important commands to control the ownership and permissions of the file system components are `chown` (change owner) and `chgrp` (change group). The command `chown` can be
used to transfer ownership of a file to another user. However, only root is permitted to perform this change.

Suppose the file Roadmap from Example 21.2 on page 266 should no longer belong to tux, but to the user geeko. root should then enter chown geeko Roadmap.

chgrp changes the group ownership of the file. However, the owner of the file must be a member of the new group. In this way, the user tux from Output 21.1 on page 265 can switch the group owning the file ProjectData to project4 with the command chgrp project4 ProjectData, as long as he is a member of this new group.

21.2.3 The setuid Bit

In certain situations, the access permissions may be too restrictive. Therefore, Linux has additional settings that enable the temporary change of the current user and group identity for a specific action. For example, the cdrecord program normally requires root permissions to access the writer for burning CDs (or DVDSs). Thus, a normal user would not be able to create CDs, as it would be too dangerous to grant all users direct access to all devices. A possible solution to this problem is the setuid mechanism. setuid (set user ID) is a special file attribute that instructs the system to execute programs marked accordingly under a specific user ID. Consider the cdrecord command:

```
-rwxr-x--- 1 root root 281356 2002-10-08 21:30 /usr/bin/cdrecord
```

Set the setuid bit with the command chmod u+s /usr/bin/cdrecord. Then, assign the cdrecord program to the group users with the command chgrp users /usr/bin/cdrecord. The following access permissions are granted:

```
-rws--x--- 1 root users 281356 2002-10-08 21:30 /usr/bin/cdrecord
```

By means of the setuid bit, all users belonging to the group users can use the program. In effect, this means that the program is executed as root.

**Caution**

Setting the setuid bit for a program makes your computer more vulnerable to attacks. Only do this in exceptional cases when you know the program well and are aware of the potential risks.
21.2.4 The setgid Bit

The setuid attribute applies to users. However, there is also an equivalent property for groups — the setgid attribute. A program for which this attribute was set runs under the group ID under which it was saved, no matter which user starts it. Therefore, in a directory with the setgid bit, all newly created files and subdirectories are assigned to the group to which the directory belongs. Consider the following example directory:

```
drwxrwxr-- 2 root archive 48 Nov 19 17:12 backup
```

Set the setuid bit with the command `chmod g+s /test`. Subsequently, the access permissions appear as follows:

```
drwxrwxr-- 2 root archive 48 Nov 19 17:12 backup
```

21.2.5 The Sticky Bit

There is also the sticky bit. It makes a difference whether it belongs to an executable program or a directory. If it belongs to a program, a file marked in this way will be loaded to the RAM to avoid needing to get it from the hard disk each time it is used. This attribute is used rarely, as modern hard disks are fast enough. If this attribute is assigned to a directory, it prevents users from deleting each other’s files. Typical examples include the `/tmp` and `/var/tmp` directories:

```
drwxrwxrw+ 2 root root 1160 2002-11-19 17:15 /tmp
```

21.2.6 Access Control Lists

The traditional permission concept for Linux file system objects, such as files or directories, can be expanded by means of ACLs (access control lists). They allow the assignment of permissions to individual users or groups other than the original owner or owning group of a file system object.

Files or directories bearing extended access permissions can be detected with a simple `ls -l` command:

```
-rw-r--r--+ 1 tux project3 14197 Jun 21 15:03 Roadmap
```
The output of \texttt{ls} does not reveal much of a change compared to an \texttt{ls} on a file without an ACL. \texttt{Roadmap} is owned by \texttt{tux} who belongs to the group \texttt{project3}. \texttt{tux} holds both write and read access to this file and his group as well as all other users have read access. The only difference that distinguishes this file from a file without an ACL is the additional + in the first column holding the permission bits.

Get details about the ACL by executing \texttt{getfacl Roadmap}:

\begin{verbatim}
# file: Roadmap
# owner: tux
# group: project3
user::rw-
user:jane:rw- effective: r--
group::r--
group:djungle:rw- effective: r--
mask::r--
other::---
\end{verbatim}

The first three lines of the output do not hold any information not available with \texttt{ls -l}. These lines only state file name, owner, and owning group. Lines 4 to 9 hold the ACL entries. Conventional access permissions represent a subset of those possible when using ACLs. Our example ACL grants read and write access to the owner of the file as well as to a user \texttt{jane} (lines 4 and 5). The conventional concept has been expanded allowing access to an extra user. The same applies to the handling of group access. The owning group holds read permissions (line 6) and the group \texttt{djungle} holds read and write permissions. The \texttt{mask} entry in line 8 reduces the effective permissions for the user \texttt{jane} and the group \texttt{djungle} to read access. Other users and groups do not get any kind of access to the file (line 9).

Only very basic information has been provided here. Find further background information about ACLs in the \textit{Administration Guide}.

\section*{21.3 Important Linux Commands}

This section gives insight into the most important commands of your SUSE LINUX system. Along with the individual commands, parameters are listed and, where appropriate, a typical sample application is introduced. To learn more about the various commands, use the \textit{manual pages} accessed with \texttt{man} followed by the name of the command, for example, \texttt{man ls}. 

\cleardoublepage
In the man pages, move up and down with \textit{(PgUp)} and \textit{(PgDn)}. Move between the beginning and the end of a document with \textit{(Home)} and \textit{(End)}. End this viewing mode by pressing \texttt{[Ctrl]}d. Learn more about the \texttt{man} command itself with \texttt{man man}.

There are many more commands than listed in this chapter. For information about other commands or more detailed information, the O'Reilly publication \textit{Linux in a Nutshell} is recommended. In the following overview, the individual command elements are written in different typefaces.

The actual command and its mandatory options are always printed as \texttt{command option}. Specifications or parameters that are not required are placed in \texttt{[square brackets]}.

Adjust the settings to your needs. It makes no sense to write \texttt{ls file(s)}, if no file named \texttt{file(s)} actually exists. You can usually combine several parameters, for example, by writing \texttt{ls -la} instead of \texttt{ls -l -a}.

### 21.3.1 File Commands

**File Administration**

\texttt{ls [option(s)] [file(s)]}  
If you run \texttt{ls} without any additional parameters, the program lists the contents of the current directory in short form.

- \texttt{-l} Detailed list
- \texttt{-a} Displays hidden files

\texttt{cp [option(s)] sourcefile targetfile}  
Copies sourcefile to targetfile.

- \texttt{-i} Waits for confirmation, if necessary, before an existing \texttt{targetfile} is overwritten
- \texttt{-r} Copies recursively (includes subdirectories)

\texttt{mv [option(s)] sourcefile targetfile}  
Copies sourcefile to targetfile then deletes the original sourcefile.

- \texttt{-b} Creates a backup copy of the sourcefile before moving
- \texttt{-i} Waits for confirmation, if necessary, before an existing \texttt{targetfile} is overwritten
**rm [option(s)] file(s)**  Removes the specified files from the file system. Directories are not removed by `rm` unless the option `-r` is used.

- `-r` Deletes any existing subdirectories
- `-i` Waits for confirmation before deleting each file.

**ln [option(s)] sourcefile targetfile**  Creates an internal link from the `sourcefile` to the `targetfile`. Normally, such a link points directly to the `sourcefile` on the same file system. However, if `ln` is executed with the `-s` option, it creates a symbolic link that only points to the directory in which the `sourcefile` is located, enabling linking across file systems.

- `-s` Creates a symbolic link

**cd [options(s)] [directory]**  Changes the current directory; `cd` without any parameters changes to the user’s home directory.

**mkdir [option(s)] directoryname**  Creates a new directory.

**rmdir [option(s)] directoryname**  Deletes the specified directory, if it is already empty.

**chown [option(s)] username.group file(s)**  Transfers ownership of a file to the user with the specified user name.

- `-R` Changes files and directories in all subdirectories.

**chgrp [option(s)] groupname file(s)**  Transfers the group ownership of a given file to the group with the specified group name. The file owner can only change group ownership if a member of both the current and the new group.

**chmod [options] mode file(s)**  Changes the access permissions.

The `mode` parameter has three parts: group, access, and access type. The `group` accepts the following characters:

- `u` user
- `g` group
- `o` others
For access, grant access with + and deny it with −.
The access type is controlled by the following options:

- r  read
- w  write
- x  eXecute — executing files or changing to the directory.
- s  Set uid bit — the application or program is started as if it were started by the owner of the file.

As an alternative, a numeric code can be used. The four digits of this code are composed of the sum of the values 4, 2 and 1 — the decimal result of a binary mask. The first digit sets the set user ID (SUID) (4), the set group ID (2), and the sticky (1) flags. The second digit defines the permissions of the owner of the file. The third digit defines the permissions of the group members and the last digit sets the permissions for all other users. The read permission is set with 4, the write permission with 2, and the permission for executing a file is set with 1. The owner of a file would usually receive a 7 — the sum of all permissions.

gzip [parameters] file(s)  This program compresses the contents of files using complex mathematical algorithms. Files compressed in this way are given the extension .gz and need to be uncompressed before they can be used. To compress several files or even entire directories, use the tar command.

- d  Decompresses the packed gzip files so they return to their original size and can be processed normally (like the command gunzip)

tar options archive file(s)  tar puts one or more files into an archive.
Compression is optional. tar is a quite complex command with a number of options available. The most frequently used options are:

- f  Writes the output to a file and not to the screen as is usually the case
- c  Creates a new tar archive
- r  Adds files to an existing archive
- t  Outputs the contents of an archive
- u  Adds files, but only if they are newer than the files already contained in the archive
- x  Unpacks files from an archive (extraction)
-z Packs the resulting archive with gzip
-j Compresses the resulting archive with bzip2
-v Lists files processed

The archive files created by tar end with .tar. If the tar archive was also compressed using gzip, the ending is .tgz or .tar.gz. If it was compressed using bzip2, the ending is .tar.bz2. Application examples can be found in [Archives and Data Compression](#) on page 263.

**locate pattern(s)** The locate command can find in which directory a specified file is located. If desired, use wild cards to specify file names. The program is very speedy, as it uses a database specifically created for the purpose (rather than searching through the entire file system). This very fact, however, also results in a major drawback: locate is unable to find any files created after the latest update of its database. The database can be generated by root with updatedb.

**updatedb [options(s)]** This command performs an update of the database used by locate. To include files in all existing directories, run the program as root. It also makes sense to place it in the background by appending an ampersand (&), so you can immediately continue working on the same command line (updatedb &).

**find [option(s)]** With find, search for a file in a given directory. The first argument specifies the directory in which to start the search. The option -name must be followed by a search string, which may also include wild cards. Unlike locate, which uses a database, find scans the actual directory.

**Commands to Access File Contents**

**cat [option(s)] file(s)** The cat command displays the contents of a file, printing the entire contents to the screen without interruption.

-\n Numbers the output on the left margin

**less [option(s)] file(s)** This command can be used to browse the contents of the specified file. Scroll half a screen page up or down with PgUp and PgDn or a full screen page down with Space. Jump to the beginning or end of a file using Home and End. Press Q to exit the program.
grep [option(s)] searchstring filenames
The `grep` command finds a specific search string in the specified file(s). If the search string is found, the command displays the line in which the searchstring was found along with the file name.

- `i` Ignores case
- `H` Only displays the names of the respective files, but not the text lines
- `n` Additionally displays the numbers of the lines in which it found a hit
- `l` Only lists the files in which searchstring does not occur

diff [option(s)] file1 file2
The `diff` command compares the contents of any two files. The output produced by the program lists all lines that do not match. This is frequently used by programmers who need only send their program alterations and not the entire source code.

- `q` Only reports whether the two files differ

File Systems

mount [option(s)] [device] mountpoint
This command can be used to mount any data media, such as hard disks, CD-ROM drives, and other drives, to a directory of the Linux file system.

- `r` mount read-only
- `t filesystem` Specifies the file system. The most common are `ext2` for Linux hard disks, `msdos` for MS-DOS media, `vfat` for the Windows file system, and `iso9660` for CDs.

For hard disks not defined in the file `/etc/fstab`, the device type must also be specified. In this case, only `root` can mount it. If the file system should also be mounted by other users, enter the option `user` in the appropriate line in the `/etc/fstab` file (separated by commas) and save this change. Further information is available in `mount (1)`.

umount [option(s)] mountpoint
This command unmounts a mounted drive from the file system. To prevent data loss, run this command before taking a removable data medium from its drive. Normally, only `root` is allowed to run the commands `mount` and `umount`. To enable other users to run these commands, edit the `/etc/fstab` file to specify the option `user` for the respective drive.
21.3.2 System Commands

System Information

\texttt{df [option(s)] [directory]} The \texttt{df} (disk free) command, when used without any options, displays information about the total disk space, the disk space currently in use, and the free space on all the mounted drives. If a directory is specified, the information is limited to the drive on which that directory is located.

- \texttt{-H} Shows the number of occupied blocks in gigabytes, megabytes, or kilobytes — in human-readable format
- \texttt{-t} Type of file system (ext2, nfs, etc.)

\texttt{du [option(s)] [path]} This command, when executed without any parameters, shows the total disk space occupied by files and subdirectories in the current directory.

- \texttt{-a} Displays the size of each individual file
- \texttt{-h} Output in human-readable form
- \texttt{-s} Displays only the calculated total size

\texttt{free [option(s)]} The command \texttt{free} displays information about RAM and swap space usage, showing the total and the used amount in both categories.

- \texttt{-b} Output in bytes
- \texttt{-k} Output in kilobytes
- \texttt{-m} Output in megabytes

\texttt{date [option(s)]} This simple program displays the current system time. If run as root, it can also be used to change the system time. Details about the program are available in \texttt{date}.

Processes

\texttt{top [options(s)]} \texttt{top} provides a quick overview of the currently running processes. Press \texttt{H} to access a page that briefly explains the main options to customize the program.
ps [option(s)] [process ID]  If run without any options, this command displays a table of all your own programs or processes — those you started. The options for this command are not preceded by hyphen.

aux  Displays a detailed list of all processes, independent of the owner

kill [option(s)] process ID  Unfortunately, sometimes a program cannot be terminated in the normal way. In most cases, you should still be able to stop such a runaway program by executing the kill command, specifying the respective process ID (see top and ps). kill sends a TERM signal that instructs the program to shut itself down. If this does not help, the following parameter can be used:

-9  Sends a KILL signal instead of a TERM signal. This brings the specified process to an end in almost all cases.

killall [option(s)] processname  This command is similar to kill, but uses the process name (instead of the process ID) as an argument, killing all processes with that name.

Network

ping [option(s)] host name|IP address  The ping command is the standard tool for testing the basic functionality of TCP/IP networks. It sends a small data packet to the destination host, requesting an immediate reply. If this works, ping displays a message to that effect, which indicates that the network link is basically functioning.

-c number  Determines the total number of packages to send and ends after they have been dispatched. By default, there is no limitation set.

-f flood ping: sends as many data packages as possible. A popular means, reserved for root, to test networks.

-i value  Specifies the interval between two data packages in seconds. Default: one second

nslookup  The domain name system resolves domain names to IP addresses. With this tool, send queries to information servers (DNS servers).

telnet [option(s)] host name or IP address  Telnet is actually an Internet protocol that enables you to work on remote hosts across a network. telnet is also the name of a Linux program that uses this protocol to enable operations on remote computers.
Caution
Do not use telnet over a network on which third parties can eavesdrop. Particularly on the Internet, use encrypted transfer methods, such as ssh, to avoid the risk of malicious misuse of a password (see the man page for ssh).

Miscellaneous

**passwd [option(s)] [username]** Users may change their own passwords at any time using this command. The administrator root can use the command to change the password of any user on the system.

**su [option(s)] [username]** The su command makes it possible to log in under a different user name from a running session. When using the command without specifying a user name, you will be prompted for the root password. Specify a user name and the corresponding password to use the environment of the respective user. The password is not required from root, as root is authorized to assume the identity of any user.

**halt [option(s)]** To avoid loss of data, you should always use this program to shut down your system.

**reboot [option(s)]** Does the same as halt except the system performs an immediate reboot.

**clear** This command cleans up the visible area of the console. It has no options.

### 21.4 The vi Editor

Operating the vi editor takes some practice. For many, it is the preferred editor, partly because it is available on any UNIX-like operating system and is included in default Linux installations. Also, if nothing else works, vi will. The short instructions that follow should enable you to edit various configuration files and other types of files with vi.

vi provides three operating modes. In command mode keys are interpreted as command elements. Insert mode interprets all keys as text entries. Last line mode is used for more complex commands, which are entered in the last line.
<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ESC</td>
<td>Changes to last line mode.</td>
</tr>
<tr>
<td>i</td>
<td>Changes to insert mode (characters appear at the current cursor position).</td>
</tr>
<tr>
<td>a</td>
<td>Changes to insert mode (characters appear after the current cursor position).</td>
</tr>
<tr>
<td>A</td>
<td>Changes to insert mode (characters are added at the end of the line).</td>
</tr>
<tr>
<td>R</td>
<td>Changes to command mode (overwrites the old text).</td>
</tr>
<tr>
<td>r</td>
<td>Changes to insert mode and overwrites each character.</td>
</tr>
<tr>
<td>s</td>
<td>Changes to insert mode (the character where the cursor is positioned is replaced by the next entry you make).</td>
</tr>
<tr>
<td>C</td>
<td>Changes to insert mode (the rest of the line is replaced by the new text).</td>
</tr>
<tr>
<td>o</td>
<td>Changes to insert mode (a new line is inserted after the current one).</td>
</tr>
<tr>
<td>O</td>
<td>Changes to insert mode (a new line is inserted before the current one).</td>
</tr>
<tr>
<td>x</td>
<td>Deletes the current character.</td>
</tr>
<tr>
<td>dd</td>
<td>Deletes the current line.</td>
</tr>
<tr>
<td>dw</td>
<td>Deletes up to the end of the current word.</td>
</tr>
<tr>
<td>cw</td>
<td>Changes to insert mode (the rest of the current word is overwritten by the next entries you make).</td>
</tr>
<tr>
<td>u</td>
<td>Undoes the last command.</td>
</tr>
<tr>
<td>J</td>
<td>Joins the following line with the current one.</td>
</tr>
<tr>
<td>.</td>
<td>Repeats the last command.</td>
</tr>
<tr>
<td>:</td>
<td>Changes to last line mode.</td>
</tr>
</tbody>
</table>

The most important commands in command mode are shown in Table 21.2. Each command can be preceded by a number specifying on how many objects the following command should operate. Delete three words at once by entering 3dw.
The command `10x` deletes ten characters after the cursor position and `20dd` deletes twenty lines.

The most important commands in last line mode are shown in Table 21.3.

**Table 21.3: Complex Commands of the vi Editor**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>:q!</td>
<td>exits vi without saving any changes</td>
</tr>
<tr>
<td>:w filename</td>
<td>saves as filename</td>
</tr>
<tr>
<td>:x</td>
<td>saves the modified file and exits the editor</td>
</tr>
<tr>
<td>:e filename</td>
<td>edits (loads) filename</td>
</tr>
<tr>
<td>:u</td>
<td>undoes the last edit command</td>
</tr>
</tbody>
</table>
This chapter is a short discussion of the ergonomic issues involved in the layout of computer workplaces. This text should not be seen as a substitute for studying the respective standards. No citations from these are included here and footnotes with references to other literature are completely omitted to preserve readability. The items referred to in each section are mostly gathered from German literature and are almost always based on regulations and policies in the Federal Republic of Germany. This information is still useful in designing an ergonomic work area.
22.1 The Working Environment

If ergonomics specialists examined the home workstations of computer users systematically, they would find many problems. Unfortunately, no standard has yet prevented individual users from buying so-called “special computer tables”. The low-priced metal-tube frames with “practical rollers” (little stability), “ergonomically retractable keyboard tray” (no wrist pad), “integrated PC case holder and printer stand with paper shelf” (little stacking space and sometimes little legroom), “swiveling mouse pad” (unstable and insufficient working space), and “good view of the screen” (too close, too high) allow you to use a computer for a short time only. They should not be used at professional terminal workstations as they hardly meet any criteria of the corresponding standards. You will not find much of this kind of computer furniture in professional computer equipment catalogs, because manufacturers indirectly keep an eye on the employees’ health by observing the minimum standards of computer workstations. Even these minimum standards should be improved.

22.1.1 The Right Desk

A table at the wrong height strains arm and back muscles. The resulting cramped posture especially strains the spine. Too little leg room can force an unnatural body posture and cause disorders to the blood supply.

Choosing the right table is very easy. It should be as wide and deep as possible. An individual adjustment of the table height would be optimal. Working tables at which you can change between sitting and standing by turning the table into a writing stand, often just at the push of a button, are a luxury, but changing between a sitting and standing position brings relief.

- The flexible arrangement of working materials requires a table top of at least 160 x 80 cm.
- Workstations made of several interlinked boards are recommended.
- Tables that cannot be vertically adjusted must be 72 cm high. Tables that are vertically adjustable must be between 68 and 76 cm high.
- Even more width is needed for certain working tasks, such as CAD workstations. When changing between screen work and other kinds of work, at least 200 cm is required.
- There should be at least 60 cm leg room. Previous experience has shown, however, that this leg room is often too little.

- When using large screens, tables should be 100 or even 120 cm deep.

- The table surface should not be in bright colors and should have minimal reflection. A lot of office furniture is available in a subdued grey only.

### 22.1.2 Sitting Correctly on the Right Working Chair

Sitting in a working chair makes you sit in the same posture for a long time, unlike in an easy chair where you can move around easily. Constant sitting in the wrong position, such as bending forward or twisting to the side, can harm the respiratory and digestive organs. This leads to premature fatigue, circulatory disturbances, and backache resulting from overstraining the spine and the vertebral disks. In extreme cases, years of sitting in the wrong position can lead to muscular and skeletal illnesses.

Correct sitting means a frequent change of posture. Different parts of the body are then constantly being used. Basically, it is a question of the correct adjustment. The height of your working chair is best when your forearms lying on the table are at right angles to your upper arms. You should be able to place your feet completely on the floor and your thighs and lower legs should also be at right angles. Gymnastic balls and balancing chairs offer an alternative to conventional seating arrangements.

Unfortunately, a good chair, constructed according to ergonomic criteria, is relatively expensive, but the investment in your health is worth it. Important features of a good chair include:

- a backrest reaching to the shoulder blades and with an adjustable kinetic resistance
- support for the lumbar spinal column
- a seat that is also adjustable and can be tilted forwards or backwards
- automatic regulation of backrest and seat to retain an ideal angle
- springs that softly cushion the weight when sitting down
- stability through at least five legs and wheels that offer more resistance when you stand
- adjustable height of the seat (according to standards, 42 to 53 cm) and backrest
- individual adjustment of arm rests, if there are any (luxury)
- a footrest if your feet do not reach the floor

22.1.3 Good Lighting for Productive Work

Generally speaking, workplace lighting does not come close to the intensity of light outdoors. This difference is unnoticed because the human faculty of perception is very flexible. The influence of lighting conditions on our own efficiency is often underestimated. If the light is too bright, you cannot see what is on the screen. If it is too dark, sharpness of vision decreases. The wrong lighting overstrains the visual system and, eventually, causes symptoms of fatigue and stress.

It is assumed that a combination of general lighting and individual workstation lighting is best. For the workstation at home, the combination of a high-powered ceiling lamp (500 watts, preferably with a dimmer) and one or two workplace lamps is recommended. The fluorescent lamps usually found in offices for general lighting should be supplemented by individual workstation lamps. The lighting should, however, not be too intense and be individually adjustable. Stark contrasts should be avoided. Be careful with strong desk lamps. Good illumination is, unfortunately, very expensive and the minimum requirements of lighting can also be fulfilled with cheaper illumination layouts.

- It is important that you are exposed to daylight. A view outside is preferable.
- General lighting is considered pleasant if it is not below 250 lx (usually 500 lx is required, 1000 lx for an open plan office).
- 500–750 lx should be emitted by the individual workstation lighting. However, individual lamps are often problematic. If they are too strong, the contrast to the general lighting is too great. Harmonic, soft transitions are considered more pleasant.
- The lighting should not flicker. In the case of worn-out fluorescent lamps, a flickering can sometimes be noticed from the corner of the eye.
- Avoid dark shadows.
Ceiling lights should emit light diagonally from above. Lighting strips should be set perpendicular to the screen table. The line of sight at the screen table should run parallel to the lighting strips.

Whether the lighting is considered to be pleasant depends on the color temperature and light color of the lamp type. Warm white or neutral white is recommended.

The light requirement depends not only on the working task, but also on age: older people need more light. The fact that older people often have only a small lamp in their homes has nothing to do with their light requirement, but rather with the fact that they want to save electricity.

A screen workstation near daylight requires optimum shielding against direct and reflex glare, especially when the line of sight is directly out the window or at a 45 degree angle to it. The built-in antiglare facilities should be variable. Under no circumstances should artificial illumination cause reflex glare on the screen.

### 22.1.4 Optimum Climate

The room climate determines our well-being to a great extent. Problems arise more often if it is too cold, too warm, too drafty, or too dry. Low relative humidity can lead to burning eyes, dry mucous membranes, skin irritations, and increased susceptibility to colds. Things get complicated when people who work in the same room are accustomed to different base temperatures. For your well-being, it is important to observe the recommended basic values for temperature and humidity and to avoid strong air movement. The working material itself should not contribute to the increase of temperature.

For activities in a sitting position or simple work, a room temperature of 20 to 22 °C is recommended. In summer, the temperature should be 26 °C at the most. This value should only be exceeded for a short time when the outdoor temperature is higher.

A lot of equipment, as well as people, emit heat and influence room air conditions. This should be reduced as much as possible.

The air humidity should be between 40 (sometimes 50) and 65 percent and should be checked. This value is especially affected by heating systems.
Draft (possibly from open windows and doors or air conditioning) should not exceed 0.1 to 0.15 m/s. Draft on individual parts of the body should be avoided.

An air conditioner should be individually adjustable. It should be serviced regularly.

The windows should be able to be opened and have sunshades to avoid glare effects. Sunlight can increase the room temperature considerably. Sunshades attached to the outside of the building provide the best protection.

Plants can improve room conditions and are therefore recommended in all cases. They increase the relative humidity and filter pollutants from the air.

22.1.5 Noise Levels

Noise is a physically powerful stress factor. Although it is often played down, too much noise makes you ill. Apart from health impairments, such as defective hearing, vegetative disorders, and psychic changes, noise affects our efficiency by impairing our ability to concentrate. Furthermore, discontent can reduce working motivation. The fact that proper noise abatement can possibly cost a lot of money is also problematic.

A calm working environment improves efficiency. Work at terminal workstations is often characterized as “mental activity”. Therefore the maximum load value for scientific work or programming is 55 dB (A). The dB (A) represent a weighted evaluation of the acoustic pressure. The A-filter curve most resembles human perception. An increase of the sound level by 10 dB (A) is normally perceived as a duplication of volume.

Because mainly mental work is done at terminal workstations, quiet working materials should be used from the start.

The maximum limiting value for office work is 55 dB (A). With especially high mental demands or necessary communication of language, as low as 35–45 dB (A) is required. This is the case, for instance, for specialized work, scientific work, or programming.

Furthermore, the evaluation level of a maximum of 55 dB (A) is important. If 70 dB (A) is measured for a quarter of an hour, the noise in the remaining time should be less than or equal to 55 dB (A).
- Workstations can be equipped with partitions, sound-absorbing floors, appropriately wallpapered walls, curtains, and other sound-reducing features.

- Loud working equipment, such as matrix printers, should be installed in sound-absorbing cases. The permissible noise levels for office equipment are determined in the DIN standards.

- An air conditioner should not increase the normal noise level.

- Strain caused by excessive noise can also be reduced by an organizational restructuring of work.

### 22.2 Office Equipment

#### 22.2.1 Buying a Screen

If you already have poor sharpness of vision, low-quality screens can make things even worse. Apart from eye problems, tenseness, fatigue, and many other disorders can be caused.

The latest technological developments are triniton, or black-matrix, screens and TFT flat screens. Unfortunately, flat screens are still relatively expensive. There are extensive standards that regulate the readability of the depicted information. When buying a screen, it is recommended to study the extensive standards to avoid a wrong purchase. One thing is certain: a good screen is usually expensive. The normal tube screens do not last forever. They only retain their focus and contrast for a few years.

- All depicted characters should be sharply defined and clearly legible up to the edges of the screen. A positive representation (dark characters on a light background, as in a book) is recommended.

- As the depicted characters must be large enough, a 17-inch monitor is recommended, at least for graphical user interfaces (like KDE). For the processing of CAD, layout, and graphics, it should be 21 inches.

- It is especially important that the screen does not flicker. In concrete terms, the minimum sync frequency with 15-inch monitors should be at least 73 Hz. However, 85 Hz is recommended. For larger screens, such as 21-inch, 100 Hz is a good value.
Luminosity and contrast should be variable. The focus of the characters should not differ with adjustments of brightness or contrast.

The image should be free from distortion and show no color errors.

To avoid reflex glare, a good antireflective coating of the screen surface is recommended.

The screen should be rotatable and inclinable. A vertical adjustment is recommended.

Colors make the displayed information easier to comprehend. However, the display of colors can also be straining for the eyes because different colors are refracted differently by the lenses. For red colors, people are farsighted, but for blue colors people are nearsighted. Older screens often have convergence errors — the three beams of the screen tube are no longer aligned precisely, so colored borders appear around letters, for example.

Electromagnetic radiation emitting from the screen should be kept to a minimum.

### 22.2.2 Screen Location

A screen put in the wrong place leads to a cramped posture at work, which can cause illnesses. A work table that has insufficient depth often prevents the screen from being placed reasonably. The natural position of the head and arms is designed for work that lies in front of the body.

Ergonomics specialists have developed their own guidelines for the “vision and gripping area.” These reject placing the screen to the side. An exception is only when the screen is rarely used. A reason for this placement is the fact that even the required minimum 80 cm worktable depth is insufficient with a large screen and the use of working documents. Often the screen is placed — as shown in many PC manual pictures — on top of the computer case. This also leads to an unnatural posture. Observe yourself while you are reading. Are you looking straight ahead or slightly down?

Shoulder, keyboard, and screen should be in one line so you always look directly at the screen. This rule does not necessarily need to be observed all the time.
Ultimately, the workstation should be individually adapted to the person and the working task. Flexibility is the key. Easily movable, rotatable, and, ideally, screens that retract into the table are encouraged.

A comfortable visual distance varies individually. At least 50 cm is required. Some people need considerably more.

It is a good idea for users to look away from the screen from time to time. In this way, their eyes can adapt to a different distance.

If a document is being copied, it should be at the same distance as the screen to avoid frequent changes of focus.

The difference in luminance between the direct working area, the screen, and the immediately surrounding areas, such as the screen case, should not be more than three to one. For this reason, computer cases in offices are not black. The difference between the working area and the surroundings should not be more than ten to one.

Shiny areas create large differences of luminance. This is why office furniture is not available in bright colors and has a matt surface.

To minimize the reflex glare on the screen, the screen and the keyboard should be arranged so the line of vision is parallel to window panes. The further the screen is away from the window, the better.

The screen should not be directly under a lighting strip, but to the side of it. The line of vision should be parallel to the lighting strip.

### 22.2.3 The Keyboard and the Wrists

It is well-known that the keyboard arrangement derived from the typewriter is not necessarily ergonomic. During typing, the fingers, hands, arms, and shoulders are strained. This leads to tense muscles. The strain caused by a keyboard of inferior quality adds up over time. Unfortunately, the tiny movements produced while typing are very difficult to measure. Risk factors include the RSI syndrome.

The keyboard is, without doubt, the most frequently-used computer input device. Therefore, it must be especially well-designed. Ergonomic specialists often criticize the fact that the `Shift` and `Enter` keys are too small. Another basic problem is the cable, which is often too short, preventing a comfortable individual placement. Consider buying a wireless keyboard or an extension for the cable.
The keyboard should be separate from the screen. It should also be inclinable, but set in a stable position (sufficiently large, rubber-coated feet).

The middle key row should not be more than 30 mm above the surface of the table.

There should be room to rest your hands in front of the keyboard. If there is no built-in wrist pad, get one.

The marking must contrast with the color of the plastic and be easy to read. The keyboard should have no intense color and a satin-matt finish.

For the keyboard legend, a dark script on a light background is recommended. Black keys are not ergonomic.

The form of the keys should enable light and accurate typing. The lift of key should be 2–4 mm and the working point should be distinctly felt. Here 50–80 g is recommended as the force of the key depression stroke.

Those who type a lot should take regular breaks.

Learning the touch system helps because the workload is distributed across all fingers.

Split or individually separable keyboards are something to which you have to get accustomed, but nevertheless are an alternative worth considering. They have been constructed according to the latest ergonomic findings and are already recommended in some standards. They prevent wrist strain to the side.

The keyboard of a notebook or laptop cannot correspond to the standards because of the crowded keys. A notebook should therefore not be used as workstation equipment unless it is linked to an external keyboard and mouse.

22.2.4 The Mouse

Due to the advance of graphical user interfaces, users are practically forced to use a mouse. The intensive use of the mouse can cause not only fatigue, but also disorders in the hands, arms, and shoulders. An example of this is RSI. The danger increases when a “bad” mouse is used. So far, there are no commonly accepted standards for an ergonomic mouse. Often a PC is sold with the standard mouse.
This mouse should certainly be examined closely. Is the mouse really suitable or should it be replaced by a better one? Have the dealer unpack several mice for you to try. The cable is probably too short. Ask the dealer to give you an extension. Evaluate your own mouse use. Can you reduce the use of the mouse? Many professional programs with a lot of interaction do without any mouse clicks. Learn how to use shortcuts to operate programs. It takes time to learn, but you can work up to four times as fast. Often a combination of mouse and keyboard operation is recommended.

- The ergonomic mouse feels good in your hand. The keys should not be too close or too small. There are even mice for children’s hands.
- Your fingers should be able to rest on the keys in a relaxed position.
- The mouse should be next to the keyboard. Left-handed users have an advantage because the keyboard has several function keys and the numerical key block between letter keys and a mouse on the right side. These extend the gripping distance. If you are left-handed, get a mouse for left-handers.
- The cable should be long enough. If necessary, purchase an extension. A wireless mouse is a luxury.
- The mouse needs a proper base to function well. Get a good mouse pad.
- Pay attention to the mouse driver. Good mice have mouse drivers with a multitude of functions. You can, for example, adjust the cursor movement exactly according to your requirements or assign special instructions to the different mouse buttons. The double-click might be placed on the middle button with the mouse driver.
- Make sure you adjust the acceleration and double-click adjustment of the mouse to your own preferences. Some people work with the mouse from the hand joint. Others prefer moving their complete forearm.
- An alternative to the mouse is a trackball. Here, you move a ball inside a stationary casing to control the mouse pointer. In contrast to the mouse, the trackball reduces the movements in the hand and arm area.

### 22.3 Links and Literature

A great manual for staff members and superiors with many checklists and questionnaires that also take the mental strain into account: Burmester, M., Görner, C.,

A clear and well-structured guide for analysis and work protection tasks around the terminal workstation:


Information Network of the European Agency for Safety and Health at Work. Available in many languages, comprehensive information: http://europe.osha.eu.int/
Help and Documentation

The SUSE Help Center provides central access to the most important documentation resources on your system in searchable form. These resources include all manuals enclosed with your product, online help for the installed applications, and databases on hardware and software issues in connection with SUSE LINUX.

Using the SUSE Help Center

When you start the SUSE Help Center for the first time from the main menu (‘SuSE Help’), the view as shown in Figure A.1 on the following page is displayed. The dialog window consists of three main areas:

**Menu Bar and Toolbar**  The menu bar provides the main editing, navigation, and configuration options. ‘File’ contains the option for printing the currently displayed content. Under ‘Edit’, access the search function. ‘Go’ contains all navigation possibilities: ‘Home’ (home page of the Help Center), ‘Back’, ‘Forward’, and ‘Last Search Result’. With ‘Settings’ → ‘Configure KDE Help Center’ → ‘Create Search Index’, generate a search index for all selected information sources. The toolbar contains three navigation icons (forward, back, home) and a printer icon for printing the current contents.

**Navigation Area with Tabs**  The navigation area in the left part of the window provides an input field for a quick search in selected information sources. Details regarding the search and the configuration of the search function in the ‘Search’ tab are presented in *The Search Function of the SUSE Help Center* on page 295. The ‘Contents’ tab presents a tree view of all available and currently installed information sources. Click the book icons to open and browse the individual categories.
**View Window** The view window always displays the currently selected contents, such as online manuals, search results, or web pages.

![Figure A.1: The Main Window of the SUSE Help Center](image)

**Contents of the SUSE Help Center**

The SUSE Help Center bundles useful information from various sources. It contains special documentation for SUSE LINUX (User Guide and Administration Guide), all available information sources for your workstation environment, online help for the installed programs, and help texts for other applications. Furthermore, the SUSE Help Center provides access to SUSE’s online databases that
cover special hardware and software issues in connection with SUSE LINUX. All these sources can be searched comfortably once a search index has been generated.

The Search Function of the SUSE Help Center

To search all installed information sources of SUSE LINUX, generate a search index and set a number of search parameters. To do this, open the ‘Search’ tab. See Figure A.2

If no search index was generated previously, the system automatically prompts you to do so when you click the ‘Search’ tab or enter a search string and click ‘Search’. In the dialog window for generating the search index (Figure A.3 on the next page), use the check boxes to determine the information sources to index. The index is generated when you exit the dialog with ‘OK’.

Figure A.2: Configuring the Search Function
To limit the search base and the hit list as precisely as possible, use the three drop-down menus to determine the number of displayed hits and the selection area of sources to search. The following options are available for determining the selection area:

**Default**  A predefined selection of sources is searched.

**All**  All sources are searched.

**None**  No sources selected for the search.

**Custom**  Determine the sources to search by activating the respective check boxes in the overview.

Upon completion of the search configuration, click ‘Search’. The relevant items are then displayed in the view window and can easily be navigated with mouse clicks.
This section provides answers to frequently asked questions.

1. **I am the only person using my computer. Why do I need to log in?**
   
   Linux is a multiuser system. The system relies on user names and passwords to identify different users. If you chose the option ‘auto log-in’ during installation, you are automatically logged in to the system after booting the machine. Only log in as root to make changes to your system (installing software or changing configuration).

2. **Are the SUSE manuals also available as PDF or HTML files?**
   
   Our manuals are included on the CDs and are also available through the SUSE help center. To start the help center, press `Alt`+`F2` and enter the command `susehelp`. The PDF files or HTML versions are available in the packages `suselinux-adminguide_en` and `suselinux-userguide_en`. In the installed system, go to the directory `/usr/share/doc/manual/suselinux-adminguide_en` or `/usr/share/doc/manual/suselinux-userguide_en`.

3. **Where can I get more information about SUSE LINUX?**
   
   Most of the information about the installation and features of SUSE LINUX is provided in the manuals. Documentation for applications is available in `/usr/share/doc/packages` and the HowTos are located in `/usr/share/doc/howto/en`. Read these files with a command like:

   ```
   less /usr/share/doc/howto/en/DOS-to-Linux-HOWTO.txt.gz
   ```

   Terminate the command by pressing `Esc`. 
4. How can I enter commands in KDE?
   Click the screen with shell icon in the panel to start the Bash shell. Select alternative terminals from the main menu. To run a single command, press \( \text{Alt} + F2 \) then enter the command.

5. I cannot find many programs in KDE.
   You can start all programs from a terminal window by entering the program name and pressing \( \text{Enter} \).

6. What is a mirror? Why should I not get these things from ftp.suse.com?
   As there are many users who need to retrieve things from the server at the same time, its capacity limit would be reached very quickly. For this reason, there are a number of other FTP servers that contain a duplicate of the SUSE server. These servers are referred to as mirrors. Select a mirror in your vicinity (same country) to speed up the download. A list of mirror is available at http://www.suse.de/en/support/download/ftp/.

7. I cannot find any .exe files. Where are all the applications?
   In Linux, executable files normally do not have file extensions. Most programs are located in /usr/bin and /usr/X11R6/bin.

8. How can I recognize executable files?
   The command \( \text{ls -l} \) returns all executable files in the directory /usr/bin in green. Also recognize them by the x in the first column.

   \[ -rwxr-xr-x 1 root root 64412 Jul 23 15:23 /usr/bin/ftp \]

9. I want to remove Linux. How does this work?
   With fdisk, delete the Linux partitions. You might need to run fdisk in Linux. Afterwards, boot from the MS-DOS disk and run fdisk /MBR in DOS or Windows.

10. How can I access my CD?
    First mount the CD with the \texttt{mount} command. Information about this command can be found in \texttt{mount} on page\textcolor{red}{275}
11. I cannot get my CD out of the drive. What should I do now?
First, unmount the CD with the `umount` command. More information about this can be found in `umount` on page 275. In KDE, just right-click the CD-ROM icon and select ‘Unmount Drive’. If YaST is running on your computer, exit it.

12. How can I find out how much space is available in Linux?
With the `df -hT` command. See `df` on page 276.

13. Can I copy and paste in Linux?
Yes, this is possible. Highlight the text block by clicking and dragging with the left mouse button then insert by clicking with the middle mouse button. The right mouse button has a special function in most programs and applications.

14. Do I need to be afraid of a virus in Linux?
In Linux, there have been no serious viruses found. Also, viruses cannot cause any serious damage if they are not activated by root. The only virus scanners available in Linux search e-mails for Windows viruses (if Linux is used as a router or server). Nevertheless, you should back up important data and configurations.

15. Do I need to compile a kernel myself?
No, this is usually unnecessary. The kernel has become so large that there are about eight hundred options to consider during the configuration. Because it is almost impossible to master all possible configurations and their effects, it is strongly discouraged for inexperienced users to recompile the kernel. Do so only at your own risk. In cases of custom compiled kernels, SUSE cannot provide any installation support.

16. Where can I see the system messages?
In a terminal window, enter `tail -f /var/log/messages` as `root`. Additional interesting programs relating to this one are `top`, `procinfo`, and `xosview`. Use the command `less /var/log/boot.msg` to view the boot messages.

17. I cannot log in to my computer with `telnet`. I always get the answer `Login incorrect`.
You are probably trying to log in as `root`. For security reasons, this is not possible via `telnet` by default. With YaST, set up a normal user account. Log
in with this user name. Then change to the user root with su. It is much better and safer, however, to use the program ssh instead of telnet. The ssh program uses encrypted, secure connections.

18. **How do I connect to the Internet in Linux?**

   [KInternet — Connecting to the Internet](#) on page 24 provides information about this.

19. **I found a bug in SUSE LINUX. Where should I report it?**

   First, ascertain whether it is actually a bug in the program or just an error in operation or faulty configuration settings. Also read the documentation in /usr/share/doc/packages and /usr/share/doc/howto. The bug may have already been discovered. Check in the support database at http://sdb.suse.de/sdb/en/html/. Enter a keyword or work your way forward or backward via the History link. If it really is a bug, send a description of it by e-mail to feedback@suse.de.

20. **How can I install applications?**

   Applications included in the SUSE LINUX CDs are best installed with YaST.

21. **I only have an application in source code. How can I install it?**

   Some know-how is required with some applications. Find more information in a good Linux book.

   Here is a brief description: Decompress the archive with `tar xvzf name.tar.gz`, read the INSTALL or README files, and follow the instructions. Usually, the following command sequence needs to be executed:
   ```bash
   ./configure;make;make install
   ```
   No installation support is available for the compilation or self-compiled programs.

22. **Is my hardware supported?**

   It is best to refer to the component database at http://hardwaredb.suse.de or http://cdb.suse.de.less /usr/share/doc/howto/en/Hardware-HOWTO.gz can also provide some information.

23. **How can I defragment my hard disk?**

   Linux has an intelligent file system. This file system makes defragmentation superfluous, because it prevents fragmentation. Make sure that you do not use more than ninety percent of each partition. Use `df -h` to view information about used and available hard disk space.
24. What is meant by partitioning?

Partitioning is dividing the hard disk into smaller sections. For the default configuration, SUSE LINUX requires at least two partitions (one for Linux itself and one swap partition for the virtual main memory).

25. How much space do I need for Linux?

This depends on how many and which packages you want to install. A standard installation with office applications requires about 1 GB. 2 GB is recommended if you want space for your own data as well. To install just about everything, you need 3–6 GB, depending on the version.

26. I need more space for Linux. How can I add another hard disk?

To make more space available, integrate a new hard disk or parts of it (partitions) into your Linux system at any time. For example, if it turns out that you need more space in /opt, mount an additional hard disk partition to this directory. To do so, follow this procedure:

(a) Install your hard disk following the instructions of the manufacturer then start Linux.
(b) Log in as the root user.
(c) Partition the new hard disk with fdisk. For further information, refer to the manual page of fdisk with man fdisk.
(d) Format the partition with mke2fs /dev/hdb1.
(e) Enter the following commands:

   cd /opt
   mkdir /opt2
   mount /dev/hdb1 /opt2
   cp -axv . /opt2

   Check thoroughly to see whether all the data has been copied. Afterwards, move the old directory and add a new one — an empty mount point:

   mv /opt /opt.old
   mkdir /opt

   Use an editor to add the new partitions in /etc/fstab. This could resemble the line in File B.1.

   Example B.1: Sample Line in /etc/fstab for an Additional Partition
   /dev/hdb1 /opt ext2 defaults 1 2
Now, shut down the computer and reboot.

(f) After rebooting, check that `/dev/hdb1` has actually been mounted to `/opt` using the command `mount`. If everything is working as desired, remove the old data from `/opt.old`:

```bash
cd /
rm -fr opt.old
```

27. **My computer crashed. Can I just press the reset button without risking anything?**

If your computer no longer reacts to your mouse or keyboard, this does not necessarily mean that your entire system has crashed. Possibly one program is blocking the mouse or the keyboard, but all other programs are still running. If your machine can be accessed remotely (serial terminal, network), log in elsewhere and abort the respective program with `killall ⟨program name⟩`. If this does not work, try `killall -9 ⟨program name⟩`.

If this is not possible, try switching to another console using `Ctrl+Alt+F2` to kill the faulty process from there. If the computer does not respond to any of the keys and network intervention is not possible, wait at least ten seconds before pressing reset to make sure there is no hard disk activity.

28. **How can I switch from a virtual text console to the graphical user interface?**

By default, there are six virtual text consoles that can be accessed with `Ctrl+Alt+F1` to `F6`. Press `Alt+F7` to go to the graphical user interface.
### Index

#### A
- access permissions ........................................... 265-269
  - chmod .................................................. 272
  - file systems ........................................... 265
- address management ........................................ see KAddressBook
- alevt .......................................................... 210
- alsamixer ..................................................... 178
- amarok ....................................................... 181

#### B
- Bash .............................................................. 256-264
  - commands ................................................ 256
  - functions ............................................... 259
  - pipes ...................................................... 262
  - wild cards .............................................. 261
- browsers ..................................................... see web browsers
- bugs ........................................................... 200
  - reporting ................................................. 200

#### C
- calendars ....................................................... 152-157
  - Evolution ............................................... 152-157
  - CapiSuite ................................................. 161-172
- cat ............................................................... 274
- cd ................................................................. 272
- CDs ............................................................... 219
  - audio
    - creating .............................................. 218
  - burning .................................................. 215-220
  - copying .................................................. 219
  - data
    - creating .............................................. 216
    - ISO images ........................................... 220
- clear ............................................................ 278
  - players ..................................................... 185
  - Workman ................................................ 185
- chgrp ........................................................... 267-272
- chmod .......................................................... 267-272
- chown ........................................................... 267-272
- cp ................................................................. 271
- date .............................................................. 276
- df ................................................................. 276
- diff .............................................................. 275
- du ................................................................. 276
- find .............................................................. 274
- free .............................................................. 276
- grep .............................................................. 275
- gzip .............................................................. 263-273
- halt .............................................................. 278
- help .............................................................. 256
- kate .............................................................. 82
- kill .............................................................. 277
- killall ............................................................ 277
- kwrite ............................................................ 78
- less .............................................................. 274
- ln ................................................................. 272
- locate ............................................................ 274
- locate ............................................................ 274
<table>
<thead>
<tr>
<th>Index</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>- ls</td>
<td>271</td>
</tr>
<tr>
<td>- man</td>
<td>270</td>
</tr>
<tr>
<td>- mkdir</td>
<td>272</td>
</tr>
<tr>
<td>- mount</td>
<td>273</td>
</tr>
<tr>
<td>- mv</td>
<td>271</td>
</tr>
<tr>
<td>- nslookup</td>
<td>277</td>
</tr>
<tr>
<td>- passwd</td>
<td>278</td>
</tr>
<tr>
<td>- ping</td>
<td>277</td>
</tr>
<tr>
<td>- ps</td>
<td>277</td>
</tr>
<tr>
<td>- reboot</td>
<td>278</td>
</tr>
<tr>
<td>- rm</td>
<td>272</td>
</tr>
<tr>
<td>- rmdir</td>
<td>272</td>
</tr>
<tr>
<td>- su</td>
<td>278</td>
</tr>
<tr>
<td>- tar</td>
<td>263, 273</td>
</tr>
<tr>
<td>- telnet</td>
<td>277</td>
</tr>
<tr>
<td>- top</td>
<td>276</td>
</tr>
<tr>
<td>- umount</td>
<td>275</td>
</tr>
<tr>
<td>- updatedb</td>
<td>274</td>
</tr>
<tr>
<td>configuration files</td>
<td></td>
</tr>
<tr>
<td>- fstab</td>
<td>275, 301</td>
</tr>
<tr>
<td>cp</td>
<td>271</td>
</tr>
<tr>
<td>crashes</td>
<td>302</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>D</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>date</td>
<td>276</td>
</tr>
<tr>
<td>desktop sharing</td>
<td>32</td>
</tr>
<tr>
<td>df</td>
<td>276</td>
</tr>
<tr>
<td>dictionaries</td>
<td></td>
</tr>
<tr>
<td>- GNOME</td>
<td>51</td>
</tr>
<tr>
<td>diff</td>
<td>275</td>
</tr>
<tr>
<td>digital cameras</td>
<td>221</td>
</tr>
<tr>
<td>- connecting</td>
<td>222</td>
</tr>
<tr>
<td>- gtKam</td>
<td>223</td>
</tr>
<tr>
<td>- Konqueror</td>
<td>222</td>
</tr>
<tr>
<td>directories</td>
<td></td>
</tr>
<tr>
<td>- changing</td>
<td>272</td>
</tr>
<tr>
<td>- creating</td>
<td>272</td>
</tr>
<tr>
<td>- deleting</td>
<td>272</td>
</tr>
<tr>
<td>- navigating</td>
<td>260</td>
</tr>
<tr>
<td>- paths</td>
<td>260</td>
</tr>
<tr>
<td>- structure</td>
<td>256</td>
</tr>
<tr>
<td>disks</td>
<td></td>
</tr>
<tr>
<td>- formatting</td>
<td>30</td>
</tr>
<tr>
<td>download manager</td>
<td>26</td>
</tr>
<tr>
<td>drives</td>
<td></td>
</tr>
<tr>
<td>- mounting</td>
<td>275</td>
</tr>
<tr>
<td>- unmounting</td>
<td>275</td>
</tr>
<tr>
<td>du</td>
<td>276</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>E</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>e-mail applications</td>
<td></td>
</tr>
<tr>
<td>- Evolution</td>
<td>149-160</td>
</tr>
<tr>
<td>- KMail</td>
<td>183-146</td>
</tr>
<tr>
<td>editors</td>
<td></td>
</tr>
<tr>
<td>- Kate</td>
<td>32</td>
</tr>
<tr>
<td>- KWrite</td>
<td>27</td>
</tr>
<tr>
<td>- vi</td>
<td>278</td>
</tr>
<tr>
<td>encryption</td>
<td>123-131</td>
</tr>
<tr>
<td>ergonomics</td>
<td>281-292</td>
</tr>
<tr>
<td>Evolution</td>
<td>149-160</td>
</tr>
<tr>
<td>- address books</td>
<td>158</td>
</tr>
<tr>
<td>- attachments</td>
<td>153</td>
</tr>
<tr>
<td>- calendar</td>
<td>152, 157</td>
</tr>
<tr>
<td>- configuring</td>
<td>150</td>
</tr>
<tr>
<td>- contacts</td>
<td>152, 158</td>
</tr>
<tr>
<td>- creating messages</td>
<td>153</td>
</tr>
<tr>
<td>- encryption</td>
<td>154</td>
</tr>
<tr>
<td>- filters</td>
<td>155</td>
</tr>
<tr>
<td>- folders</td>
<td>154</td>
</tr>
<tr>
<td>- importing mail</td>
<td>150</td>
</tr>
<tr>
<td>- signing</td>
<td>154</td>
</tr>
<tr>
<td>- starting</td>
<td>150</td>
</tr>
<tr>
<td>- virtual folders</td>
<td>156</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>F</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>FAQ</td>
<td>297</td>
</tr>
<tr>
<td>file managers</td>
<td></td>
</tr>
<tr>
<td>- Konqueror</td>
<td>20-24</td>
</tr>
<tr>
<td>files</td>
<td></td>
</tr>
<tr>
<td>- .exe</td>
<td>298</td>
</tr>
<tr>
<td>- archiving</td>
<td>263, 273</td>
</tr>
<tr>
<td>- comparing</td>
<td>275</td>
</tr>
<tr>
<td>- compressing</td>
<td>263, 273</td>
</tr>
<tr>
<td>- converting from Microsoft formats</td>
<td>60</td>
</tr>
<tr>
<td>- copying</td>
<td>271</td>
</tr>
<tr>
<td>- deleting</td>
<td>272</td>
</tr>
<tr>
<td>- formats</td>
<td></td>
</tr>
<tr>
<td>· GIF</td>
<td>241</td>
</tr>
<tr>
<td>· JPG</td>
<td>241</td>
</tr>
<tr>
<td>· PAT</td>
<td>241</td>
</tr>
<tr>
<td>· PNG</td>
<td>241</td>
</tr>
<tr>
<td>· XCF</td>
<td>241</td>
</tr>
<tr>
<td>- moving</td>
<td>271</td>
</tr>
<tr>
<td>- paths</td>
<td>260</td>
</tr>
<tr>
<td>- searching contents</td>
<td>275</td>
</tr>
<tr>
<td>- searching for</td>
<td>274</td>
</tr>
<tr>
<td>- shell</td>
<td>259</td>
</tr>
<tr>
<td>- uncompressing</td>
<td>264</td>
</tr>
<tr>
<td>- viewing</td>
<td>262, 274</td>
</tr>
</tbody>
</table>

find | 274 |
<table>
<thead>
<tr>
<th>G</th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>fonts</td>
<td></td>
<td>38</td>
</tr>
<tr>
<td></td>
<td>formatting</td>
<td></td>
<td>235–251</td>
</tr>
<tr>
<td></td>
<td>free</td>
<td></td>
<td>276</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>G</th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>GNOME</td>
<td></td>
<td>42–44</td>
</tr>
<tr>
<td></td>
<td>GIMP</td>
<td></td>
<td>235–251</td>
</tr>
<tr>
<td></td>
<td>gamix</td>
<td></td>
<td>177</td>
</tr>
<tr>
<td></td>
<td>Galeon</td>
<td></td>
<td>111–114</td>
</tr>
<tr>
<td></td>
<td>configuring</td>
<td></td>
<td>113</td>
</tr>
<tr>
<td></td>
<td>GIMP</td>
<td>colors</td>
<td>245</td>
</tr>
<tr>
<td></td>
<td></td>
<td>configuring</td>
<td>245</td>
</tr>
<tr>
<td></td>
<td></td>
<td>creating images</td>
<td>245</td>
</tr>
<tr>
<td></td>
<td></td>
<td>cropping</td>
<td>245</td>
</tr>
<tr>
<td></td>
<td></td>
<td>editing images</td>
<td>245</td>
</tr>
<tr>
<td></td>
<td></td>
<td>effects</td>
<td>245</td>
</tr>
<tr>
<td></td>
<td></td>
<td>image modes</td>
<td>245</td>
</tr>
<tr>
<td></td>
<td></td>
<td>layers</td>
<td>245</td>
</tr>
<tr>
<td></td>
<td></td>
<td>levels</td>
<td>245</td>
</tr>
<tr>
<td></td>
<td></td>
<td>opening images</td>
<td>245</td>
</tr>
<tr>
<td></td>
<td></td>
<td>printing</td>
<td>245</td>
</tr>
<tr>
<td></td>
<td></td>
<td>retouching images</td>
<td>245</td>
</tr>
<tr>
<td></td>
<td></td>
<td>saving images</td>
<td>245</td>
</tr>
<tr>
<td></td>
<td></td>
<td>scaling images</td>
<td>245</td>
</tr>
<tr>
<td></td>
<td></td>
<td>selecting</td>
<td>245</td>
</tr>
<tr>
<td></td>
<td></td>
<td>starting</td>
<td>245</td>
</tr>
<tr>
<td></td>
<td></td>
<td>templates</td>
<td>245</td>
</tr>
<tr>
<td></td>
<td></td>
<td>text</td>
<td>245</td>
</tr>
<tr>
<td></td>
<td></td>
<td>undo</td>
<td>245</td>
</tr>
<tr>
<td></td>
<td></td>
<td>views</td>
<td>245</td>
</tr>
<tr>
<td></td>
<td>GNOME</td>
<td>applets</td>
<td>185</td>
</tr>
<tr>
<td></td>
<td></td>
<td>CD player</td>
<td>185</td>
</tr>
<tr>
<td></td>
<td></td>
<td>mixer</td>
<td>185</td>
</tr>
<tr>
<td></td>
<td></td>
<td>CDs</td>
<td>185</td>
</tr>
<tr>
<td></td>
<td></td>
<td>configuring</td>
<td>185</td>
</tr>
<tr>
<td></td>
<td></td>
<td>accessibility</td>
<td>185</td>
</tr>
<tr>
<td></td>
<td></td>
<td>background</td>
<td>185</td>
</tr>
<tr>
<td></td>
<td></td>
<td>fonts</td>
<td>185</td>
</tr>
<tr>
<td></td>
<td></td>
<td>keyboard</td>
<td>185</td>
</tr>
<tr>
<td></td>
<td></td>
<td>keyboard shortcuts</td>
<td>185</td>
</tr>
<tr>
<td></td>
<td></td>
<td>menus</td>
<td>185</td>
</tr>
<tr>
<td></td>
<td></td>
<td>mouse</td>
<td>185</td>
</tr>
<tr>
<td></td>
<td></td>
<td>screensaver</td>
<td>185</td>
</tr>
<tr>
<td></td>
<td></td>
<td>system alerts</td>
<td>185</td>
</tr>
<tr>
<td></td>
<td></td>
<td>themes</td>
<td>185</td>
</tr>
<tr>
<td></td>
<td></td>
<td>toolbars</td>
<td>185</td>
</tr>
<tr>
<td></td>
<td></td>
<td>windows</td>
<td>185</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>H</th>
<th></th>
<th></th>
<th>42</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>halt</td>
<td></td>
<td>278</td>
</tr>
<tr>
<td></td>
<td>hard disks</td>
<td></td>
<td>301</td>
</tr>
<tr>
<td></td>
<td></td>
<td>adding</td>
<td>301</td>
</tr>
<tr>
<td></td>
<td></td>
<td>defragmenting</td>
<td>301</td>
</tr>
<tr>
<td></td>
<td>hardware</td>
<td></td>
<td>300</td>
</tr>
<tr>
<td></td>
<td></td>
<td>support</td>
<td>300</td>
</tr>
<tr>
<td></td>
<td>help</td>
<td></td>
<td>293–296</td>
</tr>
<tr>
<td></td>
<td></td>
<td>FAQ</td>
<td>297</td>
</tr>
<tr>
<td></td>
<td></td>
<td>man pages</td>
<td>270</td>
</tr>
<tr>
<td></td>
<td></td>
<td>OpenOffice.org</td>
<td>59</td>
</tr>
<tr>
<td></td>
<td></td>
<td>SUSE Help Center</td>
<td>293</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>I</th>
<th></th>
<th></th>
<th>24</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Internet</td>
<td></td>
<td>24</td>
</tr>
<tr>
<td></td>
<td></td>
<td>connections</td>
<td>24</td>
</tr>
<tr>
<td></td>
<td>ISDN</td>
<td></td>
<td>161</td>
</tr>
<tr>
<td></td>
<td></td>
<td>basics</td>
<td>162</td>
</tr>
<tr>
<td></td>
<td></td>
<td>configuring an answering machine</td>
<td>165</td>
</tr>
<tr>
<td></td>
<td></td>
<td>fax services</td>
<td>165</td>
</tr>
<tr>
<td></td>
<td></td>
<td>operating an answering machine</td>
<td>171</td>
</tr>
<tr>
<td>Index</td>
<td>Page</td>
<td></td>
<td></td>
</tr>
<tr>
<td>-------</td>
<td>------</td>
<td></td>
<td></td>
</tr>
<tr>
<td>.lexi</td>
<td>306</td>
<td></td>
<td></td>
</tr>
<tr>
<td>keyboard</td>
<td>289</td>
<td></td>
<td></td>
</tr>
<tr>
<td>KAddressBook</td>
<td>99–103</td>
<td></td>
<td></td>
</tr>
<tr>
<td>K3b</td>
<td>215–220</td>
<td></td>
<td></td>
</tr>
<tr>
<td>JavaScript</td>
<td>110</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Java</td>
<td>110</td>
<td></td>
<td></td>
</tr>
<tr>
<td>KDE</td>
<td>82</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ark</td>
<td>30</td>
<td></td>
<td></td>
</tr>
<tr>
<td>konqueror</td>
<td>108–110</td>
<td></td>
<td></td>
</tr>
<tr>
<td>KMail</td>
<td>133–146</td>
<td></td>
<td></td>
</tr>
<tr>
<td>KGpg</td>
<td>123</td>
<td></td>
<td></td>
</tr>
<tr>
<td>KGet</td>
<td>26</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Killing</td>
<td>277</td>
<td></td>
<td></td>
</tr>
<tr>
<td>KInternet</td>
<td>24–25</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Kmix</td>
<td>178</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Kooka</td>
<td>227–233</td>
<td></td>
<td></td>
</tr>
<tr>
<td>kill</td>
<td>277</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Kill all</td>
<td>277</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Kopete</td>
<td>35</td>
<td></td>
<td></td>
</tr>
<tr>
<td>KMail</td>
<td>133–146</td>
<td></td>
<td></td>
</tr>
<tr>
<td>KMail</td>
<td>133–146</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Kmail</td>
<td>133–146</td>
<td></td>
<td></td>
</tr>
<tr>
<td>KGet</td>
<td>26</td>
<td></td>
<td></td>
</tr>
<tr>
<td>KGpg</td>
<td>123</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- configuring</td>
<td>298</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- clipboard encryption</td>
<td>129</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- dragging and dropping</td>
<td>129</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- editor</td>
<td>130</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- exporting public keys</td>
<td>124</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- file encryption</td>
<td>129</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- generating a key pair</td>
<td>124</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- importing keys</td>
<td>126</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- key servers</td>
<td>127</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- exporting keys</td>
<td>128</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- importing a key</td>
<td>127</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- signing keys</td>
<td>126</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- text encryption</td>
<td>129</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- trusting keys</td>
<td>127</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Kill</td>
<td>277</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Kill all</td>
<td>277</td>
<td></td>
<td></td>
</tr>
<tr>
<td>KInternet</td>
<td>24–25</td>
<td></td>
<td></td>
</tr>
<tr>
<td>KMail</td>
<td>133–146</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- address book</td>
<td>141</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- attachments</td>
<td>139</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- configuring</td>
<td>136</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- decrypting messages</td>
<td>146</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- encrypting messages</td>
<td>145</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- filters</td>
<td>141–143</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- folders</td>
<td>139</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- GnuPG</td>
<td>145</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- identities</td>
<td>135</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- message status</td>
<td>138</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- PGP</td>
<td>145</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- signing messages</td>
<td>145</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- spam filtering</td>
<td>143</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- writing messages</td>
<td>138</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Konqueror</td>
<td>109</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- bookmarks</td>
<td>109</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- digital cameras</td>
<td>222</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- file manager</td>
<td>20–24</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- image galleries</td>
<td>24</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- Java</td>
<td>110</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- JavaScript</td>
<td>110</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- keywords</td>
<td>109</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- saving web pages</td>
<td>109</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- web browser</td>
<td>108–110</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Kooka</td>
<td>227–233</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- character recognition</td>
<td>232–233</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- configuring</td>
<td>230</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- gallery</td>
<td>231</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- preview</td>
<td>228</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- scanning</td>
<td>228–229</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Command</td>
<td>Page(s)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>-----------------</td>
<td>---------</td>
<td></td>
<td></td>
</tr>
<tr>
<td>mkdir</td>
<td>259, 272</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ls</td>
<td>256, 271</td>
<td></td>
<td></td>
</tr>
<tr>
<td>man pages</td>
<td>270</td>
<td></td>
<td></td>
</tr>
<tr>
<td>mirrors</td>
<td>298</td>
<td></td>
<td></td>
</tr>
<tr>
<td>mkdir</td>
<td>259, 272</td>
<td></td>
<td></td>
</tr>
<tr>
<td>moniters</td>
<td>287</td>
<td></td>
<td></td>
</tr>
<tr>
<td>more</td>
<td>262</td>
<td></td>
<td></td>
</tr>
<tr>
<td>motv</td>
<td>208, 210</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- audio</td>
<td>209</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- launchers</td>
<td>209</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- proportions</td>
<td>209</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- seeking</td>
<td>208</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- video source</td>
<td>208</td>
<td></td>
<td></td>
</tr>
<tr>
<td>mount</td>
<td>275</td>
<td></td>
<td></td>
</tr>
<tr>
<td>mouse</td>
<td>275</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- buying</td>
<td>290</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mozilla</td>
<td>115</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- configuring</td>
<td>120</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- security</td>
<td>121</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MS-DOS</td>
<td>264</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- commands</td>
<td>264</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- file systems</td>
<td>264</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Nautilus</td>
<td>49, 51</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- configuring</td>
<td>51</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- navigating</td>
<td>49</td>
<td></td>
<td></td>
</tr>
<tr>
<td>NoteEdit</td>
<td>205</td>
<td></td>
<td></td>
</tr>
<tr>
<td>nslookup</td>
<td>277</td>
<td></td>
<td></td>
</tr>
<tr>
<td>nxtep</td>
<td>211</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- filters</td>
<td>211</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- importing database</td>
<td>211</td>
<td></td>
<td></td>
</tr>
<tr>
<td>office programs</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- KAddressBook</td>
<td>99</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- KOrganizer</td>
<td>91</td>
<td></td>
<td></td>
</tr>
<tr>
<td>OpenOffice.org</td>
<td>57, 74</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- application modules</td>
<td>58</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- AutoPilot</td>
<td>63</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- Calc</td>
<td>68, 73</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- charts</td>
<td>71</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- importing spreadsheet tables</td>
<td>72</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- configuring</td>
<td>61, 63</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- Draw</td>
<td>73</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- graphics</td>
<td>68</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- help</td>
<td>59</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- Impress</td>
<td>74</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- Microsoft document formats</td>
<td>60</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- Navigator</td>
<td>64</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- presentations</td>
<td>74</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- selecting text</td>
<td>64</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- spreadsheet</td>
<td>68, 73</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- Stylist</td>
<td>65</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- tables</td>
<td>67</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- Writer</td>
<td>63, 68</td>
<td></td>
<td></td>
</tr>
<tr>
<td>partitions</td>
<td>301</td>
<td></td>
<td></td>
</tr>
<tr>
<td>passwd</td>
<td>278</td>
<td></td>
<td></td>
</tr>
<tr>
<td>passwords</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- changing</td>
<td>278</td>
<td></td>
<td></td>
</tr>
<tr>
<td>paths</td>
<td>260</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- absolute</td>
<td>260</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- relative</td>
<td>260</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- working with</td>
<td>260</td>
<td></td>
<td></td>
</tr>
<tr>
<td>permissions</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- access control lists</td>
<td>269</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- changing</td>
<td>267</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Category</td>
<td>Pages</td>
<td></td>
<td></td>
</tr>
<tr>
<td>----------</td>
<td>-------</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ping</td>
<td>277</td>
<td></td>
<td></td>
</tr>
<tr>
<td>printing</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- GIMP</td>
<td>249</td>
<td></td>
<td></td>
</tr>
<tr>
<td>processes</td>
<td>276</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- killing</td>
<td>277</td>
<td></td>
<td></td>
</tr>
<tr>
<td>overview</td>
<td>277</td>
<td></td>
<td></td>
</tr>
<tr>
<td>programs</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- installing</td>
<td>300</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ps</td>
<td>277</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Q</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>qamix</td>
<td>177</td>
<td></td>
<td></td>
</tr>
<tr>
<td>R</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>reboot</td>
<td>278</td>
<td></td>
<td></td>
</tr>
<tr>
<td>rm</td>
<td>272</td>
<td></td>
<td></td>
</tr>
<tr>
<td>rmdir</td>
<td>272</td>
<td></td>
<td></td>
</tr>
<tr>
<td>S</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>scanning</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- character recognition</td>
<td>232, 233</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- Kooka</td>
<td>227, 233</td>
<td></td>
<td></td>
</tr>
<tr>
<td>scheduling</td>
<td>see KOrganizer</td>
<td></td>
<td></td>
</tr>
<tr>
<td>screenshots</td>
<td>see KSnapshot</td>
<td></td>
<td></td>
</tr>
<tr>
<td>shells</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- Bash</td>
<td>255</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- commands</td>
<td>270, 278</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- paths</td>
<td>260</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- pipes</td>
<td>262</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- wild cards</td>
<td>261</td>
<td></td>
<td></td>
</tr>
<tr>
<td>shortcuts</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- advantages of</td>
<td>291</td>
<td></td>
<td></td>
</tr>
<tr>
<td>sound</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- mixers</td>
<td>176</td>
<td></td>
<td></td>
</tr>
<tr>
<td>· alsamixer</td>
<td>178</td>
<td></td>
<td></td>
</tr>
<tr>
<td>· gamix</td>
<td>177</td>
<td></td>
<td></td>
</tr>
<tr>
<td>· GNOME</td>
<td>178</td>
<td></td>
<td></td>
</tr>
<tr>
<td>· KMix</td>
<td>178</td>
<td></td>
<td></td>
</tr>
<tr>
<td>· qamix</td>
<td>177</td>
<td></td>
<td></td>
</tr>
<tr>
<td>· NoteEdit</td>
<td>205</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- players</td>
<td>181, 185</td>
<td></td>
<td></td>
</tr>
<tr>
<td>· amaroK</td>
<td>181</td>
<td></td>
<td></td>
</tr>
<tr>
<td>· GNOME</td>
<td>185</td>
<td></td>
<td></td>
</tr>
<tr>
<td>· kscd</td>
<td>185</td>
<td></td>
<td></td>
</tr>
<tr>
<td>· XMMS</td>
<td>184</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- WorkMan</td>
<td>185</td>
<td></td>
<td></td>
</tr>
<tr>
<td>spam</td>
<td>143</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ssh</td>
<td>299</td>
<td></td>
<td></td>
</tr>
<tr>
<td>su</td>
<td>278</td>
<td></td>
<td></td>
</tr>
<tr>
<td>SuSEWatcher</td>
<td>27</td>
<td></td>
<td></td>
</tr>
<tr>
<td>system</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- rebooting</td>
<td>278</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- shutdown</td>
<td>278</td>
<td></td>
<td></td>
</tr>
<tr>
<td>system messages</td>
<td>299</td>
<td></td>
<td></td>
</tr>
<tr>
<td>T</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>tar</td>
<td>263, 273</td>
<td></td>
<td></td>
</tr>
<tr>
<td>telnet</td>
<td>277, 299</td>
<td></td>
<td></td>
</tr>
<tr>
<td>top</td>
<td>276</td>
<td></td>
<td></td>
</tr>
<tr>
<td>TV</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- alevt</td>
<td>210</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- EPG</td>
<td>211</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- motv</td>
<td>208, 210</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- nxtvepg</td>
<td>211</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- teletext</td>
<td>210</td>
<td></td>
<td></td>
</tr>
<tr>
<td>U</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>umount</td>
<td>275</td>
<td></td>
<td></td>
</tr>
<tr>
<td>updatedb</td>
<td>274</td>
<td></td>
<td></td>
</tr>
<tr>
<td>USB</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- digital cameras</td>
<td>222</td>
<td></td>
<td></td>
</tr>
<tr>
<td>V</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>vi</td>
<td>278</td>
<td></td>
<td></td>
</tr>
<tr>
<td>virtual consoles</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- navigating</td>
<td>256</td>
<td></td>
<td></td>
</tr>
<tr>
<td>W</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>web browsers</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- Galeon</td>
<td>111, 114</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- Konqueror</td>
<td>108, 110</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- Mozilla</td>
<td>115</td>
<td></td>
<td></td>
</tr>
<tr>
<td>web pages</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- archiving</td>
<td>109</td>
<td></td>
<td></td>
</tr>
<tr>
<td>webcams</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- gqcam</td>
<td>212</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- motv</td>
<td>240</td>
<td></td>
<td></td>
</tr>
<tr>
<td>wild cards</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>XMMS</td>
<td>184</td>
<td></td>
<td></td>
</tr>
<tr>
<td>· WorkMan</td>
<td>185</td>
<td></td>
<td></td>
</tr>
<tr>
<td>spam</td>
<td>143</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ssh</td>
<td>299</td>
<td></td>
<td></td>
</tr>
<tr>
<td>su</td>
<td>278</td>
<td></td>
<td></td>
</tr>
<tr>
<td>SuSEWatcher</td>
<td>27</td>
<td></td>
<td></td>
</tr>
<tr>
<td>system</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- rebooting</td>
<td>278</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- shutdown</td>
<td>278</td>
<td></td>
<td></td>
</tr>
<tr>
<td>system messages</td>
<td>299</td>
<td></td>
<td></td>
</tr>
<tr>
<td>T</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>tar</td>
<td>263, 273</td>
<td></td>
<td></td>
</tr>
<tr>
<td>telnet</td>
<td>277, 299</td>
<td></td>
<td></td>
</tr>
<tr>
<td>top</td>
<td>276</td>
<td></td>
<td></td>
</tr>
<tr>
<td>TV</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- alevt</td>
<td>210</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- EPG</td>
<td>211</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- motv</td>
<td>208, 210</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- nxtvepg</td>
<td>211</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- teletext</td>
<td>210</td>
<td></td>
<td></td>
</tr>
<tr>
<td>U</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>umount</td>
<td>275</td>
<td></td>
<td></td>
</tr>
<tr>
<td>updatedb</td>
<td>274</td>
<td></td>
<td></td>
</tr>
<tr>
<td>USB</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- digital cameras</td>
<td>222</td>
<td></td>
<td></td>
</tr>
<tr>
<td>V</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>vi</td>
<td>278</td>
<td></td>
<td></td>
</tr>
<tr>
<td>virtual consoles</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- navigating</td>
<td>256</td>
<td></td>
<td></td>
</tr>
<tr>
<td>W</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>web browsers</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- Galeon</td>
<td>111, 114</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- Konqueror</td>
<td>108, 110</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- Mozilla</td>
<td>115</td>
<td></td>
<td></td>
</tr>
<tr>
<td>web pages</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- archiving</td>
<td>109</td>
<td></td>
<td></td>
</tr>
<tr>
<td>webcams</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- gqcam</td>
<td>212</td>
<td></td>
<td></td>
</tr>
<tr>
<td>- motv</td>
<td>240</td>
<td></td>
<td></td>
</tr>
<tr>
<td>wild cards</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>XMMS</td>
<td>184</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>