3.3 Selecting a Java Development Kit

As listed in Section 2.1, Vibe Server Requirements, you need to install a Java Development Kit (JDK) before you install Novell Vibe. You can use either the Sun JDK or the IBM JDK for the platform where you are installing Vibe (Linux or Windows).

If you want to use an SSL connection between your Novell Vibe site and a WebDAV server, and if the WebDAV server has a self-signed certificate rather than a certificate provided by a certificate authority, you must use the Sun JDK. The existing Vibe functionality for handling self-signed certificates is not compatible with the way the IBM JDK handles self-signed certificates.


Under Java Development Kit, mark the JDK that you want to use with Vibe.

You must install the JDK on the Vibe server before you install the Vibe software. If you are not familiar with installing a JDK, see Java Development Kit in Section A.0, Vibe System Requirements Assistance for instructions.


Under Java Development Kit, specify the directory where you have installed the JDK.

The Vibe Installation program uses this path as if you had set the JAVA_HOME environment variable. The path is stored for future reference in the installer.xml file so that you need to specify the path to the JDK only once.