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About This Guide

This guide contains information that will help you understand and use the 
Novell® ZENworks® for Desktops 4 Preboot Services Menu Editor utility.

Documentation Conventions
In Novell documentation, a greater than symbol (>) is used to separate actions 
within a step and items in a cross-reference path.

A trademark symbol (®, TM, etc.) denotes a Novell trademark. An asterisk (*) 
denotes a third-party trademark.
About This Guide 7
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1 Using the ZENworks for Desktops 
Preboot Services Menu Editor

This section includes information to help you understand the Novell® 
ZENworks® for Desktops 4 Preboot Services Menu Editor, including:

“What is PXE?” on page 9

“What is the Preboot Services (PXE) Menu?” on page 10

“What is the Preboot Services Menu Editor?” on page 10

“Using the Preboot Services Menu Editor” on page 11

What is PXE?
ZfD 4 Preboot Services utilizes the Preboot Execution Environment (PXE), an 
industry-standard protocol that allows a workstation to boot up and execute a 
program from the network before the workstation operating system starts. The 
PXE environment is loaded from either the Network Interface Card (NIC) in 
flash or ROM, or in the same memory as the system BIOS.

By using Preboot Services, you can put an image on a workstation even if the 
workstation's hard disk is blank. You do not need to use imaging boot 
diskettes or CDs, or install a ZfD Workstation Imaging (Linux*) partition on 
the workstation. In order to use Preboot Services, you need to install the 
Workstation Imaging and Preboot Services components of ZfD 4 on your 
server and enable workstations for PXE.
Using the ZENworks for Desktops Preboot Services Menu Editor 9
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What is the Preboot Services (PXE) Menu?
When a PXE-enabled workstation is booted, it broadcasts for DHCP 
information and receives a response from both the DHCP and Proxy DHCP 
servers. The workstation will then download the Preboot Services client and 
check for imaging work with the Transaction server. If there is imaging work 
to do, the workstation displays a default ZfD Preboot Services (PXE) Menu 
displaying the following options:

Start ZENworks Imaging in Automatic Mode 

Start ZENworks Imaging in Maintenance Mode

Disable the ZEN Partition

Enable the ZEN Partition

What is the Preboot Services Menu Editor?
If you want to create a custom Preboot Services (PXE) menu, you can use the 
ZfD Preboot Services Menu Editor to set and run your own actions and DOS 
utilities on the client workstation. Novell provides this utility as a service; no 
custom DOS or Linux* utilities have been developed by Novell.

The Menu Editor is a Windows*-based, option-driven utility that lets you do 
the following on the Preboot Services (PXE) menu:

Add menu items or submenus to the Preboot Services (PXE) menu

Add executable commands to be performed on the client workstation

Delete a submenu or an action from an existing menu

The Menu Editor generates menu files and stores them on the ZfD Preboot 
Services server. These files can be selected from the Menu Editor interface 
and downloaded to a Preboot Services client workstation.

Installation

If you chose the Preboot Services component during the ZfD 4 Preboot 
Services installation program, the Menu Editor is automatically installed on 
Windows NT*/2000 servers you designate as Preboot Services servers. For 
more information, see Setting Up ZENworks for Desktops Preboot Services 
in ZfD 4 Preboot Services Installation and Configuration. The Menu Editor is 
not installed to a NetWare® server during the Preboot Services installation; 
the files must be accessed from a Windows workstation.
10 Menu Editor User Guide

Menu Editor User Guide
103-000186-001
August 26, 2002

Novell Confidential



Manual 99a38 July 17, 2001
Accessing the Menu Editor

If you installed to a Windows server, you can access the Menu Editor from the 
Windows desktop (after the PXE-enabled Windows workstation is imaged) by 
clicking Start > Programs > ZEN Preboot Services > ZEN Preboot Services 
Menu Editor.

If you need to access the Menu Editor from a NetWare server, locate the files 
on the ZENworks for Desktops 4 Program CD in the \MENU EDITOR folder 
> copy them to your NetWare server. Then, from a Windows machine, you 
can map a drive to the location on the server and run the Menu Editor.

The Menu Editor Interface

The Menu Editor interface is not available unless you are creating or editing 
an existing menu. Add and delete functions are available from the Options 
menu or from icons on the toolbar. Menu Editor functions can also be initiated 
with keyboard commands from a Windows workstation. For example, 
pressing the Insert key while in the Menu Editor adds a menu item, and 
pressing the Delete key deletes a menu item.

You can enter descriptive text about the menu in the Information field. You 
can also add help by entering appropriate text in the Help field.

Using the Preboot Services Menu Editor
Although you will probably use the default Preboot Services (PXE) Menu for 
ZfD Preboot Services, you may want to take advantage of the flexibility of the 
Preboot Services Menu Editor to create a new menu or to modify the default 
menu.

This section contains the following information:

“Modifying the Default Menu” on page 12

“Creating a New Preboot Services (PXE) Menu” on page 14

“Creating a Submenu” on page 15

“Creating Functions Within the Menu” on page 16

“Saving the Menu as a .DAT File” on page 17
Using the ZENworks for Desktops Preboot Services Menu Editor 11
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Modifying the Default Menu
There may be circumstances that require you to limit the options on the ZfD 4 
Preboot Services (PXE) menu. For example, you may want to restrict the user 
from using the Linux bash command line options. In such a case, you must 
create a new default menu and copy it to proper location on the Preboot 
Services server.

The following steps assume that you want to overwrite the existing default 
menu. If you want to save the options of this menu, we recommend that you 
rename DEFMENU.MNU (for example, DEFMENU_OLD.MNU), edit it 
with the Menu Editor to meet your needs, then save it again as 
DEFMENU.MNU.

To modify the default menu:

1 In the Windows desktop, click Start > Programs > ZEN Preboot Services 
> ZEN Preboot Services Menu Editor to display the following dialog box:

2 Click No to display the menu files that reside in the directory from which 
MEDITOR.EXE is running.

3 Select (or browse to) the DEFMENU.MNU you want to change > click 
Open.
12 Menu Editor User Guide
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4 Select the menu item that you want to delete > click Options > Delete to 
display a message similar to the following:

Do you want to delete Start ZEN Imaging 
Maintenance and its subitems?

5 Click Yes to return to the Menu Editor.

6 Click File > Save. This opens the Save As dialog box.

7 Select DEFMENU.MNU to enter this filename in the File Name field > 
click Save. The following prompt is displayed:

 Do you want to overwrite the old file?

8 Click Yes to overwrite the file and to return to the Menu Editor window. 

You have now modified the DEFMENU.MNU menu template.
Using the ZENworks for Desktops Preboot Services Menu Editor 13
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9 In the Menu Editor window, click File > Save to reopen the Save As 
dialog box.

10 In the Save As Type drop-down list, select ZEN Preboot Menu file 
(*.DAT).

11 Select DEFMENU.DAT to enter this file name in the File Name field > 
click Save. The following prompt is displayed:

 Do you want to overwrite the old file?

12 Click Yes to overwrite the file and to return to the Menu Editor window. 

You have now modified the data file that will be displayed as the menu 
on a PXE workstation.

13 Copy the new DEFMENU.DAT file to the /TFTP folder on the Preboot 
Services server.

Creating a New Preboot Services (PXE) Menu
Use the following steps to create a new Preboot Services (PXE) menu using 
the ZfD 4 Preboot Services Menu Editor:

1 In the Windows desktop, click Start > Programs > ZEN Preboot Services 
> ZEN Preboot Services Menu Editor to display the following dialog box:

2 Click Yes to display the Create Menu dialog box.

3 Enter the name of menu you want to create > click OK to display the ZEN 
Preboot Menu Editor window.
14 Menu Editor User Guide
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Creating a Submenu

If you want to create your own functions for the Preboot Services (PXE) 
menu, you need to create a submenu of these functions. Use the following 
steps to create a submenu.

1 Select Add from the Options menu to display the Add Menu Item 
window.

2 Select Submenu > click OK to display the Add Menu dialog box.

3 In the Heading field of the dialog box, enter the text you want to use as 
the option in the submenu > click OK.

The Menu Editor displays the submenu option as a subordinate item to the 
main menu you have already created. 

4 Enter descriptive and help text in the Information and Help fields.

5 Click Update to save the text of the submenu option and any 
accompanying text you have created.
Using the ZENworks for Desktops Preboot Services Menu Editor 15
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Although the submenu item is now created and will appear on the Preboot 
Services (PXE) menu, it will not launch any utility: it is merely a text heading 
that serves as a navigation tool to options that actually perform functions.

Creating Functions Within the Menu

As stated earlier in this document, ZfD 4 Preboot Services ships with a 
Preboot Services (PXE) menu that allows only limited, predesigned actions 
from the client workstation. Novell does not ship other DOS or Linux* 
utilities. However, if you want to add functionality of your own, you can do 
so with the Preboot Services Menu Editor.

To add executable commands to the Menu Editor:

1 In the Preboot Services Menu Editor window, select a menu item > click 
Options > Add to display the Add Menu Item window.

2 Click Execute Command > OK.

3 In the Execute Command dialog box, enter menu text that describes the 
functionality of your program > click OK.

4 Enter the command parameters of the utility you want to run > click OK.

5 Enter descriptive text about the item you have created > click OK.

6 Enter any help text that you want to be accessible by an F1 command for 
this menu item > click OK.

7 When you have finished creating the menu, click File > Save to save the 
structure.

By default, the file is saved in .MNU format, which is used as a template by 
the Preboot Services Menu Editor interface. To be used by the Preboot 
Services (PXE) menu, this file must be exported to a binary (.DAT) format. 
For more information, see “Saving the Menu as a .DAT File” on page 17.
16 Menu Editor User Guide
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Saving the Menu as a .DAT File

To create a .DAT file for the Preboot Services (PXE) menu using a .MNU file: 

1 Open the Preboot Services Menu Editor > click No to display the existing 
.MNU files saved to your default folder (the same folder where the menu 
editor, MEDITOR.EXE, resides.)

2 Select the .MNU file of the menu you want to export for later use by the 
Preboot Services (PXE) menu > click File > Save.

3 In the Save As Type drop-down list, select ZEN Preboot Menu file 
(*.DAT).

4 In the file Name field, enter DEFMENU > click Save to return to the 
Menu Editor window. You have now created a data file that can be 
displayed as the default menu on a PXE workstation.

5 Copy the DEFMENU.DAT file to the /TFTP folder on the Preboot 
Services Server.

Note that the .DAT file is saved in the local folder from which you are running 
the Preboot Services Menu Editor. You must copy the file to the \TFTP folder 
at the Preboot Services server.
Using the ZENworks for Desktops Preboot Services Menu Editor 17
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