1.6 Inventoried-Only Device Requirements

You can use ZENworks 11 SP2 to inventory workstations and servers by deploying the Inventory-Only module on these devices.

IMPORTANT:If there are ZENworks product issues that are caused by an issue with the platform, the following support standards apply:

  • Platforms that are generally supported by platform vendors are supported by Novell.

  • If the platform vendor provides support to your installations through a special agreement (such as extended support), Novell expects you to extend this support infrastructure to us to resolve the issue.

  • If the platform vendor does not support the platform at all, Novell offers no additional support.

The inventoried-only devices must meet the following requirements:

Table 1-10 Inventoried-Only Device Requirements

Item

Requirements

Operating System: Servers

  • AIX 5.1-6.1 IBM pSeries (RS6000) x86, x86_64

  • HP-UX 10.20-11.23 HP PA-RISC (HP9000)

  • NetWare 5.1, 6, 6.5

  • OES 2 SP1 / SP2 / SP3 x86, x86_64

  • Red Hat Enterprise Linux 4.8-6.0 x86, x86_64

  • Solaris 2.6–10 Sun SPARC x86_64

  • SLES 8.0-11 (all editions)

  • Windows 2000 Server SP4 x86

  • Windows Server 2003 SP1 / SP2 x86, x86_64 (Enterprise and Standard editions)

  • Windows Server 2008 SP1 / SP2 x86, x86_64 (Enterprise and Standard editions)

  • Windows Server 2008 R2 SP1 (Enterprise and Standard editions)

Operating System: Workstations

  • Mac OS X 10.5.x to 10.6.6

    For Mac OS X 10.7, you need to install the full adaptive agent, as Inventory-only agent is not supported.

  • Red Hat Linux 4.8-6.0

  • SLED 8.0-11 (all editions)

  • Windows 2000 Professional SP4 x86

  • Embedded XP SP2 / SP3

  • Windows SP2 x86, x86_64 (Business, Ultimate, and Enterprise versions only; Home versions are not supported)

  • Embedded Vista SP1 / SP2

  • Windows XP Professional SP2 / SP3 x86, x86_64

  • Windows XP Tablet PC Edition SP3 x86

  • Windows 7 SP1 x86, x86_64 (Professional, Ultimate, and Enterprise editions)

Operating System: Sessions

Thin Client sessions:

  • Windows 2000 Server SP4 x86

  • Windows Server 2003 SP2 x86, x86_64

  • Citrix XenApp 4.5

  • Citrix XenApp 5.0

Inventory Only Module

After installing ZENworks 11 SP2 to your network, you must install this module on the above-listed devices to inventory them. For more information, see Deploying the Inventory-Only Module in the ZENworks 11 SP2 Discovery, Deployment, and Retirement Reference.

Hardware: Disk Space

The Inventory-Only module requires the following minimum disk space:

  • AIX: 4 MB

  • Solaris: 4 MB

  • Linux: 900 KB

  • HP-UX: 900 KB

  • Windows: 15 MB

  • Mac OS: 8 MB

  • NetWare: 30 MB

System Libraries: AIX

The following system libraries are required on AIX devices:

  • /unix

  • /usr/lib/libc.a (shr.o)

  • /usr/lib/libc.a (pse.o)

  • /usr/lib/libpthread.a (shr_xpg5.o)

  • /usr/lib/libpthread.a (shr_comm.o)

  • /usr/lib/libpthreads.a (shr_comm.o)

  • /usr/lib/libstdc++.a (libstdc++.so.6)

  • /usr/lib/libgcc_s.a (shr.o)

  • /usr/lib/libcurl.a (libcurl.so.3)

  • /usr/lib/libcrypt.a (shr.o)

System Libraries: HP-UX

The following system libraries are required on HP-UX devices:

  • /usr/lib/libc.1

  • /usr/lib/libc.2

  • /usr/lib/libdld.1

  • /usr/lib/libdld.2

  • /usr/lib/libm.2

  • /usr/local/lib/libcrypto.sl

  • /opt/openssl/lib/libcrypto.sl.0

  • /opt/openssl/lib/libssl.sl.0

  • /usr/local/lib/libiconv.sl

  • /usr/local/lib/libintl.sl

  • /usr/local/lib/gcc-lib/hppa1.1-hp-hpux11.00/3.0.2/../../../libidn.sl