Generating an Apple Push Notification Service Certificate

ZENworks® Mobile Management 2.5.x

July 2012
Legal Notices

Novell, Inc., makes no representations or warranties with respect to the contents or use of this documentation, and specifically disclaims any express or implied warranties of merchantability or fitness for any particular purpose. Further, Novell, Inc., reserves the right to revise this publication and to make changes to its content, at any time, without obligation to notify any person or entity of such revisions or changes.

Further, Novell, Inc., makes no representations or warranties with respect to any software, and specifically disclaims any express or implied warranties of merchantability or fitness for any particular purpose. Further, Novell, Inc., reserves the right to make changes to any and all parts of Novell software, at any time, without any obligation to notify any person or entity of such changes.

Any products or technical information provided under this Agreement may be subject to U.S. export controls and the trade laws of other countries. You agree to comply with all export control regulations and to obtain any required licenses or classification to export, re-export or import deliverables. You agree not to export or re-export to entities on the current U.S. export exclusion lists or to any embargoed or terrorist countries as specified in the U.S. export laws. You agree not to use deliverables for prohibited nuclear, missile, or chemical biological weaponry end uses. See the Novell International Trade Services Web page (http://www.novell.com/info/exports/) for more information on exporting Novell software. Novell assumes no responsibility for your failure to obtain any necessary export approvals.

Copyright © 2012 Novell, Inc. All rights reserved. No part of this publication may be reproduced, photocopied, stored on a retrieval system, or transmitted without the express written consent of the publisher.

Novell, Inc.
1800 South Novell Place
Provo, UT 84606
U.S.A.
www.novell.com

Online Documentation: To access the latest online documentation for this and other Novell products, see the Novell Documentation Web page (http://www.novell.com/documentation).

Novell Trademarks

For Novell trademarks, see the Novell Trademark and Service Mark list (http://www.novell.com/company/legal/trademarks/tmlist.html).

Third-Party Materials

All third-party trademarks are the property of their respective owners.
Table of Contents

Apple Push Notification Service (APNs) ........................................ 4

Generating an APNs Certificate ............................................. 6
  Generating an APNs Certificate from Windows Server 2003 .......... 6
  Creating the Certificate Signing Request (CSR) from IIS Manager 6 ....... 6
  Uploading the CSR to the ZENworks Mobile Management Certificate Request Portal ......................................................... 9
  Uploading the Intermediate Certificate to the Apple Push Certificates Portal ................................................................. 9
  Completing the Certificate Request from IIS Manager 6 ...................... 13

Generating an APNs Certificate from Windows Server 2008 ............... 18
  Creating the Certificate Signing Request (CSR) from IIS Manager 7 ....... 18
  Uploading the CSR to the ZENworks Mobile Management Certificate Request Portal ......................................................... 21
  Uploading the Intermediate Certificate to the Apple Push Certificates Portal ................................................................. 21
  Completing the Certificate Request from IIS Manager 7 ...................... 25

Uploading the APNs Certificate to ZENworks Mobile Management .... 27

Renewing an APNs Certificate .................................................. 29
Apple Push Notification Service (APNs)

What Is APNs

Apple Push Notification service (APNs) is a highly secure and efficient system for communicating with iOS devices over-the-air (OTA). Each device establishes an accredited and encrypted IP connection with the service. The provider, in this case your ZENworks Mobile Management server, connects with and sends its notification to the APNs, which pushes the notification to the target device.

An APNs certificate is required for Apple Push Notification service. The certificate must be renewed annually. This guide explains the process of obtaining the APNs certificate from Apple and provides instructions on how to upload the certificate to the ZENworks Mobile Management server via its dashboard.

There are various methods of generating the APNs certificate, any of which you may use. This document guides you through generating the certificate by using Microsoft Windows Internet Information Services (IIS) Manager, version 6 or 7.

How APNs Works

Apple Push Notification service works in conjunction with the built-in MDM protocol of Apple iOS devices. ZENworks Mobile Management uses the Apple Push Notification service to send notifications to the iOS device requesting information. Only notifications, not data, are not sent through the APNs server. The device responds directly to the ZENworks Mobile Management server.

The Apple MDM protocol provides the following functionality:

- Devices support Selective Wipe, Lock Device, and Clear Passcode
- Full Wipe and Lock Device commands are applied immediately
- You can record and access installed applications on devices
- You can record and access installed configuration profiles on devices
- You have access to additional device statistics
- Configuration profile updates require no user interaction
- Enterprise (in-house) apps
- Mobile App Management
- Manage VPP (Redemption) Codes
Requirements

- **ZENworks Mobile Management** version 2.5.2 or later
- An Apple ID. We recommend that you do not use a personal Apple ID, but create a separate corporate Apple ID for MDM. Associate the Apple ID with an email account that will remain with your company – not an email account that belongs to an individual in the company. This facilitates a smooth certificate renewal process each year.
- Windows Server 2003 or 2008 (you need administrator permissions)
- Firefox or Safari Web browser

An Overview of the Steps to Obtain the Apple Push Notification Service Certificate

1. Create a Certificate Signing Request (CSR). (This guide provides instructions for creating the certificate from Microsoft Windows Internet Information Services (IIS) Manager, version 6 or 7.)
2. Upload the CSR to the [ZENworks Mobile Management Certificate Portal](https://zmmupdate.novell.com/spn/). Novell, Inc. signs the CSR.
3. Upload the intermediate certificate (the CSR signed by Novell, Inc.) to the Apple Push Certificates Portal. Apple issues the certificate.
4. Download the signed certificate from the Apple Push Certificates Portal and complete the certificate request in IIS.
5. Export the certificate to a file.
6. Upload the certificate to the ZENworks Mobile Management server.

Generating an Apple Push Notification Service Certificate for use with ZENworks Mobile Management for iOS

1. Create a Certificate Signing Request (CSR) in IIS. The IIS server and the ZENworks server can be the same server, but this is not required.
2. Upload the CSR to the ZENworks Certificate portal to get it signed by Novell. A request file is generated. [https://zmmupdate.novell.com/spn/](https://zmmupdate.novell.com/spn/)
4. Use IIS to complete the certificate request process by using the certificate issued by Apple.
5. Export the certificate you just created as a .pfx file. (Create a password while exporting.)
6. Use the ZENworks Mobile Management dashboard to upload the APNs certificate to the ZENworks server. Log in to the dashboard with the external server address so that the Use Default URLs option can be utilized.
Generating an APNs Certificate from Windows Server 2003

The following instructions are for generating an APNs certificate from a Windows Server 2003 by using Internet Information Services (IIS) Manager version 6. You can skip this section if you use Windows Server 2008. Instructions for 2008 are in another section of this document.

Creating the Certificate Signing Request (CSR) from IIS Manager 6

1. Select Start > Control Panel > Administrative Tools > Internet Information Services (IIS) Manager.
2. Right-click any Web site in the left panel. Select Properties.
3. Select the Directory Security tab and then click the Server Certificates button in the Security section of the menu. This starts the Web Server Certificate Wizard. Click Next to continue.
4. Select the **Create a new certificate** option and click **Next**.

5. Select **Prepare the request now, but send it later** option and click **Next**.

6. Enter a certificate name that is easily remembered. In the **Bit length** field, select **2048** for the encryption level, then select **Select cryptographic service provider (CSP) for this certificate**. Click **Next**.

7. From the **Available Providers** window, select **Microsoft RSA SChannel Cryptographic Provider**. Click **Next**.
8. Enter the legal name of your Organization and the Organization unit, which is the department within your organization. Click Next.

9. In the Common name field, enter a valid Apple ID. This does not need to be an Apple Developer account ID, but you should use an Apple ID that has been designated for managing the corporate APNs certificate. The Apple ID might be in the form of an email address, or possibly a display name. Click Next.

10. Enter the Country/Region, State/Province, and City/locality of your organization. Click Next.

In the Certificate Request File Name window, save the CSR to your computer. Record the location and filename. This is the file you will upload to the ZENworks Mobile Management Certificate Request Portal. Click Next.

11. Review the information for the certificate request in the Request File Summary window. To make revisions, click the Back button. Click Next to accept, then click Finish.
Uploading the CSR to the ZENworks Mobile Management Certificate Request Portal

The CSR file you generated through IIS must be signed by Novell before you can upload it to the Apple Push Certificates Portal. You will need:

- Access to the CSR file
- Your Novell login credentials


![CSR Upload Form]

2. Browse to select the CSR file.
3. Click Get Signed Request.
4. Save the signed request.

You are now ready to upload the signed ZENworks.request file (the intermediate certificate) to the Apple Push Certificates Portal.

Uploading the Intermediate Certificate to the Apple Push Certificates Portal

At the Apple Push Certificates Portal, you accept a license agreement and upload the intermediate certificate that you downloaded from the ZENworks Mobile Management Certificate Portal. A new Apple signed push certificate is created for you to download.

1. Browse to the Apple Push Certificates portal at: https://identity.apple.com/pushcert/
2. Log in by using your Apple ID and password. This does not need to be an Apple Developer account ID, but you should use an Apple ID that has been designated for managing the corporate APNs certificate.
3. Select **Create a Certificate**.

4. Read the *Terms of Use* and accept the End User License Agreement.
5. Select and upload the intermediate certificate you downloaded from the ZENworks Mobile Management Certificate Portal.
6. When the upload has finished, a new certificate for ZENworks Mobile Management appears. Select **Download** to download the Apple signed certificate.

You are now ready to complete the CSR and export the APNs certificate to the ZENworks Mobile Management server.
Completing the Certificate Request from IIS Manager 6

1. Return to the IIS Manager. Select Start > Control Panel > Administrative Tools > Internet Information Services (IIS) Manager.
2. Right-click any Web site in the left panel. Select Properties.
3. Select the Directory Security tab and then click the Server Certificates button in the Security section of the menu. This starts the Web Server Certificate Wizard. Click Next to continue.
4. Select the Process the pending request and install the certificate option and click Next.
5. Browse to the aps_production_identity.pem file that was provided by Apple. Click Next.

6. On the Certificate Summary screen, verify that the certificate information is correct and click Next, then click Finish.
7. Open the Microsoft Management Console (MMC). Click Start > Run and enter MMC.
8. From the File menu, select Add/Remove Snap-in.
9. From the drop-down list at Snap-ins added to, select Console Root and click Add. On the Add Standalone Snap-in screen, select Certificates, then click Add.


11. Click Close. Click OK on the Add/Remove Snap-in screen.
12. At the *Console Root*, expand the directory. Select **Certificates > Personal > Certificates**. Right-click on the certificate file and select **All Tasks > Export**. This opens the Export Wizard. Click **Next** to continue.

13. Select **Yes** to export the private key, then click **Next**.

---

**Certificate Export Wizard**

**Export Private Key**

You can choose to export the private key with the certificate.

Private keys are password protected. If you want to export the private key with the certificate, you must type a password on a later page.

Do you want to export the private key with the certificate?

- **Yes, export the private key**
- **No, do not export the private key**
14. Select the **Personal Information Exchange – PKCS #12 (.PFX)** format and select the **Enable strong protection** box. Click **Next**.

15. Enter and confirm a password. You will need this password when you upload the certificate to **ZENworks Mobile Management**. Click **Next**.
16. Click the Browse button and select the .pfx file that you want to export. Click Next.

![Certificate Export Wizard]

17. Click Finish to complete the certificate export. You see a message that says the export was successful.

Now you are ready to upload the certificate to ZENworks Mobile Management. You need the following:

- APNs certificate file (.pfx format)
- The password you set when exporting the certificate

Continue with Upload the APNs Certificate to ZENworks Mobile Management.
Generating an APNs Certificate from Windows Server 2008

The following instructions are for generating an APNs certificate from Windows Server 2008 by using Internet Information Services (IIS) Manager version 7. You can skip this section if you use Windows Server 2003. Instructions for 2003 are in another section of this document.

Creating the Certificate Signing Request (CSR) from IIS Manager 7

1. Select **Start > Administrative Tools > Internet Information Services (IIS) Manager**.
2. Select the server name in the left panel, then double-click the **Server Certificates** option in the **Security** section of the menu.
3. From the **Actions** menu in the right panel, select **Create Certificate Request**. This starts the Request Certificate Wizard.
4. Enter the following in the **Distinguished Name Properties** window:
   - **Common name** – Enter a valid Apple ID. This does not need to be an Apple Developer account ID, but you should use an Apple ID that has been designated for managing the corporate APNs certificate. The Apple ID might be in the form of an email address, or possibly a display name.
   - **Organization** – The legal name of your organization
   - **Organization unit** – The department within your organization
   - **City/locality** – City in which your organization is located
   - **State/province** – Abbreviation for the state or province in which your organization is located
   - **Country/region** – Abbreviation for the country or region in which your organization is located

5. Select **Next**.

6. In the **Cryptographic Service Provider Properties** window, accept the default setting, Microsoft RSA SChannel Cryptographic Provider. In the **Bit length** field, select **2048** for the encryption level. Click **Next**.
7. In the *File Name* window, save the CSR to your computer. Record the location and filename. Click *Finish*. This is the file you will upload to the *ZENworks Mobile Management Certificate Request Portal*.
Uploading the CSR to the ZENworks Mobile Management Certificate Request Portal

The CSR file you generated by using IIS must be signed by Novell before you can upload it to the Apple Push Certificates Portal. You need:

- Access to the CSR file
- Your Novell login credentials


   ![ZENworks Mobile Management Certificate Request Portal](image)

   - Select a certificate signing request to upload.
   - (File size is required to be less than 10KB.)

   ![Get Signed Request Button](image)

   - Browse to select the CSR file.
   - Click Get Signed Request.
   - Save the signed request.

You are now ready to upload the signed ZENworks.request file (the intermediate certificate) to the Apple Push Certificates Portal.

Uploading the Intermediate Certificate to the Apple Push Certificates Portal

At the Apple Push Certificates Portal, you accept a license agreement and upload the intermediate certificate that you downloaded from the ZENworks Mobile Management Certificate Portal. A new Apple signed push certificate is created for you to download.

2. Log in by using your Apple ID and password. This does not need to be an Apple Developer account ID, but you should use an Apple ID that has been designated for managing the corporate APNs certificate.

3. Select **Create a Certificate**.
4. Read the Terms of Use and accept the End User License Agreement.

5. Select and upload the intermediate certificate you downloaded from the ZENworks Mobile Management Certificate Portal.
6. When the upload has finished, a new certificate for ZENworks Mobile Management appears. Select **Download** to download the Apple signed certificate.

You are now ready to complete the CSR and export the APNs certificate to the ZENworks Mobile Management server.
Completing the Certificate Request from IIS Manager 7

1. Return to Internet Information Services (IIS) Manager > Server Certificates and select Complete Certificate Request from the Actions menu in the right panel. This starts the Complete Certificate Request Wizard.

2. Browse to the aps_production_identity.pem file that was provided by Apple and enter a friendly name. This is simply a label you give the certificate to easily distinguish it. You might want to give it a name in which your company is identified.

3. Select OK to install the certificate to the server. You should see the certificate listed in the center panel of Server Certificates.
4. Export the certificate so that it can be uploaded to ZENworks Mobile Management. Right-click the certificate you just installed and select Export.

5. Save the file to your Desktop in the .pfx format. You must set a password. You will need this password when you upload the certificate to ZENworks Mobile Management.

You have successfully generated your APNs certificate.

Now you are ready to upload the certificate to ZENworks Mobile Management. You need the following:

- APNs certificate file (.pfx format)
- The password you set when exporting the certificate

Continue with Upload the APNs Certificate to ZENworks Mobile Management.
Uploading the APNs Certificate to ZENworks Mobile Management

This section explains how to upload the APNs certificate to ZENworks Mobile Management by using the ZENworks Mobile Management dashboard. You need:

- APNs certificate file (the .pfx format)
- The password you set when exporting the certificate

1. Log in to the ZENworks Mobile Management dashboard and select the System view.
2. Select Organization from the left panel.
3. Click the Upload button next to the APNs Certificate field.
4. Click the Browse button, then navigate to and select the APNs certificate file (.pfx format).
5. Enter the password you set when exporting the certificate.
6. Select the Use Default URLs box.

   If you did not access the dashboard externally, do not use the default check box. Enter the Server URL and Check in URL manually, in the format Error! Hyperlink reference not valid.
7. Click the Submit button.  
After you have uploaded an APNs certificate, it appears under the APN Certificate field on the dashboard in the format `com.apple.mgmt.<random string> (Enabled)`

8. Click Save Changes when you are finished.  
Your ZENworks Mobile Management server is now able to trigger iOS devices with push notifications and use the built-in Apple MDM protocol.

### Updating the APNs Certificate

1. Log in to the ZENworks Mobile Management dashboard and select the System view.  
2. Select Organization from the left panel.  
3. Click the Edit button next to the APNs Certificate field and make the needed changes. You can change/disable/delete the APNs certificate or edit the URLs if necessary.

4. Click the Submit button.

5. Click Save Changes when you are finished.

**Tip:** You might want to test APNs functionality after an update to the certificate by manually updating the APN profile on a device. Open ZENworks Mobile Management on an iOS device and tap Config > Load Configuration Profile. The device installs the initial profile and, after a brief delay, it prompts for the user's Exchange password. If the prompt for Exchange credentials does not occur, resetting IIS might resolve issues preventing the APNs from processing.
Renewing an APNs Certificate

The Apple Push Notification service (APNs) certificate must be renewed annually. Organizations should keep track of the certificate’s expiration date, because there is no automatic renewal notification as the expiration date approaches.

Follow the instructions below to renew the APNs certificate that was generated from the Apple Push Certificates Portal or from Apple’s iOS Developer Enterprise Program (iDEP).

Essentially, you follow the same process used to obtain the original certificate. The only difference is in the steps taken on the Apple Push Certificates Portal (Steps 4-6 below.)

To renew an APNs certificate:

1. Create a new Certificate Signing Request (CSR) by using IIS Manager (See the complete instructions: [IIS Manager 6](#) or [IIS Manager 7](#))
2. Upload the CSR to Novell’s ZENworks Mobile Management Certificate Request Portal. Click Get Signed Request and save the signed request file. See the complete instructions on page 21.
   - If you originally obtained the certificate from the Apple Push Certificates Portal, log in with the Apple ID you used to generate the certificate.
   - If you originally obtained the certificate through iDEP, log in with the Apple ID for the iDEP Agent account.
4. On the page where your certificate is listed, click the Renew button next to the APNs certificate you are renewing.

![Apple Push Certificates Portal](#)
5. On the Renew Push Certificate page, click the Browse button and select the .plist file to upload. Click Upload.

6. The page where certificates are listed displays the certificate with a new expiration date. Click the Download button next to the renewed certificate to download it and save it as a .pem file.

7. Use IIS to complete the CSR (See the complete instructions: IIS Manager 6 or IIS Manager 7)

8. From the ZENworks Mobile Management server dashboard, upload the renewed certificate.
   
   Select System > Organization.
   
   Click the Edit button next to the APNs Certificate field and choose Change APNs Certificate. (See complete instructions: Updating the APNs Certificate).