Legal Notices

Novell, Inc., makes no representations or warranties with respect to the contents or use of this documentation, and specifically disclaims any express or implied warranties of merchantability or fitness for any particular purpose. Further, Novell, Inc., reserves the right to revise this publication and to make changes to its content, at any time, without obligation to notify any person or entity of such revisions or changes.

Further, Novell, Inc., makes no representations or warranties with respect to any software, and specifically disclaims any express or implied warranties of merchantability or fitness for any particular purpose. Further, Novell, Inc., reserves the right to make changes to any and all parts of Novell software, at any time, without any obligation to notify any person or entity of such changes.

Any products or technical information provided under this Agreement may be subject to U.S. export controls and the trade laws of other countries. You agree to comply with all export control regulations and to obtain any required licenses or classification to export, re-export or import deliverables. You agree not to export or re-export to entities on the current U.S. export exclusion lists or to any embargoed or terrorist countries as specified in the U.S. export laws. You agree to not use deliverables for prohibited nuclear, missile, or chemical biological weaponry end uses. See the Novell International Trade Services Web page (http://www.novell.com/info/exports/) for more information on exporting Novell software. Novell assumes no responsibility for your failure to obtain any necessary export approvals.

Copyright © 2010 Novell, Inc. All rights reserved. No part of this publication may be reproduced, photocopied, stored on a retrieval system, or transmitted without the express written consent of the publisher.

Novell, Inc., has intellectual property rights relating to technology embodied in the product that is described in this document. In particular, and without limitation, these intellectual property rights may include one or more of the U.S. patents listed on the Novell Legal Patents Web page (http://www.novell.com/company/legal/patents/) and one or more additional patents or pending patent applications in the U.S. and in other countries.

Novell, Inc.
404 Wyman Street, Suite 500
Waltham, MA 02451
U.S.A.
www.novell.com

Online Documentation: To access the latest online documentation for this and other Novell products, see the Novell Documentation Web page (http://www.novell.com/documentation).

Novell Trademarks

For Novell trademarks, see the Novell Trademark and Service Mark list (http://www.novell.com/company/legal/trademarks/mlist.html).

Third-Party Materials

All third-party trademarks are the property of their respective owners.
Contents

Introduction

Check the Media in Your Student Kit

Course Objectives

Set Up Your Practice Environment

Review the Setup Diagram

Check Hardware and Software Requirements

Install and Configure VMware Player

Copy the Virtual Machines to the Host Computer

Test Connectivity Between DA1 and DA-SLED

Create the DA1 and DA-SLED Machines Manually

Create and Install the DA-SLED SUSE Linux Enterprise Desktop 11 Virtual Machine

Create and Install the DA1 SUSE Linux Enterprise Server 11 Virtual Machine

Review VMware Guidelines

How to Navigate in a VMware Virtual Machine Window

Exercise Conventions

SECTION 1 Getting to Know SUSE Linux Enterprise 11

Exercise 1-1 Perform Five Basic Tasks in Linux

Task 1: Change Your Wallpaper

Task 2: Change Your Screen Resolution

Task 3: Change Time and Date Settings

Task 4: Change Your Password

Task 5: Create a Desktop Launcher (Shortcut)

Exercise 1-2 Add an Applet to and Remove an Applet from the Bottom Panel

Exercise 1-3 Use the GNOME File Manager

Part 1: Start Nautilus and Copy a File

Part 2: Add an Emblem to the Copied File Icon

Part 3: Rename the Copied File

Part 4: Delete the Copied File

Exercise 1-4 Access the Command Line Interface

Part 1: Check IP Address of each machine

Part 2: Open Communication Between Desktop and Server

Part 3: Check and Change Hostname

SECTION 2 Locate and Use Help Resources

Exercise 2-1 Access and Use man Pages on DA1

Exercise 2-2 Access and Use info Pages on DA1

Exercise 2-3 Access Release Notes and White Paper Pages on DA1
Task I: Access Release Notes ................................................. 40
Task II: Install Howtos ......................................................... 40
Task III: Access Howtos ......................................................... 41

Exercise 2-4
Find Help on the Web on DA1 .................................................. 42
Task I: Look for Patches at the Novell Web site. ............................... 42
Task II: Use Google to Find Information ....................................... 42

SECTION 3 Manage the Linux File System .................................. 43

Exercise 3-1 Explore the SUSE Linux File System Hierarchy ............... 44
Exercise 3-2 Change Directories and List Directory Contents ............. 46
Exercise 3-3 Create and View Files ........................................... 47
Exercise 3-4 Perform Multiple File Operations ............................... 49
Exercise 3-5 Find Files on Linux ................................................ 52
Part I: Use the whereis and which Command ................................. 52
Part II: Use the GNOME Search Tool ......................................... 52
Part III: Use the find Command ................................................ 53
Exercise 3-6 Search File Content ............................................... 54
Detailed Steps to Complete this Exercise: .................................... 54
Exercise 3-7 Manage Folders with Nautilus .................................. 55

SECTION 4 Work with the Linux Shell and Command Line ................ 57

Exercise 4-1 Execute Commands at the Command Line on DA-SLED .... 58
Exercise 4-2 Perform Common Command Line Tasks on DA-SLED .... 59
Exercise 4-3 Work with Command Syntax and Special Characters on DA-SLED ......................................................... 60
Part I: Change the Character Encoding ....................................... 60
Part II: Use Search Patterns ...................................................... 60
Part III: Create Additional Files ............................................... 60
Part IV: Mask Special Characters .............................................. 61
Exercise 4-4 Use Piping and Redirection on DA-SLED .................... 62

SECTION 5 Administer Linux with YaST .................................... 63

Exercise 5-1 Get to Know YaST ................................................... 64
Part I: Start YaST ................................................................. 64
Part II: View the Content of a System Log File ............................. 64
Part III: Change Time and Date ............................................... 64
Part IV: Start the ncurses Interface of YaST. ................................ 64
Part V: View the Content of a System Log File ............................. 65
Part VI: Exit YaST ............................................................... 65
Exercise 5-2 Manage the Network Configuration Information from YaST ......................................................... 66
## SECTION 6  Manage Users, Groups, and Permissions  

### Exercise 6-1  Manage User Accounts with YaST  
- Part I: Create a New User Account with YaST  
- Part II: Log In as a New User  
- Part III: View the passwd File  
- Part IV: Log In as User geeko and Remove the New User Account

### Exercise 6-2  Check User and Group Information on Your Server

### Exercise 6-3  Create and Manage Users and Groups from the Command Line  
- Part I: Add a New User  
- Part II: Create a Password for the New User  
- Part III: Log In as New User and Change Your Password  
- Part IV: Remove the New User Account

### Exercise 6-4  Manage File Permissions and Ownership  
- Part I: Create a Private and a Public Directory  
- Part II: Try to Create a File as a Normal User in Both Directories

## SECTION 7  Use Linux Text Editors

### Exercise 7-1  Use vi to Edit Files in the Linux System  
- Part I: Enter a Text  
- Part II: Edit a Text

## SECTION 8  Manage Software with RPM

### Exercise 8-1  Manage Software with YaST

### Exercise 8-2  Install Software with PackageKit

### Exercise 8-3  Manage Software with RPM  
- Task I: Get Information on Software Packages  
- Task II: Install and Remove Software with RPM

### Exercise 8-4  Manage Software with zypper  
- Task I: Add an Installation Source and Alias with zypper  
- Task II: Remove an Installation Source with zypper  
- Task III: Remove a Software Package with zypper
Introduction

This workbook is designed to help you practice the skills associated with SUSE Linux Enterprise 11 Fundamentals (Course 3101) objectives.

These skills, along with those taught in the SUSE Linux Enterprise 11 Administration (3102) prepare you to take the Novell Certified Linux Administrator 11 (Novell CLA 11) certification practicum test.

Before starting the exercises in this workbook, you need to review the following:

- “Check the Media in Your Student Kit” on page 7
- “Course Objectives” on page 8
- “Set Up Your Practice Environment” on page 8
- “Create the DA1 and DA-SLED Machines Manually” on page 13
- “Review VMware Guidelines” on page 25
- “Exercise Conventions” on page 25

Check the Media in Your Student Kit

Your kit for Course 3101 contains the following media:

- Course 3101– SUSE Linux Enterprise 11 Fundamentals Course DVD. This DVD contains the course manual in PDF format, this workbook in PDF format, and a readme file.

  In addition, there are several folders with the following content:

  - **Exercises.** This folder contains files used for the course exercises.
  - **Documents.** This folder contains all the documentation guides referenced in the course manual.
  - **Setup.** This folder contains all the files you need to set up your practice environment.
  - **VMs.** This folder contains the Virtual Machines used in the course.

- SUSE Linux Enterprise Server 11 Product DVD
- SUSE Linux Enterprise Desktop 11 Product DVD
Course Objectives

In this course, you will do the following:

- Become familiar with the Linux Desktop and confident in your ability to perform basic tasks in Linux.
- Learn how to get help for all problems you might have.
- Understand the structure of the Linux file system and how to work in the file system (e.g., copying and moving).
- Learn how to work with the Linux Shell and Command Line Interface.
- Learn how to manage software packages with the configuration tool YaST2.
- Learn how to manage users, groups, and file permissions to ensure a basic file system security.
- Learn how to edit configuration files with a graphical editor or the command line editor vi.
- Learn how to manage software with RPM.

Set Up Your Practice Environment

Setting up your practice environment for doing the exercises in the workbook can take quite a while (sometimes up to two hours).

The exercises are based on running SUSE Linux Enterprise Desktop 11 and SUSE Linux Enterprise Server 11 as VMware virtual machines (guests) on a Windows or Linux host machine.

Your time is spent preparing the host machine for the exercises (one hour) by performing tasks such as installing and configuring VMware software; and copying the DA1 and DA-SLED virtual machines from the Course DVD to the host machine.

To set up this course, do the following:

- “Review the Setup Diagram” on page 8
- “Check Hardware and Software Requirements” on page 10
- “Install and Configure VMware Player” on page 11
- “Copy the Virtual Machines to the Host Computer” on page 12
- “Test Connectivity Between DA1 and DA-SLED” on page 12

Review the Setup Diagram

In this course, you use one host computer and one virtual machine. The practice environment setup is illustrated in the following:
This setup requires a Host workstation running two virtual machines from VMware Player.

**Figure Intro-1**

- **Host Machine**
  - VMware Player
  - VMnet1
  - IP: 172.17.8.1
  - Subnet: 255.255.0.0

- **VMware Virtual Machines**
  - **DAI**
    - SLES 11
    - Host-Only
    - IP: 172.17.8.101
    - Subnet: 255.255.0.0
  - **DA-SLED**
    - SLED 11
    - Host-Only
    - IP: 172.17.8.100
    - Subnet: 255.255.0.0
Check Hardware and Software Requirements

The following table lists the minimum hardware and software requirements for this course:

Table Intro-1  Setup

<table>
<thead>
<tr>
<th>Setup</th>
<th>Minimum Requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hardware</td>
<td>You need a host computer that meets the following requirements:</td>
</tr>
<tr>
<td></td>
<td>- Pentium 4 - 2.8Ghz CPU (or faster)</td>
</tr>
<tr>
<td></td>
<td>- Monitor and Graphics Card capable of displaying 1280x1024 (or higher) resolution</td>
</tr>
<tr>
<td></td>
<td>- 4 GB (or more) RAM</td>
</tr>
<tr>
<td></td>
<td>- 40 GB (or more) hard disk drive</td>
</tr>
<tr>
<td></td>
<td>- CD/DVD drive</td>
</tr>
<tr>
<td></td>
<td>Make sure that the host computer is actually utilizing the full 4 GB of RAM. If not, exercises can run extremely slow or even stall a process.</td>
</tr>
<tr>
<td>Software</td>
<td>To complete the setup of the host computer, you need the following software, software installation files, and DVD:</td>
</tr>
<tr>
<td></td>
<td>- SUSE Linux Enterprise Desktop 11</td>
</tr>
<tr>
<td></td>
<td>- SUSE Linux Enterprise Server 11</td>
</tr>
<tr>
<td></td>
<td>You use this software to create the DA1 and DA-SLED virtual machines.</td>
</tr>
<tr>
<td></td>
<td>- VMware Player 2.5.x</td>
</tr>
<tr>
<td></td>
<td>- Adobe Reader 9.x</td>
</tr>
<tr>
<td></td>
<td>- SUSE Linux Enterprise 11 Fundamentals Course DVD</td>
</tr>
<tr>
<td></td>
<td>The Course DVD contains software and files needed for setup and exercises.</td>
</tr>
<tr>
<td></td>
<td>- Imaging Software</td>
</tr>
</tbody>
</table>
Install and Configure VMware Player

To make use of the Virtual Machines provided for this course, you need to have VMware Player (or VMware Workstation) installed on the host machine. Since VMware Player is a free download from http://www.vmware.com, we use that application throughout the course.

1. If you’re installing VMware on a SLED workstation, use the Software Management module in YaST to install the C/C++ Compiler and Tools pattern, as shown below:

2. Install VMware Player on your host workstation.

   NOTE: The course virtual machines are configured to run in Host-Only mode, preventing them from communicating on your physical network segment.

3. If you’re running Windows XP, configure your Windows Firewall to allow PING requests:
   a. Select Start > Control Panel > Windows Firewall.
   b. Select the Advanced tab.
   c. In the ICMP field, select Settings.
   d. Select Allow incoming echo request.
   e. Select OK > OK.
Copy the Virtual Machines to the Host Computer

You need to copy the DA1 and DA-SLED virtual machines from the Course DVD to the host machine. To do that, do the following:

1. Insert the SUSE Linux Enterprise 11 Fundamentals Course DVD into the DVD drive.
2. Browse to the VMs directory on the Course DVD.
3. Extract the DA1.zip directory to the default virtual machine path on the Host machine.
4. Open VMware Player and select Open (or Open an existing Virtual Machine); then browse to and select the default_virtual_machine_path\DA1\DA1.vmx file.
   - The DA1 Virtual Machine opens and starts up.
5. Repeat steps 3 and 4 for the DA-SLED virtual machine.
6. The Virtual Machines are now ready for use in the course.

Test Connectivity Between DA1 and DA-SLED

Once the virtual machines have been copied to your host machine, you need to test the network configuration to be sure that they can connect to each other.

Test connectivity by doing the following:

1. From the DA1 virtual machine log in prompt, log in as root with a password of novell.
2. From the DA1 machine desktop, right click an open area of the desktop and select Open in Terminal.
3. At the command prompt, enter the following:
   ```
   ping -c4 172.17.8.100
   ```
   You should see four successful ping attempts.
4. At the command prompt, type exit and press Enter.
5. Repeat steps 1 and 2 for the DA-SLED virtual machine.
6. At the command prompt, enter the following:
   ```
   ping -c4 172.17.8.101
   ```
   You should see four successful ping attempts.
7. At the command prompt, type exit and press enter.
8. Shut down and power off each of the virtual machines.
Create the DA1 and DA-SLED Machines Manually

If you would rather create the DA1 and DA-SLED machines yourself, do the following:

NOTE: In order to complete the following steps, you will need VMware Workstation installed on the host machine.

- “Create and Install the DA-SLED SUSE Linux Enterprise Desktop 11 Virtual Machine” on page 13
- “Create and Install the DA1 SUSE Linux Enterprise Server 11 Virtual Machine” on page 18

Create and Install the DA-SLED SUSE Linux Enterprise Desktop 11 Virtual Machine

To install SUSE Linux Enterprise Desktop, do the following:

- “Part 1: Create the DA-SLED Virtual Machine” on page 13
- “Part 2: Boot the System and Start the Installation” on page 14
- “Part 3: Adjust Settings for Exercises” on page 16
- “Part 4: Install VMware Tools on DA-SLED” on page 16
- “Part 5: Copy Wallpaper Files to DA-SLED” on page 17
- “Part 6: Shrink the DA-SLED Virtual Machine” on page 17

Part 1: Create the DA-SLED Virtual Machine

To create a new virtual machine, do the following:

1. Insert the SUSE Linux Enterprise Desktop 11 Product DVD.
2. Start VMware Workstation; then click File > New > Virtual Machine.
3. In the Welcome and Configuration Screen, verify that Typical is selected; then click Next.
4. From the Guest Operating System Installation screen, make sure that Installer disc is selected and that the SUSE Linux Enterprise Desktop 11 Product DVD appears in the Device drop-down list.
5. Click Next.
6. (Conditional) If the Operating System is not detected, a Guest Operating System page is displayed. Do the following:
   a. In the Select a Guest Operating System screen, select Linux.
   b. In the Version drop-down menu, select SUSE Linux Enterprise Server 10; then select Next.
7. In the Virtual machine name field, on the Name the Virtual Machine screen, enter DA-SLED; then click Next.
8. In the Specify Disk Capacity Screen, increase the disk size to 10.0 GB.
9. Select Split virtual disk into 2 GB files; then click Next.
10. From the Ready to Create Virtual Machine dialog, click Customize Hardware.
    A Hardware window appears.
11. With the Memory category selected, enter a memory size of 512 MB.
12. Select the Network Adapter category.
13. In the panel on the right, select the Host-only connection type.
14. Finalize the changes and continue by clicking OK.
    You are returned to the New Virtual Machine Wizard.
15. Click Finish.
    The Virtual Machine starts up and you are presented with the GRUB installation menu.

Part 2: Boot the System and Start the Installation

To start the installation, do the following:

1. When the virtual machine starts, press Ctrl+g or click inside the VM to direct input to the VM.
2. From the installation menu, select Installation; then press Enter.
3. From the Welcome screen, in the Language and Keyboard Layout drop down menu, select your language.
4. On the same page, select I Agree to the Licence Terms; then select Next.
5. From the Media Check dialog, select Next.

NOTE: If you choose to check your installation media, be aware that this can take some time.

6. Select New installation; then uncheck (deselect) Use Automatic Configuration.
7. Click Next.
8. From the Clock and Time Zone screen, select your region and time zone.
9. Uncheck (deselect) Hardware Clock Set To UTC; then click Next.
10. Add a local user by entering the following:
    ■ User’s Full Name: Geeko Chameleon
    ■ Username: geeko.
    ■ Password: novell.
- Confirm Password: novell.
- Click the Use this password as system administrator box; (this sets the root password as novell) then click Next.
- Confirm the two warning messages by clicking Yes.

NOTE: You should use an insecure password (such as novell) only for the purpose of training. Choose a more secure password on a live system.

11. From the Installation Settings screen, click the Software link.
    A Software Selection and System Tasks screen appears.
12. Click Details.
13. From the Filter drop-down list (top left corner), select Search.
14. In the Search field, type gcc; then click Search.
15. From the list on the right, select gcc.
16. In the Search field, type kernel source; then click Search.
17. From the list on the right, select kernel-source.
18. In the Search field, type ruby; then click Search.
19. From the list on the right, select ruby.
20. Click Accept.
21. Accept all license agreements by clicking Accept.
22. From the Changed Packages dialog, click Continue.
    You are returned to the Installation Settings screen.
23. Click Install.
24. From the Confirm Installation dialog, click Install.
    The installation process begins. This can take several minutes to complete.
25. From the Hostname and Domain Name screen, enter the following:
    - Hostname: DA-SLED
    - Domain Name: digitalairlines.com
26. Deselect (uncheck) Change Hostname via DHCP.
27. Leave Write Hostname to /etc/hosts selected.
28. Click Next.
29. From the Network Configuration screen, under the Firewall category, click the disable link.
30. Click the Network Interfaces link.
    A Network Settings Configuration screen appears.
31. Make sure the 79c970 card is selected; then click Edit.
32. From the Network Settings Setup screen, select **Statically assigned IP Address**.
33. Enter the following:
   - IP Address: **172.17.8.100**
   - Subnet Mask: **255.255.0.0**
   - Hostname: **DA-SLED**
34. Click **Next**.
35. Click **OK**.
   - You are returned to the Network Configuration screen.
36. Click **Next**.
37. From the Test Internet Connection screen, select **No, Skip This Test**; then click **Next**.
38. Read the Release Notes; then click **Next**.
39. From the Hardware Configuration Screen, click **Next**.
40. From the Installation Completed screen, select **Finish**.
   - The system now reboots and loads the GNOME desktop.

**Part 3: Adjust Settings for Exercises**

Adjust password settings in YaST to allow for simple passwords:
1. Log in as **root**, with a password of **novell**.
2. From the **Computer** menu, select **YaST > Security and Users > Local Security >Password Settings**.
3. Uncheck **Check New Passwords** and **Test for Complicated Passwords**.
4. In the **Minimum Acceptable Password Length** field, reduce the number to 0; then click **OK**.
5. Close the **YaST** window.
6. Right-click the DVD icon and select **Eject Volume**.
7. Remove the **SUSE Linux Enterprise Desktop 11 Product DVD** from the drive.

**Part 4: Install VMware Tools on DA-SLED**

To install VMware tools on DA-SLED, do the following:
1. From the VMware Workstation menu, select **VM > Install VMware Tools**.
   - A File Browser window appears.
2. Double-click the **VMwareTools-7.8.x-126130.i386.rpm** file.
   - A YaST2 dialog appears and then disappears when the installation is complete.
3. Right-click an open area of the desktop; then select **Open In Terminal**.
4. At the command prompt, enter the following:
   ```bash
   vmware-config-tools.pl
   ```

5. When asked if you want the program to try to build the vmmectl module, enter `yes`.

6. (Conditional) If asked if you want to override the kernel compiler version, enter `yes`.

7. Press **Enter** at each of the prompts until you reach the prompt asking you to select a resolution.

8. Enter the **number** that corresponds with 1024 x 768.

9. When the installation is complete, close the terminal window by entering `exit`.

10. Close the File Browser window.

11. Right-click the **VMware Tools** CD icon; then select **Eject Volume**.

12. Select **Computer > Logout > Log Out**.

13. Log in as **geeko** with a password of **novell**.

**Part 5: Copy Wallpaper Files to DA-SLED**

To successfully complete the exercises in this course, you need to copy the wallpaper files from the **SUSE Linux Enterprise 11 Fundamentals Course DVD** to DA-SLED. Do the following:

1. Log out and then log in as **root** with a password of **novell**.

2. Insert the **SUSE Linux Enterprise 11 Fundamentals Course DVD**.

3. From the DA-SLED machine, in the File Browser window, right-click the **setup>Wallpaper** directory.

4. From the menu, select **Copy**.

5. From the File Browser, browse to the **/home/geeko/Documents** directory.

6. Right-click an empty space in the right pane and select **Paste**.

7. When the files have finished copying, close all open windows and eject the DVD.

**Part 6: Shrink the DA-SLED Virtual Machine**

Before DA-SLED is ready for the classroom, use VMware Toolbox to shrink the size of the .vmdk virtual hard disk file.

1. From the DA-SLED virtual machine, press **Alt + F2**.
   
   A Run Application dialog box appears.

2. Enter **vmware-toolbox**; then click **Run**.
   
   A VMware Tools Properties dialog appears.
3. Click the **Shrink** tab; then select the / (root) partition in the list and click **Shrink**.

   A dialog appears asking if you want to prepare to shrink the disk.

4. Prepare the disk for shrinking by clicking **Yes**.

   VMware Toolbox prepares the .vmdk file for shrinking, and then asks if you want to shrink the disk.

5. Shrink the partition by clicking **Yes**.

   A dialog appears tracking the progress of shrinking the DA-SLED.vmdk file (this can take several minutes).

   When the process is complete, a success dialog appears.

6. Close the dialog by clicking **OK**.

7. Close the VMware Tools Properties dialog by clicking **Close**.

At this point, you should shut down and power off the DA-SLED machine; then copy the virtual machine files to a backup directory for safe-keeping.

**Create and Install the DA1 SUSE Linux Enterprise Server 11 Virtual Machine**

To install SUSE Linux Enterprise Server on a virtual machine, do the following:

- “Part 1: Create the DA1 Virtual Machine” on page 18
- “Part 2: Boot the System and Start the Installation” on page 19
- “Part 3: Check Keyboard Layout and Install Software Packages” on page 20
- “Part 4: Specify Your Hostname and Domain Name” on page 21
- “Part 5: Configure the Network” on page 21
- “Part 6: Select Local User Authentication and Add a User” on page 21
- “Part 7: Finish the Installation” on page 22
- “Part 8: Install VMware Tools on DA1” on page 22
- “Part 9: Copy Wallpaper Files to DA1” on page 23
- “Part 10: Create an Installation Source on DA1” on page 23
- “Part 11: Shrink the DA1 Virtual Machine” on page 24

**Part 1: Create the DA1 Virtual Machine**

To Create a new virtual machine do the following:

1. Insert the **SUSE Linux Enterprise Server 11 Product DVD**.

2. Start VMware Workstation; then select **File> New> Virtual Machine**.

3. In the Welcome and Configuration Screen, verify that **Typical** is selected; then select **Next**.
4. From the Guest Operating System Installation screen, make sure that Installer disc is selected and that the SUSE Linux Enterprise Server 11 Product DVD appears in the Device drop-down list.

5. Select Next.

6. (Conditional) If the Operating System is not detected, a Guest Operating System page is displayed. Do the following:
   a. In the Select a Guest Operating System screen, select Linux.
   b. Under the Version drop down menu, select SUSE Linux Enterprise Server 10; then select Next.

7. In the Name the Virtual Machine screen, in the Virtual machine name field, type DA1; then select Next.

8. In the Specify Disk Capacity Screen, increase the disk size to 10.0 GB.

9. Make sure that Split virtual disk into 2 GB files is selected; then click Next.

10. From the Ready to Create Virtual Machine dialog, click Customize Hardware. A Hardware dialog appears.

11. With the Memory category selected, enter a memory size of 512 MB.

12. Select the Network Adapter category.

13. In the panel on the right, select the Host-only connection type.

14. Finalize the changes and continue by clicking OK.

    You are returned to the New Virtual Machine Wizard.

15. From the Ready to Create Virtual Machine dialog, click Finish.
    
    The Virtual Machine starts up and you are presented with the GRUB installation menu.

**Part 2: Boot the System and Start the Installation**

To boot the system and start the installation, do the following:

1. When the virtual machine starts, press Ctrl+g or click inside the VM to direct input to the VM.

2. From the installation menu, select Installation; then press Enter.

3. From the Welcome screen, verify that your language is selected in the Language and Keyboard Layout drop-down menus.

4. From the Novell Software License Agreement dialog on the same page, select I Agree to the Licence Terms; then select Next.

    NOTE: You may choose to check the media before proceeding, but be aware that this process can take quite a while.

5. From the Media Check dialog, select Next.
6. From the Installation Mode screen, select New installation; then select Next.

7. From the Clock and Time Zone screen, select your region and time zone; then select Next.

8. From the Server Base Scenario Screen, select Physical Machine; then select Next.

**Part 3: Check Keyboard Layout and Install Software Packages**

To check your keyboard layout and install software packages, do the following:

1. In the Overview tab, in the Keyboard Layout section, verify that your keyboard layout is selected.

2. (Conditional) If the correct keyboard layout is not selected, from the Change drop-down list, select Keyboard Layout; then select the correct layout and select Accept.

3. In the Overview tab, select Software.

4. In the Software Selection and System Task screen, select Details...

5. From the Filter drop-down menu in the upper left corner, select Search.

6. In the Search field, enter gcc and click Search.

7. In the window on the right, check gcc.

8. In the Search field, enter ruby.

9. In the window on the right, check ruby.

10. In the search field, enter kernel-source and click Search.

11. In the window on the right, check kernel-source; then click Accept.

12. In the Confirm Package License: agfa-fonts window, click I Agree.

13. In the Changed Packages window, click Continue.

14. Confirm the installation settings by selecting Install.

15. In the YaST2 Confirm Installation window, select Install.

   After copying files and finishing a basic installation, YaST reboots your computer to a Password for “root” dialog.

16. Specify the root password by entering novell (twice); then select Next.

17. Confirm the two warning messages by selecting Yes.

**WARNING:** You should use an insecure password (such as novell) only for the purpose of training. Choose a more secure password on a production system.
Part 4: Specify Your Hostname and Domain Name

To specify your Hostname and Domain Name, do the following:

1. In the Hostname field, enter DA1.
2. In the Domain Name field, enter digitalairlines.com.
3. Deselect (uncheck) Change Hostname via DHCP and select (check) Write Hostname to /etc/hosts; then click Next.

Part 5: Configure the Network

To configure the network, do the following:

1. Verify that the Use Following Configuration button is selected.
2. Under the Firewall heading, disable the Firewall by selecting disable next to the line “Firewall is enabled” (changes to “Firewall is disabled”).
3. Click the Network Interfaces link.
   A Network Settings Configuration screen appears.
4. Make sure the 79e970 card is selected; then click Edit.
5. From the Network Settings Setup screen, select Statically assigned IP Address.
6. Enter the following:
   - IP Address: 172.17.8.101
   - Subnet Mask: 255.255.0.0
   - Hostname: DA1
7. Click Next.
8. Click OK.
   You are returned to the Network Configuration screen.
9. From the Network Configuration screen, select Next.
10. In the Test Internet Connection screen, select No, Skip This Test; then click Next.

NOTE: You should install the updates on production systems. You do not install the updates during training, because the updates might change menus and user interfaces. You also need a maintenance contract with Novell to get updates for SUSE Linux Enterprise Server 11.

11. In the Installation Overview screen, make sure that Use Following Configuration is selected; then select Next.

Part 6: Select Local User Authentication and Add a User

1. In the User Authentication Method dialog, select Local (/etc/passwd); then select Next.
2. Add a local user by entering the following:
   User’s Full Name: **Geeko Chameleon**
   Username: **geeko**
   Password: **novell**
   Confirm Password: **novell**

3. When you finish, select **Next**.

4. Confirm the two warning messages by selecting **Yes**.

   **NOTE**: You should use an insecure password (such as novell) only for the purpose of training. Choose a more secure password on a live system.

YaST starts configuring your SUSE Linux Enterprise Server 11 system.

### Part 7: Finish the Installation

To finish the installation, do the following:

1. Confirm the release notes by selecting **Next**.

2. In the Hardware Configuration screen, verify that **Use Following Configuration** is selected; then select **Next**.

3. Deselect (uncheck) **Clone This System for Autoyast** and select **Finish**.
   
   The GUI login screen appears.

4. Log in as **root** with a password of **novell**.

5. Right-click the DVD icon and select **Eject Volume**.

6. Remove the **SUSE Linux Enterprise Server 11 Product DVD** from the drive.

### Part 8: Install VMware Tools on DA1

To install VMware tools on DA1, do the following:

1. From the VMware Workstation menu, select **VM > Install VMware Tools**.
   
   A File Browser window appears.

2. Double-click the **VMwareTools-7.8.x-x.i386.rpm** file.
   
   A YaST2 dialog appears and then disappears when the installation is complete.

3. Right-click an open area of the DA1 desktop; then select **Open In Terminal**.

4. At the command prompt, enter the following:

```
vmware-config-tools.pl
```

5. When asked if you want the program to try to build the vmmectl module, enter **yes**.
6. (Conditional) If asked to override the kernel compiler version, enter yes.
7. Press Enter at each of the prompts until you reach the prompt asking you to select a resolution.
8. Enter the number that corresponds with 1024 x 768.
9. When the installation is complete, close the terminal window by entering exit.
10. Close the File Browser window.
11. Right-click the VMware Tools CD icon; then select Eject Volume.
13. Log in as geeko with a password of novell.

Part 9: Copy Wallpaper Files to DA1

To successfully complete the exercises in this course, you need to copy the wallpaper files from the SUSE Linux Enterprise 11 Fundamentals Course DVD to DA1. Do the following:

1. Insert the SUSE Linux Enterprise 11 Fundamentals Course DVD into the DVD drive of the host machine.
2. From the DA1 machine, in the File Browser window, right-click the setup>Wallpaper directory.
3. From the menu, select Copy.
4. From the File Browser, browse to the /home/geeko/Documents directory.
5. Right-click an empty space in the right pane and select Paste.
6. When the files have finished copying, close all open windows and eject the DVD.

Part 10: Create an Installation Source on DA1

To complete the exercise in section 8, you need to set up DA1 as an installation source. Do the following:

1. Log out and log in as root with a password of novell.
2. Insert the SUSE Linux Enterprise Server 11 Product DVD is in the drive.
3. Select Computer > YaST.
4. From the YaST Control Center, select Miscellaneous > Installation Server.
   An Initial Setup -- Servers dialog appears.
5. Make sure that Configure as HTTP Repository is selected; then click the Select Directory button.
   A Select Directory window appears.
6. Browse to /media.
7. Click SUSE_SLES-11-0-0.001; then click Choose.
   You are returned to the Initial Setup -- Servers dialog.

8. Click Next.
   A dialog appears asking you to install the apache2 and apache2-prefork packages.

9. Click Install.
   The packages are installed and an Installation Server -- HTTP dialog appears.

10. In the Directory Alias field, type suse; then click Next.
    An Installation Server dialog is displayed.

   NOTE: The window appears to be blank, as though nothing has been set up, but the repository is active and will work.

11. In the Installation Server window, click Finish.

12. Close any open windows and remove the SLES 11 Product DVD.

Part 11: Shrink the DA1 Virtual Machine

Before DA1 is ready for the classroom, use VMware Toolbox to shrink the size of the .vmdk virtual hard disk file.

1. From the DA1 virtual machine, press Alt + F2.
   A Run Application dialog box appears.

2. Enter vmware-toolbox; then click Run.
   A VMware Tools Properties dialog appears.

3. Click the Shrink tab; then select the / (root) partition in the list and click Shrink.
   A dialog appears asking if you want to prepare to shrink the disk.

4. Prepare the disk for shrinking by clicking Yes.
   VMware Toolbox prepares the .vmdk file for shrinking, and then asks if you want to shrink the disk.

5. Shrink the partition by clicking Yes.
   A dialog appears tracking the progress of shrinking the DA1.vmdk file (this can take several minutes).
   When the process is complete, a success dialog appears.

6. Close the dialog by clicking OK.

7. Close the VMware Tools Properties dialog by clicking Close.

At this point, you should shut down and power off the DA1 server; then copy the DA1 virtual machine files to a backup directory for safe-keeping.
Review VMware Guidelines

To complete the exercises in the course, you use VMware Player with two virtual machines.

How to Navigate in a VMware Virtual Machine Window

If a VMware virtual machine has a current version of VMware Tools installed, you can easily move out of (switch focus to) a virtual machine window by moving the mouse pointer to the host computer desktop.

However, if VMware Tools is not installed (or not updated), you will need to switch (release) mouse and keyboard control to the host computer desktop by pressing Ctrl+Alt (or Ctrl+Shift+Alt).

The following are additional tips for navigating in a virtual machine window:

- **Click to change focus to the virtual machine window**
  To return mouse and keyboard control (change focus) to the VMware virtual machine window, select the VMware virtual machine window (or press Ctrl+G).

- **Use Ctrl+Alt+Insert instead of Ctrl+Alt+Delete**
  Pressing Ctrl+Alt+Insert (or Ctrl+Shift+Alt+Insert) in a VMware virtual machine is the same as pressing Ctrl+Alt+Delete. This is especially important to remember when you are asked to press Ctrl+Alt+Delete to display a login screen.

- **Click and drag to copy files in and out of a virtual machine window**
  If VMware Tools are installed (and updated) on a VMware virtual machine that runs a Windows operating system and if the host computer is also running Windows, you can drag and drop files between the host computer and the virtual machine.

Exercise Conventions

When working through an exercise, you will see conventions which indicate information you need to enter that is specific to your server.

The following describes the most common conventions:

- **italicized/bolded text.** This is a reference to your unique situation, such as the host name of your server.

  For example, if the host name of your server is DA1, and you see the following:

  `hostname.digitalairlines.com`

  you would enter:

  `DA1.digitalairlines.com`

- **10.0.0.xx.** This is the IP address that is assigned to your SUSE Linux Enterprise Server 10 server.
For example, if your IP address is 10.0.0.50, and you see the following:

10.0.0.xx

you would enter:

10.0.0.50

- **Select.** The word *select* is used in exercise steps to indicate choosing an item from a list, a menu, or an interface.

- **Click.** The word *click* is used when the button, link or item is readily apparent and not part of a list or drop-down menu.

- **Enter and Type.** The words enter and type have distinct meanings.

  The word *enter* means to type text in a field or at a command line and press the Enter key when necessary. The word *type* means to type text without pressing the Enter key.

  If you are directed to type a value, make sure you do not press the Enter key; otherwise you might activate a process that you are not ready to start.
SECTION 1 Getting to Know SUSE Linux Enterprise 11

In this section of the workbook, you learn how to do the following:

1. “Perform Five Basic Tasks in Linux” on page 28
2. “Add an Applet to and Remove an Applet from the Bottom Panel” on page 31
3. “Use the GNOME File Manager” on page 32
4. “Access the Command Line Interface” on page 34

Before beginning the exercises, make sure you know how to log in and out of the GNOME desktop by doing the following:

1. In the Username field, enter \texttt{geeko}; then press \texttt{Enter}
2. In the Password field, enter \texttt{novell}; then press \texttt{Enter}
   
   For security reasons, asterisks are displayed instead of the letters when you are entering the password.

   The GNOME desktop environment starts.
3. To log out, open the \texttt{main menu} (labeled Computer) in the bottom panel.
4. Select \texttt{Logout > Log Out}. 
Exercise 1-1  Perform Five Basic Tasks in Linux

In this exercise, you perform five basic tasks on the SUSE Linux Enterprise Desktop 11 machine to help you become familiar with and confident in working with the Linux environment.

You will perform the following tasks:

- “Task 1: Change Your Wallpaper” on page 28
- “Task 2: Change Your Screen Resolution” on page 28
- “Task 3: Change Time and Date Settings” on page 29
- “Task 4: Change Your Password” on page 29
- “Task 5: Create a Desktop Launcher (Shortcut)” on page 29

Task 1: Change Your Wallpaper

From the DA-SLED virtual machine, do the following:

1. Log in as geeko with a password of novell.
2. Right-click the desktop and select Change Desktop Background.
3. From the Appearance Preferences window, on the Background tab, select add.
4. Browse to geeko> Documents >Wallpaper. Double click the SUSENatureMod.jpg image and watch how the background instantly changes.
5. Click Close.
6. Repeat steps 1-5 on the DA1 virtual machine. The file you add from the Wallpaper folder in step 4 is called ReptileSuseMod.jpg

Task 2: Change Your Screen Resolution

From the DA-SLED virtual machine, do the following:

1. Open the main menu (labeled Computer) in the bottom panel.
2. On the right, under the System heading, click Control Center.
3. In the Hardware group, click Screen Resolution.
4. Click on the arrows in the Resolution menu and adjust the resolution to 1024 x 768.
5. Click Apply.
   A dialog appears asking if the display looks OK.
6. Click Keep this configuration.
7. Click Close.
8. Close the Control Center by clicking the X in the top right corner.
Task 3: Change Time and Date Settings

From the DA-SLED machine, do the following:

1. Open the main menu (labeled Computer) in the bottom panel.
2. On the right, under the System heading, click Control Center.
3. In the System group, click Date and Time.
4. Authenticate as the root user (Administrator). Type novell then click Continue.
5. Select the appropriate Region and Time Zone settings for your location, then click OK.
   SUSEConfig runs and the changes are made. You are returned to the Control Center.
6. Close the Control Center by clicking the X in the top right corner.

Task 4: Change Your Password

From the DA-SLED virtual machine, do the following:

1. Open the main menu (labeled Computer) in the bottom panel.
2. On the right, under the System heading, click Control Center.
3. In the Personal group, select Change Password.
4. In the Change Password window, enter novell in the Old Password field.
5. In the New Password field, enter a password of your choosing.
6. Re-enter your new password in the Confirm Password field; then click OK.
   A dialog appears indicating that the password was changed successfully.
7. Click OK.
8. Verify that your new password works by logging out and the logging in as geeko with the new password.
9. Repeat steps 1-8 to change your password back to novell.

Task 5: Create a Desktop Launcher (Shortcut)

In this exercise you will create a shortcut (called a desktop launcher in Linux). To do this you must know the path to the application.

From the DA-SLED virtual machine, do the following:

1. Open the Pidgin instant messaging application:
   - Open the Computer menu in the bottom panel.
   - Click More Applications.
   - In the Communicate group, click Pidgin.
The Pidgin application opens.
- Close the application.

You will create a launcher for this application

2. Determine the correct path to the pidgin application.
- Right-click the desktop and select **Open In Terminal**.
- At the Command prompt (`geeko@DA-SLED:~/Desktop> `), enter **which pidgin**.
  
The path `/usr/bin/pidgin` is displayed.
- Close the terminal window by entering `exit`.

This is the path you will need to create your launcher.

3. Create the Desktop Launcher.
- Right-click the desktop and select **Create Launcher**.
- In the **Name** field, enter `Pidgin`.
- In the **Command** field, enter `/usr/bin/pidgin`.
  
  If you have entered the path correctly, the purple **Pidgin** icon will appear in the upper left-hand corner of the window.
- Click **OK**.

  The Pidgin icon now appears on the Desktop.

4. Open the F-Spot photo manager application:
- Open the **Computer** menu in the bottom panel.
- Under Favorite Applications, click **F-Spot**.
  
  The F-Spot application opens.
- Close the application.

5. Repeat steps 2 and 3 to create a desktop launcher for **F-Spot** using the following parameters:
- Launcher Name: **F-Spot**
- Command path: `/usr/bin/f-spot`

**NOTE:** When using the `which` command at the command prompt, enter lower-case letters to find the correct path. For example, when searching for the location of F-Spot, enter `which f-spot`.

*(End of Exercise)*
**Exercise 1-2 Add an Applet to and Remove an Applet from the Bottom Panel**

From the **DA-SLED** virtual machine, do the following:

1. Right-click a free space in the bottom panel.

2. From the pop-up menu, select **Add to Panel**.
   
   An Add to Panel dialog appears.

3. From the list, select **System Monitor** and then click **Add**.

   A System Monitor icon is added to the Bottom Panel.

4. Close the **Add to Panel** dialog.

5. Double-click the System Monitor icon to view the **System Monitor** tool.

6. Close the System Monitor by clicking **Monitor > Quit**.

7. Remove the **System Monitor** applet from the Bottom Panel:
   
   a. Right-click the **System Monitor** applet on the Bottom Panel.

   b. From the pop-up menu, select **Remove From Panel**.

(End of Exercise)
Exercise 1-3  Use the GNOME File Manager

In this exercise, you explore your GNOME desktop. Use Nautilus to copy the /etc/DIR_COLORS file into your home directory and add the Oh no! emblem to the copied file. Then, rename the copied file to example.txt. Finally, delete example.txt and empty the trash.

This exercise is performed on the DA-SLED virtual machine.

Part 1: Start Nautilus and Copy a File

To start Nautilus and copy a file, do the following:

1. Make sure you are logged in to DA-SLED as geeko with a password of novell.
2. Start the Nautilus file manager by double-clicking the geeko’s Home icon on the desktop.
3. View the file system tree in the side panel by opening the menu at the top of the side panel (labeled Places when Nautilus is started the first time).
4. From the menu, select Tree.
5. View the contents of the /etc directory by selecting the small triangle in front of the File System entry in the side panel.
6. In the side panel, click etc.
7. Copy the /etc/DIR_COLORS file onto the desktop:
   a. Scroll down to the DIR_COLORS file icon.
   b. While holding the Ctrl key, drag the icon onto the desktop, then release the mouse button.
8. Switch back to your home directory by selecting Home Folder in the side panel.
9. Move the DIR_COLORS file from the desktop into your home directory:
   a. Click the DIR_COLORS file icon and drag it over the right frame of the Nautilus window.

   IMPORTANT: Notice there is no small plus at the mouse pointer while dragging the file, indicating that you are moving a file.
   b. Release the mouse button.

Part 2: Add an Emblem to the Copied File Icon

To add an emblem to the copied file icon, do the following:

1. Switch to the list of emblems by opening the menu at the top of the side panel (labeled Tree now).
2. From the menu, select Emblems.
3. Scroll down to the Important icon.

4. Drag the Important icon over the DIR_COLORS file icon in the right frame, and release the mouse button.

**Part 3: Rename the Copied File**

To rename the copied file, do the following:

1. Rename the copied file by right-clicking the DIR_COLORS file icon, and then selecting Rename from the popup menu.

2. For the new filename, type example.txt; then press Enter.

**Part 4: Delete the Copied File**

To delete the copied file, do the following:

1. Delete the example.txt file by dragging the file icon over the Trash icon on the desktop, and releasing the mouse button.

2. Close the Nautilus file manager window.

3. Right-click the Trash icon on the desktop and select Empty Trash from the popup menu.

4. In the confirmation dialog, select Empty Trash.

5. Delete the DIR_COLORS file from the desktop by repeating steps 1-4.

(End of Exercise)
**Exercise 1-4  Access the Command Line Interface**

In this exercise you perform three basic command line tasks.

This exercise is performed on the DA-SLED virtual machine.

**Part 1: Check IP Address of each machine**

1. Access the command line by right-clicking the desktop and selecting **Open In Terminal**.

2. Switch to root user by entering **su**.
   
   *su* stands for “switch user”. It is a Linux command used to run the shell of another user without logging out. It is commonly used to change to root user permissions for administrative work without logging off and back on; it is also used to switch to other users in the same way.

3. Enter **novell** as the password.

   NOTE: When you enter a password in the command line, you will not see any characters as you type them in. The entire field is left blank for your security rather than showing asterisks or bullets.

4. Enter **ip address show**.
   
   Your IP address is displayed in the second line: **inet 172.17.8.100**.

5. Repeat these steps on the DA-1 server to get the inet address:172.17.8.101.

**Part 2: Open Communication Between Desktop and Server**

To communicate from one machine to the other, do the following:

1. From the DA-SLED command prompt, enter the following:
   
   **ping 172.17.8.101 -c4**

   NOTE: Adding **-c4** at the end or beginning of the ip address will limit the communication to four transfers.

   The connection is now tested. The results are displayed in the terminal. An example of this is:
   
   **64 bytes from 172.17.8.101: icmp_seq=1 ttl=128 time=0.251 ms**

2. From the DA1 server command prompt, enter the following:
   
   **ping 172.17.8.100 -c4**

   The results are displayed in the terminal window.
Part 3: Check and Change Hostname

To check the Hostname of your computer do the following:

1. From the DA-SLED command prompt, enter the following:
   
   `hostname`
   
   Your hostname is revealed on the next line.

To change the Hostname, do the following:

1. In the command line, switch to root user by entering `su`.
2. Enter `hostname DA2`.
   
   The hostname is now changed.
3. Check to see this has worked by entering `hostname`.
4. Close the terminal window by entering `exit`.

NOTE: The hostname is reset when you restart the computer.

(End of Exercise)
SECTION 2  Locate and Use Help Resources

In this section of the workbook, you learn how to do the following:

1. “Access and Use man Pages on DA1” on page 38
2. “Access and Use info Pages on DA1” on page 39
4. “Find Help on the Web on DA1” on page 42
**Exercise 2-1 Access and Use man Pages on DA1**

In this exercise, use the `whatis` and `man` commands and navigate through the help text. Find out how often the man pages of the `info` command contain the word `filename`.

This exercise is performed on the DA1 server.

1. Log in as `geeko` with password `novell`.
2. Right-click on the GNOME desktop, and select `open in terminal`.
3. Find the sections of the man pages for the `info` command by entering `whatis info`.
4. Read the first section (userq commands) of the man pages of the `info` command by entering `man 1 info`.
5. To look for “filename,” enter `/filename`.
6. Scroll through the text with the up and down arrow keys.
7. When you finish viewing the information, exit (quit) the man page by typing `q`.

*(End of Exercise)*
Exercise 2-2  Access and Use info Pages on DA1

In this exercise, use the info command and navigate through the info text.

This exercise is performed on the DA1 server.

1. From the terminal window, display the info pages for the info command by entering info info.
2. Move the cursor to the first reference (Getting Started) by pressing Tab.
3. Follow the reference by pressing Enter.
4. Move the cursor to the reference Quitting Info by pressing Tab nine times.
5. Follow the reference by pressing Enter.
6. Return to the page Getting Started by typing l (lowercase L).
7. Exit the info file by typing q.
8. Close the terminal window.

(End of Exercise)
Exercise 2-3  Access Release Notes and White Paper Pages on DA1

In this exercise, you access release notes and white paper pages. First, access the HTML version of the release notes. Then, install the HTML howtos. Finally, access the howto of the DSL configuration.

This exercise is performed on the DA1 server.

Task I: Access Release Notes

To access release notes, do the following:

1. Start the file manager Nautilus by selecting the geeko’s Home on the desktop.
2. Double-click the File System icon.
3. Double-click the usr icon.
4. Double-click the share icon.
5. Double-click the doc icon.
6. Double-click the release-notes icon.
7. Double-click the SUSE_Linux_Enterprise_Server_11 icon.
8. Double-click the RELEASE-NOTES.en.html icon.
   The Firefox web browser starts.
11. Close the Nautilus window.

Task II: Install Howtos

To install howtos, do the following:

1. From the GNOME desktop, open the main menu.
2. Select More Applications.
3. Enter ya into the Filter text box.
4. Select the YaST icon to start YaST.
5. Enter the root password novell in the appearing dialog; then select Continue or press Enter.
   The YaST Control Center appears.
6. From the YaST Control Center, select Software > Software Management.
7. From the Filter drop-down list, select Search.
8. In the Search text box enter howto (no space); select Search.
9. From the right side of the window, select the howtoenh package.
10. Select Accept.
11. (Conditional) If requested by YaST, insert the appropriate SUSE Linux Enterprise Server 11 Product DVD; then select OK.

12. When asked to install or remove more packages, select No.

13. Close the YaST Control Center by selecting Close.

14. (Conditional) If you installed the howtos from DVD, remove the DVD from your drive.

Task III: Access Howtos

To access howtos, do the following:
1. Start the file manager Nautilus by selecting the geeko’s Home on the desktop.
2. Click the File System icon.
3. Click the usr icon.
4. Click the share icon.
5. Click the doc icon.
6. Click the howto icon.
7. Click the en icon.
8. Click the html icon.
9. Click the DSL-HOWTO icon.
10. Click the index.html icon.

The Firefox web browser starts.

11. Close the Firefox window.
12. Close the Nautilus window.

(End of Exercise)
Exercise 2-4  Find Help on the Web on DA1

IMPORTANT: This exercise can only be successfully performed if the instructor or training center has provided internet connectivity to the host machines.

In this exercise, you learn how to find help on the web: First you look for updates for SUSE Linux Enterprise Server 10 on the Novell support web site. Then, you use the Google Linux search engine to find information on GNOME and SLES11 on the internet.

This exercise is performed on the Host machine.

Task I: Look for Patches at the Novell Web site

To look for patches at the Novell web site, do the following:

1. Open an internet browser.
2. In the Location bar enter support.novell.com. The Novell support home page appears.
3. Select download > patches in the left column.
4. Under Update your Linux System > SUSE Patch Support Database, select Enter the PSDB.
5. Select by product.
6. Select SUSE Linux Enterprise Server 11. Then select SUSE Linux Enterprise Server 11 for x86. You get a list of patches. You must have a registered SUSE product with upgrade protection in order to access the patch downloads.

Task II: Use Google to Find Information

To use Google to find information, do the following:

1. In the address field, enter www.google.com/linux
2. In the text field at the top of the page, enter gnome and sles11
3. Select Search.
4. Select one or more of the displayed links.
5. When you finish, close the browser.

(End of Exercise)
SECTION 3  Manage the Linux File System

In this section of the workbook, you learn how to do the following:

1. “Explore the SUSE Linux File System Hierarchy” on page 44
2. “Change Directories and List Directory Contents” on page 46
3. “Create and View Files” on page 47
4. “Perform Multiple File Operations” on page 49
5. “Find Files on Linux” on page 52
6. “Search File Content” on page 54
7. “Manage Folders with Nautilus” on page 55
**Exercise 3-1  Explore the SUSE Linux File System Hierarchy**

By default, a DVD is mounted at /media/mountpoint. In this exercise, find out the mount point of the DVD. Then mount the DVD manually at another position (/mnt) in the file system.

This exercise is performed on the DA1 server.

1. Log in as root on DA1, with password novell.
2. Describe what directories the following characters refer to:
   - `/`
   - `~`

3. From the main menu, select More Applications.
4. In the Filter text box, enter term.
5. Select the Gnome Terminal icon to start a terminal emulation.
6. Insert a SUSE Linux Enterprise Server 11 Product DVD into your DVD-ROM drive.
   A Nautilus windows appears, showing the content of the DVD. Note the name of the directory used for mounting here:

7. Display the content of the /media/mountpoint/ directory by entering
   ```bash
   ls /media/mountpoint
   ```
   The content of the DVD is listed.

8. Unmount the DVD by entering
   ```bash
   umount /media/mountpoint
   ```
   The DVD icon disappears from the desktop.

9. Mount the DVD manually by entering
   ```bash
   mount /dev/dvd /mnt
   ```

10. Display the contents of the /mnt directory by entering
    ```bash
        ls /mnt
    ```
    The contents of the DVD are listed.

11. To unmount the DVD manually, enter
    ```bash
        umount /mnt
    ```
    Then push the Eject button.

12. Display the content of the /mnt directory by entering
    ```bash
        ls /mnt
    ```
The directory is now empty.

13. Close the terminal window by entering 

exit

(End of Exercise)
Exercise 3-2  Change Directories and List Directory Contents

In this exercise, you learn how to use the cd, pwd, and ls command: Change the current directory and list the directory contents.

This exercise is performed on the DA-SLED virtual machine.

1. Make sure you are logged in as geeko, with password novell.
2. Describe what directories the following characters refer to:
   - .:
   - ..:

3. From the main menu, select the Gnome Terminal icon to start a terminal emulation.
4. Change to the /tmp directory by entering cd /tmp
5. Display the name of the active directory by entering pwd
6. Change to the home directory by entering cd
7. Display the name of the active directory by entering pwd
8. Change to the /usr/share/doc directory by entering cd /usr/share/doc
9. Display the name of the active directory by entering pwd
10. Change back to the last directory (home) by entering cd -
11. Display the name of the active directory by entering pwd
12. Display the content of the current directory by entering ls
13. Display the content of the current directory, including the hidden files, by entering ls -a
14. View the permissions and the file size of all the files in the current directory by entering ls -la
15. Close the terminal window by entering exit

(End of Exercise)
**Exercise 3-3  Create and View Files**

In this exercise, create an empty file and view the content of a file. Use the `touch`, `cat`, `less`, `head`, and `tail` commands.

This exercise is performed on the **DA-SLED** virtual machine.

1. Open a GNOME terminal window from the **main menu**.
2. Create a new empty file by entering
   ```bash
   touch new_file
   ```
3. Open another terminal window and log in as root (`su -`) with a password of **novell**.
4. Display the content of the `/var/log/messages` file by entering
   ```bash
   cat /var/log/messages
   ```
5. Display the content of `/var/log/messages` page-by-page by entering
   ```bash
   less /var/log/messages
   ```
6. Find the first occurrence of the word “root” by entering
   ```bash
   /root
   ```
7. Find the next occurrence of the word “root” by typing `n`.
8. Navigate through the output by using the cursor keys and the **Page Up** and the **Page Down** keys.
9. Quit the display and return to the command line by typing `q`.
10. Display the first 5 lines of the `/var/log/messages` file by entering
    ```bash
    head -n 5 /var/log/messages
    ```
11. View a continuously updated display of the last lines of the `/var/log/messages` file by entering
    ```bash
    tail -f /var/log/messages
    ```
12. Arrange the terminal windows on the desktop so that you can see the content of both.
13. In the first terminal window you opened in Step 2, log in as root (`su -`); then enter an invalid password (such as **suse**).
    Notice that the second login attempt is logged in the first terminal window.
14. In the first terminal window, log in as root (`su -`) with a password of **novell**.
    The login is logged in the first terminal window.
15. Log out as root in the first terminal window by entering **exit**.
16. Close the first terminal window by entering **exit**.
17. Stop the tail process in the second terminal window by pressing **Ctrl+c**.
18. Log out as root by entering `exit`.
19. Close the terminal window.

(End of Exercise)
**Exercise 3-4 Perform Multiple File Operations**

This exercise is performed on the **DA-SLED** virtual machine.

**Part I: Copy and Move Files and Directories**

In this exercise, copy and move files with the `cp` and `mv` command:

1. Make sure you are logged in to DA-SLED as `geeko` with a password of `novell`.
2. Open a terminal window.
3. Rename `new_file` to `my_file` by entering the following:
   ```
   mv new_file my_file
   ```
4. Verify that the file was renamed by entering `ls -l`.
5. Make a copy of `my_file` and name it `my_file1` by entering the following:
   ```
   cp my_file my_file1
   ```
6. Verify that `my_file1` was created by entering `ls -l my*`.
7. Copy the `/usr/bin/rename` and `/usr/bin/tac` files to the `/tmp/` directory by entering the following:
   ```
   cp /usr/bin/rename /usr/bin/tac /tmp
   ```
8. Verify that the files were copied by entering `ls -l /tmp`.
9. Move the `/tmp/tac` file to the home directory (`~`) by entering the following:
   ```
   mv /tmp/tac ~
   ```
10. Verify the move by entering `ls -l`.
11. Move and rename the `/tmp/rename` file to `~/my_file2` by entering the following:
    ```
    mv /tmp/rename ~/my_file2
    ```
12. Verify that the `my_file2` file exists by entering `ls -l`.
13. Copy the complete `/bin/` directory to the home directory with the new directory named `my_dir` by entering the following:
    ```
    cp -r /bin ~/my_dir
    ```
14. Verify that the files were copied by entering `ls -l ~/my_dir`.

**Part II: Create Directories**

In this exercise, create the new `~/my_dir/new_dir` and `~/geeko_dir/empty_dir/` directories with the `mkdir` command.

1. Create a directory named `new_dir` inside the `my_dir` directory by entering the following:
   ```
   mkdir ~/my_dir/new_dir
   ```
2. Verify that the directory was created by entering the following:
ls ~/my_dir

3. Create a directory geeko_dir including a new directory empty_dir by entering the following:

   mkdir -p ~/geeko_dir/empty_dir

4. Verify that geeko_dir was created by entering ls.

5. Verify that empty_dir was created by entering ls geeko_dir.

Part III: Delete Files and Directories

In this exercise, delete files and directories with the rmdir and rm command.

1. Try to remove the ~/geeko_dir directory by entering rmdir geeko_dir.
   
   A message is displayed indicating that the directory cannot be removed. This is because the directory is not empty.

2. Remove the ~/geeko_dir/empty_dir directory by entering the following:

   rmdir geeko_dir/empty_dir

3. Verify that the /empty_dir directory has been removed by entering ls geeko_dir.

4. Remove the ~/geeko_dir directory by entering rmdir geeko_dir.

5. Verify that the directory was removed by entering ls.

6. Remove the ~/my_dir/login file by entering rm ~/my_dir/login.

7. Verify that the file has been removed by entering ls ~/my_dir/login.

8. Remove all files with names that begin with “a” in the /home/my_dir/ directory by entering the following:

   rm -i ~/my_dir/a*

9. Confirm every warning by entering y.

10. Remove the /home/geeko/my_dir/ directory including its content by entering the following:

    rm -r ~/my_dir

11. Confirm every warning by entering y.

12. Verify that the directory has been removed by entering ls ~/my_dir.

Part IV: Link Files

In this exercise, create a symbolic link to the ~/my_file file and a hard link to the ~/my_file1 file with the ln command:

1. Enter the following to create a symbolic link to the my_file file in your home directory:

   ln -s ~/my_file softlink
2. Enter the following to create a hard link to the `my_file1` file in your home directory:

   ```
   ln ~/my_file1 hardlink
   ```

3. Display the links by entering `ls -l`.

   Notice that the symbolic link identifies the file it is linked to.

4. Close the terminal window.

   *(End of Exercise)*
Exercise 3-5 Find Files on Linux

In this exercise, you find files with the `whereis`, `which`, and `find` command, and the GNOME search tool.

This exercise is performed on the DA-SLED virtual machine.

Part I: Use the whereis and which Command

To use the `whereis` and `which` command, do the following:

1. Make sure you are logged in to DA-SLED as `geeko` with a password of `novell`.
2. Open a terminal window.
3. Find the type of the `ll` command by entering `type ll`.
4. Find the manual pages of the `find` command by entering `whereis -m find`.
5. Find the path of the program Firefox by entering `which firefox`.

You should see this output:

```
/usr/bin/firefox
```

Part II: Use the GNOME Search Tool

To use the GNOME search tool, do the following:

1. Start the GNOME search tool from the main menu by going to More Applications > System > Search for Files (GNOME Search Tool).
2. Find all files in the home directory whose names start with “my” by entering `my*` in the Name contains field and clicking Find.
3. Find all files in the `/bin/` directory whose names consist of three characters, do the following:
   a. Enter `???` in the Name contains field.
   b. To search only in the `/bin` directory, open the Look in folder menu; then select Other from the menu.
   c. Select `bin` from the dialog; then click Open.
   d. Click Find to start the search.

   **NOTE:** If no files are listed, right-click the `/bin` folder and select Show Hidden Files. Then try the search again.

4. To find all files in the `/tmp/` directory that were changed or created in the last 24 hours by doing the following:
   a. Enter `*` in the Name contains field.
   b. To search only in the `/tmp` directory, open the Look in folder menu; then select Other from the menu.
   c. Select `tmp` from the dialog; then click Open.
Part III: Use the find Command

To use the find command, do the following:

1. From the terminal window command line, find all files in the home directory whose names start with “my” by entering the following:

   ```
   find ~ -name "my*"
   ```

2. Find all files in the /tmp/ directory that were changed or created in the last 24 hours by entering the following:

   ```
   find /tmp -ctime -1
   ```

(End of Exercise)
Exercise 3-6  Search File Content

In this exercise, you find a special character combination in a file with the `grep` and `egrep` commands.

This exercise is performed on the DA-SLED virtual machine.

Detailed Steps to Complete this Exercise:

1. Make sure the terminal window is still open.

2. Find all HTML headings of hierarchy 2 in the `/usr/share/doc/packages/yast2-users/users.html` file by entering the following (on one line):
   ```
   grep "<h2>" /usr/share/doc/packages/yast2-users/users.html
   ```
   The output may appear similar to this:
   ```
   <h2>Features (SL9/3)</h2>
   <h2>Implementation</h2>
   <h2>The files</h2>
   ```

3. Find all locations in the HTML files of the `/usr/share/doc/packages/yast2-users/` directory that include the word “configuration” by entering the following:
   ```
   grep configuration /usr/share/doc/packages/yast2-users/*.html
   ```

4. Find all locations in the HTML files of all “yast2” directories `/usr/share/doc/packages/yast2-*` that include lines beginning with a number by entering the following:
   ```
   egrep "^[0-9]" /usr/share/doc/packages/yast2-*/*.html
   ```

5. Find all locations in the HTML files of all `/usr/share/doc/packages/yast2-*` directories that include lines beginning with the letter “m” by entering the following:
   ```
   egrep "^[m]" /usr/share/doc/packages/yast2-*/*.html
   ```

6. Close the terminal window.

(End of Exercise)
Exercise 3-7  Manage Folders with Nautilus

In this exercise, you will learn how to edit folder preferences, create a bookmark, and archive a folder.

This exercise is performed on the DA-SLED virtual machine.

Part I: Edit Folder Preferences

1. Log in as geeko to DA-SLED.
2. On the desktop, double-click geeko’s Home to open the File Browser.
3. Go to Edit > Preferences.
4. In the Views tab, under the Default View section, select to view new folders using List View.
5. In the List Columns tab, select Owner.
6. Click Close.
7. Reload the page.
   Notice how the default view has changed to a list view that includes the owner of each folder or file.
8. Click on the small right-facing arrow left of the folder to expand that folder.

Part II: Create a Bookmark

1. Double-click the Documents folder in the geeko/home directory.
2. From the Bookmarks menu, select Add Bookmarks.
   Notice how the bookmark appears in two places:
   ■ Under the Bookmarks menu
   ■ At the bottom of the Places menu in the left section of the file browser

Part III: Archive and Extract a Folder

1. Right-click the Documents folder and rename it to Documents_old.
2. Right-click the Documents_old folder and select Create Archive.
3. For Location, specify Desktop.
4. Click Create.
5. Go to the desktop, right-click Documents_old.tar.gz, and then select Extract Here.
   The Documents_old directory is un-archived.

(End of Exercise)
SECTION 4  Work with the Linux Shell and Command Line

In this section of the workbook, you learn how to do the following:

1. “Execute Commands at the Command Line on DA-SLED” on page 58
2. “Perform Common Command Line Tasks on DA-SLED” on page 59
3. “Work with Command Syntax and Special Characters on DA-SLED” on page 60
4. “Use Piping and Redirection on DA-SLED” on page 62
Exercise 4-1  **Execute Commands at the Command Line on DA-SLED**

In this exercise, use the history feature of the shell and get root permissions at the command line. To do this, use the `history` and `su` command.

This exercise is performed on the DA-SLED virtual machine.

1. Log in as `geeko` and open a terminal window.
2. View the history cache by entering `history`.
3. Press the Up-arrow until you see a command you would like to execute; then press Enter.
4. Type `h` and press Page Up once. You should see the `history` command at the command line again.
5. Press Enter to execute the `history` command.
6. Switch to root by entering `su -`. Then enter a password of `novell`.
7. Check to make sure you are logged in as root by entering `id`.
8. Start YaST by entering `yast2`. YaST should start in Qt mode.
9. Quit YaST by selecting File > Quit.
10. Become the user `geeko` again by entering `exit`.

(End of Exercise)
Exercise 4-2  Perform Common Command Line Tasks on DA-SLED

In this exercise, create an alias labeled **hello** that prints a personal welcome message **Hello username** on the screen. Finally, remove this alias.

This exercise is performed on **DA-SLED**.

1. In the terminal window, view all defined aliases by entering **alias**.
2. Define a new alias by entering the following:
   ```bash
   alias hello='echo Hello $USER'
   ```
3. Check the functionality of the alias **hello** by entering **hello**.
4. Check the command type of the **hello** command by entering the following:
   ```bash
   type hello
   ```
5. Remove the alias by entering **unalias hello**.

(End of Exercise)
**Exercise 4-3  Work with Command Syntax and Special Characters on DA-SLED**

In this exercise, use wildcards and other special characters to do the following:

- Change the character encoding from UTF-8 to POSIX.
- List all filenames in the `/bin` directory that
  - Start with an `a`
  - Consist of 4 or more characters
  - Do not start with one of the characters from `a` to `r`
- Use Nautilus to create a new and empty file called My, File, and My File.
- Mask special characters to list these files.

This exercise is performed on DA-SLED.

**Task I: Change the Character Encoding**

To change the character encoding, do the following:

1. Open a terminal window.
2. To change the character encoding from UTF-8 to POSIX, enter `LANG=POSIX`.

**Task II: Use Search Patterns**

To use search patterns, do the following:

1. List all filenames in the `/bin` directory that start with the character “a” by entering `ls /bin/a*`.
2. List all file names in the `/bin` directory that consist of four characters by entering the following:
   
   `ls /bin/????

3. List all filenames in the `/bin` directory that consist of four or more characters by entering the following:

   `ls /bin/????`

4. List all filenames in the `/bin` directory that do not start with one of the characters from `a` to `r` by entering the following:

   `ls /bin/![a-r]*`

**Task III: Create Additional Files**

To create additional files, do the following:

1. Start the file manager Nautilus by selecting *geeko’s Home* at the desktop.
2. Create a new file by right-clicking the file view frame and selecting *Create Document > Empty File*.
3. Enter a filename of My. Then press Enter.
5. Enter a filename of File. Then press Enter.
7. Enter a filename of My File. Then press Enter.
8. Close the Nautilus window.

**Task IV: Mask Special Characters**

To mask special characters, do the following:

1. From the terminal window, list the My and File files by entering `ls -l My File`.
2. List the My File file by entering `ls -l My File`.
4. Verify that the files have been removed by entering `ls -l`.

(End of Exercise)
**Exercise 4-4 Use Piping and Redirection on DA-SLED**

In this exercise, pipe the output of standard commands into files and other commands.

This exercise is performed on **DA-SLED**.

1. In a terminal window, pipe the output of the `ls` command for the home directory ("~") to a file by entering the following:
   ```bash
   ls ~ > home_directory
   ```
2. Display the content of the file by entering `cat home_directory`.
3. Append the output of the `ls` command for the root directory ("/") to the `home_directory` file by entering the following:
   ```bash
   ls / >> home_directory
   ```
4. Display the content of the file by entering `cat home_directory`.
5. Overwrite the `home_directory` file with the output of the `ls` command by entering the following:
   ```bash
   ls / > home_directory
   ```
6. Display the content of the file by entering `cat home_directory`.
7. Write the output of the `ls` command on the screen and into the `home_directory` file by entering the following:
   ```bash
   ls ~ | tee home_directory
   ```
8. Remove the `home_directory` file by entering `rm home_directory`.
9. Verify that the file was removed by entering `ls -l`.
10. Close the terminal window.

(End of Exercise)
SECTION 5  Administer Linux with YaST

In this section of the workbook, you learn how to do the following:

1.  “Get to Know YaST” on page 64
2.  “Manage the Network Configuration Information from YaST” on page 66
**Exercise 5-1  Get to Know YaST**

In this exercise, you learn how to use the different user interfaces of YaST and how to start some YaST modules: Start the graphical user interface of YaST. Then, view the `/proc/version` file with the YaST System Log module. Finally, set the time. Repeat both tasks with the ncurses user interface of YaST.

This exercise is performed on the **DA1** server.

**Part I: Start YaST**

To start YaST, do the following:

1. Log in to **DA1** as **geeko**.
2. From the main menu under the System heading, select **YaST**.
3. Enter the root password **novell**; then select Continue or press Enter.

   The YaST Control Center appears.

**Part II: View the Content of a System Log File**

To view the content of a system log file, do the following:

1. Select Miscellaneous > System Log.
2. From the top drop-down list, select `/proc/version`.
3. Close the log window by selecting OK.

**Part III: Change Time and Date**

To change time and date, do the following:

1. Select System > Date and Time.
2. Select Change.
3. Enter the current time (such as 08:00:00) and the current date (such as 07/04/2009).
4. Select Accept.
5. Select OK.

**Part IV: Start the ncurses Interface of YaST**

To start the ncurses interface of YaST, do the following:

1. Switch to the first virtual terminal by pressing Ctrl+Alt+F1.
2. Log in as root with a password of novell.
3. View a list of the available YaST modules by entering `yast -l`.
4. Enter `yast` to start the ncurses interface of YaST.
Part V: View the Content of a System Log File

To view the content of a system log file, do the following:

1. Press cursor-down until Miscellaneous is highlighted in the left frame and press Enter.
2. Press cursor-down until System Log is highlighted in the right frame and press Enter.
3. Press cursor-down until /proc/version is selected and press Enter.
4. Press Tab twice to highlight OK and press Enter.

Part VI: Exit YaST

To exit YaST, do the following:

1. Press Alt+q to select Quit.
2. Log out by entering exit
3. Switch back to the graphical interface by pressing Ctrl+Alt+F7.
4. Close the YaST window.

(End of Exercise)
**Exercise 5-2**  

**Manage the Network Configuration Information from YaST**

Up to now, your system got all network configuration information via DHCP. In this exercise, you change all the important information into static values.

Use the `ip` command to find out which ip address you are currently using. Also note your current host name. Then change the network configuration to static IP addresses, using the values you found. Use 10.0.0.254 as default gateway and also as address of the name server.

This exercise is performed on the DA1 server.

**Part I: Get Your IP Number and Host Name**

To get your IP number and host name, do the following:

1. Open a terminal window.
2. Enter `/sbin/ip address show` to list the following information for your SUSE Linux Enterprise Server 11 server (record it here for future reference):
   - IP address:
   - Hostname:
3. Close the terminal window.

**Part II: Start the YaST Network Configuration Module**

1. From the main menu, select **System > Yast**.
2. Enter the root password **novell**; then select **Continue** or press **Enter**.
3. Start the network card module by selecting **Network Devices > Network Settings**.

**Part III: Enter a Static IP Address and Subnet Mask**

To enter a static IP address and subnet mask, do the following:

1. In the Global Options tab, make sure that **Traditional Method with ifup** is selected.
2. (Conditional) If you need to change the settings to **Traditional Method with ifup**, select **OK**.
   
   You are returned to **Yast** and must return to **Network Settings**.
3. In the Overview tab, make sure **your network card** is selected; then select **Edit**.
4. Make sure that the **Address** tab is activated.
5. Switch the setup by selecting **Statically assigned IP address**.
6. In the IP Address field, enter the **IP address** from Part I.
7. In the Subnet mask field, enter **255.255.255.0**.
8. In the Hostname field, enter **DA1**.
9. Select **Next**.
You are returned to the Network Settings window.

**Part IV: Enter a DNS Server**

To enter a DNS server, do the following:

1. In the **Hostname/DNS** tab, verify the hostname is **DA1**.
2. In the Domain Name field, enter **digitalairlines.com**.
3. In the Name Server 1 field, enter the IP address of your DNS server (**10.0.0.254**).
4. If there are values in the other Name Server text fields, remove them.
5. In the Domain Search field, enter **digitalairlines.com**.
6. If there are values in the other Domain Search text fields, remove them.
7. Select **OK**.

**Part V: Enter a Default Gateway**

To enter a default gateway, do the following:

1. Select **Routing**.
2. In the Default Gateway field, enter the IP address of your Internet gateway (**10.0.0.254**).
3. Select **OK**.

**Part VI: Activate New Settings and Finish**

To activate new settings and finish, do the following:

1. Close the YaST Control Center.
2. To test your network connection, start the web browser Firefox and try to connect to **http://www.novell.com**.

(End of Exercise)
SECTION 6  Manage Users, Groups, and Permissions

In this section of the workbook, you learn how to do the following:

1. “Manage User Accounts with YaST” on page 70
2. “Check User and Group Information on Your Server” on page 73
3. “Create and Manage Users and Groups from the Command Line” on page 75
4. “Manage File Permissions and Ownership” on page 77
Exercise 6-1  Manage User Accounts with YaST

In this exercise, create and remove a user account with the YaST User Management module by doing the following:

- Create a new account labeled \textit{tux} for the user \textit{Tux Penguin} with the password of \textit{novell}.
- Log in as user \textit{tux}.
- Open the \textit{/etc/passwd} file and look for the entries for \textit{geeko} and \textit{tux}.
- Log in as \textit{geeko} and remove \textit{tux}'s account.

This exercise is performed on the \textit{DA1} server.

Part I: Create a New User Account with YaST

To create a new user account with YaST, do the following:

1. Log in to \textit{DA1} as \texttt{root} and open the \textit{YaST Control Center}.
2. Select \textit{Security and Users > User and Group Management}.
3. On the \textit{Users} tab, add a new user by selecting \textit{Add}.
4. Enter the following information:
   - User’s Full Name: \textit{Tux Penguin}
   - Username: \textit{tux}
   - Password: \textit{novell}
   - Confirm Password: \textit{novell}
5. When you finish, click \textit{OK}.
6. Confirm the password warnings by clicking \textit{Yes}.
7. Save the new settings by clicking \textit{OK}.
8. Close the \textit{YaST} window.

Part II: Log In as a New User

To log in as the new user, do the following:

1. From the main menu, select \textit{Logout}.
2. In the logout dialog, select \textit{Log Out}.
   X Window is restarted and the GUI login screen appears.
3. In the Username field, enter \textit{tux} and press \textit{Enter}.
4. In the Password field, enter \textit{novell} and press \textit{Enter}.
5. Close or cancel any displayed dialogs.
Part III: View the passwd File

To view the passwd file, do the following:

1. Start the Nautilus file manager by double-clicking **tux’s Home** icon on the desktop.
   
The content of tux’s home directory is displayed.

2. Browse the File System to the **/home** directory.
   
   Notice there are directories for users tux and geeko.

3. Browse the File System to the **/etc** directory.

4. Open the **passwd** file by double-clicking it.
   
   Notice the entries for users tux and geeko at the end of the file.

5. Close all windows.
Part IV: Log In as User geeko and Remove the New User Account

To log in as user geeko and remove the new user account, do the following:

1. From the bottom panel, log out by selecting Computer > Log Out.

2. In the logout dialog, select Log Out.
   
   X Window is restarted and the GUI login screen appears.

3. Log in as **geeko** with a password of **novell**.

4. From the GNOME desktop, select Computer > More Applications > System > YaST; then enter a password of **novell** and select Continue.

5. From the YaST Control Center, select Security and Users > User and Group Management.

6. From the list of users, select **tux**; then click Delete.

7. Select Delete Home Directory /home/tux; then click Yes.

8. Click OK.

9. Confirm that the user tux has been removed by doing the following:
   
   a. Start the Nautilus file manager by double-clicking the **geeko’s Home** icon on the desktop.
      
      The content of Geeko’s home directory is displayed.
   
   b. Browse the File System to the /home directory.
      
      Notice there is only one entry for user geeko.
   
   c. Browse to the /etc directory.
   
   d. Open the passwd file by double-clicking it.
      
      The entry for tux has been removed from the end of the file.

10. Close the Nautilus window and YaST Control Center.

(End of Exercise)
Exercise 6-2  **Check User and Group Information on Your Server**

In this exercise, write down the GIDs of some groups and the UIDs of some users. Then, switch to user root with the `su` command.

This exercise is performed on the DA1 server.

1. Log in as `geeko` and open a terminal window.
2. From the command prompt, switch to user root by entering `su -` with a password of `novell`.
3. Display all information in the `/etc/group` file by entering `less /etc/group`
4. Write down the GIDs of the following groups:
   a. ftp
   b. lp
   c. nobody
   d. root
   e. www
   f. users
5. Exit by entering `q`.
6. Display the contents of the `/etc/passwd` file by entering `less /etc/passwd`
7. Write down the UIDs of the following groups:
   a. ftp
   b. lp
   c. nobody
   d. root
   e. wwww
   f. geeko
8. Exit by typing
   q
9. Display the identity information of the logged-in user by entering
   id
   Because you have root permissions, you see UID, GID, and group information for root.
10. Exit the su state and return to the geeko user by entering
    exit
11. Enter id again.
    Notice that the groups displayed for geeko are different from those displayed for root.
12. Close the terminal window by entering
    exit

(End of Exercise)
**Exercise 6-3**  
**Create and Manage Users and Groups from the Command Line**

In this exercise, add and remove a user from the command line by doing the following:

- Use the `useradd` command to add a new user account labeled **tux** for user **Tux Penguin**.
- Look for the new entries in the `/etc/passwd` and `/etc/shadow` files.
- Use the `passwd` command to set the password for **tux** to **novell**.
- Use the `su` command to switch to user **tux**.
- Use the `passwd` command to change the password to **d1g1t@1**.
- Use the `userdel` command to remove the account of user **tux**.

This exercise is performed on the **DA1** server.

**Part I: Add a New User**

To add a new user, complete these steps:

1. Open a terminal window; then switch to root by entering:
   
   `su`

2. Enter the following password:
   
   `novell`

3. Create a new local user by entering the following:
   
   `useradd -c "Tux Penguin" -m tux`

4. Verify that a home directory for tux was created by entering
   
   `ls /home`

5. Verify that there is a entry for the tux user in `/etc/passwd` by entering
   
   `cat /etc/passwd`
   
   The “x” in the second field indicates that the password for tux is stored in `/etc/` shadow.

6. Have a look at the password in `/etc/passwd` by entering
   
   `cat /etc/shadow`
   
   The “!” in the second field indicates that there is no valid password for tux.

**Part II: Create a Password for the New User**

To create a password for the new user, do the following:

1. Create a password for the user tux by entering `passwd tux`.
2. Enter the password **suse** twice.
3. Log out as root by entering `exit`. 

Part III: Log In as New User and Change Your Password

To log in as the new user and change your password, do the following:

1. Log in as tux by entering
   \texttt{su - tux}
2. Enter the tux password: \texttt{suse}
3. Change the password of the user tux by entering
   \texttt{passwd}
4. Enter the old password of the user tux: \texttt{suse}
5. Try to change the password to novell by entering
   \texttt{novell}
   You receive a warning that the password is too simple.
   1. Enter \texttt{d1g1t@l} as the new password (twice).
   2. Log out as user tux by entering
      \texttt{exit}

Part IV: Remove the New User Account

To remove the new user account, do the following:

1. Switch to user root (\texttt{su -}) with a password of \texttt{novell}.
2. Delete the user tux by entering
   \texttt{userdel -r tux}
3. Verify that the home directory for tux has been removed by entering
   \texttt{ls /home}
4. Verify that there is no entry for tux in /etc/passwd by entering
   \texttt{cat /etc/passwd}
5. Close the terminal window.

(End of Exercise)
Exercise 6-4  Manage File Permissions and Ownership

In this exercise, manage directories with different permissions by:
- Creating a ~/files/ directory with two subdirectories: private/ and public/
- Changing the permissions for the private/ directory so that only root has read, write, and execute permissions and change the permissions of public/ so that everyone has rights to the directory
- Switching to user geeko
- Trying to create a geeko file inside each of these directories

NOTE: For the ~/public/geeko file, you have to change the permissions so that the users group has write permissions and other does not have any permissions.

This exercise is performed on the DA1 server.

Part I: Create a Private and a Public Directory

To create a private and a public directory, do the following:
1. Open a terminal window, and switch to root (su -) with a password of novell.
2. Create the /files/ directory by entering
   
   ```
   mkdir /files
   ```
3. Change to the /files/ directory by entering
   
   ```
   cd /files
   ```
4. To create the private and public subdirectories under /files/, enter
   
   ```
   mkdir private public
   ```
5. Change the permissions on the private directory so that only root has read, write, and execute permissions by entering
   
   ```
   chmod 700 private
   ```
6. Change permissions on the public directory so that everyone has rights to the directory by entering
   
   ```
   chmod 777 public
   ```
7. Verify the changes by entering
   
   ```
   ls -l
   ```

Part II: Try to Create a File as a Normal User in Both Directories

To try to create a file as a normal user in both directories, do the following:
1. Switch to virtual terminal 3 by pressing Ctrl+Alt+Shift+F3.
2. Log in as geeko with a novell password.
3. Switch to the /files directory by entering
cd /files

4. Try to create a file named `geeko` in the private directory by entering
   
   `touch private/geeko`
   
   Permission is denied.

5. Try to create a file named `geeko` in the public directory by entering
   
   `touch public/geeko`

6. Verify that the file is created by entering
   
   `ls public`

7. Change to the public directory by entering
   
   `cd public`

8. List the permissions of the `geeko` file by entering
   
   `ls -l geeko`
   
   Notice that the groups `users` and `other` have only read permission for the file.

9. Change permissions so that the group `users` has write permissions and `other` does not have any permissions by entering the following
   
   `chmod g+w,o-r geeko`

10. Verify the change by entering
    
    `ls -l`

11. Log out as `geeko` by pressing `Ctrl+d` or by entering
    
    `exit`

12. Return to the GNOME Desktop by entering (after you hit the spacebar, continue holding Ctrl+Alt while you hit F7)
    
    `Ctrl+Alt+Space Ctrl+Alt+F7`

13. Close the terminal window

   (End of Exercise)
SECTION 7  Use Linux Text Editors

In this section of the workbook, you learn how to do the following:

1. “Use vi to Edit Files in the Linux System” on page 80
**Exercise 7-1  Use vi to Edit Files in the Linux System**

In this exercise, create a new `vi_test` file with the text editor vi. Then, edit the text using the command mode of vi.

This exercise is performed on the DA-SLED VM.

**Part I: Enter a Text**

To enter a text, do the following:

1. Open a terminal window.
2. Start vi by entering `vi`.
3. Switch to the insert mode by typing `i`.
4. Type the following two paragraphs of text (press Enter at the end of each line):
   
   Administrator training for SUSE Linux Enterprise Server 11 will be held in Training Room 4 of Building B on Tuesday of next week.

   Make sure you bring your SUSE Linux Enterprise Server 11 Administration Manual. There will be wireless Internet access available in the training room.

5. Exit the insert mode by pressing `Esc`.

**Part II: Edit a Text**

To edit a text, do the following:

1. Move the cursor to the middle of the second line of the first paragraph.
2. Delete text to the right of the cursor by typing `D` (uppercase d).
3. Undo the deletion by typing `u`.
4. Delete the character directly under the cursor by pressing Delete.
5. Copy the current line to the internal buffer by typing `y` twice.
6. Move the cursor to the beginning of the first line of the second paragraph.
7. Insert the contents of the internal buffer after the current line by typing `p`.
8. Save the file with filename `vi_test` by entering `:w vi_test`.
10. Close the terminal window.

(End of Exercise)
SECTION 8  Manage Software with RPM

In this section of the workbook, you learn how to do the following:

1. “Manage Software with YaST” on page 82
2. “Install Software with PackageKit” on page 83
3. “Manage Software with RPM” on page 84
4. “Manage Software with zypper” on page 86
**Exercise 8-1  Manage Software with YaST**

In this exercise, you practice installing and uninstalling software packages with the YaST Software Management module.

This exercise is performed on **DA1**.

**Task I: Install Software with YaST**

1. Make sure you are logged in as **geeko** on DA1.
2. Insert the *SUSE Linux Enterprise Server 11 Product DVD*.
3. Open **YaST**.
4. From the **Groups** panel on the left, select **Software**.
5. From the applications under **Software**, select **Software Management**.
   
   This starts the YaST Software Manager.
6. In the search field at the top left, enter **xosview**.

   **NOTE:** Notice that the icon shows a closed box. This indicates that the package is not yet installed.

7. From the list on the right, select **xosview**.
8. Click **Accept** to install the xosview package.

**Task II: Uninstall Software with YaST**

1. In YaST, select **Software >Software Management**.
2. In the search field at the top left, enter **3ddiag**.

   **NOTE:** Notice that the list shows a box already checked. This means that the package is installed.

3. In the list on the right, double-click **3ddiag** until a red X appears to the left.
4. Click **Accept** at the bottom right.
   
   You are returned to the YaST Control Center.
5. Repeat steps 1-4 to uninstall: **xosview**.
6. Close any open windows.

*(End of Exercise)*
Exercise 8-2  Install Software with PackageKit

In this exercise, you will learn how to use PackageKit to install software on the desktop.

This exercise is performed on DA-SLED.

Detailed Steps to Complete This Exercise

1. Make sure you are logged in as geeko on DA-SLED.
2. Insert the SUSE Linux Enterprise Desktop 11 Product DVD in the DVD drive.
3. Click on the main menu (Computer) button on the bottom of the screen.
   The PackageKit application opens.
5. In the search box type phalanx.
6. Click Find to search for the package.
7. Click the check box next to A Chess Program phalanx -22-513.8 (i586) and click Apply.
8. When prompted for the root password, type novell and then click Authenticate.
9. From the menu bar select Filters > Installed > Only Installed.
10. With phalanx in the Search box, click Find.
    In the list on the right, the program appears with a checked box to the left indicating that it is installed.
11. To exit, select Quit from the System menu.

(End of Exercise)
**Exercise 8-3  Manage Software with RPM**

In this exercise, you practice gathering information on installed software and installing software packages. The exercise has two parts:

In the first part, you learn how to get information on RPMs by looking for information on the `/usr/bin/wget` file. Find out what package contains the `/usr/bin/wget` file, get information on that package, list the files contained in that package, and verify the integrity of the files. List the files in that package containing documentation.

In the second part, install the `gvim` package from the *SUSE Linux Enterprise Desktop 11 Product DVD*, run the `gvim` program, and uninstall `gvim` again.

This exercise is performed on DA-SLED.

**Task I: Get Information on Software Packages**

To get information on a software package, do the following:

1. Log in to the DA-SLED virtual machine as **root** with a password of **novell**.
2. Use RPM to find out information on the `wget` package:
   a. From a terminal window, determine which package installed the `/usr/bin/wget` file by entering
      
      ```
      rpm -qf /usr/bin/wget
      ```
      
      **NOTE:** Make sure there is a space between “-qf” and the path.

      Notice that the `wget` package installed the `wget` file.

   b. Find out information on the `wget` package by entering
      
      ```
      rpm -qi wget
      ```
      
      Notice that the information includes the install date and a description.

   c. Show all the files installed by the `wget` package by entering
      
      ```
      rpm -ql wget
      ```
      
      Where can you find information on the `wget` package? (Notice the location of the README files.)

3. Enter the following:
   
   ```
   vi /etc/wgetrc
   ```

4. Activate the edit mode of `vi` by pressing **Insert** on your keyboard.

5. Using the arrow keys, move the cursor to the first line and the first space after the three comment marks (`###`).

6. Type the following:

   **This is a test.**

7. Press **Esc**.
8. Type the following:

`:wq!`

You are returned to the command prompt.

NOTE: If you get an error message here, it is probably because you are not logged in as root. Only root has permission to write to this file.

9. See what has changed in the files on your hard drive since the wget RPM was originally installed by entering

`rpm -V wget`

10. The following is displayed:

```
S.5....T c /etc/wgetrc
```

11. Use Table 8-2 in the manual to interpret what has changed.

12. View the documentation files for the wget by entering

`rpm -qd wget`

Notice that some of the files are still compressed (*.gz)

**Task II: Install and Remove Software with RPM**

To install and remove software with RPM, do the following:

1. Insert *SUSE Linux Enterprise Desktop 11 DVD* into your CD-ROM drive.

2. List all files included in the not-yet-installed gvim package by entering

`rpm -qpl /media/SUSE_SLED-11-0-0.001/suse/i586/gvim-7*.i586.rpm`

3. Install the gvim package by entering

`rpm -ihv /media/SUSE_SLED-11-0-0.001/suse/i586/gvim-7*.i586.rpm`

4. Remove the DVD from your drive.

5. (Conditional) If the DVD drive does not open, enter `eject`, then remove the DVD.

6. Test the installation of the software package by entering `gvim`.

   A VIM window opens.

7. Close the VIM window by selecting `File > Exit`.

8. List all files included in the installed gvim package by entering `rpm -ql gvim`.

9. Remove the gvim package by entering `rpm -e gvim`.

10. Verify that the package is no longer installed by entering the following:

    `rpm -ql gvim`

11. Log out as root and close the terminal window by entering `exit`.

*(End of Exercise)*
**Exercise 8-4  Manage Software with zypper**

In this exercise, you practice adding and removing installation sources and removing a software package with the `zypper` command.

This exercise is performed on DA1.

**Task I: Add an Installation Source and Alias with zypper**

1. Log in as geeko on the DA1 machine.
2. Open a terminal window and enter `su -` to switch to the root account.
3. List your existing installation sources (repositories) by entering the following command at the command line:
   
   ```
   zypper sl
   ```
4. Add the new installation source with an alias by entering the following command:
   
   ```
   zypper ar http://172.17.8.101/suse repo1
   ```
5. List your installation sources again by entering
   
   ```
   zypper sl
   ```
   You should now see the new installation repository.

**Task II: Remove an Installation Source with zypper**

1. To remove an installation source, enter the following command at the command line:
   
   ```
   zypper rr repo1
   ```
2. List the installation sources again to see the change:
   
   ```
   zypper sl
   ```

**Task III: Remove a Software Package with zypper**

1. Check the status of the package `joe` using the following command:
   
   ```
   zypper info joe
   ```
2. To remove the software package `joe`, enter the following command:
   
   ```
   zypper remove joe
   ```
3. Check that the package has been removed by entering:
   
   ```
   zypper info joe
   ```

(End of Exercise)