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Getting Started
Novell Linux Desktop (NLD) provides the tools that Linux* users require in their daily activities. It interfaces with the Linux system to 
access and manage files, folders, and programs; it provides an integrated suite of applications (including OpenOffice.org) with the 
ability to save files in a number of formats, including Microsoft* Office application formats. NLD includes the Firefox* Web browser and 
Novell Evolution™ for e-mail, calendaring, contact management, and task lists.

Top Panel: Use 
the top panel to 
access menu 
items, Quickstart 
Launcher icons, 
and view the date 
and time. In this 
example, the 
Programs menu is 
active.

Menu: Use the 
Programs, 
System, and Help 
menus to access 
applications and 
tools on your 
system.

Desktop Icons: 
Access programs 
and features on 
your system by 
double-clicking an 
icon. You can add 
as many icons to 
your desktop as 
you want.

Bottom Panel: 
Use the bottom 
panel to quickly 
access open 
applications.

                                                                Quickstart Launcher: Simply single-click an icon in
                                                                        the Quickstart Launcher area to open a program.

Windows Selector: 
Click here to view 
and select open 
windows.

Desktop Area: 
Right-click the 
background to 
access a menu to 
create objects, clean 
up the desktop, align 
icons, or change the 
background.

Desktop Toggle 
Button: Use this 
button to minimize 
all windows and 
quickly access the 
desktop.

Workspace 
Switcher: NLD 
provides multiple 
virtual workspaces to 
organize your work. 
Click the switcher to 
access the desired 
workspace.

Desktop Panels
The top and bottom panels can be customized to meet your 
individual needs, and additional panels can be configured to 
further personalize your desktop.

To add a new panel, right-click either the top or bottom panel 
and select New Panel. To delete a panel, right-click the panel 
and select Delete This Panel. NLD requires that at least one 
panel be left on the desktop.

Adding and Removing Panel Icons
1. Right-click a blank space on the panel and select Add to 

Panel.
2. Browse to the desired program and click it to add it to the 

panel.
3. Customize the program icon as desired by right-clicking the 

icon and selecting Properties.
4. To remove a program icon from a panel, right-click the icon 

and select Remove From Panel.



Running Programs
To run a program from Novell Linux Desktop, click the menu title 
in the top panel, then use the mouse to browse the submenus 
and locate the desired program.

Customizing Your Desktop
You can easily add, delete, and create shortcut icons on your 
desktop. You can also change icon properties and the desktop 
background to suit your needs.

Adding Icons to Your Desktop

1. Click the Programs menu.
2. Browse to the desired 

program.
3. Click and drag the icon to 

the desktop and position it 
as desired.

To delete an icon from your 
desktop, simply click the 
program icon and press the 
Delete key on your keyboard.

 
Changing Icon Properties
After a shortcut icon is on the desktop, you can change the icon, 

add an emblem  (a graphic image placed on the corner of 
the icon), configure permissions, or add a note regarding the 
program. This is done through the Properties dialog box. To 
access Properties:

1. Right-click the icon and select Properties.
2. From the tabs at the top of the dialog box, customize the 

icon as needed. Some options include:
• Basic: Choose the Select Custom Icon option to 

customize the look of the icon.
• Emblems: Choose a graphic image you want 

associated with the icon. 
• Permissions: Assign permissions for the owner, a 

group, or others who might be sharing this machine.
• Notes: Add notes regarding the program or its use to 

the icon.
3. Click Close when you have completed your changes.

Changing the Desktop Background
1. Right-click the background.
2. Select Change Desktop 

Background.
3. To select wallpaper from the 

preprogrammed images, 
browse to the desired 
image. After you select it, 
the background changes 
automatically.

4. To add an image, select 
Add Wallpaper, browse to 
the desired image, then 
click Open.

5. To display a colored background, select No Wallpaper from 
the top of the list; then, from Desktop Colors, select the fill 
pattern and the desired colors.

6. Click Close.

Using Workspaces
A useful feature of NLD is the ability to switch between multiple 
virtual workspaces. These workspaces help you better organize 
your work. You might, for example, use one workspace for your 
word-processing needs and another for graphic applications. 
Both could contain a Web browser and e-mail programs. The 
same panels, icons, menus, and background exist in each 
workspace.

To move an application to a workspace:

1. Open the 
application.

2. Click the 
application icon in 
the upper left 
corner on the title 
bar.

3. Click Move to 
Another 
Workspace and 
select the 
workspace of your 
choice.

To move between desktops, simply click the workspace of your 
choice from the Workspace switcher  on the bottom 
panel of your desktop.

Using Panel Icons Effectively
Many icons and applets can be added to the panels on your 
desktop, including one to easily adjust your screen resolution 
and another to monitor your network connections.

Screen Resolution Icon
To add the screen resolution 
icon  to a panel, select 
Program > System Tools > 
Resolution Switcher. This adds 
the icon to the top panel.

To change the screen 
resolution, click the panel icon 
and select the desired screen 
definition.

Network Connections Icon

The Network Connections icon  should already be on your 
top panel. If you don’t have a network connection,  appears in 
the top panel. This icon changes depending on the type of 
network connection you have.

Click the icon to display your network connections and options 
for disconnecting or viewing configurations. You can also use 
this icon to switch network devices.

For example, if you are 
connected to the network via a 
cable and need to switch to your 
wireless device, simply click the 
Network Connections icon, and 
then click Wireless: eth1. NLD 
switches your network 
connection and acquires a new 
IP address, if needed.



Using the File Browser
The File Browser feature is a component of the File Manager 
utility. The File Browser allows you to display, manage, and 
create files; create directories; and generally organize your file 
system the way you like. You can also run scripts, open 
Universal Resource Identifier (URI) and FTP sites, or write data 
to a CD.

To access a File Browser, right-click any folder icon on your 
desktop and select Browse Folder.

Menu

Toolbar

Location Bar

Side Panel

View Pane

Status Bar

Note: To display the File Browser using the side pane view, as 
seen here, click View > Side Pane.

Understanding File Browser Elements
The elements of the File Browser window (labeled above) 
include the following:
Menu: Use to perform most tasks.
Toolbar: Use to quickly navigate between files and folders, and 
to access files and folders.
Location Bar: Use to locate files, folders, and URI sites. Use the 
zoom buttons to increase/decrease the size of content in the 
view pane. Use the View as drop-down list to see items as a list 
or as icons.
Side Pane: Use to navigate or display information about the 
selected file or folder. You can customize what is shown in the 
pane through the drop-down list. The list includes ways to view 
information about files, perform actions on file, add emblems to 
files, view a history of recently visited sites, and display your files 
in the Tree system.
View Pane: Displays folders and files.
Status Bar: Displays the number of items in a folder. When a file 
is selected, it displays the filename and size.

Archiving Folders
If you have files you haven’t used in a while but want to keep on 
your computer, you can compress the files into a tape archive 
(TAR) format.

1. In the File Browser view 
pane, click the folder you 
want to archive.

2. Select File > Create 
Archive or right-click the 
folder and select Create 
Archive.

3. Accept the default archive file name or enter a new name. 
Use the .tar.gz file extension for the most common form.

4. Select Create. The archive file is created in the same 
directory.

5. To extract an archived file, click the file and choose Edit > 
Extract Here or right-click the file and choose Extract Here.

Creating a CD
A very useful File Browser function is the ability to burn files to a 
CD. A CD read/write drive is required, but the process is quite 
easy.

1. From the File Browser, select the Tree view in the side 
pane.

2. Locate the files or folder you want to burn.
3. Right-click the folder or file and select Copy File or Copy 

Folder.
4. From the File Browser menu, select Go > CD Creator. The 

File Browser location changes to burn:///.
5. Right-click your mouse in the View pane and select Paste 

Files. The Paste Files option pastes any copied folder or file 
to the burn:/// directory.

6. Repeat steps 2 through 5 until you’ve copied all files you 
want to burn to CD.

7. Insert a writeable 
CD into the device 
and select File > 
Write to CD.

8. Enter your desired 
recorder 
configuration 
information.

9. Click Write files to 
CD.

Using Bookmarks
Use the File Browser’s Bookmarks feature to mark your favorite 
folders.

1. Select the folder or item you want to create a bookmark for.
2. Click Bookmarks > Add Bookmark. The bookmark is added 

to the list, with the folder name as the bookmark name. 
When you bookmark a file, it is the folder that is actually 
bookmarked.

3. To select an item from 
your Bookmarks list, click 
Bookmarks, then click the 
desired bookmark in the 
list.

Using the Side Pane view in 
File Browser makes creating 
bookmarks easier because 
the parent directory is 
displayed in the side pane.

Editing Bookmarks
You can also organize your Bookmarks list by clicking 
Bookmarks > Edit Bookmarks and making your selections in the 
dialog box.

Click to 
rename a 
bookmark.

Click to 
move to a 
folder.

Click to 
delete an 
item.

To change the order of your bookmarks, click a bookmark and 
drag it to the desired location.



Searching for a File or Folder
The Search feature is used to help you find programs, files, 
folders, and other media items stored on your computer. To 
access the Search feature directly, click System > Search for  
Files or click Programs > Accessories > Find Files.

To search for files:

1. In the Name contains field, enter the filename (or a portion 
of the filename). No wildcard characters are required.

2. In the Look in folder field, click Browse to locate the search 
directory. All subdirectories are also searched.

3. Click Find. Your computer searches for files and folders that 
match the details you provided. A list of possible matches 
displays in the Search results area.

4. To open the resulting folder or file, right-click the folder or 
filename and select Open. You can also double-click the file 
or foder to open it.

To perform a more advanced search:

1. Follow steps 1 
and 2 above.

2. Click Show 
more options.

3. If desired, enter 
a full or partial 
filename in the 
Contains the 
text field (this 
option applies 
only to the file 
name).

4. Click the 
Available
options drop-down list and select the search options you 
want to use.

5. Click Add. For each option you add, a new line is added to 
the Search for Files window.

6. To remove search criteria, click Remove next to the search 
box.

7. Click Find.

Viewing PDF Files
Documents that need to be shared or printed across platforms 
can be saved as PDF (Portable Document Format ) files. Novell 
Linux Desktop ships with Adobe* Acrobat* Reader. To access 
the PDF viewer, click Programs > Office > PDF Viewer. Adobe 
Reader opens.

To view a PDF file, select File > Open. Locate the desired PDF 
file and click Open.

Using Personal Settings
The Personal Settings dialog box is the center for configuring 
how your system looks and operates. Here you can configure 
mouse and keyboard options and your system appearance. You 
can also manipulate hardware configuration and other system 
settings. To access these settings, click System > Personal  
Settings.

Personal Settings are divided into the following categories:

Personal: Use the options in this category to configure how your 
mouse and keyboard function. For those who need assistance 
with a screen reader, online keyboard, etc., select Assistive 
Technology Support. Select Menus to edit your menu choices.

Appearance: These options let you change your desktop 
background, set fonts for various elements on the desktop or 
window, add a screen saver, assign a theme to the window title, 
or configure other window properties.

Hardware: These options are used for additional keyboard and 
mouse settings, printing options, adding a printer, and setting a 
default screen resolution.

System: System options are used to specify file associations, 
identify network proxies, and configure session options and 
sound.

Using YaST to Configure Your System
YaST (Yet another Setup Tool) is the device used to perform 
initial installation and configuration on your system. You or the 
system administrator can use YaST to:

• Configure 
display 
settings

• Add 
printers

To access 
YaST, click 
System > 
Administrator 
Settings, enter 
the root 
password, and 
then click OK.



Using Red Carpet
Red Carpet® helps you manage the software on your system, 
including installing updates and subscribing to and managing the 
channels that contain groups of software. To update software:

1. Click System > Software Update, enter the root password, 
then click OK.

2. On the Updates tab, select the packages you want to 
update.

3. Click Mark for Installation. This moves the items to the 
Pending Actions pane on the left.

4. Repeat steps 1 and 2 until all actions are listed in the left 
pane, then click Run Now.

5. A list of actions displays. Click Continue if the list is 
accurate.

Subscribing to Channels
Software updates are grouped into channels. Red Carpet 
installs and updates software from the channels to which you 
have subscribed. To subscribe to a channel:

1. Click Edit > Channel Subscriptions or click the Channels 
button in the toolbar.

2. A window with available channels will display. Click the 
channels you want to subscribe to.

3. Click Close.

Before you can use Red Carpet, you need to add and activate a 
service. See “Subscribing to a Red Carpet Channel” in the 
Novell Linux Desktop Deployment Guide for more information.

Novell iFolder
Novell iFolder® allows you to manage, access, and update your 
files from any location by tracking changes and synchronizing 
those changes to all of your workstations, including your home 
computer, laptop, etc.

Using Your iFolder Client Software
After the iFolder client software is installed on your machine (by 
default), it is active and begins tracking changes as soon as you 
start your computer. You can synchronize your files across 
workstations after you are logged in. To log in:

1. Click Programs > 
Accessories > Novell  
iFolder. This adds an iFolder 
icon to your top panel.

2. Type your User ID, 
Password, and Server 
information.

3. Click Login. The icon in your 
top panel changes color, 
indicating that it is active.

If you are logging in for the first time, you might be asked to 
verify the location of your files, enable automatic login at startup, 
and set an encryption passphrase.

To synchronize files:

1. Right-click the iFolder icon, then click Sync Now. iFolder 
synchronizes your personal iFolder directory with your files 
on the iFolder server.

2. To log out and cease actively synchronizing files, right-click 
the iFolder icon and select Logout.

3. To exit your iFolder client session, which means that iFolder 
stops tracking changes, right-click the iFolder icon and 
select Exit. The iFolder icon is removed from your top panel.

4. To place the icon back on your panel and activate it, click 
Programs > Accessories > Novell iFolder and log in.

Managing Novell iFolder
To view and manage iFolder and its configuration, right-click the 
iFolder icon and select Account Information. A window with three 
tabs appears.

Account 
Information: This 
tab provides 
information about 
your folder user 
name and 
location, the space 
available on the 
iFolder server, and 
the size and 
number of files 
waiting in your 
directory to be 
synchronized with 
the server.

View Activity: This tab contains a record of the changes 
uploaded/downloaded between your directory and the iFolder 
server. From this tab, you can click Sync to immediately begin 
synchronization.

Preferences: This tab lets you set preferences about how and 
when synchronization takes place, and allows you to set 
password and encryption passphrase preferences.

Installing and Managing iPrint
iPrint allows you to access location-based printers from 
anywhere in the world that you have an Internet connection. 
iPrint is available with NLD 9 Support Pack 2 or later.

To install the iPrint Linux Client, see “Installing the iPrint Linux 
Client” in the Novell Linux Desktop iPrint Client User Guide.

To monitor and manage your print jobs, click System > Personal 
Settings > Print.

Configuring Evolution
Novell Evolution makes the tasks of storing, organizing, and 
retrieving your personal information easier so you can work more 
efficiently and communicate with others.

Evolution can help you work in a group by handling e-mail, 
address, and other contact information, as well as one or more 
calendars. It can do all this on one or several computers, 
connected directly or over a network, for one person or for large 
groups.

http://www.novell.com/documentation/nld/nld_deployment/data/bu4rlng.html
http://www.novell.com/documentation/nld/iprint/data/bwajcld.html
http://www.novell.com/documentation/nld/iprint/data/bwajcld.html


Starting Evolution for the First Time

To start Evolution, click Programs > Novell Evolution, or click  
on the top panel.

The first time you run the program, it creates a directory called 
.evolution in your home directory, where it stores all of its local 
data. Then, it opens a first-run assistant to help you set up mail 
accounts and import data from other applications. Using the first-
run assistant should take approximately two to five minutes.

Later, if you want to change this account or create a new one, 
click Tools > Settings> Mail Accounts. Then select the account 
you want to change and click Edit, or click Add to configure 
another account.

E-mail and Calendaring with the GroupWise 
Linux Client
If your company uses Novell GroupWise®, you can download 
and install the GroupWise for Linux Cross-Platform client. This 
client lets you access your GroupWise mailbox to send and 
receive mail.

The GroupWise Client is a free download from the Novell 
Download Web site. On the Novell Downloads page, select 
GroupWise from the Product or Technology list, click Search, 
then click GroupWise 7 Client.

Using the Firefox Web Browser
Firefox is fast becoming the Web browser of choice for many. It 
has all the familiarity of other browsers, plus added features 
such as security and privacy tools.

To access Firefox, click   in the Quickstart Launcher area.

Tabbed Browsing
Firefox lets you open tabbed windows to conveniently switch 
between sites. Click File > New Tab to create a tabbed window 
within the current window.

Pop-up Blocking
Firefox has built-in pop-up clocking capabilities. To configure 
sites to allow desired pop-up windows, click Edit > Preferences > 
Web Features > Block Popup Windows > Allowed Sites and type 
the URL of the site you choose. Click Allow, then click OK.

Using Google Search
Google Search is built into the Firefox toolbar. Enter a keyword 
in the search box , and the results display in 
the window. You can also click the G in the Google Search box 
and search other sites or add engines.

Viewing Toolbars
The Bookmarks Toolbar can be very useful. To display this 
toolbar, click View > Toolbars > Bookmarks Toolbar. To add a 
site to the Bookmarks Toolbar, enter the URL in the location bar. 
When the site is displayed, click the icon to the left of the URL 
and drag it to the desired location on the Bookmarks Toolbar.

Downloading from Firefox
Downloaded files are automatically saved to your desktop. To 
view of list of downloads, click Tools > Downloads. Click 
Desktop to view your desktop in File Browser mode. Click Clean 
Up to remove the history of downloaded items.

Accessing Developer Support Tools
A number of developer tools are available from the Tools menu. 
The JavaScript* Console provides detailed information regarding 
Firefox’s error/warning console for accessing sites, which can be 
helpful when troubleshooting.

Configuring Firefox Preferences

To configure Firefox 
preferences, click Edit 
> Preferences.

From here you can 
configure appearance, 
language, and privacy 
settings, determine 
Web features like pop-
up blocking, and 
specify download 
configuration and 
advanced features.

Instant Messaging with Gaim
Gaim is a multiprotocol instant messaging (IM) client for Linux, 
BSD, Mac* OS X, and Windows*. It is compatible with 
GroupWise Messenger, AOL* Instant Messenger (AIM), ICQ, 
Yahoo!*, IRC, Jabber, Gadu-Gadu, and Zephyr* networks.

To configure Gaim:

1. Click Programs > Internet > 
Instant Messenger.

2. Click Accounts > Add.
3. Select the protocol you want, then 

type your screen name, password, 
and alias in the appropriate fields.

4. Select any desired user options, 
then click Show More Options.

5. Type your server address in the 
Server Address field.

6. Type your server port (if different from the default) in the 
Server Port field.

7. Select your proxy type, if needed.
8. Click Save, then click Close in the Accounts window.
9. Select the account you just created in the Login window.
10. Type your password in the Password field.
11. Click Sign On.
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