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Getting Started
Novell Linux Desktop (NLD) provides the tools that Linux* users require in their daily activities. It interfaces with the Linux system to 
access and manage files, folders, and programs; it provides an integrated suite of applications (including OpenOffice.org) with the 
ability to save files in a number of formats, including Microsoft* Office application formats. NLD includes the Firefox* Web browser and 
Novell Evolution™ for e-mail, calendaring, contact management, and task lists.

Desktop Icons: 
Click an icon to 
access its 
associated 
program or 
application. Right-
click to access a 
menu for moving, 
copying, or 
performing other 
functions on an 
icon. You can add 
as many icons to 
you desktop as 
you want.

Novell Icon 
Button: Click here 
to access a menu 
leading to all 
programs, tools, 
and applications 
on your system. 
Scroll to the 
program you want, 
then click it to 
open. You can 
add newly 
installed programs 
here as well.

Desktop Area: 
Right-click the 
desktop to access 
this menu for 
creating new 
objects, such as 
files, folders, or 
bookmarks; 
configuring the 
appearance of the 
desktop; running 
applications; and 
logging out.

NLD Panel: From 
the icons and menu 
on the Novell Linux 
Desktop panel, you 
can access all 
programs and 
system settings. You 
can customize the 
panel with shortcut 
links and move it to 
other locations on 
the desktop. Click 
the arrow at the far 
right to hide the 
panel.

Icon Bar: The icon bar 
contains shortcuts to 
frequently used programs 
and folders, such as your 
home folder and network 
connections. You can add 
icons to the bar to 
personalize your desktop.

View Desktop Buttons: 
NLD provides multiple 
virtual desktops to organize 
your work. Click the desired 
button to move between 
desktops.

Task List: This area 
displays a button for each 
open window. Click to open 
the application. Right-click 
to see options for moving, 
restoring, or minimizing the 
window. Associated 
applications can be 
grouped together.

Applets: Click these 
applets to access 
information about system 
settings such as sound, the 
clipboard tool, and network 
connections.

Time and Date: The time is 
displayed here. Clicking it 
opens a calendar with 
options for viewing any day, 
week, month, or year you 
choose.



Running Programs
To run a program from Novell Linux Desktop, click  on the 
bottom panel, then use the mouse to browse the submenus and 
locate the desired program.

Customizing Your Desktop
You can customize your desktop by adding, deleting, and 
creating shortcut icons; customizing the NLD panel; and 
changing the desktop background.

Adding Icons to Your Desktop

1. Click .
2. Browse to the 

desired program.
3. Left-click and 

drag the icon to 
the desktop, then 
release the 
mouse button.

4. Select Link Here from the menu that appears, then position 
the icon as you like.

To delete an icon from your desktop, right-click the program icon 
and select Move to Trash or Delete. Selecting Delete will 
permanently remove an item from your system.

Customizing the NLD Panel
The Novell Linux Desktop Panel is one of the most helpful 
resources in NLD. You can customize the panel for easy access 
to you most-used programs, connections, and applets.

1. Right-click anywhere in the panel. A simple menu pops
up.

2. If you want to 
add icons or 
applets to you 
panel, click 
Add. You are 
then given the
choice of adding an Applet, Application Button, Panel, or 
Special Button.
• Applet: Applets are mini-programs, such as your 

system’s clock or the clipboard tool.
• Application Button: These buttons launch programs 

and applications on your system, such as your Web 
browser, word-processing program, or even a 
calculator.

• Panel: An additional panel can be placed on your 
desktop to further organize your space and programs.

• Special Button: These buttons provide links to special 
areas on your system, such as a list of recent 
documents  or a button to quickly view the desktop 

.
3. Scroll to the type of icon you want to add, then click the 

mouse. The icon appears on the panel. You can then drag 
the icon anywhere you want on the panel.

4. To remove an icon, right-click the icon, then click Remove.
5. Select Size to change the size of the panel.
6. Select Configure Panel to make additional changes. A 

screen appears with options for positioning and lengthening 
the panel, choosing how to hide the panel, selecting menus 
to appear on the panel, and changing the way the panel 
looks.

Changing the Desktop Background
To change your desktop background:

1. Right-click the background, select Configure Desktop, then 
click Background in the left panel.

2. Choose the 
desktops you 
want the 
image to 
appear on.

3. Click No 
picture if you 
don’t want 
one.

4. Click Picture 
and browse 
through the 
available 
images. The image displays on the right. Click the Folder 
icon  to search your system for more images.

5. Click Slide Show to have multiple images appear in a slide 
show mode.

6. Use this area to change viewing options as desired.
7. Click Apply, then click OK.

Using Virtual Desktops
Another useful feature of NLD is the ability to switch between 
multiple virtual desktops. These desktops help you better 
organize you work. You might, for example, use one desktop for 
your word-processing needs and another for graphic 
applications. Both could contain a Web browser and e-mailing 
programs. The same panels, icons, and menus are present on 
each desktop.

Moving an Application to a Virtual Desktop
To move an application to a virtual desktop:

1. Open the application.
2. Right-click the application’s title bar.
3. Click To Desktop.
4. Select the desktop you want to place the application on.

To move between desktops, simply click the desktop of your 
choice from the View Desktop Buttons  area on the 
panel.

Adding Additional Virtual Desktops
Some users might need more desktops than provided by default. 
To add additional desktops:

1. Right-click one 
of the virtual 
desktop 
buttons.

2. Select 
Configure 
Virtual  
Desktops.

3. Use the blue 
scroll icon or 
the arrows to 
select the 
number of 
desktops you’d like.

4. If desired, name each desktop to reflect its contents.
5. Click Apply, then click OK.



Using Konqueror
Konqueror is your system’s file manager. It lets you display, 
manage, and create files, and generally organize your file 
system the way you like. It also works as a Web browser.

To access Konqueror, click the Home icon  on the panel.

            Title Bar Menu  Toolbar Location Bar 

Window

Navigation 
Panel
To open, 
click 
Window > 
Show 
Navigational 
Panel OR 
use the F9 
key.

Status Bar

Understanding How Konqueror Works
The elements of Konqueror’s main window (labeled above) 
include the following:

Title Bar: Displays the path of the folder being viewed.

Menu: Use to access drop-down menus for performing most 
tasks, including changing viewing options.

Toolbar: Use to access icons for your most-used operations, 
such as moving between files and folders.

Location Bar: Displays the path of the file being viewed. Click 
the X to the left of the bar to clear the path. Click the arrow to the 
right to view previous locations.

Window: Displays the contents of a file or directory. Right-
clicking a file brings up a menu with options for copying, moving, 
renaming, and deleting the file or folder. Selecting Move to Trash 
allows you to restore the file if needed. Selecting Delete 
permanently removes the file from your system.

Navigation Panel: Click an icon for quick viewing access to your 

Bookmarks ; Devices , such as a floppy drive or CD-ROM; 

History ; Home Folder ; Network ; Root Folder , and 

Services .

Status Bar: Displays the number of items in a folder. When a file 
is selected, it displays the filename and size.

Konqueror as a Web Browser
Typing a URL in the 
Location Bar allows 
Konqueror to work just as 
any Web browser would. 
One function of 
Konqueror is tabbed 
browsing. This means 
you can load one page in 
the background while 
reading another. To 
do so, select Location > New Tab. Type in the URL, then select 
a previous tab to view while the other downloads.

Using Bookmarks
Use Konqueror’s Bookmarks feature to mark your favorite 
folders or Web sites.

1. Locate the folder or Web site you want to add a bookmark 
for (the path or URL should be displayed in the location bar).

2. Click Bookmarks > Add Bookmark. The bookmark is added 
to the list, with the path or URL as the bookmark name.

3. To select an item 
from your 
Bookmarks list, click 
Bookmarks and 
scroll to the desired 
bookmark in the 
bottom half of the 
list.

4. To edit your 
Bookmarks list, click Bookmarks > Edit Bookmarks. A list of 
your bookmarked sites and folders appears. Right-click any 
item to view a menu with options for moving a bookmark, 
creating a new bookmark folder, renaming a bookmark, and 
so on. Click File > Save when finished.

Creating a CD
You can burn files to a CD with K3b-The CD Kreator. A CD 
read/write drive is required, but the process is quite easy.

1. Click .
2. Click Multimedia > CD/DVD Burning.

3. Click the New Data CD Project button  in the bottom 
window.

4. Use the tree view in the top left pane to search for the files 
or folders you want to burn. When they appear in the main 
window, drag and drop them into the Current Projects 
window.

5. Insert a writeable CD 
into the device. then 
click Burn.

6. Enter the required 
information in the Data 
Project window. If you 
don’t know which 
settings to choose, 
click K3b Defaults. This 
should work well for 
almost all files you 
need to burn.

7. Click Burn.



Searching for a File or Folder
Finding files and folders on your system is easy with the Find 
Files feature. Simply click  > Find Files. The Find Files window 
contains three tabs for different types of searching. The simplest 
search is by Name and Location.

To search this way:

1. Enter the file name 
in the Named field. 
If needed, you can 
use asterisks * to 
indicate missing 
characters in the file 
name.

2. In the Look in field, 
type the name of 
the folder or click Browse to locate the folder.

3. To search subfolders, check Include Subfolders.
4. Click Find. A list of possible matches displays in the bottom 

half of the window.
5. To open the resulting folder or file, right-click the folder or 

file and click Open.

Searching by Contents
For more advanced searching, select the Contents tab:

1. In the File type 
field, select the 
type of file you are 
searching for. In 
this example, the 
desired file is an 
OpenOffice.org 
Text document.

2. In the Containing 
Text field, type a 
word or phrase you know is in the file. (This option does not 
work for all types of files.)

3. Enter any other pertinent information.
4. Click Find.

Searching by Properties
To refine your search even more, select the Properties tab:

1. Check Find all files created or modified.
2. Use the drop-down menus to tell the system to look for files 

created between specific dates or during a previous length 
of time.

3. Use the drop-down menus to indicate the approximate size 
of the file. 

4. If desired, type the user or owner of the file.
5. Click Find.

Viewing PDF Files
Documents that need to be shared or printed across platforms 
can be saved as PDF (Portable Document Format) files. Novell 
Linux Desktop ships with Adobe* Acrobat* Reader. To access 
the PDF viewer:

1. Click .
2. Click Office > Document Viewer. Adobe Reader opens.

To view a PDF file, click File > Open. Locate the desired PDF file 
and click Open.

Using the Control Center
From the Control Center, you can configure how your system 
looks and operates. To access the Control Center, click  > 
Control Center.

The Control Center 
is navigated by 
searching through 
the index in the left 
panel, then viewing 
the results and 
taking action in the 
right panel. From the 
Index panel, you can 
select the following 
options:

: Use this module to configure the background, 
screen saver, and the way icons, windows, fonts, and colors 
display on your system.

: Use this module to control settings for your virtual 
desktop, panels, and desktop icons.

: Use this module to set parameters for your Internet 
and network usage, such as the history of sites viewed and the 
way your system accepts cookies.

: Use this module to control settings for the 
Konqueror file manager, spell checking, and other system 
operations.

: Use this module to change settings for your 
mouse, keyboard, and printers.

: Use this module to manage how your machine is 
powered.

: Use this module to configure keyboard shortcuts, 
regional and language settings, and hot keys.

: Use this module to set up passwords and perform 
other security features for you system.

: Use this module to set up your system’s sound 
preferences.

: Use this module to configure user accounts, 
install fonts, and manage log ins.

: See the YaST section of this document (below) 
for information on this area.

After you have made a selection from the Index Pane, a new 
menu appears in its place. To return to a previous menu, simply 
click the Back arrow that appears at the top of the menu.

Performing tasks in some areas of the Control Center requires 
system administrator (otherwise known as root) permissions.

Using YaST to Configure Your System
YaST (Yet another Setup Tool) is the device used to perform 
initial installation and configuration on your system. You or the 
system administrator can use YaST to:

• Configure display settings
• Add printers

To access YaST, click  > System > YaST. System 
administrator (or root) privileges are required to proceed from 
this point.



Using Red Carpet
Red Carpet® helps you manage the software on your system, 
including installing updates and subscribing to and managing the 
channels that contain groups of software. To update software:

1. Click  > System > Configuration > Red Carpet.
2. Enter the root password, and then click OK.
3. On the Updates tab, select the packages you want to 

update.
4. Click Mark for Installation. This moves the items to the 

Pending Actions pane on the left.
5. Repeat steps 1 and 2 until all actions are listed in the left 

pane, then click Run Now.
6. A list of actions displays. Click Continue if the list is 

accurate.

Subscribing to Channels
Software updates are grouped into channels. Red Carpet installs 
and updates software from the channels to which you have 
subscribed. To subscribe to a channel:

1. Click Edit > Channel Subscriptions or click the Channels 
button in the toolbar.

2. A window with available channels displays. Click the 
channels you want to subscribe to.

3. Click Close.

Before you can use Red Carpet, you need to add and activate a 
service. See “Subscribing to a Red Carpet Channel” in the 
Novell Linux Desktop Deployment Guide for more information.

Novell iFolder
Novell iFolder® allows you to manage, access, and update your 
files from any location by tracking changes and synchronizing 
those changes to all of your workstations, including your home 
computer, laptop, etc.

Using Your iFolder Client Software
After the iFolder client software is installed on your machine (by 
default), it is active and begins tracking changes as soon as you 
start your computer. You can synchronize your files across 
workstations after you are logged in. To log in:

1. Click  > System > File 
Manager > Novell iFolder. 
This adds an iFolder icon 
to your panel.

2. Type your User ID, 
Password, and Server 
information.

3. Click Login. The icon in 
your panel changes color, 
indicating that it is active.

If you are logging in for the first time, you might be asked to 
verify the location of your files, enable automatic login at startup, 
and set an encryption passphrase.
To synchronize files:

1. Right-click the iFolder icon, then click Sync Now. iFolder 
synchronizes your personal iFolder directory with your files 
on the iFolder server.

2. To log out and cease actively synchronizing files, right-click 
the iFolder icon and select Logout.

3. To exit your iFolder client session, which means that iFolder 
stops tracking changes, right-click the iFolder icon and 
select Exit. The iFolder icon is removed from your top panel.

4. To place the icon back on your panel and activate it, click  
> System > File Manager > Novell iFolder and log in.

Managing Novell iFolder
To view and manage iFolder and its configuration, right-click the 
iFolder icon and select Account Information. A window with 
three tabs appears.

Account 
Information: This 
tab provides 
information about 
your folder user 
name and 
location, the space 
available on the 
iFolder server, and 
the size and 
number of files 
waiting in your 
directory to be 
synchronized with 
the server.

View Activity: This tab contains a record of the changes 
uploaded/downloaded between your directory and the iFolder 
server. From this tab, you can click Sync to immediately begin 
synchronization.

Preferences: This tab lets you set preferences about how and 
when synchronization takes place, and allows you to set 
password and encryption passphrase preferences.

Installing and Managing iPrint
iPrint allows you to access location-based printers from 
anywhere in the world that you have an Internet connection. 
iPrint is available with NLD 9 Support Pack 2 or later.

To install the iPrint Linux Client, see “Installing the iPrint Linux 
Client” in the Novell Linux Desktop iPrint Client User Guide.

To monitor and manage your print jobs, click  > Utilities > 
Printing > Print Jobs.

Configuring Evolution
Novell Evolution makes the tasks of storing, organizing, and 
retrieving your personal information easier so you can work more 
efficiently and communicate with others.

Evolution can help you work in a group by handling e-mail, 
address, and other contact information, as well as one or more 
calendars. It can do all this on one or several computers, 
connected directly or over a network, for one person or for large 
groups.

http://www.novell.com/documentation/nld/nld_deployment/data/bu4rlng.html
http://www.novell.com/documentation/nld/iprint/data/bwajcld.html
http://www.novell.com/documentation/nld/iprint/data/bwajcld.html


Starting Evolution for the First Time
To start Evolution, click  > Office > Evolution.

The first time you run the program, it creates a directory called 
.evolution in your home directory, where it stores all of its local 
data. Then it opens a first-run assistant to help you set up mail 
accounts and import data from other applications. Using the first-
run assistant should take approximately two to five minutes.

Later, if you want to change this account or create a new one, 
click Tools > Settings > Mail Accounts. Then select the account 
you want to change and click Edit, or click Add to configure 
another account.

E-mail and Calendaring with the GroupWise 
Linux Client
If your company uses Novell GroupWise®, you can download 
and install the GroupWise for Linux Cross-Platform client. This 
client lets you access your GroupWise mailbox to send and 
receive mail.

The GroupWise Client is a free download from the Novell 
Download Web site. On the Novell Downloads page, select 
GroupWise from the Product or Technology list, click Search, 
then click GroupWise 7 Client.

Using the Firefox Web Browser
Firefox is fast becoming the Web browser of choice for many. It 
has all the familiarity of other browsers, plus added features 
such as security and privacy tools.

To access Firefox, click  > Internet > Web Browser > Firefox 
Web Browser.

Tabbed Browsing
Firefox lets you open tabbed windows to conveniently switch 
between sites. Click File > New Tab to create a tabbed window 
within the current window.

Pop-up Blocking
Firefox has built-in pop-up clocking capabilities. To configure 
sites to allow desired pop-up windows, click Edit > Preferences > 
Web Features > Block Popup Windows > Allowed Sites and type 
the URL of the site you choose. Click Allow, then click OK.

Using Google Search
Google Search is built into the Firefox toolbar. Enter a keyword 
in the search box , and the results display 
in the window. You can also click the G in the Google Search 
box and search other sites or add engines.

Viewing Toolbars
The Bookmarks Toolbar can be very useful. To display this 
toolbar, click View > Toolbars > Bookmarks Toolbar. To add a 
site to the Bookmarks Toolbar, enter the URL in the location bar. 
When the site is displayed, click the icon to the left of the URL 
and drag it to the desired location on the Bookmarks Toolbar.

Downloading from Firefox
Downloaded files are automatically saved to your desktop. To 
view of list of downloads, click Tools > Downloads. Click 
Desktop to view your desktop in File Browser mode. Click Clean 
Up to remove the history of downloaded items.

Accessing Developer Support Tools
A number of developer tools are available from the Tools menu. 
The JavaScript* Console provides detailed information regarding 
Firefox’s error/warning console for accessing sites, which can be 
helpful when troubleshooting.

Configuring Firefox Preferences
To configure Firefox 
preferences, click Edit > 
Preferences.

From here you can 
configure appearance, 
language, and privacy 
settings, determine Web 
features like pop-up 
blocking, and specify 
download configuration 
and advanced features.

Instant Messaging with Gaim
Gaim is a multiprotocol instant messaging (IM) client for Linux, 
BSD, Mac* OS X, and Windows*. It is compatible with 
GroupWise Messenger, AOL* Instant Messenger (AIM), ICQ, 
Yahoo!*, IRC, Jabber, Gadu-Gadu, and Zephyr* networks.

To configure Gaim:

1. Click  > Internet > Chat > Gaim 
Internet Messenger.

2. Click Accounts >Add.
3. Select the protocol you want, then 

type your screen name, password, 
and alias in the appropriate fields.

4. Select any desired user options, 
then click Show More Options.

5. Type your server address in the 
Server Address field.

6. Type your server port (if different from the default) in the 
Server Port field.

7. Select your proxy type, if needed.
8. Click Save, then click Close in the Accounts window.
9. Select the account you just created in the Login window.
10. Type your password in the Password field.
11. Click Sign On.
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