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Legal Notices
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specifically disclaims any express or implied warranties of merchantability or fitness for any particular purpose. 
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stored on a retrieval system, or transmitted without the express written consent of the publisher.

Novell, Inc. has intellectual property rights relating to technology embodied in the product that is described in this 
document. In particular, and without limitation, these intellectual property rights may include one or more of the U.S. 
patents listed at http://www.novell.com/company/legal/patents/ and one or more additional patents or pending patent 
applications in the U.S. and in other countries.
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About This Guide

This document is for network administrators, consultants, and PeopleSoft* administrators who are 
using PeopleSoft 7.5 or 8.1.

The Identity Manager Driver for PeopleSoft, subsequently referred to as the driver, is designed to 
share data between the Novell® Identity Vault and PeopleSoft. This configurable solution gives 
organizations the ability to increase productivity and streamline business processes by integrating 
PeopleSoft and the Identity Vault.

This driver connects to PeopleSoft via the Message Agent, a PeopleTools interface. The driver can 
be configured to work with any PeopleSoft module. 

This guide provides an overview of the driver’s technology as well as configuration instructions. 

• Chapter 1, “Introducing the Identity Manager Driver for PeopleSoft,” on page 9
• Chapter 2, “Installing the Driver,” on page 17
• Chapter 3, “Configuring Your PeopleSoft System,” on page 21
• Chapter 4, “Troubleshooting the Driver,” on page 37
• Chapter 5, “Documentation Updates,” on page 43

Audience

This guide is intended for consultants, administrators, and IS personnel who need to install, 
configure, and maintain the Identity Manager Driver 3.6.3 for PeopleSoft.

Feedback

We want to hear your comments and suggestions about this manual and the other documentation 
included with this product. Please use the User Comments feature at the bottom of each page of the 
online documentation, or go to Novell’s Feedback Web site (http://www.novell.com/documentation/
feedback.html) and enter your comments there.

Documentation Updates

For the most recent version of this document, see the Drivers Web site (http://www.novell.com/
documentation/idmdrivers).

Additional Documentation

For documentation on using Novell Identity Manager and the other drivers, see the Identity Manager 
Documentation Web site (http://www.novell.com/documentation/idm).

Documentation Conventions

In Novell documentation, a greater-than symbol (>) is used to separate actions within a step and 
items within a cross-reference path.
7
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A trademark symbol (®, ™, etc.) denotes a Novell trademark. An asterisk (*) denotes a third-party 
trademark.

When a single pathname can be written with a backslash for some platforms or a forward slash for 
other platforms, the pathname is presented with a backslash. Users of platforms that require a 
forward slash, such as Linux* or UNIX*, should use forward slashes as required by your software.
ager Driver for PeopleSoft Implementation Guide
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1Introducing the Identity Manager 
Driver for PeopleSoft

A PeopleSoft application is composed of two primary pieces:

• PeopleTools, which is an infrastructure
• One or more modules

Example modules are Human Resources Management System (HRMS), Financials, Student 
Administration, and Customer Resource Management.

The Identity Manager Driver for PeopleSoft interacts with PeopleSoft at the PeopleTools level. By 
using object definitions within the PeopleSoft modules, along with a collection of preconfigured 
objects, you enable PeopleSoft so that you can do the following:

• Trap events in any PeopleSoft module.

• Expose trapped events to the Novell® Identity Vault.
• Collect and process the exposed data.
• Expose the data through a PeopleTools interface.

The driver creates an automated link between PeopleSoft and the Identity Vault. As new records are 
added, modified, or deactivated (disabled) in PeopleSoft, network tasks associated with these events 
can be automatically processed. 

For example, when hires, re-hires, terminations, and employee updates occur within the Human 
Resources module, resultant tasks are often created for the Information Services department. These 
tasks might include setting up, modifying or disabling an Identity Vault user account, creating an e-
mail account, or creating a domain account. By using the driver, you can automate and maintain 
these and other business processes.

• Section 1.1, “Changes in Terminology,” on page 9
• Section 1.2, “Benefits,” on page 10
• Section 1.3, “Driver Features,” on page 10
• Section 1.4, “Driver Components,” on page 11
• Section 1.5, “Publishing to the Identity Vault,” on page 13
• Section 1.6, “Subscribing from the Identity Vault,” on page 15

1.1  Changes in Terminology
The following terms have changed from earlier releases: 
Introducing the Identity Manager Driver for PeopleSoft 9
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Table 1-1   Changes in Terminology

1.2  Benefits
As the following examples illustrate, the driver enables you to automate and maintain business 
processes. You can:

• Automatically create an Identity Vault account when an individual is hired or a student is 
admitted.

• Automatically delete or deactivate Identity Vault accounts when an employee terminates.
• Synchronize bidirectional data between PeopleSoft and the Identity Vault.
• Maintain accurate and consistent Identity Vault IDs.
• Define password policies (for example, a birthdate, social security number, and first and last 

name combinations).
• Via Identity Vault, seamlessly allow integration between PeopleSoft and multiple applications 

(for example, eDirectory, Lotus Notes*, Netscape*, Exchange, Active Directory*).
• Create other eDirectory objects associated with a PeopleSoft object (for example, account 

codes or department records).
• Synchronize attributes between PeopleSoft and the Identity Vault.
• Synchronize data from the Identity Vault to PeopleSoft.

The driver includes the following:

• The Event Server program
• The driver shim
• The PeopleSoft Service Agent (PSA)
• A driver configuration file

You can configure the PSA and the driver objects to enhance your organization’s business processes. 
Before installing and configuring the driver, you evaluate and define those processes. During 
installation, you configure the driver’s policies to automate these processes wherever possible.

1.3  Driver Features
The driver provides the following features:

• Support for multiple PeopleTools.

A separate Event Server program is available for each PeopleTools release. This program 
connects to the driver shim in a Windows* socket.

Earlier Terms New Terms

DirXML® Identity Manager

DirXML Server Metadirectory server

DirXML engine Metadirectory engine

eDirectoryTM Identity Vault (except when referring to eDirectory attributes or classes)
ager Driver for PeopleSoft Implementation Guide
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Remote processing between the shim and the Event Server is also possible. This means that the 
Event Server can run on a different machine than the driver shim.

• Enhanced error processing.
The Event Server can run as a DOS window on a Windows NT* machine. The screen shows 
debug messages as an event is processed. The information includes the status of the transaction 
displayed on the Event Server. This enables you to determine exactly which transaction is being 
processed. 

• Enhanced DSTRACE capability.
DSTRACE messaging includes a detailed description of the event and event processing.

• Identity Manager query support.
You can apply a Matching policy for both the Publisher and Subscriber channels. If an 
association between the User object and the PeopleSoft employee does not exist, the 
Metadirectory engine executes a Matching policy and requests a query to merge attributes 
between the two objects.
You can also query PeopleSoft for attribute values needed for data manipulation or processing 
within a policy without copying the data to the Identity Vault.

• Command line parameters for the Event Server.
Command line parameters define how the Event Server is to be executed, how to connect to the 
driver shim, and whether the Event Server should be installed as a service. The parameters also 
designate the path of the PeopleSoft client environment. For more information, refer to Section 
3.1, “Installing the PeopleSoft Service Agent,” on page 21.

• Auto-start ability.
You can set the driver to auto-start by installing the Event Server as a Windows service and 
setting the auto-start flag on the driver. For more information, refer to Section 3.3, “Installing 
the Event Server,” on page 32.

• Support for schema query.
The driver can query the Identity Vault and PeopleSoft schemas for attributes that can be used 
in the Mapping policy, or query PeopleSoft for objects defined as policy objects on the Driver 
object.

1.3.1  Identity Manager 3 New Features
For information about the new features in Identity Manager, see “What's New in Identity Manager 
3?” in Identity Manager 3.0 Installation Guide.

1.4  Driver Components
The driver uses the following components:

• PeopleSoft Service Agent (PSA)
• Driver Shim
• XML Import File
• Event Server
• PeopleSoft Message Agent (delivered through PeopleSoft)
Introducing the Identity Manager Driver for PeopleSoft 11
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Table 1-2   Components needed for the different PeopleSoft versions

1.4.1  Driver Configuration
The driver is responsible for reporting object change events that it receives from PeopleSoft to the 
Metadirectory engine. The driver consists of both an Event Server program and the npsshim.dll 
file.

The driver contains both a Publisher channel and a Subscriber channel. The Subscriber channel 
receives XML-formatted eDirectory events from the Metadirectory engine. The driver then converts 
these documents to an appropriate data stream, forwards them to the Event Server, and updates 
PeopleSoft via the Message Agent interface.

The Publisher channel receives XML-formatted PeopleSoft events from the Event Server and 
submits them to the Metadirectory engine for publication into the Identity Vault. The engine 
processes the document by sequentially applying all configured policies based on standard driver 
process flow. 

Each policy performs a transformation on the XML document. The engine processes the event 
document according to the policies and the filter found in the Driver Publisher object. 

1.4.2  Driver Shim
The driver shim handles communication between the event server and the Metadirectory engine. For 
this version of the driver, the driver shim is named npsshim.dll. 

1.4.3  Event Server
The Event Server is a standalone executable process. It establishes and maintains connectivity 
between the driver shim and the PeopleSoft Message Agent. 

The Event Server communicates with the driver via a sockets interface and communicates with the 
Message Agent via proprietary PeopleSoft Message Agent APIs. 

The Event Server is a bidirectional component with Publisher and Subscriber channels. The 
Publisher channel polls the Message Agent for transactions. When transactions are available, the 
Event Server reads the record data via the Message Agent and transforms the proprietary format of 
the PeopleSoft records into an XML-formatted representation. The XML records are sent to the 
driver for submission to the Identity Vault. 

Likewise, the Subscriber channel receives XML-formatted eDirectory events from the driver and 
transforms them into the PeopleSoft proprietary format. The event data is then sent to the Message 
Agent for publication into the PeopleSoft database.

Component For PeopleSoft 7.5 For PeopleSoft 8.1

PSA dirxml_driver 3_6 psa.exe dirxml_driver 3_6 psa.exe 

Driver shim npsshim.dll npsshim.dll

XML Import File peoplesoft36.xml peoplesoft36.xml

Event Server nps75eventserver.exe nps81eventserver.exe
ager Driver for PeopleSoft Implementation Guide
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1.4.4  PeopleSoft Service Agent
The PeopleSoft Service Agent (PSA) is software that you receive as a PeopleSoft project. A PSA is 
a collection of objects. This collection customizes the PeopleSoft module that the objects are applied 
to. 

You can install the PSA components and then configure them for any PeopleSoft application.

The PSA serves three purposes: 

• Traps events as they occur in PeopleSoft
• Places a transaction for trapped events into the worklist
• Exposes the transaction (which is joined with relevant, current data) to the driver via the 

Message Agent

The PSA includes a sample of all objects necessary in PeopleSoft so that any PeopleSoft module can 
have connectivity to and from the Event Server.

1.5  Publishing to the Identity Vault
Publishing events to the Identity Vault begins with updates in PeopleSoft. As these updates occur, 
transactions are placed in a worklist queue. These events are then made available to the Identity 
Vault through the Event Server. 

As the Event Server receives transactions from PeopleSoft, it transforms the data into an XML 
document and passes the document to the driver shim. The driver shim then passes the document to 
the Metadirectory engine, which processes the transaction in the Identity Vault based on the policies 
as defined in the driver.

The transaction in the worklist is also updated with either a worked or error status. As the status is 
being updated in PeopleSoft, additional PeopleCode can be processed to trigger e-mail notifications 
to users in a defined PeopleSoft workflow role. The e-mail message communicates information 
regarding both successful transactions and transactions that create errors.

1.5.1  Event Descriptions
As updates or actions occur within PeopleSoft, workflow triggers are executed. These triggers place 
transactions in a PeopleSoft worklist queue. Each transaction is given key fields that uniquely 
identify the transaction to the driver.

One of these key fields is the Event Name field. Event Names are assigned based on a PeopleSoft 
action. The driver monitors the queue, checking for transactions that meet the criteria for processing.

The criteria for processing include the following: 

• The transactions have the status of 0.
• Action, date, and time are less than or equal to current date and time.

After receiving the event, the Event Server converts the event into XML and sends the XML to the 
driver shim. This shim passes the XML document to the Metadirectory engine. The engine then 
applies the appropriate policies for that event type (based on the EventName field). The driver 
changes the XML to Identity Vault commands and sends the events to the Identity Vault. 
Introducing the Identity Manager Driver for PeopleSoft 13
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The delivered solution supports the following workflow events. By default, an event in PeopleSoft 
equates to an XML functional event or document.

Table 1-3   PeopleSoft To XML Events

To trigger the appropriate event for the type of XML document that is to be generated, you must 
configure PeopleSoft appropriately. Without proper configuration and review of your business 
processes, a termination (action) could trigger a UPD event instead of a DIS event. The resulting 
XML document would be a Modify document instead of a Delete document.

The delivered driver configuration identifies two fields (Email ID and Description) on the 
Subscriber channel. These fields synchronize data from the Identity Vault to PeopleSoft. Additional 
fields can be subscribed to PeopleSoft from the Identity Vault, based on the needs of your 
organization. For Subscriber channel information, refer to “Subscribing from the Identity Vault” on 
page 15.

ADD

The ADD event is generally triggered when a new record is added. For the HR module, this is when 
an employee is hired. When a new Hire record is created within PeopleSoft, the following steps 
occur:

1. A workflow definition is triggered.
2. An ADD transaction is written to the worklist.
3. The driver reads the worklist to obtain a transaction, which is joined with user-specified data.
4. The driver transforms the data stream into an XML document.
5. The driver passes the document to the Metadirectory engine.
6. The engine applies the policies that have been configured.
7. The engine creates an eDirectory object.

The SSCreate policy is configured as a sample Create policy. You use this policy to create the User 
object. You can define the eDirectory Common Name, Initial Login Password, and other Create 
policies within this policy. 

Depending on your business requirements, you can apply additional configurations to the PSA to 
expose additional data elements. You can also configure the policies to meet business objectives.

During the ADD event processing, an association is made between the employee’s PeopleSoft 
record and the eDirectory object. For the HR module, the EmplID field is used as the key field and 
saved in the association attribute on the User object.

PeopleSoft Event Typical PeopleSoft Action XML Functional Event

ADD New hire, new student, new account code, 
new record.

Add

UPD Any change or modification to data. For 
example, a field on a panel is modified.

Modify

DIS Termination. A record becomes inactive or 
disabled.

Delete
ager Driver for PeopleSoft Implementation Guide
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When an object is created, various attributes or data elements defined in PeopleSoft could be passed 
through the interface and used to place the object. The Placement policy on the Driver object would 
use these values.

UPD

UPD events are generally triggered when data on a specified PeopleSoft field is modified. A 
workflow is triggered through the use of PeopleCode, and a UPD event is written to the worklist. 
Through the same process as the ADD transaction, the driver retrieves the transaction and applies 
the appropriate policies. In the delivered solution, the eventXform policy is used to apply these 
events. The policies might vary, based on the individual needs of an organization.

To determine the PeopleSoft fields that should be synchronized and used as part of the policies 
within the Identity Vault, analyze your business processes.

For example, a user’s location, department, or company can determine the location of that 
individual’s User object within eDirectory. If one of these fields is updated from PeopleSoft, the 
eDirectory User object must be moved to the appropriate container, based on the new information. 

PeopleSoft fields can also be stored in the Identity Vault as attributes. Telephone numbers, 
department, preferred names, business titles, and locations are some common fields that can be 
shared between the two systems. As you analyze your business processes and needs, you determine 
the necessary data mappings between the systems.

DIS

The DIS event is generally triggered when records are disabled. Many different actions within 
PeopleSoft represent a disabled process. In the HR module, this event occurs when an employee 
terminates. When a termination record is created within PeopleSoft, a workflow is triggered and a 
DIS entry is written to the worklist. 

IMPORTANT: If a DIS transaction is triggered, a Delete XML document is the result.

An organization can choose to delete, disable, or disable and move the Identity Vault account. As 
with the modify/update process, the eventXform policy is delivered to show how a Delete XML 
document is transformed into a Modify document.

NOTE: By default, when the Publisher channel processes any event, the eDirectory ID and 
eDirectory DN (distinguished name) are updated in PeopleSoft. You can disable this process by 
updating the driver’s XML properties.

1.6  Subscribing from the Identity Vault
PeopleSoft is the authoritative process for ADD and DIS (delete or disable) events. Therefore, the 
default driver only allows updates to PeopleSoft on the Subscriber channel. 

Because PeopleSoft is a relational database (instead of a hierarchical database), the Move and 
Rename processes generally do not apply. If these processes occur in the Identity Vault against an 
object that the driver is subscribed to, the driver converts them to a Modify event. The driver does 
this to update the eDirectory ID and eDirectory Distinguished Name in PeopleSoft, if the update 
process is not disabled.
Introducing the Identity Manager Driver for PeopleSoft 15
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The driver subscribes to Modify events that occur within the Identity Vault. PeopleSoft is designed 
to be the authoritative owner of data in the delivered solution. Therefore, if a User object is created 
in eDirectory, an employee record in PeopleSoft is not created with the default configuration. 

The data elements that are being subscribed from the Identity Vault to PeopleSoft must 

• Be found on the Subscriber channel filter
• Exist on the DIRXML_SCHEMA01_UPDATE Message Definition and on the 

DIRXML_SCHEMA01 Message Definition in PeopleSoft (or equivalent definitions)

When the driver is notified of a modification to an attribute selected in its Subscriber filter, the 
driver sends the event to the Event Server. The Event Server formats the event and then updates 
PeopleSoft by communicating through the PeopleSoft Message Agent. Data received from the 
Identity Vault can be placed on a panel or page inside PeopleSoft. 

Because this data is being updated and maintained outside of PeopleSoft, it should typically be set to 
Display Only from within PeopleSoft. It is not advisable to allow the same data element to be 
modified inside and outside of PeopleSoft. For this to occur, the data element would need to be 
defined in both the Publisher and the Subscriber channel on the driver.

You can update data in PeopleSoft to an existing PeopleSoft record. To do this, you must write 
appropriate PeopleCode so that data elements updated on the DIRXML_STAGE01 record definition 
are also copied to the desired record within the PeopleSoft environment.
ager Driver for PeopleSoft Implementation Guide
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2Installing the Driver 

• Section 2.1, “Driver Requirements,” on page 17
• Section 2.2, “Installation Instructions,” on page 17
• Section 2.3, “Importing the PeopleSoft Driver,” on page 17
• Section 2.4, “Activating the Driver,” on page 20

2.1  Driver Requirements
Novell® Identity Manager 3
Windows* NT 4.0 with Service Pack 5 or higher, or Windows 2000
The appropriate version of PeopleTools and Tuxedo* Application Server

2.2  Installation Instructions
You install the driver as part of the Novell Identity Manager 3 installation program. For installation 
instructions, refer to the “ Installing Identity Manager” chapter of  Identity Manager 3.0 Installation 
Guide.

2.3  Importing the PeopleSoft Driver
This section talks briefly about importing the PeopleSoft driver through Designer and iManager 
utilities.

2.3.1  Importing the Driver Configuration File In Designer
Designer allows you to import the basic driver configuration file for PeopleSoft. This file creates 
and configures the objects and policies needed to make the driver work properly. The following 
instructions explain how to create the driver and import the driver’s configuration. 

There are many different ways of importing the driver configuration file. This procedure only 
documents one way.

1 Open a project in Designer and in the modeler, right-click on the Driver Set object and select 
Add Connected Application.

2 From the drop-down list, select PeopleSoft36.xml, then click Run.
3 Click Yes, in the Perform Prompt Validation window. It has you fill in all of the fields to 

correctly configure the PeopleSoft driver.
4 Configure the driver by filling in the fields. Specify information specific to your environment. 

PeopleSoft Platform PeopleTools Version

PeopleSoft 7.5 PeopleTools 7.57 or higher

PeopleSoft 8.1 PeopleTools 8.17 or higher
Installing the Driver 17
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5 After specifying parameters, click OK to import the driver.
6 After the driver is imported, customize and test the driver.
7 Once the driver is fully tested, deploy the driver into the Identity Vault. See “Deploying a 

Driver to an Identity Vault” in the Designer for Identity Manager 3: Administration Guide.

2.3.2  Importing the Driver Configuration In iManager
The Create Driver Wizard helps you import the basic driver configuration file. This file creates and 
configures the objects and policies needed to make the driver work properly. 

The following instructions explain how to create the driver and import the driver’s configuration.
1 In Novell iManager, click Identity Manager Utilities > Import Drivers.
2 Select a driver set, then click Next.

If you place this driver in a new driver set, you must specify a driver set name, context, and 
associated server.

3 Select Import a Driver Configuration from the Server, then select PeopleSoft36.xml.
The driver configuration files are installed on the Web server when you install Identity 
Manager. During the import, you are prompted for the driver’s parameters and other 
information. 

4 Specify the driver’s parameters, then click OK to import the driver.

Table 2-1   Driver Configuration Parameters

Parameter Name Parameter Description

Driver name The actual name you want to use for the driver. 

Active Users 
Container

The name of the Organizational Unit object where Active users are placed. You 
can modify this option through the driver’s Global Configuration Variable (GCV).

Inactive Users 
Container

The name of the Organizational Unit where Inactive users are placed. You can 
modify this option through the driver’s GCV.

Active 
Employees 
Group

The name of the Group Object to which Active “Employee” users are added. You 
can modify this option through the driver’s GCV.

Active 
Managers 
Group

The name of the Group Object to which Active “Manager” users are added. You 
can modify this option through the driver’s GCV.

Event Server 
Host Name and 
Port

The host name or IP address and port number of the computer where the Event 
Server that connects to PeopleSoft is running. The default port is 16500.

PeopleSoft 
Connection 
String

The host name or IP address and port number for connecting to the appropriate 
PeopleSoft Application server. This is typically referred to as the PeopleSoft 
application server connection string. The default port is 9000.

PeopleSoft User 
ID

The PeopleSoft User ID the driver uses for PeopleSoft authentication.
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The additional driver parameters are set to default values during the import process, but they 
can be modified in iManager (by clicking the Driver Configuration tab on the driver object.)

Table 2-2   Additional Driver Parameters

PeopleSoft User 
Password

The PeopleSoft User password this driver uses for PeopleSoft authentication.

Install Driver as 
Remote/Local

Configure the driver for use with the Remote Loader service by selecting the 
Remote option, or select Local to configure the driver for local use. If Local is 
selected, you can skip the remaining parameters.

Remote Host 
Name and Port

Enter the hostname or IP address and port number where the Remote Loader 
service has been installed and is running for this driver. The default port is 8090. 

Driver 
Password

The driver object password is used by the Remote Loader to authenticate itself to 
the Metadirectory server. It must be the same password that is specified as the 
driver object password on the Remote Loader.

Remote 
Password

The Remote Loader password is used to control access to the Remote Loader 
instance. It must be the same password that is specified as the Remote Loader 
password on the Remote Loader. 

Parameter Name Description

Event Server Host Name The host name or IP address of the Event Server that connects to 
where PeopleSoft is running.

Event Server Port Number The IP port number on which the driver Event Server component 
listens for connection from the driver shim.

Data Record ID Field The name of the field in the Data Schema CI that uniquely identifies 
a PeopleSoft object. The value in this field in the Data Schema that 
uniquely identifies a PeopleSoft object. The value in this field is 
used as the DirXML® object association identifier. The default field 
name is DIRXML_ASSOC_ID.

eDirectoryTM Object Class 
Name

The eDirectoryTM object Class to which the Data Record definition 
maps. The default value is User.

Schema Data Subscriber 
Activity

The name of the PeopleSoft Activity object that defines the data that 
can be synchronized from the Identity Vault to the PeopleSoft 
application. The default Subscriber Activity is 
DIRXML_SCHEMA01_UPDATE. 

You should ensure that the Message Definition within this Activity 
matches the name of the Activity.

Schema Data Query Activity The name of the PeopleSoft Activity object that defines the data that 
the driver reads from the PeopleSoft application. This data is 
usually the subset of application data elements contained within the 
Schema Data Publisher Activity. The default Query Activity is 
DIRXML_SCHEMA01_QUERY.

You should ensure that the Message Definition within this Activity 
matches the name of the Activity.

Parameter Name Parameter Description
Installing the Driver 19
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When the import is finished, you can define security equivalences and exclude administrative 
roles from replication. 
The driver object must be granted sufficient eDirectory rights to any object it reads or writes. 
You can do this by granting Security Equivalence to the driver object. The driver must have 
Read/Write access to users, post offices, resources, and distribution lists, and Create, Read, and 
Write rights to the post office container. Normally, the driver should be given security equal to 
Admin.

5 Review the driver objects on the Summary page, and then click Finish.

2.4  Activating the Driver
Activation must be completed within 90 days of installation or the driver will not run.

For activation information, refer to “Activating Novell Identity Manager Products” in Novell 
Identity Manager 3.0 Administration Guide.

Queue Poll Interval (seconds) The number of seconds the driver waits between attempts to 
process transaction records. This poll interval is only applied when 
no transactions are available for processing.

The default Poll Interval is 5 seconds.

Queue Retrieval Limit This parameter specifies how many transactions are retrieved by 
the driver from the PeopleSoft worklist queue each time the driver 
accesses the Transaction Access Activity. 

The default value is 5.

Transaction Access Activity The name of the PeopleSoft Activity object that defines the set of 
fields required for the DirXML Transaction interface. The set of 
fields in the specified transaction activity must contain the same 
fields and keys identified in the default transaction activity in order 
for the driver to work. 

The default Transaction Activity is DIRXML_TRANS01. 

You should ensure that the Message Definition within this Activity 
matches the name of the Activity.

Schema Data Publisher 
Activity

The name of the PeopleSoft Activity object that defines the set of 
data to be synchronized from the PeopleSoft application to the 
Identity Vault. 

The default Publisher Activity is DIRXML_SCHEMA01. 

You should ensure that the Message Definition within this Activity 
matches the name of the Activity.

NOTE: Additional transaction control key fields (field names are all 
capitalized) contained within the Message Definition are used for 
processing purposes only and are not synchronized.

Parameter Name Description
ager Driver for PeopleSoft Implementation Guide
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3Configuring Your PeopleSoft 
System

Use the information in the following section to configure your PeopleSoft system to share and 
synchronize data with the Novell® Identity Vault. 

• Section 3.1, “Installing the PeopleSoft Service Agent,” on page 21
• Section 3.2, “Running the Message Agent Test Program,” on page 28
• Section 3.3, “Installing the Event Server,” on page 32

3.1  Installing the PeopleSoft Service Agent
The process for installing the PSA is different for different versions of PeopleSoft. 

• Section 3.1.1, “Installing the PSA on PeopleSoft 7.5,” on page 21
• Section 3.1.2, “Installing the PSA on PeopleSoft 8.1,” on page 25

NOTE: Any references to specific paths in these sections represent the defaults indicated during the 
installation procedures. Apply the necessary changes if applicable.

3.1.1  Installing the PSA on PeopleSoft 7.5
If you are using PeopleSoft 7.5, you should complete the following tasks to install the PSA:

• “Extracting the PSA Files” on page 21
• “Installing the PeopleSoft Service Agent” on page 22
• “Installing the PSA for PeopleSoft 7.5” on page 22
• “Copying the Novell Integration Project into a Target Database” on page 23
• “Building Project Record Definitions” on page 23
• “Establishing Roles and Initiating Workflow” on page 24
• “Establishing Security for PSA Objects in PeopleSoft 7.5” on page 24

Extracting the PSA Files

The PSA project comes as a self-extracting project. To extract the project:
1 From the location you specified when you installed the components for PeopleSoft, run 
dirxml_driver_36.exe. The default location is Novell\nds\ps.

2 Click Next, select the destination directory, then click Next to begin extracting the PSA files.
3 Click Finish to close the extraction process.

The PSA is now ready to be installed into your PeopleSoft environment.
Configuring Your PeopleSoft System 21
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Installing the PeopleSoft Service Agent

Before you can install and configure the PeopleSoft objects, you need access to a PeopleSoft user ID 
and password with Administrator or appropriate developer rights. You can create a unique user ID 
and password for implementing these objects.

To apply the delivered PSA set of objects, follow PeopleSoft's standard upgrade procedures. For 
information on PeopleSoft upgrade procedures, refer to PeopleSoft documentation.

Installing the PSA for PeopleSoft 7.5

Data Mover is an application tool used to import external PeopleSoft objects into an existing 
PeopleSoft 7.5 database. Using the standard PeopleSoft upgrade process, you use Data Mover to 
move the Identity Manager for PeopleSoft projects into an organization's PeopleSoft environment.

A Data Mover script (DMS) is provided with the driver. This script imports new and modified 
objects into the data dictionary tables. You should only run this script on a refreshed Application 
Update Database (AUD). Refreshing the database resolves any conflicts between the delivered 
objects and any objects that already exist in the AUD database. 

WARNING: If the DMS is run against a database other than the AUD, it can fail or overwrite 
existing data. If you run the script directly against the PeopleSoft development database, it corrupts 
the database. 

To ensure that the DMS files were copied during the component installation, check the C:\PSA 
directory. This is the default directory that the installation program uses. If you altered this setting 
during the installation, check the directory that you specified. The following are default steps to 
import the external PeopleSoft objects:

1 From the Start menu, click Programs > PeopleSoft > Data Mover.
2 Log in to the AUD database.
3 Select File > Open.
4 Browse to the appropriate file for your installation, then select the DMS script with the 

appropriate release number. (For example, DIRXML_DRIVER_PSA_36IMP.DMS.)
The release number should be the same as the release number of the PeopleSoft database.

5 In the Data Mover syntax dialog box, verify that the input and log files are pointing to the 
directory containing the data (.dat) files on the local drive. 
The following is an example of the delivered syntax:
SET OUTPUT c:\PSA\AU_CHECK.DAT;

SET INPUT c:\PSA\PSA-PS75\DIRXML_DRIVER_PSA_36IMP.DAT;

SET LOG c:\PSA\DIRXML_DRIVER_PSA_36IMP.LOG;

SET NO TRACE;

SET IGNORE_DUPS;

EXPORT AU_CHECK;

IMPORT *;

6 Select File > Run Script.
From the report in the bottom status panel, verify if the import was successful. If the import 
fails, make sure the input and output paths point the proper directories.
ager Driver for PeopleSoft Implementation Guide



novdocx (E
N

U
)  10 N

ovem
ber 2005
7 Click Close to close the Data Mover.

Copying the Novell Integration Project into a Target Database

Your target database contains the system catalog, data dictionary structures, and sample application 
data. When moving from an AUD database to the target database, objects from the data dictionary in 
the AUD are copied to the data dictionary of the target database. 

After the copy is complete, you must build the database. The build creates the physical tables or 
views in the underlying database so that the objects are accessible. You should be logged in as an 
administration user when completing these procedures.

We recommend the following:

• Use a clean copy of a target database for this procedure.

If you apply a copy to a database with production data, do a copy and compare before you 
apply the copy.

• Complete an installation and test that installation against a target database.
Do this before you change the configuration and before you apply the database to a 
development or production environment.

To copy the project into a target database:
1 From the Start menu, click Programs > PeopleSoft > PeopleTools.
2 Log in to the AUD database.
3 Click Go > PeopleTools > Application Designer > File > Open.
4 Click Object Type, then click Project.
5 Click Selection Criteria, Name, type DIRXML_DRIVER_PSA_36, then click Select.
6 Click the project, then click Select.
7 Click Tools > Upgrade > Copy. 
8 Type the target database name (the project will be copied to this database), operator ID, and 

password, then click OK.
Be sure to select all objects with the project, including the project itself.

9 Check the Export Project box to export the objects to the target database, then click Copy.
All objects are copied from the AUD to the target DMO database.

10 Click Close to close the Application Designer window.

Building Project Record Definitions

After you have imported the project into the PeopleSoft database, you should build project record 
definitions and then build project views.

1 From the Start menu, click Programs > PeopleSoft > PeopleTools.
2 Log in to the target database using an administrator username that has administrative and 

development rights.
3 In the Application Designer, click File, then click Open. 
4 Select the DIRXML_DRIVER_PSA_36 project, then click Open.
5 Click Build > Project.
Configuring Your PeopleSoft System 23
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6 From Build >  Options, click Create Tables and Execute SQL Now. 
7 Click Build to create sample project tables. After project tables are created, click Close to close 

the Build Progress window.
You must create project tables before creating the views. Views are created using information 
from table fields.

8 In the Application Designer, select Build > Project.
9 In Build Options, click Create Views and Execute SQL Now. 

10 Click Build to create the sample project views. After the views are created, click Close to close 
the Build Progress window.

You should now establish roles and initiate workflow. Refer to “Establishing Roles and Initiating 
Workflow” on page 24.

Establishing Roles and Initiating Workflow

A role is a class of users who perform the same type of work. Business policies typically determine 
what role performs what activity. The eDirectoryTM administrator has been designated as the role 
performing the ADD, UPD, and DIS events. This means that workflow must be activated and a role 
user must be assigned to the eDirectory administrator role. To activate a workflow, complete the 
following:

1 Click Go > PeopleTools > Workflow Administrator.
2 Click Use > Workflow System Defaults > Defaults.
3 Select the Worklist Active box.
4 If you are using e-mail and other electronic forms, select the applicable boxes.
5 Ensure that a default role user, typically WF Admin, is also assigned, then click Save. If 

workflow is not currently being used by other processes, change this role user to the role of 
eDirectory Administrator.

You should now assign security rights to the new objects. See “Establishing Security for PSA 
Objects in PeopleSoft 7.5” on page 24.

Establishing Security for PSA Objects in PeopleSoft 7.5

You can assign security rights to all new panels and pages that have been added to a project. Use an 
administrator-type account to establish security. 

Applying Security for the New PSA Objects
1 Click Go > PeopleTools > Security Administrator.
2 Click File > Open. Select the ALLPANLS Operator Class, then click OK.
3 Click the Menu Items icon from the left pane.
4 Click Insert > Menu Name.
5 Double-click DirXML_Administrator_36, click Select All, then click OK.
6 Click Select All, then click OK.
7 Click Save. 
8 After you save, you can exit the Security Administrator interface.
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Verifying Access to PSA Objects

After you have applied security to the new PSA objects, you should use the sample application to 
verify that you can access, change, and save data.

You can test to ensure that transactions are created by entering a new person using the sample 
application. This example uses Departments, so you need to create a sample department, and then 
add a person (assigning him or her to that department) to validate that the application works.

1 Connect to the PeopleSoft database as administrator in two tier mode. 
2 In the Application Designer, click Go > DirXML > DirXML Administrator 36 EP.
3 Select Use > DirXML Sample Department.
4 Click an empty Department field row to add a sample department and description.
5 Click Save to add the Department.
6 Select Use > DirXML Sample People > Add.
7 Specify an ID number for the new person, then click OK.
8 Provide data in the various fields for this ID, then click Save.

(The required fields include: First Name, Last Name, Birth Date, Status, Title, and Department 
ID.) 

9 To validate that an ADD transaction was created, access the eDirectory Worklist Maintenance 
menu. Click Use > eDirectory Worklist Maintenance > eDirectory Worklist. You can then 
search for the ID you just created. 

10 Click the Search button.
11 Double-click the event you created. Look at the panels and verify that the data you entered 

exists.
12 Click Close to close the PeopleSoft Client.

Now that you have completed the required tasks for installing and configuring the PSA, you should 
continue with “Running the Message Agent Test Program” on page 28.

3.1.2  Installing the PSA on PeopleSoft 8.1
Complete the following tasks to install the sample project for testing and configuration purposes:

• “Extracting the PSA Files” on page 25
• “Importing the PSA Project into the PeopleSoft Database” on page 26
• “Building Project Record Definitions” on page 26
• “Testing Sample PeopleSoft Applications” on page 26

NOTE: Any references to specific paths in these sections represent the defaults indicated during the 
installation procedures. Apply the necessary changes if applicable.

Extracting the PSA Files

The PSA project comes as a self-extracting project. To extract the project:
1 From the location you specified when you installed the components for PeopleSoft, run 
DIRXML_DRIVER_36.EXE. The default location is Novell\NDS\PS. 
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2 Click Next, select the destination directory, then click Next to begin extracting the PSA files.
3 Click Finish to close the extraction process.

The PSA is now ready to be installed into your PeopleSoft environment.

Importing the PSA Project into the PeopleSoft Database

With PeopleSoft 8, projects are delivered in a cache directory structure, which is similar to the cache 
structure found within PeopleSoft. With previous versions of PeopleSoft you needed to use the Data 
Mover script and compare, but this process is no longer necessary. 

To import the PSA into the PeopleSoft database:
1 Connect to the PeopleSoft database as administrator in two tier mode. 
2 From the Application Designer, select File > Copy Project From File.
3 Click Browse and select the PSA project directory: C:\PSA\PSA-PSA8\.
4 Click Copy.
5 With all object types selected, click Copy to copy all project components into the PeopleSoft 

database.

Building Project Record Definitions

After you have imported the project into the PeopleSoft database, you should build project record 
definitions and then build project views.

1 Log into PeopleSoft using an administrator username that has administrative and development 
rights.

2 In the Application Designer, select Build > Project.
3 In Build Options, click Create Tables and Execute SQL Now. 
4 Click Build to create sample project tables. After project tables are created, click Close to close 

the Build Progress window.
You must create project tables before creating the views. Views are created using information 
from table fields.

5 In the Application Designer, select Build > Project.
6 In Build Options, click Create Views and Execute SQL Now. 
7 Click Build to create the sample project views. After the views are created, click Close to close 

the Build Progress window.

Testing Sample PeopleSoft Applications

You can test to ensure that transactions are created by entering a new person using the sample 
application. This example uses Departments, so you need to create a sample department, and then 
add a person (assigning him or her to that department) to validate that the application works.

1 Connect to the PeopleSoft database as administrator in two tier mode. 
2 From the Application Designer, select Go > DirXML Administrator36.
3 From the DirXML Administrator menu, select Use > DirXML Sample Department.
4 Click an empty Department field row to add a sample department and description.
5 Click Save to add the Department.
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6 From the DirXML Administrator 36 menu, click Use > DirXML Sample People > Add.
7 Specify an ID number, then click OK.
8 Provide data in the various fields for this ID, then click Save. 

(The required fields include: First Name, Last Name, Birth Date, Status, Title, and Department 
ID.) 

9 To validate that an ADD transaction was created, click Use > eDirectory Worklist Maintenance 
> eDirectory Worklist. 

10 Click the Search button to search for the user you added. 

11 Double-click the event to view its details.

12 After you know that events are configured to process properly, you should ensure that you can 
make changes to the data and save it. Click Use > eDirectory Subscriber.
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13 Click Search and locate the sample person you created. 
14 Specify a sample value (or modify an existing value) in the phone number field, then click 

Save.
15 Click Use > eDirectory Query > DirXMLQuery01.
16 Click Search and double-click your sample person.
17 Verify that the phone number you added or modified has changed.

18 You can now close the PeopleSoft client.

Now that you have completed the required steps for configuring the PSA, proceed to “Running the 
Message Agent Test Program” on page 28.

3.2  Running the Message Agent Test Program
You can test the following PeopleSoft Message Agents:

• DIRXML_TRANS01
• DIRXML_SCHEMA01
• DIRXML_SCHEMA01_UPDATE
• DIRXML_SCHEMA01_QUERY

For detailed troubleshooting information regarding the Message Agent Test System, see Chapter 4, 
“Troubleshooting the Driver,” on page 37.

3.2.1  Testing the DIRXML_TRANS01 PeopleSoft Message 
Agent
Dirxml_trans01.ist verifies that the Message Agent is receiving events from the worklist.

NOTE: Script files that have 8 after the script name are for PeopleSoft 8.1. Other IST scripts are for 
PeopleSoft 7.5.

1 Browse to the C:\PSA\PSA-P75\ or C:\PSA\PSA-P8\ directory.
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2 Copy the appropriate test program for a message agent to the 
{ps_home}\bin\client\winx86 directory.

3 Create a shortcut on the desktop to the Message Agent Test program.
4 View the program’s properties, and validate that the .ist file is not set to read-only.
5 Double-click the test program.
6 Click File > Open.
7 Click the dirxml_trans01.ist file, then click Open.
8 Ensure that the appropriate connect string, operator ID, and password are listed for connecting 

to the application server.
9 Click Execute.

If the Message Agent is working properly, a list of processing key fields is populated.
The following is a sample script:
Connect 137.65.147.162:7000,PS,PS; 
StartMessage DIRXML_TRANS01,DIRXML_TRANS01; 
ProcessMessage; 
GetOutPutall; 
Disconnect;

In this script the connect string is 137.65.147.162:7000. The User ID is PS, and the password is 
PS.

You can now close the DIRXML_TRANS01 window. Do not close the Message Agent Test 
program, because you use it in the following steps.

3.2.2  Testing the DIRXML_SCHEMA01 PeopleSoft Message 
Agent
Dirxml_schema.ist verifies that all of the fields on the DIRXML_SCHEMA01 business 
process definition are being passed to the Message Agent. 

1 Double-click the message test program.
2 Click File > Open.
3 Click the dirxml_schema01.ist file, then click Open.
4 Verify that the appropriate connect string, operator ID, and password are listed.
5 Modify the INSTANCEID, INSTSTATUS, ACTIVITY NAME, and EVENTNAME fields. 

You can find this information by searching for the person and viewing the 
DIRXML_SCHEMA01 panel on the eDirectory Work List Maintenance Search panel shown 
below:

PeopleSoft Version Test Program

PeopleSoft 7.5 psmtst32v75.exe

PeopleSoft 8.1 psmtst32v80.exe
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These fields must correspond to the event that you are trying to receive the output data for. 
Copy and paste appropriate values from the output from the previous test. This output was 
generated from testing dirxml_trans01.ist.

6 Click Save.
7 Click Execute.

If the Message Agent is working properly, all the fields that are populated in PeopleSoft are 
populated in the output.
The following is a sample script:
Connect 137.65.147.182:7000,PS,PS; 
StartMessage DIRXML_SCHEMA01,DIRXML_SCHEMA01; 
Setfield BUSPROCNAME=DIRXML_INTEGRATION; 
Setfield ACTIVITYNAME=DIRXML_EVENT1; 
Setfield EVENTNAME=ADD; 
Setfield WORKLISTNAME=DIRXML_ADD; 
Setfield INSTANCEID=5; 
Setfield INSTSTATUS=0; 
Setfield COMMENTSHORT=Selected; 
ProcessMessage; 
GetOutPutall; 
Disconnect;

8 Close the log files.

3.2.3  Testing the DIRXML_SCHEMA01_UPDATE PeopleSoft 
Message Agent
Dirxml_schema01_update.ist tests updates to the PeopleSoft record 
DIRXML_SCHEMA01_UPDATE. This process tests events that come from eDirectory rather than 
events that are sent from PeopleSoft. 

1 Double-click the message test program.
2 Click File > Open.
3 Click the dirxml_schema01_update.ist file, then click Open.
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4 Verify that the appropriate connect string, operator ID, and password are listed.
5 Modify the ASSOC ID, NDS ID, NDS CONTEXT, and Description fields.

These fields must correspond to the employee that you are trying to update.
6 Click Save.
7 Click Execute.

If the Message Agent is working properly, the eDirectory Subscriber page (the NDS Data 
Update panel for PeopleSoft 7.5) is populated with the appropriate eDirectory ID, 
Distinguished Name, E-mail, and Description fields for the selected employee. 
The following is a sample script:
Connect 137.65.139.178:7000,PS,PS; 
StartMessage DIRXML_SCHEMA01_UPDATE,DIRXML_SCHEMA01_UPDATE; 
SetField Assoc ID=8964; 
SetField NDS ID=GHORNBE; 
SetField NDS CONTEXT=NCS.PRV.NOVELL; 
SetField Description=Updated; 
SetField email=unknown; 
ProcessMessage; 
GetOutPutall; 
Disconnect;

8 Close the log file.

3.2.4  Testing the DIRXML_SCHEMA01_QUERY PeopleSoft 
Message Agent
DirXML_schema01_query.ist tests the query function for the driver from PeopleSoft. This 
process tests the ability to retrieve data from PeopleSoft based on ASSOC ID. 

The Output fields defined on the Query object need to be equivalent to those that are defined on the 
DIRXML_SCHEMA01 object. 

The primary difference between these two objects is the key input fields. This object only has the 
object ID as the key field (for example, Assoc ID).

1 Double-click the message test program.
2 Click File > Open.
3 Click the dixml_schema01_query.ist file, then click Open.
4 Verify that the appropriate connect string, operator ID, and password are listed.
5 Modify the Assoc ID.

This field must correspond to the employee that you are trying to access.
6 Click Execute.

If the Message Agent is working properly, all the fields that are populated in PeopleSoft are 
populated in the output.
The following is a sample script:
Connect 137.65.139.178:7000,PS,PS; 
StartMessage DIRXML_SCHEMA01_QUERY,DIRXML_SCHEMA01_QUERY; 
SetField Assoc ID=8964; 
ProcessMessage; 
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GetOutPutall; 
Disconnect

7 Close the log file.

Now that you have tested your PeopleSoft message agents, you should install the event server. Refer 
to “Installing the Event Server” on page 32.

3.3  Installing the Event Server
Typically, the Event Server is installed when you run the installation program. If either of the 
following has occurred, manually install or configure the desktop shortcut for the Event Server:

• You did not install the Event Server when you installed other components.
• Any directory paths were unavailable during the installation.

3.3.1  Installing the Event Server
The following steps assume that eDirectory has been installed on drive C: of the server in the 
\novell\remoteloader\ directory.

1 Copy the following to the c:\novell\nds directory.

• NPS75EventServer.exe for PeopleSoft 7.5
• NPS81EventServer.exe for PeopleSoft 8.1

2 Create a shortcut for the Event Server application on the desktop.

IMPORTANT: If you are running multiple PeopleSoft drivers, create one shortcut for each 
Event Server.

3 Edit the command line in the Target field.
The following graphic illustrates this field:

Right-click the shortcut, then click Properties > Shortcut. 
Enter parameters for the shortcut. In the following table, {PS_Home} is the root of the 
PeopleSoft directory structure.
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The -c parameter configures the Event Server so that it runs as a console application. When you 
use this parameter, configure the DOS window properties with the following:

• A scroll bar
• A different color layout

The Event Server communicates with the driver using a Windows* sockets interface or 
listening port. The following table lists the suggested socket number for each Event Server. If 
these numbers conflict with sockets already being used in your organization, use a different 
port set. 

Because each Event Server requires four consecutive sockets or ports, socket numbers for 
multiple Event Servers must be at least four digits apart.
The Event Server must establish communications with the PeopleSoft Message Agent. It does 
this by connecting to the PeopleSoft Message Agent DLL files. 
These DLL files are typically located in the PS_HOME\BIN\CLIENT\WINX86 directory. 
For the NPS75EventServer shortcut, an example path to the PeopleSoft Message DLLs is -
p:d:\psoft\hr757\bin\client\winX86. In this example, PS_HOME is equal to 
d:\psoft\hr757.

4 Type the following in the Start In field:
c:\Novell\NDS 
This is the directory where eDirectory is installed. The following figure illustrates this field:

5 Select Apply, then click OK.
6 Open the application via the shortcut.

You can customize the scroll bar and color changes by customizing the Property tab on the window. 

PeopleSoft 
Platform Parameters

PeopleSoft 7.5 C:\Novell\NDS\NPS75EventServer.exe -c -s:16386 
-p:PS_Home\bin\client\winx86

PeopleSoft 8.1 C:\Novell\NDS\NPS81EventServer.exe -c -s:16394 
-p:PS_Home\bin\client\winx86

Event Server Port

PeopleSoft 7.5 Event Server 16386

PeopleSoft 8.1 Event Server 16394
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Stopping the Event Server

You might need to stop the Event Server to refresh PeopleSoft connectivity, recycle the server, or 
debug. When you stop the Event Server, the Event Server sends a stop command to the driver shim. 
This command shuts down the driver shim before the Event Server exits.

To stop the Event Server from a console window:
1 Select the Event Server window.
2 Enter Q.

IMPORTANT: You can stop the Event Server by clicking the Exit icon in the window. However, do 
this only if the driver shim is not running. Before clicking the icon, shut down the driver shim. Do 
this from the DirXML* Driver Set Properties menu.

Installing the Event Server as a Service

You can install the Event Server as a Windows NT or Windows 2000 service. Normally, the Event 
Server is installed during the driver installation.

Two additional shortcuts are placed on the desktop during the installation process. These shortcuts 
enable you to create or remove the Event Server as a service.

To install the Event Server as a service:
1 Ensure that the Event Server program is available. 

• On a local machine, verify that NPSxEventServer.exe is saved locally to the machine.
• If you are installing the Event Server on a remote server where eDirectory is not installed, 

copy dirxmllib.dll and expat.dll from the novell\nds directory to the 
directory that the Event Server will run from.

NOTE: The PeopleSoft client must always be installed on the server where the Event 
Server is going to run.

The remote server’s IP address is used when configuring the Event Server in the driver 
parameters.

2 At the command prompt, go to the directory where the executable file is stored, then enter the 
following:
NPS75EventServer.exe -i -s:16386 -p: PS_HOME\bin\client\winx86

The socket number and the path to the PeopleSoft Psmsg.dll might be different, based on 
your environment and driver configuration.

3 From the Start menu, click Settings > Control Panel > Services > DirXML Event Server for PS 
7.5 (or the appropriate release).

4 Click Startup > select the Automatic option button to automatically start the Event Server at 
login, then click Start.

To stop the service:
1 From the Start menu, click Settings > Control Panel > Services. 
2 Select the service, then click Stop.
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Manually Uninstalling the Event Server As a Service

You can uninstall or remove the Event Server as a service. Follow the same steps as for installing the 
Event Server. However, in Step 2, substitute the -u parameter for the -i parameter.

For example, enter the following:

NPS75EventServer.exe -u -s:16386 -p: PS_HOME\bin\client\winx86

NOTE: When the Event Server runs as a service, there is no console window. All debug information 
is only available in the DSTRACE log.
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4Troubleshooting the Driver

This section contains potential problems and error codes you might encounter while configuring or 
using the driver. 

4.1  Resolving Errors
The Resolving Errors section is broken into they types of error codes you may encounter and how to 
resolve those errors.

• Section 4.1.1, “The Event Server Does Not Load,” on page 37
• Section 4.1.2, “The Driver Does Not Start,” on page 37
• Section 4.1.3, “The Driver Is Not Communicating with the Event Server,” on page 37
• Section 4.1.4, “The Event Server Receives Message Agent Errors,” on page 38
• Section 4.1.5, “Attributes Do Not Get Refreshed on the Data Map Object,” on page 38
• Section 4.1.6, “Driver Only Appears to Process Transactions,” on page 38
• Section 4.1.7, “Data Does Not Show up in the Identity Vault on the Publisher Channel,” on 

page 39
• Section 4.1.8, “Data Does Not Update in PeopleSoft on the Subscriber Channel,” on page 39
• Section 4.1.9, “No Transactions Are Coming Across the Publisher Channel,” on page 39
• Section 4.1.10, “Transactions Do Not Get Placed in the PeopleSoft Queue,” on page 39
• Section 4.1.11, “No Data Is Returned When Running the Message Test Program,” on page 39
• Section 4.1.12, “Transactions Are Left in Selected State and Not Processed,” on page 40
• Section 4.1.13, “Receiving Errors on the Publisher Channel When Processing a Transaction,” 

on page 40
• Section 4.1.14, “Message Agent Relationships Are Not Functioning,” on page 40

4.1.1  The Event Server Does Not Load
• Check the path environment variable to assure that the PeopleSoft client and the Identity 

Manager directory are in its path.

4.1.2  The Driver Does Not Start
• Check that the Event Server is running.
• Check that the npsshim.dll file is accessible.
• Check that the connection parameters are set correctly.

4.1.3  The Driver Is Not Communicating with the Event Server
• Verify that the Event Server was started first.
• Verify that the Event Server and driver do not have multiple copies running. 
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• Verify that the connection was not previously broken.

• You might need to restart Novell® eDirectory™ and then restart the driver components.

4.1.4  The Event Server Receives Message Agent Errors
• Verify that the APIs are configured appropriately. (Use the Message Agent Test Program.)
• Verify that the Application Server is running.
• Verify connectivity to the Message Agent.
• Makes sure you have the correct PeopleSoft Application Server Connection String:

You can use either: HOSTNAME:PORT or IP:PORT for single instance of Application Server
or
Use Fail Over Mode: //HOSTNAME:PORT,//HOSTNAME:PORT where the first entry is the 
first Application Server and the second entry is the second Application Server to which the 
driver tries to connect.

• Make sure the names of the Message Agent APIs are spelled correctly. These names are case 
sensitive.

• Check for errors when updating the Worklist transaction.
• Check for errors on the Application Server.
• Check for errors on the SMTP gateway.
• Verify password usage of the driver. This might be case sensitive depending on the platform 

you use.

4.1.5  Attributes Do Not Get Refreshed on the Data Map Object
• Verify that the Message Agent APIs are working correctly.
• Verify that both the worklist and data update APIs are working correctly 

(DIRXML_SCHEMA01 and DIRXML_SCHEMA01_UPDATE).

4.1.6  Driver Only Appears to Process Transactions 
Transactions appear to be read from the worklist, but nothing gets processed by the driver. Messages 
repeat themselves. The following text output might appear on the Event Server console:

Record Count: 5

Processing record 1 of 5.

Processing record 2 of 5.

Processing record 3 of 5.

Processing record 4 of 5.

Processing record 5 of 5.

However, no data is being processed. This is a result of reading transactions out of the worklist, but 
being unable to retrieve the data from the transaction. Make sure that you can read the data from the 
default DIRXML_SCHEMA01 Message definition. You should also:
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• Verify that you can read a particular transaction with the Message Test Program.
• Verify that you only get one record when accessing the same transaction online.
• Verify that the ACTIONDTTM field has been removed as an input key field on the API.

4.1.7  Data Does Not Show up in the Identity Vault on the 
Publisher Channel

• Verify that the Mapping policy and filters are configured correctly.
• Verify that the APIs are working correctly and data is being produced by them.

4.1.8  Data Does Not Update in PeopleSoft on the Subscriber 
Channel

• Verify that the Mapping policy and filters are configured correctly.
• Verify that the APIs are working correctly.

4.1.9  No Transactions Are Coming Across the Publisher 
Channel

• Verify that the eDirectory Default Synchronization check box is selected.
• Verify that there are active transactions in the queue ready for processing.
• Ensure that driver parameters are pointing to the correct PeopleSoft database. For example, 

transactions do not process if they are in the PROD database, but the driver is still pointing to 
the test database (which is configured to run with the driver, but holds no transactions). 

4.1.10  Transactions Do Not Get Placed in the PeopleSoft 
Queue

• Verify that PeopleCode is working properly.
• Verify that you are not in correction mode when performing updates.

4.1.11  No Data Is Returned When Running the Message Test 
Program
No data is returned, particularly when you are running the Message Test Program. You might see 
errors such as “No Text Available.”

There are two typical reasons for this error: 

• The Key Input elements are not pointing to the Search Record on the Field Mapping definition 
of the Activity.

• The field elements point to an invalid reference.

Make sure the Key Input elements are associated with the Search Record entry on the field mapping 
definition and not directly with the table. Also, make sure that the field elements are mapped to an 
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appropriate field record definition that exists in the application buffer. You should also ensure that 
the data elements exist on a page within the application and that the links are configured correctly.

4.1.12  Transactions Are Left in Selected State and Not 
Processed

• Verify that all of the Message Activities can be processed and that the states can be updated to a 
2 (worked) or 4 (error). 

If e-mail is configured in PeopleSoft and the SMTP gateway is down, an error can occur 
causing the update of the transaction list to fail. You should verify that all online processing of 
the application works correctly. PeopleCode attached to the update might sometimes fail, thus 
causing the transaction to fail. If system connectivity is lost, the database or application server 
goes down during processing and causes the driver to abandon the transaction. The transaction 
is left in the state of “selected” with a status of 1.

4.1.13  Receiving Errors on the Publisher Channel When 
Processing a Transaction

Table 4-1   Sample errors and possible solutions

4.1.14  Message Agent Relationships Are Not Functioning
If data does not show up in the attributes, or isn’t getting posted into PeopleSoft, or data is missing, 
you should begin looking at the message agent relationships. You should:

• Verify that the API is getting the data from the PeopleSoft buffer. (Use the Message Agent Test 
program and follow all four steps in the driver process to test all of the APIs.)

For the delivered Message Agent Activities, the following procedure represents the process 
flow of testing the Message Agent Scripts with the Message Agent Test Program. The purpose 
of this test is to completely validate and walk through the process that the driver uses to 
interface with PeopleSoft and retrieve transactions and update the PeopleSoft environment. 
Each of the applications that these Message Activities are connected with should be tested 
online through the use of PeopleTools prior to testing the Message Agent scripts.

Sample Errors Possible Solutions

Operation vetoed by Create policy Possible required data missing in the Create policy 
or other criteria in the Create policy has an error.

generateKeyPair: -216 
DSERR_PASSWORD_TOO_SHORT

The attribute used for the initial password does not 
comply to policy, but the User object will still be 
created.

Unable to read current state of 8101 No association exists for this identity.

nameToID: -601 ERR_NO_SUCH_ENTRY Possible Placement policy error with an invalid 
container object designated.

No DN generated by Placement policy Possible missing or invalid data causing no valid 
DN to be created.
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1 Ensure that you only have one active/available transaction in the worklist ready for processing.
2 Execute the dirxml_trans01.ist script to retrieve the transaction in the worklist.
3 Verify that key elements of the transaction are returned and that they are unique.
4 Execute the second script, DIRXML_SCHEMA01, replacing the key element values with the 

values retrieved from Step 2 above from the execution of dirxml_trans01.ist script. 
Also, change the INSTSTATUS to 1 in order to represent updating the PeopleSoft transaction 
to a selected state.

5 Validate that all of the data elements appear as desired.
If elements are missing, there is probably an issue with the data being retrieved on one of the 
pages in the application. You should check the ...DATA1X, ...DATA2X, and ...DATA3X pages 
in the associated application. Sometimes, even though the data shows up on the page, it doesn't 
appear in the results when running the script because there is a problem in the related display 
definition.
Another reason why the data might not appear is that the process direction is not set to output 
on the Field Mapping within the Activity definition.

6 Repeat steps 4 and 5 by executing the script again for the same transaction while changing the 
status to 2 (worked) and 4 (error). 
The driver, when processing a transaction, always sets the transaction to a status of 1 (selected). 
When the transaction is processed it either sets the transaction to 2 (worked) or 4 (error). If an 
error occurs, the comment field is also updated. Be sure to test all possible updates and verify 
online that the update occurred as desired.

7 Execute the DIRXML_SCHEMA01_UPDATE script for a particular object. The default would 
be for a particular employee by specifying the EMPLID of the employee. The NDS ID and 
NDS CONTEXT fields are updated in PeopleSoft on the DIRXML_TRANS01 record when 
the driver complete processing of a transaction retrieved on the publisher channel. If this fails, 
the driver cannot complete the update of the status that occurs in the prior steps. The update of 
these fields is for documentation purposes only or to make them available elsewhere in 
PeopleSoft, or for using in an e-mail generated by a PeopleSoft workflow, etc. This 
functionality can be turned off by using an override parameter defined on the properties 
parameter page in the driver configuration.

NOTE: You should execute the script multiple times by replacing the contents of the 
Description and the Email ID fields and any additional fields that might have been added to the 
DIRXML_TRANS01 table and this definition that are set to be updated by the driver on the 
Subscriber channel, such as from the Identity Vault to PeopleSoft.

8 Execute the DIRXML_SCHEMA01_QUERY script to validate that the data elements for a 
particular object are accessible. 
These elements should all be set to output except for the key input value. The elements listed 
here on the field mapping should be consistent with those listed on the DIRXML_SCHEMA01 
definition. The only difference should be the key input fields. On this Activity, there is 
normally only one key input field for the object being accessed. This would equate to EMPLID 
for the delivered configuration against the HR database.

When all of the Message Agent Test Scripts have been tested completely with validation of all 
processes that the driver is configured to do, there should be no issues regarding the driver accessing 
PeopleSoft through the Message Agent. Typical other problems include: 

• Connectivity IP address and port for the application server
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• ID and password
• Correct naming of all activities in the parameters for the driver.

Remember that there are three basic test phases:

1. Test all of the processes manually online using the PeopleSoft applications as configured.
2. Test all of the processes using the four test scripts with the Message Agent Test program.
3. Test the driver connecting to the Activities through the Message Agent.
ager Driver for PeopleSoft Implementation Guide



5
novdocx (E

N
U

)  10 N
ovem

ber 2005
5Documentation Updates

This section contains information about content changes that have been made in this Novell Identity 
Manager Driver for PeopleSoft Implementation Guide. This information will help you to keep 
current on updates to the documentation.

The information is grouped according to the date the documentation updates were published. Within 
a dated section, the changes are alphabetically listed by the names of the main table of contents 
sections for Policy and Distribution Services.

The documentation is provided on the Web in two formats: HTML and PDF. The HTML and PDF 
documentation are both kept up to date with the documentation changes listed in this section.

If you need to know whether a copy of the PDF documentation you are using is the most recent, the 
title page of the PDF document contains the date it was published.

This documentation was updated on the following dates:

• “November 23, 2005” on page 43
• “August 3, 2004” on page 43

5.1  November 23, 2005
• References changed from Identity Manager 2 to Identity Manager 3, as well as all other name 

changes to applicable DirXML® names. Updated information is to apply to using the Identity 
Manager Driver for PeopleSoft v3.6.3 with Identity Manager 3.

5.2  August 3, 2004
• References to DirXML 2.0 have been changed to Identity Manager 2. The engine and drivers 

are still referred to as the DirXML engine and DirXML drivers.
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