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About This Guide

This Novell ZENworks System Reporting Reference includes information to help you create and manage 
reports by using ZENworks Reporting. The information is organized as follows:

 Chapter 1, “ZENworks Reporting,” on page 7
 Chapter 2, “Ad Hoc Editor,” on page 17
 Chapter 3, “Working with ZENworks Reporting Dashboards,” on page 49
 Chapter 4, “ZENworks Reporting Management,” on page 55
 Chapter 5, “ZENworks Reporting Configuration Tool,” on page 69

Audience

This guide is intended for ZENworks Reporting administrators.

Feedback

We want to hear your comments and suggestions about this manual and the other documentation 
included with this product. Please use the User Comments feature at the bottom of each page of the 
online documentation.

Additional Documentation

ZENworks Reporting is supported by other documentation (in both PDF and HTML formats) that 
you can use to learn about and implement the product. For additional documentation, see the 
ZENworks 11 SP2 documentation Web site (http://www.novell.com/documentation/zenworks11/).
About This Guide 5
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1 1ZENworks Reporting

The ZENworks Reporting Solution integrates with different Novell ZENworks products to provide 
reporting functionality for those products. This solution replaces the ZENworks Reporting Server 
that shipped with ZENworks 11 SP2. ZENworks Reporting Solution is available starting with 
ZENworks 11.2.4 and includes the following features: 

 Enables you to generate reports for different Novell ZENworks products.
 Provides an intuitive user interface, which can be leveraged to perform data analysis, by using 

Ad-Hoc Views. It also has enhanced capabilities to drill-down into data.
 Ships with pre-defined reports that are based on the most common use cases. You can use these 

reports as a starting point for your work.
 Provides scheduling capabilities to generate reports that can be delivered to your mailbox.
 Enables you to export report data in multiple file formats.
 Provides built-in charts that help you achieve new insights into your data.
 Supports LDAP-based authentication, thus facilitating easy access to non-ZENworks users or 

administrators within the organization.

This chapter includes the following sections:

 Section 1.1, “Overview,” on page 7
 Section 1.2, “Getting Started,” on page 8
 Section 1.3, “Connecting ZENworks Reporting from iReport Designer,” on page 14

1.1 Overview
The ZENworks Reporting Solution includes the following core components:

 Jaspersoft Reporting Engine: ZENworks Reporting uses Jaspersoft as the underlying reporting 
engine. This is a Web-based application.

 Domain: The Jaspersoft Reporting Engine uses domains to display objects or items that are used 
for reporting. A domain is a collection of objects mapped to a database schema. Domains are 
available for various ZENworks products such as ZENworks Configuration Management, Audit 
Management, and ZENworks Mobile Management. These domains are not shipped with 
ZENworks Reporting, but are provided with the individual ZENworks products. ZENworks 11 
SP3 ships with two sets of domains, ZENworks Configuration Management and ZENworks 
Audit. During the ZENworks Reporting installation, based on the information specified one or 
more of these domains will be imported into ZENworks Reporting. They can also be updated or 
imported later using the ZENworks Reporting Configuration tool. A domain is packaged as part 
of a zipped resource file.
ZENworks Reporting 7



 iReport: This is used to create complex reports and to format reports, that can be published in 
ZENworks Reporting. This is not a Web-based tool; it is installed on the server during the 
ZENworks Reporting installation. This tool allows you to create reports by using the available 
domain objects or by using user-specified SQL queries.
For more information, see Jaspersoft iReport Guide.

 LDAP Access: ZENworks Reporting currently supports only LDAP- based authentication. 
Thus, users must log in to ZENworks Reporting by using their LDAP credentials. ZENworks 
Reporting supports both Microsoft Active Directory and NetIQ e-Directory. As part of the 
installation process, the customer specifies LDAP groups with users who should have 
administrator privileges in ZENworks Reporting. During installation, these groups are mapped 
as Administrator Role in ZENworks Reporting. Subsequently, a user belonging to these groups 
can log in to ZENworks Reporting as an administrator.

 ZENworks Reporting Configuration Tool: This tool is installed on the server while installing 
ZENworks Reporting. It is used for configuring; or changing different settings such as SMTP 
Configuration, Domain and Datasource configuration, LDAP configuration, and SSL certificates.
For more information, see Chapter 5, “ZENworks Reporting Configuration Tool,” on page 69.

ZENworks Reporting presents a view of ZENworks data according to the user requirements. You can 
use the following ways to view ZENworks data:

 Ad Hoc View: These views are primarily data analysis tools provided by ZENworks Reporting. 
These views can be created by dragging and dropping various domain objects into the Ad Hoc 
Editor. Users can also select certain objects to be filters. Using these filters, a user can perform 
drill-downs on data to get further insight. In these views, a user still has access to all the data 
objects exposed by the domain and can swap objects. You can also achieve significant results by 
using the Ad Hoc View to generate reports using a combination of objects. After you get the 
required results, you can save this view for later use, or you can publish it as an Ad Hoc report. 
An Ad Hoc view can be a Tabular View, Chart View, or Crosstab View. 

 Ad Hoc Reports: These are custom reports that can be created either by saving an Ad Hoc view 
as a report, or by writing an SQL query and embedding it in a report.

 Predefined Reports: These reports are created by Novell. They are well formatted and have 
been built by using the iReport Tool. These reports are specific to a domain and are available in a 
zipped resource file, which is imported into ZENworks Reporting during installation, or can be 
configured later by using the ZENworks Reporting Configuration Tool.

 Dashboards: Dashboard is a collection of reports provided with relevant information. A 
dashboard can use the Predefined reports shipped with ZENworks Reporting, or it can be 
created using Ad hoc reports.

1.2 Getting Started
This section includes the following:

 Section 1.2.1, “Log in to ZENworks Reporting,” on page 9
 Section 1.2.2, “The ZENworks Reporting Home Page,” on page 9
 Section 1.2.3, “Browsing the Repository,” on page 11
 Section 1.2.4, “Searching the Repository,” on page 11
 Section 1.2.5, “Using Repository Resources,” on page 14
 Section 1.2.6, “Sorting the Repository List,” on page 14
8 ZENworks Reporting 5 System Reference
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1.2.1 Log in to ZENworks Reporting

You must log in to ZENworks Reporting with a password; in order to protect the data that you access 
through the server.

1 Enter http://<hostname>:<port-number> or http://<IP address>:<port-number> in a 
Web browser, where <hostname> is the name of the device that hosts the ZENworks Reporting 
Solution.

2 In the Login page, specify the user ID and password. The user ID must be the LDAP user ID.
3 If you want to change the default locale and time zone, click Show locale & time zone, then select 

the required locale and time zone from the drop-down list.
4 Click Login. 

The specified user ID internally authenticates with the LDAP server. After authorization, it 
allows you to log in to the application. Then the ZENworks Reporting Home page is displayed.

1.2.2 The ZENworks Reporting Home Page

From the Home page, you can quickly access the most frequently used features of the server. The 
menus that are displayed are based on user permissions.

The Home page contains the following icons:

 View Reports: Displays a list of reports that you can view and run.
 Create Ad Hoc View: Launches the Data Chooser wizard, followed by the Ad Hoc Editor for 

designing Ad Hoc views, which is the basis for creating reports on the server interactively.
 Create Report: Launches the Create Report wizard, which allows you to select an existing Ad Hoc 

view and generate a report.
 Manage Server: Launches the Server Settings page. Only administrators can view and access this 

menu. 

The other menus available on the Home page are  (Home), Library, View, Manage, and 
Create. The following table provides a description of these menus: 
ZENworks Reporting 9



If you log in as an administrator, the Home page is displayed with additional options and menu 
items for managing users, roles, and settings.

Menu Description

Enables you to return to the Home page.

Library Displays the repository page that contains only the Ad Hoc views, reports, and Dashboards 
for which the current logged-in user has rights to view and perform actions.

The Library table has two columns: 

 Created Date: When the resource was created.

 Modified Date: When the resource was last modified. 

Generally, the created date is earlier than the modified date. However, in scenarios such as 
the following, the created date might be after the modified date:

 When an existing report (Report A) is modified, and then is subsequently copied into a 
new report (Report B). In the Library list, Report B’s creation date is the day it was 
created, but its modified date reflects the last time Report A was changed.

 An existing report is exported from one system and imported into another. In the 
Library list, the Reports Created Date is the date it was imported into the new system, 
and the Modified Date is the date it was last modified in the original system.

View  Search Results: Displays the repository of resources filtered by the search criteria in 
the Filters panel. You can also access this by clicking View Reports on the Home 
page.

For more information about searching, see section “Filtering Search Results” on 
page 12.

 Repository: Displays the repository of files and folders containing resources, such as 
reports, report output, data sources, and images.

 Messages: Lists system messages, such as an error in a scheduled report.

Manage  Users: Displays the Manage Users page.

 Roles: Displays the Manage Roles page.

 Server Settings: Displays the Server Settings page.

Only Administrators can view and access. For more information, see Chapter 4, “ZENworks 
Reporting Management,” on page 55.

Create  Ad Hoc View: Launches the Ad Hoc Editor for designing views interactively. You can 
also access by clicking Create Ad Hoc View on the Getting Started page.

For creating an Ad Hoc View, see Section 2.2, “Creating an Ad Hoc View,” on 
page 24.

 Report: Launches the Create Report page for creating a report by selecting the 
required Ad Hoc view. You can also launch by clicking Create Report on the Home 
page.

For creating report, see Section 2.3, “Generating an Ad Hoc Report,” on page 25.

 Dashboard: Launches the Dashboard Designer to integrate reports, input controls, 
graphics, labels, and Web content in a single, integrated view.

For more information, see Chapter 3, “Working with ZENworks Reporting 
Dashboards,” on page 49.
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1.2.3 Browsing the Repository

The Repository is the server’s internal storage for reports, analysis views, and related files. The 
repository is organized as a structure of folders containing resources such as a file system. However, 
unlike a file system, the repository is stored as a private database that only ZENworks Reporting can 
access directly.

You can access the Repository page by using any of the following methods:

 In the Home page, click View Reports
 Click View > Repository 
 Click View > Search Results
 Click Library

The Repository page provides a different view of the same set of underlying objects. From the 
Repository page, you access the reports and other files stored on the server. If you have appropriate 
rights to these Folders, you can browse the repository content.

1.2.4 Searching the Repository

You can search the entire repository, subject to permissions, or narrow the search by using filters. You 
can use filters based on the resource name, who changed the resource, the type of resource, the date 
of resource creation and schedule.

 “Searching All Resources” on page 11
 “Filtering Search Results” on page 12

Searching All Resources 

To search all resources in the repository:

1 Click View > Search Results, or use the Search field in the top right corner of the Home page.
2 In the Filters panel, choose one of these filters: All available, Modified by me, or Viewed by me.
3 Select All types.

4 Click .
The search results displays files that you have permission to view. Click a resource in the list to 
view
ZENworks Reporting 11



Filtering Search Results

If you enter a search criteria and click  at the top of any server page, the server will not use filters. 
The search feature uses the following default settings:

 Includes sub folders
 Starts at the top-most folder visible to the user
 Searches for reports, report outputs, or other resources
 Sorts alphabetically by name 

If you click View > Search Results and click  on the search results page, the server uses the filters that 
you set in the Filters panel. 

NOTE: The search criteria that you enter in the search field is not cleared automatically. Click  in 
the search field; to clear the search criteria. 

You can refine a search by using filters. For example, filters can help you to find your most recently 
viewed reports. You can set the following types of filters:

 User
 Resource
 Access time
 Scheduled report 

NOTE: You can set each filter independently.

The user filter includes the following settings:

The resource type filter has the following settings:

Filter Setting Description

All available 
(default)

All resources are displayed.

Modified by me Selects only resources that were last modified by the logged-in user.

Viewed by me Selects only resources that were run and viewed by the logged-in user. This filter not only 
applies to visualization types, but also to resources that are included in reports, such as 
images.
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The access time filter has the following settings. All times are relative to the user’s effective time zone:

The scheduled report filter has the following settings:

Tips for searching for resources:

 Use word fragments. 
 Search for the display name or part of the display name of a resource.
 Search for words or fragments in the description of a resource.
 Use multiple words.
 Use case-insensitive words.
 Do not search for folder names.
 Do not enter quotes around terms or symbols between terms.

Filter Setting Description

All types (default) All resources are displayed.

Reports Displays only reports.

Report outputs Displays only the output from reports that were scheduled or run in the background. 
Report outputs can be any of the supported export types, such as HTML and PDF.

Ad Hoc views Displays only views.

Dashboards Displays only dashboards.

Domains Displays only domains.

Data sources Displays only data sources.

Deprecated 
Reports

Displays only deprecated reports.

Filter Setting Description

Any time (default) All resources are displayed.

Today Resources viewed or modified during the current day.

Yesterday Resources viewed or modified yesterday.

Past week Resources viewed or modified during the past 7 days, including today.

Past month Resources viewed or modified during the past 30 days, including today.

Filter Setting Description

Any schedule (default) All resources are displayed.

Scheduled Only reports that have scheduled jobs.

Scheduled by me Only reports that have jobs scheduled by the current logged in user.

Not scheduled Only reports that do not have scheduled jobs and all other resource types.
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1.2.5 Using Repository Resources

After finding a resource in the Repository panel, you can perform the following tasks:

 Click the name of a report to run and view.
 Right-click the name of a resource to perform other options in the context menu. For example, 

Edit or Open in Designer. Options are displayed in the context menu based on the rights assigned 
to the user.

 Click anywhere in the row except the resource name to select a resource, or select multiple 
resources. Use the context menu or buttons above the results list: Run, Edit, Open, Copy, Cut 
(move), or Delete. If the button is unavailable, it indicates that the resource does not support the 
operation or you do not have permission. For example, the Open button is available when you 
select a dashboard or an Ad Hoc report if you have write permission. 
You might also need permission to access the folder or the dependent file; such as an image of a 
resource. For example, to schedule a report, you need to have read/write/delete permissions on 
the folder in which the server saves the report output.

The following icons might appear in the Repository panel:

 This  indicates that the report is scheduled to run or is running in the background. Click this 
icon to view the list of jobs scheduled for the report.

 This  indicates that the report has saved options for its input controls. Click the  icon to list 
the saved options

1.2.6 Sorting the Repository List

To change the order of the list of reports and other resources, use the Sort By controls:

 Click Name to sort alphabetically (A at the top). This is the default sort order.
 Click Modified Date to sort by the latest modified time and date (most recent at the top).

1.3 Connecting ZENworks Reporting from iReport Designer
1 Start iReport:

For Windows: Start > ZENworks Reporting > Start iReport Designer.
For Linux: Change to /opt/novell/zenworks-reporting/js/ireport/bin and enter ./
iReportLoader.sh command.

2 Click Window > JasperReports Server Repository.
The Repository Navigator tool bar is displayed. On initial startup of iReport, no servers are 
configured.

3 To add a server, click  in the Repository Navigator tool bar.
JasperServer Plugin panel is displayed.

4 Specify the following configuration information to access the server.
 ID: An identifier for this server that appears in the Repository Navigator.
 JasperReports Server URL: Full URL to the repository web service; check that the default 

URL is jasperserver-pro. You need to change hostname to the name of your server:
 https://hostname:<secure server port>/jasperserver-pro/services/repository
14 ZENworks Reporting 5 System Reference



 Organization: (Optional) specify the ID or the user's organization.
 Username: ID of the user accessing the server from iReport.
 Password: The password of the user.

5 Click Save.
The created ID is displayed in the Repository Navigator panel.

6 Expand ID tree structure.
The Certificate panel is displayed.

7 Accept the certificate by selecting any of the following option:
 Accept this certificate permanently.
 Accept this certificate only for the current iReport session.
 Does not accept this certificate.

8 Click OK.
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2 2Ad Hoc Editor

The Ad Hoc Editor is an interactive designer for creating and editing Ad Hoc Views. This allows you 
to explore and analyze data from your Topic or Domain. Ad Hoc Views can also be used to create 
content for reports.

See the following sections for additional information about Ad Hoc Editor:

 Section 2.1, “Overview,” on page 17
 Section 2.2, “Creating an Ad Hoc View,” on page 24
 Section 2.3, “Generating an Ad Hoc Report,” on page 25
 Section 2.4, “Scheduling Reports,” on page 26
 Section 2.5, “Working with Tables,” on page 32
 Section 2.6, “Working with Charts,” on page 36
 Section 2.7, “Working with Standard Crosstabs,” on page 39
 Section 2.8, “Using Filters and Input Controls,” on page 41

2.1 Overview
The Ad Hoc Editor supports creating various types of reports such as tables, crosstabs, and charts. 
You can create reports by dragging and dropping the items. You can add and summarize items, 
define groups, label, title the report, and format data for each item. You can also use the editor to 
explore and analyze data interactively.

 Section 2.1.1, “Data Sources,” on page 17
 Section 2.1.2, “Using the Data Chooser,” on page 18
 Section 2.1.3, “Ad Hoc Editor Panel,” on page 20
 Section 2.1.4, “Ad Hoc View Types,” on page 23

2.1.1 Data Sources

The following repository objects provide connections to data sources for Ad Hoc View creation:

 Domains: These are collections of objects mapped to database schema. Domains are available for 
various ZENworks products such as ZENworks Configuration Management, Audit of 
ZENworks Configuration Management, ZENworks Mobile Management, and so on. 

 Topics: Topics are created as JRXML files and then associated with data sources in the server. A 
Topic can also be created from a Domain in the server. For more information about Topics, see 
the Jaspersoft Server User Guide.
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2.1.2 Using the Data Chooser

After selecting the data source, the Data chooser is displayed.

You must select items from the the Source to Selected Fields, to enable Pre-filters, Display, and Save as 
Topic buttons. The Pre-filters, Display, and Save as Topic buttons are optional and can be performed in 
any order. Click Table, Chart, or Crosstab at any time to begin designing a view based on the chosen 
data.

See the following sections for additional information about Data Chooser:

 “Selecting Items” on page 18
 “Pre-filtering data” on page 19
 “Changing the default label settings” on page 19
 “Saving the settings” on page 20

Selecting Items 

Click Fields to select items and sets of fields to use in the view, or to make available in the Domain 
Topic.

 The Source panel displays the sets of fields from the Domain. Use  and  to close or expand 
each set. 

 The Selected Fields panel displays the items selected from the Source panel. You can move a field 
between the panels by dragging, double-clicking, or selecting the item and clicking an arrow 
button.

 If you move an individual field from a set, it appears in a set with the same name. If you do not 
want sets, use the settings on the Display panel.

 Some Domains define sets that are not joined. When you select a field from such a set, the 
unjoined sets are not available.
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Pre-filtering data

You can pre-filter data in the Data Chooser wizard before clicking Table, Chart, or Crosstab, or before 
clicking Save as Topic. Pre-filtering data limits the data choices available in a Domain Topic or the 
fields that ultimately display in the Ad Hoc View. You can define a filter on fields that does not 
display in the final report. The filter that meets all defined filters gets displayed in the final report. 
You can also design reports that prompt users to input data to use as a filter.

The Pre-filters panel provides powerful functionality for designing views within the server.

To define a filter:

1 In the Data Chooser wizard, click Pre-filters.
2 Expand the options in the Fields panel.
3 Double-click to select a field.
4 Choose a comparison operator.

Text fields have substring comparison operators, such as starts with or contains, and also whole 
string matching operators, such as equals, or is one of. When you select a whole string matching 
operator, a list displays all existing values for the selected field; retrieved in real-time from the 
database.
In the Filters panel, a drop-down list is displayed.  The list contains the account names from 
which you can select multiple values.

5 In Available Values, click each value and move it to Selected Values for comparison.

If there are more than 50 values to display in Available Values, click  to search for the value. 
The maximum number of items that can be displayed in Available Values is configurable.

6 Select the Locked check box to limit the view in Selected Values.
By default, the Locked check box is cleared, enabling end users to use filters when they run the 
report.

7 Click OK.
8 In the Filters panel, click Change to modify the condition.
9 Click OK to save the changes.

To delete from the list, select a row, then click Remove. 

NOTE: Data rows must match all conditions. Which means, the filter applied to the data must be 
logical AND of all conditions that you have defined.

Changing the default label settings

Use the Display panel to change the default label and order of the fields in the Ad Hoc Editor. You can 
change the field labels and ordering at any time in the Ad Hoc Editor, but configuring the settings 
here makes them available in a Domain Topic.

The Display panel includes following options:

 To change the order of fields, click in the row of the required field. Then, based on the required 
position, use the Move to top, Move up, Move down, or Move to bottom buttons.

 Fields can be moved within their set, and sets as a whole can also be moved.
Ad Hoc Editor 19



 By default, the field name turns into the display label for the row, column, or measure that you 
create from the given field. To change the default display label of a field or set, double-click in 
the row and specify the new label in the text box.

 Sets are not used in views, but can be used to add all their fields at once, expediting view 
creation.

 If you do not want to use sets in the Ad Hoc Editor, select Flat List at the top of the Data Source 
Selection panel. You can then relabel the fields and reorder them.

Saving the settings

On the Save as Topic panel, you can specify a name and description to save the Data Chooser settings 
as a Domain Topic. After saving these settings, you can create different views from the Domain Topic, 
using its fields, filters, and display label settings. You can also edit the Domain Topic to change the 
settings.

2.1.3 Ad Hoc Editor Panel

 The Ad Hoc Editor enables you to create various types of views and reports. 

Figure 2-1   Ad Hoc Editor

See the following sections for additional information about the Ad Hoc Editor panel:

 “The Data Source Selection Panel” on page 20
 “The Ad Hoc View Panel” on page 21
 “The Filters Panel” on page 23

The Data Source Selection Panel

The Data Source Selection panel contains a list of items that are selected from a Topic or Domain and 
are placed in Fields and Measures. 

To hide or unhide this panel, click the Data Source Selection icon in the top-left corner. The Hide 
option helps you to arrange content in a large Ad Hoc View.
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The Ad Hoc View Panel

The Ad Hoc View panel provides tools that allow you to control what data is included in a view and 
how it is organized. 

Figure 2-2   Ad Hoc View panel

See the following sections for more information about the Ad Hoc View panel:

 “Ad Hoc Editor Tool Bar Icons” on page 21
 “The Layout Band” on page 22
 “Managing Grid Details” on page 23

Ad Hoc Editor Tool Bar Icons

Icon Name Description

 
Display Mode Enables you to hide the editor interface. This mode provides a 

subset of the editor’s full feature set.

 
Save Enables you to select save options.

 
Export Enables you to export the report into the following formats: PDF, 

Excel (Paginated), Excel, CSV, DOCX, RTF, Flash, 
ODT, ODS, XLSX (Paginated), XLSX (Paginated), and 
XLSX.

 Undo Enables you to undo the most recent action.
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The Layout Band

Below the Toolbar is the Layout Band, with two fields. These fields have different labels and functions, 
depending on the View type.

 For Table View, the available fields are Columns and Groups.
 For Charts and Crosstabs Views, the available fields are Columns and Rows.

You can drag and drop items from Fields and Measures into these boxes.

 Redo Enables you to redo the most recently undone action.

 Undo All Enables you to revert the view to its previous state before you last 
saved.

 
Switch Group Enables you to change the display groups mode.

For example, if Columns display the Bundle Type and Rows 
displays the Bundle Version and Bundle Create Date, when you 
click this icon the column information will be displayed as rows and 
vice versa.

This is enabled only for Crosstab View and Chart View.

 
Sort While working with tables, click this icon to view the current sorting 

and to select fields for sorting data. For more information, see 
“Sorting Tables” on page 34.

 
Input Controls Click this icon to see the input controls applied to this view. For more 

information, see Section 2.8.2, “Using Input Controls,” on page 45.

 
Page Options Place the cursor on this icon to select the page-level options. You 

can select the following options:

 Whether to display or hide the Layout Band.

 Whether to display or hide the title area.

 
View SQL Query Enables you to view the SQL query to verify the data. To perform 

this acton, you must have administrator rights. The query is read-
only, but can be copied to a clipboard or other document for review. 
By default it is disabled.

To enable the query, click Manage > Server Settings > Ad Hoc 
Settings, then select the Enable View Query in Ad Hoc Editor check 
box.

Drop-Down  The View type enables you to reset the View type Table, Chart, 
or Crosstab.

 The Display data enables you to display a subset of the 
available Sample Data, or Full Data in the view. It is enabled 
only for Crosstab View and Chart View.

Icon Name Description
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Managing Grid Details

Below the Layout Band is the Grid Detail selector. This option is available only for Chart View or 

Table View. In Table View, click  to select the following options: 

 Detailed Data displays the table detail.
 Totals Data displays the table totals.

 Details and Totals displays both details and totals.

The Filters Panel

The Filters panel displays filters that are defined for the view. You can set the filter values and view 
the results in the Ad Hoc View panel. To hide and unhide the Filters panel, click the Filter icon in the 
top-right corner of the Filters panel.

For more information, see Section 2.8, “Using Filters and Input Controls,” on page 41.

2.1.4 Ad Hoc View Types

The Ad Hoc Editor allows you to select the following View types:

 “Tables” on page 23
 “Charts” on page 24
 “Crosstabs” on page 24

Tables

Table views are used to view values in the database and to summarize the values in columns. The 
table view consists of columns, rows, and groups. 

Using groups, rows can be grouped by identical values in any field with intermediate summaries for 
each grouped value. For example, a table view of bundle details will contain columns that indicate 
the Bundle Name, Version, and Create Date of each bundle, and its rows will display the Bundle 
Type.

For more information about Table Views, see Section 2.5, “Working with Tables,” on page 32.

Bundle Type Bundle Name Version Create Date

Patch Bundle B1 0 09-06-2013

Windows Bundle B2 1 30-04-2013

Linux Bundle B3 1 18-08-2013
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Charts

Chart Views compare one or more measures across multiple sets of related items. Charts summarize 
data graphically and support chart types such as bar chart, line chart, area chart, and pie chart. 

For example, in the following table, the Chart tab indicates the data in a bar chart that compares the 
Bundle Count for each Bundle Type.

For more information about Charts View, see Section 2.6, “Working with Charts,” on page 36.

Crosstabs

Crosstabs are more compact representations than tables; they provide data for items and their 
computed values. Columns and Rows specify the dimensions for grouping; cells contain the 
summarized measurements.

For example, in a Crosstab with columns grouped by Bundle Type, the Bundle Count is as follows:

For more information, see Section 2.7, “Working with Standard Crosstabs,” on page 39.

2.2 Creating an Ad Hoc View
An Ad Hoc View is a view of data based on a domain or topic. An Ad Hoc View can be a table, chart, 
or crosstab. It is the entry point to analysis operations.

1 Click Create > Ad Hoc View.
2 In the Data Chooser panel, select Domains.

3 Click  to expand the treeview structure, then select domain that you want to use.
You can only view the domains for which you have appropriate rights.

4 Click Choose Data.
5 In the Data Chooser panel, click Fields to select items to use in the Ad Hoc View.

For more information, see “Selecting Items” on page 18.

 

Bundle Type

 Patch Bundle  Windows Bundle 02  Linux Bundle 

Bundle Type Bundle Count

Patch Bundle 100

Windows Bundle 150

Linux Bundle 50

Totals 300
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In the Data Chooser panel, you can also perform the following tasks:
 Click Pre-filters to create filters to limit the data available in the Ad Hoc Editor. For more 

information see, “Pre-filtering data” on page 19.
 Click Display to change the fields and the display names in the Display Label field. For more 

information, see “Changing the default label settings” on page 19.
 Click Save as Topic to save the customized topic. For more information see “Saving the 

settings” on page 20.
6 Select the type of Ad Hoc View;  Table, Chart, or Crosstab.

For more information about View types, see Section 2.1.4, “Ad Hoc View Types,” on page 23.
7 Select the items from Fields and Measures.

For more information, see Section 2.5.1, “Using Fields in Tables,” on page 32, Section 2.6.1, 
“Using Fields and Measures in Charts,” on page 36, or Section 2.6.1, “Using Fields and Measures 
in Charts,” on page 36.

8 Place the cursor on , then click Save Ad Hoc View or Save Ad Hoc View as.
9 Choose the folder where you want to save the View. By default, the Ad Hoc View is saved in the 

Repository.
10 Specify the view name, then click Save.

You can also open and edit an existing Ad Hoc View to create a new Ad Hoc View.

2.3 Generating an Ad Hoc Report
The Ad Hoc Editor is used to explore views which in turn can be saved as reports. Such reports can 
be edited in iReport, and can be scheduled and added to dashboards. 

 Section 2.3.1, “Generating an Ad Hoc Report from an Existing Ad Hoc View,” on page 25
 Section 2.3.2, “Creating an Ad Hoc View and Generating the Report,” on page 26

2.3.1 Generating an Ad Hoc Report from an Existing Ad Hoc View

If you have any existing Views to be generated as a report, then perform the following:

1 Go to the folder where you have saved the View.
2 Select the View.

3 Place the cursor on , then select Save Ad Hoc View and Create Report to save the view as Ad Hoc 
View and Ad Hoc report.

4 Choose the folder where you want to save the report.
5 Specify the view name and report name, then click Save.

The Ad Hoc View is saved as a report, when you want to:
 See data in the interactive report viewer.
 Perform additional formatting of the table data.
 Embed the data content into a dashboard.

6 To run a report, select a report.
You can view and select the reports using the following methods:
 In the Home page, click View Reports.
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 Click View > Repository.
 Click View > Search Results.
 Click Library.

The Repository panel is displayed. It provides a different view of the same set of files.
7 Click the report name, or right-click the report name, then click Run. If you are accessing the 

report from View > Repository, select the report row, then click the Run button.

Alternate procedure for Generating the Report from an Existing View

1 In the Home page, click Create Report.
2 In the Create Report panel, select the View that you want, then click OK.

3 Place the cursor on , then click Save or Save as.
4 Select the folder where you want to save the report.

2.3.2 Creating an Ad Hoc View and Generating the Report

1 Perform steps from Step 1 to Step 7, as mentioned in Section 2.2, “Creating an Ad Hoc View,” on 
page 24, and Step 3 to Step 7, as mentioned in 

2 Click the report name, or right-click the report name, then click Run. If you are accessing the 
report from View > Repository, select the report row, then click the Run button.

NOTE: After creating a report from an Ad Hoc View, a user cannot add or remove objects from that 
report.

Dependent Reports

When you create a report from an Ad Hoc View, the report is considered “dependent” on that view.

When you update an Ad Hoc View, its dependent reports are not updated. For example, if you open 
an Ad Hoc View in the Editor and add a column to it, that column is not displayed in previous 
reports created from that view. If you want to update reports, you must save the updated view with a 
different file name.

2.4 Scheduling Reports
The following sections provide information to help you schedule reports:

 Section 2.4.1, “Scheduling and Running a Report,” on page 27
 Section 2.4.2, “Output Options,” on page 28
 Section 2.4.3, “Viewing the List of Scheduled Jobs,” on page 30
 Section 2.4.4, “Simple and Calendar Options,” on page 31
 Section 2.4.5, “Running a Job in the Background,” on page 31
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2.4.1 Scheduling and Running a Report

NOTE: Before scheduling the report, you must configure the Outbound Email Server details. For 
more information about the Outbound Email Server, see the ZENworks Reporting 5 Installation Guide.

You can set up the job, when to run it, and how often to run it.

1 On the Home page, click View Reports, or click View > Repository.
2 Right-click the report name, then select Schedule.
3 Click Schedule Job, to display the Scheduler panel.

4 In the Job Name field, specify a name for the job, for example, Weekly Report. The description is 
optional.

5 Set the following schedule attributes:
 Start Job: Choose one of the following:

 Immediately: Start the job as soon as you finish it. 

 On: Start the job at future time. Click the calendar  icon and select the future start 
date and time. To set the time for the job to run, at the bottom of the calendar, click the 
hours and minutes.

 Time Zone: Specify the time zone for the schedule. The default time zone is the time zone of 
the server, the time zone you entered at log in. If you are in a different time zone, set this 
field accordingly.

 Recurrence: Choose one of the following settings:
 None: Run the report once.
 Simple: Repeat the job at an hourly, daily, or weekly interval.
 Calendar: Repeat the job on days of the week or days of the month. 

If you select Simple or Calendar, additional fields are displayed. For more information, 
see Section 2.4.4, “Simple and Calendar Options,” on page 31.

6 Click Next.
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7 (Conditional) If the report you are scheduling has input controls, you are prompted for the 
input.
If there are any Saved values, they display in a drop-down list at the top of the Set the Parameter 
Values panel. In the Use saved values drop-down, you can set the input controls defined for the 
report that you are scheduling. You can set the input values for the scheduled report, and click 
Save Current Values to save the input value.

8 Choose a set of saved values, or set the input controls, then click Next.
9 Set output options in the Output Settings panel.

For more information, see Section 2.4.2, “Output Options,” on page 28.
10 Click Submit.

The job displays in the list of Scheduled Jobs, as shown in Step 2.
11 Click Run Now to run the report in the background.

2.4.2 Output Options

In the Output Details panel, you can change the output settings. You must first setup the job, then 
output options. 

For information, see Section 2.4.1, “Scheduling and Running a Report,” on page 27.
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On the Output Details panel, you can change these settings:

 Base Output File Name: Specify a name for the Job file.
 Output Description: (Optional) Specify a description for the Job file.
 Output Format: Select the format in which you want to save the Job file. When you select more 

than one format, each format is stored as a separate file in the repository and attached as a 
separate file to the email notification.

 Output Locale: Select the locale settings for generating the report. 
The report must support locales, for example a report based on a domain with language 
bundles.

 To: Specify the email addresses for email notifications.
 Subject: Specify a subject for the email notification.
 Message: Specify a message for the email notification. 
 Attach Files: Select this option to send the output of the report with the email notification. 
 Skip Empty Reports: Select to prevent the server from attaching empty report output files to email 

notifications when report execution fails.
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 Output Location: Browse to the folder where you want to save the report. You must have the 
write permission for the folder. 

 Sequential File Names: Select this option to append a timestamp to the names of files created by 
the job. This is useful for the output of recurring jobs or for time-sensitive reports where the 
output must be dated. When the timestamp is used, the output of the file name is <basename>-
<timestamp>.<extension>.

 Timestamp Pattern: An optional pattern for the timestamp. Valid patterns for report output files 
can only contain letters, numbers, dashes, underscores, and periods. The default pattern is 
yyyyMMddHHmm. For example, 201307030601.

 Overwrite Files: Select this option to overwrite old output files with new files. This is useful when 
you do not have sequential file names or when you specify a timestamp pattern that could lead 
to identical file names.

2.4.3 Viewing the List of Scheduled Jobs

Scheduled jobs are displayed in the Repository panel with a  icon. Users can view the jobs that they 
have defined; administrators can view the jobs defined by all users.

1 On the Home page, click View Reports.
2 Right-click the report, then select Schedule.

The list of scheduled jobs is displayed.

The Scheduled Jobs panel displays the ID for the job, the owner who created the job, and the status of 
the job. The job statuses includes the following:

 Normal: The job is scheduled. 
 Running: The server is generating the report. 
 Complete: The server has finished running the job and placed the output file in the repository.
 Error: The scheduler encountered an error while scheduling or triggering the job. This does not 

include cases in which the job is successfully triggered but an error occurs while it runs. 

The Scheduled Jobs panel includes the following options:

 Edit: You can edit the scheduled job and save the changes.
 Remove: You can delete the scheduled job. 

When the server receives a request to delete a job that is running, the server finishes running the 
job before deleting it.

You can perform the following tasks from the Scheduled Jobs panel:

 Click Back to go back to the list of reports.
 Click Schedule Job to define a new job.
 Click Run Now to run the report in the background, while you continue working on the server.
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2.4.4 Simple and Calendar Options

To run reports automatically on a regular basis, select simple or calendar recurrences on the Set Up 
the Job page:

 A Simple recurrence regularly runs the job at an hourly, daily, or weekly interval. 
 A Calendar recurrence involves more settings: time of day, days of the week, or days of the 

month and months of the year. 

Simple recurrence options are:

 Repeat every: Sets the interval between jobs, in minutes, hours, days, or weeks.
 Indefinitely: Runs the job until you delete it.
 Times: Runs the job for a specified number of times.

 Until: Runs a job until the specified date is reached. Click  to select the date. 

Calendar recurrence options are: 

 Months: The months during which the report runs.
 Days: The days on which the report runs: 

 Every Day
 Week Days
 Month Days: Enter dates or date ranges, separated by commas. For example: 1, 15.

 Times: The time of day in minutes and hours when the job should run. The hours use 24-hour 
format. 
You can also enter multiple minutes or hours, and ranges, separated by commas. For example, if 
you specify 0, 15, 30, and 45 for the minutes, and 9-17 for the hours, the report runs every 15 
minutes from 9:00 A.M. to 5:45 P.M. Enter an asterisk (*) to run the job every minute or every 
hour. 

 Recur Until: The Calendar recurrence runs until the specified date is reached. Click  to select 
the date.

2.4.5 Running a Job in the Background

Running a job in the background generates a report, potentially without affecting performance of the 
server. After the job is finished, you can export the report directly to any format and save it in the 
repository. You can share a report with others by sending the generated report through email.

Running a job in the background is equivalent to scheduling the report to run immediately.

1 On the Home page, click View Reports.
2 Right-click the report, then select Run in Background.

If the report that you are running has input controls or filters, you are prompted for the inputs.
3 Choose a set of saved values, or set the fields one at a time, then click Next.
4 In the Setting Output Options panel, specify the details, then click Submit. For output options, see 

Section 2.4.2, “Output Options,” on page 28. 
5 Click Save.

The report runs immediately.
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2.5 Working with Tables
The following section explain how to open, edit, and format your Tabular View:

 Section 2.5.1, “Using Fields in Tables,” on page 32

2.5.1 Using Fields in Tables

Insert data into the table by adding items. All available items are listed in the Data Source Selection 
panel, on the left side of the Ad Hoc Editor.

The following parameters are available in the Data Source Selection panel are:

 Fields, which can be added to the table as columns or groups.
 Measures, which are specialized fields that contain data values.

NOTE: Most of the Measures display GUIDs in Tabular view and some display measures.

To add items from fields and measures as columns to a table:

1 In the Data Source Selection panel, click the required item from the Fields or Measures to add to the 
table.

2 Drag the selected item into the Columns box in the Layout Band.
The selected item is added to the view as a column in the table.

To remove an item from a table:

 In the Layout Band, click x next to the field or measure's name.

Summaries

You can display summary data for any column in your table. Summary data can be in the form of 
various functions, such as the following:

 Sum
 Count
 Distinct Count
 Average

For example, in a table with a list of Bundle Sizes grouped by Bundle Type, you can display the 
minimum, maximum, average, or sum of the bundle size, using this function.

To add a summary to a specific column:

 In the table, right-click the column for which you want to calculate a summary, then select Add 
Summary.

The summary information is added to the group header, or is added to the bottom of a column if 
no groups are included in the table.

To remove a summary from a specific column:

 In the table, right-click the column with the summary that you want to remove, then select 
Remove Summary.
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To add or remove summaries from all columns:

 Click  then select Detailed Data. 

Column and Header Labels

For Tabular reports, you can edit a column or header label directly in the Ad Hoc Editor.

To edit a column or header label:

1 In the Ad Hoc View panel, right-click the column or group header.
2 Click Edit Label.
3 In the text box, delete the existing name and specify the new name.
4 Click Submit.

To delete a column or header label:

1 In the Ad Hoc View, right-click the column or header.
2 Click Delete Label.

When you delete a label, it still displays in the Ad Hoc Editor, but does not display in the report.

To re-apply a label:

1 Right-click the column or header.
2 Click Add Label.
3 Specify the label name.
4 Click Submit.

Managing Column Size and Spacing

You can change the size of the columns in the table to use space more efficiently.

Select the columns that you want to adjust by clicking at right end of the column.

To resize a column:

1 In the Ad Hoc View panel, select the column that you want to resize.
2 Move the cursor to the right end of the column.
3 When the resize icon ( ) is displayed, click and drag until the column is adjusted to the 

required size.

To change the spacing between columns:

1 In the Data Source Selection panel, under Measures, click Spacer.
2 Drag the spacer into the Columns box in the Layout Band, between the names of the two columns 

that you want to move apart.

A spacer column, labeled , displays in the table.
To remove a spacer, right-click the spacer column then select Remove from Table.
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To use spacers to create table margins:

1 In the Data Source Selection panel, click Spacer.
2 Drag the spacer into the Columns box in the Layout Band.
3 Add the spacer to the right end of the table.

Reordering Columns

1 In the Ad Hoc View panel, right-click the column that you want to move.
2 Click Move Right or Move Left.

Sorting Tables

In the Ad Hoc Editor you can sort the rows of a table by any field.

1 Click .
The Sort panel is displayed.

2 To add a field to sort on, double-click the item in the Available Fields panel, or select the item and 

click .
3 To sort by, select one or more items.
4 Select each field in the Sort panel, then click the Move to top, Move up, Move down, or Move to 

bottom.
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5 To remove an item from the Sort On panel, select the field, then click .
6 Click OK. The table will display the rows sorted by the selected fields.

You can also sort a table using the following methods:

 Right-click a field in the Fields section of the Data Source Selection panel, then click Use for Sorting. 
In this case, the table is sorted by a field that is not in the table; you must note the sorting fields 
in the title.

 Right-click a column header on the Canvas of the Ad Hoc View panel, then click Use for Sorting.

NOTE: If a column is already being used and you want to stop using it or change the sorting, 
right-click the column, then click Change Sorting.

Adding a Title

1 Above the table, select Click to add a title.
2 Specify the title in the text box.

Changing the Data Format

You can change the formatting for columns containing numeric data, such as dates and bundle size.

1 In the Ad Hoc View, right-click the column for which you want to change the data format.
2 Click Change Data Format.
3 Select the format that you want to use.

These options vary, depending on the type of numeric data contained in the column.

Changing the Data Source

You must select a new data source for your table. Ensure that all view data and formatting is saved 
before selecting a new Topic or Domain. Any changes to the view are also lost if you navigate to 
another page.

1 At the top of the Data Source Selection panel, click , then select Change Source.
2 Select a different Topic or Domain connection.
3 Click Table to apply the new data source.

Controlling the Data Set

You can control the data displayed in the grid by using the Grid Detail Selector. The Grid Detail 
Selector includes the following options:

 Detailed Data, which displays table detail only.
 Totals Data, which displays the table totals only.
 Details and Totals, which displays both the individual and the total table.
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To change the displayed table details:

1 Place the cursor on .
2 Select the option that you want to apply to the table.

The Ad Hoc Editor displays the data as requested.

2.6 Working with Charts
Ad Hoc charts are a flexible and interactive way to explore your data graphically. You can choose 
different levels of aggregation for rows and columns, change a field from a column to a row, pivot the 
entire chart, hide chart values, and zoom to see chart details.

The following sections explain how to view, edit, and format an Ad Hoc chart. Many tasks related to 
working with charts are identical to those for tables and crosstabs.

 Section 2.6.1, “Using Fields and Measures in Charts,” on page 36
 Section 2.6.2, “Selecting a Chart Type,” on page 37
 Section 2.6.3, “Interacting with Charts,” on page 38

2.6.1 Using Fields and Measures in Charts

You must add at least one measure to view a chart. Before any measures are added to the chart, the 
Ad Hoc Editor displays a placeholder with a single entry. As you add measures, the editor displays 
the grand total of each measure in the chart.

The initial display only reflects the measures you add; it does not change when you add items or 
dimensions. For example, for each measure that you add to a bar chart, you can see a bar with the 
total value of the measure, regardless of how many items you add. You can add, remove, and arrange 
measures and fields without waiting for the display to update. After you have the fields and 
measures that you want, you can use the sliders on the right to select the level of detail.

All available fields are listed in the Data Selection panel, as either standard Fields or Measures.

 Standard fields can be added to a column or a row.
 Measures contain summarized values. They are typically numeric fields that determine the 

length of bars, size of pie slices, location of points (in-line charts), and height of areas. They can 
be added to rows or columns. However, they must be in the same target. You can add one or 
more measures to the chart as columns or rows. However, you cannot have one measure as a 
column and another as a row in the same chart.

While creating a chart, ensure that row and column groups are arranged in hierarchies, with the 
highest member of the hierarchy on the left.

To add a field or measure to a row or column:

1 In the Data Selection panel, select the item that you want to add to the chart as a group.
2 Drag the selected item into the Columns or Rows box in the Layout Band.
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Changing the Summary Function of a Measure

You can get a new view of your data by changing the summary function of a measure. For example, 
from sum to average. 

To select a new summary function for a measure:

1 Right-click on the measure in the Layout Band, then click Change Summary Function.
2 Select the function from the Cascading submenu.

Then view updates with the new summary function.

2.6.2 Selecting a Chart Type

The following are the chart types that represent your information:

 Column
 Bar
 Line
 Area
 Pie

By default, the Ad Hoc Editor creates a column chart. You can select a different type of chart at any 
time.

To select a new chart type:

1 In the Ad Hoc View panel, click the  icon.
2 Select the type of chart that you want to use.

The selected chart type is outlined in blue.

The following table describes the available chart types:

Icon Description

Column charts

 
Column: Multiple measures of a group are depicted as individual columns.

 
Stacked Column: Multiple measures of a group are depicted as portions of a 
single column whose size reflects the aggregate value of the group.

 
Percent Column: Multiple measures of a group are depicted as portions of a 
single column of fixed size.

Bar charts

 
Bar: Multiple measures of a group are depicted as individual bars.

 
Stacked Bar: Multiple measures of a group are depicted as portions of a single 
bar whose size reflects the aggregate value of the group.

 
Percent Bar: Multiple measures of a group are depicted as portions of a single 
bar of fixed size.

Line charts
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2.6.3 Interacting with Charts

After creating a view in the chart type, you can further explore your data by using interactive features 
such as brushing an area of the chart to zoom in, or clicking on a legend to hide the members of a 
group.

Zooming

Zooming lets you view a smaller area of a chart more closely. Zooming can also be helpful when the 
labels at the bottom of a chart are difficult to read, because only the labels corresponding to the 
selected area are displayed.

NOTE: Zoom cannot be saved as part of an Ad Hoc View or a report. When you save an Ad Hoc 
View or create a report from an Ad Hoc View, the zoom is automatically reset to display the whole 
chart.

To zoom in on an area of a chart:

 Click and drag or brush the area that you want to zoom in. As you are dragging or brushing, a 
pale blue area indicates the selected area. The view zooms to the area you selected.

To view the complete chart after zoom:

 Click Reset zoom at the upper right of the canvas.

 
Line: Displays data points connected with straight lines.

 
Spline: Displays data points connected with a fitted curve.

Area charts As compared to line charts, area charts emphasize quantities rather than 
trends.

 
Area: Displays data points connected with a straight line and a color below the 
line; groups are displayed as transparent overlays.

 
Stacked Area: Displays data points connected with a straight line and a solid 
color below the line; groups are displayed as solid areas arranged vertically, 
one on top of another.

 
Percent Area: Displays data points connected with a straight line and a solid 
color below the line; groups are displayed as portions of an area of fixed sized, 
and arranged vertically one on top of the another.

 
Area Spline: Displays data points connected with a fitted curve and a color 
below the line; groups are displayed as transparent overlays.

Pie charts

 
Pie: Multiple measures of a group are displayed as sectors of a circle.

Icon Description
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Hiding Group Members

Use the legends below the chart to hide or view group members.

1 To hide a group member, click on the member name in the chart. The member is removed from 
the chart and the legend is grayed out.

2 To view a group member that has been hidden, click on the grayed-out legend for the member.

NOTE: Hidden members cannot be saved as part of an Ad Hoc View. When you save an Ad Hoc 
View or create a report from an Ad Hoc View, the chart is automatically reset to display all 
members.

2.7 Working with Standard Crosstabs
Crosstabs have different data, layout, and format options than tables or charts.

 Section 2.7.1, “Using Fields in Crosstabs,” on page 39

2.7.1 Using Fields in Crosstabs

Fields can be added to crosstabs as row groups or column groups. Measures can be added to crosstab 
rows or columns. However, all measures must be included in a crosstab as either a row or a column. 
You can add one or more measures to the crosstab as columns or rows. However, you cannot have 
one measure as a column and another as a row in the same crosstab.

Crosstab Rows and Columns

While creating a crosstab view, ensure that row and column groups are arranged in hierarchies. Drag 
the group headings to rearrange the hierarchy. You can also right-click a heading and select the Move 
option or press the Arrow keys. Rearranging the groups might change the preview data in the editor.

To add a field or measure to a crosstab group:

1 In the Data Source Selection panel, select the field that you want to add to the crosstab as a group.
2 Drag the selected item into the Columns or Rows in the Layout Band.

Crosstab Measures

Measure labels are displayed in the crosstab based on their status as a row or column:

 Measures included as rows are displayed in the crosstab below the Measures heading.
 Measures included as columns are displayed in the crosstab to the right of the Measures heading.

Right-click a measure in the crosstab to perform the following:

 Change Summary Function
 Change Data Format
 Remove From Crosstab
 Create Filter
 Move Up or Move Down
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Measures are arranged in cells. You can add any number of measures. To rearrange the measures, 
drag them into the measure label area.

Slicing

The slice feature lets you keep or exclude group members in a crosstab. To slice, right-click a group 
member and select:

 Keep Only: Removes all groups except the selected one from the crosstab.
 Exclude: Removes the selected group from the crosstab.

Use Ctrl+click and Shift+click to select multiple groups to keep or exclude.

NOTE: You can select multiple row groups or multiple column groups. However, you cannot slice by 
both row groups and column groups at once.

For more information about working with filters, see Section 2.8, “Using Filters and Input Controls,” 
on page 41.

Summarizing

All row and column groups are summarized automatically.

 To turn off a group summary, right-click any heading in the group and select Delete Row 
Summary or Delete Column Summary. 

To reapply the summary, right-click the heading and select Add Row Summary or Add Column 
Summary.

NOTE: The Delete Summary option is available only for the outermost group on either axis 
(either the outermost row group or the outermost column group).

 To select the summary function and data format for a measure, right-click the measure label and 
select from the context menu. You cannot change the summary function on custom items that 
calculate percents (Percent of Total, Percent of Column Group Parent, and Percent of Row Group 
Parent).

 The summary functions for numeric fields are Sum, Average, Maximum, Minimum, Distinct 
Count, and Count All. Distinct Count is the number of different items in the row or column; 
Count All is the total number of items. For example, if there are 3 widgets of type A and 3 
widgets of type B, Distinct Count is 2 and Count All is 6.

Collapsing and Expanding Members

By default, the editor displays each row and column group of a crosstab in a collapsed state. You can 
view the totals for the group, but not the measures for its individual members. 

To view measures for a group's members, right-click the group label and select Expand Members.

When a group's members are expanded, select Collapse Members to hide the measures. Collapsing an 
outer group also collapses its inner groups. The Expand Members and Collapse Members options are 
only available for outermost groups, or for inner groups nested in an expanded outer group.
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When you collapse a group, its summary is automatically displayed. This prevents invalid crosstab 
layouts in which there is nothing to display for some totals if the summary has been deleted 
previously.

Sorting

By default, the rows and columns of a crosstab are sorted in alphabetical order of the group names.

To change crosstab sort:

1 Right-click the heading that you want to sort your crosstab.
2 In the context menu, select the sorting option to apply:

 Sort Ascending
 Sort Descending

A blue dot displays in the context menu next to the currently applied sort option.

When the crosstab includes more than one row group or more than one column group, the inner 
groups are also sorted according to your selection. Only one measure can be used for sorting at a 
time. Changing the sort order for another measure resets all others to the default.

Resizing and Layout

Many of the layout and formatting options that are set manually in tables are set automatically in 
crosstabs. In particular, row and column sizes are fixed and no spacer is available.

2.8 Using Filters and Input Controls
Domains use different mechanisms for screening the data.

 Domains (and Domain Topics) can be filtered by selecting fields in the Domain and specifying 
comparison values. The filters can be configured for users to select the data.

 Within the Domain design, filters based on conditions can also be defined; these filters are not 
displayed in the report viewer when the report runs.

You can define filters in the Ad Hoc Editor whether you are working with data from a Domain or 
Topic. Such filters are helpful in improving the view's initial performance by reducing the amount of 
data the view returns by default. 

To prevent users from seeing the full dataset, you can also use input controls in a JRXML Topic or 
filters defined in the Domain design, which can be hidden from end users. For more information, see 
Section 2.8.3, “Input Controls and Filters Availability,” on page 46.

Input controls and filters interact smoothly. For example, you can create filters in an Ad Hoc View 
that gets data from a JRXML Topic that includes input controls.

The server refreshes the editor against both the filters and the input controls. Because some 
combinations of input controls and filters do not return data, this can result in an empty view.

NOTE: If the result set is empty, check for an incompatible combination of filters and input controls, 
such as a standard filter and a Keep Only filter, or an incorrectly-defined advanced filter expression.  
(Data must meet all criteria in multiple filters, rather than meeting criteria in a subset of those filters). 
For more information, see “Advanced Filtering” on page 43.
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JRXML is an XML file format for saving and sharing reports created for the ZENworks Reporting and 
the applications that use it, such as iReport Designer and ZENworks Reporting. JRXML is an open 
format that uses the XML standard to define precisely all the structure and configuration of a report.

In some cases, filters can conflict with view parameters, and you must rename the field that is 
causing the conflict by editing the JRXML file.

2.8.1 Using Filters

You can define filters in the following places:

 The Data Chooser (While creating a view from a Domain).
 The Ad Hoc Editor (even when the view is based on a JRXML Topic).

For information about defining filters in the Data Chooser, see “Pre-filtering data” on page 19.

In addition, you can control how and what filters are applied to a field or fields by using advanced 
expressions. For more information, see “Advanced Filtering” on page 43.

To create a filter in the Ad Hoc Editor:

1 Right-click a field in the Data Source Selection panel, then click Create Filter.
A new filter displays in the Filters panel. If the Filters panel was hidden, it appears when you 
create a new filter.
If the results are empty, check for an incompatible combination of filters and input controls. 
Click  to compare input controls with the filters in the Filters panel.

2 Use the fields in the filter to change its value.
Depending on the selected data type, the filter can be multi-select, single-select, or text input.

3 Click , then select Minimize All Filters or Maximize All Filters to toggle expansion of the items 
in the filter.

4 Click , then select Remove All Filters to remove the filters.
5 Click  to hide the filter's details. 
6 Click  to view the filter’s details.
7 Click the Select All check box (if it appears in the Filters panel) to select all values in the dataset.

The Select All box does not appear in the Filters panel for numbers and dates.

When you change a filter, the server uses the new value to determine the data to display. If you 
change only the operator in a filter, you must deselect the value in that filter and then reselect it to 
apply the updated filter.

For filters with multiple values, you need not reselect all values. After changing the operator, use 
Ctrl+click to deselect one of the values and then Ctrl+click to reselect that value.

Relative Dates

You can filter information in your view based on a date range relative to the current system date. You 
can view this by using date-based filters and specifying a text expression describing the relative date 
or date span that you want to view, by using the format <Keyword>+/-<Number>.

 Keyword indicates the time span that you want to use. Options include: DAY, WEEK, QUARTER, 
SEMI, and YEAR.
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 + or - indicates whether the time span occurs before or after the selected date.
 Number indicates the number of the time spans you want to include in the filter.

To create a relative date filter:

1 Follow the instructions in the Section 2.8.1, “Using Filters,” on page 42.
2 In the filter's first text box, specify an expression describing the relative date or span date.
3 In the filter's second text box, specify the date that you want to base your filter on.

To create a complex filters:

1 Right-click a group member in a crosstab, then select Keep Only or Exclude.
When you create a filter against an inner group, the filter that appears might be created as a 
complex filter.
A complex filter cannot be edited, but can be removed. Complex filters also appear in the Ad 
Hoc Editor if a Data Chooser wizard filter was created and locked.

Advanced Filtering

When you create multiple filters they are, by default, connected with an implicit AND operator; that 
is, the data displayed in your table, chart, or crosstab is what remains after all of your filters are 
applied.

However, with the advanced filter functionality, you can control the displayed data by applying an 
advanced expression that includes more complex, nested AND, OR, and NOT operators, as well as 
by applying multiple filters to a single field.

Advanced filters are useful in situations such as the following:

 When using the AND operator isn't sufficient. For example, consider an international company that 
wants to view data for stores located on the Pacific Rim; they might create an advanced 
expression with the following criteria:
 Country is USA

 AND
 State is California OR Washington OR Oregon OR Hawaii OR Alaska.

 OR
 Country is Japan OR Indonesia

 Using the AND operator for all of these criteria returns an empty view, because no store is 
located in all of those areas.

 When you need to eliminate some results in a field. For example, if your food and beverage 
distribution company wants to view sales for all drinks except for high-price items, you might 
include the following criteria in an advanced expression:
 Product Group is Beverages

 NOT
 Price is greater than 39.99

 This filter displays all items in the Beverage Product Group, but it filters out those with 
prices over $39.99.

These are only two scenarios where advanced filters can complete your results and make your view 
more precise. There are many other situations where they can be applied.
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Other advanced filter tasks include  the following:

 Creating an advanced expression
 Editing an advanced expression
 Removing an advanced expression
 Applying multiple filters to a single field

NOTE: Advanced filters are applied to the Views, but filter details do not display on previews or 
on the report generated from that view.

To create and apply an advanced filter:

1 Create two or more filters for your data, as described in Section 2.8.1, “Using Filters,” on 
page 42. These can be standard field-based filters or Keep Only and Exclude filters.
As you create the filters for use in an advanced expression, the data in your view disappears, 
since most of the data does not meet all of the filter criteria. When you create your advanced 
expression and change some of the ANDs to ORs and NOTs, again the data appears.

2 At the top of the Filters panel, click , then select Show Expression to display the Filter 
Expression, for panel. By default, the Filter Expression, for panel is empty.

3 In the Filter Expression, for panel, click Edit.
4 In the Edit Advanced Filters panel, use the filter preview window to locate the filters.

Filter letter designations are case-sensitive and must be capitalized.
5 Enter a filter expression using the letter designations, Include the following operators:

 AND narrows your results and includes only fields that meet the criteria of both filters 
before and after the operator.

 OR broadens your results and includes fields that meet the criteria of either filter before or 
after the operator.

 NOT excludes results that match the criteria.
 Parentheses combines multiple filters into a single item in the expression.

6 Check your expression by clicking the Validate button.
If your expression is successful with the available filters, the Success message is displayed. For an 
incorrect expression, an Invalid message with details is displayed.

7 When your expression is validated successfully, then click Submit.
Your view is updated and displays in the newly applied filter criteria.

After creating an advanced filter, you can add another filter to the expression or remove existing 
expression.

NOTE: If you want to delete the simple filter from an advanced filter, you must first delete from the 
advanced filter expression. So, deleting the filter deletes the advanced filter expression.

To add a new filter to an existing advanced expression:

1 Create a new filter in the Filters panel.
2 In the Filter Expression, for panel, click Edit.
3 In the Edit Advanced Filters panel, add the new filter to the expression.

Any unused filters in the filter preview window are grayed out.
44 ZENworks Reporting 5 System Reference



4 Click Validate to check the integrity of the new expression.
5 When your expression is valid, then click Submit.

To remove a filter from an advanced expression:

1 In the Filter Expression, for panel, click Edit.
2 In the Edit Advanced Filters dialog, remove the filter from the expression, then update the 

expression as required.
3 Click Validate to check the integrity of the new expression.
4 When your expression is valid, click Submit.

When working with advanced expressions, you can delete an existing expression and create a new 
expression.

To remove an advanced expression from a view:

1 In the Filter Expression, for panel, click Edit.
2 Clear the expression from the Filter Expression box.
3 Click Submit.

When you refine your advanced expression, you can delete unused filters from the Filters panel.

 If you want to remove the filter from the advanced filter, place your mouse on  in the Filter's 
title bar, then click Remove Filter. 

 If you want to remove all existing filters, including the advanced expression, place your mouse 
on  in the Filters panel, then click Remove All Filters.

2.8.2 Using Input Controls

In the Ad Hoc Editor, you can view the input controls defined in the Topic as visible to users. You can 
accept the default values of the controls or enter other values. The Ad Hoc Editor indicates that the 
view has input controls by displaying the  icon as active on the tool bar. Click the  icon to select 
new values or to save values as the new defaults for this view. 

To add an input control to the view using a filter:

1 Create a new filter, or use an existing filter in the Filters panel.

2 In Filters, click  next to the new filter, then select Show Operator.
3 Select an operator from the drop-down and specify the value in the text box.

The filter displays as an input control when the view is used to run the report.

4 Place the cursor on , then select Save Ad Hoc View as....
5 Name the view, select a location, then click Save.

6 On the tool bar, click .
Only the input controls defined in the topic are displayed. If no input controls were defined in 
the topic, the button is grayed out.

To edit the values for a view's input controls:

1 On the tool bar, click .
A window listing the input controls defined in the Topic displays.
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2 Select new values.
3 To change default values of input controls, select the check box labeled Set these values as defaults 

when saving your view.
The selected values become the default values when you save the view.

4 Click OK.
The Ad Hoc View displays the updated data.

2.8.3 Input Controls and Filters Availability

Input controls and filters display in the Editor and when you run a report.

 Input controls can be set to be visible or invisible when you edit a view:
 Input controls that are set to Always prompt are displayed in the editor and always appear 

before the report is run.
 Input controls that are not set to Always prompt are hidden in the editor and appear when 

the report is run.

 Filters created in the Data Chooser wizard can be locked or unlocked:
 Filters that are unlocked display filter details in the editor and are available from the 

Options button when the report is running.

 Filters that are locked display input controls in the Editor when you click this icon . 
However, they are not available from the Options button when the report is running. You 
can remove the filter from the Editor, allowing them to see all the unfiltered data, when the 
report is running. 

 Filters defined in the editor are always available in the Filters panel of the editor and from the 
Options button when the report is run.

When setting up input controls for a large view that takes a long time to run, consider setting the 
view to Always prompt. Before a report is run, the report viewer prompts you to provide the input 
options, preventing the report from running with the default input options.

Filters that are unlocked are available. When input controls or filters do not display in the report 
viewer, click the Options button to view them.

To set an input control to prompt:

1 Locate a Topic, in the repository, then click Edit.
2 In the Controls & Resources panel, under Input Control Options, click Always prompt.

To determine whether an input control is visible:

1 Locate a Topic, such as the Parameterized Report Topic, in the repository, then click Edit.
2 On the Controls & Resources panel, click the name of an input control.
3 On the Locate Input Control panel, click Next.

At the bottom of the Create Input Control panel, if the Visible check box is selected, the input 
control displays on the report when it runs.
If you do not specify a default value for the input control, users are prompted to select a value 
when they create a View based on the Topic.
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To lock a filter:

1 In the Data Chooser, after selecting the fields, Click Pre-filters.
2 Double-click a field in the Fields panel.
3 In the Filters panel define a filter.

For more information, see “Pre-filtering data” on page 19.
4 Select the Locked check box, then click OK.
5 Click Table to open the Ad Hoc Editor.

In the Filters panel, the name of the filter and a note about the lock displays under the Locked 
heading.
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3 3Working with ZENworks Reporting 
Dashboards

A ZENworks Reporting Dashboard displays various reports in a single integrated view. You can use 
Predefined reports or Ad hoc reports to create a dashboard. These dashboards can include other 
dashboards, input controls for choosing the data displayed in one or more frames, and custom 
frames that point to URLs for other content. By merging different types of related content, you can 
create attractive data-rich dashboards. You can view, create, and edit a dashboard only if you have 
the administrator rights.

 Section 3.1, “Creating a Dashboard,” on page 49
 Section 3.2, “Viewing and Editing a Dashboard,” on page 50
 Section 3.3, “Tips for Designing Dashboards,” on page 53

3.1 Creating a Dashboard
1 Click Create > Dashboard.
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2 In the Available Content pane, navigate to the required folder, right-click the report name, and 
click Add to Dashboard, or drag and drop the report from Available Content to Dashboard Viewer.

3 Right-click the report, then click Size to Content.
You can save the dashboard even though its content exceeds the canvas area. In the Fixed Sizing 
mode, if content exceeds the canvas area, you must scroll to see the entire dashboard. For more 
information, see Section 3.2.3, “About Screen Sizes,” on page 52.

4 To view the entire dashboard with the selected resolution, without scrolling:
4a Place the cursor on the report, then click and move towards the right-hand, lower edge of 

the frame.

4b When the resizing icon  is displayed, click and drag the edge of the frame to resize it until 
the required view appears.
For smoother cursor movement, press the Ctrl key while dragging or resizing items and 
frames.

5 Right-click the report, then click Show Scroll Bars or Hide Scroll Bars.
Use Hide Scroll Bars for charts and small crosstabs to resize the frame to fit its content.

6 Click Save Dashboard, or click Save Dashboard As to save as a new version.
7 Specify the name, then save the dashboard in the required folder where you have access 

permissions.

NOTE: While creating a dashboard, you can add an input control. For more information, see 
Section 3.2.1, “Adding Controls to a Dashboard,” on page 51.

3.2 Viewing and Editing a Dashboard
You can view and edit a dashboard if you have access permissions.

1 To view and select the dashboard use any of the following methods:
 Click View > Repository.
 Click View > Search Results.
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 Click Library.

 In the Home page, specify the dashboard name in the search field, then click 
The Repository page is displayed. It provides a different view of the same set of files.

2 In the Repository page, click the dashboard name.
When you are viewing a dashboard that has input controls, remember the following:
 An input control might display as a text field, a drop-down list, a check box, a multi-select 

list, or a calendar icon.
 If one of the frames in a dashboard does not refer to an input control, that frame will not 

update when you change that input control’s value. Only reports that refer to the input 
control reflect the change.

If a dashboard includes a Print View button, click that button to view the dashboard without the 
ZENworks Reporting header and footer. Depending on your web browser, this displays within 
your browser's Print window

3 To run a dashboard, right-click the dashboard, then click Run. 
4 To edit a dashboard, right-click the dashboard, then click Open in Designer.
5 Edit the dashboard by adding, removing, or resizing the window.
6 Click Save.
7 To create a new version of the dashboard, select Save As, then specify a new name.

See the following sections for additional information about dashboards:

 Section 3.2.1, “Adding Controls to a Dashboard,” on page 51
 Section 3.2.2, “Adding a Custom URL to a Dashboard,” on page 52
 Section 3.2.3, “About Screen Sizes,” on page 52

3.2.1 Adding Controls to a Dashboard

When you add a report that has input controls to a dashboard, the controls will not display on the 
dashboard until you explicitly add them. You can add controls while creating or editing a dashboard.  

1 In the Dashboard designer, click Available Content > Special Content > Single Report Controls, or 
click Available Content > Special Content > Multiple Report Controls.  

2 Right-click a value and click Add to Dashboard.
The input control for the specified value is displayed on the canvas.
If you want to place the input control in a location other than above the report, drag it from the 
Available Content list to the required location. You can delete, reposition, and resize the input 
control or its label independently.

3 Select a new value from the input control.
The data displayed in the corresponding report changes.

4 In the Available Content list, click Special Content > Dashboard Controls, then drag the Submit and 
Reset buttons under the input controls on the canvas.
By default, a dashboard automatically updates when you change the values in its input controls. 
When the dashboard includes the Submit button, the server will not update the dashboard until 
you click the Submit button.

5 Click Save.
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3.2.2 Adding a Custom URL to a Dashboard

You can create a frame that displays URL-addressable content. By default, the server uses the HTTP 
protocol for custom URL frames. However, you can also use the FILE protocol by specifying file:// 
at the beginning of the value in the URL. In this case, the server uses the FILE protocol, and searches 
for the file that you specify in the server’s WEB-INF directory. This is helpful for including images.

1 In the Available Content list, click Special Content > Custom URL. 
The Custom URL panel is displayed.

2 Specify the URL of the Web page in the Enter the URL for the frame, including any fixed parameters 
text box. For example, specify www.novell.com 

3 If you want to map the input control with the specified URL, then select the check box below the 
Input Control.
In the URL Parameter Name field, replace the default text with the required parameter. This URL 
Parameter Name field is case-sensitive. 
The Custom URL dialog box uses the iframe HTML tag to define an in-line frame that can contain 
a document. If you experience a problem using the Custom URL option, check the following 
possible causes: Browser security settings have disabled support for iframe, or the target Web 
site does not allow access to its Web page using the iframe HTML tag. 

4 Click OK.
5 Select a new value from the input control, then click Submit.

The server passes the input control value to the specified URL (www.novell.com), then displays 
the related details.

6 Resize the custom URL frame so that only the first article’s outline appears.
7 Click the custom URL frame, then click Auto-refresh Interval to set the refresh interval.

By default, the frame is set to Manual Only.
8 Click Save.

3.2.3 About Screen Sizes

When you create a dashboard, you can set the size of the canvas to match a particular screen 
resolution. 

By default, the dashboard designer supports five standard screen resolutions, which are available by 
clicking Options > Guide. When a dashboard uses fixed sizing, its frames do not resize automatically 
when the window size changes.

In addition to fixed screen resolutions, dashboards support proportional sizing. When a dashboard 
uses proportional sizing, its frames resize relative to the size of the browser window. 

NOTE: As a best practice, design dashboards using the fixed sizing mode, and then switch to 
proportional sizing before you save. You can resize free text items to a smaller size, but not to a larger 
size.
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3.3 Tips for Designing Dashboards
Charts and small crosstabs are best suited for dashboards. However, you can design table reports that 
work well in the dashboard. Such reports tend to be very narrow and are typically used with input 
controls to limit the number of rows they return.

 Section 3.3.1, “Input Control Tips,” on page 53
 Section 3.3.2, “Additional Tips,” on page 53

3.3.1 Input Control Tips

When designing input controls for a dashboard, follow these tips:

 If you want a single input control on the dashboard to control the data displayed in multiple 
reports, ensure that the parameters in these reports have the same name as the input control. 

 When defining a parameter in a report, specify a significant name that can be reused in other 
reports. Then, when two reports having the same parameter are added to the dashboard, their 
input controls will display as Special Content in the Available Content list. Storing such input 
controls in the repository enables you to reuse them  in other reports that are designed and 
added to the repository.

 To pass a value to an external URL, the URL Parameter Name that you specify to the input control 
must match the name of a parameter that the URL can accept. The value of the input control 
must also be a value that the URL can accept. The target URL is likely to have additional 
requirements and limitations.  

NOTE: The  input control must pass data that the URL can accept. Otherwise, the server might not be 
able to retrieve the correct data from the external URL.

3.3.2 Additional Tips

When you create or edit a dashboard, follow these tips:

 Alignment of items: 
 You can use the arrow keys to move selected content, one grid space at a time. 
 Press the Ctrl key to move the selected content, a single pixel at a time.

 Selection of items: 
 The items on the context menu change depending on your selection. For example, the 

context menu might include the Delete Item option or Delete Frame option, depending on 
whether you selected a button or a frame. 

 If you select multiple items or frames, the context menu includes only options that apply to 
all selected items. For example, if you select a frame and a button, the context menu 
includes only the Delete Items option. 

 When you select multiple frames, the context menu includes several options that can apply 
to the frames as a group, such as Hide All Scroll Bars and Delete Items.

 Select multiple frames to change their sizes all at once. When you drag the edge of one 
frame, the other frames resize as well.

 Relocation or deletion reports in dashboards: 
 When you delete a report that includes input controls from the dashboard, the controls are 

also deleted, but their labels remain. Delete labels manually. 
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 If a custom URL frame is mapped to a deleted input control, the server indicates the default 
URL, but does not pass the parameter.

 Keep track of reports used in dashboards to prevent unintentional deletion. The server 
deletes a report from a dashboard when you delete it from the repository or when you 
move it to a new location.

 Embedding dashboards: 
 A dashboard can include other dashboards, unless this creates a circular dependency. Do 

not attempt to add a dashboard to itself.
 Multiple reports in a dashboard that refer to the same input control are controlled by that 

single input control. If you want users to set the input controls separately for each report, 
create two dashboards, with each referring to the input control; then, create a third 
dashboard that includes the other two. 

 Adding the same dashboard twice to a parent dashboard can create a compelling 
comparison, as shown in Figure 3-1 on page 54.
In the dashboard shown below, the same dashboard is used with two different input 
controls,  one with the Windows platform; and the other with the Linux platform. In this 
example, the number of devices using different versions of Windows and Linux operating 
systems are shown. 

Figure 3-1   Compelling Comparison Dashboard
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4 4ZENworks Reporting Management

In ZENworks Reporting, users are managed only through the LDAP server, which is configured 
during ZENworks Reporting installation. By default any user present in the LDAP server can login to 
ZENworks reporting. In the LDAP server, it is recommended to maintain users in groups, to have 
advantage of role based user management available in ZENworks Reporting.

When a user initially login to ZENworks Reporting:

 User is created in the ZENworks Reporting repository.
 A role is created based on the LDAP group.
 User is assigned to the newly created role.

For subsequent users belonging to the same LDAP group, when the user initially login, a user is 
created in ZENworks Reporting and user is assigned to the previously created Role in ZENworks 
Reporting.

In ZENworks Reporting users are categorized in to two categories (administrators and non-
administrators). The groups, which are selected during installation in the Configure User Source 
wizard, are mapped to ROLE_ADMINISTRATOR. For all other users a role is created based on the 
LDAP group they belongs. For example, “user1” is a user belongs to LDAP group “group1”, then a 
role by name “ROLE_ group1” is created and user1 is assigned to that role.

Administrators manage ZENworks Reporting. Initially only administrators have access permissions 
to ZENworks Reporting. Administrators provide access permissions to other users either at role level 
or at user level. 

For more information about permissions, see Section 4.3.1, “Permissions,” on page 57.

NOTE: Only administrators can view and access the Manage menu.

The Non-Administrators, can analyze the data, create and scheduling reports. 

 Section 4.1, “Managing Users,” on page 55
 Section 4.2, “Managing Roles,” on page 56
 Section 4.3, “Managing the Resources,” on page 57
 Section 4.4, “Managing the ZENworks Reporting Settings,” on page 60

4.1 Managing Users
Users are managed only through LDAP server. 

To view user properties:

1 Click Manage > Users, or in the Home page, click Manage Server > Users.
The administrator can view all users.
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2 To locate a user, search for a specific user and specify a search string in the Search field of the 
Users panel. The search results display all users.

3 Select the user in the Users panel. The user’s properties display in the Properties panel.
The properties include the user name, user ID, email address, roles assigned, and profile 
attributes. The role names are linked to the Role Management for each role.

To delete a user:

1 Select the user in the Users panel. If the list of users is too long, specify a search string to find and 
select the user.

2 Click Delete.

4.2 Managing Roles
Roles define sets of users having similar permissions. Administrators cannot assign users to Roles, it 
is done only at the LDAP server. There can be any number of roles that are mapped through LDAP 
server.

Table 4-1   Roles in ZENworks Reporting

To view role properties: 

1 Click Manage > Roles, or in the Home page, click Manage Server > Roles.
2 In the Roles panel, click the role.

To search for a specific role, specify a search string in the Search field of the Roles panel. The 
search results display the roles with name that matches the search string.

3 Select the role in the Roles panel. The role’s properties display in the Properties panel.
The Properties panel displays the role name, and the list of users to whom the role has been 
assigned. The list of users display only their user IDs, but if you place mouse over an ID it 
displays the full name and organization.

To delete a role:

1 In the Roles panel, select a role.
2 Click Delete.

NOTE: Admin can delete a role in ZENworks Reporting, but it cannot be deleted from the LDAP 
server.

Role Description

ROLE_ADMINISTRATOR ZENworks Reporting automatically assigns this role to admin user in every new 
organization. It is a special system-level role that is visible in every organization 
and which organization admins may assign to other users.

ROLE_USER Every user who logs in to ZENworks Reporting must have this role.
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4.3 Managing the Resources
You can manage the resources in the ZENworks Reporting. 

 Section 4.3.1, “Permissions,” on page 57
 Section 4.3.2, “Creating Ad Hoc View permissions,” on page 59
 Section 4.3.3, “Creating Folders,” on page 59
 Section 4.3.4, “Moving Folders,” on page 59

4.3.1 Permissions

Permissions on folders and resources determine what users see in the repository and perform 
actions. In the following table, the set of permissions are defined:

Permission Actions Granted on Repository Folders and Resources

No Access Users cannot view or access the folder or resource.

For all non-administrator users, the default permission at the root is No Access and any 
permissions must be explicitly defined.

Execute Only Users cannot view the folder or resource in the repository, but the reports or dashboard, 
that they run can access them.

Read Only  View the folder or resource.

 View the properties of a folder or a resource.

 Copy a folder and all of its readable contents.

 Copy resources.

 View (run) a report, or dashboard.

 Run a report in the background.

 Schedule a report to run later.

Read + Delete  Cut, move or delete a folder and all of its contents.

 Cut, move or delete resources.

Read + Write + 
Delete

 Add a sub folder.

 Copy or cut and paste into a folder.

 Save a new Ad Hoc view, report, or dashboard in a folder.

 Save the output of a scheduled report in a folder.

 Rename a folder or resource and change its description string.

 Open an Ad Hoc view in the Ad Hoc Editor or a dashboard in the designer.

 Modify and overwrite an existing Ad Hoc view, report or dashboard.

 Add a ZENworks Report resource to the repository (upload a JRXML)

 Edit the definition of a ZENworks Report resource in the repository (replace the 
JRXML)

Administer Set the permissions (by role and by user) on a folder or resource. This effectively 
delegates certain repository administration tasks.
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Permissions apply when browsing or searching the repository, as well as when using any dialog that 
accesses the repository, such as when browsing folders to save a report. Note that:

 Copying cannot preserve the permissions on an object. Users may copy a read-only object, paste 
it into a read-write folder, then edit the object.

 Copying and cutting (moving) actions can only be completed if the user has Read + Write + 
Delete access to the folder in which the object is pasted. For more information, see Section 4.3.4, 
“Moving Folders,” on page 59.

 Cutting, deleting, and setting permissions on folders is allowed only if the user has the same 
permission on all folder contents. Cutting and deleting resources in bulk is allowed only if the 
user has at least Read + Delete permission on all selected resources.

 Deleting a resource or the contents of a folder is only allowed if no other resources rely on them.

Setting Permissions

Administrators assign permissions to user to access any folder or resource throughout the repository. 
Users with the Administer permission on a folder can assign permissions to that folder and any 
contents that inherit the permission. Users with Administer permission to a resource can only set the 
permissions on that specific resource. 

1 Log in to ZENworks Reporting as a user with administrator privileges.
2 In the Repository, browse or search for the folder or resource.
3 Right-click the object and select Permissions...

In the Permissions panel, permissions for the selected object is displayed. By default, it shows 
the permissions given to roles. Permissions that are inherited from the object’s parent are 
indicated by an asterisk (*).

4 In the Permissions panel, click User to view the permissions assigned to specific users. Click Role 
when viewing user permissions to toggle back.

5 For each user or role, you can select a new permission from the drop-down.
It shows the default user permissions on this folder.

6 Click Apply to save the changes. If you toggle between user and role permissions, you must click 
Apply first to save the changes.

7 Click OK to save your changes.
You can open several permissions dialogs for different resources or folders at the same time, as 
well as navigate the repository. This helps when trying to set permissions uniformly across 
several folders or organizations.

NOTE: Following are two special cases while setting permissions:

 If a resource inherits a permission, for example Read-Only, you cannot set the permission to the 
same value, at least not directly. You must temporarily change the permission level on the parent 
folder, set the explicit permission, and then set the parent folder’s permission back to the 
original value.

When a resource and its parent folder have been set to the same permission in this way, the 
permission still shows the asterisk as if the permission were inherited. But when the parent is 
later given a different permission, for example Read-Write, the resource retains its explicit Read-
Only permission instead of inheriting Read-Write.

 To reset the permission level so that it inherits from its parent folder, select a different 
permissions level and click Apply, then select the permission with the asterisk and click Apply.
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4.3.2 Creating Ad Hoc View permissions 

An administrator can assign create Adhoc View permissions to users (non-administrators).

To assign permissions:

1 Log in to ZENworks Reporting as users (non-administrators). 
It allows User or Role being available for permissions.

2 Log in to ZENworks Reporting as an administrator.
3 Provide Read Only permission to the folder Organization either to the non-administrator, or to 

the role that non-administrator belongs.
4 Provide Read+Write permission to the Organization or Temp folder to the non-administrator or 

to the role non-administrator belongs.
5 Create any folder Under Organization, Reports, or ZENworks folder, for example, My Reports. 

provide Read+Write, or Read+Write+Delete permission to this folder to the non-administrator  
or to the role that non-administrator belongs.

4.3.3 Creating Folders

If you have Write permission for folders and resources, you can create folder and assign rights.

To Create a folder:

1 Log in to ZENworks Reporting.
2 Click View > Repository.
3 In the Folders panel, right-click on a folder, then click Add Folder.
4 In the Add Folder dialog box, specify a name, and click Add.

You can provide permissions to the created folder through users or roles.

4.3.4 Moving Folders

If you have read rights for folders and resources, you can copy from the folder and paste them to 
another destination folder which has write permission. You can use cut option only if you have you 
have write permission for folders and resources.

NOTE: Relocated objects inherit permissions from the destination folder. To change permissions on 
an object, set the permissions explicitly.

To move folders and resources:

1 Log in to ZENworks Reporting as a user who has these permissions: 
 Read permission on the folder or resource to move.
 Write permission on the destination folder. 

2 Click View > Repository.
3 In the Folders panel, click Reports > ZENworks > Add Folder.
4 In the Add Folder dialog box, enter a name, for example, ZENworks Reports.
5 Click Add.

The ZENworks Reports folder is displayed as a sub folder of ZENworks and inherits 
Administrator User’s default permissions (read-write-delete) on the parent folder.
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6 The ZENworks Reports folder deserves a more prominent location. Move it up one level:
6a In Folders, right-click ZENworks Reports, then click Cut.
6b Right-click Reports, and select Paste.

The ZENworks Reports folder now displays in Reports at the same level as ZENworks.

NOTE: You can relocate a folder, subject to permissions, anywhere in the repository with one 
exception: The server do not support copying and pasting a folder to the same location. If the Paste is 
disabled when you right-click a destination folder, you do not have write permission on the folder.

4.4 Managing the ZENworks Reporting Settings
An administrator can manage ZENworks Reporting settings.

 Section 4.4.1, “Managing the Log Settings,” on page 60
 Section 4.4.2, “Managing the Ad Hoc Settings,” on page 62
 Section 4.4.3, “Managing the Ad Hoc Cache Settings,” on page 63
 Section 4.4.4, “Managing the Import Settings,” on page 65
 Section 4.4.5, “Managing the Export Settings,” on page 66

4.4.1 Managing the Log Settings

The jasperserver.log file is located at the following path: 

 For Windows: %ZRS_HOME%\js\apache-tomcat\webapps\jasperserver-pro\WEB-INF\logs
 For Linux: /opt/novell/zenworks-reporting/js/apache-tomcat/webapps/jasperserver-

pro/WEB-INF/logs

To manage log settings:

1 Click Manage > Server Settings > Log Settings.
2 In the Log Settings page, use the drop-down list to change the log level for each class being 

logged.
The four logging levels indicate the type of event recorded by a logger.

The following table lists each logger name as it displays on the Log Settings page, it is used to 
find a particular log in the log file, and a description of the logger.

Setting Level of Information

ERROR Writes minimal information to the log describing serious program faults.

WARN Writes error and warning messages to the log. Warning messages contain cautionary 
information to help you whether the logged events require your attention.

INFO Writes error, warning, and informational messages to the log. Informational messages 
describe significant events, such as those that affect application performance.

DEBUG Writes error, warning, informational, and additional messages to the log. Debug messages 
are very detailed. Use this setting only to diagnose a problem. DEBUG can impact system 
performance and should not be used in production environments.
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Logger Name Identifier in log Description

SQL query executer JRJdbcQueryExe 
cuter

Logs SQL text and parameter values for queries that are 
run by the SQL query executer. 

Input control value 
queries

valueQueryLog Logs SQL text and parameter values for queries 
associated with input controls. 

Cascading input 
control parameter 
resolution

FilterCore Logs activity associated with cascading input controls. 
Query-driven input controls can cascade when a query 
has a parameter whose value comes from another input 
control. When the parameter value is changed, the query 
is automatically rerun, possibly changing the list of values 
for its input control.

Cascading input 
control query result 
caching

TokenControlLogic Logs use of the cache for results of cascading input 
control queries.

Hibernate SQL SQL Logs SQL run by the Hibernate layer to access the 
ZENworks Reporting repository database. This logger 
generates a large volume of logging that could affect 
performance.

Ad Hoc data policy 
logging

CommonDomainData
Strategy

SubFilterInputControl
Generator

Others

Logs various activities of the Ad Hoc data policy 
implementations, which use SQL queries or in-memory 
operations to get data sets for Ad Hoc views. 

SQL generated for 
Domain queries

JdbcBaseDataSet Logs SQL queries generated from queries using a 
Domain.

Connection handling 
for Domains

DataSourceResolverI
mpl

Logs use of JDBC connections used by Domains to run 
SQL queries.

Expression to JSON 
converter

ExpressionJSON 
Converter

Logs information about the conversion between DomEL 
and JSON, which is used by Ad Hoc filters.

Domain-based 
security tests

SemanticLayerSecurit
yResolver Impl

Logs activity related to Domain column- and row-level 
security.

Cascading input 
control resolution for 
Domains

DomainFilterResolver Logs the same activity as the FilterCore logger 
(Cascading input control parameter resolution) above, 
but adds information specific to Domain queries. 

Ad Hoc cache activity CachedData Logs information about the life cycle of datasets that are 
cached in memory when Ad Hoc views are accessed.

Timing for SQL 
queries run for reports

JsControlledJdbcQuer
yExecuter

Logs the time it takes a query run by the SQL query 
executer to return data to a report.

Ad Hoc 
WorkingDataSet

WorkingDataSet Logs activity for the WorkingDataSet, used by the Ad Hoc 
Editor to perform in-memory dataset transformations of 
query results.

General controller AdhocAjaxController Logs activity of the Ad Hoc Editor.

Crosstab controller AdhocCrosstabAjaxC
ontroller

Logs additional activity of the Ad Hoc Editor specific to 
crosstab reports.
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3 To add a logger, scroll to the bottom of the page.
4 Use the drop-down to set the logging level.

4.4.2 Managing the Ad Hoc Settings

The Ad Hoc settings limit the resources available for queries when Ad Hoc views are designed and 
run. The Query that you can set are:

 Ad Hoc Filter List of Values Row Limit: The maximum number of items that should be displayed in 
the Condition Editor when a user defines filters for an Ad Hoc view that is based on a Domain. If 
this limit is exceeded when users define filters, then ZENworks Reporting displays a message. 
Setting this to a lower value can improve performance.

 Ad Hoc Dataset Row Limit: The maximum number of rows that an Ad Hoc view can be return. 
ZENworks Reporting truncates the data when the limit is reached. Setting this to a lower 
number may improve performance, but your reports may not reflect the full data set.

 Ad Hoc Query Timeout: The number of seconds the server should wait before timing out an Ad 
Hoc view while running its query. Setting this to a lower number may prevent exceptions from 
being displayed to users when they run Ad Hoc views. Setting this to a higher number may 
prevent complex calculations from timing out, but it results in the use of more database 
connections. 

To set Ad Hoc settings: 

1 Click Manage > Server Settings > choose Ad Hoc Settings.
2 In the Ad Hoc Filter List of Values Row Limit, specify the maximum number of items to display in 

the Condition Editor when a user defines filters for an Ad Hoc report based on a Domain.
3 In the Ad Hoc Dataset Row Limit, specify the maximum number of rows that an Ad Hoc view can 

return.
4 In the Ad Hoc Query Timeout (seconds) field, specify the number of seconds the server should wait 

before timing out an Ad Hoc report while running its query.
5 Click Change to save your changes.

Groovy code 
generation for 
memory datasets 

GroovyGenerator Logs Groovy classes generated from DomEL 
expressions used by the Ad Hoc Editor for filters and 
calculated fields.

Ad Hoc AJAX 
requests

adhocAjaxRequests Logs information about AJAX requests done by Ad Hoc 
Editor and dashboard designer, including report 
parameters and response times. Enable this setting when 
you want Ad Hoc Editor and dashboard designer have 
encountered an error or slow response times.

Ad Hoc cache activity com.jaspersoft.comm
ons. 
datarator.CachedData

Tracks the life cycle of datasets managed by the Ad Hoc 
cache as they transition between statuses. This log 
output includes information from the Ad Hoc cache in a 
format that lends itself to troubleshooting. Use this setting 
to understand how query response times contribute to the 
performance and responsiveness of the Ad Hoc Editor. 
Because it does not log the queries themselves, use it in 
conjunction with the SQL Query Executer log setting.

Logger Name Identifier in log Description
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Understanding Data Policies

Data policies determine how ZENworks Reporting handles data loading and processing for certain 
types of Ad Hoc views. They determine how data is cached and where certain calculations occur. For 
example, you can specify that the data accessed by Domain-based reports is grouped, sorted, and 
aggregated in the database rather than having the server process it in memory.

The data polices that you can set are:

 Optimize Queries for JDBC-based Reports: Selects grouping, sorting, and aggregation of queries for 
JDBC-based reports. Otherwise, the queries run unaltered in memory.

 Optimize Queries for Domain-based Reports: Selects grouping, sorting, and aggregation of queries 
for Domain-based reports. Otherwise, the queries run unaltered in memory.

To set data policies:

1 Click Manage > Server Settings > Ad Hoc Settings.
2 Select Optimize Queries for JDBC-based Reports to process queries for JDBC-based reports.
3 Select Optimize Queries for Domain-based Reports to process queries for Domain-based reports.
4 Click Change to save your current settings.

NOTE: These data policy settings does not update the existing reports created from Ad Hoc views in 
your repository. To change the data policy for an existing report, select the appropriate policy setting, 
open the corresponding view in the Ad Hoc Editor, and save the report again.

4.4.3 Managing the Ad Hoc Cache Settings

ZENworks Reporting can temporarily cache Ad Hoc query result sets for re-use. The cache is 
populated by the data that results from queries when creating or running Ad Hoc views. The 
datasets are uniquely identified with a key that references the query itself, the data source URI, and 
parameters used when the query was issued.

Caching reduces database loads and delivers frequently-used datasets to the user quickly. Caching 
applies when reports are created as well as when they are run. You can configure the Ad Hoc cache to 
optimize memory usage and response time for your usage patterns.

Setting the Cache

By default, datasets for each user are cached separately; a parameter in the cache key identifies the 
user. This per-user caching can result in duplicate datasets when different users run the same query. 
You can configure ZENworks Reporting to share cached datasets across users by editing the \WEB-
INF\applicationContext-datarator.xml file.

The following code configures the cacheKeyInterceptor to ignore logged-in users’ credentials 
when creating the cache keys:

<property name=”ignoredParameters”> <list>

 ... <value>LoggedInUser</value>

 <value>LoggedInUsername</value> </list>

</property>
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After adding the code restart ZENworks Reporting.

Configuring the Cache

Caching improves overall performance of data retrieval and sorting, but unused datasets can 
consume memory. To address these issues, you must configure the frequency to clear the cache. 

To configure the frequency with which the cache is automatically cleared, edit the following 
configuration file:

After editing the configuration file restart ZENworks Reporting.

Manually Clearing the Cache

Administrators can view the query but not the content of the dataset in the cache. The Ad Hoc cache 
page also displays performance data about each query. This information is helpful when trying to 
resolve performance issues. 

The following are the values for query:

 Query (msec) – Time in milliseconds consumed, when query was sent to the data source 
(database) until the first row was received.

 Fetch (msec) – Time in milliseconds from when first row was received from the data source 
(database) until the last row was received.

 Memory used (MB) – Size in megabytes of the resulting dataset being stored in the cache entry. 
The Ad Hoc cache page also allows administrators to manually remove datasets if necessary to 
fetch recent data. 

To view and clear the Ad Hoc Cache manually:

1 Click Manage > Server Settings > Ad Hoc Cache.
The Ad Hoc Cache page is displayed with all the datasets that are in the cache, sorted by age.

2 In the Query & Source column, click a query for which you want to view the details.
The Detail page is displayed with additional information for the selected query, such as the 
number of rows in the cached dataset.

Ad Hoc Cache Expiration 

Configuration File

…\WEB-INF\adhoc-ehcache.xml

Property Default 
Value

Description

maxEntriesLocalHeap 1 The maximum number of cache entries  in local heap memory. 

timeToIdleSeconds 300 The number of seconds to wait after a dataset is has been accessed 
before removing it from the cache. The default is 30 minutes. Use 0 
(zero) for no limit.

timeToLiveSeconds 300 The maximum time that a dataset is stored in the cache, even if it is 
being repeatedly accessed. Ensures that stale data is periodically 
replaced. The default is 90 minutes. Use 0 (zero) for no limit.
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3 Click Clear to remove a data set from the cache.
4 Click Clear All at the top of the Ad Hoc Cache page, to remove all datasets.

4.4.4 Managing the Import Settings

Import settings allows you to simplify the import procedure. Import operates on a running server, 
and all imported resources are visible immediately. In addition, any configuration or security settings 
in the imported catalog affect immediately, without restarting the server. 

You must import only through command prompt.

Importing from the Command Line

Usage: js-import [OPTIONS]

NOTE: It is recommended to stop your server before using the import command line utility to avoid 
issues with caches, configuration, and security. For instructions see the “ZENworks Reporting 
Services”in the ZENworks Reporting 5 Installation Guide.

Reads a repository catalog from the your file system and creates the named resource in the 
ZENworks Reporting repository. The repository catalog must have been created by the export 
interface or the js-export command, either as a ZIP archive file or a folder structure.

Table 4-2   Options in js-import Command 

Option Explanation

--help Displays brief information about the available options.

--input-dir Path for importing a catalog from a directory.

--input-zip Path and filename for importing a catalog from a zip file.

--update Resources in the catalog replace those in the repository if their URIs and types match.

--skip-user-
update

When used with --update, users in the catalog are not imported or updated. Use this option to 
import catalogs without overwriting currently defined users.

--include-
access-
events

Restores access events (date, time, and username of last modification) on imported resources.

--include-
audit-events

Professional edition only. Imports any audit data that exists in the catalog.

--include-
monitoring-
events

Professional edition only. Imports any monitoring data that exists in the catalog.
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Examples:

 Import the myExport.zip catalog archive file: 

js-import --input-zip myExport.zip

 Import the myDir catalog folder, replacing existing resources if their URIs and types match those 
found in the catalog: 
js-import --input-dir myDir --update

 Import the myExport.zip catalog archive file but ignore any users found in the catalog: 
js-import --input-zip myExport.zip --update --skip-user-update

 Import the myDir catalog folder with access events: 

js-import --input-dir myDir --include-access-events

4.4.5 Managing the Export Settings

Export settings allows you to export users and roles in addition to, or instead of, repository contents, 
use the server settings pages for system administrators. 

1 Click Manage > Server Settings > Export.
2 Specify the name of the catalog zip file to export.

The Web UI supports only the zip archive format
3 Use the following check boxes to choose the contents of your exported catalog file:

 Select Export Everything to export the entire repository, including permissions and report 
jobs, as well as all organizations, users, and roles.
Select Include access events if you want to include resource modification times.

 Clear the Export Everything check box, then select only users and roles to export.
Select Include users with selected roles if you want to select only roles and the users.

 In either case, you can select Include audit events and Include monitoring events separately.
4 Click Export.

The server generates the catalog zip file and your browser prompts you to save the file, 
depending on the size of the catalog and the options that you have selected.

Exporting from the Command Line

Usage: js-export [OPTIONS]

--include-
server-
settings

Determines whether the system configuration is updated from the catalog. There are two pre-
requisites in order for the catalog to contain configuration settings:

The originating server settings must be modified through the UI (Log Settings, Ad Hoc Settings, 
Ad Hoc Cache Settings).

The catalog must be exported with the “everything” option from the user interface or the 
command-line utility.

When server settings are imported, they take effect as soon as the server is started.

Option Explanation
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NOTE: It is recommended to stop your server instance before running the export utility. For 
instructions see the “ZENworks Reporting Services”in the ZENworks Reporting 5 Installation Guide.

Specifies repository resources such as reports, images, folders, and scheduled jobs to export to the file 
system. You can also export the internal definitions for scheduled jobs, users, roles, as well existing 
audit data. The export output is known as a repository catalog; it is either an archive file or a set of 
files in a folder structure:

Table 4-3   Options in js-export Command 

Examples:

 Export everything in the repository: 

Option Explanation

--everything Export everything except audit and monitoring data: all repository resources, permissions, report 
jobs, users, and roles. If any server settings have been modified in the UI, those are included as 
well. This option is equivalent to:

--uris --repository-permissions --report-jobs --users --roles

--help Displays brief information about the available options.

--include-
access-
events

Access events (date, time, and user name of last modification) are exported.

--output-dir Path of a directory in which to create the output catalog folder.

--output-zip Path and filename of the output catalog zip file to create.

--report-jobs Comma separated list of repository report unit and folder URIs for which report unit jobs should 
be exported. For a folder URI, this option exports the scheduled jobs of all reports in the folder 
and recursively in all subfolders.

--repository-
permissions

When this option is present, repository permissions are exported along with each exported 
folder and resource.

This option should only be used in conjunction with --uris.

--roles Comma separated list of roles to export; if no roles are specified with this option, all roles are 
exported.

--role-users When this option is present, each role export triggers the export of all users belonging to the 
role. This option should only be used in conjunction with --roles.

--uris Comma separated list of folder or resource URIs in the repository.

--users Comma separated list of users to export; if no users are specified with this options, all users are 
exported. Exporting a user includes all user attributes and, in order to maintain consistency, also 
exports all roles assigned to the user. When specifying users, you must give their organization 
ID if applicable, for example:

--users user1, "user2|organization_1", ...

--include-
audit-events

Include audit data for all resources and users in the export.

--include-
monitoring-
events

Include monitoring data for all resources and users in the export.
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js-export --everything --output-dir myExport

 Export the /reports/samples/AllAccounts report unit to a catalog folder: 
js-export --uris /organizations/organization_1/reports/samples/AllAccounts --
output-dir myExport

 Export the /images and /fonts folders: 
js-export --uris /organizations/organization_1/images,/organizations/
organization_1/reports --output-dir myExport

 Export all resources (except users, roles, and job schedules) and their permissions to a zip 
catalog: 
js-export --uris / --repository-permissions --output-zip myExport.zip

 Export all resources and report jobs: 
js-export --uris / --report-jobs / --output-dir myExport

 Export the report jobs of the /reports/samples/AllAccounts report unit: 
js-export --report-jobs /organizations/organization_1/reports/samples/
AllAccounts --output-dir myExport

Export all roles and users:
js-export --roles --users --output-dir myExport

 Export the ROLE_USER and ROLE_ADMINISTRATOR roles along with all users belonging to 
either role: 
js-export --roles ROLE_USER, ROLE_ADMINISTRATOR --role-users --output-dir 
myExport
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5 5ZENworks Reporting Configuration Tool 

Perform the tasks in the following sections to launch ZENworks Reporting Configuration Tool:

 Section 5.1, “Understanding What the ZENworks Reporting Configuration Tool does,” on 
page 69

 Section 5.2, “Reconfiguring the ZENworks Reporting solution,” on page 69

5.1 Understanding What the ZENworks Reporting 
Configuration Tool does
ZENworks Reporting Configuration Tool is used for configuring, or changing different settings for 
ZENworks Reporting. You can perform the following: 

 Re-configuring Ports
 Remint SSL Certificates
 Re-configuring LDAP Server details
 Re-configuring Data Source
 Re-configuring Database Servers
 Re-configuring Outbound Email Server

This tool is accessed only on a device where ZENworks Reporting is installed. While configuring if 
particular configuration like Ports are skipped, then the earlier configuration settings are retained. 
This tool is installed along with ZENworks Reporting and is launched only in GUI mode. 

5.2 Reconfiguring the ZENworks Reporting solution
The ZENworks Reporting Configuration Tool is installed during ZENworks Reporting installation. It 
is installed at the following location:

 For Windows:  

\%ZRS_HOME%\bin\zrsconfig.exe

 For Linux:  
/opt/novell/zenworks-reporting/bin/zrsconfig.sh

1 Execute the ZENworks Reporting Configuration Tool by using the Graphical User Interface 
(GUI) method:
 For Windows: Click Start > All Program > ZENworks Reporting > ZENworks Reporting 

Configuration 
or run the following command:
\%ZRS_HOME%\bin\zrsconfig.exe
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 For Linux: Run the following command: 
/opt/novell/zenworks-reporting/bin/zrsconfig.sh

2 Follow the prompts in the configuration program. For more information, see Section 5.2.1, 
“Configuration flow,” on page 70.

5.2.1 Configuration flow

This table provides explanation for all configuration settings done by using ZENworks Reporting 
Configuration Tool. The settings are updated only after complete configuration settings are done.

Configuration 
Prompts

Explanation

Specify the 
language

You are prompted to select the language in which the ZENworks Reporting Configuration 
Tool must run. Select the language and click Continue. 

Reconfigure 
Ports

Current configured ports are displayed. You can reconfigure the ports, if you change any of 
the port, only that port gets updated and for other ports it retains the earlier configuration 
settings.

The following ports are used by the ZENworks Reporting:

 Server Port: This port is non-secure port used by ZENworks Reporting.

 Secure Server Port: Secured port used by ZENworks Reporting.

 AJP Connection Port: This port is AJP port used by ZENworks Reporting. It 
represents a connector component that communicates with a web connector through 
APJ protocol.

 Shutdown Port  

 Database Server Port: This is used by POSTGRES database embedded in 
ZENworks Reporting and cannot be modified.

Remint SSL You can remint the ZENworks Reporting SSL certificate. 

To Remint SSL certificates now: Select the Remint certificate check-box, if you want to 
remint SSL certificates.

 For Internal Certificate Authority:  

1. Select Internal Certificate Authority.

2. Click Next.

 For External Certificate Authority:  

1. Select External Certificate Authority.

2. Specify the following:

 Signed SSL Certificate: Click Choose, then browse for the .der signed 
certificate file.

 Private Key File: Click Choose, then browse for the .der private key file 
associated with the signed certificate.

 Certificate Authority Certificate: Click Choose, then browse for the .der 
trusted CA certificate file.

3. Click Next.

To Reminit SSL certifcate later: Clear the Remint certificate check-box and click Next.
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Reconfigure 
LDAP

You can reconfigure the LDAP (Lightweight Directory Access Protocol) server connection 
details. 

You can reconfigure the LDAP in the following scenarios:

 Change Admin Groups for ZENworks Reporting.

 Updating the password for a user which is used for performing a Simple Bind on the 
LDAP server.

 An LDAP server is migrated.

 An LDAP server connection details are changed.

 LDAP server needs to point to backup server.

NOTE: Users and roles are managed through LDAP. Groups in LDAP can be mapped to 
ZENworks Reporting Administrator role.

1. Current settings are displayed:

 Server: You can change the DNS name or IP address of the LDAP server which 
is used for user authentication.

 SSL: Select the SSL check box, if the LDAP server is configured in SSL mode, or 
clear the SSL check box, if the LDAP server is configured in non-SSL mode.

 Port: Currently configured port value is displayed. You can change the port value.

 Username: Update the user name in Distinguished Name (DN) format. For 
example, for eDirectory cn=admin,o=mycompany and for Active Directory 
cn=ReadOnlyUser,cn=users,dc=organization,dc=com

The user name is required to get Read-only access to the LDAP source.

 Password: Update the password of the ZENworks user.

 (Optional) Root Context: If root context is specified, then groups belonging to 
only that context (nested containers) will be available.

If you do not specify a root context, the directory’s root container becomes the 
entry point.

2. Click Next.

3. Select one or more groups in the LDAP server to assign the administrator role in 
ZENworks Reporting. Any user from those mapped groups can log into ZENworks 
Reporting with administrator rights.

The administrator rights are:

 Assign rights for various ZENworks Reporting resources (reports, domain, data 
sources, and so on) to ZENworks Reporting roles.

 Assign rights to view, create, schedule, and delete reporting resources (reports, 
domain, data sources, and so on).

4. Click Next.

Configuration 
Prompts Explanation
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Reconfigure 
Data Source

Current Data Source settings are displayed and can be updated. Data source configuration 
publishes the domains and reports for ZENworks Reporting.

 You can change the data source in the following scenarios:

 Need to import an updated data source.

 ZENworks have been updated with a new set of domain and reports.

To Reconfigure Datasource later: Select the Configure Datasource later check-box, if you 
want to change the settings later.

To Reconfigure Datasource now: Clear the Configure Datasource later check-box, and 
click Next.

You can reconfigure the data source by using one of the following methods:

 For ZENworks Management Zone:  

1. Select ZENworks Management Zone.

2. Specify the following:

 Server Address: The DNS name or the IP address of the ZENworks server 
from where you want to download the domain and reports. 

 SSL Port: The SSL port for ZENworks server.

 Username: The ZENworks user with Super Administrator rights.

 Password: The password of the ZENworks user.

3. Click Next, the ZENworks certificate dialog box is displayed.

4. Validate the certificate and click Yes in the Certificate dialog box.

The installer fetches the ZENworks resource files and publishes the reports, 
doamins and data source.

Configuration 
Prompts Explanation
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 For other ZENworks products:  

1. Select Reporting Configuration file.

2. Click Choose, browse to a resource (for example, ZENworks Mobile 
Management), then click Next.

NOTE: The resources are provided in .zip file format and posted on the Novell 
Web site (http://www.novell.com/). Download these files to a temporary location 
on your Windows or Linux device.

3. The installer prompts to configure database. The following are the databases 
supported by the ZENworks products:

 Sybase SQL Anywhere 

 Microsoft SQL Server 

 Oracle 

4. Specify the following, based on the database that you selected:

 Server: Specify the ZENworks database IP address.

 Database Server Port  

 Database Name  

 Instance Name: This field is displayed, if Microsoft SQL Server is selected. 

 Username: Specify the database user created by the ZENworks.

 Password  

5. Click Next.

Reconfigure the 
Outbound Email 
Server

You can reconfigure the Outbound Email Server. This configuration is required for enabling 
the Report Scheduling feature in ZENworks Reporting.

 To configure the Outbound Email Server now: 

1. Clear the Configure Outbound Email Server later check box.

2. Specify the following:

 SMTP Mail Server Address: Specify the DNS name or the IP address of 
the SMTP server. SMTP server is used for sending emails.

 Port: Specify the port number on which the SMTP server is listening. By 
default, the port number is 25.

 From Email Address: Specify the sender’s email address.

 Password: Specify the sender’s password.

3. Click Install.

 To configure the Outbound Email Server later:  

1. Select the Configure Outbound Email Server later check box.

2. Click Install.

Configuration 
completion

A confirmation message is displayed when the configuration is completed.

The settings that are updated in all the screens are re-configured only when configuration is 
completed.

Configuration 
Prompts Explanation
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