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About This Guide

This Novell ZENworks 11 SP3 Asset Management Reference includes information to help you manage 
the software licenses within your organization. The information in this guide is organized as follows:

 Part I, “License Compliance,” on page 11
 Part II, “License Allocation,” on page 113
 Part III, “Software Usage,” on page 135
 Part IV, “Contracts,” on page 149
 Part V, “Documents,” on page 171
 Part VI, “Reports,” on page 179

Audience

This guide is intended for Novell ZENworks administrators.

Feedback

We want to hear your comments and suggestions about this manual and the other documentation 
included with this product. Please use the User Comments feature at the bottom of each page of the 
online documentation.

Additional Documentation

ZENworks 11 SP3 Asset Management is supported by other documentation (in both PDF and HTML 
formats) that you can use to learn about and implement the product. For additional documentation, 
see the ZENworks 11 SP3 documentation Web site (http://www.novell.com/documentation/
zenworks113).
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I ILicense Compliance

Novell ZENworks Asset Management lets you monitor software products in your organization to 
know whether or not your software deployment complies with your software licensing. 

 Chapter 1, “License Compliance Concepts,” on page 13
 Chapter 2, “Setting Up License Compliance,” on page 23
 Chapter 3, “Configuring Compliance Settings,” on page 27
 Chapter 4, “Monitoring Compliance Status,” on page 29
 Chapter 5, “Generating Compliance Reports,” on page 37
 Chapter 6, “Working with Licensed Products,” on page 39
 Chapter 7, “Working with Entitlements,” on page 51
 Chapter 8, “Working with Discovered Products,” on page 67
 Chapter 9, “Working with Purchase Records,” on page 81
 Chapter 10, “Working with Catalog Products,” on page 95
 Chapter 11, “Working with Software Collections,” on page 107
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1 1License Compliance Concepts

Ensuring that your organization owns the licenses needed to cover the products your users have 
installed is a critical component of license management. At the same time, you want to minimize 
costs by purchasing only the number of licenses that you really need.

Novell ZENworks Asset Management helps you attain this balance by monitoring and reporting the 
license compliance status (compliant, overcompliant, or undercompliant) of your software products.

The following sections introduce the concepts you should understand to effectively use Asset 
Management to manage software license compliance in your organization:

 Section 1.1, “License Compliance Components,” on page 13
 Section 1.2, “Entitlements,” on page 16
 Section 1.3, “Installation Data,” on page 20
 Section 1.4, “License Data,” on page 20
 Section 1.5, “Suites and Software Collections,” on page 21
 Section 1.6, “Version Upgrades,” on page 21

1.1 License Compliance Components
To know whether or not a software product’s deployment within your organization complies with 
your software product license records, you must reconcile three important pieces of information 
about the product: 

 Entitlement: The rights to the software product, including how, where, and how long the 
product can be used. Can the user use the product only on the OEM machine with which it 
came? Can the user install the product on multiple machines under one license? Does each 
installation of the product require a license? Can the product be used forever, or does it have an 
expiration date? This information is contained in the software product’s license agreement or in 
a software purchase contract.

 Licenses: The number of licenses of the software product that your organization has purchased. 
Typically, this information comes from purchase records provided by the software vendor.

 Installations: The actual number of installations of the software product in your organization. 
ZENworks Asset Inventory can provide this information by scanning the devices in your 
organization (as long as the devices are registered in your ZENworks Management Zone). Or, 
you can manually provide this information.

The following illustration shows the components that Asset Management uses to bring your product 
information together: 
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Figure 1-1   Compliance Components

Licensed Product: A licensed product is the software product whose license compliance status you 
want to monitor. The information (entitlements, installations, and purchased licenses) needed to 
determine the compliance status is provided through the licensed product’s components 
(entitlements, discovered products, catalog products, and purchase records).

A licensed product can be version independent (such as Product A) to cover multiple versions, or it 
can be version-specific (such as Product B Version 11).

License Entitlement: More than likely, not all of your purchases of a software product fall under the 
same license agreement. Some agreements might specify different license types (full, upgrade, and so 
forth), some might specify different license models (per-user, per-installation, OEM, and so forth), or 
some might have different license periods (perpetual or fixed-term).

Catalog Products

Product A (OEM)
  • 8 Licenses

Purchase Record

Product A (OEM)
  • 5 Licenses

Purchase Record

Product A (10-Pack)
  • 10 Licenses

Discovered Products

Product A 
  • 25 Installations
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Per–User
Any Users
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Compliance Status: Over–Compliant
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Catalog Products
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Product A (5-Pack)
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Purchase Record
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Product A 
  • 25 Installations
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Each different license agreement for the software product must be represented by a unique license 
entitlement. A license entitlement defines the agreement details such as the license type, license 
model, and license period. In addition, a license entitlement includes the number of product 
installations, the number of purchased licenses, and the users and devices whose product 
installations can be covered by the entitlement. Based on the entitlement details and the available 
licenses, consumed licenses (from installations), and coverage information, Asset Management 
determines the licensed product’s compliance status.

In the example, Product A has two entitlements representing two license agreements with different 
license models:

 An OEM license agreement. The installations of the product on the covered OEM machines (M1, 
M2, M3, M4, and M5) are tracked against the OEM entitlement to monitor compliance with the 
OEM license agreement. 

 A Per-User license agreement. All other installations are tracked against the Per-User 
entitlement to monitor compliance with that agreement.

More information about entitlements is included in Section 1.2, “Entitlements,” on page 16.

Catalog Products: A catalog product identifies a software product for which you’ve purchased 
licenses. When added to an entitlement, a catalog product’s licenses become available for 
consumption by the entitlement’s installations.

Typically, a catalog product corresponds to a specific product part number. For example, when you 
purchase a single copy, a 10-pack, and a 100-pack of the same software product, each has a different 
product part number. As a result, each is a separate catalog product. Likewise, if you purchase two 
10-packs of the same software product, one a full license pack and the other an upgrade license pack, 
each of these is a separate catalog product.

As a result, a single software product might have multiple catalog products. This allows you to 
assign the appropriate catalog products to the appropriate entitlements. In the example, the catalog 
products that represent non-OEM versions of Product A are associated with the Product A Per-User 
entitlement, resulting in 25 available licenses. The Product A OEM catalog product is associated with 
the Product A OEM entitlement, resulting in 5 available licenses.

More information about catalog products is found in Section 1.4, “License Data,” on page 20.

Purchase Records: A purchase record provides details about the number of licenses purchased for a 
software product. The licenses roll up to the catalog product that represents the purchased software 
product.

When you purchase a software product over time, you end up with multiple purchase records for the 
same software product. In this case, the software product’s licenses (included in each purchase 
record) roll up to the same catalog product. In the example, Product A (10-Pack) was purchased at 
two different times; however, the licenses from both purchase records are rolled into the Product A 
(10-Pack) catalog product.

If you have electronic purchase record files, you can import the purchase records. When you import a 
purchase record file, Asset Management creates catalog products for the software products included 
in the file. If you do not have purchase record files, you must manually enter the purchase records 
and manually create the catalog products.

If you do not have purchase records that include detailed software purchase information, you can   
create purchase summary records to represent the purchased licenses. To provide proof of purchases, 
you can attach supporting documents to the purchase summary records.

More information about purchase records is found in Section 1.4, “License Data,” on page 20.
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Discovered Products: A discovered product represents a software product installed in your 
Management Zone. When associated with an entitlement, the discovered product’s installations are 
eligible to consume the entitlement’s licenses.

If a discovered product’s installations can be covered by different entitlements (for the same licensed 
product), you can assign the discovered product to each entitlement. Based on the entitlements’ 
license models and coverage, the Asset Management compliance engine determines which 
entitlement covers each installation.

In the example, Product A (the discovered product) is associated with both entitlements. Five of the 
installations (on M1, M2, M3, M4, and M5) consume licenses in the Product A OEM entitlement. The 
other 20 installations consume licenses in the Product A Per-User entitlement.

More information about discovered products is found in Section 1.3, “Installation Data,” on page 20.

1.2 Entitlements
As explained in Section 1.1, “License Compliance Components,” on page 13, license entitlements are 
one of the three pieces of information that you need to understand and manage to effectively 
maintain license compliance for a software product. The following sections explain concepts that 
apply to entitlements:

 Section 1.2.1, “Entitlement Types,” on page 16
 Section 1.2.2, “License Models,” on page 17
 Section 1.2.3, “User Sources for User-Based License Models,” on page 19
 Section 1.2.4, “License Periods,” on page 19
 Section 1.2.5, “Compliance Calculations for Multiple Entitlements,” on page 19

1.2.1 Entitlement Types

When you create an entitlement, you specify the entitlement type. There are three different types of 
entitlements:

 Full License: Represents a license agreement that gives users the right to install the product 
without owning a previous version.

 License/Maintenance: Represents a license agreement that gives users full license rights to the 
purchased version and subsequent maintenance versions.

 Version Upgrade: Represents a license agreement that gives users rights to upgrade a previous 
product version to the new version. A Version Upgrade entitlement references a base 
entitlement to automatically adjust available licenses between itself and the base entitlement. 
More information about Version Upgrade entitlements is provided in Section 1.6, “Version 
Upgrades,” on page 21.
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1.2.2 License Models

When you create an entitlement, you specify the license model for the entitlement. The entitlement’s 
license model determines 1) how license consumption is calculated and 2) which product 
installations can be covered by the entitlement.

There are different license models for entitlements that use Inventory installation data and for 
entitlements that use manually-entered installation data. 

 “License Models for Inventory Entitlements” on page 17
 “License Models for Manual Entitlements” on page 18

License Models for Inventory Entitlements

The Inventory data for a discovered product includes information about the devices on which the 
product is installed and the primary users associated with those devices. This installation-to-device-
to-user association supports the following device-based and user-based license models:

Table 1-1   License Models for Inventory Entitlements

License Model License Consumption Coverage Example

Per-Installation Each installation of the 
entitlement’s discovered 
products consumes a 
license.

All devices. 20 users have the product installed 
on one device each. An additional 5 
users each have the product 
installed on two devices. There are 
30 total installations, and each 
installation consumes a license.

OEM A covered device 
consumes a license 
whether or not any of 
the entitlement’s 
discovered products are 
installed on the device.

Only the devices you 
specify as covered 
devices.

You specify 15 devices as covered 
devices. The product is installed on 
only 12 of the devices because 
three users have uninstalled the 
product. Even though there are 12 
total installations, all 15 covered 
devices consume a license.

Machine A covered device 
consumes a license only 
if one or more of the 
entitlement’s discovered 
products are installed on 
the device.

Only the devices you 
specify as covered 
devices.

You specify 15 devices as covered 
devices. The product is installed on 
only 12 of the devices. Even though 
you specified 15 covered devices, 
there are 12 total installations, so 12 
covered devices consume a license.

Per-User Each user consumes a 
single license for any 
installations of the 
entitlement’s discovered 
products, regardless of 
the number of 
installations.    

All users. You can exclude 
specific users.

The entitlement includes two 
discovered products (DP1 and 
DP2). Both products are installed on 
User1’s device. User1 consumes 
one license.

Or, DP1 is installed on one of 
User1’s devices and DP1 and DP2 
are installed on another of User1’s 
devices, User1 still consumes only 
one of the entitlement’s licenses.
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License Models for Manual Entitlements

When you manually enter installation data (rather than use the Inventory data), no device or user 
information is associated with the installations. Because of this, entitlements with manual data source 
support only installation-based license models. You provide the total installation quantity, and that 
quantity consumes any of the entitlement’s available licenses.

There are several predefined license models for manual entitlements. These license models are 
intended to match the license models most commonly used in license agreements. If your license 
model is not represented, you can define it.

Table 1-2   License Models for Manual Entitlements

Per-Named User Each covered user 
consumes a single 
license for any 
installations of the 
entitlement’s discovered 
products, regardless of 
the number of 
installations.    

Only the users you specify 
as covered users.

Same as the Per-User model.

License Model License Consumption Coverage Example

Unrestricted

Qualified Desktop

CPU

User

Named User

Server

CAL

Site

Enterprise

Each installation 
consumes a license.

The specified 
installation 
quantity.

Example 1: 20 users have the product 
installed. The license agreement specifies a 
User license model. You select User as the 
entitlement’s license model and enter 20 total 
installations to cover the product installations. 
The 20 installations consume any licenses 
associated with the entitlement.

Example 2: 15 servers have a server product 
installed. The license agreement specifies a 
Server license model. You select Server as 
the entitlement’s license model and enter 15 
total installations to cover the product 
installations. The 15 installations consume 
any licenses associated with the entitlement.

License Model License Consumption Coverage Example
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1.2.3 User Sources for User-Based License Models

Discovered product installations are associated with devices. For example, if a discovered product is 
found on two devices, both devices are recorded in the discovered product’s information. This 
installation-to-device association enables the use of device-based license models (Per-Installation, 
OEM, and Machine). 

To enable user-based license models (Per-User and Per-Named User), Asset Management uses an 
installation-to-device-to-user association. This means that each device must have a user associated 
with it. There are two different user sources that can provide this association. You must choose one or 
the other:

 Inventory User Data: Each device’s Inventory data includes a user field. Asset Inventory does 
not automatically populate the field. There are three ways that you can populate the user 
information: 1) collect the information from users through an automated Inventory Collection 
Data form, 2) manually enter the user information by editing a device’s Inventory data in 
ZENworks Control Center, or 3) migrate Inventory data from ZENworks 7.5 Asset Management.

 Authoritative User Source: This is the LDAP directory (or directories) your ZENworks 
Management Zone connects to for user information. By default, the ZENworks system is 
configured to automatically assign users from this source as primary users on devices. If a 
device has multiple users, the primary user is determined by a calculation method that you can 
select (usage based, login based, or direct assignment).

Both options work equally well. The Authoritative User Source method provides greater automation 
because you don’t need to manually enter user information, migrate information, or rely on users to 
complete the automated collection form. 

If you are using Asset Management with ZENworks 7 Desktop Management, you must use the 
Inventory User Data method. The ZENworks Adaptive Agent’s User Management feature, which is 
required with the Authoritative User Source method, cannot coexist on the same device with the 
ZENworks 7 Desktop Management Agent. Installing the User Management feature automatically 
uninstalls the Desktop Management Agent. 

1.2.4 License Periods

License agreements (or contracts) might stipulate a period of time during which the product can be 
used. When you create an entitlement, you specify whether the license period is perpetual (never 
ending) or fixed term. With fixed term, you specify the start date and end date.

1.2.5 Compliance Calculations for Multiple Entitlements

It is common for a licensed product to have multiple entitlements that share the same discovered 
product. When this happens, the Software Compliance Engine must determine how the discovered 
product’s installations are allocated among the entitlements.

The Software Compliance Engine processes the entitlements with the most restrictive license models 
first. The most restrictive entitlements have fewer installations that meet the restrictions. By 
processing them first, the greatest number of installations can be processed against the entitlements, 
increasing the likelihood that the entitlement’s licenses are consumed.

Entitlements are processed in the following order (most restrictive to least restrictive):

1. OEM: Covers an installation only if it is on a specified device.
2. Machine: Covers an installation only if it is on a specified device.
3. Named User: Covers an installation only if it is associated with a specified user.
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4. Per User (with Installations > 1): Covers an installation only if it is associated with a user that 
has the product installed at least twice.

5. Per Installation: Covers an installation on any device.
6. Per User (with Installations = 1): Covers an installation associated with any user. 
7. Manual: Covers the manually specified number of installations.

If, after processing all of a licensed product’s entitlements, there are discovered product installations 
that have not been consumed by a entitlement, the Software Compliance Engine reports the licensed 
product as undercompliant (more installations than licenses). Each unconsumed installation is also 
reported as an unresolved installation on the licensed product’s Compliance Status page. 

1.3 Installation Data
As explained in Section 1.1, “License Compliance Components,” on page 13, the number of 
installations of a product is one of the three primary pieces of information that is required to 
determine the product’s license compliance. Your installation data can come from two different 
sources:

 Inventory Data: Asset Inventory scans the devices in your ZENworks Management Zone and 
saves the installed software product information to the ZENworks database. Asset Management 
maps the installation information to discovered products. When a discovered product is 
associated with an entitlement, the discovered product’s installations are eligible to consume one 
of the entitlement’s licenses.

Using Inventory to provide the installation data is the recommended approach because it is the 
most automated. If a product is installed or uninstalled on a device, the change is automatically 
reflected in the data (and the corresponding discovered product) after the next Inventory scan. 
In addition, using Inventory data provides the ability to use both device-based and user-based 
license models (see “License Models for Inventory Entitlements” on page 17).

 Manual Data: You manually edit an entitlement (in ZENworks Control Center) to provide the 
number of product installations. This requires you to know how many devices have the product 
installed, and to change the number whenever installations are added or removed. In addition, 
you are limited to using only installation-based license models; device-based and user-based 
license models are not available (see “License Models for Manual Entitlements” on page 18).

An entitlement can use only one source for its installation data. However, a licensed product can 
include multiple entitlements, with some entitlements drawing installation data from Inventory data 
and other entitlements using manual data. 

1.4 License Data
As explained in Section 1.1, “License Compliance Components,” on page 13, the number of 
purchased licenses is one of the three primary pieces of information that is required to determine the 
product’s license compliance. You license data can come from two different sources:

 Catalog Products and Purchase Records: A catalog product identifies a software product for 
which you have purchased licenses. When added to an entitlement, a catalog product’s licenses 
become available for consumption by the entitlement’s installations.

A catalog product’s licenses come from purchase records for the software product. If multiple 
purchase records include license purchases for the software product, all licenses are rolled up to 
the catalog product.
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Using catalog products and purchase records as the data source for your purchased licenses is 
the recommended method. Each time you add a purchase record for the software product, the 
catalog product’s available license quantity is automatically increased by the number of new 
licenses. 

 Purchase Summary Records: A purchase summary record lets you directly enter a license 
quantity on an entitlement. The summary record includes the product’s description, cost, and 
license quantity. The disadvantage to using a purchase record summary is that it doesn’t enable 
you to track the product licenses through a catalog product and a purchase record. 

An entitlement can use one or both sources for its available licenses.

1.5 Suites and Software Collections
In addition to standalone products, Asset Management can maintain license compliance for suite 
products such as Microsoft Office and OpenOffice.org. Suites are included as discovered products in 
the ZENworks Knowledgebase. A suite discovered product includes information about the suite 
members.

When an Inventory scan discovers a suite installed on a device (for example, through the registry 
settings), the installation is counted toward the suite’s installation total rather than the suite 
members’ installation totals. For example, if Microsoft Word, Microsoft Excel, and Microsoft 
PowerPoint are installed as a Microsoft Office suite on a device, the installation is applied to the 
Microsoft Office discovered product and not the Word, Excel, and PowerPoint discovered products. 
However, if these applications are discovered as standalone products (no Microsoft Office 
installation), the installation is applied to each individual discovered products.

Software collections are administrator-defined suites. You can use them to account for suites that are 
not included in the ZENworks Knowledgebase. With a software collection, you define the member 
products and specify which member products must be installed on a device to qualify as a software 
collection installation. If all required member products are installed on a device, the installation 
counts towards the software collection. If some required member products are missing, the member 
product installations count towards the individual discovered products.

1.6 Version Upgrades
A typical license agreement for a software version upgrade stipulates that you replace installations of 
the base product with the upgrade product. In other words, the license entitlement (usage, quantity, 
and so forth) is transferred from the base product to the upgrade product.

For example, if you purchase 10 licenses of the base product and then purchase 6 licenses of the 
upgrade product, you are entitled to 4 installations of the base product and 6 installations of the 
upgrade product. The total number of installations (10) you are entitled to remains the same.

To account for version upgrades, Asset Management provides a type of entitlement called a Version 
Upgrade. With a Version Upgrade entitlement, you specify a base entitlement for the upgrade. The 
following applies to the base entitlement:

 It must belong to the same licensed product as the upgrade entitlement. In other words, you 
can’t create an Upgrade Version entitlement in LicensedProduct1 and use a base entitlement 
from LicensedProduct2.
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 It can be any of the three entitlement types: Full License, License/Maintenance, or Version 
Upgrade. This supports upgrades of upgrades.

 It can support multiple Version Upgrade entitlements. For example, EntitlementA can be the 
base entitlement for VersionUpgradeEntitlement1 and VersionUpgradeEntitlement2.

When a licensed product contains a Version Upgrade entitlement, the Software Compliance Engine 
calculates the available license quantity for the Version Upgrade entitlement and subtracts that 
license quantity from the base entitlement.
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2 2Setting Up License Compliance

The following sections provide instructions to help you set up license compliance for your software 
products:

 Section 2.1, “Preparing Your Management Zone,” on page 23
 Section 2.2, “Setting Up Compliance for Software Products,” on page 24
 Section 2.3, “Monitoring Compliance,” on page 26

If you have not already done so, review the concepts in Chapter 1, “License Compliance Concepts,” 
on page 13 before beginning. In particular, make sure you understand the components introduced in 
Section 1.1, “License Compliance Components,” on page 13. 

2.1 Preparing Your Management Zone
Before you can begin setting up compliance for your software products, you need to prepare your 
ZENworks Management Zone. This includes configuring several Management Zone settings, 
discovering software products that are installed on devices in your Management Zone, and 
populating your Management Zone with software purchase information.

The following table explains the tasks you need to complete and where you can find specific 
instructions to help you complete them.

Table 2-1   Management Zone Preparation Tasks

Task Details

Configure ZENworks 
Management Zone settings

There are two ZENworks Management Zone settings related to license 
compliance. One setting determines when the compliance engine runs 
each day and the other setting determines the user source (authoritative 
user source or Inventory user data) for user-based license models.

For instructions, see Chapter 3, “Configuring Compliance Settings,” on 
page 27.
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2.2 Setting Up Compliance for Software Products
The following table explains the tasks you need to complete to configure software products for 
license compliance.

These tasks assume that you’ve already completed the tasks in Section 2.1, “Preparing Your 
Management Zone,” on page 23 to populate your ZENworks Management Zone with discovered 
products and catalog products. 

Table 2-2   Compliance Setup Tasks

Discover installed software 
products

Asset Management needs to know what software products are installed 
in your organization and how many installations exist for each product.

Asset Inventory provides this information by scanning the devices in your 
ZENworks Management Zone to discover installed software products. 
Asset Management then filters the installed products through the Asset 
Management Knowledgebase to consolidate and combine the installed 
products into the list of discovered products used with license 
compliance. 

If you have not performed a software inventory scan of the devices in 
your zone, or if the software inventory data has not been updated 
recently, you must scan the devices to create a list of discovered 
products. You cannot manually create discovered products.

For instructions, see the ZENworks 11 SP3 Asset Inventory Reference.

Record software purchase 
information

Asset Management needs to know what software products you’ve 
purchased and how many licenses you’ve purchased for each product.

You enter this information into the Asset Management system as 
purchase records and catalog products. 

For instructions, see Section 9.4, “Creating Purchase Records,” on 
page 83.

Task Details

Task Details

Create licensed products A licensed product represents a software product whose license 
compliance you want to monitor. All of the information needed to 
determine a licensed product’s compliance status (installations, 
purchased licenses, license usage agreements) is provided through the 
components associated with the licensed product

For instructions, see Section 6.5, “Creating a Licensed Product,” on 
page 43.
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Create entitlements A license entitlement typically represents a license agreement for a 
licensed product. It includes such agreement details as the license type 
(full, upgrade, maintenance, and so forth) and the license model (per-
user, per-installation, OEM, machine, and so forth). Based on the license 
model, it also specifies which users or machines are covered by the 
entitlement.

Some licensed products might have only one entitlement. For example, 
you might have a product whose installations all fall under a full license, 
per-installation agreement.

Other products, however, might have multiple entitlements. For example, 
you might have a product for which you have OEM-licensed installations 
and per-user licensed installations. To correctly cover both license 
agreements, you need two entitlements with different license models and 
user/machine coverage. A second example might be a product that 
includes a full license agreement and a version upgrade agreement.

If you used the Auto-Reconcile Wizard to create licensed products, an 
entitlement was created for each licensed product. If any of the licensed 
products require additional entitlements, you can add them at this time. If 
you manually created licensed products, they do not yet have 
entitlements; you must create them. 

For instructions, see Section 7.2, “Creating an Entitlement,” on page 52.

Add catalog products

or

Add purchase summary 
records

To populate a licensed product with the number of licenses you have 
purchased for the product, you add catalog products to the licensed 
product’s entitlements.

If you used the Auto-Reconcile Wizard to create licensed products, 
catalog products might already have been added to some of the licensed 
products. If any licensed products require additional catalog products, 
you can add them at this time. For instructions, see Section 7.3, “Adding 
Catalog Products,” on page 57.

If you don’t have a catalog product to assign to a licensed product, you 
can use purchase summary records to add licenses to the licensed 
product. For instructions, see Section 7.4, “Adding Purchase Summary 
Records,” on page 58.

Add discovered products If a licensed product you created includes an Inventory entitlement (an 
entitlement that draws its installation counts from Inventory data), you 
need to add discovered products to the entitlement. The discovered 
products associate the appropriate software product installations with the 
licensed product, Per-User, Per-Named User, OEM, Machine, and Per-
Installation are the Inventory entitlements.

For instructions, see Section 7.5, “Adding Discovered Products,” on 
page 59.

Specify users and devices 
covered by the entitlement

If you created an entitlement that uses an OEM, Machine, Per-Named 
User, or Per-User license model, you must specify with devices or users 
are covered by the entitlement.

For instructions, see Section 7.6, “Specifying User and Device 
Coverage,” on page 61.

Task Details
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2.3 Monitoring Compliance
The following table explains how you can monitor a product’s compliance status.

Table 2-3   Compliance Monitoring Tasks

Task Details

View compliance status in 
ZENworks Control Center

 ZENworks Control Center provides both high-level and detailed views of 
a product’s compliance status. The high-level views let you see if a 
product is compliant, undercompliant, or overcompliant. The detailed 
views let you see why a product’s compliance status is what it is.

For instructions, see Chapter 4, “Monitoring Compliance Status,” on 
page 29.

Generate compliance reports You can generate reports that show the compliance status for all 
products or only the products that have a specific compliance status. You 
can also generate reports that help you manage your discovered 
products, catalog products, and purchase records.

For instructions, see Chapter 5, “Generating Compliance Reports,” on 
page 37.
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3 3Configuring Compliance Settings

There are two ZENworks Management Zone settings related to license compliance. One setting 
determines when the compliance engine runs each day and the other setting determines the user 
source (authoritative user source or Inventory user data) for user-based license models.

To configure the settings:

1 In ZENworks Control Center, click the Configuration tab.
2 In the Management Zone Settings panel, click Asset Management to display the settings.
3 Configure the Compliance setting:

3a Click Compliance.
3b Select the time you want the compliance engine to run each day.

The compliance engine refreshes the compliance data and status for each licensed product. 
The default run time is 11:00 pm each day. 

3c Click OK.
4 Configure the User Source setting:

To support user-based license models (Per-User and Per-Named User), Asset Management 
requires an installation-to-device-to-user association so that any product installations on a 
device can be assigned to the device’s user. The installation-to-device association is created 
through Inventory scans. There are two different user sources that can be used to provide the 
device-to-user association.
4a Click User Source, then select one of the following user sources:

 Inventory user data: Each device’s Inventory data includes an Entered User field that 
associates a user to the device (Device tab > device > Inventory page > Detailed Hardware/
Software Inventory link > Entered User field).
Asset Inventory does not automatically populate the Entered User field. If you use this 
source, make sure that each device has an Entered User. There are three ways that you 
can populate the user information: 1) collect the information from users through an 
automated Inventory Collection Data form, 2) manually enter the user information by 
editing a device’s Inventory data in ZENworks Control Center, or 3) migrate Inventory 
data from ZENworks 7.5 Asset Management.

 Authoritative user source: This is the LDAP directory (or directories) your ZENworks 
Management Zone connects to for user information. By default, the ZENworks system 
is configured to automatically assign users from this source as primary users on 
devices. If a device has multiple users, the primary user is determined by a calculation 
method that you can select (usage based, login based, or direct assignment).

You can use only one source at a time. If you change the source, all existing assignments of 
licenses to users are removed.

IMPORTANT: If you are using ZENworks 7 Desktop Management with ZENworks 11 SP3 
Asset Management on the same devices, use the Inventory user data option instead of the 
Authoritative user source option. The Authoritative user source option requires the ZENworks 
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11 SP3 Adaptive Agent User Management feature to be installed. However, the User 
Management feature cannot coexist with the ZENworks 7 Desktop Management Agent, 
which results in the ZENworks 7 Desktop Management Agent being uninstalled. 

4b Click OK. 
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4 4Monitoring Compliance Status

There a multiple locations in ZENworks Control Center where you can view the compliance status of 
licensed products.

 Section 4.1, “Home Page,” on page 29
 Section 4.2, “Licensed Products List,” on page 29
 Section 4.3, “Licensed Product’s Compliance Status Page,” on page 30

4.1 Home Page
The Asset Management panel on the Home page lists the total number of properly licensed products 
( ), underlicensed products ( ), and overlicensed products ( ). You can click a status to view the 
licensed products with that status.

4.2 Licensed Products List
The Licensed Products list (Asset Management tab > License Management tab > Licensed Products) 
displays whether a product is properly licensed ( ), underlicensed ( ), or overlicensed ( ).
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You can click a licensed product to display details about the compliance status (see Section 4.3, 
“Licensed Product’s Compliance Status Page,” on page 30). You can also use the Search filter to 
display only the licensed products with a specific status. 

4.3 Licensed Product’s Compliance Status Page
A licensed product’s compliance status is determined by the compliance status of each of its 
entitlements. For example, three entitlements might be properly licensed and one entitlement 
underlicensed. The licensed product’s status shows as underlicensed.

A licensed product’s Compliance Status page shows details about the license compliance status for 
each entitlement. If the licensed product is non-compliant, you can use the details to understand 
what needs to be done to make it compliant.

To access a licensed product’s Compliance Status page:

1 In ZENworks Control Center, click the Asset Management tab.
2 In the License Management tab, click Licensed Products.

3 Click the licensed product.
4 Click the Compliance Status tab.
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The Compliance Status page includes the following panels:
 License Consumption (Consumption Data Source: Inventory):  Displays the installation 

data for discovered products associated with this licensed product.
The Net Consumption field provides the total number of installations for a discovered 
product. It is determined by the following formula: Net Consumption = (Installed Quantity + 
Additional Consumption) - Ignored Installations. Installed Quantity is the number of 
installations discovered by Inventory scans. Additional Consumption and Ignored 
Installations are manual adjustments that can be made by editing the discovered product’s 
details.

 Compliance Status (Consumption Data Source: Inventory): Displays the compliance 
status for all entitlements that use Inventory installation data.

 Unresolved Installations: Displays any discovered products with installations that are not 
covered by an entitlement. This panel is displayed only when there are unresolved 
installations.

 Compliance Status (Consumption Data Source: Manual): Displays the compliance status 
for all entitlements that use manually entered installation data.

4.3.1 License Consumption (Consumption Data Source: Inventory)

This panel displays the installation data for discovered products associated with this licensed 
product.
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For license compliance, the following fields are important:

 Net Consumption: Provides the total number of installations for a discovered product. All of 
these installations must be covered by the entitlements in order for the licensed product to be 
compliant. The net consumption is determined by the following formula:

Net Consumption = (Installed Quantity + Additional Consumption) - Ignored Installations.

Click the consumption number to view the discovered product’s Installations/Consumptions 
page. This page provides details for the installation and consumption data and lets you ignore 
installations and specify additional consumption.

 Installed Quantity: Displays the number of installations discovered by Inventory scans.
 Additional Consumption: Displays the number of extra installations that are included in the 

compliance calculations. This is a manual adjustment that you can make if there are installations 
that were not found by Inventory scans that you want included in the net consumption. For 
instructions, see Section 8.8, “Adjusting a Discovered Product’s Installation Count,” on page 74.

 Ignored Installations: Displays the number of installations that are excluded from the 
compliance calculations. This is a manual adjustment that you can make if there are installations 
you don’t want included in the net consumption. For instructions, see Section 8.8, “Adjusting a 
Discovered Product’s Installation Count,” on page 74.

4.3.2 Compliance Status (Consumption Data Source: Inventory)

This panel displays the compliance status for all entitlements that use Inventory installation data.

For license compliance, the following fields are important:

 Installations Covered: Displays the number of installations covered by the entitlement. 

For Machine, OEM, and Per-Installation entitlements, each installation consumes a license. 
Therefore, for these entitlements, the number of covered installations equals the number of 
consumed licenses.

For Per-User and Per-Named User entitlements, a user consumes one license regardless of the 
number of installations associated with the user. A user might have installations on five devices, 
but only one license is consumed. Therefore, for these entitlements, the number of covered 
installations can be greater than the number of consumed licenses.

The total Installations Covered (for all entitlements) should equal the total Net Consumption in 
the License Consumption (Consumption Data Source: Inventory) panel. If it does not, some 
discovered product installations are not being covered by an entitlement. These installations are 
listed in the Unresolved Installations panel.

 License Quantity: Displays the number of licenses included in the entitlement, either through 
catalog products assigned to the entitlement or purchase summary records created for the 
entitlement.

 Licenses Consumed: Displays the number of licenses consumed by the covered installations.
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 Over/Under: Displays the license compliance status. 0 indicates that the consumed licenses 
(Licenses Consumed) equal the number of available licenses (License Quantity). A negative 
number indicates that consumed licenses exceed the number of available licenses 
(undercompliant). A positive number indicates that available licenses exceed the consumed 
licenses (overcompliant).
If there are multiple entitlements, the licensed product’s overall compliance status is determined 
as follows: 
 If any entitlement is undercompliant, the licensed product is assigned an undercompliant 

status ( ).
 If no entitlements are undercompliant but an entitlement is overcompliant, the licensed 

product is assigned an overcompliant status ( ).

 If all entitlements are compliant, the licensed product is assigned a compliant status ( ).

4.3.3 Unresolved Installations

This panel lists any discovered products with installations that are unable to consume an 
entitlement’s license.

The following information is provided for each unresolved installation:

 Discovered Product: The discovered product that has unresolved installations. You can click the 
discovered product to view its details.

 Licenses Consumed: The number of installations that are unable to consume a license from one 
of the entitlements. You can click the number to view a list of the devices associated with the 
unresolved installations. 

Unresolved installations can be caused by a variety of reasons. The following sections provide 
examples and solutions for unresolved installations.

Example 1

Product A includes the following two entitlements: 

An Inventory scan discovers installations of Version 6 on the machines of User 1, User 2, and User 4. 
The installation on User 4’s machine is not covered by the Version 6 entitlement (because User 4 is not 
one of the named users) and it is not covered by the Version 7 entitlement (because it is the wrong 
version). Therefore, Product A has one unresolved installation of Version 6 because the installation 
cannot consume licenses from either of the entitlements.

Entitlement License Model License 
Quantity

Discovered Products Coverage

Version 6 Per-Named User 3 Product A Version 6 User 1, User 2, User 3

Version 7 OEM 5 Product A Version 7 Machine 1, Machine 2, Machine 
3, Machine 4, Machine 5
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There are several solutions to this situation, including the following:

 Modify the Version 6 entitlement so that it covers User 4.
 Create a Per-Installation entitlement that also covers Product A Version 6. User-based 

entitlements (Per-User and Per-Named User) and machine-based entitlements (OEM and 
Machine) are evaluated first, then any Per-Installation entitlements are checked. In this situation, 
the installation would be covered by the Per-Installation entitlement.

Example 2

Product A includes the following entitlements:

An Inventory scan discovers 26 installations of Version 6. The 26 installations belong to 22 users; 21 
users are associated with one installation each, and 1 user is associated with 5 installations. 

All 15 Per-User licenses are consumed, accounting for 19 of the installations (1 user with 5 
installations and 14 users with 1 installation). The installations for users 16 through 22 cannot 
consume a license because there are no more licenses available, so the remaining 7 installations 
associated with those users fall through to the All entitlement. Because the All entitlement’s licenses 
also cover Product A Version 6, the installations consume 7 of the 40 licenses for that entitlement.

If the All entitlement did not exist, the 7 installations would remain unresolved and Version 6 would 
be listed in the Unresolved Installations panel.

There are several solutions to this situation, including the following:

 Add 7 additional licenses to the Version 6 entitlement to cover the installations. 
 Create a Per-Installation entitlement that also covers Product A Version 6. User-based 

entitlements (Per-User and Per-Named User) and machine-based entitlements (OEM and 
Machine) are evaluated first, then any Per-Installation entitlements are checked. In this situation, 
the installation would be covered by the Per-Installation entitlement.

Example 3

Product A includes the following entitlement:

An Inventory scan discovers 5 installations of Product A Version 6 on Machine1 through Machine5. 
The installations on Machine4 and Machine5 are reported as unresolved installations because the two 
machines are not covered by the Version 6 entitlement.

Entitlement License Model
License 
Quantity Discovered Products Coverage

Version 6 Per-User 15 Product A Version 6 Any users

All Per-Installation 40 Product A Version 6

Product A Version 7

Any installation

Entitlement License Model License 
Quantity

Discovered Products Coverage

Version 6 Machine 10 Product A Version 6 Machine1, Machine2, Machine3
34 ZENworks 11 SP3 Asset Management Reference



There are several solutions to this situation, including the following:

 Modify the Version 6 entitlement so that it covers Machine4 and Machine5. 
 Create a Per-Installation entitlement that also covers Product A Version 6. Machine-based 

entitlements (OEM and Machine) and user-based entitlements (Per-User and Per-Named User) 
are evaluated first, then any Per-Installation entitlements are checked. In this situation, the two 
installations would be covered by the Per-Installation entitlement.

4.3.4 Compliance Status (Consumption Data Source: Manual)

This panel displays the compliance status for all entitlements that use manually-entered installation 
data.

For license compliance, the following fields are important:

 License Quantity: Displays the number of licenses included in the entitlement, either through 
catalog products assigned to the entitlement or through purchase summary records created for 
the entitlement.

 Licenses Consumed: Displays the number of the entitlement’s licenses that have been 
consumed. This number comes from the Quantity Consumed number assigned to the 
entitlement (entitlement > General tab > Quantity Consumed).

 Over/Under: Displays the license compliance status. 0 indicates that the consumed licenses 
(Licenses Consumed) equal the number of available licenses (License Quantity). A negative number 
indicates that consumed licenses exceed the number of available licenses (undercompliant). A 
positive number indicates that available licenses exceed the consumed licenses (overcompliant).
If there are multiple entitlements, the licensed product’s overall compliance status is determined 
as follows: 
 If any entitlement is undercompliant, the licensed product is assigned an undercompliant 

status ( ).
 If no entitlements are undercompliant but an entitlement is overcompliant, the licensed 

product is assigned an overcompliant status ( ).

 If all entitlements are compliant, the licensed product is assigned a compliant status ( ).
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5 5Generating Compliance Reports

ZENworks Asset Management includes a variety of reports that you can generate to view compliance 
and compliance-related data. In addition to viewing predefined reports, you can create custom 
reports and export reports to several file formats.

The compliance report information is combined with the software usage and contract management 
report information in Part VI, “Reports,” on page 179. The following list provides direct links to 
compliance report sections:

 Descriptions for all standard and custom reports: Chapter 29, “Standard and Custom Report 
Descriptions,” on page 181.

 How to run standard reports: Chapter 32, “Working with Standard Reports,” on page 191.
 How to create and generate custom reports: Chapter 33, “Working with Custom Reports,” on 

page 195
Generating Compliance Reports 37



38 ZENworks 11 SP3 Asset Management Reference



6 6Working with Licensed Products

A licensed product represents a software product whose license compliance you want to monitor. All 
of the information needed to determine a licensed product’s compliance status (installations, 
purchased licenses, license usage agreements) is provided through the components associated with 
the licensed product (see Section 1.1, “License Compliance Components,” on page 13).

The following sections explain the tasks associated with managing licensed products:

 Section 6.1, “Viewing the Licensed Products List,” on page 39
 Section 6.2, “Filtering the Licensed Products List,” on page 40
 Section 6.3, “Creating a Licensed Product Folder,” on page 41
 Section 6.4, “Refreshing Compliance Status,” on page 41
 Section 6.5, “Creating a Licensed Product,” on page 43
 Section 6.6, “Changing a Licensed Product’s General Information,” on page 46
 Section 6.7, “Adding Custom Fields to Licensed Products,” on page 47
 Section 6.8, “Merging Licensed Products,” on page 49
 Section 6.9, “Deleting a Licensed Product,” on page 50
 Section 6.10, “Moving a Licensed Product,” on page 50

6.1 Viewing the Licensed Products List
You can view a list of all of your licensed products. The list provides general information about each 
licensed product, such as its compliance status and whether or not discovered products and catalog 
products are associated with it.

1 In ZENworks Control Center, click the Asset Management tab.
2 In the License Management tab, click Licensed Products.

The list provides the following information for each licensed product:
Name: Displays the name of the licensed product. You can click the name to display the licensed 
product’s details.
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Status: Indicates the product’s license compliance status:

  Properly licensed: The number of licenses match the number of installations.

  overlicensed: There are more licenses than installations.

  underlicensed: There are more installations than licenses.

  Unknown: The compliance status has not been evaluated. If you don’t want to wait for 
the next scheduled compliance status refresh, click Action > Refresh Compliance Status.

Click the status to view detailed compliance status information.
Discovered Products: Indicates that at least one discovered product is associated with the 
licensed product.
Catalog Products: Indicates that at least one catalog product is associated with the licensed 
product.
License Quantity: Displays the number of licenses associated with the licensed product through 
entitlements. Click the quantity number to manage (view, add, or remove) the product’s 
entitlements.
Allocated Quantity: Displays the number of licenses that are allocated, either through 
allocations to specific devices or allocations to a department, site, or cost center. Click the 
number to display the allocation details.

6.2 Filtering the Licensed Products List
You can filter the Licensed Product list to display only the licensed products that meet certain criteria. 

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Licensed Products.

3 In the Search panel (located next to the Licensed Products panel), specify the criteria to use for 
the filter. A product must match all criteria to be displayed.
Name: Specify the text that the licensed product name (or folder name) must include. This is a 
partial match field that is case-insensitive. If the text you enter is included in any part of a 
licensed product name, the product matches the criteria.
Type: Select whether you want to match folders, licensed products, or both.
Manufacturer: Select a specific manufacturer, or select Any to match any manufacturers. 
Reconciliation Status: Select one of the following to match:
 Any: Ignore the reconciliation status. Match any licensed products.
 Without Catalog Products: Match licensed products that don’t have any catalog products, but 

have discovered products.
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 Without Discovered Products: Match licensed products that don’t have any discovered 
products, but have catalog products.

 Without Any Products: Match licensed products that don’t have any catalog products and 
discovered products.

 With Catalog and Discovered Products: Match licensed products that have both catalog 
products and discovered products.

Allocation Status: Select whether to match licensed products with allocations, without 
allocations, or both. 
Compliance Status: Select one of the following to match:
 Any: Ignore the compliance status. Match any licensed products.
 Over: Match licensed products that are overlicensed; there are more licenses than 

installations.
 Under: Match licensed products that are underlicensed; there are more installations than 

licenses. 
 Properly Licensed: Match licensed products that have the same number of licenses and 

installations.
 Not Evaluated: Match licensed products whose compliance status has not been calculated 

yet.
 Evaluated: Match licensed products whose compliance status is calculated (overlicensed, 

underlicensed, or properly licensed). 
Include Subfolders: Select this option to search the current folder and its subfolders.

4 Click Search to apply the search criteria and filter the list.

6.3 Creating a Licensed Product Folder
You can create folders in the Licensed Products list to better organize your licensed products. All 
folders are displayed at the top of the list.

1 In ZENworks Control Center, click Asset Management > License Management > Licensed Products.
2 In the Licensed Products panel, click New > Folder to display the New Folder dialog box.
3 Fill in the following fields:

Name: Specify a name for the folder. The name must be unique among all other folders and 
licensed products at the same level.
Folder: Browse for and select the folder in which to place the new folder.
Description: Specify any optional information to identify the folder.

4 Click OK to create the folder.

6.4 Refreshing Compliance Status
A licensed product’s compliance status can change if new installations are discovered or new licenses 
are purchased. The following sections explain when automatic refreshes occur, how to manually 
trigger a refresh, and how to find out when the last scheduled refresh occurred.

 Section 6.4.1, “Automatically Refreshing Status,” on page 42
 Section 6.4.2, “Manually Triggering a Refresh,” on page 42
 Section 6.4.3, “Viewing Refresh Details,” on page 42
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6.4.1 Automatically Refreshing Status

The compliance status for all licensed products is automatically refreshed at the following times:

 When you import purchase records. This ensures that a product’s compliance status 
immediately reflects any newly purchased licenses.

 Each day at the time specified for the compliance engine’s refresh schedule (see Chapter 3, 
“Configuring Compliance Settings,” on page 27). This ensures that a product’s compliance status 
reflects any changes to the installation count for its discovered products. 

In addition, the compliance status for an individual product is automatically refreshed when the 
following actions occur on the product:

 Creating or deleting an entitlement.
 Adding, modifying, or deleting any entitlement entry that affects license quantity or installation 

quantity. This includes purchase records, purchase record summaries, catalog products, 
discovered products, and software collections.

 Marking a discovered product installation (associated with an entitlement) as ignored.

6.4.2 Manually Triggering a Refresh

You can manually trigger a refresh of the compliance status for all licensed products. You cannot 
manually trigger a refresh of an individual licensed product.

1 In ZENworks Control Center, click Asset Management > License Management to display the 
License Management page.

2 Click Licensed Products to display the Licensed Products page.
A compliance refresh can also be triggered from the Discovered Products page.

3 In the Licensed Products panel, click Actions > Refresh Compliance Status.

6.4.3 Viewing Refresh Details

You can see information about the latest refresh above the menu bar of both the Licensed Products 
page and Discovered Products page. This information includes the following:

 The last time a compliance refresh was started and ended
 What initiated the refresh
 Whether it was a refresh of all products or a single product

The Compliance Status tab of the Licensed Product page also shows the time the license was last 
refreshed. In addition, clicking License Management Reports > Software Compliance > Compliance Report 
displays a column called More Recent Recalc that indicates if a license has been refreshed more 
recently than the last full refresh of all licenses.
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6.5 Creating a Licensed Product
There are two methods you can use to create a licensed product:

 You can manually create a licensed product. You then need to create the licensed product’s 
entitlements and add catalog products and discovered products.

 You can use the Auto-Reconcile Wizard to create a licensed product from a discovered product. 
During the process, you create an entitlement and reconcile any catalog products (identified by 
the wizard as possible matches for the licensed product) to the licensed product. The wizard can 
create multiple licensed products at one time.

Refer to the following sections for instructions:

 Section 6.5.1, “Manually Creating a Licensed Product,” on page 43
 Section 6.5.2, “Creating a Licensed Product from a Discovered Product,” on page 44

6.5.1 Manually Creating a Licensed Product

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Licensed Products.

3 Click New > Licensed Product to launch the Create New Licensed Product Wizard.
4 On the General Information page, fill in the following fields:

Manufacturer (Optional): The manufacturer of the product.
Licensed Product (Required): The name of the product.
Version (Optional): The product version.
Notes (Optional): Specify any notes.

5 Click Next, review the information on the New Licensed Product Summary page, then click 
Finish to add the product to the Licensed Products list.

6 Configure the licensed product by completing these additional tasks:
 Create one or more entitlements. See Section 7.2, “Creating an Entitlement,” on page 52.
 Add catalog products to the entitlements. See Section 7.3, “Adding Catalog Products,” on 

page 57.
 Add discovered products to the entitlements. See Section 7.5, “Adding Discovered 

Products,” on page 59.
 Specify the users or devices covered by the entitlements. See Section 7.6, “Specifying User 

and Device Coverage,” on page 61.
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6.5.2 Creating a Licensed Product from a Discovered Product

The Auto-Reconcile Wizard creates licensed products from discovered products. The wizard does the 
following:

 Lets you select the discovered product from which you want to create a licensed product. You 
can select multiple discovered products at one time to create multiple licensed products.

 Creates a licensed product with the same name as the discovered product.
 Creates an entitlement for the licensed product. You specify the entitlement’s description and 

license model. If you are creating multiple licensed products, the same entitlement (description 
and license model) is created for each product. 

 Adds the discovered product to the entitlement.
 Identifies any catalog products that might match the licensed product. Lets you choose whether 

or not to add the catalog products to the licensed product’s entitlement.

When you run the Auto-Reconcile Wizard, you should select discovered products that require the 
same entitlement license model. As mentioned above, the wizard applies the same entitlement to all 
licensed products created during the process. If you create a licensed product from a discovered 
product that does not fit the entitlement license model, you need to manually edit the licensed 
product’s entitlement and change its license model.

To create licensed products from discovered products:

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Licensed Products.

3 In the Licensed Products panel, click Action > Auto-Reconcile: Create Licensed Products to launch 
the Auto-Reconcile Wizard. Complete the wizard by using information from the following table 
to fill in the fields:
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Wizard Page Details

Discovered Product Filter You can filter the list of discovered products so that you have a smaller 
list of products from which to select.

Any: Select this option to ignore the filter; all discovered products are 
displayed.

Products Specified Below: Select this option to filter the discovered 
products list. Fill in the following fields:

 Manufacturer: Click Select, then select one of the listed 
manufacturers. Or, click Search and specify the text string that will 
display the manufacturers. 

 Product: Specify a text string that will display the products you 
want.

You can use an asterisk (*) as a wildcard. For example, if you want to 
display all discovered products from manufacturers that start with M, 
enter M* in the Manufacturer field and * in the Product field.

Select Licensed Products 
to Create

This page lists all the discovered products that meet the filter criteria 
defined on the previous page. 

The first column displays the name of the licensed product that will be 
created. The second column displays the discovered product that will 
be associated with the licensed product. The third column displays any 
catalog products that the wizard thinks are candidates for association 
with the licensed product. 

By default, all licensed products are selected and will be created. You 
can deselect any licensed products you don’t want created. 

You can also deselect any catalog products that you don’t want 
associated with a licensed product.

Destination Folder Lets you specify where in the Licensed Products folder hierarchy you 
want to place the new licensed products.

The field defaults to the current folder (the folder from which you 
launched the Auto-Reconcile Wizard). To specify another folder, click 

 to browse for and select the folder. The folder must already exist; 
you cannot use the selection dialog box to create a new folder.
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4 If you have not already done so, click Finish to create the licensed products and add them to the 
Licensed Products panel.

5 If necessary, configure the licensed product by completing these additional tasks:
 Specify the users or devices covered by the entitlement. See Section 7.6, “Specifying User 

and Device Coverage,” on page 61.
 Add additional catalog products. See Section 7.3, “Adding Catalog Products,” on page 57.
 Add additional discovered products. See Section 7.5, “Adding Discovered Products,” on 

page 59.
 Create additional entitlements. See Section 7.2, “Creating an Entitlement,” on page 52.

6.6 Changing a Licensed Product’s General Information
A licensed product includes general information such as its manufacturer, product name, and 
version. You can modify this information as necessary. If you’ve created any custom fields (see 
Section 6.7, “Adding Custom Fields to Licensed Products,” on page 47), you can modify those as well.

1 In ZENworks Control Center, click Asset Management > License Management > Licensed Products to 
display the Licensed Products page.

License Entitlements Every licensed product must have at least one entitlement. This page 
lets you specify a description and license model for the entitlement that 
will be added to the licensed products you are creating.

Description: Add a description for the license entitlement. The 
entitlement description serves as a name for the entitlement and 
identifies it in the licensed product’s entitlement list. The description 
can reflect the product name and version, the license model, the 
license type, or any other information that makes sense to you.

License Model: Select one of the following license models:

 Per-Installation: Each installation of the entitlement’s discovered 
products consumes a license.

 OEM: For each covered device, a license is consumed whether 
or not any of the entitlement’s discovered products are installed 
on the device. You specify the devices covered by the entitlement.

 Machine: For each covered device, a license is consumed only if 
one of the entitlement’s discovered products is installed on the 
device. You specify the devices covered by the entitlement.

 Per-User: Each user consumes a single license for any 
installations of the entitlement’s discovered products, regardless 
of the number of installations.    

 Per-Named User: Identical to the Per-User model, but you 
specify the users covered by the entitlement. 

Auto-reconcile Create 
Summary

Review your data.

Wizard Page Details
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2 In the Licensed Products panel, click the licensed product whose general information you want 
to edit.

3 Modify the fields as needed:
Manufacturer: Select the product’s manufacturer from the list or enter a new manufacturer.
Licensed Product: Select a name for the licensed product from the list or enter a new name.
Version: If the licensed product represents a specific version, specify the version. If not, leave the 
field empty.
Notes: Add any information you want to retain with the product.
Cost Center: This is a custom field added as an example. It is not included in the predefined 
general information. You can add as many custom fields as you’d like. For information, see 
Section 6.7, “Adding Custom Fields to Licensed Products,” on page 47.

6.7 Adding Custom Fields to Licensed Products
A licensed product includes predefined fields for recording the product’s manufacturer, name, and 
version. These fields are displayed on the licensed product’s General page.

You can create custom fields to record additional information for licensed products. When you create 
a custom field, it is added to each licensed product’s General page. It is also included in the Create 
New Licensed Product Wizard so that you can populate the field during creation of licensed 
products.

To create custom fields:

1 In ZENworks Control Center, click Configuration, then click the Asset Management tab.
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2 In the Administrator-Defined Fields panel, click Licensed Product to display the Licensed Product 
Fields page.

3 Click New to launch the New Administrator-Defined Field Wizard. Complete the wizard by 
using information from the following table to fill in the fields:

Wizard Page Details

General Information Fill in the following fields:

Type: Filled in by default depending on the type of field you selected.

Name: Specify the field label. This field is required.

Default Value: Specify the default value of the field. The default value 
must be valid for the field’s data type. For example, the default cannot 
be A if the data type is Integer.

Data Type: Select the type of data allowed in the field: Character, 
Integer, Decimal, or Date.

Size: Specify the maximum number of alphanumeric characters 
allowed in the field. This applies only to character-type fields.

Edit Type: Determines how you enter values into the field. There are 
three options you can select:

 Edit: Allows you to enter a value or edit the default value.

 List: Allows you to select a value from a list of values.

 Combo: Allows you to select a value from a list of values or enter 
a new value.

Edit Mask: Select a format from the Edit Mask field list to restrict how a 
value is entered. The choices are phone, time, and currency. This 
applies only to character-type fields.
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4 Click Finish to create the new administrator-defined field.
The field is added to each licensed product’s General page.

6.8 Merging Licensed Products
You can merge two or more licensed products into one licensed product. When you do so, you select 
one of the licensed products as the target product and the entitlements for each of the products are 
moved into the target product. All merged products, other than the target product, are deleted after 
the merge.

1 In ZENworks Control Center, click Asset Management > License Management > Licensed Products to 
display the Licensed Products page.

2 In the Licensed Products panel, select the licensed products you want to merge.
3 Click Action > Merge Licensed Products.
4 In the Target Product list, select the licensed product into which all the selected products will be 

merged, then click OK.
The products are merged. The target product is displayed in the Licensed Products list and all 
other merged products are deleted.

Choice List Values This page appears if you chose List or Combo as the Edit Type.

To create a list of choices:

1. Specify a value in the Choice List Values field.

2. Click Add. Repeat for additional values.

Edit: Select a value and click Edit to change it.

Remove: Select a value and click Remove to delete it.

Import: Click Import to open the Import Choice List Values dialog box 
where you can specify a file to import.

Field Summary Review the data. Use the Back button to go back to a previous page to 
edit any fields.

Wizard Page Details
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6.9 Deleting a Licensed Product
You can remove a licensed product from the Licensed Product list by deleting it. Only the licensed 
product is deleted; any catalog products and discovered products associated with the licensed 
product are not deleted.

1 In ZENworks Control Center, click Asset Management > License Management > Licensed Products to 
display the Licensed Products page.

2 In the Licensed Products panel, select the licensed product you want to delete.
3 Click Delete, then click OK to confirm the deletion.

6.10 Moving a Licensed Product
You can move a licensed product from one folder to another in the Licensed Product list. 

1 In ZENworks Control Center, click Asset Management > License Management > Licensed Products to 
display the Licensed Products page.

2 In the Licensed Products panel, select the licensed product you want to move.
3 Click Move to display the Move Licensed Product(s) dialog box.
4 Browse for and select the target folder, then click OK.
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7 7Working with Entitlements

A license entitlement typically represents a license agreement for a licensed product. It includes such 
agreement details as the license type (full, upgrade, maintenance, and so forth) and the license model 
(Per-User, Per-Installation, OEM, Machine, and so forth). Based on the license model, it also specifies 
which users or machines are covered by the entitlement.

Some licensed products might only have one entitlement. For example, you might have a product 
whose installations all fall under a full license, Per-Installation agreement.

Other products, however, might have multiple entitlements. For example, you might have a product 
for which you have OEM-licensed installations and Per-User licensed installations. To correctly cover 
both license agreements, you would need two entitlements with different license models and user/
machine coverage. A second example might be a product that includes a full license agreement and a 
version upgrade agreement.

The following sections explain the tasks associated with managing entitlements:

 Section 7.1, “Viewing a Licensed Product’s Entitlements,” on page 51
 Section 7.2, “Creating an Entitlement,” on page 52
 Section 7.3, “Adding Catalog Products,” on page 57
 Section 7.4, “Adding Purchase Summary Records,” on page 58
 Section 7.5, “Adding Discovered Products,” on page 59
 Section 7.6, “Specifying User and Device Coverage,” on page 61
 Section 7.7, “Adding Contracts and Documents,” on page 64

7.1 Viewing a Licensed Product’s Entitlements
You can view the list of entitlements for a licensed product. The list provides general information 
about each entitlement, such as its license type, license model, license quantity, and discovered 
products covered.

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Licensed Products.
3 In the Licensed Product panel, click the licensed product whose entitlements you want to view.
4 Click the License Entitlements tab

The License Entitlements page consists of two panels: Entitlements (Consumption Data Source: 
Inventory) and Entitlements (Consumption Data Source: Manual)
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The Entitlements (Consumption Data Source: Inventory) panel is used to manage the 
entitlements that pull their product installation data from the Inventory data collected during 
scans of devices in the Management Zone.
The Entitlements (Consumption Data Source: Manual) panel is used to manage entitlements that 
require product installation data to be manually entered into the entitlement.
These panels display the following details:
Description: The name of the entitlement. Click the name to display the entitlement’s details.
Type: The entitlement type: Full, License/Maintenance, or Version Upgrade.
License Period: Indicates if the license period is perpetual or for a specific term.
Term License Status: Indicates if the license is active or expired.
License Model: The type of license model.
License Quantity: The total number of licenses included in the entitlement, either through 
catalog products assigned to the entitlement or purchase summary records created for the 
entitlement. Click the quantity number to manage (view, add, or remove) the catalog products 
and purchase summary records that are contributing to the total license quantity.
Quantity Available: The number of available licenses. This is calculated by subtracting licenses 
consumed from the total number of licenses.
Versions Covered: This column is included only in the Inventory panel. It shows the discovered 
products, listed by version, that are covered by the entitlement. Click a version to manage (view, 
add, or remove) the entitlement’s covered product versions.
Upgrade From: If the entitlement type is Version Upgrade, this column displays the entitlement 
from which it is upgraded. 

7.2 Creating an Entitlement
There are two categories of entitlements that you can create: Inventory entitlements and manual 
entitlements. Inventory entitlements pull the installation data for their discovered products from the 
Inventory database. Manual entitlements require you to manually enter the installation data.

 Section 7.2.1, “Creating an Inventory Entitlement,” on page 53
 Section 7.2.2, “Creating a Manual Entitlement,” on page 55
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7.2.1 Creating an Inventory Entitlement 

The following steps explain how to create entitlements that use Inventory data as their source of 
discovered product installation data. If you need to create entitlements where you manually enter the 
installation data, see Section 7.2.2, “Creating a Manual Entitlement,” on page 55.

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Licensed Products.

3 Click the product for which you want to create an entitlement.
4 Click the License Entitlements tab.

5 In the Entitlements (Consumption Data Source: Inventory) panel, click New to launch the Create 
New Entitlement Wizard. Complete the wizard by using the information in the following table:
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6 If you have not already done so, click Finish to create the entitlement and add it to the 
Entitlements panel.

7 Configure the entitlement by doing the following: 
 Add information about purchased licenses. See Section 7.3, “Adding Catalog Products,” on 

page 57 and Section 7.4, “Adding Purchase Summary Records,” on page 58.

Wizard Page Details

License Model The license model determines how license consumption is calculated 
for eligible installations. Select one of the following license models:

 Per-Installation: Each installation of the entitlement’s discovered 
products consumes a license.

 OEM: For each covered device, a license is consumed whether 
or not any of the entitlement’s discovered products are installed 
on the device. You specify the devices covered by the entitlement. 

 Machine: For each covered device, a license is consumed only if 
one of the entitlement’s discovered products is installed on the 
device. You specify the devices covered by the entitlement. 

 Per-User: Each user consumes a single license for any 
installations of the entitlement’s discovered products, regardless 
of the number of installations.    

 Per-Named User: Identical to the Per-User model, except you 
specify the users covered by the entitlement. 

Entitlement Type Select the type of license represented by the entitlement:

 Full License: Entitles the user to new product installations (as 
opposed to upgrade installations).

 Version Upgrade: Entitles the user to upgrade a previous 
product version to the new version. This option is not displayed 
when creating the first entitlement for a licensed product.

 License/Maintenance: Entitles the user to new product 
installations and subsequent maintenance versions.

Entitlement Upgrade This page is displayed only if you selected Version Upgrade as the 
entitlement type.

Select the entitlement that is being upgraded by this entitlement. 

General Information Fill in the following fields:

Description: Specify a description for the entitlement. For example, 
Product A OEM License or Product A Version 6 Per-User License.

Platform: Select the product’s platform from the list.

License Period: The effective time period for the license. Select 
Perpetual if the license does not include a termination date. Select 
Term if the license is for a fixed period, then click the calendar icons to 
select the start and end dates.

Virtual Machine Use Rights: Specify any software use rights that 
apply when using the product in a virtual machine.

Notes: Provide any notes.

New Entitlement Summary Review the data.
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 Add information about installations. See Section 7.5, “Adding Discovered Products,” on 
page 59.

 Specify the users or devices covered by the entitlement. See Section 7.6, “Specifying User 
and Device Coverage,” on page 61.

7.2.2 Creating a Manual Entitlement 

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Licensed Products.

3 Click the product for which you want to create an entitlement.
4 Click the License Entitlements tab.

5 In the Entitlements (Consumption Data Source: Manual) panel, click New to launch the Create 
New Entitlement Wizard. Complete the wizard by using the information in the following table:

Wizard Page Details

License Model Choose one of the predefined license models. These license models 
are intended to match the license models most commonly used in 
license agreements. If your license model is not represented, select 
Other and specify the license model.
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6 If you have not already done so, click Finish to create the entitlement and add it to the 
Entitlements panel.

7 Configure the entitlement by doing the following: 
 Add information about purchased licenses. See Section 7.3, “Adding Catalog Products,” on 

page 57 and Section 7.4, “Adding Purchase Summary Records,” on page 58.
 Add information about installations. See Section 7.5, “Adding Discovered Products,” on 

page 59.
 Specify the users or devices covered by the entitlement. See Section 7.6, “Specifying User 

and Device Coverage,” on page 61.

Entitlement Type Select the type of license represented by the entitlement:

 Full License: Entitles the user to new product installations (as 
opposed to upgrade installations).

 Version Upgrade: Entitles the user to upgrade a previous 
product version to the new version. This option is not displayed 
when creating the first entitlement for a licensed product.

 License/Maintenance: Entitles the user to new product 
installations and subsequent maintenance versions.

Entitlement Upgrade This page is displayed only if you selected Version Upgrade as the 
entitlement type.

Select the entitlement that is being upgraded by this entitlement. 

General Information Fill in the following fields:

Description: Specify a description for the entitlement. For example, 
Product A OEM License or Product A Version 6 Per-User License.

Platform: Select the product’s platform from the list.

License Period: The effective time period for the license. Select 
Perpetual if the license does not include a termination date. Select 
Term if the license is for a fixed period, then click the calendar icons to 
select the start and end dates.

Quantity Consumed: Specify the number of installations you want to 
count against the entitlement.

Virtual Machine Use Rights: Specify any software use rights that 
apply when using the product in a virtual machine.

Notes: Provide any notes.

New Entitlement Summary Review the data.

Wizard Page Details
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7.3 Adding Catalog Products
To populate a licensed product with the number of licenses you’ve purchased for the product, you 
add catalog products to the licensed product’s entitlements. If you don’t have catalog products, you 
can create purchase summary records instead (see Section 7.4, “Adding Purchase Summary 
Records,” on page 58).

There are two ways to add a catalog product to an entitlement:

 Section 7.3.1, “Editing an Entitlement to Add Catalog Products,” on page 57
 Section 7.3.2, “Using the Catalog Products List to Add Catalog Products,” on page 58

7.3.1 Editing an Entitlement to Add Catalog Products

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Licensed Products.

3 Click the licensed product with the entitlement.
4 Click the License Entitlements tab.

5 In the Entitlements panel, click the entitlement to which you want to add catalog products.
6 Click the Proof of Ownership tab.
7 In the Catalog Products panel, click Add.
8 Select the desired catalog products, then click OK to add them to the Catalog Products panel.

The Catalog Products panel displays each catalog product’s Purchase Quantity, which is the 
number of units of the catalog product that you’ve purchased (according to the purchase 
records). It also displays the License Quantity, which is the total number of licenses included in 
the purchased units.
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7.3.2 Using the Catalog Products List to Add Catalog Products

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Catalog Products.

3 Select the catalog products that you want to add to an entitlement.
4 Click Action > Add to Licensed Product to launch the Add Catalog Products to Licensed Product 

Wizard. Complete the wizard by using the information in the following table:

5 If you have not already done so, click Finish to add the catalog products to the entitlement.
In the Catalog Products list, each catalog product you added displays the licensed product and 
entitlement with which it is now associated.

7.4 Adding Purchase Summary Records
A purchase summary record lets you add licenses to an entitlement without requiring a catalog 
product or a purchase record.

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Licensed Products.

3 Click the licensed product with the entitlement.

Wizard Page Details

Licensed Product Click  to browse for and select the licensed product that contains the 
entitlement to which you want to add the catalog products.

License Entitlement Select the entitlement to which you want to add the catalog products,

Summary Review the data.
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4 Click the License Entitlements tab.

5 In the Entitlements panel, click the entitlement to which you want to add purchase summary 
records.

6 Click the Proof of Ownership tab.
7 In the Purchase Summary Records panel, click New.
8 On the General Information page, fill in the following fields:

Description: Specify a description or name to identify the record.
License Quantity: Specify the number of purchased licenses.
Total Cost: Specify the total cost of the licenses. This information is optional.
Notes: Specify any optional notes to identify the record.

9 Click Next to display the Summary page.
10 Click Finish to create the purchase summary record.

7.5 Adding Discovered Products
To associate product installations with a licensed product, you add discovered products to the 
licensed product’s entitlements.

Discovered products can only be added to Inventory entitlements. Manual entitlements do not use 
discovered products.

There are two ways to add a discovered product to an entitlement:

 Section 7.5.1, “Editing an Entitlement to Add Discovered Products,” on page 59
 Section 7.5.2, “Using the Discovered Products List to Add Discovered Products,” on page 60

7.5.1 Editing an Entitlement to Add Discovered Products

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Licensed Products.
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3 Click the licensed product with the entitlement.
4 Click the License Entitlements tab.

5 In the Entitlements panel, click the entitlement to which you want to add discovered products.
6 Click the Coverage tab.
7 In the Discovered Product Versions Covered panel, click Add > Installed Discovered Products if you 

only want to choose from discover products that are installed in your Management Zone.
or
Click Add > Any Discovered Product to see all discovered products contained in the ZENworks 
Knowledgebase.

8 Select the desired discovered products, then click OK to add them to the Discovered Product 
Versions Covered panel.

7.5.2 Using the Discovered Products List to Add Discovered Products

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Discovered Products.

3 Select the discover products that you want to add to an entitlement.
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4 Click Action > Add to Licensed Product to launch the Add Discovered Products to Licensed 
Product Wizard. Complete the wizard by using the information in the following table:

5 If you have not already done so, click Finish to add the discovered products to the entitlement.
In the Discovered Products list, the discovered product displays the licensed product with 
which it is now associated.

7.6 Specifying User and Device Coverage
When you have an entitlement that uses an OEM, Machine, Per-Named User, or Per-User license 
model, you must specify which devices or users are covered by the entitlement. The following 
sections provide instructions:

 Section 7.6.1, “Adding Covered Devices to OEM and Machine Entitlements,” on page 61
 Section 7.6.2, “Adding Covered Users to Per-Named User Entitlements,” on page 62
 Section 7.6.3, “Excluding Users from Per-User Entitlements,” on page 63

7.6.1 Adding Covered Devices to OEM and Machine Entitlements

When you create an entitlement with an OEM or Machine license model, you must specify the 
devices that you want covered by the entitlement. Only the covered devices are eligible to consume 
the entitlement’s licenses.

1 If you are on the licensed product’s License Entitlements page, skip to Step 2. Otherwise, open 
the page:
1a In ZENworks Control Center, click the Asset Management tab.
1b On the License Management page, click Licensed Products.
1c Click the product whose entitlement coverage you want to modify.

Wizard Page Details

Licensed Product Click  to browse for and select the licensed product that contains the 
entitlement to which you want to add the discovered products.

License Entitlement Select the entitlement to which you want to add the discovered 
products.

Summary Review the data.
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1d Click the License Entitlements tab.

2 In the Entitlements panel, click the OEM or Machine entitlement.
3 Click the Coverage tab.
4 In the Covered Machines panel, click Add > Devices with Product Installed if you only want to see 

devices that have the product installed.
or
Click Add > Any Devices if you want to see all devices. 
The Search for Device dialog box is displayed. Because your system might include many 
devices, the Search for Device dialog box lets you limit the displays to only those devices that 
meet your defined criteria.

5 Use the Search Criteria to specify which devices you want to display. If you don’t want to limit 
the search results, skip to Step 6.
Device Type: Select the types of device (managed, inventoried, migrated) you want included in 
the search results.
Device Filter: The filters let you define specific criteria that a device must meet to be included in 
the search results. Use the Add Filter, Add Filter Set, and Insert Filter options to create the search 
criteria. 
Maximum Number of Devices to Display: Specify the maximum number of devices to include 
in the search results. 

6 In the Columns to Display in Search Results list, Ctrl+click and Shift+click to select the columns you 
want displayed in the search results.

7 Click Search to display the search results.
8 Select the devices you want to add to the Covered Machines list, then click OK.

7.6.2 Adding Covered Users to Per-Named User Entitlements

When you create an entitlement with a Per-Named User license model, you must specify the users 
that you want covered by the entitlement. Only the covered users are eligible to consume the 
entitlement’s licenses.

1 If you are on the licensed product’s License Entitlements page, skip to Step 2. Otherwise, open 
the page:
1a In ZENworks Control Center, click the Asset Management tab.
1b On the License Management page, click Licensed Products.
1c Click the product whose entitlement coverage you want to modify.
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1d Click the License Entitlements tab.

2 In the Entitlements panel, click the Per-Named User entitlement.
3 Click the Coverage tab.
4 In the Covered Users panel, click Add > Users with Product Installed if you only want to see users 

who have the product installed.
or
Click Add > Any Users if you want to see all users. 

5 If you are selecting users from your authoritative user source, browse for and select the users 
you want to add to the Covered Users list, then click OK.
or
If you are selecting users from the Inventory data source, do the following:
5a Use the Search Criteria to specify which users you want to display. If you don’t want to limit 

the search results, skip to Step 5b.
User Filter: The filters let you define specific criteria that a user must meet to be included in 
the search results. Use the Add Filter, Add Filter Set, and Insert Filter options to create the 
search criteria. 
Maximum Number of Users to Display: Specify the maximum number of users to include 
in the search results. 

5b In the Columns to Display in Search Results list, Ctrl+click and Shift+click to select the 
columns you want displayed in the search results.

5c Click Search to display the search results.
5d Select the users you want to add to the Covered Users list, then click OK.

7.6.3 Excluding Users from Per-User Entitlements

When you create an entitlement with a Per-User license model, all users are covered by the 
entitlement. If necessary, you can exclude users. An excluded user does not consume a license even if 
a discovered product installation is associated with the user.

1 If you are on the licensed product’s License Entitlements page, skip to Step 2. Otherwise, open 
the page:
1a In ZENworks Control Center, click the Asset Management tab.
1b On the License Management page, click Licensed Products.
1c Click the product whose entitlement coverage you want to modify.
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1d Click the License Entitlements tab.

2 In the Entitlements panel, click the Per-User entitlement.
3 Click the Coverage tab.
4 In the Covered Users panel, click Add > Users with Product Installed if you only want to see users 

who have the product installed.
or
Click Add > Any Users if you want to see all users. 

5 If you are selecting users from the authoritative user source, browse for and select the users you 
want to add to the Covered Users list, then click OK.
or
If you are selecting users from the Inventory data source, do the following:
5a Use the Search Criteria to specify which users you want to display. If you don’t want to limit 

the search results, skip to Step 5b.
User Filter: The filters let you define specific criteria that a user must meet to be included in 
the search results. Use the Add Filter, Add Filter Set, and Insert Filter options to create the 
search criteria. 
Maximum Number of Users to Display: Specify the maximum number of users to include 
in the search results. 

5b In the Columns to Display in Search Results list, Ctrl+click and Shift+click to select the 
columns you want displayed in the search results.

5c Click Search to display the search results.
5d Select the users you want to add to the Covered Users list, then click OK.

7.7 Adding Contracts and Documents
You can add contracts and documents to an entitlement to provide proof that you own the licenses 
associated with the entitlement.

The following instructions assume that you’ve already added contracts and uploaded documents to 
your Asset Management system. If not, see Part IV, “Contracts,” on page 149 and Part V, 
“Documents,” on page 171.

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Licensed Products.
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3 Click the licensed product with the entitlement.
4 Click the License Entitlements tab.

5 In the Entitlements panel, click the entitlement to which you want to add contracts or 
documents.

6 Click the Proof of Ownership tab.
7 In the Contracts panel, click Add.

or
In the Documents panel, click Add.

8 Browse for and select the contracts or documents you want to add, then click OK to add them to 
the Contracts list or Documents list.
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8 8Working with Discovered Products

Discovered products are used to associate installations with licensed products. Each discovered 
product includes information about its total number of installations on devices in the Management 
Zone. When you associate a discovered product with a licensed products’ entitlement, its 
installations become eligible to consume the entitlement’s licenses.

The following sections explain the tasks associated with managing entitlements:

 Section 8.1, “How Installed Software Products Become Discovered Products,” on page 67
 Section 8.2, “Viewing the Discovered Products List,” on page 68
 Section 8.3, “Filtering the Discovered Products List,” on page 69
 Section 8.4, “Excluding Discovered Products from Compliance Calculations,” on page 70
 Section 8.5, “Adding Discovered Products to Licensed Products,” on page 71
 Section 8.6, “Adding Discovered Products to Software Collections,” on page 73
 Section 8.7, “Viewing a Discovered Product’s Installations,” on page 73
 Section 8.8, “Adjusting a Discovered Product’s Installation Count,” on page 74
 Section 8.9, “Assigning a Standards Category,” on page 76
 Section 8.10, “Manually Reconciling Duplicate Products,” on page 77
 Section 8.11, “Viewing the Inventory Products Included in a Discovered Product,” on page 78
 Section 8.12, “Refreshing Compliance Status,” on page 79

8.1 How Installed Software Products Become Discovered 
Products
Asset Management includes a product Knowledgebase that includes over 27,000 predefined 
discovered products. The following process is used to map installed software products to the 
Knowledgebase discovered products:

1. Asset Inventory scans devices to collect information about installed software products. These 
installed software products are referred to as Inventory products.

2. Asset Management filters the Inventory products through the Knowledgebase to map the 
Inventory products to discovered products. During this process, the following occurs:
 All related versions, service releases, and language versions are mapped to the same minor-

version discovered product. For example, Product A 5.5, Product A 5.5 (JP) and Product A 
5.5.1 are consolidated under one Product A 5.5 discovered product. 

 Products that do not require licensing, such as browsers and viewers, are excluded.
 Software suites and their member products are identified.

3. Asset Management sets the discovered products’ installation quantity equal to the total 
installations for its mapped Inventory products. 
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As you work with discovered products, you’ll see the term installed discovered products. Discovered 
products are all 27,000+ products included in the Knowledgebase. Installed discovered products are 
only those discovered products that are actually installed in your organization (as discovered 
through Inventory scans). By default, the Discovered Products list in the ZENworks Control Center is 
filtered to show installed discovered products.

8.2 Viewing the Discovered Products List
You can view a list of all of your discovered products. The list provides general information about 
each discovered product, such as its number of installations and the licensed product with which it is 
associated

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Discovered Products.

The list provides the following information for each discovered product:
Name: The name of the discovered product. The name consists of four parts: Manufacturer 
Product Version (Platform). For example, with Acme Product A 8.5 (Windows), Acme is the 
manufacturer, Product A is the product, 8.5 is the version, and Windows is the platform. Click the 
name to display the discovered product’s details.
Excluded: Indicates if the discovered product is excluded from compliance calculations. 
Excluded products cannot be added to a licensed product.
Licensed Product: The licensed product with which the discovered product is associated. Click 
the licensed product to display its entitlements. The discovered product is included in one of the 
listed entitlements.
Installed Quantity: The number of installations of the product in the Management Zone. Click 
the quantity number to display the list of devices that have the product installed.
Active Usage Quantity:  The number of installed products that are actively being used. Active 
Usage Quantity is not displayed when the Do not show usage on License Management pages option 
is selected (Configuration > Management Zone Settings > Asset Management > Usage Display).
Standards Category: The category for the product.
68 ZENworks 11 SP3 Asset Management Reference



8.3 Filtering the Discovered Products List
By default, the Discovered Products list displays only the discovered products that are 1) installed on 
a device in your Management Zone and 2) are not excluded from compliance calculations. You can 
modify the Search criteria to change which discovered products are displayed.

For example, you can display only the discovered products from a specific manufacturer, or you can 
display only the discovered products that are associated with licensed products.

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Discovered Products.

3 In the Search panel (located next to the Discovered Products panel), specify the criteria to use for 
filtering the list. A product must match all defined criteria to be displayed.
Name: Specify the text that the discovered product name (or folder name) must include. This is a 
partial match field that is case-insensitive. If the text you enter is included in any part of a 
discovered product name, the product matches the criteria.
Manufacturer: Select a specific manufacturer, or select Any to match any manufacturers. 
Current Manufacturer: Select a specific manufacturer, or select Any to match any 
manufacturers. 
Platform: Select the platform (Windows or Mac) to match. 
Exclude Status: Select one of the following to match: 
 Any: Ignore the exclude status. Match all discovered products.
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 Excluded: Match only the discovered products that are excluded from compliance 
calculations. An excluded product cannot be associated with a licensed product.

 Not Excluded: Match discovered products that are not excluded from compliance 
calculations.

Install Status: Select one of the following to match: 
 Any: Ignore the install status. Match all discovered products.
 Installed: Match only the discovered products that are installed in your Management Zone.
 Not Installed: Match any discovered products that are included in the Knowledgebase but 

are not installed in your Management Zone. 
 Reconciled: Match only the reconciled discovered products.

Usage Status: Select one of the following to match:
 Any: Ignore the usage status. Match any discovered products.
 With Usage: Match discovered products for which active usage is recorded.
 Without Usage: Match discovered products for which no active usage is recorded. 

Reconciliation Status: Select one of the following to match:
 Any: Ignore the reconciliation status. Match any discovered products.
 Reconciled: Match discovered products that are associated with licensed products.
 Unreconciled: Match discovered products that are not associated with licensed products.

Standards Category: Select a standards category, or select Any to match any category.
Source:  Select one of the following to match the discovered products:
 Any: Ignore the source. Match all discovered products.
 Add Remove Programs: Match discovered products collected from the Add Remove Program 

panel.
 Fingerprinted Products: Match discovered products collected from the fingerprinted 

products.
 Local Software Products: Match discovered products collected from the Local Software 

Products.
4 Click Search to apply the search criteria and filter the list.

8.4 Excluding Discovered Products from Compliance 
Calculations
If there are discovered products that you don’t want associated with licensed products, you can 
exclude them. Excluded discovered products cannot be associated with licensed products and they 
do not appear in the Discovered Products list unless you change the default Search filter. Also, when 
you run the Auto-Reconcile Wizard to create licensed products from discovered products, excluded 
discovered products are not available.

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Discovered Products. 
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3 Select the product you want to exclude.
4 Click Action > Exclude.

8.5 Adding Discovered Products to Licensed Products
To associate product installations with a licensed product, you add discovered products to the 
licensed product’s entitlements.

Discovered products can only be added to Inventory entitlements. Manual entitlements do not use 
discovered products.

There are two ways to add a discovered product to an entitlement:

 Section 8.5.1, “Editing an Entitlement to Add Discovered Products,” on page 71
 Section 8.5.2, “Using the Discovered Products List to Add Discovered Products,” on page 72

8.5.1 Editing an Entitlement to Add Discovered Products

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Licensed Products.

3 Click the licensed product with the entitlement.
4 Click the License Entitlements tab.
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5 In the Entitlements panel, click the entitlement to which you want to add discovered products.
6 Click the Coverage tab.
7 In the Discovered Product Versions Covered panel, click Add > Installed Discovered Products if you 

only want to choose from discover products that are installed in your Management Zone.
or
Click Add ‘> Any Discovered Product to see all discovered products contained in the ZENworks 
Knowledgebase.

8 Select the desired discovered products, then click OK to add them to the Discovered Product 
Versions Covered panel.

8.5.2 Using the Discovered Products List to Add Discovered Products

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Discovered Products.

3 Select the discovered products that you want to add to an entitlement.
4 Click Action > Add to Licensed Product to launch the Add Discovered Products to Licensed 

Product Wizard. Complete the wizard by using the information in the following table:

Wizard Page Details

Licensed Product Click  to browse for and select the licensed product that contains the 
entitlement to which you want to add the discovered products.

License Entitlement Select the entitlement to which you want to add the discovered 
products,

Summary Review the data.
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5 If you have not already done so, click Finish to add the discovered products to the entitlement.
In the Discovered Products list, the discovered product displays the licensed product with 
which it is now associated.

8.6 Adding Discovered Products to Software Collections
You can add discovered products to software collections. After the discovered products are added to 
the software collection, they no longer appear as separate products in the Discovered Products list. 
Instead, the software collection appears in the list.

The following steps assume that you are adding discovered products to an existing software 
collection. If you need to create a software collection, see Chapter 11, “Working with Software 
Collections,” on page 107.

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Discovered Products. 

3 Select the discovered products that you want to add to a software collection.
4 Click Action > Add to Software Collection.

8.7 Viewing a Discovered Product’s Installations
Each discovered product includes a list of the devices where it is installed. To view this list:

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Discovered Products. 

3 Click the discovered product whose installations you want to view.
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4 Click the Installations/Consumption tab to display the list of installations.

8.8 Adjusting a Discovered Product’s Installation Count
A discovered product provides a count of the total number of installations for the product. If 
necessary, you can manually adjust this count by ignoring installations or adding to the installation 
count.

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Discovered Products. 

3 Click the discovered product whose installations you want to adjust.
4 Click the Installations/Consumption tab.
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The Consumption panel displays the following information:
Ignored Installations: The number of installations excluded from the total installation count 
(also referred to as the net consumption). You manually mark the installations you want 
ignored. See Step 5 for instructions.
Recognized Installations: The number of installations included in the total installation count.
Additional Consumption: The number of additional installations you want to add to the 
recognized installations. See Step 6 for instructions.
Net Consumption: The total number of installations included in the discovered product’s 
installation count. This is equal to (Recognized Installations + Additional Consumption) - Ignored 
Installations.

5 To ignore an installation, select the installation in the Installations panel by clicking the check 
box next to the installation, then click Action > Ignore Installation.

6 To add installations to the count, use the Additional Consumption field in the Consumption panel 
to select the number of additional installations.

7 Click Apply to save your changes.
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8.9 Assigning a Standards Category
If your organization has policies and standards to which installed software products must conform, 
or if you simply want another categorization to help you organize your discovered products, you can 
assign standards categories to your discovered products.

For example, you might create Standard, Non-Standard, and Standard Violation categories to track 
standards compliance across all discovered products. Or, you might make the categories more 
specific, such as Standard Desktop, Non-Standard Desktop, Standard Desktop Violation, Standard 
Server, Non-Standard Server, and Standard Server Violation.

The Discovered Products list includes a column to show each discovered product’s standards 
category. In addition, you can generate a Software Standards report that includes the standards 
category for every product (see Chapter 32, “Working with Standard Reports,” on page 191).

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Discovered Products. 

3 Click the discovered product to which you want to assign a standards category.

4 In the Standards Category field, select an existing category or type in a new one.
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You can select an existing standards category only if you’ve already created one for another 
discovered product. Otherwise, no list is available and you must define the standards category 
by typing it in the field.

5 Click Apply.

8.10 Manually Reconciling Duplicate Products
During an Inventory scan, when the collector collects information about the software products 
installed on the device, the same set of software products might be reported from the ZENworks 
Knowledgebase and from the Add or Remove Programs. The collector reconciles such duplicate 
entries automatically.

However, if duplicate entries are still displayed in the list of discovered products, you need to 
manually reconcile them to ensure that entries are reported only once.

Example:

If Product A (from the Fingerprint) and Product B (from Add or Remove Programs) appear in the list 
of discovered products and they are actually the same product, you can manually reconcile Product 
A and B. After manual reconciliation, Product B does not appear in the list of discovered products.

8.10.1 Manually Reconciling Discovered Products

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Discovered Products.
3 Select the product (primary) that you want to reconcile.
4 Click Action > Reconcile Products.

5 Click OK to continue

6 In the Selection dialog box, click  to display search results.
7 Select the relevant discovered product (secondary) that needs to be reconciled with the product 

selected in Step 3.
8 Click OK.

NOTE: Use the Reconcile option with caution, because after the manual reconciliation, all references 
to the secondary discovered product are removed from the ZENworks Asset Management database.
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8.10.2 Undoing Manual Reconciliation

If you have reconciled Product X with Product Y, and later realize that Product Y is not the same as 
Product X, you can undo the manual reconciliation. 

1 In the search panel on the Discovered Products page, locate Product Y by filtering the install 
status (reconciled).

2 Select Product Y and click Action > Reconcile Product

3 Click OK.

NOTE: To completely restore product Y to a state prior to the reconciliation, you need to do a full 
inventory scan from all the devices in the Management Zone.

8.11 Viewing the Inventory Products Included in a Discovered 
Product
Each discovered product provides a list of the Inventory products that have been consolidated into 
the discovered product (see Section 8.1, “How Installed Software Products Become Discovered 
Products,” on page 67). To view this list:

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Discovered Products. 

3 Click the discovered product whose Inventory products you want to view.
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The Inventory Products panel on the Details tab lists each of the Inventory products.

8.12 Refreshing Compliance Status
Refreshing compliance data recalculates all discovered product installation counts and recalculates 
compliance status for all licensed products. The following sections explain when automatic refreshes 
occur, how to manually trigger a refresh, and how to find out when the last scheduled refresh 
occurred.

 Section 8.12.1, “Automatically Refreshing Status,” on page 79
 Section 8.12.2, “Manually Triggering a Refresh,” on page 80
 Section 8.12.3, “Viewing Refresh Details,” on page 80

8.12.1 Automatically Refreshing Status

The compliance status for all licensed products is automatically refreshed at the following times:

 When you import purchase records. This ensures that a product’s compliance status 
immediately reflects any newly purchased licenses.

 Each day at the time specified for the compliance engine’s refresh schedule (see Chapter 3, 
“Configuring Compliance Settings,” on page 27). This ensures that a product’s compliance status 
reflects any changes to the installation count for its discovered products. 

In addition, the compliance status for an individual product is automatically refreshed when the 
following actions occur:

 Creating or deleting an entitlement.
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 Adding, modifying, or deleting any entitlement entry that affects license quantity or installation 
quantity. This includes purchase records, purchase record summaries, catalog products, 
discovered products, and software collections.

 Adjusting the installation count (net consumption) for a discovered product.

8.12.2 Manually Triggering a Refresh

You can manually trigger a refresh of the compliance status for all licensed products. You cannot 
manually trigger a refresh of an individual licensed product.

1 In ZENworks Control Center, click Asset Management > License Management to display the 
License Management page.

2 Click Discovered Products to display the Discovered Products page.
A compliance refresh can also be triggered from the Licensed Products page.

3 In the Discovered Products panel, click Actions > Refresh Compliance Status.

8.12.3 Viewing Refresh Details

You can see information about the latest refresh above the menu bar of both the Discovered Products 
page and Licensed Products page. This information includes the following:

 The last time a compliance refresh was started and ended
 What initiated the refresh
 Whether it was a refresh of all products or a single product

The Compliance Status tab of the Licensed Product page also shows the time the license was last 
refreshed. In addition, clicking License Management Reports > Software Compliance > Compliance Report 
displays a column called More Recent Recalc that indicates if a license has been refreshed more 
recently than the last full refresh of all licenses.
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9 9Working with Purchase Records

Purchase records provide details about the number of licensed purchased for your software 
products. 

For example, Purchase Record 1 includes two purchase details: 10 units of Product A (Single License 
Pack) and 3 units of Product B (10-License Pack). Purchase Record 2 includes a purchase detail for 4 
additional units of Product B (10-License Pack).

Catalog products consume the purchased license quantities from their associated purchase details. 
For example, the Product B (10-License Pack) catalog product consumes a total of 70 licenses. Purchase 
Record 1 provides 30 licenses from 3 units of Product B (10-License Pack). Purchase Record 2 provides 
40 licenses from 4 units of Product B (10-License Pack). 

The following sections explain the tasks associated with managing purchase records:

 Section 9.1, “Viewing the Purchase Records List,” on page 81
 Section 9.2, “Filtering the Purchase Records List,” on page 82
 Section 9.3, “Creating a Purchase Record Folder,” on page 82
 Section 9.4, “Creating Purchase Records,” on page 83
 Section 9.5, “Viewing a Purchase Record’s Details,” on page 86
 Section 9.6, “Changing a Purchase Record’s General Information,” on page 88
 Section 9.7, “Deleting a Purchase Record,” on page 88
 Section 9.8, “Moving a Purchase Record,” on page 89
 Section 9.9, “Working with Import Files,” on page 89

9.1 Viewing the Purchase Records List
You can view a list of all of your purchase records. The list provides general information about each 
purchase record, such as its purchase order number and date.

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Purchase Records.

The list provides the following information for each purchase record:
PO#: The purchase order number associated with the record.
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Order Date: The date of the purchase order.
Reseller: The reseller from which the purchase was made.

9.2 Filtering the Purchase Records List
You can filter the Purchase Records list to display only the purchase records that meet certain criteria. 

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Purchase Records.

3 In the Search panel (located next to the Purchase Records list), enter the criteria to use for the 
filter. A product must match all criteria to be displayed.
PO Number: Specify the text that the purchase order number (or folder name) must include. 
This is a partial match field that is case-insensitive. If the text you enter is included in any part of 
a purchase order number, the record matches the criteria.
Type: Select whether you want to match folders, purchase records, or both.
Reseller: Select a specific reseller, or select Any to match any reseller. 
Order Date: Select one of the following to match:
 Any: Ignore the order date. Match any purchase record.

 On: Match purchase records whose order date is on the specified date. Click  to specify 
the date.

 Before: Match purchase records whose order date is before the specified date. Click  to 
specify the date.

 After: Match purchase records whose order date is after the specified date. Click  to 
specify the date.

Include Subfolders: Select this option to search the current folder and its subfolders.
4 Click Search to apply the search criteria and filter the list.

9.3 Creating a Purchase Record Folder
You can create folders in the Purchase Records list to better organize your purchase records. All 
folders are displayed at the top of the list.

1 In ZENworks Control Center, click Asset Management > License Management > Purchase Records to 
display the Purchase Records page.
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2 Click New > Folder to display the New Folder dialog box.
3 Fill in the following fields:

Name: Specify a name for the folder. The name must be unique among all other folders and 
purchase records at the same level.
Folder: Browse for and select the folder in which to place the new folder.
Description: Specify any optional information to identify the folder.

4 Click OK to create the folder.

9.4 Creating Purchase Records
The easiest way to create purchase records is to import them from files supplied by resellers. Asset 
Management can import purchase records from CompuCom, Insight, KMD/SAP, SHI, and 
Softchoice. In addition, there is generic import format that you can use (see “Working with Import 
Files” on page 89).

If you are unable to import data from a supported import file, you must manually create purchase 
records.

 Section 9.4.1, “Importing Purchase Records,” on page 83
 Section 9.4.2, “Manually Creating Purchase Records,” on page 85

9.4.1 Importing Purchase Records

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Purchase Records.

3 Click Action > Start Import to display the Import Purchase Records dialog box.
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4 In the File Name field, click Browse to locate and select the import file.
5 Click OK to start the import.

During the import, the progress is displayed above the Purchase Records list. You can also click 
the Import Status tab to see the progress of the import and a record of previous imports. 
When the import is complete, the new purchase records are added to the list.

6 Click a purchase record to display its information.

The General page displays information about the reseller, purchaser, and purchase date. 
7 Click the Purchase Details tab.
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On the Purchase Details page, each software product purchase (included in the purchase record) 
is associated with a catalog product. If necessary, Asset Management creates a catalog product 
for any new software products included in the purchase record.
You can view all catalog products by clicking the License Management tab > Catalog Products.

9.4.2 Manually Creating Purchase Records

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Purchase Records.

3 In the Purchase Records panel, click New > Purchase Record to launch the Create New Purchase 
Record Wizard.

4 On the General Information page, fill in at least one of the following fields. The other fields are 
optional.
PO Number: The purchase order number. The purchase record object uses the PO number for 
its name. If you don’t supply a PO number, the name of the purchase record object defaults to 
Unknown (MM_DD_YY), where MM_DD_YY is the current date in the appropriate locale format.
Order Date: The date the product was ordered. To select a date, click , select a date, then click 
OK. If you provide a PO number but not a date, this field defaults to the current date.

5 Click Next to display the New Purchase Record Summary page.
6 Select Define Additional Properties, then click Finish to create the purchase record and display the 

Purchase Details page.
You use the Purchase Details page to enter the details for each software product purchase 
included in the purchase record.
Each purchase detail must be associated with a catalog product. For example, if your purchase 
record includes a purchase of Product B (10-License Pack), a Product B (10-License Pack) catalog 
product must exist before you create the purchase detail. The Purchase Details page lets you 
create catalog products if necessary.

7 If the catalog product already exists, click New > Purchase Detail to display the Add Purchase 
Detail dialog box. Otherwise, skip to Step 8.
7a Fill in the following fields (the other fields are optional):
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Product: Click  to browse for and select the catalog product to associate with the 
purchase detail. The catalog product inherits the purchases licenses.
Purchase Quantity: Specify the number of units of the product that were purchased. This 
number does not always correspond to the number of licenses for the product. For example, 
you might purchase 5 units of Product A (Single License Pack) or 10 units of Product B (10-
License Pack). 
Unit MSRP: The Manufacturer’s suggested retail price (MSRP) for a single unit.
Unit Price: The price you paid for a single unit.
Extended Price: The standard calculation for this field is the Unit Price multiplied by the 
Purchase Quantity (for example, $200.00 x 5). If you leave the field empty, the calculation is 
performed automatically when the purchase detail is created. If the standard calculation is 
not correct, specify the correct extended price. 

7b Click OK to add the purchase detail to the list.
7c Repeat the steps to create additional purchase details.

8 If the catalog product does not exist, click New > Catalog Product to launch the Create New 
Catalog Product Wizard. 
8a On the General Information page, fill in the following fields. The other fields are optional, 

but you should enter as much information as possible to identify the catalog product.
Product: Specify the name of the product as indicated in your purchase record. This should 
be as specific as possible. For example, if the product is Product B (10-License Pack), enter 
that name rather than Product B.
Licenses Per Package: Specify the number of licenses that come in the package.

8b Click Next to display the New Purchase Detail page, then fill in the following fields to create 
the purchase detail (the other fields are optional):
Purchase Quantity: Specify the number of units of the product that were purchased. This 
number does not necessarily correspond to the number of licenses for the product. For 
example, you might purchase 5 units of Product A (Single License Pack) or 10 units of Product 
B (10-License Pack). 
Unit MSRP: The Manufacturer’s suggested retail price (MSRP) for a single unit.
Unit Price: The price you paid for a single unit.
Extended Price: The standard calculation for this field is the Unit Price multiplied by the 
Purchase Quantity (for example, $200.00 x 5). If you leave the field empty, the calculation is 
performed automatically when the purchase detail is created. If the standard calculation is 
not correct, enter the correct extended price. 

8c Click Next, review the information, then click Finish to create the purchase detail and 
catalog product.

8d Repeat the steps to create additional catalog products and purchase details.

9.5 Viewing a Purchase Record’s Details
1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Purchase Records.
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3 Click a purchase record to display its information.

The General page displays information about the reseller, purchaser, and purchase date. 
4 Click the Purchase Details tab.

On the Purchase Details page, each software product purchase (included in the purchase record) 
is associated with a catalog product. That catalog product consumes the licenses included in the 
purchase.
You can view all catalog products by clicking the License Management tab > Catalog Products.
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9.6 Changing a Purchase Record’s General Information
A purchase record includes general information such as its purchase order number, recipient name 
and address, order date, and reseller. You can modify this information as necessary.

1 In ZENworks Control Center, click Asset Management > License Management > Purchase Records to 
display the Purchase Records page.

2 In the Purchase Records panel, click the purchase record whose general information you want to 
edit.

3 Modify the fields as needed:
PO Number: Specify the number assigned to the purchase order.
Recipient - Country: Use these fields to provide information about the order recipient. For each 
field, select a value from the list or enter a new value.
Notes: Add any information you want to retain with the purchase order.
Order Date: Click  to select the purchase date.
Reseller: Select the reseller from the list or enter a new reseller.

4 Click Apply to save the changes.

9.7 Deleting a Purchase Record
You can remove a purchase record from the Purchase Records list by deleting it. Both the purchase 
record and its details are deleted.

Deleting a purchase record reduces the license quantity of any catalog products that consume 
purchased licenses from the purchase record’s details. 

1 In ZENworks Control Center, click Asset Management > License Management > Purchased Records to 
display the Purchased Records page.

2 In the Purchased Records panel, select the purchase record you want to delete.
3 Click Delete, then click OK to confirm the deletion.
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9.8 Moving a Purchase Record
You can move a purchase record from one folder to another in the Purchase Records list. 

1 In ZENworks Control Center, click Asset Management > License Management > Purchase Records 
to display the Purchase Records page.

2 In the Purchase Records panel, select the purchase record you want to move.
3 Click Move to display the Move Purchase Record(s) dialog box.
4 Browse for and select the target folder, then click OK.

9.9 Working with Import Files
ZENworks Asset Management can import purchase records from a standard Asset Management 
import file of from any of the following reseller import files:

  CompuCom Software Compliance Report 

  Softchoice Product History Report 

  ZENworks Asset Management Reseller Connector Report 

  SHI License Compliance Report 

  KMD Asset Report: Automatic import from SAP with relevant data for asset 
management 

The following information is provided if you need to modify a reseller import file or if you want to 
create a standard Asset Management import file:

 Section 9.9.1, “Format,” on page 89
 Section 9.9.2, “Fields,” on page 89

9.9.1 Format

Import files are tab-delimited ASCII text files. The first row contains the column headers. Each 
additional row is a data row that identifies a specific product’s line item (or detail) in a purchase 
record. The following example includes the first few rows of a file; only the first six column headers 
are displayed.

PO#    OrderDate    Reseller    Recipient    CompanyName    ShippingAddress1
1234   12/16/2009   CheapSoft   Jen Adams    Novell         1800 S. Novell Pl.
87654  12/18/2009   Soft-R-Us   Nigel Ray    Novell         404 Wyman Street

The order of the columns is not important. For example, you can reverse the PO# and OrderDate 
columns or remove any columns that contain unwanted information. 

9.9.2 Fields

The table shown below lists the fields used in each reseller import file. 

The table’s first column covers standard, Insight, CompuCom, SHI, and KMD import files because 
they use the same field names. The one exception is that KMD uses PO_NUMBER rather than PO#. 
The table’s second column covers the Softchoice import file.
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Fields 1–13 identify the purchase record. Fields 14–30 identify a product’s line item (or detail) 
included in the purchase record. For two products to be included in the same purchase record, the 
information in fields 1–13 must match.

When working with an import file, the following rules apply:

 Use only the fields intended for that import file. For example, when editing a Softchoice import 
file, include only the fields listed in the Softchoice Fields column. Any invalid fields cause the 
import to fail.

 The following fields are required: (PO# | PO_NUMBER | PURCHASEORDER), (OrderDate | 
ORDERDATE), (ProductName | ITEMDESC), and (PurchaseQty | QTYORD). Removing these 
fields causes the import to fail.

 The LicensesPerPackage field is also required; however, if it is missing the importer assigns a 
default value of 1.

 All non-required fields can be removed if desired. When doing so, remove both the field column 
header and the field text in each subsequent row.

Table 9-1   Import File Fields 

Standard, KMD, Insight, 
CompuCom, and SHI Fields

Softchoice Fields Description

1 PO# (standard, Insight, 
CompuCom, SHI)

PO_NUMBER (KMD)

PURCHASEORDER The purchase order number. 

Either this field or the OrderDate field must be 
included in the record. If neither field contains 
data, the record is not imported.

The ZENworks purchase record object (created 
during import) uses the PO number for its name. 
If you don’t supply a PO number, the name of the 
purchase record object defaults to Unknown 
(MM_DD_YY), where MM_DD_YY is the current 
date in the appropriate locale format.

The maximum field length is 32 characters.
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2 OrderDate ORDERDATE The date the product was ordered.

Either this field or the PO# field must be included 
in the record. If neither field contains data, the 
record is not imported.

If you provide a PO number but not a date, the 
OrderDate field defaults to the import date.

For a standard, Insight, CompuCom, or SHI 
import file, the OrderDate field requires the short 
date format determined by the ZENworks 
Control Center’s server locale. For example, if 
the server locale is US-English, the correct date 
format is m/d/yyyy (12/16/2009 or 5/3/2010).

For a KMD import file, the OrderDate field 
requires the d/M/yy format (for example, 28/1/
09).

For a Softchoice import file, the ORDERDATE 
field requires the dd-MMM-yyyy format (for 
example, 18-JUL-2010).

3 Reseller The reseller from whom the products in this 
order were purchased.

The maximum field length is 64 characters.

4 Recipient SHIPCONTACTNAME The individual to whom the products in this order 
were shipped.

The maximum field length is 32 characters.

5 CompanyName COMPANYNAME The name of the company or entity that executed 
the order.

The maximum field length is 32 characters.

6 ShippingAddress1 SHIPADDR The first line of the shipping address.

The maximum field length is 64 characters.

7 ShippingAddress2 SHIPCITYSTZIP The second line of the shipping address.

The maximum field length is 64 characters.

8 ShippingAddress3 The third line of the shipping address.

The maximum field length is 64 characters.

9 City The city where the order was shipped.

The maximum field length is 32 characters.

10 State The state where the order was shipped.

The maximum field length is 32 characters.

11 Zip The ZIP code or mail code of the shipping 
destination.

The maximum field length is 16 characters.

Standard, KMD, Insight, 
CompuCom, and SHI Fields Softchoice Fields Description
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12 Country The country where the order was shipped.

The maximum field length is 32 characters.

13 Notes A text field for general notes about the purchase 
record.

The maximum field length is 255 characters.

14 Manufacturer PUBLISHER The manufacturer of the purchased product.

The Manufacturer, ProductName, Version, 
ProductType, and LicensesPerPackage fields 
are used to determine the existence of a unique 
product.

The maximum field length is 64 characters.

15 ProductName ITEMDESC The name or description of the purchased 
product. This field is required.

The Manufacturer, ProductName, Version, 
ProductType, and LicensesPerPackage fields 
are used to determine the existence of a unique 
product. 

The maximum field length is 255 characters.

16 Version The version of the purchased product.

The Manufacturer, ProductName, Version, 
ProductType, and LicensesPerPackage fields 
are used to determine the existence of a unique 
product. 

The maximum field length is 32 characters.

17 ProductType The type of purchased product. This field helps 
establish what the product represents, such as 
full license, upgrade, or media.

The Manufacturer, ProductName, Version, 
ProductType, and LicensesPerPackage fields 
are used to determine the existence of a unique 
product. 

The maximum field length is 32 characters.

18 LicensesPerPackage The number of licenses included in each 
purchased product unit.

For example, if the product is a 5-pack, this value 
is 5. The default is 1. Range values (for example, 
1-25) are not supported and cause the line item 
to be skipped during import.

The Manufacturer, ProductName, Version, 
ProductType, and LicensesPerPackage fields 
are used to determine the existence of a unique 
product. 

Standard, KMD, Insight, 
CompuCom, and SHI Fields Softchoice Fields Description
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19 ResellerSKU SKU The SKU number assigned by the reseller. This 
value might be important when communicating 
with a particular reseller.

The maximum field length is 32 characters.

20 MfrPart# MFGSKU The part number assigned by the manufacturer. 
If available, this value can often be used to 
distinguish one product from another.

The maximum field length is 32 characters.

21 PurchaseQty QTYORD The number of product units purchased in the 
order.

This must be a single value. Range values (for 
example, 1-25) are not supported and cause the 
record to be skipped during import.

The value must be between -1000000 and 
1000000.

22 Serial# The software serial number associated with the 
ordered product

The maximum field length is 40 characters.

23 Site1 The Site, Department, and CostCenter fields are 
used for tracking demographics. You can 
associate a line item with a value in any or all of 
these columns so that license quantities can be 
summarized within a particular demographic. For 
these values to be meaningful, corresponding 
demographics must be associated with devices 
in the ZENworks Asset Management inventory.

The maximum field length is 32 characters.

24 Department1

25 CostCenter1

26 Comment COMMENTS A text field for general comments about the 
purchased product.

The maximum field length is 128 characters.

27 Invoice# INVOICE The invoice number of the purchased product.

Multiple invoices can be associated with the 
same purchase order number.

Standard, KMD, Insight, 
CompuCom, and SHI Fields Softchoice Fields Description
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1Cost Center, Department, and Site values are meaningful for licensed products with demographic 
allocations enabled. The allocated quantity is updated (along with the license quantity) for licensed 
products that have the corresponding demographic allocation type (site, department, or cost center) 
and have enabled Update license allocations with demographic data from future purchase record imports.

28 UnitMSRP The UnitMSRP is the manufacturer’s suggested 
price for one product unit.

The UnitPrice is the actual price paid for one 
product unit.

The Extended Price is the cost for all the 
purchased product units. If no value exists in the 
ExtendedPrice field, a value is calculated based 
on the values of the PurchaseQty and UnitPrice 
fields. If a value exists, it is imported and is not 
checked to see if it matches a calculated value.

If currency symbols and thousands separators 
appear in the fields, they are stripped out when 
the data is imported. 

The importer uses the locale of the server to 
determine what characters are used for 
thousands and monetary decimal separators. If 
your values contain a mixture of currencies, the 
imported cost values might be incorrect. 

Range values (for example, 25.00-39.99) are not 
supported and cause the record to be skipped 
during import.

29 UnitPrice

30 ExtendedPrice

Standard, KMD, Insight, 
CompuCom, and SHI Fields Softchoice Fields Description
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10 10Working with Catalog Products

Catalog products are used to associate purchased licenses with licensed products. The following 
sections explain the tasks associated with managing catalog products:

 Section 10.1, “Viewing the Catalog Products List,” on page 95
 Section 10.2, “Filtering the Catalog Products List,” on page 96
 Section 10.3, “Excluding Catalog Products from Compliance Calculations,” on page 97
 Section 10.4, “Creating Catalog Products by Importing Purchase Records,” on page 98
 Section 10.5, “Creating Catalog Products Manually,” on page 98
 Section 10.6, “Adding Purchased Licenses to a Catalog Product,” on page 99
 Section 10.7, “Adding Catalog Products to a Licensed Product,” on page 100
 Section 10.8, “Creating a Catalog Product Folder,” on page 101
 Section 10.9, “Viewing a Catalog Product’s Purchases,” on page 102
 Section 10.10, “Changing a Catalog Product’s General Information,” on page 102
 Section 10.11, “Adding Custom Fields to Catalog Products,” on page 103
 Section 10.12, “Deleting a Catalog Product,” on page 105
 Section 10.13, “Moving a Catalog Product,” on page 105

10.1 Viewing the Catalog Products List
You can view a list of all of your catalog products. The list provides general information about each 
catalog product, such as the number of licenses included in one unit of the product catalog, the 
manufacture part number, and the licensed product with which it is associated.

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Catalog Products.

The list provides the following information for each catalog product:
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Name: The name of the catalog product. The name consists of five parts: Manufacturer Product 
Version (Product Type) (Licenses Per Package). For example, with Acme Product A 8.5 (Full License) 
(10), Acme is the manufacturer, Product A is the product, 8.5 is the version, Full License is the 
product type, and 10 is the number of licenses per product unit. Click the name to display the 
catalog product’s details.
Licenses Per Pkg: The number of licenses included in one unit of the catalog product. For 
example, if the catalog product is Product B (10-License Pack), the number of licenses is 10.
Mfr. Part. #: The part number that the manufacturer assigned to the software product package 
represented by the catalog product.
Reseller SKU: The SKU (stock-keeping unit) that the reseller assigned to the software product 
package represented by the catalog product.
Excluded: Indicates whether or not the catalog product is excluded from compliance 
calculations. Excluded products cannot be added to a licensed product.
Purchase Quantity:  The number of packages of the software product you have purchased. This 
number, multiplied by the Licenses Per Pkg number, provides the total licenses associated with 
the catalog product. Click the quantity number to display the list of purchases for the catalog 
product.
Licensed Product: The licensed product to which the catalog product is assigned. Click the 
licensed product to display its License Entitlements page.
License Entitlement: The specific license entitlement to which the catalog product is assigned. 
Click the entitlement to display the entitlement’s Proof of Ownership page. You can use this 
page to manage (view, add, or remove) the catalog product’s association with the entitlement.

10.2 Filtering the Catalog Products List
By default, the Catalog Products list displays all catalog products that are not excluded from 
compliance calculations. You can modify the Search criteria to change which catalog products are 
displayed.

For example, you can display only the catalog products from a specific manufacturer, or you can 
display only the catalog products that are assigned to licensed products.

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Catalog Products.

3 In the Search panel (located next to the Catalog Products panel), specify the criteria to use for 
filtering the list. A product must match all defined criteria to be displayed.
Name: Specify the text that the catalog product name (or folder name) must include. This is a 
partial match field that is case-insensitive. If the text you enter is included in any part of the 
name, the product matches the criteria.
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Manufacturer: Select a specific manufacturer, or select Any to match any manufacturers. 
Product Type: Select a specific product type, or select Any to match any product type. 
Platform: Select the platform (Windows or Mac) to match. 
Mfr. Part Number: Specify the text that the part number must include. This is a partial match 
field that is case-insensitive. If the text you enter is included in any part of the part number, the 
product matches the criteria.
Exclude Status: Select one of the following to match: 
 Any: Ignore the exclude status. Match all catalog products.
 Excluded: Match only the catalog products that are excluded from compliance calculations. 

An excluded product cannot be associated with a licensed product.
 Not Excluded: Match catalog products that are not excluded from compliance calculations.

Reconciliation Status: Select one of the following to match:
 Any: Ignore the reconciliation status. Match all catalog products.
 Reconciled: Match catalog products that are assigned to licensed products.
 Unreconciled: Match catalog products that are not assigned to licensed products.

Include Subfolders: Select this option to search the current folder and its subfolders.
4 Click Search to apply the search criteria and filter the list.

10.3 Excluding Catalog Products from Compliance Calculations
If you have catalog products that you don’t want associated with licensed products, you can exclude 
them. Excluded catalog products cannot be assigned to licensed products and they do not appear in 
the Catalog Products list unless you change the default Search filter. Also, when you run the Auto-
Reconcile Wizard to create licensed products from discovered products, excluded catalog products 
are not available.

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Catalog Products. 

3 Select the product you want to exclude.
4 Click Action > Exclude.
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10.4 Creating Catalog Products by Importing Purchase Records
Asset Management allows you to import purchase records. When a purchase record contains a 
software product that is not already identified as an Asset Management catalog product, the import 
process creates the catalog product. When a purchase record contains a software product that is 
already identified as a catalog product, the import process adds the product’s purchased licenses to 
the catalog product.

For instructions about how to import purchase records, see Section 9.4.1, “Importing Purchase 
Records,” on page 83.

10.5 Creating Catalog Products Manually
You can manually create catalog products. The catalog product defines the software product but does 
not include any licenses. To include the software product’s licenses in the catalog product, you must 
associate the catalog product with the purchase records that contain the license purchases.

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Catalog Products.

3 Click New > Catalog Product to launch the Create New Catalog Product Wizard. Complete the 
wizard by using information from the following table to fill in the fields.:
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4 If you have not already done so, click Finish to create the catalog product.
5 To add licenses to the catalog product, see Section 10.6, “Adding Purchased Licenses to a Catalog 

Product,” on page 99.

10.6 Adding Purchased Licenses to a Catalog Product
There are two ways to add purchased licenses to a catalog product:

 You can import a purchase record file that includes the purchased licenses. The purchase record 
is created and, if the software product name in the purchase record matches the catalog product 
name, the purchased licenses are associated with the catalog product. For instructions, see 
Section 9.4.1, “Importing Purchase Records,” on page 83

 You can manually create a new purchase record and add a purchase detail that is associated 
with the catalog product. The license quantity included in the purchase detail is added to the 
catalog product. For instructions, see Section 9.4.2, “Manually Creating Purchase Records,” on 
page 85.

Wizard Page Details

General Information Fill in the following fields:

Manufacturer: Specify the manufacturer of the product.

Product: Specify the name of the product as indicated in your 
purchase record. This should be as specific as possible. For example, 
if the product is Product B (10-License Pack), enter that name rather 
than Product B.

Product Type: Select a product type.

Version: Specify the product version.

Manufacturer Part Number: Specify the part number assigned to the 
product package.

Reseller SKU: Specify the reseller’s SKU.

Licenses Per Package: Specify the number of licenses that come in 
the package.

Notes: Add notes, if any.

Excluded: Select Excluded to remove the product from compliance 
calculations. Excluded products cannot be associated with licensed 
products.

New Catalog Product 
Summary

Review the data.
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10.7 Adding Catalog Products to a Licensed Product
To populate a licensed product with the number of purchased licenses, you add catalog products to 
the licensed product’s entitlements. There are two ways to add a catalog product to a licensed 
product’s entitlement:

 Section 10.7.1, “Editing an Entitlement to Add Catalog Products,” on page 100
 Section 10.7.2, “Using the Catalog Products List to Add Catalog Products,” on page 100

10.7.1 Editing an Entitlement to Add Catalog Products

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Licensed Products.

3 Click the licensed product with the entitlement.
4 Click the License Entitlements tab.

5 In the Entitlements panel, click the entitlement to which you want to add catalog products.
6 Click the Proof of Ownership tab.
7 In the Catalog Products panel, click Add.
8 Select the desired catalog products, then click OK to add them to the Catalog Products panel.

The Catalog Products panel displays each catalog product’s Purchase Quantity, which is the 
number of units of the catalog product that you’ve purchased (according to the purchase 
records). It also displays the License Quantity, which is the total number of licenses included in 
the purchased units.

10.7.2 Using the Catalog Products List to Add Catalog Products

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Catalog Products.
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3 Select the catalog products that you want to add to an entitlement.
4 Click Action > Add to Licensed Product to launch the Add Catalog Products to Licensed Product 

Wizard. Complete the wizard by using the information in the following table:

5 If you have not already done so, click Finish to add the catalog products to the entitlement.
In the Catalog Products list, each catalog product you added displays the licensed product and 
entitlement with which it is now associated.

10.8 Creating a Catalog Product Folder
You can create folders in the Catalog Products list to better organize your catalog products. All 
folders are displayed at the top of the list.

1 In ZENworks Control Center, click Asset Management > License Management > Catalog Products to 
display the Catalog Products page.

2 Click New > Folder to display the New Folder dialog box.
3 Fill in the following fields:

Name: Specify a name for the folder. The name must be unique among all other folders and 
catalog products at the same level.
Folder: Browse for and select the folder in which to place the new folder.

Wizard Page Details

Licensed Product Click  to browse for and select the licensed product that contains the 
entitlement to which you want to add the catalog products.

License Entitlement Select the entitlement to which you want to add the catalog products,

Summary Review the data.
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Description: Specify any optional information to identify the folder.
4 Click OK to create the folder.

10.9 Viewing a Catalog Product’s Purchases
You can view a list of the purchase records from which the catalog product draws its purchased 
license quantity.

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Catalog Products.

3 Click a catalog product to display its Details page.
4 Click the Purchases/Licenses tab.

Each purchase record represents a purchase. The Quantity Purchased is the number of units of 
the catalog product that were purchased. The License Quantity is the total number of licenses 
included in the purchase.

10.10 Changing a Catalog Product’s General Information
A catalog product includes general information such as its manufacturer, product name, version, and 
licenses per product package. You can modify this information as necessary.

1 In ZENworks Control Center, click Asset Management > License Management > Catalog Products to 
display the Catalog Products page.

2 In the Catalog Products panel, click the catalog product whose general information you want to 
edit.
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3 Modify the fields as needed:
Manufacturer: Select the product’s manufacturer from the list or enter a new manufacturer.
Product: Select a name for the product from the list or enter a new name.
Product Type: Select the product’s type from the list or enter a new type.
Version: Specify the product version.
Manufacturer Part Number: Specify the part number that the manufacturer assigned to the 
software product package represented by the catalog product.
Reseller SKU: Specify the SKU (stock-keeping unit) that the reseller assigned to the software 
product package represented by the catalog product.
Licensed Product: Displays the licensed product with which the catalog product is associated.
License Entitlement: Displays the entitlement (from the licensed product) with which the 
catalog product is associated.
Licenses Per Package: Specify the number of licenses included in the software product package 
(unit) represented by the catalog product. Changing the licenses per package affects the total 
licenses assigned to the catalog product. For example, if three purchase records include 
purchases of the product and you change the licenses per package from 10 to 20, the total 
licenses for the catalog product increases from 30 to 60.
Notes: Add any information you want to retain with the product.
Excluded: Select this option to exclude the catalog product from compliance calculations. 
Excluded products cannot be added to a licensed product.

4 Click Apply to save the changes.

10.11 Adding Custom Fields to Catalog Products
A catalog product includes predefined fields for recording the product’s manufacturer, name, and 
version. These fields are displayed on the catalog product’s General page.

You can create custom fields to record additional information for catalog products. When you create 
a custom field, it is added to each catalog product’s General page. It is also included in the Create 
New Catalog Product Wizard so that you can populate the field during creation of catalog products.
Working with Catalog Products 103



To create custom fields:

1 In ZENworks Control Center, click Configuration, then click the Asset Management tab.

2 In the Administrator-Defined Fields panel, click Catalog Product to display the Catalog Product 
Fields page.

3 Click New to launch the New Administrator-Defined Field Wizard. Complete the wizard by 
using information from the following table to fill in the fields:

Wizard Page Details

General Information Fill in the following fields:

Type: Filled in by default depending on the type of field you selected.

Name: Specify the field label. This field is required.

Default Value: Specify the default value of the field. The default value 
must be valid for the field’s data type. For example, the default cannot 
be A if the data type is Integer.

Data Type: Select the type of data allowed in the field: Character, 
Integer, Decimal, or Date.

Size: Specify the maximum number of alphanumeric characters 
allowed in the field. This applies only to character-type fields.

Edit Type: Determines how you enter values into the field. There are 
three options you can select:

 Edit: Allows you to enter a value or edit the default value.

 List: Allows you to select a value from a list of values.

 Combo: Allows you to select a value from a list of values or enter 
a new value.

Edit Mask: Select a format from the Edit Mask field list to restrict how a 
value is entered. The choices are phone, time, and currency. This 
applies only to character-type fields.
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4 Click Finish to create the new administrator-defined field.
The field is added to each catalog product’s General page.

10.12 Deleting a Catalog Product
You can remove a catalog product from the Catalog Products list by deleting it. If the catalog product 
is assigned to a licensed product, it (and its license quantity) is removed from the licensed product. 

1 In ZENworks Control Center, click Asset Management > License Management > Catalog Products to 
display the Catalog Products page.

2 In the Catalog Products panel, select the catalog product you want to delete.
3 Click Delete, then click OK to confirm the deletion.

10.13 Moving a Catalog Product
You can move a catalog product from one folder to another in the Catalog Product list. 

1 In ZENworks Control Center, click Asset Management > License Management > Catalog Products to 
display the Catalog Products page.

2 In the Catalog Products panel, select the catalog product you want to move.
3 Click Move to display the Move Catalog Product(s) dialog box.
4 Browse for and select the target folder, then click OK.

Choice List Values This page appears if you chose List or Combo as the Edit Type.

To create a list of choices:

1. Specify a value in the Choice List Values field.

2. Click Add. Repeat for additional values.

Edit: Select a value and click Edit to change it.

Remove: Select a value and click Remove to delete it.

Import: Click Import to open the Import Choice List Values dialog box 
where you can specify a file to import.

Field Summary Review the data. Use the Back button to go back to a previous page to 
edit any fields.

Wizard Page Details
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11 11Working with Software Collections

In some cases, the ZENworks Knowledgebase might not include a discovered product for a software 
suite you own. There are various reasons for this, ranging from the suite not yet being defined in the 
current Knowledgebase to the suite installation not registering as a suite.

A software collection is an administrator-defined suite. You create the software collection and add 
discovered products as members of the collection. When all of the member products are discovered 
on a device, the installation count for the software collection is incremented rather than the count for 
the individual member products. You can assign the software collection to a licensed product just as 
you would assign an individual discovered product or a suite discovered product.

The following sections explain the tasks associated with managing purchase records:

 Section 11.1, “How Software Collection Installations are Counted,” on page 107
 Section 11.2, “Creating a Software Collection,” on page 108
 Section 11.3, “Adding Products to a Software Collection,” on page 108
 Section 11.4, “Deleting a Software Collection,” on page 109
 Section 11.5, “Creating a Software Collection Folder,” on page 109
 Section 11.6, “Moving a Software Collection,” on page 110

11.1 How Software Collection Installations are Counted
A software collection’s member products can be required or non-required. Required member 
products must be found on a device in order for the installation to qualify as a software collection 
installation. Non-required member products, if installed on the machine, are considered part of the 
software collection but are not required to be installed.

Consider the following example. SoftwareCollection includes three member products: 

 ProdA (required)
 ProdB (required)
 ProdC (non-required).

The member products are installed as follows:

 Device1: ProdA, ProdC
 Device2: ProdA, ProdB
 Device3: ProdA, ProdB, ProdC
 Device4: ProdA

The Discovered Products list would show the following:

 SoftwareCollection: 2 installations (Device2, Device3)
 ProdA: 2 installations (Device1, Device4)
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 ProdB: 0 installations
 ProdC: 1 installation (Device1)

11.2 Creating a Software Collection
1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Software Collections.

3 Click New > Software Collection to launch the Create New Software Collection Wizard. Complete 
the wizard by using information from the following table to fill in the fields:

4 If you haven’t already done so, click Finish to create the software collection.
5 Continue with the next section, Adding Products to a Software Collection.

11.3 Adding Products to a Software Collection
1 In the Software Collections list, click the software collection to which you want to add products.
2 Click the Member Products tab.
3 Add discovered products as members of the collection:

3a In the Discovered Products panel, click Add > Installed Discovered Products if you want to see 
only discovered products that are installed on devices in your Management Zone.
or

Wizard Page Details

General Information Fill in the following fields:

Manufacturer: Specify the name of the manufacturer.

Product: Specify the product name.

Version: Specify the product version.

Platform: Specify either Windows or Mac.

Notes: Add notes, if any.

New Software Collection 
Summary

Review the summary data. Click Back to make changes.
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Click Add > Any Discovered Product to see all discovered products included in the 
Knowledgebase.

3b Browse for and select the products you want to add, then click OK to add them to the 
Discovered Products list.

4 Mark the member products as required or non-required.
A software collection’s member products can be required or non-required. By default, member 
products are set as Required when you add them to the list. Required member products must be 
present on a device in order for the installation to qualify as a software collection installation. 
Non-required member products do not need to be present; however, if they are present, their 
installation is counted under the software collection installation rather than an individual 
discovered product installation.
4a To change a required product to non-required, select the product by clicking the check box 

next to it, then click Action > Clear Required.
4b To change a non-required product to required, select the product by clicking the check box 

next to it, then click Action > Set Required.

11.4 Deleting a Software Collection
You can remove a software collection from the Software Collections list by deleting it. If the software 
collection is assigned to a licensed product, it (and its installation quantity) is removed from the 
licensed product.

Deleting a software collection does not delete the discovered products that are members of the 
collection.

1 In ZENworks Control Center, click the Asset Management tab.
2 Click Software Collections.

3 In the Software Collections panel, select the collections you want to delete.
4 Click Delete.

11.5 Creating a Software Collection Folder
You can create folders in the Software Collections list to better organize your software collections. All 
folders are displayed at the top of the list.

1 In ZENworks Control Center, click Asset Management > License Management > Software Collections 
to display the Software Collections page.
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2 Click New > Folder to display the New Folder dialog box.
3 Fill in the following fields:

Name: Specify a name for the folder. The name must be unique among all other folders and 
software collections at the same level.
Folder: Browse for and select the folder in which to place the new folder.
Description: Specify any optional information to identify the folder.

4 Click OK to create the folder.

11.6 Moving a Software Collection
You can move a software collection from one folder to another in the Software Collections list. 

1 In ZENworks Control Center, click the Asset Management tab.
2 Click Software Collections.

3 In the Software Collections panel, select the collections you want to move.
4 Click Move.
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5 Select a target folder in the Move Software Collection(s) dialog box.
6 Click OK.
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II IILicense Allocation

Novell ZENworks Asset Management lets you allocate licenses within your organization to track 
ownership and distribution of the licenses. 

 Chapter 12, “License Allocation Concepts,” on page 115
 Chapter 13, “Preparing Demographic Data,” on page 117
 Chapter 14, “Allocating Licenses,” on page 121
 Chapter 15, “Working with License Allocations,” on page 129
 Chapter 16, “Generating Allocation Reports,” on page 133
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12 12License Allocation Concepts

Allocating licenses to devices, departments, sites, and cost centers lets you track and maintain license 
ownership within your organization.

The following sections introduce the concepts you should understand to effectively use Asset 
Management to allocate licenses:

 Section 12.1, “Allocation vs. Compliance,” on page 115
 Section 12.2, “Device Allocations and Demographic Allocations,” on page 115

12.1 Allocation vs. Compliance
License allocation is an accounting tool; it assigns licenses to devices, departments, sites, or cost centers 
to track license distribution and ownership. License compliance is an evaluation tool; it compares a 
product’s license quantities against its installation quantities to determine a compliance status.

With the exception that both are based on licensed products, license allocation and license 
compliance are independent of one another. Allocating licenses does not affect the number of 
purchased licenses or installations for a product, and therefore does not affect the license compliance 
status for the product.

For example, assume that DepartmentQ purchased 30 licenses of ProductA. However, DepartmentQ 
has 35 installations of the product, which means that the license compliance status for ProductA is 
undercompliant (too few licenses for the number of installations). You decide to allocate 35 licenses to 
DepartmentQ, which you can do even though you only have 30 purchased licenses. The compliance 
status remains undercompliant because the purchased licenses, not the allocated licenses, are used 
when calculating compliance.

In some instances, license allocations might help you resolve compliance problems. For example, you 
notice that Product A is undercompliant by four licenses. You check the license allocation 
information for Product A and see that 14 licenses are allocated to DepartmentQ and 14 devices 
associated with DepartmentQ have Product A installed. At the same time, you see that 12 licenses are 
allocated to DepartmentZ but 16 devices associated with DepartmentZ have Product A installed. You 
know that you need to work with DepartmentZ to resolve the compliance problem.

12.2 Device Allocations and Demographic Allocations
You can allocate licenses to devices and to demographics (sites, departments, or cost centers).

A device allocation is the assignment of a license to a specific device. The device can have the product 
installed or not installed. For example, you purchase 10 licenses of ProductA. You can allocate the 
licenses to the target devices before ProductA is even installed on the devices.

A demographic allocation is the assignment of one or more licenses to a site, department, or cost center. 
Any device that is assigned the demographic and has the product installed shows up as an 
installation associated with the allocation. For example, you purchase 15 licenses of ProductA and 
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allocate them to DepartmentQ. There are 20 devices assigned to DepartmentQ. Of those 20 devices, 
12 have ProductA installed. The result is that the DepartmentQ allocation shows 15 allocated licenses 
with 12 installations.

Effective implementation of demographic allocations requires that the devices in your Management 
Zone include the correct demographic data. This data is stored as part of the device’s Inventory data; 
there are several ways to ensure that devices include the correct data. These methods are discussed in 
Chapter 13, “Preparing Demographic Data,” on page 117.

A single licensed product can include both types of allocations. For example, DepartmentQ 
purchases 15 ProductA licenses. At the same time, your IT organization purchases 10 ProductA 
licenses for miscellaneous use throughout the organization. You allocate 15 licenses to DepartmentQ 
and then allocate individual licenses (from your pool of 10 IT licenses) to the devices of any other 
users who request to install ProductA.

For information about creating allocations, see Chapter 14, “Allocating Licenses,” on page 121.
116 ZENworks 11 SP3 Asset Management Reference



13 13Preparing Demographic Data

Before you can allocate licenses based on demographic data (departments, sites, or cost centers), you 
need to ensure that your devices and purchase records contain the appropriate demographic data. 
The following sections provide information:

 Section 13.1, “Adding Demographic Data to Devices,” on page 117
 Section 13.2, “Adding Demographic Data to Purchase Records,” on page 118
 Section 13.3, “Adding Demographic Data to Purchase Record Import Files,” on page 119
 Section 13.4, “Making Demographic Data Consistent Between Devices and Purchase Records,” 

on page 120

If you plan to allocate licenses directly to devices, you can ignore demographic data and continue 
with Chapter 14, “Allocating Licenses,” on page 121.

13.1 Adding Demographic Data to Devices
Each device’s Inventory data contains three demographic fields: Site, Department, and Cost Center. 
Adding this demographic data to devices does the following:

 Creates the list of demographics (for example, Site1, CostCenterA, or Department12) to which 
licenses can be allocated. When you allocate licenses, you can allocate them only to sites, 
departments, and cost centers that already exist in Inventory device data or purchase record 
data. 

 Enables a device’s installations to be tracked against the license allocations. For example, you 
allocate 10 ProductA licenses to Site1. If Device1 is associated with Site1, Device1’s installation of 
ProductA is tracked against Site1’s allocations. Otherwise, it is not.

 Enables you to use the Initialize Allocations Wizard to create a licensed product’s initial 
allocations based on the devices’ demographic data. For example, assume that you are 
initializing license allocations for ProductA based on the Site demographic. Device1, Device2, 
and Device3 have ProductA installed. Device1 and Device2 are assigned to Site1 and Device3 is 
assigned to Site2. The wizard allocates two licenses to Site1 (for Device1 and Device2) and one 
license to Site2 (for Device3).

If all your license allocations will use the same demographic (Site, Department, or Cost Center), you 
can add only that demographic data to each device. For example, if all demographic allocations are 
going to be Department allocations, you only need to add a department to each device. If you will 
have a mixture of demographic allocations, you should add a site, department, and cost center to 
each device.

There are three ways you can add demographic data to a device: 

 Use ZENworks Control Center to manually enter the data for each device. To do so, go to a 
device’s Inventory page, click the Detailed Hardware/Software Inventory link, click Edit (at the 
bottom of the page), then provide information in the Site, Department, and Cost Center fields.
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 Distribute an electronic data collection form to individuals and have them supply the 
demographic data. For instructions, see “Scanning Demographic Data” in the ZENworks 11 SP3 
Asset Inventory Reference.

 Import demographic data from device objects in your LDAP directory. For instructions, see 
“Importing Demographic Data” in the ZENworks 11 SP3 Asset Inventory Reference.

13.2 Adding Demographic Data to Purchase Records
Adding demographic data to purchase records is optional. You need to do so only if you want to do 
either of the following:

 Use the purchase record data to create the list of demographics (for example, Site1, 
CostCenterA, or Department12) to which licenses can be allocated. When you allocate licenses, 
you can only allocate them to sites, departments, and cost centers that already exist in device or 
purchase record data.

 Use the Initialize Allocations Wizard to create a licensed product’s initial demographic 
allocations based on the demographic data in the purchase records. For example, assume that 
you are initializing license allocations for ProductA based on the Department demographic. 
PurchaseRecord1 includes 10 ProductA licenses assigned to DepartmentQ. PurchaseRecord2 
includes 20 ProductA licenses assigned to DepartmentZ. The wizard allocates 10 licenses to 
DepartmentQ and 20 licenses to DepartmentZ.

If all your license allocations will use the same demographic (Site, Department, or Cost Center), you 
can assign only that demographic data to each purchase record. For example, if all demographic 
allocations are going to be Department allocations, you only need to assign a department to each 
purchase record. If you will have a mixture of demographic allocations, you should assign a site, 
department, and cost center to each purchase record.

To add demographic data to an existing purchase record:

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Purchase Records.

3 Click the purchase record to which you want to add demographic data.
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4 Click the Purchase Details tab.

You add the demographic data to the purchase detail associated with the product.
5 Select the check box next to the purchase record detail, then click Edit.
6 Edit the Cost Center, Department, and Site fields to supply the appropriate data. 

For each field, you can select an existing value from the list or you can type a new value.
7 Click OK to save the changes.

13.3 Adding Demographic Data to Purchase Record Import Files
Adding demographic data to purchase record import files is optional. You need to do so only if you 
want to automatically update existing demographic allocation counts for a licensed product when 
you import a new purchase record containing the product or if you want to initialize allocations 
using purchase records.

For example, assume that ProductA has a DepartmentQ allocation of 20 licenses. You import another 
purchase record that includes 15 ProductA licenses for DepartmentQ. The additional 15 licenses are 
automatically reflected in the DepartmentQ allocation.

Each product line item (or detail) in an import file includes Site, Department, and Cost Center fields. 
These are the fields that must contain the appropriate information. For information about editing an 
import file, see Section 9.9, “Working with Import Files,” on page 89.
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13.4 Making Demographic Data Consistent Between Devices 
and Purchase Records
As demographic data is added to devices and purchase records, different values might be used to 
represent the same site, department, or cost center. For example, the same site might be represented 
by Site1 in the Inventory device data and SiteOne in purchase record data.

Inconsistent data can cause problems when Asset Management tries to match product installations to 
demographic allocations. For example, if you create a SiteOne allocation from the purchase record 
demographic data, any product installations on a device assigned to Site1 are not matched to the 
SiteOne allocation. 

In order to synchronize your demographic data, you can replace your purchase records demographic 
values with values from your Inventory device data. For example, you could replace all occurrences 
of SiteOne in purchase records with Site1.

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Purchase Records.

3 In the Purchase Records list, click Action, then click Replace Site Demographic, Replace Department 
Demographic, or Replace Cost Center Demographic.

4 In the Demographic Value dialog box, fill in the following fields:
Demographic value from Purchase Records: Select the value you want to replace in your 
purchase records. The list includes an empty value; if you select the empty value, all empty 
fields for the demographic (Site, Department, or Cost Center) are replaced.
Demographic value from Inventory: Select the replacement value.

5 Click OK.
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14 14Allocating Licenses

There are two methods you can use to allocate a product’s licenses to devices or demographics (sites, 
departments, or cost centers). You can use the Initialize Allocations Wizard to automatically create 
allocations based on device and purchase record data available in your Asset Management system. 
Or, you can manually create the allocations. Instructions for both methods are included in the 
following sections:

 Section 14.1, “Initializing Allocations,” on page 121
 Section 14.2, “Manually Adding Demographic Allocations,” on page 124
 Section 14.3, “Manually Adding Device Allocations,” on page 125

14.1 Initializing Allocations
You can use the Initialize Allocations Wizard to create either device allocations or demographic 
allocations for a licensed product. After creating the initial allocations you can add additional 
allocations or modify the initial allocations.

If you plan to create demographic allocations, you should ensure that your devices and purchase 
records include the correct demographic data. For information, see Chapter 13, “Preparing 
Demographic Data,” on page 117.

To initialize allocations for a licensed product:

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Licensed Products.

3 In the Licensed Products list, select the check box next to the licensed product whose allocations 
you want to initialize.
You can select multiple products. If you do so, all selected products are initialized with the same 
type of allocation (device or demographic) from the same data source (Inventory device data or 
purchase records). 

4 Click Action > Initialize Allocations, then click OK to acknowledge that any existing allocations for 
the selected products will be removed. 
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5 Complete the Initialize Allocations Wizard by using information from the following table to fill 
in the fields.

6 If you have not already done so, click Finish to create the license allocations.
7 To see the license allocations, locate the licensed product in the Licensed Products list and click 

the number in the Allocated Quantity column.
Demographic allocations created by the wizard are listed in the Demographic Allocations panel.

Wizard Page Details

Allocation Type Select Device if you want to allocate a license to each device that has 
the product installed.

Select Demographic, then select Site, Department, or Cost Center if 
you want to allocate licenses to sites, departments, or cost centers. 

Allocation Data Source If you are creating device allocations, the Initialize from Inventory 
option is the only enabled option. The wizard searches the Inventory 
data to find devices that have the product installed and then allocates a 
license to each device. 

If you are creating demographic allocations, select the data source you 
want to use to create the license allocations: 

 Initialize from Purchase Records: Allocates licenses based on 
demographic data found in your purchase records.

For example, assume that you are initializing license allocations 
for ProductA based on the Department demographic. 
PurchaseRecord1 includes 10 ProductA licenses assigned to 
DepartmentQ. PurchaseRecord2 includes 20 ProductA licenses 
assigned to DepartmentZ. For ProductA, the wizard allocates 10 
licenses to DepartmentQ and 20 licenses to DepartmentZ.

 Initialize from Inventory: Allocates licenses based on 
demographic data associated with Inventory device data. 

For example, assume that you are initializing license allocations 
for ProductA based on the Site demographic. Device1, Device2, 
and Device3 have ProductA installed. Device1 and Device2 are 
assigned to Site1 and Device3 is assigned to Site2. The wizard 
allocates two licenses to Site1 (for Device1 and Device2) and one 
license to Site 2 (for Device3).

 Update License Allocations Based on Demographic Data in 
Future Purchase Record Imports: When importing future 
purchase records, updates the allocated license quantity if the 
purchase record contains the appropriate demographic data.

For example, assume that you import another purchase record 
that includes ProductA licenses that are assigned to 
DepartmentQ. The additional licenses are automatically reflected 
in the DepartmentQ demographic allocation.

Also creates new allocations if necessary. For example, if a 
purchase record includes ProductA licenses that are assigned to 
a DepartmentZ (a new department not listed in ProductA’s 
allocations), a new allocation for DepartmentZ is created.

Initialize Allocations 
Summary

Review your data.
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The following information is provided for each demographic allocation: 
 Device Count: The number of devices assigned to the demographic. Click the number to 

display a list of the devices.
 Allocated Quantity: The number of licenses allocated to the demographic. You can change 

this number to allocate more or fewer licenses.
 Installed Quantity: The number of product installations on devices assigned to the 

demographic.
 Variance: The difference between the number of allocated licenses and the number of 

product installations assigned to the demographic:
Allocated Quantity - Installed Quantity = Variance

A negative variance indicates more product installations than allocated licenses, and a 
positive variance indicates more allocated licenses than product installations.

Device allocations created by the wizard are listed in the Device Allocations panel.

The following information is provided for each device allocation: 
 Machine Name, Login Name, and IP Address: Standard information about the device, 

including the login name of the user who was logged in at the time the device was 
inventoried.

 Site, Department, Cost Center: Demographic data about the device. If one or more of the 
fields is empty, the device’s inventory data does not contain that information.

 Installed Quantity: The number of installations of the licensed product on the device. This 
should typically be 1.

 Duplicate Allocation: Includes a check mark if the device’s installation is also included in a 
demographic allocation. 

 Installations with No Allocations: Displays the number of installations that are not 
allocated a license either through a demographic allocation or a device allocation. Click the 
number to display the list of installations.

8 If necessary, add additional allocations or modify the existing allocations. Refer to the following 
sections for instructions:
 Section 14.2, “Manually Adding Demographic Allocations,” on page 124
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 Section 15.1, “Adjusting the License Quantity for a Demographic Allocation,” on page 129
 Section 14.3, “Manually Adding Device Allocations,” on page 125
 Section 15.2, “Removing Allocations,” on page 130

If you find that adding additional demographic data to devices or purchase records might result 
in better initial allocations for the product, you can add the data and then run the Initialize 
Allocations Wizard again. Any existing allocations are removed before the new ones are added. 

14.2 Manually Adding Demographic Allocations
You can allocate a product’s licenses to sites, departments, or cost centers. The demographic value 
(for example, Site1, DepartmentQ, or Cost Center123) must already exist as a value in your Inventory 
device data or purchase records data.

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Licensed Products.

3 In the Licensed Products list, click the licensed product for which you want to allocate licenses.
4 By default, only device allocation is enabled to track ownership for product licenses. To allocate 

licenses to demographics a user has to perform the following steps to enable demographic 
allocation for the product:
4a Click the General tab.
4b In the License Allocation Settings panel, fill in the following fields:

Enable demographic allocations: Select this option.
Demographic allocation type: All demographic allocations for a single licensed product 
must be of the same type. Select the type (Site, Department, Cost Center) you want to use for 
this product.
Update license allocations with demographic data from future purchase record imports: 
Select this option if, when importing future purchase records for the product, you want to 
automatically update the allocated license quantity based on the purchase record’s 
demographic data.
For example, assume that the product is using Department allocations. You import a 
purchase record that includes licenses assigned to DepartmentQ. The licenses are added as 
a DepartmentQ demographic allocation.
Also creates new allocations if necessary. For example, if a purchase record includes 
ProductA licenses that are assigned to a DepartmentZ (a new department not listed in 
ProductA’s allocations), a new allocation for DepartmentZ is created.
Allocated Quantity: Displays the total number of allocated licenses, either to devices or to 
demographics. 

4c Click Apply to save any changes.
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5 Click the License Allocations tab.

6 In the Demographic Allocations panel, click Add, then fill in the following fields:
Demographic: Select the desired demographic (site, department, or cost center) from the list.
Allocated Quantity: Specify the number of licenses to allocate to the demographic.

7 Click OK to add the allocation to the list.
The following information is provided for the allocation: 
 Device Count: The number of devices assigned to the demographic. Click the number to 

display a list of the devices.
 Allocated Quantity: The number of licenses allocated to the demographic. You can change 

this number to allocate more or fewer licenses.
 Installed Quantity: The number of product installations on devices assigned to the 

demographic.
 Variance: The difference between the number of allocated licenses and the number of 

product installations assigned to the demographic:
Allocated Quantity - Installed Quantity = Variance

A negative variance indicates more product installations than allocated licenses, and a 
positive variance indicates more allocated licenses than product installations.

14.3 Manually Adding Device Allocations
You can allocate licenses to a specific devices. The devices can have the product installed or not 
installed. For example, you purchase 10 licenses of ProductA. You can allocate the licenses to the 
target devices before ProductA is even installed on the devices. 

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Licensed Products.
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3 In the Licensed Products list, click the licensed product for which you want to allocate licenses.
4 Click the License Allocations tab.

5 (Optional) To see which devices have the product installed but do not have an allocated license, 
click the Installations with no allocations number in the Device Allocations panel.

6 Click Add > Devices with Product Installed if the device you want to allocate a license to has the 
product installed.
or
Click Add > Any Devices if the device you want to allocate a license to does not have the product 
installed.
The Search for Device dialog box is displayed. 

7 In the Device Type field, select whether you want to search Managed Devices, Inventoried Devices, 
Managed or Inventoried Devices, ZAM Migrated Devices, or All.
If you are not sure of the device type, select All.

8 To limit the search, use the filters to create the search criteria.
If you don’t create filters, all devices (or all devices with the product installed) are displayed, up 
to the maximum display number.

9 Specify the maximum number of devices you want the search to display. 
10 Select the columns you want displayed in the resulting search dialog box. Control-click to select 

multiple fields.
11 Click Search to display a Select Device dialog box that lists the search results.
12 Select the devices you want to allocate licenses to, then click OK.
126 ZENworks 11 SP3 Asset Management Reference



The following information is provided for the allocation: 
 Machine Name, Login Name, and IP Address: Standard information about the device, 

including the login name of the user who was logged in at the time the device was 
inventoried.

 Site, Department, Cost Center: Demographic data about the device. If one or more of the 
fields is empty, the device’s inventory data does not contain that information.

 Installed Quantity: The number of installations of the licensed product on the device. This 
should typically be 1.

 Duplicate Allocation: Includes a check mark if the device’s installation is also included in a 
demographic allocation. 

 Installations with No Allocations: Displays the number of installations that are not 
allocated a license either through a demographic allocation or a device allocation. Click the 
number to display the list of installations.
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15 15Working with License Allocations

The following sections help you manage existing license allocations. For information about adding 
license allocations, see Chapter 14, “Allocating Licenses,” on page 121.

 Section 15.1, “Adjusting the License Quantity for a Demographic Allocation,” on page 129
 Section 15.2, “Removing Allocations,” on page 130

15.1 Adjusting the License Quantity for a Demographic 
Allocation
You can manually increase or decrease the number of licenses allocated to a site, department, or cost 
center. 

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Licensed Products.

3 In the Licensed Products list, click the licensed product whose license allocations you want to 
adjust.

4 Click the License Allocations tab.
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5 Locate the allocation in the Demographic Allocations panel, then change the number in the 
Allocated Quantity column.

6 Click Apply to save the changes.

15.2 Removing Allocations
1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Licensed Products.

3 In the Licensed Products list, click the licensed product from which you want to remove allocate 
licenses.

4 Click the License Allocations tab.
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5 Select the check box next to the allocation you want to remove, then click Remove.
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16 16Generating Allocation Reports

ZENworks Asset Management includes a variety of reports that you can generate to view allocation 
and allocation-related data. In addition to viewing predefined reports, you can create custom reports 
and export reports to several file formats.
Generating Allocation Reports 133



134 ZENworks 11 SP3 Asset Management Reference



III IIISoftware Usage

Novell ZENworks Asset Management lets you track software usage on individual devices within 
your organization. Knowing the demand for particular applications can help you better manage the 
number of licenses you need.

 Chapter 17, “Software Usage Concepts,” on page 137
 Chapter 18, “Configuring Usage Settings,” on page 139
 Chapter 19, “Setting Up Web Applications,” on page 141
 Chapter 20, “Monitoring Usage,” on page 143
 Chapter 21, “Generating Usage Reports,” on page 147
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17 17Software Usage Concepts

Tracking application use in an organization can be useful yet challenging. Knowing the demand for 
an application can help you better predict how many licenses you really need. Does it make sense to 
order 10 new license for ProductA when four installations of the product are not being actively used? 
Or does it make more sense to reallocate licenses and order fewer new licenses?

ZENworks Asset Management helps you make better decisions by tracking software usage on 
devices throughout your Management Zone. You can view basic usage data directly in ZENworks 
Control Center or generate detailed reports for analysis.

The following sections introduce the concepts you should understand to effectively use Asset 
Management to monitor software usage:

 Section 17.1, “Software That Is Tracked,” on page 137
 Section 17.2, “When Usage Data Is Collected,” on page 137
 Section 17.3, “Basic Usage Data vs. Detailed Usage Data,” on page 138

17.1 Software That Is Tracked
Asset Management tracks usage for the following software:

 Installed Discovered Products: Software products, defined in the ZENworks Knowledgebase, 
or in the Add or Remove Programs panelthat are installed on devices in your Management 
Zone. 

 Local Software Products: Installed software products that you define because they are not 
registered as discovered products in the ZENworks Knowledgebase. In essence, they are 
administrator-defined discovered products. When they are defined, they are displayed in the 
Discovered Products list.

 Software Files: Installed software files that are not included in the ZENworks Knowledgebase 
and for which no local software products have been created.

 Web Applications: Web applications or pages that are hosted on either internal or external Web 
sites. Web applications are not discovered automatically; you must create them.

Asset Management tracks executable (.exe) files to collect usage data. Therefore, it does not track 
thin-client applications launched from Citrix servers and Windows Terminal Servers. It tracks the 
thin-client usage itself, just not the applications run within the thin client.

17.2 When Usage Data Is Collected
Usage data is collected from devices during software inventory scans. You can schedule regular 
software inventory scans to control how often usage data is collected. For instructions, see “Scanning 
Managed Devices” in the ZENworks 11 SP3 Asset Inventory Reference.
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17.3 Basic Usage Data vs. Detailed Usage Data
You can view basic usage data for a product, such as number of active installations and hours used, 
through various ZENworks Control Center pages (see Chapter 20, “Monitoring Usage,” on 
page 143).

For detailed information, however, you must generate usage reports. Usage reports let you analyze 
usage data from multiple perspectives, such as the following:

 Usage by product type (local application, network server application, and Web application).
 Usage by product, user, or device.
 Usage over a specific time period.

For information about generating reports, see Chapter 21, “Generating Usage Reports,” on page 147.
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18 18Configuring Usage Settings

There are two ZENworks Management Zone settings related to software usage. One setting enables 
software usage to be collected and the other setting determines whether usage data is displayed in 
the ZENworks Control Center interface or only in software usage reports.

To configure the settings:

1 In the ZENworks Control Center, click the Configuration tab.
2 In the Management Zone Settings panel, click Asset Management to display the settings.
3 Click Usage Monitoring, make sure that the Enable Usage Monitoring option is selected, then click 

OK.
If this option is not enabled, no usage statistics are collected from devices.

4 Click Usage Display.
You can decide whether or not to show usage data on License Management pages in ZENworks 
Control Center. Displaying usage data can cause the pages to load more slowly while the usage 
data is retrieved. For information about where usage data is displayed, see Chapter 20, 
“Monitoring Usage,” on page 143.

5 If you want usage data displayed on the License Management pages in ZENworks Control 
Center, deselect the Do not show usage on License Management pages option.
or
If you only want usage data available by generating software usage reports, select the Do not 
show usage on License Management pages option. 

6 Click OK to save your changes.
Configuring Usage Settings 139



140 ZENworks 11 SP3 Asset Management Reference



19 19Setting Up Web Applications

ZENworks Asset Management lets you monitor the usage of Web-based applications or pages. You 
must define the Web applications before you can generate usage reports. 

1 In ZENworks Control Center, click the Configuration tab.
2 Click the Asset Management tab to display the Web Applications panel.

3 In the Web Applications panel, click New to launch the Create New Web Application Wizard. 
Complete the wizard by using the information in the following table to fill in the fields.
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4 Click Finish to add the application to the Web Applications list.

NOTE: The reporting for Web application usage and Windows application usage is not different. 

You can monitor the usage of any application in two ways:

 If you keep an application open for a day, the application usage for it is reported during the next 
day’s scan.

 If you open an application and close it on the same day, the application usage for that 
application is reported during the next scan which could either be on the same day or on the 
next day.

Web Application Usage in Browsers

Calculating the Web application usage differs for Internet Explorer and Firefox browsers. If you open 
multiple tabs in a Firefox browser, only the tab that is currently being viewed or that has input focus 
is monitored for usage. The tabs that are not in active usage are not monitored. However, in Internet 
Explorer, the run-time usage is calculated for all open tabs, whether they are in active usage or not.

Wizard Page Details

Application Naming Fill in the following fields:

Manufacturer: The manufacturer of the Web application.

Application: The application name.

Version: The version of the application.

Application Recognition A Web application is recognized by the text that is displayed in the 
browser window’s title bar, excluding the browser name, when viewing 
the application. You can specify one or more titles to associate with the 
Web application. 

A Web application is considered to be in use until all windows you have 
defined are closed. 

1. In the Window Title(s) field, specify the title bar text that defines 
the application.

You can use * and ? wildcards in your window titles. The * 
wildcard represents any number of characters, The ? wildcard 
represents a single character.

For example, you could create a single Web application for all 
Google pages with the window title *Google*, or you could create 
separate applications for Google Search and Google Maps with 
*Google Search* and *Google Maps*.

2. Click Add.

3. Repeat for additional values. Use the Edit and Remove buttons to 
change or delete values.

Summary Review your data. Use the Back button to edit the specified values.
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20 20Monitoring Usage

There a several locations in ZENworks Control Center where you can view basic usage data for 
products. The following sections cover these locations:

 Section 20.1, “Discovered Products List,” on page 143
 Section 20.2, “Licensed Product’s Compliance Status Page,” on page 143
 Section 20.3, “Discovered Product’s Installation/Consumption Page,” on page 144

20.1 Discovered Products List
The Active Usage column in the Discovered Products list displays the number of installations of a 
product that have been used during the current usage period.

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Discovered Products.

You can do the following to manipulate the data in the list:
 The Usage Period field, displayed above the list, determines the time period for the usage 

data. To change the time period, click Action > Update Usage Time Period, select a new usage 
period, then click OK.

 Filter the list to display only the products that have been used. In the Search panel, set the 
Usage Status field to With Usage, then click Search.

If you want to see the usage hours for each installation, you can drill down into the discovered 
product. See “Discovered Product’s Installation/Consumption Page” on page 144. 

20.2 Licensed Product’s Compliance Status Page
A licensed product’s Compliance Status page shows the same usage data as the Discovered Products 
list. The difference is that the Compliance Status page displays only the discovered products 
assigned to the licensed product.
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To access a licensed product’s Compliance Status page:

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Licensed Products.

3 Click the licensed product’s status icon ( ., , or ) to display the product’s Compliance Status 
page.

The Active Usage column in the License Consumption (Consumption Data Source: Inventory) 
panel displays the number of installations of a product that have been used during the current 
usage period.
The Usage Period field, displayed above the License Consumption panel, determines the time 
period for the usage data. To change the time period, click Action > Update Usage Time Period, 
select a new usage period, then click OK.

20.3 Discovered Product’s Installation/Consumption Page
A discovered product’s Installation/Consumption page shows the number of usage hours for each 
installation.
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To access a discovered product’s Installation/Consumption page:

1 In ZENworks Control Center, click the Asset Management tab.
2 On the License Management page, click Discovered Products.

3 Click the discovered product’s Installed Quantity number to display the product’s Installation/
Consumption page.

In the Installations panel, the Hours Active column indicates the number of hours the product has 
been used on the device during the current usage period. 
The Usage Period field, displayed above the list, determines the time period for the usage data. To 
change the time period, click Action > Update Usage Time Period, select a new usage period, then 
click OK.
You can also filter the list to display only the products that have been used. In the Search panel, 
set the Usage Status field to With Usage, then click Search.
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21 21Generating Usage Reports

ZENworks Asset Management includes a variety of reports that you can generate to view usage data. 
In addition to viewing predefined reports, you can create custom reports and export reports to 
several file formats.

The compliance report information is combined with the license management and contract 
management report information in Part VI, “Reports,” on page 179. The following list provides direct 
links to usage report sections:

 Descriptions for all standard and custom reports: Chapter 29, “Standard and Custom Report 
Descriptions,” on page 181.

 How to run standard reports: Chapter 32, “Working with Standard Reports,” on page 191.
 How to create and generate custom reports: Chapter 33, “Working with Custom Reports,” on 

page 195
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IV IVContracts

Novell ZENworks Asset Management lets you manage contracts for your organization’s assets. 

 Chapter 22, “Creating New Contracts,” on page 151
 Chapter 23, “Working with Existing Contracts,” on page 155
 Chapter 24, “Working with Date Notifications,” on page 159
 Chapter 25, “Working with Import Files,” on page 165
 Chapter 26, “Generating Contract Reports,” on page 169
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22 22Creating New Contracts

ZENworks Asset Management lets you create contract records (typically referred to simply as 
contracts) for your organization’s assets. You can then monitor the status of the contracts and generate 
reports showing various contract details.

To create a contract:

1 In ZENworks Control Center, click the Asset Management tab.
2 Click the Contract Management tab.

3 Click Contracts.
4 In the Contracts panel, click New > Contract to launch the Create New Contract Wizard. 

Complete the wizard by using information from the following table to fill in the fields:
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5 On the New Contract Summary page, select Define Additional Properties, then click Finish.
The contract is created and displayed.

Wizard Page Details

General Contract 
Information

Fill in the following fields:

Contract ID: Specify a unique identifier for the contract. Required.

Name: Specify a descriptive name for the contract. Required.

Description: Provide any additional text to identify the contract.

Total Cost: Specify the total cost of the contract from start date to 
current end date. This field forms the basis for the contract’s financial 
information, including annualized cost and cost per association (asset, 
user, department, and so forth).

Parent Contract: If this contract has a child relationship to another 
contract, click the Browse button to find and select the parent contract, 
then click OK.

Terms and Conditions: Specify any terms and conditions.

Contract Type: Select one of the fourteen predefined contract types or 
type a custom one of your own.

Status: Select Pending, Active, or Expired. You can also type a custom 
status of your own.

Original Start Date: Click  to select the beginning date for the 
contract. This date and the end date are required for annualized 
financial information.

Current End Date: Click  to select the current end date for the 
contract. If the contract never ends, select the Evergreen option. This 
date and the start date are required for annualized financial 
information.

Renewal Option: Select Yes if the contract includes an option to 
renew. Otherwise, select No.

Renewal Provision: Specify any renewal provision.

Notice Date: If the contract includes a notice, click  to select the 
notice date.

Notice Description: Specify a description for the notice.

Vendor Information Specify the vendor information in the fields. For each field, select an 
existing value or type a new value.

Lease This page is displayed only for Lease contracts. Specify the lease 
information for the contract.

New Contract Summary Review the information you entered. Use the Back button to go back.
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6 Add the desired contract information by clicking a tab and filling in the fields. Each tab is 
described below.
General: Add basic information for the contract. In addition to modifying the information 
provided when the contract was created, you can set up e-mail notifications for the start, end, 
and notice dates. For instructions, see Chapter 24, “Working with Date Notifications,” on 
page 159.
Vendor: Add vendor information for the contract. You can modify the fields if necessary.
Financial: This is a non-editable page that displays the contract’s financial data. The data is 
calculated from information provided on the other pages.
 Total Cost: This data requires that the Total Cost be defined on the General page.
 Total Cost per Item: This is displayed when the Item is included on the Relationships page. 

For example, if you have associated the contract with license entitlements on the 
Relationships page, the Per Licensed Product field displays the total cost per licensed 
product.

 Annualized Cost: This data requires that an Original Start Date and Current End Date be 
defined on the General page.

 Annualized Cost per Item: This is displayed if the Item is included on the Relationships 
page. For example, if you have associated the contract with license entitlements on the 
Relationships page, the Per Licensed Product field displays the annualized cost per licensed 
product.

SLA: Add Service Level Agreements for the contract. For each SLA you add, you can include the 
service level metric, actual service level, start date, and end date. You can also configure e-mail 
notifications for the start and end dates. For instructions, see Chapter 24, “Working with Date 
Notifications,” on page 159.
Lease: Add lease information for the contract. For each of the date fields, you can configure e-
mail notifications. For instructions, see Chapter 24, “Working with Date Notifications,” on 
page 159.
Documents: Attach documents to the contract. This could be an electronic copy of the contract 
or other supporting documents. The document must already have been added to the Asset 
Management system. For more information about adding documents, see Section 23.5, “Adding 
Documents to Contracts,” on page 158.
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Renewals: Renew the contract by adding the renewal date and new end date. Each renewal 
record is added to the Renewal History list.
Relationships: Associate the contract with devices, users, licensed products, and demographics 
(sites, departments, and cost centers).
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23 23Working with Existing Contracts

The following sections explain the tasks associated with managing existing contracts. For 
information about creating new contracts, see Chapter 22, “Creating New Contracts,” on page 151.

 Section 23.1, “Viewing the Contracts List,” on page 155
 Section 23.2, “Filtering the Contracts List,” on page 156
 Section 23.3, “Creating a Contracts Folder,” on page 157
 Section 23.4, “Copying an Existing Contract,” on page 157
 Section 23.5, “Adding Documents to Contracts,” on page 158

23.1 Viewing the Contracts List
You can view a list of all of your contracts. The list provides general information about each contract, 
such as its status, start date, and end date.

1 In ZENworks Control Center, click the Asset Management tab.
2 Click the Contract Management tab, then click Contracts.

The list provides the following information for each contract:
Contract ID: The identification number given to the contract. You can click the contract ID to 
display the contract’s details.
Name: The descriptive name given to the contract. 
Type: The type of contract (for example, Lease, SLA, or Technical Support).
Status: The status of the contract. The status changes automatically depending on the current 
date and the contract’s start and end dates.
 Pending: The current date is before the start date.
 Active The current date falls between the start and end dates.
 Expired: The current date is after the end date.

Start Date: The first effective date for the contract.
End Date: The last effective date for the contract.
Parent Contract ID: If the contract has been assigned a child relationship with another contract, 
this is the ID of the parent contract.
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23.2 Filtering the Contracts List
You can filter the Contracts list to display only the contracts that meet certain criteria. 

1 In ZENworks Control Center, click the Asset Management tab.
2 Click the Contract Management tab, then click Contracts.

3 In the Search panel (located next to the Contracts panel), specify the criteria to use for the filter. 
A contract must match all criteria to be displayed.
Contract ID: Specify the text that the contract ID (or folder name) must include. This is a partial 
match field that is case-insensitive. If the text you enter is included in any part of a contract ID, 
the contract matches the criteria.
Type: Select whether you want to match folders, contracts, or both.
Contract Type: Select a specific contract type, or select Any to match any contract type. 
Contract Status: Select one of the following to match:
 Any: Ignore the contract status. Match any contract.
 Active: Match contracts that are currently within their start date and end date.
 Expired: Match contracts that have passed their end date.
 Pending: Match contracts whose start date is in the future.

Expiration Status: Select one of the following to match: 
 Any: Ignore the expiration status. Match any contract.
 Expired: Match contracts that have passed their end date.
 Expiring within 60 Days: Match contracts with end dates that are within 60 days of the 

current date.
 Not Expiring within 60 Days: Match contracts with end dates that are beyond 60 days of the 

current date.
Program Name: Select a specific vendor program name, or select Any to match any program 
name.
Current End Date: Select one of the following to match:
 Any: Ignore the end date. Match any contract.

 On: Match contracts with end dates that are the same as the date you select. Click  to 
select the date.

 Before: Match contracts with end dates that are before the date you select. Click  to select 
the date.

 After: Match contracts with end dates that are after the date you select. Click  to select the 
date.

Contract Field: Select one of the listed fields and specify a value, or select Any to ignore the 
criteria.
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Include Subfolders: Select this option to search the current folder and its subfolders.
4 Click Search to apply the search criteria and filter the list.

23.3 Creating a Contracts Folder
You can create folders in the Contracts list to better organize your contracts. All folders are displayed 
at the top of the list.

1 In ZENworks Control Center, click Asset Management > Contract Management > Contracts to 
display the Contracts page.

2 Click New > Folder to display the New Folder dialog box.
3 Fill in the following fields:

Name: Specify a name for the folder. The name must be unique among all other folders and 
contracts at the same level.
Folder: Browse for and select the folder in which to place the new folder.
Description: Specify any optional information to identify the folder.

4 Click OK to create the folder.

23.4 Copying an Existing Contract
You can copy an existing contract to create a new contract. When you do so, the copy retains the 
general information, vendor information, lease information, and documents. All date information is 
removed.

1 In ZENworks Control Center, click Asset Management > Contract Management > Contracts to 
display the Contracts page.

2 In the Contracts panel, select the check box next to the contract you want to copy, then click Copy 
to display the Copy Contract dialog box.
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3 Fill in the following fields:
Contract ID: Specify a new identifier for the contract. The contract ID cannot be the same as any 
other contract ID in the folder.
Name: Specify a new name for the contract
Parent Contract: If you want to designate the source contract as this contract’s parent, select 
Source contract. If you want to designate the source contract’s parent as this contract’s parent, 
select Same parent as source. Otherwise, select No parent.
If you need to designate some other contract as the parent, you can create the contract and then 
edit it. At that point, you can select any existing contract.

4 Click OK to create the new contract and add it to the Contracts list.

23.5 Adding Documents to Contracts
Many physical contracts have physical documents associated with them. To retain the physical 
documents with the contract in your Asset Management system, you can add electronic versions of 
the documents to the contract.

The following instructions assume that you have already uploaded the electronic documents to your 
Asset Management system. If not, see Part V, “Documents,” on page 171.

To add documents to a contract:

1 In ZENworks Control Center, click Asset Management > Contract Management > Contracts to 
display the Contracts page.

2 Click the contract.
3 Click the Documents tab.

4 In the Documents panel, click Add.
5 Browse for and select the documents you want to add, then click OK to add them to Documents 

list.
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24 24Working with Date Notifications

Contracts include many dates that can be important to track. For example, you might want to know 
when a contract is about to expire or when leased hardware is scheduled for delivery. To automate 
this tracking process, you can enable e-mail notifications for important dates.

The following sections provide information to help you create and manage date notifications:

 Section 24.1, “Specifying an E-Mail Server,” on page 159
 Section 24.2, “Configuring Default Settings,” on page 159
 Section 24.3, “Adding Date Notifications to a Contract,” on page 160
 Section 24.4, “Viewing the Date Notifications List,” on page 162
 Section 24.5, “Filtering the Date Notifications List,” on page 162
 Section 24.6, “Creating Date Notification Folders,” on page 163
 Section 24.7, “Moving a Date Notification,” on page 163
 Section 24.8, “Deleting a Date Notification,” on page 164

24.1 Specifying an E-Mail Server
For date notifications to be sent, your ZENworks system must have an SMTP server specified as its e-
mail server. You configure the e-mail server on the Configuration > Management Zone Settings > Event 
and Messaging > SMTP Settings page. 

24.2 Configuring Default Settings
Before you can create a notification for a contract date, you must configure the default date 
notification settings. When you create a date notification, the notification is populated with the 
default settings. You can then customize the settings as necessary.

1 In ZENworks Control Center, click Asset Management > Contract Management > Date Notifications.

2 Click Action > Default Date Notification Settings.
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3 Set the defaults for the following fields:
Number of days before date to send notification: Specify the lead time for the notification.
Repeat Notification: Select this option to repeat the notification, then select the frequency 
(Monthly, Weekly, or Daily) and the number of times. For example, if you specify a lead time of 90 
days, you could repeat the notification monthly by setting the Repeat Notification field to Monthly 
and the Number of times to repeat field to 3. 
Delete date notification record when complete: Select this option to delete the notification after 
all instances of the notification have been sent.
From: Specify the e-mail address you want to appear in the From field of the e-mail notification.
Recipients: You must add at least one default recipient. To do so, you can use this field or the 
Additional Recipients field.
If the Contacts list contains addresses, select an address and move it to the To list. The Contacts 
list contains e-mail addresses only if they have been imported from the Inventory data (see 
“Configuring E-mail Addresses” in the ZENworks 11 SP3 Asset Inventory Reference). 
Additional Recipients: You must add at least one default recipient. To do so, you can use this 
field or the Recipients field. To use this field, specify at least one address (for example, 
pjones@novell.com). Separate addresses with commas.

4 Click OK.

24.3 Adding Date Notifications to a Contract
A contract includes the following date fields for which you can configure notifications:

 General page: Original Start Date, Current End Date, Notice Date
 SLA page: Start Date, End Date
 Lease page: Order Date, Ship Date, Delivery Date, Signature Date, Inspection Date, Acceptance 

Date

To add a date notification to a date field:

1 Locate the date field for which you want to add a notification.
2 Click the check box next to Date Notification to display the New Date Notification dialog box.
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3 Modify any of the default settings:
Notification Name: Date notifications are added to the Date Notification list. This is the name 
that identifies the notification in that list. By default, the name includes the contract ID and date 
fields. If desired, specify a different name.
Source Contract: The contract ID of the source contract.
Date Field: The date field to which the notification applies.
Number of days before date to send notification: Specify the lead time for the notification.
Repeat Notification: Select this option to repeat the notification, then select the frequency 
(Monthly, Weekly, or Daily) and the number of times. For example, if you specify a lead time of 90 
days, you could repeat the notification monthly by setting the Repeat Notification field to Monthly 
and the Number of times to repeat field to 3. 
Delete date notification record when complete: Select this option to delete the notification after 
all instances of the notification have been sent.
Message Subject: The default message subject includes the source contract and date field. If 
desired, specify a different subject.
Message Content: The default message content identifies the contract and the event. You can 
modify the message content as necessary. 
From: Specify the e-mail address you want to appear in the From field of the e-mail notification.
Recipients: You must add at least one default recipient. To do so, you can use this field or the 
Additional Recipients field.
If the Contacts list contains addresses, select an address and move it to the To list. The Contacts 
list contains e-mail addresses only if they have been imported from the Inventory data (see 
“Configuring E-mail Addresses” in the ZENworks 11 SP3 Asset Inventory Reference). 
Additional Recipients: You must add at least one default recipient. To do so, you can use this 
field or the Recipients field. To use this field, specify at least one address (for example, 
pjones@novell.com). Separate addresses with commas.

4 Click OK to create the date notification.
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The Date Notification check box is enabled. In addition, a date notification record is added to the 
Date Notifications list (Configuration > Contract Management > Date Notifications). For information 
about the list, see Section 24.4, “Viewing the Date Notifications List,” on page 162.

5 Click Apply to save the changes to the contract.

24.4 Viewing the Date Notifications List
You can view a list of all date notifications. The list provides general information about each 
notification, such as its status, number of times sent, and next scheduled send time.

1 In ZENworks Control Center, click the Asset Management > Contract Management.
2 Click Date Notifications.

The list provides the following information for each notification:
Name: The ID of the contract to which the date notification applies. You can click the contract ID 
to display the contract’s details.
Field: The date field to which the notification applies. 
Status: The status of the date notification.
 Pending: The first notification message has not been sent yet.
 In-Progress: One or more notification messages have been sent and more are scheduled to be 

sent.
 Completed: All scheduled notification messages have been sent.
 Disabled: The date notification is no longer active. 

Sent: The number of notification messages that have been sent.
Failures: The number of sent notification messages that failed. You should ensure that you have 
specified an e-mail server (Configuration > Management Zone Settings > Event and Messaging > 
SMTP Settings) and that the recipient is a valid.
Last: The date of the last notification message attempt.
Next: The date of the next notification message attempt.

24.5 Filtering the Date Notifications List
You can filter the Date Notifications list to display only the notifications that meet certain criteria. 

1 In ZENworks Control Center, click the Asset Management > Contract Management > Date 
Notifications.
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2 In the Search panel (located next to the Date Notifications panel), enter the criteria to use for the 
filter. A notification must match all criteria to be displayed.
Name: Specify the text that the notification name (or folder name) must include. This is a partial 
match field that is case-insensitive. If the text you enter is included in any part of a name, the 
notification matches the criteria.
Type: Select whether you want to match folders, date notifications, or both.
Status: Select a status to match, or select Any to match any status.
Include Subfolders: Select this option to search the current folder and its subfolders.

3 Click Search to apply the search criteria and filter the list.

24.6 Creating Date Notification Folders
You can create folders in the Date Notifications list to better organize your notifications. All folders 
are displayed at the top of the list.

1 In ZENworks Control Center, click Asset Management > Contract Management > Date Notifications.

2 In the Date Notifications list, click New > Folder to display the New Folder dialog box.
3 Fill in the following fields:

Name: Specify a name for the folder. The name must be unique among all other folders and 
notifications at the same level.
Folder: Browse for and select the folder in which to place the new folder.
Description: Specify any optional information to identify the folder.

4 Click OK to create the folder.

24.7 Moving a Date Notification
You can move a date notification from one folder to another in the Date Notifications list. 

1 In ZENworks Control Center, click Asset Management > Contract Management > Date Notifications.

2 Select the notification to move.
3 Click Move to display the Move Date Notification(s) dialog box.
4 Browse for and select the target folder, then click OK.
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24.8 Deleting a Date Notification
1 In ZENworks Control Center, click Asset Management > Contract Management > Date Notifications.

2 Select the check box next to the notification you want to delete.
3 Click Delete, then click OK to confirm the deletion.

You can also delete a date notification by deselecting the Date Notification check box associated with 
the appropriate date field. For example, you could delete the Current End Date notification by 
deselecting the Date Notification check box for the Current End Date field on the contract’s General 
page.
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25 25Working with Import Files

ZENworks Asset Management can import contracts from a standard Asset Management import file.

 Section 25.1, “Format,” on page 165
 Section 25.2, “Fields,” on page 165
 Section 25.3, “Relationships,” on page 167
 Section 25.4, “Attaching Documents,” on page 167
 Section 25.5, “Rights,” on page 167
 Section 25.6, “Importing Administrator-Defined Fields,” on page 168
 Section 25.7, “Locale Support for Date Formats,” on page 168

25.1 Format
Import files are comma-separated files. The first row contains the column headers. Each additional 
row is a data row that identifies the contract. 

The following example lists the fields included in the column header along with the corresponding 
data row that maps to the fields.

AdmincontractId,Contractname,Totalcost,Site,Adf10
Id1,Contract1,432.3,London|Paris,Microsoft

The first row contains the column headers, such as Admincontractid, Contractname, 
Description, Totalcost and Programname.The second row contains the sample data to be 
imported. The order of the rows is not important. You can reverse the Admincontractid and 
Contractname or remove any rows that are not mandatory or contain unwanted information.

25.2 Fields
The table shown below lists the fields used in a contract import file. The number in parentheses 
indicates the maximum character limit allowed.

Header UI Field the Header Maps To

1 Admincontractid (64) Contract ID

This is a mandatory column. Select the General tab to locate the 
field.

2 Contractname (64) Name

This is a mandatory column.

3 Description (255) Description
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4 Contracttype (32) Contract Type

5 Contractstatus (32) Status 

6 Programname (255) Program Name 

7 Totalcost (Number ) Total Cost

8 Internalcontactname (64) Internal Contact 

9 Internalcontactphone (16) Internal Phone Number

10 parentcontract Parent Contract 

11 Internalcontactemail (64) Internal E-mail Address 

12 Keyterms (255) Terms and Conditions 

13 Startdate (date) Original Start Date

14 Enddate (date) Current End Date

15 Noticedescription (255) Notice Description

16 Noticedate (date) Notice Date

17 renewaloption Renewal Option

18 Renewalprovision (255) Renewal Provision 

19 IVendorname (64) Vendor Name

20 Adminvendorid (64) Vendor ID

21 Accountnumber(64) Account Number 

22 Pricontactname (64) Primary Vendor Contact 

23 Pricontactphone (32) Phone

Number 

24 Pricontactemail (32) E-mail Address

25 Seccontactname (64) Secondary Vendor Contact 

26 Seccontactemail (32) Phone Number 

27 Seccontactphone (32) E-mail Address

28 Definedservicelevel (128) Service Level Metric

This is a mandatory column if SLA information is  imported.

29 Actualservicelevel (128) Actual Service Level

30 Servicestartdate (date) Start Date

31 Serviceenddate (date) End Date

32 Site (32) Site 

33 Department (32) Department

34 Costcenter (32) Cost center

Header UI Field the Header Maps To
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25.3 Relationships
A contract can have multiple relationships with the site, department, and costcenter columns. 
Multivalued columns are specified with the pipe symbol (|) separating each value. For example, if 
the value for site is Site1|Site2, the contract is associated with both Site1 and Site2. 

25.4 Attaching Documents
A contract can have multiple documents attched to it. The Userdocid specifies the documents to be 
attached. The Userdocid can also have multiple values separated by the pipe symbol (|). 

25.5 Rights
The user who imports the contract should have Create/Delete Contract Management  rights for 
contracts.

35 Userdocid Document ID 

36 Deliveryprocedures (255) Delivery Procedures 

37 Returnobligations (255) Return Obligations 

38 Rightstorelocate (255) Rights to Relocate, Alter, Sub-lease 

39 Defaultsandremedies (255) Defaults and Remedies 

40 Insuranceprovisions (255) Insurance Provisions

41 Insuranceamount (Number) Insurance Cost 

42 Modificationprovisions (255) Equipment Modification Provisions

43 Purchaseoption (255) Purchase Option 

44 Endofleaseprovisions (255) End-of-Lease Provisions 

45 Prevailinglaw (255) Prevailing Law 

46 Dateordered (date) Order Date 

47 Dateshipped (date) Ship Date 

48 Datedelivered (date) Delivery Date 

49 Datesignedfor(date) Signature Date 

50 Dateinspected (date) Inspection Date 

51 Dateaccepted (date) Acceptance Date 

52 Folder Folder to which the contract will be imported. For example, 
test/test1 means import in to the test1 folder, which is 
inside the test folder. 

53 Adf0-adf19 Import the administrator-defined fields for the contract.

Header UI Field the Header Maps To
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25.6 Importing Administrator-Defined Fields
Importing the Administrator-Defined Fields (adf0 -adf19) for the contract is supported. 

25.7 Locale Support for Date Formats
You can use different date formats. To support a date in a different locale, add a header 
locale=yourlocale  and provide the locale in the header line. The locale can be in the dd/mm/yy or 
en_US format. If either the locale is not valid or the locale header is not present, the dates take the 
default locale. The default locale is the locale of the server you are importing the contracts from.
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26 26Generating Contract Reports

ZENworks Asset Management includes a variety of reports that you can generate to view contract 
data. In addition to viewing predefined reports, you can create custom reports and export reports to 
several file formats.

The contract report information is combined with the software usage and license management report 
information in Part VI, “Reports,” on page 179. The following list provides direct links to compliance 
report sections:

 Descriptions for all standard and custom reports: Chapter 29, “Standard and Custom Report 
Descriptions,” on page 181.

 How to run standard reports: Chapter 32, “Working with Standard Reports,” on page 191
 How to create and generate custom reports: Chapter 33, “Working with Custom Reports,” on 

page 195.
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V VDocuments

Novell ZENworks Asset Management lets you upload document files and associate them with 
licensed products, contracts, and purchase summary records.

 Chapter 27, “Uploading Documents,” on page 173
 Chapter 28, “Working with Documents,” on page 175
Documents 171



172 ZENworks 11 SP3 Asset Management Reference



27 27Uploading Documents

Before you can add a document to a licensed product, contract, or purchase summary record, you 
must upload it to the Asset Management system. Uploaded documents are stored in the ZENworks 
database.

1 In ZENworks Control Center, click Asset Management > Documents.

2 In the Documents panel, click New > Upload Document to launch the Upload New Document 
Wizard. Complete the wizard by using information from the following table to fill in the fields:

3 Click Finish to upload the document.

Wizard Page Details

Specify Document File to 
Add

Specify the file in the File Name field or click Browse to search.

Document File Information Fill in the following fields:

Document ID: Specify a file ID.

Local Path: Displays the path of the file.

Source Location: Specify the location of the source file.

As-Of Date: Click the calendar icon to select a date.

Description: Add a description, if needed.

New Document Summary Review the data entered. Use the Back button to make corrections. 
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28 28Working with Documents

The following sections explain the tasks associated with managing existing documents. For 
information about adding documents to your Asset Management system, see Chapter 27, 
“Uploading Documents,” on page 173.

 Section 28.1, “Viewing the Documents List,” on page 175
 Section 28.2, “Filtering the Documents List,” on page 176
 Section 28.3, “Creating a Documents Folder,” on page 176
 Section 28.4, “Attaching Documents to Licensed Products, Contracts, and Purchase Summary 

Records,” on page 177

28.1 Viewing the Documents List
You can view a list of all of your documents. The list provides general information about each 
document, such as its name, file type, upload date, and whether or not it is associated with a licensed 
product, contract, or purchase summary record.

1 In ZENworks Control Center, click the Asset Management tab.
2 Click the Documents tab.

The list provides the following information for each document:
Document ID: The identification number given to the document. You can click the document ID 
to display the document’s details.
File Name: The document’s filename. 
File Type: The document’s file extension.
File Size (KB): The document’s file size in kilobytes.
As-Of Date: The document’s last edit date provided during the document upload.
Description: Any description text provided during the document upload.
Attached: Includes a check mark if the document is associated with a licensed product, contract, 
or purchase summary record.
Local Path: The document’s local path.
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Source Location: The document’s source location provided during the document upload.
Date Uploaded: The date the document was uploaded.

28.2 Filtering the Documents List
You can filter the Documents list to display only the documents that meet certain criteria. 

1 In ZENworks Control Center, click Asset Management > Documents.

2 In the Search panel (located next to the Documents panel), specify the criteria to use for the filter. 
A contract must match all criteria to be displayed.
Document ID: Specify the text that the document ID (or folder name) must include. This is a 
partial match field that is case-insensitive. If the text you enter is included in any part of a 
document ID, the document matches the criteria.
File Name: Specify the text that the file name must include. This is a partial match field that is 
case-insensitive. If the text you enter is included in any part of a filename, the document matches 
the criteria.
Type: Select whether you want to match folders, documents, or both.
File Type: Select a specific file type, or select Any to match any file type. 
Attachment Status: Select one of the following to match:
 Any: Ignore the attachment status. Match any document.
 Attached: Match documents that are associated with licensed products, contracts, or 

purchase summary records.
 Not Attached: Match documents that are not associated with licensed products, contracts, or 

purchase records.
Include Subfolders: Select this option to search the current folder and its subfolders.

3 Click Search to apply the search criteria and filter the list.

28.3 Creating a Documents Folder
You can create folders in the Documents list to better organize your documents. All folders are 
displayed at the top of the list.

1 In ZENworks Control Center, click Asset Management > Documents.
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2 In the Documents panel, click New > Folder to display the New Folder dialog box.
3 Fill in the following fields:

Name: Specify a name for the folder. The name must be unique among all other folders and 
documents at the same level.
Folder: Browse for and select the folder in which to place the new folder.
Description: Specify any optional information to identify the folder.

4 Click OK to create the folder.

28.4 Attaching Documents to Licensed Products, Contracts, and 
Purchase Summary Records

1 In ZENworks Control Center, click Asset Management > Documents.

2 Click the document ID.
3 Click the Relationships tab.
4 In the Contracts, License Entitlements, or Purchase Summary Records panel, click Add. The 

documents to be added are filtered based on the document status, which can be either Attached, 
Unattached or All.
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Figure shows the list of unattached documents in the contracts page. For example, to attach a 
document from the contracts page, select the document name, then click OK. 

Figure shows the list of documents in the entitlements page, along with the status of each 
document.

5 Follow the remaining prompts to add the documents.
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VI VIReports

Novell ZENworks Asset Management provides a variety of standard reports to help you analyze the 
data related to your assets. If a standard report does not include the information you need, you can 
create custom reports.

 Chapter 29, “Standard and Custom Report Descriptions,” on page 181
 Chapter 30, “Configuring Report Rights,” on page 187
 Chapter 31, “Configuring Report Settings,” on page 189
 Chapter 32, “Working with Standard Reports,” on page 191
 Chapter 33, “Working with Custom Reports,” on page 195
 Chapter 34, “Working with ZENworks Reporting,” on page 205
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29 29Standard and Custom Report 
Descriptions

ZENworks Control Center includes a variety of standard (predefined) and custom reports to help 
you analyze the Asset Management data in your Management Zone. The following sections describe 
the available reports. 

 Section 29.1, “License Management Reports,” on page 181
 Section 29.2, “Software Usage Reports,” on page 182
 Section 29.3, “Contract Management Reports,” on page 184

29.1 License Management Reports
License Management reports help you analyze your license compliance and license allocation data. 

 Section 29.1.1, “Standard Reports,” on page 181
 Section 29.1.2, “Sample Custom Reports,” on page 182

29.1.1 Standard Reports

Folder Report Description

Software Compliance Compliance Report Shows the compliance status for all licensed products. 
Includes general details such as the number of unreconciled 
catalog and discovered products. For each licensed product, 
includes details such as license quantity, installation 
quantity, active usage quantity, and unused installations.

Software Compliance Status Summary Summarizes the total number of licensed products, 
purchase records, catalog products, and discovered 
products.

Unreconciled Products Catalog Products Shows the catalog products that are not associated with 
licensed products.

Unreconciled Products Discovered Products Shows the discovered products that are not associated with 
licensed products.

Purchases Purchase Summary Shows purchases by product with basic information such as 
the number of purchases and average purchase price.

Purchases Purchase Details Shows purchases by purchase order/invoice with details 
such as reseller, product, version, number of purchases, and 
various purchase prices (Unit MSRP, Unit Price, and 
Extended Price).
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29.1.2 Sample Custom Reports

29.2 Software Usage Reports
Software Usage reports help you analyze the usage of local applications, served applications, and 
Web applications on devices in your ZENworks Management Zone.

 Section 29.2.1, “Standard Reports,” on page 182
 Section 29.2.2, “Sample Custom Reports,” on page 184

29.2.1 Standard Reports

Suites Suites/Components Shows discovered suites and their component products. 
Includes installation quantities associated with the suite and 
with individual component products.

Suites Standalone 
Components

Shows suite components that are installed without the suite. 
Includes installation quantities and the licensed products 
with which the standalone components are associated.

Other Reports Inventory Comparison Shows all Inventory products (those products discovered by 
Inventory scans) with the discovered products to which they 
are mapped. Includes details such as installation quantity, 
the number of standalone installations and suite component 
installations, and whether or not the Inventory product is 
excluded from license compliance.

Other Reports Software Standards Shows all discovered products and their assigned standards 
category.

Folder Report Description

Folder Report Description

Software Compliance Excluded Catalog 
Products

Shows the catalog products that are excluded from license 
compliance.

Software Compliance Excluded Discovered 
Products

Shows the catalog products that are excluded from license 
compliance.

Software Compliance Non-Compliant 
License Records

Shows the licensed products whose compliance is Unknown 
or Under (too few licenses).

Software Compliance Unreconciled 
Discovered Products

Shows the discovered products that are not associated with 
licensed products and that are not excluded from license 
compliance.

Folder Report Description

Application Usage Total Application 
Usage by Product

Shows the total local and served application usage grouped 
by product.
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Application Usage Total Application 
Usage by User

Shows the total local and served application usage grouped 
by user.

Application Usage Total Application 
Usage by Device

Shows the total local and served application usage grouped 
by device.

Application Usage Local Application 
Usage by User

Shows the local application usage grouped by user.

Application Usage Local Application 
Usage by Device

Shows the local and application usage grouped by device.

Application Usage Served Application 
Usage by Product

Shows served application usage grouped by product.

Application Usage Served Application 
Usage by Server

Shows served application usage grouped by server.

Application Usage Served Application 
Usage by User

Shows served application usage grouped by user.

Application Usage Served Application 
Usage by Device

Shows served application usage grouped by device.

Application Usage Usage Collection 
History

Shows a history of data collection.

Web Application Usage Web Application 
Usage by Application

Shows Web application usage grouped by application.

Web Application Usage Web Application 
Usage by User

Shows Web application usage grouped by user.

Web Application Usage Web Application 
Usage by Device

Shows Web application usage grouped by device.

Software File Usage Software File Usage 
by Category

Software files represent products not recognized by the 
ZENworks Knowledgebase and therefore not mapped to 
discovered products.

Shows a count of software files grouped by category (All, 
Other, Ancillary), with links to lists of the files.

Software File Usage Software File Usage 
by Manufacture

Shows a count of software files grouped by manufacturer, 
with links to lists of the files.

Software File Usage Software File Usage 
by Device

Shows a count of software files grouped by device, with links 
to lists of the files.

Network Software 
Usage

Network Software 
Usage by Product

Shows network software usage grouped by product.

Network Software 
Usage

Network Software 
Usage by Server

Shows network software usage grouped by server.

Network Software 
Usage

Network Software 
Usage by User

Shows network software usage grouped by user.

Network Software 
Usage

Network Software 
Usage by Device

Usage reports focusing on software launched from a 
network drive. 

All Usage All Usage by User Shows all usage grouped by user.

Folder Report Description
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NOTE: The total active usage of an application displayed in the software usage report is the 
accumulated value of active usage of that application. This value should be more than or equal to one 
hour to be reported in the software usage report. If the value is less than one hour, then it is reported 
as zero.

29.2.2 Sample Custom Reports

29.3 Contract Management Reports
Contract Management reports help you analyze your contract data from perspectives such as key 
financial information, service level agreements, and renewal dates.

 Section 29.3.1, “Standard Reports,” on page 184
 Section 29.3.2, “Sample Custom Reports,” on page 185

29.3.1 Standard Reports

All Usage All Usage by Device Shows all usage grouped by device.

Folder Report Description

Folder Report Description

Software Application 
Usage

Software Applications 
Not Used in 90 Days

Shows the applications that haven’t been used in the 
previous 90 days.

Software Application 
Usage

Software Usage on 
Virtual Machines

Shows software usage on virtual machines.

Software Application 
Usage

Workstations with 
Suspicious Software 
Used Within 7 Days

Shows the workstations with suspicious software (malware) 
that has been used in the previous 7 days.

Folder Report Description

Contract Management 
Reports

General Contracts Shows a list of contracts with general contract information 
such as status (active or expired), contract period, total cost, 
and vendor.

Contract Management 
Reports

Date Details Shows a list of contracts with date information such as the 
contract start and end dates, the time remaining, and 
whether or not the contract has a renewal option.

Contract Management 
Reports

Vendor Details Shows a list of contracts with vendor information such as 
name, account number, and contact.

Contract Management 
Reports

Financial Details Shows a list of contracts with financial information such as 
total overall cost and total cost per demographic 
(department, site, and cost center). Also shows annual 
costs.
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29.3.2 Sample Custom Reports

Contract Management 
Reports

SLA Details Shows a list of contracts with service level agreement 
information such as agreement period and metrics.

Contract Management 
Reports

Lease Details Shows a list of contracts with key lease information such as 
order date, insurance provisions, and end-of-lease 
provisions.

Contract Management 
Reports

Document Details Shows a list of contracts with their associated documents.

Contract Management 
Reports

Renewal Details Shows the renewal history for all contracts.

Contract Management 
Reports

Association Details Shows a list of contracts with their associated devices, 
users, cost centers, departments, sites, and license 
entitlements.

Contract Management 
Reports

Parent/Child Details Shows a hierarchical list of contracts and indicates parent/
child relationships.

Folder Report Description

Folder Report Description

Contract Management Active Contracts with 
No Associated Assets

Shows active contracts that have no associated assets; that 
is, no workstation or network devices.

Contract Management Active Software 
Maintenance 
Contracts

Shows the active contracts whose type is software 
maintenance.

Contract Management Contracts with 
Evergreen Provision

Shows all active contracts with an Evergreen provision (no 
contract end date).

Contract Management Contracts with No 
Attached Documents

Shows all contracts with no attached documents.

Contract Management Contracts Ending 
within 90 Days (No 
Renewal Option)

Shows all non-renewable contracts with end dates within 90 
days after the run date.

Contract Management Contracts Ending 
within 90 Days 
(Renewal Option)

Shows all renewable contracts with end dates within 90 days 
after the run date.

Contract Management Contracts Renewed in 
Last 90 Days

Shows contracts that have been renewed in the last 90 
days.

Contract Management Expired Contracts Shows all expired contracts.

Contract Management Lease Schedules 
Ending within 60 Days

Shows contracts with a lease schedule and a current end 
date within 60 days of the report run date.

Contract Management Pending Contracts Shows all the pending contracts.
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30 30Configuring Report Rights

ZENworks Asset Management lets you manage administrator rights to each report folder. The rights 
associated with each folder govern all the reports within that folder. For example, if you have full 
rights to a folder, you can edit reports within the folder; but with view/execute rights, you can only 
see the folder’s reports and run them.

To configure the Asset Management report rights:

1 In ZENworks Control Center, click Configuration.
2 In the Administrators panel, click an administrator.
3 In the Administrator Tasks panel (located in the left navigation panel), click Asset Management 

Report Rights.

4 Select the folders you want to change the rights to.
5 Click Edit, then click one of the following:

 Remove All Rights: Removes all rights to the folder, so the administrator cannot see it.
 Assign View/Execute Rights: Allows the administrator to view and execute a report in the 

specified folder, but not to edit, move, or delete a report in the folder.
 Assign Full Rights: Gives the administrator full rights to create, edit, move, and delete 

reports. For standard reports, this setting is the same as View/Execute, because you cannot 
alter a standard report.

The change is reflected in the Rights column.
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31 31Configuring Report Settings

There are two ZENworks Management Zone settings related to Asset Management reports. One 
setting determines how a report is initiated and the other setting determines whether or not software 
usage is displayed in all reports.

To configure the settings:

1 In ZENworks Control Center, click Configuration.
2 In the Management Zone Settings panel, click Asset Management, then click Reports.

3 Configure the following options:
Wait to run reports until search is pressed: By default, a report runs when you click it. Select 
this option to display the search criteria before running the report; the report runs only after you 
click the Search button.
Do not show usage on License Management reports: Many of the License Management 
(license compliance and license allocation) reports include software usage data. Collecting the 
software usage data typically increases the time required to generate the report. If you want to 
decrease the generation time and you don’t need the usage data in the reports, select this option.

4 Click OK to save the changes.

31.1 Administrator Rights
Administrators now have access to change or assign the report rights. The Asset Management Report 
Rights page allows you to configure the default right settings that you can assign to a user. By 
default, a user has the View/Execute Rights enabled. Changing this setting does not affect existing 
users whose default rights were already modified.

You can choose to use any one of the following as the default right setting:

 No Rights
 View/Execute Rights
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32 32Working with Standard Reports

ZENworks Control Center includes a variety of predefined Asset Management reports. Chapter 29, 
“Standard and Custom Report Descriptions,” on page 181 describes each of the standard reports. The 
following sections explain how to use the reports.

 Section 32.1, “Running a Report,” on page 191
 Section 32.2, “Exporting a Report,” on page 192
 Section 32.3, “Viewing a Report as a Graph,” on page 192
 Section 32.4, “Changing the Report Period,” on page 192
 Section 32.5, “Changing the Filter Criteria,” on page 193

NOTE: An attempt to run standard reports in ZENworks Control Center might fail or time out due to 
large amount of Inventory data that is not pruned in the database. Examples of such reports are Hot 
Fix Details, Software Files By Manufacturer, Software Files By Device, and Hardware Components By 
Category. It is recommended to prune unwanted Inventory data in the database before running such 
complex reports. For more details on purging, see “Purge Inventory History” in ZENworks 11 SP3 
Asset Inventory Reference.

32.1 Running a Report
Many of the Asset Management standard reports include usage data associated with the software 
product. If you are not interested in this data, you can exclude the data to generate the report more 
quickly. For information, see Section 31, “Configuring Report Settings,” on page 189.

1 In ZENworks Control Center, click the Asset Management tab.
2 For license compliance and license allocation reports, click the License Management tab, then click 

License Management Reports.
or
For software usage reports, click the Software Usage tab.
or
For contract management reports, click the Contract Management tab, then click Contract 
Management Reports.

3 In the Standards Reports panel, locate the report you want to run.
In some cases, you might need to open a folder to see the report you want. Within a folder, 
reports are listed by name and description. For a list of reports and descriptions, see Chapter 29, 
“Standard and Custom Report Descriptions,” on page 181.

4 If you are generating a software usage report, you can limit the scope of the report data by 
selecting one of the following Grouping Criteria:
 Zone: Displays data from the entire Management Zone.
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 Folder: Displays data for devices in a specific folder. Select Folder, then click  to browse 
for and select the folder.

 Group: Displays data for devices in a specific group. Select Group, then click  to browse 
for and select the group. 

 Demographic: Displays data for a specific demographic. Select Demographic, then select 
Department, Site, or Cost Center.

5 Click the report to run it.

Many of the reports contained linked items. You can click a linked item to display more detailed 
information about the item.

32.2 Exporting a Report
You can export report data to three formats: Excel, CSV, and PDF.

1 Run the report. For instructions, see Section 32.1, “Running a Report,” on page 191.
2 Export the report to by clicking one of the three options (Excel, CSV, or PDF) at the bottom of the 

report.
If the report includes more items than are listed in the current display (for example, 1 to 100 of 
226 products), three additional options are added: Excel (All), CSV (All), and PDF (All). The Excel, 
CSV, and PDF options export only the items in the current display. The Excel (All), CSV (All), and 
PDF (All) options export all items.

32.3 Viewing a Report as a Graph
Many reports can be viewed as a graph. If this feature is available, Graph appears at the bottom of the 
report.

A report is generated as three different graphs: bar graph, pie chart, and line graph. You can save the 
graphs as a PDF file.

Graphs work best for small data sets; if you include many values, the graphs might become hard to 
read. Use the filter and grouping criteria to limit the amount of data shown.

1 Run the report. For instructions, see Section 32.1, “Running a Report,” on page 191.
2 Click Graph at the bottom of the report.

If the report includes more items than are listed in the current display (for example, 1 to 100 of 
226 products), a Graph (All) option is added The Graph options graphs only the items in the 
current display. The Graph (All) option graphs all items.

32.4 Changing the Report Period
For greater flexibility, you can change the time period of some reports. If this feature is available, 
Change Time Period (or Change Time Period/Filter) appears at the bottom of the report.

You can select from the following time periods: 

 Previous Month
 Previous 3 Months
 Previous 6 Months
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 Previous 12 Months
 All History in Database

To change the time period:

1 Run the report. For instructions, see Section 32.1, “Running a Report,” on page 191.
2 Click Change Time Period.
3 Select an interval in the New Time Period field.
4 Click Apply.

The report runs again and the new time period is shown at the top left of the report.

32.5 Changing the Filter Criteria
Many reports allow you to change the report filter criteria. In some reports, the filter criteria are 
displayed in a navigation pane to the left of the report. In other reports, criteria are accessed through 
a Change Filter (or Change Time Period/Filter) option at the bottom of the report.

1 Run the report. For instructions, see Section 32.1, “Running a Report,” on page 191.
2 If the filter criteria are displayed in the left navigation pane, modify the criteria, then click Search.

or
Click Change Filter at the bottom of the report, select one of the filters, then click Apply.
Working with Standard Reports 193



194 ZENworks 11 SP3 Asset Management Reference



33 33Working with Custom Reports

ZENworks Control Center lets you create and run custom Asset Management reports to analyze data 
not included in the standard reports. Chapter 29, “Standard and Custom Report Descriptions,” on 
page 181 includes sample custom reports that demonstrate the different types of reports that you can 
create.

The following sections explain how to use custom reports:

 Section 33.1, “Creating a Custom Report,” on page 195
 Section 33.2, “Running a Custom Report,” on page 196
 Section 33.3, “Scheduling a Custom Report,” on page 197
 Section 33.4, “Viewing a Scheduled Custom Report,” on page 199
 Section 33.5, “Editing a Custom Report,” on page 199
 Section 33.6, “Creating a Custom Report Folder,” on page 201
 Section 33.7, “Deleting a Custom Report Folder,” on page 201
 Section 33.8, “Moving a Custom Report,” on page 202
 Section 33.9, “Deleting a Custom Report,” on page 202
 Section 33.10, “Importing New Report Definitions,” on page 203

33.1 Creating a Custom Report
1 In ZENworks Control Center, click the Asset Management tab.
2 For license compliance and license allocation reports, click the License Management tab, then click 

License Management Reports.
or
For software usage reports, click the Software Usage tab.
or
For contract management reports, click the Contract Management tab, then click Contract 
Management Reports.

3 In the Custom Reports panel, open the folder where you want to create the report.
4 Click New to display the Custom Report Definition - Step 1 of 2 page.
5 Fill in the following fields:

Name: Specify a name for the report. The name must be unique within the folder where it is 
being created.
Type: For License Management and Contract reports, this field is preset. For Software Usage 
reports, select the type of report you want to create. The type determines which Focus options 
are displayed.
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Focus: Select a focus for the report. The focus determines which fields are available to available 
to include in the report. For example, if you are creating a License Management type report and 
you select Purchase Records as the focus, only the fields related to purchase records are 
available. 

6 Click Continue to display the Custom Report Definition - Step 2 of 2 page 
7 Fill in the following fields:

Name: Displays the name you entered in Step 5. You can change it if necessary.
Folder: Displays the folder you selected in Step 3. You can change it if necessary.
Description: Specify a description for your report. This is optional
Type: Displays the report type you selected in Step 5.
Columns: From the list on the left, select the fields you want to include in your report. Use the 
arrow icons to move the selected fields to the list on the right. Use Ctrl+click to select more than 
one field at a time. Use the up and down icons to order the field display.
Criteria: Lets you include or exclude entries based on the value of a field in the database. For 
example, if you are creating a report with a Purchase Record focus and you don’t include any 
criteria, all purchase records are displayed in the generated report. However, if you select 
Purchase Reseller = CheapSoft as the criteria, only purchase records with CheapSoft as the 
purchase reseller are displayed. 
Select your filter criteria in the Field, Operator, and Value fields. Use the + icons to add filters or 
click the - icon to delete a filter. Click OR or AND to toggle back and forth between the two 
operators.
Summary Criteria: Lets you include or exclude entries based on a calculated value. 
Select your summary filter criteria in the Field, Operator, and Value fields. Use the + icons to add 
filters; click the - icon to delete a filter. Click OR or AND to toggle back and forth between the 
two operators

8 Click Save.
The report is added to the Custom Reports panel. However, it is not displayed until you refresh 
the page.

33.2 Running a Custom Report
If a custom reports include usage data associated with software products, and you are not interested 
in the usage data, you can exclude the data to make the reports generate more quickly. For 
information, see Chapter 31, “Configuring Report Settings,” on page 189.

1 In ZENworks Control Center, click the Asset Management tab.
2 For license compliance and license allocation reports, click the License Management tab, then click 

License Management Reports.
or
For software usage reports, click the Software Usage tab.
or
For contract management reports, click the Contract Management tab, then click Contract 
Management Reports.

3 In the Custom Reports panel, open the folder containing the report you want to run.
4 Click the report.
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The report definition appears. For information on editing the report definition, see Section 33.5, 
“Editing a Custom Report,” on page 199.

5 Click Run at the bottom of the report.
On the report page, click the various links on the report for additional information. You can also 
export the report to an Excel, CSV, or PDF format by clicking the corresponding link. 

33.3 Scheduling a Custom Report
You can schedule a report to run automatically and send out notifications to individuals when it is 
ready.

You must have already defined an SMTP e-mail server if you want to send e-mail notifications. This is 
done through the SMTP Settings option (Configuration tab > Management Zone Settings panel > Event 
and Messaging > SMTP Settings). 

1 In ZENworks Control Center, click the Asset Management tab.
2 For license compliance and license allocation reports, click the License Management tab, then click 

License Management Reports.
or
For software usage reports, click the Software Usage tab.
or
For contract management reports, click the Contract Management tab, then click Contract 
Management Reports.

3 In the Custom Reports panel, open the folder containing the report you want to run.
4 Click the report you want to schedule.
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5 Click Schedule/Notification.

6 Fill in the following fields:
Start Date: Click  to specify the first day that you want the report generated.
Frequency: Select how often you want to generate the report: yearly, monthly, weekly, daily, 
once, or never.
Output: Select what you want to happen when the report is generated. You can simply store the 
report, send an e-mail notification that the report is ready, or both. You can also choose to store 
the results or send a notification only when the report includes data. 
If you select Send a Notification (E-mail) or Both, you must configure the e-mail notification:
 Delivery Format: Send the report as an Microsoft Excel file or PDF file attached to the e-mail, 

or include a link to the report stored on your ZENworks server.
 Sender: Specify the name to be included in the From field of the e-mail.
 Recipients: The Contacts list includes the individuals whose e-mail addresses are listed in 

the Inventory database. If the list does not include the e-mail addresses you need, you can 
import the addresses or use the Additional Recipients field. For information about importing 
e-mail addresses, see “Configuring E-mail Addresses” in the ZENworks 11 SP3 Asset 
Inventory Reference.

To add a recipient from the Contacts list, select the recipient, then click  to add the 
recipient to the To list.

 Additional Recipients: You must add at least one default recipient. To do so, you can use this 
field or the Recipients field. To use this field, specify at least one address (for example, 
pjones@novell.com). Separate addresses with commas.

Maximum Records: Specify the maximum number of records to include in the report.
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7 Click Submit.
The report runs at the scheduled times.

33.4 Viewing a Scheduled Custom Report
Scheduled reports are stored in the ZENworks database. You can view these reports either by title or 
date. For information about scheduling reports, see Section 33.3, “Scheduling a Custom Report,” on 
page 197.

1 In ZENworks Control Center, click the Asset Management tab.
2 For license compliance and license allocation reports, click the License Management tab, then click 

License Management Reports.
or
For software usage reports, click the Software Usage tab.
or
For contract management reports, click the Contract Management tab, then click Contract 
Management Reports.

3 In the Custom Reports panel, click one of the following:
 Action > View Scheduled Report Results by Date
 Action > View Scheduled Report Results by Title

The Scheduled Reports by Grouping page displays and shows the reports grouped by date or 
title and a report count.

4 Click a grouping to open the Scheduled Reports page, then select a report to view it.

33.5 Editing a Custom Report
1 In ZENworks Control Center, click the Asset Management tab.
2 For license compliance and license allocation reports, click the License Management tab, then click 

License Management Reports.
or
For software usage reports, click the Software Usage tab.
or
For contract management reports, click the Contract Management tab, then click Contract 
Management Reports.

3 In the Custom Reports panel, open the folder containing the report you want to edit.
4 Click the report.
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5 Click Edit at the bottom of the report.

6 Edit the following fields:
Name: The name of the report. Any name you specify must be unique within the folder where 
the report resides.
Folder: The folder where you want to save the report.
Description: A description for the report. This field is optional.
Type: The report type.
Columns: From the list on the left, select the fields you want to include in your report. Use the 
arrow icons to move the selected fields to the list on the right. Use Ctrl+click to select more than 
one field at a time. Use the up and down icons to order the field display.
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Criteria: Lets you include or exclude entries based on the value of a field in the database. For 
example, if you are creating a report with a Purchase Record focus and you don’t include any 
criteria, all purchase records are displayed in the generated report. However, if you select 
Purchase Reseller = CheapSoft as the criteria, only purchase records with CheapSoft as the 
purchase reseller are displayed. 
Select your filter criteria in the Field, Operator, and Value fields. Use the + icons to add filters or 
click the - icon to delete a filter. Click OR or AND to toggle back and forth between the two 
operators.
Summary Criteria: Lets you include or exclude entries based on a calculated value. 
Select your summary filter criteria in the Field, Operator, and Value fields. Use the + icons to add 
filters; click the - icon to delete a filter. Click OR or AND to toggle back and forth between the 
two operators

7 Click Save.

33.6 Creating a Custom Report Folder
You can create folders to organize your custom reports.

1 In ZENworks Control Center, click the Asset Management tab.
2 For license compliance and license allocation reports, click the License Management tab, then click 

License Management Reports.
or
For software usage reports, click the Software Usage tab.
or
For contract management reports, click the Contract Management tab, then click Contract 
Management Reports.

3 In the Custom Reports panel, click New to display the New Folder dialog box.
4 In the Name field, specify a name for the folder, then click OK.

The name must be unique within the Custom Reports list.

33.7 Deleting a Custom Report Folder
To delete a folder and all the reports in it:

1 In ZENworks Control Center, click the Asset Management tab.
2 For license compliance and license allocation reports, click the License Management tab, then click 

License Management Reports.
or
For software usage reports, click the Software Usage tab.
or
For contract management reports, click the Contract Management tab, then click Contract 
Management Reports.

3 In the Custom Reports panel, select the folder you want to delete.
4 Click Delete, then click OK to confirm the deletion.
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33.8 Moving a Custom Report
You can move a custom report from one folder to another. The target folder must be of the same type 
(License Management, Software Usage, or Contract Management) as the source folder.

1 In ZENworks Control Center, click the Asset Management tab.
2 For license compliance and license allocation reports, click the License Management tab, then click 

License Management Reports.
or
For software usage reports, click the Software Usage tab.
or
For contract management reports, click the Contract Management tab, then click Contract 
Management Reports.

3 In the Custom Reports panel, select the report you want to move, then click Edit > Move.
4 In the New Report Location list, select the target folder, then click OK.

33.9 Deleting a Custom Report
To delete a custom report:

1 In ZENworks Control Center, click the Asset Management tab.
2 In the License Management panel, click License Management Reports.

3 In the License Management Custom Reports panel, click the folder containing the report you 
want to delete.

4 Select the report you want to delete.
5 Click Delete.

To delete a folder (and all the reports in it):

1 In ZENworks Control Center, click the Asset Management tab.
2 In the License Management panel, click License Management Reports.
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3 In the License Management Custom Reports panel, select the folder you want to delete.
4 Click Delete.

33.10 Importing New Report Definitions
If you have defined reports in ZENworks Asset Management 7.5, you can import them into 
ZENworks Control Center. You can also re-import reports that have been exported by ZENworks 
Control Center.

To import report definitions:

1 In ZENworks Control Center, click the Asset Management tab.
2 For license compliance and license allocation reports, click the License Management tab, then click 

License Management Reports.
or
For software usage reports, click the Software Usage tab.
or
For contract management reports, click the Contract Management tab, then click Contract 
Management Reports.

3 In the Custom Reports panel, click Action > Import New Report Definition.

4 Specify the file in the Query import file field, or click Browse to search for and select the file.
5 Click Import.
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34 34Working with ZENworks Reporting

In addition to the software usage, license management, and contract management reports that you 
can create and generate from the Asset Management folder in ZENworks Reporting, and also you can 
create and generate additional reports.

The ZENworks Reporting is a powerful, flexible, and customizable reporting tool that is installed and 
configured separately from the ZENworks system. For information about ZENworks Reporting 
installation, see the ZENworks Reporting 5 Installation Guide.

You can use the ZENworks Reporting to view additional predefined Asset Management reports and 
create Ad Hoc reports (custom reports). The following sections describe the predefined reports and 
how to view them.

 Section 34.1, “Viewing a Predefined Report,” on page 205
 Section 34.2, “Predefined Reports,” on page 205

For information about creating custom reports, see the ZENworks Reporting 5 System Reference.

34.1 Viewing a Predefined Report
ZENworks Reporting must be installed and configured to use the predefined reports.

1 Log in to ZENworks Reporting.
2 Navigate to the View > Repository > Folders > Organization > Reports > ZENworks > Predefined 

Reports > Asset Management > License Management folder.
The Asset Management reports are organized in four subfolders: License Allocation, Purchases, 
Software Compliance, and Suites. For a brief description of each report, see Section 34.2, 
“Predefined Reports,” on page 205.

3 Open the folder that contains a report to view.
4 Double-click the report.

34.2 Predefined Reports
The predefined Asset Management reports are organized into four categories:

 Section 34.2.1, “License Allocation Reports,” on page 206
 Section 34.2.2, “Purchases Reports,” on page 206
 Section 34.2.3, “Software Compliance Reports,” on page 206
 Section 34.2.4, “Suites Reports,” on page 207
 Section 34.2.5, “Licensed Products And Entitlements Report,” on page 207
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34.2.1 License Allocation Reports

34.2.2 Purchases Reports

34.2.3 Software Compliance Reports

Report Title Description

Allocations vs. Installations For each licensed product, shows the variance between allocated 
licenses and the total number of installations. For each licensed product, 
this report lists the total number of licenses, installed, allocated, over 
allocated, or under allocated.

Current Allocations For each licensed product, this report lists the current number of 
licenses allocated and unallocated quantity.

Demographic Over-Allocation Lists all licensed products whose number of demographically allocated 
licenses is more than the number of installations associated with the 
demographic.

Demographic Under-Allocation Lists all licensed products whose number of demographically allocated 
licenses is less than the number of installations associated with the 
demographic.

Device Over-Allocation Lists all licensed products whose number of device-allocated licenses is 
less than the number of installations associated with devices.

Duplicate Allocations Lists all licensed products with device allocations that duplicate 
demographic allocations.

Installations with no Allocations Lists all licensed products with installed licenses that are not covered by 
demographic or device allocations.

Licensed Products Allocations Lists the demographic allocations and device allocations of the licensed 
product. Data can be filtered based on the department and the site.

Report Title Description

Purchase Record Detail Lists all Purchase Order details such as, PO number, Invoice number, 
Order date,  Reseller, manufacturer, quantity along with unit price and 
MSRP.

Purchase Record Summary Compiles the purchase records by catalog product. For each catalog 
product, lists the product type, purchase quantity, average unit price, 
and total price. 

Report Title Description

Compliance Status Provides the compliance status of the selected licensed product. It lists 
the license consumption details such as, installed quantity, calculated 
license quantity, consumed quantity and net consumption. It also lists 
details about any un-resolved installations.
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34.2.4 Suites Reports

34.2.5 Licensed Products And Entitlements Report

Discovered Product Summary Provides details of the discovered product that is reconciled with the 
licensed product. 

Software Compliance Provides the compliance data of the entire list of licensed products 
present.

 Compliance Report: Shows the compliance status for all licensed 
products. Includes general details such as the number of 
unreconciled catalog and discovered products. For each licensed 
product, includes details such as license quantity, installation 
quantity, active usage quantity, and unused installations.

 Status Summary: Summarizes the total number of licensed 
products, purchase records, catalog products, and discovered 
products.

Report Title Description

Report Title Description

Discovered Standalone Components Lists the individual components of a suite that have been discovered 
through an inventory scan of devices. For each component, lists the 
number of installations and how many are being used.

Report Title Description

Licensed Products And Entitlements Lists the licensed products and its associated entitlement details.
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