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III Remote Management

The Remote Management component of Novell® ZENworks® 6.5 Server Management gives you 
the ability to manage remote servers from the management console. You can use ZENworks 6.5 
Server Management to remotely manage Novell NetWare® 5.1/6/6.5 or Windows* 2000/2003 
servers.

Remote Management can save you and your organization time and money. For example, you or 
your organization’s help desk can analyze and remote fix server problems without having to visit 
the server, which reduces problem resolution times and increases productivity.

This documentation contains following sections:

Chapter 19, “Remote Management for NetWare Servers,” on page 741

Chapter 20, “Remote Management for Windows Servers,” on page 751

Appendix M, “Documentation Updates,” on page 773
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19 Remote Management for NetWare Servers

The Java* -based remote console utility (RConsoleJ) for Novell® ZENWorks® 6.5 Server 
Management lets you control a Novell NetWare® server and perform the following tasks:

Use console commands as you would at the server console

Use NLMTM programs as you would at the server console (for example, edit.nlm to edit files)

Send console commands in the server’s native language from the RConsoleJ Client using 
Buffer Input

Control the server from another server that is using RConsoleJ

Upgrade a NetWare server (text-based UI only)

Secure Socket Layer (SSL) based secure session

This section contains the following topics:

“Overview of RConsoleJ Components” on page 741

“Loading Agents at Startup” on page 742

“Setting Up RConsoleJ” on page 743

“Initiating Remote Sessions Using RConsoleJ” on page 745

“Managing Remote NetWare Servers” on page 748

“Changing the Password of the RConsoleJ Agent” on page 749

Overview of RConsoleJ Components
RConsoleJ has the following components. These components interact with each other during the 
remote control session of a NetWare server:

“RConsoleJ Client” on page 741

“RConsoleJ Agent” on page 742

“RConsoleJ Proxy Agent” on page 742

RConsoleJ Client
The RConsoleJ Client is a Java-based utility running on the workstation. From the RConsoleJ 
Client you can remote control and monitor all NetWare console operations. 
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RConsoleJ Agent
The RConsoleJ Agent (rconag6.nlm) is a utility running on the target NetWare server. The target 
NetWare server can be connected over IP, IPXTM, or IP/IPX running the RConsoleJ Agent. The 
RConsoleJ Agent services all RConsoleJ Client requests.

The RConsoleJ Agent advertises its services using the Service Location Protocol (SLP) on a 
NetWare 5.x and later. 

RConsoleJ Proxy Agent
The RConsoleJ Proxy Agent (rconprxy.nlm) is a utility running on a NetWare server (supported 
only on NetWare 5.x and later). It routes all IP packets to IPX and vice versa.

The RConsoleJ Proxy Agent advertises its services using the Service Location Protocol (SLP).
IMPORTANT: If the target NetWare server uses only IPX, the NetWare server (loaded with the RConsoleJ 
Proxy Agent) must have both IP and IPX stacks installed.

Loading Agents at Startup
You can load the RConsoleJ Agent and the RConsoleJ Proxy Agent at the startup.

“Loading RConsoleJ Agent at Startup” on page 742

“Loading RConsoleJ Proxy Agent at Startup” on page 743

Loading RConsoleJ Agent at Startup
You can load RConsoleJ Agent (rconag6.nlm) at startup using either of the following methods:

“Using Encrypted Password (Recommended)” on page 742

“Using Plain Text Password” on page 743

Using Encrypted Password (Recommended)

1 Prepare the ldrconag.ncf script file.

1a At the console prompt, enter rconag6 encrypt.

1b In the RConsoleJ Agent server screen, enter the password and port numbers.

1c Enter Y.

2 Prepare the autoexec.ncf file to run the ldrconag.ncf script file at startup.

2a Comment out the following line:

load rconag6 user_defined_password_here 2034 16800 2036 

2b Enter the following line:

ldrconag

NOTE: The ZENworks 6.5 Server Management Remote Management Agent install will automatically execute 
the above steps if you have specified a password for the managed server in the install wizard. 
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Using Plain Text Password

Enter the following line in autoexec.ncf:

load rconag6 your_password 2034 16800 2036

Loading RConsoleJ Proxy Agent at Startup
To load the RConsoleJ Proxy Agent (rconprxy.nlm) at the startup, enter the following line in 
autoexec.ncf:

load rconprxy 2035

Setting Up RConsoleJ
To set up RConsoleJ, complete the following sections:

“Loading the RConsoleJ Agent” on page 743

“Running the RConsoleJ Client” on page 744

“Loading the RConsoleJ Proxy Agent on a Proxy Server” on page 744

Loading the RConsoleJ Agent
1 At the server console prompt, enter

rconag6

2 Enter the password you want network administrators to use when accessing the target 
NetWare server using RConsoleJ.

3 Enter the TCP port number. 

The default value is 2034.

If the server communicates using IPX only, enter -1 to disable TCP listening.

To enable listening over a dynamically assigned port, enter 0.

4 Enter the SPXTM port number on which RCONAG6 will listen for a proxy server. 

The default is 16800.

If the server communicates using IP only, enter -1 to disable SPX listening.

To enable listening over a dynamically assigned port, enter 0.
NOTE: /DEV/TCP and /DEV/TCPSSL will fail if you are using a pure IPX server.

To enable RConsoleJ across the firewall, you need to keep the following ports open: 2034, 2035, and 
2036. 

5 Enter the TCP port number for the secure session.

The default is 2036.

Ensure that the Key Material Object named SSL CertificateDNS has been created.
NOTE: The Secure connection is available only on IP and not on IPX.
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Running the RConsoleJ Client
You can run the RConsoleJ client from a workstation or a NetWare server. 

“Running the RConsoleJ Client from a Workstation” on page 744

“Running the RConsoleJ Client on a NetWare Server” on page 744

Running the RConsoleJ Client from a Workstation

You can run the RConsoleJ Client on a workstation using any of the following methods:

From a Windows* 2000/XP workstation, browse to ConsoleOne_installation_directory\1.2, 
and run rconj.exe.

In Novell ConsoleOneTM, right-click the NetWare server object that you want to remotely 
control, then click Remote Management.

In ConsoleOne, select the NetWare server object and then from the Tools menu, click 
ZENworks Remote Management > Remote Console > NetWare.

In ConsoleOne, right-click a Subscriber or Distributor object, then click Remote 
Management.

If you have installed ZENworks 6.5 Management and Monitoring Services, select the 
NetWare server in the Atlas Namespace, then click Remote Management.

Running the RConsoleJ Client on a NetWare Server

You can run the RConsoleJ Client on a NetWare server using any of the following methods:

In ConsoleOne, right-click the NetWare server object that you want to remote control and 
click Remote Management, or click the NetWare server object and then from the Tools option 
click ZENworks Remote Management > Remote Console > NetWare.

From the server console prompt, enter rconj.ncf.

From the server GUI, click Novell > Programs > RConsoleJ.

Loading the RConsoleJ Proxy Agent on a Proxy Server
The NetWare server loaded with RConsoleJ Proxy Agent should have an IP/IPX stack loaded.

1 At the server console prompt, enter the following command:

rconprxy

2 Enter the TCP port number on which RCONPRXY will listen for RConsoleJ.

The default is 2035.

To enable listening over a dynamically assigned port, enter 0.

When the NetWare server is running the RConsoleJ Proxy Agent, the RConsoleJ Client can 
communicate through it with the target NetWare server that uses only IPX to communicate.
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Initiating Remote Sessions Using RConsoleJ
This section will help you initiate remote sessions using RConsoleJ in the following scenarios: 

“Scenario 1: An IP Client Controlling an IP NetWare Server” on page 745

“Scenario 2: An IP Client Controlling an IPX NetWare Server” on page 747

Scenario 1: An IP Client Controlling an IP NetWare Server

Prerequisites

“Loading the RConsoleJ Agent” on page 743

“Running the RConsoleJ Client” on page 744

Starting a Secured IP Connection

The RConsoleJ Client communicates directly with the RConsoleJ Agent using TCP/IP. 

To setup a Secured IP connection, complete the following:

1 In the RConsoleJ Connection dialog box, select Secure IP.

2 Enter the IP address of the target NetWare server, or click the Remote Servers icon and then 
select the target NetWare server from the list.

3 Enter the password provided during loading of the RConsoleJ Agent on the target server.

NetWare Server

The target server is 
controlled from the 
client

RC

on
soleJ Client

Workstation NetWare
Server

or

The RConsoleJ Client 
communicates over IP

Secure IP Target
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4 Enter the Port Number.

The default is 2036.

5 Click Connect.

6 To ensure server authentication, read the Untrusted Certificate Verification server certificate 
issued by the target server and click OK to accept.

Starting an Unsecure IP Connection

The RConsoleJ Client communicates directly with the RConsoleJ Agent using TCP/IP.

When you run the RConsoleJ client from ConsoleOne, the Novell RConsoleJ dialog box is 
displayed with the NetWare Server IP address. To run the RConsoleJ client, see “Running the 
RConsoleJ Client” on page 744.

To start an IP connection:

1 In the RConsoleJ Connection dialog box, select Unsecure.

2 Select Connect Directly as the unsecure connection option.

3 Enter the IP address of the target NetWare server, or click the Remote Servers icon and then 
select the target NetWare server from the list.

4 Enter the password specified during loading the RConsoleJ Agent.

5 Enter the port number.

The default is 2034.

NetWare ServerUnsecure
IP

The target server is 
controlled from the 
client

RC

on
soleJ Client

Workstation NetWare
Server

or

The RConsoleJ Client 
communicates over IP

Target
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6 Click Connect.

Scenario 2: An IP Client Controlling an IPX NetWare Server

Prerequisites

“Loading the RConsoleJ Agent” on page 743

“Running the RConsoleJ Client” on page 744

“Loading the RConsoleJ Proxy Agent on a Proxy Server” on page 744

Starting an IPX Connection

The RConsoleJ Client communicates with the RConsoleJ Agent through the RConsoleJ Proxy 
Agent because the target NetWare server is based only on IPX. 

The RConsoleJ Proxy Agent is loaded on a NetWare server (proxy server) that has both IP and IPX 
stacks loaded. The RConsoleJ Proxy Agent receives all the IP requests from the RConsoleJ Client, 
converts them to IPX requests, and then sends them to the RConsoleJ Agent and vice-versa.

When you run the RConsoleJ client from ConsoleOne, the Novell RConsoleJ dialog box is 
displayed with the NetWare Server IP address. To run the RConsoleJ client, see “Running the 
RConsoleJ Client” on page 744.

NetWare Server

IP

The target server is 
controlled from the 
client

RC

on
soleJ Client

Workstation NetWare
Server

or

IP

IPX

or

The RConsoleJ Client 
communicates over IP

The proxy server provides 
access to IPX-only target 
servers (and IP servers if
desired).*

*If the target server uses IPX, the proxy server must have 
both IP and IPX stacks loaded.

Target

Proxy Server
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To start an IPX connection:

1 In the RConsoleJ Connection dialog box, select Unsecure.

2 Select Connect Via Proxy as the unsecure connection option.

3 From the Connect Type drop-down list, select Connect through Proxy. 

4 Enter the IP/IPX address of the target NetWare server, or select SPX to get the IPX address 
and TCP to get the IP address.

5 The default port is be selected when you make the above change.

The default is 16800 for IPX address and 2034 for IP address.

6 Enter the IP address of the proxy server, or click the Remote Servers icon and then select a 
proxy server from the list.

7 Enter the port number specified during loading the RConsoleJ Proxy Agent.

The RConsoleJ Client communicates with the RConsoleJ Proxy Agent on this port.

The default is 2035.

8 Click Connect.

Managing Remote NetWare Servers
After RConsoleJ establishes connection with the NetWare server, you can view and manage the 
target NetWare server from your desktop.

The following sections explain the tasks you can perform to effectively manage a remote NetWare 
Server:

“Sending Console Commands in the Server’s Native Language” on page 748

“Synchronizing RConsoleJ Client and Target NetWare Screens” on page 749

Sending Console Commands in the Server’s Native Language
You can send console commands in the server’s native language from the RConsoleJ Client using 
Buffer Input as shown in the following graphic. The buffer stores a list of ten history commands.
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To send console commands, do the following:

1 From the Novell RConsoleJ Client window, enter the command that you want to run at the 
target server in the Buffer Input field.

2 Click Send.

Synchronizing RConsoleJ Client and Target NetWare Screens
You can synchronize the screen displayed on the target NetWare server and the screen displayed 
on the RConsoleJ Client with each other. Switching the screen in the RConsoleJ Client switches 
the screen at the target server console and vice versa.

To synchronize the screens, from the Novell RConsoleJ window, click Sync.

To switch the screen on the server console to the currently activated screen on the RConsoleJ 
Client, click Activate. 

Changing the Password of the RConsoleJ Agent
You can change the agent password to ensure that RConsoleJ sessions are secure.

To change the agent password for a remotely managed NetWare server:

1 At the NetWare Console prompt, enter unload rconag6 to unload rconag6.nlm.

2 Enter rconag6 encrypt.

3 Enter a new password.

4 Enter the TCP port number. The default is 2034.

5 Enter the SPX port number. The default is 16800.

6 Enter the TCP port number for the secure session. The default is 2036.

7 Enter y when prompted to save the following command line in the ldrconag.ncf file.

If you enter n, the ldrconag.ncf file will not be updated. The new password will be valid only 
for the current session. At a later time, if you load RCONAG6 from the ldrconag.ncf file later, 
the previously saved password will be used. 

The new password will be in effect when the agent is loaded from the LDRCONAG script file 
after you reboot the server.

Alternatively, you can change the password using the following commands:

For NetWare 5.x:

LOAD RCONAG6 - E encrypted_password TCP_port_number 
SPX_port_number

For NetWare 6.x:

LOAD RCONAG6 - E encrypted_password TCP_port_number 
SPX_port_number Secure_port_number
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20 Remote Management for Windows Servers

The Remote Management component of Novell® ZENworks® 6.5 Server Management allows you 
to remotely manage Windows* 2000/2003 servers from your computer.

This chapter contains the following topics:

“Remote Management Terminology” on page 751

“Understanding Remote Management for Windows Servers” on page 752

“Setting Up Security for Remote Management” on page 753

“Managing Remote Windows Servers” on page 756

Remote Management Terminology
The following brief glossary provides basic definitions of Remote Management terms:

Managed server: A Windows server that you want to remotely manage. You must install the 
ZENworks 6.5 Remote Management Agent on it. If you manage the server through the Server 
Remote Management Policy, you must install the ZENworks 6.5 Subscriber component also‘.

Management console: A Windows 2000/XP workstation or 2000/2003 server running Novell 
ConsoleOne® with the ZENworks 6.5 Remote Management ConsoleOne snap-ins installed. The 
management console provides the interface where you manage and administer your network.

Management server: A server with Novell eDirectoryTM and the ZENworks 6.5 Distributor 
components. The eDirectory and Distributor components must be installed if you want to manage 
servers through the Server Remote Management Policy. Your management server can be a 
managed server.

Remote operator: A user who can remotely manage servers.

Administrator: A person who has the rights to install Remote Management components. All 
administrators are remote operators but all remote operators are not administrators.

Remote Management Agent: A Server Management component that is installed on a managed 
server so the remote operator can remotely manage that server. The Remote Management Agent 
starts automatically when the managed server boots up and authenticates the remote operator when 
the remote session is initiated.

Viewing window: A representation of the managed server desktop. It is displayed on the 
management console when the remote operator initiates a Remote Management session.
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Understanding Remote Management for Windows Servers
The following illustration depicts the functionality of the ZENworks 6.5 Remote Management, 
which is explained below:

To remotely manage a server, the ZENworks 6.5 Remote Management Agent component must be 
installed on that server. For more information, see “Policy-Enabled Server Management 
Installation” in the Novell ZENworks 6.5 Server Management Installation Guide. 

The Remote Management Agent starts automatically when the managed server boots up. The 
agent password can be set either by the administrator during the Remote Management installation 
or by the user at the managed server after the installation. The remote operator would be required 
to enter the password when he or she initiates a Remote Management session with a a managed 
server. On successful verification, the Remote Management session proceeds and the Viewing 
window is displayed on the management console.

The user at the managed server can change the agent password. In such a case, the new password 
will have to be communicated to the remote operator. It is recommended that the password be 
changed frequently to prevent it from being compromised. For more details on how to set up a new 
agent password or change the existing agent password, see “Setting Up the Agent Password at the 
Managed Server” on page 756.

ZENworks Remote Management

NetWare
or

Windows NT/2000

IP

Windows NT/2000/XP
Management Console

 Remote Control

Remote View

Remote
Operator

Remote
Management Agent

NDSNDSZENworks

Managed Server

Windows NT/2000

IP IP
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Setting Up Security for Remote Management
The information in the following sections help you in setting up security for the Remote 
Management sessions:

“Configuring the Remote Management Policies” on page 753

“Setting Up the Agent Password at the Managed Server” on page 756

Configuring the Remote Management Policies
To configure the Remote Management policies, you must perform the following tasks:

“Creating the Policy Packages” on page 753

“Creating and Configuring the TED Objects” on page 754

“Configuring the Server Remote Management Policy” on page 754

“Configuring the Distribution Object for Remote Management” on page 755

“Configuring the Distributor and the Subscriber Objects” on page 756

You can also change the security settings on the managed servers by modifying the [Remote 
Management Policy] section in the ZENworks_agent_directory\rmagent\zfsrcpol.ini file. 

Creating the Policy Packages

ZENworks 6.5 requires policy packages in the eDirectory tree that can hold the server policies. 
You can later configure and enable the server policies.

Policy packages are eDirectory objects that contain collections of policies grouped according to 
the object types. You should create an Organizational Unit (OU) for holding the policy packages. 
Consider the following when determining where to place this OU:

Whether you have partitions in your tree

The 256-character limit in eDirectory for the full distinguished name

How you will use the Search policy to locate the policy package

If you install ZENworks 6.5 Desktop Management to your tree, you may want to keep the 
ZENworks Server Management and Desktop Management policies in separate containers, such as 
Server_Policies and Desktop_Policies.

For Remote Management, create two containers, one for Tiered Electronic Distribution (TED) 
objects and the other for the Remote Management policy package.

To create a container:

1 In ConsoleOne, right-click the container where you want the container for the policy packages 
placed.

2 Click New > Object > Organizational Unit > OK.

3 Name the container, for example, Server_Policies, then click OK.
IMPORTANT: If you have partitions that are accessed across a WAN, make sure that the Policy Package 
objects are in the same partition as the Server object so that the Policy/Package Agents are loaded. Also make 
sure that the Search policy does not require searching outside the partition where the Server object exists. 
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For Remote Management, you must create the Distributed Server package. The Distributed Server 
package is required to distribute the Remote Management policies among the managed servers for 
enforcement.

To create the Distributed Server package:

1 In ConsoleOne, right-click the policy package’s container, then click New > Policy Package.

The Policy Package Wizard is displayed.

2 In the Policy Packages list, select Distributed Server Package, then click Next.

3 Enter a name for the Distributed Server Package, then click Next > Finish.

Creating and Configuring the TED Objects

For Remote Management, you must create and configure the following TED objects:

TED Distribution

TED Channel

To create and configure the TED objects, see Chapter 3, “Tiered Electronic Distribution,” on 
page 85.

Configuring the Server Remote Management Policy

The Server Remote Management Policy defines the behavior of the Remote Management Agent. 
This policy is distributed to the specified Windows managed servers using the TED, which helps 
the remote operator to associate the Remote Management policy to a group of Windows managed 
servers from the management console.

To configure the Server Remote Management Policy:

1 In ConsoleOne, right-click the Distribute Server Package object, then click Properties.

2 Click the Policies tab and select the Windows sub-option.

3 Select the check box under the Enabled column for the Server Remote Management Policy.

4 Click the Properties button > the Remote Management tab.

5 Click the General tab, then select the any of following options:

Enable Session Encryption: Encrypts the Remote Control and Remote View sessions. 
The Remote Operator will not be able to change this to an unencrypted mode. If you do 
not select this check box, the remote sessions will be unencrypted by default. In this case, 
the Remote Operator will have an option to switch over to the encrypted mode from the 
Console. An encrypted session will slightly impact the performance of remote sessions 
over fast links. 
IMPORTANT: This option will not work for ZENworks for Servers 3.x and earlier versions of the 
Remote Management Agent. 

Allow User to Request Remote Session: Enables the user at the managed server to 
request the Remote Operator on the management console to perform a remote session. 
IMPORTANT: This option will not work for ZENworks for Servers 3.x and earlier versions of the 
Remote Management Agent. 

Display Remote Management Agent Icon To Users: Displays the Remote 
Management Agent icon in the system tray of the Windows 2000 or Windows 2003 
managed servers on which the Remote Management Agent is running. 
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6 Click the Remote Control tab, then select the any of following options:

Prompt User for Permission to Remote Control: Allows the user at the managed server 
to either accept or reject the Remote Control session initiated by the remote operator. 

Give User Audible Signal when Remote Controlled: Generates an audible signal on 
the managed server every time the remote operator remote controls the managed server. 
You can modify the time interval as to when you want the audible signal should be 
generated. 

Give User Visible Signal when Remote Controlled: Displays a visible signal with the 
name of the remote operator and console machine on the managed server every time the 
remote operator remote controls the managed server. You can modify the time interval as 
to when the name should be displayed. 

Allow Blanking User’s Screen: Allows the remote operator to blank the screen of the 
managed server during a remote control session and also locks the mouse and keyboard 
controls.

Allow Locking User’s Keyboard and Mouse: Allows the remote operator to lock the 
keyboard and mouse controls of the managed server during a remote control session. 

7 Click the Remote View tab, then select the any of following options:

Prompt User for Permission to Remote View: Allows the user at the managed server 
to either accept or reject the Remote View session initiated by the remote operator. 

Give User Audible Signal when Remote Viewed: Generates an audible signal on the 
managed server every time the remote operator remotely views the managed server. You 
can modify the time interval as to when you want the audible signal should be generated. 

Give User Visible Signal when Remote Viewed: Displays a visible signal with the name 
of the remote operator and console machine on the managed server every time the remote 
operator remotely views the managed server. You can modify the time interval as to when 
the name should be displayed. 

8 Click Apply > Close.

9 Right-click the Server Remote Management Policy, then select Edit Schedule.

10 Modify the schedule.

11 Click Apply > Close.

12 To associate the Server Remote Management Policy with a managed server, click the 
Distribution tab.

13 Click Add.

14 Browse for and select the Distribution object, then click OK

15 Click Apply > Close.

Configuring the Distribution Object for Remote Management

You must configure the Distribution object for distributing the Remote Management policies.

To configure the Distribution object:

1 In ConsoleOne, right-click the Distribution object, then click Properties.

2 Click the Type tab.

3 Select Policy Package from the Select Type drop-down list.
Remote Management for Windows Servers 755



    Novell Confidential                                                                                            Manual (ENU)  21 December 2004
4 Click Add, then select the Distributed Server package that has the Server Remote 
Management Policy.

5 Click the Schedule tab.

6 Modify the schedule.

7 Click Apply > Close.

Configuring the Distributor and the Subscriber Objects

To configure the Distributor and the Subscriber objects, see Chapter 3, “Tiered Electronic 
Distribution,” on page 85.

If the managed servers are residing on a different eDirectory tree or the Windows 2000/2003 server 
does not have the eDirectory installed, you must create and configure an External Subscriber 
object for sending Distributions to Subscribers residing on managed servers in other trees. For 
more information on External Subscribers, see “External Subscribers” on page 154.

Setting Up the Agent Password at the Managed Server
The user at the managed server can change the password of the Remote Management Agent to 
make sure that the Remote Management sessions are secure.

To change the agent password:

1 Right-click the Remote Management Agent icon from the system tray of the Windows 2000/
2003 managed server.

2 Click Security > Set Password.

Use a password of ten or fewer ASCII (non-extended) characters. The password is case-
sensitive and cannot be blank.

The new password must be communicated to the remote operator each time it is changed.

Managing Remote Windows Servers
The following sections provide information that will help you effectively manage Remote 
Management sessions on Windows 2000/2003 servers:

“Initiating Remote Management Sessions” on page 757

“Operating with Windows XP SP2” on page 759

“Configuring Remote Management Ports” on page 759

“Managing a Remote View Session” on page 760

“Managing a Remote Control Session” on page 762

“Remote Operator Identification Display” on page 770

“Viewing the Audit Log for Remote Management Sessions” on page 770

“Improving the Remote Management Performance” on page 770

“Shutting Down and Restarting the Remote Management Agent” on page 771
756   Novell ZENworks 6.5 Server Management Administration Guide



    Novell Confidential                                                                                            Manual (ENU)  21 December 2004
Initiating Remote Management Sessions
You have several options for initiating a Remote Management session from ConsoleOne. They 
include the following:

“Initiating Remote Management Session from the ConsoleOne Tools Menu” on page 757

“Initiating Remote Management Session from the eDirectory/NDS Namespace” on page 757

“Initiating Remote Management Session from the Atlas Namespace” on page 758

“Initiating Remote Management Session from the Remote Management Agent” on page 758

Initiating Remote Management Session from the ConsoleOne Tools Menu

1 In ConsoleOne, click Tools > ZENworks Remote Management > Remote Console > 
Windows.

2 In the Remote Management dialog box, enter the IP address or the DNS name of the managed 
server.

3 Enter the agent password.

4 Select the Remote Management operation that you want to initiate with the managed server. 

5 Click OK.

Initiating Remote Management Session from the eDirectory/NDS Namespace

You can start a Remote Management session from the eDirectory (NDS) namespace (in 
ConsoleOne) using one of the following methods:

1 In ConsoleOne, select a managed server.

2 Click Tools > ZENworks Remote Management > Remote Console > Windows.

3 In the Remote Management dialog box, select the IP address of the managed server from the 
Agent drop-down list.

The IP address of the selected managed server is automatically populated to the Agent drop-
down list.

4 Enter the agent password.

5 Select the Remote Management operation that you want to initiate with the managed server. 

6 Click OK.

You can also use the following procedure:

1 In ConsoleOne, right-click a managed server.

2 Click Remote Management.

3 In the Remote Management dialog box, select the IP address of the managed server from the 
Agent drop-down list.

The IP address of the selected managed server is automatically populated to the Agent drop-
down list.

4 Enter the agent password.

5 Select the Remote Management operation that you want to initiate with the managed server. 

6 Click OK.
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Initiating Remote Management Session from the Atlas Namespace

Before initiating a Remote Management session from the Atlas namespace (in ConsoleOne), make 
sure that the NetWare® Management AgentTM (NMA) is installed and the Discovery discovers the 
network topology.

To initiate the Remote Management session:

1 In ConsoleOne, right-click a managed server.

2 Click Actions > Remote Control or Remote View.

3 Select the IP address and enter the agent password.

The IP address of the selected managed server is automatically populated to the Agent drop-
down list.

4 Click OK.

Initiating Remote Management Session from the Remote Management Agent

If the managed server is configured behind dynamic NAT, the managed server cannot be accessed 
from the management console but the management console can be accessed from the managed 
server. To resolve this problem:

1 The user at the managed server must initiate a request for a Remote Management session to 
the remote operator by using the Request Session option.
IMPORTANT: Before initiating a Remote Management session from the Remote Management Agent, 
the remote operator must ensure that ConsoleOne is running on the management console.

NOTE: The first instance of ConsoleOne receives the request when a session request is initiated from a 
Remote Management Agent to the management console running on a terminal server. None of the 
ConsoleOne instances receive the session request until all ConsoleOne instances are closed on the 
session where ConsoleOne was launched for the first time. To receive the session request, ConsoleOne 
must be launched again on any terminal session.

To request for a session, the user at the managed server must do the following:

1a Right-click the Remote Management Agent icon.

1b Select Request Session.

1c Enter the IP address or the DNS name of the management console.

1d Select the Remote Control or Remote View operation from the drop-down list.

1e Click OK.

2 The Remote Management Listener listens to the request and notifies the remote operator about 
it. The remote operator must accept the request and provide the following credentials for the 
request in the Select Authentication Mode dialog box:

2a Enter the password for authentication.

2b Click OK.
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Operating with Windows XP SP2
Windows XP SP2 comes with a firewall enabled by default. As a result, the Remote Control 
Listener running on Windows XP SP2 cannot receive connections initiated by the Remote 
Management Agent.

You need to configure the firewall settings to allow the Remote Control Listener to receive 
connections.

The Remote Control Listener binds to TCP port 1762 by default. In order to change the ports, refer 
to “Configuring Remote Control Listener Port” on page 759.

Configuring Remote Management Ports
This section provides information on the following topics:

“Configuring Remote Management Agent Port” on page 759

“Configuring Remote Control Listener Port” on page 759

Configuring Remote Management Agent Port

The Remote Management Agent port binds to TCP port 1761 by default. You may configure it to 
run on a different TCP port by following the steps mentioned below:

1 Open ZENworks_agent_directory\rmagent\rmcfg.ini file.

2 Under the Remote Management Agent Port section, set the DefaultCommPort to the desired 
port number.

3 Restart the Novell ZfS Remote Management Agent service.

To initiate a remote session to a managed server where the Remote Management Agent is running 
on any port other than 1761, the following modifications need to be done on the management 
console:

1 Open the ConsoleOne_directory\1.2\bin\rmports.ini file.

2 Under the Remote Management Agent Ports section, add the port number.

NOTE: If the Remote Management Agents are running on different ports on different managed servers, you 
may mention the port numbers one below the other under the Remote Management Agent Ports section.

Configuring Remote Control Listener Port

The Remote Control Listener port binds to TCP port 1762 by default when ConsoleOne is started. 
You may configure it to run on a different TCP port by following the steps mentioned below:

1 Open ConsoleOne_directory\1.2\bin\rmports.ini file. 

2 Under the Remote Control Listener Port section, set the DefaultCommPort to the desired port 
number.

3 Restart ConsoleOne.

To initiate a remote session request to a management console, where the Remote Control Listener 
is running on any port other than 1762, the following modifications need to be done on the 
managed servers:

1 Open the ZENworks_agent_directory\rmagent\rmcfg.ini file.

2 Under the Remote Control Listener Ports section, add the port number.
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NOTE: If the Remote Control Listeners are running on different ports on different management consoles, you 
may mention the port numbers one below the other under the Remote Control Listener Ports section.

Managing a Remote View Session
After you have initiated a Remote Management session and selected Remote View as the 
operation, you have several options to help you view the managed server. 

“Controlling the Display of the Viewing Window” on page 760

“Using the Viewing Window Accelerator Keys” on page 761

“Defining a Custom Accelerator Key Sequence” on page 762

Controlling the Display of the Viewing Window

You can regulate the display of the Viewing window through using the control options.

To enable the control options:

1 Click the Remote Management Agent icon, located at the top left corner of the Viewing 
window.

2 Click Configure.

Option Description

Enable High Quality 
Scaling

Enhances the quality of images in the Scale To Fit Mode.

Enable Accelerator 
Keys

Enables the accelerator keys on the management console so that you can 
change the default accelerator key sequences during the remote session.

Enable Encryption Encryption is an optional feature and will be effective per session. If the 
saved configuration has enabled encryption, the session will be encrypted 
from the start of the session. 

Encrypting a whole session provides greater security as the data 
transferred over the wire will be encrypted and it will be difficult to decipher 
anything meaningful even after the data over the wire is captured. 
However, it impacts performance slightly and is recommended when the 
security requirement is very stringent.

Hide Wallpaper Suppresses any wallpaper displayed on the managed server. This option 
is enabled by default. If you want to display the wallpaper on the managed 
server during a Remote View session, disable this option.

Color Quality By default, on a fast Link, the color quality is set to Normal and on a slow 
link the color quality is set to 256 colors. You can change the color quality 
of the slow link or the fast link to one of the following:

16 Colors: Forces the use of 16-color palette on the managed server 
during a Remote Management session. This enhances the Remote 
Management performance particularly over a slow-link. 

256 Colors: Forces the use of 256-color palette on the managed server 
during a Remote Management session. This enhances the Remote 
Management performance over a slow-link.

Normal: The color is not altered and the setting is the same on the 
managed server during a Remote Management session.
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3 To save the Control Parameter settings, select the Save on Exit check box.

The saved settings are implemented in the next Remote View session.

4 Click OK.

Using the Viewing Window Accelerator Keys

You can use accelerator keys to assign the shortcut keys to the control options and also to control 
the display of the Viewing window. Default accelerator key sequences are assigned to each 
accelerator key option. The Accelerator Keys dialog box displays the default key sequence in the 
edit field of each accelerator key option. You can define a custom accelerator key sequence to 
change the default sequence. For more information, see “Defining a Custom Accelerator Key 
Sequence” on page 762.

To enable the Accelerator Keys option:

1 Click the Remote Management Agent icon, located at the top left corner of the Viewing 
window.

2 Click Configure.

3 Select Enable Accelerator Keys.

4 Click OK.

To open the Accelerator Keys dialog box:

1 Click the Remote Management Agent icon, located at the top left corner of the Viewing 
window.

2 Click Accelerator Keys.

The following table explains the Accelerator Key options you can during the Remote View 
session:

Network Type if the managed server is connected by a LAN, select the Fast Links option 
to enhance the Remote Management performance.

if he managed server is connected over a dial-up link or by WAN, select 
the Slow Links option to enhance the Remote Management performance.

Option Default Keystroke Description

Toggle Full Screen Ctrl+Alt+M Applicable only if the color resolution settings on the 
management console and managed server are 
same.

Sizes the Viewing window to the size of your screen 
without window borders.

Refresh Screen Ctrl+Alt+R Refreshes the Viewing window.

Restart Session Ctrl+Alt+T Re-establishes the connection with the managed 
server.

Enable Accelerator Keys Ctrl+Alt+A Allows you to enable or disable the default 
accelerator key sequences.

Option Description
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Defining a Custom Accelerator Key Sequence

The default keystrokes assigned to the accelerator key options are displayed in the edit field to the 
right of each accelerator key option in the Accelerator Keys dialog box. You can change the 
accelerator key sequence and define a custom accelerator key sequence if you do not want to use 
the default keystroke.

To define a custom accelerator key sequence:

1 Click the Remote Management Agent icon, located at the top-left corner of the Viewing 
window.

2 Click Accelerator Keys.

3 Click the edit field of the accelerator key option where you want to define a custom accelerator 
key sequence.

4 Press the new accelerator key sequence.

5 Click OK.
IMPORTANT: The shift keys are left-right sensitive, and are indicated in the Control Options dialog box as 
LShift and RShift. Avoid the use of standard key sequences like Ctrl+C, Ctrl+V, Shift+Del, etc.

Managing a Remote Control Session
After you have initiated a Remote Management session and selected Remote Control as the 
operation, you can control the managed server from the management console to provide user 
assistance and to help resolve server problems. With remote control connections, the remote 
operator can go beyond viewing the managed server to taking control of it.

You can effectively manage a Remote Control session by performing the following tasks with the 
Viewing window control options, the Viewing window toolbar buttons, and the Remote 
Management Agent icon options:

“Controlling the Display of the Viewing Window” on page 763

“Using the Viewing Window Accelerator Keys” on page 764

“Using the Toolbar Buttons on the Viewing Window” on page 766

“Enabling the Wallpaper on the Managed Server” on page 767

“Using the Remote Management Agent Icon” on page 768

“Setting Up a Password for the Managed Server” on page 768

“Obtaining Information About Remote Management Sessions” on page 769

Stop Viewing Left-Shift+Esc Closes the Viewing window.

Configure Dialog Alt+M Opens the Control Parameters dialog box.

Accelerator Keys Dialog Alt+A Opens the Accelerator Keys dialog box.

Poll Full Screen Alt + L Scans and renders the information of the entire 
screen of the managed server.

Scale To Fit Ctrl+Alt+G Hides the scroll bars and scale the Remote 
Management window to fit your screen.

Option Default Keystroke Description
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“Obtaining General Information” on page 769

“Obtaining Security Information” on page 769

Controlling the Display of the Viewing Window

You can control the display of the managed server by using the Viewing window control options.

To enable control options:

1 Click the Remote Management Agent icon, located at the top left corner of the Viewing 
window.

2 Click Configure.

3 Select the control options you want to enable for the remote session.

The following table explains the options you can use to control the display of the Viewing 
window.

Option Description

Block Mouse 
Movements to Agent

To reduce network bandwidth consumption, blocks all the mouse 
movements to the Agent.

Enable High Quality 
Scaling

Enhances the quality of images in the Scale To Fit mode.

Enable Accelerator 
Keys 

Enables the accelerator keys on the management console so that you can 
change the default accelerator key sequences during the remote session.

Enable Encryption Encryption is an optional feature and will be effective per session. If the 
saved configuration has enabled encryption, the session will be encrypted 
from the start of the session. 

Encrypting a whole session provides greater security as the data 
transferred over the wire will be encrypted and it will be difficult to decipher 
anything meaningful even after the data over the wire is captured. 
However, it impacts performance slightly and is recommended when the 
security requirement is very stringent.

System Key Pass Passes Alt-key sequences on the management console to the managed 
server.

NOTE: During a Remote View session, the System Key pass Through 
option is not enabled.

Hide Wallpaper Suppresses any wallpaper displayed on the managed server. This option 
is enabled by default. If you want to display the wallpaper on the managed 
server during a Remote Control or Remote View session, disable this 
option.

Enable Encryption Encryption is an optional feature and will be effective per session. If the 
saved configuration has enabled encryption, the session will be encrypted 
from the start of the session. 

Encrypting a whole session provides greater security as the data 
transferred over the wire will be encrypted and it will be difficult to decipher 
anything meaningful even after the data over the wire is captured. 
However, it impacts performance slightly and is recommended when the 
security requirement is very stringent.
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4 To save the Control Parameter settings, select the Save on Exit check box.

The saved settings are implemented in the next Remote Control session.

Using the Viewing Window Accelerator Keys

You can use accelerator keys to assign shortcut keys to the control options and also to control the 
display of the Viewing window. Default accelerator key sequences are assigned to each accelerator 
key option. The Accelerator Keys dialog box displays the default key sequence in the edit field of 
each accelerator key option. You can define a custom accelerator key sequence to change the 
default sequence. For more information, see “Defining a Custom Accelerator Key Sequence” on 
page 762.

To enable the Accelerator Keys option:

1 Click the Remote Management Agent icon, located at the top left corner of the Viewing 
window.

2 Click Configure.

3 Select Enable Accelerator Keys.

To open the Accelerator Keys dialog box:

1 Click the Remote Management Agent icon, located at the top left corner of the Viewing 
window.

2 Click Accelerator Keys.

Color Quality By default, on a fast Link, the color quality is set to Normal and on a slow 
link the color quality is set to 256 colors. You can change the color quality 
of the slow link or the fast link to one of the following:

16 Colors: Forces the use of 16-color palette on the managed server 
during a Remote Management session. This enhances the Remote 
Management performance particularly over a slow-link.

256 Colors: Forces the use of 256-color palette on the managed 
server during a Remote Management session. This enhances the 
Remote Management performance over a slow-link.

Normal: The color is not altered and the setting is the same on the 
managed server during a Remote Management session.

Network Type If the managed server is connected by a LAN, select the Fast Links option 
to enhance the Remote Management performance.

If the managed server is connected over a dial-up link or by WAN, select 
the Slow Links option to enhance the Remote Management performance.

Option Description
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The following table explains the Accelerator Key options you can use to control the display of the 
Viewing window:

Option Default Keystroke Description

Toggle Full Screen Ctrl+Alt+M Applicable only if the color resolution settings on the 
management console and managed server are similar.

Sizes the Viewing window to the size of your screen 
without window borders.

Refresh Screen Ctrl+Alt+R Refreshes the Viewing window.

Restart Session Ctrl+Alt+T Re-establishes the connection with the managed server.

Enable Accelerator 
Keys

Ctrl+Alt+A Enables you to change the default accelerator key 
sequences.

Stop Viewing Left-Shift+Esc Closes the Viewing window.

Configure Dialog Alt+M Opens the Control Parameters dialog box.

Accelerator Keys 
Dialog

Alt+A Opens the Accelerator Keys dialog box.

Poll Full Screen Alt + L Scans and renders the information of the entire screen.

Scale To Fit Ctrl+Alt+G Hides the scroll bars and scale the Remote Management 
window to fit your screen.

System Key Pass Ctrl+Alt+S Passes Alt-key sequences on the management console to 
the managed server.

Mouse/Keyboard 
Lock

Ctrl+L Locks the keyboard and mouse controls at the managed 
server.

This option is available only if the Allow Locking User’s 
Keyboard and Mouse option is enabled in the Server 
Remote Management Policy. 

Blank Screen Ctrl+Alt+B Blanks the screen at the managed server.

This option is available only if the Allow Blanking User’s 
Screen option is enabled in the Server Remote 
Management Policy. 

Reboot Ctrl+Alt+D Sends the Ctrl+Alt+Del keystroke to the managed server.

Display the Security window on the managed server.

Start Alt+R Invokes the Start menu on Windows server.

Switch Applications Ctrl+T Switches applications on managed servers.
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Using the Toolbar Buttons on the Viewing Window

The following table describes the toolbar options in the Viewing window:

Button Default Keystroke Key Function

Screen Blanking Ctrl+L Enabled only if the Allow Blanking User’s Screen option is 
enabled in the effective Remote Control policy of the 
managed server.

Blanks the screen at the managed server. When the 
remote operator selects this option, the screen of the 
managed server is be blacked out and the operations 
performed by the remote operator on the managed server 
are not visible to the user at the managed server.

Not supported over certain display adapters. Refer to the 
ZENworks 6.5 Server Management Readme for the list of 
display adapters that do not support this feature. 

Mouse and 
Keyboard Lock

 

Ctrl+Alt+B Locks the keyboard and mouse controls at the managed 
server. When the remote operator selects this option, the 
user at the managed server will not be able to use the 
keyboard and mouse controls of the managed server.

System Start

 

Alt+R Invokes the Start menu on the managed server.

Application Switcher

 

Ctrl+T Sends the Alt-tab key sequences to the managed server.

Switches applications on managed servers. 

To switch the applications, 

1. In the Viewing window, click the Application Switcher 
icon or press the Application Switcher shortcut key.

2. To traverse to the application you want using the 
Application Switcher icon.

3. To view the application, press Tab.

System Key Pass 
Through

 

Ctrl+Alt+S Sets the system key pass to On or Off.

Passes Alt-key sequences from the management console 
to the managed server.

Certain key sequences such as Ctrl+Esc, Alt+Tab, 
Ctrl+Alt+Del, and Alt+PrintScreen are not allowed even 
when the System Key Pass-Through is set to On. 
However, you can use the toolbar buttons on the Viewing 
window for the Ctrl+Esc, Alt+Tab, and Ctrl+Alt+Del 
keystrokes.

Reboot

 

Ctrl+Alt+D Sends the Ctrl+Alt+Del keystroke to the managed server.

Displays the Security window on the managed server. 
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You can define a custom key sequence if you do not want to use the default key sequence. For more 
information, see “Defining a Custom Accelerator Key Sequence” on page 762.

Enabling the Wallpaper on the Managed Server

When the remote operator initiates a Remote Control session, any wallpaper displayed on the 
desktop of the managed server is suppressed. This feature reduces the response time from the 
managed server for requests from the management console because less traffic is generated over 
the network while the wallpaper is suppressed.

You can configure the control parameter for this option to change the default settings and enable 
the display of the wallpaper on the managed server. When you terminate the Remote Control 
session, the suppressed wallpaper will be restored.

To enable the display of suppressed wallpaper on the managed server:

1 Click the Remote Management Agent icon, located at the top left corner, then click Configure.

2 Deselect the Hide Wallpaper option.

Refresh Screen Ctrl+Alt+R Refreshes the viewing window.

Full Screen Polling Alt+L Scans and renders the information of the entire screen of 
the managed server continuously.

Scale To Fit Ctrl+Alt+G Hides the scroll bars and scales the Remote Management 
window to fit your screen.

Session Encryption Encryption is an optional feature and will be effective per 
session. If the saved configuration has the option enabled, 
the session will be encrypted from the start of the session. 

Encrypting a whole session provides greater security as 
the data transferred over the wire will be encrypted and it 
will be difficult to decipher anything meaningful even after 
the data over the wire is captured. However, it impacts 
performance slightly and is recommended when the 
security requirement is very stringent.

Button Default Keystroke Key Function
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Using the Remote Management Agent Icon

By default, the Remote Management Agent icon is displayed in the system tray of the Windows 
servers. This icon indicates that the Remote Management Agent is loaded on the managed server.

The user at the managed server can right-click the Remote Management Agent icon and choose 
from the following options:

Setting Up a Password for the Managed Server

The user at the managed server can set an agent password. This password overrides the password 
set by the administrator during the ZENworks 6.5 Remote Management installation.

To set the agent password:

1 From the managed server, right-click the Remote Management Agent icon.

2 Click Security > Set Password.

Use a password of ten or fewer alphanumeric characters. The password is case sensitive and 
cannot be blank.

After the completion of the Remote Management session, you can clear the agent password. If you 
clear the agent password, the remote operator cannot perform the Remote Management operations.

To clear the agent password:

1 On the managed server, right-click the Remote Management Agent icon.

2 Click Security > Clear Password.

Option Description

Terminate RC/RV 
Session

Disconnects and closes the remote session on the managed server and 
displays a message on the management console indicating that the remote 
session is closed.

Security Allows the user at the managed server to set or clear the password for the 
server.

Information Displays information such as who is accessing the managed server for the 
remote session, security settings, and the protocol in use for the remote 
session.

For details, see “Obtaining Information About Remote Management Sessions” 
on page 769.

You can right-click or double-click the Remote Management Agent icon to view 
the Information window.

Shutdown Agent This option is always dimmed on managed servers. To shutdown the Remote 
Management Agent on managed servers, the user must go to the Service 
Control Panel and stop the “Novell ZFS Remote Management Agent” service.

Request Session Enables the user at the managed server to request a remote operator to 
perform remote session.

Help Displays the Remote Management Agent help.
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Obtaining Information About Remote Management Sessions

Using the Information window, the user at the managed server can view details about the session, 
such as the name of the remote operator how is remotely managing the server, the security settings, 
and the protocol in use for the remote session.

To view information about remote sessions:

1 On the managed server, right-click the Remote Management Agent icon.

2 Click Information.

3 Click the General tab to view the general information and the Security tab to view the security 
information.

See the following sections for details:

“Obtaining General Information” on page 769

“Obtaining Security Information” on page 769

Obtaining General Information

The following table explains the general information you can obtain about Remote Management 
sessions from the Information window:

Obtaining Security Information

The Security Information dialog box displays information based on the Remote Control and 
Remote View sessions.

Parameter Description

RM Operation Lists the ongoing Remote Management sessions.

RM Information > 
Initiator

Displays the name of the remote operator.

RM Information > 
Protocol

Displays the protocol that the Remote Management Agent uses to 
communicate with the management console during a remote session.

Optimization Status 
> RC/RV 
Optimization

Displays if the optimization driver is enabled or disabled for the Remote 
Management session. The remote session performance is enhanced if the 
optimization driver is enabled.

Options Description

Permission 
Required

Indicates if the remote operator should obtain permission from the user at the 
managed server each time the he wants to perform the remote management 
session on the managed server.

Audible Signal 
Required

Indicates if an audible signal should be sent to the managed server every time 
the remote operator accesses the managed server.

Beep Every Indicates the time interval based on which the audible signal is periodically sent 
to the managed server.

Visual Signal 
Required 

Indicates if a visible signal should be sent to the managed server every time the 
remote operator accesses the managed server.
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Remote Operator Identification Display
The Remote Management Agent will display the identification of the remote operator in the 
following dialog boxes on the managed server:

Permission dialog box

Visible signal dialog box

The information displayed is console_machine_name\console_windows_username.

Viewing the Audit Log for Remote Management Sessions
ZENworks Server Management records log information on a Windows managed server. 

To view the audit log for Remote Management sessions:

1 Click Start > Programs > Administrative Tools > Event Viewer.

2 Click Log > Application.

3 Double-click the event associated with the source Remote Management Agent.

To view only the events pertinent to the Remote Management Agent, choose Remote Management 
Agent from the source drop-down list in the Filter dialog box.

Improving the Remote Management Performance
The Remote Management performance, especially over a slow link, has been enhanced through 
using improved compression.

The performance during a Remote Management session over a slow link or a fast link varies 
depending on the network traffic. For better response time, try one or more of the following 
strategies:

On the Management Console

Select the Hide Wallpaper option on the managed server in the Control Parameters dialog box.

Assign color settings on the management console higher than the managed server or assign 
the same color settings for the management console and the managed server.

Select 16 Colors or 256 Colors mode in the Control Parameters dialog box to enhance the 
Remote Management performance.

Session Encryption 
Enabled

Indicates whether a remote session will be encrypted or not. Session 
Encryption Enabled is applicable for Remote Control and Remote View.

Display Name Every Indicates the time interval based on which the visual signal is periodically sent 
to the managed server.

Screen Blanking 
Allowed

Indicates if the remote operator is allowed to blank the managed server screen. 
Screen Blanking Allowed is applicable for Remote Control only.

Locking Control 
Allowed

Indicates if the remote operator is allowed to lock the keyboard and mouse 
controls of the managed server. Locking Control Allowed is applicable for 
Remote Control only.

Options Description
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The speed of the management console depends upon the processing power of the client 
machine. We recommended that you to use single-processor client with a Pentium* III, 
500MHz (or later).

On the Managed Server

Deselect the Enable Pointer Shadow option before starting the Remote Control or Remote 
View session.

To disable Enable Pointer Shadow:

1. From the Windows desktop, click Start > Settings > Control Panel > double-click Mouse.
2. Click Pointers.
3. Deselect Enable Pointer Shadow.
4. Click Apply >OK.

At the managed server, use a plain background. Do not set a wallpaper pattern.

If the Task manager is opened at the target machine, it is recommended to minimize or close it.

Make sure that the scrolling texts (such as the debug windows) and animations are not active 
on the managed server.

Make sure to minimize or close the dialog boxes that are not in use.

To perform any operations at the managed server, if possible, use the toolbar options instead 
of menu options.

To maximize the Remote Management performance over WAN, configure the following 
settings in the Control Parameters dialog box at the managed server:

Set the color mode of the managed server to 16 color.

Select the Slow Link Option.

Shutting Down and Restarting the Remote Management Agent
The following sections explain how you can use the Remote Management Agent during remote 
sessions:

“Shutting Down the Remote Management Agent” on page 771

“Restarting the Remote Management Agent” on page 772

Shutting Down the Remote Management Agent

You can shut down the Remote Management Agent during a remote session. When you shut down 
the Remote Management Agent, the remote session stops. To start another remote session, you 
need to restart the Remote Management Agent. For more information, see “Restarting the Remote 
Management Agent” on page 772. 

To shut down the Remote Management Agent on a Windows 2000/2003 managed server:

1 From the Control Panel, double-click Administrative Tools.

2 Double-click Services.

3 Click Novell ZFS Remote Management Agent > Stop.
IMPORTANT: You can stop the Remote Management Agent on Windows 2000/2003 server only if you have 
the rights to stop the Windows service.
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Restarting the Remote Management Agent

During ZENworks Server Management installation, the Remote Management Agent is installed 
on the managed server and started automatically when the managed server starts up. If you shut 
down the Remote Management Agent during a remote session, the remote session stops. To start 
another remote session, you need to restart the Remote Management Agent on the managed server.

To restart the Remote Management Agent on Windows 2000/2003 managed server:

1 From the Control Panel, double-click Administrative Tools.

2 Double-click Services.

3 Click Novell ZFS Remote Management Agent > Start.
IMPORTANT: You can start the Remote Management Agent on Windows 2000/2003 server only if you have 
the rights to start the Windows service.
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M Documentation Updates

This section contains information on documentation content changes that have been made in the 
Administration Guide for Remote Management since the initial release of Novell® ZENworks® 
6.5 Server Management. This information will help you to keep current on updates to the 
documentation.

All changes that are noted in this section were also made in the documentation. The documentation 
is provided on the Web in two formats: HTML and PDF. The HTML and PDF documentation are 
both kept up-to-date with the documentation changes listed in this section.

The documentation update information is grouped according to the date the documentation 
updates were published. Within a dated section, the changes are alphabetically listed by the names 
of the main table of contents sections for Remote Management.

If you need to know whether a copy of the PDF documentation you are using is the most recent, 
the PDF document contains the date it was published on the front title page or in the Legal Notices 
section immediately following the title page.

The documentation was updated on the following dates:

“March 11, 2005” on page 773

“February 11, 2005” on page 774

“September 2, 2004” on page 774

March 11, 2005
Updates were made to the following section: 

“Remote Management for NetWare Servers” on page 773

Remote Management for NetWare Servers
The following updates were made in this section:

Location Change

“Remote Management for 
NetWare Servers” on 
page 741

Reorganized this chapter.

“Initiating Remote 
Sessions Using 
RConsoleJ” on page 745

Renamed the “RConsoleJ” section to Initiating Remote Sessions Using 
RConsoleJ, and updated the section.
Documentation Updates 773



    Novell Confidential                                                                                            Manual (ENU)  21 December 2004
February 11, 2005
Updates were made to the following section: 

“Remote Management for Windows Servers” on page 774

Remote Management for Windows Servers
The following updates were made in this section:

September 2, 2004
Throughout the guide, graphics have been updated with font changes and newer icons. No notable 
content changes were made to any graphics.

“Changing the Password 
of the RConsoleJ Agent” 
on page 749

Renamed the “Setting Up Security for RConsoleJ” section to Changing the 
Password of the RConsoleJ Agent, and updated the section.

Location Change

“Operating with Windows 
XP SP2” on page 759

This new section has been added.

“Initiating Remote 
Management Session 
from the Remote 
Management Agent” on 
page 758

Added the following note in Step 1:

NOTE: The first instance of ConsoleOne receives the request when a 
session request is initiated from a Remote Management Agent to the 
management console running on a terminal server. None of the 
ConsoleOne instances receive the session request until all ConsoleOne 
instances are closed on the session where ConsoleOne was launched for 
the first time. To receive the session request, ConsoleOne must be 
launched again on any terminal session.

Location Change
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