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73 Setting Up GroupWise Modes and Accounts

This section will familiarize you with GroupWise® modes and accounts, and help you set up users 
to use them.

“GroupWise Modes” on page 965

“Accounts” on page 972

GroupWise Modes
GroupWise provides three different ways to run the GroupWise client: Online mode, Caching 
mode, and Remote mode. 

“Online Mode” on page 965

“Caching Mode” on page 965

“Remote Mode” on page 967
NOTE: Remote mode is not available in the GroupWise Cross-Platform client.

Most GroupWise features are available in all three GroupWise modes, with a few exceptions. 
Subscribing to other users’ notifications is not available in Caching mode. Subscribing to other 
users’ notifications and Proxy are not available in Remote mode.

Online Mode
When users use Online mode, they are connected to their post office on the network. The user’s 
mailbox displays the messages and information stored in the network mailbox (also called the 
Online Mailbox). Online mode is connected to the network mailbox continuously. In Online mode, 
if the Post Office Agent shuts down or users lose their network connection, they will (temporarily) 
lose the connection to their mailboxes.

Users should use this mode if they do not have a lot of network traffic, or if they use several 
different workstations and do not want to download a local mailbox to each one. 

Caching Mode
Caching mode stores a copy of a user’s network mailbox, including messages and other 
information, on the user’s local drive. This allows GroupWise to be used whether or not the 
network or Post Office Agent is available. Because the user is not connected to the network all the 
time, this mode cuts down on network traffic and has the best performance. A connection is made 
automatically to retrieve and send new messages. All updates are performed in the background so 
GroupWise work is not interrupted.

Users should use this mode if they have enough disk space on the local drive to store their 
mailboxes. 
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Several users can set up their Caching Mailboxes on a single shared computer.

If users run Caching Mode and Remote Mode on the same computer, the same local mailbox (also 
called the Caching Mailbox or Remote Mailbox) can be used to minimize disk space usage. 

If disk space is limited, users can restrict the items that are downloaded to the local mailbox. They 
can specify to get the subject line only or specify a size limit.

If users back up their Caching Mailbox, they can protect items that might be deleted if the system 
is set up to automatically clean up items (or if the system administrator runs an Expire and 
Reduce).

To use Caching mode, the client installation must be a standard installation, not a workstation 
installation.

Allowing or Forcing Use of Caching Mode

The system administrator can allow or disallow the use of Caching mode, and can also force users 
to log in to GroupWise in Caching mode. 

If the system administrator forces Caching mode on Cross-Platform client users and then restricts 
Online mailbox size so that users have items in their Caching mailboxes that are no longer 
available online, the administrator needs to make sure users understand about doing backups. See 
“Backing Up Your Mailbox” in “Managing Your Mailbox” in the GroupWise 6.5 Cross-Platform 
Client User Guide.

1 In ConsoleOne®, click Tools > GroupWise Utilities > Client Options.

2 Click Environment > Client Access.

3 Select or deselect Allow Use of Caching Mode.

4 Select or deselect Force Use of Caching Mode.

Specify the number of days before Caching mode will be enforced. This allows the user to 
continue using Online mode until the grace period has passed. The grace period begins the 
first time the user connects to the POA. The setting applies per user per workstation.

The Force Caching Mode setting is not enforced on a workstation that does not have enough 
disk space for a Caching mailbox. The following amount of disk space is required: the size of 
the mailbox + 20 MB + 25% of the mailbox size.

The Force Caching Mode setting is also not enforced when a user connects from a shared 
Windows workstation or terminal server if you configure these workstations to be excluded. 
You do this by setting a registry key on the Windows workstation. The registry key is in 
HKEY_LOCAL_MACHINE. Under Software\\Novell\\GroupWise\\Client, add a dword 
value named No Local Store with a value of 1. This will prevent the user from creating a 
Caching or Remote mailbox by using the GroupWise Windows client menus. However, the 
user can still create a Caching or Remote mailbox by using the startup switches /pc, /pr, or /ps.

Downloading the System Address Book

When users prime their Caching mailboxes, they receive a copy of the system address book. After 
the initial priming of the Caching mailbox, users can re-download the system address book and 
their personal address books in Caching mode by clicking View > Retrieve System Address Book 
or View > Retrieve Personal Address Book while in the Address Book. Address books will also 
be re-downloaded in Caching mode when users click Tools > Retrieve Entire Mailbox.
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Users can also specify to download the system address book (and any rules they have created) on 
a regular basis. In Remote or Caching mode, click Accounts > Account Options. Right-click the 
GroupWise account, then click Properties > Advanced. Select Refresh Address Books and Rules 
Every __ Days. By default this is set to 7 days, but can be changed.

If you configure the POA to generate the system address book regularly, Caching mode users will 
always have a current copy to download. In ConsoleOne, right-click the POA object, then click 
Properties > GroupWise > Maintenance. On the Maintenance page, make sure that Generate 
Address Book for Remote is selected. You can choose the time when you want the generation to 
take place.

If you want to generate the system address book for download more often than once a day, you can 
delete the existing wprof50.db file from the \wpcsout\ofs subdirectory of each post office. A new 
downloadable system address book will be generated automatically for users on each post office.

Remote Mode
Remote mode is familiar to GroupWise users on the road. Similar to Caching mode, a copy of the 
Online mailbox, or the portion of the mailbox that users specify, is stored on the local drive. Users 
can periodically retrieve and send messages with the type of connection they specify (modem, 
network, or TCP/IP). Users can restrict what is retrieved, such as only new messages or only 
message subject lines. 
NOTE: Remote mode is not available in the GroupWise Cross-Platform client.

To use Remote mode, the Windows client installation must be a standard (full) installation, not a 
workstation installation.

As an administrator, you can allow or disallow the use of Remote mode for client users.

1 In ConsoleOne, click Tools > GroupWise Utilities > Client Options.

2 Click Environment > Client Access.

3 Select or deselect Allow Use of Remote Mode.

The following topics explain the capabilities users have when they are allowed to use Remote 
mote.

“Remote Password” on page 967

“Async Gateway and X.25 Gateway” on page 968

“Remote Performance” on page 968

“Hit the Road” on page 968

“Remote Properties” on page 968

“Remote Mode Connections” on page 969

Remote Password

To use Remote mode, users must have a password set in Online mode. When they run in Remote 
mode for the first time, they can specify to use the same password in Remote mode or choose a 
new one.
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Async Gateway and X.25 Gateway

For GroupWise to use a modem connection, the GroupWise Async Gateway or X.25 Gateway 
must be installed and configured in your GroupWise system. The gateway provides the means by 
which the client communicates with the GroupWise system.

Remote Performance

The system administrator can configure the MTA so that it re-directs Remote mode requests to 
other MTAs and POAs. The GroupWise client can establish a client/server connection to an MTA 
across the Internet. For more information, see “Enabling Live Remote” on page 589.

Hit the Road

Users can use Hit the Road on the Tools menu (or switch from Online mode to Remote mode) to 
create, set up, or update the Remote mailbox. A copy of the mailbox is created on the user’s local 
drive and any current connections are detected and set up. If users have already used Caching 
mode, the local mailbox has already been created. Users can also use Hit the Road to create setup 
files on a diskette to set up their Remote mailbox on a computer that’s not connected to the 
network. Several users can set up their Remote mailboxes on a single shared computer.

Hit the Road creates a network connection for the method (direct connection or TCP/IP) 
GroupWise uses to access the user’s post office. GroupWise can then use this connection, when 
running in Remote mode, to connect to the GroupWise system. For example, a network connection 
lets users of docked laptops run GroupWise in Remote mode and connect to the GroupWise system 
through the network connection rather than a modem connection.

Hit the Road also creates modem connections for Remote Profiles in the Async Gateway or X.25 
Gateway. Remote Profiles let GroupWise connect to the GroupWise system.

To use Hit the Road:

1 In the GroupWise client, click Tools > Hit the Road.

2 Follow the prompts to create the Remote mailbox on the computer or on a diskette.

Installing the Remote Mailbox from Diskette

If Hit the Road created the user’s Remote mailbox on diskette, the user needs to install the Remote 
mailbox on the computer that will be running in Remote mode. 

1 Insert the diskette containing the Remote mailbox into the computer’s disk drive. 

2 From the Windows Taskbar, click Start > Run.

3 Type a:\setup, then click OK.

Follow the prompts. The setup program creates a Remote mailbox and copies the required 
files to the computer’s hard drive.

Remote Properties

Users can change the way Remote mode is set up, including the connection, time zone, signature, 
and so forth, in Account Options on the Accounts menu. Remote is listed as an account.

By default, if an item is deleted from the Remote mailbox, the item will be deleted from the Online 
mailbox the next time a connection is made. Deletion options in Remote Properties can be changed 
so that an item deleted from the Remote mailbox will stay in the Online mailbox or vice versa.
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Remote Mode Connections

“Setting Up a Modem Connection” on page 969

“Setting Up a Network Connection” on page 970

“Setting Up a TCP/IP Connection” on page 971

Setting Up a Modem Connection

If you are going to connect with a modem, you must create at least one modem connection. A 
modem connection provides GroupWise with the information it needs to connect to the 
GroupWise system through the GroupWise Async Gateway or GroupWise X.25 Gateway.

To set up a modem connection:

1 In the client, log in or change to Remote mode.

2 Click Accounts > Send/Retrieve > GroupWise Options. 

3 Click Configure > Connect To > New.

4 Make sure Modem is selected, then click OK.

5 Type a descriptive name for the modem connection in the Connection Name box.

6 Click the country code, then type the area code and phone number for the gateway to the 
master GroupWise system.

You can use a comma (,) to signal a one-second pause in dialing such as 9, (800) 555-5555. 
The 9 accesses an outside line and the comma causes a one-second pause to wait for the dial 
tone before dialing the number. If you enter dashes, spaces, and parentheses, they are ignored. 

7 Type the login ID for the gateway.

8 Click Password, type the gateway password, then click OK.

9 Retype the password, then click OK. 

10 Click the Advanced tab.

11 If your modem requires a script, specify the path to the script in the Modem Script box, click 
Edit Script, then specify the necessary When Given and Respond With commands.

To save the script without changing its filename, click Save > Close.

or

To save the script with a new filename, click Save As, type a name, then click Close.

12 Click a disconnect method.

Method Description

When All Updates Are Received Disconnects after requests are sent and after all responses 
to the requests are received (or disconnects automatically 
when the time allowed by the gateway has expired).

Do Not Wait for Responses Disconnects immediately after requests are sent and 
pending responses are received. Pending responses are 
responses to other requests that are waiting to be 
downloaded to you.

Manually Lets you manually control when to disconnect (or 
disconnects automatically when the time allowed by the 
gateway has expired).
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13 Click Attempts, then specify the number of times to redial if the line is busy.

14 Click Retry Interval, then specify the time interval between each redial attempt.

15 Click OK.

16 Select the connection you want, then click Select.

17 Select the location you are connecting from in the Connecting From box. If none are listed, 
use the Default Location option.

If you need to create a new location, click the Connect From button. This is useful for laptop 
users who are calling into the GroupWise system from different geographic locations. 

18 Select the modem to use for dialing up the gateway in the Connect Using box. If you have not 
yet defined your modem, click Modem to add a modem to your system.

19 Click OK, then click Close.

Setting Up a Network Connection

While running in Remote mode, GroupWise can connect to the user’s Online mailbox using a 
network connection. A network connection is useful for laptop users connecting to the network 
through a docking station, or for remote users connecting through a modem using remote node 
software.

To create a network connection:

1 In the client, log in or change to Remote mode.

2 Click Accounts > Send/Retrieve > GroupWise Options.

3 Click Network > OK.

4 Type a descriptive name for the network connection in the Connection Name box.

5 Type the path to any post office directory in the master GroupWise system.

Users can connect to their own post offices or to any post office in the master GroupWise 
system to access their Online mailboxes.

6 Click a disconnect method.

7 Click OK.

8 Select the connection you want, then click Select.

Method Description

When All Updates Are Received Disconnects after requests are sent and after all 
responses to the requests are received (or disconnects 
automatically when the time allowed by the gateway 
has expired).

Do Not Wait for Responses Disconnects immediately after requests are sent and 
pending responses are received. Pending responses 
are responses to other requests that are waiting to be 
downloaded to you.

Manually Lets you manually control when to disconnect (or 
disconnects automatically when the time allowed by 
the gateway has expired).
970   GroupWise 6.5 Administration Guide



    Novell Confidential                                                                                            Manual (99a)  21 December 2004
9 Select the location you are connecting from in the Connecting From box. If none are listed, 
use the Default Location option.

If you need to create a new location, click the Connect From button. This is useful for laptop 
users who are calling into the GroupWise system from different geographic locations. 

10 Click OK > Close.

Setting Up a TCP/IP Connection

A TCP/IP connection enables GroupWise, while running in Remote mode, to connect to the 
GroupWise system through a network connection using TCP/IP rather than a modem connection. 
A TCP/IP connection can be made through a network connection, such as a laptop connecting to 
the network through its docking station, or through a modem using remote node software.

To create a TCP/IP connection:

1 In the client, log in or change to Remote mode.

2 Click Accounts > Account Options, then double-click the Remote account.

3 Click Connection > Connect To > New > TCP/IP > OK.

4 Type a descriptive name for the TCP/IP connection.

5 Type the IP address or the DNS name.

6 Type the IP port for this address.

7 Click a disconnect method.

8 Click OK.

9 Select the connection you want, then click Select.

10 Select the location you are connecting from in the Connecting From box. If none are listed, 
use the Default Location option.

If you need to create a new location, click the Connect From button. This is useful for laptop 
users who are calling into the GroupWise system from different geographic locations. 

11 Click OK > Close.

Method Description

When All Updates Are Received Disconnects after requests are sent and after all responses 
to the requests are received (or disconnects automatically 
when the time allowed by the gateway has expired).

Do Not Wait for Responses Disconnects immediately after requests are sent and 
pending responses are received. Pending responses are 
responses to other requests that are waiting to be 
downloaded to you.

Manually Lets you manually control when to disconnect (or 
disconnects automatically when the time allowed by the 
gateway has expired).
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Accounts
“Accounts Menu” on page 972

“Enabling POP3, IMAP4, and NNTP Account Access in Online Mode” on page 972

Accounts Menu
In addition to the Remote account, users can access and configure POP3 and IMAP4 Internet e-
mail accounts and NNTP News accounts from the Accounts menu. While the user is in Remote 
and Caching mode, POP3, IMAP4, and NNTP accounts are accessed without needing to connect 
to the GroupWise system. If the system administrator enables it, users can also access and 
configure their POP3, IMAP4, and NNTP accounts from the Accounts menu while in Online 
mode.
NOTE:  The Accounts menu is not available in the GroupWise Cross-Platform client.

Enabling POP3, IMAP4, and NNTP Account Access in Online Mode
By default, POP3, IMAP4, and NNTP accounts can be added, configured, and accessed by users 
in Remote and Caching mode only. Account items and information are not accessible in Online 
mode, nor can items and information be uploaded to the Online mailbox until the system 
administrator enables it.

To enable POP3, IMAP4, and NNTP account access in client users’ Online mode for an entire post 
office:

1 Make sure GroupWise 6.x agents have been installed. For more information, see “Message 
Transfer Agent” on page 555.

2 Make sure Internet Addressing is enabled. For more information, see “Internet Addressing” 
on page 61.

3 In ConsoleOne, select the post office object.

4 Click Tools > GroupWise Utilities > Client Options.

5 Click Environment > General.

6 Select Allow Use of POP and IMAP Accounts in the Online Mailbox.

7 Select Allow Use of News (NNTP) Accounts in the Online Mailbox.

8 Click OK.
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74 Setting Defaults for the GroupWise Client 
Options

The GroupWise® client includes options (preferences) that can be set by individual users. As a 
GroupWise administrator, you can determine the default settings for the options. If you don’t want 
users to change the default settings you’ve established, you can lock the settings. 

“Client Options Summary” on page 973

“Setting Client Options” on page 976

“Resetting Client Options to Default Settings” on page 1002

Client Options Summary
Default settings can be established at the user level, the post office level, or the domain level. User 
settings override post office settings, and post office settings override domain settings.

1 In ConsoleOne®, select a Domain, Post Office, or User object, then click Tools > GroupWise 
Utilities > Client Options.

The client options table in this section summarizes all client options and provides links to 
descriptions of the options. For more detailed instructions, see “Setting Client Options” on 
page 976.

Environment

Send

Security

Date and Time
NOTE: The Cross-Platform client does not recognize all of the client options that can be set in ConsoleOne. 
Client options that the Cross-Platform client does recognize are marked with an asterisk (*) in the table.
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Client Options Type Client Options Tab Client Options

Environment
Click Tools >
GroupWise Utilities >
Client Options >
Environment

General Refresh Interval
Allow Shared Folder Creation
Allow Shared Address Book Creation
Check Spelling Before Send
Junk Mail Handling

Enable Junk Mail Handling
Enable Junk Mail Using Junk Mail Lists
Enable Junk Mail Using Personal Address Books
Auto-Delete After __ Days
Enable Blocked Mail Using Block Mail Lists

Allow Use of POP and IMAP Accounts in the Online 
Mailbox
Allow Use of News (NNTP) Accounts in the Online Mailbox

Client Access Client Licensing
Full License Mailboxes
Limited License Mailboxes

Client Login Mode
Allow Use of Remote Mode
Allow Use of Caching Mode

Force Caching Mode after __ Days
Show Login Mode Drop-Down List on Client Toolbar

Views View Options
Read Next After Accept, Decline, or Delete
Open New View after Send

Disable HTML View

File Location Archive Directory
Custom Views

Cleanup Mail and Phone
Manual Delete and Archive
Auto-Delete After
Auto-Archive After

Appointment, Task, and Note
Manual Delete and Archive
Auto-Delete After
Auto-Archive After

Empty Trash
Manual
Automatic After
Allow Purge of Items Not Backed Up

Prompt before Purging

Threshold Operations

Retention Retention
974   GroupWise 6.5 Administration Guide



    Novell Confidential                                                                                            Manual (99a)  21 December 2004
Send
Click Tools >
GroupWise Utilities >
Client Options > 
Send

Send Options Classification*
Normal, Proprietary, Confidential, Secret, Top Secret,

 For Your Eyes Only
Priority*

High, Standard, Low
Reply Requested*

When Convenient, Within __ Days
Allow Use of Reply to All in Rules
Allow Use of Internet Mail Tracking
Expiration Date
Delay Delivery
Wildcard Addressing
Notify Recipients
Convert Attachments
Allow Reply Rules to Loop

Mail Create a Sent Item to Track Information
Delivered, Delivered and Opened, All Information,
Auto-Delete Sent Item

Return Notification*
When Opened/Deleted

None, Mail Receipt, Notify, Notify and Mail

Appointment Create a Sent Item to Track Information
Delivered, Delivered and Opened, All Information,
Auto-Delete Sent Item

Return Notification*
When Opened/Accepted/Deleted

None, Mail Receipt, Notify, Notify and Mail

Task Create a Sent Item to Track Information
Delivered, Delivered and Opened, All Information,
Auto-Delete Sent Item

Return Notification*
When Opened/Accepted/Completed/Deleted

None, Mail Receipt, Notify, Notify and Mail

Note Create a Sent Item to Track Information
Delivered, Delivered and Opened, All Information,
Auto-Delete Sent Item

Return Notification*
When Opened/Deleted

None, Mail Receipt, Notify, Notify and Mail

Security Conceal Subject
Require Password to Complete Routed Item
Secure Items Options

Do Not Allow Use of S/MIME*
URL for Certificate Download
Sign Digitally*
Encrypt for Recipients

Encryption Key Size

Disk Space 
Management

User Limits
Mailbox Size Limit
Threshold for Warning Users
Maximum Send Message Size

Client Options Type Client Options Tab Client Options
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Setting Client Options
Default settings can be established at the user level, the post office level, or the domain level. User 
settings override post office settings, and post office settings override domain settings. However, 
if you set a lock on an option at a higher level, the higher level then overrides the setting for the 
lower level.

To modify the default settings for the GroupWise client: 

1 In ConsoleOne, click a Domain object if you want to modify the settings for all users in the 
domain.

or

Click a Post Office object if you want to modify the settings for all users in the post office.

or

Click a User object or GroupWise External Entity object if you want to modify settings for 
the individual user. To change the same settings for multiple users, select multiple objects.

2 With the appropriate GroupWise object selected, click the Tools menu > click GroupWise 
Utilities > click Client Options to display the GroupWise Client Options dialog box.

Security
Click Tools >
GroupWise Utilities >
Client Options >
Security

Password Enter New Password*
Clear User Password*
Allow Password Caching
Allow eDirectory Authentication Instead of Password
Enable eDirectory Single Sign-On

Macros View Macro Security
Always Play Received Macros
Never Play Received Macros
Always Prompt Before Playing a Macro

Notify Check for Mail Every

Date and Time
Click Tools >
GroupWise Utilities >
Client Options > 
Date and Time

Calendar Month Display Option
First of Week
Highlight Day
Show Week Number

Appointment Options
Include Myself on New Appointments
Display Appointment Length As

Duration, End Date and Time
Default Length

Alarm Options
Set Alarm When Accepted
Default Alarm Time

Work Schedule
Start/End Time
Work Days

Busy Search Appointment Length
Range and Time to Search
Days to Search

Client Options Type Client Options Tab Client Options
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3 To set the Environment options, click Environment > continue with “Modifying Environment 
Options” on page 977.

or

To set the Send options, click Send > skip to “Modifying Send Options” on page 987.

or

To set the Security options, click Security > skip to “Modifying Security Options” on 
page 996.

or

To set the Date and Time options, click Date and Time > skip to “Modifying Date and Time 
Options” on page 999. 

Modifying Environment Options
1 If the Environment Options dialog box is not displayed, follow the instructions in “Setting 

Defaults for the GroupWise Client Options” on page 973 to display the dialog box.

2 Click the tab that contains the options you want to change. Refer to the following sections for 
information about options:

“Environment Options: General” on page 978
“Environment Options: Client Access” on page 980
“Environment Options: Views” on page 982
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“Environment Options: File Locations” on page 982
“Environment Options: Cleanup” on page 983
“Environment Options: Threshold” on page 985
NOTE: The Environment options are not currently recognized by the Cross-Platform client.

3 If you want to prevent users from changing an option’s setting, click the lock button next to it.

After you click it, the lock button indicates whether the setting is locked at the domain level, 
the post office level, or the user level.

4 If you want to return all the options on a tab to their default settings, click Restore Default 
Settings.

5 When finished, click OK to save your changes.

Environment Options: General

The General options determine such settings as the refresh interval for new messages, whether 
users can create shared folders and address books, and which types of accounts can be used while 
in Online mode.

Refresh Interval

This option determine how often the GroupWise client lists will be updated to reflect new message 
status. The default is 1 minute.

Allow Shared Folder Creation

Select this option to enable users to share folders with other users. By default, this option is 
enabled.
978   GroupWise 6.5 Administration Guide



    Novell Confidential                                                                                            Manual (99a)  21 December 2004
Allow Shared Address Book Creation

Select this option to enable users to share address books with other users. By default, this option 
is enabled.

Check Spelling Before Send

Select this option to have the message text of each item automatically spell checked before the item 
is sent. By default, this option is disabled.

Junk Mail Handling

Choose from the following settings to determine what Junk Mail Handling options are available 
to client users.

Enable Junk Mail Handling: Select this option to make the Junk Mail Handling feature 
available for a user. This setting affects both the client and the POA. Junk Mail Handling 
allows users to block or "junk" unwanted Internet e-mail. When this setting is enabled, the 
client will display Junk Mail Handling menus and dialog boxes, and the POA will perform 
Junk Mail Handling if the block and junk lists are also enabled.

When this setting is disabled, the client will not display any Junk Mail Handling menus or 
dialog boxes, and the POA will not perform any Junk Mail Handling for the user.

Enable Junk Mail Using Junk Mail Lists: Select this option to make junking available to 
users. A user can junk e-mail from an Internet e-mail address or Internet domain, when the e-
mail addresses and Internet domains are listed in the user’s Junk List. (Initially, there are no 
entries in a user’s junk list.) Junked items are delivered to the Junk Mail folder in the user’s 
Mailbox.

When this setting is enabled or disabled and not locked, the user’s initial setting to use the 
Junk List will be enabled or disabled. Users can change the setting. When enabled and locked, 
a user’s Enable Junk List setting is enabled and cannot be disabled. When disabled and locked, 
the Junk List will be unavailable to the user. Client menu options and dialogs involving the 
Junk List will not be displayed. 

Enable Junk Mail Using Personal Address Book: Select this option to allow users’ personal 
address books to function like Junk Lists. All items from e-mail addresses not in users’ 
Frequent Contacts address book and other personal address books will be delivered to the 
Junk Mail folder in the user’s Mailbox.

When this setting is enabled or disabled and not locked, the user’s initial setting to use 
personal address books will be enabled or disabled. Users can change the setting. When 
enabled and locked, a user’s Enable Junk Mail Using Personal Address Books setting is 
enabled and cannot be disabled. When disabled and locked, the personal address books option 
will be unavailable to the user. Client menu options and dialog boxes involving personal 
address books will not be displayed. 

Auto-Delete After __ Days: Select this option to automatically delete items from the Junk 
Mail folder. Specify the number of days after which items should be deleted.

Enable Blocked Mail Using Block Mail Lists: Select this option to make blocking available 
to users. A user can block e-mail from an Internet e-mail address or Internet domain, when 
blocked e-mail addresses and Internet domains are listed in the user’s Block List. (Initially, 
there are no entries in a user’s Block List.) Blocked items are blocked when the POA 
processes delivery to the user’s mailbox, and the items are never delivered to the user’s 
mailbox. When the POA log uses Verbose mode, the log will display information about 
blocked items.
Setting Defaults for the GroupWise Client Options 979



    Novell Confidential                                                                                            Manual (99a)  21 December 2004
When this setting is enabled or disabled and not locked, the user’s initial setting to use the 
Block List will be enabled or disabled. Users can change the setting. When enabled and 
locked, a user’s Block List setting is enabled and cannot be disabled. When disabled and 
locked, blocking will be unavailable to the user. Client menu options and dialog boxes 
involving the Block List will not be displayed.

Allow Use of POP and IMAP Accounts in the Online Mailbox

Select this option to enable users to access POP and IMAP accounts while using the GroupWise 
client in Online mode.

By default, this option is disabled. If you enable this option, an Accounts menu is added to the 
GroupWise client, allowing users to add POP and IMAP accounts to GroupWise, set account 
properties, and send and retrieve items from their POP and IMAP accounts. In addition, users are 
allowed to upload POP and IMAP items from the Remote mailbox to the Online mailbox.

Allow Use of News (NNTP) Accounts in the Online Mailbox:

Select this option to enable users to set up newsgroup (NNTP) accounts while using the 
GroupWise client in Online mode.

Environment Options: Client Access

The Client Access options allow you to apply a license type (full or limited) to users’ mailboxes 
and enable/disable the Remote and Caching modes in the GroupWise client for Windows.    

Client Licensing

GroupWise offers two types of mailbox licenses: full client mailbox licenses and limited client 
mailbox licenses. 

A full client mailbox license has no mailbox access restrictions; the mailbox can be accessed by 
any GroupWise client (Windows or WebAccess) as well as any third-party plug-in or POP/IMAP 
client.
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A limited client mailbox license restricts mailbox access to the following:

The GroupWise WebAccess client (including wireless devices)

A GroupWise client (Windows or WebAccess) via the Proxy feature

A GroupWise client (Windows or WebAccess) via the Busy Search feature

A POP or IMAP client

Note that a limited client license mailbox does not allow access through the GroupWise client for 
Windows (other than via Proxy or Busy Search).

You can use this option to specify the type of client license that you want applied to users’ 
mailboxes. This enables you to support the type of GroupWise mailbox licenses you’ve purchased. 
For example, if you’ve only purchased limited client license mailboxes for users on a specific post 
office, you can mark all mailboxes on that post office as being limited client license mailboxes.

For information about generating an audit report that shows the type of license applied to each 
mailbox in a post office, see “Auditing Mailbox License Usage in the Post Office” on page 180.

Client Login Mode

Choose from the following settings to determine which login modes are available to GroupWise 
users when using the GroupWise client for Windows. These settings apply only if you selected 
Full License Mailboxes for the client licensing.

Allow Use of Remote Mode: Select this option to enable users to log in with GroupWise in 
Remote mode. With Remote mode, the GroupWise client uses a Remote mailbox on the user’s 
local drive. The user must initiate a connection (modem, direct, or TCP/IP) to send or retrieve 
items from the GroupWise system. For more information about Remote mode, see “Remote 
Mode” on page 967. By default, this option is enabled. 
NOTE: Remote Mode is not available in the Cross-Platform client.

Allow Use of Caching Mode: Select this option to enable users to log in with GroupWise in 
Caching mode. With Caching mode, the GroupWise client uses a Caching mailbox on the 
user’s local drive (this can be the same mailbox as the Remote mailbox). The GroupWise 
client periodically initiates a connection with the GroupWise system to send and receive 
items. For more information about Caching mode, see “Caching Mode” on page 965. By 
default, this option is enabled.

Select the Force Caching Mode option (available only if the Allow Use of Caching Mode 
option is enabled) to force users to run in Caching mode. By default, this option is disabled. 
Specify the number of days before Caching mode will be enforced. This allows the user to 
continue using Online mode until the grace period has passed. The grace period begins the 
first time the user connects to the POA. The setting applies per user per workstation.

The Force Caching Mode setting is not enforced on a workstation that does not have enough 
disk space for a Caching mailbox. The following amount of disk space is required: the size of 
the mailbox + 20 MB + 25% of the mailbox size.

The Force Caching Mode setting is also not enforced when a user connects from a shared 
Windows workstation or terminal server if you configure these workstations to be excluded. 
You do this by setting a registry key on the Windows workstation. The registry key is in 
HKEY_LOCAL_MACHINE. Under Software\\Novell\\GroupWise\\Client, add a dword 
value named No Local Store with a value of 1. This will prevent the user from creating a 
Caching or Remote mailbox by using the GroupWise Windows client menus. However, the 
user can still create a Caching or Remote mailbox by using the startup switches /pc, /pr, or /ps.
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By Default, Show Login Mode Drop-Down List on Client Toolbar: Select this option to 
have the Login Mode drop-down list displayed on the client’s toolbar. This enables users to 
change the mode themselves and is only necessary if you allow multiple modes to be used. By 
default, this option is enabled.

Environment Options: Views

The Views Environment options determine when items open, and whether or not users can read 
and compose messages in HTML.

View Options

Choose from the following settings to determine what occurs when the user performs an action 
that closes the current view.

Read Next after Accept, Decline, or Delete: Select this option to have the next available 
received item automatically open after the user accepts, declines, or deletes an appointment, 
task, or note. By default, this option is enabled.

Open New View after Send: Select this option to have a new send view open after a user 
sends a message. By default, this option is disabled.

Disable HTML View

Turns off the ability to view or compose messages in HTML View.

Environment Options: File Locations

The File Locations options determine the locations of users’ archive directories and the custom 
views directory.
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Archive Directory

Select the directory to be used for archiving items. Each user must have his or her own archive 
directory, so this can be a local directory (for example, c:\novell\groupwise) or a personal user 
directory on a network server. If you select a local drive, make sure users have the directories 
created. If you select a network drive, make sure users have the necessary rights to access the 
directories.

Custom Views

This option applies only if you are using custom views. Select the directory where the views are 
located. The GroupWise product does not include the capability to design custom views, but third-
party products make use of this feature to support their specialized capabilities.

Environment Options: Cleanup

The Cleanup options determine the delete and archive settings for GroupWise items (mail 
messages, phone messages, appointments, tasks, and notes).
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Mail and Phone

Choose from the following settings to determine how mail and phone messages are deleted and 
archived:

Manual Delete and Archive: Select this option to have mail and phone messages deleted or 
archived only when users manually do it. This is the default setting.

Auto-Delete After: Select this option to have GroupWise automatically delete mail and 
phone messages that are older than the specified number of days. If you use this option, you 
should notify users so they know they must archive items they want to save.

Auto-Archive After: Select this option to have GroupWise archive mail and phone messages 
that are older than the specified number of days. Users must have an archive directory 
specified in order for items to be archived. See “Environment Options: File Locations” on 
page 982 for information about setting a default archive directory location. 

Appointment, Task, and Note

Choose from the following settings to determine how appointments, tasks, and notes are deleted 
or archived:

Manual Delete and Archive: Select this option to have appointments, tasks, and notes 
deleted or archived only when users manually do it. This is the default setting.

Auto-Delete After: Select this option to have GroupWise automatically delete appointments, 
tasks, or notes that are older than the specified number of days. If you use this option, you 
should notify users so they know they must archive items they want to save.

Auto-Archive After: Select this option to have GroupWise automatically archive 
appointments, tasks, and notes older than the specified number of days. Users must have an 
archive directory specified in order for items to be archived. See “Environment Options: File 
Locations” on page 982 for information about setting a default archive directory location.
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Empty Trash

Deleted items are moved to the Trash folder. They can be retrieved from the Trash until it is 
emptied. Items in the Trash still take up disk space. Select from the following settings to determine 
how the Trash folder is emptied: 

Manual: Select this option to require the user to manually empty the Trash. This is the default 
setting.

Automatic: Select this option to have GroupWise automatically empty items from the trash 
after they have been in it for the specified number of days.

Allow Purge of Items Not Backed Up: Select this option to enable items that have not been 
backed up to be removed from the trash. This option is enabled by default.

Select the Prompt Before Purging option (available only if Allow Purge of Items Not Backed 
Up is enabled) to prompt the user to confirm the purging of any files that have not been backed 
up.

Environment Options: Threshold

The Threshold option lets you determine how much work the GroupWise client performs versus 
how much work it offloads to the Post Office Agent (POA).

Operations

Set the number of operations for the GroupWise client to perform before offloading message 
delivery to the POA. The default is 0, which means that all message delivery will be offloaded to 
the POA.

The Threshold can be set only by the administrator and cannot be changed by users. 
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Environment Options: Retention

The Retention tab is displayed only if the Provides Message Retention Service setting is turned on 
for a trusted application. For information, see “Trusted Applications” on page 62.

Message retention is configurable by administrators only, not by GroupWise users. The Retention 
options do not display in the GroupWise client.

Enable Message Retention Service

Select this option to enable the Message Retention Service. If you are setting client options for a 
domain, all user mailboxes in the domain will support message retention. Likewise, if you are 
setting options for a post office, all users in the post office will support message retention. Once a 
user’s mailbox is enabled for message retention, the user can not perform any action (purging, 
archiving, etc.) that removes messages from the mailbox until the messages have been copied to 
another storage location by a trusted application that has been designed to provide the Message 
Retention Service.
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Modifying Send Options
1 If the Send Options dialog box is not displayed, follow the instructions in “Setting Defaults 

for the GroupWise Client Options” on page 973 to display the dialog box.

2 Click the tab that contains the options you want to change. Refer to the following sections for 
information about options:

“Send Options: Send Options” on page 987
“Send Options: Mail” on page 990
“Send Options: Appointment” on page 991
“Send Options: Task” on page 992
“Send Options: Task” on page 992
“Send Options: Note” on page 993
“Send Options: Security” on page 994
“Send Options: Disk Space Management” on page 995
NOTE: To determine which Send options are recognized by the Cross-Platform client, refer to the client 
options table in “Client Options Summary” on page 973.

3 If you want to prevent users from changing an option’s setting, click the lock button next to it.

After you click it, the lock button indicates whether the setting is locked at the domain level, 
the post office level, or the user level.

4 If you want to return all the options on a tab to their default settings, click Restore Default 
Settings.

5 When finished, click OK to save your changes.

Send Options: Send Options

The Send Options determine general settings that apply to all GroupWise item types (mail 
messages, phone messages, appointments, tasks, and notes).
Setting Defaults for the GroupWise Client Options 987



    Novell Confidential                                                                                            Manual (99a)  21 December 2004
Classification

Select the default for the security classification label at the top of the message box. It does not 
provide any encryption or additional security. It is meant to alert the recipient to the relative 
sensitivity of the item. The options are Normal, Proprietary, Confidential, Secret, Top Secret, and 
For Your Eyes Only. The default is Normal.

Priority

Select High, Standard, or Low as the default item priority. Priority determines which post office 
directory an item is placed in. This, in turn, determines how quickly items will be delivered. High 
priority items will be queued ahead of normal or low priority items.

Reply Requested

Select the Reply Requested option to have items always include a reply request. By default, this 
option is disabled. If you enable the option, select whether the recipient will be asked to reply when 
it is convenient or within a specific number of days.

Allow Use of Reply to All in Rules

Select this option to enable users to use the Reply to All action when creating rules. By default, 
this option is disabled, which means that only the Reply to Sender action is available.

Allow Use of Internet Mail Tracking

Select this option to allow users’ GroupWise clients to automatically embed information in 
Internet-bound items. The embedded information instructs the receiving system to send back a 
delivery notification message (if it is supported). By default, this option is enabled.

To make Internet Status Tracking work, users must also turn on the setting in the GroupWise client 
(Tools menu > Options > Send Options > Mail > Enable Delivery Confirmation). By default, the 
Enable Delivery Confirmation is turned off in the GroupWise client.
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Expiration Date

Select this option to have unopened messages expire after the specified number of days. By 
default, this option is disabled.

Delay Delivery

Select this option to delay the delivery of messages for the specified number of days. For example, 
if you specify 3 days, a message will not be delivered until 3 days after the day it is sent. Messages 
will be delivered at 12:01 a.m. of the appropriate day. By default, this option is disabled.

Wildcard Addressing

 Wildcard addressing enables a user to send an item to all users in a post office, domain, 
GroupWise system, or connected GroupWise system by inserting asterisks (*) as wildcards in e-
mail addresses.

Not Allowed: Select this option to disable wildcard addressing.

Limited to Post Office (Default): Select this option to limit wildcard addressing to the user’s 
post office. This means that a user can send an item to all users on the same post office by 
entering * in the item’s address field.

Limited to Domain: Select this option to limit wildcard addressing to the user’s domain. This 
means that a user can send an item to all users in the domain by entering *.* in the item’s 
address field. A user can also send an item to all users on another post office in the domain by 
entering *.post_office_name in the item’s address field.

Limited to System: Select this option to limit wildcard addressing to the user’s GroupWise 
system. This means that a user can send an item to all users in the GroupWise system by 
entering *.*.* in the item’s address field. A user can also send an item to all users in another 
domain by entering *.domain_name or to all uses in another post office by entering 
*.post_office_name.

Unlimited: Select this option to allow unlimited use of wildcard addressing. This means that 
a user can send an item to all users in another GroupWise system by entering 
*.post_office_name.domain_name or *.domain_name in the item’s address field.

Notify Recipients

Select this option to have recipients notified when they receive an item, provided they are using 
GroupWise Notify. By default, this option is enabled.

Convert Attachments

Select this option to allow conversion of attachments in items sent to non-GroupWise e-mail 
systems through a GroupWise gateway.

Allow Reply Rules to Loop

By default, GroupWise will not allow a rule-generated reply to be replied to by another rule-
generated reply. This situation, referred to as looping, can quickly increase message traffic. To 
allow reply rules to loop, select this option.   
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Send Options: Mail

The Mail options apply to mail and phone messages only.

Create a Sent Item to Track Information

By default, items the user sends are inserted in the user’s Sent Items folder. Deselect this option if 
you do not want the items placed there. If items are not placed in the Sent Items folder, users cannot 
check the delivery status of the item. The following options are available only if this option is 
selected.

Delivered: Select this option to track delivered status only. The user can open the Properties 
window of the message to view the status.

Delivered and Opened (Default): Select this option to track delivered and opened status 
only. The user can open the Properties window of the sent message to view the status.

All Information: Select this option to track all status information (delivered, opened, deleted, 
emptied). The user can open the Properties window of the message to view the status.

Auto-Delete Sent Item: Select this option to automatically delete messages from the user’s 
Mailbox after all the recipients have deleted the messages and emptied them from the Trash.

Return Notification

In addition to status tracking information, the user can receive notification when a message is 
opened or deleted. Choose from the following notification options:

None (Default): The user will not receive notification. 

Mail Receipt: The user will receive a mail message stating that the recipient opened or 
deleted the message.

Notify: The user will receive notification through GroupWise Notify when the recipient opens 
or deletes the message.

Notify and Mail: The user will receive notification through GroupWise Notify and a mail 
message.
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Send Options: Appointment

The Appt options apply to appointments only.

Create a Sent Item to Track Information

The setting for this option is inherited from the setting on the Mail tab; it can only be enabled or 
disabled on the Mail tab. If the option is enabled, you can choose from the following status tracking 
levels: 

Delivered: Select this option to track delivered status only. The user can open the Properties 
window of the appointment to view the status.

Delivered and Opened: Select this option to track delivered and opened status only. The user 
can open the Properties window of the appointment to view the status.

All Information (Default): Select this option to track all status information (delivered, 
opened, deleted, emptied). The user can open the Properties window of the appointment to 
view the status.

Return Notification

In addition to status tracking information, the user can receive notification when an appointment 
is opened, accepted, or deleted. Choose from the following notification options:

None (Default): The user will not receive notification. 

Mail Receipt: The user will receive a mail message stating that the recipient opened, 
accepted, or deleted the appointment.

Notify: The user will receive notification through GroupWise Notify when the recipient 
opens, accepts, or deletes the appointment.

Notify and Mail: The user will receive notification through GroupWise Notify and a mail 
message.
Setting Defaults for the GroupWise Client Options 991



    Novell Confidential                                                                                            Manual (99a)  21 December 2004
Send Options: Task

The Task options apply to tasks only.

Create a Sent Item to Track Information

The setting for this option is inherited from the setting on the Mail tab; it can only be enabled or 
disabled on the Mail tab. If the option is enabled, you can choose from the following status tracking 
levels: 

Delivered: Select this option to track delivered status only. The user can open the Properties 
window of the task to view the status.

Delivered and Opened: Select this option to track delivered and opened status only. The user 
can open the Properties window of the task to view the status.

All Information (Default): Select this option to track all status information (delivered, 
opened, deleted, emptied). The user can open the Properties window of the task to view the 
status.

Return Notification

In addition to status tracking information, the user can receive notification when a task is opened, 
accepted, completed, or deleted. Choose from the following notification options:

None (Default): The user will not receive notification. 

Mail Receipt: The user will receive a mail message stating that the recipient opened, 
accepted, completed, or deleted the task.

Notify: The user will receive notification through GroupWise Notify when the recipient 
opens, accepts, completes, or deletes the task.

Notify and Mail: The user will receive notification through GroupWise Notify and a mail 
message.
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Send Options: Note

The Note options apply to notes only.

Create a Sent Item to Track Information

The setting for this option is inherited from the setting on the Mail tab; it can only be enabled or 
disabled on the Mail tab. If the option is enabled, you can choose from the following status tracking 
levels: 

Delivered: Select this option to track delivered status only. The user can open the Properties 
window of the note to view the status.

Delivered and Opened (Default): Select this option to track delivered and opened status 
only. The user can open the Properties window of the note to view the status.

All Information: Select this option to track all status information (delivered, opened, deleted, 
emptied). The user can open the Properties window of the note to view the status.

Return Notification

In addition to status tracking information, the user can receive notification when a note is opened 
or deleted. Choose from the following notification options:

None (Default): The user will not receive notification. 

Mail Receipt: The user will receive a mail message stating that the recipient opened or 
deleted the note.

Notify: The user will receive notification through GroupWise Notify when the recipient opens 
or deletes the note.

Notify and Mail: The user will receive notification through GroupWise Notify and a mail 
message.
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Send Options: Security

The Security options apply to all GroupWise item types (mail messages, phone messages, 
appointments, tasks, and notes).

Conceal Subject

Select this option to conceal the item’s subject so the notification that appears on the recipient’s 
screen does not include the subject. The subject of the item is also concealed in the recipient’s 
mailbox and the sender’s Sent Items folder. It is visible only when the item is being read.

Require Password to Complete Routed Item

Select this option to require a user to enter a password before completing a routed item.

Secure Items Options

If users have installed security providers on their workstations, select the options you want them 
to use.

Do Not Allow Use of S/MIME: Select this option to disable S/MIME functionality. This 
disables the Encrypt and Digitally Sign buttons (and other related S/MIME functionality) in 
the GroupWise client. By default, this option is enabled. When enabled, you can modify the 
following options.

URL for Certificate Download: Specify the Internet address of your preferred certification 
authority. If not otherwise changed in this field, the GroupWise client accesses http://
www.novell.com/groupwise/certified.html, which lists several common certification 
authorities.

Sign Digitally: Select this option to enable users to add a digital signature to their outgoing 
messages. Recipients of a digitally-signed item who have S/MIME-enabled e-mail products 
are able to verify that the item is actually from the sender. This setting will not be a useful 
security measure unless you lock it as the default.
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Encrypt for Recipients: Select this option to enable users to encrypt an outgoing item so they 
can ensure that the intended recipients who have an S/MIME-enabled e-mail product are the 
only individuals who can read the item. This setting will not be a useful security measure 
unless you lock it as the default.

If you enable the Encrypt for Recipients options, you can set the encryption algorithm and key 
size. The available algorithm methods (RC2, RC4, DES, 3DES) are trusted algorithms that 
encrypt or transform data to mask the original content. The key size sets the default size (in 
bits) of the encryption key that will be used with the algorithm you select. These settings will 
not be useful security measures unless you lock them.

Send Options: Disk Space Management

The Disk Space Management options let you enforce disk space limitations for users on a post 
office.

User Limits

Select this option if you want to impose limits on the size of users’ mailboxes or the size of 
message they can send. By default, this option is disabled. If you enable it, modify the following 
options:

Mailbox Size Limit: Specify the maximum amount of post office disk space available to 
users for storing message and attachment files. The setting uses logical disk space because 
attachments are shared by all recipient users on the same post office. Messages in shared 
folders are counted as disk space only for the owner of the shared folder. If you do not want 
to limit the mailbox size, set the value to zero (0).

If users meet or exceed their mailbox size limits, they will not be able to send items until their 
mailboxes are under the size limit. Users can reduce the size of their mailboxes by deleting or 
archiving items.

Threshold for Warning Users: Select the mailbox capacity (in percentage) that must be 
reached before the user is warned that his or her mailbox is reaching its limit. For example, if 
the mailbox size limit is 200 MB and the threshold is set at 75%, users will receive warnings 
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when their mailboxes reach 150 MB. Set the value to 0 or 100 if you do not want users to 
receive a warning.

Maximum Send Message Size: Specify the maximum size of a message (in kilobytes) that a 
user can send using the GroupWise client. If the user sends an item that exceeds this size, a 
message notifies the user that the item is too large to send. 

You can also set message size limits at the post office level through POA configuration, at the 
domain level through MTA configuration, and at the GroupWise system level through 
Internet Agent configuration, as described in “Restricting the Size of Messages That Users 
Can Send” on page 175.

Modifying Security Options
1 If the Security Options dialog is not displayed, follow the instructions in “Setting Defaults for 

the GroupWise Client Options” on page 973 to display the dialog box.

2 Click the tab that contains the options you want to change. Refer to the following sections for 
information about options:

“Security Options: Password” on page 997
“Security Options: Macros” on page 998
“Security Options: Notify” on page 999
NOTE: To determine which Security options are recognized by the Cross-Platform client, refer to the 
client options table in “Client Options Summary” on page 973.

3 If you want to prevent users from changing an option’s setting, click the lock button next to it.

After you click it, the lock button indicates whether the setting is locked at the domain level, 
the post office level, or the user level.

4 If you want to return all the options on a tab to their default settings, click Restore Default 
Settings.

5 When finished, click OK to save your changes.
996   GroupWise 6.5 Administration Guide



    Novell Confidential                                                                                            Manual (99a)  21 December 2004
Security Options: Password

The Password options let you reset a user’s password and enable various methods by which a user 
can set up the GroupWise client so that he or she doesn’t have to enter a password at startup. 

For background information about passwords, see Chapter 79, “GroupWise Passwords,” on 
page 1033.

Enter New Password

This option is available only when setting client options for an individual user. You can use this 
option to set or reset a user’s password. You should advise the user to change the password as soon 
as possible.

Retype Password

This option is available only when setting client options for an individual user. If you enter a new 
password, verify it by retyping it in this field.

Clear User Password

This option is available only when setting client options for an individual user. Select the option 
to clear an existing password without assigning a new password.

Allow Password Caching

Select this option to allow users to enable the Remember My Password option under Security 
options in the GroupWise client. The Remember My Password option stores the user’s password 
in the workstation’s Windows password list so that the user does not need to enter the password 
when starting GroupWise. This option is enabled by default.

The Remember My Password option applies to Windows 98 only. It will not be displayed to users 
running the GroupWise client on Windows NT/2000.

Allow eDirectory Authentication Instead of Password

Select this option to allow users to select the No Password Required with eDirectory option under 
Security options in the GroupWise client. When selected, this option lets the user access his or her 
mailbox without requiring a password if he or she is already logged in to Novell® eDirectoryTM. 
Mailbox access is granted based on eDirectory authentication, not on password information.
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In versions of GroupWise prior to the GroupWise 5.5 Enhancement Pack, this option was called 
Allow NDS Single Sign-on. The option name has been changed to avoid confusion with the Novell 
Single Sign-on product.

Enable Single Sign-On

 Select this option to allow users to select the Use Single Sign-on option under Security Options 
in the GroupWise client. When selected, this option lets the user access his or her mailbox without 
reentering the password. The GroupWise password is stored in eDirectory for the currently 
logged-in user.

Novell Single Sign-on must be installed on user’s workstation in order for this option to take effect.

Security Options: Macros

The Macros option determines how GroupWise handles macros that are included in received 
messages.

View Macro Security

Choose from the following settings to determine the level of macro security:

Always Play Received Macros: Select this option to play attached macros when the message 
is opened.

Never Play Received Macros: Select this option to ignore attached macros. Macros will not 
play. 

Always Prompt Before Playing a Macro (Default): Select this option to have the user 
prompted to play the macro.
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Security Options: Notify

The Notify option determines how often GroupWise Notify checks a user’s mailbox for newly 
received items. If new items are detected, the user is notified. The default is every minute.

Modifying Date and Time Options
1 If the Date and Time Options dialog box is not displayed, follow the instructions in “Setting 

Defaults for the GroupWise Client Options” on page 973 to display the dialog box.

2 Click the tab that contains the options you want to change. Refer to the following sections for 
information about options:

“Date and Time Options: Calendar” on page 1000
“Date and Time Options: Busy Search” on page 1002
NOTE: The Date and Time options are not currently recognized by the Cross-Platform client.
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3 If you want to prevent users from changing an option’s setting, click the lock button next to it.

After you click it, the lock button indicates whether the setting is locked at the domain level, 
the post office level, or the user level.

4 If you want to return all the options on a tab to their default settings, click Restore Default 
Settings.

5 When finished, click OK to save your changes.

Date and Time Options: Calendar

The Calendar options determine basic settings for the GroupWise Calendar.

Month Display Option

Select from the following options to determine how the month calendar is displayed:

First of Week: Select the day of the week that you want to display as the first day on the 
calendar.

Highlight Day: Select any days you want highlighted, such as weekends and holidays.

Show Week Number: Select this option to display the week number (1 through 52) at the 
beginning of the calendar week.

Appointment Options

Select from the following options to determine how appointments are handled:

Include Myself on New Appointments: Select this option to have the sender automatically 
included in the appointment’s To: list. This option is enabled by default.

Display Appointment Length As: When creating an appointment, the sender must specify 
the appointment’s length. You can use this option to determine whether the sender enters a 
duration for the appointment or an end time for the appointment. Select the Duration setting 
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to have appointments display a Duration field that the sender must fill in (for example, 30 
minutes, 1 hour, or 10 hours). Select the End Date and Time setting to have appointments 
display End Date and Time fields that the sender must fill in (for example, June 3, 2001 and 
10:00 a.m.). The default setting is Duration.

Default Length: Select the default length for appointments. Users can change the length. If 
the appointment’s length is displayed as a duration, the duration defaults to this length. If it is 
displayed as an end date and time, the end time defaults to the start time plus the default length 
(for example, if the start time is 9:00 a.m. and the default length is 1 hour, the end time will 
default to 10:00 a.m.).

Alarm Options

Users can set appointment alarms so that they are notified prior to an appointment time. Select 
from the following options to determine the default settings for an alarms:

Set Alarm When Accepted: Select this option to have an alarm automatically set when the 
user accepts an appointment. By default, this option is enabled.

Default Alarm Time: Select the number of minutes before an appointment to notify the user. 
The default is 5 minutes.

Work Schedule

The work schedule determines the user’s normal work days and hours. In the calendar and during 
busy searches, any days or hours outside of the work schedule are represented by gray squares (Out 
of Office). Users can still be scheduled for appointments during non-work hours.   

Start Time: Select the daily start time. The default is 8:00 a.m.

End Time: Select the daily end time. The default is 5:00 p.m.

Work Days: Select the work days. The start time and end time will be applied to each work 
day. 
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Date and Time Options: Busy Search

The Busy Search options determine the amount of free time required for the appointment and the 
range of dates to search. 

Appointment Length

Set the default appointment length to search. You can set the length in 15-minute increments. The 
default is 15 minutes. This setting is used only when the user does a busy search through the Busy 
Search option on the Tools menu. Otherwise, the default appointment length defined on the 
Calendar tab (see “Date and Time Options: Calendar” on page 1000) is used.

Range and Time to Search

Specify the number of days to include in the search then set the daily start and end times for the 
search.

Days to Search

Select the days to search. By default, the typical work days (Monday through Friday) are selected. 

Resetting Client Options to Default Settings
You can reset client options to the defaults for one or more users using Mailbox/Library 
Maintenance.

1 In ConsoleOne, select one or more User objects (or GroupWise External Entity objects).

2 Click Tools > GroupWise Utilities > Mailbox/Library Maintenance.

3 In the GroupWise Objects list, select Users/Resources.

4 In the Actions list, select Reset Client Options > click Run.
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75 Distributing the GroupWise Client

You can distribute the GroupWise® client software in various ways:

“Using GroupWise AutoUpdate and SetupIP to Distribute the GroupWise Windows Client” 
on page 1003

“Using ZENworks Desktop Management to Distribute the GroupWise Windows Client” on 
page 1015

“Using Red Carpet to Distribute the GroupWise Cross-Platform Client” on page 1020

Using GroupWise AutoUpdate and SetupIP to Distribute the 
GroupWise Windows Client

During installation and subsequent updates, the GroupWise® 6.x. Windows client Setup program 
generally requires user intervention at the workstation to install the client software. By using a 
configuration file, you can cause installations and updates to occur, simplifying or eliminating the 
user response during installation. You can also use this configuration file to enable AutoUpdate, 
which forces updates to take place. This allows you to maintain current versions of the GroupWise 
software on the network.

“Understanding the Configuration File” on page 1003

“Installing with the Configuration File (setup.cfg)” on page 1004

“Modifying the Configuration File” on page 1005

“Adding LDAP Directory Service Accounts” on page 1010

“Enabling AutoUpdate” on page 1011

“Modifying the addon.cfg File” on page 1013

“Error Log File” on page 1014

“Startup Switches for Administrator-Defined Setup” on page 1014
NOTE: This section does not apply to the Cross-Platform client.

Understanding the Configuration File
The use of a configuration file to install GroupWise is often called an administrator-defined setup. 
The configuration file, setup.cfg, is an ASCII text file that supports extended ASCII characters. 
The file contains the responses normally provided by the user during the installation of the 
Windows client files; for example, the path for the client files, whether to complete a workstation 
or standard installation, and the folder for the GroupWise icon are specified in this file. 
Information can be added to the configuration file to add predefined LDAP directory service 
accounts to the Address Book in the client during installation.
Distributing the GroupWise Client 1003



    Novell Confidential                                                                                            Manual (99a)  21 December 2004
When the GroupWise Windows client setup.exe file is executed, it looks in the same directory for 
a setup.cfg file. If none is found, the installation proceeds, prompting the user for the needed 
information. If the setup.cfg file is found, the setup program installs the software, using the 
information outlined in the configuration file. Depending on the entries in the configuration file, 
the user might or might not be prompted to provide information during the installation.

If you are going to use a configuration file to install Windows client software, users should be 
given Read and File Scan rights to the software_distribution_directory\client and 
software_distribution_directory\client\win32 directories. (This does not apply if you are running 
AutoUpdate over an IP connection.)

Installing with the Configuration File (setup.cfg)
During the installation of GroupWise Administration, the GroupWise client files were copied to 
the software distribution directory on your server. For example, if you accepted the default 
z:\grpwise\software as your target, the GroupWise client software was copied to 
z:\grpwise\software\client\win32. 

Installing with a Configuration File (setup.cfg)

1 Make a backup copy of software_distribution_directory\client\setup.cfg. Using an ASCII text 
editor, edit the setup.cfg file entries with the values you want. See “Modifying the 
Configuration File” on page 1005 for more information.

2 If you want to add predefined LDAP directory service accounts to the Address Book, follow 
the procedure in “Adding LDAP Directory Service Accounts” on page 1010.

3 If you want to use AutoUpdate, follow the procedure in “Enabling AutoUpdate” on 
page 1011.

4 Save setup.cfg > copy the file to the software_distribution_directory\client\win32 directory. 

5 If you want to install additional components on users’ workstations, follow the procedure in 
“Modifying the addon.cfg File” on page 1013. 

For information about installing GroupWise Messenger as an additional component by 
modifying the addon.cfg file, see “Installing the Messenger Windows Client as a GroupWise 
Windows Client Add-On” in “Managing Messenger Client Users” in the Messenger 1.0 
Administration Guide.

If you use several different configuration files, you will need to save them with different names 
and use the config=setup filename startup switch. See “Startup Switches for Administrator-
Defined Setup” on page 1014 for more information.

To stop setup.exe from using the setup.cfg file, delete setup.cfg from the directory where setup.exe 
resides.

Setupip.fil File

In previous versions of GroupWise, all language versions of the setupip.fil file, used when running 
AutoUpdate over an IP connection, were not included on the CD and had to be downloaded from 
the Novell® Downloads page (http://download.novell.com). 

In GroupWise 6.5 Support Pack 1, all non-localized files are included in the setupip.fil file and 
there is a separate setupip.language_code file for each language (setupip.de, setupip.fr, and so on). 
All of these files are included in the setupip directory on the GroupWise 6.5 Client CD in Support 
Pack 1 and do not need to be downloaded separately. 
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If you did not select all options for Client when you initially created your software distribution 
directory, you will need to copy the setupip directory from the GroupWise 6.5 Client CD to the 
software distribution directory. Copy the setupip.fil file and any language-specific 
setupip.language_code files you want to the HTTP Web server that you will be using for SetupIP. 
If there are multiple SetupIP files on the Web server, users are prompted for which languages they 
want to install. For more information, see “Enabling AutoUpdate” on page 1011.

Modifying the Configuration File
The configuration file is divided into the following sections. In the configuration file, each section 
head must be enclosed in brackets [ ] as shown.

“[GroupWiseSetup]” on page 1005

“[ShowDialogs]” on page 1006

“[AutoUpdate]” on page 1007

“[Startup]” on page 1008

“[GWTIP]” on page 1008

“[GWMAILTO]” on page 1009

“[GWCHECK]” on page 1009

“[IntegrationApps]” on page 1010

“[Languages]” on page 1010

[GroupWiseSetup] 

“Version=” on page 1005

“StandardInstall=” on page 1005

“Path=” on page 1005

“Folder=” on page 1006

“LaunchMessenger=” on page 1006

“DefaultIPAddress=” on page 1006

“DefaultIPPort=” on page 1006

Version= 

This must match the version being installed; otherwise, the setup program will not use setup.cfg. 
The default is 6.

StandardInstall= 

Specify the type of installation desired. Specify No for a workstation installation, which allows the 
user to run GroupWise from the network. Specify Yes for a standard installation, which allows the 
user to run GroupWise from the computer’s hard drive. A standard installation is required to use 
Caching mode and Remote mode. The default is No.

Path= 

This is the path where you want GroupWise to be installed during a standard installation. The 
default path is c:\novell\groupwise\.
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Folder= 

This will create and install the GroupWise icons to the specified folder. The default folder is 
GroupWise.

LaunchMessenger=

This optional entry specifies whether GroupWise Notify should be launched when GroupWise 
starts.

DefaultIPAddress=

This optional entry specifies the default IP address for the client to use the first time it is started.

DefaultIPPort=

This optional entry specifies the default IP port for the client to use the first time it is started.

[ShowDialogs]

“HideAllDialogs=” on page 1006

“Welcome=” on page 1006

“SetupOptions=” on page 1006

“DestinationDirectory=” on page 1007

“SelectOptionalComponents=” on page 1007

“SelectProgramFolder=” on page 1007

“SelectStartUpFolderSoftware=” on page 1007

“LanguageSelection=” on page 1007

“SoftwareIntegrations=” on page 1007

“StartCopyingFiles=” on page 1007

“SetupComplete=” on page 1007

HideAllDialogs=

Specify No to display dialog boxes during the installation. Specify Yes to hide the dialog boxes. 
A progress indicator will be displayed to inform the user of the installation status. The default is 
No.

If an entry is missing from the setup.cfg file and HideAllDialogs=Yes, the setup program will 
select the default setting. If HideAllDialogs=No, the setup program will prompt the user for a 
selection.

Welcome=

Specify Yes to display the Welcome dialog box during the installation. Specify No to hide this 
dialog box. The default is Yes.

SetupOptions=

Specify Yes to display the Setup Options dialog box during the installation. Specify No to hide this 
dialog box. The default is Yes.
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DestinationDirectory=

Specify Yes to display the Destination Directory dialog box during the installation. Specify No to 
hide this dialog box. The default is Yes.

SelectOptionalComponents=

Specify Yes to display the Select Optional Components dialog box during the installation. Specify 
No to hide this dialog box. The default is Yes.

SelectProgramFolder=

Specify Yes to display the Select Program Folder dialog box during the installation. Specify No to 
hide this dialog box. The default is Yes.

SelectStartUpFolderSoftware=

Specify Yes to display the Select Startup Folder Software dialog box during the installation. 
Specify No to hide this dialog box. The default is Yes.

LanguageSelection=

Specify Yes to display the Language Selection dialog box during the installation. Specify No to 
hide this dialog box. The default is Yes.

SoftwareIntegrations=

Specify Yes to display the Software Integrations dialog box during the installation. Specify No to 
hide this dialog box. The default is Yes.

StartCopyingFiles=

Specify Yes to display the Start Copying Files dialog box during the installation. Specify No to 
hide this dialog box. The default is Yes.

SetupComplete=

Specify Yes to display the Setup Complete dialog box during the installation. Specify No to hide 
this dialog box. The default is Yes.

[AutoUpdate] 

When an update to the GroupWise software is available, users are prompted if they want to install 
the new software when they start GroupWise. For complete instructions on enabling AutoUpdate, 
see “Enabling AutoUpdate” on page 1011.

“Enabled=” on page 1007

“SetupIPEnabled=” on page 1008

“ForceUpdate=” on page 1008

“GraceLoginCount=” on page 1008

“PromptUntilUpdated=” on page 1008

Enabled=

Specify Yes if you want users to be prompted to update their GroupWise client software as soon 
as a newer version is available. Specify No if you want to disable the AutoUpdate feature. The 
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ForceUpdate= entry is then ignored. This can be useful if you intend to distribute the client 
software using a different method such as ZENworks® Application Launcher, or if you want to 
disable AutoUpdates at the post office level during a migration to a newer version of GroupWise. 
The default is Yes.

SetupIPEnabled=

The default is No. Specify Yes if you want to run AutoUpdate over an IP connection to a software 
distribution directory that resides on an HTTP web server.

ForceUpdate= 

When this entry is set to Yes, GroupWise automatically updates the users’ software. The default 
is No.

Users can still click Cancel to cancel out of the update; however, they cannot run the client 
software and access their mailboxes until they update the software.

GraceLoginCount=

Specify the number of grace logins allowed before you will require the users to update their client 
software. If ForceUpdate is set to No, this entry is ignored.

PromptUntilUpdated= 

When PromptUntilUpdated= is set to Yes, the user will be prompted to update the client each time 
the GroupWise client starts. The user can choose not to install the new software when prompted 
and still run the currently installed version of the client. The AutoUpdate reminder will appear the 
next time the user starts the client. The default is No.

[Startup] 

Notify=

If you specify Yes, the setup program will place Notify in the Startup folder to be started 
automatically when the computer starts. The default is No.

[GWTIP] 

The Tip of the Day introduces what’s new in the GroupWise client, as well as displaying a variety 
of hints about using GroupWise. A new tip is displayed each time GroupWise is started.

“Default=” on page 1008

“Hide=” on page 1008

“Workstation=” on page 1009

Default=

If you specify No, Tip of the Day will not be installed. If you specify Yes, Tip of the Day will be 
installed. The default is Yes.

Hide=

If you specify No, Tip of the Day will appear in the Select Components dialog box. The default is 
No.
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The Hide= entry allows the system administrator to force the user to install or not install a 
particular component. If Hide=Yes, then the component will not be listed in the Select 
Components dialog and the Default= entry will determine if the component is going to be installed. 
For example, if Hide=Yes and Default=Yes, then the component will always be installed. 
However, if Hide=Yes and Default=No, then the component will never be installed.

Workstation=

If you specify No, Tip of the Day will not be available for a workstation installation. If you specify 
Yes, Tip of the Day will be available for a workstation installation. The default is Yes.

[GWMAILTO]

This section enables Internet Browser Mail Integration, which makes the GroupWise client the 
default e-mail program in the user’s browser. Whenever a user clicks an e-mail link on a Web page 
or chooses Mail in the browser, the GroupWise client opens.

“Default=” on page 1009

“Hide=” on page 1009

“Workstation=” on page 1009

Default=

If you specify No, Internet Browser Mail Integration will not be installed. If you specify Yes, 
Internet Browser Mail Integration will be installed. The default is Yes.

Hide=

If you specify No, Internet Browser Mail Integration will appear in the Select Components dialog 
box. The default is No.

The Hide= entry allows the system administrator to force the user to install or not install a 
particular component. If Hide=Yes, then the component will not be listed in the Select 
Components dialog and the Default= entry will determine if the component is going to be installed. 
For example, if Hide=Yes and Default=Yes, then the component will always be installed. 
However, if Hide=Yes and Default=No, then the component will never be installed.

Workstation=

If you specify No, Internet Browser Mail Integration will not be available for a workstation 
installation. If you specify Yes, Internet Browser Mail Integration will be available for a 
workstation installation. The default is Yes.

[GWCHECK]

This section installs and enables GroupWise Check (also called GWCheck). GroupWise Check is 
a tool that performs maintenance and repair tasks to keep GroupWise operating efficiently. It is 
essentially a standalone version of the Mailbox/Library Maintenance feature available in 
GroupWise Administration in ConsoleOne. GWCheck will check and repair GroupWise user, 
message, library, and resource databases without having ConsoleOne® and the GroupWise snap-
in loaded. In addition to checking post office, user, and library databases, it will also check remote 
and archive databases.

“InstallGWCheck=” on page 1010

“GWCheckEnabled=” on page 1010
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InstallGWCheck=

Specify Yes to install GWCheck files to the workstation. Specify No to not install GWCheck. The 
default is Yes.

GWCheckEnabled=

Specify Yes to install the files to the same directory as the GroupWise client, which will result in 
the Repair Mailbox option being enabled under the Tools menu in the client. Specify No to install 
the files in a GWCheck subdirectory below the GroupWise client directory, which disables the 
Repair Mailbox option until the files are manually copied into the GroupWise directory. The 
default is No.

[IntegrationApps] 

GroupWise will install integration for the following applications, if found, unless the entry is set 
to No.

Lotus Word Pro

Microsoft Binder

Microsoft Excel (versions higher than 7.0)

Microsoft Excel 7.0

Microsoft Word (versions higher than 7.0)

Microsoft Word 7.0

Microsoft PowerPoint

Corel Presentations

Corel Quattro Pro

Corel WordPerfect 7.0

Corel WordPerfect 8.0

Corel WordPerfect 9.0

Corel WordPerfect 10.0

[Languages] 

The default language is set to English, and all other languages are set to No, meaning they will not 
be installed. See the setup.cfg file for a listing of the different languages. The GroupWise client 
might not yet be available in all listed languages.

Adding LDAP Directory Service Accounts
LDAP directory service accounts provide users with the ability to search directory services such 
as Bigfoot* for names of people. Each search can check potentially millions of names. After 
locating a name through a directory service search, users can add those names to their personal 
address books.

You can add predefined LDAP directory service accounts to the Address Book by adding 
information to setup.cfg. This information can be added even after the initial installation. After the 
accounts are added, this information does not have to be removed from setup.cfg. During 
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subsequent installations, GroupWise will add any new accounts listed but will not update or 
duplicate existing LDAP accounts.

The user can also choose to add LDAP directory service accounts after the GroupWise client is 
installed.

To add an LDAP account during installation, add the following lines to the setup.cfg file, 
providing information that is specific to the account:

[LDAP Account 1]
Description=Ldap Server1
Server=ldap.server1.com
Port=389
SearchRoot=c=us
Login=TRUE

You can add multiple accounts:

[LDAP Account 2]
Description=Ldap Server2
Server=ldap.server2.com
Port=389
SearchRoot=0=widget, c=us
Login=FALSE

Enabling AutoUpdate
AutoUpdate can occur whether users have a mapped drive or IP connection to the software 
distribution directory. If users have a mapped drive to the software distribution directory, make 
sure they have Read and Scan rights to the software_distribution_directory\client and 
software_distribution_directory\client\win32 directories. 
IMPORTANT: To install the GroupWise client using AutoUpdate, you must first make sure GroupWise 6.x 
Administration and GroupWise 6.x agents have been installed, and that administration, agent, and client 
software has been updated.

IMPORTANT: If you did not select all options for Client when you initially created your software distribution 
directory, you will need to copy the setupip directory from the GroupWise 6.5 Client CD to the software 
distribution directory. If you are going to use AutoUpdate over an IP connection, copy setupip\setupip.fil to an 
HTTP web server, or copy the entire client directory to the HTTP web server.

For information about the location of setupip.fil, see “Setupip.fil File” on page 1004.

Parameter Description

Description= The name that displays in the list of LDAP directory services in the 
Address Book.

Server= The LDAP server name or IP address.

Port= The LDAP directory service’s port number. The number is usually 389.

SearchRoot= The base or root of the LDAP directory service where the user will 
search for names. For example, the base could be a country, 
organization, or other type of grouping. This is not required for all LDAP 
directory services. If a search root is required, the LDAP directory 
service will provide the information.

Login= TRUE means users are prompted for a username and password when 
they use that LDAP directory service.
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In the following procedure, steps 1-4 apply only if you will be using an IP connection for 
AutoUpdate.

1 Run software_distribution_directory\setupip\writeip.exe. 

Specify an IP location for setupip.fil (or the IP location of the software distribution client 
subdirectory). For example, you can specify:

http://151.155.135.122/gw65/client

or

http://intranet.company.com/software/gw65/gwclient

You can include proxy and port information, for example:

http://name.mycompany.com/software/gw65/
client;proxy.place.mycompany:1690

You can specify up to five locations. During AutoUpdate, each location is checked, in order, 
until a connection is made. 

If you select Choose IP Address at Random, the order in which the locations are checked is 
selected randomly when AutoUpdate occurs. This will balance the load on the web server.

2 Specify other options, such as the location for downloading the client installation files 
(setupip.fil or the client subdirectory files). 

You can have files downloaded to a temporary or specific directory.

If you select Allow the User to Change the Download Directory, the user is prompted for the 
location of the download directory and can change the default location.

3 Click OK.

The setupip.exe file is created. The writeip.ini file is also created, which stores the options you 
selected in writeip.exe.

4 Copy setupip.exe to the software_distribution_directory\client\win32 directory.

5 Make a backup copy of software_distribution_directory\client\setup.cfg.

6 Using an ASCII text editor, edit the setup.cfg file entries with the values you want.

6a Under the [AutoUpdate] heading, specify

Enabled=Yes

6b Specify

ForceUpdate=Yes

if you want GroupWise to automatically update the users’ client software

or

ForceUpdate=No

if you want users to be prompted to update their client software.

6c Specify the number of grace logins you want to allow a user before forcing an 
AutoUpdate, for example:

GraceLoginCount=2

This entry is ignored if ForceUpdate=No.

6d If you will be using an IP connection for AutoUpdate, specify

SetupIPEnabled=Yes
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7 Save the file as setup.cfg. Copy setup.cfg from software_distribution_directory\client to 
software_distribution_directory\client\win32.

8 If necessary, modify addon.cfg files with the values you want. See “Modifying the addon.cfg 
File” on page 1013 for more information.

9 Log in to ConsoleOne as an Admin equivalent.

10 Click Tools > GroupWise System Operations.

11 Double-click Software Directory Management.

12 Click the software distribution directory > Update.

13 Select Force Auto-Update Check by GroupWise Components.

This causes the GroupWise client to check for a new version. If a new version is found, the 
next time a user starts the GroupWise client, he or she is prompted to update the client 
software. If you have set ForceUpdate=Yes, the user will not be prompted before installation 
begins. If a mapped drive to the software distribution directory is found, the client software is 
installed from the mapped drive. If a mapped drive to the software distribution directory is not 
found, GroupWise looks at the IP locations you specified in writeip.ini and installs the client 
software.

In the event that no connection to the software distribution directory can be made, the file 
setupip.err is created in c:\windows of the user’s workstation. This file explains why none of 
the connections could be made.

Modifying the addon.cfg File
The addon.cfg file is an ASCII text file that supports extended ASCII characters. The GroupWise 
client setup program uses the addon.cfg file to install additional components on users’ 
workstations. The components might include software not shipped with GroupWise. The 
addon.cfg is specific to each program being installed. The required program files and the 
associated addon.cfg file must be copied to a subdirectory under 
software_distribution_directory\client\win32\addons.

During the client installation, the GroupWise setup program will search the subdirectories under 
the \addons directory for any addon.cfg files. The setup program will then execute the installation 
program for that component using the settings specified in the addon.cfg. If an entry is missing in 
the addon.cfg file, the installation program will prompt the user for the required information.

The addon.cfg files for Internet Browser Mail Integration and GroupWise Tip of the Day are 
included in the corresponding subdirectories under \addons, but the basic control for installing 
these two components is in the [GWMAILTO] and [GWCHECK] sections of setup.cfg.

For information about installing GroupWise Messenger as an additional component by modifying 
the addon.cfg file, see “Installing the Messenger Windows Client as a GroupWise Windows Client 
Add-On” in “Managing Messenger Client Users” in the Messenger 1.0 Administration Guide.

When creating an addon.cfg file for a different component, you must include at least the following 
section headings and associated entries. If the installation program requires additional information, 
you can include that information as additional entries. The required entries are as follows:

“[GroupWiseAddon]” on page 1014

“[Name]” on page 1014

“[Description]” on page 1014
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[GroupWiseAddon] 

This section head must be included with the following entries.

[Name] 

Under this section head, specify the two-letter language code for the language being installed, 
followed by the name of the add-on. This name appears in the components listing. 

Example: US=GroupWise Tip of the Day

[Description] 

Under this section head, specify the two-letter language code followed by a short description of 
the add-on. This description appears in the Description field when the component is highlighted in 
the component listing. 

Example: US=GroupWise Tip of the Day introduces new features and 
provides tips for using the GroupWise client.

Error Log File
If an error occurs during the installation and ShowDialogs=No, the error message is logged in 
gwsetup.err in the user’s \windows directory. If ErrorMessage=error_text has been added as the 
last entry under the [GroupWiseSetup] section, the error text will be displayed. Otherwise, a 
generic error message will be displayed notifying the user to contact the system administrator. The 
log file is an ASCII text file.

Startup Switches for Administrator-Defined Setup
The following startup switches can be used in conjunction with an administrator-defined setup. 
These switches can be used individually or in combination.

config=setup_filename

noconfig

record

config=setup_filename 

This runs the setup program using a configuration file other than setup.cfg. The other configuration 
file must be located in the software distribution directory. This switch does not apply when the 
GroupWise Windows client setup program is executed by AutoUpdate. 

Entry Example

Install=add-on’s_setup_program_filename Install=setup.exe

Parameters=parameters_to_be_passed_o
n_to_the_add-on’s_setup_program

Parameters=/install

Silent=parameters_to_append_to_administ
rator-defined_setup

Silent=/s

Size=installed_size_of_add-
on_in_kilobytes

Size=100
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Syntax: config=setup_filename

Example: setup config=test.cfg

noconfig

This runs the setup without using the configuration file, even if one exists. 

Syntax: noconfig

Example: setup noconfig

record 

This option runs the setup program, displaying all installation dialog boxes, and records the 
installation responses as they are selected. No installation files are copied and no changes are made 
to your workstation. After setup finishes, a corresponding setup.cfg file is created in the \windows 
directory of your workstation. 

Syntax: record

Example: setup record

Using ZENworks Desktop Management to Distribute the 
GroupWise Windows Client

You can use the Application Management functionality in Novell® ZENworks® Desktop 
Management to distribute the GroupWise Windows client to workstations. The following sections 
provide instructions:

“Understanding the GroupWise Windows Client .aot Files” on page 1015

“Creating a GroupWise Client Application Object” on page 1016
IMPORTANT: This information assumes that you are familiar with ZENworks Desktop Management. For 
background information, or for help completing the ZENworks tasks outlined in the steps below, see the 
ZENworks Desktop Management documentation at the Novell ZENworks documentation site (http://
www.novell.com/documentation-index/index.jsp?category=ZENworks).

Understanding the GroupWise Windows Client .aot Files
The most effective way to create a GroupWise client Application object is from an Application 
Object Template (.aot) file. If desired, you can use the ZENworks Desktop Management 
snAppShotTM utility to create a GroupWise Windows client .aot file, or you can use one of the 
predefined .aot files included with GroupWise:

us-9x.aot: Creates an Application object you can use to install the English version of the 
GroupWise client to a Windows 95/98/ME workstation.

us-9xwms.aot: Creates an Application object you can use to install the English version of the 
GroupWise client and the Windows Messaging System to a Windows 95/98/ME workstation

us-nt.aot: Creates an Application object you can use to install the English version of the 
GroupWise client to a Windows NT/2000/XP workstation.

us-ntwms.aot: Creates an Application object you can use to install the English version of the 
GroupWise client and the Windows Messaging System to a Windows NT/2000/XP 
workstation.
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multi19x.aot: Creates an Application object you can use to install the English, Portuguese, 
French, Italian, German, Spanish, Danish, Dutch, Norwegian, Finnish, and Swedish versions 
of the GroupWise client to a Windows 95/98/ME workstation. 

multi1nt.aot: Creates an Application object you can use to install the English, Portuguese, 
French, Italian, German, Spanish, Danish, Dutch, Norwegian, Finnish, and Swedish versions 
of the GroupWise client to a Windows NT/2000/XP workstation. 

multi29x.aot: Creates an Application object you can use to install the English, Hungarian, 
Czech, Polish, and Russian versions of the GroupWise client to a Windows 95/98/ME 
workstation. 

multi2nt.aot: Creates an Application object you can use to install the English, Hungarian, 
Czech, Polish, and Russian versions of the GroupWise client to a Windows NT/2000/XP 
workstation. 

multi39x.aot: Creates an Application object you can use to install the English, Chinese 
Simplified, Chinese Traditional, Japanese, and Korean versions of the GroupWise client to a 
Windows 95/98/ME workstation.

multi3nt.aot: Creates an Application object you can use to install the English, Chinese 
Simplified, Chinese Traditional, Japanese, and Korean versions of the GroupWise client to a 
Windows NT/2000/XP workstation.

The .aot files contain the basic information required to create GroupWise client Application 
objects in Novell eDirectory®. For example, the multi2nt.aot file can be used to create an 
Application object that, when associated with users, will cause the English, Czech, Hungarian, 
Polish, and Russian versions of the GroupWise client to be installed to a user’s Windows NT/2000/
XP workstation. For this to work, you must have already installed the files for these language 
versions to a GroupWise software distribution directory or another installation source directory.

Creating a GroupWise Client Application Object
The following steps explain how to use ZENworks Desktop Management to create an GroupWise 
client Application object from one of the .aot files. Depending on your version of ZENworks 
Desktop Management, the steps you need to complete might be slightly different. 

1 In ConsoleOne®, right-click the container where you want to create the GroupWise client 
Application object, then click New > Object to display the New Object dialog box.

2 In the list of objects, click App:Application > OK to display the New Application dialog box.
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3 Select the An Application that Has an .AOT/.AXT File option, then click Next to display the 
.AOT/.AXT file path page.

4 In the Path to .AOT/.AXT File field, browse for and select the .aot file you want to use.

By default, the .aot files are located in the client\zen directory in the GroupWise software 
distribution directory or on the GroupWise 6.5 Client CD

For example, if you want to create an Application object that will install the English, Czech, 
Hungarian, Polish, and Russian versions of the GroupWise client to a Windows NT/2000/XP 
workstation, select the multi2nt.aot file.

5 Click Next to display the Application object information page, then customize the object 
name, source path, and target path information if necessary.

Object Name: This is the name that will be used for the Application object in eDirectory. You 
might want to use a descriptive name (for example, "GroupWise ECHPR Client - 
Windows9x" for the English, Czech, Hungarian, Polish, and Russian versions installed to a 
Windows 95/98/ME workstation. 

SOURCE_PATH: This is the directory from which the GroupWise client will be installed. 
Specify the full path to the client directory (for example, 
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\\server1\vol1\grpwise\software\client). Unless all users will have the same drive mapping to 
the volume, make sure you use a UNC path.

This path is saved as the SOURCE_PATH variable. If you need to change it later, you can do 
so on the Application object’s Macros page (Application object > Common tab > Macros 
page).

TARGET_PATH: This is the workstation directory where the GroupWise client will be 
installed. Specify a path relative to the user’s workstation.

This path is saved as the TARGET_PATH variable. If you need to change it later, you can do 
so on the Application object’s Macros page (Application object > Common tab > Macros 
page).

6 Click Next to display the system requirements page, then modify the system requirements if 
necessary.

7 Click Next to display the user associations page.

You can associate the Application object with the users and workstations you want it 
distributed to at this time, or you can create the associations later.

8 After you’ve added the associations you want, click Next, review the information, then click 
Finish to create the Application object.
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9 Right-click the newly-created GroupWise client Application object, then click Properties.

10 Click Common > Macros to display the Macros page.

If you used one of the multix.aot files to create the Application object, the Macros list includes 
a DEFAULT_LANGUAGE variable. This variable specifies the interface language that the 
GroupWise client will default to when it is installed. If necessary, individual users can change 
the language when they start the GroupWise client. If you modify the default language, use 
the language codes listed under “/l-xx” on page 1027.

If you have users who use different language versions and you don’t want them to need to 
change the default language, you can use the same .aot file to create multiple Application 
objects. For each Application object, you would need to specify a default language and then 
associate the Application object with the users who would want that default language. 

11 Configure any other Application object settings required to provide the performance or 
functionality you want.

For example, you can configure the Application object so that the GroupWise client will be 
installed immediately upon distribution to the user’s workstation, without any intervention by 
the user. Or, you can change the locations where the GroupWise client’s icon will be 
displayed. For information about Application object settings, see the ZENworks Desktop 
Management documentation at the Novell Documentation Web site (http://www.novell.com/
documentation-index/index.jsp?category=ZENworks).

After you associate the Application objects with the users you want, Novell Application 
Launcher will display the Application object’s icon on the users’ workstations, provided the 
workstation meets the operating system requirements. If the Application object’s icon does 
not appear immediately, have the user refresh Novell Application Launcher. 

12 If necessary, repeat the above steps to create additional GroupWise client Application objects 
from the GroupWise client .aot files.
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Using Red Carpet to Distribute the GroupWise Cross-Platform 
Client

You can install the GroupWise Cross-Platform client and agents using Red CarpetTM 2.0 or later. 
Refer to the Red Carpet Web site (http://www.ximian.com/products/redcarpet) for additional 
information.
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76 Supporting the GroupWise Client in Multiple 
Languages

The GroupWise client software is available in a broad range of languages to meet the needs of 
users in many countries. If your GroupWise system services users who speak more than one 
language, the following tasks help you meet your multilingual users’ needs.

“Providing the GroupWise Client Software in Multiple Languages” on page 1021

“Providing Post Office Support for Multiple Languages” on page 1021

Providing the GroupWise Client Software in Multiple Languages
1 Make sure that you have the multilingual version of GroupWise.

Both initial releases and Support Packs are provided in an English Only version (for faster 
download) and a multilingual version (that includes all available languages).

2 Install the client software in the languages you need in one or more software distribution 
directories, following the instructions in “Software Directory Management” on page 57.

3 Distribute the client software to users, as described in Chapter 75, “Distributing the 
GroupWise Client,” on page 1003.

By installing the GroupWise client software in their language of choice, users can begin using 
GroupWise in that language immediately. However, there are a few language-related details of 
GroupWise functionality that are not taken care of by the client software running on users’ 
workstations. For a fuller multilingual implementation, continue with “Providing Post Office 
Support for Multiple Languages” on page 1021.

Providing Post Office Support for Multiple Languages
A few aspects of GroupWise functionality are affected by the language in use by the POA running 
for the post office to which users belong. The POA returns certain text in the language in which it 
is running, not the language in use on users’ workstations. 

The status information (Delivered, Opened, an so on) displayed in the Properties page of items

The text of return notification mail receipts (if the user has enabled this type of notification)

The sort order in the Address Book

In some circumstances, these issues can be resolved by grouping users who speak the same 
language into the same post office and then installing the POA in the same language that the users 
are using. The following sections of the GroupWise 6.5 Administration Guide help you with the 
tasks of setting up additional post offices and installing the POA for each one:
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“Creating a New Post Office” on page 147

“Installing and Starting the POA” on page 427

At present, the POA is available in fewer languages than the GroupWise client, so this solution 
helps only those client users who are at least somewhat familiar with the language in use by the 
POA.
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77 Tools for Analyzing and Correcting GroupWise 
Client Problems

The following tools can assist you in analyzing and correcting GroupWise® client problems.

“GroupWise Exception Handler for the Windows Client” on page 1023

“GroupWise Check” on page 1023

GroupWise Exception Handler for the Windows Client
In the event that the GroupWise Windows client causes an exception (or “crashes”), GroupWise 
generates a GroupWise Exception Report. This report contains information that is useful in 
analyzing the problem that the client is having so that it can be solved.

The report is saved in \temp\grpwise.rpt. The \temp directory used is the one specified by the TMP 
environment variable, or if not defined by TMP, the one specified by the TEMP environment 
variable. If neither environment variable is defined, GroupWise uses the current directory 
specified when grpwise.exe is started (on Windows 95/98/ME) or the windows directory (on 
Windows NT/2000).

Each time an exception or crash occurs, a new report is appended to grpwise.rpt. If the file reaches 
100K, the oldest reports (at the beginning of the file) are deleted.

The GroupWise Exception Report contains information such as the date and time the report was 
generated, the exception code, fault address, date of grpwise.exe, computer and username where 
the exception occurred, hardware and operating system information, process modules, raw stack 
dumps, and call stacks.

GroupWise Check
GroupWise Check (GWCheck) is a tool that performs maintenance and repair tasks to keep 
GroupWise operating efficiently. It is essentially a standalone version of the Mailbox/Library 
Maintenance feature available in ConsoleOne®. GroupWise Check checks and repairs GroupWise 
user, message, library, and resource databases without having ConsoleOne and the GroupWise 
snap-in loaded. In addition to checking post office, user, and library databases, it also checks 
remote and archive databases. 

“Enabling GroupWise Check in the Windows Client” on page 1024

“Using GroupWise Check with the Cross-Platform Client” on page 1024
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Enabling GroupWise Check in the Windows Client
GroupWise Check can be installed with the GroupWise Windows client (unless you have specified 
in setup.cfg that it not be installed), and is available by clicking Tools > Repair Mailbox in the 
client in Caching and Remote modes after you complete the following:

1 Locate the directory named gwcheck. This is a subdirectory of the directory where the client 
is installed (usually c:\novell\groupwise).

2 Locate grpwise.exe. It is usually in c:\novell\groupwise.

3 Copy all the files in gwcheck to the directory where grpwise.exe is located.

You can now run GroupWise Check in Caching and Remote mode. The GroupWise Check dialog 
box is titled GroupWise Mailbox Maintenance. You can also use Ctrl+Shift when accessing a 
Caching or Remote mailbox to run GroupWise Check before opening the mailbox.

For detailed information about GroupWise Check, click Help or see “GroupWise Check” on 
page 391.

Using GroupWise Check with the Cross-Platform Client
GroupWise Check is not accessible from the Cross-Platform client but can be installed on a Linux 
workstation if you need to repair local databases. For installation instructions, see “Starting 
GWCheck on a Linux Workstation” on page 394.
NOTE: GroupWise Check is not available on Macintosh.
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78 Startup Switches for the GroupWise Client

The GroupWise® client has optional startup switches that you can use when you start the program. 
Some of these startup switches are for your convenience, while others are necessary to run 
GroupWise on your particular hardware. Some switches are not available in the Cross-Platform 
client. 

/@u-?
Displays a login dialog box whenever you open the GroupWise client, allowing you to supply any 
necessary login information.

Syntax: /@u-?

Example: grpwise.exe /@u-?

Windows Client Cross-Platform Client

/@u-? -@u ?

/@u-user_ID -@u user_ID

/bl N/A

/c N/A

/cm N/A

/iabs N/A

/ipa-IP_address_or_hostname -ipa IP_address_or_hostname

/ipp-port_number -ipp port_number

/l-xx -l xx

/la-network_ID N/A

/nu -nu

/ph-pathname -ph pathname

/pc-path_to_caching_mailbox -pc path_to_caching_mailbox

/pr-path_to_remote_mailbox N/A
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/@u-user_ID
Lets you use your GroupWise user ID to use the GroupWise client as yourself on another user’s 
computer. The other user remains logged on to the network.

Syntax: /@u-user_ID

Example: grpwise.exe /@u-ltanaka

/bl 
Prevents the GroupWise client logo screen from being displayed when you start the GroupWise 
client. 

Syntax: /bl

Example: grpwise.exe /bl

This startup switch is not available in the Cross-Platform client.

/c
Checks for unopened items. If there are unopened items, the GroupWise client opens as usual. 
Otherwise, the GroupWise client does not start. 

Syntax: /c

Example: grpwise.exe /c

This startup switch is not available in the Cross-Platform client.

/cm
Checks for unopened items. If there are unopened items, the GroupWise client opens minimized 
and a beep sounds. Otherwise, the GroupWise client does not start. 

Syntax: /cm

Example: grpwise.exe /cm

This startup switch is not available in the Cross-Platform client.

/iabs
Initializes the Address Book when the GroupWise client starts. 

Syntax: /iabs

Example: grpwise.exe /iabs

This startup switch is not available in the Cross-Platform client.
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/ipa-IP_address_or_hostname
Lets you specify the IP address or the hostname when you are running in client/server mode.

Syntax: /ipa-IP_address

Example: grpwise.exe /ipa=127.65.45.1

/ipp-port_number 
Lets you specify the IP port number when you are running in client/server mode.

Syntax: /ipp-port_number

Example: grpwise.exe /ipp-1677

/l-xx
Applies only if you have two or more language versions or language modules. This option instructs 
GroupWise to override the default environment language (under Environment in Options) with the 
language specified by the language code xx. The language codes are listed below. This table lists 
the language codes used by all Novell® products. GroupWise might not yet be available in some 
of the listed languages. For current information, contact your local reseller.

Language Code

Arabic AR

Chinese Simplified ZH-CN

Chinese Traditional ZH-TW

Czech CS

Danish DK

Dutch NL

English US

Finnish SU

French FR

German DE

Hebrew HE

Hungarian MA

Italian IT

Japanese JA

Korean KO

Norwegian NO
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Syntax: /l-xx

Example: grpwise.exe /l-ES

/la-network_ID
Lets you use your network ID to use the GroupWise client as yourself on another user’s computer. 
The other user remains logged on to the network. 

Syntax: /la-network_ID

Example: grpwise.exe /la-jgrey

This startup switch is not available in the Cross-Platform client.

/nu
Turns off AutoRefresh. If this option is selected, click View > Refresh whenever you want to 
update the display to see the items currently in your mailbox.

Syntax: /nu

Example: grpwise.exe /nu

/ph-pathname
Lets you specify the path to the post office.

Syntax: /ph-pathname

Example: grpwise.exe /ph-j:\mail\denver1

/pc-path_to_caching_mailbox
Opens GroupWise in Caching mode. GroupWise must be restarted when you change from Online 
to Caching.

Syntax: /pc-path_to_caching_mailbox

Example: grpwise.exe /pc-c:\novell\groupwise\cache

Polish PL

Portuguese BR

Russian RU

Spanish ES

Swedish SV

Language Code
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/pr-path_to_remote_mailbox
Opens the GroupWise client in Remote mode. This startup switch can be used in the Target text 
box only. 

Syntax: /pr-path_to_remote_mailbox

Example: grpwise.exe /pr-c:\novell\groupwise\remote

This startup switch is not available in the Cross-Platform client.
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