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About This Guide

As part of the open source movement, many enterprises and small businesses are looking to Linux 
as a key platform for their business systems. Novell® Linux Small Business Suite (NLSBS) brings 
to the Linux platform all the network services you need to enable and manage the your small 
business network.

This guide will help you understand, set up, manage, and use the products and rich features 
included in Novell Linux Small Business Suite 9.

For information on the features and benefits of NLSBS, see Chapter 1, “Overview,” on page 9.

For information on setting up and configuring the server environment, see Chapter 2, “Installing 
Novell Linux Small Business Server,” on page 15.

For information on managing e-mail and other collaboration services, see Chapter 3, “E-Mail and 
Instant Messaging,” on page 25.

For information on setting up printing for network users, see Chapter 4, “Network Printing,” on 
page 49.

For information on publishing documents to the Web, see Chapter 5, “Web Server Publishing,” on 
page 53.

Documentation Conventions

In this documentation, a greater-than symbol (>) is used to separate actions within a step and items 
within a cross-reference path.

A trademark symbol (®, TM, etc.) denotes a Novell trademark. An asterisk (*) denotes a third-party 
trademark.

When a single pathname can be written with a backslash for some platforms, or a forward slash 
for other platforms, the pathname is presented with a forward slash to reflect the Linux convention. 
Users of platforms that require a backslash, such as NetWare®, should use backslashes as required 
by the software.
About This Guide 7
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1 Overview

As a small business owner, you need to get the job done and keep your business running. 
Technology can improve your business processes and save you time and money, but you do not 
have unlimited IT resources, employees, and time. 

With Novell® Linux Small Business Suite (NLSBS), you can have confidence that your data is 
secure, your employees are communicating effectively, and your customers are being served with 
the best networking technologies in the market.

Designed to deliver complete, reliable networking solutions tailored for your needs, this suite of 
products provides many features traditionally available only in large enterprises but without all the 
complexity. NLSBS delivers real value to small businesses with a small network of up to 100 
workstations.

Features and Benefits
Novell Linux Small Business Suite is a network server environment that provides market-leading 
tools and technologies to help you and your employees be more productive and efficient. Setting 
up the suite delivers secure e-mail, shared scheduling, secure data storage, easy and reliable 
printing, Web server publishing, and much more.  

The following table summarizes just a few of the main features available in NLSBS.

Table 1 Features and Benefits

Feature Benefit

Novell Linux Small Business Server Reliable and secure network operating 
system with powerful tools for network 
administrators.

GroupWise® post office A powerful server environment providing 
e-mail and other collaboration services.

GroupWise WebAccess Desktop software that allows access to 
e-mail over the Internet with a Web 
browser.

GroupWise client software Desktop software that includes e-mail, 
calendaring, and task management for 
Linux, Windows*, and Macintosh* 
workstations.

GroupWise Messenger Desktop software that provides instant 
messaging capability for Linux, 
Windows, and Macintosh workstations.
Overview 9
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Novell Linux Small Business Server
At the heart of the NLSBS is the server running Novell SUSE® Linux Enterprise Server (SLES) 
operating system. The SLES operating system is the same fast, reliable server platform used for 
enterprise-level networks, but customized in NLSBS to meet the needs of companies with smaller 
networks. 

The server manages the network traffic and provides connectivity to workstations using 
technologies such as Internet Protocol (IP), Domain Name Service (DNS), Dynamic Host Core 
Protocol (DHCP), and Novell eDirectory. You can run all your business applications and services 
on a single server or you can dedicate it to provide just a few services, such as Internet connectivity 
with a firewall, a file server where users can store files, or a collaboration server to provide e-mail 
and instant messaging services. However you choose to configure the Novell Linux Small 
Business Server, it has the horsepower to handle your network needs. 

NLSBS includes several utilities and applications to help you manage network resources. Novell 
eDirectory, a network directory service which lets administrators organize network objects into a 
directory or tree, simplifies management of network resources and streamlines the user login 
experience. Novell iManager and ConsoleOne are two important utilities you can use to manage 
Novell eDirectory. 

Because the Novell Linux Small Business Server runs on Linux, you can use open source 
technologies and solutions to help you keep down the cost ownership. You can realize significant 
benefits associated with software such as Apache, MySQL*, Perl, Common UNIX Printing 
System (CUPS), and Tomcat, which are all included as part of the NLSBS.

Apache HTTP Server Web server software that stores and 
provides HTML documents to users on 
the Internet or intranet using a Web 
browser.

Samba Server services that provide network 
access to Windows and other CIFS/SMB 
client workstations.

Common UNIX Printing System A printing environment that lets users 
print to printers on the network.

Novell eDirectoryTM A network directory that organizes 
network resources to simplify network 
administration.

Novell iManager and ConsoleOne® Linux, Windows, and browser-based 
software, used to manage the directory 
and network resources.

Novell Red Carpet® Administrative and desktop program to 
keep your server and desktop updated 
with the latest software programs and 
patches.

Feature Benefit
10   Novell Linux Small Business Suite 9 Product Guide
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Novell GroupWise and Messenger
Novell GroupWise and Messenger deliver powerful tools for administrators and easy-to-use 
interfaces for end users. Network end users can use these collaboration programs to organize their 
work and improve communication with others. GroupWise and Messenger provide the following 
benefits to end users running on Linux, Windows, or Macintosh workstations.

GroupWise: Send and receive e-mail, schedule appointments, track contacts, monitor tasks, and 
manage documents and files.

! E-mail and other messages: A mail message is for general correspondence. A phone message 
is designed for those who take phone messages for others. A reminder includes a start date 
and, when accepted by the recipient, is posted to the receipient’s calendar.

! Appointments and tasks: When you schedule an appointment, you can search other users' 
calendars to find free times for the appointment. When you schedule a task, you can assign a 
priority and due date to the task. If the recipient accepts an appointment or task, it is 
automatically added to his calendar.

Of course, you have options to view and manage your own appointments, tasks, and reminder 
notes in several different ways. You can accept or decline the tasks you are sent, and track 
accepted tasks through to completion. You can categorize and prioritize your tasks by using 
the Checklist feature.

! Contacts: Manage information for your contacts, groups, resources, and organizations, 
including being able to view, update, delete, and add information to the contacts in your 
address book. In addition, you can view a history of messages sent to and received from 
individual contacts.

Folder List
Folder and Item 

List Header
Toolbar

Quick Viewer Item List
Overview 11
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! Documents and files: Store documents, graphics, presentations, and other files in GroupWise. 
You can store them in folders or attach them to appointments, tasks, or e-mail messages. The 
files are compressed to save disk space and encrypted to maintain security.

GroupWise WebAccess: Endusers can use a Web or network browser on any computer to access 
their GroupWise e-mail, schedules, tasks, and contacts over the Internet. This easy-to-use user 
interface lets users at home, in the office, or on the road organize their work and communicate with 
others.

Novell Messenger. Communicate instantly, in real time, with other users on the network. 
Messenger lets you know when other users are online, busy, or away from their desks. It also 
allows you to save conversations to a file.

The infrastructure for these collaboration services is delivered through a GroupWise post office 
and software programs (called agents) running on the Small Business Server. This powerful and  
secure infrastructure provides the service level and capability demanded by end users while 
reducing the cost of ownership for system administrators.

Folder List Item List

Toolbar
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Workstation Connectivity
Novell Linux Small Business Suite lets users log in, communicate, and share files on the network 
using Linux, Macintosh, and Windows workstations. 

Linux workstations can use native commands and desktops to access the network. The Novell 
Linux Desktop (NLD) is included in the NLSBS. The NLD is a desktop operating system and suite 
of office software that enables businesses to use Linux and open source with confidence. It 
includes Novell editions of OpenOffice.org (the leading open source office productivity suite), 
Novell Evolution (the most popular open source collaboration client), Mozilla* Firefox* (a secure, 
feature-rich 
Web browser), and Red Carpet (update services for adding patches and additional software). NLD 
is included as part of the NLSBS. Of course, Novell Linux Small Business Server works with other 
Linux desktops too.

Windows workstations: When properly configured with Samba, the Novell Linux Small Business 
Server provides network services to Windows and other Common Internet File Service (CIFS) 
workstations. Without installing additional software, Windows users can access network files and 
folders through familiar Windows venues such as My Network Places and My Computer.

What’s Next
Now that ou have an understanding of Novell Linux Small Business Suite, you can install and set 
up the software. Continue with Chapter 2, “Installing Novell Linux Small Business Server,” on 
page 15.
Overview 13
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2 Installing Novell Linux Small Business Server

The Novell® Linux Small Business Server is the heart of the network. It is based on the Novell 
SUSE® LINUX Enterprise Server (SLES) platform. Using auto-detection, preselected 
configuration choices and wizards, the installation program and this chapter guide you through the 
steps to install the server and configure it for your business needs. 

To install the server operating system and configure the network environment for the Novell suite 
of products, you must complete the following tasks in the following order.

1. Meet system requirements.

2. Install the server operating system.

3. Set up Red Carpet® automatic updates.

4. Set up Novell eDirectoryTM.

5. Set up GroupWise® e-mail and Messenger.

6. Set up iManager.

There are many different options for installing the server operating system. This chapter explains 
how to set up a basic one-server, one-tree network environment.
NOTE: For information on installing other server/network configurations and about problems you might 
encounter during the server installation, see the SUSE LINUX Enterprise Server 9 Administration and 
Installation Guide (http://www.novell.com/documentation/sles9/pdfdoc/sles_9_admin_guide/
sles_9_admin_guide.pdf).

After installing the server operating system and configuring the initial services on the server, you 
can provide network services, such as Web servers and network printers. For more information on 
setting up and managing available network services, see the other chapters in this book.

Meeting System Requirements
Before you start the server installation, make sure the computer meets the system requirements and 
you have the necessary information in the following table.

Table 2 System Requirements and Descriptions

Requirement Description

Computer (minimum requirements) Pentium* II processor, 512 MB of RAM, 10 GB disk space, and 
CD-ROM drive.

Computer (recommended requirements) Pentium 4 1.5 GHz processor, 1 GB of RAM, 20 GB disk 
space, and CD-ROM drive. Additional space might be required 
depending on the software components installed and specific 
data storage needs.
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During the installation, installed devices and connected peripherals are auto-detected. Before you 
begin, verify that network cards, graphics cards, sound cards, and other internal devices are 
installed and that printers, backup devices, and other peripherals are attached. Also, make sure the 
computer hardware is properly attached to the network and Internet.

Installing the Server Operating System
The installation program guides you through the following tasks required to install and configure 
the server:

1. Begin the installation.

2. Specify language and installation settings.

3. Configure the server.

For information on installing other server/network configurations and about problems you might 
encounter during the server installation, see the SUSE Linux Enterprise Server 9 Administration 
and Installation Guide (http://www.novell.com/documentation/sles9/pdfdoc/
sles_9_admin_guide/sles_9_admin_guide.pdf).

Static IP address An externally visible, static IP address must be specified for at 
least one network card in the Small Business Server. You can 
get IP addresses from your Internet Service Provider (ISP).

Novell eDirectory and GroupWise require a static IP address, 
and will not work properly if the network card is configured with 
DHCP.

Domain names At least one domain name must be registered with your DNS 
provider. You can set up the same or different DNS names for 
other services such as host and e-mail. You can get domain 
names from your ISP.

IMPORTANT: The domain name used for e-mail addresses 
needs a DNS record of type MX (mail exchange) that identifies 
this server as your mail server and a DNS record of type A 
(address) that resolves to this server's public IP address. You 
can set up GroupWise and Messenger for internal use before 
your Internet connection has been activated by your ISP.

Internet connection The computer must be properly connected to the Internet to 
configure and use Internet services, such as e-mail and 
external Web publishing.

Network time source (recommended) Specifying and linking to an external time source is 
recommended to provide accurate time to all devices on the 
network. The source can be on the internal network or on the 
Internet, but it must use Network Time Protocol (NTP).

Contact your ISP for the address or domain name of an NTP 
server or see a list of public NTP servers at NTP.Servers Web 
(http://ntp.isc.org/bin/view/Servers/WebHome). 

Requirement Description
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Beginning the Installation
1 Insert Novell Linux Small Business Suite CD 1 into the CD-ROM drive.

2 Boot the computer from the CD-ROM drive.

3 Use the arrow keys to select Installation.

Figure 1 The Boot screen

4 Use the arrow keys to highlight Installation, then press Enter to begin the installation.

Throughout the installation, use the keyboard or mouse to supply the required information, then 
click the appropriate button to proceed to the next screen. When the installation begins, you are 
prompted to specify language and installation settings. 

Specifying Language and Installation Settings
The installation program uses a Linux program named YaST (Yet another Setup Tool) to guide 
you through the steps to install and configure the server. Novell Linux Small Business Suite 9 has 
already preloaded the installation program with optimal server settings for your business 
environment. 

In this section of the installation program, you are prompted to select the language and keyboard 
settings to use for the rest of the installation program. You are also asked to specify or verify 
settings such as how disk partitions should be created and which software programs should be 
installed. 

1 When prompted, select the language you want to use during the installation program.

2 Click New Installation.

3 Review the Installation Settings to verify they are correct. To change settings, click Change. 
IMPORTANT: Do not change the Sofware setting to anything other than Novell Linux Small Business 
Suite 9. This selection installs a mix of software designed specifically for this initial installation program. 
Other Software selections (such as Minimum System, Minimum Graphical System, Full Installation, and 
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Default System) are designed for installations in other environments. Of course, if you need to, you can 
remove or install additional software programs after the initial server installation is complete.

4 After verifying all settings, click Accept.

5 Insert the CDs as prompted by the installation program.

The installation program creates disk partitions, copies program files and selected software 
packages to the server, and sets up the computer as specified. After completing the steps in this 
section, you are prompted to configure the server.

Configuring the Server
The steps to set up the server require you to set up the root user, configure network settings and 
services, and choose the authentication method for users on your system. 

1 Enter a password for the root user.

The root user, sometimes referred to as System Administrator or Superuser, is an account with 
access to everything on the system.

2 Configure the network settings.
IMPORTANT: NLSBS products (such as Novell GroupWise and eDirectory) require the network card to 
be configured with its own static IP address instead of using DHCP to obtain an IP address. 

To configure the network interface card, click Change > Network Interfaces, then follow the 
screen instructions to specify the IP address, subnet mask address, hostname, domain name, 
name server addresses, domain search server addresses, and the address of the default 
gateway.
TIP: Contact your ISP for information required to configure your network interface card.

3 Test the Internet connection.

This step verifies that network configuration settings are properly specified. If the Internet test 
connection fails, go back and check the settings in Network Configuration.

4 Configure network services.

NLSBS provides a network service known as the Certificate Authority (CA) which issues 
certificates to establish credibility of users and services over SSL connections. There can be 
only one CA on the network and it is created during this server installation program. 

For more information about Certificate Authority and other network services, see Network 
Services (http://www.novell.com/documentation/sles9/pdfdoc/sles_9_admin_guide/
sles_9_admin_guide.pdf#page=66).

5 Select the authentication method for user accounts on the system.

NLSBS was designed for network environments consisting of a single server and up to 100 
users logging in using local authentication methods. If you are installing a server on a network 
that uses another authentication method, see User Authentication (http://www.novell.com/
documentation/sles9/pdfdoc/sles_9_admin_guide/sles_9_admin_guide.pdf#page=67).

6 Create at least one local user account.

User and group accounts are used to manage who has access to which files on the system. To 
add more than one local user account, click User Management on the Add New Local User 
screen before you click Next.

7 Configure graphics card, printer, and sound card.
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If properly connected and installed, the correct settings for each device should be found with 
the installation’s auto-detection program. If the settings are incorrect or a device is not 
detected, click Change and enter the correct settings.

The installation program now installs operating system files and does the initial configuration of 
Novell Small Business Server.

Next Steps
The next step is to set up Red Carpet automatic updates so the server is updated with the latest 
software patches and programs.

Set Up Red Carpet Automatic Updates
Your purchase of Novell Linux Small Business Suite entitles you automatic updates and patches 
using Red Carpet to connect to a service on the Internet. It is a simple, convenient way to keep 
your network running smoothly. 

It is recommended that you set up automatic updates as soon as you install the server operating 
system.

1 From the server desktop’s Main menu, select System > Configuration > Red Carpet.

2 Select Connect to This System, and then click Connect.

If you are prompted to start the daemon, click Yes.

3 On the Updates - Red Carpet screen, activate the service by clicking File > Activate.

Activation requires you to enter the activation code and other information you received when 
you purchased the product. 

4 Subscribe to all relevant channels.

5 Verify the updates on the Updates page, then click Update All.

You can configure Red Carpet to update automatically or at the interval you choose. For more 
information, see the Novell Red Carpet Administration Guide (http://www.novell.com/
documentation/ximian/redcarpet.pdf).

What’s Next
After updating your system with the latest patches and software, you should continue with the next 
section, “Setting Up Novell eDirectory” on page 19 so your network resources are secure and easy 
to manage.

Setting Up Novell eDirectory
Novell eDirectory is a directory framework (or tree) that organizes network resources such as user 
accounts, applications, data, and services into a hierarchical system called a tree. Each network 
resource is represented by an object residing in a container in the tree.

1 Launch the eDirectory Setup Wizard.

The Setup Wizard is located on the server desktop in the YaST Control Center. From the 
server desktop’s Main menu, select System > YaST, then click Novell Linux Small Business 
Suite.
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2 Create a new eDirectory tree.

Novell Linux Small Business Server is designed for use in a single-tree, single-server 
environment, but it can also be added to an existing tree.

3 Select a network time source.

The network time source, or NTP server, is the device you select to be the time source for 
devices and services on the network. Network services often require system clocks on 
network devices to be synchronized with the clock on the servers.

Contact your ISP for the address or domain name of an NTP server or see a list of public NTP 
servers at NTP.Servers Web (http://ntp.isc.org/bin/view/Servers/WebHome). 

4 Create a context and administrator account.

The administrator account (admin) is a user with all rights to all files, folders, and objects in 
eDirectory. In this step, you create the admin user account and designate and create the 
container (or folder) where the admin User object will reside in the eDirectory tree. 

It is recommended that you place the admin account in the organization folder by simply 
replacing organization with the name of your organization. 

To create an admin in a different container, type the username and contexts in fully-
distinguished-name format. The admin User object, context, and subcontexts are created for 
you. For example, typing cn=admin.ou=sales.o=companyname creates and places the admin 
user in the organizational unit (ou) named sales in the organization (o) named companyname.

5 Specify eDirectory contexts and ports.

The eDirectory Server Context is the container where the Server object will reside. It is 
recommended that you place the Server object in the organization (o) container.

To place the Server object in a different container, type the server context in fully-
distinguished-name format in eDirectory Server Context. The context and subcontexts are 
created and the Server object is placed in the specified container. For example, typing 
ou=servers.o=companyname creates and places the Server object in the organizational unit 
named servers in the organization (o) named companyname.
TIP: See the online help for a list of the default port assignments.

6 Do not configure Service Location Protocol (SLP).

In a small-business environment, SLP is not required.

The eDirectory Setup Wizard now sets up eDirectory with the settings you chose and returns you 
to the Novell Linux Small Business Suite category page.
IMPORTANT: Do not create user accounts in eDirectory until after you set up GroupWise on the server. After 
GroupWise is installed, you can create user accounts in iManager and be prompted to assign a post office for 
each user.

What’s Next
Continue with the next section, “Setting Up GroupWise E-Mail and Messenger” on page 21 so 
network users can have a post office and e-mail services.
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Setting Up GroupWise E-Mail and Messenger
Novell Linux Small Business Suite includes several GroupWise software components that provide 
network users with secure, easy-to-use collaboration solutions. During the installation, you are 
prompted to install and configure the following components.

! Basic GroupWise system (one domain with its Message Transfer Agent and one post office 
with its Post Office Agent)

The domain functions as the main administrative unit for your GroupWise system. The post 
office serves as an administrative unit for a group of users and contains users’ mailboxes. Each 
GroupWise user has an address that consists of a user ID, the user’s post office name (gwpo 
by default), the GroupWise domain name (gwdom by default) and, optionally, an Internet 
domain name (typically, the name of your company).

! E-mail connectivity to the Internet (Internet Agent)

The Internet Agent allows communication between GroupWise users and users of other 
messaging systems who use the Internet to send e-mail. It also allows users to user POP and 
IMAP e-mail clients to access their GroupWise mailboxes.

! Browser-based access to mailboxes (WebAccess)

WebAccess enables access to GroupWise mailboxes through Web browsers, WAP-enabled 
wireless telephones, Palm OS devices, and Windows CE devices. WebAccess, when used on 
a computer’s Web browser, provides most of the functionality available in the GroupWise 
client for Windows. Functionality on other devices is more limited.

! Instant messaging (Novell Messenger)

Messenger is a corporate instant messaging product that is based on eDirectory. It enables 
users to send instant messages in a secure environment that includes user authentication 
through eDirectory and SSL encryption of instant messages.
IMPORTANT: SSL encryption requires that you obtain a public certificate and private key file for your 
Small Business server. If you are not familiar with the process of obtaining these files, refer to “Server 
Certificates and SSL Encryption” in “Security” in the GroupWise 6.5 Administration Guide. These files 
must exist on your Small Business server before you can set up instant messaging.

! Check the status of GroupWise and Messenger agents (Monitor)

Monitor lets administrators use an Internet browser to check the status of GroupWise and 
Messenger agents. As administrator, you can monitor agents and gateways from any location 
where you are connected to the Internet and have access to a Web browser. You can also use 
Monitor to do some administrative tasks from your Internet browser.

NOTE: If you are planning to set up your GroupWise system on more than one server, review “Setting Up a 
Multiple Server System” on page 45 before setting up your initial GroupWise system. If you want to set up 
GroupWise and Messenger using an installation script (instead of running the GroupWise Setup Wizard), see 
“Using a Response File” on page 46.

To set up the initial configuration of GroupWise on the server:

1 Launch the GroupWise Setup Wizard.

The Setup Wizard is located on the server desktop in the YaST Control Center. From the 
server desktop’s Main menu, click >System > YaST, then click Novell Linux Small Business 
Suite.

2 Select the GroupWise components that you want to configure on your Small Business server, 
then click Next. 

3 Specify the admin name and password for your Small Business server, then click Next.
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Figure 2 YaST LDAP Authentication page

In order to set up your GroupWise and Messenger systems, YaST needs access to eDirectory 
so that it can create the eDirectory objects where GroupWise configuration information is 
stored for the domain, the post office, and the GroupWise and Messenger agents. eDirectory 
uses LDAP authentication to grant access. You must provide the fully distinguished name of 
the admin user (for example, cn=admin.o=mycompany), which includes the context of the 
admin User object.
IMPORTANT: Remember the admin name, password, and context. You will use it often to log in and 
manage the network.

4 (Conditional) If you selected the Internet Agent in the list of items to configure in Step 2 on 
page 21, specify the Internet domain name where you want to receive incoming e-mail from 
Internet senders, and then click Next.

Figure 3 YaST Internet Domain page

After you have provided the requested information, YaST lets you modify your choices and 
customize a variety of configuration settings, if needed, before performing the installation.

5 (Conditional) If necessary, click Change to refine the configuration of your GroupWise 
system and then click Next to return to the Configuration Summary page.
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Figure 4 YaST Summary page

6 Click Finish on the Configuration Summary page to create your initial GroupWise and 
Messenger systems.

After the GroupWise domain and post office have been created, YaST starts the GroupWise 
and Messenger agents so that your GroupWise system is ready for use. In addition, it 
configures your Linux server so that the GroupWise and Messenger agents start automatically 
whenever you reboot the server. For information about stopping, starting, and monitoring the 
agents, see “Managing the GroupWise and Messenger Agents” on page 41.

The GroupWise Setup Wizard now sets up the Novell Linux Small Business Server with 
GroupWise components and returns you to the Novell Linux Small Business Suite category page. 

What’s Next
Continue with the next section, “Setting Up iManager” on page 23 so you can create, edit, and 
delete network resources. This includes creating Novell eDirectory users who can use GroupWise 
e-mail and messaging services.

Setting Up iManager
Novell iManager is a network management utility that you run in an Internet browser. With it, 
network administrators can view and manage resources (objects) in the network tree and create, 
edit, and delete network objects such as user, printer, and container.

1 Launch the iManager Setup Wizard.

The Setup Wizard is located on the server desktop in the YaST Control Center. From the 
server desktop’s Main menu, click >System > YaST, then click Novell Linux Small Business 
Suite.

2 Authenticate to eDirectory and enter the domain name of the Web server.

The iManager Setup Wizard now sets up iManager with the settings you chose and returns you to 
the Novell Linux Small Business Suite category page. You are now finished setting up the Novell 
Linux Small Business Server.
Installing Novell Linux Small Business Server 23



    Novell Confidential                                                                                            Manual (ENU)  21 December 2004
What Next
You have now completed the installation and initial setup of the Novell Linux Small Business 
Server. You can now configure other features and technologies based on your networking needs:

! E-Mail and Instant Messaging (page 25)

! Network Printing (page 49)

! Web Server Publishing (page 53)
24   Novell Linux Small Business Suite 9 Product Guide



    Novell Confidential                                                                                            Manual (ENU)  21 December 2004
3 E-Mail and Instant Messaging

After you have set up your basic GroupWise® system, as described in “Setting Up GroupWise E-
Mail and Messenger” on page 21, you can create e-mail accounts for your users and set up users’ 
workstations so they can access their GroupWise mailboxes. As time passes, you might also need 
to perform some agent management tasks.

! “Creating GroupWise E-Mail Accounts” on page 25

! “Setting Up User Workstations for E-Mail and Instant Messaging” on page 27

! “Maintaining E-Mail and Instant Messaging” on page 35

Creating GroupWise E-Mail Accounts
You can use iManager to create new users with GroupWise accounts and instant messaging 
capabilities. 
NOTE: All other GroupWise and Messenger administration requires the use of ConsoleOne®, as described in 
“Using ConsoleOne” on page 35.

1 To start iManager, open the Small Business Suite home page.

http://server_address

2 In the right pane, click Launch iManager.

3 Specify the admin name and password for your Small Business server, and then click Login.

4 Add a user to your Small Business system.

4a In the left pane, scroll down to the Users section, and then click Create User.
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4b Provide user information as needed, and then click OK.

A message informs you that the Create User request succeeded.

5 Click OK.

The Create User Mailbox page then prompts you for the GroupWise post office.

6 Click OK to add the user to the post office that was created as part of your initial GroupWise 
system.

7 Repeat Step 4 through Step 6 for each new user.

If you have users whose eDirectory accounts existed before you created your GroupWise 
system, you must use ConsoleOne to add GroupWise accounts to the existing eDirectory User 
objects (see “Creating GroupWise Accounts Manually” on page 38).

What’s Next
After you created user and assign a post office, continue with the next section, Setting Up User 
Workstations for E-Mail and Instant Messaging.

Setting Up User Workstations for E-Mail and Instant Messaging
After your GroupWise system is up and running (see “Setting Up GroupWise E-Mail and 
Messenger” on page 21) and you have created eDirectory user accounts and GroupWise mailboxes 
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(see “Creating GroupWise E-Mail Accounts” on page 25), users can start communicating quickly 
and efficiently using e-mail and instant messaging.

! “Setting Up E-Mail” on page 27

! “Setting Up Instant Messaging” on page 33

Setting Up E-Mail
After the GroupWise agents are running and users have GroupWise accounts set up, users can 
access their GroupWise mailboxes to send and receive e-mail in a variety of ways:

! “Using the GroupWise WebAccess Client” on page 27

! “Installing and Using the GroupWise Linux Client” on page 28

! “Installing and Using the GroupWise Macintosh Client” on page 29

! “Installing and Using the GroupWise Windows Client” on page 29

! “Using a POP or IMAP E-Mail Client” on page 30

! “Using Microsoft Outlook” on page 32

Using the GroupWise WebAccess Client

The GroupWise WebAccess client allows users to access their GroupWise mailboxes from a Web 
browser on the road, in the office, or at home. The WebAccess Agent and a Web server must be 
running on your Small Business server in order for WebAccess to be available to GroupWise users. 
You must give the users the IP address or hostname of your Small Business server in order for them 
to use WebAccess. Then give them the following instructions.

1 Open the Small Business home page.

http://server_address

You can use either the server IP address or hostname.

2 In the right pane, click Access E-Mail from the Web.

The WebAccess Login page appears.

3 Save this URL as a bookmark.

4 Provide the username and password associated with your GroupWise mailbox.

5 Click Login to log in to GroupWise WebAccess.
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For assistance in learning to use GroupWise WebAccess, click Help or refer to the GroupWise 
6.5 WebAccess Client User Guide in the Groupwise 6.5 online documentation.

Installing and Using the GroupWise Linux Client

The GroupWise Linux client is ideal for e-mail, calendaring, scheduling, and much more on Linux 
workstations. The GroupWise Linux client software must be installed on each user’s workstation.

1 Open the Small Business home page.

http://server_address

You can use either the server IP address or hostname.

2 In the right pane, click Download the GroupWise Linux Client.

3 Review the installation instructions, and then click the link to download the file.

4 Save the install.bin file to a convenient location on your workstation.

5 Open a new terminal window, and then change to the directory where you saved the install.bin 
file.

6 Become root by entering su and the root password.

7 Enter sh install.bin.

Progress is displayed in the terminal window.

8 To start the GroupWise Linux client, click the GroupWise shortcut on your desktop.

9 Provide your GroupWise user ID, your eDirectory password, and the address (IP address or 
hostname) of your Small Business server, and then click OK.

For assistance in learning to use the GroupWise Linux client, click Help or refer to the 
GroupWise 6.5 Cross-Platform Client User Guide in the GroupWise 6.5 online 
documentation.

Installing and Using the GroupWise Macintosh Client

The GroupWise Macintosh client is ideal for e-mail, calendaring, scheduling, and much more on 
Macintosh workstations. The GroupWise Macintosh client software must be installed on each 
user’s workstation.

1 Open the Small Business home page.

http://server_address
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You can use either the server IP address or hostname.

2 In the right pane, click Download the GroupWise Macintosh Client.

The GroupWise.app.sit file automatically installs the Cross-Platform client software on your 
Macintosh workstation.

3 To start the GroupWise Macintosh client, click the GroupWise shortcut on your desktop.

4 Provide your GroupWise user ID, your eDirectory password, and the address (IP address or 
hostname) of your Small Business server, and then click OK.

For assistance in learning to use the GroupWise Macintosh client, click Help or refer to the 
GroupWise 6.5 Cross-Platform Client User Guide in the GroupWise 6.5 online 
documentation.

Installing and Using the GroupWise Windows Client

The GroupWise Windows client is ideal for e-mail, calendaring, scheduling, and much more on 
Windows workstations. The GroupWise Windows client software must be installed on each user’s 
workstation. You have two options for distributing the GroupWise client software to users:

! Make copies of the Novell GroupWise 6.5 Client CDs and give them to users. The client 
Installation program is located at the root of the CD.

! Have users download the GroupWise Windows client from the GroupWise 6.5 Product 
Updates Web page (http://support.novell.com/filefinder/16963/index.html).

The following procedure assumes that users have the Novell GroupWise 6.5 Client CDs or have 
downloaded and extracted the client software files.

1 Make sure you are logged in as yourself on your workstation.

2 Click Start > Run, browse to the location of setup.exe on the Novell GroupWise 6.5 Client CD 
or the download location, select setup.exe, and then click OK.

3 Follow the instructions in the Setup program to install the Windows client software on your 
workstation.

Immediately after installation, the client Setup program gives you the opportunity to start the 
GroupWise Windows client. It also places an icon on your desktop to use when starting 
GroupWise in the future.

4 When you start GroupWise, provide your GroupWise user ID, your eDirectory password, and 
the address (IP address or hostname) of your Small Business server, and then click OK.
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For assistance in learning to use the GroupWise Windows client, click Help or refer to the 
GroupWise 6.5 Windows Client User Guide in the GroupWise 6.5 online documentation.

Using a POP or IMAP E-Mail Client

If your users are familiar with a common POP or IMAP e-mail client such as Outlook* Express on 
Windows or EvolutionTM on Linux, they can continue to use it to access their GroupWise 
mailboxes. Users of POP or IMAP e-mail clients have access to the feature sets of their familiar 
e-mail clients, but there are many GroupWise features that are not available to POP and IMAP e-
mail clients.

The GroupWise Internet Agent is required in order for users to access their mailboxes using POP 
and IMAP e-mail clients. If you have not already installed the Internet Agent, you can rerun the 
GroupWise installation in YaST (as described in “Setting Up GroupWise E-Mail and Messenger” 
on page 21) selecting only the Internet Agent, or you can follow the instructions for installing the 
Internet Agent in the GroupWise 6.5 Installation Guide.

In order for users to access their GroupWise mailboxes from a POP or IMAP e-mail client, they 
must configure their e-mail clients to access their GroupWise accounts. 

! “Configuring Outlook Express to Access Your GroupWise System” on page 30

! “Configuring Evolution to Access Your GroupWise System” on page 32

Configuring Outlook Express to Access Your GroupWise System
NOTE: Steps might vary depending on the versions of Windows and Outlook Express installed on the 
workstation.

1 In Outlook Express, click Tools > Accounts > Add > Mail.

2 Follow the prompts and provide personal information until you are prompted for the e-mail 
server information.

3 Select POP3 or IMAP as your incoming mail server type.

4 In the Incoming and Outgoing Mail fields, specify the IP address or hostname of your Small 
Business server, and then click Next.

5 Continue following the prompts and providing personal information until the new account has 
been set up in Outlook Express.

6 Click Tools > Accounts.
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7 Select the new account you just created, and then click Properties > Servers.

8 Select My Server Requires Authentication, and then click OK.

The default setting for this option is Use Same Settings as My Incoming Mail Server, so you 
do not need to change any settings.

9 To access your GroupWise mailbox in Outlook Express, click Tools > Send and Receive.

10 Click the IP address or hostname of your Small Business server.

11 Provide your username and password, and then click OK.

Configuring Evolution to Access Your GroupWise System
NOTE: Steps might vary depending on the version of Evolution installed on the workstation.

1 Click Settings > Mail Accounts > Add.

2 Click Forward to start the Evolution Mail Configuration Assistant.

3 On the Identity page, provide your e-mail address in the GroupWise system (for example, 
mycompany.com), and then click Forward.

4 On the Receiving Email page, select IMAP in the Server Type list, specify the hostname of 
your Small Business server in the Host field, set the other Receiving Email options as 
appropriate for your system, and then click Forward.

5 On the Sending Email page, select SMTP in the Server Type list, specify the hostname of your 
Small Business server in the Host field, set the other Sending Email options as appropriate for 
your system, and then click Forward.

6 On the Account Management page, specify the name you want to use to identify this account 
on the Evolution Settings page, and then click Forward.

7 Click Apply to create the GroupWise account.

Your GroupWise mailbox now appears in the list of available e-mail accounts.
E-Mail and Instant Messaging 31



    Novell Confidential                                                                                            Manual (ENU)  21 December 2004
Using Microsoft Outlook

If your users have been using the Microsoft Outlook e-mail client that comes standard with 
Microsoft Office, they can continue to use it to access their GroupWise mailboxes. However, not 
all GroupWise functionality is available in Outlook.

In order for users to access their GroupWise mailboxes from Outlook, they must configure 
Windows to access their GroupWise accounts.
NOTE: Steps might vary depending on the versions of Windows and Outlook installed on the workstation.

1 In the Windows Control Panel, click Mail and Fax.

The default profile is displayed.

2 Click Show Profiles > Add to add a new profile for your GroupWise account.

3 Select Internet E-Mail, and then follow the prompts and provide personal information until 
you reach the Servers property page.

4 In the Outgoing Mail and Incoming Mail fields, specify the IP address or hostname of your 
Small Business server.

5 In the Account Name and Password fields, specify your GroupWise user ID and password.
IMPORTANT: Do not select Logon Using Secure Password Authentication.

6 Continue providing information on the Connection and Advanced property pages as needed, 
and then click OK to save the mail account information.

7 Continue following the prompts and providing personal information until the new account has 
been set up.
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8 To access your GroupWise mailbox in Outlook, click Tools > Check for New Mail On, and 
then select the mail service that you set up from the Control Panel.

9 Provide your username and password, and then click OK.

What’s Next

After you have set up users’ workstations for e-mail, you can set up instant messaging (see “Setting 
Up Instant Messaging” on page 33) or you can consider long-term GroupWise system 
management issues (see “Maintaining E-Mail and Instant Messaging” on page 35).

Setting Up Instant Messaging
After your Messenger system is set up, you must implement Secure Sockets Layer (SSL) 
encryption on your Small Business server because the Messaging Agent requires SSL on Linux. 
After your Messenger system is secured by SSL encryption, users can set up their workstations for 
instant messaging.

! “Configuring Messenger for SSL” on page 33

! “Setting Up Messenger Software” on page 34

Configuring Messenger for SSL

If you do not yet have a public certificate and private key file on your Small Business server, follow 
the instructions in “Server Certificates and SSL Encryption” in “Security” in the GroupWise 6.5 
Administration Guide. These files must exist on your Small Business server before you can set up 
secure instant messaging.

1 In a terminal window, become root by entering su and the root password.

2 Copy your public certificate file and private key file into the /opt/novell//messenger/certs 
directory on your Small Business server.

3 Stop the Messaging Agent by entering

/etc/init.d/novell-nmma stop
4 Start ConsoleOne.

See “Using ConsoleOne” on page 35.

5 Browse to and expand the Messenger Service object.

6 Right-click the Messenger Server object, and then click Properties.

7 Click Server > Security.

8 Fill in the following fields:
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Certificate Path: This field defaults to /opt/novell/messenger/certs.

SSL Certificate: Browse to and select the public certificate file. If it is located in the directory 
specified in the Certificate Path field, you can simply type the filename.

SSL Key File: Browse to and select your private key file. If it is located in the directory 
specified in the Certificate Path field, you can simply type the filename.

Enable SSL: Select this option to enable SSL encryption for your Messenger system.

Because you provided the SSL information on the Messenger Server object, it applies to both 
the Messaging Agent and the Archive Agent.

9 Click OK to save the SSL settings.

10 Restart the Messaging Agent by entering

/etc/init.d/novell-nmma start

Setting Up Messenger Software

In order for users to send instant messages, they must install Novell GroupWise Messenger on their 
workstations. 

1 Open the Small Business home page.

http://server_address

You can use either the server IP address or hostname.

2 In the right pane, click Download the GroupWise Messenger Client.

3 Follow the instructions on the Messenger Welcome page to install and start Messenger on the 
platform of your choice (Linux, Macintosh, or Windows).

For assistance in learning to use Messenger, click Help or refer to the GroupWise Messenger 
1.0 Client User Guide.

For administrative information about your Messenger system, see the Messenger 1.0 
Administration Guide.

What’s Next

After you have set up users’ workstations so they can use e-mail and instant messaging, you are 
ready to consider long-term GroupWise and Messenger management issues, as described in the 
next section,Maintaining E-Mail and Instant Messaging.
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Maintaining E-Mail and Instant Messaging
The GroupWise/Messenger Setup Wizard in YaST helps you create your initial GroupWise and 
Messenger systems. iManager helps you automatically add GroupWise accounts for new 
eDirectory users. But long-term management and growth of your GroupWise and Messenger 
systems require that you use ConsoleOne for maintenance tasks.

! “Using ConsoleOne” on page 35

! “Managing Users” on page 38

! “Managing GroupWise and Messenger Systems” on page 41

Using ConsoleOne
The eDirectory Setup Wizard in YaST installed ConsoleOne, along with the GroupWise snap-ins, 
under the /usr/ConsoleOne directory. You start ConsoleOne in a terminal window.

1 On your Linux desktop, open a terminal window, and then become root by entering su and 
the root password.

2 Enter the following command to start ConsoleOne:

/usr/ConsoleOne/bin/ConsoleOne
TIP: For ease of use, you can create a desktop icon for starting ConsoleOne. For example, if you use the 
KDE desktop, right-click the desktop, and then click Create New > File > Link to Application. On the 
Application tabbed page, specify the above command in the Command field. Click Advanced Options, 
and then in the User box, select to run ConsoleOne as root. Set up other icon properties as desired. Other 
desktops offer similar functionality.

The first time you start ConsoleOne on Linux, you are prompted for the directory where you 
typically mount external file systems.

TIP: If the Linux Mount Directory dialog box does not appear, click the ConsoleOne window to clear the 
splash screen.

The default of /mnt is typically correct. You can change the directory as needed. ConsoleOne 
requires direct access to any server where a domain or post office is located. This dialog box 
does not appear again when you start ConsoleOne in the future.

For more information about what the Linux mount directory is used for, see “Selecting a 
Linux Mount Directory” in “Installing a Basic GroupWise System” in the GroupWise 6.5 
Installation Guide.

3 If necessary, specify or browse to and select the Linux mount directory, and then click OK.

The first time you start ConsoleOne on Linux, ConsoleOne does not automatically 
authenticate to any eDirectory trees, so the NDS® object is not immediately expandable.
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4 In ConsoleOne, select the NDS object, and then click File > Authenticate.

5 Fill in the following fields:

Login Name: The Small Business server admin username.

Password: The password for the username.

Tree: The eDirectory tree for your Small Business server.
TIP: Under some circumstances, you need to provide the IP address of your Small Business server, 
rather than the tree name.

Context: The full context of the User object associated with the username you provided.

By default, the Admin object is created in the Organization object you specified when you ran 
the eDirectory Setup Wizard.

6 Click Login.

The next time you start ConsoleOne, all information except the password is automatically 
provided for you.

After you are logged in to eDirectory, you must connect to the GroupWise domain in order to 
access GroupWise system information.

7 Select the GroupWise System object, and then click Tools > GroupWise System Operations 
> Select Domain.

By default, the domain directory structure is created in /opt/novell/groupwise/db/gwdom and 
the post office directory structure is created in /opt/novell/groupwise/db/gwpo on your Small 
Business server.

8 Browse to and select the gwdom directory, and then click OK.
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9 Expand the GroupWise System object, and then expand the Domain object to view the 
structure of your basic GroupWise system in the GroupWise View.

10 Expand the NDS object, expand your tree, and then expand the Organization object to see 
where the GroupWise and Messenger objects are located in the eDirectory View.

By default, the Domain and Post Office objects are located in the same container where the 
Admin User object is located.

The sections that follow cover basic GroupWise administration tasks that you might need to 
perform in maintaining your GroupWise system on your Small Business server. For more detailed 
instructions for using ConsoleOne to manage GroupWise, see the GroupWise 6.5 Administration 
Guide.

Managing Users
As time passes, you might need to perform some of the following tasks for users:

! “Creating GroupWise Accounts Manually” on page 38

! “Deleting GroupWise Accounts” on page 39

! “Disabling LDAP Password Changing” on page 40

! “Assigning a Postmaster” on page 40

Creating GroupWise Accounts Manually

You can create eDirectory users and GroupWise accounts in ConsoleOne as well as in iManager. 
In ConsoleOne, you can create GroupWise accounts individually or for multiple users in the same 
post office.

! “Adding GroupWise Accounts When Adding eDirectory Users” on page 38

! “Adding Multiple eDirectory Users to a Post Office” on page 39

Adding GroupWise Accounts When Adding eDirectory Users

1 In ConsoleOne, browse to and right-click the container object where you want to create a new 
User object, and then click New > User.

2 Fill in the fields as needed for the eDirectory user.
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3 Select Add User to GroupWise Post Office, and then browse to and select the post office that 
you want the new user to belong to.

4 Click OK in the New User dialog box to create the new eDirectory user and assign the new 
user to the selected post office.

This creates a GroupWise tab on the property page of the User object.

Adding Multiple eDirectory Users to a Post Office

1 In ConsoleOne, browse to and right-click the post office where you want to add users (by 
default, the gwpo object), and then click Properties.

2 Click GroupWise > Membership.

3 Click Add, select one or more User objects, and then click OK.

4 Click OK on the Membership page to add the listed users to the post office.

Deleting GroupWise Accounts

You cannot delete GroupWise accounts in iManager. You must use ConsoleOne.

1 In ConsoleOne, browse to and select the context where the User object is located. 

2 Right-click the User object, and then click Delete.

or

Select multiple User objects, right-click the selected objects, and then click Delete.

3 Click Yes to display the Delete Options dialog box.
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In ConsoleOne, you can delete the user’s eDirectory object and GroupWise account together, 
or you can delete the GroupWise account while retaining the eDirectory object.

4 Click OK to delete both the eDirectory object and the GroupWise account.

or

Deselect Delete in the eDirectory Account box if you want to retain the eDirectory object, 
while deleting the GroupWise account.

5 Click OK.

Disabling LDAP Password Changing

To facilitate easy access to GroupWise mailboxes, the GroupWise/Messenger Setup Wizard in 
YaST automatically enables LDAP authentication for the post office it creates. It also configures 
the LDAP server for use by GroupWise users. This default configuration accommodates SSL if it 
is in use on the LDAP server.

LDAP authentication allows the same password to be used for network login and mailbox access. 
When LDAP authentication is enabled, users are, by default, allowed to change their LDAP 
passwords in any of the GroupWise clients (WebAccess, Linux, Macintosh, or Windows). It is 
possible that users could change their GroupWise passwords without realizing that they are also 
changing their network login passwords. To prevent this, you can use ConsoleOne to disable the 
ability to change LDAP passwords in the GroupWise client.

1 In ConsoleOne, browse to and right-click the post office (by default, the gwpo object), and 
then click Properties.

2 Click GroupWise > Security.
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3 Select Disable LDAP Password Changing, and then click OK.

ConsoleOne notifies the POA to restart so the new LDAP setting can be put into effect.

Assigning a Postmaster

On the Internet, each site must assign at least one user to be a Postmaster. The Postmaster is the 
recipient of messages addressed to postmaster@mydomain.

1 In ConsoleOne, browse to and select the domain (by default, the gwdom object) to display its 
contents.

2 Right-click the Internet Agent (GWIA) object for the domain, and then click Properties.

3 Click GroupWise > Gateway Administrators.

4 Click Add, select a GroupWise user to be the Postmaster, and then click OK.

5 Select the user from the list, and then click Postmaster.

6 Click OK to save the information.

ConsoleOne notifies the Internet Agent to restart so that applicable messages are sent to the 
Postmaster as needed.

Managing GroupWise and Messenger Systems
As time passes and your small business grows, your e-mail and instant messaging systems might 
need to change and grow as well. The following tasks can help you handle system maintenance 
and growth.

! “Managing the GroupWise and Messenger Agents” on page 41

! “Maintaining Your GroupWise System” on page 44

! “Maintaining Your Messenger System” on page 45
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Managing the GroupWise and Messenger Agents

When you set up your GroupWise system, the GroupWise and Messenger agents are configured 
to start automatically whenever you reboot your server. When started automatically, the agents run 
as daemons, without a user interface. Status information is written to log files.

In a smoothly running system, you should not need to deal with the agents individually. However, 
the following sections provide useful commands and procedures for managing the GroupWise and 
Messenger agents, should you need to do so.

! “Viewing Agent Log Files” on page 41

! “Starting and Stopping the Agent Daemons” on page 41

! “Starting the Agents with a User Interface” on page 42

! “Monitoring the Agents from Your Web Browser” on page 43

Viewing Agent Log Files

The log files for the GroupWise and Messenger agents are located in agent-specific subdirectories:

/var/log/novell/groupwise
/var/opt/novell/log/messenger

Starting and Stopping the Agent Daemons

The following table lists commands that help you manage the agent daemons in a terminal 
window. You must be logged in as root to start and stop the agents.

In addition, the agents respond properly to a standard Linux kill command.

Starting the Agents with a User Interface

The Post Office Agent, the Message Transfer Agent, and the Internet Agent can run with a user 
interface that provides information, status, and message statistics, as well as the ability to 
temporarily change some agent configuration settings. The WebAccess Agent can run so that it 
displays configuration and status messages in the terminal window. The Monitor Agent and the 

Task GroupWise Agents Messenger Agents

List the agent processes to see if 
they are running

ps -eaf | grep gw ps -eaf | grep nm

Start the agent daemons /etc/init.d/grpwise start
/etc/init.d/grpwise-ia start
/etc/init.d/grpwise-wa start
/etc/init.d/grpwise-ma start

/etc/init.d/novell-nmma start
/etc/init.d/novell-nmaa start

Stop the agent daemons /etc/init.d/grpwise stop
/etc/init.d/grpwise-ia stop
/etc/init.d/grpwise-wa stop
/etc/init.d/grpwise-ma stop

/etc/init.d/novell-nmma stop
/etc/init.d/novell-nmaa stop

Restart the agent daemons /etc/init.d/grpwise restart
/etc/init.d/grpwise-ia restart
/etc/init.d/grpwise-wa restart
/etc/init.d/grpwise-ma restart

/etc/init.d/novell-nmma restart
/etc/init.d/novell-nmaa restart
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Messenger agents cannot run with any type of user interface. Running the agents with a user 
interface can be useful for troubleshooting.
IMPORTANT: The X Windows System and OpenMotif* are required by the user interfaces for the GroupWise 
agents.

1 In a terminal window, become root by entering su and the root password.

2 Stop the agents if they are currently running as daemons.

3 Change to the /opt/novell/groupwise/agents/bin directory.

4 Use the following commands to start the agents with a user interface:

./gwpoa --show @../share/gwpo.poa &

./gwmta --show @../share/gwdom.mta &

./gwia --show @../share/gwia.cfg &

./gwinter --show @../share/webac65a.waa &

The interfaces for the Post Office Agent, the Message Transfer Agent, and the Internet Agent 
are very similar.

5 To stop an agent from its user interface, click File > Exit.

or

To stop the WebAccess Agent from its configuration and status window, close the window.

For information about using the agent console interfaces, see the following sections of the 
GroupWise 6.5 Administration Guide

! “Using the POA Agent Console”

! “Using the MTA Agent Console”

! “Monitoring the Internet Agent through the Server Console”

! “Monitoring the Linux WebAccess Agent”
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Monitoring the Agents from Your Web Browser

If you installed Monitor (see “Setting Up GroupWise E-Mail and Messenger” on page 21), you can 
monitor the GroupWise and Messenger agents from your Web browser by viewing the following 
URL:

http://server_address/gwmon/gwmonitor

By default, the Post Office Agent and the Message Transfer Agent are monitored. For information 
about configuring the Internet Agent and the WebAccess Agent to be monitored, see the following 
sections of the GroupWise 6.5 Administration Guide:

! “Monitoring the Internet Agent through the Web Console”

! “Monitoring the WebAccess Agent through the Web Console”

For information about configuring the Messenger agents to be monitored, see the following 
sections of the Messenger 1.0 Administration Guide:

! “Using the Messaging Agent Web Console”

! “Using the Archive Agent Web Console and GroupWise Monitor”

Maintaining Your GroupWise System

Depending on the importance and volume of e-mail generated by your users, a number of 
maintenance tasks might need to be performed to keep your GroupWise system running smoothly. 
The GroupWise 6.5 Administration Guide can help you learn to perform the tasks your system 
needs. 

The following table summarizes the most common tasks and where they are described:

Guide Section Task

System ! Using the GroupWise View in ConsoleOne

! Customizing the GroupWise Address Book

Domains ! Adding a domain

! Moving a domain

Post Offices ! Adding a post office

! Moving a post office

! Managing disk space usage
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Users ! Renaming users

! Moving users

Resources ! Creating schedulable resources for meeting rooms, company equipment, 
etc.

Distribution Lists, 
Groups, and 
Roles

! Creating public groups of e-mail users in addition to eDirectory groups

Libraries and 
Documents

! Creating a library to store and manage documents

! Importing documents into the library

Databases ! Repairing damaged databases

! Backing up databases

! Restoring databases and deleted messages

! Recovering deleted GroupWise accounts

Post Office Agent ! Monitoring and optimizing the Post Office Agent

! Scheduling database maintenance and disk space management

Message Transfer 
Agent

! Monitoring and optimizing the Message Transfer Agent

! Scheduling domain links

Internet Agent ! Monitoring and optimizing the Internet Agent

! Configuring SMTP/MIME services

! Configuring paging services

! Blocking unwanted e-mail

WebAccess ! Monitoring and optimizing the WebAccess Agent

! Customizing the WebAccess interface

! Creating Palm Query Applications for Palm OS devices

Monitor ! Monitoring all GroupWise and Messenger agents from a single Web page

! Generating reports about domain links, server environments, and 
message traffic

! Measuring agent performance

Client ! Supporting Caching mode and Remote mode for the GroupWise Windows 
client

! Enabling AutoUpdate of the GroupWise Windows client software

Security ! Supporting personal digital certificates, digital signatures, and S/MIME 
encryption

! Generating and installing server certificates for SSL encryption

Guide Section Task
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Maintaining Your Messenger System

Depending on the importance and volume of instant messages generated by your users, a number 
of maintenance tasks might need to be performed to keep your Messenger system running 
smoothly. The Messenger 1.0 Administration Guide can help you learn to perform the tasks your 
system needs. 

The following table summarizes the most common tasks and where they are described:

Specialized Installations
The GroupWise/Messenger Setup Wizard in YaST is the best way to set up your GroupWise 
system for most Small Business systems. This section provides additional information for those 
with multiserver Small Business systems and for resellers of the Novell Small Business Suite 9 
product.

! “Setting Up a Multiple Server System” on page 46

! “Using a Response File” on page 47

! “Using the Standard GroupWise Installation Advisor” on page 48

Setting Up a Multiple Server System
The GroupWise/Messenger Setup Wizard in YaST allows you to set up all or just some of the 
components of GroupWise and Messenger on your initial Small Business server.

Guide Section Task

Messaging Agent ! Monitoring and optimizing the Messaging Agent

Users ! Providing user searches based on e-mail addresses

! Setting user policies

Archiving ! Enabling archiving of instant messages

! Monitoring and optimizing the Archive Agent

! Searching the instant message archive
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By default, all components are installed together on the same server. However, if you anticipate a 
high volume of incoming and outgoing Internet e-mail, you might, for example, consider installing 
the Internet Agent on a different server from where the Post Office Agent is servicing GroupWise 
client requests. If you anticipate a high volume of instant messaging, you might consider installing 
your Messenger system on a different server from your GroupWise system.

You can run the GroupWise/Messenger Setup Wizard in YaST on any server where you want to 
install a GroupWise or Messenger component, keeping in mind the following:

! Select the Basic GroupWise System item only once. If you run it a second time on the same 
server, it deletes the existing GroupWise system and creates a new one. If you run it a second 
time on a different server, it creates a new, independent GroupWise system.

! Each domain needs only one Internet Agent and only one WebAccess Agent. If you choose to 
install either of these agents on a different server from where you set up your initial 
GroupWise system, you must provide a read/write file system mount from the server where 
they are installed to the domain directory.

! Your Messenger system is completely independent from your GroupWise system. If you 
install it on a different server, there are no dependencies to consider.

If you would prefer to use the standard GroupWise Installation Advisor to install on multiple 
servers, see “Using the Standard GroupWise Installation Advisor” on page 48.

Using a Response File
Resellers of Novell products install the Small Business Suite and set up GroupWise systems at 
numerous customer sites. To assist with this repetitive task, the GroupWise/Messenger Setup 
Wizard provides the option of saving GroupWise configuration information in a response file. That 
response file can then be used as input to the Silent Install script that sets up a standardized 
GroupWise system automatically, without user intervention during the process.

1 Run the GroupWise/Messenger Setup Wizard as described in “Setting Up GroupWise E-Mail 
and Messenger” on page 21 until you reach the Summary page.

2 If necessary, click Change to specify configuration settings that are different from the defaults 
provided by the GroupWise/Messenger Setup Wizard.

You might also choose to edit the response file after it has been created, as explained in Step 6 
below.
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3 Select Save Response File, and then click Finish to finish the GroupWise/Messenger setup 
process. 

By default, the response file is created in the following location:

/opt/novell/groupwise/software/gwinst.YaST2.cfg

4 If desired, change the location or filename in the Response File Path field, and then click 
Finish to create the response file.

The steps below elaborate on the instructions that appear in a warning dialog box when you 
click Finish.

5 Click Continue close the warning dialog box and create the response file.

When you create a response file, no GroupWise system is created on the server where you ran 
the GroupWise/Messenger Setup Wizard, nor is any other configuration performed. In this 
case, the response file is the only output from the wizard.

6 Print the response file to become familiar with its content.

The response file is an ASCII text file in .ini format. It contains a section for each item on the 
Select Items to Configure page of the GroupWise/Messenger Setup Wizard. You can use the 
response file with all sections in order to install all components on the target server or you can 
remove sections of the response file so that the removed components are not installed on the 
target server. 

Some fields in the response file must be edited to provide information specific to each 
customer site:

! eDirectory tree name

! Admin user context of the 

! Admin user password

! Server IP address where the Small Business Suite is installed

! Customer time zone

You might want to edit other fields to customize the GroupWise system for the customer:

! GroupWise system name

! Domain name

! Post office name

! GroupWise eDirectory object context

7 Edit the response file as needed for the customer site where you plan to use the Silent Install 
script to set up the GroupWise system.

8 Copy the response file from the software distribution directory to whatever medium you use 
to bring data with you to the customer site.

9 At the customer site, install Novell Small Business Suite 9 and run the eDirectory Setup 
Wizard.

10 Copy the response file to /opt/novell/groupwise/software, and then change to that directory.

11 As root, run the silent-install script.

Syntax:
./silent-install -r response_file -p admin_password -s status_file
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Example:
./silent-install -r gwinst.YaST2.cfg -p palmtree -s gwinst.log

If you do not use the -s option, status information is displayed on the screen but is not written 
to a log file.

12 When the Silent Install script finishes, continue setting up the Small Business server as 
needed.

Using the Standard GroupWise Installation Advisor
If you would prefer to run the standard GroupWise Installation Advisor rather than the GroupWise/
Messenger Setup Wizard, you can use YaST to set up a GroupWise software distribution directory 
where a standard GroupWise installation can be performed from.

1 In the YaST Control Center, click Software > Install and Remove Software.

2 In the Filter field, select Search.

3 In the Search field, type groupwise, and then click Search.

4 Select GroupWise Software Distribution Directory, and then click Accept.

5 After YaST has set up the GroupWise software distribution directory, open a terminal window.

6 Become root by entering su and the root password.

7 Use the following command to start the GroupWise Installation Advisor:

/opt/novell/groupwise/software/install
8 Follow the instructions in “Installing a Basic GroupWise System” in the GroupWise 6.5 

Administration Guide to install and set up GroupWise.

For your convenience, the Messenger software is also included in the GroupWise Software 
Distribution Directory RPM. After that RPM has been installed, you can start the standard 
Messenger Installation program using the following command:

/opt/novell/messenger/software/server/install.sh
Then follow the instructions in “Installing a Novell Messenger System” in the Messenger 1.0 
Installation Guide to install and set up Messenger.
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4 Network Printing

Novell® Linux Small Business Suite 9 (NLSBS9) software lets your users share printers on the 
network through Common UNIX* Printing Services (CUPS), an open source print server solution. 
Although lprng and lpdfilter packages will continue to be supported, CUPS offers these 
advantages:

! Setting individual parameters on the user level

! Optimum support for PostScript* printers

! Browsing in the network

! Web front-end (on the user level and for administration)

This chapter guides you through the steps to set up a basic CUPS print server to service the print 
jobs on the network and provides instructions for printing from Linux and Windows workstations. 
After completing these steps, your network users can send their print jobs to server-attached 
printers.

For more information on printing in a Linux environment, see “Printer Operation” in the SUSE 
LINUX Enterprise Server Administration and Installation guide  (http://www.novell.com/
documentation/sles9/index.html).

Setting Up the Print Server
Setting up a print server requires you to create a CUPS password for the root user and then 
configure CUPS on the computer.

Creating a CUPS Password for Root
The CUPS printing software comes installed in SUSE® LINUX Enterprise Server 9 (SLES 9) and 
is a simple way to share printers with workstations. You set up a print server through CUPS from 
a browser after creating a password for the root user.
NOTE: CUPS supports fundamental LPD functionality, both on the recipient side by means of the cups-lpd 
and on the sender side by means of the lpd back-end. CUPS does not, however, support full LPRng 
functionality.

Follow these steps to create a password for the root user from your SLES 9 desktop: 

1 Click the Shell icon to open the Shell Konsole.

2 At the prompt, type lppasswd -a root and press Enter. 
You are prompted to enter a password.

3 Enter your password, then re-enter it when prompted.
 It must contain at least six characters and one number.
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Once you’ve created your admin user and password, you may exit the Shell Konsole and open a 
Web browser.

Configuring CUPS Print Server
1 In your browser, go to http://localhost:631. The CUPS administration screen appears.

2 Log into the CUPS Web site.

3 Click Manage Printers to open the Printer screen.
TIP: Don’t confuse the  Manage Printers link with the link Manage Printer Classes link. 

4 On the Manage Printers page, click Add Printer. 
An authentication dialog will opens. 

5 Enter the admin name and password you created. 
Once you have authenticated, the Add Printer page opens.

6 Type in a name, location, and description of the printer, then click Continue. 
The Device for Storage page opens.

7 Select the appropriate device from the dropdown list, then click Continue. 
The Printer URI page opens.

8 Type the appropriate hostname for your printer and port, then click Continue. The Model/
Driver for Storage page opens.

9 Select the appropriate printer driver for the printer you have attached, then click Continue to 
finish setting up your printer. 
Consult your printer manual for information on your printers’ makes, models, etc.

What’s Next
After you have set up a print server with CUPS, you can now print from any workstation on the 
network. See the next step, “Printing from Linux and Windows Workstations” on page 50 for more 
information.

Printing from Linux and Windows Workstations
You can print to any network printer from Windows or Linux workstations.

Printing from a Novell Linux Desktop
1 In YaST, click Hardware > Printer.

2 In the Printer Configuration window, select Other Not Detected and click Configure.

3 Select Print Directly to a Network Printer, then click Next. 

4 In the Connection Type window, select Direct TCP Port Printing and click Next.

IMPORTANT: The network printer you connect to must have a NIC card; otherwise, select Remote IPP 
Queue.

5 In the IPP printer window, specify your connection information, and then click Next. 

5a Type in the hostname of the print server; If you don’t know it, click Lookup to check for 
available socket servers.
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5b Click Test Remote Socket Access to check the accessibility of the print server.

6 In the Queue Name window, set up your printer and then click Next.

6a Check the name and location of the printer. 

6b Select  the Do Local Filtering option.

6c Test the printer by clicking on Test Printing.

7 In the Printer Model window, select the make and model of printer you want to connect to, 
and then click Next.

8 In the Printer Configuration window, edit the elements of your printer configuration if desired, 
and click OK. 
The newly selected print server appears in the lower pane with the words Changed, Not Yet 
Saved after it.

9 Click Finish to save the new print server configuration.

Printing from a Windows Workstation
You can print from Windows workstations via Samba, an open source implementation of 
SMB. The name Samba is derived from the initials SMB, or Server Message Block, a 
message format used by DOS and Windows to share files, directories, and devices.

Samba is a file sharing protocol that provides file and print services to SMB/CIFS clients. It allows 
a non-Windows server to communicate with the same networking protocol as the Windows 
products. Samba was originally developed for UNIX but also runs on Linux and other UNIX 
variants.

To print to a Linux printer from a Windows workstation, follow the normal Windows printing 
steps:

1 Click the Start button in the lower left of your Windows screen.

2 Click Printers and Faxes. 
If Samba is configured correctly on your server, all printers will appear in the window and all 
Windows functions are available to the Linux printers.

For more information on setting up Samba for your Windows workstations, see Samba (http://
www.novell.com/documentation/oes/index.html?page=/documentation/oes/sles_admin/data/sec-
samba.html) in the Heterogenous Networks chapter of the Novell Open Enterprise Server online 
documentation.
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5 Web Server Publishing

Web sites perform different functions. Some are simple collections of HTML pages that contain 
static information, such as company background information. Some are more dynamic, creating 
information as it is requested from a user or another computer. Building dynamic Web sites 
involves the use of servlets or Web applications, and might also involve databases (such as 
MySQL) and scripting languages (such as PHP or Perl). 

Web sites where products or services are bought or sold are examples of dynamic Web sites. Other 
dynamic Web sites are not seen by users, but are used as part of a supply chain process between 
businesses.

For more information on the Apache Web server, visit the Apache Web site (http://
httpd.apache.org/docs-2.0/).

NLSBS 9 Web Server—Novell Apache
The Novell® Linux Small Business Suite 9 (NLSBS9) home page and various GroupWise® and 
iManager Web pages use Novell-Apache. It is installed by both GroupWise and iManager YaST 
wizards using the Novell-web-sdd package. 
TIP: Novell-Apache and Apache2 are not compatible, and compete for the default HTTP port 80. If you would 
like to install Apache2, use a separate server.

Although it looks as though it has overrun your Web server, NLSBS 9 has merely rearranged some 
key files. Once you know the new names and locations of the files that you’re already familiar 
with, administrating your NLSBS 9 Web server is much the same as your NetWare servers. 

Three key elements now have new names and locations:

! Config files are now located at /var/opt/novell/http/

! Doc root is now located at /var/opt/novell/httpd/htdocs

! Startup Daemon in now located at /etc/init.d/novell-http

Tomcat files also have new names and locations:

! Tomcat is now located at /etc/opt/novell/tomcat4

! Root files are now located at /var/opt/novell/tomcat4

! The startup daemon is novell-tomcat4

Startup names have changed to Novell.httpd.

Your NLSBS 9 Web Site 
The Novell Linux Small Business Suite provides a Web page with useful links for your small 
business. If you would rather use your own design, you can copy it over the Novell index file.
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To replace the NLSBS 9 Web page with your own:

1 Locate the NLSBS 9 Web page at /var/opt/novell/httpd/htdocs/Index.html.

2 Copy your small business’ home page over the index.html file.

3 Use the Restart command to stop and restart Apache:
/etc/init.d/novell-http restart.  

What’s Next
Using the NLSBS9 structure, you’re ready to adapt your Web server to your specific needs. 
Although the main purpose of having a Web server is to host a Web site, you can also use Apache 
as the HTTP server in a partnership with an application server, such as the Novell® exteNdTM 
Application Server.
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