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About This Guide

This ZENworks Configuration Management Policy Management Reference includes information
about Policy Management features and procedures to help you configure and maintain your Novell
ZENworks Configuration Management system.

For information on policies that control a range of security-related functionalities for Windows
devices or help protect and configure the ZENworks Endpoint Security Agent, see the ZENworks
Endpoint Security Policies Reference.

For information on policies supplied by ZENworks Full Disk Encryption that are used to encrypt entire
disks (or volumes) for Windows devices, see the ZENworks Full Disk Encryption Policy Reference.

The information in this guide is organized as follows:

+ Chapter 1, “Overview,” on page 9

¢ Chapter 2, “Creating Linux Configuration Policies,” on page 15

+ Chapter 3, “Creating Windows Configuration Policies,” on page 21
¢ Chapter 4, “Creating Mobile Device Policies,” on page 55

+ Chapter 5, “Managing Policies,” on page 57

+ Chapter 6, “Managing Policy Groups,” on page 91

¢ Chapter 7, “Managing Folders,” on page 95

+ Appendix A, “Troubleshooting Policy Management,” on page 97
+ Appendix B, “Best Practices,” on page 137

+ Appendix C, “iPrint Policy Management Utility,” on page 139

+ Appendix D, “Documentation Updates,” on page 151

Audience

This guide is intended for Novell ZENworks administrators.

Feedback

We want to hear your comments and suggestions about this manual and the other documentation
included with this product. Please use the User Comments feature at the bottom of each page of the
online documentation.

Additional Documentation

ZENworks Configuration Management is supported by other documentation (in both PDF and HTML
formats) that you can use to learn about and implement the product. For additional documentation,
see the ZENworks documentation Web site (http://www.novell.com/documentation/
zenworks2017).

About This Guide
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1.1

1.2

Overview

ZENworks Configuration Management provides policies to configure operating system settings and
select application settings. By applying a policy to multiple devices, you can ensure that all of the
devices have the same configuration.

The following sections contain additional information:

*

Section 1.1, “What Is a Policy?,” on page 9

*

Section 1.2, “What Is a Policy Group?,” on page 9

*

Section 1.3, “Understanding the Policy Types,” on page 10

*

Section 1.4, “Understanding the Features of a Policy,” on page 11

What Is a Policy?

A policy is a rule that controls a range of hardware and software configuration settings on the
managed devices. For example, an administrator can create policies to control browser bookmarks
available in the browser, printers to access, and security and system configuration settings on the
managed devices.

You can use the policies to create a set of configurations that can be assigned to any number of
managed devices. It helps you to provide the devices with a uniform configuration, and it eliminates
the need to configure each device separately.

You can assign a policy directly to a device or a user. You can also assign the policy to a folder or
group where the user or device is a member. Assigning a policy to device groups rather than device
folders is the preferred way, because a device can be a member of multiple device groups, but it can
be a member of only one device folder.

On managed devices, each policy type is enforced by a Policy Handler or Enforcer, which makes all
the configuration changes necessary to enforce or unenforce the settings in a given policy.

What Is a Policy Group?

A policy group is a collection of one or more policies. Creating policy groups eases the administration
efforts in managing policies. You can create policy groups and assign them to managed devices the
same way you would assign individual policies.

Because the policy inherits the group’s assignments, managing a policy group is easier than
managing individual policies. For example, if multiple policies are included in a policy group and the
policy group is assigned to a device or a device group, then all the policies included in the policy
group are automatically assigned to the device or device group at the same time. You need not
individually assign each policy to a device or a device group.

Overview



1.3 Understanding the Policy Types

ZENworks lets you create the following policy types:

+ Linux Configuration Policies: Lets you configure policies supplied by ZENworks Configuration
Management that are used to manage configuration settings for Linux devices. The following
policies are located in this category:

+ External Services policy
+ Puppet policy

+ Windows Configuration Policies: Lets you configure policies supplied by ZENworks
Configuration Management that are used to manage configuration settings for Windows
devices. The following policies are located in this category:

+ Browser Bookmarks policy

+ Dynamic Local User policy

+ Local File Rights policy

+ Power Management policy

+ Printer policy

+ Remote Management policy

+ Roaming Profile policy

+ SNMP policy

+ Windows Group policy

¢ ZENworks Explorer Configuration policy

+ Windows Endpoint Security Policies: Lets you configure policies supplied by ZENworks
Endpoint Security Management that are used to manage security settings for Windows devices.
The following policies are located in this category:

+ Application Control policy

¢ Communication Hardware policy
+ Data Encryption policy

+ Firewall policy

+ Location Assignment policy

+ Microsoft Data Encryption policy
¢ Scripting policy

+ Security Settings policy

+ Storage Device Control policy

+ USB Connectivity policy

+ VPN Enforcement policy

+ Wireless policy

The Windows Endpoint Security policies are not covered in this guide. For information about
these policies, see the ZENworks Endpoint Security Policies Reference.
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+ Windows Full Disk Encryption Policies: Lets you configure policies supplied by ZENworks Full
Disk Encryption that are used to encrypt entire disks (or volumes) for Windows devices. The
following policy is located in this category:

+ Full Disk Encryption policy

The Windows Full Disk Encryption policies are not covered in this guide. For information about
these policies, see the ZENworks Full Disk Encryption Policy Reference.

+ Mobile Device Policies Lets you configure policies supplied by ZENworks Configuration
Management that are used to manage security settings for Mobile Devices. The following
policies are located in this category:

Android

+ Android Enterprise Enrollment Policy
General Mobile Policies

+ Device Control Policy

+ Device Enrollment Policy

+ Mobile Email Policy

+ Mobile Security Policy
ioS

+ iOS Intune App Protection Policy

For more information about these policies, see the ZENworks 2017 Mobile Management
Reference guide.

1.4 Understanding the Features of a Policy

+ A policy is applied to a device or a user only if the policy is directly or indirectly associated to
that device or user.

The Browser Bookmarks policy, Dynamic Local User policy, Printer policy, Remote Management
policy, Windows Group policy, and ZENworks Explorer Configuration policy can be applied to a
device or a user:

The Local File Rights and SNMP policies can be applied only to a device.

The Roaming Profile policy can be applied only to a user.
+ A policy can be associated to groups and containers.

In ZENworks Control Center, devices and users can be organized by using containers and groups.
A device or user can be a member of multiple groups. The containers can be nested within
other containers. If a policy is associated to a group of users, it applies to all users in that group.
If a policy is associated to a user container, it applies to all users in the entire subtree rooted at
that container. The same behavior applies to device groups and containers.

+ A policy can be associated to query groups.

In ZENworks Control Center, the devices can also be members of query groups. Query groups
are similar to ordinary groups except that the membership is determined by a query defined by
the administrator. All devices that satisfy the query become members of that device group. The
query is evaluated periodically and the membership is updated with the results. An

Overview 11
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administrator can configure the periodicity of the evaluation. An administrator can also force an
immediate refresh of a query group. Query groups act just like other groups where policies are
concerned.

Policies are chronologically ordered by default.

When multiple policies are associated to a device, user, group, or container, the associations are
chronologically ordered by default. The administrator can change the ordering.

If a device or user belongs to multiple groups, the groups are ordered. Consequently, the
policies associated to those groups are also ordered. The administrator can change the ordering
of groups for a device or user at any time.

In addition, the policies in a policy group are ordered.

Policies have a precedence configured to determine the policy that is effective for a device or a
user.

Many policies of the same type can be applied to a user or a device through direct association
and inheritance. For example, if a Browser Bookmark policy is associated to a user and another
Browser Bookmark policy is associated to a container containing that user, the policy directly
associated to that user overrides the policy associated to the container.

Policies support management by exception.

You can define a global policy for your enterprise and associate it to the top-level container
containing all your user objects. You can then override configuration items in the global policy
by defining a new policy and associating it to specific users or user groups. These users receive
their configuration from the new policy. All other users receive their configuration from the
global policy.

Policies support system requirements.

You can specify the system requirements of a device or user in a policy. The policy is applied to a
device or user only if the device or user meets the system requirements.

For example, the SNMP policy is applied by default on all devices having the SNMP service
installed.

ZENworks Configuration Management supports singular and plural policies.

Singular Policy: If multiple policies of the same policy type are assigned to a device or a user
and the policy type is a Singular policy, then only the nearest associated policy meeting the
system requirements is applied. If the policy type is associated to both user and device, then
two different policies can be assigned to user and device.

The SNMP policy, Dynamic Local User policy, Remote Management policy, Roaming Profile
policy, Power Management policy, and ZENworks Explorer Configuration policy are singular
policies.

Plural Policy: If multiple policies of the same policy type are assigned to a device or a user and
the policy type is a Plural type, then all policies meeting the associated system requirement are
applied.

The Browser Bookmarks policy, Local File Rights policy, Windows Group policy, and Printer
policy are plural policies. However, the security settings in the Windows Group policy are not
plural.

Policies can be disabled.

When you create a policy in ZENworks Configuration Management, the policy is enabled by
default. You can disable it if you do not want to apply it on a user or a device.



+ ZENworks Configuration Management allows you to resolve policy conflicts.

The set of effective policies is a subset of the set of assigned policies. The set of effective
policies for a device or user is calculated by applying precedence rules, multiplicity rules, and
system requirements filters on the set of assigned policies. Effective policies are calculated
separately for devices and users. The Policy Conflict Resolution setting determines how user
and device policies interact for a specific user and device combination.

Effective policies are calculated separately for devices and users. When a user logs in to a
device, policies associated to both the user and the device must be applied. Policy Conflict
Resolution settings are used only when policies of the same type are associated to both the
device and the user. This setting determines the precedence order among the policies
associated to the user and those associated to the device. The Policy Conflict Resolution
settings are applied after the effective policies are calculated.

Policy Conflict Resolution settings are defined when associating a policy to a device. The
settings cannot be defined for associations to users. For each policy type, the Policy Conflict
Resolution setting defined in the closest effective policy of that type is applied for all policies of
that type.

A Policy Resolution Conflict setting can have one of the following values:

+ User Precedence: User-associated policy will override the device-associated policy. Select
this option to apply policies that are associated to the users first, and then to the devices.

+ Device Precedence: Device-associated policy will override the user-associated policy.
Select this option to apply policies that are associated to the devices first, and then to the
users.

+ User Only: Applies only the policies associated to the user and ignores the policies
associated to the device.

+ Device Only: Applies only the policies associated to the device and ignore the policies
associated to the user.

NOTE: The Policy Conflict Resolution setting is taken from the device-associated policy with the
highest precedence.
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2.1

Creating Linux Configuration Policies

Novell ZENworks Configuration Management lets you create policies by using ZENworks Control
Center or by using the zman command line utility.

The following sections contain step-by-step instructions about creating the Linux configuration
policies by using ZENworks Control Center.
+ Section 2.1, “External Services Policy,” on page 15

+ Section 2.2, “Puppet Policy,” on page 17

External Services Policy

The External Services policy lets you configure the external services on a Linux managed device for
YUM, ZYPP or MOUNT repositories. It enables you to download and install the software packages or
updates from these repositories on the managed devices.
1 In ZENworks Control Center, click the Policies tab.
2 Inthe Policies list, click New, then click Policy.
or
In the Policy Tasks, click New Policy.
The Select Platform page is displayed.
3 Select Linux, then click Next.
The Select Policy Category page is displayed.
4 Select Linux Configuration Policies, then click Next.
5 Select External Services Policy as the Policy Type, then click Next.
6 In the Define Details page fill in the following fields:

Policy Name: Provide a name for the policy. The policy name must be different from the name
of any other item (group, folder, and so forth) that resides in the same folder. The name you
provide displays in ZENworks Control Center.

Folder: Type the name or browse to and select the ZENworks Control Center folder where you
want the policy to reside. The defaultis / Pol i ci es, but you can create additional folders to
organize your policies.

Administrator Notes: Provide a short description of the policy’s content. This description
displays in ZENworks Control Center.

7 Click Next to display the External Services Policy page.
8 In the External Services Policy page, click Add to display the External Services Policy dialog box.

9 The following table lists the tasks you can perform in the External Services policy dialog box.

Creating Linux Configuration Policies 15



Task Steps Additional Details

Add an External 1. Click Add to display the External Services The available repository types
Service Policy dialog box. are AUTO, ZYPP, YUM, and
MOUNT.

2. Specify the name of the service, the URL
for the service, and the type of repository
to which you want to add the service.
Click Help for information on how to fill

AUTO is a default repository
type, if selected, the system
automatically detects either
the required fields. ZYPP or YUM as the type of
3. Select the checkbox Recursive to add repository.
services on the managed device for the
Romps present under all the
subdirectories of the specified URL. The
recursive property is applicable only to
the MOUNT service type.

The credential option is not
applicable to the MOUNT
service type.

4. For External Services that require

authentication, click |&] to browse to and
select an existing credential from the
Credential Vault.

5. Select the check box Synchronize with
External Package Management Tools, to
synchronizes the External Services with
the package management tools.

6. Click OK.
Edit an External 1. Select the External Service you wantto  The service name and recursive
Service edit, then click Edit. property once specified cannot

be edited. To edit these options

2. Follow the online prompts to make T .
for the existing service, remove

changes. i
. the service and add a new
3. Click OK. External Service.
Remove an External 1. Select one or more External Services that
Service you want to remove, then click Remove.

10 Review the information on the Summary page and, if necessary, use the Back button to make
changes to the information on the Summary page.

11 (Conditional) Select Create as Sandboyx, if you want to create the sandbox version of the policy.
12 Select the check box for Define Additional Properties.
13 Click Finish to create the new External Services policy.

14 Click Relationships and assign the newly created External Services policy to a test device and a
non-test device.

NOTE

If you disable the Bundle Management module, services that are a part of the External Services
policy do not flow down to the agent.
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2.2 Puppet Policy

The Puppet policy lets you apply the Linux configuration on the Linux devices.

1 In ZENworks Control Center, click the Policies tab.
2 In the Policies list, click New, then click Policy.
or
In the Policy Tasks, click New Policy.
The Select Platform page is displayed.
3 Select Linux, then click Next.
The Select Policy Category page is displayed.
4 Select Linux Configuration Policies, then click Next.
5 Select Puppet Policy as the Policy Type, then click Next.
6 In the Define Details page fill in the following fields:

Policy Name: Provide a name for the policy. The policy name must be different from the name
of any other item (group, folder, and so forth) that resides in the same folder. The name you
provide displays in ZENworks Control Center.

Folder: Type the name or browse for and select the ZENworks Control Center folder where you
want the policy to reside. The defaultis / Pol i ci es, but you can create additional folders to
organize your policies.

Administrator Notes: Provide a short description of the policy’s content. This description
displays in ZENworks Control Center.

7 Click Next to display the Puppet Policy page. You can create a puppet policy to run scripts as
either Manifest or Module.

The following options lets you run puppet scripts on a managed device, upload the script file,
and specify if a dry run on the script should be performed.

+ Run Script As: You can create a policy to run script as either Manifest or Module.

+ FileName: Depending on your selection to run the script as Manifest or Module, browse for
and upload the script file in the following formats:

Manifest: Upload a . pp file.
Module: Uploada.zip, .tar, .tar.gz, .tar.bz2, .tgz, or .tbhz2 file.

NOTE: After creating either Manifest or Module on a Windows operating system, run the
dos2uni x command on the puppet script file, to avoid parsing errors on the managed
device.

+ Dry Run: Select this option to have ZENworks Configuration Management perform a test to
determine if the Puppet policy can be successfully enforced on a managed device.

If there are any issues that could prevent the policy from being enforced, you can view the
issues in the log file created to troubleshoot the policy creation process. The log file is
located at/ var/ opt/ novel | /| og/ zenwor ks/ puppet . | 0g. A successful dry run
ensures that the policy can be successfully enforced on the managed device.

+ Advanced Options: Select this option to specify the Puppet Command Options.

Creating Linux Configuration Policies 17



18

The Run Puppet Command As field displays the puppet command that will be run on the
managed device. The command consists of the following two parts:

Part 1:
Includes the non-editable part of the command as follow:
[ opt/ novel | / zenwor ks/ bi n/ puppet scri pt_nane --noop

[ opt/ novel | / zenwor ks/ bi n/ puppet is the portion of the command that is displayed
by default. Based on your choice to run the script as a manifest or a module, the
script_name parameter is replaced by the name of the manifest file or the module name. If
the Dry Run option is enabled, then --noop string gets appended to the command.

Part 2:

Includes the editable part of the command. The following portion of the command is
displayed by default:

-dv --detail ed-exitcodes --confdir /etc/opt/novell/zenworks/puppet
-1 /var/opt/novel | /1 og/ zenwor ks/ puppet. | og

For information on the parameters used in the command, see the following table:

Parameter Description

d Enables full debugging.

v Prints extra information.

detailed-exitcodes Provides transaction information through exit
codes.

[ Creates a log file.

log_file_path Path of the log file, the default path is
[ var/opt/novel | /| og/ zenwor ks/
puppet . | og.

--confdir Is the Puppet Configuration Directory.

You can choose to edit this portion of the command as in the following examples.
Example 1:

The default log path is / var / opt / novel | / | og/ zenwor ks/ puppet . | og. However, you
can choose to specify a different log file such as a /tmp/puppet.log using the following
command.

/ opt/ novel | / zenwor ks/ bi n/ puppet script_name --noop -dv --detail ed-
exit codes --confdir /etc/opt/novell/zenworks/puppet -1 /tnp/
puppet. | og

Example 2:

The default puppet configuration file is / et ¢/ opt / novel | / zenwor ks/ puppet /
puppet . conf . However, you can choose to specify a different configuration file as follows:

Creating Linux Configuration Policies
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[ opt/ novel | / zenwor ks/ bi n/ puppet script_name --noop --config=/tnp/
nypuppet.conf -1 /tnp/puppet.|og

The availability of the supported parameters is dependent on the version of the puppet installed
on the managed device.

Review the information on the Summary page and, if necessary, use the Back button to make
changes to the information on the Summary page. In the Summary page the Module file
content displays the list of files that are packaged as either Module or Manifest.

(Conditional) Select Create as Sandbox, if you want to create the sandbox version of the policy.

Select the check box for Define Additional Properties.
Click Finish to create the new Puppet policy.

Click Relationships and assign the newly created Puppet policy to a test device and a non-test
device.

Creating Linux Configuration Policies
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3.1

Creating Windows Configuration Policies

ZENworks Configuration Management lets you create policies by using ZENworks Control Center or
by using the zman command line utility.

The following sections contain step-by-step instructions about creating the Windows Configuration
policies by using ZENworks Control Center:

+ Section 3.1, “Browser Bookmarks Policy,” on page 21

+ Section 3.2, “Dynamic Local User Policy,” on page 23

+ Section 3.3, “Local File Rights Policy,” on page 29

+ Section 3.4, “Power Management Policy,” on page 31

+ Section 3.5, “Printer Policy,” on page 33

+ Section 3.6, “Remote Management Policy,” on page 40

+ Section 3.7, “Roaming Profile Policy,” on page 40

+ Section 3.8, “SNMP Policy,” on page 41

+ Section 3.9, “Windows Group Policy,” on page 43

+ Section 3.10, “ZENworks Explorer Configuration Policy,” on page 46

¢ Section 3.11, “Creating ZENworks Branding Policy,” on page 48

NOTE: A Dynamic Local User (DLU) policy, Windows Group policy, and Roaming Profile policy cannot
be used on a device that has Citrix XenApp 6.5, Citrix XenDesktop, or VMware VDI installed because
Novell client login is not involved when it is launched.

The following section explains how to create policies by using the zman command line utility:

+ Section 3.12, “Creating Policies by Using the zman Command Line Utility,” on page 49

Browser Bookmarks Policy

The Browser Bookmarks policy lets you configure Internet Explorer favorites for Windows devices
and users.
1 In ZENworks Control Center, click the Policies tab.
2 In the Policies list, click New, then click Policy.
or
In the Policy Tasks, click New Policy.
The Select Platform page is displayed.
3 Select Windows, then click Next.
The Select Policy Category page is displayed.

4 Select Windows Configuration Policies, then click Next.
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5 Select Browser Bookmarks Policy as the Policy Type, then click Next

6 In the Define Details page fill in the following fields:

Policy Name: Provide a name for the policy. The policy name must be different than the name
of any other item (group, folder, and so forth) that resides in the same folder. The name you
provide displays in ZENworks Control Center.

Folder: Type the name or browse to and select the ZENworks Control Center folder where you
want the policy to reside. The default is / pol i ci es, but you can create additional folders to
organize your policies.

Administrator Notes: Provide a short description of the policy’s content. This description
displays in ZENworks Control Center.

Click Next to display the Bookmarks Tree Data Source page.

Create a browser bookmarks tree by importing a previously exported file or manually entering
the data. Before you import a book marks file ensure that it is in UTF-8 format. To manually
convert the bookmark file into UTF-8 format, use a text editor

The following list contains browser-specific information to create the exported file:

+ Internet Explorer 8.x/9.x: In the browser window, click File > Import and Export. Follow the
instructions given in the Import/Export Wizard to create t he bookmar k. ht mfile.

+ Mozilla Firefox 3.x: In the browser window, click Bookmarks > Organize Bookmarks, then
click Import and Backup > Export HTML to createt he bookmar ks. ht ni file.

+ Mozilla Firefox 4.x to 10.x: In the browser window, click Bookmarks > Show All Bookmarks
to open the library. From the toolbar on the library, click Import and Backup > Export
Bookmarks to HTML to create t he bookmar ks. ht nl file.

Click Next to display the Bookmarks Tree Configuration page, then use the options to configure
the bookmarks tree.

The following table lists the tasks you can perform with the New, Edit, and Delete options.

Field Details

New ¢ Click New > Folder to display the Add Folder to Bookmarks dialog box, through which
you can add a new folder to the bookmarks tree.

¢ Click New > Bookmark to display the Add Bookmark to Bookmarks dialog box,
through which you can add a new bookmark to the bookmarks tree by specifying the
bookmark name and a URL. Click the button next to the URL field to verify that the
URL entered by you is correct and functional.

Edit ¢ Select the bookmark name you want to change, click Edit > Rename, then specify a
new name.
+ Click Edit > Sort to organize the bookmarks in ascending or descending order.

¢ Click Edit > Move Up, Move Down, or Move To to relocate a bookmark.

+ Click Edit > Select All Children > to select all the subdirectories and bookmarks of the
selected parent directory.

* Click Edit > Deselect All Children > to deselect all the subdirectories and bookmarks
of the selected parent directory.

* Click Edit > Clear Selection > to clear the selections.
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Field Details

Delete * Click Delete to delete the selected bookmarks and the bookmarks folder from the
bookmarks tree. However, you cannot delete the default bookmarks folder named
Booknmar ks.

10 Review the information on the Summary page and, if necessary, use the Back button to make
changes to the information on the Summary page.

11 (Conditional) Select Create as Sandboyx, if you want to create the sandbox version of the policy.

12 Click Finish to create the policy now, or select Define Additional Properties to specify additional
information, such as policy assignment, system requirements, enforcement, status, and which
group the policy is a member of.

Dynamic Local User Policy

The Dynamic Local User policy lets you create new users and manage existing users on the managed
device after they have successfully authenticated to user source.

NOTE:

+ |tis recommended that you install the latest version of the Novell Client on the managed device
before the Dynamic Local User policy is enforced. To obtain the latest version of Novell Client,
see the Novell Download Web site (http://download.novell.com/index.jsp).

+ To implement the Dynamic Local User policy without the Novell Client, see Section 3.2.3,
“Implementing the Dynamic Local User Policy Without the Novell Client,” on page 28.

+ Dynamic Local User policy is not supported for Domain Services for Windows (DSfW) users.

1 In ZENworks Control Center, click the Policies tab.
2 In the Policies list, click New, then click Policy.
or
In the Policy Tasks, click New Policy.
The Select Platform page is displayed.
3 Select Windows, then click Next.
The Select Policy Category page is displayed.
4 Select Windows Configuration Policies, then click Next.
5 Select Dynamic Local User Policy as the Policy Type, click Next.
6 In the Define Details page fill in the following fields:

Policy Name: Provide a name for the policy. The policy name must be different than the name
of any other item (group, folder, and so forth) that resides in the same folder. The name you
provide displays in ZENworks Control Center.

Folder: Type the name or browse to the ZENworks Control Center folder where you want the
policy to reside. The default is/ pol i ci es, but you can create additional folders to organize
your policies.
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Administrator Notes: Provide a short description of the policy’s content. This description
displays in ZENworks Control Center.

Click Next to display the User Configurations page, then use the options on the page to
configure the user account.

The following table contains information about configuring dynamic local user accounts and
managing them on managed devices:

Field

Details

Use User Source
Credentials

Use the Credentials
Specified Below (Always
volatile)

Manage Existing User
Account (if any)

Volatile User

Enables logging in through the user source credentials instead of the
Windows Operating System credentials.

If you do not select Use User Source Credentials, the user account that is
created is always volatile and is not accessible. This setting allows you to
specify the following user credentials for a volatile user:

+ User Name: Specify the user’s name.
+ Full Name: Specify the user’s complete name.

+ Description: Provide any additional information that helps the
administrator to further identify this user account.

+ Use User Source Password: Select this option to create the account
with the password configured in the user source. Ensure that you
enable the setting Manage Existing User Account (if any). If both
settings are enabled, a user who has logged into the workstation at
least once, can login locally on the workstation and access it even in
case of network logon failure.

If a user logs in to a device that has the Dynamic Local User policy applied
and then logs out of the device when the device is disconnected from the
network, the user is unable to log in to the disconnected device again. For
information on this issue, see “Dynamic Local User Policy Troubleshooting”
on page 101.

Helps you to manage a user object that already exists.

If you select both the Volatile User and the Manage Existing User Account
(If Any) check boxes, and the user has a permanent local account that uses
the same username specified in the user source, the permanent account is
changed to a volatile (temporary) account and is removed when the user
logs out.

If a local user object already exists with a DLU user name, any changes to the
DLU user name cannot be applied on the policy unless you enable Manage
Existing User Account (if any). This setting must be enabled for the following
scenarios to work:

+ Manually changing the user password.
¢ Changing the user e-directory password.

* Applying updated settings if the local user account is present on the
device.

Specifies the use of a volatile user account for login. The user account that
NWGINA creates on the local workstation can be either a volatile or a
nonvolatile account.
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Field Details

Enable Volatile User Enables the caching of the volatile user account on the device for a specified
Cache period of time.

If the Enable Volatile User Cache setting is set in disconnected mode, the
following are possible:

+ On adevice that has Novell Client installed, the last logged in user can
log in to the system locally.

+ If you have enabled ZENworks GINA to use DLU without the Novell
Client, then any previously logged in cached user can log in to the
system locally.

Cache Volatile User for Allows you to specify the number of days to cache the volatile user account
Time Period (Days) on the device. The default value is 5. You can specify a value from 1 to 999
days.

This volatile user account is deleted after the expiry of the specified cache
period when another DLU user logs out from the device.

Not a Member Of Displays the available group to which a user can be assigned as a member.
Member Of Displays groups a user is member of.
Custom Click Custom to display the Custom Group Properties dialog box, through

which you can add a new custom group and configure its rights.

Edit Click Edit to view and edit the details of a custom group. You cannot edit the
default Windows groups with this option.

Delete Click Delete to delete a custom group. You cannot delete the default
Windows groups with this option.

Click Next to display the Login Restrictions page, then fill in the fields to configure user access:

¢ Included / Excluded Users: Lists the users and containers that you want to include or
exclude access to. For more information, see “Rules for Users” on page 27.

+ Included / Excluded Workstations: Lists the workstations and containers that you want to
include or exclude access to. For more information, see “Rules for Workstations” on
page 26.

The Excluded Workstations List displays the workstations and containers that you want to
exclude DLU access to. Workstations listed or workstations that are in the containers listed here
cannot use DLU access. You can make exceptions for individual workstations by listing them in
the Included Workstations List. This allows DLU access to those workstations only, and excludes
DLU access to the remaining workstations in the container. If the user account is already on the
workstation, the option to exclude the device from receiving the DLU policy is ignored.

Click Next to display the File Rights page.

For a DLU Policy, the timeout duration for enforcing file rights, if it is configured, is 120 seconds.
For large directory structures, the DLU policy might not be enforced because of a time out. To
enforce the file rights, follow instructions in TID 7004171, in the Novell Support Knowledge base
(http://www.novell.com/support/search.do?usemicrosite=true&searchString=7004171).

The following table contains information about managing Dynamic Local User file system access
on the managed device:
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Field

Details

Add

Edit

Move Up or
Move Down

Remove

Allows you to select and assign appropriate file rights.

To add a file/folder:
1. Click Add, then specify a file or folder.
2. Select the file rights you want to assign to the specified file or folder.

3. If you want to restrict the inheritance of the rights to only the immediate child file
or folder, select Restrict inheritance to immediate child files/folders only.

4. Click OK.

Copy: Allows you to copy and add a file rights setting to the list.
1. Select a file or folder, then click Edit.
2. Click Copy.
3. Specify a new name.

4. Click OK.

Rename: Allows you to edit only the filename.
1. Select a file or folder, then click Edit.
2. Click Rename.
3. Specify a new filename.

4. Click OK.

Allows you to reorder the files or folders.
1. Select the check box next to the file or folder you want to move.

2. Click Move Up or Move Down to relocate it.

Allows you to remove a file or a folder from the list.
1. Select the check box next to the file or folder.

2. Click Remove.

10 Click Next to display the Summary page. Review the information and, if necessary, use the Back
button to make changes to the information on the Summary page.

11 (Conditional) Select Create as Sandboyx, if you want to create the sandbox version of the policy.

12 Click Finish to create the policy now, or select Define Additional Properties to specify additional
information, such as policy assignment, system requirements, enforcement, status, and which
group the policy is a member of.

3.2.1 Rules for Workstations

Be aware of the following:

+ By default, all workstations are included.

+ For an indirect association, if an object is in both lists, the closeness of the association is
considered. A direct association is closer than a group association, which in turn is closer than a

folder.
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+ If the closeness is the same, a workstation is directly added to Group A and Group B, and the

Included List takes precedence.

Excluded List Included List

Result

Workstation-A Workstation-B

Workstation Group-1 Workstation-A

Container-1 Workstation Group-1 or
Workstation-A

The policy is applied on all
workstations except
Workstation-A.

The policy is not applied on any
workstations in Workstation
Group-1, except for Workstation -
A.

The policy is applied on
workstations that are not
contained in Workstation Group-
1.

The policy is not applied on any
workstations in Container-1,
except for Workstation Group-1
or Workstation-A.

The policy is also applied on
workstations that are not
contained in Container-1.

3.2.2 Rules for Users

Be aware of the following:

+ By default, all users are included.

+ For an indirect association, if an object is in both the lists, the closeness of the association is
considered. A direct association is closer than a group association, which in turn is closer than a

folder.

+ If the closeness is the same, a user is directly added to Group A and Group B, and the Included

List takes precedence.

Excluded List Included List Result

User-A User-B The policy is applied on all users
except User-A.

User Group-1 User-A The policy is not applied on any

users in User Group-1, except for
User -A.

The policy is also applied on
users that are not contained in
User Group-1.
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3.2.3

Excluded List Included List Result

Container-1 User Group-1 or User-A The policy is not applied on any
users in Container-1, except for
User Group-1 or User-A.

The policy is also applied on
users that are not contained in
Container-1.

Implementing the Dynamic Local User Policy Without the Novell
Client

To log a dynamic user with an e-directory account into a workstation using the Dynamic Local User
policy:

1 Install the ZENworks Agent on the workstation.
2 After successful installation, create a DWORD value Al | owDLUW t hout Novel | d i ent under

the following registry key and set its data to 1:

Windows XP (32-bit): HKEY_LOCAL_MACHI NE\ \ SOFTWARE\ \ Novel | \\ N\G NA

For this registry key to be effective, it is mandatory that you reboot the Windows XP device.
Windows Vista (32-bit and 64-bit):

HKEY_LOCAL_MACH NE\\ SOFTWARE\ \ Novel | \\ Aut henti cati on

Windows 7 (32-bit and 64-bit):

HKEY LOCAL_MACHI NE\\ SOFTWARE\ \ Novel | \\ Aut henti cati on

This support is not available on managed devices running Windows Server operating systems.

NOTE: In Windows Vista or Windows 7, if the initial login screen does not have an option to
enter the username, then do one of the following:

1. Enable the following setting from the Local Security policy:
a. Launch secpol . msc.
b. Navigate to Security Settings > Local Policies > Security Options.
c. Enable Interactive Logon: > Do not display last user name.
or

2. Create the following registry key
[ HKEY_LOCAL_MACHI NE\ SOFTWARE\ M cr osof t \ W ndows\ Cur r ent Ver si on\ Pol i ¢
i es\ Systen] dontdi spl ayl ast user nanme 2dwor d: 00000001

For more information on the Registry key see, ZENworks Registry Keys Reference.

Create a user source on the ZENworks server, assuming the user source has one user with the
credentials admin/novell.

Log in to the workstation using user-source credentials (admin/novell).

A Dynamic Local User account gets created.
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IMPORTANT:

+ If the DLU policy is created to take the credentials other than the user-source credentials, a
DLU user fails to unlock the workstation.

3.3 Local File Rights Policy

The Local File Rights policy allows you to configure rights for files or folders that exist on the NTFS file
systems.
1 In ZENworks Control Center, click the Policies tab.
2 In the Policies list, click New, then click Policy.
or
In the Policy Tasks, click New Policy.
The Select Platform page is displayed.
3 Select Windows, then click Next.
The Select Policy Category page is displayed.
4 Select Windows Configuration Policies, then click Next.
5 Select Local File Rights Policy as the Policy Type, then click Next
6 In the Define Details page fill in the following fields:

Policy Name: Provide a name for the policy. The policy name must be different than the name
of any other item (group, folder, and so forth) that resides in the same folder. The name you
provide displays in ZENworks Control Center.

Folder: Type the name or browse to and select the ZENworks Control Center folder where you
want the policy to reside. The default is / pol i ci es, but you can create additional folders to
organize your policies.

Administrator Notes: Provide a short description of the policy’s content. This description
displays in ZENworks Control Center.

7 Click Next to display the Configure Basic Properties page, then use the options on the page to
configure the attributes.

The following table contains information about configuring a file or folder and the attributes
associated with it:

Field Details

File / Folder Path  Allows you to specify the complete path of a file or folder on the managed device.
You can use the ZENworks system variables or environment variables to specify the
path.

To configure system variables in ZENworks Control Center, click the Configuration
tab > the Device Management setting in the Management Zone Settings panel >
System Variables. Click the Help button for details about configuring system
variables.
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Field

Details

Notify if the file
or folder does not
exist

Attributes

When you select this option, a message is sent to the Primary Server. If a folder
entered by the user is not present on the ZENworks Agent, then the policy fails to
enforce on the managed device.

If you de-select this option, even if a folder is not present on the ZENworks Agent, a
message will not be sent to the Primary Server and the policy will be enforced
successfully on the managed device.

Allows you to specify the attributes of a file or folder, such as Read only and
Hidden.

This page allows you to configure permissions for only one file or folder. If you want to assign
permissions to multiple files or folders, then configure them in the Details page after creating

the policy.

Click Next to display the Configure Permissions page, then use the options on the page to
configure permissions for selected users or groups.

The following table contains information about configuring permissions:

Field

Details

Permission for
Users or Groups

Create Groups on
the Managed
Device if they Do
not Exist

Remove Access
Control Rules not
Configured by
ZENworks

Allows you to configure permissions for users or groups.

1. Click Add, then Click User or Group to select a user or a group from the
appropriate drop-down list.

2. Select the type of permission you want to configure as Simple NTFS
Permissions or All NTFS Permissions. Depending on the type of permission
you select, a list of permissions are displayed. Configure the permissions as
applicable to the selected user or group.

3. By default, when a permission is set on a folder, all the subfolders and the
files also inherit the permissions. If you want to restrict the inheritance of
the rights to only the immediate child file or folder, select Restrict
inheritance to immediate child files/folders only.

4. Click OK.

The permissions configured for the user or group in the Dynamic Local User policy
takes precedence over the permissions configured in the Local File Rights policy.

Creates a group for which permissions are configured; however the group does
not exist on the managed device. With this option, you can create only local
groups.

Removes all access control entries for users or groups not configured by the
ZENworks Local File Rights policy. Also, updates the existing access control entries
for users and groups configured in the policy. After the policy is applied, any
manual changes made to the permissions for a user or group configured by the
policy are lost when the policy is re-applied.
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Field Details

Inherit Applicable  Select Yes if you want a file or folder to inherit applicable access control rules from

Access Rights its parent object. If you select No, inherited rules are removed. If you do not want
Configured on to make any changes, select not configured on the managed device.At least one
Parent Folders attribute, permission, or inheritance setting must be configured to create a policy.

Without configuring any settings, you cannot create a policy.

NOTE: If the Full Control access right is denied for the Administrators or Authenticated Users
group, the policy is successful only during the first enforcement. However, if the Full Control
access right is denied for the Administrators or Authenticated Users group and the Remove
access control rules not configured by ZENworks option is selected, the policy fails.

The unenforcement of the Local File Rights policy from a device fails if the Full Control access
right is denied for the Administrators or Authenticated Users group in the policy.

9 Click Next to display the Summary page. Review the information and, if necessary, use the Back
button to make changes to the information on the Summary page.

10 (Conditional) Select Create as Sandboyx, if you want to create the sandbox version of the policy.

11 Click Finish to create the policy now, or select Define Additional Properties to specify additional
information, such as policy assignment, system requirements, enforcement, status, and which
group the policy is a member of.

Power Management Policy

The Power Management policy allows you to configure the Power Management settings on the
managed devices by creating a power scheme. It lets you configure the plugged in and battery power
management settings and assign them to a device or a user.
1 In ZENworks Control Center, click the Policies tab.
2 In the Policies list, click New, then click Policy.
or
In the Policy Tasks, click New Policy.
The Select Platform page is displayed.
3 Select Windows, then click Next.
The Select Policy Category page is displayed.
4 Select Windows Configuration Policies, then click Next.
5 Select Power Management Policy as the Policy Type, then click Next.
6 In the Define Details page fill in the following fields:

Policy Name: Provide a name for the policy. The policy name must be different than the name
of any other item (group, folder, and so forth) that resides in the same folder. The name you
provide displays in ZENworks Control Center.

Folder: Type the name or browse to and select the ZENworks Control Center folder where you
want the policy to reside. The default is / pol i ci es, but you can create additional folders to
organize your policies.
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Administrator Notes: Provide a short description of the policy’s content. This description
displays in ZENworks Control Center.

7 Click Next to configure the power settings for a managed device.

In the Add Power Scheme Settings page fill in the following fields:

Scheme Name: The policy name specified on the Define Details page is automatically displayed.
You can either retain the policy name for the scheme or specify a new scheme name. ZENworks
creates a scheme with the specified name on the managed device.

Scheme Description: Provide a description for the power scheme. The description is displayed
as a tooltip for the power scheme on the managed device.

Power Settings: To add power scheme settings to a device or user, refer to the following table:

Task

Description

Turn off hard disk after

Slide show

Power saving mode

Sleep after

Allow hybrid sleep

Enable System Hibernation

Hibernate after

Allow wake timer

USB selective suspend setting

Lid close action

Power button action
Sleep button action

Link state

Minimum processor state
System cooling policy
Maximum processor state
Dim display after

Turn off display after

Display brightness

How long your hard disk is inactive before the disk turns off.

The duration for which you want the desktop background slide show
to be active.

The power saving mode for a wireless adapter.

How long your computer will be inactive before switching to sleep
mode.

If your system needs to save work it can, enter a low power state and
resume work immediately.

If system hibernation is enabled or not.

How long your system will be inactive before switching to hibernate
mode.

If timed events should change the state of the computer from sleep
mode to active mode.

If the USB selective suspend feature is turned Off or On.

The action that the computer takes when you close the lid of your
mobile-PC.

The action to be taken when you press the Power button.
The action to be taken when you press the Sleep button.

The Active State Power Management mode to be used for PCI
Express-based serial links when the links are idle or less active.

The minimum performance state of your processor.

The cooling mode for your system.

The maximum performance state of your processor.

How long your system is inactive before the display dims.
How long your system is inactive before the display turns off.

The normal brightness level of your system.
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Task

Description

Dimmed display brightness
Enable adaptive brightness
When sharing media

When playing video

JavaScript timer frequency

Critical battery action

Low battery level

Critical battery level

Low battery notification

Low battery action

Reserve battery level

The display brightness when your monitor display is dimmed.
If your monitor supports adaptive brightness.
What your computer does when sharing media files.

The power optimization mode used by your computer's video
playback pipeline.

The power optimization mode used by your computer for Internet
Explorer 9 and Internet Explorer 10 browsers.

The action that your computer takes when the battery reaches the
critical level.

The percentage of battery capacity remaining that initiates the low
battery action.

The percentage of battery capacity remaining that initiates the
critical battery action.

Whether a notification is shown when the battery capacity reaches
the low level.

The action that your computer takes when battery capacity reaches
the low level.

The percentage of battery capacity remaining that initiates reserve
power action.

NOTE:

. We recommend that you configure the power scheme duration in the following
descending order: System Hibernation > System Standby > Hard Disks > Monitor.

. The values of System Standby and System Hibernation are interdependent. If you
choose to set the state of these settings to Not Configured, in such a case, the other setting
can only be set to either Never or Not Configured. This is to ensure that the 'Standby
Timeout' is always lesser than the 'Hibernate Timeout'.

For example, if you set a duration for the System Standby value and then set the System
Hibernation value to Not Configured, the System Standby value automatically changes to

Not Configured.

. When you apply power management settings on a Windows XP managed device, the
scheme name is displayed in the settings panel of the Windows Power Options console

only for a system user.

3.5 Printer Policy

The Printer policy allows you to configure Local, SMB, HTTP, TCP/IP, CUPS, and iPrint printers on a
Windows device.
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NOTE: On a 32-bit agent machine, when the iPrint printer is installed through a user assigned printer
policy, you will not be able to view the printer preferences or properties.

=

In ZENworks Control Center, click the Policies tab.

N

In the Policies list, click New, then click Policy.
or

In the Policy Tasks, click New Policy.

The Select Platform page is displayed.

3 Select Windows, then click Next.

The Select Policy Category page is displayed.

H

Select Windows Configuration Policies, then click Next.

(9}

Select Printer Policy as the Policy Type, then click Next.

[=)]

In the Define Details page fill in the following fields:

Policy Name: Provide a name for the policy. The policy name must be different than the name
of any other item (group, folder, and so forth) that resides in the same folder. The name you
provide displays in ZENworks Control Center.

Folder: Type the name or browse to and select the ZENworks Control Center folder where you
want the policy to reside. The default is / pol i ci es, but you can create additional folders to
organize your policies.

Administrator Notes: Provide a short description of the policy’s content. This description
displays in ZENworks Control Center.

7 Click Next to display the Printer Identification page, then select the type of printer to be
installed on the managed device.

8 Click Next, then skip to the appropriate step, depending on which printer type you chose in
Step 7:

+ Local Printer: Continue with Step 9.
+ Network Printer: Skip to Step 10.
¢ iPrint Printer: Skip to Step 11.

NOTE: Create and assign separate policies for different platforms for a printer.

9 (Conditional) If you are configuring a local printer, refer to the following table for more

information:

Field Details

Name Specify the name of the local printer that you want to configure on the target
device.

Driver Browse to and select a suitable driver for the printer. If the driver is not

contained in the browser list, type in the correct model name. The driver must
either be installed on the target device or specified in the enforced policies.
The driver must be digitally signed by Microsoft. However, if you choose to use
a driver that is not digitally signed, see the Troubleshooting Scenario.
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Field

Details

Port

IP Address

Protocol

Port Number

Queue Name

LPR Byte Counting
Enabled

SNMP Status Enabled

Install a Driver

Select the physical port to which the printer is added, such as LPT1, COM1 or
Standard TCP/IP.

NOTE: If you assign a TCP/IP Printer policy to a 11 SP1 or older version of the
agent, the policy gets applied and then fails and sends errors to the server at
every refresh, as it is not supported.

Remove the association with the lower version of the agents from the TCP/IP
printer policy, to prevent it from being applied at every refresh.

Specify the IP address of the local printer. This field appears only if you select
Standard TCP/IP as the port.

Specify the protocol of the local printer. You can select either RAW or LPR from
the drop-down options. This field appears only if you select Standard TCP/IP as
the port.

Specify the port number for the protocol. Typically the port number is 9100.
This field appears only if you select the RAW protocol on the Standard TCP/IP
settings page.

Specify the queue name to be used by this port, if a name is required by your
printer. This field appears only if you select the LPR protocol on the Standard
TCP/IP settings page.

Choose this option if you encounter problems such as missing or incomplete
documents when printing. When LPR byte counting is enabled, the system
counts the number of bytes in a document before processing the print request.
Most printers do not need byte counting enabled because it can be very time
consuming. This field appears only if you select the LPR protocol on the
Standard TCP/IP settings page.

Select this option if the printer attached to this port supports RFC1759. This
field appears only if you select Standard TCP/IP as the port.

Community Name: Specify a community name, for example: public.
SNMP Device Index: Specify the device index, for example: 1.

Select this option to install a driver on the target device. The driver installation
must be non-interactive and silent. The supported driver installation types are
.inf and .exe. For the .inf type, the driver files can be bundled in .zip or .tar
formats. The .inf file can be specified directly if it is already available on the
target device

NOTE: To add a new printer driver to the existing driver list:

Edit the

zenwor ks_i nstal I di r\novel | \ zenwor ks\ shar e\ t ontat \ webapps
\ zenwor ks\ VEB- | NF\ conf\ printerDriverDetails.conf fileto
add the following line:

Printer_ Manufacturernane = Printer_ Mdel

For example, if you want to add an HP Color LaserJet 4550 PCL printer, then add
the following line:

HP = HP Col or LaserJet 4550 PCL
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Field Details

Model Name Browse to select the model name of the driver.

Driver File Path Specify the driver files either from a particular device where the browser is
running or from a path on the managed device, such as C: \ t enp\ ni pp. zi p.

NOTE: While configuring the policy, if you are using a UNC path to access the
Driver file, make sure the file you access must be on an anonymous share.

Supported Platforms  Specify a platform for the driver. The platform information helps to select a
suitable driver from the available drivers list, which is based on the installation

platform.
Language of Select the installation language. Your choices are English (United States),
Installation French, German, Portuguese, Spanish, Italian, Chinese (Traditional), Chinese

(Simplified), or Japanese.

Install Forcefully Even Select this option to force installation of the driver, even though it is already
if the Driver is Already installed on the target device.
Installed

10 (Conditional) If you are configuring a Network printer, refer to the following table for more

information:

Field Details

Name / Location Specify the UNC path or URL name of the HTTP, SMB or CUPS printer.
For example, itis\ \ server - nane\ pri nt er - nane for an SMB printer,
http://server: 631/ printers/nyprinter foraCUPS printer, or
http://server/printers/.nmyprinter/.printer foraHTTP printer.
NOTE: Support for network printer that prompts for user credentials is not
provided.

Driver Browse to add and select a suitable driver for the Windows HTTP printer. You

can ignore this for SMB printers.

The driver must be digitally signed by Microsoft. However, if you choose to use a
driver that is not digitally signed, see the Troubleshooting Scenario
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Field

Details

Install a Driver

Model Name

Driver File Path

Supported Platforms

Language of
Installation

Install Forcefully
Even if the Driver is
Already Installed

Use this option to install a driver on the target device. The driver installation is
non-interactive and silent. The supported driver installation types is . i nf and
the . i nf driver files can be bundled in. zi p or. t ar formats. The . i nf file
can be specified directly if it is already available on the target device. Ensure
thatthe . i nf file supports the installation of the driver.

NOTE: To add a new printer driver to the existing driver list:

Edit the

zenwor ks_instal I dir\novel |\ zenwor ks\ shar e\t ontat \ webapps
\ zenwor ks\ VEEB- | NF\ conf\ printerDriverDetails.conf fileto
add the following line:

Printer_ Manufacturernane = Printer_ Mdel

For example, if you want to add an HP Color LaserJet 4550 PCL printer, then add
the following line:

HP = HP Col or LaserJet 4550 PCL
Browse to select the model name of the driver.

Specify the driver files either from a particular device where the browser is
running or from a path in the managed device, such asc: \ t enp\ ni p. zi p.

NOTE: While configuring the policy, if you are using a UNC path to access the
Driver file, make sure the file you access must be on an anonymous share.

Specify a platform for the driver. The platform information helps to select a
suitable driver from the available drivers list, which is based on the installation
platform.

Select the installation language. Your choices are English (United States), French,
German, Portugese, Spanish, Italian, Chinese (Traditional), Chinese (Simplified),
or Japanese.

Select this option to force the installation of the driver on the device every time
the policy is applied on the device, even if the driver is already installed on the
device.

(Conditional) If you are configuring an iPrint printer, refer to the following table for more

information:

On Windows Vista devices, you need to install the Novell iPrint client 5.04 or later.

Field

Details

Name / Location

Update iPrint Printer
while Installing the
Driver

Specify the URI name of the iPrint printer. For example, i pp: // acne. conl
i pp/ server nane.

Select this option to update the printer driver and to reinstall the printer
driver from the iPrint server while installing the iPrint printer.
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Field Details

Install iPrint Client Select this option to install the iPrint client on a target machine. The iPrint
client is not supported on 64-bit versions of Windows Server 2003.

The installation file can be either ni pp. zi p or ni pp- s. exe, both of which
are capable of carrying out non-interactive silent installation.These files can
be uploaded from the machine where the browser is running.

To install the iPrint client, you cannot use a . exe file that does not support a
silent installation. For example, you cannot use a ni pp. exe file to install

iPrint client.
iPrint Client Installer Allows to specify the path to the iPrint Client Installer (which installs the iPrint
File Path client on the managed device).

+ On the Managed Device: Select this option to specify the path to the
iPrint client installer on the managed device.

+ Select from this Device: Select this option to add the iPrint client
installer as content with the policy. You can also distribute the iPrint
client installer along with the policy.

If the installer file path is a UNC path, the Novell iPrint Client dialog box is
displayed until the installation process completes. This process can be
perfomed only by users with administrative rights.

Install forcefully evenif Select this option to force the installation of the iPrint client, even if it is
iPrint client is already  already installed on the target device.
installed

Configure iPrint Client  Select this option to configure the iPrint proxy server.

If the workstations are located outside the physical firewall, you can use this
option to specify the proxy address followed by a (:) and the port number.

Proxy Server Specify the iPrint proxy server name. For example, htt p: //
pr oxy. conmpanyx. com 8080

12 Click Next to display the Printing Preferences page, then use the options to specify the
preferences. Refer to the following table for more information:

Field Details

Orientation Select this option to specify the paper layout for the printer, such as landscape
or portrait.

Duplex Printing Specify whether or not to print on both sides of the paper, if the printer has that
capability.

Collate Specify whether or not the printer should organize multiple copies of a

document, if the printer has that capability.

Print Quality Select the print quality. Select High quality, for the best possible resolution, or
select Low quality for lower resolution and lower quality.
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14

15
16

Field

Details

Paper Source

Paper Size

Specify the paper source for the printer. A source that is not listed in the
standard available list can also be specified, but it must be supported by the
printer. Information on supported paper sources is available in the printer
documentation or in the registry key

HKEY LOCAL_ MACHI NE\ SOFTWARE\ M cr osof t \ W ndows

NT\ Current Versi on\Print\Printers\printer-

nanme\ DsDri ver\ pri nt Bi nNanes on a Windows machine.

Specify the paper size for the printer. You can specify any paper size supported
by the printer, in addition to the options listed in the menu. Information on
supported sizes is available in the printer documentation or in the registry key
HKEY_LOCAL_MACHI NE\ SOFTWARE\ M cr osof t \ W ndows

NT\ Current Versi on\Print\Printers\printer-

nanme\ DsDri ver\ pri nt Medi aSupport ed on a Windows machine, where a
printer is locally installed.

Click Next to display the Additional Printer Policy settings, then use the options to specify the
settings. Refer to the following table for more information:

Field

Details

Set as Default
Printer

Remove all Printers
not Specified by
ZENworks Printer
Policies

Select this option to specify a printer as the default printer to which the print
requests are sent if no other printer is specified by the user.

On a Windows 7 managed device, the assigned printer might be set as a default
printer on the device even if the Set as Default Printer option is not selected in the

policy.

Select this option to remove all printers that are not specified through the
ZENworks Printer policy.

Click Next to display the Summary page. Review the information and, if necessary, use the Back
button to make changes to the information on the Summary page.

This wizard allows you to configure only one printer. If you want to configure additional printers,
then configure them in the Details page after creating the policy.

(Conditional) Select Create as Sandbox, if you want to create the sandbox version of the policy.

Click Finish to create the policy now, or select Define Additional Properties to specify additional
information, such as policy assignment, system requirements, enforcement, status, and which
group the policy is a member of.

Only the preferences that are supported by the printer are configured on that printer.

NOTE: Upon unenforcement of a user-assigned printer, a user with administrative privileges
continues to have access to the local printer on a Windows XP managed device.
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3.6

3.7

Remote Management Policy

The Remote Management policy lets you configure the behavior or execution of a Remote
Management session on the managed device. The policy includes properties such as Remote
Management operations and security.

By default, a secure Remote Management policy is created on the managed device when the
ZENworks Agent is deployed with the Remote Management component on the device. You can use
the default policy to remotely manage a device. To override the default policy, you can explicitly
create a Remote Management policy for the device.

For information on creating the Remote Management policy, see “Creating the Remote
Management Policy” in the ZENworks 2017 Remote Management Reference.

Roaming Profile Policy

The Roaming Profile policy allows you to create a user profile that is stored in a network path. An
administrator can either use the roaming profile stored in the user’s home directory or the profile
stored in the network directory location.

On a Windows 8 machine, the Roaming Profile policy works when a user logs in through the Novell
Client.

IMPORTANT: Because of the security settings in Microsoft Vista, administrators must manually add
the appropriate security rights to the user registry hive to enable roaming profiles. For more
information, see Section 5.9, “Assigning a Roaming Profile Policy for a User Profile Stored on a
Windows, Linux, or NetWare Share,” on page 67.

1 In ZENworks Control Center, click the Policies tab.
2 In the Policies list, click New, then click Policy.
or
In the Policy Tasks, click New Policy.
The Select Platform page is displayed.
3 Select Windows, then click Next.
The Select Policy Category page is displayed.
4 Select Windows Configuration Policies, then click Next.

5 Select Roaming Profile Policy as the Policy Type, then click Next.

NOTE: If you log into Windows Vista or Windows 7 by using a domain account, Roaming Profile
policy is not supported.

6 In the Define Details page fill in the following fields:

Policy Name: Provide a name for the policy. The policy name must be different than the name
of any other item (group, folder, and so forth) that resides in the same folder. The name you
provide displays in ZENworks Control Center.

Creating Windows Configuration Policies


https://www.novell.com/documentation/zenworks-2017-update-4/pdfdoc/zen_cm_remote/zen_cm_remote.pdf#bau5mpr
https://www.novell.com/documentation/zenworks-2017-update-4/pdfdoc/zen_cm_remote/zen_cm_remote.pdf#bau5mpr
https://www.novell.com/documentation/zenworks-2017-update-4/pdfdoc/zen_cm_remote/zen_cm_remote.pdf#bookinfo

Folder: Type the name or browse to and select the ZENworks Control Center folder where you
want the policy to reside. The default is / pol i ci es, but you can create additional folders to
organize your policies.

Administrator Notes: Provide a short description of the policy’s content. This description
displays in ZENworks Control Center.

7 Click Next to display the Roaming Profile Policy page, then use the options to specify the
settings. Refer to the following table for more information:

Field Details

Store User Profile  Select this option to load and save a user’s profile from the user’s home directory
in User’s Home as specified in eDirectory.

Directory
This option is applicable only if the user object is in eDirectory. However, it is

currently not supported in Domain Services for Windows environment.

User Profile Path Select a UNC path to a user’s roaming profile. If you want to administer the policy
on more than one user object, use WSERNANMEYbas the environment variable. In
this case, the environment variable is resolved with the logged-on username and
the user profile is loaded from the specified path.

Override Terminal If a user is accessing a terminal server that has its own profile, enable this option
Server Profile to override the terminal server’s profile.

8 Click Next to display the Summary page. Review the information and, if necessary, use the Back
button to make changes to the information on the Summary page.

9 (Conditional) Select Create as Sandboy, if you want to create the sandbox version of the policy.

10 Click Finish to create the policy now, or select Define Additional Properties to specify additional
information, such as policy assignment, system requirements, enforcement, status, and which
group the policy is a member of.

3.8 SNMP Policy

The SNMP policy allows you to configure SNMP parameters on the managed devices.

1 In ZENworks Control Center, click the Policies tab.
2 In the Policies list, click New, then click Policy.

or

In the Policy Tasks, click New Policy.

The Select Platform page is displayed.
3 Select Windows, then click Next.

The Select Policy Category page is displayed.
4 Select Windows Configuration Policies, then click Next.
5 Select SNMP Policy as the Policy Type, then click Next.
6 In the Define Details page fill in the following fields:
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Policy Name: Provide a name for the policy. The policy name must be different than the name
of any other item (group, folder, and so forth) that resides in the same folder. The name you
provide displays in ZENworks Control Center.

Folder: Type the name or browse to the ZENworks Control Center folder where you want the
policy to reside. The defaultis/ pol i ci es, but you can create additional folders to organize
your policies.

Administrator Notes: Provide a short description of the policy’s content. This description
displays in ZENworks Control Center.

Click Next to display the SNMP Community Strings page. Refer to the following table for more
information:

Field Details

Add a Community String Allows you to add a community string.

Community String Specify the name of the SNMP community string to be added.
Community Rights Allows you to administer rights for a selected community, such as Read

Only, Read & Write, Read & Create, and Notify.

Remove All SNMP Select this option to remove all the community strings that are not
Community Strings not specified through ZENworks SNMP policy.

specified by ZENworks

SNMP Policies

Send SNMP Authentication  Select this option if you want to send authentication trap information.
Trap

This page allows you to add only one community string to the policy. If you want to add multiple
community strings, then configure them in the Details page after creating the policy.

Click Next to display the SNMP Default Access Control List page, then use the options to specify
the settings. Refer to the following table for more information:

Field Details

Allow SNMP Communication  Select this option to specify whether SNMP communication is allowed
from any host or a list of predefined hosts.

Remove All SNMP Allowed Select this option to remove all the SNMP allowed hosts that are not
Hosts not Specified by specified through the ZENworks SNMP policy.
ZENworks SNMP Policies

Click Next to display the SNMP Trap Targets page, then use the options to specify the settings.
Refer to the following table for more information:
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11

12
13

Field Details

Add a Trap Target Allows you to add a trap target for the SNMP service.

IP Address / Host Name Specify an IP address or host name of the target device.

Community String Specify a community string for the trap target defined in IP address/
Host name.

Remove All SNMP Trap Targets Select this option to remove all the trap targets that are not specified
Not Specified by ZENworks through the ZENworks SNMP policy.
SNMP Policies

This page allows you to add only one trap target to the policy. If you want to add multiple trap
targets, then configure them in the Details page after creating the policy.

Click Next to display the Default System Requirements for SNMP Policy page, then use the
options to specify the settings. Refer to the following table for more information:

Field Details

Apply Policy Only if SNMP Select this option apply the SNMP policy only if the SNMP service
Service Exists On the Target exists on the target device. If the target device does not contain the
Device SNMP service, the SNMP policy cannot be fully applied or effective

on the target device.

Click Next to display the Summary page. Review the information and, if necessary, use the Back
button to make changes to the information on the Summary page.

(Conditional) Select Create as Sandbox, if you want to create the sandbox version of the policy.

Click Finish to create the policy now, or select Define Additional Properties to specify additional
information, such as policy assignment, system requirements, enforcement, status, and which
group the policy is a member of.

3.9 Windows Group Policy

The Windows Group Policy allows you to configure a Group Policy for Windows devices.

1
2

In ZENworks Control Center, click the Policies tab.
In the Policies list, click New, then click Policy.

or

In the Policy Tasks, click New Policy.

The Select Platform page is displayed.

Select Windows, then click Next.

The Select Policy Category page is displayed.

Select Windows Configuration Policies, then click Next.

5 Select Windows Group Policy as the Policy Type, then click Next.

In the Define Details page fill in the following fields:
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Policy Name: Provide a name for the policy. The policy name must be different than the name
of any other item (group, folder, and so forth) that resides in the same folder. The name you
provide displays in ZENworks Control Center.

Folder: Type the name or browse to and select the ZENworks Control Center folder where you
want the policy to reside. The defaultis / pol i ci es, but you can create additional folders to
organize your policies.

Administrator Notes: Provide a short description of the policy’s content. This description
displays in ZENworks Control Center.

7 Click Next to display the Windows Group Policy Settings page, then use the options to specify
the settings. Refer to the following table for more information:

Field Details

Select the Type of With the Windows Group Policy, you can manage either a Local group or an
Group Policy to Active Directory group policy.

Manage

Install ZCC Helper before configuring a Windows Group policy. Click Configure,
and allow browser to launch ZCC Helper.

+ Local Group Policy: Select this option to configure a Local Group policy.

To launch the group policy helper, click Configure. Configure or edit the
settings in the Local Group policy, then upload the configured policy to
the ZENworks Server.

+ Active Directory Group Policy: Select this option to use an Active
Directory Group policy.

To launch the group policy helper, click Configure. Import an Active
Directory Group policy created from Windows Server 2003 or Windows
Server 2008 Active Directory, then upload to the ZENworks Server. (You
cannot edit an Active Directory policy through ZENworks Control Center.)
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Field Details

Select the After you have adjusted the policy settings as you prefer, you can select how
Configuration Settings  to apply the settings to the managed device.
to Be Applied On the

Managed Device Computer Configuration Select this option to apply the computer

configuration settings to the managed device.

+ Apply all settings: Select this option to apply all the computer
configuration settings to the managed device.

+ Apply only security settings: Select this option to apply only the security
settings to the managed device.

However, if you select this option, the software restrictions in security
settings are not enforced on the device. To enforce the software
restrictions, select Apply all settings.

+ Apply all settings except security settings: Select this option to apply all
the computer configuration settings except for security settings to the
managed device.

IMPORTANT: During creation of a Group policy, if the value(s) of Security
settings on the machine where ZENworks Control Center is launched is
modified, then while restoring back the machine settings, the security
setting(s) having default state as NOT DEFINED (prior to creation of policy)
does not get restored.

User Configuration Select this option to apply the user configuration settings
to the managed device.

NOTE:

¢ The Computer Configuration settings from a user associated group
policy are not applied when the user logs into a Windows 2000 or
Windows 2003 Terminal Server.

* Group Policy Objects get assigned to a device on a general refresh.
The Computer Configuration settings of a device-assigned Group Policy
Object remains in-effect on user logout.

Click Next to display the Summary page. Review the information and, if necessary, use the Back
button to make changes to the information on the Summary page.

(Conditional) Select Create as Sandbox, if you want to create the sandbox version of the policy.

Click Finish to create the policy now, or select Define Additional Properties to specify additional
information, such as policy assignment, system requirements, enforcement, status, and which
group the policy is a member of.

If the login/logoff scripts are configured in a user-associated group policy and the After
enforcement, force a re-login on the managed device, if necessary, then a relogin is forced and
the login scripts run when the user logs into the managed device again. The startup scripts from
a device-associated policy run only when the device reboots the next time.

The Group policy login scripts do not support the environment variables for users on Windows
Vista, Windows Server 2003, Windows Server 2008, Windows 7, and Windows Server 2008 R2.

The scripts configured through Active Directory group policy are not enforced on the device
even though the policy displays success in the ZENworks Agent Policies page. For more
information see, Section A.14, “Windows Group Policy Troubleshooting,” on page 122.
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IMPORTANT

+ If you want to apply the security settings of the Windows Group policy on Windows XP SP1
or SP2 managed device, ensure that the device has Windows Hotfix KB897327 installed.
For more information about how to install the Hotfix, see the Microsoft Support Web site
(http://support.microsoft.com/KB/897327).

3.10 ZENworks Explorer Configuration Policy

46

The ZENworks Explorer Configuration Policy allows you to administer and centrally manage the
behavior and features of ZENworks Explorer.

1
2

In ZENworks Control Center, click the Policies tab.
In the Policies list, click New, then click Policy.

or

In the Policy Tasks, click New Policy.

The Select Platform page is displayed.

Select Windows, then click Next.

The Select Policy Category page is displayed.

Select Windows Configuration Policies, then click Next.

5 Select ZENworks Explorer Configuration Policy as the Policy Type, then click Next.

In the Define Details page fill in the following fields:

Policy Name: Provide a name for the policy. The policy name must be different than the name
of any other item (group, folder, and so forth) that resides in the same folder. The name you
provide displays in ZENworks Control Center.

Folder: Type the name or browse to and select the ZENworks Control Center folder where you
want the policy to reside. The defaultis / pol i ci es, but you can create additional folders to
organize your policies.

Administrator Notes: Provide a short description of the policy’s content. This description
displays in ZENworks Control Center.

Click Next to display the ZENworks Explorer Configuration Settings page, then use the options to
specify the settings. Refer to the following table for more information:

Field Details
Allow the end user to Enables user to pin bundles to Start and Taskbar.
pin bundles

If you select the value as Unconfigured, the default value No is set on the
managed device.

Show the All Folder in Specifies whether All folder should be displayed when you start the
ZENworks Explorer and  ZENworks Explorer and ZENworks Application. If you select the value as
ZENworks Application Unconfigured, the default value Yes is set on the managed device.
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Field

Details

Enable Folder View

Expand the Entire Folder
Tree

Display Applications in
Windows Explorer

Name of Root Folder

Hide the ZENworks Tray
Icon

Show Default
Notifications

Show Technician
Application Help

Enable Manual Refresh

Allow Logout / Login as
a New User

View Progress

Use this option to display a folder list in the application window.

The values are Yes, No, and Unconfigured. If you select the value as
Unconfigured, the default value Yes is set on the managed device.

Use this option to expand the entire folder tree when the application
window is opened.

The values are Yes, No, and Unconfigured. If you select the value as
Unconfigured, the default value No is set on the managed device.

Use this option to display the application list in Windows Explorer.

The values are Yes, No, and Unconfigured. If you select the value as
Unconfigured, the default value Yes is set on the managed device.

Use this option to change the name of the root folder.
Use this option to hide the ZENworks icon in the taskbar.

The values are Yes, No, and Unconfigured. If you select the value as
Unconfigured, the default value No is set on the managed device.

Use this option to specify whether the default notification should be
displayed. The notification is displayed when the content associated with a
policy or a bundle is downloaded on the device. For example, during the
enforcement of the Printer policy on a device, the following message is
displayed in the notification area of the device:

Downl oading Files for Printer Policy

The values are Yes, No, and Unconfigured. If you select the value as
Unconfigured, the default value Yes is set on the managed device.

Specifies whether the technician application should be displayed.

If you select the value as Unconfigured, the default value Yes is set on the
managed device.

Use this option to specify whether manual refresh of applications is enabled
after starting ZENworks Explorer.

The values are Yes, No, and Unconfigured. If you select the value as
Unconfigured, the default value Yes is set on the managed device.

Use this option to enable the user to log out and log in as a new user.

The values are Yes, No, and Unconfigured. If you select the value as
Unconfigured, the default value Yes is set on the managed device.

Use this option to specify whether the progress of the bundle operations
should be displayed.

The values are Yes, No, and Unconfigured. If you select the value as
Unconfigured, the default value Yes is set on the managed device.
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10

Field Details

Show location change Displays location change notification pop ups on managed devices when the
notifications location of these devices changes.

If you select the value as Unconfigured, the default value Yes is set on the
managed device. Therefore, this setting should be applied to disable
displaying of location change pop ups on devices.

Click Next to display the Summary page. Review the information and, if necessary, use the Back
button to make changes to the information on the Summary page.

(Conditional) Select Create as Sandbox, if you want to create the sandbox version of the policy.

Click Finish to create the policy now, or select Define Additional Properties to specify additional
information, such as policy assignment, system requirements, enforcement, status, and which
group the policy is a member of.

Creating ZENworks Branding Policy

Branding policy enables your organization to customize certain aspects of the ZENworks Application
based on your own branding requirements, such as the ZAPP icon, wallpaper, and color.

To create a ZENworks End User Branding Policy:

1
2

In ZENworks Control Center, click the Policies tab.
In the Policies list, click New, then click Policy.

or

In the Policy Tasks, click New Policy.

The Select Platform page is displayed.

Select All, then click Next.

The Select Policy Category page is displayed.

Select General, then click Next.

5 Select ZENworks End User Branding Policy as the Policy Type, then click Next.

In the Define Details page fill in the following fields:

Policy Name: Provide a name for the policy. The policy name must be different than the name
of any other item (group, folder, and so forth) that resides in the same folder. The name you
provide displays in ZENworks Control Center.

Folder: Type the name or browse to and select the ZENworks Control Center folder where you
want the policy to reside. The default is / pol i ci es, but you can create additional folders to
organize your policies.

Administrator Notes: Provide a short description of the policy’s content. This description
displays in ZENworks Control Center.

Click Next to display the ZENworks End User Branding Policy Settings page, then configure the
following options:

+ Title Icon: Replaces the ZENworks Application icon with the selected icon. ICO, JPEG, JPG,
PNG, and SVG formats are supported.
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+ Title image: Changes the title image. JPEG, JPG, PNG, and SVG formats are supported.

+ Theme color: Changes the theme color, which includes the color of the login and logout
screens, the font color of the hover-on items, and folder tree font.

+ Display size: Changes the size of the bundle icons and font size of the bundle names and
folder tree text. The available options are small, medium and large.

+ Primary font color: Changes the font color of the bundle names, login page, hover-on
items, and folder tree font.

+ Customize background: Changes the color or image for the ZENworks Application
background.

8 Click Next to display the Summary page. Review the information and, if necessary, use the Back
button to make changes to the information on the Summary page.

9 (Conditional) Select Create as Sandboy, if you want to create the sandbox version of the policy.

10 Click Finish to create the policy now, or select Define Additional Properties to specify additional
information.

Creating Policies by Using the zman Command Line
Utility

ZENworks Configuration Management allows you to create different types of policies, such as
Browser Bookmarks policy, Dynamic Local User policy, Local File Rights policy, and Printer policy.
Each policy has its own set of data and configuration settings. Because it is complex to pass the data
as arguments in the command line, the zman utility takes XML files as an input to create policies. You
can use exported XML files as a templates to create polices. To use the zman command line utility to
create a policy, you must have a policy of the same type already created through ZENworks Control

Center and export it to an XML file. For more information on creating policies by using ZENworks
Control Center, see Chapter 3, “Creating Windows Configuration Policies,” on page 21.

For example, you can export a Browser Bookmarks Policy already created through ZENworks Control
Center into an XML file, then use it to create another Browser Bookmarks Policy by using zman.

A policy can have file content associated with it. For example, the printer driver to be installed is a
file associated with the Printer policy.

Review the following sections to create a policy by using the zman command line utility:

¢ Section 3.12.1, “Creating a Policy without Content,” on page 49
+ Section 3.12.2, “Creating a Policy with Content,” on page 52
¢ Section 3.12.3, “Understanding the zman Policy XML File Format,” on page 53

Creating a Policy without Content

1 Create a policy in ZENworks Control Center.

For example, use ZENworks Control Center to create a Browser Bookmarks Policy called google
containing a bookmark to http://www.google.co.in.

2 Export the policy to an XML file by using the following command:
zman policy-export-to-file policy_name policy_filenane. xni

Creating Windows Configuration Policies 49



50

For example, export the google policy to googl e. xm by using the following command:
zman policy-export-to-file google google. xm

If you want to create a new policy with new data, continue with Step 3. If you want to create a
new policy with the same data as the google policy, skip to Step 4.

3 Modify the XML file according to your requirements.

For example, in googl e. xm , change the value of <URL> from ht t p: / / www. googl e. co.in
tohttp://ww. yahoo. comin the br owser bookmar kspol i cy action of the Enf or cenment
action set and <Pol i cyDat a> element in both <Act i ons> and <Pol i cyDat a> elements as
shown below.

<ns2: Acti onSet s>
<l d>879de60b7591b6f 6aef ae09f cd83db54</ | d>
<Type>Enf or cenent </ Type>
<Ver si on>1</ Ver si on>
<Modi fi ed>f al se</ Modi fi ed>
<Acti ons>
<l d>0ab9a1785370bcd38bc862bd2817abac</ | d>
<Nane>br owser booknar kspol i cy</ Name>
<Type>br owser booknar kspol i cy</ Type>
<Dat a>

<Pol i cyData xm ns="http://novell.com zenwor ks/ dat anodel / obj ect s/
policies">

<Booknar ksPol i cyHandl er Data xm ns="">
<Enf or cePol i cy>
<Booknar ks>
<Bookmark Type="url _string">
<Nanme>Googl e</ Nane>
<Url >http://ww:.yahoo. conx/ Ul >
<Fol der >/ </ Fol der >
</ Booknar k>
</ Booknmar ks>
</ Enf or cePol i cy>
</ Bookmar ksPol i cyHandl er Dat a>
</ Pol i cyDat a>
</ Dat a>

<Conti nueOnFai | ur e>t rue</ Cont i nueOnFai | ure>
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<Enabl ed>t r ue</ Enabl ed>

<Pr operti es>St andal oneName=br owser bookmar ksenf ; | nper sonat i on=SYSTEM </
Properti es>

</ Actions>
</ ns2: Acti onSet s>

<ns2: ActionSets xm ns:ns2="http://novell.con zenwor ks/ dat anodel /
obj ects/actions" xm ns="http://novel|l.conl zenwor ks/ dat anodel / obj ect s/
actions">

<l d>4ef a37c827cf 0e8a8ac20b23a3022227</ 1 d>
<Type>Di stri buti on</ Type>
<Ver si on>1</ Ver si on>
<Modi f i ed>f al se</ Modi fi ed>
<Acti ons>
<l d>27c4a42544210b3ac3b067f f 6af f 2d5¢c</ | d>
<Nanme>Di stri bute Acti on</ Nanme>
<Type>Di stri bute Action</Type>
<Cont i nueOnFai | ure>t rue</ Conti nueOnFai | ure>
<Enabl ed>t r ue</ Enabl ed>
<Properties />

</ Acti ons>
</ ns2: Acti onSet s>

<Appl yI medi at e>f al se</ Appl yl nmedi at e>
<Pol i cyDat a>
<Bookmar ksPol i cyHandl| er Dat a>
<Enf or cePol i cy>
<Bookmar ks>
<Bookmark Type="url _string">
<Name>Googl e</ Nane>
<Url >http://ww. yahoo. conx/ Url >
<Fol der >/ </ Fol der >
</ Bookmar k>
</ Bookmar ks>
</ Enf or cePol i cy>

</ Booknar ksPol i cyHand! er Dat a>
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</ Pol i cyDat a>

4 Create a new policy by using the following command:

zman policy-create new policy nanme policy xm filenane.xnl
For example, to create a policy named yahoo, use the following command:

zman policy-create yahoo googl e. xm

Creating a Policy with Content

1 Create a policy in ZENworks Control Center.

For example, use ZENworks Control Center to create a Printer policy of type iPrint called iPrint
Policy that automatically installs an iPrint driver from the dri ver. zi p file provided as the
policy content, and configures an iPrint printer on the device.

Export the policy to an XML file by using the following command:
zman policy-export-to-file policy_nane policy_fil enane.xnl

This creates pol i cy_fil enanme. xm and pol i cy_fil ename_Acti onCont ent| nfo. xm
files.

For example, export iPrintPolicy to i Print Pol i cy. xm by using the following command:
zman policy-export-to-file iPrintPolicy iPrintPolicy.xm

Thei PrintPolicy.xm andiPrintPolicy_ActionContentlnfo.xm filesare created.
For more information about Act i onCont ent | nf 0. xm , see Section 3.12.3, “Understanding
the zman Policy XML File Format,” on page 53.

If you want to create a new policy with new data, continue with Step 3. If you want to create a
new policy with the same data as iPrintPolicy, skip to Step 4.

Modify thei Print Policy.xm andiPrintPolicy actioncontentinfo.xmn files
according to your requirements.

For example, to create a new policy to configure and install another iPrint in the network with a
newer version of the driver, do the following:

+ Change all references of dri ver. zi p tonewDri ver. zi p in the <Act i onSet > and the
<Pol i cyDat a> section of i Pri nt Pol i cy. xm , and in the <Act i onSet > section of
i PrintPolicy_actioncontentinfo.xm.

+ Replace the name of the printerinthe i Pri nt Pol i cy. xm file with the new name of the
printer.

Asamplei PrintPolicy_actioncontentinfo.xm isshown below.
<Act i onl nf or mati on>
<ActionSet type="Enforcenment">
<Action name="printer policy" index="1">
<Cont ent >
<Cont ent Fi | ePat h>dri ver. zi p</ Cont ent Fi | ePat h>
</ Cont ent >

</ Action>
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</ Acti onSet >
</ Acti onl nformation>

4 Create a new policy by using the following command:

zman policy-create new_policy_nane policy_xm _filename.xm --actioninfo
pol i cy_nane_acti oncontentinfo. xnl

For example, use the following command to create a policy called New_iPrintPolicy:

zman policy-create New_iPrintPolicy iPrintPolicy.xm --actioninfo
i PrintPolicy_ActionContentlnfo.xmn

Understanding the zman Policy XML File Format

The pol i cy-export-to-fil e command serializes the policy information, which is stored in the
database, into an XML file. Each policy contains actions that are grouped into Action Sets,
Enforcement, and Distribution. An exported policy XML file contains information for the policy, such
as UID, Name, Path, PrimaryType, SubType, PolicyData, System Requirements, and information on all
Action Sets and their actions. The file does not include information about assignment of the policy to
devices or users.

A sample XML format template, W ndows G- oupPol i cy. xm , is available at / opt / novel | /
zenwor ks/ shar e/ zman/ sanpl es/ pol i ci es on a Linux server and in

ZENworks I nstallation_directory:\Novel I\Zenworks\shar e\ zman\ sanpl es\ pol i ci
es on a Windows server.

NOTE: If the exported XML file contains extended ASCII characters, you must open it in an editor by
using UTF-8 encoding instead of ANSI coding, because ANSI coding displays the extended ASCII
characters as garbled.

When you create a policy from the XML file, zman uses the information specified in the

<Descri pti on>, <SubType>,<Cat egor y>, <Acti onSet s>, <Pol i cyDat a>, and <SysReqs>
tags of the file. The values for the Name and Parent folder are taken from the command line. For the
remaining elements, the default value is used.

Follow the guidelines listed below to work with the XML file:

+ If you want to create a policy without file content, you need only the policy XML file to create
the policy.

For example, a Local File Rights Policy does not have file content associated with it.

+ If you want to create a policy with content, you must provide an additional XML file, which
contains the path of the content file, as an argument to the - —act i oni nf o option of the
pol i cy-creat e command.

For example, a Printer policy can have the printer drivers to be installed as associated file
content.

A sample XML format template, Act i onl nf 0. xni , is available at / opt/ novel | / zenwor ks/
shar e/ zman/ sanpl es/ pol i ci es on a Linux server and in

ZENwor ks _Install ation_directory:\Novel I\ Zenwor ks\ shar e\ znman\

sanpl es\ pol i ci es on a Windows server.
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*

If you want to modify the <Dat a> element of actions in the exported XML file, ensure that the
new data is correct and that it conforms to the schema. The zman utility does a minimal
validation of the data and does not check for the errors. Hence, the policy might be successfully
created, but with invalid data. Such a policy fails when deployed on a managed device.

*

File content is associated with a particular action in an Action Set. The Action Content
Information XML file should contain the path of the file to which the file content is to be
associated and the index of the action in the Action Set.

For example, the Printer driver selected to be installed when creating a Printer policy is
associated to the printerpolicy action in the Enforcement action set of the created Printer
policy.

The Action Set is specified by the type attribute in <Act i onSet > element. It should be the
same as the Action Set type of the policy XML file.

*

*

The <Act i on> element has a name attribute, which is optional, for user readability.

*

The i ndex attribute is mandatory. It specifies the action to which the content should be
associated to. The index value of the first action in the Action Set is 1.

*

Each action can have multiple <Cont ent > elements, each containing a <Cont ent Fi | ePat h>
element. The <Cont ent Fi | ePat h> element contains the path of the file content to be
associated with the Action. Ensure that the filename is the same as the filename specified in the
policy XML file in <Dat a> for that action.

*

Ensure that the order of the <Cont ent > elements is in accordance with the order in the policy
XML file. For example, a Printer Policy can have multiple drivers configured.The path to the
driver files should be specified in the <Cont ent > elements in the order the files are specified
in the data for the action as show below.

<Act i onl nf or mai on>
<ActionSet type="Enforcement">
<Action name="printer policy" index="1">
<Cont ent >
<Cont ent Fi | ePat h>dri ver 1. zi p</ Cont ent Fi | ePat h>
</ Cont ent >
<Cont ent >
<Cont ent Fi | ePat h>dri ver 2. zi p</ Cont ent Fi | ePat h>
</ Cont ent >
</ Acti on>
</ Acti onSet >

</ Actionl nfornmation>
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4 Creating Mobile Device Policies

ZENworks Configuration Management lets you create policies for mobile devices. For more
information, see Securing a Device.
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5 Managing Policies

Novell ZENworks Configuration Management lets you use effectively manage software and content
in your ZENworks system. In addition to editing and deleting existing objects, you can create new
objects and perform various tasks on the objects.

You can use ZENworks Control Center or the zman command line utility to manage policies. This
section explains how to perform this task by using ZENworks Control Center. If you prefer the zman
command line utility, see “Policy Commands” in the ZENworks Command Line Utilities Reference.

*

*

Section 5.1, “Creating Policies,” on page 58

Section 5.2, “Viewing the Policy’s Summary,” on page 58
Section 5.3, “Policy Groups,” on page 61

Section 5.4, “Editing Policies,” on page 62

Section 5.5, “Deleting Policies,” on page 63

Section 5.6, “Adding Policies to Groups,” on page 63
Section 5.7, “Assigning a Policy to Devices,” on page 64
Section 5.8, “Assigning a Policy to Users,” on page 66

Section 5.9, “Assigning a Roaming Profile Policy for a User Profile Stored on a Windows, Linux,
or NetWare Share,” on page 67

Section 5.10, “Assigning a Roaming Profile Policy for a User Profile Stored on a Home Directory,”
on page 70

Section 5.11, “Assigning the Local File Rights Policy to Devices Running Different Languages,” on
page 70

Section 5.12, “Unassigning a Policy from Devices,” on page 71

Section 5.13, “Unassigning a Policy from Users,” on page 71

Section 5.14, “Adding System Requirements for a Policy,” on page 72

Section 5.15, “Disabling Policies,” on page 79

Section 5.16, “Enabling the Disabled Policies,” on page 80

Section 5.17, “Copying a Policy to a Content Server,” on page 80

Section 5.18, “Publish a Policy,” on page 82

Section 5.19, “Reviewing the Status of the Policies at the Managed Device,” on page 83

Section 5.20, “Policy Issues on a Windows 7, Windows Server 2008, or Windows Server 2008 R2
device,” on page 83

Section 5.21, “Viewing the Predefined Reports,” on page 84
Section 5.22, “Understanding Policy Versions,” on page 85
Section 5.23, “Managing Policy Versions,” on page 85
Section 5.24, “Publishing a Sandbox,” on page 86

Section 5.25, “Policy Behavior Based on Content Replication Settings,” on page 88
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5.1

5.2

5.2.1

Creating Policies

For step-by-step instructions on creating Linux policies, see Chapter 2, “Creating Linux Configuration
Policies,” on page 15 and for creating Windows policies, see Chapter 3, “Creating Windows
Configuration Policies,” on page 21.

For more information on Mobile Device policies, see the ZENworks 2017 Mobile Management
Reference guide.

Viewing the Policy’s Summary

The Summary page of a policy displays the following panels:

¢ Section 5.2.1, “General,” on page 58
+ Section 5.2.2, “Policy Status,” on page 59
+ Section 5.2.3, “Message Log,” on page 60

General

The General panel provides a summary of the policy’s general settings. Click the headings below for
descriptions of the settings.

Policy Type

Displays the type of policy.

Size

Click Compute to display the size of the content associated with the policy.

Version

Displays the policy’s version number.

Enabled

Displays whether or not the policy can be deployed to managed devices and copied to content
servers.

If a policy is enabled, it can be deployed to managed devices and copied to content servers.

If you disable a policy that has already been deployed to some managed devices and content
servers, the policy is removed from those devices and content servers. Also, it cannot be deployed to
new devices and content servers.
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Number of Errors Not Acknowledged

An error is anything that causes the deployment or installation of the policy to fail. The number
displayed indicates the number of unacknowledged errors, which are any errors that you have not
specifically marked as acknowledged. Unacknowledged errors are displayed in the Message Log
section.

Number of Warnings Not Acknowledged

A warning is anything that does not cause the deployment or installation of the policy to fail, but
indicates minor problems with the policy. The number displayed indicates the number of
unacknowledged warnings, which are any warnings that you have not specifically marked as
acknowledged. Unacknowledged warnings are displayed in the Message Log section.

GUID

Lists the policy’s GUID (global unique identifier), a randomly generated string that provides a unique
identifier for the policy. You cannot edit the GUID.

Administrator Notes

Displays the policy’s description, if one was provided when the policy was created. The description
appears in ZCC and the ZENworks Agent (on managed devices). Click Edit to change the description.

Policy Status

The Policy Status panel displays a summary of the policy’s assignment and enforcement status. The
User row displays the status of the policy through assignment to users; the Device row displays the
status of the policy through assignment to devices. A policy can be directly assigned or assigned
through membership in a folder or group. You can click an underlined link in any column to view the
status of the individual users and devices to which the policy is assigned, retry a failed policy, or
export the data to a CSV file.

A policy’s status is calculated using the status of many events. The numbers in the various columns
represent an overall view of the policy’s status.

NOTE: The Policy Status panel on the policy’s sandbox or the older versions page does not display
the status. However, the Policy Status panel on the policy’s published version page displays the
status of the policy’s published version, sandbox, and the older versions.

The policy status information is separated into the following groups, which are independent of each
other. For example, it is possible for an installation to be successful, but the launch to be
unsuccessful.

Assignment Status

The following status information is available:

Targeted: Displays the number of users and devices on which the policy is enforced.
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Devices Effective: Displays the number of devices on which the policy is effective through a user or
device assignment. A policy is effective for a device if the device meets the system requirements of
the policy. The number of users or devices in the Devices Effective column might be less than the
number in the Targeted column because the policy might be enforced on a device that does not
meet the policy’s system requirements. For example, you might have a Windows policy enforced on
a Linux device, but the policy is not effective for that device.

Devices Not Effective: Displays the number of devices on which the policy is not effective through a
user or device assignment. If a policy is not effective for the device, it means that the device does
not meet the policy’s system requirements.

Pending: The pending status for the device displays the number of devices on which the policy is not
yet enforced, such as devices that are switched off. Click the underlined link to display the list of such
devices.

Enforcement Status

The following status information is available:

Devices Pending: Displays the number of devices on which the policy is pending. A policy’s status is
pending if the policy has met the device’s system requirements, but the policy has not been enforced
on the device.

Devices Succeeded: Displays the number of devices on which the policy was successfully enforced.

Devices Failed: Displays the number of devices on which the policy’s enforcement failed.

Message Log

The Message Log panel displays all unacknowledged messages generated for the object. An
unacknowledged message is one that you have not yet reviewed and marked as acknowledged.

+ Status: Displays an icon indicating the type of message: %I critical, O warning, and e
normal.
+ Message: Displays a brief description of the event that occurred.

+ Date: Displays the date and time the event occurred.

NOTE: The Message Log panel on the policy’s sandbox or the older versions page does not display
any messages. However, the Message Log panel on the policy’s published version page displays the
messages of the policy’s published version, sandbox, and the older versions.

A message remains in the Message Log list until you acknowledge it. You can acknowledge individual
messages, acknowledge all messages at one time, or view more information about both
acknowledged and unacknowledged messages. The following table explains how to do these tasks:
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Task Steps Additional Details

Acknowledge a 1. Click the message to display the If you decide that you do not want to
message Message Detail Information dialog  acknowledge the message, click Finished
box. to dismiss the dialog box. This causes the
2. Click Acknowledge. Imessage to remain in the Message Log
ist.
Acknowledge all 1. Inthe Tasks list located in the left
messages navigation pane, click Acknowledge
All Messages.
View all 1. Click the Advanced button to display In addition to viewing all acknowledged
acknowledged or the Edit Message Log page. and unacknowledged messages, you can
unacknowledged also view only those messages with a
messages specific status or date, view more details
about messages, and acknowledge
messages.

Click the Help button on the Edit Message
Log page for specific information about
performing tasks on that page.

Delete a message 1. Click the message to display the Deleting a message completely removes
Message Detail Log dialog box. the message from your ZENworks system.

2. Click Delete.

Policy Groups

A policy group consists of two or more policies. Creating policy groups eases administration efforts
by letting you assign the group, rather than each individual policy, to devices and users. You can
create a policy group with a single policy and then add policies to the group as and when required.

1 In ZENworks Control Center, click the Policies tab.

2 In the Policies list, click New, click Policy Group to display the Basic Information page, then fill in

the fields:

Group Name: Provide a unique name for your policy group. The name you provide displays in
the ZENworks Control Center interface.

Folder: Type the name or browse to and select the folder that contains this policy group

Description: Provide a short description of the policy group’s content. This description displays

in ZENworks Control Center.

3 Click Next to display the Add Group Members page. You can add any number of policies to the
group. You cannot add other policy groups to the group.

To add a policy:
3a Click Add to display the Select Members dialog box.

Because you are adding policies to the group, the Select Members dialog box opens with
the Pol i ci es folder displayed.
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3b Browse for and select the policies you want to add to the group. To do so:

3b1 Click ¢ next to a folder to navigate the folders until you find the policy you want to

select.

If you know the name of the policy you are looking for, you can also use the Item name
box to search for the policy.

3b2 Click the underlined link in the Name column to select the policy and display its name
in the Selected list.

3b3 (Optional) Repeat Step 3b1 and Step 3b2 to add additional policies to the Selected list.
3b4 Click OK to add the selected policies to the group.

4 Click Next to display the Summary page. Review the information and, if necessary, use the Back
button to make changes to the information on the Summary page.

5 (Conditional) Select Create as Sandbox, if you want to create the sandbox version of the policy.

6 Click Finish to create the policy group now, or select Define Additional Properties to specify
additional information, such as user assignment, device assignment, and which members the
policy group is a member of.

5.4 Editing Policies

The following table lists the tasks you can perform for a policy:

Task Steps Additional Details

Edit the content of a 1.

policy

Click the policy whose content you
want to edit.

. Click the Details tab, then edit the

settings according to your
requirements.

. Click Apply.

Click the Summary page.

5. Increment the version of the policy

Rename a policy 1.

. Click Edit > Rename, then specify

to enforce the changes made to the
policy on the managed device.

Select the check box next to the If more than one check box is selected,
policy. the Rename option is not available in the
Edit menu.

the new name. If a sandbox exists, the policy is updated

. (Conditional) Select Publish changed to a sandbox.

display name immediately. .
If a sandbox does not exist, you can

Click OK. choose to publish the policy as a new
version or update to a sandbox.
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Task Steps Additional Details

Create a copy of the 1. Select the check box next to the If more than one check box is selected,
policy policy. the Copy option is not available in the

2. Click Edit > Copy, then specify anew -dit menu.

name. The copy option is useful to create a new
policy that is similar to an existing policy.
You can copy a policy and then edit the
new policy's settings.
Move a policy to a 1. Select the check box next to the
different folder policy (or policies).

2. Click Edit > Move, then select the
target folder.

Copy the system 1. Select the check box next to the If more than one check box is selected,
requirements of one policy. the Copy System Requirements option is
policy to another 2. Click Edit > Copy System not available in the Edit menu.

policy Requirements.

3. Select Policies, then click Add to
select the policies to which you want
to copy the selected policy’s system
requirements.

Deleting Policies

1 In ZENworks Control Center, click the Policies tab.
2 Select the check box next to the policy (or policies) that you want to delete.
3 Click Delete.

Adding Policies to Groups

1 In ZENworks Control Center, click the Policies tab.

2 Select the check box next to the policy (or policies) that you want to add to the group.
3 Click Action > Add to Group to display the Existing Group or a New Group page.
4

You can add the selected objects (users, devices, bundles, policies) to an existing group or a new
group.

+ [f the group to which you want to add the objects already exists, select Add selected items
to an existing group, then click Next to continue with Step 5.

+ If you need to create a new group for the selected objects, select Create a new group to
contain the selected items, then click Next to skip to Step 6.

5 (Conditional) If you are adding selected items to an existing group, the Targets page is displayed.
Select the groups to which you want to add the objects (users, devices, bundles, policies).

You can add any number of policies to the group. You cannot add other policy groups to the
group.
5a Click Add to display the Select Groups dialog box.
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Because you are adding policies to the group, the Select Members dialog box opens with
the Pol i ci es folder displayed.

5b Browse for and select the policies you want to add to the group. To do so:

5b1 Click ¢ next to a folder to navigate the folders until you find the policy you want to
select.

If you know the name of the policy you are looking for, you can also use the Item name
box to search for the policy.

5b2 Click the underlined link in the Name column to select the policy and display its name
in the Selected list.

5b3 (Optional) Repeat Step 5a and Step 5b to add additional policies to the Selected list.
5b4 Click OK to add the selected policies to the group.
5c¢ Click Next to skip to Step 7.

6 (Conditional) If you are creating a new group to contain the selected items, the Basic
Information page is displayed. Fill in the following fields, then click Next to continue with Step 7.

Group Name: Provide a unique name for your policy group. The name you provide displays in
the ZENworks Control Center interface.

Folder: Type the name or browse to and select the folder that contains this policy group

Description: Provide a short description of the policy group’s content. This description displays
in ZENworks Control Center.

7 On the Finish page, review the information and, if necessary, use the Back button to make
changes to the information.

8 Click Finish.

5.7 Assigning a Policy to Devices

Certain key points that you must be aware of before you assign a policy to a device are as follows:

+ If you are assigning a Local File Rights policy to a network made up of devices running different
languages, see Section 5.11, “Assigning the Local File Rights Policy to Devices Running Different
Languages,” on page 70.

+ The Dynamic Local User policy and The Roaming Profile policy are not supported on a 64-bit
Windows Server 2003 device.

Perform the following steps to assign a policy to a device:

1 In ZENworks Control Center, click the Policies tab.
2 In the Policies list, select the check box next to the objects such as policies or policy groups.
3 Click Action > Assign to Device.

4 Browse for and select the devices, device groups, and device folders to which you want to
assign the group. To do so:

4a Click ¢ next to a folder (for example, the Wor kst at i ons folder or Ser ver s folder or
Mobi | e Devi ces folder) to navigate through the folders until you find the device, group,
or folder you want to select.
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If you are looking for a specific item, such as a Workstation or a Workstation Group, you
can use the Items of type list to limit the types of items that are displayed. If you know the
name of the item you are looking for, you can use the Item name box to search for the item.

4b Click the underlined link in the Name column to select the device, group, or folder and
display its name in the Selected list box.

4c Click OK to add the selected devices, folders, and groups to the Devices list.
Click Next to display the Policy Conflict Resolution page.

Set the priority between device-associated policies and user-associated policies for resolving
conflicts that arise when policies of the same type are associated to both devices and users.

+ User Last: Select this option to apply policies that are associated to devices first and then
the users.

+ Device Last: Select this option to apply policies that are associated to users first and then
the devices.

+ Device Only: Select this option to apply policies that are associated only to devices.
+ User Only: Select this option to apply policies that are associated only to users.

Click Next to display the Finish page, review the information and, if necessary, use the Back
button to make changes to the information.

If you want the policies to be immediately enforced on all the assigned devices, select Enforce
Policies Immediately on all Assigned Devices.

Polices might not be enforced immediately if the server is loaded, the duration for policies to be
enforced on the managed devices depends upon the server load.

Click Finish.

The following points are applicable when you assign a policy to a device:

*

If you assign a DLU policy to a device on which a user has logged in, the user is prompted to log
in to the device again. Unless the user logs in to the device again, no new policies are enforced
on the device.

When you assign a ZENworks Explorer Configuration Policy to a device, the settings configured
in the policy are not immediately reflected on the device. For example, even if Hide the Z icon in
the taskbar is enabled in the policy, the ZENworks icon is displayed for a few seconds on the
device after the policy is assigned to the device.

If both user-associated and device-associated policies are effective for a device, only the policy
that takes precedence according to the Policy Conflict Resolution settings is applied on the
device. However, the Effective status for both policies is displayed as Success in the ZENworks
Agent icon

User settings of a device associated Group policy cannot be enforced in console sessions of a
Windows Server 2003, Windows Server 2008, or Windows Server 2008 R2 device.

On a managed device, if you launch a published application that is installed on a Citrix server
having iPrint policy configured, it might take considerable time for the policy to be enforced on
the server. During this period, the iPrint functionality is not available for the application.
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5.8 Assigning a Policy to Users

Certain key points that you must be aware of before you assign a policy to a user are as follows

*

There are two types of users: users in the corporate directory and local users on managed
devices. Policies can be associated to users in the corporate directory. ZENworks assumes that a
mapping exists between users in the corporate directory and users on a device. When a user
logs in to the corporate directory, ZENworks obtains the policies for the corporate user and
caches them on the device.

If a mapping exists between a corporate user and a local user, ZENworks also associates the
cached policies with the local user. When a user logs in to the device, the previously cached
policies are enforced for the local user. When the user also logs in to the corporate directory,
the policies for the corporate user are refreshed, then enforced.

The set of policies, both directly assigned and inherited, is called as a set of assigned policies for
a device or a user. When calculating the set of assigned policies, filters such as multiplicity or
system requirements are not applied. Groups and containers also have assigned policies.
Policies that are disabled are not included in the set of assigned policies.

If you are assigning a Local File Rights policy to a network made up of devices running different
languages, see Section 5.11, “Assigning the Local File Rights Policy to Devices Running Different
Languages,” on page 70.

Before assigning a Roaming Profile policy to a user on a Windows Vista device or Windows
Server 2008 device, make sure a user profile with correct registry hive permissions is available
on the device. See Section 5.9, “Assigning a Roaming Profile Policy for a User Profile Stored on a
Windows, Linux, or NetWare Share,” on page 67.

Perform the following steps to assign a policy to a user:

1 In ZENworks Control Center, click the Policies tab.

2 In the Policies list, select the check box next to the objects such as policies or policy groups.

3 Click Action > Assign to User.

4 Browse for and select the user, user groups, and user folders to which you want to assign the

group. To do so:

4a Click ¢ next to a folder to navigate through the folders until you find the user, group, or
folder you want to select.

If you are looking for a specific item, such as a User or a User Group, you can use the Items
of type list to limit the types of items that are displayed. If you know the name of the item
you are looking for, you can use the Item name box to search for the item.

4b Click the underlined link in the Name column to select the user, group, or folder and display
its name in the Selected list box.

4c Click OK to add the selected devices, folders, and groups to the Users list.

5 Click Next to display the Finish page, review the information and, if necessary, use the Back

button to make changes to the information.

6 Click Finish.
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The following points are applicable when you assign a policy to a user:

*

When you assign a ZENworks Explorer Configuration Policy to a user, the settings configured in
the policy are not immediately reflected on the device on which the user logs on. For example,
even if Hide the Z icon in the taskbar is enabled in the policy, the ZENworks icon is displayed for
a few seconds on the device after the policy is assigned to the user.

User assigned policies are not enforced in the console sessions of Windows Server 2003,
Windows Server 2008, and Windows Server 2008 R2 device.

If you launch a published application from a Citrix server on to the device, it might take some
considerable time for the list of the iPrint printers to be displayed on the device.

If you launch a published application installed on a Citrix server that has the iPrint printer policy
configured, it might take considerable time for the policy to be enforced on the server. During
this period, the iPrint functionality is not available for the application.

5.9 Assigning a Roaming Profile Policy for a User Profile
Stored on a Windows, Linux, or NetWare Share

If a default profile already exists at a shared location, start with Step 3 in the following procedure. If
you do not yet have a default profile, start with Step 1.

1

Create a default profile folder in a shared location that will be used to pre-populate each user’s
home directory.

For information on creating the default profile folder, see Section 5.9.1, “Creating a Default
Profile Folder in a Shared Location,” on page 67.

Create the default profile from a Windows Vista device, Windows 2008 device, or a Windows 7
device to the default profile folder in the shared location.

For information on creating the default profile in the shared location, see Section 5.9.2,
“Creating the Default Profile from a Windows Vista, Windows 2008, or Windows 7 Device to the
Default Profile Folder in the Shared Location,” on page 68.

3 Configure the registry hive permissions for the default profile.

For information on configuring the registry hive permissions, see Section 5.9.3, “Configuring the
Permissions for the Default Profile Registry Hive,” on page 68.

5.9.1 Creating a Default Profile Folder in a Shared Location

Create a default profile folder in a shared location, depending on where you want to store the user
profile. For example:

+ User Profile Path: \\ DNS_nane_of _file_ server\profiles\DefaultProfile.V2
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5.9.2 Creating the Default Profile from a Windows Vista, Windows
2008, or Windows 7 Device to the Default Profile Folder in the
Shared Location

Ensure that the user profile you want to copy as a default profile already exists on the device. If the
desired profile is not available, create a new user account and then log in to the device with the new
account credentials to create the profile.

Perform the following steps to copy the default profile to the default profile folder in the shared
location:

A U1 A W N =
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9
10

Log in to the device as an administrator.

Right-click Computer, then click Properties > Advanced system settings.
In the User Profiles section, click Settings.

Select a profile on the device to store as a default profile.

Click Copy To.

Browse to and select the default profile folder you created in Section 5.9.1, “Creating a Default
Profile Folder in a Shared Location,” on page 67.

Click Change in the Permitted to Use section.

Specify Everyone in the Enter the object name to select option to provide permissions, then click
OK.

Click OK to copy the profile to the shared location, then click OK.
Click OK.

5.9.3 Configuring the Permissions for the Default Profile Registry Hive

1

To open the Registry Editor when the shared location is on a Windows device, runr egedi t .
or

To open the Registry Editor when the shared location is on a Linux or NetWare device, map the
location from a Windows device, then open the Registry Editor on the Windows device.

Select HKEY USERS, then click File > Load Hive.

Open the NTUSER. DAT file from the default profile folder created in Section 5.9.1, “Creating a
Default Profile Folder in a Shared Location,” on page 67.

The NTUSER. DAT file might be hidden. To unhide the file:
1. Open the default profile folder in Windows Explorer.
2. Click Tools > Folder Options > View.

3. Deselect Hide protected operating system files.

In the Load Hive dialog box, specify the Key Name for the hive. For example, Vista.

5 Right-click the Vista hive, then click Permissions.

Ensure that the following groups or usernames have Full Control permissions:

+ Everyone
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5.9.4

5.9.5

5.9.6

+ SYSTEM
+ Authenticated Users
7 Click Advanced.

8 Select the Replace permission entries on all child objects with entries shown here that apply to
child objects option, click OK, then click Yes.

9 Click OK.

10 To unload the hive, select the Vista registry hive that you created, then click File > Unload Hive.

Copying the Default Profile to User Folders

Ensure that you copy the default profile from Section 5.9.3, “Configuring the Permissions for the
Default Profile Registry Hive,” on page 68 to the user folders before assigning the Roaming Profile
policy to the users. Depending on the user profiles stored, these user folders are:

+ User Profile Path:\\ UNC_Pat h_of User's Hone Directory\Wndows NT 6.1
Workstation Profile. V2

Configuring Novell Client 2 for Windows 7

Under the Advanced Login Tab in the Novell Client Properties Window, ensure that “Allow Roaming
User Profile paths to non-Windows servers is enabled. (Note: This is the default value.)

Enable Do not check for user Ownership of Roaming Profile
Folders

Incase Novell Client 2 for Windows 7 is installed, enabling Do not check for user ownership of
roaming profile folders is not required unless Group Policy is configured to override the Novell Client
settings.

1 Create or Edit a Group Policy Object.

2 Browse to the following folder: Conput er Confi gurati on\ Adm ni strative
Tenpl at es\ Syst eml User Profiles.

3 In the right pane, double click Do not check for user Ownership of Roaming Profile Folders.
4 Click Enabled.
5 Click OK.
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5.10 Assigning a Roaming Profile Policy for a User Profile
Stored on a Home Directory

If a Roaming Profile policy is assigned to a user, the policy fails if the user profile is stored on Linux or
NetWare Home Directory. This is because the registry hive of the user profile does not have
permissions to load the profile to other devices. If a default profile already exists at a shared
location, you need to configure the permissions for the default profile registry hive.

For more information, see TID 7007207 in the Novell Support Knowledgebase (http://
www.novell.com/support/search.do?usemicrosite=true&searchString=7007207).

To Configure the Permissions for the Default Profile Registry Hive

1 At the shared location, run r egedi t to open the Registry Editor.

If the shared location is on a NetWare or Linux device, map the location from a Windows device
then open the Registry Editor on the Windows device.

2 Select HKEY_USERS, then click File > Load Hive.
3 Open the NTUSER. DAT file from the default profile folder.
The NTUSER. DAT file might be hidden. To unhide the file:
3a Open the default profile folder in Windows Explorer.
3b Click Tools > Folder Options > View.
3c Deselect Hide protected operating system files.
4 In the Load Hive dialog box, specify the Key Name for the hive. For example, Vista.
5 Right-click the Vista hive, then click Permissions.
6 Ensure that the following groups or usernames have Full Control permissions:
¢ Administrators
* SYSTEM
+ Users
7 Click Advanced.

8 Select the Replace permission entries on all child objects with entries shown here that apply to
child objects option, click OK, then click Yes.

9 Click OK.

10 To unload the hive, select the Vista registry hive that you created, then click File > Unload Hive.

5.11 Assigning the Local File Rights Policy to Devices
Running Different Languages

1 Create a separate Local File Rights policy for each language. For more information on creating
the policy, see Section 3.3, “Local File Rights Policy,” on page 29.

2 Add afilter for each policy:
2a Click the policy, then click Requirements.

2b Click Add Filter, select the Registry Key Value condition, then specify the following:
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Key:

\ HKEY_ LOCAL MACHI NE\ SOFTWARE\ M cr osof t \ W ndowsNT\ Cur r ent Ver si on\ WOW
\ boot . descri ption

Value: | anguage. dl |
Comparator: = (String Type)
Value Data: language

For example, on a device with the English language, language is English (American). You can
use the registry editor to determine the value data of the language.

2c Click Apply.

3 Assign the policy to the device. For more information on assigning a policy to a device, see
Section 5.7, “Assigning a Policy to Devices,” on page 64.

or

Assign the policy to the user. For more information on assigning a policy to a user, see
Section 5.8, “Assigning a Policy to Users,” on page 66.

5.12 Unassigning a Policy from Devices

In ZENworks Control Center, click the Policies tab.
In the Policies list, click the policy you want to unassign.
Click Relationships.

In the Device Assignments panel, select the devices from which you want to unassign the policy.

g A W N =

Click Remove.

On a Windows Server 2008 device, the Group policy user settings associated to a user are not
unenforced when the user logs out.

5.13 Unassigning a Policy from Users

1 In ZENworks Control Center, click the Policies tab.

2 In the Policies list, click the policy you want to unassign.

3 Click Relationships.

4 In the User Assignments panel, select the users from whom you want to unassign the policy.

5 Click Remove.

When you unassign a printer policy that is assigned to a user, the printer permissions for the user
are removed from the device. However, the printer continues to be configured on the device.
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5.14.1

Adding System Requirements for a Policy

The System Requirements panel lets you define specific requirements that a device must meet for
the specified version of the policy to be assigned to it. You can choose to edit the requirement.

You define requirements through the use of filters. A filter is a condition that must be met by a
device in order for the policy to be applied. For example, you can add a filter to specify that the
device must have exactly 512 MB of RAM in order for the policy to be applied, and you can add
another filter to specify that the hard drive be at least 20 GB in size.

To create system requirements for a policy:

1 In ZENworks Control Center, click the Policies tab.

2 Click the underlined link for the desired policy to display the policy’s Summary page.
3 Click the Requirements tab.

4 Click Add Filter, select a filter condition from the drop-down list, then fill in the fields.

As you construct filters, you need to know the conditions you can use and how to organize the
filters to achieve the desired results. For more information, see Section 5.14.1, “Filter
Conditions,” on page 72 and Section 5.14.2, “Filter Logic,” on page 78.

5 (Conditional) Add additional filters and filter sets.
6 Click Apply to save the settings.

Filter Conditions

You can choose from any of the following conditions when creating a filter:

Architecture: Determines the architecture of Windows running on the device. The condition you use
to set the requirement includes a property, an operator, and a property value. The possible
operators are equals (=) and does not equal (<>). For example, if you set the condition to
architecture = 32, the device’s Windows operating system must be 32-bit to meet the requirement.

Bundle Installed: Determines if a specific policy is installed. After specifying the bundle, the two
conditions you can use to set the requirement are Yes and No. If you select Yes, the specified bundle
must already be installed to meet the requirement. If you select No, the bundle must not be
installed.

Configuration Location: Determines if the policy is applicable to a specific location. The condition
you use to set the requirement includes an operator and a value. The possible operators are equals
(=) and does not equal (<>). The values are the existing locations in the Management Zone. For
example, if you set the condition to =l ocat i on_nan®, the selected location must match the
device’s location to meet the requirement.

NOTE: This system requirement is applicable for Linux Configuration Policies and Windows
Configuration Policies only.

Configuration Network Environment: Determines if the policy is applicable to a specific network
environment. The condition you use to set the requirement includes an operator and a value. The
possible operators are equals (=) and does not equal (<>). The values are the existing network
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environments in the Management Zone. For example, if you set the condition to
=net wor k_envi r onment _nane, the selected network environment must match the device’s
current network environment to meet the requirement.

NOTE: This system requirement is applicable for Linux Configuration Policies and Windows
Configuration Policies only.

Connected: Determines if the device is connected to a network. The two conditions you can use to
set the requirement are Yes and No. If you select Yes, the device must be connected to the network
to meet the requirement. If you select No, it must not be connected.

Connection Speed: Determines the speed of the device’s connection to the network. The condition
you use to set the requirement includes an operator and a value. The possible operators are equals
(=), does not equal (<>), is greater than (>), is greater than or equal to (>=), is less than (<), and is less
than or equal to (<=). The possible values are bits per second (bps), kilobits per second (Kbps),
megabits per second (Mbps), and gigabits per second (Gbps). For example, if you set the condition to
>= 100 Mops, the connection speed must be greater than or equal to 100 megabits per second to
meet the requirement.

Disk Space Free: Determines the amount of free disk space on the device. The condition you use to
set the requirement includes a disk designation, an operator, and a value. The disk designation must
be a local drive map (for example, c: or d:). The possible operators are equals (=), does not equal
(<>), is greater than (>), is greater than or equal to (>=), is less than (<), and is less than or equal to
(<=). The possible values are bytes (Bytes), kilobytes (KB), megabytes (MB), and gigabytes (GB). For
example, if you set the conditiontoc: >= 80 MB, the free disk space must be greater than or equal
to 80 megabytes to meet the requirement.

Disk Space Total: Determines the amount of total disk space on the device. The condition you use to
set the requirement includes a disk designation, an operator, and a value. The disk designation must
be a local drive map (for example, c: or d:). The possible operators are equals (=), does not equal
(<>), is greater than (>), is greater than or equal to (>=), is less than (<), and is less than or equal to
(<=). The possible values are bytes (Bytes), kilobytes (KB), megabytes (MB), and gigabytes (GB). For
example, if you set the conditiontoc: >= 40 GB, the total disk space must be greater than or
equal to 40 gigabytes to meet the requirement.

Disk Space Used: Determines the amount of used disk space on the device. The condition you use to
set the requirement includes a disk designation, an operator, and a value. The disk designation must
be a local drive map (for example, c: or d:). The possible operators are equals (=), does not equal
(<>), is greater than (>), is greater than or equal to (>=), is less than (<), and is less than or equal to
(<=). The possible values are bytes (Bytes), kilobytes (KB), megabytes (MB), and gigabytes (GB). For
example, if you set the conditiontoc: <= 10 GB, the used disk space must be less than or equal to
10 gigabytes to meet the requirement.

Environment Variable Exists: Determines if a specific environment variable exists on the device.
After specifying the environment variable, the two conditions you can use to set the requirement
are Yes and No. If you select Yes, the environment variable must exist on the device to meet the
requirement. If you select No, it must not exist.

Environment Variable Value: Determines if an environment variable value exists on the device. The
condition you use to set the requirement includes the environment variable, an operator, and a
variable value. The environment variable can be any operating system supported environment
variable. The possible operators are equal to, not equal to, contains, and does not contain. The
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possible variable values are determined by the environment variable. For example, if you set the
condition to Pat h cont ai ns c:\w ndows\ syst enB2, the Path environment variable must
contain the c: \ wi ndows\ syst enB2 path to meet the requirement.

File Date: Determines the date of a file. The condition you use to set the requirement includes the
filename, an operator, and a date. The filename can be any filename supported by the operating
system. The possible operators are on, after, on or after, before, and on or before. The possible dates
are any valid dates. For example, if you set the condition to appl. nsi on or after 6/15/07,
the appl. nsi file must be dated 6/15/2007 or later to meet the requirement.

File Exists: Determines if a file exists. After specifying the filename, the two conditions you can use
to set the requirement are Yes and No. If you select Yes, the specified file must exist to meet the
requirement. If you select No, the file must not exist.

File Size: Determines the size of a file. The condition you use to set the requirement includes the
filename, an operator, and a size. The filename can be any file name supported by the operating
system. The possible operators are equals (=), does not equal (<>), is greater than (>), is greater than
or equal to (>=), is less than (<), and is less than or equal to (<=). The possible sizes are designated in
bytes (Bytes), kilobytes (KB), megabytes (MB), and gigabytes (GB). For example, if you set the
condition to docl. pdf <= 3 MB, the docl. pdf file must be less than or equal to 3 megabytes to
meet the requirement.

File Version: Determines the version of a file. The condition you use to set the requirement includes
the filename, an operator, and a version. The filename can be any file name supported by the
operating system. The possible operators are equals (=), does not equal (<>), is greater than (>), is
greater than or equal to (>=), is less than (<), and is less than or equal to (<=).

Be aware that file version numbers contain four components: Major, Minor, Revision, and Build. For
example, the file version for cal c. exe might be 5.1.2600.0. Each component is treated
independently. For this reason, the system requirements that you set might not provide your
expected results. If you do not specify all four components, wildcards are assumed.

For example, if you set the condition to cal c. exe <= 5, you are specifying only the first
component of the version number (Major). As a result, versions 5.0.5, 5.1, and 5.1.1.1 also meet the
condition.

However, because each component is independent, if you set the condition to cal ¢c. exe <= 5.1,
the cal c. exe file must be less than or equal to version 5.1 to meet the requirement.

IP Segment: Determines the device’s IP address. After specifying the IP segment name, the two
conditions you can use to set the requirement are Yes and No. If you select Yes, the device’s IP
address must match the IP segment. If you select No, the IP address must not match the IP segment.

Linux Service Pack: Determines whether the Linux Operating System on the managed device has
been upgraded to a particular Service Pack. For example, if you add a system requirement, Li nux
Servi ce Pack >= 2, if using a SLES 10 box, the requirement is satisfied only when the Operating
System has been upgraded to SLES 10 SP 2. The possible operators are equals (=), does not equal
(<>), is greater than (>), is greater than or equal to (>=), is less than (<), and is less than or equal to

(<=).

Linux Kernel Version: Determines the version of the core Linux kernel installed on the managed
device. For example, if you add a system requirement, Li nux Ker nel Versi on >= 2. 6, then the
requirement evaluates to true only if kernel version is actually greater than or equal to 2.6, say if it's
2.6.16 and so on. The possible operators are equals (=), does not equal (<>), is greater than (>), is
greater than or equal to (>=), is less than (<), and is less than or equal to (<=).
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Linux Distribution: Determines the flavour of the Linux Operating System installed and differentiates
between architecture and version of the desktop or server installed. For example, if you add a
system requirement, Li nux Di stribution = SUSE Linux Enterprise Desktop 11 -

i 586, then the requirement evaluates to true only on SLED 11 32 bit managed devices. The possible
operators are equals (=) and does not equal (<>).

Logged on to Primary Workstation: Determines whether the user is logged on to his or her primary
workstation. The two conditions you can use to set the requirement are Yes and No. If you select Yes,
the user must be logged on to his or her primary workstation to meet the requirement. If you select
No, and no user is logged on to the workstation, the requirement is not met. However, if a user other
than the primary user is logged on to the workstation, the requirement is met.

Memory: Determines the amount of memory on the device. The condition you use to set the
requirement includes an operator and a memory amount. The possible operators are equals (=),
does not equal (<>), is greater than (>), is greater than or equal to (>=), is less than (<), and is less
than or equal to (<=). The memory amounts are designated in megabytes (\MB) and gigabytes (GB).
For example, if you set the condition to >= 2 @B, the device must have at least 2 gigabytes of
memory to meet the requirement.

Novell Client Installed: Determines if the device is using the Novell Client for its network
connection. The two conditions you can use to set the requirement are Yes and No. If you select Yes,
the device must be using the Novell Client to meet the requirement. If you select No, it must not be
using the Novell Client.

Operating System - Windows: Determines the service pack level, server type, and version of
Windows running on the device. The condition you use to set the requirement includes a property,
an operator, and a property value. The possible properties are service pack, server type, and version.
The possible operators are equals (=), does not equal (<>), is greater than (>), is greater than or equal
to (>=), is less than (<), and is less than or equal to (<=). The property values vary depending on the
property. For example, if you set the condition tover si on = W ndows XP Versi ons, the
device’s Windows version must be XP to meet the requirement.

NOTE: Be aware that operating system version numbers contain four components: Major, Minor,
Revision, and Build. For example, the Windows 2000 SP4 release’s number might be
5.0.2159.262144. Each component is treated independently. For this reason, the system
requirements that you set might not provide your expected results.

For example, if you specify Operating System - Windows in the first field, Version in the second field,
> in the third field, and 5.0 -Windows 2000 Versions in the last field, you are specifying only the first
two components of the version number: Major (Windows) and Minor (5.0). As a result, for the
requirement evaluated to true, the OS will have to be at least 5.1 (Windows XP). Windows 2003 is
version 5.2, so specifying > 5.2 will also evaluate to true.

However, because each component is independent, if you specify the version > 5.0, Windows 2000
SP4 evaluates to false because the actual version number might be 5.0.2159.262144. You can type
5.0.0 to make the requirement evaluate as true because the actual revision component is greater
than 0.

When you select the OS version from the drop-down, the Major and Minor components are
populated. The Revision and Build components must be typed in manually.
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Primary User Is Logged In: Determines if the device’s primary user is logged in. The two conditions
you can use to set the requirement are Yes and No. If you select Yes, the primary user must be logged
in to meet the requirement. If you select No, the user must not be logged in.

Process Running: Determines if a process is running. After specifying the process name, the two
conditions you can use to set the requirement are Yes and No. If you select Yes, the specified process
must be running to meet the requirement. If you select No, the process must not be running.

NOTE: This system requirement is applicable only for servers and agents with ZENworks 2017
Update 4.

Processor Family: Determines the device’s processor type. The condition you use to set the
requirement includes an operator and a processor family. The possible operators are equals (=) and
does not equal (<>). The possible processor families are Pentium, Pentium Pro, Pentium II, Pentium
I1l, Pentium 4, Pentium M, WinChip, Duron, BrandID, Celeron, and Celeron M. For example, if you set
the condition to <> Cel er on, the device’s processor can be any processor family other than
Celeron to meet the requirement.

Processor Speed: Determines the device’s processor speed. The condition you use to set the
requirement includes an operator and a processor speed. The possible operators are equals (=), does
not equal (<>), is greater than (>), is greater than or equal to (>=), is less than (<), and is less than or
equal to (<=). The possible processor speeds are hertz (Hz), kilohertz (KHz), megahertz (MHz), and
gigahertz (GHz). For example, if you set the conditionto >= 2 CGHz, the device’s speed must be at
least 2 gigahertz meet the requirement.

Registry Key Exists: Determines if a registry key exists. After specifying the key name, the two
conditions you can use to set the requirement are Yes and No. If you select Yes, the specified key
must exist to meet the requirement. If you select No, the key must not exist.

Registry Key Value: Determines if a registry key value exists on the device. The condition you use to
set the requirement includes the key name, the value name, an operator, a value type, and a value
data. The key and value names must identify the key value you want to check. The possible
operators are equals (=), does not equal (<>), is greater than (>), is greater than or equal to (>=), is
less than (<), and is less than or equal to (<=). The possible value types are INT_TYPE and STR_TYPE.
The possible value data is determined by the key, value name, and value type.

If the value type is String Type, ZCM compares only those values in the registry if the actual type in
the registry is REG_STRING or REG_EXPANDED_STRING.

If the value type is Integer, ZCM compares only those values in the registry if the actual type in the
registry is REG_DWORD.

Leave the key value field blank to use the default value. The default value of a registry key has no
name and is displayed in regedit as ( Def aul t) .

For example, if you specify HKEY LOCAL MACHI NE\ SOFTWARE\ Novel | \ Messenger\ Logi n as
the key name, Port as the value name, select = as the operator, select Integer Type as the value
type, and specify 443 as the value data, the port specified as the value data must match with the
port specified in the registry key to meet the requirement.

If the value type is IP Address, ZCM compares only those values in the registry if the actual type in
the registry is REG_STRING.
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NOTE: The filter condition Registry Key Value is available only for Windows policies. The value type IP
Address for Registry Key Value is applicable only in VDI environments (VMwareVDI and CitrixVDI).

If you have set the condition to Registry Key Value and selected IP Address as the value type, then the
two conditions that you can use to set the requirements are Is in Subnet and Is not in Subnet. If you
select Is in Subnet, then the thin-client IP address of the device must be within a specific subnet. If

you select Is not in Subnet, then the thin-client IP address of the device must be outside the subnet.

Specify the following in the text fields:

+ Path of the registry key that should be compared
+ Name of the registry value, for example: Vi ewCl i ent _| P_Addr ess

+ |P Address of the network and a subnet mask to compare in order to determine if the device is
within the segment (Example: 10.0.0.0/24)

For the VMware-VDI Environment

If you are connected to a VMware desktop from any thin client, the following registry key will be
created automatically in the VMware desktop, indicating the thin-client IP address through which it
is connected. You can use the same Registry key as a filter to specify the filter requirement.

Example 5-1 Example:

Registry key Path: HKEY CURRENT USER\ Vol ati | e Environment
Registry key Name: Vi ewd i ent _| P_Address

Value: This specifies the thin-client IP address through which you are connected to the VMware
desktop. This value should be in the CIDR format for both Is in Subnet and Is not in Subnet (Example:
10.0.0.0/24).

For the Citrix- VDI Environment

If you are connected to a Citrix desktop from any thin client, the following registry key will be created
automatically in the Citrix desktop, indicating the thin-client IP address through which it is
connected. You can use the same registry key as a filter to specify the filter requirement.

Example 5-2 Example:

Registry key path: HKEY_LOCAL_MACHI NE\ SOFTWARE\ Ci tri x\ | ca\ Sessi on
Registry key name: Cl i ent Addr ess

Value: This specifies the thin-client IP address through which you are connected to the Citrix desktop
(Example: 10.0.0.0/24).

Registry Key and Value Exists: Determines if a registry key and value exists. After specifying the key
name and value, the two conditions you can use to set the requirement are Yes and No. If you select
Yes, the specified key and value must exist to meet the requirement. If you select No, the key and
value must not exist.
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5.14.2

Security Location: Determines if the policy is applicable for a specific security location. The
condition you use to set the requirement includes an operator and a value. The possible operators
are equals (=) and does not equal (<>). The values are the existing security locations in the
Management Zone. For example, if you set the condition to =security_| ocati on_nane, the
selected security location must match the device’s security location to meet the requirement.

NOTE: This system requirement is applicable for Linux Configuration Policies and Windows
Configuration Policies only. The system requirement is applied to a managed device only if the
Location Assignment Policy has been applied to the device. If the policy has Security Location system
requirement configured, the policy enforcement fails on Windows Server 2003 and Windows Server
2008 devices because the ZENworks Endpoint Security Management policies are not supported on
these devices.

Service Exists: Determines if a service exists. After specifying the service name, the two conditions
you can use to set the requirement are Yes and No. If you select Yes, the service must exist to meet
the requirement. If you select No, the service must not exist.

Service Running: Determines if a service is running. After specifying the service name, the two
conditions you can use to set the requirement are Yes and No. If you select Yes, the specified service
must be running to meet the requirement. If you select No, the service must not be running.

NOTE: This system requirement is applicable only for servers and agents with ZENworks 2017
Update 4.

Specified Devices: Determines if the device is one of the specified devices. After specifying the
devices, the two conditions you can use to set the requirement are Yes and No. If you select Yes, the
device must be included in the specified devices list to meet the requirement (an inclusion list). If
you select No, the device must not be included in the list (an exclusion list).

Version of RPM: Determines the version of the RPMname provided if installed. For example, if you
add a system requirement, Ver si on of RPM cups > 1.0, then the requirement evaluates to
true, if cups rpm is installed and the version of the installed cups rpm is greater than 1.0. If cups rpm
is not installed, the requirement is evaluated to be false. The possible operators are equals (=), does
not equal (<>), is greater than (>), is greater than or equal to (>=), is less than (<), and is less than or
equal to (<=).

Filter Logic

You can use one or more filters to determine whether the policy should be applied to a device. A
device must match the entire filter list (as determined by the logical operators that are explained
below) for the policy to be applied to the device.

There is no technical limit to the number of filters you can use, but there are practical limits, such as:

+ Designing a filter structure that is easy to understand

+ Organizing the filters so that you do not create conflicting filters
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5.15

Filters, Filter Sets, and Logical Operators

You can add filters individually or in sets. Logical operators, either AND or OR, are used to combine
each filter and filter set. By default, filters are combined using OR (as determined by the Combine
Filters Using field) and filter sets are combined using AND. You can change the default and use AND
to combined filters, in which case filter sets are automatically combined using OR. In other words,
the logical operator that is to combine individual filters (within in a set) must be the opposite of the
operator that is used between filter sets.

You can easily view how these logical operators work. Click both the Add Filter and Add Filter Set
options a few times each to create a few filter sets, then switch between AND and OR in the Combine
Filters Using field and observe how the operators change.

As you construct filters and filter sets, you can think in terms of algebraic notation parentheticals,
where filters are contained within parentheses, and sets are separated into a series of parenthetical
groups. Logical operators (AND and OR) separate the filters within the parentheses, and the
operators are used to separate the parentheticals.

For example, “(u AND v AND w) OR (x AND y AND z)” means “match either uvw or xyz.” In the filter
list, this looks like:

Nested Filters and Filter Sets

Filters and filter sets cannot be nested. You can only enter them in series, and the first filter or filter
set to match the device is used. Therefore, the order in which they are listed does not matter. You
are simply looking for a match to cause the policy to be applied to the device.

Disabling Policies

When you create a policy in ZENworks Configuration Management, the policy is enabled by default.
Policies can be disabled by an administrator. If a policy is disabled, it is not considered for
enforcement on any of the devices and users that it applies to.

To disable a policy:

1 In ZENworks Control Center, click the Policies tab.
2 Select the check box next to the policy (or policies) that you want to disable.
3 Click Action > Disable Policies.
In the Policies list, the status of Enabled for the policy (or policies) is changed to No.

When you disable a policy that has already been enforced for some managed devices and users,
the policy is removed from those devices and it is not enforced for new devices and users.
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5.16 Enabling the Disabled Policies

1 In ZENworks Control Center, click the Policies tab.
2 Select the check box next to the policy (or policies) that you want to enable.
3 Click Action > Enable Policies.

In the Policies list, the status of the Enabled column for the policy (or policies) is changed to Yes.

5.17 Copying a Policy to a Content Server

By default, a policy is copied to each content server. If you specify certain content servers as hosts,
the policy is hosted on only those content servers; it is not copied to all content servers. You can also
specify whether the selected policy is replicated to new content servers (ZENworks Servers and
satellite servers) that are added to the Management Zone.

To specify a content server:

1 In ZENworks Control Center, click the Policies tab.
2 In the Policies list, select the check box next to the policy (or policies).

3 Click Action > Specify Content Server to display the New Content Replication Rules page.

Wizard
&N Step 1: New Server Content Replication Rules

Choose whether you would like new servers added to the system, to replicate the content selected
by this wizard.

WARNING: Any content replication relationships previously set between the content and
servers selected by this wizard will be LOST.

For the selected content, please choose the default replication behavior for new servers added to
the system:

New Primary Servers will:

@ Include this content
O Exclude this content

New Satellite Servers will:

@ Include this content
O Exclude this content

4 Specify the default replication behavior for new serve