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Designer for Identity Manager:
Help

Designer for Identity Manager can help you design, test, document, and deploy Identity Manager-
based solutions in a highly productive environment.

Newcomers can use wizards to build Identity Management solutions. Veterans and expert users can
bypass the wizards and interact directly at any level of detail.

Audience

This guide is for enterprise IT professionals and developers, consultants, sales engineers, architects
or system designers, and system administrators.

Feedback

We want to hear your comments and suggestions about this manual and the other documentation
included with this product. Please use the User Comment feature at the bottom of each page of the
online documentation, or go to www.novell.com/documentation/feedback.html and enter your
comments there.

Documentation Updates

For the most recent version of the Designer for Identity Manager: Administration Guide, visit the
Identity Manager Web site (http://www.novell.com/documentation/idm35/).

Documentation Conventions

In Novell® documentation, a greater-than symbol (>) is used to separate actions within a step and
items in a cross-reference path.

A trademark symbol (®, ™ etc.) denotes a Novell trademark. An asterisk (*) denotes a third-party
trademark.

When a single pathname can be written with a backslash for some platforms or a forward slash for
other platforms, the pathname is presented with a backslash. Users of platforms that require a
forward slash, such as Linux* or UNIX*, should use forward slashes as required by your software.

Additional Documentation

¢ Identity Manager 3.5.1 Installation Guide

* Novell Identity Manager 3.5.1 Administration Guide

¢ Understanding Policies for Identity Manager 3.5.1

¢ Policies in Designer 2.1

¢ Novell Credential Provisioning Policies for Identity Manager 3.5.1
¢ Identity Manager 3.5.1 DTD Reference

Designer for Identity Manager: Help
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¢ Identity Manager 3.5 User Application: Design Guide (http://www.novell.com/documentation/
idm35/index.html?page=/documentation/idm35/dgpro/data/bookinfo.html)

¢ Driver guides (http://www.novell.com/documentation/idm35drivers/index.html)
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What’s New

¢ Section 1.1, “What’s New in Designer 2.1,” on page 17

1.1 What’s New in Designer 2.1

To find out what’s new in Designer 2.1:

1 Run Designer for Identity Manager.

Help

B
id5) Welcome

{7) Help Contents
‘I Search
Diynamic Help

Key fzsist,. Clrl+5hift+L

Check for Designer Updates

=] Designer Readme
:@T Report a Bug or Give Feedback
2L Identity Manager Forums

N |dentity Manager Resources

About Designer

2 Click Help > What's New.

You can also click Help > Help Contents > Designer for Identity Manager > What s New in
Designer.

What's New 17
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Designer Concepts

Designer is a powerful, graphical toolset that helps you configure and deploy Identity Manager.

Figure 2-1 The Outline View, Modeler, and Palette in Designer
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An Identity Vault stores data and definitions. The Identity Manager engine manages the flow of data
in and out of the Identity Vault as well as between other systems and directories. Drivers tie the
systems together and ensure that communication flows smoothly, regardless of formats used.
Designer’s user interface uses an abstraction of the data in order to remain flexible without
impacting existing data and definitions, until you decide to deploy the model that you have designed

and tested.

¢ Section 2.1, “Target Audience,” on page 20

¢ Section 2.2, “Identity Manager: Overview,” on page 20

¢ Section 2.3, “Designer’s Features,” on page 22

¢ Section 2.4, “Highly Productive Environment,” on page 22

¢ Section 2.5, “Tools for Developers,” on page 23

¢ Section 2.6, “Features That Require Identity Manager 3.x Engines,” on page 23

¢ Section 2.7, “Designer and iManager,” on page 26
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2.1 Target Audience

Designer was created for the following audiences:

¢ Enterprise IT developers

¢ Consultants

¢ Sales engineers

¢ Architects or system designers

¢ System administrators
This tool is aimed at information technology professionals who

+ Have a strong understanding of directories, databases, and their information environment

¢ Actin the role of a designer or architect of identity-based solutions

You don’t need to be a developer or programmer to fully make use of every aspect of this tool. We
provide many capabilities for developers to extend this tool to suit their own needs.

Wizards make this tool easy to learn and use for building Identity Management solutions.
Experienced users can bypass the wizards and interact directly at any level of detail.

You can also use Designer as an effective and valuable tool to help communicate key Identity
Solution concepts and design to strategic decision makers in the organization. You can use the visual
Modeler as well as documentation that captures and displays Designer data.

2.2 ldentity Manager: Overview

¢ Section 2.2.1, “Managing Identities, Access, and Groups,” on page 20

¢ Section 2.2.2, “How Identity Manager Works,” on page 21

2.2.1 Managing Identities, Access, and Groups

Identity Manager (formerly known as DirXML®) is a cross-platform service that helps you manage
identity information across select systems on your corporate network or your partners’ networks.
For more information on the Novell® solution, visit the Novell Identity Manager Web site (http://
www.novell.com/products/identitymanager).

Identity Manager helps you manage identity information in any system for which Novell provides a
special connector (and for connectors that you or a third party write). Novell provides connectors
that interface with popular applications, databases and directories, including PeopleSoft*, SAP*
HR, GroupWise®, Microsoft* Exchange, Lotus* Notes*, Oracle*, and Microsoft Active Directory*.
(An asterisk--*--denotes a third-party trademark.)

Identity Manager helps you securely manage the access needs of your ever-changing user
community. You can manage the full user life cycle and deliver first-day access to essential
resources. For example, when you create a new user in your HR database (or a customer or partner
in the customer’s related application), all of the user’s accounts are generated automatically,
according to your business rules, and any necessary resources or services are supplied.

You can also quickly and consistently manage groups. For example, you can automatically grant
access rights to everyone with a given role. You can also synchronize multiple passwords into a
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single login, modify or revoke access rights instantly, and even support compliance with
government regulations.

Former employees pose a common threat to many businesses, but Novell Identity Manager closes
this security loophole. The moment you change an employee’s status to dismissed in an authoritative
data source, Identity Manager terminates the user’s accounts and access rights in all specified
systems, and provides an audit report of the successfully revoked user access rights. Your
confidential resources remain safe, and you eliminate countless hours of manual, error-prone
administration.

With its Metadirectory capabilities, Identity Manager enables an identity integration foundation for
unifying identities across platforms, systems and organizational boundaries. It permits departments
to maintain control of the identity data that they are responsible for.

At the same time, the enterprise as a whole gains a single virtual identity for each user by

¢ Linking scattered identity information

+ Setting rules that govern automatic updates to all designated systems when a change is made in
an authoritative source

This foundation serves as the underlying architecture for password management, user provisioning,
white pages, role-based administration, and other capabilities.

Since August 2002, Novell has been in the Leader quadrant of Gartner Metadirectory Magic
Quadrant. Novell offers the most flexible identity management solution on the market. This solution
adapts to each customer’s needs and business rules, enables enterprises to automate processes for
quick and efficient deployment, and provides the flexibility to customize and adapt the solution as
requirements evolve.

2.2.2 How ldentity Manager Works

To control when and how identity information is exchanged between these systems, you configure
the systems’ respective connectors by creating various types of rules. You base these rules on your
company’s needs and on its relationship with partners and employees.

Identity Manager uses Extensible Markup Language (XML) and extensible Stylesheet Language
Transformations (XSLT), the two formats in which DirXML rules have traditionally been
represented. Identity Manager 3.5 and later include features that exceed traditional DirXML
capabilities by significantly simplifying the rule-building (business policy) process and by
simplifying password management.

Novell Identity Manager runs on eDirectory™ 8.7.3 or later and supports all of the platforms that
eDirectory supports, including NetWare®, Microsoft Windows* NT/2000, Red Hat* Linux,
Solaris*, AIX* and HP-UX*. (For specific version numbers, visit the Novell eDirectory Web site
(http://www.novell.com/products/edirectory/sysreqs.html).

For an article on how Identity Manager works, see Too Many Directories? (http://www.novell.com/
connectionmagazine/2000/05/DirXML50i.final.pdf).

Also, see the Novell Identity Manager (http://www.novell.com/products/identitymanager/) Web site.

Designer Concepts
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2.3 Designer’s Features

Designer enables you to do the following:

*

*

*

*

Carry projects with you, work offline, and save projects to disk.
Keep a project open for an extended period of time.
Work on multiple projects at the same time.

Experience higher performance while designing and developing a model. Processing is
performed on the local CPU.

Enjoy a smoother interface with fewer clicks and fewer sub-windows to resize or close.

Benefit from an included development/debugging environment and integration with other
client-based tools for editing and debugging.

For a list of features, and details about them, see Appendix A, “Designer: An Effective Tool,” on
page 517.

2.4 Highly Productive Environment

The following help you be highly productive in your environment:

*

Rich-client environment: work in a highly productive rich-client environment, with a native
look and feel

Disconnected mode: work well in a disconnected mobile environment when you’re “on the go”
Strong visual editors, minimal pop-ups, and well-synchronized views laid out to maximize
productivity

Powerful window, view, perspective, and tool management

Reduction of steps to configure solutions

Wizards to help you get started and configure projects

Auto-creation of objects, auto-value, auto-connection, auto-layouts

Strong copy/paste within and across editors

Full keyboard support in all editors in a way that only a client can perform

Full undo/redo in most editors and views

Ability to scale the UI from basic to more advanced views

Ability to filter key views to see as much or as little as you need to see

Integrated XML editor with syntax highlighting, auto-suggest, and search and replace
Very efficient, compact, powerful, and productive off-line schema management tools
Value history on many fields to reduce typing

Many preferences and settings that tailor the UI to how you want to use the product

Logs and traces that are easy to access and view

Thorough contextual help and powerful searchable help system

Quick and very easy installation

Auto-Update

Auto-update installation notifies you of any updates and easily pulls them in.
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2.5 Tools for Developers

¢ Easily add and model something not in the shipping version.

For example, you can add your own applications, drivers, resources, and icons.
¢ Configure Designer to use a different editor.

Configure all file types (for example, . xm1 and . txt) to use your editor of choice. Eclipse-
based editors work best, but you can also include various artifacts (for example, word
processing documents and spreadsheets). The native editor is automatically integrated into
Designer if the platform supports it.

¢ Develop and debug in Java*.

If you install Designer plug-ins into a full Eclipse install, you can do Java development and
debugging, ANT, C#, and UML modeling, all in the same tool alongside Designer. This has
particular value to Identity Manager driver writers (Java or C) who want the tools all together.

¢ Use public APIs.

Identity Manager uses fully published public Eclipse APIs, an underlying project data model
that is consistent with open industry standards in its format, and published Eclipse extension
points.

Though not public yet, a strong set of APIs and extension points is being developed to make it
easy to add your own integrated wizard, editor, process, view, menu, toolbar item, or help page.
For the most part, you can use the public APIs and extension points that Eclipse already
provides. We are further augmenting that with additional APIs and extension points, based on
Eclipse standards, to give you more power and options.

We use these APIs ourselves. Many internal developers are currently using them. When they
are stable enough, they will be made public. We are not appending APIs as an afterthought, but
building them in from the beginning. We fully support the open model, patterns, and API
standards as outlined by Eclipse, rather than taking a proprietary approach.

In the future, with an off-the-shelf Eclipse book and knowledge of our extension points, you
should be able to contribute very rich content to Designer. You will have an abundance of
books, resources, and forums in the Eclipse community to address most of your needs. Some
developers are having success doing this now, even without access to our APIs.

2.6 Features That Require Identity Manager 3.x
Engines

The following features in Designer 2.1 won’t work on Identity Manager engines that were installed
earlier than Identity Manager 3.0:

¢ Enhancements in Driver Set and Driver Log Events
¢ Changes in the Policy Script
+ Support for entitlements

+ Support for workflow-based provisioning

Designer Concepts
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2.6.1 Driver Set and Driver Log Events

Driver Set Log Events

To identify non-functional properties for a driver set:

1 Right-click a driver set in the Modeler.

2 Select Properties.

3 Select Driver Set Log Level > Log Specific Events.

@ Properties for Driver Set

I type Filker text

3. Driver Set Log Level

-1, General

2., Global Configuration e
3, Drriver Set Log Level
4 Server Lisk

L5, Trace

4 Click the Expand icon.

5 Select options.

Items that have the earlier-version icon £t won’t work on Identity Manager engines earlier than

3.0.

Driver Log Events

r Log errors

i Log errors and warnings

" Update only the last log time

™ Turn logging off

[ Turn off logging to driver sek, subscriber, and publisher logs

Maximum number of entries in the log {S0-500): I 50

To identify non-functional properties for a driver:

1 Right-click a driver in the Modeler.

2 Select Properties.
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Select Driver Log Level > Log Specific Events.

@ Properties for Text Driver

| bype Filker text 3. Driver Log Level
-1, General ) '
Use |og settings fram the driver set
- 2. alobal Configuration e B sz b g
3, Driver Log Level
-4, Driver Configuration & Log errors
5. Driver Marifest {” Log errors and warnings
- &, Mamed Passwords
- iManager Icon
-8 Trau?e " Update only the last log time
-9, Engine Contraol Yalues
" Turn logging off
[ Turn off logging to driver sek, subscriber, and publisher logs
Maximum number of entries in the log {S0-500); I 50

If this option is dimmed, the driver is using properties from the driver set.

4 Click the Expand icon.

il

5 Select options.

Items that have the earlier-version icon ‘£ won’t work on Identity Manager engines earlier than
3.0.

2.6.2 Policy Script

The following changes were made in the Policy Script for Identity Manager 3.

*

Added do-implement-entitlement. Updated do—-for-each to include implied do-
implement-entitlement.

Updated token-entitlement, token-added-entitlement, and token-
removed-entitlement toreturn entitlement-impl in a node-set context and to
change behavior relative to granted vs. revoked entitlements.

Updated i f-entitlement to change behavior relative to granted vs. revoked entitlements.
Changed all usages of “nodeset” to “node-set” to make terminology consistent.

Updated comment to add support for multiple comments and comment names.

2.6.3 Support for Entitlements

Entitlements created in Designer 1.1 won’t work on Identity Manager engines earlier than Identity
Manager 3.0.

The following table compares entitlements in Identity Manager 2 with entitlements in Identity
Manager 3.0.

Designer Concepts

25



Table 2-1 Comparison: Entitlements in Identity Manager 2 and Identity Manager 3

Identity Manager 2 Identity Manager 3

Entitlement definitions existed only as XML in the  Entitlement definitions are stored as a DirXML

driver manifest on a DirXML® Driver object. Entitlement object contained by a DirXML Driver
object.

Entitlements are implemented by using driver Entitlements are implemented by using driver

policies. policies.

Role-based entitlements can use dynamic Role-based entitlements can use dynamic

membership (default) or static include/exclude membership (default) or static include/exclude

(additional). (additional).

No workflow entitlements Provides workflow entitlements.

Entitlements are granted and revoked through the  Entitlements are granted and revoked through the
addition of an aux class’s attribute to an object. addition of an aux class’s attribute to an object.

No status tracking. Status tracking through the Identity Manager
engine into one of the aux class’s attributes.

Only one Entitlement Service Driver can run in a Only one Entitlement Service Driver can run in a
driver set. driver set.

A driver set can be associated with only one server. A driver set can be associated with multiple
servers.

You can access the Entitlements Wizard from the Modeler or from the Outline view.
From the Modeler:

1 Right-click a driver.
2 Select Entitlements > Add Entitlements.

From the Outline View:

1 Right-click a driver.
2 Select Add Entitlements.

2.6.4 Support for Workflow-Based Provisioning

Workflow-based provisioning is the process of managing user access to secure resources in an
organization. Users request resources, and one or more individuals (including delegates or proxies)
with approval rights can approve or deny the request. Users can view the status of requests.

Support for workflow-based provisioning is a key feature of Identity Manager 3. It is not supported
in Identity Manager 2.

2.7 Designer and iManager

iManager’s primary use is for administration. iManager will continue to be updated with new
functionality for managing and monitoring deployed solutions.
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iManager’s Web-based environment continues to have the following advantages:

+ Remote access

¢ Centralized administration

+ Support for roles

+ Integration with other web-based tools
iManager and Designer have similarities, but their features and user experience are optimized for
their respective target users and environments. They are compatible. You can export information

(for example, a driver set or driver) from one to the other. Also, several key common UI elements
are now similar so that you can move between the tools effectively.
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Planning Identity Solutions

¢ Section 3.1, “Security: Best Practices,” on page 29
¢ Section 3.2, “Solving Identity Issues,” on page 30

¢ Section 3.3, “How to Use Designer,” on page 34

3.1 Security: Best Practices

When using Designer for Identity Manager, observe best practices.

Limiting Rights

Before giving a consultant an Identity Vault administrator password, limit the rights assigned to that
administrator to areas of the tree that the consultant must access. Doing so protects sensitive data
from being misused, damaged, or unintentionally compromised.

Changing Passwords

After a consultant has completed work, change the password of the user (for example, admin) that
the consultant used. If you created a special user (for example, consadmin) for that consultant to use,
delete that user or change passwords. Doing so restricts access and brings closure to the consulting
process.

Deleting or Saving .proj Files
Delete the project files (. proj) or save them to a company directory.

Designer .pro7 files are to remain at the company’s project site. A consultant does not take the
files after completing a project.

Deleting Files That Aren’t Needed

After project files, log files, and trace files are no longer needed, delete them. These files might
contain sensitive information.

Verifying Files

Before discarding or surplusing a laptop, verify that project files have been cleaned. Otherwise,
someone might discover sensitive information.

Securing Connections

Ensure that the connection from Designer to the Identity Vault server is physically secure.
Otherwise, someone could monitor the wire and pull sensitive information.

Handling Documents

When you create documents by using the Document Generator, take care with those documents.
These documents can contain passwords and sensitive data in clear text.

Planning Identity Solutions
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Working with Encrypted Attributes

If Designer needs to read or write to an eDirectory™ attribute, you can mark the attribute to be
encrypted and allow the attribute to be read over the wire in clear text. This means that you can have
encrypted attributes, but they cannot be retrieved securely.

Handling Sensitive Passwords
Do not store passwords that are sensitive.

At this time, Designer projects are not encrypted. Passwords are only encoded.Therefore, do not
share Designer projects that have saved passwords.

To save a password for a session, but not save it to the project:

1 In an expanded Outline view, right-click an Identity Vault.
2 Select Properties.
3 On the Configuration page, type a password, then click OK.

You can enter a password once per session. After you close the project, the password is lost.

To save a password to the project, complete Step 1 through Step 3, select Save, then click OK.

Security When Using the User Application

For information on security issues relating to the User Application, see the Security section (http://
www.novell.com/documentation/idm/index.html?page=/documentation/idm/agpro/data/
b2gx72y.html) in the Identity Manager User Application: Administration Guide (http://
www.novell.com/documentation/idm/index.html).

3.2 Solving Identity Issues

1 Identify target goals.

Make sure that you and others working on the project use the same terminology. For example,
password synchronization and single sign-on are two different technologies.

Also, make sure that the meaning and usage of “metadirectory” are clear as you communicate
with others on the project.
Clearly write down the big picture of what you are trying to do.

2 Discover the business process.

The process that you are trying to automate with Identity Manager is often already defined and
written down.

Be careful. Even if a process exists, people commonly don’t fully understand how it works.
Clearly write down what the business process is, and clarify the process to others.
3 Identify all systems.

Identify the systems and all connectivity interfaces with existing systems. Doing this can lead
to an increase or decrease in the originally planned systems that you had in mind.

Keep in mind that telephony systems often don’t have an easy API interface.
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SQL-based systems sometimes have a very complex database relationship model. It’s possible
that nobody in your environment understands how the model actually works.

Identify how many Identity Vaults you will need, where they will be located, and what they will
connect with.

What to Do In Designer: You can use the Designer Architect Modeler while you are doing
this process. It’s very helpful to build a diagram of your enterprise and capture key information
about each of your systems and each of the users that administer those systems.

As you start a project, keep in mind that the “people management” aspect is vital to your
ultimate success. As you identify systems, you need to start the wheels in motion for getting
access to those systems in the various departments of the organization.

Define high-level data sync flow.

Define the different information types that you want to synchronize. It’s common to have
different employee types (for example, internal or external).

Be aware of the relationships and dependencies between information of different types (for
example, employee, manager, organization, or location).

Doing this step well is critical in helping you to define your data and policy needs.

What to Do In Designer: You can design these data flows in the Dataflow view while you are
in the Architect mode or Developer mode.

Define objects and attributes to synchronize.

After knowing the data and relationships, you can break the data into specific Identity Vault and
Application object types and attributes.

Define merging behavior, passthrough, notification, and reset of attributes.
Identify and derive additional operations based on an original event.
Identify attributes for match, creation, and placement behaviors.

What to Do In Designer: You can use the Task view to capture all of this information or add it
to a section in a Document Generation form. One advantage for having it in the Task view is
that you can then mark off your tasks as you move into the implementation phase and write the
policy to deliver on your requirements.

You can also include any file (word processing document, spreadsheet, presentation) in your
Designer project through the Navigator view. By default, the Navigator view launches the
appropriate native application to edit and view that document in a way that integrates into
Designer, as long as the platform supports it. If you prefer to, you can also configure Designer
to use a different editor. This view gives you many options for the types of documents you can
include and edit in a Designer project.

Write a Requirements Assessment Document.
Document all of the above findings.

Write a high-level acceptance proposal.
Describe the infrastructure.

Create a project timeline.

What to Do In Designer: You can use Designer’s Document Generator to capture your high-
level design, systems, and basic data flows. You can also fill in sections in the document or
create your own sections that describe the project.

7 Fill in the technical details.
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Take the high-level diagram that you created in the Architect mode and transition it to a
detailed diagram that you can configure your entire solution with.

Configure servers and authentication information on the Identity Vaults.

Create driver sets and drivers. Determine how many driver sets are on each vault. Define what
drivers are associated with each driver set, and what servers the driver set is running on. Run
the Driver Configuration Wizard on each driver.

Develop driver policies. Make sure that you define and use Global Configuration Values
(GCVs) as much as possible. Doing this leads to easier maintenance.

What to Do In Designer: With the Modeler in Developer mode, use the Outline view, Policy
Flow view, and properties dialog boxes on all objects, Filter editor, Schema Map editor, E-mail
Template editor, Policy Builder editor, and other functionality.

NOTE: The preceding six steps assume that you are building an identity solution from the
beginning.

However, Designer is also intended for working on existing solutions. You can create a project
and import existing driver sets, drivers, policies, and configurations. Designer lets you easily
diagram and manage all components as one complete solution. You can edit existing policies or
configurations, add new elements, and then redeploy.

Using Designer on existing solutions has several advantages. You can do the following:

*

Work in a high-productivity development environment.
¢ Easily work off-line.
+ Have everything on your local file system for versioning and backup.
+ Simulate.
+ Generate documentation for your projects.
8 Unit test.
Use project-proposal documents and requirements as a basis.

Test all policies. In addition to the Designer tools, you can deploy the project (or parts of it) into
a test environment to test more fully.

Generate a report on results.

What to Do In Designer: Use the Designer Policy Simulator to do much of your policy
simulation and debugging. It is very easy to use, helps you catch a lot of issues, and is ideal for
off-line development.

9 Build a production environment.
As much as possible, mirror existing production environments.
Make sure of the following:
+ All Identity Manager engines and drivers are installed.
¢ All servers have correct IP addresses.
¢ The applications your drivers will connect to are in place.

As an extra precaution, you might want to deploy to a full test environment or staging
environment first. If this is the case, all of the above steps apply to configuring that
environment.
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What to Do In Designer: To make the next steps easier, you can click a button, get a full PDF
document of all of the configuration details of your project, and use that document as you set
up your machines and software.

Make sure that the data is clean before you deploy.
Ensure the following:
+ Each user has a unique and correctly formatted ID.
+ All users and other objects are where you expect them to be.
+ No duplicate objects exist.
+ No extra or unnecessary objects exist.
Deploy to production.

Make sure that the production systems are working well. For example, machines are up and
running.

Before you deploy, make sure you have done adequate testing on your project.

If you have previously configured the project to deploy to a separate test or staging
environment, you need to change the IP addresses on each Identity Vault (and maybe some
GCVs) to successfully deploy to the production environment.

After you deploy, quickly test and redeploy all or any part of the project with any fixes you
need.

What to Do In Designer: In the future, more will be done in Designer to help in this area. For
now, the following tips can help in this process.

+ Do a full copy of the project in the Project View.

This lets you fill in the new IP addresses for production and leave the old ones alone, so
that you can have a project called Staging and another called Production. The
disadvantage is that if you change something such as a policy in one, you need to change it
in the other to keep the policies in sync. Designer does let you copy/paste between
projects to make synchronization easier.

+ Always use GCVs to keep your policies easily portable.

If you have a value that is environment-dependent, you only need to edit a GCV when
switching to a different environment.

+ Use the Modeler’s Table editor.

This editor is a quick and easy way to get to objects of a certain type (for example, all of
your Identity Vaults or all of your servers), see their values, and edit them.

¢ Document your project.
Document Generation is always available to help you understand your configurations.
Document, back up, and maintain the production system.
What to Do In Designer: Run the Document Generator and save the document.

Make a copy of your project in the Project view. A copy is useful in case you ever need to
return to that state or set up a production system again for any reason.

Over time, you will certainly add systems and policies, and make changes in your production
environment. You can use iManager for the management of your system (especially if the
change is more of an administrative task) and then reimport those changes into your local
Designer project.
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If the changes you need to make are more suited for a development environment, (for example,
policy debugging, policy development, or adding new systems) then continuing to use
Designer is the best practice. After each change, you can redeploy the project or just the
elements that have changed.

As you version and extend your project over time, remember to always use Document
Generation as your paper trail.

3.3 How to Use Designer

*

*

*

Section 3.3.1, “Designing New Solutions,” on page 34
Section 3.3.2, “Redesigning Existing Solutions,” on page 34
Section 3.3.3, “Working on Live Systems,” on page 35

3.3.1 Designing New Solutions

A » O N =

Launch Designer.

Using the New Project Wizard, open or create a project.

Drag and drop items from the Modeler Palette.

Edit the items’ settings and configurations (for example, names, [P addresses, and passwords).

Using the Policy Builder and other policy editors, write a policy for sharing data between
systems.

6 Check your work.

Use the Document Generator to generate project documentation, and review the documentation
with others.

Deploy the project to live systems.

3.3.2 Redesigning Existing Solutions

1
2
3
4

Launch Designer.
Open or create a new project.
Import Identity Management elements (drivers, driver sets) from working directories.

Edit the element settings and configurations (for example, names, IP addresses, and
passwords).

Using the Policy Builder and other policy editors, write a policy for sharing data between
systems.

Check your work.

Use the Document Generator to generate project documentation, and review the documentation
with others

Deploy the project back to live systems.
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3.3.3 Working on Live Systems

The fundamental model/paradigm of Designer is to import solutions, configure them locally in the
Designer environment, and then deploy when a solution is ready. This approach was taken to
optimize the experience for the following:

¢ Off-line work
¢ Highly productive development

+ A safer model of configuring and testing before touching your live system
The tool is aimed at developers and architects as the primary audience.

For convenience, Designer enables you to do key operations that a developer typically needs to do,
so that the developer can be effective: browse live trees, check driver status, start/stop drivers, and
configure driver security. Functionality in the Live Operations options takes immediate effect on the
end systems. These operations are clearly grouped in the Designer Ul, so that you can tell if you’re
doing something live.
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Installing Designer

*

*

*

Section 4.1, “Requirements,” on page 37
Section 4.2, “Installing,” on page 37
Section 4.3, “Uninstalling Designer,” on page 40

4.1 Requirements

*

*

Section 4.1.1, “System Requirements,” on page 37

Section 4.1.2, “Platform Requirements,” on page 37

4.1.1 System Requirements

*

*

*

*

Minimum resolution: 1024 x 768. The recommended resolution for Designer is 1280 x 1024.
512 MB RAM (recommended).

1 GB available disk space (recommended).

1 GHz processing speed.

Gettext utilities (Linux only).

When you install support packages for Designer (NDSbase and NICI), certain Linux core
utilities are needed. The GNU gettext utilities provide a framework for internationalized and
multilingual messages. Before installing Designer, make sure that you have installed this
package. You can use YaST to check for dependencies and installed packages.

4.1.2 Platform Requirements

You can install Designer on the following:

*

*

*

*

Windows 2000 Professional SP4
Windows XP SP2

Windows Server 2003

Red Hat Fedora* Core 5

Red Hat Linux 4.0

Novell® Linux Desktop 9

SUSE® Linux 10.1

SUSE Linux Enterprise Desktop 10
SUSE Linux Enterprise Server 10

4.2 Installing

*

*

Section 4.2.1, “Installing Designer If Eclipse Is Not Already Installed,” on page 38
Section 4.2.2, “Installing Designer If Eclipse Is Already Installed on Your System,” on page 40
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4.2.1 Installing Designer If Eclipse Is Not Already Installed

*

*

*

*

“Downloading the Files” on page 38
“Installing on Windows” on page 38
“Installing on Windows Vista” on page 39

“Installing on Linux” on page 40

Because Designer runs in an Eclipse environment, Designer installs Eclipse on your workstation.

Downloading the Files

1

2

Download the correct . i so image or . zip file for your system.

Downloads are available at the following locations:
+ Novell Downloads (http://download.novell.com/index.jsp)
¢ Cool Solutions (http://www.novell.com/coolsolutions/dirxml/designer/)

If you downloaded a . i so image, burn that image file to an Identity Manager CD or DVD.

Installing on Windows

1

2

From the designer install directory,run install.exe.

The \nt directory also contains an install.exe file. However, that file is for the
Metadirectory system. Use the install.exe file found in the designer install
directory.

Select a language to use during the installation, then click OK.
o ] S
i A
Design. Deploy. Document.
v20
O 198E3-2007 Mavell, Inc. AN righis resaroed N OVB I I
English ~| [ox]

Portugués (Brasil)

The default language is English. You can select a different language from the drop-down list.
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The languages displayed in the language-selection dialog box are filtered, based on the default
system locale. If the default system locale is English (or another Latin-based character set),
only languages that use the Latin character set are displayed.

If the default system locale is set to Japanese (or any double byte-locale), only the double-byte
locales, such as Chinese, Korean, and Japanese, are displayed in the list. The exception to this
is English, which is always in the list, regardless of the default system locale.

3 Review the Introduction, accept the license agreement, select a location for the Designer files,
then select shortcuts to Designer.

4 Sclect a language for the Designer user interface.

2 Designer for Identity Manager - |EI|5|

Select Language

:,_0 Introduction Please selectthe preferred user interface language for Designer
) License Agreement for Identity Manager. You may change this preference later from
4’) Install Folder within Designer for ldentity Manager,
= Language
FPre-Installation Summary
Installing...
Install Complete Select a language:
English LI
Cutch -
Enalish
French
(German
Ttalian
Japanese
N Spanish hd

Installamawhere by Macrovision

Cancel | FPrevious | I ext |

The default is the language that you selected to use for the installation. You can select a
different language from the drop-down list.

After installation, you can change the language. See Section 23.3.7, “Changing the Language
Setting,” on page 460.

5 Review the summary of choices, then install Designer.
6 Review known issues in the Readme, then complete the installation.

7 To run Designer, click the Designer icon on the desktop.

Installing on Windows Vista

Designer 2.1 is not officially supported or tested on Windows Vista. However, our initial impression
is that Designer runs well on Vista.

During the install, you see a message stating that you are installing on an unsupported Windows
version. You can continue with the installation by selecting OK.
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Windows Vista has implemented a new User Account Control feature that prevents applications
from running as Administrator unless you specifically allow it. If Designer does not launch after
installation on Windows Vista:

1 Right-click the Designer shortcut.

2 Select Run as Administrator.

Installing on Linux

Installing eDirectory™ base components and NICI requires root privileges. The install program
prompts you for the root password so that you can install these components.

To install on Linux:
1 From the Identity Manager CD or . zip file, run /1linux/designer/install.bin.

The /1inux directory also contains an install.bin file. However, that file is for the
Metadirectory system. Use the install.bin file found in the designer directory.

2 To run Designer, click the Designer icon on the desktop.

4.2.2 Installing Designer If Eclipse Is Already Installed on Your
System

Because of the interaction between Designer and third-party Eclipse plug-ins, Novell does not
support installing Designer into an existing Eclipse installation.

For information on installing Designer into an Eclipse environment, see the CoolSolutions Web site
(http://www.novell.com/coolsolutions/dirxml/designer/existinginstall_instructions.html).

4.3 Uninstalling Designer

¢ “Uninstalling on Windows” on page 40
¢ “Uninstalling on Linux” on page 40
Uninstalling on Windows

1 In the Control Panel, select Add/Remove Programs.
2 Click Designer for Identity Manager > Change/Remove > Uninstall > Yes.

To easily uninstall on English-language workstations, select Uninstall from the Start menu. For
example, on Windows 2000, click Start > Programs > Designer for ldentity Manager > Uninstall.

Uninstalling on Linux

1 Make sure that you have the correct privileges to uninstall.
2 RunUninstall Designer for Identity Manager.

This fileis in [path you chose to install into]/designer/
UninstallDesigner.
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Getting Help

Information about Designer is in the local help system, in the readme . txt file, and in the online
documentation. Information in the help system is not localized. If you need localized information,
refer to the Designer 2.1 for Identity Manager 3.5.1 guide on the Novell Documentation (http://
www.novell.com/documentation/designer2 1/index.html) Web site.

¢ Section 5.1, “Help from the Welcome Page,” on page 41

¢ Section 5.2, “Browsing for Information,” on page 43

¢ Section 5.3, “Getting Context-Sensitive Help,” on page 43

¢ Section 5.4, “Help from the Web,” on page 44

¢ Section 5.5, “Viewing Demos,” on page 45

¢ Section 5.6, “Searching for Information,” on page 45

¢ Section 5.7, “Customizing the Browser and Help Server,” on page 46

5.1 Help from the Welcome Page

When Designer starts, a Welcome page appears and makes it easy for you to get started.

Figure 5-1 The Welcome Page

@ Designer - Kvedjur - Developer - Designer

File Edt Wew Mavigate Project Tools Live Modsl Window Hslp

Designer for
Novell. Identity Manager

Design. Deploy. Document.

aflzl=

Overview What's New

N

Tutorials

Web Resources

Run Designer
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Table 5-1 Options on the Welcome Page

Option Description
Overview Provides an overview of Designer and Identity
Manager.
What's New + Describes what’s new in this release.
+ Enables you to update Designer.
+ Links to the readme file.
Tutorials Launches Flash demos of Designer tasks.

Web Resources

Run Designer

Provides links to online information and downloads.

Takes you to Designer’s Modeler.

The icons on the toolbar take you to the Welcome page, toggle between previous and next pages,

and enable you to customize the Welcome page.

Figure 5-2 Icons on the Toobar

{it b

You can close the Welcome page at any time by clicking the X next to Welcome.

Figure 5-3 The Close Icon

To return to the Welcome page, click Help > Welcome.
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5.2 Browsing for Information

To navigate all of the help topics, you can use a built-in Web browser:

1 From the main menu, select Help > Help Contents.

® Help - Designer =
Search: [ searchscope: Al topics
Contents & WO S ol o

© Designer for Identity Manager

Using the help system

Browse topics in the Contents frame (@) on the left. Click on a topic to have it displayed. Use the Back and Forward buttons
to navigate within the history of viewed topics

Searching

To guickly locate topics on a particular subject in the documentation, enter a query in the Search field. Use the Search frame
() to display the Search view. You can narrow the scope of your search by selecting only the sections you are interssted in

Synchronizing

After you run a search and find a topic you were logking far, click either the Refresh / Show Current Topic button (") ar
Show in Table of Contents button (%) to match the navigation tree with the current topic. You might also find it useful to
synchronize after following in-topic links.

Capabilities

To show documentation about capabilities that are disabled in the application, select the Show All Topics button (€7). When

you choose to show all topics in the table of contents, the headings for documentation about any disabled activities are shown in
the table of contents and also appear in search results

The text under Using the help system describes the icons that help you navigate and use the

Help system.
2 In the Contents pane, select Designer for Identity Manager.

Help - Designer

Search: l:l m Search scope: All kopics

Contenks @ w B | Designer for Identity Manager

e
B - signer for Tdentity Manager

[E what's Mew in Designer
[ concepts N . N N
[ Planning Identity Solutions Desi g ner: The Bi g Picture
L Installing Designer O O O O
[ Getting Help
[ Creating a Project
[ Building a Model N
[ Managing Projects Demg Designer: A powerful, graphical tools:
[ Designing User Application Components Ide ntity deploy Identity Manager
[ Configuring ©bjects in Designer
[ Managing Yersions Manager
[ Managing the Schema
[ Managing the Flow of Cata
[ Managing Policies
[EE] Importing into Designer
[EE] Documenting Projects
[ Entitlements
[ Scheduling Jabs
[ Deplaving and Exparting

Wwhen complete, Designer will include

= Enterprise modeling
= Configuration
= Project versioning and staging

= Policy management

[ rovwell ¥rL Edikor e Integrated ¥MLSLT editor
A Toals . .
[ Setting Preferences s Data analysis and scrubbing
[ Troubleshooting « Resource management
[ Fan-out Driver Plug-in
[ Reference e Wnrkflowes

3 Navigate to the topic that you’re interested in.

5.3 Getting Context-Sensitive Help

1 Press F1 or click the help icon @
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NOTE: If you maximize an editor (for example, the Modeler), help topics do not display when
you press F1. To view the help, minimize the editor.

2 Click links under About and Dynamic Help.

1 o, Designer »
) i Help 32 =0
Policy Builder for IDM 3.5 and Neweréj v | o 5 | i & | @ = & | =
Cutput Transform, Active Direckory, Driver Set, 11 Yault

Related Topics
* About

» Policy Description E

Rules (

Street Address: Convert LF to CR-LF

Policyy Builder Help

[+

Accessing Policy Builder

Using the Palicy Builder

=)

logonHours: Conwert to Active Directory form
Creating a Palicy

[+

accountExpires: Convert to Active Directory form Editing a Palicy

lockout Time: Convert to Active Directory Form Creating Rules

Add: User - convert multi-valued Telephone to single
—value

[+

Creating Arguments

]
NN Y
RNORN RN RN RN R

Wigwing the Policy in 5ML

[+

update Active Directory logon name
Ising Additional Builders

Ising the ¥Path Builder

DirxML Script DTD
Commands and Events

B
B
B
B
B
= Using Predsfined Rules
B
B
B
B
B
B

Filter DTD Commands 1
and Events

* Dynamic Help

Search resulks:

Y Manager

Palicy Builder: Crverview ;I
o Tol

all Topics 57 search

Palicy Builder | %ML Source | #ML Tree | E]:ﬂ Bookmarks
5.4 Help from the Web

To view results found through Google* or in the Eclipse help system, click More results > Web
Search.

44 Designer 2.1 for Identity Manager 3.5.1



Figure 5-4 Related Topics in Google and Eclipse

= DirgML Entitlements
DTD Commands and
Events

+ Dynamic Help
Search resulks:

= Pre-Identity Manager
Palicy Builder: Crwerview

= Identity Manager DTD
Reference

=l Examples of
ECMASCripts with
Policies

= Creating Rules

= Placement - Publisher
Flak

= Command
Transformation -
Publisher Delete to
Disable

=l Ewent Transformation -
Scope Filtering - Include
Subkreses

T Mare resulks...

X

Al Topics @) Search
Eu] Bookmarks

5.5 Viewing Demos

To see how Designer works, view the Flash demos that are available on the Welcome page:

1 Select Help > Welcome.

2 Select the Tutorials icon.

3 Select a demo:
¢ Model Projects
¢ Import
¢ Create a Workflow
¢ E-Mail Templates
¢ Manage and Simulate Policies

+ Document Generation Overview

5.6 Searching for Information

1 Select Help > Search.
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2 Type a topic in the Search field, then click Go.

You can also select Help > Help Contents, then use the Search option above the Contents pane,
or click Search at the bottom of the context-sensitive Help view.

.Help - Desinner

Search scope: Al topics
Contents & a0 Designer for Identity Manager

[ﬂ Designer for Identity Manager
[ what's Mew in Designer

# L Concepts Getting Help

[ Planning Identity Solutions

[ 1nstalling Designer

[ creating a Project Information about Desiagner is in the local help sy
LA Building a Model online documentation. Information in the help sysi
[ Managing Projects information, refer to the Designer for identy Mana
[ pesigning User Application Components docurmentation VWek site.

LA Configuring Objects in Designer

[ Managing Versions » Help from the Welcome Page

[ Managing the Schema

[ Managing the Flow of Data e Browsing for Infarmation

[ Managing Policies

LH Imparting into Designer s Getting Context-Sensitive Heln

A Dacumenting Projects

[ Entitlements

s Help from the Web
[ scheduling Jobs

[ Deploving and Exporting
[ Movell ¥ML Editor

LA Toals

[ Setting Preferences

[ Troubleshooting
L3 Fan-out Driver Plug-in o Custornizing the Browser and Help Senver

o Yiewing Demos

e Searching for Information

5.7 Customizing the Browser and Help Server

1 From the main menu, click Window > Preferences.
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2 Seclect Help, make changes, then click OK.

@ rreferences

I type filker bext

- General

- Designer For TDM
=

Mowell

[ Provisioning

- Web and XML

Because Designer is built on Eclipse, you are able to use Help Server functionality. It is a
development tool for building your own tools. If you have a team environment where the entire
team is using Eclipse, you might want to set up a common Help server, and then use that server

Help

=10l x|

Specify how help information is displaved.
[ Use external browser

See "Web Browser' For configuring the external browser used to display help bopics.

—iZpen window context help

% in a dynamic help wiew " inan infopop

—Open dialog context help
¢ indislogtray © in an infopop

—Help view document open mode

& openinplace ¢ Openin editor area

—Search
{* Show all pokential hits {Faster)
= Show only actual hits

for help files and content in your intranet.

For more information on Help and the Help server:

+ See the Help section in Preferences.

+ Go to the Eclipse Web site.
3 (Optional) Expand Help, then click Help Server.

@ rreferences

I type filker bext

[ General
[+ Desigrer for [0
)

- Provisioning
-Web and ZML

4 (Optional) Make changes concerning the Help Server, then click OK.

Help Server

=10l x|

- o=

Internal Application Server configuration. The server is used internally by help

syskerm.,

Host name or IP address: |

Server pork: |

Mote: Leave the abowe fields empty to have the IP address and port number
dynamically computed by the help swstem. IF the server is already running, these

preferences will only take effect after restarting.
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Creating a Project

IMPORTANT: Projects created in Designer releases earlier than Designer 3.0 work in Designer
3.0. However, projects created in Designer 2.1 or 3.0 don’t work in Designer 1.1 or earlier releases.

¢ Section 6.1, “When No Project Exists,” on page 49
¢ Section 6.2, “When You Want to Create an Additional Project,” on page 50
¢ Section 6.3, “When You Want to Import a Project,” on page 51

6.1 When No Project Exists

1 Make sure that the Designer perspective (in the upper right corner) is selected.

raif i Designer

l—2| —— Palette — 4

— |[§ Select
{73 Marguee

<& _onneckion

|IHI Tdarkitae Ve ilk |

2 Ifyou are just starting Designer and have no projects in the Project tab, you see the following

window:

- s

== Project &2 Outline + = |
No projects available @

There are currently no Designer projects tao
list, ‘fou can create new projects by clicking the
links below,

g e Tdentity Manager project

L5 Import From Identity Yault

L2 Import From file syskem
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3 Click New Identity Manager Project to launch the Identity Manager Project Wizard.

’ Mew Identity Manager Project 5[
MNew Identity Manager Project @

Mame the project and choose a location,

Project Name:

Project contents
¥ Use default

Direckory: I i fDocuments and Setkingsy bobil fworkspace Browse. .. |

4 Name the project, then click Finish.

6.2 When You Want to Create an Additional
Project

1 Right-click in the Project view pane, then click New > Identity Manager Project.

-
M\Navi. 0 ‘ Cutlire | = O || 2 s Blanston - Developer - Blanskon
—| || Modeler | 100%% @ -

Impork 4

E§3 Refresh

|dea| Copy Project...
Mave, .,

¥ Delete

Properties

2 In the Identity Manager Project Wizard, name the project.

@ New Identity Manager Project =]
New Identity Manager Project @

Mame the project and choose a location,

Project Mame: | Blanstonl

Project contents
[ Use default

Direckory: I i Documents and Settingsy bobil fworkspace Browse. .. |

Designer stores the project in a local directory. You specified this directory when you installed
Designer. Typically, this default directory is c: \Documents and
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Settings\Username\workspace. To specify a different directory, deselect Use Default,
then browse to and select the desired directory.

3 Click Finish.
The project is stored is a directory structure with the project name as the initial directory
containing files with a .proj and a . project extension. In this example, the project is

stored in the c: \Documents and Settings\Novell
User\workspace\Blanstonl directory on a Windows workstation.

5

»
43 :address [ ChDocuments and SettingsiMovel User\workspace|Blanstonl

Mame Size  Type
|ZJBlanstonl _files File Folder
|[Z)documentation File Folder
Jproject 1KBE PROIECT File
Blanstonl.proj 1KE PROIFile

& Modeleroutlinestate. xml 2KB ¥ML Document

The project name appears in the Project view. When you select the System Model icon under
the project name, Designer opens the Modeler (an editor) for the new project.

For information on saving a project, see “Saving” in Section 8.4.2, “Tasks You Can Perform
from the Project View,” on page 114.

6.3 When You Want to Import a Project

To import a project from an Identity Vault or from the File System, see Chapter 15, “Importing into
Designer,” on page 257.
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Building a Model

¢ Section 7.1, “Basic Tasks,” on page 53

¢ Section 7.2, “Accessing the Modeler,” on page 54

¢ Section 7.3, “Selecting a Modeling Mode,” on page 55

¢ Section 7.4, “Working from the Palette,” on page 62

¢ Section 7.5, “Copying and Pasting,” on page 68

¢ Section 7.6, “Moving Items,” on page 72

¢ Section 7.7, “In-Line Editing,” on page 73

¢ Section 7.8, “Tooltips and Toolbar,” on page 73

¢ Section 7.9, “Organizing by Domain Groups,” on page 74

¢ Section 7.10, “Connecting Applications,” on page 82

¢ Section 7.11, “Aligning and Laying Out Components,” on page 88
¢ Section 7.12, “Editing Multiple Objects,” on page 95

¢ Section 7.13, “Modeling Active Directory Domain Controllers,” on page 95

¢ Section 7.14, “Saving Your Model,” on page 96

7.1 Basic Tasks

This section lists basic tasks for creating a model after you have created a project.
1 Select a project.
If your project doesn’t appear in the Modeler, open the Project view (Window > Show View >
Project), expand the project, then double-click System Model.
2 Drag an Identity Vault object from the palette to the Modeler.

When you create an Identity Vault or server in Designer 2.1, the default Identity Manager
engine version is 3.5. Designer assumes that the Identity Vault has 3.5 capabilities. You can
successfully deploy and run 3.5 projects only on Identity Manager 3.5 servers.

You can easily change the engine version by selecting a version from the Server DN field.

Before you deploy a project, you must associate a server with the Identity Vault. You do this
through the Identity Vault properties. See Section 9.3, “Configuring Identity Vaults,” on
page 148.

You an add multiple Identity Vaults.
3 Configure a driver set.

Each Identity Vault contains a driver set. See Section 9.5, “Configuring Driver Sets,” on
page 152.

4 Add applications.

Drag applications from the palette to the Modeler. See Section 9.8, “Configuring Application
Properties,” on page 170.

5 Configure drivers.
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Driver connections are automatically drawn between the application and the driver set. See
Section 9.6, “Configuring Drivers,” on page 158.

6 Develop and customize your model.
Develop according to what you planned in Section 3.2, “Solving Identity Issues,” on page 30.
7 Save your model (design).
Do one of the following:
+ From the main menu, select File > Save (or Save All).
+ From the main menu, select File > Close > Yes.

+ Click the X in the Modeler’s tab, then select Yes.

7.2 Accessing the Modeler

The Modeler space is the main working area. It is an editor where you design projects. It is the main
work space and primary means of interacting with Designer. All other editors, views, and dialog
boxes support and provide functionality for the Modeler.

Figure 7-1 Designer’s Modeler
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To get started, you create a project and drag items from the palette into the Modeler space. Then you
arrange and configure the items.
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If the Modeler doesn’t display:

1 Expand a project in the Project view.

=== Elanskon
1| System Model
@ docurnentation
[ = resources
E Brosandi

T& Brosfugur

If you haven’t yet created a project, create one.
2 Double-click System Model.

7.3 Selecting a Modeling Mode

¢ Section 7.3.1, “Developer Mode,” on page 56
¢ Section 7.3.2, “Architect Mode,” on page 57
¢ Section 7.3.3, “Dataflow Mode,” on page 61
¢ Section 7.3.4, “Table Mode,” on page 62
The Modeler has tabs along the bottom, so that you can switch among different modeling modes.

The modes have different advantages, depending on the task you’re trying to do and the role that you
are acting in.

Figure 7-2 Modeler Modes
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The modes are synchronized with each other with selection, data, and content. They are also
synchronized with the Outline View and Thumbnail view.

As you switch modes in the Modeler editor, the editor tab at the top displays the mode that you are
in.
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By default, the theme preference is different for each mode. To configure each theme independently
in the Modeler preferences:

1 Click Window > Preferences > Designer for IDM > Modeler.
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2 Click the Themes tab.
3 Select a theme, then click OK.

7.3.1 Developer Mode

Figure 7-3 Developer Mode
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Use Developer mode to do all low-level operations with driver sets, drivers, policies, and
applications. This mode lets you manage all of the visual elements and configuration details that you
need to fully build and deploy an identity solution.

In Developer mode, the palette organizes the applications and systems into categories. You can
customize them to show up as one alphabetical list by using the Modeler Preferences. See “Palette”
on page 465.

Working with Labels

Figure 7-4 An Application’s Label

By default in both Developer and Architect modes, labels appear under application icons in the
Modeler. They also appear above Identity Vaults in Architect mode.To configure these labels to not
appear, use the Modeler Preferences. See Section 23.3.8, “Modeler,” on page 461.

7.3.2 Architect Mode

Figure 7-5 Architect Mode
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Use Architect mode to work at a higher level. Because a higher level doesn’t show drivers, driver
sets, or policies, you focus more on systems. This mode helps you do large-scale design, which is
more intuitive to architects and business strategists.

It is quite likely that you will start in this mode when you begin each project. You will probably
spend time putting together an accurate diagram of your enterprise as you consult with various
people throughout your organization. As you do so, you should capture key information on each
system, such as the owner, contact information, machine environment, software versions, and
authentication credentials. As you go through this process, you will also define your project
requirements, start thinking about your data, and capture that information in your project.

When the time is right, you can switch to the Developer mode and delve into the technical details of
building a working solution. Depending on the size of your project and makeup of your team, you
could have architects and designers build high-level solutions with Designer in Architect mode, and
then send the project to identity developers who understand all the details of writing policies and
configuring systems. They can share the same project.

In Architect mode, you can connect any design element with any other design element, application,
image, or Identity Vault. The connecting lines enable you to express any relationship, making
Architect mode a general-purpose, high-level business modeler. The Architect-mode lines don’t
display when you switch to the Developer mode.

The design elements have connectivity information tied to them. You can use design elements to do
live operations or to remotely control other elements that are in your environment but are not
necessarily included in your Identity Manager infrastructure.

The Palette in Architect Mode

In Architect mode, the palette alphabetically lists all applications in one folder and design elements
in another folder.

The Graphics folder has an Image icon. When you drag this icon to the Modeler, Designer displays a
generic graphic:

Figure 7-6 The Image Icon
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To edit the properties of this icon:

1 Right-click the icon, then select Properties.

. Properties for Image

I bype Filker text 1. Image
1. Irmage
i3, Conneckivity Mame: |image

h

Browse.., |

2 In the Name field, replace Image with a caption.

3 Browse to and select a replacement graphic, then click OK.
You might need to reduce the size of the graphic before importing it.

After the image is in the Modeler, you can drag it, change it, connect lines to it, align or distribute it,
or delete it.

High-Level Data Flows in Architect Mode
To set data flows in Architect mode:

1 Right-click the line between an application and an Identity Vault.

2 Select Dataflow.

3 Specify synchronization and notification events, then click OK.
This option is used the same way as in Developer mode except that in Architect mode, Designer
automatically configures all the details (schema, filters, and mapping policies) for you. You won’t

see the Data Flow Wizard for these details. Before deployment, you can edit the details by using
Developer mode.

Tasks
You can do the following tasks in Architect mode:
¢ Straighten connections (edges). See Section 7.11, “Aligning and Laying Out Components,” on
page 88.

¢ View Password Sync icons and edit synchronization. See Section 12.6, “Integrating
Passwords,” on page 245.

¢ Auto-connect eDir-to-eDir.
¢ When deleting the driver line, view a prompt to confirm drivers being deleted.

¢ Display design elements in your model.
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Open the Design Elements folder on the palette, drag design elements onto the Modeler, and
connect the design elements.

Figure 7-7 Items in the Design Elements Folder
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7.3.3 Dataflow Mode

Figure 7-8 Dataflow Mode
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The Dataflow mode launches the Dataflow Editor, so that you can see all filters that control how
data flows between systems and Identity Vaults.

The Dataflow mode is synchronized with the Modeler and with the Outline view when you add,
delete, change, or synchronize objects. Also, you can see how passwords flow from each server. See
Chapter 12, “Managing the Flow of Data,” on page 221.
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7.3.4 Table Mode

Figure 7-9 Table Mode
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Table mode provides a global table editor, which provides a list of all design elements in the project.
You can scroll this table to quickly scan essential information. You can efficiently find all items of a
particular type and edit their settings.

To edit an entry in the table, double-click a line, or right-click, click Open With, then select an editor.

When you select an item in the table, Designer synchronizes the selection with the Outline view, so
that you can view the selection’s container.

To sort the lists, click a column header.

7.4 Working from the Palette

¢ Section 7.4.1, “About the Palette,” on page 63

¢ Section 7.4.2, “Palette Operations,” on page 63

¢ Section 7.4.3, “Using Generic Applications,” on page 64

¢ Section 7.4.4, “Fly-Out Palette,” on page 64

¢ Section 7.4.5, “Resizing the Palette,” on page 65

¢ Section 7.4.6, “Docking the Palette,” on page 66

¢ Section 7.4.7, “Arranging Folders and Applications,” on page 66
¢ Section 7.4.8, “Changing the Layout,” on page 67

¢ Section 7.4.9, “Keyboard Support for the Palette,” on page 68
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7.4.1 About the Palette

Figure 7-10 Designer s Palette
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The palette is the source of all of the items that you add into the Modeler. To build a model, do one

of the following:

¢ Drag and drop items from the palette to the Modeler space. When you drag and drop an
application, it auto-connects to the closest driver set.

¢ Click an item in the palette, then click in the Modeler space where you want the item to go.

7.4.2 Palette Operations

Table 7-1 Palette Operations

Operation Description

Connection Connects items in the Modeler space.

Identity Vault Places an Identity Vault in the Modeler space.

Driver Set Places an eDirectory Driver Set object in an Identity Vault. All applications

Domain Group

that you want to connect use a Driver Set object as a hub between the two
applications.

Lets you group and organize items in the Modeler space.
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Operation Description

Folders Applications are organized within folders or drawers. To open or close a
folder, click it. To hold the folder in place and make sure that it doesn't fully
collapse (even when you open other folders), click the pin. An unpinned
folder automatically closes when you open another folder.

Applications The various applications that you can connect are grouped into folders by
type. You can drag and drop these applications to the Modeler space and
begin editing them. The Modeler automatically adds a connecting line, which
represents a driver.

Scrolling Arrows Small directional arrows. If a folder has many items, or if the screen area is
restricted, scrolling arrows appear. To scroll through he contents of a folder,
click the arrows.

7.4.3 Using Generic Applications

Figure 7-11 The Generic App Option on the Palette
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Scenario: A Generic Application. Fridrik creates a project with his own items and graphics, in his
own version of Designer. He transfers the project to you, but you are using a different version of
Designer, which doesn’t understand those items. Your version renders the transferred objects as
Generic applications.

7.4.4 Fly-Out Palette

Figure 7-12 The Palette’s Control Arrow
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To hide the palette, click the small control arrow on the palette. The palette collapses.
To open the palette again and keep it open, click the arrow.

To temporarily open the palette again, hover the cursor over the collapsed palette, below the control
arrow. The palette quickly expands. This is fly-out mode.
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To change the palette from fly-out mode, click the control arrow again. The state persists and is

restored the next time you run the application.

7.4.5 Resizing the Palette

1 Click the palette’s thick border that faces the Modeler space.
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2 Drag the line.

The size persists and is restored the next time you run the application.
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7.4.6 Docking the Palette

To dock the palette on the left or right of the Modeler space:

1 Click the top palette header.
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2 Drag the palette to the desired location.

The location persists and is restored the next time you run the application.

7.4.7 Arranging Folders and Applications

By default, applications are placed in folders.
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To arrange applications alphabetically instead of in folders:

1 Click Window > Preferences > Designer for IDM > Modeler > Palette.
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2 Select Arrange applications in alphabetical list, then click OK.

7.4.8 Changing the Layout

1 Right-click the palette.
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2 Select Layout.

3 Select an option.

Setting Description

Layout: Columns Displays folders and applications in columns.

Layout: List Arranges folders and applications in a list.

Layout: Icons Only Removes descriptive labels.

Layout: Details Briefly describes palette items.

Use Large Icons Toggles the size of icons used for applications.

Settings Enables you set the layout and icon size in one
dialog box. Controls how folders (drawers)
behave.
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7.4.9 Keyboard Support for the Palette

Table 7-2 Shortcut Keys for the Palette

Keystroke Description

Left-arrow Collapses an open folder. The focus must be on the folder, not the
application.

Right-arrow Opens a collapsed folder. Moves into an open folder.

Up-arrow Moves up to the next folder.

Down-arrow Moves down to the next folder.

7.5 Copying and Pasting

¢ Section 7.5.1, “Copying Applications,” on page 68
¢ Section 7.5.2, “Copying a Driver Set,” on page 69
¢ Section 7.5.3, “Copying an Identity Vault,” on page 70

*

Section 7.5.4, “Copying a Domain Group,” on page 71

*

Section 7.5.5, “Copying between Editors,” on page 71

7.5.1 Copying Applications

Figure 7-13 Applications to Copy

You can copy and paste the following within the same editor or to another editor:

¢ Applications, including custom applications
¢ Disconnected applications

* Driver icons

1 Select an application or driver icon.
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2 Press Ctrl+C, then Ctrl+V.

The copy and paste operations are also accessible from the Clipboard context menu. (Currently, they
aren’t accessible from the main menus.)

When you copy an application in the same editor, Designer copies all of the application’s attributes,
and copies all subelements. Therefore, all drivers that the application is connected to are copied, and
all policies that the drivers contain are also copied. The new application defaults to connect to the
same driver sets that the previous application connected to.

To copy an application to a different driver set (in the same editor or in another editor):

1 Select the application.

2 Press Ctrl+C.

3 Select the target driver set that the application will connect to.
4 Press Ctrl+V.

If you copy and paste an application without selecting a target driver set, Designer makes a copy and
connects it to the current driver set.

You can select multiple applications and then copy and paste them.

7.5.2 Copying a Driver Set

Figure 7-14 Driver Sets
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You can copy and paste driver sets within the same Identity Vault or to another Identity Vault in the
same editor or in another editor.

1 Select a driver set.
2 Press Ctrl+C, then Ctrl+V.

When you copy a driver set in the same editor, Designer copies all of the attributes of the driver set,
including the following:

+ All drivers that the driver set is connected to

Building a Model 69



¢ All policies that the drivers contain

+ All target applications
To copy to a different editor:

1 Select a driver set.
2 Press Ctrl+C.

3 Select the target Identity Vault in the other Modeler editor where you want the driver set to be
copied to.

4 Press Ctrl+V.

By default, the new driver set is created in the same Identity Vault as the one that it was copied from.
However, if you select another Identity Vault, the driver set is copied there.

After you copy and paste, you might need to move the pasted objects to a better location so that they
don’t cover up an existing object. To do this, leave the objects selected after you paste them, then
move them. Another way to easily select objects:

1 Right-click a driver set.

2 Select Select All Connected Applications.

3 Move one of the selected applications.

All connected applications move together.

When you copy a driver set, it has the same settings, except for the selected servers, which are blank.
This exception occurs because the Identity Manager engine does not allow more than one driver set
on an Identity Vault to be associated with the same server. Therefore, you need to set up the servers

for the new driver set. If you copy an Identity Vault, Designer copies the driver sets. The new driver
set has the same server settings set up for you.

You can select multiple driver sets and then copy and paste them. To copy and paste multi-driver
connections, you must copy the driver set or Identity Vault that contains them. In Designer 2.1, if
you copy the application that has a multi-driver connection, the application and only one of its
drivers are copied.

7.5.3 Copying an Identity Vault

You can copy and paste Identity Vaults within the same editor, to another editor in the same Modeler
space, or in a specific Domain Group.

1 Select an Identity Vault.

2 Press Ctrl+C.

3 Select nothing or the target Domain Group (in the same editor or another) where you want the
Identity Vault to be copied to.

If you select nothing, the new Identity Vault is copied to the right of the previous Identity Vault
in the current editor.

4 Press Ctrl+V.

The new Identity Vault appears to the right of the previous Identity Vault and is the same size as the
one that is it being copied from.
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When you copy an Identity Vault, Designer copies all of the elements of the Identity Vault. The
elements include servers, e-mail templates, driver sets, and connected applications.

You can select multiple Identity Vaults and then copy and paste them.

7.5.4 Copying a Domain Group

You can copy and paste Domain Groups within the same editor or to another editor in the same
Modeler space or in a specific Domain Group.

1 Select a Domain Group.
2 Press Ctrl+C.
3 Select the location for the new Domain Group.

If you select nothing, the new Domain Group is copied to the right of the previous Domain
Group in the current editor.

4 Press Ctrl+V.

The new Domain Group appears to the right of the previous Domain Group, and is the same size as
the one it was copied from.

When you copy a Domain Group in the same editor, Designer copies all of the attributes of the
Domain Group. However, Designer doesn’t copy all subelements.

You can select multiple Domain Groups and then copy and paste them.

7.5.5 Copying between Editors

To easily copy and paste between two editors:
1 Using the Project view, open two projects.

One project is active. The second project’s tab displays at the top of the Modeler.
2 Close the palette by clicking the control arrow on the palette’s title bar.

3 Click the second project’s tab and drag it to the Modeler’s right border.

The tab changes to a folder icon until it arrives near the border, where the folder changes to an
arrow.

Building a Model
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4 Release the mouse.
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After an item is in the Modeler space, you can move it by dragging it to a new location. The Modeler
prevents you from placing objects where they don’t belong. For example, you cannot move a driver
set out of an Identity Vault to the Modeling space, or drop an application inside of an Identity Vault.
You can always drag objects into a Domain Group, or drag a driver set from one vault into another.

If you drag a driver set into an Identity Vault, the Identity Vault automatically grows or shrinks to fit
the driver set, so you don’t need to manually resize the vault. This behavior can be turned on or off
in Preferences. See Section 23.3.8, “Modeler,” on page 461.

Figure 7-15 Example Driver Sets in an Expanded Identity Vault
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7.7 In-Line Editing

Figure 7-16 An In-Line Edit
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To edit the names of objects, do one of the following:

¢ Select the item, press F2, then edit the label.
+ Double-click the item, then edit the Name field.

You can do an in-line edit for any type of item in the Modeler, including the driver lines.

7.8 Tooltips and Toolbar

As you move the mouse over objects in the Modeler, a tooltip appears with the name of the object.

Figure 7-17 A Tooltip

The Modeler also provides a tool bar.

Figure 7-18 The Modeler Toolbar
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The Modeler toolbar enables you to quickly find often-used features:

+ Search

¢ Find a driver’s status (also available from the Live menu when you select a driver set or Identity
Vault)

+ Start, stop, or restart a driver (also available from the Live menu when you select a driver set or
Identity Vault)

¢ Clear all items
+ Save a snapshot of the model

¢ Launch Modeler preferences
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¢ View demos on how to use the Designer
¢ Get help

7.9 Organizing by Domain Groups

*

*

*

Section 7.9.1, “About Domain Groups,” on page 74

Section 7.9.2, “Key Features,” on page 75

Section 7.9.3, “Creating a Domain Group,” on page 75

Section 7.9.4, “Minimizing (Collapsing) Domain Groups,” on page 77
Section 7.9.5, “Restoring Domain Groups,” on page 77

Section 7.9.6, “Maximizing Domain Groups,” on page 77

Section 7.9.7, “Auto-Placement of Neighbors,” on page 78

Section 7.9.8, “Grouping into a New Domain Group,” on page 78
Section 7.9.9, “Ungrouping a Domain Group,” on page 79

Section 7.9.10, “Clearing Contents,” on page 80

Section 7.9.11, “Changing a Domain Group Icon,” on page 81
Section 7.9.12, “Keyboard Support for Domain Groups,” on page 81

7.9.1 About Domain Groups

Figure 7-19 The Domain Group Option on the Palette
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Domain Groups enable you to organize your model into logical groupings that help to keep your
diagram clean. Domain Groups have no technical function, and they have no impact on how items
and relationships are stored in the Identity Vault. This option is just a tool to help you better organize
and view items in the Modeler.

Using Domain Groups is the key to modeling your entire enterprise, no matter how large it is. You
can create a model that is manageable, useful, and logical, according to how you want to organize
and diagram your enterprise.
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Figure 7-20 A Domain Group in the Modeler
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7.9.2 Key Features

+ Change a group name through the Properties view.
¢ Drag and drop items in and out of groups.

¢ Minimize or restore groups.

+ Move everything in a group.

¢ Remove everything in a group.

¢ Nest groups within groups (no limit).

¢ Resize groups. A minimum size is enforced.

¢ Ungroup. Remove the group but leave the children.

7.9.3 Creating a Domain Group

1 Drag and drop a Domain Group from the palette to the Modeler space.

2 Organize items inside Domain Group items.

To add another Domain Group, right-click inside the Domain Group, then select Add Domain
Group.

To add an Identity Vault, do one of the following:

¢ Drag an Identity Vault from the palette.
¢ Right-click in the Domain Group, then select Add Identity Vault.
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The Add Server to Identity Vault dialog box appears. If you select Specify a Server, Designer
provides a dialog box that enables you to select an eDirectory™ server or specify a server
manually.

To add a driver set:

1 Right-click inside an Identity Vault.
2 Select Add Driver Set.

To add an application:

1 Right-click a Driver Set object.
2 Select Add Connected Application.

The application is added to the right of the right-most connected application. If this is the first
application, it is placed under the driver set.

The application defaults to a generic application type. To change the type:

1 Right-click the application, then select Properties.
2 Select a different application, then click OK.

When you add selected items to a Domain Group, the Domain Group expands.

Figure 7-21 A Domain Group
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If you move an item to the edge of the Domain Group, the boundaries expand, so that the items
remain inside the Domain Group. You can drag an item from the Domain Group to remove it from
the group.
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You can have nested domains. If you expand a nested domain, the outer (hosting) domain auto-
increases in size. You aren’t required to manually resize parent domains. By expanding, the hosting
domain displays the nested domain, so that the nested domain isn’t cut off.

7.9.4 Minimizing (Collapsing) Domain Groups

To minimize a Domain Group, click the Minimize = button. When a Domain Group is
minimized, it defaults to a random icon. You can use Properties to change the icon. (See “Changing
a Domain Group Icon” on page 81.) The icon and minimized state of the group are saved in the
Project file.

When a group is minimized, you can’t see its contents, nor can you drag new items into the group.
However, you can move, rename, or delete it.

When you minimize a group, lines that were connected to items in the group now connect to the
group. This functionality enables you to see that there is a relationship with items in the group and
items outside the group. Depending on your objects, their relationships, and state of other related
groups, multiple lines might collapse into one line.

Figure 7-22 A Collapsed Group
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When you expand the group, the lines are moved back to the actual items they connect with. This
functionality works for any level of nesting of groups.

7.9.5 Restoring Domain Groups

To restore the Domain Group to its original size, click the Restore B button.

7.9.6 Maximizing Domain Groups

To maximize a Domain Group, click the Maximize - button. The group expands to a much larger
size. To return it to the original size, click the Resfore button.

You can maximize only first-level groups. For inner groups, the Maximize function is disabled.
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7.9.7 Auto-Placement of Neighbors

To push or pull the neighboring items when you expand or contract Domain Groups, hold down the
Ctrl key while you expand or contract the Domain Group. Any item that is to the right or below a
Domain Group is affected.

7.9.8 Grouping into a New Domain Group
1 In the Modeler, select multiple items.
2 Right-click, then select Add to Group.

The Modeler creates a new Domain Group and adds those items, preserving their relative spacing to
each other. This process removes the items from wherever they previously existed and places them
in the proper area in the new group.

The following figure illustrates two Applications that have been added to a new Domain Group and
removed from their previous groups.

Figure 7-23 Grouping into a New Domain Group
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7.9.9 Ungrouping a Domain Group

Figure 7-24 Ungrouping a Domain Group

= Straighten Connections
Distribute L4
Align 3

—a Add to Group

an-0 8 Ungrou
e Far-Cut

o /7 Clear Domain Contents

Docurnent Selection. ..

Live L4

¥ Delete

Properties

To ungroup a Domain Group, right-click it, then select Ungroup.

This process removes the Domain Group but leaves all contents where they are, so that they won’t
be deleted. This is just a way to ungroup the items. Depending on what level you are in the Modeler,
the ungrouped items are automatically added to the parent group or to the main Modeling space.
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7.9.10 Clearing Contents

Figure 7-25 Clear All Items
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To remove all contents from the Modeler, click Model, then select Clear All Items.
To remove all contents from a Domain Group, right-click, then select Clear Domain Contents.

Designer prompts you before clearing the Modeler space.
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7.9.11 Changing a Domain Group Icon

1 Right-click a Group Domain item in the Modeler, then select Properties.

® Properties for Domain Group 1
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Mame: I :I)Dmain Group 1

MNotes:

2 Browse to and select an image (for example, finance.png).

Icons for Domain Group components reside in the

com.novell.designer.core\icons\Group directory. By default, Designer opens

the Group directory.

Designer supports .GIF, . JPEG, . PNG, and Windows . BMP formats. You can add your own

icons to the Group directory.
3 Click Open, then click OK.

The minimized 16x16 version of the image also now appears in the Domain Group title bar.

As you add Domain Group items, Designer randomly assigns icons from the Group directory to the

new Domain Group.

7.9.12 Keyboard Support for Domain Groups

Table 7-3 Shortcut Keys for Domain Groups

Keystroke Description

Alt+Down-arrow
Alt+Up-arrow

Delete Deletes the selected items

Navigates into a Domain Group

Navigates out of a Domain Group
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7.10 Connecting Applications

¢ Section 7.10.1, “Automatic Connections,” on page 82

¢ Section 7.10.2, “Connection Target Highlights,” on page 82

¢ Section 7.10.3, “Automatically Creating Objects,” on page 83

¢ Section 7.10.4, “Auto Redraw,” on page 83

¢ Section 7.10.5, “Manually Connecting,” on page 83

¢ Section 7.10.6, “eDir-to-eDir Connections,” on page 84

¢ Section 7.10.7, “Multiple Driver Connections,” on page 84

¢ Section 7.10.8, “Straightening Connections,” on page 86

¢ Section 7.10.9, “Reconnecting,” on page 87

¢ Section 7.10.10, “Driver Icons,” on page 87

¢ Section 7.10.11, “Selected Drivers,” on page 87

¢ Section 7.10.12, “Auto-Layout of Imported Objects,” on page 87
¢ Section 7.10.13, “Keyboard Support for Connections,” on page 88

7.10.1 Automatic Connections

When you drag an application into the Modeler space, and the Modeler contains a driver set,
Designer automatically draws a connecting line between the Driver Set object and the application.

When you use the palette’s Connection function to connect an application to an Identity Vault, you
can begin or end your driver line at the Identity Vault. The line automatically connects to a driver set
in an Identity Vault.

If the Identity Vault contains more than one driver set, the Connection function connects the driver
line to the first driver set. This functionality also works for multi-driver connections.

All multi-driver driver lines are bendable. You can lay them out so that the lines don’t overlap at any
angle. Also, you can reconnect multi-driver connections.

If an Identity Vault has multi-driver connections in a Domain Group and you minimize that Domain
Group, a single collapsed line represents all of the multi-driver connections.

7.10.2 Connection Target Highlights

When you drag an application across the Modeler space, the closest Identity Vault and closest driver
set in that Identity Vault are highlighted. The highlights indicate the item that the application will
connect with when you drop the application.
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Figure 7-26 Connected Objects
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7.10.3 Automatically Creating Objects

If you drop an application into the Modeler space, and that space has no Identity Vaults, Designer
automatically creates an Identity Vault.

7.10.4 Auto Redraw

If you move items, lines are automatically redrawn.

7.10.5 Manually Connecting

To manually connect an application to a driver set:

1 Click Connection in the palette.

2 Draw a line between the application and the driver set.

To reconnect an application, select the driver line, then drag one end of the line to another driver set
or application.

The drag gesture gravitates the line towards the nearest connectable point. This functionality helps
you know what you can connect to and where you can connect the item. If you try to connect to
something that isn’t allowed, the cursor usually indicates so, or nothing happens when you drop the
item.

Building a Model

83



7.10.6 eDir-to-eDir Connections

Figure 7-27 eDir-to-eDir Connections

An eDir-to-eDir connection is a special type of connection. It is used frequently in Identity Manager
environments. This connection is a way to configure two eDirectory drivers to communicate directly
with each other. (No other drivers are able to communicate directly with any other type of driver.)
This type of connection is most commonly used for synchronizing a local directory tree with a
Metadirectory Identity Vault.

To create an eDir-to-eDir connection, do one of the following:

¢ Drag a line between two Identity Vaults

+ Drag a line between two driver sets

When you connect a line between two eDirectory applications, the line automatically turns into an
eDir-to-eDir connection. See the illustration in Section 12.2.6, “Viewing an eDir-to-eDir Driver,” on
page 234.

To disconnect an eDir-to-eDir connection, right-click an eDir item, then select Disconnect eDir-to-
eDir. Designer creates two new eDirectory applications and redirects each driver to its respective
application. A new driver is not created. No data is lost. Designer keeps the same drivers.

If you delete one side of an eDir-to-eDir connection, Designer converts the remaining half into a

regular driver connection to an eDirectory application.

7.10.7 Multiple Driver Connections

To connect more than one driver from a driver set to an application:

1 Select Connection in the palette.

2 Connect the driver set and the application again and again.

Each time you connect, a new line is added. All lines are bendable, so that the lines don’t overlap. To
get the model to look optimal, you probably need to move the application slightly from its default
position.

84 Designer 2.1 for Identity Manager 3.5.1



You can also connect more than one driver to a single application. This actually causes the
application to act as a hub. Each driver can connect to and authenticate to the application or system
the same or differently, depending on your needs. Each driver can access the same part of the
application or system or different parts (for example, different tables in a database). The Modeler
lets you diagram a layout according to your needs.

Figure 7-28 Multi-Driver Connections
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7.10.8 Straightening Connections

To straighten connecting lines:

1 Press Ctrl, then select one or more applications in the Modeler.

Distribute 4
Align 4

2 Right-click, then select Straighten Connections.

What is straightened depends on what you select:

Table 7-4 Straightened Connections

Selected Item What Is Straightened

A driver That driver’s line

An application The connecting driver’s line

An |dentity Vault All lines that originate from that driver set in that
Identity Vault

A Domain Group Everything in the Domain Group

A project (selected by clicking the Modeler’s Everything in that project

background)

Lines are straightened only if they are less than 20 pixels from a north, west, south, or east
alignment. The intent of this operation is to quickly nudge lines that are almost straight, so that they
become perfectly straight.

This nudging removes the tedium of meticulously dragging items into perfect alignment and being
concerned with the pixels. If a line isn’t almost straight, it is left alone. In fact, the Straighten
Connection operation is disabled unless the selected items qualify to be straightened. If some of the
selected items qualify but others don’t, the operation is still enabled, but only eligible lines are
straightened.
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7.10.9 Reconnecting

To reconnect components, do one of the following:

¢ Drag the end of a line (driver) from one application to another.

¢ Drag the end of a line (driver) from one driver set to another.
7.10.10 Driver Icons

Table 7-5 Driver Icons

Icon Description
[3 A driver. The entire line between a driver set object and an application represents
a driver.
§-] A remote driver.
™ A firewall. Indicates that the driver is communicating across a firewall.

The following figure illustrates these icons.

Figure 7-29 Driver Icons
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To see, turn on, or turn off driver icons:

1 Right-click a driver line.

2 Select an option (for example, Mark as Firewall) to turn on or turn off.

7.10.11 Selected Drivers

As you move the mouse over a driver, the line thickens so that it is more obvious. You can click and
interact with this line.

7.10.12 Auto-Layout of Imported Objects

When you import objects from the directory, they are automatically laid out, connected with lines,
and assigned an icon that matches objects and relationships as closely as possible.
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For example, if you import a Driver Set object, Designer imports all of the drivers and connects
them with lines. Also, each driver points to an application icon. Application icons include the
following:
¢ The exact Application icon (for example, Avaya* or PeopleSoft*)
¢ The image stored on the driver
The image is embedded in a square application icon.
¢ A generic application icon

If no image is stored on the driver, Designer supplies an icon for one of the following
applications:

+ Generic

+ JDBC*

+ LDAP

¢ Delimited Text

The auto-layout mechanism uses the layout topology that you have selected. The default is Fan
Out - Bottom. You can customize this setting in Preferences. See Section 23.3.8, “Modeler,” on
page 461.

7.10.13 Keyboard Support for Connections

Table 7-6 Shortcut Keys for Connections

Keystroke Description
/ Navigates to the item’s next connection
\ Navigates to the item’s previous connection

7.11 Aligning and Laying Out Components

¢ Section 7.11.1, “Alignment Hints,” on page 89
¢ Section 7.11.2, “Using Rulers,” on page 90

*

Section 7.11.3, “Using a Grid,” on page 92
¢ Section 7.11.4, “Distributing Applications,” on page 93
¢ Section 7.11.5, “Auto-Layouts,” on page 94
¢ Section 7.11.6, “Layouts to Use for Imports,” on page 94
Alignments place objects in the same horizontal or vertical plane. Alignments help you see

relationships in your model. You can align or attach items to the left, center, or right of alignment
guides.

When you move the guide, attached items move with it, staying attached in the same relative
positions.
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To align components:

1 Press Ctrl, then select more than one item.
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2 Right-click, then select Align.

3 Select an alignment option.

You can also attach an item by dragging it to a guide. After you wait a moment, the guide line is
highlighted, indicating that the item is attached.You can align within the same group but not across
groups.

Guides that you set up are restored the next time that you run Designer. You don’t need to re-create
them.

Also, the alignments and attachments (left, center, or right) are stored in the project on a per-item
basis, so that they are also restored.

7.11.1 Alignment Hints

Horizontal and vertical “hint” lines automatically show as you drag items into vertical or horizontal
alignment with neighboring items.

Building a Model 89



Figure 7-30 Alignment Hints
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The Alignment Hints feature is off by default. To turn it on, click View > Alignment Hints.

Horizontal and vertical hint lines automatically show as you drag items into vertical or horizontal
alignment with neighboring items.

7.11.2 Using Rulers

To turn on the horizontal and vertical rulers:

1 Click the Modeler space to make it active.
2 Click View > Rulers.
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To create a guide (line), click either ruler. If the Modeler background is dark blue, you might want to
change the color so that the guides are easier to see.

To anchor items to a guide, drag the items in the model to the line.

To simultaneously move all anchored items, drag the line.

Building a Model 91



7.11.3 Using a Grid

Figure 7-31 The Modeler's Grid
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When the grid is on, the snap-to-grid functionality is on.
To turn grid lines on and off:

1 Click the Modeler, so that the Modeler is the active view.
2 Click View > Grid.

To coerce objects to not align with the grid, temporarily turn off snap-to-grid by holding down the
Alt key. (Linux doesn’t support this functionality.)

To constrain items to north-south or east-west coordinates, press Shift while dragging the items.
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To change the grid size:

1 Click Window > Preferences > Designer for IDM > Modeler > Display.
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2 Type a value in the Grid Width field.

7.11.4 Distributing Applications

Figure 7-32 Distributing Applications
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To equally distribute (space) applications horizontally or vertically:

1 Press Ctrl, then select three or more items.
2 Right-click, then select Distribute.

3 Select a distribution (for example, Vertical).
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7.11.5 Auto-Layouts

Designer ships with a number of predefined layout topologies: circle, half-circle, star, box, and
different fan-out layouts.

Figure 7-33 A Circle Layout
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These layouts are set on a per-driver-set basis. Therefore, each driver set can have its own layout.
To select a layout:

1 Right-click a driver set, then select Arrange Applications.
2 Seclect an arrangement (for example, Fan Out - Left).
If your model has an incorrect layout, the layout options are dimmed.
After you set a layout, applications that you connect will automatically snap into that layout. Certain
connected objects (for example, multi-driver connections, eDir-to-eDir connections, and

applications that are connected but reside in a different Domain Group) are ignored. They aren’t
included in the layout, and they don’t disturb it.

An option on the Arrange Applications submenu on the Modeler’s context menu enables you to
expand or contract the layout arrangement. This option makes all spokes of the layout longer or
shorter when you drag a slider.

7.11.6 Layouts to Use for Imports

To specify what layout to use on new driver sets that you import:

1 Select Window > Preferences > Designer for IDM.
2 Click Modeler > Layouts.
3 Select an arrangement (for example, Half Circle), then click OK.
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7.12 Editing Multiple Objects

You can open multiple objects and edit them at the same time. These objects must be of the same
type (for example, policies).

To find out whether you can edit an object, right-click it. If Edit displays among the menu items, you
can edit that object.

1 In the Outline view, expand the project that contains the objects that you want to edit.
2 Select the objects.

3 Right-click, then select Edit.

4 Edit the objects.

You can copy and paste from one editor to another. Data must be of the same type.

7.13 Modeling Active Directory Domain
Controllers

¢ Section 7.13.1, “Configuring a Connection,” on page 95
¢ Section 7.13.2, “Discovering Controllers,” on page 95

¢ Section 7.13.3, “Information about Domain Controllers,” on page 96

7.13.1 Configuring a Connection

You can configure an LDAP connection to an Active Directory* system so that you can discover its
Domain Controllers.

1 Right-click the AD application, then select Properties > Connectivity.

@ Properties for Active Directory 2 ;[Elﬂ
|t3f|:'E Filker bext 4. Connectivity =R v

-1, General

- 2. Environiment LDaP |\-'NC |

-3, Administrakor _

4. Conneckivity Haost: ||dm44.hraun.vm|:u.cnm

-5, AD Domain Lser: I cn=administrator, cn=users,dc=idm44 ,dc=local

Password: I Hkk

2 Complete the LDAP authentication information.

As you tab from the Host field to the User field, Designer automatically builds a full user
context. You can modify this context.

7.13.2 Discovering Controllers

1 Right-click the Active Directory application.
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2 Select Discover Domain Controllers.

E]l 1dentity Yault

If Designer finds any controllers, it lays them out and expands the Active Directory application
as a container.

7.13.3 Information about Domain Controllers

Information about each controller is loaded into the Modeler. To view this information, edit the
Domain Controller object and select the AD Domain page.

Figure 7-34 The AD Domain Page
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| type Filker bext 5. AD Domain L

71, General

2. Environment @ This information is currently used solely For docurmentation purposes, ! Qg}g |

i3, Administrakor :

i, Connectivity - -

5. AD Domain DMS Host: Ildde.ldedom.Iocal

Operating System: IWindDWS Server 2003

Cperating System Wersion: |5.2 [3730)

Service Pack: |Service Pack 1

If the LDAP connection information is filled out, you can reread the information from that system
by clicking the Refresh button on the AD Domain page.

7.14 Saving Your Model

To save your model, do one of the following:

¢ From the main menu, select File > Save (or Save All).
+ From the main menu, select File > Close > Yes.
+ Click the X in the Modeler’s tab, then select Yes.
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For more information, see “Saving” in Section 8.4.2, “Tasks You Can Perform from the Project
View,” on page 114.
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Workspaces, Perspectives, and
Views

This section assumes that you have created a project. See Chapter 6, “Creating a Project,” on
page 49.

Designer has many views to help you manage your projects. Many of these views help you manage
the different elements that appear in the Modeler view and give you a different perspective on the
projects you are creating. For instance, the Project view shows all of the projects you have presently
created, while the Outline view shows all of the objects that have been created and added to the
project. The Navigator view shows all of the files that have been created for the project and their
respective file types and locations.

For information on the Modeler view and its functions, see Chapter 7, “Building a Model,” on
page 53. For information on policies, see Understanding Policies for Identity Manager 3.5.1 and
Policies in Designer 2.1.

¢ Section 8.1, “Specifying the Workspace,” on page 99

¢ Section 8.2, “Managing Perspectives,” on page 105

¢ Section 8.3, “Managing Views,” on page 107

¢ Section 8.4, “The Project View,” on page 113

¢ Section 8.5, “The Outline View,” on page 121

¢ Section 8.6, “The Navigator View,” on page 135

¢ Section 8.7, “The Policy Set View,” on page 138

¢ Section 8.8, “The Properties View,” on page 139

¢ Section 8.9, “The Search Results View,” on page 142

¢ Section 8.10, “The Tasks View,” on page 143

¢ Section 8.11, “The Trace and Error Log Views,” on page 144

¢ Section 8.12, “The Dataflow View,” on page 144

8.1 Specifying the Workspace

A workspace is a directory on your local hard drive where your projects and settings are stored. You
specify your workspace directory each time you launch Designer, unless you select the Use this as
the default and do not ask again option to skip the Workspace Launcher window.
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Figure 8-1 Selecting a Workspace Directory

@ workspace Launcher X|

Select a workspace

Designer stores your projects in a folder called a workspace,
Choose a workspace Folder bo use For this session,

e et - B | D ocurnents and Setkingsiuserworkspace Browse. .. |

[ Use this as the default and do not ask again

0K, I Cancel

A typical default workspace directory for a Windows™* workstation is Documents and
Settings\username\workspace.

You can switch to another workspace by selecting File > Switch Workspace. Designer quickly
restarts, loads the new workspace, and loads any projects and settings you have in that workspace. If
the workspace doesn’t exist, Designer creates it.

You can have multiple workspaces.

¢ Section 8.1.1, “Project File Format,” on page 100

¢ Section 8.1.2, “Editing by Using a Related Editor,” on page 101

8.1.1 Project File Format

All projects are stored on the file system in a directory. By default on Windows workstations, this is
inthe C: \Documents and Settings\Username\workspace directory on a Windows
workstation. However, you can specify a different directory when you create the project. (See
Chapter 6, “Creating a Project,” on page 49.) All of your data and graphical layout information is
saved in a directory corresponding to the project name. For example, the following files are stored
under the \workspace\Blanston3 directory:

Figure 8-2 Local Directory Structure

» o
= '-12] ¢ Address |[3) C\Documents and SettingsiMovell User\workspace'\Blanstonl

Mame Size  Type
|[C)Blanstonl_files File: Folder
| documentation File Folder
project 1 KE PROIECT File
Blanstonl .proj 1KE PROIFile

odelerOutlineState, ol ZKE  #ML Document

The main file in the project’s directory is the . pro7j file. This file uses an industry-standard XML
format called XMI (XML Metadata Interchange Format). You never need to directly edit this file.
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What is XMI?

XMI enables easy interchange of metadata between modeling tools and between tools and metadata
repositories in distributed heterogeneous environments. XMI integrates three key industry
standards:

¢+ XML (Extensible Markup Language, a W3C standard)

¢ UML (Unified Modeling Language, an OMG modeling standard)

¢+ MOF (Meta Object Facility, an OMG modeling and metadata repository standard)
The integration of these three standards into XMI combines the best of OMG and W3C metadata
and modeling technologies. The integration enables developers of distributed systems to share
object models and other metadata. XMI, together with MOF and UML, forms the core of the OMG

repository architecture that integrates object-oriented modeling and design tools with each other and
with a MOF-based extensible repository framework.

For more information about XMI, go to XML Metadata Interchange (XMI) (http://www.oasis-
open.org/cover/xmi.html).

8.1.2 Editing by Using a Related Editor

The editors enable you to edit projects or other items listed in the Navigator view. Designer comes
with a number of editors that you can use for editing, with a default editor designated for most file
types. To select an editor other than the default editor:

1 Expand a project in the Navigator view.

2 Select the documentation\images or the resources folder.
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3 Right-click on any of the files, such as .docgen, .xm1, .pdf, or .t xt, and select Open With >
Editor Name. The example below shows the file opening with the Text Editor from the
Navigator view.

Project | Outling ﬂim =8l
PN
11 Blanston
=-1=F Blanstonl
= Blanstonl_files
== documentation
=+ images
Ltﬂ 1EF713BC-132C-28010-940E-FFE1F98
Blanstonl_1.docgen
Blanstonl.docgen
by Blanston . fo.xrml

[Elearaton oo it |

| =t s L

i Cpen esigner.xml

g Open With  +|® B Text Editor

E = Copy = System Editor

| = In-Place Editor
¥ Delete Default Editor

I

i Move ger.source.style.xml

+|

BB Rename

1 g Import,..
BOE LA Export.,

o

I fril
I Blar | Refresh

=B oo *

= Blar

1= Blar Froperties

The editor you choose depends on the type of file you click on.

The following figure illustrates a text editor. When you right-click the editor, a menu is available:
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Figure 8-3 The Text Editor’s Menu
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<foow.novell . designer. idm.model:Projects

< Undo CirHz
Rewvert File
Save
Shiow I alt+Shift+a r
Lt CirH+X
Copy CirH+C
Paste Cir+Y
Shift Right
Shift Left

£ ] |

The Preferences window lets you set a text editor’s preferences. You get to this screen by selecting

Window > Preferences > General > Editors > Text Editors.
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Figure 8-4 Preferences: Text Editors

@ Preferences

| type filter text | Text Editors oo
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IResh:re Defaults ] [ Apply ]
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For information on the settings, see “Text Editors” on page 446.
Each file type you right-click brings up a list of editors.

¢ .docgen extension:
Style Editor (default)
Text Editor

*

*

*

System Editor
In-Place Editor
¢ Default Editor
¢ .xml extension:
Novell XML Editor (default)
Text Editor

*

*

*

*

System Editor
In-Place Editor
Default Editor

*

*
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¢ .txt extension:

Text Editor (default)
System Editor

In-Place Editor
Default Editor

¢ .pdf extension:

Text Editor

System Editor (default)
In-Place Editor
Default Editor

*

*

*

*

*

*

*

*

¢ .project extension:
Text Editor (default)
System Editor
In-Place Editor
Default Editor

*

*

*

*

¢ .proj extension:
+ Modeler (default)
Text Editor

*

*

System Editor
In-Place Editor
Default Editor

*

*

¢ .log extension:
DS Trace Editor
Text Editor

*

*

*

System Editor
In-Place Editor
Default Editor

*

*

8.2 Managing Perspectives

A perspective is a collection of related views and editors. To get to the perspective choices, select
Window > Open Perspective > Other. The following perspectives are available:

¢ Designer: Provides views (for example, Project, Outline, Property, and Tasks) and editors (for
example, the Modeler or the Policy Editor) to help you design and deploy Identity Management
solutions.

+ Resource: A generic perspective. You can use this perspective for projects other than Designer.
+ exteNd Perspective: For XML development to the exteNd platform.
+ Debug: Used for XML development.

¢ Section 8.2.1, “Opening a Perspective,” on page 106
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+ Section 8.2.2, “Resetting a Perspective,” on page 107
+ Section 8.2.3, “Closing a Perspective,” on page 107

8.2.1 Opening a Perspective

The Designer perspective should be open and active the first time you run the application. If you
close the perspective and want to reopen it, use menus or the Perspective Bar.

+ “Using Menus to Open a Perspective” on page 106

+ “Using the Perspective Bar to Open a Perspective” on page 106

Using Menus to Open a Perspective

1 On the main menu, click Window > Open Perspective.

Wdircdcnae

Help

Meswe W indo
Mewe Editor

Open Perspective

Shiow View

Customize Perspective...
Save Perspective As...

Reset Perspective

Close Perspective
Close all Perspectives

Mavigation

[ Launch wweb Browser ..,

Preferences...

2 Select Designer.
3 Click OK.

Using the Perspective Bar to Open a Perspective

1 On the main Perspective Bar (found on the right side, on the same level as the toolbar), click
the Perspective Switcher icon.

Desigrer |

Open Perspective| = =

. | —Palette — >|
(e

2 From the list, select Designer, then click OK.

You can also double-click the Designer label.
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8.2.2 Resetting a Perspective

After moving or resizing items in the Modeler workspace, you might want to return your perspective
to its original layout. To quickly reset items in the workspace:

1 From the main menu, click Window.

2 Click Reset Perspective.

8.2.3 Closing a Perspective

Do one of the following:

¢ On the main menu, select Window > Close Perspective (or Close All Perspectives).

Figure 8-5 Options to Close a Perspective

| REGEEE Help

Mewy YWindaw

Mew Edlitar
o

Open Perspective b
& Show Yiew 4

Customize Perspective...
Save Perspective As..,
Reset Perspective

Close Perspective

Close All Perspectives
Mawigation 4

[} Launch weh Browser...

Preferences...

+ On the Perspective Bar, right-click the perspective, then click Close.

8.3 Managing Views

Views enable you to view or edit projects.

¢ Section 8.3.1, “Opening a View,” on page 108

¢ Section 8.3.2, “Moving a View,” on page 108

¢ Section 8.3.3, “Minimizing and Maximizing Views,” on page 109
¢ Section 8.3.4, “Closing a View,” on page 109

¢ Section 8.3.5, “Reopening a View Window,” on page 110

¢ Section 8.3.6, “Using Fast Views,” on page 111
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8.3.1 Opening a View

Figure 8-6 Selecting a View to Open

MNew Window
ey Edlitar

ISR p =< | Eoriston2 - Dey

Open Perspective L4
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- Mavigator

Customize Perspective...

5F Outline
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[ Launch wweh Browser... & Tasks
[EE Trace
Preferences...
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To open a view, select Windows > Show View, then select an option.
To narrow the list of views, use the view filter:

1 Select Window > Show View > Other.

2 In the edit box, type the name of the view that you want (for example, Trace).

| frace

= (= Designer for Identity Manager
[El Trace

Cancel

You can open, maximize, and close these views, arrange them however you want, or make Fast
Views from them. See Section 8.3.6, “Using Fast Views,” on page 111.

To quickly expand a view, double-click the view’s tab.

8.3.2 Moving a View

To move a view, click the view’s tab, then drag it to one of the following locations:

¢ The left, bottom, top, or right of Designer
¢ Stacked with other views

¢ Outside of Designer, where it floats on your desktop

If two or more views are open, you can switch their order.
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8.3.3 Minimizing and Maximizing Views
To minimize a view, do one of the following:

+ Click the Minimize button in the view’s title bar — 5.

¢ Press Ctrl+M.
To restore the view to its original size, click the Restore button in the view’s title bar.
To maximize a view or editor, do one of the following

+ Double-click the view’s tab.
+ Click the Maximize button — &
* Press Ctrl+M.

When expanded, the view or editor fills the entire application space. This feature provides maximum
working space.

To restore the editor or view to its original dimensions, double-click the view’s tab.

8.3.4 Closing a View

To close a view or editor, do one of the following:

¢ Click the X on the title bar.
+ Right-click the title bar, then select Close.

Figure 8-7 Options to Close a View

Fast View
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8.3.5 Reopening a View Window

1 From the main menu, select Window > Show View.

i Mew Window
| Mew Editor
& *joho123
Open Perspective 8 — =
3 & Dataflow
; . .- igator
Customize Perspective. .. - .
. = Outline
Save Perspective As... i
(2 Policy Set

Feset Perspective
Close Perspective
Cloze All Perspectives

1= Project
lig7 Project Chedker
2 Provisioning “iewr

| Mavigation ¥ | [Ey Search Results
1[0 Launch Web Browser... & Tasks
[E Trace
Preferences. ..
T O pehie 9
R

2 Seclect one of the views (for example, Navigator).

You can also select Window > Show View > Other, then select one of the views under Designer for
Identity Manager (for example, Projects).

Figure 8-8 Other View Choices

| type filter text |

(= General

(= Debug

(= Desigher for Identity Manager
= Help

(= Provisioning
(= ML

Cancel

The views you can select are as follows:

+ General
+ Bookmarks
+ Console
+ Internal Web Browser
+ Navigator
¢ OQOutline

+ Problems
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+ Project Explorer
+ Properties
¢ Tasks
¢ Debug
¢ Breakpoints
¢ Debug
+ Expressions
¢+ Memory
+ Registers
¢ Variables
¢ Designer for Identity Manager
¢ Dataflow
¢ eDirectory Browser
+ Policy Set
+ Project
+ Project Checker
¢ Search Results
+ Trace
Help
+ Help
PDE Runtime

*

*

¢ Error Log
¢ Plug-In Registry
¢ Provisioning
¢ Data Item Mapping
¢ E-mail Notification
+ Provisioning View
+ XML
+ XPath Navigator

8.3.6 Using Fast Views

Fast Views provide an efficient way to manage certain types of views that you don’t want to clutter
the desktop, but still want to have readily accessible. To create a Fast View perspective:

1 Click the Show View as a Fast View Perspective icon [”in the bottom left corner of the
Designer window (under the Properties view).
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2 Select a View.
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3 The view appears to the left of the Modeler view. Right-click the view’s tab and deselect Fast
View to see the view’s default placement in Designer.

4 Reselect Fast View to have the view with its icon appear next to the Show View as a Fast View
Perspective icon.
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After the icon appears next to the Show View as a Fast View Perspective icon, do the following to
restore a Fast View to a normal view:

1 Right-click the Fast View icon.
2 Select Fast View.

3 Reselect Fast View to have the view with its icon appear next to the Show View as a Fast View
Perspective icon.

You can also set the following:

¢ Whether you want the Fast View to appear horizontally or vertically (the Orientation option)
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Figure 8-9 Options for Fast Views
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¢ Where you want to dock the Fast View

Views and selected items that appear by default in the Modeler view do not have the Fast View
option.

8.4 The Project View

The Designer Project view lists all of your projects so that you can quickly find, open, view,
navigate, manage, close, or delete any project.

Figure 8-10 The Project view
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¢ Section 8.4.1, “Viewing and Editing Projects: The Project View,” on page 113
¢ Section 8.4.2, “Tasks You Can Perform from the Project View,” on page 114
+ Section 8.4.3, “What You See in the Project View,” on page 116

8.4.1 Viewing and Editing Projects: The Project View

To open the Project view:

1 Click the Project tab in the upper left view of Designer.
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2 If'the view is not present, click Window > Show View from the main menu, then click Project.
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8.4.2 Tasks You Can Perform from the Project View

You can perform the following operations in the Project view.

Table 8-1 Project View Operations

Operation Description

Creating You can create projects with an easy-to-use wizard. You can also import projects from
the file system or an Identity Vault. Right-clicking a folder allows you to create a new
folder or a new file within that folder.

Importing You can import projects from the Identity Vault, from an iManager export file, or from
the file system.

Opening Double-clicking the System Model icon opens the project into the Modeler view. If
more than one editor is registered for the item you are opening, you can select which
editor you want to open it with.

Double-clicking the Project Name tab in the Modeler expands the Modeler to full
screen and double-clicking the Project Name tab again brings the Modeler back to its
default view size. All tabs work this way, including the Project tab.

Deleting To delete a project (or multiple projects), right-click the project, then select Delete. Or
select a project, then press the Delete key.

Copying and To copy a project, right-click the project, then select Copy Project. Give the project a
Moving a Project name, select where to place the project contents, then click OK.

To move a project, right-click the project, then select Move. In the Move Project
window, select the location for the project, then click OK.

Copy and Paste  You can copy files from one project to another by using Copy and Paste. Dragging
and dropping a file from one documentation folder to another works like a copy and
paste menu selection.

Drag and Drop  You can drag and drop files from one project to another and from one
documentation or resource folder to another.
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Operation

Description

Viewing
Properties

Saving

You can view the properties of a project by right-clicking a project and selecting
Properties. For convenience, the Properties view is located just below the Project
view and allows you to edit the properties.

When a project is first created, it doesn’t need to be explicitly saved because it's
already created in the file system. Whenever a project changes (through modifications
made in an editor) and you are exiting that project, you see a Save Resources dialog
box, which allows you to save your work.

To manually save after opening the project in an editor, do one of the following:

+ From the Main menu, click File > Save (or Save All).

+ On the main menu, click File > Close (or Close All) or click the X'in the Modeler’s
tab. If something was changed in the editor, you are prompted to save.

+ Click the Save icon.

For information on the file format, see Section , “What is XMI?,” on page 101.

Right-click any of the view tabs in the Project Group view to perform the following functions.

Figure 8-11 Options in the Project Functions
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Table 8-2 Right-Click Operations

Operation

Description

Fast View

Detached

Restore

Move

Size

Places the Project view in the lower left corner of the Designer screen.

Detaches the Project pane from the upper right location. You can then move the pane to
another location in the Designer window. The pane size adjusts to the area where you place
it. This is a feature of Eclipse that allows you to design your own look and feel for the
Designer utility.

To reattach the pane to the upper left location, drag the detached pane to just below the
Outline/Navigator panes, then position the pane just below the colored Project bar. When
you see the folders icon appear next to the Outline/Navigator tabs, release the mouse
button.

Restores a collapsed pane to its normal size.

Move View allows you to move the selected tab to another location in the Designer window.
Move Tab Group allows you to move all of the tabs connected to that group to another
location in the Designer window.

Allows you to adjust the size of the tab group’s pane.
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Operation Description

Minimize Allows you to collapse the selected tab’s pane. You can also click the Minimize/Maximize
icons in the right corner of each tab.

Maximize  Restores a collapsed pane to its normal size. You can also click the Minimize/Maximize
icons in the right corner of each tab.

Close Closes the tab. To re-open a closed tab, select Window > Show View > Project (or whatever
tab you want to open).

Icons to the right of the Project view tab change, depending on the tab you have open. With the
Project tab selected, you see the following icons:

Figure 8-12 Project Tab Icons
= project

il Blanston11.proj
s Modeleroutline. xm

Table 8-3 Project Tab Icons

Name Description

Expand Selected  Allows you to see anything under the item that you have selected. For example, in
Elements (+) the Project tab, selecting this icon shows all items in all of the projects. In the
Outline tab, select a driver and click this icon to expand all of the items associated
with that driver.
+

Collapse Selected  Allows you to collapse all of the items that you have selected. For example, in the

Elements (-) Project tab, selecting this icon collapses all items to show only the project titles. In
the Outline tab, select a driver and click this icon to collapse all of the items
associated with that driver.

Minimize/Maximize ~Minimize allows you to collapse the selected tab’s view. Maximize restores the
collapsed pane to its normal size.

= B8

8.4.3 What You See in the Project View

What you see when you click the Project tab depends on what is open. Below is an open Project tab
showing most of the items you can see for a project.
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Figure 8-13 Project View Icons
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Table 8-4 Project View Icons

Icon Name Description

Project Name The name of the created project. It is the name of the project stored in the
selected workspace directory. Double-clicking the Project name expands and
collapses the entries under the project.

Right-clicking a project name allows you to do the following:

+ Create a new |dentity Manager Project.

+ Import an Identity Manager Project from:
+ An Identity Vault
+ An iManager Export file
+ Afile system

*

Refresh the project.

+ Make a copy of the project.

*

Move the project to another workspace.

*

Delete the project.

+ View the project’s properties window.

Workspaces, Perspectives, and Views 117



Icon Name Description

System Model Double-clicking the System Model entry puts the project into the Modeler view.
You can create or import driver sets, drivers, channels, or policies into the Modeler
to modify the project as needed. Then you can deploy the driver set, drivers,

5 System Model channels, or policies into an Identity Manager system.

Right-clicking the System Model allows you to:

+ Create a new Identity Manager Project.
+ Import an Identity Manager Project from:
+ An Identity Vault
+ An iManager Export file
+ Afile system

+ Open the project in the Modeler.
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Icon Name

Description

Documentation

2 Docurnentation

Shows all of the files that have been saved under the documentation folder. For
example, under Blanston1 you see XML Source files (icon), PDF documents
(icon), and the log file. In addition, Blanston2 contains a Document Generator
style (. docgen with the * icon) that can be used as a template for all documents
generated, as well as PDF, RTF, and text files.

Right-clicking the documentation folder allows you to:

*

*

*

*

*

*

Create a new ldentity Manager Project.
Create a new file.

Open a wizard to create a document export template wizard. The wizard
generates a style (template with a . docgen extension) that displays under
the documentation folder. (See Chapter 16, “Documenting Projects,” on
page 299 for more information.)

Import an Identity Manager Project from:
+ An Identity Vault
+ An iManager Export file
+ Afile system
Import a file or a folder.
Copy the documentation folder.
Paste items into the documentation folder.

Refresh the folder’s view.

Right-clicking an entry under Documentation allows you to open the file in a text or
a system editor, where you can do the following:

*

*

Create a new ldentity Manager Project.
Import an Identity Manager Project from:
+ An Identity Vault
+ An iManager Export file
+ Afile system

Use Copy and Paste to copy documentation files to different projects or
folders.

Refresh the folder’s contents.

On Windows machines, . txt files are opened by default in a text editor in
the Modeler view.

On Windows machines, .pdf files are opened in Adobe* Reader if it is
available on the machine.

Open the file with the Text or System Editor. You can also double-click the file
to use the default editor assigned to the file type.

Rename a file.
Delete a file.

Right-click a .docgen file to run the Document Generator for this style. See
Editing by Using a Related Editor for more options.
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Icon Name Description

Resources The new resources folder under each project allows you to place any files that
you want included with your Designer projects. For example, you can place
DSTrace, HTML, XML, OpenOffice, etc. files in this folder and then double-click
the file to use the default editors within Eclipse or on the file system to edit those
files. You can drag and drop files from the desktop or from your favorite file
browser.

=F resources

Right-clicking the resources folder allows you to:

+ Create a new Identity Manager Project.
+ Add a new folder.
+ Add a new file.
* Import an Identity Manager Project from:
* An Identity Vault
+ An iManager Export file
+ Afile system
+ Import a file
* Import a folder

+ Copy, paste, open, rename, and delete subfolders.

*

Refresh the folder’s view.
.docgen File Right-clicking the . docgen file entry allows you to:

+ Create a new Identity Manager Project.
Blanston.docgen * Import an Identity Manager Project from:
+ An Identity Vault
+ An iManager Export file
+ Afile system

+ Copy and delete the .docgen file. Use Copy and Paste to copy
documentation files to different projects or folders.

+ Refresh and rename the file.

+ Open the . docgen file with the Style Editor. You can also do the same by
double-clicking the . docgen file.

+ Generate a document for this style.
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Icon Name Description

Additional File Because the resources folder can contain many different files, you can see
Types different icons displayed, depending on the file extension.

Right-clicking these any of these files allows you to:
+ Create a new |dentity Manager Project.
+ Import an Identity Manager Project from:

+ An Identity Vault
+ An iManager Export file

= resources

+ Afile system

+ Copy and delete the file. Use Copy and Paste to copy documentation files to
different projects or folders.

+ Refresh and rename the file.

+ Open the file or open the file with a text or system Editor. You can also
double-click the file and have Designer choose an editor for the file.

+ Delete the file.

8.5 The Outline View

The Outline view provides an outline of the active editor. The contents vary, depending on the editor.

¢ For the standard Designer editors, you see a tree view of the information, a thumbnail graphical
view, or a Policy Flow view, depending on which mode you are in.

¢ Ifyou open an XML editor on an XML file in the Navigator view (not the embedded XML
editor that’s part of the Designer editors), you see a tree view of the XML document.

¢ Section 8.5.1, “Viewing Contents of the Active Editor: The Outline View,” on page 121
¢ Section 8.5.2, “Tasks You Can Perform in the Outline View,” on page 122
¢ Section 8.5.3, “The Outline View Tab,” on page 123

8.5.1 Viewing Contents of the Active Editor: The Outline View

Typically, the Outline tab displays next to the Project tab or the Navigator tab. If it isn’t visible, click
Window > Show View > Outline.

Workspaces, Perspectives, and Views 121



Figure 8-14 An Outline Tab and View
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8.5.2 Tasks You Can Perform in the Outline View

Right-click any of the tabs in the Project Group View to perform the functions explained in
Section 8.4.2, “Tasks You Can Perform from the Project View,” on page 114. There are also some
icons to the right of the Outline tab. With the Outline tab selected, you see the following icons:

Figure 8-15 Outline Tab Icons
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Table 8-5 Outline Tab Icons (from Left to Right)

Icon Name Description

Show Model The default. Shows the project’s outline in the Outline tab.
Outline

B
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Icon Name

Description

Show
Thumbnail of
Modeler

Show Policy
Flow

=
u

Expand
Selected
Elements (+)

+

Collapse
Selected
Elements (-)

Filter

_¥i

Minimize/
Maximize

= B

Shows a thumbnail of what you see in the Modeler view.

With a driver selected in the Outline view, click this icon to see a working model of that
driver’s policy flow. By clicking any item in the Policy Flow modeler, you can see the
policies that have been created at that level. For more information about policies, see
Policies in Designer 2.1.

Allows you to see anything under the item that you have selected. For example, in the
Outline view, selecting the project name and clicking this icon shows all items in the
project. Select a driver and click this icon to expand all of the items associated with that
driver.

Allows you to collapse all of the items that you have selected. For example, in the
Outline view, selecting the project name and clicking this icon collapses all items to
show only the project name. Select a driver and click this icon to collapse all of the
items associated with that driver.

By enabling the Filter icon, you can select which items you want to see in the Outline
tab. The filters include the Identity Vault, Server, Driver Set, Driver, Publisher,
Subscriber, Policy, Entitlement, Application, Email Notification Template, and Design
Elements.

For example, you can filter the entitlements out of the outline view by clicking the filter
and deselecting the Entitlement check box. This hides the entitlement objects from the
Outline view. You can still add and edit entitlements in the Modeler view if this filter is
enabled.

For the E-mail Notification Template selections, Designer reads the machine’s locale
settings to determine which e-mail templates to display. If you want to see e-mail
templates in other languages, click the Filter icon and select the languages.

Minimize allows you to collapse the selected tab’s view, while Maximize restores the
collapsed pane to its normal size.

8.5.3 The Outline View Tab

What you see when you click the Outline tab depends on what is open. Below is an open Outline tab
showing most of the items you can see under a project. As you select an item (or items) in the
Outline view, the selection is also made in the Modeler. If the item in the Modeler isn’t visible, it
automatically scrolls into view.
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As items are added or removed in the Modeler, they are automatically added to the Outline view. To
undo that operation from this view, right-click and select Undo or Redo.

Figure 8-16 [tems You Can See under a Project
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Table 8-6 Items You Can See under a Project

Icon Name Description

Project Name  The name of the project when you create it. This is the name of the project stored in the

\workspace\project name directory. Right-click the project name to do the
following:

s,
4 + Under New, you can add an application, a Domain Group, or an Identity Vault.
+ Document the project.

+ Through the Live option, you can import a driver set from the Identity Vault.

+ Delete the project.

*

See the Properties window associated with this object.
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Icon Name Description

Identity Vault ~ An Identity Vault represents the eDirectory™ tree that has Identity Manager installed on
it. Right-click the Identity Vault to perform the following:
I * Under New, you can add a driver set, a library, or a server object to the project.
+ Manage Ildentity Vault schema.
+ Generate documentation on the Identity Vault.
+ Import schemas from a file.
+ Export the Identity Vault configuration and schema to a file.
+ Under Live:
¢ Import a driver set from eDirectory
¢ Deploy the Identity Vault
+ Compare all driver sets
¢ Import and deploy schema
+ Open iManager
* Browse the Identity Vault
+ Start, stop, and restart drivers, as well as show their status
+ Delete the Identity Vault.
+ See the Properties window associated with this object.
Domain Group Domain groups allow you to group projects into granular portions. Right-click the
Domain object to perform the following:
[d + Under New, you can add an application, a Domain Group, or an Identity Vault.
+ Generate documentation on the Domain.
+ Export driver sets to a configuration file.
+ Under Live, you can Import from the Identity Vault.
+ Delete the Domain Group.
+ See the Properties window associated with this object.

If you select Document this Group, your generated document filters items that are
outside the Domain Group. Drivers bordering the domain are included in the document.
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Icon Name Description

Library The Library object is a repository of commonly used policies that can be referenced
‘i frqm multiple locations. Yog can place a policy in the library that every drivgr ir? the
driver set can reference. Right-click the Library object to perform the following:
+ Under New, you can add the following policy types:
¢ Credential application
¢ Credential repository
+ DIrXML® Script
¢+ ECMASCcript
* Mapping Table
¢ Resource
¢ Schema Map
¢ XSLT
¢ Add a policy from a copy
+ Export the library to a configuration file.
+ Under Live, you can:
+ Import a policy
+ Delete a policy
¢ Compare a policy
+ Delete the Library object.
+ See the Properties window associated with this object.
Server Object  The Server object is the server in the tree where you have Identity Manager installed.
Right-click the Server object to perform the following:
ﬂ + Delete the Server object.

+ See the Properties window associated with this object.
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Icon Name Description

Driver Set The driver set is a collection of Identity Manager drivers that are stored in a single
location. Right-click the driver set to perform the following:
E + Under New, you can create a new driver, a job, or a library.
+ Copy the driver set settings and global configuration values.
+ Generate documentation on the driver set.
+ Import a driver configuration to a file.
+ Export the driver set to a configuration file.
+ Under Live:
¢ Import a driver
¢ Deploy a driver set

+ Compare the driver set in Designer to a deployed driver set in the Identity
Vault

+ Import and deploy driver set configuration attributes
+ Start, stop, and restart drivers, as well as show their status
+ Delete the driver set.
+ See the Properties window associated with this object.
If you select Document Selection, your generated document filters most items that are

outside the driver set. Child objects are also included and parent objects are included in
the document for perspective purposes.
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Icon Name

Description

Driver Object

A Driver object is a collection of channels, policies, rules, and filters that connect an

application to an eDirectory tree running Identity Manager. Each driver performs

different tasks. Policies, rules, and filters tell the driver how to manipulate the data to

©

perform those tasks. Right-click the Driver object to do the following:

+ Under New, you can add the following policy types:

¢ Credential application
+ Credential repository
¢ DirXML Script

¢ ECMASCript

¢ Entitlement

+ Job

* Mapping Table

¢ Resource

¢ Schema Map

¢ XSLT

¢ Add a policy from a copy

+ Copy driver settings or server-specific driver settings.

+ Show the dataflow view.
+ Simulate policy transformation.
+ Show the driver’s policy sets.

+ Run the Driver Configuration Wizard.

+ Synchronize passwords to an associated server.

+ Manage application schema.
+ Generate documentation for this driver.

+ Export the driver to a configuration file.

+ Copy server-specific data between servers. To do this, you must have more than
one server associated with the driver set. You can add a server to a driver set by
going into the Driver Set Properties page. The replica data that you can copy

includes:
¢ Global configuration values
+ Named passwords
¢ Driver authentication information
* Driver startup option

¢ Driver parameters
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Icon Name

Description

Driver Object,
Continued.

Publisher
Channel

Right-click the Driver object to perform the following:

+ Under Live:

*

*

*

*

*

*

Import a driver

Deploy a driver

Compare the driver in Designer to a deployed driver in the Identity Vault
Import and deploy driver configuration attributes

Start, stop, and restart drivers, as well as show their status

Set up driver security

+ Delete the Driver object.

+ See the Properties window associated with this object.

If you select Document Selection, your generated document will filter most items that
are outside the driver. Child objects are also included and parent objects are included in
the document for perspective purposes.

A channel is a combination of rules and policies, and Designer allows you to import a
channel instead of the entire driver. The Subscriber and Publisher channels describe
the direction in which the information flows.

The Publisher channel takes the event from the application, database, csv file, etc., and
sends that event to the Identity Vault. Channel events do not need to be corresponding.

Right-click the Publisher or Subscriber channel to perform the following:

+ Under New, you can add the following policy types:

*

*

*

*

*

Credential application
Credential repository
DirXML Script
ECMAScript

Mapping Table
Resource

Schema Map

XSLT

Add a policy from a copy

+ Run the Simulate Policy Transformation program on the channel to ensure that it
is working correctly.

+ Export the Channel configuration to a file.

+ Under Live:

*

*

*

*

Import objects into a driver
Import a policy
Deploy a channel

Compare the channel in Designer to a deployed driver channel in an Identity
Vault

+ See the Properties window associated with this object.
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Icon Name

Description

Subscriber
Channel

o

Policy

Overlay Icons

B

Schema
Mapping

M

A channel is a combination of rules and policies, and Designer allows you to import a
channel instead of the entire driver. The Subscriber channel takes the event from the
Identity Vault and sends that event to whatever the receiving system is (application,
database, CSV file, etc.). (See Publisher Channel for right-click actions.)

A policy is a collection of rules and arguments that allow you to configure an application
to send or receive events to or from eDirectory. You use policies to manipulate the data
you receive from eDirectory or from the application. Each driver performs different
tasks, and policies tell the driver how to manipulate the data to perform those tasks.

Right-click the Policy object to perform the following:

+ Edit, duplicate, save as, and delete the Policy object.

+ Run the Simulate Policy Transformation program on the policy to ensure that it is
working correctly.

+ Export a policy configuration to a file.
+ Under Live:
+ Deploy a policy

¢ Compare the policy in Designer to a deployed driver or channel policy in an
Identity Vault

+ Delete a policy.

+ See the Properties window associated with this object.
Overlay icons have a symbol overlay in one of the corners to signify that the object is in
a certain state. For example, the policy icon to the left signifies that the policy does not
belong to a policy set. An application icon with an overlay signifies that there are more

than one driver connected to the application. A driver set icon with a server overlay
signifies that the driver set is connected to an Identity Manager server.

Overlay icons can be informational, warnings, or they can signify errors. In the
Compare window, overlay icons tell you whether the object is on the server or is in
Designer.

Schema Mapping allows Identity Manager to synchronize information to the connected
system without changing the connected system. Schema translates all classes and
attributes for the connected system.

Right-click the Schema Mapping object to perform the following:

+ Edit, copy, save as, and delete the Schema Mapping object.

+ Run the Simulate Policy Transformation program on the object to ensure that it is
working correctly.

+ Export a Schema Mapping policy configuration to an XML file.
* Under Live:
+ Deploy a policy

+ Compare the policy in Designer to a deployed driver or channel policy in an
Identity Vault

+ Delete the object.

+ See the Properties window associated with this object.
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Icon Name

Description

Resource
Objects

XSLT

I

Filter

Resource objects include Application SSO objects and Repository SSO objects.
Double-clicking a resource object brings up the object in an editor.

Right-click the Resource object to perform the following:

*

*

*

*

Edit, duplicate, save as, and delete the Resource object.
Export a Resource policy configuration to a file.
Under Live:

+ Deploy a Resource policy

¢ Compare the policy in Designer to a deployed driver or channel policy in an
Identity Vault

Delete the object.

+ See the Properties window associated with this object.

XSLT represents XSLT style sheets, which are used instead of the DirXML Script.

Right-click the XSLT object to perform the following:

*

*

*

*

Edit, duplicate, save as, and delete the object.

Run the Simulate Policy Transformation program on the style sheet to ensure that
it is working correctly.

Export an XSLT style sheet configuration to an XML file.
Under Live:
+ Deploy the style sheet

+ Compare the style sheet in Designer to a deployed driver or channel style
sheet in an Identity Vault

Delete the object.

See the Properties window associated with this object.

Filter allows the objects to be sent. It's the gatekeeper that restricts the objects (groups,
users, and the attributes associated with them) that can be sent to and from an Identity
Vault.

Right-click the Filter object to perform the following:

*

*

Edit, and save the object.

Run the Simulate Policy Transformation program on the filter to ensure that it is
working correctly.

Export a filter configuration to an XML file.
Under Live, you can deploy the filter into an existing eDirectory tree.

Clear the Filter object.
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Icon Name

Description

Application
Object

Entitlement
Object

Job Object

&

The Application object represents a connected system, whether that system is a
database, an application, or CSV files.

Right-click the Application object to do the following:

*

*

*

*

Show the dataflow view.

Manage application schema

Set up remote control through VNC connectivity.
Generate documentation on the application object.

Under Driver, you can manage application schemas, deploy the driver, and set up
driver security.

Delete the object.
Under Distribute, you can select Horizontal or Vertical.

If this is an eDir-to-eDir connection, under Live, you can create eDir-to-eDir
certificates if this is an eDir-to-eDir connection.

If this is an eDir-to-eDir connection, you can configure the connections for SSL/
TLS activation.

See the Properties window associated with this object.

If you select Document Selection, your generated document filters most items that are
outside the driver. The driver object is also included and parent objects above the driver
object are included in the document for perspective purposes.

The Entitlement object represents an entitlement assigned to the Subscriber channel.

Right-click the Entitlement object to perform the following:

*

*

*

*

Edit, copy, and save the object.
Export an entitlement configuration to an XML file.
Under Live:

+ Deploy the entitlement

+ Compare the entitiement in Designer to a deployed entitlement in an Identity
Vault

Delete the object.

The Job object represents a job that you can schedule to run either immediately or at a
later date. Designer presently ships with three job types: Random Password Generator,
Schedule Driver, and Subscriber Channel Trigger. You can also have custom jobs.

Right-click the Job object to perform the following:

*

*

*

Edit the job object.
Export a job configuration to an XML file.
Under Live:
¢ Deploy the job
+ Compare the job in Designer to a deployed job in an Identity Vault
Delete the object.

See the Properties window associated with this object.
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ECMAScript The ECMAScript object represents an ECMAScript assigned to the Subscriber
Object Channel.

54 Right-click the ECMAScript object to perform the following:

+ Edit, copy, and save the object.
+ Export an ECMAScript configuration to an XML file.
+ Under Live:

¢ Deploy the ECMAScript

¢ Compare the ECMAScript in Designer to a deployed ECMAScript in an
Identity Vault

+ Delete the object.

+ See the Properties window associated with this object.

Mapping Table The Mapping Table object represents a Mapping Table assigned to the driver.
Object

= Right-click the Mapping Table object to perform the following:

+ Edit, copy, and save the object.
+ Export a Mapping Table configuration to an XML file.
+ Under Live:

+ Deploy the Mapping Table

¢ Compare the Mapping Table in Designer to a deployed Mapping Table in an
Identity Vault

* Delete the object.

+ See the Properties window associated with this object.
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Icon Name Description

User The User Application object allows you to manage workflow provisioning. Right-click
Application the User Application object to perform the following:
Object

— + Show the Dataflow view.
k2 + Manage application schemas.
+ Set up remote control through VNC connectivity.
+ Generate documentation for the User Application.
* Under Driver:
* Manage application schemas
+ Deploy the User Application object
¢ Set up driver security
* Delete the User Application object.
* Under Localize:
+ Export localization data
¢ Import localization files
* Under Distribute, you can select Horizontal or Vertical.
+ Migrate the User Application object.
+ Import the User Application object from a file.
+ Export the User Application object to a file.
+ Deploy the User Application object to an Identity Vault.

+ Compare the User Application object in Designer to a deployed User Application
object in an ldentity Vault.

* Import the User Application object from an Identity Vault.
+ Validate the User Application object.
+ Show the Provisioning view.

+ See the Properties window associated with this object.

Default Placeholder for all notification templates.

Notification ) ) o ) . .
Collection Right-click the Notification Collection object to perform the following:

+ Create a new notification template.

+ Edit Filter. (If you want to see e-mail templates in other languages, click this option
and select the languages.)

+ Import a naotification template from a file.

+ Update templates.

+ Under Live:
¢ Import an e-mail template from an Identity Vault
¢ Deploy e-mail templates

+ Compare the Notification Collection in Designer to a deployed Notification
Collection in an Identity Vault

+ See the Properties window associated with this object.
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Icon Name Description

Notification A natification template.
Object

+ Edit, copy, or save a template.

[I_"u

+ Under Live:

+ Deploy e-mail templates

Right-click the Notification object to perform the following:

+ Compare the Notification object in Designer to a deployed Notification object

in an Identity Vault
+ Delete a template.

+ See the Properties window associated with this object.

8.6 The Navigator View

The Navigator view enables you to manage and view the file resources that are in your workspace.
You can see your projects and files as they actually exist in the file system. You can add files and
folders, and append them to your projects or workspace. These extra items won’t change or affect
the behavior of your Identity solution. However, they enable you to conveniently append other
pieces of information that you want to associate with your projects and workspace.

Figure 8-17 The Navigator View
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The Navigator view enables you to do the following:

Table 8-7 Navigator View Icons

Icon Name

Description

Project Name

ERPS S [anston

Project’s Files
Folder and
Subfolders

RERC nston2_files

#- [ documentation
= resources

The name of the created project. This is the name of the project stored in the
selected workspace directory. Double-clicking the Project name expands and
collapses the entries under the project.

Right-clicking a project name allows you to do the following:

+ Under New:
+ Create a new project
+ Create a new Identity Manager Project
+ Create a new provisioning artifact
¢ Create other projects
+ See just this project’'s workspace (the Go Into option).
+ Open in a new window.
+ Copy, paste, delete, move, and rename the project.
+ Import and export the project.
+ Refresh the project.
+ Close the project or close unrelated projects.
+ Through the Source option, format the document.

+ View the project’s Properties window.

The files folder contains the files of the created project. Beneath the files
directory are the documentation and resources folders and any other folders you
have created in this project.

Right-clicking any of the project folder names allows you to do the following:

* Under New:
+ Create a new project
¢ Create a new Identity Manager Project
+ Create a new provisioning artifact
+ Create other projects
+ See only this project’s workspace (the Go Intfo option).
+ Open the directories in a new window.
+ Copy, paste, delete, move, and rename the folder.
+ Import and export the project.
+ Refresh the directory.
+ Through the Source option, format the document.

+ View the project’s Properties window.
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All File Types Because the project folders can contain many different files, you can see different
icons displayed, depending on the file extension. Right-clicking any of these files
allows you to:

+ Under New:

= project )
*
il Blanston1L.proj Create a new project
i ModelerOutline. xr ¢ Create a new Identity Manager Project

+ Create a new provisioning artifact

¢ Create other projects
+ Open the file in a Designer-chosen editor.
+ Open the file with the following choices:

+ Text editor

¢ System editor

* In-place editor

¢ Default editor

+ XML files can choose an XML editor

+ Proj files can choose the Modeler

¢ Filter files can choose the Filter editor

+ Policy files can choose the Policy Builder editor
+ Copy, paste, delete, move, and rename the files.
* Import and export the files.
+ Refresh the file or directory.
* Through the Source option, format the document.

+ View the file’s Properties window.

In the Navigator view, you can move any document into your project and edit it with a selected
editor. For example, you can add a Word* or PowerPoint* document, then double-click the
document. The native application loads inside Designer, as any other editor would, where you can
view and edit the document. (This feature only works on Windows.)

You can create linked resources at any depth within projects. This allows you to put resources from
different places in the file system anywhere you like in the project structure, including below other
linked resources. The same resource can be linked to the same project.

To create a linked resource:

1 Select Window > Show View > Navigator.

2 In the Navigator view, right-click a project, then select New > More Projects.
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3 Expand the General folder.

@® New ®
Select a wizard

Create a new folder resource

Wizards:
type filter text

== General
7 File
CEEm
= Untitled Text File
== Designer Document Generation
Docurnent Generation Style {.docgen)
== Navell Identity Manager
7 Identity Manager Project...
=== Provisioning
[# Directary abstraction Layer Entity
[7] Directory Abstraction Layer List
(@] Directary Abstraction Layer Query
#] Directory Abstraction Layer Relationship
i | Provisioning Request Definition
== XML
[3] xmL

4 Select Folder, then click Next.
5 Click Advanced, then select Link a folder in the filesystem.
6 Browse to and select a folder, click OK, then click Finish.

Designer creates a link to that folder directly under the project. You can then easily access the
folder.

You can use the same procedure to link to a file.

8.7 The Policy Set View

The Policy Set view lists policies and displays a toolbar.
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Figure 8-18 The Policy Set View
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The list displays all policies contained in the selected policy set. During a transformation, the
policies within the list are executed from top to bottom.

The toolbar contains buttons and a drop-down menu so that you can manage policies displayed in
the list. To manage policies, you edit, add, delete, remove, or change the processing order of the
policies.

The Policy Set view renders differently, depending on what mode the Outline view is in. If you are
in Tree mode, the Policy Set view shows policies in a hierarchical containment. However, if you are
in Policy Flow mode, the view shows a flat list of policies in the selected policy set.

To bring up a policy in the Policy Builder view, double-click the policy. For more on policies, see
Understanding Policies for Identity Manager 3.5.1 and Policies in Designer 2.1.

8.8 The Properties View

The Properties view displays information on key-value pairs (for example, Max Log Entries 2). The
information displayed depends on what is selected in the active view (for example, Modeler or
Outline).

Often, the Properties view lets you edit the information. For example, you can select a driver in the
Modeler and then edit the Trace Level value that is displayed in the Properties view. You can also
view and edit the Administrator settings in an Identity Vault.

Figure 8-19 The Properties View of an Active Directory Driver

Data Flow | Palicy Set| = O

= Properties X

Property

MName

Firewall false
Java Module

Log Lewel ]

Max Log Entries 0
Mative Module addriver.dll

Password ok ok
Trace File

Trace Lewal 0

Trace Narme

Trace Size Limit (0
Use DS Log Settin false

¢ Section 8.8.1, “The Spinner Control,” on page 140
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*

Section 8.8.2, “The DN Cell Editor,” on page 140
Section 8.8.3, “Editing Boolean Values,” on page 140

*

*

Section 8.8.4, “Keyboard Tips,” on page 141

*

Section 8.8.5, “Resizing Column Widths,” on page 141

*

Section 8.8.6, “Summary Table,” on page 141

8.8.1 The Spinner Control

Figure 8-20 The Spinner Control

Trace File

Trace Level E
Trace Narne

Trace Size Limit (0

Lt

When you edit numeric values in the Properties view, Designer displays a spinner control so that you
can increase or decrease the number.

The maximum value on the spinner is set appropriately, based on the attribute type. For example, the
maximum for log entries is 500.

8.8.2 The DN Cell Editor
Figure 8-21 DN Cell Editor

dormain.blanston|

|

| Deploy Context

To edit attributes that are of type DN syntax (for example, Driver Set Deploy Context):

1 Click Deploy Context.
2 Type the distinguished name of the context.

You can also click the Browse button, then browse to and select an object with the eDirectory
browser. In this case, you are selecting the Distinguished Name of the container to deploy the
driver set.

8.8.3 Editing Boolean Values
Figure 8-22 Drop-Down List for Boolean Values

Trace Size Limit (0
Lise DS Log Settin true -

To edit Boolean values, select true or false from the drop-down list.
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8.8.4 Keyboard Tips

Table 8-8 Keyboard Tips

Task Description

Save the value of the current cell editor and set the Press Tab, Enter, the Up-arrow, or the Down-arrow.
focus on the next editor

Navigate backwards Press Shift+Tab. Navigation loops when you reach
the top or bottom of a value.

Exit the Properties view Press Ctrl+Tab for forward navigation. Press
Ctrl+Shift+Tab for backward navigation.

8.8.5 Resizing Column Widths

If you resize the columns in the Properties view, those column widths persist in user preferences.
When you open the Properties view again or restart Designer, the resized widths are displayed.

8.8.6 Summary Table

Below is a summary table of what you can do in the Properties view.

Function Description

Opening If the view doesn’t already display, select Window > Show View >
Propetrties.

Edit You can edit the settings of any item selected in the Modeler or Outline
View.

Multi-edit If you have selected more than one item, you can edit any settings that both

items have in common. For example, if they both have a Name setting, you
can select both and edit once. The change is made to both items. This
function can boost productivity on certain edit operations.

Saving When you click Save, all changes are saved to the project file. When you
reopen the project, all settings are restored.

Boolean Editor You can edit Boolean settings (true/false) by clicking the value, which
toggles to the other value.

Workspaces, Perspectives, and Views 141



8.9 The Search Results View

To search across an entire project:

1 With the Modeler view active, press Ctrl+F.

Find: | Blanston, Inc |

Case Sensitive

Application 5 Select all

Design Elerment
Domain Group
Driver

Driver Set

ECMASCript —
Enfitlement
Filter

Identity Wault
Job

Filter:

il £ILgl 1[E]

IHEREEREEEEE

37 E‘t il

£

[ 0K ] [ Cancel

2 Select whether the search is case-sensitive.

3 Filter object types you want to search on. You can select or deselect all items through the Select
All or Deselect All buttons.

4 Click OK.

The results appear in the Search Results view, sorted by name, class, type, and notes. To sort on a
different column, click the column headers.

Figure 8-23 The Search Results View

: =i
Nama Clazs Type Notes ~
eDir2eDir Application eDirzeDir F
= LDAP o AD Application GenericDirectory
Userapplication Application NP o
&) Active Directary Application ActiveDirectory
5 pelimited Test Application DalimitedTextapp
] Groupwisel Application Grouphiise
@ Active Directory 2 Application ActiveDirectory
=) aD02 Application ActiveDirectory
SF application SIF -
ro i m Pt omie e e el [T O Padtoa
< 3

If the Search Results view isn’t already open, the search opens it.

As you select an item (for example, a policy) in the Search view, the corresponding item (for
example, the driver) is selected in the Modeler.
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If you double-click an item, its appropriate dialog box or editor launches. To open an item with
another editor, right-click the item and select Open With.

To clear the Search view, click the Clear icon in the Search view’s toolbar.

When you subsequently invoke the Search dialog box, Designer remembers your latest search
settings.

8.10 The Tasks View

Figure 8-24 The Tasks View
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The Tasks view enables you to make and prioritize notes while you manage identities. This view is

for your convenience. It can contain whatever you want. It won’t affect the functionality of your
solution.

This view enables you to do the following:

¢ Add tasks

¢ Delete tasks

¢ Filter on completion status

¢ Filter on priority

+ Filter on text in the description
¢ Mark if completed

+ Provide a description

¢ Set a priority

¢ Sort on all fields

To add a task:

1 Open the Tasks view by selecting Window > Show View > Tasks.
2 Right-click in the Tasks view, then click Add Task.
3 Type a name in the Description field, select a priority, then click OK.

To filter tasks:

1 Click the filter icon L5,
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2 Select filters, then click OK.

@ Filters " =
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8.11 The Trace and Error Log Views

The Trace and Error Log views help you troubleshoot Designer. For more information, see the
following:

¢ “Turning on Trace Messages” on page 492

+ “Viewing the Error Log” on page 491

¢ “Checking Loaded Plug-Ins” on page 494

8.12 The Dataflow View

Designer allows you to manage how the data flows between the Identity Vault and the connected
systems. You can see how the data flows between all of the connected systems, make changes as
needed, create reports about the data, and view the flow of passwords between the systems.

The Dataflow view and the Dataflow editor manage the data. The Dataflow view displays the flow
of data in the modeler per driver. The Dataflow editor displays a more granular view. For more
information, see Chapter 12, “Managing the Flow of Data,” on page 221.
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Configuring Objects in Designer

Designer allows you to easily view, configure, and modify settings for domain groups, Identity
Vaults, servers, driver sets, drivers, and connected systems.

¢ Section 9.1, “Viewing Object Properties,” on page 145

¢ Section 9.2, “Configuring a Domain Group,” on page 148

¢ Section 9.3, “Configuring Identity Vaults,” on page 148

¢ Section 9.4, “Configuring Servers,” on page 150

¢ Section 9.5, “Configuring Driver Sets,” on page 152

¢ Section 9.6, “Configuring Drivers,” on page 158

¢ Section 9.7, “Configuring Jobs,” on page 169

¢ Section 9.8, “Configuring Application Properties,” on page 170

¢ Section 9.9, “Configuring Policies,” on page 174

¢ Section 9.10, “Adding Prompts to a Driver Configuration File,” on page 175

¢ Section 9.11, “Editing a Notification Template Name,” on page 177

¢ Section 9.12, “Synchronizing Passwords,” on page 177

9.1 Viewing Object Properties

To quickly view or edit properties of items (for example, an Identity Vault or a driver), you can use
the Properties view or a Properties dialog box.

¢ Section 9.1.1, “Properties View,” on page 145
¢ Section 9.1.2, “Properties Dialog Box,” on page 146
¢ Section 9.1.3, “Operations Relating to Properties,” on page 147

9.1.1 Properties View

If the Properties view is open when you select an item in the Modeler, information about that item
displays in the Properties view. You can then quickly view or edit information.
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Figure 9-1 The Properties View
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To open the Properties view, click Window > Show View > Other > General > Properties. For
additional information, see Section 8.8, “The Properties View,” on page 139.

9.1.2 Properties Dialog Box

To view or edit properties of items:

1 Open the Properties dialog box by doing one of the following:
¢ Double-click an item in the Modeler or in the Outline view.

+ Right-click an item (for example, an Identity Vault) in the Modeler or Outline view, then
select Properties.

¢ Select an item, then press Enter.
+ Select an item, then select File > Properties.

+ Select an item, then select Model > [object] > Properties.
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The following figure illustrates a driver’s properties page:

.Pruperties for eDirecto

| type Filker bext

. General

. Global Configuration e
, Driver Log Level

, Driver Configuration

. Driver Manifest

. Mamed Passwords

. iManager Icon

. Trace

. Engine Contral Yalues

L ) LU L

Driver ) m]
1. General - -
e | eDirectary Driver
Mokes: ;I
[ -]
SErver I Diriver Yersion I LT |
[l LUNDT. skrane Unavailable
Basic configuration ; - -
file: | elirectory-IDMZ_0_0-41. xml @
Supported DR
Format: I S @
Restore Defaulks | Apply |
(0] 4 I Cancel |

2 Edit settings, then click OK to save.

9.1.3 Operations Relating to Properties

Table 9-1 Operations Relating to Properties

Operation

Description

Open the Properties view

Click Window > Show View > Other > General > Properties.

Open the Properties dialog box

Double-click an item, or right-click, then select Properties.

Edit settings

You can edit the settings of any item selected in the Modeler or
Outline view.

View a server’s properties

In the Outline view, right-click the server icon, then select Properties.

Save to memory or disk

When you click Apply or OK in a properties dialog box, changes are
committed to memory. However, changes are not saved to disk
unless you select File > Save.
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9.2 Configuring a Domain Group

To view or change a domain group’s settings, double-click the domain group.

Figure 9-2 The Domain Group Property Page

Domain Group

Icom:

Browse, .. |

Marne: | Darmain Group

Miokes:

1 To change the domain group’s icon, click Browse, then navigate to and select an image file.

By default, the Browse button opens the i cons/group folder in the
com.novell.designer.core plug-in. The default image selected is
administrative.png. To select a different image, double-click it.

Click Apply.

To change the name of the domain group, edit the Name field.
Add details in the Notes pane.

Click OK.

The image (for example, administrative.png) appears to the left of the domain name in
the Modeler.

a b ODN

9.3 Configuring Identity Vaults

To view or change an Identity Vault’s settings, double-click the vault.The Identity Vault properties
page has three options: Configuration, Administrator, and Server List.
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Figure 9-3 Identity Vault Properties
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Table 9-2 Configuration Settings for an Identity Vault

Field Description

Vault name The name of the Identity Vault object. The default is Identity Vault.

Host The eDirectory™ host where you plan to log in and deploy.

Username The eDirectory username that has sufficient rights to make changes to
objects associated with this deployment.

Password The password for the above user.

Save Password

Test Credentials

Deploy context

Saves the password permanently, so that you can be authenticated

into this Identity Vault without having to prompt for a password each

Designer session. If you use Save Password, the password is saved
locally in Designer’s file system and is not secure.

If you do not select this option, the password is remembered only until
you close Designer.

Attempts a connection to the eDirectory server to validate your login
credentials.

The default DN container assigned to all driver sets that are
associated with this Identity Vault. If you specify a DN container on the
Driver Set object, that setting takes precedence over the default
setting.

Administrator

The Administrator option is divided into three sections. Entering information in these sections is

optional.

+ Personal Information: Lets you enter information specific to the Identity Vault, such as
Name, Title, Department, and Location,
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¢ Contact Information: Lets you enter information such as Email, Phone, Cell phone, Pager,
and Fax.

+ Notes: Allows you to type any reminders you might need for future reference.

Server List

The Server List option displays the servers that are associated with the selected Identity Vault. You
can add, edit, or remove the server entries.

NOTE: If you select the option to allow a default server to be created, that server shows up as
Default Server.default container in the list. You cannot deploy a driver set into an existing
eDirectory tree if you have Default Server.default container in the Server List. You must first
remove this reference and add a Metadirectory server in an eDirectory tree.

9.4 Configuring Servers

1 Right-click the server icon in the Outline view.

@ Designer - Kvedjur - Developer - Designer

File Edit ‘iew Project Tools Live Model WWwindow

[ C3- B O] G |B B |«

BLTTTTE ek
[H-&g) Avaya Driver
Eﬁ; Driver

Password{Subi-Pub Email Matifi
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2 Select Properties.
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The following tables lists settings for the Properties page:

Field Description

Name The name of the Server object. The Identity Vault
lists the server. You can browse to and select the
server.

Context The server’s context. The Identity Vault assigns
the context. You can browse to and select the
context.

IP address The server’s IP address.

DNS name The domain name, or complete directory context

name.

Identity Manager version

The version of Identity Manager that is running
on the server. The default is Identity Manager
3.5. You can change the version by using the
drop-down list. See Section 10.2, “Changing the
Identity Manager Version,” on page 180.

eDirectory version

The version of eDirectory that the server is
using.

Assigned driver set

The driver set that the server is assigned to.

Notes

Information that you want to specify, to help you
maintain the server.
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The following figure illustrates the Contact Information page for the server:

@ Froperties for LUNDI ] 4|
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.:':J:. (414 I Cancel |

Use this page to provide information on the person to contact and other items of interest
concerning the server.

9.5 Configuring Driver Sets

A driver set is a container that holds Identity Manager drivers. Only one driver set can be active on a
server at a time. As a result, all active drivers must be grouped into the same driver set. To view or
change settings, double-click a driver set in the Modeler.

¢ Section 9.5.1, “Driver Set General Options,” on page 153

*

Section 9.5.2, “Driver Set Global Configuration Values,” on page 154

*

Section 9.5.3, “Driver Set Log Levels,” on page 154

*

Section 9.5.4, “Driver Set Server List,” on page 155

*

Section 9.5.5, “Driver Set Trace,” on page 156
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9.5.1 Driver Set General Options

When you create an Identity Vault, a driver set is added to the vault by default.

Figure 9-4 A Driver Set in an Identity Vault

El Idertity Yaul: 2

You can add other driver sets by dragging the Driver Set object from the palette to the Modeler.

From the General page, you can specify or change driver set values.

Figure 9-5 Driver Set Properties
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Table 9-3 Driver Set Settings

Field Description

Name The name of the Driver Set object (for example,
DriverSet1.)

Create a new patrtition on this driver set We recommend that you select this option. For
details, see Planning the Technical Details of your
Identity Manager Implementation (http://
www.novell.com/documentation/idm/install/data/
alorukq.html#alorukq)
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Field Description

Deploy context The Identity Vault assigns the default DN container
value to all driver sets. If you specify a DN
container here on the Driver Set object, that setting
takes precedence over the Identity Vault setting.

You can manually enter this value or browse for it.

9.5.2 Driver Set Global Configuration Values

Global configuration values (GCVs) are settings that are similar to driver parameters. Global
configuration values can be specified for a driver set as well as an individual driver. If a driver does
not have a GCV, the driver inherits the value for that GCV from the driver set.

GCVs allow you to specify settings for Identity Manager features such as password synchronization
and driver heartbeat, as well as settings that are specific to the function of an individual driver
configuration. Some GCVs are provided with the drivers, but you can also add your own. You can
refer to these values in a policy to help you customize your driver configuration.

To view or change the driver set's GCV settings, double-click the driver set. From the Global
Configuration Values page, you can add, edit, or remove values, or edit the XML file for the driver
set.

9.5.3 Driver Set Log Levels

The Driver Set Log Level options enable you to view high-level information. For lower-level
information, use “Driver Set Trace” on page 156.

Figure 9-6 Driver Set Options for Logging
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By default, logging is turned off. To track errors, messages, or events, change the default.

1 Double-click the driver set.
2 Select Driver Set Log Level.
3 Select a logging option.

The log option that you select determines which messages are available in the log.
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To configure audit instrumentation, select Log specific events, click the event selector button,
select events, then click OK.

The Update only the last log time option updates the time stamp to indicate the last activity of
the driver.

4 Specify the number of entries in the log.
The default is 50 entries (lines) in the log. If you want a longer history, increase the number.
5 Save changes by clicking OK.
The driver set log contains messages from the engine when it tries to start or stop drivers. To view

the log, use iManager. Select the Status Log icon above the Identity Vault in the Identity Manager
Overview.

9.5.4 Driver Set Server List

After adding one or more servers to the Identity Vault, you can view or change the driver set’s server
association.

Figure 9-7 Server List

i@ Properties for Driver Set o ] |
| b Filker et 4. Server List LA
1, General -
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5, Driver Set Log Level LUMDL. akranes

. Server Lisk
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=

@ ‘fou can add additional servers that will show upin these lisks by going inko the
Server Lisk property page of the associated Identity Wault,

Select a server in the Available Servers list, then use the arrows to move the server to the Selected
Server list. If a server is not in the Available Server list, you must first add it by editing the Identity
Vault properties. See Section 9.3, “Configuring Identity Vaults,” on page 148.
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9.5.5 Driver Set Trace

Although a driver set has nothing to trace, you can add a trace level to your driver. The Trace setting
specifies the trace level for all drivers in the driver set that use the driver set trace settings.

With the trace level set, DSTRACE displays the Identity Manager (DirXML®) events as the engine
processes the events. The trace level affects each driver in the driver set. Use the trace level for
troubleshooting issues with the drivers when they are deployed. DSTRACE displays the output of
the specified trace level.

Table 9-4 Driver Set Trace Settings

Setting Description

Driver trace level As the driver trace level increases, the amount of information
displayed in DSTRACE increases.

Trace level 1 shows errors, but not the cause of the errors. If you
want to see password synchronization information, set the trace
level to 5.

XSL trace level DSTRACE displays XSL events. Set this trace level only when
troubleshooting XSL style sheets. If you do not want to see XSL
information, set the level to 0.

Java debug port Allows developers to attach a Java debugger.

Java trace file When a value is set in this field, all Java information for the driver is
written to file. The value for this field is the path for that file.

As long as the file is specified, Java information is written to this
file. If you do not need to debug Java, leave this field blank.

Trace file size limit Sets a limit for the Java trace file. If you set the file size to
Unlimited, the file grows in size until no space is available on the
disk.

NOTE: The trace file is created in multiple files. Identity Manager
automatically divides the maximum file size by ten and creates ten
separate files. The combined size of these files equals the
maximum trace file size.

The following methods help you capture and save Identity Manager trace information.

NetWare

Use dstrace.nlm to display trace messages on the system console or trace messages to a file
(sys:\system\dstrace.loq). Dstrace.nlm displays the trace messages to a screen
labeled DSTrace Console.

Use the following commands at the server console:
DSTRACE SCREEN ON: Allows trace messages to appear on the DSTRACE Console.

DSTRACE FILE ON: Captures trace messages sent to the DSTRACE Console to the
dstrace.log file.
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DSTRACE FILE OFF: Stops capture trace messages to the log file.
DSTRACE -ALL: Turns off all Trace flags.
DSTRACE +DXML DSTRACE +DVRS: Displays the Identity Manager (DirXML) events.

DSTRACE +TAGS DSTRACE +TIME: Displays the message tags and times tamps.

Windows

Open the Control Panel, select NDS Services, then click DSTRACE.DLM > Start. A window named
NDS Server Trace Utility opens.

To set the filters to capture the DirXML trace information:

1 Click Edit > Options > Clear All.
2 Click the boxes next to DirXML and DirXML Drivers, then click OK.

To save the information to a file:
1 Click File > New.

A dialog box prompts for a filename.

2 Enter a filename with the extension of .10g.

3 To stop capturing information, click File > Close.
The file is saved.

UNIX

Use the ndstrace command at the console to display the Identity Manager events. The exit
command quits the trace utility.

Table 9-5 ndstrace Commands

Command Description

Set ndstrace=nodebug Turns off all trace flags.

Set ndstrace on Displays trace messages to the console.

Set ndstrace file on Captures trace message to the ndstrace. log file in the /var/

nds directory.

Set ndstrace file off Stops capturing trace messages to the file.
Set ndstrace=+dxml Displays the Identity Manager events

Set ndstrace=+dvrs Displays the Identity Manager driver events.
iMonitor

Use iMonitor to get DSTRACE information from a Web browser.
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Table 9-6 Platforms and Commands for Web Browsers

Platform Command
NetWare® ndsimon.nlm
Windows ndsimon.dlm
Linux/Solaris/AIX/HP-UX ndsimonitor
1 Access iMonitor from http://server_ip:8008/nds (the default port).

2 Click Trace Configuration.

3 Click Clear All.

4 Click DirXML and DirXML Drivers.

5 Click Trace On, then click Trace History.

6 Click the Current document icon to view the live trace.

9.6 Configuring Drivers

A driver provides the connection between an application and the Identity Vault. The driver is the
connector that enables data synchronization and sharing between systems. To view or change
settings, double-click a driver or driver line in the Modeler.

*

*

Section 9.6.1, “Driver General Settings,” on page 159

Section 9.6.2, “Driver Global Configuration Values,” on page 160
Section 9.6.3, “Driver Log Level,” on page 160

Section 9.6.4, “Driver Configuration,” on page 161

Section 9.6.5, “Driver Manifest,” on page 163

Section 9.6.6, “Driver Named Passwords,” on page 163

Section 9.6.7, “Editing or Creating a Driver iManager Icon,” on page 164
Section 9.6.8, “Driver Trace Levels,” on page 165

Section 9.6.9, “Engine Control Values,” on page 167
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9.6.1 Driver General Settings

Figure 9-8 The Driver’s General Property Page
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Table 9-7 The Driver’s General Settings
Setting Description
Name Displays the driver name, which you can change.
Notes Enables you to type notes about your driver implementation.
Basic configuration file Displays the configuration filename that this driver uses. Contains

the filename of the configuration file that was used during import.

To view the path to this file, click the information icon next to the
filename. You might want to view the file to find out version
information.

If you haven’t yet run the import wizard, this field is set to None.

Supported DN format Displays the format (for example, LDAP) that is supported for each
driver. This DN information is important for policy building and
simulation.

For additional details, click the information icon next to the format
field.

The driver property page is dynamic. Labels and descriptions are dynamically read from the driver
configuration file for the Authentication ID an. connection information
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9.6.2 Driver Global Configuration Values

Global configuration values (GCVs) are settings that are similar to driver parameters. Global
configuration values can be specified for an individual driver as well as a driver set. If a driver does
not have a GCV, the driver inherits the value for that GCV from the driver set.

GCVs allow you to specify settings for Identity Manager features such as password synchronization
and driver heartbeat, as well as settings that are specific to the function of an individual driver
configuration. Some GCVs are provided with the drivers, but you can also add your own. You can
refer to these values in a policy to help you customize your driver configuration.

To edit the driver set's GCV settings, double-click the Driver object. From the Global Configuration
Values page, you can add, edit, remove, or edit the XML for GCVs.

To view or change the driver’s GCV settings, double-click the driver. From the Global

Configuration Values page, you can add, edit, or remove values, or edit the XML file for the driver.

9.6.3 Driver Log Level

The Driver Log Level options enable you to view high-level information. For lower-level
information, use the Trace option. See Section 9.6.8, “Driver Trace Levels,” on page 165.

Figure 9-9 Settings for the Driver Log Level
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By default, logging inherits the setting from the driver set. To change the default:

1 Double-click the driver.
2 Select Driver Log Level.
3 Select a logging option.
The option that you select determines which information is available in the log.

To configure the audit instrumentation, select Log specific events, click the event selector
button, select events, then click OK.

4 Specify the number of entries in the log.
The default is 50 entries (lines) in the log. If you want a longer history, increase the number.

5 Save changes by clicking OK.
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The driver log contains messages from the driver. The messages are related to operations that the
driver performed or tried to perform. To view the log, use iManager. Select the log icon on the

Driver object in the Identity Manager Overview.

9.6.4 Driver Configuration

+ “Driver Module” on page 161
¢ “Authentication” on page 161
¢ “Startup Option” on page 163

¢ “Driver Parameters” on page 163

Driver Module

Table 9-8 Driver Module Settings

Setting

Description

Java: Name of the Java class

Native: Name of the DLL

Connect to Remote Loader

Driver object password: Set Password

Remote Loader client configuration for
documentation: Include in documentation

Specify the name of the Java class that will be
instantiated for the shim component of the driver.
This class can be located in the classes directory
as a class file, or in the 1ib directory as a .jar file.

Specify the name of the .d11 file that will be
instantiated for the application shim component of
the driver.

Select this option if you want to connect the driver
to the Metadirectory engine that uses the Remote
Loader.

Set a password for the Driver object. If you are
using the Remote Loader, you must enter a
password on this page or the remote driver cannot
run. The Remote Loader uses this password to
authenticate itself to the remote driver.

Enables you to document your Remote Loader
configuration for the driver. From the drop-down
list, select a name that you specified on the driver’s
documentation property page.

To use this option, see Section 9.6.9, “Engine
Control Values,” on page 167.

Authentication

Table 9-9 Authentication Settings

Setting

Description

Authentication information for server

The server that the driver is associated with.
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Setting Description

Authentication ID Enter the application user ID. This ID is used to pass Identity
Vault subscription information to the application. If you have
enabled SSL/TLS for eDirectory drivers, this option is
dimmed.

Remote tree address and port Enter the address or name and port of the server that the
application shim should communicate with.

Set Password Enables you to set or change an application password (for
example, Active Directory).

Remove Password Deletes the password to the application.

Host name Specifies the address or name of the machine where the
Remote Loader runs. For example, enter
hostname=192.168.0.1.

If you don't enter this communication parameter, this value
defaults to localhost.

Port Specifies the port that the Remote Loader uses to accept
connections from the remote interface shim. For example,
enter port=8090.

If you don't enter this communication parameter, this value
defaults to 8090.

KMO Specifies the Key Name of the Key Material Object containing
the keys and certificate used for SSL. For example, enter
kmo=remote driver cert.

If you don't enter this communication parameter, no value is
stored for this parameter. SSL won'’t be available.

Other parameters Provides reference information. It is included when you
document your entire project.

Driver Cache Limit

Figure 9-10 Options for the Driver Cache
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The driver cache is a file that holds Identity Vault events until a driver can process them.
This file can become very large in the following situations:

+ Events occur at a steady rate that is faster than Identity Manager can process them over a long
period of time.

¢ The driver is shut down for long period of time but is not disabled.

By default, the driver cache (file) size is limited only by available disk space. This is the
recommended setting.
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The only reason to set some other limit is to protect against accidentally filling up the disk. The
number that you use depends on the difference between projected amount of available disk space
without anything in the cache and the amount of free disk space that you want to ensure will always
be left available, divided by the number of drivers on the server.

The primary reason that the cache file becomes very large is if the driver is left not running over a
long period of time. In this case, the recommendation is to disable the driver rather than set a cache
limit. After the limit is reached, all the cached events are discarded.

Startup Option

Table 9-10 Startup Settings

Setting Description

Auto start The driver starts automatically when the Metadirectory engine loads.
Manual You must start the driver manually from the driver state location.

Disabled Disables the driver.

Do not automatically If you don't select this option, a driver that has been deployed but disabled
synchronize the driver resynchronizes on startup. If you select this option, a driver that has been

deployed but disabled does not resynchronize.

Driver Parameters

From this tab, you can enter common driver options, Subscriber and Publisher channel options, as
well as edit XML. Because the options here differ between drivers, refer to the Identity Manager
Drivers (http://www.novell.com/documentation/idm35/index.html) for configuration information.

9.6.5 Driver Manifest

The driver manifest is like a resume for the driver. The driver manifest states what the driver
supports, and includes a few configuration settings. The driver developer should provide the driver
manifest. Usually a network administrator does not need to edit the driver manifest.

For more information, see the developer documentation for Identity Manager drivers.

9.6.6 Driver Named Passwords

You can store multiple passwords securely for each of your drivers. This functionality is referred to
as Named Passwords because each different password is accessed by a key, or name.

Named Passwords are useful because you can refer to the password by name in a driver policy.
When the driver needs to use the password, it requests the password from the Metadirectory engine.
This method lets you avoid revealing the actual password in the code for a driver policy.

The following example shows how a Named Password can be referenced in a driver policy on the
Subscriber channel in XSLT:

<xsl:value-of
select="query:getNamedPassword ($srcQueryProcessor, 'mynamedpassword
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4 ) ”
xmlns:query="http://www.novell.com/java/
com.novell.nds.dirxml.driver.XdsQueryProcessor/>

You can store and retrieve Named Passwords for any driver without making changes to the driver
shim.

As a security measure, in addition to using Named Passwords, you should control access to all
Identity Manager objects in eDirectory.

NOTE: A driver developer can also customize a driver to use Named Passwords in other ways, such
as retrieving Named Passwords when the driver starts up, instead of requesting them from the
Metadirectory engine each time they are needed.

For example, the Identity Manager Driver for Lotus Notes* driver has been customized to support
additional ways of using Named Passwords, and examples of those methods are included in the
sample driver configurations. For more information, see the Identity Manager driver guides (http://
www.novell.com/documentation/idm35/index.html).

9.6.7 Editing or Creating a Driver iManager Icon

You can see and edit the iManager icons that each driver uses. This is important because iManager
renders driver icons in a particular way. However, those icons don't appear anywhere in Designer.
Conversely, Designer's application icons don't appear anywhere in iManager's user interface.

To help bridge that gap, you can view the iManager icon to be used in Designer:

Figure 9-11 The Option to View the iManager Icon
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1 Right-click a driver (for example, eDirectory) in the Modeler, then select Properties.
2 Select iManager Icon.

Designer displays an icon. It is associated with the driver in Designer, unless a different one
was imported and stored on the driver.

3 To change the icon, click Browse or New, browse to and select an image file, then click OK
twice.
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The next time that the driver deploys, Designer sets the icon in eDirectory, and iManager uses

it.

Also see Chapter 22, “Editing Icons for Drivers and Applications,” on page 437.

9.6.8 Driver Trace Levels

Through the Modeler, you can add a trace level to your driver or driver set. With the trace level set,
DSTRACE displays the Identity Manager events as the engine processes the events. The trace level
only affects the driver or driver set it is set on.

Use the trace level for testing or for troubleshooting issues with the drivers when they are deployed.
If you run DSTRACE while the drivers are in production, the Identity Manager server might process

events slowly.

DSTRACE displays the output of the specified trace level.

The following tables describes each trace field:

Table 9-11 Driver Trace Settings

Field

Description

Trace level

As the driver trace level increases, the amount of information
displayed in DSTRACE increases.

Trace level 1 shows errors, but not the cause of the errors. To see
password synchronization information, set the trace level to 5.

Trace level: Use setting from the
driver set

If you select this option, all trace levels set at the driver set level
take precedence over any driver settings. Otherwise, settings at
the driver level are effective.

Trace file

Specify a filename and location where the Identity Manager
information is written for the selected driver. When a value is set in
this field, all Java information for the driver is written to file.

As long as the file is specified, Java information is written to this
file. If you do not need to debug Java, leave this field blank.

Trace file: Use setting from the
driver set

If you select this option, all trace levels set at the driver set level
take precedence over any driver settings. Otherwise, settings at
the driver level are effective.

Trace file size limit

Allows you to set a limit for the Java trace file. If you set the file size
to Unlimited, the file grows in size until no disk space is available.

NOTE: The trace file is created in multiple files. Identity Manager
automatically divides the maximum file size by ten and creates ten
separate files. The combined size of these files equals the
maximum trace file size.

Trace name

Helps you track trace messages. The name that you specify here
appears with the driver trace messages. Use a trace name if the
driver name is very long.
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NetWare

Use dstrace.nlm to display trace messages on the system console or trace messages to a file
(sys:\system\dstrace.loq). Dstrace.nlm displays the trace messages to a screen
labeled DSTrace Console.

Use the following commands at the server console:
DSTRACE SCREEN ON: Allows trace messages to appear on the DSTRACE Console.

DSTRACE FILE ON: Captures trace messages sent to the DSTRACE Console to the
dstrace. log file.

DSTRACE FILE OFF: Stops capture trace messages to the log file.
DSTRACE -ALL: Turns off all Trace flags.
DSTRACE +DXML DSTRACE +DVRS: Displays the Identity Manager (DirXML) events.

DSTRACE +TAGS DSTRACE +TIME: Displays the message tags and times tamps.

Windows

Open the Control Panel, select NDS Services, then click DSTRACE.DLM > Start. A window named
NDS Server Trace Utility opens.

To set the filters to capture the DirXML trace information:

1 Click Edit > Options > Clear All.
2 Click the boxes next to DirXML and DirXML Drivers, then click OK.

To save the information to a file:
1 Click File > New.

A dialog box prompts for a filename.

2 Enter a filename with the extension of .10g.

3 To stop capturing information, click File > Close.
The file is saved.

UNIX

Use the ndstrace command at the console to display the Identity Manager events. The exit
command quits the trace utility.

Table 9-12 ndstrace Commands

Command Description

Set ndstrace=nodebug Turns off all trace flags.

Set ndstrace on Displays trace messages to the console.

Set ndstrace file on Captures trace message to the ndstrace. log file in the /var/

nds directory.
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Command Description

Set ndstrace file off Stops capturing trace messages to the file.
Set ndstrace=+dxml Displays the Identity Manager events

Set ndstrace=+dvrs Displays the Identity Manager driver events.
iMonitor

Use iMonitor to get DSTRACE information from a Web browser.

Table 9-13 Platforms and Commands for Web Browsers

Platform Command

NetWare® ndsimon.nlm
Windows ndsimon.dlm
Linux/Solaris/AIX/HP-UX ndsimonitor

1 Access iMonitor from http://server_ip:8008/nds (the default port).
2 Click Trace Configuration.

3 Click Clear All.

4 Click DirXML and DirXML Drivers.

5 Click Trace On, then click Trace History.

6 Click the Current document icon to view the live trace.

9.6.9 Engine Control Values

The engine control values enable you to change certain default behaviors of the Metadirectory
engine can be changed. You can access the values only if a server is associated with the Driver Set

object.
In Designer:

1 In the Modeler, right-click the driver line.

2 Select Properties > Engine Control Values.

3 Click the tooltip icon to the right of the Engine Controls for Server field. If a server is
associated with the Identity Vault, and if you are authenticated, the engine control values

display in the large pane.

Table 9-14 Engine Control Values

Option Description
Subscriber channel retry The Subscriber channel retry interval controls how frequently the
interval in seconds Metadirectory engine retries the processing of a cached transaction after

the application shim's Subscriber object returns a retry status.
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Option

Description

Qualified form for DN-syntax
attribute values

Qualified form from rename
events

Maximum eDirectory
replication wait time in
seconds

Use non-compliant
backwards-compatible mode
for XSLT

Maximum application
objects to migrate at once

Set creatorsName on
objects created in Identity
Vault

The qualified specification for DN-syntax attribute values controls whether
values for DN-syntax attribute values are presented in unqualified slash
form or qualified slash form. A True setting means the values are
presented in qualified form.

The qualified form for rename events controls whether the new-name
portion of rename events coming from the Identity Vault is presented to the
Subscriber channel with type qualifiers. For example, CN=. A True setting
means the names are presented in qualified form.

The maximum eDirectory™ replication wait time controls the maximum
time that the Metadirectory engine waits for a particular change to
replicate between the local replica and a remote replica. This only affects
operations where the Metadirectory engine is required to contact a remote
eDirectory server in the same tree to perform an operation and might need
to wait until some change has replicated to or from the remote server
before the operation can be completed (for example, object moves when
the Identity Manager server does not hold the master replica of the moved
object; file system rights operations for Users created from a template.)

This control sets the XSLT processor used by the Metadirectory engine to
a backward-compatible mode. The backward-compatible mode causes
the XSLT processor to use one or more behaviors that are not XPath 1.0
and XSLT 1.0 standards-compliant. This is done in the interest of
backward-compatibility with existing DirXML® style sheets that depend on
the non-standard behaviors.

For example, the behavior of the XPath “I=" operator when one operand is
a node set and the other operand is other than a node set is incorrect in
DirXML releases up to and including Identity Manager 2.0. This behavior
has been corrected; however, the corrected behavior is disabled by default
through this control in favor of backward-compatibility with existing DirXML
style sheets.

This control is used to limit the number of application objects that the
Metadirectory engine requests from an application during a single query
that is performed as part of a Migrate Objects from Application operation.

If java.lang.OutOfMemoryError errors are encountered during a Migrate
from Application operation, this number should be set lower than the
default. The default is 50.

NOTE: This control does not limit the number of application objects that
can be migrated; it merely limits the batch size.

This control is used by the Identity Manager engine to determine if the
creatorsName attribute should be set to the DN of this driver on all objects
created in the Identity Vault by this driver.

Setting the creatorsName attribute allows for easily identifying objects
created by this driver, but also carries a performance penalty. If not set, the
creatorsName attribute defaults to the DN of the NCP™ Server object that
is hosting the driver.
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Option Description

Write pending associations  This control determines whether the Identity Manager engine writes a
pending association on an object during Subscriber channel processing.

Writing a pending association confers little or no benefit but does incur a
performance penalty. Nevertheless, the option exists to turn it on for
backward compatibility.

Use password event values This control determines the source of the value reported for the
nspmbDistributionPassword attribute for Subscriber channel Add and
Modify events.

Setting the control to False means that the current value of the
nspmDistributionPassword is obtained and reported as the value of the
attribute event. This means that only the current password value is
available. This is the default behavior.

Setting the control to True means that the value recorded with the
eDirectory event is decrypted and is reported as the value of the attribute
event. This means that both the old password value (if it exists) and the
replacement password value at the time of the event are available. This is
useful for synchronizing passwords to certain applications that require the
old password to enable setting a new password.

Enable password This control determines whether the Identity Manager engine reports the
synchronization status status of Subscriber channel password change events.
reporting

Reporting the status of Subscriber channel password change events
allows applications such as the Identity Manager User Application to
monitor the synchronization progress of a password change that should
be synchronized to the connected application.

9.7 Configuring Jobs

Designer has a job scheduling utility to schedule events. Through this utility, the system can be set to
disable an account on a specific day, or to initiate a workflow to request an extension for a person’s
access to a corporate resource. Designer’s job scheduler contains the same functionality as the job
scheduler found in iManager. For information on creating jobs, see Section 18.1, “Creating a Job,”
on page 361.

In the Outline view, right-click the Job icon, then select Properties.

¢ Section 9.7.1, “General,” on page 169
¢ Section 9.7.2, “Trace,” on page 170

9.7.1 General

You have one selection under the General heading: Policy Name. You can change the job’s name by
modifying the name that appears in the Policy Name entry. Then click OK.
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9.7.2 Trace

Through the Modeler, you can add a trace level to your jobs. With the trace level set, DSTRACE
displays the Identity Manager events as the engine processes the events. The trace level only affects
the driver it is set on.

Use the trace level for testing or for troubleshooting issues with the designated job. If you run
DSTRACE while the drivers are in production, the Identity Manager server might process events
slowly.

DSTRACE displays the output of the specified trace level.

The following table describes each trace field:

Table 9-15 Job Trace Settings

Field Description

Trace level As the job trace level increases, the amount of information
displayed in DSTRACE increases.

Trace level 1 shows errors, but not the cause of the errors. To see
password synchronization information, set the trace level to 5.

Trace file Specify a filename and location where the Identity Manager
information is written for the selected driver. When a value is set in
this field, all Java information for the job is written to file.

As long as the file is specified, Java information is written to this
file. If you do not need to debug Java, leave this field blank.

Trace file size limit Allows you to set a limit for the Java trace file. If you set the file size
to Unlimited, the file grows in size until no disk space is available.

NOTE: The trace file is created in multiple files. Identity Manager
automatically divides the maximum file size by ten and creates ten
separate files. The combined size of these files equals the
maximum trace file size.

Trace name Helps you track job trace messages. The name that you specify
here appears with the job trace messages.

For more information on DSTRACE, see Section 9.6.8, “Driver Trace Levels,” on page 165.

9.8 Configuring Application Properties

To view or change an application’s settings, double-click the application (for example, LDAP
Directory) in the Modeler.
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Figure 9-12 The General Properties Page for an Application
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Section 9.8.1, “General,” on page 171
Section 9.8.2, “Environment,” on page 172
Section 9.8.3, “Administrator,” on page 172
Section 9.8.4, “Connectivity,” on page 172
Section 9.8.5, “AD Domain,” on page 174

Table 9-16 An Application’s General Settings

Field Description

Type Changes the type of application your driver connects to. For
example, if you configure a JDBC driver to connect to a MySQL
database, but then need to change to an Oracle database, you can
scroll to Database, select Oracle, then click Apply.

New .Enables you to edit a driver’s icon. See Section 9.6.7, “Editing or
Creating a Driver iManager Icon,” on page 164.

Edit Enables you to use the Icon Editor to customize the application’s
icon. Is available after you click New, edit an icon, and click
Update.

Browse .Enables you to navigate to and select an image file.

Name .Enabled you to customize the application’s name or label.
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Field Description

Version .Enables you to document the application’s version.

9.8.2 Environment

You can enter notes about the application’s environment.

9.8.3 Administrator

The Administrator option is divided into three sections. Entering information in these sections is
optional.

¢ Personal Information: Enables you to enter information specific to the Identity Vault, such as
Name, Title, Department, and Location,

¢ Contact Information: Enables you to enter information such as Email, Phone, Cell phone,
Pager, and Fax.

+ Notes: Allows you to type any reminders you might need for future reference.

9.8.4 Connectivity

+ “LDAP” on page 172
¢ “VNC” on page 172
¢ “Configuring a Remote Connection” on page 173

¢ “Customizing the Viewer” on page 174

LDAP

You can configure some applications (for example, Active Directory, eDirectory, and LDAP) for an
LDAP connection. If the application doesn’t support an LDAP connection, the LDAP tab doesn’t
display.

Host: The server’s IP address or DN (in LDAP format).
User: The user’s name.

Password: The user’s password.

VNC

From within Designer, you can view the desktop of the machine that is running your applications,
and remotely control that desktop by interacting with it. This feature enables you to administer users
or your applications with the native tools of that system, from one location.

This functionality is hosted in an embedded editor inside Designer. You can have multiple remote
control sessions with different systems, all open at the same time.
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Figure 9-13 A Remote Desktop
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Configuring a Remote Connection

To remotely control a desktop, the machine that is running your application needs to have a VNC
(virtual network computing) server installed and running. You can usually download a VNC server
for free from the Internet.

You can easily configure any system or design element in Designer for this feature by editing any
application or design element:

1 Right-click an application or design element.

2 Select Properties > Connectivity.

@ Properties for MySL o ] 5
Itype Filter bext 4. Connectivity SR

1, General
-2, Environment WHC |
-3, Administrakor
4, Conneckivity

@ You can remote control the deskbop of this resource iF a YR server
i= running an ik, The Port is usually 5301 For Linox servers and 5900
Far Windows.

Hosk: | |

Port: I
Password: I

3 On the VNC tab, type the authentication information.
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Host: The DN (for example, server33.houston.company.com) of the server where the VNC is
running.

Port: Typically 5901 for Linux servers or 5900 for Windows.
Password: The password to the VNC server.
4 Click OK.

Customizing the Viewer
A toolbar at the top of the desktop viewer enables you configure the following:
+ Encoding type (RAW, RRE, CoRRE, Hextile, Zlib, Tight).
The default is Tight.

¢ Compression level.
¢ JPEG Image Quality (0 - 9).
The default is 6.
¢ Cursor shape updates.
The default is Enable.
¢ Use CopyRect.
The fault is Yes.
¢ Mouse buttons 2 and 3.
The default is Normal.
+ View only.
The default is No, so that you can interact with the desktop.
¢ Clipboard.
¢ Record session and save to file.
+ Send Ctrl+Alt+Delete.
¢ Refresh.

For more information, see Tight VNC documentation.

9.8.5 AD Domain

You can capture information about an Active Directory application. This information is useful if you
want Document Generator to include this information when you document the project.

If you provided information in the LDAP settings, Designer populates the AD Domain fields.

9.9 Configuring Policies

¢ Section 9.9.1, “Editing a Policy Name,” on page 175
¢ Section 9.9.2, “Viewing References,” on page 175

¢ Section 9.9.3, “Editing a Credential Provisioning Policy,” on page 175
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9.9.1 Editing a Policy Name

To edit a policy name:

1 In the Outline view, right-click a policy or rule.

2 Select Properties.

The General setting displays by default.
3 Edit the name in the Policy Name field, then click OK.

9.9.2 Viewing References

The References page lists policy sets and policies that reference the policy listed in the General

page. To view the references to this policy:

1 In the Outline view, right-click a policy or rule.

2 Select Properties > References.

Linkage is how the policies reference each other. In Identity Manager versions earlier than 3.5,
linkage determined the order that policies were executed. To change the linkage, use the Policy

Builder.

9.9.3 Editing a Credential Provisioning Policy

1 In the Outline view, right-click a credential provisioning policy (for example, a repository).

- {@] 1dentity vaul

? 12 Yaulk

E‘ Kvedjur Yault

ﬂ MDI

EE Drriver Set
ﬁ,; Avaya Driver
Eﬁp Drivver

)

Eapto edjurRepository
M= MappingRule

2 Select Properties.
3 Edit the policy name, then click OK.

o [N, =F
B | R 3
El-e| kvedjur 1=

-l Password(Sub)-Pub Email Motifications |

9.10 Adding Prompts to a Driver Configuration

File

Several node types are defined for driver configuration files. These extensions were made to support

the following:

+ Prompting once for a value that is used repeatedly throughout a single driver configuration file.
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+ Prompting once for a value that is used across multiple driver configuration files, as part of the
Import Drivers wizard.

+ Allowing the user to select a value from a drop-down list of values.
+ Global modification of the driver configuration file as per a contained XSL stylesheet.

¢ Built-in variables that can be referenced without declaring them to access information about the
driver and its environment (a tree name, driver set name, driver set DN, server name, server
DN, driver name and driver DN).

¢ The ability to “layer” prompts. It is possible to ask the user multiple sets of questions, with the
2nd and later sets being controlled by the user's responses to prior sets. For more information,
refer to the FlexiblePrompts document.

The primary new node types are variable-decl, variable-ref, and xsl-modify.

Table 9-17 New Node Types

New Node Type Description

variable-decl Allows you to define driver configuration variables that are prompted for (optionally)
and replaced into a driver configuration file during its import. Multiple variable-decl
blocks can be used to define a “layered” set of prompts. Refer to the FlexiblePrompts
document for more information.

variable-ref Used to reference a variable defined in a variable-decl within your driver configuration
files.
xsl-modify Used to globally modify the driver configuration file after all variables (and prompting)

have been resolved. The contents of this Node are extracted and used as an XSL
stylesheet that is applied to the patched driver configuration file.

For information on adding prompts to a sample configuration file, see “Editing Driver Configuration
Files,” an appendix in the Novell Identity Manager Administration Guide (http://www.novell.com/
documentation/idm35/index.html).
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9.11 Editing a Notification Template Name

1 In the Outline view, expand Default Notification Collection.

o N =
=@

- ﬁ) LII‘ILIIII'UI'IIX Driver ;I

][]+ [
L
I
=
T
=
L]
=
=
@
@

i l t,- Userapplication
E| [{=' Default Motification Collection

-E2 A ailability

L= Default Job Motification
-2 Delegate

B2 Forgot Hint

B2 Forgat Password

-E=) Password Reset: Fail
-B2) Password Set Fail
~E5] Password Sync Fal

L-= Provisioning Approwal Completed ki

2 Right-click a notification template (for example, Forgot Password), then select Properties.
3 Edit the name, then click OK.

For additional information, see Chapter 14, “Setting Up E-Mail Notification Templates,” on
page 249.

9.12 Synchronizing Passwords

To view or edit password synchronization, use the Dataflow editor. See Section 12.2.1, “Filtering
Views,” on page 228 and “Synchronizing Passwords” on page 228.
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Managing Versions

Your environment might have versions of Identity Manager earlier than version 3.5, or you might
have a mixture of different versions of Identity Manager.

Before Designer 2.1, if you configured and wrote policies for an earlier version of Identity Manager
in your environment, you might have encountered the following issues:
¢ You could easily build a solution that would not deploy.

¢ You did not know which features worked in one environment versus another environment.
To solve these issues, Designer 2.1 tracks versions of the following objects:

¢ Identity Manager engines

¢ Identity Vaults (trees)

¢ Drivers
As you use Designer 2.1, you see only the UI of features that apply to the version that you are
working on. Project Checker and Deploy ensure that what you have configured is supported in the
target environment.

¢ Section 10.1, “Key Differences in Identity Manager Versions,” on page 180

¢ Section 10.2, “Changing the Identity Manager Version,” on page 180

¢ Section 10.3, “Tracking Versions of Identity Manager,” on page 181

¢ Section 10.4, “Information in the Driver Configuration Wizard,” on page 183

¢ Section 10.5, “Checking Projects for Version Issues,” on page 185

¢ Section 10.6, “Adjusting the UI Based on the Version Number,” on page 186
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10.1 Key Differences in Identity Manager
Versions

Table 10-1 Differences in Identity Manager Versions

Identity Manager 3.0 Identity Manager 3.0.1 Identity Manager 3.5
+ New DirXML® Script + New DirXML Script actions + New object types were added:
actions + New Log Events: + ECMAScript Objects
+ Entitlements were added + Add Value (on add) * Jobs
+ Get Named Password + Mapping Table Resource
+ Reset Attributes Objects
+ Add Value (on modify) * Resource Libraries

+ New Policy Linking capabilities

+ Resource Objects were ) )
where a policy can be in

added: ' :
multiple lists
+ Credential ' '
rocations " actons, conditons, tokons
Applications ; , ,
o and verbs
+ Credential N . .
Provisioning ¢ Ab"t'ty fo;.?erML Script to
Repository Objects nest conditions

* Driver-scoped local variables
in DirXML Script that let you
refer to variable outside of the

policy

+ Generic Resource
Objects

10.2 Changing the Identity Manager Version

You can both import and deploy to all versions of Identity Manager that shipped since Identity
Manager 2.0, up to and including Identity Manager 3.5.1. You can also import from DirXML 1.x
environments.

Because versions earlier than Designer 2.0 M5 did not track Identity Manager versions, those earlier
projects do not have version information.. When you convert an earlier project, Designer 2.1
defaults the Identity Manager version numbers to 3.0.1. During conversion, Designer informs you
that this default is being applied.

You can change this version number by doing either of the following:

+ In the Outline view, right-click the Server object, select Properties, then select from the Identity
Manager Version drop-down list.

+ In the Modeler, select an Identity Vault, click Window > Preferences > Designer for IDM >
Versions, then select a version from the drop-down list.

You can also find information on upgrades, information on downgrades, and a link to a help topic.
This information explains the key differences between versions of Identity Manager.

When you import into a new server (or create a server based on a server that you have browsed to in
the directory), the new server inherits the imported version of Identity Manager.
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If you do a live update in the server properties page, Designer updates the server to the current
version of Identity Manager that is in the target environment.

10.3 Tracking Versions of Identity Manager

Designer 2.1 tracks the Identity Manager version. Filtering functionality is based on this version
information. When multiple servers are associated to a driver set, Designer calculates an “effective
engine version.” This version is the earliest Identity Manager version in the driver set.

If you want to use the latest Identity Manager 3.5.1 features, it is important that all servers belonging
to the driver set are upgraded to 3.5.1. This version can be manually upgraded or downgraded from
the server properties page.

Additionally, live update buttons retrieve current Identity Manager and eDirectory version
information on the server properties page.

Figure 10-1 Live Update Buttons

|dentity Manager 202 -
wETsion: I = J '
eDirectony version: |EDirectDr_l,l ag

&ssigned Driver Set [Driver Set Identity Wault

The Add Server dialog box allows you to specify version information when an Identity Vault is
created.

Figure 10-2 The Add Server Dialog Box

.Add Server Association x|

Specify Server for Identity Vault [=

Take the defaul, specify, or browse ko a server,

Server DM: | server, conkext f§

Identity Manager Yersion: |3.5 'I

Far wersion infarmation of to change the default, click here

oK I Cancel |

The Driver Set Log Level and Driver Log Level propety pages have dynamic version widgets next
to any log event that is not supported by your effective Identity Manager version. Designer 2.0 M5
added support for several Identity Manager log events: Set SSO Credential, Clear SSO Credential
and Set SSO Passphrase.
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Figure 10-3 Log Events

@ Log Events

Engine Events
e
v Engine ‘W arnings

Status Events

v Stop Criver

v Engine Errors

I success I Retry v ‘ifarning

¥ Error [V Fatal [~ other
Dperation Events

I™ search [~ add ™ Remove

™ Modify [ Rename [ Move

™ Add Association

™ Check Password

- Swnc

I add value fon add)
I Get Named Password

" Remove Assaciation
[ Check Ohject Password
™ Cuskom Cperation

" Remove Yalue

" Resst Attributes

[ Query Schema

[ Change Password

[" Clear Attribute

I Merge Entry

[T add value fon madify

[~ set 550 Credential i

[~ Clear 550 Credential & [~ Set 550 Passphrase 5,

Transformation Events|Thi5 feature requires Identity Manager version 3.0.1 or later. |

I Initial Document I Input I Qukput
I Event [ Placement [T Create
(l Input Mapping I Cutput Mapping I Makching

[~ Driver Filker ™ User Agent Request

I Migrate Reguest

I” Command
(l Resync Reguest [~ Passward Sync

" Password Reset

Select Al | Deselect all |
Ok I

Cancel |

For more information about these events, see the Credential Provisioning Policies (http://
www.novell.com/documentation/idm35/index.html?page=/documentation/idm35/policy credprov/
data/bookinfo.html) documentation.

The following figure illustrates an unsupported log event:

Figure 10-4 Message Concerning an Identity Manager Version

.Feature Mot Supported

"Job" is not supported with vour current server's Identity
Manager setking.

AN

To enable this Feature, set the Identity Manager version an all of
your servers in the driver set to 3.0.1 of later,

Faor more details on the differences betwesn the versions of
Identity Manager, click ;
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10.4 Information in the Driver Configuration

Wizard

Figure 10-5 The Driver Configuration Wizard

.Driver Configuration Wizard x|

Select Driver Configuration
Listed below are all driver configurations that can connect to applications or swstems ‘
in wour model,

ou are importing to an Identity Manager 3.0.1 swskem

[ Show al

Drriver Configuration | Config ver | I4in 10N Yer | -

uscli®

]

Active Directory (Resource Kit) 1 201

Delimited Text - C5Y 1 301

C5Y User Impork/Export (Resource Kik) 1 2.0

=l
I idm_2.0.0,200703152140/defs driver_configs/&ctiveDirectory-IDM3_0_1-%1,xml Browse. .. |

[ Perform required prompt checking
[ Do nat show this dislog again

(2] Run Close

In Designer 2.1, the Driver Configuration Wizard provides more information than previous

milestone releases provided:

*

project. You control the version number.

The version of the configuration as a single (undelimited) version number.

The minimum required engine version for this configuration to run.

transparency.

A descriptive name of the driver configuration (no longer just the filename).

The engine version that you are importing into. This information is taken from the current

The full filename of the selected list item. This name is below the list. It is displayed there for

A check box that indicates possible unrecommended or incompatible configuration files.
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Figure 10-6 A Deselected Show All Check Box

@ Driver Configuration Wizard x|
Select Driver Configuration
Listed below are all driver configurations that can connect to applications or systems G

in wour model,

%ou are importing ko an Identity Manager 3.0.1 system

I show Al
Drriver Configuration | Config Wer | Wi IDRT7Er | -

Active Directory (Resource Kit) 1 2.0.1

=

% Delimited Text - C5y 1 3.0.1

By default, the Show A!l check box is deselected if unrecommended or possibly incompatible
configuration files are available. If all available driver configuration files are recommended and

guaranteed compatible, the check box is dimmed and selected, demonstrating that all available
options are displayed.

A deselected Show All check box implies the following:
+ Additional driver configuration files are available but they are not recommended.

¢ The additional driver configuration files are probably incompatible with the engine
version that you are importing to.

In the following figure, the Show All check box is selected.
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Figure 10-7 A Selected Check Box in the Wizard

@ Driver Configuration Wizard

Listed below are all driver configurations that can connect to applications or swstems in wour
model.

Select Driver Configuration 3

‘ou are importing ko an Identity Manager 3.0.1 swstem

IDM Drriver For JDBC 2 1 2.0.1

‘ IDBE" 1" 10M Criver For DBC 2 1 3.5.0

IDM Driver For IMS 3.0 1 3.5.0

Drriver Configuration Config Wer | Min IDM ¥ #*

LD&P 1 20,1
=
2 |

(B

| Caftrunkfcom.novell, designer idm/defs/driver_configsfactiveDirectory-10M2_0_1-v1.xml 2

Perform required prompt checking
[J Do nat show this dislog again

[—::'i il

Run ] [ Close ]

The list now contains many more items than were displayed when the check box was deselected.
These new items were previously hidden because the minimum required engine version for them is

3.5. Because the user is importing to 3.0.1, the configuration might be incompatible.

10.5 Checking Projects for Version Issues

A full suite of project checks makes sure that what you have configured makes sense for your target
environment and can be successfully deployed. Designer's Ul blocks the creation of unsupported
objects and hides features based on the version number. Nevertheless, unsupported actions might

still occur through a few “back-door” methods, such as copying and pasting, importing, and

downgrading your server after you have configured for a newer environment.

In all of these methods, Project Checker catches the problems.

For example, for policy libraries to work, all of the servers on a given driver set need to be at the
same Identity Manager 3.5 version. Project Checker catches problems like this where you might
have an unsupported mix of servers. In this case, the project check results would look like the

following figure:
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Figure 10-8 Project Checker

$E=~ "0

T

Results non-filkered: (& of 8 items )

Sewetity | Error Descripkion Maodel Object
!_1_:] Unsupparted Identity Manager wersion mix on - Driver Set Drriver Set. Identity Yaulk
(%) Identity Wault is missing Host Mame, Identity Wault
(%) Driver set does not contain deployment context, Drriver Set, Identity Yault
(%) Driver set does not contain deployment context, Driver Setl, Identity Yault
[x] Driver set does not have a server associated wikh it. Driver Setl. Identity Yault
Ay Deployment context should be a fully qualified DM (e.g. o=novell) Driver Set, Identity Yault
(D Identity Yault is missing User Mame. Identity vault
(—D Identity Wault user password is not stored in the project, Identity Wault
4 »

Version problems are sorted to the top and have a version icon. If you double-click the item, you get
more details about the problem and how to resolve it.

10.6 Adjusting the Ul Based on the Version
Number

Designer hides or shows and enables or disables capabilities based on the version of Identity
Manager that is associated with the Identity Manager engine. For example, if you edit a policy that is
associated with a server that uses Identity Manager 3.5, Policy Builder shows you all of the new
actions, conditions, verbs, and tokens that ship with that release. This feature lets you try out the
next version of Identity Manager before it is even released.

Also, if you set the server to Identity Manager 3.0.1 (or earlier), you get the previous version of
Policy Builder that Designer has shipped with in the past.

If you try to create an object that is not supported by your server version, a prompt tells you that this
action isn't supported. For example, Identity Manager 3.5 introduces the concept of Jobs, Mapping
Tables, and Policy Libraries. If you try to create one of these objects on a 3.0.1 server, you see the
following message:

Figure 10-9 Prompt: Feature Not Supported

.Feature Mot Supported x|

"Job" is nok suppaorted with your current server's Identity
& Manager setking.

To enable this Feature, set the Identity Manager version on all of
your servers in the driver set ko 3.5 or laker,

For maore details on the: diff
Identkity Manager, click i

rences between the versions of

Future milestones of Designer will continue to evolve the Ul to better handle version differences.
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Managing the Schema

Designer includes a copy of the base eDirectory™ schema, which is stored in the
BaseIVSchema.xml file. This file is located in
designer\eclipse\plugins\com.novell.designer x.x.x\defs\schema.

Do not directly modify BaseIVSchema . xml. Instead, use Designer to add the schema
information from this file into your project. The Manage Schema tool allows you to change the
schema as part of the project. The original BaseIVSchema . xml file is not changed.

Figure 11-1 The Manage Schema Tool

® Manage Schema |

Classes | attributes |
[shift-click ko select range] Ghx (@) Flags:

[Anything] 2| | Effective ™ ron Removable
[Mathing] ! Hon-effective )

AFF Server 3 sl [~ Container
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applicationEntiy ASNL: |
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Audit:File Object
authPasswordObject

Bindery Object Aktributes ISuper | Sub | Containmentl
Bindery Queus

certificationauthoriy @ G G M
cettificationauthorityyer2

CommExec

Campuker

contingentiarker

Counkry

cRL DistributionPoint

deObject

Device

Directory Map

DirxML-Applicationattrs

DirsML-Drriver

DirsML-DriverSet

DirsML-Entitlement

DirsML-EntitlementRecipient
DiraML-iSosDirectoryEnkry Aux
DirsML-iSosGroupPrafiles: ;I

[ Show inherited associations

[ orly show changes

ok I Cancel | j ™| Bocument this Class

You can add, delete, rename, and modify classes and attributes in the eDirectory schema. You can
import the eDirectory schema from the production environment, or use the default schema. After
modifying the schema, you can deploy it into the production eDirectory tree.

WARNING: If you do not have a good understanding of how the eDirectory schema works,
changing the default schema can cause data corruption. If you modify classes or attributes and then
deploy the modified schema into a tree where these classes are in use, one of the following problems
can occur:

¢ Those objects can become unknown.

+ cDirectory synchronization errors can occur.
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To understand the basics of the schema, see Managing the Schema (http://www.novell.com/
documentation/edir88/index.html?page=/documentation/edir88/edir88/data/a4a9bz0.html) in the
online documentation for eDirectory 8.8.

If you subscribe to LogicSource®, see Novell® LogicSource for eDirectory (http://
support.novell.com/subscriptions/articles/novell logicsource.html) for additional information.
LogicSource is a subscription-based service that Novell provides to its customers.

¢ Section 11.1, “Accessing the Manage Schema Tool,” on page 188

¢ Section 11.2, “Creating Classes and Attributes,” on page 189

¢ Section 11.3, “Modifying the Schema,” on page 201

¢ Section 11.4, “Deploying the Schema into the eDirectory Tree,” on page 204

¢ Section 11.5, “Exporting the Schema to a File,” on page 206

¢ Section 11.6, “Importing the Schema,” on page 209

¢ Section 11.7, “Managing a Copy of an Application Schema,” on page 216

¢ Section 11.8, “Mapping eDirectory to an LDAP Schema,” on page 220

11.1 Accessing the Manage Schema Tool

1 Right-click an Identity Vault, then select Manage Vault Schema.

<= Unda

Mew 4

== Shraighiten Connestions

{1 Select Connected Applications

Distribute 4
Align 3
eDirectary Diriver ? Change to eDirectary Tree
. [Ehatige ta ldestitn et o eta-Directans
5 Add to Group

It Schema...

Document S election...

You can import the schema by using the Live menu:
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Figure 11-2 The Live Option

Live ‘Window Help
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i Stop Driver
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. Create eDir-ko-ebir Certificates. .,
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If a custom schema in the production environment needs to be tested, you can import the schema
into Designer. After you have tested and modified the schema, you can deploy it into the production

environment.

11.2 Creating Classes and Attributes

Designer allows you to create eDirectory classes and attributes to fit the needs of your environment.
You can test and use the new schema with the Identity Manager drivers in Designer before

implementing it in the production environment.

¢ Section 11.2.1, “Creating eDirectory Classes,” on page 189
¢ Section 11.2.2, “Creating eDirectory Attributes,” on page 194

11.2.1 Creating eDirectory Classes

¢ “Adding a Class” on page 190
¢ “Icons and Fields in the Classes Page” on page 193

¢ “Adding a Note” on page 194
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Adding a Class

1 In the Modeler, right-click the Identity Vault, then select Manage Vault Schema.

@ Manage schema x|

Classes | attributes |

[Shift-click ta select range] @b @ x (Z) Flags:

[anything] =] © Effective I~ mon Remoyatle
[Mathing]  Mon-effective -

AFP Server & Auliary 1 cenieaines
Alias
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applicationProcess

Audit:File Object [ show inherited associations
authPasswordObject

Bindery Chiject Attributes |Super I Sub I Cantainment |
Bindery Queus

certificationauthority @i TG M
certificationAutharityers

CommExec

Campuker
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Country
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dcObject

Device

Directory Map

DireML-ApplicationAttrs

Dir=ML-Dviver

DirsML-DriverSet

Dir¥ML-Entitlement
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[~ only show changes

ok I Cancel | j I~ Docurment this Class

The Classes tab lists all classes that are defined in the schema and stored in Designer.
2 Decide whether to show changes.

The Only show changes option is below the Classes pane. This option enables you to see only
classes that are different from the base schema (stored in the BaseIVSchema . xml file). If
the base schema is unchanged, the list is empty.

3 Click the Add a Class icon & on the Classes toolbar.
4 Specify the name of the class (for example, EmpInfo), and (if applicapable) an ASN1 ID, then
click OK.

® New Class Wizard x|
Create Class Name @
Specify a name and an ASN1 ID For the new class,

Class name:

| EmpInf|

As5M1 ID (optional):

If you register your schema definition with Novell, Novell provides an ASN1 number. It
resolves the possibility of schema collisions caused by duplicate schema names with different
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definition structures. You register your schema definition if you want to make the schema
definition publicly available.

5 Select the type of class (for example, Effective Class), then click Next.

@ New Class Wizard x|

Class Hags @
Select bype of class and whether or not it is to be a container class.,

Class type:
{* Effective Class

" Mon-Effective Class
 puiliary

[ Container Class

Flag Description

Effective You can create an instance of the defined object
in the eDirectory tree.

Noneffective Only used to define other classes. You cannot
create an object of a noneffective class.

Auxiliary Combines attributes to be added to other
classes by extending the object class attribute.

Non Removable Sets the class so it cannot be removed from the
schema.
Container Sets the object as a container object instead of a

leaf object. If it is set to container, this object can
contain other objects.

6 Seclect the classes that the new class will inherit from, then click Next.
Select a class in the Available classes pane and move it to the Inherited classes pane.
7 Select the mandatory attributes, then click Next.

The inheritances that display in the Inherited mandatory attributes pane depend upon the class
that you selected.

8 Select optional attributes, then click Next.
The Inherited optional attributes pane lists default optional inheritances.
9 Select the naming attributes, then click Next.

The eDirectory schema allows for inheritance from other classes. A class that another class
inherits from is called a super class. A class can inherit attributes from more than one super
class.

Every class inherites from the super class Top. No class exists above Top. For example, Group
inherits directly from Top, but User inherits from Organizational Person. Organizational Person
inherits from Person. Person inherits from ndsLoginProperties, and ndsLoginProperties inherits
from Top.
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10 Select the containment classes.

In eDirectory, an object is a leaf object or a container object. For example, if you select the
class Group, the Manage Schema tool lists the domain, Organization, and Organizational Unit
classes, which can contain the Group class

11 Review the summary, then click Finish.
The new class appears in the Classes pane.
12 Save the settings by clicking OK.

13 Show inherited associations.

Iv Show inherited associations:

Attributes ISuper I sub | Conkainment |
T OT X
M {Maming) -

CH {Mandatory)

Cbiject Class {Mandatory)
AL

Audit:File Link

Autharity Rewvocation
auxi_lassCompatibility
Back Link

Bindery Property
businessCategory

A Private kKey

C4 Public Key

Certificate Revocation
Certificate Yalidity Interval
creatarsMame

Cross Certificate Pair

Description j

PLLURAL A Lo o

[ Document this Class

Attributes: If you select Show inherited associations, Designer lists all attributes that are
associated with a class, whether assigned or inherited. If you don’t select this option, only the
assigned attributes are listed.

The Attributes tab also lists the type of attributes. For example, the class Group has a naming
attribute of CN and a mandatory attribute of CN. All of the other attributes in the list are
optional attributes.

You can add and delete attributes from the selected class by selecting the proper icon.

Super: The eDirectory schema allows for inheritance from other classes. A class that another
class inherits from is called a super class. The Super tab lists the selected class’s immediate
super class.

A class can inherit attributes from more than one super class. The super class that every class
inherits from is Top. No class exists above Top. For example, Group inherits directly from Top,
but User inherits from Organizational Person. Organizational Person inherits from Person.
Person inherits from ndsLoginProperties, and ndsLoginProperties inherits from Top.

Sub: The Sub tab list all classes that inherit from the selected class. If a class isn’t listed in the
Sub tab, no classes inherit from the selected class.

Containment: In eDirectory, an object is a leaf object or a container object. The Containment
tab lists other classes that can contain the selected class.
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For example, if you select the class Group, the Manage Schema tool lists the domain,
Organization, and Organizational Unit classes, which can contain the Group class.

Class Field Description

Add Naming i Adds a naming attribute to the class that is
selected.

Add Mandatory i Adds a mandatory attribute to the class that is
selected.

Add Optional o Adds an optional attribute to the class that is
selected.

Delete % Deletes an attribute from being associated with

the select class.

14 Document the class.

[ Document this Class

If you select Document this Class, Designer documents information on the class when you run
Document Generation.

Icons and Fields in the Classes Page

The following tables explains icons in the Classes toolbar:

Table 11-1 Icons in the Classes Toolbar

Icon Description
Add a Cass C] Creates an eDirectory class.
Rename cCass [f® Renames any class that is not a base class. Not an

available option for base classes.

Delete Class % Deletes any class that is not a base class. Not an
available option for base classes.

Schema Notes H| Enables you to add notes about any class you
create. Not available for base classes.

Help @ Launches the help for the Manage Schema tool.
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Adding a Note

Designer allows you to add notes about any class you create. The information is stored as desc in
the . 1dif file and as a note in the . sch file.

1 Select the class you want to add a note to, then click the Schema Notes icon.

@ Manage Schema

Classes | aeributes |

[Shift-click ko select range] (ﬁa @ * @ @

DirsML-Fesource .
Cir ML -Fule _I
Dir#ML-3haredProfile

Dir ¥ML-SharedProfilessus:

Cir¥ML-SharedProfileSet

DirxML-5tvleSheet

Dir ¥ML-3Subscriber

drmd

domain

d3d

dynamicGroup

dynamicGroupai

edirschemaiersion

encryptionPolicy

2 Type the note in the window, then click OK.

@ Emplinfo Schema MNotes ﬂ
| =l

11.2.2 Creating eDirectory Attributes

¢ “How to Create eDirectory Attributes” on page 194
+ “Syntax for Attributes” on page 198

How to Create eDirectory Attributes

1 In the Modeler, right-click the Identity Vault, then select Manage Vault Schema.

By default, the Classes tab is active. If you want to view or modify attributes for a particular
class, select that class before you select the Attributes tab.

2 Select the Attributes tab.
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The Attributes pane lists all attributes that are defined in the schema and stored in Designer.
You can view all attributes at once, or view the attributes associated with a specific class. When
you select a class from the drop-down list, the attributes associated with that class are listed.

Decide whether to show changes.

The Only show changes option is below the Attributes pane. This option enables you to see
only attributes that are different from the base schema (stored in the BaseIVSchema . xml
file). If the base schema is unchanged, the list is empty.

Click the Add an Attribute icon @,

Specify the name of the new attribute (for example, EmpID) and (if applicable) an ASN1 ID,
then click Next.

® New Attribute Wizard x|
Create Attribute Name @
Specify a name and an ASN1.ID For the new attribute,

Attribute narme:

| Emp1D]

A35M1 ID (optional):

If you register your schema definition with Novell, Novell provides an ASN1 number. It
resolves the possibility of schema collisions caused by duplicate schema names with different
definition structures. You register your schema definition if you want to make the schema
definition publicly available.

Select the syntax, then click Next.

An attribute syntax defines a standard data type that an attribute uses to store its values in the
eDirectory tree. Syntax is required for each attribute. See Table 11-2 on page 199.

Select the flags for the attribute.

Flag Description

Single Valued Allows one value to be stored in the attribute.

Sync Immediate When the attribute is modified, it is synchronized
immediately to all of the servers in the replica
ring.

Public Read Allows anyone to read this attribute without the

Read privilege specifically assigned. You can’t
use inheritance masks to prevent an object from
reading attributes with this constraint.

Write Managed Explicit rights are granted before this attribute
can be changed. In order to modify this attribute,
users must have managed rights on the object to
change the attribute.

Per Replica Allows one value to be stored in the attribute.
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8 Review the summary, then click Finish.

The new attribute appears in the A#tribute pane.

9 Select the constraints for the attribute.

The following figure illustrates the constraints that display on the Manage Schema tool.

@® Manage Schema

Classes  Attributes |

[shift-click to select range]

a2 X =@

Attributes of: I Al Classes >

Horne Direckory
Home Directory Rights
homeEmailaddress
hiomeFax
homePhone
homePostalAddress
homestate
homeZipCode

Hoskt Device

Haost Resource Mame
Hask Server
houseldentifier
httpAuthRequiresTLS
httpDefaulkClearPort
httpDefaulk TLSPork
httpHostServerD
httpIOBUfferSize

httpkeyiaterialObject
httpRequest Timeout
httpServerDh
httpSessionTimeout
httpThreadsPerCPU

[~ only show changes

oK | Cancel |

httpkeepaliveR equest Timeout

X

- l Public Read ™ Mon Removable

[ sync Immediate [ Hidden
A I pead orly [ single Yalued

[ string [ Per Replica

[~ wWrite Managed [~ Server Read

ashil: |

Synkazx: ICase Ignore Skring j
1 [ sized Lower Bound:

Upper Bound:
[ Show inherited associations
Used by Classes: Gy G @ %X

htkpTraceLevel
M i

j [ Document this Attribube

The constraints restrict the information that is stored in the data type and constrain the
operations of eDirectory and eDirectory clients.

Constraint

Description

Public Read

Sync Immediate

Read Only

String

Write Managed

Allows anyone to read this attribute without the
read privilege specifically assigned. You can’t
use inheritance masks to prevent an object from
reading attributes with this constraint.

When the attribute is modified, it is synchronized
immediately to all of the servers in the replica
ring.

The attribute is available to be read, but it cannot
be modified.

Allows only string information to be stored in the
attribute.

Explicit rights are granted before this attribute
can be changed. In order to modify this attribute,
users must have managed rights on the object to
change the attribute.
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Constraint Description

Non Removable The attribute cannot be deleted from schema.

Hidden Only applications running on a NetWare® server
can use this attribute.

Single Valued Allows one value to be stored in the attribute.
Per Replica Allows one value to be stored in the attribute.
Server Read The attribute can be read by an NCP™ server

object even though the right to read is not
inherited or explicitly granted. The NCP server
object is always able to read this attribute,
regardless of the rights granted in the ACL.

Specify size.

If the size of the schema definition is limited, select Sized, then specify the size in decimal
form.

The following figure illustrates the Sized field in the Manage Schema tool. The example in this
figure has no value.

Lower Bound: ID
Upper Bound: ID

This value is the length of the schema definition in the eDirectory database, in bytes. The tool
accepts the information in decimal form. In order to use the information, the eDirectory
database converts it to hexadecimal.

Show inherited associations.

The schema allows for inheritance of other attributes from super classes. If you select this item,
all attributes that are associated with a class, whether assigned or inherited, are listed. If you
don’t select this item, only the attributes assigned are listed.

™ Show inherited associations:

Used by Classes: G G G X
applicationEnkity {MNaming) 3
applicationProcess (Maming)

Audit:File Object {Naming)

Bindery Object (Marming)

Bindery Queue (Maming)

cRLDistributionPoint {Maming)

Device (MNaming)

DirEML-Driver {MNaming)

Dirx¥ML-DriverSet {Maming)

DirxEML-Entitlernent (Marning)

DirxML-Job {Marming) LI
Mri Bl il e FB—rmima™

Used by Classes lists all classes that use the selected attribute. If you select Show inherited
associations, the list includes classes that inherit the attribute.

12 Specify an attribute type.
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™ show inherited associations

Lsed by Classes: @ G @& X
drmd -
daomain Add as Maming
External Entity
Crganization

Organizational Person
Organizational Role
Organizational Unit
sapAddonUmM
Template

The attribute types help define the class.

Icon

Description

Add Naming i
Add Mandatory Tl
Add Optional &

Delete ¥

Adds the selected attribute to a class as a
naming attribute.

Adds the selected attribute to a class as a
mandatory attribute.

Adds the selected attribute to a class as an
optional attribute

Deletes a class from being associated with the
selected attribute.

13 Select the class to associate with the attribute.

Classes | attributes |

& Select Naming Attributes Cl x|

[Shift-click to select range] (ﬁ’ @ b a @
dynamicGraupau ;I
edirschemalersion

encryphionPolicy
External Entity
feder ationBoundary

14 Select whether to document this attribute.

If you select Document this attribute, the data is included when you run Generate

Documenation.

15 Save changes by clicking OK.

Syntax for Attributes

The following information from Novell LogicSource for eDirectory gives details about the
eDirectory schema. LogicSource is a subscription-based service Novell provides to its customers.
This section contains only a small portion of the information available in LogicSource for
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eDirectory. For more information about LogicSource, see Novell Technical Subscriptions (http://
support.novell.com/subscriptions/articles/novell logicsource.html).

Table 11-2 Syntax for Attributes

Syntax Description

Back Link The remotelD field identifies the backlinked object on the server, and the
objectName field identifies the server holding an external reference.

Boolean Two Boolean attributes match for equality if they are both True or both False. True is

Case Exact String

Case Ignore List

Case Ignore String

Class Name

Counter

Distinguished
Name

EMail Address

Facsimile
Telephone Number

Hold

Integer
Interval

Net Address

represented as one (1), and False is represented as zero (0). Any attribute defined
using this syntax is single valued.

Attributes using this syntax can set size limits. Two Case Exact Strings match for
equality when they are of the same length and their corresponding characters are
identical.

Two Case Ignore Lists match for equality if the number of strings in each is the
same, and all corresponding strings match. For two corresponding strings in the list
to match, they must be the same length and their corresponding characters must be
identical (according to the rules for case ignore strings).

Used in attributes whose values are strings and where the case (upper or lower) is
ignored.

Used to match two class names where the case (upper or lower) is ignored.

The attribute is single valued. The syntax is similar to Integer, except that any value
added to an attribute is arithmetically added to the total, and any value deleted is
arithmetically subtracted from the total.

The attribute is the distinguished name of the object up to 256 Unicode* characters.
This is not case sensitive.

Used to match attributes whose values are e-mail addresses and whose lengths
and corresponding characters are identical; however, it ignores case (upper and
lower). Only the EMail Address attribute uses this syntax.

Facsimile Telephone Number values are matched based on the telephone number
field. The rules for matching fax telephone numbers are identical to those for the
Case Exact syntax except that all space and hyphen (-) characters are skipped
during the comparison. Only the Facsimile Telephone Number attribute uses this
syntax.

This syntax is an accounting quantity, which is an amount tentatively held against a
subject’s credit limit, pending completion of a transaction. In the wire format, the
Subject field is the distinguished name of the object. eDirectory treats the Hold
amount similarly to the Counter syntax, with new values added to or subtracted from
the base total. If the evaluated Hold amount goes to 0 (zero), the Hold record is
deleted.

The attribute is an integer. Attributes using this syntax can set size limits.
The Interval value is the number of seconds in a time interval.

Stores the network address as a binary string. The string is the literal value of the
address. It lists the type of communication protocol used.
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Syntax

Description

Numeric String

Object ACL

Octet List

Octet String

Path

Postal Address

Printable String

Two numeric strings match for equality when they are of the same length and their
corresponding characters are identical. It matches the digits 0-9 and spaces if they
are contained in the numeric string.

An Object ACL value can protect either an object or an attribute. The protected
object is always the one that contains the ACL attribute. If an ACL entry is to apply
to the object as a whole, the protected attribute name should be left empty (NULL).
If a specific attribute is to be protected, it should be named in the ACL entry.

A presented octet list matches a stored list if the presented list is a subset of the
stored list. Octet strings are so designated because they are not interpreted by the
Directory. They are simply a series of bits with no Unicode implications.

The length is the number of bits divided by 8 and rounded to the nearest integer.
Thus, each octet represents eight bits of data. The number of data bits is always
evenly divisible by 8.

For two octet strings to match, they must be the same length and the corresponding
bit sequence (octets) must be identical. When comparing two strings, the first pair of
octets that do not match are used to determine the order of the strings. Octet strings
are not Unicode strings.

The string represented by the path field is compared for equality using the same
rules that Case Exact String uses. That is, two paths match for equality when their
lengths and corresponding characters, including case, are identical.

An attribute value for Postal Address is typically composed of selected attributes
from the MHS Unformatted Postal O/R Address version 1 according to
Recommendation F.401. The value is limited to 6 lines of 30 characters each,
including a Postal Country Name. Normally the information contained in such an
address could include a name, street address, city, state or province, postal code,
and possibly a postal office box number depending on the specific requirements of
the named object.

The following characters are in the printable string character set.
A.Z

a..z

0..9

Space Character

‘ Apostrophe

( Left Parenthesis

) Right Parenthesis
+ Plus Sign

, Comma

- Hyphen

. Period

/ Slash

: Colon

= Equal Sign

? Question Mark

Two printable strings match for equality when they are the same length and their
corresponding characters are identical. Case (upper or lower) is significant when
comparing printable strings. For example, as printable strings, “Jones” and “JONES”
do not match.
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Syntax

Description

Replica Pointer

Stream

Telephone Number

Time

Timestamp

Typed Name

Unknown

Each value of the replica pointer syntax is composed of five parts:

* The complete name of the server that stores the replica.

+ A value describing a the capabilities of this copy of the partition: master,
secondary, read-only, or subordinate reference.

+ A value indicating the current state of the replica (new, dying, locked, changing
state, splitting, joining, or moving).

+ A number representing the replica. All replicas for a partition have a different
number assigned when the replica is created.

+ A referral that contains a count of the addresses and one or more network
addresses that hints at the node where the server probably resides. Because
servers are accessible over different protocols, the server might have an
address for each supported protocol.

Streams are files of information. The data stored in a stream file has no syntax
enforcement of any kind. It is purely arbitrary data, defined by the application that
created and uses it. The attribute is singled valued.

The length of telephone number strings must be between 1 and 32. Two telephone
numbers string match for equality when they are of the same length and their
corresponding characters are identical. All spaces and hyphen (-) characters are
skipped during the comparison.

A time value consists of a whole number of seconds, where zero equals 12:00
midnight, January 1, 1970, UTC.

A Timestamp value contains three components:
* The wholeSeconds field consists of the whole number of seconds, where zero
equals 12:00 midnight, January 1, 1970, UTC.

* The replicaNum field identifies the server that created the Timestamp. A
replica number is assigned whenever a replica is created on a server.

* The eventID field is an integer that orders events occurring within the same
whole-second interval. The event number restarts at one for each new second.

The syntax names an eDirectory object and attaches two numeric values to it:

+ The level of the attribute indicates the priority.

+ The interval indicates the frequency of references.

The the objectName or Distinguished Name identifies the eDirectory object referred
to by the Typed Name.

Unknown syntax is used to stop the loss of data, if the eDirectory database
becomes corrupted. When an object becomes Unknown, there is information stored
in this attribute that can allow the object to be recovered. This syntax is used by
eDirectory.

11.3 Modifying the Schema

Designer allows you to modify the eDirectory schema. The following sections describe fields and
definitions used in the Manage Schema tool for classes and attributes.

¢ Section 11.3.1, “Deleting Schema Definitions,” on page 202
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¢ Section 11.3.2, “Modifying Classes or Attributes,” on page 202

¢ Section 11.3.3, “Renaming Schema Definitions,” on page 202

11.3.1 Deleting Schema Definitions

You can delete an extended schema definition. You cannot delete any base schema. If you select a
base schema item, the Delete icon is dimmed, indicating that it is unavailable.
1 In the Modeler, right-click an Identity Vault, then select Manage Schema.

2 Select the class or attribute that you want to delete, then click the Delete icon .

11.3.2 Modifying Classes or Attributes

1 In the Modeler, right-click an Identity Vault, then select Manage Vault Schema.
2 Select the class or attribute that you want to modify.
3 Select a field.

If you select a base schema class or attribute, the following pop-up message appears:

& Confirm &l

¢ ‘You cannot modify base schema classes, Would wou like to create an identity
et vault specific copy of this class to allow modification? Selecting wes may cause
errors if the schema is deploved.

It is best to modify only the extended schema and not the base schema. Modifying the base
schema can cause data corruption and eDirectory synchronization errors.

4 Modify the item, then click OK.

11.3.3 Renaming Schema Definitions

You can rename extended schema definitions. You cannot rename any base schema classes or
attributes. If you select a base schema item, the Rename icon is dimmed, indicating it is unavailable.

¢ “Renaming a Class” on page 202

+ “Renaming an Attribute” on page 203

Renaming a Class

1 In the Modeler, right-click an Identity Vault, then select Manage Vault Schema.
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2 In the Class page, select a class that you want to rename, then click the Rename Class icon.

@ Manage Schema

Classes | attributes |

[Shift-click ko select range] @ @ X = @

DirEML-Resource -
DirsML-Rule _I
Dit ¥ML-SharedProfile

Dir=ML-SharedProfilesiu

Dir=ML-SharedProfileSet

Dit £ML-SkyleShest

DirxML-Subscriber
dmd
daormain

d3a

dynamicGroup
dynamicaroupaux
edirSchemak'ersion

encryptionPolicy

3 Specify the new name of the class, then click OK.

@ Rename Class x|

Enker the class name:

| EmpInfol

kK I Cancel

Renaming an Attribute

1 In the Modeler, right-click the Identity Vault icon, then select Manage Vault Schema.

2 Select an attribute you want to rename in the attribute tab, then click the Rename an Attribute
icon.

@ Manage Schema

Classes  Attributes |

[shift-click ko select range] @F @ # 5 @

Attributes of: | il Classes= j

ermboxConfi -

emplovesstatus
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3 Specify the new name of the attribute, then click OK.

® Rename Attribute X|

Enter the attribute name:

I NewEmpID

11.4 Deploying the Schema into the eDirectory
Tree

After the Identity Manager driver is tested with the new schema, you can deploy the modified
schema into eDirectory.

1 In the Modeler, select the Identity Vault.

2 Select Live > Deploy Schema.

3 Specify the Host Name.

@ schema Deploy Wizard

Select Destination for Deploy @

Select the location where vou would like to deploy the schema

Deploy to eDirectory

Host Name: | 133.56.121.38 |
(Example: 192.168.14, 199 of myseryer.Compary, com)
User Mame: I j

(Example: Admin.Movell)

Password: |

The host name can be the server’s IP address or the DNS name of the server.

4 Specify the User Name, which must be a user with administrative rights to the schema.

5 Specify the user’s password, then click Next.
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6 Select the classes and attributes to deploy into the eDirectory schema, then click Next.

® schema Deploy Wizard x|

Select Classes and Attributes for Deploy @
Check "Deploy all associations” to associate the selected attributes with classes that
may already exist in the swstem of destination,
Classes: Attributes: ™ Deploy all associations
EmpInfo MewEmpID

Select All | Unselect All Select All | Unselect All | Showe all |

(7) < Back. Mexk = | Firish I Cancel

7 Review the summary of classes and attributes to be deployed, then click Finish.

If you have selected duplicate attributes or classes, a warning box appears

@ Confirm X|

Do you want to kry to delete duplicate existing attributes or classes From
eDirectory before deploving?

i[x] |

8 Select Yes or No, depending upon whether you want to resolve the duplicate classes or
attributes.
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9 Review errors or warnings, then click OK.

@ Schema Export Wizard x|

Deploy Messages @
The Follawing problems and warnings occured during schema deploy.

@ Error deploving class Emplnfo, ((Errar -5641) The server did not understand the request because

4| | 2
(7] K, I Save toLog... |

11.5 Exporting the Schema to a File

¢ Section 11.5.1, “Exporting the Schema to a .sch File,” on page 206
¢ Section 11.5.2, “Exporting the Schema to an LDIF File,” on page 208
11.5.1 Exporting the Schema to a .sch File

1 In the Modeler, right-click an Identity Vault, then select Export to File > Schema.
2 Select .sch format.

@® 5chema Export Wizard x|
Select Destination for Export @

Select the location where vou would like to export the schema

Export to file

| Browse. ., |

& sch format
Mdif Farmat

3 Specify a path or browse to where you want to save the schema file, specify a filename, then
click Save > Next.

Designer appends the .sch extension when you export the file.
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4 Select the classes and attributes to export to the . sch file, then click Finish.

@ Schema Deploy Wizard X

Select Classes and Attributes for Deploy @
Check "Deploy all assoriations" to associate the selected attribubes with classes that
may already exist in the system of destination,
Classes: Attributes: I™ Deploy all assoriations
EmpInfo MewEmpID

Select Al | Unselect Alll Select Elll Unselect F'.||| Show Al

7 < Bark | Hext = | Finish I Cancel |

Deploy all associations (above the Attributes pane) enables you to associate the selected
attributes with the classes that might already exist in the eDirectory tree. If you do not select
this box, the new attributes that should be associated with the class are not associated.

For example, if the Employee Photo attribute is associated with the User class, and Deploy all
associations is not selected, Employee Photo is not associated with the User class.

The classes and attributes that are in Designer are listed in the two columns. All classes and
attributes are selected by default. To prevent a class or attribute from being deployed, deselect
it. To add all classes and attributes, click Select All. To remove all classes and attributes, click
Unselect All.

5 Click Finish.

@ Schema successfully exported

If errors occur, a deploy summary screen lists them.
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11.5.2 Exporting the Schema to an LDIF File

1 In the Modeler, right-click the Identity Vault, then select Export to File > Schema.
2 Select Export to file.
3 Select .ldif format.

® Schema Export Wizard x|
Select Destination for Export @
Select the location where you would like to export the schema

Export to file

| Browse. ., |

" sch format
& Idif Farmat

4 Specify a path or browse to where you want to save the schema file, specify a filename, then
click Save > Next.

Designer appends the .1d1 f extension when you export the file.
5 Select the classes and attributes to export to the . 1di £ file, the click Finish.

The classes and attributes that are in Designer are listed in the two columns. All classes and
attributes are selected by default. To prevent a class or attribute from being deployed, deselect
it. To add all classes and attributes, click Select All. To remove all classes and attributes, click
Unselect All.

6 Click OK in the warning.

@ warning

zelected clazses or attibutes. Yerify that the LDAP name for the
clazz or attribute in the 1dif file is corect before imparting the file
into the production environment.

2 The LDAF names are different from the eDirecton names of

[~ Do not show thiz dialog box agaire

The class and attribute names in Designer are the eDirectory names. The names for the classes
and attributes in the LDIF file are the LDAP names. The eDirectory names differ from the
LDAP names. Verify that the names listed in the LDAP file are correct for your environment
before importing the file. For a list of eDirectory class and attribute names mapped to LDAP
class and attribute names, see Section 11.8, “Mapping eDirectory to an LDAP Schema,” on
page 220.

7 Click OK.

If errors occur, a deploy summary screen lists them.
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11.6 Importing the Schema

Designer allows you to import the schema from your production environment to do in-depth testing

with the Identity Manager drivers.

¢ Section 11.6.1, “Importing the Schema from the eDirectory Tree,” on page 209
¢ Section 11.6.2, “Importing the Schema from a File,” on page 211

11.6.1 Importing the Schema from the eDirectory Tree

1 In the Modeler, select an Identity Vault.
2 From the main menu, select Live > Import Schema.

3 Specify information for the server that has the schema that you want to import.

.SEhema Import Wizard x|
Select Source for Import @
Select the location ko import the schema

Import from eDirectory

Hosk Mame: || j
(Example: 192.168.14,199 ar myserver, companty . com)
User Mame: I j

(Example: Admin.Movell)

Passward: |

The host name can be the server’s IP address or the DNS name of the server.
The user name must be a user with administrative rights to the schema.

4 Click Next.

Managing the Schema 209



5 Select the classes and attributes to import into Designer, then click Next.

@ schema Import Wizard x|

Select Classes and Attributes for Import @

Check "Impaort all associations" to associate the selected attributes with classes that

may already exist in Designer.
Classes: Attributes: [T Import all associations
[Anything] - [Anything] ﬂ
[Mothing] [Mathing]
AFP Server accessCardhumber
Alias Account Balance
apchadmnConfiguration ACL
apchadmniConfigur ationBlock aliased Chject Mame
apchadmnModule allowdliasToAncestor
apchadmnServer Allows Unlimited Credit
apchadmniirkualHost apchadmn-BlockType
applicationEntity apchadmn-ConfigurationInfo
applicationProcess apchadmn-ModuleDisable
Audit:File Object apchadmn-ModuleFilefanme
authPasswordObject apchadmn-ModuleQbjectFile
bhCommunity apchadmn-ModuleSymbolMame
bhZommunityiMembership apchadmn-Scope
bhizadget apchadmn-Serveralias
bhModule apchadmn-ServerConfLastModified
bhPage apchadmn-ServerLastBackup
bhPageset apchadmn-Serverame
bhPartal apchadmn-ServerPath
bhPartalConfig ;I apchadmn-ServerPlatform ;I
Select All | Unselect All | Unselect All | Showe Al |
Wiew Differences. .. |

Import All Associations: Enables you to associate the selected attributes with the classes that
might already exist in Designer. If you do not select this box, the new attributes that should be
associated with the class are not associated.

For example, if the attribute of Employee Photo is associated with the User class, and you do
not select Import all associations, Employee Photo is not associated with the User class.

View Differences: Enables you to view the differences in the schema between the eDirectory
tree and Designer.

When you click View Differences, Designer lists the differences in a separate window. To select
all classes and attributes that are different from what is in Designer, click Select All. If you do
not want the different items automatically selected, click Cancel.
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6 Review classes and attributes that Designer will import.

@® schema Import Wizard x|

Import Summary @
The Following classes and attributes will be imported From eDirectory,

Classes: 3

[Anvthing]

[Mokhing]

AFP Server

Alias
apchadmnConfiguration
apchadmnConfigurationBlock
apchadmnModule
apchadmnServer
apchadmnirtualHost
applicationEntity
applicationProcess
Audit:File Object
authPasswordObject
bhZamrunity
bhZommunityMembership
bhGadgek

bhModule

bhPage

bhPageset

bhPortal

bhPortalConfig
bhPortalConfigrtw
bhPartalZonfigSecretStare
bhPaortalGroun LI

(7) < Back i Iext = Finish Cancel

7 Click Finish.

If errors occur, a summary screen lists them.

11.6.2 Importing the Schema from a File

NetWare servers use .sch files. Servers on other platforms use .1d1 f files.

When you created an Identity Vault in the Modeler, Designer created a base schema in your project.
Ifa.sch file or .1d1if file has been saved, you can quickly add classes and attributes for your

drivers by importing classes and attributes from the saved file.

¢ “Importing the Schema to a .sch File” on page 211
¢ “Importing the Schema to an LDIF File” on page 213

Importing the Schema to a .sch File

1 In the Modeler, right-click the Identity Vault that will use the imported .sch file.
2 Select Import Schema from File.
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3 Select .sch format.

@® Schema Export Wizard x|
Select Source for Import
Import your schema From eDirectory or a file,

Import from File

|| Browse. .., |

% sch format
= Idif Farmat

4 Browse to and select the .sch file that you want to use, then click Open.

| & &k E-

fad

2|

File name: ILDAF‘.sch

Lef Lol

Files of twpe: Iﬁ.ll Filez [*.¥]

Open

Cancel
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5 Click Next, then review the .sch file.

@ schema Export Wizard x|

Review .LDIF/.SCH File for Import @

Review and make any desired changes to wour diff.sch file. Changes will be
imported ko Designer, buk not saved back to the file,

MDSschemaExtensions DEFIMITIONS 1= d
BEGIN

"MewEmpID" ATTRIBUTE ;=
{

Operation  ADD,
SyntaxID  SYM_CI_STRING
r

"EmpInfo" OBIECT-CLASS 1=

{
Operation ADD,
Flags {05 _EFFECTIVE_CLASS:

EMD

6 Make changes if necessary, then click Finish.
7 Click OK.

® 5chema Import Wizard x|
Import Messages @
The Following problems and warnings occured during schema import,

Ay attribute already exists - MewEmpID, Overwriting old attribute, |
Ay Class alveady exists - EmpInfo, Cwerwriting old class,

If errors occur, a deploy summary screen lists them.

Importing the Schema to an LDIF File

1 In the Modeler, right-click the Identity Vault that will use the imported .1d1if file.
2 Select Import Schema from File.
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3 Select .ldif format.

® schema Export Wizard

[x

Select Source for Import @
Import your schema from eDirectory or a file.
Import Fram File

Il Browse. .. |

" sch Farmat
&+ |dif Format

4 Browse to and select the . 1di f file that you want to use, then click Open.

2 x|
Look in: Ia zchema ﬂ = I'j{ ‘
LDAP. sch
. schema. dif
File name: Ischema.ldif j Open
Files of ype: f 411 Files (. | Cancel /|
2
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5 Click Next, then review the .1d1i £ file.

@ schema Export Wizard x|

Review .LDIF/ .SCH File for Import @

Review and make any desired changes to your Idiff.sch file. Changes will be
imported ko Designer, buk not saved back to the file,

™ Far existing classes, only impart optional attributes

wersion: 1

|»

#MD3 attribute;MewEmplID

#5ynbaSYM_CI_STRING

#Generated LDAP name;newEmpID

dn: cn=schema

changetype: modify

add: attributeTypes

attributeTypes: (
newemnpid-oid
MAME "mewEmpID’
SYNTAX 1.3.6.1.4.1.1466,115.121.1.15
#-MDS_MAME "MewEmpID'
#-MDS_MOT_SCHED SYMC_IMMEDIATE '1'
!

#MDS class:EmpInfo
#Generated LDAP name;empInfo
dn: cn=schema
changetype: modify
add: objectlasses
objectClasses:
empinfo-oid
MAME "empInfo’
STRUCTURAL
#-MDS_MOT_COMTAIMER '1'
#-MDS_MAME 'EmpInfo’

i of

[exk = Finish | Cancel |

6 Make changes if necessary, then click Finish.
7 In the Warning dialog box, click OK.

the eDirectory names, Designer displays the eDirectory names of
the classes and attributes. Designer does not update the Attribute
Map and Class Map kables on the LDAP Group object in eDirectory,

:' The LDAP names of the attributes and classes are different From

[~ Do not show this dialog againd

The class and attribute names in Designer are the eDirectory names. The names for the classes
and attributes in the LDIF file are the LDAP names. The eDirectory names differ from the
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LDAP names. Verify that the names listed in the LDAP file are correct for your environment
before importing the file. For a list of eDirectory class and attribute names mapped to LDAP
class and attribute names, see Section 11.8, “Mapping eDirectory to an LDAP Schema,” on
page 220.

8 Click OK.

® Schema Import Wizard x|
Import Messages IE
The Following problems and warnings occured during schema impart,

A iatbribube already exists - MewEmpID, Owverariting old attribute, §
A Class already exists - EmplInfo, Owenwriting old class,

If errors occur, a deploy summary dialog box lists them.

11.7 Managing a Copy of an Application Schema

The Identity Manager engine currently uses the application schema for the following:

¢ DirXML Script uses the dn-format/dn-delims to figure out how to parse or convert DN's
coming from and going to the application.

¢ The multi-valued flag on attributes are used during the attribute merge process that happens as
part of a match, resync, or migrate.

¢ Section 11.7.1, “Editing an Application’s Schema,” on page 217
¢ Section 11.7.2, “Refreshing the Application Schema,” on page 219

216 Designer 2.1 for Identity Manager 3.5.1



11.7.1 Editing an Application’s Schema

Designer enables you to manage a copy of the connected system’s schema. You can make changes to
a copy of the application schema so that you can test the Identity Manager drivers in Designer. The
schema changes cannot be deployed into the live application schema.

1 Right-click the driver connection in Designer, then select Manage Application Schema.

i@ < Undo

Mew k

Nirectorny Driver Copy i’

g2 Mark az Firewall

== Straighiter Cannestion

?" Show D atatlow View

o Simulate..
(. Show Policy Sets

E] Fun Configuration Yfizard. .
&2 Edit Entitlernents...

% FPazsword Swnchronization. .

¥ Manage Application Schema...

Daocumnent Selection...
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2 Add, rename, or delete the application’s classes or attributes, then click OK.

@ Application Classes and Attributes x|

Classes: (ﬁ“ @ ¥ % (7 attributes of this class: ar [@ x

Address =
Assoc ID —
Birthdate

Business Phone

Cellular Phone

Ciky

Departrment Descr

Dept Container

Dept ID

Description

Email 1D

Empl Status

Firsk Mame

Full Mame

Home Phone b
Job Code

Job Code Descy

Lask Marne

IMail Drop

Manager ;l

Zonskrainks:

[T Case-Semsitive r IWarming
Flags: [T Read-only [~ Multi-valued
[ Container ™| Required
ASNL: | ashit: |
™ Document this Class Type: I j
04 I Cancel |

Field Description

Classes Lists all of the classes stored in Designer from
the application’s schema.

Add a class Adds a new class.

Rename class Renames the selected class.

Delete class Deletes the selected class.

Refresh application schema Provides a new copy of the application’s
schema.This option is useful if the application
schema changes.

Help Launches the Help documentation for the
Manage Schema tool.

Flags: Container Specifies whether the class is a container.

ASN1 The unique ID of the class.
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Field

Description

Document This Class

Attributes of This Class

Add an attribute
Rename attribute
Delete attribute

Constraints

Type

Adds the schema information into the Document
Generator. For more information see

Chapter 16, “Documenting Projects,” on

page 299.

Lists all of the attributes stored in Designer for
the selected class from the application’s
schema.

Adds a new attribute for the selected class.
Renames the selected attribute.
Deletes the selected attribute.

Specifies the details of the attribute. To edit the
constraints, select an attribute.

Specifies the syntax of the attribute. To view the
syntax, select an attribute. To change the syntax,
select an option from the drop-down list.

11.7.2 Refreshing the Application Schema

If the application schema changes, you can get a new copy of the application’s schema by refreshing

the application schema.

1 Right-click the driver connection, then select Live > Refresh Application Schema.

@. Dacument Selection. .
Export to Configuration File. ..

Live d = Import...
5} Deploy...

&5 Compare..

| Delete
I

Froperties

&5 Fefresh &pplication Schema...

Drriver Configuration L4

&Y Driver Status...
D Start Driver
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2 Click the browse icon.

@ Select Server E|
Server DN (eDirectory): | DMy ault  Morvell| g?

@ Select & server from the eDirectory tree that the driver is
running o,

K | Cancel

3 Browse to and select the server where the driver is installed, then click OK twice.

11.8 Mapping eDirectory to an LDAP Schema

When eDirectory is accessed through LDAP, the names of classes and attributes might be different
than when accessed through the standard NCP-based APIs.

For more information about how that mapping is performed, see

¢ Class and Attribute Mappings (http://www.novell.com/documentation/edir88/
index.html?page=/documentation/edir88/edir88/data/h0000007.html#aSbwxyz)

+ NDK: Novell eDirectory Schema Reference (http://devsup.novell.de/ndk/doc/ndslib/
index.html?page=/ndk/doc/ndslib/schm_enu/data/h4qlmnli.html) at the Novell Developer
Support Web page
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Managing the Flow of Data

Designer allows you to manage how the data flows between the Identity Vault and the connected
systems. You can see how the data flows between all of the connected systems, make changes as
needed, create reports about the data, and view the flow of passwords between the systems.

The Dataflow view and the Dataflow editor manage the data. The Dataflow view displays the flow
of data in the modeler per driver. The Dataflow editor displays a more granular view.

¢ Section 12.1, “The Dataflow View,” on page 221

¢ Section 12.2, “The Dataflow Editor,” on page 227

¢ Section 12.3, “Adding Items in the Dataflow Editor,” on page 235

*

Section 12.4, “Editing Items,” on page 239

*

Section 12.5, “Generating HTML Reports,” on page 243

*

Section 12.6, “Integrating Passwords,” on page 245

12.1 The Dataflow View

The following figure illustrates the Dataflow view. You can use it to control the flow of data
between the Identity Vault and connected systems. The Modeler displays the dataflow.

Figure 12-1 The Dataflow View
T =

@& @& )
- O B

@ Group

@ Organization
@ Qrganizational Unit
@ dzer

[ Show effective flows

*

Section 12.1.1, “Accessing the Dataflow View,” on page 221

*

Section 12.1.2, “Flow Arrows in the Modeler,” on page 222

*

Section 12.1.3, “Viewing How Attributes Are Synchronized,” on page 224

*

Section 12.1.4, “Changing the Data Flow,” on page 224

12.1.1 Accessing the Dataflow View

If you have closed the Dataflow view, you can access it by selecting Window > Show View >
Dataflow.
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Figure 12-2 Selecting the Dataflow View

| window Help
e Window
e E ditar
Qpen Perzpective 4
Show Wiew & Dataflow
Cusgtomize Perzpective... 5 Navigator
Save Perspective Az, . EE Outline
Reset Perspective (. Policy Set
Cloze Perzpective == Project
Cloze All Perspectives i, Project Checker
v » . Provisioning Yigw

If the Dataflow view is blank and no project is displayed in the Modeler:

1 Expand a project in the Project view.
2 Open the project by double-clicking System Model.

Objects and icons appear in the Dataflow view.
If you want to change how the data flows from the Modeler:

1 Right-click a driver or application in the Modeler.

< Unda Change Location

SUSE Linux
inu Mew »

Copy ]

g2 Mark as Firewal

=s-a Straighten Connection

FARE| ?'* Show Dataflow Yiew
3 "‘-.\

&g Publish "asdras" from SUSE Linusx
@ Subscribe "asdfas" to SIISE Linus:
@@ Sync “asdfas" both directions

o Simulate. ..

(. Shaw Policy Sets

<:| Ignore “asdfas" From SUSE Linux
i . D Ignore “asdfas" bo SISE Linusx
& Edt Entitlements... GD Ignore “asdfas" both directions

E] Fun Configuration YWizard. ..

2 Select Dataflow, then select how you want the data flow to change.

12.1.2 Flow Arrows in the Modeler

When the Dataflow view opens, it automatically reads the filters and shows the classes and
attributes. (If a filter with classes and attributes doesn’t exist, create one.)
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Figure 12-3 Flow Arrows in the Modeler

El%) Publisher

- Password{Pub)-Add Passw
Password{Pub)-Check Pass
Password(Pub)-Default Pa:

d Password({Pub)-Publish MD?
1 PublisherCreateRule -

d PublisherMatchingRule | Y THa
PublisherPlacementRule : -

ubscriber Driver
-8 SubscriberEventTransForm:

a Driver
[ ST R TU S TN hl
4| | 3
= paaion x N =0

G @ = &

@ Counkry
@ Group
Cirganizakion
-8 Organizational Unit

@ Lser

[ Show effective Flows

@ Developer | [g Architect ?" Dataflow Tahble

As you select a class (for example, ) or attribute in the Dataflow list, the appropriate driver lines are
highlighted in red in the Modeler. Icons enable you to see Sync, Notify, Reset, and Ignore filter
settings all at the same time.

Table 12-1 Dataflow Icons

Icon Description

Q—“ Green arrow: the Publisher channel is synchronized.
L Orange arrow: the Subscriber channel is synchronized.
E Bell: the attribute is set to Notify.

ﬁ Reset arrow: the attribute is set to Reset.

No decoration  The attribute is set to Ignore.

The color coding matches the Dataflow icons in the Filter editor and the Dataflow editor.
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12.1.3 Viewing How Attributes Are Synchronized
Figure 12-4 Show Effective Flows

m\mlicy Set ‘ Provisioning V... | =0

L CRCRE RIS

s

Show effective Flows

To view whether attributes are synchronized or whether they will be notified, select Show effective
flows. When you select this check box, the synchronize arrows don’t show if the parent class isn’t set
to synchronize. Therefore, you view an accurate diagram of actual flows.

However, if you want to view how attributes are configured to synchronize, regardless of the parent
class, deselect Show effective flows. The synchronize arrows indicate which items are synchronized.

If you select an attribute that can't synchronize (whether or not Show effective flows is selected), you
see a Blocked warning in the upper left. This warning indicates that this attribute can’t be
synchronized or notified because the parent class isn’t synchronized.

Figure 12-5 The Blocked Text and Icon

Palicy Set ?" Data Flow &3 ! =0

CIEEL
@m ”

@ Description
@ Equivalent Ta Me
@ Full Mame
@ Grouo Membershio

[ 5how effective Flows

To view an explanation, hover the mouse over the Warning icon.

12.1.4 Changing the Data Flow

You can change how the data flows for classes and attributes from the Dataflow view.
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To change the flow for a class:

1 Select a class in the Dataflow view.

Properties Palicy Set =g
G @ B &
Crganizational Unit ~
ser —
@ buildirgrare
@ M

=)
-
=]
=
h=]
@
=]
=
€

[ showe effective Flows

2 Right-click a driver line in the Modeler.
3 Select Dataflow.

<! Undo Change Location

SUSE Linux
I MeEw »

Copy »

g2 Mark as Firewall

=s-a Straighten Connection

o Simulate. ..
(. Shaw Policy Sets

El Run Configuration YWizard. ..
£# Edit Entitlements. ..

@ Publish "asdfas" from SISE Linux
@ Subscribe "asdfas" to SISE Linusx
@@ Sync "asdfas" both directions

<:| Ignore "asdfas" From SUSE Linux
D Ignore "asdfas" bo SISE Linusx
GD Ignore "asdfas" both directions

4 Select the option to change the data flow for the class.
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To change the flow for an attribute:

1 Select an attribute in the Dataflow view.

Properties Palicy Set =g
G @ B &
= G |dser ~
@ [Tk -
@ compary

@ Description
@ DirsML-ADAlasMame

[ showe effective Flows

|£

2 Right-click a driver line in the Modeler.
3 Select Dataflow.

< Unda Change Location

e L4
Copy r

g2 Mark. a5 Firgwall

=== Straighten Connection

?" Show Dataflow Yiew

@ Publish "Group,Description” From SUSE Linus
@ Subscribe “Group.Description” ko SUSE Linusx
@@ Svnc "Group.Descripkion” both directions

o Simulate. ..
(. show Policy Sets

Q—b Matify “Group. Description” from SIUSE Linus:
b" Motify "Group, Description” to SUSE Linux
Gﬁ-’ Matify “Group. Description” both directions

i El Run Configuration WWizard, ..
£2 Edit Entitlements. ..

'_*a Password Synchronization. .
& Manage Application Schema. .. <% Reset "Group.Description” From SUSE Linux
%—i Reset "iGroup.Description” to SUSE Linux
ﬁa'i Reset "aroup.Description” both directions

Dacurnent Selection. .,

‘i@ Export to Configuration File. ..

<:| Ignore “Group.Description” From SUSE Linux
D Ignore "Group.Description” o SUSE Linusx
3 Delete GD Ignore “Group,Description” both directions

Live

4 Select the option to change the data flow for the attribute.
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12.2 The Dataflow Editor

Figure 12-6 The Dataflow Editor
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The Dataflow editor enables you to do the following:

¢ Use filters to display how data flows between all systems and Identity Vaults.
¢ View how passwords flow from each server.

¢ Generate reports of the data.

When object additions, deletions, changes, and selections synchronization occur, the Dataflow
editor synchronizes with the Modeler and the Outline view.

To access the Dataflow editor, click the Dataflow tab.

To adjust the area for the Identity Vaults, move the slider bar. This setting persists and is restored the
next time you run the editor.

¢ Section 12.2.1, “Filtering Views,” on page 228
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¢ Section 12.2.2, “Filtering Identity Vaults and Applications,” on page 230

¢ Section 12.2.3, “Pinning the Identity Vault,” on page 230

¢ Section 12.2.4, “Expanding and Collapsing the Identity Vault,” on page 231
¢ Section 12.2.5, “Switching to an eDirectory Tree Icon,” on page 233

¢ Section 12.2.6, “Viewing an eDir-to-eDir Driver,” on page 234

¢ Section 12.2.7, “Keyboard Support,” on page 235

12.2.1 Filtering Views

By default, the Dataflow editor shows all dataflows. The View drop-down list (in the upper left
corner of the Dataflow editor, not in the Dataflow view), enables you to view notification,
synchronization, reset, or Password Sync information. These filtered views do not allow you as
much editing capability as the main view, but just what is necessary in that filter. For example, you
can’t add attributes, vaults, or applications, because by default they wouldn’t appear in the filter.

Figure 12-7 Options to Filter Views in the Dataflow View

Yiew: | Al Filkers w

Matify - Filkered

Sync - Filkered

Reset - Filkered
Password Sync

If you are in the All Filters view, you can further filter with the A#ributes list. Because the Dataflow
editor provides non-filter attributes, you can choose to view regular filter-based attributes, non-filter
attributes, or both.

Figure 12-8 Options on the Attributes Combo Box

View: | Al Filters v Attributes: |al w
ADEzxchani{ &l nts Servic..
D ADExchard i mFilker nts Setvic,,
&l ] 3
MW!
Directory,
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Group @ @ <:| D
Organizational Unit @ ® <:| D
User @ ® <:| ®

Synchronizing Passwords

The Password Sync view enables you to see and edit how all passwords flow in the project.
Designer displays the information on a per-server basis and shows how passwords flow among all of
the applications.
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Figure 12-9 The Password Flow
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To edit the password flow:

1 Select Password Sync in the View filter.

2 Double-click the flow arrow.

You can also right-click, then select Password Synchronization.

3 Edit the password synchronization options.

For more information about password synchronization, see “Password Synchronization across
Connected Systems” in the Novell Identity Manager Administration Guide (http://
www.novell.com/documentation/idm35/index.html).

Pazsword Synchronization Options

[V ddentity Manager accepts passwords [Publisher channel @ L

™ Use the Distibution Paszword for password synchronization @

(% Leceptthe passwardlanlyif it complieswith the users password palicy @

I¥ | Besetthe user's password b the Distibution Fasswaornd @

Pazzword

@ If the paszword does not comply, enforce the
pazzword policy on the connected spstern by
rezetting th euzer's pazzword to the Distnbution

1 fliways aceept the password: ignoe passwond polizes

¥ The application sccepts passwords [Subscriber Channel] @ 0

v Maotify the uzer of password sunchranization failure via e-mai @

o]
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4 Click OK.

12.2.2 Filtering Identity Vaults and Applications

You can select the Identity Vaults and applications that you want to view in the editor.

1 In the Dataflow editor, click the Filter View icon.

View: [H)SES Attributes: Im 3] o] e | (L] ] | i 4 | @ JSZ (7}
eDirectory Drive LDAP Entitlement
eDirectary Driver LDAF Driver
— N Direotory
[= Identity ¥ault

2 Select Enabled.

The Identity Vaults and applications that you select here are included in the HTML reports. For
more information, see Section 12.5, “Generating HTML Reports,” on page 243.

= Filter x|

33 Waul:

eDirectary Driver (eDirectary Driver)
- [#] Active Direckory (Active Directory)

=[] kvedjur Yault

eDirectory Driver (eDirectory Driver)

Driver (Diriver)

Userapplication {Userapplication)

You can scroll and resize the dialog box. Also, you can interact with the Dataflow editor in the
background, in any mode. This is convenient if you want to scroll a different section into view
while this dialog box is up.

12.2.3 Pinning the Identity Vault

To change the scope of the editor to show a single Identity Vault, right-click the vault, then select
Pin Vault to Top Header Row.
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Figure 12-10 Pinning an Identity Vault
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With a medium or large-sized project, the dataflow table can contain hundreds of rows and
thousands of items. If you have multiple vaults and want to narrow the scope to more easily edit a
vault without excessive scrolling, you might want to pin a vault. When an Identity Vault is pinned, a
pin icon displays in the upper right corner.

Figure 12-11 A Pinned Identity Vault

ERIDM Vault]

-

To unpin the vault, right-click the Identity Vault, then select Unpin Vault from Top Header Row.

12.2.4 Expanding and Collapsing the Identity Vault

¢ “Expanding an Identity Vault” on page 231

¢ “Expanding All Identity Vaults” on page 232

+ “Expanding Classes” on page 233

Expanding an Identity Vault

When the editor first loads, all vaults are expanded at the top level by default.
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To collapse or expand the list of classes and attributes in an Identity Vault, do one of the following:
¢ Click the - or + icon below the Identity Vault icon.

Figure 12-12 Icons to Expand or Collapse the List of Classes
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¢ Select the Identity Vault, then press the Right-arrow key to expand the information, or press the
Left-arrow key to collapse the information.

Expanding All Identity Vaults

To expand or collapse the list of classes and attributes for all Identity Vaults, click the + or - icon on
the toolbar.
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Figure 12-13 Icons to Expand All Identity Vaults
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Expanding Classes

To view all attributes in a class, select the class, then press the Right-arrow key. To collapse the list
of attributes, press the Left-arrow key.

To view all classes and attributes in an Identity Vault, right-click the Identity Vault icon, then select
Expand Vault. To list just classes in an Identity Vault, right-click the Identity Vault, then select
Collapse Vault.

Figure 12-14 Menu Options to Expand an Identity Vault
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12.2.5 Switching to an eDirectory Tree Icon

To switch from an Identity Vault icon to an eDirectory™ tree icon, right-click the Identity Vault, then
select Change to eDirectory Tree.
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Figure 12-15 Changing to an eDirectory Tree
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12.2.6 Viewing an eDir-to-eDir Driver

You can easily view both ends of an eDir-to-eDir connection so that you can configure the dataflows
on both sides. Designer automatically detects the two eDirectory applications and aligns them in the
same table column. A red line connects them.

Figure 12-16 An eDir-to-eDir Connection
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12.2.7 Keyboard Support

You can navigate by using the Up-arrow, Down-arrow, Left-arrow, and Right- arrow keys as well as
PageUp, PageDown, Home, and End. In addition, you can navigate from one Identity Vault to

another by clicking the Up-arrow or Down-arrow on the toolbar.

Figure 12-17 Navigation Icons
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12.3 Adding Items in the Dataflow Editor

¢ Section 12.3.1, “Adding an Identity Vault in the Dataflow Editor,” on page 235
¢ Section 12.3.2, “Adding a Driver in the Dataflow Editor,” on page 236

*

*

Section 12.3.4, “Adding Classes and Attributes,” on page 237
Section 12.3.5, “Adding Non-Filter Attributes,” on page 238

*

12.3.1 Adding an Identity Vault in the Dataflow Editor

Figure 12-18 The Dataflow Editor s Toolbar

Section 12.3.3, “Adding an Application in the Dataflow Editor,” on page 236

o
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Identity ¥ault 1

To add an Identity Vault, click the Add Identity Vault icon on the toolbar.
To configure the Identity Vault, double-click it.

To delete an Identity Vault, select it, then press Delete.
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12.3.2 Adding a Driver in the Dataflow Editor

Figure 12-19 An Identity Vault in the Dataflow Editor
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To add a driver while in the Dataflow editor, right-click an Identity Vault, then select 4dd App/

Driver.

To delete an Identity Vault or driver, select it, then press the Delete key.

12.3.3 Adding an Application in the Dataflow Editor

1 On the toolbar, click the Add Application icon.

View: |4l Fiters - IR & B EE
Avaya 2 elirectory 2 b=
Dtiwet Dtiver 2
AVAyA
PBI N
Identity Yault 1

2 Browse to and select the driver set that you want this application to connect to, then click OK.

® Choose Driver Set

Which driver set do wou want to connect this app ko?

-] Kvediur

[ 72 vaul:

#-{@] 1dentity vault
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3 Select the driver you want to create, then click OK.

@ Sclect Driver El

Select one of the Following drivers:

E}‘A‘i"”ﬁ AD Driver
L e

b
@f Avaya Driver
-_l’_
“ﬁ eDir Driver
[., J) Entitlement Driver
IE;'J..’::{If Exchange Driver
| J) Generic Driver

— v

| Cancel

Designer creates a skeleton of the driver. It does not launch the Driver Configuration Wizard. If
you want to configure the driver, right-click the connection icon in the Modeler, then select Run
Configuration Wizard.

12.3.4 Adding Classes and Attributes
You can add classes and attributes to the dataflow.
To add a class:

1 Right-click an Identity Vault, then select Add Filter Classes.

50 add Filker Cla

G
SDMYAU L
—————— [ Add App/Driver...

2 Select the class that you want to add, then click OK.

If you want to add more than one class, press Ctrl and select the classes.
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To add an attribute:

1 Right-click a class, then select Add Filter Attribute.

ADExchange
D ADEichange
@| T
Activa
Directory,
= IDMYAULT
=] Employee s e

& Add Filker Attributes. .,
/% &dd Mon-Filter Attribute. .,
i Edit Schema...

@ departr
@ Object

2 Select the attribute that you want to add, then click OK.

If you want to add more than one attribute, press Ctrl and select the attributes.

12.3.5 Adding Non-Filter Attributes

The Dataflow editor provides non-filter attributes. By default, all classes and attributes in the
Dataflow editor come directly from all of the filter policies of the drivers. However, in production
environments, it is common to cause data to flow a certain way directly in your Policy Script code,
XSLT, or in external code that you call out to.

Usually, these non-filter attributes aren’t defined in a policy filter (unless you’re describing
“augmented” processing) and aren’t in the schema map. This is because they are generated outside
of normal driver operations and you need them in the schema mapping rule only if the engine
processes them.

Normally, non-filter attributes are operated on in the Publisher Command Transformation policy set
or the Subscriber Output Transformation policy set.

The Dataflow editor lets you add the non-filter attributes to the table for documentation purposes so
that you can capture the attributes and have an accurate picture of your actual enterprise dataflows.

To add a non-filter attribute:
1 Right-click the class or attribute name, then select Add Non-Filter Attribute.

=l 11 ¥ault

Country

Group

[= Organization
(@ Description

GUI
o @ Add Filker Attribute. ..
@ o

A add Mon-Filter Attribute
= Drgani: iy Edit Schema...

@ Des

¥ Remove
@ GUL
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2 Specify the name of the attribute or class, or click Browse, then browse to and select the
attribute or class.

® Add Mon-Filter Attribute x|
Add Non-Filter Attribute
This attribute usually isn't defined in a filker or the schema map, but is actual data that your
policies define Flows For and that wou want to noke For documentation.
—Whete the Flow is Defined
Marne:
Eromse. . | * In Policy
3y Policy Script or X5LT
@ Usually in the Publisher channel's
Command step or Subscriber
S (R TR TR e = Y
" In External Service
@, e.g. Java RMI call aut ko the driver,
3 Click OK.

4 Select where the flow of the attribute or class is defined.
In Policy: The dataflow is defined in a policy script or an XSLT style sheet.

In External Service: The dataflow is defined in a Java* RMI call to the driver.
5 Click OK.

If the non-filter attribute is defined by a policy, a small P is added to the icon. This icon distinguishes
a non-filter attribute from a regular filter attribute.

Figure 12-20 A Non-Filter Attribute

3y In Policy

If the attribute is defined by an external service, a small E is added to the icon.

Figure 12-21 A Non-Filter External Attribute

@, In External Service

12.4 Editing Items

¢ Section 12.4.1, “Editing within the Dataflow Editor,” on page 240

*

Section 12.4.2, “Editing Non-Filter Attributes,” on page 241

*

Section 12.4.3, “Managing Schema,” on page 241

*

Section 12.4.4, “Removing a Flow,” on page 242

*

Section 12.4.5, “Changing Data Flows,” on page 242
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12.4.1 Editing within the Dataflow Editor

As a convenience, you can edit many items within the Dataflow editor. This capability turns the
Dataflow editor into a full project editor that allows you to have all the tools you need in one place.
You can edit Identity Vault properties, classes, attributes, drivers, and applications.

¢ “Identity Vault Properties” on page 240
+ “Classes and Attributes” on page 240
¢ “Drivers” on page 241

¢ “Applications” on page 241
Identity Vault Properties

Access the Identity Vault’s properties pages by doing one of the following:

¢ Double-click the Identity Vault.
¢ Select the Identity Vault, then press Enter.
¢ Right-click the Identity Vault, then select Properties.

Figure 12-22 The Properties Option

22 Edit Driver Set..,,
% Add Driver Set...

—— ¥ Remove Identity Yaulk
Properties
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Classes and Attributes
Launch the Manage Schema tool by doing one of the following:

¢ Double-click the class or attribute.
¢ Select the class or attribute, then press Enter.

+ Right-click the class or attribute, then select Edit Schema.

This tool enables you to modify classes and attributes. For more information, see Chapter 11,
“Managing the Schema,” on page 187.

Figure 12-23 The Edit Schema Option
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Drivers

To access the driver’s property pages, click the driver name below the application name.

Figure 12-24 Location of a Driver Name
LDAP Directory Active D
WLAP | pap (dick bo edit)
LDAPER
=== At
Directory Dfn_a:

Applications

Access the properties pages for the application by doing one of the following:

¢ Double-click the application.
¢ Select the application, then press Enter.

+ Right-click the application, then select Properties.

Figure 12-25 The Properties Option for an Application

B Al
@B B
eDirectory Driver Driver
eDirectory Diriver Crriver
[rectory | i M‘Hi
__"] Add App|Driver...
22 Edit App's Driver...
@E ¥ Remove App/Driver

Propertigs

12.4.2 Editing Non-Filter Attributes

The directional flow of these attributes is edited in the same way as other attributes. Right-click the

arrows and select Publish, Subscribe, Ignore, Reset, or Remove from Filter.

Reset means that you have the value reset under certain conditions. The attribute might be in a
policy filter, but in addition, you might have some manual logic that resets the value. Occasionally,

resets by manual logic occur in production environments.

12.4.3 Managing Schema

To import, deploy, and edit the schema in the Dataflow editor, right-click an Identity Vault. All
schema changes made outside of this editor are synchronized. For more information, see Chapter 11,

“Managing the Schema,” on page 187.
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Figure 12-26 The Manage Schema Option
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12.4.4 Removing a Flow

If a particular flow (Publisher or Subscriber channel) is not defined in the policy filter’s XML, a red
X replaces the Publisher or Subscriber channel arrow. This means that it’s not in the policy and there
will be no flow. This scenario is essentially the same as an Ignore Flow icon, which is an empty
white arrow. However, the distinction is useful so that you know what is actually in your policy’s
XML.

To remove the flow from the XML:

1 Right-click the Publisher or Subscriber channel icon.

2 Select Remove from Filter.

'
<:| Ignore - Other Yault's Changes

ﬁg b Motify - Yault of Other Yault's Changes
@E @ Publish - Other Yault's Changes ko this Yaulk
@E F‘!” Resek - Changes in Yaulk Mok Made by Other Yaulk

o¥ Remove From Filker

If a class or attribute is marked to be removed on both channels and nothing references it,
Designer removes it from the Dataflow editor’s table.

12.4.5 Changing Data Flows

To change the way data flows, right-click the arrow that displays the dataflow, then select the option
that you want.

The Publisher channel is on the left. The Subscriber channel is on the right.

Figure 12-27 Changing the Subscriber Flow

fam oY fam oY
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The Reset-Changes in App Not Made by Vault option is available when you select an attribute.
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Figure 12-28 The Option to Reset Changes

db @
@ @
dbD @
G A [,

D Ignore - Yault's Changes

@ @ b Matify - App of Yault's Changes
<:| @ Subscribe - Yault's Changes o App
@ @ '5'__'. Reset - Changes in &pp Mok Made
B ¥ Remove From Filker

12.5 Generating HTML Reports

1 Click the Save Current View to HTML icon or the Save All Views to HTML icon.

View: |4l Filters - = @Q‘a‘] E[_%D{r 1 O % ®

Avaya 2 eDirectory 2
Crriver Crriwer 2
KvayA
PEX N
Identity Yault 1

Save Current View to HTML generates a report for the current view. Save All Views to HTML
generates nine reports.

Mame £ | Modified | Sizel Type
[Cicans 12/8/2006 12:15 PM File Folder
&] DakaFlowall, bl 12812006 12:29 PM 1KE HTML File
&] DakaFlowFilker hkml  12/8/2006 12:15 PM 1 KB HTML File
@ DakaFlowMonFilke,,.  12/8j2006 12:15 PM 1EE HTMLFil=
&] MokifyFlowall, bl 12/8§2006 12:15 PM 6kE HTMLFile
@ PasswordFlowal....  12/8/2006 12:15PM 7KE HTML File
@ ResetFlowall,htrml 12812006 12:15 PM 1KE HTMLFil=
&] SyncFlowall bl 12/8§2006 12:15 PM 101 KB HTML File
@ SyncFlowFilker . html  12/8/2006 12:15 PM 101 KE HTML File
@ SyncFlowMonFilke, .. 12/8)2006 12:15 PM 1KE HTML File
« e

The HTML files are automatically named. The descriptive names tell what the report is. All
images that you need to support the HTML document are copied to an i cons subdirectory
where the HTML is saved. The process includes all of your custom application icons.

Managing the Flow of Data 243



You are prompted to save the project to disk.

@® Save View to HTML X

31) The project will be saved first to make sure the images are on disk,

Do wou want to proceed?

[ Do not show this dialog box againd

Yes Mo

Saving is necessary to make sure that all of your icon information is in a state where it can be
successfully copied.

2 Click Yes to save the project.
3 Browse to and select the location where you want to save the reports, then click OK.

The directory you select for saving is stored in Designer’s memory and becomes the default
directory the next time you save.

4 Click OK in the Information dialog box that indicates where the report is saved.

If you pin an Identity Vault and then generate a report, the report is for that Identity Vault. The
Identity Vault’s name is included in the HTML name.

Figure 12-29 A Pinned Identity Vault

ERIDM Yault]
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If the Dataflow editor has multiple applications, Designer wraps the table so that the applications
appear as Continuation #1, Continuation #2, etc. in the report for the pinned Identity Vault.
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Figure 12-30 Continuation Rows in a Report
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12.6 Integrating Passwords

If a driver is synchronizing passwords (in at least one direction), a small password-field icon
appears under the driver icon. This icon enables you to know where passwords are being
synchronized.

You can toggle this icon on or off in Preferences.

1 Select Window >Preferences > Designer for IDM > Modeler.
2 Click the Display tab.

3 Select or deselect Show password icons in Developer mode.

® Preferences

|tvpe

- General
[ Desigrer For IDM

B

=

filker kext

Modeler

- Configuration

- Dacument eneratian
- Entitlements

- iManager

- Impork/Deploy

- Drakaflow
e Palette

- Policty Builder

- Project Checker

- Schema

- Simulation

Behaviors  Display |§uidance | Layautsl Pages | Prompts | Themes |
[w Show labels by applications and Identity Yaulks (architect mode)

[w Shows driver icons in Developer mode

@assward icans in Deve@

[ auto-expand Identity Yaulks to fit contents
v auto-shrink Identity Yaulks ko fit contents
[ Auto-size Identity Yaults ko fit their titles

iarid Width: | 50
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If you hover the mouse over the password icon in Developer mode, a helpful tip explains how your
passwords are flowing for each server involved in the flow.

To configure the flow of password synchronization:

1 In Dataflow mode, select Password Sync in the View drop-down box.
2 Double-click the flow arrow.

3 Select options, then click OK.

Paszword Synchronization Options

@ IF the pazsword does not comply, enforce the
pazswaord policy on the connected system by
rezetting th euzer's pazsword ta the Diztribution
Pagzwiard
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Creating and Managing Policies

Policies enable you to customize the flow of information into and out of Novell® eDirectory™ for a
particular environment.

For example, one company might use the inetorgperson as the main user class, and another company
might use User. To handle this, a policy is created that tells the Metadirectory engine what a user is
called in each system. Whenever operations affecting users are passed between connected systems,
Identity Manager applies the policy that makes this change.

Policies also create new objects, update attribute values, make schema transformations, define
matching criteria, maintain Novell Identity Manager associations, and many other things.

For more information on policies, refer to the following:

¢ Understanding Policies for Identity Manager 3.5.1

¢ Policies in Designer 2.1

* Novell Credential Provisioning Policies for Identity Manager 3.5.1
¢ Identity Manager 3.5.1 DTD Reference
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Setting Up E-Mail Notification
Templates

Notification templates enable you to customize and send e-mail messages that users receive when

triggers occur.

*

Section 14.1, “Viewing Notification Templates,” on page 249

¢ Section 14.2, “Editing a Notification Template,” on page 251

*

*

Section 14.3, “Adding a Notification Template,” on page 255
Section 14.4, “Policy Builder and Notification Templates,” on page 256

¢ Section 14.5, “Configuring the E-Mail Server,” on page 256

14.1 Viewing Notification Templates

Designer provides default notification templates, which you can view or edit.

1 Select an Identity Vault in the Modeler.
2 In the Outline view, scroll to the Default Notification Collection for that Identity Vault.

(=2 ouine x N =

8

e @ B O

l

EII{=_=L [Elel‘ault Matification Callection
-E5)| dvailabilivy

[

i

= Availability_en

L-= Default Job Matification
B2 pefault Job Motification_en

Delegate
Delegate_en

~E5)] Fargat: Hint

Forgot Hint_en

=| Forgat Passward

| Forgot Password_en
=| Password Reset Fail

=l Password Reset Fail_en
“=)| Password Set Fail

/| Password Set Fail_en

| Password Sync Fail

=) Password Sync Fail_en
B2 Provisioning Approval Complete

Provisioning Approval Complete
Prowisioning Mokification
_' Provisioning Mokification Ackivits
- Provisioning Motification Ackivits
- Prowisioning Motification_en
: Provisioning Reminder

e Prowisioning Reminder_en

- Proxy -
| 3

[
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If Default Notification Collection isn’t expanded, expand it. The expanded tree shows the
notification templates. If you selected English as the language option during the install, the
expanded tree view lists an _en item and a non_en item for each template.

The install program installs all of the notification templates with Designer. However, templates
are filtered out of the Outline view based on your workstation’s locale settings. To view and
edit the internationalized template files, click the Filter button in the Outline view, then select
languages that you want to see. To eliminate the duplicate (_en) set of templates, deselect
English in the filter.
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Show items of bvpe:
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EEEEEE
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Forgok Hink

Forgot Password

EZ) password Reset Fail

Passward Set Fail
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Provisioning Motification
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Provisioning Reminder

-2 | Proxy
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: Server

- [#] Driver Set

¢ B[] Driver
Publisher
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Palicy
Entitlement
Application

EE' E-[ail Mptification Template
(Qenalsh)
- LI Chinese Simplified

--[ chinese Traditional
- butch

- French

--[] serman

-] Tkalian

- Japanese

--[] Portuguese Brazil
--[ Spanish

--[] Russian

- swedish

You use the templates in the Default Notification Collection to send e-mail notifications to
users in the Identity Vault. You can customize these templates with your own text.

Right-click a template (for example, Forgot Hint), then select Edit.

You can also open a template by double-clicking it.

Template Name

Description

Availability

Default Job Notification

Delegate

Forgot Hint

Sends an e-mail notification when an availability
setting has been created or modified.

Sends an e-mail notification to report results of
the job as configured in the template. Contains
the name of a job and any status information
from the job.

Sends an e-mail notification when a a delegate
assignment has been created or modified

Sends an e-mail notification when a user forgets
a password and requests a hint.
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Template Name Description

Forgot Password Sends an e-mail notification when a user
incorrectly enters a password.

Password Reset Fail Sends an e-mail notification when a user tries to
reset a password but doesn’'t meet password
policy requirements.

Password Sync Fail Sends an e-mail notification when a user’s
password fails to synchronize.

Provisioning Approval Completed Notification Sends an e-mail notification when a workflow is
completed. Indicates the overall workflow and
provisioning decision.

Provisioning Notification Sends an e-mail naotification to a user or
manager approval. Indicates that action is
required from the user or manager.

Provisioning Reminder Sends an e-mail notification when a user activity
timeout expires. Reminds the user or manager to
act.

Proxy Sends an e-mail notification when a proxy

assignment has been created or modified.

14.2 Editing a Notification Template

1 Select an Identity Vault.
2 In the Outline view, right-click a template (for example, Forgot Hinf), then select Edit.

3 Select a format, specify a subject, add tokens, customize the message that users receive, then
save and close the template.

+ “Selecting a Format” on page 252

+ “Specifying a Subject” on page 252

+ “Working with Tokens” on page 253

+ “Editing a Template Message” on page 254
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15| Stjarna - Developer

E-mail Template Editor

E:_i Fargot Hint.Default Motification Collection. Identity Yault 1

E-mail Content

()

<body BGCOLOR="#FFFFFF">
<p=>Dear §UserFullllames, </ p>

hint iz given helow:</p>
<prHint: §Hintd</p>
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<p> — hutomated Security</p>
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Send s @ HTML O Text Tokens:
. $lserFullMamed Mew..,
Subject: $Hink$
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| Wour password hink regquest
Insert |
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<head:> it
<title>Tour password hint request</titlesx
“styles
<!=— hody { font-family: Trebuchet M3 } -->
<fstyle>
</ head:>

<p>¥ou have regquested that your password hint he emailed to you.

<p=If wou did not request that your hint be emailed to wyou,

<& href="mailto:help.desklmycompany.com™>help.desklmycompany . com</ ax

<imgy ALT="Powered by MNowvell" ZRC="cid:powered by novell.gif" heighto=rzor
=) ¥ r L by =) o

The password

please contact the

Wil
| 3

<]

| ]

E,:f,_ E-mail Template Editor

Selecting a Format

Select whether users receive this e-mail notification in HTML or text format.

Figure 14-1 Options for Sending the Notification

Specifying a Subject

The subject is the text that a user views in an e-mail’s Subject headline or field. You can change the
text in the Subject field. You can also use tokens here. The text or tokens don’t determine the name

of the template.
Figure 14-2 The Subject Field

Subjeck:

| Your password hink request
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Working with Tokens

A token is a variable or replacement tag for items such as the user’s name. Tokens help you
personalize the message to the user.

Figure 14-3 The Tokens Dialog Box

Tokens:

fUserFulMarmes Mew. ..
$HinkS

Rermaove

fl

Inserk

Each template includes default tokens. For example, the Forgot Password e-mail template for
sending a password to the user includes the default replacement tag named $CurrentPasswords$.

You can define other tokens for use in the body of the message or in the subject. Your ability to do so
depends on the application that uses the templates. To find out how to define additional replacement
tags, see the documentation for the application. For example, Identity Manager Password
Synchronization can’t use a replacement tag that you create unless the policy in the driver
configuration that uses the template also contains the definition of the replacement tag.

Adding a Token

1 Click New.

Create a Replacement Tag

Add a Replacement Tag
Enter the token name and value For the token,

Marne: | |

Description: |

[0]4 I Cancel

2 In the Create a Replacement Tag dialog box, type a name for the token.
You don’t need to type the $ characters. Designer provides them.

3 Type a description for the token.

4 Click OK.

When you add a token, the tag is automatically added to the XML source for the template. After you
add a tag, you can edit it only in the XML Source view.

Removing a Token
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To delete a token, select it, then click Remove.

Make sure that you don’t remove tags that are needed for the body of the message.

Inserting a Token

1 In the template, click where you want to insert a token.
2 Select a token.
3 Click Insert.

Designer inserts the selected token into the e-mail template.

Editing a Template Message

The text of the e-mail message appears in the Message field. Customize the text so that it suits your
environment. Use tokens to personalize the e-mail message.

Figure 14-4 The Message Edit Box

| 7 B | S &1 [ T | |

itlexYour password hint requhst<ititle>
cylex
<!=—= hody { font-family: Trebuchet M3 } -->
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>
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i
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i
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>You have regquested that your password hint be emailed to you. The password -
: H

Al [+

£ E-Mail Template Editur]

1 In the E-Mail Template Editor, place your cursor in the Message edit box, then press
Ctrl+Spacebar.

2 Select an HTML tag by double-clicking a tag from the drop-down list.

<p>Dear §UserFul lNamed, </p>

<3 a [|& link iF the href attribute is present, and the target For a link if
B the name attribute is present
abbr ==

< > acronym
< raddress
< » applet
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< »basefonk
< »bdo

< »bgsound ll

3 Format text by using the toolbar.
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4 Preview the text by clicking the Preview icon L2,
5 Save the template by selecting File > Save.
You can also click the Save icon.

If the code isn’t valid, you can’t save the template.

14.3 Adding a Notification Template

1 Select an Identity Vault in the Modeler.
2 In the Outline view, scroll to Default Notification Collection for that Identity Vault.
3 Right-click, then select New Template.

E-Mail Templates

Add a Notification Template
Enter the template name.

Marne: |

[¥ ©pen the editar after creating a kemplate

0K I Cancel

4 Name the template.

5 Ifyou want to automatically open the template editor so that you can view or edit the template,
select Open the editor after creating a template.

6 Click OK.

7 Customize the text by editing the template message.

Importing a Notification Template
To import a notification template from a file:

1 In the Outline view, scroll to Default Notification Collection for an Identity Vault.
2 Right-click, then select Import Template from File.
3 Browse to and select the template.

4 Customize the text for your environment by editing the template message.
To import a notification template as a live operation:

1 In the Outline view, scroll to Default Notification Collection for an Identity Vault.
2 Right-click, then select Live > Import.
3 Specify the host name (IP address).
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4 To authenticate, specify the user name and password.
5 Browse to and select the template, then click OK > Continue > Import.

6 Customize the text for your environment by editing the template message.

Deploying a Template
After you add or import a template, deploy it.

1 Customize the text for your environment by editing the template message.
2 Right-click the template.
3 Select Live > Deploy.

14.4 Policy Builder and Notification Templates

For information on using the Policy Builder interface to send e-mail notifications, see “Send Email”
and “Send Email from Template” in the Policies in Designer 2.1 guide.

14.5 Configuring the E-Mail Server

The e-mail server sends notification e-mails from applications that use the Notification
Configuration templates.
1 Select an Identity Vault in the Modeler.
2 In the Outline view, scroll to Default Notification Collection for that Identity Vault.
3 Right-click, then select Properties.
4 Specify the host name, From, and authentication settings for your SMTP e-mail server.
Host Name: The host name of your SMTP e-mail server. This can also be an IP address.

From: When a user opens the e-mail, the text that you enter in the From edit box is displayed
in the From field of the user’s e-mail header. Depending on your mail server settings, the text in
this field might need to match a valid sender in the system (for example,
helpdesk@company.com instead of descriptive text such as The Password Administrator).
Such a match allows the mail server to do reverse lookups or authentication.

Authenticate to the server by using credentials: Use for a secured SMTP server.

If your server requires authentication before sending e-mail, specify the username and
password here.

Although the authentication information is specified here, you might also need to specify it
separately for the application that is sending the notification e-mails.

For example, Forgotten Password e-mail notifications can be sent by using the authentication
information you specify here. However, notification e-mails for Identity Manager Password
Synchronization require the authentication information to be provided in the driver policy that
is used to send notification e-mails.

5 Click OK.
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Importing into Designer

Designer’s Import feature allows you to import the following items into defined projects:

¢ Projects from the File System or from the Identity Vault (eDirectory™)

* Driver sets

*

Individual drivers

*

Channels

+ Policies

¢ Schema
Depending on a project’s complexity, importing can save you time in building and rebuilding
drivers, channels, and policies. For instance, after a driver, channel, or policy is built, you can import

it into new projects and modify it to run in the new environment instead of starting from scratch on
each new driver, channel, or policy.

You import projects, drivers, channels, schema, and policies from an existing eDirectory tree
running the Identity Manager system (Identity Vault) or from an exported project located in the file
system. In Designer, use the Deploy feature to save drivers, channels, and policies into a
Metadirectory server in an Identity Vault. Use the Export feature to save project, drivers, channels,
and policies to a local, removable, or network directory.

What you can import depends on the level you are at within a project. For instance, at the File >
Import level, you can import a project from the file system or from an Identity Vault. At the project
level, you can import driver sets, drivers, channels and policies; at the driver level, you can import
channels and policies, and at the channel level, you can import policies.

During import, Designer does not import anything that is encrypted. This includes named
passwords, e-mail notifications, existing certificates, and the Secure Login administrator password.
¢ Section 15.1, “Importing Projects,” on page 257
¢ Section 15.2, “Importing a Driver Set or Driver from the Identity Vault,” on page 266
¢ Section 15.3, “Importing a Driver Configuration File,” on page 275

¢ Section 15.4, “Importing Channels, Policies, and Schema Items from the Identity Vault,” on
page 281

¢ Section 15.5, “Using the Compare Feature When Importing,” on page 291

¢ Section 15.6, “Error Messages and Solutions,” on page 298

15.1 Importing Projects

Designer’s Import feature allows you to import projects from the File System or from an Identity
Vault (eDirectory). What you are able to import depends on the level you are at within a project. To
import an eDirectory object, you must have sufficient rights to access the eDirectory tree that is
associated with the Identity Vault you are designing.

When you initially open the Designer utility and close the Welcome view, you have no projects that
are currently available:
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Figure 15-1 Initial No Projects Available View

No Projects Available @

There are currently no Designer projects 1o list, You
can create new projects by clicking on the links
below.

B pewe Identity Manager Project
L5 Import Project From Identity Yault

Impart Project From iManager Export File
% Existing Project From File System

For information on creating a new project, see Chapter 6, “Creating a Project,” on page 49. For
information on importing projects, see the following sections:

¢ Section 15.1.1, “Importing a Project from the Identity Vault,” on page 258
¢ Section 15.1.2, “Importing a Project from the File System,” on page 262

¢ Section 15.1.3, “Importing a Project from iManager,” on page 264

15.1.1 Importing a Project from the Identity Vault

1 In Designer, click File > Import.
or
Click Import Project From Identity Vault from the No Projects Available page in the Projects

view, then skip to Step 3.

2 From the Import window, select Identity Manager Project (From Identity Vault) under the
Designer for Identity Manager heading. Click Next.

Select
N |
Import an existing Identity Manager project from an Identity Vault, I E 5 i

Select an import source:

| type filker text |

K% Project (From File System)

Project (Fram Identity %ault)
Project (From iManager Export File)

@ Next > Cancel
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The Import window allows selections under a number of tabs, including Designer for Identity

Manager. Selections under the Designer for Identity Manager tab include:

+ Importing an existing Identity Manager project from the file system (the project must have

avalid .project file).

+ Importing an existing Identity Manager project from an Identity Vault.

+ Importing an existing Identity Manager project from an iManager export file (Driver Set

or Driver).

3 In the Project (From Identity Vault) window, give the new project a name. Select where the

contents of this project are to reside (for Windows workstations, the default is
C:\Documents and Settings\Username\workspace). Click Next.

@ Project (From Identity Vault) &)

Give Project Name And Location @

Give this project a name and choose a location, A

Project Mame: | Blanston |

Project Cortents
Uz Default

’ < Back ” MNext = l

Cancel

4 In the Import Project From Identity Vault window, specify the information needed to
authenticate to the Identity Vault (eDirectory) of your choosing. In the Host Name field, you

can use either a tree name or the IP address of the Identity Vault.

@ Project (From the Identity Vault) [x]

Enter Authentication Information @

Enter information to authenticate to the Identity Vault of vour choice. 4
Host name: | 123.123.1,23 v ®
Lizer name: |admin.blansmn v| @

Passwiord: | ssssas |

Csave password

7 [ < Back ” Mext > l

Cancel

5 Fill in the User Name and the Password fields.
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If you select Save Password, Designer remembers your password. Otherwise, the next time you
close Designer, you need to re-authenticate when you import, deploy, or compare Designer
objects with the Identity Vault.
You can use history drop-down lists to choose a previously entered value from a list.

6 Click Next.

7 In the Import Project From Identity Vault window, type the Distinguished Name of the driver

set or driver you want to import, or click the Browse button to select the object within
eDirectory. Click OK, then click Finish.

2 )

Import Project From Identity Vault @

Add Driver Sets or Drivers to the import list by clicking on the
Browse button and selecting them from the Identity VWault,

Ohijects o Import:

@ Browse Identity Vault %)
File
Select an object:
=2 IOMYAULT & Active Directary
= &3y Movell © Active Directory2
8 Extend & Active Directorys
+-718 South & Delimited Text
+-78 Tomcat-Roles &/ DSML S0P
+713 Users & eDirectory Driver
+- 78 Virtualoffice & Groupiiisel
+-45 Novell+hetiwlare 6 & ‘})LD”“P
+- €2 spache Group ‘})mebaCk
+-k apchadmn-Registry @ test
+- 6 Roots
[ Security
+- &% Logging Services
4 EA) 8 >
(a4 | Cancel |
Driver Set.Movell

You can import multiple driver sets during the import operation. Just browse to the various
objects that you want to import and add them to the list.

Driver sets that are not associated with a server have a red minus sign in the lower right portion
of the driver set icon. These driver sets need a server association in order to be deployed.

(Conditional) If you are importing more than one eDirectory driver, select the eDirectory driver
in the Objects to Import window and click the eDir-to-eDir button to display the Connect to

Identity Vault window, where you can import the associated driver in the other eDirectory trees.
Novell® recommends that you import both eDirectory drivers, especially if you have SSL/TLS
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enabled. Provide the user name and password, then click Continue. (Skip this step if you only
want to import one eDirectory driver.)

@ Connect to Identity Vault &

_?yn Provide the credentials to the Identity VYault that contains the associated
eDirectory driver for driver 'eDirectory Driver to madeans'.

Host Mame: | 192.158.14.199 v| @
User Marne: | admin.blanston v| ®
Password: | R |

[O5ave password

[ Continue H Cancel l

9 (Conditional.) If you specify the user name and password and select Continue to import both
eDirectory drivers, you then see a Browse Identity Vault window where you select the
corresponding eDirectory driver. Select the driver and click Finish.

@ Project (From the Identity Vault) [
Import Project from Identity Vault @
Add driver sets to the impart list by clicking the Browse button and selecting them from the Identity Yault. P

Cbjects to Impoart:

=-[E]64 mydriverset.navell.MADEAN2_TREE, Browse...

7% #ctive Directory
[ Delimited Text
[ Delimited Text OO
eDirectory Driver to madeans
G} Password Sync Status Reflector
@& User Application
ﬁ) Userspplication

o AADEANS_TREEE.

eDirectory Driver to madean2

@ I Einish l [ Cancel ]

You are returned to the Project (From Identity Vault) window, where you can select or deselect
the drivers, allowing you to choose only the drivers in a driver set that you want to import.
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10 Click Finish. By having both drivers available, you can view the complete data flow between
the two eDirectory drivers, as well as the other drivers you selected.

El ©m_TREE El Blanston Inc,

Text

Delimited

15.1.2 Importing a Project from the File System
1 In Designer, click File > Import.
or

Click Existing Project From File System from the No Projects Available page in the Project’s
view, then skip to Step 3.

262 Designer 2.1 for Identity Manager 3.5.1



2 From the Import window, select Designer for Identity Manager > Project (From File System),

then click Next.

Select
N\

Import an existing Identity Manager project from the file system. ﬁ - 5 i

This project must have a valid .project file.

Select an import source:

| type filter text |

]
57 Project (From Identity Yault)
Project (From iManager Export File)

@ < Back

Cancel

3 Type the project name or browse to the directory where the project was saved.

@ Project [From File System)

Import Existing Projects

Choose & project folder that contains one or maore valid .project files,

®)

33

V|

(¥ Select root directary: | Chypocuments and SettingsiNovell Useryworksg | ’aruwse... l

(O select archive file: |

| Browse...
Projects:
E=gE | Select All
Deselect All
[¥] Copy project into the workspace
@ Mext = [ Finish l ’ Cancel ]

4 Select the directory where the exported project is saved with the Project extension.
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There must also be a valid Project file in the selected directory, or the project does not display
in the Projects window. If you have multiple projects you want to import and they are under the
same directory, select the directory above the projects and Click OK. In the Projects window,
you can select or deselect any of the projects, then click Finish.

5 Make sure the Copy Project into Workspace option is selected to copy the contents of the
project into the workstation’s local workspace.

Earlier versions of Designer did not copy the contents into the workspace, but pointed to the
location where the project was imported. Any changes made to the project were saved to the
imported location and not to the local workspace, which caused some confusion because all
other imports were copied into the local workspace.

You can also use the Import Project from File System feature to import a project from another
workspace.

You can also import multiple projects at the same time by entering the base or root directory
where you want to start your search. The Import Wizard searches the selected directory and all
of its subdirectories for valid Designer projects to import. You can then select the projects that
you want to import into Designer by using the check boxes. If a project by the same name
already exists in Designer, you can’t import that project and you won’t be able to select it from
the list.

6 You can also import projects from ZIP or TAR archives. Click the Select archive file selection
and select the directory where the exported project is saved with the .zip or .tar extension.
The whole archive is searched for valid Designer projects to import.

15.1.3 Importing a Project from iManager

You can create a new Designer Project by selecting an iManager .xm1 export file. These include
driver set and driver exports as well as Novell sample configuration files.

1 Click File > Import > Designer for Identity Manager > Project (From iManager Export File).

or
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Click Project (From iManager Export File) from the No Projects Available view, then skip to

Step 3.

@ Import &)

Select

{driver set or driver),

Select an import source:

Irport an existing Identity Manager project from an iManager expart file | g 4 ﬁ I

N,

| type filter text

2 Project (From File System)
45 Project (From Identity Vault)

2 Type a project name. Use the default workspace directory for the project, or type or browse
to the directory where you want to import the project. Click Next.

% Project (From iManager Export File)

Choose File

Choose an iManager export file to import.

33

4

File: |

| |Browse. .

Look ir; | |j':‘| My Documents

‘____ () Adobe
{ E; () Cybetlink

MyFecent  [Cidfiles
Documents @My Tusic
= @My Pickures
|__ @My ‘ideos

Desktop (Dmyfiles

(@ Ackive Directory2,xml

(@ Active Direckory, sl

@] Active Directory_Publisher 062606, xml
My Documents 9% Active Direckory_Publisher, xml

@) (@ AD02-0306,xml

| | @ aD0z_Publisher . xml

i Blanston_xfer_to_IDM.xml

i@ Delimited Text. xml

-

My Computer

@ DriverSet,xml

i eirectary Driver to Blanston Inc.xml
.’3'._" Event Transform.xml

3: IDMDriver3et,xml

3] IDBC 2 xml

@ Manage Modify sl

@ mydriverset, xml

i@ SchemaMapping, =ml

@ template.xml

File: narne; |Driver Set.uml

vl Coen ]

Files of type:

by Metwork * xl

“ | [ Cancel J
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3 Select the directory where the exported project is saved with the .xm1 extension, click Open,
then click Finish.

4 When importing a driver set or driver into a project, you are asked if you want to validate the
values within the drivers you are importing. If you do not want to validate the driver
configuration at this time, click No.

Otherwise, click Yes and continue importing the project.

You can only import the driver functionality that you saved to the .xm1 file. This file does not
contain default driver configurations unless that is what you have saved.

5 Fill out the information requested in all of the Import Information Requested windows that you
see for each driver in the driver set, or for each driver selected. The Import Information
Requested windows contain different driver information from each selected driver. Click Next
or Finish (depending on the number of pages presented).

6 Click OK to close the Import Configuration Results window.

15.2 Importing a Driver Set or Driver from the
Identity Vault

To import an eDirectory object, you must have access to the eDirectory tree that is associated with
the Identity Vault.

+ Section 15.2.1, “Associating a Server to the Identity Vault,” on page 266
¢ Section 15.2.2, “Importing a Driver Set from the Identity Vault,” on page 268
¢ Section 15.2.3, “Importing a Driver from the Identity Vault,” on page 273

15.2.1 Associating a Server to the Identity Vault

When you add a new Identity Vault to a project, you see the Add Server Association window, where
you can accept the default server, specify a server, or browse to a server. The import and deploy
features use the server association for later identification. To do this:

1 In the Modeler view, drag an Identity Vault icon from the Palette to the Modeler view to bring
up the Add Server Association window.

@ Add Server Association 3]

Specify Server for Identity Yault —

Take the default, specify, or browse to a server, =

Server DN: | server.context 2

Identity Manager Yersion: |3.5,1

For version information or to change the default, click here

Ok l I Cancel
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Type the server’s DN context in the Server DN field, or click Browse.

2 TIfyou select Browse, fill in the appropriate host name, user name, and password at the
Credentials to Identity Vault window. Click OK.

|dentity Vault Credentials

Host Marne: | 1592,168.14,199 v| @
User Marme: | admin.blanston v| ®
Password: | sssens |

[5ave password

[ oK l l Cancel l

3 At the Browse for Server Object window, select the server you want to associate with this
driver set and click OK.

4 At the Add Server Association window, you also see the Identity Manager version displayed.
This is important when importing and exporting driver sets and drivers, as you must match
driver sets and drivers to the correct Identity Manager version. Click the For version
information or to change the default, click here entry for more information.

5 Click OK to close the Add Server Association window and add an Identity Vault to your
Modeler view.
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15.2.2 Importing a Driver Set from the Identity Vault

To import an Identity Manager Driver Set object (and all contained drivers) into an Identity Vault
object in the Modeler view:

1 Right-click the Identity Vault in the Modeler view, then click Live > Import.

==s Straighten Connections
{1 Select Connected Applications

Distribute *
align

@ Change to eDirectory Tree
Change to Identity Yault / Meta-Directory
i Add to Group

§& Manage Yault Schema...

Document selection...

7, Import Schema from File. .,

Export to File 4
E-rnail Templates

& Import...

& Deploy...
5%, Compare...

¥ Delete

Properties
Schema 4

@] Open iManager...
4% Browsa Identity Vault. .

@ Driver Status...
@ StartDrivers
© Stop Drivers
@ Restart Drivers

2 (Conditional) If the Driver Set that comes with the Identity Vault creation is empty, you are
asked if you want to remove the default Driver Set icon from the selected Identity Vault. Click
Yes.

3 (Conditional) If you filled out the authentication information when you initially created an
Identity Vault icon in the Modeler view, go to the Properties view under the Project view.
Specify authentication credentials for the selected Identity Vault, then skip to Step 5.

4 (Conditional) If you have not yet provided authentication information, specify it now. In the
Identity Vault Credentials window, fill in the host name, the user name and password
information, then click OK.

Use the drop-down lists if they apply to your connection and user information. The Save
Password option allows Designer to keep password information for future connections to this
Identity Vault. Otherwise, you will see the Identity Vault Credentials window the next time you
open Designer.
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5 In the Import from Identity Vault window, browse to the driver set by clicking the Browse
button.

Om #f ] 1T
m IdEnLLy |

Import objects into an Identity Vault @
Select the objects to impart from eDirectory,
@ Browse |dentity Vault &)

File

Select an object: owse. .,
| — EMove
-y novell il ™

=78 Tomcat-Role

#-78 virtualoffice

-4 Nowel+Mety
=62 spache Grou
€2 apchadmn-Ri
€7 OpenSSH Se
=8 ) rrydriverset

-4 paople

=] EI Security

- 2 by
. 58 | cnninn Sarvicac |

L] |

o

CK ” Cancel ]

CH=rydriverset. O=novell

2] [ Continue H Cancel ]

6 Select the driver set you want to import, click OK to place the driver set in the Objects to
Import list in the Import Driver Set from eDirectory window. You can then deselect the drivers
you do not want to import by deselecting the box next to the driver name. If you chose the
wrong driver set, select the driver set and click Remove. Otherwise, click Continue.

You can import multiple driver sets during the import operation. Just browse to the various
objects that you want to import and add them to the Objects to Import list.

Driver sets that are not associated with a server have a red minus in the lower right portion of
the driver set icon. These driver sets need a server association in order to be deployed. An error
displays if the application can’t authenticate to the eDirectory tree you have selected.

7 (Conditional) If you are importing one or more eDirectory drivers, select the eDirectory driver
in the Objects to Import window, then click the eDir-to-eDir button.
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8 (Conditional.) If you fill out the user name and password and click Continue to import both
eDirectory drivers, you then see a Browse Identity Vault window where you select the
corresponding eDirectory driver. Select the driver and click OK.

@ Import from Identity Vault ®
Import objects into an Identity Yault .
Select the objects to import from eDirectory,

Ohbjects to Import:

[l MapDriver A Browse. .,

¥l Reforiver

e Ti-References

v Tz-References
=] DE mydriverset.novell. MADEANZ _TREE.

e/ Active Directory

7]’ Delimited Text

[ Delimited Text OO

& eDirectary Driver to 102

EI eDirectory Driver to madeanS

[l Sereric Loopback =

e/ Password Sync Status Reflector

[ User application »

(@) The selected eDirectory driver is not associated with another
eDirectory driver,

@ [ Continue H Cancel ]

You are returned to the Import Driver Sets from eDirectory window, where you can select or
deselect the drivers, allowing you to choose only the drivers in a driver set that you want to
import.

9 Click Continue. This brings up the Import Summary window, where you can see all of the
Driver Set objects that are being imported into Designer. This summary uses the same format
as the Compare window (see Section 15.5, “Using the Compare Feature When Importing,” on
page 291 for further information). Click Import to continue.
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10 (Optional) As the import operation progresses, you are asked to associate a server with the
Identity Vault. Select the option that best suits your needs.

@ Add Server to Identity Vault 1 3]

? ‘ou need to associate a server with "Identity Yault 1"
in order to deplay, How do you want to do that?

®isllow default server to be created:

(O Specify a server

O Don't create a server now

[lremember selection - don't prompt again

[ Ok l ’ Cancel ]

+ Allow default server to be created. Creates a dummy server with global configuration
values and other elements that are associated with this project until you specify an actual
server for the project. You must make sure you have designated a correct Identity Vault
server when you deploy the driver set.

+ Specify a server. Brings up the credentials screen, allowing you to designate a host server,
a user name, and password for the Identity Vault server for this project.

+ Don’t create a server now. Skips all associations for this project. You need to fill in the
host information before you deploy this driver set.

¢+ Remember selection--don’t prompt again. Continues to use whatever server option you
chose the next time Designer needs to associate a server with an Identity Vault.

11 After you decide your plan of action and select the option you want, click OK to continue the
import procedure.
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12 Click Finish. If you select Step 7 to connect eDirectory drivers, you can view the complete data
flow between the two eDirectory drivers, as well as the other drivers you selected.

El ©m_TREE El Blanston Inc,

Text s Text
Il pelimited Text A — Delimited Tex

'd Sync Reflector

13 When the driver set imports, you see the Import Results window showing you if there were any
problems with the import procedure.

@ Import Results &)
Operation Results: = | El

------ @) DriverSet,South.Novell

Details:
o Information
Description: The import of DriverSet.South.Novell was successful,

Errors during the import procedure are displayed with a red icon, and you see an Error
description that is related to the operation results. If you have multiple errors, selecting an error
displays the error’s description in the Details > Description field. See “Error Messages and
Solutions” on page 498 for further information.

14 Click OK to finish the import process.
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15.2.3 Importing a Driver from the Identity Vault

To import an Identity Manager Driver object (and all contained channels and policies) into a driver

set:

1 Select an Identity Vault in the Modeler. If you add a new Identity Vault to a project, see

Section 15.2.1, “Associating a Server to the Identity Vault,” on page 266.

2 Verify that the authentication credentials in the Properties view for the Identity Vault are

correct.

3 Right-click a DriverSet object within the Identity Vault, then select Live > Import.

El Blanston Inc.

Copy

waa Straighten Connections
{73 Select Connected Applications

Arrange Applications 4
Digtribute L4
Aligr L4

Document selection...
Irnpart fram File...
Export to Configuration File...

¥ Delete

Properties

eploy...
5 Compare...

Driver Set Configuration ¥

@ Criver Status...
D Start Drivers
© Stop Drivers
@ Restart Drivers

4 (Conditional) If the Identity Vault is not authenticated to the eDirectory tree, you see the
Identity Vault Credentials window asking for the host name, user name and password. Provide

the information, then click Next.
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5 In the Import Drivers from eDirectory window, click Browse to select a Driver object from the
eDirectory tree.

E Import from ldentity Vault
Import objects into a Driver Set @
Select the objects to impart from eDirectory,

Objects to Import:

| Browse,,, i)

@ Browse Identity Vault
File

Select an object:

. =8 Driver Set ol Y
w g Active Direct || &
& &g/ Driver E=2
i g/ Driver 2 =
&g/ eDirectory O —fl
E‘: ‘I-’ Grouphiise g

@) SAP-USER
g Userapplicat
&l Driver Set jj

& DriverSet

&1 IDM Driver Set &

@ T— i

oK ” Cancel J

B
|:+3
[+

1]
|

CH=GroupWise, CN=Driver Set.O=Novell

6 Click OK to place the driver in the Import from eDirectory window, then click Continue to
display the Import Summary window, where you can see all of the Driver objects that are being
imported into Designer.

This summary uses the same format as the Compare window; however, because you are
importing the object, you cannot use the Reconcile Action options (see Section 15.5, “Using the
Compare Feature When Importing,” on page 291 for further information).

An error displays if the application can’t authenticate to the eDirectory tree you have selected.

7 Click Import to continue.
8 In the Import Results window, click OK if the import worked as planned.

If it does not, you see an Error description that is related to the operation results. If you have
multiple errors, selecting an error displays the error’s description in the Details > Description
field. See “Error Messages and Solutions” on page 498.

9 (Conditional) If you are importing one or more eDirectory drivers, select the eDirectory driver
in the Objects to Import window and click the eDir-fo-eDir button. Fill out the user name and
password for the other eDirectory tree and select Continue to import both eDirectory drivers.

10 In the Browse Identity Vault window, select the corresponding eDirectory driver, then select the
driver and click OK. You are returned to the Import Drivers from eDirectory window.

11 When the driver imports, you see the Import Results window showing you if there were any
problems with the import procedure.

Errors during the import procedure are displayed with a red icon, and you see an Error
description that is related to the operation results. If you have multiple errors, selecting an error
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displays the error’s description in the Details > Description field. See “Error Messages and
Solutions” on page 498 for further information.

12 Click OK to finish the import process.

15.3 Importing a Driver Configuration File

You can import an Identity Manager driver configuration file into the selected driver set for a project
by using the Import from File option, which imports an XML configuration file that can be a driver
set, an individual driver, driver channels, or policies. If you import a driver configuration file that
contains only a policy, Designer creates the framework for parent containment objects, such as a
channel, a driver, or a driver set. Such parent containment objects do not contain attributes; they are
only the framework of the channel, driver, or driver set from where the policy came.

These configuration files are in XML format, which you can save to a local, removable, or network
directory through the Export to Configuration File option. After you select the driver configuration
file to import, you are prompted to provide driver-specific information for setting up the driver and
building policies. The exported .xm1 files are compatible with those used by the iManager driver
configuration file plug-ins for Identity Manager 2.0.2 and later. This allows you to export
configuration files from Designer and import those files through iManager or through Designer’s
Import feature.

You can also use the Import from File option as a backup method. For example, if you are working
on a group of policies in an Active Directory* driver, you can use the Export to Configuration File to
back up your work, adding dates to the exported files so you can select a particular driver
configuration that you want to use as the basis for your Active Directory driver. If something goes
wrong, you can re-import the base driver. You can also use this export/import feature to export and
import just the policies you are working on.

You can import a configuration from a file in three ways:

¢ Section 15.3.1, “Importing an Identity Manager Project from the File System,” on page 275

¢ Section 15.3.2, “Importing a Driver Configuration from a File in the Modeler View,” on
page 275

¢ Section 15.3.3, “Importing from a File through the Outline View,” on page 278

15.3.1 Importing an Identity Manager Project from the File
System

The Import an Identity Manager Project from File System option allows you to import an Identity
Manager project that has been saved to the file system through the Export > File System option. The
project must have a valid .project file and accompanying file structure for the project to
completely import. This topic is covered under Section 15.1.2, “Importing a Project from the File
System,” on page 262.

15.3.2 Importing a Driver Configuration from a File in the
Modeler View
A driver configuration file can contain one or more driver configurations. You can import a

previously exported configuration file or one of the sample .xm1 driver configurations that are
included with Designer.
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To import a configuration file containing one or more Identity Manager driver configurations into a
driver set:

1 Select an Identity Vault in the Modeler view.
2 Right-click a DriverSet object within the Identity Vault, then click Import from File.

=== Sfraighten Connections

{71 Select Connected Applications
Arrange Applications
Distribute
Align

Docurment selection...

Live
¥ Delete

Properties

3 In the Import a Driver Configuration File window, type the name of the configuration file, or
browse to and select the .xm1 file.

If you use the Browse feature, by default Designer takes you to the C: \Program
Files\Novell\Designer\eclipse\plugins\com.novell.designer.idm 2
.0.0.x\defs\driver configs directory where the Identity Manager driver templates
that come with Designer are stored on Windows workstations. On Linux workstations, the
default drivers are stored in the
C:\home\username\designer\eclipse\plugins\com.novell.designer.i
dm 2.0.0.x\defs\driver configs directory. (The “x” after the idm_2.0.0 number
refers to Designer build numbers) You can use one of these driver files or you can browse to a
directory containing an exported configuration file.
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4 Complete the import by filling out the Import Information Requested forms for the driver

configuration file.

@ Import Information Requested

\_?/ The driver writer requested that the Following information be supplied in order to import this driver configuration file.

Information requested; * Required

The name of the driver contained in the driver configuration file is "eDirectory Driver". Enter the actual name wou want to use For the driver,

Criver name: *

eDirectory Driver| g?

Enter the DMS host name or IP address, and communication port of the DirsML server in the remote tree. For example:
[151.155.144.23:5196]
[hostname:§196]

Remote Tree Address and Port: *

| hostriame 8196

Data flow can be configured at this time For the driver. Select the data flow that wou desire, Bi-directional means that both eDirectory trees are
authoritative sources of the data synchronized between them, Authoritative means that the local tree will be the authoritative source.
Subordinate means that the local tree is NOT an authoritatve source,

Configure Data Flow:

Bi-directional -+

Choose the desired form of placement. Choose Mirrored to synchronize objects hierarchically between the local and remote trees, Choose Flat
to synchronize all Users and Groups inta specific containers, Choose Department to synchronize Users and Groups by department (OU).

Configuration Option:

Wiy s -

OF | Cancel

£y

W

3

The form varies, depending on the driver configuration file selected. Saved files might only
prompt for a driver name. You might have imported a single driver or a collection of drivers (a
driver set). If you are importing a driver set, fill out an Import Information Requested template

for each imported driver.

If you fail to provide the information requested in the Import Wizard page, your driver
configuration is incomplete, and the exported driver is also incomplete. Do not use the

Configuration Wizard on the driver configuration file that you exported. The wizard brings up
the Import Information Requested forms, but these forms are pulled from the default driver file

and overwrite the driver file you exported.

5 Click OK, then click OK in the Import Configuration Results window.
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15.3.3 Importing from a File through the Outline View

You can use the Outline View to import driver sets, drivers, channels, and policy configuration files
from the file system. The following example demonstrates how to import a driver, but the procedure
also works for the other files.

1 Double-click the System Model icon under a project name in the Project view. This brings up
the project model in the Modeler view.

2 Click the Qutline tab.
3 Right-click the Driver Set object and select Import from File.

Project Mavigator =

8
B IEEES
M

= &2l Blanston2
= Blanston Inc.

fl momTEST
o Ry
W= »
Copry 4

Document selection..,
B Import from File...

Export to Configuration File...
Live »
¥ Delete

Froperties
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4 TIn the Import a Driver Configuration File window, type the name of the configuration file, or

browse to and select the .xm1 file.

% Import a Driver Configuration File

HE-ru:uwse... J

Look in: | [B My Documents

V| .J:?’;."v

. _E ) 4dobe
4 I Cyberlink
My Recent | hidfiles
1 Documents I_E%-IMV MLsic
s @M‘y’ Pickures
|_. @Mv Yideos
Dieskiop myfiles
I)5eafang

Ackive DirectoryZ, xm
| Active Directory,xml

ive Directory_Publisher
Active Directory_Publisher, xml
[29 Ap02-0308. 5l
ADOZ_Publisher  xml
Blanston_xFer_ka_IDM, xml

.

by D ocuments

€

ty Computer

2] Delimited Text.xml

2] Drivver Set,xml

2] DriverSet, xml

@ eDirectory Driver to Blanston Inc,:xml
2 Event Transformm.:ml

@ IDMDriverSet, xml

] IDBC 2. xml

@ Manage Modify,xml

@ mydriverset,xm

@ scheratapping. xml

@ kernplate, xml

File name:

|f-\c:live Directony_PublizherDB2606. xml

A | [ Open

1

by Metwork Files of type:

*uml

W | [ Cancel ]

Then a driver is exported, Designer uses the name of the driver set or driver object, to which
you can add dates. In this example, it is an Active Directory driver that was exported June 26th

and is now being imported.

5 Click Open, then click OK to import the configuration file.

To import a policy into a driver set:

1 In the Outline view, click the Driver Set icon, then click Import from File.
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2 In the Import a Driver Configuration File window, type the name of the configuration file, or
browse to and select the .xm1 file.

@ Import a Driver Configuration File

Loak, in: | [ Projects w | €] 5 s FE

i [ Blanstonl ModelerOutlinestate. xml

i 23 L) Blanstanz mydriverset, xml
My Recent |3 Blanston3 P: rdiSub)-Pub Emnail Matifications . xn
Documents o) BLanskons

= Blanston2, fo,xml
|_ Blanston?2. source.none. xml
Desktop Blanstonz . source. primary . xml

Blanston2,source, style, xml
Driver Set, il

Entitlements Service Driver=ml
Exchange Yolker.xml

Input Transform, sl

&

by Documents

i LDAR i
E‘j}g LDAP_Publisher <l
: % Loopback. xml
4y Computer .
< | >
.% File name: |Password[5 ub]-Pub Email Matifications. sml w | I Open l
My Metwark Files of type: = xrl o | [ Cancel ]

3 Click Open, then click Save to import the selected policy.

Each policy is saved to its own .xm1 file. By default, Designer uses the name of the policy or
rule selected.

4 In the Perform Prompt Validation window, you are asked if you want to fill in required driver
information. If you answer Yes, you see the Import Information Requested dialog box as
described in Step 5 and you must provide values to all of the required fields. If you answer No,
you still see the Import Information Requested dialog box, but it isn’t necessary to fill in the
required information.

5 Complete the import by filling out the Import Information forms for the driver configuration
file as necessary. Policies are saved with a skeleton driver configuration structure, which
designates where the policy resides. In this case, the driver already existed and the imported
policy was initially written for that driver.

6 Click OK.
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7 When the policy or rule is imported, you see the Import Configuration Results window, which
indicates if there were any problems with the import procedure.

@ Import Configuration Results

COperation Results:
& Manage Modify.xml

Details:

0 Information

Description:

The file import of Manage Modify.xml was successful,

Errors during the import procedure are displayed with a red icon, and you see an Error
description that is related to the operation results. If you have multiple errors, selecting an error
displays the error’s description in the Details > Description field. See “Error Messages and
Solutions” on page 498 for further information.

8 Click OK to finish the import process and close the Import Configuration Results window.

15.4 Importing Channels, Policies, and Schema
Items from the Identity Vault

A channel is a combination of rules and policies, and Designer allows you to import a channel
instead of the entire driver. The Subscriber and Publisher channels describe the direction in which
the information flows. The Subscriber channel takes the event from the Identity Vault and sends that
event to whatever the receiving system is (application, database, CSV file, etc.) The Publisher
channel takes the event from the application, database, CSV file, etc., and sends that event to the
Identity Vault. The Subscriber and Publisher channels act independently; actions in one are not
affected by what happens in the other.

¢ Section 15.4.1, “Importing a Channel,” on page 282

¢ Section 15.4.2, “Importing a Policy,” on page 285

¢ Section 15.4.3, “Importing a Schema,” on page 288
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15.4.1 Importing a Channel

To import an Identity Manager channel (a Subscriber channel or a Publisher channel) object (and all
contained policies) into a driver:

1 Select either a Driver object or an Application object in the Modeler view. The Driver object is
represented by the line between the Identity Vault and the Application object and has a circle
icon to represent it ©. The Application object connects to the Identity Vault through the Driver
object.

2 Right-click a Driver object, then click Live > Import.
or

Right-click an Application object and click Driver > Import.

-

El 1oM_TREE El Blanston Inc.

{ g Simulate...
§i (B Show Policy Sets

EE] Run Configuration Wizard...

& Manage application Schema...

W <7 Undo Change Location

Document selection...

Distrbute R & Export to Configuration File...
istribu

o) Deploy...

[E3] Show Subsystems

Driver Configuration 4
i Add to Group

& Driver Status...

Show Dataflow Vi
7 Show Dattafiow View © Start Driver

@' Remote Control Desktop © Stop Driver
& Manage application Schema... @ Restart Driver
Document selection... & Set Up Driver Security...

Driver Properties
¥ Delete

Fropertes _
If Designer can’t authenticate to the eDirectory tree specified in the Identity Vault, you see the

Identity Vault Credentials window if you have not previously specified the authentication
credentials or if you do not save the password. Fill in the appropriate information and click OK.
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3 In the Import from Identity Vault window, browse to and select either a Publisher or a
Subscriber Channel object from the eDirectory tree under the corresponding driver.

3 Import from |dentity Vault [%|

Import objects into a Driver

Select the ohjects to import from eDirectory.

Obijects to Import:
@ Browse |dentity Vault 3

File

]

Select an object:

= &g Active Direct: &
- #-4%) Publisher
& Subscribe = InputTransform
w & Marv's Jot - = OutputTransform
, & Delimited Tes 2= Password(Pub-Sub Email Motifications
© Delimited TE}l_ = Password(Sub)-Fub Email MNotifications
=
g ) =& Schemalapping
G_J eDirectory Or || Hjjary's 1oh
# 4@ eDirectory Or
g/ Generic Loopl
- @ &) Password Sy ¥
< | >

[ o]4 H Cancel J

CH=Subscriber.Chl=Active Directory. CH=rnydriverset. O=novell cancel

You can import more than one channel at a time; if you want to import both channels, select
one channel, click OK, then browse to the next channel, select it, and click OK.

4 Click Continue.
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5 As the channel imports, you see the Import Summary window showing you the differences
between eDirectory (the source of the import) and Designer (the destination).

& Import Summary

Select an ohject or attribute: =
= & Subscriber Infarmation
S Atrbutes Compare Status: = Not Imported

(@ DirxML-EventTransformationRule
3 Manage Modify

[Vl only show differences

Text Compare

.+ Designer (Destinatior eDirectory (Source)

name="DirXHML-Entitl

[CJDon't show this dialag again

@ [ Import: H Cancel ]

You can click the different objects in the channel view differences between the two drivers. All
channel information is overwritten by the import procedure; however, the rest of the driver is
unaffected.

Click Import.
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For more information on Compare, see Section 15.5, “Using the Compare Feature When
Importing,” on page 291.

@ Import Results 3]

Operation Results: = | &L

&) Subscriber. Userapplication.Criver Set.Movell

Details:

0 Information

Description: The import of Subscriber UserApplication.Driver Set.Movell was
successful,

If there are any problems with the import procedure, they are displayed with a red icon in the
Import Results window and you see an error description that is related to the operation results.
If you have multiple errors, selecting an error displays the error’s description in the Details >
Description field. See “Identity Vault Configuration Errors” on page 499 for further
information.

6 Click OK to finish the import process.

15.4.2 Importing a Policy

A policy is a collection of rules and arguments that allows you to transform the data that an
application sends to and receives from eDirectory. You use policies to manipulate the data you
receive from eDirectory or from the connected system so they can synchronize the information in
their databases. Each driver connects to a different system, and policies tell the driver how to
synchronize the data on that connected system to the Identity Vault.

You might use the Import feature for policies more than anything else. For example, you can set up a
policy to allow users with the title “Manager” to be placed in a specific container, no matter which
application the information is coming from, and you can place this information in multiple
connected systems. However, because each application is different, you need to modify the
arguments and rules within policies to reflect those differences. For more information about policies,
see Understanding Policies for Identity Manager 3.5.1 and Policies in Designer 2.1.
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To import an eDirectory Policy object (for example, a rule or a style sheet) into a driver or channel
(Subscriber or Publisher):

1 Select a driver in the Modeler view.
or

Click the Outline tab and select a Driver or Channel object from the Outline view.

2 Verify that the authentication credentials in the Properties view for the selected Identity Vault
are correct.

3 Right-click the Driver or Channel object, then click Live > Import.

p o mmm e m e g e

& Simulate...

Expart to Configuration File...

& Deploy...

Froperties & C
. & Compare...
"B Fassword(Pub)-Publish Disributial.... P

If the application can’t authenticate to the eDirectory tree, you see the Identity Vault
Credentials window asking for the host name, user name, and password if you have not
previously specified the authentication credentials or if you do not save the password. Fill in
the appropriate information and click OK.

4 Tn the Import from Identity Vault window, click Browse, then select a policy object from the
channel you specified when you started the import process.

@ Browse |dentity Vault []
File

Select an object:

%) Publisher || S=Command Transform S5

& Subscriber = Command Transform
& Marv's Job E= Creation
& Delimited Text 2= Event Transform
& Matching

& Delimited Text O
& eDirectory Driver 1
& eDirectary Driver 1

=% Password{Pub)-Add Password Payload
=2 Password(Pub)-Check Password GCY
=2 Password(Pub)-Default Password Policy

"_l" Generic Loopback = Passward (Pub)-Publish Distribution Password
&’ Passward Sync St || 22 Password (Pub)-Publish NDS Password

& test = Placermant

& User spplication = UserMameMap

& Userspplication

ffis DS=tLib

& PwdExpz
& TestDSet W
fify rvLib
fify tarv's Library ~

|

Ead
e

(04 ] [ Cancel

Ch=Creation.CN=FPublisher. CN=Active Directory CN=mydriverset. O=novell
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Policies are found under either the Publisher or Subscriber channel of a selected driver or under
the driver itself. Be sure to match the proper policy to the proper channel or driver object.

Click OK, then click Continue to import the policy.

You see the Import Summary window showing you the differences between eDirectory (the
source of the import) and Designer (the destination). You can click the different objects in the
policy to see what is different between the two policies. All selected policy information is
overwritten by the import procedure; however, the rest of the driver is unaffected.

Click Import.

If the importing policy contains the same values as the policy in Designer, you are not allowed
to import the policy. (See Section 15.5, “Using the Compare Feature When Importing,” on
page 291 for more information on the Compare feature.)

Clicking Import brings up the Import Results window. If there are any problems with the
import procedure, they are displayed with a red icon, and you see an Error description that is
related to the operation results. If you have multiple errors, selecting the different errors
displays the error’s description in the Details > Description field. See Section 24.4.3, “Error
Messages and Solutions,” on page 498 for further information.

Click OK to finish the import process.

For policy design, see the Policy Builder and Policy Management Help topics within the
Designer utility. Also see Understanding Policies for Identity Manager 3.5.1 and Policies in
Designer 2.1.
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15.4.3 Importing a Schema

You can import a schema from the Identity Vault or from a .sch file into your project. When you
import a schema, you can select the whole Identity Vault schema (not recommended) or just the
schema differences between the Identity Vault and your project.

1 Bring up the project in Designer’s Modeler view. Right-click the Identity Vault and select Live
> Schema > Import.

< Undo Change Location

MNew

== Straighten Connections

"1 Select Connected Applications
Distribute
Align

@ Change to eDirectory Tree
Change to Identity Yault / Meta-Directory
i Add to Group

& Manage Yault Schema...

Dacument selectian. ..

= Import Schema from File...
Export to File
E-mail Templates

I
&0 Deploy...
Deleta -
X % Compare...

Froperties

@] Cpen iManager...
4 Browse Identity Yault...

& Driver Status...
Q Start Drivers
© Stop Drivers
@ Restart Drivers
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2 On the Select Source for Import page, select Import from eDirectory if you are connected to an
actual Identity Vault.

@ Schema Import Wizard 3]
Select Source for Import @
Select the location to import the scherma

Irnport fram eDirectary

Host Name: | 192.168.14.199 v
(Example: 192,168,14,199 or myserver.Company.com)

User Mame: | adrmin.novell v
(Example:  Admin.Movell)

Password: | ssssss

3 In the Import from eDirectory section, specify the host name, user name and password
connection information.

The Host Name and User Name entries have drop-down menus storing the last information you
typed into these fields, which you can use for filling in these entries.

4 Click Next.
5 Decide which classes and attributes to import.

On the Select Classes and Attributes for Import page, you can select all of Identity Vault’s
scheme, including classes and attributes. However, this creates very large documents when you
document the project (600 pages or more: see Section 24.5, “Issues When Generating
Documents,” on page 509 for more information on this matter).

6 If you want to import all the classes and attributes, click Select All, click Finish, then skip to
Step 8.
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Select only the classes and attributes that you want to import. If you only want to import the
schema differences between Identity Vault and your project, click View Differences, then
continue with Step 8.

@ Schema Import Wizard &)

Select Classes and Attributes for Import @
Check "Import all associations" to associate the selected attributes with
classes that may already exist in Designer.
Classas: atributes:  [Import all associations
L [anything] a8 0 0] o
[ [Mothing] [ [Nothing]
[ 4FP Server [ accessCardiumber
[ alias [ Account Balance
[ applicationEntity O acL
[ applicationProcess [ aliased Object Mame
[ audit:File Object [ allowsliasTasncestor
[ authPasswardohiect [ aliow Unlimited Credit
[ Bindery Chject [ assistant
[ Bindery Queve v | | [ assistantPhone v
4 < *
[gelect all ] ’Qeselect all l ISeIect all ] [Dgselect all ] IShDW all ]
Yiew Differences...
@ < Back Mext = ] [ Einish l [ Cancel
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7 On the Schema Differences page, you see the schema differences between Identity Vault and
your project. Click Select All if you only want to import schema differences. Otherwise, click

Cancel.

@ Schema Import Wizard

Schema

Differences

Class/Attribute

1 apchadmnConfiguration

: apchadmnConfigurationBlock
» apchadrmnMaodule

» apchadmnServer

s apchadmnyirtualHost

» bhCommunity

: bhCommunityMembership
' bhGadget

: bhiodule

' bhPage

: bhPagesSet

: bhPortal

: bhPortalConfig

: bhPortalConfigRiw

' bhPortalConfigSecretStore
: bhPortalGroup

' bhPortalGroupList

' bhTheme

: bootableDevice

1 cRLDistr ibutionPoint

. Device

» DFS-Junction

: DirxML-Driver

: DirxML-Job

: DirX¥ML-Library

Difference

Class does not exist in project
Class does not exist in project
Class does not exist in project
Class does not exist in project
Class does not exist in project
Class does not exist in project
Class does not exist in project
Class does not exist in project
Class does not exist in project
Class does not exist in project
Class does not exist in project
Class does not exist in project
Class does not exist in project
Class does not exist in project
Class does not exist in project
Class does not exist in project
Clags does not exist in project
Class does not exist in project
Class does not exist in project
Different containrment
Optional atiributes are different
Class does not exist in project
Cptional attributes are different
Class does not exist in project
Class does not exist in project

&)

This table shows all of the differences between the Identity Vault schema and the current

W

[ Select all H

Cancel l

8 Selecting Select All brings you back to the Select Classes and Attributes for Import page with
the schema differences now selected under the Classes and Attributes headings. By default, the
Import All Associations box is also selected. Leave it selected and click Finish. If you selected
Cancel on the Check Differences page, make your schema selections here and click Finish.

9 On the Import Messages page of the Schema Import Wizard, click OK.

If you want to save the differences to a log file, click Save fo Log. This brings up the Save As

dialog box, where you can choose a filename and directory to store the file in.

10 Click Save, then click OK.

15.5 Using the Compare Feature When Importing

Designer’s Compare feature allows you to see differences between the driver sets, drivers, channels,
and policies that are stored in projects and those that are running in deployed systems, and reconcile
any differences to either Designer or Identity Vault. Previous versions of Designer only provided
conflict resolution when importing a Driver. While importing, you could select which policies of the
driver you wanted to update, but you could not view any differences between existing and new

values.
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Designer provides conflict resolution on an object-by-object basis and allows you to view the
differences between existing and new values when importing and deploying driver sets, drivers,
channels and policies. For example, before importing a driver object in Designer to a driver object
that already exists in the Identity Vault, you can run Compare. Compare shows whether the driver
objects are equal (no action is necessary) or unequal. If unequal, you can choose not to reconcile the
driver objects, choose to update the driver object in Designer, or choose to update the driver object
in the Identity Vault.

You can run the Compare feature at any time. If you choose to reconcile the differences between
drivers objects in Designer and eDirectory™ while in Compare, you won’t need to run Import or
Deploy.

¢ Section 15.5.1, “Using Compare when Importing a Driver Object,” on page 292
¢ Section 15.5.2, “Using Compare On a Channel Object,” on page 295

¢ Section 15.5.3, “Using Compare On a Policy,” on page 295

¢ Section 15.5.4, “Matching Attributes with Designer Properties,” on page 295

15.5.1 Using Compare when Importing a Driver Object

Use this procedure if you want to import a Driver object from the Identity Vault and the same driver
already exists in Designer.

1 Right-click the driver object in either the Modeler view or in the Outline view, then click Live
> Compare to bring up the Designer/eDirectory Object Compare window.

@ Designer/eDirectory Object Compare - B

Select an chject or attribute: B E

| & fiw Active Directory [t C A
=@ Attributes Compare Status: " Mot Imported

4 outputTransform Reconcile Action: () pg not reconcile
@ Password (Pub)-Sub Emaill Notifications
(& Update Designer

[lonly show differences
Text Compare 4 ¢

. Designer (Destination) eDirectory (Source)

' encoding="UTF-5" cy |[Ead
rert selected attr

<Arg=value:-
<token-replace-all regex=
<token-local-variable | -

@ [ Reconcile ” Close ]
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Under the Select an object or attribute, you see the selected object with the differences between
Designer’s and eDirectory’s driver object. You can select the attributes and child objects to see
the actual differences displayed in the Text Compare area.

@ DesignerleDirectory Object Compare

Select an obiject or attribute: +H [

=l fy) Active Directory »
=40 Atributes
(@ Public Key
(@ Dir¥ML-ShimauthPassword { MADEANZ-MWDS )
=i Publisher
=40 Attributes
(@ Dir¥ML-CornmandTransfor mationRule
(@ Dir¥ML-PlacementRule
(@ DirXML-MatchingRule
(@ Dir¥ML-CreateRule
(@ Dir¥ML-EventTransformationRule
Creation v

[¥] Showr only differences

The plus icon at the right side of the Select an object or attribute allows you to expand all
elements in the parent object, and the minus icon collapses all of the elements. The “?” button
in the bottom left portion of the window displays the Summary/Compare dialog box help.

Server-specific attributes are attributes that have a value for each server that is associated with
a driver set. These attributes are displayed in the A#tributes list with the server name in
parentheses to the right of the attribute name.

By default, the Compare window only displays values that are different between Identity Vault
and Designer. To view all of the object values, deselect Show only differences.

Values that are equal are shown as Equal on the Compare Status line under Information.

Infor rmation
Compare Status: ™ Mot Imported

Reconcile Action: @ pg not recancile

(O Update Designer

The following table describes what you see in the Compare Status line:

Compare Status Description

Equal The selected attribute’s value or all attributes of the selected object are the
same in eDirectory and Designer.

Unequal The value of the selected attribute, or one or more attributes of the
selected object are different in eDirectory and Designer.
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Compare Status Description

Not Deployed The selected object or the object containing the selected attribute is not
deployed to eDirectory.
Not Imported The selected object or object containing the selected attribute does not

exist in Designer.

The overlay image displayed in the object and attribute tree identifies objects or attributes that
need reconciliation. You can also see an Attribute Note if you select an attribute.

3 In the Information portion of the Compare window, select how you want to reconcile the
differences between the Source and Destination. If Compare Status shows Unequal, you have
three choices:

+ Do not reconcile. To do nothing, keep the default value of Do Not Reconcile.

+ Update Designer. To update the driver in Designer so that it contains the same
information as the driver in the Identity Vault, select Update Designer.

+ Update eDirectory. To update the driver in eDirectory to reflect the changes you have
just made to the driver in Designer, select Update eDirectory.

If you select the parent object to perform the update, then all of the child objects under the
parent reflect that choice and you see the Reconciled By Parent button selected. If you do not
choose a parent object, you can reconcile each child object individually.

4 View the differences displayed in the Text Compare area.

Text Compare
o Designar (Destination) aDirectory (Source)
<?xml wversion="1.0" encoding="UTF-8"2?><pol: <description>5treet Address: CqEd
<descriprion>Convert Selected actribute <COomment xXml:space="prese s
<rule: <conditions:
<descriprionraccountExpires: Convel
<conditions: <fconditions>
<and/ > <AcTions>
<f/conditions> <do-reformat-op-Aattr name=
<actions:> <arg-value>
<do-reformat-op-attr name="accd <token-replace-all
<arg-value type="octert> <coken-local-w
<token-xpath expressiod </token-replace-al
<facg-values> <farg-value>
</do-reformat-op-acLr: </do-reformat—op-attr> v
< < >

The Text Compare values displayed in the bottom portion of the Designer/eDirectory Object
Compare window vary, depending on the object being compared. For instance, Compare shows
you changes down to the policy level. The Text Compare dialog box uses the Eclipse Compare
editor to compare attributes that contain XML data, such as policy data, driver filters, or
configuration data. The differences in the code are highlighted in blue.

5 After you view the differences, click Reconcile to perform the reconciliation actions for each
object in the tree, or click Close to close the Designer/eDirectory Object Compare screen.

After reconciliation, the object matches both locations and has been imported or deployed
through the action.
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15.5.2 Using Compare On a Channel Object

Use this procedure if you want to import a channel object from the Identity Vault and the same
channel already exists in Designer. You can view the differences and decide whether to reconcile
them.

1 Right-click the channel object in the Outline view. Click Live > Compare to bring up the
Designer/eDirectory Object Compare window.

All Compare windows behave as described under the Section 15.5.1, “Using Compare when
Importing a Driver Object,” on page 292.

2 After reconciliation, the Channel object matches both locations and has been imported or
deployed through the action.

15.5.3 Using Compare On a Policy

Use this procedure if you want to import a policy object from the Identity Vault and the same
channel already exists in Designer. You can view the differences and decide whether to reconcile
them.

1 Right-click the policy object in the Outline view. Select Live > Compare to bring up the
Designer/eDirectory Object Compare window.

All Compare windows behave as described under the Section 15.5.1, “Using Compare when
Importing a Driver Object,” on page 292.

2 After reconciliation, the policy object matches both locations and has been imported or
deployed through the action.

15.5.4 Matching Attributes with Designer Properties

The attributes of the object are displayed in the single list. Selecting an attribute displays its value
below the attribute list with the Designer value on the left and the eDirectory value on the right. The
name displayed in the list is the eDirectory attribute name.

The following tables map the eDirectory attribute to the Designer property page or control where
you can change or set the attribute (you can’t make changes inside the Compare window).

¢ Table 15-1 on page 295 shows Driver Set eDirectory attributes

*

Table 15-2 on page 296 shows Driver eDirectory attributes

*

Table 15-3 on page 297 shows Channel eDirectory attributes

*

Table 15-4 on page 297 shows the Job eDirectory attributes

*

Table 15-5 on page 297 shows the Resource eDirectory attributes

Table 15-1 Driver Set eDirectory Attributes

Driver Set eDirectory Attribute Designer Property
DirXML-DriverTracelLevel Driver Set Properties->Trace->Driver Trace Level
DirXML-XSLTracelLevel Driver Set Properties->Trace->XSL Trace Level
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Driver Set eDirectory Attribute

Designer Property

DirXML-JavaDebugPort
DirXML-JavaTraceFile
DirXML-TraceSizeLimit
DirXML-LogLimit
DirXML-LogEvents
DirXML-ConfigValues

Driver Set Properties->Trace->Java Debug Port

Driver Set Properties->Trace->Java Trace File

Driver Set Properties->Trace->Trace File Size Limit

Driver Set Properties->Driver Set Log Level->Log Limit

Driver Set Properties->Driver Set Log Level->Log Specific Events

Driver Set Properties->Global Configuration Values

Table 15-2 Driver eDirectory Attributes

Driver eDirectory Attribute

Designer Property or View

DirXML-InputTransform
DirXML-OutputTransform
DirXML-MappingRule
DirXML-Driver Filter
DirXML-ConfigValues
DirXML-DriverTracelLevel
DirXML-LogEvents
DirXML-LogLimit
DirXML-ConfigManifest
DirXML-JavaModule
DirXML-NativeModule
DirXML-Driverlmage
DirXML-TraceLevel
DirXML-TraceFile
DirXML-TraceSizeLimit
DirXML-TraceName
DirXML-DriverCacheLimit

DirXML-ShimAuthID
DirXML-ShimAuthServer

DirXML-ShimAuthPassword

DirXML-ShimConfiglnfo

Policy Set View->Input Transformation

Policy Set View->Output Transformation

Policy Set View->Schema Mapping

Policy Set View->Driver Filter

Driver Properties->Global Configuration Values

Driver Properties->Driver Log Level->Driver Log Level

Driver Properties->Driver Log Level->Log Specific Events
Driver Properties->Driver Log Level->Log Limit

Driver Properties->Driver Manifest

Driver Properties->Driver Configuration->Driver Module: Java
Driver Properties->Driver Configuration->Driver Module: Native
Driver Properties->iManager Icon

Driver Properties->Trace->Trace Level

Driver Properties->Trace->Trace File

Driver Properties->Trace->Trace File Size Limit

Driver Properties->Trace->Trace Name

Driver Properties->Driver Configuration->Authentication->Driver
Cache Limit

Driver Properties->Driver Configuration->Authentication->User ID

Driver Properties->Driver Configuration->Authentication-
>Connection Information

Driver Properties->Driver Configuration->Authentication->Set
Password

Driver Properties->Driver Configuration->Driver Configuration-
>Driver Parameters
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Driver eDirectory Attribute

Designer Property or View

DirXML-DriverStartOption
DirXML-ECMAScript

Driver Properties->Driver Configuration->Startup Option

Driver Properties->Driver Configuration->ECMAScript

Table 15-3 Channel eDirectory Attributes

Channel eDirectory Attribute

Designer View

DirXML-EventTransformationRule
DirXML-MatchingRule
DirXML-CreateRule
DirXML-PlacementRule

DirXML-CommandTransformation

Policy Set View->Event Transformation
Policy Set View->Matching

Policy Set View->Creation

Policy Set View->Placement

Policy Set View->Command Transformation

Table 15-4 Job eDirectory Attributes

Job eDirectory Attribute

Designer View

XmiData

DirXML-ServerList
DirXML-Scope
DirXML-EMailTemplates
DirXML-EMailServer
DirXML-NamedPasswords
DirXML-TraceName
DirXML-TraceFile
DirXMI-TraceSizeLimit
DirXML-TraceLevel

Job Editor, XML cannot be edited directly only
through Job Editor Ul

Job Editor
Job Editor
Job Editor
Job Editor
Job Editor
Job Properties -> Trace
Job Properties -> Trace
Job Properties -> Trace

Job Properties -> Trace

Table 15-5 Resource eDirectory Attributes

Resource eDirectory Attribute

Designer View

DirXML-ContentType

DirXML-DirXMLData
DirXML-NamedPasswords

Read only, cannot be edited set at creation time of
object

Resource Editor

Resource Editor
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15.6 Error Messages and Solutions

To view error messages along with their possible solutions associated with importing and deploying
files, see Section 24.4, “Deploying Identity Manager Objects,” on page 495.
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Documenting Projects

When you create a project, it’s vital to keep track of how the driver works and how it’s implemented
into a network. The Document Generator helps you quickly generate customized documentation for
your Designer projects. These documents can save you weeks or months of gathering and writing
driver specifications and their implementations. To generate a document, choose a document style
(it can be the default style that comes with Designer or one that you customize) and a Designer
project or portion of a project. The Document feature combines the information and structure of the
selected style with the project information in order to generate customized project documentation.

Designer comes with a default document style so you won’t have to create a document from scratch.
This default style contains everything that you have placed in a project through Designer. You must
first use this default style to create your own document style for the project you are working on, then
you can either use it as it is or customize it to meet your particular needs, including or excluding
information as needed. After you have edited the style to your liking, you can also use it to
document your other projects. There is an advanced editing feature that allows you to create your
own sections for adding information that you did not create in Designer.

¢ Section 16.1, “Creating a Document Style,” on page 299

¢ Section 16.2, “Editing a Document Style for Your Needs,” on page 300

¢ Section 16.3, “Generating a Document,” on page 302

¢ Section 16.4, “Using Your Template Style for Other Projects,” on page 306

¢ Section 16.5, “Customizing Styles to Include or Exclude Information,” on page 311

+ Section 16.6, “Advanced Editing of a Document Style,” on page 320

¢ Section 16.7, “Troubleshooting Issues When Generating Documents,” on page 337

16.1 Creating a Document Style

A document style allows you to define how you want your project information to look. In a matter of
minutes, you can generate a document that contains all elements that you have placed in a project
and define a document style to designate how the information looks, as well as what information
you want in a document.

1 Select a project in the Project view, then right-click the Documentation icon.

2 Click New > Document Generation Style (.docgen).

mmline = = 8|l Blanstor

1=F Blanston

1= Blanstonl
=-1=* Blanston3
Tl Systern Model

docurnentation

4 7 Identity Manager Project...

Irmport Y [ File...

Copy B Documen

&% Refresh
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The Document Generation Style (. docgen) is the default style that is provided with Designer.
You use this as the template for your own .docgen style.

3 Specify a name for the style, with a . docgen extension, or use the default name of the project
you are presently in, then click Finish.

@ New Document Generation Style

Name Your New Style

Your new Style (.docgen) is placed in the selected project.

Style Mame: | Blanstonl.docgen |

(@) Mote: Do not specify a path with this Style
narme, This Style will be created in the
Docurmentation folder of the "Blanston3"
project.

2 ’ Mext = ] [ Einish l ’ Cancel ]

A .docgen file is created that you can use as the basis for designing your own style template.
The . docgen template is placed in the Style Editor view for your modification (see

Section 16.2, “Editing a Document Style for Your Needs,” on page 300). You can use the
defined elements in your new style template again and again.

4 Use this basic document style to generate documentation for a project, or customize it for your
needs.

¢ Section 16.3, “Generating a Document,” on page 302

¢ Section 16.2, “Editing a Document Style for Your Needs,” on page 300

¢ Section 16.4, “Using Your Template Style for Other Projects,” on page 306

* Section 16.5, “Customizing Styles to Include or Exclude Information,” on page 311

+ Section 16.6, “Advanced Editing of a Document Style,” on page 320

16.2 Editing a Document Style for Your Needs

Now that you have created a .docgen template, you can edit the file to meet your documentation
needs. The .docgen file appears under the documentation directory in the Project view. Double-
click the .docgen file to bring up the template in the Style Editor.

You can add or modify information in the style template, which in turn affects the documents that
you generate. The information that you can customize through the Style Editor appears in the Style
Editor view. For more detailed editing, see Section 16.6, “Advanced Editing of a Document Style,”
on page 320.

¢ Section 16.2.1, “Editing a Style Template,” on page 301

¢ Section 16.2.2, “Editing Sections of a Style,” on page 301
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16.2.1 Editing a Style Template

1 Select a project in the Project view, then right-click the Documentation icon.

2 Double-click the . docgen file. The file appears in the Style Editor view.

1 Blanston - Developer B *elarstmonl.docgen X =g
Style Editor e Identity Manager System
ERE ] icentity Manager Syatern

[E] (Tl Paney
[E] Table of comants
= 1=l L Documant .
8 3- f':;;él Tl | tdentity Manager SystEm
E Disclaimer
(=] Trademarks e ——
[E] 1.2, Docurment Histary Document Froperties Cliert Propernes | Headsr | Fort Settings ¢ F
=-[E 2 Projact Information
[l 2.1. Expounve Surmmary Sokibon Mame:
El 2.2 spstem Crarvizw Idertity Manager System Solution
[E) 2.2.1 Higrarchical View
[E] 2.2.2. Contact Infor mation Short (sboraviated) Sokition Marme:
[E:R Prioject Configquration e
[El 4, Apperdic
= [B] 4.1 appendis A: Policies Frepared By:
[E 4.1.1. Policy Containers
Frepared by
[E] 4.1.2. Policy Detail (Prep byl
[E] 4.2 appendi B: Sthema Docurment Date:
[5] 2.2.1, Schema Cwervien

[E 2.2.2. Schema Detail
Docurent Typs:

SO Hurrbar:

3 Use the Style editor to edit sections of a style or to modify the style according to your needs.

The Style editor is divided into two parts, beginning with the Identity Manager and working
through the Appendixes. When you click an item under the Style Editor section, the right
portion of the view changes to display the information associated with the heading. For
example, clicking Disclaimer under the Document > Legal heading allows you to edit the
disclaimer content.

4 Save your changes. Your changes are saved when you close the Style Editor, or when you click
Save.

16.2.2 Editing Sections of a Style

1 Select an item (for example, Executive Summary) in the Style Editor view.
2 Enter data or make changes in the left pane.

3 Select other items as appropriate and make changes. The information in the left pane varies,
depending on items that you select.

The main areas that you need to pay attention to are the information found under Identity
Manager System (Title Page and Table of Contents), Document, Legal, Disclaimer,
Trademarks, and Executive Summary.

4 Save your changes. Your changes are saved when you close the Style Editor, or when you click
Save.
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5 Use this document style to generate documentation for a project, or continue to customize it for
specific documentation needs.

+ Section 16.3, “Generating a Document,” on page 302
¢ Section 16.4, “Using Your Template Style for Other Projects,” on page 306
¢ Section 16.5, “Customizing Styles to Include or Exclude Information,” on page 311

+ Section 16.6, “Advanced Editing of a Document Style,” on page 320

16.3 Generating a Document

1 (Conditional) If you haven’t yet created a Designer Project, create one.
1a Sclect File > New > Identity Manager Project.
1b Provide a project name, then click Finish.

2 (Conditional) If you haven’t yet created a document style that you want to use as a template for
your documentation, create one. See “Creating a Document Style” on page 299 and “Editing a
Document Style for Your Needs” on page 300.

3 In the Project view, select and expand a project, then right-click the .docgen icon and select
Generate Documentation for This Style.

or
Select Project > Documentation > Generate Documentation.

Mavigamr Cuitline =

[=-1=F Blanstonl
T2l System Model
=7 documentation
Blanstonl.docgen
[enwy r

Irnpart s

Copy
@ Refrash
Cpen With »

Renarmea

g ¥ Delete

B Generate documentation for this style...

B HOCUTHET LS TorT
Blanstonz.docgen
Blanston2. log. bt
|=! Blanstonz, pdf
o Blanston2 source,none, kil
Blog. et

= resources
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You can also expand the Documentation folder and click the . docgen file to open the file in
the Style Editor, then click the Document Generation icon to the right of the Style Editor
heading.

4 (Conditional) If the Documentation folder you selected does not contain a . docgen file,
you are asked to select a Base Style. Select a . docgen style, then click Next.

@ New Document Generation Style 3]

Select a Base Style

Define your docurnent's formatting by selecting a Style,

Styles:

= styles
Default_Style.docgen

(= Provisioning Style

¢ Blanstonl

=5 Blanston2

ton2.docgen
2| Blanston3
‘] Blanston4

@ I Einish l [ Canicel ]

5 In the Generate Documentation window, click the Input Settings tab, select the project you
want to create documentation for using this style template, then click the Output Settings tab.

@ Generate Documentation 3]
Output Settings  Input Settings l

Designer Project:

04 | Cancel
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6 (Conditional) This release of Designer includes the ability to generate documents to RTF (Rich
Text Format). If you want to enable this functionality, click Window > Preferences to bring up
the Preferences window. Then, under Designer for IDM, select Document Generation.

@ Preferences FE®E
type filker text Document Generation = v
General
= Designer for 10 eneral

Configuration [¥] sutomatically open the rendered file after document generation

Document Geners| [V]Shaw warning dialog box when the style is an alder version

Entitlements [¥IEnable RTF support (experimental)

iManager

Import/Deploy Modeler

Language [“IDacument applications and drivers related to other selected items
Modeler

Document Appearance

Palicy Build
olicy Buiier Select the language you want the docurment 1o generate in:

Project Checker
Schema

Simulation )
Trace Select the font to use for documentation:

Help arial -
Mowell

Provisioning

Web and XML

English w

[ B [

[Resb:re Defaults ] l Apply ]

@ [ Ok l[ Cancel ]
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By selecting Enable RTF support (experimental), you can select the RTF format when creating
documents.

@ Generate Documentation &

Specify Output Criteria

Select a format, filenarme and location for your docurnent,

Format;
Filename:

[¥] overwrite existing file
Cutput XML source files
[¥] Capture Model diagrams

(1) Mote: If you use the default output location (Documentation folder
of working project) your generated document will be visible under
the Documentation folder of the Project view,

@ [ Einish l I Cancel

7 On the Output Settings page, fill in the needed information.

@ Generate Documentation ®

Format: PDF (Printable Docurment Format)

Filepame: | Blanston3.pdf |

Directary: | C:\Documents and Settings\Movell Userworksp | Browse. ..

[#] Overwrite existing file
Output #ML source files
Capture Model diagrams

@) Maote: If you use the default output location (Documentation falder
of working project) vour generated document will be visible under
the Documentation folder of the Project view,

[ Ok ] ’ Cancel ]

¢ Select the format for the file. If you have enabled rich text formatting, you can select PDF
(Printable Document Format), TXT (Text Document), or RTF (Rich Text Format).

¢ Select the name you want to call the file, or keep the default name. If you are generating
the whole document, the default name often suffices. If you are generating a document for
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a section, such as an Executive Summary, name the file to reflect the section you
documented.

+ Select the directory where you want to store the document. If you use the default output
location that appears in the Directory field, your generated document is visible under the
Documentation folder of the Project View.

+ To overwrite an existing .pdf file, select the Overwrite existing file option (selected by
default).

+ To see the XML source files, select the Output XML source files option (selected by
default).

¢ To include the model diagrams in the PDF file, select the Capture Model diagrams option
(selected by default).

8 Click Finish to generate the document. The document appears in the current Project >
Documentation folder unless otherwise specified.

PDF files must be viewed through a PDF viewer, such as Adobe Acrobat*. If Adobe Acrobat is
presently installed on your workstation, Designer launches the document in Acrobat. RTF files
can be viewed in any word processor that can handle Rich Text Formatted files.

9 If you receive an “Out of Memory” error message while generating documentation, see “Issues
When Generating Documents” on page 509.

16.4 Using Your Template Style for Other
Projects

To generate documentation for any project, you can use the default style provided with Designer or
you can use your own customized styles.

For example, suppose you have created a Blanston2 style. You customize the Blanston2 style to fit
your needs, and you save it in the Documentation folder as Blanston?2.docgen as outlined
in Section 16.1, “Creating a Document Style,” on page 299. You can use this style to create
documentation for the Blanston2 project or for other projects.

¢ Section 16.4.1, “Start with the Style and Choose the Project,” on page 306

¢ Section 16.4.2, “Start with the Project and Choose the Style,” on page 307

¢ Section 16.4.3, “Document a Section of the Style,” on page 308

¢ Section 16.4.4, “Document Multiple Sections of the Style,” on page 310

16.4.1 Start with the Style and Choose the Project

1 With the Blanston2 project open in the Project view, right-click the Blanston2.docgen file
in the Documentation folder.

2 Click Generate Documentation for This Style.
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3 In the Generate Documentation window, click the Input Settings tab, then select the project you
want to create documentation for with this style template (in this example, Blanston3).

@ Generate Documentation 3
Output Settings  Input Settings l

Designer Project:

oK | Cancel

4 Select the Output Settings tab to open the Specify Output Criteria window, fill in the necessary
information, then click OK.

For information on using this style to generate documentation, see “Generating a Document”
on page 302.

16.4.2 Start with the Project and Choose the Style

1 With two projects open (for example, Blanston1 and Blanston2), go to the Project view and
click Documentation > New > Documentation Generation Style (.docgen).

2 Name the new . docgen file (this example is Blanston?2 . docgen), then click Next.

3 Select a base style (for this example, Blanston.docgen), then click Finish.

@ New Document Generation Style

Select a Base Style

Define your document's formatting by selecting a Style.

Styles:

= styles
Default_Style.docgen

(= Provisioning Style

T3¢l Blanstonl

-1 Blanston2
Blanstonz.docgen

T2l Blanston3

¢l Blanstond

@ Einish l [ Cancel
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The Blanston2.docgen file opens in the Style Editor. Because a style usually contains
project-specific information, such as the company name, use the above information to see if the
template transferred. If you often use the Blanston?2.docgen style with the Blanston1
project, you might want to copy the Blanston2 style to the Blanstonl Documentation
folder, or copy the . docgen file to the styles template library. For more information, see
Section 16.6.5, “Saving a Style File in the Styles Template Library,” on page 337.

4 You can click the Generate Documentation icon in the Style Editor to generate a document.
See Section 16.3, “Generating a Document,” on page 302.

NOTE: If you see an exclamation mark in the .docgen file icon, it means the file does not
contain new features and needs to be updated. To do this, create a new .docgen file, copy any
changes to the new file from the older .docgen file, then delete the older .docgen file.

16.4.3 Document a Section of the Style

Instead of generating a document for the entire project, you can generate a document for a selected
section of a project.

1 With the project’s . docgen file open in the Style Editor pane, right-click a section of the
style.

2 Select Generate Documentation for This Section.

3 In the Generate Documentation window, type a different project name in the Filename field

(for example, ExecutivSumofMerger), then click OK.

B| *Blarstonl.daogen % ]

Style Editor # B @ | Executive Summary
= [l 1dantivy Manager System
B {Title Page)
|2] Table of contents [lIre ude this saction in the final document
= [E 1. Dooument
= B 1.1, Legal
[E pisclaimer
[E] Trademarks
[E] 1.2, Document History
= [ 2 Praject Information
= v CretEnt:
T Chiikd 4

Title: | Executive Sumimary

CWEIEN | Other

I!.rr‘.l';{p‘»Elémstm. Inc. ard I0M are merging, Dur g »
2 Undo Set }year 2002, Blanston and 100 signed 3 merger
eement. low they nead to bring ther IT management
dor Metware and Linu, <>
o CUE =Blangtan's and IOM's workwide IT mansgemart
- Capy ed to establish a straight forward portal user
E inistration ard, at the same time, provide employess
ez sarme login ID and password for the existing IT

3 Delete vircrment and the rew portal. Arother impartant
uirement was rot o changes existing admnistration
walidate s ard processes. </

=The administration of portal usars is seamlassly o

Load Resource...

Refresh
Show Properties Yiew

Hf} Generate documentation for this secton....

Specify which portion or portions of the project you want to include in the generated document.

You can document domains, Identity Vaults, driver sets, drivers, and applications using the Modeler
view or the Outline view (use the Ctrl key to select multiple items). Document generation also ties in
with schema notes, classes and attributes. You can find out more about this in Chapter 11,
“Managing the Schema,” on page 187.
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For example:

1 To document a specific driver in a project, right-click the driver in the Modeler or Outline view

and select Document Selection.

-85 Driver Set
o FE——

Mesw 3
Copy ’
&* Show Dataflow View
=
& Simulate. ..
(B Show Policy Sets

] Run Configuration Wizard. ..
%3 Password Synchronization. .,

& Manage spplication Schema...
o) @ ge App

B Docurnent selection. ..
‘i@ Export o Configuration File...
=

Live 4
¥ Delete

B Properties

HE==-—

2 Select the .docgen style sheet for the document, give the document a filename, and generate

the driver document.

By default, documenting an application includes the connected driver (and its related objects).
Likewise, documenting a specific driver includes its connected application. However, you can

change this behavior in the Documentation Generation’s Preferences page.

1 Click Window > Preferences to bring up the Preferences window.

Documenting Projects 309



2 Under Designer for IDM, select Document Generation.

type filter text Document Generation S o
+- General
- Dagigner for IDM General
Configuration [ automatically open the rendered file after document generation
Document Geners|  [v]Show warhing dialog bax when the style is an older version
Entitiements [¥IEnable RTF support (experimental)
iManager
Irmport/Deploy Modeler
Language [“IDocument applications and drivers related to other selected items:
H Moldeler " Document Appearance
Falicy Builder
* _y Select the language you want the document to generate in:
Project Checker
Schema English v
Sirmulation .
Trace Select the font to use for documentation:
- Help Arial o
+- Movell
+- Provisioning
+-Web and XML
- " ’Resh:re Qefaults] [ Apply ]
i3] I Ok ] ’ Cancel ]

Under the Modeler heading, the Document applications and drivers related to other selected
items option is selected by default, which means that directly related items are included in the
documentation. For example, by default, documenting a driver set includes the direct children
(the applications) as well as some information of the direct parents (the Identity Vault and
domain) to give context to the driver set. Deselecting this option excludes direct children of the
selected item.

3 Select or deselect the options you want, then click OK.

16.4.4 Document Multiple Sections of the Style

If necessary, you can generate only selected sections so that peers can help you with information in
the selected sections.

1 If you have not already done so, double-click the .docgen file to bring up the template in the
Style Editor.
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2 Select or deselect section headings. Each section and child section has a check box entitled
Include this section in the final document. By default the box is checked, as shown below.

Project Configuration

[¥linclude this section in the final docurment

Title: | Project Configuration

To limit the sections you want to document, deselect the check boxes in the sections you don’t
want to generate.

3 Click the Generate Document icon to the right of the Style Editor heading and generate your
document.

Give the document a unique name to reflect the type of information it includes.

16.5 Customizing Styles to Include or Exclude
Information

If you import a project with the entire Identity Vault schema and run document generation on that
project, you can have an extra 600 pages or more of schema information. This happens because you
have all of the Identity Vault’s base schema along with the added schemas are included in the

document.

Novell does not recommend that you document all Identity Vault schema unless you need to. The
main problem in doing this is that your workstation can run out of memory. If you do have memory
issues when generating documentation, see Section 24.5, “Issues When Generating Documents,” on
page 509.

These are the general ways you can control the amount of information you generate:

¢ Section 16.5.1, “Limiting Documentation for the Identity Vault Schema and Application
Schema,” on page 311

¢ Section 16.5.2, “Deleting Extra Identity Vault Schema from Your Generated Report,” on
page 315

¢ Section 16.5.3, “Using Project Configuration to Limit Information,” on page 318

16.5.1 Limiting Documentation for the Identity Vault Schema
and Application Schema

You can limit what you document for the Identity Vault and application schema that you have
imported. This is accomplished by selecting the Appendix B: Schema heading the in the Style Editor
view. This brings up the Appendix B section template in the right-hand side of the Style Editor view.
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Figure 16-1 The Appendix B: Schema Section Template

Appendix B: Schema

[FlInclude this section in the final docurment

Title: Appendix B: Schema

...................................................................................................................

(@) Identity Yault schema is MOT available to render unless

! marked for docurmentation using the schema tool, or
schema has been imported or manually created in
Designer.

[(Joacument all custam Identity Vault Schema even if not marked for documentation

(@) spplication schema will NOT be documented unless
individual classes have been marked to be documented
or the override option below is used,

[(Joacument all &pplication Schema even if not marked for documentation

The Appendix B: Schema section has three boxes:

¢ Include this section in the final document

¢ Document all custom Identity Vault Schema even if not marked for documentation

¢ Document all Application Schema even if not marked for documentation
Include this section. The Include this section in the final documentation check box allows you to
include or not include Appendix B information in the documentation. The default is checked to

include this information. Deselect the check box if you do not want to include application or Identity
Vault schema in the document.

Document all custom Identity Vault Schema. The Document all custom Identity Vault Schema
even if not marked for documentation check box allows you to control documentation on Identity
Vault schema that you import from the Identity Vault or that you create.

To select the Identity Vault schema you want to document:

1 Right-click the Identity Vault icon in the Modeler view and select Manage Vault Schema.

2 In the Manage Schema window, select the classes that you want to document, then click
Document this Class.
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You can select multiple classes by using the Ctrl or the Shift key.

@ Manage Schema &)

Classes | Attributes

[Shift-click to select a range]1ﬁ

dynarmicGroupaus
edirSchemaversion
encryptionPolicy
External Entity
feder ationBoundar

Groupwise Agent
Grouphvise Distribution List
Grouphvise Domain
Groupiise External Entity
Groupwvise Gateway
Grouphvise Library
Groupiise Post Office
GroupWiise Resource
hamelnfo

httpServer
immediateSuperiorReference
LDAP Group

LDAF Server

List

Locality

MASY :Security Policy
[CJonly show changes

[ Ok H Cancel l

@

Eay

Flags:

@ Effective Man-remavable
O Mon-effective [ cantainer

O awiliary

ASM1: | 2.5.6.17

[Ishow inherited associations
aftributes | Super | Sub | Containment

@ T

CH (Marming) -
CH (Mandatory)

businessCategory

Description

Erail Address

Full Name

GID

L

Login Script

Mailbos: 10

Mailbos Location

Member

MNEW: Grouplidise ID -

3 Click OK.

If you select the Document all custom Identity Vault Schema even if not marked for documentation
box in the Appendix B: Schema section, it effectively overrides any Identity Vault schema selections
you make through the Schema Import Wizard. To summarize:

+ Ifyou select the Document all custom Identity Vault Schema box in the Appendix B: Schema
section, the entire Identity Vault schema is documented.

¢ Ifyou deselect the Document all custom Identity Vault Schema box in the Appendix B: Schema
section, only the Identity Vault schema that you have selected through the Manage Vault

Schema option is documented.

¢ If you do not select the Document all custom Identity Vault Schema box in the Appendix B:
Schema section and you do not select any Identity Vault schema through the Manage Schema
window, then no schema is documented.

Document all Application Schema. The third check box on the Appendix B: Schema page,
Document all Application Schema even if not marked for documentation, refers to your ability to
choose which driver’s application classes you want to document. If you select the Document all
Application Schema box in the Appendix B: Schema section, then all application schema is
documented. You can also select the application schema that you want to document instead of

documenting the entire schema. Use the following example for more information.

1 To select a driver’s application classes, bring up a project in the Modeler.
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2 Right-click the driver icon and select Manage Application Schema.

El IDM Tree El Blanston Inc,

Copy

g Mark as Firewall

REman Straighten Connection

£ Show Dataflow View

& Sirmulate.
(B Show Policy Sets

] Run Configuration Wizard...
2 Edit entitlerents...
%3 Password Synchronization. .,

nage Application Sc

Document selection...
Export 1o Configuration File. ..

Live

¥ Delete

Properties

3 The Application Classes dialog box appears with a list of classes that you can add to or delete.
The right side shows the attributes that already have been created for the class. If you do not see
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any classes in the Application Classes window, it means that there are presently no classes
created for this driver.

@ Application Classes and Attributes ]

Classes: @ @ X 5 @ atiributes of this class: @ @ ®

Email

Fax

Firsthame
Lastame

Title
WirelessPhone
WiorkPhone

Constraints:
[casesensitve  [IMaming
Flags: [read-onky [CIrutti-valued

[ cantainer [Orequired
ASHL: ASHL:

Type: | string w

[ Ok ” Cancel ]

4 1In the lower right corner is a check box entitled Document this Class. When you select this box,
you can choose which application classes you want to document through the Document
Generator instead of documenting the entire schema.

If you select the Document all Application Schema even if not marked for documentation box in the
Appendix B: Schema section, it effectively overrides any driver application schema selections you
make through the Application Classes window. To summarize:

¢ Ifyou select the Document all Application Schema box in the Appendix B: Schema section, the
entire application schema is documented.

¢ If you deselect the Document all Application Schema box in the Appendix B: Schema section,
only the application schema that you have selected through the Application Classes window is

documented.

¢ If you do not select the Document all Application Schema box in the Appendix B: Schema
section and you do not select any application schema through the Application Classes window,

then no schema is documented.

16.5.2 Deleting Extra Identity Vault Schema from Your
Generated Report

If you import a project with the entire Identity Vault schema and run document generation on that
project, it can result in an extra 600 pages or more of schema information. This happens because all
of the Identity Vault’s base schema is included in the document.

Follow these steps if you do not want to document all of the Identity Vault’s base schemas:
1 Go into the workspace folder for this project and locate the . data file.

For example, on a Windows workstation, the Blanstonl files directory is found at
C:\Documents and Settings\Novell
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User\workspace\Blanstonl\Blanstonl files. Click Type to see all of the
.data files shown together. The largest . data file holds the base Identity Vault schema.

[ CHiDocuments and SettingsiNovell Useriworkspace\BlanstonlBlanstonl_files

Mame Size  Type
|[Ipolicy_trace File Folder
DFEZDC13-FEC3-FSDB-6895-1393#\1E91439.application 1KE APPLICATION File
9D9FDD6?-5159-93C4-EBFF\-B?4lCZBB?Ql?.apphcatiDn 1KE APPLICATION File
34#\?54#\2-DBZZ-E6F8-C6F2-056BDDBCBDBS.app|icati0n 1KE APPLICATION File
BODE1EOC-5FE3-AE42-998A-2860685E9A41 , application 1KE APPLICATION File
BD65362?—6C6F—CB44—?.°.DA—ED?B??DCEEDD.application 1KE APPLICATION File
ECEDFF\?F\-UUCS-SDC?-GDQB-SGBC‘%?SZFEBD.app|icati0n 1KE APPLICATION File
ED2ISDDP.-EDF?-F\DS1-4DC?-SBB4CF902823.application 1KE APPLICATION File
jDDF\SFZ?S-DZ?C-ZI88-4484-C5E865C5?205.data 36 KE DATAFile
j 1DFSD40C-B309-DF 76-D30E-47C1780720E9, data 4KE DATA File
j2DF?4C6D-BSSB-52F2-A239-16364C23EEE4.data 4KE DATA File
j31?2436C-9E64-F\CA1-D354-4D620851016E.data 3KE DATAFile
j A4C7920B-BDES-C 169-6FCS-6FDFESS067ES, data 4KE DATA File
j BODE1EOC-SFE3-AE42-998A-2860685E9A41 data 4KE DATA File
jB4F82?A5-DEDF-ISB?-9C16-BF81C28298E6.data 4KE DATA File
jBDElZB?U-UDAD-?FE‘}-ZFSl-ASQASFESSF?F.data 1KE DATA File
jDBlFCFBF\-F?BD-DQEE-EF\RU-DDS49DC88F61 .data 4KE DATA File
ﬁ EDZECDEZ-E16F-0D45-E168-9A7E b 340KE DATA File

If you have more than one Identity Vault in your project, you will see more than one large
.data file in the project’s folder.

2 Open the . data file in a text-based editor (in this instance, Wordpad) to make sure you have
the schema file. Schema files have <schema-de > at the top of the file.

File Edit Wiew Insert Format Help

Ded & #

<schema-def>

<class-def class-name="AFF Server™:>
<attr-def attr-name="Aiccount Balance™ multi-valued
<attr-def attr-name="ACL"™ type="structured"/>
<attr-def attr-name="A4llow Unlimited Credit" multi
<attr-def attr-name="iudit:File Link"™ multi-waluesd
wattr-def attr-name="Authoritcy Revocation™ malti-w
wattr-def attr-name="gauxClassCormpatibilicy" read-o
<attr-def attr-name="Back Link" read-only="true" ¢
<attr-def attr-name="Eindery Propercy"” read-only=" .

£ >
Far Help, press F1

B

Now suppose you only want to import the Identity Vault schema differences between your
project and the Identity Vault.

3 To get the schema differences, delete any large . data files,
4 Re-import the project’s schema:

4a Bring up the project in Designer’s Modeler view. Right-click the Identity Vault and select
Live Operations > Import Schema.

4b At the Select Source for Import page, select Import from eDirectory if you are connected
to an actual Identity Vault, or select Import from .sch File if you have saved the schema
files locally.

4c In the Import from eDirectory dialog box, type the host name, username, and password
connection information, then click Next.
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4d On the Select Classes and Attributes for Import page, click View Differences.

@ Schema Import Wizard &)

Select Classes and Attributes for Import @

Check "Import all associations" to associate the selected atiributes with

Classes: atributes:  [J1mport all associations
0] [anything) ~] [ Dyt -
[ [Nathing] [ [Mothing]

[ &Fp Server [ accessCardiumber

[ alias [ account Balance

[] apchadmnconfiguration [ acL

[ apchadmnconfigurationglock [ aliased Chject Name

[ apchadmntadule [ allowalizsTosncestor

[ apchadmnserver [ allaw Unlimited Credit

[ apchadmnyirtualHast [ apchadmn-BlockType

[] applicationEntity [ apchadmn-Configurationinfo

[ applicationProcess [ apchadmn-MaoduleDisable

[ sudit:File Ohject [ apchadmn-toduleFileMame

[] bhCammunity [ apchadmn-MaduleCbiectFile R
[ bhcammunitytembershin 2 "_' B

T e e

lgelect all l Ignselect All ] ISeIect All ] IUQseIect All ] lShOW All ]
Wiew Differences. ..

3] < Back ” Mest = ] [ Einish ] ’ Cancel
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On the Schema Differences page, you see the schema differences between Identity Vault
and your project.

@ Schema Import Wizard ]

Schema Differences @
This table shows all of the differences betwesn the Identity Yault scherma and the «
Clags/atiribuie Difference ~
iClass: apchadmnConfiguration | Class does not exist in project
Class: apchadrmnConfigurationBlock Class does not exist in project
Class: apchadmnmModule Class does not exist in project
Class: apchadrmnServer Class does not exist in project
Class: apchadmnvirualHost Class does not exist in project
Class: bhCommunity Class does not exist in project
Class: bhCommunityMernbership Class does not exist in project
Class: bhGadget Class does not exist in project
Class: bhiModule Class does not exist in project
Class: bhPage Class does not exist in project
Class: bhPageSet Class does not exist in project
Class: bhPortal Class does not exist in project
Class: bhPortalConfig Class does not exist in project
Class: bhPortalConfigRi Class does not exist in project
Class: bhPortalConfigSecretStore Class does not exist in project
Class: bhPortalGroup Class does not exist in project
Class: bhPortalGroupList Class does not exist in project
Class: bhThetme Class does not exist in project
Class: bootableDevice Class does not exist in project
Clags: cRLDistributionPaint Different containment
Class: Device Optional atributes are different
Class: DFS-Junction Class does not exist in project
Class: Group Optional attributes are different
Class: ieeeS02Device Class does not exist in project
Class: ipHost Class does not exist in project b
@ ’ Select all ] [ Cancel l

4e Click Select All. This brings up the Select Classes and Attributes for Import page with the
differences now selected under the Classes and Attributes headings. By default, the Import
All Associations box is also selected. Leave it selected, then click Finish.

4f On the Import Summary page, click OK.

5 Bring up the Manage Schema window and select the classes and attributes you want to
document, as described in “Limiting Documentation for the Identity Vault Schema and
Application Schema” on page 311.

16.5.3 Using Project Configuration to Limit Information

The Project Configuration heading allows you to include or deselect information on:

¢ Identity Vault
* Driver Sets
* Drivers

+ General

The following table shows what type of information can be included or excluded in these areas.
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Table 16-1 Project Configuration

Identity Vault

Information to Select or Deselect

Selected Include host information

Selected Include username information

Deselected Include deployment context information

Selected Include driver set names

Selected Include policy library on Identity Vaults

Deselected Include e-mail notification templates

Deselected Include XML source while documenting policies under the policy library

Deselected Include XML source while documenting credential provisioning objects under
the policy library

Deselected Include XML source while documenting mapping table objects under the policy
library

Driver Set Information to Select or Deselect

Selected Include server information associated with the driver set

Selected Include driver set Global Configuration Value (GCV)

Selected Include the policy library on driver sets

Selected Include job objects on driver sets

Deselected Include XML source for policies under the policy library

Deselected Include XML source for credential provisioning objects under the policy library

Deselected Include XML source for mapping table objects under the policy library

Deselected Include XML source for job objects

Driver Information to Select or Deselect

Selected Include the driver filter policy

Selected Include policy set

Selected Include server-specific information for this driver

Selected Include Remote Loader configuration

Selected Include entitlements

Selected Include credential provisioning

Selected Include mapping table

Selected Include ECMA script resource object

Selected Include job objects

Selected Include XML source when documenting entitlement objects

Deselected Include XML source when documenting credential provisioning objects
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Identity Vault Information to Select or Deselect

Deselected Include XML source when documenting mapping table objects
Deselected Include XML source when documenting job objects

General Information to Select or Deselect

Deselected Include passwords

Selected Page break after this section

WARNING: Credential provisioning the XML source might contain passwords that will be
displayed in clear text. If selected, passwords will be displayed in clear text and documentation will
include all passwords in the project.

16.6 Advanced Editing of a Document Style

In addition to selecting and deselecting the content of a document style, you can also change the
layout and usability of your document style. You do this by editing the attributes that are associated
with certain sections. You can also create additional sections for your documents as you see fit.

¢ Section 16.6.1, “What’s In the Advanced Editing Mode,” on page 320
¢ Section 16.6.2, “A Walk-through Tutorial,” on page 327

Section 16.6.3, “Selecting a Language for Generated Documents,” on page 334

*

*

Section 16.6.4, “Double-Byte Font Support,” on page 335

*

Section 16.6.5, “Saving a Style File in the Styles Template Library,” on page 337

16.6.1 What’s In the Advanced Editing Mode

The Advanced Editing icon 5 lets you toggle between simple editing and advanced editing modes.

By using the advanced editing mode, you can define information and a structure that is different
from the default template already attached to a predefined style. In this example, the Title Page
template is shown in its XSL format, which you must maintain.
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Figure 16-2 Viewing a Predefined Template

Style Editor
@ CLIENT_MUMBER: “
¢ DOCUMENT_DATE

¢ DOCUMENT_TYPE

& SOW_NUMBER

@ PAGE_NUMBERING_FORMAT

© CUSTOM_HEADER_TEXT

@ FOMT_SIZE_1
*
&
@
&
<@
@
&

3

&

FONT_SIZE_2
FOMT_SIZE_3
FOMT_SIZE_4
FOMT_SIZE_S
Comment
DEBLIG
DEBLIG_PARAMS
[E] (Title Page)
[E] Tsble of contents
B 1. Document
% @ BreakafterSection
# [F 1.1, Legal
+ [B] 1.2, Document History
=[] 2. Solution
% % BreakAfterSection
@ [E] 2.1. Executive Summary
# [E] 2.2, System Overview
= [B 3. configuration
# (8] 3.1, Overview
% [8 2.2, System Configuration
# [B] 3.3 Remote Loader Configuration
= [E] 4. Appendix A: Policies
= [E 4.1. Policy Cortainers
[l Templats
® % Content
= [B 4.2, Policy Detail
= [E 5. appendix B: Schema
% % Comment
#- ¢ doclvSchema
< » b

-8B -8-0-8-80

|6y @ | section Template
| <Pxml version="1.0"7>
<x=2l:scyleshesr wersion="1.0" xmlns:docgen="hctctp://cor

<#sl:import href="dgSection.xsl"/>

<xzliparam name="Content"/>
<x=l:param name="szhowSectionNuwrbering™/>

ate name="Section.Body” xmlns:des="http
:k break-after="page”:
“xslicall-template name="Format.oucpucTextil
iwith=param neme="value" select="${Coni
</xslicall-templates

<x=l:1f cesr="//policies” wmins:xsi="hotp
<fo:table>
<fo:table-column colunn-width="6&1i1
<fo:table-column coluwmn-widch=".7;
<fortable-bodys
<¥3lrapply-templaces mode="loca.
</fo:table-hody>
</fo:table>
<fu=liif>

<ffo:blocks
<fxal:cemplate:>

“<xslitemplate mode="local"” match="domain|domainlte

<x=licall-template name="Format.ContextRow'>

twith=-parsm name="text" select="fname"/:
rith-param name="level™ select="count (i
swith-param name="href"” selecc="fguid"”/:
“xsl:vith-param name="show-page-ref™><xsl:i:
iwith=parom neme="ipage"” =zelect="'auto''
<f¥slicall-template>

“xslrapply-templaces mwode="local®/ >

</xsl:tempplace>

<frslistylesheer>

Table 16-2 Style Editor Legend

Icon Name

Description

Green Page

Grey Page

White Page

Template

Global Attribute

A green page means it’s a titled section. The title appears

when you generate the document.

A grey page means it's not a titled selection. These pages

are also in parentheses; for example, (Title Page).

A white page means this section is disabled and will not be

included when you generate the document.

A yellow template page gives specific format and styles that

are included when you generate a document.

A global (red) attribute means it is passed down to every

section below it (all children sections).
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Icon Name Description

Local Attribute A local (green) attribute means it is only used by the section
o in which it appears.

Grey Attribute A grey attribute is used for comments.
@

Control Icon A Control type defines the functionality that you can give to
H'_ Attributes. Each Control type has a different functionality.

Advanced editing mode allows you to add the following:

¢ “Sections” on page 322

+ “Viewing or Editing Properties of a Section” on page 324

¢ “Templates” on page 325

* “Attributes” on page 325

¢ “Controls and Parameters” on page 326
You can have multiple sections in a document, but only one template per section. The template
defines the section’s layout; however, you can use the default template for newly created sections.
You can also have multiple attributes defining how the section looks, as well as multiple controls.
You use parameters (such as names and values) to specify options for a Control type. A Parameter is

a general name for a child item of a Control. The name of the Control denotes the type of control and
what you can perform by using that type.

Sections

Sections are blocks of the documentation composed of attributes, parameters, templates, and
controls through XSL programming. Section content includes a Title, Body, and children or
subordinate information. The following example shows the Section Properties page of the Identity
Manager System as seen through the simple edit mode.
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Figure 16-3 Section Properties Page

1l Blanston1 - Developer | *elanstonl.docgen x

Style Editor =0 E

BYE] vt Varager Sy
[E] (1l Paged
Bl Table of contants
= [E] 1. Document
= [F 11. Legal
[E] Disclairner
(8] Trademarks
[E] 1.2. Document Histary
= [E] 2. Projact Infarmation
B 2.1, Exerunve Surmmary
5] 2.2. System ovarview
[E] 2.2.1. Higrarchical View
[E] 2.2.2. Contsct Infor ration
& = Project Confiquration
=] 4. Appendic
= [B 4.1 appendiz &: Policies
[E 4.1.1. Policy Containars
[E 4.1.2. Policy Cetil
[l 4.2. appenci: B: Schama
[5] 4.2.1. Schiema Owerview
[E 422 Schema Detail

Identity Manager System

Tl | rdentiny Manager System

Document Propertios Client Propertes | Header | Font Settings < 7

Solinon Mame:
Idertity Managar System Solibon
Short (abtraviated) Sokition Mame:
o
Freparad By:
|Prepared by

Docurment Date:

Decument Typa:

SO Murrber:

The Identity Manager System section contains a Section Title (this can be changed), along with a
number of tabs (attributes): Document Properties, Client Properties, Header, Font Settings, and
Other. Each of these tabs contain fields that are editable; for instance, you can give the Section Title
a different name. When you click the Advanced Editing icon, you see that the Identity Manager
System section contains one template but several attributes, controls, and parameters underneath the

heading.

Figure 16-4 Advanced Editing

Mode

H e SHORT _SOLUTION_NAME

Style Editor =
= Identity Manager System »~
F] Template

@ SOLUTIOM_MAME
= @ SHORT_SOLUTION_MAME
-/ Cortrol (textboid

P label = "Shart (abbreviate

PREPARED_BY
CLIEMT_MAME
SHORT_CLIEMT _MAME
I Control (texthox)
CLIEMT_MUMBER.
DOCUMENT _DATE
DOCUMENT _TYPE
SOW_MNUMBER
P&GE_MUMBERING_FORMAT
CUSTOM_HEADER _TEXT
FONT_SIZE_1
FONT_SIZE 2
FONT_SIZE 3
FONT_SIZE 4
FONT_SIZE 5

Comment

® ¢ ¢

LR R IR R I R R R

Short (abbrevisted) Solution Marme
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Viewing or Editing Properties of a Section

If you click a section within the Style Editor and look in the Properties view (by default the lower
left corner of Designer), you see the values associated with the selection. (If you do not see the
Properties view by default, right-click a Section and select Show Properties View.)

Figure 16-5 The Properties View of the Appendix B: Schema

Property
Enabled
D

Mg 1D
Mumbered
Source
Title
Titled
Yarsion

Policy Set B _NElEafal=au=E8

|E o - = q E| 1.1. Legal

— [El 1.2, Dacument History
alue J =-[El 2. Project Information
- true % BreakafterSection
= sthemadppendix [E] 2.1. Executive Summary

TR TR AT
q‘
i
[ar]

[E] z.2. System Overview
[E] 3. Project Configuration
= [E] 4. appendix
= Appendix B: Schema [E] 4.1, Appendix & Paolicies
e [E] 4.2. Appendix B: Schema

These values are edited in the Properties view, and for the Section heading the values are listed in the

following table:

Table 16-3 Values of a Section

Property Name

Description

Enabled

ID

NLS ID

Numbered

Source

Title

Titled

Version

(True/False) Indicates whether this section is enabled. You can change this
setting using the section Style Editor, which is the editor shown to the right of the
hierarchical view.

Used for reference. Most the time, ID is left empty. However, you can specify an
ID for convenience in finding this section during the transformation process.

Used for reference. Most the time, NLS ID is left empty.

(True/False) Indicates whether this section should be included in the numbering
and placed in the Table of Contents.

Data source used to transform the template. For example, designer, style, and
none.

The value to be displayed as the title. You can change this setting using the
section Style editor, which is the editor shown to the right of the hierarchical view.

(True/False) Indicates whether the title value should be shown in the generated
document. Otherwise, it is used only in the GUI for context.

The version of the section.

NOTE: Values change, depending on what you select under the Style Editor view. For example, an
attribute shows different properties than a section or a template.
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Templates

A template is the XML source that defines the overall layout of a generated page. For instance, the
Title Page contains a template, as well as a number of other headings. The following figure

illustrates the parts of the Executive Summary template. For more information about templates, see
“A Walk-through Tutorial” on page 327.

Figure 16-6 Parts of the Executive Summary Template

-

Section Content <

L

Section Main <

-~

Attributes

2.1 Executive Summary

This company operates a Meta
Directory and other various
information systems where
identity information related to
employees and user accounts
are stored and maintalned

The administrator of portal
users is seamlessly integrated
in the existing user
adminlsiration process.

2.1.1 Account Details

Some of the accounts include

Information on the &=

} Section Title

> Section Body

P

} Section Childran

Attributes are the child elements of a Section. For example, clicking the Advanced Editor mode
while selecting the section title Identity Manager System reveals the following attributes in red
(global), green (local), and grey (comment):
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Figure 16-7 Attributes

| Blanston1 - Developer Mode Blans

Style Editor g5 N O
= Identity Manager System

5] Template
SOLUTION_MaME
SHORT _SCLUTION_MAME
PREFPARED_BY
CLIEMT _MAME
SHORT_CLIENT _MNAME
CLIEMT _MUMBER.
DOCUMENT _DATE
DOCUMENT _TYPE
SO _HNUMBER.
PAGE_MUMBERING_FORMAT
CUSTOM_HEADER_TEXT
FOMT_SIZE_1
FOMT_SIZE_2
FOMT_SIZE_2
FOMNT_SIZE_4
FOMT_SIZE_S
Camment
DERLG
DERLG_PARAMS
(Title Page)
[5] Template
< Comment
< Comment
@ customImage
¢ imagepidth
% BreakafterSection

e O 3 0 B R
[ ¢ ¢ ¢ ¢ © ¢ ¢ ¢ ¢ ¢ ¢ ¢ ¢ ¢ ¢ ¢ ¢ ¢ ¢

T [F] o] [ [

Controls and Parameters

You can add parameters to control how things appear. In the Advanced Editing mode, the structure
of the Short (abbreviated) Solution Name entry is a global attribute that contains a control and a
label. For example, the control type known as textbox allows anyone to type a name that appears in
the generated document. Use the Properties view to edit controls.

Designer’s supported parameters or values for controls include the following:

Table 16-4 Supported Parameters

Control Parameter or Value Description
Table columns=“3” Number of columns to show in the Control.
header=“date” Column header text.
width="30" Column width for each column.
label=“show this” Explains what you see in this control.
addrows Displays a button to perform this function.
removerows Displays a button to perform this function.
File extensions=".jpg;*.gif’ Supported extensions separated by a semicolon
(*.9pg;*.jpeqg;*.gif). (One file only.)
label="show this” The label explains what to perform with this
control.
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Control Parameter or Value Description

Select (Identity option=“font 1” Parameters allow font point selection, such as

Manager System/ option="font 2” option = “20pt” and option = “24pt”

font Settings) label=“show this” The label indicates what you can do with this
control.

Checkbox label="show this” The label explains what you can perform with

this control. It includes a check box.

Textbox or label=“show this” The name gives a title to the text box or text
Textarea area control. You edit these controls through the
Properties view.

Comment label=“show this” Allows you to add comments to help guide
users. You edit this control through the
Properties view.

16.6.2 A Walk-through Tutorial

Now that you better understand what components are necessary in order to add advanced
functionality to your template, use this section to create a new section, add an attribute, and view the
source.

+ “Creating a New Section in a Style” on page 327

¢ “Adding an Attribute to a Style” on page 327

¢ “Getting Documents to Recognize Your Additions” on page 328

* “Viewing the Source” on page 333

Creating a New Section in a Style
To insert an additional section into the Style Editor:

1 Create or open an existing . docgen file in the Style Editor.
2 Click the Enable Advanced Editing icon. g

The tree view of the document outline expands to include additional objects, (such as attributes,
template, and parameters).

3 Right-click the parent section where you want to add your new section, then select New Child
> Section. Specify a new section name; for this example, call it “My Section.”

4 (Optional) Reorder the section by dragging the section object to a different location in the
navigation tree. You can also copy and paste within this style or other styles.

5 Click the Save icon, then continue with the next section.
Adding an Attribute to a Style

1 Right-click a section under the Style Editor view. Select New Child > Attribute.

2 Specify the attribute name in the Attribute Name window. For example, MyAttribute with no
spaces. Click OK.
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3 Specify a value under the Value property in the Properties view. For example, This is my
attribute value.

Policy Set | &l Properties 22 5|3 ¥ = A #-5| 1.1. Legal _
+-[E] 1.2, Document History
Property Yalle 53 1.3 My Section
Global % false I v At ILite
Group = =-[E] 2. Project Information
Marme '%Myﬁttrihube +- % BreakafterSection
Nis 1D If o _ +-[E] 2.1, Executive Surmary
Walue '=This iz my attribute value #-5 2.2 System Overview
+-[E] 3. Project Configuration

The Properties view shows the following values of Attributes (attributes are defined through
controls and parameters).
¢ Global: passed down to subsections

¢ Group: used to group attributes together--these appear as part of a tab in Style Editor’s simple
mode

+ Name: the attribute’s name
NLS ID: the attribute’s NLS identification

*

*

Value: the attribute’s value

You can also show your attribute with another control type. The following example first creates a
control, then changes the control type from check box (the default) to something else, such as a text

area.
1 Right-click MyAttribute and select New Child > Control.

2 With your cursor on the control you just created, change the control type value to Text Area in
the Properties view.

3 Click your section to see the changes take place.

Palicy Set [ b B E ¥ =0 #-El 1.1, Legal _
+-[E] 1.2, Document History
Property - [8 1.3. My Section
Type 2 @ Myatribute

Bl Contral frextho)
=-[E] 2. Project Information
+- ¢ BreakasflerSection
+-[E] 2.1, Executive Summary
+-[E] 2.2, Systerm Cwerview

Check Box

Select

Getting Documents to Recognize Your Additions

After you have added attributes, your generated document doesn’t include information from these
attributes until you do one of the following:
+ Make sure your section is a leaf section (does not contain child sections).

¢ Create a template that uses the attribute explicitly. This is usually the preferred method because
you can display the attribute values exactly the way you want by describing the layout using the
template.
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Method 1: Set the Section Source to “Style”

If you create a section without a template (and the template is a leaf section containing no section
children), the default template generates the attribute values with the document. You do not need to
do anything. You can generate a document for just that section by right-clicking the section head and
selecting Generate Documentation for This Section. Or you can click the Generate Document icon
at the top to generate the whole document.

NOTE: Text boxes, text areas, and tables are the only attributes that are generated through the
default template (check boxes, selects, and comments are not generated).

Method 2: Add a Template for a Custom Layout
Complete the following tasks:

¢ “Creating a Template” on page 329

¢ “Creating Another Section and Template” on page 331
Creating a Template

1 Right-click your newly created section.
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2 Seclect New Child > Template.

Section Template
<?xml version="1.0" encoding="UTF-8"0><xsl:stylesheet version="1.0" xmlns:fo="htop:// 1A
<ksl:import hrefs"dgSsction.xsl"/>

<x&l:pacam name="DOCUMENT DATE"/>
<x3l:param neame="SOLUTION NAME"/:
<xsl:param neme="SHORT SOLUTION NAME"/>
<xzl:iparam name="DOCUNENT TYPE"/>
<xsl:pacam neme="CLIENT NANE"/>
<xsl:param name="SHORT_CLIENT_NAHE"H>
<x3l:param name="CLIENT NUHNBER"™/>
<xsl:param name="PREPARED BY"/>
<¥sl:param neme="50W NUNBER"/>

<¥sl:pacam name="custonlmage’/ -
<x#sl:param name="imageWidch”/ >

<isl:template name="Section.Content":
<fo:block>
<¥3l:1f test="§SO0LUTION MNAME '= '' or §$SHORT SOLUTION NAME != ''":
<fo:block space-after="{JFONT_SIZE_4)">
Solution: <x=2l:value-of select="§SOLUTION NAME"/>
<k=l:if test="{SHORT_SOLUTICN NAME != ''®:
(<xal:value-ol selecc="§5HORT SOLUTION NAME™/:
<lxsliif>
</ Torblocks
<fx=l:if>

<x8l:if ceste"§PREFARED BY i= '!Ms
<fothlock space-after="{JFONT_SIZE 4) ">
Prepared by: <xsl:value-of selecc="§PREPARED BY"/>
</ fosblock>
</xsl:ifs
<x3l:if test="§CLIENT NAME != '' or S5HORT_CLIENT NAMNE != '''">
<fothlock space-atter="{3FONT SIZE 4)">
For Client: <xsl:value-of select="{CLIENT NAME"/>
<x2l:1f tesc="}5HORT CLIENT NANE |= *'#>
{<xsl:value-of selecc="§{SHORT_CLIENT NAME"/:)
<fusl:if>
</fo:rblocks
</fxsliil>
<xsl:if test="$§CLIENT NUHBER != ''">
<fo:block space—sf:er=”l$FONT_SIZE_4}"b
Client number: <xsl:value-of aselect="3CLIENT NUMBER"/>
</fo:block:>
</xsl:if>
<x5l:if test="{DOCUMENT DATE != '!®:
<to:block space-attec="{JFONT_SIZE_4;">
Document Date: <xsl:value=of select-"$DOCUHENT_DATE"Jb
</fo:block>

24

The template has some default content that consists mostly of comments, which helps you get
started on your first template. This is shown in the next task; for now, replace the comments in this
template with the following XSL commands:

<xsl:param name="MyAttribute"/>

<xsl:template name="Section.Body">
MyAttribute:
<xsl:call-template name="Format.OutputTextArea">
<xsl:with-param name="value" select="$MyAttribute"/>
</xsl:call-template>
</xsl:template>

There is a Format.OutputTextArea call in the XSL that is a helper function included with the
DocGen Core Support Templates. Because HTML code is allowed in text areas, this ensures that it’s
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interpreted and escaped properly. If you want to see the core XSL library calls for documentation
generation, see “Document Generator Core Support Templates” on page 525.

Your template should look like this:

Figure 16-8 Example Template

<?¥ml wersion="1.0" encoding="UTF-3"2>
<xzl:atylesheet version="1.0" =xmlnzs:xsl="http:/ /www.wd.org 1
<¥slrimport href="dgfection.x=1"/>

<Hzliparam name="Myittribute”/>

<¥zl:template name="Section. Body™>
Myittribute:
<xsl:call-template name="Format.OutputTextirea™s>
<xsl:with-param name="value" aelect="iHyittribute™/»
</fH=zlipall-template:
</xalitemplates

</xslistylesheets

Generating a document for this section should give you something like this:

Figure 16-9 Sample Section

1. MySection

MyAttribute:
This is my attribute

Creating Another Section and Template
1 Right-click your newly created section and select New Child > Section. In the Section Name
window, name the new section Table of Contents and click OK.

2 Right-click this new section and select New Child > Template. Carefully read through the
comments in this template. These details are important.

When you create a custom section, you are inserting some information into the document. As
the comments mention, developers usually override one of the following template functions:

¢ Section Body (most common)
+ Section Content

+ Section Title
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The following image illustrates which section is being defined. As a developer of the style, you
write this template to overwrite the area that is of interest.

e
2.1 Executive Summary } Section Title
=

This company operates a Meta
Directory and other various
information systems where
identity information related to
employees and user accounts
Section Content 4 are stored and maintained

> Section Body

The administrator of portal
users is seamlessly integrated
in thie exisbing user
administration process.

L P

2.1.1 Account Details
Section Main 4 Section Childran
l Some of the accounts include
Information on the ge—""

For this example, we are going to overwrite the Section.Body because we don’t want to change
the default behavior of the Title, nor do we want to change the way other sections are related to
this one. (You can use the hierarchical view to control this with the default template anyway).

3 To overwrite the Section Body, we simply uncomment the sample function that is shown in the
default template. This is shown below:

Section Template

<?xml wersion="1.0" encoding="UTF-5"">
<xsl:stylesheet version="1.0" xmlns:xsl="http:/ www.ws.org/:
<xsliimport href="dgiection.x=1"/>

le— fEE
* Table of Contents exsmple (remove comoenting helow

This template assumes you have your sSection source
to 'style' (the defasult wvalue), and demonstrates hi
render data taken from an XML source.

EE

wo——=
“Hslitemplate nawe="Iection., Body™s
<foihlockrHere iz my Table of Contents:</fo:block:
<¥aliapply-templates/ >
</xslitemplate>

<xsl:template match="children:>
<fo:block margin-lefc="{count (ancestor: %) rem™> - <xslis
<xsl:apply-templates/>

</usl:templatesr

</x=liatylesheet>

2l |

If you render your document at this point, you get no content in your Table of Contents (other than
the surrounding text). This is because this template assumes that the style source has been specified
for this Section. To specify the source:

1 Click the Table of Contents section.

2 From the Properties view, set the source to style.
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3 Right-click MySection and select Generate Documentation for This Section.

Sample

1. My Section

MyAdttribute:
This is my attribute value.

1.1. Table of Contents

Here is my Table of Contents:
- My Section
- Table of Contents

Viewing the Source

When your generate your document, you’ll notice there is an option to Output XML Source Files.
Click the box next to this option to turn it on. You’ll see .xm1 source files appear where you are
generating the document. These source files are the XML data that is used in your template when
you set the source (for example, to “style”). Designer 1.1 and above include the following sources:

Table 16-5 Sources

Source Key Description

none An empty source, used when no source is specified or when “none” is specified.
style The XML source of the style, used to build things like the Table of Contents.
designer A source that has been defined by an extension point for the Designer model. This

contains all information about the configuration of your Designer project.
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16.6.3 Selecting a Language for Generated Documents

You can also select the language you want to print the document in.

1 Click Window > Preference > Designer for IDM > Document Generation. Under the
Document Language heading, select the language you want to use for document generation.

@ Preferences CE&E
type filter text Document Generation 4= v
General
= Designer for IDM General

Configuration [¥] sutomatically open the rendered file after document generation

Docurment Geners [l show warning dialog box when the style is an older version

Entitlements [“]Enable RTF support (experimental)

iManager

Impart/Deploy Modeler

Language []Document applications and drivers related to other selected items
Modeler

Document Appearance

Policy Build
- |_cy Hier Select the language you want the document to generate in:
Project Checker

Scherna 3

Sirnulation
Trace
Help
Movell
Provisioning
Web and XL

cumentation:

[ H

[ F

IResmre Defaults ] [ Apply l

@ I 0K ] I Cancel ]

Present languages include:

¢ Chinese simplified

¢ Chinese traditional

¢ Dutch

+ English (default)

+ French

¢ German

¢ [talian

¢ Japanese

¢ Portuguese Brazil

* Spanish
2 Once you select a language, click Apply.
3 Click OK to close the Preference page.
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16.6.4 Double-Byte Font Support

Designer now has double-byte font support for the Document Generation feature. If you select a

language that uses double-byte fonts, such as Chinese Simplified, Chinese Traditional, and

Japanese, Designer automatically installs the font Proportional Mincho.

Figure 16-10 Selecting a Double-Byte Font Language

@ Preferences EIE)E

Policy Builder
Project Checker
Scherna
Sirnulation
Trace

Help

Mowell

Provisioning

Wb and XML

) B B

type filter tesdt Document Generation B e
General
= Designer for 1D General
Configuration [] sutamatically apen the rendered file after document generation
Docurnent Geners [“]show warning dialog box when the style is an older version
Entitlarnents [¥]Enable RTF support (experimental)
iManager
Import/Deploy Maodeler
[“]Dacument applications and drivers related o other selected items
Language PR
Modeler

Document Appearance
Select the language you want the docurment to generate in:

Select the font to use for docurmentation:

Proportional Mincho

IResmre Qefaults] I Apply

l

[ Ok l [ Cancel

]

For English and other languages, the default font is Arial.
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To add a font for your specific language:

1 Click Window > Preference > Designer for IDM > Document Generation. Under Font
Settings, select the font you want to use.

| type filter text | Document Generation A=l 5
#- General
= Designer for IDM General
- Configuratian [¥] sutomatically open the rendered file after document generation
-Document Geners [V]Shaw warning dialog box when the style is an alder version
- Entitlernents [“]Enable RTF support (experimental)
- Manager
- ImportDeploy Modeler
- Language [“]Document applications and drivers related to other selected items
5 Moldeler " Document Appearance
Policy Builder
s ,Y Select the language you want the document to generate in:
- Project Checker ;
.Schema | English w
- Sirmulation )
Trace Select the font to use for documentation:
-Help |Aria| v|
3 —
N EE
& Lok i | age Mew CDrive (] vl (€] T > Er
Y (D) DELL IC2)Program Files
§ :, () docsysx i Temp
My Recent | |[)Documents and Settings  [Sjuser
i Documents | [5) downloads 15 WINDOWS
— (CIORIVERS [ skt
@ E: Sled
Desktop ii_j ERSON
|2 queclient
. (5 gwsetup
’_/' 1386
Py Diocuments E:EPS
- . () Movell
iProjg ‘ij [ MwC49tinst all
- (C000Install113
ty Compriter
Jever, ]
L Filz name: !times.ttf Vl [ Open J
My Metwork. Files of type: | TrueType Font [ ttf) w | [ Cancel ]

To change the font on a Windows workstation, you must first copy the font file from the
C:\Windows\Fonts directory to another directory. You can then use the Browse button to
select the font.

To change the font on a Linux workstation, browse to the usr/share/fonts/truetype
directory, or to another directory containing the fonts you want.

Click the Browse button to bring up the Open window, then change to the directory where you
placed the font, then click Open.

You can also type the directory and font file name into Font Settings field, or use the pull-down
menu to select a font that you have previously selected.

3 Click Apply, then click OK.
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Using the above steps will change the font globally in the generated document, as well as add
double-byte font support for such selections.

16.6.5 Saving a Style File in the Styles Template Library

Designer provides one or more default styles that you can use to generate documentation for your
project. The Default Style.docgen file is stored in the
Novellldesigner\eclipse\plugins\
com.novell.designer.idm.docgen.editor 2.0\content\styles folderand is
displayed as an option when you choose a new style.

You can add your own style files to the . . . \content\styles folder so that you can easily find
them when choosing a basis for a new style.

1 Locate the . docgen file you want to add.

By default, the file is in a directory inside the project where you saved it. For example, the
Blanston?2.docgen file was created in the
workspace\Blanston2\documentation directory.

2 Copy the . docgen file into the Styles Library
(Novell\designer\eclipse\plugins\
com.novell.designer.idm.docgen.editor 2.0\content\styles). The
.docgen file appears in the styles folder the next time you open Designer and generate a
document.

@ Generate Documentation &3]

Select a Base Style

Define your document's formatting by selecting a Style to serve as your model,

Styles:

2= styles
Blanstonl.docgen
Default_Style.dacgen

[ Provisioning Style

=1l Blanstonl
Blanstonl.docgen

sl Blanstonz

| Blanston3

2| Blanstong

7 I Mext = ] I Einish ] I Cancel ]

16.7 Troubleshooting Issues When Generating
Documents

For information on troubleshooting issues that you encounter when generating documents, see
Section 24.5, “Issues When Generating Documents,” on page 509.
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Managing Entitlements

Identity Manager allows you to synchronize data between connected systems. Entitlements allow
you to set up criteria for a person or group that, once met, initiate an event to grant or revoke access
to business resources within the connected system. This gives you one more level of control and
automation for granting and revoking resources.

Use Designer to create entitlements and deploy them into existing Identity Manager drivers.
Designer allows you to create entitlements through the Entitlement Wizard, which gives you a
graphical interface where you can create the entitlement and steps you through the process. Because
of its graphical interface, we recommend using Designer for creating and editing entitlements.

There are four aspects to making entitlements work effectively: design, creation, editing, and
management.

¢ Section 17.1, “Designing Entitlements,” on page 339

¢ Section 17.2, “Creating Entitlements through the Entitlement Wizard,” on page 342
¢ Section 17.3, “Editing and Viewing Entitlements,” on page 354

¢ Section 17.4, “Managing Entitlements,” on page 359

17.1 Designing Entitlements

You must know beforehand what you want to accomplish with entitlements. Entitlements work from
the functionality you build into Identity Manager drivers through policies. These driver policies
implement rules and process the events between the Identity Vault and the connected system. If the
policies in the Identity Manager driver do not specify what you want to do, entitlements cannot
work. For example, if you don’t specify the action section of the Check User Modify for Group
Membership rule in the Command policy, attempts to grant or revoke a group membership
entitlement are ignored.

When you know what you want to accomplish with Identity Manager, you can correctly design
granting and revoking capabilities for any connected system resources. The following four-step
procedure can help you plan to create and use entitlements:

1. Know what you want to accomplish in your business situation. You can design and implement
many business solutions through Identity Manager, but you need to know what you want to do
before implementing something that isn’t defined. Make a numbered list of what you want to
do.

2. Define an entitlement that represents one item from your numbered list. You can create
valueless and valued entitlements. Valued entitlements can get their values from an external
query, they can be administrator-defined, or they can be free form. There are examples in
Section 17.2, “Creating Entitlements through the Entitlement Wizard,” on page 342.

3. Add policies to the Identity Manager Driver to implement the designed entitlement. To create a
policy for an Identity Manager driver, you need to be conversant with XSLT or DirXML®
script, in the way the connected system handles and receives information, and with the way
Novell® eDirectory™ stores information. Unless you are a good DirXML programmer, this is a
job for consultants.
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4. Set up a managing agent to grant or revoke the entitlement. If you want an automated process,
use Role-Based Entitlements; if you want a manual process, use the User Application’s
workflow-based provisioning feature. See “Identity Manager Installation Programs and
Services” in the .Identity Manager 3.5.1 Installation Guide.

¢ Section 17.1.1, “Terminology,” on page 340

¢ Section 17.1.2, “Entitlement Prerequisites,” on page 340

¢ Section 17.1.3, “Identity Manager Drivers with Preconfigurations that Support Entitlements,”
on page 341

¢ Section 17.1.4, “Enabling Entitlements On Identity Manager Drivers,” on page 341

17.1.1 Terminology

Following are some terms that are used throughout this section.

Table 17-1 Terminology

Terms Explanation

Entitlement An |dentity Vault object that represents a business resource in a connected
system.

Entitlements Service Grants and revokes entitlements. For Role-Based entitlements, the agent is

Driver the Entitlements Service driver that must be initiated for entitlements to
work.

Grant or Revoke Granting or revoking an entitlement is controlled by Global Configuration

Variables (GCVs) on an Identity Manager driver.

Entitlement Consumer  Anything that uses entitlement-related information. Entitlement consumers
include iManager, the User Application, and Identity Manager policies.

17.1.2 Entitlement Prerequisites

O eDirectory 8.7.3.3 or later with the latest Support Pack (SP8 or later)
O Identity Manager 2 or 3
O An Entitlements Service driver

You must have an Entitlements Service driver in each driver set where you want to use
entitlements. This requires a very simple, two-step setup for each driver set. To do this, see
“Creating an Entitlements Service Driver Object ” in the Novell Identity Manager 3.5.1
Administration Guide.

O A driver configuration that supports entitlements
Before you can use entitlements with a connected system, do one of the following:

¢ Import the Identity Manager driver configuration for the driver and specify that the driver
has entitlements enabled.

+ Enable your driver to support entitlements. To do this:

a. Create entitlements using Designer.
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b. Add the DirXML-EntitlementRef attribute to your driver filter as described in
Section 17.1.4, “Enabling Entitlements On Identity Manager Drivers,” on page 341.

c. Write policies to implement the entitlements you create in Step 1 under Section 17.1,
“Designing Entitlements,” on page 339.

17.1.3 Identity Manager Drivers with Preconfigurations that
Support Entitlements

Identity Manager comes with several preconfigured drivers that already contain entitlements,
policies to implement the entitlements, and the driver enabled to listen for entitlement activities. You
must enable entitlements when you initially install preconfigured drivers in order to add the
preconfigured elements to the driver’s structure. The following drivers have preconfigurations that
support entitlements:

¢ Driver for Active Directory: Grant and revoke accounts, group membership, Exchange
Mailbox

¢ Driver for Exchange 5.5: Grant and revoke mailbox and group membership

¢ Driver for GroupWise: Grant and revoke accounts, grant and revoke members of distribution
lists

¢ Driver for LDAP: Grant and revoke user accounts

¢ Driver for Linux and UNIX: Grant and revoke accounts

¢ Driver for Lotus Notes: Grant and revoke user accounts and group memberships
¢ Driver for NT Domain: Grant and revoke user accounts and group membership

¢ Driver for RACF: Grant and revoke group accounts and group memberships

These preconfigured drivers fulfill the first three of the four steps outlined in Section 17.1,
“Designing Entitlements,” on page 339. They contain example entitlements and policies that you
can use as is if they meet your needs; you can also change them to better meet your needs, or you
can use them as examples and make your own entitlements through Designer.

17.1.4 Enabling Entitlements On Identity Manager Drivers

Before you can use entitlements, you must first ensure that your driver has entitlements enabled.
You can do this through the Entitlements Wizard as you finish creating entitlements; this applies to
both preconfigured and non-preconfigured drivers.

However, if you want to use the preconfigured driver’s entitlements and the infrastructure that
supports them, you must enable entitlements when you initially create a driver in Designer or
iManager; the preconfigured policies and rules that support the preconfigured entitlements cannot be
added later without re-creating the driver. If you import a driver that has entitlements enabled into
Designer from an Identity Vault, the imported driver also has entitlements enabled. If you deploy a
driver that has entitlements enabled into an Identity Vault, the deployed driver also has entitlements
enabled.

You can see if your preconfigured drivers have entitlements enabled by clicking the Outline view,
then clicking the Subscriber channel of your selected driver. If entitlements are enabled, you should
see the preconfigured entitlements appear under the Subscriber Channel. If entitlements do not
appear under the Subscriber Channel in the Outline view, entitlements were not enabled when the
driver was initially installed.
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However, you can still use entitlements on preconfigured Identity Manager drivers that do not have
entitlement preconfigurations enabled. To do this, run the Entitlement Wizard. The last page in the

Entitlement Wizard asks if you want to add the DirXML-EntitlementRef attribute to the driver filter,
with Yes selected. Click OK. However, because the policies and rules are not in place on the driver,
you won’t be able to use their preconfigured entitlements without adding those supporting policies

and rules yourself.

Figure 17-1 Enabling Entitlements
@ Add To Filter 3]

?/ To enable entitlzments for this driver, the DiFXML-EntitiementRef

= stiribute needs to be added o the Liser class in the driver filter
If you want to enable entitlerments for another class, you can do
50 from the filker editor,

Do you want Designer to enable entitlements for the User class in the
driver filker for you?

[Iremermber selection. Don't prompt again.

[ CK ] [ Cancel ]

You can also use entitlements on Identity Manager drivers that do not contain entitlement
preconfigurations. To enable your driver to support entitlements, add the DirXML-EntitlementRef
attribute to your driver filter. Run the Entitlement Wizard as described above to add the DirXML-
EntitlementRef attribute to the driver filter.

17.2 Creating Entitlements through the
Entitlement Wizard

Designer comes with an Entitlement Wizard. This wizard steps you through the creation of
entitlements by asking a series of questions about how the entitlement will be used in the enterprise.
Use one of the following methods to access the Entitlement Wizard:

From the Outline View

To access the Entitlement Wizard from the Outline view, right-click a Driver object, then click New
> Entitlement.
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Figure 17-2 Adding an Entitlement through the Outline View

=8 ¥ croupiiise
M = Credential Application. ..
Copy ¥ | % Credential Repository...
Dir¥ML Script...
& Show Dataflow view 5 O Fr|p
FEF ECMASCHipt.
& Simulate... & Entitlement...
(B Show Policy Sets & Job...
K£] Run Configuration Wizard... B Mapping Table...

5= Resource...

% Password Synchranization...

—
& Manage Application Schema... M2 Schema Map...

TF XELT..,
Document selection, ..,
A Export to Configuration File. .. From Copy...
Live 4
¥ Delete

or rm Distribution Password
Properties

From the Modeler View

To access the Entitlement Wizard from the Modeler view, right-click the driver icon, then click New
> Entitlement.

There are two types of entitlements that you can create: valueless and valued. The type you use
depends on whether you need to pass additional information to the policies.

¢ Section 17.2.1, “Valueless Entitlements,” on page 343

¢ Section 17.2.2, “Valued Entitlement that Queries an External Application,” on page 345

¢ Section 17.2.3, “Administrator-Defined Entitlements with Lists,” on page 351

¢ Section 17.2.4, “Administrator-Defined Entitlements without Lists,” on page 353

17.2.1 Valueless Entitlements

A valueless entitlement has no values to go with it. An example is the Account Entitlement for
Active Directory, which is used to turn on account capabilities. You use valueless entitlements if you
don’t need to pass any extra information to driver policies.
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To create a valueless entitlement:

1 Right-click the driver icon in the Outline view or in the Modeler view, then click New >
Entitlement.

@ New Entitlement Wizard 3]
e

Mame Entitlement

Give the entitlerment a name and a description.

Marme: | Account

W Use name for display name

Display Marne: |

Description: | This is an Account Entitliement,

@ | Mext = | Cancel

2 Type the name and description information. For this example, the entitlement is named
Account, with a description of “This is an Account Entitlement.” Click Next.

@ New Entitlement Wizard 3]

Set Entitlement Yalues
You can set values on an entitiement for use by policy or other entitliement consumers,

Do you want this entitierment to include valuss?
@ No

(1) Choose this if your entitlerment doesn't require values,
Oves

(1) Choose this if you want to query values from an application or to define a group of
values,

I Finish ] ’ Cancel ]

3 Because this first example is valueless, select No to Do you want this entitlement to include

values?
4 Click Finish.
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5 In the Add To Filter dialog box, answer Yes if you want the driver to listen for this entitlement.
This enables entitlements for the driver.

@ Add To Filter 3

?/ To enable entitlements for this driver, the DirkML-EntitlementRef
e atiribute needs to be added to the User class in the driver filer.
If you want to enzble entitiernents for another class, you can do
so frorm the filtter editor,

Do you want Designer 1o enable entitliements for the User class in the
driver filter for you?

OMo

[CJrRemember selection. Don't prompt again.

I Ok l ’ Cancel ]

The DirXML-EntitlementRef attribute allows the driver filter to listen for entitlement activities.
This is necessary in order to use the entitlements you are creating.

If you don’t want to see the Add To Filter window on every entitlement you are creating for any
driver in Designer, select Remember Selection - Don t Prompt Again, then click OK. However,
after the attribute is added to this driver filter, you won’t see the Add To Filter window again.

17.2.2 Valued Entitlement that Queries an External Application

Values are a way of passing data that you might need to use in policies. Valued entitlements can get
their values from an external query; they can be administrator-defined, or they can be free-form.
Below are four examples of the entitlements that you can create.

The second example is an application query entitlement. Use this entitlement when you need values
from a connected system in order to implement entitlements in that system.

1 Right-click the driver icon in the Outline view or in the Modeler view, then click New >
Entitlement.
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2 Give the entitlement a name. This example uses Application Query, with the Use Name for
Display Name option selected. In the Description box, type Looks for the Class name
of Groupx, then click Next.

@ New Entitlement Wizard &)

Mame Entitlement

Give the entitlement a narme and a description.

Marme: | Application Query

W Lse name for display name

Display Mame: |

Description: | | aoks for the Class name of Groupsx

Cancel

3 On the Set Entitlements Values page, select Yes so you can query values from an application or
define a group of values, then click Next.

4 The next Set Entitlements Values page allows you to define where you get the values for this
entitlement. Valued entitlements can get their values from an external query, or they can be
administrator-defined. For this example, select the Values from Application Query option, then
click Next.

@& New Entitlement Wizard

Set Entitlement ¥alues

Define where to get the values for this entitlement.

This entitlement will hawe:
O adrinistrator-defined values
(@) Chanse this if you want an entitiement that defines

attributes {phone number, office location, etc.) to be set in
an application,

@i\.{gllues from an application guery.:

(@) Chanse this if you want an entitiement that allows a user o
becorme a mermber of & group in an external application,
The groups wsed are queried from the application.

J

@ < Back “ Mext =
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The Define Application Query window combines two steps: defining the query and mapping
the query results. To define the query, fill in the Class, the Base DN (Distinguished Name), and
the Scope (subtree, entry, or subordinates). Then map the query results to values that are used
by the entitlement consumers (either iManager for Role-Based Entitlement policies, or the User

Application for workflow entitlements).

5 To fill in the Class Query, click the Schema Browser button on the right side of the Class entry.

@ Schema Browser 3]

Classes ] Attributes |

Classes: @h

DirX¥ML-StyleSheet
Dir¥ML-Subscriber
dmd

damain

dsSa

dynamicGroup
dynarmicGroupau
edirSchemat'ersion
External Entity

FederatiunBuundari

hamelnfo

httpServer
ieeeB02Device
immediateSuperiorReference
ipHost

ipMetwork

ipProtocol

ipService
iscsilnitiator
isCsilnitiator o
isCsiServicadun

[ Only show changes

K | Cancel | ﬂ

6 The Schema Browser shows you the Classes in the eDirectory namespace that are available to
choose from (the Attributes tab shows you which attributes are part of the Class). If you know
the name of the Class type you want to query, click to select a selection in the Classes tab, then

Managing Entitlements 347



start typing the Class name. The browser jumps to the alphabetical order of what you type.
Select the Class name, then click OK.

@ New Entitlement Wizard ]

Define Application Query .

Define an application guery that will return value(s) to be used by !‘E
this entitlerment.

Enter a class to query

o

Class: | Graup

Enter a base DN and select a scope to search from
Base DN: |E.Ians133n Scope: subtree| -

Map query results to values used by entitlerment consumers

Yalue From Query =+  Yalue Used by Entitlement Consumers

|SDUFCE Distinguishec j 5+ "Digplay-Mame" shown to entitlement consumers

|Descripti0n j 5 "Description” shown 10 entitlement cansumers

|Assuciati0n j = "alue" used by policy

@ < Back | Mext = | | Cancel

7 Type the base distinguished name (DN) and the scope. For this example, select the Class
Group, at the Base Distinguished Name of Blanston, with the Scope of subtree (choices are
subtree, entry, and subordinates).

Our example maps the query results from the connected system to certain values that
entitlement consumers can use. At present, the consumers are iManager managing Role-Based
Entitlement policies and the User Application managing workflow-based provisioning
entitlements. The Value From Query information pre-populates the consumer’s user interface
with the following:

+ Display Name: Defines the attribute that displays in the list of values. The example
selects Source Distinguished Name for the display name. Click the drop-down button on
the Display Name shown to entitlement consumers list to see a list of Attributes associated
with the class you selected through the Schema Browser. The list includes both the
Attributes and the Inherited Attributes for the selected class.

+ Description: Defines the attribute that displays as a description for that value. For the
description, select Description from the Value drop-down list to map the query results
from the connected system to the entitlement.

¢ Value: Defines the attribute or token that is the actual value. The Value entry is not seen in
the entitlement consumer, but it is the value that is assigned when the entitlement is
granted or revoked. In this case, choose 4ssociation.

If you do not use the Schema Browser button when selecting the class, you see only two
selections in the Value From Query lists: Association and Source Distinguished Name. If these
attributes suit your needs, use them. You can also type the attribute name into the text field.
However, if you want to select the attributes from the lists, use the Schema Browser button
when selecting a class for the query. You see the attributes and inherited attributes for the
selected class.
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9

10

1"

12

When the values are filled out, select Next.

In the Assign Multiple Values window, select Yes if you want the entitlements to be granted
more than once and with different values. If you select No, the entitlement can only be granted
once.For our example, click Yes, then click Next.

It makes sense to assign group entitlements with multiple values, but it would not make sense
to assign an account entitlement more than once.

You are asked if this entitlement is intended to be used by Role-Based Entitlement policies
through iManager. If you want this entitlement to be granted or revoked automatically, select
Yes to the Role-Based Entitlements question, click Next, then continue with Step 11.

Or

If you want the granting or revoking of this entitlement to be a manual process (approved by
someone), select No to use the User Application, then skip to Step 12.

We recommend that you have only one agent control an entitlement. If multiple agents are in
control, you have the following consequences:

+ Whoever comes last controls the entitlement results
¢ Results are unpredictable
+ Using both agents to control an entitlement is not supported by Novell

(Conditional) If you select Yes to the Role-Based Entitlements question, you are asked if you
want to use the Role-Based Entitlements priority to resolve any conflicts that might happen
when this entitlement is assigned more than once with different values. You can resolve the
conflict by either using Role-Based Entitlements priority, or by merging the values.

Merging the values merges the entitlements of all involved Role-Based Entitlement policies, so
if one policy revokes an entitlement but another policy grants an entitlement, the entitlement is
eventually granted. Solving conflicts by priority works if you need to ensure that only one
policy is applied to this entitlement at any time. This example uses priority.

Click Finish.

For this example, the query values look for the Source Distinguished Name attribute of the
Class name of Group, starting from the Base DN (Blanston) and checking through the subtree
from that beginning point. The values that come back from the query are similar to the
following:

<instance class-name="Group" src-dn="o=Blanston, cn=groupl">
<association>o=Blanston,cn=groupl</association>
<attr attr-name="Description"> the description for groupl</attr>
</instance>
<instance class-name="Group" src-dn="o=Blanston, cn=group2">
<association>o=Blanston,cn=group2</association>
<attr attr-name="Description"> the description for group2</attr>
</instance>
<instance class-name="Group" src-dn="o=Blanston, cn=group3">
<association>o=Blanston, cn=group3</association>
<attr attr-name="Description"> the description for group3</attr>
</instance>
<l== .0 =>

The information received from the query fills in the various fields. For instance, the
<display-name> field receives o=Blanston,cn=groupl. The <description> field
receives the description for Groupl, and the <ent-value> field receives
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o=Blanston,cn=group1. Because more than one group exists and meets the query criteria, this
information is also collected and shown as other instances of the query.

The association format value is unique for every external system, so the format and syntax are
different for each external system queried.

13 At the Add To Filter window, click Yes if you want the driver to listen for this entitlement. This
enables entitlements for the driver.

@ Add To Filter 3

?/ To enable entitlements for this driver, the DirkML-EntitlementRef

e atiribute needs to be added to the User class in the driver filer.
If you want to enzble entitiernents for another class, you can do
so frorm the filtter editor,

Do you want Designer 1o enable entitliements for the User class in the
driver filter for you?

[CJrRemember selection. Don't prompt again.

I Ok l ’ Cancel ]

The DirXML-EntitlementRef attribute allows the driver filter to listen for entitlement activities.
This is necessary in order to use the entitlements you are creating.

If you don’t want to see the Add To Filter window on entitlements you are creating for any
driver in Designer, select Remember Selection - Don t Prompt Again, then click OK. However,
after the attribute is added to this driver filter, you won’t see the Add To Filter window again.
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17.2.3 Administrator-Defined Entitlements with Lists

The example in the following procedure is an administrator-defined entitlement that allows you to
select a listed entry. This type of entitlement is best used through Workflow entitlements rather than

Role-Based Entitlements.

1 Right-click the driver icon in the Outline view or the Modeler view, then click New >

Entitlement.

@ New Entitiament Wizard

Mame Entitlement

&3] | Mext = |

o0
Give the entitlement & narme and a description, !‘LE
Mame: |Admin-deﬁned
I Use name for display name
Display Mame: |Admin—deﬁned Entitlement
Description: | This will show Administrator-defined values,
Cancel

In this example, the entitlement name is Admin-defined, but the defined display name is
Admin-defined Entitlement. You need to define a display name only if you want the display
name to be different from the name you called the entitlement; otherwise, you can just use the
entitlement name as the display name. In this example, the Description field is defined as This

will show Administrator-defined Values.
2 Click Next.

3 In the Set Entitlement Values window, select Yes to the question “Do you want this entitlement

to include values?” Click Next.

4 In the next Set Entitlement Values window, select Administrator Defined Values, then click

Next.
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5 In the Define Values window, type the values you want to add to the Entitlement Value entry,
click Add to add the value to the Defined List pane, then click Next.

@ New Entitlement Wizard &)

®
Define Yalues .. '
Entitlement values can be taken from a defined list, or they can be entered by entitlement consumers., 1 g;_%

Do you want to define a list of values?

@ ves
(@) Chaonse this if you want to define a list of values for the entitement consumers to choose from,
OHha

(L) Choose this if you want entitlement consumers to define their awn values,

Entitlement Yalue:

Building D Add
Defined List:

Building A Remove
Building B
Building C

€] [ < Back ” Mext > l

In this example, the values are corporate buildings: Building A through Building D. Through
an entitlement client, such as an iManager Role-Based Entitlement task or through the user
application, users or defined-task managers can specify the building information, which is then
included in an external application, such as Novell eDirectory.

6 In the Assign Multiple Values window, select Yes if you want the entitlements to be granted
more than once and with different values. If you select No, the entitlement can only be granted
once. For the example, click No, then click Next.

It makes sense to assign group entitlements with multiple values, but it does not make sense to
assign building letters more than once.

7 You are asked if this entitlement is intended to be used by Role-Based Entitlement policies
through iManager. If you want this entitlement to be granted or revoked automatically, select
Yes to the Role-Based Entitlements question, click Next, then continue with Step 8.

Or

If you want the granting or revoking of this entitlement to be a manual process (approved by
someone), select No to use the User Application, then skip to Step 9.

We recommend that you have only one agent control an entitlement. If multiple agents are in
control, you have the following consequences:

+ Whoever comes last controls the entitlement results

¢ Results are unpredictable
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+ Using both agents to control an entitlement is not supported by Novell

8 (Conditional) If you select Yes to the Role-Based Entitlements question, you are asked if you
want to use the Role-Based Entitlements priority to resolve any conflicts that might happen
when this entitlement is assigned by different Role-Based Entitlement Policies with different
values. You can resolve the conflict by either using the Role-Based Entitlements priority, or by
merging the values. This example merges the values.

Merging the values merges the entitlements of all involved Role-Based Entitlement policies, so
if one policy revokes an entitlement but another policy grants an entitlement, the entitlement is
eventually granted. Solving conflicts by priority works if you need to ensure that only one
policy is applied to this entitlement at any time.

9 Click Finish.

10 If you see the Add To Filter window, answer Yes if you want the driver to listen for this
entitlement. This enables entitlements for the driver. The DirXML-EntitlementRef attribute
allows the driver filter to listen for entitlement activities, which is necessary in order to use the
entitlements you are creating.

Or

If you don’t want to see the Add To Filter window on entitlements you are creating for any
driver in Designer, select Remember Selection - Don t Prompt Again, then click OK. However,
after the attribute is added to this driver filter, you won’t see the Add To Filter window again.

17.2.4 Administrator-Defined Entitlements without Lists

The example in the following procedure is an administrator-defined entitlement that forces the
administrator to type a value. You can use this kind of entitlement if you do not have all of the
information at the initial setup, so you cannot create a task list.

1 Right-click the driver icon in the Outline view or the Modeler view, then click New >

Entitlement.
@ New Entitlement Wizard X
Q
Name Entitlement .
Give the entitiement a name and a description, ==

Marme: |Admin—deﬁned (no lists)

W LUse name for display name

Display Marme: |

Description: | There is no pre-defined list.

@ | Mext = | Cancel ‘

In this example, the entitlement name is Admin-defined (no lists), and it uses the entitlement
name as the displayed name because the Use Name For Display Name option is selected.
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2 Click Next.
3 Select Yes on the Set Entitlement Values page, then click Next.

4 Select Administrator Defined Values on the second Set Entitlement Values page, then click
Next.

5 Select No to the question “Do you want to define a list of values?” on the Define Values page,
then click Next.

This displays a text field, where the administrator or users must type information. Using this
option can be risky; if the information is wrong or is misspelled, the value is incorrect and the
action in the entitlement fails.

6 Select No to the question “Allow this entitlement to be assigned multiple times with different
values?” on the Assign Multiple Values page, then click Next.

7 You are asked if this entitlement is intended to be used by Role-Based Entitlement policies
through iManager. If you want this entitlement to be granted or revoked automatically, select
Yes to the Role-Based Entitlements question, click Next, then continue with Step 8.

Or

If you want the granting or revoking of this entitlement to be a manual process (approved by
someone), select No to use the User Application, then skip to Step 9.

We recommend that you have only one agent control an entitlement. If multiple agents are in
control, you have the following consequences:

+ Whoever comes last controls the entitlement results
¢ Results are unpredictable
+ Using both agents to control an entitlement is not supported by Novell

8 (Conditional) If you select Yes to the Role-Based Entitlements question, you are asked if you
want to use the Role-Based Entitlements priority to resolve any conflicts that might happen
when this entitlement is assigned by different Role-Based Entitlement Policies with different
values. You can resolve the conflict by either using the Role-Based Entitlements priority, or by
merging the values. This example uses priority.

Merging the values merges the entitlements of all involved Role-Based Entitlement policies, so
if one policy revokes an entitlement but another policy grants an entitlement, the entitlement is
eventually granted. Solving conflicts by priority works if you need to ensure that only one
policy is applied to this entitlement at any time.

9 Click Finish.

10 If you see the Add To Filter window, answer Yes if you want the driver to listen for this
entitlement. This enables entitlements for the driver. The DirXML-EntitlementRef attribute
allows the driver filter to listen for entitlement activities, which is necessary in order to use the
entitlements you are creating.

Or

If you don’t want to see the Add To Filter window on entitlements you are creating for any
driver in Designer, select Remember Selection - Don t Prompt Again, then click OK. However,
after the attribute is added to this driver filter, you won’t see the Add To Filter window again.

17.3 Editing and Viewing Entitlements

Designer comes with an Entitlement Wizard. This wizard steps you through the creation of
entitlements by asking a series of questions about how the entitlement will be used in the enterprise.
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However, before beginning this procedure, you should first see Section 17.1, “Designing

Entitlements,” on page 339. For information on creating entitlements, see Section 17.2, “Creating
Entitlements through the Entitlement Wizard,” on page 342.

¢ Section 17.3.1, “Entitlement XML Source and XML Tree Views,” on page 356
¢ Section 17.3.2, “Using the Novell Entitlement DTD,” on page 359

After you have created entitlements, you might need to edit them. You can also use the Edit mode to
see the entitlements in their XML source code.

To edit an entitlement:

1 From the Outline view, right-click an entitlement that appears under the Subscriber channel of
the selected driver, then click Edit.

or

Double-click the entitlement icon to bring up the entitlement in the Entitlement Editor.

You can also right-click the driver icon in the Modeler view, then select Edit Entitlements.

If you have more than one entitlement for the selected driver, you see the Edit Entitlements
windows listing the available entitlements. Select an entitlement, then click OK. The
entitlement appears in the Entitlement Editor.

] Blanstond - Developar |3 Account e o= = I [ ~polication Cuery =
Name And Descripltion

7 Vales
Specify 2 name and & description for the entitiement. Doyl weanit.,
NamiE: application Quary CONa vales
; — O pdmingramr-defned vales,

Digplay-farme:  Application Quary @ Values Fom the application

Dascription: Lacks for the Clsss name of Groupx.
Class: Group %
Base ON:  Blanston Scope:  subfres S|

value from query, Ertitlerment consumer value
Multi-Yalue

_ Source Distinguished Name | = Digplay-fame
If this entiternent i wsed to assign valies, do you want this
entitiemant 1o be assignable more than once? |Description |

= Description
() allow the enttiement 1o be assigred multpls times? Asgaciation

~ = Wale

Role-Based Entitlements

If thiz entitiemant will ba consumed by Role-Based Entitements,
Foover dio yiows want o rezolve conflick=?

(%) The Role-hasad entitiemant with priarity will set the value.
Ciiverga the values assigned.

2 Entitiemant Editor | ML Source | XML Trae

The Entitlement Editor view shows you all of the pages and choices that you see in the
Entitlement Wizard, but the information is on one page.

+ Name and Description: Allows you to edit the name, the display name, and the
description that you have given to this entitlement.

¢ Multi-Value: Allows you to select if you want an entitlement to be assigned multiple
times.

+ Role-Based Entitlements: Allows you to select conflict resolution for Role-Based

Entitlements. If you do not select Role-Based Entitlements, the Role-based entitlements
with priority button is the default.
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¢ Values: Allows you to define how values are defined: no values, administrator defined

values, or values from an application.

The information that appears in the Entitlement Editor depends on what you initially defined in
the entitlement. If you choose to edit a valueless entitlement, the Values heading displays No
Values. If you are editing a valued entitlement and you want to add values to a list, type the
value in the Value field and click 4dd. If you want to remove a value, select the value in the

Values list and click Remove.

If you don’t want to select from a list, select Administrator Defined Values under the Values
heading and leave the Values list blank. This gives you a blank text box in iManager or in the

user application, and you can fill in the value there.

3 When you have made your changes to the entitlement, click the Save icon in the upper left
corner of Designer, or click the X on the entitlement’s tab to display a Save Resource window,

allowing you to save changes (Yes/No/Cancel).

17.3.1 Entitlement XML Source and XML Tree Views

To view the entitlement in XML source code:

1 From the Outline view, right-click an entitlement that appears under the Subscriber channel of

the selected driver, then click Edit.

or

Double-click the entitlement icon to bring up the entitlement in the Entitlement Editor.

You can also right-click the driver icon in the Modeler view, then select Edit Entitlements.
2 To see the XML Source view, click XML Source at the bottom of the Entitlement Editor view.
The XML Source view shows the XML code in a formatted state.

i Blamston3 - Developer |l Blanstonl - Developer | & projl - Developer

inds ded-version="2.0":

<inpucs

l-attr attr-nams="CN"/:

r attr-name="CN"/>

LLE attE-name="Description’s>

<

WPath: fprocessing-instructionxml')
2| Entitlerment Editor | XML Source | XML Tree

FE entitlement F

ss=-name="msExchPrivateMDB” dest-dn="CHN=Configuracion,
class class-name="msExchPrivacteNDB"/ >
tEr mttr-name="Description”/>

[ ExchangeMailbox. X =ia

B e E®

"dirxmlentitlements'A

The upper right corner of the XML Source view has the following selections:

356 Designer 2.1 for Identity Manager 3.5.1



Name Description

Expand All Allows you to see all items under the item that you have selected.

Collapse All Allows you to collapse all items that you have selected.

Attach XML Catalog Entry, Allows you to attach an XML Catalog entry, an XML schema file, or a

XML

Schema, or DTD DTD (Document Type Definition) file. For default Windows installation,
the DTD for entitiements is found under C: \Program
Files\Novell\Designer\eclipse\plugins\com.novell.de
signer.idm.entitlements 1.1.0\DTD\dirxmlentitlement
s.dtd.

Find/Replace (Ctrl+F) Ctrl+F brings up the Find/Replace window, which allows you to query

Help

text, structure, and XPath searches in a forward or a backward
direction. Other options include case sensitive, wrap search, whole
word, incremental, and regular expressions search capabilities.

Opens the Help view to the right of the XML Source view.

Right-clicking in the XML Source view brings up the following options:

*

*

*

*

*

Undo Text Change (Ctrl+Z)

Revert File

Save

Cut (Ctrl+X)

Copy (Ctrl+C)

Paste (Ctrl+V)

Format the document or active elements
Clear Validation Errors

Validate

Preferences

3 To see the XML Tree view, click XML Tree at the bottom of the Entitlement Editor view.

The XML Tree view is a tree control view of the XML source code. You can perform the same
edits in this view as you can in the Entitlement Editor view or the XML Source view. To view
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the entitlement in XML Tree view, select XML Tree at the bottom of the Entitlement Editor
view.

& Blanston3 - Developer ¢ Blanstonl - Developer 5 projl - Developar E]Er;maﬂgerdamm x

72 wml version="1.0" encoding="UTF-8"
% DOCTYPE entitliernent PUBLIC "dirkmientitiements” "C:\Program Files\Novell\Designer\eclpse\pluginsicom.
= [2] entitiement
conflict-resoltion Linian
@ description The Group Entitliement grants or denies an Exchange mailbox for the user in Microsoft Exchange
@ display-name Exchangs Mailbox Entitiement
@ name ExchangelMailbox
= (2] values r I
= (€] query-app
= [g] query-xml
= [e] nds
® dbd-version 2.0
+ || Input
| result-set

i
M [

[&] display-name
+ [g] token-attr
= [g] description
# [g] token-atr
= [e] ent-value
[&] wokesarc-dn

HPath:
=l Entitlement Editor | XML Source | XL Tree

The upper right corner of the XML Tree view menu contains the following selections:

Name Description
Expand All Allows you to see all items under the item that you have selected.
Collapse All Allows you to collapse all items that you have selected.

Attach XML Catalog Entry, Allows you to attach an XML Catalog entry, an XML schema file, or a

XML Schema, or DTD DTD (Document Type Definition) file. For default Windows installation,
the DTD for entitiements is found under C: \Program
Files\Novell\Designer\eclipse\plugins\com.novell.de
signer.idm.entitlements 1.1.0\DTD\dirxmlentitlement
s.dtd.

Find/Replace (Ctrl+F) Brings up the Find/Replace window, which allows you to query text,
structure, and XPath searches in a forward or a backward direction.
Other options include case sensitive, wrap search, whole word,
incremental, and regular expressions search capabilities.

Help Opens the Help view to the right of the XML Tree view.

Right-clicking in the XML Tree view can bring up a number of different options. For example,
right-clicking the highlighted value on the right side presents the following options:

+ Undo

+ Cut

+ Copy

+ Paste

+ Delete

+ Select All
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Right-clicking an attribute on the left side in the XML Tree view presents the following
options:

+ Remove
+ Edit the Selected Attribute
+ Replace with a value

Depending on what you select on the left side in the XML Tree view, you see different options.
For example, right-clicking an element presents the following options:

+ Remove Element
+ Add New Attribute

¢ Add to a Child Element a Comment, a Processing Instruction, a PCDATA, a CDATA
Section, a new Element

+ Add Before a Comment, a Processing Instruction, a PCDATA, a CDATA Section, a new
Element

¢ Add After a Comment, a Processing Instruction, a PCDATA, a CDATA Section, a new
Element

17.3.2 Using the Novell Entitlement DTD

Some entitlements come predefined on drivers that have entitlements enabled. (For a list of these
drivers with predefined entitlements see Section 17.1.3, “Identity Manager Drivers with
Preconfigurations that Support Entitlements,” on page 341.) You can use these entitlements or you
can create your own entitlements in iManager or Designer. To help you create your own
entitlements, you can use the Novell Entitlement DTD as an example to create entitlements. For an
example of the Novell Entitlement DTD and an explanation of its functionality, see “Using Novell's
Entitlement Document Type Definition (DTD)” and “Explaining the Entitlement DTD” sections in
the Entitlements section of the Novell Identity Manager 3.5.1 Administration Guide.

17.4 Managing Entitlements

After you create entitlements (or use entitlements that come preconfigured with certain Identity
Manager drivers), you need to manage them. Entitlements are tied into the eDirectory event system
and granting and revoking are initiated through two agents:

+ iManager through Role-Based entitlement policies

¢ The User Application as workflow entitlements

Role-Based Entitlements allow you to automatically grant or revoke business resources if the
criteria are met. In order for workflow entitlements to work with the User Application, manual
approval is first required.

For instance, you can specify that if user has A, B, and C, then through a Role-Based Entitlement,
the user is made a member of Group H; but if the user has E and F qualifications, he or she is made
a member of Group I. Through Role-Based entitlements, this action is done automatically, as long as
the conditions are met. In order for this entitlement to work with workflow entitlements, the User
object must first acquire approval, which you need to set up through the User Application. However,
if you do not add to the driver the policies and rules to interpret the event in the designated system,
granting and revoking entitlements has no effect.
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Use either Role-Based Entitlements or workflow entitlements; it is a not good idea to mix them to
manage the same resource. We recommend that you have only one agent control an entitlement. If
multiple agents are in control, you have the following consequences:

+ Whoever comes last controls the entitlement results

¢ Results are unpredictable

+ Using both agents to control an entitlement is not supported by Novell
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Scheduling Jobs

Designer has a job scheduling utility to schedule events. Through this utility, the system can be set to
disable an account on a specific day, or to initiate a workflow to request an extension for a person’s
access to a corporate resource, such as:

+ Create a Job object from an installed job definition.

¢ Define when a job is to run, which servers the job is to run on, the scope of the job in terms of
eDirectory objects, and the a job reports intermediate and final results.

+ Set values for the job’s parameters, its description and display name.
+ Enable/disable a job, manually start a job, stop a job that is running, and display a list of
running jobs.

Designer’s job scheduler contains the same functionality as the job scheduler found in iManager.

¢ Section 18.1, “Creating a Job,” on page 361
¢ Section 18.2, “Editing a Job,” on page 363

18.1 Creating a Job

To create a new job:
1 In the Outline view, right-click a driver and select New > Job.

=2l 1omM_TREE
fi) marv's Liorary
B MADEAM2-MDS
= &l mydriverset
& PwdExp2
(9] :.ctive Directo

Copy »| ¥ Credential Repository. .
s DirxML Script...
& Show Dataflow View = ) "
=T ECMASCript...
& Sirmulate. . T Entitlement...
(B Show Palicy Sets & 1ob...,
=] Rur Caonfiguration Wizard.., [/ Mapping Table...
&y Password Synchronizatian. . :ET; Resaurce...
§& Manage application Schema... ME Schema Map...
TE HELT..
Document Selection...
Export to Configuration File... From Copy...
Live 3
¥ Delete
Properties

Scheduling Jobs 361



2 In the New Job window, give the job a descriptive name, or use the name provided.

@ New Job

Choose Job Criteria

Enter a name for your new job, Select & server and choose a job definition

MNarme: | Job01
Jobs
Server: A0 2-NDS. novell v N
Job Definition Description
& ]Random Password Gene...  This job generates a random password far each ohiject in sc...
&) Schedule driver This job starts or stops its associated driver,

& ]Subscriber channel trigger  This joh submits zera or more trigger documents o the subs...

[¥]open the editar after creating the abject.

I Ok ] ’ Cancel ]

3 In the Server field, select the server to perform the job execution. You can click the drop-down
item to select a different server than the one listed.

4 If the administrator has created and installed any custom job definitions on the selected server,
click the Update Job Definitions from Server icon to the right of the server entry to read in a
live list of available jobs from the server. Since Designer is an offline modeling tool, only the
Identity Manager 3.5 job definitions show in the server’s Job Definition list by default.

5 Choose a definition for the job. The New Job Wizard comes with three job definitions.
Additional custom jobs might also be listed.

+ Random Password Generator: Generates a random password for each object in the job’s
scope. The password is generated by NMAS to match Password Policy object that the job
references. Generally these Password Policy objects are not the same as those used for
eDirectory user password policies.

The job submits the generated password one at a time to the driver’s Subscriber channel.
The Subscriber channel policies must do something useful with the passwords.

¢ Schedule Driver: Starts or stops the associated driver. You can also toggle a driver to start
the driver if it is stopped or to stop the driver if it is running.

¢ Subscriber Channel Trigger: Submits zero or more trigger documents to the Subscriber
channel. The submission can either be a document per object if a scope is defined, or it can
be a single trigger event if no scope is defined.
Trigger event documents identify the job and the scope object. A trigger event can bypass
the cache and “go to the head of the queue” if desired. You will likely use trigger jobs the
most and they allow you to use driver policies that you can customize for your personal
requirements.
6 Decide if you want to edit the job. The Open the editor after creating the object option opens
the newly created job in the IDM Job Editor window after it first saves the job object. If you do
not want to open the editor at this time, deselect the editor.

7 Click OK.
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8 The File Conflict window gives you the option to save the job object and continue. If you want
to create the job object and continue with the IDM Job Editor, click Yes. Otherwise, click No.

9 Continue with Section 18.2, “Editing a Job,” on page 363.

18.2 Editing a Job

After you create a job, you need to add the necessary information to make the job useful. To edit a
job, double-click a newly created job in the Outline view to bring up the job in the IDM Job Editor
view.

Figure 18-1 The IDM Job Editor View

‘& Blanstond - Developer *Blanstonil.docgen m =8

IDM Job Editor @
& Job01.aDedomain.driver s&tLIDM

General Settings
This job starts or stops its associated driver,

Job Type: |

[oelete Job after running once
[pisable Job fram rurning

Servers: | caryer List
B 11-N0S novedl

Scopes: | Scopes for JobOl Description
i DU nove Apply job to this container only
cf Domain Admins.people Apply job to members of this group

£ | b4

R=0 Scope...] [Edit...] lgemove]

< >

General | Job Parameters | Schedule | Motification

The IDM Job Editor has four tabs at the bottom of its view:

¢ Section 18.2.1, “Job Editor Selections Under the General Tab,” on page 363
Section 18.2.2, “Job Editor Selections Under the Job Parameter Tab,” on page 367
Section 18.2.3, “Job Editor Selections Under the Scheduler Tab,” on page 371
Section 18.2.4, “Job Editor Selections Under the Notification Tab,” on page 373

*

*

*

18.2.1 Job Editor Selections Under the General Tab

The top of the General tab shows the Java class name of the job. This is followed by the job type,
which shows the type of job you selected. Under the Job Type heading, you can enable or disable the
job, or to delete the job after it runs.
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Figure 18-2 [tems Under the General Tab

‘7l Blanstond - Developer *Blanstonil docgen m =8

IDM Job Editor
& ] Job01. ADBdamain, drivers&t1. 100

General Settings
This job starts or stops its associated driver,

Job Type: |

[Joelete Job after running once
Ooisable Joh from running

Servers: | Sgrver List
A 11-HDS.novell

Scopes: | Scopes for Job01 Description
iy TestoU, novell Apply job to this container only
¢z Domain Admins.peaple Apply job o mermbers of this group
< 2

[W=00d Scupe...l ’Edit... ] Igemove]

|

<

General | Job Parameters | Schedule | Notification

1 To delete the job after it runs, select Delete job after running once.
2 To disable the job from running, select Disable job from running.
3 1In the Server List column, select the server or servers where this job should run.

A filtered list of servers is available to help you assign this job. A custom job can be installed
on one server but not on another. In this case, the server without this custom job is filtered out
of the Server List.

A job can be assigned to multiple servers as long as it has been installed on each server.
Designer only allows this association if the jobs are properly installed and packaged so that the

Metadirectory engine can see them.

364 Designer 2.1 for Identity Manager 3.5.1



4 To add a scope to the Scopes column, click New Scope.

@ Create Scope

Specify Job Scope Criteria

Provide job scope criteria here.

Scope Input

Scope
Ohject:

Advanced Scope Options
(O Scope is a Container

Apply job to objects that are one of the following classes:

{If no scope classes are specified, all

classes are included in the scope.)
() Scope is a Group/Dynamic Group

[l5cope is the group itself and not its members
(O scope is a Mon-Container

Domain Admins.people v| B

I |

Cancel l

5 To select a scope object, type the Distinguished name of the object or use the Browse icon to

browse to the object. Click OK to add the scope object.

Scopes allow you to define the objects that this job applies to. An object in eDirectory™ can be
a container, a dynamic group, a group, or a leaf object. If you select a group object, you can

apply the job to the group's members, or only to the group. If you select a container object, you
can apply the job to all descendants in that container, to all of the children in the container, or to

the container only.

6 If the object is a container, select Scope is a Container. Then select how you want to apply the

job:
+ Apply job to this container only
+ Apply job to children of this container
+ Apply job to all descendants of this container

7 (Optional) If you select Apply job to children of this container or Apply job to all descendants
of this container, you can specify the classes and attributes you want to scope. Click the Plus
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icon to bring up the Schema Browser window to select the classes you want to scope. Select the
class schema, then click OK.

@® Schema Browser 3]

Classes | attributes

[Shift-click to select 3 range]}’ @

Dir¥ML-SharedProfileSet -~
Dir {ML-StyleSheet
Dir ¥ML-Subscr iber
Dir¥ML-TES-GROUP
Dir¥ML-TES-LISER
Diir XML\ ork Or der
Dir¥ML-workToDo
drnd

domain

dsa

dynamicGroup
dynarmicGroupaLs
edirSchematersion
encryptionPolicy
External Entity

federationBoundari

Groupiiise Agent b
[CJonly show changes

[ K H Cancel l B

The classes are added to the Classes box. To remove a class, select it and click the Minus icon.

8 If the object is a group or a dynamic group, select Scope is a Group/Dynamic Group. You can
then select the Scope is the group itself and not its members option if the scope is for the group.

9 If the object is a non-container, select Scope is a Non-Container.
10 After the scope criteria are selected, click OK to return to the General Settings page.
11 If you need to edit a scope, select the scope name, then click Edit.

12 To remove a scope, select the scope name, then click Remove.

Deploying a Job with Scope Objects

Jobs might need access to eDirectory data and certain Identity Manager actions, such as starting and
stopping drivers. Such access is subject to eDirectory rights assignments and is controlled by the
rights that are granted to the Di rXMLJob object. While Identity Manager actions are controlled by
special attributes, normal eDirectory rights are needed for data reads and writes.

When you deploy a job object that has scope objects, there might be eDirectory rights assignments
that Designer cannot properly set up. The rights needed to complete the task depend on the scope
objects that are assigned to the job object.
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Figure 18-3 Warning Messages When Deploying a Job with Scope Objects

@ Deployment Results
Operation Results! B = | E
= <>‘ PwdExp3. Test DSet. novel
; E% 0 The job named 'PwdExp3' being deploved may require eDireckory rights that cannot be setup by Designer.
: 'Q’ The Jab named 'PwdExp3’ was deploved but is incorrectly configured and cannot be starked on the server named M
[ £
Dietails:
& Warning
Object: PuwdExp3. Test DSet.novel
Description: The job named 'PwdExp3’ being deployed may require eDirectory rights that cannat be
setup by Designer,
Resolution: Launch iManager to assign the job named 'PwdExp3' rights to the job scope objects,

If you see this warning when deploying job objects, use the iManager utility to assign eDirectory
rights to the job object so it can properly access the job scope objects and complete its task.

18.2.2 Job Editor Selections Under the Job Parameter Tab

The Job Parameter page allows you to add additional parameters to the job and to view the
parameters as they are presently set up. What you can do depends on the type of job you selected.

¢ “Parameters for the Schedule Driver Job” on page 368
¢ “Parameters for the Generate Random Passwords Job” on page 369

¢ “Parameters for the Subscriber Channel Trigger Job” on page 370
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Parameters for the Schedule Driver Job

Figure 18-4 The Job Parameter Page for a Schedule Driver Job

‘52| Blanstond - Developer Blanstonll.docgen w Entitlement Policies =B
1DM Job Editor @

& 10h01.808damain.driversgtl, IomM

Job Parameters

Scheduled action: |Start the driver hd

Start the driver

General |Job Pararmeters | Schedule | Notification

1 If you want the job to start the driver, select Start the driver.
2 If you want the job to stop the driver, select Stop the driver.

3 If you want the job to stop the driver if it’s started or to start the driver if it’s stopped, select
Toggle the driver.
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Parameters for the Generate Random Passwords Job

Figure 18-5 The Job Parameter Page for the Generate Random Password Job

& Blanston11 - Developer m = 0O

IDMY Joh Editor

@
& ] job01.Active Directary. mydriverset, IDM_TREE
Job Parameters
Fassword Policy object used for password generation:
V% ©

Generate a password for objects without a driver association?: ®

< | =
General | Job Parameters | Schedule | Motification

1 Type the Password policy object’s Distinguished name, or use the Browse icon to select the
Password policy you want to use for password generation.

2 If you want to generate passwords for scoped objects without a driver association, select True.
Otherwise, select False.
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Parameters for the Subscriber Channel Trigger Job

Figure 18-6 The Job Parameter Page for the Subscriber Channel Trigger Job

17| Blanston11 - Developer & ] *joh01 m =0

IDM Job Editor @
& Job3.Active Directory, mydriverset, IDM_TREE

Job Parameters

Submit a trigger document for objects without a driver association?: [false @

Use Job CN as trigger document identifier?:

Trigger element source value:

1 ®

Method for submitting trigger documents: |direct (hypass cache) v | (&)

Start driver if not running: |true % @

Stop driver when finished processing frigger(s): (frue v @

General | Job Parameters | Schedule | Notification

1 If you want to submit a trigger document for scoped objects that do not have a driver
association, select True. Otherwise, keep the default of False.

2 If you want to use the job’s Common Name (CN) as a document identifier trigger, keep the
default of True. Otherwise, select False.

3 (Optional) If you select False, enter the string that the job can use as the value for the trigger
element’s “Source” attribute.

4 Sclect a method for submitting the trigger documents. If you want to queue the job the trigger is
from, keep the default of Queue (use cache). Otherwise, select Direct (bypass cache).

5 (Optional) If you select Direct (bypass cache), you are presented with the Start driver if not
running option. If you want to start the driver if it is not running, keep the default of True.
Otherwise, select False.

6 (Optional) If you select True on the Start driver if not running option, you are presented with
the Stop driver when finished processing triggers option with the default of 7rue. Use the
default to stop the driver once it finishes processing the trigger job, or select False to keep the
driver running.

Customized job definitions will have their own parameter set.
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18.2.3 Job Editor Selections Under the Scheduler Tab
The Scheduler tab allows you to set up when you want to run the job.
Figure 18-7 The Job Options for the Scheduler Tab

1 Blanston1l - Developer & job01 m =0

IDM Job Editor @
& Joh3.Active Directory. mydriverset.IDM_TREE

Scheduler

All schedules automatically repeat, The crontab standard is used to schedule and execute Identity
Manger jobs. Use the "Run custom” option to input complesx, patterned schedules,

ORun job manually
@1 :

Startjobat; (1 w||00 | &M v | 1:00 &M )

O Daily

@ weekly: Sunday [IMaonday  [Tuesday [wednesday [ Thursday
ClFriday  [Isaturday

O Manthly: Choose Day(s) of Month

O vearly: Maonth(s) of year
Daryis) of month

Crontab syntax

Minute: 0-59; Hour: 0-23; Day of month: 1-31; Month: 1-12; Day of
week: 0-6, 0=Sunday; *=all. Use a comma to separate integers and
ranges within & field, and a space to separate fields.

O Custam:

Crontabh Text: (01 * * 0

£ >

General | Job Parameters | Schedule | Motification

1 Select the Use schedule option to set the date and time, and whether to run the job daily,
weekly, monthly, yearly.

Or

Select the Run job manually option to run the job when you choose to.

2 With Use schedule selected, set the time when you want the job to start running. Use the drop-
down menus to select the hours, minutes, and AM or PM. The default is 1:00 AM.

3 If you want to run the job repeatedly, use the Daily, Weekly, Monthly, Yearly, or Custom fields
to select when you want it to run.
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For example, if you want the job to run weekly, select Weekly, then the day you want it to run
on. If you want the job to run once a month, select Monthly, then click the Plus icon to select

the day of the month.

@ Choose Day(s) of Month ]

Days of Month b

017

Oia

]

Ozn

Oz1

& 2
Oza —
Oz4

[zs v

’Select All l ’Unselect all l

[ Ok l ’ Cancel ]

4 If you select Custom, you can choose minutes, hours, days, months and days of the week from
the Choose Advanced Crontab Criteria page.

@ Choose Advanced Crontab Criteria =]
MinLtes of FHour o) Hours of Cay Lol Daps of ionth o]
Oas [l 200 pm 1
Oes [ 4:00 pm Oz i
Oaz7 [ 5:00 pm O3
Oa= ’ [ &0 pm Oa
Oae [ 7:00pm Os
L [0 2:00pm Oa
3t [ 9:00 pim | Oz
O3z 10:00 pm Oa
Oaz R 1100 pm :I Ouo -
| ===
ronthe of Year fa | Days of Vilesk
Tanusry 0
[¥] Februzy [ oy
Warch _ ||| O Tuesday
agpril I [ wiehnesday
[¥] may ] Thursday
une |:| Friday
Jly T Salurclay
[¥] August
Septerrer e
|
[ Ok, l [ Carcel ]

The Advanced Crontab Criteria page default has everything selected. Click Unselect All,
choose the time and days you want to run the job, then click OK to return to the Scheduler page.

The information displayed in the Crontab Text field displays any settings you make on the
Scheduler page. For example, if you click Monthly and select two days, those two days are
displayed in the Crontab Text field.
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18.2.4 Job Editor Selections Under the Notification Tab

The Notification Settings page allows you to define what you want to do with the job results. It is
divided into two parts, Intermediate and Final, with the Success, Warning, Error, and Aborted results

for each part.

The Notification Settings page allows you to set how you want to be notified for each result. Actions

include sending an audit result or sending an e-mail when the result completes.

Figure 18-8 The Job Options Under the Notification Tab

‘52l Blanstonll - Developer m Job3

1IDM Job Editor
& jobD1.Active Directory. mydriverset, [IDM_TREE

Notification Settings

Inter mediate Success
[VIsend email for this event

Motification

Termplate:

Motification Recipients

Ta: | admin.IDM

Reply To: | SecuritylT.peoples
(o(of |

BOC: |

[Juse Movell sudit for this event

Inter mediate Warning

General Job Parameters | Schedule | Matification

1 If you select Send email for this event, Designer supplies the Default Job Notification.Default
Notification.security template in the Notification Template field. To change templates, click the

Model Browser icon to select another template.
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2 Under Notification Recipients, select who you want to send the results to by typing in the user’s
or group’s fully Distinguished name. You can use the Plus icon to create a mail profile.

@ Create Mail Recipient Profile 3]

Recipient Profile S
TO:—7g
Enter email recipients. To and Reply are required fields.

MName: | Network Administrator

Email Recipients

To: | adrnin, IO |

Reply To: | SecuritylT.peoples |

cc: | |

BCC: | |

[ CK l I Cancel l

The To and Reply fields are required for a profile.

3 When you have filled in the information, click OK.
4 If you want the results to go to Novell Audit, select Use Novell Audit for this event.
5 Use Steps 1 through Step 4 for each of the options:

¢ Intermediate Success

¢ Intermediate Warning

+ Intermediate Error

¢ Intermediate Abort

¢ Final Success

+ Final Warning

¢ Final Error

+ Final Abort

If you do not select an option, no action is taken for the result.
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Deploying and Exporting

The Deploy feature in Designer places a project, a set of drivers, a single driver, channels, and
policies into a deployed Identity Manager system in an eDirectory™ tree. This can be a production
tree or a test tree.

Use the Export feature to make backups of all of your projects and the drivers you want to
implement. This way, if something happens to the driver in production, you have a backup.

Use the Deploy feature after you have thoroughly tested the policies that make up your drivers. To
test policies, use the Policy Simulator (right-click a policy to see the simulation results of the policy
that is being tested) or use the Project Checker to ensure that the project is valid. Then use Deploy to
test the policy in a test environment; after you test the driver, you can deploy the driver into
production.

You can also use the Import feature to import an existing eDirectory driver, a channel, or a policy;
after it is imported, you can modify the object or objects, run the Policy Simulator to ensure that the
object is working correctly, then deploy the object back into a test tree for further analysis. For more
information about policies, see Understanding Policies for Identity Manager 3.5 (http://
www.novell.com/documentation/idm35/index.html?page=/documentation/idm35/policy/data/
bookinfo.html).

To help you decide on changes to make before deploying, you can use the Compare feature to see
differences between the objects you are deploying and those that already reside in an eDirectory
tree. See Section 19.7, “Using the Compare Feature When Deploying,” on page 383.

¢ Section 19.1, “Preparing to Deploy,” on page 375

¢ Section 19.2, “Deploying a Project to an Identity Vault,” on page 376

¢ Section 19.3, “Deploying a Driver Set to an Identity Vault,” on page 376

¢ Section 19.4, “Deploying a Driver to an Identity Vault,” on page 379

¢ Section 19.5, “Deploying a Channel to an Identity Vault,” on page 381

¢ Section 19.6, “Deploying a Policy to an Identity Vault,” on page 382

¢ Section 19.7, “Using the Compare Feature When Deploying,” on page 383

¢ Section 19.8, “Troubleshooting Deployed Objects,” on page 387

¢ Section 19.9, “Exporting a Project,” on page 387

¢ Section 19.10, “Exporting To a File,” on page 390

19.1 Preparing to Deploy
Before deploying a project, run Project Checker and fix any errors that appear.
1 Click Window > Show View > Project Checker, then click the Run the Project Checker icon.

After you have corrected any problems to the project, make a backup copy of the project before
deploying.
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Before you deploy objects into an Identity Vault, you need to designate the Deployment DN
(distinguished name), or the place in the tree where you plan on deploying the Identity Manager
project or objects. To do this:

1 1In Designer, select the Identity Vault that contains the object or objects you want to deploy,
then look in the Properties view below the Project/Outline view. (You can also open the
Identity Vault’s or driver’s Properties window.)

Property Yalue
Mame IDMTREE
Host Address 192,168.14.199
Izer DM adrmin.blanston
Password ook
Deploy Context  hlanston
Meta Directory  true
Save Password  false

2 In the Properties view, fill in the Identity Vault’s Name, Host Address, User DN, Password, and
Deployment DN information if it is not already present.

3 Click the Browse button to find the Deploy Context distinguished name on an existing tree if
the other information is accurate and Designer can attach to the tree. You need this information
to deploy anything, even a policy.

You can also use the driver set’s Deploy Context entry if you want to deploy a driver set to a
different context than the one designated in the Identity Vault’s Properties view. The driver set’s
Deploy Context entry overrules the Identity Vault’s Deploy Context entry.

IMPORTANT: You must have enough rights to access the eDirectory tree that is associated with
the Identity Vault to which you want to deploy.

19.2 Deploying a Project to an Identity Vault

To deploy a project to an eDirectory tree that is running Identity Manager, you use the same
procedure that you use for deploying a driver set, a driver, channels, or policies. The procedure is
described in Section 19.3, “Deploying a Driver Set to an Identity Vault,” on page 376.

To deploy an Identity Manager-based project or an object in a project, you must have access to the

eDirectory tree that is associated with the Identity Vault you are designing. You also need to know

the deployment DN (distinguished name) context, or the place in the tree where you plan to deploy
the Identity Manager driver set or driver objects.

19.3 Deploying a Driver Set to an Identity Vaulit

Suppose you finish a new driver set that you want to deploy into a test tree, or suppose you have
imported a driver set, made modifications, and now you want to deploy the driver set back into its
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working tree. Use the following procedure to deploy an Identity Manager Driver Set object (and all
contained Identity Manager drivers) into an existing Identity Manager system in an eDirectory Tree:

1 Right-click the Driver Set icon in the Modeler view, then click Live > Deploy.

El 1oM_TREE El Blanston Inc.

Copry

=== Sfraighten Connections

{1 Select Connected Applications
Arrange Applications
Digtr ibute
Align

Document Selection. .,
Import fram File. ..,
jEl Export to Configuration File...

8 = Import...

¥ Delete b
s Compare. .,

Froperties ) ]
Driver Set Configuration *

& Driver Status, .,
D Start Drivers
@ Stop Drivers
@ Restart Drivers

You can also select the Driver Set object from the Outline view. Click the Outline tab, right-
click the Driver Set object, then click Live > Deploy.

The Identity Vault Credentials window displays if Designer can’t authenticate to the eDirectory
tree specified in the Identity Vault, or if you do not have the Deployment DN designated in the
Properties tab of the Identity Vault you are deploying to.

2 Use the Compare feature to see differences between the objects you are deploying and those
that already reside in an eDirectory tree. See Section 19.7, “Using the Compare Feature When
Deploying,” on page 383.

3 In the Deployment Summary window, click Deploy.
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4 Click OK to close the Information window.

@ Deployment Results &)

Operation Results: = | EL
LSO iver

Set.Movell

Details:

A Warning

Description: The deployment of Criver SetNovell completed with warnings,

5 (Conditional.) If you see other informational messages, decide what action to take.

You might also see a message in the Deployment Results window stating that the deployment
was unsuccessful. Click on the error messages in the Operation Results portion of the window
to see the error descriptions and possible reasons in the Details portion.

6 (Conditional) If this is a new deployment, the Deploy - New Driver Settings window displays.
Define security equivalences on the driver set and identify all objects that represent
Administrative roles and exclude them from being replicated.

@ Deploy - New Driver Settings

Novell recommends that you do the following for newly created drivers:
- Define Security Equivalences on them; and

- Identify all objects that represent Administrative Roles and exclude them from replication.

|§Deﬂne ‘Security Equivalences'... |

IEchude ‘sdministrative Roles'... ]

In both instances, Novell recommends that you select the Admin object, and any other objects
that qualify in your network environment.
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19.3.1 eDir-to-eDir Deployments and SSL/TLS

By default, always deploy both sides of an eDirectory-to-eDirectory connection when you have SSL
and TLS enabled. If SSL/TLS are enabled, Designer creates the certificates in the eDirectory tree
when you deploy the drivers. SSL and TLS are not enabled nor configured by default.

To check your present SSL settings, select Window > Preferences > Designer for IDM >
Configuration > eDir-to-eDir SSL/TLS. Once configured, the Deploy feature adheres to the SSL
preference settings under Certificate Overwrite Policy.

19.4 Deploying a Driver to an Identity Vaulit

Suppose you finished a new driver object that you want to deploy into a test tree, or suppose you
have imported a driver object, made significant modifications, and now you want to deploy that
driver object back into its working tree. Use the following procedure to deploy an Identity Manager
Driver object (and all contained channels and policies) into a driver set:

1 Select an Identity Vault in the Modeler view.

2 Right-click a driver object connected to a Driver Set icon in the Identity Vault.

The driver object is represented by a circle icon.
3 Click Live > Deploy.

</ Undo Change Location

ey
Copy

g Mark as Firewall

LR ... Straighten Connection

& Show Dataflow View
Dataflow

& Simulate, .
3 Show Palicy Sefs

5] Run Configuration Wizard...
&2 Edit Entitlerments, .

24 Password Synchronizatian...
@ Manage Application Schema...

Document Selection. .
Export to Configuration File. ..

¥ Delete :
€ Compare...
Properties
‘eloper P Diriver Configuration 4
¥ Log 2 @ Refresh Application Schema...
ige Driver Status...
g @
D Start Driver
© Stop Driver

@ Restart Driver

& SetUp Driver Security...

Deploying and Exporting 379



You can also select the driver object from the Outline view. Click the Outline tab, right-click
the driver object you want to deploy, then click Live > Deploy.

An error displays if Designer can’t authenticate to the eDirectory tree specified in the Identity
Vault, or if you do not have the Deployment DN designated in the Properties tab of the Identity
Vault you are deploying to.

The Deployment Summary window shows you the differences between the objects you are
deploying and those that already reside in an eDirectory tree. It is the same as the Compare
feature. For more information on how to use the Compare window, see Section 19.7, “Using
the Compare Feature When Deploying,” on page 383.

@ Deployment Summary - EE

Select an object or atribute: B &
= f) Driver Set | Information ;
= fy) Userapplication Compare Status: L Unegual
=@ Atributes |
@ DirXML-InputTransfarm

[Flonly show differences

Taxt Compare

s Designer (Source) eDirectory (Destination)
I-(.ND Values:| |‘.L . PurgeEnticlemencs,. Useripplication. Driver Sec l

[[I0on't show this dialog again

@ I Deploy ” Caricel ]

4 Click Deploy to begin the process.
5 Click OK to close the Deployment Results window.
6 (Conditional.) If you see other informational messages, decide what action to take.

You might also see a message in the Deployment Results window stating that the deployment
was unsuccessful. Click on the error messages in the Operation Results portion of the window
to see the error descriptions and possible reasons in the Details portion.
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7 (Conditional) If this is a new deployment, the Deploy - New Driver Settings window displays.
Define security equivalences on the driver set and identify all objects that represent
Administrative roles and exclude them from being replicated.

@ Deploy - New Driver Settings

Movell recommends that you do the following for newly created drivers:
- Define Security Equivalences on them; and

- Identify all ohjects that represent Administrative Roles and exclude them from replication.

|§Deﬂne ‘Security Equivalences'... |

IEchude ‘sdministrative Roles'... ]

In both instances, Novell recommends that you select the Admin object, and any other objects
that qualify in your network settings.

19.5 Deploying a Channel to an Identity Vault

A channel is a grouping of rules and policies, and Designer allows you to deploy a channel object
into a driver if necessary. The Subscriber and Publisher channels describe the direction in which the
information flows. The Subscriber channel takes the event from Identity Vault (eDirectory) and
sends that event to the connected system (application, database, CSV file, etc). The Publisher
channel takes the event from the application, database, CSV file, etc., and sends that event to the
Identity Vault. The Subscriber and Publisher channels act independently; actions in one are not
affected by what happens in the other.

Channel objects must be a part of a newly created driver, or they must be a part of an existing driver
that now needs to be modified. Driver objects are created through the Designer or iManager utilities.
Because channel objects are a part of a driver object, you deploy a channel object into an existing
driver object. If you simply deploy the channel object, Designer creates a skeleton driver as a
placeholder for the channel object.

To deploy an Identity Manager channel (a Subscriber channel or a Publisher channel) object and all
contained policies into a driver in an Identity Vault:

1 In the OQutline tab, select the channel object under the driver object. The driver object is
represented by a circle icon; the Publisher icon shows a black dot on the icon 5 and the
Subscriber icon shows a white dot &,

2 Right-click the channel object you want to deploy, then click Live > Deploy.
{F’ﬁﬁm
§  Mew v
- & Simulate. .,

A Export to Configuration File...

T - e
(

% Ceploy...

Properties

©

& Compare. .

Mapping Rule Policies
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An error displays if Designer can’t authenticate to the eDirectory tree specified in the Identity
Vault, or if you do not have the Deployment DN designated in the Properties tab of the Identity
Vault you are deploying to.

The Deployment Summary window shows you the differences between the objects you are
deploying and those that already reside in an eDirectory tree. It is the same window format as
the Compare feature. For more information on how to use the Compare window, see

Section 19.7, “Using the Compare Feature When Deploying,” on page 383.

An error displays if Designer can’t authenticate to the eDirectory tree specified in the Identity
Vault, or if you do not have the Deployment DN designated in the Properties tab of the Identity
Vault to which you are deploying.

3 In the Deployment Summary window, click Deploy.
4 After the channel deploys, click OK to close the Deployment Results window.

19.6 Deploying a Policy to an Identity Vault

A policy is a collection of rules and arguments that allow you to configure an application so it can
send and receive events between itself and an Identity Vault (eDirectory). You use policies to
manipulate the data you receive from an Identity Vault or from the application. Each driver performs
different tasks and policies tell the driver how to manipulate the data to perform those tasks. For
more information about policies, see Understanding Policies for Identity Manager 3.5 (http:/
www.novell.com/documentation/idm35/index.html?page=/documentation/idm35/policy/data/
bookinfo.html).

To deploy an Identity Manager-based Policy object (for example, a rule or a style sheet) into a driver
or channel (Subscriber or Publisher):

1 Click the Outline tab and select a policy under a driver object or a channel object.

Policies can be of the type DirXML® Script, Schema Mapping, or XSLT style sheet, and each
type has its own icon.

2 Right-click a policy object, then select Live > Deploy.

&) ¢ copy..
b/ Usel [5] Save As..,
Mg ¢

1 & Simulate..,

ey 4 Export to Configuration File...

o
L =
Tz Cornpare. ..
& 3¢ Delete h R
=K
| Properties

An error displays if Designer can’t authenticate to the eDirectory tree specified in the Identity
Vault, or if you do not have the Deployment DN designated in the Properties tab of the Identity
Vault you are deploying to.

The Deployment Summary window shows you the differences between the objects you are
deploying and those that already reside in an eDirectory tree. It is the same window format as
the Compare feature. For more information on how to use the Compare window, see

Section 19.7, “Using the Compare Feature When Deploying,” on page 383.
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3 In the Deployment Summary window, click Deploy.
4 After the policy deploys, click OK to close the Deployment Results window.

19.7 Using the Compare Feature When
Deploying

Designer’s Compare feature allows you to see differences between driver sets, drivers, channels, and
policies that are stored in projects and those that are running in deployed systems. Previous versions
of Designer only provided conflict resolution when importing a Driver. While importing, you could
select which policies of the driver you wanted to update, but you could not view any differences
between existing and new values.

Designer now provides conflict resolution on an object-by-object basis and allows you to view the
differences between existing and new values when importing and deploying driver sets, drivers,
channels and policies. For example, before deploying a driver object in Designer to a driver object
that already exists in the Identity Vault, you can run Compare. Compare shows whether the driver
objects are equal (no action is necessary) or unequal. If unequal, you can choose not to reconcile the
driver objects, choose to update the driver object in Designer, or choose to update the driver object
in eDirectory.

You can run the Compare feature at any time. If you choose to reconcile the differences between
drivers objects in Designer and eDirectory while in Compare, you won’t need to run Import or
Deploy.

¢ Section 19.7.1, “Using Compare when Deploying a Driver Object,” on page 384

¢ Section 19.7.2, “Using Compare Before Deploying a Channel Object,” on page 387

¢ Section 19.7.3, “Using Compare Before Deploying a Policy,” on page 387

¢ Section 19.7.4, “Matching Attributes with Designer Properties,” on page 387
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19.7.1 Using Compare when Deploying a Driver Object

Suppose you want to determine if you have deployed all of the changes you have made to a driver
object in Designer to the same driver in the Identity Vault.

1 Right-click the driver object in either the Modeler view or in the Outline view. Select Live >
Compare to bring up the Designer/eDirectory Object Compare window.

@ Designer/eDirectory Object Compare

Select an object or attribute: 7 1B
= fy Active Dirsctary | Information =
W 4D Attributes Compare Status: ~ Not Imparted
4 OutputTransform Reconcile Action: (g not reconclle
o Pazgword(Pub)-Sub Email Notifications
(& Update Designer
~
[lanly show differences
Text Compara o
. Designer (Destination) eDiractory (Source)

nl version="1.0" encoding="UTF-: -

l<tio values] E,
nrConvert sslscted

p-ACLLE name="scy
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2 In the Select an object or attribute portion of the window, you see the listed objects and
attributes. Select the attributes and child objects to see the actual differences displayed in the
Text Compare portion of the window.

@ Designer/eDirectory Object Compare

Select an object or atribute: H =@
= fp) Delimitad Text -

£@ DirXML-InputTransform
B DirML-OutputTransfor m
@ DirxML-MappingRule
£® DirXML-DriverFilter
@ DirxML-Confighanifest
@ DirxML-JavaModule
£@ DirxmL-Driverlmage
£@ DirxML-DriverStartOption { IDMTEST )
= i3 Publisher
=@ atributes ~

[“lonly show differences

The plus box at the right side of the Select an object or attribute allows you to expand all
elements in the parent object, and the minus box collapses all of the elements. The ? icon
displays the Summary/Compare dialog box help. Server-specific attributes which are attributes
that have a value for each server that is associated with a driver set, are displayed in the
Attributes list with the server name in parentheses to the right of the attribute name.

3 By default, the Compare window only displays values that are different between eDirectory
and Designer. To view all of the object values, deselect Only Show Differences.

4 Check to see the status of the values that are shown. Values that are equal are shown as Equal
on the Compare Status line in the Information portion of the Compare window.

Infor mation
Compare Status: = Unequal

Reconcile Action: &) pg rot reconcile
O Update Desigher

O Update eDirectory

The following table describes what you see in the Compare Status line:

Compare Status Description

Equal The selected attribute’s value or all attributes of the selected object are the
same in eDirectory and Designer.
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Compare Status Description

Unequal The value of the selected attribute, or one or more attributes of the
selected object, are different in eDirectory and Designer.

Not Deployed The selected object or the object containing the selected attribute is not
deployed to eDirectory.
Not Imported The selected object or object containing the selected attribute does not

exist in Designer.

The overlay image displayed in the object and attribute tree identifies objects or attributes that

need reconciliation.

5 Under the Information portion of the Compare window, select how you want to reconcile the

differences between the Source and Destination.
If Compare Status shows Unequal, you have three choices:

+ To do nothing, keep the default value of Do Not Reconcile.

+ To update the driver in Designer so that it contains the same information as the driver in

eDirectory, select Update Designer.

¢ To update the driver in eDirectory to reflect the changes you have just made to the driver

in Designer, select Update eDirectory.

The green check box in the bottom corner of the icons shows all of the child objects that are
being reconciled with the parent object. If you select the parent object to perform the update,
then all of the child objects under the parent reflect that choice and you see the Reconciled By
Parent button selected. If you do not choose a parent object, you can reconcile each child object
individually. You can also see a small Designer icon and an eDirectory icon, showing how

objects are being reconciled.

6 Check to see the Text Compare values.

The Text Compare values displayed in the bottom portion of the Designer/eDirectory Object
Compare window vary, depending on the object being compared. For instance, Compare shows
changes to policies or XML data. The Text Compare dialog box uses the Eclipse Compare
editor to compare attributes that contain XML data, such as policy data, driver filters, or

configuration data. The differences in the code are highlighted in blue.

Text Compara

. Designer (Destination)
<?%ml version="1.0" encoding="UTF-E"?><polic
<description>Convert selected attributes
<rule
<descriptionraccountExpires: Convert
<oonditions:
<and/ >
</conditionss
<actions:

<farg-value>
</do=reformat=-op=mttr>

|~
| ™

(=3

<do-reformat-op-actr name=raccou <toRken-replace-all ¢
<arg-value type="octer"> <token-local-var
<token-xpath expression= </token-replace-all>

o A
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7 After you view the differences, click Reconcile to perform the reconciliation actions for each
object in the tree, or click Close to close the Designer/eDirectory Object Compare window.

19.7.2 Using Compare Before Deploying a Channel Object

Suppose you want to deploy a channel object from the Identity Vault and the same channel already
exists in Designer. You can compare the two channels to see similarities and differences.

1 Right-click the channel object in the Outline view.

2 Select Live > Compare to bring up the Designer/eDirectory Object Compare window.

All Compare windows behave the same as described under the Section 19.7.1, “Using
Compare when Deploying a Driver Object,” on page 384.

19.7.3 Using Compare Before Deploying a Policy

Suppose you want to deploy a policy object from the Identity Vault and the same policy already
exists in Designer. You can compare the two policies to see similarities and differences

1 Right-click the policy object in the Outline view.
2 Select Live > Compare to bring up the Designer/eDirectory Object Compare window.

All Compare windows behave the same as described under the Section 19.7.1, “Using
Compare when Deploying a Driver Object,” on page 384.

19.7.4 Matching Attributes with Designer Properties

The attributes of the object are displayed in the single select attribute list. Selecting an attribute
displays its value below the attribute list with the Designer value on the left and the eDirectory value
on the right. The name displayed in the list is the eDirectory attribute name.

Three tables map the eDirectory attribute to the Designer property page or control, where you can
change or set the attribute (you can’t make changes inside the Compare window). Table 15-1 on
page 295 shows Driver Set eDirectory attributes, Table 15-2 on page 296 shows Driver eDirectory
attributes, and Table 15-3 on page 297 shows Channel eDirectory attributes.

19.8 Troubleshooting Deployed Objects

For information on troubleshooting deployed objects, see Section 24.4, “Deploying Identity
Manager Objects,” on page 495.

19.9 Exporting a Project

Designer’s export feature allows you to export Projects and Driver Configuration files to a local,
removable, or network directory.

1 Click File > Export.
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2 From the Export window, you can export an existing Identity Manager Project to the File
System or to an Archive File. Select General > File System, then click Next.

@ Export 3]
Select /-‘
Export resources to the local file system, ' E 5 i

Select an export destination:
| type filter text |

== Genaral
JE archive File
Al ile System
= Prefarences
== Designer for Identity Manager
& Manager Configuration File

3 In the Export File System window, select the projects you want to export.

File system \:7
Export resources to the local file system,

project
li7lBlanstond.proj
EmModelerOutlineState xml

[E = Blanstoni
[ Blanstonz
[ = Blanston3
[ = elanstong
[] 1= Blanstons
[0 projt

EEE

Select Iypes...] [ Select all ] [ Deselact All
To directory: |T:\Froject5 v| I Browse..,
Options

[l owerwrite existing files without warning
O Create directory structure for files
&) Create only selected directories

@ Mest = Einish ] [ Cancel
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4 Click Select All to select all projects in Designer’s \workspace directory (for Windows, the
default location is C: \Documents and
Settings\user’s login name\workspace).
or

click Deselect All to clear the selections. You can then select the projects you want to export.

IMPORTANT: You must select all items relating to a project if a subsequent import of that
project is to work.

The Select Types button is a feature of Eclipse (the platform that Designer is running on) and is
not a Designer feature.

You can also browse to the directory location where you want to select the resources.

5 After you designate the directory to which to export the projects, click Create directory
structure for files, then click Finish.

6 In the Save Resources window, select the projects you want to save, then click OK.
You can also export projects to an archive file:

1 Click File > Export.
2 Select the General > Archive File option in the Export window, then click Next.

Export ®]
aArchive file =%

Export resources to an archive flle on the local file system. L=
Hpor sy 1
- [¥] = Blanston =l .project
= [¥] = Blanstonl EdBlanston.proj

@ @ Blareton files imMadaleroutlineState,urnl
FJ = documentation
i = resources
-] = Blanston3
Select Types. . | [ Select Al | [ Desslect All
To archive file: | J:iY01Projectsiprojectzip ~ | Browse... j
Options
@5ave nzip format @ Create directory structure for files
O5ave in tar format (OCreate only selected diractories
[Mcampress the contents of the file
@ et > Eneh [ cancel

3 Select the projects you want to archive.
4 Designate where you want the archive file saved.
5 Select the archive format (zip or tar).

6 Select whether you want to compress the contents of the file and whether to keep the directory
structure for files (recommended), then click Finish.
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19.10 Exporting To a File

You can use the export feature to export everything you create in Designer, from projects containing
all Identity Vaults and their driver sets down to a single policy. If you export a driver configuration
file that contains only a policy, Designer creates the parent containment objects, such as a channel, a
driver, or a driver set, as part of the exported policy object. Such parent containment objects do not
contain attributes; they are only the framework of the channel, driver, or driver set.

The exported .xm1 files are compatible with those used by the iManager driver configuration file
plug-ins for Identity Manager 2.0.2 and later. This allows you to export configuration files from
Designer and import those files through iManager or through Designer’s import feature.

You can export a driver configuration to a file from a number of places, including:

¢ Section 19.10.1, “The Export Context Menu,” on page 390
¢ Section 19.10.2, “Exporting Configuration Files from the Modeler View,” on page 391
¢ Section 19.10.3, “Exporting Configuration Files from the Outline View,” on page 391

19.10.1 The Export Context Menu

To export all driver sets, drivers, channels, and policies found in the Modeler view:

1 Right-click the driver set in the Outline View.
2 Select Export to Configuration File.

Froject MNawigator

= 1l Blanstonz
= Blanston Inc.
fl momTEST
=80 iver St

E

0=
%m
0 =
- v

&) Document Selection...
[E] Import from File..,

8 Export to Configuration File. ..

Live 4

¥ Delete

Properties

(i i = =T

Designer takes the name of the driver sets and uses that name for the .xm1 file.

3 For future reference, name each driver set to denote that it is a driver set and denote the Identity
Vault it comes from. You can also add a date to the name. Click Save.

4 To close the Export Configuration Results window, click OK.

390 Designer 2.1 for Identity Manager 3.5.1



19.10.2 Exporting Configuration Files from the Modeler View

To export a driver set configuration file:

1 Double-click the System Model icon under a project name in the Project view to open the
project model in the Modeler view.

2 Right-click the Driver Set object inside an Identity Vault icon, then select Export to
Configuration File.

=-%&u, Driver Set

+ g Active Directory

=g GroupWwise
8 Mapping Rule Policies
2 Groupiwise_spplication
'3_% Groupiize_Repository
i test
Mz Mapping Rule
i Grouptise Filter

S

=R FLblisher

[ewy 4

& Simulate..,

8 Export to Configuration File. ..

Live 4

=)\ Froperties
Nrsresy

T T AT

3 In the Export Driver Configuration window, select a filename and location to use in future
references. You can also add a date to the filename if you save a lot of driver iterations.

By default, Designer uses the name of the driver or driver set corresponding to the object
selected. If you right-click an Identity Vault or Driver Set object, you see the Driver Set name
in the File Name entry. If you have more than one Driver Set object in the Identity Vault, you
see the Export Driver Configuration window with the name of that driver set in the File Name

entry for each Driver Set object.

4 Select the directory where you want to store the file, then click Save.

19.10.3 Exporting Configuration Files from the Outline View

You can use the Outline View to save driver sets, drivers, channels, and policy configuration files to
local, removable, or network directories. The following procedure documents steps for exporting

channels and policies.

1 Double-click the System Model icon under a project name in the Project view. This brings up
the project in the Modeler view.

2 Click the Outline tab.
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3 Right-click a channel object under a driver object, then select Export to Configuration File.

=-%1 Driver Set
& active Directory
=) Groupiise
Mapping Rule Palicies
21 Groupwise_spplication
_% Groupiise_Repository
i) test
M| Mapning Rule
% Grouphiise Filter

& Simulate..,

+H Export to Configuration File...

f Live »

= G)_L Properties

e R E st s kil RALR R

4 From the Export Driver Configuration window, select a filename and location to use in future
references. You can also add a date if you are backing up multiple iterations of the file.

Export Driver Configuration
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Desktop I myfiles @ DB 2. xml
I Seafang @ Manage Modify,xml
I Active Direchory2,xml @ mydriverset,xml
"‘/' ctive Directory, xml @ Schemalapping. xml
ctive Directory_Publisher06 2606, xml @ template, xml

My Documents

ctive Directory_Publisher, sxml

- L0Z-0306, xml
5])3 D0Z_Publisher, xml
L Blanston_xfer_ta_IDM.xml
by Computer
‘Q File harne: |Active Directony_Publisherd21507. sml hd | [ Save ]
My Metwark | Save as type: | * sl - | ’ Cancel ]

By default, Designer uses the name of the driver or object corresponding to the object selected.
You might also need to designate that it is the Publisher channel of an Active Directory driver,
along with the date when you saved the file.

5 Click Save.
6 In the Export Configuration Results window, click OK.
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To export one or more policies from a driver or channel:
1 From the Outline view, right-click a Policy object and select Export to Configuration File.

=i Subscriber

Create

Placem
il Grouphiyise
=-ig) Userapplicatio

M= Schemahia
T IdentityTra 8 Export to Configuration File...
K= PurgeEntith

@% Userapplic:
%) Publisher | 9 Delete

& Subscriber
=3 Lsarannlics

Live 4

You can also use the Ctrl key to select more than one policy, then right-click them as a group
and select Export Policy to Configuration File.

2 From the Export Driver Configuration window, select a filename and location to use for future
reference. You can also add a date if you are backing up multiple iterations of the file.

3 Click Save for each policy selected; each policy is saved to its own .xm1 file. By default,
Designer uses the name of the policy or rule selected.

4 Tn the Export Configuration Results window, click OK.
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The Novell XML Editor

This section provides an overview of the features of the Novell XML Editor. Topics include:

¢ Section 20.1, “About the Novell XML Editor,” on page 395

¢ Section 20.2, “Using the Source Editor,” on page 401

¢ Section 20.3, “Using the Tree Editor,” on page 402

Section 20.4, “Attaching Schema or DTD,” on page 403
Section 20.5, “Setting XML Editor Preferences,” on page 405

20.1 About the Novell XML Editor

The Novell XML Editor lets you create, edit, and validate XML files.You can edit XML files in
either the Source or Tree editor. You can customize the certain behaviors, such as code completion,
in the Preferences tab.

*

*

The Novell XML editor is built on the Web Standard Tools (WST) project architecture.

*

Section 20.1.1, “Creating XML Files,” on page 395
¢ Section 20.1.2, “Validating Files,” on page 400

*

Section 20.1.3, “Outline View,” on page 400

*

Section 20.1.4, “XPath Navigator,” on page 400

20.1.1 Creating XML Files

You use the New XML File Wizard to create new XML Files. The wizard can create an empty XML
file or a generated XML file based on an XML schema or DTD. Generated files contain skeleton
XML data that is generated based on a given root element and an XML Schema or DTD.

To launch the New XML File Wizard:

1 Select File > New > More Projects.

The Novell XML Editor 395



2 Open the XML Folder, select XML then select Next.

@ Create XML File

Create XML File

Select how you would like to create your XML file,

(O Create %ML File From a DTD file
(O Create %ML file From an %ML schema File

Cancel

3 Choose one of the source options on which you want to base the new XML file.

Option

Description

Create XML file from a DTD file

Create XML File from an XML schema file

Create XML File from scratch

Generates an XML document containing a root
element and a skeleton based on a DTD that you

either import or choose from an existing catalog
entry.

Generates a skeleton XML document containing
a root element and skeleton based on a schema

that you either import or choose from an existing
catalog entry.

Creates an XML document containing the XML
Declaration with the version and encoding
attributes set to 1.0 and UTF-8 by default.
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4 Click Next. The wizard prompts you to supply the name and location for the new file.

@ Create XML File

¥ML File Name LL‘[jrl

The Folder is emply, X
LX|

Enter or select the parent Faolder:

T=F ControlTestProject
1=F PreferenceTestProject

File name: | \ewFile. xml

@

5 Fill in the fields as follows:

Field Description

Enter or select Parent Folder Specify where the wizard should create the new
file.

File Name Specify the name of the new file.

Advanced>> Click this button if you want to specify that the
new XML file should link to another file in the file
system.
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6 If you chose to create the file from scratch, click Finish, otherwise click Next. You are
prompted for the catalog entry (shown below) or Schema or DTD.

@ Create XML File X

Select DTD File L 1

Select the DTD file ko create the XML file,

() Selact file From workbench
(#) Select ML Catalog entry

XML Catalog

Key LURI:

[} VSCHDTD #HTML 1.0 Frameset)/ER jar :file: s fProgram Files/MovelliDesigner/,
@ -1 WECDTD WHTML 1.0 SkrictfJEM jar:File:C: fProgram Files/Movell/Designer/. ..
@ -1 MWECHDTD ®HTML 1.0 Transitional/fEM  jar:File: C: fProgram Files/MNovel/Designer/. ..
[O] -}y DD =HTML 1. 1EN jar :file: s fProgram Files/MoveliDesigner/, .
@ -1 WACHDTD ®HTML Basic 1.07/EMN jar:File:C: fProgram Files/Movell/Designer/. ..
(O] - sPRORUMIDTD WL 1.1//EN jar :file: s fProgram Files/MoveliDesigner/, .
@ - MAPFORIMIDTD WL 1,3 /EM jar:File:C: fProgram Files/Movell/Designer/. ..

@ - APFORIMJDTD XHTML Mobile 1.0/, jar:file:C: fProgram Files/MNovel/Desianer/. ..

@ l < Back ” Mext = l

7 Fill in the fields as follows, then click Next:

Field Description

Select file from workbench If you choose this option, you must select from a
list of DTDs or schemas in your workspace. You
can also choose to import a new schema into
your project if the schema is not available.

Select XML catalog entry Choose one of the XML Catalog entries from the
list. You can edit this list in the Preferences >
Web and XML > XML Catalogs.
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8 Click Next. You are prompted to specify the Root Element.

@ Create XML File

Select Root Element

Select the root element of the XML file,

Root element:
set
Conkent options
[]create optional attributes
[ create optional elements
Create first choice of required choice
Fill elements and attributes with data

Docurment bvpe information
Public 1D:

System ID: | docsysx/Dedfnovdocx.ded

Finish l [ Cancel

9 Fill in the fields as follows:

Field

Description

Root element

Create optional attributes

Create optional elements

Create first choice of required choice

Fill elements and attributes with data

Choose or type the new document’s root
element.

Select if you want the wizard to generate
optional attributes.

Select if you want the wizard to generate
optional elements.

Select if you want the skeleton XML to always
contain the first choice in a required choice. If
this is not selected, no elements are inserted for
the choice.

Select if you want the wizard to generate dummy
data in the file for elements and attributes.

The generated XML inserts the node name as
the data of the elements
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Field Description

Public ID Specify the file’s Public ID

System ID Specify the file’s System ID.

10 Click Finish.

You can launch the editor by double-clicking an existing XML file.

20.1.2 Validating Files

You can validate your XML files using the right-mouse menu in the Source editor. If any validation
errors or warnings occur, they are displayed in the Problems view.

20.1.3 Outline View

The editor provides an Outline view containing a tree that displays the structure of the XML
document including its nodes are the elements, attributes, text nodes, comments, and so on from the
document.

The Outline tree is closely connected to the Source editor and the Tree editor. When you edit a
document in either the Source or Tree editor, the Outline tree updates automatically. If the editing
results in a document that isn't well-formed, the structure displayed in the tree might seem odd. But
the structure corresponds as closely as possible to the well-formed parts of the document.

Editing or generally moving the cursor in the Source Editor or changing the selection in the Tree
editor expands and selects the corresponding node (if possible) in the Outline tree. This makes it
possible to easily locate the current place in the document.

In a similar fashion, selecting a node in the Outline tree moves the cursor in the Source editor to the
textual position of the node (if the Source editor is active) or change the selection in the Tree editor
(if the Tree editor is active). The Outline view provides structural editing capabilities such as
inserting and removing nodes.

20.1.4 XPath Navigator

The XPath Navigator view supports context-sensitive editing of XPath expressions and syntax
highlighting. It automatically attaches to the currently selected XML editor and uses its Document
node as the evaluation context. The namespace context shows all namespaces in scope on its
document element.

The view consists of two parts—an editor pane and a results table. When the user types an
expression in the editor pane and pauses for 0.5 seconds, the result is shown in the table. If the result
is a node list, each row in the table displays an icon for the node type, a short description of the node,
and the location of the node in the text (line numbers). Selecting a row in the table selects the text of
the corresponding node in the XML editor. However, this is only supported in the Source Editor.

Typing Ctrl-Space, /', '[' or '(" triggers code-completion—the expression is evaluated up until the
cursor location, and insertable elements are shown in a drop-down box.
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20.2 Using the Source Editor

The Source editor supports the following features:

¢ Syntax highlighting.

¢ Context-sensitive code-completion based on DTD and/or XML Schema.

The code completion is based on the existing content of the XML document if no DTD or XML
schema is associated with the XML document. When code completion is activated and the
XML document contains <root><a><b/></a><a></a></root> once you type the
second <a>, the editor suggests that you add b as a child of the a element.

editor indicates the error.

+ General text editing operations such as undo, redo, cut, copy, paste, select all.

Figure 20-1 XML Source Editor

Eile Edit Project Tools Live Window Help
if-E & ®x
ER=|

B i e

SEon 1| ContralTestProject - Developer

ft *PickList TestForPamela, saml

<7xml wersion="i.0%3>
<repeatingRovs XmlnS=TUrn:com.myes.dewo. erplovec-dataTs
<rows
<idrl</ids
<fname>Duke</ fname>
<Iname>Ellingtonc/ lneme>
<hireDate>2002-01-04</hireDares
<3alary>50000.00</ salary>
</raw>
<rows
<idrz</ide
<fname>Fars</ fneme>
<lnawexWaller</ Inawe>
<hireDats>2002-01-04</hireDats>
<=salary>20000.00</salary>
</rouws
<rous
<ido3e/id>
<frawe>Charlie</ fnames
<lnsme>Parker</ lnames>
<hireDate>1899-07-18</hireDate>
<galary>70000.00</5alary>
</rows
<rous
“id>4</ics
<Enzme>Johne/ Ename>
<lname>Coltrane</ lnams>

Path: [*local-name()="repeatingRows *[local-namel j="row (1] ftext()[6]
XML Surce | XML Tres

@ Designer - EmployeeListData. xml - Designer EEX

| ) Designer |

0 e = Read-Only Smart Insert

8:

34

The XML Editor toolbar contains the following:

As-you-type validation. If the XML is invalid (for example, the > is removed from a tag), the

Table 20-1 XML Editor Toolbar
Button Description
Expands all foldings (if code folding is enabled).
+

You can enable/disable code folding in two ways.

+ Selecting Windows > Preferences > General >

Editors. Select Structured Editors. Select

Enable Code Folding.

ruler. Access the Folding submenu.

+ In the Source editor, right-mouse in the left
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Button Description

Collapses all folding (if code folding is enabled)

Attaches a schema. For more information on using
this feature, see Section 20.4, “Attaching Schema
or DTD,” on page 403

Shows help

The Source editor right-mouse menu contains these options:

Table 20-2 XML Editor Source Editor Right-mouse Menu Options

Menu choice Description

Revert File

Cut, Copy, Paste, Undo,  Performs the common editor function.

Save

Format Document: Formats the entire document as specified in the preferences.
Active elements: Formats only selected elements.

Clear Validation Errors Clears reported validation errors from the Problems view.

Validate Validates the XML document and shows errors in the Problems view.

Preferences This is the same as setting preferences using the Windows > Preferences

option. For more information, see Section 20.5, “Setting XML Editor
Preferences,” on page 405.

20

.3 Using the Tree Editor

The Tree editor supports these features:

*

Direct editing: You can directly edit the text fields, for example, attribute values. It is possible
to edit element names, attribute names and values, namespace names and values, text, and
comments.

Insertion: You can insert new nodes using the Tree editor’s right mouse menu. The right mouse
menu allows you to insert nodes as children before or after the selected node. If the node is an
element, you can insert attributes. The submenus for Add Child, Add After, Add Before contain
the node that can be legally added. If no schema or DTD is associated with the document the
submenus contain New Attribute or New Element.

Deletion: To delete a node, select it and either press the Delete key or use the right mouse menu
item Remove.

Drag-and-drop inside the tree and between trees.

General editing operations such as undo, redo, cut, copy, and paste.
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The Tree Editor is a table-tree editor that displays the XML nodes where the value of each node is
displayed in a table-cell next to the tree node. It uses the standard WST icons for elements,
attributes, text, and so on.

Figure 20-2 XML Editor Tree Editor

@ Designer - EmployeelListData.xml - Designer
File Edit Project Tools Live Window Help
e B 75| Desner |
i ControlTestProject - Developer T PickList TestForPamela.xrml =g
BB
P2 xml wersion="1.0" -~
= [€] repeatingRows
xmins urn;com.myco,dema . employee-data
=[] row
[e] id 1
[e] Fname Duke
[&] Iname Ellington
[E] hireDate 2002-01-04
(€] salary S0000,00
o [e] row
[e] id z
[e] Fname Fats
[&] Iname waller
[E] hireDate 2002-01-04
(€] salary 20000,00
(] row
& [e] row
# (€] row
& [e] row
[&] row
(€] row v
Path:
HML Source | KML Tree
2L Problems 22 w-=n
0 errars, 0 warnings, 0 infos
I° e % Read-Only [T D
The Tree Editor supports these options on the toolbar:
Table 20-3 Tree Editor Toolbar
Button Description
Expands all node
EI Collapses all nodes
@ Attaches a schema. For more information on using this features, see Section 20.4,
“Attaching Schema or DTD,” on page 403.

Launches help

20.4 Attaching Schema or DTD

Both Source and Tree editors allow you to attach an XML schema or DTD from the toolbar.

To choose from a list of entries in the XML catalog, choose an entry from XML Catalog Entry list.
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Figure 20-3 Attach an XML Catalog

Attach Schema or DTD

X

attach schema or DTD by either choosing an entry From the ¥ML Catalog
or point ko an XML schema or DTD in the file system

Zancel

To reference an XML schema on disk, choose XML Schema, then specify the namespace URI and
the file’s disk location.

Figure 20-4 Attach an XML Schema

Attach Schema or DTD

3

Select an entry from the XML Catalog,

Mamespace LIRI: |

File: |

]

Cancel

To reference a DTD on disk, choose DTD, then specify the Public and System IDs and the file’s disk
location:
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Figure 20-5 Attach a DTD

Attach Schema or DTD
Specify DTD identifiers and DTD File,

(1ML Catalog Entry () XML Schema (3

X

Publid 10 |

Swskem ID: |

File: |

=

20.5 Setting XML Editor Preferences

You can customize some XML Editor behaviors by setting preferences. You access the preferences
page through Windows > Preferences > Web and XML. You can learn more about these preferences

in the following sections:

¢ Section 23.7.4, “Task Tags,” on page 482
¢ Section 23.7.5, “XML Catalog,” on page 482
¢ Section 23.7.6, “XML Files,” on page 484
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Tools

*

*

Section 21.1, “Converting Earlier Projects,” on page 407

Section 21.2, “Opening a Web Browser,” on page 413

Section 21.3, “Launching iManager,” on page 413

Section 21.4, “Checking Your Projects,” on page 414

Section 21.5, “Managing Directory Objects,” on page 423

Section 21.6, “Configuring TLS for eDir-to-eDir Drivers,” on page 427
Section 21.7, “Viewing DSTrace Log Files,” on page 431

Section 21.8, “Working with Generic Resources,” on page 434

Section 21.9, “Updating Designer,” on page 435

For information on managing workspaces, perspectives, and views, see Chapter 8, “Workspaces,
Perspectives, and Views,” on page 99:

21.1 Converting Earlier Projects

The internal format for storing project information in Designer 2.1 differs from the internal format
used in earlier releases. Therefore, the Project Converter in Designer 2.1 converts earlier project
information to the Designer 2.1 file format.

Conversion is necessary when the following occur to an object in the model:

*

*

*

The object has been renamed.
The object has been removed.
An attribute name on the object was changed.

An objects’s relationship was changed by one of the following:

*

The objects points to a different object.

*

A different object points to this object.

*

The object is contained by a different object.
+ The object contains a different object.

The multiplicity of the relationship with another object has changed from one-to-many or from
many-to-one.

Conversion is not necessary under the following conditions:

*

*

*

*

*

*

A class is added
An attribute is added.
An additional relationship is added between objects.

A class inherits from a different class.

Section 21.1.1, “Converting Projects That Were Open,” on page 408
Section 21.1.2, “Converting Projects That Were Not Open,” on page 408
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¢ Section 21.1.3, “Running Later Projects on Earlier Designer Versions,” on page 412

21.1.1 Converting Projects That Were Open

If an editor was open when you last closed Designer, and Designer requires a later file format when
Designer is launched again, you receive a prompt:

Figure 21-1 Prompt: Newer Format

2 Warning E|

Restaring project "Digitalfirlines", but it requires a conversion ko the newer
M Designer Format,

il

‘hen Designer launches, the editors will automatically close,

‘ou will then need to open this project From the Project wiew so that it can be
propetly converted.

When you proceed, Designer closes all the editors, even if they belong to other projects, because the
projects probably need to be converted. This procedure ensures that you must manually re-open each
project. The Project Converter can then back up and convert the project if Designer detects that these
tasks are necessary.

When editors are automatically closed, the input focus is set on the Project view.

Scenario: An Editor Is Open. Using Designer 2.0 M4, Nelson created the StarPlus project. It was
open in the Modeler when Nelson closed Designer.

Nelson installs Designer 2.1. When Designer 2.1 launches, it closes the editor and then opens it
again. Designer detects that the StarPlus project requires a new file format. The Project Converter
Wizard backs up the project and converts it to the new Designer 2.1 file format.

21.1.2 Converting Projects That Were Not Open

To convert projects that were not open in an editor when Designer was closed, open the project by
doing one of the following:

¢ Double-click the project in the Project view.

¢ Right-click the project in the Project view, then select Open.

Although you can open a project in the Navigator view by clicking the project’s . proj file, Novell
recommends that you use the Project view instead. Otherwise, the Navigator view takes you into the
raw file system.
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To convert an earlier project:
1 In the Project view, expand the project, then double-click System Model.

-
Cutline = B

H =

i '@ docurnentation
2 peSOUFCES

When Designer opens the project file, Designer understands the new format. Designer
successfully loads the project into memory because the file format matches the model elements
in the newer Designer.

2 Review the steps, then click Next.

@ Project Converter x|

Converting project "Strokkur_z.omM4"

This project needs to be converted to 2.1,
1t was last used with Designer 2.0 M4,

If wou proceed, the wizard will do the Following:

B8 Back up your project.

28 Convetrt to the new format.

8 Log the changes to a file

2 DOpen your new project

= Back Caonvert Cancel

3 Name the project, then click Nexz.
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The Project Converter backs up your project before converting. You can accept or change the
default name.

@ Project Converter x|

Back Up Project m

Before wou conwert the project, it will be backed up to the project name
you specify belaw,

Backup Mame: |5tmkkur_2.nM4.|:.ak1 Reset |

@ You should hold on ko this backup For a while just be be safe, especially if
wou are using this project with nightly builds or release candidates.

If you edit the name but want to return to the default, click Reset.

4 Convert the project by clicking Convert.

@ Project Converter |

Pre-Conversion Summary

Review the following before converting your project:

your project will be backed up to: Strokkour_2.0M4.bak1

@ Designer now tracks the Identity Manager version of each server, Because this
project does nok have versions yet, they have been defaulted to 3.5.1.

You can access the Properties page of any server and chanage this version

number so khat Designer can belp make sure your configuration works in your
targek environments,

Click, Convert to begin,

[ Canverk Cancel

The converter changes, adds, and removes references, attributes, and elements. It might also
create new files or delete old ones. It converts the project file to the new, correct file format. A
progress bar displays during the backup and conversion. Converting very large projects might
take a few seconds.
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5 View the conversion log by clicking View Log.

@ Project Converter x|

Results Summary

Conversion Success: 40 files changed.

«f Backed up ko: Strokkur_2.0M4,bakl
" This backup can be opened with Designer 2.0 M4,
+f Older versions of Designer are on the Download Site's archive page.

v Conversion.log was created in the root of the backed-up project,

Wiew Log... |

= Back Mext =

Close |
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The conversion. log file is in the project folder in the Workspace directory (for
example, c: \documents and
settings\skopaildigitalairlines\conversion.log).

#fj conversion.log - Notepad -0 x|
Eile Edit Format Help

Designer Conversion —

Date Converted: September 22, 2007 1:55%:10 p.m.
Project Backup: C:QDDCL,ImEH‘ES and settingshusernamehworkspaceh,st

Converted From: 2.0 mMd (File Format wersion: 1.1.1.1)
Comserted To: 2.1 (File Format version: 2.0 M5
Platform: windows 2000

=» Rename driver element in Filters

1. 032513DE-E1CF-CBCE-CDEE-072AG54203F5. Filterpolicy
®*# penamed 1 <policyDriver: element to <drivers

2. 532CB9DE-Al3C-ABSA-7C4D-65EB47DD7529. T Tterpolicy
*® peanamed 1 <policyDrivers element to <drivers>

3. COSF0T73C-5A7FS-4B8B6-F40C-77AAMFD410556. Filterpolicy
% penamed 1 <policyDrivers element to <driver:

4. EBB744E4-ZEFF-5ABS-FFS1-G6C32F77238F3.Tilterpolicy
## penamed 1 <policyDrivers element to <driver:s>

»» Rename applicationschema attribute in Driwvers

1. OD1FF558-5A05-DAAT-EFIE-270L101AG5A459. driver (Driver)
% penamed 1 "applicationschema" attribute to "appsSchema'

6 Open the project.

Regardless of the internal format (for example, Designer 1.2 or Designer 2.1), Designer always
deploys to the proper format of the target Identity Manager environment.

The converter ensures only forward compatibility. It does not ensure backward compatibility. You
can’t convert to a newer release of Designer and then convert back if you want to return to an older
release. If you need to go back to an earlier format, use the project’s backup file.

21.1.3 Running Later Projects on Earlier Designer Versions

Designer 2.0 M5 or later (including Designer 2.1) does not let you load a project created in later
Designer versions if the file format has changed between versions.

For example, Designer 2.0 M4 and Designer 2.1 use different formats. If you create a project in 2.1,
you cannot open that project in 2.0 M4. Instead, a message informs you that you can’t open the
project because it requires the later version of Designer.

Even if the version formats are the same, it isn’t a good practice to run later projects on earlier
versions of Designer. Later versions of Designer have additional bug fixes and features that might
make more use of the existing format. Therefore, going back to an earlier Designer version could
result in a degraded experience.
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21.2 Opening a Web Browser

You can open a Web browser by using Designer. The Web browser button is available from the main
toolbar.

When you first launch the browser, you are prompted for a home page. After you enter the URL, it is
stored in Preferences.

To change the URL:

1 Select Window > Preferences.

2 Select Designer for IDM .

3 Click the Browser tab.

4 Type the new URL, then click OK.

21.3 Launching iManager

To launch iManager from within Designer:

1 Right-click the Identity Vault, then select Live > Open iManager.

<! Undo Change Location

ey

=== Shrajighiten Conneckions
[j! Select Connected Applications

Distribute »
Align

? Change to eDirectary Tree
. Chamge ba Identity Yault [ Meta-Diteckory:
Sy A bo Group

& Manage Yault Schema...

Document Selection, ..
71 Import Schema From File. .
Export ko File 4
E-Mail Templates 4
Live 4 | Impart...
(W
3 Delete & Deploy
%% Campare. ..
Properties

Schema 4

{0 Open iManaget. ..
Q& Erowse Idenkity Vault. ..

B Driver Status. ..
i Statk Drivers
ﬁ Skop Drivers
@ Restart Drivers
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You can also select Tools > iManager.

2 Enter credentials.

Designer stores the credentials in a history for subsequent launches.

3 Click OK.

21.4 Checking Your Projects

Designer provides a Project Checker tool to check your project. The project can be checked at any
time, but you should run the Project Checker before deploying your project. The Project Checker
checks for proper design, contexts, server associations, policies, missing user data, and dependency
problems that would cause the deployment of project into the Identity Vault to fail. It only checks
the objects in Designer; it does not check the current objects in the Identity Vault.

¢ Section 21.4.1, “How to Check Your Project,” on page 414
¢ Section 21.4.2, “Customizing the Project Checker,” on page 418
¢ Section 21.4.3, “Items That Are Checked,” on page 421

21.4.1 How to Check Your Project

1 Select the project in the Modeler or in the Project view.
2 Select Window > Show View > Other.
3 Expand Designer for Identity Manager, then double-click Project Checker.

wWindow  Help
J Ejl @ show Yiew
i@: I type Filker text

wdeler I -] Propetties ﬂ
2] Tasks

[#-[= Debug

E-(= Designer For Identity Manager
?" Drataflow

% eDirectary Browser

-2 Policy Set

~le=r Project

E,‘ Project Checker
B‘? Search Results
-1iE Trace

(== Help

Help

== PDE Runtime

@ Errar Log
5F Plugrin Registey LI

K I Cancel |

You can also click the Project Checker icon #at the top of Designer to bring up the Project
Checker view.
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The Project Checker is displayed in a new view.

Figure 21-2 Project Checker
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Severity | Error Description | Model Object

Jl |

4 Click the Run the Project Checker icon.

e

»E@7 =0

Results filtered: {9 of 9 items )
Sewer...  Error Description
The driver set does not contain a deployment context.
& Placerment policy on the Publisher channel doesn't exist.

Groupwyise does not have a schema mapping policy.
Entitiements are not supported by the driver filter.
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hone of the policies in the Subscriber channel perform a...

Class MarvauxClass in the driver filter is missing from th...
attribute Marvatlrl part of class MarvauxClass in the dri...

Model Object A
Driver Set.Blanston Inc.
Grouptise.Oriver Set.Blanston Inc.
Grouptise.Oriver Set.Blanston Inc.
Grouptise.Oriver Set.Blanston Inc.
active Directory.Oriver Set.Blanston Inc.
Schematapping. Active Directory.Driver Set.Blar
Schematapping. Active Directory.Driver Set.Blar
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If you haven’t saved the project, Project Checker prompts you to save it.

The Project Checker displays versioning conflicts, errors, warnings, and information messages

about the project.

Figure 21-3 Errors Listed in the Project Checker View

18 proc cred WY

Results non-filtered: { & of § ikems )

Severiby I Error Descripkion I Model Object I
[x] Identity Yault 2 is missing the Host Mame. Identity Wault 2
[x] The driver set does not contain a deploym...  Driver Set.Identity Vaulk 2
oy The driver filker is empty, This disables syn... Driver Filker,Driver.Driver Set, Identity Yaulk
o The driver filker is empty, This disables syn... Driver Filker,Driver, Driver Set, Identity Waulk 2
o Driver does not have a schema mapping po... Driver,Driver Sek, Identity Yaulk 2
G} Identity Yault user password is not stared i... | Identity Yaulk
G} Identity Yault 2 is missing the User Mame. Identity Wault 2
G} Identity Yault 2 user password is nak skore, .. Identity Wault 2

To see more information, double-click an item.
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Figure 21-4 Details of an Item

Description: & Placement policy on the Publisher channel doesn't exist.

Severity: | WARNING

Model Elernent: Active Directory, mydriverset.IDM_TREE

Line Mumkber:

Details: your filter settings indicate that you want to publish data to the Identity

Yault, If you want to add new objects through the Publisher channel, you
most probably need a Placement policy, If you only update existing
objects, you might be fine without the Placement policy.

Solution:

[5]:4 l [ Cancel ]

The expanded view lists a description of the message, the severity of the message, and which object
caused the error. If there is a line number, it lists the line number where the problem occurred. If
there is a known solution for the message, it is also listed.

You can use the Configure Filters icon to customize which object types are checked. For more
information, see “Customizing the Project Checker” on page 418.
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Figure 21-5 The Configure Filters Icon

Project Ch ::::} Lmj Q;?.. ¥ =08
Results filtered: (9 of 9 items )
Sever... Error Description Mode| Object )
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You can save the results to a file. Browse to a location and specify a filename and file type, then

click Save.

Figure 21-6 Saving the Results of the Project Checker

:%D@%vz'ﬁ

Results filtered: (9 of 9 items )
Sever...  Error Description

The driver set does not contain a deployment context.

& Placement policy on the Publisher channel doesn't exist,

Mone of the policies in the Subscriber channel perform a...

Groupise does not have a schema mapping policy.

Entitlements are not supported by the driver filter,

Class MarvauxClass in the driver filter is missing from th...

attribute Marvatirl part of class MarvauxClass in the dri...
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A

Mode| Object S
Driver Set.Blanston Inc,
Groupivise.Driver Set.Blanston Inc.
Groupivise.Driver Set.Blanston Inc.
Groupwise.Driver Set.Blanston Inc.
Active Directory. Driver Set.Blanston Inc.
Schemalapping. Active Directory. Driver Set.Blar
Schemalapping. Active Directory. Driver Set.Blar
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The Project Checker allows you to view the messages in a hierarchical format or in a flat format. It
allows you to limit the object-specific messages that are displayed. Click the Menu icon for more

choices.

Figure 21-7 Changing the View

Results filkered: {9 of 3 items )
Sever...  Error Description

The driver set does not contain a deployment context.

& Placerment policy on the Publisher channel doesn't exist.

Mone of the policies in the Subscriber channel perform a...

Groupise does not have a schema mapping policy.

Entitlements are not supported by the driver filter,

Class MarvauxClass in the driver filter is missing from th...

atribute Marvatirl part of class MarvauxClass in the dri...
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Model Object -
Driver Set.Blanston Inc,
GroupWvise.Driver Set.Blanston Inc.
Groupivise.Driver Set.Blanston Inc.
Groupivise.Driver Set.Blanston Inc.
Active Directory. Driver Set.Blanston Inc.
Schematapping. Active Directory Driver Set.Blar
Schemalapping. Active Directory. Driver Set.Blar
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The drop-down menu has the following options:
¢ Hierarchical Layout: Displays the messages under Identity Manager and Provisioning
headings.
+ Flat Layout: Displays all messages without the hierarchical structure.
¢ Auto-check on Save: Automatically runs the Project Checker every time you save a project.
¢ Configure Filters: Allows you to customize which objects are checked.

¢ Preferences: Limits the number of messages that are visible. The default is 100 items.

Figure 21-8 Views

fa- Hierarchical Layout

® i Flak Layout

i:g futo-check on Save

}:bCDnFigure Filters. ..
2~ Preferences. ..

21.4.2 Customizing the Project Checker
You can customize the Project Checker by creating and editing filters. The filters allow you to

receive messages about the items you want to verify. You can create multiple filters, but only one
filter can be used at a time.
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Figure 21-9 Customizing the Project Checker

@ Filters
Create and Edit Filters

to see for this filker,

Filters:

allows you to create a filter, add a description, and select the filtered items you want

Driver Sets and Drivers

| New Filter... | [Edit

Filtered Items:

deritity I .

] &pplication

[] Credential Provisioning
Driver

Driver Set
[JECMASCript

(] E-mail Template
] Entitlements

[] Icentity Resource
[] Identity 4ault
[]ob

[]Library

| £

=

Filter Description

“ersion conflict, errors, warnings, and
infor mational messages about driver sets and
drivers,

Severity

Yersion Conflict Error

Warning Infor matian
Errar Description
Where description | contains v|
Ok l [ Cancel

To create a filter:

-
1 In the Project Checker, click the Configure Filters icon

2 Click New Filter.

3 Specify a name and description for the filter.
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You can select which items are checked, what types of messages are returned about the items,
and use key words to limit the messages returned. For example, you can search for all messages
about the Driver Set and Driver objects that contain the word “attribute”.

@ Filters 3
Create and Edit Filters

Allows you to create a filter, add a description, and select the filtered items you want
to see for this filter.

Filters:
Driver Sets and Drivers

Filter Description

Yersion conflict, errors, warnings, and
informational messages about driver sets and
drivers,

| 2w Filter... | Edit... || Delete |

Filtered Items;

B [ Identit agement Severity
[] Application
[] Credential Provisioning
O fver Wiarning Infarmatian
Oriver Set
[] ECMASEript Error Description
[]E-mail Template
[] Entitlements
[] Identity Resource |

[] Iddentity %ault

[]ib
[]Library

version Conflict Errar

Where description ‘ contains w |

£

)] Ok, ] [ Cancel

4 Click OK.
To edit the name and description of the filter:

1 Select the filter, then click Edit.
2 After you have completed the changes, click OK.

To delete a filter:

1 Select the filter.
2 Click Delete.
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21.4.3 Items That Are Checked

The Project Checker looks at specific items in the project. It checks the items in the User
Application as well as the rest of Identity Manager.

The following table describes the specific items that are checked. The list will increase with each

release of Designer.

Table 21-1 Identity Manager Items That Are Checked

Item Description

Driver .

*

*

Checks for the presence of a Schema Mapping policy.
Checks for an invalid Active Directory container.

Checks the trace level setting. If it is set to more than 0, an informational
message is displayed.

Checks to see if the LoopBack driver is being used instead of the eDirectory™
driver.

Verifies that the GUID attribute is set to synchronize on the Subscriber channel.

Verifies that the GUID attribute is not set to synchronize on the Publisher
channel.

Checks the classes on the Publisher and Subscriber channels that are set to
Ignore and verifies that the attributes for these classes are not set to
Synchronize.

Checks for the presence of a filter and makes sure it is not empty.

Checks to make sure that the Publisher Placement policy does not contain set
operation destination DN or set xml attribute operations.

Checks for the presence of a Publisher Placement policy.

Checks to make sure that no policy on the Publisher channel contains set
operation destination DN or set xml attribute operations.

Checks to make sure that the Subscriber Placement policy does not contain
set operation destination DN or set xml attribute operations.

Checks to see if the Subscriber Placement policy is missing.

Checks to make sure that no policy on the Subscriber channel contains set
operation destination DN or set xml attribute operations.

Checks to make sure that the npsmDistributionPassword attribute and the
public-private key pair attributes do not simultaneously exist in the User class.

Checks to make sure that the authentication method on the Active Directory
driver is set to Negotiate when synchronizing passwords.

Checks the filter for invalid data.

Checks the driver to see if it is publishing both NDS® and Distribution
passwords. If it is, this is an invalid setting.

Checks for the presence of the nspmDistributionPassword attribute in the User
class in the Filter, if password synchronization is enabled.

Checks that the nspmDistributionPassword attribute is set to sync or notify, if
password synchronization is enabled.
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Item

Description

Driver Set

E-mail Template

Entitlements

ECMAScript
Identity Vault

Job

Library
Mapping Table
Policy

Schema

+ Checks to make sure that the deployment context for the Driver Set object is
set.

+ Checks to make sure that a server object is associated with the Driver Set
object.

Checks to see if the e-mail notification template is empty.

+ Checks to see if the driver supports entitlements.

* Checks to see if the attribute DirXML-EntitlementRef is added to the
Subscriber channel, if there are policies that use entitlements in the driver.
The DirXML-EntitlementRef must be set to Notify or Synchronize for the
entitlements to work.

Checks to see that the ECMAScript object can run only on Identity Manager 3.5.

+ Checks to see if the username to authenticate to the Identity Vault is missing.
+ Checks to see if the hostname for the Identity Vault server is missing.

+ Checks to see that the password for the user is not stored in the project.
Checks to see that the job object can run only on Identity Manager 3.5.
Checks to see that the library object can run only on Identity Manager 3.5.
Checks to see that the mapping table object can run only on Identity Manager 3.5.

+ |If there are global configuration values in the policy, it checks to make sure they
exist on the Driver or Driver Set object.

+ Checks to see if local variables are defined before they are used.

+ Validates the policy against the DTD.

+ Checks to see if the class is missing from the schema.
+ Checks to see if the attribute is missing from the schema.

+ Checks to see if the attribute for the class is missing from the schema.

Table 21-2 Provisioning Items That Are Checked

Item Description

Configuration Verifies that the XML is well-formed and complies with the schema
that defines the elements needed for entities, attributes, lists,
relationships, and so on.

Entity + Checks every entity to ensure that references to other entities

and global lists are valid.
+ Ensures that every entity has at least one attribute defined.

List Ensures that every local and global list contains at least one item.

Org Chart Relationship Verifies that the entities and attributes of a relationship have been
deployed.

Provisioning Request Definition Verifies that a workflow follows rules for activities and flow paths.
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21.5 Managing Directory Objects

Sometimes it is necessary to locate or modify objects during your project development. Rather than
using a separate management interface, you can use the eDirectory Object Manager to browse to and
edit attributes of objects in the following locations:

¢ The Identity Vault
¢ Other eDirectory trees

Figure 21-10 Sample eDirectory Object Manager view

= [2] META
=--{@] data
f_’? devices
(%! aroups
= [:,_} USErS
3
d?; jsamuels
= [ﬁ syskem
[ﬂ admins
f_’? Servers
=18 services
@ idm
Clz'ﬂ Role Based Service 2
ﬂ custormui
= m Security
w& META CA
i Kap
rﬂ Security Policy
5 Autharized Login Methods
¥ Lagin Palicy
_|—le Authorized Post Login Methods
Password Policies
£7 CRL Container
£ Issued Certificates
@ Defaul: Motification Collection
@ SecretStore

To launch the eDirectory Object Manager, use the tool-based method or the task-based method. The
method you use is largely a matter of preference and the target directory that you will browse.

¢ Section 21.5.1, “Tool-Based Method,” on page 424

¢ Section 21.5.2, “Task-Based Method,” on page 425

¢ Section 21.5.3, “Browse, View, or Modify Object Attributes,” on page 425

¢ Section 21.5.4, “Advanced Editing,” on page 427
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21.5.1 Tool-Based Method

To access an eDirectory tree other than the Identity Vault, or if there is no Identity Vault defined in
your current project, use the tool-based method. You can always launch the eDirectory Object
Manager from the Tools menu, even when an Identity Vault isn’t selected in the Modeler.

1 Click Tools > eDirectory Object Manager.

Projectngals Live Model Mindow Help

| § &% DS Trace Viewer. ..

==+ eDirectory Object Manager

(_l:l iManager. ..

<; Access User Application. ..

2 Select an Identity Vault.

Select Tree

Login Credentials

Hosk Mame: |131.65.158.188 ﬂ @

Uset Marne: | admin. skrane

Password: I [rm———

[" | Save password

QK I Cancel

4 Access information by using icons on the eDirectory Object Manager’s toolbar

Table 21-3 Icons on the eDirectory Object Manager’s toolbar

Icon

Descriptions

+

Expands all containers in the currently selected tree.

IMPORTANT: This might be a heavyweight operation if you have a
million-object tree.

Collapses all expanded containers in the currently selected tree.

Adds a new custom tree, which persists across sessions.

424 Designer 2.1 for Identity Manager 3.5.1



Icon Descriptions

Removes trees previously added with the Add Tree operation.
Automatically discovered trees cannot be removed.

Refreshes the currently active tree.

m %%

Displays an object’s properties.

Expansion states and selection states are persistent between sessions per tree.

21.5.2 Task-Based Method

To use the eDirectory Object Manager to browse the Identity Vault in your current project:
1 Select Live > Browse Identity Vault.

You can also right-click the Identity Vault object and select Live > Browse Identity Vault.

2 In the eDirectory Browser, browse to and select an object.
The eDirectory Object Manager automatically does the following:.

+ Populates the field by inserting the Identity Vault directory credentials (Host name, User name,
Password)

¢ Displays the Identity Vault directory structure

21.5.3 Browse, View, or Modify Object Attributes

After you have populated eDirectory Object Manager with one or more directories, you can browse
the directory tree for specific objects, and view and modify object attributes.

Table 21-4 Objects That You Can Modify

Object Description
Container Object Double-click to expand a collapsed container or to collapse an expanded
container.

Right-click and select Properties to open that object’s attributes page.

Select the object and click the Open properties of this object icon Tin the
Action bar.

Leaf Object Double-click (or right-click and select Properties) to open that object’s
attributes page.

Select the object and click the Open properties of this object icon “inthe
Action bar.
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Figure 21-11 eDirectory Object Manager Attributes List

Properties of mkurtz
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Attributes:
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21.5.4 Advanced Editing

Figure 21-12 The Advanced Object Editor

Properties of bjesse

“hdvanced $napi
i SEEEE e |

Cther |

Given Name:

|Elen

Last Hame:

|Jesse

Full Hame:

|Elen Jesse

Account: [ disabled

Password Expires:
July B, 2007 7:04:00 PM MDT

Description:

Photo:

Groups:

2L 00-Agents.groups.data

(1] Add || Delete |

eMail:
[707@miuk |

Phone:

Ben Jezze, oubleshooter

[222-222-2222 |

Fax:
444-444-2444 |

Pager:
|555-555-6555 |

mobhile:
[333-333-3333 |

| OK || Cancel || Apphy |

21.6 Configuring TLS for eDir-to-eDir Drivers

*

*

*

21.6.1 Prerequisites

Section 21.6.1, “Prerequisites,” on page 427
Section 21.6.2, “Enabling TLS,” on page 428

Section 21.6.3, “Creating Certificates,” on page 430

Identity Vaults exist in your physical network tree as well as in the Modeler.

Each Identity Vault is set up. Otherwise, you are prompted for setup information when you try

to create certificates.

Each driver set is associated with a server.

Using the eDir-to-eDir driver’s General property page, verify that each driver has a name and a

deploy context. The context might be inherited from the driver set.

The eDir-to-eDir drivers have been deployed. Otherwise, Designer cannot create certificates.

To find out whether the driver has been deployed:

1. Right-click the eDir-to-eDir driver.
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2. Click Live > Deploy.
3. In the eDir-eDir Driver Deployment dialog box, click No.

If the driver has been deployed, the Compare Status field in the Deployment Summary dialog
box displays Equal or Unequal. Otherwise, the field displays Not Deployed.

After objects have been deployed, the objects should show as equal unless passwords are set in
eDirectory that are not set in Designer. Designer does not deploy passwords unless they are
specifically set in Designer. This exception prevents overwriting passwords in eDirectory
because Designer cannot import them.

21.6.2 Enabling TLS

1 Launch the TLS Configuration dialog box.

A common way to launch the dialog box is to right-click the eDir-to-eDir application, then
click Secure Connection Settings.

El 11 infrasctructure 1

I-f Disconnect eDit-ta-eDir
=== Straighten Connection
Distribute
Align

iy Documnent Seleckion. ..

Live

¥ Delete

Other launch points:

+ Select the eDir-to-eDir application, then click Model > eDir-to-eDir > Secure Connection
Settings.

+ Right-click eDir-to-eDir in the Outline view, then click Secure Connection Settings.

+ Right-click an eDir-to-eDir driver, click Properties > Driver Configuration >
Authentication, then click Configure TLS.

The Configure TLS button displays only on eDir-to-eDir driver pages.
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2 Click Enable SSL/TLS.

.TLS Configuration ﬂ

" 13 Infrasctructure Tree trusts IT ID Wault @

2T ID Waulk trusks 13 Infrasctruckure Tres
%" putual Trust

QK I Cancel |

3 (Optional) Use the Advanced TLS Configuration to select key size, hash algorithm, and validity
period.

The validity period is important for when a certificate has expired and you need to overwrite or
create a new one.

4 Select a direction of trust.

33 Infrasctructure Tree trusts IT 1D Vaulk @

€ JT 1D Yault trusts 13 Infrasctructure Tree
& Mubual Trust

These options apply to certificates that Novell creates for eDirectory. The options do not apply
to third-party security certificates.

The default is Mutual Trust, which could be considered the most secure.

Unless you want to use the certificate for authentication, the option that you select doesn’t
matter. If only encryption is important, you can select any one of the three options.

If authentication is important, select the option that gives you the appropriate trust.

Scenario: JJ Infrastructure Tree Trusts JT ID Vault. JJ Infrastructure Tree is the
organizational Certificate Authority. JJ Infrastructure Tree signed a certificate and placed it in
JT IDVault. JT ID Vault trusts JJ Infrastructure Tree. The two vaults synchronize data through a
secure connection.

If the two vaults break their trusted relationship, JJ Infrastructure Tree can prevent sensitive
data from being synchronized by revoking its certificate.

Scenario: JT ID Vault Trusts JJ Infrastructure Tree. JJ Infrastructure Tree creates two
certificates. One is placed in JJ Infrastructure Tree, and the other is placed in JT ID Vault. The
two vaults synchronize data through a secure connection.

If the two vaults break their trusted relationship, JJ Infrastructure Tree can prevent sensitive
data from being synchronized by revoking its certificate.

Scenario: Mutual Trust. JT ID Vault and JJ Infrastructure Tree both sign certificates.
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5 Click OK.
After you click OK, Designer does the following:
+ Modifies both eDirectory drivers.
¢ Locks the User ID field, which displays on the driver configuration’s Authentication page,

because both drivers must use that field.

You can enable or configure TLS without immediately deploying the drivers. You can turn the
settings on. However, you can’t create SSL/TLS certificates unless the drivers have been deployed
into their respective Identity Vaults. If you enable SSL/TLS but want to create certificates later, you
can do so. When you later deploy the eDir-to-eDir drivers, Designer guides you through steps to
automatically create certificates.

21.6.3 Creating Certificates

A driver’s Properties page enables you to configure a driver so that you can deploy it. Similarly, the
Enable SSL/TLS option enables you to set up your configuration for TLS and then, when you are
ready, create and deploy the certificates. When you deploy a configured driver set or select Create
eDir-to-eDir Certificates, Designer creates the certificates in the directory.

This section assumes that you have enabled and configured SSL/TLS for the deployed eDir-to-eDir
drivers.

1 Right-click the eDir2eDir application.

eyl — ;
_"..-:"- - — ] "f
L] Disconneck eDir-to-eDir MPL““

= Straighten Connection

Exchange 5_5

Diskribute 4
Align 4
Sy Add ko Group
?" Show Dataflow Yiew

[ Secure Connection Setkings. ..

Docurment Selectkion. ..

Live L

¥ Delete

2 Click Live > Create eDir-to-eDir Certificates.
You can also do one of the following:

+ Right-click the eDir2eDir object in the Outline view, then click Create eDir-to-eDir
Certificates.

¢ The first time that you enable and configure SSL/TLS on driver’s Authentication tab, click OK,
then follow prompts. A Create Certificates dialog box appears. Click Yes.

Scenario: Enabling TLS. TLS has not been enabled. Sandy selects Live > Create eDir-to-eDir
Certificates. Designer prompts Sandy to enable SSL/TLS. Sandy clicks OK, enables TLS, selects a
direction of trust, and clicks OK. Designer creates certificates.
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Scenario: Deploying eDir-to-eDir Drivers. Sandy has configured the eDir-to-eDir drivers and the
driver set. A context displays in the driver set’s Deploy Context field. Sandy is ready to deploy the
driver set.

Sandy right-clicks the driver set, then clicks Live > Deploy Driver Set. Designer prompts Sandy to
deploy both eDirectory drivers. (Otherwise, Designer can't successfully create certificates.) Sandy
clicks Yes. Designer builds a deployment summary, then lists items that are associated with the
Identity Vaults and will be deployed. To deploy the drivers, Sandy clicks Deploy.

Because the driver set is already configured, Designer creates the certificates.

For additional information on eDir-to-eDir certificates, see eDir-to-eDir SSL/TLS in Preferences.

21.7 Viewing DSTrace Log Files

The DSTrace view is an editor that enables you to view DSTrace log files. These log files contain
information (including XML data) about the Metadirectory.

Figure 21-13 The DS Trace View

Basic | Enhanced XML

The DSTrace view is not the same as the Trace view, which provides information about Designer
functionality. For information on the Trace view, see Section 23.3.13, “Trace,” on page 467.
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To view DSTrace log files:
1 Click Tools > DS Trace View.

|T|:|0Is Live Model ‘Window Help

ﬁ;& eDirectory Object Manager

(ﬂ iManager. ..
{ Access User Application. ..

2 Navigate to and open a DSTrace log file.

| In Folder

Search X | | MName

Erew | S 5] psTRaAcE.LOG
] DSTRACE.LOG

@ Search for Files and Folders 2] DSTRACE LOG

Search for files or folders named:

Idstrace.log

LContaining text:

Look in;
IQ Local Harddrives [C:] j

C:\Documents and Settingsiusemame\Recent
CiiDocuments and Settingsiworkspace\KvedjuriDocumentsi Trace Files
Cii\Documents and Settingsiworkspace\kvedjur_2.0.baklresourcesiTrace Files

x| e ®EekE

2]

m.avigatar | Cutline |

File name: ID STRACE.LOG j DOpen I
Filez of type: I"_ log J Cancel |
y/
= E-\‘
=

EI '[5- Kwedjur
iy System Model
@ documentation
E---[B resources
E-E= Trace Files
Ll DSTRACE.LOG

To import these log files, drag them from the file browser or the desktop and drop them in the

Project view’s resources folder.

3 Filter the trace based on date and time.

j Clear Filker |

ﬁl
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4 View XML information in the .10g file by clicking Enhanced XML.

»

sources/ Trace Files 1

Start Time: | End Time: | | clear Filterl

=l

<default-password display-name="Default Notes Ps
<defsult-http-password display-name="Default HT]
</subscribher—-optionss
</init-params:>
</ inputs>
</ ndsx
<fsubscriber-init>
<publisher-init:>
<hds dtdwversion="zZ.0" ndsversion="g.x">
<S0Urce>
<product version="2.0.5.51 ">DirXML</prc
woontactxMello., Inc. </ contacts
<fsourceﬂ
<input:
<init-parsms sro-dn="%EDZ-TREEY EMGCY 3er
<authentication-info>
<zerver>MTORLNAPOSS Server/f MO+

T, PO | o mm i mmmde e e -

< |

DirXML: [01/24/05 19:15:36.17]: ation-term display—na.me=ﬂ
<rinimurn—pwd-len display-name="Minirmun Notes Pac—!

<u=2er>BMOEDS Connector/ON/EBMO</ 1 =
o v

Basic | Enhanced XMLI

Designer highlights the XML code. This feature can be helpful when you want to see the
various parts of the XML documents in the trace file. [f no XML exists in the file, content in the

Basic tab displays.

5 Search for content that you are interested in.

@ Find/Replace
Eind:

Replace wwith; I j FOe
Juls
—Direction ———— roope ————————— CC
% Forward @l oF
" Backward € Selected Lines | o1
FOC
—Options futs
[ Case Sensitive [ Wrap Search Coc
[ whole Word [ Incremental -
™ Reau : hr:
eqular expressions Lo
noc
Find I Replace/Find | oc
E o
Replace | Feplace 4l | | -
a ht:
asel 1

Tools
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To quickly find information in the .1og file, click the Search icon, enter text in the Find field,
then click Find.

You can also access the Find/Replace dialog box by pressing Ctrl+F or by clicking the main
menu’s Edit > Find/Replace path.

21.8 Working with Generic Resources

A Resource object is stored in a Driver object or a library. A Resource object stores parameters,
which drivers use at any time. When multiple drivers need the same set of constant parameters, the

drivers use a Resource object.

A Generic Resource object in Designer enables you to store information in XML or text format. The
information can be a piece of documentation, notes, or some piece of data that policies access.

¢ Section 21.8.1, “Creating a Generic Resource Object,” on page 434

¢ Section 21.8.2, “Editing a Generic Resource Object,” on page 435

21.8.1 Creating a Generic Resource Object

1 In the Outline view, right-click a driver, then select New > Resource.

8

o,

Exl
@ 1 vak Al
B omrEST

EE Driver Set

- |(RAe) — v D . R

_____ Y TS ' s vicion.
..... H ot Copy b &5 Credential Repositary,..
""" E Pas: @" Show Dataflow Yiew BEY (DAl Sedgt...

----- A Pas: P=1 ECMASCript. .

""" .ﬂ Res o Simulate. . T Entitlemert. ..

""" -_ﬂ Res [ Show Policy Sets & 100

----- ME| Sch "

..... acti K] Run Configuration Wizard. .. =] Mapping Table...
[:If'_;l Pub s Password Synchronization. ..

You can also do one of the following:
¢ Right-click a driver, then select New > Resource.
+ With the Dataflow view active, right-click a Subscriber or Publisher channel, then select
New > Resource.
¢ In the Outline view, right-click a library, then select New > Resource.
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2 Specify the name of the Generic Resource object.

.New Resource

Set Resource Name

Enter a name For your new resource.

ooog

ame: |Lit|a><MLResource

Content bype:  [KML

L

¥ ©pen the editor after creating the object

QK I Cancel |

3 Select the content type, XML or Text.

4 Select Open the editor after creating the object, then click OK.
5 In the File Conflict dialog box, click Yes.

6 Specify the desired XML or text, then press Ctrl+S to save the resource object.

21.8.2 Editing a Generic Resource Object

1 In the Outline view, below the library, right-click the generic resource object, then select Edit.
2 In the File Conflict dialog box, click Yes.
3 Make changes, then save (Ctrl+S).

21.9 Updating Designer

When you start Designer, you are prompted about how you want to receive updates. You can change

this setting in Preferences.

Figure 21-14 The Updates Tab

@ Preferences

| tvpe filker kexk

=10l |

Designer for IDM =l -

- General
BB Cesiqner For IDM

- Configuration

- Dacument Generation
- Enkitlements

- iManager

- ImportfDeploy

- Language

[+~ Modeler

- Palicy Builder

- Project Checker

- Schema

=+
s}

Yersions Updates |Eru:um|:uts | Browser |

{* Do not check for updates
" Prompt to check For updates on skartup

" Automatically check For updates on startup

[v Maotify me when no updates are available

LRL: Ihttp:Il',l'www.nm-'ell.com,l'c0DIs0|utiunsIl'dirxmI,l'designer,l'updatesitez_tl_
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If you select to not automatically update Designer, you can get updates by using the Help menu or
the Welcome page.

To update from the Help menu:

1 Click Help > Check for Designer Updates.

+ If your version of Designer is up-to-date, a prompt informs you that no updates are
available.

+ [f an update is available, a prompt lists components that you can update. Select
components, then click OK.

+ Ifyour version of Eclipse needs to be updated before you can install Designer 2.1, a dialog
box prompts you to click the URL that takes you to the Designer download site.

2 Select updates, then click OK.
To update from the Welcome page:

1 Click Help > Welcome.
2 Click the What's New icon.

3 Click New Updates.

4 Follow prompts to download and install the latest Designer.
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Editing Icons for Drivers and
Applications

The Icon editor enables you to create customized icons for your drivers and applications. You can
enrich predefined templates or images with labels, choose background images and colors, and
overlay images. Within minutes, you can create a custom branded icon for your implementation,
including your company’s logo or name.

1 In the Modeler, select a driver, then click Properties.

.Pruperties for Delimited Text

| type Filker text 7. iManager Icon

. General
+ Global Configuration e (&) This is the icon that will be used to reprasent the
. Driver Log Level

. Driver Configuration
. Driver Manifest

. Mamed Passwords

driver in the iManager Web interface,

=] Jn A ) SR R L

. iManager Icon
. Trace
. Engine Contral Yalues

w00

e, , | Edit, .. |ﬁrnwse...|

The object properties dialog box displays the default icon.
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438

2 Click iManager Icon > New.

“Icon Editor

File

—Preview

— Infarmation

Criginal

L Dimensions: 100 x &0
File Size: 4K

File Format: PRG

Zoomed

Configuration:

Object: nfa

Last Saved As:  <unsaved>

Template:

Mame: Drriver

Description: Identity Manager Driver Icon (Manager)
File: driver.cct

abels I Crwerlay Images I Settings I Derivations I

Background Colar: I REFFFFF

Background Image: I

3 To enter text for your icon, select Labels, then click Add.

[ =101 x|
File
- Preview - Information

[

Object: nfa

Last Saved Ast <unsaveds

Template:

Name: Driver

Description:  Identity Manager Driver Icon {iManager)

File: driver.cct

Original

Dimensions: 100 x 80
File Size: 4k
File Farmat: PG

Zoomed

Ba[kgruun(LahE‘SDver\ay Images | Settings | Derivations |

Text [ Offsetx | Offsst | Size [ Color [ Font

4 12 12 . #000000 Arial

:Add}l ) Delete

Updata Clase

To edit the label, click new in the fext column, type a new label, then click Update.

You can edit the label, control its placement through the Offset X and Offset Y options, and edit

font size, font type, and color.
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4 To add an overlay image to your icon, select Overlay Images, then click Add.

[ o [=] B3
Fie
~Preview ~Information
e :
Object: nfa
Last Saved Ast <unsaved>
p" " Template:
. . 3 Name: Driver
QI Im |tﬂ¢_ Description:  Identity Manager Driver Icon (iManager)
il | File: driver,cct
Original
Dimensions: 100 x 80
Flle Size: 9K
File Farrask: PG
Zoomed
Background | Labels  Overlay Images | Settings | Dertvations |
[ Offsetx | Offsst | Size [
~lis a0 40
Add | Delete
Update Close

To select an image, click the cell in the File column, select a filename from the drop-down list,
then click Update. To place the image farther below the text, increase the value in the Offset Y

column.

5 To add a background color or image to your icon, select Background.

‘IconEditur

File

~Preview ~Information
Configuration:
Object: nfa
Last Saved Ast <unsaved:>
Template:
Name: Driver

Zoomed

Criginal

Dimensions: 100 x 80
File Size: 126
File Format: PNG

Description:  Identity Manager Driver Icon {iManager)
File: driver.cct

Background |Lahels | Owerlay Images | Settings | Derivations |

sackyround ok |

Background Image: |

To change the background color, click the Browse button next to the Background Color field,
select a color form the palette, then click OK. You can also click the Browse button next to the
Background Image field, select a filename from one of the folders (for example, gradients),

then click Open.

To change the background image, click the Browse button next to the Background Image field,

T

select an image from the applications folder, then click Open.
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6 To create a similar icon for iManager, select Derivations, then select Driver or Application.

Background I Labels I Cwerlay Images I Settings Derivations |

I &

Jelimied

This transfers the icon to the driver’s or application’s iManager properties. (See the iManager
icon on the driver properties page.)

® Properties for Driver i ]

| type filker bext 7. iManager Icon R i

. eneral
+ Global Configuration v (%) This is the icon that wil be used to represent the
. Driver Log Lewvel

. Driver Configuration
. Driver Manifest

. Mamed Passwords
iManager Icon

-8, Trace
-9, Engine Contral Yalues

driver in the iManager Web interface,

~1 J= T R

e, . | Edit... | B_rowse...l

Restore Defaults | Apply |
1] | &

'éf' (0]4 I Cancel |

7 When you are finished editing the icon, click Update.
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Setting Preferences

¢ Section 23.1, “Finding Preference Pages,” on page 441

¢ Section 23.2, “Preferences: General,” on page 441

¢ Section 23.3, “Preferences: Designer for IDM,” on page 448
¢ Section 23.4, “Preferences: Help,” on page 469

¢ Section 23.5, “Preferences: Novell,” on page 470

¢ Section 23.6, “Preferences: Provisioning,” on page 470

¢ Section 23.7, “Preferences: Web and XML,” on page 470

23.1 Finding Preference Pages

You customize Designer by setting options in Preferences.

1 From the main menu, select Window > Preferences.

.Preferem:es _ Ol x|
| kyvpe Filker bext General Sl -
" " [~ Always run in background
[#- Desigrer For IDM
__ Help ™ Keep nextiprevious part dislog open
B Movel Iv show Heap Status
[#]- Provisioning T s
- Web and XML
B-Wieb an * Double dlick,
" Single click
™| select om hover
I™ | Spen when using arrow keys
Mote: This preference may nok kake effect on all views

2 Seclect a heading (for example, Designer for IDM) or navigate to a subheading.
3 Make changes, then click Apply or OK.

23.2 Preferences: General

¢ Section 23.2.1, “Appearance,” on page 442

¢ Section 23.2.2, “Capabilities,” on page 444

¢ Section 23.2.3, “Compare/Patch,” on page 444

¢ Section 23.2.4, “Content Types,” on page 444

¢ Section 23.2.5, “Editors,” on page 445

¢ Section 23.2.6, “Keys,” on page 447

¢ Section 23.2.7, “Perspectives,” on page 447

¢ Section 23.2.8, “Startup and Shutdown,” on page 447
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¢ Section 23.2.9, “Web Browser,” on page 448
¢ Section 23.2.10, “Welcome,” on page 448

Table 23-1 Preferences: General

Setting

Description

Always run in background

Keep next/previous part dialog open

Show heap status

Open mode: Double click
Single click: Select on hover

Single click: Open when using arrow keys

Searches all the preferences and shortens the tree
view, depending upon what you type in the edit box.

Enables operations to run in the background
without disturbing you.

Keeps the editor and view dialog boxes open when
an activation key is released. Normally, the dialog
box closes as soon as the key combination is
released.

Places a field in Designer’s bottom right corner and
displays the amount of memory being used of total
memory available.

Opens a project when you double-click it.
Selects the setting when the cursor hovers there.

Opens the setting when you select it.

23.2.1 Appearance

Figure 23-1 Preferences: Appearance

@ rreferences o ]
I tvpe Filker text Appearance g -
- General Current Presentation:
[2B Appearance
- Capabilities IDeFauIt {ourrent) ﬂ
- CamparefPatch [~ owerride presentation settings
E;l:tent Types —Editor tab positions
- Editors = Top £ Bottom
- Keys
- Perspectives —Wigw tab positions
- Startup and Shukdow % Top € Bottom
- Web Browser e . ek -
- YWalcome erspective switcher positions

£ Left € Top Left £ Top Right

+]- Designer For IDM
+- Help

L Current Theme:
+- Pravisioning

[V | Showe text o the perspective bar

E
E
- Mowvel
E
E

+- Web and XML IDeFauIt (current)
[ Show traditional style tabs

I Enable animations
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Table 23-2 Preferences: Appearance

Setting Description

Current Presentation: Override presentation Alters how the tabs and views appear in the
settings workbench

Editor tab positions Positions tabs on the Modeler, Novell® XML Editor,

or Text Editor at the top or bottom.

View tab positions Positions view tabs (for example, the Project view
tab) at the top or bottom of views.

Perspective switcher positions Positions the Perspective Switcher & at the left,
top left, or top right of the workbench.

Show text on the perspective bar Determines whether text (for example, Designer)
displays next to the icons in the Perspective
Switcher.

Current theme The general theme (colors and fonts) that Designer
uses.

Show traditional style tabs Displays square Windows-style tabs. The

alternative is rounded tabs.

Enable animations Animates views (for example, Fast Views) and
editors that you minimize, maximize, or restore.
Reinforces tasks in Designer.

¢ “Colors and Fonts” on page 443

Colors and Fonts
To change a color:

1 Expand an option (for example, Basic).
2 Select an item (for example, Active hyperlink text color).
3 Click the color button.

L]

4 Seclect a color from the Color palette, then click OK.
To change a font:

1 Expand an option (for example, Basic).

2 Select an item (for example, Banner Font).
3 Click Change.

4 Select a font, style, and size, then click OK.
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23.2.2 Capabilities

Currently, this section relates to Eclipse functionality. Designer functionality will be implemented
later.

¢ “Prompt When Enabling Capabilities” on page 444

Prompt When Enabling Capabilities

Eclipse lets you turn off capabilities. However, Eclipse sometimes detects that you need the
capability, depending on how you use the product, and automatically turns the capability on again.
This feature doesn’t apply to Designer 2.1.

23.2.3 Compare/Patch

This Eclipse functionality customizes the behavior of the comparison editor. When you select to
compare or synchronize two or more resources in the Workbench, one or more comparison editors
usually open.

Table 23-3 Preferences: Compare/Patch

Setting Description

Open structure compare automatically Makes visible an additional information area that
shows differences in the underlying structure of the
resources being compared. This information might
not be available for all comparisons. The default is

On.
Show additional compare information in the status Causes the status line to display additional context
line information about the comparison. The default is
Off.
Ignore white space Causes the comparison to ignore differences that

are white space characters (for example, spaces
and tabs). Also causes differences in line
terminators (LF versus CRLF) to be ignored. The
default is Off.

Automatically save dirty editors before patching Controls whether any unsaved changes are
automatically saved before a patch is applied. The
default is Off.

For information on 7ext Compare, refer to the Eclipse documentation.
23.2.4 Content Types

Table 23-4 Preferences: Content Types

Pane Description

Content types The type of content (for example, HTML or XML)
that a file contains.
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Pane

Description

File associations

The file extension that is associated with a content
type. For example, . xml is associated with a file
that contains XML content. To add a file
association:

1. Select a content type.
2. Click Add.
3. Define a new file type, then click OK.

23.2.5 Editors

Table 23-5 Preferences: Editors

Setting

Description

Size of recently opened files list

Show multiple editor tabs

Close editors automatically

Number of opened editors before closing

When all editors are dirty or pinned

The number of files to add to the file menu of
recently opened files, which you can easily reopen.

Displays tabs for all opened projects. If you
deselect this option, only one editor tab displays.
However, an abbreviated name displays on the
editor tab.

Automatically closes the first-opened editor when
you open additional editors. This option prevents
displaying too many editors and cluttering the
workbench.

Determines how many editors can be open. For
example, if you specify two and then open a third
project, the first-opened project automatically
closes.

Prompts you to save unsaved components in the
project that is about to automatically close, or to
open an additional editor.

+ “File Associations” on page 445

¢ “Structured Text Editors” on page 446

+ “Text Editors” on page 446

File Associations

Enables you to associate editors (whether internally installed in the Designer, or an external
application) with file types (extensions) so that you can edit files.

To find out which editor is associated with a file type, select the file type. For example, a . docgen
file type is associated with Style Editor, buta . scriptpolicy file type is associated with Policy

Builder.
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To associate an additional editor with a file type:

1 Select the file type.
2 In the Associated Editors pane, click Add.
3 Select an additional editor, then click OK twice.

To add a file type:

1 In the File Types pane, click Add.

2 Type the extension (for example, . doc) for the file type, then click OK.
3 Inthe Associated Editors pane, click Add.

4 Select an editor for that file type, then click OK twice.

Structured Text Editors

For information on structured text editors, refer to the Eclipse documenation.

Text Editors

Table 23-6 Preferences: Text Editors

Setting Description

Displayed tab width The number of characters or spaces moved when
you press the Tab key in a text editor. The default is
4. The maximum is 16.

Undo history size Determines how many changes that you can undo
in an editor. The default is 25 changes.

Highlight current line Selects the line that has focus.

Show print margin Controls whether the print margin is visible. A
vertical line identifies the margin.

Show line numbers Numbers each line in the editor.

Show range indicator Controls whether an editor displays a range
indicator.

Support hyperlink style navigation Determines whether hyperlink-style navigation is

supported. If you put a link (for example,
www.novell.com) in a text editor, press Ctrl, and
hover the cursor over the link, Designer launches
the link and loads it into an HTML view inside
Designer.

Disable overwrite typing mode Controls whether Overwrite Typing mode is
enabled. The default is Off.

Appearance color options To change an option’s color, select the option, click
Color, select a color, then click OK.

For additional information on text editors, see the Eclipse documentation.
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23.2.6 Keys

Enables you to view a table of all of the keyboard mappings, change those mappings, and add new

mappings.
23.2.7 Perspectives

Table 23-7 Preferences: Perspectives

Setting

Description

Open a new perspective

Open a new view

Open the associated perspective when creating a
new project

Available perspectives

In the same window: Places a new icon in the
Perspective Switcher, so that you can toggle
between perspectives in the same window.

In a new window: Opens a new perspective in a
different window. You can toggle between
perspective windows by selecting icons on the
taskbar.

Within the perspective: Opens the view so that it is
contiguous to the Modeler.

As fast view: Opens the view and places a Fast
view in the bottom left corner of the perspective.

Determines how and when you switch to an
associated editor when you open a perspective.

Designer is the default perspective. Use Designer.

23.2.8 Startup and Shutdown

Table 23-8 Preferences: Startup and Shutdown

Setting

Description

Prompt for workspace on startup

Refresh workspace on startup

Confirm exit when closing last window

Plug-ins activated on startup

Prompts you for a workspace folder. You can have
multiple workspace folders and can specify a folder
on startup.

Synchronizes the workspace with resources (for
example, myfile.xml) on disk.

Displays an Exit Designer? prompt when you exit
Designer.

Lists plug-ins that are automatically loaded and
registered.
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23.2.9 Web Browser

Table 23-9 Preferences: Web Browser

Setting

Description

Use internal Web browser

Use external Web browser

External Web browsers

Enables you to use an internal Web browser.

Enables you to add and use an external browser
(for example, Netscape®). If you enable this option,
you must also enable Use External Browser in the
Help section (also found in Preferences).

Lists browsers.
To add a browser:

1. Click New.
2. Name the new browser.

3. Scroll to and select an executable (for
example, netscp6.exe).

4. Specify a parameter, then click OK.

23.2.10 Welcome

Table 23-10 Preferences: Welcome

Setting

Description

Home: Home Page Theme

Home: Root Pages

Enables you to select the theme that appears when
you click Help > Welcome.

Adds tabs (for example, Overview) on the Welcome
properties page. You add functionality by
customizing these tabs.

23.3 Preferences: Designer for IDM

¢ Section 23.3.1, “Versions, Updates, Prompts, and Browsers,” on page 449

¢ Section 23.3.2, “Configuration,” on page 451

¢ Section 23.3.3, “Document Generation,” on page 455

¢ Section 23.3.4, “Entitlements,” on page 457
¢ Section 23.3.5, “iManager,” on page 458

+ Section 23.3.6, “Import/Deploy,” on page 458

¢ Section 23.3.7, “Changing the Language Setting,” on page 460

¢ Section 23.3.8, “Modeler,” on page 461

¢ Section 23.3.9, “Policy Builder,” on page 465
¢ Section 23.3.10, “Project Checker,” on page 466
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¢ Section 23.3.11, “Schema,” on page 466
¢ Section 23.3.12, “Simulation,” on page 466
¢ Section 23.3.13, “Trace,” on page 467

23.3.1 Versions, Updates, Prompts, and Browsers

* “Versions” on page 449
¢ “Updates” on page 450
¢ “Prompts” on page 450

+ “Browsers” on page 451

Versions

Figure 23-2 Preferences: Versions

@ Preferences

| bype fileer text Designer for IDM

- General .
: Yersions |g|:u:Iates | Brompts I Browser I

= gnier Far IDM

- i_onfiguration

- Dacurment Generatian

. Entitlements Default Identity Manager Yersion: |3.5.1 'I

- iManager

| tiDepl

mport /Deploy Downgrade Motes
- Language
If wou downgrade the version, some elements of your
[+ Modeler ) . i . "
) . configuration might not wark in wour Earget environment,
[#1- Policy Builder IF thiis is the case, the Projeck Checker will infFarrm you of any

- Project Checker version-conflick problems,

- 5chema

- Simulakion Upgrade Notes

- Trace If wou upgrade the version, make sure that vou will eventually
[#-Help have this version in wour target environment. Otherwise,
- Mavell some of your configuration might not be deployable.
[#- Provisioning
[+-w'eb and XML

For more details on the key differences between the different
versions of Identity Manager, click here .

Specifies the Identity Manager version running on a server.
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Updates

Figure 23-3 Preferences: Updates

@ rreferences _ O] x|
|WDE Filker bext Designer for IDM P i
[#- General : ,
] [ ——— Versions Updates | Prompks I Browser I
- Configuration
- Document Generation {* Do nok check for updates
- Entitlernents
. " Prompt bo check For updates on starkup
-~ iManager
- Import/Deploy " pukomatically check for updates on startup
- Language
[#- Modeler
[#- Palicy Builder I¥ Motify me when no updates are available
- Project Checker LRL: | http:{ fea. novell.com)coolsalutions dirml i designer fupdatesitez_0_0
- Schema

Table 23-11 Preferences: Automatic Updates

Settings

Description

Do not check for updates

Prompt to check for updates on startup

Automatically check for updates on startup

Notify me when no updates are available

Prevents Designer from checking for updates on
startup. Hides the Designer Updates dialog box.

Displays a prompt each time you run Designer. You
can disable this prompt.

Always checks for updates. If you disable the
prompts that appear on startup, select this option.

Displays a No New Updates message when you
select to check for updates.

Prompts

Table 23-12 Preferences: Prompts

Setting

Description

Warn when downgrading server versions

Warn when upgrading server versions

Warn when another editor has updated files in the
same project space

Prompts you when you select an earlier server
version for a project. If you downgrade, some
elements of your configuration might not work in
your target environment.

Prompts you when you select a later server version
for a project. If you upgrade, some of your
configuration might not be deployable unless you
have this later server version in your environment.

Warns you that your project might be erased from
your workspace. The prompt occurs when
overwriting a file in the file system for notification
templates and policies.
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Setting Description

Warn when deleting items from the outline view Confirms that you want to delete the selected
items.

Browsers

You can use Designer to open a Web browser. The Web browser button is available from the main
toolbar.

Figure 23-4 The Web Browser button
| BB D - -

When you first launch the browser, you are prompted for a home page.

Figure 23-5 The Prompt for a Home Page

Web Browser Information

Enter the Home Page LIRL:

@ This information will be stored in Preferences, To change the URL, go
ko window = Preferences = Designer For IDM, then dlick Browser,

(04 I Cancel

After you enter the URL, Designer stores it.

To change the URL, type a new one in Preferences, then click OK.

23.3.2 Configuration

¢ “General” on page 451
+ “eDir-to-eDir SSL/TLS” on page 452
¢ “Prompts” on page 454

Each driver has a startup parameter. If it is disabled, the driver never starts until you change the
setting. By default, Identity Manager drivers are disabled when you create them in the Modeler or
start Designer. You must start them manually.

For more information, see Section 9.5, “Configuring Driver Sets,” on page 152.

General

These general settings specify how drivers start up and how their global configuration values
(GCVs) act on specified target servers. The default state uses Disabled and Merge GCVs.
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Figure 23-6 Configuring General Driver Settings
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- Trace

- Help

- Movell

[#- Provisioning

[+ w'eb and <ML

Table 23-13 Driver Settings: General

Setting Description

Auto-Start The driver automatically starts after you create it or
whenever you start or load Designer.

Manual You must start the driver manually.

Disabled The driver never starts.

Merge GCVs on the target server during copy Copies the GCVs from one driver/driver set to

multiple targets of the same type. For example, you
might configure GCVs on one driver and then copy
them to multiple drivers. You also have the option of
overwriting the target GCVs or merging your
“source GCVs” with the existing target driver GCVs,
if they exist.

Overwrite GCVs on the target server during copy ~ Overwrites existing GCVs when they are copied to

the server.

eDir-to-eDir SSL/TLS

This setting configures how two eDirectory drivers communicate with each other over a secure
channel. For more information, see Section 21.6, “Configuring TLS for eDir-to-eDir Drivers,” on

page 427.
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Figure 23-7 Configuring eDir-to-eDir Drivers

@ Preferences

| bype filker text Configuration

=101 %]

[+ izeneral . .
EI Designer For DM General  eDir-to-eDir SSLITLS |Er|:|m|:|ts I
B _onfiguration Preferred Key Size:
- Diacument Generatian |2D48
- Entitlements
- iManager Preferred Secure Hash Algarithmn:
- Impork{Deploy |SHA1-RSA
[] kqaﬂndgel'll:rge Preferred Walidity Period:
[+ Policy Builder |2 ¥Bars
- Project Checker
SFhemE_' Certificate averwrite policy
- Simulation
- Trace ™ Always overwrite existing certificates
- Help " Qverwrite certificates only if they have expired
- Novell " Mever overwrite existing certificates
[#- Provisioning
[+ w'eh and XML [ Restart drivers after building certificates

Table 23-14 eDir-to-eDir and SSL/TLS Settings

Setting

Description

Preferred key size

Preferred secure hash algorithm

Preferred validity period

Always overwrite existing certificates

Overwrite certificates only if they have expired

Never overwrite existing certificates

Specifies the preferred key size that is generated
when drivers are encrypted and stored in
eDirectory: 512, 768, 1024, or 2048 bytes.

Specifies the preferred hash algorithm to use when
encrypting drivers: SHA1-RSA, MD2-RSA, or MD5-
RSA.

Specifies the validity period for a driver certificate
ranging from 6 months to 10 years.

Specifies that existing driver certificates are
overwritten with each deployment. If you select this
option, Designer deletes existing certificates and
creates new ones. The new certificates are then
good for another two years (assuming the default
value is two years, as defined in the Preferred
Validity Period field.) If you select Live > Create
eDir-to-eDir Certificates, Designer deletes old
certificates and creates new ones

Specifies that only expired driver certificates are
overwritten with each deployment. This is the
default setting. The default expiration length is two
years. If a certificate expires, SSL/TLS stops
working. If a certificate is expired, Designer deletes
it and creates a new one.

Never overwrites driver certificates.
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Setting Description

Restart drivers after building certificates Restarts drivers after certificates have been
updated/created.

When you create certificates, Designer reads the preferences, including Preferred Key Size,
Preferred Secure Hash Algorithm, and Preferred Validity Period. These options are also available
through Secure Connection Settings > Advanced TLS Configuration.

Figure 23-8 The Advanced TLS Configuration Dialog Box

@ 1LS Configuration

TLS Configuration | &dvanced TLS Configuration I

Preferred Key Size:

2048 |

Secure Hash algarithnn:
[sHAL-RSA |

Yalidity Period:

|2 WEars j

NOTE: Designer reads these preferences after you first set them. If you subsequently change the
preferences by using the driver’s configuration page, those changes override the settings in
Preferences.

After you change default settings and click OK, that configuration information is recorded. When
you deploy the driver, Designer creates the certificates, or deletes and creates new certificates with a
new time stamp.

Prompts

These settings specify how users are prompted to manage driver certificates on the target server. All
are selected in the default state.

Figure 23-9 Configuring Certificate Prompts

.Preferem:es =10l x|
|t';-'pe filker texk Configuration = A
- General

- Designer For IDM General | eDir-to-eDir S5L/TLS  Erompts

& _onfiguration
- Dacurment Generatian
- Entitlements

[w Prompt to replace existing certificates
v Prompt to merge/overwrite GCVs on the target server during copy

|¥ Prompt ko create certificates after configuration

- iManager
- Import/Deploy rd Promnpt bo overwrite existing settings and policies From the Driver Configuration \Wizard
- Language Iv Prompt when policy operations affect multiple policy sets

[+ Modeler
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Table 23-15 Configuration Prompts

Setting

Description

Prompt to replace existing cetrtificates

Prompt to merge/overwrite GCVs on target server
during copy

Prompt to create certificates after configuration

Prompt to overwrite existing settings and policies
from the Driver Configuration Wizard

Prompt when policy operations affect multiple
policy sets

Prompts the user to provide new certificates.

Prompts the user to merge or overwrite when
copying GCVs to the target server.

Prompts the user to create certificates after
configuring a secure connection.

In the Driver Configuration Wizard, prompts the
user whether to reset (overwrite) all driver settings
and policies.

Turns on and off a warning dialog box associated
with policy operations. The dialog box appears
when you move policies in a pre-3.5 environment
and the move operation affects multiple policy sets.

23.3.3 Document Generation

The Document Generator comes with the following settings:
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Figure 23-10 Document Generation Settings

@ Preferences

type filter text Document Generation
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= Designer for I0M
Configuration
Document Geners
Entitlements
iranager
Import/Deploy

General

Mocdeler

[¥] sutarnatically open the rendered file after docurment generation
[¥]Show warning dialog box when the style is an older version
[“]Enable RTF suppart (experimental)

- B

Language

[¥]Document applications and drivers related to other selected iterns!

MWodeler

Palicy Builder
Project Checker
Schema
Sirnulation
Trace

Help

Mawvell

Provisioning

Weh and XL

English

Arial

E--E--E--B

Document Appearance
Select the language you want the document fo generate in:

Select the font to use for documentation:

w

¥l 5]

[Resb:re Defaults ] ’ Apply ]

||

[ 04 Cancel I

Table 23-16 Document Generation Preferences

Setting

Description

Automatically open the rendered file after
document generation.

If you have a PDF reader installed on your
workstation, the rendered file automatically opens
in the reader. If you have enabled the RTF format
and have a TRTF reader installed, the rendered file
automatically opens in the reader. The default is
On.

Show warning dialog box when the style is an older
version.

Shows a warning when generating documents on
out-of-version styles. The default is On.

Enable RTF support (experimental).

Allows you to save documents to RTF format. This
is a pre-release version. The default is Off.

Document applications and drivers related to other
selected items.

With this option selected, parent objects and direct
child objects are included to give context to the
document. Deselecting this option excludes direct
children of the selected item. The default is On.
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Setting

Description

Document Language

Allows you to select a language other then English
in which to generate documents. Languages
include Chinese Simplified, Chinese Traditional,
Dutch, English, French, German, Italian, Japanese,
Portuguese Brazil, and Spanish. The default is
English.

Font settings

Allows you to select the font you want to use for
document generation. This selection adds double-
byte font support. The default is Arial font.

23.3.4 Entitlements

Figure 23-11 Entitlements Settings

type filter text

General
= Desigrer for I0M
Configuration

Entitlements
Manager
Import/Deploy
Language
Madeler
Policy Builder

Schema
Sirnulation
Trace
Help
Mowel|
Prowizioning
Web and XML

A
[ -

Entitlements el

Document Geners

Project Checker

Add the DirxML-EntitlementRef atiribute to the driver filter
(& Prompt me each time I create an entitlement
O sbways add it
O Mever add it
(3) The DirXML-EntitiermentRef atribute will be added
only if it doesn't already exist in the driver filter, If

the atiribute already exists, the above selections
have no effect.

[Resmre Defaults ] ’ spply ]

[ Ol l [ Cancel I

Controls whether or how often you receive a prompt whenever you add the DirXML-EntitlementRef
attribute to a driver filter. The default is Prompt me, but because this attribute is added only if it
doesn’t already exist on the driver filter, you can select Always add it to not see the pop-up window.
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23.3.5 iManager

Table 23-17 Preferences: iManager

Setting

Description

iManager URL

Show Novell iManager Information Dialog

. The IP address and port for the iManager server

Prompts you for the URL to the iManager server
after you select Tools > iManager. If the URL is
missing or incorrect, iManager is unable to launch.

23.3.6 Import/Deploy

The Import/Deploy preference window contains five tabs: Deploy, Import, Export, Prompts, and
Trace. The following table describes their options.

Table 23-18 Preferences: Deploy

Setting

Description

Show the summary dialog prior to performing a
deployment

Replace driver set/server associations when
deploying a driver set

Always deploy both drivers of an eDir-to-eDir
connection when SSL/TSL is enabled

Restart running drivers after deploying the driver

Displays a summary of what is going to be
deployed. The default is On.

If you want driver set and server associations when
deploying, select this option. The default is Off.

With this option selected, you are prompted to
deploy both sides on the connection. With both
drivers deployed, Deploy is integrated with the
creation of eDir-to-eDir certificates, if the
certificates are created in Designer. Deploy
adheres to the settings set in Preferences >
Designer for IDM > Configuration > eDir-to-eDir.
The default is On. This is the recommended setting.

Restarts the driver after it is deployed. The default
is On.

Table 23-19 Preferences: Import

Setting

Description

Perform prompt checking when running a driver
configuration file

Displays the Do you wish to perform all mandatory
and required prompt checking when running this
Driver configuration file? prompt. If you select Yes
to the prompt, you must then enter information in
required fields while configuring the driver. If you
select No, you temporarily disable this setting and
can skip required fields.
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Setting

Description

Include application schema when importing drivers

Show the summary dialog prior to performing an
import

Imports the eDirectory application schema when
you select this option. You might not want to import
all the associated data. The default is Off. See
Section 15.4.3, “Importing a Schema,” on

page 288.

Allows you to view what'’s being imported in a
summary screen. The default is On.

Table 23-20 Preferences: Export

Setting

Description

Copy cross driver policy references into exported
configuration files

Selected by default, this option saves you the
trouble of manually inputting cross-driver policy
references.

Table 23-21 Preferences: Prompts

Setting

Description

Show dialog to export cross driver policy
references to configuration files

Show a warning dialog when overwriting a driver
set/server association

Show the dialog box to deploy both drivers in an
eDir-to-eDir system when SSL/TLS is enabled

Show the dialog box to restart drivers after a
deployment

Selected by default. If you do not want to see a
dialog box about these references, deselect the
option.

Warns that the driver set being deployed has a
different server association than the server that you
are about to deploy to. The association in the
deployed driver set overwrites the existing server
association.

This is the default, and it is also the recommended
setting. With this option selected, you are prompted
to deploy both sides on the connection.

Selected by default. If you do not want to see a
dialog box about these references, deselect the
option.

Table 23-22 Preferences: Trace

Setting

Description

Trace import and deploy event information

Generate debug messages for the Driver
configuration prompt dialog box

Show verbose debug messages

Deselected by default. If you need to troubleshoot
an import or a deploy, select this option, then open
the Trace view to inspect the import or deploy.

Deselected by default. If you need to generate
debug messages, select this option.

Deselected by default. If you need to generate
verbose debug messages, select this option.
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Setting Description

Time import and deploy operations Deselected by default. If you need to time how long
it takes to import or deploy an object, select this
option.

23.3.7 Changing the Language Setting

When you installed Designer, you selected a language to display Designer’s UI. This setting enables
you to change the language.

1 Select Window > Preferences > Designer for IDM > Language.

@ Preferences =] 3
|ty|:ue Filter bext Language T v
- General ) -
1 Designer for DM " Chinese Simplified
- Configuration {~ Chinese Traditional
- Dacument Generation " Dutch
- Entitlements & i
- iManager * English
- Impart/Deploy " French
" German
[ Modeler -~ _
[+~ Policy Builder Iesfiair
- Project Checker " Japaness
- Schema " Portuguese Brazi
- Simulation
r-\l .
- Trace Spanish
- Help
[+ Movell
[#]- Provisioning
[+ Web and XML

Restore Defaulks | Apply |

(7) kK, | Cancel |

2 Select a language, then click OK.
The Apply and OK buttons set the language and prompt you to restart Designer.

Restore Defaults reads the config. ini file, detects the previous language setting, and then
defaults to that setting. When the changed property is written back to the . ini file, all
comments are removed from the file. To preserve these comments, Designer copies the original
config.initoconfig.ini.bak anduses the backup to determine the default setting.

3 Restart Designer.
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23.3.8 Modeler

¢ “Modeler Tabs” on page 461
¢ “Dataflow” on page 464
+ “Palette” on page 465

Modeler Tabs

+ “Behaviors” on page 461
+ “Display” on page 461

¢ “Guidance” on page 462
¢ “Layouts” on page 462

+ “Pages” on page 463

+ “Prompts” on page 464
¢ “Themes” on page 464

Behaviors

Table 23-23 Preferences: Modeler Behaviors

Setting

Description

Auto-create servers when connecting a driver to a
different driver set

Launch the driver Properties dialog box

Show the driver’s Policy Flow view

Automatically creates a server for a driver set when
you connect a driver to a different driver set.

Launches the driver’s Properties page.

Displays the driver’s Policy Flow diagram in the
Outline view.

Display

Table 23-24 Preferences: Modeler Display

Setting

Description

Show labels by Applications and Identity Vaults
(Arhitect. mode)

Show driver icons in Developer mode

Show password icons in Developer mode

Auto-expand Identity Vaults to fit contents

Auto-shrink Identity Vaults to fit contents

Shows labels below applications (in both modes)
and above Identity Vaults (Architect mode only).

Displays a driver icon i- on the line that represents
a driver in the Modeler.

Displays a password sync icon . below a driver
icon in the Modeler.

Causes Identity Vaults to expand to accommodate
objects that you place in them.

Causes Identity Vaults to shrink when you remove
objects from them.
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Setting

Description

Auto-size Identity Vaults to fit their titles

Grid Width

Enables vaults to expand horizontally, to
accommodate long titles. Otherwise, the titles
concatenate after approximately 20 characters.

Increases or decreases cells in the Modeler’s grid.
To access the grid, select the Modeler, then click
View > Grid.

Guidance

Table 23-25 Preferences: Modeler Guidance

Setting

Description

If an Identity Vaultdoesn'’t already exist, one will be
created when you drop the application

eDir-to-eDir connection tip, when you’ve connected
the same eDir app to two driver sets

Setting data flows in architect mode will default all
policy and schema settings

Saving Dataflow to disk will first force a project save

Creates an Identity Vault when you drag or drop an
application from the palette into the Modeler.

Prompts you to connect a line directly between the
end driver sets when you set up an eDir-to-eDir
relationship.

Sets policy and schema settings to defaults when
you set data flows in architect mode. To edit the
settings, use the Developer mode.

Requires you to save a project before you can save
Dataflow to disk.

Layouts

Layout settings determine how applications are displayed in the Modeler. To set a default layout
when you import projects, select an option (for example, Circle).

Figure 23-12 Preferences: Modeler Layouts

Modeler

Behaviors I Display I Guidance  Layouts |Pa_ges I Prompts I Themes I

Defaulk Layout For Applications on Import:

Half Circle
Star

Fan ok - Left
Fan Cut - Right
Fan Qut - Tap

The following figure illustrates a half-circle layout:
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Figure 23-13 An Example Layout
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To arrange existing applications in a particular layout:

1 Right-click a Driver Set object in the Modeler.
2 Select Arrange Applications.
3 Select a layout.

Pages

Figure 23-14 The Pages Properties Page

Modeler

Behaviors I Display I Guidance | Layouts Pages IErDmpts I Themes I
Check the additional Modeler pages you want visible:

V¥ Architect

IV Dataflow

V¥ Table

Determines whether the Architect, Dataflow, and Table pages display as tabs at the bottom of the
Modeler. By default, the Developer page (mode) appears in the Modeler. Displaying the additional
tabs enables you to quickly toggle among pages.
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Prompts

Table 23-26 Preferences: Modeler Prompts

Setting

Description

Show the Driver Config Wizard at connection time

Confirm when a driver is being deleted

Launches the Driver Configuration Wizard when
you drag or drop an application in the Modeler.

Provides a Yes/No prompt for you to choose
whether you want to delete the driver and its
policies.

Themes

Defines themes for the Developer and Architect modes. Customizes the colors of the background,
text, line, Domain Group background, and Domain Group title in the Modeler.

Figure 23-15 The Themes Property Page

rodeler

Behaviors I Display I Guidance I Layouts I Pages I Prompks Ihemes

Developer: I Default

Architect:

Default

French Country
Jamaica

Lunar
Mediterranean
Mapa Plurm
Ccean

Pebble Beach
Polar Ice

Dataflow

Stické Maoke

Specifies the number of columns per page that the Dataflow editor saves in the HTML reports.

To view or use the Dataflow editor, select the Dataflow tab in the Modeler.

Figure 23-16 The Dataflow Tab

& Developer | 2 Architect | % Dataflow Table
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Palette

Table 23-27 Preferences: Palette Settings

Setting Description

Arrange applications in folders Displays folders (for example, Database) in the
palette and places applications in appropriate
folders.

Arrange applications in an alphabetical list Places all applications into one folder in the palette,

and lists the applications alphabetically.

23.3.9 Policy Builder

Policy Builder creates and manages the policies in the drivers.

Table 23-28 Preferences: Policy Builder

Setting Description

Expand all rules when the Policy Builder is loaded  Automatically expands rules in the Rules pane
when you open the Policy Builder.

Show version/author/last changed information Displays fields in the Rule Inline Editor when you
double-click a rule. When you enter data in the
fields, the comments are added to the policy.

=+ logonHours: Convert to Login Allowed Time Map form

The Identity Yaulk Login Allowed Time Map is an ocket string holding one bit For
Description | each half-haur periad in & week. Users can logon when the bit representing the

current half-hour is a 1. The Active Directory lagonHours works similarly except

Author I

Yersion I Last Changed

Policy Description
The Policy Description allows you to add comments about the policy.

Figure 23-17 Preferences: Policy Description

+ Policy Description

Caonvert selecked attributes to a Form mosk commonly used in the Identity Yaulk,

= Pulicy Builder | Source |
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Table 23-29 Preferences: Policy Description Settings

Setting Description

Expand the Policy Description field Automatically expands the Policy Description field.
You can hide the field by selecting the check box.

Number of rows of text to display Determines how many rows to display in the Policy
Description field. The default is 3.

Policy Description position on the page Places the Policy Description field above or below
the Rules pane.

23.3.10 Project Checker

Allows you to validate your project.

Table 23-30 Preferences: Project Checker

Setting Description

Limit Visible Items to Allows you to limit the number of items displayed in
the Project Checker. The default value is 100.

Prompt me to save the editor before running Allows you to receive a prompt asking you to save
Project Checker your project before running the Project Checker. By
default, this is enabled.

23.3.11 Schema

Allows you to manage the Identity Vault and connected system’s schema.

Table 23-31 Preferences: Policy Builder > Schema

Setting Description

Warn when LDAP names are different from Allows you to turn off this warning prompt, which
eDirectory names during .Idif import/export appears during the import or export of the schema.
Warn when exporting base classes to .Idif Allows you to turn off this warning prompt, which

appears during the export of the schema.

Show the information message for the Manage Allows you to turn off the information message that
Application Schema context menu appears when managing the application schema.

23.3.12 Simulation

The Simulation setting enables you to test a policy.
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Table 23-32 Preferences: Simulation

Setting

Description

Directories: Input

Directories: Output

Directories: Java Extensions

Options: Clear the policy simulation log file prior to
performing a simulation

Options: Show the information prompt when a
query is generated

Options: Enable unsupported and experimental
pre-release functionality

The directory that stores the input document. To
simulate (test), you must have or generate an input
document. Designer provides several predefined
input documents. They are in subdirectories (for
example, Add) in the
Designer\eclipse\plugins\com.novell.d
esigner.idm.policy version directory.

You can specify a different location to store the
input documents.

The directory that stores the output document.
When you select Save As while testing a
document, Designer stores the file in an output
directory. By default it is the
Designer\eclispe\plugins\com.novell.d
esigner.idm.simulation directory.

You can specify a different location to store the
output documents.

Enables you to simulate policies that contain
references to external Java extensions. Specify the
directory where the jar file is located, then copy the
jar file containing the Java class to that directory.

You can specify multiple Java extensions.

Automatically clears the log file. If you don’t enable
this setting, Designer displays a Clear Log button
that you can use. If you do many simulations in
succession, you might want to disable this option.
The log file then captures and displays the events
of all the tests, until you click Clear Log.

Displays a prompt when the simulator generates a
query. It simulates what the engine would do when
a query is required to process the policy.

Enables a live version of the Policy Simulator.

WARNING: This feature is not supported and it is
not documented.

23.3.13 Trace

The Trace view is useful in the following situations:

¢ To trace internal errors and messages, so that you can find out why something might not work

as expected.

+ To provide information for Novell Support, engineers, or other consulting resources.

All Designer-specific trace messages go to the Trace view if this view is open. Otherwise, no trace

messages are sent.
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Warnings and error messages are sent to the . 1og file, found in the run-time workspace
metadata directory. Use the Error view to view this information.

Table 23-33 Parameters: Trace

Setting

Description

Enable tracing

Include stack traces

Include XML processor traces

Show plug-In names in the trace

Show view when tracing

Trace buffer size

Plug-Ins to Trace

Select All
Deselect All

Writes events to the Trace view. By default, tracing
is off. To increase performance, disable tracing
when you don'’t need it.

Provides separate traces. Dumps the entire stack
where an internal exception occurs, so that you can
see in the code where the internal exception is
failing.

Provides separate traces that detail all of the
processing of XML documents. This trace can
become quite verbose.

In the Trace view, displays names of plug-ins where
tracing has occurred. This is useful if you are
tracing more than one plug-in.

Automatically brings up the Trace view if a trace is
trying to be logged. By default, this setting is On.

Increases the buffer to show more characters. As
the buffer increases in size gets higher,
performance might degrade, depending on your
system.

Lists all Designer plug-ins (in their simple name
form). Select plug-ins that you want to trace.

Enables tracing in all Designer plug-ins.

Disables tracing in all Designer plug-ins.
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23.4 Preferences: Help

Table 23-34 Preferences: Help

Setting

Description

Specify how help information is displayed: Use
external browser

Open window context help

Open dialog context help

Help view document open mode

Search: Show all potential hits/Show only actual
hits

If an embedded Web browser is supported on your
system, the help window uses that browser to
display help contents. To force help to use an
external browser, enable this option. To select an
external browser, use the Web Browser preference

page.

Determines whether the window context help
opens in a dynamic Help view or in a pop-up
window.

Determines whether the dialog box context help
opens in a dynamic help section of the Help view or
in a pop-up window.

Determines whether the documents selected in the
Help view open in place or in the editor area.

Determines how quickly the search is completed.

+ Section 23.4.1, “Help Server,” on page 469

23.4.1 Help Server

The Help system includes an internal server that serves help contents to the browser. Use the
following settings to change the interface and the port that the server users. Change these settings
only if you experience problems and can’t view help by using the default settings.

Table 23-35 Help Server Settings

Setting

Description

Host name or IP address

Server port

The name or address of a local IP interface that the
server uses. Either leave this field blank or point it
to your own |IP address.

The IP port for the server to listen on. If you don’t
assign a port, the operating system assigns one.
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23.5 Preferences: Novell

Figure 23-18 Novell NIM

@ Preferences

| bype filker text NI

- General
[+ Designier For IDM
- Help

-- Provisioning
[+ web and #ML

Provides legal notices for Novell Integration Manager (formerly exteNd Composer™), parts of
which are included in a Designer plug-in.

23.6 Preferences: Provisioning

For information on provisioning settings, see Setting Provisioning View Preferences (http://
www.novell.com/documentation/idm35/dgpro/index.html?page=/documentation/idm35/dgpro/data/
palprovprefs.html).

23.7 Preferences: Web and XML

The Web and XML preferences let you specify how Designer should handle editing and creation of
CSS, HTML, and JavaScript* files.

¢ Section 23.7.1, “CSS Files,” on page 470

¢ Section 23.7.2, “HTML Files,” on page 474

¢ Section 23.7.3, “JavaScript Files,” on page 479
¢ Section 23.7.4, “Task Tags,” on page 482

+ Section 23.7.5, “XML Catalog,” on page 482

¢ Section 23.7.6, “XML Files,” on page 484

23.7.1 CSS Files

The CSS Files preferences allow you to specify how Designer displays and manages CSS files.
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Figure 23-19 CSS Files

type Filber bext CSS Files o
General ) L
Designer For IDM Creating or saving files
Help The Following line delimiter will apphy:
Harved Line delimiter: |ND translation Vl
Prowvisioning
(= Web and =ML Creating files
Add this suffix (if not specified): | =5 |
HTHML Files _ o
Javascript Files The Following encoding will apply;
Task Tags Engoding: | 150 Latin-1 |
#ML Cakalog
wML Files TANA: I20-55859-1
[Restore Defaults ] [ Apply ]
@ [ ol's l [ Cancel ]

Table 23-36 CSS Files

Preference Description

Creating or saving files: Line Delimiter Sets the type of line delimiter applied to newly created files. The
options are:

¢ Windows
* Unix
¢ Mac

* No translation

Creating files: Add this suffix The file suffix the editor adds when creating files. The default is
CSs.
Creating files: Encoding The encoding used for new files.

+ “CSS Source” on page 472
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¢ “CSS Styles” on page 473

CSS Source

Figure 23-20 CSS Source

. Preferences = 1O
bype Filter becct CSS Source o
General )

Designer For 100 Farmatting
Help Line width:
Norve Insert line break between properties
Prowvisioning
- Web and =ML [#] Disable wrapping in style attribute of HTML
(=) 255 Files (%) Indent using tabs
! ":""':'3 () Indent using spaces
(C55 Styles
HTML Files Indentation size: El
lawaScripk Files
Task Tags Capitalization style
%ML Catalog Identifier: Property name: Property value:
%ML Files (%) Uppercase () Uppercase () Uppercase
D Lowercase @ Lowercase @ Lowercase
[Restore Defaults ] [ Apply ]
@ [ K l [ Cancel ]
Table 23-37 CSS Source
Setting Description
Formatting: Line width Specifies the number of characters in a line.
Formatting: Insert line between properties Specifies whether the editor should insert a line

between the CSS properties.

Formatting: Disable wrapping in style attribute of Specifies whether the HTML editor (used in the e-
HTML mail notification template editor) should allow
wrapping of the value of a style attribute.
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Setting Description

Formatting: Indent using tabs or Formatting Indent  Specifies how the first line of text indents.
using spaces and

Specifies the size of the indent.
Formatting: Indentation size

Formatting: Capitalization style Specifies the default case for identifiers, property
names, and property values.

CSS Styles

Figure 23-21 CSS Styles

@ Preferences

cs5 Styles -

Gen.eral Customize the syntax highlighting by selecting the bvpe of text whose skyle wou wank bo customize From
Diesigner Far DM either the combo box or the sample text area
[#-Help
Morvel Conkent bype: |.C\I:-Rule w | [Eestore Diefaulk ]
Pravisioning
= VéEhc‘;I;dFﬁ;L Eoreground: - Background: [] Bold
C55 Source Sample kext:
- HTML Files Fimportc url("™../sampleZ. css");
lawascript Files
Task Tags /% Sample Styles #/
wML Cakalog
[+ =ML Files BODY {

color @ hlack:

background-color @ rgh (181, ZE83, Z11):
text-align : center;

font-fammily @ "Heisei Mincho W3™, =serif

fpage :left { margin-left @ 4cm b

Broedia aural {
P.heidi {
azimuth : center-left;
elevation @ 12.3deg;
pause @ I0ms 1.6s2

[Restore Defaulks ] [ Apply ]

Ok H Cancel ]
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Table 23-38 CSS Styles

Setting Description

Content type Choose the content type for which you want to
define a style.

Foreground/Background/Bold Specifies the syntax highlighting (foreground and
background color) and whether the text should be
bold for individual CSS constructs.

23.7.2 HTML Files

The HTML Files preferences allow you to specify how Designer displays and manages HTML files
and content.

Figure 23-22 HTML Files

type Filber bext HTML Files o
General ) o
Designer For IDM Creating or saving files
Help The Following line delimiter will apphy:
Harved Line delimiter: |ND translation Vl
Prowvisioning
(= Web and =ML Creating files
(55 Files Add this suffix (if not specified): | hikral |
HTML Files _ o
Javascript Files The Following encoding will apply;
Task Tags Engoding: | 150 Latin-1 |
#ML Cakalog
wML Files TANA: I20-55859-1
Loading files. ..
Use workbench encoding
[Restore QeFauIts] [ Anply ]
@ [ [o]'4 l [ Cancel ]
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Table 23-39 HTML Files

Preference Description
Creating or saving files: Line Choices are:
Delimiter

* Windows

* Unix

* Mac

* No translation

Creating files: Add this suffix Specifies the file suffix the editor should add when creating a new file.
The default is html.

Creating files: Encoding Specifies the editor’s encoding for new files.

Loading files Choose the encoding for files opened in the editor. Click Use
workbench encoding to accept the default UTF-8, or select one from
the list.

¢ “HTML Source” on page 476
¢ “HTML Styles” on page 477
¢ “HTML Templates” on page 478
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HTML Source

Figure 23-23 HTML Source

kype filker bext HTML Source =T
General i
Designer For IDM Farmatting
Help Line width; T2
Novel [I5plit mulkiple attributes each on a new line
Provisioning )
- Web and ¥ML []clear all blank lines
55 Files (%) Indent using tabs
= HTML Files O Indent using spaces
HTML Source
HTML Styles Indertation size: |1 5
HTML Templates i
JavaScript Files -onkent assist
Task Tags Aukomatically make suggestions
#ML Catalog Prompt when these characters are inserted: | <
=ML Files
Suggestion strategy: Lax b
Preferred markup case For cankent assist, and code generation
Tag names: attribuke names:
() Uppercase () Uppercase
@ Lowercase @ Lowercase
5 5 [Restore Defaults ] [ Apply
@ [ K l [ Cancel ]

Table 23-40 HTML Source

Setting

Description

Formatting: Line Width

Formatting: Clear all blank lines

Formatting: Split multiple attributes each on a new
line

Formatting: Indent

Specifies the number of characters for each line.

Specifies what the editor should do with blank lines

Specifies what the editor should do with multiple
attributes.

Specifies whether the indent should be using tabs
or spaces and also the indentation size.
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Setting

Description

Content assist: Automatically make suggestions

Content assist: Prompt when these characters are
inserted

Content assist: Suggestion strategy

Preferred markup: Tag Names/Attribute Names

Specifies whether to do automatic code completion.

Specifies the characters that initiate the content
assist.

Specifies whether to use Lax or Strict grammar
when making suggestions

Specifies if the editor’s suggestions should be in
uppercase or lowercase.

HTML Styles

Figure 23-24 HTML Styles

@ Preferences

oo

Apply ]

twpe Filker text HTML Styles
Gen.eral Customize the syntax highlighting by selecting the bvpe of text whose skyle wou wank bo customize From
Designer Far 1DM either the combo box or the sample text area
Help
Morvel Conkent bype: |F\ttribute Marnmes w | [Eestnre Diefaulk
Pravisioning
= Wweb and xML
Foreground: Background: Bold
1235 Files BT -_ ka I:‘ -
= HTML Files Sample kst
HTML Source -
i <!DOCTYPE HTHL
HTML Templates PUELIC "-//W3C/DTD/ HTML 4.01 Transitional//EN"
JavaScripk Files "http://www. w3 . org/ TR/ htmld/ loose .. ded™s
Task Tags <HTHML>
#ML Cakalog <HEAD>
=ML Files <METL content="text/html™:
<TITLE>HTML Highlighting Preferences</TITLE>
</HELD>
<BODY>
< -
we need a flaming logao!
——x
</ BODY>
</HTHML>
5 5 [Restore Qefaults] [
@

Lo JI

Cancel ]
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Table 23-41 HTML Styles

Setting

Description

Content type/Foreground/Background/Bold

Specifies how the editor performs syntax
highlighting (foreground and background color) and
bolding for the selected HTML content type.

HTML Templates

Figure 23-25 HTML Templates

@ Preferences

bype filter bext Templates =
gen.eral For DM Create, edit or remove templates:
esigner For
Help Marme Cankext Descripkion AutoIn,.. =
Mowell commenk HTML Tag comment on
Provisianing dl HTML Tag definition list on
- Web and =ML img HTMLTag  img (map} on
35 Files Mew HTML ... Mew HTML htrl 4,01 frameset on
=1 HTML Files Mew HTML ... Mew HTML htral 4,01 transitional on
HTML Source Mews XHTML,.. Mew HTML xhkml 1.0 frameset on
HTML Stvles Mews XHTML,..  Mew HTML xhtml 1.0 transitional on
oy T" . ol HTML Tag ordered lisk on
- ':"F" fai scripk HTML Tag script (commented) on
Javascript Files style HTML Tag style  (commented) on
Task Tags table HTML Ta tabl UL
0 able on
#ML Catalog ul HTML Tag unordered lisk on
=ML Files
Preview:
< IE [Restore gefaults] [ Apply ]
@ [ ol's l [ Cancel ]
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Table 23-42 HTML Templates

Setting Description

Templates The templates are used in the code completion in
source editor.

Use this preference to add, remove or edit
templates.

23.7.3 JavaScript Files

Changes how JavaScript files are created.

Figure 23-26 JavaScript Files

JavaScript Files d= <

Creating or saving files
The following line delimiter will apply:

Line delimiter: | Mo translation A

Creating files

add this suffix (f not specified): | js

Table 23-43 JavaScript Files

Setting Description

Creating or saving files: Line delimiter Sets what type of line delimiter is applied to the file.
The options are:

* No translation
* UNIX
* Mac

¢ Windows

Creating files: Add this suffix (if not specified) Sets the suffix for the file. The default value is js. It
can be set to any value.

¢ “JavaScript Source” on page 479
+ “JavaScript Styles” on page 480
¢ “JavaScript Validation” on page 482

JavaScript Source

Changes the formatting for the JavaScript files.
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Figure 23-27 JavaScript Source
JavaScript Source =) <

Farmatting

'G:' Indent using tahs

C' Indent using spaces
Indentation size: -

Conkent assist

Autornatically make suggestions

Prompt when these characters are inserted:

Table 23-44 JavaScript Source

Setting Description

Formatting Sets the formatting for the editor. The options are:

* Indent using tabs

* Indent using spaces

* Indentation size: Changes the indentation size
by setting a numeric value.

Content assist Helps with prompts when creating the files.

Automatically make suggestions: Can be enabled
or disabled if the check box is selected.

Prompt when these characters are inserted: Allows
you to receive prompts when the specified
characters are entered.

JavaScript Styles

Customizes the content of the JavaScript files.
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Figure 23-28 JavaScript Styles

JavaScript Styles (=l

Customize the syntax highlighting by selecting the tvpe of kext whose style you want to customize From
either the combo box or the sample text area

Content bype: [ Comments “ | | Restore Default

Eoreground: - Background: [] Bold

Sample kext:

function init i) |
IfWer=zions = new Arravi)]:
fWersions[1l] = 'Version 1';
fWersions[2] = 'Version 2':

/4 For which version is the user regquesting support?
i
function selectVersion(f) |
war cnt = 0;
wvar 1i:
for (i =0 ; i < f£.version.length ; i++) |
if [f.wersion[i] .selected] |

crnt++;
H
H
war doall = [(ent == f.product.length || ocnt == 0]
3tring unfinished3tring = "resource;

Table 23-45 JavaScript Styles

Setting Description

Content type Selects the content to be customized. You can
change each element independently. The sections

that can be changed are:

+ Comments
+ Default Code
* Keywords
* Lijteral Strings

* Unfinished Strings and Comments

If you select the element in the sample text field,

the content type changes to what is selected.

Foreground Displays the color that is set for the foreground.
Double-click the color field to select another color.

Background Displays the color that is set for the background.
Double-click the color field to select another color.

Bold Allows you to bold an element. Select the element,

the click the Bold check box.

Setting Preferences

481



Setting Description

Sample text Displays a sample file to see the changes.

JavaScript Validation

Allows the editor to validate the JavaScript as it is entered. To automatically validate the scripts,
select Automatically validate scripts. Otherwise, the JavaScript is not validated.

23.7.4 Task Tags

The Task Tag Preferences allow you to specify whether Designer should search for task tags and
which task tags to display in the Task view. If Enable searching for Task Tags is not selected,
Designer does not search for task tags. If you do not use the Task view, make sure this option is not
selected because the search can affect Designer’s performance.

The TODO and FIXME task tags are defined by default, but you can specify additional tags by
selecting New and completing the Task Tag dialog box. Use the Filters tab to specify the file types
that Designer should search for the selected task tags.

23.7.5 XML Catalog

The XML Catalog Preferences allow you to manage the WST XML Catalog implementation. You
can add, edit, or delete user-specified catalogs. You cannot use this preference to manage the plug-in
specified entries.The XML editor uses the WST XML catalogs implementation to resolve XML
schema and DTD references for associating URLs, system and public identifiers with URLSs.
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Figure 23-29 XML Catalog Preferences

@ Preferences

type filter text XML Catalog o
General )
Designer for DM ¥ML Catalog Entries
Help User Specified Entries A
Independent Driver Serv =45 Plugin Specified Entries
Novell -}WSCHDTO 2HTML 1.0 Frameset/{EN o
5;0;'5'03";31 -}W3CHDTD BHTML 1.0 Strict}/EN
c:; e -/ ECHDTD BHTML 1.0 Transitional{/EN
_ -/ ECHDTD RHTML 1,1/ [EN
HTHML Files ) w
Task Tags -/ 3CH{DTD #HTML Basic 1.0//EN v
%ML Catalog - :
E!- Edit. .. Delete
%ML Files - -
Details
URI:
Key Type:
key:
24 | &
€] K l [ Cancel

To add a user-specified entry:

1 Click Add.

@ Add XML Catalog Entry

X

Catalog Entry

E]E

Mext Catalog

LRI | |
Key Type: | v
key: | |

[ specify alternative web address

(0]4

Cancel
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2 Fill in the fields as follows:

Field Description

URI Specify a location on disk or a URL of the schema or DTD.

Key Type Specify the key type. Values are public identifiers for DTDs or URIs for XML
schemas.

Key Specify a unique key

Specify alternative ~ Optionally, specify an alternative Web address for locating the schema or
web address DTD.

3 Click OK to save.

23.7.6 XML Files

You can set the following general XML File preferences:
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Figure 23-30 XML File Preferences

@ Preferences
bype filker bext =ML Files iR
General ) o
Desigrer for IDM Creating or saving Files
Help The Following line delimiter will apphy:
Independent Criver Serv Line delimiter: |No translation w |
Moreell
Pravisioning Creating files
=l Web and KL Add this suffix (if nok specified): | xml |
55 Files ] ] )
HTHML Files The following encading will apply:
Task Tags Encoding: |150 10646/ Unicade{UTF-5) v |
#IML Catalog
" . IaNA:  UTF
XML Source o
ML Skyles Validating files
%ML Templates [Jwarn when no grammar is specifisd
¢ | [Restore Defaults ] [ Apply ]
':?:' [ CF ] l Cancel ]
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Table 23-46 XML Files Preferences

Category Preference Description
Creating or saving files Line delimiter Choices are:
* Windows
* Unix
* Mac

Creating files Add this suffix
Encoding

Validating files Warn when no grammatr is
specified

* No translation
The file suffix. The default is XML.
The encoding used by the editor

Specifies whether to display a warning when no
grammar (such as XML Schema or DTD) is
associated with the XML document.

¢ “XML Source” on page 486
¢ “XML Styles” on page 488
¢ “XML Templates” on page 488

XML Source

You can set the following XML Source preferences:
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Figure 23-31 XML Source

@ Preferences

type Filker bext

General
Desigrer For IDM
Help
Independent Driver Sery
Torwell
Provisioning
Web and XML
+- £33 Files
+- HTML Files
Task Tags
#IML Catalog
—I- ¥ML Files

o B o

HML Skyles
*ML Templates

XML Source

Farrnatking

Line width: 7z

[ 5plit multiple attributes each on a new line
[ <lear all blank lines

{#) Indent using tabs

O Indent using spaces

Indentation size: |1 %

Content assist

Automatically make suggestions

Prompt when these characters are inserked: | <
Suggestion strakegy: Lax

Grammar Conskrainks
Ise inferred grammar in absence of DTD/Schema

<;:| -
w
[Restore QeFauIts] [ Apply
[ QK l [ Cancel l

Table 23-47 XML Source Preferences

Category

Preference

Description

Formatting

Line width

Split multiple attributes each on a
new line

Clear all blank lines

Indent using tabs/Indent using
spaces, Indentation size

Specifies the number of
characters in a line.

Specifies how attributes are
formatted (whether to show each
attribute on a separate line).

Specifies whether blank lines are
removed when formatting.

Specifies whether to use tabs or
spaces as indentation and
indentation size.
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Category Preference Description

Content Assist Automatically make suggestions  Specifies whether to do automatic
code completion.

Prompt when these characters The list of characters that initiate

are inserted code completion.

Suggestion strategy Specifies whether to use Lax or
Strict grammar when making
suggestions

Grammar constraints Use inferred grammar in absence Specifies whether to display code

of DTD/Schema completion suggestions based on
existing content of the XML
document.

XML Styles

The XML Styles preferences allow you to specify the syntax highlighting (foreground and
background color) and whether the text should be bold for individual XML constructs.

XML Templates

Use the XML Templates preference page to define XML templates. The templates are used in the
code completion in the XML Source Editor. For example, selecting the XSL. Processing
Instruction template in the code completion inserts <?xml-stylesheet type="text/
xs1” href=""72> in the source editor and places the cursor in the href value.
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Figure 23-32 XML Templates Preference

I type filter ket

General
Designer for IDM
Help

Independent Driver Sery |

Maovell
Provisioning
Web and XML
[ C55 Files
- HTML Files
Task Tags
¥ML Catalog
= ®ML Files
XML Source
HML Skvles
#ML Templates

Templates =ik
Create, edit ar remove templates:
Marne Context Descripkion Auto Insert Mew. ., ]
icomment ML Tag sl comrment on
xml declaration Mew ¥ML xml declaration on
#5L processing instruckion XML Tag #5L processing instruckion on

Preview:

[Restore Defaults ] [

Apply ]

Lo JI[

Canicel ]
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Troubleshooting Designer

+ Section 24.1, “Viewing the Error Log,” on page 491

¢ Section 24.2, “Turning on Trace Messages,” on page 492

¢ Section 24.3, “Checking Loaded Plug-Ins,” on page 494

¢ Section 24.4, “Deploying Identity Manager Objects,” on page 495
¢ Section 24.5, “Issues When Generating Documents,” on page 509
¢ Section 24.6, “No F1 Help in Maximized Editors,” on page 513

¢ Section 24.7, “Freeing Heap Memory,” on page 513

¢ Section 24.8, “Reporting Bugs and Giving Feedback,” on page 514

24.1 Viewing the Error Log

The Error Log view can help you troubleshoot. If something isn’t working, messages written to the
error log might help you. The log is named . 1og. It is a hidden file.

To view the error log, you can use menus or browse the file system.

¢ Section 24.1.1, “Using Menus,” on page 491
¢ Section 24.1.2, “Browsing the File System,” on page 492

24.1.1 Using Menus

1 Select Window > Show View > Other > PDE Runtime > Error Log.
2 Click OK.

If you view the log through the application, a list of messages displays.

Figure 24-1 The Error Log

Message &

D] Failed o parse URL: file:///com.novell. designer. idm/fcontexts.xml at line: 22, column: 7. 00The element type "conte
2 |
@ Unhandled event loop exception

@] java.lang.NullPointerException

@ Unhandled event loop exception

D] jawa. lang.NullPointerException

@] jawa. lang.NulPoirter Exception

@ Unhandled event loop exception

A b wnrlenara mrash weas detertad Tha nravinn iz sassinn did nnt avit Bormalbe bt

< | ?

For details, double-click a message. (You can also right-click, then select Event Details.)

To sort messages, click the appropriate header bar.
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To use the Error Log view toolbar, right-click a message. The toolbar allows you to copy the log,
clear the log viewer, delete, open, restore, export, import, and view the event’s details.

To set filters for the types (and number) of messages to see:

1 On the Error Log view toolbar, click the filter icon.

Ackivate on new events

2 Select Filters.
3 Customize the filter settings, then click OK.

@ Log Filters &)

Event. Types

ir o
Wiarning
Errar

[“ILimit visible everts to; | 50

Show events logged during:
@ all sessions
O Most recent session

@ [ Ok l [ Cancel ]

24.1.2 Browsing the File System

1 Browse to your Designer workspace.

In Windows, the log file is typically in subfolders in the /eclipse/workspace/
.metadata directory.

In Linux, the log file is typically in the Home directory, in the /eclipse/workspace/
.metadata directory.

2 Open the log file.

24.2 Turning on Trace Messages

You might want to send trace messages to the error log so that the messages are captured in a file.
You can then easily e-mail the trace message to Novell® Support or others.

Programmers sometimes place hidden messages in their code so that if you are having problems,
you can turn on the trace functionality and get additional insight. Even if you don’t understand the
hidden messages, they can help Novell Support diagnose the problem.
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To get trace messages:

1 Click Window > Preferences > Designer for IDM.

@ Preferences

I bype Filker text

[+]- General
B Designer For IDM
- Configuration
- Diocument aener ation
- Entitlements
- iManager
- Impork{Deploy
- Language
[+ Modeler
- Policy Builder
- Project Checker
- Schema
- Simulation

T+
e}

Trace

[~ Enable tracing

I Include stack traces

I~ Imclude ML processar braces
™ show plugHn names in the brace

¥ shaw view when tracing

Trace buffer sizer (rminimum: 20,000 characters)

Plug-Ins ko Trace:

O composerEditar

O customscriptEditor Plug-in
D DS Trace Viewer

D Designer Core Services
CEclipse Enhancements

2 Expand Designer for IDM, then click Trace.

3 Select Enable tracing, then select the options that you want to include or show.

Trace

- - .

[ Include stack traces

[ Include ¥ML processor traces

v shaow plug-in names in the trace

W Show wiew when tracing

Trace buffer size:  {minimum: 20,000 characters)

I 30000

Plug-Ins ko Trace:

O composerEditar

D DS Trace Viewer
D Designer Core Services
OEedipse Enhancements

Entitlernents Plug-in

O Fan-out Driver Plug-in
D IDM - Common Services
I 1om - Corfig Marnt
CJ1oM - Data Flow Editor

1 trna - Pk = Bl Wicas

Select All | Deselect All

O customscriptEditar Plug-in

O EcmaExpressionBuilderPlug-in

4 Select the plug-ins that you want to trace, then click OK.

To view the results of traces:

1 Select Window > Show View > Trace.
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2 View data in the Trace view.

ZEE="

DocgenDocumenttodelitemaction:In run method
DocgenDocurnentvodelltemaction:In run method
Added DESourceProvider: designer

Added DGESourceProvider: provisioning

Added DESourceProvider: desigrner

Added DESourceProvider : provisioning

3 You can also turn on trace options from the Trace view by clicking the Preferences icon =/ in
the Trace view.

4 Use the Clear Trace icon to clear the Trace view.

5 Use the Save icon to save Trace view contents to a .txt file.

24.3 Checking Loaded Plug-Ins

A problem can occur if a plug-in fails to load. To see which plug-ins are loaded:

1 Select Window > Show View > Other.
2 Open the PDE Runtime folder.
3 Click Plug-in Registry > OK.

U & Plug-in Registry X
Filter matched 100 of 197 plug-ins.

&

com.hovell.designer.cor 30450}
@ C:\Prograrm Files\Novell\Designer\aclipse\plugins\com.novell.designer .core_2.0.0,200702130450 =
¥ Extensions
<9 Extension Points
e Prerequisites
[ Rur-time Libraries
)% com.novell.designer. core.datatools (2.0.0,200702130450)
<)% com.novell.designer.core. iconeditor (2.0.0.200702130450)
<)% com.nowell.designer.core.ids (2.0.0.200702130450%
#-0% corm novelldesioner, core,livemode (2,0,0, 2007021304500 by

The Plug-in Registry page lists the Designer plug-ins, which have a green triangle in the plug-
in icon.

4 Use the Home icon to bring you to the top of the plug-in list.

5 Select a plug-in and use the Right Arrow icon to drill into the plug-in, and use the Left Arrow
icon to return.

6 Use the Refresh icon to refresh the Plug-In Registry view.
7 Use the Plug-In Registry view toolbar to select Show Active Plug-Ins Only.
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24.4 Deploying Identity Manager Objects

When you see an error message in Designer, the error message corresponds to the place where
Designer could not complete the task, and indicates the best place to start troubleshooting. This
section discusses the common problems you face when deploying Identity Manager objects into an
eDirectory™ tree. To see error messages and possible solutions, see Section 24.4.3, “Error Messages
and Solutions,” on page 498.

Deployment Considerations

+ Ensure that the Metadirectory server meets the system requirements necessary to run Identity
Manager. See Overview chapter in thel/dentity Manager 3.5.1 Installation Guide for
requirements.

+ Ensure that the Metadirectory server you are deploying to has Identity Manager installed and
holds a real copy of the objects to which you want to synchronize. The server running
eDirectory must have a Master Read-Write or a Filtered Read-Write replica.

+ Ensure that the Java software installed on the server is running correctly, because Identity
Manager is dependent on Java. If Java is corrupted, you might be able to deploy to a
Metadirectory server but not run the Identity Manager drivers.

+ To deploy an Identity Manager-based project or an object in a project, you must have access to
the eDirectory tree that is associated with the Identity Vault you are designing. Select the
Identity Vault you want to deploy, then look in the Properties view below the Project/Outline
view.

Figure 24-2 The Properties View

Property Yalue
Marme IDMTREE
Host Address 192,168.14.199
User DM admin.blanston
Passwiord ok
Deploy Context  hlanston
Meta Directory  true
Save Password  false

In the Properties view, ensure that the Identity Vault’s Name, Host Address, User DN,
Password, Deploy Context’s Distinguished Name (DN), and Metadirectory information is
complete and accurate. (You can click the Browse button to find the Deploy Context’s DN on
an existing tree if the other information is accurate and Designer can attach to the eDirectory
tree.) You need this information to deploy anything, even a policy, into an existing eDirectory
tree running the Metadirectory engine.

¢ Use the Deploy feature only after you have thoroughly tested the rules and policies that make
up your drivers. To test a policy, use the Policy Simulator (right-click a policy and select
Simulate, then click Start to see the simulation results of the policy that is being tested). For
policy design, see the Policy Builder Help topics within the Designer utility.

You can use the Import feature to import a driver, a channel, or a policy. You can then modify
the object or objects, run the Policy Simulator to ensure that the object is working correctly,
then deploy the object back into the test tree for further analysis. You can also run the Compare
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feature to see the differences between your modified driver and the driver that is currently
running on an Identity Vault server.

¢ In the Outline view in the Project Group view, right-click the driver object in question (you can
also double-click the driver object). Use the Properties window to make most changes to
drivers. Properties are unique to each driver.

A simple driver problem is specifying the incorrect context (Distinguished DN) for an
eDirectory tree. For example, the context of a user object in eDirectory is shown with the slash
notation (for example, Blanston\Sales\Users) on the Properties of the Identity Manager driver
or when you import the driver. However, different drivers can use formats other than the slash
notation. For example, Active Directory and LDAP drivers use comma-delimited format
(OU=Users,OU=Sales,O=Blanston). See the driver guides for further details on the drivers
you are deploying.

¢ Section 24.4.1, “An Example Deploy Error,” on page 496

¢ Section 24.4.2, “Deploying a Driver with an Empty Server List,” on page 497

¢ Section 24.4.3, “Error Messages and Solutions,” on page 498

24.41 An Example Deploy Error

When deploying an Identity Vault for the first time, there are several common sources for errors,
from incorrectly typing information to not completing the driver set templates.

Figure 24-3 Default Server Container Message

@ Confirm X

The Server whiose DM is 'Default Server.default_container' associated with the Driver Set
narned 'ConnectingSet’ cannot be accessed. It is not deployable.

In this message, the server cannot be accessed because the server information is incorrect. Right-
click the Identity Vault in the Modeler view, select Properties > Server List, then click the Edit
button to edit the server information.
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Figure 24-4 Correcting a Server Name Problem
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type filter text | 3. Server List i
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O specify a sf File

Select an object:

' = [B) IDMDESIGNTREE Al
= &5 Navell
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# "B Tomcat-Roles
& 98 Users
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& B Novell+NetwWare & Se1
& &2 Apache Group
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@ &L Driver Set
i+ & DriverSet
& & IOM Driver Set
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[y Security ~|
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| o ][ Cancel I
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24.4.2 Deploying a Driver with an Empty Server List

When deploying a driver set with an empty server list, you see the following error message:
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Figure 24-5 No Server Association
@ Confirm &)

There are no servers associated with the Driver Set named 'IDM Connection',
There must be at least one server associated with any OriverSet being
deployed or the DriverSet containing any objects being deployed.

To correct this problem, make sure the server list information is set correctly on the Identity Vault
and driver set’s Properties page.

Figure 24-6 Available Servers

@ Properties for IDMVALILT CIE)E]

| type filter text | 3. Server List = ©
1. Configuration
2. Administrator (@) The following is the list of servers that have bheen
3. Server List associated with this Identity Yault,
Default Server . default_container add...

IDMTEST. Mavell

Apply

(7 [ ok I l Cancel ]

24.4.3 Error Messages and Solutions

When you see an error message in Designer, the error message corresponds to the place where
Designer could not complete the task and indicates the best place to start troubleshooting. This
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section discusses the error messages you might see when deploying Identity Manager objects into an
eDirectory tree, followed by their cause and possible solutions.

¢ “Identity Vault Configuration Errors” on page 499

¢ “Driver Configuration Errors” on page 499

¢ “Internal Designer Errors” on page 501

+ “eDirectory Access Errors” on page 501

+ “eDirectory Object/Attribute Creation Errors” on page 502

+ “Warnings” on page 504

Identity Vault Configuration Errors

Cannot connect to host [Identity Vault Host]; verify the address is
correct and that the server is running.

Possible Cause: The address listed in the Identity Vault properties is incorrect or the server is not
running.

Solution: Verify that the server address is correct and that the server is up and running.

[User] could not be authenticated to [Identity Vault Host]. Cannot
proceed.

Possible Cause: The user name or password listed in the Identity Vault properties is incorrect.

Solution: Verify the user name specified in the Identity Vault properties and reenter the user’s
password.

Driver Configuration Errors

The driver configuration file [Driver Config File] is not a valid XML
document: [Error Message].

Cause: The Driver Configuration file being imported from the file system does not contain a valid
XML document.

Solution: Fix the Driver Configuration file format.

The XML contained the file named [Driver Config File] is not a driver
configuration file. The file cannot be imported.

Cause: The Driver Configuration file being imported from the file system is a valid XML document
but is not a valid driver configuration file.

Solution: Import a driver configuration file.

The following 'XML DOM Exception' was thrown.
[ExceptionInfo]

Cause: The Driver Configuration XML document is incorrectly formatted. This is probably an
internal error because driver configuration files are dynamically generated by Designer for
deployment.

Solution: Turn on trace for Designer. To do this, select Window > Preferences > Designer for IDM
Trace > Enable Tracing. In the Trace window, select the check box for Include XML Processor
Traces. Attempt to deploy again and send the trace file to Novell Support.
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The following 'Number Format Exception' was thrown.
[ExceptionInfo]

Cause: An integer value in the driver configuration file being deployed is invalid. All integer fields
in Designer should validate the content when it is set.

Solution: Turn on trace for Designer. To do this, select Window > Preferences > Designer for IDM
Trace > Enable Tracing. In the Trace window, select the check box for Include XML Processor
Traces. Deploy again and analyze the generated driver configuration file to see if all integer attribute
values are correct. Identify the incorrect parameter in Designer, correct the setting, and redeploy.
The specified driver configuration file does not contain a valid driver
configuration.

Cause: Designer attempted to process a dynamically generated driver configuration file with an
invalid format.

Solution: Turn on XML tracing for the Import/Deploy plug-in. To do this, select Window >
Preferences > Designer for IDM Trace > Enable Tracing. In the Trace window, select the check box
for Include XML Processor Traces. Deploy again and send the trace to Novell Support. Otherwise,
edit and correct the configuration file being imported.

Tree population is not supported from a Driver Set configuration. Tree
population components will be ignored.

Cause: The driver configuration file being processed has a <ds-object> element under a
<driver-set-configuration> element, which is not permitted.

Solution: If this is a dynamically generated configuration file, contact Novell Support; otherwise,
move the <ds-object> element under a <driver-configuration> element.

The following Driver Set based global variables could not be resolved:
[Global Variable List]

These variables exist in both the source and target Driver Sets. The
two definitions, however, have different types.

Cause: The driver configuration file being processed has global variable definitions that could not be
resolved.

Solution: If this is a dynamically generated configuration file, contact Novell Support. If it is a
driver configuration file on disk, check the global variable definitions.

The driver configuration file being processed does not contain a valid
driver configuration.

Cause: The driver configuration file being processed does not contain a <driver-
configuration> element.

Solution: If this is a dynamically created configuration file, turn on XML tracing for the Import/
Deploy plug-in. To do this, select Window > Preferences > Designer for IDM Trace > Enable
Tracing. In the Trace window, select the check box for Include XML Processor Traces. Deploy again
and send the trace to Novell Support. Otherwise, edit and correct the configuration file that is being
imported.

The specified driver configuration file was only intended to be
imported from a ConsoleOne command line.

Cause: The driver configuration file being processed is not a valid document.
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Internal Designer Errors

An internal error has occurred in the Designer Data Model: The policy
named [Policy Name] does not know its container.

Cause: The policy being deployed is not contained in a Channel or Driver object. This is an
abnormal error, indicating that the Designer model has become corrupted.

Solution: Contact Novell Support.

eDirectory Access Errors

The following 'Component Creation Exception' occurred while trying to
access eDirectory.
[Exception Info]

Cause: A value contained in the driver configuration file being deployed could not be successfully
created in eDirectory. This is probably an internal error because driver configuration files are
dynamically generated by Designer for deployment. However, if the Driver in Designer was created
by importing a driver configuration file from the file system and that configuration file contained a
Tree Population Segment, a value within a <ds-object> element might be invalid.

Solution: Turn on trace for Designer. To do this, select Window > Preferences > Designer for IDM
Trace > Enable Tracing. In the Trace window, select the check box for Include XML Processor
Traces. Deploy again and analyze the generated driver configuration file to see if any <ds-
object> elements exist. If they do, verify that all attribute values are correct. If no <ds-
object> elements exist or if all values seem to be correct, contact Novell Support.

The following 'IO Exception' occurred while trying to access
eDirectory.

[ExecptionInfo]

Cause: This is a Java exception indicating that Designer could not perform the requested input or
output operation.

Solution: Contact Novell Support.

DSAccessException:
[ExceptionInfo]

Cause: Designer could not connect to the target deployment server.

Solution: Verify that the server information specified in the Identity Vault properties page is correct
and that the eDirectory server is up and running.

The following 'Namespace Exception' occurred while trying to access
eDirectory. ({0})

Cause: This is a namespace exception indicating that there is a problem with the eDirectory schema,
such as a missing attribute or class.

Solution: Verify that the eDirectory schema being imported from or deployed to is correct. If the
driver being deployed contains Tree Population segments, verify that the objects being created are
valid for the target eDirectory schema.

An exception occurred during the deployment. Cannot perform the
operation.

Cause: An unknown exception was encountered.
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Solution: Contact Novell Support.

The following 'Snapin Exception' occurred while trying to access
eDirectory.
[ExceptionInfo]

Cause: Snap-in exceptions can be thrown in certain methods to report exceptions or errors during
import/deploy. Subclasses of a snap-in exception include:

+ NotAContainerException: There was a call to get the children of an eDirectory object that is
not a container.

¢ ObjectNotFoundException: The object being resolved cannot be found in eDirectory.

+ SPIException: Unable to connect to the eDirectory tree.

Solution: The exception might include the name of the object that caused the exception. Verify that
the eDirectory tree being imported or deployed to is up and running and that it has Identity Manager
installed.

The following exception occurred but was not handled. ({0})
Cause: An unexpected error occurred while resolving an object in eDirectory.

Solution: Contact Novell Support.

eDirectory Object/Attribute Creation Errors

The driver could not be created.
Cause: Designer attempted to create a driver in eDirectory, but the process failed.

Solution: Verify that the target eDirectory server has Identity Manager installed.
A [ObjectClass] object named [ObjectName] could not be created.

Cause: Designer attempted to create a Publisher, Subscriber, or Policy object in eDirectory, but the
process failed.

Solution: Verify that the target eDirectory server has Identity Manager installed.
The driver password could not be saved.

Cause: Designer attempted to set the Driver password in eDirectory, but the request failed.

Solution: Verify that the target eDirectory server has Identity Manager installed.
The password named ''{0}'' could not be saved.

Cause: Designer attempted to set a named password in eDirectory, but the request failed.

Solution: Turn on stack tracing for the Import/Deploy plug-in to get details of the exception. To do
this, select Window > Preferences > Designer for IDM Trace > Enable Tracing. In the Trace
window, select the check box for Include Stack Traces.

The value for the attribute named [Attribute Name] could not be stored
on the object named [Object name].

Cause: Designer attempted to add an attribute to an object in eDirectory, but the request failed. The
error message should contain information about the attribute and object.

Solution: Verify that the attribute and value are valid for the given eDirectory object type.
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The value for the attribute named ''{0}'' could not be updated using
the XSLT on the object named ''{1}''.

Cause: Unable to export shim configuration information.

Solution: Contact Novell Support.

An exception was thrown updating the value of the [Attribute Name]
attribute on the [Item Type] object named [Object Name].
[Exception Info]

Cause: Unable to deploy the Identity Manager object and attributes to eDirectory. The error message
should contain details of the exception.

Solution: Contact Novell Support.
A [Object Class] object could not be created. The name is missing.

Cause: An eDirectory object could not be created for the given object class because a name was not
provided.

Solution: Contact Novell Support.

The policy named [Policy Name] contains a cycle in its next
transformation list.

Cause: This is a warning message generated when Designer encounters a circular loop in the policy
chain.

Solution: Remove the policy loop by correcting the next policy in the Policy Set view.

The policies named [Policy name] contain cycles in their next
transformation lists.

Cause: This is a warning message generated when Designer encounters a circular loop in the policy
chain.

Solution: Remove the policy loop by correcting the next policy in the Policy Set view.

Driver [Driver name] could not be restarted for the deployed changes to
be in effect.

Cause: Designer was unable to restart a driver after a deployment.

Solution: Turn on DSTRACE screen in eDirectory to identity the error preventing the driver from
starting.

Driver '[Driver Name]' is disabled and could not be restarted for the
deployed changes to be in effect.

Cause: Designer was unable to restart a driver after a deployment because its Driver Start option is
set to Disabled.

Solution: Change the Driver Start option to Manual or Auto-start under the driver properties and
then deploy the driver.

Driver ' [Driver Name]'

be in effect.

could not be stopped for the deployed changes to

Cause: Designer was unable to stop a running driver after a deployment.

Solution: Turn on DSTRACE screen in eDirectory to identify the error preventing the driver from
stopping.
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An invalid request to set up security on an exported driver was made,
no Driver objects were provided. The request cannot be processed.

Cause: The code to set up the security equivalence for a deployed driver was passed an invalid
parameter.

Solution: Contact Novell Support.

Warnings

The version of Identity Manager running on the server named '[Server
Name] ' does not support all the features of Designer. Although you can
import a configuration from that server, changes may not work if the
configuration is deployed back to it.

Cause: An import or deploy action was made to an eDirectory server running an unsupported
version.

Solution: The server must be upgraded for deployments.

An internal error has occurred. The parameters passed into the importer
were invalid.

Cause: The code that performs the import was passed an invalid parameter.

Solution: Contact Novell Support.

The '[Attribute Name]' attribute of '[Object Name]' refers to a policy
that does not exist or cannot be accessed.

Cause: The driver configuration file being processed contains a DN attribute that cannot be resolved
in eDirectory.

Solution: Verify or correct the DN attribute value on the specified object in eDirectory.
An external reference to '[Object Name]' was not handled.

Cause: The driver configuration file being processed contains a DN attribute that cannot be resolved
in eDirectory.

Solution: Contact Novell Support.

The XML for the policy named '[Object Name]' contained in the [Policy
Type] named '[Policy Name]' does not contain valid XML for a policy.
'[Root Node]' is not recognized as the root node for policy XML.

The policy is being ignored.

A}

Cause: The policy being imported does not contain a valid XML document.

Solution: Correct the content of the policy in eDirectory.

A [Item Type] can only be imported into a [Item Type].
A [Item Type] can only be imported into a [Item Type] or [Item Type].

Cause: An attempt was made to import an Identity Manager object into an invalid parent object. For
example, policies might not be imported into a Driver Set. The code should prevent this from
happening, but this error identifies scenarios that were not caught.

Solution: Contact Novell Support.

An unhandled import request was encountered in DeployImporter Import
method [Object DN].
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Cause: An attempt was made to import an unknown object or attribute from eDirectory. The code
should prevent this from happening, but this error identifies scenarios that were not caught.

Solution: Contact Novell Support.

Could not access the driver configuration file named '[File Name]'.
Cause: Designer could not open or parse the given driver configuration file.

Solution: Contact Novell Support.

The driver filter could not be read from the driver named ' [Driver
Name] .

Cause: Designer could not import the Driver filter.

Solution: Turn on the DSTRACE in eDirectory to determine the error, then contact Novell Support.

An error was encountered processing the driver configuration file. The
variable named [Variable Name] is defined more than once.

Cause: The driver configuration file has a variable that is being defined multiple times.

Solution: If you are importing a driver configuration file from a file, edit the file and remove
multiple declarations for the specified variable. If this is a dynamically generated configuration file
(import/deploy to eDirectory), turn on XML tracing for import/deploy to get a trace of the generated
configuration file, then contact Novell Support. To turn on trace for Designer, select Window >
Preferences > Identity Manager > Application > Trace > Enable Tracing. In the Trace window,
select the check box for Include XML Processor Traces.

An error was encountered processing the driver configuration file. The
declaration of the Node variable named [Variable Name] is invalid. The
[Attribute name] attribute is missing.

Cause: The driver configuration file being processed has an invalid variable declaration.

Solution: If you are importing a driver configuration file from a file, edit the driver configuration file
and correct the variable declaration. If this is a dynamically generated configuration file (import/
deploy to eDirectory), turn on XML tracing for import/deploy to get a trace of the generated
configuration file, then contact Novell Support. To turn on trace for Designer, select Window >
Preferences > Identity Manager > Application > Trace > Enable Tracing. In the Trace window,
select the check box for Include XML Processor Traces.

An error was encountered processing the driver configuration file.
Flexible prompting requires a 'use-when-value' when a 'use-when-var'
is specified.

Cause: The driver configuration file being processed has an error.

Solution: If you are importing a driver configuration file from a file, edit the driver configuration file
and add a use-when-value for the specified use-when-var. If this is a dynamically generated
configuration file (import/deploy to eDirectory), turn on XML tracing for import/deploy to get a
trace of the generated configuration file, then contact Novell Support. To turn on trace for Designer,
select Window > Preferences > Identity Manager > Application > Trace > Enable Tracing. In the
Trace window, select the check box for Include XML Processor Traces.

An error was encountered processing the driver configuration file.
Flexible prompting requires a 'use-when-var' when a 'use-when-value'
is specified.

Cause: The driver configuration file being processed has an error.
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Solution: If you are importing a driver configuration file from a file, edit the file and add a use-
when-var for the specified use-when-value. If this is a dynamically generated configuration file
(import/deploy to eDirectory), turn on XML tracing for import/deploy to get a trace of the generated
configuration file, then contact Novell Support. To turn on trace for Designer, select Window >
Preferences > Identity Manager > Application > Trace > Enable Tracing. In the Trace window,
select the check box for Include XML Processor Traces.

The variable named [Variable Name] has been referred to but not defined
in the driver configuration file being processed.

Cause: The driver configuration file has a variable that is being referenced but has not been defined.

Solution: If you are importing a driver configuration file from a file, edit the driver configuration file
and add a declaration for the specified variable. If this is a dynamically generated configuration file
(import/deploy to eDirectory), turn on XML tracing for import/deploy to get a trace of the generated
configuration file, then contact Novell Support. To turn on trace for Designer, select Window >
Preferences > Identity Manager > Application > Trace > Enable Tracing. In the Trace window,
select the check box for Include XML Processor Traces.

An error was encountered processing the driver configuration file.
Built-in variables cannot be used as a flexible prompting control
variable. The reference to the variable named ' [Variable Name]' is
invalid.

Cause: The driver configuration file being processed contains an invalid reference to a variable.

Solution: If this is a dynamically created configuration file generated during an import/deploy
action, contact Novell Support. If this is a driver configuration file being imported from disk, edit
and correct the configuration file for the variable specified.

An error was encountered processing the driver configuration file.
There was a non-checkbox reference to the checkbox variable named

' [Check Box Variable name]'.

Cause: The driver configuration file being processed contains an invalid reference to a check box
variable.

Solution: If this is a dynamically created configuration file that is generated during an import/deploy
action, contact Novell Support. If this is a driver configuration file being imported from disk, edit
and correct the configuration file for the check box variable specified.

An error was encountered processing the driver configuration file. An
unhandled import prompt was encountered.

Cause: The driver configuration file being processed contains an invalid prompt type.

Solution: If this is a dynamically created configuration file that is generated during an import/deploy
action, contact Novell Support. If this is a driver configuration file being imported from disk, edit
and correct the configuration file.

The eDirectory tree corresponding to the Identity Vault named
'[Identity Vault Name]' cannot be accessed. Directory browsing cannot
be performed.

Cause: Designer attempted to access eDirectory through an eDirectory browse button in the Driver
Configuration Wizard, but the connection could not be created.

Solution: Cancel out of the Driver Configuration Wizard, set up the connection parameters in
Identity Vault, and run the Driver Configuration Wizard again.
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The partition could not be created on the ''{0}'' object. The problem
may be that it has not replicated to the master yet. You can try
creating the partition manually later.

Cause: Designer attempted to create a partition when deploying a driver set and the partition
operation failed.

Solution: Turn on the eDirectory tracing options for partitioning to determine why the eDirectory
partitioning operation failed.

The Driver Set was created but did not replicate to all the servers in
the replica ring. The deployment cannot proceed.

Cause: Designer cannot deploy per-server attributes until the driver set has replicated to the
eDirectory server.

Solution: Turn on the eDirectory tracing options for replication and determine why eDirectory
replication is not occurring.

There are no servers associlated with the Driver Set named ''{0}'"'.
There must be at least one server associated with any Driver Set being
deployed or the Driver Set containing any objects being deployed.

Cause: Designer cannot deploy an Identity Vault or driver set with an empty server list.

Solution: Edit the properties of the Identity Vault and the driver set to add a server to the server lists.

The Identity Vault name '[Identity Vault Name]'' does not contain any
Driver Set objects to deploy.

Cause: You cannot deploy an Identity Vault that does not contain at least one driver set.

Solution: Add a Driver Set to the Identity Vault.

' [User Name]' could not be authenticated to '[Host Name]'. Cannot
proceed.

Cause: Designer could not authenticate to the eDirectory tree.

Solution: Verify that the host name, user, and password for the Identity Vault are correct in the
Identity Vault properties.

The Identity Vault named '[Identity Vault Name]' does not contain the
eDirectory tree to access. Cannot proceed.

Cause: The Identity Vault does not contain a host address or DNS name for authentication.

Solution: Specify the host address or DNS name for the Identity Vault in the Properties view or
Properties page.

Deploy Util NoldentityVault=The {2} named ''{1l}'' is not contained in
an {0}. Cannot proceed.

The Identity Vault named '[Identity Vault name]' does not contain the
DN of the user to authenticate to the target eDirectory tree with.
Cannot proceed.

Cause: The Identity Vault does not contain a user for authentication.

Solution: Specify the user for the Identity Vault in the Properties view or Properties page.

The server list on the parent Driver Set for the following eDirectory
Driver is empty. We were unable to import the connected eDirectory
Driver:
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Cause: Designer uses the per-server Shim Auth Server attribute of an eDirectory driver to identify
the tree and connected eDirectory driver to import. Because the server list is empty, the connected
eDirectory driver cannot be imported.

Solution: Fix the server list on the driver set for the eDirectory driver and the Drivers Shim Auth
Server attribute in eDirectory or import the connected eDirectory driver separately.

The Shim Auth Server parameter for the eDirectory Driver '[Driver
Name] ' on server '[Server Name]' is empty. We were unable to import the
connected eDirectory Driver.

Cause: Designer uses the Shim Auth Server parameter of an eDirectory driver to identify the tree
and connected eDirectory driver to import. If this parameter is empty, the connected eDirectory
driver cannot be imported.

Solution: Fix the Shim Auth Server parameter on the eDirectory driver or import the connected
eDirectory driver separately.

Unable to save Driver Configuration to file '[File Name]'.
Cause: Designer was unable to save an exported driver configuration file.

Solution: Try to save the file to a different directory or filename.

Unable to clear contents of Driver Configuration file '[File Name]'.

Cause: Designer was unable to clear the contents of a driver configuration file that is being
overwritten.

Solution: Delete the configuration file being overwritten.

Setting up the Security Equals and Excluded objects may only be
performed on a Driver object.

Cause: An invalid object was selected in the Modeler or Outline view.

Solution: Select a single Driver object to set up security equivalences or excluded users.

Only one Driver object can be selected to set up the Security
Equivalences and Excluded objects.

Cause: Multiple Driver objects are selected in the modeler or outline view.

Solution: Select a single Driver object to set up security equivalences or excluded users.

The selected Driver ''{0}'' has not been deployed or cannot be found in
the eDirectory ''"{1}''.

Cause: Designer cannot resolve to the Driver object in eDirectory to set up the security equivalences
or excluded user list.

Solution: Deploy the driver to eDirectory before setting up the security equivalences or excluded
users.

The eDirectory tree corresponding to the Identity Vault named ' [Tree
Name]' cannot be accessed. Setting up the Driver Security Equivalence/
Excluded Users cannot be performed.

Cause: Designer cannot connect or authenticate to the eDirectory tree to set up a driver's security
equivalences or excluded user list.

Solution: Verify that the eDirectory parameters specified on the Identity Vault are correct and that
the eDirectory server is running.
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The Identity Vault named '[Identity Vault Name]' has no deployment DN
specified. It is not deployable.

Cause: A deployment context is not specified on the Identity Vault or driver set being deployed.

Solution: Add a deploy DN (context) to the properties of the Identity Vault or Driver Set object in
Designer.

24.5 Issues When Generating Documents

There are two main issues that occur when generating documents:

¢ Section 24.5.1, “Memory Issues,” on page 509
¢ Section 24.5.2, “Editing Extra Identity Vault Schema Items from Your Report,” on page 511

24.5.1 Memory Issues

When generating documentation for a project, Designer puts all model/project information into the
document. If the Designer’s memory parameters are not being used or if your computer does not
have enough memory available to run the document generation process, you see the following error
message:

Figure 24-7 Out of Memory Message

@ Confirm 3]

size, Please refer ko help For information on how to adjust memory settings.

@ Cuk of memaory: There is nok enough memory to generate a docurment of this
Java heap space

¢ “Solution 1: Ensure that Memory Parameters Are in Place” on page 509
¢ “Solution 2: Change Memory Parameters” on page 510

¢ “Solution 3: Disable Schema Generation” on page 511

Solution 1: Ensure that Memory Parameters Are in Place

The amount of memory that the default JVM* instance of Designer uses is defined in the memory
parameters -vmargs -Xms256m -Xmx512m. The -Xms256m parameter is the minimum amount of
memory (in megabytes) that is set aside for Designer, and the -Xmx512m parameter is the maximum
setting. These are the only parameters that need to be adjusted. In Windows, these settings are
included as part of the Shortcut Properties and are implemented when Designer loads.
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Figure 24-8 Windows Shortcut

Designer for Identity Manager Properties  [Z][¥]

General | Shortcut |Eompatibilit_l,l Security | MNetware Version

Dezigner for [dentity Manager

It

Target type: Application

Target location: eclipze

Target:

Start in: |"I::"~F'rogram Files'Movel\Designerheclipse" |

Shartcut key: |N0ne |

Bur: | Marmal window b |

Comment; | |

[ Find Target... ] [ LChange lcon... ] [ Advanced... ]

[ Ok ][ Cancel ]

You can run into memory issues if you have deleted the parameters in your Designer shortcut and
forgot include them again. Or you might be clicking the Designer executable file directly, so
Designer won’t use these designated memory parameters. To ensure that the memory parameters are
in your Windows shortcut, right-click the desktop shortcut for Designer and select Properties. On
the Target line in the Shortcut window, you should have the following:

C:\Program Files\Novell\designer\eclipse\designer.exe” -vmargs -
Xms256m -Xmx512m

For Linux workstations, the parameters are located in the /designer/eclipse/
StartDesigner. sh file. This file should contain the following line:

/home/user/designer/eclipse/Designer -vmargs -Xms256m —-Xmx512m

Solution 2: Change Memory Parameters

The default memory parameter should be adequate for most document generation. However, if you
have enough available memory, change the -Xmx512m parameter to ~Xmx768m or ~Xmx1024m.
This changes the maximum setting.

NOTE: These settings are adjusted in megabytes.
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Solution 3: Disable Schema Generation

If you are using the maximum amount of memory you can on this workstation and are still receiving
Out Of Memory errors when generating documents, disable the schema when generating
documents. To do this, click on the 5. Appendix B: Schema heading in the Style Editor.

Under the Appendix B: Schema heading, deselect the Include this section in the final document.
When deselected, Appendix B: icons under the Style Editor view change to reflect the new settings.
You should now be able to generate a document without memory errors.

NOTE: This issue is being addressed in later versions of Designer.

24.5.2 Editing Extra Identity Vault Schema Items from Your
Report

If you import a project with the entire Identity Vault schema and run document generation on that
project, you can have an extra 600 pages or more of schema information. This happens because you
have all of the Identity Vault’s base schemas included in the document. Follow these steps if you do
not want to document all of the Identity Vault’s base schemas:

1 Go into the workspace folder for this project and delete the . data file.

For example, on a Windows workstation, the Blanston1_files directory is found at
C:\Documents and Settings\Novell
User\workspace\Blanstonl\Blanstonl files. By clicking Type, you will see all
of the .data files shown together. The largest . data file holds the base Identity Vault

schema.
arme Size  Tvpe
|2 policy_trace File Folder
OFEZ[v_13-FEC3-FSOB-6B95-139BA1E21439, application 1 KB APPLICATION File
I4A75442-DE22-E6FE-C6F2-056BD0SCE0BS, application 1 KB APPLICATION File
BODE1EQNC-8FBE3-AE42-9934-2860685E944 1 . application 1 KB  APPLICATION File
BDAS3627-6C 6F-CB44-7ADA-EQ7E770CESOD, application 1 KB  APPLICATION File
ECEDFATA-00C5-50C 7-6096-366C4 7 32FEED. application 1 KB APPLICATION File
ED218004-EDF7-ADS1-40C7-3684CFI02623 , application 1 KB APPLICATION File
ﬂ 1DFS040C-B803-DF75-030E-47C 1 730720E9. data 4EKE DATA File
ﬂ ZDF74CAD-B35E-52F2-A239-16364C_23EEE4. data 4KE DATA File
ﬂ 206A7590-E46A-2308-AF LE-405194A516CA, daka 27T KE  DATA File
ﬂ 3172436C-9E64-ACA1-D354-4DE620A51016E data 3KBE DATA File
ﬂ A4Z7920B-BDES-C 1 A9-AFCS-6FDFESS067ES, data 4KE DATA File
)| AFE1DCE4-DEAF-B0EE- -DADC199AFI4E, data I40KE DATA File
ﬂ BODE1EOC-SFE3-AE42-9984-2860685E9441 . data 4 KB DATA File
ﬂ B4F327A5-0EDF-13B7-9C 16-BFE1C2529BE6, data 4KE DATA File

If you have more than one Identity Vault in your project, you see more than one large .data
file in the project’s folder.
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2 Open the . data file in a text-based editor (in this instance, Wordpad) to make sure you have
the schema file. You see <schema-de > at the top of the file:

<zchema-def>

<class-def class-hatwe="AFPF Serverf:
<attr-def attr-nawme="Account Balance™ multi-value
<attr-def attr-name="ACL" type="structured"/:>
<attr-def attr-nane="A4llow Unlimiced Credit™ mmltc
<attr-def attr-name="Audit:File Link" multi-wvalue
<attr-def attr-name="Authority Revocation'™ multi-

<attr-def attr-name="auxClassCompatibility" read-
<artr-rdef artr-name="Rark T.ink" rerad-rmlw="rru="

3 Assume that you don’t want the Identity Vault’s entire base schema, only the schema
differences between your project and the Identity Vault. To get the schema differences, delete
any large .data files and re-import the project’s schema, using the following steps:

3a Bring up the project in Designer’s Modeler view. Right-click the Identity Vault and select
Live Operations > Import Schema.

3b On the Select Source for Import page, select Import from eDirectory if you are connected
to an actual Identity Vault, or select Import from .sch File if you have saved the schema
files locally.

3¢ On Import from eDirectory, type the host name, user name, and password connection
information. Click Next.

3d On the Select Classes and Attributes for Import page, click View Differences.

@ Schema Import Wizard 3

Select Classes and Attributes for Import @
Check "Import all associations" to associate the selected atiributes with
Classes that may already exist in Designer,
Classes: Affributes: [ Import all associations
O anything] | |Oranything] ~
O mothing] O Mathing]
CaFF Server accessCardMumber
Oalias Oaccount Balance
Capchadmncaonfiguration ClacL
OapchadranconfigurationBlock Calizsed Chiect Marne
Oapchadmntdodule Oallow Unlimited Credit
CapchadmnsServer lapchadmn-Block Type
OapchadmnyirualHost O apchadmn-Configurationinfo e
O applicationEntity v | ¥
Select all ‘ Unselect All ‘ Select All | Unselect All

Yiew Differences, .. |

Help

| Finish | Cancel
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3e On the Schema Differences page, you see the schema differences between Identity Vault

and your project.

@ Schema Import Wizard

Schema Dilferences

Classfatribute

Class: Counlry

Class: DNIPIDHCP Servar
Class: DWIP:DNS Rizat
Class: DMIP:DNS Server
Class: DHIP:DNS Zone

Class: DMIF:Locator
Class: DHIP:Subret

Clags: DHIP:Subnet Pocl

Zlass: domain
Class: Employes Infio
Class: Locali
Class: MauditThanne!

Clags: MAuditsVR

Class: MauditFie

Class: Maudifiter

Class: MAudiFiterContainer
Clazs: MAudiHearheat
Class: MaudiDava

Class: Mauditlogapn

Class: MAudittdySIL

Class: DNIPIIP scdress Configuration

Class: DMIP:Subret Address Range

Class: dnpDNSDHCPServerviarsion

Class: MauditThannelContainer

Clazs: Maudit egappContainer

This table showes all of the differences between the Identity Yault schama and the

Difference

Optional ablributes are differant
Clazs does not exiet in projact
Class does not existin project
Class does not exist in project
Class does nol exist in project
Clazs does not exiet in projact
Class does not exist in project
Class does not exist in projact
Clazs does nol exist in project
Class does not exist in project
Class does not exist in projact
Optional atiributes are differant
Clazs does nol exist in project
Optional atrfutes are different
Class does not exist in project
Class does not exist in project
Clazs does nol exist in projact
Class does not exkst in project
Class does not exist in project
Class does not exist in project
Clazs does nol exist in projact
Class does not exist in project
Class does not exist in project
Class does not exist in project
Class does not exist in orojact

e

(3
[a

w

Check Differences | Cancal

3f Select Check Differences. This brings you back to the Select Classes and Attributes for
Import page with the differences now selected under the Classes and Attributes headings.
By default the Import All Associations box is also selected. Leave it selected and click

Finish.

3g On the Import Summary page, click OK.

When you run document generation on this project, you only document the schema differences that
you imported, not the whole Identity Vault schema. Your present choices are to import the entire
Identity Vault schema or just the schema differences between the Identity Vault and the project. You
can also choose to not include the schema in your document by deselecting Include This Section in
the Final Document, as described in “Solution 3: Disable Schema Generation” on page 511. This

document generation of the schema a known problem and will be fixed in the future.

24.6 No F1 Help in Maximized Editors

Context-sensitive help is available when you press F1. However, if you maximize an editor (for
example, the Modeler), help topics do not display when you press F1. To view the help, minimize

the editor.

24.7 Freeing Heap Memory

A status field at the bottom of Designer displays heap memory used and heap memory available for

an application or other item in Designer.

Troubleshooting Designer

513



Figure 24-9 The Heap Memory Display

J| | 21M of 254M “[Tl]‘ |

The information varies, depending on which item (for an example, an application) you click in the
Modeler, Outline view, or other editors.

To free unused heap memory at any time, click the Run Garbage Collector icon.

Figure 24-10 The Run Garbage Collector Icon

J HW@RT arbage Collector]
24.8 Reporting Bugs and Giving Feedback

Gathering bugs and getting your ideas are keys to improving the performance of Designer and
making Designer a tool of choice for you. To send us your feedback, select Help > Report a Bug or
Feedback. We encourage you to try it!

1 Select Help > Report a Bug or Give Feedback.
2 Log in to Bugzilla.

& for the Open Erterprise™ United States - English search

NOVE'L Products & Solutions Services & Support Partners & Communities e dovwnload & Login

Login to Continue

Learn Authertication is reguired to access this page or file. % what does this mean™

Create Account »

Manage Account it

walidate Email Address .
B - Usamame:
Forgot Password e |
Forgot Lsername a0t p 7 ;
Forgat A0

If you don’t have an account, you can easily create one.
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3 Select the component in the product that you are reporting on.

Enter Bug: Identity Manager Designer

This page lets you enter a new bug into Bugzilla.

u Before reporting a bug, please do the following

+ Search for the bug
=+ Look atthe list of most frequently repored bugs

=+ Read the bug writing guidelines

u Report Bug Found in - Identity Manager Designer

-n
=
=
=
=
<
jud
@2,
=
=
E]
-y
=
=
L}
-
o,
s}
=
o

>

DL grid oo moga e
Common ‘widgets
Configuration kM anagement
Dataflow Editor

Dataflow Wiew

Denlow

Hnr(lwm'e:| Other v | ﬁ:| Other v |
Se'\-'el'i_ly.l Marmal v |

Found By'| Other A | Partner ID:| |

NTS Priority: | | NTS Support = | |

EAES

Component:*

<

» Bug Details

Summary:* |
Description:™

The Designer 2.1 product is preselected. If you don’t know which component you are reporting
on, select your best guess (for example, Modeler).

4 1In the Summary field, summarize the problem or your request for an enhancement.
5 In the Description field, describe the bug or enhancement.

If you are reporting a bug, provide clear steps on how to reproduce the problem.
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Designer: An Effective Tool

Designer has abundant, easy-to-use features.

Section A.1, “Core Application Services and Framework,” on page 517

Section A.2, “Installation,” on page 518

Section A.3, “Enterprise Modeler,” on page 518

Section A.4, “Project View,” on page 519

Section A.5, “Outline View,” on page 519

Section A.6, “Import and Deploy,” on page 519

Section A.7, “XML Editor,” on page 520

Section A.8, “Configuration Management,” on page 520
Section A.9, “Policy Management,” on page 520
Section A.10, “Policy Simulation,” on page 522

Section A.11, “Dataflow View and Editor,” on page 522
Section A.12, “Entitlements,” on page 522

Section A.13, “E-Mail Notification Templates,” on page 523
Section A.14, “Document Generator,” on page 523
Section A.15, “Directory Tools,” on page 523

Section A.16, “Version Handling,” on page 524

Section A.17, “Project Converter,” on page 524

Section A.18, “Project Checker,” on page 524

A.1 Core Application Services and Framework

*

*

Basic views: Error Log, Outline, Project, Navigator, Tasks
A fully indexed and searchable Help system

General undo/redo capabilities

Internal common services: utilities, APIs, widgets, and resource caches

Log and trace files

Perspective management: open close, copy, and reset

Preferences: general appearance, fonts, colors, styles, file associations, and history

Text editor: CUA keyboard, tabs, print margins, line numbers, colors, preferences, find/replace,

bookmarks, go-to line, print

Toolbar, menu bar, welcome bar, perspective bar, and fast view bar

Trace view with preferences for controlling the output
View and editor management

Welcome page: what’s new, updates, and Flash demos
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*

Localized software for international customers

A.2 Installation

*

*

*

*

*

Ability to install newer plug-ins, manage installed plug-ins, and back-rev if necessary
Option to place the Designer icon on the desktop

Option to run Designer directly from the install

Automatic (or manual) checking for updates, with a setting to turn updates on or off

Language selection for localized installs

A.3 Enterprise Modeler

*

*

Alignment capabilities: grid, snap, ruler, distribution, and hints
Auto-layouts: star, circle, half-circle, and expand or contract in and out
Copy/paste within editors and across editors

Color themes

Delete (with multiselect support)

Driver Configuration Wizard integration

A graphical Dataflow view and the ability to manipulate data flow arrows: update filters,
schema, and mapping policies visually

Decoration support: change vaults to trees, mark drivers as remote or communicating across
firewalls, resource icons (help desk, log, and audit)

Domain group management: add to group, ungroup, nest groups, clear, minimize/maximize,
expand/collapse all, restore, auto-size, icon library

Drag and drop Identity Vaults, driver sets, applications, domain groups, and resources
Integration among editors

Modeling Palette: drag and drop, folders, configurable in Preferences
Graphic snapshot services

Help: context-sensitive, search, browse, and demos

Direct link from the help menu to the Identity Manager forums
High-level architect mode and low-level developer modes

Inline editing of titles and labels

Integrated hierarchical Outline view

Keyboard support

Edit icons

Manage line connections: auto-connecting, auto-highlight, mouse gravitation, collapsing lines
when groups collapse, line straightening, reconnect, eDir-to-eDir connections, multidriver
connections

Preferences: many preferences for display behaviors, prompts, and auto-wizards
Print support with various fit-to-page options

Search a model: case sensitivity, integrated editors, and searching by class
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Manage selections: marquee and selection tools, synchronized selections with external views,

select all, and extend or remove from selection

Integrated services: start or stop drivers, driver information, and import or deploy

Subapplication modeling with applications that contain applications

Table editor: sort columns and launch editors
Dataflow editor
Server creation requests version information

Zoom, pan, and scan (in the Thumbnail view)

A.4 Project View

*

*

*

Copy projects

Delete projects

Create projects with the New Identity Manager Project Wizard
Expand/collapse all

Help-me-get-started process

Import from directory or file system

Move project

Multiproject support

Project documentation folder and content management

A.5 Outline View

Create new items: vaults, drivers, driver sets, and applications
Delete a selected item

Integrated launching of editors

Expand/collapse all

Export to a driver configuration file

Filter the view to show only certain objects

List all project items hierarchically

Host the Modeler Thumbnail view and the Policy Flow view
Import/deploy integration

Save and restore the expansion state and selection
Synchronize selections with the Modeler

Undo/redo

A.6 Import and Deploy

+ Deploy groups, identity vaults, driver sets, drivers, policies, channels, and e-mail templates

¢ Import an existing Identity Manager solution from the directory into a project

*

Import driver sets, drivers, policies, and channels
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Import both sides of eDir-to-eDir drivers
Import and deploy driver configuration files
Handle multiserver environments

Set up driver security

Easily protect overwriting during conflicts

View changes before you deploy

A.7 XML Editor

*

Used in policy management and configuration editing

For notification templates, you can use an HTML editor.
Outline view support

Find and replace

Highlight syntax

Auto suggest

Auto-insert end tags

A.8 Configuration Management

*

*

Edit applications: name, type, icon, environment, and administrator notes

Edit drivers: Global Communication Values (GCVs), log level, module, authentication, driver
parameters, startup option, driver manifest, named passwords, icon, and trace

Edit driver sets: GCVs, servers, trace, and log level

Edit e-mail templates: collections, e-mail notification server, and all template content with
token support

Edit Identity Vaults: credentials, administrator notes, and server list
Edit resources: name, type, icon, and administrator notes
Edit servers: name, context, host, DNs name, notes, and contact information

Properties view: column resizing, hierarchical groups, inline editors and editor launching, and
support for simultaneously editing selected items

A.9 Policy Management

*

*

*

*

Section A.9.1, “Policy Flow View,” on page 520
Section A.9.2, “Filter Editor,” on page 521
Section A.9.3, “Schema Map Editor,” on page 521
Section A.9.4, “Policy Builder,” on page 521

A.9.1 Policy Flow View

*

*

Reorder, add, and delete policies (Policy Script or XSLT)

Policy editor integration

520 Designer 2.1 for Identity Manager 3.5.1



+ View policy flow between an application and the Identity Vault
¢ View Policy Set details in the Policy Set view

¢ In the Outline view, view a hiearchical organization of policies in the Policy Set view

A.9.2 Filter Editor

¢ Add classes and attributes
¢ Copy the filter

¢ Delete

¢ Multiselect support

¢ Keyboard support

¢ Refresh the schema

+ Expand/collapse all

¢ Configure default values
¢ Create a home directory
¢ Track member templates
¢ Merge authority

¢ Optimize modifications
¢ Undo/redo

¢+ XML editor integration

A.9.3 Schema Map Editor

¢ Add classes and attributes
¢ Delete

¢ Multiselect support

¢ Keyboard support

¢ Refresh the schema

+ Expand/collapse all

+ Non-class specific handling

¢ Integrated XML editor

A.9.4 Policy Builder

¢ Create and edit policy scripts

¢ Define rules: conditions, actions, groups
+ Support for predefined rules

¢ Emphasis on productivity

¢ Nested inline editors

¢ Keyboard support
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Copy/paste within an editor and across editors
Drag and drop

Integrated Help

Policy creation wizards

Import/export

Namespace editing

Expand/collapse all

Reordering

Integrated e-mail templates

Integrated Global Configuration Values
Integrated schema

Various display preferences

Argument builder and token editor
Undo/redo

Validation

Integrated XML editor

A.10 Policy Simulation

*

*

*

Launch a simulation wizard from the Policy Flow view, policy editors, and the Policy Set view
Load sample input documents: user add, delete, query, modify, and association

Edit input documents by using an inline XML editor

Query document input

Render output documents

See the Metadirectory engine log of event processing

Clear logs

Select a policy set you want to simulate

Chain simulation from one policy to the next

A.11 Dataflow View and Editor

View the filters that allow the data to flow between all of the systems and the Identity Vaults
View how the passwords flow through the different systems
Add, delete and edit driver sets, drivers, filters and Identity Vaults from one location

Generate HTML reports of the data flow and password flow

12 Entitlements

Set up criteria that, once met, initiate an event to grant or revoke access to business resources

Use Role-Based entitlements (automated) and workflow provisioning entitlements (approval
required)
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¢ Use the Entitlement Wizard graphical interface to create the types of entitlements that you can

*

*

use
For a number of drivers, use preconfigurations that already contain entitlements

Manage entitlements by using either of two packages: iManager through Role-Based
Entitlement Policies, or the User Application for workflow entitlements

A.13 E-Mail Notification Templates

*

*

*

*

Provide users with hints when they forget passwords
E-mail new passwords

Explain why a password wasn’t reset or didn’t synchronize
Add or import templates

Customize e-mail messages

A.14 Document Generator

*

*

*

*

*

Click a button and generate a PDF document of your project

Edit the content of the document: title, name, legal disclaimer, executive summary, and
overview

Edit the Document Style (template) to format the style and content any way you want
Generate a linkable appendix and a table of contents

Generate graphical filter policy tables with a legend

Generate Policy Builder rule tables

Generate detailed information on all vaults, driver sets, drivers, and policies
Generate schema tables

Generate server configuration tables

Include model diagrams

Manage and view multiple styles in the Project view

Number pages

A.15 Directory Tools

*

*

*

*

*

Directory browser for selecting objects: filtered on type; switch to another vault
Import and deploy the schema to a directory or .sch file
Use available eDirectory™schemas for offline-from-scratch modeling

Manage schema attributes: add, rename, delete, set constraints, syntax, size, see what classes
are used, define hierarchy, and specify mandatory/naming/optional attributes

Manage schema classes: add, rename, delete, set class flags, define hierarchy, specify
mandatory/naming/optional attributes

Schema management filter to see only changes that you’ve made in a project
Remotely control desktop applications and resources

Launch and use iManager
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¢ Manage directory objects

A.16 Version Handling

+ Most Designer components are now sensitive to the version of Identity Manager that the piece
of configuration is going to run on

+ Prevents incompatible configurations by adapting the UI to show only available features for the
selected version.

¢ The Add Server Wizard lets you specify the Identity Manager version. Easily change to another
version.

+ Loads the Legacy Policy Builder loads if your Identity Manager version earlier than Identity
Manager 3.5. Loads the new Policy Builder loads if your Identity Manager version is 3.5.

+ Warning or preventing deployment to a legacy server if an incompatible configuration is
detected during import or deployment.

¢ Driver configuration files report the minimum required engine version.

A.17 Project Converter

+ Is a framework of chained converters
+ Converts earlier projects to Identity Manager 3.5 formats
+ Provides a backup of an earlier project in case you need to use the earlier version

¢ Launches automatically

A.18 Project Checker

¢ Checks project for validity and completeness before deploying
¢ In manual mode by default, but can be changed to run at every save

¢ Checks whether global variables exist as GCVs when referenced from conditions or actions
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Document Generator Core
Support Templates

*

*

*

*

Section B.1, “dgSection.xsl,” on page 525

Section B.2, “dgFormat.xsl,” on page 526

Section B.3, “idmConfig.xsl,” on page 528
Section B.4, “idmUtil.xsl,” on page 529

B.1 dgSection.xsl

Import: dgFormat.xsl

Table B-1 dgSection.xsl

Template

Description

match “/”

Section.Sequence

Section.Main
Section.Content
Section.Body
Section.ShowStyleAttributes

Section.Children

Section.PagelLayout

Section.staticContent

Section.Title

Section.TitleText

Main template that invokes all sub-templates. Users can override this
template to create their own template behavior; however it is
recommended that you override the Section.Content, Section.Body or
Section.Main.

Main template that invokes all sub-templates. Users can override this
template to create their own template behavior; however it is
recommended that you override the Section.Content, Section.Body or
Section.Main.

This section includes Section.Content and Section.Children.
This section includes Section.Title and Section.Body.
The body content of the section.

Describes the default way to display attributes (when no template is
defined).

Parameters:
border - border used for tables. The default value is 0.5pt solid black.

Inserts the child sections that are passed as a parameter into this
template.

Formats the page layout including paper size, headers, page numbering,
and so forth. The Section.Main template is called to insert the document
into this layout.

This template formats the page layout, including paper size, headers,
page numbering, and so forth. The Section.Main template is called to
insert the document into this layout.

Creates a title block containing the appropriate title text and link.

Gets the text that should be displayed for this section.
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B.2 dgFormat.xsl

Table B-2 dgFormat.xsl

Template

Description

Format.Title

Format.FigureTitle

Format.OutputTextArea

Format.EnabledStatus

Format.Chechbox

Format.PropertyRow

This template takes care of all the details involved in formatting a
title block.

Parameters:

text - Text to display.

id - Id for linking to this title (such as from the table of contents).
font - Font size to use.

image - Image to show as a bullet. The auto value tries to
determine an image based on the current element.

This template takes care of all the details involved in formatting a
figure title block.

Parameters:
title - Title text.
description - Description text.

Formats parameter information returned from a text area control
that can contain HTML tags. If there is no HTML prefix, then line
breaks are inserted.

Parameters:
value - Value of the textarea to output.

Shows enabled image if value is True, disabled image shows
only when parameter showDisabled is set to True.

Parameters:

value - Enabled, True/False.

showDisabled - Set to True if the disabled image should show
when the value is False. The default value is False.

Shows a check box image if the value is True, or an empty check
box image otherwise.

Parameters:

value - Checked, True/False.

default - Default value if ", False or some other value besides
True exists The default value is False.

Shows a table property row with two columns, one for the name
and one for the value.

Parameters:

propertyName - The property name.

propertyValue - The property value.

border - Border used for table. The default value is 0.5pt solid
black.

disable-output-escaping - Disable output escaping on the output
value, used so you can pass escaped FO content. The default
value is False.

showEmpty - Show empty values. The default value is False.

526 Designer 2.1 for Identity Manager 3.5.1



Template Description

Format.ContextRow Shows a contextual row with related attribute. Use this inside a
table.

Parameters:

text - Text to display.

level - Level or indent. The default value is 1.

href - Href value to link to another portion of the document.
image - Image to show as a bullet. The auto value will try to
determine an image based on the current element.
show-page-ref - Show page reference; True/False. The default
value is True.

Format.ShowBulletimage Show a bullet image.

Parameters:
image - Image to show as a bullet. The auto value will try to
determine an image based on the current element.

Format. XMLFigure This template takes care of all the details involved in formatting a
figure that shows XML content.

Parameters:

title - Title text.

description - Description text.

xml - XML data to show in the figure in text. You can also use a "."
to get the current node and children

simple-format - If True, this shows the XML without text selecting.
This can also be preferred if name space attributes need to be
included or if the XML is not well-formed. The default value is

False.
match "node()" XML-to-text formatting function.
mode "xml-to-text"

Parameters:

attr-name-color, attr-value-color

match "@*" XML-to-text formatting function.

mode "xml-to-text"
Parameters:

attr-name-color, attr-value-color

match "text()" XML-to-text formatting function.
mode "xml-to-text"

match "comment()" XML-to-text formatting function.

mode "xml-to-text"
Parameters:

comment-color

Format.ImageFigure This template formats a figure that shows an image for its
content.

Parameters:
title - Title text.
description - Description text.

Format.PageBreak Inserts a page break.
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Template

Description

Format.BasicLink

Format.BasicLinkToReferencedltem

Format.Uppercase

Format.SmartSpace

Format.OutputDebugParameters

Format.Debug

Creates a basic link to the given href using the given text. If the
href is empty, it only outputs the text value.

Parameters:
text - Link text
href - Link href

Creates a basic link to the XSl referenced item. This uses the
@guid attribute to build the link. If no @guid is available, only the
text label is rendered.

Parameters:
xsiHref - XSl value of referenced node.

Used to convert a string to uppercase text.

Parameters:
value - The value you want to convert to upper-case.

Used to convert a string to smart-spaced text.

Parameters:
value - The value you want to smart-space.

Outputs the debug parameters for a section when the attribute
DEBUG_PARAMS is enabled.

Outputs the specified text in a debug format when attribute
DEBUG is enabled.

Parameters:
text - Debug text.

B.3 idmConfig.xsl

Table B-3 idmConfig.xsl

Template

Description

match nkn
mode "xmlFigure"

match
"xsl:stylesheet|xsl:transform”

match "attr-name-map"

match "policy"

opConcat

Build an XML Figure for any policy type.

Parameters:
title, description, alwaysShowPolicyXmISource

Filter.

Parameters:
title, description

Attribute mapping.
Policy matching.

Parameters:
title, description, alwaysShowPolicyXmISource
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Template Description

opDelim

matCh ll@*ll
mode "DirXMLScript"

matCh nkn
mode "DirXMLScript"

match "arg-actions"
mode "DirXMLScript"

match "arg-dn"
mode "DirXMLScript"

match "arg-value"
mode "DirXMLScript"

match "token-text"
mode "DirXMLScript"

getLabel Utility method used to get policy related text labels.

Parameters:
name - The name of the label.

match "actions"

B.4 idmUtil.xsl

Table B-4 idmUtil.xsl

Template

Description

IdmUltil.ItemPropertyTable

IdmUtil.StartOptionPropertyRow

IdmUtil.ItemNumbering

IdmUtil.ltemText

IdmUtil.ItemType

Shows a table of values for the current Item. Depending on the item
might filter attributes.

Parameters:

title - Title text.

description - Description text.

showEmpty - Show empty values. The default value is False.

Shows the appropriate icon and text for the startup option on the
current Item. (0 = Disabled, 1 = Manual, 2 = Auto)

Parameters:
propertyName, propertyValue, border

Gets the current item numbering in context to the Designer source
(such as "2.4.5.2."). This template helps centralize what should be
counted in the numbering process because several places reuse
this information.

Based on the XSl type, returns text for the type, followed by a colon
and the name value (for example, Identity Vault: my vault 1)

Returns text representing the type of the current Item (such as
Identity Vault, Domain, or Driver Set)
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Template

Description

IdmUtil.PolicySetPropertyRow

IdmUtil.PolicySetLinks

IdmUtil.ConfigValuesTable

IdmUltil.FilterTable

IdmUtil.showSynclcon

IdmUtil.ValueOfReferencedltem

IdmUtil.ItemCustomlconFileName

IdmUtil.ShowlManagericon

Builds a property row with a list of the policies based on the next
policy value.

Parameters:

policy - Root policy of the policy set, passed by attribute name
(such as mappingPolicy).

label - Label for the displayed value.

emptyLabel - Text to show if the value is empty. The default value is
(none defined).

Returns a list of policy set links, called recursively.

Parameters:
xsiRootPolicyHref - Root policy of the policy set.

Shows a Config Value table for the given XML.

Parameters:

title - Title text.

description - Description text.

xml - XML value to use to create the table.

border - Border used for the table. The default value is 0.5pt solid
black.

emptyLabel - Text to show if the value is empty. The default value is
(none defined).

Shows a Filter table for the given XML.

Parameters:

title - Title text.

description - Description text.

xml - XML value to use to create the table.

emptyLabel - Text to show if the value is empty. The default value is
(none defined).

Show an IDM sync icon based on input type and sub-type.

Parameters:
type - Type is pub, sub.

sub-type - Sub-type is "", sync, ignore, notify, reset.

Returns the value of the node given the XSI expression. When
extracting the name of an item, you should use the
Format.BasicLinkToReferencedltem method so that the text is
created as a link inside the document.

Parameters:
xsiHref - XSl value of referenced node.
suffix - Suffix to append before select (the default is the current

node). The default value is ".
Get the custom icon filename for the given GUID.

Parameters:
guid - The item's GUID

This method is left here for backwards compatibility. Use
IdmUtil.Showlcon.
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Template Description

IdmUtil.Showlcon Shows the icon for the current ltem. This first checks the
cusomlconURI for a referenced image, then builds to a generic
path based on the type attribute (for Drivers and Applications).

Parameters:
image-width - The image width to use. The default value is 49px.
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Designer’s Architecture

¢ Section C.1, “Built on Eclipse Technology,” on page 533
¢ Section C.2, “Core Model Uses the Eclipse Modeling Framework,” on page 533

C.1 Built on Eclipse Technology

Designer is based on Eclipse technology. This open source technology is actively supported by over
60 leading companies (such as IBM*, HP*, Intel*, SAP, Fujitsu*, and Oracle) and by thousands of
other developers throughout the commercial industry and the academic world.

With Designer based on Eclipse, you receive the following benefits:

¢ Published, well-documented, and supported APIs used heavily across the industry.
¢ An underlying model that integrates well with any plug-in.
+ A rich, advanced Ul
¢ Capability to fully and easily extend our product in the future.
¢ Better integration and leveraging of other applications.
¢ Open source as the basic framework.
You can install Novell tools into any Eclipse-based framework.

¢ Out-of-box tools (Java* editor, debugger, JUnit, ANT, CVS integration) that are free if you
want to access them (and other tools) within the Designer.

¢ Cross-platform benefits of Java, but native performance and native look of the platform.
¢ Quick access to meaningful tools.
+ A framework that will quickly pick up entirely new capabilities contributed by a larger

community.

Instead of focusing on tools, developers are able to concentrate on providing quality content and not
spend so much time on the plumbing, debugging, and fixing of the framework.

C.2 Core Model Uses the Eclipse Modeling
Framework

At the heart of Designer for Identity Manager is a strong object model that is based on the Eclipse
Modeling Framework. This model uses the industry standard XMI format (XML Metadata

Interchange Format) for storing objects and their relationships. By basing Designer on this
technology, you get the following benefits:

¢ Published industry-standard APIs so that you can programmatically interact with the model.

*

A solid event-notification mechanism if the model ever changes.

+ All views, editors, and plug-ins will be notified and in sync.

*

The ability to auto-generate Java code or UML from the model, or vice-a-versa.

*

Undo/redo the stack across all views, editors, and plug-ins that are in sync with the model.
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The main purpose of XMI is to enable easy interchange of metadata between modeling tools (based
on the OMG UML) and between tools and metadata repositories (OMG MOF based) in distributed
heterogeneous environments. XMI integrates three key industry standards:

¢ XML (extensible Markup Language), a W3C standard

¢ UML (Unified Modeling Language), an OMG modeling standard

¢+ MOF (Meta Object Facility), OMG modeling and metadata repository standard
The integration of these three standards into XMI integrates the best of OMG and W3C metadata
and modeling technologies, allowing developers of distributed systems to share object models and
other metadata. XMI, together with MOF and UML, forms the core of the OMG repository

architecture that integrates object-oriented modeling and design tools with each other and with a
MOF-based extensible repository framework.
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Quickview: Menu Options

The following links provide information about options on the main menu and toolbar. If other items
appear in the user interface, they are contributed by other plug-ins. Documentation for those items

are in that plug-in’s section of the help system.

¢ Section D.1, “Options on the File Menu,” on page 535

¢ Section D.2, “Options on the Edit Menu,” on page 537

¢ Section D.3, “Options on the View Menu,” on page 538

¢ Section D.4, “Options on the Project Menu,” on page 539

¢ Section D.5, “Options on the Tools Menu,” on page 539

¢ Section D.6, “Options on the Live Menu,” on page 540

¢ Section D.7, “Options on the Model Menu,’

> on page 541

¢ Section D.8, “Options on the Window Menu,” on page 546

¢ Section D.9, “Options on the Help Menu,” on page 552

D.1 Options on the File Menu

Table D-1 Options: File Menu

Option

Description

File > New > Identity Manager Project

File > New > Provisioning

File > New > More Projects
File > New > More Projects > General > File
File > New > More Projects > General > Folder

File > New > More Projects > General > Untitled
Text File

File > New > More Projects > Designer Document
Generation > Document Generation Style
(.docgen)

File > New > More Projects > Designer for Identity
Manager > Identity Manager Project

Creates an Identity Manager project and location.
The project then appears in the Project view. See
Section 3.3, “How to Use Designer,” on page 34.

Helps you define directory abstraction layer objects
and provisioning request definitions for the user
application.

Launches the Identity Manager Projects Wizard.
Creates a new, empty file resource.
Creates a new folder in the project resource folder.

Creates an empty, untitled text file in the project
folder.

Creates a Document Generator style (template).

NOTE: At least one Designer project must exist
before you can create a Document Generation
Style.

Creates an Identity Manager project name and
location.
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Option

Description

File > New > More Projects > Provisioning >
Directory Abstraction Layer Entity

File > New > More Projects > Provisioning >
Directory Abstraction Layer List

File > New > More Projects > Provisioning >
Directory Abstraction Layer Query

File > New > More Projects > Provisioning >
Directory Abstraction Layer Relationship

File > New > More Projects > Provisioning >
Provisioning Request Definition

File > New > More Projects > Provisioning >
Provisioning Team

File > New > More Projects > XML > XML

File > Open File

File > Close
File > Close All
File > Save

File > Save As

File > Save All

File > Move

File > Rename

Specifies the project and application for the new
entity, as well as the display name and key for the
new entity. See Configuring the Directory
Abstraction Layer (http://www.novell.com/
documentation/idm/index.html?page=/
documentation/idm/agpro/data/
agproconfigdirabstractionlayer.html).

Specifies the project and application for the new list
as well as the key for the new list. See Configuring
the Directory Abstraction Layer (http://
www.novell.com/documentation/idm/
index.html?page=/documentation/idm/agpro/data/
agproconfigdirabstractionlayer.html).

Specifies the project and provisioning application
for the new directory abstraction layer query object,
as well as the display name and key. See
Configuring the Directory Abstraction Layer (http://
www.novell.com/documentation/idm/
index.html?page=/documentation/idm/agpro/data/
agproconfigdirabstractionlayer.html).

Specifies the project and application for the new
relationship as well as the display name and key for
the new relationship.

Specifies the basic information from a workflow
template of the provisioning request definition.

Enables you to define a set of users who can act as
a team for the Requests & Approvals tab of the
User Application. The team definition determines
who can manage provisioning requests and
approval tasks associated with this team.

Creates a new project XML file with specified
project files. See Section 23.7, “Preferences: Web
and XML,” on page 470.

Enables you to browse to and open a text or XML
file.

Closes the active editor.
Closes all open editors.
Saves changes made in the active editor.

Saves changes made in the active editor to a
different file.

Saves changes in all editors.

Moves a file, folder, or project to a different location
in the file system. Only available in the Navigator
view.

Renames a file or project. Only available in the
Navigator View.
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Option

Description

File > Refresh

File > Print

File > Switch Workspace

File > Import

File > Import > Project (From File System)

File > Import > Project (From Identity Vault)

File > Import > Project (From iManager Export File)

File > Export

File > Export > General > Archive File

File > Export > General > File System
File > Export > General > Preferences

File > Export > Designer for Identity Manager >
iManager Configuration File

File > Properties

File > History

Loads the project or file from disk and makes sure it
is in sync. (If you add new files outside of the tool
directly in the file system, this option displays them
in the Project View.)

Prints from an editor.

Opens another workspace with its projects. This
option automatically restarts Designer.

Imports resources, projects, or preferences. See
Section 15.1, “Importing Projects,” on page 257.

Imports existing project files from selected
directories or archive files.

Imports existing projects from specified secure
entities after entering the required authentication
information.

Imports an existing Identity Manager project from
an iManager export file (driver set or driver).

Exports resources or preferences. See
Section 19.9, “Exporting a Project,” on page 387.

Exports resources to an archive file on the local file
system.

Exports resources to the local file system.
Exports preferences to the local file system.

Exports a driver set, driver, channel, or policy to an
iManager-compatible configuration file.

Enables you to view the file's full name, date, size,
type, and read-only status.

Lists the history of files and projects opened. By
selecting items in this history list, you can reopen a
file or project. To configure the length of this history
list, use the Preferences dialog box.

File > Exit Closes the application.
D.2 Options on the Edit Menu

Table D-2 Options: Edit Menu

Option Description

Edit > Undo Change Location
Edit > Redo
Edit > Cut

Undoes the last operation.
Redoes the last undone operation.

Copies the selected item to the Clipboard and
removes it after it is pasted.
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Option

Description

Edit > Copy
Edit > Paste

Edit > Delete
Edit > Select All

Edit > Find/Replace
Edit > Add Bookmark
Edit > Add Task

Copies the selected item to the Clipboard.

Pastes the current item in the Clipboard to the
selected area.

Deletes the selected item

Selects all items in a text or XML editor. To select all
items in the Modeler, select it, then press Ctrl+A.

Replaces text strings in text or XML editors.
Used in text editors.

Adds a task and leaves a mark in the file. Used in
text editors.

D.3 Options on the View Menu

Table D-3 Options: View Menu

Option

Description

Zoom In

Zoom Out

Grid

Alignment Hints

Rulers

Increases an item's size. You can also slide the
Zoom slider in the main toolbar. To reset Zoom to
100%, click the Zoom Restore icon.

@

Decreases an item's size. You can also slide the
Zoom slider in the main toolbar. To reset Zoom to
100%, click the Zoom Restore icon.

Provides a grid, so that you can align items. See
Section 7.11.3, “Using a Grid,” on page 92.

Helps you see relationships in your model. You can
align or attach items to the left, center, or right of
alignment guides. See Section 7.11, “Aligning and
Laying Out Components,” on page 88.

Turns rulers off and on, to help with alignment and
layout. See Section 7.11.2, “Using Rulers,” on
page 90.
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D.4 Options on the Project Menu

Table D-4 Options: Project Menu

Option Description

Project > Import Project > File System Imports an existing project from the file system into
Designer from a selected root directory or archive
file.

Project > Import Project > Identity Vault Imports an existing project from an Identity Vault

into Designer.

Project > Import Project > iManager Export File Creates a Designer project by selecting an
iManager . xm1 export file. The . xm1 file can be a
driver set export, driver export, or Novell®
preconfiguration file.

Project > Document > New Style Generates a new style document for a specified
project.

Project > Document > Edit Style Edits a style document for a project located in the
Documentation folder under a project in the Project
view.

Project > Document > Generate Documentation Generates project PDF documentation after saving

file changes. You can select the directory location
where documentation is stored and specify to
overwrite existing files and to create XML source
files.

Project > Properties Enables you to discover where the project is stored
in the directory structure and when the project was
last modified. Provides information on text file
encoding and a line delimiter for Windows,
Macintosh, or UNIX text files.

D.5 Options on the Tools Menu

Table D-5 Options: Tools Menu

Option Description

Tools > DS Trace Viewer Enables you to browse to and open a specified
DSTrace log file.

Tools > eDirectory Object Manager Opens an eDirectory browser to add a new tree.

Tools > iManager Specifies the Novell® iManager URL, which is
stored in the application preferences folder.

Tools > Access User Application Automatically directs and opens a user application
session from within the embedded HTML browser,
provided a user application is configured in the
Designer project.
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Option

Description

Tools > Export Localization Data

Tools > Import Localization Data

Sends the User Application's display labels and e-
mail notification templates to an XML or properties
file so that the data can be localized.

Imports localization data from a project.

D.6 Options on the Live Menu

Table D-6 Options: Live Menu

Option

Description

Live > Browse Identity Vault

Live > Import

Live > Import Attributes

Live > Import Schema

Live > Deploy

Live> Deploy Attributes

Live> Deploy Schema

Live > Compare

Live > Refresh Application Schema

Live > Driver Status

Live > Start Driver

Live > Stop Driver

Live > Restart Driver

Browses specified Identity Vault configurations.
See Section 9.3, “Configuring Identity Vaults,” on
page 148.

Imports driver sets, drivers, or applications. Used in
the Modeler and in the Outline view. See

Section 15.2, “Importing a Driver Set or Driver from
the ldentity Vault,” on page 266.

Imports a driver configuration from an already-
saved XML file. Section 15.3, “Importing a Driver
Configuration File,” on page 275.

Imports a schema from an Identity Vault.

Deploys driver sets, drivers, or applications. Used
in the Modeler and in the Outline view.

Deploys attributes to selected objects.

Deploys a schema stored in Designer into an
Identity Vault.

Saves a driver configuration to a . xm1 file. See
Appendix D, “Quickview: Menu Options,” on
page 535.

Specifies the server on an eDirectory tree where
the schema is refreshed after an application’s
schema changes. See Section 11.7.2, “Refreshing
the Application Schema,” on page 219.

Displays each driver’s status. Enables you to start,
stop, or restart drivers. Enables you to browse,
import, and deploy various functionality, depending
on the item selected. See Section 9.6, “Configuring
Drivers,” on page 158.

Starts an inactive driver. See Section 9.6,
“Configuring Drivers,” on page 158.

Stops an active driver.

Restarts an active driver.
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Option

Description

Live > Create eDir-to-eDir Certificates

Live > Setup Driver Security

Configures two eDirectory drivers to communicate
directly with each other. See Section 21.6,
“Configuring TLS for eDir-to-eDir Drivers,” on
page 427.

Configures security parameters for drivers.

D.7 Options on the Model Menu

Table D-7 Options: Model Menu

Option Description

Model Accesses the Modeler applications, tools, drivers,
and other resources. See Chapter 7, “Building a
Model,” on page 53.

Model > Application Accesses tools to create Designer applications.

Model > Application > New

Model > Application > Connection Settings

Model > Application > Remote Control Desktop

Model > Application > Show Subsystems

Model > Application > Notes

Model > Application > Administrator

Model > Application > Icon

Model > Application > Properties

NOTE: Functionality becomes active when objects
in the Designer window are clicked.

Creates a new .xml application driver after a driver
set is selected in the Modeler window. You can
select from a preconfigured list of driver types and
run the associated scripts to verify the driver
requirements.

Configures the VNC connectivity settings for
objects created in the Modeler window.

Configures the remote control desktop of the
resource if a VNC server is running on it.

Shows or hides an application’s subsystems. See
“Show/Hide Subsystems” on page 563.

Opens the environment properties window in
Modeler to document platform, hardware, and other
environment notes about objects you create.

Opens the administrator properties window in
Modeler to document personal and contact
information and other notes about objects you
create.

Opens the general properties window in Modeler to
create or edit icons you create for Designer objects.
See Section 9.6.7, “Editing or Creating a Driver
iManager Icon,” on page 164.

Opens the general properties window for objects
selected in Modeler. See Section 9.8, “Configuring
Application Properties,” on page 170.
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Option

Description

Model > Design Element > New

Model > Design Element > Connection Settings

Model > Design Element > Remote Control
Desktop

Model > Design Element > Administrator

Model > Design Element < Properties

Model > Domain Group > New

Model > Domain Group > Clear Domain Contents
Model > Domain Group > Add to Group

Model > Domain Group > Ungroup

Model > Domain Group > Properties

Model > Driver > New

Model > Driver > Copy > Server-Specific Settings

Model > Driver > Copy > Settings

Model > Driver > Simulate

Model > Driver > Log Level

Model > Driver > Global Configuration Values

Model > Driver > Trace Settings

Instructs you to click the Architect tab, click the
Design Element drawer in the palette, and drag and
drop items into the Modeler.

In Architect mode, launches the Connectivity page
for design elements that have VNC connectivity.
Enables you to connect to an element or object.

Connects to the application by using the VNC
protocol. Displays an editor that you can use to
control the application.

Launches the Design Elements properties page.
The Administrator option enables you to capture
information about whom to contact concerning the
application.

Specifies a design element’s properties.

Creates a new domain into which se